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This release of WordPerfect 1.0.3 for the Macintosh contains bug fixes,

the WordPerfect PC 5.0 conversion filters, enhanced text export filters,

and the MS Word Fast Save file import filter. In spite of the enhancements

made, this version will be 1.0.3 and not 1.1 because we feel that these

enhancements do not merit, nor do time constraints allow, a

documentation upgrade.

There are also a few other things that you should be aware of. They are

listed below.

WWWWPPPP 1111....0000....3333 RRRReeeessssuuuullllttttssss

We are conducting a study with version 1.0.3 to see which WordPerfect

Macintosh features are most frequently used. When you first start version

1.0.3, a file called "WP 1.0.3 Results" will be created in your System

folder; and every time you run WordPerfect, the file will be updated. This

file records each occurrence of every function used in WordPerfect.

If you ever need to send a file to our Customer Support department, we ask

that you also include a copy of your Results file. The results will be

compiled with those of all other users who send us their files and will be

used to help us better design the interface of future versions of our

product.

WWWWPPPP 1111....0000....3333 DDDDeeeeffffaaaauuuullllttttssss

The WP Defaults file located in the System folder has been renamed WP

1.0.3 Defaults. WP generates this file the first time you start

WordPerfect and keeps the program's defaults recorded here. Because of

the different file name, it is not necessary to delete your old WP Defaults

file when installing version 1.0.3. If you have created your own default

files, you will need to recreate those files in 1.0.3. Macintosh II owners

with color monitors will need to reset their color settings inside

WordPerfect.

Conversions

Some files that have heavy formatting in them have to be fully formatted

before editing and printing can be accurately done. Therefore, after a file

has been imported, do a Word Count (Choose Spell from the Special menu,

then choose Word Count) to force a full formatting).



1111....0000....3333 ttttoooo 5555....0000 CCCCoooonnnnvvvveeeerrrrssssiiiioooonnnn

Please keep in mind the following items when converting documents from

WordPerfect Macintosh to PC 5.0:

1. GRAPHICS: Graphics cannot be converted from 1.0.3 to 5.0.

2. MACROS: Macros cannot be converted.

3. MARGIN RELEASE, CONDITIONAL END OF PAGE, INDENT: These codes

may not be in the same place you put them in 1.0.3 due to differences

in system fonts, printer setups, and screen size.

4. JUSTIFICATION: All justification becomes full. 1.0.3 allows left,

right, full and center justification. 5.0 allows only left and full

justification.

5. INSERT LITERAL: If your character matches a compose address, it

will convert. However, it may not be the same character.

6. MERGE: All merge codes convert. Unlike PC to Mac, the document can

be read as a merge file without saving it in 5.0 first.

7. POSTSCRIPT: Postscript does not convert.

8. KERNING: Kerning is not supported.

9. FONTS: If the font is on both machines, it will convert (with the

exception of default fonts). A document created using a default font

on one machine will appear in the default font of the machine that

the document is transferred to. The following fonts are known to

transfer:

Avante Garde

Bookman

Courier

Helvetica

Narrow Helvetica

New Century Schoolbook

Palatino

Times

Zapf Chancery
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Please keep in mind the following items when converting documents from

PC 5.0 to WordPerfect Macintosh:

1. Font attributes like Fine, Small, Large, Very Large, Ext. Large, and

Small Caps are not supported.

2. If both machines support the same fonts, they will convert to the

closest bit-mapped match.

3. GRAPHICS: WPG (WordPerfect) Graphics will convert.

4. LINE DRAW: Lines will not convert, but characters will. They will

not be exactly where they were in 5.0, but by using your space bar,

you can rearrange them.

5. TABLES, TEXT BOXES, USER DEFINED BOXES, GRAPHIC LINES: Do not

convert.

6. MARGIN RELEASE, CONDITIONAL END OF PAGE, and INDENT: Due to

different system fonts, printer setups, and screen size, these codes

may not be where you placed them in 5.0.

7. MERGE: All merge codes except the ^O convert. In WordPerfect

Macintosh you must first save the opened, untitled 5.0 document as a

Macintosh file for it to be used as a merge file.

8. PARAGRAPH NUMBERING and OUTLINE: If you define characters as

your numbering style, they will convert into numbers.

9. COLUMNS: Parallel columns without block protect are converted to

newspaper columns.

10. MATH COLUMNS: Once calculated, all information will convert into

its proper place. You will be unable to recalculate if edited, since

1.0.3 does not support math columns.

11. WORD SPACING, LETTER SPACING, KERNING: Not supported.



12. TABLE OF AUTHORITIES: Will convert as long as it is generated

before conversion.

13. ENDNOTES: Endnote spacing and placement are not supported.

14. COMMENTS and SUMMARIES: Not supported in regular format.

However, when saved as TEXT, they will convert.

15. TABLE OF CONTENTS: Can be defined and generated before or after

conversion.

16. INDEX: Can be defined and generated before or after conversion.

17. LIST: 5.0 allows up to nine lists to be defined and generated. 1.0.3

only allows up to five lists to be defined and generated. In

conversion, lists 6, 7, 8, 9 become 1, 2, 3, 4 and can be defined or

generated before or after conversion.

18. MACRO: Macros cannot be converted.

19. COMPOSE: If both machines support the character, it will be

converted.

20. JUSTIFICATION: 5.0 defaults to Full Justification. 1.0.3 defaults to

Left Justification. In order for Full justification to be converted,

you must have a [Just On] code in your document. Or change it once

converted into 1.0.3.

21. FAST SAVE: Fast save documents can be opened as text documents

into 1.0.3.

22. FONTS: If the font is on both machines, it will convert, with the

exception of default fonts. A document created using a default font

on one machine will appear in the default font of the machine that

the document is transferred to.

PPPPCCCC 5555....1111 ttttoooo 1111....0000....3333 CCCCoooonnnnvvvveeeerrrrssssiiiioooonnnn



The WordPerfect 5.1 files will convert using the 5.0 filter. The same

restrictions for 5.0 conversion explained above apply. Following are some

helpful hints about the additional features 5.1 supports.

1. TABLES: The text inside Tables will be converted. If you convert

your Tables into 5.0 format (CTRL F5) before bringing the file to the

Macintosh, the text will come over in parallel columns.

2. GRAPHICS: The Bicycle.WPG and Clock.WPG graphics do not

completely convert because they contain bit-mapped images which

will not convert.

3. EQUATIONS do not convert.

4. JUSTIFICATION: All Justification styles convert to the Macintosh.

5. MERGE codes will be completely stripped. However, the parameter

information will convert since it is editable text. WordPerfect 5.1

has a Merge language, so 1.0.3 has no way of interpreting these new

codes. If you execute your merge, then transfer the document, the

information will convert.

6. FOOTNOTE/ENDNOTE OPTIONS: On the PC you are allowed 20

characters in Style for Number in TEXT and Style for Number in NOTE.

On the Macintosh you are allowed only 15 characters. The [Note Num]

code counts as two characters. So, you can insert up to thirteen

characters plus the [Note Num] code for it to look the same on both

machines.

PPPPCCCC 4444....2222 ttttoooo 1111....0000....3333 CCCCoooonnnnvvvveeeerrrrssssiiiioooonnnn

Please keep in mind the following items when converting documents from

PC 4.2 to the WordPerfect Macintosh:

1. If you have tab sets in your headers or footers, you will have to

reset the tabs after conversion. 4.2 reads tab sets in or out of

headers. In 1.0.3 you must set tabs in headers for them to be read.

2. LINE DRAW: Converts into extended characters. If you draw with

characters, you will have to rearrange them after conversion. If you



plan on taking the file back to the PC, don't change anything. It will

look bad on the Mac, but everything should transfer back.

3. TABLE OF AUTHORITIES: Will convert if they have been generated

before conversion.

4. COMMENTS and SUMMARIES: Will convert if saved as TEXT.

5. MATH COLUMNS: Convert fully if calculated before conversion.

6. TABLE OF CONTENTS, LISTS, INDEX: You can define and generate these

before or after conversion.

1111....0000....3333 ttttoooo PPPPCCCC 4444....2222 CCCCoooonnnnvvvveeeerrrrssssiiiioooonnnn

Please keep in mind the following items when converting documents from

WordPerfect Macintosh 1.0.3 to PC 4.2:

1. FOOTNOTES and ENDNOTES: In the conversion process footnotes are

separated by a soft page return, and are displayed on separate pages.

Do a Word Count to format correctly.

2. FONTS: Font changes are not supported in conversion.

3. TABLE OF CONTENTS, LIST, INDEX: These features can be defined and

generated before or after conversion.

4. ATTRIBUTES: Only the text attributes that 4.2 supports are

converted.

5. GRAPHICS: Not supported in conversion.

6. KERNING AND LEADING: Not supported.

7. LINES PER INCH: 4.2 only supports 6 and 8 LPI.

8. POSTSCRIPT: Not supported in conversion.



9. JUSTIFICATION: Right, Center, and Full Justification convert to Right

Justification On. Left Justification converts to Right Justification

Off.

WWWWoooorrrrddddPPPPeeeerrrrffffeeeecccctttt ttttoooo WWWWoooorrrrdddd EEEExxxxppppoooorrrrtttt CCCCoooonnnnssssttttrrrraaaaiiiinnnnttttssss

Please keep in mind the following items when converting documents from

WordPerfect to Word:

1. LINE NUMBERING: Not supported in export. Formats requiring

sections in Word will not be exported. These include the following:

Columns

Headers and Footers

Page Numbering Control

Title Page

Endnotes (converted to footnotes)

2. OUTLINES: Will be exported as text without paragraph numbering

codes. Tables of Contents, Indexes and Lists will all be exported as

text without the formatting codes.

WWWWoooorrrrdddd ttttoooo WWWWoooorrrrddddPPPPeeeerrrrffffeeeecccctttt IIIImmmmppppoooorrrrtttt CCCCoooonnnnssssttttrrrraaaaiiiinnnnttttssss

The following features from Word are not supported when imported to

WordPerfect:

Condensed/Expanded Text

Footnote Symbols

Page Renumbering

Roman Page Numbers

Side by Side Text

1. UNDERLINE: Underline modes in WordPerfect are slightly different

from those in Word. WordPerfect underlines spaces in the standard

mode, Word does not.

2. TITLE PAGES AND PAGE NUMBERING: If these are done without

section formatting, they will be imported.



3. FAST SAVE: Fast Save is now supported when importing to

WordPerfect. However, due to the strange format done during a fast

save, you may find better results when you import a slow save

document. If results are not satisfactory, save your Word document

one more time with a slow save and try the import again.

TTTTeeeexxxxtttt CCCCoooonnnnvvvveeeerrrrssssiiiioooonnnnssss

When using Save As, the following information will be useful:

1. Generic Text will convert a soft return (SRt) to a space.

2. PC Generic Text (SR to Space) and PC Text (SR to CR LF) are

converted for use on IBM computers and IBM compatibles.

3. PC Generic Text (SR to Space) will convert a soft return to a space.

4. PC Text (SR to CR LF) will convert a Soft Return to a carriage return

and line feed.

5. Text (SR to CR) is converted to text formatted for Macintosh editors.

6. All special formatting codes are stripped out so the text may be

used with most basic editors.

MMMMiiiisssscccceeeellllllllaaaannnneeeeoooouuuussss

MACGENIUS TWO PAGE MONITOR: WordPerfect used to crash on startup;

this has been corrected.

OPENING A NON-MAC WORDPERFECT DOCUMENT: The dialog that appears

when you open or retrieve a document that has not been saved in

WordPerfect Macintosh format has changed, but the functionality is the

same.

DATE FORMAT: When you are in the Date Format dialog box (Choose Date

from the Format menu, then choose Date Format), Press Shift-Option-D to



insert an abbreviated month function, and Shift-Option-F to insert an

abbreviated day function.

TTTTeeeemmmmppppoooorrrraaaarrrryyyy FFFFiiiilllleeeessss

When temporary files are created in WordPerfect because of a system

error or power failure, a dialog box will appear the next time you start

WordPerfect, asking you if other copies of WordPerfect are running.

Select No unless multiple copies of WordPerfect are running under the

MultiFinder or were launched from a file server. Selecting the No button

when multiple copies of WordPerfect are running under MultiFinder will

delete the temporary files from your system folder that belonged to your

first launch. If multiple copies are launched from a file server, click

Yes—temporary files found may belong to another launch of WordPerfect.

When multi-launching WordPerfect from a file server, direct WordPerfect

temporary files to each Macintosh station's System folder (this is the

default setting). The temporary files will include the user's name as

recognized by the Server.

CCCCooooddddeeeessss

A document window can still be resized when the Codes window is open.

Click in the extreme lower-right corner of the Codes window and drag the

window to the desired size.

CCCCoooolllluuuummmmnnnnssss

Pasting a graphic image into columns may require resizing the image to

fit within the column margins. Open your ruler to see the column margins.

Scroll (in columns, scrolling is easier with the keyboard arrow keys) to

the graphic image and select it. Resize the image to fit within the column

margins.

DDDDiiiiaaaalllloooogggg BBBBooooxxxx SSSShhhhoooorrrrttttccccuuuutttt

Most dialog box buttons can be executed by pressing Command and the

first letter of the button desired. For example, in the Speller, you can

press Command-I instead of clicking Ignore.



GGGGrrrraaaapppphhhhiiiiccccssss CCCCeeeennnntttteeeerrrriiiinnnngggg

To center a graphic on the page, position the cursor in front of the graphic.

Choose Line from the Format menu, then choose Center. You can also

center the cursor before you paste the graphic into your document. If you

want to select the graphic to center it, drag across the graphic to

highlight it, then choose Center. Do not select the graphic by clicking on

it . This will not center your graphic.

PPPPoooossssttttSSSSccccrrrriiiipppptttt

In addition to supporting the standard Postscript commands (see

Postscript Commands in the Reference manual, pages 491-492),

WordPerfect lets you embed the following variables into the WordPerfect

Postscript dialog box:

$$VPOS Vertical position of bottom of cursor, measured in points.

$$HPOS Horizontal position of bottom of cursor, measured in points.

$$PNUM Page number.

$$BMAR Bottom margin.

$$TMAR Top margin.

$$RMAR Right margin.

$$LMAR Left margin.

$$PGHITE Vertical size of page.

$$PGWID Horizontal size of page.

$$DATE Inserts the current date into a document.

Variable names can be followed by any character other than an uppercase

letter. When printed, all variable commands are replaced by a number

which is relative to the bottom left corner of the page. The number, not

the variable, becomes part of the definition.



CCCCooooppppyyyy RRRRuuuulllleeeerrrr

Copy Ruler in the Format menu will copy

formatting specifications from the current ruler

to the clipboard. You may then paste these

specifications into your document at any point.

The formatting of the text from that point on

will have the same attributes as the text where

you copied the ruler. (Of course, as with most

WordPerfect functions, these specifications

will affect your document only until a new

function code is encountered. At that point,

formatting related to the new code will change.)

Functions that will be copied to the clipboard include left and right

margins, hyphenation zone, page number position, tabs, justification, and

column definition.

SSSSeeeelllleeeeccccttttiiiinnnngggg TTTTeeeexxxxtttt

You can also select text by positioning the cursor at one end of the text to

be selected and then performing a shift-click at the other end. This will

turn the selection on and extend it to the new position. This method of

selecting also works in the Codes window.

CCCCoooonnnnvvvveeeerrrrttttiiiinnnngggg DDDDaaaattttaaaabbbbaaaasssseeee FFFFiiiilllleeeessss ttttoooo WWWWoooorrrrddddPPPPeeeerrrrffffeeeecccctttt SSSSeeeeccccoooonnnnddddaaaarrrryyyy FFFFiiiilllleeeessss

You will find a WP FileConvert icon on your 1.0.2 disk.

WP FileConvert lets you convert a database or

spreadsheet file to a WordPerfect secondary merge file.

To convert a database or spreadsheet file to a WordPerfect secondary file,

1. Choose Save As or Export Data to save your database or spreadsheet

file as a text file (See Additional Help for Exporting Files below).

2. Quit your database or spreadsheet program (unless you are using

Multifinder).



3. Open the WP FileConvert program. The following dialog box appears:

4. Click the appropriate database or spreadsheet radio button, then

click OK. A file dialog box appears and asks you to choose the file

you want to convert.

5. Select the appropriate file, then click OK.

The resulting WordPerfect secondary file can be opened by double-clicking

the file icon, or by choosing Open from the File menu. This file can be

merged with a WordPerfect primary file.

AAAAddddddddiiiittttiiiioooonnnnaaaallll HHHHeeeellllpppp ffffoooorrrr EEEExxxxppppoooorrrrttttiiiinnnngggg FFFFiiiilllleeeessss

Excel: Since Excel is a spreadsheet program, each lettered row represents

a record and each numbered cell represents a field in the record. For

example, cell A1 represents record 1, field 1, cell A2 is record 1, field 2,

and so forth. Choose Save As, then click the Text radio button to save the

worksheet.

4th Dimension: Choose Output Layout from the File menu, then choose

Export. Type the new filename, then click the Text radio button. Change

the record delimiter to 10 and the field delimiter to 9, then click Save.



dBase Mac: From the User Environment, choose Export from the DataFile

menu to display the Delimiter dialog box. Make sure "Carriage Return" is

selected in the Field Terminator text box, and "Tab" is selected in the

Record Delimiter text box, then click Save. Type the new filename in the

dialog box that appears, then click Save. The Exporting dialog box appears

with the name of the file to export. Click Start. Once the file is

converted, you may need to manually insert the Merge E codes, depending

on the particular database structure from dBase Mac.

Microsoft Works: Choose Save As from the File menu to display the Save

As dialog box. Type the new filename, click the Export check box, then

click Save. When the Save Text As dialog box appears, click the Text With

Values Only radio button, then click OK.

Reflex Plus: Press Command-= to generate the report, then choose Export

Data from the Report menu to display the Export dialog box. Type the

filename, then click the Text File button. Each database field will be

displayed in a dialog box. Select the fields you want to export, then click

Create.

OverVUE: Choose Save As from the File menu to display the Data Sheet As

dialog box. Type the new filename, click the Text only (Mailmerge format)

radio button, then click Save.

The format for exporting files from Microsoft File, Double Helix II, Omnis

3 Plus, FileMaker Plus and Jazz, should follow the same or similar

procedures as the previous programs.


