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Foreword

Welcome to the LittleSnapper manual! Over the next thirty or so pages, you’ll learn everything you need to 

learn about LittleSnapper and QuickSnapper.

Should you have any further questions about LittleSnapper, we encourage you to pay our forums a visit at 

forums.realmacsoftware.com where you can learn more about LittleSnapper, join in the community discussions 

about the product and get support from the Realmac Software team.

The manual is split into two sections: Getting Started and Reference. The Getting Started section will teach 

you how to use LittleSnapper, whilst the Reference section provides you with an invaluable index of all Little-

Snapper’s features.

Thanks for your interest in LittleSnapper.

André, Aron, Ben, Dan, Danny, and Nik

Brighton, England

January 2009
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Getting Started with LittleSnapper

Welcome

Welcome to the LittleSnapper Manual. The first part of the manual is dedicated to helping you quickly start 

building a library of snaps and capture your design inspiration, whilst later in the manual you can find a feature-

by-feature run down of all LittleSnapper’s options.

Conventions Used

Menus Options

These are a series of Menu options to follow in LittleSnapper’s menu system. The example below takes 

you to the File menu, and to the Export Images menu option.

File > Export Images

Keyboard Shortcuts

LittleSnapper has a significant number of Keyboard Shortcuts. The example below shows the shortcut 

to export the currently selected images using the Command (Cmd or ) key, the Shift key and the letter 

E.

Cmd + Shift + E (Export Images)
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Installing LittleSnapper

Installing LittleSnapper is quick and easy. Just follow the easy steps below to get snapping!

Download the littlesnapper.dmg file from the Realmac Software Downloads page found at  1.	

www.realmacsoftware.com/downloads

Once the download has completed, open the littlesnapper.dmg file  found in your Downloads folder.2.	

Drag LittleSnapper from the new Finder window to your Applications folder.3.	

Launch LittleSnapper!4.	

LittleSnapper requires Mac OS X 10.5 Leopard, and 10MB disk space. Once you have downloaded and in-

stalled the application, you can remove the downloaded littlesnapper.dmg file.
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Registering LittleSnapper

Whilst we would love you to register LittleSnapper with a shiny new serial number and unlock the demo ver-

sion you have downloaded, you can run it in demo mode for as long as you like. The only limitation is that your 

library can contain no more than thirty (30) images at any time.

When LittleSnapper launches for the first time, you will be prompted to do one of three things:

Purchase LittleSnapper•	

Enter a valid serial number•	

Run LittleSnapper in Demo mode•	

After you’ve made your choice, LittleSnapper will launch and create a new library file with a few pre-built smart 

collections, as shown in Figure 2.

 LittleSnapper’s Main Window and New LibraryFigure 1:
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Snap

Global Menu Item

Once you’ve installed and started LittleSnapper, you’ll notice a new menu-bar item in the OS X menu bar 

(shown in Figure 2). This shows that LittleSnapper is running, and allows you to easily access the snap con-

trols from any application.

To capture your first webpage, launch your preferred web browser. Throughout this manual, we’ll be using Sa-

fari in our examples, however LittleSnapper works with all the popular Mac OS X web browsers (Safari, Firefox, 

Camino, OmniWeb, Flock and Opera). 

Navigate to a website you want to capture [we’re using the Realmac Software website as an example], and 

choose the Snap Web Address from Safari option from the LittleSnapper menu item. Alternatively, you can use 

the keyboard shortcut Cmd + Ctrl + 1.

In the background, LittleSnapper will capture the website and add the snap to your Library complete with the 

page’s web address and title. If you switch back to LittleSnapper from Safari, you’ll note that the snap has 

been added to your library. 

Note:
LittleSnapper also saves the HTML 

associated with any websnaps you 

take so that you can take a look at 

it later on.

 The Global Menu Item.Figure 2:

 Snaps are automatically added your library with the related metadata.Figure 3:
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Built-in Browser

We’re now going to add another snap to this new library, this time using the web browser built into LittleSnap-

per. You can switch to the browser using the browser button found below the Icon view, or use keyboard 

shortcut Cmd + 3. If you’re already in Safari, and want to open the currently-viewed page in the LittleSnapper 

browser, you can simply use the keyboard shortcut Cmd + Option + 2 [or the Open Current Website in Lit-

tleSnapper menu item option].

Once in the LittleSnapper browser, you can visit any webpage as normal, however there are two extra action 

bar buttons found to the left of the address field: one for full webpage capture (shortcut Cmd + S), the other 

for page element selection and snapping (shortcut Cmd + D). 

With the page loaded and the elements you want to capture in front of you, click the ‘Element Selection’ tool. 

As you roll over the page’s images, navigation and text the automatic selection detects the width of the page 

elements. To select an area of the page, simply click over one of the highlighted areas as shown in Figure 4. 

A set of resize handles appear around the area, to allow you to refind the selection and once you’re happy with 

the area simply click ‘Snap’. LittleSnapper captures only that area, and adds it to your library.

 Using the built-in browser’s element selection tools.Figure 4:
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Import Existing Snaps

If you have a folder of existing snaps on your desktop, you can import them into your library using the File > 

Import option. Simply point LittleSnapper to the folder, specify whether the snaps are web or screensnaps (you 

can always change this after import if you wish), and click import to bring them into your library.

You can also drag snaps onto the LittleSnapper dock icon to import images into your library.

 The File menu.Figure 5:
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Organise

The Inspector

Within the inspector (shown in Figure 6) are all the tools you need to customise the metadata for each snap. 

To open the inspector, click the (i) button found in the bottom-left corner of the window, or use the keyboard 

shortcut Cmd + Shift + i.

You can modify almost any metadata relating to a snap: the title (which is used to identify the image, and 

used when you export a snap), the image’s rating, tags you want to associate with a snap, and any notes or 

descriptions you want to store with the image. You can directly edit all the fields within the inspector apart 

from the Published table, which notes which sharing services you have uploaded a snap to.

Rating snaps is easy: simply choose a rating from one to five stars, and select it using all the stars shown in 

the inspector. To apply tags to a snap, enter them into the Tags field making sure you press return between 

each tag you want to use.

The Sidebar

In order to help you manage your snaps, you can create collections, smart collections and folders in the 

LittleSnapper sidebar. Clicking the [+] button in the bottom left allows you to add items to the sidebar.

Collections

Collections allow you to create sets of snaps through drag and drop. Control over exactly which snaps are 

added and removed from a collection is left entirely to the user.

Smart Collections

Smart collections are much like iTunes’ Smart Playlists, and allow you to automatically group snaps based on 

rules such as their rating, title, original web address or the date a snap was taken. You can also specify rules 

based on whether a snap was taken Today, whether a tag has been applied to a snap. 

 The InspectorFigure 6:
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Folders

Folders allow you to manage the sidebar. Folders can contain other (nested) folders, collections and smart col-

lections. There are no limits to the number of folders you can create in the sidebar.�

Edit

LittleSnapper comes with a number of editing tools that let you annotate snaps. All of the annotation tools 

are vector-based, and create non-destructive annotations that leave your original images intact. Just like Icon 

view, the Edit view has a Publish button to let you share images any of the support webservices.

If you ever want to hide annotations from an image, you can toggle the display of annotations by using the 

Layers > Hide Annotations option when in Edit mode.

Tools

Highlight

The Highlight tool overlays the snap with a semi-transparent layer which you can then ‘cut out’ areas to em-

phasise particularly areas of the snap.

 LittleSnapper’s Annotation ToolsFigure 7:

LittleSnapper’s Highlight ToolFigure 8:
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Blur

The blur tool lets you obscure details [perhaps of a username, password or email address] that have been 

captured as part of a snap.

Shapes - Square, Circle, Line & Arrow

You can draw as many shapes over your snap as you want. All shape can be customised in line-width and 

colour using the colour picker and slider in the actionbar. The fill of shapes can be switched between Outline 

and Fill by selecting the shape, and using the keyboard shortcut F.

LittleSnapper’s Blur ToolFigure 9:

LittleSnapper’s Drawing Tools.Figure 10:
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Text

LittleSnapper comes with a fully featured text tool. In addition to full font-control and colour options, the text 

tool can also add numbered callouts onto annotations, allowing you to add text in a more spacious location 

than the snap allows. You can even drag text annotations that are linked to called off the snap [and onto the 

canvas background] to leave just numbered callouts that you can then refer to in footnotes or emails.

To change between regular text annotations and callouts, simply double-click a text annotation and choose 

the drop-down menu located in the bottom-left of the text-editing HUD. You can choose any number (up to 

the total number of text annotations). The number badge is placed near the text annotation it corresponds to, 

however you can move it to anywhere on the image you choose.

You can insert multi-line text annotations by using a carriage return (Option + Return) in the text-editing HUD 

window.

Crop

LittleSnapper also allows you to non-destructively crop images. The crop tool can be found on the Layers > 

Crop option, or keyboard shortcut Cmd + K. A semi-transparent layer is placed over the image, and you can 

specify the crop area by dragging the cursor over the desired area. The image remains at original size when in 

Edit mode, even after you switch to another tool, however the crop is applied to the image, and the preview 

image in Icon view is updated to reflect this.

LittleSnapper’s Text ToolFigure 11:
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Publish & Export

LittleSnapper includes support for a number of webservices, as well as the ability to export to folders on your 

Mac.

Publishing

To get started with Publishing, open the LittleSnapper > Preferences window, and choose the Publishing tab. 

There are two options: sign-up for a QuickSnapper account (or log in to an existing one) or add another type of 

account such as FTP, SFTP or Flickr.

Once you have added a publishing account it appears on the dropdown Publishing menu which is found in the 

actionbar when in Icon and Edit views.

The Publishing Preferences window.Figure 12:
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QuickSnapper

To sign up for a QuickSnapper account (included with each copy of LittleSnapper) click the Create QuickSnap-

per Account button. Simply enter your desired username and password, fill in your email address, and give the 

account a name that LittleSnapper should use in the publishing menu to identify the account.

Click Create Account, and LittleSnapper will register your for the service (provided your username is not al-

ready taken) and set it up for your use throughout the application.

If you already have a QuickSnapper account, choose the [+] button in the bottom-left corner of the Preferences 

window, and select QuickSnapper from the drop-down list. You will then be prompted to enter your username 

and password. Once logged in, you will be presented with a view similar to that found in Figure 13 that allows 

you to view your account details, visit your online profile, and change your avatar for the service using a built-

in iSight camera.

 QuickSnapper Preferences.Figure 13:
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Flickr

If you already have a Yahoo Flickr account, simply press the [+] button found in the bottom-left corner of the 

and choose ‘Flickr’ from the drop-down list. After entering your username into the sheet that appears, Little-

Snapper will open the Flickr website your default browser so that you can authorise LittleSnapper to upload to 

your account. Once you have completed the authorisation process on the Flickr website, you will be automati-

cally re-directed to LittleSnapper and the application will finish the setup process.

Once a Flickr account has been added to your list of services, you can choose a Photoset and Group that 

LittleSnapper should use when uploading to Flickr, as well as a other privacy and content type settings as 

shown in figure X.

LittleSnapper automatically applies the title, tags, rating and description you have added in the Inspector to 

snaps uploaded to Flickr. 

The Flickr Preferences window.Figure 14:
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FTP and SFTP.

LittleSnapper can upload to both FTP and SFTP servers. To add a server, simply choose FTP or SFTP from the 

accounts dropdown menu in the LittleSnapper preferences window. When entering your server details, be sure 

to check that the Path, Port and Web Address are correct.

The Path is the location that LittleSnapper should upload snaps to. The exact path varies from host to host, 

however the path should be the location within your webspace for whichever folder you choose in the Web 

Address field to store your images.

The Web Address is the publicly-accessible location of the folder that LittleSnapper is uploading to, and is 

used to generate the web address of any images you upload. It must always begin http:// in order for Little-

Snapper to generate accurate locations and HTML code to point to your images.

The FTP & SFTP Preferences window.Figure 15:
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Export

If you need to export images to a location on your Mac, you can do so using the File > Export Images and File 

> Export Website to PDF options (or their keyboard shortcuts Cmd + Shift + E and Cmd + Option + Shift + E 

respectively).

Export Images allows you to export any snap in either PNG or JPEG format, with or without annotations. When 

exporting, LittleSnapper uses the names specified in the Inspector to name the files.

Export Website to PDF lets you export websnaps to PDF format. The ‘Use Pagination’ option allows you to 

export the PDF as a multi-page PDF, or simply export the selected websnap to a single-page, text-selectable 

PDF.

Drag and Drop

If you need to quickly export a snap, you can simply drag and drop the relevant snap out of LittleSnapper into 

the Finder, Mail.app or any other Mac OS X application. By default, LittleSnapper will apply annotations to any 

snaps you drag out of the application however this can be configured in the LittleSnapper preferences.

Working with External Editors

LittleSnapper allows you to send snaps (and the HTML that accompanies Websnaps) to external image and 

HTML editors. Once you’ve set up your preferred editors in LittleSnapper’s Preferences > General tab, simply 

right-click on an image, and choose the ‘View Image in’ or ‘View Source in‘ option from the contextual menu or 

the Images menu.
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Taking Snaps

LittleSnapper has a number of different ways to take snaps. Whether you’re working with a website or an ap-

plication on your desktop, you can use LittleSnapper’s menu-bar icon and global keyboard shortcuts to quickly 

add a snap to your library.

Menu Item

The menu item has a number to features to allow you to quickly take a snap:

Snap Web Address from (Browser Name) - Depending on the currently-open browser, LittleSnapper will •	

insert the browser name into the menu. If multiple browers are open, it will show the one highest in the OS 

X window order.

Open Current Website in LittleSnapper - grabs the currently-open URL and opens it in the LittleSnapper •	

Browser.

Snap Full Screen - Snaps the entirety of your Mac desktop.•	

Snap Area - Allows you to make a selection using crosshairs and snap it.•	

Snap Window - Snap a specific window by hovering over the window and clicking.•	

Global Keyboard Shortcuts

LittleSnapper’s Menu Item options listed can also be accessed through Global Keyboard Shortcuts. The 

default shortcuts can be found at the end of this manual, however they can be customised to any shortcut of 

your choosing in LittleSnapper’s Preferences > Shortcuts window.

LittleSnapper Browser

LittleSnapper has a built-in web browser that uses the same WebKit rendering engine as Apple’s Safari brows-

er.  The built-in browser offers you an even greater level of control in what you capture from webpages. In addi-

tion to snapping entire webpages, you can snap specific areas of a page using the DOM-snapping feature.

LittleSnapper will show the outline of elements as you hover over them, and make links inactive so that you 

can easily snap any item on the page. Select the area you want to capture by rolling over, and the clicking the 

relevant element.

With the element selected, a set of drag handles appear allowing you to refine the selected area you want to 

 Global Menu Item.Figure 16:
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snap. When you’re happy with the selection, simply click the Snap button found in the purple bar above the 

page, or press Return on your keyboard to capture the area and add it to your library. 

LittleSnapper saves the selected area as an image, and saves all the source code associated with the page 

into your library for future reference.

Folder Import

If you already have a folder, or series of folders containing existing snaps, you can import these into Little-

Snapper using the File > Import option [Command + O].

In order to let LittleSnapper know what type of snap [screen or web] you’re importing, you can select the 

correct type in the Import dialogue. The ‘Automatically Organise Snaps’ option will create Collections in the 

sidebar for each folder of snaps LittleSnapper finds when importing, and groups any created collections in an 

‘Import’ folder.

Collections
You can learn more about 

Collections and LittleSnapper’s 

other management tools on page X.

 The built-in browser’s element selection (DOM snapping) mode.Figure 17:
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Icon View

The icon view is LittleSnapper’s main view and allows you to browse and organise snaps. The view changes to 

show the content of whichever option is selected in the application’s sidebar. At the top of the Icon View is the 

Action Bar, containing the Share button, contextual menu and the search field.

Publish Button

The Publish button allows you to quickly upload the selected image, or images, to any of the sharing services 

you may have added in LittleSnapper’s Publishing preferences window. After choosing the snaps you wish 

to upload, clicking the Share button will reveal your list of services. If you do not have any services enabled, 

simply click the ‘Configure Accounts’ option to open the Publishing preferences and add a sharing account.

The Contextual Menu

The actionbar’s contextual menu is the same as that found by Ctrl-clicking (Right-clicking) on an image in Icon 

view.

View and Edit Image (Cmd + 2)

Selecting this option will switch from Icon view to Edit view, with the currently selected image ready to be 

edited and annotated.

Remove Image from Collection (Enabled only when viewing a Collection - Cmd + Shift + Backspace)

This will remove the image from the current collection, however the image remains in your library and all other 

collections it may have been added to.

Remove Image from Library (Cmd + Backspace)

This option removes the currently selected image(s) from your LittleSnapper library, and any collections you 

may have added them to. The snaps are moved to the Mac OS X Trash Can should you wish to recover them.

View Image in Editor / View Source in HTML Editor (Cmd + Shift + U / Cmd + Option + U)

LittleSnapper allows you to send snaps [and the HTML that accompanies Websnaps] to external image and 

HTML editors. Details on how to set up this feature can be found on page 21.

 The Contextual MenuFigure 18:
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Open Website in Default Browser (Cmd + Shift + O)

If a websnap is selected in the main icon view, this will allow to open the originally-snapped webpage in your 

default browser.

Open Website in LittleSnapper (Cmd + Option + Shift + O)

If a websnap is selected in the main icon view, this option allows you to open the originally-snapped webpage 

within the built-in LittleSnapper browser.

View Saved Web Archive in LittleSnapper Browser

As LittleSnapper saves a WebArchive for each website you capture, this option allows you to view the saved 

WebArchive within the LittleSnapper browser.

Sort By

The sort options allow you to specify how snaps appear in the Icon view. You can sort snaps by descending 

and ascending date, title or URL.

Search you Library

If you ever need to find a snap quickly, simply choose the Search box found at the top right of the Icon view. 

You can choose to search snaps by Title, URL or Tag. Clicking on the magnifying glass shows a list of meta-

data you can limit the search to. You can also quickly jump to the search box by using keyboard shortcut Cmd 

+ F when in Icon view.

The Inspector

The Inspector [toggled through the (i) button or keyboard shortcut Command + Shift + i] allows you to view 

and add metadata to snaps. As well as viewing the original URL of a websnap and the creation date of any 

snap, you can edit an image’s title, star rating, associated tags, description. If a snap has been uploaded to 

either Flickr or QuickSnapper, the URL to view the image on the service is also shown. You can use metadata 

found in the Inspector to search your library and create Smart Collections.

Title

The title is auto-generated for Websnaps, however you can customise it at any time.
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Rating Snaps

Rate a snap by simply clicking the Rating area, and then clicking the star rating you wish to apply to a snap.

Address

The Address field displays the website address that a snap was captured from. The field is left blank for 

screensnaps and any images you import, however you can add or edit the web address field at any time.

Type

The Type menu allows you specify whether the selected snap is a Screenshot, Websnap, Photo, Illustration, 

Mockup, iSight, iPhone or Other image. This can be particularly useful when building Smart Collections.

Date

The Date field shows the date that a snap was taken. The snap date cannot currently be edited.

Published

The Published table shows a list of locations that you have published a given snap to. The table will remain 

empty until you setup an account in the Publishing preferences tab, and publish an image to a service.

Assigning Tags

Images can be assigned as many images as you wish. To assign tags, ensure that a snap is selected and sim-

ply click in the Tags field. Type in the tags you wish to add to a snap, pressing return after each tag to apply it 

to the snap. You can also enter tags as comma-separated words or phrases, and LittleSnapper will convert the 

values to tags after each comma.

If you have selected more than one snap, entering tags into the inspector will overwrite all the existing tags 

associated with an image.

Snap Descriptions

You can add descriptions to snaps by clicking in the Description field, and entering a plain-text description.

 The InspectorFigure 19:
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Organise your Library

To help manage snaps, you can use the ‘Collections’ area of the source-list to create sets of related snaps.

Collections

Collections allow you to create groups of images using drag and drop. To start a new collection, click the 

[+] button found in the bottom left of the main window, and choose ‘New Collection’. You may also use the 

keyboard shortcut Cmd + N to create a new collection. To add snaps to a collection, drag them from the main 

library [or an existing collection] to the desired collection in the source list.

To create a new collection from an already-selected group of snaps, simply use the ‘New  Collection from 

Selection’ option in the File menu, or keyboard shortcut Cmd + Shift + N.

Smart Collections

Smart Collections are generated dynamically based library metadata and user-defined rules relating to that 

metadata. To start a new smart collection, click the [+] button found in the bottom left of the main window, and 

choose ‘New Smart Collection’. You can also use the keyboard shortcut Cmd + Opt + N.

When creating a Smart Collection, you are able to specify rules that are used to 	generate the collection. You 

can use almost any library metadata, and specify whether snaps must meet all or any of the chosen rules.

Folders

Folders allow you to keep your collections organised. To create a new folder, click the [+] button in the bottom 

left of the main window, and choose ‘New Folder’. You may also use the keyboard shortcut Cmd + Opt + Shift 

+ N.

To move a collection or smart collection to another area or foler in the sidebar, simply drag and drop the items 

onto the target folder. You can also nest folders within other folders in the sidebar, should you wish.
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Editing Your Snaps

When in Edit mode, the action bar changes to show the editing and annotation tools.

Actionbar Tools

Share button The Share button lets you quickly publish the cur-

rently-edited snap to any setup publishing account. 

Should you wish to add or remove accounts, simply 

click the ‘Configure Accounts’ option at the bottom 

of the menu.

Cursor tool (A) The cursor tool allows you to select, resize and move 

annotations. You can also use it for click-and-drag 

element selection.

Hand tool (H) The Hand tool lets you pan around the currently-

edited snap.

Zoom Out (Cmd - ) Lowers the level of zoom in the Edit mode.

Zoom In (Cmd + ) Lets you zoom in on the snap up to a maximum of 

1600%.

Highlight / Mask (M) The Highlight tool overlays a semitransparent layer 

over the selected snap and allows you to cut out ar-

eas of the overlay to accentuate certain areas of the 

image. You can cut out as many rectangular areas as 

you wish.

 LittleSnapper’s Annotation ToolsFigure 20:
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Blur (B) The Blur tool lets you easily obscure areas of a snap. 

You can create an unlimited number of blur annota-

tions over any portion of a snap.

Square (S) The square tool allows you to draw rectangular 

shapes over the snap.

Circle (O) The circle tool allows you to draw circular shapes 

over a snap.

Line (L) The line tool lets you draw a line over the selected 

snap.

Arrow (R) Draws an arrow over the selected snap. All arrows 

that LittleSnapper draws have a slight curve for a 

slightly hand-drawn effect.

Text (T) Create text annotations with ease. To change a font 

use the Format menu or bring up the font-picker us-

ing keyboard shortcut Cmd + T. 

You can also use the drop-down menu in the text 

annotation HUD to add callouts to the text. This will 

add a second circular, numbered badge that you can 

place anywhere on the snap as a reference point.

Colour Picker The colour picker lets you change the colour for the 

currently-selected annotation(s).

Removing Annotations

If you ever need to remove annotations simply select the cursor tool, click the annotation you wish to remove 

and hit Delete or Backspace. To remove multiple annotations, you can click and drag (or use combinations of 

the Shift and Cmd keys) to make a selection, then use the Backspace or Delete key.

Shape Tools
All the shape tools (square, circle, 

line and arrow) can be customised 

using the colour-picker. The slider in 

the action bar allows you to change 

the stroke width.

You can also specify a particular 

fill option (outline or fill) using the 

keyboard shortcut F when an 

annotation is selected.
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Sharing Your Snaps

Publishing to Online Services

QuickSnapper

QuickSnapper is a free service provided by Realmac Software to LittleSnapper users. The service allows you 

to share your snaps and their metadata with your friends, colleagues and clients. Once set up, LittleSnapper 

uploads all metadata associated with the snap to your QuickSnapper account, and copies the web address to 

view the image online back into your library.

To register for the QuickSnapper service, go to the LittleSnapper Preferences window, and sign up from within 

the Publishing tab. You can also use this preferences window to sign into an existing account if you’re already 

registered.

Flickr

LittleSnapper allows you to upload snaps to Yahoo’s Flickr photo-sharing service. If  you have not already 

added your Flickr account to LittleSnapper you can do so by opening the application’s Preferences window 

and choosing the Publishing tab. You can add as many Flickr accounts as you wish to the LittleSnapper Pub-

lishing preferences.

Metadata from your library including image titles, URLs, descriptions, ratings and tags are automatically added 

to snaps sent to Flickr.

Discover QuickSnapper
To learn more about the service 

visit QuickSnapper.com

More About Flickr
To learn more about Flickr visit 

www.flickr.com
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Exporting to your Mac

Drag and Drop

To quickly export a snap from your library, simply drag the snap from the main icon view to your desktop [or to 

any other Finder window]. Any annotations you may have made will be automatically applied to the image.

When working in Edit mode, holding down the Option key allows you to drag and drop images directly out of 

the editing area. Annotations are automatically included with the snap.

PDF Export

LittleSnapper exports snaps to full-text PDFs, allowing you to retain links found on any snapped webpages, 

create multi-page and single-image PDFs.

Select any number of snaps, and choose the File > Export Website to PDF menu option [or use keyboard 

shortcut Cmd + Option + Shift + E].

Unchecking the ‘Use Pagination’ option will export an image-based PDF, whilst selecting the ‘Use Pagination’ 

option will generate a multi-page PDF. Both PDF versions are fully searchable and text-selectable.

Image Export

LittleSnapper exports to JPEG and PNG formats. To export to either format, simply select the snap(s) you 

wish to export, and choose the File > Export Images option. Select the image format you desire from the drop 

down, and select when to include annotations, and click ‘Export’.

Sending Images to External Applications

LittleSnapper allows you to send snaps [and the HTML that accompanies Websnaps] to external image and 

HTML editors. Once you’ve set up your preferred editors in LittleSnapper’s main preferences, simply right-click 

on an image, and choose the ‘View Image in’ or ‘View Source in‘ option to launch the selected snap in the ap-

propriate editor.
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Application Preferences

General Preferences

The General Preferences allow you to configure LittleSnapper’s application-wide settings.

On Login Launch LittleSnapper

The ‘On Login Launch LittleSnapper’ option is enabled by default to ensure that global shortcuts are always 

available for you to use and subsequent screenshots are added to your library automatically.

On Login Hide Main window

If you wish to hide LittleSnapper once launched [whether at login or otherwise], enable the ‘Hide main window’ 

option. You can easily re-open the LittleSnapper window by clicking its dock icon, by choosing ‘Show Little-

Snapper’ from the menu item or using the global keyboard shortcut Ctrl + L.

On Launch Show Welcome Sheet

If you want to hide the welcome sheet that appears each time you launch LittleSnapper, simply untick this op-

tion.

Before Snapping Hide Main Window

This option allows you to choose whether LittleSnapper should hide its main window whenever you launch one 

of the capture tools.

After Snapping...

Whenever you take a snap, you can choose to have LittleSnapper stay hidden, open in Icon view to view your 

library or open the current snap in Edit mode. You can also choose whether to show LittleSnapper or not.

LittleSnapper Browser Options

When using the LittleSnapper browser, you can turn on or off the snapshot sound played when a page is 
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captured. You can also enable basic editing options in the browser that allow you to change text and other 

elements on the page.

View image in / View source in

LittleSnapper allows you to send snaps to external editors. These options allow you to configure which image 

and HTML editors are used to open saved snaps.

WebSnaps

The WebSnaps preferences allow you to configure the resolution that LittleSnapper should use when captur-

ing webpages using the ‘Snap Web Address from Safari’ browser option. A list of recent Mac models and their 

resolutions are included for easy reference, however if you wish to specify a custom resolution simply choose 

‘Custom’ from the drop-down menu and enter the required dimensions.

Shortcuts

The LittleSnapper preferences allow you to customise the global keyboard shortcuts for the options found in 

LittleSnapper’s menu item. You can find a list of defaults at the end of this manual. If at any time you need to 

reset the keyboard shortcuts to the defaults that ship with the application, simply click the ‘Reset Shortcuts’ 

button.

Publishing

The Publishing tab is where you set up and configure your account details for any webservices you wish to 

publish to. You can add an unlimited number of sharing accounts to the preferences and any accounts added 

here appear in the Share menus found in the Icon and Edit views.

LittleSnapper supports QuickSnapper, Flickr, FTP and SFTP accounts. To setup an account, simply click the 

[+] button, select the type of account you wish to add and follow the steps for each service type.

FTP Uploading

When setting up FTP accounts, be sure to enter a fully-formed web address including the http:// into the Web 

Address box. The Web Address should be the publicly-accessible location of the folder that LittleSnapper is 

uploading to, and is used to generate the web address of any images you upload.

Note:
Whenever you’re exporting snaps 

as images, PDFs or drag-and-

dropping them into the Finder, 

LittleSnapper automatically names 

files based on the Title used in the 

LittleSnapper library.
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Updates

To ensure you’re always running the newest version of LittleSnapper, we strongly advise users to let the ap-

plication check for new versions when you launch it. Sending Anonymous System Information is optional, 

however provides us with useful information on which Mac models, and versions of Mac OS X our users are 

running. No personally-identifiable information is sent to Realmac Software when the anonymous system 

information option is checked.

Advanced

The Advanced options allow you to customise the location of your LittleSnapper library. By default your library 

is stored in the ~/Library/Application Support/LittleSnapper/ folder with a Username.lslibrary filename.

You can move your library to anywhere on your Mac (or to a shared location such as Dropbox). To link Little-

Snapper to this moved library, simply launch LittleSnapper once you’ve moved the library. Go to the Preferenc-

es > Advanced window and click “Choose” to point LittleSnapper to the new location. You will need to restart 

LittleSnapper in order for the change of library to be applied.

 LittleSnapper’s Advanced PreferencesFigure 21:
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Keyboard Shortcuts

User Interface

Icon View Cmd + 1

Edit View Cmd + 2

Browser View Cmd + 3

Toggle Inspector Cmd + Shift + i

Icon View

Rename Snap Return

Delete Image from Library Cmd + Backspace

Remove Image from Collection Cmd + Shift + Backspace

View Image in Image Editor Cmd + Shift + U

View Source in HTML Editor Cmd + Option + U

Open Website in Default Browser Cmd + Shift + O

Open Website in LittleSnapper Cmd + Option + Shift + O

Search Cmd + F
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Keyboard Shortcuts

Browser

Snap Page Cmd + S

Open Element Selection (DOM Snapping) Cmd + D

Library Organisation

New Collection Cmd + N

New Collection from Selection Cmd + Shift + N

New Smart Collection Cmd + Option + N

New Folder Cmd + Option + Shift + N

Snap

All snap tool keyboard shortcuts are global and customisable in the LittleSnapper Preferences > Shortcuts tab. 

Snap Web Address from (Browser) Cmd + Option + 1

Open Current Website in LittleSnapper Cmd + Option + 2

Snap Full Screen Cmd + Option + 3

Snap Area Cmd + Option + 4

Snap Window Cmd + Option + 5

Show LittleSnapper Cmd + Option + L
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Keyboard Shortcuts

Edit

Cursor tool A

Hand tool H

Zoom Out Cmd - 

Zoom In Cmd +

Highlight / Mask M

Blur B

Square S

Circle O

Line L

Arrow R

Text T

Export

Export Images Cmd + Shift + E

Export Website to PDF Cmd + Option + Shift + E


