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Chapter 1: Building Workgroup Sites

The workgroup features in Adobe CioLive let

you work collaboratively with others on a

Web site. You check files out from the

Adobe Web Workgroup Server to edit them, and

the files are protected until you check them in

again. Once a file is checked in, all links to the file

are checked and updated, ensuring link integrity

for the site. The site window shows which files are

checked out at any given time by which users. The

Workgroup Server also stores previous versions of

checked-in files, so you can compare changes with

earlier versions or revert to a previous version.

This chapter describes how to author workgroup

sites in GoLive. For instructions on installing and

starting the Workgroup Server, see "Installing,

starting up, and shutting down the Workgroup

Server" on page 28. Chapter 2 describes how to use

the browser-based Workgroup Administration

tool to carry out basic tasks like adding new users

to the workgroup and controlling access to

workgroup sites.

About GoLive workgroup sites

GoLive workgroup sites are simply GoLive sites

that are stored on the Adobe Web Workgroup
Server instead of the file system of your computer.

The Workgroup Server acts as a repository for sites

being developed rather than as a typical Web

server, ihough stored on the Workgroup Server,
workgroup sites have the same structure as regular

single-user sites and appear the same in the site

window when you open them. However, special

workgroup features of GoLive are activated when

you open a workgroup site. These features let you

track who's doing what in the workgroup — which

files in the site are available for editing, which are

being worked on by others, and what's left to do

for each file.

Files in a workgroup site — pages, images, style

sheets, or any other components of the site — have

to be checked out before you can edit them. Once

a file is checked out, others in the workgroup who

have the site open can see in their site window that

the file is temporarily locked and unavailable for

editing. They also know who has the file checked

out, and when it was checked out. The file still

appears in their site window, and it can still be

opened, but in read-only form.

Getting started with
workgroup sites

Here's how you get started using workgroup sites

in GoLive 6.0:

Install the Workgroup Server Install and start the

Workgroup Ser\cr, on a computer accessible to

members of the workgroup. The Workgroup

Server is ready to use, requires minimal adminis-

tration, and comes with preinstalled user

accounts. Add new accounts as needed for

workgroup members.
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Create a workgroup site As with single-user sites,

you can use the GoLive site wizard to create

workgroup sites. You can create a new, blank site,

or create a new site based on an existing folder of

Web files. Another option is to convert an existing

GoLive single-user site into a workgroup site.

Creating a workgroup site places the site

structure — site project file, site folders, and any

pages or supporting files that make up the site—

on the Workgroup Server, and also creates a copy

of the site project file and the site folder structure

on your computer. This site project file is a little

different fi^om the usual GoLive site project file in

that it contains login information for the

Workgroup Server. Opening a workgroup site

proiect file connects you to the actual site on

the server.

Mount a workgroup site To work on a workgroup

site that you didn't create yourself, you need to

mount the site on your computer. Mounting is a

one-time operation that moves a copy of the site

project file and the site folder structure from the

Workgroup Server onto your computer (when you

create a site yourself, this happens as part of the

process). After mounting a workgroup site, you

can open it like any other GoLive site.

Author the site After you've created (or mounted )

a site, you're ready to start collaborating with
others in the workgroup. The following features

make it possible for several users to work simulta-

neously on the site:

•  Check in and check out. Workgroup site files

need to be checked out before they can be

edited. This locks the file and prevents others in

the workgroup from editing it. The Locked

column in the site window tells vou which files

are checked out and by whom. If a file is

available, open the file and begin editing —

you're then prompted to check out the file. For

others in the workgroup, the Locked column

will now show that the file is checked out to you.

When you're done editing, check the file back

in, and use the comment field to update others

on what changes you've made to the file. The

Locked column icon is automatically updated to

show others in the workgroup that the file is

now available for editing.

Note: If a file is checked out, you can open it in read-

only mode. If necessary, the server administrator can

reset the lock on any file to make it available for

editing (however, any changes made after the file was

checked out will be lost).
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B. Icon for a file checked out by you

•  File versioning. Whenever you or another

member checks in a file, a new version of the file

is created in the Workgroup Server database.

The file you (and others) see in the site window

is the most recent version of the file checked in

to the database; however, all previous versions
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of the file are also stored in the database. You can

open previous versions, compare them with the

most recent version or your local checked-out

version, and revert to a previous version if

necessary.

• Shared information. For workgroup sites, you

can use the To Be Edited column and

(Completed column in the site window (Files

tab) to track work needed on particular files.

(To edit these columns, choose Window >

Workflow to open the Workflow palette.)

Another source of information is the site

window's User Activity tab, which lists all

workgroup members with site access and which

files they are currently working on.

• Workgroup-enabled clients. You can check out

workgroup site files—including images, anima-

tions, or QuickTime clips—with Photoshop,

Illustrator, I.iveMotion, or any application that

supports the WebDAV protocol.

• Site backups. During development, the server

administrator can easily create backup copies of

the Web site. The backups are stored on the

Workgroup Server database for easy search and

retrieval.

Publish the site For workgroup sites, one or more
publishing servers are set up in advance by the

server administrator. Any member of the

workgroup can publish the site, choosing a server

from the preset list. The server administrator can
also choose to publish the site using the

Workgroup Server Administration tool, or

Workgroup Admin. (See "Publishing sites" on

page 41.)

u u

Work}^roiip production ciivironiiicnt
A. Workgroup member using GoLive B. Workgroup member
C. Workgroup member D. Workgroup Server
E. Workgroup Web site F. Publishing server G. End user

Workgroup advantages for the
single user
Although designed for team Web-building,
Ciol.ive's workgroup features can also be useful

when you're working on a Web site by yourself.
Simply install the Workgroup Server on the same

computer where you're running (loLive, and then
create your site as a workgroup site rather than a

single-user site. Or, convert an existing single-user
site to a workgroup site. Then take advantage of
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workgroup site features such as easy site archiving

(using the Workgroup Admin) and the file history,

which lets you save previous versions ot all site

files, compare source code between versions, and

restore deleted files.

About the workgroup site
window
WTien you open a workgroup site in the site

window, the title bar shows the site name and the

Workgroup Server name and port in parentheses.

The Locked column in the site window displays

information about the current lock state of

the files.

• Checked In status has no icon. The file can be

checked out for editing.

• Checked out e.xclusixe status, indicated by a
pencil icon 8?, applies to files you've checked

out yourself You can immediately open and edit

files checked out to you. .\s long as the file is

checked out to you, other users have read-only

access.

• Checked out b\- Someone Else status is indicated

by the padlock icon ^. You have read-access

only to files checked out by another member of

the workgroup. If a file is checked out, you

should periodically refresh the site window

(Site > Refresh \'iew, or click the Refresh View

button on the toolbar) to see whether the file

has been checked in again. (See "Refreshing the

site view" on page 15.)

The workgroup site window also adds two

columns to the right of the Status column:

Completed, and To be edited. You can add infor-

mation to these two columns using the Workflow

palette, accessible from the Window menu. You

can use these fields to inform other workgroup

users how much work or what type of editing is

needed on a particular file.

Using the Workgroup toolbar
buttons

The Workgroup toolbar, at the right end of the

main toolbar, puts Workgroup features into easy

reach next to GoLive's existing tools. You can use

the Workgroup toolbar buttons to check in and

check out files, compare file versions, revert to a

previous file version, and verif\' which files are

checked out by whom.

• To show or hide the toolbar, select or deselect

the Workgroup Toolbar choice in the Window

menu.

• To undock the toolbar, drag its left edge to the

desired location. To redock the toolbar with the

main toolbar, double-click its title bar

(Windows only).

The following buttons are a\ ailable on the

Workgroup toolbar:

• The Check Out button ^1 checks out selected

files in the site window. It will also check out a

file open in read-only mode it that file is the

active window.

• The Check In button »ir| checks selected files

back in again.
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The Undo Check Out button | jyl discards any

changes you have made to a checked-out file

and checks it back into the server, but without

creating a new revision of the file. This saves

storage on the server. Undo Check Out is useful

if you have inadvertently saved unwanted

changes to a checked-out file, or if you

mistakenly check out a file and don't want to

create a new, identical revision by checking the

file back in again.

The Compare to Server button B^ compares

the currently selected checked-out file with the

last checked-in version of the file on the server.

This can be useful when you want to track

changes you've made to the file since checking

it out.

The Revision List button [£^1 displays all stored

revisions of the selected file. Each time you

check in a file, GoLive saves a revision to the

Workgroup Server. This revision history lets

you inspect and return to any previous version

of a file, and view any comments entered for

each revision.

The User Activity button H^l displays users

currently logged in to the Workgroup Server
and any files checked out to those users.

Clicking this button activates the User Activity
tab in the site window.

Creating workgroup sites

To create a CoLive workgroup site, you can use the

site wizard or the (]on\ert to Workgroup Site

menu choice. You can easily import an existing

Web site and bring it under GoLive's management.

• Use the site wizard to create a new, blank

workgroup site, or a workgroup site based on a

folder on your computer containing a site,

pages, or resource files created with another

application.

• Choose Site > Workgroup > Convert to

Workgroup Site to convert a GoLive single-user
site on your computer to a workgroup site for

collaborative editing. Converting a site copies
the site contents (site project file, site folders,

pages, and supporting media) to the

Workgroup Server. The original site remains on

your computer but is now linked as a mirror

version to the server copy. (See "Converting

single-user sites to workgroup sites" on page 7.)

Note: Workgroup luenibers with administrative
privileges on the Workgroup Server can also create
workgroup sites using the Workgroup Admin. (See
"Creating sites" on page 33.)

Using the site wizard

Use the site wizard to create a new, blank

workgroup site, or a new workgroup site based on

existing files. When you create a workgroup site

using the site wizard, GoLive places the full site on

the Workgroup Server and a partial copy of the site

on your local computer. The local site is a place-

holder version of the server site, with the same

folder structure but containing no files except the

site project file. Opening the local site project file

connects you to the server and allows you to view

and edit ihe lull site in the site window as if it were

on your computer.
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Logging into the Workgroup Server After

selecting a site creation option in the site wizard,

you log into the Workgroup Server to create the

site on the ser\'er. Before \'0u use the site wizard,

obtain the following information from your server

administrator: a user name and password, the IP

address or server name of the computer the

Workgroup Server is running on, and the server

port number (default port is 1102).

Advanced URL handling During site creation you
ha\ e the opportunit\" to specif)' how GoLive

handles site URLs, including how URLs are

encoded and whether they are case-sensitive. If

you're creating a site by importing an existing site,

it's particularly important to set URL encoding

correctly to avoid broken links in the new site.

After you create the site, you can change the URL

encoding (but not URL case-sensitivity checking)

using the Site Settings dialog box. (Choose Site >

Settings, select URL Handling, and then select

URL Encoding options. ) For more information on

URL handling, see GoLive Help.

To create a workgroup site using the site wizard:

1 Choose File > New Site to open the site wizard.

2 Select Workgroup, and click Next.

3 Do one of the following:

• Select Blank Site to create a site project file; a

root folder containing a blank home page

named index.html; a data folder containing

empty subfolders for resource files; and a

settings folder containing site-specific settings

on the Workgroup Server database.

• Select Mount if you want to connect to a

workgroup site that's already been created on

the Workgroup Ser\'er by another member of

the workgroup (see "Mounting a workgroup
site" on page 8).

• Select Import from Folder to create a new

workgroup site based on a folder of existing

Web files— HTML, XML, XHTML, or other

resource files — on your computer. GoLive

creates a copy of the folder and makes it the new

site's root folder, and adds new folders for the

site's data and settings files. You specif)' a name

for the site project file and create a folder to put

it in.

/^   Use the Import from Folder option to bring a

s   non-GoLive site under GoLive management.

• Select Import from GoLive Site to create a

workgroup site from one of the site templates

installed with GoLive. The templates are located

in the Site Templates folder, inside the GoLive

6.0 folder. (See GoLive Help.) You can also use

this choice to convert an existing GoLive single-

user site to a workgroup site.

Note: To create a workgroup site based on a copy of

a site downloaded from the Web via FTP or HTTP,

you must first use the site wizard to create a single-

user site, and then convert the site to a workgroup

site. (See GoLive Help, and "Converting single-user

sites to workgroup sites" on page 7. )

4 Click Next. If you selected Import ft-om Folder

or Import from GoLive Site, follow the instruc-
tions for selecting a folder or GoLive project file,

respectively, and then click Next to log into the

Workgroup Server. (For Blank Site or Mount,
proceed directly to the login dialog box.)
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5 In the Workgroup Server login dialog box, enter
the server login data:

• In the Server text box, enter the IP address or

server name of the computer the Workgroup

Server is running on. If the Workgroup Server is

running on the same computer with GoLive,

you can also enter localhost as the server name.

• In the User Name and Password text boxes,

enter your workgroup server user name and

password.

• The Port value defaults to 1 102.

6 Select the Save box if you don't want to be

prompted for the password during subsequent

logins. Since you only have to connect once per

session, we recommend that you don't select this

option unless you work on a computer that is

physically secure.

7 Click Next, and follow the instructions in the

site wizard.

Naming conventions for local copies of

workgroup sites

As part of the site creation process in the site

wizard you create and name a local, or mirror copy

of the workgroup site. The folder name for the

local copy will combine the site name you choose

and the name or address of the computer hosting

the Workgroup Server. The part of the name that

identifies the host computer varies depending on

how you logged into the Workgroup Server when

you started the wizard.

If you logged into the Workgroup Server as

localhost (allowed if GoLive and the Workgroup

Server are running on the same computer) and

created a site called Test Site, the local site copy

will be named "Test Site on localhost".

If you logged in using the IP address or name of

the Workgroup Server's host computer, the local

site copy will be named "Test Site on

192.168.1.210" or "Test Site on <computer

name>".

Converting single-user sites to
workgroup sites

Another way to create a workgroup site is to

convert an existing GoLive single-user site. The

conversion copies the local site onto the
Workgroup Server database. After the site is copied

to the database, workgroup features like file

versioning, file comparison, and site backup are

available.

Note: After conversion, your local sitigle-user site
will be linked as a mirror copy with the workgroup

site on the Workgroup Server database. If you want

to create a new workgroup site and also preserve a
copy of your original single-user site, use the Import

from CjoLive Site option in the site wizard.

To convert a local single-user site into a

workgroup site:

1 With the single-user site open, choose Site >

Workgroup > Convert to Workgroup Site, and

then click OK in the message box.
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2 In the Workgroup Server login dialog box, enter
the server login data:

• In the Server text box, enter the IP address or

name of the computer the Workgroup Server is

running on. If the Workgroup Server is running

on the same computer with GoLive, you can

also enter localhost as the server name.

• In the Username text box, enter your

Workgroup Server user ID.

• In the Password text box, enter your Workgroup

Server password.

3 Select the Save box if you don't want to be

prompted for the password during subsequent

logins. Since you only have to connect once per

session, we recommend that you don't select this

option unless you work on a computer that is

physically secure.

4 Click Convert.

GoLive converts the local single-user site into a

workgroup site and uploads it to the Workgroup

Server. As part of the conversion, the single-user
project file on your computer is replaced by a local

copy of the new workgroup site project file. The

local version now contains login information that

connects you to the Workgroup Server when you

open it.

Note: The site folder for a converted single-user site

does not follow the naming conventions for local

copies of workgroup sites created using the site
wizard (see "Naming conventions for local copies of

workgroup sites" on page 7). The site folder for a

converted single-user site retains its original name.

Mounting a workgroup site
If you did not create a workgroup site yourself but

need to work on it, you must first mount the site

on your computer. Mounting a site connects you

to the Workgroup Server and copies the site

project file (and settings and data folders) from the

server onto your hard drive. You only have to

mount a workgroup site once. After the site is

mounted, you can open the site on your computer

in the same way you open a single-user GoLive

site. Opening the site project file after the site is

mounted automatically connects you to the

Workgroup Server.

Before you attempt to mount a workgroup site,

make sure you have obtained the following

information from your Workgroup Server

administrator:

• IP address or server name of the computer the

server is running on.

• Your user name and password.

• The port number for the server (default port

number is 1102).

To mount an existing workgroup site:

1 Choose File > Mount Workgroup Site.

2 In the Mounting a Workgroup dialog box, enter

the login data — server IP address, user name and

password, port number —you have obtained from

your server administrator. If the Workgroup

Server is running on the same computer with

GoLive, you can also enter localhost as the

server name.
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3 Select the Save box if you don't want to be

prompted for the password during subsequent

logins. Since you only have to connect once per
session, we recommend that you don't select this

option unless you work on a computer that is

physically secure.

4 Click Next.

If you have successfully logged into the Workgroup

Server, you see a list of sites on the server that you

have permission to edit. Access to sites is

controlled by your system administrator. If the site

you're looking for isn't in the list, contact your

server administrator.

5 In the site list, select the site you want to mount

on your computer, and click Next.

6 Use the Browse button to locate the folder

where you want to store the local copy of the site,

or create a new folder. After you have selected or

created a folder, the full path to the folder displays

in the dialog box. Click Finish.

GoLive creates a site on your computer that

matches the server site, but with empty site folders.

The name of the local site follows the same rules

that apply when you create a workgroup site using

the site wizard (see "Naming conventions for local

copies of workgroup sites" on page 7). The site

window shows the contents of the site on the

server. You can now start checking in and out your

work (see "Authoring a workgroup site" on

page 10).

Opening sites that have already

been mounted
Once a local copy of a workgroup site exists on

your computer, you can open it like any other

GoLive site. If you've mounted a workgroup site,

converted a single-user site, or created a site using

the site wizard, a local copy of the site exists on

your computer. When you open the local copy,

GoLive requires you to log into the Workgroup

Server. This allows you to check in or check out

files and see whether other workgroup users have

checked out files in the site.

To open a workgroup site that is already mounted:

1 Do one of the following:

• Choose File > Open Recent Files, and select the

site from the submenu.

• Choose File > Open, navigate to the mounted

site file, select it, and click OK.

• In your file system, locate the mounted copy of
the workgroup site file and double-click its icon.

2 In the login dialog box, enter your password

and click OK.

Note: If you saved your password when you mounted

the site, you are logged in automatically and the
login dialog box does not appear.
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If you open a workgroup site when the Workgroup

Server is not running, an alert appears. Click OK

to open the local copy of the workgroup site

anyway. Files that are currently checked out to you

are available for editing. (See "Editing checked-out

files in offline mode" on page 14.) The following

files are available in read-only mode:

• Files that you've checked out in the past, and

checked in again. Checking in a file updates the

site on the server and leaves a local copy of the

file on your computer.

• Files that you've downloaded. Downloading a

file doesn't check it out, but places a read-only

version on your computer, useful when you

\vant to check links to it from files that are

checked out.

Authoring a workgroup site

GoLive offers specific tools and features that make

it easy to collaborate with others on a workgroup
site. Consider the following when collaborating on

a site:

• Files that make up the workgroup site must be

checked out before you can edit them. If a file is

checked outlay another member of the

workgroup, you have read-only access to the file

until it's checked back in again.

• WTiile working on a workgroup site, refresh the

site view regularly to ensure that the site

structure mirrored in the site window is up to

date. (See "Refreshing the site view" on

page 15.)

Checking files in and out

After checking out and editing a file, you check the

file back in to make the new version available on

the server for other users. WTien you create a new

page or file, you are automatically prompted to

check the file in to make it available to other users.

Note: You cannot delete, copy, rename, or movefiles

that are checked out from the Workgroup Server.

When you check out a file, the following actions
take place:

• If the file does not exist locally, it is copied to

your local platform.

• If a local copy of the file exists, GoLive checks to

make sure that the file is up to date. If necessary,

GoLive replaces the local copy of the file with

the most recent version.

• The file is locked on the server, and the lock

status displayed in the site window is updated to

reflect the checkout.

When you check the file back in, the following

actions take place:

• The Workgroup File Check In dialog box allo^vs

you to enter a comment on any changes you've

made.

• The version of the file on the Workgroup Server

is replaced with the current version.

• The file is unlocked, and the lock status

displayed in the site ^^'indow is updated to

reflect the check-in.

• A revision is created.
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• Any links in the file are checked, and if necessary

updated, based on changes made to other files

in the site while this file was checked out; also,

links in other files are checked against changes

in this file and updated as needed.

Note that after checking a file back into the

Workgroup Server, a local copy of the file remains

on your computer. You can open this file in read-

only mode if you're working without a connection

to the Workgroup Server.

In addition to the Files tab, you can check in

and check out files in the Extras tab, navigation

view, and links view.

Checking out files and folders

You can check out files and folders in the

workgroup site that are not already checked out to

another workgroup member. The Locked column

in the site window shows which files are available

for checkout.

To check out files:

1 Choose File > Open, select the workgroup site

file, and click Open.

2 Do one of the following:

• In the Files tab of the site window, double-click

the file you want to check out. For HTML or

XHTML files that are editable in GoLive, the file

opens in read-only mode. As soon as you try to

edit it, a Check Out dialog box appears asking

vou whether vou want to check out the file.

Click Yes. When you double-click files that are

not editable in GoLive (such as PSD files or

JPEG files) you are prompted to check out the

file first, after which it opens in the application

mapped to that file type.

• In the Files tab, select the files or folders you

want to check out. Then click the Check Out

button itg^l in the Workgroup toolbar.

• In the Files tab, select the files or folders

you want to check out. Then choose Site >

Check Out.

• In the Files tab, select a file or folder. Then

choose Check Out from the context menu.

• Right-click (Windows) or Ctrl-click (Mac OS)

anywhere in an open, still checked-in document

and choose Document > Check Out from the

context menu.

Note: Menu commands, context menu commands,

and buttons are sensitive to the lock status of the

selected item. For checked-out items, for example.

Check Out commands aren't available.

When you check out folders, the Workgroup File

Check Out dialog box lists all files to be checked

out and gives you the option to exclude individual

files from being checked out. You can choose a

structured view (folders displayed) or a flat view

(folders omitted). To exclude a file from the check-

out, simply deselect its check box. Then click the

Check Out button.
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Checking in files and folders

When you"re done editing a file and have saved

your changes, check the file in to create a new

version that will be available to others in the

workgroup. If you're adding a new file, GoLive

requires that you check the file in, aft:er which it

will appear in the site window for other users in

the workgroup.

To check in files:

1   To select the files you want to check in, do one

of the following:

• In the site \\"indo\\'s Files tab, select the files or

folders you want to check in to the Workgroup

Ser\'er, and then click the Check In button &fS^l

in the Workgroup toolbar.

• In the Files tab, select the files or folders you

want to check in, and choose Site >

Check In.

• In the Files tab, select a file or folder, and then

choose Check In from the context menu.

• With no files selected in the Files tab. Right-click

(Windows) or Ctrl-click (Mac OS) in the tab,

and then select Check in aU from the context

menu to check in all checked-out files.

Note: You can also check in an open document using

any of the above methods.

/^   You can view just your checked-out files on the

s    User Activity tab, and check them in from there.

After you choose Check In, the ^\'orkgroup File

Check In dialog box displays the files or folders

you have selected for check-in, and allows )'ou to

enter check-in comments.

2 In the Workgroup File Check In dialog box, use
the options as follows:

• If )'ou \vant to exclude a file or entire folder

listed from being checked in, deselect the check

box next to it.

• If you're not sure whether to check in a file and

you first want to compare the current version

with the version that was last checked in, select

the file in the list and cUck the Compare to

Server button. The Compare Revisions dialog

box displays the source code of the current

version side by side with the source code of the

server version of the file and highlights any

differences.

• To view the list of files for check- in grouped by

folders, select the Show Folder Structure option.

This structured view allows you to deselect an

entire folder. If you want a flat list omitting

folders, deselect this option. This flat view

provides a check box at the top of the list, which

lets you deselect all files.

• If you \vant to add a check-in comment, t}^e it

into the bottom pane of the dialog box. This

check-in comment appears next to the

respective revision in the Revision List dialog

box.

3 Click Check In.

Note: After checking a file back into the \Vorkgroup
Server, a local copy of the file remains on your

computer. This local copy is locked for read-only

access.
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Undoing a checkout

It you check out a tile, edit it, and then decide you

don't want to save the changes, you can undo the

checkout. This discards any changes you've made

to the file and checks it back into the server

without creating a new entry in the revision

history.

To undo a checkout:

1 Select the checked-out file or files in the Files

tab of the site window.

2 Do one of the following:

• Right-click (Windows) or Ctrl-click (Mac OS)

one of the selected files, and select Undo Check

Out from the context menu.

• Select Site > Undo Check Out.

3 In the Workgroup File Revert dialog box,

click Revert.

The files are checked back into the Workgroup

Server and any changes discarded.

9    Instead of selecting specific checked-out files,
you can select Site > Undo Check Out All, and

then select the files you want to undo checkout for in

the Workgroup File Revert dialog box.

Checking referenced source files in

and out

You can check in or check out referenced source

files such as images. Smart objects, and Compo-

nents from within the file that references them.

Select the referenced object on the Web page, and

choose Source Link > Check Out or Check In from

the context menu.

Reference and link updating

CoLive's site management features keep track of

links and cross-references between all files in a

workgroup site, just as they do for single-user sites.

This means that if you change the name of a

workgroup file or its location in the site, GoLive

updates references to it throughout the site. Even if
you change the name or location of a file refer-

enced by a checked-out file, the Workgroup Server

maintains"still-to-update" information for the file

and updates the reference as soon as the file is

checked in again.

The Workgroup Server also monitors links and

references for files checked out by a WebDAV-

compatible client other than GoLive, and updates

those links and references as needed when the file

is checked in by the WebDAV client.

Note: For WebDAV clients that can rename, move,
or delete files in the site, the Workgroup Server will
update links and references in the site (as it does in

GoLive). However, underlying HTTP restrictions
prevent GoLive from displaying the same notifi-

cation you receive for updates that take place
within GoLive.

Opening a file in read-only mode

If a file ischeckedout by another user, you can still

open it in read-only mode. The read-only file will

match the last version checked into the server (it

won't show changes made after the file was

checked out).

Note: Opening a file without checking it out also
opens the file in read-only mode.
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To open a checked-out file in read-only mode:

1 In the site window's Files tab (or in navigation

view or links view), double-click the file you want

to open.

2 Click Yes to open the file in read-only mode.

Editing checked-out files in offline mode

Occasionally you may need to edit workgroup files

without connecting to the Workgroup Server — for

example, on a laptop computer with no network

connection. In this situation, you can edit

checked-out files in offline mode. To do this, you

first check out the desired files in onhne mode.

(See "Checking out files and folders" on page 11.)

If you want links to appear intact while editing,

you then do\vnload related files that you don't

need to edit but that are referenced by your

checked-out files. (Do\\'nloading a server file

copies a read-only version of the file to your local

site.) You can then edit the checked-out files offline

and check them back into the server when the

connection is restored.

To download files from the Workgroup Server:

1 WTiile connected to the server, select the files

you want to download in the site window. Select

multiple files by Ctrl-clicking (Windows) or Shift-

clicking (Mac OS).

2 Do one of the following:

• Choose Site > Download.

• Select the files, and then choose Download from

the context menu.

To edit a file in offline mode:

1 Check out the needed files while still connected

to the Workgroup Server.

2 WTien you want to edit the files, open the

site file.

An alert appears, and a warning also displays in the

Network Status window.

3 In the alert, click OK to open the site am'way.

/^   You can also switch directly to offline mode

s   without closing the workgroup site. Select Site >

Workgroup > Work Offline. To go online again,
select the command again.

The site opens in offline mode. The site window

shows all files in the site. However, the only files

that you can edit are files currently checked out to

you. You can also open (in read-only mode) any

files you've downloaded, and any file you have a

local copy of on your computer (a local copy exists

for any file checked out during previous site

editing).

4 In the site windo\v, locate the checked-out file

you want to edit. Checked-out files are indicated

by a pencil icon in the Locked column.

5 Double-click the checked-out file to open it.

Edit the file as needed, and save the changes.

6 The next time you are online and the server is

accessible, open the site and check in the file. (See

"Checking in files and folders" on page 12.)
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Removing local copies of checked-in files

When you first create a workgroup site, an empty

copy of the workgroup site (containing a site

project file only) is created on your computer. As

you edit, any files that you check out from the

server are copied to your local site. These local

copies remain even after files are checked in again.

You can remove these local files from your

computer at any time.

To remove local copies of checked-in files:

• To remove all local files. Right-click (Windows)

or Ctrl-click (Mac OS) annvhere in the

background of the site window's Files tab and

choose Remove Local Files from the context

menu, or choose Site > Remove All Local Files.

• To remove a single file, select the file and choose

Remove Local File from the context menu, or

choose Site > Remove Local Files.

• To remove selected files, Ctrl-click (Windows)

or Shift-click (Mac OS) the files and choose

Remove Local Files from the context menu, or

choose Site > Remove Local Files.

Tracking workgroup activity
You can use GoLive's site refresh features to keep

track of recent updates to site files and compo-

nents. The User Activity tab tracks which files are

checked out to individual users in the workgroup.

Refreshing the site view

Since several users may work on a site at the same

time, it's a good idea to regularly refresh the site

view to make sure it reflects the site as it exists on

the Workgroup Server.

When you refresh the site view, GoLive communi-

cates with the Workgroup Server and checks for

lock state changes (whether files have been

checked in or out), and for files added to or deleted

from the server. It then updates the Files tab to

reflect this information.

The site view is automatically refreshed when you

check in or check out files, compare file versions,

or open the Site Settings dialog box.

To refresh the site view:

1 Open the site window, if not already open.

2 Do one of the following:

• Click the Refresh View button | Vi \ on the

toolbar.

• Choose Site > Refresh View.

• Right-click (Windows) or Ctrl-click (Mac OS)

anywhere in the background of the site

window's Files tab, and choose Refresh View

from the context menu.

• Press the F5 key (Windows only).
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Refreshing the External, Colors, and Font

Sets tabs

You can use the Refresh View command to check

the current site on the Workgroup Server for

added or removed colors, references, or font sets

and update the External, Colors, and Font Sets

tabs of the site window to reflect any changes.

You can also set up an automatic refresh of the

External, Colors, and Font Sets tabs. For instruc-

tions, see "Setting automatic refreshing of the

External, Colors, and Font Sets tabs" on page 24.

For a more comprehensive rescan of the entire site

on the server for new colors, references, or font

sets, use the Get Items Used command on the Site

menu. If the scan finds new colors, references, or

font sets that aren't listed, New Item groups are

created and added to the appropriate tabs in the

site window.

To manually refresh the view of the External, Colors,

and Font Sets tabs:

1 Click the External, Colors, or Font Sets tab in

the site window.

2 Do one of the following:

• Click the Refresh View button on the toolbar.

• Choose Site > Refresh View.

• Right-click (Windows) or Ctrl-click (Mac OS)

in the tab, and choose Refresh View from the

context menu.

• Press the F5 key (Windows only).

To rescan the site on the Workgroup Server for

items used:

1 Click the External, Colors, or Font Sets tab in

the site window.

2 Do one of the following:

• Choose Site > Get Items Used.

• Right-click (Windows) or Ctrl-click (Mac OS)

in the tab, and choose Get Items Used from the

context menu.

Note: The specific command displayed on the Site

and context menus varies with the tab you select.
The Get References Used command, for example, is

displayed when you select the External tab.

Viewing user activity

The User Activity tab lets you view users currently

logged into the server and which files they've

checked out. The tab displays a variety of infor-

mation on checked-out files, including file type,

size of the file when it was checked out, date and

time of checkout, whether the file is referenced in

the site, and the path to the local copy of the file.

To view which files are checked out by whom:

1   With a workgroup site open in the site window,

do one of the following:

• Choose Site > Workgroup > Show User Activity.

• Click the User Activity button |t^| on the

Workgroup toolbar.



ADOBE WEB WORKGROUP SERVER

User Guide

17

• Click the User Activity tab in the left pane of the

site window.

The User Activity tab lists all users who have access

to the site.
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User Activity tab in the Site Window

2 Click the Expand icon next to a user name to

show all files currently checked out to that user.

Using the file version history
When you check in a workgroup file, GoLive

creates a revision of the file and stores it on the

Workgroup Server. Repeated check-ins create a

version history, or Revision List, for each file. You

can view the file history for any file, revert to

previous versions in the history, and compare the

HTML source code for different versions side by

side. (See "Comparing different versions of a file"

on page 18.)

Inspecting and reverting to previous file

versions

The topmost file in the Revision List is the last

checked-in version of the file. For each version in

the list, the Revision List shows the check-in date,

the name of the user who checked it in, the path to

the file on the server, and check-in comments

(optional). You can open any file in the list, and if

necessary revert to that file, which moves a copy of

the file to the top of the list and makes it the most

current version on the server.

To inspect the file revision history of a file:

1 In the site window, select the file.

2 Do one of the following:

• Click the Revision List button  £^ | on the

Workgroup toolbar.

• Choose Site > Revisions > Revision List.

• Select the file in the site window, and choose

Revisions > Revision List from the context

menu.

The Revision List dialog box displays all revisions

of the file. Depending on whether you want to

compare revisions or revert to a previous file

version, proceed as described in the following

sections.

To revert to a previous version in the file history:

1 In the site window's Files tab, select the file you

want to revert to a previous version (the file must

be checked in).
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2 Invoke the Revision List by either chcking the

Revision List button  £fei | in the Workgroup

toolbar or selecting Site > Revisions >

Revision List.

3 In the Revision List dialog box, choose the file

version you want to revert to. The date and

comment information displayed next to each

version helps you identify each version. If you need

more information, you can open individual

revisions. To look at a revision, select it in the list

and click the Open button. The document opens

in layout mode.

4 When you find the file version you want to

revert to, select it in the list, and click Make

Current.

GoLive immediately reverts to the selected file

version, which replaces the current server version.

The file version you have reverted to appears at the

top of the Revision list. The version that has been

replaced is listed directly below.

Comparing different versions of a file

With GoLive's file comparison feature, you can see

the exact differences between file versions by

comparing their source code. Three types of

comparison are possible:

• You can compare a revision in the file history

with your current local version of the file. This

is useful if you have checked a file out and made

changes, and haven't yet checked the file back in.

The changes can be compared against any

selected revision.

• You can compare tvvo revisions in the file

history with each other.

• You can compare your local version with the

current server version.

In each case, a Compare dialog box displays the
source code of the selected file versions side by side

and highlights differences between them.

To compare a revision listed in the file history with

your current local version:

1 Select a file in the site window, and click the

Revision List button or choose Site > Revisions >

Revision List.

2 In the Revision List dialog box, select the

revision you want to compare with your current

local version.

3 Click Compare to Local.

The Compare Revision to Local dialog box shows

the source code of both file versions side by side.

Differences between them are highlighted. The

bottom left pane of the dialog box lists three

possible types of differences found:

• Added in Local. The code highlighted in the left

pane has been added to the local version and

does not exist in the version on the server.

• Removed in Local. The code highlighted in the

right pane (the server version) has been deleted

in the local version.

• Changed in Local. The highlighted code has

been changed in the local file. The respective
code is highlighted in both versions (left and

right panes).
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dialog box:

• Previous/Next Difference to move to the

previous or next difference found in the codes.

• Skip Empty Lines to ignore linefeeds added to

the code for readability. (Extra linefeeds in the

HTML code have no effect on the appearance of

the page and so can be ignored as a difference.)

• Show Different Colors to use a different

highlight color for both file versions.

• Hide Identical Lines to hide all code that is

identical in both file versions. This leaves only

the code differences displayed.

• Synchronize Scrolling to scroll the code in both

panes simultaneously while comparing code.

To compare two revisions included in the file history:

1 Select a file in the site window, then click the

Revision List button or choose Site > Revisions >

Revision List.

2 In the Revision List dialog box, Ctrl-click

(Windows) or Shift-click (Mac OS) the two

revisions you want to compare to select them.

3 Click Compare Revisions.

4 In the Compare Revisions dialog box, select

options as described earlier in step 4 for

comparing a revision with the current local

version.

After you have checked out and edited a file, you

may want to compare the local state ot the file with

the state the file had before you checked it out —

that is, you want to compare it with the current,

still valid server version.

To compare your current local version with the current

server version:

1 Do one of the following:

• With the file selected in the site window, or

while in the document, choose Site >

Revisions > Compare to Server, or click the

Compare to Server button.

• With the file selected in the site window, or

while in the document, click the Revision List

button  fe)| on the Workgroup toolbar; in the

Revision List dialog box, select the topmost

revision, and click the Compare to Local button.

2 In the Compare Revision to Local dialog box,

select options as described earlier in step 4 for

comparing a revision with the current local

version.

Inspecting and restoring deleted
files
GoLive gives you two ways of deleting workgroup

files and folders. You can move the files to the site

trash or completely delete the files from the server.

If you decide later that you need the files, you can

restore them to the site. Even files deleted from the

server can be restored to the exact location they

had in the site before they were deleted.

To choose how files are deleted from your site:

1  Choose Edit > Preferences, and select Site in the

left pane of the Preferences dialog box.
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2 Under When Remo\'ing Files, select one of the

options for handling deleted files:

• Move Them To System Trash deletes files ft-om

the server. The revision history of each deleted

file remains available on the server.

• Move Them To Site Trash moves deleted files to

the Site Trash folder, available on the Extras tab

of the site window. Moving the files to the site

trash does not delete the files.

Viewing and restoring deleted files

All workgroup files that you delete from a site can

be viewed and restored. The method for restoring

a deleted file depends on ho^v the file was deleted.

• If your site preferences are set to move deleted

files to the Site Trash folder, you restore the files

by manually moWng them back to the appro-

priate folder.

• If your site preferences are set to move deleted

files to the system trash, you can use the Restore

command to automatically restore the deleted

files to their original location in the site.

Note: If you delete the file revision history of a file

using the Workgroup Admin, a file deleted to the

system trash cannot be restored. (See ''Cleaning up
the file revision history" on page 47.)

To restore files from the site trash:

1 On the Extras tab of the site window, expand

the Site Trash folder.

2 Select the files in the Site Trash folder you want

to restore, and drag them to the desired location

on the Files tab.

To view and restore files deleted from the server:

1 With the site open, choose Site > Revisions >

Show Deleted Server Files, or Right-click

(Windows) or Ctrl-cUck (Mac OS) am'where in

the background of the Files tab, and then choose

Revisions > Show Deleted Server FUes from the

context menu.

Deleted files appear dimmed in the site window

at the same location they had before they were

deleted.

2 Select the deleted file you want to restore,

and choose Revisions > Restore from the

context menu.

GoLive automatically restores the file to its

original location in the site. Refresh the site view

(Site > Refresh View) to ensure that all files are

correctly displayed.

Publishing workgroup sites

You can publish a workgroup site using the

browser-based Workgroup Admin or fi-om within
GoLive. In both applications you specify publish

settings that control how the site is published. In

GoLive, use the Publish section of the Site Settings
dialog box (Site > Settings > Pubhsh) to specif)'

pubUsh settings, including options that let you

streamline your site by stripping out custom
GoLive code that isn't needed after a site is

published. In the Workgroup Admin, you specify

publish settings during the publishing process—
these settings temporarily override the publish

settings made in GoLive.
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Setting up publishing servers in the

Workgroup Admin

Before you can publish from within GoLive, the
server administrator (or someone in the
workgroup with administrator privileges) must
use the Workgroup Admin to define at least one
publishing server for the site. (See "Publishing

sites" on page 41.) A workgroup site can have one
or more publishing servers, for example, for
staging, archiving, and live publishing.

To open the Workgroup Admin, choose Site >
Workgroup > Open Workgroup Administration.
GoLive launches your default Web browser and
displays the Workgroup Administration startup

screen with your personal login information
already entered.

Publishing a workgroup site in GoLive

Publishing a workgroup site includes preparing
the site for publication, connecting to the

publishing server, and uploading the site's data. To
prepare the site for publication, use the optional
site cleanup feature. (See GoLive Help.)

Note: With workgroup sites (unlike single-user
sites), downloading files from the publishing server is

not supported. However, you can apply late-state
changes directly to the site after it's on the publishing

server. If you do so, make sure you also update the
local site files before pubUshing them again, to avoid
overwriting the changes on the publishing server.

To publish a site from within GoLive:

1   With the site window open, click the Site

Settings button on the toolbar, or choose

Site > Settings.

2 In the left pane of the Site Settings dialog box,

click the Publish Server icon.

3 From the Server pop-up menu, choose the

publish server where you want to publish the site.

If you're not sure which publishing server to

choose, contact your workgroup administrator.

Note: You cannot define a publishing server from

within GoLive. If you have administrator privileges,

choose Edit Server from the pop-up menu to open the
Workgroup Admin in your Web browser. In the

Workgroup Admin you are taken automatically to a
screen where you can add a publishing server. (See
"Defining a publishing server" on page 42.) If you
don't have administrator privileges, contact your

workgroup administrator.

4 Click OK.

5 Choose Site > Settings.

6 In the left pane of the Site Settings dialog box,

select Publish.

7 Select from the following options:

• Honor "Publish" State Of to conform to the

individual publish state you can set for each file

and folder in GoLive. Publish states for files are

If Referenced (default). Always, and Never; for

folders. If Not Empty (default). Always, and

Never. To override individual publish state

settings for files and folders, deselect the

respective options.

• Publish linked files only to upload only those

files that are part of the site hierarchy. This

option is enabled only if you haven't checked the

Honor "Publish" State Of options.
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• Publish linked files that are not part of the site to

upload even referenced files that are not part of

the site hierarchy (outside the root folder) and

copy them to a new folder. The new folder name

defaults to Other, but you can rename it using

the text box in the Hierarchy section of the

dialog box.

8 Use Hierarchy options to configure the

directory structure of the site when you

upload it.

• As in site preserves the current site structure.

• Separate pages and media creates a root folder

with two subfolders for HTML pages and media

items. You can change the default names for

each folder in the text boxes below.

• Flat creates a root folder containing all HTML

pages and media, with no subfolders.

9 Use Strip HTML Code For options as needed to

remove selected source code elements and

streamline the code without affecting the

appearance of the pages.

• Adobe GoLive Elements to remove GoLive-

specific tags and attributes that are used to edit

animations and scripted actions. If you don't

intend to edit animation or actions again, or

retain the full code in a separate archive copy of

the site, you can remove it from the files being

uploaded.

• Spaces to remove extra spaces, returns, and

linefeeds that are added to the code for

readability. HTML doesn't require extra spaces

and linefeeds between items.

• Comments to remove comments you have

added to annotate your pages.

10 Select Strip GoLive data from media files to

remove the GoLive-specific data that is saved with

Smart Objects used in your site. Stripping this data

reduces the HTML code in your pages and also

breaks the link between a Smart Object and its

source file. If you later edit the source file (for

example, a PSD file in Photoshop), the target GIF

or JPEG file will no longer be updated in GoLive.

Note: If your system administrator requires you to

adapt the site to the server environment to which you
are uploading—for example, altering site folder

structure or stripping code that should not be

available to the public—see GoLive Help.

11 Select Show options dialog to display the

Upload Options dialog box before starting the file

transfer. This lets you review your Upload options

before publishing.

12 Connect to the publishing server by doing one

of the following:

• Click the Publish Server connect/disconnect

button /€ I in the Site toolbar.

• Choose Site > Publish Server > Connect.

• Right-click (Windows) or Ctrl-click (Mac OS)

anywhere in the background of the site

window's Files tab, and choose Publish Server >

Connect from the context menu.

After successfully connecting to the publishing
server, the server directory structure displays in

the Publish Server tab in the right pane of the site

window.

13 Do one of the following to upload the

entire site:

• Choose Site > Publish Server > Upload All.
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• Right-click (Windows) or Ctrl-click (Mac OS)

in the background of the Files Tab, then choose

Publish Server > Upload All from the context

menu.

14 In the Workgroup Publish Options dialog box,
click Publish to start uploading files.

Updating published sites

After publishing a site, you may have additions or

changes that require updating the site on the

publishing server. In GoLive, you can copy new
site files and site files that have been modified since

the last upload (Modified Items Upload), or you

can upload any files that you select (Selection

Upload).

To update a site by uploading to the publishing

server:

1 Open the workgroup site, and connect to the

publishing server.

2 Do one of the following:

• To upload only modified items, either choose

Site > Publish Server > Upload Modified Items,

Right-cHck (Windows) or Ctrl-click (Mac OS)

in the background of the Files tab and choose

Publish Server > Upload Modified Items from

the context menu.

• To upload a selected file or folder, select the file

or folder you want to upload in the Files tab.

Then either choose Site > Publish Server >

Upload Selection, or Right-click (Windows) or

Ctrl-click (Mac OS) the selected file or folder

and choose Publish Server > Upload Selection

from the context menu.

3  In the Workgroup Publish Options dialog box,

click Publish to start uploading files.

Workgroup site settings

For workgroup sites, site-specific settings override

global site preferences. This ensures that

workgroup team members working on a site all see

the same site settings. Any member of the

workgroup can change the site-specific settings.

Once changed, the new settings are saved to the

Workgroup Server and are in effect for other users

when they next open or refresh the site in GoLive.

The option to turn site-specific settings off is

disabled for workgroup sites.

Note: All GoLive users collaborating on a workgroup

site should use the same Web Settings, Modules, and

Actions to ensure that shared work is consistent in

appearance and functionality.

About Workgroup Server site settings

The Workgroup Server section of the Site Settings

dialog box (Site > Settings > Workgroup Server)

displays your current login information for the

Workgroup Server, and the current refresh rate for

updating the External, Colors, and Font Sets tabs

in the site window.

To view current login information and server refresh

rate settings:

1   Choose Site > Settings to open the Site Settings
dialog box.
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2  In the left pane of the dialog box, select

Workgroup Serxer.

• The Server Information section of the dialog
box shows the IP address or server name of the

Workgroup Server computer, the name of the

workgroup site you have open, and the user

name and password with which you logged into

the server. You can use the Change User or
Change Password commands as needed to

change your login information.

• The Refresh section of the dialog box contains

an option to automatically refresh the External,

Colors, and Font Sets tabs in the site window, as

well as a text box where )'ou can enter a refresh

interval.

Logging into the Workgroup Server as a

different user

If you have a workgroup site open, you can log into

the site as a different user without closing and

reopening the site. To do this, you need correct

login information for another user with site access,

including a valid user name and password. You

may occasionally want to log in as a different user
in order to make checked-out files available for

editing or publishing.

To log in to the Workgroup Server as a different user:

1 Choose Site > Workgroup > Change User.

2 In the Web Workgroup Server Change User

dialog box, enter a valid user name and password

in the appropriate fields. Select the Remember
Password option if you don't want to be prompted

for your password ne.xt time you open the
workgroup site.

3 Click OK.

You are immediately switched to the new user, and

the Locked column in the site window is updated.

Your new user name appears at the left bottom

corner of the Files tab in the site window.

Changing your login password

Your user name and password are created by the

Workgroup Server administrator using the
Workgroup Admin. If you are a workgroup user

and don't have administrative privileges allowing

you to log into the Workgroup Admin tool, you
can change your Workgroup Server login

password yourself from within GoLive.

To change your login password:

1 Choose Site > Workgroup > Change Password.

2 In the Web Workgroup Server Change Password

dialog box, enter your existing password in the Old
Password field, and your new password in both the

New Pass^vord and Verify Password fields.

3 Click OK.

Setting automatic refreshing of the

External, Colors, and Font Sets tabs

Although transactions between GoLive and the

Workgroup Server — such as checking in or out a

file— will automatically refresh the contents of the

Files tab in the site window, it will not refresh the

External, Colors, and Font Sets tabs. You can

refresh these manually (see "Refreshing the

External, Colors, and Font Sets tabs" on page 16)

or use the Site Settings dialog box to set an

automatic refresh interval.
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To set automatic refreshing of the Colors, External

and Font Sets tabs:

1 Choose Site > Settings.

2 In the left pane of the Site Settings dialog box,

choose Workgroup Server.

3 Select the Reload Data Automatically option.

4 Set the desired refresh interval in seconds.

5 Click OK.

Enabling the ARM module

The ARM i Asset Replication Manager) module,

included with GoLive, allows GoLive to share
information about Workgroup Server files with

other Adobe applications such as Illustrator,

Photoshop, and LiveMotion. In GoLive, you can

designate these applications as editors tor specific

file types—for example, Photoshop as your GIF or

JPEG editor. In a workgroup site, when you check

out a GIF or JPEG file in the site window,

Photoshop starts and opens the file for editing.

The ARM module allows you to check the edited

file back into the Workgroup Server directly from

Photoshop, rather than performing the check-in

from GoLive. After checking in the file from

Photoshop, you should refresh the site view in

GoLive to reload the current Checked In lock state.

To enable or disable the ARM module:

1 Choose Edit > Preferences.

2 In the left pane of the Preferences dialog box,

choose Modules.

3 In the right pane, locate the ARM module and

select or deselect it.

4 Click OK.

Note: You must restart your computer to activate the

enabled module.
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Chapter 2: Using the Web Workgroup
Server Administration Tool

As Workgroup Server administrator, you

use the browser-based Administration

tool to manage the Adobe Web

Workgroup Server and the Web sites stored on it.

Tasks include adding users, setting access privi-

leges, and creating and maintaining Web sites.

Administering the Workgroup

Once the Adobe Web Workgroup Server is
installed, a member of the workgroup designated

as Workgroup Server administrator uses the

browser-based Administration tool (or

Workgroup Admin) to manage the Server on an

ongoing basis. As administrator, you run the
Workgroup Admin by launching a standard Web

browser and pointing it at the IP address of the

computer running the Server. After connecting,

you can use the Workgroup Admin's main menu

to perform the following tasks:

Create Users   Create a user account for each

member of the workgroup, and assign each

member an access level: Administrator or User.

Administrators can create sites using the

Workgroup Admin or GoLive, and also have the

ability to set their own access privileges to

workgroup sites. Users can create workgroup sites

using GoLive, but can't use the Workgroup Admin

and must be assigned access to any sites they don't

create themselves.

Create sites As an alternative to the GoLive site

wizard, use the Workgroup Admin site wizard to

create workgroup sites directly on the Workgroup

Server. You can create a new, blank site, import an

existing site or files from a local computer or an

FTP Web server, or create a site based on a GoLive
template. During site creation, you define one or

more FTP publishing servers for the site. FTP

publishing servers defined with the Workgroup

Admin show up by default in GoLive's site settings,

making it easy to coordinate publishing for the

entire workgroup.

Manage sites While the workgroup site is under

development, use the Workgroup Admin to make

site backups or to copy or delete sites on the Server.

Add new users to a site or change site access as

needed. Use the Reset Locks feature to free up any

checked-out files needed for editing by another

member of the workgroup.

Publishing sites You can publish workgroup sites
using the Workgroup Admin or from within
GoLive. Publishing from the Workgroup Admin
lets you define a new publishing server during the

publishing operation. You can also use the Site
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Clean Up feature to prepare a workgroup site for

publication, streamlining the site and eliminating

unused files. Use the Workgroup Admin to view

and store Publish Reports, which detail any errors

encountered while publishing.

System administration As server administrator,

use the Workgroup Admin to monitor the opera-

tions of the Workgroup Server. Configure the Log

File to report different levels of information about

server operations.

Installing, Starting up, and
shutting down the Workgroup
Server
For instructions on installing the Workgroup

Server, see the HowToInstall file on the Adobe Web

Workgroup Server CD. The Workgroup Server is

automatically started after you install it. After

installation, you can use the Web Workgroup

Server Monitor application, installed along with

the Workgroup Server, to shut the Server down or

to start it if it is stopped. Once the Server is started,

you can use the Server Monitor to get status infor-

mation on Server operation.

To start the Workgroup Server Monitor application:

• In Windows, choose Start > Programs > Adobe

Web Workgroup Server 1.0 > Server Monitor.

• In Mac OS, double-click the Workgroup Server

Monitor alias on your desktop (created during

installation).

The status field at the top of the Server Monitor

window displays information about the current

server status. Use the options in the Server

Monitor window as follows:

• Start or Stop to start or shut down the server,

respectively.

• Refresh to verify that the Server status is

showing the current condition of the server.

• Hide to minimize the Server Monitor to an icon

displayed in the Notification Area at the bottom

right corner of your screen (Windows). CHck

the Minimize button (Mac OS) to minimize the

Server Monitor to an icon in the Mac OS X's

Dock at the edge of your screen. To maximize

the Server Monitor, click the icon in the Notifi-

cation Area (Windows) or Dock area (Mac OS).

• Exit to close the Server Monitor application.

You can also choose File > Exit.

9   From within the Server Monitor window, you
can open the Workgroup Admin by choosing

File > Open Workgroup Administration.

To start the Workgroup Server:

1 Start the Workgroup Server Monitor appli-
cation, if it is not running.

2 If necessary, maximize the Workgroup Server

Monitor window by clicking its icon displa)'ed in

the Notification Area (Windows) or Dock area

(Mac OS).

3 In the Workgroup Server Monitor window,

click the Start button.
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To shut down the Workgroup Server:

1 If necessary, maximize the Workgroup Server

Monitor window by clicking its icon displayed in

the Notification Area (Windows) or Dock area

(Mac OS).

2 In the Workgroup Server Monitor window,

click the Stop button.

Note: If the Workgroup Server is stopped, it will

restart when you restart your computer. To prevent

the Server from restarting, you must use the installer

to remove the associated service (Windows), or

remove the Server entry in the Startupltems

(Mac OS).

Connecting to the Workgroup
Server
When the Workgroup Server is running on its host

computer, you can log into it from any location

using a Web browser. You can initially connect to

the server using a default user account created

when the server is installed. Once connected, you

can create new user accounts as needed.

Preparing to connect for the first time

You administer the Workgroup Server through a

standard Web browser, such as Netscape Navigator

or Internet Explorer (versions 4.5 or later). You

can access the server from the computer it is

installed on or from another computer. Before

trying to log in for the first time, make sure the

following tasks have been completed:

• The Workgroup Server has been installed and

started on the host computer.

• You know the IP address of the host computer

(the computer that the Workgroup Server is

installed on).

About installed accounts

Any user with administrative privileges can log

into the Workgroup Server. Two users with admin-
istrative privileges are created when you install the

Workgroup Server: system and admin (with

matching passwords). You cannot delete the

system account or change its access privileges.

Note: When the Workgroup Server starts for the first

time, you are prompted to change the default

password for the System user account—"system"—
to a different password.

You can start using the Workgroup Admin as

either the system or admin user, and later create

additional users according to your needs. You can

also create new user accounts by using the Setup

Wizard, available from the home screen when the

Workgroup Admin first opens.

To connect to the Workgroup Server and log in:

1   Do one of the following:

• If the Workgroup server is installed on your

computer, use the Server monitor to launch the

Workgroup Admin (File > Open Workgroup

Administration).
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• If you're connecting from a different computer,

launch your browser. In the Location

(Netscape) or Address (Internet Explorer) text

box, type http://, followed by the IP address of

the computer that the Workgroup Server is

running on, followed by :http port number/.

The default port number is 1102. Press Return

to connect.

Note: If you are connecting to the Workgroup Server

via a browser from the computer the server is

running on, you can also use

http://localhost: 1102/ as an address.

The Web Workgroup Server Administration

window displays a Login section and two URLs:

the GoLive URL and the WebDAV URL.

• Use the GoLive URL when creating or

mounting (opening for the first time) a

workgroup site from within GoLive. GoLive

prompts you to enter this URL (and a user name

and password) to access the Workgroup Server.

• Use the WebDAV URL when opening and

editing Workgroup Server files with a WebDAV-
compatible client such as Photoshop or

Illustrator.

2  In the Login section, enter a user name and

password, and then click Log In.

After login, the navigation pane at the left side of

the window contains buttons for the main tasks

you can perform with the Workgroup Admin.

Navigating in the Workgroup Admin

The Workgroup Admin navigation pane is always

available. Click on a button in the pane to link to

the main screen for that administrative task. Once

you have navigated down one or more levels

within a particular subsection, you can return to

the main screen for that section by clicking on the

button for that task in the navigation pane. To

return to the main Workgroup Admin screen, click

on Home at the top right of all screens.

-;^'[Âdobe Web Wofkgioi^ Server Adminnlfatjon - Netscape

File    Edi!    -lev.     3;.    :c--...':5-y    -e;
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Creating and managing user

accounts
Each workgroup member needs a user account to

access Web sites that are stored on the Workgroup

Server. As server administrator, you're responsible

for creating user accounts and granting users

access to Web sites stored on the Workgroup

Server. You must also decide whether to grant

users administrator privileges. A user without

administrator privileges cannot use the

Workgroup Admin but can be granted access to

edit sites stored on the server and can create new

sites using GoLive.

About the Users screen

Click on the Users button in the Workgroup

Admin navigation pane to display the Users

screen. The Users screen lists all user accounts

stored on the Workgroup Server, and displays the

login name for each user, whether the user has

administrative privileges, and when the account

was last modified. From the Users screen, you can

create a new user, edit a user account, or delete

a user.

To edit a user account:

Click the Edit button 0 next to a user name, or

click the user name, to display the Edit User screen.

To create a new user:

Click the New User link in the Workgroup Admin

navigation pane.

To delete a user:

Click the Delete User button §] to the right of the

user account information.

Creating new user accounts

A user account includes a user name and

password, optional information to identifv' the

user, and a privileges level. You can enable a new

account for immediate login or activate the

account at a later time.

To create a new user account:

1 Log in using an existing administrator account,

as described in "About installed accounts" on

page 29.

2 In the Workgroup Admin navigation pane,

click Users.

The User List displays all user accounts currently
stored in the Workgroup Server database.

3 In the navigation pane, under Users, click the

New User link.

4 Enter user information in the New User screen:

• In the Full Name, Phone, and E-Mail text boxes,

enter the relevant information for the new user.

• In the Info text box, enter any additional user

information needed.

• In the Login Name and Password text boxes,

enter the name and password the user will enter

when logging into the Workgroup Admin.

• In the Verify Password text box, enter the user's

password a second time to have your entry

checked by the system.
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• Select the Login enabled option to enable the

user to log in immediately.

• Select Administrator to assign administrator

privileges to the user. Administrator privileges

allow the user to log into the Workgroup

Admin.

5 Click Save. The new user is immediately added

to the User List.

Note: New users don't have access to existing Web

sites stored on the Workgroup Server. You must

explicitly add a new user to any site you want that

user to have access to. (See "Changing a site's

assigned users" on page 37.) All users have

automatic access to sites that they create.

Editing user accounts

After creating a user account, you can edit the user

information at any time, including changing the

user name and password. For instructions on

adding or removing access to specific workgroup
sites, see "Changing a user's site access" on

page 32.

To edit a user account:

1 In the Workgroup Admin navigation pane, click

the Users button.

2 In the User List, click the Edit button @ next

to the user account you want to edit, or click the

user name.

3 In the top section of the Edit User screen, use
the options provided to change user privileges,
disable or enable user login, or change personal
user data.

4 When you are done editing, click Save.

Changing a user's site access

Use the Assigned Sites section of the Edit User

screen to control which workgroup sites a user has

access to.

Note: You can also use the Assigned Users section of

the Edit Site screen to control user access to a site. See

"Changing a site's assigned users" on page 37.

To change the user's site access rights:

1 In the Workgroup Admin navigation pane, click

the Users button.

2 In the User List, click the Edit button [2] next

to the user account you want to edit, or click the

user name.

The Assigned Sites section lists all sites currently

stored in the Workgroup Server database. A check

mark next to a site name indicates that site access

is enabled.

3 Select a check box next to a site to enable access,

and deselect a check box to deny access. To enable

or deny access to all sites, click the Select

All/Deselect All toggle button at the bottom of

the list.

4 Click Save.

Deleting a user account

The server administrator can delete a user account

from the User List at any time.

If you want to disable a user account without
deleting it, deselect the Login enabled check box

in the top section of the Edit User screen (see "Editing
user accounts" on page 32).
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To delete a user account:

1 In the Workgroup Admin navigation pane, click

the Users button.

2 In the User List, click the Delete button g] to

the right of the user account you want to delete.

3 On the Delete screen, click Delete to remove the

user account.

Creating sites

You can create workgroup sites using the
Workgroup Admin or from within GoLive. As

with a regular single-user site, a workgroup site

contains a root folder, settings and data folders,

and a site project file. The site folders and contents

are stored in the Workgroup Server database,

centralizing GoLive's site management features to
facilitate workgroup collaboration. Once you

create a site, workgroup members can connect to
it from GoLive or a from a supported WebDAV-

compatible client such as Adobe Photoshop or

Adobe Illustrator.

The URL needed to connect to the Workgroup
server from a WebDAV client such as Photoshop

or Illustrator is displayed on the Workgroup Admin

login screen.

A site wizard guides you through the site creation

process. The wizard offers four site creation

options:

• Blank Site creates an empty folder structure and

a new site project file on the Workgroup Server.

• Import from folder converts an existing Web

site (GoLive or non-GoLive) to a GoLive

workgroup site, or if you have a local folder of

resource files that you want to convert to the

root folder of a new site.

• Import from FTP server imports an existing
Web site (GoLive or non-GoLive) from its

location on a Web server. The site is copied in its

entirety to the Workgroup Server.

• Copy from template creates a workgroup site
based on one of the GoLive Web site templates.

Creating a blank site

The Blank Site option in the site wizard creates

root, data, and settings folders, a site project file,

and a generic home page on the Workgroup

Server.

To create a new blank site:

1 Log into the Workgroup Admin.

2 In the Workgroup Admin navigation pane, click
Sites to bring up the Site list.

3 In the Workgroup Admin navigation pane, click

New Site to bring up the Site Wizard.

4 In the Site Wizard, select Blank Site, and

click Next.

5 In the Site Name text box, enter the name for

the new, blank site you want to create, and

click Next.

At this point you can set up a publishing server for

the new site (you can also set up a publishing

server later). This is the server where you will move

the site when you are ready to make it public.
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Note: You can set up more than one publishing
server per site. You may want to specif}' different
locations for archiving, staging, and final publi-

cation. For information on assigning additional
servers, see "Defining a publishing server" on

page 42.

6 In the Server Name text box, enter the name of

the pubHshing server.

7 Select the Default Server option if you want the

server to be used as the default publishing server. If

you specifv' a default FTP publishing ser\'er in the

Workgroup Admin, the server will also be prese-

lected in the Workgroup Site Settings in GoLive.

This allows any workgroup member using the

client to publish the site to this ser\'er without

making any additional changes to the site settings.

Note: A publishing server must he an FTP server to
be the default publishing server in GoLive.

8 Choose a Protocol to access the server.

Depending on whether your publish folder is

accessible via FTP or the file system of the

computer the Workgroup Server is running on, do

one of the following:

• Choose File when your publish folder is a local

folder on the computer the Workgroup Server is

running on, or resides on a disk accessible from

the server computer. In the Location text box,

enter the complete path to the publish folder:

/volume/folder/publishfolder (Mac OS), or

<drive>:\folder publishfolder (Windows).

• Choose FTP if your publish folder is on an FTP

server. Use the Host, Directory, User, Password,

and Server Port text boxes to enter the data

required to connect to the FTP server. For Host,

enter the FTP address specified by your ISP for

the FTP server you want to publish the site on.

In the Directory text box, type the directory

path to the publish folder. If required, use the

Server Port text box to specifv' the port number

value. FTP service is always initiated from a

client to a server via port 2 1. All FTP servers, by

default, expect to connect back via that port.

However, some FTP servers might be

configured to Hsten on a different port. In that

case, you need to enter a different port value.

Select the Use Proxy option if your network

requires that you connect via a prox)' server for

filtering or security- reasons. The proxy port

used is specified in the Preferences dialog box

(see "Setting Workgroup Server preferences" on

page 46). Select Use Passive Mode if you need to

go through a firewall or are having other

problems connecting to an FTP server. This

initiates a connection from GoLive to the server

rather than requesting that the server connect

back to you, which is the default behavior. If you

have specified a server port other than 21,

always select Use Passive Mode.

9 Click Next.

10 To define additional publishing servers, click

Yes. To complete the wizard, click Finish.

1 1 Click OK to finish creating the site.
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The new site is stored on the Workgroup Server. To

add info text, change site access privileges, or

change pubHsh server definitions for the site, click

either the Edit button next to the site name, or the

site name.

Importing sites

Instead of creating a new Web site from scratch,

you can import an existing site. The site can be

located either in a folder on the computer the

Workgroup Server is running on or a folder on an

FTP server. In either case, the imported site will be

stored on the Workgroup Server after import.

To import a site from a local folder:

1 In the Workgroup Admin navigation pane, click

Sites to bring up the Site list.

2 In the Workgroup Admin navigation pane, click

New Site to bring up the Site Wizard.

3 In the Site Wizard, choose Import from Folder,

and click Next.

4 In the Site Name text box, enter the name you

want to assign to the new site.

5 In the Local Path text box, enter the complete

path to the root folder of the site you want to

import.

6 Specify URL handling settings for the new site:

• Select Check URLs case-sensitive to observe

case sensitivity in URLs.

• Select a URL handling method, either UTF-8 or

ISO 8839-1.

• Select %HH-Escaping to comply with the URL

syntax which requires that all non-safe

characters be encoded as a % symbol followed

by two hexadecimal digits.

Note: To maintain the same URL handling that was

in effect for the site you re importing, accept the

default settings here. For more information on URL
handling settings, see GoLive Help.

7 Click Next.

8 Use the options provided on the Publish Server

screen to define publishing servers for the site you

are importing. (See steps 6 through 10 in

"Creating a blank site" on page 33.)

9 Click OK to finish creating the site.

The imported site is stored on the Workgroup

Server. To add info text, change site access privi-
leges, or change publish server definitions for the

site, click either the Edit button displayed next to

the site name, or the site name.

To import a site from an FTP server:

1 In the Workgroup Admin navigation pane, click

Sites to bring up the Site list.

2 In the Workgroup Admin navigation pane, click

New Site to bring up the Site Wizard.

3 In the Site Wizard, choose Import from FTP

Server, and click Next.

4 In the Site Name text box, enter a name for the

new site you are creating.



36 CHAPTER 2

Using the Web Workgroup Server Administration Tool

5 Specify the FTP sender data as follows:

• In the Server text box, enter the FTP address

specified by your ISP for the FTP server from

which you want to import the site.

• In the Directory text box, t\-pe in the path to the

folder where the site is located.

• In the User text box, t)"pe in your user ID for

FTP access.

• In the Password text box, enter your personal

password for FTP access.

• In the Server Port text box, specify the server

port number. FTP service is ahvays initiated

from a client to a server via port 21. ^\11 FTP

ser\'ers, by default, expect to connect back via

that port. However, some FTP servers might be

configured to listen on a different port. In that

case, you need to enter a different port value.

• Select the Use Passive Mode option to initiate a

connection from the client to the FTP server.

This overrides the default behavior, which is

that the server connects back to the cUent. If you

have specified a serv'er port other than 2 1,

always select the Use Passive Mode option.

6 Specify URL handling settings for the new site:

• Select Check URLs case-sensitive to observe

case sensitivit)' in URLs.

• Select a URL handling method, either UTF-8 or

ISO 8859-1.

• Select %HH-Escaping to comply with the URL

sratax which requires that all non-safe

characters be encoded as a % symbol followed

by tvvo hexadecimal digits.

Note: To maintain the same URL handling that was
in effect for the site you re importing, accept the
default settings here. For more information on URL
handling settings, see GoLive Help.

7 Click Next.

8 On the Publish Server screen, define publishing

servers for the site you are importing. (See steps 6

through 10 in "Creating a blank site" on page 33.)

9 Click OK to finish creating the site.

The imported site is stored on the Workgroup

Server. To add info text, change site access privi-

leges, or change publish server definitions for the

site, click either the Edit button next to the site

name, or the site name.

Creating a site by copying a site template

You can also create a new site by copying one of the

site templates provided with GoLive. You can view
a site template by opening its site project file in

GoLive. The templates are located in the Site
Templates folder, inside the GoLive 6.0 folder.

To create a site by copying a site template:

1 In the Workgroup Admin navigation pane, click

Sites to bring up the Site list.

2 In the Workgroup Admin navigation pane, click

New Site to bring up the Site Wizard.

3 In the Site Wizard, choose Copy ft^om Template,

and click Next.

4 In the Site Name text box, enter the name for

the new site.

5 From the Site Template list, choose the desired

site, and click Next.
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6 Use the options provided on the Publish Server

screen to select publishing servers for the site you

are importing. (See steps 6 through 10 in
"Creating a blank site" on page 33.)

The Finish Site Creation screen informs you that

the site has successfully been created on the server.

7 Click OK.

To add info text, change site access privileges, or

change publish server definitions for the site, click

either the Edit button next to the site name, or the

site name.

Editing sites
Use the Workgroup Admin's Edit Site screen to

edit site information. You can enable or revoke

access to the site for members of the workgroup,

edit publishing servers assigned to the site, or add

a new publishing server. To display the Edit Site

screen, click on a site name in the Sites screen.

Editing site information

The top section of the Edit Site screen displays the

site name and Site Info text box, which you can use

to enter descriptive information about the site.

The Site Info entered here displays next to the site

name on the Sites screen.

To enter descriptive information about the site for the

Sites screen:

1 Type information into the Site Info text box.

2 Click Save.

Changing a site's assigned users

Initially, only the user who created a site has access

to the site. To grant access to other users, you need

to add them to the list of authorized users for the

site. (You can also grant access by editing the user's

account information. See "Editing user accounts"

on page 32.)

To enable site access for an existing user:

1 In the Workgroup Admin navigation pane,

click Sites.

2 On the Site List screen, click the Edit Site

button [^ next to the site you want to give the user

access to, or click the site name.

The Assigned Users section of the Edit Site screen

lists all user accounts stored in the Workgroup

Server database (except the default System

account) . A selected check box indicates that a user

has access to the site.

3 Select the check box next to the user to enable

site access. Click Select All to enable site access for

all workgroup members.

4 Click Save.

/^   To add a new user to the workgroup, click the

W   New User button below the Assigned Users list.

(See "Creating and managing user accounts" on

page 31.)

Revoking site access

You can easily revoke access to a particular site by
editing the list of approved users for that site.
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To disable site access for a user:

1 In the Workgroup Admin navigation pane,

cliclc Sites.

2 In the Site List, click the Edit Site button [21

next to the site to which you want to limit access,

or click the site name.

The Assigned Users section of the Edit Site screen

lists all user accounts stored in the Workgroup

Server database. A selected check box indicates

that a user has access to the site.

3 Deselect the check box next to the user to v^hom

you want to deny site access. Click Deselect All to

revoke site access for all workgroup members.

4 Click Save.

Editing publishing servers

The Publish Serv^ers section of the Edit Site screen

displays all publishing servers you've set up for the

site. You can edit an existing server, add a new

server, or delete a server.

To edit settings for an existing publishing server:

Click the Edit Publish Server button, or the

server name.

To define a new publishing server:

Click the New Publish Server link in the

Workgroup Admin navigation pane.

To delete a publishing server:

Click the Delete button to the right of the

server name.

Managing sites

The Workgroup Admin's Sites screen is the starting

point for site management options. To display the

Sites screen, click on the Sites button in the

Workgroup Admin navigation pane.

Using the Sites screen

The Sites screen lists all sites stored on the

Workgroup Server. The Info field contains

descriptive information about the site. The Last

Modified field tells you which member of the

workgroup last made changes to the site,

and when.

From the Sites screen, select a button to back up,

duplicate, or delete a site, or to edit site infor-

mation. You can also clean up a site before

publishing it.
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To edit the text in the Info field:

Click on the Edit Site button to the left of the site

name, and then enter information in the Site Info

text box on the Edit Site screen.

To duplicate, back up, delete, or clean up a site:

Click on the appropriate button next to the

site name.

To create a new site or view a list of site backups:

Click on the appropriate links in the Workgroup

Admin navigation pane at the left of the screen.

Backing up sites

You can use the Workgroup Admin to create a site

backup that stores all the information that makes

up a site. Site backups are stored on the server's file

system. You can use the Workgroup Admin to
easily restore your site with these backups. They

also provide a complete record of how a site looked

on a specific date. For example, you may want to

try out a new structure and look for a site. With

backups you can easily return to the old version.

To create a site backup:

1 In the Workgroup Admin navigation pane, click
the Sites button.

2 In the Site List, click the Create Site Backup

button [Sj next to the site you want to

back up.

3 On the Backup Site screen, enter backup infor-

mation into the text box as needed. (Entering
information is optional.)

4 Click Save.

A message on the Backup Site screen informs you
that the backup has been successfully created.

5 Click OK.

The Site Backups screen shows the backup you just

created and any other backups that are currently

stored on the server's file system, along with the

creation time and date of each backup.

Restoring or deleting a backed-up site

You can use the Workgroup Admin to restore or
delete a backed-up site.

To restore a backed-up site:

1 In the Workgroup Admin navigation pane, click

the Sites button.

2 Click the Site Backups link in the navigation

pane.

3 In the Site Backups list, locate the backup you

want to restore, and then click the Restore Site
Backup button [5 next to it.

4 On the Restore Site Backup screen, enter a new

site name in the Site Name text box (a default

name is filled in — the original site name followed

by "backup"). You must enter a unique name that

is not yet assigned to a site stored on the database.

5 Click Restore.

Note: If you haven't assigned a unique site name, an

error message indicates that the site name is

currently in use. Click OK to return to the Restore

Site Backup screen; then enter a unique name and
click Restore.
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The restored site is stored in the Workgroup Server

database and appears in the Site list. If you want to

remove the old, possibly corrupted site, you need

to delete it from the server. (See "Deleting sites" on

page 40.) Removing a site doesn't automatically

remove its backups.

To delete a site backup:

1 In the Workgroup Admin navigation pane, click

the Sites button.

2 Click the Site Backups link in the navigation

pane.

3 In the Site Backup List, locate the backup you

want to delete, and click the Delete button [S] next

to it.

4 On the Delete Site Backup screen, chck Delete.

Note: Site backups are stored in the sitebackup
folder, inside the wgdata folder on the volume or
drive where the Workgroup Server is installed.

Deleting sites

Deleting a site removes all its site files from the

Workgroup Server. It does not delete any site

backups you may have made of the site. (See

"Restoring or deleting a backed-up site" on

page 39.)

To delete a site:

1 In the Workgroup Admin navigation pane,
click Sites.

2 In the Site List, click the Delete button jS] next

to the site vou want to remove.

Duplicating sites

Duplicating a site is a quick, convenient way to

make an editable copy of the site (a site backup

cannot be edited —you must restore a site backup

before it is editable). A duplicated site appears in

the site list along with the original site, under a

different name.

To duplicate a site:

1 In the Workgroup Admin navigation pane,

click Sites.

2 In the Site List, click the Duplicate Site
button [§i next to the site you want to duplicate.

3 In the Site Name text box, enter the name you

want to assign to the copied site. If you don't

specify a new name, the application will use the
current name and add "copy." For example, if the

original site name is "velocitygames", the copy will

be named "velocitygames copy".

4 If desired, enter descriptive text in the Site Info

text box.

5 Click Save. A copy of the site is stored on the

Workgroup Server and appears in the Site list.

Note: Assigned users are not duplicated with a site.

You must reassign users to the duplicated site as

needed (see "Changing a site's assigned users" on

page 37).

3 Click Delete.



ADOBE WEB WORKGROUP SERVER

User Guide

41

Cleaning up a site

Before publishing a site, you can perform a site

cleanup. (Cleaning up a site gets rid of unused links,

colors, e-mail addresses, and font sets that are

cluttering up the site, and moves stray files into the

root folder for better organization. You can choose

any combination of the following cleanup options:

• Copy files that are used in the site, including

Web pages, images, and media files, into the

site's root folder. {Used means "referenced on

some page in the root folder.")

• Add references (for example, URLs and e-mail

addresses), colors, and font sets that are used in

the site to the External, Colors, and Font Sets

tabs of the site window.

• Remove any files that are not referenced on any

page in the root folder.

You can perform a site cleanup using the

Workgroup Admin or from within GoLive.

To clean up a site:

1 In the Workgroup Admin navigation pane, click

the Sites button.

2 In the Site list, click the Clean Up Site button 0

next to the site you want to clean up.

3 On the Clean Up Site screen, use the following

options as needed:

• Rescan Root Folder updates the site project file

if you have added or removed files or iolders

from the site from outside of GoLive— for

example, if you've used Windows Explorer
or the Finder to add or delete files (not

recommended).

• Add Used Files copies all orphan files (refer-

enced files outside the site root folder) into the

site root folder.

• Add External References copies all external

references — e-mail addresses and URLs — used

on pages in the site to the External tab of the site

window.

• Add Colors copies all colors used on pages in the

site to the Colors tab of the site window.

• Add Font Sets copies all font sets used in the site

to the Font Sets tab of the site window.

• Remove Unreferenced Files moves all excess,

unreferenced files to the site trash.

• Remove Unused External References/Colors/

Fontsets removes unused non-file objects from

the External, Colors, and Font Sets tab of the site

window, respectively.

4 Choose Clean Up.

Publishing sites

Publishing a workgroup site means moving it from

the Workgroup Server to another server— for

example, for staging, archiving, or live publishing.

You can publish sites using the Workgroup Admin

or from within (KiLive. When you create a site

using the Workgroup Admin, you can set up a

publishing server at the time you create the site.

When you're ready to publish, you can use that

server as a target or define a different server.
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When publishing the site, you need to specify
pubHshing conditions. You can set pubHsh condi-

tions in both the Workgroup Admin and GoLive.

In GoLive, you set publishing conditions in the

Site Settings dialog box, which is accessible from

the Site menu. When you publish using the
Workgroup Admin, you specify publishing condi-

tions during the publishing process. The condi-

tions you specif}' in the Workgroup Admin for a

single publishing process take precedence over the

publishing settings made in GoLive.

Defining a publishing server

If you didn't set up a publishing server when you

created your site, you can do so using the Edit site

screen. You can also change your publishing server

at any time even if you already have one set up for

your site.

To add a publishing server to a site from the

Edit Site screen:

1 In the Workgroup Admin navigation pane, click

the Sites button.

2 In the Site List, click the Edit Site button (2

next to the site you want to define a publishing

server for, or click the site name.

The Edit Site screen displays the assigned users and
publishing servers for the site.

3 In the navigation pane, under Sites, click the

New Publish Server link.

4 In the Server Name text box, enter the name of

the publishing server. Use a descriptive name, such

as "Staging" or "Live" so that team members can

easily identify the function of the server.

5 Select the Default Server option if you want the

server to be used as the default publishing server. If

you specify a default Fl P publishing server in the

Workgroup Admin, the server will also be prese-

lected in the Workgroup Site Settings in GoLive.

This allows a workgroup member using the client

to publish the site to this server without making

any additional changes to the site settings.

Note: A publishing server must be an FTP server to

be the default pubUshing server in GoLive.

6 Choose a Protocol to access the server.

Depending on whether your publish folder is

accessible via FTP or the file system of the

computer the Workgroup Server is running on, do

one of the following:

• Choose File when your publish folder is a local

folder on the computer the Workgroup Server is

running on, or resides on a disk accessible from

the server computer. In the Location text box,

enter the complete path to the publish folder:

/volume/folder/publishfolder (Mac OS), or

<drive>:\folder\publishfolder (Windows).

• Choose FTP if your publish folder is on an FTP

server. Use the Host, Directory, User, Password,

and Server Port text boxes to enter the data

required to connect to the FTP server. For Host,

enter the FTP address specified by your ISP for

the FTP server you want to publish the site on.

In the Directory text box, type in the directory

path to the publish folder. If required, use the

Server Port text box to specify the port number

value. FTP service is always initiated from a

client to a server via port 2 1. All FTP servers, by

default, expect to connect back via that port.

However, some FTP servers might be
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configured to listen on a different port. In that

case, you need to enter a different port value.

Select the Use Proxy option if your network

requires that you connect via a proxy server for

filtering or security reasons. The proxy port

used is specified in the Workgroup Admin

preferences. (See "Setting Workgroup Server

preferences" on page 46.) Select Use Passive

Mode if you need to go through a firewall or are

having other problems connecting to an FTP

server. This initiates a connection from GoLive

to the server rather than requesting that the

server connect back to you, which is the default

behavior. If you have specified a server port

other than 2 1, always select Use Passive Mode.

7 Click Save. The publishing server now appears

in the Publish Servers section in the lower right

corner of the Edit Site screen.

Editing or deleting a publishing server

You can use the Workgroup Admin to edit

attributes for a publishing server or to delete

a server.

To edit attributes for a publishing server or to

delete a server:

1 In the Workgroup Admin navigation pane,

click Sites.

2 In the Site List, click the Edit Site button 0

next to the site whose server definition you want to

edit or delete, or click the site name.

The Edit Site screen displays the defined

publishing servers in the lower right corner.

3  Locate the publishing server you want to edit

or delete.

• To change server attributes, click the Edit

button next to the server. On the Edit Publish

Server screen, make the desired changes.

• To delete a server, click the Delete button next to

the server. On the Delete screen, click Delete.

Publishing a site using the

Workgroup Admin

You can publish a site using the Workgroup Admin

or from within GoLive. For information on

publishing from within GoLive, see "Publishing

workgroup sites" on page 20.

To publish a site using the Workgroup Admin:

1 Log into the Workgroup Admin.

2 In the Workgroup Admin navigation pane, click

the Publishing button.

3 On the Publish Site screen, select the site you

want to publish from the pop-up menu.

4 Click OK.

5 Choose the target publishing server from the

Server Name pop-up menu. The pop-up menu
provides a list of all currently stored publish server

definitions available for the site. Select New Server
to define a new publishing server (see "Defining a

publishing server" on page 42).

After you select or define a server, the Site Specific

Settings screen displays options that control how
the site is published.
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6  Set Publish conditions as follows to control

which files and folders get uploaded to the

publishing server:

• Honor "Publish" state of folders and Honor

"Publish" state of files. All files and folders in the

Web site have a setting called Publish state,

which allows you to control whether or not the

file or folder is uploaded when the site is

published. Possible Publish states for files are If

Referenced (default), Always, and Never.

Publish states for folders are If Not Empty

(default), Always, and Never. The Publish state

for a file or folder is set in GoLive.

Note: The Honor "Publish" state setting is also

available in GoLive (choose Site Settings > Publish).
However, when publishing from the Workgroup

Admin, the Workgroup Admin setting overrides the

GoLive setting.

• Use the Export referenced files only option to

upload only files located in the site's root folder

that are referenced from the home page or a

page linked to the home page. (This option is

enabled only if you haven't checked the Honor

Publish State Of options, which take prece-

dence.)

• Use the Export referenced files that are not part

of the site option to include in the upload refer-

enced files that are outside of the site root folder.

This option also copies these referenced files

into a newly created folder. If you want to

change the folder name, which defaults to

Other, use the text box provided in the

Hierarchy section (the next section of the

screen).

7 Set Hierarchy options to control the underlying
directory structure of your site before uploading to
the publishing server:

• As in Site (default) leaves the current site

structure unchanged.

• Separate Pages and Media creates a root folder

with two subfolders, one for HTML pages and

one for media items. By default, these folders

are called Pages and Media. If you want to

change the default names, use the text boxes.

• Flat creates a root folder containing all HTML

pages and media items, but no subfolders.

8 Set the Strip HTML Code for options to

streamline the code in your pages. Removing these

source code elements will not change the way your

pages display in a browser.

• Adobe GoLive Elements removes GoLive-

specific tags and attributes that are needed to

edit animations, scripted actions, and so forth

in GoLive.

Note: These tags cannot be restored once they are

removed during publishing.

• Spaces removes extra spaces, returns, and

linefeeds that were added to the code for

readability. (HTML doesn't require extra spaces

and linefeeds between items.)

• Comments removes comments you have added

to annotate your pages.
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9 Select the GoLive Data option to check for GIF,

JPEG, PNG, SWF, and SVG files that are targets for

Smart Objects, and remove data that was added to

the files to enable the Smart Object workflow.

Removing this data reduces the size of these files

and also breaks the link with the source file. If you

later edit the source file (for example, a PSD file in

Photoshop), the target GIF or JPEG file will no

longer be updated in GoLive.

10 Set the Publish Mode. By defiuilt, the system

performs an incremental upload. That is, only

those items that were added or changed since the

last publishing process will be uploaded. If you

want the entire site to be uploaded, select

Publish All.

11 GlickOK.

A progress bar indicates that publishing is in

progress. When the process is finished, a publish

report gives you detailed information about the

publishing process and identifies any errors that

have occurred.

12 Click OK.

The publish report is stored in the Workgroup

Server database and appears in a Publish

Reports list.

Using publish reports

Each time you publish a Web site, the Workgroup

Server automatically creates a publish report and

.stores it in the database. The report gives you
detailed information about the publishing process

and helps you locate any errors that have occurred.

Reports are listed in the order they were created,

with the most recent report at the top of the list.

You can view all publish reports, or view only the

reports for a particular site.

To view a publish report:

1 In the Workgroup Admin navigation pane, click

the Publishing button.

2 In the navigation pane, click Publish Reports.

The Publish Reports list shows all reports

currently stored in the database.

3 To view only the publish reports for a particular

site, select the site name in the pop-up menu, and

click Filter.

4 In the Publish Reports list, locate the desired

publish report, and click either the View

button [^ next to it, or the site name.

To delete a publish report:

1 In the Workgroup Admin navigation pane, click
Publishing.

2 In the navigation pane, click Publish Reports.

3 In the Publish Reports list, locate the report you

want to delete, and click the Delete button §] next

to it.

4 On the Delete Publish Report screen,

click Delete.
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Note: GoLive uses the publish reports to detenuiiie
which files to publish during an increnientcil (versus
full-site) publish. If you delete a publish report, all
files reported as published in the report are marked
as changed, and therefore are published again when
you next perform an incremental publish. Deleting
all pubUsh reports for a site will result in all site files

being published (when you next publish).

Setting Workgroup Server
preferences
The Workgroup Admin preferences screen allows

you to customize a number ot Workgroup Server

settings, including the detault port value, FTP

proxy server name, and the type of status infor-

mation recorded in the server log file.

To set Workgroup Server Preferences:

1 In the VVorkgrt)up Admin navigation pane, click

the Preferences button.

2 Set the Server Port and Control Port options:

• The default server port for the Workgroup

Server is 1102. If you do change the server port,

workgroup members must also change the port
when they log into the server to access

workgroup sites.

• The control port is an administrative port used

for server startup and shutdown. The default

control port value is 1103.

3 Set the Log Level option to control what kind of

information is tracked to the server log. The server

log continuously logs all server operations,
including errors, warnings, and informational

messages. Set tracking options as follows:

• Hrror records only errors in the server log.

• Warning tracks errors and warnings.

• Info tracks specific actions that the server is

performing, such as starting and stopping

publishing operations.

Note: The more items the server log tracks, the slower

performance will be.

4 Set the FTP Proxy option if your network

requires that you connect via a proxy server for

filtering or security reasons. Fnter the address and

port numberof the proxy server in the appropriate

text boxes. If in doubt, contact your system admin-

istrator or ISP.

5 Click Save.

Performing System Maintenance
Tasks
Click the Maintenance button in the Workgroup

Admin navigation pane to display the System

Maintenance screen. Click on the available links in

the navigation pane to synchronize the

Workgroup Server database, clean up the file

revision history, or reset user locks.
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Updating sites

Occasionally the Web site content that appears in

GoLivc or in the Workgroup Admin may appear to

be out of sync with the actual content of the

Workgroup Server's file system. This can occur if

site files are deleted, moved, or renamed outside of

GoLive, using the file system of the Workgroup

Server computer (this is not recommended). You

can correct any mismatches by updating the site.

This synchronizes the content of the Workgroup

Server database with the server computer's

file system.

To update the site:

1 In the Workgroup Admin navigation pane, click

Maintenance.

2 In the navigation pane, click Synchronize Site.

3 In the Synchronize Site screen, use the pop-up

menu to select the site you want to update, and

click OK.

4 C^Iick Synchronize.

Cleaning up the file revision history

Each time a user checks a file into the Workgroup

Server, a file revision is stored on the Workgroup

Server database. This creates a file revision history

that lets you quickly return to any former state of

the file. While a revision history is a useful tool

when you're creating a Web site, an extensive

history can slow the performance of the

Workgroup Server. If po.ssible, you should period-

ically clean up the revision history during devel-

opment to help speed server performance.

To clean up the revision history:

1 In the Workgroup Admin navigation pane, click

Maintenance.

2 In the navigation pane, click Clean Up

Revisions.

3 On the (^lean Up Revisions screen, use the site

selection pop- up menu to select the site whose

revision history you want to clean up.

4 Choose one or both of the following options to

clean up revisions:

• Select Delete All Revisions Older Than, and

then use the Month, Day, and Year pop-up

menus to specify the date after which you want

to retain revisions. Any revision that was created

earlier will be deleted.

• Select Number Of Revisions To Keep, and enter

the maximum number ot revisions to be kep in

the text box. The most recent revisions will be

retained. For example, enter 200 to keep the last

200 revisions created.

5 Click Delete.

Resetting user locks

If a checked-out file needs to be edited or

published and the workgroup member who

checked out the file is unavailable, the server

administrator can reset locks for the user who has

the file checked out. This restores any files checked

out by that user to their original unchecked-out

state on the server (changes made to the file after it

was last checked out will be wiped out when the

lock is reset ). The files are then available for editing

or publishing by other woi kgroup members.
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Note: Files locked by the System user—the default

administrator account installed with the Workgroup

Server—can only he reset by System.

To reset the lock state of files currently checked out by

a user:

1 In the Workgroup Admin navigation pane, click

Maintenance.

2 In the navigation pane, click Reset User Locks.

3 On the Reset User Locks screen, select the user

whose locks you want to reset.

4 Click Reset.

Monitoring Workgroup status

The Workgroup Server log file keeps track of all

server operations according to the log level you

have specified in the preferences.

Any user with administrative privileges can view

the log file. To view the file, click Log File in the

Workgroup Admin navigation pane.

The log file can record different types of infor-

mation, depending on your Log Level settings on
the Preferences screen (see "Setting Workgroup

Server preferences" on page 46).

Note: Display time may vary depending on the size

of the log file. The default log file size is 32K, but you

can set a larger size during a Custom installation. If

the log file exceeds its size limit, the system creates a

new log file and saves the old one. The current log file

displayed in the Workgroup Adttun is contact.log.

Log files are saved in the logs directory, located in the
Adobe Web Workgroup Server folder (Mac OS) or

the Web Workgroup Server directory (Windows).
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