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LICENSE AGREEMENT
THIS IS A CONTRACT.  BY OPENING ANY OF THE SEALED 
SOFTWARE CONTAINERS, YOU ACCEPT ALL THE TERMS 
AND CONDITIONS OF THIS AGREEMENT. If you do not 
agree with the terms and conditions of this Agreement, return 
this entire package and the UNOPENED software containers 
to your place of purchase for a full refund.

1. Definitions
(a) “Deneba” means Deneba Systems, Inc., a Florida 
Corporation d/b/a Deneba Software.
(b) “Software” means the software programs included in 
this package.
(c) “Product” means all Software, manuals and other 
related documentation included in this package as well as all 
future related updates supplied by Deneba.
2. License – Deneba grants to you and you hereby 
accept a license to use the Product and all related materials 
delivered with this AGREEMENT as follows:
(a) The Software may be installed in one computer and 
may be used by more than one person on that computer; 
however, in no event shall two or more persons use the Soft-
ware at the same time. This restriction applies regardless of 
how many language versions (e.g. English, German) or media 
copies (e.g. diskette or CD-ROM) may be included in this 
Product.
(b) You may make one copy of the Software in machine-
readable form for archival backup purposes only. As an 
express condition of this allowance you must reproduce on 
each backup copy any copyright notice or other proprietary 
notice that is on the original copy supplied by Deneba.
(c) You may transfer the entire Product and all rights 
granted herein on a permanent basis provided you retain no 
copies, the recipient agrees to the terms of this Agreement, 
and you notify Deneba in writing of the transfer of ownership.
3. Restrictions
(a) You may not make or distribute copies of the Product. 
You should be aware that it is unlawful to copy, reproduce, or 
transmit any part of the Product in any form or by any means 
(including translation to another language, computer lan-
guage, or format) except as permitted by the Copyright Act of 
the United States (Title 17, United States Code). You are per-
mitted to write the contents of the Software into the machine 
memory of your computer so that the software can be execut-
ed.
(b) You may not install this program on a network server 
nor lend usage of a copy of this software with metering soft-
ware. These types of usage require a special license, unless a 
copy of this software is owned for each user on that network 
or each computer connected to that network. For information 
on this expanded license usage see section 4, Supplementary 
Licenses in this agreement.
(c) In order to protect Deneba trade secrets contained 
therein which may be revealed by such action, you may not 
reverse engineer, decompile, disassemble or otherwise 
reduce the Software to any human readable or perceivable 
form.
(d) You may not modify, rent, resell for profit, distribute or 
create derivative works based on the Software or any part 
thereof.



 

(e) You agree not to export or reexport the Product into 
any country prohibited by the United States Export Adminis-
tration Act.
4. Supplementary Licenses – If you wish to enter into a 
site license, network license or concurrent-use license agree-
ment please contact Deneba.
5. Termination – Any failure to comply with the terms 
and conditions of this Agreement will result in automatic ter-
mination of this license. Upon termination of this license for 
any reason, you agree to destroy all copies of the Product.
6. Software Updates – Deneba may from time to time, at 
its own discretion, provide you with updates to the manuals 
and/or Software. Deneba reserves the right to provide these 
updates for a fee. You may refuse to accept the updates. By 
accepting the updates, you agree to destroy all prior copies 
and versions of the Software and manuals (if applicable). Only 
then will the License granted to you by this Agreement trans-
fer to the updated Software.
7. Ownership – This license gives you limited rights to 
use the Software. Although you own the disks and CDs on 
which these are recorded, you do not become owner of the 
Software to which Deneba and/or its licensors retain all title 
to. All rights not specifically granted herein, including but not 
limited to Federal and International Copyrights, are reserved
worldwide by Deneba.
8. Limited Warranty and Disclaimer, Limitation of Reme-
dies and Damages – You hereby acknowledge that you are 
solely responsible for selecting the Product and that the Prod-
uct may not satisfy all your requirements or be free from 
defects. Deneba specifically does not warrant that the Soft-
ware will operate uninterrupted or error free. You therefore 
agree to license the Product “AS IS.” Notwithstanding the 
foregoing, Deneba warrants to you (the original purchaser), 
that if you discover physical defects in the media on which the 
Software is recorded, or in the manuals distributed with the 
Product, Deneba will replace the media or manuals at no 
charge, provided you return the defective items, postage pre-
paid and with proof of purchase, within 90 days of the date of 
original purchase. Your exclusive remedy for breach of warran-
ty will be the replacement of the diskettes, CDs or manuals or 
the refund of the purchase price.
Deneba reserves the right to revise the Product without obli-
gation to notify any person of such revision. In no event shall 
Deneba or its developers, directors, officers, employees or 
affiliates be liable to you for any indirect, special, incidental, or 
consequential damages (including damages for loss of busi-
ness profits or goodwill, business interruption or loss of busi-
ness information), resulting from any defect in the Product 
whether foreseeable or not, arising out of the use or inability 
to use the Product. Deneba’s liability to you or others for actu-
al damages for any cause whatsoever, will in no event exceed 
the lesser of US$500 or the amount paid by you for the Prod-
uct that caused the damages.  In particular, Deneba shall have 
no liability for any data stored in or used with Deneba Prod-
ucts, including the cost of recovering such data.

EXCEPT AS SPECIFICALLY STATED HEREIN, DENEBA 
MAKES NO OTHER WARRANTIES, EXPRESSED OR IMPLIED, 
WITH RESPECT TO THE SOFTWARE, MEDIA, OR MANUALS 
INCLUDING (BUT NOT LIMITED TO) IMPLIED WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE.  THE WARRANTY AND REMEDIES SET FORTH 
ABOVE ARE EXCLUSIVE AND IN LIEU OF ALL OTHERS, 
ORAL OR WRITTEN, EXPRESSED OR IMPLIED. IF APPLICA-
BLE LAW IMPLIES ANY WARRANTIES WITH RESPECT TO 
THE PRODUCT, ALL SUCH WARRANTIES ARE LIMITED TO 
(90) NINETY DAYS FROM THE DATE OF DELIVERY. No 
Deneba dealer, agent, or employee is authorized to make any 
modification, extension, or addition to this warranty.
Some states do not allow limitations on how long an implied 
warranty lasts or the exclusion or limitation of implied warran-
ties or liability for incidental or consequential damages, so the 
above limitation or exclusion may not apply to you.  This war-
ranty gives you specific legal rights and you may also have 
other rights which vary from state to state.
9. U.S. Government Restricted Rights – This Deneba 
Product is “Restricted Computer Software.”  Use, duplication, 
or disclosure by the Government is subject to restrictions as 
set forth in subparagraph (c)(1)(ii) of the Rights in Technical 
Data and Computer Software clause at DFARS 252.227-7013 
or subparagraphs (c)(1) and (2) of the Commercial Computer 
Software - Restricted Rights at 48 CFR 52.227-19, as applica-
ble. The manufacturer is Deneba Systems, Inc., 7400 S.W. 
87th Avenue, Miami, Florida 33173.
10. General – This agreement shall be governed by the 
laws of the State of Florida. This document contains the entire 
agreement between you and Deneba with respect to the sub-
ject matter hereof and supersedes all prior agreements 
between you and Deneba. All questions concerning this 
agreement should be sent to: Deneba Systems, Inc., Attn. 
Chief Financial Officer, 7400 S.W. 87th Avenue, Miami, Florida 
33173.
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INTRODUCTION

Welcome to DENEBACAD, a new perspective for 
CAD on Mac OS™ systems.

DENEBACAD gives professionals in many disci-
plines the tools to get their work done faster and 
easier than ever before. DENEBACAD is an inte-
grated solution that lets you produce 2D draw-
ings, 3D models, and realistic renderings in one 
program. 

You can open multiple windows to visualize a 
project from several views and perspectives. You 
can fine-tune the details in any window and see 
instant updates in all open windows. The fast 

rendering engine offers natural and artificial 
lighting, shading, reflectiveness, transparency, 
and surface mapping controls. 

This is the DENEBACAD Evaluation Guide. This 
documentation accompanies evaluation versions 
of DENEBACAD. A manual with a comprehen-
sive reference section is included with registered 
versions of DENEBACAD.

This chapter provides information on system 
requirements for running DENEBACAD and basic 
skills you should know. 

THINGS YOU SHOULD KNOW

Recommended system requirements

For best performance with DENEBACAD, it is 
recommended that your system should contain 
the following minimum software and hardware 
components:

• A Mac OS compatible system with a 
PowerPC™ processor, running Mac OS 
System 7.5 or later

• 16 MB of RAM available to 
DENEBACAD (minimum)

• 32 MB of RAM available to 
DENEBACAD (recommended)

• 20 MB of free hard disk space available 
for installation

• A CD-ROM drive

• A 24 -bit color video display capable of 
800 x 600 dpi resolution or higher

Mac OS skills

You should be familiar with the basics of using 
the Mac OS operating system. If you need more 
information on any of the following topics, 
please refer to your Mac OS documentation.

• Using the mouse

• Opening, closing, resizing, and moving 
windows and using scroll bars

• Opening and saving files using the stan-
dard directory dialog box
THINGS YOU SHOULD KNOW 1



                                       
Conventions used in the documentation

The DENEBACAD documentation uses certain 
terms and syntax when describing mouse actions, 
commands, and keyboard keys.

Click To quickly depress the button on the 
mouse (or other pointing device) and release. 
Often, clicking is done at a specific location after 
moving the pointer to the location.

Double-Click To click the mouse button twice 
in a row with almost no pause between clicks. 
You must not move the mouse between clicks.

Drag To press the mouse button and move the 
mouse while the button is held down. Usually the 
button is released when the pointer has been 
moved to the location you want.

Press To hold down the mouse button while the 
pointer is over a specific location. This term is 
also used to describe the action of using a key-
board key.

Select To drag the mouse over text or click on 
a window, icon, object, or option in a dialog box.

Choosing commands

To execute many procedures in DENEBACAD, 
you choose a command from a menu, submenu, 
or pop-up menu. Choosing a command is accom-
plished the same way in nearly all Mac OS soft-

ware. If you are not familiar with using menu 
commands, read the procedures below to learn 
the necessary steps. 

To choose a command in a menu

1. Move the pointer to the menu title in the 
menu bar. 

2. Press the mouse button. The menu drops 
down from the menu bar.

3. Move the pointer to the menu command you 
want to choose and release the mouse but-
ton.

To choose a command in a submenu

1. Move the pointer to the menu title in the 
menu bar and press the mouse button. The 
menu drops down from the menu bar.

2. Drag to the submenu that contains the com-
mand you want to choose. The submenu 
expands when the pointer is on the submenu 
name.

• You can identify a submenu by the small 
triangular indicator ( ) that appears at the 
right of the submenu name. 

3. Drag into the submenu to the command that 
you want to choose. Release the mouse but-
ton when the command name is highlighted.
2 DENEBACAD User’s & Reference Guide



     
Fig. 1 Choosing menu commands

Activating windows

Because you can display multiple views of a 
drawing on screen, you often need to make a par-
ticular window active before you can use a com-
mand or tool. For example, to change your view 
of a rendering, you need a Render mode window 
to be active, and then you can use one of the 
Focal Point tools.

To activate a window, simply click anywhere in 
the window, or on the edge of the window.

Only one drawing window is active at any time. 
The active window appears in front of other 
drawing windows. Windows that are not active 
appear gray or dimmed.

1. Point to the menu title

2. Press the pointer 
on the menu title; 
the menu drops 
down.

3. Drag to a command name and 
release the mouse, or drag to a 
submenu name and the submenu 
opens.

4. To select a submenu command, 
drag into the submenu, highlight 
the command and release the 
mouse.

submenu

Choosing menu commands

Follow the steps illustrated here to choose commands in menus 
and submenus.
THINGS YOU SHOULD KNOW 3



              
Fig. 2 Active and inactive windows

KEYBOARD KEYS AND 
COMMAND SHORTCUTS

When you can execute a command by pressing 
keyboard keys, this is referred to as a keyboard 
shortcut or command shortcut. 

To use most command shortcuts, you press a spe-
cial key at the same time you press a letter or 
number key on the keyboard. This manual uses 
standard names and abbreviations for special 
keys. However, the keyboard that you use might 
have different labels.

The following are special keys you can use for 
command shortcuts:

Command This keyboard key is labeled “Com-
mand,” or marked with a propeller ( ) or Open 
Apple symbol. In menus, the propeller symbol-
izes the Command key.

Control The keyboard key labeled “Control” or 
“Ctrl.” In menus, a caret ( ^ ) symbolizes the 
Control key.

Option The keyboard key labeled “Option.” In 
menus, an option symbol ( ) designates the 
Option key.

Shift This key is labeled “Shift” on most key-
boards. This is the key you press to type capital 
letters. In menus, an upward pointing arrow ( ) 
designates the Shift key.

The active window has 
horizontal stripes in the 
title bar and patterns in 
the scroll bars

The Mode, Zoom, and 
Layer pop-up menus 
appear in the active 
window

In an inactive window, 
the title bar and scroll 
bars are dimmed
4 DENEBACAD User’s & Reference Guide



INSTALLING DENEBACAD

Before installing any Mac OS program, it’s a 
good idea to disable all unnecessary system 
extensions. You can disable all extensions by 
restarting your computer and holding down the 
Shift key until the message “Extensions off” 
appears.

Note: If you do not have a valid DenebaCAD 
serial number see the Readme file included on 
the CD.

To install DENEBACAD

1. Double-click the Installer icon on the first 
DENEBACAD floppy disk or CD-ROM. 

2. An installer screen appears. Click Continue.

3. A scrolling window displays important 
information about the program. Be sure to 
read the text, and then click Continue. 

4. An installation dialog box appears. Use the 
options in this dialog box to configure the 
installation of DENEBACAD on your com-
puter (figure 4).

5. Select Easy or Custom installation from the 
pop-up menu at the upper left.

▲ Choose Easy unless you know that you 
want to install only certain components of 
DENEBACAD.

▲ If you choose Custom, the scrolling list 
displays the DENEBACAD components you 
can install. Select check boxes for the items 
you want to install.

6. Select a folder in which to install the 
DENEBACAD program.

▲ Select an available disk, and then choose 
Select Folder in the pop-up menu under 
Install Location. A directory dialog box 
appears. Highlight the name of the folder 
where you want to install DENEBACAD, and 
then click Select.

7. Click Install to begin installation. A window 
shows you the progress of installation. 
When installation is complete, a message 
appears. Click Quit to leave the installer.

Fig. 3 Information window 

Click to continue 
installation after 
reading the 
information

Click to print the 
information in this 
window
INSTALLING DENEBACAD 5



Fig. 4 Installation dialog box options

Fig. 5 Installation messages

Select Easy 
Install for a 
standard 
installation

The name of 
the folder 
selected for 
installation 

Select a disk 
and folder for 
installation

Click to install

Click to select other mounted disks

Click to 
view the 
latest 
important 
information

Installation messages

If you select a network volume as the Install 
Location, a message tells you that you cannot 
install DENEBACAD on a network server 
volume. You should select a disk that is part 
of your computer and not located on a 
network.

This window lists the number of items to be copied 
and the bar indicates the progress of installation

A message box appears when DENEBACAD has been 
installed successfully. Click Quit to leave the installer
6 DENEBACAD User’s & Reference Guide



LAUNCHING DENEBACAD

To start DENEBACAD, double-click the 
DENEBACAD icon in the DENEBACAD folder. 

▲ The start-up screen appears while 
DENEBACAD is loading.

▲ Note: If DENEBACAD can’t locate your 
Materials folder, a directory dialog box 
appears asking you to locate your Materials 
folder. This might happen if you misplace 
the folder, or perform a custom installation 

of DENEBACAD without installing materi-
als.

▲ When DENEBACAD finishes loading, it 
creates a new document. The untitled docu-
ment appears in a Draft mode window in 
Top view.

▲ If you double-click a DENEBACAD doc-
ument icon to launch the program, the 
selected document appears, in the mode that 
was active when the document was saved.

Fig. 6 DENEBACAD start-up screen

PERSONALIZING DENEBACAD

The first time you launch DENEBACAD after 
installing the program, you need to type your 
name and evaluation serial number in the person-

alization dialog box. This procedure has to be 
performed only once (unless you throw away the 
DENEBACAD Prefs file).

Keep your evaluation serial number in a safe 
place. You need it to personalize DENEBACAD 
again if you reinstall the program.
LAUNCHING DENEBACAD 7



To enter personalization information

1. When you launch DENEBACAD the first 
time, the personalization screen appears.

2. Type your name and organization in the text 
boxes. In the Serial Number box, type the 
evaluation serial number.

3. Click OK to personalize DENEBACAD.

ENDING A WORK SESSION

When you finish working and want to stop run-
ning DENEBACAD, use the Quit command.

◆ To stop running DENEBACAD: Choose 
Quit in the File menu or press Command+Q.

Saving documents before quitting

If any unsaved documents are open when you 
choose the Quit command, a message box 
appears and prompts you to save the documents. 

▲ If you want to continue working in 
DENEBACAD without quitting the program, 
click Cancel to close the message box.

▲ If you do not want to save changes to 
any open documents, click Don’t Save.

◆ To save document changes: Click Save in 
the message box. 

▲ DENEBACAD saves any open docu-
ments that have been saved at least once. 

▲ If a document has not been saved, a 
directory dialog box appears. To save the 
document, type a name in the text box, 
select a location, and click Save.
8 DENEBACAD User’s & Reference Guide



CONCEPTS OVERVIEW 1

DENEBACAD is the first fully integrated Archi-
tectural design environment for Mac OS comput-
ers. The DENEBACAD environment includes 2D 
drafting, 3D modeling, rendering, architectural 
publishing, and animation features in one appli-
cation.

DENEBACAD is programmed to increase design-
ers’ productivity. By developing your projects in 
DENEBACAD, you can print and plot working 
drawings, generate animated walkthroughs, 
interact with virtual reality scenes, and export 
project management information to spreadsheet 
or database applications.

• You can design exclusively in 3D mode, 
or start in 2D and extrude into 3D. 

• Once you create a 3D model, 
DENEBACAD lets you view it from any per-
spective in Render mode. 

• You can also extract plans, sections, and 
facades from the 3D model to use as the 
working drawings. 

• You create a structure once, and 
DENEBACAD makes it possible to move 
information between 2D and 3D without 
additional work.

WORKING MODES FOR DESIGN AND RENDERING

DENEBACAD offers three integrated working 
modes: Draft, Sculpt, and Render. Each mode 
provides an appropriate tool set to streamline the 
design, modeling, and rendering processes.

You can open three windows for each 
DENEBACAD document that you open. Each 
window can be set to any working mode.

Draft mode

Draft mode lets you create working drawings, 
including notes, dimensions, material tracking, 
and data analysis information. 

In Draft mode, the work space contains up to 256 
two-dimensional layers in each of six orthogonal 
views. You can picture this as if each view is a 
drawing pad of 256 acetate sheet layers.

Sculpt mode

Sculpt Mode lets you design and model in 3D. 
To create 3D objects, you can extrude 2D objects 
from Draft into Sculpt mode. You can also draw 
3D objects directly in six orthogonal views in 
Sculpt mode. You can use up to 256 total layers 
to organize 3D objects in Sculpt mode. 

Render mode

DENEBACAD’s rendering options provide an 
unparalleled medium for displaying and viewing 
your 3D environment. 

After establishing a point of view using horizon-
tal and vertical “camera” tools, you can create 
snapshots or movies of your projects, complete 
with textured surface materials, lighting controls, 
and motion. 
WORKING MODES FOR DESIGN AND RENDERING 9



DENEBACAD lets you view a scene as Wire-
frame, Hidden Line, and Solid renderings. You 
can save renderings as still images, Quick-
Time™ movies, and QuickTimeVR™ environ-
ments. In addition, you can render in 

Stereoscopic 3D; this type of two-color-shifted 
rendering can be used to create a true sense of 
spatial perspective in scenes that users and audi-
ences can view with 3D glasses.

RELATIVE VIEWS

Fundamental to the operation of DENEBACAD is 
the use of Relative Views. In Sculpt mode, a Rel-
ative View lets you change the coordinate system 
to create a new drawing plane aligned with any 
surface. This allows precise drawing control in 
any environment and situation.

In DENEBACAD, you work in an infinite cubic 
environment. Normally, you view the environ-
ment from one face of the cube. With Relative 
Views, you define a new relative position from 
which to view the cubic environment. 

For example, you can shift the Relative View so 
that your point of reference — the computer 
screen — is parallel to the slope of a roof. Then, 
drawing a skylight in the roof is as simple as 
drawing a rectangle. You can work in 3D the 
same way you would work in a 2D drawing.

The drawing plane is always parallel to the draw-
ing screen. When you create a Relative View, 
you shift the drawing plane so the surface of any 

object can be viewed in real size and parallel to 
the drawing screen. You can always work on 
objects from an accurate vantage point. 

Because DENEBACAD can adjust the point of 
reference to match the slope or angle of any 
object, the Relative View feature eliminates the 
need to calculate slopes and angles. 

Fig. 7 Default and relative views

EXTRUSION METHODS FOR 3D MODELING

You can create 3D objects easily by extruding 
2D shapes using one of three extrusion methods 
in DENEBACAD.

Linear This method extrudes an object by 
extending it along a single axis between two 
defined planes.

Coordinate axes in the 
default view

Coordinate axes in a 
relative view

Z

Y
X

Y

Z

X
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Spin This method extrudes an object by revolv-
ing it around a defined axis.

Sweep This method extrudes an object by 
extending it along an open or closed path.

You can create 3D objects by automatic extru-
sion while drawing in Sculpt mode or by select-
ing a 2D object and extruding it.

EXTRUSION PLANES

You can define two extrusion planes to limit the 
projection of 2D objects into 3D space. For 
example, by setting a pair of extrusion planes at 
ground level and at 10 feet, you can draw a 
polyline to form 3D walls 10 feet tall.

If you set one extrusion plane four meters high 
and a second extrusion plane seven meters high, 
and draw a circle, this generates a cylinder three 
meters high placed four meters above the floor.

Extrusion planes can also be used to create flat 
objects contained in them. For example, use the 
Extrusion Format buttons to specify End Cap 
only extrusion format, and then draw a circle. 
The result is a disk floating in space.

Extrusion planes are primarily used to define the 
extent of objects that are extruded with the Lin-
ear extrusion method. Extrusion planes can be set 
up and used in Draft and Sculpt modes.

• You define extrusion planes for any view 
from two other views. For example, to set 
the height of objects you draw in Top view, 
DENEBACAD switches temporarily to Front 
view or Left view when you define extru-
sion planes.

• Extrusion planes can be parallel to each 
other, or angled independently.

• Extrusion planes are usually parallel to 
the view plane but may also be angled to it. 
The view plane is always parallel to the 
computer screen.

Within the 3D space, you can define, for exam-
ple, that the Top view plane is horizontal, that the 
Front view plane is vertical and that the Left 
view plane is also vertical.

An extrusion plane parallel to the Top plane is 
horizontal and therefore perpendicular to the Z 
axis.

An extrusion plane angled with respect to the 
active view plane will be perpendicular to the 
view plane from where it was defined.
EXTRUSION METHODS FOR 3D MODELING 11



Fig. 8 Orientation of extrusion planes relative to the viewer

Defining extrusion planes

In general, the extrusion planes are perpendicular 
to the view plane from where they were defined.

• If you are using a horizontal view (Top or 
Bottom) and define the extrusion planes 
from a frontal view (Front or Back), the 
extrusion planes will be angled with respect 
to the horizontal plane and perpendicular to 
the front plane (X-Z plane).

• If you are using a horizontal view (Top or 
Bottom) and define the extrusion planes 
from a side view (Left or Right), the extru-
sion planes will be angled with respect to the 
horizontal plane and perpendicular to the 
side plane (Y-Z plane). These planes will 
determine the upper and lower limits of the 
projected objects.

• If you are using a front view (Front or 
Back) and define the extrusion planes from a 
horizontal view (Top or Bottom), the extru-
sion planes will be angled with respect to the 
frontal plane and perpendicular to the hori-
zontal plane (that is, vertical). These extru-
sion planes will determine the front and 
back limits of the projected objects.

• If you are using a side view (Left or 
Right) and define the extrusion planes from 
an horizontal view (Top or Bottom), the 
extrusion planes will be angled with respect 
to the lateral plane and perpendicular to the 
horizontal plane — that is, vertical. These 
planes will determine the left and right limits 
of the projected objects.

Near  P l ane

Far  Pl ane

Gen er a ted S ol id

S creen P lan e Scr een

XY

Z
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EXTRUSION FORMATS

DENEBACAD lets you generate three-dimen-
sional objects in several ways without altering 
the extrusion planes.

Projected When active, the extruded objects 
are projected between the two extrusion planes. 
This is the result of selecting the Sides Extrusion 
Format.

Fig. 9 Projected extrusion 

Super-contention When active, the objects 
will be projected as contained in the extrusion 
plane nearest to the observer. This is the result of 
selecting the Front Cap Extrusion Format.

Fig. 10 Super-contention extrusion

Sub-contention When this is the active projec-
tion, the objects will be projected as contained in 
the extrusion plane farthest from the observer. 
This is the result of selecting the Back Cap 
Extrusion Format.

Super-Contention Plane

Sub-Contention Plane

Projected Polygon

Polygon

Super-Contention Plane

Polygon

Sub-Contention Plane
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Fig. 11 Sub-contention extrusion

Extrusion formats are additive, so you may gen-
erate solid appearing objects by activating all 
three Extrusion Format buttons. The following 
figure illustrates several possible combinations 
of extrusion formats.

Fig. 12 Combinations of extrusion formats

Super-Contention Plane

Sub-Contention Plane

Polygon

S uper Conta ined S ub Contained Contained

Projected
Projected +
Super Contained Sub-Contained Super-Contained

Front Cap + Sides + Back Cap Sides + Back Cap Back Cap + Front Cap

Sides Front Cap +Sides Back Cap Front Cap
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INTERFACE OVERVIEW 2

DENEBACAD’s drawing environment makes the 
program easy to use and easy to adapt to your 
working methods. Items such as shortcut buttons, 
context-sensitive prompts, smart pointers, and 
status readouts help new users learn the program 
quickly and help advanced users become more 
productive.

This chapter presents an overview of the 
DENEBACAD work environment, including 
brief descriptions of interface elements, tools, 
and drawing modes.

WINDOWS AND TOOLBARS

You can customize many aspects of the 
DENEBACAD interface (figure 13), including 
the display of toolbars, information fields, and 
multiple windows. 

By default, DENEBACAD displays only the tool-
box, the Attributes bar and Action buttons, and 
the Help bar. You can also display optional tool-
bars that offer quick access to snap settings, posi-
tion data, and drawing and viewing options.

This section briefly described the features of the 
optional interface features and tells you how to 
display them.

◆ To display or hide toolbars: Choose the 
Toolbars command in the Layout menu. In the 
Toolbars dialog box, select the options you want 
to display and click OK. When you first start 
using the program, it’s recommended that you 
select all the toolbar items to display.

DENEBACAD displays the same elements each 
time you launch the program, until you change 
the setup. 

Attributes bar

The Attributes bar contains buttons you can use 
to select attributes such as colors, patterns, 
arrowheads, and Surface materials. You can also 
use the attributes buttons to open the Pen and Fill 
palettes. 

Action buttons

Action buttons appear as an option to the right of 
the Attributes buttons. Action buttons provide 
shortcuts for the commands in the following sub-
menus: Extrude, Trim, Path, Combine, and Posi-
tion. There are Action buttons for the Reshape, 
Scale, and Align commands also.

Info bar

The Info bar shows the absolute and relative 
coordinates of the pointer and the drawing vec-
tor. This data appears when you create or modify 
objects and when you set extrusion planes, Rela-
tive Views, and other items. 

By pressing Tab, you can enter coordinates 
directly in the text boxes in the Info bar.
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Status bar

The pop-up menus on the Status bar show the 
current viewing mode, layers display, Clipping 
plane, extrusion planes, and Relative View, and 
let you select new settings.

Extrusion Format buttons

The Extrusion Format buttons set constraints for 
extruding objects as solids, or as sides, faces, or 
any combination.

Toolbox

The toolbox is a floating palette containing tools 
for creating objects, dimensioning, zooming, and 
panning.

Help bar

The Help displays the names of tools and com-
mands when the pointer is on an item, and gives 
feedback on procedures. The amount of available 
memory is displayed at the right end.

Fig. 13 Main elements of the DENEBACAD interface

Status bar

Attributes bar
Info bar

Menus

Document window

Help bar

Mode Zoom Layers 

Toolbox

Centerpoint

Action buttons Extrusion format buttons

Document name Mode View

Free memory
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DRAFT, SCULPT, AND RENDER TOOLS

DENEBACAD’s toolbox is a floating window that 
displays DENEBACAD’s tools for drawing and 
rendering. Additional tools appear on toolbars 
that pop out like drawers from the main toolbox.

Tool icons 

A single arrow at the 
upper-right in a tool 
icon indicates that a 
toolbar will open if 
you press the icon. 
Similar tools are 
grouped on a pop-out toolbar. Drag into the tool-
bar to select a specific tool. The last tool that you 
select appears in the home position in the tool-
box.

When a tool icon has two arrows 
pointing down, the tool has options 
you can configure. Double-click the 
icon to open an options dialog box.

Toolbox modes

The toolbox appears in one place on the screen, 
though the tools in the toolbox change for Draft, 
Sculpt, and Render modes. 

The toolbox changes when you activate a win-
dow set to a different mode, or change the mode 
of the active window. 

• In Draft mode, the toolbox contains tools 
for 2D drawing, dimensioning, and placing 
text. 

• In Sculpt mode, 3D drawing tools, the 
Light Source tools, and the Camera Path tool 
appear in the toolbox. 

• In Render mode, the Focal Point tools for 
setting point of view, and tools to change the 
rendering perspective appear in the toolbox.

To avoid selecting the wrong tool, set the draw-
ing mode by clicking the window you want to 
draw in before you select a tool from the toolbox.

Fig. 14 Tools in Draft, Sculpt, and Render modes

SELECTING TOOLS

When you start 
DENEBACAD in Draft or 
Sculpt mode, the Selection 
tool is active. To use 
another tool, click the 
tool’s icon. The icon of the 
active tool is shaded. 

To select a tool located on a 
pop-out toolbar, press the 
home icon (the tool visible 
in the toolbox) to open the 
toolbar, drag to the tool you 
want to use and release the 
mouse. The tool you select stays in the home 
position for the toolbar.

Toolbar

Render mode 
tools

Sculpt mode 
tools

Draft mode 
tools

Selection tool
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To move the toolbox, drag the window by its title 
bar. If you use Mac OS 8 or have the Window-
Shade control panel installed, you can roll up the 
toolbox and other windows into their title bars by 
double-clicking the title bars (if this setting is 
selected in the Window Shade or Appearance 
control panel).

USING DRAWING TOOLS

To draw objects, select a drawing tool from the 
toolbox and follow the prompts displayed in the 
Help bar. You draw 2D objects in a Draft mode 
window and 3D objects in a Sculpt mode win-
dow.

With most drawing tools, you can click the 
mouse to set an object’s creation points. With the 
Circle by Radius tool, for example, you click to 
set the center of the circle and click again to set 
the circle’s radius. Or, you can drag the mouse 
from the first point to the second one.

When the Info bar is displayed, you can enter 
numeric data when creating objects. Press the 
Tab key to enter X, Y, or Z coordinates (if the 
Cartesian coordinate system is selected); click 
the check mark button or press Return to set the 
first point. Or, press Enter and then enter relative 
coordinates for subsequent points. To move from 
one field to another in the Info bar, press Tab.

TABLE OF DENEBACAD TOOLS

The following table lists every tool that appears 
in the toolbox in Draft, Sculpt, and Render 
modes. The tools are listed in alphabetical order 

and according to the toolbars in which they are 
grouped in the toolbox.

Toolbar Tool names Functions Modes

Arc

Arc Radius

Arc 3 Points

Arc Elliptical

Draw arcs from center to 
vertex, from 3 points, or 
from 5 points

Draft, 
Sculpt

Camera Path Camera Path Set waypoints and camera 
vectors for rendering walk-
throughs

Sculpt

Curve Curve Draw open and closed 
objects with smooth curves

Draft, 
Sculpt

Dimensions

Chain Dimension

Baseline Dimension

Leader Dimension

Constrained Dimension

Angle Dimension

Leader Text

Dimension 2D objects, 
place baseline, chain, or 
angular dimensions and 
single or double leaders in 
drawings

Draft
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Ellipse

Ellipse Diagonal

Ellipse Center to Corner

Circle Radius

Circle 3 Points

Ellipse 3 Points

Draw ellipses and circles 
from corner to corner, 
from center to corner, by 
radius, or by setting 3 
points

Draft, 
Sculpt

Focal Point

Horizontal Focal Point

Vertical Focal Point

Dual Focal Point

Set the horizontal view-
point, vertical viewpoint, 
or both at once for render-
ings

Render

Library Library Place Library Objects and 
Symbols in drawings

Draft, 
Sculpt

Light
Directional Light

Omnidirectional Light

Place light sources for illu-
mination in solid render-
ings

Sculpt

Line Line Draw lines and planes Draft, 
Sculpt

Polygon
Polygon Vertex

Polygon Midpoint

Draw closed, multiple-
sided objects from the cen-
ter to a side or vertex

Draft, 
Sculpt

Polyline
Single Polyline

Double Polyline

Draw open polygons with 
or without offset edges

Draft, 
Sculpt

Rectangle

Rectangle Diagonal

Rectangle Center to Corner

Rounded Rectangle
Diagonal

Rounded Rectangle Center 
to Corner

Rectangle 3 Points

Draw rectangles, rounded 
rectangles and cubes from 
corner to corner, center to 
corner, or from 3 corner 
points

Draft, 
Sculpt

Render View
Perspective Render

Isometric Render

Select standard or isomet-
ric perspective for render-
ings

Render

Selection
Selection

Point Selection

Select objects and text

Select points within objects

Draft, 
Sculpt

Text
Text

Text Rotated

Place text with horizontal or 
angled baselines

Draft

View
Zoom

Pan

Increase or decrease view 
magnification and scroll the 
active drawing

Draft, 
Sculpt

Toolbar Tool names Functions Modes
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DRAWING AND RENDERING MODES

When you launch DENEBACAD or create a new 
document, a Draft mode window appears. To 
display other views of a project, or to work with 
3D objects and renderings, you can open addi-
tional windows in Draft, Sculpt, and Render 
modes.

Draft mode is the 2D drawing mode. A Draft 
mode window shows a Top, Bottom, Left, Right, 
Front, or Back view of a 2D document.

Sculpt mode is the 3D drawing and modeling 
mode. A Sculpt mode window shows 3D objects 
from Top, Bottom, Left, Right, Front, or Back 
view.

Note: You can use display options to view 2D 
and 3D objects in Draft or Sculpt modes.

Render mode is the 3D visualization mode. A 
Render mode window displays a Wireframe, 
Hidden Line, or Solid rendering. You also use 
Render mode to generate animated walk-
throughs, QuickTime movies, and QuickTime 
VR scenes.

Displaying multiple modes

To see multiple views of a project, you can open 
up to three windows and set them to any 
DENEBACAD view or mode. For example, you 
can use two Sculpt windows to view 3D objects 
from Front and Top views while you also view 
the finished model with Surface materials and 
lighting in a Render window.

◆ To display the Draft mode window: If the 
Draft mode window isn’t already open, choose 
Show Draft in the Window menu. If this window 
is already displayed, the command reads Hide 
Draft.

◆ To display the Sculpt mode window: In 
the Window menu, choose Show Sculpt. If this 
window is already displayed, the command reads 
Hide Sculpt.

◆ To display the Render mode window: In 
the Window menu, choose Show Render. If this 
window is already displayed, the command reads 
Hide Render.

◆ To change the display mode of a win-
dow: Choose the new display mode from the 
pop-up menu at the bottom-left corner of the 
active window.

Fig. 15 Mode pop-up menu

Current mode
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APPLYING ATTRIBUTES TO OBJECTS

In Draft and Sculpt modes, you can assign a vari-
ety of attributes to objects. You can apply Pen 
and Fill colors, hatch patterns, and Pen styles to 
most objects. You can apply full-color surface 
materials to 3D objects for Solid renderings.

The buttons on the Attributes bar let you access 
palettes containing all Pen and Fill attributes.

When a particular attribute can’t be applied to a 
selected object, or can’t be used in the current 
mode, the attribute control is dimmed on the 
Attributes bar.

Note: The Attributes bar is always displayed 
when DENEBACAD is running. 

Fig. 16 Attributes bar and Text toolbar

When you use multiple 
windows, DENEBACAD 
arranges the windows so 
they don’t overlap. You 
can choose the Tile 
command or press 
Command+T to arrange 
windows neatly on 
screen.

The text controls replace the Attributes icons 
when you use text tools

Attributes icons provide instant access to 
Pen and Fill properties

Snap buttons activate 
snap-to options

Action buttons are shortcuts for 
common object commands
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PEN CONTROLS ON THE 
ATTRIBUTES BAR

The Pen controls let you apply Pen color, Pen 
weight, Pen style, and Arrows to objects. You 
can use the buttons to apply attributes, or to open 
the Pen palette.

You can set Pen attributes before or after you 
create an object. The current attributes apply to 
new objects you create. When you change the 
Pen attributes of a selected object, the current 
attributes for new objects remain the same.

The Pen attributes conform to the AIA pen color 
and weight standards. When you render a 3D 
object with the Hidden Line rendering command, 
the object’s Pen color becomes the 3D object’s 
outline color.

FILL CONTROLS ON THE 
ATTRIBUTES BAR

The Fill controls let you apply Fill colors, Fill 
patterns, and Fill hatches to 2D objects, and 
apply Surface materials to 3D objects. You can 
use the buttons on the Attributes bar to apply 
attributes, or to open the Fill palette.

Surface materials are used only in Solid render-
ings. In quick Hidden Line renderings, a 3D 
object’s Pen color becomes its outline color. In 
Solid renderings, an object’s Pen color becomes 
its surface color if the object does not have a Sur-
face material (or if the Materials option is not 
selected in the Rendering Options dialog box).

You can set Fill attributes before or after you cre-
ate an object. The current attributes apply to new 
objects you create. When you change the Fill 
attributes of a selected object, the current 
attributes for new objects remain the same.

Pen attribute 
buttons (above) 
correspond to tabs 
in the Pen palette 
(right)

You can tear the 
Pen palette away 
from any Pen 
attribute button to 
keep the palette 
open

Pen color
Pen weight

Arrows
Pen style

Fill attribute 
buttons (above) 
correspond to tabs 
in the Fill palette 
(right)

You can tear the 
Fill palette away 
from any Fill 
attribute button to 
keep the palette 
open

Surface material
Fill hatch

Fill pattern

Fill color
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GETTING STARTED 3

This chapter presents an overview to help you 
become familiar with the tools and commands 
you use to create objects in DENEBACAD. It 
includes an introduction to commands that you 
can use to set up documents, drawing scale and 

the drawing grid, and introduces the Snaps menu, 
a versatile constraint system that helps you con-
trol any drawing tool or operation you perform 
on objects in DENEBACAD.

SETTING UP THE DRAWING ENVIRONMENT

To start using DENEBACAD, double-click the 
DENEBACAD application icon. 

When DENEBACAD begins running, it opens a 
single Draft mode window, with “Untitled-
Draft-Top” displayed in the window’s title bar.

Setup for exploring DENEBACAD

To be sure that DENEBACAD is set up in the best 
way for exploring the program, the next section 
describes how to customize the drawing environ-
ment, before introducing basics of drawing in 
DENEBACAD.

Displaying optional toolbars

By default, DENEBACAD presents an almost 
empty drawing interface on screen. When you 
first start the program, the toolbox appears on the 
left, and the Attributes bar and the Action buttons 
appear in a row at the top of the screen under the 
menu bar.

Several optional toolbars are available as well. 
The Status bar provides shortcuts for changing 
your view of a drawing. The Info bar shows 

drawing data and lets you create objects using the 
keyboard. The Help bar displays a variety of 
helpful information about DENEBACAD’s tools, 
commands, and procedures.

When you first begin using DENEBACAD, it’s a 
good idea to display the optional toolbars. Once 
you become familiar with the shortcuts they pro-
vide, you can decide whether to continue to dis-
play all or some of them.

To display optional toolbars

1. Choose Toolbars in the Layout menu. The 
Toolbars dialog box appears.

2. To display all toolbars, select the four check 
boxes so that each one has X, and then click 
OK.
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Fig. 17 The Attributes bar, Action buttons, Info bar, and Status bar

SETTING PREFERENCES

To configure DENEBACAD for the introduction 
to drawing in this chapter, use the Preferences 
command to set up drawing and display prefer-
ences. 

The settings recommended here are not necessar-
ily the settings you would prefer. Once you 
understand the basics, use the Preferences com-
mand to customize the work environment to your 
liking. DENEBACAD applies the Preferences set-
tings to all documents, and you can change these 
settings at any time.

To set up drawing preferences

1. Choose Preferences in the Edit menu. The 
Preferences dialog box opens.

2. Select the check boxes for the options on the 
General tab to match the illustration 
(fig. 18).

3. Click OK to close the Preferences dialog 
box.

Fig. 18 The General tab in the Preferences dialog box.

DRAWING SCALE AND GRID 
SETTINGS

Before you begin any new project, you’ll want to 
check the settings for measurement units, draw-
ing scale, and the drawing grid that appears in the 
Draft and Sculpt drawing windows.

• Once you create a document with the set-
tings you want to use often, you can save the 
document as a template. Then you can open 
this document to work with the same set-
tings. Use the Save As command to save it 

Attributes bar

Action buttons

Info bar

Status bar

Extrusion format buttons
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with a new name when you start a new 
project.

To set up measurement units

1. Choose Units Setup in the Layout menu. 
The Units Setup dialog box appears.

2. Set the dialog box to match the following 
illustration and click OK. 

▲ To make the new settings the default set-
tings for all new documents, click Default.

To set up the drawing grid

1. Choose Grid Setup in the Layout menu. The 
Grid Setup dialog box appears.

2. In the Grid pop-up menu, choose 1" by 1" 
and click OK to implement the grid settings.

Note: The grid setting specified here is appropri-
ate for drawing objects like doors, as described in 
the following tutorial lesson. For larger-scale 
drawings, you will want to use a larger grid set-
ting.

BASICS OF DRAWING OBJECTS

Objects are geometric shapes which form the 
basis of almost all drawings. In DENEBACAD, 
you can easily draw 2D objects, including lines, 
polylines, ellipses, arcs, curves, and rectangles. 
And you can just as easily create 3D objects, 
including cubes, columns, walls spheres, planes, 
arches, and more complex shapes.

You can use any of the following methods to 
draw objects with 2D (Draft) and 3D (Sculpt) 
tools:

Click or drag Select a drawing tool, position 
the pointer in the drawing area, and click or drag 
the mouse to set the points that define an object. 

Enter coordinates Select a drawing tool, 
press Tab, and type coordinates or dimensions 
for the object in the text boxes in the Info bar. 
After you type coordinates for the first creation 
point, press the Enter key and then type relative 
coordinates to set subsequent creation points.

Using existing objects You can also create 
objects by using other objects. To do this, select 
an existing object and choose the Duplicate, Mir-
ror, Rotate, Copy, Array, or Combine command 
to create new objects.
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COORDINATE SYSTEMS

You can use several coor-
dinate systems in 
DENEBACAD.

You select a coordinate 
system from the pop-up 
menu in the Info bar. The 
values that appear in the 
Info bar when you draw 
with the mouse reflect the 
current coordinate system. Also, you work in the 
current coordinate system if you type coordinates 
in the text fields in the Info bar to create objects.

You can use the six coordinate systems in 
DENEBACAD. The coordinate systems are 
briefly described here. You can learn more about 
the coordinate systems by choosing each one in 
the Info bar and looking at how the text boxes in 
the Info bar change, and the coordinates that 
appear when move the pointer and draw objects.

Cartesian

The Cartesian system is based on a grid divided 
into four quadrants with a horizontal X axis and a 
vertical Y axis in Top view. 

The Centerpoint in the Cartesian system is the 
intersection of the horizontal and vertical axes at 
coordinates 0, 0. To specify the location of a 
point, you can type a pair of distances measured 
along the X and Y axes in the Info bar. The coor-
dinates can be absolute, expressed as the dis-
tances along the X and Y axes from the 
Centerpoint; or relative, expressed as the change 
in distance (∆X, ∆Y) from one point to another.

Polar

When you use the Polar coordinate system, you 
can set the length of a line segment (labeled ∆D 
in dialog boxes) and its angle (labeled ∆A) 

directly. Each quadrant in the coordinate system 
encompasses 90 degrees.

Relational

The Relational system expresses all distances as 
relative to the last creation point or edit point on 
an object.

Bearing

In the Bearing coordinate system, a measurement 
is expressed as a distance and a bearing. Coordi-
nates are expressed in geographic direction — 
North, South, East, West — to a fixed point or to 
the Centerpoint of the document.

Fig. 19 Bearing coordinate system

Geographic

The Geographic system can also be called the 
Linear or Reticular coordinate system. The Geo-
graphic system is a cartesian system based on a 
grid divided into four quadrants with a horizontal 
E (East) axis and a vertical N (North) axis. This 
system is similar to the horizontal X axis and ver-
tical Y axis of the Cartesian coordinate system. 
Coordinates are positive or negative values, with 
positive N and E values for points above and to 
the right of the Centerpoint, and negative N and 

Coordinate 
Systems menu in 
the Info bar

N

S

EW

NW NE

SESW
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E values for points below and to the left of the 
Centerpoint (fig. 20).

Fig. 20 Geographic coordinate system

Gradient

When you use the Gradient coordinate system, 
the location of a point on the grid is expressed as 

a distance from the Centerpoint (or from the last 
creation point) and an angular measurement. 
Each quadrant in this system encompasses 100 
degrees.

Fig. 21 Gradient coordinate system

Fig. 22 Info bar data and coordinate systems
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Coordinate System pop-up menu
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DRAWING WITH THE MOUSE

Drawing with the 
mouse is the most 
common method for 
creating objects in 
DENEBACAD.

To draw objects with 
the mouse, you have a 
choice between two 
methods:

• You can click to place the points that 
define an object, such as the endpoints of a 
line segment.

• You can press the mouse button to set the 
first creation point, and drag to the location 
of the second and subsequent points.

Both methods work with most drawing tools. 
The exceptions are tools that define objects with 
more than two points, such as the Rectangle 
Rotated and Circle 3 Points tools. With these 
tools, you drag from the first to the second cre-
ation point, and then click to set the third point.

When you draw by dragging the mouse, you usu-
ally complete an object in one step. You can do 
this when you don’t need to type numeric values 
in the Info bar to set creation points.

When you draw objects by clicking the mouse to 
set the first point, you are able to enter coordi-
nates or distances numerically for subsequent 
points, as described in the next section.

To draw a line by clicking endpoints

1. Select the Line tool from the tool box. 

2. To set the first point, click in the drawing 
window. 

3. Move to the position of the second point. 
The line segment appears to stretch, or “rub-
ber band,” as you move the pointer. 

4. Click to set the second point and finish the 
line. The line segment appears with the cur-
rent Pen color and Pen weight, and is 
selected.

To draw a line by dragging between endpoints

1. Position the pointer where you want the line 
segment to begin

2. Press and hold the mouse button and drag to 
the second endpoint of the line. When you 
release the mouse button, the line segment 
appears with the current attributes, and the 
line is selected.

DRAWING WITH THE INFO BAR

You can draw an object by using the text boxes 
in the Info bar to specify coordinates for the 
object’s creation points. Drawing an object by 
typing values in the Info bar can be the best 
method to use when you want to set an object’s 
location and size numerically.

When you draw using the mouse, notice that the 
numbers in the Info bar change as you move the 
pointer. 

In the Cartesian coordinate system, for example, 
the X and Y fields show the pointer’s position as 
X and Y coordinates with the Centerpoint at 0, 0. 
After you set an object’s first creation point, the 
∆X and ∆Y fields show the pointer’s distance 
from the previous creation point. 

When you use a coordinate system that displays 
distance and angle, you can control the length 

Line tool
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and angle of the drawing vector for any opera-
tion.

When you draw an object using the Info bar, you 
type in the same values that would appear if you 
were moving the pointer with the mouse and 
clicking to set object creation points.

To draw a line by entering coordinates

You can draw a line by setting the coordinates of 
the first point and specifying the length of the 
line.

1. Be sure the Cartesian coordinate system is 
selected in the Info bar, then select the Line 
tool in the toolbox. 

2. Press the Tab key to highlight the X field in 
the Info bar. 

3. Type the X coordinate of the first endpoint. 
This is the distance horizontally from the 
Centerpoint to the starting point of the line.

4. Press Tab to highlight the Y field. Type the 
Y coordinate of the first endpoint. This is the 
distance vertically from the Centerpoint to 
the starting point of the line.

5. Press RETURN to set the first endpoint at 
the X,Y coordinates.

6. Press Tab to highlight the ∆X field in the 
Info bar, and type the line’s length on the X 
axis (the horizontal distance).

7. Press Tab to highlight the ∆Y field, and type 
the line length on the Y axis (the vertical dis-
tance). The line appears with the current 
attributes and is selected.

Fig. 23 Typing creation point coordinates

Alternate method for using the Info bar to 
create an object

1. Select the Line tool in the toolbox. 

2. Press the Tab key to highlight the X field in 
the Info bar. 

3. Type the X coordinate of the first endpoint, 
the distance horizontally from the Center-
point to the starting point of the line.

4. Press Tab to highlight the Y field. Type the 
Y coordinate of the first endpoint, the dis-
tance vertically from the Centerpoint to the 
starting point of the line.

5. Press Enter to set the first point at the X, Y 
coordinates.

6. Notice that the ∆X text box is highlighted. 
Type the length of the line on the X axis in 
the text box.

7. Press Tab to highlight the ∆Y field, and type 
the line length on the Y axis (the vertical dis-
tance). The line appears with the current 
attributes and is selected.

To draw a horizontal line from the Centerpoint

This procedure gives an example of drawing a 
50-foot line horizontally from the Centerpoint.

X and Y values set the first creation point relative to the 
Centerpoint.

∆X and ∆Y values set the second creation point relative 
to the first creation point.
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1. Select the Line tool. Press 
Tab to highlight the X field 
in the Info bar.

2. To set the first endpoint at 
the Centerpoint, type 0 in the X field. 

3. Press Tab, type 0 in the Y field, and then 
press Enter. 

4. To complete a 50-foot horizontal line, type 
50' in the ∆X box, press Tab, type 0 in the 
∆Y box, and then press Return. 

MODIFYING PROPERTIES OF OBJECTS

You can use the Properties Manager to view and 
edit the properties of an object. The Properties 
Manager is a floating palette, so you can keep it 
open while you work.

◆ To open the Properties Manager: Choose 
Properties Manager in the Window menu, or 
double-click an object you want to edit.

The Properties Manager shows position data and 
other information for a selected object. When 
you create an object, it is selected and its data 
appears in the Properties Manager. To work with 
a different object, click the object you want to 
select with the Selection tool.

The Properties Manager contains four tabs. 
When it first appears, the Coordinates tab is in 
front. The Coordinates tab displays information 
and position data for a selected object.

• The top of the tab displays and lets you 
edit an object’s name.

• The pop-up menus under the name let 
you choose relative or absolute position 
data, and the coordinate system to be used.

• Under the pop-up menus, text boxes 
show data on the object’s creation points. If 
the Show Vector option is selected, the 
drawing vector appears in the drawing. 
When you use absolute position data, 
DENEBACAD displays the vector that 

defines the point’s position from the Center-
point.

Fig. 24 The Coordinates tab in the Properties Manager

Line tool

Expanded 
data view

Coordinates tab

Click to 
expand tab

Centerpoint

Drawing vector

The drawing vector appears when you select an 
object and select Show Vector in the Properties 
Manager
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To edit a line in the Properties Manager

This procedure is an example of using the 
Properties Manager to change an object’s size or 
coordinates.

1. With a line selected, choose the Properties 
Manager command in the Window menu. 
The Properties Manager appears.

2. Click the Coordinates tab to 
bring it to the front, if neces-
sary.

3. Choose Relative and Polar 
from the pop-up menus under the Name 
box. This sets the coordinate and measure-
ment systems.

4. The values under the pop-up menus are the 
length (∆D) and angle (∆A) of the line. Type 
a new length in the ∆D box and press Tab to 
change the line length. Type a new angle in 
the ∆A box and press Tab to change the 
line’s angle.

5. To view area, perimeter and volume data for 
a selected object, click the arrow at the 
lower-left to expand the Properties Manager. 

6. When you finish editing an object, click the 
Close box if you want to close the Properties 
Manager.

Fig. 25 Editing position data in the Properties Manager

Coordinates 
tab

Choose a coordinate system

Specify a creation point to edit

Vector data shows the location 
of the selected point 

Choose Relative or Absolute 
position data

Total number of creation points

Data displayed conforms to the 
selected coordinate system

With a line selected, the 
Coordinates tab in the Properties 
Manager displays data about the 
line’s creation points 

When you select point 1, the 
Properties Manager reports the 
absolute distance from the 
Centerpoint to the object, shown 
by the drawing vector.

When you select point 2 of a line, 
Relative position data and the 
drawing vector show the length 
from the first to the second 
creation points, which is the 
length of the line. Point 1 selected Point 2 selected

Vector Vector

Line

Centerpoint
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SNAPS MENU CONSTRAINTS

As shown in the next section (see “Drawing with 
snap constraints” on page 33), the Snaps menu 
provides constraints that let you precisely align 
objects by controlling the pointer and the draw-
ing vector, without having to specify angles or 
distances numerically. 

USING THE SNAPS MENU 

The Snaps menu pops up in the drawing area 
when you press the Control key and the mouse 
button at the same time. 

In most cases, you indicate which object should 
be the reference for the constraint by pointing to 
an object when you press Control. In descriptions 
of the constraints in this section, the object you 
point to when you open the Snaps menu is called 
the reference object.

You can also make the Snaps menu appear 
whenever you press the mouse button to draw an 
object (without pressing the Control key). To do 
this, select the check box labeled “Always Show 
Snap Options” on the General tab in the Prefer-
ences dialog box.

You can combine constraints and use different 
constraints to set each creation point when you 
draw objects. Also, snap constraints can be used 
for all DENEBACAD operations, not just object 
creation. 

Constraints can be applied to the positioning of 
planes when you define extrusion planes, clip-
ping planes, and Relative Views. For example, 
when you use the Define Frontal 3D Plane com-
mand, you can choose Included in the Snaps 
menu to align the plane with the slope of a roof 
gable.

The Snaps menu lets you constrain the drawing 
vector and pointer in many ways. Listed below 
are all the constraints in the Snaps menu. If a 
constraint has a keyboard shortcut, it appears 
after the constraint name.

Free Mouse

This option frees the pointer and drawing vector 
from any constraint that is in effect. In other 
words, Free Mouse is not a constraint itself; it 
restores the pointer to free movement.

Click

Choosing Click is a substitute for clicking the 
mouse during a procedure.

Snap Points (Spacebar)

This constraint displays the Snap points of the 
reference object. When an object’s snap points 
are displayed, the vector snaps to the closest 
point.

Included (I)

The Included constraint confines the pointer or 
vector to the path of the object at the pointer; if 
you move the pointer beyond the object, the con-
straint continues as if the object or segment 
extended through the entire drawing.

Parallel (P)

Choosing Parallel constrains the vector to a path 
parallel to the object at the pointer. If you choose 
Parallel before setting an object’s first creation 
point, a line appears at the pointer, parallel to the 
object you indicated. Move the pointer and then 
click to establish the offset from the object. An 
Offset dialog box appears so you can confirm the 
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offset, or type a new value in the text box. Click 
OK to set the offset. A small cross appears where 
you click, and the pointer is constrained to the 
parallel line at the specified offset distance.

Perpendicular (N)

This constraint snaps the pointer or vector to a 
path perpendicular to the object you indicate (the 
object at the pointer) when you choose the con-
straint.

Tangent (T)

Tangent constrains the vector to be tangent to a 
circle or circular arc. After setting the first end-
point of a line, choose Tangent and the vector 
snaps to the perimeter of the indicated circle. 
This constraint is not available unless the pointer 
is on a circle or circular arc.

Direction (D)

The Direction constraint snaps the vector to the 
angular direction that you establish before choos-
ing the constraint. For example, as you move the 
pointer away after setting the first creation point 

of a polyline, you establish a direction. If you 
choose Direction or press D, the vector locks to 
the established direction.

Center (C)

Snaps the pointer and vector to the center of the 
reference object or segment.

Intersection (X)

Aligns the pointer and vector to the intersection 
of two separate objects, such as the point at 
which two lines meet or cross.

Numeric (Tab)

Choosing Numeric is the same as pressing Tab 
during an operation: it lets you enter position 
data in the Info bar during an operation. For 
example, you might click to set the first creation 
point of an object, and then type numeric values 
to set the length and direction of the vector to 
complete an object.

DRAWING WITH SNAP CONSTRAINTS

DENEBACAD provides powerful and flexible 
“snap-to” drawing aids. In addition to the snap-
to-grid and snap-to-object features, 
DENEBACAD offers a unique Snaps constraint 

system that you can use to control the drawing 
vector in all operations. 

When you open the Snaps 
menu, not all Constraints 
are available at all times. 
The available constraints 
depend on the position of 
the pointer and the type of 
operation in progress.
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You apply the Snaps constraints using the Snaps 
pop-up menu that appears at the pointer location 
in a drawing, or by pressing a shortcut key 
(fig. 26).

The Snaps menu lets you constrain the drawing 
vector and pointer in many ways. You can draw 
parallel to an object, tangent to an object, aligned 
to an object’s center, sides or snap points, per-
pendicular to an object, at a constant angle, and 
aligned to an object’s snap points. 

You can combine constraints and use different 
constraints to set each creation point when you 
draw objects. In this way, the Snaps menu gives 
you precise control over any drawing situation. 

To use the Snaps menu

1. Select the drawing tool you want to use.

2. Hold down the Control key and press the 
pointer on an object that you want to snap to. 
The Snaps menu appears in the drawing 
area. 

3. Drag into the Snaps pop-up menu to choose 
a snap constraint. 

▲ The constraints that are available in the 
Snaps menu depend on what you click in the 
drawing.

▲ Choose Free Mouse to release a con-
straint that is in effect.

4. Click or drag the mouse to draw an object. 
The constraint you selected controls the 
drawing vector and pointer.

Fig. 26 The Snaps menu 

To snap endpoints of lines

This procedure gives an example of snapping the 
creation point of a new object to the endpoint of 
an existing line.

1. Select the Line tool and draw a line. Click 
away from the line to deselect it. 

2. Select the Line tool again. Point to the first 
line, press the Control key and hold down 
the mouse button at the same time. The 
Snaps menu appears. 

3. Drag into the Snaps menu and choose Snap 
Points. The line’s snap points appear as 
small handles (fig. 27). 

4. Click the snap point at one end of the line. 
The first point of the new line snaps to the 
point you clicked.

5. Move the mouse and click anywhere to set 
the second endpoint of the new line.

Fig. 27 Snap points on a line

Constraint 
shortcuts

Snaps pop-up menu
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To draw using two Snaps constraints

1. Select the Circle Radius tool. If the Circle 
Radius tool icon isn’t visible in the toolbox, 
press the Ellipse toolbar icon to open the 
pop-out toolbar, and then drag to the Circle 
Radius tool.

2. Point to the intersection of the two lines you 
drew before, press Control, and choose 
Intersection in the Snaps pop-up menu. 

▲ If Intersection is dimmed so you can’t 
select it, be sure you point to the exact inter-
section of the two lines.

3. Press the pointer on one of the line segments 
and press the Control key. The Snaps menu 
appears.

4. In the Snaps menu, choose Center. The edge 
of the circle snaps to the center of the line 
segment. This completes the circle and 
leaves it selected. 

Fig. 28 Snapping a circle to two lines

Ellipse toolbar 
icon

Circle Radius tool

Point to one of the lines and choose the Center snap 
option

Point to the 
intersection of the 
lines and choose 
Intersection in the 
Snaps menu
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Fig. 29 The drawing vector in common operations
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THE DRAWING 
VECTOR AND 
SNAPS

The drawing vector is a 
gray arrow that appears 
when you create objects 
and perform most opera-
tions, including Rotate, 
Mirror, Array, Define 3D 

Plane, and Define Clip-
ping Plane.

The drawing vector indi-
cates the distance from 
one point to another by 
its length. It also indicates 
angle or bearing. Because 
the Info bar and the Prop-
erties Manager display 
the drawing vector’s 
length and angle, and 

because you can control 
the vector with the Snaps 
menu constraints, the 
drawing vector is one of 
the most powerful draw-
ing aids in DENEBACAD.

The illustrations on this 
page show the drawing 
vector as it appears when 
you create objects and 
perform other operations.

Circle 3 Points

Vectors

Vector Vector Vector Vector Vector

Vector Vector

Vector

Vector

Vector

Vector

Vector
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CLEARING THE DRAWING WINDOW

To make sure you have enough room to continue 
drawing while you follow the examples in this 
chapter, you might want to clear all objects from 
the drawing window from time to time. To do 

this, Press Command+A to select all objects in 
the drawing. Then press the Delete or Backspace 
key to remove all selected objects.

MAKING COPIES OF OBJECTS

Another method you can use to create objects is 
making copies of existing objects. Several com-
mands let you duplicate an object and also rotate, 
flip, or reposition the copy at the same time.

To duplicate a rectangle

1. Select the Rectangle Diago-
nal tool in the toolbox and 
drag the pointer to draw a 
rectangle.

2. With the rectangle selected 
(selection handles should be 
visible), select the Duplicate command in 
the Edit menu. 

3. A copy of the original rectangle appears in 
front of the original. Point to one side of the 
rectangle and drag it away. You can see that 
the original rectangle remains in position 
behind the copy.

DUPLICATING OBJECTS BY 
PASTING

You can cut and then paste a selection in 
DENEBACAD the same as you would in any Mac 
OS application. In addition, DENEBACAD’s 

Paste Special command lets you paste a selection 
in a variety of ways.

To position a pasted object with Paste Special

1. Draw or select an object in your drawing.

2. Choose Copy in the Edit menu. This places 
a copy of the object on the Clipboard.

3. Choose Paste Special in the Edit menu. The 
Paste Special dialog box appears. You can 
choose from three options for pasting: 

▲ Absolute places the copy in front of the 
original, at the same absolute coordinates.

▲ Relative places the copy relative to the 
current view, at the center of the screen.

▲ Cursor Position lets you click to place 
the copy.

Rectangle 
Diagonal 
tool
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4. Select an option and click OK to paste the 
object. If you chose Cursor Position, click in 
the drawing to set the upper-left corner of 
the object’s bounding box.

COPYING AND MIRRORING 
OBJECTS

Mirroring an object lets you create a flipped copy 
or a mirror image of a selected object.

To copy an object by mirroring

1. Select the Single Polyline 
tool from the Polyline tool 
bar. 

2. Click at several points in the 
drawing, and then double-
click the last point to draw an 
irregular shape. The new polyline is 
selected.

3. Choose Mirror a Copy in the Position sub-
menu in the Object menu. A vertical line, 
representing the mirror axis, appears at the 
pointer.

4. Move the pointer to position the axis hori-
zontally, then click to set the horizontal 
position of the axis over which the object 
will be mirrored, or flipped. 

▲ The copy will appear twice the distance 
from the axis to the original. 

5. After you click, the drawing vector appears. 
Move the pointer to angle the axis away 
from vertical, if desired. The drawing vector 
indicates the angle and distance from the 
center of rotation, which is at the point you 
clicked in step 4.

▲ To snap the axis to 15° increments, press 
the Shift key as you position it. 

6. Click to set the angle of the axis. A mirror 
copy of the original object appears and is 
selected. 

Fig. 30 Using the Mirror a Copy command
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Setting the mirror axis vertically (as above) results in a 
copy aligned horizontally with the original

Setting the mirror axis at a 45-degree angle results 
in a copy rotated 90 degrees from the original
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COPYING AND MOVING 
OBJECTS

The Move a Copy command provides another 
method for you to copy an object and set the 
position of the copy in relation to the original.

To copy and move an object

1. Draw a rectangle or select an existing object.

2. Choose Move a Copy in the Position sub-
menu in the Object menu.

3. Click to set the reference point for moving 
the object.

4. When you move the pointer, the drawing 
vector shows the relative movement from 
the reference point, and an outline of the 
object shows where the copy will appear.

5. Click to set the position of the object copy.

Fig. 31 Using the Move a Copy command

COPYING AND ROTATING 
OBJECTS

Rotating a copy is another method you can use to 
create an object by duplicating an existing one.

To copy and rotate an object

1. Draw an object or select an existing one in 
your document. 

2. Choose Rotate a Copy in the Position sub-
menu in the Object menu.

3. Click in the drawing to enter the base point 
of rotation for the object. 

4. When you move the pointer, the drawing 
vector shows the position of the pointer rela-
tive to the rotation point you clicked. Click 
in the drawing again to set the reference 
point and click a third time to input the rota-
tion angle of the object.

5. A dialog box appears so you can confirm the 
rotation angle you have indicated. 

▲ You can type a new angle in the text 
box, or click OK to use the existing value. 
When you click OK, the rotated duplicate 
object appears.

Fig. 32 Using the Rotate a Copy command

The drawing vector shows the relative movement of 
the reference point

Drawing vector

Click (2)

Click (3)

Click to set the center of rotation, then click to set the 
first vector and the second vector. The angle between 
the vectors is the angle of rotation

Click (1)
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DUPLICATING OBJECTS IN 
ARRAYS

You can duplicate and create new objects using 
the Linear Array and Polar Array commands. 
These commands let you create one or many 
copies and position the copies a set distance from 
one another. 

With the Linear Array command, in Draft mode, 
you can specify the ∆X, ∆Y, distances, as well as 
having the option of copying the objects by offset 
distance or inclusively. 

In Sculpt mode, you can specify the ∆X, ∆Y, and 
∆ Z distances, as well as having the option of 
copying the objects by offset distance or inclu-
sively.

• The Offset Array option will create the 
number of copies you specify and place each 
copy a specified distance from the last one. 

• The Inclusive Array option will place the 
specified number of copies within a speci-
fied distance. 

To use the Linear Array command

1. Select an object you want to duplicate.

2. Choose Linear Array in the Position sub-
menu in the Object menu.

3. The pointer becomes a four-way arrow. 
Click to set the reference point and move to 
set the array distance and angle, as shown by 
the drawing vector. You can also drag from 
one point to another.

4. The Linear Array dialog box appears. Type 
the number of copies to create in the “# Cop-
ies” text box.

▲ You can type new coordinate values in 
the text boxes and select a coordinate system 
from the pop-up menu.

5. Click a button in the dialog box to choose 
the Array method.

▲ Click offset to use the drawing vector as 
an offset distance and direction. Each copy 
appears the same distance away from the 
previous copy.

6. Click Inclusive to distribute the copies 
within the distance and direction specified 
by the drawing vector.
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Fig. 33 Using the Linear Array command

CREATING OBJECTS WITH BOOLEAN OPERATIONS

Boolean operations let you create complex 
shapes by combining multiple objects. You can 
choose from six combine operations: Unite, 
Intersect, Punch from Back, Punch from Back 
and Trim, Punch from Front, and Punch from 
Front and Trim.

UNITING OBJECTS

The Unite command unifies selected objects into 
one new object.

To unite objects

1. Draw several objects, such as circles, 
squares, polygons, or any other shapes that 
you like. 

2. Make sure that the objects all overlap each 
other. If necessary, drag the objects to repo-
sition them.

3. To apply a fill color to one or 
more of the objects, select 
the object. Press the Fill 
Color icon in the Attributes 
bar and drag to select the 
color to apply.

Note: You can apply Fill colors to 2D objects 
only.

4. Press Command+A to select all the objects.

5. Choose Unite in the Combine submenu in 
the Object menu. A new object made from 
the union of the original objects appears. 
The new object takes on the attributes of the 
original backmost object.

 

Inclusive array optionSetting the array distance Offset array option

Vector

The drawing vector indicates the distance and angle for 
duplicating objects with the Array command

Fill color 
icon
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Fig. 34 Objects combined with Unite 

RESHAPING OBJECTS

After you create a Boolean object using a Com-
bine submenu command, you can reshape the 
object by editing its original components. When 
you finishing editing the shapes and reposition-
ing the component objects, DENEBACAD reap-
plies the Combine command that you had used to 
create the Boolean object.

To reshape a Boolean object

1. Select the Boolean object.

2. Choose Reshape in the Edit 
menu, or click the Reshape 
action button on the 
Attributes bar. DENEBACAD 
displays the original objects.

▲ Because the Preference option “Show 
Boolean outlines” is selected, the original 
objects have a black outline, and a red out-
line appears around the Boolean object.

3. Drag one of the component objects to a new 
position.

Fig. 35 Reshaping a Boolean object

4. Click outside of the objects. The Boolean 
object is reshaped based on the change to its 
component objects.

ZOOMING IN AND OUT OF DRAWINGS 

You can adjust the view of a 
drawing by zooming in to spe-
cific areas, and zooming out for 
an overview of the whole draw-
ing. 

Use the Zoom tool to drag a box around an area, 
and DENEBACAD magnifies the area until it fills 
the drawing window. To zoom out, press the 
Option key and drag in the drawing. You can use 
the Zoom tool in Draft and Sculpt windows.

United 
object

Original 
objects

Reshape 
button

Reshaped 
object

Boolean 
object in 
Reshape 
mode

Vector

Zoom tool
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You can also change magnification with the 
Zoom bar at the bottom of the active window. 
Press the center of the bar to use the Zoom pop-
up menu. You can quickly zoom by clicking the 
Zoom In and Zoom Out buttons. In the Zoom 
pop-up menu, you can choose Fit to Window, 
Home View, and a number of preset zoom 
scales.

Fig. 36 The Zoom bar 

Zoom pop-up menu

Current zoom level
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2D AND 3D LIBRARY OBJECTS 4

Libraries offer a way of creating, organizing, and 
using items such as doors and windows, wiring 
and plumbing symbols, and roof and wall sec-
tions in your work. This chapter explores proce-
dures for creating 2D and 3D Library Objects. 

Library Object types

There are two types of items you can store in the 
Library Palette: Symbols and Objects. You can 
create Library items in 2D, 3D, and combined 
2D/3D. 

The items described in this chapter are 2D and 
3D Library Objects. As part of creating Library 
items, you’ll learn how to use some tools not 
described in preceding sections.

To follow the exercises in this chapter, open the 
file named “Library.start” located in the Tutorial 
folder. This file has all the preferences set up cor-
rectly for the procedures described in this 
chapter. When you open the file, you should see 
a blank document in Draft mode.

DRAWING A 2D DOOR

To create a combination 2D/3D Library Object, 
you usually start by creating the 2D object. 

To draw a 2D frame

1. Select the Rectangle Diagonal tool.

2. Click to set one corner of the door rectangle. 
Press Tab and Type 3' for ∆X, press Tab 
again and type 6" for ∆Y.

3. Press the Return key to set the points.

To draw 2D door jambs

1. Select the Rectangle Diagonal tool and snap 
to the outside corner point of the rectangle 
and draw a 2" wide by 6" tall door jamb.

2. To apply a Fill color to the door jamb, press 
the Fill Color icon in the Attributes bar and 
drag to select the Fill color you want to 
apply.

3. Make a mirror copy of the door jamb so 
there is one on the other side of the door. 
With the door jamb you just drew still 
selected, choose Mirror a Copy in the Posi-
tion submenu in the Object menu. Snap to 
the center of the outlined rectangle to set the 
insertion point. Set the mirror axis so it is 
vertical using the Shift key to restrain its 
position. 

4. Click the mouse when you have the axis set 
correctly. A mirror copy of the door jamb 
appears. 

To draw a 2D door

1. Select the Rectangle Diagonal tool. 

2. Snap to the mid point of the door jamb and 
click the mouse to set the insertion point. 

3. Drag until you have a rectangle that is 1" 
thick (shown in the ∆X box) by 3' tall 
(shown as ∆Y). 
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4. You can assign a Fill color to the door the 
same as you did with the door jambs. For 
now, assign the door the same Fill color as 
the door jambs.

Fig. 37 Drawing a door 

Now that you have drawn the door frame, jamb 
and door, you can draw the door swing. 

To draw a 2D door swing

1. Select the Arc Radius tool 
from the Arcs toolbar. 

2. Snap to the midpoint of the 
right side door jamb and click 
the mouse to set the center 
point of the arc. 

3. Snap to the corner point of the door to set the 
first endpoint of the arc. 

4. Set the second endpoint of the arc at the 
midpoint of the left side door jamb. You 
now have the door swing. 

Fig. 38 Drawing a door swing

The last object to draw for the door is a rectangle 
that will be used as a Boolean object. 

To draw a 2D door’s Boolean object

1. Select the Rectangle Diagonal tool from the 
Rectangles toolbar.

2. Snap a rectangle from the top-left edge of 
the left door jamb to the bottom-right edge 
of the right door jamb.

Fig. 39 Drawing a door’s Boolean object

MAKING A 2D DOOR A LIBRARY 
OBJECT

When you finish drawing a 2D door, you can 
convert it into a Library Object by using the 
Properties Manager. 

To create a Library Object

1. Select all the objects drawn for the door.

2. Choose Group in the Object menu. Handles 
appear around the door. 

Midpoint 

Arc Radius 
tool
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3. Choose Properties Manager in the Window 
menu to open the Properties Manager.

4. Click the Object Info tab to bring it to the 
front, if necessary. This tab lets you view 
information about the new group. 

5. Type 3' Door in the Name box to give the 
door a descriptive name, and then press 
Enter.

6. To convert the door to a Library Object, 
check the Library Type check box, and then 
click the Object radio button.

7. Check the Boolean check box. This makes 
the front object in the group, the rectangle 
drawn last, a subtractive shape. The rectan-
gle will cut the opening needed when you 
place the door in a wall. 

Fig. 40 Designating a Library Object in the 
Properties Manager

Setting the insertion point

An insertion point is the point at which a Library 
Object snaps to objects in a drawing. When a 
Library Object is first defined, DENEBACAD 
places the insertion point at the center of the 
Library Object.

In the case of a door, an insertion point at the 
center of the door object is not useful. You can 
move the insertion point to the midpoint of the 
door jamb. This will center the door in any wall 
where you place it.

To position a door’s insertion point

1. Select the door Library Object.

2. Choose Reshape in the Edit menu, or click 
the Reshape Action button on the Attributes 
bar. The highlighted insertion point appears 
at the center of the Library Object. 

3. Drag the insertion point to its new location 
at the midpoint of the outer edge of the left 
door jamb. 

You have now completed a 2D door Library 
Object.

Click to designate a 
Library Object
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Fig. 41 Setting the insertion point for a door Library Object

DRAWING AN ELEVATION OF A DOOR

In this part of the lesson, you’re going to draw an 
elevation for the 3-foot-wide door you created.

Using multiple windows

First, open a new drawing window in Sculpt 
mode. 

To open a new window

1. Choose Show Sculpt in the Window menu. 
A new window in Sculpt mode set to Top 
View appears. DENEBACAD arranges, or 
“tiles” the windows so you can see both the 
Draft mode window and the Sculpt mode 
window. 

2. Click the Draft mode window to make it 
active.

3. Choose Fit to Window in the Zoom pop-up 
menu, or press Command+Shift+W, so you 
can see the entire drawing.

To move the Centerpoint

Next we’re going to move the drawing’s Center-
point (origin) to a new location. 

1. Choose Set Position in the Centerpoint sub-
menu.

2. Move the pointer to the left door jamb and 
snap to the lower-left corner. Click to set the 
new Centerpoint position.

Original insertion 
point

Move insertion point to here

Enlarged view
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Fig. 42 Changing the Centerpoint location

To change views

1. Choose Front in the View menu. The win-
dow displays the DENEBACAD workspace 
from the Front. The document window is 
empty because you haven’t created any 
objects in Front view.

2. Make sure the Centerpoint is visible. If nec-
essary, zoom in or out, or scroll until the 
Centerpoint is visible in the lower-left cor-
ner of the window.

Drawing the door’s elevation

Let’s now start drawing the elevation of the door 
To do this, you’ll need to configure the Double 
Polyline tool. 

To configure the Double Polyline tool

1. Double-click the Polyline tool 
icon to configure its settings. 
The tool’s dialog box appears.

2. Type 2" in the Width box and 1" in the Off-
set box.

3. Click OK. This will allow you to draw the 
door frame at the same thickness as the door 
jambs in Top view.

To draw an elevation of the door 

1. Click 2 inches away in the X direction from 
the Centerpoint and 0 inches in the Z direc-
tion. 

2. Move the pointer up 6'8" in the ∆Z direction 
and click to set the second point.

3. Move the pointer 3' in the ∆X direction and 
click to set the third point and complete the 
top of the door frame.

4. Move the pointer -6'8" in the ∆Z direction 
and double-click to complete the door 
frame.

Original Centerpoint location

New Centerpoint location

Double 
Polyline 
tool
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Fig. 43 Drawing a door elevation

To draw the door

1. Select the Rectangle Diagonal tool.

2. Snap to the inner corner of the top-right cor-
ner of the door frame. Drag to create a rect-
angle that is -1" in the ∆X direction and -6'7" 
in the ∆Z direction.

WORKING WITH 2D & 3D OBJECTS

We have now constructed the elements we need 
to build a 3D door. The next step is to extrude 
these 2D objects into 3D objects. To extrude a 
2D object into 3D, you first define a set of extru-
sion planes. 

Using 2D and 3D display modes

First, let’s change the display mode of the Draft 
window in the Status Bar to “View 2D & Lock 
3D Objects.” This mode lets you see 3D infor-
mation in the window set to Draft mode. 

To change the display mode

1. In the Display Mode pop-up menu at the left 
end of the Status bar, choose View 2D & 
Lock 3D Objects.

Fig. 44 Using the View Options pop-up menu

First Point

Second Point
Third Point

Complete 
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2. When you change the display mode, a mes-
sage box appears to inform you that all 2D 
objects will now be displayed in red and all 
3D objects will now be displayed in blue. 
Click OK to close the message window.

DEFINING EXTRUSION PLANES

Now, you are ready to begin defining the 3D 
extrusion planes and extruding the objects that 
make up the 3D door.

To define extrusion planes

1. Choose Define Vertical 3D Plane in the 3D 
Plane submenu in the Layout menu. Your 
view of the active window changes to Top 
View. The 2D door you drew should now be 
visible. A line extends from the pointer. The 
line is the first extrusion plane.

2. Move the extrusion plane so it aligns hori-
zontally with the bottom face of the door, 
and then click. Move the mouse up; the 
drawing vector appears, extending from the 
line you just defined. 

3. Align the line pointer with the top face of the 
door and click. The view of the window 
changes back to the original view, which is 
Front view. 

Fig. 45 Setting extrusion planes

To extrude the door into 3D

You have just defined the depth of the door. The 
next step is to extrude the door. 

1. Click the door to select it.

2. Choose Extrude Linear in the Extrude sub-
menu in the Object menu. A blue rectangle 
appears in the Sculpt window. This means 
that a 3D object has been created from the 
2D object.

Now you will repeat the operation, but this time 
we will set the parameters for the extrusion of the 
door jamb. 

To extrude the door jamb

1. Switch to Front view, and then choose 
Define Vertical 3D Plane in the 3D Plane 
submenu. DENEBACAD switches the docu-
ment window to Top view.

2. Move the first extrusion plane, align it with 
the bottom face of the door jamb, and then 
click.

3. Move the second extrusion plane, align it 
with the top face of the door jamb, and then 
click.

4. Select the door jamb object.

Select the check 
box to prevent this 
message from 
appearing again

Top face of 
door

Bottom 
face of 
door
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5. Choose Extrude Linear in the Extrude sub-
menu in the Object menu. A blue rectangle 
— the 3D doorjamb — appears in the Sculpt 
window. If you can’t see the door jamb, 
choose Fit to Window in the pop-up menu in 
the Zoom bar.

Fig. 46 Setting extrusion planes for the door jamb

Creating a Boolean outline

The last object you will need to draw for the 3D 
door is a Boolean outline object. Just as we did 
for the 2D door, we need to create a rectangle 
that will cut an opening into the object that the 
Library Object it is placed into.

To create the door Boolean object

1. Switch to Sculpt mode.

2. Choose Front in the View menu. 

3. Select the Rectangle Diagonal tool.

4. Snap to the bottom-left corner of the door 
frame and drag up to the upper-right corner 
of the door frame and snap to the corner 
point. A blue rectangle now surrounds the 
perimeter of the 3D door. Because you drew 
the rectangle in Sculpt mode, it is extruded a 
based on the active set of extrusion planes. 
In this case, the active extrusion planes are 
equal to the depth of the door frame.

Fig. 47 Drawing the Boolean object for a 3D door

5. Before continuing, change the display mode 
in the Status Bar to View 2D Objects for the 
Draft mode window and View 3D Objects 
for the Sculpt mode window.

Converting the drawing to a Library 
Object

Now that we have finished drawing a 3D door, 
we will convert it into a Library Object and link 
it to the existing 2D door Library Object.

1. Press Command+1 to change the Sculpt 
mode window to Top view. 

2. Press Command+A to select all of the door 
objects.

3. Press Command+G, or choose Group in the 
Object menu, to group the door objects. 

Top face of 
jamb

Bottom 
face of 
jamb
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4. Choose Properties Manager in the Windows 
menu (if necessary) to open the Properties 
Manager. 

5. On the Object Info tab, type the name for the 
door in the Name text box. Type 3' Door, 
the same name that you used for the 2D 
door. By naming the two library groups the 
same, you link them together as one Library 
Object with both 2D and 3D characteristics. 

6. To convert the group into a Library object, 
check the Library type check box and select 
the Object radio button. 

7. To give the door a Boolean feature, check 
the Boolean check box. 

Fig. 48 Designating a 3D door Library Object

As before, the topmost object in the group, the 
rectangle drawn last, will be a subtractive shape. 
The rectangle will cut through the walls to which 
you add the door.

To set the insertion point for the 3D door

The last step for creating the 3D library door is to 
set the insertion point. This point aligns the door 
with a wall opening.

1. In the Sculpt mode window, select the door 
Library Object.

2. Choose Reshape in the Edit menu, or click 
the Reshape button on the Attributes bar. 
The insertion point appears highlighted at 
the center of the Library Object.

3. Drag the insertion point to the midpoint of 
the left side of the left door jamb.

Type 
object’s 
name

Click to 
create 
Library 
Object
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Fig. 49 Setting the insertion point for the 3D Library Object

Saving a Library Object

You should now save the Library Object you 
have created so you can insert it into your next 
document. 

To save the document containing the door 
Library Object

1. Choose Save As in the File menu. In the 
directory dialog box, select the Libraries 
folder in the DENEBACAD folder.

2. Type “Doors” in the Save as text box. Any 
new doors you want to save can be created 
in this document following the same proce-
dures.

3. Click Save to save the document.

Fig. 50 Saving the door Library Object

When you insert the door 
into a wall, the door will 
be centered within the 
wall.

Original insertion point

Move insertion point to here

Enlarged view
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DESIGNING AND RENDERING 5

This chapter demonstrates how you can place 
Library Objects, like the door completed in the 
previous chapter, into a new document. This 
technique lets you use Library Objects in as 
many documents as you like. 

To follow the tutorial lesson in this chapter, open 
the file named “Library.inserts” located in the 
Tutorial folder in the DENEBACAD folder.

To open the library document

1. Launch DENEBACAD if it isn’t running.

2. Press Command+O or choose Open in the 
File menu.

3. In the directory dialog box, open the Tuto-
rial folder inside the DENEBACAD folder.

4. Select the file named “Library.inserts” and 
click Open. A blank document appears in a 
Draft mode window.

DRAWING A STRUCTURE IN 2D

This section describes how to construct a simple 
building in DENEBACAD. The procedure uses a 
Library Object to quickly place a door in the 
drawing in 2D and 3D.

To draw a basic structure, you can draw simple 
shapes, and then combine the shapes into a more 
complex wall outline.

To see dimensions when you draw objects, be 
sure that the Info bar is displayed. If the Info bar 
is not visible, choose the Toolbars command in 
the Layout menu. In the Toolbars dialog box, 
select the Info Bar check box, and click OK. 

To draw shapes for the building’s shell

1. Select the Rectan-
gle Center to Cor-
ner tool in the 
toolbox. 

2. Draw a rectangle 
measuring 19 feet 
by 14 feet. In the Info bar, 19' appears in the 
∆X text box and 14' appears in the ∆Y text 
box when you drag the pointer. 

3. Select the Circle Radius tool. 

4. Draw a circle, setting the center of the circle 
at the lower-right corner of the rectangle, 
and extending the circle until its edge is at 
the midpoint of the right side of the rectan-
gle.

▲ You can use the Snaps menu to snap the 
circle’s center and edge to the exact points 
on the rectangle.

Rectangle 
Center to 
Corner tool

Circle 
Radius tool
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Fig. 51 Aligning a circle to a rectangle

To combine objects to form the shell

1. Select both objects.

2. Choose Unite in the Com-
bine submenu in the Object 
menu. Or, click the Unite 
action button. DENEBACAD 
combines the selected 
objects into one outline.

Fig. 52 Combining object with the Unite command

To set wall thickness using Offset

1. Choose Offset in the Path 
submenu in the Object menu. 
Or, click the Offset action 
button. The Offset dialog 
box appears.

2. Type 6" in the Width box and click OK.

3. To apply a Fill color to the new walls, press 
the Fill Color icon in the Attributes bar. 
Drag to select a Fill color to apply.

LOADING LIBRARY OBJECTS

After completing the structure’s footprint by 
building the exterior walls, you can now load the 
Library Object that will be used to add doors to 
the building. The procedure used to create the 
Library Objects is described in the previous 
chapter.

Vector

Unite action 
button

Original 
objects

United 
objects

Offset action 
button

Object offset 6"
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To open a document and select a Library 
Object 

1. Double-click the Library tool 
in the toolbox. The Library 
palette appears. 

2. Click the Object tab to bring 
it to the front, if necessary. 

3. Choose the Add command in the pop-up 
menu in the Library palette.

4. In the directory dialog box, open the folder 
where you stored the “Doors” file you cre-
ated earlier. If you didn’t create this file, 

open the Tutorial folder inside the 
DENEBACAD folder. Select the file named 
“Doors” and click Open. The Library Picker 
appears. The Library Picker displays and 
lists all Library Objects contained in the 
DENEBACAD document that you selected.

5. Select the object named “3' Door” and click 
Add. This adds the selected Library Object 
to the current document. 

6. Click OK to close the Library Picker.

Fig. 53 Using the Library palette and Library Picker dialog box

To place the door object from the Library

1. The Library palette displays a thumbnail 
sketch of the door object. Click “3’ Door” to 
select it.

2. Move the pointer into the drawing. A grayed 
image of the door’s bounding box follows 
the pointer. Point to the exterior wall at the 
bottom of the drawing and click at the center 

of the wall. A drawing vector appears, 
showing the orientation of the Library 
Object. 

3. Press Shift to constrain the pointer move-
ment and drag to the right in a straight line. 
This places the door in the wall and sets its 
orientation. 

Library tool

Choose the Add command in the 
Library palette pop-up menu.

The Add button in the Library Picker 
adds the selected item.

The selected Library Object appears 
in the Library palette.

Object tab
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Fig. 54 Positioning the door

4. Press Shift and click the wall 
with the Selection tool to 
select both objects.

5. Choose Unite in the Com-
bine submenu in the Object 
menu, or click the Unite 
action button. The door makes a cutout in 
the wall. Also, only one set of selection han-
dles appears around the entire object, 
because the door and the wall have become 
one Boolean object. 

EXTRUDING FROM 2D INTO 3D

When you have a structure in Draft mode, you 
create a 2D building plan. You can then set up 
extrusion planes and extrude the 2D objects into 
a 3D model.

A linked 2D/3D Library Object, like the door 
added to the drawing in the previous section, will 
appear correctly in the 3D model when you 
extrude the wall containing the door.

To define extrusion planes

1. Choose Define Frontal 3D Plane in the 3D 
Plane submenu in the Layout menu. The 
drawing window changes to Front view. 

2. A line extending from the pointer indicates 
the first plane that will limit extrusions. 
Align the line with the Centerpoint of the 
drawing and click to set the extrusion plane. 

3. Move the pointer 10 feet up on the Z axis 
(until 10' appears in the ∆Z box in the Info 
bar). Click to set the second extrusion limit 
for a 10-foot-high wall. The drawing win-
dow changes back to Top view.

Position door here

Closeup of door in wall

Unite 
action 
button

Cutout of door in wall
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Fig. 55 Setting extrusion planes

To extrude the walls

1. Select the building in the drawing window.

2. Choose Extrude Linear in the Extrude sub-
menu in the Object menu. DENEBACAD 
extrudes the selected objects according to 
the extrusion planes set up in the previous 
procedure. This creates a 3D structure from 
the 2D objects, and the original 2D objects 
remain in the Draft mode drawing window.

DISPLAYING SCULPT AND RENDER MODES

You can open additional windows when you 
want to view a design from more than one point 
of view or when you want to work in more than 
one mode. Objects that you draw in Draft mode 
and then extrude appear when you open a win-
dow set to Sculpt mode or Render mode.

To open Sculpt and Render mode windows

1. Choose Show Sculpt in the Window menu. 
A new window set to Sculpt mode appears.

2. Choose Show Render in the Window menu. 
A new window in Render mode appears.

3. Choose Tile in the Window menu. 
DENEBACAD arranges the windows so all 
three are visible, with the Draft mode win-
dow along the left of the screen, the Sculpt 
mode window at the upper right, and the 
Render mode window at the lower right.

▲ This step is not necessary when the pref-
erence “Auto-tile windows” is selected.

4. Click in the Draft mode window to make it 
active. Choose Fit to Window in the pop-up 
menu in the Zoom bar.

5. Click in the Sculpt mode window. Choose 
Front in the View menu. Press 
Command+Option+W to set the zoom so 
you can see all of the drawing. The window 
shows the wall elevation, including the door 
library object.

Set the first extrusion plane at the Centerpoint

Centerpoint

Set the second extrusion plane at ∆Z = 10'

Zoom pop-up 
menu

Zoom bar
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RENDERING A 3D SCENE

You can set the focal point, or “camera” position, 
to view a rendered drawing in the Render mode 
window. When you change the focal point, 
DENEBACAD renders the scene from the new 
point of view.

To set the horizontal focal point

1. Click in the Render 
window. The toolbox 
changes to display 
four tools that are 
used in Render 
mode.

2. Select the Horizontal Focal 
Point tool. The view in the 
Render window changes to 
show the drawing from Top 
view in Sculpt mode.

3. Adjust the zoom if necessary so you can see 
the entire drawing in the window. You 
might want to zoom out slightly so you can 
see some of the area outside the building.

4. A symbol with an extended red line appears 
in the drawing (figure 56). The symbol is the 
horizontal focal point from which an 
observer views the rendered scene. The red 
line is the direction of view. Click in the 
drawing to set a new focal point. 

5. Two lines appear angled outward from the 
point you clicked. The area inside these lines 
is the field of view. The drawing vector 
between the lines indicates the angle of 
view. Click to set the view angle. The win-
dow displays a rendered scene based on the 
new horizontal focal point.

Fig. 56 Setting the focal point

Render 
mode 
tools

Horizontal 
Focal Point 
tool

Click to set new focal point

Limit of field of view

Center of field of view (vector)

Original horizontal focal 
point
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To set the vertical focal point

1. Select the Vertical Focal Point tool. The 
Render mode window changes to show the 
building elevation from Front view in Sculpt 
mode. A symbol with a red line appears in 
the drawing. The symbol represents the 
height of an observer; the line shows the 
direction of view.

2. Move the pointer to adjust the vertical view 
position. As the pointer moves, a large cross 
shows the new vertical position. The cross 
moves only up and down in the drawing. 
Click to set the new vertical position.

3. Two lines appear angled outward from the 
new vertical focal point to indicate the verti-
cal field of view. A drawing vector extends 

from the new position and indicates the ver-
tical angle of view. Move the pointer to 
adjust the view angle, and then click to set 
the new vertical focal point. The window 
displays a rendered scene based on the new 
vertical focal point.

Fig. 57 Focal points and Hidden Line rendering

Move the pointer to set the height of the view with the 
Vertical Focal Point tool.

Original focal point

Horizontal focal point

Original focal point

Vertical focal point

3D model rendered with Hidden Line command
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HIDDEN LINE RENDERING

A final step in the visualization process is to view 
a Hidden Line rendering of a project you design. 

To view a Hidden Line rendering

1. Make sure the Render mode window is the 
active window.

2. Choose Hidden Line in the Rendering menu. 
DENEBACAD performs the calculation to 
remove hidden lines, which can require sev-
eral seconds, depending on the complexity 
of the drawing, and then displays the ren-
dered scene.

Fig. 58 A Hidden Line rendering
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MODELING WITH SWEEP METHOD 6

This chapter shows you how you can create a hip 
roof using the Sweep extrusion method. 

The tutorial shows you how to convert a shape 
into a sweep section, and then how to use the 
Sweep command to extrude the sweep section 
along a path.

Opening the tutorial document

To follow this tutorial, open the file named 
“Roof.start” located in the Tutorial folder in the 
DENEBACAD folder.

To open the document

1. Launch DENEBACAD if it isn’t running.

2. Press Command+O or choose Open in the 
File menu.

3. In the directory dialog box, select the file 
“Roof.start” in the Tutorial folder and click 
Open. DENEBACAD opens the file. 

4. Choose Toolbars in the Layout menu, select 
all the options, and then click OK in the 
Toolbars dialog box. 

CREATING A HIP ROOF USING A SWEEP EXTRUSION

In this section, you’ll learn how to create a sweep 
section. In the Sweep extrusion method, you use 
one or more objects as a sweep section, which is 
a cross-section of the extruded object.

CREATING A SWEEP SECTION

You can make a sweep section from any objects, 
including a single object or many objects that 
have been unified with the Group command. In 
the tutorial document, the sweep section object 
has been created. The following procedure shows 
you how to designate the existing object as a 
sweep section.

To create a sweep section

1. After opening the file “Roof.start,” you’ll 
see a Draft mode window in Top view with 
four objects: three rectangles, and a smaller 

object to the left of the rectangles. To make 
the smaller object into a sweep section, you 
use the Properties Manager.

▲ If you do not see all of the objects when 
you open the file, you can choose Fit to 
Window in the Zoom bar or press Com-
mand+Option+W.

2. Select the Zoom tool in the toolbox and drag 
a box around the smaller object to the left of 
the rectangles. DENEBACAD zooms in on 
the area. This gives you a close-up of the 
object to be used as a sweep section.

Fig. 59 Sweep section close-up
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Fig. 60 Roof.start tutorial

3. Double-click the object. This opens the 
Properties Manager and selects the object. If 
necessary, move the Properties Manager so 
you can see the entire object.

4. In the Properties Manager, click the Info tab 
to bring it to the front. 

5. To designate the object as a sweep section, 
click the Section checkbox. The sweep sec-
tion will appear in the Sweep Sections pal-
ette.

6. In the Name text box, type “Hip roof.” 
When you name a sweep section, try to indi-
cate its purpose. After typing the name, 
press Enter. The name you assigned to the 
section appears in the Object pop-up menu 
on the Info tab, because the object is 
selected.

7. To close the Properties Manager, click its 
close box at the upper-left corner in the title 
bar.

Fig. 61 Info tab

Objects representing 
the sweep path and 
extrusion section in 
Draft mode, Top 
view.

Sweep section

Click to 
designate a 
sweep section

Type “Hip roof”
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Fig. 62 Sweep section settings

By clicking the Section checkbox, you’ve made 
the object a sweep section.

Setting the insertion point for a sweep 
section

Before you use a sweep section, you might need 
to adjust its insertion point. This is important 

because it affects the orientation of the sweep 
section along the extrusion path.

To adjust the sweep section’s 
insertion point

1. Click the Reshape action button on the 
Attributes bar. You can do this because the 
section remains selected when you close the 
Properties Manager. DENEBACAD puts the 
sweep section into Reshape mode. It also 
displays the object’s creation points, and 
shows the sweep insertion point. The sweep 
insertion point appears as a black dot in the 
center of the object’s sloping line.

2. Move the tip of the pointer until it’s on the 
object. Press the Spacebar to activate the 
object’s snap points. The makes the drawing 
vector snap to the end points of segments of 
the object. 

3. Drag the insertion point to the point where 
the slope of the hip roof section meets the 
gutter (figure 64). The drawing vector snaps 
to this point as you drag toward it.

Fig. 63 Dragging the sweep insertion point with snap points active

Insertion point

Drawing vector
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Fig. 64 Sweep insertion in position

CREATING A HOUSE OUTLINE 
FOR THE ROOF MODEL

To create a roof you can extrude it directly on top 
of a house, using the perimeter of the house as a 
sweep path. The Unite command makes it easy 
to combine basic shapes into the outline of a 
structure. 

To create a sweep path

1. Choose Fit to Window in the Zoom pop-up 
menu. DENEBACAD increases the zoom 
level so you can see the rectangles and the 
sweep section.

2. Drag a box around the three rectangles 
(figure 65). DENEBACAD selects the rectan-
gles, and a bounding box appears around 
each rectangle. 

Fig. 65 Selecting rectangles

3. Press Command+U. This is a shortcut for 
the Unite command in the Combine sub-
menu. DENEBACAD unites the rectangles 
into a single shape. This shape becomes the 
outline of a building that you will use as the 
sweep path for the roof.

Insertion point
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Fig. 66 United object

4. Deselect the united object by clicking in an 
empty area of the document.

5. Choose the Sweep extrusion method by 
selecting the Sweep action button in the 
Attributes bar. 

▲ When you select the Sweep extrusion 
method, the Sweep Sections palette appears. 
This palette displays the sweep section des-
ignated earlier as “Hip roof.” To see your 
objects clearly, you can drag the palette to 
move it out of the way.

6. Double-click the Sweep action button to 
open the Extrude Options dialog box.

7. Make the settings in the Extrude Options 
dialog box match the illustration (figure 68), 
and then click OK.

8. Select the house (the object you combined). 

9. To sweep the section around the house, click 
the Sweep action button once. DENEBACAD 
sweeps the section around the selected path.

Note: You won’t see the result of the sweep 
extrusion until you switch to Sculpt and Render 
modes as described later.

Fig. 67 Sweep action button and Sweep Sections 
palette

’

Fig. 68 Sweep extrusion settings

Action buttons

Sweep button

Selected sweep 
section

Click Stand Up in 
Plan

Type 100 in Scale 
text boxes

Select all the Solid 
Faces buttons
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OFFSETTING AND 
EXTRUDING WALLS

Extruding the roof with the Sweep method cre-
ates a 3D object. To make the house match the 
hip roof, you can turn the simple path into walls, 
and then extrude the walls into 3D to meet the 
roof.

This section explains how to offset the house out-
line to make walls, and how to give height to the 
walls using predefined extrusion planes.

To offset an outline for walls

1. Select the house object, which became dese-
lected after the Sweep procedure.

2. Press Command+Shift+O or choose the Off-
set command in the Path submenu in the 
Object menu. The Offset dialog box 
appears.

3. Make the value in the Width text box 
3 31/32". Type 8" in the Offset text box. 
Click OK. DENEBACAD offsets the path 8 
inches.

Fig. 69 An offset path for walls

To extrude the walls

1. In the 3D Plane pop-up menu on the Status 
bar, choose the 8' High Wall, which is a pre-
defined set of extrusion planes for Linear 
extrusions.

Fig. 70 Predefined extrusion planes

2. Select the house, and type Com-
mand+Shift+E, the shortcut for the Linear 
Extrude command. DENEBACAD extrudes 
the walls from 0' to 8' feet high into 3D 
space.

As mentioned previously, you won’t see the 
results of the sweep and linear extrusions until 
you switch to Sculpt and Render mode in the 
next section of the tutorial.
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VIEWING THE HOUSE MODEL 
AND RENDERING

To see the results of the roof and wall extrusions, 
you can open Sculpt and Render mode windows.

In these windows, you can see now that the 
extruded walls meet the hip roof.

◆ To open a Sculpt mode window: Choose 
Show Sculpt in the Window menu.

◆ To open a Render mode window: Choose 
Show Render in the Window menu. 

▲ Notice that DENEBACAD arranges the 
windows so you can see all three windows 
on-screen. This happens when the setting 
“Auto-tile windows” is selected in the Pref-
erences dialog box.

In the window titled “Roof.start-Sculpt-Top,” 
you can see the results of extruding the hip roof 
(figure 71). 

Fig. 71 The roof visible in Draft and Sculpt windows
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VIEWING A WIREFRAME 
RENDERING

Because the roof document now contains 3D 
objects, you can develop isometric and perspec-
tive renderings in the Render window.

By working in Render mode, you can view the 
building from any perspective. You can create 
your own perspectives by setting focal points 
wherever you want as you follow the procedures. 

To generate an isometric perspective

1. Choose the Isometric Render tool in the 
Rendering toolbox. DENEBACAD creates 
an isometric Wireframe rendering in the 
Render window.

Fig. 72 Render mode tools 

2. To center the rendering in the 
window, you can click the 
zoom box at the far right of the 
Render window’s title bar. This expands the 
window to fill the screen, and should give 
you a full view of the Isometric Wireframe 
rendering (figure 73).

Fig. 73 Hip roof renderings

Isometric Render tool

Final Isometric 
Wireframe rendering

By using the Solid command in the Render menu and 
the Sunlight option in the Rendering Options dialog 
box, you can create a perspective Solid rendering of the 
house with shadows and lighting effects
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MODELING A STRUCTURE 7

This chapter is a tutorial that describes how to 
model a building from the ground up. The proce-
dures include using drawing tools, extrusions, 
and Library Objects to create a structure. Then, 
you place lights and furniture, and apply surface 
materials to the model, before creating a final 
solid rendering. 

To open the model file

1. Launch DENEBACAD if the program isn’t 
already running. 

2. To open the file for this tutorial, press Com-
mand+O. In the directory dialog box, go to 
the Tutorial folder in the DENEBACAD™ 
folder. 

3. Select the document named “Tutorial.start” 
and click Open. 

DENEBACAD displays the document in a Draft 
mode window set to Top view. The options and 
grid settings are already configured for the 
project. 

◆ To display all toolbars: If the Info bar and 
Status bar aren’t displayed on screen, choose 
Toolbars in the Layout menu. In the Toolbars 
dialog box, select the four options, and then click 
OK. 

DRAFTING A DESIGN FOR MODELING

In DENEBACAD, you use the same working 
method whether you intend to produce 2D plans 
or a completely rendered scene. 

To draft wall sections

1. Select the Single Polyline tool. 

2. Click at the Centerpoint of the drawing 
(X=0, Y=0).

3. Move the pointer up; the drawing vector 
appears. Click at ∆X=0' ∆Y=30'.

4. Move the pointer to the right and click at 
∆X=38' and ∆Y=0', and then press Return to 
complete the polyline. 

This object will become two walls of a building.

Fig. 74 Drawing a polyline wall section

38’, 0’ 0’, 30’
ClickClick

Click 0’, 0’
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5. Choose Offset in the Path submenu in the 
Object menu. In the Offset dialog box, type 
8" in the Width box and 0" in the Offset box, 
and then click OK. 

To draw a ground plane

1. Select the Rectangle Diagonal tool. Click at 
X=-1' (1 foot left of the Centerpoint) and 
Y=31' to set the first point. 

2. Click at ∆X=40' and ∆Y= -32' to complete 
the rectangle. 

To insert a door from the library 

Using a library object lets you quickly add a door 
and windows to the building’s walls. 

1. Double-click the Library tool 
in the toolbox. The Library 
Manager appears. The 
Library Manager contains 
the Library Objects stored in 
this document. 

2. Click the Object tab to bring it to the front, if 
necessary. Be sure “Display by Name” is 
selected. Then, select the name “Door” in 
the scrolling list (fig. 75). 

3. Move the pointer to X=8' and Y=30' and 
click to insert the door into the drawing. 

4. Press Shift and drag to the right until the 
drawing vector appears. This aligns the door 
within the wall. 

Fig. 75 Library Object selection

To insert windows from the library

1. In the Library Manager scrolling list, select 
the “3'x 4' Window” object.

2. Move the pointer to X=35' and Y=30' and 
click to insert the window into the drawing. 

3. Press Shift and drag to the right until the 
vector line appears. This aligns the window 
within the wall. 

4. Click the close box to close the Library 
Manager. 

To duplicate windows in an array

With one window inserted, you can use the Lin-
ear Array command to evenly space copies of the 
window along the wall.

1. Select the window object. 

2. Choose Linear Array in the Position sub-
menu in the Object menu. 

3. Move the pointer to the center of the win-
dow at X=35' and Y=30'. Click to define the 
starting point of the linear array. 

Library 
tool

Selected object

Object tab

Select Display by 
Name
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4. Move the pointer to ∆X= -20' and ∆Y=0'. 
Click to set the end point of the array. The 
Linear Array dialog box appears. Type 2 in 
the “# Copies” box. 

5. Click the Inclusive button. This will evenly 
distribute the number of copies you specify 
within the distance defined by the drawing 
vector. The result is three windows spaced 
evenly along the wall.

Fig. 76 Copying window objects

COMBINING OBJECTS AND 
WALLS

The commands in the Combine submenu let you 
create Boolean groups by adding and subtracting 
objects from each other.

To combine objects into the wall

1. Hold down the Shift key and click each win-
dow object, the door object, and the wall 
objects to select them. 

▲ You can press Command+A to select all 
the objects in the drawing, and then press 
Shift and click the ground plane object to 
deselect it.

2. Choose Unite in the Com-
bine submenu in the Object 
menu, or click the Unite 
action button. 

▲ The Unite command 
makes a new Boolean object 
by combining the door and windows with 
the wall. 

▲ The door and window Library Objects 
include invisible rectangles. The rectangles 
define the area to be cut out when you apply 
a Combine submenu command to the 
Library Objects and a wall object.

The drawing vector indicates the 
direction and distance for copying with 
the Linear Array commandVector

Original windowCopy 1Copy 2

The copies appear evenly distributed 
within the distance defined by the 
drawing vector

Unite 
action 
button
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Fig. 77 Boolean objects in a wall

PLACING ROOF TRUSSES 

By inserting a roof truss from the Library Man-
ager, and using the Linear Array command to 
quickly distribute trusses over the structure, we 
can construct a roof framework in only a few 
steps. 

To insert a roof truss library object

1. Double-click the Library tool in the toolbox 
to open the Library Manager. 

2. Select the “Truss” item in the Library Man-
ager scrolling list.

3. Move the pointer to X=0' and Y=30' and 
click the mouse to place the roof truss. 

4. Press Shift and drag straight up until the 
drawing vector appears to align the truss 
with the left wall. 

5. Click the close box to close the Library 
Manager.

Fig. 78 Inserting a roof truss

To array roof trusses

1. Select the roof truss inserted in the previous 
steps. 

2. Choose Linear Array in the Position sub-
menu in the Object menu. 

3. Move the pointer to X=0' and Y=30' over 
the center of the wall. Click to set the start-
ing point for the array of trusses. 

4. Move the pointer to the right to ∆X=2' and 
∆Y=0'. The drawing vector indicates the dis-
tance and direction for the array operation. 

5. Click to define the offset distance of the 
array. The Linear Array dialog box appears.

6. Type 19 in the “# Copies” box and click 
Offset. This creates an offset array, placing 
the specified number of copies the same dis-
tance apart. There are now 20 trusses above 
the walls.

Doorway cutout Window and cutout

Door

Click at 0, 30

Vector
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Fig. 79 Arraying roof trusses

INSERTING FURNITURE FROM 
THE LIBRARY

While Library Objects can speed the design of 
elements such as walls and roofs, they can also 
be used to place interior design elements, such as 
couches and other furnishings. 

To insert a couch library object

1. Double-click the Library tool in the toolbox 
to open the Library Manager. 

2. Select the item named “Couch” in the 
Library Manager scrolling list. 

3. Move the pointer to X=28' and Y= 20' and 
click to place the library object. Drag to the 
right in a straight line until the drawing vec-
tor appears; this sets the object’s orientation.

4. To insert another couch, select the Library 
tool again; the “Couch” should still be 
selected in the Library Manager. Click at 

X=34' and Y=14' to place the object. This 
time, drag downward in a straight line until 
the drawing vector appears. 

5. Select “Rug” in the Library Manager. Click 
at X=28' and Y=13' to place the object in the 
drawing. Drag in a straight line to the right 
to set the orientation. 

6. Select “Coffee Table” in the Library Man-
ager. Click at X=28' and Y=13' to place the 
coffee table in the drawing. Drag straight to 
the right to set the table’s orientation. 

7. Close the Library Manager.

Fig. 80 Placed furniture Library Objects 

Vector

Truss shadow
Click at 2, 0
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EXTRUDING THE PLAN INTO 3D 

So far, this project has been designed in Draft 
mode with all objects created in 2D. Now you 
can extrude the drawing into 3D Sculpt mode. To 
be able to see the objects in different modes, you 
can open additional windows. 

To view Sculpt and Render windows

1. Choose Show Sculpt in the Window menu. 
A window appears in Sculpt mode. 

2. Choose Show Render in the Window menu. 
A new window in Render mode appears. 

3. Choose Tile in the Window menu. 
DENEBACAD arranges the three windows 
on screen so all are visible. This step isn’t 
necessary if the preference “Auto-tile win-
dows” is selected.

4. Click the Draft window to make it active. 
Press Command-Option+W (shortcut for the 
Fit to Window command) so you can see 
your entire drawing in the window.

Fig. 81 The Draft mode window active
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EXTRUDING WITH PRESET 
EXTRUSION PLANES 

Before extruding the objects in the building into 
3D, you can define extrusion planes to set the 
height of a building’s walls. You can save vari-
ous sets of extrusion planes in a document, and 
then select one of the saved sets as needed. 

To extrude parts of the building in this document, 
you can use several preset extrusion planes. 

To extrude the building’s slab

1. Choose the pre-defined set of extrusion 
planes named “1' Thick Slab” in the 3D 
Plane submenu in the Layout menu. You 
can also select the pre-defined extrusion 
planes from the 3D Plane pop-up menu in 
the Status Bar.

2. Select the rectangle representing the slab 
under the building.

3. Choose Linear in the Extrude submenu in 
the Object menu. DENEBACAD extrudes the 
rectangle into a 1-foot-thick slab, which 
appears in the Sculpt mode and Render 
mode windows. 

To extrude the building’s walls

1.  Choose the pre-defined extrusion plane 
named “10' Tall Exterior Wall” in the 3D 
Plane submenu in the Layout menu. 

2. Select the wall object.

3. Press Command+Shift+E or choose Linear 
in the Extrude submenu in the Object menu. 
The 3D wall appears in elevation in the 
Sculpt mode window and in perspective in 
the Render mode window. 

Fig. 82 Extruded walls, door, and windows

EXTRUDING 2D/3D LIBRARY 
OBJECTS

You have already extruded the objects that 
needed to be extruded using preset extrusion 
planes. The next step is to extrude Library 
Objects that already have 3D information in 
them, such as the 2D/3D Library Objects in the 
drawing. 

To extrude the doors, windows, and roof 
trusses

1. Click the Draft mode document window to 
make it active.

2. Press Command+A to select all the objects 
in the scene. 

3. Press Shift and click the wall object and then 
the slab object to deselect them, because 
these have already been extruded.

4. Press Command+Shift+E or choose Linear 
in the Extrude submenu in the Object menu. 
The Library Objects now appear as 3D 
objects in the Sculpt and Render mode win-
dows. 
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Fig. 83 Wireframe rendering of 3D objects

USING 3D LIBRARY OBJECTS

The last items to be included in the structure are 
3D-only Library Objects. These are Library 
Objects that contain only 3D information, so 
these objects are used in Sculpt mode.

To insert 3D Library Objects

1. Click in the document window set to Sculpt 
mode to make it active. If the window does 
not show Top view (the title bar doesn’t say 
“Name-Sculpt-Top”), choose Top in the 
View menu. 

2. To make the model fit in the window, press 
Command+Option+W, the shortcut for the 
Fit To Window command in the Zoom pop-
up menu.

3. Double-click the Library tool in the toolbox. 
The Library Manager appears. Several items 
which weren’t listed when the Draft mode 
window was active now appear in the 
Library Manager’s scrolling list. 

4. Select the “Balcony” Library Object. Click 
at X=0' and Y=12' to place the balcony. 
Then press Shift and drag in a straight line to 
the right until the vector arrow appears. This 
sets the orientation of the balcony. The bal-
cony appears in the Sculpt window and in 
the rendering of the room shown in the Ren-
der mode window.

5. To insert a set of lights, select the “Lights” 
object in the Library Manager. Click the 
pointer to X=20' and Y=15', click to insert 
the object, then drag straight to the right to 
set the orientation. 

6. To insert a set of spot lights, select the “Spot 
Lights” Library Object. Click at X= 27' and 
Y=8' to place the object, and then drag 
straight to the right to set its orientation. 
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7. Finally, to insert the roof and finish the 
model, select the “Roof” Library Object. 
Click at X=0' and Y=9' to place the object, 
and then drag straight to the right to set its 
orientation. 

 

Fig. 84 Preview in Library Manager

APPLYING 3D SURFACE MATERIALS

Before producing a final rendering of the model, 
you can apply materials to the surfaces of the 3D 
objects. 

All of the Library Objects that have been inserted 
into the model already have surface materials. 
You can apply other surface materials to the 
walls and the floor. 

To create a tiled floor

1. Be sure the Sculpt mode window is active 
and is set to Top view. 

2. In the Attributes Bar, press the Surface 
Materials button and drag into the drawing 
area to float the Fill palette. 

3. In the Sculpt window, select the floor object. 

4. In the Fill palette, click the Materials tab. 
Scroll through the surface material swatches 
and notice the names of the surface materi-
als in the Name text box as you select differ-
ent surface materials. Click the “Checkers” 
swatch to apply the surface material to the 
floor. 

5. In the pop-up menu in the Fill palette, 
choose Cubic. Select the Set Direction 
checkbox in the Fill palette.

6. Move the pointer to the upper-left corner of 
the floor, press Shift, and drag to the right of 
the object. This sets the direction of the sur-
face material (fig. 86).

Preview of 
selected object

Balcony object 
selected

Surface Materials button
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Fig. 85 Applying a surface material

Fig. 86 Setting the surface material direction

To apply a wall material 

1. Select the wall object. 

2. On the Material tab, scroll through the mate-
rials and select the material named “Stucco 
Wall.” 

3. From the Surface Mapping pop-up menu, 
choose Cubic. Select the Set Direction 
checkbox. 

4. Move the pointer to the upper-right corner 
of the wall. Press Shift and drag in a straight 
line to the right.

CREATING A FINAL RENDERING 

When a model is complete and you have placed 
the objects, lights, and surface materials that you 
want to use, you can produce a Solid rendering. 
DENEBACAD’s rendering engine generates 
photo-realistic renderings, complete with trans-
parency, reflectivity, gloss, and shadows.

 To render the model

1. Click the Render mode document window to 
make it active.

2. Choose Solid in the Rendering menu. The 
program will calculate the scene, which can 
take several minutes, depending on the 

speed of the system. When complete, the 
final rendered image appears in the Render 
window. 

3. To save a picture of the rendering, choose 
Copy in the Edit menu. Switch to the Draft 
mode window. Choose Paste in the Edit 
menu. A copy of the rendering is now pasted 
into the Draft drawing.

Material swatches

Materials tab

Choose Cubic

Select Set Direction

Name of Selected 
surface material

Vector

Floor

Truss
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VIEWING FINISHED RENDERINGS

If you weren’t able to complete this tutorial or 
didn’t get the results you expect, you can still 
view a complete rendering of the final result.

To view a fully rendered scene:

1. In DENEBACAD, choose Open in the file 
menu.

2. In the directory dialog box, open the Tuto-
rial folder. Select the file named “Tutorial 
Rendering” and click Open. A document 
opens in Draft mode, with a “picture” of the 
fully rendered scene.

3. To view other types of rendering from the 
same perspective, choose Wireframe or Hid-
den Line in the Rendering menu.

Fig. 87 A Solid rendering of the building
CREATING A FINAL RENDERING 81



Fig. 88 A Hidden Line rendering of the building

To view a QuickTime VR scene

1. Locate the file named “Tutorial QTVR” in 
the Tutorial folder.

2. Double-click the file icon to launch the 
QuickTime VR application and display the 
stereoscopic rendering of the scene. 

The QuickTime VR application is included in the 
DENEBACAD folder so you can view the Quick-
Time VR rendering. If you view the scene with 
stereoscopic glasses, you see true a true 3D ren-
dering, and QuickTime VR lets you tilt and pan 
to see a 360-degree view of the rendered model.

FINISHING UP

Congratulations on finishing this introduction to 
the basics of DENEBACAD. You can use the 
Save As command to save your project with a 

new name. Do not use the Save command unless 
you want to replace the tutorial file with your 
version.
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SETTING UP A PROJECT 8

This chapter presents an overview of options you 
can configure in DENEBACAD. Using the work-
ing drawings of a house as an example, this chap-
ter explains how to specify a document’s 
measurement system, output settings, grids, layer 

structure, and classes, as well as how to define 
extrusion planes for creating 3D models. It also 
describes situations in which you can use Librar-
ies, layers, and classes to organize a project.

SETUP OVERVIEW

To start using DENEBACAD, double-click the 
DENEBACAD application icon. 

When DENEBACAD begins running, the program 
opens a Draft mode window. The window’s title 
bar displays “Untitled-Draft-Top.” You can con-
figure all of the following settings with this win-
dow active. 

The following are brief descriptions of the types 
of settings you probably want to configure when 
you start a new project. Later sections in this 
chapter go into greater detail on these topics.

Units setup Choose the Units Setup command 
in the Layout menu to select the measurement 
system and the units of measure you want to use 
in the document. For details, see “Drawing scale 
and measurements” on page 85.

When you launch DENEBACAD the first time, 
the US measurement system is selected, and the 
program uses feet and decimal inches in dimen-
sions and all other measurements. If you nor-
mally work with this configuration, you can skip 
the Units Setup step.

Output setup Choose the Output Setup com-
mand in the Layout menu to select the output 
scale and set the number of pages for printing. 
For details, see “Output setup” on page 86.

Grid setup If the Show Grid command is 
active, DENEBACAD displays a grid of dots 
based on the current units and measurement sys-
tem. Choose the Grid Setup command in the 
Layout menu to specify the grid spacing. For 
details, see “Grid setup” on page 88.

Layers Choose Layer Manager in the Window 
menu to set up layers. For details, see “Library 
items” on page 88.

Other configuration steps

After you set up measurement units, output, the 
grid, and layers, you can begin to draw. There 
are, however, other things you might want to set 
up that will save time: You can import Library 
Objects and Symbols, establish classes, and 
define 3D planes before you start to draw.

Library items If you want to use existing 
Library Objects and Symbols in your document, 
you can double-click the Library tool to open the 
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Library Manager, and use the Add command in 
the pop-up menu to import the Library items. For 
details, see “Library items” on page 88.

Classes You can choose the Class Manager 
command in the Window menu to set up classes. 
If you do not plan to categorize objects in your 
drawings so you can create reports, you can skip 
this step. For details, see “Setting up classes” on 
page 90.

Extrusion planes If you want to model 3D 
objects, use the 3D Plane submenu commands to 
define and save extrusion planes. For example, 
you can set up extrusion planes for the height of 
walls, a porch floor and porch railings. 

You can choose saved extrusion planes from a 
pop-up menu on the Status bar. The current 
extrusion planes set the depth of objects that you 
extrude in draft mode and model in Sculpt mode. 
For details, see “Setting up 3D extrusions” on 
page 91.

USING DOCUMENT TEMPLATES

After you configure drawing and document set-
tings you can create a template, which is a spe-
cial kind of document that incorporates all the 
current DENEBACAD settings. 

Templates can help you save time. By using a 
template to start a project, you avoid having to 
configure the same settings again. For example, 
you can save the drawing scale, layer structure, 
grid settings, and other options for a house draw-
ing, and use the template again when you start 
the working drawings of another house.

To create a document template

1. After establishing the document settings that 
you want to save, choose the Save As com-
mand in the File menu.

2. In the directory dialog box, be sure to select 
the DENEBACAD file format. Type a name 
for the document and click Save to store the 
document on disk. 

After you save a template, make the saved docu-
ment a stationary pad. When you open a station-
ary pad, an untitled document appears to prevent 
you from overwriting the template.

1. Select the template document’s icon and 
choose Get Info in the File menu in the 
Finder. The Get Info dialog box appears.

2. Select the Stationary pad check box and then 
choose Close in the File menu to close the 
Get Info dialog box.
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DRAWING SCALE AND MEASUREMENTS 

You can use the Units Setup command in the 
Layout menu to open the Units Setup dialog box. 
This dialog box lets you choose the U.S. or met-
ric measurement system, the units and format for 
linear and angular measurements, and specify the 
accuracy to be used for measurements in the cur-
rent document.

In U.S. versions of DENEBACAD, the U.S. mea-
surement system is the default system, and the 
program displays measurements in feet and deci-
mal inches, in the form 15'-3.5". 

Measurement system If you use feet and deci-
mal inches in your work, you do not need to 
change the settings in the Units Setup dialog box. 
If you use metric measurements, choose Metric 
in the System pop-up menu.

Linear measurement formats If you prefer a 
format for measurements other than the default 
feet and decimal inches, choose the format you 
want to use from the Linear pop-up menu. You 
can choose feet and fractional inches; decimal 
inches only; or fractional inches only.

For example, to create the plan and interior ele-
vations of a house, you might want to change the 
format for measurements from feet and decimal 
inches to feet and fractional inches. To do this, 
choose 1'3-1/2" in the Linear pop-up menu. 

To create cabinet and millwork drawings for a 
house, you might want to choose inches as the 
units. In this case, choose 15 1/2" or 15.5" in the 
Linear pop-up menu.

Displaying unit marks When you select only 
inch or foot measurements, select the Show Unit 
Marks check box if you want to display tick 
marks for feet and inches in measurements and 
dimension text. This option is not available when 
you choose either of the combined foot and inch 
formats in the Linear pop-up menu.

For a millwork drawing in inches, you might not 
want tick marks in dimension text. In this case, 
you would deselect the Show Unit Marks option.

Fig. 89 Show Unit Marks option

Select U.S. or 
metric units
Select the format 
for linear 
measurements

3.05 Mts

120.00 120"
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U.S. dimension (inches)
Show Unit Marks not 
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U.S. dimension (inches)
Show Units Marks 
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Metric dimension 
(meters)
Show Unit Marks 
selected

Metric dimension 
(meters)
Show Unit Marks not 
selected
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You might find that you don’t need to change 
many settings in the Units Setup dialog box to 
create working drawings of a house, for example. 
The default measurement system, linear and 
angular units, and accuracy are appropriate for 
many projects. You probably won’t need to 
select the Scientific Notation option, which dis-
plays numerical values as a base value and base 
10 exponent, except in special situations.

Setting default measurement options

If you want the settings in the Units Setup dialog 
box to be the default settings for every new docu-
ment, click the Default button.

Refer to the Units Setup command in the Layout 
menu chapter for more information about the 
options and settings in the Units Setup dialog 
box.

OUTPUT SETUP

You can use the Output Setup command to set up 
a project for printing. In DENEBACAD, you print 
or plot in Draft mode.

The Output Setup dialog box lets you select a 
scale for printing the document. You can also 
specify the size of the printable area and the 
arrangement of pages (if the document must be 
divided into pages for printing). 

Setting the scale for a document

You can select the most common architectural 
and engineering scales from the Architectural or 
Engineering pop-up menus in the Output Setup 
dialog box. Or, you can enter a custom scale in 
the Custom text box.

If you are setting up a document for plans and 
interior elevations of a house, you probably want 
to select the 1/4"=1'-0" scale. To develop details 
of the house, you might select the 1-1/2"=1'-0" 
scale.

The document scale you select in the Output 
Setup dialog box affects an entire document. If 
you are accustomed to working in more than one 
scale, you can set up a document for each scale.

Working within the printable area

It is helpful to set a document’s output scale and 
specify the number of pages in the document so 
you can work within the printable area in the 
Draft window. 

Two factors affect the size and configuration of 
the printable area in Draft mode: The settings for 
Document Scale and Pages in the Output Setup 
dialog box, and the page size and orientation 
specified in the Page Setup dialog box. 
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To see the printable area in Draft mode, select 
“Display Page Breaks on Screen” in the Output 
Setup dialog box. With this option selected, 
DENEBACAD displays one or more gray boxes in 
the Draft window to represent page boundries.

Setting page boundaries

You can control how DENEBACAD divides the 
document into pages for printing, and how the 
pages are arranged when you output them. 

You can set up a document so that the plan prints 
on one page, elevations print on another, and ren-
derings print on a third page, for example 
(figure 90).

To set up the page arrangement, type the number 
of pages you want to print in the “Pages” and “by 
Pages” text boxes in the Output Setup dialog 
box. The value in the first “Pages” text box sets 
the number of pages across; the value in the sec-
ond text box sets the number of pages down. To 
set up two pages side-by-side, for example, type 
2 in the first box and 1 in the second box.

When you create a new document, the values in 
the “Pages” and “by Pages” boxes are set to 1. 
This means DENEBACAD prints one page, with 
the center at the Centerpoint of the current view.

To adjust the location of the printable area in the 
Draft window, choose Set Print Area in the File 
menu. Move the pointer to position the gray bor-
der that represents page boundaries, and then 
click to set the printable area.

When the printable area is displayed on screen 
(with the “Display Page Breaks on Screen” 
option selected in the Output Setup dialog box), 
you can drag parts of the project, such as plans, 
elevations, and renderings, to position them 
within the page boundaries.

Fig. 90 Printable area in Draft mode

Keep in mind that the scale specified in the Out-
put Setup dialog box applies to an entire docu-
ment. Though you might print parts of the 
document on separate sheets of paper, the scale is 
the same for all pages.

When you open a new DenebaCAD document, 
the printable area is not visible on screen. If you 
create a drawing and print it without first ensur-
ing that all of the objects are in the printable area, 
some objects might appear cut off in the printed 
output.

Page setup

You can use the Page Setup command in the File 
menu to set the orientation of printed pages. For 
example, it’s common to use landscape orienta-
tion for printing drawings. Click the landscape or 
portrait button to set the paper orientation. The 
setting you choose affects the orientation of the 
printable area in the Draft mode window.

Page breaks border

Page 1 Page 2

Click for landscape 
orientation

Click for portrait orientation
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GRID SETUP

The grid is a pattern of evenly spaced dots in hor-
izontal and vertical rows. When you draw and 
move objects, they can be made to snap to the 
grid, whether or not the grid is visible. Also, you 
can display the grid whether snap is active or not.

The Snap Grid button lets you turn grid snap on 
and off, and select from five preset grid spacing 
settings. Press the button to display a pop-up 
menu of grid spacing options.

You can use the Grid Setup command in the Lay-
out menu to change the settings for grid spacing. 
When you specify a custom grid spacing, the 
new setting appears in the pop-up menu under 
the Snap Grid button. If the pop-up menu already 
contains five grid spacing settings, the new set-
ting replaces one setting in the pop-up menu.

The grid spacing is affected by the units and 
measurement system specified in the Units Setup 
dialog box. If you are working in U.S. units, you 
specify grid spacing in U.S. units. 

To specify new grid spacing options

1. Choose Grid Setup in the Layout menu.

2. In the Grid Setup dialog box, choose the grid 
setting you want to modify from the Grid 
pop-up menu.

3. The the horizontal spacing value in the first 
text box, and type the vertical spacing value 
in the second text box.

4. Click OK to implement the new Grid set-
ting.

◆ To activate grid snap: Choose the Snap to 
Grid command in the Layout menu, or click the 
Snap Grid button.

◆ To display the grid: Choose the Show 
Grid command in the Layout menu.

LIBRARY ITEMS

Before you begin to draw, you might want to add 
Library items to the document. You can import 
saved Library Objects and Symbols to use in 
your drawing. You can create and save your own 
Library items, and you can use sample Library 
items distributed on the DENEBACAD CD-ROM.

Library items let you place common elements 
such as elevation symbols in a document with the 
Library tool. This is helpful if you use the same 

drawing symbols and objects in all of your draw-
ings. For example, you will probably use the 
same elevation symbol in every plan you draw.

Fig. 91 Elevation symbol

Choose preset 
grid spacing 

Type custom 
spacing values
88 User’s Guide



You might also use the same interior door in 
every house you design. If this is the case, using 
the Library eliminates the repetitive task of creat-
ing the same door.

Doors, windows, plumbing fixtures, electrical 
symbols, and drawing symbols are examples of 
Library Objects and Symbols that you might 
want to add to a new document.

Adding Library items

To add Library items to a document so they can 
be placed in a drawing, use the following proce-
dure:

1. Click the Library tool icon to open the 
Library palettes. 

2. Choose the Add command in the pop-up 
menu under the right triangle button. 

3. In the directory dialog box, select the docu-
ment that contains the Library items you 
want to add. 

4. Use the Library Picker to add items one at a 
time to the current document (figure 92).

You can refer to the Library tool in the 2D and 
3D Drawing tools chapter for more information 
on adding and working with Library Objects and 
Symbols.

Fig. 92 Adding Library items to a document

Double-click the Library tool to open 
the Library palette

Choose Add 
to select a 
document on 
disk

Select a Library 
item in the list and 
click Add to add the 
item to the current 
document

Library Symbols

Library Objects

Selected object
LIBRARY ITEMS 89



USING LAYERS AND CLASSES

Creating a layer structure is one effective way 
you can use to organize objects and structural 
components in a drawing. 

Standard layer structures let architects and engi-
neers share common information between docu-
ments. By using the same layer structure in all 
documents, they can share CAD files easily and 
improve consistency within documents.

If you do not need to use an industry standard 
layer structure, you can name layers according to 
what kind of plans you are creating. For a house, 
you might create layers named “walls,” “roof,” 
“electrical,” and “lighting.” When you want to 
edit walls, you can hide the other layers so they 
don’t interfere with editing. If you want to print a 
lighting plan, you can hide all other layers. When 
a layer is not visible, it does not print.

You use the Layer Manager command in the 
Window menu to open the Layer Manager, a pal-
ette for working with layers. You can then define 
as many as 256 layers. You can add 255 layers to 
the layer structure at one time before you begin 
to draw, so you don’t have to go back and add 
layers later.

SETTING UP CLASSES 

DENEBACAD lets you set up classifications of 
objects so that you can generate reports using 
information that you enter into the class text 
boxes.

In other words, you can classify objects and then 
generate reports using the classifications. 

Using a house as an example, you can create 
hardware, plumbing, and electrical classes. You 
can then organize the information by categories 
such as model, price, and color.

You can then generate reports based on the spe-
cific information you need. For example, if you 
need to order door knobs for the house, you can 
categorize door knobs under the hardware class. 
You can then generate a report based on the 
hardware class, and more specifically the model, 
price and quantity of the door knobs.

To do this, you set up a class system using the 
Class Manager. You can then assign an object a 
class using the Properties Manager, and generate 
reports based on the object’s categorizations 
using the Analysis Manager.
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SETTING UP 3D EXTRUSIONS

After you configure your document’s drawing 
environment, you might want to set up 3D extru-
sion planes.

Extrusion planes are a set of two planes (which 
can be parallel to each other or not) that define 
the boundries of a linear extrusion. You will use 
extrusion planes if you model your structure in 
3D in Sculpt mode, or draw plans in 2D in draft 
mode and then extrude objects to make a 3D 
model.

Note: You can use three extrusion methods in 
DENEBACAD: linear, spin, and sweep. For linear 
extrusion, you define a set of extrusion planes, 
which is described in this section. For spin extru-
sion, you define an extrusion axis. For sweep 
extrusion, you select a sweep section and a path. 

Configuring extrusion planes

Defining and saving extrusion planes at the start 
of a project is a very effective way to work. You 
can save the extrusion planes with useful names, 
and then select them from the 3D Plane pop-up 
menu in the Status bar. As you work on various 
aspects of your project, you will probably switch 
among several sets of extrusion planes; settings 
these planes up before you begin lets you con-
tinue drafting and modeling without stopping to 
set up new extrusion planes each time you want 
to extrude an object in either Draft of Sculpt 
mode.

The extrusion planes you might set up for a 
house project would define things such as the 
height of the walls, the length of the roof and 
overhangs, the height and depth of countertops 
and built-ins. Extrusion planes are also used to 

set the position of lights used for rendering, and 
the height of camera paths used to generate walk-
throughs of 3D models. 

The following procedure illustrates how to define 
and save extrusion planes for the walls of a 
house. You establish the height of the walls by 
defining planes at floor and ceiling level. With 
the wall height defined, you can then create 3D 
walls by drawing the tops of the walls in Top 
view.

To define extrusion planes for walls

This procedure uses Top view in Draft mode. 
This is the view and mode of the drawing win-
dow when you create a new document. It’s best if 
you can see the Centerpoint ( ) in the window 
so you know you are near the origin (0,0) of the 
document when you begin.

1. Choose Define Frontal 3D Plane in the 3D 
Plane submenu in the Layout menu. The 
window changes to Front view and the 
pointer becomes a small cross with a hori-
zontal line that extends to the window edges. 
The line represents the first extrusion plane. 

2. To position the first extrusion plane at floor 
level, move the pointer up or down until the 
line passes through the Centerpoint (the Y 
coordinate in the Info bar will be 0"). Click 
to set the first extrusion plane in place.

Centerpoint Pointer

Extrusion plane
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3. Move the pointer upward to position the sec-
ond extrusion plane at ceiling height. A sec-
ond horizontal line (the second extrusion 
plane) follows the pointer. For this example, 
move the pointer to Z=8' to establish an 8-
foot-high wall extrusion. Click to set the 
second extrusion plane in place. The Draft 
window switches back to top view.

After you define the extrusion planes, you can 
create the walls of the house by drawing the tops 
of the walls in Top view. You can draw the walls 
in Draft mode and use the Linear command to 
extrude 3D objects, or draw 3D objects directly 
in Sculpt mode when the Linear extrusion 
method is selected.

Saving extrusion planes

After you define a set of extrusion planes, you 
can save them using any name you want — pref-
erably one that will make it easy to select the cor-
rect extrusion planes later. 

Note: If you do not save extrusion planes, they 
will be replaced by the next set of extrusion 
planes you define.

To save the extrusion planes

1. Choose the Save 3D Plane command in the 
3D Plane submenu in the Layout menu. The 
Save 3D Plane dialog box appears.

2. Type the name you want to use for the extru-
sion planes in the text box.

3. Click OK to save the extrusion planes in the 
document.

Selecting saved extrusion planes

After you save extrusion planes, you can select 
them using the 3D Plane pop-up menu in the Sta-
tus bar.

Second extrusion plane

First extrusion plane

Drawing vector

Click

3D Plane pop-up menu
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GLOSSARY

Absolute Origin The coordinates x=0, y=0, z=0 in the Cartesian coordinate 
system. This is the Default Centerpoint for a new document 
and for the DENEBACAD workspace. The Absolute Origin 
can never be changed. See also Custom Centerpoint.

Action buttons The group of icons in a row at the right on the Attributes bar. 
Action buttons are shortcuts for choosing commands. You 
click an action button to execute the associated command, or 
press the button to open a toolbar of related action buttons.

active document 
window

The Draft, Sculpt, or Render mode window with 
DENEBACAD’s focus. The Info bar and Status bar display 
information related to the active document window.

alignment To horizontally or vertically line up objects with the Align 
command or action button.

Analysis Manager A palette that lets you display summary reports of objects and 
other information in a DENEBACAD document. The Analysis 
Manager compiles information from preset object data and 
Classes defined in the Class Manager. Analysis Manager 
reports can be exported in tab-delimited form.

array Copies of an object positioned a set distance from each other 
or within a specified distance from the original object.

Arrowhead A line terminator shape such as an arrow, circle, or witness 
line that can be applied to lines from the Arrow tab in the Pen 
palette.

attributes Graphical modifiers such as color and line width that can be 
applied to an object. See Pen color, Pen weight, Pen style, 
Arrowhead, Fill color, Fill pattern, Fill hatch, and surface 
material.

Attributes bar A bar near the top of the screen containing buttons that dis-
play the Pen palette and Fill palette. The Action buttons 
appear on the right end of the Attributes bar. When the Text 
tool is selected, text controls appear in the Attributes bar.

Attributes cluster The group of buttons at the left end of the Attributes bar, 
which let you apply attributes from the Pen and Fill palettes.
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axis A reference line from which distances or angles are mea-
sured. DENEBACAD utilizes X, Y, and Z axes to draw 3D 
objects.

Back view One of six orthogonal views in Draft and Sculpt modes. Back 
view shows the DENEBACAD workspace from the back. This 
is an elevation view.

Boolean object Two or more objects combined into a single object using a 
command in the Combine submenu. 

Bottom view One of six orthogonal views in Draft and Sculpt modes. Bot-
tom view shows the DENEBACAD workspace from the bot-
tom.

bounding box An invisible rectangle that defines the boundaries of a 
selected object in Draft and Sculpt modes. The bounding box 
is shown on screen by tiny black handles located at the cor-
ners of a selected object

Centerpoint A location in a document at the Cartesian coordinates x=0, 
y=0, z=0. You can create a Custom Centerpoint and save 
Custom Centerpoints so you can assign the 0, 0, 0 coordinates 
to various locations in a document as you work.

Class A classification that you can define and then assign to objects 
as a way of categorizing information about a project. Classes 
are defined in the Class Manager with up to eight data fields 
for each Class. 

Class Manager A dialog used to define classes of objects. In the dialog box, 
you can enter a Class name and up to eight fields of informa-
tion for that Class. Classes appear in the Properties Manager 
and can also be used in the Analysis Manager.

Clipboard A part of the Mac OS operating system that stores objects cut 
or copied in any program. The Show Clipboard command in 
DENEBACAD displays the Clipboard contents.

clipping planes Planes defined in Sculpt mode or Render mode that limit the 
view of a document so objects between the planes are visible 
and other objects are not visible.

combined object Two or more objects combined into a single shape using the 
commands in the Combine submenu.
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constrain To restrict the movement of the pointer and the drawing vec-
tor to a certain direction or type of movement. For example, 
to snap the pointer to 15-degree intervals by pressing the 
Shift key when moving an object with the Selection tool. 
When you constrain the drawing vector, you can also restrict 
an object to a shape, such as a perfect circle or square, when 
drawing or editing.

container An object defined as a container in the Properties Manager. 
Containers can be used to display information in the Analysis 
Manager about objects within their boundaries.

coordinate system A method of specifying the positions of points in space by 
reference to fixed points, lines, or planes. DENEBACAD pro-
vides six coordinate systems: Cartesian, Polar, Relational, 
Bearing, Geographic, and Gradient.

coordinates Two numbers that identify the location of a point in space in a 
given dimension by its distance from a set point. The current 
coordinate system determines whether coordinates are 
expressed as linear or angular measurements.

Copy A command that copies selected objects or text and places the 
data on the Clipboard.

creation points The points that define an object, such as the endpoints of a 
line or the opposite corners of a rectangle. Creation points are 
visible in reshape mode and when they are selected with the 
Point Selection tool.

custom Centerpoint A location in a drawing designated as coordinates x=0, y=0, 
z=0 by the user. 

custom Relative 
View

The last Relative View defined by a user in Sculpt mode, 
regardless of whether the view was saved.

custom 3D Axis The last 3D Axis defined by a user in the current view in 
Draft mode or Sculpt mode.

custom 3D Plane The last 3D Plane defined by a user in the current view in 
Draft mode or Sculpt mode.

current attributes The attributes applied to a new object that is created with a 
drawing tool.

current layer In Draft or Sculpt mode, the layer on which a newly created 
object appears. Because Draft layers and Sculpt layers are 
separate, each mode has its own current layer when the mode 
is active.
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default A setting for object attributes, tool functions, window 
options, or operations that are in effect when you start a 
DENEBACAD work session.

default Centerpoint The Centerpoint that is in effect when you create a new docu-
ment or choose the Default Centerpoint command.

default 3D Axis The 3D Axis that is in effect when you create a new docu-
ment or choose the Default 3D Axis command. 

default 3D Plane The set of 3D planes that are in effect when you create a new 
document or choose the Default 3D Plane command.

default Relative 
View

The Relative View that is in effect when you create a new 
document or choose the Default Relative View command.

DENEBACAD 
workspace

An infinite 3D space for construction of 3D models, and a 
related 2D space for construction of 2D objects and working 
drawings. These spaces can be viewed from various perspec-
tives in Draft and Sculpt mode windows.

∆X Delta X; the change in the value represented by X, such as the 
horizontal coordinate of a point.

∆Y Delta Y; the change in the value represented by Y, such as the 
vertical coordinate of a point.

∆Z Delta Z; the change in the value represented by Z, such as the 
coordinate of a point.

dialog box A window displayed to report or request information. You 
use dialog boxes to choose options, specify values, and start 
and cancel operations.

dimension object An object containing dimensions created with a Dimension 
tool. 

document scale A ratio of the size of objects in a drawing to the actual size in 
the physical world represented by the drawing.

drawing vector A vector represented by a gray arrow on screen in 
DENEBACAD. The drawing vector indicates the vector from 
the absolute origin to a point, or from one creation point to 
the next, when you draw, move, reshape, rotate, extrude, 
resize or otherwise manipulate an object’s position. 

Draft mode The mode of DENEBACAD when a Draft mode window is 
active. In Draft mode you can create 2D objects and assemble 
working drawings based on the 2D and 3D objects in a docu-
ment.
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Draft mode window Any window showing your work in Draft mode.

duplicate To make an exact copy of an object with the Duplicate com-
mand. Also, the object resulting from duplication. 

endpoint Either of two points that define the ends of a line segment, a 
polyline, or an arc.

extrude The process of adding a third dimension to a 2D object using 
the Linear, Spin, or Sweep extrusion method.

extrusion axis The axis along which Linear, Spin, and Sweep extrusion 
methods add depth to a 2D object. The Extrusion axis 
changes based on the current view, current Relative View, 
and current coordinate system.

extrusion format A setting that controls which parts of a 2D object are 
extruded into 3D. The extrusion format can be set using three 
buttons in the Status bar. 

extrusion method The procedure used to extrude 2D objects, either Linear, 
Spin, or Sweep, which affects the resulting 3D shape. You 
specify an extrusion method in Sculpt mode by selecting an 
Extrusion action button. In Draft mode, you choose an extru-
sion method when you extrude objects with an action button 
or Extrude command in the Object menu.

extrusion planes A set of two planes, parallel or not, that define the boundaries 
of linear extrusions. The planes are identified by creation 
order as first and second, or by position in a particular view as 
lower and higher. Some objects, such as walkthrough paths 
and light sources, are always drawn on the lower or higher 
extrusion plane. 

Fill color A color on the Fill Color tab of the Fill palette, which can be 
applied to the interior of a 2D object.

Fill hatch A hatch pattern on the Fill Hatch tab of the Fill palette, which 
can be applied to the interior of a 2D object.

Fill palette A floating window containing four types of attributes — col-
ors, patterns, hatches, and surface materials — that can be 
applied to objects.

Fill pattern A pixel-based pattern on the Fill Pattern tab of the Fill palette, 
which can be applied to the interior of a 2D object.
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Fit to Window A command that changes the magnification of a document so 
that all objects appear within the active Draft or Sculpt win-
dow.

Front view One of six orthogonal views in Draft and Sculpt modes. Front 
view shows the DENEBACAD workspace from the front. This 
is an elevation view.

first plane The plane you set first, regardless of position, when you 
define a set of extrusion planes.

grid A pattern of evenly spaced dots in horizontal and vertical 
rows. The pointer and objects can be made to snap to the grid 
dots, whether or not they are visible. The Grid Setup com-
mand can be used to set the grid spacing.

group (v.) To associate two or more objects so they behave as a uni-
fied object; (n.) the resulting object.

handles Small black squares displayed at the corners of an object’s 
bounding box when the object is selected. Also, similar 
squares that define parts of walkthrough paths and control 
points on curve objects.

Help bar The area at the bottom of the screen that displays messages 
about tools, commands, and procedures based on the position 
of the pointer and the currently selected tool.

Hidden Line 
rendering

A type of rendering displayed in the Render mode window in 
which 3D objects appear as solids without any shading.

Horizontal Focal 
Point

 A point set with the Horizontal Focal Point tool in the Ren-
der mode window. The point defines the distance and the hor-
izontal direction of the sight line from the viewer to the 
objects to be rendered.

Info bar An area at the top of the screen containing the coordinate sys-
tem pop-up menu and a set of text boxes. In the text boxes, 
you can view and enter coordinates for creating and modify-
ing objects, planes, and axes.

insertion point (1.) A point on a library object that can snap to other objects. 
(2.) The vertical blinking line that indicates where text you 
type will appear in a document or dialog box. See also Sweep 
insertion point.
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layer A virtual drawing overlay used to segregate objects in Draft 
and Sculpt modes. Draft mode can contain up to 256 layers 
per view, or 1,536 total. Sculpt mode can contain up to 256 
layers that are part of all views.

Layer Manager A floating palette in which you can create, arrange, select, 
and configure options for drawing layers. 

layer structure The overall organization of layers in a DENEBACAD docu-
ment. You can name layers, reorder layers, and assign colors 
to layers. Each layer has an absolute number which desig-
nates the order in which it was created. 

layer set A subset of the total number of layers. Each view in Draft 
mode has separate layers and layer sets. Sculpt mode has lay-
ers and layer sets shared by all views. Only one layer set can 
be active. Layers in non-active layer sets do not appear in the 
Layer Manager. Objects on layers in non-active layer sets do 
not appear in a drawing. Layer sets can be defined and named 
in the Layer Manager.

Left view One of six orthogonal views in Draft and Sculpt modes. Left 
view shows the DENEBACAD workspace from the left. This 
is an elevation view.

Library Object An object that has been designated as a Library Object in the 
Properties Manager. Library Objects can contain a combina-
tion of 2D and 3D objects.

linear array Copies of an object arranged a set distance from each other or 
distributed over a specified distance.

Linear extrusion A method of adding a third dimension to a 2D object by 
extending the object along a single axis.

message box A window that displays information and asks for a response 
from the user before continuing.

midpoint The point on a line segment or curvilinear arc that divides the 
object into two parts of equal length.

mode See Draft mode, Sculpt mode, and Render mode.

Mode pop-up menu A pop-up menu that lets you set the active document window 
to Draft, Sculpt, or Render mode.
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object An item that can be selected in a DENEBACAD Draft or 
Sculpt window, including 2D and 3D shapes such as lines, 
rectangles, Boolean objects, cubes, cylinders, dimensions, 
text, pasted renderings, and views copied to Draft mode.

page breaks The boundaries, which can be displayed on screen, between 
individual pages of a document when it is printed.

palette A type of dialog box that can remain open. For example, you 
apply attributes to objects from the Pen and Fill palettes.

Panned Zoom A method of changing the view that lets you position a rect-
angle on screen to select the view and zoom level.

paste To insert the Clipboard contents into the active window with 
the Paste command.

Pen color A color on the Pen Color tab of the Pen palette, which can be 
applied to the outlines of a 2D or 3D object.

Pen palette A floating window that contains Pen colors, Pen Weights, 
Pen styles, and Arrowheads, which can be applied to lines 
and the outlines of objects.

Pen style A pattern of dashes made of solid lines and blank spaces, 
which can be applied to the outlines of 2D objects.

Pen weight The thickness of a line or the outline of a 2D object, which 
can be set from the Pen Weight tab of the Pen palette.

PICT A standard Mac OS graphics file format that supports vector 
objects, raster images, and formatted text. 

polar array Radial copies of an object that are separated from one another 
by a specific distance and angle

polygon A closed 2D shape bounded by three or more lines or seg-
ments.

polyline An open shape drawn by setting endpoints of connected line 
segments with the Single Polyline or Double Polyline tools.

preferences Settings that users can adjust with the Preferences command, 
which control the operation of DENEBACAD’s tools and other 
features.

properties Aspects of an object’s identity, including size, coordinates, 
the tool used to create it, its attributes, name, Class, and status 
as a container, library object, or symbol. The Properties Man-
ager lets you view and edit information about a selected 
objects’s properties.
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Properties Manager A palette that displays a variety of information about the 
properties of a selected object. You can display information 
about an object’s attributes, position, name, creation points 
and class in the Properties Manager, and use it designate a 
selected object as a Container and Library Object.

QuickTime A Mac OS technology, installed as a system extension, used 
for recording and reproducing digital movies. QuickTime is 
used with DENEBACAD to create animated walkthroughs of 
renderings.

QuickTime movie A digital animation file created in DENEBACAD from a walk-
through path of a rendering.

QuickTime VR A Mac OS technology used with DENEBACAD to create ren-
dered scenes that can be viewed in 360-degree perspective.

refresh The process of redisplaying the screen contents after choos-
ing the Refresh command in the Window menu.

Relative View A plane set at any angle as a window through which the user 
views a drawing. A Relative View lets you work on any sur-
face in a drawing as if the surface were parallel to the com-
puter screen.

render To create a picture of the 3D objects in a document in a Ren-
der mode window with the Wireframe, Hidden Line, or Solid 
commands. 

Render mode The mode in which DENEBACAD operates when a Render 
window is active. Render mode is used to create Wireframe, 
Hidden Line, and Solid renderings of the 3D objects in a doc-
ument.

Render mode 
window

Any window showing your work in Render mode.

reshape mode A mode initiated by the Reshape command which allows you 
to reposition creation points of selected objects.

Right view One of six orthogonal views in Draft and Sculpt modes. Right 
view shows the workspace from the right. This is an elevation 
view.

rotate To change an object’s orientation by moving it around a spec-
ified point with the Rotate command.
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scale-dependent An object in a DENEBACAD document whose size measure-
ment is relative to the scale set for the document. Nearly all 
objects, except text and dimension objects, are scale-depen-
dent.

scale-independent An object, such as text or a dimension, which maintains a 
particular size measurement regardless of the scale set for the 
document.

Sculpt mode The mode in which DENEBACAD operates when a Sculpt 
window is active. Sculpt mode can be used to create and view 
3D objects and to set up lighting and walkthroughs.

Sculpt mode 
window

Any window showing your work in Sculpt mode.

second plane The plane you set second, regardless of position, when you 
define a set of extrusion planes.

snap To align to an object or a point on the grid through constraints 
available in the Snaps menu.

snap points The points on the outline of an object that can attract the 
pointer so it snaps to the exact position of the point.

Snaps menu A menu that appears in the drawing window when you press 
the pointer on an object and press the Control key. The com-
mands in the menu let you constrain the pointer and drawing 
vector to align objects when you draw them.

Solid rendering A rendering created when you choose Solid in the Rendering 
menu. A Solid rendering shows objects as solids shaded with 
either their pen colors or surface materials.

Spin axis A line around which a 2D object is rotated to create a 3D 
object using the Spin extrusion method.

Spin extrusion A method of extending a 2D object into three dimensions by 
rotating the object around a Spin axis.

Status bar An area at the top of the screen that displays five pop-up 
menus from which you choose object or layer display 
options, a Full View or Sectioned View, 3D Planes, and Rela-
tive Views. 

Surface material A pixel-based image that can be applied to 3D objects and 
displayed in a Solid rendering to give the appearance of real-
world surfaces, such as wood, glass, and metal.
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Sweep extrusion A method of extruding a 2D object into three dimensions by 
extending the object along a specified path.

Sweep insertion 
point

A point on a Sweep section that follows the Sweep path when 
using the Sweep extrusion method to create a 3D object from 
a 2D Sweep section.

Sweep section A 2D object designated for extrusion into three dimensions 
using the Sweep extrusion method.

Sweep path A path along which a Sweep section can be extruded.

Symbols Objects that have been grouped and saved as Symbols in the 
Properties Manager. You can access Symbols on the Symbols 
tab in the Library palette. Symbols can contain 2D and 3D 
objects. Unlike Library objects, symbols are scale indepen-
dent. 

text objects An object created with a text tool that contains text. Text 
objects are scale independent.

3D Axis See Spin axis.

3D objects Objects defined in three dimensions. 3D objects have width, 
height, and depth. 3D objects can be created by extruding 2D 
objects in Draft mode, or by drawing objects in Sculpt mode. 
Only 3D objects can be rendered.

3D Plane A linear extrusion space defined by a pair of extrusion planes. 
In Draft and Sculpt modes, a 3D Plane can be selected only 
from the view in which it was defined.

tile To arrange multiple windows of an active document so two 
or more windows do not overlap.

tools Items used to create objects and set points of view in 
DENEBACAD. Tools are represented by icons in the toolbox.

toolbars Optional drawing and information elements that can be dis-
played on screen, including the Action buttons, Info bar, Sta-
tus bar, and Help bar, using the Toolbars command.

toolbox A floating palette from which you can select tools to draft, 
model, and render in DENEBACAD.

Top view One of six orthogonal views in Draft and Sculpt modes. Top 
view shows the DENEBACAD workspace from the top. This 
is the plan view.

2D objects Objects defined in two dimensions. They have width and 
height, but no depth.
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units The smallest named unit of measurement from which all cal-
culations are based in the document.

view One of the six orthogonal views of the DENEBACAD work-
space, designated Top, Bottom, Front, Back, Left, or Right.

View Options mode The mode that determines if 2D and 3D objects are displayed 
in Draft and Sculpt modes.

vertex A point of intersection of two vectors, or a point on a poly-
gon.

Vertical Focal Point A point of view specified by the height of a camera and the 
vertical angle of its sight lines, which determines the view of 
3D objects seen in a rendering.

walkthrough A type of animated rendering made by recording the views 
along a specified path through the 3D space of a 
DENEBACAD document.

Wireframe 
rendering

A rendering created in the Render mode window when you 
choose the Wireframe command in the Rendering menu. A 
Wireframe rendering shows 3D objects as transparent out-
lines. 

zoom To change the view of a drawing by changing the view mag-
nification. Changing magnification changes only the appear-
ance on screen, not the actual size of the objects in the 
drawing.
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∆X 28
∆Y 28

Numerics

2D objects 103
3D Axis 103
3D objects 103
3D Plane 103
3D Plane pop-up 92

A

Absolute Origin 93
Action buttons 15, 93
activating windows 3
active document window 93
adding layers 57
alignment

defined 93
Analysis Manager 93
Angle Dimension tool 18
Arc 3 Points tool 18
Arc Elliptical tool 18
Arc Radius tool 18
arrays 93

Inclusive Array option 73
Linear Array command 40
Offset Array option 40
Polar Array command 40

Arrowhead 93
attributes 93
Attributes bar 15, 21, 93

Attributes cluster 93
axis 94

B

Back Cap Extrusion Format 13
Back view 94
Baseline Dimension tool 18
Bearing coordinate system 26
Boolean object 94
Bottom view 94
bounding box 94

C

Camera Path tool 18
Cancel 8
Center constraint 33
Centerpoint 29, 94
Chain Dimension tool 18
choosing menu commands 3
Circle 3 Points tool 19
Circle Radius tool 19, 35
Class 94
Class Manager 90, 94
click 2
Click constraint 32
Clipboard 94
clipping planes 94
Combine command 73
combined object 94
Command key 4
command shortcuts 4
concepts overview 9
constrain 95
Constrained Dimension tool 18

constraints, drawing with 32-33
container objects 95
Control key 4
coordinates 95
coordinate systems 26

Bearing 26
Cartesian 26
Geographic 26
Gradient 27
Polar 26
Relational 26

copying
defined 95

creating
document templates 84

creation points 95
current attributes 95
current layer 95
Curve tool 18
custom 3D Axis 95
custom 3D Plane 95
custom Centerpoint 95
Custom installation option 5
custom Relative View 95

D

default 3D Axis 96
default 3D Plane 96
default Centerpoint 96
default Relative View 96
default settings 96
defined 95
defining extrusion planes 12
DenebaCAD workspace 96
dialog box 96
dimension objects 96
Directional Light tool 19
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Direction constraint 33
documentation conventions 2
documents

icons 7
scale 96
untitled 7

document templates 84
double-click 2
Double Polyline tool 19, 49
Draft mode 9, 20, 96
Draft mode window 7, 97
drag 2
drawing

modes 99
drawing vector 96

using with constraints 36
drawing window 3
Dual Focal Point tool 19
duplicate 97

E

Easy installation option 5
Ellipse 3 Points tool 19
Ellipse Center to Corner tool 19
Ellipse Diagonal tool 19
ending a DenebaCAD work 

session 8
endpoints 97
executing commands and 

procedures 2
extensions (Mac OS), disabling 5
extrusion

axis 97
defined 97
for 3D modeling 10
formats 13, 97
methods 97
planes 11, 91, 97
projected 13
sweep 63, 103
sweep path 65

Extrusion Format buttons 16
extrusion formats 13

F

Fill color 97
Fill controls 22
Fill hatch 97
Fill palette 97
Fill pattern 97
first extrusion plane 98
Fit to Window 98
Fit to Window command 43
Focal Point tools 3
Free Mouse constraint 32
Front Cap 13
Front view 98

G

Geographic Coordinate System 26
Gradient coordinate system 27
grid 98
Grid Setup command 24-25, 88
group, defined 98

H

handles 98
hard disk space requirement 1
hardware requirements 1
Help bar 16, 98
Hidden Line command 62
Hidden Line rendering 98
hip roof 63
Home View command 43
Horizontal Focal Point 98
Horizontal Focal Point tool 19, 60

I

icons of documents 7
Included constraint 32
Inclusive Array option 73
Info bar 15, 28, 98
insertion point 47, 98
installation 5

network volume 6
select folder option 5

Installer program 5
Intersection constraint 33
introduction to DenebaCAD 1
Isometric Render tool 19

K

keyboard keys 4
keyboard shortcuts 4

L

launching DenebaCAD 7
Layer Manager 99
Layer Manager command 90
layers

adding 57
defined 99
layer sets defined 99
structure defined 99

Leader Dimension tool 18
Leader Text tool 18
Left view 99
Library Object 99
Library palette 57
Library Picker 89
Library Picker dialog box 57
Library tool 19, 57, 89
Linear Array command 40, 72
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linear array defined 99
linear extrusion defined 99
Line tool 19
list of tools 18

M

Mac OS™ 1
materials, locating 7
menu bar 2
menu title 2
message box 99
midpoint 99
Mirror a Copy command 38
Mode pop-up menu 99
modes, drawing 99
mouse actions 2
Move a Copy command 39

N

network volume installation 6
number, program version 7
Numeric constraint 33

O

objects
basics of drawing 25
defined 100
properties defined 100
reshaping 42
scale-dependent 102
scale-independent 102
selecting 2
text 103

Offset Array option 40, 74
Offset command 56

Omnidirectional Light tool 19
Option key 4
Output setup command 86

P

page breaks 100
Page Setup command 87
palettes defined 100
Panned Zoom defined 100
Pan tool 19
Parallel constraint 32
Paste command 100
Paste Special command 37

Absolute 37
Cursor Position 37
Relative 37

Pen color 100
Pen controls 22
Pen palette 100
Pen style 100
Pen weight 100
Perpendicular constraint 33
personalizing DenebaCAD 7
Perspective Render tool 19
PICT 100
planes, extrusion 11
pointer 2
Point Selection tool 19
polar array 100
Polar Array command 40
Polar Coordinate System 26
Polygon Midpoint tool 19
polygons defined 100
Polygon Vertex tool 19
polylines defined 100
PowerPC™ processor 1
Preferences 24

defined 100
press 2
program version number 7
projected 13

projected extrusion format 13
properties defined 100
Properties Manager 30, 64, 101

Q

QuickTime 101
QuickTime VR 101
Quit command 8

R

RAM requirements 1
Rectangle 3 Points tool 19
Rectangle Center to Corner tool 19
Rectangle Diagonal tool 19
Refresh command 101
Relational Coordinate System 26
Relative View 10, 101
rendering

defined 101
Render mode 9, 20, 101
Render mode window 3, 101
Reshape command 42
reshape mode 101
Right view 101
Rotate a Copy command 39
rotation defined 101
Rounded Rectangle Center to Cor-

ner tool 19
Rounded Rectangle Diagonal 

tool 19

S

Save command 8
scale-dependent 102
scale-independent 102
INDEX 107
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Sculpt mode 9, 20, 102
Sculpt mode window 102
second plane 102
Select Folder for installation 5
selecting

objects 2
Selection tool 19
Setting up a document 83
setup

grids 24
measurement system 24
units 24

Shift key 4
shortcuts for commands 4
Show Grid command 88
Single Polyline tool 19
snap, defined 102
snap points 102
Snap Points constraint 32
Snaps menu 32, 102

Center 33
Click 32
Direction 33
Free mouse 32
Included 32
Intersection 33
Numeric 33
Parallel 32
Perpendicular 33
Snap Points 32
Tangent 33

Snap to Grid command 88
software requirements 1
Solid rendering 102
special keys 4
Spin axis 102
spin extrusion 102
start-up screen 7
Status bar 16, 102
submenus 2
Super-contention 13
Surface material 102
Sweep extrusion 63, 65, 103

path 103
Sweep insertion point 103
sweep section 63, 103
Symbols 103
System 7.5 1
system requirements 1

T

Tangent constraint 33
text

objects 103
Text Rotated tool 19
Text tool 19
tiling 103
toolbars 23, 103
toolbox 16, 103
tools 18, 103

Angle Dimension 18
Arc 3 Points 18
Arc Elliptical 18
Arc Radius 18
Baseline Dimension 18
Camera Path 18
Chain Dimension 18
Circle 3 Points 19
Circle Radius 19, 35
Constrained Dimension 18
Curve 18
Directional Light 19
Double Polyline 19
Dual Focal Point 19
Ellipse 3 Points 19
Ellipse Center to Corner 19
Ellipse Diagonal 19
Horizontal Focal Point 19
Isometric Render 19
Leader Dimension 18
Leader text 18
Library 89
Library tool 19
Line 19

list of tools 18
Omnidirectional Light 19
Pan 19
Perspective Render 19
Point Selection 19
Polygon Midpoint 19
Polygon Vertex 19
Rectangle 3 Points 19
Rectangle Center to Corner 19
Rectangle Diagonal 19
Rounded Rectangle Center to 

Corner 19
Rounded Rectangle 

Diagonal 19
Selection 19
Single Polyline 19
Text 19
Text Rotated 19
Vertical Focal Point 19
Zoom 19, 42

Top view 103

U

Unite command 41
units 25, 104
Units Setup command 85
Units Setup dialog box 25
untitled document 7
using

DenebaCAD documentation 2
document templates 84
the mouse 2

V

version number 7
vertex 104
Vertical Focal Point 104
Vertical Focal Point tool 19, 61
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video display requirements 1
view 104
View 2D & Lock 3D Objects 50
View Options mode 104

W

walkthrough 104
walls 68
windows

activating 3
not active 3

Wireframe rendering 104

Z

zoom 42, 104
Zoom bar 43

Zoom In button 43
Zoom Out button 43

Zoom pop-up menu 43
Fit to Window command 43
Home View command 43

Zoom tool 19, 42
INDEX 109
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