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Getting Started

Welcome to Expression 3, the innovative vec-
tor-based stylish drawing and illustration software
that continues to re-define vector graphics. Whether
you are a veteran professional illustrator working
on print-quality illustrations, a web designer build-
ing the most dazzling web site or a budding artist
eagerly experimenting with various styles and tech-
niques, you will find Expression 3 an indispensable
tool for your creative tasks. It brings you the best of
both worlds — the richness of pixel-based painting
software and the convenience and editability of
vector graphics.

System Requirements

Macintosh Systems:
• PowerPC-based Macintosh system supporting

thousands or millions of colors.
• Mac OS version 8.6 or later, with a minimum of

64MB free application memory, with Col-
orSync 2.6.1 or later installed.

• Mac OS X version 10.1 or later, with a mini-
mum of 128MB memory.

• Mouse and/or digitizer tablet supporting the
WACOM tablet software interface.

Windows Systems:
• Pentium-based or compatible systems with a

minimum of 64MB memory.
• Windows 95, 98, NT4 or later, ME, 2000 or XP
• Mouse and/or digitizer tablet supporting the

WinTab API; this includes WACOM and Cal-
Comp tablets.

End User License 
Agreement
Most software is licensed, not sold, to end users.
This is also true for Expression 3. Please consult the
End User License Agreement (included on the CD
and also at the end of this manual), and make sure
you accept the terms before you start to use the soft-
ware. If you do not accept the terms of the agree-
ment, please delete and destroy any copies of the
software you have made, and contact your distribu-
tor to return the complete package and request a
refund.

Installing and Launching 
Expression
The following setup procedure may change on
future updates to the application. Please consult the
“Read me” file for the latest setup procedure.

For Macintosh Systems:
1. If your CD contains multiple language versions

of the software, go into the language folder of
your choice first.

2. Simply drag the entire “Expression 3” folder
onto your Desktop or hard disk to copy the
installation from the CD to your system and
that’s it! You are done.

3. To run Expression 3, go into your newly copied
“Expression 3” folder, double-click the “E3”
icon (or “E3 X” icon on Mac OS X) to launch
the application.
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Windows Systems:
1. If the auto-run feature has been turned on in

your system, the Setup program will start auto-
matically after you have inserted the Expres-
sion 3 CD.

2. If your CD contains multiple language ver-
sions, choose the language version of your
choice and click “Install”. Otherwise, dou-
ble-click “Setup.exe”.

3. Follow the setup instructions to complete the
installation.

4. The program can be launched from “Start menu
> Programs > Expression 3 > Expression 3”.

Serial Numbers
The first time you launch the application after
installation, the program will prompt you to enter a
serial number. Enter the serial number given to you
at the time of your purchase. The serial numbers are
case insensitive.

If you are upgrading from a previous version of
Expression and have a serial number starting with
the letter “U”, you will be prompted for your previ-

ous serial number in a second dialog. You must
enter a valid Expression 1, 2 or LE serial number.

If you have entered the serial numbers incorrectly,
the application will either quit immediately, or start
in save-disabled mode. Launch the application
again to enter the correct serial number.

Troubleshooting and 
Technical Support
If you think you have entered your serial numbers
correctly but cannot launch the application, or if
you encounter system errors when launching the
application, please contact Creature House by email
at contact@creaturehouse.com. To help us diag-
nose your problems, please include the “e3.log” file
from your “Expression 3” folder (Macintosh) or
from “Start menu > Programs > Expression 3 >
Resources” (Windows). The log file is a record of
the program launch process, and is very useful for
troubleshooting start-up problems.

Obtaining the Latest 
Updates
Creature House releases bug fixes and free updates
with feature additions from time to time. Please
visit the Creature House web site (http://www.crea-
turehouse.com) to download the latest updates.

Windows version.

Macintosh version.
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Chapter 1: Introduction

Spread your wings and let your creative power
unfold! The unique tools and features in this new
major version of Expression will bring you a new
level of energy and freedom to create stylish draw-
ings and illustrations. Built on Creature House’s
proprietary, efficient and powerful graphics engine
and cross-platform framework, Expression 3 con-
tinues to break new grounds, introduce new unique
features, enhance and improve on existing features
to make the software more accessible and useful as
a creative tool.

1.1 A Stylish Vector-Based 
Drawing Application
Expression 3 is an object-based drawing applica-
tion. All brush trails, painted areas, lines, curves
and text are recorded analytically as high-precision
mathematical lines and curves. Graphics and soft-
ware using this approach are generally referred to
as vector-graphics or vector-based, so named
because of historical reasons rather than being an
accurate description of the approach, which actu-
ally involves more than linear vectors. In contrast to
this object-based and analytical approach, paint

applications, like Photoshop, record pictures in
unstructured arrays of pixels, and possibly layers of
them. Such applications are generally referred to as
being pixel-based or bitmap-based.

Vector-based applications, in general, name supe-
rior editability and resolution independent graphics
as their main advantages. However, as you create
more and more graphical objects in a picture docu-
ment, its structural complexity and hence the com-
putational demand on the computer increases.

Pixel-based paint applications, on the other hand,
are generally resolution dependent. This is a disad-
vantage, because pictures displayed in output
devices whose resolution is higher than the resolu-
tion at which the pictures were created will appear
blocky. A further disadvantage is that one usually
cannot edit the brush strokes that are drawn on bit-
map-based pictures, except at the pixel level. None-
theless, in terms of complexity, that of bitmap
pictures always remains the same, regardless of the
look of the images and the length of time spent
working and re-working them.

For reasons explained above, vector-based drawing
applications have often been used mainly for design
work, where precise curves, crisp edges and
smoothly shaded areas of colors are often
requested. Whereas photo touch-up and other more
organic paint effects were usually in the realm of
pixel-based applications.

That is, until this monotony was broken by the
launch of Expression 1, which introduced to the
vector graphics world the Skeletal Strokes technol-
ogy and full transparency. And after that, with
Expression 2 pushing the vector graphics boundary
even further by introducing, for the first time in the
software industry, real-time soft-edged and
embossed fills, “live” paper textures, watercolor
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strokes with variable width/transparency, and warp-
ing of arbitrary vector/bitmap objects.

Continuing in the spirit to raise the expressive capa-
bility of vector-based drawing applications,
Expression 3 is once again ready to release its new
features and solutions for containing the problem of
growing complexity which is inherent to all vec-
tor-graphics software. Read on to explore what new
power now lies in your hands.

1.1.1 Skeletal Strokes
Core to the application is Creature House’s original
Skeletal Strokes technology. Skeletal Strokes is the
kind of user-definable stylish brush strokes made
from arbitrary vector or bitmap pictures. Skeletal
Strokes are applied along a path, also referred to as

the skeleton of the stroke, and can be easily con-
trolled by manipulating the path itself.

Graphics of any design can be easily turned into a
Skeletal Stroke. All you need is a quick simple mar-
queeing gesture using the Stroke Definition Box
tool. Whether a watercolor brush trail, a fish, an
arm or a picture created from other Skeletal
Strokes, they can all be turned into new Skeletal
Strokes, and be used for drawing at once.

In Expression, Skeletal Strokes are always in your
control. You can make different parts stretch or
repeat differently, or use multi-view strokes to add
variety or make animations. If you are new to
Expression or Skeletal Strokes, the next chapter
presents an introduction to Skeletal Strokes and
their power.

1.2 What Is New in 
Expression 3
Here is a quick list of the new features added to
Expression 3.

New Fill Types and Stroke Power
• Tiled bitmap fill with alpha channel, for conve-

nient re-positionable textures.
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• Reflection-mapped embossed fill, for photore-
alistic metallic blobs and effects.

• User-definable fringes, from realistic natural
blotting effects to roughened paper effects.

• Bitmap strokes with head/tail anchoring and
multi-part repeatable body sections, giving
more variations to your stroke gallery.

• Independently controllable transparency vari-
ability and width variability, providing even
more control over the appearance of your
organic brush strokes.

Unique Power Features Extending Creative 
Possibilities
• Unique Eraser Mode applicable to any graphics

objects, for vector-based editable lifting and
feathering effects. (Works even with paper tex-
tures.)

• Powerful effect line groups with fully user-con-
trollable shapes and variations, for speed lines
in comics or complex interference fringe
effects.

• Unique and versatile 3-in-1 Star-Polygon-Twirl
tool with controllable variations, for creating –
in one dragging gesture – the wildest looking
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stars, the most regular polygons, and twirls
winded up using your mouse or stylus.

New and Improved Drawing Tools
• Rectangle tool with new round-corner control,

and the option to create rotated rectangles in a
single dragging gesture.

• Ellipse tool with new option to draw from the
center.

• Numerical specification dialogs for Rectan-
gle/Ellipse/Star/Twirl/Line tools, for precise
positioning and dimensions.

• Enhanced text handling with Unicode text and
full support for Mac OS X ATSUI fonts, new
controls for baseline-shift and tracking, and
enhanced accuracy of text-on-path.

• New “Position” and “Size” sections in the
Transformation palette for precise numerical
specifications.

• New Transform Fill tool for interactive manip-
ulation of tiling pattern fills and bitmap fills.

Productivity Enhancements
• Unique Frozen-Layer feature for temporary

freezing of any layers, reducing any arbitrarily
complex layer to a preview alpha channel bit-
map, allowing the fastest possible manipulation
of even the most complex pictures.

• User-editable shortcut keys for all menu com-
mands and tool switching commands.

• Numerous new options for fine-tuning and cus-
tomizing the application’s behavior.

• Support for native Photoshop PSD and PNG
format import/export.

• New auto-cling-on Macintosh palettes for max-
imum efficiency in managing desktop space.

• Fine-tuned and improved functions; improved
efficiency.

1.3 Original Expression 
Features

Skeletal Strokes Power
• The original skeletal strokes technology allow-

ing arbitrary vector graphics to be used as brush
strokes.

• Bitmap-based skeletal strokes for re-creating
the most realistic watercolor and tradi-
tional-media brush strokes.

• Infinite variations for each brush stroke through
complete control over stroke modes (sausage,
ribbon or elliptical), shear angle, twist, variable
width, transparency profile, joint type and the
use of dash patterns.

• Unique anchoring and repeating capability of
individual stroke elements for controlling the
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appearance of brush strokes along different
brush trails.

• Corner deformation suppression using the
“Break At Joints” attribute.

Stylish Rendering Functions
• Soft-edged fill, now with user-definable

fringes.
• Real-time embossed fill effect.
• User-definable paper textures.

• Blending modes for controlling the color mix-
ing behavior of overlapping objects.

• Independent stroke and fill transparency con-
trol.

• Warping of vector and bitmap objects.

Tool Box
• Familiar classic drawing tools like the Freehand

Pen tool and Bezier Pen tool.
• Intuitive and powerful B-Spline and

Polyline/Arc tools for convenient construction
of the smoothest curves or the sharpest poly-
gons.

• All-in-one Text tool for creating and editing of
point-text, text-on-path or area-text objects.

• One-drag object creation tools for rectangles,
ellipses and straight lines.

• Transformation tools for scaling, rotating,
shearing (slanting), mirroring and for applying
perspective transformation to graphics objects.

• Specialized path modification tools, for adjust-
ing path (and sub-path) direction, for choosing
starting nodes of closed paths, for splitting
paths, and for adding and deleting nodes.

• Bitmap editing tools for simple editing of bit-
map objects.

• Eye-dropper tools for capturing colors or object
attributes in full, and for copying colors and
attributes from one object to another.

• Specialized selection tools for selecting indi-
vidual objects, and for selecting nodes or
groups of objects. Selections are made by using
single clicks on objects or nodes, by surround-
ing objects or nodes with a rectangular mar-
quee, or by drawing a lasso around objects or
nodes.

• Picture navigation tools, such as the Hand tool
and Zoom tool.

• Accessible definition box tools, for creating
definitions of skeletal strokes and patterns.

Compatibility
• Native support of bitmap import/export of the

following image file formats: TIFF, BMP (Win-
dows only), GIF, JPEG. Export to Photoshop
PSD format with original layer structure and
alpha channel preserved.

• Photoshop filters applicable to any bitmap
objects.

• Import of Adobe Illustrator files of formats up
to version 8, with optional conversion of art
brushes to skeletal strokes.

• AI and PDF format export.
• WMF/EMF format import (Windows only).
• Flash SWF export, from multi-view strokes to

multi-frame movies, or from any graphics to an
interactive page with animating buttons.

• Color management based on ICC profiles.
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1.4 Software Design 
Philosophy
Creature House is a small team of computer scien-
tists who set out to put their ideas into practice.
From the very beginning, we have had no doubt as
to what we intended Expression to be. It was not to
be yet another drawing application competing with
other existing tools. It was to be the realization of
our vision of an ideal drawing tool, which is at the
same time powerful, expressive and easy to use.

Expression does not claim to be an “all purpose”
tool, and may not contain all features imaginable.
What it does offer, are rich and organic graphics
whose descriptions are not always totally compati-
ble with current industry standards, some of which
are aging, some restrictive, like PostScript, PDF or
Flash. We believe it impractical and short-sighted
to allow expressive possibilities to be stifled by
existing vector graphic standards, which are, after
all, compromises based on yesterday’s technology.

Should compatibility be a prime concern in certain
tasks, we leave the decision to restrict usage to
users themselves.

This is not to say that compatibility and data
exchange with other applications are not one of our
prime concerns. In fact, Expression’s export func-
tions are optimized for each particular file format so
that editability and the appearance of graphics are
retained as much as possible. Each application has
its own strengths and unique features, and the best
results can often be achieved by taking advantage
of the best tool for each creative step.

1.4.1 Expression Work Flow
Due to the limitations of the vector-based graphics’
industry standards like PostScript and PDF, many
of the more stylish renderings supported by Expres-
sion cannot be faithfully transferred to these file
formats without losing the graphics objects’ analyt-
ical forms or editability.

Therefore the most effective way to capture the
richness and subtleties of pictures created using
Expression is to export pictures as rasterized
images. Expression 3 provides native support for
many major image file formats, including TIFF,
JPEG, BMP, GIF, PNG and PSD. When used with
suitable Photoshop format filters, other file formats
can also be used. Rasterized images produced from
Expression can be color-separated or post-pro-
cessed in other applications if so needed for
high-quality printing.

That large image files may take up much hard disk
space should not be a worry, because as long as you
have the original Expression picture, you can
always rasterize it again at the same or different res-
olution later when the need arises. Artwork is best
kept in the native Expression format, which is very
compact.
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1.4.2 Expression UI Design 
Principles
Newcomers to Expression may find the Expression
User Interface (UI) slightly different from other
drawing applications. We trust that very soon you
will discover the reason for the difference – not for
merely being different in appearance but for achiev-
ing maximum accessibility and convenience.

The Expression UI is displayed using the same ren-
dering engine as is used for displaying Expression
pictures. This approach is, in a way, similar to the
Aqua UI on Mac OS X.

The emphasis of the Expression UI is on substance,
not just looks. All UIs are designed to allow direct

access to the tools and controls at sensible loca-
tions, yet not consuming too much precious Desk-
top “real estate”. Most commonly used controls are
placed at the top level, without having to go through
multi-levels of tabs or hidden pages. We have spe-
cial double sliders for grouping controls of related
values into one compact form. For numerical input,
we have designed a convenient meter control for
entering precise values without the need to release
the mouse or tablet stylus, while accepting key-
strokes equally well, should you prefer to input
numbers by keyboard. For more details on the oper-
ation of the meter control and other Expression 3 UI
elements, refer to Chapter 6.
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Chapter 2: Drawing with Skeletal Strokes

2.1 What Is a Skeletal 
Stroke?
From a user’s point of view, a skeletal stroke is sim-
ply a stylish brush stroke of arbitrary form — it
could be a natural-looking dab of paint that resem-
bles the brush trail left by a bristle brush, or a surre-
alistically stretched centipede with as many pairs of
legs as is allowed by the length of your brush trail.
Skeletal strokes can take any shape and form, and
have many variations that you can easily control.

From Expression’s point of view, skeletal strokes is
the software technology that performs the con-
trolled deformation of certain pre-recorded graph-
ics along a user-specified skeleton, which is also
referred to as a path. Vector-graphics brush strokes
similar to skeletal strokes have been implemented
in other drawing applications, but Expression is the
original application that introduced this concept to
the vector graphics world.

2.2 Drawing with Skeletal 
Strokes
Pick a brush and draw! That’s how you work with
skeletal strokes. With an array of drawing tools,

from the classical tools like the Freehand Pen tool
(Section 7.4) and Bezier Pen tool (Section 7.7) to
the convenient B-Spline tool (Section 7.5) and
Polyline/Arc tool (Section 7.6), you can lay down
expressive strokes on your virtual drawing surface
and make as many changes and revisions to them as
you like. With a pressure sensitive tablet, you can
draw in a natural way, with the strokes responding
to your hand’s articulations, in terms of width vari-
ations and opacity changes.

2.3 Bitmap Strokes
Since Expression 2, bitmap images can also be
defined as skeletal strokes (Section 14.4). Using
scanned images of real watercolor strokes on paper,
authentic-looking brush strokes can be re-created,
with the same flexibility as vector skeletal strokes.
The transparency of bitmap strokes with an alpha
channel can vary along the brush trail, based on the
pressure of the stylus or according to a variable
width profile (see Section 8.10). The richness of the
strokes you create and their realistic appearance
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will soon make you forget that you are actually
using a vector-based drawing application.

Expression 3 further allows arbitrary head and/or
tail portions to be anchored so that they do not
stretch with the rest of the stroke. The body section
can be stretched along the path or be made to be
repeatable. Strokes can even have several repeat-
able sections, so that when stretched, different body
variations can be formed from random combina-
tions of the repeatable sections. For more details,
refer to Section 14.4.

2.4 Defining Skeletal 
Strokes
To create a new skeletal stroke, simply pick any
vector drawing or bitmap, and turn it into a stroke
using the Stroke > Define Stroke command or using

the Stroke Definition Box tool (see Section 10.1.3).
It is simple! You can start drawing using the newly
defined stroke immediately. A simple skeletal
stroke applied along a brush trail will be stretched
uniformly. But if you like, you can constrain the
deformation of certain parts of the stroke or make
certain portions repeat on stretching. For more
details and options of defining skeletal strokes,
refer to Chapter 10.

2.5 Multi-View Skeletal 
Strokes
The appearance of a skeletal stroke can be dynamic,
if, instead of a simple stroke, you define a
multi-view stroke from a number of variations of a
picture. You can think of a simple skeletal stroke as
a deformable, still picture, and a multi-view stroke
as a deformable animation. Indeed, Expression
allows a multi-view stroke to be exported as an ani-
mation in the Flash SWF format. For more details
on creating Flash animations using multi-view
strokes, see Chapter 16.

The appearance of a multi-view stroke is not
restricted to the finite number of views defining the
stroke. In fact, an application of a multi-view stroke
can take any intermediate shape in between the
defining views. The exact in-between shape is spec-
ified using a shape parameter (see Section 9.2).
The shape parameter can be an explicit value, or it
can be randomly assigned by Expression.

Multi-view strokes are useful not only as animation
objects; they can also be used to create random

A simple composition using just a few bitmap 
strokes.

A multi-view stroke of a turning head of an ox.
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variations of a main design, or to give brush strokes
a more organic look.

2.6 Skeletal Stroke Power
In addition to the richness in form and shape, skele-
tal strokes can be adjusted in many ways and
applied in different styles. Like constant-thickness
PostScript strokes, the sharp-angled joints of skele-
tal strokes can be shaped in one of three artificial
styles: mitered, round or beveled (see Section 9.6).
A skeletal stroke can also be bent along a brush trail
in one of three stroke modes: sausage, ribbon or
elliptical mode (see Section 9.4). Other variations
and application styles are described in Chapter 9.

Despite the organic appearance of skeletal strokes,
pictures with skeletal strokes are remarkably com-
pact. This is because these compositions contain
only the path geometry and a reference to the stroke
definitions used. There is no need to record any

redundant graphical details on individual path
objects.

You can read about other expressive uses of skeletal
strokes and about the power of Expression in the
coming chapters.
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Chapter 3: Creating Expressive Pictures

Expression 3 is a complex and powerful software,
and the sheer number of commands, palettes and
controls can be overwhelming to newcomers. But
rest assured, because the basic drawing model is
actually very simple, and after all, you do not need
to know every detail and function to begin creating
great pictures.

The purpose of this chapter is to introduce the basic
concepts of Expression 3, and to suggest some pos-
sible approaches to creating richly textured pic-
tures.

3.1 Paths as Basic Picture 
Elements
In an object-based drawing application like Expres-
sion 3 or Adobe Illustrator, every single picture
component, from a simple curve to an area painted
with a color gradation, is an individual component
recorded in some form of abstract digital represen-
tation.

In Expression, the most commonly used basic pic-
ture component is the path, a term which probably
originated from PostScript, referring to an abstract
shape defined by a sequence of straight lines or
curve segments.

On its own, a path is nothing more than an abstract
shape. But when annotated with descriptions on
how it should be rendered, a path can start to

become all sorts of interesting objects: a brush trail
of a stylish stroke, an area filled with a solid color, a
color gradation, a blob of liquid metal or even a
stain mark. Such annotations which accompany a
path are called paint style attributes.

3.2 Thinking in Terms of 
Area
The experience of drawing and painting in tradi-
tional media and bitmap-based painting software
encourages us to build up shapes and shading by
overlaying numerous brush strokes. This approach,
while applicable in Expression 3, is not very eco-
nomical in terms of computational efficiency.
Another approach — a one-step method — is to use
a path to define the area to be shaded or filled, and
then specify the paint style attributes for producing
the final rendering in that area.
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Adjusting to this more structured approach of creat-
ing pictures does have many advantages. It encour-
ages experimentation, as paint style attributes and
shapes of paths can be easily modified at any time.
It also provides other advantages, such as efficiency
in picture creation, and compactness of data for
storage and transmission.

Indeed, it takes a slightly different way of thinking
to create pictures with object-based drawing appli-
cations than paint with traditional media. This is
probably why it is bitmap-based applications, not
object-based ones, that are often called “paint pro-
grams”.

3.2.1 Paper-Cutting and 
Collage
In a way, the “path/attribute” approach to picture
creation is analogous to collage making. Collage
artists would collect colorful and richly textured
materials, cut them up into appropriate shapes using
scissors, and paste these shapes onto an art board to
form the composition. In Expression 3, the paths
are like the shapes cut out by scissors, and the col-
ors and textures are provided by the paint style
attributes. The added advantage with Expression is
that the shapes can be “cut” or modified as many
times and in any way you like. So can the materials
and textures, until you are fully satisfied with the
result.

3.2.2 Enriching Pictures with 
Textures, Stylish Strokes, Fringes 
and Erasers
Expression 3 provides many different paint style
attributes, together with options and adjustable set-
tings, for creating richly textured rendering on each
path. For example, you can pick a skeletal stroke
from the array of available strokes to draw along a
path, or, for that special touch, define your own
unique stroke. You can fill the area enclosed by a
path with a gradation, pattern, hatching or paper
texture of your choice. Or even a fill with fuzzy,
fringed edges or with a metallic, shiny look, where
the occasion calls for one.

Sometimes, you may want to go beyond the built-in
attributes available to the single path object, and
create a unique and personal rendering. This is
when the clipper group can be most effective. First,
create the richest texture and paint effect on a blank
area. Then, draw a clipper path to “cut” the texture
and paint effect to the exact size and shape that you
want. But would this give rise to hard-edged
shapes? There is no need to worry, because clipper
paths can also have their own fill and stroke
attributes, and using a clipper path with textured
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and fringed edges will result in very rich and
organic-looking rendering.

In fact, the use of the clipper is similar to another
technique which is employed by traditional media
artists. Eric Carle, in his popular children’s book
“The Hungry Caterpillar”, composes each picture
by laying out cutout shapes of colorfully painted
pieces of paper.

Yet another technique worthy of mention here is the
eraser mode, which makes the ultimate feathered
edges and smooth edges across overlapping painted
areas not only possible, but also easy! Just choose a
soft or textured stroke and, with the eraser mode 
turned on, apply it across the edge to be softened.
This creates a semi-transparent “lift” effect to pro-
duce the most organic blend, which is difficult to
achieve with any other vector-based software.

3.3 The Expression Work 
Flow
Expression is designed for all artists, whether work-
ing in a professional capacity or just drawing for
fun. It aims to be a tool for the creative process, and
you may sometimes find it useful to take Expres-
sion artwork to other graphics software for further
touch-up or production work. The PostScript model
commonly adopted by many vector graphics pro-
grams has been in existence for over a decade now,
and does not support many of Expression’s special
drawing features. The best way to faithfully render
your Expression pictures is to rasterize them into
various bitmap formats. Expression files can be ras-
terized to TIFF format with alpha channels or PSD
format with layers, to ensure a smooth and natural
transition into pre-press tools like Adobe Photo-
shop or QuarkXPress for further processing.
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Chapter 4: Color and Color Management

When drawing on traditional media, we pay little
attention to the nature of the color pigments or the
physics behind human color vision. We rely on the
fact that the same picture will appear more or less
the same over time and space, and that most people
can differentiate the sensation of different colors
relatively consistently. Without this color consis-
tency, artists cannot reliably communicate their col-
orful creations with viewers.

In the creation of digital artwork, there must also be
a consistent way to specify, display and reproduce
colors consistently. This is less obvious than one
would generally imagine. Different monitors and
printers have very different color characteristics.
Textual color descriptions, e.g., “red”, “azure”, are
both too vague and imprecise for general color
specification. Therefore graphics software must
record and transmit color information in a generally
adopted way based on certain standards. Digital art-
ists should also understand the basic underlying
principles and mechanisms in order to use, commu-
nicate and reproduce their colors effectively and
accurately.

4.1 Specifying Colors
Colors are perceptual quantities stimulated by a
spectrum of light waves. To simplify the identifica-
tion and specification of colors, simplified color
models are often adopted to allow colors to be con-
sistently described. RGB, CMYK, and HSL are the
three color models supported in Expression 3. For a
description on picking colors, refer to Section 8.11.

4.1.1 RGB Model
The RGB model is based on the tri-stimuli model of
human vision. It also corresponds to the use of RGB

phosphors in CRT displays and tube-based moni-
tors. Many LCD and plasma panel displays are also
based on pixel cells responsible for one of the red,
green and blue primaries that combine to create a
sensation of various colors. Full intensity of red,
green and blue would give a sensation of a white
color.

Because the sensation of a color in human vision is
actually triggered by the entire spectrum of light
waves entering our eyes, the range of colors that we
can see is far wider than the limited color range that
is reproducible by the red, green and blue primaries.
The range of colors describable by a particular
color model or a particular device is known as the
color gamut.

Since the RGB color model is closely related to the
technology behind most display devices and moni-
tors, it is a useful model for describing colors for
digital applications. The gamut of many monitors is
also wide enough to cover a significant portion of
the gamut of the CMYK model commonly used in
offset printing processes.

The RGB model is known as an additive color
model because any particular color sensation cre-
ated using different intensities of the R, G and B
primaries is the combined effect of the three prima-
ries.

The RGB model. (Color plate on page 193.)
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In earlier days, RGB values were tied to the monitor
and display devices when the RGB values were
used directly as the RGB pixel values in the frame
buffer of the monitor. As a result, a color of a par-
ticular combination of R, G and B can look com-
pletely different from one device to another.

Many applications now resolve this problem by
storing a color profile (information describing the
color input/output characteristics of a device and
the interpretation of device-specific color values)
for the particular monitor the RGB values are tied
to. By interpreting the color profile together with

the RGB values, a consistent color can be displayed
on different devices.

Expression 3 adopts a different approach by storing
RGB values in a device-independent RGB space.
The advantage of using a device-independent color
space is that there is no need for an explicit color
profile to be carried with the picture document, yet
consistent colors can be displayed across different
devices. Many different device-independent RGB
space standards are available. The particular RGB
space that Expression has adopted is known as the
sRGB space. This is a standard color space
approved by the International Electrotechnical
Commission (IEC 61996-2-1 sRGB). While there
are arguments favoring the use of other
device-independent RGB spaces for their wider
gamut or linearity, the adoption of the sRGB space
is based on its compatibility with the largest num-
ber of existing color images and its resemblance to
most monitors’ device RGB spaces.

The same RGB values can produce different 
colors on different devices.
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4.1.2 HSL Model
When an artist thinks of a color, it is probably not
thought of in terms of red, green and blue compo-
nents (perhaps only technicians in CRT factories
would). People usually describe a color in terms of
its perceptual properties: its lightness (or bright-
ness), its paleness or color strength (saturation), its
tint, color family or hue.

The HSL model supported in Expression and many
graphics applications is one such model. The color
space is orientated in a cylindrical coordinate sys-
tem as a double cone, with the vertical axis being
the lightness axis, the radial axis saturation, and the
radial angle the hue.

In Expression, an HSL color picker is provided for
choosing colors in an intuitive way (see Section
8.11.1). The triangular color area displays a vertical
slice of the double cone for the particular hue cur-
rently chosen. To save space and make the design
more stylish, only a portion of the hue ring is dis-
played if the “Draggable color wheel” option is
chosen in the “Preferences” dialog (see Section
18.2.3). If this option is turned off, the hue ring is
compressed and displayed as a vertical spectrum.

A color chosen from the HSL color picker is actu-
ally stored in sRGB values. sRGB values can be
converted to and from the HSL values consistently.

4.1.3 CMYK Model
The CMYK model is a color model directly related
to the offset printing process using the four standard
process color inks: cyan, magenta, yellow and
black.

The choice of the process color inks is again based
on the tri-stimuli model for human vision, with
cyan being the complementary color of red,
magenta the complementary color of green, and
yellow the complementary color of blue. Because
colored ink does not emit light, but reflects light
after a portion of the incident light has been
absorbed, such an ink-based color model is called a
subtractive color model. Cyan ink absorbs the red
component in the incident white light and reflects
the remaining components to give the cyan color.
Magenta and yellow inks work in a similar way by
absorbing the green and blue components respec-
tively.

Ideally, with three inks at full strength and overlap-
ping in a particular area, all red, green and blue
components of the incident light will be absorbed
and the result will be blackness. In reality, the light
absorption property of the inks is not perfect, and
the color produced from a mix of C, M, and Y inks
is usually a muddy brown color. The introduction of
the black color (K) extends the range of colors
reproducible and enhances the contrast of the print-
out.

Expression supports CMYK values. However, in
order for CMYK values to be interpreted and dis-
played consistently, a CMYK color profile must be

The HSL model. (Color plate on page 193.)

The CMY model. (Color plate on page 193.)
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specified in the “Color Management Setup” dialog
as is described in Section 4.2. If no such profile is
chosen, Expression uses its default method to con-
vert CMYK values to and from standard color
spaces.

4.1.4 Custom Colors
Another intuitive and yet consistent way to commu-
nicate colors is to use one of the standard named
color systems like PANTONE, Trumatch, Focol-
tone etc. To keep the licensing cost low, Expression
3 currently does not ship with the major, named
color systems. However, Expression allows the
importing of swatch library files from Illustrator
files. You can also define your own, named colors
in the custom color list. By using custom colors in a
design, you can easily revise the color scheme by
re-defining the color values corresponding to the
custom colors used. See Section 8.11.4 and Section
15.1 for more details.

4.1.5 CIE XYZ, L*u*v* and L*a*b*
Neither the RGB nor CMYK gamuts are wide
enough to represent the entire range of colors that is
visible to the human eye. In response to this
problem, the CIE (Commission Internationale
d’Eclairage) devised a standard color space that
contains the entire human visible color range. This
color space uses three abstract imaginary color
components, known as X, Y and Z. All perceivable
colors can be specified by different combinations of
positive values of X,Y and Z. Though useful as a
standardized, device-independent specification of
colors, the XYZ color space is rather unintuitive to
use in general. Except for the Y component, which
corresponds to the brightness of a color, the X and Z
components are not directly related to meaningful
color qualities. Therefore XYZ color values are
mainly used for recording, transmission or internal
computation. Expression 3 does not provide a user
interface for specifying colors in XYZ values.

L*u*v* and L*a*b* are two other
device-independent color spaces that are based on
the XYZ space, but unlike the XYZ space, these
two color spaces are adjusted so that equally spaced
color values in the spaces have more or less similar
perceived differences. These two spaces are
therefore known as perceptually uniform color
spaces. Again, because L*u*v* and L*a*b* values
are not intuitive color spaces, Expression 3
currently does not support specification of colors in
these color spaces.

4.2 Color Management
Color management is the process of the conversion
between colors described in different device depen-
dent/independent color spaces to achieve color con-
sistency and accurate visual display and printout.
For example, when a graphics object is to be dis-
played on the monitor screen, the sRGB color val-
ues are converted to the device-specific RGB
values of the monitor through color matching func-
tions.

The use of color management helps to ensure that
what you see on your monitor is what you see in
print, and what others see on their monitors.

4.2.1 Color Profiles
Expression relies on ICC (International Color Con-
sortium) color profiles to provide specifications of
the monitor and CMYK space characteristics, and
to carry out color management functions. Macin-
tosh users need to have ColorSync 2.6.1 or later
installed. The Windows version of Expression
relies on ICM 2.0 (Image Color Management).
ICM 2.0 is available only on Windows 98, Win-
dows 2000, Windows ME, XP and later. The color
management functions will not work on Windows
95. You also need to obtain the appropriate (and cal-
ibrated) ICC profiles for your intended display and
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output devices. Please check the web sites of your
monitor and printer manufacturers to obtain the
appropriate ICC profiles and information on cali-
brating the profiles.

In Expression 3, the most important color profile
that needs to be set up properly is the monitor color
profile. If you have already set up your monitor pro-
file properly under your operating system, Expres-
sion 3 will automatically select and use the same
monitor profile. So, normally, you should not need
to make any special changes. If you will be using
CMYK colors, the CMYK color profile should also
be set up accurately in order for the colors in the
final process-color printout to be accurately simu-
lated on your monitor screen.

4.2.2 sRGB Space and RGB 
Bitmap Export
In Expression 3, all color values specified using the
RGB or HSL picker are recorded in the sRGB
space. When rasterizing a picture to one of the sup-
ported image formats, Expression 3 currently
always exports the pixel values in the sRGB space.
An ICC profile for the sRGB space is also embed-
ded in the exported file, if the particular format sup-
ports ICC profile embedding. When you take an
image rasterized from Expression, and open it in
another application, the application should be able
to recognize the color values as sRGB values, and
perform the appropriate conversions. If the format
of the image you have export into does not support
profile embedding (e.g., JPEG), you need to explic-
itly specify to the application that the sRGB profile
should be assumed for the pixel values. Most
graphics applications assume the default profile to
be sRGB when opening images without embedded

ICC profiles. Therefore images rasterized from
Expression should normally need no special han-
dling when opened in other applications.

4.2.3 Rendering Intents
During most of time you are spending on a picture,
you would want your colors to be displayed accu-
rately as specified. This is the standard behavior of
the color management functions performed by
Expression. However, not all monitors are born
equal, and the sRGB colors you use may often fall
outside the displayable range of your monitor.
When this happens, the color management func-
tions have to allow for a compromise, and substi-
tute the colors that cannot be displayed with those
that can.

There are different strategies for doing this. One
strategy is to simply clip the out-of-range color and
replace it with the displayable color closest to it.
This leaves most colors unchanged, but shades and
variations at areas with many out-of-range colors
are flattened. Another color manager may compress
the entire color range (non-uniformly) in order to
preserve the subtleties and details in the picture, at
the expense of slightly shifting all colors. Whether
such shift in color is acceptable or not depends on
how you intend to use your picture. If most colors
in the picture need to be absolutely accurate, the
gamut compression strategy will not be a good
choice. The color management functions used by
Expression 3 allow you to choose different strate-
gies for color matching. This is specified in the
“Rendering Intent” popup in the “Color Manage-
ment Setup” dialog.

The four “Intents” defined by ICC are:

• Perceptual: This rendering intent maps one
gamut to another through a smooth global
gamut transformation. All colors will be shifted
but the tonal variations are preserved.

• Saturation: This intent attempts to preserve
the saturation of the colors at the expense of
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other color qualities. For example, if a saturated
green is not displayable, an equally saturated
color of a different hue or brightness will be
used instead. This approach does not produce
good results in general, except when used for
business graphics, where color vividness is
more important than color accuracy.

• Relative Colorimetric: This approach
replaces out-of-gamut colors with the closest
match, after making an overall adjustment to
map the white point of the source color space to
that of the destination color space. This is the
default rendering intent in Expression 3.

• Absolute Colorimetric: This approach also
replaces out-of-gamut colors with the closest
match, but without making any global white
point mapping adjustment.

4.2.4 Soft Proofing
Sometimes, you may want to see how colors will
appear when displayed or printed on other devices,
and to see a simulation on your screen. This is
known as soft proofing for that particular output
device. Expression does not normally perform
proofing, unless you explicitly turn on the option in
the “Color Management Setup” dialog.

If the target output device has a wider color gamut
than your current monitor screen, all colors should
be faithfully rendered. The simulated appearance
(or the proof) should also be identical to what you
normally see on your monitor screen. However,
printers generally have a much more limited color
gamut than monitor screens — for example, it is
usually impossible to reproduce the brilliant blues
and vivid greens easily displayed in most monitors.
If your picture uses any of these out-of-range col-
ors, these colors will have to be substituted by other
printable ones, using one strategy or another.
Again, your choice should be made according to the
intended use of your output. You can choose which
strategy to adopt in the Proofing Intent popup of the

“Color Management Setup” dialog. The meaning of
the proofing intents are identical to that of the ren-
dering intents except that it describes how to map
colors from our sRGB colors to the printer color
profile. This setting is applicable only if proofing is
turned on.

Note that the proofing option and your choice of
proofing intents will not affect the actual printing
process. What the proofing intent describes is a
simulation, for proofing purposes, of your picture’s
colors after conversion to and back from the
printer’s color space to your current monitor. When
you actually print your picture, the printer or printer
driver software will perform its own color manage-
ment functions. At that point, you should again
specify the desired rendering intent for the printing
process, if your printer driver provides such
choices. If the picture is to be sent to a printing
press for offset printing, please consult the techni-
cal staff to learn more about their specific process
before determining the best strategy and work flow.

4.2.5 Using Color Management
1. Choose File > Color Management. This opens a

“Color Management Setup” dialog.

2. Choose the monitor and CMYK profiles. If you
do not want to use color management, turn off
the “Enable Color Management” option.

3. Choose an appropriate Rendering Intent to
specify the strategy for handling gamut mis-
match between the internal sRGB space, the

The “Color Management Setup” dialog.
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chosen CMYK profile and the output monitor
profile.

4. If you want to see all colors as a soft proof sim-
ulating the output to a particular output device,
turn on the “Proofing for” option, and choose
the color profile for your output device. Note
that this choice of printer profile does not affect

the actual printing process or color values of
rasterized pixels in any way. Choose an appro-
priate proofing intent to specify the strategy for
handling gamut mismatch between the printer
profile and the monitor profile.

5. Click “OK”. The screen will be refreshed after
the color conversion tables have been built.
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Chapter 5: Expression Picture Document 
Structure and View

An Expression picture is a structured document
storing a hierarchy of graphics objects created by
the user. Each object has a unique stacking order in
the object hierarchy. For convenience and ease of
managing a complex composition, you can option-
ally create sub-structures like groups and layers
among objects.

5.1 Expression Document
An Expression document is a self-contained picture
file. Any resources used in the picture, e.g., pat-
terns, gradients, strokes, paper textures etc., are
recorded in a resource section in the document.
This makes it possible for picture documents to be
carried to another, different system and to still be
opened correctly.

Although a document and an installation used to
open the document may both contain resources
with the same names, the definitions of these
resources are not necessarily identical. So when a
document is opened, the local resources (i.e., the
document’s resources), with the exception of gradi-
ents and custom colors, are not normally shown in
the palettes. If you want the local resources to

become system-wide resources for future use, you
need to edit and re-define them specifically.

5.1.1 Auto-Save and Rescue 
Files
To safeguard your precious art creations, Expres-
sion 3 will, from time to time, automatically save
the document currently being worked on to the disk
in a less self-contained format. Such files are
known as rescue files. In the case of a system failure
or program error, the contents of the rescue files
will be re-opened on re-starting Expression.

The idea of the rescue file is to provide a quick way
to back up your unfinished picture. A rescue file
does not have a resource section recording all the
resources used in the original file. To make the sav-
ing of rescue files less intrusive, bitmap image data
is also not saved; only place-holder frames for bit-
map images are saved into rescue files. Therefore
you must not rely on rescue files as a means to save
pictures. Rescue files are nothing more than a
safety mechanism to minimize data loss in case of
unexpected problems.

If you make no modifications to a picture docu-
ment, or if you have just saved it, no operation to

Local resources.
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auto-save to a rescue file will be performed. Other-
wise, auto-saving will take place after a certain
period of time has elapsed from the time of the
modifications, when the program is idle. You can
also adjust the auto-save frequency in the “Print,
Save and Export” page of the “Preferences” dialog
(Section 18.5.2).

5.2 Document Frame, Ruler 
Units, Origin
The positions of graphics objects are recorded
internally in a coordinate system with the origin at
the bottom left corner of a reference frame known
as the document frame. You can move the origin to
any other position, inside or outside the paper
frame, according to your measurement needs. The
document frame is normally used for identifying
the boundary of the intended output area. However,
if you like, you can freely create objects outside the
document frame and, by setting up crop marks
(Section 17.2), specify any other region for output
and printing. You can specify the size and orienta-
tion of the document frame in the “Document
Setup” dialog.

The size and coordinates of objects are recorded
internally using an abstract numerical unit. In the
various UI controls, measurements are displayed in
one of the standard length units: inch, centimeter,
millimeter, point or pica (1 pica=12 points). In
Expression, the point is taken to be exactly 1/72

inch, following the PostScript definition for com-
patibility.

5.3 Grid and Guides

5.3.1 Using the Grid
A grid can be shown in the document window as a
visual reference, or as a snapping guide for creating
and positioning paths. The spacing of the grid can
be specified in the “View and Display” page of the
“Preferences” dialog (Section 18.4.1). Note that the
grid is always drawn upright, regardless of how the
document is rotated, and is always relative to the
current origin of the picture document.

• Showing the grid: Enable or disable View >
Show > Grid as needed.

You can optionally set up a visible grid for position-
ing and alignment purposes. The settings for the
ruler unit, origin, grid spacing and paper frame are
all recorded in each Expression 3 picture file. Dif-
ferent pictures can have their own independent set-
tings.

Besides the regular grid, arbitrary paths can be
turned into guides for snapping and alignment pur-
poses.
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5.3.2 Creating Guides
1. Select the paths you want to turn into guides

using one of the selection tools.
2. Choose Objects > Guide > Make to turn all

selected paths into guides. Each guide will be
displayed as a semi-transparent thin line on top
of all other graphics objects.

Normally when you edit or transform selected
objects, the nodes of the objects will snap to nearby
guides or grid lines. You could turn on or off this
snapping behavior using the menu commands View
> Snap > To Guides or View > Snap > To Grid.

If guide snapping is turned on, all guides will be
shown as semi-transparent thin blue lines, other-
wise they will be shown as semi-transparent thin
black lines.

For more information on snapping, see Section
11.4.

5.4 Graphics Objects
There are many different types of graphics objects
in Expression 3. Simple objects include: paths,
ellipses, clones and images. There are also struc-
tured objects built up from other simple objects:
text, clipping groups, warp groups and effect line
groups.

Path Objects
Paths are the basic build-
ing blocks in Expression.
You can apply various
strokes and fill, and use
them to build new skeletal strokes and patterns. The

appearance of paths can also be further distorted by
warping them as if they were bitmaps. Paths are
also useful as clipping paths and positioning guides.

Ellipse Objects
Ellipse objects are special kinds of paths. An ellipse
object has only two editable nodes, which, if edited,
would open up the ellipse into an arc. The two
nodes would be the end points of the arc. The arc
could take one of the three arc modes: open arc
mode, pie mode, or with chord (closed arc) mode.

Cloned Paths
A cloned path,
or simply a
clone, can be
created from
any path
object. The shape of a clone follows that of the orig-
inal path object. When the shape of the original path
is modified, that of the clone follows. A clone has it
own transformation and paint style attributes.
Clones are sometimes useful for creating different
instances of the same shape in different places.

Clippers (or Masks)
A clipper (or mask as is called in
some drawing applications) is a
path used for clipping other
graphics objects. A path
becomes a clipper when it is
defined into a clipping group
together with other objects to be clipped. A clipper
in Expression retains its original stroke and fill
attributes, but is rendered is a special way: its fill is
used as a background for the entire clipping group
and its stroke is rendered on top of the entire clipper
group, outlining the clipping group. In a way, other
objects in the clipping group are sandwiched
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between the filled background and the stroked out-
line of the clipper.

Text Objects
A text object is a special group of text characters,
which are special closed paths whose shapes are
based on the glyph shapes defined in the Font being
used. Each text character can have its own stroke
and fill attributes. Text can be selected, transformed
and otherwise treated as normal paths. They can
also be converted into ordinary paths.

Text objects can exist on their own or be fitted onto
or inside another path object. If a text object is fitted
on a path, the text characters will flow along the
outline of the attached path. If fitted inside, the
attached path will be used as a frame for the text to
flow within, justified or otherwise.

Warp Groups
One or more path or text objects can be made into a
warp group for overall non-linear deformation
through manipulating a warp grid. The objects
within a warp group remain fully editable.

A detailed description of various paths and path
related objects, like text, clipping groups and warp
groups, can be found in Chapter 7.

Bitmap Objects
Bitmaps are images in grids of pixels with fixed
resolution, and can be imported (see Section 5.11)

or created from scratch. Expression supports bit-
maps with transparency and you can define bitmap
strokes from bitmaps. Photoshop and compatible
filters can also be applied to bitmaps. Chapter 14
contains a detailed description on the use of bitmap
images in Expression 3.

Effect Line Groups
Effect Line Groups are special
objects formed from two
non-compound path objects (or
one path and its clone). Once
formed, a sequence of effect
lines will be automatically cre-
ated, dynamically, between the
two source paths. There are many parameters and
variations that you could adjust to control the
appearance of effect lines. Effect line groups are
described in more detail in Chapter 13.

5.5 Layers and Groups
The main structural elements in an Expression pic-
ture are groups and layers. Each is a collection of
graphics objects, and can be manipulated as a
whole. Groups and layers are basically the same
thing. It is just conventional to call the top level
groups as layers. Layers also have some special set-
tings for controlling the on-screen display of the
graphics objects within. For example, the color of
the highlights can be specified for each layer to help
users identify the objects in the hierarchy.
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5.5.1 Layers
Layers are the top level structures for graphics
objects. Individual layers can be optionally hidden
or locked. Expression 3 further allows layers to be
frozen, i.e., temporarily rasterized, to make
on-screen redraw as efficient as possible.

An analogy to the use of layers is the stacking of
painted transparent celluloid films. Each layer is
like one such film, on which graphics objects are
drawn. When you want to focus on the graphics in
one of the layers, you can hide or lock all other lay-
ers so as not to be distracted by objects in other lay-
ers.

Expression documents usually contain at least one
layer. When you create a new Expression docu-
ment, an empty layer with a pre-assigned name will
be automatically created.

The layered structure of a document
can be inspected and modified in
the Object List palette (Section
11.7) or in the Layer mini-list (Sec-
tion 11.6) at the right side of the
document view. Layers can be cre-
ated, deleted or have their settings

modified through the lists.

5.5.2 Groups
In some cases, objects are logically related to each
other, and should be treated as a whole. Grouping
allows this to be realized. All types of objects can
be made to form an object group, which can then be
conveniently selected as a whole, or as individual
objects. However, you can only group objects (and
object groups) that come from the same layer.

• Forming object groups: Select the objects,
and choose Arrange > Group. Alternatively, use
the keyboard shortcut +G.

• Breaking up object groups: Select the
group, and choose Arrange > Ungroup. Alter-
natively, use the keyboard shortcut +U.

5.6 The Expression 
Workspace
The Expression workspace consists of the menu
bar, the status bar, various palettes and tools.
Expression pictures are created and generally
worked on in the view area of document windows,
which have various viewing features themselves.

5.6.1 About the Status Bar
The status bar in the workspace gives information
about tools, menus and operations. You can hide
and show the status bar using Windows > Status
Bar.

• Showing tool usage: The status bar shows
some information related to the operation of the
currently chosen tool.

• Showing transformation values: During
an object transformation, the status bar shows
the numerical values in real time. For example,
during an object rotation, the coordinates of the
center of rotation and the angle rotated will be
updated as you drag with the Rotate tool.

• Showing steps for canceling tasks: The
status bar shows instructions for canceling
time-consuming tasks, like rasterization, before
they are completed.

• Showing memory usage (Mac OS 8/9
only): The status bar shows Expression’s
memory usage and the available resources on
the system. The first value in the square brack-
ets (labeled “Free”) is the size of the heap mem-
ory allocated to Expression; it is best to allocate
more memory to Expression before starting it.
The second value is the amount of free memory
in the system. The next value (labeled “Used”)
is the total amount of memory used in Expres-
sion. This value is broken down into the amount
from the application heap and the amount from
the system heap, when Expression starts using
memory from the system’s heap. In such a case,
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the memory level may be so low as to stop other
applications from starting.

5.7 Document Windows
For every document that you create or open, a sep-
arate document window will be opened, with the
name of the file shown in the title bar and the Flip
bar.

5.7.1 View Area and View 
Parameters
The most important part of a document window is
the view area. Because graphics objects can be
placed basically anywhere in the boundless space,
inside or outside the document frame, the view area

could display only a portion, i.e., a view, of this vast
space. All drawing and manipulation of graphics
objects are made through this view area. You can
pan the view to display other parts of a picture,
zoom in and out to change the magnification level
of the view, and rotate the view for the most conve-
nient orientation to work on a drawing.

These view parameters are mostly directly visible
and controllable through UIs in the document win-
dow: the X-Y position of the view can be read off
from the rulers and changed by dragging the rulers;
the magnification level is displayed in the Zoom
popup at the bottom left corner and changed by
clicking the Zoom popup.

If a view has been rotated, the ruler units will not be
shown. They will re-appear when the view rotation
is reset to the upright direction. The menu com-
mands under the View menu are also convenient for
changing and resetting the view parameters.

New windows are normally opened at the same size
and at the same on-screen position as the window
that was previously in focus. In addition, the view
parameters, like view positions and magnification
levels of the windows, are automatically synchro-
nized, using the bottom left corner of the document
frame as a reference point. This synchronization
behavior is designed to allow users to easily trace
another opened document when the onion skin
mode is turned on. It also makes flipping between
documents consistent.

5.7.2 Disabling View Parameter 
Synchronization
You can optionally disable this synchronization of
view parameters by unchecking the “Flip view syn-
chronizes view parameters” checkbox in the “View
and Display” page of the “Preferences” dialog
(Section 18.4.4).

A View area
B Document frame
C Ruler
D Ruler unit
E Crop marks
F Zoom popup
G Resize handles
H Flip tabs on the 

flip bar
I New layer

J Delete layer
K Layer settings
L Layer color box
M Object selection indica-

tor
N Locking status indicator
O Visibility status indicator
P Active layer
Q Layer mini-list

The document window.
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5.7.3 Arranging and Switching 
Windows
• Moving windows: Drag a document win-

dow’s title bar to move it.
• Resizing, collapsing and closing win-

dows: Use the standard window buttons. Only
Macintosh OS 8/9 windows can be collapsed.

• Arranging windows (Windows only): In
the Window menu, choose Cascade or Tile as
needed.

• Opening additional document win-
dows for the current document: Choose
View > New View.

• Switching windows without aligning
them: Click the window’s title bar or its view
to switch focus to it. Alternatively, on Win-
dows, choose the name of the document in the
Window menu.

• Switching and aligning windows: Click
the flip tab of the window you want to switch
to.

5.7.4 Viewing Document Names
When more than one document is opened, Expres-
sion will offset the flip tabs in order to accommo-
date them all. Flip tabs are arranged according to
the alphabetical order of the file names, so a file
called “ABCpict” will come before the file “BCD-
pict”, and you will see the “ABCpict” tab to the left
of the “BCDpict” tab. The ordering of windows has
significance when you use document flipping or
onion skin display.

If more than one window is opened for the same
document, the document name in each title bar will
be followed by a number to indicate the order in

which the window was opened, e.g., “Tree:1”,
“Tree:2”, “Tree:3” etc.

5.7.5 Setting the Document 
Frame
The document frame sets the intended output area
of a document, and its dimensions are saved in the
file. This frame size can be different from the paper
size.

1. Choose File > Document Setup.
2. In the dialog that is opened, choose the paper

size you want, or choose the “Custom” option,
and enter the dimensions as needed.

3. Choose the orientation as needed.
4. Enable the “Use as Default” option if you want

to use these settings for all new documents as
well. Click “OK”.

5.7.6 Using the Rulers
The pair of rulers sets the coordinate system of the
document window, and indicates pointer positions
in the view area.

A Grid
B Document frame

C Paper frame based on 
printer’s settings

D Printer’s paper margins
The view area.



32 Expression 3 Manual
Since the view area does not have a well-defined
limit, scroll bars are not suitable controls for scroll-
ing the view area. In Expression 3, the rulers are
also used for panning or scrolling the view area.
Simply drag the ruler to pan the view synchro-
nously. The vertical ruler is for vertical panning,
and the horizontal ruler horizontal panning. The
cursor will turn into a grabbing hand when it is
above the rulers, hinting that they are ready to be
dragged. There are many other convenient methods
to navigate around the picture view. Refer to Sec-
tion 5.8 for more details.

Usually, the ruler origin is at the bottom left corner
of the document frame.

• Setting ruler origin: Choose Edit > Set Ruler
Origin (the pointer becomes ). Click-drag in
the view area, and release the mouse button
when you reach the position you want the ruler
origin to be.

• Changing ruler units: You can change the
ruler units in the “Preferences” dialog (see Sec-
tion 18.4.3).

5.7.7 Setting Display Quality
Display quality refers to the different ways with
which objects can be shown in the view area.

You may want to use a lower quality display to
reduce the time for screen refresh, when arranging
objects in a view full of objects. For details on set-
ting display quality in the “Preferences” dialog, see
Section 18.4.2.

• Using path quality: Choose View > Display
Quality > Path to view paths in their skeletons
only.

• Using wireframe quality: Choose View >
Display Quality > Wireframe to view paths as
outlined shapes plus their skeletons (the curves
themselves).

• Using preview quality: Choose View > Dis-
play Quality > Preview to view paths in full,
including all stroke and fill attributes.

• Using better preview quality: Enable View
> Display Quality > Better Preview to improve
the display of bitmaps by using pixel interpola-
tion and better handling of overlapping regions
of bitmap strokes and paper textures.

5.7.8 The Layer Mini-List
A Layer mini-list can optionally be displayed on the
right side of the document window. The list pro-
vides a very compact UI for displaying the layer
structure of a document and for managing object
selections and layers. For a complete description of
the use of the Layer mini-list and the related but
more powerful Object List palette, refer to Section
11.6 and Section 11.7.

To show or hide the display of the Layer mini-list,
use the menu command View > Show > Layer
Mini-List.

From left to right: preview quality, wireframe 
quality, and path quality.

Original display (left), and display using the “Bet-
ter Preview” option (right).
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5.8 Navigating around a 
Picture
The view area in the document window is the place
for drawing and editing pictures. You can scroll and
zoom the view area using tools, using features in
the document window, and using menu commands.
For more specific viewing features (e.g., at the
object or layer level), refer to Section 11.6 and Sec-
tion 11.7.

5.8.1 Scrolling
• Scrolling with the rulers: Drag the horizon-

tal ruler to scroll horizontally, and the vertical
ruler to scroll vertically.

• Using the mouse wheel: You can choose to
use the mouse wheel for scrolling in the hori-
zontal or vertical direction. See Section 18.3.4.

5.8.2 Zooming with Tools and 
Other Devices
• Using the Hand tool: Choose the Hand tool

 (or hold the Spacebar key so that the pointer
becomes ), and drag in the view area to
scroll it.

• Using the Zoom popup button: Click-hold
the Zoom popup button to show a list of avail-
able magnification levels, and drag to the one
you want.

• Using the Zoom tool: Choose the Zoom tool
. The pointer becomes . To zoom in, click

the view area. To zoom out, hold  (the
pointer becomes ), and click instead. To
zoom into a particular area, drag diagonally
across that area.

• Using the mouse wheel: You can choose to
use the mouse wheel for zooming in and out.
You can also choose to use the pointer position
as the zoom center, so that graphics at the
pointer position will always stay within the
view area regardless of the magnification level.
See Section 18.3.4.

5.8.3 Using Zooming 
Commands
The View menu has commands for more specific
zooming operations.

• Zooming in: Choose View > Zoom In to zoom
to a higher magnification level.

• Zooming out: Choose View > Zoom Out to
zoom to a lower magnification level.

• Zooming into objects: Choose View >
Zoom On Selection to zoom to the highest
zoom level under which the object selection can
be fully shown. See also Section 11.7.4 for
locating and zooming on objects in the Object
List palette.

• Viewing all objects: Choose View > View
All to zoom to the highest zoom level under
which all visible objects in the file can be fully
shown.

• Viewing documents at actual size:
Choose View > Actual Size to view the docu-
ment at the actual size.

• Viewing documents in center view:
Choose View > Center View to view the docu-
ment with the document frame in the center.

5.8.4 Rotating the View Area
The view area in the document window can be
rotated in steps, each at an offset of 22.5 degrees, or
one-sixteenth of a cycle.

• Rotating the view area: In the View menu,
choose “Rotate Clockwise” or “Rotate

Scrolling the view area by dragging the ruler.
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Counterclockwise” as needed. More conve-
niently, these commands can also be applied
using the { and } keyboard shortcuts.

• Resetting view rotation: Choose View >
Reset View Rotation to revert the view area to
its original, upright position.

If you have a tablet device that reports the tilt angles
of the stylus or a WACOM 4D Mouse or compati-
ble device supporting Z-Axis rotation, the view
rotation can be directly controlled when the Hand
tool  is selected. In such a case, there are no
pre-defined rotation steps and you can continuously
turn the view to any angle you like. This direct view
rotation function can be turned off in the “Tools”
page in the “Preferences” dialog (Section 18.3.4).

5.9 Flipping Documents
Document windows can be aligned and shown one
after another in succession, like the way an anima-

tor flips the pages of a stack of drawings. Flipping
is useful for checking the smoothness of an action
sequence, and in Expression, you can flip opened
documents forward or backward in the alphabetical
order of their file names.

• Flipping documents: Press the ] key repeat-
edly to align and flip opened documents for-
ward, starting from the window currently in
focus. To flip documents backward, press the [
key repeatedly instead. Note that the above key-
board shortcuts work only if you have not
rebound the document flipping commands in
the “Keyboard Shortcuts” page of the “Prefer-
ences” dialog.

• Scrubbing documents: Drag horizontally
from one flip tab to another.

5.10 Using Onion Skin 
Display
Onion skin display refers to the option of allowing
another opened document to be shown through as a
faint image in the current document window. This
image cannot be edited, and is useful as a reference
or for tracing.

You can make the previous or next file (according
to the alphabetical order of the file names) show
through. Unless you have turned off the “Flip view
synchronizes view parameters” option in the “Pref-
erences” dialog, Expression will always keep the
two overlapping document windows (the current
window and the one showing through) aligned,
even when you scroll, zoom or rotate the view area.

• Enabling onion skin display: Choose the
“Show Previous” or “Show Next” option from

A rotated view area allows you to create 
graphic elements in an orientation that is natu-
ral to you.
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View > Onion Skin. To turn off onion skin dis-
play, choose “Off”.

5.11 Opening Files and 
Importing Objects
You can open picture files in Expression by opening
them directly (for files in Expression format and
other supported vector formats), by importing them
into opened files (for bitmap formats), and by past-
ing them from the clipboard.

Vector file formats that can be opened in Expres-
sion include Expression 2 and earlier, Illustrator 8
and earlier, EPS, WMF (Windows only), and EMF
(Windows only).

Bitmap file formats that can be imported into
Expression include PSD, TIFF, JPEG, GIF89a,
PNG, BMP (Windows only), and other formats
through third party plugins.

• Opening files: Choose File > Open. In the
“Open Picture File” dialog (Macintosh) or the
“File Open” dialog (Windows), click the file
you want. If the file had been saved with a
thumbnail image, it will be shown too, unless
you click the “Hide Preview” button (Macin-
tosh) or disable the “Show Preview” box (Win-
dows). On Windows, you can choose more files
by clicking or dragging with the Shift or Ctrl
keys.

Using onion skin display. Here the previous doc-
ument is shown through as a faint image.

A Chosen file
B Thumbnail image

C Hide Preview button

The Navigation Services dialog on the Macin-
tosh (for Mac OS 8.5 and later). On operating 
systems without support for the Mac OS Naviga-
tion Services, the classic “Open File” dialog will 
be used, without the thumbnail.

A Thumbnail image
B Chosen files

C Show Preview box

The “File Open” dialog on Windows.
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• Converting Illustrator art brushes: When
you open an Illustrator file with art brushes in
it, you can choose to convert them into skeletal
strokes, or leave them as vector objects.

• Importing bitmap files: Choose File > Insert
Bitmap. In the dialog that is opened, click the
file you want.

• Pasting objects from the clipboard:
Copy the objects you want (vector graphics,
bitmaps or text from another application) to the
clipboard using the Edit > Copy command in
that application. In Expression, choose the
“Paste”, “Paste In Front” or “Paste In Back”
command from the Edit menu as needed. For a
description of these commands, see Section
11.3.2.

5.12 Reversing Document 
Changes
The changes that you make to a document can be
reversed one step at a time for a set number of
times, or reversed all the way to the state when the
file was last saved. You can set the number of undo
levels in the “Preferences” dialog (see Section
18.2.1).

• Reversing the last change to a file:
Choose Edit > Undo.

• Reversing the last undo action: Choose
Edit > Redo.

• Reverting to the state when the file was
last saved: Choose File > Revert To Saved.
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Chapter 6: Floating Palettes, Controls and 
Palette Management

Expression’s various features are available from the
palettes, each of which is responsible for a different
set of tasks. For example, to choose colors and gra-
dients, you will use the Paint Style palette, and to
see the layer and object structure, you will use the
Object List palette.

Palettes in general show information about objects
currently selected, and let you make changes to
them. If you select a path and then choose a stroke
from the Strokes palette, the stroke will be applied
to the path at once. The stroke will also be shown in
the Paint Style palette’s Stroke Preview, which is
updated whenever certain stroke related attributes
are changed.

The choices that you make in a palette will remain
after all objects have been deselected, or after the
palette has been hidden, or after you have switched
to another document window (unless that other
document window already contains selected
objects, in which case the palette will be updated to
reflect the status of that object selection). These
palette settings will not be updated until you change
them yourself, or until you select another object.
This design lets you use previous settings on new
objects, and is useful for drawing new paths.

Before introducing each palette, some of the palette
controls that are unique to Expression will be
described first.

6.1 Using Palettes
Palettes can be placed anywhere. Some can be
docked (all Windows palettes except the Object
List and Item List palettes), and some can snap to
other palettes (all Macintosh palettes and Windows’
Strokes, Object List and Item List palettes).

• Showing and hiding palettes: Choose a
palette’s name in the Window menu or use its
keyboard shortcut (F2 to F11) to show or hide
it. To hide a palette, you can also click its Close
button. To hide all palettes except the one you
want (Macintosh only), hold the Command
key and enter the keyboard shortcut of the pal-
ette you want to stay.

• Moving palettes: Drag a palette’s title bar to
move the palette to a new position. See also
Section 6.1.1 about behavior of cling-on pal-
ettes.

• Snapping palettes: Drag a palette near
another one. Both palettes must be snappable.

• Collapsing palettes (Macintosh only): In
Mac Classic and Windows, double-click the
title bar of a palette to toggle between the col-
lapsed state (with only the title bar showing)
and the normal state. In Mac OS X, because this
behavior is not natively supported by the OS,
you need to hold the Option or Command
key and click the title bar instead.

Expression’s palettes.
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6.1.1 About Cling-On Palettes 
(Macintosh Only)
All Macintosh palettes are cling-on palettes. When
one cling-on palette is being dragged around, any
palette that is currently snapped to its bottom edge
will be moved with it. So, for example, if three pal-
ettes are snapped one on top of another, dragging
the top palette will cause all three palettes to move,
but dragging the middle palette will move only
middle and bottom palettes.

When you collapse a cling-on palette, any palette
currently snapped to its bottom edge (and all pal-
ettes following it) will shift upwards to remain
snapped to the collapsed palette. Similarly, when
you expand a collapsed cling-on palette, the pal-
ettes “clinging” on to it will shift downwards.

6.1.2 About Dockable Palettes 
(Windows Only)
All Windows palettes, except the Object List and
Item List palettes, are dockable palettes. Docking
snaps a palette to the top left or top right edge of the
workspace, and keeps it snapped to the edge even
when the workspace is re-sized or moved. When
more than one palette is docked, they form a stack
of palettes down the edge of the workspace. If you
like, you can turn off the docking behavior of pal-
ettes all together in the “Preferences” dialog (Sec-
tion 18.2.3).

• Docking palettes: Drag the title bar of a
dockable palette to the left or right edge of the

workspace to dock it there. Alternatively, dou-
ble-click its title bar to dock it to the left edge.

• Arranging docked palettes: Drag the title
bar of a docked palette up or down to move the
palette up or down the stack of docked palettes.

• Releasing docked palettes: Hold Ctrl and
click a palette’s title bar to float it. Alterna-
tively, drag its title bar away from the edge of
the workspace.

6.2 Using Sliders
The slider is a common control in palettes, and is
useful for adjusting an attribute’s value between the
value limits.

• Viewing numbers: Click-hold the slider area
to view the value in numbers. (For sliders with-
out accompanying meters only.)

• Choosing values: Drag the slider to choose a
value.

• Previewing colors: For sliders showing
color values (e.g., the RGB sliders in the Paint
Style palette), the slider areas themselves show
the color spectrum that is covered by the range.

• Using numerical entries: Double-click the
slider area to open a dialog for entering the
value.

• Snapping to zero values: If a slider’s val-
ues range from negative to positive (e.g., the
Shear slider in the Attributes palette), it will
snap to the zero mark when you start dragging
from a non-zero value and approach the zero
mark.

The Opacity sliders.
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• Using double sliders: For a double slider
(e.g., the Stroke/Fill Opacity sliders in the Paint
Style palette), the two sub-sliders can be moved
separately by dragging one of them at the end
that is not touching the other sub-slider. To
move two sub-sliders as one, +drag one
of them, or, if they are already at the same posi-
tion, start dragging where they touch in the
middle. The  pointer will change into 
when you are operating both sliders simulta-
neously.

• Using slider/meter pairs: For sliders with
accompanying meters (e.g., the RGB sliders in
the Paint Style palette), changes in the sliders
will be reflected in the meters immediately.

6.3 Using Meters
The meter shows a value in numbers, possibly with
units, and lets you make both big and small changes
to that value, without having to switch between
mouse/stylus and keyboard.

• Changing digit by digit: Drag any digit
up/down to change it one unit at a time. Make
big changes by dragging more significant digits
(e.g., digit “4” in the value “416.22”); make
fine adjustments by dragging less significant
digits. Digits will overflow and underflow auto-
matically. For example, dragging the digit “9”
in the value “9.35” upwards will update the
value to “10.35”, and dragging the digit “1” in
the value “1.35” downwards will likewise
update the value to “0.35”.

• Changing number of decimal places:
Drag the decimal place icon (the dot) to the
left/right to change the number of decimal
places.

• Changing units: Drag the unit digit up/down
to change the unit. The numerical value shown
will be updated immediately.

• Switching signs: For meters that support both
positive and negative numbers (e.g., the meters
in the Transformation palette), you can drag an
empty digit space (left of the value digits)
downwards to switch the value from positive to
negative. Similarly, to switch a value from neg-
ative to positive, drag the digit with the nega-
tive sign upwards.

• Setting values to or from zero: Hold 
and click any digit to quickly reset the meter
value to zero or the minimum allowed value. If
it is not the minimum value you are aiming at,
but you want to start dragging the meter from
the minimum value, hold  and drag
instead.

• Using keyboard: Click any digit to highlight
all digits, and you can enter the whole value
(including decimal places if needed) by key-
board. Press the Return/Enter key to apply the
value. Negative numbers can be entered in the
form of a number followed by the Minus key
(-), e.g., the value “-41.22” should be entered in
the sequence of “41.22-”. Note, however, that
you cannot enter a number with more decimal
places than are currently shown in the meter.

• Using dialogs: Double-click any digit to open
a dialog for entering the whole value by key-
board and for changing value units.

• Using slider/meter pairs: For meters that
accompany sliders (e.g., the RGB meters in the
Paint Style palette), changes in the meters will
be reflected in the sliders immediately.

6.4 Using Popup Buttons
The popup button shows your current choice out of
two or more options, and can be distinguished from

The Stroke Width meter.
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an ordinary button by the presence of a small trian-
gular area at either of the lower corners.

• Using buttons with triangles at the bot-
tom left: Clicking such a button will pop up
the options in a list. The Choose Color Picker
button in the Paint Style palette is an example
of such buttons.

• Using buttons with triangles at the bot-
tom right: If the button is already enabled,
clicking the button will toggle through the
available options, and clicking the triangle or
holding the button for one second will pop up
the options in a list. The tool buttons in the
Toolbox palette are examples of such buttons.

6.5 The Toolbox Palette
The Toolbox palette shows the main tools for tasks
such as path creation, selection and editing, as well
as zooming, object transformation, stroke definition
etc. Most tool buttons are popup buttons, and some
tools have additional control buttons which are
shown at the right of the palette when the tool is
chosen.

A short introduction to the tools will be given here.
For more details about each tool, refer to the rele-
vant sections.

The Object Select tool  lets you select objects
and object groups (Section 11.1.1).

The Group Select tool  lets you select objects
within a group (Section 11.1.1).

Using a popup button to choose a tool.

A Object Select tool
Group Select tool
Transform Fill tool
Anchor tool

Repeat tool
B Hand tool
C Freehand Pen tool

Bezier Pen tool
Bitmap Pen tool

D Color Dropper tool
Attribute Dropper tool

E Rectangle tool
Ellipse tool
Twirl Star tool
Line tool

F Cut Path tool
Reverse Path tool
Start Point tool

G Stroke Definition Box tool
Pattern Definition Box tool

H Node tool
Node Lasso tool
Convert Node tool

I Zoom tool
J B-Spline tool

Polyline tool
K Gradient Vector tool

Reference Vector tool
Lighting tool

L Add Node tool
Delete Node tool

M Rotate tool
Scale tool
Mirror tool
Shear tool
Perspective tool

N Text tool
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The Transform Fill tool  lets you transform
gradient, pattern and image fill (Section 8.12.5,
Section 8.13.3 and Section 8.14.3).

The Anchor tool  lets you specify the paths and
nodes to be anchored (Section 10.2).

The Repeat tool  lets you specify objects to be
made repeatable in stroke definitions (Section
10.3).

The Node tool  lets you select and edit nodes
(Section 7.19).

The Node Lasso tool  lets you select and edit
nodes and paths in more global way (Section 7.19).

The Convert Node tool  lets you convert cor-
ner and curve nodes into one another (Section
7.22).

The Hand tool  lets you scroll the view area in
the document window (Section 5.8.2).

The Zoom tool  lets you perform zooming
tasks (Section 5.8.2).

The Freehand Pen tool  lets you create
freely-drawn Bezier paths and perform simple
object selections (Section 7.4).

The Bezier Pen tool  lets you create Bezier
paths (Section 7.7).

The Bitmap Pen tool  lets you paint bitmap
objects (Section 14.2).

The B-Spline tool  lets you create B-spline
paths (Section 7.5).

The Polyline tool  lets you create paths with
line and curve segments (Section 7.6).

The Color Dropper tool  lets you copy colors
across objects and from objects to the Paint Style
palette (Section 15.4).

The Attribute Dropper tool  lets you copy
stroke and fill attributes across objects (Section
15.4).

The Gradient Vector tool  lets you change
the directions and positions of gradients that are
applied to objects (Section 8.12.4).

The Reference Vector tool  lets you assign
reference points and orientation information to
objects for the handling of transformations in object
blending (Section 7.18.2).

The Lighting tool  lets you specify a light
source for shading the embossed fill effect (Section
8.5.4).

The Rectangle tool  lets you create rectangu-
lar paths (Section 7.9).

The Ellipse tool  lets you create elliptical paths
(Section 7.12).

The Twirl Star tool  lets you create paths with
regular and irregular shapes such as stars, polygons
and sickle shapes (Section 7.11).

The Line tool  lets you create paths of straight
lines (Section 7.10).

The Add Node tool  lets you add nodes to
paths (Section 7.23).

The Delete Node tool  lets you delete nodes
from paths (Section 7.23).

The Cut Path tool  lets you split paths (Section
7.23).

The Reverse Path tool  lets you change the
direction of paths (Section 7.23).

The Start Point tool  lets you specify starting
points for closed paths (Section 7.23).

The Rotate tool  lets you rotate objects (Sec-
tion 12.4.2).

The Scale tool  lets you scale objects (Section
12.3.2).

The Mirror tool  lets you reflect objects (Sec-
tion 12.6.1).

The Shear tool  lets you shear objects (Section
12.5.2).
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The Perspective tool  lets you perform per-
spective transformations (Section 12.8.1).

The Stroke Definition Box tool  lets you set a
stroke definition area (Section 10.1.3).

The Pattern Definition Box tool  lets you set
a pattern definition area (Section 15.3.2).

The Text tool  lets you create, select and edit
text objects and characters (Section 7.27).

6.6 The Paint Style Palette
The Paint Style palette provides controls for the
main stroke and fill attributes, such as colors, gradi-
ents, transparency and stroke width.

The Stroke Type buttons at the top right of the pal-
ette let you choose a type of stroke (none, basic,
gradient or skeletal strokes), and the Fill Type but-
tons (three rows below the Stroke Type buttons) let
you choose a type of fill (none, solid, gradient, pat-
tern or image fill).

When you choose a type of stroke or fill, the lower
section of the palette will change accordingly to
show the options for that type of stroke or fill. For
example, if you click the Basic Stroke button, the
color selection controls (the Color picker, the Color
Preview etc.) will be shown in the lower section of
the palette, but if you click the Gradient Fill button,
the gradient selection controls (a list of available
gradients, gradient editing buttons etc.) will be
shown instead.

Besides these attributes, the palette has controls for
transparency, paper textures, blending modes,
stroke width and fill edge width (for soft-edged and
embossed fill). The choices that you make for the
main attributes (such as colors, gradients and trans-
parency) are instantly reflected in the Stroke Pre-
view and Fill Preview. For more details, refer to
Chapter 8.

In fact, most tasks related to colors and gradients
can be handled in the palette. You can create and
edit custom colors and gradients, and when you do
so, the upper section of the palette will change into
a custom color editor or gradient editor as needed.
You can also copy colors across the previews (the
Stroke Preview, Fill Preview and different Color
previews) by a dragging action. For more details,
refer to Chapter 15.

A Stroke preview
B Opacity sliders
C Fill preview
D Color picker
E Paper texture on/off
F Stroke types

G Stroke width meter
H Blending mode 

popup
I Fill types
J Fill width meter
K Lower section

The Paint Style palette.
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6.7 The Attributes Palette
The Attributes palette displays and controls the
more specialized stroke and fill attributes. For more
details, refer to Chapter 9.

6.8 The Font Palette
The Font palette displays and controls the font and
text attributes. For more details, see Section 7.27.

6.9 The Object List Palette
The Object List palette lists a file’s layers and
objects in a tree view, and lets you view, arrange
and lock individual objects and layers. Layers can

be expanded to show objects within. For more
details, refer to Section 11.7.

6.10 The Variable Width 
Palette
One of skeletal strokes’ special features is variable
width, which refers to the uneven variation in the
width of strokes and fill edges (for soft-edged fills
and embossed fills) along stroke paths. Variable
width for strokes and fill edges (for soft-edged fills
and embossed fill) along stroke paths is described
as width profiles, which can be created and applied
from the Variable Width palette.

A width profile is shown as a graph of width varia-
tion against path length, and its shape can be
changed by editing the profile nodes on it. Profiles
can be saved for future use, and the Presets popup
menu lets you choose one from the profile list. For
bitmap strokes, you can use the width profile for

A Shape parameter
B Stroke shear
C Fill rule
D Dash pattern
E Stroke mode

F Stroke continuity
G Stroke joint
H Stroke cap
I Node continuity
J Dash phase offset

The Attributes palette.

A Font name
B Font style
C Baseline shift
D Relative leading
E Text alignment

F Font size
G Tracking
H Horizontal scaling
I Text placement

The Font palette.

A Expand/Collapse 
switch

B Partially selected 
group

C Object type icon
D Selection indicator
E Object selection indi-

cator
F Locking status indica-

tor

G Visibility status indi-
cator

H Active layer indi-
cator

I New layer
J Delete layer
K Locate object
L Zoom on
M Properties
N Collapse all

The Object List palette.
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controlling opacity variations as well. For more
details, refer to Section 8.10 and Section 15.6.

6.11 The Strokes Palette
The Strokes palette lists the skeletal strokes from all
the stroke folders, or, if you like, from a stroke
folder of your choice. The name of the current
stroke folder is shown at the bottom right of the pal-
ette.

Each entry in the stroke list consists of a thumbnail
of the stroke (with a blue dot if it is a multi-view
stroke), the name of the stroke, and the name of the

folder to which the stroke belongs if you have cho-
sen to see strokes from all folders. You can choose
the folder you want to see using the Stroke Folder
popup menu at the bottom right of the palette, and
organise strokes using the Folder Operations popup
button next to it. For more details, refer to Section
10.5.

6.12 The Transformation 
Palette
The Transformation palette is for applying object
transformations (translation, rotation, scaling,
shearing and mirroring) and for setting object size
and position. The meters of the palette change
according to the type of transformation chosen in
the lower section of the palette. For more details,
refer to Chapter 12.

6.13 The Item List Palette
Some stroke and fill attributes that you choose in
the Paint Style palette can be saved in the Item List

A Reset
B Add node
C Delete node
D Presets popup
E Add to presets

F Edit preset list
G Transparency vari-

ability slider
H Width variability 

slider
The Variable Width palette.

A Edit stroke
B Delete stroke

C Folder operations 
popup

D Stroke folder popup
The Strokes palette.

A Translation
B Rotation
C Scaling
D Shearing
E Mirroring

F Bounds
G Size
H Apply to a duplicate
I Apply transformation

The Transformation palette.
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palette as stroke items or fill items. For more
details, refer to Section 15.5.

6.14 The Colorize Palette
The Colorize palette lets you replace the color spec-
trum of one or more vector objects, which may have
different and multiple colors. White, black and any
color in the hue spectrum can be replaced. For more
details, refer to Section 8.17.

6.15 The Effect Lines Palette
The Effect Lines palette is for specifying effect line
attributes, such as line spacing, width, use of clus-
tering, focus point and template path. Most attribute
controls are accompanied by variation sliders for
adding the right amount of random variation to the
attribute settings of the effect lines. For more
details, refer to Chapter 13.

6.16 The Flash Button 
Palette
The Flash Button palette is for choosing and
fine-tuning motion and color effects for objects and

A Create item
B Edit item
C Load item list

D Save item list
E Delete item

The Item List palette.

A HSL color picker
B Black node
C White node
D Selected hue 

node
E Deselected hue 

node

F Brightness slider
G Saturation slider
H Colorized spectrum
I Hue reference ring
J Remove colorization

The Colorize palette.

A Line spacing
B Stroke width
C Clustering on/off, 

cluster size and 
gap size

D Focus on/off
E Start edge varia-

tion

F Spacing variation
G Width variation
H Cluster variation
I End edge variation
J Add template path
K Remove template path
L Reverse line direction
M Create effect lines

The Effect Lines palette.
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groups to be exported as Flash buttons. For more
details, refer to Chapter 16.

A Reset
B Object/Group 

preview
C Motion effects in 

normal, 
pointer-over and 
pointer-click 
states

D Color effects in 
normal, 
pointer-over and 
pointer-click 
states

E Effect cycle time
F Motion effect magni-

tude
G Color effect magnitude
H Number of effect cycles
I Reciprocate on/off
J Export stroke animation
K URL
L Target

The Flash Button palette.
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Chapter 7: Paths, Text and Other Path-Based 
Objects

7.1 Paths: The Basic 
Building Blocks
Paths are core to most vector-based drawing appli-
cations. They are also the basic graphics primitive
in Expression.

A path is just an abstract shape description. When
we refer to a path object, we are actually referring
to the graphics object with a shape defined by a
path, and with various paint style attributes
attached to specify how the path is to be rendered.

Many other graphics objects are actually made up
of path objects. For example, the complex appear-
ance of a vector-based skeletal stroke is composed
of many paths, the strokes of which may in turn
have been made up of other finer paths. Top level
path objects are directly manipulatable by the user.
Other internal path objects within other graphics
objects are generated dynamically and they can
only be controlled indirectly. Text characters in a
text object are also path objects. However, their
shapes are based on the font being used and the
shapes of the text characters are not directly edit-
able (except when a warp group is created from the
text object).

This chapter explains the internals of paths and the
use of paths in detail, together with other
path-based graphics object types.

7.2 Anatomy of a Path
A path is made up of a sequence of curved and
straight segments, and can be made up of different
kinds of curves for different drawing and editing

needs. The curves used in Expression are Bezier
curves and B-splines.

The Bezier curve describes a shape by the positions
of its control points (the nodes) and the condition of
the tangents at each node. For Bezier paths, there is
a pair of tangent handles at each node for control-
ling the curvature and curve continuity at that node.

A Bezier curve can be continuous at some nodes
(i.e., the curve is smooth at those nodes) and dis-
continuous at others (i.e., there may be sharp cor-
ners or cusp points at those nodes).

The B-spline curve is a smooth curve. The kind of
B-spline used in Expression is called uniform
B-spline, with second order continuity, i.e., not only
does the curve have a continuous tangent vector,
but the rate of change of the tangent vectors is also
continuous. Therefore B-splines are generally
much smoother in appearance than Bezier curves.
The shape of a B-spline curve is described by the
positions of its control points, called nodes, which,

Bezier and B-spline paths.
A A path containing only straight line segments.
B A path made up entirely of Bezier curve seg-

ments.
C A path made up entirely of B-spline curve seg-

ments.
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with the exception of the starting and ending nodes
of an open path, do not lie on the curve itself.

Each path has a starting node and an ending node,
which is marked with an arrow when the path is
selected. The direction of this arrow (from starting
node to ending node) is the direction in which
strokes will be applied, and you can reverse the path
direction, or choose another starting node alto-
gether (if the path is a closed one).

Paths can be open-ended (e.g., a simple line) or
closed (e.g., rectangles and circles). An open-ended
path can be appended to another open-ended path,
and its fill area is the area bounded by the path and
an imaginary straight line across its starting and
ending nodes.

Compound paths, clones and text objects are three
kinds of special paths, and their usage will be
explained later. See Section 7.16, Section 7.17 and
Section 7.27.

7.3 Creating Paths
Expression provides a number of different drawing
tools for creating paths. You should experiment
with them to find out which is the most convenient
one for you. Using the Freehand Pen tool, you can
directly draw out the shape you want, but with the
node-based drawing tools like the B-Spline tool,
Polyline/Arc tool or Bezier Pen tool, you need to
place each node by clicking (and dragging if you
want to control the tangent as well). Tools for
pre-defined shapes, such as the Ellipse, Rectangle
and Twirl Star tools, let you quickly create a shape
in one single drag of the mouse/stylus. The Text
tool lets you enter text characters from the key-
board.

When used with certain modifier keys, some tools
can have additional control over shapes of paths.
Using the  key with the Rectangle tool will
create squares, and using it with the Bezier Pen tool

will constrain the tangent handle angles to certain
angular steps, e.g., at every 45 degrees (or eight
constraint steps in 360 degrees), or at another num-
ber of steps as is set by you in the “Preferences”
dialog (see Section 18.2.2).

7.4 Using the Freehand Pen 
Tool
When you draw a shape using the Freehand Pen
tool, a Bezier curve will be fitted to the trail to form
a path. You can choose how tightly you want the
path to be fitted to the trail in the “Preferences”
dialog (see Section 18.3.2).

To create a freehand path using the Freehand Pen
tool:

1. Choose the Freehand Pen tool .
2. Adjust the Freehand Pen tool setting controls

on the right side of the Toolbox palette if neces-
sary.

3. Draw out a path in one of the following ways:
• Creating an independent path: Simply

draw out the shape you want in the view area. If
you want to create a closed path, end the shape
near the starting point of the path, and release
the mouse button when the pointer becomes

.
• Starting a path at an existing open

path’s end nodes: Hold the  key and
position the pointer near one of the nodes until
the pointer becomes . Then begin drawing
the path. The new path created will be
appended to the existing path you started from.

• Ending a path at an existing open
path’s end nodes: Draw out the shape
towards one of end nodes of an existing path,
hold the  key and release the mouse but-
ton when the pointer becomes . The new
path will be joined with the existing path.
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Freehand Pen Tool Pressure Settings
If you use a pressure sensitive device (e.g., a
WACOM tablet), Expression can vary the stroke
width of the path according to the pressure applied
at each point.

The Freehand Pen tool pressure settings controls
are displayed at the right side of the Toolbox palette
whenever the Freehand Pen tool is selected. You
can turn pressure sensitivity on and off and adjust
the pen-pressure related behavior as follows:

• Using pressure sensitivity: Expression reg-
isters the pressure information from your stylus
as you draw, and uses it to vary the stroke width
along the path. Disable the Variable Width
On/Off button  if you do not want this. Note
that if pressure sensitivity is turned on (and
your tablet reports pressure values to Expres-
sion), the current stroke width settings in the
Paint Style palette will have no effect on the
final stroke width.

• Setting width at maximum pressure: The
more pressure you apply to your stylus, the
thicker will be the stroke. To set the width that
corresponds to maximum pressure, choose a
value (in screen pixels) in the Maximum Pres-
sure Width meter. To draw a really wide stroke,
you could zoom out a bit first. To draw fine
details, zoom in before you draw.

• Controlling width and transparency
variability: For bitmap strokes defined with
an alpha channel, both width and transparency
can be controlled by pressure. Use the Width
and Transparency Variability sliders (shown in
the Toolbox palette when the Freehand Pen tool
is chosen) to control how much the width or
transparency should be affected by the stylus
pressure. The setting here will be used in the
paths you subsequently create with the Free-
hand Pen tool. Note that even after a path has
been created, you can still change the variable
width and transparency using the Variable
Width palette (see Section 8.10).

As a side note, the Freehand Pen tool can also be
used as an object selection tool by simply clicking
on the object to be selected.

7.5 Using the B-Spline Tool
The B-Spline tool lets you build up B-spline curves
by placing nodes in succession. Although B-splines
are smooth curves, the B-Spline tool lets you intro-

Creating a path with variable stroke width.

Pressure sensitivity options for the Freehand Pen 
tool.
A Variable width on/off.
B Maximum pressure width meter.
C Transparency/Width variability slider for the 

Freehand Pen tool.

From top to bottom: a path with variable stroke 
width only, with variable stroke width and trans-
parency, and with variable stroke transparency 
only.
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duce discontinuities such as sharp corners to a path
by starting a new B-spline curve segment at every
discontinuity.

B-splines are used less often in 2D drawing applica-
tions, probably because PostScript does not support
B-splines. 3D software, on the other hand, almost
exclusively uses B-spline curves and surfaces as
modelling primitives because of their smoothness
and ease of control. Try the B-Spline tool and you
will find that it is a more convenient tool for all of
your curve (or even straight line) construction
needs.

To create paths using the B-Spline tool:

1. Choose the B-Spline tool .
2. Click on the view to place the B-spline control

points or nodes one by one:
• Placing the first node: Position the pointer

where you want to start the path, and click to
place the first node.

• Placing subsequent nodes: Move the
pointer and click to place more nodes (use the
rubber line linking the previous node and the
pointer as a guide). Alternatively, where you
want to make the path discontinuous (i.e., a
sharp corner), +click to place the node.
You can also hold the  key before you
click to constrain the angle made by the node
and the previous two nodes. Repeat this step to
place the subsequent nodes.

• Canceling nodes: Press the
Delete/Backspace key to delete the previ-
ous node that you placed.

• Placing the last node: Double-click to
place the last node. Alternatively, press the
Return/Enter key to end the path at the last
node. If you want to create a closed path, posi-

tion the pointer near the first node and click
when the pointer becomes .

B-Spline Tool Options
When the B-Spline tool is selected, the Append and
Do Not Append option buttons will appear at the
right side of the Toolbox palette.

Enable the Append Path button  in the Toolbox
palette if you want to connect newly created
B-spline paths to existing open paths. If not, enable
the Do Not Append button .

7.6 Using the Polyline/Arc 
Tool
The Polyline tool lets you build up paths made up of
straight line and/or Bezier curve segments by plac-
ing nodes in succession. Simple clicking creates
line segments, and click-dragging creates circular
arc segments:

1. Choose the Polyline tool .
2. Add straight line or circular arc segments one

by one:
• Placing the first node: Position the pointer

where you want to start the path, and click to
place the first node.

• Adding a straight line segment: Move the
pointer and click to place a node for a straight
segment.

Creating a path using the B-Spline tool.
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• Adding a circular arc segment: Move the
pointer and click to set up the tangent direction
of the circular arc you are going to create, then
continue to drag the pointer to form the circular
arc. There is an initial tolerance before the cir-
cular arc mode is started. This tolerance is pro-
vided to prevent circular arcs from being
accidentally created when straight lines are
intended. Therefore you might want to drag the
pointer a bit to start the arc first, and then adjust
to define the arc. The length of the tangent vec-
tor (the distance between the previous node and
the clicked point) does not affect the final shape
of the arc at all. However, a longer tangent vec-
tor would give you a more accurate control over
the tangent direction. You can also hold the

 key while you click to constrain the angle
between the line segments. In the case of arc
segments, dragging with the  key held
constrains the arc angle.

• Canceling nodes: Press the
Delete/Backspace key to delete the previ-
ous node or segment that you placed.

• Ending the path: Double-click when placing
the final node. Alternatively, press the
Return/Enter key to end the path at the last
node. If you want to create a closed path, posi-
tion the pointer near the first node and click
when the pointer becomes .

Polyline/Arc Tool Options
When the Polyline/Arc tool is selected, the Append
and Do Not Append option buttons will appear at
the right side of the Toolbox palette.

Enable the Append Path button  in the Toolbox
palette if you want to connect newly created
Polyline/Arc paths to existing open paths. If not,
enable the Do Not Append button .

7.7 Using the Bezier Pen 
Tool
The Bezier Pen tool lets you build up arbitrary Bez-
ier curves by placing nodes and Bezier tangent han-
dles in succession. As you click to place a node, you
can adjust the curvature and continuity at that node
by dragging out tangent handles.

The Bezier curves created using the Bezier Pen tool
are known as piecewise Bezier curves because each
curve is pieced together from individual Bezier
curve segments. The continuity between two adja-
cent Bezier segments could be smooth or discontin-
uous. Each Bezier curve segment consists of the
two nodes that mark the ends of the Bezier segment,
and the two tangent handles from the nodes. Both
the lengths and the directions of the tangent handles
affect the final shape of a Bezier segment. When the
tangent handles are retracted fully into the end
nodes, the Bezier segment will appear as a straight
line.

It takes practice to get used to drawing Bezier
curves. If you are new to vector-based drawing
tools, you would probably find the B-Spline tool
more handy for any kinds of constructions, from
smooth curves to polylines.

To create Bezier paths:

1. Choose the Bezier Pen tool .
2. Click to place a Bezier node, and drag to bring

out the tangent handle. If you just click but do

Creating a path using the Polyline tool.
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not drag out a tangent handle, the tangent han-
dles on both sides of your node will be fully
retracted.

• Placing the first node and the initial tan-
gent: Position the pointer where you want to
start the path, and click to place the first node.
Unless you are trying to create straight line seg-
ments, remember to drag out the initial tangent
vector as you place your first node.

• Placing subsequent nodes: Move the
pointer and click to place subsequent nodes.
Before releasing the mouse, drag to bring out
the tangent handles on both sides of the node.
Note that the tangent handles on both sides will
be co-linear and have the same length so that
the adjacent curve segment will be smoothly
connected. If you hold down the  key
while you drag, the angle of the tangent handles
will be constrained. You could also hold down
the  key while you drag to lock the tan-
gent handle on the other side of the node in
place to break the continuity.

• Adjusting the tangents: If you want to
adjust the tangent handles of the node you last
placed, position the pointer at that node (the
pointer becomes ), then drag to set the tan-
gent handles again.

• Canceling nodes: Press the
Delete/Backspace key to delete the previ-
ous node that you placed.

• Closing a path: Move the pointer to the start-
ing node (the pointer becomes ), and click it
again to close the path. Remember to drag out
the final pair of tangent handles.

• Ending a path: End a path explicitly by
pressing the Return/Enter key. Double-click-
ing to place the final node also ends a path, but
you would not be able to drag out the tangent
handle for the final node. Note that the Bezier

Pen tool does not have a rubber curve/line cue
to indicate whether you are continuing on a
working path (this is for compatibility with
Bezier Pen tools in other drawing applications.)
You have to rely on the pointer shape to know
whether you are continuing on the path you
have been working on ( ) or whether you are
starting a new path ( ).

Bezier Pen Tool Options
When the Bezier Pen tool is selected, the Append
and Do Not Append option buttons will appear at
the right side of the Toolbox palette.

Enable the Append Path button  in the Toolbox
palette if you want to connect newly created Bezier
paths to existing open paths. If not, enable the Do
Not Append button .

7.8 Shape-Based Drawing 
Tools: Rectangle, Ellipse, 
Line, Star/Polygon/Twirl
Expression 3 provides a few tools specialized in
creating certain commonly used shapes, including
square/round cornered rectangles, ellipses, simple
straight lines, regular or irregular stars with 3 to 99
points, regular or irregular polygons and twirling
curves.

Creating a path using the Bezier Pen tool.
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7.9 Using the Rectangle 
Tool
The Rectangle tool lets you create rectangles and
squares, optionally with round corners.

1. Choose the Rectangle tool .
2. Click and drag out a rectangular shape. The

proportion of the rectangle can be constrained
to a square if you hold down the  key
when you drag the pointer. Also, the aspect
ratio of the rectangular shape can be locked
during dragging by pressing the  key, and
further dragging at this point will rotate the
rectangle. The angle of rotation can also be con-
strained by holding down the  key.

3. Release the mouse button to create the closed
rectangular path. The starting point of the rect-
angular path will be at the position where you
first clicked.

If you click on the view area using the Rectangle
tool and release the click without dragging, a “Rect-
angle Specification” dialog will be displayed for
entering numerical values of the position, size, cor-
ner roundness and rotation angle of a rectangle.

Rectangle Corner Roundness
When the Rectangle tool is selected, a Corner
Roundness slider will be displayed at the right side
of the Toolbox palette. This slider lets you specify
the roundness, i.e., the radius of the circular arc for
the corners as a percentage of the half length of the
shorter side of the rectangle. A roundness of 0%
produces sharp-cornered rectangles and a 100%

roundness produces a rectangle with semi-circular
corners.

7.10 Using the Line Tool
The Line tool lets you create straight lines with only
two nodes, through one single click-drag action.
This tool is particularly useful for quickly drawing
a sequence of straight lines.

1. Choose the Line tool .
2. Click where you want the starting point of the

line to be, drag and release at the desired ending
point to create the straight line path.

If you click on the view area using the Line tool
without dragging, a “Line Specification” dialog
will be displayed for numerical entry of the end
point coordinates. The starting point coordinates in
the dialog will be initially filled with the coordi-
nates of the point you clicked.

Line Tool Options
When the Line tool is selected, the Append and Do
Not Append option buttons will appear at the right
side of the Toolbox palette.

Enable the Append Path button  in the Toolbox
palette if you want to allow the newly created lines
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be connected to existing open paths. If not, enable
the Do Not Append button .

7.11 Using the Twirl Star Tool
The Twirl Star tool is for creating a wide variety of
convex and concave shapes with straight or curved
sides, such as stars, hexagons, sickle blades, and
other shapes with indentations.

1. Choose the Twirl Star tool .
2. Click where you intend the center point of the

star or polygon to be, and drag out the star or
polygon shape. If you drag the pointer before
releasing the mouse, the shape will also be
rotated. The angle of rotation can be con-
strained by holding down the  key. The
rotation and size of the star/polygon can be
locked by pressing the  key. Further drag-
ging will cause the star shape to be winded up
into twirls. You could unwind the stars by turn-
ing in the opposite direction.

3. Release the mouse to create the star/poly-
gon/twirl path.

If you click on the view area using the Twirl Star
tool without dragging, a “Star Specification” dialog
will be displayed for entering the various parame-
ters of the star/polygon/twirl object to be created.
The parameters are basically the same as the Twirl
Star tool settings described below, except that the

radius and angular variations can be controlled sep-
arately.

7.11.1 Twirl Star Tool Settings
When the Twirl Star tool is selected, a few controls
will be displayed at the right side of the Toolbox
palette for adjusting the various star/polygon
related parameters:

• Setting number of corners: This is the
number of convex vertices to be created in the
shape. For example, choose “5” for pentagons
and five-pointed stars.

• Setting inner depth: Inner depth is a mea-
sure of indentation, or more precisely, how far
the concave vertices will be from the
un-indented shape to be created. At zero inner
depth, there will be no indentation, and a
straight line will join each pair of adjacent con-
vex vertices to form a convex polygon. As you
increase the inner depth, the concave vertices of
the shapes to be created will become increas-
ingly closer to the center of the shape, and the
convex angles will become increasingly nar-
rower. Setting an inner depth of 100% will

A Break at joints 
on/off

B No. of corners

C Inner depth slider
D Star variation slider

The Twirl Star tool settings.
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make the stars so narrow that the “arms” will
become lines. In such a case, the resulting path
will be a compound path with a number of open
lines (or curves, if twisted) radiating from the
center.

• Setting variation: Star variation is the
amount of randomness to be introduced to both
the radial length of the corners and angular sep-
aration of the corners. Setting it to zero pro-
duces regular stars or polygons. The larger the
value, the wilder looking the shapes will be.

• Setting “Break At Joints” option: This
switch specifies whether the “Break At Joints”
attribute should be turned on for the stars and
polygons created using the tool. This option is
meaningful only if skeletal strokes are applied
to the resulting paths. With the “Break At
Joints” option turned on, one stroke will be
applied to each smooth segment of the path.
With the option turned off, one stroke will be
applied along the entire path. The “Break At
Joints” setting of created polygons and stars can
subsequently be changed using the Attributes
palette. See Section 9.7.

7.12 Ellipses and the Ellipse 
Tool
Ellipse objects are a special kind of path designed
for circles, ovals and partial ellipses such as arcs
and sectors. An ellipse object has two editable
nodes, normally concurrent, marking the starting
point and the ending point of the elliptical arc.

Although an ellipse looks like a closed path when it
is created, it can actually be an open path with two
nodes at the same position (or with a zero-length
line segment joining them, depending on the cur-
rent arc mode). These nodes can be slid along the
circumference of the ellipse to form an open arc, a

sector, or a closed arc, which is an open arc with a
straight line across the two nodes.

Ellipse objects can be turned into ordinary paths
with the menu command Object > Convert To Path.
Once converted, the resulting path will consist of
Bezier curve segments, the nodes on which can
then be freely edited to form arbitrary non-elliptical
shapes.

7.12.1 Using the Ellipse Tool
The Ellipse tool lets you create ellipses and circles.

1. Choose the Ellipse tool .
2. Click and drag out an ellipse. Hold down the

 key to constrain the ellipse to a circle.
3. Release the mouse to create the ellipse object.
If you click on the view area using the Ellipse tool
and release the mouse without dragging, an “Ellipse
Specification” dialog will be displayed for you to
enter the numerical values of the position and
dimension of an ellipse object. In the dialog, an arc
angle refers to the angle a line joining the ellipse
center and a node is at with reference to the hori-
zontal axis, measured in the counterclockwise
direction. Because there are two nodes for each
ellipse object, there are two arc angles that you can
specify. If the two arc angles are identical, a full
ellipse will be created.

7.12.2 Ellipse Tool Settings
When the Ellipse tool is selected, certain ellipse
tool settings controls will be displayed at the right
side of the Toolbox palette. Choose the “From cen-
ter” option if you want to use the starting point of
your dragging action as the center of the ellipse to
be created. Otherwise, with the “From bounding
box” option chosen, the point where you start drag-
ging will be a corner of the bounding box of the
ellipse to be created. The Arc Mode popup at the
lower right is for choosing the arc mode for subse-



56 Expression 3 Manual
quent ellipses to be created using the tool. Arc
modes are described in the sub-section below.

7.12.3 Creating Arcs and Pies
1. Select an ellipse object.
2. Opening up ellipses: Choose the Node tool

 or Node Lasso tool . Drag one of the
nodes along the path as far as you want the
ellipse opening to be. When you release the
mouse button, two nodes, one at each side of
the opening, will be shown.

3. Choosing open arcs, closed arcs and
pies: From Objects > Arc Mode, choose
“Open Arc”, “With Chord” (closed arc), or
“Pie” as needed. These options are also avail-

able from the Object List palette (see Section
11.7.3).

Converting Ellipses to Bezier Curves
• Select the ellipse, and choose Objects > Con-

vert To Path.

7.13 Joining Paths
You can combine two open paths into one path by
joining them end to end. The paths are joined at the
ends that are closer together, and the position of one
node is changed to merge with the node of the other
path. A related operation, called virtual joining,
brings nodes together without merging them.

• Joining two paths: Select the paths, and
choose Objects > Join Path > Real.

• Making two paths meet without joining
them: Select the paths, and choose Objects >
Join Path > Virtual.

Dragging a node to open up an ellipse.

From left to right: open arc, with chord, and pie.

Joining two paths into one.
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7.14 Closing Paths
You can close selected open paths (simple or com-
pound) by choosing the “Close Path” command. If
a path is already closed, the command will have no
effect. Similar to the “Join Path” commands, an
open path can be closed by just bringing the end
nodes to the same position (called virtual closing),
or it can actually become a closed path.

• Closing one or more paths: Select the
paths, and choose Objects > Close Path > Real.

• Moving the end points of an open path
together: Select the paths, and choose Objects
> Close Path > Virtual.

7.15 Forming Paths Using 
Path Operations
Path operations (or Boolean operations) form paths
of Bezier curves based on the addition or subtrac-
tion of the shapes of the fill areas of two or more
paths. The newly formed paths will have the stroke
and fill attributes of the topmost or bottommost
source path, depending on the kind of path opera-
tion used.

If there are more than two source paths, the path
operation will be applied to the first two paths, then
to the newly formed path and the next path, and so
on, until all source paths are worked on. You can set
the option to keep or delete sources paths after path
operations (see Section 18.2.1).

1. Select the paths.
2. Choose the path operation you want from

Objects > Path Operations:
• Unite: Forms a path whose shape is made by

merging the fill areas of the source paths.
• Front minus back: Forms a path whose

shape is made by cutting the fill area of the
source path behind out of that of the source path
in front.

• Back minus front: Forms a path whose shape
is made by cutting the fill area of the source
path in front out of that of the source path
behind.

• Intersection: Forms a path that is the shape of
the overlapping area of the source paths.

• Divide: Forms a number of paths by cutting up
the fill areas of the source paths along the paths.

7.16 Working with 
Compound Paths
A compound path is a path that is made up of two or
more sub-paths, each with its own starting and end-
ing nodes. Compound paths are useful for making
shapes with holes in them, such as the numbers “8”
or “0”, and are formed from two or more paths, or
formed as a result of path operations.

• Forming a compound path: Select the
source paths, and choose Objects > Compound
Objects > Make.

• Converting a compound path to its
source paths: Select the compound path, and
choose Objects > Compound Objects >
Release.

Dividing paths.

Turning two independent paths into a com-
pound path with a hole.
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7.17 Working with Clones
The clone is a special kind of object that is closely
related to the path. A newly created clone looks
exactly like the path from which it is formed (the
master path), but it is not just a duplicate of the
master path. Unlike its master (or any ordinary
path), a clone does not have nodes, and cannot be
edited directly. In fact, its structure remains tied to,
and dependent on, the master’s, and whenever the
master’s nodes are edited, the clone’s shape is
updated to follow.

Clones can, however, have their own stroke and fill
attributes, and be transformed independent of their
masters. When a master is deleted or unstructured, a
clone will be automatically freed, or converted to a
path.

• Creating a clone from a path: Select the
path, and choose Edit > Clone.

• Selecting the master of a clone: Select
the clone, and choose Edit > Select Master.

7.18 Blending Paths
Blending creates a series of paths of Bezier curves
by interpolating the position (of nodes and objects)
and attributes of two paths. The stroke and fill
attributes that are interpolated include color, width
(stroke width, soft-edged/embossed width and vari-
able width), stroke shear, opacity, dash pattern and
shape parameter.

The source paths need not have the same number of
nodes. Expression will determine a correspondence
between the nodes, and compensate for any differ-
ence. After the blending operation, the resulting
paths (also called in-betweens) are grouped

together. The source paths are not affected in any
way.

If you try to blend three or more paths, Expression
will blend the first and second paths, then the sec-
ond and third paths, and so on. The order mentioned
here is the object order; the first path is the
bottommost path, and the last path is the topmost
path.

1. Select the paths.
2. Choose Objects > Blend Paths. This opens a

“Blend Paths” dialog.
3. Choosing the number of new paths:

Choose or enter the number of new paths that
you want in the “No. of Steps” box.

4. Choosing interpolation method: The
“Linear interpolate” option treats nodes on a
source path as individual nodes, with no regard
for node positions relative to adjacent nodes.
The “Angle and length” option takes into
account the angle and distance between adja-
cent nodes during interpolation.

5. Click “OK”.

7.18.1 Marking Nodes
The blending process can be controlled with more
precision by raising the status of certain nodes
beforehand, in an operation called node marking. If
you mark one node from each source path, then
these two marked nodes will have preference (over
other unmarked nodes) in being matched for inter-
polation during blending. You can mark more than
one node from each source path and the number of
nodes marked in each source path does not need to
be the same.

• Marking a node: Select it and choose
Objects > Node Marking > Set.
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• Removing a mark from a node: Select the
node and choose Objects > Node Marking >
Clear.

7.18.2 Using Reference Vectors
Before blending two paths, you can assign a refer-
ence vector to each path, to indicate a point of ref-
erence and an orientation.

1. Select one or more path objects.
2. Choose the Reference Vector tool .
3. Choose from these options:
• Adding and editing reference vectors:

Place the pointer where you want the reference
point to be, and drag in the direction you want.

• Removing reference vectors: Choose
Objects > Remove Reference Vector.

7.19 Selecting Nodes
Two tools are available for selecting nodes. The
Node tool lets you select nodes individually and by

dragging out a marquee. The Node Lasso tool has
all the features of the Node tool, but offers more
flexibility.

1. Choose the Node tool  or Node Lasso tool .
2. If the nodes are not shown, click the path to

select it and show the nodes.
3. Choose from these options:
• Selecting nodes one by one: Click a node

to select it. +click another node to add it
to the node selection.

• Selecting nodes by dragging out a
marquee: For the Node tool, drag out a box to
enclose the nodes you want to select. For the
Node Lasso tool, drag out a shape (e.g., a circle
or S-shape) to enclose the nodes you want.

+drag to enclose more nodes to add to the
node selection.

• Selecting nodes by encircling nodes:
Using the Node Lasso tool, drag out a curve
around the nodes you want to select.

+drag to enclose more nodes to add to the
node selection. Objects cut across by the curve
will also be selected at the object level.

Blending paths with and without node marking.

Blending paths with reference vectors.
Selecting nodes using the Node tool.

Selecting nodes using the Node Lasso tool.
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• Deselecting all nodes: Click an empty
space in the view area to deselect all nodes. You
can also use the Freehand Pen tool in this way.

• Toggling node selection state: Hold the
 key and click each node that you want to

select or deselect, or +drag out a shape to
enclose them.

7.20 Editing Nodes
You can change the shapes of paths by editing node
positions, path curvature and continuity.

7.20.1 Editing Nodes Using the 
Node Tools
The Node tool and Node Lasso tool let you edit
nodes, and take advantage of the node snapping
feature, as is described in Section 11.4.2.

1. Select the node you want.
2. Choose the Node tool  or Node Lasso tool .
3. Choose from these options:
• Moving nodes: Drag the node to move it. If

more than one node has been selected, dragging
one selected node will move all selected nodes.

• Changing the tangent vectors of Bezier
curves at a node: Drag one of the tangent
handles at the node to change the curvature near
it. Or, you can hold the  key while you

drag to lock one tangent handle in place (the
tool actually temporarily changes to the Con-
vert Node tool when you hold the  key.)
To change the behavior of a pair of tangent han-
dles, see Section 7.21.

• Reshaping path segments: +drag
one node (the pointer becomes ) to move the
node. Nearby nodes will also be influenced.
The influence diminishes with the distance
from the node being dragged.

7.20.2 Editing Nodes Using Other 
Methods
You can move nodes by nudging them one step at a
time, or by transforming two or more selected
nodes using the resize handles or any of the trans-
formation tools.

1. Select the nodes.
2. Choose from these options:
• Nudging nodes: Press the arrow keys

repeatedly to move the nodes one step at a time,
in the direction you want. Alternatively, hold
the  key while you press an arrow key to
move half a step at a time. You can also change
the nudge increment in the “Preferences” dialog
(see Section 18.2.2).

• Using resize handles: Choose the Object
Select tool ; the resize handles will be
shown if two or more nodes have been selected.
Use the resize handles to transform the path
segments near the selected nodes, as you would

Dragging one selected node to move all 
selected nodes.

Dragging a node to reshape the path seg-
ments.
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to transform objects. For details, see Chapter
12.

7.21 Changing Bezier 
Tangent Continuity
A Bezier path can be continuous at some nodes, and
discontinuous at others. Where a path is continu-
ous, you will see a smooth curve segment; where it
is discontinuous, there may be an abrupt change in
tangent, like a sharp corner, or a cusp point. The
continuity of a node between adjacent Bezier seg-
ments can be specified explicitly.

1. Select the node.
2. Choose from these options:
• Maintaining continuity and symmetry

at a node: Click the Symmetrical button 
in the Attributes palette, or choose Objects >
Node Continuity > Symmetrical. When you
edit one of the node’s tangent handles subse-
quently, the other tangent handle will move so
that it will always be opposite the handle being
dragged, and be at the same distance from the
node.

• Maintaining continuity at a node: Click
the Smooth button , or choose Objects >
Node Continuity > Smooth. When you edit one
of the node’s tangent handles subsequently, the
other tangent handle will move so that it will
always be opposite the handle being dragged.
This is the default option for new Bezier curves.

• Allowing discontinuity at a node: Click
the Unconstrained button , or choose
Objects > Node Continuity > Unconstrained.
When you edit one of the node’s tangent han-
dles subsequently, the other tangent handle will
stay unchanged.

• Locking the relative tangent angle at a
node: Click the Angle Locked button , or
choose Objects > Node Continuity > Angle
Locked. When you edit one of the node’s tan-
gent handles subsequently, the other tangent

Symmetrical node continuity.

Smooth node continuity.

Unconstrained node continuity.
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handle will move so that it will always make the
same angle with the handle being dragged.

7.22 Converting Nodes
Since a path can be made up of a mixture of straight
lines, Bezier curves and B-splines, you may some-
times want to convert a particular segment from one
type of curve to another. This can done with the
Convert Node tool, which modifies the continuity
and nature of a node, hence the nature of the adja-
cent path segments.

The Convert Node tool allows you to turn a discon-
tinuous Bezier node into a smooth one, or a junction
between two straight line segments into a smooth
B-spline node. However, it is not possible to
directly convert a Bezier node to and from a
B-spline node. You can also adjust the tangent han-
dles at a Bezier node, and switch the continuity
from smooth to discontinuous.

1. Select the node.
2. Choose the Convert Node tool .
3. Choose from these options:
• Converting nodes in Bezier curves: Click

an ordinary node to convert it to a corner node.
The tangent handles will be retracted. The seg-
ment between two consecutive corner nodes
will also be turned into a straight line. To con-

vert a corner node to an ordinary node, drag it to
pull out its tangent handles.

• Converting nodes in B-spline curves:
Click a B-spline node to convert it to a corner
node, and vice versa.

• Converting nodes between
straight-line segments: Click a corner node
to convert it to a B-spline node. Alternatively,
drag the node to bring out a pair of handles to
turn the adjacent segments into Bezier seg-
ments.

7.23 Using Miscellaneous 
Path Modifying Tools
A selected path can be further modified in one of
the following ways:

• Adding nodes: Choose the Add Node tool
, and click the path segment (not a node)

where you want to add a node. The shape of the
path will not be affected, unless you are adding
nodes to B-spline segments, in which case the
newly introduced B-spline nodes will slightly
change the path’s shape. Adding a node to an
ellipse will convert it to a Bezier curve.

• Deleting nodes: Choose the Delete Node
tool , and click the node you want to delete.
Alternatively, select the node, and press the
Delete/Backspace key. The shape of the
path will change accordingly.

• Splitting paths: Choose the Cut Path tool ,
and click the path segment where you want to
split it. The path segment will be split into two
independent paths.

• Reversing path direction: Choose the
Reverse Path tool , and click anywhere on
the path. Alternatively, choose Objects >
Reverse Path. Clicking a compound path will

Angle-locked node continuity.
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reverse the direction of each individual
sub-path.

• Changing starting nodes of paths:
Choose the Start Point tool , and click the
node that you want to be the starting node. For
open paths, clicking a node other than those at
the open ends will convert the path to a closed
path.

7.24 Smoothing Paths
The purpose of smoothing is to reduce the number
of nodes on a path while retaining the approximate
shape of the path. After smoothing, the path is
re-fitted with new Bezier curves.

1. Select the paths.
2. Choose Objects > Smooth Path. This opens a

“Smooth Selected Path(s)” dialog.
Choose a tightness of fit value, within the range of
0.1 (tight) and 10 (very loose). The looser the tight-
ness of fit, the fewer nodes there will be in the
resulting path, and the smoother will it be. You can
also set a default value in the “Preferences” dialog
(Section 18.2.1).

7.25 Unstructuring Strokes
Unstructuring converts the skeletal strokes on a
path to individual paths. Text objects must be con-
verted into paths before they can be unstructured.
The resulting paths are grouped together.

Unstructuring paths: Select the paths, and
choose Objects > Unstructure.

7.26 Working with Clippers
In clipping (or masking), the shape of a path is used
to mask other paths and bitmaps, so that only those
object areas within the fill area of the clipping path
(or clipper) are shown. The clipper itself retains its
own stroke and fill attributes, such as soft-edges
and variable width, and all objects in the clipper
group remain editable.

If the clipper path has a fill attribute, the fill will be
drawn at the background of the clipper group. On
the other hand, if the clipper group has a stroke
applied to it, the stroke will be drawn on top of
everything else within the clipper group, outlining
the clipping shape.

Normally, Expression assumes that you want to use
the top object in an object selection as the clipper
for clipping other objects in the selection. However,
if you like, you can use the bottom path as the clip-
per instead.

7.26.1 Forming Clipper Groups
1. Create the path (the clipper-to-be) and move it

in front of the objects to be clipped. Or, move
the clipper-to-be behind other objects.

2. Select the clipper-to-be, and the objects to be
clipped.

3. Choose Objects > Clipper > Make With Top
Path to use the top path to clip other objects in
the selection. If you choose the “Make With

Reversing path direction.

Changing a path’s starting point.
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Bottom Path” command, Expression will move
the bottom object to the top of the selection, and
use it to clip the other objects in the selection.

7.26.2 Breaking up Clipper 
Groups
Select the clipper group, and choose Objects >
Clipper > Release.

7.27 Text Objects
A text object is a special group of text characters,
which are special closed paths whose shapes are
based on the glyph shapes defined in the font being
used. Each text character can have its own stroke
and fill attributes. Text can be selected, transformed
and otherwise treated as normal paths. They can
also be converted into ordinary paths.

Text objects can exist on their own or be fitted onto
or inside another path object. If a text object is fitted
on a path, the text characters will flow along the
outline of the attached path. If fitted inside, the
attached path will be used as a frame for the text to
flow within, justified or otherwise.

7.27.1 Creating Text Objects
Text can be pasted into Expression from the clip-
board, or created using the Text tool.

1. Choose the Text tool .
2. Choose from these options:
• Creating text by itself: Place the text carat 

by clicking in the view area.
• Creating text along a path (text on

path): Place the pointer near the path, and
click when the pointer becomes . See also
Section 7.27.3 for details on attaching existing
text objects to paths.

• Creating text in a path’s fill area (area
text): Place the pointer near the path, and

+click when the pointer becomes . See
also Section 7.27.3 for details on forming area
text from existing text objects.

3. Enter text from the keyboard. To use a new line
(for ordinary text and area text only), press the
Return/Enter key.

7.27.2 Editing Text Characters
The Text tool can be used to select individual text
characters.

1. Choose the Text tool.
2. Choose from these options:
• Selecting text: Highlight text characters by

dragging the pointer over the characters, or start
highlighting from the text carat by holding the

 key and using the arrow keys.
• Editing text: Select the characters or place the

text carat where you want, and enter the new

The clipper group on the right is formed by the 
paths on the left. The spade shaped path with 
soft-edged fill is used to clip the paths behind it.

Typing text.
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characters. To delete characters, use the
Delete/Backspace key.

7.27.3 Attaching Text to Paths
There are two ways in which a text object can be
attached to a path. One is called text on path, in
which the text is made to flow along the shape of a
path. Here, any line breaks in the text object are
ignored, and all the text characters appear in
sequence along the shape of the path.

The other kind of attachment is the area text, in
which the text is confined within the fill area of a
path. In this case, all line breaks are honored, except
at places where the lines are too long to fit into the
fill area of the path. You can attach text to paths as
the text object is being created, or bring text and
path together at any other time.

• Using text on path: Select both text and
path, and choose Objects > Text On Path >
Attach. To move the text along the path, or flip
it to the other side of the path, place the pointer
near the first text character (the text carat
becomes ), and drag it.

• Using area text: Select both text and path,
and choose Objects > Text On Path > Attach
Area Text.

• Releasing text from paths: Select the
attached text object, and choose Objects > Text
On Path > Release.

7.27.4 Choosing Font and Text 
Attributes
A text object has text characteristics such as font
style and font size, and can be organized into rows
of text characters with controls such as alignment
and leading.

1. Select the text object or text characters.
2. Choose from these options in the Font palette:
• Choosing fonts: Choose the font and style

you want. Change the font size in the Point Size
meter .

• Aligning and justifying text: Choose the
“Left” , “Center” , “Right” , “Right
Justify”  or “Right Justify All” button 
as needed. For ordinary text and text on path,
the “Left”, “Center” and “Right” options let
you align the text (the left sides, horizontal cen-
ters or right sides) at the left side of the first
character in the first line. For area text, align-
ment of all lines is made against the path’s

Text on a path.

Area text.
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shape, and the “Right Justify” and “Right Jus-
tify All” options are also available.

• Using superscript and subscript: Choose
the “Normal” , “Superscript”  or “Sub-
script” button  as needed.

• Setting baseline shift: Change the baseline
shift value in the Baseline Shift meter  to set

Centered text.

Right justified text.

Justified text.

All lines justified.

Text with superscript and subscript.
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the vertical positions of characters with respect
to the baselines.

• Setting tracking: Change the tracking value
in the Tracking meter  to set the tracking
(extra horizontal spacing between characters)
as needed. A positive tracking value will make
the spacing looser and a negative value will
make the spacing tighter. If you want to adjust
the spacing between only two adjacent charac-
ters, you should select only the first character
and adjust its tracking value. Selecting both
characters will modify the spacing between the
second and the following character (if there is
any).

• Setting leading: Click the Leading/Auto
Leading button  to show the Leading meter,
and change the leading (vertical spacing
between lines) as needed.

• Setting horizontal scaling: Change the
scaling value in the Horizontal Scaling meter

 to scale individual characters and the
spaces between them horizontally.

7.27.5 Converting Text to Paths
Text objects can be converted to ordinary Bezier
paths, for example, for editing the outlines.

• Converting text to paths: Select the text
object, and choose Objects > Convert To Path.

7.28 Bitmap Objects
Bitmaps are images in grids of pixels with fixed
resolution, and can be imported (see Section 5.11)
or created from scratch. Expression supports bit-
maps with transparency and you can define bitmap
strokes from bitmaps. Photoshop and compatible
filters can also be applied to bitmaps. See Chapter
14 for more details.

7.29 Object Warping and 
Warp Groups
Warping distorts a picture unevenly by squeezing
some parts together, and pulling them apart at oth-
ers. In Expression, warping can be applied to both
bitmaps and paths.

While bitmaps are created with warp grids in place,
paths need to be specially fitted with warp grids, by
making them into warp groups. When vector
objects are warped, it is the top-level paths them-
selves that are being warped. The strokes on the
paths are applied to the warped paths.

Having a warp grid does not affect the structure of
the paths themselves, and paths can continue to be
selected (as a warp group), edited, transformed and
arranged as before.

• Forming warp groups: Select the paths, and
choose Arrange > Make Warp Group.

Text with different horizontal scaling.

Text outlines can be edited after the text has 
been converted to paths.

Warping vector objects. These paths and text 
objects (left) are made into a warp group, and 
are warped (right). Objects within a warp group 
remain intact until the warp group is ungrouped.
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7.29.1 Editing Paths within Warp 
Groups
Paths within warp groups can still be edited as
before, but in a separate document window contain-
ing only those paths, in their pre-warped state. Any
changes made in this window will be instantly
updated in the original window, in the warped
group.

1. Select the warp group.
2. Choose View > Edit Warp Group. This opens a

new document window containing the paths.
3. Edit the paths as needed, and close the window

after you have finished.

7.29.2 Deforming and Resetting 
a Warp Group
The warp nodes on a warp grid let you deform the
warp group until you have the distorted effect that
you want. The grid resolution can also be adjusted
to allow for warping over a more local or global
area.

1. Select the bitmap or warp group.
2. Choose from these options:
• Changing warp grid resolution: In

Objects > Warp Mesh, choose “Increase Reso-
lution” or “Decrease Resolution” as needed.

• Deforming a warp mesh: Choose the Node
tool  or Node Lasso tool . Click a warp
node to select it, and +click others to
select them too, if you want. Drag a selected
node to apply warping to the area around the
node selection.

• Resetting a warp group: Choose Objects >
Warp Mesh > Reset Grid to revert the bitmap or
warp group to the state before any warping was
applied.

7.29.3 Breaking up Warp Groups
You can commit to the warped appearance of paths
by breaking up the warp group. This will remove
the warp frame, and cause a set of new curves to be
fitted to the paths so as to maintain the warped
appearance.

• Select the warp group, and choose Arrange >
Ungroup.

7.30 Effect Line Groups
Effect Line Groups are special groups formed from
two non-compound path objects (or one path and its
clone). Once formed, a sequence of effect lines will
be automatically created between the two source
paths. There are many parameters and variations
that you could adjust to control the appearances of
the effect lines. Effect lines are described in more
detail in Chapter 13.

Breaking up a warp group causes new curves to 
be fitted to the vector objects.
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Chapter 8: Paint Style and Other Object 
Attributes

A path by itself is only an abstract geometrical
description. To make a path interesting, or visible at
all, a set of paint style attributes must be applied to
it. The paint style attributes describe how the inte-
rior of a path should be filled, what kind of line or
stroke should be rendered along the path, as well as
other more detailed path rendering settings, like
joint type, dash pattern etc.

The basic paint style attributes for a path are the
stroke and fill attributes, which are displayed and
specified in the Paint Style palette. When Expres-
sion starts, the Paint Style palette displays the
default stroke, the skeletal stroke called s01, and the
default fill type No Fill.

8.1 The Paint Style Palette
The Paint Style palette is divided into two main sec-
tions. The upper section is for setting the stroke
type and fill type. The lower section displays the
controls for the stroke type or the fill type, depend-
ing on the current palette focus.

The Stroke Preview is depressed when the preview
focus is on stroke type, either when you click one of
the Stroke Type buttons, or when you click the
Stroke Preview to switch focus yourself. Similarly,
the Fill Preview is depressed when the preview
focus is on fill type, when you click one of the Fill
Type buttons or when you switch the focus by
clicking the Fill Preview yourself.

You can see the name of the current stroke or fill by
placing the pointer over the Stroke Preview or Fill
Preview. You can also double-click the Stroke Pre-
view or Fill Preview to go to edit the stroke or fill.

8.2 Setting Stroke Type
In the Paint Style palette, to the right of the Stroke
Preview, there are four buttons that correspond to

A Stroke preview
B Opacity sliders
C Fill preview
D Color picker
E Paper texture on/off
F Stroke types

G Stroke width meter
H Blending mode 

popup
I Fill types
J Fill width meter
K Lower section

The Paint Style palette.

Choosing a new fill type switches the preview 
focus from stroke to fill. The lower section 
changes accordingly.
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the four available types of strokes, namely, “No
Stroke”, “Basic Stroke”, “Gradient Stroke” and
“Skeletal Stroke”.

• No Stroke: Enable the No Stroke button if
you do not want an outline to be drawn along a
path.

• Basic Stroke: Enable the Basic Stroke
button if you want a stroke with constant thick-
ness and a single color to be drawn along a path.
The color can be chosen from one of the color
pickers in the lower section, as is described in
Section 8.11.

• Gradient Stroke: Enable the Gradient
Stroke button if you want a stroke with constant
thickness and gradient colors to be drawn along
a path. The gradient can be chosen from the
gradient list displayed in the lower section, as is
described in Section 8.12.

• Skeletal Stroke: Enable the Skeletal
Stroke button if you want a stroke created from
a vector or bitmap picture to be drawn along a
path. The skeletal stroke can be chosen from the
Strokes palette, as is described in Section 8.15.

8.3 Setting Fill Type
In the Paint Style palette, to the right of the Fill Pre-
view, there are five buttons that correspond to the
five available types of fill, namely, “No Fill”,
“Solid Fill”, “Gradient Fill”, “Pattern Fill” and
“Image Fill”.

• No Fill: Enable the No Fill button if you
want the interior of a path to be left empty.

• Solid Fill: Enable the Solid Fill button if
you want a uniform color to be applied to the
interior of a path. The color can be chosen from
one of the color pickers displayed in the lower
section, as is described in Section 8.11. Note
that if you want to use solid fill with no stroke,
you can use the keyboard shortcut +F.

• Gradient Fill: Enable the Gradient Fill but-
ton if you want gradient colors to be applied to
the interior of a path. The gradient can be cho-
sen from the gradient list displayed in the lower
section, as is described in Section 8.12.

• Pattern Fill: Enable the Pattern Fill button
if you want a tiling pattern to be applied to the
interior of a path. The pattern can be chosen
from the pattern list displayed in the lower sec-
tion, as is described in Section 8.13.

• Image Fill: Enable the Image Fill button if
you want a bitmap image to be tiled in the inte-
rior of a path. The image file can be chosen
from the image list displayed in the lower sec-
tion. The list contains all Expression readable
image files from the “Images” folder as well as
any additional ones you have added yourself.
See Section 8.14 for more details.

8.4 Setting Stroke Width
The width of the stroke that is applied to a path can
be specified in the Stroke Width meter  below
the Stroke Type buttons. The stroke width can be
between 0 and 10,000 points, and when it is set to 0
point, it is rendered as the finest hairline visible on
your output device.

Skeletal strokes have a default stroke width, which
is saved with the stroke definition, and which is
used when the stroke is applied to a path that does
not already use a skeletal stroke. You can also vary
the width of a skeletal stroke along a path, if you
use a pressure sensitive stylus (see Section 7.4) or
apply a width profile to it, as is described in Section
8.10.

8.4.1 Setting Stroke Width Using 
the Width Meter
1. Select one or more path objects.
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2. Choose the stroke width you want in the Stroke
Width meter . (For details on the usage of
meters, see Section 6.3.)

8.4.2 Setting Stroke Width Using 
Width Handles
When a path that uses skeletal strokes is selected, a
width handle appears at the end of the path for
adjusting stroke width and shear. The width handle
can be manipulated using the Node tool or the Node
Lasso tool by holding the  key, or, if the
“Direct drag width handle” option has been turned
on in the “Preferences” dialog (Section 18.3.1), the
width handle can be dragged directly using these
tools.

1. Select one or more path objects.
2. Choose the Node tool  or the Node Lasso tool

.
3. Hold  and drag the width handle to

lengthen it (for a thicker stroke) or shorten it
(for a thinner stroke) as needed.

Note: If you do not want to adjust the stroke shear
while you drag the width handle, hold the  key
to keep the stroke shear at 0 degree; this keeps the
width handle perpendicular to the path.

8.4.3 Scaling Stroke Width
If you have a bunch of paths with different stroke
widths, and you want to make all of them thicker or
thinner, you can use the “Increase” and “Decrease”
command under Objects > Width. A more conve-
nient way to do this is to use the shortcut keys

+] and +[.
1. Select one or more path objects.
2. Choose Objects > Width > Increase (or

+]) to increase stroke width by 20%. To
decrease stroke width by the same amount,
choose Objects > Width > Decrease (or

+[) instead.

8.5 Setting Soft-Edged or 
Embossed Width
Soft-edges and embossed edges can be thought of
as a kind of border extending from the fill area.
Soft-edges refer to a fuzzy region outside the fill
area where the fill color gradually fades into full
transparency. Embossed edges refer to a region
inside the fill area where a shading resembling an
embossed shape is rendered. The embossed edge
effect applies to all fill types.

In the Paint Style palette, the meter below the Fill
Type buttons indicates the width of a soft-edged or
embossed fill. A positive meter value describes the
width of a soft-edged fill, and a negative value that
of an embossed fill. You can also vary a soft-edgedSetting stroke width and shear by dragging the 

width handle.

Setting stroke width only, by constraining the 
shear angle to 0 degree.
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or embossed width along the path, as is described in
Section 8.10.

8.5.1 Setting Soft-Edged Fill 
Width
1. Select one or more path objects.
2. In the Paint Style palette, choose a positive

value in the Soft-Edged/Embossed Width meter
. The more positive the value, the more

blurred the edges of the fill will be.

8.5.2 Applying Fringes
Instead of a smoothly varying soft-edge, Expres-
sion 3 allows arbitrary fringe images to be applied
in place of the soft-edge. Fringes are useful for cre-
ating a watercolor blotting appearance or even a
woodcut effect.

Fringe images are simply Expression readable
images placed in the “Fringes” folder under the
“Textures” folder. To make it possible for the
fringed fill to create a blotting effect with a denser
color at the outer rim of the fringe, the grayness of
the bottom-left pixel of a fringe image is used to
control the transparency of the body of the fill area.

If you create your own fringe image, make sure that
all pixels in the bottommost row have the same
pixel value, or the resulting fringe will have a dis-
continuous appearance.

To apply a fringe image to a path with a soft-edged
fill:

1. Select one or more path objects.
2. In the Paint Style palette, choose a positive

value in the Soft-Edged/Embossed Width meter
.

3. Click the Soft-Edge button  to display the
“Fringe Texture” dialog.

4. Choose the fringe texture you want, or choose
the <No Fringe> entry at the top if you want the
normal soft-edge.

5. The fringe texture can be stretched along the
entire perimeter of the fill area or be repeated.
This choice can be made using the “Fringe
Options” popup. Click “OK”.

The path on the right has a soft-edged fill.
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8.5.3 Setting Embossed Fill Width
1. Select one or more path objects.
2. In the Paint Style palette, choose a negative

value in the Soft-Edged/Embossed Width meter
, which changes into  when showing a

negative value. The more negative the value,
the more protruding the edges of the fill will
look.

8.5.4 Setting the Light Source of 
Embossed Fill
1. Select one or more path objects. They must use

embossed fill.
2. Choose the Lighting tool .
3. Place the pointer  where you want the light

source to be, and click to direct the light
towards the center of the paths. Alternatively,
click-drag in the direction you want.

8.5.5 Using a Reflection Map
While the embossed fill can create a smoothly
shaded appearance that resembles an embossed
form, Expression 3 currently does not provide a full
set of controls for specifying the reflectivity, shini-
ness or material properties for 3D shading. Even
with a full set of parameters and controls for 3D
shadings, realistic lighting effects would still be dif-
ficult to specify without a 3D environment.

Expression 3 provides an easier solution: to allow
arbitrary photorealistic lighting effects to be
applied to embossed shapes using a technique
known as reflection mapping. This technique uses a
sampled image, called a reflection map or an envi-
ronment map, which has recorded the appearance of
a surface at all normal directions under a particular
lighting environment. Such a reflection map serves
as a look-up table for the appearance of the surface
at any orientation. This technique is commonly
used in 3D computer graphics and the film industry
to give the most photorealistic lighting effects.

Reflection maps can take different forms. Some 3D
software uses six rectangular images forming the
surface of a cube that represents the lighting envi-
ronment. Expression 3 uses a spherical form of the
reflection map — one that resembles the appear-
ance of a circular sphere under the particular light-
ing environment.

A reflection map can be applied to any path with an
embossed fill by pressing the “Embossed” button

/  beside the Embossed Width meter. A

Using embossed fill with different light sources.

(Color plate on page 193.)
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“Reflection Maps” dialog for choosing one of the
reflection maps installed in the system will be dis-
played. After choosing any one of the reflection
maps, the embossed object will be rendered based
on the selected reflection map. If you want to revert
to the normal, smoothly shaded emboss effect with
lighting direction control, choose the <No Map>
entry in the “Reflection Maps” dialog.

New reflection maps can be added at any time by
simply copying a bitmap image file to the “Env-
Maps” folder under the “Images” folder. Refer to
Chapter 14 for more detailed information about the
various uses of images in Expression 3.

A reflection map image is simply a bitmap with
identical X and Y resolution, and with an image of
any rendering of a circular sphere in it. The circular
sphere rendering must extend fully to the edges of
the reflection map. The pixels outside the circular
sphere rendering are ignored.

Photographs of real spheres, dull or shiny, make
excellent reflection maps. You can even draw your
own reflection to create surrealistic rendering
effects.

To apply a reflection map to a path object with an
embossed fill:

1. Select one or more path objects.
2. In the Paint Style palette, choose a negative

value in the Soft-Edged/Embossed Width meter
, which changes into  when showing a

negative value.
3. Click the “Embossed” button  to display the

“Reflection Maps” dialog.

4. Choose the reflection map you want or choose
the <No Map> entry. Click “OK”.

To rotate a reflection map:

1. Select the path object which uses a reflection
map.

2. Choose the Transform Fill tool .
3. Drag the resize handles at the sides to rotate the

reflection map.

8.6 Opacity, Paper Textures 
and Blending Modes
A few paint style attributes are relevant to the path
as a whole. These include opacity, paper textures,
and blending modes. These attributes are specified
in the upper section of the Paint Style palette, in the
row between the Stroke Preview and the Fill Pre-
view.

Controls for opacity, paper textures and blend-
ing modes.
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The Reset Colorization button is normally disabled
unless the selected objects are colorized. For details
on colorization, see Section 8.16.

The Opacity sliders let you specify the opacity of
selected graphics objects as a whole, or adjust the
opacity for stroke and fill independently.

The Paper Texture buttons let you apply a paper
texture to paths.

The Blending Mode popup buttons determine the
way a path is mixed with the background on render-
ing.

8.7 Setting Opacity (or 
Transparency)
Objects with less than 100% opacity allow objects
behind themselves to be shown through in varying
degrees. Expression uses an opacity scale of 0%
(transparent) to 100% (opaque), and allows the
stroke and fill of a path to have different opacity
values. If you want to check how the picture will
look if exported to a format that does not support
opacity less than 100%, you can turn off the “Dis-
play transparency” option in the “Preferences”
dialog (Section 18.4.4).

For paths using bitmap strokes defined with an
alpha channel, the stroke opacity can be made to
vary along the path as well, as is described in Sec-
tion 8.10.

8.7.1 Setting Opacity
1. Select one or more path objects.
2. Choose from these options:
• Setting individual opacity values: In the

Paint Style palette, place the pointer over the
upper slider (the pointer becomes  ) and drag
to change stroke opacity. To change fill opacity,
drag the lower slider instead. (For details on the
usage of sliders, see Section 6.2.)

• Setting one opacity value for stroke
and fill: +drag either slider to align them
and set the same opacity value for stroke and
fill. Alternatively, if the sliders are already
aligned, place the pointer where the sliders
touch in the middle (the pointer becomes ),
and drag to move the sliders as one.

8.8 Setting Paper Textures
The Paint Style palette has a paper texture name
button (between the Paper Texture button and the
Blending Mode popup button), which shows the
name of the paper texture if one is chosen; if not,
the area is blank. The degrees of darkness of a paper
texture bitmap are used for modifying the transpar-
ency of the path, and are used as local thresholds for
making particular areas completely transparent,
giving the appearance of paint on rough texture.
You can also add new paper textures to Expression
by placing Expression readable bitmap files in the
“Textures” folder under the “Expression 3” folder
(Macintosh) or under “Start menu > Programs >
Expression 3 > Resources” (Windows).

A paper texture can be applied in transparent mode
or opaque mode. In transparent mode, lighter areas
in the texture bitmap are more transparent, reveal-
ing objects underneath. In opaque mode, a higher
degree of whiteness is mixed with the path in the

The opacity of the fill is set to 50%, while that of 
the stroke remains at 100%.
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lighter areas in the texture bitmap, but the transpar-
ency values remain unchanged.

8.8.1 Applying Paper Textures
1. Select one or more path objects.
2. Click the Paper Texture On/Off button  in

the Paint Style palette. This opens a “Paper
Texture” dialog.

3. Choosing paper textures: Click the paper
texture you want from the list.

4. Setting texture scaling and transpar-
ency: If you want to scale the paper texture,
choose or enter a percentage value in the “Tex-
ture Scaling” box. In the “Mode” box, choose
the “Transparent” or “Opaque” option as
needed. Click “OK”.

8.8.2 Changing and Removing 
Paper Textures
1. Select one or more path objects.
2. Choose from these options:
• Changing paper texture settings: Click

the name of the paper texture in the Paint Style
palette. In the “Paper Texture” dialog that is
opened, choose the settings as in Section 8.8.1
above.

• Removing paper textures: Click the
depressed Paper Texture On/Off button  to
turn it off.

8.9 Setting Blending Modes
The use of blending modes affects a path’s colors
by blending them with the screen colors behind the
path. The effect of the blending depends on the
blending mode chosen.

Normal: The foreground color is not blended
with the background, and will be displayed in place
of the background color (except when the opacity
of the foreground object is below 100%). This is the
normal behavior unless one of the following special
modes is chosen.

Eraser: The foreground object and all back-
ground objects overlapped by it in the same layer
become transparent, so that objects in the layers
underneath are shown through.

Multiply: This is basically a subtractive
color-mixing mode, where the darker value in each
channel is taken as the resulting color. For example,

Using paper textures in transparent mode (left) 
and opaque mode (right).

The blending modes. (Color plate on page 194.)

Normal mode. (Color plate on page 194.) 
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a bright yellow color mixed with a cyan back-
ground will give a green result.

Light: This is basically an additive color-mix-
ing mode, where for each channel, the lighter of the
two color values (the value of the path and the value
of the background) is taken as the resulting value.
Under this mode, a path placed in front of a white
background always becomes white. If three paths,
one bright red, one bright green and one bright blue,
are placed in front of a black background, the inter-
section of the three will be white, like the effect of
three colored spotlights.

Color Dodge: The color channels of the
background color are brightened based on the color
values of the corresponding channels of the fore-
ground color. A white foreground color will pro-
duce whiteness, and a black foreground color (i.e.,
all color channels are zero) has no effect.

Color Burn: The color channels of the back-
ground color are darkened based on the darkness of
the corresponding channels of the foreground color.
A black foreground color will produce blackness
while a white foreground color has no effect.

Brighten: The color channels of the back-
ground color are replaced by the corresponding
channels of the foreground color if the foreground
color channels are lighter. If the original back-
ground color channels are already lighter than the
corresponding foreground channels, the back-
ground color channels will not be changed.

Darken: The color channels of the back-
ground color are replaced by the corresponding
channels of the foreground color if the foreground
color channels are darker. If the original back-
ground color channels are already darker than the

Multiply mode. (Color plate on page 194.)

Light mode. (Color plate on page 194.)

Color Dodge mode. (Color plate on page 194.)

Color Burn mode. (Color plate on page 194.)

Brighten mode. (Color plate on page 194.)
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corresponding foreground channels, then back-
ground color channels will not be changed.

Difference: The background’s color value for
each channel is subtracted mathematically from the
path’s color value for the same channel. If the result
is a negative value, the value is wrapped around
from 1.0. This blending mode produces interesting
but sometimes unexpected results, especially with
soft-edged paths in bright colors.

8.9.1 Applying Blending Modes
1. Select one or more path objects.
2. Choose the blending mode you want from the

Blending Mode popup button  in the Paint
Style palette. To revert to the normal mode,
choose the Normal button .

8.10 Setting Variable Width 
and Opacity
For paths using skeletal strokes, soft-edged fill, or
embossed fill, the width of these features can be
made to vary along the path using a width profile.

A width profile is a graph of width variation against
path length, and its shape is determined by the posi-
tions of the profile nodes on it. You can create, edit,
arrange and save width profiles for future use, as is
described in Section 15.6.

For paths using bitmap strokes defined with an
alpha channel, the width profile can also be used to
control transparency variations.

Note: Opacity variations have no effect on vector
skeletal strokes.

1. Select one or more path objects. They must use
skeletal strokes, soft-edged fill and/or
embossed fill.

2. Choosing width profiles: In the Variable
Width palette, choose the width profile you
want from the Presets popup . To remove
the width profile from the path, click the Reset
button .

3. Controlling variable width and opacity
for bitmap strokes with alpha channel:
Use the Transparency slider and Width slider to
control variable transparency and width.

8.11 Picking Colors
Expression supports three color models (HSL,
RGB and CMYK) as well as custom colors. A more
detailed description of the color models and color
management is provided in Chapter 4. Each color
model has a corresponding color picker, which is
displayed in the lower section of the Paint Style pal-
ette. In addition, you can choose colors by entering

Darken mode. (Color plate on page 194.)

Difference mode. (Color plate on page 194.)

Using variable width with soft-edged fill, 
embossed fill and skeletal stroke.
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a description directly in the Paint Style palette, and
let Expression find the closest match. See Section
8.11.5 for details.

The HSL, RGB and CMYK color pickers each have
graphical controls and corresponding numerical
controls for choosing color components, a color
preview, a status bar, and a Dropper Content button.

The usage of sliders and meters can be found in
Chapter 6. Colors can also be copied from object to
object, or copied to and from the Paint Style palette,
as is described in Section 15.4.

8.11.1 Using the HSL Color Picker
The HSL color model describes colors based on the
human perception of hue, saturation and lightness.
Hues are chosen using the color wheel, which
shows a part of a much larger hue spectrum. Upon
dragging, the hue spectrum shifts as much or as lit-
tle as you want, so that you can pick the exact hue
that you want. The current hue is the hue pointed to
by the tip of the triangle, which shows the satura-
tion and lightness variations for that hue. If you pre-
fer to see the full hue spectrum in the palette, you
can double-click the color wheel or turn off the
“Draggable color wheel” option in the
“Preferences” dialog (Section 18.2.3). In this case,
the hue spectrum will be shown as a wraparound
column, and there will be a circle in the column to
indicate the position of the current hue.

• Changing the triangle’s background
color: Choose a color you like using the color
picker, and drag from the color preview to the
triangle’s background space (the pointer
becomes ).

8.11.2 Using the RGB Color 
Picker
The RGB color model describes colors based on the
overlapping of red, green and blue light. The value
of each color component is in the range of 0-255.

8.11.3 Using the CMYK Color 
Picker
The CMYK color model describes colors based on
the overlaying of process inks (cyan, magenta, yel-

The HSL color picker with the non-draggable 
color wheel.

The HSL color picker with the draggable color 
wheel.

The RGB color picker.

The HSL color picker with the non-draggable 
color wheel.
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low and black) printed on paper. The value of each
component is in the range of 0-100%.

8.11.4 Using the Custom Color 
List
Custom colors are colors identifiable by name, and
they can be darkened or lightened using the Inten-
sity slider under the custom color list. At ±0%
intensity change, the color is its original color. At
-100% intensity change, it becomes white; at
+100%, it becomes black. Besides the custom col-
ors provided in Expression, you can create your
own custom colors, as is described in Section 15.1.

8.11.5 Using the Color Text 
Display Box
You can specify a color by directly entering
descriptions of colors in the Color Text Display
Box at the bottom left of the Paint Style palette.
Expression accepts a wide range of color descrip-
tions:

• HTML RGB values: e.g., “#ff12e4” or
“ff12e4”.

• HSL values: e.g., “H=270 L:50%”.
• RGB values: e.g., “B=50% r=128”.
• CMYK values: e.g., “50 0 0 0”.
• Individual channel values: e.g., “R=14%”.
• Custom color names: e.g., “Pale Green

(-10%)”.
• Partial custom color names and tint val-

ues: e.g., “2727U” (this would match “Day-
tone 2727U”), “D?y* 2727U” (this would
match “DIY 2727”, “Doyoda 272727” etc.),
“30% Red”, “+40% Red”, “Red (-20%)” etc.

8.11.6 Applying Color Strokes
1. Select one or more path objects.
2. Click the Basic Stroke button  in the Paint

Style palette. Alternatively, click the Stroke
Preview if the path already uses basic strokes.

3. Choose the color model and color as follows:
4. Choosing colors in HSL values: Choose

HSL  in the Choose Color Picker popup but-
ton. In the HSL color picker, choose the hue by
dragging the color wheel or, for the non-drag-
gable color wheel, drag the circle on it. To
choose the saturation and lightness, drag the
cross in the triangle towards the right for higher
saturation, and upwards for lighter colors.

• Choosing colors in RGB values: Choose
RGB  in the Choose Color Picker popup
button. In the RGB color picker, use the sliders
or meters to choose the red, green and blue
components.

• Choosing colors in CMYK values: Choose
CMYK  in the Choose Color Picker popup
button. In the CMYK color picker, use the slid-
ers or meters to choose the cyan, magenta, yel-
low and black components.

• Choosing custom colors: Choose Custom
Color  in the Choose Color Picker popup

The CMYK color picker.

The custom color list.
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button. In the custom color list, choose the
color you want. To darken the custom color,
drag the Intensity slider towards the right; to
lighten the custom color, drag it towards the
left.

8.11.7 Applying Color Fill
1. Select one or more path objects.
2. Click the Solid Fill button  in the Paint Style

palette. Alternatively, click the Fill Preview if
the path already uses solid fill.

3. Choose a color picker and color as in Section
8.11.6 above.

8.12 Applying Gradients
A gradient is a sequence of colors that blend from
one to the next. Each color can have its own degree
of transparency, and the pattern as a whole can be
applied in a linear or radial direction. Besides the
gradients provided in Expression, you can create
your gradients, as is described in Section 15.2.

8.12.1 Using the Gradient List
When you choose the Gradient Stroke button or
Gradient Fill button in the Paint Style palette, the

lower section of the Paint Style palette changes into
the gradient list.

8.12.2 Applying Gradient 
Strokes
1. Select one or more path objects.
2. Click the Gradient Stroke button  in the

Paint Style palette. Alternatively, click the
Stroke Preview if the path already uses gradient
strokes.

3. In the gradient list, click the gradient you want.
4. Enable the Linear Gradient button  to use a

linear gradient, or enable the Radial Gradient
button  to use a radial gradient.

8.12.3 Applying Gradient Fill
1. Select one or more path objects.
2. Click the Gradient Fill button  in the Paint

Style palette. Alternatively, click the Fill Pre-
view if the path already uses gradient fill.

3. Choose a color picker and color as in Section
8.12.2 above.

8.12.4 Setting Gradient Axes
A gradient has two axes: the main axis (along
which the color varies) and the second gradient axis
(which affects the skewing of the gradient coordi-
nate system). If a gradient is radially applied, and
its axes are skewed and of different length, the gra-
dient will have an elliptical appearance. For linearly

Custom colors can be darkened and lighted 
using the Intensity slider. Here the same custom 
color (bottom) is applied at -50% intensity 
change (top left), at (±0% intensity change 
which is the color as it is defined (top middle), 
and at +50% intensity change (top right).

The gradient list.
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applied gradients, only the direction of the second
gradient axis is significant; the direction of the
color bands follows that of the second axis.

1. Select one or more path objects.
2. Choose the Gradient Vector tool .
3. Choose from these options:
• Setting the main gradient axis: Place the

pointer where you want the gradient’s starting
point (0%) to be, and drag in the direction you
want, releasing the mouse button at where you
want the gradient’s ending point (100%) to be.
The second gradient axis will automatically be
set to a perpendicular direction with the same
magnitude as the main axis.

• Setting the second gradient axis: Hold
 (the pointer becomes ) and drag out

the second gradient axis. Only the direction and
magnitude of the second gradient axis is
changed. The gradient starting point and the
main axis will not be affected.

8.12.5 Transforming Gradient Fill
You can use the Transform Fill tool to move, scale,
rotate and otherwise transform the gradient fill
applied to a path independently of the path itself. If
you are trying to adjust the appearance of a gradi-
ent, it is probably easier to use the Transform Fill
tool than to define a new gradient every time.

1. Select the path object.
2. Choose the Transform Fill tool .
3. To shift the gradient, drag it. To scale, rotate, or

shear the gradient, drag the resize handles as
you would to transform an object. (See Section
12.1.1.)

8.13 Applying Pattern Fill
A pattern is a set of path objects which tile them-
selves over an area. If the pattern tiles are not com-
pletely covered by the path objects that define the
pattern, the areas not covered will be left fully
transparent. Expression allows semi-transparent
objects to be used in pattern definitions.

When a path with a pattern fill is transformed, the
pattern is transformed with it. However, you can fix
the position, size and orientation of patterns by
turning off the “Transform patterns” option in the
“Preferences” dialog (Section 18.2.1).

8.13.1 Using the Pattern List
When you click the Pattern Fill button, or when a
pattern fill is used and the Fill Preview is depressed,
the lower section of the Paint Style palette changes
into the pattern list. When you choose patterns from
the pattern list, a preview of the pattern chosen will
be shown in the Fill Preview. Besides the patterns
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provided in Expression, you can create your own
patterns, as is described in Section 15.3.2.

8.13.2 Applying Pattern Fill
1. Select one or more path objects.
2. Click the Pattern Fill button  in the Paint

Style palette. Alternatively, click the Fill Pre-
view if the path already uses a pattern fill.

3. In the pattern list, click the name of the pattern
you want.

8.13.3 Transforming Pattern Fill
You can use the Transform Fill tool to move, scale,
rotate and otherwise transform the pattern fill
applied to a path independently of the path itself.

1. Select the path object.
2. Choose the Transform Fill tool .
3. To shift the pattern, drag it. To scale, rotate, or

shear the pattern, drag the resize handles as you

would to transform an object. (See Section
12.1.1.)

8.14 Applying Image Fill
Image fills are similar to pattern fills, except that
images are used for tiling the fill area. This allows
for more efficient screen redraw, and is convenient
for creating much distorted images for special
effects or for organic textures with subtly changing
pixel values.

8.14.1 Using the Image List
When you click the Image Fill button, or when an
image fill is used and when the Fill Preview is
depressed, the lower section of the Paint Style pal-
ette changes into the image list. When you choose
images from the image list, a preview of the image
chosen will be shown in the Fill Preview. Besides
the images provided in Expression, you can bring in
your own images.

The pattern list.

A fish pattern with a transparent background is 
applied to a fish-shaped path.
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• Adding images to the image list: Go to
the image list in the Paint Style palette, and
click the Add Image button . In the dialog
that is opened, choose the image you want to
add, and click “Open”.

• Removing images from the image list:
In the image list of the Paint Style palette,
choose the image you want to remove from the
list, and click the Delist Image button . The
image will not be shown any more in the image
list, but the file itself will not be deleted from
your hard disk.

8.14.2 Applying Image Fill
1. Select one or more path objects.
2. Click the Image Fill button  in the Paint Style

palette. Alternatively, click the Fill Preview if
the path already uses an image fill.

3. In the image list, click the name of the image
you want.

8.14.3 Transforming Image Fill
You can use the Transform Fill tool to move, scale,
rotate and otherwise transform the image fill
applied to a path independently of the path itself.

1. Select the path object.
2. Choose the Transform Fill tool .
3. To shift the image, drag it. To scale, rotate, or

shear the image, drag the resize handles as you
would to transform an object. (See Section
12.1.1.)

8.15 Applying Skeletal 
Strokes
Skeletal strokes are picture strokes created from
paths or bitmaps. To use a skeletal stroke, click the
Skeletal Stroke button in the Paint Style palette, or
choose a skeletal stroke from the Strokes palette. In
the former case, the last skeletal stroke used or
selected will be applied. If no skeletal stroke has
been used before, the default stroke s01 will be
used.

When a skeletal stroke is applied to a path, the pic-
ture defining the stroke is fitted along the shape of
the path. The way this is done depends on how the
skeletal stroke is defined, with or without anchoring
and repeatable parts. The details on defining strokes
can be found in Chapter 10.

8.15.1 Using the Strokes Palette
The Strokes palette lists the installed skeletal stroke
files under your current stroke folder. You can click
one of the listed strokes to apply it to the selected
paths.

Strokes can be organized into different folders.
Expression supports only one level of sub-categori-
zation to keep the interface simple. The Strokes pal-
ette does not, however, list local stroke definitions
stored in a picture file. You can organize strokes
into different folders, as is described in Section
10.5.

Choosing a stroke category in the Strokes pal-
ette.
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• Viewing strokes in individual folders:
Choose a stroke folder’s name in the folder
popup menu to view strokes from that folder
only.

• Viewing strokes in the root folder: Choose
<General> in the folder popup menu to show
strokes from the “Strokes” folder under the
“Expression 3” folder (Macintosh) or under
“Start menu > Programs > Expression 3 >
Resources” (Windows), but not from individual
sub-folders.

• Viewing all strokes: Choose <All> in the
folder popup menu to show all strokes.

• Choosing a skeletal stroke: Click one of
the listed strokes to apply it to the selected
paths.

8.15.2 Applying Skeletal Strokes
To use a skeletal stroke from a picture file, simply
select a path that uses that stroke, then start drawing
new paths. The new paths will have the same
attributes as the original path, including the particu-
lar skeletal stroke.

When a skeletal stroke is applied, Expression auto-
matically removes the path’s fill. If you want to
keep the fill while you change strokes, turn off the
“No fill with skeletal strokes” option in the
“Preferences” dialog (Section 18.3.1).

1. Select one or more path objects.
2. Choose from these options:
• Using the Strokes palette: Click the skele-

tal stroke you want in the Strokes palette.
• Using quick strokes: Press a numeric key

(from 1 to 9) to choose the corresponding
stroke previously assigned to that number. For
details on how to assign quick strokes, see Sec-
tion 10.6.

8.16 Colorizing Objects and 
Skeletal Strokes
Certain types of objects in Expression contain mul-
tiple colors; patterns, gradients and skeletal strokes
are such objects. Now if you want to modify the
color scheme of these objects, you can of course
define different versions of them, but there is a far
more convenient way to do this, and that is to col-
orize these strokes, gradients or patterns after they
have been applied to paths.

Colorization provides an external control over such
multi-colored objects. General colorization of vec-
tor objects is performed through the Colorize pal-
ette by spectrum re-mapping, and lightness and
saturation shift. For skeletal strokes, a simpler but
effective foreground/background colorization
method can also be specified directly in the Paint
Style palette.

8.16.1 Colorizing Skeletal 
Strokes
The foreground/background colorization mode
replaces a skeletal stroke’s original color spectrum

A path with a multi-colored skeletal stroke (top) 
and the colorized versions. (Color plate on page 
193.)
A Foreground/Background mode with a white 

foreground and a red background.
B Colorized using spectrum re-mapping. The red 

hue has been re-mapped to a yellow color, 
the yellow hue to a reddish color, and the 
green hue unchanged.

C Brightness increased.
D Saturation decreased.
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with a new spectrum created from two new colors
of your choice. The two colors are called the fore-
ground color and the background color, and the
new spectrum is the range of colors formed by a
gradual blending of these two colors. For example,
if you choose a red and a yellow as the foreground
and background colors, the new spectrum will con-
sist of reds, yellows, and the different shades of
orange in between the two.

When you colorize a stroke, the foreground color
replaces black in the stroke, and the background
color replaces white in the stroke. Areas that are
neither black nor white are replaced with colors
from the new spectrum according to the degree of
lightness. The darker the original color, the closer to
the foreground color the replacing color will be,
and vice versa. Colorization is based on lightness
alone, with no regard to hue and saturation.

Note that colorization affects only the stroke that is
applied to the path, not the stroke definition itself.

8.16.2 Using the 
Foreground/Background Color 
Previews
When you choose the Skeletal Stroke button in the
Paint Style palette, the lower section of the palette
changes into the color picker, as when the Basic
Stroke button or Solid Fill button is chosen. How-
ever, at the bottom right of the palette, the color pre-
view will be replaced by a Foreground Color
Preview, a Background Color Preview (below the
Foreground Color Preview), and a Reset Color but-
ton in the middle.

The Foreground Color Preview and the Back-
ground Color Preview show the currently chosen
foreground and background colors respectively.
You can switch focus between foreground and
background colors by clicking the relevant color
preview. The colors in the color previews can also
be copied to the Dropper Content button (below the

Background Color Preview) by a dragging action,
as is described in Section 15.4.

8.16.3 Colorizing Skeletal 
Strokes
1. Select the path whose stroke you want to col-

orize.
2. Click the Stroke Preview in the Paint Style pal-

ette.
3. Click the Foreground Color Preview if you

want to colorize the foreground color. To col-
orize the background color, click the Back-
ground Color Preview instead.

4. Choose a color picker and color as in Section
8.11.

8.17 General Colorization 
of Objects
Colorization lets you affect the colors on different
strokes and paths at the same time, by replacing the
color spectrum. Composite objects, like fill patterns
or skeletal strokes, are made up of different color
components, and colorization allows you to control
these different color components externally without
modifying the original definition. Colorization is
also useful for changing the tone or mood of an
entire picture without numerous individual color
changes.

The Foreground Color Preview, the Background 
Color Preview, and the Reset Color button.
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The color spectrum is changed by replacing the
individual hues on the original hue ring with any
other colors, by replacing the black point and white
point (this is like the foreground/background col-
orization for skeletal strokes), and by changing sat-
uration and lightness.

8.17.1 Using the Colorize Palette
The rainbow colored circular ring at the center part
of the palette is the hue reference ring, which shows
the original hue spectrum as a reference for the col-
orized spectrum inside the ring. Without coloriza-
tion, the hues in the colorized spectrum match those
in the hue reference ring.

By adding hue nodes around the hue reference ring,
the original hue at each node position is replaced by
the color of that node. Hue nodes can be dragged
around the ring to colorize different parts of the
spectrum, and the colors of the nodes themselves
can be changed using the color picker at the left of
the palette.

The vertical bar to the left of the colorized spectrum
shows a preview of the color variations between the
White node (at the top of the vertical bar) and the
Black node (at the bottom of the vertical bar). You
can replace the white point and the black point of
the color space by changing the colors in the White
node and Black node.

The two sliders at the right of the palette are for
adjusting the overall saturation and lightness levels
of objects. The button below the sliders is for

restoring the original spectrum and hence the
objects’ original colors.

8.17.2 Replacing Hues
1. Select the paths you want to colorize.
2. In the hue reference ring, place the pointer over

the new hue that you want, and drag it (a hue
node in the new hue will appear and follow the
pointer as you drag) along the hue reference
ring to the hue that you want to be replaced. The
colorized spectrum will be updated accord-
ingly.

3. Edit the hue nodes as follows:
• Changing colors of hue nodes: Click a

hue node, and choose a color using the color
picker at the left of the Colorize palette. For
details about the HSL color picker, see Section
8.11.

• Moving hue nodes: Drag a hue node along
the hue reference ring to the new position.

• Adding hue nodes: Click the hue reference
ring to add a hue node that is the same color as
the color it replaces. Alternatively, add a node
and replace a hue as in step 2 above.

• Duplicating hue nodes: Hold  and
drag a hue node to duplicate it.

• Deleting hue nodes: Drag a hue node away
from the colorized spectrum to remove it.

A HSL color picker
B Black node
C White node
D Selected hue node
E Deselected hue 

node

F Brightness slider
G Saturation slider
H Colorized spectrum
I Hue reference ring
J Remove colorization

The Colorize palette.
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Note: The substituted hue color will affect a neigh-
borhood of up to ±30 degrees in the hue dimension
(with a diminishing influence over distance), or up
to the midpoint between adjacent hue replacement
nodes if they are less than 30 degrees apart.

8.17.3 Replacing the White and 
Black Points
The vertical bar in the Colorize palette shows the
spectrum between the white point and the black
point, and without colorization, the bar shows a gra-
dient from white to black. You can choose the
White and Black nodes, and replace them with any
two colors. To replace white and black on skeletal
strokes only, you can also use the Fore-
ground/Background colorization mode, as is
described in Section 8.16.1.

1. Select the paths you want to colorize.
2. If you want to replace white, click the top node

of the vertical bar in the Colorize palette. To
replace black, click the bottom node instead.

3. Choose the color you want to replace with
using the color picker at the left of the Colorize
palette.

8.17.4 Changing Overall 
Lightness and Saturation
You can change the overall lightness and saturation
levels of all colors in the spectrum. Note that if you
have replaced white and black with another two
colors, then the lightness level will be in the range
of the two new colors, not from white to black.

1. Select the paths you want to colorize.
2. In the Colorize palette, drag the Brightness or

Saturation slider to change the lightness or sat-
uration as needed.

Note that if you perform hue re-mapping as well as
saturation/brightness shift, the shift in saturation or
brightness will be performed after the hue-remap-
ping.

8.17.5 Removing Colorization
Removing colorization restores the original colors
of the strokes and paths.

1. Select the paths.
2. Click the Remove Colorization button  in

the Colorize palette or the Paint Style palette.
Alternatively, in the Paint Style palette, click
the Stroke Preview to show the Reset Color but-
ton , and click it.
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Chapter 9: More Specialized Stroke and Fill 
Attributes

The Attributes palette displays and controls the
more specialized attributes, some of which apply
only to skeletal strokes, like shape parameter (for
multi-view strokes), stroke shear, stroke mode and
the “Break At Joints” option. Two other attributes,
dash pattern and stroke joint, apply to all kinds of
strokes, whereas stroke cap is for basic and gradient
strokes only. You can also choose the fill rule and
tangent handle behavior (see Section 7.21). For a
description on the usage of meters and sliders, see
Chapter 6.

9.1 Multi-View Strokes and 
Shape Parameter
Multi-view strokes are strokes defined from a num-
ber of variations (the views) of the definition pic-
ture, and can take the appearance of one of the
in-between shapes. The exact in-between shape of a
multi-view stroke that is taken in a path object is
specified in the shape parameter attribute.

9.2 Setting Shape 
Parameters
The value of the shape parameter can be within the
range of 0 to 100%. The shape parameter 0% refers
to the first view, and 100% to the last view of the
multi-view stroke. You can choose a specific shape
parameter, or, for variety, let Expression choose one
for you at random.

1. Select one or more path objects. They must use
multi-view strokes.

2. Choose from these options:
• Using a random shape: Enable the Ran-

dom button  to let Expression choose a
shape at random for each path.

• Setting shape parameters: Disable the
Random button  to show the Shape slider,
and drag the slider to the shape parameter you
want.

9.3 Setting Stroke Shear
For paths using skeletal strokes, the amount of
stroke shear determines how much the stroke is
sheared with reference to the path. Note that stroke
shear is an attribute of skeletal strokes, and is differ-
ent from the shearing transformation that can be
applied to all objects.

Strokes with the same shape parameter (left), 
and strokes using a random shape parameter 
(right).

A skeletal stroke applied to a path with stroke 
shear.
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To set stroke shear:

1. Select one or more path objects. They must use
skeletal strokes.

2. Choose from these options:
• Setting stroke shear using the Shear

slider: In the Attributes palette, drag the Shear
slider  towards the right (for a positive shear
angle) or left (for a negative shear angle).

• Setting stroke shear using the width
handle: Choose the Node tool  or Node
Lasso tool . Hold  and drag the width
handle to change the angle between the handle
and the path. The stroke shear can be reset to
zero by holding down  as you drag the
width handle. To adjust the shear angle this way
without altering the stroke width is difficult, so
if the width must be retained, use the Shear
slider to control stroke shear instead.

• Resetting stroke shear: In the Attributes
palette, drag the Stroke Shear slider  to the
zero mark. Alternatively, choose Stroke > Reset
Stroke Shear.

9.4 Setting Stroke Modes
As a skeletal stroke follows the shape of the path it
is applied to, the normal of the stroke can be made
to be always perpendicular to the path to give a gen-
erally rounded shape (the sausage mode), or remain
aligned with the vertical axis as if drawn with a flat
nib pen (the ribbon mode). Somewhere in between
the two stroke modes is the elliptical mode, which

makes a stroke look as if drawn with an elliptical
pen.

To set stroke modes:

1. Select one or more path objects. They must use
skeletal strokes.

2. In the Attributes palette, choose from these
options:

• Using the sausage mode: Enable the Sau-
sage Mode button .

• Using the ribbon mode: Enable the Ribbon
Mode button . To reverse the direction in
which the strokes appear to be folding, choose
Stroke > Reverse Ribbon Folds.

• Using the elliptical mode: Enable the
Elliptical Mode button . To change the
length-width ratio, choose Stroke > Set Ellipse
Ratio. Choose or enter a lower value for a style
closer to the ribbon mode, or a higher value for
a style closer to the sausage mode. Click “OK”.

9.5 Setting Stroke Twist
You can give a skeletal stroke a twist by specifying
the number of turns.

1. Select one or more path objects. They must use
skeletal strokes.

2. Choose Stroke > Set Stroke Twist, and in the
dialog that is opened, enter the number of turns
and click “OK”.

From left to right: sausage mode, ribbon mode, 
and elliptical mode.
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9.6 Setting Stroke Joints
For paths with sharp corners, like rectangles, you
can change the way the strokes look at the corner
nodes by choosing different kinds of stroke joints.

To set stroke joints:

1. Select one or more path objects.
2. In the Attributes palette, choose from these

options:
• Using miter joints: Enable the Miter Joint

button  to make the stroke corners sharp by
joining the outer stroke sides with straight lines.

• Using round joints: Enable the Round Joint
button  to make the stroke corners round.

• Using bevel joints: Enable the Bevel Joint
button  to make the stroke corners beveled.

9.7 Breaking Strokes at 
Corners
The skeletal stroke applied to a path can be mapped
to the entire length of the path, or, in the case of
paths with discontinuities (e.g., sharp corners), it
can be re-applied whenever a discontinuity is
encountered in the path.

For example, with a rectangular path, there is a dis-
continuity at each corner, and by starting the stroke
anew at each corner, you can create the effect of a
picture frame.

Note that discontinuities in paths do not necessarily
mean sharp corners; Bezier curves are discontinu-
ous where the node continuity setting is
“angle-locked” or “unconstrained”.

To break strokes at corners:

1. Select one or more path objects. They must use
skeletal strokes.

2. In the Attributes palette, choose from these
options:

• Using continuous strokes: Enable the Con-
tinuous button  to fit one skeletal stroke to
the entire length of the path.

• Breaking strokes at corners: Enable the
Break At Joints button  to start a new skele-
tal stroke whenever there is a discontinuity in
the path.

9.8 Setting Stroke Caps
For open paths that use basic or gradient strokes,
you can choose different stroke caps to give the
stroke ends different looks. Objects not using basic
or gradient strokes are not affected by this attribute.

From left to right: round joints, bevel joints, and 
miter joints.

The same flower stroke, applied using the “Break 
At Joints” option (left), and without (right).

Another example of using the “Break At Joints” 
option.
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1. Select one or more path objects. They must use
basic or gradient strokes.

2. In the Attributes palette, choose from these
options:

• Using square caps: Enable the Square Caps
button  to make the stroke ends square and
overhanging from the starting and ending
nodes.

• Using round caps: Enable the Round Caps
button  to make the stroke ends round.

• Using butt caps: Enable the Butt Caps button
 to make the stroke ends flat at the starting

and ending nodes.

9.9 Applying Strokes in 
Dashes
Basic, gradient and skeletal strokes can be applied
in dashes, so that a stroke is repeated at regular or
irregular intervals along the path, like a string of
beads in a necklace. Dashes are not necessarily of
equal length, nor need they be evenly spaced out.

A dash pattern can also be offset from the path’s
starting point; such a pattern is referred to as having
a phase offset. There are three kinds of phase off-
sets: normal offset, snake offset and blanked offset.
The normal offset option shifts the entire dash pat-
tern along the path, and the blanked offset option
adds a blanked section before the dash pattern
starts. The snake offset option ignores all but the
first value of the dash pattern, and uses it to create a

dash pattern with only one section. The section is
shifted along the path based on the snake offset
value.

9.9.1 About Dash Patterns and 
Phase Offsets
Dash patterns and phase offsets are specified in
strings of numbers, as in these examples:

• Dash pattern “100”: This is a regular pattern
of a dash (100 points), then a gap of the same
length, then a dash of the same length, and so
on.

• Dash pattern “100 50”: Long dash (100
points), short gap (50 points), long dash (100
points), etc.

• Dash pattern “100 50 25”: Long dash (100
points), short gap (50 points), very short dash
(25 points), long gap (100 points) etc.

• Dash pattern “100 50 25” and phase off-
set “1”: Phase offset is measured in number of
cycles. Here, the cycle length is 175 points (100
+ 50 + 25 = 175 points). A phase offset of “1”
means shifting 175 points from the start of the
path, but because the dash pattern repeats itself
every 175 points anyway, no change will be
seen.

• Dash pattern “100 50 25” and phase off-
set “0.2”: This means shifting 35 points (175 x

From top to bottom: butt caps, round caps, and 
square caps.

From top to bottom: a repeating stroke applied 
without dash pattern, with the dash pattern 
“50”, and with the dash pattern “40 10 30 5”.
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0.2 = 35 points) from the start of the path. This
time, a change should be seen.

9.9.2 Applying Strokes in Dashes
1. Select one or more path objects.
2. In the Attributes palette, enable the Dash

On/Off button  to show the “Dash” box.
3. In the “Dash” box, set the dash pattern as fol-

lows:
• Using one length for dashes and gaps:

Enter the length (in points), and press the
Return/Enter key.

• Using individual dash and gap lengths:
Enter the lengths in succession, i.e., dash
length, gap length, next dash length (if any),
next gap length (if any), next dash length (if
any) etc. Separate the values with a space char-
acter as in the examples in the previous section.
Press the Return/Enter key.

4. If you want to set a phase offset as well, choose
it as follows:

• Using normal offset: Choose the Normal
Offset button  to show the Dash Phase Off-
set meter. Set the offset value (in points), and
press the Return/Enter key. The normal offset
shifts the dash pattern along the path.

• Using snake offset: Choose the Snake Offset
button . Set the offset value, and press the
Return/Enter key. The snake offset specifies
by how much a one-section dash pattern is
shifted along the path. Only the first dash value
is used. At snake offset of “0”, the section is at
the start of the path; at “1”, it is at the end of the
path.

• Using blanked offset: Choose the Blanked
Offset button . Set the offset value, and
press the Return/Enter key. The blanked off-
set specifies the amount of space at the start of
the path before the dash pattern begins.

9.10 Setting Fill Rules
For a path that crosses over itself a few times, you
can choose the fill rule to make sure that the fill
areas are filled the way you want them to be.

Expression supports both the non-zero winding rule
and the even-odd rule for determining the
inside-ness of a path. To tell whether a particular
point in the 2D space is inside a path of not, a wind-
ing number count is determined. The winding num-
ber count is simply the number of times a particular
point is encircled by the path, with each counter-
clockwise turn canceling each clockwise turn. The
non-zero winding rule considers all points with a
non-zero winding number count to be inside the
path, while the even-odd rule considers only points
with an odd winding number count to be inside the
path.

To set fill rules:

1. Select one or more path objects.
2. In the Attributes palette, choose from these

options:
• Using the non-zero winding rule: Enable

the Winding Rule button .
• Using the even-odd rule: Enable the

Even-Odd Rule button .

Using the non-zero winding rule (left), and the 
even-odd rule (right). The numbers shown are 
the winding number count.



94 Expression 3 Manual



95
Chapter 10: Defining and Managing Skeletal 
Strokes

Using skeletal strokes, you can draw expressive and
stylish brush strokes at the flick of the stylus or the
mouse. It is just as easy to create your own skeletal
strokes. This chapter starts by explaining how you
can turn arbitrary graphics into a skeletal stroke
with a simple command, and goes on to cover the
finer controls over the deformation and repetition
of various parts of a design.

When you create skeletal strokes, they are added to
the list of existing strokes in the Strokes palette,
ready to be applied to paths, as is described in Sec-
tion 8.15. Note that when you open an Illustrator
file with art brushes, they can also be converted to
skeletal strokes. These skeletal strokes are, how-
ever, not added to the Strokes palette unless you
define them in Expression.

Each skeletal stroke is recorded in a stroke defini-
tion file (using the extension of “.sks” on Windows)
in the “Strokes” folder under the “Expression 3”
folder (Macintosh) or under “Start menu > Pro-
grams > Expression 3 > Resources” (Windows).
Stroke definitions can be organized into stroke fold-
ers for easy access, using controls in the Strokes
palette.

10.1 Defining and Editing 
Strokes
You can create your own skeletal strokes from paths
and bitmaps, and the process is referred to as defin-
ing strokes. For vector objects, the stroke definition
process in the simplest form involves adding a ref-
erence frame to some paths. The reference frame,
called the stroke definition box, defines the orienta-
tion and scale of the stroke, and in strokes with

anchoring and repeating parts, allows structural
controls to be appended to it. The stroke definition
box can be specified explicitly, or it can come from
the bounding box of the source objects.

For bitmap strokes, there are no structural controls,
and the stroke definition process is even more
straightforward, as is described in Section 14.4.

10.1.1 About the Stroke Window
When you define or edit vector strokes, a stroke
window opens to show the stroke and the stroke
definition box.

10.1.2 About the Stroke 
Definition Box
The stroke definition box is a reference frame for
the stroke. The horizontal arrow acts as the pic-
ture’s reference backbone, which will be used to
map a stroke to a path when you apply the stroke;
the two ends of the arrow define the parts that will

A Add view
B Delete view
C View markers

D Stroke definition box
E Define stroke

The stroke window.
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be mapped to the path’s starting and ending nodes.
The height of the stroke definition box is a refer-
ence for the stroke width.

10.1.3 Defining Strokes
1. Create the paths to be defined as a stroke.
2. Choose from these options:
• Using the bounding box as the stroke

definition box: Select all paths to be included
in the stroke definition, and choose Stroke >
New Stroke Definition.

• Setting stroke definition box by drag-
ging out a marquee: Choose the Stroke
Definition Box tool , and drag diagonally
across the paths, releasing the mouse button
when you have the right size.

3. In the stroke window that is opened, edit the
paths if needed, and use the Stroke Definition
Box tool to redefine the stroke definition box
again if needed.

4. Click the Define Stroke button , or choose
Stroke > Define Stroke. This opens a “Define
Stroke” dialog.

5. Enter the stroke name and default width.
Choose a stroke folder in which to put the
stroke, or enter a new name in the “Folder” box
to add a new folder. Click “OK”.

10.1.4 Editing Strokes
1. Open the stroke window in one of the following

ways:
• From the Paint Style palette: Double-click

the Stroke Preview where the stroke is shown.

• From the Strokes palette: Double-click the
stroke in the Strokes palette, or choose the
stroke and click the Edit Stroke button .

• Using a menu command: Choose the
stroke or select a path using the stroke, and
choose Stroke > Edit Stroke Definition.

2. In the stroke window, edit the paths, and define
the stroke as in Section 10.1.3 above.

10.1.5 Deleting Strokes
1. Choose the stroke in the Strokes palette, or

select a path using the stroke.
2. Click the Delete Stroke button , or choose

Stroke > Delete Stroke Definition. The stroke
file will be deleted from your hard disk.

10.2 Defining Strokes with 
Anchoring
When you apply a simple skeletal stroke to a path
whose length and stroke width are different from
the length and height of the stroke definition box,
the picture you see will be stretched or squashed,
and its aspect ratio will be changed. Sometimes,
this may not be what you want.

For example, if you apply a stroke of a fish to a long
path, all parts of the fish will be equally stretched. If
what you want is to always keep the proportions of
the fish picture, or to keep the proportions in the
head and tail but let the fish’s body stretch with the
path, this can be done using anchoring.

The use of anchoring in stroke definitions refers to
the way in which nodes in a stroke definition can be
locked at fixed and different positions on the refer-
ence backbone. By doing so, the locked parts will
be mapped to the path according to the positions
(relative to the reference backbone) at which they
are fixed in the stroke definition, and their aspect
ratios will be preserved.

A stroke with the stroke definition box.
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10.2.1 About Anchor Markers
Nodes can be anchored to the reference backbone at
the starting point (left end of arrow), the ending
point (right end of arrow), or any position along the
reference backbone. Each position to which nodes
have been anchored is marked with an anchor
marker , which becomes  when chosen. The
anchor marker indicates the position of the point on
the skeleton that the anchored nodes will move
with. Nodes anchored to the ending point will move
with the tail of a stroke, and nodes anchored to the
starting point will move with the head of the stroke.
If nodes are anchored to an anchor point at a 1/3
position (i.e., one third the distance from the start-
ing point), the nodes will always stay at the same
distance away from the 1/3 position of the stroke as
the stroke is stretched.

• Locating anchor markers: Click or drag a
marquee over one or more nodes to choose their
associated anchor marker.

• Locating anchored nodes: Click an
anchor marker to select all nodes anchored to it.

10.2.2 Anchoring Nodes in 
Strokes
1. Open the stroke window for the stroke, as is

described in Section 10.1.4 above.
2. Select the nodes you want to anchor.
3. Choose the Anchor tool .
4. Anchor the nodes as follows:
• Anchoring nodes to the starting point:

Click the Anchor to Start button  or choose
Stroke > Anchor > To Start.

• Anchoring nodes to the ending point:
Click the Anchor to End button  or choose
Stroke > Anchor > To End.

• Anchoring nodes to any position:
Anchor the nodes to the starting or ending
point, and then drag the anchor marker  to
the position you want.

5. Edit anchor markers as in Section 10.2.3 below.
6. Continue to define the stroke as in Section

10.1.3.

10.2.3 Editing Anchor Markers in 
Strokes
1. Open the stroke window for the stroke, as is

described in Section 10.1.4.
2. Choose the Anchor tool . The anchor markers

will be shown.

The selected nodes are anchored to the starting 
point of the reference backbone.

The hand in this stroke has been anchored to 
the starting point of the reference backbone.
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3. Edit anchor markers as follows:
• Choosing anchor markers: Click the

anchor marker  so that it becomes .
• Moving anchor markers: Choose an

anchor marker, and drag it along the reference
backbone to change its position.

• Removing nodes from anchoring: Click,
+click or drag a marquee over the nodes

you want to free from anchoring. Click the
Remove Anchor button , or choose Stroke >
Anchor > Free.

• Removing anchor markers: Choose the
anchor marker. Click the Remove Anchor but-
ton , or choose Stroke > Anchor > Free.

4. Continue to define the stroke as in Section
10.1.3.

10.3 Defining Strokes with 
Repeatable Paths
When you apply a stroke to a long path, the picture
you see will be stretched. By making some objects
repeatable in the stroke definition, they can be
made to repeat themselves (in their original aspect
ratios) along a path that is longer than the stroke’s
reference backbone.

For example, you can define a stroke of a fish with
scales that are repeated along a long path, instead of
being stretched along the path. If the shape of the

fish’s body tapers towards the tail, you can scale
down the repeats accordingly as well.

10.3.1 Making Paths Repeatable 
in Strokes
1. Open the stroke window for the stroke, as is

described in Section 10.1.4.
2. Select the paths you want to become repeatable.
3. Choose the Repeat tool .
4. Click the Make Repeating button , or

choose Stroke > Repeating > Make. A pair of
repeat handles appears at the two ends of the
reference backbone.

5. Edit the repeat handles as in Section 10.3.3
below.

6. Continue to define the stroke as in Section
10.1.3.

10.3.2 About Repeat Handles
Repeatable paths need not repeat over the whole
length of the path, nor need they be the same height
throughout. In fact, you can define the repeating
limits using a pair of repeat handles in the stroke
definition.

A A picture defined as a simple skeletal stroke.
B The head and tail of the arrow are anchored 

to the start and the end.
C Same as B, but the heart is anchored to the 

30% position between start and end.
D Same as B, with the heart made repeating. 

The repeat limits are approximately 30% to 
70%.

E Same as D, except that the repeat limits them-
selves are anchored to the start and end.
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The area in the repeat limits is shown as a rectangle
or trapezium in dashed lines, and when you click
the dashed lines, a pair of repeat handles will appear
for you to edit the repeat limits.

• Locating repeat handles: Click or drag out
a marquee over one or more paths to show their
associated repeat handles.

• Locating repeatable paths: Click the
dashed lines to select all paths associated with
the repeat limits.

10.3.3 Editing Repeat Handles in 
Strokes
1. Open the stroke window for the stroke, as in

Section 10.1.4.
2. Choose the Repeat tool  to show the repeat

limits (in dashed lines).
3. Click the dashed lines. Alternatively, click or

drag out a marquee over the paths associated
with the repeat limits. The repeat handles will
be shown.

4. Edit the repeat handles as follows:
• Moving repeat handles: Drag the handle’s

left or right icon (  or ) to change the han-
dle’s position. This sets the positions of the
starting and ending sides of the repeat limits.

• Scaling repeat handles: Drag the handle’s
top or bottom icon (  or ) up or down to
change the handle’s length. This sets the height
of the ending repeat limit, hence the height of
the repeats towards the end of the repeat limits.

• Anchoring repeat handles: +click
the handle’s left or right icon (  or ) to
anchor it. The icon changes to . To remove
anchoring, +click the icon again. (In the
current version, the left repeat limit is always
anchored to the starting point of the stroke and
the right repeat limit is always anchored to the
ending point of the stroke.

• Removing paths from repeat limits:
Select only the paths that you want to make
non-repeatable. Click the Do Not Repeat button

 or choose Stroke > Repeating > Release.
Other repeatable paths will be unaffected.

• Removing repeat handles: Click the Do
Not Repeat button  or choose Stroke >
Repeating > Release.

5. Continue to define the stroke as in Section
10.1.3.

10.4 Defining Multi-View 
Strokes
A multi-view stroke is a skeletal stroke defined
with two or more vector pictures, each of which

In the top stroke definition, the four path objects 
have the same repeating limits, whereas in the 
bottom stroke definition each path object has 
its own repeating limits. The difference in the 
resulting stroke applications is illustrated in the 
next picture.

The stroke applications of the two strokes 
above.
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forms one view of the stroke. Expression can blend
these views to form a series of in-between pictures,
which, if viewed in sequence, represent a gradual
change from the first to the last view.

For example, if a multi-view stroke consists of
three or four views of a person’s head at different
angles, then viewing the in-between pictures in
sequence will give an illusion of the rotation of the
head. In fact, you can make such an animation by
exporting a picture with multi-view strokes to the
Flash format.

But multi-view strokes are useful in pictures too.
When you apply a multi-view stroke to a path, you
can choose an in-between picture from the stroke,
by specifying a shape parameter. You can also let
Expression choose a shape parameter at random, to
add variety to a picture. For example, if a
multi-view stroke consists of different variations of
a blade of grass, you can create a varied patch of
grass. For more details, see Section 9.2.

The stroke views of a multi-view stroke can be cre-
ated by editing from the first view, or from any
other existing views.

10.4.1 About Stroke Views
The controls for managing stroke views are at the
top of the stroke window. The Add View button 
and the Remove View button  at the left let you
add and delete stroke views, and the view markers
(rectangles) along the view bar indicate the posi-
tions of individual stroke views.

When you select a path in the stroke window, the
corresponding path from the previous and next

stroke views will also be shown (in different colors)
in the current stroke view for reference.

This multi-view stroke consists of four views.

The same multi-view stroke applied with differ-
ent shape parameters.
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10.4.2 Creating Multi-View 
Strokes
1. Open the stroke window for the stroke you

want to use, as is described in Section 10.1.4.
2. Click the Add View button  or choose Stroke

> Add Stroke View to add a stroke view. A new
view marker will be added to the view bar at
100%, and the focus will be switched to this
new view.

3. Edit the paths as you like.
4. Add more stroke views, or edit them, as in Sec-

tion 10.4.3.
5. Continue to define the stroke as in Section

10.1.3.

10.4.3 Editing Stroke Views in 
Multi-View Strokes
1. Open the stroke window for the stroke, as in

Section 10.1.4.
2. Edit stroke views as follows:
• Switching stroke views: Click the view’s

marker in the view bar to switch to that view, or
use the shortcut keys ] and [ instead.

• Moving stroke views: Drag a view marker
along the view bar to change its position. Drag-
ging the view marker at 0% or 100% duplicates
the view.

• Adding stroke views: Go to the view that is
to the left of the position at which you want the
new view to be. Click the Add View button 
or choose Stroke > Add Stroke View.

• Duplicating stroke views: Hold  and
drag a view marker to duplicate it.

• Deleting stroke views: Go to the view you
want. Click the Remove View button  or
choose Stroke > Remove Stroke View.

3. Continue to define the stroke as in Section
10.1.3.

10.5 Managing Strokes and 
Folders
Strokes in the Strokes palette can be organized in
stroke folders for easy management. The contents
of a stroke folder are updated every time you switch
to the folder in the Strokes palette, but you can also
refresh a folder yourself. This is useful for updating
any changes in stroke files that have been made out-
side the Expression session. For example, if you
move stroke files (files with the extension “.sks”) in
the Macintosh Finder or Windows Explorer, you
can update the Strokes palette without having to
restart Expression.

10.5.1 Moving Strokes across 
Folders
1. In the Strokes palette, choose the stroke you

want to move.
2. Choose the Set Stroke Folder button  in the

Folder Operations popup button . This
opens a “Change Stroke Category” dialog.

3. Choose the name of the folder to which you
want to move the stroke. If you want to move

The Folder Operations popup buttons.
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the stroke to a new folder, enter a new name
instead. Click “OK”.

10.5.2 Changing Stroke Folder 
Names
1. In the Strokes palette, go to the stroke folder

whose name you want to change.
2. Choose the Rename Folder button  in the

Folder Operations popup button . This
opens a “Rename Stroke Category” dialog.

3. Enter the name you want, and click “OK”.

10.5.3 Refreshing Stroke Folders
Choose the Refresh Folder button  in the Folder
Operations popup button  to refresh the current
stroke folder.

10.6 Setting Quick Strokes
By assigning a skeletal stroke to one of the quick
stroke slots, you can quickly apply the stroke to the
selected paths by pressing the corresponding
numeric key. These quickly accessible strokes are
called quick strokes, and you can set up to nine of
them.

1. Choose the stroke you want in the Strokes pal-
ette, or select an object that uses the stroke.

2. Choose Stroke > Set As Quick Stroke. This
opens a “Set as Quick Stroke” dialog.

3. Choose the number (0 to 9) you want to assign
to the stroke. If the number has already taken by
another stroke, you can overwrite the assign-
ment, or choose another number. Click “OK”.
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Chapter 11: Selecting and Managing Graphics 
Objects

Objects have to be selected before they can be iden-
tified as targets for any command or operation.
Selected objects can be identified by their highlight,
which is drawn in a color specific to the layer they
reside in. Selected objects are usually also sur-
rounded by eight resize handles, which are placed
around the selection. These handles can be used for
scaling, rotating and shearing of the selected
objects. See Chapter 12 for a more complete discus-
sion on various ways to transform objects.

11.1 Selecting Objects
Objects can be selected by using one of the selec-
tion tools: the Object Select tool, the Group Select
tool, the Node tool and the Node Lasso tool. The
Transform Fill tool is also a selection tool, except
that it is designed mainly to select one path object
for transforming its fill pattern or gradient.
Although the Node tool and the Node Lasso tool are
mainly for selecting nodes on path objects, they can
also be used for selecting objects as a whole, by
clicking or by dragging out a marquee over the
body of an object.

When you are using a drawing tool, transformation
tool or a miscellaneous tool, you may often need to
select a new set of objects or nodes. Instead of
going to the Toolbox palette to switch to a selection

tool, make a selection and then go back to the pre-
vious tool, you can actually use the  key with
most tools to temporarily switch to one of the cur-
rent node tool or selection tool.

The Object Select tool and the Group Select tool let
you select objects as a whole by clicking the objects
or by dragging out a marquee over them. The oper-
ations of the two tools are basically the same,
except that with the Object Select tool, all objects in
a group will be automatically selected whenever
one group member is selected. The groups here
refer to object groups and clipper groups. You can
also select objects at the Object List palette, as is
described in Section 11.7.

Usually, paths are selected automatically after they
are created, but you can disable this behavior by
turning off the “Highlight new paths” option in the
“Preferences” dialog (see Section 18.3.1).

Some objects cannot be selected, and these include
locked objects, objects in locked or hidden layers,
and object guides.

Besides using a tool to make a selection, you can
also use the command Edit > Select All to select all
selectable objects.

11.1.1 Selecting Objects Using 
the Object Selection Tools
1. Choose the Object Select tool  or Group

Select tool .
2. Choose from these options:
• Selecting objects by clicking them one

by one: Click the object body or its path to
select it. To add objects to a selection, hold the

 key and click them one by one. To
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remove objects from a selection, +click
the selected objects.

• Selecting objects by dragging out a
marquee: Drag out a box to enclose or cut
across the objects you want to select. To add
objects to a selection, +drag to enclose or
cut across more objects. To remove objects
from a selection, +drag out a shape to
enclose them.

• Selecting objects underneath other
objects: With the modifier keys +
both held, the selection tools enter a select
below mode, and the pointer becomes . In this
mode, preference for selection will be given to
objects below the current selection, when you
click to make a selection. If there is no selection
yet, the tool just functions normally. In this
mode, you can click a selected object to toggle
selection from the currently selected object to
the object which also occupies the place that
you click and which is the next such object
down the object list (i.e., the next such object
behind the originally selected object). If there
are more objects overlapping at the same place,
subsequent clicks will toggle the selection
through all these objects.

• Adding other group members to the
selection (Group Select tool only): Click
a selected object to add all other members of the
group to the selection. If the group itself is a
member of another group, clicking it again will
select other members of that upper-level group
as well.

• Deselecting objects: Click an empty space
in the view area to deselect all objects.

+click to deselect one particular object
from the current selection.

11.1.2 Selecting Objects Using 
the Freehand Pen Tool
1. Choose the Freehand Pen tool .

2. Click an object to select it. To deselect all
objects, click an empty space in the view area.

11.1.3 Selecting Paths 
According to Attributes
1. Select a path.
2. Choose Edit > Select By. This opens a “Select

By” dialog.
3. Choose from these options:
• Selecting paths with the same stroke:

Choose the “Same Stroke Name” option and
click “OK” to select all paths that use the same
gradient stroke or skeletal stroke.

• Selecting paths with the same stroke
color: Choose the “Same Stroke Color” option
and click “OK” to select all paths that use the
same stroke color (for basic strokes), stroke
gradient (for gradient strokes), or foreground
color (for skeletal strokes).

• Selecting paths with the same fill: Choose
the “Same Fill” option and click “OK” to select
all paths that use the same fill color, gradient,
pattern or image as the selected path.

11.1.4 Selecting Objects Using 
Menu Commands
• Selecting all objects: Choose Edit > Select

All to select all objects in the view area. Alter-
natively, use the keyboard shortcut +A.
Locked objects, objects in locked layers, and
guides cannot be selected.

• Deselecting all objects: Choose Edit >
Deselect All. Alternatively, use the keyboard
shortcut + +A.

• Reversing the selection: Choose Edit >
Invert Selection. Only the previously dese-
lected objects will become selected.
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11.1.5 Disabling the Highlights
Sometimes when you are manipulating a large
number of objects, the highlighted nodes and paths
can become rather distracting or even block the
appearance of the objects themselves.

You can turn off the “Show selected object nodes”
option in the “View and Display” page of the “Pref-
erences” dialog to disable the drawing of the high-
lighted nodes of selected paths (Section 18.4.4).
This option does not affect the editability of the
nodes. If you select some nodes in certain path
objects, those selected nodes will be highlighted for
node level manipulation.

There are times when you want to turn off all high-
lights altogether to give an unobstructed view of
your selected objects for attribute modifications.
You can use the “View > Turn Off Highlights Tem-
porarily” command to hide all highlights and yet
retain the current selection. The highlights will
remain hidden even if you pan the view, zoom in

and out, modify the objects’ attributes or issue com-
mands at them. Highlights will be resumed when
you click in the view area.

11.2 Managing Graphics 
Objects
A complex drawing can easily contain hundreds of
graphics objects. To manage them efficiently, you
can organize a drawing hierarchically into layers
and object groups. You can also change the
front-to-back order of objects.

The following sections describe the various ways to
adjust the composition of a picture, graphically or
structurally, using the many object arrangement
commands, tools and the convenient Object List
palette.

11.3 Moving, Copying and 
Editing Objects
Objects can be moved around in the view area using
the object selection tools, through the clipboard, or
using the arrow keys. You can also translate objects
using the Transformation palette (see Section 12.2).
To bring objects forward or backward, or to move
objects between layers, see Section 11.5.



106 Expression 3 Manual
11.3.1 Moving Objects Using the 
Object Selection Tools
The object selection tools let you move objects
around the view area quickly. If the “Quick (area)
select” option in the “Preferences” dialog is turned
on, you can select and move objects in one dragging
action (see Section 18.2.1).

1. Select the objects.
2. Choose the Object Select tool  or Group

Select tool .
3. Choose from these options:
• Moving objects: Drag one of the objects or

their paths to move all of them. As a guide, use
the rubber object outlines, or refer to the dis-
placements in the status bar (bottom left of the
document window). The movement can be con-
strained to the vertical, horizontal or diagonal
direction by holding down the  key.

• Moving a duplicate of the objects: Hold
 (the pointer becomes ) and drag one of

the objects to make a duplicate of the selection.

11.3.2 Moving and Copying 
Objects Using the Clipboard
The clipboard is useful for moving and copying
objects between different files that are opened in
Expression, or between Expression and another text
or graphics application.

1. Select the objects.
2. Choose from these options:
• Copying objects to the clipboard:

Choose Edit > Cut to move the objects to the
clipboard. To copy the objects instead, choose
Edit > Copy.

• Pasting objects at the center of the
view area: Choose Edit > Paste to paste
objects in the current center of the view area
and as the topmost objects in the current layer.

• Pasting objects at the same position in
the view area: If you want to paste objects at
the same position in the view area as the origi-
nal objects, but place them one step in front or
behind a certain object, select this object and
choose Edit > Paste In Front, or Edit > Paste In
Back, as needed. If you do not select any object
before using these commands, the clipboard
contents will be pasted as the topmost objects in
the current layer.

• Pasting objects with layers intact:
Choose Edit > Paste with Layer to paste objects
and their respective layers. If the current file
already has layers with the same names, objects
will be pasted into these layers accordingly.

11.3.3 Moving Objects Using the 
Keyboard
You can move objects by nudging them, one step or
half a step at a time. The size of a step, called nudge
increment, can be changed (see Section 18.2.2).

1. Select the objects.
2. Press the arrow keys repeatedly to move the

objects one step at a time, in the direction you
want. Alternatively, hold the  key while
you press an arrow key to move half a step at a
time.

Moving an object by dragging it with an object 
selection tool.
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11.3.4 Editing Objects Using 
Menu Commands
• Duplicating objects: Choose Edit > Dupli-

cate to duplicate objects with the cumulated
result of the previous transformations in the
session. You can also duplicate objects while
you are moving or transforming them.

• Deleting objects: Press the Delete/Back-
space key, or choose Edit > Clear.

11.4 Using Snapping
Snapping can be enabled for the grid, for nodes on
paths, or for paths that have been converted to
guides. This is useful for aligning and positioning
objects in the view area.for nodes on paths, or for
paths that have been converted to guides. This is
useful for aligning and positioning objects in the
view area.

When snapping is enabled, the snappable feature
(the grid, the nodes, or the object guides) will
attract nearby path elements (such as nodes on Bez-
ier curves, starting and ending nodes on B-spline
curves, and bounding box corners of paths), while
the paths or nodes are being dragged across the
view area.

While paths or nodes of paths are being dragged,
different marks will appear to show the type and
position of the snapping being carried out. Where a
moving node is snapped to a grid corner, another
node or a guide, an “×” is displayed; where it is
snapped to a vertical grid line, a  is displayed.
When snapped to a horizontal grid line, a  will

be shown. As for bounding box corners, snapping at
grid lines are shown with angle icons (  and ).

Snapping is also effective when you create paths
using the drawing tools, with the exception of the
Freehand Pen tool. As you move the pointer to
place a node, or drag out a regular shape (rectan-
gles, ellipses or straight lines), the pointer will be
snapped to a nearby snapping feature.

11.4.1 Using Grid Snapping
When grid snapping is enabled, the grid will be
automatically shown, and all grid lines and corners
will become snappable. More options for the grid
can be set in the “Preferences” dialog (see Section
18.4.1).

• Enabling grid snapping: Use View > Snap
> To Grid to turn the feature on and off.

11.4.2 Using Node Snapping
By enabling node snapping, all nodes on paths that
are not hidden will become snappable.

• Enabling node snapping: Use View >
Snap > To Nodes to turn the feature on and off.

11.4.3 Using Guides
Once a path has been converted to a guide, the
entire length along the path will become snappable.
Guides themselves are shown without stroke or fill
attributes (these attributes will reappear with the
release of the guide), and can only be selected from
the Object List palette (see Section 11.7.2).
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• Converting paths to guides: Select the
paths, and choose Objects > Guide > Make.

• Reverting guides to the original paths:
Choose Objects > Guide > Release to release all
guides. To release only some of the guides,
select them in the Object List palette and then
choose the command.

Guide snapping can be turned on or off from the
“Preferences” dialog. If guide snapping is enabled,
they will be displayed as thin blue lines. Otherwise
they are displayed as thin black lines.

11.5 Changing Object 
Order
Object order refers to the front-to-back (or overlap-
ping) order of objects in the view area. When
objects are created or imported into Expression,
they are put at the top of the current layer.

You can use menu commands or the Object List
palette to bring objects forward or backward within
their layers. If you want to move objects from layer
to layer, use the Layer mini-list or Object List pal-
ette instead, as is described in Section 11.6.6.

11.5.1 Changing Object Order 
Using Menu Commands
The menu commands are useful for changing object
order within a layer.

1. Select the object.
2. Choose from these options:
• Moving objects to the front: Choose

Arrange > To Front to make the object the top-
most object in the layer.

• Moving objects to the back: Choose
Arrange > To Back to make the object the bot-
tommost object in the layer.

• Moving objects one step in front: Choose
Arrange > Up One to move the object one step
above in the layer.

• Moving objects one step back: Choose
Arrange > Down One to move the object one
step below in the layer.

11.6 Managing Layers
Layers in a document are like a stack of paper fold-
ers in a file cabinet. Objects can be put into differ-
ent layers for easy handling. The top-to-bottom
order in the layer list corresponds to the
front-to-back order in the view area.

Layers have individual names, can be locked or
hidden from view, and can be found in the Layer
mini-list or the Object List palette.

11.6.1 About the Layer Mini-List
The Layer mini-list is a “layer only” version of the
Object List palette, and is attached to every docu-
ment window at the right side.

• Showing the Layer mini-list: Turn on or off
View > Show > Layer Mini-List as needed.

• Viewing the layer names: Place the
pointer within the list area to view the layer
names. The layer names will disappear when
you move the pointer away.

The Layer mini-list.
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• Scrolling the layer list: Use the Scroll Up 
and Scroll Down  buttons to scroll the list of
layers.

11.6.2 Adding and Editing 
Layers
New files are created with one layer, called “Layer
1”. Subsequently added layers are named “Layer
2”, “Layer 3”, and so on, but these names can be
changed as layers are being added or at any time
afterwards.

• Adding layers: Click the New Layer button
 in the Layer mini-list or Object List palette.

To add a layer and rename it at once, hold 
and click instead. In the “New Layer” dialog,
enter the name you want, and click “OK”. See
also Section 18.2.1 about the options to add lay-
ers above the current layer, and to open the
“New Layer” dialog automatically when creat-
ing a new layer.

• Selecting layers: Click a layer’s Color icon
(color square) in the Layer mini-list (or its
name in the Object List palette) to make it the
current layer.

• Deleting layers: Go to the layer, and click the
Delete Layer button  in the Layer mini-list or
Object List palette.

11.6.3 Changing Layer Settings
You can change a layer’s name, color (for high-
lighting selected objects), display quality, lock
state, visibility state and freeze state in the “Layer
Settings” dialog.

1. Double-click the layer’s Color icon (color
square). Alternatively, go to the layer, and click
the Layer Settings button  in the Layer
mini-list or the Properties button  in the

Object List palette. This opens a “Layer Set-
tings” dialog.

2. Choose from these options:
• Changing layer names: Enter the name

you want in the “Name” box.
• Changing layer colors: Drag the RGB slid-

ers in the Layer Color section to change the
layer color’s RGB values. The resulting color is
shown in the Color Preview to the right.

• Changing layer display quality: Choose
the “Path”, “Wireframe” or “Preview” option to
set the display quality for objects in the current
layer, or choose “Default” to use the same set-
ting as the current document window.

• Locking and hiding layers: Turn on or off
the “Lock” and “Visible” options as needed,
and click “OK”. See also Section 11.6.4 below
for another way to lock and hide layers.

• Freezing layers: Turn on the “Frozen” option
if you want to freeze a layer, i.e., rasterize its
contents temporarily to a bitmap for viewing
but not editing. You can also choose the bitmap
resolution. Freezing layers that you are not cur-
rently working on can vastly reduce screen
redraw speeds for complex pictures. You can
also set an upper limit to the amount of memory
allowed for rasterizing each layer in the “Pref-
erences” dialog (Section 18.2.1). If your
machine has enough memory, you should
freeze any complex layer containing a lot of
textured objects as soon as you are not going to
edit them for a while. Note that, however,
blending mode effects, except the eraser mode,
would not be shown correctly in the frozen lay-
ers because those effects depend on the graph-
ics underneath the layer, and rasterizing one
particular layer could not taken into account
these cross-layer effects.
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3. Click “OK” to commit to the settings.

11.6.4 Locking and Hiding 
Layers
Locking a layer prevents objects within from being
selected, and hiding a layer hides the objects within.
You can lock or hide layers using the Layer
mini-list or Object List palette.

• Locking layers: In the Layer mini-list or
Object List palette, click a layer’s Lock icon to
toggle between  (layer unlocked) and 
(layer locked). Note that if the layer is empty,
the Lock icons look like  and  instead. (If
the layer itself is not locked but contains one or
more locked objects, the Lock icon looks like

.) To toggle the lock state of all layers except
the current one, hold  and click instead.

• Hiding layers: In the Layer mini-list or
Object List palette, click a layer’s Visibility
icon to toggle between  (layer shown) and

 (layer hidden). If the layer is empty, the Vis-
ibility icons look like  and  instead. To
toggle the visibility state of all layers except the
current one, hold  and click instead.

11.6.5 Changing Layer Order
The higher a layer’s position in the layer list, the
nearer the front its objects are; the lower a layer’s
position, the nearer the back its objects are.

• From the Layer mini-list: Drag a layer’s
Color icon (color square) up or down to move
its position in the layer list.

• From the Object List palette: Drag a
layer’s name instead.

11.6.6 Moving and Copying 
Objects across Layers
Objects in one layer can be moved or copied to
another layer quickly using the Layer mini-list or
Object List palette. However, if your selection con-
tains objects from different layers, or if you want to
copy objects as well as the layers they are in, use the
clipboard instead, as in Section 11.3.2.

1. Select the objects (they must all be in the same
layer). In the Layer mini-list and Object List
palette, a cube icon  appears in the layer to
indicate that the selection includes objects in
this layer.

2. Drag the cube icon to the layer you want to
move the object. To move a duplicate of the
objects, hold  and drag instead.

The “Layer Settings” dialog.

Moving a layer up the Layer mini-list.

Moving an object selection from one layer to 
another.
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11.7 Managing the Object 
List
The object list is a diagram showing the layer and
object order in a document, and is shown in the
Object List palette. The top-to-bottom object order
in the Object List palette corresponds to the
front-to-back order in the view area. Besides chang-
ing object order, the object list diagram also pro-
vides structural information about objects. The
object list can also be used to select overlapping
objects that are difficult to locate in the view area
by eye.

11.7.1 About the Object List 
Palette
In the Object List palette, each layer can be
expanded to show the object list within, and each
group can be likewise expanded to show the mem-
ber objects. Each object or group is identified by an
icon (indicating its type such as an ellipse or a clip-
per group), and a text description of its path struc-
ture or bitmap size.

• Viewing the object list: Click a layer’s or
group’s triangle icon  (so that it becomes )
to show the list of objects within. To retract a
layer’s or group’s object list, click the triangle
icon again. To retract all layers’ object lists,
click the Collapse All button .

Understanding the object type icons:

11.7.2 Selecting Objects Using 
the Object List Palette
You can select objects from the Object List palette.
For other selection methods, see Section 11.1.

• Selecting objects one by one: Click the
square icon to the left of an object or group to
select it. To add objects to or remove objects
from the selection, +click their square
icons one by one. Clicking a selected square
icon with the  key held deselects the
object, and vice versa.

• Selecting objects by dragging:
+drag the square icon of an object/group

up/down the list to add the object/group to the
object selection. To remove objects from the
selection, +drag their square icons again.

11.7.3 Changing Object Settings
1. Double-click the object/group’s type icon or

name. Or, select the object/group and click the
Properties button  in the Object List palette.

2. Change object settings as follows:
• Entering notes: Enter a text description of the

object/group in the “Note” box, to be shown in
the Object List palette for reference.

A Expand/Collapse 
switch

B Partially selected 
group

C Object type icon
D Selection indicator
E Object selection 

indicator
F Locking status indi-

cator

G Visibility status indica-
tor

H Active layer indica-
tor

I New layer
J Delete layer
K Locate object
L Zoom on
M Properties
N Collapse all

The Object List palette.

Path with no stroke/fill
Path with stroke only
Path with fill only
Path with stroke and fill
Ellipse
Text

Guide
Bitmap
Object group
Warp group
Clipper group
Effect line group
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• Changing arc mode (ellipses only):
Choose the “Open Arc”, “Pie Mode”, or “With
Chord” option as needed. For more details on
ellipses, see Section 7.12.

• Hiding and showing reference vectors:
Enable or disable the “Show Reference Vector”
option as needed, for objects that already have a
reference vector (Section 7.18.2).

• Locking and unlocking objects: Enable
or disable the “Locked” option as needed. Also
also Section 11.7.5.

11.7.4 Identifying and Locating 
Objects
Objects in the view area can be quickly located
using the zooming buttons in the Object List pal-
ette. Objects cannot be hidden individually, but hid-
ing a layer hides the objects within.

• Displaying thumbnail preview: In the
Object List palette, right-click (or Ctrl+click on
Macintosh) the object, group or layer to pop-up
a preview of the object, group or layer.

• Locating objects in the view area: In the
Object List palette, click the Locate Object but-
ton  to pan the view area so that the object
selection is shown in the center while the rest of
the view area is dimmed.

• Zooming into objects: In the Object List
palette, click the Zoom On button  to zoom
into the object selection in the view area.

• Flagging objects: In the Object List palette,
click the space at the left of the object you want
to flag, and a  icon will appear next to it. Flags
are for your own reference only, and have no
functional effect on objects.

11.7.5 Locking Objects
Locking an object prevents it from being selected.
Locking a group locks all objects within.

• Locking objects/groups: In the Object List
palette, click the space between the type icon
and name of the object/group so that a  icon
appears. Or, select the objects/groups and
right-click (or Ctrl+click for Mac) in the view
area to choose the “Lock Object” command.
Also see Section 18.4.5 on setting which cate-
gories to make available in the context menu.

• Unlocking objects/groups: In the Object
List palette, click the  icon of the locked
object/group to unlock it. Or, in the view area,
place the pointer over the locked object/group,
and right-click (or Ctrl+click for Mac) to
choose the “Unlock Object” command. If there
is more than one locked object overlapping at
the position where you clicked, using the com-
mand repeatedly will continue to unlock those
objects that are behind one by one.
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Chapter 12: Transformation and Precise Size and 
Position Control

In Expression, an object keeps record of a separate
piece of transformation information, which is inde-
pendent of the geometry of the base object. The
final rendered appearance of an object is the com-
bined result of the object geometry multiplied by
the attached transformation. The transformation
used in Expression is a general 2D homogeneous
transformation, which allows true perspective
transformation to be specified.

When an object is moved, scaled or rotated, an
additional transformation will be multiplied to the
transformation information stored in the object
while the internal geometry remains unchanged.
The accumulated transformation information can
be completely removed to return the object to its
“pure” geometrical form using the command
Arrange > Reset Transform. Another way to
remove the transformation is to multiply the trans-
formation into the geometry so that the new geom-
etry describes the transformed object without any
additional transformation. This is done by the com-
mand Arrange > Commit Transform.

This chapter describes the various tools and con-
trols for applying transformation to objects interac-
tively or numerically (by specifying precise
values).

12.1 Transforming Objects
When you drag selected objects around using one
of the selection tools, you are translating the
objects. Other methods to transform selected
objects include using the resize handles, the trans-
formation tools, the Transformation palette and the
transformation commands under the Arrange menu.

Transformations applied can be reset and re-applied
to other objects.

As you transform objects using the resize handles
or transformation tools, the transformation values
will be instantly updated in the status bar (and the
Transformation palette where appropriate) for your
reference.

When an object is transformed, the basic strokes or
the pattern fill applied to the objects may or may not
transform with the objects themselves. These are
controlled through the “Scale line weight” and
“Transform patterns” options in the “Preferences”
dialog (Section 18.2.1).

12.1.1 About the Resize Handles
When you select objects or select more than one
node, the resize handles will appear around the
selected objects or nodes. The resize handles pro-
vide a convenient way to transform objects without
the need to switch tools. They also indicate the
bounding box of the current selection. The resize
handles at the corners are for scaling, and those at
the sides are for rotating and shearing. Use the
“Show resize handles” option in the “Preferences”
dialog to turn on and off the display of the resize
handles (Section 18.4.4).

The resize handles.
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12.1.2 About the Transformation 
Tools
Expression provides six specialized transformation
tools to carry out the translation, scaling, rotation,
shearing, mirroring and perspective transformation.
The transformation tools are all grouped under a
popup button in the Toolbox palette. The more
often used Scale tool and Rotate tool can be conve-
niently accessed using the keyboard shortcuts

+S and +R.

Except for the perspective transformation, all trans-
formations are performed relative to a transforma-
tion origin, which is usually the midpoint of the
selection bounding box or the reference point, if a
reference vector has been defined. The transforma-
tion origin can also be explicitly specified with a
click using any one of the tools before carrying out
the transformation.

The Perspective tool computes the transformation
based on the deformation of a reference quadrilat-
eral frame and requires no transformation origin.

12.1.3 About the Transformation 
Palette
The Transformation palette lets you transform
objects by entering precise numerical values.

12.2 Translating Objects
Objects can be translated using the Transformation
palette, or by other methods, as are described in
Section 11.3.

12.2.1 Translating Objects Using 
the Transformation Palette
1. Select the objects.
2. Click the Translation button  in the Trans-

formation palette.
3. Entering translation values: Enter the x and

y displacements in the X Translation meter 
and the Y Translation meter . Displacement
values are positive when translating upwards
and to the right.

4. Applying translation: Click the Apply
Transformation button . To translate a
duplicate of the objects, click the Apply To A
Duplicate button  instead.

12.3 Scaling Objects
Objects can be scaled using the resize handles, the
Scale tool, or the Transformation palette.

12.3.1 Scaling Objects Using 
Resize Handles
1. Select the objects.
2. Drag a corner handle away from the objects to

scale them up; drag towards the objects to scale
them down. To scale proportionally or to scale
in one of the horizontal or vertical directions,

A Translation
B Rotation
C Scaling
D Shearing
E Mirroring

F Bounds
G Size
H Apply to a duplicate
I Apply transformation

The Transformation palette.
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+drag instead. To scale a duplicate of the
objects, hold  and drag instead.

12.3.2 Scaling Objects Using the 
Scale Tool
1. Select the objects.
2. Choose the Scale tool . The pointer becomes

.
3. Setting scaling centers: Click where you

want the scaling center to be. The default scal-
ing center is the center of the selection.

4. Applying scaling: Drag the objects away
from the center to scale them up; drag towards
the center to scale them down. To scale propor-
tionally, +drag instead. To scale a dupli-
cate of the objects, hold  and drag
instead.

12.3.3 Scaling Objects Using the 
Transformation Palette
1. Select the objects.
2. Click the Scaling button  in the Transforma-

tion palette.
3. Setting scaling center: Enter the x and y

coordinates in the Scaling Center X meter 
and the Scaling Center Y meter . You could
also automatically set the scaling center to one
of the bounding box corners or bounding box
center using the five buttons (see picture below)
in the Size page of the Transformation palette.

4. Setting scaling factors: Enter the x and y
scaling factors (in percentage) in the Horizontal
Scale meter and the Vertical Scale meter.

5. Applying scaling: Click the Apply Transfor-
mation button . To scale a duplicate of the
objects, click the Apply To A Duplicate button

 instead.

12.4 Rotating Objects
Objects can be rotated using the resize handles, the
Rotate tool, or the Transformation palette.

12.4.1 Rotating Objects Using 
Resize Handles
1. Select the objects.
2. Place the pointer at a side handle (the pointer

becomes ), and drag it to rotate the objects.

Scaling an object by dragging a corner handle.

Scaling an object with the Scale tool.
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To rotate a duplicate of the objects, hold 
and drag instead.

12.4.2 Rotating Objects Using 
the Rotate Tool
1. Select the objects.
2. Choose the Rotate tool . The pointer

becomes .
3. Setting rotation center: Click where you

want the center to be. The default rotation cen-
ter is the center of the selection.

4. Applying rotation: Drag the objects to rotate
them. To rotate to a constrained angle (see Sec-
tion 18.2.2), +drag instead. To rotate a
duplicate of the objects, hold  and drag
instead.

12.4.3 Rotating Objects Using 
the Transformation Palette
1. Select the objects.

2. Click the  button in the Transformation pal-
ette.

3. Setting rotation center: Enter the x and y
coordinates of the rotation center in the Rota-
tion Center X meter  and the Rotation Cen-
ter Y meter . You could also automatically
set the rotation center to one of the bounding
box corners or bounding box center using the
five buttons in the Size page of the Transforma-
tion palette.

4. Setting rotation angle: Enter the rotation
angle (in degrees) in the Rotation Angle meter

.
5. Applying rotation: Click the Apply Trans-

formation button . To rotate a duplicate of
the objects, click the Apply To A Duplicate but-
ton  instead.

12.5 Shearing Objects
Objects can be sheared along a plane (or axis) using
the resize handles, the Shear tool, or the Transfor-
mation palette.

12.5.1 Shearing Objects Using 
Resize Handles
1. Select the objects.
2. Place the pointer at a side handle, hold the

 key (the pointer becomes  or ), and
drag it to shear the objects.

Rotating an object by dragging a side handle.

Rotating an object with the Rotate tool.
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12.5.2 Shearing Objects Using 
the Shear Tool
1. Select the objects.
2. Choose the Shear tool . The pointer becomes

.
3. Setting shear center: Click where you want

the center to be. The default shear center is the
center of the selection.

4. Applying shear: Drag the objects to shear
them. To shear a duplicate of the objects, hold

 and drag instead.

12.5.3 Shearing Objects Using 
the Transformation Palette
1. Select the objects.
2. Click the Shearing button  in the Transfor-

mation palette.
3. Setting shear center: Enter the x and y

coordinates of the shear center you want in the
Shear Center X meter  and the Shear Center
Y meter . You could also automatically set
the shear center to one of the bounding box cor-
ners or bounding box center using the five but-
tons in the Size page of the Transformation
palette.

4. Setting shear angle and plane: Enter the
shear angles (in degrees) in the Shear Angle
meter , and the shear plane (in degrees) in
the Shear Plane Angle meter .

5. Applying shear: Click the Apply Transfor-
mation button . To shear a duplicate of the
objects, click the Apply To A Duplicate button

 instead.

12.6 Mirroring Objects
You can make a mirror reflection of objects by
reflecting them along a plane (or axis), using the
Mirror tool or the Transformation palette.

12.6.1 Mirroring Objects Using 
the Mirror Tool
1. Select the objects.
2. Choose the Mirror tool . The pointer

becomes .
3. Setting mirror center: Click where you want

the center to be. The default mirror center is the
center of the selection.

4. Applying mirroring: Drag the objects to mir-
ror them. To mirror to a constrained angle (see
Section 18.2.2), +drag instead. To mirror
a duplicate of the objects, hold  and drag
instead.

12.6.2 Mirroring Objects Using 
the Transformation Palette
1. Select the objects.
2. Click the Mirroring button  in the Transfor-

mation palette.
3. Setting mirror center: Enter the x and y

coordinates of the mirror center that you want
in the Mirror Center X meter  and the Mirror
Center Y meter . You could also automati-
cally set the mirror center to one of the bound-
ing box corners or bounding box center using
the five buttons in the Size page of the Trans-
formation palette.

4. Setting mirror plane: Enter the mirror plane
(in degrees) in the Mirror Plane Angle meter

.
5. Applying mirroring: Click the Apply Trans-

formation button . To apply mirroring to a
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duplicate of the objects, click the Apply To A
Duplicate button  instead.

12.7 Setting Object Size 
and Bounds
You can move and scale objects by specifying the
absolute positions of the objects’ top, bottom, left
and right edges, also referred to as the objects’
bounds. The positions of the four bounds can be
specified individually. However, if you want to
move the objects without scaling them (vertically,
horizontally, or in both directions), you do not need
to specify the positions of all four bounds. Instead,
you can link the top and bottom bounds to fix the
distance between them. By doing so, any position
changes made to either the top or bottom bound will
cause the position of the other bound to be automat-
ically updated. Similarly, by linking the left and
right bounds, you can preserve the horizontal size
of the objects.

1. Select the objects.
2. Click the Bounds button  in the Transforma-

tion palette.
3. Keeping horizontal or vertical size

unchanged: If you want to shift or scale the
objects without changing the horizontal size of
the objects, turn on the Horizontal Bounds
Linked button  so that it becomes . Similarly,
to keep the vertical size unchanged, turn on the
Vertical Bounds Linked button.

4. Specifying object bounds: Enter the posi-
tions of the object bounds you want in the Left
Edge meter , Right Edge meter , Top Edge
meter  and Bottom Edge meter .

5. Applying transformation: Click the Apply
Transformation button .

12.7.1 Setting Object Size
Using the Size page of the Transformation palette,
you can specify the dimensions and position of
objects with reference to the center or a corner of
the objects.

1. Select the objects.
2. Click the Size button  in the Transformation

palette.
3. Specifying a reference for scaling: The

buttons at the top left of the palette are for
choosing the reference point for the size
changes. The middle button represents the cen-
ter of the current selection, and the other four
buttons represents the top-left , top-right

, bottom-left  and bottom-right  cor-
ners of the bounding box of the selection
respectively. Click one of the buttons to choose
the reference point.

4. Specifying object dimensions: Enter the
object dimensions to which you want to scale
the objects in the Horizontal Size meter  and
Vertical Size meter .

5. Applying transformation: Click the Apply
Transformation button .

Note that the size and bounds adjustments are
equally applicable to selected objects as a whole
and to individual selected nodes. If individual
nodes are selected, only the positions of the
selected nodes will be translated or scaled.

The interpretation of the size and bounds of a selec-
tion can be changed using the “Size/Bounds use
path bounding box” option in the “Preferences”
dialog (Section 18.2.1). The option determines
whether only the paths (i.e., taking no account of
whether the strokes are thin or thick, and whether
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the fill has a soft-edge) of the selected objects are
used in the measurement of the bounding box.

12.8 Applying Perspective 
Transformation
Perspective transformation is applied through a
perspective frame, through the perspective nodes at
the four corners of the frame.

12.8.1 Applying Perspective 
Transformation
1. Select the objects.
2. Choose the Perspective tool . The pointer

becomes .
3. Adjusting the perspective frame: Drag

the perspective nodes one by one until the
frame is the right size and shape.

4. Enabling the perspective frame: Click
the objects to enable to perspective frame. If
you want to disable it later to edit the frame
again, click the objects again.

5. Applying perspective transformation:
Drag the perspective nodes one by one to trans-
form the objects.

12.9 Working with Previous 
Transformations
The Transformation palette records the previous set
of values for each type of transformation, so that
you can apply a transformation to other objects.

You can also use menu commands to apply the pre-
vious transformation used in the session, or apply
the cumulative transformation of the session, which
is the cumulative result of all the previous transfor-
mations in the session.

• Applying the previous translation, scal-
ing, rotation, shear or mirroring: Select
the object, and click the Apply Transformation
button  in the appropriate transformation
setting area in the Transformation palette.

• Applying the previous transformation in
the session: Select the object, and choose
Arrange > Repeat Last Transform.

• Applying the cumulative transforma-
tion of the session: Select the object, and
choose Arrange > Repeat Accumulated Trans-
form.

Object bounding box (left) and path bounding 
box (right).

The original object (left), and after applying per-
spective transformation (right).



120 Expression 3 Manual
12.9.1 Resetting and 
Committing to an Object’s Own 
Transformations
Graphics objects in Expression carry a transforma-
tion independent of its geometry. The transforma-
tion stores the cumulative effect of all
transformations previously applied to an object.
Such a transformation can be removed by either the
Arrange > Reset Transform command or the
Arrange > Commit Transform command.

The “Reset Transform” command simply removes
the transformation from an object. The object will
be reverted to its pure geometrical state, i.e., the
state before any transformation was applied to it.

The “Commit Transform” command will multiply
the transformation to an object, modifying its base
geometry before removing the transformation
information. Therefore an object should look more
or less unchanged after applying the “Commit
Transform” command.

If the transformation stored in an object has
non-uniform scaling or has been sheared, the
appearance of the strokes on the object will proba-
bly change a bit. This is because the appearance of a
stroke on a path is arrived at by first applying the
stroke and then transforming the “stroked” object.
If you commit to the transformation, however, the

stroke will be applied to the transformed path
instead. Although the stroke width will be scaled on
committing to a transformation to make it resemble
the original appearance, in the case of a non-uni-
formly scaled or skewed transformation, it will sim-
ply be impossible for an untransformed stroke to
have an identical appearance as before.

• Resetting an object’s cumulative trans-
formation: Select the object, and choose
Arrange > Reset Transform.

• Committing to an object’s cumulative
transformation: Select the object, and choose
Arrange > Commit Transform.

You could also turn on the “Auto commit trans-
forms” option in the “Preferences” dialog (Section
18.2.1) to tell Expression 3 to perform all transfor-
mation operations directly to the path nodes. This
would make the width meters faithfully display the
actual widths, but would sacrifice the capability of
non-uniformly transforming stroke widths.

12.10 Aligning, Distributing 
and Stacking Objects
The alignment commands align objects’ edges or
centers. The distribution commands move objects
in the middle so that they become evenly spaced.
The stacking commands move objects in one direc-
tion so that they become separated by a uniform
gap, whose size can be specified in the
“Preferences” dialog (“Stack gap size” in Section
18.2.2).

12.10.1 Using the Alignment 
Commands
1. Select the objects (at least two).
2. Choose from these options in the Arrange

menu:

A Original object.
B Transformed object. Notice that the stroke has 

been non-uniformly transformed; part of it is 
wider and part of it is thinner.

C Committing to the transformation in B.
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• Aligning top edges: Choose Align > Top to
align all top edges (or corners) to that of the
topmost object.

• Aligning bottom edges: Choose Align >
Bottom to align all bottom edges (or corners) to
that of the bottommost object.

• Aligning left edges: Choose Align > Left to
align all left edges (or corners) to that of the
leftmost object.

• Aligning right edges: Choose Align > Right
to align all right edges (or corners) to that of the
rightmost object.

• Aligning vertical centers: Choose Align >
V. Center to align all vertical centers (horizontal
axes) to the selection’s original vertical center
(horizontal axis).

• Aligning horizontal centers: Choose Align
> H. Center to align all horizontal centers (ver-
tical axes) to the selection’s original horizontal
center (vertical axis).

12.10.2 Using the Distribution 
Commands
1. Select the objects (at least three).
2. Choose from these options in the Arrange

menu:
• Distributing top edges: Choose Distribute >

Top to move objects that are between the top-
most and bottommost objects so that all top
edges are evenly spaced in the vertical direc-
tion.

• Distributing bottom edges: Choose Dis-
tribute > Bottom to move objects that are
between the topmost and bottommost objects so
that all bottom edges are evenly spaced in the
vertical direction.

• Distributing left edges: Choose Distribute >
Left to move objects that are between the left-

most and rightmost objects so that all left edges
are evenly spaced in the horizontal direction.

• Distributing right edges: Choose Distribute
> Right to move objects that are between the
leftmost and rightmost objects so that all right
edges are evenly spaced in the horizontal direc-
tion.

• Distributing vertical centers: Choose Dis-
tribute > V. Center to move objects that are
between the topmost and bottommost objects so
that all vertical centers are evenly spaced in the
vertical direction.

• Distributing horizontal centers: Choose
Distribute > H. Center to move objects that are
between the leftmost and rightmost objects so
that all horizontal centers are evenly spaced in
the horizontal direction.

12.10.3 Using the Stacking 
Commands
1. Select the objects (at least two).
2. Choose from these options in the Arrange

menu:
• Stacking upwards: Choose Stack > Up to

move objects that are above the bottommost
object so that all objects are the same distance
apart in the vertical direction.

• Stacking downwards: Choose Stack >
Down to move objects that are below the top-
most object so that all objects are the same dis-
tance apart in the vertical direction.

• Stacking to the left: Choose Stack > Left to
move objects that are to the left of the rightmost
object so that all objects are the same distance
apart in the horizontal direction.

• Stacking to the right: Choose Stack > Right
to move objects that are to the right of the left-
most object so that all objects are the same dis-
tance apart in the horizontal direction.
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Chapter 13: Creating Effect Lines

Speed lines and other effect lines are at the very
heart of action comics and Manga (Japanese com-
ics); they are indispensable conveyers of action and
emotion, whether the message to get across is one
of speed, strength, urgency, shock, romance,
embarrassment, absurdity or otherwise.

With minimal instructions, Expression can generate
a set of effect lines or curves, which can then be
enriched (with skeletal strokes) and varied (in line
spacing, length and arrangement) to achieve the
boldest or subtlest effects.

In fact, the effect line function in Expression has
more general uses than as a tool for speed lines and
comics effects. By applying different stylish strokes
and semi-transparent fill, dazzling interference pat-
terns and effects can be created. The most creative
uses of this powerful function are left for you to
explore.

13.1 Generating Effect Lines
An effect line group can be generated across any
two arbitrary open or closed paths, referred to as the
start edge and the end edge. Individual effect lines
extend from the start edge to the end edge, forming
a set of diverging, converging, parallel or intersect-
ing lines, depending on the relative lengths and

shapes of the start and end edges. If you provide
only a start edge, Expression will create a clone as
the end edge.

1. Specifying start and end edges: Draw
and select the paths to be used as the start edge
and end edge. (If you like, you can use only the
start edge, and let Expression create a clone as
the end edge.)

2. Generating effect lines: Click the Create
Effect Lines button  in the Effect Lines pal-
ette, or choose Objects > Effect Lines > Create.
A default set of straight effect lines will be gen-
erated across the start and end edges.

13.2 About Effect Line 
Groups
An Effect Line Group is a special kind of group
containing two path objects: the start edge path and
the end edge path. The generated effect lines are
dynamic objects, and so cannot be edited directly
using path or node editing tools. Unlike other kinds
of groups, which are abstract structures without a
tangible body, an effect line group does have a tan-
gible body — the set of generated effect lines.

Because the start and end edges are grouped
together as part of an effect line group, selecting
one edge using the Object Select tool  will result
in the entire group being selected. If you want to
edit or transform one specific edge, you need to
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select it using the Group Select tool , the Node
tool  or the Node Lasso tool .

As for the generated effect lines, because they are
the tangible body of the effect line group, any
attempt to select one or more effect lines will result
in the entire effect line group being selected, includ-
ing the start and end edges.

• Editing the Start and End Edges: Select
the start or end edge using the Node tool ,
Node Lasso tool  or Group Select tool . If
one of the edges is a clone (i.e., the effect line
group is created from only one path), you can
select and edit the nodes of the master path.

• Transforming the Start and End Edges:
Select the edge using the Group Select tool ,
and transform it using the resize handles or one
of the transformation tools (Chapter 12). Make
sure that the generated effect lines are not
selected to avoid transforming the entire group.

13.3 Applying Strokes to 
Effect Lines
You can apply any kind of stroke (skeletal, gradient
or basic stroke) to the effect lines, and apply the rel-
evant stroke attributes.

1. Select the effect lines.
2. Applying strokes and attributes: Apply

strokes and stroke attributes as you would for
ordinary strokes.

3. Changing the direction of the gener-
ated effect lines: To reverse the direction of
the strokes that are applied to the generated
effect lines, click the Reverse Line Direction

button  in the Effect Lines palette. Note that
the number of generated effect lines may
change, because the spacing of the generated
effect lines is based on the base points on the
start edge. Reversing the direction of the effect
lines actually causes a swap of roles between
the start and end edges and hence also the inter-
pretation of the spacing value. For more infor-
mation about setting line spacing, refer to the
next section.

13.4 Setting Effect Line 
Variations
Newly generated effect lines are evenly-spaced
straight lines of the same width. Their appearance
can be modified through various parameters, such
as line spacing and width. They can also be
arranged in clusters (e.g., of three effect lines each),
and directed towards an editable focus point.

Another attribute that you can vary is the position
of the starting and ending points of the effect lines.
Newly generated effect lines all begin from the start
edge, extending all the way to the end edge, so that
the contour formed by all the effect line starting
points resembles the shape of the start edge. The sit-
uation is similar at the end edge. By specifying a
randomness value for the positions of starting or
ending points, you can easily create effect lines
with a hand-drawn quality to them.

In fact, for maximum flexibility, most parameter
controls are accompanied by their own variation
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sliders for varying the parameter settings among
effect lines.

1. Select the entire effect line group, either by
clicking the effect lines or by selecting with the
Object Select tool .

2. Adjust the effect line parameters and options
according to your needs, as follows:

• Setting line spacing: Use the Line Spacing
meter  in the Effect Lines palette to change
the spacing between adjacent effect lines. The
spacing value is the distance between adjacent
effect lines at the start edge. If the end edge is
shorter than the start edge, the effect lines will
actually be more densely spaced at the end edge
than is indicated by the spacing value. Like-
wise, if the end edge is longer than the start
edge, the lines at the end edge will be more
sparsely spaced than indicated. You can also
use the Variation slider  at the right to intro-
duce randomness to the spacing.

• Setting stroke width: Use the Stroke Width
meter  in the Effect Lines palette to change
the stroke width of the effect lines. Use the
Variation slider  at the right to introduce ran-
domness to the width of the effect lines.

• Forming clusters: Sometimes it is useful to
draw the effect lines in groups for certain com-
ics/manga styles. Click the Clustering On/Off
button  to turn on clustering, and set the clus-

ter size and spacing using the Cluster Size
meter  and the Gap Size meter . The clus-
ter size is the number of effect lines to be
grouped together as a cluster. Gap size is the
number of effect lines to be omitted between
adjacent clusters. Use the Cluster Variation
slider  to the right to add random variations to
both cluster size and gap size. Note that this
variation does not affect the spacing of individ-
ual effect lines within a cluster.

• Using a focus point: Click the Focus to a
Point On/Off button . The generated effect
lines from the start edge will all point towards a
focus point, but will become invisible beyond
the end edge. If the focus point is positioned
such that certain effect lines cannot reach the
end edge before reaching the focus point, those
effect lines may extend all the way to the focus
point. If you want to change the position of the
focus point, drag it directly, using the Node tool

 or Node Lasso tool .

• Varying starting positions of effect lines:
The starting positions of the generated effect
lines from the start edge can be made uneven by
adding random variations. Drag the Start Edge
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Variation slider  to specify the amount of
randomness.

• Varying ending positions of effect lines:
The ending positions of the generated effect
lines near the end edge can be made uneven by
adding random variations. Drag the End Edge
Variation slider  to specify the amount of
randomness.

13.5 Using a Template Path
Newly generated effect lines are straight lines, but
they can take on any shapes that you choose; they
can be curves, polylines or any open paths. By
attaching a path of your choice, referred to as a tem-
plate path, to the set of effect lines, all effect lines
will take on the shape of the template path.

When you select an effect line group to which a
template path has been attached, the attached tem-
plate path will be shown across the start and end
edges of the effect lines. You can continue to make
changes to the shapes of the effect lines by editing
the attached template path, using the Node tool or
the Node Lasso tool.

13.5.1 Attaching Template Paths
1. Select the effect lines and the open path to be

used as the template path.
2. Click the Add Template Path button  in the

Effect Lines palette, or choose Objects > Effect
Lines > Add Template Path.

13.5.2 Editing the Shapes of 
Template Paths
Because the attached template path is not an ordi-
nary path but part of the effect line group, some
path modification tools and commands cannot be
directly used on it. If you need to replace an
attached template path with another one, first
remove the existing template path and then attach
the new path to the effect line group.

1. Select the entire effect line group by clicking or
dragging a marquee around the effect lines
using a selection tool.

2. Use the Node tool  or Node Lasso tool  to
drag the attached template path.

13.5.3 Removing Template 
Paths
1. Select the effect line group from which you

want to remove the template path.
2. Click the Remove Template Path button  in

the Effect Lines palette or choose Objects >
Effect Lines > Remove Template Path to revert
to using straight lines as effect lines.
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Chapter 14: Using Bitmap Images

Bitmaps are images in grids of pixels with fixed
resolution, and can be imported (see Section 5.11)
or created from scratch. Expression supports bit-
maps with transparency and you can define bitmap
strokes from bitmaps. Photoshop and compatible
filters can also be applied to bitmaps.

Warping distorts a picture unevenly by squeezing
some parts together and pulling them apart at other
places. For more on warping, see Section 7.29.

14.1 Creating Bitmaps
Bitmaps with transparency can be created from
scratch, or created by rasterizing a part of the view.

1. Choose Objects > Bitmap > Create Bitmap. The
pointer becomes .

2. Drag diagonally in the view area, and release
the mouse button when you have the right size.
This opens a “New Bitmap” dialog.

3. Choose from these options:
• Creating bitmaps from scratch: Enable

“Transparent” or “Opaque White” as needed.
• Creating bitmaps by rasterizing the

view area: Enable “Rasterize Region” to con-
vert the chosen part of the view to a bitmap.

4. Setting bitmap resolution: Choose or enter
the resolution you want in the “Resolution”
box, and click “OK”.

5. Paint the bitmap as in Section 14.2.

14.2 Painting Bitmaps
With no inherent structure, bitmaps cannot use
stroke and fill attributes, but you can create very

rich and subtle pictures by painting a bitmap at dif-
ferent brush, color, and opacity values.

About the Bitmap Brush Setting Area
The bitmap brush setting area in the Paint Style pal-
ette lets you choose brush settings for painting col-
ors or masks on bitmaps.

• Showing the bitmap brush setting area:
When the Bitmap Pen tool  is chosen, indi-
cating an intention to paint bitmaps, the upper
section of the Paint Style palette will change
into the bitmap brush setting area.

• Previewing brush shape: Refer to the Bit-
map Brush Shape Preview (top left of the bit-
map brush setting area) as you make changes to
the brush size and hardness.

14.2.1 Painting Colors on 
Bitmaps
Brushes for painting bitmaps can vary in size, hard-
ness, spacing, opacity, and color. The width and
opacity of bitmap trails can also be controlled by
the pressure levels from the stylus.

1. Select the bitmap.
2. Choose the Bitmap Pen tool . The tool set-

tings are shown in the Toolbox palette.

The bitmap brush setting area.
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3. In the Toolbox palette, choose tool settings as
follows:

• Using pressure sensitivity: Enable the Vari-
able Width button  if you want Expression to
use the pressure information from your stylus to
vary the width of your bitmap trail. To vary
opacity as well, enable the Variable Transpar-
ency button  too.

• Enabling color painting: Enable the Draw
on Image button  to paint on the bitmap.

4. In the bitmap brush setting area of the Paint
Style palette, choose brush types as follows:

• Using soft and pixel brushes: Click the
Soft Brush button  for painting soft-edged
trails. For hard-edged trails, click the Pixel
Brush button  instead. To set individual brush
settings directly, see step 5 below.

• Using the eraser mode: Click the Eraser
Mode button  for removing colors from the
bitmap completely or partially (with a partly
transparent brush).

5. Click a preset brush setting (top right of the bit-
map brush setting area), or choose individual
settings as follows:

• Setting brush size: Enter or choose a value
(1-99 pixels) in the Brush Size meter .

• Setting brush hardness: Enter or choose a
value (1-100%) in the Brush Hardness meter

. For pixel brushes, the hardness is always
100%.

• Setting brush spacing: Enter or choose a
value (1-999%) in the Brush Spacing meter .

6. Set brush opacity by dragging the Brush Opac-
ity slider.

7. In the lower section of Paint Style palette,
choose a brush color, as is described in Section
8.11.

8. In the view area, drag on the bitmap to paint it.

14.2.2 Painting Masks on 
Bitmaps
An opaque bitmap mask protects the masked area
from being displayed, and the bitmap image will
appear transparent at the masked areas. A
semi-transparent bitmap mask allows more flexibil-
ity than the opaque mask when painting over the
masked area.

1. Select the bitmap.
2. Choose the Bitmap Pen tool .
3. Enable the Draw on Mask button  in the

Toolbox palette.
4. Choose from these options:
• Painting bitmap masks: Choose a soft

brush or pixel brush, and choose brush settings
and opacity as in Section 14.2.1 above.

• Removing bitmap masks: Choose the
eraser mode at 100% opacity. When drawing on
the mask, the color of the brush is ignored.

5. In the view area, drag on the bitmap to paint the
mask.

14.3 Using Bitmap Filters
If Photoshop filters have been installed on your sys-
tem, they can be applied to bitmaps.

Painting a bitmap mask.
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14.3.1 Choosing the Bitmap 
Filter Folder
You can indicate the location of your plugin folder
the first time you start Expression or at other times.

1. Choose PS-Plugins > Set Plugins Folder. This
opens a “Photoshop Plugin Settings” dialog.

2. Enter the path to the plugin folder, or click
“Browse” to choose it. Alternatively (for Win-
dows only), you can also let Expression locate
the folder by disabling the “Do Not Search for
Photoshop Plugins” option. Click “OK”.

3. Restart Expression.

14.3.2 Applying Bitmap Filters
For details on individual filters, refer to documenta-
tion provided by the software developers of the plu-
gin filters in question.

1. Select the bitmap.
2. Choose the filter you want from the PS-Plugins

menu.
3. Choose filter settings accordingly.

14.4 Defining Bitmap 
Strokes
Bitmap strokes are skeletal strokes defined from
bitmaps, and if defined with an alpha channel, they
too can be colorized. The two ends of a bitmap
stroke can be anchored, and the middle section can
be made into one or more repeatable parts.

14.4.1 Defining Simple Bitmap 
Strokes
1. Select the bitmap.

2. Choose Stroke > Define Bitmap Stroke. This
opens a “Define Bitmap Stroke” dialog.

3. Naming bitmap strokes: Enter a new
stroke name in the “Stroke Name” box.

4. Setting stroke folder: Choose the stroke
folder to use in the “Folder” box. If you want to
create a new folder, enter a new folder name
instead.

5. Setting default width: Enter the width in the
“Default Width” box.

6. Including an alpha channel: Choose “No
Alpha” to define the stroke without an alpha
channel. Otherwise, choose “Use the Original
Alpha” or “Grayscale” as needed.

7. You can continue to specify anchoring and
repeatable parts in this dialog (see Section
14.4.2 and Section 14.4.3), or do this at any
time after the stroke has been defined. Click
“OK” to define the stroke.

14.4.2 Defining Bitmap Strokes 
with Anchored Head and Tail 
Sections
By anchoring one or both ends of a bitmap stroke,
you can ensure that the aspect ratios of the anchored
parts will always remain unchanged, even when the
stroke is applied to a path longer than itself.

1. Double-click the stroke in the Strokes palette,
or double-click the Stroke Preview when the
stroke is chosen. This opens the “Bitmap Stroke
Anchor/Repeat Settings” dialog.

2. To anchor the left end of the stroke, enter the
length (in pixels) to be anchored in the
“Anchored head section length” box. Similarly,
to anchor the right end of the stroke, enter the
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length in the “Anchored tail section length”
box. Click “OK” to define the stroke.

14.4.3 Defining Bitmap Strokes 
with Repeatable Body Sections
Bitmap strokes can be defined to contain one or
more repeatable body sections of equal length.
When a bitmap stroke with one repeatable part is
applied to a path longer than itself, the entire part
will repeat itself. With two repeatable parts, the two
parts randomly alternate along the path. With three
or more repeatable parts, the parts appear in random
order along the path, and there will be a different
combination for each new path.

1. Open the “Bitmap Stroke Anchor/Repeat Set-
tings” dialog for the stroke, as is described in
Section 14.4.1.

2. In the “Body section” box, choose the “Simple
repeat” option if you want the stroke to have
one repeatable part. Choose the “2-part repeat”
or other options to define two or more repeat-
able parts. Click “OK”.

14.5 Converting Bitmaps to 
Paths
Auto-tracing converts a bitmap to a group of paths.
If you want to, you can perform a low pass filter on
a bitmap before conversion.

1. Select the bitmap.
2. Choose Objects > Bitmap > Auto Trace Bit-

map. This opens a “Bitmap Tracing Options”
dialog.

3. Choose from these options:
• Setting number of colors: Choose or enter

the number of colors to be used in the “No. of
Colors” box.

• Setting value of pre-filtering: Choose a
value from the “Pre-Filtering” box if you want.
The higher the value, the more the bitmap will
be smoothed. If you do not want to use pre-fil-
tering, choose “None” instead.

• Setting tightness of fit: Choose the option
you want (from “Very Loose” to “Very Tight”)
from the “Tightness of Fit” box. The looser the
fit, the fewer nodes the resulting paths will
have, and fewer features of the bitmap will be
retained.

4. Click “OK”. Expression starts the auto-tracing
process. When this is completed, the resulting
paths will be grouped and placed in front of the
bitmap.

A bitmap (left) can be auto-traced to give a 
group of paths (right).
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14.6 Bitmap Resources
In Expression 3, bitmap images are also used as a
fill type, as reflection maps, paper textures and
fringe textures. Images can be in Expression’s
natively readable formats: PSD, TIFF, BMP, GIF,
PNG or JPEG.

14.6.1 Image Fill Bitmaps
Image fill bitmaps are generally stored in the
“Images” folder under the “Expression 3” folder
(Macintosh) or under “Start menu > Programs >
Expression 3 > Resources” (Windows). Images
here are listed in the image fill list in the Paint Style
palette. You can also add additional links to image
files placed elsewhere on your system to the image
fill list, using the Add Image  button. Note that
the image list is simply a list of links to the image
files, which are themselves not copied into the
“Images” folder. Expression verifies the validity of
the links on using the image fill list. Invalid entries
are automatically removed. You can also de-list
links from the list manually using the Delist Image
button . For more details about the use of image
fill, refer to Section 8.14.

14.6.2 Reflection Maps
A reflection map is a look-up table of the appear-
ance of a surface at any normal direction under a
particular lighting environment. Expression 3 uses
spherical reflection maps, each of which is an
image of a circular sphere of a particular material
under a certain lighting environment. Photographs
of real spheres or hand-painted reflection maps can

also be used effectively. Reflection maps have to be
placed in the “EnvMaps” sub-folder under the
“Images” folder.

14.6.3 Paper Textures
Paper textures are image files placed in the “Tex-
tures” folder in the “Expression 3” folder (Macin-
tosh) or under “Start menu > Programs >
Expression 3 > Resources” (Windows). Any paper
texture images will be shown in the “Paper Tex-
ture” dialog. Colored images are converted to gray-
scale automatically. For more about the use of
paper textures, see Section 8.8.

14.6.4 Fringe Textures
Soft-edged fills have a smooth transparency grada-
tion, giving the appearance of a soft-edge. You can
give a soft-edge fill more rugged edges by applying
a fringe texture to the soft-edge. Details are
described in Section 8.5.2.

A hand-painted reflection map. (Color plate on 
page 193.)
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Fringe textures have to be placed inside the
“Fringes” sub-folder under the “Textures” folder.
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Chapter 15: Managing Custom Colors, 
Gradients, Patterns, Width Profiles and Attribute 
Sets

Colors, gradients, and patterns can be created, cop-
ied to and from objects, and copied between objects
and the Paint Style palette. Some stroke and fill
attributes can also be saved in the Item List palette
for later use. For width profiles, they too can be cre-
ated, edited and saved, but in the Variable Width
palette.

15.1 Managing Custom 
Colors
Custom colors are colors with names, and in
Expression, you can create your own custom colors
in RGB or CMYK values. The use of custom colors
in a design allows a global revision of the overall
color scheme by redefining the color values for par-
ticular custom colors. It provides a consistent way
to communicate colors. When you create custom
colors or open picture files containing custom col-
ors, these custom colors will be added to the list of
existing custom colors in the Paint Style palette,
ready to be applied to paths, as is described in Sec-
tion 8.11.4.

In fact, all the operations on custom colors can be
performed in the Paint Style palette. You can create
and edit custom colors here, as well as import and
export custom colors as a file. Note that when you
edit a custom color, all paths using the custom color
will be updated automatically.

15.1.1 About the Custom Color 
Editor
When you create or edit custom colors, the upper
section of the Paint Style palette changes into a cus-
tom color editor. The editor contains a name box, a
color preview, and a status bar showing the colors
values in RGB or CMYK, depending on the color
picker used when the color was defined.

15.1.2 Creating Custom Colors
1. Go to the custom color list in the Paint Style

palette.
2. Click the New Custom Color button . The

custom color editor appears.
3. Edit the custom color as follows:
• Changing custom color names: Enter the

custom color name you want in the box at the
top.

• Changing custom color values: Choose a
color in the lower section of the Paint Style pal-
ette, as is described in Section 8.11.

A Custom color name
B Color preview
C Color values

D Cancel
E Commit

The custom color editor.
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4. Click the Commit button  to save the
changes, or click the Cancel button  to can-
cel the changes.

15.1.3 Editing Custom Colors
1. Double-click the Stroke Preview or Fill Pre-

view where the custom color is shown. Alterna-
tively, choose the custom color in the custom
color list, and click the Edit Custom Color but-
ton .

2. Edit the custom color as in Section 15.1.2
above.

15.1.4 Deleting Custom Colors
1. Choose the custom color in the custom color

list in the Paint Style palette.
2. Click the Delete Custom Color button . To

retrieve the deleted color, click the Undelete
button .

15.1.5 Importing Custom Colors
Custom colors can be imported into Expression by
loading custom color list files saved in Expression
or Illustrator.

1. Go to the custom color list in the Paint Style
palette.

2. Click the Load Custom Colors button .
3. In the dialog that is opened, choose the file

whose custom color list you want to load, and
click “Open”.

4. In the dialog that is opened, choose the
“Replace existing list” or “Add to existing list”
option as needed, and click “OK”.

15.1.6 Exporting Custom Colors
Custom colors in the Paint Style palette can be
exported as a custom color list file. On Windows,

these files use the extension of “.ccl” (for custom
color list).

1. Go to the custom color list in the Paint Style
palette.

2. Click the Save Custom Colors button .
3. In the dialog that is opened, enter the file name

in the folder that you want, and click “Save”.

15.2 Managing Gradients
You can create your own gradients with color and
transparency variations. And when you open pic-
ture files containing gradients, these gradients will
also be added to the list of existing gradients in the
Paint Style palette, ready to be applied to paths, as
is described in Section 8.12.

The colors in a gradient can be RGB or CMYK col-
ors, or a mixture of both, but if you choose a custom
color, it is the RGB/CMYK value, not the name of
the custom color, that will be recorded in the gradi-
ent. This means that gradients will not be affected
by any subsequent changes made to custom colors.

15.2.1 About the Gradient Editor
When you create or edit gradients, the upper section
of the Paint Style palette changes into a gradient
editor. The editor contains a name box, followed by
a gradient preview bar showing the gradient.

The gradient nodes (pentagons  in the gradient
editor under the gradient preview bar) indicate the
color and transparency at different positions along
the gradient. When a gradient node is chosen (by
clicking it), the color at the node is shown in the
pentagon.

The position of the midpoint marker (diamond 
above the gradient preview bar) between every two
gradient nodes indicates where the color and trans-
parency values are midway between those of the
nodes at either side of it.
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Below the gradient preview bar is the status bar
showing the color, transparency and position values
for the chosen node, and a transparency slider.

15.2.2 Creating Gradients
1. Go to the gradient list in the Paint Style palette.
2. Click the New Gradient button .
3. In the dialog that is opened, enter the name you

want, and click “Yes”. The gradient editor
appears.

4. Edit the gradient as follows:
• Changing gradient names: Enter the

name you want in the box at the top.
• Changing colors at gradient nodes:

Click a gradient node  to choose it (the color
is shown in the gradient node). Choose a color
in the lower section of the Paint Style palette, as
is described in Section 8.11.

• Changing transparency at gradient
nodes: Click a gradient node to choose it, and
drag the slider.

• Moving gradient nodes: Drag a gradient
node (the pointer becomes ) along the gradi-
ent preview bar to change its position.

• Adding gradient nodes: Place the pointer
under the gradient preview bar (the pointer
becomes ). Click where you want to add a
gradient node.

• Deleting gradient nodes: Drag a gradient
node away from the gradient preview bar to
delete it.

• Moving gradient midpoints: Drag a mid-
point marker  along the gradient preview bar
to change its position.

5. Click the Commit button  to save the
changes, or click the Cancel button  to can-
cel the changes.

15.2.3 Editing Gradients
1. Double-click the Stroke Preview or Fill Pre-

view where the gradient is shown. Alterna-
tively, choose the gradient in the gradient list,
and click the Edit Gradient button .

2. Edit the gradient as in Section 15.2.2 above.

15.2.4 Deleting Gradients
1. Choose the gradient in the gradient list in the

Paint Style palette.
2. Click the Delete Gradient button .

15.3 Managing Patterns
When you create your own patterns, or open picture
files containing patterns, these patterns will be
added to the list of existing patterns in the Paint

A Gradient name
B Gradient preview 

bar
C Gradient node
D Color/Transparency 

values

E Transparency slider
F Midpoint markers
G Cancel
H Commit

The gradient editor.
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Style palette, ready to be applied to paths as pattern
fill, as is described in Section 8.13.

15.3.1 About Pattern Definition 
Boxes
When you create or edit patterns, a pattern defini-
tion box is added over the source path objects. The
pattern definition box is hollow in the center; this
area defines the size and coverage of the basic unit
(or tile), and the grayed out area surrounding the tile
shows the effect of the tiling.

15.3.2 Creating Patterns
1. Create the paths to be used as a tile of the pat-

tern.
2. Choose the Pattern Definition Box tool .
3. Drag diagonally across the paths, and release

the mouse button when you have the right tile
coverage and size. A selected pattern definition
box appears over the paths.

4. If you want to move or transform the pattern
definition box, select it and transform it as for
other objects. If you want to edit the paths,
deselect the pattern definition box first.

5. When you have finished editing, select the pat-
tern definition box. The Define Pattern button

 appears at the bottom left of the docu-
ment window.

6. Click the Define Pattern button . This
opens a “Define Pattern” dialog.

7. Enter the name you want in the box, and click
“OK”.
To make it easier to make adjustments to newly 
defined patterns, you can set an option in the 
“Preferences” dialog (Section 18.3.1) to have 
the pattern definition box remain on-screen 
after patterns have been defined.

A Pattern definition 
box

B Source paths

C The tiling pattern
D Define pattern

The pattern definition controls.

Creating a pattern. Four source path objects 
with a deselected pattern definition box (left), 
and a preview of the tiling pattern shown when 
the pattern definition box is selected (right).

A transformed pattern definition box (right) 
changes the tiling pattern.
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15.3.3 Editing Patterns
1. Double-click the Fill Preview where the pattern

is shown. Alternatively, choose the pattern in
the pattern list, and click the Edit Pattern button

.
2. Edit the pattern as in Section 15.3.2 above.

15.3.4 Deleting Patterns
1. Choose the pattern in the pattern list in the Paint

Style palette.
2. Click the Delete Pattern button .

15.4 Copying Colors and 
Attributes
Colors can be copied from objects to paths directly
using a drag-and-drop action, or through the Drop-
per Content button in the Paint Style palette.

15.4.1 About the Color Dropper
When you use the Color Dropper tool to pick up
colors, you can either pick up the object color,
which is the object’s HSL or RGB values, or the
screen color, which is the color shown in the view,
after being affected by other attributes, such as
opacity. The screen color is always in RGB values.
You can choose the “Pick object color” or “Pick
screen color” option in the Toolbox palette when
the Color Dropper tool is chosen. You can also set
the default to be the option you want in the
“Preferences” dialog (see Section 18.3.3).

15.4.2 About the Dropper 
Content
The color picker in the Paint Style palette has a
Dropper Content button, which acts as a buffer for
transferring colors to and from the view area.

15.4.3 Copying Colors, 
Gradients and Patterns
The Color Dropper tool lets you pick up colors, gra-
dients and patterns from the view area.

1. Choose the Color Dropper tool .
2. Enable the Object Color button  if you want

to pick up object colors. Otherwise, enable the
Screen Color button  to pick up screen col-
ors. If you want to copy gradients and patterns,
use the Object Color button.

3. Choose from these options:
• Copying colors, gradients and patterns

to paths: Place the pointer over the color, gra-
dient or pattern that you want to copy, and drag
it to another stroke or fill area to deposit it.

• Copying colors to the Dropper Content:
Click the color you want to copy (the pointer
becomes ). The color is shown in the Drop-
per Content button.

• Clearing the Dropper Content: Enable the
Object Color button, and click an empty space
in the view area.

15.4.4 Copying Both Stroke and 
Fill Attributes
The Attribute Dropper tool lets you copy both
stroke and fill attributes from one path to another at
the same time.

1. Choose the Attribute Dropper tool .

The Dropper Content button.
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2. Enable the Object Color button  if you want
to pick up object colors. Otherwise, enable the
Screen Color button  to pick up screen col-
ors.

3. Place the pointer over the path whose attributes
you want to copy, and drag it to another path to
deposit the attributes.

15.4.5 Copying Colors from the 
Paint Style Palette
You can copy colors from the Paint Style palette to
the appropriate part of the path, be it the stroke, fill,
foreground color or background color.

1. Select the path to which you want to deposit the
color.

2. Go to a color picker in the Paint Style palette.
3. Choose from these options:
• Copying colors from the color pre-

views: Place the pointer over the color pre-
view, and drag it to Stroke Preview, Fill
Preview or the Dropper Content button (the
pointer becomes ) as needed.

• Copying colors from the Dropper Con-
tent: Click the Stroke Preview (for copying
colors to the strokes) or Fill Preview (for copy-
ing colors to the fill) as needed. Click the Drop-
per Content button.

15.5 Managing the Item List
Some stroke and fill attributes in the Paint Style
palette or in path objects can be stored as items,
each of which is a set of stroke-only attributes or a
set of fill-only attributes. Not all attributes can be
stored, however. Attributes that are relevant to the

path as whole, including opacity, paper textures and
blending modes, cannot be stored.

15.5.1 About the Item List Palette
The Item List palette provides temporary storage
for items. An example of a stroke item may be a
skeletal stroke called “tree” with width of 10 points
and colorized using blue and yellow, while a fill
item may be a red color with soft-edge width of 12
points. The items in the Item List palette can also be
applied to paths directly.

15.5.2 Adding Items
1. Select the path whose attributes you want to

add to the Item List palette.
2. In the Paint Style palette, click the Stroke Pre-

view to use the stroke attributes. If you want to
use the fill attributes, click the Fill Preview
instead.

3. In the Item List palette, click the Create Item
button .

4. In the dialog that is opened, enter a descriptive
name for identifying the item, and click “OK”.

15.5.3 Applying Items
1. Select the path to which you want to apply the

item.

A Create item
B Edit item
C Load item list

D Save item list
E Delete item

The Item List palette.
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2. In the Paint Style palette, click the Stroke Pre-
view to use the item on the stroke. If you want
to use it on the fill, click the Fill Preview
instead.

3. In the Item List palette, click an item to apply it.

15.5.4 Editing, Importing and 
Exporting Items
The list of items in the Item List palette can be
saved in a separate item list file for future use. On
Windows, these files use the extension of “.itl” (for
item list).

• Renaming items: Click an item, and click
the Edit Item button . In the dialog that is
opened, enter the name you want, and click
“OK”.

• Deleting items: Click an item, and click the
Delete Item button .

• Importing item lists: Click the Load Item
List button . In the dialog that is opened,
choose the item list file you want, and click
“Open”.

• Exporting item lists: Click the Save Item List
button . In the dialog that is opened, enter
the file name in the folder you want, and click
“Save”.

15.6 Managing Variable 
Width
The Variable Width palette displays various width
profiles for use with soft-edged fill, embossed fill
and skeletal strokes, as is described in Section 8.10.

Besides the width profiles provided in Expression,
you can create your own width profiles, and edit
and arrange them in the Variable Width palette.

15.6.1 Creating and Editing 
Width Profiles
Width profiles are automatically created when you
create paths using a pressure sensitive tablet, with
pressure sensitivity turned on (see Section 7.4). You
can also build up width profiles yourself.

1. Choose a width profile or start with a flat pro-
file in the Variable Width palette.

2. Edit it as follows:
• Moving profile nodes: Click a profile node,

and drag it to the position you want.
• Adding profile nodes: Click the Add Node

button  to add a profile node to the right of
the current node. If no node is chosen, the new
node will be added to the right of the leftmost
node.

• Deleting profile nodes: Click a profile
node, and click the Delete Node button .

15.6.2 Saving and Arranging 
Width Profiles
1. Select the path whose width profile you want to

save, or create a width profile in the Variable
Width palette.

A Reset
B Add node
C Delete node
D Presets popup
E Add to presets

F Edit preset list
G Transparency Vari-

ability slider
H Width variability 

slider
The Variable Width palette.
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2. Click the Edit Preset List button . This opens
a “Preset Variable Width” dialog.

• Adding width profiles: Click the Add Pro-
file button  to add the profile to the profile
list.

• Duplicating width profiles: Click the pro-
file you want to duplicate, and click the Add
Profile button .

• Deleting width profiles: Click the profile
you want to delete, and click the Delete Profile
button .

• Arranging width profiles: Drag a profile up
or down to change its position in the profile list.

3. Click “OK”.
The “Preset Variable Width” dialog.
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Chapter 16: Turning Graphics Objects into Flash 
Buttons

16.1 Exporting as Flash 
Movie Files and Interactive 
Flash Pages
Flash is becoming a de facto standard format for
vector graphics on the Web. Its relatively compact
format, support of user interaction, and efficient
transformation of graphics objects make it a popu-
lar format for Web contents.

Expression pictures can be exported to the Flash
format relatively faithfully, but without some of the
more sophisticated features like blending modes,
embossed/soft-edged fill, paper textures and fully
colored bitmap strokes.

There are other considerations as well. Because
Flash only uses quadratic curves and not cubic
curves (which are used by Expression 3 and many
other vector illustration software), most exported
paths have to be approximated. Also, the lack of
support for the non-zero winding rule in Flash
means that Expression has to convert any self-inter-
secting paths into simple paths that have no self
crossings before exporting them.

Furthermore, because Flash supports only constant
thickness strokes with round caps and round joints,
any thick strokes that use a different type of cap,
joint, or a richer style (e.g., a skeletal stroke) have
to be flattened into explicit outlines. While all these
additional procedures help to ensure a more faithful
export of the picture, they inevitably also reduce the
efficiency of the export process, and increase the
size of the exported file. The number of quantiza-
tion levels for the vectorization of bitmap strokes
can be adjusted with an option in the “Preferences”
dialog (see Section 18.5.1).

16.2 About the Flash Button 
Palette
You can easily turn an Expression picture into an
interactive web page without knowing a single line
of scripting! Using the Flash Button palette, any
individual graphics object or group of graphics
objects can be turned into an interactive Flash but-
ton by exporting the Expression picture file as an
SWF file. The SWF file can then be placed in your
web page directly.

If you define a multi-view stroke, any path applied
with the multi-view stroke can also be exported as a
multi-frame SWF movie by pressing the Export
Stroke Animation button . Such SWF movies
can subsequently be imported into third-party Flash
movie applications for further editing.

A Normal State Effects column. The two popup 
buttons in this column set the motion and color 
effects of the resulting button in the normal 
state (i.e., when the mouse pointer is neither on 
top of the button object nor clicking the but-
ton.) See Section 16.5 for details.

B Pointer-Over State Effects column. The two 
popup buttons in this column set the motion 

The Flash Button palette.
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and color effects of the resulting button when 
the mouse pointer is on top of the button 
object.

C Pointer-Click State Effects column. The two 
popup buttons in this column set the motion 
and color effects of the button when the but-
ton object is being clicked.

D Animation cycle time in seconds. This meter 
control sets the duration of one cycle of the 
effects that are chosen in the A, B and C col-
umns.

E Number of effect cycles to run before stopping. 
The default setting is “perpetual”. See Section 
16.9 for details.

F Reciprocate toggle button . If this button is 
depressed, the animation effect will be played 
backward after a forward cycle has finished. 
The cycle time in this case refers to the time for 
a complete forward-and-backward sequence. 
This button is only applicable to objects that 
can have animation effects (e.g., an object 
with a multi-view stroke, or a stroke path with a 
dash pattern and snake offset.) 

G Export animation effects as an SWF movie . 
(Applicable to objects that can have anima-
tion effects.)

H Reset button. Clears all Flash button settings 
and reverts the graphics object(s) to the nor-
mal state.

I Stroke button display. Shows the stroke button 
being modified. If the currently selected object 
has no Flash settings yet, this display will be 
dimmed and un-depressed. If multiple objects 
are selected or the current selection cannot be 
used as a Flash button, the display will be 
blanked.

J URL of the button. This is the URL to be jumped 
to when the button is clicked.

K Motion effect magnitude. This basically controls 
the strength of all motion effects. Note the dif-
ferent interpretations of this value for different 
effects as is described in Section 16.6.

L Color effect magnitude. This basically controls 
the strength of all color effects. Note the differ-
ent interpretations of this value for different 
effects as is described in Section 16.6.

M URL target. The name of the target HTML frame 
to replace with the URL content. You can enter 
any target name or choose one of the stan-

dard targets from the list. Refer to any HTML 
manual or Section 16.4 for details.

16.3 Choosing Flash 
Settings
The Flash format supports simple user interactions
with objects and groups of objects. Expression
takes advantage of these features, and allows an
object or object group to become a Flash button, to
have different animated effects under different
mouse pointer conditions, and to perform a hyper-
link jump to a specified URL (Uniform Resource
Locator).

1. Select the object or group.
2. Choose the flash settings and options in the

Flash Button palette. For details, refer to the
following sections.

16.4 URL and Target Settings
You can create a hyperlink for an object by indicat-
ing an URL and target for it. The Flash Button pal-
ette offers some special targets:

• _blank: This specifies that no existing window
or frame should be replaced. Instead, a new
window should be opened to hold the new con-
tents.

• _self: This specifies that the current frame or
window should be replaced with the new con-
tents.

• _parent: This specifies that the new contents
should be loaded into the parent window or
frameset containing the frame with the Flash
document. If the current frame is the top-level
frame, it is equivalent to the target “_self”.

• _top: This specifies that the new contents
should be loaded into the current window,
replacing any frames currently displayed.
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16.5 Motion Effects, Color 
Effects and Pointer States
There are two types of animation effects for objects,
namely, motion effects and color effects. Motion
effects make objects move in various ways, e.g.,
pulsate, rock, rotate, or even animated (by choosing
the Animate motion effect if the path uses a
multi-view stroke). Color effects modify the tone,
color or transparency of objects.

The Flash Button palette lets you specify three sets
of animation effects for an object, one for each of
the three user interaction states, so that the appro-
priate set of animation effects will be activated
depending on the state the object is in.

• Normal state: This is when the mouse
pointer is not touching the object.

• Pointer over state: This is when the
mouse pointer is over the object; the object is
not being clicked yet.

• Pointer click state: This is when the
object is being clicked.

Motion Effects

Color Effects

16.6 Effect Setting Sliders
You can introduce variations to a particular set of
animation effects by specifying the degree of the
motion or color change. In the Flash Button palette,
there are two magnitude setting sliders, each of
which controls the set of effects (motion and color
effects) to the left of itself. The parameter you

 No effect
 Pulsate
 Horizontal Pulsate
 Vertical Pulsate
 Rock
 X Vibrate

 Y Vibrate
 XY Vibrate
 Rotate
 Enlarge
 Shrink
 Animate

 No effect
 Fade
 Blink

 Brighten
 Darken
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choose in a slider controls the effects specific to
each motion or color effect, as is tabulated below.

16.7 Reciprocating 
Multi-View Stroke 
Animations
For multi-view strokes using the Animate motion
effect, the multi-view stroke will be animated in the
Flash export, with the shape parameter varying with
time. You can enable the “Reciprocate” option to
make the animation reciprocating, i.e., to make the
shape parameter increase from 0% to 100% and
decrease back to 0%. If it is not reciprocating, the
shape parameter will increase from 0% to 100%
and then go straight back to 0% again.

16.8 Speed of Effects
Most of the animation effects are cyclical, and the
speed of the effects can be controlled by specifying
a cycle time parameter (in seconds, with decimals if
needed) in the “Effect cycle time” box.

16.9 Number of Effect 
Cycles
The Cycle popup menu in the Flash Button palette
lets you specify the number of times you want a set
of effects to be repeated. You can choose the “Per-
petual” option to repeat an effect forever, or choose
a finite number of times, up to 40 times. Towards
the end of the repeating period, the strength of the
effect will diminish, and finally any motion or
change will be stopped. Note that this setting does
not apply to one-off effects such as “Enlarge” and
“Shrink”.

16.10 Exporting to Flash 
Format
1. Choose File > Export > Flash Export.
2. In the dialog that is opened, enter the file name

in the folder you want and click “Save”.
3. In the dialog that is opened, choose options as

follows:
• Choosing output area: Enable “Paper

frame” to output the area within the document
frame. To output the area bounded by the crop
marks, enable “Crop marks”. To output the area
bounded by the bounding box of all objects,
enable “Objects bounding box”.

• Setting raster resolution and frame rate:
Choose the raster resolution and frame rate you
want from the popup menus.

Effect Interpretation of the Setting 
Parameter

Pulsate The amount of scaling (5% 
-100%).

Rock The angular amount of the rock-
ing.

Vibrate The amount of shifting 
(5%-100%). 

Rotate Indicates a counterclockwise 
rotation when the slider is at the 
right side.

Enlarge The amount of scaling 
(5%-100%).

Shrink The amount of shrinking 
(95%-5%).

Stroke Ani-
mation

No effect on multi-view stroke 
animation. For snake-path ani-
mation, the slider controls the 
direction of the snaking: having 
the slider at the left side indi-
cates start-to-end snaking, hav-
ing the slider at the right side 
indicates end-to-start snaking.

Color Effects The amount of color/tonal/trans-
parency change (5%-100%).
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• Emulating joints and caps: Enable “Emu-
late joint/caps” if you want Expression to emu-
late the stroke joints and caps that are not
supported by Flash.

• Protecting output from being edited:
Enable “Protect from editing” to prevent the
output from being edited in the Flash program.

4. Click “OK”. Expression will start the export
process, and a progress bar appears to show the
estimated time to completion. To cancel the
process at any time, click “Cancel”, or, press
Command-Period (Macintosh) or the Esc
key (Windows).
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Chapter 17: Printing, Saving and Exporting

Expression documents can be saved in the native
format, copied to other applications through the
clipboard, exported to other vector and bitmap for-
mats, and output to a printer.

17.1 Saving Documents
Expression documents are saved in the Expression
file format, which uses the file extension of “.xpr”
on Windows. You can choose to save Expression
files in binary or text format, and include a thumb-
nail image with size of up to 64x64 pixels if you
want. The thumbnail image will be shown when the
file is chosen in the file opening dialog. The thumb-
nail image may be also saved at a slightly bigger
size, up to 100x100 pixels. You can set this option
in the “Preferences” dialog (Section 18.5.2).

For crash recovery purposes, Expression saves
modified documents periodically into rescue files.
These rescue files are also saved in Expression’s
native file format. They are automatically removed
as soon as the document has been properly saved or
closed. Rescue files are opened automatically on a
subsequent launch if the program has been termi-
nated improperly. To make the saving of the rescue
file less interruptive, pixel data in bitmap objects is
not recorded. Since bitmap objects are often
imported from external bitmap files, the images are
usually recoverable from the original source even
in the case of a crash.

Refer to Section 18.5.2 for instructions on setting
the options for saving Expression documents and
rescue files.

• Saving documents: Choose File > Save. If
the document is being saved for the first time, a
dialog opens. Enter the file name in the folder
you want, and click “Save”.

• Saving documents under new names:
Choose File > Save As, and in the dialog that is
opened, enter the new name in the folder you
want and click “Save”. If you want both the
original and new documents to remain opened
after saving, choose File > Save A Copy
instead.

17.2 Using Crop Marks
You can use a set of crop marks to define a rectan-
gular area (or crop area) in a file for output use. If
no crop marks are set, the document frame or
bounding box of objects is usually used as the out-
put boundary instead.

17.2.1 Setting Crop Marks
• By dragging out a marquee: Choose Edit

> Crop Marks > Set, and drag diagonally across
the area (in the view area) that you want to set
as the crop area.

• By entering position coordinates: Choose
Edit > Crop Marks > Set, and click in the view
area to open a “Set Crop Marks” dialog. Enter
the coordinates of the two diagonally opposite
corners of the crop area, and click “OK”.

• Using the object selection’s bounding
box: Select the objects whose bounding box
you want to use as the boundary of the crop
area. Choose Edit > Crop Marks > From
Bounding Box.

17.2.2 Removing Crop Marks
Choose Edit > Crop Marks > Remove.
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17.3 Exporting to PostScript 
Based Formats
Expression documents can be exported to the Illus-
trator 3.0, 5.0, 7.0, 9.0/PDF file formats and the
EPS (Encapsulated PostScript) file format. You can
also use the clipboard to paste objects directly from
Expression to and from any applications that sup-
port the AICB (Adobe Illustrator Clipboard) for-
mat.

Note, however, that because some Expression fea-
tures (e.g., transparency) are not supported by some
of these file formats, some of these features have to
be approximated when exported; some features are
lost when exported.

The best way to preserve the rich features of
Expression is to rasterize them to a bitmap format,
but sometimes it is useful to export a picture to the
EPS format to preserve the crispness of lines and
text.

17.3.1 Exporting to EPS Format or 
Illustrator Formats Without 
Transparency Support
1. In the File menu, choose Export > Illustrator

Export, or Export > EPS Export as needed.
2. In the dialog that is opened, enter the file name

in the folder you want and click “Save”.
3. In the dialog that is opened, choose from the

options:
• For Illustrator 3, 5 or 7 format: Choose the

Illustrator format you want to use. Choose the
“Export hidden layers” option if you want to
export hidden layers as well as shown layers.

• For EPS format: Choose “No preview image”
to save the file without a thumbnail image.
Alternatively, choose “PICT resource” (Macin-
tosh) or “Binary TIFF preview” (Windows) to
save a thumbnail image in the bitmap format
you want. You may also choose “Platform inde-

pendent preview” to save a preview image in a
special PostScript comment block as defined in
the PostScript Reference Manual. Note, how-
ever, that some applications ignore the platform
independent preview comments block.

4. Click “OK”. Expression starts the export pro-
cess, and a progress bar appears to show the
estimated time to completion. To cancel the
process at any time, click “Cancel”, or, press
Command-Period (Macintosh) or the Esc
key (Windows).

17.3.2 Exporting to the PDF 
Format
1. In the File menu, choose Export > PDF Export.

Alternatively, choose Export > Illustrator
Export and then choose the “9.0/PDF” option.

2. In the dialog that is opened, enter the file name
in the folder you want and click “Save”.

3. In the dialog that is opened, choose PDF set-
tings as follows:

• Setting objects for rasterization: You can
choose which types of objects to be rasterized
for the export: objects with soft-edged or
embossed fill, those with paper textures, those
with transparent gradients, and those with bit-
map strokes.

• Setting rasterization resolution: If you
have chosen to rasterize objects for the export,
you can choose the resolution as well.

• Setting bitmap stroke vectorization
level: If you have chosen not to rasterize bit-
map strokes, bitmap strokes will be vectorized
into overlapping solid fill objects for the export.
You can choose the number of overlapping
objects to create for each bitmap stroke.

• Exporting hidden layers: Choose the
“Export hidden layers” option if you want to
export hidden layers as well as shown layers.

4. Click “OK” to start the exporting process.
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17.4 Rasterizing to Bitmap 
Formats
Pictures in Expression can be rasterized to different
bitmap file formats, including PSD (with layers and
alpha channel), TIFF (with alpha channel), JPEG,
GIF, PNG and BMP (for Windows only). If you
have Photoshop 4 or above, all the format plugins
available to the application are also available.

Besides outputting to bitmap files, you can also
convert an area of the view area to a bitmap object
directly, as is described in Section 14.1.

1. Choose File > Save As Bitmap.
2. Setting name and file format: In the dialog

that is opened, enter the name you want, and
choose the file format to use. Click “Save”.

3. In the dialog that is opened, choose bitmap set-
tings as follows:

• Keeping aspect ratio: Turn on the “Keep
aspect ratio” option if you want Expression to
automatically update the counterpart to the
width or height value that you are editing in
order to maintain the aspect ratio of the crop
mark area (if used) or the document frame.

• Setting output size and resolution: In the
“Pixel dimension” and “Output size” sections,
enter the values you want.

• Saving with alpha channel: Some bitmap
formats support alpha channels (e.g., TIFF and
PSD). Turn on the “Save alpha channel” option
if you want to include them in the bitmap.

• Saving with layers (PSD only): The PSD
bitmap format supports layers. Turn on the
“Save with layers” option if you want to
include them in the bitmap.

• Enabling antialiasing: Turn on the “Anti-
alias” option if you want the bitmap to be anti-
aliased.

• Setting output area: Turn on the “Save crop
mark region only” option if you want to raster-
ize only the area bounded by the crop marks.
This option is available only if crop marks have
already been set.

4. Click “OK”. Expression starts the rasterization
process, and a progress bar appears to show the
estimated time to completion. To cancel the
process at any time, click “Cancel”, or, press
Command-Period (Macintosh) or the Esc
key (Windows).

17.5 Exporting through the 
Clipboard
If you have copied some graphics objects from
Expression into the clipboard, those objects can be
pasted into another application in one of the follow-
ing formats, depending on the type of clipboard
data formats the application requested:

• Windows BMP (Windows only)
• PICT Image (Macintosh only)
• PDF
• AICB (Adobe Illustrator Clipboard) formats
• Plain Text (Text objects only)
Since Photoshop and Illustrator will normally
request AICB in favor of image formats like BMP
or PICT, objects with transparency will not be
exported faithfully. You could set the AICB option
in the “Preferences” dialog to “Always rasterize” or
“PDF format” to tell Expression to supply only ras-
terized images or PDF format data into the clip-
board.

A rasterization progress bar.
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17.6 Printing Documents
Expression rasterizes documents into images before
printing them. When you initiate the printing pro-
cess, a “Print Rasterization Settings” dialog will be
displayed to let you choose the rasterization resolu-
tion. The maximum rasterization resolution will be
the printer’s maximum resolution. In the “Print
Rasterization Settings” dialog, a small preview of
the printed page based on the current choice of
printing area (document frame or crop mark region)
will also be shown, with the printer’s margins in
red. The preview image will be updated as the print-
ing area is changed.

1. Choose File > Print. This opens the operating
system’s printing dialog.

2. Choose the settings you want, and click “Print”
(Macintosh) or “OK” (Windows).

3. In the dialog that is opened, choose print raster-
ization settings as follows:

• Choosing printing resolution: Choose the
resolution (in dpi) at which you want to print
the picture.

• Choosing printing area: Enable “Print crop
mark region” to print the area bounded by the
crop marks. If you want to print the area within
the document frame instead, disable this option.
This option is available only if crop marks have
already been set.

• Centering image: Enable “Center image” to
align the picture center with the paper center for
printing.

4. Click “OK”. Expression starts the rasteriza-
tion/printing process, and a progress bar
appears to show the estimated time to comple-
tion. To cancel the process at any time, click
“Cancel”, or, press Command-Period
(Macintosh) or the Esc key (Windows).

The “Print Rasterization Settings” dialog.
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Chapter 18: Customizing Expression 3

18.1 Setting Options and 
Preferences
Certain tool behavior, object operations, as well as
viewing and output options can be set to suit your
working needs and personal preference. These set-
tings are organized into different preference pages
in the “Preferences” dialog.

18.1.1 Changing Preferences
1. Choose File > Preferences. This opens a

“Preferences” dialog, showing the “General”
preference page.

2. To switch to another page, use the popup menu
at the top of the dialog.

3. Make the changes you want (see below for a
description of each item), and click “OK”.

Your preferences are saved in a preference file. The
following settings are also saved in the same file:
option settings, other persistent tool and control
states, including plugin folder settings, WACOM
tablet Tool ID tool mappings, quick stroke bind-
ings, color management settings, suppressed mes-
sage list settings etc.

18.2 “General” Preferences

18.2.1 Objects
• Quick (area) select: When you drag a dese-

lected object using an object selection tool, it
will be selected; to move it, you need to drag
again. However, if the “Quick (area) select”
option is turned on, you will be able to select
and move an object in one dragging action.

• Transform patterns: When you scale, rotate
or otherwise transform a path that has a pattern
fill, the pattern will be transformed accordingly.
Turn off the “Transform patterns” option if you
want the pattern applied to an object to be in its
original size and orientation despite object
transformations.

• Scale line weight: When you scale a path
that uses a basic stroke or gradient stroke, the
value of the stroke width remains unchanged.
Turn on the “Scale line width” option if you
want the value of the stroke width to be scaled
up or down with the path.

• Path operations: Keep originals: Turn on
this option to keep the source paths after using
path operations. For details on path operations,
see Section 7.15.

• Create new layer above current layer:
Turn on this option if you want new layers to be
created above the current layer, and not at the
top of the layer list.

• Ask for layer name when creating new
layer: Turn on this option if you want a dialog
for entering layer names to be automatically
opened every time you create a new layer. If
this option is turned off, the new layers will be
named “Layer 1”, “Layer 2” etc.

• Auto commit transforms: Turn on this
option if you want transformations to be com-
mitted to automatically after each transforma-
tion. With this option on, values of stroke width
always reflect the true visual thickness of the
strokes, but for transformations that do not pre-
serve the aspect ratio of objects, compromised
stroke widths may result. To use this option on
all kinds of transformations, choose “All
kinds”. To use this option on all transformations
except for perspective transformations, choose
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“Except perspective”. See Section 12.9.1. This
option is also available directly from File >
Options.

• Size/Bounds uses path bounding box:
When you are using the Size or Bounds pages
in the Transformation palette to specify exact
object positions, the size and bounds could be
referring to: (1) the bounding box of all visible
parts of the object(s) including soft-edges or
strokes; or (2) the bounding box of the paths
only. If this option is turned on, the bounding
box of the object path (instead of the bounding
box of all visible parts) will be used as the
bounds of the object.

• Frozen layer memory limit: Freezing a
layer rasterizes a layer’s objects to a bitmap at a
resolution of your choice. You can specify an
upper limit of the amount of memory you are
prepared to use for rasterizing each layer.

• Path simplification tolerance: The default
tightness of fit value used in path smoothing is
1.0, but you can choose a value within the range
of 0.1 (tight) and 10 (very loose). This value
can also be accessed from Objects > Smooth
Path.

• Undo levels: The default number of undo lev-
els is 15, but you can choose a number within
the range of 2 to 200. For this change to take
place, you need to restart Expression.

18.2.2 Arrangement
• Angular constraint steps: The default num-

ber of angular constraint steps is 8, but you can
choose a number within the range of 1 to 360
steps.

• Nudge increment: The default distance
traveled by an object selection or node selection
by nudging it once (i.e., by pressing an arrow
key once) is 1 point, but you can choose a value
within the range of 0 to 72 points.

• Stack gap size: The default gap between
stacked objects is 8 points, but you can choose a
value within the range of -2,000 to 2,000 points.

18.2.3 Palette
• Draggable color wheel: Turn on this

option if you want to choose hues by dragging
the Paint Style palette’s color wheel (thus shift-
ing the hue spectrum) until the hue you want is
being pointed at by the triangle. With this
option turned off, the entire hue spectrum is
shown as a column, with a circle on it to indi-
cate the chosen hue. (See Section 8.11.1.) Note
that this option affects the color wheel in both
the Paint Style palette and the Colorize palette.

• Dockable palettes (Windows only): Turn
off this option to prevent palettes from docking
when they are dragged near the edges of the
workspace.

18.2.4 Messages and Warnings
• Display all messages and warnings:

This option is available only if you have chosen
to hide some messages and warnings previ-
ously. Enable this option to let them be shown
again.

• Beeps replace hidden messages: This
option is available only if you have chosen to
hide some messages and warnings previously.
Disable this option if you do not want Expres-
sion to indicate a hidden message or warning
with a beeping sound.

18.3 “Tools” Preferences

18.3.1 General Options
• Drawing tools: Append to path: Turn on

this option if you want to be able to start or end
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new paths at existing open paths. Note that this
option only applies to the node-placing drawing
tools (i.e., not the Freehand Pen tool, which has
its own path appending controls). This option is
also available from the Toolbox palette when
such a tool is chosen, or directly from File >
Options.

• Highlight new paths: Turn off this option if
you want paths to be deselected immediately
after they are created. When drawing many
paths that are close together (e.g., a patch of
grass), this will prevent paths from being acci-
dentally moved. This option is also available
directly from File > Options.

• No fill with skeletal strokes: Turn off this
option if you want to keep a path’s fill when
you change skeletal strokes.

• Direct drag width handle: If this option is
turned off, you will need to hold the  key
in order to drag the width handle of a skeletal
stroke. This additional requirement prevents the
stroke width and stroke shear from being acci-
dentally changed during path selection and
arrangement.

• Ellipse tool draws from center: Turn on
this option if you want the pointer position to be
used as the center of the ellipses to be created.
With this option turned off, the pointer position
is used as a corner of the bounding box of the
ellipses. This option is also available from the
Toolbox palette when the Ellipse tool is chosen.

• Apply variable width profile to new
paths: Turn on this option if you want the
width profile in the Variable Width palette to be
automatically applied to newly created paths.

• Object tool clicks show input dialog:
Normally, when you click in the view area with
the Rectangle, Ellipse, Twirl Star or Line tools,
a dialog box will appear to let you specify the
exact dimensions of these shapes using numeri-

cal values. Turn off this option if you do not
want this feature.

• Define pattern: Keep definition box:
Normally, after defining a pattern, the pattern
definition box will no longer be shown in the
view area. However, if you want to keep the
pattern definition box after defining a pattern
(e.g., to make it more convenient for editing
and re-defining patterns immediately after
defining patterns), you can turn on this option.

18.3.2 Freehand Pen Tool
• Show pressure trail: Turn on this option if

you want the shape of the variable width stroke
to be shown while you are dragging on a tablet
with pressure sensitivity turned on. If this
option is turned off, the shape of the resulting
stroke will be shown only after you release the
pressure on the tablet. This option is also avail-
able directly from File > Options.

• Tightness of fit: The tighter a curve is fitted to
the freely drawn trail, the more nodes will the
curve have, and the closer will the shape of the
curve resemble that of the trail. Choose from
the options of “Very Tight”, “Tight”, “Normal”,
“Loose”, and “Very Loose”.

• Enable pressure sensitivity: Turn off this
option if you want Expression to ignore the
pressure information from your stylus as you
use the Freehand Pen tool (to draw paths) or the
Bitmap Pen tool (to paint bitmap trails).

• Maximum pressure brush width: This is
the width a stroke or part of a stroke will have if
the pressure applied at that part is the maximum
level detected by the pen/tablet. The default
brush width at maximum pressure is 60 pixels,
but you can change it to any number within the
range of 4 and 60. This option is also available
from the Toolbox palette when the Freehand
Pen tool is chosen.
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18.3.3 Color Dropper Tool
• Pick: When the Color Dropper tool is used to

pick up colors on objects, the “Object color”
option (the default) makes it pick up the object
color, i.e., the color values in RGB, HSL values
etc. Choose the “Screen color” option if you
want it to pick up the color as is shown on the
screen, after being affected by other attributes
such as transparency and gradients. This option
is also available from the Toolbox palette when
the Color Dropper tool is chosen.

• Reset colorization: When copying colors to
an already colorized object, the resulting color
(i.e., the color displayed after colorization) can
look completely different from the color cop-
ied. You can turn on this option to automatically
reset any colorization on an object before copy-
ing colors to it using the Color Dropper tool.

18.3.4 Tablet/Digitizer Support
• Z-Axis Rotation: Hand tool rotates

paper: Turn on this option if you want the
rotation of the WACOM 4D mouse under the
Hand tool to be used for controlling the rotation
of the paper.

• Z-Axis Rotation: Direct object rotation:
Turn on this option if you want the rotation of
the WACOM 4D mouse under a selection tool
to be used for controlling the rotation of
selected objects.

• Z-Axis Rotation: Use pen tilt for rotation:
Turn on this option if you want the tilt angle
detected by the WACOM pen to be used for
controlling the rotation of the paper or of
selected objects. Also turn on the “Hand tool
rotates paper” and/or “Direct object rotation”
options as needed.

• Mouse wheel: You can assign the rolling of
the mouse wheel to different tasks. Choose
“Zoom” to use it for zooming. Choose “V/H
scroll” for scrolling primarily vertically (hori-

zontal scrolling accessed with a modifier key),
and “H/V scroll” for scrolling primarily hori-
zontally. “Switch tool” lets you toggle among
tools in the same tool group, e.g., within the
definition box tools, or within the selection
tools.

• Mouse wheel zooms about mouse posi-
tion: Turn on this option if you want certain
graphics to remain visible in the view area
while you zoom into it using the mouse wheel.
With this option turned on, the pointer position
is used as the zoom center, and the graphics
near it will remain visible regardless of the
magnification level.

18.4 “View and Display” 
Preferences

18.4.1 Grid and Snapping
• Snap to nodes: Turn on this option to enable

node snapping in the file.
• Snap to guides: Turn on this option to enable

guide snapping in the file.
• Show guides: Turn off this option if you want

to hide the guides in the file.
• Snap to grid: Turn on this option to enable

grid snapping in the file.
• Show grid: Turn on this option to show the

grid in the file.
• Grid spacing: The default grid spacing is 36

points, but you can choose a value in the range
of 1 to 360 points.

18.4.2 Display Quality
• Path, Wireframe and Preview: The default

option is “Preview”, but you can change it to
“Path” or “Wireframe”. For more details, see
Section 5.7.7.
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• Greek limit: The default greek limit (the min-
imum pixel size below which text objects will
be shown as gray lines) is 10 pixels, but you can
choose a value within the range of 1 to 100 pix-
els.

18.4.3 Other Settings
• Ruler unit: The default unit for the rulers is the

inch, but you can choose to use millimeters,
centimeters, picas or points. If you want to use
this setting for all files as well, enable the “Set
as Default” option.

• Show printable area: Turn off this option if
you do not want to see the actual paper size and
printable area in the document window.

• Set as default: Turn on this option if you
want the settings at the left hand side of the
“View and Display” page to be used in all files
as well as the current one.

18.4.4 Display Options
• Show selected object nodes: Turn off

this option if you do not want the nodes of paths
to be shown even when the paths are selected.
The paths themselves are still highlighted. This
option is also available directly from File >
Options.

• Show resize handles: Usually, resize han-
dles are shown around an object selection, so

that you can scale, rotate and shear objects.
Turn off the “Show resize handles” option to
hide them.

• Display transparency: Turn off this option
if you want all paths in the view area to be
shown as if they are 100% opaque. Use this
option to check how the picture will look if
exported to a format that does not support trans-
parency.

• Flip view synchronizes view parame-
ters: Turn on this option if you want view
parameters (e.g., magnification level, document
frame etc.) of opened documents to be made the
same when you flip through them.

• Onion skin opacity: The higher this value,
the less clearly the objects from the adjacent
opened document can be shown through.

18.4.5 Context Menu Items
• Right-clicking in the view area (or Ctrl+click-

ing on Macintosh) will bring up a context menu
with activated commands that are relevant to
the current selection. This part of the
“Preferences” dialog lets you customize the
context menu. Commands are grouped into cat-
egories according to function, e.g., the “Object”
category includes commands such as “Lock
Object”, “Unlock Object”, “Export As Image
File” etc. Choose the command categories that
you want to include in the context menu.

18.5 “Print, Save and 
Export” Preferences

18.5.1 Print/Export
• Refit curves to output paths: Turn on this

option if you want to fit smooth curves to the
resulting stroke shapes exported to an external
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format or for printing. Fitting smooth curves
reduces the number of nodes but may introduce
a slight distortion to the output shapes.

• Split long path (PostScript): Turn on this
option if you want to split long, complex paths
when printing or exporting a file.

• Path quality: By default, the “Best” option is
used, but you can choose the “Draft” or the
“Normal” option.

• Bitmap stroke vectorization: The default
number of levels used to vectorize bitmap
strokes in file exports is 3, but you can choose a
number within the range of 1 to 16 levels.

18.5.2 Native Format Save 
Options
• Binary format: Expression files are saved in

binary format. Turn off the “Binary format”
option if you want to save them in text format.

• Thumbnail: Each Expression file is saved
with a small image, which is shown in the file
opening dialog as a reference. Choose the
“Large” option for a larger image, or the “Off”
option to not save a thumbnail at all.

• Thumbnail image range: A thumbnail
image contains objects within the boundaries of
the paper frame. Choose the “Crop marks”
option or the “Objects bounding box” option if
you want to use these areas as the thumbnail
image area.

• Auto save: Expression periodically saves
opened files for backup purposes. This option

lets you choose how often (“Never”, “Seldom”,
“Normal”, or “Frequently”) this is done. For
more about auto-save files, see Section 5.1.1.

18.5.3 Clipboard
• AICB format: AICB stands for Adobe Illus-

trator Clipboard (see Section 17.5). When
copying and pasting to and from Illustrator and
other compatible applications, Expression can
make use of one of the AICB formats, the PDF
format or rasterize the graphics to bitmaps. The
AICB 3.0 format is compatible with Illustrator
4.0 and before, and the AICB 5.0 format is
compatible with Illustrator 6.0 and before. If
you have Illustrator 7.0 or later, you can use the
AICB 7.0 format to take advantage of the newer
features (e.g., RGB colors).

• Rasterization resolution: If you choose the
AICB format’s “Always rasterize” option, you
can choose the rasterization resolution as well.

18.6 “Keyboard Shortcuts” 
Preferences
To assign a new shortcut or to modify an existing
one, choose the menu command, tool group or tool
that you want. The currently assigned shortcut key
combination will be shown. To make a new assign-
ment, choose the combination of shortcut key and
modifier key that you want, and click “Define
Shortcut”.
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Menu Commands

File Menu
File > New: Opens a blank document.

File > Open: Opens a dialog to let you choose an
existing document to open.

File > Recent Files: Lets you choose an existing
document to open from the list of most recently
opened documents.

File > Close: Closes the current document, or, if it
contains unsaved modifications, asks if the docu-
ment should be saved before closing.

File > Save: Saves the current document, or, in the
case of an untitled document, opens a dialog to let
you specify the file name with which to save the
document.

File > Save As: Opens a dialog to let you enter a
new file name to be used for saving the current doc-
ument.

File > Save A Copy: Opens a dialog to let you
save the current document under a new name, and
then opens the new document without closing the
original one.

File > Revert To Saved: Reverses all modifica-
tions made to the current document to the state
when it was last saved.

File > Close All: Closes all opened documents, or,
in the case of documents with unsaved modifica-
tions, asks if those documents should be saved
before closing.

File > Import Bitmap: Opens a dialog to let you
choose an existing bitmap file to open.

File > Save As Bitmap: Opens a dialog to let you
enter a file name for the bitmap, and then opens
another dialog to let you choose bitmap settings.

File > Export > Illustrator Export: Opens a dia-
log to let you enter a file name for the Illustrator

file, and then opens another dialog to let you choose
settings for the export.

File > Export > Flash Export: Opens a dialog to
let you enter a file name for the Flash file, and then
opens another dialog to let you choose settings for
the export.

File > Export > EPS Export: Opens a dialog to let
you enter a file name for the EPS file, and then
opens another dialog to let you choose settings for
the export.

File > Export > PDF Export: Opens a dialog to let
you enter a file name for the PDF file, and then
opens another dialog to let you choose settings for
the export.

File > Document Setup: Opens a dialog to let
you specify the dimensions and orientation of the
paper frame for the current document.

File > Preferences: Opens a dialog to let you set
options and parameters related to general program
behavior, tool operations, display preferences,
export options and shortcut assignment.

File > Options: Lets you turn on and off certain
frequently used preference items.

File > Color Management: Opens a dialog to
let you choose color management settings, such as
color profiles and rendering intent.

File > Print: Opens the operating system’s print
dialog to let you specify a printer and related set-
tings, and then to open another dialog to let you
choose the resolution at which to rasterize the doc-
ument for printing.

File > Exit: Ends the Expression session.

Edit Menu
Edit > Undo: Reverses the last change made to the
current document.
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Edit > Redo: Reverses the last undo operation.

Edit > Cut: Copies the selected objects to the clip-
board, and deletes them from their original posi-
tion.

Edit > Copy: Copies the selected objects to the
clipboard.

Edit > Paste: Copies the clipboard contents to the
center of the current document.

Edit > Clear: Deletes the selected objects.

Edit > Paste In Front: Copies the clipboard con-
tents at the same position in the view area as the
original objects, but places them one step in front of
the currently selected object.

Edit > Paste In Back: Copies the clipboard con-
tents at the same position in the view area as the
original objects, but places them one step behind
the currently selected object.

Edit > Paste With Layer: Copies the clipboard
contents with their layers to the current document.

Edit > Duplicate: Duplicates the selected objects
and places them next to the original objects.

Edit > Clone: Creates a clone object from the
selected object.

Edit > Select All: Selects all unlocked objects in
the current document.

Edit > Deselect All: Deselects all objects in the
current document.

Edit > Invert Selection: Selects all formerly
deselected objects and deselects all formerly
selected objects.

Edit > Select By: Opens a dialog to let you specify
the criteria by which to select objects in the current
document.

Edit > Select Master: Selects the master of the
currently selected clone.

Edit > Crop Marks > Set: Shows a set of rubber
cross lines to let you drag out the crop mark area.

Edit > Crop Marks > From Bounding Box:
Creates a set of crop marks at the position of the
bounding box of the currently selected objects.

Edit > Crop Marks > Remove: Removes the set
of crop marks in the current document.

Edit > Set Ruler Origin: Lets you change the ruler
origin by clicking or dragging.

Arrange Menu
Arrange > To Front: Moves the selected object in
front of all other objects in the same layer.

Arrange > To Back: Moves the selected object
behind all other objects in the same layer.

Arrange > Up One: Moves the selected object
one object up in the same layer, i.e., moves the
object in front of the object originally in front of it.

Arrange > Down One: Moves the selected
object one object down in the same layer, i.e.,
moves the object behind the object originally
behind it.

Arrange > Group: Forms a group from the
selected objects.

Arrange > Make Warp Group: Forms a warp
group from the selected objects.

Arrange > Ungroup: Breaks up the selected
group.

Arrange > Repeat Last Transform: Applies the
session’s previous transformation to the selected
objects.

Arrange > Repeat Accumulated Transform:
Applies the session’s cumulative transformation to
the selected objects.

Arrange > Reset Transform: Reverts the
selected object to the state before any transforma-
tion was applied to it.

Arrange > Commit Transform: Multiplies the
transformation to the selected object to modify its
base geometry before removing the transformation
information.
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Arrange > Align > Top Edges: Aligns top
edges of the selected objects to the top edge of the
topmost object.

Arrange > Align > Bottom Edges: Aligns bot-
tom edges of the selected objects to the bottom edge
of the bottommost object.

Arrange > Align > Left Edges: Aligns left edges
of the selected objects to the left edge of the left-
most object.

Arrange > Align > Right Edges: Aligns right
edges of the selected objects to the right edge of the
rightmost object.

Arrange > Align > Vertical Centers: Aligns
vertical centers (horizontal axes) of the selected
objects to the selection’s original vertical center.

Arrange > Align > Horizontal Centers: Aligns
horizontal centers (vertical axes) of the selected
objects to the selection’s original horizontal center.

Arrange > Distribute > Top Edges: Moves
objects that are between the topmost and bottom-
most objects in the selection so that all top edges are
evenly spaced in the vertical direction.

Arrange > Distribute > Bottom Edges: Moves
objects that are between the topmost and bottom-
most objects in the selection so that all bottom
edges are evenly spaced in the vertical direction.

Arrange > Distribute > Left Edges: Moves
objects that are between the leftmost and rightmost
objects in the selection so that all left edges are
evenly spaced in the horizontal direction.

Arrange > Distribute > Right Edges: Moves
objects that are between the leftmost and rightmost
objects in the selection so that all right edges are
evenly spaced in the horizontal direction.

Arrange > Distribute > Vertical Centers:
Moves objects that are between the topmost and
bottommost objects in the selection so that all verti-
cal centers are evenly spaced.

Arrange > Distribute > Horizontal Centers:
Moves objects that are between the leftmost and

rightmost objects in the selection so that all hori-
zontal centers are evenly spaced.

Arrange > Stack > Upwards: Moves objects
that are above the bottommost object in the selec-
tion so that all objects are the same distance apart in
the vertical direction.

Arrange > Stack > Downwards: Moves
objects that are below the topmost object in the
selection so that all objects are the same distance
apart in the vertical direction.

Arrange > Stack > To The Left: Moves objects
that are to the left of the rightmost object in the
selection so that all objects are the same distance
apart in the horizontal direction.

Arrange > Stack > To The Right: Moves
objects that are to the right of the leftmost object in
the selection so that all objects are the same dis-
tance apart in the horizontal direction.

Objects Menu
Objects > Compound Object > Make:
Forms a compound object from the selected
objects.

Objects > Compound Object > Release:
Breaks up the selected compound object into indi-
vidual objects.

Objects > Clipper > Make With Top Path:
Forms a clipper group by using the top path in the
selection to clip other objects in the selection.

Objects > Clipper > Make With Bottom
Path: Forms a clipper group by moving the bottom
path in the selection to the top before using it to clip
other objects in the selection.

Objects > Clipper > Release: Breaks up the
selected clipper group into individual objects.

Objects > Text On Path > Attach Text:
Attaches the selected text object to the selected path
so that the text baseline follows the shape of the
path.
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Objects > Text On Path > Attach Area Text:
Attaches the selected text object to the selected path
so that the text flows within the boundaries of the
path.

Objects > Text On Path > Release: Separates
the selected path and the attached text into individ-
ual objects.

Objects > Guide > Make: Converts the
selected object to a guide.

Objects > Guide > Release: Reverts guides to
ordinary objects.

Objects > Bitmap > Create Bitmap: Lets you
drag out an area in the view area to form a new bit-
map object.

Objects > Bitmap > Auto Trace Bitmap:
Opens a dialog to let you specify settings for per-
forming bitmap tracing on the selected bitmap
object.

Objects > Bitmap > Export As Image File:
Export the selected bitmap object as an image file
in one of the supported image file formats. The bit-
map will be exported in its original untransformed
and unwarped state.

Objects > Effect Lines > Create: Generates a
set of effect lines across the selected paths or, in the
case of a single selected path, clones the selected
path and generate effect lines across the path and
the clone.

Objects > Effect Lines > Add Template
Path: Attaches the selected path to the selected
effect line group, so that all effect lines take on the
shape of the template path.

Objects > Effect Lines > Remove Template
Path: Removes the attached template path from the
selected effect line group, and reverts to using
straight lines as effect lines.

Objects > Unstructure: Converts the skeletal
strokes on the selected paths to individual paths.

Objects > Convert To Path: Converts the
selected text, ellipses, clones or effect line groups to
individual paths.

Objects > Reverse Path: Reverses the direction
of the selected paths.

Objects > Join Path > Virtual: Brings the ends
of the selected open paths together by moving the
nodes at those ends to the same position.

Objects > Join Path > Real: Joins the two
selected open paths into one path.

Objects > Close Path > Virtual: Brings the two
ends of the selected open path together by moving
the nodes at the ends to the same position.

Objects > Close Path > Real: Joins the two
ends of the selected open path to form a closed path.

Objects > Blend Paths: Opens a dialog to let
you specify settings for blending the selected paths.

Objects > Smooth Path: Opens a dialog to let
you specify the smoothness value to be used on the
selected paths.

Objects > Stroke Width > Increase: Increases
the width of the selected strokes by 20%.

Objects > Stroke Width > Decrease:
Decreases the width of the selected strokes by 20%.

Objects > Soft-Edge Width > Increase:
Increases the soft-edge width of the selected paths
by 20%.

Objects > Soft-Edge Width > Decrease:
Decreases the soft-edge width of the selected paths
by 20%.

Objects > Remove Reference Vector:
Removes the reference vector and hence any orien-
tation information from the selected paths.

Objects > Set Opacities: Opens a dialog to let
you choose stroke and fill opacity values.

Objects > Arc Mode > Open Arc: Causes the
selected ellipse to take the form of an open arc.
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Objects > Arc Mode > Pie: Causes the selected
ellipse to take the form of a sector.

Objects > Arc Mode > With Chord: Causes
the selected ellipses to take the form of an arc with
a straight line joining the two ends of the arc.

Objects > Node Continuity > Symmetrical:
Causes a tangent handle of the selected node to
always be at 180 degrees to and the same length as
the other tangent handle of the node, when the other
tangent handle is subsequently edited.

Objects > Node Continuity > Smooth:
Causes a tangent handle of the selected node to
always be 180 degrees to the other tangent handle
of the node, when the other tangent handle is subse-
quently edited.

Objects > Node Continuity > Angle
Locked: Causes a tangent handle of the selected
node to always be at the same angle to the other tan-
gent handle of the node, when the other tangent
handle is subsequently edited.

Objects > Node Continuity > Uncon-
strained: Causes a tangent handle of the selected
node to be unaffected by any subsequent movement
of the other tangent handle of the node.

Objects > Node Marking > Set: Marks the
selected nodes as more preferred candidates over
unmarked nodes for matching for interpolation dur-
ing path blending.

Objects > Node Marking > Clear: Reverts the
selected marked nodes to ordinary nodes.

Objects > Path Operations > Unite: Forms a
path whose shape is made by merging the fill areas
of the selected paths.

Objects > Path Operations > Front Minus
Back: Forms a path whose shape is made by cut-
ting the fill area of the lower of the selected paths
from that of the upper path.

Objects > Path Operations > Back Minus
Front: Forms a path whose shape is made by cut-

ting the fill area of the upper of the selected paths
from that of the lower path.

Objects > Path Operations > Intersection:
Forms a path that is the shape of the overlapping
area of the selected paths.

Objects > Path Operations > Divide: Forms a
number of paths by cutting up the fill areas of the
selected paths where they intersect.

Objects > Warp Mesh > Reset Grid: Reverts
the selected warp group or bitmap object to the state
before any warping was applied.

Objects > Warp Mesh > Increase Resolu-
tion: Increases the resolution of the warp mesh of
the selected warp group or bitmap.

Objects > Warp Mesh > Decrease Resolu-
tion: Decreases the resolution of the warp mesh of
the selected warp group or bitmap.

Stroke Menu
Stroke > New Stroke Definition: Opens a
stroke window containing the selected paths for
you to define them as a new stroke.

Stroke > Delete Stroke Definition: Opens a
dialog to ask if the selected stroke definition should
be deleted from your hard disk.

Stroke > Edit Stroke Definition: Opens a stroke
window containing the stroke that is applied to the
selected path for you to edit the stroke definition.

Stroke > Add Stroke View: Adds a stroke view
to the stroke window for creating a multi-view
stroke.

Stroke > Remove Stroke View: Deletes the
current stroke view from the multi-view stroke.

Stroke > Define Stroke: Opens a dialog to let
you enter a stroke name and specify other settings
for the vector stroke currently being edited.

Stroke > Define Bitmap Stroke: Opens a dialog
to let you enter a stroke name and specify other set-
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tings for creating a bitmap stroke from the selected
bitmap object.

Stroke > Set As Quick Stroke: Opens a dialog
to let you assign a quick stroke number to the
selected stroke.

Stroke > Anchor > To Start: Anchors the
selected nodes to the starting point of the stroke
definition.

Stroke > Anchor > To End: Anchors the selected
nodes to the ending point of the stroke definition.

Stroke > Anchor > Free: Releases the selected
nodes in the stroke definition from anchoring.

Stroke > Repeating > Make: Makes the
selected paths repeatable in the stroke definition.

Stroke > Repeating > Release: Makes the
selected paths not repeatable in the stroke defini-
tion.

Stroke > Reset Stroke Shear: Reverts the shear
angle of the selected stroke to zero degree.

Stroke > Reverse Ribbon Folds: Reverses the
direction in which the selected strokes (which are
currently in ribbon mode) appear to be folding.

Stroke > Set Ellipse Ratio: Opens a dialog to let
you specify the ellipse ratio for the selected strokes,
which are currently in elliptical mode.

Stroke > Set Stroke Twist: Opens a dialog to let
you specify how many turns you want to twist the
selected strokes.

PS-Plugins Menu
PS-Plugins > Set Plugins Folder: Opens a dia-
log to let you specify the path under which you
want Expression to search for plugins.

View Menu
View > Show > Grid: Toggles between showing
and hiding the grid in the current document.

View > Show > Guide: Toggles between show-
ing and hiding the guides in the current document.

View > Show > Layer Mini-List: Toggles
between showing and hiding the Layer mini-list in
the current document.

View > Snap > To Grid: Toggles between
enabling and disabling snapping to the grid in the
current document.

View > Snap > To Nodes: Toggles between
enabling and disabling snapping to the nodes in the
current document.

View > Snap > To Guides: Toggles between
enabling and disabling snapping to the guides in the
current document.

View > Display Quality > Path: Displays the
paths in the current document as skeletons only.

View > Display Quality > Wireframe: Dis-
plays the paths in the current document as outlined
shapes plus the skeletons.

View > Display Quality > Preview: Displays
the paths in the current document in full, including
all stroke and fill attributes.

View > Display Quality > Better Preview:
Displays bitmap objects by using pixel interpola-
tion and better handling of overlapping regions.

View > Onion Skin > Off: Turns of onion skin
display.

View > Onion Skin > Show Previous: Lets
objects from the previous document be shown in
the current document as a faint image for reference.

View > Onion Skin > Show Next: Lets objects
from the next document be shown in the current
document as a faint image for reference.

View > Turn Off Highlights Temporarily:
Hides highlights on selected objects temporarily to
give an unobstructed view of the current object
selection.

View > Zoom In: Zooms to a higher magnifica-
tion level.

View > Zoom Out: Zooms to a lower magnifica-
tion level.
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View > Zoom On Selection: Zooms to the high-
est magnification level under which the selected
objects can be fully shown.

View > View All: Zooms to the highest magnifi-
cation level under which all visible objects in the
document can be fully shown.

View > Actual Size: Sets the magnification level
to 100%.

View > Center View: Shows the document with
the document frame in the center of the view area.

View > Rotate Clockwise: Rotates the current
document 22.5 degrees in the clockwise direction.

View > Rotate Counterclockwise: Rotates the
current document 22.5 degrees in the counterclock-
wise direction.

View > Reset View Rotation: Reverts the cur-
rent document to its original, upright position.

View > New View: Opens a new window of the
current document.

View > Edit Warp Group: Opens a window con-
taining the contents of the selected warp group, for
you to edit the contents without ungrouping.

Window Menu
Window > Status Bar: Toggles between showing
and hiding the status bar.

Window > Toolbox: Toggles between showing
and hiding the Toolbox palette.

Window > Paint Style: Toggles between show-
ing and hiding the Paint Style palette.

Window > Attributes: Toggles between showing
and hiding the Attributes palette.

Window > Font: Toggles between showing and
hiding the Font palette.

Window > Object List: Toggles between show-
ing and hiding the Object List palette.

Window > Variable Width: Toggles between
showing and hiding the Variable Width palette.

Window > Strokes: Toggles between showing
and hiding the Strokes palette.

Window > Transformation: Toggles between
showing and hiding the Transformation palette.

Window > Item List: Toggles between showing
and hiding the Item List palette.

Window > Colorize: Toggles between showing
and hiding the Colorize palette.

Window > Effect Lines: Toggles between show-
ing and hiding the Effect Lines palette.

Window > Flash Button: Toggles between show-
ing and hiding the Flash Button palette.

Help Menu
Help > User Guide: Opens the Expression man-
ual.
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Tutorial 1: Easy Paths and the B-Spline Tool

Creating paths is one of the most frequently per-
formed tasks in the picture creation process, and
Expression 3 provides a number of different tools
for it. If you are a veteran vector-based drawing
software artist, you would probably be familiar
with the more traditional tools like the Freehand
Pen tool and Bezier Pen tool.

Here we will introduce the B-Spline tool.

The B-Spline tool is a very versatile path construc-
tion tool which is good for almost any kind of paths,
smooth or sharp cornered, straight-edged or curved.
If you are new to vector-drawing software and have
not got too used to the Bezier Pen tool, we would
particularly recommend this tool to you.

The use of the tool is easy — just click, click, click
to place the nodes, then hit Return/Enter and you
have the path. If you do not like the nodes you just
placed, you can hit the Backspace or Delete
key to remove the last node placed. To introduce a
sharp corner, hold down the  key when plac-
ing a node.

The only thing that may need some getting used to
is that the B-spline nodes (control points) are gener-
ally not positioned on the paths themselves. So
when you want to draw a shape, you have to place

the nodes somewhere around the shape you are try-
ing to construct.

To get a feel of how the nodes control the shape of
the path, try to create a closed oval shape using dif-
ferent numbers of B-spline nodes:

Using three nodes gives a somewhat triangular
shaped oval; using four nodes gives a smoother
oval and using six nodes gives a very round circular
shape. You can, of course, place more than enough
nodes to create curves, but that would make it more
difficult to edit the paths. In general, placing nodes
to form angles of about 120° gives a reasonable bal-
ance between node economy and shape control.

Experiment a bit and try to create all kinds of com-
plex shapes using the B-Spline tool. You will soon
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find it an indispensable tool, when you are using a
mouse to create paths.

A further note on shape control: when you want to
create a bend from a straight portion, you should
add an extra node before your bend begins. Other-
wise, the nodes at the bend will influence the shape
of your entire previous straight portion. Alterna-
tively, add a corner before the bend begins.
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Tutorial 2: Effective Use of Layers

When you are composing a picture, you would
often like to prepare a layout of your composition
first, and then work on various parts of your compo-
sition. Layering your Expression picture would
help you construct your picture with such an
approach.

Here we will draw a picture of a dish on a table. We
begin by creating a layer called “Layout” for plan-
ning out the composition and as a reference for fill-
ing in the details. Of course you can choose
whatever name you like. (You can also refer to Sec-

tion 11.6 of the manual for more information and
options about creating and naming layers.)

We choose the basic stroke and draw a few simple
lines as a guide for our composition. We then make
the lines semi-transparent (using the Opacity slid-
ers, as described in Section 8.7 of the manual) and
lock the entire layer, so that these lines will not
affect our drawing process. This layer is purely
used for planning, and will be made invisible or
even discarded when the final composition is done.
Depending on your drawing habit, you can draw a
more elaborate guiding layer with colors and
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painted areas, or just a few curves for partitioning
your drawing space.

We then create another layer called “Dish”. We
move this “Dish” layer below the “Layout” layer so
that the reference lines are always visible and on
top.

We use the B-Spline tool to draw the outline of the
dish and give it a bluish fill and a bold watercolor
outline.

On the dish, a simple flower pattern is drawn and
defined into a repeating stroke. (For more details on
defining strokes and making strokes repeatable,
refer to Chapter 10 of the manual.) The flower pat-
tern is then drawn on the dish using the B-Spline
tool again.

We add a curve, using the B-Spline tool, for a shad-
ing on the disk to suggest the depression, and add
another curve with a white stroke for the highlight.

The “Layout” layer can be hidden to give an unob-
structed view of the finished dish.

Similarly, we create another layer called “Fish” and
draw the fish skeleton. When we draw the bones,
we rotate the drawing paper first, to make it more
convenient to draw the freehand curves for the
bones. We use the “Rotate Clockwise” and “Rotate
Counterclockwise” commands from the View menu
to rotate the paper. You can also define your own
keyboard shortcuts for these commands.

After we are done with the dish and the fish, we
make all layers except the “Layout” layer invisible
by using +click on the Lock icon in the Layer
mini-list.

We create one more layer, “Table”, for the table
cloth. We use a simple red stroke to draw the



Tutorial 2: Effective Use of Layers 169
stripes. The stripes are set to about 40% opacity for
a nice color mix at the intersections of the strokes.

We then make all layers visible again (except the
“Layout” layer), to see the overall composition.

We then add the finishing touches. Lock all layers
except the table cloth and draw another ellipse with
a black fill for the shadow. We set the opacity of the
black ellipse to about 15% and give it a thick
soft-edge. Adjust the size a bit by transforming it
using the Object Select tool or resize handles. We
add yet another layer called “Fish Shadow” and

move it between the “Fish” and “Dish” layers. We
draw some freehand curves using the Bitmap Air-
brush stroke for the shadow of the fish bones. More
thin white strokes are also added to the top of the
bones as highlight. Again we rotate the paper when
we draw the freehand curves.

Finally we use the Edit > Crop Marks > Set com-
mand to drag out a rectangular region for rasteriza-
tion or printing.
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Tutorial 3: Defining Vector Skeletal Strokes

Skeletal Strokes is core to Expression. You will find
that it is actually very easy to create your own
unique stroke. A single drag using the Stroke Defi-
nition Box tool on top of some graphics objects will
turn them into a new skeletal stroke.

This tutorial introduces the more advanced controls
over your vector strokes. Anchoring allows you to
lock certain parts (at the node level) of your stroke
so that they will not be stretched along long paths.
Making certain parts repeatable allows those parts
of the stroke to populate themselves along a path.

We will first define a fancy arrow stroke. Arrows
and pointers are often useful in graphic design. You
may find it handy to define a few signature arrows
of your own.

We draw the arrow head shape using the B-Spline
tool. Because of its symmetrical shape, we draw
only one half of it. Then we use the Mirror tool to
set the mirror center somewhere at the base of the
shape. Next, by holding down the  key, we

constrain the mirror plane to the horizontal. Then,
also hold down the  key to make a duplicate of
the upper shape instead of just transforming it.

Next, we select both halves and use the Objects >
Join Paths > Real command to join the paths into
one. If you prefer the path to be a closed shape, you
can further use the Objects > Close Path > Real
command to close it.

We create the tail of the arrow in a similar way and
add various decorations to the arrow.

Now we are ready to define it into a stroke. Use the
Stroke Definition Box tool to drag out a box with
the axis placed along the arrow. Note that it is OK
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even if some objects extend beyond the definition
box.

On releasing the mouse, a new
stroke definition window is
opened. You can just click the
Define Stroke button to define it into a simple
stroke, but here, we will do more than that. We will
control the arrow head and tail and lock their aspect
ratio. We do this by anchoring them using the
Anchor tool.

The Anchor tool works like a node selection tool.
We click on the arrow head to select the entire
object. Then we drag out a small marquee to select
the first few nodes at the stem of the arrow. We are
anchoring those nodes to make sure that they will
be locked together with the arrow head shape, so
that the gap between the arrow head and the stem
will not be stretched.

To anchor those nodes, we
click the Anchor To Start
button at the right side of the
Toolbox palette.

We do the same for the arrow tail. The few decora-
tive shapes at the tail are also anchored, together
with the arrow tail, to the end of the stroke.

If we define the stroke now, the head and tail part
will be locked and the body will be stretched nor-
mally. Of course, you can also anchor the few dec-
orative shapes in the body of the arrow to make
them non-stretching. But here, we will make them
repeatable.

To do this, we use the Repeat tool.

The Repeat tool works like an object selection tool.
You can specify certain objects in a stroke as a
whole to be repeated, but you cannot specify indi-
vidual nodes to be repeated.
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We select the decorative objects in the body and
click the Make Repeating button to make them
repeating.

However, the stroke would not look good if we
define it like this. The repeating range is from the
start of the stroke to the end. This means that the
repeating unit will consist of the decorative shapes,
plus the empty space near the head and the empty
space near the tail. If you make it repeat like this,
the repeating decorative units will be separated by
spaces.

So we adjust the repeating range by dragging the
two bars tighter around the decorative shapes.

Note that the repeating range now not only controls
the size of the repeating unit but also the starting
and ending fractional position of the repeating por-
tion. Because the arrow head is anchored, we want
the starting point of the repeating portion to be
locked with the arrow head as well, so that the dec-
orations will start repeating right after the anchored
arrow head. We do this by anchoring the repeating
range — by holding down the  key and click-
ing the repeat handle. An anchor icon will be shown
indicating that the repeating range start point has
been anchored.

You can anchor the ending point of the repeating
range in the same way. Here, we leave it the way it
is, because it looks better, and so that you can see
the difference with and without anchoring the
repeating range limits.
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Tutorial 4: Strokes with Multiple Repeating Parts

Repeating parts are very useful for creating varia-
tions to an expressive stroke. If all graphics objects
in a stroke were to repeat in the same way, the
stroke would be a static repetitive pattern. By con-
trolling different objects in a stroke differently, the
resulting stroke will look different on every stroke
application.

To demonstrate this idea, we draw five
wave-shaped paths, each with a slightly different
wavelength. These paths are then defined into a
stroke.

If we make this stroke repeat, it will have a simple
repetitive pattern.

Now we select each of the wavy paths and give
each of them a different repeating range.

The result is much more intriguing and each stroke
drawn will have a unique complex pattern.
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Strokes with both stretching and repeating parts
often give the most interesting results.

Here we use a few embossed and reflec-
tion-mapped circular shapes with a simple water-
color stroke at the back to define a stroke. The
watercolor stroke is left to stretch but each circular
path is set to repeat with a different range.

The resulting stroke can be used for a bubble gum
advertisement.
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Tutorial 5: Variable Width without Pressure

A pressure sensitive pen and tablet is convenient for
drawing freehand strokes with varying width, but it
is by no means the only way to achieve variable
width strokes. Let us see how the Variable Width
palette can be used not only as a substitute for the
pressure sensitive pen and tablet, but also for creat-
ing some interesting results.

Suppose we have drawn a stroke using the B-Spline
tool (or the Freehand Pen tool) and the mouse.
When we select the stroke and look at the Variable
Width palette, a straight horizontal line (or, flat pro-
file) there indicates that the stroke has constant
width throughout.

To make some variations, click the  button a few
times. Each click will add a node to the profile, and
you can drag the nodes to form the shape that you
want.

In fact, you can create all sorts of shapes just by
using different profiles with the same stroke. As an
example, let us take the originally unexciting rect-
angle stroke (the stroke at the left in the picture
below). Just by applying different width profiles to
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the same stroke, we can get some interesting varia-
tions.

For more possibilities, let us apply the above width
profiles to the strokes below.

Here are the results.

The Variable Width is very convenient for quickly
tweaking the appearance of strokes, without the
need to edit stroke definitions or draw new paths.
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Tutorial 6: Scraping and Lifting Effects

Scraping and color lifting are commonly employed
drawing techniques for creating subtle effects by
revealing the underlying colors below painted
areas.

Expression 3 is the first vector-based software pro-
viding general support for this kind of effects, using
the Eraser mode. The Eraser mode can be applied to
any graphics object, yet allows the editability of the
scraping paths and strokes to be maintained. Here
we will demonstrate the use of such techniques in
creating artwork.

One point you should bear in mind when using this
technique in Expression 3 is that the erasing part is
performed through the complete layer, revealing
the underlying layers, if any. This is slightly differ-
ent from scraping on real paints, where you can
scrap through a layer of pigments as thin as you
want, or dig all the way down to the canvas (or even
cut through it!). If you want to achieve a multi-level
erasing effect, you should create different layers
and erase the layers individually.
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We are going to draw a picture of a fish in negative,
somewhat like a relief-print. We begin by creating a
navy blue rectangle in a layer called “scratch”.

We give it a soft-edge with fringe texture for a more
earthy appearance.

The soft-edge is set by adjusting the Soft-Edged
Width meter in the Paint Style palette to a positive
value. The larger the value, the wider the soft-edge
will be. By pressing the button besides the
Soft-Edged width meter, a Fringe Texture dialog
will be displayed for you to choose a fringe texture,
instead of the smooth transparency gradient, for the
soft-edge. We choose a nice texture and we also
choose the “Stretch to fit” option so that the fringe
texture will be stretched along the edge to give a
blurry, fibered appearance. (Normally, if the
“Repeating” option is chosen instead, the fringe
texture is repeated along the path.)

We then create another layer, called “hilights”, and
use the s01 stroke (the default skeletal stroke) to
make a rough sketch of the fish shape we are going
to draw. We colorize the stroke to white and set the
opacity of the stroke to about 20% to make the lines
more subtle.

When we are done with the sketch, we lock the
“hilights” layer and return to the “scratch” layer to
start scraping. To make the process more conve-
nient, we lock the navy blue rectangle in the Object
List palette first. We then use various different
strokes, some coarser and some softer, to do the
scraping. Of course, we have to choose the Eraser
mode for the strokes, otherwise they will simply be
painted onto the navy-blue rectangle.

The Eraser mode can be accessed from the Blend-
ing mode popup button in the Paint Style palette.
When the Erase mode is applied to a graphics
object, the color of the object no longer matters;
only its transparency value affects the strength of
the eraser. The more opaque the object, the more it
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will reveal the colors from the underlying layers.
Therefore you can use the Opacity sliders to control
how much you want to scrap through the current
layer you are working on.

We continue to draw the fish using various strokes,
all in Eraser mode. The strokes appear to be white
because we have no underlying layer and the back-
ground color (i.e., white) is revealed.

The white parts are actually transparent, and this
becomes apparent if you draw something below
that layer, which is exactly what we are going to do.
However, instead of drawing underneath that layer,
we will draw on top of it first, and then move the
new drawings below. We create another layer called
“undercolor” and paint various colored strokes in it.
To avoid accidentally touching other layers, we

lock the other layers before we start painting the
colors in the new layer.

We can paint rather freely, without worrying about
painting outside the white parts. This is because this
entire layer will be moved below the “scratch” layer
later, when only the scraped area will show through.
When we are done painting the colors, we move the
layer to the bottom by dragging it down in the Layer
mini-list.

Then we add the few finishing touches on the
scraped layer and our fish picture is completed. We
leave the semi-transparent white sketching lines
there because they seem to make the picture look
richer.
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Tutorial 7: Personal Expressive Styles

The charm of a picture comes always
from the artist. Expression is just a tool
for the digital medium. It is all up to you
to make your own expression. Here,
award-winning veteran artist Walter van
Lotringen has created a series of cats
using Expression. Each cat has its own
unique personality, from adorable to
shaggy and stately arrogant. Each pic-
ture also shows a different mood. The
richness and personal expression is con-
veyed through bold and fluid freehand
strokes created using a pressure sensi-
tive pen and tablet.

Walter used only simple vector strokes
throughout the pictures, yet the overlap-
ping semi-transparent strokes give a
pleasant richness so fresh that it is a sur-
prise to realize that the picture structures
are after all so clean and simple. In addi-
tion, the pictures are always crystal
sharp when rasterized to any resolution.
(The original Expression picture for the

black-and-red “Character” cat is available in the
“Samples” folder for closer study.)

In the handling of the painted areas, Walter likes to
fill up areas with strokes in a painterly way instead
of creating fills. This gives each area its unique tex-
ture.

All cat pictures Copyright © 2002-2003 Walter van 
Lotringen. walt@emotive-image.com
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You can also find your own favorite way to handle
your pictures and create your unique personal
styles.
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Tutorial 8: Blending Mode Surprises

Blending modes specify how colors in a graphics
object should be mixed with the background. Draw-
ing in different blending modes creates unusual
changes that are difficult to achieve though simple
transparency.

This picture titled “Elephant in Light” by Moriyuki
Sato uses the Light mode extensively. The Light
mode mixes colors additively, similar to the results
you see when light beams are projected onto a sur-
face. Each stroke or any graphics object created in
Light mode brightens up the picture a bit. This is
why this elephant picture has achieved such a lumi-
nous appearance.

Blending modes can be applied to any graphics
object using the Blending Mode popup button in the
Paint Style palette.

You cannot, however, draw a picture entirely in
Light mode. Drawing anything in Light mode on a

Elephant in Light. Copyright © 2002-2003
Moriyuki Sato. http://www.amy.hi-ho.ne.jp/satom/
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white background will result in just whiteness
because you cannot brighten whiteness any further.
Therefore Moriyuki started the picture with a base
in solid color, with a paper texture applied. Colorful
dabs are added to it to form the foundation for the
elephant composition.

In fact, many of the strokes in this base layer are in
other blending modes. Some are in Color Dodge
mode for “lifting” certain colors; some are in Color
Burn mode for darkening certain colors.

All blending modes, except the special Eraser
mode, are purely artificial color mixing functions.
The Multiply mode effect somewhat resembles pig-
ment-based color mixing effects, and the Light
mode effect resembles the mixing of projected
lights on a screen. The other blending modes do not
have natural analogies or any physical foundation,
so you may find yourself surprised at the resulting
colors when you begin experimenting with them.

To make sense of blending modes, it is best to do
some experiments yourself. Try to draw a few dabs
of various colors, then draw a stroke across the dabs
using various blending modes and in different col-
ors. Here we try a dash of green across a few strokes

in four colors at the background, using the Color
Dodge and Light modes.

The behaviors of the two modes are quite similar:
both intensifies the green component of the colors.
The main difference is the strength and linearity of
this intensification. The Color Dodge mode intensi-
fies the colors more significantly while the Light
mode intensifies them more smoothly. The
Brighten mode can also be used to intensify the
color components based on the foreground color,
except that it operates in a maximizing manner,
where the foreground component is used if its
intensity is higher, and if not the background com-
ponent is not changed. Since the green component
of the stroke in the foreground is rather dim, apply-
ing it in the Brighten mode will produce little
change.

You will probably find that the other more dramatic
blending modes, like the Color Burn and Difference
modes, are actually easier to grasp after a little
experimenting.

Color Dodge vs. Light mode.

Color Burn and Difference modes.
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Tutorial 9: Dry Brush Effects

Dry brush produces coarsely textured strokes and is
often used to convey a rough and earthy touch.
There are different ways that you can create these
dry medium effects in Expression 3.

You can scan in some real pencil, crayon or dry
brush strokes, and define them as bitmap strokes.
However, this simple method may not be the most
effective approach, because on stretching the
strokes along paths, the original grains of the stroke
texture will be elongated and the characteristics of
the original media may be lost. If you choose to
define pencil or crayon strokes from scans, you
should at least try to make the strokes repeatable,
with an anchored head and tail at the two open ends.

Even if the textured stroke image you have scanned
in is highly random, simply defining it into a repeat-
ing bitmap stroke can still make the joints between
repeating units rather conspicuous.

To define a nice seamlessly repeating stroke from a
scanned image requires some preprocessing. You
may want to use some image touch-up software like
Photoshop. Here we demonstrate how to create a
repeating pencil stroke with anchored head and tail
sections.

We start with a scan of a real waxy pencil stroke on
rough parchment. To create a seamlessly repeating
stroke, we will be splitting the image into three or
more sections: head, body and tail. If and after such
a stroke is defined and applied, the body section
will be repeated zero or more times. We must make
sure that one end of the body fits well against the
other end, and fits also with the head and tail sec-
tions. As for the head and tail sections, they have to
fit against each other too.

To achieve this, we have to find splitting points that
have relatively similar features and then touch-up
the image a bit to smooth out the regions around the
splitting points. To keep this demonstration simple,
we will prepare a stroke with a one-part repeating
body.

We find two splitting points which are of similar
width, and partition the image into three sections.
To start making the head section (the left end) and
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tail section (the right end) fit seamlessly, we first
move the two sections together.

Although the two sections, which are of similar
width, fit reasonably well against each other, there
is a quite visible discontinuity at the boundary. We
use the Rubber Stamp or Clone tool in Photoshop or
other programs to copy the neighboring texture
onto the boundary to remove any visible disconti-
nuity.

Now we move the head and tail sections back to the
two ends of the body section. To prepare the body
section, we can paint the two ends of the body sec-
tion to make them fit against the modified head and
tail, but then the two ends may not fit very well with
each other. One simple way to achieve both objec-
tives at the same time is to duplicate a small section
from the head section and put it at the body section
at the end close to the tail, and likewise, duplicate a
small section from the tail section and put it at the
body section at the end close to the head. This guar-
antees that the body section fits perfectly against
the head and the tail, and also with itself.

Of course, we still need to clean up the internal part
of the body section a bit, after pasting the small sec-
tions from the head and tail. Because we are now
working on the inner parts of the body section, we
do not have to worry about misfits any more.

We then import the finished image into Expression
3 and define it into a bitmap stroke using the Stroke
> Define Bitmap Stroke command. We specify the
pixel length of the head and tail sections and set the
body to “Simple repeat”. The pixel lengths of the
head and tail sections should be taken from your
image touch-up program. We also choose “Gray-
scale” to make the white background transparent.

The resulting stroke will give a very realistic pencil
effect, if used with high transparency variability
and low width variability.

If you want to create a really high quality textured
stroke, you may want to divide the body part into
more self-repeatable sections that fit seamlessly
against each other. This may sound difficult, but if
you start with the head and tail sections and con-
tinue to prepare each body section in the same way,
you will get a multi-part repeating bitmap stroke.
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Since the body sections will be applied in random,
the appearance of the resulting strokes will be very
organic.

The above approach can be used to define any kind
of bitmap strokes, from a photograph of a centipede
to ropes and chains.

Another effective way to create dry brush effects in
Expression is to use paper textures. Paper textures,
when used together with smooth watercolor strokes
or airbrush-like strokes, give the best results. The
stack of farm animals at the beginning of this tuto-
rial is drawn using watercolor bitmap strokes
together with various paper textures applied at dif-
ferent scale. To create a rich and complex chalky
appearance, you can overlay different paper tex-

tures at different scale. The following picture is
drawn this way.
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Tutorial 10: Comics and Effect Lines

Expression 3 is very suitable for
creating crisp graphics and illus-
trations, especially with the versa-
tility of vector skeletal strokes. It
is also a convenient tool for draw-
ing comics and Manga (Japanese
comics). Professional comics and
manga artists often use complex
sets of stylish strokes to enhance
the action or atmosphere of a
scene. The Effect Line functions
of Expression 3 is particularly
suitable for creating these stroke
effects. You can refer to Chapter
13 of the manual for more details
on the use of effect lines.

We are going to demonstrate the use of
effect lines with this picture of a robot drawn in
comics style. Although this picture is drawn in
color, the techniques and line styles are similar to
those often employed in black and white manga.

We use mostly vector strokes for the outlines of the
robot figure.

The classic strokes s01, s02, s03 and s07 are well
suited for the comics drawing style. We also use
some specially defined strokes to add variety to the
line styles. The use of rougher strokes on complex
hatching could be distracting, but for the clean and
simple design of this robot character, some stylish
strokes would enrich the final picture.

We create
Effect Line groups to render the shading of the
robot’s eyes and one side of the robot’s head.

Create any two paths as the starting and ending
edges for the effect lines, and click the Create
Effect Lines button in the Effect Lines palette. The
effect lines so created will be straight lines. We then
draw a curve to be used as a guide for the effect
lines. Select the curve and the entire effect line
group, and click the Add Template Path button. A
template path will be copied into the effect line
group and the original curve can be discarded. We
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then adjust the shapes of the effect lines by editing
the template path and the starting/ending edges to
make the effect lines look nice. The End Edge Vari-
ation slider is also used to make the effect lines less
monotonous. The straight effect lines on the side of
the robot head are made in the same way.

For the white radial lines in the background, we
turn on the “Focus to a Point” function to make
make the effect lines radiate to/from the adjustable
focus point. We change the color of the effect lines
to white to make them resemble rain.

Comics artists often use manual screening to create
shading and special effects. Expression can be used
for creating and applying “screens” too. The star
shape in the robot picture is created using the
B-Spline tool and with the “Break At Joints” option
in the Attributes palette turned on.

The star shape is filled with a screen of red dots on
a yellow background. The screen is a pattern
defined in Expression. It is often useful to turn on
the grid for precise patterns like this. It is not neces-
sary to pre-specify the color into the pattern. You
can use the Colorize palette to change the colors of
a pattern after it has been applied to a graphics

object. The pattern we defined is actually quite
large in scale. When applied to the star shape, it
looks unnatural. We use
the Transform Fill tool to
scale the pattern to a
suitable density. You can
rotate it too, if another
screen orientation is
needed.

A final note. Effect lines in Expression 3 are not
designed purely for comics effects. You can make
complex interference patterns and other interesting
effects. Effect lines are here for you to explore.
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Color Plates

The RGB model.
(Section 4.1.1, page 17)

The HSL model.
(Section 4.1.2, page 19)

The CMY model.
(Section 4.1.3, page 19)

A reflection map.
(Section 8.5.5, page 73)

Colorization.
(Section 8.16, page 85)

A hand-painted reflection map.
(Section 14.6.2, page 131)
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Blending modes. 
(Section 8.9, page 76)

Normal mode.

Multiply mode.

Light mode.

Color Dodge mode.

Color Burn mode.

Brighten mode.

Darken mode.

Difference mode.
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Index

A
Absolute colorimetric intent 22
Actual Size command 33
Adding

gradient nodes 135
hue nodes 87
images 84
items 138
layers 109
profile nodes 139
stroke views 101
template path 126
width profiles 140

Aligning
objects 120
text 65

Alpha channel 129, 149
Anchoring 96

nodes 97
repeat handles 99

Animation effects 143
Antialiasing 149
Append Path button 52
Arcs

converting from ellipses 56
Area text 64, 65
Arranging

document windows 31
objects 105
palettes 37
width profiles 139

Auto-save files 25, 147
Auto-tracing 130

B
Background color 85
Baseline shift 66
Basic strokes 70
Better preview quality 32
Bevel joints 91
Bezier curves 47

converting from ellipses 56
Bitmap files

exporting 149
importing 35

Bitmaps 28, 32, 67, 127, 131
auto-tracing 130
bitmap strokes 9, 129
creating 127
filters 128
importing 36
opacity 128

Black point 88
Blanked dash offset 93
Blending modes 74, 76
Blending paths 58
BMP files 35, 149
Boolean operations 57
Bounding box 96, 107, 113, 144, 147
Breaking strokes at joints 91
Brighten mode 77
B-splines 47

converting nodes 62
Butt stroke caps 92

C
Caps 91, 145
Center View command 33
Circles 55

Clipboard 106
importing objects 36
preferences 156

Clippers 27, 63
releasing 64

Clones 27, 58, 123
Closing paths 57
Clusters 125
CMYK color model 19
CMYK color picker 79
Color Burn mode 77
Color Dodge mode 77
Color effects 143
Color management 20

rendering intents 21
soft proofing 22

Colorizing objects 85
Colors

CMYK model 19
color gamut 17
color management 22
color profiles 18, 20
copying 137
custom colors 20, 133
foreground/background colors 85
gradient nodes 135
HSL model 19
hue nodes 87
L*a*b* and L*u*v* color spaces 20
RGB bitmap export 21
RGB model 17
selecting 78
sRGB space 18, 19, 21
XYZ color spaces 20

ColorSync 20
Compound paths 57
Constraining angles 48, 152
Converting

bitmaps to paths 130
ellipses to Bezier curves 56
nodes 62
paths to guides 108
strokes to paths 63
text to paths 67

Copying
attributes 137
colors 137
Item List palette 138

Creating
arcs 56
Bezier paths 51
bitmap masks 128
bitmap strokes 129
bitmaps 127
B-splines 49
clones 58
custom colors 133
effect lines 123
ellipses 55
freehand paths 48
gradients 135
lines 53
multi-view strokes 99
patterns 136
polyline paths 50
rectangles 53
vector strokes 95
width profiles 139

Crop marks 144, 147, 149, 150
Custom colors 20, 80, 133

D
Darken mode 77
Dash patterns 92
Defining

bitmap strokes 129
vector strokes 95

Deleting
custom colors 134
gradient nodes 135
hue nodes 87
images from the list 84
layers 109
nodes 62
objects 107
patterns 137
profile nodes 139
stroke views 101
strokes 96
width profiles 139, 140

Deselecting objects 104
Difference mode 78
Display quality 32, 109

preferences 154
Distributing objects 121
Docking 38, 152
Document windows 30

arranging 31
opening additional 31

Documents
flipping 34
frame 31
onion skin display 34
opening 35
printing 150
rescue files 147
resources 25
reverting changes 36
saving 147
scrubbing 34

Double sliders 39
Duplicating

hue nodes 87
objects 106, 107
stroke views 101
width profiles 140

E
Editing

anchoring 97
custom colors 134
effect lines 124
gradient nodes 135
multi-view strokes 101
nodes 60
objects 107
paths in warp groups 68
repeatable vector strokes 99
shortcut keys 156
template paths 126
text characters 64
trangent handles 60
vector strokes 96
warp mesh 67
width profiles 139

Effect lines 28, 123
Ellipse stroke mode 90
Ellipses 27, 55

converting to Bezier curves 56
Embossed edges 71
EMF files 35
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EPS files
exporting 148
opening 35

Eraser mode 76
Even-odd rule 93
Exporting 155

bitmap files 149
custom colors 134
Flash files 141, 144
item lists 139
preferences 156
vector files 148

F
Fill

colors 81
embossed edges 71
fringes 72
gradients 81
images 83
patterns 82
rules 93
soft-edges 71
types 70
width 72

Filters 128
Flash files

animation 143
exporting 141
preferences 156

Flip tabs 31, 34
Flipping 34
Focus point 125
Fonts 65
Foreground color 85
Frame rate 144
Freezing layers 109
Fringes 72, 131

G
GIF files 35, 149
Gradient fill 70
Gradient strokes 70
Gradients 134
Greeking 155
Grid 26

preferences 154
snapping 107

Groups
clippers 63
effect lines 123
locking 112
object groups 29
selecting 103

Guides 27, 107

H
Hiding

grid 26
Layer mini-list 108
layers 110
palettes 37
reference vectors 112
selection highlights 105

HSL color model 19
HSL color picker 79

preferences 152
Hue nodes 87

I
ICC profiles 20, 21
ICM 20
Illustrator files

art brushes 36
exporting 148
opening 35
preferences 156

Image fill 70, 83, 131
Importing

bitmap files 36
custom colors 134
item lists 139
vector files 36

Items 139

J
Joining paths 56
Joints 91, 145
JPEG files 35, 149

L
L*a*b* and L*u*v* color spaces 20
Layer mini-list 32, 108
Layers 29, 108

display quality 109
exporting 149
preferences 152

Light mode 77
Lightness 19, 88
Line weight

preferences 151
Lines

converting nodes 62
Locking

layers 110
objects 112
tangent handle angles 52, 61

M
Magnification 33
Masks 27, 63
Memory usage 29
Meters 39
Mirroring 117
Miter joints 91
Motion effects 143
Mouse wheel 33, 154
Moving 114

gradient nodes 135
hue nodes 87
nodes 60
objects 105, 106, 110
profile nodes 139
strokes between folders 101

Multiply mode 76
Multi-view strokes 10

defining 99
editing 101
Flash animation 143

N
Nodes

anchoring 97
converting 62
deleting 62
editing 60
marking 58
nudging 60
selecting 59
snapping to nodes 107

Non-zero winding rule 93
Normal dash offset 93
Nudging

nodes 60
preferences 152

O
Object color 137
Objects 27

aligning 120
arranging 105, 108
colorizing 85, 86
deleting 107
distributing 121
editing 107
grouping 29
locking 112
mirroring 117
moving 105, 106, 110, 114
object list 111
perspective transformation 119
rotating 115
scaling 114
selecting 103
setting bounds 118
setting size 118
settings 111
shearing 116
stacking 121
transforming 113

Onion skin display 34
Opacity 74, 75, 155

bitmaps 128
Opacity profiles 128
Opening

document windows 30
documents 35

Origin
ruler 32

P
Palettes 37

Attributes 43, 89
Colorize 45, 87
docking 38, 152
Effect Lines 45, 123
Flash Button 45, 141
Font 43
hiding 37
Item List 44, 138
Object List 43, 111
Paint Style 42, 69, 127
snapping 37
Strokes 44, 84, 101
Toolbox 40
Transformation 44, 114
Variable Width 43, 139

Paper textures 74, 75, 131
Path operations 57
Path quality 32
Paths 13, 27, 47

blending 58
changing starting points 63
clippers 63
clones 58
closing 57
compound paths 57
converting 63, 67
converting from bitmaps 130
fill area 48
joining 56
preferences 151, 152
reshaping 60
reversing 62
smoothing 63
splitting 62
unstructuring 63

Pattern fill 70
Patterns 135

fill 82
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preferences 151
PDF files 148
Perceptual intent 21
Perspective transformation 119
Phase offset 92
Photoshop filters 128
Pies

converting from ellipses 56
Plugins 149

bitmap filters 128
importing 35

Pointer states 143
Polygons 54
Popup buttons 39
Preferences 151
Pressure sensitivity 49, 128

preferences 153
Preview quality 32
Printing 150, 155

preferences 156
PSD files 149

Q
Quick strokes 85, 102

R
Raster resolution 144
Rasterization 127, 149
Redo 36
Reference vectors 59

hiding 112
Reflection maps 73, 131
Relative colorimetric intent 22
Releasing

clones 58
compound paths 57
guides 108
object groups 29
text and paths 65

Removing
bitmap masks 128
colorization 88
crop marks 147
node marking 59
reference vectors 59
template path 126

Rendering intents 21
Repeating commands 99
Rescue files 25, 147
Reset View Rotation command 34
Resetting

warp mesh 67
Resize handles 103, 105, 113, 155

editing nodes 60
Reverting to saved state 36
RGB bitmap export 21
RGB color picker 79
RGB model 17
Ribbon stroke mode 90
Rotate View commands 33
Rotating

view area 33
Rotation 115
Round joints 91
Round stroke caps 92
Rulers 31, 155

scrolling 33

S
Saturation 19, 88
Saturation intent 21
Sausage stroke mode 90
Saving 155

documents 147

preferences 156
thumbnails 156
width profiles 139

Scaling 114
Screen color 137
Scrolling 33, 154

view area 31
Selecting

colors 78
layers 109
master paths 58
nodes 59
objects 103, 111
preferences 151, 153
text characters 64

Shape parameter 89
Shear

strokes 89
Shearing 116
Shortcut keys 156
Show Next command 34
Show Preview command 34
Skeletal strokes 9, 70, 84

anchoring 96
bitmap strokes 9
colorizing 85
defining 95
defining bitmap strokes 129
deleting 96
editing 96
multi-view strokes 10, 99
preferences 153
quick strokes 85, 102
repeatable strokes 98, 130

Sliders 38
Snake dash offset 93
Snapping 107

bounding box 107
palettes 37
preferences 154
to grid 26, 107
to guides 27, 107
to nodes 107

Soft proofing 22
Soft-edges 71
Solid fill 70
Square stroke caps 92
sRGB space 18, 19, 21
Stacking 121

preferences 152
Status bar 29
Stroke folders 101
Stroke windows 95
Strokes

applying to effect lines 124
breaking at joints 91
caps 91
colors 80
dash patterns 92
gradients 81
joints 91
shape parameter 89
shear 71, 89
stroke modes 90
twist 90
types 69
width 70

T
Tangent handles 60
Target 142
Template paths 126
Text 28, 64

aligning 65

area text 64, 65
converting 67
editing 64
greeking 155
selecting 64
text on path 64, 65

Textures 74, 75, 131
Thumbnails 156
TIFF files 35, 149
Tightness of fit 130

preferences 152
smoothing 63

Tools
Add Node 41, 62
Anchor 41, 97
Attribute Dropper 41, 137
Bezier Pen 41, 51
Bitmap Pen 41, 127
B-Spline 41, 50
Color Dropper 41, 137, 154
Convert Node 41, 60, 62
Cut Path 41, 62
Delete Node 41, 62
Ellipse 41, 55
Freehand Pen 41, 48, 60, 104, 152, 

153
Gradient Vector 41, 82
Group Select 40, 103, 104, 106
Hand 33, 41
Lighting 41, 73
Line 41, 53
Mirror 41, 117
Node 41, 56, 59, 60, 90, 124
Node Lasso 41, 56, 59, 60, 90, 124
Object Select 40, 103, 106
Pattern Definition Box 42, 136
Perspective 42, 119
Polyline 41, 50
preferences 152
Rectangle 41, 53
Reference Vector 41, 59
Repeat 41, 98
Reverse Path 41, 62
Rotate 41, 116
Scale 41, 115
Shear 41, 117
Start Point 41, 63
Stroke Definition Box 42, 96
Text 42, 64
Transform Fill 41, 82, 83, 84, 103
Twirl Star 41, 54
Zoom 33, 41

Tracking 67
Transformations 29, 113

committing to 120
effect lines 124
fill 82, 83, 84
mirroring 117
moving 114
preferences 151, 152
resetting 120
rotation 115
scaling 114
shearing 116
transformation origin 114
Transformation palette 114

Transparency 75, 155
Twist 90

U
Undo 36, 152
Units

rulers 32
Unstructuring 63
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URL 142

V
Variable width 78

Freehand Pen tool 49
Vector files

exporting 148
opening 35

View area 33
document frame 31

rotating 33

W
Warp groups 28, 67
White point 88
Width handles 90

preferences 153
Width profiles 78, 128, 139, 153
Wireframe quality 32
WMF files 35

X
XYZ color space 20

Z
Z-axis 154
Zooming 33, 112, 154
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END-USER LICENSE AGREEMENT FOR MICROSOFT SOFTWARE
MICROSOFT CREATURE HOUSE EXPRESSION 3
IMPORTANT — READ CAREFULLY: This End-User License
Agreement ("EULA") is a legal agreement between you (either an
individual or a single entity) and Microsoft Corporation
("Microsoft") for the Microsoft software that accompanies this
EULA, which includes computer software and may include asso-
ciated media, printed materials, "online" or electronic documenta-
tion, and Internet-based services ("Software"). An amendment or
addendum to this EULA may accompany the Software. YOU
AGREE TO BE BOUND BY THE TERMS OF THIS EULA
BY INSTALLING, COPYING, OR OTHERWISE USING
THE SOFTWARE. IF YOU DO NOT AGREE, DO NOT
INSTALL, COPY, OR OTHERWISE USE THE SOFTWARE.

MICROSOFT SOFTWARE LICENSE
1. GRANTS OF LICENSE. Microsoft grants you the rights
described in this EULA provided that you comply with all terms
and conditions of this EULA. Microsoft grants to you as an indi-
vidual, a personal, nonexclusive license to install and use the Soft-
ware on a single computer located on your premises for your
internal use.
2. RESERVATION OF RIGHTS AND OWNERSHIP.
Microsoft reserves all rights not expressly granted to you in this
EULA. The Software is protected by copyright and other intellec-
tual property laws and treaties. Microsoft or its suppliers own the
title, copyright, and other intellectual property rights in the Soft-
ware. The Software is licensed, not sold.
3. LIMITATIONS ON REVERSE ENGINEERING,
DECOMPILATION, AND DISASSEMBLY. You may not
reverse engineer, decompile, or disassemble the Software, except
and only to the extent that such activity is expressly permitted by
applicable law notwithstanding this limitation.
4. NO DISTRIBUTION/RENTAL/COMMERCIAL HOST-
ING/SOFTWARE TRANSFER. You may not distribute, rent,
lease, lend or provide commercial hosting services with the Soft-
ware. You may not assign or otherwise transfer the Software or
any of your rights hereunder to any third party.
5. CONSENT TO USE OF DATA. You agree that Microsoft
and its affiliates may collect and use technical information gath-
ered as part of the product support services provided to you, if any,
related to the Software. Microsoft may use this information solely
to improve our products or to provide customized services or tech-
nologies to you and will not disclose this information in a form
that personally identifies you.
6. ADDITIONAL SOFTWARE/SERVICES. This EULA
applies to updates, supplements, add-on components, or Inter-
net-based services components, of the Software that Microsoft
may provide to you or make available to you after the date you
obtain your initial copy of the Software, unless we provide other
terms along with the update, supplement, add-on component, or
Internet-based services component. Microsoft reserves the right to
discontinue any Internet-based services provided to you or made
available to you through the use of the Software.
7. EXPORT RESTRICTIONS. You acknowledge that the
Software is subject to U.S. export jurisdiction. You agree to com-
ply with all applicable international and national laws that apply to
the Software, including the U.S. Export Administration Regula-
tions, as well as end-user, end-use, and destination restrictions
issued by U.S. and other governments. For additional information
see <http://www.microsoft.com/exporting/>.

8. TERMINATION. Without prejudice to any other rights,
Microsoft may terminate this EULA if you fail to comply with the
terms and conditions of this EULA. In such event, you must
destroy all copies of the Software and all of its component parts.
9. DISCLAIMER OF WARRANTIES. TO THE MAXI-
MUM EXTENT PERMITTED BY APPLICABLE LAW,
MICROSOFT AND ITS SUPPLIERS PROVIDE THE SOFT-
WARE AND SUPPORT SERVICES (IF ANY) AS IS AND
WITH ALL FAULTS, AND HEREBY DISCLAIM ALL
OTHER WARRANTIES AND CONDITIONS, WHETHER
EXPRESS, IMPLIED OR STATUTORY, INCLUDING, BUT
NOT LIMITED TO, ANY (IF ANY) IMPLIED WARRAN-
TIES, DUTIES OR CONDITIONS OF MERCHANTABIL-
ITY, OF FITNESS FOR A PARTICULAR PURPOSE, OF
RELIABILITY OR AVAILABILITY, OF ACCURACY OR
COMPLETENESS OF RESPONSES, OF RESULTS, OF
WORKMANLIKE EFFORT, OF LACK OF VIRUSES, AND
OF LACK OF NEGLIGENCE, ALL WITH REGARD TO
THE SOFTWARE, AND THE PROVISION OF OR FAIL-
URE TO PROVIDE SUPPORT OR OTHER SERVICES,
INFORMATION, SOFTWARE, AND RELATED CONTENT
THROUGH THE SOFTWARE OR OTHERWISE ARISING
OUT OF THE USE OF THE SOFTWARE. ALSO, THERE IS
NO WARRANTY OR CONDITION OF TITLE, QUIET
ENJOYMENT, QUIET POSSESSION, CORRESPON-
DENCE TO DESCRIPTION OR NON-INFRINGEMENT
WITH REGARD TO THE SOFTWARE.
10. EXCLUSION OF INCIDENTAL, CONSEQUENTIAL
AND CERTAIN OTHER DAMAGES. TO THE MAXIMUM
EXTENT PERMITTED BY APPLICABLE LAW, IN NO
EVENT SHALL MICROSOFT OR ITS SUPPLIERS BE
LIABLE FOR ANY SPECIAL, INCIDENTAL, PUNITIVE,
INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSO-
EVER (INCLUDING, BUT NOT LIMITED TO, DAMAGES
FOR LOSS OF PROFITS OR CONFIDENTIAL OR OTHER
INFORMATION, FOR BUSINESS INTERRUPTION, FOR
PERSONAL INJURY, FOR LOSS OF PRIVACY, FOR FAIL-
URE TO MEET ANY DUTY INCLUDING OF GOOD
FAITH OR OF REASONABLE CARE, FOR NEGLIGENCE,
AND FOR ANY OTHER PECUNIARY OR OTHER LOSS
WHATSOEVER) ARISING OUT OF OR IN ANY WAY
RELATED TO THE USE OF OR INABILITY TO USE THE
SOFTWARE, THE PROVISION OF OR FAILURE TO PRO-
VIDE SUPPORT OR OTHER SERVICES, INFORMATION,
SOFTWARE, AND RELATED CONTENT THROUGH THE
SOFTWARE OR OTHERWISE ARISING OUT OF THE
USE OF THE SOFTWARE, OR OTHERWISE UNDER OR
IN CONNECTION WITH ANY PROVISION OF THIS
EULA, EVEN IN THE EVENT OF THE FAULT, TORT
(INCLUDING NEGLIGENCE), MISREPRESENTATION,
STRICT LIABILITY, BREACH OF CONTRACT OR
BREACH OF WARRANTY OF MICROSOFT OR ANY
SUPPLIER, AND EVEN IF MICROSOFT OR ANY SUP-
PLIER HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.
11. LIMITATION OF LIABILITY AND REMEDIES. NOT-
WITHSTANDING ANY DAMAGES THAT YOU MIGHT
INCUR FOR ANY REASON WHATSOEVER (INCLUDING,
WITHOUT LIMITATION, ALL DAMAGES REFERENCED
HEREIN AND ALL DIRECT OR GENERAL DAMAGES IN
CONTRACT OR ANYTHING ELSE), THE ENTIRE LIA-
BILITY OF MICROSOFT AND ANY OF ITS SUPPLIERS
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UNDER ANY PROVISION OF THIS EULA AND YOUR
EXCLUSIVE REMEDY HEREUNDER SHALL BE LIM-
ITED TO THE GREATER OF THE ACTUAL DAMAGES
YOU INCUR IN REASONABLE RELIANCE ON THE
SOFTWARE UP TO THE AMOUNT ACTUALLY PAID BY
YOU FOR THE SOFTWARE OR US$5.00. THE FOREGO-
ING LIMITATIONS, EXCLUSIONS AND DISCLAIMERS
SHALL APPLY TO THE MAXIMUM EXTENT PERMIT-
TED BY APPLICABLE LAW, EVEN IF ANY REMEDY
FAILS ITS ESSENTIAL PURPOSE.
12. APPLICABLE LAW. If you acquired this Software in the
United States, this EULA is governed by the laws of the State of
Washington. If you acquired this Software in Canada, unless
expressly prohibited by local law, this EULA is governed by the
laws in force in the Province of Ontario, Canada; and, in respect of
any dispute which may arise hereunder, you consent to the juris-
diction of the federal and provincial courts sitting in Toronto,
Ontario. If you acquired this Software in the European Union, Ice-
land, Norway, or Switzerland, then local law applies. If you
acquired this Software in any other country, then local law may
apply.
13. ENTIRE AGREEMENT; SEVERABILITY. This EULA
(including any addendum or amendment to this EULA which is
included with the Software) are the entire agreement between you
and Microsoft relating to the Software and the support services (if
any) and they supersede all prior or contemporaneous oral or writ-
ten communications, proposals and representations with respect to
the Software or any other subject matter covered by this EULA. To
the extent the terms of any Microsoft policies or programs for sup-
port services conflict with the terms of this EULA, the terms of
this EULA shall control. If any provision of this EULA is held to
be void, invalid, unenforceable or illegal, the other provisions
shall continue in full force and effect.

Si vous avez acquis votre produit Microsoft au CANADA,
la garantie limitée suivante s'applique :

DÉNI DE GARANTIES. DANS LA MESURE MAXI-
MALE PERMISE PAR LES LOIS APPLICABLES, LE
LOGICIEL ET LES SERVICES DE SOUTIEN TECH-
NIQUE (LE CAS ÉCHÉANT) SONT FOURNIS TELS QUELS
ET AVEC TOUS LES DÉFAUTS PAR MICROSOFT ET SES
FOURNISSEURS, LESQUELS PAR LES PRÉSENTES
DÉNIENT TOUTES AUTRES GARANTIES ET CONDI-
TIONS EXPRESSES, IMPLICITES OU EN VERTU DE LA
LOI, NOTAMMENT, MAIS SANS LIMITATION, (LE CAS
ÉCHÉANT) LES GARANTIES, DEVOIRS OU CONDI-
TIONS IMPLICITES DE QUALITÉ MARCHANDE,
D'ADAPTATION À UNE FIN PARTICULIÈRE, DE FIABIL-
ITÉ OU DE DISPONIBILITÉ, D'EXACTITUDE OU
D'EXHAUSTIVITÉ DES RÉPONSES, DES RÉSULTATS,
DES EFFORTS DÉPLOYÉS SELON LES RÈGLES DE
L'ART, D'ABSENCE DE VIRUS ET D'ABSENCE DE
NÉGLIGENCE, LE TOUT À L'ÉGARD DU LOGICIEL ET
DE LA PRESTATION OU DE L'OMISSION DE LA PRES-
TATION DES SERVICES DE SOUTIEN TECHNIQUE OU À
L'ÉGARD DE LA FOURNITURE OU DE L'OMISSION DE
LA FOURNITURE DE TOUS AUTRES SERVICES,
RENSEIGNEMENTS, LOGICIELS, ET CONTENU QUI S'Y
RAPPORTE GRÂCE AU LOGICIEL OU PROVENANT
AUTREMENT DE L'UTILISATION DU LOGICIEL . PAR
AILLEURS, IL N'Y A AUCUNE GARANTIE OU CONDI-
TION QUANT AU TITRE DE PROPRIÉTÉ, À LA JOUIS-
SANCE OU LA POSSESSION PAISIBLE, À LA
CONCORDANCE À UNE DESCRIPTION NI QUANT À
UNE ABSENCE DE CONTREFAÇON CONCERNANT LE
LOGICIEL.

EXCLUSION DES DOMMAGES ACCESSOIRES, INDI-
RECTS ET DE CERTAINS AUTRES DOMMAGES. DANS
LA MESURE MAXIMALE PERMISE PAR LES LOIS
APPLICABLES, EN AUCUN CAS MICROSOFT OU SES
FOURNISSEURS NE SERONT RESPONSABLES DES
DOMMAGES SPÉCIAUX, CONSÉCUTIFS, ACCESSOI-
RES OU INDIRECTS DE QUELQUE NATURE QUE CE
SOIT (NOTAMMENT, LES DOMMAGES À L'ÉGARD DU
MANQUE À GAGNER OU DE LA DIVULGATION DE
RENSEIGNEMENTS CONFIDENTIELS OU AUTRES, DE
LA PERTE D'EXPLOITATION, DE BLESSURES COR-
PORELLES, DE LA VIOLATION DE LA VIE PRIVÉE, DE
L'OMISSION DE REMPLIR TOUT DEVOIR, Y COMPRIS
D'AGIR DE BONNE FOI OU D'EXERCER UN SOIN RAI-
SONNABLE, DE LA NÉGLIGENCE ET DE TOUTE
AUTRE PERTE PÉCUNIAIRE OU AUTRE PERTE DE
QUELQUE NATURE QUE CE SOIT) SE RAPPORTANT DE
QUELQUE MANIÈRE QUE CE SOIT À L'UTILISATION
DU LOGICIEL OU À L'INCAPACITÉ DE S'EN SERVIR, À
LA PRESTATION OU À L'OMISSION DE LA PRESTA-
TION DE SERVICES DE SOUTIEN TECHNIQUE OU À LA
FOURNITURE OU À L'OMISSION DE LA FOURNITURE
DE TOUS AUTRES SERVICES, RENSEIGNEMENTS,
LOGICIELS, ET CONTENU QUI S'Y RAPPORTE GRÂCE
AU LOGICIEL OU PROVENANT AUTREMENT DE
L'UTILISATION DU LOGICIEL OU AUTREMENT AUX
TERMES DE TOUTE DISPOSITION DE LA PRÉSENTE
CONVENTION OU RELATIVEMENT À UNE TELLE DIS-
POSITION, MÊME EN CAS DE FAUTE, DE DÉLIT CIVIL
(Y COMPRIS LA NÉGLIGENCE), DE RESPONSABILITÉ
STRICTE, DE VIOLATION DE CONTRAT OU DE VIOLA-
TION DE GARANTIE DE MICROSOFT OU DE TOUT
FOURNISSEUR ET MÊME SI MICROSOFT OU TOUT
FOURNISSEUR A ÉTÉ AVISÉ DE LA POSSIBILITÉ DE
TELS DOMMAGES.

LIMITATION DE RESPONSABILITÉ ET RECOURS.
MALGRÉ LES DOMMAGES QUE VOUS PUISSIEZ SUBIR
POUR QUELQUE MOTIF QUE CE SOIT (NOTAMMENT,
MAIS SANS LIMITATION, TOUS LES DOMMAGES SUS-
MENTIONNÉS ET TOUS LES DOMMAGES DIRECTS OU
GÉNÉRAUX OU AUTRES), LA SEULE RESPONSABILITÉ
DE MICROSOFT ET DE L'UN OU L'AUTRE DE SES
FOURNISSEURS AUX TERMES DE TOUTE DISPOSI-
TION DE LA PRÉSENTE CONVENTION ET VOTRE
RECOURS EXCLUSIF À L'ÉGARD DE TOUT CE QUI
PRÉCÈDE SE LIMITE AU PLUS ÉLEVÉ ENTRE LES
MONTANTS SUIVANTS : LE MONTANT QUE VOUS
AVEZ RÉELLEMENT PAYÉ POUR LE LOGICIEL OU 5,00
$US. LES LIMITES, EXCLUSIONS ET DÉNIS QUI PRÉCÈ-
DENT (Y COMPRIS LES CLAUSES CI-DESSUS), S'APPLI-
QUENT DANS LA MESURE MAXIMALE PERMISE PAR
LES LOIS APPLICABLES, MÊME SI TOUT RECOURS
N'ATTEINT PAS SON BUT ESSENTIEL.

À moins que cela ne soit prohibé par le droit local applicable,
la présente Convention est régie par les lois de la province
d'Ontario, Canada. Vous consentez à la compétence des tribunaux
fédéraux et provinciaux siégeant à Toronto, dans la province
d'Ontario.

Au cas où vous auriez des questions concernant cette licence
ou que vous désiriez vous mettre en rapport avec Microsoft pour
quelque raison que ce soit, veuillez utiliser l'information contenue
dans le Logiciel pour contacter la filiale de Microsoft desservant
votre pays, ou visitez Microsoft sur le World Wide Web à
<http://www.microsoft.com>.


	Expression 3: User Manual
	Trademarks, Copyright, Credits
	Contents

	Getting Started
	Chapter 1: Introduction
	1.1 A Stylish Vector-Based Drawing Application
	1.2 What Is New in Expression 3
	1.3 Original Expression Features
	1.4 Software Design Philosophy

	Chapter 2: Drawing with Skeletal Strokes
	2.1 What Is a Skeletal Stroke?
	2.2 Drawing with Skeletal Strokes
	2.3 Bitmap Strokes
	2.4 Defining Skeletal Strokes
	2.5 Multi-View Skeletal Strokes
	2.6 Skeletal Stroke Power

	Chapter 3: Creating Expressive Pictures
	3.1 Paths as Basic Picture Elements
	3.2 Thinking in Terms of Area
	3.3 The Expression Work Flow

	Chapter 4: Color and Color Management
	4.1 Specifying Colors
	4.2 Color Management

	Chapter 5: Expression Picture Document Structure and View
	5.1 Expression Document
	5.2 Document Frame, Ruler Units, Origin
	5.3 Grid and Guides
	5.4 Graphics Objects
	5.5 Layers and Groups
	5.6 The Expression Workspace
	5.7 Document Windows
	5.8 Navigating around a Picture
	5.9 Flipping Documents
	5.10 Using Onion Skin Display
	5.11 Opening Files and Importing Objects
	5.12 Reversing Document Changes

	Chapter 6: Floating Palettes, Controls and Palette Management
	6.1 Using Palettes
	6.2 Using Sliders
	6.3 Using Meters
	6.4 Using Popup Buttons
	6.5 The Toolbox Palette
	6.6 The Paint Style Palette
	6.7 The Attributes Palette
	6.8 The Font Palette
	6.9 The Object List Palette
	6.10 The Variable Width Palette
	6.11 The Strokes Palette
	6.12 The Transformation Palette
	6.13 The Item List Palette
	6.14 The Colorize Palette
	6.15 The Effect Lines Palette
	6.16 The Flash Button Palette

	Chapter 7: Paths, Text and Other Path-Based Objects
	7.1 Paths: The Basic Building Blocks
	7.2 Anatomy of a Path
	7.3 Creating Paths
	7.4 Using the Freehand Pen Tool
	7.5 Using the B-Spline Tool
	7.6 Using the Polyline/Arc Tool
	7.7 Using the Bezier Pen Tool
	7.8 Shape-Based Drawing Tools: Rectangle, Ellipse, Line, Star/Polygon/Twirl
	7.9 Using the Rectangle Tool
	7.10 Using the Line Tool
	7.11 Using the Twirl Star Tool
	7.12 Ellipses and the Ellipse Tool
	7.13 Joining Paths
	7.14 Closing Paths
	7.15 Forming Paths Using Path Operations
	7.16 Working with Compound Paths
	7.17 Working with Clones
	7.18 Blending Paths
	7.19 Selecting Nodes
	7.20 Editing Nodes
	7.21 Changing Bezier Tangent Continuity
	7.22 Converting Nodes
	7.23 Using Miscellaneous Path Modifying Tools
	7.24 Smoothing Paths
	7.25 Unstructuring Strokes
	7.26 Working with Clippers
	7.27 Text Objects
	7.28 Bitmap Objects
	7.29 Object Warping and Warp Groups
	7.30 Effect Line Groups

	Chapter 8: Paint Style and Other Object Attributes
	8.1 The Paint Style Palette
	8.2 Setting Stroke Type
	8.3 Setting Fill Type
	8.4 Setting Stroke Width
	8.5 Setting Soft-Edged or Embossed Width
	8.6 Opacity, Paper Textures and Blending Modes
	8.7 Setting Opacity (or Transparency)
	8.8 Setting Paper Textures
	8.9 Setting Blending Modes
	8.10 Setting Variable Width and Opacity
	8.11 Picking Colors
	8.12 Applying Gradients
	8.13 Applying Pattern Fill
	8.14 Applying Image Fill
	8.15 Applying Skeletal Strokes
	8.16 Colorizing Objects and Skeletal Strokes
	8.17 General Colorization of Objects

	Chapter 9: More Specialized Stroke and Fill Attributes
	9.1 Multi-View Strokes and Shape Parameter
	9.2 Setting Shape Parameters
	9.3 Setting Stroke Shear
	9.4 Setting Stroke Modes
	9.5 Setting Stroke Twist
	9.6 Setting Stroke Joints
	9.7 Breaking Strokes at Corners
	9.8 Setting Stroke Caps
	9.9 Applying Strokes in Dashes
	9.10 Setting Fill Rules

	Chapter 10: Defining and Managing Skeletal Strokes
	10.1 Defining and Editing Strokes
	10.2 Defining Strokes with Anchoring
	10.3 Defining Strokes with Repeatable Paths
	10.4 Defining Multi-View Strokes
	10.5 Managing Strokes and Folders
	10.6 Setting Quick Strokes

	Chapter 11: Selecting and Managing Graphics Objects
	11.1 Selecting Objects
	11.2 Managing Graphics Objects
	11.3 Moving, Copying and Editing Objects
	11.4 Using Snapping
	11.5 Changing Object Order
	11.6 Managing Layers
	11.7 Managing the Object List

	Chapter 12: Transformation and Precise Size and Position Control
	12.1 Transforming Objects
	12.2 Translating Objects
	12.3 Scaling Objects
	12.4 Rotating Objects
	12.5 Shearing Objects
	12.6 Mirroring Objects
	12.7 Setting Object Size and Bounds
	12.8 Applying Perspective Transformation
	12.9 Working with Previous Transformations
	12.10 Aligning, Distributing and Stacking Objects

	Chapter 13: Creating Effect Lines
	13.1 Generating Effect Lines
	13.2 About Effect Line Groups
	13.3 Applying Strokes to Effect Lines
	13.4 Setting Effect Line Variations
	13.5 Using a Template Path

	Chapter 14: Using Bitmap Images
	14.1 Creating Bitmaps
	14.2 Painting Bitmaps
	14.3 Using Bitmap Filters
	14.4 Defining Bitmap Strokes
	14.5 Converting Bitmaps to Paths
	14.6 Bitmap Resources

	Chapter 15: Managing Custom Colors, Gradients, Patterns, Width Profiles and Attribute Sets
	15.1 Managing Custom Colors
	15.2 Managing Gradients
	15.3 Managing Patterns
	15.4 Copying Colors and Attributes
	15.5 Managing the Item List
	15.6 Managing Variable Width

	Chapter 16: Turning Graphics Objects into Flash Buttons
	16.1 Exporting as Flash Movie Files and Interactive Flash Pages
	16.2 About the Flash Button Palette
	16.3 Choosing Flash Settings
	16.4 URL and Target Settings
	16.5 Motion Effects, Color Effects and Pointer States
	16.6 Effect Setting Sliders
	16.7 Reciprocating Multi-View Stroke Animations
	16.8 Speed of Effects
	16.9 Number of Effect Cycles
	16.10 Exporting to Flash Format

	Chapter 17: Printing, Saving and Exporting
	17.1 Saving Documents
	17.2 Using Crop Marks
	17.3 Exporting to PostScript Based Formats
	17.4 Rasterizing to Bitmap Formats
	17.5 Exporting through the Clipboard
	17.6 Printing Documents

	Chapter 18: Customizing Expression 3
	18.1 Setting Options and Preferences
	18.2 “General” Preferences
	18.3 “Tools” Preferences
	18.4 “View and Display” Preferences
	18.5 “Print, Save and Export” Preferences
	18.6 “Keyboard Shortcuts” Preferences

	Menu Commands
	Tutorial 1: Easy Paths and the B-Spline Tool
	Tutorial 2: Effective Use of Layers
	Tutorial 3: Defining Vector Skeletal Strokes
	Tutorial 4: Strokes with Multiple Repeating Parts
	Tutorial 5: Variable Width without Pressure
	Tutorial 6: Scraping and Lifting Effects
	Tutorial 7: Personal Expressive Styles
	Tutorial 8: Blending Mode Surprises
	Tutorial 9: Dry Brush Effects
	Tutorial 10: Comics and Effect Lines
	Color Plates
	Index
	END-USER LICENSE AGREEMENT FOR MICROSOFT SOFTWARE

