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LIMITED WARRANTY
AND DISCLAIMERS

A. Limited Warranty on Media.
CLARIS™ warrants the diskettes
on which the Software is
recorded to be free from
defects in materials and faulty
workmanship under normal use
for a period of ninety (90) days
from the date of delivery as
evidenced by a copy of the sales
receipt. CLARIS™ will, at its
option, replace or refund the
purchase price of the diskette at
no charge to you, provided you
return the faulty diskette with the
sales receipt to CLARIS™ or

an authorized CLARIS™ Dealer.
CLARIS™ shall have no respon-
sibility to replace or refund the
purchase price of a diskette
damaged by accident, abuse

or misapplication. ANY
IMPLIED WARRANTIES ON
THE DISKETTES, INCLUDING
IMPLIED WARRANTIES OF
MERCHANTABILITY AND
FITNESS FOR A PARTICULAR
PURPOSE, ARE LIMITED IN
DURATION TO 90 DAYS FROM
THE DATE OF DELIVERY.

B. Disclaimer of Warranty on
Software. THE SOFTWARE IS
PROVIDED “AS 1S” WITHOUT
WARRANTY OF ANY KIND,
AND CLARIS™ EXPRESSLY
DISCLAIMS ALL IMPLIED
WARRANTIES, INCLUDING BUT
NOT LIMITED TO THE IMPLIED
WARRANTIES OF MERCHANT-
ABILITY AND FITNESS FOR

A PARTICULAR PURPOSE.
CLARIS™ DOES NOT
WARRANT, GUARANTEE, OR
MAKE ANY REPRESENTATIONS
REGARDING THE USE OR

THE RESULTS OF THE USE OF

THE SOFTWARE OR ANY
ACCOMPANYING WRITTEN
MATERIALS IN TERMS OF
THEIR CORRECTNESS,
ACCURACY, RELIABILITY,
CURRENTNESS, OR
OTHERWISE. THE ENTIRE
RISK AS TO THE RESULTS AND
PERFORMANCE OF THE
SOFTWARE AND WRITTEN
MATERIALS IS ASSUMED

BY YOU. CLARIS™ DOES

NOT WARRANT THAT THE
SOFTWARE WILL WORK
CORRECTLY IN YOUR MULTI-
USER ENVIRONMENT. IF THE
SOFTWARE IS DEFECTIVE,
YOU, AND NOT CLARIS™ OR
ITS DEALERS, DISTRIBUTORS,
AGENTS, OR EMPLOYEES,
ASSUME THE ENTIRE COST OF
ALL NECESSARY SERVICING,
REPAIR, OR CORRECTION.
SOME STATES DO NOT ALLOW
THE EXCLUSION OF IMPLIED
WARRANTIES, SO THE ABOVE
EXCLUSION MAY NOT APPLY
TO YOU.

C. Complete Statement of
Warranty. THE LIMITED
WARRANTIES PROVIDED IN
PARAGRAPHS A AND B ABOVE
ARE THE ONLY WARRANTIES
OF ANY KIND THAT ARE
MADE BY CLARIS™ ON THIS
CLARIS™ PRODUCT. NO ORAL
OR WRITTEN INFORMATION
OR ADVICE GIVEN BY
CLARIS™, ITS DEALERS,
DISTRIBUTORS, AGENTS, OR
EMPLOYEES SHALL CREATE A
WARRANTY OR IN ANY WAY
INCREASE THE SCOPE OF THIS
WARRANTY, AND YOU MAY
NOT RELY ON ANY SUCH
INFORMATION OR ADVICE.
THIS WARRANTY GIVES YOU
SPECIFIC LEGAL RIGHTS. YOU

MAY HAVE OTHER RIGHTS,
WHICH VARY FROM STATE TO
STATE.

U.S. GOVERNMENT END-USER
PROVISIONS. If this Software is
acquired by or on behalf of a
unit or agency of the United
States Government this pro-
vision applies. This Software:
(a) was developed at private
expense, and no part of it was
developed with government
funds, (b) is a trade secret of
CLARIS™ for all purposes of the
Freedom of Information Act,

(c) is “commercial computer
software” subject to limited
utilization as provided in the
contract between the vendor and
the governmental entity and

(d) in all respects is proprietary
data belonging solely to
CLARIS™,

For units of the Department of
Defense (DOD), this Software

is sold only with “Restricted
Rights” as that term is defined

n the DOD Supplement to the
Federal Acquisition Regulations,
52.227-7013 (b) (3) (i) and: Use,
duplication or disclosure is
subject to restrictions as set
JSorth in subdivision (&) (3) (ii)
of the Rights in Technical Data
and Computer Software clause
at 52.227-7013. Manufacturer:
CLARIS™ Corporation, 440
Clyde Ave., Mountain View,
California 94043.

If this Software was acquired
under a GSA Schedule the
U.S. Government has agreed
to refrain from changing or
removing any insignia or
lettering from the Software
or the accompanying written



materials that are provided or
from producing copies of
manuals or disks (except one
copy for backup purposes) and:

(D Title to and ownership of this
Software and documentation
and any reproductions thereof
shall remain with CLARIS™;

(2) Use of this Software and
documentation shall be limited
to the facility for which it is
acquired; and

(3) If use of the Software is
discontinued to the installation
specified in the purchase/
delivery order and the U.S.
Government desires to use it at
another location, it may do so
by giving prior written notice to
CLARIS™, specifying the type of
computer and new location site.
U.S. Governmental personnel
using this Software, other than
under a DOD contract or GSA
Schedule, are hereby on notice
that use of this Software is subject
to restrictions which are the
same as or similar to those
specified above.

© CLARIS Corporation, 1987.
All Rights Reserved. CLARIS,
440 Clyde Ave., Mountain View,
California, 94043

(415) 960-1500

CLARIS is a trademark of
CLARIS Corporation.

MacPaint is a registered
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are registered trademarks of
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POSTSCRIPT is a trademark of
Adobe Systems Incorporated.

ITC Garamond, ITC Avant Garde
Gothic, and ITC Zapf Dingbats
are registered trademarks of
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Preface

About MacPaint

MacPaint® 2.0 is for creating pictures. It's for professional artists,
people who enjoy drawing, business people who need to spruce up
reports with illustrations—even people who think they have no
artistic skills. It's for people who love to make pictures and anyone
who needs an easy-to-use tool to sketch out ideas and plans.

With MacPaint, you can

O

draw straight lines and round circles and create precise shapes
and intricate patterns with ease

add patterns to your pictures by “painting” with several sizes and
shapes of brushes that you never have to clean

select any part of a picture and move, duplicate, rotate, flip,
stretch, shrink, or invert it

add text to a picture in a variety of fonts, font sizes, and font
styles

move in for close-up views of a picture—as if you had a
magnifying glass—so you can do detail work

enjoy the freedom to experiment, try new effects, undo what you
don’t like, create several versions of an idea, combine images
from several different sources, and finally, put your work on
paper when it’s just right

create or edit pictures that you can “paste” into documents
created with word processing or page-layout programs

As you create pictures with MacPaint, you may find MacPaint
complements the artist in you by giving you an easy-to-use tool that
produces good-looking results.

Xiii
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Click Double Drag
click

These are the symbols that this

guide uses for click, double click,

and drag.

Different versions of the
Command key

Xiv Preface

What you need

MacPaint 2.0 works on the Macintosh™ 512K enhanced, Macintosh
Plus, Macintosh SE, and Macintosh II. A second disk drive is
required; a printer is recommended but not required.

About this guide

This guide assumes that you have set up your Macintosh and have
read the owner’s manual. You should know how to use menus, how
to click and drag with the mouse, and how to copy documents and
applications in the Finder.

You don’t have to read this guide straight through. Dive in, try
things out, experiment, have fun.

Here are some suggestions for using the guide:

0O If you've never used a Macintosh graphics program before, turn
to the tutorial exercises in Chapter 1, “Learning MacPaint.”

O If you're experienced with Macintosh graphics, you can skip
directly to Chapter 2, “Using MacPaint.” This chapter presents a
series of step-by-step procedures, each describing how to
perform one task with MacPaint.

O If you've already used earlier versions of MacPaint, the summary
of new features at the end of this preface may be all you need to
get started.

0O When you need to know about a specific menu, command, or
dialog box, see Chapter 3, “MacPaint Reference,” which briefly
describes every MacPaint command.

O
%

About the Command key: Throughout this guide, you’ll see
references to the Command key. On some Macintosh
keyboards, the Command key is labeled with the cloverleaf
symbol. On other keyboards, it bears the Apple® symbol as
well as the cloverleaf. This guide refers to both of these keys as
the Command key.



Summary of new features

MacPaint 2.0 is an enhanced version of MacPaint, the first graphics
application for Macintosh computers. Here’s how version 2.0
differs from earlier versions of MacPaint.

O You can open up to nine documents at a time, depending on how
much memory is available in your Macintosh. (With a Macintosh
512K enhanced, you may be limited to opening two windows at a
time.)

O When you open a document, MacPaint creates a window as large
as the screen allows, up to the size of a MacPaint document (8 by
10 inches).

O Tools and patterns are located in menus that you can pull down
or relocate anywhere on the screen.

O A document scrolls automatically when a drawing or selection
tool reaches the edge of a window, letting you draw or select
objects beyond the limits of the window.

O You can zoom in to magnify a picture 200, 400, or 800 percent
and use all the tools in the magnified view.

O You can zoom out to see a document reduced by 50 percent and
use all the tools in the reduced view.

O You can draw ovals, circles, rectangles, and rounded rectangles
from the center outward or from corner to corner.

O As you create a document, you can take a “snapshot” of a picture,
which MacPaint keeps as you work. Then at any time, you can
change all or part of the document back to the way it originally
appeared in the snapshot.

Summary of new features XV
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Preface

You can use a “magic” eraser to make erased images reappear in
a picture.

You can temporarily change all the tools (except the text tool) to
the grabber (the hand tool) by holding down the Option key.

You can draw shapes with different vertical and horizontal line
weights. Curves and diagonal lines can graduate from one line
weight to another.

You can choose how patterns mix, letting one pattern appear
transparently through another, or completely cover another.
You can even “erase” with a pattern.

You use the Command key (instead of the Option key) to create
patterned lines and borders.

You can specify the spacing between grid lines as 2, 4, 8, 16, or
32 pixels (or screen dots). (In earlier MacPaint versions, the
spacing is 8 pixels.)

The selection rectangle disappears as you move a selection,
allowing you easily to position small selections with precision.

A mouse position inset (a small window) provides a gauge
displaying the location and distances the pointer moves in
pixels, inches, or centimeters, helping you draw lines and
shapes with precision.

You can set up a document, choosing the options and drawing
the images you use routinely, and save it as “stationery.” You can
then open the stationery document when you need to create a
new document and start work with the basic document format
already set up.



Important

Warning

Definitions of terms and
references to other parts of the
book sometimes appear this
way, in the margin.

Some conventions used in this guide

Several special elements in this manual’s text are designed to make
learning easier.

< By the way: A note like this presents additonal information or
interesting sidelights.

Be sure to read every item that's labeled this way.

Warnings like this alert you to situafions where you could
damage software or hardware or could lose data.

Terms in boldface type are defined in the glossary. Sometimes the
definition or additional information also appears in the margin.

% Keyboard equivalent: These notes tell you keyboard shortcuts
for menu commands.

Some conventions used in this guide xVii
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Chapter 1

Learning MacPaint



Chapter 1, “Learning MacPaint” introduces the basic drawing
procedures used to create MacPaint documents. You’ll use many of
MacPaint’s features as you create several drawings. You'll learn to
draw lines, rectangles, and ovals; to paint with the paintbrush,
spray can, and paint bucket; and to change, erase, and copy
portions of a drawing, as well as many other drawing procedures.

This chapter provides step-by-step instructions that explain how to
use MacPaint. After reading a hands-on introduction to MacPaint’s
tools, you'll perform two exercises in which you’ll complete a
landscape and a business logo. If you don’t consider yourself
particularly expert at producing art, don’t worry. This tutorial
explains and shows exactly what to do.

After completing the exercises, you should be familiar enough with
MacPaint to strike out on your own. You can then refer to Chapter 2,
“Using MacPaint,” when you want instructions for specific MacPaint
procedures. You can turn to Chapter 3, “MacPaint Reference,”
when you want to look up the meaning and use of a MacPaint
command.

Before you use MacPaint, you should make a working copy of the
program disk and keep the original in a safe place. Refer to your
Macintosh owner’s guide for information about copying disks. Use
the working copy during the tutorials and when you create MacPaint
documents on your own. If you use a hard disk with your Macintosh,
copy the contents of the program disk onto the hard disk. Also make
sure that the system you use is the same version (or later) of the
system specified on the MacPaint box.

Chapter 1: Learning MacPaint



Starting MacPaint

1. Turn on the Macintosh.

Important  If you have copied the program disk onto a hard disk, locate
the MacPaint application and sample documents on the
desktop or open the folder that contfains them and skip fo
step 4.

2. Insert a system disk in a disk drive.
3. Put the working copy of your MacPaint program disk in a disk

drive.
Anicon is an image that After a few moments, the icon for the MacPaint disk appears. A
g{)?gg“cglcl:yo;nec%g‘?egrf; an window opens displaying the MacPaint program icon and an
messog';e. ’ icon for a MacPaint document called Landscape, among several

other icons (see Figure 1-1). You'll start by opening and
examining the Landscape document.

& File Edit Diew Special

MacPaint =rta0—0————=—=
&18K in disk 161K available

i

MacPaint Landscape

Landscape document icon

MacPaint disk icon

Figure 1-1
The MacPaint desktop

Starting MacPaint 3



Menu bar

Important

If the window displaying the MacPaint program icon doesn’t
appear, either click the MacPaint disk icon to select it and
then choose Open from the File menu, or double-click the
MacPaint disk icon.

4.

Either click the Landscape document icon to select it

(the icon appears highlighted when selected) and choose
Open from the File menu, or double-click the Landscape
document.

After a few moments, a window opens showing a landscape
created with MacPaint (see Figure 1-2). Later in this tutorial you’ll
complete the landscape by drawing a tree like the others pictured
here and placing it over the X.

The drawing tools and patterns used to create a drawing such as
the one in Figure 1-2 are found in the Tools and Patterns menus.

R

% File Edit Goodies Font Style Patterns Tools ]

Close box
Title bar

"Landscape" at 100%

Zoom box

Drawing area

Scroll bars

Size box

Figure 1-2
MacPaint landscape
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Oval tool
Pencil

< By the way: If you're using a large-screen monitor, you may wish

to resize the window so that it approximately matches the screen
size shown in the figure. That way, what you see on the screen will
match the illustrations in this guide.

. Position the pointer on the Tools menu and press and hold

down the mouse button.

The Tools menu appears as shown in Figure 1-3.

( & File Edit Goodies Font Style Patternsm

b’

[J "Landscape" at 100%

(4
i |

Eraser

+/

Figure 1-3
The MacPaint Tools menu

The Tools menu contains tools that let you draw lines and
shapes, add patterns and text, and change your picture. For
example, the pencil is used for drawing lines, the oval tool for
drawing ovals and circles, and the eraser for erasing unwanted
portions of a drawing.

If you like, you can “tear off” the Tools menu from the menu bar
and place it anywhere on the screen.

Starting MacPaint 5



5. Hold down the mouse button to display the Tools menu and
then move the mouse to drag the menu to the position
shown in Figure 1-4. Release the mouse button.

( ®. File Edit Goodies Font Style Patterns j
EED% "Landscape" at IUD%H_ ST110E HIE

Tools menu drag bar Figure 1-4
The Tools menu being torn off and repositioned on the screen

As you position the menu, an outline appears showing the
location of the menu when you release the mouse button. If you
want to reposition the menu, position the pointer on the drag bar
at the top of the window and drag the menu to a new location.
(You can also pull down the menu again, tear it off, and place it
in a new position.)

-1

A ﬂ'h —

10
3|0

o

Now examine the patterns you can use to create a MacPaint
document.

6. Position the pointer on the Patterns menu, press and hold
down the mouse button, drag the menu to the position
shown in Figure 1-5, and release the mouse button.

o) Chapter 1: Learning MacPaint



( @ File Edit Goodies Font Style Patterns Tools

—

"Landscape"” at 100%

Figure 1-5
The Patterns menu torn off and repositioned on the screen

Similar to an artist’s palette, the Patterns menu holds a
selection of patterns ready for use in a drawing. You can apply
patterns to the pictures you draw in much the same way as you
apply paint. For example, you can use the paintbrush tool to add
strokes of black, white, or any other pattern to your picture.

You can create MacPaint documents with or without the Tools or
Patterns menus on the screen. If one of the menus gets in the way,
drag the menu around the screen with the drag bar or click the
close box to put it away. After you put a menu away, you can still
choose a pattern or tool by pulling down the appropriate menu
from the menu bar.

You can also have MacPaint record the way you like to work with
the menus by choosing the Preferences command in the
Goodies menu. After you indicate your preferences, MacPaint
will set up the menus just as you want them each time you open
the document.

Now you're set to start drawing. Your tools and patterns are in view,
and you have a clear picture of the road ahead.

Starting MacPaint 7



A quick tour of the tools

Next, you'll try each of the tools on the Tools menu. You'll use the
tools to draw lines and shapes; to paint with patterns; to erase,
reposition, and change parts of a drawing; to draw with lines of
different thicknesses, or weights; and to add text to a document.

Important As you complete the tutorial, you’ll work with several
documents on the screen at one time. If you have a 512K
Macintosh, your computer cannot open more than two
documents at a time. If you open two documents at the same
fime, you cannot use the Take Snapshot command because
of memory limitations. During this tutorial, work with only
one document open at a time. When asked to open a new
document, close the currently open document and then open
a new one.

Close the currently open document by choosing Close from the
Edit menu. You may see a dialog box asking if you wish to save
the document. Save the document, if you wish, but it is not
necessary to save it to complete the tutorial. You can then
choose New to open a new document. Tear off the Tools and
Patterns menus as you did in the previous section and
continue following this tutorial.

Drawing lines
Before you add anything to the landscape, you'll create a new

document to use as a scratch pad for practice drawing.

1. Choose New from the File menu.

A new document appears partially covering the Landscape
document. You now have two documents open at the same time.

Depending on how much memory your Macintosh has, you can
work on up to nine documents at the same time. Now for some
practice drawing.

Chapter 1: Learning MacPaint



The pencil tool is currently selected. (If it is not selected, click

+ : T the pencil tool on the Tools menu.) Notice that the pencil tool in
— (jj ‘ the Tools menu is highlighted, and the pointer becomes a pencil
L5 (L) whenever it is positioned over the drawing area.

{ﬁ? H O 2. Position the pointer over the document at the place you
@ T |O|E wish to begin drawing a line.

M@ 3. Hold down the mouse button, move the mouse in the

A é?‘ﬂ’ direction you want to draw, and release the mouse button

to stop drawing.

Don’t worry about how the line looks; this is just practice.

W

If you do something you wish you hadn’t, you can undo your last
action.

4. Choose Undo from the Edit menu.

Your line disappears, allowing you to draw a new one. Undo
works on any command or drawing procedure that changes the
content of a document. It undoes only the last action you took,
however.

Drawing straight lines can sometimes be a painstaking task with
paper, pens, and rulers. Not so with MacPaint.

5. Click the line tool on the Tools menu.

6. Position the pointer over the document at the place you
wish to begin drawing a line.

A quick tour of the fools Q
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7. Hold down the mouse bution, move the mouse in the

direction you want the line to go, and release the button
when you want to stop drawing.

As long as you hold down the mouse button, you can stretch and
reposition the line as you wish. Try drawing several vertical,
horizontal, and diagonal lines.

< Note: Most of MacPaint's tools work the same way, requiring
you to hold down the mouse button, move the mouse, and
release the mouse button to stop using the tool. From now on,
instructions will simply ask you to drag with the mouse when
using a tool.
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1. Click the paintbrush on the Tools menu.

In addition to painting with solid colors, you can choose a
pattern to apply like paint.

2. Click a gray pattern in the Patterns menu, as shown in
Figure 1-6.

Pattern box

Figure 1-6
Selecting a gray pattern

The pattern you select appears in the pattern box at the top of the
Patterns menu. MacPaint applies this pattern as you paint until
you select a different pattern.

3. Position the pointer in the drawing area.

4. Drag the pointer across the document and release the
mouse button to stop painting.

A quick tour of the fools 11



Try painting with several different patterns. Later, you'll learn to
paint with brushes of different sizes and shapes.

Now see how the spray can lets you apply patterns using a
different technique.

5. Click the spray can on the Tools menu.
I i 6. Click the brick pattern in the Patterns menu, as shown in
= [ Figure 1-7.
ol & [
P
Alo=

TR &
A & e

Figure 1-7
Selecting the brick pattern
7. Position the pointer over the drawing area.

8. Drag the spray can pointer to apply the pattern; release the
button when you want to stop.

You can also point and click with the spray can to apply
individual spots of paint. Notice that if you spray paint over the
same spot, the pattern becomes more apparent. Try it.

You've experimented with drawing lines and painting. Now clean
up some of your handiwork with the eraser.
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Erasing

You use the eraser to sweep over and erase images and text,
much like you use a chalkboard eraser. But what happens if you
accidentally erase something you wanted to keep? MacPaint also
provides a “magic” eraser that makes erased images reappear in
your document.

1. Choose Take Snapshot from the File menu.

Whenever you’re about to erase or to perform a drawing
procedure that you’re unsure of, you can take a snapshot of the
document, so that MacPaint memorizes the way the document
looks.

If you become dissatisfied with your drawing, you can later use
the snapshot to return the document or a part of the document to
the way it appeared originally. You'll see how this technique
works in a2 moment, when you use the magic eraser.

2. Click the eraser in the Tools menu.

3. Position the pointer over an image that you want to erase in

the drawing area.

4. Drag the eraser and release the button when you want to
stop erasing (see Figure 1-8).

Figure 1-8
A picture being erased with the eraser tool
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What if you erase too much? You can use the magic eraser to
bring the original drawing back into view.

5. Hold down the Command key and drag the eraser over part
of the document thal’s been erased.

The images in your document reappear. By alternating the eraser
and the magic eraser, you can erase just the parts of the drawing
that you want to eliminate.

If you want to erase an entire document, MacPaint provides a
shortcut.

6. While holding down the Shift key, double-click the eraser
tool on the Tools menu to erase the entire document.

With two clicks, the document is wiped clean, and you're ready
for more drawing.

Rectangle tool

Rounded ———— () | )

rectangle tool
Oval tool ———

=
' '
[Ap—

A [~

Figure 1-9
Selecting the rectangle tool

Drawing rectangles and ovails

MacPaint provides tools that make it easy to draw rectangles, ovals,
circles, and squares. You can choose whether the shapes are hollow
or filled with a pattern.

Now try drawing a few shapes.

1. Click the hollow rectangle tool in the Tools menu, as shown
in Figure 1-9.

2. Position the pointer near the upper-left corner of the
document, where the corner of the rectangle will appear.

The pointer becomes a crossbar, with the center point
indicating where the rectangle will begin.
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3. Hold down the mouse button and drag diagonally to where
the opposite corner of the rectangle should be, as shown in
Figure 1-10.

Figure 1-10
Drawing a rectangle

As long as you hold down the mouse button, you can adjust the
size of the rectangle. Once you release the button, however, the
rectangle is complete.

4. Release the mouse button fo stop drawing the rectangle.

With the rectangle and oval tools, you draw shapes by dragging
in the manner described here. From now on, instructions will
simply tell you to drag diagonally rather than giving the steps
for pressing and releasing the mouse button.

Next you'll draw rectangles, squares, ovals, and circles similar

Rectangle

Oval

to those pictured in Figure 1-11.

P
Rounded rectangle
L™
Square
Circle
Figure 1-11

A rectangle, a rounded rectangle, a square, an oval, and
a circle
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5. Click the filled rectangle tool (which appears gray next to
the hollow rectangle tool in the Tools menu).

6. Drag diagonally with the mouse to draw a filled rectangle.

Isn’t it amazing to draw rectangles that fill with a pattern so
easily? You can fill rectangles or ovals with any pattern you
select from the Patterns menu.

Here’s how to draw squares.

7. Click a different pattern on the Patterns menu.
8. Hold down the Shift key and drag with the mouse to draw a

filled square.
To constrain a tool limits its use Holding down the Shift key as you draw constrains the
fo drawing specific shapes or rectangle tool so that it produces squares only.
moving the pointer in specific
directions.

9. Click the hollow rounded rectangle tool on the Tools menu.

10. Position the pointer over the drawing area and drag
diagonally to draw a rounded rectangle.

11. Click the hollow oval tool in the Tools menu.

12. Position the pointer over the document and drag
diagonally to draw an oval.

13. To draw a circle, position the pointer over the document,
hold down the Shift key, and drag diagonally.

Try experimenting with the rectangle and oval tools as you
practice drawing these shapes.
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Using the grabber

After all your drawing, you may not have much room left on the
screen. MacPaint documents can be as large as 8 by 10 inches,
however. You can use the scroll bars to bring a different part of your
document into view. MacPaint also provides a tool called the
grabber, which is handy for quickly adjusting the position of a
document on the screen.

1. Click the grabber on the Tools menu.

2. Position the pointer at the bottom of the screen.

3. Hold down the mouse button, drag toward the top of the
screen, and release the button when you want to stop
scrolling.

Scroll the document far enough to give you a nearly blank screen
with more room for drawing. Your screen should look similar to
Figure 1-12.

& File Edit Goodies Font Style Patterns Tools |
"Landscape" at 100%
[I==————"—— "Untitled-2" at 100%

I}

!

Q== /D)=

The grabber : o

G|0|0|0
¢|0|0|H

i

Figure 1-12
Scrolling with the grabber

% Note: Except for the text tool, any tool becomes the grabber if
you hold down the Option key as you use the tool. This feature
lets you easily position your document on the screen at any time.
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Drawing freehand shapes and polygons

Sometimes you may want to draw irregular or curved shapes, such as
pear shapes, or you may want to produce angular shapes made up of
short connected line segments, such as triangles or stars.

You can draw curved irregular shapes with the freehand shape tool,
and you can draw shapes made up of angles and lines with the
polygon tool. As with the rectangle and oval tools, shapes drawn
with the freehand shape and polygon tools can be hollow or filled.

1. Click the hollow freehand shape tool.

2. Drag the freehand shape pointer over the document as
you draw a shape similar to the one shown in Figure 1-13.

Figure 1-13
Freehand shape

Because this is your first try at drawing a freehand shape, don’t
worry if the shape doesn’t match the one in the figure.
Remember, you can always choose Undo from the Edit menu
and try again.
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3. Click the filled freehand shape tool.
4. Click a pattern on the Patterns menu.
5. Drag the freehand shape pointer over the document as

you draw a shape similar to the one pictured in Figure 1-14.

Figure 1-14
A filled freehand shape

Notice how the shape automatically fills with a pattern. If you
draw a filled freehand shape in which the two ends of the line
don’t connect, MacPaint automatically connects the ends with
a straight line and fills the shape’s interior with a pattern.

Next, you'll draw a polygon.

A quick tour of the tools
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7. Position the pointer at the bottom of the document, hold
down the Option key fo display the grabber, and drag
upward to make more room for drawing a polygon.

You'll draw a polygon similar to the one shown in Figure 1-15.

Figure 1-15
A polygon

8. To draw a polygon, position the pointer over the document
and click to start drawing a line. (Don’t hold the mouse
button down; just click once.)

9. Move the mouse to where the end of the first line segment
should be and click to tack down the line.

Now you can draw another line at a different angle from the end
of the first line.

20 Chapter 1: Learning MacPaint



10. Move the mouse to where the end of the second line

segment should be and click once to tack down the line.
Continue drawing line segments this way as you draw an
incomplete polygon similar to the one in Figure 1-16.

Figure 1-16
An incomplete polygon

You can leave a polygon open-ended as in Figure 1-16, or you

can connect the last line to the first to create a closed polygon.

To stop drawing a polygon, you either double-click where the
last line segment should end or position the pointer on the
starting point of the polygon and click once.

You'll close up this polygon.

. Move the mouse to the starting point of the polygon and

click to create a completed polygon similar to the one
shown in Figure 1-15.

A quick tour of the tools
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Painting with the paint bucket

After you draw a hollow shape—such as a rectangle, oval, freehand
shape, or polygon—you can fill the shape with a pattern. You use
the paint bucket tool to fill hollow shapes. The effect of the paint
bucket tool is similar to pouring paint into a container (your hollow
shape) until the shape is entirely filled.

To try out the paint bucket, you’ll fill the polygon you just drew.
1. Click the paint bucket tool.

2. Click the waffle pattern (or any other pattern you like) on
the Patterns menu, as shown in Figure 1-17.

7
S s
VNP

G e
i Ft b g
ettt

Figure 1-17
Selecting the waffle pattern
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Tip of paint bucket

Important

3. Position the tip of the paint dripping from the paint bucket
within the polygon and click.

The polygon is filled with the pattern, as shown in Figure 1-18.

Figure 1-18
A filled polygon

When you use the paint bucket, make sure no “leaks” (open
white gaps) occur in the shape you're filing. A paint patftern
can escape through the leak and fill more of the drawing than
you intend. If you discover a leak, choose Undo to cancel the
effect of the paint bucket, and close the leak by drawing
across it with a drawing tool.

A quick tour of the tools
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Choosing different line weights

As you draw lines and shapes in your documents, you’ll probably
want to vary the thickness of the lines. You can choose from five line
weights (or thicknesses), and you can even specify that a shape be
drawn with invisible lines (if you want a filled shape to appear with
no line or border, for example).

The top part of the Tools menu lets you choose the weight of the
lines drawn by the line and shape tools (although not with the pencil
or painting tools.)

J0
1l

1. To draw in an empty document, choose New from the File
menu.

A new empty document appears. Notice that it’s called
“Untitled-3” to differentiate this new document from the other
untitled document that was covered up. You now have three
drawings, or documents, open at once: Landscape, Untitled-2,
and Untitled-3. You'll later learn how to quickly choose one
document to work on from among several.

Next, you'll draw the oval and rectangles that appear in
Figure 1-19.

& File Edit Goodies Font Style Patterns Tools
"Landscape" at 100%
"Untitled-2" at 100% 0

"Untitled-3" at 100% —=—JF

| |

[}
L]

EE

b

Figure 1-19
Shapes drawn with different line weights
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Line weight indicator box

"N

Figure 1-20
The thickest line weight
is selected

C LA

Figure 1-21
Selecting the thinnest
line weight

Cad

 SHRIT T L

Figure 1-22

Combining the thinnest
line weight and the
thickest line weight

in one shape

. Click the hollow oval tool in the Tools menu.

First you’ll draw an oval with a thick border.

. Position the pointer on the thickest line weight and click

once fo select it, as shown in Figure 1-20.

Arrows appear above and below the line weight you've selected.
The line weight indicator box shows that this weight will be used
for both horizontal and vertical lines.

. Position the pointer over the drawing area and drag to draw

an oval similar to the one in Figure 1-19.

Next, you'll draw a rectangle that has thick horizontal lines and
thin vertical lines.

. Position the pointer above the thinnest line weight (not

on it) and click as shown in Figure 1-21. (Don't click on the
dotted line weight, since that symbol selects an invisible
line.)

The top arrow appears above the thinnest line weight, indicating
that vertical lines will be drawn at this weight. An arrow also
appears below the thick line weight previously chosen, showing
that this weight remains selected for the horizontal line weight.
The line weight indicator box in the upper-left corner of the
Tools menu shows that you’ll draw with thick horizontal lines and
thin vertical lines.

6. Click the hollow rectangle tool.

7. Position the pointer and drag to draw a rectangle similar to

9,
°

the one in the center of Figure 1-19.

Last, draw a rectangle with thick vertical lines and thin horizontal
lines.

. Click below the thinnest line weight (not on i) and then

click above the thickest line weight, as shown in Figure 1-22.

. Position the pointer and drag to draw a rectangle similar to

the one on the right in Figure 1-19.
You've seen how to change the thickness of the lines and borders
in the shapes you draw.

Note: If the vertical and horizontal lines weights aren’t identical,
any curves or diagonal lines you draw graduate from one weight
to the other.
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Using the selection tools

What if you want to copy an image, move part of a drawing to a new
position, or enlarge or reduce an image? You can carry out all of
these editing procedures, and many others, by using the selection
tools. The selection tools allow you to select part of a drawing and
drag the selection or choose a command to effect the change you

want.
F Q The two tools that let you select portions of your pictures are the
L—d selection rectangle tool and the lasso tool, shown in Figure 1-23.
Figure 1-2§ You're going to move the oval you just drew to a new position.
The selection rectangle tool When you want to select an irregular shape, you use the lasso tool to

and the lasso ool .
select it.

1. Click the lasso in the Tools menu.

2. Position the lasso pointer beside the oval.

_E To select an image, encircle it by dragging the lasso around it.
The lasso trails a line from the tip of the lasso pointer.

i
gr
3
3. Drag the lasso in a complete circle around the oval to
select it, as shown in Figure 1-24, and release the mouse

button.
The lasso trails a line from its tip

Figure 1-24
The oval encircled by the lasso tool

When you release the mouse button, the lasso tightens to select
the area enclosed by the black outline of the oval. The selected
part of the picture shimmers.
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4. Position the pointer on the oval, hold down the mouse
button, and drag the oval to the new position, as shown in
Figure 1-25.

Notice that the lasso becomes the arrow pointer when
positioned on the selection, signalling that you can now drag
the selection.

Figure 1-25
The oval dragged to a new position

Now you see how easy it is to rearrange the images you draw.
When an image is selected, you can also choose a command to
manipulate it.

5. With the oval still selected, choose Copy from the Edit
menu.

6. Click somewhere in the document to deselect the oval,
and choose Paste from the Edit menu.

A copy of the oval appears in the middle of the window.

7. With the copy of the oval still selected, drag the oval to
the position shown in Figure 1-26.

OLLIO

Figure 1-26
A duplicate oval moved to a different position
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Another way to select part of a drawing is with the selection
rectangle tool.

8. Click the selection rectangle tool on the Tools menu.

To select images with the selection rectangle tool, drag to draw
a rectangle around the images.

Now reduce one of the rectangles you drew to half its size. Begin
by selecting it with the selection rectangle tool.

9. Position the pointer at one corner of the rectangle you
want to select and then drag diagonally until the rectangle
is totally encompassed by the selection rectangle, as
shown in Figure 1-27. Release the mouse button.

Figure 1-27
A rectangle selected with the selection rectangle tool

When you release the mouse button, a dashed rectangle
shimmers around the selected image. Notice that the

A selection box is a box drawn selection box does not shrink to fit the image and that it
with the selection rectangle. Al selects not only the area within the rectangle, but white space
images enclosed by the box are :

selected. around the selected image as well.
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10. With the rectangle selected, choose Scale Selection from
the Goodies menu.

Scale selection to:

Figure 1-28
The Scale Selection dialog box

The dialog box shown in Figure 1-28 appears, asking you to type
the percentage of enlargement or reduction you wish. For
example, to enlarge a selection to twice its size, you type “200”
(for 200-percent enlargement). To reduce the rectangle to half
its size, you type “50” (for 50-percent reduction).

11. The dialog box is preset for 50-percent reduction, so click
OK. (If a number other than 50 appears, type “50” in the
dialog box and click OK.)

As Figure 1-29 shows, the lines making up the selected rectangle
shrink to half their previous size.

Figure 1-29
The selected rectangle has been reduced
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In addition to enlarging and reducing parts of a drawing, you can
use other MacPaint commands to make such changes as rotating or
flipping a selection. After you finish this tutorial, refer to Chapter 3,
“MacPaint Reference,” for more information about MacPaint
commands.

Adding text to a document

A picture can be worth a thousand words, but a diagram without
words can be confusing. You can easily add words to a document
with the text tool. Your text can appear in any number of fonts,
fonts sizes, and font styles.

1. Click the text tool on the Tools menu.

Now add a caption under the ovals and rectangles in the
document.

2. Position the I-beam pointer (shaped like the capital letter /)
over the document under the ovals and rectangles and
then click.

3. Type “Four MacPaint Images,” as shown in Figure 1-30.
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& File Edit Goodies Font Style Patterns Tools

"Landscape"” at 100%

"Untitled-2" at 100%

"Untitled-3" at 100% =—

OcllO

Four MacPaint Imagﬁ

R(C|00)@

Text insertion point

One point equals about
1/72 inch, so 18-point
characters are about
1/4 inch high.

Figure 1-30
Typing a caption

Until you click the mouse button or choose another tool, you can
backspace to make corrections; press Return to start a2 new line;
and change the font, font size, font style, and alignment of the
characters you've typed.

4. Choose New York from the Fonts menu.
Your text changes to a different font.
5. Choose 14-point size from the Style menu.

The text enlarges to 14-point size. Try experimenting with
different fonts, font sizes, and font styles to familiarize yourself
with adding text to your drawings.

Now that you've had an introduction to MacPaint's tools, you can
get back on the road in the next exercise and complete the
landscape you saw earlier.
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Exercise 1: Drawing a tree

In this exercise, you'll draw a tree and complete the Landscape
document so that it looks similar to the picture in Figure 1-31. You'll
draw the tree in one document and then copy it into the Landscape
document.

Figure 1-31
MacPaint landscape
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1. Choose New from the File menu.
A new document appears on screen.
2. Click the paintbrush on the Tools menu.
3. Choose Brush Shape from the Goodies menu.

4. Choose the next-to-the-largest round brush shape
by clicking it in the Brush Shape dialog box, shown in
Figure 1-32.

When you click a brush shape, the dialog box disappears.

nHe NI -
Hie| - N I — 7
R
H ® Z N =
Figure 1-32

Brush shapes from the Brush Shape dialog box



5. Near the middle of the window, paint a tree trunk with
branches. Make it about the same size as in the figure.
Hint: Your tree will look best if each stroke begins in the trunk
and ends with a branch.

Tree trunk

6. Choose Brush Shape from the Goodies menu. Choose the
next-smallest paintbrush in the Brush Shape dialog box, and
add smaller branches to the tree.

Adding branches

7. Choose Brush Shape from the Goodies menu, choose the
smallest round paintbrush shown in the dialog box, and add
smaller branches to the tree.

You might also add some roots around the base of the tree.

Tree with two sizes of branches
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Tree with three sizes of branches

Tree with light foliage

Tree with darker foliage

. Again, choose Brush Shape from the Goodies menu. Choose

the smallest paintbrush available, which is a single dot (in
the bottom right of the Brush Shape dialog box). Then add
smaller branches to the tree.

Now with the branches drawn, you can add some foliage. But
before you do, take a snapshot of your tree so that you can erase
or alter parts of your drawing and then use the magic eraser as
you work.

. Choose Take Snapshot from the File menu.

Now you can use the magic eraser any time you want to erase
and redraw the tree as you add foliage to it.

. Click the spray can tool on the Tools menu.

. Point and click with the spray can to add spots of paint to

the outer branches.

. Drag the spray can in short strokes to darken foliage on the

inner branches.

With the tree complete, it’s time to select it and place it in the
Landscape document.
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. Choose the lasso from the Tools menu and use it to select
the tree.
. Choose Copy from the Edit menu.

The Copy command puts a copy of the selection onto the
Clipboard, a part of memory that holds information being
moved or copied from one place to another.

Now bring the Landscape document back into view.

. Choose Landscape from the Goodies menu.

All the open documents are listed at the bottom of the Goodies
menu. When you choose a document name, that document
moves to the active window.

If you have a 512K Macintosh, you cannot open more than one
document at a time. Instead of choosing Landscape from the
Goodies menu, you must close the current document, saving it
on the disk, if you wish, and then open the Landscape
document. Tear off the Tools and Patterns menu and position
them on the screen as you did in the beginning of the tutorial.

Your screen should look like Figure 1-33. You'll place the tree
on the right side of the road.

16. Click the close box on the Patterns menu to put the menu

away.
The X, where you will place the tree, comes into view.

Chapter 1: Learning MacPaint
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Figure 1-33
Landscape

17. Choose Paste from the Edit menu.

A shimmering copy of the tree appears in the center of the
window.

18. Position the pointer on the tree and drag the tree to where
the X is located on the right side of the landscape. Then
click somewhere else in the document to deselect the tree.

Voila! You've completed your first work of MacPaint art.

19. Save the document by choosing Save As from the File
menu.

20. Type a name for the document and click Save.
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Exercise 2: Creating a business logo

Getting down to business now, you'll create a logo for a pie
company. You'll draw the company’s apple pie emblem and
complete the logo shown in Figure 1-34.

Figure 1-34
Completed business logo
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Choose these line weights

. Close all the open documents.

To keep the screen from being too crowded, close the
documents currently open. To close a document, you first
activate the document by clicking in it or by selecting its name
from the Goodies menu. Then choose Close from the File menu
or click the close box on the left side of the title bar. You can
save the documents if you wish, but it’s not necessary for this
exercise.

2. Choose New from the File menu to open a new document.

3. Tear off the Tools and Patterns menus and position them on

the screen where you wish.

. Choose the light vertical and heavy horizontal line weights

from the Tools menu.
You'll begin by drawing the top of the pie.
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An oval as the top of the pie

Erase part of the pie fop

Draw the pie top

Draw the pan bottom

10.

. Use the hollow oval tool @ o draw an oval of

approximately the same size as shown here.

Because pies aren't perfectly flat, you'll erase part of the oval
and draw an irregular mounded top.

. Click the eraser tool and erase the top third of the

pie.

. Choose Brush Shape from the Goodies menu and then click

the small round brush shape.

. Use the paintbrush tool @ to draw the top of the pie as

an irregular mound.
Now, draw the bottom of the pie pan..

. Click the hollow oval tool and draw another, slightly

smaller oval under the top of the pie as the pan bottom.

For ease of drawing, draw the pan bottom well below the top of
the pie. You can then select and move the pie top into place.

Click the lasso tool, ﬂ lasso the top of the pie to select
it, and drag the pie top down over the pan bottom.

Remember, the lasso tool is best for selecting the pie top,
because the area you lasso shrinks to fit the image, allowing you
to drag the pie top closely down over the pan bottom.
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Draw sides of pie pan

Paint out the unwanted lines

Shade the pie crust

Shade the pie pan

12.

13.

14.

L
Click the paintbrush tool, E click the white pattern, and
paint out the unwanted curved lines inside the pan.

Painting with white paint can have the same effect as erasing.
You can choose different size paint brushes to paint out
unwanted images in tight spots that the eraser might not fit
within.

Choose a gray pattern from the Patterns menu and add
some shading to the pie crust with the paintbrush.

You can use shading to add contrast and heighten the interest

of a drawing. Apply just enough paint to the pie top to create the
sense of an irregular surface.

Click the paint bucket tool, LA | elick a dark pattern of
your choosing, and click within the pie pan to fill it with the
pattern.

Filling the pie pan with a dark color is easy with the paint bucket
and provides contrast that makes the pie stand out.

If paint leaks through a break in the outline: Choose Undo from
the Edit menu, repair the leak, and fill the pie pan again.
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Now move the pie emblem into the background of the company
logo, which has already been drawn for you and saved on disk.

15. Click the lasso, drag around the pie to select it, and choose
Copy from the Edit menu.
A copy of the pie emblem is now on the Clipboard ready to be
pasted into another document.

16. Choose Open from the File menu, click the document name
Logo, and click Open.

Important  If you have a 512K Macintosh, you cannot open more than one
document at a time. Close the current document, saving it on
the disk, if you wish, and then open the Logo document. Tear
off the Tools and Patterns menu and position them on the
screen as you did in the beginning of the tutorial.

You're all set now to paste the pie into this document and
complete the logo.

17. Choose Paste from the Edit menu.

18. Drag the selected pie into position, as shown in Figure 1-35,
and click somewhere else in the document to deselect the

pie.
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Figure 1-35
Completed logo

The company logo is complete—thanks to you and MacPaint.

19. If you want to keep the logo, choose Save As from the File
menu, type a new name, and click Save.

What next?

You've now completed the tutorial. From this point, you can

O go on to Chapter 2, “Using MacPaint,” which provides step-by-
step instructions and tips for performing common drawing tasks.

O go on to Chapter 3, “MacPaint Reference,” which explains the
commands found in menus and dialog boxes.

O put this book aside and explore MacPaint on your own.

What next? 43
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Using MacPaint




Chapter 2, “Using MacPaint,” explains the basic procedures for
using MacPaint. You don't have to read this chapter from
beginning to end; each topic in this chapter is independent of the
others. When you’re not sure how to perform a specific task, such as
printing part of a document, look up the procedure here and follow
the step-by-step instructions.

If you want the essential steps only, without a lot of explanation,
read the material in boldface. When steps are numbered, follow
them in order. Bulleted text offers tips or alternative procedures
that you may find useful.
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Using the Tools and
Patterns menus

You'll use the Tools and
Patterns menus more often
than the other MacPaint
menus because they provide
the tools and patterns used to
create pictures. For efficient
drawing, you can keep these
menus on the screen while
you work and you can move
them around to convenient
positions.

You can also pull down the
Tools and Patterns menus
and choose from them just as
you do with other menus
—what you choose is
represented by a graphic
image rather than a written
command.

When you move the pointer
over the document after
choosing a tool, the pointer’s
shape indicates the tool
you've chosen. For example,
when you choose the paint
bucket from the Tools menu,
the pointer takes the shape of
a paint bucket.

To keep the Tools or
Patterns menu on the
desktop

. Pull down the Tools or

Patterns menu (don’t
release the mouse
button).

. Drag the pointer beyond

the boundary of the
menu.

A dotted outline of the menu
follows the pointer.

. Release the mouse button

when the outline is where
you want the menu to be.

The menu snaps into place.

You can now choose a tool or
pattern by clicking it.

Click here to put the menu away

To move or put away the
Tools or Patterns menu

m Position the pointer on

the drag bar and drag to
move the menu to a new
position.

You can also pull down a
menu and tear it off again to
relocate it on the screen.

E Click the close box on the

left side of the drag bar to
put away the menu.

Drag here

]
@
(<

Tools menu

Patterns menu
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To constrain tools

You can limit, or constrain,
the movement of several of
the tools in the Tools menu so
that they draw or select
images in specific ways. If you
hold down the Shift key while
using one of these tools, it is
constrained in the ways
described here. Use Caps
Lock to constrain tools
continuously.

Hold down the Shift key
while using the
paintbrush, spray can,
pencil, or eraser to move
vertically or horizontally
only, but not diagonally.

® Hold down the Shift key

while using the line tool or
polygon tool to move
vertically, horizontally, or
at a 45-degree angle only.

Hold down the Shift key
while drawing with the
oval tool or rectangle tool
to draw circles or squares

only.
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Painting

You can use the paintbrush or
spray can with any of the
patterns in the Patterns
menu. You can change the
shape of the brush and paint
symmetrical forms. When
you're painting, MacPaint
patterns are preset to be
opaque and cover whatever
you paint over. However, you
can make them transparent
so they blend with whatever
you paint over.

To brush on patterns

. Choose the
paintbrush from

the Tools menu.

If you desire, choose a
different pattern from the
Patterns menu.

. Position the paintbrush
pointer in the document.

. Drag to brush on the

pattern and release the

mouse button to end the

stroke.

E To paint with transparent

patterns, hold down the
Command key while
dragging the paintbrush.

m Hold down the Shift key or

press the Caps Lock key as
you paint to make brush
strokes that are vertical or
horizontal only.
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To change the
brush shape

. Choose Brush Shape from
the Goodies menu, or if
the Tools menu is on the
desktop, double-click the
paintbrush tool.

A dialog box appears with
brush shapes and a square
around the current shape.

. Click a brush shape.

Clicking the selected shape
closes the dialog box. The
next time you use the
paintbrush, it will paint with
the new shape.

. Choose the spray g:.@

To spray paint

can from the Tools
menu.

If desired, choose a different
pattern from the Patterns
menu.

. Position the spray can

pointer in the document
and click to spot spray.
Drag the pointer to spray
continuously.

The spray can paints with the
selected pattern—except that
each pass of the spray can

pointer paints only part of the

pattern. If you keep dragging
the pointer back and forth
over the same area, the full
pattern eventually appears.

He NI -
E|® - N | -
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m Hold down the Shift key

or press the Caps Lock
key as you paint to spray
strokes that are vertical or
horizontal only.

To spray paint with
transparent patterns,
hold down the Command
key while dragging the

spray can.




To paint mirror images

. Choose Brush Mirrors
from the Goodies menu.

A dialog box appears with
lines that represent four axes
of symmetry.

. Click to select one to four
of the axes lines in the
box.

To deselect a selected axis,
click it again.

3. Click OK.

Whenever you paint with the
paintbrush, the brushstrokes
on one side of the center of
the window are duplicated as
a mirror image on the other
side along the selected axis.
You can create up to four
pairs of mirror images.

A check appears next to Brush
Mirrors in the Goodies menu

to indicate it’s active.

You can use Brush Mirrors at
the 100-percent and 50-
percent zoom levels only.

m To turn off Brush Mirrors,

choose Brush Mirrors
from the Goodies menu
and click None.

| 0K None
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Drawing lines and
shapes

MacPaint lets you draw lines,
rectangles, rounded
rectangles, squares, ovals,
circles, freehand shapes, and
polygons.

A shape can be hollow (just
an outline), or filled with a
pattern, including black or
white.

MacPaint is preset to draw
shapes starting from a

corner, but you can also draw
shapes from the center out.

The pointer appears as
crosshairs to allow accurate
positioning. You use its
center to mark the starting
point for your line or shape.

While drawing, you can use
the Shift or Caps Lock key to
constrain lines and
shapes—for example, you
can limit the rectangle tool to
drawing squares.

To learn about the special
effects you can attain by
overlapping filled shapes, see
“Option-Command Pattern
Effect” in Chapter 3.

Rectangle tool

Rounded rectangle tool

Oval tool

Freehand shape tool

Polygon tool
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To draw straight lines

. Choose the line tool
from the Tools
menu.

. Position the pointer
where you want the line to
begin.

. Drag the pointer to where
you want the line to end.

If no line appears, the dotted
line instead of solid in the
Tools menu may be selected
for drawing borderless filled
shapes. See “To Choose Line
Weights” in this section.

Hold down the Shift key or
press the Caps Lock key to
draw lines that are all
vertical, horizontal, or at a
45-degree angle only.

. Choose a

To draw a rectangle or
square

C 116
(|6

rectangle tool
from the Tools
menu.

Choose either the hollow or
filled rectangle or rounded
rectangle tool. If you desire,
choose a different pattern
from the Patterns menu when
drawing with a filled tool.

. Position the pointer

where you want one
corner of the rectangle to

appear.

3.

4.

Drag the pointer
diagonally.

Release the mouse button
when the rectangle is the
size and shape you want.

To draw a square or
rounded square, hold
down the Shift key or
press the Caps Lock key
while you use the
rectangle tool.
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. Choose an oval
O|é

To draw an ovall or circle

tool (either filled

or hollow) from the Tools
menu.

Choose either the hollow or
filled oval tool. If you desire,
choose a different pattern
from the Patterns menu when
drawing with the filled tool.

. Imagine that the oval is

going to be enclosed by a
rectangle, and position
the pointer at one corner
of that imaginary
rectangle.

. Drag the pointer

diagonally.

. Release the mouse button

when the oval is the size
and shape you want.

To draw a circle, hold
down the Shift key or
press the Caps Lock key
while you use an oval tool.

To draw a shape from the
center out

. Choose Draw From

Center from the Goodies
menu, and then choose
the desired drawing tool

If the Tools menu is on the
desktop, you can instead
double-click a rectangle or
oval tool in the Tools menu.

Crosshairs E_

appear within each

of the affected

shape tools in the

Tools menu. Any OIS

shapes drawn with
these six tools will be drawn
from the center outward.

2. Position the pointer where

you want the center of the
shape to be and drag to
draw the shape.

To draw a square or circle
from the center, hold
down the Shift key or
press the Caps Lock key as
you drag the tool.

To turn off Draw From
Center, choose Draw
From Edge from the
Goodies menu or double-
click one of the affected
tools in the Tools menu.

54
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To draw a polygon

. Choose a
polygon tool < |2
from the Tools menu.

Choose either the hollow or
filled polygon tool.

. Position the pointer
where you want to begin
the polygon.

. Click the mouse button.

4. Move the mouse to draw a

line (do not hold the
mouse button down).

. Click when you wish to
stop drawing the line and
want to start drawing
another line at a different
angle.

A line follows behind the
pointer and moves until you
determine the end point for
that line by clicking. Make
any straight-sided shape you

want. The lines can cross over

each other.

. To complete the polygon,

either click the original
starting point or double-
click anywhere else.

Hold down the Shift key or
press the Caps Lock key to
draw lines that are all
vertical, horizontal, or at a
45-degree angle only.

If you don’t close up a filled
polygon, MacPaint closes it
automatically with a straight
line connecting the starting
and ending points and fills
the shape. Hollow polygons
remain as drawn.

2 Il
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To draw a freehand shape

. Choose a
freehand shape ©
tool from the Tools menu.

Choose either the hollow or
filled freehand shape tool.

. Position the pointer and
drag to draw the line or
shape.

Lines can cross over each
other. It’s not necessary to
complete the shape where it
began.

. Release the mouse button
when the shape is the way
you want it,

m If you don’t close up a
Sfilled shape, MacPaint
closes it automatically with
a straight line connecting
the starting and ending
points. Hollow shapes
remain as drawn.
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To choose line weights

To choose a single line
weight for both vertical
and horizontal lines, click
on one of the lines at the
top of the Tools menu.

el

The dotted line represents an
invisible line you can use for
drawing borderless filled
shapes.

To choose the weight of
vertical lines, click just
above one of the six lines
at the top of the Tools
menu.

+|i1enn

A small triangle points down
to the chosen vertical line
weight.

Chapter 2: Using MacPaint

E To choose the weight of
horizontal lines, click just
below one of the six lines
at the top of the Tools
menu.

eI
S

A small triangle points up to
the chosen horizontal line
weight.

If you've chosen different
vertical and horizontal line
weights, any curves or
diagonal lines you draw
change gradually from one
weight to the other.



Working with patterns

You can add shading and
contrast to drawings by
applying patterns with the
paintbrush, spray can, paint
bucket, and filled shape
tools. The Patterns menu
provides a selection of
patterns ready for use. You
can also replace patterns on
the menu with patterns of
your own.

I’s important to choose the
appropriate drawing tool for
the way you want to apply the
pattern to your drawing.

You can use the paintbrush to
“stroke” the pattern onto the
drawing as if you were using a
brush. You can use the spray
can to create an effect similar
to spraying a pattern onto the
drawing. With the paint
bucket, you can add a pattern
to fill a shape.

You can also use the filled
shape tools to draw shapes
that automatically fill with a
pattern of your choosing.
You can even draw straight
lines and shapes with borders
that are patterned instead of
black.

Working with patterns
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To choose a pattern

Pull down the Patterns

menu, drag the pointer to
the pattern you want, and
release the mouse button.

If the Patterns menu has
been torn off, click one of
the pattern squares.

The pattern you choose will
appear in the rectangle in the
top-left corner of the Patterns
menu.

Your choice is shown here

Click here

58

2. Choose the paint

To fill an area with a
pattern

1. Choose a paint pattern

from the Patterns menu.

bucket from the &
Tools menu.

3. Position the paint bucket

so that the tip of the
dripping paint is within
the area you want to fill;
then click.

Tip of paint bucket

If the tip of the paintis on a
white dot when you click, all
adjoining white dots change
to the chosen pattern. If the
tip of the paint is on a black
dot when you click, all
adjoining black dots change
to the chosen pattern.

E To fill beyond the

boundaries of the window,
position the paint bucket,
hold down the Shift key,
and then click.

Chapter 2: Using MacPaint

m To stop a pattern from

“leaking” to an area
beyond the area you want
to fill, choose Undo from
the Edit menu, find the
gap in the border of the
area you want to fill, and
use the pencil tool or
another tool to repair the
gap. Then use the paint
bucket again to fill the
area.

Paint leaking from an
enclosing shape spreads until
it is contained by another
enclosing shape, or until it
reaches the boundary of the
window.

If you make a change after
using the paint bucket, you
will not be able to use Undo to
cancel the effect of the paint
bucket operation. Undo
cancels only your last
change.




To draw patterned straight
lines and borders

To draw lines that are
made of the currently
selected pattern instead of
black, hold down the
Command key while you
use the line tool.

To draw shapes with
borders that are made of
the currently selected
paint pattern rather than
black, hold down the
Command key while you
draw the shape.

To change a pattern

. Choose the pattern you

want to change.

. Choose Edit Pattern from

the Goodies menu.

Or, if the patterns menu is on
the desktop, you can double-
click the pattern you'd like to
change.

A pattern-editing dialog box
appears. The left box displays
a close-up view of the current
pattern in a grid of 64 dots,
each of which can be either
black or white. The right box
displays a normal view of the
pattern created from this
arrangement of the 64 dots.

3. To change a dot from black
to white or from white to
black, click it in the left
box.

4. Click OK to record the
pattern in the Patterns
menu or Cancel to stop
editing the pattern and
leave the Patterns menu
unchanged.

The new pattern appears in
the Patterns menu whenever
the document is in the active
window. When you save the
current document, the new
pattern is saved with it.

Click to change any dot from black
to white or white to black

Changes reflected here

R
) (EameeD)
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To capture a pattern from
a picture

. Choose a pattern from the

Patterns menu.

The pattern you capture will
take the place of the selected
pattern in the menu.

. Choose Edit Pattern from

the Goodies menu.

You may first have to scroll
the picture so that the dialog
box doesn’t cover the pattern
you want to capture.

3.

Position the pointer on
the pattern that you wish
to capture; then click.

The pattern that you clicked
fills the pattern-editing
boxes.

You can change your mind
and click again, or you can
click the dots in the left box to
change the captured pattern.

Chapter 2: Using MacPaint

4. Click OK.

The new pattern appears in
the Patterns menu whenever
the document is in the active
window. When you save the
current document, the new
pattern is saved with it.



Drawing with the
pencil

You can use the pencil to
draw dots, lines, and
freehand shapes—but the
pencil is most useful as a
precision tool for changing
pictures.

A MacPaint document is
made up of tiny dots, or
pixels. (Pixel is short for
picture element.) At any
moment, each dot is either
black or white.

Use the pencil to change
dots—from white to black and
black to white. This tool is
useful for putting the final
touches on your work.

Because dots are small and
can be difficult to change
individually, you may find it
useful to zoom in for a closer
view of the picture and make
changes. See “Zooming” in
this chapter.

. Choose the pencil ﬂ

To change a dot

from the Tools
menu.

. Put the tip of the pencil

where the dot is to appear
and click.

If you click on a black dot, it
changes to white and vice
versa.

o

Tip of pencil
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To draw a line

. Choose the pencil from

the Tools menu.

. Put the tip of the pencil

where you want the line to
start and drag to draw a
line.

If you begin the line on a
white dot, the entire line will
be black. If you begin the line
on a black dot, the entire line
will be white.

. Release the mouse button

to end the line.

Pencil lines are one dot wide.
For thicker lines, use the
paintbrush, freehand shape
tool, or line tool.

To make a straight vertical
or horizontal line, hold
down the Shift key or
press the Caps Lock key as
you draw.
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Zooming

MacPaint provides five levels
of magnification. In addition
to the normal 100-percent
view, you can zoom in for
200-percent, 400-percent,
and 800-percent magnified
views or zoom out to a 50-
percent reduced view. Each
window title bar shows the
current magnification of the
document in that window.

The tools in the Tools menu
and the commands in the
Edit menu are available in all
five views. The pencil is
especially useful in the
magnified views, because you
can use it to change
individual dots.

When you start MacPaint by
opening a new or an existing
document, the view is at 100
percent until you change it.

To zoom in

To zoom in one step at a
time, choose Zoom In
from the Goodies menu,
or hold down the
Command key and click
with the pencil tool

To zoom directly to the
800-percent view, double-
click the pencil tool in the
torn-off Tools menu.

Double-clicking the pencil
tool in the Tools menu again
returns the view to 100
percent.
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To zoom in on a selection

1. Use the lasso or the

selection rectangle to
select the area you want to
zoom in on.

See “Selecting Part of a
Picture” in this chapter.

. Choose Zoom In from the

Goodies menu.

After you zoom in, MacPaint
tries to keep the selection
centered in the window—but
you may need to scroll a little
to keep it in view.



To zoom in on a dot

. Choose the pencil tool
from the Tools menu.

. Position the pointer on or
near the dot you want to
zoom in on.

. Hold down the Command
key and click.

Each time you click,
MacPaint zooms in one level
of magnification up to 800
percent. The specific dot you
clicked on will be centered on
the screen each time the
picture zooms.

To zoom in directly to 800
percent on the last place
you clicked, double-click
the pencil in the torn-off
Tools menu.

Double-clicking the pencil
tool in the Tools menu again

To use the actual-size
inset

In the 800-percent view, an
inset appears that lets you see
the normal 100-percent view
of the window.

E To see the inset while in

the 200-percent and 400-
percent views, choose
Show Actual Size from the
Goodies menu.

You can drag the inset by its
drag bar to reposition it.

E To return to 100-percent

magnification, click within
the inset box.

m To put away the inset, click

its close box or choose
Hide Actual Size from the
Goodies menu.

To zoom out

To zoom out one step at a
time, either choose Zoom
Out from the Goodies
menu or hold down the
Command and Shift keys
and click with the pencil
tool.

To zoom directly from the
800-percent view to the
100-percent view, click in
the actual size inset or
double-click on the pencil
tool in the torn-off Tools
menu.

ré File Edit Goodies Font Style Patterns Tools
"Untitled-1" at 800%

returns the view to 100 -
percent. =H

Click here to put away

Drag here
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Selecting part of a
picture

There are two ways to select
part of a picture.

The selection rectangle
selects every dot within a
rectangular area. This
method is quick, but unless
the object you want to select is
itself rectangular, some
surrounding white space will
be selected along with it.

You can use the lasso to
encircle and select shapes
that don’t conform well with
the rectangular selection
method. With the lasso, the
selection area you prescribe
contracts and selects only the
black shapes within it. White
space is included in the
selection only if it’s enclosed
by a black outline.

After selecting part of a
picture, you can drag that
selection to a different
position, duplicate it, shrink
it, expand it, stretch it, rotate
it, invert it, trace its edges,
fill it with a paint pattern,
and flip it vertically or
horizontally. You can also
cut, copy, paste, or clear
(erase) it.

To select a rectangular
areda

. Choose the selection [~--

rectangle from the [-— 4

Tools menu.

. Position the pointer at one

corner of the area you
want to select.

. Drag the pointer

diagonally to the opposite
corner.

. Release the mouse button

to complete the selection.

You can use the commands in
the Edit menu and the
Goodies menu to make
changes to the selection.

To cancel a selection, click
outside the selection (but
within the document
window) or choose
another tool from the
Tools menu.
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To shrink a rectangular
selection to fit

Hold down the Command
key while making a
rectangular selection.

The rectangular selection
“shrinks to fit"—the
surrounding rectangle
becomes as small as possible
while still enclosing all black
bits.




To select an irregularly
shaped image

1. Choose the lasso Q
from the Tools
menu.

2. Carefully drag the lasso
around the part of the
picture you want to select.

A line trails behind the tip of
the lasso to show what you're
selecting.

3. Release the mouse button.

-
_:Il"

Tip of lasso tool

The lasso makes selections
that shrink around the
black outline of an image
without selecting any
surrounding white areas
(white background). The
areas you select with the
lasso can be irregular in
shape.

If you don't fully close up the
loop, it will automatically be
closed with a straight line that

joins your starting and ending

points.

To cancel a selection, click
outside the selection (but
within the document
window) or choose
another tool from the
Tools menu.

To select the entire
window

. Tear off the Tools menu.

. Double-click the selection

rectangle or the lasso.

This makes a selection that
extends as far as the borders
of the window.
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To select the entire
document

1. Tear off the Tools menu.

2. While holding down the
Shift key, double-click
either the selection
rectangle or the lasso.

This makes a selection that
extends as far as the borders
of the document.
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To move a selection

. Make a selection with

either the selection
rectangle or the lasso.

. Position the pointer inside

the selection until the
pointer changes into an
arrow.

. Drag the selection to a

new location and release
the mouse button.

To move the selection,
vertically or horizontally,
hold down the Shift key or
press the Caps Lock key as
you drag.
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To duplicate a selection

. Make a selection with
either the selection
rectangle or the lasso.

. Position the pointer inside
the selection until the
pointer changes to an
arrow.

. While holding down the

Option key, drag the
selection to a new location
and release the mouse
button.

A copy of the selection
remains behind while you
move the selection
somewhere else.

® To make the copy line up

(vertically or horizontally)
with the original, hold
down the Option and Shift
keys and drag the
selection.
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To make multiple copies
of a selection

. Make a selection with 3. Holding down both the
either the selection Option and Command
rectangle or the lasso. keys, drag the selection

. Position the pointer inside i)anu :it:slease the mogse
the selection until the ’
pointer changes into an How fast you move the mouse
arrow. and the current line weight

selected determine the
spacing between the copies.

® To make the copies line up
(vertically or horizontally)
with the original, hold
down the Option,
Command, and Shift keys
and drag the selection.

68
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To cut a selection

. Make a selection with
either the selection
rectangle or the lasso.

. Choose Cut from the Edit
menu.

The Cut command deletes a
selection from the picture
and puts it in the Clipboard.

To copy from the Clipboard,
use the Paste command on
the Edit menu.

To copy a selection

. Use either the selection

rectangle or the lasso to
select the area you want to

copy.

. Choose Copy from the

Edit menu.

The Copy command copies a
selection onto the Clipboard
without deleting it from the
picture.

To copy from the Clipboard,
use the Paste command on
the Edit menu.

Selecting part of a picture
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To paste from the
Clipboard

1. Choose Paste from the
Edit menu.

If the Paste command is
dimmed in the Edit menu,
the Clipboard is empty. To
put a selection in the
Clipboard, choose Cut or
Copy.

2. When the selection
appears in the center of
the window, drag it to
where you want it.

You can paste images and text
placed on the Clipboard into
a MacPaint document. You
can also copy or cut all or
part of a MacPaint document,
and paste it into 2 document
created with some other
application, such as a word
processing or page layout
application.
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While a rectangular selection
remains active (while a
rectangular marquee
surrounds it), you can shrink
or stretch it to alter the image
being pasted into the
document.

See “To Resize a Selection in
Proportion” and “To Resize a
Selection Changing Its
Proportions” in this chapter.



To fit a selection into a
specific size and shape
area

. Use either the selection
rectangle or the lasso to
make a selection.

. Choose either Cut or Copy
from the Edit menu.

. Use the selection
rectangle again (or select
an existing image with the
lasso tool)—this time to
specify the location, size,
and shape the contents of
the Clipboard should take
when pasted into the
document.

You can think of this second
selection area as a target into
which the contents of the
Clipboard are placed.
Whatever is on the Clipboard
will be forced to conform to
the placement and size of the
target selection.

When you paste into an area
selected by the lasso, the
Clipboard contents take on
the size and shape of a
rectangle roughly bounding
the selection. The actual
shape of the selection does
not determine the shape of
the pasted image.

. Choose Paste from the

Edit menu.

Because selections made with
the lasso shrink to enclose
images outlined in black, the
lasso may not work effectively
to create a target selection if
the area is mostly white.

To clear a selection

. Use either the selection

rectangle or the lasso to
select the area you want to
clear.

. Choose Clear from the

Edit menu or press the
Backspace or Delete key.

The selection is deleted. To
restore it, immediately
choose Undo from the Edit
menu.

The Clear command deletes a
selection without copying it to
the Clipboard.

Because a cleared selection is
not copied to the Clipboard,
it can’t be pasted into the
document again.
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To resize a selection in

proportion
1. Use the selection 3. To reduce the selection to Any request that would make
rectangle to make a 50 percent of its original the selection larger than the
selection. size, click OK. To choose document is ignored. A
T miniies sursunding some other scale, type warning box appears if you try
; a number representing to enlarge a selection so
white space, hold down the : ;
. the percentage of much that it would be bigger
Command key while you ;
select enlargement or reduction than a MacPaint document.
' youwishand cickOR. You can also resize a
2. Choose Scale Selection : «
B the Gobilies men If you choose 50 percent, the selection gradually; see “To
: selection is reduced by half. If Resize a Selection Changing
The Scale Selection dialog you choose 200 percent, the Its Proportions” in this
box appears. selection is doubled in size. chapter.

Scale selection to:

|~

}

= &
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To resize a selection
changing its proportions

1. Use the selection
rectangle to make a
selection.

2. Position the pointer on
any side or corner of the

selection until the pointer

changes into an arrow.

Original tree

3. While holding down the

Command key, drag the
pointer to resize the
selection and then release
the mouse button.

Dragging the pointer toward
(or even past) the center of
the selection shrinks the
selection.

Dragging the pointer away
from the center of the
selection in any direction
stretches the selection in that
direction.

Hold down both the Shift
key and Command while
dragging to maintain the
selection’s original
proportions.
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To invert a selection

1. Use the selection
rectangle or the lasso to
make a selection.

2. Choose Invert from the
Edit menu.

Inverting a selection means

changing all black dots to
white and all white dots to
biack.

To return the selection to the
way it was originally, either

choose Invert again or

choose Undo from the Edit

menu.

To trace the edges of a
selection

. Make a selection with the

selection rectangle.

. Choose Trace Edges from

the Edit menu.

You can trace the same
selection repeatedly for
interesting effects.

If you hold down the Shift
key while you trace the
edges of a selection, the
outline will also be
shadowed on the bottom
and right, producing a
drop-shadow effect.
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To flip a selection To rotate a selection To fill a selection with a
90 degrees pattern

1. Make a selection with the 1. Make a selection with the 1. Choose a pattern from the

selection rectangle. selection rectangle. Patterns menu.

2. Choose Flip Horizontal or 2. Choose Rotate from the 2. Make a selection with the
Flip Vertical from the Edit Edit menu. selection rectangle.
mena. The selection rotates 90 3. Choose Fill from the Edit
The Flip Vertical and Flip degrees counterclockwise. menu.

Horizontal commands Repeat to rotate the selection
respectively flip a selection another 90 degrees.

upside down and sideways.
: F=———————=-—- 1
Flip Vertical

Flip Horizontal Rotate

D, o
<
X
2

B, 0, L2

>
-
>

T, R,
g P
B o, o, £, o
> W<

&

o

D o, 20, i,
o "
P, i, 80, 0,
%

%,
i &
n ol B B A

>
%, N
2 e g R g g

<
&,
i

b, £, B
L

>
Y
-

Selecting part of a picture 75



Aligning a picture To use the grid

to a grid
Autogrid covers a document 1. Choose Turn Grid On E To turn Autogrid off,
with an invisible grid and from the Goodies menu. choose Turn Grid Off
gllows you to draw'and locate If Turn Grid OFf appears in the from the Goodies menu.
images you draw with . . .
.. g . Goodies menu, Autogrid is For more details, see
precision. When Autogrid is “ . . . i
. already on. Autogrid Spacing (Pixels)
on, you can draw only lines in Chiapster 3
and shapes that conform to 2. To specify the distance ASERET S
the grid intervals (similar to a between grid lines,
drawing made on grid choose Preferences from
paper.) Your lines and the Goodies menu,
shapes automatically align on choose an Autogrid
the grid, allowing easy and spacing, and click OK.
;?:Egzzjszmg g Your choices of Autogrid
) spacing are 2, 4, 8, 16, or 32
Text also aligns on the grid. pixels (dots).
Autogrid also affects
selecting, dragging, and
duplicating with the selection
rectangle as well as dragging
and duplicating with the
lasso.
Autogrid doesn’t affect the
paintbrush, pencil or the
spray can.
Without Autogrid With Autogrid
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Tracking mouse
movements

The mouse position inset
lets you see exactly where the
pointer is in relation to the
upper-left corner of the
document and exactly how far
it moves each time you drag
the pointer. This makes it
easy to draw lines and shapes
to precise dimensions.

Click here to close

To use the mouse position
inset

m Choose Show Mouse

Position from the Goodies
menu.

To hide the mouse position
window, choose Hide Mouse
Position from the Goodies
menu or click the close box
on the inset.

You can drag the inset by its
drag bar to reposition it.

Drag here /

T

£ +07z.00
4> +268.00

Current unit of measure

B £ +000.00
4ty +000.00

| o +000.004|
pixels

va

Tracking mouse movement

N

E To change the unit of
measure—pixels (dots),
inches, or centimeters,
choose Preferences from
the Goodies menu, click
the desired measuring
unit, and click OK.

For more details, see
“Autogrid Spacing (Pixels)”
in Chapter 3.

Vertical distance from
uppper-left corner of
document

Horizontal distance from
upper-left corner of
document

Vertical and horizontal
distance from starting
point of line or shape

Actual distance from
starting point
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Adding text

You can add text to your
pictures, choosing from a
number of fonts and from
various styles and sizes of
characters.

Some fonts (Cairo and
Mobile, for example) consist
of small pictures rather than
letters and numbers. Use the
Key Caps desk accessory to
see these and other fonts.

e, L
£ TR Aol

Cairo font

To type text

1. Choose the text
tool from the
Tools menu.

A

2. Position the pointer (it
now looks like an I-beam)
where you want to start
typing text and click the
mouse button.

A blinking insertion point
appears.

3. Begin typing.

Chapter 2: Using MacPaint

Until you click the mouse
button or choose another
tool, you can backspace to
make corrections, press
Return to start a new line, and
change the font, style, size
and alignment of the
characters you've typed.

Once you click the mouse
button or choose a tool other
than the text tool, the text
you've typed is no longer
active (the insertion point is
gone). The text becomes part
of the picture; you can no
longer edit it as text. You can
select and use commands to
manipulate text just as you
can with other MacPaint
images.



To change the text font

E To change the font of
active text, choose a font
from the Font menu.

The Font menu lists all the
fonts available in your System
file.

E To change the font of
future text without
affecting text you’ve
already typed, press Enter
before choosing a new
font or click somewhere
else in the document.

To change the text style,
size, or alignment

m To change the size of
active text, choose a size
from the Style menu.

E To change the style of
active text, choose one or
more styles from the
Style menu.

E To change the alignment

of active text, choose an
alignment (left, middle,
or right) from the Style
menu.

To change the style, size,
or alignment of future
text without affecting text
you’ve already typed,
press Enter before
choosing a new attribute
or click somewhere else in
the document.

Change the
size of the text,
change the style,

change the font,

change

the

alignment.

Text can be
Plain,
Bold,
Htalic,
Underline,
Chailime,
Eireslsm,
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To change line spacing
(leading)

To space lines of active
text closer together, hold
down the Command and
Option keys and press the

< key.

To space the lines farther
apart, hold down the
Command and Option
keys and press the > key.

Change the line spacing last,
after you are satisfied with the
text’s font, style, size, and
alignment. Changing the
font, style, size, or alignment
automatically changes text to
a preset line spacing.

Chapter 2:

1.

To change the text mode

Choose Preferences from
the Goodies menu.

. Click Normal, Overlay, or

Inverted in the
Preferences dialog box
and click OK.

If you choose Normal, any
text you type over a dark
background appears within a
white band.

If you choose Overlay, there’s
no white band around the text

you type.

If you choose Inverted, the
text you type appears in black
over any white background
and inverts to white over any
black background.

Text mode is:
 a
Sample @ Normal

Ela}/jle O Overlay
E;'/G,;{lgi]e O Inverted m 0K |]

A o
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To create text in the
Note Pad

1. Open the Note Pad desk
acCessory.

2. Compose your text.

3. Select the text that you
want to paste into your
MacPaint document.

4. Choose Cut or Copy from
the Edit menu.

5. Close the Note Pad.

6. Choose Paste from the
Edit menu.

:18 great for
llquic:k text

rediting jobs. 1jobs.

P === = e

:The Mote Pad is great
:fnr guick text editing

Use the Note Pad desk
accessory as a simple word
processor. You can insert,
delete, backspace, cut and
paste, and change the
insertion point. You can’t
change the font, size, or
style—but you can do these
things after pasting the text
into the MacPaint document.

The pasted text is active until
you click. While it remains
active, you can change its
alignment, font, size, and
style. You can even change
the size and shape of the
block of text by holding down
the Command key while you
drag a corner of the
selection.

Adding text
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Undoing

MacPaint lets you change
your mind, undo mistakes, or
try out several ideas until you
find the one that’s just right.

If you take an action that you
instantly regret, MacPaint
provides several alternatives
for restoring your picture to
its original appearance. First,
you can choose the Undo
command, which cancels

the effect of the last (and only
the last) action you took. You
can also erase an image, a
window, or even an entire
document and start over.

To avoid starting over,
however, you can take
snapshots of your picture as
you create it. You can then
use a snapshot to change part
or all of the document back to
the original. Finally, if you've
previously saved a document,
you can choose the Revert to
Saved command from the
File menu to start over with
the document as it was last
saved on disk.

To undo a single change

Choose Undo from the
Edit menu.

With the Edit menu’s Undo
command you can reverse
the effect of any command
used to change the document
or any drawing task that you
perform, including Undo
itself.

Remember that Undo works
only on the last change you
made. If, for example, you
erase something and then
make any other change (no
matter how small), choosing
Undo won't restore what you
erased.
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To erase part of a picture

. Choose the eraser

from the Tools
menu.

. Hold down the mouse

button while you move the
eraser pointer over the
area you want to erase.

Hold down the Shift key or
press the Caps Lock key to
make erasures that are

vertical or horizontal only.

'L
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To erase an entire window
or document

To erase the entire
window, double-click

the eraser tool in the torn-
off Tools menu.

To erase the entire
document, hold down the
Shift key while double-
clicking the eraser tool

This procedure has no effect

on any documents saved on
disk.

To make your own eraser

Paint over an area with the
plain white pattern.

You have a choice of brush
shapes.

Select an area and choose
Clear from the Edit menu
or press Backspace.

®m Use a borderless filled

shape tool together with
the white pattern to erase
an area of a particular
shape.

@8 C((C

Undoing 83



84

To take a snapshot

Choose Take Snapshot
from the File menu.

When you first open a
document, MacPaint
automatically saves a
“snapshot” of it in memory.
After you've made changes to
the document, you can revert
all or part of the picture to the
snapshot.

When you open a new
document, the snapshot is
blank until you add to the
document and take a new
snapshot.

If you have a 512K Macintosh,
you won't be able to take a
snapshot if you have two
windows open at once
because of memory
limitations.

You can take a new snapshot
at any time. Take a snapshot
just before trying an effect you
might later want to undo.
When you’re experimenting
with different approaches to
your drawing, take snapshots
often.

You can have only one
snapshot at a time per
picture, so the new snapshot
replaces the old one.

To delete the snapshot of
the active picture, choose
Throw Away Snapshot
from the File menu.

Throwing away a snapshot
saves 52K of memory, which
may allow you to open more
documents at the same time,
for example.

Chapter 2: Using MacPaint

To undo all changes in a
selected area

. Make a selection with the

selection rectangle or the
lasso.

. Choose Revert To

Snapshot from the Edit
menu.

You can return a selected area
of a document to the way it
was the last time you took a
snapshot by choosing Revert
to Snapshot from the Edit
menu.

Revert to Snapshot is dimmed
if you threw away the most
recent snapshot.



To undo changes with the
magic eraser

. Select the eraser tool on
the Tools menu.

. Hold down the Command
key and drag the magic
eraser over a part of the
picture that has been
changed since the last
snapshot was taken.

As you hold the Command
key down, you see the eraser
pointer become animated
with sparking lines within it,
indicating that you are using
the magic eraser.

The magic eraser is handy for
restoring a part of a picture to
the way it appears in the
current snapshot.

To change an entire
document back to the way
it appears in the most
recent snapshot, hold
down the Command and
Shift keys, and double-
click the eraser tool in the
torn-off Tools menu.

To undo all changes

. Choose Revert To Saved

from the File menu.

A dialog box appears. At this
point you can click Cancel to
cancel the procedure, if you

wish.

. Click OK.

After a few moments, the
changed version of the
document is replaced by the
last version saved on a disk.

When you use the Revert to
Saved command, a new
snapshot is taken at the same
time.

Undoing
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Working with windows

You can open as many as
nine windows at a time,
depending on how much
memory is available in your
Macintosh. You use
commands in the File menu
to open a window for a new
or existing document, to
close windows, and to save
documents.

If you want, you can open a
window to use as a scratch pad
while your main document is
in another window.

Command key shortcuts

Names of open documents

To open a new document
window

Choose New from the File
menu.

A new window opens up. It
is automatically named
Untitled-1, Untitled-2, and
so on up to Untitled-9,
depending on how many
windows are already open.
When you save a document,
you can give it a more
descriptive name.

The number of windows you
can have open at one time
depends on the amount of
available memory. If you
have a 512K Macintosh, you
cannot open more than two
documents at a time.

If you have nine documents
open, New becomes dimmed
and you have to close a
window before you can open
a new window.

| Turn Grid On

To switch from one
window to another

m Choose a document name

from the Goodies menu.
(The names of all open
documents appear in the
Goodies menu.)

The chosen document
window moves to the active
window. You can also make a
window active to other ways.

E Hold down the Command

key and type a number
from 1 to 9 corresponding
to the desired window.

m Click in any visible part of

the window you want to
activate.

odies

Draw From Center
Show Mouse Position %K

Zoom In #M
Zoom Out 3L
Shaw fciuat §ize S
Shortcuts... 38H
Preferences...

Edit Pattern...
Brush Shape...
Brush Mirrors...
Seande Selaction,
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To scroll in increments

m To scroll in small
increments, click a scroll
arrow.

B To scroll in larger
increments, click in the
gray area of one of the
scroll bars.

E To scroll to a specific part
of the document, drag one
of the scroll boxes.

Scroll arrow

To scroll continuously

Place the pointer in a scroll
arrow and hold down the
mouse button.

For faster continuous
scrolling, place the
pointer in the gray area of
one of the scroll bars and
hold down the mouse
button.

While you are using any
drawing or selection tool, the
window scrolls automatically
if you reach the edge of the
window without reaching the
edge of the picture.

Gray area

Scroll arrow

Scroll bars

Working with windows
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To scroll without using
scroll bars

. Choose the grabber
from the Tools
menu.

. While holding down the
mouse button, drag in the
direction you want the
document to scroll.

Hold down the Shift key or
press the Caps Lock key to
constrain scrolling to
horizontal or vertical
movement only.

You can temporarily change
any tool except the text tool
to the grabber by holding
down the Option key.

Also remember that when you
drag the pointer to the edge
of the window, the document
scrolls automatically.

To close a window

. If the window you want to

close isn’t active, click in it
to make it active or choose
the document name from
the Goodies menu.

You can click anywhere in
that window, or you can
choose the document name
from the Goodies menu.

. Choose Close from the

File menu or click in the
window’s close box.

If the document has not yet
been saved to a disk or if it has
changed since it was last
saved, a dialog box asks
whether you want to save the
document.
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Opening and saving
documents

After working on a document,
you will usually save it so that
you have a copy safely stored
on a disk. Later, if you want to
edit or change the document,
you can open it again and
begin work where you left

off. You can have several
documents open at one time.
(The number of documents
that you can have open at one
time depends on the amount
of memory available. If
enough memory is available,
you can open up to nine
documents at once. If you
have a Macintosh 512K
enhanced, you may be

able to open one or two
documents only.) You can
also save different versions

of the same document by
saving each new version with
a different name.

To open an existing
document

. Choose Open from the

File menu.

If Open is dimmed, you'll
have to close a window before
you can open another.

. When the dialog box

appears, use it to choose
the MacPaint document
you want to open.

To open a MacPaint
document from the
Finder, either select the
document’s icon and then
choose Open from the File
menu, or double-click the
document’s icon.

MacPaint starts and the
document opens.

Opening and saving documents
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To save a document

To save a document under
the name already showing
in its title bar, choose Save
from the File menu.

If the document has been
saved before, it's saved again
under the same name. The
new version replaces the
older version on the disk.

If the document is untitled or
has not been saved before, a
dialog box appears allowing
you to specify a name for the
document. Type a name for
the document and click Save.

® To save a new copy of the
active document under a
different name, choose
Save As from the File
menu. When the Save As
dialog box appears, type a
different name for the
document and click Save.

Choosing the Save As
command and giving a
previously saved document a
new name lets you keep both
the old and new versions of a
document on the disk.

[B)-Untitled
[ Sketches 1 Untitled
[ Final Art -
Y House Plan
]
Save Paint document as:
l —I Cancel

Document format:
O stationery

@ MacPaint

(O Startup screen
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To save a document as
stationery

. Create a MacPaint
document, adding
graphics and text and
setting up the menu
positions, patterns, and
options available in the
Preferences dialog box
and the Page Setup dialog
box as you want them.

. Choose Save As from the
File menu.

. When the Save As dialog
box appears, type a name
for the stationery
document.

. Click the Stationery option
and click Save.

MacPaint saves the
document, recording the
options you've chosen. When
you open the stationery
document later, it appears
untitled and set up just as it
was when you saved it. You
can begin drawing with the
routine elements of a picture
already present and with
MacPaint’s menus and
options ready for use the way
you like them.

) Untitled
O Sketches iy 3 Untitled
O Final Art .
{} House Plan
Save Paint document as:
| | Cancel

Document format:
@ Stationery

O MacPaint

QO Startup screen

In the Finder display,
stationery documents have
icons that appear with a heavy
outline, or drop shadow, to
distinguish them from other
MacPaint documents.

[

Stationery document icon
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To save a document as a
startup screen

Create a MacPaint
document.

. Choose Save As from the

File menu.

. Click the Startup screen

option and click Save.

Clicking the Startup screen
option automatically
names the document
“startupscreen.” A startup
screen must have this name
to work (spelled as one
word with no spaces—
capitalization of the letters
makes no difference when
spelling the name).

MacPaint saves the document
as a startup screen that will
appear each time you start the
Macintosh.

4. Close the document by

clicking the close box or
choosing Close from the
File menu.

5. Choose Quit from the File

menu to leave MacPaint.

6. In the Finder display,

place the document in the
System Folder.

You can also place the Startup
screen document directly
into the System folder when
you save it.

(2] Untitied

When you save a MacPaint
document as a startup screen,
only a part of the document is
saved. The part saved starts at
the upper-left corner of the
document and includes a
rectangular area 512 dots
(horizontal) by 342 dots
(vertical).

You can create several startup
screens with different names.
The Macintosh uses only the
startup screen named
“startupscreen” found in the
System Folder, however. To
use a different startup screen,
you rename the desired
document as “startupscreen”
and move it into the System
Folder.



Printing MacPaint
documents

If you have a printer
connected to your
Macintosh, you can print all
or part of any MacPaint
document. You can print
MacPaint documents on
several kinds of printers such
as the Apple ImageWriter or
LaserWriter.

If you have more than one
printer available for printing,
you may have to use the
Chooser desk accessory to
specify which printer to use.

You specify how a document
is to be printed by choosing
options in the Page Setup and
the Print dialog boxes. The
options available in the Page
Setup and Print dialog boxes
vary according to the
capabilities of the printer
type being used. For
information about the
specific printing options
available with your printer,
refer to your Macintosh
owner’s guide or printer
manual.

To adjust the page setup

. Choose Page Setup from

the File menu.

. Click buttons and boxes in

the Page Setup dialog box
to indicate how you want
the document to be
printed.

The exact content of the
dialog box depends on the
printer you're using. Refer to

your Macintosh owner’s guide

or printer manual for more
information about the
specific printing options
available with your printer.

3. Click OK.

The Page Setup command lets
you control how a document
is printed. When you save a
document on a disk, the page
setup options you choose are
saved as well.

All MacPaint documents have
one orientation (vertical) and
size (8 by 10 inches).

—_—
Imagelriter v2.6 L[ oK ||
Paper: @ US Letter (O A4 Letter

QO US Legal O International Fanfold Cancel |

(O Computer Paper

Orientation

Special Effects: [JTall Adjusted

050 % Reduction
[0 No Gaps Between Pages

Prinfing MacPaint documents
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To print an entire
document

To print part of a
document

1. Choose Print from the File 1. Use the selection
menu. rectangle or the lasso to
The Print dialog box tells you male:a selectlon,
which printer will be used and 2. Choose Print Selection
lets you specify printing from the File menu.
options. The exact content of . ;
the dialog depends on the Thf.: P dmlog box appeass;
. ) . letting you specify how the
printer you're using. Refer to S .
; ; ; selection is to be printed. The
your Macintosh owner’s guide .
or printer manual exact content of the dialog
’ box depends on the printer
2. Click OK. being used. Refer to your
After a few moments, printing MZ.ICIDtOSh Grner s o
. . . printer manual.
begins, and an information
box appears.
B To stop printing, hold
down the Command key
and press period (.).
Imagellriter vze [ 0K |
Quality: O Best @ Faster O Draft
Page Range: @ RII O From: To: Cancel
Copies:
Paper Feed: @& Automatic (O Hand Feed
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3. Click the desired options
in the Print dialog box and
then click OK.

After a few moments, printing
begins and an information
box appears.

The selection occupies the
same position on the paper as
it does in the document—as if
the whole document had
been printed with everything
but the selection masked. If
you want to control where the
selection appears on the
page, copy it and paste it into
a new document.

® To stop printing, hold
down the Command key
and press period (.).



To print several
documents

. In the Finder display,
select the icons of the
MacPaint documents you
want to print.

To select more than one
icon, hold down the Shift key
while clicking one icon after
another.

. Choose Print from the File
menu.

MacPaint opens and printing
begins.

To stop printing, hold
down the Command key
and press period (.).

Getting help

Choose Shortcuts from
the Goodies menu.

Choosing Shortcuts from the
Goodies menu brings up a
screen of helpful MacPaint
hints, reminders, and
shortcuts. You'll find
information about how to use
key combinations to do such
tasks as changing fonts, font
size, and line spacing; how to
zoom in and out with the
pencil tool; and how to copy
selections in various ways.
You'll also see a diagram
showing the functions of keys
on the keyboard and a list of
tool icons that can be double-
clicked on the torn-off Tools
menu to perform specific
operations such as selecting
an entire window or zooming
in on a document.

Getting help
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The desktop is the
MacPaint working
environment,

This chapter provides an overview of MacPaint features and
commands and a summary of keyboard tricks and shortcuts.

For a hands-on introduction to using MacPaint, see Chapter 1,
“Learning MacPaint.”

For step-by-step instructions for performing specific tasks with
MacPaint, see Chapter 2, “Using MacPaint.”

The MacPaint desktop

The MacPaint desktop provides the drawing space, tools and
commands needed to create drawings (see Figure 3-1).

Menu bar (& File Edit Goodies Font Style Patterns Tools ]
Close box —QEB_ "Untitled-1" at 100%

Title bar

Zoom box

Tools menu

Patterns menu

RO BN

+
o
&
5

Scroll bars

Size box

Figure 3-1
The MacPaint desktop

You draw in the central area of the window. Your documents can be
as large as 8 by 10 inches, larger than your screen can display
without scrolling unless you have a large-screen monitor. MacPaint
provides ways to view documents, to enlarge them many times to
work on fine details, and to scale them down to provide overviews of
documents on the screen.

98 Chapter 3: MacPaint Reference



Bruprl isn Sapad

New geM
Open... 880
Close g
Save fAs... R‘

Take Snapshot ®xY
Throw Away Snapshot

Page Setup...
Print...
Print Saladctinn.,

Quit ®0

Figure 3-2
The File menu and
the Save command

Across the top of the screen, you see the menu bar that contains all
MacPaint's pull-down menus.

The pull-down menus provide easy access to the MacPaint
commands. Once a document is complete, for example, you can
save it on a disk with the Save command from the File menu (see
Figure 3-2).

Just under the menu bar, a title bar shows the name of your
document. With a new document, the title bar shows “Untitled-1
at 100%.” New documents do not have names, and so “Untitled”
appears in the bar. After you save and name a document, the
document’s name appears in place of “Untitled.”

The title bar also shows the current zoom level of a document.
MacPaint lets you use enlarged or reduced views of a document, and
the zoom level shown next to the document name tells by what
percentage the document has been enlarged or reduced. New
documents are displayed at 100 percent—in other words, at their
original size. Refer to “Zoom In” and "Zoom Out” in this chapter
for more information about changing the zoom level.

Also appearing on the MacPaint desktop are the close, size, and
zoom boxes and the scroll bars. The close box appears on the left
side of the title bar. By clicking the close box, you close, or put
away, a MacPaint document when you no longer need it. If you
haven’t saved your work on a disk, MacPaint asks if you want to do so
before closing the document.

You use the size box to change the window size. Each MacPaint
document appears in its own window. You can move and resize
individual windows to better see them on the screen. The size box is
in the bottom-right corner of the desktop. You drag the size box to
change a window to any size, large or small, that fits the Macintosh
screen.

The zoom box appears on the right side of the title bar. You use it to
quickly change the size of the window. If you want to enlarge a
window, you click the zoom box; MacPaint enlarges the window to
the largest size that fits the screen. Clicking the zoom box again
reduces the window to its former size.

At the bottom and at the right side of the window are scroll bars that
allow you to position your view of a drawing. Refer to “Working With
Windows” in Chapter 2, and to your Macintosh owner’s manual for
an explanation of how to use the scroll bars to move through a
document.
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Figure 3-3

The Tools menu

Two new features of MacPaint 2.0 are the Tools and Patterns menus
that you can move to convenient locations on the screen or put
away to provide more drawing room. MacPaint 2.0 is preset not to
display the Tools and Patterns menus, but you can tear them off the
menu bar by pulling them down and reposition them on the screen,
if you wish.

The Tools menu provides a choice of tools to use (see Figure 3-3).
On the MacPaint Tools menu you see

O six choices of line weights (including an invisible line) for

drawing lines and shapes

the selection rectangle and the lasso for selecting shapes or
text and changing or repositioning them

O the grabber for scrolling a document in a window
O the paint bucket for filling shapes with patterns

O the paintbrush for applying patterns to documents in a manner

similar to stroking on paint

the text tool for typing text such as labels, captions, or
paragraphs in documents

the line tool for drawing straight lines vertically, horizontally, or
at any angle diagonally

the spray can for applying patterns to documents in a manner
similar to spraying on paint

the pencil for drawing lines freehand as you might with a pencil
on paper

the eraser for erasing parts of a picture

O the rectangle tools for drawing rectangles and squares

the rounded rectangle tools for drawing rectangles and
squares with rounded corners

O the oval tools for drawing ovals and circles

O the freehand shape tools for drawing lines to form irregular or

curving shapes

the polygon tools for drawing angular shapes composed of
angles and straight lines such as triangles, quadrilaterals, and
other polygons
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Figure 3-4
The Patterns menu

You use these MacPaint tools for all your drawing, from the simplest
diagram to the most complex graphics. You click a tool once to use
it. The tool you click becomes highlighted in black to show that it is
selected. Refer to “The Tools Menu” in this chapter for more
information about using the Tools menu.

You use the Patterns menu to shade drawings, applying the
patterns like paint with the paint tools (see Figure 3-4).

The Patterns menu has 38 preset patterns ready for your immediate
use. You can also change the patterns on the menu. Refer to “The
Patterns Menu” in this chapter for more information about using
patterns in a document.

Creating and saving documents

When you work with MacPaint, you follow a routine of opening a
document, working on it, and saving it on a disk.

To start MacPaint and create a new document, you select the
program icon and choose Open from the File menu, or double-
click the MacPaint program icon to start MacPaint and
automatically create a new window. If MacPaint is already running,
you choose New from the File menu to make a new window appear.

At the Finder, you can open a document already on a disk by
clicking the document icon to select it and choosing Open from the
File menu. You can also double-click the document icon to open
the document. If MacPaint is already running, you choose Open
from the File menu and specify the document you wish to open; the
document appears in a2 new window.

MacPaint has settings, called preset options, that it uses when
creating a new document. For example, a new document always
appears without the Tools and Patterns menus on the screen. You
can change the MacPaint settings as you like when you work on a
document.

Instead of changing the preset options each time you create a
document, you can create stationery documents with settings that
match your preferences. You can then open stationery documents
and complete them.
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Figure 3-5
The Apple menu

Once a document is open, you use the MacPaint drawing tools and
commands to draw and create pictures.

Remember, as you work on a MacPaint document, it temporarily
resides in the Macintosh memory. If the computer is turned off and
you haven't saved your document on a disk, you lose the document.
To keep a copy of your work, you must save the document on a disk.

You should also save your document periodically as you work on it.
That way you keep an up-to-date version on a disk, and won'’t lose all
your work if a power outage occurs.

When a document is finished, you save the final version on a disk
for later use (unless you wish to abandon your work and not keep a
copy). Once a document is saved on a disk, you have a permanent
copy that is ready whenever you need it. You can view or change a
document whenever you wish.

It's also a good idea to make copies of your documents on other
disks. These backup copies ensure that if a disk is accidentally
harmed in some way, you won't lose documents, because you have
more than one copy.

The Apple menu

Most of the content of the Apple menu (see Figure 3-5) depends on
the desk accessories installed in your system.

About MacPdaint...

Choosing About MacPaint opens a window of information about the
MacPaint program. To dismiss it, click anywhere on the screen.

Desk accessories

The Apple menu lists all desk accessories, such as the Alarm
Clock and the Calculator, installed in the System file of your startup
disk. Your Macintosh owner’s guide shows how to use the Font/DA
Mover (Font and Desk Accessory Mover) on the System Tools disk
to add or delete desk accessories.
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Figure 3-6
The File menu

The File menu

The File menu (see Figure 3-6) contains the commands for opening,
saving, and printing documents, and for ending a work session.
Another command, Take a Snapshot, lets you make a copy of the
document, which you can use to restore all or part of a document to
the way it appeared at the time of the snapshot. When the copy, or
“snapshot,” is no longer useful you can use another command to
throw it away to conserve memory. You can also throw away all your
recent changes to a document by choosing the Revert to Saved
command, which reopens the document as it was last saved on a
disk, canceling any changes that haven’t been saved since that time.

New

Choosing New opens a new MacPaint document on the desktop.
You can use the New command even if a document is already open
on the screen. A new document appears on top of existing ones
without replacing them.

You can have up to nine documents open at one time if sufficient
memory is available. (If you have a 512K Macintosh, you cannot
open more than two windows at a time.) As each new document is
created, it is named “Untitled” and given a number corresponding
to the number of documents currently open. New documents are
named “Untitled-1,” “Untitled-2,” and so on through “Untitled-9,”
depending on how many windows are already open. If New is
dimmed, you can’t open a new window until you close a window.

A new document is set up according to MacPaint’s preset options.
If a new document’s preset options don’t match the settings you
routinely use, you can create stationery that allows you to open
documents with the settings you need. Instead of choosing New,
you choose Open to open a stationery document. For more
information about creating and using stationery, refer to “Save As”
in this chapter.

% Keyboard equivalent: Command-N
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Open...

Choosing Open opens a MacPaint document that has been saved
on a disk. A dialog box appears that allows you to specify the
document you want to open. If there are already nine document
windows open, Open is dimmed to show that you can't open any
more windows until you close a window.

When you choose Open, you see the dialog box shown in
Figure 3-7.

1 System Folder B = untitied
O Test -
|
b4
Save Paint document as:
—I Cancel
Document format:
@ MacPaint (O Stationery O Startup screen
Figure 3-7

The Open command dialog box

The name of the disk you are using is shown on the right side of the
dialog box above the Eject button.

You select the document you want from the list in the dialog box.
The list contains the names of the MacPaint documents and folders
on the current disk. If more documents are on the disk than fit in the
list box, you can use the scroll bars to find the document name or
folder you want.

To open a document, click the name to select it. Then click Open.
Alternatively, you can double-click the name to open the document
in one step.

If your document is within a folder, double-click the folder name.
The folder opens and the names of documents and folders within it
appear in the list box. You can then open a document or another
folder. To close the current folder, click the disk name that appears
over the Open button.
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To see a list of the currently open folders, position the pointer on
the folder name displayed over the list box and hold down the
mouse button. A list of the open folders and the disk name appears.

You can also open a folder from the list of folder names. Drag to
select the folder name on the list and release the mouse button. A
list of the folder contents appears.

To open a document on a disk not inserted in a drive, insert the disk
in an empty drive or click Eject to eject the current disk so you can
insert the disk holding your document. The names of documents
and folders on the inserted disk automatically appear in the list box.
You then select and open your document from the list.

To open a document on a disk in a different disk drive, click Drive
until the name of the desired disk appears. The documents and
folders on the disk appear in the list box, ready for you to open.

If you decide not to open a document, you can click Cancel and
return to using MacPaint where you left off.

Opening stationery

You also use Open to open stationery. A stationery document
contains settings, text, and drawings that you frequently use. You
save the document as stationery, similar to a pad of preprinted
forms.

When you begin a new document, you can open a stationery
document and immediately start working on it. You don’t have to
change settings or add the basic text or design elements that always
appear in documents you create.

When you open stationery, the title bar in the document name is
“Untitled” as if you were starting a new document. After completing
the document, you name and save it on a disk.

For information about creating stationery documents, refer to
“Save As” in this chapter.

% Keyboard equivalent: Command-O
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Close

Choosing Close closes the active window. Other windows on the

screen are not affected. To close a window that is not active, click
the window to activate it and then choose Close or click the close
box.

If you have made changes to a document since the last time you
saved it, a message asks if you want to save the document before
closing it (see Figure 3-8).

Save changes to "Untitied-1"
before closing?

Cancel

Figure 3-8
The Close command message

< Keyboard equivalent: Command-W

Save

Choosing Save saves the document in the active window to a disk.
The window remains open. If several windows are open, you must
activate the window holding the document you wish to save before
choosing the command.

If the document hasn’t been saved previously, a dialog box
appears asking where you want it saved and under what name (see
Figure 3-9).
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Figure 3-9
The Save dialog box appears when you save untitled
documents

You type a name and dlick the Save button or press Return. (See
“Save As” in this chapter for more information about this dialog
box.) If not enough room exists on the current disk to hold the
document, you see a message asking you to save the document on
another disk.

If the document has been saved before, you see no dialog box or
message. The Save command updates the document by replacing
the version on the disk with the version on the screen.

Use Save when you want to update a document on a disk with the
most recent changes. Use Save As when you want to save a copy of a
document without affecting a version of the document already on a
disk.

For information about saving a document as stationery or as a
startup screen, refer to “Save As” in this chapter.

% Keyboard equivalent: Command-S
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Save As...

Choosing Save As saves a copy of the document in the active
window to a disk. A dialog box appears asking where you want the
document saved and under what name (see Figure 3-10).

[E) Untitied |

[ Sketches 1 &) Untitled
O Final Art

- Ei t
{} House Plan m

Drive
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Save Paint document as:
I | Cancel

Document format:

@ MacPaint O Stationery O Startup screen

Figure 3-10
The Save As dialog box

You can use this command to save a copy or a different version of a
document under a different name. The window remains open after
the document is saved.

Three options for saving a document appear at the bottom of the
Save As dialog box: MacPaint, Stationery, and Startup screen.
MacPaint is preset to save a document as a MacPaint picture.

You can also save a document as stationery, which saves the
MacPaint document and records the page setup, menu positions,
and other options that you’ve chosen with the Preferences
command. When you open a stationery document, it opens as an
untitled document set up according to your preferences.

Using stationery documents can save you the steps it takes to set up a
new document with the graphics, text, and working preferences that
you routinely use. Stationery documents appear with a different
icon on the desktop to distinguish them from other MacPaint
documents.

Chapter 3: MacPaint Reference



Each time the Macintosh is turned on, it is preset to briefly display a
startup screen that welcomes you to the Macintosh. You can
change this screen to display a MacPaint document of your own.
You must place the graphics and text you wish displayed in the
upper portion of a MacPaint document. Only information within a
rectangular area 512 dots (pixels) wide by 342 dots long, starting
from the upper-left corner of the document, is saved as the startup
screen.

When you save the document, you choose the Startup screen
option. The document must also be named “startupscreen,” with
no spaces in the name (it makes no difference whether you
capitalize letters). After saving the document, you must place it in
the System Folder containing the System and Finder icons. Once
the new startup screen document is in the folder, your Macintosh
will display it each time it is turned on.

Revert To Saved

Choosing Revert To Saved removes all changes made to a
document since the last time you saved it. The command reopens
the last saved version of the document from the disk you saved it on.

If you discover that the changes you make to a document are not
appropriate and that correcting them will be time-consuming, you
can use Revert To Saved to start over.

After you choose Revert To Saved, a message asks if you want to
return the document to the last version saved. Click Yes to revert or
No to cancel the command, leaving the current document with all
its changes.

You cannot cancel the Revert To Saved command by choosing
Undo.
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Important

Take Snapshot

Choosing Take Snapshot saves in memory (not on disk) a copy of
the document in the active window. Taking a snapshot of your
document provides you with a handy backup version of a picture. If
you becomes dissatisfied with the results of a drawing procedure and
it’s too late to use the Undo command, you can always use the
snapshot to restore all or part of a document to the way it appeared
in the snapshot.

Whenever you open a document, MacPaint automatically takes a
snapshot of it. As you work, it’s a good idea to routinely take a
snapshot at each stage of your work. Then if you misjudge or draw or
change the document inappropriately, you can rely on the most
recent snapshot to restore the document and avoid starting over.

To restore a document, you can choose Revert To Snapshot from
the Edit menu or use the magic eraser to restore parts of a
document. Refer to “Revert To Snapshot” and “Eraser” in this
chapter for more information about restoring a document with a
snapshot.

If you have a 512K Macintosh and you open two documents at
the same time, you cannot use the Take Snapshot command
because of memory limitations.

% Keyboard equivalent: Command-Y

Throw Away Snapshot

Choosing Throw Away Snapshot discards the snapshot of the
document in the active window. You’ll need to use this command
only when memory is in short supply. Discarding the current
snapshot frees about 52K of memory. Discarding a document
snapshot, for example, may allow you to open additional
documents.
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Page Setup...

Choosing Page Setup brings up a dialog box that lets you specify
how you want documents printed. The dialog box varies according
to your printer and system software. Refer to your Macintosh
owner’s guide or to your printer manual for information about the
printing options available with your printer.

% LaserWriter users: For the best quality printing of documents with
the LaserWriter, deselect the Faster Bitmap Printing option on
the Page Setup dialog box. Click the Options button and select
the two options, Precision Bitmap Alignment and Larger Print
Area from the Options dialog box.

Print...

Choosing Print prints a copy of the document in the active window.
A dialog box (which one you see depends on the printer you're
using) lets you specify how you want the selection to be printed. The
dialog box varies according to your printer and system software.
Refer to your Macintosh owner’s guide or to your printer manual for
information about the printing options available with your printer.

Once printing begins, you can press Command-period to stop
printing.

% LaserWriter users: If you print MacPaint text on a LaserWriter
—even if you use laser fonts—you won't get the quality of text
you'd get from a word processor printing to a LaserWriter. This is
because MacPaint converts all text to bit maps: The text becomes
part of the picture, and the LaserWriter doesn’t even know it's
printing text.

O
L X4

Screen images: If you want your printed documents to look as
much as possible like screen images, make sure the Smoothing
option is not selected in the LaserWriter Page Setup dialog box or
choose Draft in the ImageWriter Print dialog box.
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Print Selection...

Choosing Print Selection prints a copy of the selected portion of the
document in the active window. This command is useful if you wish
to print a specific part of a document. You make a selection with the
selection rectangle or the lasso and then choose Print Selection
from the Edit menu. A dialog box lets you specify how you want the
document to be printed.

The selection occupies the same position on the paper as it does in
the document—as if the whole document had been printed with
everything but the selection masked out. If you want to reposition
the selection on the page, copy and paste it into a new document at
the position where you want it.

Once printing begins, you can press Command-period to stop
printing.

Quit

Choosing Quit exits MacPaint. You use the Quit command when
you finish working on a document and want to leave MacPaint.

If you have changed any open documents, the message “Save
changes before quitting?” appears. To save the changes, click Yes.
If several windows are open on the screen, you are asked to save
each one individually. A message appears naming each open
document and asks if you want to save it. If a document is untitled,
the Save As dialog box appears to let you name the document
before you save it.

< Keyboard equivalent: Command-Q
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Figure 3-11
The Edit menu

The Edit menu

Most of the commands in the Edit menu (see Figure 3-11) operate
only on parts of the active document selected with the selection
rectangle or lasso. To use these commands, you must first make a
selection and then choose a command to change the selection. If
you haven’t made a selection with either the selection rectangle or
the lasso, the commands remain dimmed to show they can’t be
chosen.

Undo

Choosing Undo cancels the last change you made to a document.
For example, if you draw a line by mistake, you can choose Undo to
remove the line from the document. Undo works for the last action
only, however. Once another action changes the document, the
preceding action cannot be undone.

You can cancel any action you took, such as cutting or pasting,
duplicating, resizing, changing patterns, or changing position and
location, with the Undo command. You can undo a deletion made
by choosing the Clear command or by pressing Backspace.

Actions that don’t change the contents of the document, such as
scrolling, changing a dialog box, selecting a drawing tool, or
resizing a window, cannot be undone.

The Undo command itself can also be canceled by choosing Undo
again.

% Keyboard equivalent: Command-Z, Tilde key, or Escape key
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Cut

Choosing Cut cuts a selection from a document and puts it on the
Clipboard. When you use Cut, you replace anything already on the
Clipboard with the selection you cut.

You must select part of a drawing before it can be cut. You use Cut to
delete a selection or to move it to a new position in a document. To
move a selection, you cut it and send it to the Clipboard, select a
new insertion point in the document, and choose the Paste
command to place a copy of the Clipboard contents in the
document.

You can use Cut to move a selection to another part of a document,
to another MacPaint document, or to another document of a
different application.

Immediately after cutting a selection, you can cancel the deletion
by choosing Undo from the Edit menu. You can also use Paste to
recall a selection as long as it remains on the Clipboard.

% Keyboard equivalent: Command-X

Copy

Choosing Copy makes a copy of the selection and puts it on the
Clipboard. Copy replaces anything already on the Clipboard with a
copy of the selection. You use Copy when you want to duplicate a
selection in the same or in another document.

You must make a selection before you choose Copy. After you
choose the Copy command, the selected part of the document
remains selected.

After copying a selection onto the Clipboard, you can paste the
Clipboard contents into another part of the document, into a
different document, or into a document of another application.

¢ Keyboard equivalent: Command-C
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Paste

Choosing Paste places the Clipboard contents into the center of the
active window. Because the Clipboard contents remains on the
Clipboard, you can use Paste repeatedly to make multiple copies of
whatever is on the Clipboard.

Before choosing Paste, you can make another selection with the
selection rectangle or lasso in your document; choosing Paste will
then place the Clipboard contents into the selected area. (When
you paste into a selection made with the lasso, the Clipboard
contents is pasted into a rectangular area that bounds the
selection.) Whatever is on the Clipboard will take on the size and
shape of the selected area in the document. Pasting into a selection
is a handy way to specify a new size or shape for images or text.

As long as the pasted selection remains active (as long as it
shimmers or is surrounded by a rectangular marquee), it can be
dragged, inverted, and so on. If you made the selection with the
selection rectangle, you can also resize and stretch the selection. If
the Clipboard is empty, the Paste command is dimmed.

You can paste text or graphics from the Scrapbook desk accessory
or from an application other than MacPaint. You can also paste text
from the Calculator, Note Pad, or Key Caps desk accessories.

<% Keyboard equivalent: Command-V

Clear

Choosing Clear deletes a selection from the document without
putting it on the Clipboard. Clear is useful for permanently deleting
a selection from a document. If you want to remove a selection from
the document, but you do not want to alter the Clipboard contents,
you can use Clear to remove the selection without changing the
Clipboard.

You can use Undo to cancel a deletion you make with Clear.

% Keyboard equivalent: Backspace/Delete
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Invert

Choosing Invert inverts the pattern of black and white dots in a
selection. That is, it changes white dots to black and black dots to
white. The Invert command is useful for producing special effects,
such as making a drawing look like a “photographic negative.” You
can also use it to invert black text appearing on a white background
so that it appears as white text on a black background, for example.

Fill

Choosing Fill fills a selection made with the selection rectangle tool
with the current pattern. After making a selection, you can choose
any of the patterns on the Patterns menu and fill the selection with
that pattern. The Fill command is useful for adding background
patterns to a document before you begin drawing or typing text, for
example.

The Fill command lets you select areas not enclosed by a black
border (or shape) and fill them, without letting the pattern leak
beyond the selected area. You can use the Fill command when the
paint bucket tool will not work successfully for lack of an enclosing
shape. After filling a rectangular area in this way, you can use the
eraser (or other tools) to reshape and change the filled area to your
liking.
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Trace Edges

Choosing Trace Edges traces the edges of a selection made with the
selection rectangle. A thick black line or border, for example, will
appear hollow with thin lines tracing the outline of the line or
border. You can use the command repeatedly on the same
selection to build up a pattern of outlines.

If the Shift key is held down when Trace Edges is chosen, a drop
shadow is added to the image. Drop shadow means that the edges

on the right and bottom appear heavier than those on the left and
top.

% Keyboard equivalent: Command-E (Trace Edges), Shift-
Command-E (Trace Edges with drop shadow)

Before Trace Multiple Trace Edges
Trace Edges  Edges Trace Edges with drop shadow
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Flip Horizontal

Choosing Flip Horizontal flips a marquee selection horizontally
around a vertical line through its center (see Figure 3-12).

Figure 3-12
An image flipped horizontally

Flip Horizontal is useful for creating objects that should be
symmetrical along a vertical axis. You can draw a freehand shape,
copy it, and reposition and flip the copy to produce two freehand
lines with symmetrical curves. For example, you can create
interesting border patterns, such as the one in Figure 3-13.
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Figure 3-13
Border pattern created with the Flip Horizontal command
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Flip Vertical

Choosing Flip Vertical flips a marquee selection upside down. Flip
Vertical is useful for creating objects that should be symmetrical
along a horizontal axis. You can draw a freehand shape, copy it,
and reposition and flip the copy to produce two freehand lines with
symmetrical curves. For example, you can create interesting mirror
images, such as the one in Figure 3-14.

Figure 3-14
Mirror image created with the Flip Vertical command
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Rotate

Choosing Rotate rotates a selection 90 degrees counterclockwise.
You must first select an image with the selection rectangle before
you can rotate it. After making a selection, you can choose the
command several times in a row to rotate the selection in 90-degree
increments.

If you start with a selection that is taller than a document is wide (8.5
inches), it will be truncated (chopped off) at both ends after it
rotates.

< Keyboard equivalent: Command-T

Revert To Snapshot

Choosing Revert To Snapshot reverts the selected area of the
document to the way it appeared in the most recent snapshot.
Revert To Snapshot is useful for eliminating changes that you are
dissatisfied with. You can change any area of a document (or even
the whole document) back to the way it appeared when you made
the most recent snapshot. Using Revert to Snapshot, you don’t have
to erase large portions of a document and start over drawing them
from the beginning. Instead, you can quickly use a snapshot to
restore your drawing,

You first select the part of the drawing you wish to change with the
selection rectangle or the lasso. You can change a rectangular area
of any size if you make a selection with the selection rectangle. You
can select irregularly shaped areas or specific portions of a
document with the lasso. After making a selection, you choose
Revert to Snapshot, and MacPaint reproduces the corresponding
portion of the snapshot within the selected area. Everything within
the selected area will revert to its snapshot appearance.
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The Goodies menu

Turn Grid On %86

Draw From Center The Goodies menu (see Figure 3-15) lets you turn on and off a

Show Mouse Position 28K | number of special MacPaint features, zoom in and out to different
magnifications, see a list of shortcuts, set your preferences for the

Zoom In M|  way MacPaint works, and switch from one document to another.
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Shortcuts... sH | Turn Grid On, Turn Grid Off

Prgfarences... Autogrid imposes an invisible grid on the active document. Using

Edit Pattern... soge . . .
Autogrid is similar to using grid paper, except that MacPaint makes

Brush Shape... . . K

] sure that you start and end the lines and shapes you draw in the right

Brush Mirrors... X ; ;

Senin Sota spot. It's useful for making sure images are drawn and located

BB SEIECHER consistently in relation to one another and that text lines up

. correctly in relation to images. When Autogrid is on, all lines and
Untitled-1 &1 : : . .
Untitled-2 o shapes you draw with the line and shape tools automatically begin
e and end where these grid lines intersect.

Untitled-3 %83

The spacing of the grid depends on your selection in the
Figure 3-15 Preferences dialog box. Grid spacing can be in 2, 4, 8, 16, or 32

The Goodies menu

dots (pixels). When Autogrid is off, you can create irregular shapes
and position images and text freely, without relation to the grid.

When the Autogrid is on, this command reads Turn Grid Off. When
the Autogrid is off, this command reads Turn Grid On.

% Keyboard equivalent: Command-G
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Draw From Edge
Draw From Center

©)

Figure 3-16
Shapes that can be
drawn from the center

Draw From Edge, Draw From Center

You can draw rectangles, rounded rectangles, and ovals in either of
two ways: from the edge (or corner) or from the center outward.
MacPaint is preset to draw shapes from the edge outward. This
means that you begin drawing a rectangle, for example, by dragging
from one corner to the opposite corner.

You can also draw shapes from the center outward, however, by
choosing Draw From Center. You can draw a circle, for example,
by dragging from the center of the circle outward to where its
perimeter should appear. Choosing Draw From Center can make
drawing shapes in specific locations easier.

When Draw Frem Center is in effect, small crosshairs appear inside
the affected tools in the Tools menu (see Figure 3-16). You can
choose Draw From Center or Draw From Edge from the Goodies
menu or by double-clicking the desired tool in the torn-off Tools
menu.

Show Mouse Position, Hide Mouse Position

You can display a window that shows the pointer’s location and the
distance that it moves. The mouse position inset (see Figure 3-17)
displays coordinates that tell you exactly where the pointer is on the
screen and exactly how far it moves each time you drag. This feature
is useful in drawing images to precise sizes and in exact locations.

Vertical distance from
upper-left corner of
document

Vertical and horizontal

distance from starting
point of line or shape
Current unit of measure

[m]
{O_t\ & FOT3.00
Aty +268.00 Horizonal distance from
oy upper-left corner of
A o 000,00
e ——— document
e 000,00 Actual distance from
pixels starting point
Figure 3-17

The mouse position inset

If the mouse position inset is not on the screen and you want to see
it, choose Show Mouse Position. If it is on the screen and you want
to hide it, choose Hide Mouse Position or click the close box in the
drag bar. You can move the mouse position inset around the screen
for convenient viewing by positioning the pointer on the drag bar at
the top of the inset and dragging.
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The top two numbers in the inset indicate the pointer’s vertical and
horizontal distance from the upper-left corner of the document—
in other words, the x and y coordinates relative to the upper-left
corner. These numbers are updated constantly as the pointer
moves.

The second pair of numbers in the inset shows the vertical and
horizontal distance the pointer moves when dragging. For
example, if you draw a rectangle, these numbers indicate the
vertical length and horizontal width of the rectangle.

The bottom number in the inset indicates the absolute distance the
pointer moves when dragging. For example, if you draw a diagonal
line, this number indicates the length of the line.

The unit of measure currently in effect appears at the bottom of
the inset. Units can be in pixels, inches, or centimeters. Choose
Preferences from the Goodies menu to change the unit of measure.

% Keyboard equivalent: Command-K

Zoom In, Zoom Out

You can change the zoom level (or magnification) of the document
as displayed in the active window. MacPaint offers five levels of
magnification: the 100-percent, or normal, view; 200-percent,
400-percent, and 800-percent magnified views; and a 50-percent
reduced view. You choose Zoom In to enlarge your view of the
document by one zoom level and Zoom Out to reduce the
document by one zoom level.

Once the document is enlarged or reduced you can continue
working on it with any of the tools and commands in the menus. For
example, you can zoom in to the 800-percent view and add fine
detail to a drawing, or you can zoom out to the 50-percent reduced
view and draw or move images with an overview of the how the
document looks. Note that drawing in the reduced view produces
images that are scaled up in the larger views. When scaled up, these
images may not appear as well formed as they might have been if
drawn at another zoom level.

You can also use the pencil to zoom in and out on a document
instead of choosing the zoom commands. To zoom in on a specific
point, choose the pencil from the Tools menu, place the pointer on
that spot, and click while holding down the Command key.
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Figure 3-18
The same figure at 50, 100, 200, 400, and 800 percent

Double-click on the pencil in the torn-off Tools menu to zoom
directly to the 800-percent view from any other view. Double-
clicking the pencil tool in the torn-off menu when the document
is at 800 percent returns the document to normal view again.

At the 800-percent zoom level, an inset appears that shows a

small portion of the magnified area at the 100-percent size (see
Figure 3-19). As you draw or change the enlarged view, this inset
displays your changes as well and lets you judge the effect of the
changes you make. The actual-size inset is preset to appear in the
800-percent view. To display it in 200-percent or 400-percent views
or to hide it in the 800-percent view, press Command-F.
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Figure 3-19
An 800-percent view with actual-size inset

% Keyboard equivalent: Command-M (Zoom in),
Command-L (Zoom out)

Show Actual Size, Hide Actual Size

Choosing Show Actual Size displays the actual-size inset. This inset
shows the normal (100 percent) view of the window when the
document itself is at some other zoom level. It's useful for judging
the changes you make in a document as you work in a different zoom
level. Each change that you make in a document immediately
appears in the actual size inset so you can see the result of your work
in its actual size and location. Clicking in the actual-size inset
returns the entire document to the normal (100-percent) view.

After you choose the Show Actual Size command, this command
becomes Hide Actual Size. You choose Hide Actual Size when you
no longer want the inset to appear on the screen.

% Keyboard equivalent: Command-F
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Shortcuts...

Choosing Shortcuts displays a screen of helpful MacPaint hints,
reminders, and shortcuts (see Figure 3-20).

1 Shrink marquee to fit; stretch selection
. or n Change font size

MMu]hple pattevn aligned copies

)
E {7200m1n
EX 3 (S|

_ Use special pattern effects while
ab 5
dragging a selection

(eenstrain] [ JC IO IO IR

(7 Double
Zoorn out Click

WDDDDDCIDDDEIDEI Clear
L O A

I

[seron|[Streteh]| |

—
Multiple Copies

Scroll document, except in

Patterned lines and borders

Select window

Select contents of window
Choose brush shape

Togale 100% and 8005 zoom
Erase window or document

E Toggle “Draw From Center?™

% Select document
m? Select contents of document
{1 Select contents of window

[ 1 Select contents of doc

Figure 3-20
The Shortcuts screen

To dismiss the Shortcuts screen, click anywhere.

» Keyboard equivalent: Command-H
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Preferences...

Choosing Preferences displays a dialog box that lets you change
some of the preset options in MacPaint (see Figure 3-21).

Preferences for “Untitled-1”

Measurements shown in: Option-3% pattern effect:
O pigels @ inches Ay~ O Opague (normal)
O centimeters -}~ @ Transparent

fiutogrid spacing (pixels): B4+ O Reversed
02 04 @8 Z 1 Oftrased
O16 O32 [ Invert pattern first

New windows: Text mode is:

@ Use auto window sizing

S
_ ample @ Normal
O Use current window size A ®

Sle O Overlay

[0 Memorize menu positions S%]e &y Inperted I,W]

Figure 3-21
Preferences dialog box with standard settings

When the preferences are set to your liking, click OK. Your
preferences are saved on the disk with the document. To
permanently record your preferences (or a set of them for a special
purpose) for use with other documents, you can save a document as
stationery. The next time you open the stationery document, the
preferences will be just as you set them, and you can change them
again whenever you like. Refer to “Save As” in this chapter for more
information about saving documents as stationery.

Measurements

To choose the unit in which the mouse position is measured, click
the button next to pixels, inches, or centimeters. MacPaint is preset
to measure in inches. The actual-size inset will display pointer
positions and distances in the unit of measure chosen here.
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Autogrid spacing (pixels)

To set the spacing of the Autogrid, click the button next to 2, 4, 8,
16, or 32 pixels (screen dots). A pixel is about 1/72 inch. MacPaint
is preset to use 8 pixels.

New windows

You can specify that all new document windows have the same size
as the currently active window, or you can let MacPaint make them
the standard size for your screen. Click Use Auto Window Sizing to
have MacPaint make windows the standard size or Use Current
Window Size to have MacPaint make all windows the same size as the
current window.

Memorize menu positions

You can record how you like to use the Tools and Patterns menus.
You first set up the menus as you like them (tearing them off and
placing them at specific locations, if you wish) and then choose the
Preferences command. Then you click the Memorize Menu
Positions box. The torn-off Tools and Patterns menus will appear
automatically at their current positions on the screen whenever you
open a document.

Option-Command pattern effect

You can see how patterns will interact when they are overlapped.
You can have one pattern completely block out another (Opaque).
You can have one pattern appear transparently through another
(Transparent). You can have one pattern invert the dot pattern of
the pattern beneath it (Reversed). You can have a pattern erase
parts of another pattern that it overlaps as if you were erasing with a
patterned eraser (Erased).

After choosing one of the four paint modes, you can call it into
effect by holding down the Option and Command keys together as
you draw with any filled shape tool. To choose a paint mode, click
the button next to one of the options. To invert the second pattern
where it crosses the first, also click the Invert Pattern First box.
Inverting the selected pattern changes the black dots to white and
white dots to black, allowing you to paint with the opposite pattern
than the one selected on the Patterns menu.
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Each of the examples in Figures 3-22 and 3-23 was made the same
way: A borderless rectangle (filled with a checkerboard pattern) was
drawn. Then Option and Command were held down while another
rectangle (filled with a diagonal pattern) was drawn over the first
rectangle. The differences result from the pattern effect chosen
from the Preferences dialog box. Figure 3-22 shows the effect of the
four paint modes. Figure 3-23 shows the effect of first inverting the
second pattern and then applying it in the four paint modes.
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Figure 3-22
Option-Command pattern effects
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Figure 3-23
Option-Command pattern effects, inverted first

The Goodies menu 129



< By the way: You can take advantage of these effects when you
drag a selection over another part of a picture: Simply hold
down the Tab key while you drag. If Erased is the chosen
effect, using this feature is like having a patterned eraser. If
Transparent is the chosen effect, using this feature is like sliding
transparent overlays over one another.

Text mode

You can determine how text will appear against a background
pattern. When you choose Normal, text appears with a white
background as you type (blocking out the background pattern
behind it). Choosing Overlay produces text surrounded by the
background pattern. When you select Inverted, text appears
reversed in relation to the background, for example, text will
appear white on a black background and black on a white
background. The Preferences dialog box illustrates the three text
modes (see Figure 3-24). Click the button next to Normal, Overlay,
or Inverted.

Tert mode is:

a
Sample @ Normal

—

' c O Overlay

Sie O Inverted E‘I 0K }

&

Figure 3-24
The Normal, Overlay, and Inverted text modes from the
Preferences dialog box
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Edit Pattern...

Choosing Edit Pattern displays a dialog box that lets you edit the
current pattern (see Figure 3-25). You can create patterns of your
own or capture patterns that appear in your document and store
them on the Patterns menu. When you save the document, your new
patterns and edited patterns are saved as well.

You first click a pattern on the Patterns menu that you wish to
replace. After you choose Edit Pattern from the Goodies menu, a
dialog box appears. Both a magnified view of the selected pattern
and the pattern as it appears normally appear within the box. By
clicking in the magnified view, you can change the pattern of black
and white dots. (You can also click directly on a pattern in the
document to “capture” it.) The changes in the magnified view
immediately appear in the normal view. When you are satisfied with
the pattern, you click OK to add it to the Patterns menu. Clicking
Cancel cancels your changes and leaves the Patterns menu
unchanged.

Click to change any dot from
black to white or white to black

I ok ]]/{/Cancel]

Changes reflected here

Figure 3-25
The Edit Pattern box

Note that double-clicking a pattern in the torn-off Patterns menu

chooses that pattern and also displays the Edit Pattern dialog box
for editing.
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Brush Shape...

Choosing Brush Shape displays a dialog box that lets you choose
one of 32 paintbrush shapes (see Figure 3-26). The currently
selected brush shape appears within a black square. Click the brush
shape you wish to choose and dismiss the dialog box.

Ve N\ | —

Figure 3-26
The Brush Shape dialog box

Note that double-clicking the paintbrush in the torn-off Tools menu
also displays the Brush Shape dialog box.

132 Chapter 3: MacPaint Reference



Brush Mirrors...

Choosing Brush Mirrors displays a dialog box that lets you select up
to four “mirrors” (axes of symmetry) for painting symmetrical
figures with the paintbrush (see Figure 3-27). Brush Mirrors is useful
for creating interesting patterns, such as snowflakes, or creating
kaleidoscopic effects. You can use Brush Mirrors at the 100-percent
and 50-percent zoom levels only. If you select the vertical and
horizontal axis, for example, you see four brushes mirroring the
action of the pointer as you drag it. Each axis passes through the
center of the window, but not necessarily through the center of the
document. You can use one, several, or all of the mirrors at the
same time. Choose None to use no brush mirrors.

N

{L_oK JJ (_None ]

Figure 3-27
The Brush Mirrors dialog box

To select an axis for painting, click the desired line. Selected

mirrors appear as lines wider than the others. To deselect a selected
mirror, click the line.
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Animals ®3
Figure 3-29

Portion of the Goodies menu
that displays names of
currently opened documents

Scale Selection...

Choosing Scale Selection displays a dialog box that lets you reduce
or enlarge a selection made with the selection rectangle (see
Figure 3-28). Scale Selection is useful if you need to change the size
of an image to better fit a picture. You can scale the image up or
down until it’s the appropriate size. When the dialog box appears,
you specify the percentage of enlargement or reduction. To reduce
a selection, type a number less than 100; to enlarge the selection,
type a number greater than 100. Click OK to see how the selection
changes. After you choose Scale Selection, the image (or text)
remains selected, and you can choose the command again to
rescale the selection to a different size.

Scale selection to:

5o ia
-

Figure 3-28
The Scale Selection dialog box

A warning box appears if you try to enlarge a selection so much that
it would be bigger than a MacPaint document.

Windows 1 through 9

The Goodies menu (see Figure 3-29) lists the titles of the currently
open documents. When you choose a document name from the
Goodies menu, that document comes to the front and becomes the
active window. When several documents are open at the same time
the Goodies menu may become so long that all the document
names cannot be seen on the screen. An arrow appears at the
bottom of the menu indicating that more documents are available
on the menu. You can scroll the menu to bring document names
into view by dragging past the bottom of the menu.

% Keyboard equivalent: Command-1...Command-9
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The Font menu

The Font menu lists all fonts installed in your startup disk System
file. When typing text with the text tool, you can change text fonts at
any time by choosing a font name from the menu. If you want to use
different fonts in the same text, you can press Enter and choose the
font that should next appear. (You can't edit previously typed text if
you do this, however.) You can add and remove fonts from the
Fonts menu. Because fonts are stored in the Macintosh system, you
must use the Font/DA Mover program to add or delete fonts.

You can change the currently selected font to the one that appears
above or below it on the Font menu by holding down the Command
and the Shift keys and pressing the > or < keys.

The Style menu

The Style menu lists three sets of attributes that MacPaint text can
have: Size, Style, and Alignment.

Size

The available font sizes for your text appear at the top of the menu.
You may see font sizes listed in black or outlined numbers. Black
font numbers indicate that the Macintosh will have to scale (enlarge
or reduce mathematically) the font to match that particular font
size. Outlined font numbers indicate that a font in exactly that size is
available. The font sizes with outlined numbers will look best on the
screen because they are already stored in your system and therefore
don’t have to be scaled by the computer.

One point equals about 1/72 inch, so 18-point characters are about
1/4 inch high.
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The text styles portion of the
Style menu

vAlign Left
Align Middle
Align Right

Figure 3-31
The text alignments portion of
the Style menu

To reduce the size of active text by one increment, press
Command-<. To increase it by one increment, press
Command->.

To increase the leading (spacing between lines) of active text,
press Option-Command->. To decrease leading, press
Option-Command-<.

Style

You can type text that is boldfaced, italicized, underlined,
outlined, or shadowed, or that has a combination of these
attributes, in addition to creating standard (plain) text. The style
names in the Style menu (see Figure 3-30) are examples of these
attributes. Choosing one of these styles changes the text you are
currently typing in your document. Check marks appear beside the
styles that have been chosen. By choosing a style name again, you
can cancel that text style. For example, if your text is bold and
underlined, you choose Underline from the menu if you want the
text bold but not underlined.

Choosing Plain cancels all the text styles.

% Keyboard equivalents: Command-P (Plain), Command-B
(Bold), Command-I (Italic), Command-U (Underline)

Alignment

You can choose from among three types of alignment for your text:
Align Left, Align Middle, and Align Right (see Figure 3-31).

If you choose Align Left, individual lines of text line up with the
insertion point as their left margin.

If you choose Align Middle, lines of text center horizontally on the
original insertion point.

If you choose Align Right, individual lines of text line up with the
insertion point as their right margin.
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Figure 3-32
The Patterns menu

The Patterns menu

The Patterns menu (see Figure 3-32) provides a choice of 38 patterns
for shading a document. The Patterns menu lets you choose the
pattern used by the paintbrush, the paint bucket, the spray can, and
the five filled shape tools. You also use the Patterns menu to choose
patterns for patterned borders or lines. You can choose patterns by
pulling down the menu or you can tear the menu off the menu bar
and move it around the screen to convenient locations.

To choose a pattern from the menu bar, pull down the Patterns
menu, drag to the pattern you want to choose, and release the
mouse button. The pattern will blink momentarily to show that it has
been selected, and then the menu will disappear. If you pull the
menu down again, you'll see that the selected pattern appears in the
pattern box at the top of the menu.

To tear off the Patterns menu, pull it down from the menu bar.
Without releasing the mouse button, drag the pointer beyond the
menu boundary. A dotted outline of the menu follows the pointer.
Release the mouse button when the outline is where you want the
menu to be. You can reposition the menu by positioning the
pointer on the menu’s drag bar and dragging. (You can also tear it
off again.) If the Patterns menu has been torn off, you can click the
desired pattern to select it.

You can change the patterns that appear on the Patterns menu.

Refer to “Edit Pattern” in this chapter for more information about
editing patterns. Double-click any pattern in the torn-off Patterns
menu to choose a pattern and display the Edit Pattern dialog box.
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Vertical line weight
Line weight sample

Selection rectangle

The Tools menu

The Tools menu (see Figure 3-33) lets you choose among 6 line
weights and 20 tools for use in your documents. Like the Patterns
menu, the Tools menu can be torn off the menu bar and moved
around the screen. All tools can be chosen either from the menu
bar or from the torn-off menu, but shortcuts that require double-
clicking are available only when the Tools menu is torn off. Tearing
the Tools menu off the menu bar is just like tearing off the Patterns
menu. Refer to “The Patterns Menu” in this chapter for information
about tearing off menus.

Drag here

Horizontal line weight

Rectangle tool

Lasso tool
Grabber

Line tool

Rounded rectangle tool

Paint bucket tool

Spray can tool

Oval tool

Paintbrush tool

Freehand shape tool

Pencil
Text tool

Eraser

Polygon tool

Figure 3-33
The Tools menu

To choose a tool, pull down the Tools menu, drag to the tool you
want to choose, and release the mouse button. If the Tools menu
has been torn off, just click a tool.

The pointer takes a shape appropriate to the chosen tool.
Generally, to use a tool you hold down the mouse button while
moving the pointer in the drawing window. For conciseness, this
section calls that action dragging a tool.

Holding down the Option key while you use any tool (except the text
tool) temporarily changes the tool to the grabber.

If you reach the edge of the window (as opposed to the edge of the
document) while dragging a tool, the window scrolls automatically.
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Figure 3-34
Line-weight indicator box

Line weights

You can draw lines and shapes with thick or thin lines depending on
the line weight you choose from the top of the Tools menu (see
Figure 3-34). You have a choice of five line weights plus an invisible
line weight, shown as a dotted line, which can be used to draw
borderless shapes. You can draw shapes with one line weight or give
the shape different vertical and horizontal line weights. The line-
weight indicator box to the left of the line weights shows which
vertical and horizontal line weights have been chosen.

O To choose the same line weight for both vertical and horizontal
lines, click on the appropriate line in the Tools menu.

O To choose a vertical line weight, click just above the appropriate
line in the Tools menu.

0O To choose a horizontal line weight, click just below the
appropriate line in the Tools menu.

‘When the horizontal and vertical line weights differ, any curves or
diagonal lines graduate from one weight to the other. You can select
an invisible line weight for either the horizontal or vertical weight
and draw with the rectangle tool to draw two parallel lines
automatically.

Figure 3-35
Figures drawn with various line weights
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Selection rectangle

Use the selection rectangle to select a rectangular portion of a
picture. After selecting an image or text, you can move it by
dragging or use a command to change it in some way.

To make a selection, choose the selection tool and position the
pointer beside the image you wish to select. You drag as if drawing a
rectangle to encompass the image you want to select, so position
the pointer as if it were at one corner of the proposed rectangle.
Drag to draw a selection rectangle that completely encloses the
image. Release the mouse button and the area circumscribed by the
rectangle is selected. If you hold down the Command key while
dragging the tool, the selection rectangle shrinks as small as
possible to enclose the outline of the image.

Once an image is selected, move the pointer close to the selection
until the pointer becomes an arrow. You can then drag to move the
selection, hold down the Option key while dragging to duplicate the
selection, or hold down both the Command and Option keys while
dragging to make multiple copies.

You can use the commands in the Edit menu (Cut, Copy, Paste,
Invert, Fill, and so on) to manipulate selections made with the
selection rectangle. You can also stretch or shrink such a selection
by holding down the Command key while dragging a corner of the
selection. To resize a selection without changing its proportions,
hold down both the Command and Shift keys while dragging a
corner of the selection.

Double-click the selection rectangle in the torn-off Tools menu to
select the entire window. Hold down the Shift key while double-
clicking the selection rectangle to select the entire document.

Use Tab while dragging a selection to use the Option-Command
pattern effects (as set in the Preferences dialog box) to specify how
overlapping patterns interact.
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Lasso

Use the lasso to select an irregularly shaped portion of a picture.
After selecting an image or text, you can move it by dragging or use
a command to change it in some way.

To make a selection, choose the lasso and position the pointer
beside the image you wish to select. Drag as if drawing a loop
around the image you want to select. The loop will automatically
close with a straight line from the beginning to the ending points if
you do not close it. A line trails from the lasso tip showing the size of
the selection. Release the mouse button and the loop shrinks as
small as possible to enclose the outline of the image. The selected
image begins to shimmer.

Once an image is selected, move the pointer close to the selection
until the pointer becomes an arrow. You can then drag to move the
selection, hold down the Option key while dragging to duplicate the
selection, or hold down both the Command and Option keys while
dragging to make multiple copies. You can also Invert or Fill a
lassoed selection.

Double-click the lasso in the torn-off Tools menu to select the entire
window. Hold down the Shift key while you double-click on the lasso
to select the entire document.

Use Tab while dragging a selection to use the Option-Command
pattern effects (as set in the Preferences dialog box) to specify how
overlapping patterns interact.

Grabber

Use the grabber to scroll the document within the window. The
grabber allows you to scroll vertically, horizontally, and diagonally
within the window, whereas scrolling with the scroll bars allows you
to scroll in only one direction, vertically or horizontally, at a time.

Choose the grabber from the Tools menu and position the pointer
over the document. Drag in the direction you want the document to
scroll; release the mouse button to stop scrolling. All the tools on
the Tools menu (except the text tool) can be changed to the grabber
by holding down the Option key.
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Tip of paint bucket

Line tool

Use the line tool to draw straight lines. You can draw vertical,
horizontal, and diagonal lines in any of the line weights available
on the Tools menu. Click the line tool, position the pointer where
the line is to begin, and drag to draw the line. As long as the mouse
button is pressed, you can lengthen, shorten, or change the angle
of the line. Release the mouse button when the line is as you want it.

If you hold down the Shift key while using the line tool, you can draw
only lines that are horizontal, vertical, or at a 45-degree angle.

Hold down the Command Key while using the line tool to draw lines
made of the current pattern rather than black.

Paint bucket

The paint bucket tool is used to fill enclosed areas with a pattern. It's
useful for filling shapes such as triangles or ovals, or any closed
shape. A closed shape is one that has an unbroken outline or
perimeter of black dots (without gaps of white dots), such as a circle
or rectangle. After selecting the paint bucket and a pattern, move
the paint bucket pointer over an enclosed area of the drawing and
click to fill that area with the current pattern.

The tip of the pouring paint must be inside the area you want to fill.
You must be careful to position the tip of the paint bucket within the
enclosed area. If it is not within the enclosed area, you may fill a
much larger area of the drawing than you anticipated.

If the shape you fill has an opening, or gap, even the size of one dot
(pixeD), the pattern will spread through it onto the rest of the
document. If you discover that the pattern has leaked from a shape,
choose Undo to cancel the results of choosing Fill. Then use the
pencil tool or another tool to stop up the leak in the image by
drawing across the gap. You may want to zoom in to discover leaks.
Once a leak has been patched, you can use the paint bucket to fill the
shape.

To fill beyond the boundaries of the document window, hold down
the Shift key while using the paint bucket.
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Spray can

Use the spray can to spray the current paint pattern. Select the
pattern you wish to apply, choose the spray can tool, and
position the pointer over the document. You can apply spots of
paint by clicking, or you can drag the pointer to spray the paint
on continuously. You can apply the paint pattern in light strokes
or go over the same area several times to darken the pattern. The
more you drag over a given area, the more apparent the pattern
becomes.

Hold down the Shift key while using the spray can to limit this tool to
horizontal and vertical movement only.

Paintbrush

Use the paintbrush to paint strokes with the current paint pattern.
Select the pattern you wish to apply and choose the paint brush
tool. To determine the brush shape, choose Brush Shape from the
Goodies menu. Position the pointer over the document and drag
to apply the paint pattern.

Hold down the Command key while using the paintbrush to paint
with transparent paint.

Hold down the Shift key while using the paintbrush to limit brush
strokes to horizontal and vertical only.

Pencil

Use the pencil tool to draw lines and to perform fine editing of

the dots that make up an image. After choosing the pencil tool,
position the pointer on the document. Click to put 2 dot on the
document or drag to draw a line. If the tip of the pencil is on a white
dot, the pencil tool will draw a black dot or line. If the pencil tip is
on a black dot, the tool will draw a white dot or line. As long as you
hold the mouse button down, the pencil will continue to draw in
black or white.
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You can use the pencil tool as a very fine eraser, erasing black or
white dots by dlicking on them. For example, if you click on a black
dot to erase it, you can continue holding down the mouse button
and erase other black dots—any you touch with the pencil tip. You
may find zooming in on a document and editing images with the
pencil a useful method for working in fine detail.

Hold down the Shift key while using the pencil to limit lines to
horizontal and vertical only. Hold down the Command key and
double-click with the pencil tool to zoom in on a document. Hold
down the Shift and Command keys and double click to zoom out on
the document.

Double-click the pencil in the torn-off Tools menu to zoom directly
to the 800-percent view from any other view. In the 800-percent
view, double-click on the pencil in the torn-off Tools menu to
return to the 100-percent view.

Text tool

Use the text tool to add text to documents. The text tool is useful for
adding captions or labels to documents, for example. After
choosing this tool, the pointer becomes shaped like an I-beam.
Position the pointer where you want text to appear and dick. You
then begin typing. Press Return when you want to end a line and
start typing on the line below. You can use Backspace/Delete to
eérase errors. You can change the font, font size, style, and
alignment at any time as you type text. After choosing another tool
or clicking elsewhere in the document to add additional text, you
cannot edit or change your text.

Use the Font and Style menus to change the font, size, style, and
alignment (left, right, middle) of active text. To change the font,
size, or style within a single passage of text, press Enter and choose
different text choices from the menu.

To space lines of active text closer together, press Command-
Option-<. To space lines of active text farther apart, press
Command-Option->. Changing the text font, style, size, or
alignment automatically changes the line spacing, so change line
spacing after you have made your final choices about how text
should appear.
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Eraser

Use the eraser to erase portions of the document. You can use the
eraser to erase mistakes or clean up images such as by erasing the
ends of lines that were drawn too long. After choosing the eraser,
position the pointer over the image you wish to erase. You can click
to erase only the dots below the pointer or drag the eraser over an
area you want to erase.

You can also use the eraser as a magic eraser that restores images to
the document. If you hold down the Command key as you drag with
the eraser tool, MacPaint uses the current snapshot to restore the
document. By alternating between the eraser and magic eraser, you
can erase only those images you want to remove without risking
losing part of your document by mistake.

Refer to “Take Snapshot” in this chapter for more information
about using snapshots with MacPaint.

Hold down the Shift key while using the eraser to limit its movement
to horizontal and vertical only.

Double-click the eraser in the torn-off Tools menu to erase the
entire window. Hold down the Shift key while double-clicking the
eraser to erase the entire document.

Hold down the Command key and double-click the eraser on the
Tools menu to revert the images in the current window to the
snapshot. Hold down the Command and the Shift keys and double-
click the eraser tool on the Tools menu to revert the entire
document to the snapshot.

Rectangles: Hollow and filled

Use the rectangle tools to draw rectangles or rounded rectangles.
You can draw rectangles that are hollow or filled automatically with
a pattern. Click the gray rectangle tools to draw filled shapes.

To draw a rectangle, click the desired tool and position the pointer
over the document where a corner of the rectangle should appear.
Drag diagonally to where the opposite corner of the rectangle
should appear. As long as you hold down the mouse, you can
change the size of the rectangle. Release the mouse button to stop
drawing the rectangle.
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If you prefer, you can draw rectangles from the center out by
double-clicking the desired tool from the torn-off menu or by
choosing Draw From Center from the Goodies menu. Refer to
“Draw From Edge, Draw From Center” in this chapter for more
information about changing how rectangles are drawn.

Filled rectangles are filled with the current paint pattern. The
current line weights determine the thickness of a shape’s borders.

To produce squares or rounded squares, hold down the Shift key
while drawing a rectangle.

To draw a rectangle with borders made of the current pattern rather
than black, hold down the Command key while drawing a shape. To
draw a filled rectangle with no border, choose invisible (dotted)
line weights from the Tools menu before drawing the rectangle.

To use the special pattern effects chosen in the Preferences menu,
hold down both the Command and Option keys while drawing a
rectangle.

Ovails: Hollow and filled

Use the oval tools to draw ovals and circles. You can draw ovals that
are hollow or filled automatically with a pattern. Click the gray oval
tool to draw filled shapes.

To draw an oval, click the desired tool and imagine a rectangle that
encloses the oval. Position the pointer over the document where a
corner of the imaginary rectangle should appear. Drag diagonally
to where the opposite corner of the rectangle should appear. As
long as you hold down the mouse, you can change the size of the
oval. Release the mouse button to stop drawing the oval.

If you prefer, you can draw ovals from the center out by double-
clicking the desired tool from the torn-off menu or by choosing
Draw From Center from the Goodies menu. Refer to “Draw From
Edge, Draw From Center” in this chapter for more information
about changing how rectangles are drawn.

Filled ovals are filled with the current paint pattern. The current line
weights determine the thickness of a shape’s borders.
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To produce a circle, hold down the Shift key while drawing an oval

To draw an oval with a border made of the current pattern rather
than black, hold down the Command key while drawing the oval. To
draw a filled oval with no border, choose the invisible (dotted) line
weights in the Tools menu before drawing the oval.

To use the special pattern effects chosen in the Preferences menu,
hold down both the Command and Option keys while drawing an
oval.

Freehand shapes: Hollow and filled

Use the freehand shape tools to draw freehand shapes. You can
draw freehand shapes that are hollow or that fill automatically with a
pattern. To draw a freehand shape, choose the desired tool and
position the pointer over the document. Drag to draw the desired
shape and release the mouse button to stop drawing. Your lines can
cross, and you can draw in any direction desired. If you are drawing
a filled shape, MacPaint will automatically connect the beginning
and the ending points and fill the shape if you don’t connect the
points yourself.

Filled shapes are filled with the current paint pattern. The current
line weights determine the thickness of a shape’s borders.

To draw a shape with a border made of the current pattern rather
than black, hold down the Command key while drawing the shape.
To draw a filled shape with no border, choose the invisible (dotted)
line weights in the Tools menu before drawing the shape.

To use the special pattern effects chosen in the Preferences menu,
hold down both the Command and Option keys while drawing a
shape.
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Polygons: Hollow and filled

Use the polygon tools to draw shapes made up of angles and straight
lines. The polygon tool is useful for drawing shapes such as
triangles, pentagons, and so on.

To draw a polygon, first click where you wish to begin drawing the
polygon. With the mouse button released, move the mouse to draw
a line (do not hold the mouse button down.) Click the mouse to tack
down the line when you wish to draw at a different angle. To stop
drawing, double-click when the pointer is at the ending point of the
polygon, or position the point on the starting point of the polygon
and click once.

If the polygon’s ending point and starting point differ, hollow
shapes remain incomplete, but MacPaint automatically completes
filled shapes by connecting the ending point to the starting point.
Filled polygons are filled with the current paint pattern. The current
line weights determine the thickness of a shape’s borders.

To limit lines to horizontal, vertical, and 45 degrees, hold down the
Shift key while using the tool.

To draw a polygon with a border made of the current pattern rather
than black, hold down the Command key while drawing the
polygon. To draw a filled polygon with no border, choose the
invisible (dotted) line weights in the Tools menu before drawing the
polygon.

To use the special pattern effects chosen in the Preferences menu,
hold down both the Command and Option keys while drawing a
polygon.
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Double-clicking and using modifier keys

When the Patterns and Tools menus are torn off, there are several
shortcuts you can take by double-clicking or Shift-double-clicking
tools or patterns in those menus.

You can also use the Shift, Option, Command, and Tab keys to
modify some of the tools and perform menu commands from the
keyboard.

Patterns menu
O Double-click any pattern to edit that pattern.

Paintbrush

O Double-click the paintbrush to choose Brush Shape.

O Use Command to paint with transparent paint.

O Use Shift or Caps Lock to limit strokes to vertical and horizontal.

Spray can

O Use Shift or Caps Lock to limit movement to vertical and
horizontal.

O Use Command to paint with transparent paint.

Paint bucket
O Use Shift or Caps Lock to fill beyond the window.

Ovais, rectangles, and rounded rectangles

O Double-click to switch between Draw From Center and Draw
From Edge.

O Use Shift or Caps Lock to draw squares and circles.
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Polygon tool

O Use Shift or Caps Lock to limit lines to vertical, horizontal, and
45 degrees.

Any shape tool
0O Use Command to draw shapes with patterned borders.

O Use Option-Command with a filled shape tool to paint with
pattern effects (as set in the Preferences dialog box).

Line tool
0O Use Command to make patterned lines.

O Use Shift or Caps Lock to limit lines to vertical, horizontal, and
45 degrees.

0 Use Option-Command with the line tool to draw patterned lines
with pattern effects (as set in the Preferences dialog box).

Pencil

0 Double-click to zoom in to the 800-percent view or back to the
100-percent view.

0 Use Command-click with pencil chosen to zoom in on a given
point.

O Use Command-Shifi-click with pencil chosen to zoom out on a
given point.

O Use Shift or Caps Lock to limit lines to vertical and horizontal.
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Eraser

O
O

O

Double-click to erase the entire window.
Shift—double-click to erase the entire document.

Use Command with the eraser to revert the erased portion to the
snapshot.

Use Command-double-click to revert the current window to the
snapshot.

Use Command-Shift-double-click to revert the entire document
to the snapshot.

Use Shift or Caps Lock to limit erasures to vertical or horizontal.

Selection rectangle

O

O
(]
O

Double-click to select the entire window.
Shift—-double-click to select the entire document.
Use Command to shrink the selection to fit.

Use Command while dragging the selection to stretch the
selection.

Use Command-Shift while dragging to resize the selection while
maintaining the image’s same proportions.

Use Option while dragging the selection to duplicate the
selection.

Use Option-Command while dragging a selection to make
multiple copies.

Use Tab while dragging a selection to use the Option-Command
pattern effects (as set in the Preferences dialog box) to specify
how overlapping patterns interact.
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Lasso

0

[m]

Double-click to select all black dots (and white areas enclosed in
black) in the window.

Shift-double-click to select all black dots in the document.

O Use Option while dragging selection to duplicate the selection.

0 Use Option-Command while dragging a selection to make

multiple copies.

O Use Tab while dragging a selection to use the Option-Command
pattern effects (as set in the Preferences dialog box) to specify
how overlapping patterns interact.

The grabber

O Use Shift or Caps Lock to limit scrolling to vertical and
horizontal.

O Use Option to change any tool (except the text tool) to the
grabber.

Text

0O Use Option-Command-< to space active text lines closer
together.

O Use Option-Command-> to space active text lines farther apart.

O Use Command-< to reduce the font size.

0O Use Command-> to enlarge the font size.

O Use Command-Shift-< to choose the font above the current one
on the Fonts menu.

O Use Command-Shift-> to choose the font below the current one

on the Fonts menu.
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Keyboard equivalents for menu commands

Bold text (Style menu) Command-B
Copy (Edit menu) Command-C
Trace Edges (Edit menu) Command-E
Trace Edges with drop shadow (Edit menu) Command-Shift-E
Show/Hide Actual Size (Goodies menu) Command-F
Turn Autogrid On/Off Command-G
Shortcuts (Goodies menu) Command-H
Ttalic text (Style menu) Command-I
Show/Hide Mouse Position (Goodies menu) Command-K
Zoom Out (Goodies menu) Command-L
Zoom In (Goodies menu) Command-M
New document window (File menu) Command-N
Open a saved document (File menu) Command-O
Plain text (Style menu) Command-P
Quit MacPaint (File menu) Command-Q
Revert To Snapshot (Edit menu) Command-R
Save (File menu) Command-S
Rotate (Edit menu) Command-T
Underline text (Style menu) Command-U
Paste (Edit menu) Command-V
Close (File menu) Command-W
Cut (Edit menu) Command-X
Take Snapshot (File menu) Command-Y
Undo (Edit menu) Command-Z
Tilde (~)
Escape

Activate an open window (Goodies menu) Command-1...Command-9

Double-clicking and using modifier keys
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Appendix A

Ready-Made Pictures

There are many sources of MacPaint pictures—you don’t have to
create every one from scratch.

Clip art

Clip art has traditionally been found in books full of images that,
because they are not copyrighted, can freely be reproduced in
newsletters, advertisements, and so on. MacPaint has spawned a
whole new kind of clip art: disks of MacPaint images you can use in
the pictures you make. Some of these images are in the public
domain (not copyrighted), but others are copyrighted. Before
using copyrighted images in a commercial publication, you must
first get permission and sometimes pay a fee and credit the source.

What kind of clip art can you buy? Maps, symbols, portraits, fancy
borders, buildings, furniture, logos, office equipment, cartoon
figures, plants and animals, sports—you name it!

You can learn about available clip art at your CLARIS dealer, from
magazines that feature Macintosh applications, and from user
groups.
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Screen dumps

You can capture almost any image from the Macintosh screen as a
MacPaint document, even when you're not using MacPaint. See the
owner’s guide that came with your Macintosh for details.

Digitizers

Digitizers are devices that scan images and convert them to
documents you can manipulate with MacPaint. Some of them also
let you adjust brightness, contrast, and so on. Once an image is
scanned, you can open the document from MacPaint and add text,
combine several different images, and make any number of other
changes.

There are two types of digitizers:

O Video digitizers consist of a video camera and special software
that converts a video picture into digital form. They’re ideal for
capturing images of three-dimensional objects. They can also be
used to digitize an image from a television screen.

O Scanners capture two-dimensional images from printed pages,
drawings, or photographs and convert them to digital form.
Some scanners scan a page as it's fed through a dot-matrix
printer. Bed scanners digitize an image as it lies on a flat glass
surface.
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Appendix B

Using MacPaint on the
AppleShare File Server

The AppleShare™ file server lets you store and share information
over the AppleTalk® Personal Network. MacPaint 2.0 is compatible
with AppleShare and is a network-ready application.

You can store MacPaint documents and MacPaint 2.0 on the
AppleShare file server and open them from your AppleShare
workstation. Only one workstation user at a time can open the
MacPaint application stored on the file server. If another user tries
to open it, a message tells the user that MacPaint is being used.

One recommended way to use MacPaint with the file server is for
each user to have MacPaint on a workstation disk to work with
MacPaint documents stored on the file server. With each
workstation using MacPaint on a workstation disk, all workstations
can open and work on MacPaint documents at the same time.
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Warning

Different workstations can also open and work on the same
document simultaneously. When two or more workstations open the
same document, the first workstation to save the revised document
can save it in the regular manner. Any workstation saving the
document after that will see a message saying that the document has
been changed since the last time it was opened. The workstation
user then has the option of saving the document with a different
name, replacing the document stored on the file server with the
newly revised document of the same name, or canceling the save
procedure.

See the AppleShare User’s Guide for information about using
network-ready applications on the AppleShare file server.

Remember, it is a violation of copyright laws to make extra
copies of MacPaint for use on more than one computer or
workstation at a time.
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Glossary

actual size inset: A window appearing in an
enlarged view that shows the normal (100 percent)
view of the window.

Autogrid: An invisible grid covering a document.
When the Autogrid is on, lines and shapes drawn
with the line and shape tools begin and end where
the invisible grid lines intersect. Text is also
aligned to the grid.

Caps Lock key: A key that, when engaged, causes
subsequently typed letters to appear in uppercase.
The effect is like that of the Shift key except that
numbers and other non-letter symbols are not
affected.

Clipboard: A holding place for the last selection
cut or copied.

clip art: Ready-made images that can be
reproduced in MacPaint documents.

close box: A small box on the left side of the title
bar of an active window. You click it to close the
window.

command: A word, usually in a2 menu, that
describes an action for MacPaint to perform. Also
a combination of the Command key and another
key on the keyboard that accomplishes the same
action as the menu command.

Command key: A key on the Macintosh
keyboard. You can choose a command from a
menu by holding down the Command key and
typing another key.

constrain: To limit a form to a certain shape,
direction, or angle while drawing or moving it.

crosshairs: The cross-shaped pointer used to
indicate the starting and ending points of shapes
as they are drawn.

cut: To delete a selection from a picture and put it
on the Clipboard.

desk accessories: Mini-applications that are
available from the Apple menu regardless of which
application you are using—for example, the
Calculator, Note Pad, Alarm Clock, Puzzle,
Scrapbook, Key Caps, and Chooser.

desktop: The MacPaint working environment.

digitizer: A device that scans images and converts
them to documents that can be used by MacPaint.

dimmed command: A command that appears
gray rather than black in the menu. You cannot
choose a dimmed command, usually because the
command would be unable to act successfully.

double-click: To position the pointer and then
press and release the mouse button twice in rapid
succession without moving the mouse.

drag: To position the pointer on a portion of a
picture, press and hold the mouse button, move
the mouse, and release the mouse button.

Draw From Center: The command on the
Goodies menu used to draw circles, rectangles, or
rounded rectangles from the center. Compare
Draw From Edge.
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Draw From Edge: The command on the Goodies
menu used to draw circles, rectangles, or rounded
rectangles from the outer edge. Compare Draw
From Center.

drop shadow: An outline of a shape that is heavier
on the right and bottom than on the left and top.

duplicate: To make a copy of a selected area of a
document.

eraser: A tool used to erase a picture or part of a
picture.

Finder: The hub of the Macintosh system. The
Finder lets you manage your documents and
change applications.

flip: To turn a selected object upside down or
sideways to its mirror image.

Font/DA Mover: An application available on the
Macintosh System disk and on the LaserWriter
Installation disk that allows you to add to or
remove fonts from a disk’s system file.

freehand shape tool: A tool used for drawing
freeform shapes. The tool has a hollow and a filled
form.

grabber: A tool used to move into view parts of
the document that are outside the window.

I-beam: A type of pointer, shaped like the capital
letter 7, which appears when the text tool is
selected.

icon: An image that graphically represents an
object, a concept, or a2 message.

invert: To change a pattern by changing all black
dots to white and all white space to black dots.

keyboard equivalent: The keys pressed to choose
a command from a menu instead of pulling down
the menu.

Key Caps: A desk accessory that shows you the
optional character set.

lasso: A tool used for selecting an irregularly
shaped portion of a picture.

line tool: A tool used to draw straight, vertical,
horizontal, or diagonal lines.

line weight: The thickness of lines drawn with the
line tool, or the thickness of the borders of shapes
drawn with the rectangle, oval, polygon, and
freehand shape tools.

mouse position inset: A window showing exactly
where the pointer is in relation to the upper-left
corner of the document and how far the pointer
moves each time it is dragged.

Note Pad: A desk accessory that allows you to enter
and edit small amounts of text while working on
another document.

opaque paint: Paint that covers a shape or picture
completely.

Option key: A modifier key that gives a different
meaning or action to another key you type or
mouse actions you perform. You use the Option
key to type foreign characters or special symbols
contained in the optional character set.

oval tool: The tool used to draw circles and ovals.
The tool has a hollow and a filled form.

paintbrush: A tool used to paint black, white, or
patterned brush strokes.

paint bucket: A tool used to fill an area with the
current pattern.

Patterns menu: The menu used for choosing

the pattern used by the following tools: the paint-
brush, the paint bucket, the spray can, and the five
filled shape tools.

pencil: A tool used for drawing thin black lines.

pixel: Tiny dots (picture elements) that make up a
MacPaint document. At any moment, each dot is
either black or white.

polygon tool: A tool used to draw polygons and
open-ended shapes. The tool has a hollow and a
filled form.



Preferences: The command in the Goodies
menu used to change the MacPaint preset options
concerning measurements, autogrid spacing,
window sizing, menu positions, pattern effects,
and text.

preset option: A MacPaint setting that is always in
effect when a new document is created. You can
change preset options to your own settings after
opening a document.

rectangle tool: A tool used to draw rectangles.
The tool has a hollow and a filled form.

revert: To change back to the version of the
document previously saved.

rounded rectangle tool: A tool used to draw
rounded rectangles. The tool has a hollow and a
filled form.

scroll bar: A rectangular bar that may be along the
right or bottom of a window. Clicking or dragging
in the scroll bar causes the view of the document to
change.

selection box: A box drawn with the selection
arrow pointer. All objects enclosed by the box are
selected.

selection rectangle: A tool used to select a
rectangular portion of a picture.

snapshot: A version of a document saved
automatically in memory by MacPaint when the
document is opened. Updated versions of
snapshots can be saved (taken) or deleted (thrown
away) at any time.

spray can: A tool used to spray the current
pattern.

startup screen: A screen that appears when the
Macintosh is first turned on. MacPaint documents
can be saved as startup screens by clicking the
startup screen option on the Save As dialog box.

stationery: A MacPaint document that records
the graphics, text, menu positions and other
option preferences used routinely when creating
documents.

System file: A file Macintosh computers use to
start up and to provide systemwide information.
The System file contains system programs.

tear-off menu: A menu, such as the Tools or
Patterns menu, that can be dragged from (torn off)
its original position and placed anywhere in a
window.

text mode: Three choices of text to add to a
picture: Normal, Overlay, and Inverted. Normal
refers to text typed over a dark background and
appearing within a white band. Overlay refers to
text typed over a dark background not within a
white band. Inverted refers to text that appears in
black over a white background that is inverted to
white over a black background.

text tool: A tool used for adding text to a
document.

Tools menu: The menu that provided 6 line
weights and 20 tools for creating MacPaint shapes
and pictures.

transparent paint: Paint that blends with and
does not totally block the view of a shape or
pattern that it overlaps.
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A

About MacPaint command (Apple
menu) 102
actual-size inset 63, 124-125
Align Left command (Style
menu) 136
alignment (of text). See Style menu
Align Middle command (Style
menu) 136
Align Right command (Style
menu) 136
angular shapes. See polygon tools
Apple key. See Command key
Apple menu 102
About MacPaint command 102
Calculator 115
Key Caps 78, 115
Note Pad 81, 115
Scrapbook 115
AppleShare 158-159
AppleTalk Personal
Network 158-159
Autogrid. See Turn Grid Off
command; Turn Grid On
command
Autogrid spacing (pixels):
(Preferences command) 76,

128

B

Boldface command (Style
menu) 136

Brush Mirrors command (Goodies
menu) 51, 133
Brush Mirrors dialog box 51, 133

Index

Brush Shape command (Goodies
menu) 50, 132
Brush Shape dialog box 50, 132

C

Calculator (Apple menu) 115

Caps Lock key, shortcuts 149-152

centimeters option (Preferences
command) 77, 127

circles. See oval tools

Clear command (Edit menu) 71,
115

clicking xiv

clip art 156

Clipboard 69, 70, 71, 114, 115

close box 4, 88, 98, 99

Close command (File menu) 88,
106

cloverleaf key. See Command key

Command key xiv

shortcuts 149-152

Command key equivalents 153

commands. See specific command

constraining tools 16, 48

Copy command (Edit menu) 69,
114

crosshairs 54

curved shapes. See freehand shape
tools

Cut command (Edit menu) 69, 114

D

desk accessories 102, 115. See
also Apple menu
desktop 3, 98-102

dialog boxes. See specific dialog
box
digitizers 157
documents
creating 101-102
erasing entire 83
opening 89
printing 93-95
saving 90-92, 101-102
selecting entire 66
dotted line (invisible line weight).
See line weights
double-clicking xiv
shortcuts 149-152
Draft option (Print command) 111
dragging xiv
Draw From Center command
(Goodies menu) 54, 122
Draw From Edge command
(Goodies menu) 54, 122
drawing
with freehand shape
tools 18-19, 56
with line tool 9-10, 53
with oval tools 16, 54
with pencil 9, 61
with polygon tools 20-21, 55
with rectangle tools 14-16, 53
with rounded rectangle tools 16
drop shadow. See Trace Edges
command

E

Edit menu 113-120
Clear command 71, 115
Copy command 69, 114

Index 165



Cut command 69, 114
Fill command 75, 116
Flip Horizontal command 75,
118
Flip Vertical command 75, 119
Invert command 74, 116
Paste command 70, 115
Revert To Snapshot
command 84, 120
Rotate command 75, 120
Trace Edges command 74, 117
Undo command 9, 82, 113
Edit Pattern command (Goodies
menu) 59, 60, 131
Edit Pattern dialog box 59, 60,
131
800-percent view. See Zoom In
command; Zoom Out
command
enlargement. See Scale Selection
command; Zoom In command,
Zoom Out command
Erased option (Preferences
command) 128, 129
eraser 5, 13-14, 82-83, 85, 100,
138, 145
shortcuts 151
exercises 32-43

F

Faster Bitmap Printing option (Page
Setup command) 111
features, new xv—xvii
S0-percent view. See Zoom In
command; Zoom Out
command
File menu 103-112
Close command 88, 106
New command 8, 86, 101, 103
Open command 4, 89, 101,
104-105
Page Setup command 93, 111
Print command 94, 95, 111
Print Selection command 94,
112
Quit command 112
Revert To Saved command 85,
109
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Save As command 90, 91, 92,
108-109
Save command 90, 99, 106-107
Take Snapshot command 8, 13,
84, 110
Throw Away Snapshot
command 84, 110
file server. See AppleShare
Fill command (Edit menu) 75, 116
filled freehand shapes. See
freehand shape tools
filled ovals. See oval tools
filled polygons. See polygon tools
filled rectangles/squares. See
rectangle tools; rounded
rectangle tools
Flip Horizontal command (Edit
menu) 75, 118
Flip Vertical command (Edit
menu) 75, 119
folders, opening 104-105
Font/DA Mover 102
Font menu 79, 135
fonts. See Font menu; Style menu
400-percent view. See Zoom In
command; Zoom Out
command
freehand shape tools 52, 100, 138,
147
drawing with 18-19, 56

G

Goodies menu 121-134

Brush Mirrors command 51, 133

Brush Shape command 50, 132

Draw From Center command 54,
122

Draw From Edge command 54,
122

Edit Pattern command 59, 60,
131

Hide Actual Size command 63,
125

Hide Mouse Position
command 77, 122-123

Preferences command 7, 76,
77, 80, 127-130

Scale Selection command 29,
72, 134

Shortcuts command 95, 126
Show Actual Size command 63,
125
Show Mouse Position
command 77, 122-123
Turn Grid Off command 76, 121
Turn Grid On command 76, 121
windows and 86, 134
Zoom In command 62, 123-125
Zoom Out command 63,
123-125
grabber 17, 88, 100, 138, 141
shortcuts 152
grid. See Turn Grid Off command;
Turn Grid On command

H

hardware requirements xiv

help. See Shortcuts command

Hide Actual Size command
(Goodies menu) 63, 125

Hide Mouse Position command
(Goodies menu) 77, 122-123

hollow freehand shapes. See
freehand shape tools

hollow ovals. See oval tools

hollow polygons. See polygon tools

hollow rectangles/squares. See
rectangle tools; rounded
rectangle tools

horizontal line weight. See line
weights

1, J

I-beam pointer. See text tool

icons 3. See also specific icon

ImageWriter 93, 111

inches option (Preferences
command) 77, 127

Invert command (Edit menu) 74,
116

Inverted option (Preferences
command) 80, 130

Invert Pattern First option
(Preferences command) 128,
129

invisible line weight. See line
weights



irregular shapes. See freehand
shape tools
Italic command (Style menu) 136

K

keyboard equivalents 153
Key Caps (Apple menu) 78, 115

L

Landscape document icon 3
Larger Print Area option (Page
Setup command) 111
large-screen monitors 5
LaserWriter 93, 111
lasso 26-27, 64-69, 71, 74, 100,
138, 141
shortcuts 152
leading (of text). See Style menu
leaks (in shapes). See paint bucket
line tool 100, 138, 142
drawing with 9-10, 53
patterns and 59
shortcuts 150
line weight indicator box. See line
weights
line weights 24-25, 56, 100, 138,
139

M

Macintosh 512K, Take Snapshot
command and 8

MacPaint disk icon 3

MacPaint option (Save As
command) 108

magic eraser. See eraser

magnification. See Zoom In
command; Zoom Out
command

Measurements shown in:
(Preferences command) 127

Memorize menu positions
(Preferences command) 128

menu bar 4, 98, 99

menus/menu commands. See
specific menu/menu command

mirror images. See Brush Mirrors
command

monitors, large-screen 5
mouse position inset 77, 122-123

N

network. See AppleTalk Personal
Network

New command (File menu) 8, 86,
101, 103

new features xv-xvii

New windows: (Preferences
command) 128

Normal option (Preferences
command) 80, 130

Note Pad (Apple menu) 81, 115

(@)

100-percent view. See Zoom In
command; Zoom Out
command

Opaque option (Preferences
command) 128, 129

Open command (File menu) 4, 89,
101, 104-105

Open dialog box 104

Option-Command pattern effect:
(Preferences
command) 128-130

Option key, shortcuts 149-152

options (preset) 101

Options dialog box 111

Outline command (Style
menu) 136

oval tools 5, 14, 52, 100, 138,
146-147

drawing with 16, 54
shortcuts 149

Overlay option (Preferences

command) 80, 130

P

Page Setup command (File
menu) 93, 111
Page Setup dialog box 93, 111
paintbrush 100, 138, 143
painting with 11-12, 49-50
shortcuts 149
paint bucket 100, 138, 142

painting with 22-23, 58
shortcuts 149
painting 49-51
with paintbrush 11-12, 49-50
with paint bucket 22-23, 58
with spray can 12, 50
paint modes. See Erased option;
Opaque option; Reversed
option; Transparent option
Paste command (Edit menu) 70,
115
Patterns menu 6-7, 11-12,
47-48, 49-51, 57-60, 98,
100-101, 137
shortcuts 149-152
pencil 5, 100, 138, 143-144
drawing with 9, 61
shortcuts 150
pixels (defined) 61
pixels option (Preferences
command) 77, 127
Plain command (Style menu) 136
polygon tools 52, 100, 138, 148
drawing with 20-21, 55
shortcuts 150
Precision Bitmap Alignment option
(Page Setup command) 111
Preferences command (Goodies
menu) 7, 76, 77, 80, 127-130
Preferences dialog box 80,
127-130
preset options 101
Print command (File menu) 94,
95, 111
Print dialog box 94, 111
Print Selection command (File
menu) 94, 112

Q

Quit command (File menu) 112

R

rectangle tools 14, 52, 100, 138,
145-146
drawing with 14-16, 53
shortcuts 149

Index 167



reduction. See Scale Selection
command; Zoom In command;
Zoom Out command
requirements Xiv
resizing. See Scale Selection
command
Reversed option (Preferences
command) 128, 129
Revert To Saved command (File
menu) 85, 109
Revert To Snapshot command (Edit
menu) 84, 120
Rotate command (Edit menu) 75,
120
rounded rectangle tools 14, 52,
100, 138, 145-146
drawing with 16
shortcuts 149

]

Save As command (File menu) 90,
91, 92, 108-109
Save As dialog box 90, 91, 108
Save command (File menu) 90,
99, 106-107
Save dialog box 107
Scale Selection command (Goodies
menu) 29, 72, 134
Scale Selection dialog box 29, 72,
134
scanners 157
Scrapbook (Apple menu) 115
screen dumps 157
scroll arrows 87
scroll bars 4, 87, 98, 99
scroll boxes 87
scrolling 87, 88
selection box 28
selection rectangle 26, 28-29,
64-69, 71-75, 100, 138, 140
shortcuts 151
selections 64-75
clearing 71
copying 69
cutting 69
duplicating 67
filling 75
fitting 71
flipping 75

168 Index

inverting 74
moving 66
multiple copies of 68
pasting 70
resizing (change proportions) 73
resizing (keep proportions) 72
rotating 75
tracing edges of 74
Shadow command (Style
menu) 136
shape (of brushes). See Brush
Shape command
shapes. See specific shape
Shift-double-clicking,
shortcuts 149-152
Shift key, shortcuts 149-152
shortcuts 149-153
Shortcuts command (Goodies
menu) 95, 126
Show Actual Size command
(Goodies menu) 63, 125
Show Mouse Position command
(Goodies menu) 77, 122-123
size (of text). See Style menu
size box 98, 99
Smoothing option (Page Setup
command) 111
snapshots. See Revert To Snapshot
command; Take Snapshot
command; Throw Away
Snapshot command
spray can 100, 138, 143
painting with 12, 50
shortcuts 149
squares. See rectangle tools;
rounded rectangle tools
starting 3-7
Startup screen option (Save As
command) 92, 108, 109
startup screens, saving 92, 109
stationery 101
opening 105
saving 91, 108
Stationery option (Save As
command) 91, 108
straight lines. See line tool
style (of text). See Style menu
Style menu 79, 80, 135-136
Align Left command 136
Align Middle command 136

Align Right command 136
Bold command 136

Italic command 136
Outline command 136
Plain command 136
Shadow command 136
Underline command 136

T

Tab key, shortcuts 149-152
Take Snapshot command (File
menu) 13, 84, 110
Macintosh 512K and 8
text. See Font menu; Style menu;
text tool
Text mode is: (Preferences
command) 130
text modes. See Inverted option;
Normal option; Overlay option
text tool 30-31, 78-81, 100, 138,
144
shortcuts 152
Throw Away Snapshot command
(File menu) 84, 110
title bar 4, 98, 99
tools, constraining 16, 48
Tools menu 5-6, 47-48, 98,
100-101, 138-148. See also
specific tool
shortcuts 149-152
Trace Edges command (Edit
menu) 74, 117
Transparent option (Preferences
command) 128, 129
transparent patterns 49
Turn Grid Off command (Goodies
menu) 76, 121
Turn Grid On command (Goodies
menu) 76, 121
200-percent view. See Zoom In
command; Zoom Out
command

U

Underline command (Style
menu) 136

Undo command (Edit menu) 9, 82,
113



units of measure. See Autogrid
spacing (pixels):

Use auto window sizing option
(Preferences command) 128

Use current window size option
(Preferences command) 128

\'

vertical line weight. See line weights
video digitizers 157

W, X, Y

weight (of lines). See line weights
windows 86-88

closing 88

erasing entire 83

Goodies menu and 86, 134

opening 86

scrolling 87, 88

selecting entire 65

Z

zoom box 4, 98, 99

Zoom In command (Goodies
menu) 62, 123-125

zoom level 99, 123. See also
Zoom In command; Zoom Out
comrmand

Zoom Out command (Goodies
menu) 63, 123-125

Index
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Tuck end flap inside back

cover when using manual.
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