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Introduction 
How the manual is laid 
out and how to gain the 
most benefit from it. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This is an example of what an 
important note will look like.  
These will call attention to 
special circumstances or 
potential problem areas, as 
well as providing useful tips. 
 
 

Welcome to the ZBrush 2 Practical Manual. 
 
We know that people tend to learn best by doing, and so this 
manual is written to give you an introduction to ZBrush 2’s 
features in a tutorial-based format.  A series of brief projects will 
introduce you to the ZBrush interface, as well as how to perform 
the most common tasks.  This manual is also supported by the 
many forms of help that are built directly into ZBrush. 
 
Careful attention has been given to accommodate a variety of 
learning styles and objectives.  If you are an experimental learner 
who learns best by doing, simply follow the steps in bold text. 
 

� Reading just the bold sentences will allow you to 
proceed through the steps of a tutorial. 

 
Directions to interface items will often be given as a path, from 
the highest-level element to the lowest.  For example, 
Tool>Deformations>Smart ReSym would lead you to the Smart 
ReSym button, which is located in the Deformations menu within 
the Tool palette. 
 
After completing each tutorial, you will then have enough 
information to begin exploration in that area on your own. 
 
To accommodate people who learn best through reading, each 
bold step is followed by supplemental information.  Here we will 
explain why the particular step was taken, as well as other 
options that might be available.  This text is meant to give you a 
comprehensive understanding not just how to do things in ZBrush, 
but why. 
 
People who learn best by lectures are also taken care of.  Many of 
the tutorials are complemented by ZScripts.  In these cases, the 
text will tell you what ZScript to run and where to find it: 
 
Look for sentences such as this one to learn where to find the 
accompanying ZScript. 
 
There are also many places where very important or useful 
information might be mentioned.  These will be found to the left 
of the main text. 
 
While the overall layout of this book builds in complexity, it is not 
essential that you follow the tutorials in any particular order.  
Wherever possible, we have provided the work files for previous  
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steps so that you can dive right into an area that strikes your 
interest.  However, if you are new to ZBrush it is highly 
recommended that you do follow the tutorials in the order in 
which they are presented.  Later tutorials assume knowledge that 
is covered in earlier chapters. 
 
Also, it is important to bear in mind that there are usually many 
ways to do accomplish a task.  The techniques taught in the 
tutorials are meant to illustrate specific approaches or features.  
This is necessary in order to ensure a comprehensive 
understanding of ZBrush’s tools.  As you become more familiar 
with the software, you will learn what works best for your 
particular needs and style. 
 
Be sure to visit www.ZBrush.com and www.ZBrushCentral.com for 
additional tutorials and documentation as they are made 
available.  The online help system has been created specifically to 
be expandable, and we will regularly be releasing updates to it. 
 

Macintosh Users 
Wherever possible, this manual has been written to avoid being 
specific to any particular platform.  The exception is in the use of 
certain keyboard combinations.  Wherever this manual refers to 
the Ctrl key, simply use the Cmd key instead. 
 

If you’re upgrading… 
If you have used an earlier version of ZBrush, there are many 
changes to the interface as well as several new tools and 
features.  We will call these areas out with the use of the new Z 
logo to the left of the text.
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Basic Concepts 
This section introduces 
the fundamental 
principles on which 
ZBrush is founded.  New 
users should pay special 
attention to this 
information! 
 

ZBrush 2 represents a fundamental breakthrough in computer 
graphics technology in that it offers features that will enhance 
nearly any artist’s workflow.   
 
Illustrators can use ZBrush as a start-to-finish painting solution.  
The depth-enabled canvas enables you to paint with less emphasis 
on the mechanics of depth and lighting, freeing up more time for 
pure creativity.  The fact that ZBrush uses a 3D rendering engine 
makes it possible to create illustrations that look like they’re 
ready to come right off the page. 
 
Artists working in an animation field such as the game and motion 
picture industries will be attracted to other parts of the ZBrush 
toolset.  ZBrush 2 offers a powerful suite of mesh editing tools, 
the ability to paint textures directly onto the 3D mesh, innovative 
UV mapping techniques (along with support for other mapping), 
optimization to work with millions of polygons in real time for 
ultra high-resolution sculpting, and the ability to create 
displacement or normal maps for use in a rendering engine that 
supports them. 
 
Regardless of what area of computer graphics you work in and 
whether you are a professional or a hobbyist, in the end it’s all 
about speed.  The faster you can work, the more productive you 
can be, and the more freedom you will have to experiment.  
ZBrush 2 offers the power to deliver that speed. 
 
ZBrush has been highly optimized to make real time rendering 
possible even with extremely dense mesh resolutions or the most 
complicated of scenes.  At the heart of ZBrush’s methodology lies 
the “pixol.” 

The Concept of the Pixol 
Most art software uses the pixel as its basic building block.  These 
pixels each contain information about their X and Y positions, as 
well as their RGB (Red, Green and Blue) color values.  ZBrush 
takes this a step farther by adding depth, orientation and 
material to the equation – thus producing a smart pixel, which we 
call the “pixol.”  These pixols are saved with your document so 
that when you open the scene back up again the depth is still 
present.  Exporting an image, however, finally flattens the pixols 
and turns them back into pixels so that other software can read 
the image. 
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Polygons can become pixols, 
but pixols cannot normally be 
converted to polygons.  The 
exception to this rule is when 
you are using Projection Master, 
which allows you to sculpt a 
high-resolution model by 
painting displacements onto it. 

Most of ZBrush’s painting tools are designed to add pixols to the 
canvas.  A few are only capable of altering pixols that are already 
present.  You can also turn the addition of depth on or off, 
sometimes painting with depth and sometimes without.  As you 
might imagine, pixols enable a lot of power when you’re painting! 
 
3D objects are a little bit different.  They begin life as polygons – 
small planes formed by interconnected points.  Usually, there are 
relatively few polygons which are then smoothed by the rendering 
engine to make the model look like it has more than are really 
present.  While a model is in a polygonal state, you can sculpt it 
in 3D to change its shape and add details.  When you actually 
incorporate the model into your scene, though, it becomes 
“snapshot” to the canvas.  At this point, ZBrush converts the 
model from polygons to pixols and in the process culls anything 
that is not visible to the camera.  Since non-visible information is 
discarded, ZBrush resources are free to be devoted to the next 3D 
object that you wish to work with.  This is a critical concept to 
understand!  Only one object is allowed to be fully 3D at a time.  
This means that no matter how complex your scene becomes, you 
are still able to work with the next model in real time. 
 
Even though a model is snapshot to the canvas, it is not actually 
lost as a polygonal object.  What is snapshot is in reality an 
instance of the model.  The original remains in the Tool palette 
and can be drawn again on the canvas.  It can then continue to be 
edited until you snapshot it again. 
 
Another time that this distinction between polygons and pixols is 
important is when you are saving your work.  Saving the document 
saves the pixols that are currently on the canvas.  It does not save 
any custom items in any of the palettes, such as models.  If you 
have a 3D object on the canvas and are editing it, saving the 
document will actually save a snapshot of the model rather than 
the model itself.  Each palette that can hold custom items has its 
own inventory controls.  So if you wish to save your model as 
polygons it must be saved from the Tool palette. 
 

In Conclusion 
ZBrush 2 offers a unique and powerful blend of 2D painting with 
3D sculpting, texturing and rendering.  The program is highly 
optimized to allow tremendous levels of detail, both in terms of 
extremely high polygon counts for your models and also for your 
finished scenes.
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The ZBrush 2 
Interface 
The key to getting the 
most out of ZBrush is to 
be able to get around the 
interface quickly and 
easily.  ZBrush 2 has 
introduced many 
enhancements to be more 
intuitive and faster than 
ever to use.  It is well 
worth taking the time to 
explore this chapter 
before proceeding to the 
other tutorials. 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
In its standard configuration, the ZBrush window is mostly taken 
up by the canvas.  This area is where you will do your painting 
and modeling.  Immediately below the canvas is the ZScript area, 
where ZScripts load unless they are designed to embed their 
components within the interface.  Completely surrounding the 
canvas and ZScript window is the Shelf.  This provides a handy 
space to keep the most commonly used interface items. 
 

� To hide the Shelf, press the Tab key on your keyboard.  
Pressing the Tab key again will bring it back. 

 
By hiding the Shelf, you are able to reclaim almost the entire 
interface for your canvas, providing a great amount of room to 
work in.  The Shelf, like much of the rest of the interface, can be 
customized to suit your needs.  We will deal with this in detail in 
a later section. 
 
Beneath the title bar, there is a row of words that spans the top 
of the screen.  This is the Palette List. 
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� Move your pointer over one of the palette names to open 
the palette. 

 

 
 
All of ZBrush’s functions are contained within palettes.  Each 
palette contains a group of related functions.  Within the palette, 
these functions are further broken down into groups in order to 
help make it easier to locate the particular control that you need. 
 
Buttons are shown as a light gray raised object.  Pressing a button 
causes something to happen. 
 
Switches are interface items that can be turned on and off.  
When off, the switch is shown as dark gray.  When on, it is 
orange. 
 
Sliders allow you to set a ranged value.  They show the current 
setting as a number next to the slider’s title, and also show where 
it fits within the range by a small indicator at the bottom of the 
slider.  The minimum value is to the left, and the maximum value 
is to the right. 
 

� In the Render palette, click in the 3D Shading slider and 
drag to the left to set a value of 50. 

 
The slider value will update as you move the slider.   
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� Click the 3D Shading slider and type 100. 

 
You can also set a slider value without dragging simply by clicking 
in it and then typing the value that you want. 
 

� Also in the Render palette, click the word “Antialiasing”. 
 
 

 
 
In order to further help with organization, many palettes contain 
menus, also known as sub-palettes.  These menus contain controls 
that are all related to a specific task within the palette’s more 
generalized categorization. 
 
Clicking on a menu’s name will expand or collapse it. 
 

� Open all of the menus within the Render palette.  Move 
the pointer into any blank space within the palette.  When 
it changes to up-and-down arrows, click and drag up. 

 

 
 
Depending on your system’s display settings, palettes can 
sometimes get to be so long that they go off the bottom of the 
screen.  By dragging within empty space in the palette, you can 
slide its contents to reveal the hidden items. 
 

� Move your pointer off of the palette to close it. 
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Palettes only remain open as long as you keep the pointer over 
them.  In most cases clicking on an element within the palette 
will not close the palette.  This allows you to change several 
settings without having to constantly pull the palette down again.  
However, there are times when modifying a setting causes the 
palette to close.  This happens when you are using the Best 
Renderer and the change that you made requires ZBrush to render 
the scene again and is meant to allow you to see the effects of 
your changes without the palette getting in the way. 
 

� Move your cursor over any interface item and watch the 
area beneath the palette list. 
�  

 
 
The area between the palette list and the top part of the Shelf is 
called the Note Bar.  This area is meant to provide helpful 
feedback while you work. 
 
In most cases, the note bar will show you the name of the current 
interface item.  Other times, it will provide helpful suggestions 
for what to do next.  Also, when ZBrush is performing a complex 
action such as a best-quality render, the note bar will provide 
several kinds of feedback at once.  In the example shown above, 
it informs us of the type of action being performed, how long it 
has spent on that action already, how long it estimates will be 
required to complete the action, and finally an orange bar 
showing a graphical representation of its progress. 
 

In Conclusion 
You should now have a good understanding of where to find the 
major interface components, and a broad feel for how the 
palettes work.  You will get more practice working with palettes 
as we proceed through the following sections. 



ZBrush 2 Practical Guide                                                                         More with Palettes 17 

 

More With Palettes 
Now that the basics of 
working with palettes 
have been covered, we 
proceed to more advanced 
operations to make your 
work easier. 

 
 
ZBrush provides many ways to make your workflow easier.  When 
working with palettes, you will normally find that they are more 
convenient as pull-down menus.  However, there will also be 
times when you need to repeatedly return to a particular palette.  
For example, if you are sculpting a model, you might find that you 
return to the Tool palette frequently.  ZBrush accommodates this 
need by providing Trays on the left and right sides of the 
interface.  These trays are used to keep palettes open 
continuously. 
 

� To open a tray, click along its outside edge.  To help you 
find the right spot, there is a pair of arrows at the vertical 
center of the interface. 
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Clicking this separator will expand the tray.  In the default 
configuration, both trays are empty.  This allows you to use them 
however you see fit. 
 

� To move a palette to the tray, open it and look in the 
upper left corner.  Click on the orange circular icon. 

 

 
 
This orange icon is called the palette’s handle.  Clicking on it now 
moves the palette to the top of the open tray.  It will now stay 
open while you continue to work on the canvas. 
 
Each palette has a preferred tray.  If neither tray is open, clicking 
on the handle will open the preferred tray and move the palette 
there automatically.  If both trays are open, the palette will 
automatically go to the top of its preferred tray. 
 
You can also drag the handle to move the palette where you want 
it.  This is handy when you have both trays open and want to put 
the palette in its non-preferred tray, or if you wish it to be below 
other palettes that are already in the tray.  
 
When a palette is in a tray, its appearance changes slightly.  Its 
icon appears to the left of the palette’s name and the handle  
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 moves to the right.  Next to the handle, there is also now a small 
icon with a triangle in it.  Clicking the icon will toggle between 
the palette’s basic and advanced states.  If you would like to 
simplify the palette so that only its most basic features are 
available, click this icon. 
 
A palette that is in the tray can be expanded and collapsed by 
clicking on its title.  This conserves room when several palettes 
are in a tray. 
 
When several palettes are in a tray, it is not uncommon for them 
to scroll off of the screen.  To bring items back into view, simply 
click in any empty space within the palette and drag up or down. 
 
A palette can only exist in one place at a time.  If you have a 
palette in the tray, you can still access it as a pull-down menu 
from the palette list.  If you do this, it will temporarily disappear 
from the tray and will reappear once its pull-down counterpart 
closes. 
 

� To collapse a tray, click its separator bar. 
 
Doing this leaves the palette in the tray.  It will still be waiting 
for you if you expand the tray again. 
 

� To remove a palette from the tray, click its handle. 
 
You can also use the handle to move a palette from one location 
to another within the tray. 
 

� In the Tool palette, click the large thumbnail. 
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 � In the popup menu, select the Sphere3D. 
 

 
 
We have now changed the active tool from the Simple Brush to 
the Sphere3D.  
 
Several palettes use this thumbnail system to select from.  For 
your convenience, their large thumbnails are also located on the 
left side of the shelf. 
 
Once an item has been selected the first time using the large 
thumbnail, a small thumbnail of it is added to the palette next to 
the large thumbnail.  These small thumbnails provide shortcuts to 
recently used items.  You can reselect that item by clicking on its 
small thumbnail rather than going through the popup menu.  The 
active item will always be highlighted with a teal background and 
a small triangle in its lower right corner.   
 
Double-clicking on a small thumbnail will allow you to replace it 
with a different item from the popup menu.   
 
As more items are selected, more small thumbnails will appear.  
To restore the palette to its starting number of small thumbnails, 
click the R button just above all the thumbnails to the right. 
 

In Conclusion 
We have now covered several additional features of the palette 
system.  You now know how to select items using the thumbnails, 
as well as how to capitalize on the trays to keep palettes open 
when the pull-down version would be an inconvenience.
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Getting Around the 
Canvas 
ZBrush 2 provides 
convenient ways to 
change your view of the 
canvas.  There are also 
controls to change your 
view of objects while 
editing them. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
In order to accommodate ZBrush’s 2D functionality, the camera 
system operates much like a paint program with the ability to pan 
across the canvas and zoom in for a closer look.  You can use the 
icons in the tray to accomplish this, or you can use keyboard 
shortcuts. 
 

� Press Document>Open and then browse to the document 
titled Chapter1-3.zbr. 

 
The document that loads is very large, with a few objects on it.  
We’ll now look at several ways to move around the document. 
 

� On the right shelf, place your pointer over the Scroll 
button.  When it changes to the four-way arrow, click and 
drag. 
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 As you drag, you’ll be able to move the canvas around.  When you 
release the mouse button, the movement stops.   
 
Like with a paint program, the camera is restricted to movement 
along the XY plane. 
 
Rather than using the Scroll button, you can hold down the 
spacebar.  The pointer will change to the four-way movement 
arrow, allowing you to click and drag to move the canvas. 
 

� The next button down is the Zoom button.  Click and 
drag on it to zoom in and out of the canvas. 

 
Zooming the canvas resizes the pixols.  As a result, when you 
enlarge the canvas beyond 100%, it will become pixilated. 
 
Bear in mind that when you zoom the canvas you are not moving 
the camera closer to it.  The camera cannot be moved along the Z 
axis.  Instead, you are changing its focus to show more or less of 
the canvas. 
 
The plus and minus keys (+ and -) on your keyboard will step your 
magnification up or down by 10% increments. 
 

� After zooming into or out of your document, press the 
Actual button to return to 100% magnification. 

 
This immediately sets the zoom level back to its start of 100%.   
 
The keyboard shortcut for this is 0. 
 
While the view is at this level, look closely at the edges of 
objects.  You’ll see that curved edges have a tendency to 
pixelate.  This is because pixols, like pixels, are square.  ZBrush 
provides a way to compensate for this, however. 
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A good rule of thumb is to 
always create your images at 
twice the size that will ultimately 
be exported.  Not only does this 
make it easy to add greater 
detail, but when combined with 
AAHalf mode it ensures that 
your images will always have 
the highest quality edges.

 
� Press the AAHalf button. 

 

 
 
The zoom level of your canvas will change to 50%.  This 
immediately causes all edges to become averaged, which removes 
the jaggies.  However, ZBrush’s AAHalf mode is more than simply 
resizing your image.  If you were to change the zoom level to 50% 
via regular zooming, your exported image would be the full size.  
Using the AAHalf mode allows you to export exactly what you see. 
 
Many artists actually prefer to work in AAHalf mode, and only use 
actual size when they wish to zoom in for greater detail. 
 

Working with 3D Objects 
Now that we have covered how to control the camera and move 
about the canvas, let’s examine how to work with a 3D object 
while it’s being edited.   Since the ZBrush camera operates like a 
paint program, you are provided with ways to rotate, move and 
scale the object itself. 
 

� Press Preferences>Init ZBrush. 
 
This command restores ZBrush to its startup configuration, 
clearing all custom data. 
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 � From the Tool palette, select the Arrow3D object. 
 

 
 
We’ll use this tool since, when drawn, it is very easy to see its 
orientation. 
 

� Click and drag on the canvas to draw the object. 
 
All objects are drawn with their Z axis pointing toward the 
camera. 
 
At this moment right after it has been drawn, the object exists in 
a kind of transitory state.  It has been drawn as pixols, but you 
still have the opportunity to work with the object on a polygonal 
level instead.  You do this by entering Edit mode: 
 

� In the Transform palette, press the Edit Object switch. 
 

 
 
The circles surrounding the pointer will turn red.  This indicates 
that you are in Edit mode, and the object can be sculpted as 
polygons.  At the same time, several more buttons on the shelf to 
the right of the canvas become active.  We’ll cover them in a 
moment. 
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These icons are used to 
manipulate an object while it is 
being edited.

 
� Rotate arrow by clicking on a blank part of the canvas 
and dragging. 

 

 
 
If you hold the Shift key while rotating the object, it will snap to 
90 degree rotations.  Bear in mind that only the object is rotating.  
The camera is not moving. 
 
This form of rotation is the same as using the Rotate icon on the 
shelf. 
 

 
 
Below that icon is the Spin icon.  This icon provides two kinds of 
rotation, depending upon which way you move your mouse after 
clicking on it: 
 

� Click on the icon and drag to the left or right.  The 
object will spin about its Z axis. 

 
� Click on the icon and drag up or down.  The object will 
move in relation to the canvas. 
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 By combining the two forms of rotation, you can easily maneuver 
it to any angle that you desire. 
 

� Click and drag on the Move icon.  The object will move 
around the canvas without rotating. 

 
This movement can be duplicated by holding down the Alt key 
while clicking and dragging on any blank portion of the canvas. 
 

� Click and drag on the Scale icon.  The object will be 
resized larger or smaller. 

 
Scaling the object is NOT the same as zooming into it.  The 
camera does not move.  Remember that when zooming the 
camera, the scene becomes pixilated as you zoom into it.  When 
scaling the object, it is redrawn at the new size and so no 
pixilation occurs.  This is an important distinction. 
 
There is a keyboard shortcut for scaling, as well.  Hold the Alt key 
and click on a blank part of the canvas.  Now, without releasing 
the mouse button release the Alt key.  When you then drag up and 
down, the object will be scaled. 
 
By default, all rotations are performed around the object’s 
geometric center.  There are two ways that you can change the 
pivot point: 
 

� Change the Draw>Draw Size setting to 10. 
 
This changes your cursor to a smaller size, so that you affect a 
smaller area on the model. 
 

� Click anywhere on the model itself. 
 
This causes the model to be edited.  For our illustration, it really 
doesn’t matter what you do; we just want to change a point or 
two. 
 

� Click the Local icon on the right shelf. 
 
This tells ZBrush to use the last edited point as the model’s new 
center of rotation.  Now, when you rotate the model, it will spin 
around the last point that you clicked. 
 
This is extremely useful when you have scaled the model large so 
that you can work on a small part of it.  At that scale, any  
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Local Transform overrides the 
model’s regular pivot point.  This 
holds true even for one that you 
have set yourself.

 
rotation can easily cause the model to spin right off the canvas 
and disappear.  By activating the local transform mode, your 
model will always rotate around the area that you are currently 
working on. 
 

� Hold down the Alt key and click on any blank part of the 
canvas. 

 
This keyboard shortcut immediately scales the model to fit the 
canvas, and centers it on the canvas.  This works even if the 
model has been moved or rotated out of sight! 
 

� Now that the model fills the canvas, rotate it so that it 
points straight up.   

 
� Hold down Ctrl+Shift, then drag from above the model to 
the left to below the arrow’s point on the right.  The green 
selection box should fully cover the point.  When it does, 
release the mouse button. 

 

 
 
The polygons that are not completely encompassed by the 
selection rectangle will become invisible.  
 

� Press S.Pivot on the shelf to the right of the canvas. 
 

� Turn off Local. 
 

� Rotate the model. 
 
The S.Pivot button resets the model’s pivot point to be the center 
of the currently-visible polygons. 
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 � To make the model fully visible again, hold Ctrl+Shift and 
click on any blank part of the canvas. 

 
Even though the model’s visibility is restored, the new pivot paint 
remains active.  
 

� Click the C.Pivot button to clear the new pivot point. 
 
The model’s pivot point returns to being the geometric center of 
the object. 
 

In Conclusion 
In this section, we have covered several ways to get around the 
canvas, as well as how to control your view of a model while it is 
being edited.  It will help you to always remember that ZBrush’s 
camera system is that of a paint program.  ZBrush provides many 
ways to help with your work.  The AAHalf mode provides a sure-
fire way to get crisp edges in your work.  The ability to change a 
model’s pivot point helps you keep an area of interest centered 
on the canvas. 
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The Gyro 
In the previous section, 
we looked at how to 
rotate your view of a 3D 
object while it’s in a 
polygonal state.  In this 
section, we’ll work with 
the options that are 
available as pixols. 

 
 
ZBrush provides an extremely useful tool for any time you wish to 
change something that you have just painted on the canvas.  It is 
called the gyro because of how it looks somewhat like a 
gyroscope.  In this tutorial, we’ll show several ways to use the 
gyro. 
 

� Choose Document>New Document to begin with a fresh 
scene. 

 
� Create a torus by clicking the Tool thumbnail on the 
shelf and selecting the Ring3D from the popup menu. 

 
You can also select any color and material that you would like to 
use. 
 

� Draw the ring on the canvas.  Make it pretty large, 
occupying most of the screen. 
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 � Now select the Cone3D object.  Draw it in the center of 
the ring, but not too large. 

 

 
 

� In the Transform palette, click the Move button.  This 
will activate the gyro, in move mode. 

 

 
 
You will now see the gyro surrounding the center of your cone.  
Activating the gyro always affects the last stroke that you made 
on the canvas; an object can only be transformed immediately 
after it has been drawn, before you do anything else (including 
selecting another tool). 
 

 
 
The gyro is made up of four different-colored rings.  (In the 
example above, the gray and blue rings are currently occupying 
the same plane.)  There are also differently-colored sections 
wherever the rings intersect. 
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 Different things can happen, depending upon how you manipulate 
the gyro, and which mode you are currently in (Move, Scale or 
Rotate).  We will cover each of these in turn. 
 

� Click inside the gyro (but not on any of the rings) and 
drag to the right until your pointer moves over the torus. 

 

 
 
Dragging inside the gyro moves the object across the canvas.  
However, it continuously orients the object to the pixol that is 
immediately below its geometric center.  As a result, when you 
drag the cone across the torus, its orientation changes so that it’s 
always pointing away from the surface below. 
 
Stop dragging when you have something similar to the image 
above.  You can now see that the gray and blue rings have found 
their own planes, and all four rings that make up the gyro are 
clearly visible.  
 

� Click and drag on the gray ring.  The cone will move 
across the XY plane without changing orientation. 

 
The gray ring allows you to move the object without changing its 
depth, which can easily be seen by moving the cone through the 
torus.  The direction that the cone is pointing also will not 
change.  In fact, when using Move the only thing that will change 
the orientation of the object is clicking inside the gyro. 
 

� Now click on any of the colored rings (but not an 
intersection) and drag. 

 
Clicking on a ring constrains your movement to the invisible plane 
that the ring rests upon.  The example below shows these 
imaginary planes so that you can more clearly see what we mean: 
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� Click on one of the differently-colored intersections and 
push toward the center of the gyro. 

 
The intersections restrict movement even further.  The object 
will now move in a straight line that goes through the intersection 
that you’re clicking on, the center of the object, and then back 
out the matching intersection on the other side of the gyro. 
 

� Once again, click inside the gyro and move the object so 
that it is over the torus. 

 
Notice that when you drag inside the gyro, the object once again 
immediately snaps back to the pixols on the canvas regardless of 
what depth it is currently at.  This is a fast way to undo your 
movements, restoring the object to a freshly-drawn position. 
 

� Click outside the gyro and drag up or down. 
 
While the gray ring allows you to move the object across the 
canvas, there isn’t a ring for depth.  That’s because such a ring 
would be edge-on toward the camera, and impossible to select.  
Instead, you can move the object along the Z axis by clicking and 
dragging outside the gyro.  Up movement will push the object 
deeper into the canvas and down movement will pull it out 
toward the camera. 
 
If you move the object too deep, it will vanish.  ZBrush’s 
maximum depth is a function of the canvas size.  The maximum 
depth is referred to as the clipping plane, since anything behind 
it is “clipped” and disappears. 
 



ZBrush 2 Practical Guide                                                                                                                            The Gyro 33 

 

 
 
 
Since the Transform palette is 
used to modify anything that has 
just been drawn on the canvas, 
several of its functions are used 
constantly.  For your 
convenience, these have been 
placed on the shelf for you. 

Now that we have examined the various functions of the gyro in 
Move mode, let’s take a look at how it behaves with Scale and 
Rotate. 
 

� On the top shelf, activate the Scale switch. 
 

 
 
The gyro will not appear to change at all, but its effects will 
change dramatically. 
 

� Click anywhere around or in (but not on) the gyro and 
drag. 

 
The entire object will be scaled larger or smaller, depending upon 
the direction of drag.  If you drag toward the center of the gyro, 
the object will be scaled smaller.  If you drag away from the 
center, the object will be scaled larger. 
 

� Click and drag on one of the colored rings. 
 
The object will now scale larger along the two axes that the ring 
rests upon.  The third axis will not be affected.  This flattens the 
object our along the plane that the ring lies upon. 
 
The gray ring has no effect when in Scale mode. 
 

� Click and drag on one of the intersections. 
 
This scales the object, but only along one axis. 
 
In short: 
 
Dragging on an intersection scales the object in one direction. 
 
Dragging on a ring scales the object in two directions. 
 
Dragging anywhere else scales the object in all directions. 
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The QWERT keys on your 
keyboard correspond to the 
transform modes as they are 
laid out in the palette.  Q 
switches to Draw mode, W to 
Move, E to Scale, and R to 
Rotate.  T switches into Edit 
mode. 

� Press the R key on your keyboard to switch to Rotate 
mode. 

 
Once again, the gyro does not change in appearance, but changes 
radically in function. 
 

� Click inside the gyro and drag in any direction. 
 
This tumbles the object, just the same as if you were in Edit 
mode and rotating it.  To snap the rotation to the closest 90 
degree increment, hold down the Shift key while rotating. 
 

� Click on any ring and drag. 
 
This rotates the object around a single axis. 
 
The intersections have no effect when in Rotate mode. 
 

� Click outside the gyro and drag up or down to move the 
object along the Z axis. 

 
This is exactly as if you were in Move mode.  
 

� Place the Transform palette in either tray and open the 
Info menu.  Use the gyro in any mode and see the results in 
the Info sliders. 

 
The Info sliders correspond to the X, Y and Z axis for the current 
transform mode.  If Move is active, they show the current position 
of the object.  If Scale is active, they show its size and if Rotate is 
active they show its orientation. 
 
Like with any slider, you can change these values manually.  Doing 
so updates the object on the canvas.  Precise positioning is 
therefore very easy. 
 

In Conclusion 
The gyro makes it easy to precisely place any object, anywhere on 
the canvas.  Remember that only the last item drawn can be 
transformed in this manner.  When a new object is drawn or a 
new tool is selected, the current object becomes fully 
incorporated into the scene and can no longer be modified as a 
discreet object.
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Curves 
ZBrush graphs, also known 
as curves, provide a visual 
way to modify a range of 
values.  Due to their 
versatility, curves are 
found throughout the 
ZBrush interface. 

 
 
A curve in ZBrush is simply a graph showing a range of values.  
They can be found in nearly every part of the ZBrush interface:  
material modifiers, defining the falloff of the sculpting tool, 
defining how fog or depth cue acts throughout a scene, etc.  In 
this tutorial, we’ll work with one of the curves that has been 
introduced in ZBrush 2:  the Alpha Adjust Curve.  As you will see, 
this curve makes it possible to modify the current alpha – and 
with it, your paint brush -- “on the fly.” 
 

� Begin by reinitializing ZBrush.  (Preferences>Init ZBrush) 
 

� For convenience, place the Alpha palette in either tray. 
 
We’ll be adjusting the curve constantly while working through this 
tutorial, so it will be easiest to keep it open rather than having to 
pull it down again each time. 
 

� Click where it says Alpha Adjust. 
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In order to conserve screen real estate, curves are normally 
displayed in a compressed state.  Clicking on the curve opens it 
for editing, simultaneously closing any other curve that might 
already have been open elsewhere in the interface.  Only one 
curve can be open at a time. 
 

 
 
So that we can better see the results of our edits, we’ll draw an 
example of the alpha on the canvas.  Use the thumbnails on the 
left shelf to work faster: 
 

� Select the Simple Brush. 
 

 
 

� Select the DragRectangle stroke type. 
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� Select the Toy Plastic Material. 

 

 
 

� Press Ctrl+F to fill the canvas with the current material 
and color. 

 
� Select another color (such as blue). 

 

 
 

� Also set the Z Intensity (on the top shelf) to 100. 
 

 
 

� Drag a large stroke on the canvas.    
 

 
 
 

� Press W to activate the Move gyro, then position the 
stroke so that it’s pretty well centered on the canvas.   
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ZBrush uses 16 bit grayscales, 
which give a far greater range of 
values than the standard 0-255 
range of an 8 bit image.  When 
exporting a displacement map, it 
is crucial to use the TIFF format, 
which also supports the 16 bit 
range.  
 

While the gyro is active, our changes to the Alpha Adjust Curve 
will also update the example on the canvas.  This is an important 
principle of the gyro: it allows you to make changes to many of 
the components that were used to draw the most recent stroke. 
 
Now we’ll go back to paying attention to the curve: 
 
First, let’s clarify what an alpha is.  An alpha is simply a grayscale 
image.  More precisely, an alpha is an array of pixels, each 
ranging somewhere between white and black. 
 
The Alpha Adjust Curve provides a way to interact with those 
values, which in turn changes the alpha.  The horizontal portion 
of the curve represents the current grayscale values of the image, 
with black on the left and white on the right.  The vertical portion 
determines how those values are output, with black at the bottom 
and white at the top. 

 
 
At this point, the curve simply shows a straight line from the 
lower left corner to the upper right.  That means that any alpha 
values that are black will be output as black (lower left) and any 
values that are white will be output as white (upper right).  
Anything falling in between is also output exactly true to the 
alpha. 
 
Let’s put it to work. 
 
Any point on a curve can be moved.  Right now, the curve is made 
up of only two points.  Since they are the end points, they can 
only be moved vertically.   
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� Move the lower left point to the upper left by clicking on 
it and dragging.  Move the upper right point to the lower 
right. 

 

 
 
What this did is tell ZBrush to output black (left side) as white 
(top) and white (right side) as black (bottom).  In effect, the 
curve has been reversed, and the current alpha has been modified 
along with it.  You can see the changes both in the alpha large 
thumbnail and on the canvas.  
 

� Click the Reset button to restore the alpha to its original 
state. 

 

 
 

� Click any point along the line between the two existing 
points. 

 

 
 
This adds a new point to the curve.   The yellow circle 
surrounding it represents the point’s area of influence on the 
curve. 
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� Drag the new point around to see how the curve is 
adjusted by it, then finish with something like the example 
below. 

 

 
 
As you move the point, watch how it affects the alpha and what 
you’ve drawn on the canvas. 
 

� Now add another point, moving it above and to the left 
of the last one. 

 

 
 
If you move the point too far to the left, you’ll notice that the 
curve can end up shooting way up off the top of the graph.  That’s 
due to the point’s radius.   
 

� To tighten the point, click on the circle surrounding it.  
When it turns orange, drag to resize the circle. 
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 Any point can be modified at any time.  Simply click on it to make 
it the active point, and then adjust its position or radius. 
 

� Now drag the point off the curve and – without releasing 
the mouse – back on again. 

 

 
 
When the point comes back into view, it will be a sharp angle 
instead of a soft curve.  Radius no longer applies, so the circle 
won’t be present.  You’ll also notice that any points adjacent to it 
become “split.”  The line coming out will be a sharp point on the 
side leading toward the angular point, and the line going out the 
other side will still be curved. 
 
To make a point soft again, simply drag it off the curve and back 
on. 
 

� Now click on the point to make sure it’s active, then 
click on it again. 

 

 
 
This zooms in on the point, allowing you to make fine 
adjustments.  To return to a normal view of the entire curve, 
move your mouse anywhere off the graph. 
 

� Remove the sharp point by dragging it off the graph and 
releasing the mouse. 
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 You’ll now be left with the three point curve.  Go ahead and play 
around with the curve a little bit, adding points and moving them 
around.  Watch how it affects the alpha and the canvas.  Make 
sure that you have a few of them before you move on to the next 
step. 
 

� Immediately beneath the curve is a slider called Focal 
Shift.  Drag it to the left and right. 

 

 
 
When you move the slider, watch what happens to the curve.  The 
points on the curve will shift horizontally, but not vertically.  This 
compresses the curve toward one side or the other.   
 
The purpose of this slider is to make it easy to quickly modify the 
curve without the need to move points around.  Even with the 
simplest possible curve (the straight line that we started with), 
the focal shift can dramatically alter the alpha. 
 

� Adjust the Noise slider to .25 
 

 
 
This slider affects the curve without actually changing any points.  
At this low value, you can see on the canvas how the noise was 
added, but the overall shape of the alpha remains essentially the 
same. 
 

� Click Undo a few times. 
 

 
 
As you can see, Undo affects all edits made to the curve.  This 
includes changes to the Focal Shift slider, and also the Noise 
slider.  Redo behaves the same way. 
 

� The remaining controls are for inventory.   
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 You can save a graph to disk for use in another project or for 
sharing with other users.  I say “graph” here because any graph 
can be loaded into any curve, anywhere within the ZBrush 
interface.  If you create one that you really like, save it for later.  
Feel free to experiment, also, with copying graphs and pasting 
them into other places.  One area in which this is extremely 
useful is when you’re working with  materials.  The Material 
palette has many curves, and sometimes it is useful to place the 
same graph into several of them. 
 

� To close the curve, click the Close button at the bottom. 
 

 
 
This helps keep the interface from becoming cluttered.  Of 
course, the curve would also close automatically if you opened 
one somewhere else. 
 

� Now switch to alpha 19. 
 

 
 
Notice how the new alpha is immediately modified by the Alpha 
Adjust Curve.  That curve affects the current alpha, regardless of 
which one is selected.  Also, if you look at the popup menu again, 
you will see that the previous alpha now looks exactly like it did 
when we started.  By default, modifying the Alpha Adjust curve 
does not permanently change any apha. 
 

� To convert the modified curve to a permanent alpha, 
click the Make Modified Alpha button. 

 

 
 
Two things will happen: 
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 First, a new alpha will appear at the end of the thumbnails.  It is 
automatically selected.  The original alpha #19 is now shown in 
the thumbnail list in its unmodified state, and is no longer 
selected.  This new alpha will not remain if you initialize or 
restart ZBrush.  If you want to save it for another session, use the 
Export button at the top of the Alpha palette. 
 
Second, the new alpha is also modified by the same Alpha Adjust 
settings!   
 

� Open the Alpha Adjust curve again and click Reset. 
 
This restores the newly-created alpha to exactly what you saw 
before you clicked the Make Modified Alpha button. 
 

In Conclusion 
This section has shown the many ways that you can modify a 
curve, no matter where that curve may be found within ZBrush.  
The results that can be achieved are nearly limitless, even within 
a single curve.  ZBrush 2’s new curve features and inventory 
controls also make it easy to modify a curve without editing 
points or to reuse a curve that you like. 
 
Lastly, we have looked at a few features that are unique to Alpha 
palette.  Since saving a tool also saves the currently-selected 
alpha, this feature makes it possible to build a library of custom 
paint brushes.
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Customizing 
ZBrush 
Every artist has unique 
tastes, interests, needs 
and ways of working.  
ZBrush accommodates this 
diversity by providing 
many opportunities for 
customization. 
 

 
 
During this section, we’ll go through the various ways that you 
have available to tailor ZBrush to your needs.  In the process, 
we’ll create a custom environment that will automatically load 
every time you launch ZBrush. 
 

� We need to begin by initializing ZBrush. 
 

 
 
If you are starting this section immediately after any of the other 
tutorials, you might have settings that you would not wish to 
keep.  Therefore, it’s best to begin with a fresh slate. 
 

� Open the Preferences>Interface 
menu. 

 
This part of the palette contains many 
settings that govern the overall way that 
the interface appears and behaves. 
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� To learn more about any setting, hold down the Ctrl key 
as you move your pointer over it. 

 

 
 
ZBrush’s online help system is comprehensive.  It’s like having a 
reference manual built directly into the software!  This also brings 
us to the first item in the list:  Popup Info.  Turning this off will 
also disable the online help text.  It is not recommended that you 
do this until you are very familiar with ZBrush! 
 
Most of the settings in this section should be left alone until you 
have become more accustomed to ZBrush and begun to get a feel 
for how it works.  However, there are a few items that can be 
changed even now. 
 

� Turn on Iconized. 
 

 
 
This changes the list of palettes from text to icons.  Some people 
feel that icons are easier to learn with than text, or just like the 
look better.  Try both settings, and decide which you like best. 
 

� Turn off Float Menu. 
 
This is the same as pressing the Tab key.  It hides or unhides the 
shelf along with any custom palettes that you might build over the 
canvas.  If you would like ZBrush to launch with the shelf hidden, 
leave this off.  Otherwise, turn it back on (recommended). 
 

� Turn off Auto Pulldown. 
 
This is a highly personal preference.  Some people find that 
having the palettes open automatically when you mouse over  



ZBrush 2 Practical Guide                                                                                                           Customizing ZBrush 47 

 

their names (or icons) is the fastest and most convenient.  Other 
people prefer that the interface to work more like your operating 
system’s menus, requiring you to click on a palette to open it.  
Set this to suit your own liking. 
 

� PulldownMenuOpacity and DisabledItemsOpacity both 
control the “look” of ZBrush.  Set them however you like. 

 
PulldownMenuOpacity makes the background for each palette 
more or less transparent when it’s pulled down.  At a setting of 0, 
each palette would only consist of the interface items – the 
palette background would be gone.  At 100, the palette would be 
completely opaque. 
 
DisabledItemsOpacity applies to interface items that require 
something else to be active before they become available.  By 
default, ZBrush makes these items nearly invisible, which calls 
more attention to the actions that ARE available at the time.  You 
can change this to anything you prefer, however. 
 

� Open the Icolors menu. 
 
 
This section of the Preferences is for 
controlling the colors of the interface.  
The color patches each correspond to a 
different part of the interface and can 
all be set individually.  
 
Below the color patches are several 
sliders.  These allow you to modify the 
interface as a whole.  Not only does 
this make it faster to update, but it is 
also easy to keep a unified and 
consistent look throughout the 
interface with enough contrast 
between item types to easily tell the 
types of elements apart. 
 

� Adjust the various sliders to 
create a color scheme that you 
like. 
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� When finished, press Apply Adjustments. 
 

 
 
This resets all sliders, with their 0 values now being the new color 
scheme. 
 

� Open the Mem menu. 
 

 
 
This section of the Preferences controls how ZBrush utilizes your 
system’s resources.   
 

� Set Compact Mem to a value near (but not above) the 
amount of RAM that your system has. 

 
ZBrush utilizes its own memory management system, which is 
independent of your operating system’s virtual RAM.  Basically, 
when you exceed the amount of RAM that is indicated by this 
slider (in megabytes), ZBrush will write all extra data to disk.  
When this happens, ZBrush will temporarily pause and you will see 
a “compacting memory” message in the note bar.  When ZBrush 
finishes writing to disk, you can then continue working.   
 
The more RAM that your system has, the higher you can set this 
slider.  In turn, that means that ZBrush doesn’t have to write data 
to disk as often, which enables a more fluid workflow. 
 
If you set this slider above your available RAM, ZBrush would 
never write to disk.  While this might seem like a good thing 
(since virtual memory is slower than RAM), it’s not.  Such a 
setting would limit the scenes that you could create with ZBrush, 
since anything requiring more RAM than your system has available 
would be impossible. 
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Smart workflow can make it 
possible to achieve extremely 
high polygon counts on even 
average systems without unduly 
taxing your system.  The key 
lies in using a lower subdivision 
level when you wish to rotate 
the object, and selectively hiding 
everything except the portion of 
the mesh that you wish to edit. 
 

 
� Increase the Doc Undo and Tool Undo settings. 

 
Document undo negates actions that have been performed on the 
canvas (in pixols).  Tool undo does the same, but on a polygonal 
level (normally when the model is in Edit mode).   
 
The more undo levels you have available, the farther back in time 
you go if you decide that you don’t like something.  New users 
will usually want these settings to be fairly high.  Bear in mind, 
however, that undo levels require memory.  Therefore, the more 
of them you have available, the more often your system will have 
to compact memory. 
 
The last setting here is MaxPolyPerMesh.  Its default setting is 
calculated by ZBrush based upon your system, and is meant to 
ensure smooth interaction with your model.  You can raise this 
value as you become accustomed to working with high resolution 
models, but should never set it to more than twice the default 
value. 
 

� Open the Importexport menu and take a look at the 
settings. 

 

 
 
ZBrush 2 has many settings to streamline its integration with 
other software.  These settings are automatically applied 
whenever a model is imported into or exported form ZBrush.  “i” 
settings are applied on import and “e” settings on export.   
 
Every program has its own world coordinate system.  The first 
cluster of switches are designed to manipulate your model so that 
it corresponds with ZBrush.  If you have a human figure facing the 
camera in your other application, you will want to adjust these 
switches so that the figure faces “down” in the  
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Tool>Preview window (the top of his head would be pointed 
directly toward the camera).  You will also want to set the export 
switches so that the model is returned to your other software 
facing the same direction.  Experimentation will tell you which 
settings are necessary for your software. 
 

 
 
An added benefit to having separate settings for import and 
export is that ZBrush fits into any workflow.  You can import from 
one application and export back to it, or export to a third 
application. 
 
The Unify Scale slider determines how a model is scaled when it is 
imported and exported.  At the default setting of 8, an imported 
model will be 8 times the size of a native ZBrush object.  The 
same factor will be applied in reverse when the model is 
exported. 
 
The final switches all apply to normal maps.  Activating them 
causes ZBrush to output a normal map using different color 
systems.  Experimentation or your rendering engine’s 
documentation will tell you what settings are appropriate for your 
needs. 
 

� For the moment, just leave all of these settings as they 
are. 

 
� Open the Preferences>Draw menu. 
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Most of these settings are for how ZBrush displays polyframes.  
This display option provides a way to see the wireframe of your 
model superimposed over the shaded geometry.  Mesh grouping is 
also shown by default, which is useful for selecting portions of the 
mesh to edit. 
 

 
 
Max Brush Size allows you to increase the Draw>Draw Size setting 
to a very large value.  You can increase it now, or leave it for if 
you ever need it. 
 
Adots tells ZBrush when to switch from a shaded view of the 
model to a wireframe view.  At the default setting, this will 
happen when the model reaches 800 pixols in size (larger than the 
default canvas), and is meant to help ZBrush continue to operate 
in real time.  Faster systems can increase this setting.  Note that 
the wireframe only displays while the mesh is being manipulated.  
As soon as the mouse button is released, the view will return to 
the regular shaded display. 
 

� The Tablet section will only be active for people with a 
connected graphics tablet.  If you do, then use the help text 
to learn more about each setting and adjust it to suit your 
style. 

 
Remember, to view the help text simply hold down the Ctrl key 
and mouse over each item. 
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� Open the Performance menu and take a look at the 
settings. 

 

 
 
These settings are all meant to maximize ZBrush interactivity, 
especially when working with high polygon models. 
 

� If you have a multiprocessor system or a hyperthreading-
capable processor, click the Test Multithreading button. 

 
ZBrush will take a few minutes to perform a test of your system’s 
performance with and without multithreading enabled.  When it 
completes, it will tell you what kind of performance increase (if 
any) you can expect from this feature, and gives a 
recommendation of whether or not to activate it.  If the 
recommendation is positive, you can activate the MultiDraw and 
MultiRender switches. 
 
The other settings should generally be left alone, but you can 
modify them if you feel the need to maximize ZBrush 
performance.  Use the online help system to learn more about 
each. 
 

� Open the Misc section and decide whether or not to use 
ZFolders. 

 

 
 
ZBrush comes with several pre-made folders in its directory for 
various types of content (ZTools, ZMaterials, etc.).  When Use 
ZFolders is active, ZBrush will default to these folders every time  
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you use an inventory command.  For example, pressing Tool>Load 
Tool will always open the ZTools folder.   
 
If this setting is off, ZBrush will instead open the last folder that 
you browsed to.  This is especially useful if you keep your 3D 
content on a different hard drive from your programs, or if you 
are using ZBrush as part of an animation workflow where you are 
modifying content that will be rendered elsewhere. 

More Modifications 

The Shelf 
 

 
 
In addition to the preferences, ZBrush has other ways in which it 
may be customized.  The most obvious of these is the Float Menu, 
of which the shelf is a part.  These instructions will explain how 
to customize the shelf, but bear in mind that you can also place 
elements on the canvas itself should you choose. 
 
Any permanent part of the interface can be added to the shelf.  In 
other words, any elements that are present when ZBrush launches 
or is initialized.  Elements that cannot be added are those which 
only appear after something else has been selected.  Such 
elements quite literally do not exist at any other time, and so  
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cannot be added to the shelf.  Since we started this section by 
initializing ZBrush, we know that everything present in any of the 
palettes right now can be added to the shelf. 
 

� While holding down the Ctrl key, drag any element out of 
any palette.  

 

 
 
A copy of the element will be created, which you can place 
anywhere on the canvas.  For the moment, we’ll leave it 
somewhere on the middle of the canvas. 
 

� Drag from the color selector on the left shelf to any 
empty portion of the shelf below it. 

 
When you drag out of any color box, including the large thumbnail 
from the Color palette, the cursor becomes a picker.  When you 
release the cursor, the color that is beneath the picker will be 
selected.  This is like an eyedropper tool. 
 

� Click on the white tab above the interface element that 
you’ve dragged onto the canvas.  

 
� Click Preferences>Interface>Colorize 

 

 
 
This colors the white tab to match the current color.  Since we 
just set the color to match the shelf, the element now matches it 
as well. 
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� Again holding the Ctrl key, drag a few more elements 
from the interface. 

 

 
 
When you bring one of these new items close to the one you 
already have on the canvas, they will attempt to dock with it.  
This makes it easy to build blocks of elements. 
 
If you hold down the Shift key while dragging, the element will 
still dock, but with a small space between itself and the other 
element(s).  You can use this technique to build groups of related 
items. 
 
You can also change the way the organization of docked elements 
by holding the Ctrl key again and moving them around 
individually. 
 

� Without holding down the Ctrl key, click on the bar 
above the block of elements.  Use this bar to move the 
block around as a group. 

 
When you move close to a part of the shelf, a line will appear 
around that area.  This is meant to make it easy to spot the shelf 
regions.  There are four of them – to each side of the canvas, 
above it, and below the ZScript window at the very bottom of the 
interface.  This fourth area is initially empty. 
 
When anything is placed in any portion of the shelf, it will 
automatically expand to accommodate the new item(s).  There is 
a limit to how much it will expand, but by the time you reached it 
you would be seriously cutting down on the amount of space 
available for the canvas. 
 

� To remove an item from the shelf, hold down the Ctrl 
key and click it. 

 
Using these techniques, the items that you find that you use the 
most will always be able to be within easy reach, and in a method 
of organization that makes the most sense to you.  
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The Trays 
As you’ve already learned, palettes may be placed in the trays, in 
any order that you desire.  These trays may be kept expanded or 
collapsed.  Several modifiers within the Preferences>Interface 
menu control the behavior of palettes when they are in the trays. 
Whatever arrangement you create will be saved with your 
configuration. 
 

Saving the Configuration 
At this point we have covered all of the settings and layout 
features that will be saved with your configuration.  We have also 
made several settings adjustments that are meant to tailor ZBrush 
to your system and personal tastes.  It’s now time to save 
everything so that ZBrush will recall it the next time you start. 
 

� Click the Preferences>Config>Store Config button. 
 

 
 
ZBrush will give you a message that your settings have been saved 
successfully. 
 
The keyboard shortcut for this action is Ctrl+Shift+I. 
 
What you have just saved is called the Custom configuration.  It 
will be loaded every time ZBrush launches.   
 

Layouts 
On the right side of the title bar, you will see several buttons for 
switching between layouts.   
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� Click Standard 
 
This returns you to the same layout that ZBrush shipped with.  
Any colors and special settings within the palettes (such as 
memory management) will not be changed.  In other words, only 
the positions of elements are changed by clicking on any of these 
layout buttons.  Your personal settings will remain unaffected 
regardless of the layout. 
 

� Click on Custom 
 
You are now returned to the custom layout that you just built. 
 

� Click on Z 
 

 
 
This layout is meant for ZScripts that take up a lot of window 
space, such as some of the built-in tutorials or threads that you 
might have downloaded from ZBrushCentral.  In this layout, the 
canvas is tucked away above the ZScript area. 
 

� Click on D 
 
This final layout was created to maximize your canvas space.  The 
ZScript window is collapsed, and the shelf is empty. 
 
You might also like to use this layout as a base for when you build 
more configurations. 
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Additional Configurations 
While the custom configuration is the one that will load 
automatically when ZBrush launches, you are not limited to it.  
The Preferences>Config>Save Ui and Load Ui buttons make it 
possible to create a variety of specialized configurations for 
various purposes. 
 

 
 
For example, you might prefer to have one configuration for 
sculpting, another for texturing, and a third for lighting and 
rendering.  There is no limit to the number of configurations that 
you may create. 
 
Each of these configurations saves the current color settings.  
However, by default, those settings are not loaded.  If you would 
like to load the saved color scheme along with the layout, hold 
down the Shift key when you click the Load Ui button. 
 

The Startup Document 
While the configuration files store many settings, there are many 
others that are not saved.  These additional settings are all an 
integral part of your document (such as the background color or 
lighting setups). 
 
All document-related settings can be saved as part of a startup 
document.  This document will be loaded every time ZBrush 
launches. 
 

� To create a startup document, click Document>Save As 
 

 
 

� Navigate to the ZBrush\Zstartup folder 
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Since ZScripts rely on many of 
these settings, automatic 
ZScript recording is turned off if 
you use a startup document.  
You will need to manually begin 
recording if you wish to record 
your session.  Bear in mind that 
unless you initialize ZBrush 
before beginning recording, you 
would also need to distribute 
your startup document if you 
wish to share the ZScript with 
any other users. 

 
� Save the file as in the ZStartup folder as 
StartupDocument.zbr 

 

 
 
ANY document can be saved as your startup; even one where you 
have already begun painting on the canvas. 
 
Settings that will be recalled by the startup document include: 
 
Canvas size 
Background color and Border color 
Layers 
Lighting 
Render settings 

In Conclusion 
This section has been lengthy, but that is only because ZBrush 
offers MANY ways in which to customize your working 
environment so that it suits your own needs and style.  As you 
become increasingly experienced with ZBrush, you will no doubt 
find many ways in which these customization features can assist 
you.  Since they can all be overwritten at any time, ZBrush will 
also be able to evolve with your skills. 
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Finding Help 
No single manual or other 
source can possibly cover 
every nuance of ZBrush 
and its usage.  To that 
end, there are many 
places that you can look 
to for answers. 
 

 
 
ZBrush help is available from several online sources, and has also 
been built directly into the software.  We’ll take just a few 
minutes to introduce you to the best places to find more 
information as you need it. 

Autonotes 
 

� To learn more about any ZBrush feature, place the 
pointer over it and press the Ctrl key. 

 

 
 
A popup window will appear near the pointer, containing detailed 
information about that item and its usage.  This is like having an 
entire reference manual built directly into the software.   

The ? Button 
 

� For the most comprehensive online help, click the 
question mark near the right end of the title bar. 

 
When this button is active, ZBrush will automatically display 
detailed text as you work.  In many ways, this is as if you’re 
working with the Ctrl key pressed.  However, there are also times  
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 (such as mousing over a palette) when information will be 
displayed that is not shown by the autonotes. 
 

The Help Button 
 

� In the Title bar, click the Help button. 
 

 
 
ZBrush 2 includes a comprehensive library of online help topics.  
This help browser includes sections on nearly everything that you 
could wish to do in ZBrush, whether it be painting, modeling, 
texturing or rendering.  Many topics also include tutorial ZScripts, 
along with links to associated topics. 
 
There are also sections for Frequently-Asked Questions and ZBrush 
Essentials, along with links on the main page to ZBrushCentral and 
the Pixologic website. 
 
Updates to this help system will be made available for download 
at various times in the future.  Watch www.ZBrushCentral.com for 
when they are announced. 

ZBrushCentral 
 

� On the Help Topics main page, click Visit 
ZBrushCentral.com. 

 
This button launches your web browser and takes you to 
www.ZBrushCentral.com.  The official online ZBrush community,  

http://www.zbrushcentral.com
http://www.zbrushcentral.com
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ZBC provides a forum in which to interact with other ZBrush users 
from around the world. 
 
The F.A.Q. Forum provides answers to many of the most 
frequently asked questions about ZBrush. 
 
The QuickLinks (accessed from the F.A.Q. Forum or the top right 
corner of every page at ZBC) contains many of the most pertinent 
topics concerning ZBrush usage.  There are also a great many 
tutorials that have been created by other ZBrush users or by 
Pixologic. 
 

Pixologic 
 

� Click Zplugin>Web Access>Go to ZBrush.com 
 

 
 
The Web Access ZPlugin provides another way to reach both 
helpful websites. 
 
The Pixologic website contains the latest information concerning 
ZBrush, as well as resources such as a library of useful ZScripts.  
Additional content will be added in the future. 
 
The Support page provides ways to contact Pixologic directly for 
assistance should the other resources covered above not be able 
to help you. 
 

In Conclusion 
ZBrush offers a variety of ways to learn about the software – 
without ever needing to leave the program!  Every feature is 
documented in several ways.  Basic facts can be found by holding 
down the Ctrl key, while more comprehensive reading is available 
from the Help Topics browser.  Last of all, www.ZBrush.com and 
www.ZBrushCentral.com provide still more resources.
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Painting Basics 
In this section, we’ll 
cover the basic principles 
of what 2.5D painting is 
all about, and how 
several palettes work 
together to create a wide 
variety of effects. 

 
 
ZBrush operates as a paint program powered by a real-time 3D 
rendering engine.  At its core, it utilizes “pixol” technology.  
Every dot on your canvas not only contains information about its 
XY coordinates and color values, but also its depth, orientation, 
and material.  What this means is that you can “paint” a 3D 
object onto the canvas (or paint a brush stroke with depth 
enabled) and ZBrush will automatically shade what you’ve painted 
with the scene’s lighting and other 3D-type settings.  Rather than 
spending time trying to make shadows and highlights look real and 
consistent (and possibly having to redo work if you decide that 
you’d like to try something else), you can allow ZBrush to handle 
the details so that you can spend more time simply being 
creative! 
 
We’ll begin by examining how the interface elements work 
together to produce what you paint on the canvas.  This is critical 
to your mastery of ZBrush, so don’t give in to the temptation to 
skip ahead!   
 
As covered previously, all of ZBrush’s functions are grouped 
together in palettes, each aimed at a specific type of task.  
ZBrush’s flexibility comes from the fact that these palettes do not 
operate in a vacuum.  Instead, they work together to create or 
modify everything that goes on the canvas.  The default interface 
configuration has been specifically designed to make these 
interactions as intuitive as possible. 
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When you chang tools, you may 
notice that the thumbnails below 
also change.  This is because 
each tool has default settings in 
the other palettes, and is yet 
another reason why the 
thumbnails are presented in this 
particular order. 

On the left side of the interface, there is a column of 
large thumbnails.  Each of these corresponds to a 
single palette.  To make things easy, all but the color 
selector also shows its palette name. 
 
These palettes directly interact to affect what is 
painted on the canvas: 
 
Tool – The Tool palette is at the very heart of it all, 
which is why its thumbnail comes first.  Every tool 
provides a different unique way to draw or modify 
pixols on the canvas.  Tools fall into three unique 
categories: 
 
Pixol-adding brushes.  These are paint brushes, which 
add pixols to the canvas when you paint with them. 
 
Pixol-changing brushes.  These are also brushes, but 
they require pixols to already be on the canvas.  For 
example, the Snake Hook can draw pixols out into a 
tendril while the Shading Enhancer can accentuate the 
bright or dark parts of your scene. 
 
Objects.  All 3D objects are also present in the tool 
palette.  When first drawn on the canvas, they can be 
modified on a polygonal level.  They will normally be 
snaphot to the canvas, becoming pixols within your 
scene. 
 

� With the Simple Brush selected (it is the default brush 
when ZBrush launches, and is shown in the illustration 
above), draw a horizontal line across the top of the canvas. 

 
� Click the Tool thumbnail, select the Single Layer brush 
and draw another horizontal line beneath the first. 
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� Now select the Spiral3D object and draw another 
horizontal line beneath the second. 

 

 
 
As you can see, the results are radically different depending upon 
what tool is being used.  Tools are the most fundamental building 
blocks for everything that you will paint on the canvas. 
 
Alpha – These are grayscale images that can be used in a variety 
of ways.  The most common use is to change the shape of your 
paint brush.  However, alphas can also be used for masking 3D 
objects, creating stencils to paint through, modifying fog and 
depth cue during a render, and much more.  They can even be 
skinned and converted into 3D objects.  All displacement maps 
are alpha images. 
 

� Clear the canvas by pressing Ctrl+N. 
 

� Select the Single Layer brush and then with the Stroke 
thumbnail select Freehand. 

 
� Draw a stroke on the canvas. 

 
� Select any other alpha and draw another stroke. 

 

 
 
As you can see, the Alpha palette provides a simple way to 
radically change the nature of your brushes. 
 
Stroke – Every time you click and drag on the canvas, a stroke is 
painted.  The Stroke palette provides different things that can 
happen during that stroke – from drawing a single instance of an 
object to spraying down a chaotic “splatter.” 
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 In the previous example, we changed from the Dots to Freehand 
stroke type.  They are different in that Freehand ignores the 
speed of your cursor as it moves across the canvas, painting 
instances of the alpha at precise intervals.   
 

� Change to Dots again and draw a stroke on the canvas. 
 
This stroke type determines the distance between alpha instances 
based upon the speed of the cursor.  The master you move your 
mouse or pen, the farther apart the alphas will be placed. 
 

� Change to DragDot and draw another stroke. 
 
Only one instance of the alpha is placed, at the point that you 
ultimately end the stroke. 
 

� Now draw a stroke using the Spray type. 
 

 
 
By providing you with a variety of stroke types, ZBrush makes it 
easy to get exactly the results that you need with a minimum of 
effort.  For example, the Spray stroke can be used with a 3D 
pebble to paint a stream bed, with the scattered pebbles drawn 
in various sizes and shades of color. 
 
Material – The 3D rendering engine interprets how light interacts 
with the pixols that are present on the canvas.  A significant 
element in that process is the material used to paint each pixol.  
Simply put, materials tell the rendering engine how to shade the 
colors on the canvas.  Materials can be used to simulate metal, 
glass, stone, plastic, and more. 
 

� Clear the canvas. 
 

� Select the Single Layer brush along with any alpha and 
stroke that you wish. 

 



ZBrush 2 Practical Guide                                                                                                                   Painting Basics 67 

 

� Paint a stroke on the canvas. 
 

� Now select the Toy Plastic material and draw another 
stroke. 

 
This material has specularity settings that are very different from 
the default Fast Shader.  Even though you haven’t changed the 
color that is being painted, the colors of the new stroke appear 
different from those of the first stroke.  This is because the Toy 
Plastic material tells the rendering engine to shade the colors 
differently than the Fast Shader. 
 

� Draw a few more strokes using different materials. 
 

 
 
A single scene can have many materials, up to the number of 
small thumbnails that are visible in the material pop-up menu. 
 
Texture and Color – Every pixol on the canvas has color.  The 
Color palette is used to give a single color to your brush stroke.  
The Texture palette is used to give several colors to the stroke by 
means of another image.  Textures can also be wrapped onto the 
surface of a 3D object.  The Color thumbnail is underneath the 
Texture thumbnail because a texture will automatically override 
the currently-selected color. 
 

� Clear the canvas. 
 

� Select the Sphere3D tool. 
 

� Select any color and paint a sphere on the canvas. 
 

� Now select a texture from the Texture palette and draw 
another sphere. 

 
Even though your color of choice is still selected, you don’t see it.  
This is because the texture overrides the color. 
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� Change to the Simple Brush and draw another stroke. 
 

� Click the Texture thumbnail and select your texture 
again, then draw another stroke. 

 

 
 
Color and texture provide different – and mutually exclusive – 
ways to add color to anything that you draw on the canvas.  These 
colors are then modified by the material. 
 
Now that we have covered the six palettes that are used to create 
your brush strokes, let’s take a look at two more very important 
palettes:  Draw and Transform. 
 
For your convenience, the most commonly used elements from 
each palette are provided on the top part of the shelf, above the 
canvas. 
 

 
 
The simplest way to explain these palettes is this: 
 
The Draw palette is normally used to modify a stroke before it is 
drawn.  The Transform palette is used to edit something 
immediately after it has been drawn. 
 
This is a generalization, since Draw settings can also be changed 
while something is being transformed after it has been drawn. 
 
Let’s put this to work so that you can see it in action. 
 

� Press Preferences>Init ZBrush to restore ZBrush to its 
launch state. 

 
� Press Ctrl+F to fill the canvas. 
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� Select the Toy Plastic material and any color, then paint 
a stroke on the canvas. 

 
This is a standard brush stroke, using the default settings.  Take a 
look at the top shelf to see what we mean.  The Draw palette 
elements are arranged in groups to make things easier. 
 
Mrgb/Rgb/M – These three switches are related, since only one 
can be active at a time.   Mrgb is the default, and the stroke that 
you just drew painted both material and color onto the canvas. 
 

� Press Rgb, then draw another stroke below the first. 
 
Notice how this time there is none of the Toy Plastic’s distinctive 
shininess.  This is because the Rgb setting tells ZBrush to ignore 
the selected material, and only paint color. 
 

� Press M and draw another stroke below the second. 
 
No color at all has been painted.  Only material has been added to 
the canvas. 
 

 
 
Only one of the three switches can be active at a time.  Activating 
one deactivates the others.  However, you can also turn them all 
off. 
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� Press M to turn it off.  Draw a vertical stroke down the 
middle of the canvas. 

 

 
 
No color or material has been painted on the canvas.  Only the 
depth has been changed. 
 
Zadd/Zsub/Zcut – These three switches operate similarly to the 
previous three, but affect depth instead.  When Zadd is active 
(like we have used so far), depth is added to whatever is already 
present on the canvas.  Notice how with the last stroke that you 
painted, the pixols built up depth on top of what was already 
there when your stroke crossed the three that you’d painted 
earlier.   
 

� Activate Zsub and paint another stroke to the right of 
the last. 

 

 
 
The dark shading is now on the left of the stroke.  This is because 
your stroke just subtracted depth from what was already in the 
scene rather than building up on top of it.   
 
The third option, Zcut, is currently disabled.  It is only available 
for 3D objects and is beyond the scope of this tutorial.  Like with 
the Mrgb switches, these three can also be turned off to protect 
the current depth on the canvas.  (In fact, painting a 3D object 
with depth turned off is a handy way to create shapes.) 
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There are also RGB Intensity and Z Intensity sliders.  The first 
controls how much color will be added to the scene when you 
paint.  At a value of 100, new colors will completely overwrite 
existing color on the canvas.  At 25 the color is very transparent, 
which works well for building up detail within a scene or texture. 
 
Z Intensity specifies how much depth is added.  A value of 0 is the 
same as turning Zadd and Zsub off. 
 
Draw Size is used to change the diameter of your brush. 
 
Immediately after something has been painted on the canvas, it 
can be edited using the Transform palette.   
 

� Clear the canvas. 
 

� Draw a brush stroke using the Single Layer brush. 
 

� Activate the Move gyro by pressing the Move icon or the 
W key on your keyboard. 

 
The gyro will appear at the starting point of your stroke.  You can 
now use it to move your stroke around the canvas.  You can also 
use Scale and Rotate. 
 

� Select a new alpha, material, and color. 
 

� Change the RGB Intensity and Z Intensity. 
 
All of your changes take place immediately.  The only changes 
that you cannot make are for the tool and stroke.  If you wish to 
change either of them, you would have to undo the current stroke 
and draw a new one with the new tool or stroke type. 
 

� Press Q to deactivate the gyro, then clear the canvas. 
 

� Draw a new stroke. 
 

� While holding down the Ctrl key, draw a few more 
strokes. 
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� Release the Ctrl key and activate the gyro again. 
 

 
 
This time, the gyro will appear at the starting point for the last 
stroke drawn.  However, you will be able to transform all of the 
strokes together.  The Ctrl key provides a way for you to chain 
multiple strokes so that they can be edited as a group. 
 

In Conclusion 
In this section, we have examined how several palettes in ZBrush 
work together to create everything that is painted on the canvas.  
We have also seen how the interface is laid out to make your work 
easier.  The thumbnails to the left of the canvas each correspond 
to one of the “building block” palettes, and are used to build your 
strokes.  The elements on the shelf above the canvas are then 
used to affect what will be drawn on the canvas or change it 
immediately after it has been drawn. 
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Rusted Golden Idol 
In this section we’ll put 
the theory behind 
ZBrush’s 2.5D painting 
techniques to work. 
 

 
 
In the last section, we learned the basic principles behind 2.5D 
painting.  Now we’ll apply those principles to create a simple – 
but fun – project. 
 
We’ll begin by creating the idol out of simple primitive shapes.  
Color and material will then be used to paint the rust onto it.  
Lastly, we’ll create a background and use some ZBrush trickery to 
paint the shadow. 
 

� Press Preferences>Initialize ZBrush to return to the 
startup state. 

 
� Select the Ring3D tool. 
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 � Select the Basic Material, and a Brown color. 
 

 
 
This material will be modified later to suit our needs.  We’re 
using it instead of the default Fast Shader because the Basic 
material has many more modifiers. 
 

� Set the Tool>Initialize values. 
 

 
 
Use SRadius 39, Coverage 180, Scale 1, Twist 0, SDivide 32, 
LDivide 64, and ITwist 0. 
 
Every native ZBrush object is parametric in nature.  This means 
that you can use the Initialize menu to set various parameters 
that influence the object’s shape. 
 

� Draw the object on the canvas. 
 

� Activate Rotate. 
 

 
 
This turns on the rotate gyro. 
 

� Rotate the half ring so that it curves up. 
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Markers must be placed while 
the current object is active.  
Once you have switch to a new 
tool, it is too late to place a 
marker without redrawing the 
object. 
 
Also, only one marker can 
occupy any part of the canvas.  
If you try to place a marker too 
close to another one, the first 
will be replaced by the new one. 

 
 
When close to the desired rotation, press Shift to snap it the rest 
of the way. 
 

� Activate Move. 
 

 
 

� Position the ring near the top center of the canvas as 
shown. 

 

 
 
Use Scale if necessary, to match the illustration. 
 

� Press Transform>Place Marker. 
 

 
 
You’ll see a small animation as the marker flies from the button 
to the center of the object on the canvas. 
 
Markers are a very powerful feature of ZBrush.  They are able to 
remember many details about a 3D object, including its position 
on the canvas, scale, orientation, material, color and more. 
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We’ll use this marker to assist with positioning the rest of the 3D 
elements in the scene. 
 

� Select the Sphere3D tool. 
 

 
 
If you receive help message, select “Switch Now.” 
 

� Draw it at one end of the arc on the canvas. 
 

� Activate the gyro. 
 

 
 

� Position this small sphere so that it is embedded in the 
Ring object. 

 

 
 

� Draw another sphere. 
 

� Activate the gyro. 
 

� Set Tool>Initialize>Coverage to 180. 
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While the gyro is active, the object is in a transformable state.  
This means that adjusting the Initialize settings will also affect 
the sphere on the canvas, making it into a hemisphere. 
 

� Use Move, Scale and Rotate to flatten out the 
hemisphere and position it as shown. 

 

 
 

� Press Layer>Dup to clone the layer. 
 

 
 
This new layer will be an exact copy of the first. 
 

� Press Layer>Flip H to flip the layer horizontally. 
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� Move the duplicated layer so that the two arcs merge. 
 

     
 
You can use the Displace H slider to move the layer, or hold down 
the tilde (~) key and click+drag within the canvas. 
 

� Merge the layers by pressing Layer>Mrg. 
 

 
 
This combines the current layer with the one to its left (the 
original one).  The result is one layer again. 
 
Always be sure that Zadd and Mrgb are active before merging 
layers.  Otherwise, you can get strange effects. 
 

� Duplicate the layer again and flip it vertically. 
 

� Use Displace V to move the layer down, forming legs. 
 

 
 

� Merge the layers. 
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� Select the Sphere3D and move the pointer so that it is 
where the marker was placed. 

 

 
 
The marker will appear when you get close to it, and will enlarge 
when your pointer is directly on top of it. 
 

� Click the marker. 
 
The sphere will be drawn with the exact scale, orientation and 
position of the ring. 
 

� Use the gyro to scale it smaller. 
 

 
 

� Select the Cylinder3D and click the marker to draw it. 
 

� Use the gyro to rotate and move it into position.  Use 
scale to lengthen it. 

 

 
 
Remember that clicking on the intersections of the gyro makes it 
possible to constrain your transformations.  For example, the 
yellow intersection is used to lengthen the cylinder without 
changing its diameter. 
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 � Add several Ring3D objects. 
 

 
 
The one around the head is added by clicking the marker and then 
scaling and rotating the ring appropriately.  Snapshot was pressed 
to copy the ring at its current position before moving the ring 
down the body and scaling/rotating it.  The ring was snapshot 
three times here before moving and rotating it into place for the 
arm band and ankle. 
 
Note that the right side is left alone. 
 

� Duplicate the layer, flip it horizontally, and move it into 
position. 

 

 
 

� Merge the layers. 
 

� Create a new layer for the background. 
 
While the simplest way to color the background is to change the 
Document>Back color, we will want to paint on ours.  To make 
this possible, we will use a different technique involving a second 
layer and a 3D object. 
 



ZBrush 2 Practical Guide                                                                                                             Rusted Golden Idol 81 

 

� Select the Plane3D tool. 
 

 
 

� Select the Flat Color material.  
 
This material is unaffected by the rendering engine, and so will 
not receive shadows from it.  While ZMode shadows with good 
Rays and Aperture settings will produce an excellent shadow, we 
have chosen to paint the shadow manually in order to illustrate 
other ZBrush features. 
 

� Draw the plane on the canvas and use the gyro to scale it 
to fill the screen.  Also, move it back behind the idol. 

 

 
 
Remember that you can change an object’s depth while Move or 
Rotate are active by clicking and dragging anywhere on the canvas 
surrounding the gyro. 
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� Select alpha 27 and the Simple Brush. 
 

 
 

� Rotate the alpha by pressing the Alpha>Rotate button. 
 

      
 

� Select the Drag Rectangle stroke type. 
 

 
 
This stroke will allow us to paint a single instance of the alpha. 
 

� Choose a darker color, turn off Zadd, and paint a stroke 
on the canvas so that the gradient fills it completely. 
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You can use the gyro after drawing the gradient to move and scale 
it if necessary. 
 

� Switch back to layer 1 so that we can paint on the idol. 
 

� To begin painting the rust, use the Simple Brush and 
alpha 23. 

 

 
 

� Using the Drag Rectangle stroke and various shades of 
color, paint multiple copies of the alpha all over the idol. 

 

 
 
You could also use the Spray stroke type for parts of this. 
 
Since the background is on a different layer, it is completely 
unaffected by these strokes.  With ZBrush, there is no need to 
“color within the lines.” 
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� Change the Draw>Width to 50% 
 

 
 
This changes the width of the alpha, which in turn will affect the 
strokes being painted on the canvas. 
 

� Continuing to vary the colors, add still more rust to the 
idol. 
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� Adjust the direction and intensity of the primary light. 
 

 
 
To adjust the direction, click and drag on the small square 
located on the thumbnail.  You will be able to see the lighting 
update on the canvas in real time. 
 
Set the intensity to 1.22. 
 

� The next step is to adjust the 
material properties to look more like 
rusted metal. 

 
Use the settings shown to the right. 
 
Diffuse should be 86 
 
The Diffuse Curve should be modified 
slightly, and given about 50% noise.   
 
Also pay attention to Specular to modify 
the shininess of the metal and Color Bump 
to make it rougher. 
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The material now looks a lot more like rusted metal, but it’s still 
missing something.  Rusted metal doesn’t only contain variations 
in color, but also variations in specularity, diffuse, reflections, 
etc. 
 

� Press the CopyMat button located above the material 
modifiers. 

 
� Select another material such as Fast Shader 5. 

 
� Press the PasteMat button. 

 
This replaces the Fast Shader 5 material with a duplicate of the 
Basic material. 
 

� Set the material’s Diffuse to 60. 
 
This will make it possible for us to see where we are painting this 
new material because it will stand out against the existing one. 
 

� Activate M on the top shelf. 
 

 
 
This instructs ZBrush to ONLY paint with material.  Colors and 
depth will not be changed. 
 

� Paint the new material in scattered places across the 
idol. 
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 Because this material is a copy of the original, it still has the 
same rust quality that we had built previously.  This is a real time 
saver.  It’s simply darker than the first because we adjusted the 
Diffuse before painting the new material. 
 

� Adjust the other material 
modifiers. 

 
Raise the specular setting. 
 
Adjust the Diffuse Curve. 
 
Add a little noise to the material itself, 
etc. 
 

 
 
 

� At this point, tweak the colors on 
the idol a bit by switching to Rgb and 
painting with just color.   
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For purposes of this manual, 
“Tool” always refers to an item 
found in the Tool palette. 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

Note:  The Alpha>GrabDoc 
button could also have been 
used.  We chose the 
MRGBZGrabber simply to 
illustrate the capabilities of this 
tool. 
 

Three are several methods by which a drop shadow can be added 
to the scene.  As previously mentioned, we could simply tell the 
rendering engine to render shadows.  The drawback to that is due 
to the fact that our background is a vertical plane located just 
behind the idol.  Rendered shadows would give it away 
immediately.  Since we wish to give the impression that the idol is 
standing on a vast plane, we’ll use a different technique. 
 

� Select the MRGBZGrabber tool. 
 

 
 
This complicated-sounding tool is used to grab a kind of snapshot 
of the canvas.  It can capture the materials (M), colors (RGB), or 
depth (Z) – hence its name. 
 

� In the Tool>Modifiers, turn Auto Crop off. 
 
With Auto Crop active, the grabbed area would automatically be 
cropped to the size of the objects on the layer.  We want to 
capture the entire canvas, instead. 
 

� Click and drag on the canvas to capture the entire scene. 
 
Two things will happen when you release the mouse.  A capture of 
the canvas will be placed in the Texture palette.  At the same 
time, a depth map of the canvas will be placed in the Alpha 
palette. 
 

 
 
This alpha is a precise representation of the canvas with the 
grayscale values representing relative depths.  White is the 
highest depth while black is the lowest. 
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� Press Alpha>Make St to convert the alpha into a stencil. 
 

      
 
The stencil will immediately be activated on the canvas.  Dark 
areas can be painted through, while light areas will block paint. 
 

� Activate Stencil>Elv. 
 

      
 
This displays the stencil as an outline, making it easier to see the 
rest of the scene.  It does not change the stencil’s effect at all. 
 

� The stencil is too small.  Press Stencil>Stretch to match 
the size of the stencil to the size of the canvas. 
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� Hold down the Spacebar to activate the stencil’s Coin 
Controller. 

 
This controller will appear at the pointer location, and has several 
controls built into it. 
 

� Click V on the controller and drag to reduce the height of 
the stencil. 

 

 
 

� Release the Spacebar to dismiss the controller. 
 

� Select the background layer from the Layer palette. 
 

 
 

� Use the Simple Brush and a dark color to paint the 
shadow through the stencil. 
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� Once the shadow has been painted, you can turn off the 
Stencil>Stencil On switch. 

 

 
 

� Use the Blur brush (found in the Tool palette) to 
soften the shadow edges. 

 
� Return to layer one (the idol layer). 

 
� Select the Colorizer1 material. 

 
� With Draw>M active, paint this material onto the figure. 
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� Modify the material properties. 
 
This material 
has two shader 
channels that 
must be 
modified.  You 
switch between 
them using the 
S1 and S2 
buttons at the 
top of the 
modifiers. 
 
 
 
 
Match the images at the right. 
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� Add a few more brush strokes of color, only to complete 
the scene. 

 

 
 

In Conclusion 
In this project, we’ve combined 3D objects with traditional 
painting techniques to create an extremely detailed figure.  By 
using ZBrush’s materials and real-time rendering engine, we can 
quickly duplicate real-world materials.  The ability to switch 
between painting with or without depth and combinations of color 
and materials gives great flexibility to your workflow. 
 
We have also seen the strengths of such features as the 
MRGBZGrabber and the Stencil, as well as experimenting with Blur 
– one of ZBrush’s effects brushes. 
 
 
This tutorial is also available as a ZScript, found in the ZScript list 
under the name of Materials: Rusted Golden Idol.
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Bamboo Part 1 --
Background 
In this section, we’ll 
create the ground for our 
bamboo scene. 

 
 
This section covers the first of four parts to create the “Bamboo” 
scene.  We’ll begin by creating the ground layer, which in the 
following sections will be used as a base to paint vegetation onto, 
as well as the bamboo itself.  The last section will deal with 
creating the beetles that will be used to add interest to the 
scene. 
 
While working, you’ll quickly begin to see the advantages of being 
able to work in a hybrid 2D/3D environment. 
 
To begin, resize your document. 
 

� Turn off Document>Pro 
 

 
 
The Document palette contains everything to control your 
document’s basic properties.  This includes its dimensions, 
background color, and border color. 
 
The Proportional button keeps the relative dimensions of your 
document the same.  When it’s active, adjusting the width will 
also adjust the height and vice versa.  Since we want a canvas 
that is wider than it is high, we need to disable this feature. 
 

� Set Width to 1280 
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� Click Resize, and then say OK to the confirmation 
dialogue. 

 

 
 
We’re creating a document that is considerably wider than it is 
high.  In addition, we’re creating it at twice the actual size that 
will be exported from ZBrush.  This will provide us with very 
clean, antialiased edges when we do our final render.  Working at 
a larger canvas size also makes it easy to add extra detail.   
 

� Select the Plane3D tool. 
 

� In the Initialize menu, set V Radius to 40. 
 

 
 
All native ZBrush objects ending in “3D” are parametric tools.  
This means that you can modify the object by changing several 
parameters associated with it.  All of these parameters are found 
in the Initialize menu, and will vary from object to object. 
 
In the case of the Plane3D object, we have settings for its width 
and height, as well as for its resolution.  Since this plane will 
provide our background, we’re setting the V Radius so that the 
object’s dimensions are similar to the canvas dimensions. 
 

� Draw the plane on the canvas, and then press T to enter 
edit mode. 
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� Rotate the plane a little. 
 

 
 
From this angle, it will be easy to see the effects of the 
deformations that we’re about to perform. 
 

� Select alpha 32. 
 

 
 
This particular alpha has a bumpy sort of appearance.  It will 
make it easy for us to transform the plane into bumpy ground. 
 

� Press Tool>Masking>Alp 
 

 
 
This applies the alpha to the plane as a mask.  You’ll see that the 
plane on the canvas now has a grayscale pattern that matches the 
alpha. 
 
Masking applies to a model based on its polygons.  Since we have 
relatively few polygons at this point, the masked pattern is 
blocky.  That’s ok for our purposes. 
 



ZBrush 2 Practical Guide                                                                                             Bamboo Part 1 – Background 97 

 

� Open the Tool>Deformations menu.  In the offset slider, 
make sure that only Z is active. 

 

 
 
Each deformation has X Y Z settings.  These correspond to the 
model’s coordinate system.  By turning off X and Y, and turning Z 
on, we’re telling ZBrush to apply the deformation only along the 
model’s Z axis.  In the case of the plane, that means the flat side. 
 

 
 
If you ever want to know what the model’s coordinate system is, 
open its preview.  X will be horizontal, Y will be vertical, and Z 
will be the direction pointing directly toward you.  All 
deformations operate along the coordinates seen in the preview, 
which will not necessarily match the scene’s coordinate system. 
 

� In the Offset slider, enter a value of -20. 
 
This tells ZBrush to offset points, creating raised bumps.  A value 
of 100 is equal to 1 ZBrush unit, so -20 is equal to 1/5 of a ZBrush 
unit toward the preview camera (+20 would have been away from 
the camera). 
 
The offset is restricted by the masking that has been applied to 
the model.  Areas that are completely masked (dark gray) won’t 
be offset at all.  Areas that are completely white will be offset 
the most. 
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By combining masking with deformations, it is truly amazing what 
can be created from the primitive 3D objects!  
 

� Turn off Quick 3D Edit on the top shelf. 
 

 
 
Quick3D disables ZBrush’s smoothing routines.  This allows a 
model to render faster while you work on it, but it also makes the 
model appear angular.  By turning Quick3D off, we are telling 
ZBrush to render many polygons for every real one.  This results in 
a much smoother model. 
 

 
 
Your model should now look something like the image above.  It 
still has a checkered pattern caused by the masking. 
 

� Press Tool>Masking>Clear to remove the mask. 
 
Now that the model has been deformed, we no longer need the 
mask. 
 

� Do an Inflate deformation at a value of 100. 
 

 
 
Since the masking has been removed, this deformer now applies 
to the entire model.  Every point gets moved by this deformer 
according to its surface normal.  This has the effect of inflating 
the features. 
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Here we have the results.  The bumps created by the offset 
deformation have now been inflated to create a surface that is 
ideal for our needs. 
 

� In the Transform>Modifiers, turn off Xyz.  Then change 
the X Y Z switches beside it so that only Z is active. 

 

 
 
Normally, when you sculpt on a mesh your editing tool will affect 
the model in all three directions.  What we want to do next will 
be to only sculpt depth details into the model.  These settings will 
force ZBrush to only sculpt along the Z axis. 
 

� Now sculpt some extra depth onto parts of the model by 
simply drawing on it.  Create a higher area in the center of 
the mesh, with a few other bumps surrounding it. 

 

 
 
Whenever you click the mouse, the model will temporarily 
become very angular.  This is because ZBrush needs to switch 
back to Quick 3D Edit while you are applying an edit.  As soon as  
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you release the mouse, ZBrush switches back to the rendered 
view, allowing you to see the finished results of your work. 
 

� Now use the move, scale and rotate features to fill the 
canvas with the ground that you have sculpted. 

 

 
 

 
 
The canvas should now look something like the image above.  You 
may find that you need to switch to the AA Half zoom level in 
order to be able to see the entire canvas. 
 

� From the Materials, select NoisePattern1. 
 

 
 

� Use the color selector to choose a yellowish-brown color. 
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Even though the object has 
been converted to pixols, a copy 
of it remains as polygons in the 
Tool palette until the end of the 
ZBrush session.  You could 
therefore save it for use in 
another scene or clear the 
canvas and redraw it if you 
decided that it needed further 
sculpting on a polygonal level. 

Since the model is still in edit mode, changes to the color and 
material affect it immediately.  You should now have something 
like this: 
 

 
 

� Press T to exit edit mode and return to normal draw 
mode. 

 
Since the ground is placed how we want it, and has had material 
and color assigned, we no longer need to keep it editable.  At this 
point, we can convert it from a 3D object made up of polygons to 
a 2.5D object made up of pixols.  This gives us much more room 
for creative freedom than polygons could offer, with the trade-off 
being that the object will no longer be able to be picked up from 
the canvas again. 
 
This is very close to what we want, but too shiny metallic-looking 
to be ground.  We can remedy that by changing the material’s 
modifiers. 
 

� Pull down the Material palette and change the Specular 
setting to 30. 

 

 
 
The canvas will immediately update to reflect the change.  This is 
because materials remain “live” on the canvas, even after the 
model has been snapshot. 
 
While we’re at it, let’s change some other modifiers for a more 
dramatic effect. 
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 � Set Noise Radius to 45. 
 

 
 
This increases the scale of the noise pattern. 
 

� Set Color Bump to -5. 
 

 
 
Color bump tells the rendering engine to make a surface appear 
less smooth based upon its color values.  With a negative value, 
darker areas will be raised.  In this case, that gives the 
appearance of smooth stone with dirt caked on top of it. 
 

� Edit the NoiseCurve to match the image below.  Once 
you have created the overall pattern, you can fine tune it 
with its Focal Shift slider. 

 

 
 
What we want is for there to be a few lightly-colored smooth 
areas, surrounded by lots of caked-on grunge. 
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From this point forward you 
might prefer to work with the AA 
Half zoom level active, and only 
switch to full size when 
precision is required.  This will 
allow you to work with the image 
as it will actually be seen when 
complete. 
 
 
 

 
 
When finished, you should have something like the image above. 
 

� Select the Simple Brush tool, select alpha 8, and the 
Spray stroke type.   

 
These settings combine to create a randomized spray paint effect 
using the selected alpha and variations of the current color. 
 

� On the top shelf set a Draw Size of 80, and an RGB 
Intensity of 50. 

 
We want our new color to blend nicely with the existing canvas 
color, which is why the intensity is set where it is. 
 

� Now paint a few strokes on the canvas to break up the 
pattern created by material. 

 

 
 
Nature is very chaotic.  The Spray stroke is an invaluable tool for 
replicating that randomness with minimal effort.  In fact, let’s 
take things a step farther by modifying the stroke settings: 
 

� First, select the FastShader material. 
 
We change to a different material because otherwise the strokes 
that we’re about to paint would blend too much with the existing 
noise pattern material.   
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 � Select alpha 23, and set the RGB Intensity to 100. 
 

� In the Stroke palette, change Placement to 100 and 
Color to 100. 

 

 
 
A high placement setting will give the maximum scatter as we 
paint our strokes.  A high color setting will cause the greatest 
randomness in color variation while we paint. 
 

� Changing colors to yellows and greens, paint a few 
random strokes across the canvas. 

 

 
 
The random effects of the spray stroke give us the look of mosses 
and other stuff growing on the rocky surface.  The effect is very 
realistic. 
 

� Save your work using Document>Save As.  If you wish, 
you can also save your ground plane as a 3D object using 
Tool>Save As. 

 
Always remember that saving your document saves the pixols that 
are on the canvas.  It will not save any models as 3D objects.  To 
save them, you MUST use the inventory controls in the Tool 
palette. 
 
Saving the document also saves any materials that are in use on 
the canvas.  We therefore have no need to save them separately 
unless you would like to use the ground material again in another 
project.  If you do, then select the NoisePattern1 material again 
and press Material>Save. 
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In Conclusion 
In this section we have seen how deformations and masking can 
be used to transform simple parametric objects into much more 
complex models for use in your ZBrush scenes.  We’ve also 
experimented with materials and the Spray stroke type to mimic 
the randomness of nature with hardly any time or effort.  In the 
next section, we will incorporate more 3D elements into our 
scene.
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Bamboo Part 2 -- 
Modeling 
In this section, we’ll 
continue the “Bamboo” 
project by adding the 
bamboo itself.  This will 
be accomplished by 
deforming parametric 
objects to be snapshot 
onto the canvas. 

 
 
In the previous section we used the very simplest of primitive 
objects – a plane – to create the background for our scene.  In this 
section, we’ll take things a step farther by using more 
complicated objects to add visual interest.  While the objects 
themselves are more complex, the basic techniques are still the 
same. 
 
If this is a new ZBrush session, load your scene file from the 
previous section by pressing Document>Open.  If you have not yet 
followed that tutorial, you can load the source file that we have 
provided.  It is called Chapter3-1 and is located in the 
Documentation\SourceFiles\Chapter3 folder. 
 

� Begin by pressing Layer>Create to create a new layer. 
 

 
 
ZBrush layers can best be thought of as parallel universes.  Each 
layer contains the entire 3D space of the ZBrush canvas.  This 
means that objects on one layer can literally exist inside of those 
on another layer.  In short, while some features (such as material-
based transparency) require multiple layers, their most common 
purpose is to provide a means for organizing your scene.  For 
example, you can place objects on different layers and then paint 
on one object without worrying about affecting what lies on the 
other layers. 
 
In this tutorial, we’ll use the new layer to contain our bamboo. 
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When the new layer is created, it appears next to the first one in 
the small thumbnails at the top of the Layer palette.  Each 
thumbnail shows a continuously-updated view of the unshaded 
colors that are present on that layer.  This makes it easy to tell 
what’s on a particular layer without bogging the computer down 
with more rendering than is necessary. 
 
Layers can be turned on or off.  Visible layers are identified by a 
teal background and a triangle in the upper left corner.  Invisible 
layers have a gray background and no triangle.  The currently-
active layer has a box around it.  By default, the layer that you 
just created is active.  To make a layer active, click on it.  To 
turn it off, click on it a second time.  To turn it back on, click it 
again. 
 

� Hold down the Shift key and click on the active layer. 
 

 
 
The shift key provides a shortcut to toggle visibility for all layers 
at the same time.  We have just turned all layers off.  This hides 
the background layer, so that it will not distract us while we 
begin modeling on this layer, as well as freeing up system 
resources. 
 
Incidentally, the active layer will always be visible on the canvas, 
even if it is turned off.  In this way, you can switch from one layer 
to another without having to turn them on and off individually.  
They can all be turned off, so that switching from one to another 
will hide the former while unhiding the new. 
 

� If you have AA Half view active, press 0 to switch to 
actual size. 
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While modeling, it is almost always easiest to view actual size.  
We’ll switch back to AA Half when we start placing objects. 
 

� Select the Cylinder3D tool. 
 

� In the Initialize menu, set X Size and Y Size to 5, and 
VDivide to 128. 

 

 
 
This changes the cylinder so that it is 20 times longer than it is 
across, and also has 8 times more polygons along its length than 
the default value. 
 

� Draw the cylinder on the canvas. 
 

� Activate edit mode by turning on the Edit Object switch. 
 

 
 

� Rotate the model so that it is seen from the side.  When 
close to the angle that you wish, hold down the Shift key to 
snap the model into position. 

 
� Press Alt and click once on any empty part of the canvas. 

 

 
 
The Alt+click combo is a shortcut to center the object on the 
canvas and resize it to fit.  In short, it provides a “fit object to 
screen” function.  You can also accomplish the same thing by 
clicking once on either the Move or Scale button. 
 
To create bamboo-like ribs, we’ll be using the Inflate 
deformation.  Before we can do that, though, we must use 
masking to specify where we want the deformation to take place. 
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We could accomplish this by holding down the Ctrl key and 
tediously dragging the mask across the particular polygons that 
we want.  Since this is a parametric object, there is an easier way 
which makes it easy to unmask by letting ZBrush count polygons. 
 

� Press Tool>Masking>MaskAll 
 

 
 
This masks the entire object, which must be done before the next 
step can be possible. 
 
The Select and Skip sliders are used to specify how the unmasking 
will take place.  Select specifies how many polygons will be 
unmasked.  Skip specifies how many will be remain masked.  This 
pattern will be continued across the entire model. 
 

� Sel is already at 8.  Leave it alone.  Set Skp to 1. 
 

 
 
This tells ZBrush to unmask 8 polygons, leave 1 masked, then 
repeat the pattern.  Now we need to tell ZBrush whether we want 
the pattern to be applied to Rows, Columns, or both (in a Grid). 
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Important!  Changing the 
initialize settings for any object 
will immediately undo any work 
that has been done on that 
object.  Therefore, when 
working with a parametric object 
you should always set the 
initialize settings first. 
 

� Press Row 
 

 
 
ZBrush now immediately unmasks the entire cylinder in the 
specified pattern. 
 

 
 
At this point, it would actually be possible to continue unmasking 
by column instead, to turn each ring into a series of segments.  By 
applying overlapping unsmask routines, very complicated patterns 
can be created if your work calls for them.  This project only 
needs the rings as they are, however, so we will stop here. 
 
You will notice that one end has more unmasked polygons than 
the other.  This is because the total length of the object is not 
evenly divisible by 9 (the total of the Select and Skip values).  If it 
was a case that mattered, we could have used an initialize value 
that would have allowed the ends to be even, but this is nature 
that we’re modeling, where nothing is truly perfect. 
 
We’re now ready for the deformation. 
 

� Tool>Deformation>Inflate at -10.  There is no need to 
change the X Y Z settings for this operation. 

 

 
 
A negative value causes shrinkage rather than inflation.  If we had 
used a positive value here, the model would have been given a 
series of rings cut into its length rather than protruding from the 
surface. 
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Take a close look at the image above.  Here you can see that 
while masking applies to an entire polygon, deformation actually 
take place at the points.  When a polygon is masked, two of its 
points will be masked while two will be left unmasked.  This is an 
important distinction to keep in mind while you are modeling, as 
it allows more precision than if all four points were masked. 
 

� Turn off Quick 3D Edit. 
 
This enables ZBrush’s smoothing routines. 
 

 
 
The bamboo is now ready for a material and color to be applied. 
 

� Select a nice yellowish-orange color and the 
NoisePattern2 material. 

 
� Modify the material as follows: 

 
 Diffuse 56 
 DiffuseCurve Focal Shift -62 
 Specular 50 
 NoiseCurve to match the graph: 
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Noise Radius 40 
Color Bump 5 
Colorize Specular 100 
High Dynamic Range 1.1 
 

� Lastly, drag from the Spec color patch at the bottom of 
the material modifiers to a yellow-gold color on the color 
thumbnail.   

 

 
 
All color patches in ZBrush can be set by selecting a color and 
then clicking on the patch or by dragging from the patch onto any 
part of the interface or canvas.  Since the color of the model is 
still “live” because it’s in edit mode, we don’t want to use the 
first technique.   
 

 
 
The model should now look something like the image above.  
We’ll actually leave the masking in place, since it helps make the 
rings stand out realistically. 
 

� Save the model using Tool>Save As, and name it 
bambooStick. 

 
� Press T to exit edit mode, then Ctrl+N to clear the layer. 

 
Now that we’ve created the stick, we’ll also create a bamboo 
ring. 
 

� Select the Ring3D tool. 
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� Draw it on the canvas, enter edit mode, and center the 
object on the canvas. 

 
� For the Initialize values, set SRadius to 0 and LDivide to 
128. 

 

 
 
This gives us a very thin ring with 128 rows of polygons around its 
circumference.  
 

� Enter Edit>Move mode by activating the Move switch. 
 

 
 
This allows us to move points around by dragging them.  The 
default Draw Size of 64 allows us to move several points at once.  
This is also why we’ve made the ring so thin. 
 

� Reshape the ring a little by moving parts of it around.  
 

 
 
You will get the best results by moving in short steps rather than 
making long drags. 
 

� Apply the Smooth deformation 3 or 4 times to soften the 
edits and get rid of any irregularities. 
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This is important, since our next step would magnify any 
irregularities in the mesh. 
 

� Perform the Inflate deformation with a value of 50. 
 

 
 
You’ll now have a fatter ring, which is nicely smoothed. 
 
Now all we have to do is use the same technique to create the 
ribs that was used for the stick: 
 

� In the Masking menu press MaskAll 
 

� Set Skp to 1 
 

� Press Col 
 
For the Ring3D object, the columns wrap around the model while 
rows form its circumference. 
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� Inflate -10 
 

 
 

� Save the model as BambooRing 
 

� Press T to exit Edit mode, then Ctrl+N to clear the 
canvas. 

 
Last of all, we need to create the Z.  This will be created from a 
cylinder using a combination of the techniques that were used on 
the stick and ring. 
 

� Select the Cylinder3D. 
 

� Set X Size and Y Size to 1.  Set VDivide to 128. 
 

 
 

� Draw the object on the canvas, enter Edit mode, and 
center the object. 

 
Press W to activate Edit Move mode.  Working in small 
increments, reshape the cylinder into the letter “Z”. 
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� Use the Smooth deformation several times to relax the 
shape. 

 
� Edit the shape a little more if you like, then Smooth 
again. 

 
� When you are satisfied with the shape, Inflate it with a 
value of about 8. 

 

 
 

� Save the model as bambooZ, then exit Edit mode and 
clear the canvas. 

 
� Shift+Click on the active layer’s thumbnail to toggle 
layer visibility back on again.  Make sure that the active 
layer is the empty one. 

 

 
 

� Return to the AA Half zoom level. 
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� Now select a slightly lighter shade of yellow and draw 
the Z on the canvas.  Use the gyro to move, scale and rotate 
it into position. 

 

 
 
Make sure that the Z is positioned so that it’s resting on the 
ground layer.  The easiest way is to draw the object and move it 
into position, then rotate it.  Remember that you can adjust the 
object’s depth while the Rotate gyro is active. 
 

� Select the stick object and choose a more orange-gold 
color to provide contrast with the Z.   

 
� Draw several copies of the stick around the edges of the 
scene.   

 

 
 
After drawing the first, it is easiest to press the Snapshot button 
(or Shift+S) to leave a copy of the stick at its current location 
without having to deactivate the gyro.  This makes it easy to 
place instance after instance of the object without the need to 
redraw it every time. 
 

 
 

� Save your document as Chapter3-2.zbr 
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In Conclusion 
In this section, we have learned about how layers can be used to 
separate your work, along with more techniques for masking 
objects and using those masks to control deformations.  The 
advantage of being able to paint with 3D objects can clearly be 
seen:  even with the time spent sculpting our shapes and fine 
tuning our material, it has still taken very little time to create an 
image with all of the shadows and realism of a 3D scene. 
 
While the techniques described here provide one way to create 
this type of object, there are certainly others!  Another approach 
would be to use ZSpheres.  An excellent tutorial on the subject is 
located at ZBrush Central.  Click Here 
 
This section is also available in ZScript format.  Please see the 
Help Topics\Supplemental Reading\Bamboo. 

http://www.pixolator.com/zbc-bin/ultimatebb.cgi?ubb=get_topic&f=1&t=010970
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Bamboo Part 3 --
Creating Grass 
In this section we’ll 
explore two different 
ways to add vegetation to 
a scene, using the Fiber 
brush and ZBrush’s new 
Fibers material shader.  

 
In this section we’ll bring life to the scene by painting grass.  
There are actually two ways that this can be done: using the Fiber 
brush, or by using a Fibers material shader.  Each technique has 
advantages and disadvantages: 
 
With the Fiber brush, you can paint fibers exactly where you want 
them.  If you don’t like the effect, you undo, change the settings 
slightly, and paint again.  This can be faster than repeatedly re-
rendering the scene to get the exact fibers that you wish.  The 
disadvantage to this technique is that you must usually bake the 
layer’s lighting before you can get the best results from the 
brush.  This can be gotten around by using a dual-layer system for 
painting the fibers, which has the added benefit of allowing the 
fibers to cast shadows on their surroundings (if not on each 
other).  Also, if you are using fibers on a figure, you must re-paint 
them for every pose of the figure.   
 
With the Fibers shader, you are dealing with a render-time effect.  
This means that there is no need to bake the layer.  You can 
therefore paint fibers at any time; even before you have finalized 
the scene’s lighting.  Also, you can apply a fibers-enabled 
material to a figure, then repose the figure.  The fibers will adapt 
to the new pose.  The disadvantage is that the only control you 
have over the fibers is through the shader modifiers.  This means 
that fibers can “poke through” other objects that are present 
within a scene.  Also, because fibers are rendered last, they 
cannot cast shadows on the scene (although they can cast 
shadows on themselves). 
 
It is up to you to determine which approach will work best for 
your needs.  In this tutorial, we will introduce you to both.  We’ll 
begin with the Fiber brush method. 
 

� If it is not already open, load your document from the 
previous chapter. 
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� Make sure that the first layer is active, then click 
Layer>Dup. 

 
This duplicates the current layer, placing the duplicate 
immediately to the right of the original in the thumbnail list.  The 
new layer will be the active layer. 
 

 
 

� Turn off layer 3 by double-clicking on it, then reselect 
layer 2. 

 

 
 
The bamboo will disappear from view.  This is one of the reasons 
why we created the bamboo on a second layer in the first place. 
 

� Click Layer>Bake 
 
What this does is change the layer to the Flat Color material.  In 
the process, all coloring that has been created by the materials 
and lighting gets converted to unshaded RGB color.  You can see 
the result in the layer thumbnail, which now matches the canvas 
exactly. 
 

 
 
We took this step because the Fiber brush works best with the 
Flat Color material.  In order to resolve any conflicts between the 
material properties of the fibers and the properties of the 
background, we convert the background to the same material that 
the fibers will use. 
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� Click Layer>Displace Z and set the slider to a value of 1.  
Press Enter. 

 

 
 
This moves the current layer 1 pixol away from the camera.  The 
result is that its surface now lies immediately behind the original 
background layer.  The Flat Color material cannot receive any 
new shading information, including shadows.  If we just painted 
our fibers onto a baked layer, then we couldn’t change the 
lighting later, nor would the fibers cast shadows onto the 
background.  However, since the original background layer has 
not been baked and now rests one pixol in front of the baked 
layer, we can change the lighting later and it will receive shadows 
from the fibers that we’re about to paint!  
 

� Turn layer 3 back on, but keep layer 2 as the active 
layer. 

 

 
 
In order to properly place our fibers, we’ll need to see the 
bamboo. 
 

� Select the Fiber brush from the Tool palette. 
 

 
 

� Select the Flat Color material.  Then select the grass 
texture. 
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Note: Because the depth history 
buttons are a part of 
ProjectionMaster, they should 
never be used when you have 
used ProjectionMaster to drop a 
model for texturing or painting 
displacement.  It is perfectly ok 
to use them at any other time, 
however.

 
 
The Flat Color material is essential for high quality fibers.  The 
grass texture will be applied to each fiber, resulting in very nice-
looking vegetation. 
 

� Select alpha 23 
 

 
 
Grass tends to grow in clumps.  This alpha will simulate that. 
 

� Set Rgb Intensity to 100. 
 
We don’t want transparent grass. 
 

� Click Document>StoreDepthHistory 
 

 
 
This step is a nifty and very useful trick, which borrows a feature 
embedded in ZBrush by the ProjectionMaster plugin.  Ordinarily, 
every stroke that is painted on the canvas will interact with every 
stroke that has come before it.  In the case of the Fiber brush, 
fibers would quickly be drawn on top of teach other, resulting in a 
jumbled mess.  By storing the depth history, we’re taking a 
snapshot of the current depth in the scene.  All new depth that is 
added will be ignored until the depth history is deleted again. 
 
 In the lower left corner of the scene, paint a few strokes. 
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Not bad, but the fibers are a bit fine.  Press undo a few times to 
remove them again. 
 

� In the Tool modifiers (which change to match the 
currently-active tool), set Thickness to 2. 

 

 
 
This will make the fibers a little thicker. 
 

� Paint a few strokes again. 
 

 
 
This is now very close to what we want.  A few more 
modifications will finalize our settings. 
 

� Set Grooming to 0, and activate Back C. 
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No grooming tells ZBrush to ignore the direction of your brush 
strokes.  All fibers will be painted solely based on the orientation 
of the pixols that the fibers are painted on.  Back Color active 
tells ZBrush to blend the background color (which is black by 
default) with the foreground color (set by the texture).  This gives 
fibers that are a little darker at the base. 
 

� Lastly, set Draw>Depth to 4. 
 

 
 
This doubles the length of the fibers that will be painted. 
 

� Draw a few more strokes on the canvas. 
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Now that you have a brush that 
paints high quality grass, you 
might want to save it using 
Tool>Save As.  That way, you 
won’t need to recreate your 
settings in the future.

 
 
Perfection!  This is exactly what the scene calls for, so go ahead 
and paint grass to your heart’s content.  As you work, remember 
that you can modify the fiber length at any time using 
Draw>Depth. 
 
Also, you will notice that changing the Draw Size also changes the 
length of the fibers.  Again, use Draw>Depth to compensate. 
 

 
 

� When finished, save your document as Chapter3-3a.zbr 
 
 
Next, we’ll redo the grass, this time using the Fibers material 
shader. 
 

� Click Preferences>Initialize ZBrush 
 
ZBrush will revert to the startup state. 
 

� Open the Chapter3-2 document again. 
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 We’re now back to where we were before we started adding 
fibers. 
 

� The first thing that we need is a Fibers material.  There 
is already one at the end of the thumbnails, so select it. 

 

 
 

� Place the material palette in a tray, so that it stays open 
while working. 

 
This makes modifying the materials a little easier. 
 
The fibers material is actually a shader, which must be in the S1 
channel of any material that uses it.  Take a look at the modifiers 
with S1 active.  These are “raw” values for the Fibers shader.  As 
you can see from the thumbnail, there’s nothing going on.  This is 
because several key modifiers have not been set. 
 

� Click Material>Load, and select the Fibers05.ZMT 
material from the ZMaterials folder. 

 

 
 
We have provided five fibers materials to get you started in your 
exploration of this feature.  Clicking on any material name will 
show a preview of the material in the dialogue box.  Fibers05 is 
the closest to grass. 
 
When it’s loaded, the material thumbnail immediately updates to 
reflect the settings. 
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� On the top shelf, activate M and turn off Zadd. 

 
We want to paint just the material.  No color or depth.  You might 
also want to select alpha 8 again. 
 

� Paint the material strategically throughout the scene. 
 

 
 
As you work, you will be able to easily see where you’re painting.  
This is because the Fibers shader works in conjunction with the 
material’s S2 shader.  In short, the S1 channel paints the fibers 
and the S2 channel paints the background.  Since the S2 shader 
for this material is by default very generic, the base color 
becomes visible again.  At this point, that’s a good thing, because  
otherwise it would be very hard to tell where we’ve painted 
anything! 
 
Also, you don’t need to worry about the bamboo at all.  That lies 
on a different layer, so might as well not even exist as far as the 
paint brush is concerned. 
 

� Drag from the Material thumbnail onto some of the 
original background of our scene, then release. 

 
Like the color patches, the Material thumbnail can be used as a 
Picker.  We have now selected the NoisePattern1 material, which 
gives our scene its background colors. 
 
Notice in the Material modifiers that this material only has one 
shader channel.   
 

� At the bottom of the modifiers, click the CopySH button. 
 



ZBrush 2 Practical Guide                                                                                         Bamboo Part 3 – Creating Grass 128 

 

 
 
ZBrush makes it easy to mix materials by providing these copy and 
paste functions. 
 

� Switch back to the Fibers material, and select the S2 
channel. 

 
� At the bottom of the channel, press the PasteSH button. 

 
The preview of the material will change slightly, along with all of 
the modifiers in this channel.  At the same time, the scene itself 
will update.  Everything that was just painted will seem to vanish.  
By copying the NoisePattern1 settings into this channel, we have 
created a background that exactly matches the rest of the scene. 
 

� Place the Render palette in the other tray. 
 

� In its settings, activate Fibers. 
 

 
 
Since Fibers are a render-time effect, they can be activated or 
deactivate at will.  The ability to turn them off can be very useful 
at times.  It also conserves system resources. 
 

� Activate the Best renderer. 
 

 
 
All of the Render palette special effects only become active when 
a Best render is executed.  On the canvas, you’ll see the scene 
render, and then the fibers will be added. 
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This looks really great – for an autumn scene.  What is happening 
is that the fibers are getting their colors from what is already 
present on the canvas.  Since the canvas is all shades of brown, so 
are the fibers. 
 
There are several ways that we can override this, however. 
 

� Switch back to the Fibers S1 channel. 
 

� Select a grassy green color using the Color thumbnail, 
then click the Tip swatch in the Material modifiers. 

 

 
 
The scene will render again, but won’t appear to be any 
different.  Every time a change is made to the modifiers, the 
scene will re-render.   
 

� To allow the material to use this new color, we must 
activate the TipColor blend modifier.  Set it to about 50. 

 

 
 
When the scene renders again, the green color will blend with the 
colors from the canvas. 
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Well, we have green grass, but if you ask me, it’s a bit much.  
Let’s try the other way to override the color. 
 

� Click on the Texture patch at the bottom of the shader, 
and choose the grass texture. 

 

 
 

� Set ReflectColor blend to .75 
 

 
 
This tells ZBrush to blend the texture with the other colors 
already present in the fibers.  Each fiber will now be 25% what it 
was in the last render, and 75% grass texture. 
 

 
 
Here’s the result.  Just the right shade! 
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Now that the color is perfect, it’s time to tweak the rest of the 
modifiers so that we have tufts of grass rather than a bunch of 
bushes. 
 

� Set Density to 10 
 

� Set Length variations to 25 
 

� Set Density variations to 25 
 

� Set Direction variations to 35 
 

� Set SelfShadows to 25 
 

� Set DarkenEdge to .25 
 

� Set Strand Width to 3 
 
A Best render now should give results like what you see in the 
picture below: 
 

 
 

� Save your document as Chapter3-3b 
 
You will be able to compare the two versions and use the one you 
like best for the next section. 
 

In Conclusion 
In this chapter, we have explored two unique ways to add fibers 
of all kinds to a scene.  The Fiber brush is a power 2.5D paint tool 
that adds fibers to the canvas as pixols that can then be modified 
later in your work.  The Fibers material shader adds the fibers as 
a post-render effect.  A variety of modifiers are available for 
either approach, which can be used to create anything from grass 
to hair to waterfalls. 
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Bamboo Part 4 --
Finishing Touches 
In this section we will 
finish the scene by 
creating a few beetles, 
and also adjusting the 
scene’s lighting and 
rendering options.  

 
We’ll begin this section by doing a little bit more modeling, and 
touching on texturing for the first time.  We’ll then modify the 
scene’s lighting and rendering options to tie everything together 
and bring it to life. 
 

� Draw a Sphere3D on the canvas.  Enter Edit mode and 
rotate the sphere so that the poles are at the top and 
bottom.  Hold down the Shift key to snap the model into 
position. 

 

 
 

� Set the Tool>Initialize>X Size and Y Size values to 80. 
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� Holding down the Ctrl key, drag a bounding box across 
the bottom ¾ of the sphere. 

 

 
 
The Ctrl key by itself activates ZBrush’s masking mode. 
 

� In Tool>Deformation, perform an Inflat XY at a value of -
50 

 

 
 
Remember that you can click on the Z next to Inflat to deactivate 
that axis. 
 

� Mask one more row of polygons. 
 

� Do a Squeeze XY at -10. 
 

 
 

� Press Tool>Selection>Masking>MaskAll 
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� Also in Masking, set Sel 2 and Skp 30.  Press Col. 
 

   
 

� Mask the remaining head polygons by holding Ctrl to 
paint a drag-rectangle. 

 
� If you rotate to the side, you’ll see that there are other 
groups of unmasked polygons.  Mask them, as well, so that 
only the double row on the back remains unmasked. 

 

 
 

� Perform an Inflat XY at a value of -30. 
 

� Unmask the model. 
 

� Again in Deformation, do a Flatten Y at a value of -80. 
 

 
 
Your model should now look like the image above.  Depending 
upon the orientation of the model when you were masking it, you 
might have to use the X axis for Flatten or a positive value instead  
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of the negative 80.  If that’s the case, simply undo and use the 
different settings. 
 

� Activate Transform X to turn on symmetry. 
 

� Turn on Transform>StdDot, and set Z Intensity to 80.  
Change the Draw size to 40. 

 
� Hold down the Alt key to switch to Zsub.  Place a pair of 
eye sockets on the model. 

 
� Let go of the Alt key and set Draw>Focal Shift to -40.  
Place eyes inside the sockets. 

 

 
 
Now that the stylized beetle has been created, it needs a texture.  
We’ll use Projection Master to do the job. 
 
Since the model is a parametric object, it already has the most 
appropriate UV mapping assigned.  In this case, that’s spherical 
mapping. 
 

� Create a blank texture by setting Texture>Width and 
Height to 1024.  Click New. 

 

 
 
Although the texture can be any dimension you like, ZBrush is 
optimized for powers of 2.  Therefore, the best options are 
256x256, 512x512, 1024x1024, 2048x2048, or 4096x4096. 
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� Rotate the model so that its back is to the camera and 
click the Projection Master button on the top shelf. 

 

   
 
The Projection Master panel will appear in front of the canvas.   
 

 
 

� Turn on Material and Double Sided, turn off Fade, then 
click Drop Now. 

 
Double Sided tells PM to texture the side facing the camera and 
the opposite side of the model at the same time.  Fade means 
that the colors being applied will not be faded as the polygons 
angle away from the camera.  (For most texturing, you would 
leave this on, since it allows even blending as you rotate the 
model over the course of several drops.)  Material tells ZBrush to 
also embed any selected materials as a part of the texture. 
 
Now that the model has been dropped, you can use all of ZBrush’s 
tools to texture it. 
 

� Set Rgb Intensity to 100. 
 

� Select Alpha 00 and the Basic Material. 
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 � Paint a stroke to cover the entire model. 
 

 
 

� With the Toy Plastic material and a dark red color, paint 
another stroke.  Move and scale it to cover one half of the 
shell. 

 

 
 

� Click the Snapshot button on the right shelf, then move 
the painted stroke down to the second half of the shell. 

 

 
 

� Press Q to dismiss the gyro. 
 

� Select the Circle3D tool and a white color. 
 

� Activate Rgb and turn off Zadd. 
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� Paint a spot on the beetle’s back and press W to activate 
the move gyro. 

 

 
 
3D objects can be used to draw all kinds of shapes when Zadd is 
turned off.  No depth is applied, so all that you get is the object’s 
filled shape. 
 

� Using move, scale and snapshot, paint several dots on 
the shell. 

 

 
 
When move is active, it’s best to click inside the gyro (without 
clicking on one of the rings).  This keeps the circle object aligned 
to the surface beneath it. 
 

� Click the Projection Master button and then the Pickup 
Now button. 

 
The model is now fully editable again, and can be rotated to a 
new angle.  You’ll also see that the Texture thumbnail has 
updated to reflect the painting that you just did. 
 

� Rotate the model so that its bottom is facing the camera.  
 

� Activate Projection Master and turn off Double Sided 
before clicking the Drop button. 
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We don’t want the shell pattern on the beetle’s belly, so we’ll 
remove it. 
 

� Select the Simple brush, Alpha 14, and the Dots stroke 
type. 

 
� Drag from the Material thumbnail onto the grey part of 
the beetle.  Release the mouse. 

 
This selects the Basic Material again by sampling it from the 
canvas. 
 

� Do the same with the foreground color patch to match 
the grey of the head. 

 
Any of the color patches in the ZBrush interface can be used as 
pickers by dragging from them onto the canvas.  Whatever color 
the picker is over when the mouse is released will be the selected 
color.   
 

� Turn off Zadd, make sure that Rgb Intensity is at a value 
of 100, and paint the belly except for a bit of shell around 
the edges. 

 

 
 
There’s no need to be really accurate with this, since the 
underside will probably never be seen. 
 

� Press G to pick the model up from the canvas again, and 
then rotate it so that the eyes are facing forward.  Press G 
again to drop it in this new position. 

 
� With the Circle3D tool again, DoubleDotsMetal material, 
and a dark shade of grey, paint the eyes. 
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� Press G to activate Projection Master, and pick the 
model up. 

 

 
 

� It’s still a little fat, so do Tool>Deformation>Size Y at -
20. 

 
� If you wish, you could also rotate it in the Tool>Preview 
so that it faces down. 

 

 
 
This will make it easier to draw the model in the scene. 
 

� Use Tool>Save As to save this model as Ladybug.ztl 
 

 
 

� When asked if you would like to include the texture, 
click Yes. 

 
Now that our little ladybug is finished, it’s time to put it in the 
scene. 
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� Click Document>Open, and load your favorite version of 
the scene from the last section. 

 
� Paint several beetles in strategic locations. 

 

 
 
Now it’s time to make the scene more dramatic.  We’ll do this 
with lighting and render effects, which will bring out the detail. 
 

� In the Light palette, set Ambient to 0. 
 
This removes ambient light from the scene, so that all the lighting 
comes from the lights themselves. 
 

� Set the Intensity to 1.2 
 

� Adjust the Focal Shift of the Intensity Curve to 86. 
 
This makes the light slightly more focused. 
 

� Drag the orange square in the light thumbnail so that it’s 
positioned as shown. 
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Lights can be moved around the canvas using this thumbnail.  
Some light types can also be precisely positioned by dragging 
Light>Placement>P onto the position in the scene where you want 
the light. 
 
Clicking on the square in the light thumbnail changes it from a 
front light to a back light.  Clicking again turns it into a front light 
once again. 
 

� Select the second light and give it an orange color by 
choosing that color in the Color palette and then clicking on 
its color patch. 

 

 
 

� Select the first light again, and open the Shadow menu.  
Set Intensity to 1.5, Length to 200, and turn on ZMode. 

 

 
 
ZMode is a special way of rendering shadows that takes the depth 
of the pixols at the edges of objects into account.  It results in 
more accurate shadows. 
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� In the Render palette, turn off Fibers (if your scene is 
using materials to create the grass), and turn on Shadows. 

 

 
 
This cluster of switches is used to activate ZBrush’s render 
effects.  They are only used during a Best render.  While basic 
shadows are generated by the Preview renderer, you need to 
activate the render setting and do a Best render to see the high 
quality shadows controlled by the Light>Shadow menu. 
 

� Click the Best button to render the scene. 
 

 
 
Pay close attention to the shadow outlines.  If the shadows look 
right, your shadow length setting is good.  If parts of the shadows 
seem to be missing where the model is farthest from the surface 
that the shadow is being cast on, you’ll need to increase the 
setting. 
 
You may find holes in the shadows in places that obviously have 
nothing to do with the shadow length.  This is because 1 ray is not 
enough for high quality ZMode shadows.  We don’t want to  
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increase the number of rays until necessary, however, as that also 
increases render time.   
 

� When satisfied with your other light settings, set 
Light>Shadow>Rays to 100 and Aperture to 20. 

 

 
 

� Render the scene. 
 
The render will take longer this time because more rays are being 
cast. 
 
The shadows are probably too indistinct now.  This is because the 
shadow-casting objects in the scene are very narrow in diameter 
and we’re using quite a lot of rays in order to get really good 
shadow accuracy.  Lowering the Aperture setting further 
“tightens” each ray, making the shadow edges more distinct while 
still retaining the softness of Global Shadows. 
 
The more rays that you use and the more distinct you wish your 
shadows to be, the lower you will need to set the Aperture. 
 

� Set Aperture to 10 and render again. 
 

 
 
The play of light and shadow should now be pretty dramatic.   
 



ZBrush 2 Practical Guide                                                                                    Bamboo Part 4 – Finishing Touches 145 

 

� You can make it even more dramatic by turning on 
Render>Adjustments>Adjust and setting the Contrast to 20. 

 

 
 
The Adjustments menu gives several controls for manipulating the 
overall appearance of a scene without the need to render it 
again. 
 

� Turn Shadows off, return to the Preview renderer, and 
then activate Fog. 

 
Fog is another render effect that can be used for a variety of 
purposes.  It has several controls, found in the Render>Fog menu. 
 

 
 
The two color patches are used to set the near and distant fog 
colors.  We’ll leave them alone. 
 
The Depth1 slider sets the closest fog depth, while Depth2 
specifies the farthest depth. 
 

� Click on Depth1 and drag it onto the canvas to a high 
ground point just behind the Z. 

 
This sets the near depth to the point at which the cursor was 
released.  Now the fog is localized so that it won’t obscure the Z 
at all. 
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� Change the fog curve’s Focal Shift setting to something 
like -55. 

 
This makes the fog reach its maximum intensity sooner. 
 
There are two special patches between the color patches.  These 
are used to give the fog a texture and an alpha. 
 

� Click the alpha patch and select the shown texture from 
the popup menu. 

 

 
 
Nothing will change in the document, since we’re using the 
Preview renderer.  
 

� Do a Best render now. 
 

 
 
The while the curve and depth settings determine the fog 
intensity at various depths, the alpha determines its intensity at 
various XY values across the canvas.  The closer to white the 
alpha is, the more intense the fog will be. 
 
Now we’ll tie everything together, doing the final render.   
 

� Switch back to Preview for a moment. 
 
This keeps the engine from doing a new Best render for each 
setting change. 
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� Turn on Shadows and Fibers (if you’re using Material 
fibers). 

 
� Click Best again. 

 

If the results are to your liking, there is one last step to take: 
 

� Activate Zoom>AAHalf. 
 
This turns on ZBrush’s special antialiased display mode.  The 
document is not resized, but any exported image will be.   
 

� Save your document as Chapter3-4.ZBR, and then Export 
the document. 

 

In Conclusion 
Congratulations!  You’ve just completed a 2.5D project.  In this 
section, we’ve covered a lot of ground.  We used a parametric 
object to sculpt a simple beetle, which was textured using 
Projection Master.  We then worked with ZBrush’s lighting and 
rendering effects to make the image more dramatic. 
 
These same techniques can be used to sculpt/paint far more 
impressive scenes that what was created in this tutorial.  While 
the bamboo may not be incredibly dramatic, it was chosen as a 
project specifically for the wide variety of techniques that are 
employed.  You should now be able to sculpt a variety of shapes 
from primitives, understand the difference between an editable 
object and a snapshot, and be able to create custom materials.  
You should also be able to texture using Projection Master, and be 
comfortable with painting using various combinations of material, 
color, and depth. 
 



ZBrush 2 Practical Guide                                                                                    Bamboo Part 4 – Finishing Touches 148 

 

Remember that there are MANY ways to accomplish various tasks 
in ZBrush.  As you become more familiar with the software, you 
will come to learn the techniques that work best for your personal 
style and needs.  This tutorial has been meant to give you a broad 
understanding of 2.5D painting, which you will then be able to 
expand upon during your own sessions. 
 
Now that you have the basics down, the remaining chapters of 
this manual will cover more specialized portions of the ZBrush 
software.
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Not So Primitive 
In this section we’ll 
introduce some basic 
modeling principles by 
using masking and 
deformations to 
transform primitive 
objects. 

 
 
One aspect of ZBrush’s workflow is the ability to create extremely 
complex scenes by combining a bunch of smaller objects.   
Ultimately, a scene could be composed of millions or even billions 
of polygons, yet still render in real time!  This is because only one 
object ever exists as polygons at a time.  But where to get those 
building block objects in the first place?   
 
ZBrush provides a very powerful masking and deformation system 
that is unique to parametric objects.  (Both are available for 
polymeshes, but the more specialized selection functions that 
we’ll make heavy use of here are only available for primitives.)  In 
this section, we’ll explore a few of the possibilities inherent in 
this system by creating several complex objects. 
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Plastic Pipe 
 

� Select the Cylinder3D tool.  Draw it on the canvas and 
enter Edit mode by pressing T. 

 

 
 
It is possible to do the effects in this tutorial while the model is 
still in the Tool palette, but it’s much easier to see your results 
when the model is on the canvas. 
 

� In the Tool>Initialize menu, set X Size and Y Size to 20. 
 

 
 
The Initialize menu has settings that change from one primitive to 
the next.  These are the parameters that you set to control the 
model on its most basic level.  In this case, we’ve changed the 
model’s cross section to be 20% of a ZBrush unit.  As a result, the 
cylinder is not five times longer than it is wide. 
 

 
 
It is important to adjust the Initialize settings before you modify 
the model through sculpting or deformations.  Any change in this 
menu causes the model to revert to its primitive state. 
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 � Press Tool>Masking>MaskAll 
 

     
 
The object becomes completely dark to show that it’s fully 
masked.  You could also hold down the Ctrl key and paint your 
mask onto the surface of the model, but this is faster for our 
purposes. 
 

� Set Tool>Masking>Sel to 1. 
 

 
 
This tells ZBrush how to deal with the unmasking process.  By 
leaving the Skp value alone, we’re actually telling ZBrush to use 
the same value as for Sel. 
 

� Press Row. 
 

 
 
At this point, the model is unmasked in alternating rows of 1 
polygon each (the Skp value).  All masked areas will be left alone 
when deformations are applied. 
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� Apply Tool>Deformation>Inflate at a value of 100. 
 

      
 
As you can see, the deformations affect a model’s points, while 
the masking affects its polygons.  This is perfectly normal. 
 

� Perform the Inflate a second time. 
 

� Clear the mask by pressing Tool>Masking>Clear. 
 

� On the top shelf, turn off Quick 3D Edit. 
 

 
 
This activates ZBrush’s smoothing algorithims.  The effect is that 
while the model is stationary (not being edited or rotated), it will 
be displayed with many more polygons than it really has. 
 

      
 
If we had used a Tool>Initialize>VDivide value of 32 at the outset, 
the result would have been more tightly-packed ribs.  Go ahead 
and try that now. 
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Round Plastic Pipe 
 
The next object that we’ll create is very similar to the regular 
pipe.  We’ll use the Ring3D primitive instead, though. 
 

� Exit Edit mode (T) and clear the canvas (Ctrl+N). 
 

� Select the Ring3D.  Draw it on the canvas and enter Edit 
mode. 

 

 
 

� Set the Initialize>Coverage value to 180. 
 

 
 
This turns the ring into a half ring. 
 

� Press Masking>MaskAll, then set the Sel value to 1 before 
pressing Col. 
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For the Ring3D object, rows run along the large circumference 
while columns ring the small circumference. 
 

� Perform the Inflate deformation at a value of 100, then 
clear the mask. 

 

 
 
And there we have our curved pipe. 
 

Round Metallic Spring 
 

� For this object, repeat the steps above for the Ring3D 
object.  But this time, use a Masking>Sel value of 2 and a 
Skp value of 1.   

 

 
 
This tells ZBrush to unmask 2 columns for every 1 that it leaves 
masked. 
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� When you get to the Inflate step, use a value of 50 
twice. 

 

 
 
Deformations are cumulative.  Sometimes it’s best to do a series 
of smaller deformations rather than try to accomplish everything 
in one. 
 

Webbed Pipe 
 
 

� Repeat the steps for the spring, stopping when you have 
unmasked the rings. 

 
� Set Sel to 1 and leave Skp at 1.  Press Row. 

 

 
 
Unmasking is also cumulative.  So the unmasking by row now gives 
us a checkered pattern. 
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� Do two Inflate routines at 50, and then clear the mask. 
 

 
 
As you can see, by creating more complex masks we are in turn 
able to create more complex models!  And we did all of this with 
just a few very simple steps. 
 

Bolt 
 

� For this one, we’re going to start with the Cube3D 
primitive. 

 
� In the Initialize menu, set X Size and Y Size to 20.  Set 
Sides Count to 6, HDivide to 30 and VDivide to 45. 

 

      
 
The cube can actually become a cylinder with enough sides!  It 
has slightly different parameters than the Cylinder3D, though, 
which is why we’re using it for this example. 
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� In the Masking menu, MaskAll and then set Sel to 32.  
Press Row. 

 

 
 
 

� In the Deformation menu, click on the Z in the Size slider 
to turn it off. 

 

 
 
Each deformation has XYZ settings to control the axis that the 
deformation will operate on.  By turning Z off, we’re telling 
ZBrush not to change the length of the unmasked polygons when 
we perform this deformation.  
 

 
 
Note that the axis is NOT in relation to the canvas (world 
coordinates).  Deformations use an object’s local coordinates.  If 
you ever wonder what the local coordinates are, open the 
Tool>Preview menu.  You can also change the local coordinates on 
the fly by rotating the figure in the preview. 
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� Apply the Size deformation at a value of 50, followed by 
SFlatten at 5. 

 

 
 

� Now that the head of the bolt is complete, reverse the 
mask by pressing Masking>Inverse. 

 
This protects the head that we just created, and allows 
subsequent deformations to only affect the bolt’s shank. 
 

� Apply Twist 6 times at a value of 100.  Follow it with 
Inflate at 30. 

 
There’s no need to adjust the XYZ settings for the twist, since it’s 
set to Z by default. 
 

� Clear the mask. 
 

 
 

A Tire 
 

� Select the Sphere3D. 
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� Set Initialize>Z Size to 50. 
 

 
 

� Use the SFlatten deformation at a value of 25, followed 
by Inflate at 100. 

 

 
 
The combined effect creates a rim and rubber. 
 

� MaskAll.  Set Sel to 32, then press Row. 
 
This unmasks everything but what will become the tread. 
 

� Set Sel to 3 and Skp to 1.  Press Col. 
 
Now there will be just a few masked lines. 
 

� Apply Size XY at a value of 10. 
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� Press MaskAll, followed by Row. 
 

� Apply Twist at a value of 40, then clear the mask. 
 

 
 

Creature Tail 
 

� For this object, we’ll return to our old friend, the 
Ring3D. 

 
� In the Initialize menu, set SRadius to 50, Coverage to 
220 and Scale to .01. 

 

      
 
SRadius thickens the torus a bit, and Scale causes it to taper down 
to almost nothing. 
 

� MaskAll, then set Sel to 2 and press Col. 
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� Apply Inflate at 100, followed by Rotate Z at -20 and 
then another Inflate at 50. 

 

 
 

� MaskAll, then press Row. 
 

� Inflate 25, then Smooth 100. 
 

� Clear the mask. 
 

 
 
 

In Conclusion 
Masking can easily be combined with a variety of deformations to 
create one complicated-looking shape after another.  These 
various shapes are then able to be combined with other scene 
elements to build incredibly detailed scenes.  In fact, some 
ZBrush artists use these techniques almost exclusively in the 
creation of their artwork.  It should be noted that Row, Column 
and Grid are only available for parametric objects.  The remaining 
masking options are available for both primitives and polymeshes.  
To learn more about them, use the online help system. 
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Z Logo -- Creases 
In this section we’ll use 
the Create Difference 
Mesh feature to quickly 
create a custom 3D shape, 
then modify the 
subdivision smoothing via 
ZBrush 2’s Crease 
feature. 

 
 
ZBrush 2 has the ability to create a 3D mesh by comparing a 
model’s current state to its stored morph target.  We’ll put that 
to work here by creating a 3D letter “Z” from a Circle3D 
primitive.  Along the way, we’ll also make use of ZBrush’s mesh 
visibility features. 
 

� Begin by selecting the Circle3D primitive. 
 

� Press the Tool>Make Polymesh button. 
 
Since the Difference Mesh feature uses a stored morph target, and 
only polymesh objects can store one, we need to convert the 
primitive into a polymesh. 
 

� Select the new polymesh and draw it on the canvas. 
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� Enter Edit mode and activate the Polyframe view. 

 

   
 
We’ll need to be able to see the polygons in order to selectively 
hide some of them. 
 
Before proceeding, let’s quickly go over the selection features.   
The core of these features is the Ctrl+Shift key combination.  All 
mesh visibility options involve those two keys.   
 
When a mesh is completely visible, Ctrl+Shift+Clicking on any 
group will hide everything except that group. 
 

  
 
When a mesh is partly visible, Ctrl+Shift+Clicking on a group will 
hide that group. 
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When a mesh is partly visible, Ctrl+Shift+Clicking on the blank 
canvas will restore full visibility. 
 
At any time, holding Ctrl+Shift while dragging across the model 
will activate a green selection box.  Any polygons within that box 
when the mouse button is released will remain visible.  All other 
polygons will be hidden. 
 

   
 
If the keyboard is released before the mouse button, the box 
turns red.  Any polygons within the box will be hidden while the 
rest of the mesh remains visible. 
 

   
 
Dragging a small box (of either color) on any empty part of the 
canvas will invert the visibility. 
 

   
 
The drag-rectangle selections use a “smart” system.  If 
the drag rectangle encloses an entire polygon, then the 
system will select by polygons, only.  In other words, a 
polygon must be fully enclosed by the box to be 
selected.  If no polygon is completely enclosed, then the 
system will select by points instead.  You can also force 
point selection by activating the Pt Sel switch on the 
right shelf. 
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� Using a red drag-rectangle, hide several polygons. 
 

      
 

� Continue to hide polygons, creating a simple “Z” shape. 
 

 
 
As you work, you will find that sometimes it’s beneficial to use 
polygon selection and other times it’s easier to use points.  If you 
want to use points, the fastest approach is generally to just make 
sure that your selection box doesn’t fully enclose a polygon. 
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� Press Tool>Geometry>Delete Hidden 

 

 
 
We no longer need the hidden polygons, so we’ll delete them. 
 

� Press Tool>Morph Target>StoreMT 
 

 
 
This stores the current geometry so that it can be referenced 
later. 
 

� In the Tool>Deformations menu, set Offset to Z and then 
enter a value of around -40. 

 

 
 
This moves all of the visible points toward the camera by 40% of a 
ZBrush unit, or 2/5 the size of the object. 
 

� Back in the Morph Target menu, press CreateDiff. 
 

 
 
At this point, ZBrush compares the current mesh to the stored 
morph target and creates a brand new mesh. 
 

� Exit Edit mode and clear the canvas. 
 

� Select the MorphDiff_PM3D_Circle3D tool. 
 



ZBrush 2 Practical Guide                                                                                                               Z Logo - Creases 167 

 

ZBrush automatically names models in a way that makes it easy to 
tell how they were derived.  From the name alone, we can tell 
that it’s a difference mesh generated from a polymesh3D object 
that was in turn derived from a Circle3D primitive.  Of course, you 
can rename the model to anything you’d like by saving it. 
 

� Draw the new model on the canvas and enter Edit mode. 
 

 
 
As you can see, the new model is a fully-enclosed 3D figure.  
ZBrush used the stored morph target as one group, the offset 
position as a second group, and the polygons filling the difference 
between the two as a third group. 
 
This technique can be used in a remarkable variety of ways.  For 
example, form-fitting clothing for a figure could be created very 
quickly and easily. 
 
Now let’s take a look at what happens when the mesh is divided a 
few times. 
 

� Press Tool>Geometry>Divide three times. 
 

 
 
By default, when the mesh is divided it is also smoothed by 
averaging the new points with the pre-existing points.  This 
behaviour can be overridden by turning off Tool>Geometry>Smt,  
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but the result would be that the mesh remains very faceted.  
What if you want partial smoothing instead?   
 
ZBrush 2 provides a way. 
 

� Press Ctrl+Z three times to return to the original mesh. 
 

� Rotate the model to the side, activate Pt Sel, and draw a 
red rectangle to hide all but the front of the model. 

 

 
 

� Press Tool>Geometry>Crease. 
 

 
 
The polyframe view will change to show a fine dotted line around 
the edges of the visible area. 
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� Restore full visibility by holding Ctrl+Shift and clicking on 
any blank part of the canvas. 

 
� Divide the mesh three times again. 

 

 
 
This time, the front surface of the mesh remains flat.  The crease 
tags serve as weighting to prevent their adjacent edges being 
smoothed when the geometry is divided. 
 

 
 
When you look closely at the polyframe, you will see that the 
hidden polygons remain uncreased.  So the edges where the front 
and side groups come together are only creased along one side.  
Let’s crease the other side, as well. 
 

� Press Ctrl+Z to undo the mesh subdivision. 
 

� With Pt Sel off, rotate to the side view and use red drag-
rectangles to hide the front and back surfaces. 

 
� Press Crease. 

 
� Restore full visibility. 
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Now you will see that the edges common to the front and side 
surfaces have two rows of dotted lines.   
 

 
 

� Divide the mesh three times again. 
 

 
 
The edge is now sharper than ever, but the mesh does not have a 
faceted appearance.  This is because the non-creased edges are 
still being smoothed.  Creases are very useful for creating 
mechanical objects! 
 

� Undo several times until only the front surface is 
creased. 

 
� Restore full visibility. 

 
� Set Tool>Geometry>CreaseLvl to 1. 
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� Divide four times. 
 

 
 
The crease level tells ZBrush the maximum level at which to apply 
the crease tags.  With a value of 1, the crease is only applied the 
first time the mesh is divided.  For each subdivision after that, 
the crease is ignored and the mesh is smoothed.  The result is a 
front edge that is slightly harder than the back edge. 
 

� Undo the division and set the CreaseLvl to 2. 
 

� Divide the mesh four times. 
 

 
 
 
Now the crease is used for the first two subdivisions, and ignored 
for the second two.  The result is an edge that’s harder than the 
back surface, but still somewhat soft. 
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In Conclusion 
In this chapter, we’ve taken a look at how ZBrush 2’s mesh 
visibility controls operate and can be used to interact with the 
mesh.  We’ve also used morph targets to store a base level for a 
mesh that was then modified.  By comparing this modified mesh 
to the stored morph target, ZBrush was able to quickly create a 
shape that would have been very difficult to model by other 
means.  Finally, we’ve examined how creases can be used to 
modify how ZBrush subdivides a mesh, giving you control over the 
sharpness of your model’s edges. 
 
A tutorial on this subject is also available in ZScript format in the 
Help system.  Go to Modeling 3D Objects\Creases to view it. 
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Telephone Part 1 -- 
Edge Loop 
Modeling 
In this section, we’ll 
cover basic Edge Loop 
functionality, 
demonstrating the Crisp 
function. 
 

 
 
ZBrush 2 offers two ways to create sharp edges in a model.  In this 
tutorial, we’ll use the Crisp feature, which is a part of the Edge 
Loops command.  Along the way, we’ll work with partial mesh 
visibility. 
 
This tutorial is part 1 of 3.  It should be done before you continue 
to the other two Telephone tutorials. 
 
Before proceeding, let’s quickly go over the selection features.   
The core of these features is the Ctrl+Shift key combination.  All 
mesh visibility options involve those two keys.   
 
When a mesh is completely visible, Ctrl+Shift+Clicking on any 
group will hide everything except that group. 
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When a mesh is partly visible, Ctrl+Shift+Clicking on a group will 
hide that group. 
 

  
 
When a mesh is partly visible, Ctrl+Shift+Clicking on the blank 
canvas will restore full visibility. 
 
At any time, holding Ctrl+Shift while dragging across the model 
will activate a green selection box.  Any polygons within that box 
when the mouse button is released will remain visible.  All other 
polygons will be hidden. 
 

   
 
If the keyboard is released before the mouse button, the box 
turns red.  Any polygons within the box will be hidden while the 
rest of the mesh remains visible. 
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Dragging a small box (of either color) on any empty part of the 
canvas will invert the visibility. 
 

   
 
The drag-rectangle selections use a “smart” system.  If 
the drag rectangle encloses an entire polygon, then the 
system will select by polygons, only.  In other words, a 
polygon must be fully enclosed by the box to be 
selected.  If no polygon is completely enclosed, then the 
system will select by points instead.  You can also force 
point selection by activating the Pt Sel switch on the 
right shelf. 
 

� Begin the tutorial by loading phone.ztl from the 
Resources folder. 

 
� Draw the phone on the canvas and press T on your 
keyboard to enter Edit mode. 

 

 
 
This basic mesh was created using ZSpheres with only 1 resolution 
level.  The skin was then sculpted to block out the shape of the 
phone. 
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� Press Tool>Geometry>Divide 3 times. 

 

 
 
The divided and smoothed model now has a fairly sleek 
appearance.  It’s a little too smooth in places, though, such as 
where the ear and mouthpieces would go.  The Crisp feature will 
be used to create these edges. 
 

� Press Ctrl+Z three times to return to the original model. 
 
In order to use any of the Edge Loop features, we must be at 
subdivision level 1.  We’re using undo here instead of Multi-
Resolution Subdivision Editing because we want to work with the 
original, unmodified mesh.  MRSE would reshape subdivision level 
1 to more closely match level 4, which in this case is an effect 
that we don’t want. 
 

� Hold Ctrl+Shift and drag a green rectangle over the 
polygon that makes up the earpiece. 

 

   
 
If you do it right, you’ll be left with just the one polygon.  If you 
accidentally are left with more than one, use any visibility control 
that you prefer to isolate the single polygon. 
 



ZBrush 2 Practical Guide                                                                             Telephone Part 1 – Edge Loop Modeling 178 

 

 
� Press Tool>Geometry>Edge Loop. 

 

   
 
This adds a row of polygons around the outer perimeter of the 
visible area.  With just one polygon visible, the result is an inner 
extrusion.   
 
With the I-Grp and O-Grp modifiers selected, the new polygons 
are also assigned to new groups.  One group is created for the 
center of the loop, and another is created for the outer row.  
(Note: Your colors may be different from what’s shown here.) 
 

� Activate the Crisp modifier. 
 

 
 

� Press Edge Loop again. 
 

 
 
Another edge loop has been added, but thanks to the Crisp 
modifier, it is so narrow that you can’t really see it.   
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� Activate Move on the top shelf, and set the Draw Size to 
a low value like 20.   

 
� Press X on the keyboard to activate X symmetry. 

 
� Move the points for the center polygon to enlarge and 
recess it. 

 

 
 

� Now Ctrl+Shift+Click on a blank part of the canvas to 
restore full visibility. 

 

 
 

� Press divide four times to subdivide and smooth the 
mesh. 

 
� Set PFill on the top shelf to 0 in order to hide the 
polyframe group coloring. 
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 The row of very thin polygons prevents the mesh from being 
smoothed in that area.  The result is a nice, crisp edge.  One 
advantage to this technique is that the low resolution mesh can 
be exported from ZBrush and the crisp edge will remain.  Crisp 
edge loops are a truly cross-application edge weighting method! 
 

� Undo to return to the low resolution mesh. 
 

� Repeat the process for the mouthpiece polygon and what 
will be the number plate on the back. 

 

 
 

� For the mouthpiece, use a regular Edge Loop followed by 
a Crisp one.   

 

 
 

� For the number plate, use just the Crisp loop. 
 

� Also perform a Crisp loop on the three polygons making 
up the base of the mouthpiece area. 
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� Divide the mesh four times. 
 

 
 
The phone is now smoothed overall, but is also still sharp exactly 
where we want it to be. 
 

� Undo to remove the higher subdivision levels, and save 
this model as phone2.ztl. 

 
There’s no point in wasting disk space by saving extra polygons 
when we can quickly add them later.  In this state, the model is a 
mere 64 polygons, and could also be taken into another program 
for use in an animation. 
 

In Conclusion 
This section has given a brief introduction to one of ZBrush 2’s 
advanced geometry tools – the Edge Loop.  Combined with the 
partial mesh visibility controls, edge loops provide a very quick 
and simple way to modify your mesh on a polygonal level.  When 
the Crisp modifier is activated, the result is an edge weighting 
system that controls subdivision smoothing in any application. 
 
This section will be continued in Telephone Part 2, where we will 
use Projection Master to “sculpt” high resolution details.  We’ll 
finally conclude with Telephone Part 3, in which we’ll generate 
displacement and normal maps. 
 
This tutorial is also available as the “Displacement Mapping 
Tutorial” ZScript, found in the Modeling 3D Objects\Displacement 
Maps chapter of the Help browser.  Part 1 of that ZScript shows 
the original ZSphere modelling of the phone, while part 2 shows 
the material covered in this section of the manual. 
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Telephone Part 2 – 
Projection Master 
Here we’ll cover the use 
of Projection Master to 
paint displacements onto 
a high resolution mesh.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
ZBrush 2’s ability to work with exceptionally dense meshes in real 
time provides a powerful way to detail your models – whether 
they will be incorporated directly into a ZBrush scene, or 
ultimately used in an animation package.  While the sculpting 
brushes found in the Transform palette provide a powerful way to 
freehand-sculpt details, they aren’t sufficient for all purposes.  
This is where Projection Master comes in. 
 
Projection Master provides a way to paint textures directly onto 
the surface of your models.  It can also be used to paint depth-
based details that will then be incorporated directly into the 
mesh via displacements.  You can even paint texture and depth at 
the same time! 
 
In this tutorial, we’ll only deal with the displacement side of the 
equation, illustrating how Projection Master makes it possible to 
edit your meshes using any or all of ZBrush’s brushes and 3D 
objects.  Along the way, we’ll explore the uses of alpha’s, various 
stroke types, and even the ability to transform strokes after they 
have been painted. 
 
Note:  This chapter continues where Telephone Part 1 left off, 
and requires the model that was saved at the end of that section.  
If you have not yet worked through Part 1 (or at least run the  
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Helpful tip:  Even as highly 
optimized as ZBrush is, it is still 
possible to reach a number of 
polygons that will make it hard 
for your computer to keep up.  If 
you find ZBrush acting sluggish 
while you rotate the model, 
there are two things that you 
can do to speed up your 
workflow.  First, press Shift+D a 
few times to go to a lower 
subdivision level, then D to 
return to the higher level once 
the model has been rotated into 
its new position.  Lower 
subdivision levels are also an 
ideal time to hide parts of the 
mesh. 
 

associated ZScript and saved the tool at the end of it), please do 
so now. 
 

� Begin by loading the phone2.ztl file that you saved at the 
end of Part 1.  Draw it on the canvas and enter Edit mode. 

 
� Divide the mesh several times until you have 7 
subdivision levels. 

 
The model will now be comprised of 262,144 polygons, which is 
sufficient for our demonstration.  When using Projection Master to 
paint mesh displacements, the quality of your work will be 
directly influenced by the size/number of polygons.   
 

� Turn off the Polyframe view by pressing Shift+F. 
 

� Rotate the model so that it is squarely facing the camera 
and scale it to fit the screen. 

 

 
 
Remember that when the phone is close to the desired 
orientation, you can press Shift to snap it into position. 
 

� On the top shelf, press the Projection Master button. 
 

 
 
The Projection Master (PM) control panel will pop up.  You can 
use this panel to tell ZBrush what you want to do.   
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� Turn off Colors and Fade.  Turn on Deformation. 

 

 
 
When settings are changed, the thumbnails next to the buttons 
update to show the effects of your changes. 
 

� Press the Drop Now button to drop the mesh onto the 
canvas, ready for projection painting. 

 
� PM will display a note asking if you’d like to create a 
texture.  Say yes.   

 

 
 
By default, when PM is first used in a session it selects the 
SingleLayer brush.  That’s perfect for our needs. 
 

� Select the Radial stroke type. 
 

� Select Alpha 06 (a hard-edged circle). 
 

� With a Draw Size of 32, draw a ring of dots on the 
earpiece.   
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� Use Scale and Move to position the ring as shown. 
 

 
 

� Switch to Zsub and set Z Intensity to 50.  Press Shift+S or 
use the Snapshot button on the right shelf to make an 
instance of the holes. 

 
� Use Scale and Snapshot to add two more concentric 
rings. 

 

 
 

� Activate Projection Master and press the Pick Up button. 
 

 
 
While the PM panel is showing, you have a final chance to change 
your settings.  This is useful if you were planning to do one thing 
before dropping the model, but changed your mind and did  
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something different while working with the dropped model.  If 
you wish to skip the PM panel, simply press G to pick up the 
model.  (This keyboard shortcut can also be used to drop the 
model.) 
 
After pressing Pickup, the model will become editable again.  At 
the same time, the depth that was just painted onto the dropped 
model is now incorporated into the actual geometry of the phone.  
You can clearly see this when you rotate the mesh. 
 

� Hide all but the lower ¼ of the model, and then rotate it 
so that the mouthpiece area is squarely facing the camera. 

 

 
 

� Repeat the Drop/paint/Pick Up steps to add another 
group of holes for the mouthpiece. 

 
� Restore full visibility to the mesh. 

 

 
 

� Rotate the model so that the number panel is squarely 
facing the camera.  Drop the mesh again. 
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� This time using the Grid stroke with repeat settings of 3 
x 4, add 12 indentations to the number pad. 

 

 
 

� Snapshot them in place, then change to Zadd and a Z 
Intensity of 90.  Modify the Draw Size to place buttons 
within the indentations. 

 

 
 

� Use PM to pick the mesh up again, then rotate to a side 
view. 

 

 
 

� Drop the mesh.  Use the Line II stroke and Zsub to paint 
four lines onto the side – two for the base, and two for the 
ear/number pad area. 
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Choose the Z Intensity that you like best as you go.  Remember 
that you can transform your strokes after the fact to modify the 
Draw Size.   
 
Any place that the line touches the side of the mesh, be sure to 
extend it past the sides.  This even applies later when using Zadd.  
Projection Master will ignore anything that it doesn’t need when 
the displacements are calculated, and going off the edges ensures 
a nice, uniform projection that wraps all the way around to the 
other side. 
 

� Using the DragRectangle stroke and Zadd with a Z 
Intensity of 27, paint a dot on the base. 

 

 
 

� Snapshot the dot, then use the Move gyro to place more 
along the side of the handle. 

 

 
 

� Switching between stroke types and Zadd/Zsub, add a 
few more details, as well (as shown above). 

 
� Before picking the mesh up again, activate the Double 
Sided option in Projection Master. 

 
This tells ZBrush to apply the displacements to the back of the 
mesh (the side facing away from the camera), as well as the 
front.  When a symmetrical model is positioned squarely along the  
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axis of symmetry, Double Sided provides a quick and easy way to 
maintain the symmetry while using Projection Master. 
 
At this point we can also easily see the effects of the Normalized 
option.  Any place that our painting went off the edges of the 
mesh, the displacements wrapped nicely around to the opposite 
side. 
 

� Rotate the model so that it faces front again and move it 
off to one side of the canvas. 

 

 
 

� Drop the model, and then draw a Plane3D to the left as 
shown. 

 

 
 
For the next step, we need a surface to paint on.  The plane will 
provide that surface, and will be ignored by Projection Master 
when the phone is picked up again. 
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� Using the PaintBrush tool and Zadd with a Draw Size of 
14 and alpha 01, paint a Z on the plane. 

 

 
 
You can use Stroke>Mouse Avg to steady your hand and ensure 
that the letter turns out nice. 
 

� While holding down the Ctrl key, add “Brush”. 
 

 
 
Ordinarily, only the last stroke drawn can be transformed.  
Holding the Ctrl key allows us to chain several strokes together so 
that they can be transformed as a unit. 
 

� Activate the Move gyro and move the word over onto the 
phone. 
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� Rotate and scale the word into position, then switch to 
Zsub. 

 
� If you’re happy with the result, press Q to return to 
regular draw mode, which makes a snapshot of the word. 

 

 
 

� Pick the mesh up again. 
 
The plane will disappear from the canvas while the word is 
projected onto the phone. 
 

� Rotate the model so that the back is facing the camera, 
and drop it. 

 

 
 
Incidentally, it is not necessary to keep the entire model within 
the canvas when using Projection Master.  Only the portion that 
you wish to work on needs to be visible. 
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� Use the Grid stroke and SingleLayer brush to add several 
rows of bumps on the back. 

 

 
 
In our example, we used an array of 3 x 15.  Remember that while 
the gyro is active for transforming the stroke, you can also change 
the alpha that is being used, as well as the Draw Size and Z 
Intensity. 
 

� Pick up the model and rotate it to the side.  Drop it 
again. 

 
� Using the Line II stroke, add a row of dots. 

 

 
 

� Pick up the model. 
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� You’re done!  Save the completed model as phone3.ztl 
so that you can use it for the final part of this tutorial. 

 

 
 

In Conclusion 
In this section we’ve tapped into the awesome power of 
Projection Master to sculpt a variety of high resolution details by 
simply painting them on using ZBrush’s many tools and other 
features.  This process makes it very easy to create details that 
would be extremely tedious – or even impossible – with traditional 
sculpting methods. 
 
The final part of this tutorial will show how to compare this high 
resolution model to the original “cage” model in order to create 
displacement and/or normal maps.  We’ll also cover how to apply 
displacement maps within ZBrush. 
 
This tutorial is also available as the “Displacement Mapping 
Tutorial” ZScript, found in the Modeling 3D Objects\Displacement 
Maps chapter of the Help browser.  Part 3 of that tutorial shows 
the material covered in this section of the manual. 
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Telephone Part 3 – 
Difference Maps 
This section concludes the 
telephone project by 
showing how to use 
ZBrush to process 
Displacement and Normal 
maps. 
 

 
 
While ZBrush 2 is highly optimized to work with figures of up to 
ten million polygons, animation packages can’t handle nearly that 
many.  Also, real time game engines require extremely low 
numbers of polygons.  ZBrush 2 provides the tools to compare 
your high resolution and low resolution models, and generate a 
difference map.  Displacement maps can be used with many 
animation programs, while normal maps are useful in the game 
industry.  Some animation packages can also combine 
displacement and normal maps. 
 
This tutorial will not explain how to use these maps in your other 
software.  You should consult your software’s documentation for 
that information.  Instead, we’ll show you how to generate the 
maps.  We’ll also show you how the maps can be used in ZBrush. 
 
It should be noted that there is no need to create difference maps 
if you’ll be using the model in a ZBrush scene.  ZBrush will 
incorporate the high resolution version as-is. 
 

� Begin by loading the phone3.ztl from the previous part 
of this tutorial. 
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� Draw it on the left side of the canvas, snapshot it, and 
then move another copy over to the right. 

 

 
 
It is not necessary to have two copies on the canvas.  We’re 
simply doing that here for demonstration purposes, so that you 
can clearly see how similar the high resolution version is to the 
displaced low resolution version that we’ll end with. 
 

� Press “T” to enter Edit mode. 
 

� Lower the Sudivision level to 1. 
 

 
 
Sometimes you might want to use a different subdivision level.  If 
you’re using a model that is already being animated in another 
program, though, you will absolutely need to use level 1, 
however, so that is what we’re going to show in this tutorial. 
 

 
 
Here we see the model at level 1.  If you remember what our 
original model looked like, it was quite a bit different.  This is 
because ZBrush interpolates changes made at one subdivision 
level across the other levels.  Under normal circumstances, that  
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would be exactly what we want, but for making a difference map 
we need the original, unmodified mesh. 
 
We have three options available.  Let’s look at each of them in 
turn. 
 

� Press Tool>Geometry>Cage. 
 

   
 
This calculates a cage object that you could export to another 
program.  This option is normally the least desirable of the three, 
however, and should only be used if neither of the next two is 
available to you. 
 

� Turn off Cage. 
 

� Press Load Tool and load the phone2.ztl model. 
 

   
 
By loading the original model back into subdivision level 1, the 
level is replaced by the original geometry.  This is particularly 
useful in a production environment where your animation team 
has already begun working with a model and it cannot be 
changed. 
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The third option requires some pre-planning.  While at subdivision 
level 1, before beginning the high resolution modelling, you would 
press Tool>Morph Target>StoreMT.  This stores the unmodified 
low resolution geometry so that it can be retrieved later. 
 

     
 
Now when you wish to reuse that geometry, you would simply 
press the Switch button to return to it.  In fact, this technique is 
what you will see illustrated if you run the ZScript companion to 
this tutorial. 
 

� Set Texture>Width and Height to 1024.  Press the New 
button. 

 
Displacement mapping requires that the mesh has properly-
assigned UV coordinates.  If it doesn’t, you can apply any of 
ZBrush’s mapping methods or export the base mesh to another 
application for mapping.  When the mesh is imported back into 
subdivision level 1, the mapping will be retained.   
 
Since this model does not already have mapping assigned, we’ll 
do that now.  To give the best quality mapping, you should first 
assign a texture to the mesh.  The best sizes to use are powers of 
2 such as 256x256, 512x512, 1024x1024, 2048x2048 or 4096x4096. 
 

� Press Texture>GUVTiles. 
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GUVTiles is new to Z2, and is an automated mapping system 
designed to let you see details on the unwrapped map.  Like 
AUVTiles, it is a virtually distortion-free mapping method.  Since 
it unwraps the model in the largest polygon groups possible 
without introducing distortion, this mapping method has the 
advantage that you can often do some painting on the unwrapped 
texture should you need to. 
 
If a texture is not already applied to the model when AUVTiles or 
GUVTiles is pressed, ZBrush assumes a size of 1024x1024.  Since 
that is the size of our texture, it wasn’t really necessary for us to 
assign a texture to this model, but it’s good to get in the habit. 
 
We’re now ready to create our maps. 
 

� Set Tool>Displacement>DPRes to 2048. 
 

� Activate Adaptive and SmoothUV, if you wish. 
 
These are not necessary in our example, but are important to use 
if any of your sculpting has used the Nudge or Pinch editing 
brushes from the Transform palette.  It takes slightly longer to 
calculate than a map created without it. 
 

� Click the Create DispMap button. 
 

 
 
The new map will be added to the Alpha palette. 
 

� Open the Tool>NormalMap menu and activate Tangent.  
 
Again, Adaptive and SmoothUV may also be activated. 
 

� Set NMRes to 2048. 
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� Click CreateNormalMap. 

 

   
 
The normal map will be generated, added to the Texture palette, 
and assigned to the model. 
 
ZBrush provides a variety of options for normal maps, to 
accommodate your particular rendering engine.  For example, if 
the Tangent switch had not been activated, then the map would 
have been calculated for World space instead. 
 

 
 
Also, the Preferences>Importexport menu contains five switches 
for flipping maps when their generated.  Use these to make sure 
that ZBrush’s maps match your rendering engine’s needs. 
 
If you’re going to be using another program to render your model, 
then you’d now be done! 
 

� Press Texture>Export to export the normal map if you 
need it.   

 
You have a choice of formats, including BMP, PSD, TIFF, and (for 
Mac users) PICT. 
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� Select the displacement map from the alpha popup 
menu. 

 

 
 
The popup is structured so that your custom content appears in a 
separate section beneath the other thumbnails. 
 

� Export the alpha. 
 
That’s all there is to creating difference maps for use in other 
programs!  The rest of this section will show how to use a 
displacement map in ZBrush. 
 
If ZBrush 2 can work with extremely dense models, why would you 
wish to use displacement maps?  Well, there are a few reasons.  
Maybe you are importing a displacement-mapped model from 
another program for use in a ZBrush scene.  Maybe you wish to 
refine a map that you’ve already created.  Or maybe you simply 
wish to conserve disk space, and so prefer to only keep the low 
resolution versions of your models, with their displacement maps.  
Along the same lines, you might have a friend who wishes to share 
his model with you; it’s easier to send a level 1 model with a 
displacement map than a level 7 model. 
 
Whatever your reasons, ZBrush provides an easy way to use 
displacement maps, which we’ll cover here: 
 

� If you would like to see what the alpha looks like on the 
model, press Alpha>Make Tx. 

 

 
 



ZBrush 2 Practical Guide                                                                                  Telephone Part 3 – Difference Maps 201 

 

The new texture will automatically be applied to the model.  
There’s not really a need to do this, but sometimes it’s nice to 
see. 
 

� Press Texture>Clear. 
 
In order for a displacement map to be viewed in ZBrush, the 
model must have a texture assigned to it.  We’ve cleared the 
texture because we wish to demonstrate how displacements alone 
can allow a low resolution model to match its high resolution 
“brother.” 
 

� Press Tool>Geometry>Del Higher. 
 

 
 
We now have the exact model that you would be working with if 
you’d imported it from another program or were starting fresh 
without having saved the high resolution version. 
 
In other programs, you’d use this model as a subdivision surface.  
The cage object would then appear to have more polygons than it 
really does.  We need to simulate that effect. 
 

� Press Tool>Geometry>Divide three times. 
 

 
 
The model is now comprised of 4096 polygons, which is probably 
equal to what an animation package would use. 
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� Make sure that the displacement map is the current 
alpha. 

 

 
 

� Turn off Quick 3D Edit. 
 

 
 
ZBrush’s displacement rendering requires render-time mesh 
smoothing, which is disabled by Quick mode.  
 

� Set Tool>Display Properties>DSmooth to 1. 
 

 
 
This activates render smoothing.  Each of the polygons is divided a 
few times when the model is rendered.  How many times is 
determined by the Dres setting. 
 

� Note the value of the Alpha Depth Factor slider, found at 
the bottom of the Alpha palette. 

 

 
 
In this case, the value is .0562.  This number will only have 
relevance if the displacement map was created by ZBrush.  For 
maps imported from other applications, you’d have to experiment 
to find the correct value to use in our next step: 
 



ZBrush 2 Practical Guide                                                                                  Telephone Part 3 – Difference Maps 203 

 

� Back in the Tool>Displacement menu, set Intensity to the 
Alpha Depth Factor value. 

 

   
 
This slider tells ZBrush how strongly to apply the map.  At the 
moment, it’s only being applied as a bump map, however.  This 
means that pixols are only being displaced along the world Z axis.  
This changes the appearance of the model, but does not change 
its profile. 
 
In short, ZBrush 2 offers two ways to add bump to your models.  
The first is the Color Bump material modifier, already familiar to 
experienced ZBrush users.  Alternatively, a bump map can be used 
that will operate independently from the model’s colors or 
texture.  This lends even greater realism to your work. 
 

� Also in the Displacement menu, activate the Mode 
switch. 

 

   
 
This switches ZBrush from rendering the displacement map as 
bump to full displacement. 
 
If you look closely at the model, you will see that the quality of 
the displacements is good, but not perfect.  This is because the  
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number of rendered polygons is still lower than the high 
resolution model that was used to create the map.  It’s also easy 
to compensate for. 
 

� Set Tool>Display Properties>DRes to 6. 
 
This subdivides the mesh a few more times at render time, 
resulting in a finished render that is almost indistinguishable from 
the high resolution model. 
 
Obviously, what you’re seeing here is a render-time effect applied 
to a low resolution model.  What if you wanted to continue to 
sculpt this model as a high resolution figure?  After all, every time 
you click on the model, the smoothing is deactivated and the 
displacement effect along with it. 
 

� Divide the mesh three more times to reach subdivision 
level 7. 

 
The model is now comprised of as many polygons as the original 
high resolution version. 
 

� Click Tool>Displacement>Apply DispMap. 
 

 
 
This button converts the details created by the displacement 
effect back into being a part of the actual mesh.  It’s sort of like 
applying Projection Master to your entire model, all at once.  It 
also sets the displacement intensity back to 0, but your mesh will 
not appear to change. 
 

� Activate Quick 3D Edit again. 
 
This turns off all smoothing.  Your mesh still looks exactly like the 
high resolution version still on the left side of the canvas.  The 
displacement map has been applied as actual geometry, and you 
can now continue to sculpt on the mesh or use Projection Master,  
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just as if you’d never gone through the displacement process to 
begin with. 
 

In Conclusion 
ZBrush 2 provides an incredibly fast and efficient method to 
create high resolution versions of your models and generate 
difference maps from them.  This technique eliminates the need 
to create and scan clay sculptures in order to create high quality 
maps, thus saving tremendous time and money.   
 
Modifiers are available to fit the needs of your rendering 
software.  In addition, ZBrush 2 can not only render displacement 
maps, but can actually transform their detail back into being a 
part of the high resolution mesh.  This makes it possible to edit 
the high resolution model further, and provides an alternative to 
having to fill up hard drive space by always saving the high 
resolution version of your models. 
 
This tutorial is also available as the “Displacement Mapping 
Tutorial” ZScript, found in the Modeling 3D Objects\Displacement 
Maps chapter of the Help browser.  Part 4 of that tutorial shows 
the material covered in this section of the manual. 
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ZSphere Insertions 
ZBrush 2 provides ways to 
insert other meshes into a 
ZSphere figure.  This 
provides yet another way 
to easily build complex 
figures from simpler 
parts. 

 

 
 
In this section, we’ll work on a ZSphere model of a scimitar.  
While the overall shape has been defined by the ZSpheres, and it 
would be a relatively simple matter to sculpt certain details into 
the skinned mesh, Z2 offers a different method.  What we will do 
is create a few elements from primitives, then insert them into 
the ZSphere figure.   
 

� Begin by loading the Scimitar.ztl from the manual 
resources folder, and draw it on the canvas. 

 

 
 
This figure uses a combination of regular ZSpheres to build the 
base shape, which is then modified by Attractor ZSpheres to pull 
the mesh in places (such as to create the blade). 
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� While in Edit mode, press A on the keyboard to preview 
the mesh. 

 

 
 
This is what we’d get if we simply skinned the mesh right now.  
What we’d like to do though is create a fancier hilt and details for 
the hand guard. 
 

� Press A again to deactivate the preview.  Exit Edit mode, 
and clear the canvas. 

 
� Select the Helix3D tool and draw it on the canvas.  Enter 
Edit mode. 

 

 
 
We’re going to use this tool to create a hilt. 
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In the Initialize menu, open the Radius curve. 
 

 
 
This curve is what causes the bulge in the middle of the helix.   
 

� Remove the center point. 
 

      
 

� Change Coverage to 16. 
 

 
 
The path of the helix now makes 16 rotations rather than 8 along 
the same length.  This packs them more tightly and creates and 
interesting “wrapped” effect. 
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� Apply a Twist deformation three times at a value of -100. 
 

 
 
We now have what looks like very intricate wrapping with leather 
or cord. 
 

� Save the model as Hilt.ztl 
 
Our hilt is now complete. 
 

� Draw another Sphere3D and enter Edit mode. 
 

� Rotate it so that the poles are to the left and right. 
 

 
 
Hold down the Ctrl key and drag two rectangles to mask the 
poles. 
 

 
 

� Press Masking>Create Alpha to store this mask. 
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We’ll want to return to the unmodified mask later.  Rather than 
trying to exactly duplicate it by hand, it’s much easier to turn it 
into an alpha. 
 

� Also in the Masking menu, set Sel to 3 and Skp to 1.  
Press Row, then Inverse. 

 
� Apply an Inflat deformation at -20. 

 

 
 

� Press Masking>Alp to apply the currently selected alpha 
as a mask. 

 
This is the alpha that we just created a few steps ago. 
 

� Apply Inflat at -50. 
 

� Invert the mask. 
 

� Set Sel to 1, then press Grd. 
 

 
 
This creates a checker pattern.   
 

� Invert the mask again, then do a Size XY deformation 
with a value of 5. 
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� Clear the mask. 

 

 
 

� Activate Transform>Z to turn on symmetry along the Z 
axis, then press R to make it radial.   

 
The default RadialCount of 8 will work fine. 
 

� Activate Transform>Smooth. 
 

� Set the Draw Size to 60. 
 

� Smooth out a portion of the mesh around the equator. 
 

 
 
Due to symmetry, you’ll get 8 small patches, equally spaced. 
 

� Change to Transform>StdDot. 
 

� On the top shelf, change Focal Shift to -60.  Activate 
Zsub, and change the Z Intensity to 100. 
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� Click on the sphere and drag your indentation to the 
center of the smoothed area. 

 

 
 
The great thing about StdDot is that you are able to place your 
edit with great precision. 
 

� Change to Zadd and a Draw Size of 30. 
 

� Place a dot in the center of each indentation. 
 

 
 

� Save your model as Bead.ztl. 
 
Now that we’ve finished the various elements that will be 
incorporated into the scimitar, we’re ready to return to the 
ZSphere model. 
 

� Draw the scimitar on the canvas and enter Edit mode. 
 

� Make sure to set the Focal Shift back to 0.  Also, since 
we’re working with ZSpheres change the Draw Size to 1. 

 
� Press X and Y on the keyboard to activate XY symmetry. 
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� Place your model so that you can easily see the basket. 

 

 
 
What we want to do is replace the four beads along the edge of 
the basket with our Bead.ztl model.   
 

� Press W to switch to Move mode. 
 
This allows us to select an individual ZSphere by clicking on it, 
rather than adding a new ZSphere to the model. 
 

� Move the pointer close to one of the beads.  When a red 
circle outlines the ZSphere that you want, click once to 
select it. 

 

 
 
The selected ZSphere will turn red. 
 

� Press Tool>Adaptive Skin>Insert Local Mesh. 
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 You’ll be given a popup menu that contains all of the currently-
available 3D objects. 
 

� Select the Bead.ztl model. 
 

 
 
The selected ZSphere is immediately replaced by the model.  The 
bead will be oriented so that its Z axis passes through the 
ZSphere’s Z axis (the line connecting the ZSphere to its parent. 
 
You can now move, scale and rotate the inserted mesh just as you 
would any ZSphere. 
 

 
 
Here is a preview of the model with the inserted mesh. 
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� Select the pommel ZSphere. 
 

 
 

� Insert another local mesh, this time selecting the Cone3D 
primitive.  Preview the mesh. 

 

 
 
Each inserted mesh is given its own group.  This will make it easy 
later to select just this part if we wish to further modify it after 
the model has been skinned. 
 

� Point to the linking spheres in the second hilt segment. 
 

 
 
There will be an orange square at the pointer, to indicate that 
you’re about to affect a linking sphere.  There is also a yellow line 
going from the pointer to a yellow circle.  This is meant to point 
out the ZSphere that will be selected if you click the mouse.  This 
is extremely useful in instances like now, because the ZSphere 
that we wish to select is inside another one! 
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� Click to select this ZSphere. 

 
� Click Tool>Adaptive Skin>Insert Connector Mesh. 

 
� Select the Hilt.ztl object. 

 

 
 
The Insert Connector Mesh option allows to insert a model into 
the selected span of linking spheres.  It stops at the next ZSphere, 
which in this case gets us only halfway up the hilt.   
 

� Preview the mesh. 
 

 
 
There is a problem where the hilt joins to the pommel.  This is 
easily resolved by changing the ZSphere structure slightly. 
 

� Turn off the preview, then press Ctrl+Z to undo the 
mesh insertion. 

 
� Add another ZSphere along the chain of linking spheres. 
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� Insert your connector mesh. 
 

 
 
You’ll actually get two copies of it inserted – one on either side of 
the selected ZSphere. 
 

� Delete that second one by switching to draw mode and 
Alt+clicking on it. 

 

 
 

� Now move the ZSphere forming the end of the 
connecting mesh up into the large ZSphere.   

 

 
 
The connector mesh will overlap the smaller ZSphere that is still 
there. 
 

 
 
The preview should look something like what you see above. 
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� Delete ZSphere halfway along the hilt by switching to 
draw mode and Alt+clicking on it. 

 

 
 
This extends the connector mesh along the length of the hilt. 
 
Now all that’s left is to clean things up a bit.  You can do this by 
resizing the hilt ZSpheres a bit so that the inserted mesh is more 
proportional to the rest of the model. 
 
One thing that you may notice is that the inserted meshes have a 
much higher resolution than the parts created by ZSpheres.  The 
pre-divide feature is meant to compensate for this. 
 

� Set Tool>Adaptive Skin>Pd to 3. 
 

� Preview the mesh. 
 

 
 
The pre-divide feature does not modify the density of the inserted 
meshes.  It only increases the density of the parts specifically 
created by ZSpheres. 



ZBrush 2 Practical Guide                                                                                                            ZSphere Insertions 219 

 

In Conclusion 
ZSpheres – already a powerful modelling tool before ZBrush 2 – 
have been made even more versatile by including the ability to 
insert meshes that replace either ZSpheres or linking spheres.  
Any 3D object can be inserted into your mesh; even imported 
meshes or skins created by other ZSpheres.  Once inserted, each 
mesh can be modified as if it was a part of the ZSphere structure.  
This includes rotating, scaling and moving models. 
 
For a ZScript tutorial on this subject, activate the Help browser 
and go to the Modeling 3D Objects\ZSpheres: Adaptive Skinning 
section.  Run the ZSphere Insert Meshes tutorial found at the 
bottom. 
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Warrior Part 1 - 
ZSpheres 
By J.S. Rolhion 
In this section, we’ll use 
ZSpheres to create a base 
mesh that will be refined 
in the following sections. 

 
 

� If this is not a fresh ZBrush session, initialize ZBrush 
(Preferences>Init ZBrush). 

 
� Select the ZSphere tool. 

 
� Holding down the Shift key, draw the ZSphere on the 
canvas. 
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By holding down the Shift key, you constrain ZBrush to draw the 
object “squarely” on the canvas.  It will be oriented so that X is 
perfectly horizontal, Y is vertical, and Z is directly facing the 
camera. 
 

� Press Transform>Edit Object. 
 

 
 
This allows you to sculpt the most recently drawn object – in this 
case, the ZSphere. 
 

� Press S and change the Draw Size to 1. 
 
This step is very important when working with ZSpheres.  Larger 
draw sizes can cause you to affect more than one ZSphere at a 
time, which is usually undesirable. 
 

� Also in the Transform palette, click on X Symmetry. 
 

 
 
Now all edits made to one side of the model will be duplicated on 
the other side. 
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The small circles indicate the future positions of ZSpheres.  They 
turn green when the positioning is ideal, but that is not always 
important.  Don’t worry about it for the purposes of this tutorial.  
Also, the red line is drawn from your pointer’s position to the 
center of the ZSphere that would be affected by clicking at the 
pointer’s current location. 
 

� Click and drag to add two new ZSpheres as shown: 
 

 
 
The red ZSphere is the one that you actually draw, while 
symmetry also draws an identical ZSphere on the other side.  
White lines show the parent/child relationships for the currently-
selected (red) ZSphere. 
 

� Rotate the object by clicking and dragging on a blank 
part of the canvas. 
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 � Switch to Edit>Move mode. 
 

 
 
The keyboard shortcut for this is W. 
 

� Click and drag on the new ZSphere to move it slightly 
away from its parent. 

 

 
 

� Activate the mesh preview by pressing A. 
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� Change Tool>Adaptive Skin>Density to 4. 
 

 
 
This greatly increases the number of polygons in the preview 
mesh.  It also increases the number of subdivision levels that a 
skin created from this model would have.  Density of 4 means that 
the skin would have 4 subdivision levels. 
 

� If the preview looks like the image above, your ZSpheres 
are positioned correctly.  If not, adjust them as needed by 
pressing A, moving ZSpheres, and then reactivating the 
preview until the mesh looks correct. 

 



ZBrush 2 Practical Guide                                                                                                  Warrior Part 1 - ZSpheres 225 

 

� Press A to return to the ZSphere view. 
 

� Activate Edit>Draw mode by clicking on the Draw Pointer 
button or pressing Q. 

 

 
 
You must be in Draw mode to add ZSpheres to the model. 
 

� Create a new ZSphere for the armor’s torso. 
 

 
 
To draw a single ZSphere, move your pointer so that the two red 
circles overlap.  When they become one circle, this indicates that 
a single ZSphere will be created, exactly centered along the 
model’s axis. 
 
For this ZSphere, try to get the circle to turn green before you 
click and drag.  
 

� Create another small ZSphere for the neck. 
 

 



ZBrush 2 Practical Guide                                                                                                  Warrior Part 1 - ZSpheres 226 

 

 � Move the ZSphere slightly forward of center. 
 

 
 
You can try different moves and then see the result by pressing A 
to activate the preview. 
 
To help get the proper positioning, don’t hesitate to rotate your 
model.  You will often find that it is beneficial to work from one 
of the “planar” views.  Rotate the object so that it is close to the 
planar orientation, then hold down the Shift key to snap it into 
position. 
 

� Move the neck ZSphere into the main structure.  You’ll 
know that its position is correct when it becomes semi-
transparent. 

 

 
 
When a ZSphere is inset into its parent, its effect on the mesh 
changes.  Instead of adding to the mesh’s mass, it creates an 
indentation. 
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� Activate the preview, then set the density to 3. 
 

 
 
While ZSphere meshes can be created with any density up to 8, 
lower numbers of polygons are usually better, as they allow 
broader-scale control over your mesh. 
 
Your preview should be close to this: 
 

 
 

� When satisfied, deactivate the preview and then return 
to Edit>Draw mode so that more ZSpheres can be added. 

 

 
 

� Draw arm ZSpheres from the base of the shoulders. 
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� Like with the neck, press W to switch to Move mode and 
then inset these new ZSpheres into their parents. 

 

 
 

� Return to Draw mode.  Click on the first linking sphere 
connecting the chest ZSphere to the shoulder. 

 

 
 
Clicking on a linking sphere while in Edit>Draw mode converts it 
into a ZSphere.  By adding a new ZSphere so close to its parent 
and child, we force a crease to appear in the mesh as shown: 
 

 
 

� With the preview active, change to Move mode. 
 

� Increase your Draw Size to about 100.  The cursor should 
be slightly larger than the waist ZSphere. 
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While the preview mesh can be 
sculpted, it is important not to do 
so until you are sure that you 
will not be adding additional 
ZSpheres or otherwise changing 
the structure of the ZSphere 
figure.  If you were to make a 
change to the ZSphere structure 
that caused the number of 
vertices in the preview to 
change, your sculpting would be 
lost. 
 
 
 
 
 
 

� Click on the bottom of the mesh and drag to move the 
center polygons up inside of the figure. 

 

 
 
There are other ways that you could achieve this same result, 
such as by adding another inset ZSphere.  We’re using this 
technique instead to show that you can sculpt the preview mesh, 
even without skinning the model. 
 

� Rotate to a side view and refine the shape further. 
 

 
 

� Now increase the mesh density to a value of 5. 
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Now that the basic shape of the mesh is finished, it’s ok to add 
more polygons to it.  This will allow finer detail to be created in 
the next section. 
 

� Press Tool>Save As and save your model as 
ArmorPart1.ztl 

 

In Conclusion 
ZSpheres provide a very fast and easy way to create a wide 
variety of shapes.  All you need to do is block out the shape that 
you want by creating a skeleton of linked ZSpheres, and ZBrush 
will then create a nicely-organized mesh around the structure.  
You can preview this mesh at any time, and even sculpt the 
preview on a polygonal level.  For more information on ZSphere 
modeling, including the use of Attractors (magnet ZSpheres), be 
sure to review the ZScript documentation and tutorials included 
with ZBrush. 
 
In the next section, we will add details to the armor using the 
mesh-level editing tools that are at our disposal. 
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Warrior Part 2 - 
Sculpting 
By J.S. Rolhion 
In this section, we will 
explore ZBrush 2’s new 
editing tools to further 
refine the shape of our 
mesh. 
 

 
 
The Transform Brushes provide a really powerful way to obtain 
precise results when adding details to a mesh figure.  You’ll find 
them in the Transform palette. 
 

 
 
Std is the Standard brush.  It moves points away from the surface 
along a single direction.  This direction is determined by the 
surface normal at the center of the brush’s area of influence. 
 
StdDot is similar to the Std brush, except that it only draws a 
single “bump.”  This bump can be dragged across the surface until 
you are satisfied with its position. 
 
Inflat has an effect that can be very similar to Std, or very 
different depending on where you use it.  Every point within the 
brush’s area of effect is moved according to its own normal.  On 
mostly flat areas, this effect is indistinguishable from Std, but in  
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places where the polygons have very different orientations this 
brush has the effect of infating the edited area. 
 
IflatDot allows precise placement of an inflated bulge by allowing 
you to drag the inflated area around before releasing the mouse. 
 
Layer raises the polygons in a single hard-edged layer.  The effect 
is similar to the Single Layer tool when painting in 2.5D, but works 
on a fully 3D polygonal level. 
 
Pinch pulls nearby polygons toward the center of the edited area.  
This is very useful for creating creases or sharpening edges. 
 
Nudge pushes vertices along the object’s surface.  This is useful 
for refining edge loops and the overall “flow” of polygons. 
 
Smooth is used to soften edits that have been made to the 
surface of a model by averaging the points within its area of 
influence.  Taken to an extreme, it can erase edits that have been 
made to portions of a mesh. 
 
Many brushes can also be reversed by holding down the Alt key.  
For example, Std normally adds depth to a surface but by holding 
down Alt it can cut into the surface instead. 
 
Each brush has its own Z Intensity settings. 
 
Last of all, the Shift key by default activates the Smooth brush.  
You can change this by holding Shift while activating any of the 
other editing brushes.  Shift will then activate that brush instead. 
 
Let’s start putting this into practice. 
 

� If you are starting a new session, press Tool>Load Tool 
and select ArmorPart1.ztl.  Draw it on the canvas and press 
T to enter Edit Mode. 

 
Make sure that Edit>Draw is active, like in the illustration above.  
Also make sure that X Symmetry is still active. 
 

� Set your Draw Size to 39, and Z Intensity to 25. 
 

� Paint additional detail onto the model to build up the 
neck and chest. 
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While working, you can change your Draw Size and Z Intensity.  Be 
sure to add details to every side of the mesh.  You may also at 
times want to hold down the Alt key to chisel into the mesh 
rather than building up detail. 
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 These tools are very intuitive, since they are much like traditional 
sculpture.  They are extremely useful for organic shapes.  Of 
course, armor is usually very sharp along edges and intersections.  
ZBrush can accommodate this need, as well. 
 

� Activate the Pinch brush. 
 

 
 

� Choose a Z Intensity of 40 and a Draw Size of 25. 
 

� Draw on the areas where you wish to make harder 
edges. 
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As you can see, this brush directly sharpens area where we 
originally had an organic look that was not realistic enough for 
this armor. 
 
You should experiment with different Z Intensity and Draw Size 
settings to really get a feel for this brush, or to achieve different 
results.  Feel free as you work to alternate between Std and 
Pinch. 
 

� Press Tool>Adaptive Skin>Make Adaptive Skin. 
 

      
 
This creates a new object in the Tool palette, which starts with 
“Skin” for the object name.  This new mesh is no longer tied to 
the ZSpheres that were used to generate it, and is a discreet 
polymesh object. 
 
You could actually continue to work with the model while it’s 
connected to the ZSpheres.  While this is useful if you plan to 
animate the finished figure in ZBrush, it’s not necessary for a 
project such as this still scene.   
 

� Save the model as ArmorPart2a.ztl. 
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It’s always wise to save your work in case you wish to return to 
the ZSphere model later for some reason. 
 

� Press T to exit Edit Mode, then Ctrl+N to clear the 
canvas. 

 
We do this because the ZSphere version of the model is still on 
the canvas.  ZBrush is programmed to work this way, since it 
allows you to change the model and create additional skins if you 
wish.  For our purposes, though, we want to switch to the skin 
object instead of the ZSphere model, so we need to remove the 
ZSphere figure from the canvas. 
 
Place your pointer over the thumbnail for the skin object.  A 
popup will appear with information about the mesh, including the 
number of polygons, points, groups, etc.  This information can be 
very useful. 
 
When creating a skin using the Make Adaptive Skin button, ZBrush 
also keeps the mesh’s subdivision levels.  This means that you 
could actually make broad-scale changes to your mesh by going to 
a lower subdivision level and moving a few points, then return to 
the higher level without losing the detail that has been sculpted 
so far.  We’ll make use of this feature later.   
 

� Select the skin object and draw it on the canvas. 
 

� Press T to enter Edit Mode. 
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� In Tool palette, click on Geometry to open the Geometry 
menu. 

 
� Press Divide. 

 

 
 
Dividing the mesh quadruples the number of polygons.  More 
polygons make it possible for finer details to be added to the 
mesh.  The number of times that you can divide the mesh is 
ultimately dependent on the amount of RAM that your system has 
and the processor speed. 
 
Dividing also adds a new subdivision level in the top section of the 
Geometry menu.  You can then use the Lower Res button to 
temporarily decrease the number of polygons and Higher Res to 
increase it again. 
 

� Select the Intensity Metal material. 
 

 
 
While the Fast Shader material allows slightly faster mesh 
interaction (especially at really high polygon counts), it is also 
beneficial to be able to see what the figure will look like with a 
metallic material. 
 



ZBrush 2 Practical Guide                                                                                                 Warrior Part 2 - Sculpting 238 

 

 
 

 
 
You can create your own material by changing the modifiers, but 
for this tutorial the standard Intensity Metal is perfect. 
 

� Select Transform>InflatDot 
 

� Set the Draw Size to 10. 
 

� Click on the surface of your model.  Drag the raised dot 
to where you want it, then release the mouse. 

 

 
 
Feel free to put these dots anywhere you like to add visual 
interest to the armor. 
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As you can see, this is a very fast and easy way to create detail! 
 

� Use varying Z Intensity settings to modify achieve 
different effects. 
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When you’re done, the armor should look something like the 
image below (depending on how much detail you’ve chosen to 
add). 
 

 
 

� Save the tool as ArmorPart2b.ztl 
 

In Conclusion 
In this section we’ve created a skin from our ZSphere model and 
experimented with several of the sculpting brushes to refine the 
look of our armor.  These techniques allow us to sculpt the figure 
in a very intuitive way, working with the model as if it’s made of 
clay. 
 
In the next section, we’ll add more details in a different way:  
using Projection Master. 
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Warrior Part 3 – 
Projections 
By J.S. Rolhion 
In this section we’ll finish 
the armor chest plate by 
using Projection Master to 
paint detail onto the 
model.  We’ll also cover 
the subjects of texturing, 
lighting and rendering. 
 

 
 
In part 2 we saw how to create the base mesh for the armor 
through modelling.  But what about when you wish to add detail 
that cannot be achieved through the editing brushes? 
 
ZBrush offers an innovative solution called Projection Master.  
Using this utility, you can literally paint details onto the model, 
using any or all of ZBrush’s 2.5D painting tools – even other 3D 
objects! 
 
UV mapping will also be assigned to the model, which can be used 
for texturing or for export to other applications. 
 

� If it is not already active on the screen, load 
ArmorPart2b.ztl and draw it on the screen.  Enter Edit Mode 
by pressing the T key. 

 
� Hold down the Shift key and rotate the model so that it 
is exactly facing you. 
 
� Ensure that the model is at least subdivision level 7.  If 
you don’t have enough subdivision levels, add another by 
Dividing the mesh. 

 
Projection Master will project anything you paint directly onto the 
mesh below.  Because of this, it is important to position your 
model so that the area that you will be working on is facing the 
camera as directly as possible. 
 

� Click the Projection Master icon on the top shelf. 
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The following popup menu will open: 
 

 
 
You are presented with a panel showing the various Projection 
Master options.  The top section is for painting textures while the 
bottom section is for projecting displacements.  As you click on 
the check boxes, the preview to the right will update to show the 
effect that your selection will have. 
 

� Activate the options shown above (Colors, Material, 
Fade, Deformation and Normalized). 

 
� Click Drop Now. 

 
ZBrush will snapshot the model to the canvas.  This prevents the 
model from being rotated until you use Projection Master to pick  



ZBrush 2 Practical Guide                                                                                              Warrior Part 3 - Projections 243 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Projection Master functions best 
when the texture dimensions 
are a power of 2.  These 
include:  256x256, 512x512, 
1024x1024 (the default), 
2048x2048, or 4096x4096. 

it up again, but it also enables all of ZBrush’s other tools.  This 
opens up possibilities beyond what can be achieved with the 
Transform palette alone. 
 
Since a texture has not yet been created for this model, 
Projection Master will prompt you with a warning window. 
 

 
 

� Click the “Create a texture and continue” option. 
 
This instructs ZBrush to create a texture at the default size of 
1024x1024.   
 
If you wanted to work with a different size, you would cancel 
projection instead and create a texture.  First, you would need to 
set the desired width and height in the Texture palette.  Next, 
click New.  Finally, open Tool>Texture and select the UV mapping 
that you would like to use (unless you’re working with an 
imported model that already has mapping applied). 
 

 
 
Since the model cannot be rotated while you are working on it, a 
full mesh texturing needs to be done in parts, over the course of 
several drop and pick cycles.  You will usually find that it works 
best to paint the entire model with one step before moving on to 
the next.  For example, paint a base texture across the entire 
model (using several drops and picks).  Next paint the next level 
of detail onto the entire model.  Then proceed to the next level 
of detail, etc.  This makes it easy to keep your work consistent 
across the entire model. 
 

� Choose the Single Layer brush. 
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� Choose alpha 08. 
 

� Choose the Spray stroke. 
 

 
 

� Set Zsub with a Z Intensity between 5 and 10, and a 
Draw Size between 10 and 15. 

 

 
 

� Begin texturing by painting details like you see on the 
example below.   
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Feel free to experiment with different alphas, Z Intensity 
settings, and Draw Sizes to create naturalistic results. 
 

� Choose the Simple Brush 
 

� Select alpha 52 
 

� Choose the DragRect stroke. 
 

      
 

� Activate Zadd and set the Z Intensity to 25 
 

 
 

� Click and drag on the mesh to create a large sunburst. 
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Remember that after drawing the stroke, you can use the gyro to 
move and scale it for the best positioning. 
 
Note that for this tutorial, we are using the alphas that have been 
included with ZBrush.  If you wish, you can modify them using the 
Focal Shift slider and Alpha Adjust curve.  You can also create or 
import your own to create custom brushes and personalize the 
armor. 
 
As you can see, you can obtain a very high level of detail using the 
various brushes, alphas, and stroke types.  Feel free to add as 
many details as you wish. 
 

� Click the Projection Master button again. 
 

 
 
The Projection Master panel will open once more.  It will be 
exactly like you last saw it, except that Drop Now has changed to 
Pickup Now.   
 
At this point, you can change your settings if you find that your 
creativity took you in a direction that you hadn’t anticipated.  In 
our example, we did not paint any colors or materials onto the 
model. 
 

� Deselect Colors and Material. 
 
Of course, your own experimenting might have led you to use 
color and/or material.  If that’s the case, then you should modify 
the settings appropriately. 
 

� Press Pickup Now. 
 
At this point, ZBrush will return the model to Edit Mode, ready for 
you to rotate it to a new position or do anything else that you 
like.  In the process, all of the details that you have painted while 
it was dropped will be transferred onto the model.  In the case of 
depth details, they will be incorporated directly into the mesh 
geometry. 
 
The quality of this projection displacement will depend upon the 
number of polygons that your model has.  More polygons mean the 
ability to paint finer levels of detail. 
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� Rotate the model to take a look at your work. 
 

 
 
As you can see, all painted depth has literally become a part of 
the mesh. 
 

� Repeat the Projection Master steps from several 
different angles to add details to the entire mesh.  

 

 
 
Feel free to use different colors and alphas to get a variety of rust 
effects and produce a truly aged, beaten look.  Various Z Intensity 
and Rgb Intensity settings will also lend realistic randomness to 
your work.  The more time you put into this step, the more 
compelling your finished scene will be! 
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Regarding Rays and Aperture:  
The more rays you use, the 
more realistic your shadows will 
be (at the price of longer render 
times).  More rays also makes 
the shadows softer, and you 
should lower generally lower the 
Aperture setting to compensate. 
 
 
 

Now that texturing and painted displacements are complete, we 
are ready to take a look at some of ZBrush’s lighting and 
rendering options. 
 
Lighting in ZBrush is very powerful.  Different options are 
available, such as colored lights, light intensity, light type (Sun, 
Point, Spot, Glow, Radial), very precise placement, and raytraced 
shadow options. 
 

� Duplicate the settings below, or feel free to modify 
them. 

 

      
 
If you wish to learn more about any setting, hold down the Ctrl 
key and place the pointer over it. 
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 � Rotate the model into a position that you like, then exit 
Edit Mode (press T). 

 
While ZBrush can do a Best render while a model is in Edit Mode, 
ZBrush will only render the model and a bounding box surrounding 
it.  To render the entire scene, Edit Mode must be off. 
 

� Turn Render>Shadows on. 
 
This tells ZBrush to render shadows when a Best render is 
performed. 
 

� Turn SoftZ and SoftRGB on.  Set the Antialiasing 
adjustments as shown. 

 

 
 
This will give a higher quality to the Best render. 
 

� Press the Best button to render the scene. 
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While it certainly took you longer to work through this tutorial 
because you are still learning ZBrush and also had to read and 
follow the steps, I’d like to say that I created this whole 
breastplate in 30 minutes, including rendering.  A “classic” 
workflow (using the other modeling packages on the market) 
would have taken a little bit longer.  ☺ 
 
If you are using the model within a ZBrush scene (like we will do 
later in this tutorial), there is nothing more that you need to do. 
 

� Save your model as ArmorPart3.ztl. 
 
However, if you are planning to use the model in an animation 
package, it would be a simple matter to create a displacement 
and/or normal map, and then export a cage object from ZBrush as 
an OBJ.  Displacement and normal maps are really powerful when 
exported to other applications, and enable you to keep all these  
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wonderful details while working with a much lower resolution 
mesh.  Bear in mind that the quality of the finished work will 
depend on how your rendering engine implements such features.   
 
Creating displacement and normal maps is covered in another 
chapter of this manual. 
 

In Conclusion 
This section of the armor tutorial has given us hands-on 
experience with texturing and painting displacements onto a 
mesh.  Once a model has been dropped to the canvas, ALL of 
ZBrush’s tools become available for use, including meshes that 
have been imported from other sessions or programs.  This 
provides an extremely fast and powerful approach for adding high 
resolution detail to your meshes, which in turn results in far more 
compelling renders. 
 
Part 4 of this tutorial will practice the techniques that have been 
learned in these three lessons by creating an upper arm to go with 
the breastplate. 
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Warrior Part 4 – 
Upper Arm 
By J.S. Rolhion 
In the last three sections, 
we learned how to use 
ZSpheres to create a 
simple mesh and then 
detail that model through 
the combined use of 
ZBrush’s editing brushes 
and Projection Master.  In 
this section, we will 
practice those techniques 
by creating another piece 
of armor to be used in the 
finished scene. 
 

 
 
In this section, we’ll begin with ZSpheres, and then go all the way 
through mesh sculpting and projection painting.  Let’s dive right 
in! 
 

� Initialize ZBrush or clear the canvas. 
 

� Select the ZSphere tool and draw it on the canvas. 
 

 
 

� Enter Edit Mode and set the Draw Size to 1.  
 

� Activate X symmetry. 
 

� Hold down the Shift key and move the pointer over the 
ZSphere until the two red circles become one and turn 
green.  Click to add a new ZSphere. 
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 By holding down the Shift key when adding a new ZSphere, we tell 
ZBrush to make the new ZSphere identical in size to the first one.  
Making the ZSphere when the cursor is green means that the 
ZSphere will have the optimal placement for a clean mesh. 
 

� Press W to switch to Move mode, then rotate the model 
and move the new ZSphere down a little as shown. 

 

 
 

� Press Q to return to Draw mode, and add another 
ZSphere. 

 

 
 

� Move the new ZSphere back into the first one until it 
changes to show that it will create an indentation in the 
mesh. 
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� On the opposite side of the root (first) ZSphere from the 
ones that you have added thus far, create two more 
ZSpheres. 

 

 
 
The easiest way is to create one, move it down so that it is 
connected to its parent by three linking spheres, then convert the 
first linking sphere to a ZSphere by clicking on it while in Edit 
Draw mode. 
 

� Preview the mesh by pressing Tool>Adaptive 
Skin>Preview (or A on your keyboard). 

 
� Set Tool>Adaptive Skin>Ires to 7. 

 
Ires is an advanced feature covered in the online users guide and 
by holding the Ctrl key while moving your pointer over the slider.  
It affects the way that skins are created.
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The mesh should look similar to what you see above.  If necessary, 
you can adjust the ZSpheres by pressing A and then moving or 
scaling them as appropriate. 
 

� Make sure that Density is set to 2. 
 

� With the preview active, press W to switch to Edit Move 
mode.  Using a Draw Size of between 50 and 70, move 
polygons around to refine the shape as shown. 
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Feel free to change the Draw Size as necessary while you work. 
 

� Once you are satisfied with the base mesh, increase the 
Density to 3, and click the Make Adaptive Skin button. 

 

 
 
This operation creates a new polygon mesh in the Tool palette.  
This new mesh has three subdivision levels, so you can return to 
the lower resolution later if you wish to make large-scale 
adjustments to the mesh. 
 

� Press T to leave Edit Mode, then Layer>Clear (Ctrl+N) to 
clear the canvas. 

 

 
 

� Select the new mesh in the Tool palette. 
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 � Draw the new mesh on the canvas and press 
Transform>Edit Object to return to Edit Mode. 

 
� Press Tool>Geometry>Divide a few times until you have 
7 subdivision levels. 

 

 
 
This step can also be avoided by setting Tool>Adaptive 
Skin>Density to 7 before skinning the ZSphere model. 
 
From here forward, the mesh will be edited at an extremely high 
resolution using the various Transform brushes.  However, if you 
would like to make large-scale changes to the mesh, you can use 
the Lower Res button to temporarily reduce the number of 
polygons.  It is then a matter of moving a few points to make 
major changes to the mesh.  When you return to subdivision level 
7, the mesh will adapt to the new shape without losing any details 
that you have sculpted at this higher level. 
 
Multi-resolution mesh editing enables you to sculpt any level of 
detail at any time.  This frees your creativity by letting you work 
in a non-linear fashion. 
 

� Use Transform>Inflate to exaggerate the ridge.  A Draw 
Size of 7 and Z Intensity of 25 are appropriate to begin with.  
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Feel free to experiment with different sizes and intensities as you 
work. 
 

� Use Pinch to sharpen these inflated edges. 
 

 
 
Z Intensity of 40 and Draw Size of 25 are probably what you’ll 
need. 
 

� Switching between Inflate and Pinch, chisel a ring 
around the mesh. 

 

 



ZBrush 2 Practical Guide                                                                                               Warrior Part 4 – Upper Arm 259 

 

 Remember that you can switch between Zadd and Zsub by holding 
down the Alt key.  This turns Inflate into Deflate, allowing you to 
cut the ring.  The edges can then be sharpened using Pinch. 
 

� Select the Intensity Metal material. 
 

 
 
As with the breastplate, it is nice to be able to see a material 
applied to the model while working, so as to have a better 
impression of what the finished result will be. 
 

� Using InflatDot and various Z Intensity settings, add 
bumps and spikes to the armpiece. 

 

 
 

� Using a very small Draw Size and a high Z Intensity, add 
small spikes to the edges. 
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� Rotate the model to the position shown in the next 
illustration. 

 
� Activate Projection Master.  Make sure that Color, Fade, 
Deformation and Normalized are active, then click the 
“Drop Now” button. 

 
� Click the “Create a texture and continue” button in the 
help dialogue box that will appear. 

 
� Select a pale yellow color, the Single Layer brush, alpha 
6, and the Line stroke. 

 
� Paint several lines as shown. 
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� When finished, press the Projection Master button, then 
pick up the mesh. 

 
� Rotate the model to new positions and continue adding 
details.   

 
The Fade setting in Projection Master helps with this.  What it 
does is apply the strongest projections to polygons pointing 
directly toward the camera and no projections to polygons 
pointing to the side.  This fading effect makes it much easier to 
blend the details together over several Drop and Pick operations. 
 
Remember that you can also return to using the Transform 
brushes at any time.  Feel free to experiment, using each form of 
mesh sculpting to add different kinds of details.  (For example, 
cracks can be added most easily using Transform>Std rather than 
Projection Master). 
 
Also feel free to use color variations and even materials to really 
“rough up” the armor. 
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Here is where we finished.  You can duplicate our work, or try 
new ideas of your own.  Since this section is meant to refine your 
skills with the various techniques employed, you should 
experiment as much as you like! 
 

� Save your model as ArmorPart4.ztl 
 

In Conclusion 
While no new ground has been covered in this section, you should 
already be seeing an increase in your working speed.  It 
undoubtedly took you less time to create this upper arm piece 
than it did to create the breastplate.   
 
In the next section, we’ll sculpt the head of the man who will be 
wearing our armor.
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Warrior Part 5 – 
The Head 
By J.S. Rolhion 
Since this section builds 
upon techniques taught in 
the previous parts of this 
tutorial, it is highly 
recommended that you 
complete those first. 
 

 
 
Many people consider realistic heads to be one of the most 
difficult modeling tasks.  It doesn’t need to be!  Through the use 
of ZSpheres, multi-resolution mesh editing, the various sculpting 
tools, and Projection Master, you can sculpt a believable head 
nearly as easily as the armor pieces that have been done thus far. 
 
Since this tutorial builds upon the techniques already covered in 
the earlier sections, we will not go over many of the basics.  It 
will generally be assumed that you know how to do many of the 
steps. 
 

� Initialize ZBrush. 
 

� Select the ZSphere tool and while holding down the Shift 
key, draw it on the canvas. 

 
� Activate Transform>Edit Object, and then press the X 
key to turn on X symmetry. 

 
� As always when working with ZSpheres, change the Draw 
Size to 1. 

 
� Add two new ZSpheres as shown below. 
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� Rotate the model to the side, and hold down the Shift 
key to snap to a perfect side view. 

 
� Move the ZSpheres into their parent so that they will 
create indentations. 

 

 
 

� Add more ZSpheres for the ears, nose and mouth.  Move 
the mouth and ear Zspheres into the parent, as well. 
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� Activate the mesh preview. 
 

 
 
The problem here is caused by the fact that ZSpheres are treated 
as cubes for skinning purposes.  Each face of the cube normally 
can have one child in order to create a clean mesh.  However, in 
this case we have four children on the same side.  This can be 
resolved by changing the Ires setting from its default of 6. 
 

� Set Ires to 1. 
 

 
 
The mesh now looks much more like a face. 
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� Make an Adaptive Skin, and draw it on the canvas. 
 
We no longer need the ZSphere model.  Its sole purpose was to 
give us a basic face shape that we can then refine using mesh 
editing tools. 
 

� Enter Edit mode and make sure that X Symmetry is 
active. 

 
� Using the Move tool and medium Draw Sizes (between 30 
and 50), move points around to begin refining the shape. 

 

 
 
The following steps are a general guideline, only.  Be creative as 
you move points around.  The important thing is to block out the 
overall shape of the head while there are few polygons to contend 
with. 
 
Use different Draw Size settings while you work, depending upon 
how many points you wish to affect at a time.  For example, when 
adding the neck you will probably want to use a large Draw Size.  
Alternatively, you can use the Geometry menu to go to 
Subdivision Level 1, move just a few points to create the neck, 
then return to Level 2. 
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Notice that for step 6, the mesh resolution has been increased.  
For this step, we divided the mesh once, adding a third 
subdivision level. 
 

� Continue to refine the face. 
 

 
 
From this point on, different artists have different preferences.  
Some like to sculpt as much as possible by moving a few points at 
a low subdivision level.  They only add a new level after they have 
accomplished as much as they can at the current level.  Other 
artists prefer to jump to a high level and sculpt.  Ultimately, you 
should try both approaches and decide which works best for you.  
There is no “right” or “wrong” way. 
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� Divide once more. 
 

� Using the Inflat brush, begin adding brows, cheek bones 
and nostrils. 

 

 
 
Change Draw Size and Z Intensity as necessary to get the results 
that you’re looking for. 
 

� Add ears by using Inflate to create the raised ring of the 
ear (1), followed by Move mode to push it into shape (2). 

 
� Move can also be used to refine the cheek shape (3) and 
the eyes (4). 

 
These steps are all illustrated in the image on the next page:
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� Divide the mesh once more.  Continue using Inflat to add 
details such as fatty tissues and lips, nostrils, etc. 
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� Continue work, dividing as necessary to add finer levels 
of detail.  

 
 

 
 
Remember as you work that even after you have divided the 
mesh, you can always return to a lower subdivision level.  Also, 
remember that Inflat can be reversed by holding down the Alt 
key. 
 
At some point, you will want to turn off symmetry and Move large 
parts of the mesh around a bit to keep the face from being 
unnaturally symmetrical.  At this point, you can also add 
character to your figure by sculpting details such as veins and 
scars.  You might even rough up the nose and chin a bit to create 
pores or places for stubble.  A lot is possible when you can work 
with hundreds of thousands of polygons in real time! 
 
Once the face has been sculpted, it’s time to apply a material.  
We’ll build a skin shader by using ZBrush’s copy and paste 
features for the Material palette. 
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� Begin by selecting the Colorizer 1 material. 
 

 
 

� Select the S1 channel and press CopySH to copy this 
shader. 

 
� Select the QuadShaders material. 

 

 
 

� Select the S1 channel again and press PasteSH. 
 
What we have done is create a material with four shader 
channels, the first of which is from the Colorizer1 material.  We 
can now easily modify this to create a complex, four-layered 
material effect that will appear to be somewhat translucent. 
 
The images on the following pages show the settings that you 
should use for each channel. 
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As you can see, a lot has been accomplished toward a “textured” 
appearance for the model without having to use any texture at 
all!  The ability to create custom materials by copying and pasting 
channels together is truly powerful. 
 
Even so, there is only so far that the material will take you.  For 
more detail, it is necessary to paint a texture.   
 

� Activate subdivision level 1. 
 
New UV mapping can only be assigned at the lowest subdivision 
level. 
 

� Create a new texture by setting Texture>Width and 
Height to 2048, each, and then pressing New. 

 
� Assign UV coordinates to the model by pressing 
Tool>Texture>GUVTiles. 

 
This assigns the Group UVTiles mapping method that is unique to 
ZBrush 2.  It is as distortion-free as is mathematically possible, 
while still keeping the groups of polygons as large as possible.  It 
is ideal for painting on using Projection Master. 
 

� Return to the highest subdivision level. 
 

� Rotate the model so it faces the camera squarely. 
 
Remember that you can press Shift when near the desired 
orientation to snap the model into position. 
 

� Press the Projection Master button, select Colors and 
Fade, then press “Drop Now”. 
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� Use your choice of brushes, alphas and stroke types to 
begin texturing. 

 
In our example, we began with the Single Layer brush, alpha 7, 
and the Spray stroke. 
 

 
 
The nice thing about the Spray stroke is that it has a random 
quality that is very suitable to texturing natural objects.   
 
Turn off Zadd, and activate Rgb instead of Mrgb. 
 

� This allows us to paint with color, alone.  No depth or 
materials will be added while we work. 

 
Vary your colors, draw size, RGB Intensity, etc.  Low Rgb Intensity 
settings are essential for realistic texturing, since they allow you 
to build color up gradually, blending it together as you go. 
 

� When ready, use Projection Master to pick up the model 
and rotate it to a new angle. 

 
Remember that in order to keep your texturing consistent across 
the entire surface of the model you shouldn’t try to do everything 
at once!  Instead, it is best to repeatedly pick up the model, 
rotate it to a new angle, and drop it again so that you can texture  
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every part of the head that can benefit from the current settings 
before you changing them to add a different kind of detail.  This 
process of dropping and picking will quickly become second 
nature to you. 
 
Here is our texturing in progress: 
 

 
 
Many details will be added by the material’s cavity settings.  
These will not appear, however, until a Best render is performed.  
Check your work occasionally by doing one while the model is 
dropped. 
 
The next page shows our finished result. 
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� Save this head as Head.ztl.  When prompted to save the 
texture with the model, say yes. 

 
� In addition, you should save your material by pressing 
Material>Save.  Call it skin.zmt. 
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In Conclusion 
Using ZSpheres, a very basic mesh complete with edge loops can 
quickly be blocked out.  This mesh can then easily be modified by 
using the many sculpting brushes available from the Transform 
palette.  More and more polygons are added to the mesh as 
necessary for the details that we wish to add.  When modeling is 
finished, a complex material can be built by combining elements 
from other materials.  Projection Master then provides an easy 
way to paint textures directly onto the model without the need to 
compensate for UV mapping distortions.  What’s more, ZBrush 
offers several UV mapping methods including the new GUVTiles. 
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Warrior Part 6 – 
Composition 
By J.S. Rolhion 
This is where it all comes 
together!  The various 
elements from the 
previous five sections will 
now be used to build a 
scene, which will be 
finished and rendered. 
 
 

 
 
Something that you may have noticed in the course of working on 
this project is that we did not attempt to create a single 
character but instead created a few pieces.  This is because our 
figure is going to be used within ZBrush and so each piece can be 
added to the canvas one at a time. 
 
This feature of ZBrush has several strengths.  First, we at this 
point have four very “heavy” pieces in terms of polygons.  If all 
four of them were active in a scene at the same time, your 
system might very well begin slowing down.  But since ZBrush 
makes it possible to snapshot each piece to the canvas, you 
actually only have one that exists as polygons at any given 
moment.  You could actually build scenes with figures totally 
billions of polygons, yet never sacrifice real-time interactivity.   
 
The second advantage to building one piece at a time is that 
these pieces can be posed any which way you please without the 
need for skeletal rigs or anything else.  Place each part where you 
want for the scene and you’re done! 
 
The third benefit is that pieces can be recycled from one scene to 
the next.  The Smooth brush can be used to remove details, 
making room for fresh detailing without the need to build a whole 
new model.  The other editing tools make it easy to reshape 
elements; for example to change the shape of a face and give him 
a new expression.  By building a relatively small library of 
reusable parts, you can create an endless variety of scenes while 
saving hours off the time required creating each one. 
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Before putting together the final composition, you’ll need to 
define the size of the final image. 
 

� Click Document>New Document. 
 

 
 

� Turn off Pro, then set the Width to 1400 and the height 
to 1200. 

 
With Pro turned off, we can change the width and height values 
independently, creating documents with different relative 
dimensions. 
 
The size of your document should be double the size of the image 
that you plan to export from ZBrush.  Ours will be 700x600, so we 
create it at 1400x1200.  This allows us to take advantage of 
ZBrush’s antialiasing zoom level for the best quality render. 
 

� Click Resize 
 
Your document is now probably too large to fit within the 
viewable area.  This is not a problem, as you can zoom out to get 
a full view when you need it (such as when blocking out the 
scene), then return to actual size when you wish to add detail. 
 

� Press the AAHalf button on the right shelf. 
 
The Half-Sized antialiased view is now active, and depending on 
your display resolution, the entire canvas could well be visible  
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again.  The advantage to working in this view is that you can see 
exactly what the final image will look like while you work. 
 

� Using the Tool palette, Load ArmorPart1.ztl 
 

 
 
The model is selected as soon as it’s loaded. 
 

� Select the Intensity Metal material. 
 

� Draw the model on the canvas. 
 

� Move, scale and rotate it into the position shown. 
 

 
 
There are two ways that you can do this, depending on your 
preferences.  In the example above, we entered Edit Mode and 
used the Move, Scale and Rotate icons from the right shelf to 
position it.  That was fine for this piece since there was no need 
to change the depth. 
 
Alternatively, you could use the gyro.  The main difference is that 
you can change the object’s depth with this method.  Also, you 
can use the sliders in Transform>Info to achieve very precise 
placement should you need it for a project. 
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� Load the Head.ztl model. 
 

 
 
At this point, the breastplate is now snapshot to the canvas and 
cannot be moved without clearing the layer and drawing it again. 
 

� Press Layer>Create to add a new one and make it active. 
 

� Select the Skin material. 
 
If this is a new session, the material will not be in the palette.  In 
this case, select any material that you do not plan to use in your 
scene (Fast Shader 5 is a good one) and then load the Skin.zmt 
that you saved in section 5.  The skin material will replace the 
other. 
 

� Draw the head on the canvas. 
 

� Activate the Move switch.  Use the gyro to move the 
head into position. 

 

 
 

� Use Move, Rotate and Scale as necessary to get the best 
placement. 
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� Create another layer. 
 

� Select the Sphere3D tool. 
 

 
 

� Choose the Toy Plastic material. 
 

 
 

� Draw the Sphere3D.  Use the gyro to move it into 
position within the head’s eye socket. 
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� When it is positioned right, press Shift+S to snapshot it to 
the canvas. 

 
� Use the gyro to position the second eye. 

 

 
 
Snapshot lets us create an instance of the object without having 
to turn off the gyro and draw a second copy.  This means that 
both eyes will be the same size. 
 
We now have one layer with armor, one with the head, and one 
with the eyes.  There are several advantages to placing 
intersecting elements on their own layers.  For example, if we 
decided that we weren’t happy with the head we could clear that 
layer and draw it again without affecting anything on the other 
layers.  Also, we will be able to paint on the eyes or armor 
without worrying about affecting the head in any way.  Layers are 
far more than an organizational tool! 
 

� For the background, select the Plane3D. 
 

� Create a new layer. 
 

� Select the Basic Material. 
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� Draw the plane on the canvas and use the gyro to move 
it into a background position. 

 

 
 

� Use Scale to enlarge the background so that it fills the 
canvas. 

 

 
 

� Paint your background using any method that you like. 
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We used the Single Layer brush, alpha 01 and the Spray stroke to 
do the majority of the painting. 
 
Because the background is on a separate layer, it can be painted 
on without affecting the rest of the scene. 
 
Modify the material properties if you like to make the background 
more visually interesting.  For example, you could use a little bit 
of color bump, and even slightly increase the High Dynamic Range 
modifier to realistically brighten the sky. 
 

� When you are satisfied, press Layer>Bake. 
 
This changes the layer to the Flat Color material and converts the 
colors that are generated by the material on this layer to 
unshaded colors.  There are two important reasons for doing this: 
 
You could now use the correction brushes (such as Highlighter II, 
Smudge and Blur) to add even more detail to the background.   
Since these brushes affect unshaded color, you will get the most 
dramatic results from them when working on a layer that has 
been baked. 
 
The Flat Color material is impervious to shadows.  This means that 
when we set up our lighting and render the scene with shadows, 
the man in his armor will not cast shadows on the sky (which 
wouldn’t be very believable). 
 

� Load the ArmorPart4.ztl tool. 
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� Select the layer that the breastplate is on. 
 
We’ll keep both armor parts on the same layer so that we can 
paint additional details and keep them consistent across the 
figure. 
 

� Draw the arm on the canvas and use the gyro to move, 
scale and rotate it into position. 

 

 
 

� Snapshot the arm, then move and rotate the second one 
into place. 

 

 
 
You may find that the second arm becomes partly submerged in 
the background layer.  This is easily corrected by selecting the 
background layer and increasing the Layer>Displace Z slider by  
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small increments until the background is completely behind the 
figure. 
 
Now that the scene is blocked out, it’s time to bring it to life.  
 

� Use the various paint tools, alphas, and stroke types to 
paint character onto the head and armor.   

 

 
 
You can also add soft details using different Draw Size, Z Intensity 
and Rgb Intensity settings, as well as toggling between Rgb and 
Mrgb.  Activate Zadd or Zsub when you wish to paint depth, but 
otherwise turn them off. 
 
Change layers as necessary to paint the part that you wish. 
 
Don’t forget to add details such as iris and pupil on the eyes.  
Also, the Shading Enhancer brush is great for adding shadows on 
the eyes caused by the eyelids.  All brushes with the split 
thumbnail can be reversed by holding down the Alt key.    For 
example, the Blur brush can become Sharpen and Highlighter can 
be used to darken instead. 
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Simulate rust on the armor, and in general have fun with the 
image. 
 

� Adjust the scene’s lighting.   
 
You might want to reuse the settings from part 5, but this time 
activate ZMode in the Light>Shadows menu. 
 

� Adjust the Render settings to match those from part 5. 
 

� Press Render>Best Renderer. 
 

 
 

In Conclusion 
ZBrush is really powerful when editing your image to get the best 
effects using a combination of 2D tools, 2.5D tools and 3D tools in 
one integrated environment.  And all of that in real time!  This 
gives artists the freedom to experiment a lot more than could be 
accomplished with either a 2D or a 3D program. 
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Character 
Modeling Part 1 -- 
ZSphere Modeling 
& Adding 
Geometry 
By Glen Southern 
In this tutorial we’ll work 
with ZSpheres to create 
the base mesh, and 
become acquainted with 
the geometry tools that 
are available in ZBrush 2. 
 

 

Over the course of this three part project, we will create a full-
body mesh from the ground up.  In this first section, we’ll begin 
by creating the ZSphere figure and skinning it.  Low resolution 
shaping of the mesh will be performed. 
 
Part 2 will continue the project by sculpting medium and high 
resolution details.   These are the details that really bring a 
model to life.  They are also what you will be focusing on if you 
intend to create displacement or normal maps for your work. 
 
Finally, in part 3 we will touch on texturing and materials.  While 
these topics could fill up a book on their own, we will at least 
cover the basics. 
 
This tutorial can’t hope to teach you all aspects of ZBrush, but 
you will need a good understanding of ZSpheres.  The following is 
a quick guide to get you started.  The idea behind ZSpheres is that 
you can use them as “place markers” or a “skeleton" to indicate 
to the program where you would like geometry placed in a model. 
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ZSphere Reference Table 

 

To add a ZSphere, select ZSPHERE from the 
tool menu and draw it into the document 
window. 

Hit `T` to enter EDIT mode. 
You can now add child ZSphere's with DRAW 

mode selected from the top menu bar  then 

move , scale  and rotate  them 
and keep adding more and more to construct the 
basic shape that you require. 

 ADDING ZSPHERES– DRAW POINTER MODE  

Add another ZSphere 

Click on the ZSphere to add a “Child” ZSphere 

Delete a ZSphere 

ALT+Click on a ZSphere to remove 

Insert a ZSphere in the chain 
 

Click on a gray link chain between ZSphere's 

 MOVING – MOVE MODE  

To move a ZSphere 

Click and drag a ZSphere 

To move the Link-ZSphere 

Click and drag a link ZSphere to move all child 
ZSphere's 

Move without stretching Links 
 

ALT+Click a Link ZSphere to move without 
stretching links 
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ZSphere Reference Table, Continued 

 SCALING – SCALE MODE  

To Inflate or Deflate a ZSphere 

Click on a ZSphere and drag to inflate or deflate 

To Inflate/Deflate all Child ZSphere's 

ALT+Click and drag on a Link-ZSphere 

Linked Re-Size 

 Click on a Link-Sphere and drag to resize 

 ROTATING – ROTATE MODE  

To Rotate a ZSphere 

Click and Drag on a Link-ZSphere to rotate 

To do a constrained Rotate 

Click and Drag on a ZSphere to rotate around its 
Parent. 

To twist a ZSphere (change its up/down 
direction) 

 

ALT+Click and drag on a ZSphere 

 

Building the Basic Figure 

 
 

� To jump right in and start a ZSphere model you need to 
select the ZSphere icon from the TOOL palette. 
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“Tool” in ZBrush is a generic 
term to describe everything that 
can be used to paint on the 
canvas.  This can include 
models and brushes, both.

 
 
It is the two-tone red ball. If you can't see it at first click on the 
biggest icon in the TOOL panel and it will show you everything 
that is available as a tool. 
 

� With your stylus draw a small ZSphere out in the center 
of the document window. 

 
Start with the pen in the middle of the screen and on your first 
stroke drag outwards very slowly.  This is the “root” ZSphere, and 
will form the figure’s hip. 
 

� To start using the ZSpheres we need to activate EDIT 
mode.  Press “T” on the keyboard. 

 
You should now see a red ring 
indicating the current size of your 
brush. This will become more 
important later in the tutorial. 
 

� Go to the TRANSFORM palette 
and click X. 

 
See the image to the right. 
 
As we intend to model a humanoid 
character that is essentially 
symmetrical we need to turn 
symmetry on across the X Axis. You 
will now notice two red dots; one on 
each side of the Red ZSphere. This 
will now add child ZSpheres in a 
symmetrical manner. 
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When symmetry is active, the circles 
will show you what to expect when 
adding ZSpheres. 
 
When you see two circles, two 
ZSpheres will be added. 
 
When the two circles merge into one 
(which happens at the axis of 
symmetry), only one ZSphere will be 
added. 
 
Green circles indicate ideal 
placement, directly on one of the 
ZSphere’s “faces.”  (For skinning 
purposes, each ZSphere is actually 
treated as a cube with six potential 
faces that can be connected to.)  Red 
circles indicate that the placement is 
close to an edge between faces.  
ZSpheres can still be added, but you 
should check the mesh preview to 
make sure that you get the desired result. 
 

� To preview your mesh at any time, press the “A” key on 
your keyboard. 

 
The next steps refer to the following image.  Use it as a reference 
while you work. 
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� Add a child ZSphere and reposition it away from the hip 
ZSphere.  

 
Get used to rotating the ZSphere model to look at it from all 
angles. 
 

� Add three more child ZSpheres and reposition them using 
MOVE.  

 
You are creating a leg at this stage and these first few ZSpheres 
are the thigh. The last one is the knee joint. 
 

� Looking form the side, angle the thigh forward as a leg 
would be for a figure with slightly bent knees. 

 
� Add a slightly larger one for the calf and a further one 
for the ankle. 

 
� Add an additional three ZSpheres for the feet and check 
the reference image to see how things are looking.  

 
With the legs complete, we’ll return to the hip and build the 
torso. 
 

� Add a ZSphere in the center of the hip ZSphere.  
 
This will become the bottom of the spine.  
 

� Carry on creating ZSPheres up the spine and then create 
a large shoulder ZSphere. 

 
Refer to the images as necessary to ensure proper placement. 
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Prior to skinning, a ZSphere 
model is not exportable.  If you 
wanted to export the mesh, you 
would need to skin the model 
first.  However, there are many 
advantages to not skinning a 
ZSphere figure.  The preview 
mesh can actually be sculpted 
and textured, and then the 
figure can be posed by moving 
the ZSpheres that are used to 
create it.  This is very useful for 
creating figures to be used 
within ZBrush scenes.

 
� From the shoulder create the bicep, elbow, forearm and 
wrist.  
 

To create the hands: 
 

 
 

� In the same way that the figure was created, we need to 
add smaller ZSpheres as children to the final arm ZSphere.  
These new ZSpheres will make up the fingers and a thumb.  

 
Keep rotating the model to get a rough shape for the fingers. 
Make sure that you have a ZSphere at each bend in the fingers. 
 

� Add ZSpheres for the neck and head. 
 

� Add child ZSpheres to the main head ZSphere.  Move 
them so that they become indented into their parent. 

 
These ZSpheres will become the eye 
sockets.  Whenever a ZSphere is 
moved far enough into its parent, its 
appearance changes to show that it 
will have a subtractive effect on the 
mesh.  Edge loops will also 
automatically be created around these 
indentations. 
 

� Add a single indented ZSphere 
to the middle part of the lower 
face. 

 
This will become the figure’s mouth. 
 

� Save your model using Tool>Save As. 
 
This saves the figure in ZBrush’s native format (with a .ZTL 
extension).   
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Working with the Adaptive Skin 
 
We will be continuing the session using the figure that was just 
created from ZSpheres.  If you wish to skip the ZSphere process, 
you can load the figure_zspheres.ZTL model from the Southern 
folder in the Resources. 
 

� Make sure that Edit, Quick, and Frame are all active on 
the top shelf. 

 

 
 
Quick will normally be on by 
default, and speeds up working with 
a high density mesh by disabling 
ZBrush’s render smoothing routines.  
When it is active, the Polyframe 
display mode also becomes 
available.  With this display style, 
we can see the wireframe 
superimposed onto the shaded 
model. 
 
ZBrush assigns automatic grouping to a ZSphere-created model.  
By default, this grouping will be displayed as colors on the 
polyframe.  You can change the display to grayscale in the 
Preferences, or even turn off the group display entirely. 
 
The figure at right shows three versions of the same model.  On 
the left is the ZSphere figure.  In the center is the polyframe 
showing the grouping.  On the right is the smoothed version that 
you would see with Quick 3D turned off. 
 

� ZSpheres in a mesh should all face the same way.  
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The ZSpheres in ZBrush 2 are two-tone red, which helps you 
understand which direction the ZSphere is facing. If a mesh 
becomes twisted at any point, you can use ROTATE while holding 
keyboard ALT and rotate a ZSphere and its Children.  
 
Up to this point, we have only been working with a preview.  Now 
we need to turn the ZSpheres into polygons.  Before we skin it, 
though, there are a few settings in the Tool>Adaptive Skin menu 
that should be adjusted to help ZBrush create the best mesh 
possible. 
 

Density 
This will allow you to increase the density of the 
polygons in the mesh. For our example we will 
leave the setting at 2. 

Ires 
Intersection Resolution: Used to improve the mesh 
when more child ZSpheres are added to a single 
ZSphere. Set it to 30. 

Mbr 
Membrane Curvature: Defines how membranes will 
be created at L and T intersections. We can use a 
setting of 40. 

MC 
Minimal skin to Child: Affects how polygons are 
created at intersections. We need to set this to 
active (selected). 

MP 
Minimal skin to parent: This setting makes for a 
more rounded intersection. We will leave this 
setting inactive (unselected). 

NOTE: These settings are only a guideline. To get experience, 
try changing the settings I have given above and see the model 
update (if it is still in EDIT mode) 

 
 

� You can turn it into polygons using the 
MAKE ADAPTIVE SKIN button. 

 
The ZSphere figure will not change.  Instead, a 
new model is created in the Tool palette.  To 
work with this model, you will need to clear the 
canvas (to remove the ZSphere figure), and draw 
the skin on the canvas in its place. 
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Polygroups 
You’ve already seen how ZBrush gives an Adaptive mesh a set of 
defined colours to each body part. This auto grouping is done at 
major intersections in the mesh based on the ZSphere model that 
it came from, or in the case of a third party imported models they 
can be assigned based on UV maps. These polygroups become very 
important later in the exercise where you will see how to hide 
areas of the mesh while editing the visible section. By using 
SHIFT+CTRL and clicking a polygroup, it is possible to hide the 
selected poly group (or colored area). 
 

Adding Geometry 
One of the fantastic new features of ZBrush is its ability to handle 
and manipulate polygon meshes with polycounts into the low 
millions. Not many other programs on the market today can 
handle even a small fraction of that without bringing the 
computer to a near standstill. The next part of the tutorial 
introduces some of the steps that will enable you to take a low 
resolution polygon mesh and subdivide it and then detail the 
polygon surface. 
 
HIDING PARTS OF YOUR MODEL - BASICS  
In the next section we will be subdividing the polygon mesh and 
will end up with a model that has over 2 million polygons. While 
this density of mesh is fine on higher spec machines it is still 
advisable to hide parts of the mesh at certain times in the 
modeling process. 
 

� Draw the Polygonal model into the document window 
from the TOOL palette. Press `T` for EDIT mode. 
 
� To hide a polygroup use CTRL+SHIFT and click onto the 
group you want to remain visible. 

 

 
� To reveal the hidden parts CTRL+SHIFT and click on the 
canvas away from the model. 
 



ZBrush 2 Practical Guide                                                                   Character Modeling Part 1 – ZSphere Modeling 299 

 

� You can hide portions of the 
model based on a drag rectangle. 
Use CTRL+SHIFT and left mouse 
button to drag out a GREEN 
rectangle over the area you wish 
to keep visible. Release the mouse 
button and anything outside the 
rectangle is hidden 
 
� To hide everything inside the 
rectangle use CTRL+SHIFT and left 
mouse button to drag out a GREEN 
rectangle but release the SHIFT 
key and the rectangle goes RED.  
Then release the mouse button, 
and everything inside will be 
hidden. 

 
� To reverse mesh visibility, drag 
a small rectangle anywhere on the 
blank canvas without selecting any 
part of the model. 

 
Try this a few times as it can be 
difficult at first. Get used to hiding and 
revealing mesh using polygroups and 
the drag rectangle methods as both will be needed later.  The 
techniques will quickly become second nature to you. 
 

Edge Loops 
Yet another powerful feature in the ZBrush tool kit is the ability 
to add edge loops to your mesh. Before we divide the mesh in any 
way we can give the model extra polygons in areas that may need 
more detail later in the process.  
 

� Press Tool>Geometry>Del Lower. 
 
The Edge Loops feature needs a mesh to be at the lowest 
subdivision level.  Since the model already has a more basic level 
below this, we need to delete it before we can proceed with the 
detailing. 
 

� Hide all but the arms polygroup. 
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� Click the Edge Loop button. 
 

 
 
You will notice that an edge loop has been created at the two 
open ends of the revealed mesh.  When the mesh is subdivided 
later, these areas will have a higher resolution. 
 

Subdividing Your Model 
This next stage is where we actually add more geometry to our 
model using the Divide button in the Geometry menu. One 
principle that I like to adopt when modeling in this way is to do as 
much as possible in the way of sculpting on a model at each 
subdivison level. That is to say, our model is currently made up of 
1608 polygons. Before dividing the model it is always best to get 
the model as near as possible to the final shape that we require. 
If this is done at each suddivide, the very high resolution work at 
the end is limited to fine detail only.  
 

� Click Divide once.  
 
If you hover your cursor over the model thumbnail in the Tool 
palette you will see the poly count is now 6432 polygons. (4x1608) 
 
At this stage we can tweak the figure using MOVE with symmetry 
still turned on across the X axis. To shape the body, use varying 
brush sizes and remember to rotate the model frequently to 
check its proportions.  
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For now try to add volume to places where the mesh has gone a 
little flat such as the thighs, the shoulders, the calves etc.  Once 
the mesh looks like the image above, we can move on to 
subdividing further.  
 
Each time you hit the Divide button, the mesh will quadruple its 
polygon count so 1608 becomes 6432.  Divide again and it will 
become 25,728 etc... 
 
The current Subdivide level is 2. Each time we press Divide that 
level goes up by 1.  
 
A point to note is that when ZBrush does this subdivide it retains 
the information about the lower resolution mesh and you can 
come back down at anytime by using the LOWER RES button.  
 

 
 

� For now hit the DIVIDE button twice. 
 
The mesh should now be over 100,000 polygons in size and be 
sitting at Sub-D level 4.  
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As with most types of modeling 
or sculpting it is better to work 
from some sort of reference 
rather than making it up from 
memory. As we can get a great 
deal of detail into these ZBrush 
models it is advisable to work 
from some sort of photograph or 
sketch. 

We can now do some more tweaking and refine the shape some 
more. Make sure the feet are flat to the ground and are indeed 
feet shaped.  See that the chest has enough volume.  Start to 
think how the muscles will look in the arms and legs. 
 

In Conclusion 
In this part of the tutorial, we have studied how to manipulate 
ZSpheres in the construction of a full-body figure.  We’ve also 
covered the basics of ZBrush’s mesh grouping and partial visibility 
features, Edge Loops, and other geometry tools.  The figure is 
now at a medium level of resolution and ready for further 
detailing.  We’ll do the medium and high resolution sculpting in 
the next part. 
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Character 
Modeling Part 2 – 
Medium & High 
Frequency 
Sculpting 
By Glen Southern 
In this tutorial we’ll learn 
how to use ZBrush 2’s 
many mesh sculpting 
features to detail the 
model from Part 1. 
 
 
 
 
 
 
 
 
 
 
 
 
 
By default, the Shift key 
activates the Smooth brush.  
You can change it to any of the 
other brushes by holding down 
Shift and clicking on the 
sculpting brush of choice.  From 
then on, Shift will activate that 
brush instead of Smooth. 

Now to add some specific muscle detail to the chest and arms. 
One of the much awaited features Z2 is the ability to manipulate 
and edit polygonal meshes with polygon counts in the low 
millions. To be able to follow this tutorial make sure you are 
confident in hiding and un-hiding parts of your model. 
 

Sculpting Basics 
Sculpting or painting depth onto a model in ZBrush can be done in 
a number of ways.  The most basic technique, which will already 
be familiar to experienced ZBrush artists was the Draw Pointer: 
 

The basic way is to put the ZTool (Your 
model) into EDIT mode (T),  

Use the DRAW POINTER mode with ZADD 
activated to build up the surface of the mesh  

Set the BRUSH SIZE and Z INTENSITY to suit the type of 
modeling you want to achieve. With this new version there is 
also the FOCAL SHIFT slider which helps you to refine your 3D 
painting by adjusting the falloff curve. 

 
Use the DRAW POINTER mode with ZSUB activated indent the 

mesh 

Use DRAW POINTER + SHIFT KEY to activate the 
new SMOOTH BRUSH. This new tool is invaluable for 
create smooth, organic meshes. 

 
 

New Sculpting Brushes 
ZBrush 2 has a range of new brushes in the 
Transform palette that build on the above toolset.  
Again, these brushes are used with the Draw Pointer 
tool and are simply 'painted' onto a mesh in EDIT 
mode. 
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STANDARD - As described above, the standard 
mode simply raises mesh off the surface of the 
model based on brush size and Z-Intensity.  All 
polygons move in the same direction. 

 
STANDARD DOT - This is the same effect 

however the effect is a one off at the point 
your stylus hits the model. After clicking you 
can drag the bump effect around before placing 
it.  

INFLATE - Applied in the same way as the 
standard brush, but inflate lifts each polygon 
along its own surface normal. 

 
INFLATE DOT - See inflate, but the effect is a 

one-off at the contact point as per standard 
dot. 

 
LAYER - Applies an even layer of raised mesh 

defined by the brush size. 

 
PINCH - This brush pulls geometry together to 

a point at the center of the brush. 

 
NUDGE - Nudge displaced mesh in the 

direction that the brush stroke is applied. 

 
SMOOTH -This brush (same as holding down 

shift while painting) smooths out the mesh 
under the brush radius. 
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Sculpting the Figure 
With a basic understanding of the tools in the new version we can 
start work on detailing the figure. The subdivide level should be 
at 4 giving the mesh 100,000+ polygons to work with.  We can now 
start to add the next level of detail to the model. 
 

� If you haven't already, hide everything but the torso and 
upper arms.  

 

 
 

� Turn POLYFRAME and QUICK off to allow surface 
smoothing.  Set Tool>Display Properties>DSmooth to 1. 

 
This activates a render-time smoothing effect where ZBrush will 
further divide the model whenever it’s not being edited.   The 
effect will be that when you are rotating or sculpting the mesh, 
you will see the true number of polygons that the model has.  
When you release the mouse button, the mesh will become 
smoothed to show the high-quality effects of your work. 
 

� Using the standard brush on the torso start to build up 
the chest and abdominal muscles.  

 
Use reference material where 
needed and try to match the 
muscle groups.  
 
Keep turning the model to make 
sure the silhouette is correct. 
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� For the abdominal muscles switch to the nudge brush 
and push the edges outwards to give a more defined look to 
the muscle edge.  

 

 
 
Remember that if you go too far you can CTRL+Z to undo or use 
SHIFT+standard brush to smooth the mesh out. 
 

� Build up the muscles around the lower abdomen, under 
the arms, around the pelvis. 

 

 
 

� Rotate the model and work under the armpits and onto 
the shoulder blades and onto the spin.  

 

 
 
For the shoulder blade you may find that the layer brush is useful 
to create a wide flat area. 
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� When you have completed the bulk of the torso start to 
work down one of the shoulders and onto the biceps.  

 

 
 
We will finish the arms and hand later but for now we will move 
on to the neck and head. 
 

� To unhide the model, SHIFT+CTRL+Click away from 
mesh.  

 
� Hide everything but the chest, shoulders and head. 

 
� Using the standard brush build up and define muscles 
around the neck up to the ear and bring out the adam’s 
apple. Using the Inflate brush can help underneath the chin.  

 

 
 

� Add some bulk to the back on the skull.  
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� With the standard brush start to shape the facial 
features.  Swap back and forth between standard, inflate 
and nudge to manipulate the mesh into the shape you 
require. Use nudge to make creases around the mouth and 
cheeks. 

 

 
 

� Bulk up some mesh for the eyeball, and then using 
inflate bring the lids out around it.  Move on to the 
eyebrow, again inflating if needed. 

 

 
 

 
 

� Hide everything but the legs and feet. 
 

� Work your way down the legs with the standard brush 
and bulk out all the major muscle groups as we did for the 
chest. 
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The nudge brush is useful here to 
help push the muscles back 
together once you have given 
them enough volume. Don't forget 
to change your brush size and Z-
Intensity to model different parts 
of the leg. 
 
You will need to use 
standard+ALT a lot here to indent 
the back of the legs and define 
the calf muscle. 
 

 
 
 

� When you reach the feet 
you can hide everything but 
the feet and detail the toes 
and nails with standard, 
layer, nudge and inflate.  

 
Pinch can help get between the 
toes and for pulling the nail back 
into the skin and use Layer to 
draw the nails on. 
 

� Hide all but the arms for the next section. 
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Even with a fast machine, use 
hide and unhide as much as 
possible. Get into the habit of 
hiding all but the area you are 
detailing as this dramatically 
improves the speed. 
 
 
 
Use the new Focal Shift setting 
to your advantage. When it is 
set to its highest you can 
achieve some interesting detail 
effects on the model’s surface. 
Combine this with different 
Brush Size and Z Intensity 
settings, and it becomes an 
invaluable tool for detailing the 
mesh. 

 
� As with the rest of the figure use a combination of the 
new brushes to build up muscles and indent areas of the 
figure.  

 
The fingers need to be done with a very small brush and a low Z-
intensity. The finger nails can be achieved with the layer brush. 
 
However, to get really fine details on the hands and feet we need 
to go to an even higher density mesh. 
 

 
 

High Resolution Modeling 
The next stage in the modeling process takes the mesh to 
extremely high resolution (polygon count) and gives us the 
opportunity to add details to the figure that would be difficult if 
not impossible in any other 3D package on the market.   A fast 
processor and lots of RAM will help you to work faster. 
 
While it is possible to complete the tutorial on machines with 
lower amounts of memory it can become difficult to rotate and 
move the model. This is where hiding the mesh becomes really 
crucial and the ability to step up and down the resolution is 
absolutely necessary.  A good workflow is to go down a couple 
subdivision levels every time you need to see a large portion of 
the model.  Hide all but the area that you wish to detail before 
returning to the highest subdivision level to continue your work. 
 

� Go to Tool>Geometry and hit DIVIDE twice more.  
 
This will take the mesh to level 7 which is the highest level we 
can go in this project. Depending on which ZTool you are using 
you will now have anywhere from 1.6 to 2 million + polygons. With 
that number of polygons in a mesh we can now add very small 
details to the model that would only be possible in other programs 
by using bump maps and displacements of some type. 
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Using Projection Master for Modeling 
Although adding detail to the mesh in EDIT mode alone is 
acceptable, there is another way to refine the detail even more. 
With PROJECTION MASTER you can drop the mesh to the canvas 
and paint depth and color onto the 2.5D model then pick it back 
up as 3D with the changes. This allows you to use some of the 3D 
brushes and any number of ALPHA BRUSHES to add detail. 
 

� Hide everything but the head of the figure. 
 

� Rotate the model so that it is viewed exactly from the 
side.   

 

 
 
Hold down the Shift key when you are close to the right angle to 
snap the model into position. 
 

� Click the Projection Master button on the interface or 
use “G” on the keyboard. 
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This brings up the Projection Master panel in front of the canvas.  
Here, you can change the settings that PM will use.  As settings 
are turned on or off, the thumbnails will update to show how they 
work together. 
 

� Turn off all three of 
the settings in the top 
section. 

 
We will only be painting 
displacements at this point, 
so don’t want to use color or 
material effects. 
 

� Turn on Double Sided. 
 
This is why it was important 
to snap the head to the Z 
axis.  Projection Master will 
make our work easier by 
painting both sides of the 
model at the same time. 

 
� Turn on Deformation and leave the Normalized setting 
active. 

 
� When the settings are correct, click the Drop Now 
button. 

 
� Using a stippled alpha brush add some detail around the 
eyes, cheeks and mouth and down onto the neck. 

 
It is possible to use any alpha images as brushes at this point. 
These can be imported into the Alpha palette using Alpha>Import. 
 
For the neck area I used a wrinkled alpha that allows me to stamp 
wrinkles onto the neck without having to paint each one on. 
 
This alpha is provided in the Resources 
as neck_wrinkle_alpha.jpg. 
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� Next, pick the model back up off the canvas using “G” 
again and select the PICK UP option.  

 
The model is now back into EDIT mode and should have been 
changed according to your alpha painting. 
 

� Rotate the head back to the front, using SHIFT again so 
that the model looks straight out of the canvas. 

 
� Hit “G” again and drop it back down to canvas. 

 
Make sure that you don’t have “Double Sided” checked, or the 
changes that you make to the front of the head will be reflected 
on the back. 
 

� Now using more ALPHA BRUSHES make any changes that 
you see fit. 

 
Use different brush sizes and Z-INTENSITY settings to vary the 
effect. Remember that this part is not symmetrical so you will 
need to do the changes to both sides of the face. 
 

� When you are done, use Projection Master to pick the 
model up again.   

 
You will see your painting transferred to the model. 
 

� Using these methods, reveal and re-hide parts of the 
model and use Projection Master over and over again, 
changing the rotation of the model each time until you have 
added enough detail to suit. 
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Use this image as a reference while you work on detailing the rest of the body. 
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Character 
Modeling Part 3 – 
Texture & Material 
By Glen Southern 
Now that the model has 
been fully sculpted, it’s 
time to finish the figure 
by painting texture and 
applying materials. 
 
 
 
 
 
 
AUVTiles is incomprehensible to 
the naked eye, but easily 
recognized by the computer.  It 
offers a zero distortion form of 
UV mapping, and so is ideal for 
painting via Projection Master. 
 
Because AUVTiles unwraps 
each polygon to its own square, 
it should not be used on a 
model with triangles.   
 
An alternative to AUVTiles is the 
new GUVTiles.  This method 
unwraps groups of polygons as 
a unit.  It attempts to keep the 
polygon groups as large as 
possible while still maintaining 
distortion-free mapping.  It is 
also ideal for models with 
triangles. 

The third and final part of this tutorial is to add some color to the 
figure using a texture map and some material properties. This 
section deals with a few choices I made to texture this model and 
serves only as an introduction to the Material and Texturing 
potential of ZBrush. 
 

Creating a Texture Map with Projection Master 
AUVTiling 
Once the model is complete we can start to work on a texture for 
it. ZBrush has a number of different UV modes but for this 
exercise we will be using AUV tiling. 
 

 
 
Adaptive UV Tiling maps the selected texture onto an object by 
assigning a small rectangular area of the texture to each polygon. 
The portion of the texture map assigned varies according to the 
polygon’s relative size. Larger polygons are assigned larger areas 
of the texture map, based upon the AUV Ratio setting. 
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ZBrush is optimized for texture 
dimensions that are a power of 
two.  You will get best results 
with the following sizes:  
256x256, 512x512, 1024x1024, 
2048x2048 or 4096x4096. 

 
� In the Texture Palette enter a 
new size for the texture map that 
you wish to create.  

 
As we want to create a detailed map for 
the whole body create it at 2048x2048 (or 
4096x4096 if you have a lot of RAM).  
 

� Select a dark skin tone in the 
Color Palette.  

 
This will become the base color for the 
texture map. 
 

� Click new and a texture map will 
be created using the base color. 

 
� Click Tool>Texture>AUVTiles to 
assign the mapping. 

 
ZBrush also supports Cylindrical, Planar, 

Spherical and group UV tiles in addition to the Adaptive tiling that 
we are using here.  It will also use UV coordinates given to an 
imported model from other programs. 
 

� To detail the texture map we can use the Projection 
Master function again but this time we will leave 
DEFORMATIONS turned off and work solely with color. 

 
� Using the GYRO and SHIFT, spin the model to a side 
profile. 

 
� Use 'G' to activate Projection Master.  Make sure that 
Color, Fade, and Double Sided are turned on, then press 
Drop Now. 

 
� Use Alpha brush 23 and a 
slightly lighter shade of your base 
color and start to paint areas of 
the model that are not in a recess 
or fold. 
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Use a small Brush Size and a low Z-intensity and build up the color 
slowly. Don't be tempted to change the color yet as we need to 
apply this first coat all over the mesh to give consistency. The 
idea will be to build up layer upon layer of color dropping and 
picking up the model as you go. 
 

 
 

� Pick the model up (G) and rotate it to the front using 
SHIFT to lock it to Z. Continue texturing in the same way, 
adding more and more detail. 

 
Don’t forget to turn off Double Sided! 
 

� Apply the same principle as you did on the side, slowly 
building up some color on areas that are not recessed. 
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You can select a new Alpha brush from the Alpha palette or use 
one of your own but this initial stage is really laying down a base 
layer so it shouldn't matter too much for now. 
 

� Pick it up again. Rotate it forward so that the top of the 
models head is facing you and do the same for his skull and 
shoulders. 

 

 
 
You may find that you have to drop the model to canvas in some 
odd angles to get the texture map right. This is fine, but 
remember that what ever angle it is you will have to do the same 
on the other side of the model. 
 

Creating a Material 
This section could be a whole tutorial by itself. The material 
Palette of ZBrush 1.55b was a huge area to discover and version 
2.0 just adds more. I will simply create a material and use some 
of the new settings available in the new version. 
 
Materials basically tell the rendering engine how to deal with 
light.  They can also achieve special effects such as creating 
fibers or cavity shading. 
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The finished model (shown on the next 
page) uses our texture map and a modified 
Basic Material.  
 

� Place the Material palette in a Tray 
so that you can work with it more 
easily. 

 
� Select one of the Basic materials. 

 
ZBrush 2’s main addition in most of the 
shader channels is the section containing 
the Cavity settings.  This new set of sliders 
lets you add color to recessed areas on a 
model (or raised areas, depending on your 
settings). 
 
The first of these settings is the Cavity 
Intensity.  It can be set from -1000 to 
+1000. 
 
The second, Cavity Radius, sets how far 
color will be applied away from the 
cavity’s deepest point. 
 
Cavity Colorize controls the color of the 
cavity shading based on the chosen color in 
the Cavity patch (at the bottom of the 
palette). 
 
For example, our model 
needs a dark skin tone in 
the cracks, but if we chose 
a red color this would 
happen:  
 
And finally, there are Cavity Diffuse and 
Specular, which control those settings 
within the cavity area of effect. 
 
For this model I have chosen to give it a 
small amount of color Color Bump as well, 
which will raise up the lighter areas of the 
texture map. 
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For your convenience, the material is also provided in the 
Resources as CavitySkin1.ZMT. 
 

 
 

� When the settings are done, click Render>Best. 
 
Cavity shading only appears 
during a Best render. 
 
Feel free to experiment with 
the lighting and render 
settings.  The images above 
were done with a single light. 
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Box Modeling Part 
1 - Modeling 
By Lonnie Sargent 
This section of the 
multipart tutorial covers 
how to use ZBrush 2’s 
Edge Loops feature for 
modeling detailed 
meshes. 

 
 
With the introduction of Edge Loops and many other exciting new 
features in ZBrush 2.0 we now have more flexibility than ever in 
our approach to building models.  A common method in the 3D 
world for building models is called “Box Modeling.”  A simple cube 
is taken and formed into a basic shape to which additional detail 
and form is added.  This can be done in ZBrush 2.0 now as well, 
but ZBrush offers its own unique base modeling methods which 
greatly simplify the Box Modeling technique.  In Part 1 of this 
tutorial we shall use ZBrush box modeling techniques to build and 
define a low-density mesh.  Part 2 of the tutorial will explore 
refining and detailing the model using new techniques and 
features found in ZBrush 2.0.  Part 3 of the tutorial will cover 
texturing, painting, rendering and post work.   
 
The two alphas that are used in this tutorial are available in the 
Resources\Sargent folder. 
 
These tutorials are of an intermediate level.  It is assumed you 
have a basic understanding of ZBrush and its features.  If you 
have not done so, please go through the starting sections of this 
manual and the ZScripts that were included with ZBrush 2.0 in 
order to familiarize yourself with all the new features.  Of 
immediate importance is that you understand and are  
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comfortable with the new polygon selection capabilities 
presented in ZBrush 2.0.     
 
During the course of the tutorial I work in a document size of 1280 
x 960.  At the end of each of the steps of the tutorial I highly 
advise you to save your tool.  In the event something happens you 
can always load the last saved tool without fear of having to start 
the tutorial from the beginning again.  Save your tool and save 
often! 
 
Now without further ado let us begin our journey. 
 

� Create a basic ZSphere object that looks similar to the 
one I have created.   

 
You will notice as 
you create the 
object that the 
spheres are 
different from 
earlier versions of 
ZBrush.  The 
spheres are two-
toned and you will 
see triangular 
vectors within it.  
The dual colors 
allow easier 
manipulation of the 
spheres and 
indicate the orientation of the mesh (press A on the keyboard to 
preview the mesh).  The triangular vector inside the spheres 
indicates the child/parent relationship of the currently selected 
sphere.  The benefits of this feature become more evident when 
dealing with larger ZSphere objects containing hundreds of 
branching sphere chains. 
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� We will be 
using an 
Adaptive Skin 
for modeling 
so set the 
Density of the 
Adaptive Skin 
to 1 and skin 
it. 

 
�  Clear the 
document and 
draw the new 
skin out onto 
the document.   

 
� Enter Polyframe mode.   

 
We will be working in this mode through the rest of this chapter.  
 
It is possible that your base mesh may not look like the image on 
the right.  If this is the case you may use the selection features in 
ZBrush 2.0 to isolate the mesh as shown in the six steps below to 
reassign polygroups.  This is not entirely necessary in this 
tutorial, as it will not affect the final outcome of the model we 
are working on but for purposes of following the tutorial you may 
find it helpful to match your mesh to the mesh I have created in 
the image on above.   
 

� You may find it necessary to tweak the model a bit by 
entering EDIT>MOVE and moving the vertices around.  Make 
sure you are in X-Symmetry mode when doing this by 
pressing the X key on the keyboard.   

 
You should see two red dots appear in symmetrical relation to one 
another on the model.  Move the vertices around until you are 
satisfied. 
 

 
 
1) The default polygroups generated; 2) Select the blue polygroups (your 
actual colors may differ); 3) The blue polygroup is selected and the remaining 
mesh is hidden; 4) Invert the selection; 5) Assign the selected area to a new 
polygroup; 6) The final grouping. 
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� Subdivide the object once by pressing Divide located in 
the Tool>Geometry pallet.   

 

 
 
You should now have two subdivision levels.  By subdividing we 
are generating additional polygons, which will help us to further 
define groupings and place additional Edgeloops as we model.  
Before we place the Edgeloops we must delete the lower 
subdivision level first.   
 

� Go to TOOL>GEOMETRY and DEL LOWER.   
 
It is located in the same pallet as the Divide command.   
 
Edgeloops may only be created on the lowest subdivision level 
thus for our purposes this step is necessary. 
 
Now we will create the eyes.   
 

� While holding the Shift key rotate the object on the 
workspace until it snaps into a full side view.   
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CTRL+SHIFT DRAG to select the two rows of polygons depicted in 
the image below.   
 

 
 
With the object at a full side position we will be able to select 
the polygons needed on both sides of the head at the same time. 
 
We need to further isolate the polygons we wish to work on.  To 
do this we will use the constrained HIDE SELECTION feature.   
 

� Rotate the rows of polygons while holding the SHIFT key 
so that they snap into a top view.   

 
� Then press CTRL+SHIFT and begin dragging the selection 
box across the top polygons.  Release both CTRL and SHIFT 
but continue to drag the selection box.   

 
You will notice it will turn from green to red.  This indicates that 
any selection made with the red selection mode enabled will 
remove polygons from the currently selected group.  This is the 
opposite of the green selection mode which selects polygons.  
This is a handy feature but can be a bit tricky to get accustomed 
to at first. 
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You should now have two polygons on each side of the head 
selected.   
 

� Create an Edgeloop on the selected polys. 
 

 
 
It will be necessary to move the vertices 
around so they conform more to the shape of 
the original polys.   
 

� Enter EDIT>MOVE mode to do this.   
 
Ultimately when the model is subdivided 
several times this “square” area will become 
rounded. 
 

� Hide the outside edgeloop of polygons 
by CTRL+SHIFT+LMB Clicking on them. 
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� Create another Edgeloop and move the vertices once 
again.  This time move the vertices inward to create depth.   

 
This will become the basis of the eye socket later on. 
 
Once you have completed cutting in all the additional edgeloops 
for the eyes and moving the vertices accordingly you should have 
something similar to the picture below.   
 

 
 
It is important to cut in all the edgeloops that we need at this 
stage.  If you wait until after you have modeled in details to add 
edgeloops you will be in for a nasty surprise.  Edgeloops add 
geometry and if you add geometry after you have detailed your 
model you will find the change in mesh topology will destroy 
much of the detail you created.  So it is a good habit to train 
oneself to think ahead and get those loops in early on during the 
initial model development. 
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Next we will select the jaw area and 
begin to add edgeloops using the same 
method we used for the eyes.   
 

� Select the polygons just below 
the eyes all the way through the 
first row just behind the eyes. 

 
� Create an edgeloop and move 
the vertices if need be. 

 
� Hide the edgeloop of polygons 
you just created. 

 
� Clean up the vertices by 
moving them. 

 
� Create another edgeloop. 

 
� Hide the outer edgeloop once 
again and create another 
edgeloop (not shown here). 

 
 
Your model should now look similar to 
the image below.   
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Move vertices around a bit and make any final adjustments that 
beg for attention. 
 

� Use the same procedure to create edgeloops for the 
nostrils. 

 

 
 
Next we shall create the 
top ridge of plates that run 
along the top of the head.   
 

� Select the polygons 
that run along the top 
of the base of the 
nostrils all the way to 
the back edge of the 
neck as shown in the 
image at the right.  

 
� Next you will create 
an Edgeloop.  

 
It should look similar to the 
image at the right. 
 

� Make sure to move 
the vertices on the 
outer edge out closer 
to those edges.   

 
Now we are ready to move on to making the actual ridges. 
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To create the ridge polygons on the back of the head we will use 
Edgeloops to extrude and make new polygons for us.   
 

� To do this we first select the polygons that will become 
the tops of the ridges.   

 
The front three polys will each become a separate ridge and the 
back two polys near the base of the neck will form the largest 
ridge.   
 

 
 

� Select just the tops of the polys (see bottom of image) 
then enter EDIT>MOVE and move the vertices upward.   

 
� Next click on the EDGELOOP button.   

 
New polygons will be created between the original position and 
the new position of the vertices.  The blue edgeloop in the image 
shows what this would look like when done correctly.  The last 
step would be to move any vertices around that might need 
tweaking to get the final form. 
 
Following this same procedure we will create a set of horns for 
our dragon creature.   
 

� Select the polygon that is about midway between the 
jaw and the base of the neck.   

 
Make sure to select it on both sides of the head and be certain 
you are in symmetry mode.   
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� Create an Edgeloop around these selected polygons.   
 

� Then select the inside polygon and using EDIT>MOVE 
move the vertices out and away from the head.   

 
� Create an Edgeloop and you should have the first 
building block of your horn. 

 

 
 

� Repeat the process and while you are moving the 
vertices about make sure to turn them ever so slightly as 
you proceed so the horn has a gradually twist toward the 
front of the face.   

 

 
 

� Finish off by moving the vertices to give the horns final 
shape. 
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Creating the neck plate at the base of 
the neck involves the same Edgeloop 
extrusion process.   
 

� Select the last two rings of 
polys on the base of the neck. 

 
� Using Edit>MOVE, move the 
vertices up and outward away 
from their original position.   

 
� Use the Edgeloop command to 
generate the additional polys.  
Then immediately follow it with 
another Edgeloop command.   

 
You should get results similar too the 
image on the right.  We are after that 
small ring of polys on the inside edge 
so make certain you generate them with the Edgeloop command. 
 

� To finish off the neck plate, move the vertices to form a 
nice sweeping form.   Flare it out near the top and tighten it 
up near the bottom of the neck.   

 

 
 
Don’t be afraid to exaggerate the form a bit.  However, be 
careful to keep the vertices in a neat and orderly fashion.  If they 
become jumbled up now, then they will be all the more messy to 
work with once you have subdivided the mesh several times.  It is 
much easier to set things correctly now than to fix them later. 
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The last step in creating our base mesh will be to determine areas 
that should have sharp edges.  We will do this around the eye 
socket, the base of the horns, and the base of the neck plate.   
 

� Simply select the yellow eye polygons, all the polygons 
that comprise the horns, and the blue and purple polygons 
that make up the neck plate.   

 

 
 

� Next simply press the Crease button located in 
TOOL>GEOMETRY menu.   

 

 
 
Small dotted lines will appear around the edges of your selected 
polygons.  When subdivided, these edges will remain weighted or 
crisp and will not be smoothed.  The CreaseLvl setting next to the 
Crease button tells ZBrush how long the crease will be 
propagated when subdividing.  If left at the default value of three  
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then the crease will remain in effect through three subsequent 
subdivisions after which it will begin to smooth.  Crease is a very 
powerful tool that can aid you in both organic and mechanical 
modeling. 
 
The final model should look similar to the image depicted below.  
If you feel confident enough about the tools I encourage you to 
experiment and make alterations.  Experiment and have fun. 
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Box Modeling Part 
2 – Creating Details 
By Lonnie Sargent 
With the base modeling 
complete, the tutorial 
now moves to the subject 
of high resolution details. 

 

 
 
In this second chapter we shall be focusing entirely on detailing 
our model using many of the new features to be found in ZBrush 
2.0.  We will take a look at how alphas can be adjusted and put 
to good use, how to create custom alphas on the fly while 
modeling, and how to use Projection Master to advantage 
painting in details.  So fire up ZBrush 2.0 and load the model you 
created from Chapter 1 of the tutorial if you haven’t already done 
so.  Let’s have fun. 
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� The first step will be to Divide the mesh twice.   
 

  
 
This should place the mesh at three subdivision 
levels.   
 
During this “roughing out” phase I like to use 
several TRANSFORM>EDIT BRUSHES.  These 
can be found in the Transform pallet.  My 
particular favorites at this stage of the 
modeling are Standard and Inflate.   
 
I switch back and forth on brush sizes – large 
sizes to cover large areas and small sizes to do 
finer edge work.   
 
Generally a Zadd setting of around 8 to 12 will 
suffice.  It is at this point where all the extra 
edge loops we created around the eyes and 
mouth will come in handy.  With the added 
geometry in those areas we can inflate and add 
detail much easier without fear of stretching 
too few polys over a wide surface area.  Should you run into a 
situation where an area has become overworked and looks a bit 
nasty then just use the Transform>Edit Smooth Brush and 
smooth out the polys.  This edit feature is ideal for fixing 
mistakes, smoothing rough spots, or even flattening the surface of 
an area.   You can also store a morph target and then use the 
Morph brush to revert to the stored geometry.   
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After you have worked over the model use Edit>Move to move 
large areas like the neck flab into a more natural-looking state.   
 
You will want to take the opportunity to shape the eye at this 
point.  Move the polygons around the eye area to create a round 
socket.  You can clean up afterwards if need be with the Smooth 
Brush. 
 

� The ridges on top of the head need to be a bit larger so 
CTRL+SHIFT+LMB CLICK to select them then perform an inverted 
selection by SHIFT+CTRL+LMB Dragging across the document 
area away from the model.   

 

 
 
This in effect hides the area you selected first and reveals the 
areas that were hidden.   
 

� CTRL+LMB CLICK anywhere within the document window 
but not on the model itself.  This will mask the visible area.   

 
� You can now reveal the entire model and as you can see 
the entire model save for the tops of the head ridges has 
been masked.   
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Set your brush size to a large size (around 50) and proceed to 
EDIT>MOVE the vertices until you get the shape and form you are 
after.   
 
The masking ensures that the rest of the model will remain 
unaffected when we use our large brush size to move the vertices 
of the head ridges. 
 

� We need to tighten up a few lines so let’s use the Pinch 
Brush.   

 
� Set ZAdd to 50 and set the brush size to about 8 or 10.   

 
� Use it on the line between the lips and also near the 
base of the horns where the horn meets flesh.   

 

 
 
This will tighten the lines and give a nice sharp form.  I often use 
Pinch on eyelids, lips, teeth, and around the nostrils.  It is also a 
very handy tool for making scars. 
 
Let’s add a little more detail around the mouth.   
 

� First Divide the mesh two more times.   
 
You should be at five subdivision levels now.   
 

� Using the Standard Brush turn on Zsub with a setting 
around 10 and a small brush size and sub out the areas 
where the two teeth will be placed.   

 
Use the Smooth Brush to smooth out areas that get a little rough 
and continue.   
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� Next use Zadd with the Standard Brush and begin 
working in some basic teeth shapes.   

 
� Use Inflate Brush and Pinch Brush to punch the details, 
especially around the edges of the teeth.   

 

 
 
There is no need to overwork it at this point since we will be 
coming back to the teeth once we have subdivided again.   
 

� Use the Inflate Brush to add in some detail around the 
snout area.   

 
� Use Edit>Move to push some of the polys around to get a 
more pleasing shape.   

 
I did that with the nose to get more of a slope on top. 
 
Now let’s add some bumpy bits to the model.   
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� Use both Standard Dot Brush and Inflate Dot Brush to 
place some bumps and warts around the face area.  

 

 
 
I used the Standard Dot Brush with a high setting to create the 
little horns near the mouth opening. 
 
Now it is time to roll out the big guns and get Projection Master 
cranking.   
 

� Divide the mesh two more times.   
 
This should put it at seven subdivision levels.  Be warned, at this 
level the mesh will most probably be around 1.5 million polygons.  
If your system has limited resources you may want to limit the 
subdivision to 6 levels instead of 7.    Remember that you can 
speed up interaction with a high polygon mesh by going to a lower 
subdivision level before rotating it, hiding all but the area that 
you wish to work on, and then returning to your highest level. 
 

� Rotate the model so it is in a side viewing position.   
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� Activate Projection Master.   
 

 
 

� Turn off Colors and make sure 
Double Sided, Fade, Deformation, and 
Normalized are all marked.  Click the 
Drop Now button.   

 
� You are now ready to begin 
displacement painting.   

 
I used Alpha Brush 03 with a Focal Shift 
setting of 70 in conjunction with the 
Simple Brush using DragRect stroke to lay 
in the rough areas on the skin.   
 

� Use small values of Zsub and Zadd.   
 
I generally use a setting of 1 or 2.  When 
working in Projection Master at this point 
we are only concerned with creating 
surface detail so we will be working with 
Zadd and Zsub exclusively.  You should not 
at this time have any other Drawing 
features enabled such as RGB or Material.   
 
The scale texture on the bottom of the 
neck was created using a custom Alpha 
that I created on another layer while 
working on the model.  The 
Resources\Sargent folder contains the two 
alphas that were used.   
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� I used the Single Layer brush with ZAdd and DragRect 
stroke to lay in the scales.   

 

 
 

� Once we are done with this level of detailing, activate 
Projection Master again and click on the Pickup Now button.   

 
The detailing we painted will be picked up and the displacement 
will be calculated and applied to the mesh. 
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You may notice the detail is a little less defined and not as sharp 
as it was when we were painting it on.  The crispness of the detail 
is completely dependent on the mesh density of the model you 
are applying it to.  To retain high levels of fine detail it will be 
necessary to create models with polygon counts in excess of one 
million polygons.  If your computer has the resources you can go 
significantly higher.  If you are having difficulty working on the 
entire model in this manner you can select portions of it and hide 
the remaining mesh.  Projection Master can be used on selections 
just as easily as the whole model.  Working on small select areas 
will help to optimize computer performance and make it easier to 
manipulate large polygon meshes.   
 

� Now, using Projection Master and various alphas, 
continue to paint in details.     

 

 
 
I specifically like to use Alphas 7 and 8 with Focal Shift set to 
around 90 or 95.  These alphas in conjunction with the 
SimpleBrush and SingleLayer Brush make good work of laying in 
lines and creases.   
 

� Use a Zadd or Zsub setting of 1 or 2 and set the stroke to 
Freehand with Zero spacing.   
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� You can also at this stage accent certain areas of detail 
by adding to them.  

 
For example the scales on the neck of our dragon creature could 
use a little more definition.   
 

� Use the SimpleBrush and Zadd to accentuate some of the 
larger scales.   

 
� Do the same on the ridges on the top of the head and the 
lips around the mouth.   

 
� Put lines and creases around the eye socket.   

 
Another custom alpha was used for the bumps on the head.  It is 
also found in the Resources\Sargent folder.   
 

� Activate Projection Master and Pickup the model.   
 
The details will be applied to the mesh. 
 

� We repeat the process to detail the horns and the neck 
plate.   

 

 
 
Notice I selected the horns and neck plate and worked on them 
individually.  This makes it much easier to get into tight hard to 
reach areas.  It also takes the strain off system resources. 
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Here we have the final result.   
 

 
 
I encourage you to experiment with detailing in Projection 
Master using your own custom alphas and settings. 
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Box Modeling Part 
3 – Finishing Work 
By Lonnie Sargent 
With high resolution 
detail sculpted, we’ll 
complete the project by 
focusing on 2.5D painting, 
lighting, materials and 
rendering. 

 

 
 

� If you do not already have it available go ahead and load 
the Dragon Head you created in the previous chapter.   

 
� Draw it on the workspace and move it into final position.   

 
� Enter Edit mode by pressing the T key on the keyboard 
and choose a light sandy brown color from the Color menu.   

 
� Fill the object with this color (Color>Fill Object) and 
drop it to the workspace by pressing the T key again.   

 
It is not necessary to choose a material at this time.  We will be 
creating custom material later on.  The default Fast Shader 
material will suffice for now, and the model will not be moved again. 
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Now we will begin to paint in darker and lighter values of color.  
 

 
 

� Select the Paintbrush, SprayStroke, activate RGB mode 
and set RGB value to 20.   

 
� Select a darker brown and choose a Draw size of around 
80.   

 
� Begin making strokes across the model and darken areas 
to suggest shadow.   
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 The paintbrush allows you to lay increasing values of color with 
each stroke so apply it in short overlapping strokes.  This will 
keep the color from looking too uniform. 
 
We will do the same for adding lighter areas of color.   
 

� Using the same technique as before select a light crème 
color but change the brush size to 40 and apply it with the 
Dots stroke.   

 
� Work in light areas around the face and surface areas 
that should be emphasized.   

 

 
 

� Change the color to a medium red and set the brush size 
to 80.   

 
� Change the RGB setting to 5 and paint in some red to 
give the color work a little more impact.   
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� Switch to a light Cyan color and do the same. 
 

 
 

� Select the Shading Enhancer tool.  Set RGB value to 10 
and select the Dots stroke.   

 
� Set the brush size to about 20 and use the Shading 
Enhancer tool to lighten up areas that should be 
highlighted. 
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This includes raised features such as the brows and head ridges, 
areas around the mouth and neck folds etc.  
 

� Use the Shading Enhancer tool to darken in recessed 
areas by holding the ALT key.   

 
� Paint darker areas where the facial features recede into 
shadow. 

 

 
 
We will now add an eye.   
 

� Begin by selecting the 
Sphere3d tool from the Tool 
menu.   

 
� Select a dark red color and 
choose the Toy Plastic 
material.   

 
� Create a new layer in the 
Layer menu.   

 
� With this layer selected draw the Sphere3d into the eye 
socket.   

 
� Press the W key on the keyboard to bring up the Gyro.  
Move the eye into position.  When done press the W key 
again.   
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� To texture the eye choose 
the Shading Enhancer brush.  
Set RGB intensity to 10 and the 
brush size to 18.  Select Alpha 
01.   

 
� Start by working on the area 
of the Iris.    

 
Lighten it up until you are satisfied 
with the results.   
 

� Decrease the size of the brush to get sharper highlights.    
 

� To paint in the pupil choose the Simple Brush from the 
Tool menu.  Set RGB to 100 and select black from the Color 
menu.   

 
� Select Alpha 12 from the Alpha menu and set stroke to 
DragDot with a size of 8 and place the pupil on the eye.  
Next select Alpha 09 from the Alpha menu and set the brush 
size to 22.   

 
� Position this dark circle as shown in the above image.   

 
� Select the Shading Enhancer brush again and set RGB 
intensity to 5 with a brush size of 15.    

 
� Add additional highlight around the darker area outside 
the pupil to give it additional interest.    

 
� Change brush size to 8 and the RGB intensity to 20.     

 
� While holding the Alt key draw in dark areas around the 
outside edge of the pupil and around the top edge of the 
eye just under the top eyelid.   

 
� Select the Simple Brush, set RGB intensity to 20, select 
the Dots stroke, and set brush size to 4.  Choose a golden 
yellow color from the Color menu.   

 
� Add a few bits of color to the iris area.   
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� Select the Shading Enhancer brush and set the brush size 
to 8 with RGB intensity of 20 and darken the middle part of 
the iris slightly. 

 
� We are ready to apply lighting, materials and render 
settings.   

 
I have provided snapshots of all the settings to help you in setting 
up your final render. 
 

Light Settings 
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Light 1:  Sun 
Intensity: 1.21 
Color: White 
Shadows: 50 with intensity 100 blur 2 
 
Light 2:  Sun 
Intensity: .45 
Color: 255, 143, 106 
No shadows 
 
Light 3:  Sun 
Intensity: .40 
Color: 197, 250, 247 
No shadows 
 

Material Settings 
 
I used two materials, which are identical 
except Material 2 has a specular value of 20. 
 

� Created from the BasicMaterial 
 
Ambient: 0 
Diffuse: 75 
Cavity Intensity: 15 
Cavity Colorize: .3 
Cavity Color: 236, 223, 206 
 

� Apply the new material to the 
model by Copying the material and 
Pasting it into the Fast Shader material 
slot.   

 
The entire model will now be covered in the 
custom material we created.  
 

� Paste the material into another 
material slot and increase the specular 
value to 40.  

 
� Using the Simple Brush with only 
Material selected (Rgb, Zadd etc turned 
off) paint in the specular material 
around the eyes, mouth, nose, and skin 
folds. 
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Render Settings 
 
Fog enabled with Intensity 100 and Depth 2 
of .7 
Alpha used in Fog Alpha 
Contrast Adjustment: 25 
See Adjustment graph in picture 
 

� To create the fog alpha select Alpha 
01 in the Alpha palette and press 
Alpha>Make TX. 

 
� Go to the Texture palette and 
select the newly created texture.  
Click on the Invert button to invert the 
texture.   

 
� In the Render>Fog menu click on 
Fog Alpha and select the fog texture 
we created. 

 
� Click on Best render to generate the 
rendered image.   

 
� Once it is rendered, press 
Texture>Grab Doc. 

 
This is a fast way to capture the entire 
document as a texture. 
 

� Next create a new layer from the 
Layer palette.   

 
� Deactivate the other layers and make sure you select the 
newly created empty layer.   

 
� Turn off Fog in the Render palette.   

 
� Select the rendered image we grabbed in the Texture 
palette.  Select the Flat Material in the Material palette.  
Fill the empty layer with the grabbed image and flat 
material.   

 
You can do this from the Texture palette by pressing the Crop 
And Fill button.  Alternatively, you can press Ctrl+F.   
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We are almost done. 
 
The color is looking a little flat so let’s liven it up a bit with the 
Saturation Brush.   
 

� Select the Saturation Brush from the Tool palette.  Set 
the RGB value to 2 and the brush size to 60.   

 
� Now paint over areas of the model to increase the color 
levels.   

 
Be careful not to overdo it.   
 

� After adjusting the color in this fashion select the 
Contrast Brush from the tool palette.  Set RGB intensity to 5 
and choose Alpha 07 from the Alpha palette.  Make sure you 
are using Dots stroke.   

 
� Drag the brush across portions of the image to increase 
contrast.   

 
A little goes a long way so don’t overdo it.   
 

� Finally choose the Blur Brush from the Tool palette and 
blur some of the farther edges of the image.   

 
Feel free to experiment with the other 2d brushes in the Tool 
palette.   
 
We have now completed our image. 
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This tutorial has touched upon several key elements used when 
working with ZBrush 2.0.  There are numerous other techniques 
that can be used to accomplish the same results we arrived at 
here.  I encourage you to play and have fun with all the various 
tools.  You will be surprised at just how many ways there are to 
skin the proverbial cat within ZBrush 2.0. 
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The Hand 
By Francois Rimasson 
In this tutorial we’ll cover 
a workflow between Maya 
and ZBrush, such as would 
be used in animation.  In 
this part, we begin with a 
box model that has been 
sculpted in Maya. 

Step 1 - Maya 
 

� First, build in Maya a simple model, without any 
triangles. 

 

 
 

� At this time, we create UV coordinates.  
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Personally, I'm used to creating straight UV borders. 
You can use any layout that you like, so long as the coordinates 
don’t overlap.  ZBrush can also assign coordinates automatically. 
 

� Smooth the model, using the Smooth UVs option, and 
extrude some faces to rough out the nails. 

 

 
 

� Select groups of faces, and create Selection Sets. 
 
Polygroups will be automatically created from these sets in 
ZBrush, to help hiding parts of the model. 
 

� Now, it's time to export the model into ZBrush as an 
.OBJ file. 

 
Note:  In the Resources\Rimasson folder, you’ll find the hand 
model, custom Alphas specially created for use with the Deco 
Brush, and the skin and cavity materials I used on the model. 
 
 



ZBrush 2 Practical Guide                                                                                                                         The Hand 361 

 

Step 2 -- Import, sculpt and detail 
 

� Expand the Tool palette, and import the model.  
 

 
 
The model is now a ZBrush polymesh tool that we can edit. 
 

� Drag on your document to draw the model.  
 
While drawing, you can press the Shift key to snap to object axes. 
 

� Press the Edit button. 
 

 
 

� Press Tool>Geometry>Divide a few times to increase the 
mesh resolution. 
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� At this high subdivision level, press Tool>Morph 
Target>StoreMT. 

 
We can then use the Morph and Morph Dot editing brushes to return to the 
original model in places if necessary. 
 
Once the morph target is stored, all of the sculpting brushes become 
available in the Transform palette. 
 

 
 

� Sculpt details such as veins, creases, etc. 
 
To create good-looking creases and folds, we can precisely control 
the shape of the strokes with the Edit Curve and the Focal Shift 
slider. 
 

 
 
When modifying the brush profile, it is good to activate the 
Accurate Curve switch, which yields the best results. 
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Also, while editing the model we can switch between subdivision 
levels.  If we move some vertices at a lower level, the 
deformation will be interpolated across the higher levels as well. 
 

� Try to sculpt as much as you can at each level before 
adding a new one.  

 
� When the model becomes too dense to easily 
manipulate, hide parts of the model by pressing Ctrl+Shift 
and dragging a selection around the part you wish to work 
on. 

 
� We can also mask parts of the model by pressing Ctrl and 
dragging a selection around the part that we wish to 
protect. 

 

 
 
We can store the mask selections as Alpha maps, which can be applied 
later using the Tool>Masking>Alp button. 
 
Polygroups are another great way to control mesh visibility.  They 
were assigned when the model’s selection groups were created in 
Maya, but you can modify them here using the Polygroups menu. 
 
Once the model is at its highest subdivision level, it’s time to 
bring in Projection Master. 
 

� Rotate the model to the angle that you wish to work 
from and press the Projection Master button. 

 
It’s important to select the angle first, since you won’t be able to 
rotate the model again until you pick it up again. 
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� In the Projection Master palette, deactivate everything 
in the top section, leave Fade on, and activate the two 
Deformation buttons in the bottom section.   

 

 
 

� Press Drop Now. 
 
At this point, you can use all of ZBrush’s other tools – including 3D 
objects – to add detail to your mesh. 
 

� One of the best ways to create fine wrinkles is with the 
Deco brush.   

 
You can use the provided alpha02.psd or alpha03.psd textures 
with the tool. 
 

� When you’re happy with the result, press the Projection 
Master button again and pick your model back up. 

 
The model will now be able to be rotated to a new position for 
additional detailing. 
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� When you have finished sculpting, save your model. 
 

Step 3 – Displacement 
Now we’ll generate two maps: a bump map and a displacement 
map.  
 

 
First and sixth subdivision levels. 
 

� Our model has 6 levels of subdivision.  Go to the fourth. 
 

� Activate Tool>Geometry>Cage. 
 
This tells ZBrush to construct a cage model that is similar to the 
high resolution model and can be exported for use in Maya. 
 

� Set Tool>Displacement>DPRes to 2048 and activate Best. 
 
We’ll generate our displacement map at 2048x2048.  The use of 
Best mode allows ZBrush to create an accurate map even if the 
Pinch editing brush has been used. 
 

� Delete the higher levels with Tool>Geometry>Del Higher. 
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� Go to the lowest subdivision level and generate another 
displacement map. 

 
This second map will serve as our displacement map, and will 
serve to make medium-frequency changes to the model in Maya.  
The first map provides the high-frequency detail, and will be used 
as our bump map. 
 
The generated maps will appear in the Alpha palette and should 
be saved for use in Maya.   
 

� Press Alpha>Flip V for each map, then export it. 
 

 
 
It is really important that you save the displacement map out as a 
TIFF file so that it retains its 16 bit depth.  Unlike bump maps, an 
8 bit depth displacement map would create a “staircase” or 
“step” effect because it has fewer levels of gray to make smooth 
displacements with. 
 

� Export your cage mesh at level 1 as an OBJ. 
 

Step 4 – Color and Material 
 

� Select the Fast Shader 5 material, then load the 
Cavity.zmt from the Resources\Rimasson folder. 

 
The new material replaces the selected material.  It’s therefore 
best to always select a material that you know will not be used 
for your project before loading a new material.  The Fast Shader 
materials are usually a good candidate for this. 
 

� Select the second alpha that we created.  In the Color 
palette, choose a pink color. 

 
� Press Alpha>Crop and Fill. 

 
Unlike with the Texture palette’s Crop and Fill, the pixols drawn 
on the canvas will retain depth based upon the alpha’s grayscale 
values.  This makes the next step possible. 
 

� Press Render>Best Renderer. 
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The cavity effect requires a Best render to be seen.  In this case, 
what it does is darken the wrinkles sculpted into the model’s skin. 
 

� Press Texture>GrabDoc to capture the canvas as a new 
texture. 

 
We now have a basic color texture. 
 
At this point, let’s take a look at the hand in ZBrush. 
 

� To create the skin material, use the ColorizerTriShaders 
material. 

 
The skin translucency is simulated by using 2 shaders and 
wrapping the light diffusion around the model on the second 
shader using the Anisotropic Diffuse parameter. 
 
A bluish specular color also helps to create a realistic rendering. 
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Now let’s detail the texture a 
little bit. 
 

� Create a new 
document, reload the 
hand model, the skin 
material, and the texture. 

 
� Activate Projection 
Master and drop the 
model. 

 
� Select the Simple Brush 
with a very low Rgb 
Intensity setting and start 
by adding color variations 
for the finger tips, the 
palm, and the veins. 

 
� To add finer details, 
we’ll use the HighlighterBrush II with a Freehand or a Spray 
stroke. 

 
Another way of adding details is to use a Stencil. 
 

� Load the skin_text.psd picture from Resources\Rimasson 
into the Alpha palette. 

 
� Press Alpha>Make ST to convert the alpha into a stencil. 

 
� In the Stencil palette, activate Wrap. 

 
When working with the stencil, you can access the interactive 
coin controller by holding down the spacebar. 
 
At this point, you can paint through the stencil to add still more 
detail to your texture. 
 

� For the nails, duplicate the skin material and modify it to 
have sharp specular properties. 

 
� Paint this new material onto the nails. 

 
You now have a great hand in ZBrush!
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Step 5 – Back in Maya 
If you’re working on a big production, your model may have 
already been skinned and animated by other people.  That’s why 
Vertex order is important and shouldn’t change. 
 

� Open your original model in Maya and import the new 
one. 

 
� In the import options, don’t forget to uncheck Create 
Multiple Objects. 

 

 
 
If everything worked fine, you can create a blendshape between 
the two models. 
 

� Convert your model into a Subdiv Surface. 
 
Displacement in Maya is best handled by Subdivision Surfaces, so 
you should use them. 
 

� Set the Tesselation attributes of your model and uncheck 
the Feature Displacement. 

 

 
 

� Assign the bump, displacement, and color maps. 
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� Now set up your displacement.  Adjust the intensity with 
the Alpha Gain slider.  As a 50% gray value shouldn’t 
produce any displacement, notice how the Alpha Offset is 
used to correct intensity. 

 

 
 

� Render your model. 
 
Now let’s imagine that your production manager wants you to 
modify the displacement map.  ZBrush makes it easy to restore 
your high resolution model from the displacement map itself! 
 

� Re-import your model in ZBrush. 
 

� In the Alpha palette, load your displacement map and 
flip it vertically. 

 
Since you flipped it vertically before exporting, you need to flip it 
again on import. 
 

� Divide the model several times so that you’re back at 
subdivision level 6. 

 
� Turn off Quick 3D Edit, then set Tool>Display 
Properties>DSmooth to 1. 

 
This activates ZBrush’s render smoothing. 
 

� Activate Tool>Displacement>Mode. 
 

� Assign a texture. 
 
I used a white texture in my example, so that you can see the 
displacements. 
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� Modify the Displacement>Intensity value until the model 
looks right. 

 

 
 

� Press the Apply DispMap button. 
 
The detail created by the displacement map is now transferred to 
the model itself, and you can continue sculpting. 
 

� When finished, create a new displacement map. 
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Quick Starters 
Guide 
By Martin Krol 
In this tutorial, Martin 
explains his workflow for 
an animation pipeline.   

 
 

Introduction to ZBrush, and ZSpheres 

 
In this Tutorial we will create a full figure character. We will first 
start inside ZBrush, creating a prototype model out of ZSpheres, 
then make an adaptive skin out of it which will be taken into 
another application to give detail to the cage and wire it in a way 
that will make ZBrushing details into the model easier down the 
road. To finish off, we will add color to the model. This tutorial is 
written with new users in mind. Expect lots explanations, so make 
sure to read carefully 
 
When launching ZBrush, you will right away notice changes made 
to the interface from the last commercial version. Most notably 
are the trays being hidden away. This is because you can now 
more easily access the separate menus and properties from drop 
down menus at the top of the screen. 
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An Interface Layout 
 
Start with increasing the document size from the default 640 x 
480 resolution to 1280 x 960.  
 

� Go to the document menu that is found near the top left 
section of the interface, and simply press the “double” 
button. 

 
(Note: Making your document size smaller gives you better refresh 
while working on your model and having it zoomed in, so it’s 
really up to the user to decide what kind of document size is 
optimal to him.) 
 
To place a ZSphere (or any tool 
that you will be working on), 
there are several ways to go 
about it. One direct method is to 
right click on the canvas to bring 
up the QuickMenu (figure 1.2), 
left click on the paintbrush, and 
choose your new tool. The other 
way is to go to the “Tool” drop 
down menu, near the top right 
side of the interface, and once 
again click on the paintbrush 
button. Personally I use the  
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QuickMenu more often just because I don’t like to travel too much 
around the interface. So I grab things from where my cursor is 
currently at. After clicking on the paintbrush button:  
 

� Select the ZSphere tool (it looks like a red pokeball.) 
 

 
 

� Draw it on the canvas. 
 
Click and hold, while dragging mouse in any direction, and 
release. 
 

� When you draw any 3 dimensional item, the first thing 
you want to do is right-click to bring up the menu and select 
the Edit button.  

 
This will make sure that you can manipulate the geometry, and 
not have to worry about ZBrush converting your model to Pixols. 
 
With the ZSphere in edit mode, we can begin to work on it. (Note: 
At this time I recommend changing the draw size to 1. if you have 
your draw size set higher when working on ZSpheres, you will get 
a sort of “magnet effect” when you have more limbs in place. At 
the moment we don’t want this, so make sure to use draw size = 
1.) 
 

� Go to the Transform palette, and about ½ way down the 
menu you should notice a number of buttons that say X, Y, 
Z. 

 
These buttons toggle Dynamic Symmetry, which you will see 
update as you draw. 
 

� Press the X button, and when you go back to the 
ZSphere, notice that you now have 2 cursors over the 
model.  
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� Draw a single ZSphere on top of the model to get 
something similar to the image. 

 

 
 

� Right click to bring up the menu, and switch from Draw 
to Move. 

 
What we have so far is what we will use for the chest and the 
shoulders.  
 

� Use move to position the shoulders how you like.  
 

� Switch back to Draw. 
 

� Draw more ZSpheres coming out of the shoulder.  
 

� Switch to move, and position them so you have a full 
arm.  

 
You can click on the ZSpheres/joints or the bones while 
manipulating the model to get different effects (same when using 
scale and rotate).  Try out both methods.  If at any time you feel 
that you need to add new spheres between joints, use the draw 
command and click on the bones to split them. 
 

Navigation  
At this point, you might want to know how to navigate in ZBrush.   
 
To rotate: Click and hold the left mouse button outside the model 
and drag the mouse around. While working on models you will 
most likely want to snap the viewport into views such as the side 
view or the top view. To do this while you are rotating around a 
model, press and hold shift.  You can also press the “Rotate” 
button on the right shelf.  
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To Pan:  Press and hold alt, and then use the left mouse 
button outside the model. You can also press the 
“Move” button on the right shelf. 
 
To Zoom:  Zooming is similar to panning because you 
start off by pressing and holding alt, then left-click. 
This activates panning. To go into zoom mode, release 
alt. You can also press the “Scale” button on the right 
shelf. 
 
The top buttons (Scroll/Zoom/etc.) relate to document 
navigation that is meant for when painting, when using 
the 2d toolset, or when texturing models. 
 
One useful command when modeling inside ZBrush is 
the “local” button that is found on the right shelf of the 
interface. How this works is, every time you make any 
edit this command moves the rotational center onto the 
last spot you pressed your mouse on. 
 
This makes rotating around a model much easier, so I 
suggest keeping this button turned on.  
 
When you get far enough along making the ZSphere 
model, you might want to start to preview the mesh. 
You can do this in 2 ways. The fastest way is to press 
the “A” hotkey. The other way is to go into the Tool 
palette, open up the Adaptive Skin sub menu, and press 
the preview button. 
 

 
ZSpheres and Preview modes. 
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If you are not getting wanted results, try these settings (that I 
used for this particular model).  
 

� Go to the Adaptive Skin menu: 
 
Make sure the “Mc” and “Mp” buttons are checked on. 
 
Set the Intersection Resolution (Ires) slider to something low, 
like 4 
 
Set the Membrane curvature (Mbr) slider to something high, 
like 90+ 
 

 
Fuller body. 
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ZSpheres done 
 
Saving 
When you work for a while and you feel that you need to save 
your model, the most common mistake for new users is that they 
try to go to save document.  This is not the same as saving the 3d 
model.  In ZBrush, what you do is save elements that you can 
reuse for later.  This includes tools, (such as in this case where we 
want to save your model). You will find save and load buttons 
under a number of the palettes.  
 

� Go to the Tool palette and save your tool. 
 
Adaptive skin and moving on. 
The ZSphere creation process should have been rather painless, as 
all you do is draw new ZSpheres, scale them up or down, and 
move them into place. One advantage of using ZSpheres for 
starting a character’s skin is that you can decide the proportions 
of the character, and pose them with great ease.  
 
Now that we are done with the ZSpheres however, it is time to 
commit to a mesh.  
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� Make sure to preview your model, and that you like your 
current look.  

 
Don’t be too picky if not everything is perfect, because we will 
use some vertex-level editing to fix up the form of the character.  
 

� If the model is to your satisfaction for this step, press 
Tool>Adaptive Skin>Make Adaptive Skin. 

 
When you press the “Make Adaptive Skin” button, ZBrush makes a 
new object/tool with the mesh we will work on. Before we work 
on this new tool however, we need to clear the canvas with the 
current tool we have.  
 

� Turn off the edit button, then press undo.  
 
This should clear the Tool you used for building. The reason the 
model disappeared was that there was only a single action that 
we used on the actual “canvas mode”, and that was to draw the 
ZSphere tool onto the canvas.  
 

� Right click on the canvas to bring up the QuickMenu, and 
then choose the tool icon (currently the ZSphere) on the top 
left.  

 
� You should notice that the menu has a new object by the 
name of “Skin_ZsphereCopy”. Pick it, draw it onto the 
canvas, and go into edit mode. 

 
On my particular model I don’t like how the feet came out. 
Usually I could spend time in the adaptive skin submenu and try to 
play with the switches/sliders to get more acceptable results. But 
sometimes it might take too long to try and achieve a perfect 
result, when we could just move a few points later down the road 
to get what we wanted all along.  
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 � For tweaking we will set the brush to Move, and draw 
size still at 1.  

 

 
 
This will let us work on single vertices, and move them into place. 
For tweaking Volume you might want to use a larger radius than 
draw size 1. 
 

� When you are done with the tweaks, Save your model. 
 

Exporting, and Continuing the Model 
 
For this model I will be working outside of ZBrush to work on the 
animation cage. I will be using Clay for the task. Since this quick 
starters guide focuses on how I make this model and work within 
ZBrush, I won’t explain how to use clay, but rather a few notes on 
polygon distribution. 
 

� Click Tool>Export. 
 
Before we can work on the model inside our application of choice 
we have to export the model. At the moment we don’t need any 
particular properties for the object file, so a straight export by 
clicking the Export button is all we need. 
 
I shaped the model inside clay until I came to a good enough mesh 
for this tutorial. 
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Imported model 
 
When modeling your characters that you plan to do high detail 
modeling on, there are a few things you need to always keep in 
mind if you want to get good results. 
 
The biggest thing is poly distribution. When placing 
edges/polygons on your model, make sure you have enough detail 
on the areas you plan to do your heavy detailing. The reason this 
is important is because your computer will only accept so many 
polygons before it gives up. When you arrive at a polygon count 
that your computer can barely handle, you don’t want to be in a 
situation where you won’t be able to put the detail that you’d 
like to because you would need another subdivide to achieve it. 
So before you import your model back into ZBrush, make sure that 
you are happy with the polygon distribution. 
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One common rule when subdividing modeling organic objects is 
that you should only add detail where you need it. (Mostly for 
animation purposes.)  So areas like the back of the head, or the 
characters back as a whole, won’t receive as much attention as 
the face. Of course if you plan on detailing the back, then for 
better results I suggest you add more edges to the areas that you 
will be working on (and spread evenly.) 
 
When dealing with man-made objects, a common problem that 
I’ve come across is when they contain creases; those objects 
often also are associated with very rectangular-shaped polygons. 
Rectangular-shaped polys can be rather troublesome when you 
want to paint details such as cracks (or just standard wear and 
tear) around the crease. So the best thing you want to do is try to  
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eliminate any rectangular polys by adding an extra edge loop or 
two. On the example below you can notice some rectangular-
shaped polys around the belly area. I won’t be adding any really 
heavy detail to that area so it is fine in this case. 
 

 
Poly distribution 
 
Important Geometry Cleanup 
Before exporting back to ZBrush, you might want to try to 
optimize your mesh, if it isn’t already. ZBrush will let you import 
geometry with Ngons, but it will triangulate all of them. This is 
usually not wanted, especially if you plan on using symmetry. You 
will still be able to use symmetry regardless, but only the dynamic 
symmetry mode that is found in the transform menu (in ZBrush) 
will work effectively. The down side to the dynamic symmetry is 
that it forces you to have both sides of the model visible if you 
want it to work.  
 
This means you need twice the visible amount of polygons visible 
at all times, and can slow down the update of your strokes while 
you are painting. As a result you will get a “bubbly” effect of your 
strokes. So to setup your model to be able to use the “smart  
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On slower machines expect to 
use Smart Resym more so than 
the dynamic symmetry.  These 
steps are then especially 
important.  

resym” tool (Tool>Deformation>Smart resym) you want to make 
sure the model is 100% symmetrical. What I like to do is go either 
into Wings 3d or Mirai, and go to “Select>By>Faces With>5 or 
more” and then use “Tessellate>Quadrangulate.” 
 
If you were working within an application that allows isolated 
vertices placed in 3d space, then you might want to use a cleanup 
tool to get rid of any floating verts. 
 
After you quadrangulated and deleted any unwanted verts, make 
sure the model is 100% symmetrical.  If you were using symmetry 
while quadrangulating, then you “should” have nothing to worry 
about, but if the model had frozen symmetry then you can expect 
that the application didn’t keep symmetry in mind when placing 
the triangles inside the Ngons. To solve this, delete ½ the model 
and re-symmetrize it.  
 

 
Smoothed test 
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For the remaining work I 
recommend using a Wacom 
tablet. 

Smooth the model to see if any of the new edges cause pinching. 
If it smoothed ok then export an object file. 
 
Note:  if you are going to want to use Photoshop for 
painting/editing textures, make sure to setup the models UV’s 
before exporting. I will be using AUTO UVs 
 
 

Back in Z, and Ready to Roll. 
 
Finally we get to the good stuff. The model is all ready to do the 
detail work.  
 

� Once again, set your document size before you begin 
working.  

 
� Go to Tool>Import, choose the model, draw it onto the 
canvas, and enter edit mode from the right click menu. 

 
Hiding and Polygroups 
Before sculpting on the model, it would be a good idea to 
establish different groups on the model for areas like the arms, 
the front of the head, chest, etc.  To do this we will need to 
isolate polygons on the model, and assign a group to the area. 
 
To start, I like to first hide a large part of the model, so I can 
focus on a smaller area.  
 

� Start by moving the mouse outside the model, press and 
hold “Shift+Ctrl+left click” while dragging over an area on 
the model.  

 
This will give you a green rectangle meaning that anything inside 
it will be visible, and everything outside it will disappear. Once 
you let go of left click you will see only what you chose. 
 
Now that we have our general area we want to keep for our 
group, we should define it further so we get exactly what we 
want. To do this, instead of hiding what’s outside the rectangle, 
we will want to hide the contents inside.  
 

� This procedure starts off exactly like what we did a 
second ago (by pressing “shift+ctrl+left click” to get the 
green rectangle), but this time while we drag the rectangle, 
let go of shift.  
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This will turn the rectangle to a red color. (If you press shift again 
while doing this operation it’ll toggle the green rectangle back on 
again.). 
 
You can hide by points or by polygons.  By default, if your 
rectangle contains an entire polygon it will only hide polygons 
that are fully contained within the box.  If your rectangle does 
not contain an entire polygon, it will hide all polygons connected 
to the points within the box. 
 
Keep using the red rectangle to hide polygons that you don’t want 
until you reach a point that you are satisfied with what will 
become a group. 
 

� To Define a Polygroup, click Tool>Polygroup>Group 
Visible. 

 
In case you want to see the group colors while defining groups, 
make sure to turn on the “Frame” button (or press the Shift+F 
hotkey).  
 

� To unhide the model, press, “shift+ctrl+left click” 
anywhere on the empty space on the canvas.  

 
� Continue defining groups until you are satisfied, and 
have all the general areas of the model defined. 

 

 
Hiding and Grouping 
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To make grouping easier, once you have a number of groups made 
and you are trying to deselect polygons that are visible from 
previously generated groups, simply “Ctrl+shift+left click” on any 
polygon from a visible group and all the polygons that belong to 
that polygroup will disappear. (If the full model is visible, doing 
this hides everything but what you clicked on) 
 

 
Grouped Model 
 
Sculpting at Last 
In order for us to do any fine details to the model, we must first 
subdivide the mesh a few times. Good practice is to start off with 
2 initial divisions, and do as much as you can for that level. Then 
subdivide again and refine details until you’ve reached a point 
that you are happy with. 
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� Click Tool>Geometry>Divide twice so that you are at 
SDiv level 3. 

 
You can jump up and down levels by using 
the SDiv slider just above the Divide 
button (or using the D or shift+D hotkeys). 
 

� The first thing I do is set my brush 
radius to about 30-40, and the Z 
intensity to about 6-8. 

 
When sculpting I always like to rough out 
any volumes first, or rather work starting 
a broad area, and refine as I go 
 
At this time, since our model is not yet so 
dense that performance lags, it’s good to 
turn on the dynamic symmetry from the 
Transform palette.  
 

� Just like you did back when making the ZSphere model, 
click Transform>X.  

 

 
Symmetry painting 
 

� Choose a part you would like to work on by 
“Ctrl+shift+left clicking” on any of the defined polygroups. 

 
I start by painting subtle volumes. Usually I perform strokes along 
the muscles if I want to bulge them up a bit, or paint in a circular 
fashion (especially on fuller areas like the belly).  I then work 
along the creases with a smaller brush. I use a draw size of about 
10-20 for this.  I do this because smoothed CG models tend to  
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have this very clean/sleek look to them, so I add irregularity to 
the creases. This also gets rid of that statue look, and makes the 
model look as if it has skin verlaid on top of bone, muscle, and or 
fat. While painting along the creases, I smooth the area out by 
using the smooth brush. To toggle on the smooth brush you can 
press and hold the shift button. You should notice your brush 
radius turn blue.  
 

 
Getting Rid of Clean Creases 
 
While on the topic of using the “Smooth Brush” if you go to the 
Transform palette, you should immediately notice the words 
“Std” (standard edit brush), “Inflat” (inflate edit brush), and so 
on. These are the 10 brush modes available to you to use at any 
time during the modeling process. You can change your standard 
brush to any of these, or you can hold shift and should notice that 
your brush mode in the transform menu changes to “Smooth”. 
This allows you to change the toggle brush inside ZBrush when you 
hold shift at any time.  If you want to have “Shift” activate a 
brush other than Smooth, hold “Shift” and click on the desired 
brush. 
 
Remember that if you eventually plan to take a displacement map 
generated within ZBrush and use it for rendering in an outside 
application which uses standard subdivision algorithms, you may 
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Displacement>Best mode 
compensates for most of these 
differences. 

find that some details will not render as sharp as they were while 
rendered in ZBrush.  The more disproportional difference you 
have between the high-resolution mesh and the low-resolution 
mesh in ZBrush, the more likely it is that the outside application 
will not be able to reproduce the details faithfully. I recommend 
that while initially experimenting with displacement maps you 
limit yourself to using the standard ZBrush editing tools.  Only 
when you feel comfortable with the process should you venture 
forth and experiment with other editing modes such as Pinch. 
 
On to the next level 
 

� When you get to the point where you think you’ve done 
as much as you could for the current subdivision level, go 
back to the Tool>Geometry section and hit divide so you can 
refine further.  

 
When you start to reach 4-5 
subdivision levels, you might want to 
check how many polygons your model 
is made out of. To do this, open up 
the Tool palette and put your mouse 
cursor over the model icon.  
 
Generally you should work within 
your computer’s ability. Performance 
is greatly affected by the amount of 
RAM you have in your machine. For 
example:  On my Pentium 4 machine 
with 1 GB RAM I am able to push over 
2.5 million polygons at a workable 
rate (obviously I have to hide a lot to 
get better frame rates and that’s 
where grouping comes in handy).  On my Pentium 3 with 768 Ram 
usually I want to stop at around 2 million. (I’m using the P3 to 
make this model.) 
 
At the Fourth subdivision level, you should notice a considerable 
performance drop.  
 

� At this moment it is a good idea to go into the Transform 
menu, and turn off the Dynamic Symmetry, because 
Transform>X won’t be as responsive as it was on lower 
levels.  
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Since at this point you have a lot more detail in the mesh, you 
should notice that if you paint with it on, you often start to get 
“blobs” showing up instead of smooth strokes. To solve this we 
will use a post-process symmetry tool after we are finished with 
painting on this level. 
 
Because we are going to use a post-process symmetry tool, we 
don’t need to have both sides of the model visible anymore.  
 

� From now on make sure to hide ½ the model when you 
work, and refine visibility from there. 

 
The higher you go in levels, the less broad-scale work that you 
should do.  You should be just refining your model, and adding 
small details such as small wrinkles while using a smaller and 
smaller brush as you go along. Since you’re no longer working on 
broad areas, you can have more hidden away, which in turn brings 
up performance. 
 
After painting all the details that you need for this level, it is time 
to apply symmetry onto the other side using the “Smart Resym” 
tool. The way this tool works is that it averages both sides of the 
model and makes changes so both sides are identical. We don’t 
want to change both sides of the model; that would waste our 
time that we spent on painting details to the one side. We can use 
this tool in another way however, that enables us to completely 
retain the work that was made on one side and apply those 
changes to the other side of the model. 
 
To do this, we will have to mask all the details that we want to 
stay where they are, and then use the smart resym. This will lock 
the details from one side when trying to re-symmetrize the 
model. 
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Smart Resym 
 
To symmetrize both sides using “Smart resym” do this: 
 

� Move your cursor outside your model, press and hold 
CTRL+left click. 

 
� Drag the mouse to create a black mask rectangle over all 
the areas that you added detail to. 

 
� When all seems to be covered, let go of the mouse 
button to apply the mask. 

 
� Click Tool>Deformation>Smart Resym. 
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� To get rid of the mask, you can go about it in a few ways. 
Click Tool>Masking>Clear mask button, use the hotkey 
“Ctrl+Shift+A”, or you can do it right from within viewport 
by dragging a mask rectangle over an empty area of the 
canvas. The mask should clear. 

 
Projection Master 
If you want to go even further in detailing your model, you can 
subdivide your model one more time. This could bring you over 2 
million polygons. By default, ZBrush will not allow you to go over 
2 million. This default is only there to protect users with slower 
computers, or with computers that don’t have lots of RAM. If a 
user chooses to go over what his PC will be able to handle, then 
he could end up having to close down ZBrush. If, however you 
have a faster machine with plenty of RAM then you could go into 
the Preferences>Mem menu, and change the Max poly per mesh 
slider from 2 to something higher like 3 or 4.  
 
While we are talking about the “Mem” submenu, you should be 
sure to set your Preferences so that ZBrush doesn’t switch to 
virtual memory as quickly.   (See the “Customizing ZBrush” 
chapter of this manual.)  Another word of caution: You should 
make sure that the partition where you have ZBrush installed has 
at least 1-2 GB of hard drive space free.  ZBrush uses its own 
virtual memory, which is written to the main ZBrush folder.  If 
ZBrush runs out of Virtual Memory it could be forced to shut 
down, losing your work.  Make sure you have enough hard disk 
space before subdividing. 
 

� Before moving ahead, I would suggest saving your mesh.  
 
At this point, saving can take some time and your files will be 
large. To make files smaller and save faster you should lower your 
subdivision level back to 1. This will also make it easier to draw 
your model back onto the canvas in future sessions. 
 

� Now that you are sure that you’ll be able to handle the 
last subdivision, go ahead and divide your model once more.  

 
On this last level your feedback should be very slow. If we were to 
sculpt the detail on this level, it would be very time consuming, 
and very tedious. To solve this however we have another part of 
the application that has not yet been explored in this tutorial, 
and that is Projection Master. Using Projection Master will let us 
work in real time, and will let us use tools that were not available 
to us earlier while sculpting. The reason why I left it to the end is  
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that while in Projection Master your strokes give you real time 
feedback with no lag, but you cannot tumble the view while using 
it.  Also, Projection Master is meant to be used when your model 
has enough resolution to support high quality displacements.  So 
for modeling purposes it is most effective when left to last. 
 

 
Projection Master 
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� In order to use Projection Master, you will have to press 
the “Projection Master” button that is found on the upper 
left of the interface.  

 
When you press the button, ZBrush will show a popup with a 
number of options. Here you can choose which defaults you want 
to start with for when you enter Projection Master. I usually start 
off by turning off color, and then turn on Fade, Deformation and 
Normalize.   
 

� To fully activate PM, press the “Drop Now” button.  
 
What this does is put you into a canvas mode in which you can 
paint detail in a 2.5d mode, and then bake that detail into the 
mesh below when you’re done. This means you can texture your 
model inside Projection Master, and paint displacements at the 
same time.  It’s great for having your geometry and the color 
channel match up perfectly. 
 
Projection master Brushes 
Inside Projection Master we can do a number of things we weren’t 
able to do while in Edit mode. While using standard edits outside 
of projection master is good for volume, it doesn’t quite work 
well for small details that you could use to define bump map like 
details. This is where Projection master comes handy. 
 
The properties that we can now 
access that affect the look of our 
strokes are, Tool, Alpha, Stroke, and 
Texture. Some of these are affected 
by which tool you use however. For 
example, Texture is grayed out in 
Layer brush. In order to use Texture 
you have to use Paintbrush, Roller 
brush, etc.  
 
Stroke controls the way that ZBrush 
will draw samples (instances of your 
selected tool) onto the screen in a 
number of ways. The Default method 
is the Dots Stroke. It has no 
properties that you can access. If you 
draw in quick strokes and are not 
satisfied, you should use the 
Freehand Stroke and adjust the 
spacing property to your liking. I  
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particularly use the Freehand stroke a lot with a higher spacing 
(0.8-1.2) when painting bump maps with specific Alphas. There 
are other useful strokes such as Draw Rectangle, which places a 
single instance of your brush, and strokes like Spray, which 
randomizes your samples. I would suggest experimenting with 
each (press ctrl while having your cursor over each icon to get 
more information on each stroke). 
 
Stroke Edit, and Refinement 
One useful ability with Projection master is that your last stroke 
that you made is in an active state. Right after you complete a 
single stroke, you can then do things like move, scale, and rotate 
the stroke by using the Move, Scale, 
Rotate buttons. You can also do 
things like duplicate your strokes 
using the Snapshot button, or go 
into the Alpha palette to change the 
alpha that was used in your stroke, 
or change any other setting that was 
used to make up that stroke such 
as: Zadd, Zsub, Intensity, Draw Size, 
Focal Shift, or the material buttons. 
 
Alpha palette gives you control of 
the samples that are made while 
painting strokes (in other words, the 
brush shape).  There you can import 
your own custom black and white 
images to get more specific patterns 
that you’re looking for. You can 
Flip, Invert, Rotate, make textures 
out of the alphas (and vice versa), 
adjust the falloff, etc, etc. 
 
The Alpha palette is also where your 
displacement maps will be sent off 
to after they are calculated. 
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Pick up 
When you reach a point that you are satisfied with the painted 
details, you will want to pick up the information from the canvas, 
and apply it to displace on the actual model.  
 

� To apply these changes we made, press the Projection 
Master button to get the popup window. 

 
� Make sure the properties/modes that you want to apply 
are checked, and then press Pick Up.  

 
Since Projection Master doesn’t add polygons, you will only get as 
much detail transferred to you model as its resolution/detail can 
show. The more polygons that the area where you applied the PM 
job to has, the better-looking the results will be. The same can be 
said of texturing in Projection Master. The higher resolution your 
texture is, the more details will be picked up from Projection 
Master. Usually to finish off after using Projection Master, I go in 
and manually edit or smooth areas to my liking. 
 
And that about does it for this Tutorial. Hope it helps, Cheers! 
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ZBrush 2: Digital 
Clay 
By Meats Meier 
This tutorial presents 
guidelines for working 
with ZBrush and other 
applications.  Rather than 
being specific to any 
particular application, 
the instructions can easily 
be applied to any 
package. 

 

ZBrush 2 is a revolutionary 
program that can be used to 
create a high level of detail for 
your geometry. With its 
excellent sculpting tools and 
fall-off manipulators, ZBrush is 
the closest thing to digital clay 
that you will experience. The 
only limitations will be your 
imagination. 
 
ZBrush is not meant to be a 
replacement for your usual 3D 
application, but as a complement to it. It is a specialty program, 
specializing in modeling and texture mapping. Z2 has an excellent 
low polygon model creator in the ZSphere tool, or you can start 
with your own optimized model created in the program of your 
choice and detail it from there. This overview will focus on the 
path from your 3D application to ZBrush and back again. 
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Game developers and people familiar with the rules and 
techniques of Low Polygon modeling have the upper hand in the 
beginning steps. In order to take best advantage of its 
capabilities, care must be taken to start with well laid out low 
polygon models before they go into Z2. 
 

Some things to remember when creating the optimal 
low polygon model for use in ZBrush: 
 

� Create low resolution geometry; usually under 1000 
polygons, but there is no upper or lower limit. The higher it 
begins, the fewer times you will have to subdivide it. 

 
� Concentrate on just the main form. You need to only 
model in details such as holes or extrusions. The form that 
you describe early on will greatly aid in the success of the 
model later on in the process. 

 
� Aim for evenly spaced polygons.  

 
� Must be a clean model with no holes (water tight).  

 
� Texture in 0 to 1 UV coordinates leaving a small space 
between individual shells. 
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 � No need to assign a texture as you will do that in ZBrush. 
 

� Export as obj.  
 

 
 
Subdividing the geometry layout on the left results in both a high 
concentration of polygons in localized areas, and in an overall 
smoothing effect. 
 

 
 
Evenly spaced polygons within a model will hold its original form 
better when subdivided.  
 
The spacing also ensures that polygons are evenly distributed, 
giving you more control over later deformations as well as less 
wasted density in the minute details. 
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When Z2 subdivides a triangle, 
it is converted into three 
quadrangles. 

 
 
ZBrush will accept both four and three sided polygons (no N-
sided), although using triangulated geometry results in an unclean 
subdivision, which can result in artifacts after later deformation. 
 
A tip for working with triangulated geometry: 
 

 

 
 



ZBrush 2 Practical Guide                                                                                                                      Digital Clay 402 

 

In times when properly quadrangulating your geometry would be 
too time consuming, converting to subdivision surfaces and back 
again to polygons can save effort and gives you a nice model that 
will yield decent results in ZBrush.  The conversion back to 
polygons produces all 4 sided geometry, which is preferred in 
ZBrush. 
 

Working with multiple objects 
 

 
 
When you are working with more than one piece of geometry, it is 
usually more efficient to work on them one at a time in ZBrush. 
Models are easier to work on separately and require less memory, 
allowing ZBrush to work more smoothly.  
 
Once all the displacement maps are created for the separate 
pieces, import them back into your 3D program. Select all 
intertwining objects and export once more into ZBrush to adjust 
interactions and once more export back into your application to 
render or animate.  
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Working in ZBrush 

 
 
ZBrush can be a very powerful tool for any digital sculptor that is 
willing to learn. Although it is an easy to use program, many hours 
will have to be spent in mastering the tools and to a lesser extent 
the interface. One of the bigger challenges comes from the 
amount of detail that you are able to add - you will find that a lot 
of time must be put into properly detailing the entire surface. 
Once you get the hang of it, your models will be putty in your 
hands... 
 
One of the first things that you should do after exploring ZBrush a 
little bit is to set up your work space and save it so that you will 
be able to feel at home a little quicker each time you enter the 
program. (Preferences>Config>Store Config) 
 
Zscripts are by far the best way to learn ZBrush; you can just sit 
back and watch as the program describes and illustrates all of the 
features for you. Look for the "Help" button in the title bar, which 
activates ZBrush’s online help browser.  This contains a section 
that is filled with ZScripts on nearly every subject. 
 
ZBrush isn't like any other modeling program out there, so don't 
expect it to act like them. One of the things to get used to is that 
it's not scene-based, but tool-based. This means that items get 
imported in and back out instead of saving complete scenes. 
(Although, of course you can save individual tools and use them in 
the construction of other tools.) 
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There is no one way to sculpt with ZBrush, but approaching it 
much like traditional sculpting is a great way to work - throw 
down the clay, give it form, and then create the details. 
 
Working theory: Do your main shape sculpting first, followed by 
medium details with brush edit tools, and then the fine, high 
resolution details within Projection Master (the plugin that lets 
you use the 2D tools to sculpt the surface). 
 
ZBrush works best with at least one gig of ram and a fairly up to 
date CPU. I highly recommend a pressure sensitive tablet for the 
best sculpting experience. 
 

Overall working strategy 
 

� Import an OBJ using Tool>Import 
 

� Subdivide the model once with Tool>Geometry>Divide. 
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� Manipulate the geometry using Move (W) and Scale (E), 
then divided a few more times (giving more detail to work 
with). 

 

 
 

� Once there are sufficient polygons to manipulate, 
medium resolution details are drawn using the Transform 
brushes. 
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� Subdividing the geometry above a million polygons allows 
you to project fine details such as skin pores using 
Projection Master. 

 

 
 

 
 
I’m not sure what it is, but it only took 15 minutes to complete. 
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Main Shape Changes 
 
ZBrush’s Move and Scale tools can be used to finesse the shape. 
 
If you find yourself making changes that are too large, consider 
modeling it into the original geometry.  You can also use the 
Smooth tool by pressing the Shift key while in Edit mode to 
redistribute the polygons.  Overly stretched polygons will deform 
badly and also warp the UV map. 
 

 
 
The object above was deformed using the Move tool.  The objects 
below were deformed using the Scale tool. 
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� Use the Focal Shift slider to control brush fall-off.   
 

 
 
Negative numbers give hard brushes while high numbers result in 
a smooth blend. 
 

Medium Detail 
 
Paint details directly in the viewport with the various Transform 
brushes. 
 

 
 
Standard pushes and pulls geometry.  All polygons are moved in 
the same direction regardless of their surface normal.  I consider 
this to be the most useful brush. 
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Standard Dot drags a single dot across the surface, which isn’t 
placed until you release the mouse button. 
 

 
 
Inflate expands or contracts geometry.  All points within the 
brush’s area of influence are moved according to their individual 
normals.  Inflate Dot works the same way, but doesn’t finalize the 
edit placement until the mouse button is released. 
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Layer deforms a uniform layer as you paint across the surface. 
 

 
 
Pinch squeezes geometry toward the center of the edit, or pushes 
it away (the effect of most brushes is reversed by holding down 
the Alt key).  This is very useful for sharpening an edge created by 
the Layer brush. 
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Nudge turns your geometry into digital liquid clay.  It’s cool!  
Generally, it will try to move polygons across the surface of your 
object. 
 
Two brush types not shown here are Morph and Morph Dot.  These 
require you to first store your model’s current state as a morph 
target (Tool>Morph Target>Store MT).  You can then use these 
brushes to selectively restore parts of your mesh to the stored 
state (effectively undoing your edits, but only to portions of the 
mesh). 
 

 
 
Adjusting the fall-off curve on the Edit brush (Transform>Edit 
Curve) can provide some interesting effects. 
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Fine Detail 
 
Projection Master can be used to transfer 2.5D painted effects 
onto your 3D geometry. 
 

� If you plan to project color (painting displacements and 
texture at the same time), you should assign a texture at 
this point. 

 
� Press the G key to launch Projection Master. 

 

 
 
At least one million polygons are recommended for nice results.  
Any resolution can be projected, but the lower the resolution the 
lower the quality of the projection. 
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The image above shows a one million polygon plane before and 
after using Projection Master.   
 
Since all projections transfer directly along the Z axis to the 
model beneath, you will get the cleanest depth changes by 
orienting your mesh to face the camera squarely before dropping 
it using Projection Master. 
 

 
 
Here, horizontal lines have been projected with the Fade button 
active.  This blends the effect at the edges, permitting smooth 
transitions as you rotate your model through several drops. 
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The following series of images shows the effect of polygon 
resolution when using Projection Master: 
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As you can see, Projection Master does its best to transfer detail 
as subdivision is lowered, but the highest quality comes from the 
highest polygon count. 
 
Let’s take a look at some of the many possibilities available when 
starting from a single, well-laid-out piece of geometry: 
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Creating tools to project using Z depth 
 
A 2.5D image painted on the canvas is captured using Alpha>Grab 
Doc and projected onto geometry using Projection Master. 
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A depth grab such as this can also be used to create new 
geometry (Alpha>Make 3D Mesh)… 
 

  
 
…which can then be used as a tool to be projected or used to 
create even more complex tools. 
 

  
 



ZBrush 2 Practical Guide                                                                                                                      Digital Clay 418 

 

Exporting from ZBrush 2 
With all of these easy methods to create great-looking images and 
polygon models, ZBrush thankfully also includes many ways to 
export them for use in other programs such as Maya or Photoshop. 
 

  
 
Here we have a close-up of an exported high-resolution OBJ, and 
also the entire geometry as seen in Maya’s viewport. 
 

  
 
Low resolution geometry can be converted to subdivision surfaces 
and rendered with a displacement map for high quality, memory-
efficient results. 
 
Export the low polygon cage. 
 
Convert to a subdivision surface. 
 
Render with displacement. 
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For rendering engines that don’t support subpixel displacement, 
an excellent approach is to use displacements for medium-
frequency detail (as shown on the left) combined with a bump 
map for high-frequency detail (the combined render is on the 
right).  This combination will closely resemble the ZBrush 
sculpture, even with folded geometry that wouldn’t hold up using 
a displacement map (which can only push the surface directly in 
and out). 
 

 
 
Rendered ZBrush images and alpha masks can be brought into 
Photoshop for further editing.  Use Alpha>Grab Doc to capture, 
and Alpha>Export to bring the z-depth into Photoshop or another 
image manipulation program.  Changing the levels then yields a 
perfect alpha mask. 
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Let’s not forget that ZBrush also has a very fast, high quality 
renderer complete with material editors and lights.  And that’s 
not even counting the fact that once an object has been 
incorporated into the canvas you can use the other excellent 2D 
and 2.5D tools to manipulate the image.  A whole book could be 
written on that subject alone.  (Be sure to read the earlier parts 
of this manual, which deal with 2.5D painting.) 
 
Have fun with ZBrush!
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Posing Characters 
for Rendering in 
ZBrush 
By Rob Skitt 
This tutorial covers a 
technique for bringing 
figures into ZBrush from 
other applications for 
rendering.

 
 
Here's a really nice and simple new method I discovered while 
beta testing, which will enable you to pose your model using your 
favorite external animation package for use in a ZBrush scene.  
 
Since animating is application-specific, I'll not be dwelling on the 
various animation posing methods.  I’ll leave that to your own 
devices. 
 
This method offers a new alternative way to repose a model at 
any stage in the modeling process (rather than the usual adaptive 
preview mode way). With adaptive preview posing you're limited 
to only posing a pre-skinned ZSphere-based model.  Using this new 
method, the model source can not only be a natively Skinned 
ZSphere mesh, but also any ZBrush models that are converted to 
PolyMeshes, and even custom base meshes that have been 
imported from other modeling packages. This means you can 
make use of the whole modeling toolset on any mesh and still  
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repose a multi-million-poly model in any fashion (e.g. FK/IK) for 
use in a killer ZBrush image! 
 
OK, here we go. 
 

POSING THE CHARACTER 
� The first step is to create an adaptive skinned ZSphere 
model or import a base mesh from another modeling 
package.  

 
This base should be in a nice default pose with enough detail in 
the joints, etc. to make later posing pain free.  
 

� Then detail out your model using as many SDiv levels 
that you need. 

 
In this example I'll be using this 700,000 poly (approx.), multi SDiv 
level caveman character below, which I created using ZSpheres. 
He's textured in ZBrush with AUV tiling, and furred up with the 
new fibers material shader. 
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 We now need to prepare our model for export. 
 

� Load up your multi SDiv tool and Switch to SDiv level 1. 
 
If the model was initially created using ZSpheres as in this case, 
usually the first base SDiv level (SDiv1 below) is a bit too lowpoly 
for posing, it's best to delete the first level so level 2 will become 
your base (SDiv 2 below). 
 

 
 

� In the Tool palette open the 
Export menu. 

 
� Check that Txr (texture) button 
is active.  

 
This is important otherwise the assigned UV co-ordinates will be 
lost on export.  
 

� Also check that the scale slider is set at 1. 
 
The scale has to remain the same in order for this method to work 
correctly. 
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� Now open up the Preferences 
palette. 

 
Go to the Importexport options menu 
where you'll see there are various 
switch settings for importing and 
exporting objects. If your animation 
package’s default axis orientation is 
different from ZBrush’s, you'll want 
make sure you set up the right 
import/export flip switches so you 
don't have to keep on reorienting your 
model all the time. 
 
Also make sure the Unify Scale slider 
is set at 4 (the default is at 8).  This 
is very important since any other 
setting will either enlarge or shrink 
your model on export/import (which 
has the effect of inflating or 
flattening out your models detail 
levels when importing back later). 
 
On the right are the preferences 
settings I use for exporting to and 
back from Lightwave, flipping the x and y-axis on import, and 
flipping the y and z on export. (Obviously if you're not exporting 
to Lightwave these settings will need tweaking to suit your 
particular package) 
 

� When you're set, export your model out as an .obj file. 
 

� Import the file into your choice animation package, 
where you can then bone and rig up your model. 

 
How you do that is up to you.  For this tutorial I made a simple rig 
with Lightwave, and then posed the model. It's important to note 
that you should make sure that after posing, the model maintains 
its original position.  In other words, if you move the model from 
it's spot to, say 0,10,0 from it's original position at the origin 
(0,0,0) move it back before exporting or you'll get distorted 
results later. 
 

� When you're done export your new pose out to an .obj 
format and return to ZBrush. 
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� Make sure that your original ZBrush model is active in 
the tool menu and set the SDiv slider at the first level. 

 
Hit the Tool>Import button to locate and load in your new posed 
model. This model will replace your base level mesh just like a 
morph target, and all the higher SDiv levels will adjust 
accordingly. 
 

� Switch to the highest SDiv level, to see how the new 
pose looks with all the details and texture co-ordinates 
intact!  

 

 
 
You can repeat this process any number of times you like and if 
you store a morph target before you import your new pose, you 
can swap between two poses. 
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ZBrush and Maya 
By Shaun Absher 
Another artist’s approach 
to using ZBrush-created 
displacement maps in 
Mental Ray for Maya. 

 
 
Here is a tutorial of my workflow to render Zbrush made 
displacement maps in Maya with Mental Ray.  
 

� First I modeled this in Maya making sure it was ALL 
QUADS. 

 
Anything else well crash mental ray when using the subdivision 
approximation editor.  
 

� I have also divided the model into 5 sections to 
individually detail them in ZBrush.  

 
This allows for greater detail. 



ZBrush 2 Practical Guide                                                                                                              ZBrush and Maya 427 

 

 
 

� I then export out each object separately as an OBJ. 
 
In order to make this character I needed to sculpt stress wrinkles 
around bolts in flesh. Some of the OBJ’s have stand in geometry.  
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I laid out the UV’s in Maya so I could use ZBrush’s color groups to 
make things easier when sculpting. The colors are determined by 
what quadrant you put Maya’s texture coordinates in. 
 

 
 

� When you import your OBJ, just hit the 
Tool>Polygroups>Uv Groups button to create the color 
groups. 

 

 
 

� Next, I subdivide the model and then sculpt in ZBrush.  
 
If you use the Pinch brush for detailing, be sure to use Best mode 
when calculating the displacement map.   
 

� When you are done sculpting hide all your stand in 
geometry or your displacement map won’t render correctly. 
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� Render out a displacement map with Dsubpix 4 (or Best 
mode) and your desired image size.  

 
The higher the Dsubpix size the more accurate the map will be. 
 

� After it renders select the displacement map in the 
Alpha tab and look at its ALPHA ADJUST FACTOR.  

 
In my case it was at about .226. Write this down we will need it 
later.  
 

� Export this map as a TIFF.  
 
We will call it mid.tif 
 

� In the Alpha palette maximize 
the Alpha Adjust curve.  

 
� With your displacement map 
selected load the 
NegativeDisplacement.ZCV.  

 
� Export this map as a tif. 
(Neg.tif)  

 
Make sure the EXP button is pressed 
when exporting this map. 
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� Now load the PositiveDisplacement.ZCV and export this 
map.(Pos.tif)  

 
Make sure the EXP button is pressed when exporting this map. 
 

� Open the DOS command prompt and use the command 
"imgcvt" to convert the tif's to iff's.  

 
Example command: imgcvt pos.tif pos.iff 
 
You should now have three 16 bit .iff maps. It’s important to keep 
them 16 bit as it will contain more grayscale information then 
8bit. 
 
These maps can be applied to the original Maya geometry. 
 

Rendering in Maya 
 

� Open your Maya scene. 
 
ZBrush creates displacement maps where 50% gray equals no 
displacement. The darker values push in and the lighter values 
push out. Maya’s displacement maps work where black equals no 
displacement and the lighter the value the more it pushes out.  
 
The following hypershade network, with the three displacement 
maps we created will compensate for this difference. 
 

� Assign a shader to the geometry. Assign the mid.iff to 
the shader as a displacement.  

 
Note a 50% gray texture works fine too. 
 

� Assign pos.tif to mid.tif's alpha gain. 
 

� Assign neg.tif to mid.tif's alpha offset. 
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� All three images should have their Repeat UV settings set 
to 1 / -1.  

 
This will flip the maps to the correct orientation. 
 

 
 

� Set pos.iff's alpha gain to that ALPHA ADJUST FACTOR we 
wrote down earlier. (In this case .226.) 

 

 
 

� Set neg.iff's alpha gain to the same value as pos.iff but 
make it negative. (Ex: -.226.) 
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Now our shaders are set up correctly. 
 

� Next you will want to use the Maya approximation editor 
to assign a displacement approximation and a subdivision 
approximation to your geometry. 

 
� Displacement approx settings: Spatial / Fine. The more 
you crank the numbers the better things look. 

 
� Subdivision Appox settings: Parametric. With N 
Subdivisions at 5. 

 
� Set up your lighting and Render out the images. 

 
Here are the images rendered in Maya with Mental Ray. 
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Here is the character assembled in ZBrush. 
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ZBrush 
Displacement Maps 
in Maya 5/Mental 
Ray 
By Paul Hourmouzis 
This tutorial only spends 
enough time in ZBrush to 
create the high resolution 
model and displacement 
map.  Instead, it focuses 
on the necessary steps to 
take in Maya in order to 
prepare a model for 
ZBrush and make use of 
the displacement map 
after it has been created. 

STAGE 1 - PREPARATION 
 

� If you are not already within Maya, import your model 
and orient so that it's standing on the ground plane. 

 
For this tutorial, I am using the head of a character freely 
available from www.cgnetworks.com. 
 

� If you have any triangles in your object, you need to 
remove them.  

 
To do so: 
 

� Convert your object to a Subdivision Surface (Modify -> 
Convert -> Polygon to Subdiv), then 

 
� Collapse the Subdivision Surface Hierarchy (Subdiv 
Surface -> Collapse Hierarchy), setting Number of Levels to 
1: 

 
 

 
 
This will create a denser Subdiv object, but that's fine, as we will 
be subdividing this even further within ZBrush. Your object should 
now be made entirely of quads. 
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� Convert your object back to a polygon (Modify -> 
Convert -> Subdiv to Polygons) using the following options: 

 
 

 
 
 

� Center the pivot of your character (Modify -> Centre 
Pivot), then place the pivot point at the origin.  

 
� Export your object as an OBJ file. 

 
Here's a view of the character in the Maya view port: 
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� Start ZBrush and modify your 
Import/Export Preferences. 
Activate iFlipY and iFlipZ, eFlipY 
and eFlipZ.  

 
This will ensure the orientation of your 
object is correct when imported and 
exported out of ZBrush. I also usually 
set Unify Scale to 1, but this depends 
on the scale of your object when you 
exported it from Maya. 
 

� Now import your object into 
ZBrush (Tool -> Import). 

 
Before you begin detailing, you may 
want to store a morph target. This 
allows you to return to your original 
geometry shape at any time in the 
future. To store a Morph Target, press 
Tool -> Morph Target -> StoreMT. 
 

� If you don't already have UV's 
assigned to your object, you can 
assign UV's within ZBrush. Select 
Tool -> Texture -> GUVTiles.  

 
This will layout all polygons in 0 to 1 texture space in a tiled 
fashion and will group then as best as possible.  
 
This tiled layout produces absolute minimal distortion of your 
textures. 
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� To speed things up, switch off one of the two default 
lights, and go into Fast Render mode. 

 

STAGE 2 - DETAILING 
 
You are now at a stage where you can begin subdividing and 
detailing your object.  
 

� Draw your object onto the canvas by holding the shift 
key and dragging the mouse/tablet.  

 
Holding the shift key has the effect of snapping your object to its 
local axis. 
 

� To sculpt your object, you need to be in Edit Mode 
(Transform -> Edit), or simply hit the T key to enter this 
mode.  

 
You may also want to enable Local Transformations, which 
temporarily centers rotation around your most recent edit, which 
is useful when you tumble your object in the view. 
 
For the purpose of this tutorial, we will only make changes to this 
characters face. To speed things up, we want to hide parts of the 
model we are not working on. 
 

� Press and hold the CTRL and SHIFT keys, then drag a 
rectangle over the parts of the model you want to show. 
The rectangle will be green in color. 

 
Everything outside the green rectangle is hidden when you release 
the mouse button. If you make a mistake, simply press and hold 
the CTRL and SHIFT keys and press the left mouse button on an 
empty section of the canvass (outside your model). The complete 
object will re-appear again. 
 
This process of hiding geometry is very important, especially when 
your character reaches several millions polygons, and you will find 
that you continually hide and unhide portions of your model as 
you detail it. 
 

� To automatically maximize the zoom, press ALT and the 
left mouse button on a blank part of the canvas.  

 
You can also manually zoom by pressing and holding ALT key,  
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then the LMB, releasing ALT key and then moving the mouse 
around. 
 

� Subdivide your object by pressing the Divide button 
(Tool -> Geometry -> Divide).  

 
Also ensure Suv is enabled - this smoothes UV's as you further 
subdivide your object. You can move between different levels of 
subdivision by pressing the D key (higher level) and Shift-D (lower 
level). 
 

 
 
While in Edit mode, you have several 
draw modes available to you. These are 
Standard, StdDot, Inflate, InflateDot, 
Morph, MorphDot, Layer, Pinch, Nudge 
and Smooth. You also have Move, Scale 
and Rotate edit modes. 
 
Each of these modes is located in the 
Transform palette. Take the time to 
explore how each of these modes work. 
 
For the purpose of this tutorial, I am 
going to add some rather obvious 
details around one of the eyes of this 
character, using various tools such as 
Projection Master and the Edit Tool 
and its various modes. 
 



ZBrush 2 Practical Guide                                                               ZBrush Displacement Maps in Maya 5/Mental Ray 439 

 

Here's a screen shot before any editing: 
 
 

 
  
And here's a screen shot after adding some detail around the eye: 
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 To achieve this level of detail, my original model was subdivided 
four times and weighs in at 808,192 polygons. 
 

STAGE 3 - GENERATING DISPLACEMENT MAPS 
 
We will now calculate the displacement map for this character.  
 
Switch to the lowest level of subdivision (Level 1) and either press 
the Cage button (Tool -> Geometry -> Cage). 
 
Alternatively, if you stored a Morph Target earlier, you can recall 
the original shape of your object by pressing Morph Target -> 
Switch from the Tool rollout.  If you did not use ZBrush UV’s, you 
can also import your original model back into subdivision level 1.   
 
Do not switch to any other level of subdivision. 
 

� In the Displacement section, 
set DPSubdPix to 4, DPRes to 4096 
and press the Best button.  

 
� Finally, press the Create 
DispMap button. ZBrush will then 
calculate your displacement map. 

 
Depending on various factors, such as 
the complexity of your model, and 
these displacement quality settings, 
your map will take a few minutes or 
longer to calculate. 
 
When complete, your displacement 
map is stored in the Alpha palette. You 
want to export it from ZBrush for use 
in Maya, but before doing so, you need 
to flip it vertically.  
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� Press the Alpha -> Flip V 
button to invert your map.  

 
� Export your map as a TIFF file 
by clicking on Export in the Alpha 
Palette and giving it a file name.  

 
It will be exported as a 16 bit TIFF 
grayscale image. 
 
Convert it from a grayscale image to an 
RGB image in your favorite image 
editing package. 
  
Note the Alpha Depth Factor value, 
found at the bottom of the Alpha 
Palette. This is an important value to 
recall when using the map in Maya. 
 

� If you used ZBrush to assign the 
UV’s, export your model from 
ZBrush.  

 
Ensure that Mrg is on and Grp is off. 
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STAGE 4 - RENDERING IN MAYA 
 
You now need to import your model back into Maya. If you work in 
a production studio, you may be in the situation where your 
original model has been skinned for animation. If this is the case, 
the order of vertices is important and must not change. 
 

� When importing, you need to disable Create Multiple 
Objects by selecting False in the Import Options box to 
ensure the vertex order doesn't change. 

 
 

 
 
You can now import your modified object and the vertex order 
will be the same as your original object. 
 

� Add a displacement shader to your object and load the 
displacement map.  

 
� In the Alpha Gain section, input the number you 
obtained from the Alpha Depth Factor from within ZBrush. 
Enter a value of half that of Alpha Gain in Alpha Offset and 
make it negative. 
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In this example, my Alpha Gain is 0.1, and my Alpha Offset is -
0.05. If you scale your object, either during the export from 
ZBrush, or while in Maya, you will need to change these values 
accordingly. 
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� In the Attribute Editor, select your objects Shape node 
tab and ensure Feature displacement is off. 

 

 
 
As we are rendering with mental ray, it is best to add its own 
tessellation attributes to your object. 
 

� Open the mental ray Approximation Editor (Window -> 
Rendering Editors -> mental ray -> Approximation Editor), 
and create both a Displacement Approximation and a 
Subdivision Approximation for your object. 
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You will now have two additional nodes connected to your object. 
These will appear in the Attribute Editor under separate tabs. 
 

� In the mental ray Subdivision Approximation settings, set 
the following variables: 

 
 Approx Method = Spatial 
 Min Subdivisions = 2 
 Max Subdivisions = 5 
 Length = 0.100 
 View Dependant = On 
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� In the mental ray Displacement Approximation settings, 
set the following variables: 

 
 Presets: Fine View High Quality 
 
This preset adjusts the other variables below it.  
 

 
 
The quality of rendered displacement is reliant on both the 
settings for Displacement and Subdivision Approximation. Also, if 
you don't allow for enough subdivisions, your displacement detail 
may not appear no matter how high your displacement settings 
are. 
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The settings given here worked reasonably well for this example; 
however, you will need to experiment with these settings to find 
an optimal balance between render speed, quality and memory 
consumption. 
 

� Render your object. 
 
Here's my render: 
 
 

 
 
 
As a final note, when adjusting your displacement and subdivision 
settings, you can get a good indication of how your object is being 
tessellated. 
 

� In the mental ray Render Globals, select Translation -> 
Export Verbosity -> Progress Messages.  

 
� At the end of each render, check Maya's Output Window 
to see how many triangles your object was tessellated to.  
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In this example, my object was tessellated to 404096 triangles. 
Quite amazingly, this number is exactly half of the number of 
polygons my object is made of when in ZBrush. 
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ZBrush, Maya & XSI 
By Michel Roger 
While this tutorial covers 
bringing a model from 
Maya to XSI and ZBrush, 
the real meat of it is in 
how to apply the ZBrush-
generated displacement 
map in XSI. 

 
 
This tutorial shows a workflow that I use for going between Maya, 
ZBrush and XSI.  It works well for me, and I hope that you find it 
useful. 
 
Please pay careful attention to the illustrations; especially for the 
render tree setup near the end.
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I begin by doing my modeling and UV editing with Maya 5, then export the model in OBJ format to 
XSI 3.5 and to ZBrush. 
 
The particular program that you use to do your modeling and UV layouts is entirely a matter of 
personal preference.  You could even do it all in ZBrush.  The nice thing about ZBrush, though, is 
the fact that it can be used with whatever workflow you’re already comfortable with. 
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Here is the work in ZBrush.  Notice that you must store a morph target of the model at subdivision 
level 1 before dividing the model and sculpting high resolution details.  When subdividing the 
mesh, be sure that Tool>Geometry>Suv is active so that the mesh UV’s will be smoothed along with 
the model. 
 
Before generating the displace map, you recall it with the morph slider (100%).  Alternatively, you 
can click the Switch button. 
 
What this does is ensure that the displacement map is relative to the original model.  For more 
information on this process, see the Phone – Part 3 tutorial in this manual. 
 
Before importing in XSI, you must convert the 16 bits greyscale Tiff to a 48 bits rgb Tiff because XSI 
doesn’t seem to like the 16 bits one.  You can easily do this in Photoshop. 
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Here is the setup for the model in XSI, with the render level at 2 and no Automatic Discontinuity.  
 
In the displacement params, choose parametric and two steps.  
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In the render tree, notice that you must add an intensity node (0.2 here) and a change range node 
to tweak how the model is inflating. 
 
On the ZBrush map, 50% grey is no displacement.  XSI is different, however but the change range 
node compensates for that.   
 
You’re done! 
 

  



ZBrush 2 Practical Guide                                                                                     ZBrush Normal Maps In LightWave 454 

 

ZBrush Normal 
Maps in LightWave 
By Glen Southern 
What this tutorial lacks in 
text it makes up for in 
illustrations.  All of the 
steps are covered to apply 
a ZBrush-generated 
normal map in LightWave. 
 

 
 
At the time of this writing, LightWave is still working on subpixel 
displacements (which is where the highest level of displacement 
quality is to be found).  That doesn’t keep ZBrush from being able 
to enhance my LightWave work, however! 
 
In this tutorial, I have created a low poly model in another 
application, which was then UV mapped in LightWave.  The model 
was taken into ZBrush, where it was subdivided to 1.1 million 
polygons and then detailed.  ZBrush then generated a normal 
map, which was applied in LightWave using the NormalMapShader 
from ATI. 
 
The panels on the following pages show the entire process. 
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ZBrush and 3D 
Studio Max – 
Normal Mapping 
By Kip Malek 
This tutorial shows one 
way to use ZBrush to 
create normal maps for 
use with 3D Studio Max 
models. 
 

 
 
In this tutorial, I will explain how to go from Max to ZBrush to 
Max, and then how to view the normal-mapped object in Crytek's 
Polybump Previewer.  Alternatively you could use Max's metal 
bump.  
 
Besides ZBrush and Max 5.1, you will also need to download and 
install Habware's MAX2OBJ and OBJ2MAX plugins, the Polybump 
Previewer, and Nvidia's DDS Photoshop plugin. These plugins/apps 
are to be found at: 
 
http://www.habware.at/duck4.htm  
 
http://www.crytek.com/downloads/index.php?sx=polybump 
 
http://developer.nvidia.com/object/nv_texture_tools.html  
 
I've taken some screenshots of the processes I go through.  Here 
goes: 
 

� Load up your model in Max. 
 
In the attached images I'm going to use a monster I modeled, 
unwrapped, and textured for the PS2 RPG “Summoner 2” 
(developed by Volition, published by THQ).  
 

http://www.habware.at/duck4.htm
http://www.crytek.com/downloads/index.php?sx=polybump
http://developer.nvidia.com/object/nv_texture_tools.html
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� Export the model as an OBJ. 
 
Use the settings in the screenshot image 
I've attached. You would want to change 
the faces setting to "quads" if your object 
is mostly quads.  However, this monster 
model was not built in the Bay Raitt quad 
method, and as such it was better to 
export it as triangles.  
 
 
 
 
 

 
 

� Open ZBrush and import your model using Tool>Import. 
 

� Add some subdivisions to it using Tool>Geometry>Divide.  
 

 
 
I imported the original texture as a guide using Texture>Import. 
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Since ZBrush and Max have different coordinate systems, it’s 
necessary to flip the texture vertically after importing.   
 

� Press Texture>Flip V.  
 

 
 
ZBrush flips bitmap textures automatically, so this is only 
necessary for formats other than BMP.  Also, remember to flip 
your textures (including your normal map) vertically again before 
exporting them from ZBrush.    
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� Model, texture, and do whatever you wish to your 
model.  

 

 
 
To do this sculpting, you can use any of the sculpting brushes 
found in the Transform palette, or (if your model has been 
subdivided to sufficient resolution) you can use Projection Master 
to paint displacements.  You can even paint texture and 
displacements at the same time! 
 

� Once you are done, follow the methodology to create a 
displacement map, but click Tool>Normal Map>Create 
Normal Map rather than the Create Displacement Map 
button.  

 
This methodology is explained in detail in the Phone – Part 3 
section of this manual. 
 
I choose a size of 1024x1024.  For more detailed maps, you would 
obviously use larger textures.  As far as game development goes, 
you usually create maps which are powers of 2 (32x32, 64x64, 
256x256, 128x256, etc).  This is perfect for ZBrush, since it is also 
optimized for the same dimensions. 
 

� After the normal map has been created, go to the 
Texture palette and export the map. 

 
Remember to flip the map vertically if you export it as anything 
other than a BMP.  
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There is no need to export your model again, and you only need 
to export the texture if you have modified it in ZBrush. 
 

� Open your normal map in Photoshop and save it as the 
.dds file format.  

 
� Within the save format dropdown of the Nvidia exporter 
that opens, choose dxt1 RGB(no alpha).  

 

 
 

� If you have a diffuse (color) map save it as a .dds as well.  
 
You can read an explanation of the dxt format at the nvidia 
website.  http://developer.nvidia.com/object/General_FAQ.html  
 

http://developer.nvidia.com/object/General_FAQ.html
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� Return to Max and within a new texture load up your 
.dds diffuse map in the diffuse color slot and your .dds 
normal map in the bump slot.  

 

 
 
 

� Export the model as an .obj again.  
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� Open the Crytek Polybump Previewer.  
 

� Load your .obj file.  
 

 
 

� You can cycle through the different rendering options by 
pressing the f2 key.  
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Woo hoo!  That's it!  Alternatively you could use a version of the 
normal map previewer.  That uses a different method though, 
which is beyond the scope of this tutorial.  
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Max to ZBrush & 
Back 
By Glenn Melenhorst 
This section gives a good 
workflow for 
incorporating ZBrush, Max 
5.1 and Vray together 
into your workflow. 

 
 
This tutorial is meant to give a brief explanation of how I create 
models using ZBrush 2 with Max 5.1 and Vray. 
 
Here is a sketch that I’m using as my guide in this tutorial. 
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Step 1 – Rough Out 
Inside max I roughly model the character using edit poly and 
meshsmooth. I use simple shapes and avoid tiny details. I also 
work to keep my mesh completely built from quads and no tris.  
 
I'm going to use ZBrush to apply the texture coordinates, so I 
won't bother applying a map or UVW coordinates just yet.  
 

 
 

Step 2 – Export 
I export the mesh as an .OBJ file because 
OBJ's retain mapping coordinates and can 
export quads. This is done with an OBJ 
importer/exporter built by Habware and 
can be found at 
http://www.habware.at/duck4.htm.  
 
When exporting, I use the settings shown 
at right. 

http://www.habware.at/duck4.htm
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Step 3 – Import and Sculpt 
Load the OBJ into ZBrush and you're ready to get sculpting. 
 

 
 
In the example above, I clicked the Tool thumbnail on the left 
shelf.  The Import button appears at the bottom of the popup. 
 
Once loaded, you can sculpt the mesh to your heart's desire 
adding detail by dividing the mesh to create a subdivision surface.   
The button to use is Tool>Geometry>Divide. 
 

 



ZBrush 2 Practical Guide                                                                                                       Max to ZBrush & Back 470 

 

 
The beauty of this technique is that it takes a simple blocked out 
character and makes it quite sculptural and natural. 
  

 
 
As you reach the limit of detail that can be achieved with your 
current subdivision level, divide the mesh again to add more 
polygons.  Keep detailing until you’re satisfied with the character. 
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Refer to other sections of this manual or the excellent tutorials 
built into ZBrush and online to learn the finer points of sculpting 
in ZBrush.  For the focus of this tutorial, I'm more concerned with 
getting between the two applications. 
 

Step 4 – Texture 
Create a high resolution texture map.  It will be a blank canvas 
for your paint work. 
 
A blank texture at the desired resolution should be created before 
the UV mapping is assigned. If no texture is present, ZBrush 
assumes a size of 1024x1024.  But if you create the 2048x2048 or 
even 4096x4096 texture and then assign the mapping, you will get 
the most precise results. 
 

 
 
Choose your base color, set the dimensions, and then click the 
Texture>New button. 
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Next create your mapping coordinates in ZBrush using GUV tiles. 
It's like unwrap in max and does an excellent job of creating 
distortion-free maps.  Unlike the similar AUVTiles, this mapping 
method keeps polygons together where necessary and so works 
well even if your model has triangles. 
 
Note that you must be at Subdivision level 1 to assign the 
mapping.  You can then return to the higher subdivision level 
after. 
 

 
 
Use Projection Master to paint the texture.  At the same time and 
if your mesh has a high enough resolution, you can also paint 
displacements for use in creating a displacement or normal map. 
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The picture on the previous page shows rough painting.  Refine 
your texturing to whatever level of detail you prefer. 
 
After painting, your texture will look like a patchwork or mosaic.  
 

 
 
Now you're ready to export the texture map for use in MAX.  
 
Press Tool>Texture>Fix Seams to make sure that there are no 
seams at the edges of UV regions.   
 
The other option is to let ZBrush export the map when you export 
the OBJ.  ZBrush performs the fix seams operation automatically, 
flips the texture, and saves it as a BMP of the same name if you 
have the texture wrapped onto it when you export the model.  It's 
only necessary to do the steps manually if you are exporting a 
TIFF from the Texture palette. 
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Step 5 - Displacement 
 
Next we need to generate a displacement map which denotes the 
difference between the low resolution and highest resolution 
subdivisions of the model. 
 

 
I usually make a displacement map of about 2000 pixels. 
 

 
 
The generated displacement map will appear in your Alpha 
palette and should be saved for use in Max. 
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The displacement will look a little like this: 
 

 
 
It's really important that you save it out as a TIFF file so that it 
retains its 16 bit depth.  An 8 bit depth image will 'staircase' or 
'step' because it has fewer levels of gray to make smooth 
displacements with.  
 
All that's left to do in ZBrush now is export your mesh at the 
lowest subdivision level as an OBJ… 
  

Step 6 - Max and Vray 
 
...and import it into max using Habware's OBJ importer mentioned 
at the start of this tutorial. 
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Be sure to set your Vertex scale to 1. 
 

 
 
I add a layer of meshsmooth to the model to smooth out the 
faces. I sometimes set it to one or two levels of subdivision if the 
base model is really low. I found it doesn't pay to have the base 
model too low. I try to keep it and the final relatively close 
together in terms of topology. 
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If you just apply the texture map from ZBrush to your model, it 
looks wrong. Simply set your v tiling to -1 and it'll look a lot better 
:)   
 

 
The other option here is to set Texture>Flip V in ZBrush. This will 
correct the map flipping so you don't have to adjust it in Max. 
 
Again, ZBrush performs this operation automatically and saves the 
texture as a BMP of the same name if you have the texture 
wrapped onto it when you export the model, so it's only necessary 
to do the steps manually if you are exporting a TIFF from the 
Texture palette. 
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Now setup your displacement. I use Vray 
so here is a snapshot of my settings. 
Notice I compensate for inward 
displacement as well as outward 
displacement. I have no hard and fast 
rule for this as the amount of 
displacement depends on the height of 
the peaks and valleys you have painted in 
ZBrush. If you painted high lumps, you 
need a greater value in your 
displacement than if you painted fine 
details. 
 
 
The render: 
 

 
 
 
 
I know it's not great but that's me rushing through to get a point 
across. You can make anything of any detail in this method while 
keeping a mesh light enough to animate easily. Look into ZBrush's 
cavity material (it helps bring out the detail of the models) as 
well as using ZBrush for painting secularity maps, bump maps and 
anything else you might require. 
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ZBrush & Poser 5 
By Michael Melnik 
Poser 5 offers a low cost 
rendering engine that 
supports subpixel 
displacements.  This 
tutorial shows techniques 
for using the two 
packages together. 

 

 
 
Have you ever wanted to make ultra highly-detailed 3D models for 
Poser5 without losing system resources? Well, now you can.  
ZBrush 2 allows you to create 3d models with up to ten million 
polygons. Yes, you read that right, I said ten million polygons! 
This would bring most other 3D programs to their knees, even the 
high end programs. Ok, you can quit drooling now! Now imagine 
this:  you can make a ten million polygon displacement map for 
use on your standard Poser characters. This will also work if you 
like to create your own figures and props for Poser.  
 
This tutorial is broken up into three steps. First, in step number 
one, I will describe how to make highly detailed displacement 
maps with ZBrush. In the second step, I will explain how to export 
them correctly for use in Poser5. Finally, I will explain how to 
apply the displacement maps in Poser5.   
 
NOTE: This tutorial uses Poser5 with Service Pack 4. 
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Step 1: Creating Displacement Maps with ZBrush 
 
To start things off, we have to export the figure out of Poser5. In 
this case we will use the good old Business Man figure.  
 

� Open Poser5, delete the default figure and locate the 
Business Man figure.  

 
You will find him in the Poser Library under Figures\Poser 1-
4\Poser 4 Hi.  
 

 
 

� Once you’ve located the figure then double click on his 
icon to “Create the figure” or in other words, bring him into 
the current scene.  
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Now that the figure is created we can export him as an OBJ file 
for use in ZBrush. 
 

� To do this click on the File pull down menu, select 
Export, then select Wavefront OBJ. 

 

 
 

� In the Hierarchy Selection window that pops up uncheck 
Universe then put a check on Figure 1. 

 

 
 

� Click “Ok”.  
 
This way we only export the figure and nothing else.  
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� The Save dialog box now opens and we will save our 
figure as PzBizMan1.OBJ. 

 

  
 
NOTE: While saving the OBJ file you need to create a special 
folder titled BizManDisp for the files of this tutorial. It will make 
it easier to keep track of everything. 
 
Now that our model has been exported from Poser it is time to 
bring it into ZBrush. This is easy enough to do.   
 

� First let’s open ZBrush and click on the Import 3d Mesh 
button found in the Tool palette. Locate the PZBizMan1.OBJ 
file that we created and open it.  

 

 
 

� Now that the model is in ZBrush make sure it is selected 
then go ahead and click-drag anywhere in the canvas.  
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As you can see, this action will let us add our model to the ZBrush 
workspace, or Canvas area. 
 

 
 
You should already know these five shortcuts, but in case you 
don't, here's a brief explanation on how they work: 
 
1. Click and drag in the space outside of the object to rotate it 
freely.  
 
2. Click and drag while holding down the “Alt” key on your 
keyboard to pan the object side-side or up and down. 
 
3. Click and drag while holding the “Alt” key on your keyboard 
then let go of the “Alt” key while still click-dragging to scale the 
object up and down in size. 
 
4. Hold the “Alt” key on your keyboard and just click once on the 
canvas to automatically resize and scale your object to fill the 
canvas.  
 
5. Hold down the “Shift” key to constrain the rotations to forty-
five degree 45° increments. 
 
You can also perform these actions by using the icons on the right 
shelf. 
 
Ok, let’s move along… 
 

� Press the “T” Key to enter Transform/Edit/Draw mode.  
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� Scale the object up in size and reposition it so that we 
can work on the forehead area of our model. 

 

 
 

� Press the Tool>Morph Target>StoreMT button to store 
the current mesh for later use. 

 

 
 
This will store a perfect copy of our model that we can switch 
back to at any time.   
 
Now we are prepared to add more polygons.  We want to make a 
high poly model for the displacement map.  
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� Go into the Tool>Geometry sub-palette and click the 
Divide button four times. 

 

 
 
This action will subdivide the object four times bringing us to a 
level four subdivision.  Mesh density increases from 17,138 to 
1,060,262 polygons. We now have plenty of polygons for our 
displacement map, though if you have a powerful enough system 
you could subdivide one more time if you wanted to. We’ll just 
keep it at level four for this tutorial. 
 
Ok, time to add some high resolution details for our displacement 
map.  
 

� For this demonstration we will use the Layer Edit Brush.  
Click Transform>Layer, make sure you have Zadd selected, 
then draw a “Z” on the forehead of our model.   
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� Change to Z-Sub and draw a “B” on the other side of his 
forehead. 

 
I know, I know… at this point all of the major Poser fans are 
saying to themselves “What is this guy thinking? It’s intolerable!”  
LOL… please bear with me!  
 
That is all the detail I will be adding for this tutorial. You can, of 
course, add as much detail as you want.  It is time for us to make 
preparations for creating a displacement map.  
 

� First, let’s set the subdivision to level 1.  
 

 
 
You may notice that the original mesh has been slightly altered, 
which we don’t want. Remember the Morph Target that we saved 
earlier? We will use it as the level one base mesh of our 
displacement map.  
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Instead of DPSubPix, you can 
use the Best button (not shown 
in this example). 

 
� Click on the Tool>Morph Target>Switch button.  

 
You will notice now that we have switched back to our original 
imported geometry. 
 

 
 
The previous few steps are very important, as they allow ZBrush 
to compare the original unmodified mesh to the high resolution 
model that you created.  This in turn means that the 
displacement map will be true to your original model.  
 
You may want double check and make sure you followed them 
correctly.  
 
Ok, let’s look at the big picture. Here is what we have so far:  A 
level one base mesh with the original geometry intact and a level 
four altered high poly mesh. We want to create a displacement 
map using these two levels of subdivision. So, open the 
Tool>Displacement sub-palette and have a look.  
 

 
 
See the slider that says DPSubPix?  This slider lets you increase 
the displacement map SubPixel Accuracy. The higher the level the 
more accurate the displacement map will be. In conjunction, the 
higher the level the longer it will take to create the displacement 
map. For this tutorial we’ll just keep the slider level at zero. 
Also, you can determine the actual size of the displacement map 
by inputting a value into the DPRes(displacement map resolution)  
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slider located right next to the DPSubPix slider in the palette. 
We’ll just keep it at the default value of 1024x1024 pixels.  
 

� Finally it is time to make the displacement map. Click on 
the Create Displacement Map button. 

 

 
 
ZBrush automatically calculates the difference between the 
current level of subdivision and the highest level of subdivision (in 
this case, level four) when creating the Displacement map.  You 
should always be at the level that you wish to create the map for 
before creating the map.  In most cases, that will be subdivision 
level 1. 
 
We have just created a displacement map for our object. You can 
see the displacement map in the Alpha palette. It is represented 
by a small icon titled PzBizMan1.   
 

 
 
Now that we have our displacement map created we should take a 
look at it on our base mesh to make sure it works. This is an 
important part of the tutorial. You don’t want to export your 
displacement map and then find out that it didn’t work. 
 
In order to see the displacement map active on our model we 
must remove all the extra levels of subdivision then create new 
unmodified subdivision levels. We can then apply the 
displacement map to the newly subdivided mesh.  
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� The first thing we need to do is look at the Alpha Depth 
Factor value.  

 

 
 
Our Alpha Depth Factor is .0157. Write this number down! 
 

� Ok, let’s remove the upper levels of subdivision. Press 
Tool>Geometry>Del Higher. 

 

 
 
This will leave us with our unmodified base mesh (the same mesh 
that we exported out of Poser. Now that the old higher 
subdivision levels are deleted we need to activate smoothing to 
simulate Poser’s smoothing. 
 

� Set Tool>Display Properties>DSmooth to 1.   
 
If the mesh isn’t quite smooth enough, you can increase the DRes 
value next to it. 
 

� Turn off Transform>Quick. 
 
As long as Quick is active, ZBrush will ignore the DSmooth setting, 
preventing the displacement map from being applied. 
 

� Activate Tool>Displacement>Mode. 
 
This switches ZBrush from displaying the map as bump to full 
displacement. 
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� The last thing we have to do is to input the Displacement 
Intensity value. This slider is also located in the 
Tool>Displacement sub-palette. Use the Alpha Depth Factor 
as our value.  

 
In this case, the ADF = .0157. Enter this value into the 
Displacement Intensity slider. 
 
Alrighty then, your mesh should look like this.  It looks just like it 
did right before we created the displacement map.  If it looks like 
this to you then go on to step two, if it looks messed up then you 
need to go back and figure out where you went wrong along the 
way. 
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Step 2: Exporting the Displacement Maps Correctly 
 
In order to export the displacement map correctly for use in 
Poser5 we must modify it with the Alpha Adjust curve and create 
separate displacement maps for both positive and negative 
displacement. We can then export each separate map.  
 

� Let’s start by selecting our PzBizMan1 alpha map. 
 
It is in the Alpha palette of course.  
 

� Next, let’s click open the Alpha>Alpha Adjustment curve 
box and then click on the Load button. 

 
Here we can load the settings for positive displacement. Find the 
ZBrush\ZCurves folder and open the PositiveDisplacement.ZCV 
file.  
 

 
 

� Once the Positive Displacement curve is loaded, press 
the Make Modified Alpha button. 

 

 
 
This will make a copy of the modified alpha/displacement map.  
 



ZBrush 2 Practical Guide                                                                                                              ZBrush & Poser 5 492 

 

Now that we have created a texture map out of the positive 
modified alpha we need to do the same thing to create the 
negative displacement map.  We’ll use the same process as we 
did with the positive displacement map.  
 

� Let’s start by reselecting the PzBizMan1 alpha. 
 

� Open the Alpha Adjustment curve box and press the 
Load button. Find the file NegativeDisplacement.ZCV.   

 
Now that the negative adjustment curve is loaded we can press 
the Create Modified Alpha button. 
 

� Select each new map and flip it vertically using 
Alpha>Flip V. 

 
ZBrush and Poser use different coordinates for their texture 
mapping.  Flipping the map vertically will ensure that it will work 
inside of Poser. We’ll do this for both maps.  
 
The last thing we need to do is export our displacement maps.  
 

� Select the positive displacement map and press the 
Export button located at the top of the Alpha palette. 
Locate the folder we created earlier titled “BizManDisp”. 
Save the file as PzBizManDisp+.psd. 

 
� Now export the negative displacement map and save it 
as PzBizManDisp-.psd. 

 
The ZBrush portion of this tutorial is now done. 
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Step 3: Using the Displacement Map in Poser5 
 
Finally, we have come to the last step of this tutorial. Now we get 
to go back into Poser and put the displacement maps on our 
figure. This part should be a cakewalk. I, mean, relatively a 
cakewalk.  LOL 
  

� Open up Poser and select the Business Man figure. 
Position him so that his head is in full view. 

 

 
 
I used the face cam to do this. 
 

� Open up the Material room and use the eyedropper to 
select the head of our figure.  

 

 
 
Using the eyedropper will bring up the nodes for the current skin 
shader.   
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� Look on the main node titled “Poser Surface”. Towards 
the middle of it you’ll see the word “Displacement”. Click 
on the little plug-in icon, drag it out and down a little then 
release.  

 
A popup menu will appear.  
 

� Select New Node/Math/Math_Functions.   
 

 
This will bring up a Math Function node. We’ll use this node to 
blend both the positive and negative displacement maps together. 
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Since we want Value 2 to be negatively displaced we need to 
change its value to negative one (-1.0).   
 

� Click on the white numbers next the word “Value_2”, 
type in -1 then click the Enter key on your keyboard. 

   

 
The next thing we want to do is set the amount of displacement. 
In this case it is .157. 
 

� Click on the values next to the words Displacement on 
the main Poser Surface node and input the value of .157  

 

 
 
We acquired this value from ZBrush… remember?  I know it’s not 
quite the same value; for some reason, the decimal point needs 
to be moved up one place for Poser to do it correctly. Strange, 
but if it works, that is all that matters to me. Trust me everyone, 
everything else in this tutorial really does make sense! LOL 
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The next thing we want to do is to assign the texture maps to the 
values of the Math Functions Node. Value_1 is going to be the 
positive displacement map and Value_2 is going to be the 
negative displacement map.  
 
The Math_Argument option located in the Math Functions node 
will remain at “Add”. This will add the two values creating one 
sum. Or, in other words, this will combine both the positive and 
the negative displacement maps into one map.  Understanding 
how these nodes work can really open some creative doors and in 
my opinion makes Poser very powerful at creating realistic 
shaders. Poser5’s Firefly render engine is very nice! 
 
Well, it sure has been a long journey and we are getting very 
close to the end of the tutorial now, so, marching on.  Let’s 
import our displacement maps. 
 

� First we’ll import our positive displacement map. Click 
and drag out the plug-in icon for Value_1 located in the 
Math Functions Node. Release the mouse button and select 
New Node/2D textures/image_map from the popup menu.  
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You will now have a new node titled “Image_Map_2”. Notice that 
this node has all sorts of options for your image map.  
 

 
 

� Click the word “None” next to the Image_Source option. 
 

� This will bring up a Texture Manager window that will let 
you browse your PC for the source file. Click on the word 
“Browse”. 
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� Locate the positive displacement map. You will find it in 
the BizManDisp folder that we created.  

 
The name of the file is PzBizManDisp+.PSD. Open this file then 
click the word “OK” in the Texture Manager window. Well, that 
will do it for the positive displacement map. Next we’ll use the 
same steps as above for the negative displacement map.  
 

� Click and drag out the plug-in icon for Value_2 located in 
the Math Functions Node. Release the mouse button and 
select New Node/2D Textures/image_map from the popup 
menu. 

 
You will now have a new node titled “Image_Map_3”. Notice that 
this node has all sorts of options for your image map.  
 

� Click the word “None” next to the Image_Source option. 
 
Same as before this will bring up a Texture Manager window that 
will let you browse your pc for the source file.  
 

� Click on the word “Browse” 
 

� Locate the negative displacement map. You will find it in 
the BizManDisp folder that we created.  Open this file then, 
click the word “OK” in the Texture Manager window. 

 
Well, that just about does it. Our displacement maps are now 
built into the current shader of our figure. All we have to do now 
is set the render options of the Firefly render engine.  
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� Open the Render Options palette located in the bottom 
of the Render pull down menu.  

 

 
� You can use either Draft or Production quality rendering. 

 
I chose Production quality.  
 

� Be sure that you have the FireFly renderer checked and 
also check Use Displacement maps, Raytracing on, Cast 
Shadows, and Smooth polygons.  

 
Using these options will make for a very nice render.   
 

� See the option called Use Displacement maps, 
underneath it are the words Maximum displacement 
bounds. We need to input our Displacement value here .157   

 
Once again, it is exactly the same value that we used earlier, the 
Alpha Depth Factor with the decimal dropped one place.  
 

� And finally, go back into the Pose room and…*gratuitous 
drum roll please* press Ctrl+R to render the image.  
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Look at those beautiful displacement maps!  
 

 
Well, it’s been real fun. I’m sure you will get the hang of it real 
quick and start creating ultra-high detail displacement maps for 
your Poser characters. It’s really a wonderful technology with 
amazing potential!  
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Keyboard Shortcuts 
 
In order to make it as easy as possible to find 
a particular shortcut, the following list is laid 
out by palette name. 
 

Alpha Palette  (Alt+A)  
 

Color Palette (Alt+Z)    
      
C  Selects whatever color is under 
the cursor  
Ctrl+F  Fills Layer with currently 
selected color 
V  Swaps the foreground and 
background colors   
 
 

Document Palette (Alt+O)   
       
Ctrl+O Open a Document   
Ctrl+S  Saves the Document  
   
  

Draw Palette (Alt+D)    
      
D  Brings up Depth slider at cursor 
location  
I  RGB Intensity slider appears at 
cursor location  
Shift+I Z Intensity slider appears at 
cursor location  
L  Lock RGB and Z Intensity sliders  
S  Brings up Draw Size slider at 
cursor location  
ALT  While held down, toggles 
between Zadd and ZSub 
 
 

Edit Palette (Alt+E) 
 
Ctrl+Z  Undo 
Ctrl+Shift+Z Redo 
     
(Note that both functions are based on the mode that the 
user is in.  If Transform>Edit Object is active, then will 
undo or redo the last change to the model.  If it is not 
active, then they will undo or redo the last chnage to the 
canvas.  Some changes, however, cannot be undone.) 
 
 

Layer Palette (Alt+Y) 
 
Ctrl+N  Clears the active layer 
Ctrl+F  Fills the active layer with the 
currently selected material and color or 
texture. 
Ctrl+B  Bakes the layer shading 
Shift+Click On any layer will toggle all 
layers on or off. 
~+Click Selects the layer on which the 
clicked pixol resides 
~+Drag Moves the layer contents.  (Equal 
to Layer>Displace H and Layer>Displace V) 
~+Alt+Drag Moves the layer content depth 
(Equal to Layer>Displace Z) 
 
 

Light Palette (Alt+L) 
 

Marker Palette (Alt+K) 
 

Material Palette (Alt+M) 
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Movie Palette (Alt+V) 
 
Ctrl+Shift+G Brings up Grab Frame slider at 
cursor position 
Ctrl+Shift+O Starts continuous recording 
Ctrl+Shift+P Plays ZMovie 
Ctrl+Shift+W Select a Window 
Ctrl+Shift+! Records a single frame 
 
 

Picker Palette (Alt+I) 
 

Preferences Palette (Alt+P) 
 
F  Quick 3D Edit 
Shift+F Polyframe mode 
Ctrl  When Popup Info is turned on, 
hold down Ctrl to see even more detailed 
descriptions 
Ctrl+Click On a Float Menu item, removes 
that item from the Float Menu 
Ctrl+Drag Pull an item from the interface 
into the Float Menu.  Items can be docked 
with otther items, or left floating separately 
Ctrl+Shift+I Store Interface Configuration 
Tab  Toggles Float Menu on and off 
   

Render Palette (Alt+R) 
Ctrl+R  Render area around cursor 
Ctrl+Shift+R Render All 
 
 

Stencil Palette (Alt+N) 
 
Alt+H  Turns Stencil on/off 
Ctrl+H Hide/Show Stencil 
Spacebar Bring up Coin Controller at 
cursor position 
 
 

Stroke Palette (Alt+S) 
 
Ctrl+1  Replay last stroke 
Ctrl+2  Replay all strokes 
Ctrl+3  Record brush strokes 
 
 

Tablet Palette (Alt+B) 
 

Texture Palette (Alt+X) 
 

Tool Palette (Alt+T) 
 
Ctrl+Shift+T Save the active tool 
     

Transform Palette (Alt+F) 
 
D  Go up 1 subdivision level 
Shift+D Go down 1 subdivision level 
E  Scale 
Q  Draw pointer 
R  Rotate 
T  Edit Object 
W  Move 
(Note that the above shortcuts can work be used 
together.  For example, when Edit Object is not active, 
W will bring up the Move gyro.  When Edit Object is 
active, W will enter Edit>Move mode.) 
M  Create a marker 
Ctrl+M  Remove a marker 
X  X symmetry 
Y  Y symmetry 
Z  Z symmetry 
Ctrl  When Edit Object is active, hold 
down to paint a mask on the object 
Ctrl+G  3D Copy 
Shift  Constrains object rotation when 
in Rotate or Edit Object mode 
Shift+S Snapshot the current object 
Ctlr+Shift Combine with click or drag to 
control partial mesh visibility. 
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Zoom Palette (Alt+W) 
 
0  View actual size 
+  Zoom In 
-  Zoom Out 
Ctrl+0  Half-Sized, Antialiased view.  
After doing a best render, use this before 
exporting to save an antialiased image. 
Spacebar+Drag Pans the canvas 
 
 

ZScript Palette (Alt+Z) 
 
H  Show/Hide ZScript window 
Ctrl+U  Reload a ZScript 
Ctrl+Shift+L Load a ZScript 
Left Arrow Load last ZScript 
Right Arrow Load next ZScript (only works if 
you have used Left Arrow) 
Up Arrow Scroll ZScript Up 
Down Arrow Scroll ZScript Down 
Esc  Halt ZScript execution 
 
 

Special 
 
Spacebar Brings up QuickMenu at cursor 
location 
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