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Quick start
1. After installing Kineticon (and restarting your Mac), launch Kineticon Editor.
2. In Kineticon Editor, enable the icon animations that you wish to use.

For each enabled icon animation you would like to have appear on a file, folder or drive:
3. Copy the kine's "replacement" icon (to the right of it's enabling check-box) onto the 
clipboard by selecting the icon and using the "Copy" command in Kineticon Editor's "Edit" 
menu or by clicking on the small clipboard icon to the right of the kine's replacement icon.
4. Paste the kine's icon onto a file, folder or drive in the Finder by selecting the file, folder or 
drive and using the "Get Info" command in the Finder's "File" menu.  After the "Get Info" 
window for the file, folder or drive opens, select the icon in the upper-left corner of the 
window (click on it to select it) and choose "Paste" from the Finder's "Edit" menu. Close the 
"Get Info" window.

5. Quit Kineticon Editor.  The newly pasted icons in the Finder will animate.

More complete instructions...

What does Kineticon do?
Kineticon replaces static (non-animating) icons on your Mac with animated icons.  In order to 
do this, Kineticon attempts to learn where the icons that you've requested it animate are 
located, it then plays the requested animation in place of the icons.  Because Kineticon is 
only concerned with what the replacement icon looks like while it's trying to figure out 
where to put an animation, there's no need to "tell" Kineticon which file or folder has an 
animating icon.  Whenever an icon that matches a kine's replacement icon is drawn, it will be 
replaced by the kine's animation; all that's necessary is to give the file or folder the correct 
icon.

Installing Kineticon
To install Kineticon, use the Kineticon installer.  The installer will place the Kineticon folder 
onto your startup drive and the Kineticon extension into your Extensions folder. Once 
Kineticon has been installed, you can locate Kineticon Editor anywhere that you find 
convenient.   The "Kines" (pronounced as "kinny" like in "skinny") folder and the "Kines 
(Disabled)" folder can be located anywhere as well, as long as they are somewhere on your 
startup drive.  The first time you launch Kineticon Editor it will ask you to locate the "Kines" 
folder; if the "Kines" folder is in the same folder as Kineticon Editor it will find it without 
your help.  In addition, if located in either the "Applications Support" folder (only with 
MacOS 8.0 or higher) or the "Preferences" folder inside your System Folder, Kineticon Editor 
will automatically locate the "Kines" folder.  If you ever need to force Kineticon to ask you 
where your "Kines" folder is located, simply hold down the option key while launching 
Kineticon Editor - the editor will ask you to locate the "Kines" folder.



Removing Kineticon
To disable Kineticon, just take the “Kineticon” file out of your Extensions folder (either by 
dragging it out yourself or by disabling it with an extensions manager) and restart your 
Macintosh.  Kineticon does not make any permanent changes to your system, so once you 
disable it, it will no longer have any effect.  Note: when you paste a new icon onto a file, 
folder or drive, any previously pasted icon will be lost forever.  You can clear the file, folder 
or drive's new icon and return it to its default icon by selecting the icon in the "Get Info" 
window and choose "Clear" from the "Edit" menu.

Using Kineticon Edtior to configure Kineticon (choosing your kines)
Kineticon Editor is the application that you use to create and edit your kines.  Kineticon 
comes with a nice collection of kines (inside the "Kines" and "Kines (Disabled)" folders).  

Kineticon will only animate those kines that you have enabled with Kineticon Editor.

To enable a kine, check the "enable" checkbox to the left of the kine's icon in Kineticon 
Editor.  To disable a kine, un-check the "enable" checkbox.

To add new kines place them either into your "Kines" folder or into your "Kines (Disabled)" 
folder and launch Kineticon Editor to enable or disable them.

To use a kine, copy the icon from the kine (see Figure 1) and paste it onto a file, folder or 
drive that you wish Kineticon to animate (see Figure 2).  When you quit Kineticon Editor the 
file or folder's icon will animate.  You can click the small clipboard icon directly to the right 
of the kine icon to quickly copy it to the clipboard.

Alternatively, to create a new folder with the kine's icon in the Finder, simply drag the kine's 
replacement icon from Kineticon Editor to your desktop; a new folder will be created with 
the kine's icon.

Kineticon Editor will display all the kines that are located in either your "Kines" folder or your 
"Kines (Disabled)" folder.  You should enable and disable kines directly from Kineticon Editor 
rather than moving the files between these two folders manually.  Simply dragging a kine 
from the "Kines (Disabled)" folder to the "Kines" folder will not activate it.  Kineticon needs 
to be re-started to stop or start kines.  When you launch Kineticon Editor, Kineticon is 
stopped.  Kineticon is re-started with your new kine selections active when you quit 
Kineticon Editor.

Note/caveat: Enabling two or more kines with the same replacement icon image will have 
unpredictable results.



What about the Trash Can?  I can't paste over it!
Kineticon can replace certain "standard" system icons with animations as well (without 
pasting).  For example, to replace the Empty Trash icon with an animation, open Kineticon 
Editor, and open the desired animation (double-click the kine); next to the replacement icon 
in the upper-left of the kine's window there's a small popup menu.  Using this menu choose 
"Empty Trash" and Save the kine.  When you quit Kineticon Editor, that kine's animation will 
be applied to the Empty Trash icon on your desktop.



Previewing kines in Kineticon Editor
To preview a kine from within Kineticon Editor without having to enable it, simply click and 
hold (don't release the mouse button) on the little movie icon directly to the right of the 
kine's icon.  The kine will animate until you release the mouse button.

Note: currently, in order to preview a kine from within its editing window after it has been 
modified, the modifications must be saved to disk (the preview button will only be enabled 
after any modifications to the kine have been saved).

Using Kineticon Editor to edit kines and create new kines
To edit a kine simply double-click it in the main "Kines" window or choose "Open" from the 
file menu to open it and change its settings (speed, etc.).  Some kines allow you to change 
the icon that they replace on your desktop (the Warp Hole kine will not allow this).  To 
modify the icon that a kine replaces, simply paste (or drag) an icon picture onto the upper 
left hand icon image in the kine's window.

Note: you can get a file or folder's icon image onto the clipboard by using "Get Info..." in the 
Finder, clicking on the icon in the upper left hand corner of the Info window and choosing 
"Copy" from the Edit menu.  This puts a picture of the file or folder's icon onto your 
clipboard; from there you can paste it onto a kine's icon.

If you would like to create your own kine, choose "New Kine" from the File menu.  You can 
edit this new kine to create the animation that you want.  You can cut, paste or drag the 
sequence of icons displayed in the lower portion of the new kine's window with icon images 
of your own creation.  Once the new kine has been saved and enabled, the images displayed 
in the lower portion of the kine's window will be animated from left to right (and possibly 
back again) replacing the kine's icon (in the upper-left of the kine's window) on your 
desktop according to the kine's other settings.

In addition, you can use a graphics or icon editor (PhotoShop, ResEdit, Icon Machine, etc.) to 
create your icons and then paste or drag them into the appropriate places in the kine's 
window.  When you paste a picture as an icon, Kineticon Editor will create an appropriate 
mask for that icon by trying to "fill" the space around the icon that is white (whatever it 
can't fill becomes the mask - this works just like the Finder's pasting of icons onto files and 
folders).  If you would like to directly change the mask of an icon,  use the "Paste Mask" 
command in the Edit menu.  Also, sometimes it's useful to be able to paste a series of icons 
all at one time; if the pasted or dragged icon image is more than 32 pixels wide it will be 
interpreted as a collection of icons.  Pasting or dragging such an image into the Sequence 
portion of a kine window will paste multiple icons into the sequence.  For example if your 
icon image was 128 by 32 pixels, that would be interpreted as 4 icons (32 times 4 equals 
128).  If you want to see what such an image looks like, open one of the editable kines (the 
Trash Flies kine for example) and select four of the icons in the animation sequence, choose 
"Copy" from the Edit menu, go to the Finder and choose "Show Clipboard" from the Edit 
menu - there's the icon image.  If you want to see what the masks of the four icons would 
like like, choose "Copy Mask" from the Edit menu then look at the clipboard in the Finder.

If you're using Photoshop to create the artwork for your kine, you can utilize the bundled 
"Copy Kine Icon" Photoshop plug-in.  Simply move the plug-in to your Photoshop plug-ins 
folder.  This plug-in will allow you to copy an entire 32x32 pixel, Photoshop layer to the 
clipboard for pasting as an icon inside Kineticon Editor.  Simply create a new 32x32 pixel, 
RGB document in Photoshop and then create a new layer.  You can use any of Photoshop's 
tools, filters, etc. to create your artwork on the layer.  When you're ready to move the 
image to Kineticon Editor, simply select the layer in the Photoshop layers palette and 



choose "Copy Kine Icon" from the "Filters" menu ("Copy Kine Icon" will be inside the 
"Kinetic Creations" sub-menu of the "Filters" menu).  This filter will copy the ENTIRE layer to 
the clipboard in a format that Kineticon Editor will understand.  This special format will 
include the layer's transparency which Kineticon Editor will transform into the icon's 8-bit 
mask (all Kineticon icons are 32-bit with 8-bit masks - even on pre-8.5 systems).

Trouble-shooting (just in case Kineticon doesn't perform flawlessly)
Kineticon WILL NOT animate labeled icons.  If you want an icon to animate, you must set its 
label in the Finder to "none" (use the "Label" command in the Finder's "File" menu).

In order to conserve RAM and CPU usage, Kineticon will only animate one icon belonging to a 
given kine at a time.

If a kine that was animating on your desktop mysteriously stops, try either selecting and de-
selecting it or moving it around.  If the kine is in a window, using the "window shade" tool 
(at the right of the window's title bar) to collapse and expand the window or closing and re-
opening the window will usually restart the kine.

Sometimes it may take a few seconds for Kineticon  to start or restart an animation - wait a 
few seconds and Kineticon may surprise you.

Purchasing Information

BY FAR the easiest way to pay for Kineticon is online with a credit card.  Go to our web site 
at: http://www.KineticCreations.com/shop/ and follow the link to the online payment form. 
Then simply fill in the form with your purchasing information.

Otherwise, paying for Kineticon is still fairly simple. Open the "Purchase by mail/email/FAX" 
application that accompanies Kineticon. Enter your name, your email address, and the 
quantities you desire. Save, Copy or Print the data from the purchase program and send the 
data and payment to "Kagi".  More specifics on the purchase application to follow.

If you are paying with a credit card, you can email or fax the data to Kagi. Their email 
address is sales@kagi.com and their fax number is +1 510 652-6589. You can either Copy 
the data from "Purchase by mail/email/FAX" and paste it into the body of an email message 
or you can Save the data to a file and you can attach that file to an email message. There is 
no need to compress the data file, it's already pretty small. If you have a fax modem, just 
Print the data to the Kagi FAX number. 

Payments sent via email are processed within 3 to 4 days. You will receive an email 
acknowledgement when it is processed. Payments sent via fax take up to 10 days and, if 
you provide a correct internet email address, you will receive an email acknowledgement. 

If you are paying with cash or USD check you should print the data using the purchase 
application and send it to the address shown on the form, which is: 

Kagi
1442-A Walnut Street PMB #392-3U6
Berkeley, California 94709-1405
USA



You can pay with a wide variety of cash from different countries but at present if you pay 
via check, it must be a check drawn in US Dollars. Kagi cannot accept checks in other 
currencies, the conversion rate for non-USD checks is around USD 15 per check and that is 
just not practical.

If you have a purchasing department, you can enter all the data into the purchase program 
and then select invoice as your payment method. Print three copies of the form and send it 
to your accounts payable people. You might want to highlight the line that mentions that 
they must include a copy of the form with their payment. Kagi cannot invoice your 
company, you need to act on our behalf and generate the invoice and handle all the 
paperwork on your end. Please do not fax or email payment forms that indicate cash, check 
or invoice as the payment method. As far as we know, there is still no technology to 
transfer physical objects via fax or email and, without the payment, the form cannot be 
processed. Payments sent via postal mail take time to reach Kagi and then up to 10 days 
for processing. Again, if you include a correct email address, you will hear from Kagi when 
the form is processed.


