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1. Introduction

ReVision is a ReWire master application that allows you to synchronise playback of
a ReWire device such as Reason or Live and a QuickTime movie. These music
production tools have all the features you need to compose a soundtrack except for
an integrated video player. ReVision fills the gap and lets you use the tools you
know and love.

Notes for ReVision 1.0 Users:

The new tempo and time signature features require that ReVision 1.1 projects have
an initial tempo and time signature. You may find your existing projects playing
back at this tempo. Use the "Options->Show Project Settings" dialog to set the
correct tempo and time signature.

You no longer need to import a QuickTime movie in order to use most of ReVisions
features which is very useful for Reason users looking for a general tempo change
feature.

2. Getting Started

Note: Until Revision is registered you will be unable to save a project and the
program will automatically quit after ten minutes. To register choose the "ReVision-
>Register..." menu item and follow the instructions on the Register window.

When you first launch ReVision it presents you with an untitled window that can be
used for your first project. To import a movie choose the "File->Import Movie..."
menu item. The first frame of the movie will be displayed in the movie view. To load
a ReWire device choose the appropriate device from the "Device" menu. The
available devices you have installed should be listed.

When you choose a device the console app with which you're probably familiar
may be launched. (Some devices such as Live require you to start the device Ul
yourself by launching the application).

You're now ready to begin your composition. Clicking on the "Play" button will start
the QuickTime movie and the ReWire device. Clicking "Stop" will stop them both.
The Fast Forward and Rewind buttons change the movie and the ReWire device



playback position simultaneously allowing you to search for a particular point in the
movie.

You can use the Markers to record an interesting position in the movie and then
jump to that position at any time. To add a marker simply get to an interesting
position in the movie and click on the '+' button. A new marker will be added to the
list. To change the name of the marker to something more meaningful, double click
on it and type in the new name. You can add as many markers as you need. They
will be saved along with the URL to the movie and the name of the ReWire device
you chose.

Note: Device song names are not able to be saved so you must reopen the song in
the device you were working with after to you reopen the ReVision document.

Note: For best results videos with low data rates should be used in order to avoid
over-taxing the CPU. The video does not need to be full-quality HD for composition
purposes. Data rates of less than 200Kbps should be adequate. Higher data rates
can cause the performance of the ReWire device to suffer.

When your composition is complete you can export it from ReVision using the "File-
>Export AIFF..." menu item. The Export dialog allows you to make various audio
format choices and also export a demo movie that includes your new soundtrack.

Notes for non-video users: If you're using ReVision for general composition and
want to export your audio through ReVision to take advantage of the adjustable
tempo feature you need to set a ReVision marker to indicate the end of the audio.
To do this simply click on the End marker in Reason (or equivalent in Live) and
then add a marker in ReVision (ReVision is unable to detect the end marker
position through ReWire). Then when you are exporting audio the End marker
should be selected as the export end point in the Export dialog.

3. Guide to the User Interface

ReVision a very straightforward application focusing on handling the video aspects
of your project and letting the sequencers of the ReWire devices handle all the
music processing. The Ul is split down the middle dividing the controls from the
viewers. There are buttons for controlling playback, sliders for setting the volume
levels of the movie and the ReWire devices or muting them entirely if needed. You
can also create markers for quick access to important points in the video.
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ReVision allows you to work on a single project at a time. You cannot have two
ReVision projects open at a time because each project is tightly connected to a
particular ReWire device. To switch projects first close the current project and then
open the next project. The New and Open menu items will be disabled while there
is an open project.

Note: If you are using Live with ReVision you must close the Live Ul before quitting
ReVision. Otherwise ReVision will appear to hang while it waits for the Live Ul to
quit. However once you quit Live, ReVision will quit normally.

If you want the movie to be always visible even when you're working in Reason or
Live you can choose the "Window->Float" menu item. To turn it off just select the
menu item again.



4. Movie Preview
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This part of the interface lets you see the video as it plays with the music or when
you scrub back and forth in ReVision or in your ReWire device. Note that ReWire
only passes the new play position back to ReVision when you stop dragging the
play head. ReVision on the other hand sends the current play position to the
ReWire device as you fast forward and rewind.

You can resize the window in order to adjust the movie view to suit the dimensions
of the video on which you're working. By default ReVision is set to display a 4x3
aspect ratio correctly.

The SMPTE display lets you see where you are in hours:minutes:seconds:frames.
The number of frames is established from the video you imported and can vary.
The SMPTE origin can be changed by using the Project Settings discussed later.
By default the origin is set to "01:00:00:00". You can also adjust the start point of the
movie in order to sync any burned in SMPTE time code to ReVision's time code
display.

The slider allows you to quickly scrub through the video. Dragging the slider to the
far right allows you get to the end of the video. You can play the audio beyond this
point if you need but the slider will no longer move. The left point is set to the start
of the movie (taking into account any offset you may have specified).



You can also use a scrollwheel mouse to scrub back and forth when the mouse is
over the movie view. Scrolling up steps back frame by frame. Scroll down does the
opposite. Holding down the "Option" scrubs by seconds rather than frames.

Finally the left and right arrow keys on your computer keyboard also control

scrubbing in a similar manner (holding down the Option key enables faster
srubbing).

5. Transport
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The transport controls follow standard conventions with Play, Stop, Fast Forward,
Rewind and single frame advance/step back for precise positioning.

During playback the positioning controls are disabled. They are re-enabled when
playback is stopped.

Volumes can be set using sliders or muted entirely using the checkboxes. The
Movie volume slider moves between the minimum and maximum levels. The
ReWire volume slider is initially positioned at the 0 dB level but can be increased to
amplify the audio. The meters can be used to set the audio to a good level.

The clip indicator lets you know when the audio level is to high. It can be reset by
clicking on it. Lower the volume level slider to prevent further clipping. Note: The
volume level is used during the export process.

6. Markers
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The Scoring Markers let you establish locations where music is needed to
accompany the video. When a marker is created the current SMPTE location is
stored with it. While markers are generally disabled during playback you can create
new markers at any time. This allows you to play through a video and create
markers while watching. Once you've created the markers you can jump to any one
by selecting it.

Note: If you find that a marker is slightly off from where you need it to be you can
use the frame advance/rewind buttons to position the video correctly and then use
the "Set to Current" button to set the selected marker to the current SMPTE location.

You can reorder a marker by dragging it up or down the list. Delete a marker by
selecting it and clicking on the "-" button.

You can use the marker locations to optionally specify a tempo change and/or a
time signature change. Any music after the marker will playback using the new
tempo and time signature. A '-' indicates that no tempo or time signature has been
specify and the current settings apply. To clear a setting simply select the contents
of the field and hit the "delete" key.

Note: Use caution when changing tempos during music playback with Reason.
Tempo synced effects may go temporarily "haywire" as they attempt to match the
new tempo.

If you use tempo changes in your project then you must use ReVision's audio
export feature to have those tempo changes reflected in an audio file.

ReVision projects have an initial tempo (120 bpm) and time signature (4/4). This
can be adjusted using the Project Settings dialog accessed from "Options->Show
Project Settings":
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You can also adjust the start offset of the movie. This will change ReVision's
"00:00:00:00" location to a more appropriate point in the movie. Frames are
specified in the frame rate of the movie. You can set this more easily using the
"Options->Set Movie Start To Current" menu item.

The TimeCode origin lets you set an appropriate start value for the SMPTE counter.
A default value for new projects can be set in the ReVision Preferences.

Matching burned in timecode example: To get ReVision to display its timecode in
sync with a 25 fps video that has a burned in timecode starting at "01:01:49:12" you
would do the following:

1. Use the frame advance button to set the current location to the nearest
second. In other words: "01:01:50:00".

2. Use the Options->Set Movie Start To Current" to set the zero point to the
current movie location.

3. Use the TimeCode Origin settings to match the video timecode. In other
words enter: "01" for hours, "01", for minutes and "50" for seconds.

The two timecodes should now remain in sync.

8. Export Audio

To export audio from ReVision use the "File->Export Audio" menu item. This menu
item will be disabled if you have not imported a movie and have not created any

markers (a marker is needed to indicate the length of the project.)

When you select the menu item the following dialog is presented:
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There are a number of options available allowing you great flexibility.

The Export From: and To: popup menus allow you to specify the start and end
points of the audio export. If you have imported a movie these will default to the
start and end locations of the movie (taking into account any start offset you have
specified). You can adjust these to select a range between particular markers if
needed.

The Sample Rate: popup defaults to 44100 Hz but can be adjusted between 11025
Hz and 96000 Hz. The Bit Depth popup lets you choose between 16 and 24 bits.

If you have imported a movie the "Create demo movie" checkbox lets you create a
new movie (with the same name but with a .mov) extension. If you have not
imported a movie this checkbox is disabled.

Note: The demo movie will use the volume settings you've used during playback.
For example if the movie's original audio track is muted in the project then it will be
muted in the demo.

9. Preferences

Set the preferred folders for finding movies to import and exporting audio files. Also
set the default TimeCode origin.

Thank you for using ReVision.

Visit us on the web at: www.grantedsw.com
or email us at: info@grantedsw.com



