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Read Me First
 
Welcome to Take Control of Bookle, version 1.0, published in 
January 2012 by TidBITS Publishing Inc. This book was written by 
Adam C. Engst and edited by Tonya Engst. 

This book teaches you everything you need to know to read DRM-
free EPUBs in Bookle, the EPUB-reading app created as a joint 
project of TidBITS Publishing Inc. and Stairways Software. Why? 
Because the Mac world needs a good EPUB reader. 

Copyright © 2012, TidBITS Publishing, Inc. All rights reserved.
 

Updates and More
 

You can access extras related to this ebook on the Web. On the ebook’s 
Take Control Extras page, you can: 

•	 Find out about any available new version of the ebook. 

•	 Download various formats, including PDF, EPUB, and—usually— 
Mobipocket. (Learn about reading this ebook on handheld devices 
at http://www.takecontrolbooks.com/device-advice.) 

•	 Read postings to the ebook’s blog. These may include details of 
Bookle updates, new tips for using Bookle, or other useful 
information, as well as links to author interviews. 

•	 Add the ebook to your Take Control account (create one if 
necessary) to be notified by email of important updates to Bookle. 

Basics
 

Here are a few rules of the road that will help you read this book: 

•	 Menus: Where I describe choosing a command from a menu in 
the menu bar, I use an abbreviated description. For example, the 
abbreviated description for the menu command that opens an 
ebook in Bookle is is “File > Open.” 
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• Contextual menus: Contextual menus, also known as secondary 
menus—appear when you Control-click various elements on a 
Macintosh screen, including Dock items and files in Finder 
windows. To describe opening a contextual menu, I usually I tell 
you to Control-click an item on the screen. If your mouse offers 
a right-click option, or if you use a trackpad or other means of 
opening a contextual menu, you should feel free to use the method 
you prefer. 

• Finding System Preferences: I sometimes refer to settings in 
System Preferences that you may want to adjust. To open System 
Preferences, click its icon in the Dock or choose System Preferences 
from the Apple  menu. When the System Preferences window 
opens, click the icon of the pane whose settings you want to adjust. 
I refer to these panes using an abbreviated notation such as “the 
Speech preference pane.” 

• Path syntax: This book occasionally uses a path to show the 
location of a file or folder in your file system. For example, Mac 
OS X stores most utilities, such as Terminal, in the Utilities folder. 
The path to Terminal is: /Applications/Utilities/Terminal. 

The slash at the beginning of the path tells you to start from the 
root level of the disk. You will also encounter paths that begin with 
~ (tilde), which is a shortcut for the user’s home directory. For 
example, if a person with the user name joe wants to install fonts 
that only he can access, he would install the fonts in his ~/Library/ 
Fonts folder, which is just another way of writing /Users/joe/ 
Library/Fonts. 

• User Library: The library folder mentioned in the previous 
paragraph, ~/Library, is normally invisible in Lion. To see it, hold 
down the Option key and choose Go > Library in the Finder. 
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Introduction
 
Welcome to Bookle! This book, and the program that it documents, is 
a departure for us. Here at TidBITS Publishing, we’re used to helping 
people learn how to use programs designed and written by others. 
But Bookle is different. It’s the result of a four-hour drive that I took 
to a Mac user group meeting, which gave me ample time to ponder the 
state of the ebook world. By the time I finished the trip, I had decided 
that the Mac needed a native program devoted to ebook reading, and 
particularly one designed with a Mac user’s sensibility and that could 
display books in the EPUB format. Not being a programmer, though, 
I started thinking about who I could convince to write Bookle from 
my design. 

Almost immediately, my friend Peter Lewis of Stairways Software 
came to mind, since he’s well known for writing programs like FTPd, 
Anarchie (later called Interarchy), and, most recently, Keyboard 
Maestro. Although Peter is from Australia, we’ve known each other 
since the early days of the Internet, when I accidentally invited him 
to visit me in Seattle for a week after nothing more than some email 
exchanges. (Moral of the story: It turns out that Australians will travel 
nearly anywhere when they’re on the right continent.) 

Peter is a top-notch programmer, and with only a brief delay caused 
by throwing out his back in what I hope was not a Mac-related 
accident, he figured out the EPUB spec and built the Bookle app in 
record time. With Bookle and our test EPUB documents in Dropbox, 
we went back and forth for a while on testing and tweaking, and before 
long, Bookle 1.0 was ready. 

It’s worth taking a moment to talk about what we mean by that 1.0 
version number. We have lots of ideas for features we’d like to add to 
Bookle, ranging from support for additional formats to a full ebook 
library management interface, but let’s be realistic here—Apple is the 
800-pound gorilla in the room. Part of the reason I came up with the 
idea for Bookle is that Apple has failed to build EPUB support into Mac 
OS X 10.7 Lion in any way. Not in Preview, not in Safari, not in iTunes, 
not anywhere. 
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So our goal with Bookle 1.0 is to get a program out quickly that can 
help you read your ebooks in the here and now (Figure 1). 

Figure 1: With Bookle, you can read EPUBs on your Mac now! 

As long as Bookle remains popular and Apple doesn’t crush us 
underfoot with built-in EPUB support, we’ll keep improving the 
program with features we have planned and from feedback we get from 
users. We’ve started a UserVoice site at http://bookle.uservoice.com/, 
where you can vote for your favorite ideas and add new ones. 

The one feature I don’t know if we’ll be able to add, though, is support 
for ebooks that are encrypted with digital rights management code 
(DRM), including many books from the iBookstore and other ebook 
resellers. DRM is generally thought of as a way of preventing digital 
content from being copied, but the side effect that big companies like 
Apple and Amazon really appreciate is that it prevents anyone from 
offering competing, interoperable ebook reader products. 

Neither Apple nor Amazon will license their DRM systems, and while 
Adobe will license Adobe Digital Editions, it’s a six-figure cost that 
effectively eliminates all but the largest of companies from the game. 
So, our apologies in advance, but I don’t think there’s anything we’ll be 
able to do with DRM-shackled ebooks. 

But enough naysaying—let’s take a look at Bookle and EPUB! 
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Manage EPUBs in Bookle
 
Before you can read an EPUB in Bookle, you’ll need to add it to your 
Bookle library. Luckily, that’s trivially easy, and it’s equally easy to 
remove EPUBs that you’ve read or no longer wish to keep around. 

Installing Bookle: If you don’t have Bookle installed yet, you can 
purchase it for $9.99 from the Mac App Store. Bookle requires at least 
Mac OS X 10.6.8 Snow Leopard or 10.7 Lion. To learn more, visit 
http://bookle.stairways.com/. 

Understand Bookle’s Library
 

Bookle works a bit like iTunes in that it can open EPUB files from 
anywhere on your hard disk, but upon opening them, it copies the file 
into a special location for future use. (The original remains intact and 
is never touched.) That way, when you want to return to reading an 
ebook tomorrow, you don’t have to open the file from the Finder again, 
since it’s ready and waiting for you in Bookle. 

To meet the Mac App Store’s sandboxing requirements, Bookle can’t 
just use a folder in ~/Documents. Instead, EPUBs are stored in one of 
two places, depending on whether you’re using Mac OS X 10.7 Lion or 
10.6 Snow Leopard: 

•	 Lion: ~/Library/Containers/com.stairways.Bookle/Data/Library/ 
Application Support/Bookle 

•	 Snow Leopard: ~/Library/Application Support/Bookle 

I’m telling you this so you know how things work behind the scenes, 
and so you can make sure you know where your EPUBs are for backup 
purposes or if you need to send one to a friend. That said… 

Warning! You should never add or remove files from this folder 
manually: Bookle won’t see any new files that appear here without 
its knowledge, and deleted files won’t be removed from your library 
properly (they’ll still appear in it, but can’t be viewed). 
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Luckily, it’s easy to add and remove EPUBs from Bookle. If you don’t 
have any to work with, you can either Find EPUB Books or Create 
EPUB-formatted Files. 

Add EPUBs to Your Library
 

There are a number of ways to add EPUBs to your Bookle library: 

•	 From within Bookle, choose File > Open and select the EPUB in the 
Open dialog. 

•	 In the Finder, drag the EPUB file onto Bookle’s icon in the Dock or 
the Finder. 

•	 In the Finder, double-click the EPUB file. Note that this method— 
and any other way you open files in the Finder—may not work if 
some other application has set itself to open files with the .epub 
filename extension. 

Regardless of how you add the EPUB, Bookle makes a copy of it 
internally and displays it alphabetically within the list of titles in your 
library (Figure 2). The original file remains untouched and in its 
original location. 

Figure 2: Look in the sidebar at the left of the Bookle window to see 
the Library listing of all the EPUBs that you’ve added to Bookle. 
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Whether or not you choose to maintain your original EPUB separately 
from Bookle’s copy is up to you, since you can always recover the file 
from Bookle’s internal storage location mentioned previously. 

Delete EPUBs from Your Library
 

At the moment, there’s only a single way to remove an EPUB from your 
library, since it’s something you’re unlikely to want to do all that often. 
To do so: 

1. Select the title you want to delete in the Library. 

2. Choose File > Delete Book. 

3. In the confirmation dialog, click the Delete button. 

To reiterate, deleting an EPUB from Bookle’s library affects only 
Bookle’s internal copy of the file. 

Sorting and Managing Your Bookle Library
 

Since our goal with Bookle 1.0 was to make it available quickly so 
people could start reading EPUBs on their Macs, there’s currently no 
way to sort the library other than alphabetically by title. In a future 
version of Bookle, we’re planning an interface that would let you sort 
based on title, author, date added, date last read, and other bits of 
metadata. If this sounds appealing, vote for the idea in our UserVoice 
forum: http://bookle.uservoice.com/forums/139729-feature-
suggestions/suggestions/2528805. 

Bug or Other Infelicity?
 

If you should experience a bug or other problem with Bookle, please 
let us know at bookle-support@stairways.com so we can fix it. 
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Read EPUBs in Bookle
 
Once you’ve added EPUBs to your library, it’s time to read them. I 
assume you have the whole reading thing down, but there are a few 
details and niceties that you might not realize on your own. 

Switch between EPUBs
 

As I mentioned previously, any time you open an EPUB in Bookle, it is 
automatically added to your library, so there’s no need to open it from 
the Finder again. (However, if you open a book already in the library, 
Bookle is smart enough to avoid adding it again, assuming the file is 
exactly the same as the one that’s already stored.) 

Also, when you open an EPUB for the first time, Bookle automatically 
displays the table of contents and first page of that book. How do you 
then switch to reading a different EPUB? 

Simple. Just click its title in the Library section of the sidebar at the 
left. Nothing more is necessary, and if you were reading the EPUB 
previously, Bookle automatically returns you to where you were before. 

In Lion, Bookle also tries to remember which EPUB you were reading 
last when you quit, so it can open that file and return you to the 
previous location when you next launch the app. 

If you’re using Snow Leopard, or if you hold the Option key down and 
choose File > Quit and Close All Windows in Lion, Bookle won’t reopen 
your last-read EPUB. Instead, it opens a new window showing the 
contents of the library but without a book selected. Just click one in the 
Library section and you’ll be all set. 
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Want to Open Multiple EPUBs Simultaneously? 

Let’s say you want to compare two versions of an EPUB, or you’re 
researching a topic using multiple EPUB files. Although it’s easy to 
switch between EPUBs by clicking their titles in the Library section 
of the sidebar, it might be better to have several showing at once. 
To accomplish that, choose File > Open Library (Command-N). 

Once you have multiple windows open, you can tile or stack them 
however makes sense for your screen space. You can close a window 
by choosing File > Close (Command-W), or, if you’ve ended up with 
a bunch of windows open, hold down Option and choose File > Close 
All (Command-Option-W). 

Scroll within an EPUB
 

Moving around within an EPUB in Bookle uses all the standard 
mechanisms you’re accustomed to from other Mac applications, with 
two slightly unusual differences. 

First, like a Web browser (and Bookle is very much like a Web browser, 
given that EPUB files are essentially HTML files), Bookle keeps track 
of your history, that is, the list of actions that you take while clicking 
links in an EPUB. So if you’re reading along in a Take Control ebook, 
for instance, and you click an internal link to jump to another part 
of the book, you can use the Back button in the toolbar, a keyboard 
shortcut, or a menu item to return your previous location, just as you 
would in a Web browser. And once you’ve jumped back, the Forward 
command takes you forward again. 

Second, just as Web sites are split up among multiple Web pages, 
EPUB files are generally split up into chapters. The Table of Contents 
section of the sidebar (Figure 3) lists the EPUB’s chapters (which may 
have subheads—Take Control ebooks have two-level tables of contents, 
for instance). 
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Figure 3: Click entries in the Table of Contents at the left (shown 
here) to move around in the text of your ebook at the right. 

Click any entry in the Table of Contents section of the sidebar to view 
the start of its text in the main pane of the Bookle window. Of course, 
you can also read a multiple-chapter EPUB straight through; the 
easiest way to move from the end of one chapter to the beginning of 
the next is to press the Space bar. 
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Table 1 lists all of the ways that you can move around within an 
EPUB in Bookle. 

Table 1: Bookle Navavigation Commands 

Action Command 

Scroll by line • Up/Down arrow keys 

• Two-fingered trackpad gestures 

• Scroll wheel 

Scroll by page • Page Up/Down keys 

• Space bar (scrolls down only) 

Navigate by history • Back/Forward toolbar buttons 

• Go > Back, Go > Forward menu items 

• Cmd-[ and Cmd-] keyboard shortcuts 

Navigate by chapter • Click a chapter name in the Table of 
Contents section of the sidebar 

• Next/Previous toolbar buttons 

• Go > Next Chapter, Go > Previous Chapter 
menu items 

• Cmd-left arrow and Cmd-right-arrow 
keyboard shortcuts 

• Spacebar (at the end of a chapter) 

Change EPUB Display
 

Everyone has different preferences when it comes to reading onscreen. 
Some people prefer large text in serif fonts; others are happier with 
relatively small font sizes and sans serif fonts. Plus, the bright white of 
the Mac’s screen, while providing excellent contrast with black letters, 
can be a bit glaring for lengthy reading; some people prefer a soothing 
gray or sepia background. 

Bookle lets you choose the font, size, and background color for each 
EPUB separately, and remembers your settings for each file. So, you 
could have one book that uses 20 point Georgia and a light yellow 
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background and another that instead appears in 18 point Century 
Schoolbook with a white background—it’s entirely up to you. 

Or rather, it may be up to you. Some EPUBs specify their own CSS 
stylesheets and don’t allow certain aspects of them to be overridden. 
For instance, we’ve seen one EPUB where Bookle’s font and size 
settings are ignored, but the background color can be changed. And 
in other EPUBs, the font and size can be changed, but the background 
color remains stuck at white. So if you attempt to tweak what an EPUB 
looks like and nothing happens, it’s because the author hasn’t allowed 
it. Sorry! 

Change the Font 
To change the font, simply choose the desired font face from the 
Font pop-up menu in the toolbar. (If the toolbar isn’t showing 
because you’ve hidden it to have more reading space, choose View > 
Show Toolbar.) 

Bookle provides access to all the fonts installed on your Mac, so 
experiment to see which you prefer. If your Mac is anything like mine, 
you probably have a bunch of special-purpose fonts that might be good 
for a flyer or invitation, but which aren’t appropriate for reading 
straight text for any amount of time. 

My advice is to stick with familiar fonts like Georgia, Helvetica, 
Palatino, and Verdana, since they are classics that are generally well-
designed for onscreen reading. 

Change the Font Size 
Don’t bother changing the font size until you’ve chosen a font face, 
since every font will have a somewhat different base size and while 12 
point might be appropriate for one, 18 point might be best for another. 

You can choose a specific size from the Size pop-up menu in the 
toolbar (again, if it’s hidden, choose View > Show Toolbar), or you 
can click the Size buttons in the toolbar to step up and down through 
the specified font sizes. The buttons perform the same action as the 
View > Bigger and View > Smaller menu items, and the Command-+ 
and Command-- keyboard shortcuts. 

Personally, I prefer picking a font face and then using the keyboard 
shortcuts to adjust the font size for optimal viewing. 
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And This Line Length Was “Just Right.” 

It’s not clear that there is a “right” answer when it comes to how 
long lines should be. Some modern research suggests that people 
read fastest with longer line lengths (up to 10 inches, or 25 cm) 
but may find moderate line lengths (around 5 inches, or 12 cm) 
more comfortable. Also the amount of blank space between lines 
can change the comfortable reading width of the lines. 

Although font face and size affect line length, you can change the 
line length of EPUBs in Bookle by adjusting the window size (unless 
you’re reading in full-screen mode in Lion) and by dragging the 
divider between the sidebar and the main content pane. 

Change the Background Color 
Finally, you can change the background color; just click the Color 
button in the toolbar and move the selection point around in the color 
picker (Figure 4). If the EPUB allows the background color to be 
changed, the color will change as you move the selection point. 

Figure 4: Choose a background color in the color picker. 
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Generally you’ll want to pick a relatively light color to maintain the 
strong contrast with the black letters. 

Note: In Bookle 1.0, there’s no way to set the color of the text, 
which unfortunately precludes creating the white or green text on 
black background display that some people like. If you’re in this 
camp, be sure to vote for this feature on our UserVoice forum so 
we can see how desired it is: http://bookle.uservoice.com/forums/ 
139729-feature-suggestions/suggestions/2528912. 

Listen to an EPUB
 

There’s one other way you can “read” an EPUB in Bookle, and that’s 
by having Mac OS X’s speech synthesis read it out loud to you. In 10.6 
Snow Leopard, the Alex voice is particularly good, and in 10.7 Lion, 
Apple introduced a number of additional high-quality voices. You 
won’t mistake them for a professional reader in an audiobook, but it 
might be a good way to enjoy an EPUB while you’re cooking. 

To choose a voice for Bookle, follow these steps: 

1. Launch Mac OS X’s System Preferences, open the Speech pane, and 
click the Text to Speech button. 

2. From the System Voice pop-up menu, choose a voice (Figure 5). 
Or, to add more voices to the menu, choose Customize (Lion) or 
Show More Voices (Snow Leopard). 

Figure 5: Choose a voice and speaking rate. 

3. If you like, you can adjust how quickly or slowly the voice reads 
using the Speaking Rate slider. 
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Use Airfoil to Listen Through Your Stereo 

If you have one of Apple’s AirPort Express base stations for listening 
to music streamed wirelessly from iTunes, you can use it to listen to 
Bookle reading your EPUB to you as well. What you need to make this 
happen is the Airfoil software from Rogue Amoeba. With it, you can 
stream audio wirelessly to an AirPort Express (or any other AirPlay-
compatible device, or even another Mac running Airfoil Speakers) 
from any application, not just iTunes. Airfoil costs $25 and is available 
from http://www.rogueamoeba.com/airfoil/. 

You have two choices when it comes to listening to an EPUB. You can 
either have Bookle read an entire chapter to you, or you can select a 
portion of the chapter to read. 

To have Bookle read an entire chapter, follow these steps: 

1. In the EPUB you want Bookle to read out loud, navigate to the 
chapter you want Bookle to read. 

2. If you clicked in the table of contents to navigate to your chapter, 
click once more in the text of the EPUB. 

3. Choose Edit > Speech > Start Speaking. 

After a pause to load the voice, Bookle starts reading, and it reads 
everything until the end of the chapter. To stop the reading sooner, 
choose Edit > Speech > Stop Speaking. 

In a few EPUBs, such as some I’ve seen from Project Gutenberg, each 
chapter contains front matter that you probably don’t want to hear. To 
avoid listening to it, select just the portion of the chapter you want to 
hear before choosing Edit > Speech > Start Speaking. 

Faster Selection
 

While you can just select text by clicking and dragging, if you want 
to select almost all of a chapter, a faster approach is to choose Edit > 
Select All (Command-A), hold down the Shift key, and click where 
you want to deselect some of the selected text. If you Shift-click near 
the top of the file, Bookle deselects the text above where you clicked; 
if you click near the bottom of the file, the text below your click is 
deselected. 
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Understand EPUB
 
EPUB is an industry standard developed by the International 
Digital Publishing Forum (IDPF) for reflowable electronic books 
that can be read on any platform, regardless of screen size. In 
essence, the EPUB format is just a collection of HTML files with 
a CSS stylesheet that controls how they look, all compressed into 
a special Zip archive. 

EPUB isn’t the only ebook standard out there, but it has some 
unique advantages over others. Adobe’s Portable Document Format 
(PDF) is nearly ubiquitous (and is, indeed, the primary format we 
use for our Take Control ebooks), but it’s a page-based format that 
tends to work poorly on small-screened devices like the iPhone and 
iPod touch. And while Amazon’s Mobipocket format is reflowable, 
like EPUB, it is used pretty much exclusively by Amazon’s Kindle 
devices and applications. Because of this, many books are being 
converted to EPUB format. 

Plus, as EPUB grows in popularity, it’s becoming increasingly 
easy to create EPUB files, making it a good format for read-only 
documents of various types. So, if you have long documents in 
Microsoft Word that you want to read on an airplane trip, for 
instance, converting them to EPUB would be a good way to get 
them into a format you can read on your iPhone. And with Bookle, 
you can now read those EPUBs on your Mac as well. 

In this chapter, I help you find existing EPUB books and talk about
 
how you can Create EPUB-formatted Files from a variety of sources.
 

Find EPUB Books
 

So what’s available to read in EPUB format? Lots, and especially 
all those classics of Western literature that are out of copyright and 
available for everyone to read. (I was a little embarrassed to realize 
recently that I’d never read either The Adventures of Tom Sawyer or 
Adventures of Huckleberry Finn, something I quickly rectified with 
quick downloads from Project Gutenberg.) But there are plenty of 
modern books as well. Here are some of my favorite sources, and if 
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you know of others, let me know so I can add them to future versions 
of this book, or even build them into a Bookle update in some way. 

Hey, that’s a good idea! If you’d like to see us build EPUB 
acquisition into Bookle, vote for the idea at: http:// 
bookle.uservoice.com/forums/139729-feature-suggestions/ 
suggestions/2528889. 

Tip: However you find EPUBs, once you’ve downloaded them, you’ll 
want to Add EPUBs to Your Library. 

•	 Project Gutenberg: The granddaddy of all free ebook sites, 
Project Gutenberg was founded in 1971 by Michael S. Hart, who 
typed the U.S. Declaration of Independence into an early computer 
at the University of Illinois at Urbana-Champaign. The non-profit 
and volunteer-driven Project Gutenberg offers over 38,000 out-of-
copyright ebooks for free download. (http://www.gutenberg.org/) 

•	 epubBooks: epubBooks offers free titles as well as links to paid 
content. Many of its books come from Project Gutenberg, but it 
claims to have better EPUB formatting, so if you find the formatting 
of a Project Gutenberg book lacking, it may be worth looking for it 
here. (http://www.epubbooks.com/) 

•	 Feedbooks: Feedbooks features public domain titles and original 
books from contemporary authors, many of which are free to 
download and read. However, beware of their commercial books 
(check the Protection line in the book description), many of which 
use Adobe Digital Editions DRM and which won’t be readable in 
Bookle. (http://www.feedbooks.com/) 

•	 Baen Free Library: The venerable science fiction publisher 
Baen Books makes a number of its titles available for free download 
under the entirely correct assumption that once you’ve enjoyed 
one book from an author, you’re more likely to want to buy more. 
I particularly enjoyed their collection of books by Keith Laumer. 
(http://www.baen.com/library/) 

•	 iBookstore: Although it’s tempting to download EPUB books 
from Apple’s iBookstore, and many of them are free, there’s no way 
to tell in advance if the book has been shackled with DRM that will 
prevent you from reading it in Bookle. Whether or not a book has 
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DRM on it is entirely up to the publisher (all our Take Control titles 
in the iBookstore are DRM-free, of course), but my suspicion is that 
most non-free titles will have DRM. 

To download a free book or buy a commercial one from the 
iBookstore, you either use iTunes on your Mac, just like with music 
and apps, or the iBooks app on an iOS device. If you use iBooks, 
you’ll need to sync the file to your Mac. 

Once you download a book from the iBookstore, you can determine 
its DRM status in iTunes on a Mac by clicking Books in the Library 
section of the sidebar and looking in the Kind column. Books 
downloaded from sites other than the iBookstore appear as “Book,” 
DRM-free titles from the iBookstore appear as “Purchased Book,” 
and DRM-shackled books from the iBookstore are labeled as 
“Protected Book.” 

Once a DRM-free EPUB is on your Mac within the iTunes Books 
library, you can open it in Bookle, but first you’ll need to know 
where iTunes has stored the EPUB in the folder hierarchy on your 
Mac’s drive. iTunes stores its files deep within an iTunes Media 
folder; the easiest way to find an ebook’s location is to Control-click 
the ebook’s listing in iTunes and then choose Show in Finder. 

No Kind column in iTunes? Choose View > List. If you 
still don’t have a Kind column, choose View > View Options 
(Command-J), select the Kind checkbox, and click OK. 

Note: In late-breaking news, enhanced textbooks created with 
iBooks Author will almost certainly not work in Bookle—we have very 
little to test with right now, but we’ll be examining those books more 
closely in the future. 
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Create EPUB-formatted Files
 

Although there are a wide variety of ways to create EPUB files, for most 
people, I recommend one of four options: 

•	 Use Apple’s Pages word processor to create a new document or to 
convert text or Microsoft Word documents, and then export the 
resulting Pages document to EPUB. See Create EPUBs in Pages. 

•	 Use another word processor or page layout program to create 
EPUB. Read Create EPUBs with Other Programs. 

•	 Create EPUBs with Automator if you want to generate EPUBs 
automatically 

•	 Convert Other Formats to EPUB using online tools or the open-
source app Calibre. 

Build EPUBs from Scratch 

If you are comfortable with creating Web pages in a text editor and 
working with command-line tools, you can make EPUB files from 
scratch. To learn how to do this, I strongly recommend you read 
Elizabeth Castro’s book, “EPUB Straight to the Point,” which you can 
buy (in EPUB format, natch) directly from her Web site at 
http://www.elizabethcastro.com/epub/. 

Create EPUBs in Pages 
If you have the Mac version of Pages (http://www.apple.com/iwork/), 
it is by far the easiest way to create EPUBs, and if you don’t already 
own Pages, it’s only $19.99 in the Mac App Store, making it an 
inexpensive purchase. In fact, we’ve moved the entire Take Control 
publishing process from Microsoft Word to Pages to take advantage 
of Pages’ EPUB export capabilities. 

For the most part, Pages does a pretty good job at replicating the way 
your source files look in the EPUB version, although there are certain 
formatting features that Pages doesn’t export, mostly things like 
paragraph borders. 

To get started with making an EPUB in Pages, first download the 
“EPUB Best Practices” sample document, which is linked within 
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Apple’s helpful “Creating EPUB Files with Pages” support page at 
http://support.apple.com/kb/HT4168. 

EPUB or ePub?
 

You may notice that Apple has chosen to capitalize the format we’re 
talking about here as “ePub” rather than “EPUB.” The capitalization 
that the group in charge of the format—the IDPF—prefers is “EPUB,” 
but for reasons that have never been explained the IDPF’s logo for 
EPUB uses mixed case (Figure 6). 

Figure 6: The IDPF’s EPUB logo. 

Apple’s “EPUB Best Practices” document, while brief, is important 
because it contains the styles that the Pages EPUB exporter uses to 
build the EPUB table of contents. Most important among those styles 
are Chapter Name and Heading. They map, respectively, to the top 
two levels of the table of contents in the eventual EPUB file. You can 
change their style definitions in Pages all you want, but make sure you 
keep their names the same. 

Note: Be careful, since a new Pages document contains the default 
styles Heading 1 and Heading 2. Ignore those (they can’t be deleted), 
since they don’t map to anything in the eventual EPUB’s table of 
contents. 

The document also contains additional advice on how to format your 
document for a good EPUB export, most notably the all-important tip 
that graphics you want to appear in your EPUB must be placed inline, 
which you do by Command-dragging them into Pages, or by selecting 
them and clicking the Inline button in either the Formatting bar at the 
top of the window or in the Wrap view of the Inspector palette. 

Once you have the EPUB Best Practices document, you can either use 
it as a starting point by replacing its text and graphics with your own, 
or you can import its styles into an existing Pages document. To do the 
latter, make sure your document is open and frontmost, choose 
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Format > Import Styles, and select the EPUB Best Practices document 
in the Open dialog. Then select all the styles and bring them into your 
existing document. 

After you create your file, follow these steps to export an EPUB: 

1. With your file open, choose File > Export, and click the ePub 
button. 

2. Enter a title and, if desired, and author and genre (Figure 7). 

Figure 7: Enter the metadata in the Pages Export dialog. 

3. If you want the first page of your document be used as the cover 
of the EPUB—it will appear in the iBooks interface, for instance, 
but not in Bookle—select Use First Page as Book Cover Image. 
(Remember that if you want to use an image on your cover, it must 
be an inline graphic.) 
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4. Click Next to switch to a standard Save dialog where you can name 
your file and save it. It’s easiest to save the file to the Desktop and 
double-click it from there to copy it into Bookle’s library. 

Note: The Hide Extension checkbox in the EPUB Save dialog is 
selected by default. Although you can deselect it, a bug in Pages 4.1 
always causes it to save the file with the .epub filename extension 
hidden. If you want the extension to appear, you must select the file 
in the Finder, choose File > Get Info, and deselect the Hide Extension 
checkbox in the file’s Info window. 

Since Pages can open Word documents, your best bet for converting 
Word documents to EPUB may be to open them in Pages, rename 
Word’s Heading 1 style to Chapter Name and Heading 2 to Heading, 
and then export from within Pages. That’s roughly how we convert 
our older Take Control ebooks to Pages for updating and eventual 
EPUB export. 

Create EPUBs with Other Programs 
Although EPUB has been around for a while, not all that many 
programs can generate EPUB-formatted files. This is actually a 
little odd, given how EPUB is an open standard based on other well-
understood formats like HTML, CSS, and Zip. Nevertheless, there 
are a few programs that can generate EPUB. 

•	 InDesign: Adobe InDesign is the dominant player in the page 
layout and publishing market, so it shouldn’t be surprising that 
it can generate good EPUBs. If you’re already using InDesign, 
learning how to export an EPUB is mostly a matter of using the 
right styles and understanding EPUB’s limitations in comparison 
to InDesign’s page-layout capabilities. However, InDesign is a large, 
complex program, and I wouldn’t recommend it as your first step 
in making EPUBs, in part because it costs somewhere between $699 
and $2,599, depending on what other Adobe products you get with 
it. Learn more at http://www.adobe.com/products/indesign.html. 

Tip: If you’re going down the InDesign path, I recommend checking 
out Elizabeth Castro’s $10 ebook From InDesign CS5 to EPUB and 
Kindle. Read more about it at http://www.pigsgourdsandwikis.com/ 
2011/12/from-indesign-cs-55-to-epub-and-kindle.html. 
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•	 Scrivener: Scrivener, from Literature & Latte, is a $45 word 
processor aimed at providing writers with sophisticated tools for 
doing the real work of writing. When you finish all your writing 
in Scrivener, you compile your work into a complete manuscript 
to share with others in various ways. One compilation method is 
to create an EPUB. 

If you have Scrivener, or if Scrivener sounds like a program that 
you’d like to try, you can use it to make EPUBs. More details are 
available at http://www.literatureandlatte.com/scrivener.php. 

Tip: Take Control of Scrivener explains many of the organizing and 
writing features in Scrivener, and it touches on how to compile an 
EPUB. The Scrivener manual has even more about EPUB compilation. 

•	 Sigil: Sigil is an open-source, cross-platform editor designed to 
create and edit books in the EPUB format. It’s a WYSIWYG editor, 
which means you can format your text as you write and have those 
styles reflected in the EPUB. Also, unlike Pages, InDesign, and 
Scrivener, Sigil uses EPUB as its native format, which means that 
it’s easy to make changes without having to export a new file each 
time. 

On the downside, Sigil is a rather mediocre Mac application; 
it looks and works strangely, and in my limited testing, I’ve found 
it to be rather awkward. But it is free, and if you don’t have or want 
to use Pages, it’s probably your best bet for creating an EPUB from 
scratch. Download your copy at http://code.google.com/p/sigil/. 

Tip: Although it’s tempting to use Sigil to make small changes in 
existing EPUB files generated from other sources, be very careful 
when doing that, and keep your original files separate. Although 
I believe this bug has been fixed, an earlier version of Sigil 
automatically generated a new (and erroneous) table of contents 
from headings in edited documents, rather than simply using the 
table of contents that was already present. 

•	 eCub: eCub is more of an EPUB compiler than an editor like 
Sigil. You feed it existing text or HTML files, provide appropriate 
metadata, and it generates an EPUB. eCub also has a simple 
interface for designing a cover graphic. Like Sigil, eCub is a cross-
platform tool, which makes it a little harder to use than a real Mac 
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application. It’s free, and I would recommend it only to someone 
who has a collection of HTML files (perhaps from an old Web site 
that uses simple HTML) and wants to turn them into an EPUB. 
Download a copy of eCub at http://www.juliansmart.com/ecub. 

•	 Jutoh: Jutoh, created by the same people who made eCub, is 
another full-fledged EPUB editor along the lines of Sigil. It’s neither 
open-source nor free, but at $39 it’s not a major investment. Again, 
as a cross-platform application, Jutoh will seem a little awkward on 
the Mac, but from what I can tell, you could use it to create fairly 
full-featured EPUBs. It appears to be a bit more capable than Sigil, 
so if you get started using Sigil to create EPUBs from scratch and 
run into limitations, it may be worth trying Jutoh. Learn more 
about Jutoh and download a free demo at http://www.jutoh.com/. 

Create EPUBs with Automator 
If you’re using Mac OS X 10.7 Lion, there is a new Automator action— 
Text to EPUB File—and some associated services that can help you 
create EPUB files. Using Automator for EPUB creation is more 
complex than relying on Pages, but it may be better if you have a 
system that regularly creates files that you’d like to have end up in 
EPUB format. Plus, the Mac OS X services that you can download may 
be the fastest possible way to create a simple EPUB from selected files, 
selected text, or the contents of the Clipboard. 

To learn more about using the Text to EPUB File Automator action 
and download both it and the related services, go to the Mac OS X 
Automation site at http://www.macosxautomation.com/lion/epub/. 

Convert Other Formats to EPUB 
I almost hate to mention that it’s possible to convert from other 
formats to EPUB because the converters I’ve found do such a horrible 
job most of the time that it’s almost not worth the effort. That said, if 
you have a document in a format that one of the converters claims to 
support, and the document has a sufficiently simple layout, it’s worth 
seeing what will come out the other end. 
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The online converters I’ve had some level of success with (meaning, 
they actually gave me a file that Bookle was able to open, thoroughly 
malformed though it may have been) include: 

• Online-Convert.com 
http://ebook.online-convert.com/convert-to-epub 

• 2epub.com 
http://www.2epub.com/ 

Although these sites claim to support Word’s .doc files, you might get 
better results if you export to HTML from within Word and then feed 
the HTML file to a converter. 

There’s also Calibre (http://calibre-ebook.com/), which is a cross-
platform, open-source ebook management application that can 
convert between some ebook formats. Calibre is the antithesis of 
a Mac application—it’s huge (210 MB), ugly as sin (including menu 
items that are so long that Mac OS X has to truncate some of the text 
in the middle), and horribly confusing (you have to see it to believe it). 
Using Calibre makes my teeth hurt, but if you have a few days to play, 
you might be able to convince it to convert something for you in an 
acceptable fashion. 
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About This Book
 
Thank you for reading this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments at 
tc-comments@tidbits.com. 

Ebook Extras
 

You can access extras related to this ebook on the Web. Once you’re on 
the ebook’s Take Control Extras page, you can: 

•	 Find out about any available new version of the ebook. 

•	 Download various formats, including PDF, EPUB, and—usually— 
Mobipocket. (Learn about reading this ebook on handheld devices 
at http://www.takecontrolbooks.com/device-advice.) 

•	 Read postings to the ebook’s blog. These may include details of 
Bookle updates, new tips for using Bookle, or other useful 
information, as well as links to author interviews. 

•	 Add the ebook to your Take Control account (create one if 
necessary) to be notified by email of important updates to Bookle. 

About the Author
 

Adam C. Engst is the publisher of TidBITS, one of the oldest and 
most respected Internet-based newsletters, available on the Web at 
http://tidbits.com/ and distributed weekly by email and RSS to many 
thousands of readers. He has written numerous technical books, 
including the best-selling Internet Starter Kit series, and many 
magazine articles (thanks to Contributing Editor positions at MacUser, 
MacWEEK, and Macworld). 

Beyond TidBITS, Adam’s innovations include the creation of the first 
advertising program to support an Internet publication (in 1992), the 
first flat-rate accounts for graphical Internet access (in 1993, with 
Northwest Nexus for Internet Starter Kit for Macintosh), and the Take 
Control ebook series. 

28 

mailto:tc-comments@tidbits.com
mailto:tc-comments@tidbits.com
http://www.takecontrolbooks.com/checkforupdates?mw=mbooko&bt=0131&bv=1.0
http://www.takecontrolbooks.com/device-advice
http://www.takecontrolbooks.com/device-advice
http://tidbits.com/
http://tidbits.com/


       
         

            
          

           
       

          

        

 
              

            
        

            
           

          
      

 

 

         
          

           
         

            
           

Adam’s indefatigable support of the Macintosh community and 
commitment to helping individuals has resulted in numerous awards 
and recognition at the highest levels. In the annual MDJ Power 25 
survey of industry insiders from 2000 through 2006, he ranked in 
the top five most influential people in the Macintosh industry, and he 
was named one of MacDirectory’s top ten visionaries. And how many 
industry figures can boast of being turned into an action figure? 

For comments about this book, contact Adam at ace@tidbits.com. 
Please send bug reports to us at bookle-support@stairways.com. 

Author’s Acknowledgments 
I’m grateful to Peter Lewis, who was far more game to jump on this 
project than I had any right to expect. His programming skills and 
amiable disposition have made the entire experience truly enjoyable. 

Thanks are also due to Tonya, who makes far more possible than 
she realizes. That becomes especially obvious when I stray from my 
particular roles at Take Control into her domain of expertise with 
actually writing, editing, and formatting the ebooks. 

About the Publisher
 

Publishers Adam and Tonya Engst have been creating Apple-related 
content since they started the online newsletter TidBITS, in 1990. 
In TidBITS, you can find the latest Apple news, plus read reviews, 
opinions, and more (http://tidbits.com/). Adam and Tonya are known 
in the Apple world as writers, editors, and speakers. They are also 
parents to Tristan, who thinks ebooks about clipper ships and castles 
would be cool. 
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Special thanks to Apple for not releasing an EPUB reader for the Mac 
alongside iBooks 2 for the iPad and iBooks Author. That would have 
been a major bummer, coming as it did just as we were finishing up. 
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Copyright and Fine Print
 
Take Control of Bookle 

ISBN: 978-1-61542-400-9
 
Copyright © TidBITS Publishing Inc., 2012. All rights reserved.
 

TidBITS Publishing Inc.
 
50 Hickory Road
 

Ithaca, NY 14850 USA
 
http://www.takecontrolbooks.com/
 

Take Control electronic books help readers regain a measure of control in an oftentimes 
out-of-control universe. Take Control ebooks also streamline the publication process so 
that information about quickly changing technical topics can be published while it’s still 
relevant and accurate. 

This electronic book doesn’t use copy protection because copy protection makes life 
harder for everyone. So we ask a favor of our readers. If you want to share your copy of 
this ebook with a friend, please do so as you would a physical book, meaning that if your 
friend uses it regularly, he or she should buy a copy. Your support makes it possible for 
future Take Control ebooks to hit the Internet long before you’d find the same information 
in a printed book. Plus, if you buy the ebook, you’re entitled to any free updates that 
become available. 

Although the author and TidBITS Publishing Inc. have made a reasonable effort to ensure 
the accuracy of the information herein, they assume no responsibility for errors or 
omissions. The information in this ebook is distributed “As Is,” without warranty of any 
kind. Neither TidBITS Publishing Inc. nor the author shall be liable to any person or entity 
for any special, indirect, incidental, or consequential damages, including without 
limitation lost revenues or lost profits, that may result (or that are alleged to result) from 
the use of these materials. In other words, use this information at your own risk. 

Many of the designations used to distinguish products and services are claimed 
as trademarks or service marks. Any trademarks, service marks, product names, or named 
features that appear in this title are assumed to be the property of their respective owners. 
All product names and services are used in an editorial fashion only, with no intention of 
infringement of the trademark. No such use, or the use of any trade name, is meant to 
convey endorsement or other affiliation with this title. 

This title is an independent publication and has not been authorized, sponsored, 
or otherwise approved by Apple Inc. Because of the nature of this title, it uses terms that 
are trademarks or that are the registered trademarks of Apple Inc.; to view a complete list 
of the trademarks and of the registered trademarks of Apple Inc., you can visit http:// 
www.apple.com/legal/trademark/appletmlist.html. 
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Featured Titles
 
Click any book title below or visit our Web catalog to add more 
ebooks to your Take Control collection! 

Take Control of iCloud (Joe Kissell): Understand the many features, 
get set up properly, and enjoy iCloud! 

Take Control of iTunes 10: The FAQ (Kirk McElhearn): This FAQ-style 
ebook helps you wrap iTunes around your little finger and enjoy your 
media more. 

Take Control of Making Music with GarageBand ’11 (Jeff Tolbert): 
Combine your creativity with GarageBand’s editing and mixing 
techniques to compose tunes that please the ear! 

Take Control of PDFpen 5 (Michael E. Cohen): Learn to create, edit, 
and manipulate PDFs with Smile’s PDFpen 5! 

Take Control of Scrivener 2 (Kirk McElhearn): Write your screenplay, 
novel, or dissertation with the author-focussed features in Scrivener! 

Take Control of Safari 5 (Sharon Zardetto): Make the most of Apple's 
Safari, a Mac Web browser with many hidden and under-appreciated 
talents! 

Take Control of Spotlight for Finding Anything on Your Mac (Sharon 
Zardetto): Whether by mouse or menu, or by typing a complex query, 
you’ll learn how to find your files, contacts, images, and much more. 

Take Control of Using Lion (Matt Neuburg): Learn to use 10.7 Lion 
effectively, whether you embrace all of Lion’s new features or strike a 
balance between old and new. 

Take Control of Your iPad (Tonya Engst): Optimize your iPad 
experience—make important customizations, sync media and data, and 
get tips on making the most of core iPad apps. 

Take Control of Your Paperless Office (Joe Kissell): With your Mac, 
scanner, and this ebook in hand, you’ll finally clear the chaos of an 
office overflowing with paper. 
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