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Copyright Notice

Warranty

No part of this manual may be reproduced or transmitted in any form or by any
means, electronic or mechanical, including photocopying and recording, for any
purpose without the express written permission of Qdea.

Copyright © 2001 Qdea. All rights reserved.

Manual version 3.6.
Eighth edition.

If this software is delivered on disk, Qdea warrants that the disk on which this
software is received is free from defects in material and workmanship, under
normal use, for 90 days after the date of original purchase. If a defect occurs
during the 90-day period, you may return the disk to Qdea for a free
replacement.

The remedy for breach of this warranty shall be limited to replacement and shall
not encompass any other damages, including but not limited to loss of profit, and
special, incidental, or other claims.

This software is licensed and delivered on an “as is” basis. Except for the express
warranty set forth above, Qdea makes no other warranties, either express or
implied, by statute or otherwise, regarding the enclosed computer software
product, or its fitness for any particular purpose.

Software License

Each copy of Synchronize! is licensed for installation on one computer. A single
copy of Synchronize may be installed on a second computer for the purposes of
synchronizing the information between the two computers, with the restriction
that the software may not be in use on both computers at the same time.
Installing Synchronize! on more than one computer at the same location requires
the purchase of one copy of Synchronize! for each installation.
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Introduction

Synchronize! solves the problem of changing your documents on more than one
computer.

You’re familiar with the problem: you have a Mac at work and a PowerBook or a
Mac at home, and you have some changes that you need to make in a few of your
documents. So you copy them onto your PowerBook or a removable disk, take
them with you, and change them. When you’re done with the changes, you
replace the older documents on your Mac at work with the newer ones.

No problem. But then the day comes when you’d like to make a few changes, but
you don’t have the most recent version of your document with you.

Or you make changes, accidentally, to an older version of a document, and lose
other important changes you made before.

Wouldn’t it be nice if you always had the most recent versions of your
documents with you, so you could make changes without worrying about
whether you had the right version?

Wouldn't it be nice if any changed documents ended up back on your hard disk
at work, automatically, so that you could start your day without searching for
any documents which you changed on another Mac?

Synchronize! does these things for you, and more. Its purpose is to automate the
process of keeping the most recent version of any number of documents on
multiple Macs that you use, so that you don’t have to worry about it.

Synchronize! will keep two folders on different Macs synchronized, and always
copy the newest document in a folder to the corresponding folder on a
PowerBook, another Mac, or on a removable disk you take with you. These two
folders can be called “clones”.

Since a clone is an identical copy, Synchronize! keeps the folder on your hard
disk and the folder on your removable disk identical. Synchronize! always keeps
cloned folders identical by copying the most recent version of a document to the
other folder.

Using Synchronize! with disks on the desktop

Synchronize! works with any disk that appears on your desktop, whether it is a
hard disk, removable disk, a PowerBook in “SCSI Disk Mode”, an AppleShare
file server or a Mac with File Sharing, using a LocalTalk or EtherTalk network
connection, or a remote connection such as AppleTalk Remote Access.

If the disk appears on your desktop, synchronizing your files between any two

folders is easy. Once you set it up, Synchronize! will copy any newer files
between two folders on any disk, automatically.
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Synchronizing remotely via removable disks

In this scenario, you synchronize a folder on your hard disk at work and a folder
on a removable disk. Synchronize! copies only the documents which are newer
from the hard disk to the removable disk, so it takes less time.

When you arrive at your Mac at home, and want to work on some of your
documents, use Synchronize! again to copy any newer documents from your
removable disk to your hard disk.

All you have to do to keep the newest versions of your documents on both Macs
is to use Synchronize! when you leave one Mac, and when you arrive at the other
Mac.

Nested folders

Synchronize! will synchronize files contained in any number of folders nested
within the top-level folder. This makes keeping track of your documents easier,
because each folder can contain work you’re doing for a particular purpose.
Synchronize! will search each nested folder for documents which are newer than
documents in the corresponding folder on your removable disk, and copy only
the newer documents to the other folder.

If you want to add another folder for documents in a new category, just create
the folder. A corresponding folder will be automatically created on the other
disk.

Of course, there are other uses for Synchronize!. Please see the chapter “Six Ways
To Use Synchronize!” for more ideas.
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Getting Started

Installation

Installing Synchronize! is as simple as copying the folder containing the
application from the disk it comes on to the disk you want to use it from. The
instructions below explain how to do this.

Copying Synchronize! to your startup disk

Installation requires only that you copy the Synchronize! Folder from your
master floppy disk to your startup disk. No restart is required.

1. Insert the Synchronize! Disk.
2. Drag the folder named “Synchronize! Folder” to your startup disk.
This folder may be placed anywhere on your disk.

That’s all there is to installation. For information on how to set up to use
Synchronize!, please see the following tutorial.

A file called “Synchronize! Guide” is included in the folder you copy to your
hard disk. This file contains information for Apple Guide, an interactive help
system from Apple. This file is not required for Synchronize! to operate properly,
and can be deleted if you wish. If you are not using System 7.5 or later, it cannot
be used, and you may want to remove it from your hard disk.

Try an example
To see Synchronize! in action, try the example on your master Synchronize! Disk:

Insert the Synchronize! Disk.

Open the folder named “Synchronize! Example”.

Double-click the settings document* named “Try Me”.

Click the Sync... button. Synchronize! shows the documents which
will be copied.

5. Click the Start button in the dialog box. Synchronize! copies the
documents from one folder to the other.

Eal A o

* Just like a word processor or a spreadsheet, Synchronize! uses the
contents of its settings documents to tell it what to do. In the case of
Synchronize!, its documents tell it what folders to synchronize, and what
options have been set.

If you try the example more than once, Synchronize! reports that “The two
folders are the same.”. This is because Synchronize! has copied all files which are
different to the other folder, making the folders identical. Because Synchronize!
copies files only when they are different, it has no more files to copy.
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Tutorial

For those who want to go through the steps for using Synchronize!, the following
tutorial covers the steps needed to set up a document which tells Synchronize! to
keep a folder on your hard disk identical to a folder on a floppy disk,
PowerBook, or file server.

Just like a word processor or a spreadsheet, Synchronize! uses the contents of its
documents to tell it what to do. In the case of Synchronize!, its settings
documents contain settings for what folders to synchronize and what options
have been set.

Make sure your Mac knows what time it is

Make sure that the clock on your Mac is set correctly!

It’s critical to Synchronize!’s proper operation that the time on your Mac is set
correctly, since it is used to stamp the time your files are changed. Use the “Date
& Time” Control Panel to check the time of your Mac’s clock. The time does not
need to be accurate to the second, but it should be accurate within five minutes.

Running the application

Double-click the Synchronize! application icon to run the application. The icon
looks like one of these:

[
I:'l-__l‘l Synchronize! |;_—1|

Synchronize!
Synchronize! application icons

Setting up a document

If you have started Synchronize! for the first time, you will see a window titled
“Untitled 1”. This represents a new Synchronize! settings document.

Synchronize! settings documents describe two folders which are to be kept as
“clones” of each other. A clone is an exact duplicate, so two folders which are
clones contain the same documents and the same folders, arranged in the same
way.
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[ Show files to copy

[] Re-open at startup

New settings document window

For the purposes of this tutorial, we will assume that you have a folder on your
hard disk which contains the documents you are currently working on, and
would like to have on your other Mac.

Click on the left-hand folder icon. Use the dialog box to choose one of the folders
to be synchronized. Note that the name of the folder and its disk is displayed
below the folder. In a similar way, click on the right-hand folder to choose the
other folder to be synchronized.

Once both folders have been chosen, you are ready to synchronize them.

Starting a synchronization
Every time you click the “Sync...” button in a settings document, Synchronize!
checks the contents of the two folders shown in the document. When it

encounters a file which is newer than the corresponding file, or which doesn’t
have a corresponding file, it marks the newer document to be copied to the other

folder.

To start checking, click the “Sync...” button. The cursor rotates until
Synchronize! shows a list of the files and folders which need to be copied or
created.
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This is an example of such a list:

Files To Copy

‘= Working Documents
on Synchronize! Disk

‘= Travelling Documents
on Synchronizel Disk

= [ Warking Documents <:> [ Travelling Documents Q
= {71 Expenses { [ Expenses
% Trip Expenses & [ Trip Expenses
~ [ Personal E:} i Persanal
[ Letter to Mom o % Letter to Mom
= [ Projects o rojects
0 rassive Project E:) *t Maszive Project
~  [3Proposals Oy [ Proposals
O My Proposal W % My Proposal ]
3 files (6 K) tocopy 1file £2 KJ tocopy

( wemove tromiist | [ cancel | [ start ||

List of files to be copied

Check the list over, if you wish. Files and folders to be copied may be removed
from the list. When the files and folders to be copied are OK, click the Start
button.

Synchronize! begins to copy the files and folders in its list. The Status window
shows the copying progress, and how much time is left to complete.

Notice that Synchronize! does its copying “in the background”, which means
that you are free to use your computer for other things while copying is
underway.

Hints on using Synchronize!

Since you will probably be using Synchronize! to keep your working documents
with you, it’s a good idea to set up a system.

We recommend keeping Synchronize! and its documents in a separate folder.
This way, it’s easier to find the documents you’ve created.

When you’re ready to run Synchronize!, just open the folder and double-click the
Synchronize! icon.

It’s easiest to set your documents to reopen at startup, so they will be opened

automatically. When you want to synchronize your files, just run Synchronize!,
then start the synchronization for each document.
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Saving the document

Once you’ve set up your document, it’s important to save it so that you can use it
again. To save your document:

1. Choose “Save As...” from the File menu.

2. Name your document, for example, “Working Documents Sync”.
3. Click the Save button.

To use Synchronize! effectively, create a Synchronize! document for each
Macintosh on which you intend to keep working files. Keep the document on the
hard disk of your computer. Open and Start the document on each Macintosh
before you make changes to your working files, and after you’'re done.
Synchronize! keeps the folders on both disks current with the newest versions of
your documents, automatically.

For tips on how to automate your use of Synchronize! even more, see the chapter
“Tips and Techniques.”
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Using Synchronize!

The problem

The solution

This chapter discusses how Synchronize! works. It describes one way
Synchronize! can work for you.

The primary purpose of Synchronize! is to keep the most recent versions of your
documents on more than one disk.

This is best illustrated by two documents, A and B. For the purposes of this
example, Document A is on your Mac at work, and Document B is on your Mac
at home.

Document A is initially the same as Document B. While at wok, you make some
changes to Document A. At home, an inspiration hits you, and you make some
changes to Document B.

You put Document B on a floppy disk, intending to update your Mac at work.
But wait! If you copy Document B onto your hard disk at work, the changes you
made to Document A will be lost!

Naturally, if you only worked with one document, you’d remember where you
made the last change. But it you hadn’t changed it in a while, it might be hard to
remember which location has the most current version of a document.

Wouldn't it be nice if there were a way to automatically keep both locations’
documents up-to-date, so that any changes are always made to the most recent
version?

That’s what Synchronize! does for you, automatically.

Using Synchronize! with removable disks

To let Synchronize! solve this problem for you, create a folder on your Mac at
work. Call it “Working Documents”. This folder contains your working
documents, which are those documents you’re changing regularly.

Arrange the organization of your files so that your “Working Documents” folder
contains the files you’re working on. The contents of this folder should be
smaller than the size of your removable disk.

It's OK to create as many folders within your “Working Documents” folder as
you need to keep a manageable arrangement. You might have, for example, a
different folder for each project you work on.

Take out a new removable disk and label it “Travelling Disk”. This is the disk
that you will use to carry your updated files to your other Mac.
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Important!

Create a folder on your removable disk. Give it a name like “Travelling
Documents”, which shows that it contains the files that travel from one Mac to
the other.

Set up a Synchronize! document which identifies the folder on your hard disk
and your “Travelling Disk” as “clones*”, or folders which are to be made
identical.

Check the “Reopen at startup” box in the document. Save it on your hard disk.

* In biology, a clone is an exact biological duplicate. Two people who are
clones have the same fingerprint. The idea here is that Synchronize! will
always keep these two folders identical, so that when you make a change
to a file in one folder, the newer file will replace the file in the
corresponding folder.

At home, create a similar “Working Documents” folder on your hard disk.
Create a Synchronize! document which identifies the “Working Documents”
folder on your Mac at home, and the “Travelling Documents” folder on your
removable disk. Check the “Reopen at startup” box in the document, and save it
on your hard disk at home.

Make sure that the clocks on all Macs on which you use Synchronize! are set accurately!

It’s critical to Synchronize!’s proper operation that the time of the clock on your
Mac is set correctly, since it is used to stamp the time your files are changed. Use
the “General” Control Panel to check the time of your Mac’s clock. The time does
not need to be accurate to the second, since you won’t be changing files on more
than one Mac at a time, but it should be accurate within five minutes.

Your setup is complete. Now you’re reading to put Synchronize! to work.

Putting Synchronize! to work

Since Synchronize! compares the files in your “Working Documents” folder with
the files in your “Travelling Documents” folder and copies the newest file to the
other folder, run Synchronize! whenever you make changes to any of your
working documents.

It’s often easiest to run Synchronize! every day just before you go home, as a
routine part of leaving for the day, so that any documents you may have
changed during the day are copied to your “Travelling Disk”.

When you’re ready to use your Mac at home, run Synchronize! before you start
working. Any documents which have been changed at work are on your
“Travelling Disk”; Synchronize! copies them to your "Working Documents"”
folder on your hard disk at home.

When you’re finished making changes at home, run Synchronize! again before
you shut down your Mac, and run Synchronize! at work when you arrive.
Synchronize! copies any documents you changed at home to your “Travelling
Disk” and then to your Mac at work.
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You’ve completed the cycle, always taking your working documents with you.
You didn’t have to compare the dates of your documents and drag the newest
ones to your removable disk, or copy an entire folder from your Mac to the disk.

Synchronize! copies the files for you, and since it copies only the newest ones,
you spend as little time as possible keeping your files with you!

An added benefit of using Synchronize! is that you also always have a backup of
your most recently changes files, which are the ones least likely to be backed up!

Using Synchronize! with a direct connection

If you have a way of connecting your Macs together so that the disks of both
Macs appear on your desktop, you can use Synchronize! without a removable
disk. There are several ways to do this, including using File Sharing and
AppleTalk or AppleTalk Remote Access, or using “SCSI Disk Mode” for a direct
connection to the hard disk in some PowerBooks.

In this case, you need only one Synchronize! document. Choose a folder on each
Mac in the document, and save it. Whenever you make changes to your
documents, connect your Macs together and use Synchronize! to synchronize
your files.

If you use File Sharing and/or AppleTalk Remote Access, Synchronize! can make
the connection to your remote Mac automatically. Please see the description of
the “Auto-Connect” option in the “Synchronize! Reference” chapter.

How Synchronize! works
Synchronize! works by looking through the two folders identified in a
Synchronize! settings document, creating pairs of files and folders which
correspond to each other.

This is a diagram of corresponding folders:

Corresponding
K Folders \

working Documents Traveling Documents
| |
I I 1 I I 1
Projects Proposals Personal Projects Proposals Personal

N N

Corresponding
Folders

Corresponding folders

Each folder pair has the same name, except for the top-level folders, without
regard to capitalization. Each pair is also nested within the same folders on both
sides; for example, the two “Projects” folders correspond, but neither of them
could correspond with a “Projects” folder within the “Personal” folder.
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The files in each folder pair are compared by name, without regard to
capitalization, to find file pairs. Each file pair is compared to determine if they
are the same; if they were last changed at exactly the same time (to the second),
they are considered to be identical.

If they are not the same, Synchronize! copies the newer file to replace the older
file.

Advanced Features

Synchronize! has a number of advanced features that make it more useful. These
features appear under the Options menu.

For example, it is possible to set up synchronization to occur when disks are
inserted, when a settings document is opened, at startup, shut down, or
periodically at a particular time of day.

It is possible to connect to a file server or another Mac via an AppleTalk network
connection, or via AppleTalk Remote Access, automatically supplying the
password even if you aren’t present.

Synchronize! can recognize when you make changes to two different versions of
a document, warn you, and take appropriate action.

Finally, it’s possible for Synchronize! to automatically unmount or eject the disk
and disconnect AppleTalk Remote Access, completely automating file
synchronization. If your Mac has the capability, Synchronize! can shut down
your Mac when it’s done.

With these features, you can automatically synchronize in the middle of the night
when you aren’t using your Mac, and when telephone rates are at their lowest.

Or you can synchronize your files at the end of the day by inserting your backup
floppy or removable disk, making a backup of the day’s work while you go
home.

For more information on these features, please see the description of the Options
menu in the “Synchronize! Reference” chapter.
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Six Ways To Use Synchronize!

1. Keep folders on two Macs the same.

This is the primary use for Synchronize!. If you’d like more information on how
to set up Synchronize! for this use, see the Getting Started chapter in this manual.

Remember that more than one folder can be synchronized by using a
Synchronize! document for each folder, or by using aliases to other folders. When
using removable disks for large numbers of files, more than one removable disk
can be used, as long as each removable disk can contain the contents of the folder
it is synchronized with.

2. Back up your hard disk to a server.

Synchronize! will make a backup of all or part of your hard disk to an
AppleShare server, or a Mac running File Sharing.

To make an exact backup, choose your hard disk as one of the “folders” to be
synchronized. Check the “Master” box for your hard disk. Check the “Delete files
and folders not in the master folder” and “Make folder views the same” boxes
also.

Set the Start Options in the settings document to “Start copying when opened”,
and “When complete, Shut Down”. When you’re ready to go home, open the
backup document. Many Macs will automatically shut off when the backup is
complete!

As an alternative, use the Start Options to set up an automatic backup daily, at a
particular time. Run Synchronize! in the background so that it starts the backup
at the appropriate time.

3. Distribute files to one or more remote Macs or file servers with AppleTalk Remote
Access.

This makes document distribution to other sites easy - just start the
synchronization, and the remote disk will be mounted automatically!

Since Synchronize! copies only the information which has changed, your Remote
Access connection need not be in use any longer than necessary, saving you
money in telephone bills.

Synchronize! will keep the files and the folder organization at the remote
locations identical to your master site if you: a) check the “Master” box for the
folder at the master site and b) check the “Delete files and folders not in the
master folder” box.

Use “Auto-Connect” in the Options menu to enter the passwords for AppleTalk

Remote Access and the file server, so that the connection can be made
automatically, when you are not present.
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Check “Unmount disk when complete” and “Disconnect AppleTalk Remote
Access” in the Completion Options to automatically disconnect when
synchronization is complete.

Finally, to completely automate the activity, set a start time and how often the
synchronization should take place in the Start Options. Leave Synchronize!
running in the background so that the file distribution will be done
automatically, without further intervention.

4. Increase the information you store on a removable disk by copying files compressed
by AutoDoubler in their compressed form.

Normally, copying files to a removable disk when AutoDoubler is active causes
those files to be decompressed before they are copied.

Set the AutoDoubler option to “Don’t expand compressed files.” This tells
Synchronize! to leave any compressed files it copies in their compressed form.
Files which are not compressed are not affected. This option can increase your
removable disk utilization by as much as 100%.

5. Keep documents on a hard disk for speed and convenience, and use Synchronize! to
keep a current copy on an AppleShare server, for others to use.

Synchronize! will copy a folder containing files which you make available to
others on a server, while allowing you to keep a master copy on your hard disk,
where you can access them more quickly.

When you want to make new versions available to others, use Synchronize! to
copy the changed files to the server.

6. Keep a backup copy of your important files on a removable disk, such as a Zip, Jaz,
Syquest or magneto-optical disk.

Synchronize! will make a backup of your important files to a removable disk in
the minimum time necessary, since it copies only those files which have changed.
Set the Synchronize! document to backup your hard disk and the removable
disk, and set the folder which represents your hard disk to be the Master folder.
Check the “Delete files and folders not in the master folder” box. With these
settings, Synchronize! makes the removable disk an identical copy of the hard
disk.

In its simplest form, this method requires that your removable disk contain no
more information than your hard disk. If your hard disk is bigger, try using the
“Don’t copy folders...” option to exclude certain folders, such as the System
Folder, or a folder containing your applications, from the backup.

7.  Mirror afile server.

Synchronize! will mirror the contents of one file server to another over a
network, making it possible to keep a “hot” copy of mission-critical information
available on your network. If your primary file server fails, the secondary server
is immediately available, with information which is as current as the last
synchronization.
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If you need to mirror user and group privileges to the secondary server, consider
Synchronize! Pro. Among other things, it adds keeping folder privileges up to
date to the many other advanced features in Synchronize!.
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Tips and Techniques

This chapter describes ways to get more out of Synchronize!, and how to simplify
its day-to-day use.

Using Synchronize! automatically

Once you’re familiar with the operation of Synchronize!, you’ll probably want to
use it with a minimum of fuss. The following tips automate the use of
Synchronize! and its documents, so that it’s a simple part of your normal routine.

= Put an alias to Synchronize! in your Apple Menu Items folder. Then when
you want to synchronize your files, just choose Synchronize! from the Apple
menu.

e Check the “Reopen at startup” box. When this box is checked, your
document will be automatically opened when Synchronize! is opened, and
you won'’t have to find and open the document manually.

< Don’t check the “Show files to copy” box . This eliminates the dialog box
which appears to tell you what files and/or folders will be copied.

= Use the “Auto-Connect” feature. If you use AppleTalk Remote Access, or
you synchronize with AppleShare or File Sharing, use the “Auto-Connect”
option to enter your passwords so that a connection can be made without
having to re-enter them.

e Turn off the verify option for hard disks and file servers. If your
synchronization is between two hard disks or a hard disk and a file server,
you can turn off Verify in the Options menu. This will speed up your file
transfers by eliminating a re-read of all the data written to the disk.

We recommend that you leave Verify on for synchronization involving a
removable disk, because errors occur more frequently with these disks.

Synchronizing with removable disks
If you carry files between two Macs on removable disks, or floppy disks, it’s

more convenient to synchronize automatically when you insert your removable
disks.

AutoSync, a small background application, can automatically start a
synchronization when you insert your removable disks.

= Use the Options menu to choose Start Options. Check the “When disks
become available” box to start synchronization when you insert your
removable disk. Click OK.

Synchronize! asks you if you would like a startup application installed which
will automatically open Synchronize! at the appropriate times. Click Yes.
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Synchronize installs AutoSync in your Startup Items folder under System 7,
and in the same folder as Synchronize! under System 6.

< Choose the “When copying is complete, Quit” option in the Start Options.
Then set Synchronize! to run in the background.

< You may want to check one or both of the “Start copying at Startup” and the
“Start copying before Quit or Shut Down” boxes. This causes the document
to be automatically started when you turn on your computer, and when you
shut it down. If the removable disk that you use to carry your work with you
isn’t inserted into your Mac, Synchronize! will ask for the appropriate disk.

= Be sure to save your synchronization setup (it doesn’t matter where).
With these options set, Synchronize! will automatically synchronize your files

when you insert your removable disk. All you have to remember to do is to take
the removabledisk with you!
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Synchronize! Reference

This chapter describes each of the features of Synchronize! and how to use them.

You may find it most helpful to read a portion of this chapter when you have a
particular question, rather than read it all at once.

Synchronize! Windows

Document Windows

Synchronize! document windows describe two folders which will be made
identical, or clones of each other. You choose the folders which will be clones in a
document window. A document window looks like this:

El

Working Docs Sync

‘Working Documents Travelling Docurments

on Power Book an Travelling Floppy
[ Master [ Master

[ eiete f#es and Toldars anlin Ihe master Taldey
[ mmks fniger sipus the snme

[ Show files to copy

[] Re-open at startup

Documentwindow

Synchronize! document windows represent the contents of a settings document.
Each settings document contains all the information on a single synchronization

setup. The document
settings.

Choosing Folders

window and the Options menu make it easy to change the

To change the folder to be cloned, click on the folder icon. Use the dialog box to

choose the folder:

Choose a folder:

[0 Folder Outside — PowerBook

[ HyperCard

[0 LDEF test £ v

O PageMaker

0 PowerBook

[ System Folder —_—

[ Temporary ltems

[0 Test Folder

[ THINK 4.0

[ Tools [ ]

I Working Documents
[ Select “PowerBook™ ]

""Choose a folder" dialog box
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Use this dialog the same way you open a document. To choose a folder in the list,
click the name of the folder and click the Choose button. To choose the folder
whose contents are displayed, click the button below the list.

To create a new folder, click the New Folder button.
Master check box

When the box titled Master is checked, the folder above it is considered a Master
folder. No files in that folder will be replaced, even by newer files. Any file in the
Master folder which is different from a corresponding file in the other folder,
whether newer or older, will replace the file in the other folder.

This feature makes Synchronize! copy files in one direction only. This is useful
when you use Synchronize! to create a backup of your work.

When neither Master box is checked, only newer files will replace older files;
older files will not replace newer files.

Copy Direction Arrow

The arrow between the two folders in a document indicates which direction files
and folders will be copied or moved.

When the arrow points in both directions, files will be copied in both directions.
The file which is replaced will always be the older or nonexistent file. This is the
normal setting for file synchronization.

When the arrow points in one direction, files will be copied only in the direction
of the arrow.

The Master check box below a folder identifies the folder as containing files
which are considered “master files”, regardless of age. When a Master box is
checked, files will be copied in the direction of the arrow only, replacing corresponding
files which are newer or older.

When “Move files” from the Options menu is checked, the word “mMOvE” will
appear below the arrow. This indicates that the files will be moved to the
destination folder, not duplicated.
An alternate way of setting the direction of the arrow is to click on the arrow.
Each time you click, the folder which is the Master will change, and the arrow
will change as well.

Delete files and folders not in the master folder
Check this box to delete any file or folder which is not in the Master folder.
The effect of checking this box is equivalent using the Master folder to replace
the other folder. Synchronize! does this as efficiently as possible, however, by

replacing only the files which are different.

Use this option to create a backup of a folder on your hard disk.
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This option is active only when one of the Master boxes is checked, and “Move
files” in the Options menu is not checked.

Make folder views the same

Check this box to copy the arrangement of the folders and files in the Master
folder to the other folder. File and folder labels and locations are copied from the
Master folder to the other folder.

Note that the Finder sometimes remembers information about files and folders in
windows it has open, so when using this option, it's best to have any windows
for the synchronized folders closed in the Finder. If they are not closed, the
Finder may override the changes Synchronize! makes.

This option is active only when the Copy Direction Arrow points in a single
direction.

Show files to copy

When “Show files to copy” is checked, Synchronize! shows you what files will be
copied. When it is not checked, Synchronize! starts copying without requiring
you to dismiss a dialog box.

Reopen at startup

To cause your synchronization settings document to be reopened every time
Synchronize! is opened, check this box.

Synchronize! saves information on whether a document is to be reopened at
startup only when the document is saved. This means that if you checked the box
and did not save the document, the document will not be reopened the next time
you open Synchronize!.

The first time you run Synchronize! on a different Macintosh, you will have to
manually open any documents which have “Reopen at startup” checked, so that
Synchronize! knows where they are.

Sync... button

The Sync... button initiates the synchronization of the two folders shown in the
window. If the “Show files to copy” box is checked, a dialog shows the files and
folders which will be copied or deleted. If the box is not checked, copying starts
immediately.

When you click the Sync button of a document window, and “Show files to

copy” is checked, Synchronize! shows what files and folders need to be copied
and deleted in a dialog box like this:
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Files To Copy

‘=l Working Documents ‘=l Travelling Documents
an Main Mac an PowerBook
=~ [0 working Documents E:}DTravelling Documents Q
(@) ~ [ Personal L» I Personal
® O Letter to Marn [y I Letter to Mo
@ =~ ETempuraru Stuff
® B Proposal (DRAFT)
~ [OTrips L» [Trips
@ [ Flight Canfirmation E:/ [ Flight Canfirmation
=]
[ Flight Confirmatian 15 hours | [ Flight Confirmation
4K 34 minutes | 4

Modified 10/25/93 9:47 AW |13 seconds| Modified 10/24/93 2:53 PM

[iémm;is@? frivny iés:%] [ Cancel ] | Start I

Files to copy dialog box

This dialog shows what actions Synchronize! must take, in what order, to make
the folders identical. Files and folders may need to be copied or deleted,
depending upon the option settings.

To see how many files are to be copied in a particular folder, click on that folder.
To open or close the folder and all folders below it, click on the triangle to the left
of the folder.

Icons are used to show the different actions to be taken during the
synchronization. The descriptions which follow refer to the actions in the “Files
to copy” dialog illustration above.

1. The folder “Personal” will be created in its appropriate place within the
folder “Travelling Documents”.

2. The file “Letter to Mom” will be copied to the folder named “Personal”.
3. The folder “Temporary Stuff” will be deleted.
4. The file “Proposal (DRAFT)” will be deleted.

5. The file “Flight Confirmation” will be copied to the folder named
“Trips”.

Note that when a file is selected, the modification dates for the file and its
corresponding file, if one exists, will be shown below, as well as the
difference in time between the modification of the two files.

“Trash Can’” button

The “Trash Can” button causes any selected files to be marked for deletion. Once
the synchronization is started, the files will be deleted with no further warning.

The effect of this button can be reversed by double-clicking the same files, or by
removing them from the list.
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Remove from list

The “Remove from list” button removes any selected actions from the list. Use
“Remove from list” to manually tell Synchronize! not to copy, move, or delete a
particular file or folder.

Sometimes removing an action from the list requires that other actions also must
be removed. For example, removing a folder to be created from the list requires
that any files to be copied into that folder must also be removed. When such
situations arise, Synchronize! will warn you and ask whether you want to
remove all affected items.

Reversing copying direction

Sometimes you may discover that a file which is to be copied should not replace
an older version of the file. To reverse the direction the file will be copied,
double-click the file.

When an older file will replace a newer file, the arrow will be shown in gray.

To reverse the direction again, double-click the file again.

Cancel

The Cancel button cancels the actions shown in the dialog. When you click
Cancel, no files or folders are copied or deleted.

Start

The Start button initiates the copying actions shown. If no other copying is in
progress, copying will start immediately*. If other copying is in progress, the
synchronization will be placed in the Waiting List until the other copying is
complete.

* Remember that the speed at which copying proceeds depends on the
Copying Speed setting in the Preferences — setting the copying speed to 1
and checking the “Don't copy when the mouse is moving” box will make
copying proceed very slowly, and not at all until your Mac is idle.

Status Window
The Status window shows the status of the most recent copy operation. When

copying is active, the Status window shows how far the copying has proceeded
toward completion. This is what the Status window looks like:
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S[IE=———— Status

Synchronizing Working Documents => Travelling

Copying Proposal 16 K bytes

I |
Complete Rermaining Total
Filez u] E) S
Size 16 K 41 K STE
Tirne 000002 000003 000007

T Pause

Status Window
Stop
The Stop button stops copying. Normally, when copying is stopped, a file which
has been partly copied will not be affected. However, if there is very little free
space on the disk, a partially-copied file may be deleted from its destination
without being replaced. Any deleted file is always the file to be replaced.

Pressing the command and period keys at the same time when the Status
window is active has the same effect as clicking the Stop button.

Continue

The Continue button resumes copying which has been paused. Pausing has no
detrimental effect on the completion of the synchronization.

Pause

The Pause button temporarily suspends copying. Use the Pause button when you
want access to your Mac without the background activity of copying.

Pause is useful when you’ve thought of one small thing you wanted to do before
you leave.

Wiaiting List Window

The Waiting List window shows a list of all documents whose synchronization
will be started. This is what the Waiting List window looks like:
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Help Window
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Waiting List Window

Use the Waiting List window to monitor multiple synchronizations which are
waiting to be completed.

Remove from list

Use the “Remove from list” button to cancel a waiting synchronization
operation. Select the operation to be cancelled before clicking the button.

Up and Down Buttons

Use the Up and Down buttons to change the order of the list. The first item (the
one at the top) will always be the next one to start.

The Waiting List is useful for starting several synchronizations when it will take
some time for them to complete. If the “Show files to copy” box is not checked

for these synchronizations, they will proceed as soon as the current
synchronization is complete.

The Log window shows the contents of the log. The date, time, and results of
each synchronization is normally stored in the log.

Position the Log window conveniently; its position will be remembered.
To select portions of the text in the Log window, click on the text and drag. The
selected lines are highlighted. Choose Copy from the Edit menu to copy selected

lines.

When Macintosh Drag and Drop is installed, selected text in the Log can be
dragged directly to another application.

Use Log Preferences in the Edit menu to affect the way the log is displayed.

The Help window shows information on many Synchronize! topics.

For information on how to use the Help window, please see the section on the
Help menu.
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Synchronize! Menus

This section describes the menus in Synchronize! and how to use them.

File Menu

Use the File menu to create and save Synchronize! documents.

New
Use New to create a new settings document. A Synchronize! settings document
contains the information describing two folders to be synchronized.

Open
Use Open to open an existing settings document. When a settings document is
opened, a window appears to show the contents of the document.

Close
Use Close to close the active window. Windows generally show the contents of a
settings document. Status, Waiting List, and Log are windows which are always
present, although they are not always visible. Closing a window dismisses it and
makes it disappear.

Save
Use Save to store the contents of a window in its settings document.
Synchronize! settings documents contain all the settings for synchronizing two
folders.
Use Save As... to store the contents of a window in a different document which
you name.

Revert
Use Revert to discard any changes you have made to a document since you last
saved it. Revert is useful when you try some different settings and decide that
you liked it better the way it was.

StartAll...

Use Start All... to start several synchronizations at once. Start All... works just
like clicking the Start button on each document, one at a time.

When you choose Start All..., a dialog shows all open Synchronize! documents in
a list. The “Start copying without showing files to copy” check box causes each
document which is started to behave as if its “Show files to copy” box is
unchecked, whether it actually is or not. You may remove any documents you
don’t want to start from the list.
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Quit

Edit Menu

Use Quit to exit the application. If copying is still underway when you quit, you
will be asked if you really want to quit. While the dialog is shown, copying
continues. If you leave your Mac alone until copying completes, Synchronize!

will quit when it is done.

Undo, Cut, Copy, Paste, and Clear

Because setting up a Synchronize! document requires almost no text or graphics
manipulation, the standard Undo, Cut, Copy, and Paste functions are disabled
except when portions of the Log window are selected, or a desk accessory is

active.

Any changes made to a document since the last time it was opened or saved may

be undone by choosing Revert from the File menu.

Undo, Cut, Paste, and Clear are not available for the Log window.

Preferences

Preferences displays the following dialog box:

Preferences

(< Copy open files

] When copying is complete,

O Don't open Untitled windows at startup

play | Simple Beep

|

Copying speed: 6
1

[ Copy when the mouse is moving

8

The higher the copying speed, the faster files will be
copied, and the slower your sustem will respond
while copying is underway.

Preferences dialog box

Settings in the Preferences dialog box apply to all Synchronize! documents.

Don't open Untitled windows at startup

Check this box to avoid opening a new Untitled window every time you open

Synchronizel.
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Copy openfiles

Check this box to copy files which are already open in some other application.
Usually this is OK, but if a file is written by another application at exactly the
time Synchronize! is reading it, the file copied to its destination may be
corrupted.

It's a good idea to refrain from changing documents in folders being
synchronized.

If you have files which are being used by a database, or you are copying files
which are being shared with other people, and those people might save a
document while you’re copying it, we recommend that you leave this box
unchecked.

When this box is unchecked, you must close any documents which you want to
copy before Synchronize! can copy them.

When copying is complete, play

Check this box to play a sound when copying completes. When this box is not
checked, no sound is played.

Use the popup menu to choose the sound that will be played when copying
completes. If the sound shown in the popup menu is gray, the chosen sound is
not available, and you should choose a different sound.

Copy when the mouse is moving

Check this box to enable copying when the mouse is moving. Synchronize! uses
movements of the mouse to know when someone is using the computer.

Checking this box gets copying done more quickly, since it’s active all the time.
Leaving the box unchecked means that any copying to be done will be postponed
until the computer is idle.

If you don’t want to be bothered with slow response time due to copying going
on in the background while you work, leave this box unchecked.

Copying Speed

The copying speed setting affects how quickly copying is done, and how
responsive your Macintosh will be while copying is underway.

A larger value for copying speed will make copying complete faster, and make
your Mac less responsive.

To change the copying speed, drag the hand to any value. Numbers 1 to 4 are
useful when copying files to and from a network server, in the background,
while working on your Mac. Numbers 5 through 7 are useful for copying files to
and from a removable disk. Numbers 8 through 10 are particularly useful for
rapidly copying files between hard disks. Note that an additional increase in
copying speed will occur if Verify in the Options menu is not checked.
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Log Preferences

Log Preferences displays the following dialog box:

Log Preferences

[]Show Log window at startup

Font: | Geneva -|
Limit log file to |[[ITI tines

[] Don't save anything in the log

[JLog the names of copied files

Cancel

Log Preferences dialog box

Settings in the Log Preferences dialog box affect how the Log is displayed and
used.

Show Log window at startup

Check this box to show the Log window every time Synchronize! is started.

Font

Use the popup menu to choose a font for the text displayed in the Log window.
Size

Use the popup menu to choose the size of the text displayed in the Log window.
Limit Log file

Enter the maximum number of lines allowed in the Log file. When the number of
lines in the Log file exceeds this value, the oldest entries in the Log file are

removed.

The range for this number is 100 to 30,000. The larger the log file, the longer it
will take to open the Log file at startup.

Don't save anything in the log
Check this box to prevent any information from being saved in the Log.
Log the names of copied files

Check this box to enter the name of each copied file in the Log.
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Error Preferences

Error Preferences displays the following dialog box:

Error Preferences dialog box

Settings in the Error Preferences dialog box affect how errors which occur while
copying files are handled.

Wait forever

Click this button to cause Synchronize! to show any errors in a dialog box until it
is dismissed.

Retry, Skip, or Cancel

Click the radio button for the action you want performed after a particular time.
These actions appear as buttons in the dialog box presented when an error
occurs.

Options Menu

The Options menu contains many ways of modifying how two folders are
synchronized. All items displayed in the Options menu apply to the active
window. When the active window changes to a different document window, the
content of the Options menu changes to reflect the options set for that settings
document.

When options which affect the operation of the settings document are changed
from their initial settings, a diamond is displayed next to that menu item.

When the active window is not a document window, the Options menu is
disabled.
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Auto-Connect. ..

Auto-Connect allows passwords for AppleTalk Remote Access and file servers to
be set in advance. Choose Auto-Connect... to show the following dialog box:

Auto-Connect

[ Automatically connect via
fAppleTalk Remote Access

Name: Joe User
Password:
Phone: 642-1893

[ #utomaticaly alfach
fartabie

Password:

H

[ Automatically attach
"Remote Disk"

Password:

[ Cancel

ppe—
=
-~

=

Auto-Connect dialog box
Automatically connect via AppleTalk Remote Access
Check this box to make a connection with AppleTalk Remote Access. Enter the
password needed to make the connection. The Name and Phone information is

automatically set when choosing the remote folder to be synchronized.

This box is active only when AppleTalk Remote Access is installed, and one of
the two folders to be synchronized is available via AppleTalk Remote Access.

Automatically attach “Remote Disk”

Check this box to automatically attach a file server disk. Enter the password
needed for the file server disk.

This box is active only for folders which are on an AppleShare file server, or a
Mac with File Sharing.
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Start Options...

Choose Start Options... to show the following dialog box:

Start Options
Start synchronization:
[J At startup
JWwhen document is opened
[J When disks become available
[] Before Quit or Shut Down
dJon Sunday 10/24/1993 6:21 P™

O start again every ([ [ day -]

Start Options dialog box
Start synchronization at startup

Check this box to start synchronization immediately when Synchronize! is
opened, or started up. The document will be opened automatically and started
when Synchronize! is opened. Use this option to automatically synchronize your
files by double-clicking the Synchronize! application.

Start synchronization when document is opened

Check this box to start synchronization immediately when the document is
opened. This works the same as if you clicked the Sync button when you open
the document.

This option is particularly useful when you put your settings document in your
Apple Menu Items folder, under System 7. Just choose the document name in
your Apple menu, and copying begins.

Start synchronization when disks become available

Check this box to start synchronization when both disks needed for a
synchronization become available.

When both disks are available, the settings document will be opened, and
synchronization will begin.

A common use for this feature is to automatically start synchronization to a
removable disk when it is inserted.

To start synchronization with this feature, Synchronize! must be running before

both disks become available. In order to take full advantage of this feature, it is
recommended that Synchronize! be run in the background.
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Start synchronization before Quit or Shut Down

Check this box to start synchronization just before Synchronize! quits, or your
Mac shuts down. This works the same as if you had opened the document and
clicked Start before choosing Quit or Shut Down. The document will be opened
and started before quitting or shutting down.

This option is effective only when you leave Synchronize! running in the
background while you work. When you’re done, just choose Shut Down from the
Special menu in the Finder.

Before your Mac is turned off, Synchronize! automatically transfers your new
work to a removable disk or your network server.

Start synchronization at a preset time

Check the “On Sunday...” box to start synchronization at a particular time. To
set the time, click the time and use the up and down arrows, or type.

This option is effective only when Synchronize! is running before the
synchronization is set to start.

Startagain every...

Check this box to start synchronization periodically. Enter the amount of time
between synchronizations. Use the popup menu to set the time in minutes,
hours, days, weeks, months or years.

Each time a synchronization is completed, the start time is reset.

AutoSync

When you click the “OK” button with synchronization set to occur at a preset
time, or when disks are available, you are asked if you would like AutoSync, a

small background application, to be installed.

AutoSync checks for conditions which you have set for starting synchronization,
and automatically launches Synchronize! for you when those conditions are met.

AutoSync is installed in the Startup Items folder under System 7.

To re-install AutoSync at any time, hold down the Option key when you click the
“OK” button.
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Completion Options...

Choose Completion Options... to show the following dialog box:

Completion Dptions

B When copying is complete:
@ Close this document
) Quit
1 Sleep
7 Shut Down

[Junmount "Hard Disk" when complete
[JEject "Floppy Stuff" when complete

[ bisconnect AppleTalk Remote Access

Cancel 0K
Completion Options dialog box

When copying is complete:

Check this box to perform one of the four actions shown, when copying is
complete. Only one action can be chosen at a time.

Close this document

Click this radio button to close the document when copying is complete.

Quit

Click this radio button to quit when copying is complete. Note that Synchronize!
will not quit until all copying is complete, even if the document containing this
option is the first one started.

Sleep

Click this radio button to cause the computer to sleep when copying is complete.
Note that the computer will not go to sleep until all copying is complete, even if

the document containing this option is the first one started.

Choosing this option will have no effect if the computer is incapable of going to
sleep.

Shut Down
Click this radio button to shut down the computer when copying is complete.

Notice that the computer will not be shut down until all copying is complete,
even if the document containing this option is the first one started.
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Unmount “Hard Disk”” when complete
Eject “FHoppy Stuff” when complete

Check these boxes to unmount or eject the disk when copying is complete. When
a disk is ejected or unmounted, the action is equivalent to dragging the disk to
the trash.

Disks which cannot be ejected are unmounted. When a hard disk is unmounted,
the disk is removed from the desktop.

The disk containing the active System Folder cannot be unmounted.

A hard disk or removable disk containing one or more open files will not be
removed from the desktop.

AutoDoubler...

Choose AutoDoubler... to show the following dialog box:

AutoDoubler
[J Don't espand compressed files

Check this box to copy files compressed with
AutoDoubler in their compressed form.

AutoDoubler.. . dialog box
Don'texpand compressed files
Use this option to copy files compressed with AutoDoubler in their compressed
form, even to floppy disks. This feature makes it possible for you to use
AutoDoubler’s compression capabilities to carry more information on your
floppy disks.
Keep in mind that when you take a floppy disk with AutoDoubler files on it to
another computer which does not have AutoDoubler running on it, you will
need the “ADExpand™ Util” to decompress the files.
This option is only available if AutoDoubler is installed.

Conflicts...

Use the Conflicts... option to set how file conflicts should be handled.

There are two types of file conflicts:

= Both files have been changed since the last synchronization. Overwriting the
older file in this situation causes the changes made to it to be lost.
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= Two files have the same name, but have different types. An example of such a
situation might be two files called “Proposal”, one of which was created by a
word processing application, and another which was created by a spreadsheet
application. The two files are obviously different, and should not overwrite each
other.

Choose Conflicts... from the Options menu to show the following dialog box:

Conflicts
(] Don't check for conflicts (saves memoryl

If both files have been changed
since the last synchronization:
[ Alert Me
> Don't copy either file

) Overwrite the older file
@ Move the older file to the Conflicts Folder

If two files have the same names
but different types:
(<] Alert Me

2 Don't copy either file
) Overwrite the older file
@ Move the older file to the Conflicts Folder

Conflicts. .. dialog box
Don't check for conflicts

Check this box to turn off conflict checking. When this box is checked, less disk
space and less memory is required. Synchronization will also take less time.

Alert Me

When this box is checked, a conflict will be announced with a dialog box.
Don't copy either file

Click this button to avoid copying conflicting files.

Overwrite the older file

Click this button to overwrite the older file. This is the same action taken when
conflict checking is turned off.

Move the older file to the Conflicts Folder
Click this button to move the older conflicting file to a special Conflicts Folder.
This folder is located immediately within the top-level folder containing the

conflicting file. If a Conflicts Folder does not exist, it will be created.

After the conflicting file is moved, the newer version of the file will be copied to
replace it.
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Move files

Check “Move files” to move files, rather than copy them. Use this feature to
extract certain files from a larger set. For example, all word processing
documents last modified more than two months ago could be moved to a
removable disk for storage.

When files are moved to another folder on the same disk, they are moved very
quickly. When files are moved to another disk, they are copied completely, then
the original file is deleted.

Copy existing files only
Check “Copy existing files only” to synchronize only those files which have an
existing corresponding file in the other folder. Any file which does not have a
corresponding file already in existence will be ignored.

This option is not active when a Master box is checked.

Don't copy empty folders

When “Don’t copy empty folders” is checked, any folders which would normally
be created, and which will be empty when the synchronization is completed, will
not be copied.

This option is useful when copying or moving only certain files. With this option
checked, only those folders which will contain files will be created.

Sync deleted files

When “Sync deleted files” is checked, any files which are deleted from one folder
will cause the corresponding file to be deleted at the next synchronization.

Check this option to make it easier to delete files from two synchronized folders;
when this option is not checked, a file which is deleted from one folder, or
dragged to the Trash, will be replaced by a copy of the file from the other folder.

With this option checked, when a file is no longer needed, just drag it to the
Trash. Its corresponding file will be deleted during the next synchronization.

This option is not available if “Don’t check for conflicts” is checked in the
“Conflicts...” dialog box.

Copy only folders...

Use “Copy only folders...” to limit a synchronization to a subset of the folders
which would normally be synchronized.

This option is useful for synchronizing only certain folders on a hard disk. For

example, you might want to synchronize only a Working Documents folder, and
the contents of your Preferences folder.
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The following dialog box creates a list of folders to be copied:

< Applications v

[0 AppMaker 1.5.1 it — Hard Disk

01 CIM _

03 Working Documents Eieed

O HyperCard Desktop

[0 Mavis Beacon

O MPID -

OO THINK P 4.0

O Tools [ 114

Copy only the contents of: [[ I]pen_]]

Working Documents 7]

Preferences
fg

Add "Applications"

Copy only folders... dialog box

To include a folder in the list, choose a folder and click the Add button. To
remove a folder from the list, click the Remove button.

Any number of folders may be included in the list. Only those folders which
actually appear within one of the top-level folders shown in the settings
document will actually be copied.

Don't copy any folders. ..

Use “Don’t copy any folders...” to exclude certain folders from a

synchronization.

This option is useful for synchronizing several folders on a hard disk without
synchronizing them all. For example, you might want to synchronize all folders
except the System Folder and a folder containing applications.

Use this option to create a list of folders whose contents are not to be

synchronized, in a similar way to the dialog box shown in “Copy only folders...”
above.
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Copy onlyfiles...

Choose “Copy only files...” to show the following dialog box:

Copy only those files:
O Whose names

[ Which [ were modified within the last -]
1 day "l
Which are:

[J applications [Jaliases []invisible [Jon the desktop
[J Which were created with [ Choose... ]
[J Which are the same type as [ Choose... ]
[J Which are labelled

[ Mane O Project 1 [ coot [ Hat

D FProject 2 D Personal D In Progress D Essential

Copy onlyfiles... dialog box

“Copy only files” restricts the files which are copied. Only files which meet at
least one of the criteria checked will be copied. Other files which do not meet the
criteria are ignored by Synchronize!.

If no boxes are checked in this dialog, all files in all folders are copied.
“Whose names” check box

Use this check box to copy files by matching their names. Enter the portion of the
name which is to be matched. Use the popup menu to choose the kind of
matching. Matches can be made with the first part of the name (starts with), the
last part of the name (ends with), the whole name (matches), a part of the name
(contains), or from a list of file names (are).

“Which were modified” check box

This check box restricts files by how old they are, or by the time they were last
changed. Use this check box to copy files which are older, or newer by a certain
time, or some particular date.

Some applications always modify a file when it is opened. HyperCard is an
example of such a program. Each time you open a stack, HyperCard writes to the
stack, changing the modification date. The only way around this, which causes
files which weren’t really changed to be copied, is to lock the file. Use Get Info
from the File menu in the Finder to lock a file.

“Which are applications” check box
Use this check box to copy only those files which are applications, like

Synchronize!, a word processor, or a spreadsheet. Documents are not copied if
this is the only box checked.
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“Which are aliases” check box

Use this check box to copy only those files which are aliases. This check box
works whether System 6 or System 7 is running. This check box has no effect
when the “Resolve Aliases” option is checked, because the alias is resolved first.

“Which are invisible”” check box

Use this check box to copy only those files which are invisible. The invisible files
for virtual memory, and the Desktop files, are never copied, even when this box
is checked.

“Which are on the desktop” check box

Use this check box to copy only those files which are on the desktop. For this
option, the top-level folder in the synchronization must be the entire disk. This
check box works with System 6 or System 7.

“Which are the same type as”” check box

This check box restricts files to documents which have one or more particular
types. The most common types are TEXT and PICT, which refer to files
containing text only and bitmap pictures, respectively. Use this check box to copy
only certain kinds of files, regardless of which application created them.

“Which were created with’” check box

This check box restricts files to documents created by one or more applications.
Use this check box to copy only spreadsheet files, or only word processing files.

Click the Choose button to choose the applications whose files are to be included.
Add the applications you want, and click OK. Any number of applications may
be included in this list.

Don't copy anyfiles...

Choose “Don't copy any files...” to choose files which are not to be copied. A
dialog box is presented which is identical to the “Copy only files...” dialog box
described above. This dialog box, however, describes files which will not be
copied.

Well, you ask, what happens if | tell it to copy a file, and also tell it not to copy a
file? It won’t be copied.

Synchronize! first includes all files which fit the description in the “Copy only
files” dialog, then excludes those which fit the description in the “Don't copy
files” dialog.

If no boxes are checked in this dialog, no files are ignored.
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Resolve aliases

When “Resolve aliases” is checked, aliases may be used to include files and
folders in a synchronization, even if they actually reside elsewhere.

An alias is a file which contains information on the location of a file or folder. Its
contents “point” to the actual location of the file or folder. An alias is useful
because, in many cases, it can be used as the actual file or folder, while allowing
the actual file or folder to be located elsewhere.

To use an alias to include a file or folder in a synchronization, create an alias to
the file or folder in the Finder with Make Alias in the File menu. Drag the alias to
the folder to be synchronized. Check “Resolve aliases” in the Options menu in
your Synchronize! document.

When the folder is synchronized, the alias is “resolved”, which causes the alias to
be replaced with the file or folder itself, as if it were actually located where the
alias is located.

Note: Remember that the name of the original file is used to find a
corresponding file, not the name of the alias. It’s a good idea to give the
alias a name similar to the name of the original it was created from, but
it’s not necessary.

“Resolve aliases” is available only under System 7. Aliases may not refer to files
or folders on a disk other than the disk or folder to be synchronized.

Verify copied files

When “Verify copied files” is checked, the contents of each file is read back from
the disk to verify that it was correctly written.

If you have had trouble reading or writing floppy disks, or are writing critical
information to floppy disks, it’s a good idea to check this option.

This option increases the time it takes to copy your files, since each file must be
read after it is written. Using it can increase the time it takes to copy your files by
as much as 100%, depending upon the situation.

Although Synchronize! verifies the contents of files that it copies, it is not designed to
verify the contents of two folders exactly, comparing the contents of each file with the
contents of its corresponding file.

Windows menu

The Windows menu shows all windows which are available in Synchronizel.
When you open documents, they are added to the Windows menu.

Use the Windows menu to show a particular window. Notice that the Waiting
List, Status, Log and Help windows are always present in the Windows menu.
These windows are always available in Synchronize!, although they may not be
visible.
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For more information about the Waiting List, Status, Log and Help windows, see
the section “Synchronize! Windows”, above.

The Windows menu is particularly useful when many Synchronize! settings
documents are open at the same time. Use it to show the window for a particular
settings document.

The check mark in the Windows menu shows which window is active. If no
windows are active, no check mark will appear in the menu.

Help Menu

Use the Help menu to get information on a particular topic.
To show the Help menu, choose “Help” from the Windows menu.

Show Help at startup
When “Show Help at startup” is checked, the Help menu and windows will be
active when the application is opened.

Hide Help
Use “Hide Help” to hide the Help menu, the Help window, and the Topics
window.

Show Topics
Use “Show Topics” to make the Topics window active. Use the Topics window
to choose a help topic of interest. Double-click on the topic to see the information
on that topic.

Previous
Choose “Previous” to see the previous help topic.

Next
Choose “Next” to see the next help topic.

Print Topic
Choose “Print Topic” to print the information in the Help window.

Print All Topics

Choose “Print All Topics” to print all help topics.
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Troubleshooting

Sometimes you may encounter difficulty while using Synchronize!.

This chapter lists some of the common problems you may encounter, and
suggests ways to solve those problems.

Synchronize! tells me that | don’t have enough space on my removable disk.

When your working documents no longer fit on one removabledisk, you have
several choices: use two or more disks, move some older documents from your
folder, or connect your two Macs directly, using File Sharing or a direct SCSI
connection.

If you move some older documents from your “Working Documents” folder,
make sure to move them on your second Mac as well, or Synchronize! will re-
copy them into the folder you removed them from.

If you choose to use more than one removable disk, create one Synchronize!
document for each removable, and rearrange your documents into as many
folders as the number of removable disks you plan to use. Use Synchronize! to
copy the files to the folders in the new configuration.

| get the error message “The file *“ " is already in use.”

This error occurs when Synchronize! tries to copy an open file when “Copy open
files” is not checked in the Preferences.

To copy open files, choose Preferences from the Edit menu. Check the “Copy
open files” box. Remember that files which are changed while they are copied could be
corrupted.

Synchronize! says there isn’t enough memory. | can’t start all my documents.
Remember that each synchronization requires memory to record the files which
need to be copied. Starting many documents can use up all the memory allocated
to Synchronize!.
Either allocate more memory to Synchronize!, using “Get Info” in the File menu
in the Finder, or wait until some synchronizations are complete before starting
the others.

It’s taking a long time after I click the Start button.

This problem is related to the number of files and folders Synchronize! has to
compare before it can show what files and folders need to be copied or deleted.

If you synchronize your entire hard disk, this process can be quite lengthy.
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| get an error message “Can’t find the folder...”

This error message occurs when Synchronize! can’t find one of the two folders
identified in the Synchronize! document. It occurs because a folder or disk has
been renamed, moved or deleted.

To fix this problem, click on the folder icon in the Synchronize! document and
choose the appropriate folder again.

I get a message that the server time and my Mac’s time aren’t within 5 minutes of each other, and
when | correct the time on my Mac, it still complains!

When you connect to an AppleShare file server or a Mac running File Sharing
(which is also a file server), the difference between your Mac’s time and the time
on the file server is calculated and rounded to the nearest 30 minutes. This time
difference is applied to all times set on files which reside on the server.

Because of this, if your Mac’s time and the server time differ at the time you
connect to the server, the time reported for files which exist on the server will be
offset by the time difference, and it will look like files which were the same are
now different, because they have different modification times.

It’s very important, if you receive the error message described above, that you disconnect
from the file server by dragging all the shared disks to the Trash, correct the time on your
Mac,and then mount the disk that you want to synchronize. Until you disconnect from
the server, the time difference between your Mac and the file server is not re-
calculated, even if you change the time on your Mac.
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Requirements

Synchronize! is designed to work effectively on all Macintosh computers,
including the Macintosh 512K and Plus, PowerBooks, Quadras, and Power Macs.

Synchronize! has been tested and is expected to work properly on Macintosh
computers running System 6.0.2 or later, System 7.0 or later, and Mac OS 8.

When using System 7, additional features are supported. These features include
Balloon Help, using the Preferences folder, “drag and drop” operation, alias
support, and AppleScript.

Synchronize! supports AppleScript. For more information on AppleScript
support, see the AppleScript topic in the built-in Help.

Synchronize! runs under A/UX 3.0 and later, and the Macintosh Application
Environment for UNIX computers.

Synchronize! requires a minimum memory allocation of 300 K; however, with
large numbers of files or folders to be searched, or many documents to be
opened, additional memory may be required.

Synchronize! needs 500K plus 160 bytes times the maximum number of items in
either folders. For example, syncing 10,000 files requires 500K plus 160 * 10,000 =
2100K. Remember to set both the minimum and the preferred sizes to this
amount.

Synchronize! documents vary in their requirements for disk space. When large

hard disks are synchronized with conflict checking turned on, disk space
requirements can be substantial.
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Feedback

Technical

Synchronize! can be what you’d like it to be. Make suggestions and see them
incorporated into the product.

Send us your suggestions and feedback via electronic mail to one of the
email addresses below, or via U.S. Mail to:

Qdea

Synchronize! Technical Support
6331 Hilton Court

Pine Springs, MN 55115

Supyport

Upgrades

Technical Support is available for Synchronize! via electronic mail, or by letter at
the address above. Please allow 48 hours for a response to electronic mail.

Internet email support@Qdea.com

Technical support is also available by telephone:
(651) 779-0640
Answers to common questions about Synchronize! are included in a set of

Technical Notes, which are part of the Synchronize! distribution. To find these
notes, search your computer for a folder called Notes on Synchronize!.

Updates to new versions are free for two years from the date of
your purchase. Replace your old version with the new "demo"
version, which is also an updater. If you have purchased
Synchronize! Pro or a renewal in the last two years, your serial
number will be automatically recognized by the new version.

For the latest version, check Qdea’s Web site:
http://www.gdea.com

The latest version is also available via anonymous ftp:
ftp.qdea.com, in the directory /pub.

You can sign up for email notification of new versions by visiting the Qdea web
site.
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