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1 Introduction

Welcome to RotoDV

RotoDV is a video painting and special-effects program for Power Macintosh. 
RotoDV provides an outstanding collection of painting tools in a real-time, motion-
video environment. 

RotoDV has many uses—from realistic touch-up to special effects to animation. 
You can paint over video, either one frame at a time or live while it plays. RotoDV’s 
organic brushes and filters give you the power to create effects not possible 
elsewhere. 

In RotoDV, your painting and effects go into separate layers above the video. It’s 
easy to experiment and swap layers in and out. The source material is never altered, 
so you’re free to explore the possibilities. You can add any number of Video and 
Paint layers to your project. RotoDV’s Timeline window lists the layers in the 
project and lets you control them over time.

As you paint and make changes, you can view the results in real time. The 
document window immediately displays the results of all painting tools and effects.

When you’re finished working in RotoDV, you can save any combination of layers 
to a QuickTime movie. You can then use an editing or compositing program to 
combine your RotoDV work with other material. 
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Into the Workflow
RotoDV is just one component in a desktop video production suite. Most systems 
will include a non-linear video editor and, perhaps, a compositing program. Some 
will also have a 3D program for generating animation. Because RotoDV uses 
QuickTime for file I/O, it integrates perfectly with many other applications. 

The following steps describe how we suggest you use RotoDV:

First, generate source material. Video footage may come from a 
rendered 3D animation, stock video “clip art”, or be captured 
from video with Digital Origin’s EditDV, Adobe Premiere, or 
other software. Many systems will use dedicated hardware for 
video capture.

Second, use your non-linear video editor to trim the clip to just 
the frames that need work in RotoDV. Avoid the overhead of 
bringing in frames that you’ll leave untouched. Since RotoDV 
manipulates the realtime playback in RAM, you’ll find it more 
efficient to work on shorter segments.

Third, open the source material in RotoDV and perform your 
special-effects magic. 

When finished in RotoDV, save the file to a standard format, 
appropriate for the next application in your workflow.

At this point, the flow diverges—you might import the clip to your editing 
application for assembly with other material. Or you might take the finished 
RotoDV clip into a compositing application such as Adobe After Effects. 
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About this User Guide

Conventions
Menu commands are given as follows: Menu> Item or in the case of a sub-menu, 
Menu> Sub-Menu> Item.

On screen buttons or controls are shown as: The New button.

Keyboard commands and shortcuts are shown as: Press the Return key.

Note: The 
Command key on 
your keyboard is 
labeled with a 
cloverleaf symbol. 

Primary palettes that have sub-palettes are listed as follows: Palette: Sub-Palette. 

Using This Guide
This user guide is designed to help you get productive with RotoDV as quickly as 
possible. 

■ After this introduction, a “Getting Started” chapter covers program installation 
and setting preferences.

■ Three tutorials build on each other to cover the range of features and project 
goals. 

■ The body chapters are organized categorically. The information progresses 
from basic functions in the early chapters to more advanced techniques later 
on.

If you’re looking for information in this guide, try the Table of Contents. Locate the 
general category and heading that describes what you’re looking for. If there’s no 
exact match, check out a related section. You might find it there or find a cross-
reference to the right section.

You can also search the Index for the term or feature you want to find.
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2 Getting Ready

Before Installing

This chapter provides information on installing RotoDV, launching the program for 
the first time, setting preferences, getting help and contacting Digital Origin.

System Requirements
Before installing RotoDV on your computer, please review these system 
requirements:

Minimum System Requirements
■ Macintosh with a PowerPC G3 or 604 processor

■ Display system capable of 832x624 resolution at Millions of colors (24-bit)
(high performance accelerated video recommended)

■ 128 MB RAM minimum1

■ CD-ROM drive

■ Sufficient hard drive free space for projects2

■ Mac OS version 8.5 or later

■ QuickTime 3.0 or later
15
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Additional Recommended Hardware
The following hardware will greatly improve RotoDV performance:

■ 256MB to 1GB RAM for extended realtime playback

■ Accelerated, high resolution graphics capability

■ Large, fast hard drive with plenty of free space for video clips and scratch files

Optional Accessories
Many systems will include the following:

■ Pressure-sensitive drawing tablet (Wacom or compatible)

■ QuickTime-based editing software, such as Digital Origin EditDV

Notes on the System Requirements:
1. RotoDV requires significant RAM for real-time playback. Many artists will want at least 256 MB 

to 1 GB of RAM.
2. The RotoDV installation occupies approximately 25 MB.

Installing RotoDV
Note: RotoDV 
requires QuickTime. 
If you don’t already 
have QuickTime 
installed on your 
system, use the 
installer provided on 
the RotoDV CD, or 
visit: 
www.apple.com.

1. Insert the RotoDV CD-ROM into your computer’s CD drive.

When the disc is mounted, the disc contents window opens.

2. Double-click the RotoDV Installer icon and follow the on-screen instructions.
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Allocating Memory to RotoDV

Layered video projects require significant memory—especially at larger frame sizes. 
To provide real-time playback, live painting and other functions, RotoDV will take 
advantage of as much RAM as you can give it.

For maximum capabilities in RotoDV, you’ll want to run the program by itself 
and disable all unnecessary system extensions.

To allocate memory to RotoDV:

1. Quit all applications.

2. Choose Apple Menu> About This Computer and check the memory used by 
your system software and note the “Largest Unused Block”. Close the window.

3. Select the RotoDV application icon.

4. Choose File> Get Info to open the application Info window.

5. If necessary, Choose “Memory” from the Show pop-up.

6. In the “Preferred Size” box, enter a value about 10 MB less than the Largest 
Unused Block you noted earlier. Do not enter a number smaller than the Mini-
mum Size.

7. Close the Info window. You’re now ready to launch RotoDV.

Getting Help and More Information

Browsing to Digital Origin’s web site
Digital Origin maintains a web site that may include additional helpful information. 

The Digital Origin logo button on the Button Bar will launch your browser and link 
to our web site, provided that your system is networked. 

You may also visit directly from your browser—

http://www.digitalorigin.com

Once you’re connected, you can navigate to the RotoDV support section.
17
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Registering
Please take time to complete and mail the RotoDV registration card. Registering 
makes you eligible for technical support and allows Digital Origin to contact you 
with product update information.

Technical Support
If you’ve searched this user guide and the RotoDV support web site and you still 
have a problem or question, you can contact Digital Origin technical support.

The preferred method for contacting technical support is by e-mail. For most 
questions, you should include details on your particular system:

■ Processor type and speed

■ Installed RAM

■ Model, size and speed of disk storage

■ Display system specifics 

■ Video compression/acceleration hardware

■ Format of the video source you are using (including: frame size in pixels,
frame rate in frames per second, QuickTime codec, and project length)

■ Model of input device (drawing tablet)

■ Version of RotoDV are you are running

Send the details along with a description of the problem or question you have to:

support@digitalorigin.com

You may also contact technical support using fax, voice or mail.

Fax: (650) 404-6060

Voice: (650) 404-6400 

(Monday-Thursday: 7 am to 4 pm Pacific Time, Fridays 7 am to 3 pm Pacific 
Time)

Technical Support
Digital Origin Inc.
460 East Middlefield Rd.
Mountain View, CA 94043 USA
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3 Tutorials

About the Tutorials

This chapter includes three tutorials, designed to introduce you to RotoDV. These 
tutorial projects begin with the basics and progress into advanced features and uses.

■ Tutorial One covers starting a project, choosing tools, painting and playing 
through your work.

■ Tutorial Two shows you how to use Clone Paint with video.

■ Tutorial Three introduces the major features of the Timeline—Media Stack 
layers and the Blend Stack.

Tutorial One

This tutorial teaches you to add an effect to a digital video clip. Along the way, 
you’ll learn to use the main features of the Transport palette, the Tools palette, the 
Brush tool and how to choose colors.

Open a new Project
1. Launch RotoDV.

2. From the File menu, choose New. (Hereafter, menu command notation will be 
File> New.).
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3. For frame size, choose DV NTSC Quarter from the pop-up or type in 360 x 
240.

4. Set Duration and Real Time to 20 frames each.

5. Click the New button, or press the Return key to create the new project file.

The New Project dialog with the settings for this tutorial.
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Tutorial One
Import the Movie Clip
1. Use the Import Clip dialog to locate and open the file RotoDV Application 

Folder/Tutorial Files/wineglass.mov27f.

This is a simple 360x240, 30fps video clip.

When you click Open, the Clip Options dialog box appears.

2. Move the selection bar so that the In Point Frame box reads “4”, and the Out 
Point Frame box reads “23”.

This selects the twenty frames in the middle of the clip to import into the 
project. You can also type a frame range in the In Point and Out Point boxes.

3. Verify that the Alpha setting is “None”.

4. Click OK or press Return to import the selected frames.

The Clip Options dialog box displays the first and last frames in the selection.
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Preview the Video
1. Display the Transport palette.

All palettes and windows may be displayed/hidden using commands on the 
Windows menu. The Button Bar is a special palette that gives you one-click 
access to all of the palettes and windows.

The Transport palette provides the movie play controls and miscellaneous 
related functions.

2. Click Play and preview the video. Try out the several transport features—Play-
mode, Jog, Shuttle, and Scrub.

Note: The first 
frame of a movie or 
project is identified 
as frame #0. This 
means that a 
project that has 30 
frames will end on 
frame #29. This 
follows the SMPTE 
convention.

3. When you’re ready to continue, click the Rewind button to return to frame #0.

Choose a Brush Tool and a Color
In this phase of the project, you’ll use the Brush tool to paint in some red wine. 
You’ll work across time so that the wine will spill when the glass tips over. This 
kind of effect is easy to accomplish in RotoDV, but would be impossible in all but 
the most sophisticated 3D programs.

The Transport palette provides the movie play controls and miscellaneous related functions.

Play Mode

Transport

Frame rate

Shuttle

Record

controls

Scrub

Timecode

Jog

Safe area

Field Mode Auto Paint

guides
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Tutorial One
1. If necessary, display the Tools palette. You may use the Windows menu, Button 
Bar or press F2 to open it.

The Tools palette holds an icon for each tool. The Brush tool has several ver-
sions to choose from, and you can create new, custom versions to add to your 
tool set. Customizing brushes is a major feature of RotoDV. You’ll learn all 
about it in Chapter 6.

2. Hold down on the Brush tool icon.... All available brush tools in the current set 
pop-up in a string of icons.... select the Airbrush, as shown below.

3. If necessary, display the Color palette. Choose Windows> Show Color, or 
press F5.

4. Select a color for the wine. In the Color palette, use the slider at the bottom to 
choose the color range, then refine your selection by moving the circle in the tri-
angular color area above. Notice that the primary color indicator in the Tools 
palette reflects your color choice.

Select the airbrush from the brushes pop-up.

Use the color palette to choose a color.
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Adjust the Brush and the View
1. f necessary, display the Tool Options palette. Choose Windows>

Show Tool Options, or press Shift-F2.

2. Adjust the Opacity slider to about 15%.

3. Click the Zoom tool (magnifying glass icon) on the Tools Palette. Click once 
with the zoom tool in the document window to enlarge the wineglass.

4. Drag the size box at the lower right corner of the window to enlarge the docu-
ment window so you can see the whole top part of the wineglass.

5. Click the Hand tool in the Tools palette. Drag the image in the document win-
dow to reposition the wine glass in the center.

Less opacity makes the paint more transparent, like wine.

Enlarge the window to see the top of the wineglass.
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Tutorial One
Select a Mask
1. Click once on the Lasso tool in the Tools palette.

2. Select an area slightly smaller than the inside of the wine glass that you want to 
fill with wine. If you don’t get the selection exactly right, don’t worry.

■ Use the Shift key with the lasso to add to the selected area.

■ Use the Option key with the lasso to subtract from the selected area.

3. Choose Select> Feather, or press Command-Option-D to open the Feather 
dialog box. Enter a value of 2.

Feathering the selected area blends the edged into the surrounding imagery.

You’ve created the mask, now you can fill it with paint.

Use the Lasso tool to select an area to mask.

Feathering the edges of the selection makes the wine blend smoothly into the glass.
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Apply Some Paint
1. Verify that the Paint Layer is selected in the Timeline. Click the paint layer in 

the Timeline to select it, or use the up and down arrow keys to select a layer.

2. Click the Airbrush icon on the Tools palette to select your brush again.

You’re ready to paint.

Note: If you need 
to erase, you can 
click the Erase 
Mode icon in the 
Tools palette (see 
page 78). Click the 
Paint mode icon to 
return to paint 
mode.

3. In the document, drag brush strokes into the selected area to paint in the wine. 
You don’t need to be too careful, you can return to this frame later and clean up 
your work. This is one of the advantages of working in layers.

Notice that the paint is confined to the selected area, except for a small amount 
of color around the edges. This is because of the Feather command and why 
you made the selected area slightly smaller than the wineglass.

TIP: To produce a more realistic effect of the wine in the glass, set the Blend 
Mode to Hard Light in the Brush Options palette

4. Use the right arrow key to advance to the next frame and paint the wine in 
again.

5. Continue painting and advancing until you see the wineglass tipped over on the 
table.

6. Return the window to normal size by double clicking the Zoom tool on the 
Tools palette. Click the zoom box at the upper right of the document window 
to shrink the window to the frame.

7. Choose Select>None or press Command-D to remove the selection.

Use the up and down arrow keys to select a layer in the timeline.
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Tutorial One
Use Auto Paint
Before painting the frame where the wine glass is tipped over, we’re going to engage 
a special option—Auto Paint. This feature automatically copies anything you paint 
in this frame to the next one (when you advance). Using the Auto Paint feature 
ensures that the shape of the wine stain on the table cloth won’t change 
unexpectedly.

1. Turn on Auto Paint by clicking its icon in the Transport palette, or choose 
Edit> Auto Paint, or press Command-B. 

2. Paint the wine spilling out of the glass and onto the table cloth.

3. Press the right arrow key to advance to the next frame. Notice that the work 
you did in the last frame appears also in this one. This is the power of the Auto 
Paint feature.

To change the brush shape: 

■ Display the Dab Options palette (shift-F4).

■ Adjust the Ratio slider to about 45% to make the brush shape more horizontal.

Empty the Glass
1. Click on the Erase mode icon on the Tools palette, or press the E key.

2. Use the airbrush in erase mode to remove paint from the glass as you advance.

The stain trails out from the lip of the wineglass. You’ll probably want to use a different shaped brush 
for this part.
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3. Switch back to paint mode to paint the expanding wine stain, then advance to 
the next frame.

4. Repeat this process until all the wine is out of the glass.

5. Continue painting the wine stain and advancing until you reach the last frame 
of the clip.

6. Turn off the Auto Paint feature by clicking its icon again (command-B).

Finish the Project
1. Save your work by choosing File> Save.

Now is a good time to preview the spilling wine.

2. Click the Play Mode button in the Transport palette to select the play back and 
forth mode. (See “Play Mode” on page 64.)

3. Choose 10fps from the frame rate pop-up on the Transport palette.

4. Click the Transport Play button to review your work.

5. You’ll probably notice several places where the wine doesn’t flow as it should. 
You can stop the preview, move to any frame, and correct problem:

■ Use the Brush to apply more wine. 

The final frame should look something like this.
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Tutorial Two
■ Switch to Erase Paint mode (press E) and use the same brush tool to 
remove wine. 

Because the wine is in a layer floating above the wine glass, you can make any 
number of changes to the wine without touching the glass.

Tutorial Two

This second tutorial builds on the information covered in the first. In this project, 
you’ll work with two video layers, the clone paint feature and effects brushes. The 
end result will produce the effect of a man breathing fire.

Create the Project
1. Close any document you may have open.

2. Choose File> New to start a new project.

3. In the New Project dialog, set frame size to DV NTSC quarter (360 x 240)

4. Set project duration to 37 frames, and Set Real Time range to 37 frames as well.

5. Click New. RotoDV opens a new project.

Import the Clips
Now you can import the two video clips. 

1. Choose File> Import Clip... from the File menu.

Use the dialog to locate and open the file RotoDV Application Folder/Tutorial 
Files/Fire Clip™37f.

2. The Clip Options dialog appears. Go ahead and click OK to use the default set-
tings to import the clip.
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3. Once the clip has been imported, double click the layer title (Layer 2• Video) in 
the Timeline. This opens the Set Layer Name dialog box.

4. Enter “Fire” for the name of the first layer, then click OK.

5. Repeat steps 1 through 4 to import a second file, Ric Clip™37f.

Note: The paint 
layer is on top of all 
video layers, but it 
is transparent, so 
the top video layer 
shows through.

Notice that although the video clip of Ric is not visible in the document win-
dow, it is present in the Timeline. This is because the fire video layer is on top of 
Ric’s video layer in the media stack.

To rearrange the Media Stack:

You need to bring Ric’s video layer forward in the media stack so that it appears in 
the document window.

■ Resize the Timeline window with the size box at the lower right of the window 
so that all layers in the media stack are visible.

■ Press the down arrow key twice, until Ric’s video layer is selected. You can also 
click on the video layer in the timeline to select it.

Name the layers in the Set Layer Name dialog box.
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■ Choose Layer> Move Forward, or press (command-]).

Setup Clone Paint
Now you’ll use RotoDV’s Clone Paint feature to combine the fire video with Ric’s 
head. Clone Paint copies the images from one layer into another using the Brush 
tool.You need to select the source for the clone paint, in this case the fire video.

Note: You can turn 
on Clone Paint 
mode by pressing 
the “S” key on the 
keyboard.

1. Click the Clone mode icon (Sheep) in the Tools palette to select clone mode.

2. If necessary, Display the Clone palette (F7).

3. From the Source Layer pop-up in the clone palette, choose “Fire • Video”.

This selects the fire video as the source for the clone paint.

Once you swap the layers you should see Ric in the document window.

The Clone palette allows you to set up clone paint.
31



Chapter 3      Tutorials
4. If necessary, adjust the Ghost slider in the Clone palette so that you can see a 
trace of the fire in the document window. This gives you a guide for painting.

Select and Modify the Effects Brush
To clone in the fireball, you will use one of RotoDV’s effects brushes: the skywriter 
brush. This paints a effect like the texture of lettering from a skywriter, which 
works well for the fireball.

1. Choose the Fire icon from the Brush pop-up on the Tools palette (see “The 
Tools Palette” on page 72).

2. Press F3 to show the Brushes palette (see Chapter 7).

3. From the second pop-up choose Skywriter.

4. Press the up arrow key to select the paint layer in the timeline (You can’t paint 
directly onto video layers).

Use the Skywriter brush to clone in the fireball.
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5. Now try out the Skywriter brush on the document window. Brush in the fire 
next to the Ric’s mouth. Start with a small ball of fire in the first frame and 
make it grow larger over time.

That looks pretty good, but lets adjust the brush a bit for more precise painting.

1. Display the Dab Options palette (shift-F4).

2. Use the Size slider to adjust the dab size to about 20 pix.

3. Set the Angle slider to 0º so that the dab is horizontal.

4. Adjust the Ratio slider to about 30%.

The skywriter brush is designed to angle the dab in the direction of your stroke. You 
need to change that to paint in the fireball.

1. Press Shift-F3 to display the Brush Options palette.

The skywriter brush clones the fire from the video layer into the paint layer.
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2. Click the Links button at the bottom of the palette. The Links drawer opens.

3. Click once on the Direction > Angle link, then click Delete.

You’ve finished modifications to the skywriter brush, try it out on the document 
window.

You have just created your own personalized skywriter brush. You may want to use 
it again in the future, so here’s how to save your custom brush:

1. Display the Brushes palette (F3).

Delete the Angle link from the skywriter brush.

Links
Button
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2. Choose Save Brush Variant from the pop-up at the top right of the Brushes 
palette.

Note: You can also 
save sets of your 
own custom 
brushes. (See 
“Saving Custom 
Brushes” on 
page 83.)

3. Choose an icon and enter a name for your new brush in the Brush Variant 
dialog box, then click OK. Your brush now appears with the other effects 
brushes in the pop-up at the top of the Brushes palette.

Finishing up
Once you have a skywriter brush you like you can complete the fire breathing effect.

1. Advance to the next frame and continue to paint in the fireball. Remember, the 
fire expands outward and upward from the Ric’s mouth.

2. Choose File> Save to save your work.

When you finish painting in the fireball, use the controls on the transport pal-
ette to preview your work. You can stop at any time, go to a specific frame and 
touch up your work.

To touch up the fireball:

■ Click the eraser icon to switch to erase paint mode, or press the “E” key on the 
keyboard. This removes the cloned fire on the paint layer, and also adds texture 
to the edges of the fireball.

■ Experiment with other settings in the Brush Options palette for variation. 
(Hint: Use the Opacity setting to dilute the black background to gray at the 
edges of the fireball.)

When finished, choose File> Make Movie… to export the project to a stand-alone 
movie file. You can choose a frame range and a compression setting in the Make 
Movie dialog box. Click Make to create the movie file.

Save your new fire brush for later use.
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By cloning the fire video to the paint layer you can experiment with different fire 
variations without affecting the underlying video files. Exporting the project 
combines all layers into a single flattened movie file.

Tutorial Three

In tutorial three you’ll work with two layers, apply an effect on a paint layer, apply 
a key to create an alpha channel, and then combine layers using the blend stack.

Close any document you may have open.

1. Choose File> New to start a new project.

2. In the New Project dialog, set frame size to 360 x 240, and set project duration 
and real time range to 30 frames.

3. Click OK. RotoDV opens a new project.

In the clouds
When you create a new project, RotoDV automatically creates a Paint layer in the 
Timeline Media Stack.

1. Click on the Paint layer to make it active.

2. Click once on frame 0 in the Paint layer.

Click once on the Paint layer in the Timeline to make it the active layer.
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Tutorial Three
3. Scroll to the last frame on the Paint layer and shift-click on it. You have now 
selected the entire range of frames in the Paint layer.

4. With the frames still selected, choose Effects> Apply QuickTime Effect. The 
QuickTime effects dialog appears.

5. In the scrollable list on the left side of the dialog, choose the Cloud effect. The 
sliders on the right control the rotation of the cloud through the range of 
frames—when both sliders match the cloud remains at a stationary angle. 
Experiment with the sliders to see how they control the cloud’s rotation. Return 
the sliders to the default settings (90º) and, click OK.

RotoDV goes to work and applies the cloud effect on each of the selected frames. 

Apply a Key
The next step is to remove the blue background by applying a color key. All frames 
in the paint layer stay selected after the cloud effect has been applied, so you don’t 
need to select them again.

1. Choose Effects> Apply Key. The Key filter dialog box appears with the color 
keyer selected.

QuickTime Select Effect... dialog box shows the settings for the cloud effect.
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2. Move the pointer over the document window and use the eyedropper to select 
the blue background for the key color.

If you have the preview box checked, the blue background disappears when 
you select the color.

3. Adjust the Tolerance and Softness sliders to soften the edges, but make the 
cloud as large as possible.

4. Click OK to apply the key to all the selected frames.

This removes the blue sky, but leaves the cloud. You can play the project in real-
time as soon as RotoDV finishes applying the key.

Import the Clip
Now you can import the video clip.

1. Choose File> Import Clip... from the File menu.

Use the dialog to locate and open the file RotoDV Application Folder/Tutorial 
Files/fish.mov.

Select the blue color near the corner to get the background color.
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Tutorial Three
2. The Clip Options dialog appears. Click OK to import the clip with the default 
settings.

RotoDV imports the fish clip into a new video layer.

Blend the Layers
Now you are going to blend the layers to create the effect of a fish in a cloud.

1. In the Timeline palette, click the new layer icon in the Blend Stack area.

2. Enter the name “Fish-Cloud” in the Name box

The double blend layer combines the fish and the cloud.
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3. Now click the Double Blend checkbox.

4. From the Blend pop-up select “Inside Alpha”.

5. From the top layer pop-up select “Layer 2 • Video”, from the lower layer pop-
up select “Layer 1 • Paint.

6. Click OK to create the blend layer.

Now your document window should show the effect of a fish projected onto a 
cloud.

Use the Transport palette’s controls to see how the combined layers look in motion.

Congratulations! You’ve finished the tutorial section of this manual. Please review 
the remaining chapters which describe RotoDV’s many features and controls in 
more detail.
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4 Climbing In and Out 
of a RotoDV Project

This chapter covers the basics of starting and saving a RotoDV project, including 
how to import video clips and other raw materials. This chapter includes file 
operations and describes how to deliver output when your project is finished.

Starting a New Project

When you launch the application, RotoDV presents the New Project dialog. (You 
can change this startup option in the Preferences dialog.) You can also open the 
New Project dialog by choosing File menu> New Project, or by typing 
Command-N on the keyboard. 
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Chapter 4      Climbing In and Out of a RotoDV Project
The specific options are described in the following sections. When you’re finished 
setting project options, click New to dismiss the dialog and create the specified 
project.

Frame Size
The Frame Size describes the number of pixels horizontally (x) by the number of 
lines vertically (y) in the document window. (The frame size is also called the 
resolution.)

You may enter values in the text fields, or choose a standard size from the pop-up 
menu. If you enable Lock Aspect ratio, RotoDV maintains the proportions when 
you edit either the width or height.

In most cases, you’ll choose the frame size based on your intended output format. In 
other cases, your source video might determine the frame size. 

Project Length
Your project length is constrained by disk space. The number of the live preview 
frames is constrained by available RAM. Remember that shorter projects will 
always be more manageable.

The New Project dialog.
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Starting a New Project
Duration
The total number of frames for your project. Maximum determined by free RAM 
or disk space. Once you create the project you cannot change this setting.

Note: The Real-
Time Range holds 
the composited 
view of all layers. It 
is this data that you 
view when playing a 
movie. For this 
reason, the Real-
Time Range is 
always in RAM, and 
is always real-time.

Real Time Range
The number of frames which will appear in the live preview range. The number of 
frames available for the Real Time Range is affected by the total duration of the 
project.

Cache Location
This pop-up lets you choose the volume to use for scratch files. Choose the fastest 
disk with the most space available.

Paint On Fields
RotoDV allows you to edit your project one field at a time with interlaced video 
fields. Video imagery will benefit from working in fields.

To open the new project with Field Mode on:

■ Check the Paint On Fields box.

RotoDV allows you to switch back and forth between working in the whole frame 
and in separate fields. You can save time by using Field Mode only where it provides 
benefit. You can also set the dominant field in this area. See Appendix B, “Field 
Rendering,” for more information on working with fields.

Background Color
The Background Color is the color beneath all other layers. The Background Color 
will show through at any point where there are no valid pixels in any of the movie, 
paint or object layers. For most video uses, black is the best choice. For animations, 
you might want white or a pastel “paper color.”
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To set the Background Color: 

■ Click the color chip. RotoDV presents the system’s color picker so you can 
choose a color. 

Adding Items to the Project

To import a clip:

1. Choose File> Import Clip. You can also press Command-I on the keyboard.

2. Use the dialog to locate and open a media item. You can import video clips and 
still images in any of the formats listed below.

3. The Clip Options dialog will open, where you can control various settings for 
your clip or still image. The Clip Options dialog is discussed below.

4. RotoDV creates a layer for the clip in the Media Stack and places the clip in the 
layer. This may take a while, depending on your project options, the length of 
the clip and other settings. The Media Stack is introduced on page 50. For more 
information, see “Layers in the Media Stack” on page 105.

Imported clips are placed in the media stack.
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Adding Items to the Project
Supported File Types
RotoDV can open any of the following file types.

When you save the project, RotoDV includes references to your original source 
material—not the data itself. This is an efficient use of disk space, but it means that 
you must maintain the original source files throughout the life of the project. Do not 
delete, move or rename any clip you are using in a RotoDV project.

Movie

■ AVI

■ DV

■ OpenDML

■ QuickTime

■ Animated GIF

■ FLC/FLI

■ PICS

Still Image

■ BMP

■ GIF

■ JPEG/JFIF

■ PICT

■ PNG

■ QuickTime Image

■ SGI

■ Targa

■ TIFF

■ Adobe Photoshop—files are 
opened “flattened”

■ 3DMF—opened as a 2D image
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Setting Clip Options
Note: For best 
results, all clips you 
use in a project 
should have the 
same frame rate 
and field 
dominance.

The top of the dialog provides the name of the clip and its size and rate details. The 
remainder of the dialog offers options for interpreting the data for use in the 
project.

In Point, Out Point and Duration
The In and Out Point Frames define the duration of the clip. You may not want to 
use the entire clip in the project. Set the In and Out Points to describe the portion of 
the clip you want to work on.

The Clip Options dialog offers options for interpreting the clip data for use in the project.

Sliding the In and Out markers in the Set Clip Options dialog determines which frames are included in 
the project. You can also enter values in the text boxes.
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Changing Project Settings
Alpha
Enable the Alpha checkbox if you want to use the clip’s alpha-channel data. The 
alpha masks the clip (controls visibility). 

■ None—This is the default setting. Leave the Alpha set for “None” unless you 
know the video clip contains an alpha channel.

Note: If you select 
Straight alpha, and 
the clip contains no 
alpha layer, the clip 
will not be visible in 
the project.

■ Straight—RotoDV uses the alpha data that came with the clip. 3D animations 
might include alpha data. And you might pre-process video in another 
application to develop the alpha. If you choose straight, but the clip has no 
alpha data, the clip will be fully transparent.

■ Invert checkbox— Sometimes it is easier to isolate a specific element by 
masking its surroundings with an alpha channel instead of the element itself. 
Because of this, it’s sometimes useful to be able to invert the area that is 
included in an alpha channel. To invert an alpha upon import, click this 
checkbox.

Changing Project Settings

During a project, you might need to change some of the basic project settings or 
preferences.

Project Settings
Several settings can be found in the Project Settings dialog box.

To change project settings:

1. Choose Edit> Project Settings. You can also click the Settings button on the 
Button Bar, or press Command-K on the keyboard.
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2. Use the Project Settings dialog to change the timeline thumbnail option, field 
mode options or background color. For more information, see below.

Thumbnail Options
This setting determines how thumbnails appear in the Timeline window.

■ None—Thumbnails do not display in the Timeline.

■ First and Last Frame—Only the first and last frame of the real time range 
appear in the Timeline.

■ Every Frame—Each frame in the real time range is represented by a thumbnail 
in the Timeline. This option may degrade playback speed.

Field Rendering
Working with fields in a project offers better temporal resolution for moving 
imagery. Use the Field Rendering option if you want to work with fields, not 
frames. Choose the field order that’s consistent with your video source material and 
video output system.

■ Paint On Fields unchecked—Each frame is treated as a full frame image. This is 
appropriate when your source is not interlaced.

■ First Field Dominant—The frame is treated as interlaced fields, with the upper 
field displayed before the lower, as in NTSC video.

Use the Project Settings dialog to change the settings of an existing project.
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Changing Project Settings
■ Second Field Dominant—The frame is treated as interlaced fields, with the 
lower field displayed before the upper, as in PAL video.

To take advantage of field rendering, you’ll need to work in Field Mode. For 
complete information on working with fields, see Appendix B: Field Rendering.

Background Color
This setting works just like the Background color option in the New Project dialog 
box. See “Background Color” on page 43 for complete details.

Changing the background color requires you to use the Render command to update 
the project. See “Manual Rendering” on page 110 for more information.

Preferences
The Preferences dialog box contains the disk cache location setting and other 
RotoDV workflow settings.

To change the disk cache location:

1. Choose Edit> Preferences.

2. Select a new location for the disk cache from the pop-up at the bottom of the 
dialog box. Choose the fastest disk with the most free space available.

3. Quit and restart RotoDV to use the new disk cache location.

Select a volume for scratch files in the Preferences dialog box.
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Other workflow options available in the Preferences dialog box:

■ Show Tool Tips—When checked, tool labels appear when the pointer rests on a 
tool or mode button.

■ Live Window Dragging—When checked, window contents remain visible while 
dragging.

■ When Starting Up—Turn off the “New Project on Start-up” option here. Takes 
effect after you quit and restart RotoDV.

Opening an Existing File or Project

After you’ve saved a RotoDV project, you can reopen it and resume working. 

Note: RotoDV 
allows you to have 
only one project 
open at a time.

To open a saved RotoDV project: 

Choose File> Open or press Command-O on they keyboard. Use the dialog to 
locate and open the RotoDV project file you want.

Note: Important: 
Source clips 
(movies and stills) 
are retained only as 
references in the 
RotoDV project file. 
You must not 
delete, move or 
rename any source 
item used in the 
project. 

Introduction to the Project Timeline

Every RotoDV project has a Media Stack which contains at least one paint layer 
and any layers you have created to hold imported video clips. The combined video 
that appears in the document window depends on the order and contents of the 
layers. If your project requires that the layers interact in more complex ways, you 
can add layers to the Blend Stack. A project with Blend layers requires more 
memory and disk space. Use the controls in the Timeline to switch between viewing 
the Media Stack and the Blend Stack.

■ The Media Stack lists all paint and video layers in the project. These layers are 
the building blocks of your composition. Use the Media Stack to create imagery 
and control sources. If the project has no Blend layers, the order of the Media 
stack determines the output.

■ The Blend Stack arranges layers from the Media Stack in logical relationships, 
like one layer matting the visibility of another. If the project has Blend layers, 
then the Blend Stack determines your final output.
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Introduction to the Project Timeline
Note: Remember, 
if you don’t create 
any layers in the 
blend stack, then 
the output is 
determined by the 
layer order of the 
Media stack.

As you work, you can switch the document window between displaying the Media 
Stack and displaying the Blend Stack. The two views may be quite different. For 
example, the order of layers in the Media Stack doesn’t influence the display order 
of the Blend. This means you can change the order of layers for output purposes 
without affecting the result of the blend.

In Chapter 8, “Layers and Time,” you’ll find complete information on the Timeline 
window and the Media and Blend Stacks. 

Real-Time Range
The Real-Time Range defines the section of your project that is available for real-
time playback. RotoDV accomplishes full-speed playback of your project by 
loading frames of the composited image into RAM. The number of frames you can 
load and play will depend on the amount of RAM you have available. 

When you start a project, you set the Real-Time Range. You can play through this 
range and begin developing imagery here. If your project is longer and you want to 
play through a later section, you can adjust the Real-Time Range.

The Timeline displays thumbnails of clips in both the Media and Blend Stacks.
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To adjust the Real-Time Range:

Select Edit>Set Real-Time Range. You can also click on the Range button on the 
Button Bar, or type Command-Option-R on the keyboard. Type frame numbers into 
the In Point and Out Point boxes provided.

When you adjust the Real-Time Range, RotoDV must load this new set of frames 
into RAM. You’ll have to wait a few moments before you can play and continue 
working.

AutoSpool
If your real time range is shorter than the total project duration, the real time range 
advances as you step forward with the arrow keys or the step buttons on the 
Transport palette. This insures that the real time range always contains the current 
frame as you step forward, frame by frame, to edit your project.

Moving Through Time
The Timeline has a Current Frame Indicator that shows which frame you’re on. The 
current frame is also listed in a SMPTE readout in the Transport palette. The 
Timeline window automatically updates to show the frame which is currently 
displayed in the document window.

The primary tools for moving through time are on the Transport palette. The 
Timeline also provides some methods for moving to other frames:

■ You can drag the triangular top of the current frame indicator.

■ You can click on the thumbnail image of the frame you want.

The Set Real Time Range dialog box lets you control the live playback range.
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The Document Window
■ You can drag the slider at the bottom of the Timeline window and scrub back 
and forth for a real-time flip book effect. This is a handy way to preview video 
at thumbnail size.

The Document Window

The document window displays the image content of your project. It’s where you 
paint and do all your editing. At any moment, the document window displays either 
the Media Stack or the Blend Stack. You can toggle between the stacks as needed.

To set the document window view:

Click the stack label in the timeline window to activate a particular stack.

Media View displays the combined layers in the Media Stack. See “Layers in the 
Media Stack” on page 105.

Blend View displays the results of combining layers in the Blend stack. See 
“Creating a Blend Stack” on page 111 for details.

Safe Regions 

The Safe Regions option displays two margin rectangles to indicate the outer 
portions of the frame. Imagery outside this rectangle may not display correctly on 
some TVs or video monitors. Using the Safe Regions reference can help you avoid 
putting important detail where it may be distorted or cut off.

The Safe Regions option displays a margin rectangle.

Action Safe

Title Safe
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■ The inner rectangle is the title safe area where text will display accurately, while 
the outer rectangle defines the action safe area.

To control Safe Regions reference display, click the Safe Regions button in the 
Transport palette to toggle the display.

Zooming in on the Document Window

Sometimes you’ll want to magnify an area to make painting or selecting easier. 

Changing the view with the Zoom Tool

1. Choose the Zoom tool from the Tools palette (see “The Tools Palette” on 
page 72). You can also select the Zoom tool by pressing the Z key.

2. Click on the spot you want to magnify. 

■ Hold down the Option key and click to zoom out.

■ Double-click the Zoom tool in the Tools Palette to return the view to 
100%.

Panning with the Hand Tool

After you’ve zoomed in, you may need to move around the frame, a process called 
“panning.” To do this, you’ll use the Hand tool or the scroll bars in the document 
window.

1. Choose the Hand tool from the Tools palette (see “The Tools Palette” on 
page 72). You can temporarily select the Hand tool by holding down the H key.

2. In the project window, drag the image to bring the area of interest into view.

Saving the Project

Saving a RotoDV project preserves the contents of all your layers and Timeline 
information. However, keep in mind that source media (movies and stills) are 
retained only as references in the RotoDV project file. You must not delete, move or 
rename any source item used in the project. 
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Exporting the Project
Note: See 
“Making a Movie” 
on page 55 for 
information on 
exporting a movie 
file of the project 
that will be suitable 
for other programs.

Save
Choose File> Save to write the current project to disk, or press Command-S on the 
keyboard. If this project has never been saved, this command triggers Save As.

When you save the project, RotoDV includes references to your original source 
movies—not the movie data itself. This is an efficient use of disk space, but it means 
that you must maintain the original source files throughout the project. Again, do 
not delete, move or rename any movie clip you are using in a RotoDV project.

Save As...
Choose File>Save As... when you want to save the project under a different name. 
You can also choose Save As.. by pressing Shift-Command-S on the keyboard. 

Close
File>Close closes the current project. You can also press Command-W on the 
keyboard to close the project. If the document has unsaved changes, you are asked 
to save it, discard changes, or cancel the command.

Exporting the Project

When it’s time for your creations to leave RotoDV, you’ll use the Make Movie 
command. 

Making a Movie
The Make Movie command is useful for delivering your RotoDV project to other 
QuickTime applications. You can use it to export a fully flattened version of the 
project. 
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To export a QuickTime movie:

Note: If you have 
created Blend 
layers, but the 
Media stack is 
selected in the 
Timeline window, 
only the media 
stack is exported to 
the movie file.

1. Set up either the Media Stack or the Blend Stack to create your desired output. 
If you don’t have a Blend Stack, RotoDV will export the Media Stack.

■ Only layers that are visible will be included in the exported file.

■ If you want the exported movie to include an alpha channel, you’ll need to 
set this up in the Blend Stack (see “Alpha” on page 57).

2. Make sure the correct stack is selected in the Timeline.

3. Click the Make Movie button on the Button Bar. You can also select Make 

Movie from the File menu, or type Command-M on the keyboard. 

RotoDV displays the Make Movie dialog, described below, where you can set 
your options for the output.

4. When you’re finished setting options, click the Make button to create the 
movie.

In Point and Out Point 

The three radio buttons at the left offer three options for setting the range of frames 
to include in the output movie—Live Playback Range, Project Range and Custom. 
The first two options depend on the settings in the Timeline window. Selecting 
either option displays the In Point and Out Point fields at the right.

If you choose Custom, use the In Point and Out Point text fields to specify the range 
of frames you want.

Use File> Make Movie to export a project.
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Alpha

Note: You must 
export to a file 
format that retains 
alpha data. Only the 
“None” and 
“Animation” 
compression 
options support 
Alpha layers.

Enable the Alpha option if you want the output clip to include alpha data. The 
alpha mask will be significant only if the composite of all visible Blend layers leaves 
some portion of the background color visible.

■ Straight—RotoDV creates the output alpha from the Blend Stack.

■ Premultiplied—RotoDV creates the output alpha from the Blend Stack. 
RotoDV also shifts the colors of any pixels whose alpha is not 100% toward 
the “premultiply color.” You can set the premultiply color here using the color 
chip. Black is typically used. This technique can be useful for avoiding artifacts 
along the perimeter.

Enable the Invert option if you want to invert the alpha data. You might need to do 
this if the next application you’ll use with the movie considers the alpha differently.

Compression
The current file format settings are listed beside the Compression button. 
Compression helps you achieve an optimum relationship between image quality and 
file size/data rate.

To set the file format:

In the Make Movie dialog, click the Compression button.

Use the Compression Settings dialog, described below, to set the format, quality 
level, and other options.
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When you’re done setting compression options, click OK to dismiss the dialog.

Compression Settings

Note: It’s 
important to note 
that only a few 
compression 
formats support 32-
bit pixels — color 
and an alpha 
channel.

The Compressor pop-up lets you choose a compression format. Most of the 
available formats are part of QuickTime. You may have additional formats to 
support other software or hardware you have installed. 

Of the formats, the most useful are as follows:

■ None—Frames are stored without compression, maintaining pristine image 
quality. This is the preferred format when transferring the output to 
another program for further compositing or editing work. Resulting file 
sizes can be quite large. 

■ Cinepak—Designed for CD-ROM delivery, this format offers decent 
quality at relatively high frame rates. This is an asymmetric format—it 
takes far longer to compress than to play back. It’s not recommended for 
large frame sizes.

■ Animation—Animation is a useful choice for painted or object imagery, not 
video. It won’t maintain high rates at large frame sizes, but it might be 
useful for smaller sizes or for transferring material to other programs.

You can find detailed descriptions of the other software compression formats at 
the Apple Computer’s QuickTime web site. Many of these formats compromise 

The Compression Settings dialog.
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image quality for disk playback speed and, as such, aren’t appropriate for most 
of the work you’ll do in RotoDV.

Color Level and Alpha Channel

The Color Level pop-up lets you choose how much color information is saved for 
each pixel. Some compression formats support only one color level, and you don’t 
have a choice. For other formats, you can choose from limited colors, Grayscale, 
Thousands, or Millions of colors.

If you want the output file to include alpha data, you must choose the “Millions of 
colors+” color level. “Millions of colors” means the pixels have 24 bits of color, 
and the appended “+” means the pixels also have an alpha channel, yielding 32-bit 
pixels in the output file. 

Quality

The Quality slider lets you adjust the amount of compression. The higher the 
compression ratio, the smaller the file, but the lower image quality. Some formats 
don’t allow adjustment. For example, “None” uses no compression, so the Quality 
slider has no effect.

Frames per Second

Choose a frame rate that is appropriate to the material and the delivery platform. 
Material that will be played only on a computer can be effective at lower rates. 
Material destined for video output should be in the frame rate of the video standard 
(NTSC, PAL, HDTV, etc.) you are using.

Key frame Every ___ Frames

This setting adjusts the amount of temporal (time-based) compression. It is only 
relevant for compression formats that use temporal compression, such as Sorenson 
Video or Cinepak. If you want to use temporal compression, enable this option and 
set a value for the rate of producing keyframes.

Keyframes are frames that are stored in their entirety. Between keyframes, a 
temporal compression format stores only the changes since the last key. Frequent 
keyframes keep quality high, while keys set far apart may let quality slip on fast-
moving material.
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Limit Data Rate to __ K/Second

Limiting the data rate is an alternative to the Quality slider, described above. This 
feature is supported by only a few compression formats.

By enabling and setting a data rate limit, a compression format adjusts the 
compression level dynamically (frame to frame) to maintain a steady data rate. This 
is advantageous when the accelerated video system can maintain real-time playback 
up to a certain data rate. For example, if your hard disk can sustain a transfer rate 
of 4.5 MB/second, you can set the data rate limit just below this level. This ensures 
you’ll get the best compression ratio (Quality setting) possible within that data rate. 
Compression acceleration hardware performs better when the data rate is constant.

When the Quality slider is used instead of limiting the data rate, the amount of data 
used to store the frames may vary, depending on the image content. When the data 
rate jumps up, the system might “stumble” and drop frames. In most cases, you’d 
want to avoid this.

Saving the Movie
Clicking the Make button opens a dialog that asks you to provide a disk location 
and name for the file to be created. 

To set the file name and disk location:

1. Click the Make button.

RotoDV opens a standard Save dialog.

2. Use the file system controls to choose a disk location.

3. Type in the file name you want.

These settings persist, so that each time you use Make Movie, RotoDV will replace 
the previous version of the file. This helps use disk space efficiently. RotoDV will 
alert you before overwriting a file, in case you’d like to cancel and preserve the old 
file by changing the name of the output file.

When you’re done with the Save dialog, click Save to begin the file rendering.
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5 Navigating Time 
and the Frame

The Transport Palette

The Transport palette provides the controls for moving through time and changing 
your view within the frame. It also provides controls for working in the document 
window and other related features.

The Transport palette.
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Chapter 5      Navigating Time and the Frame
About the Real-Time Range
RotoDV accomplishes full-speed playback of your project by loading frames into 
RAM. The number of frames you can load and play will depend on the amount of 
RAM you have available. This set of frames that RotoDV loads and can play at full 
speed is called the Real-Time Range. 

Playing, looping, rewinding and the other transport controls operate within the 
domain of the Real-Time Range.

Optimizing Playback Capabilities
A number of factors influence your playback speed. The following suggestions will 
help you get the most out of RotoDV’s real-time playback:

■ Keep palettes off the document window. Any palette that overlaps the 
document window increases processing overhead. The system must mask out 
that region of video and replace it with the palette image. This results in delay 
that can impact your playback rate.

■ Disable unnecessary system extensions. Some background programs poll the 
system occasionally to see if they’re needed. This can put a hitch in the 
playback and cause you to miss a frame. Networking (like AppleTalk) and 
screen-saver programs fall into this category.

■ Use a fast processor. Faster computers can pass the data from memory to 
display more quickly. Refer to “System Requirements” on page 15 for 
suggestions.

■ Use a high-performance display system. The video graphics card that drives 
your monitor can make a huge difference in performance.
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The Transport Palette
The Transport Palette
The Transport palette provides control over movie play functions, including speed 
control and basics like frame-forward, rewind and jog/shuttle. The Transport 
palette also has features that let you record your painting actions and set options for 
how your work is carried forward in time.

Current Frame and Field
Note: The FIeld 
mode button 
(page 66) activates 
Paint on Field mode 
and adds a field 
indicator to the 
Timecode display.

The current frame is shown in the SMPTE Timecode field.

To the right of the timecode display, you’ll find an indicator of the current field:

■ 1—The first field is displayed.

■ 2—The second field is displayed.

■ No Indicator–Field mode is off – the whole frame is displayed.

The field display is only present when working in Field Mode. In this case, two 
Frame Advances are necessary (one for each field) to move to the next frame. See 
Appendix B for more on field rendering.

The Transport palette.

Playmode

Transport

Frame rate

Shuttle

Record

controls

Scrub

Timecode

Jog

Safe Regions

Field Mode Auto Paint
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Play Mode
The Play Mode button has three states:

Forward—Play to the end of the range and stop.

Loop—Play forward through the range, repeated continually.

Back and Forth—Play forward, then reverse continually.

The Transport Controls 
The Transport buttons provide the basic controls for moving through the frames.

Record (round button to left of timecode)—Record your painting as the movie 
plays. For more information, see “Painting While the Movie Plays” on page 118.

(Working in from the ends)

Start/End—Go to the first/last frame of the range. On the keyboard, press 
Option-left arrow/Option-right arrow keys.

Fast Reverse/Fast Forward—Play in reverse/forward quickly. Stop at the beginning/
end of range.

Note: You can also 
move to a particular 
frame by clicking its 
thumbnail in the 
Timeline window.

Frame Back/Frame Forward—Step back/forward one frame. Pressing the
left/right arrow keys on the keyboard will yield the same result.

Play/Pause—Play through the range using the current setting of the Play Cycle. 
During play, the icon turns into a Pause button. Pressing the Spacebar will toggle 
between Play and Pause.

The Transport controls.

Start End

Fast Reverse Fast forward

Frame Back Frame Forward

Play/Pause
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The Transport Palette
Shuttle, Jog and Scrub
The Shuttle, Jog and Scrub controls let you move through the frames of your project 
in various ways.

Shuttle— This control functions as an indicator while the project is playing. You 
can drag the slider to go to any location in the Real-Time Range. Shuttling is bi-
directional—you control the direction and speed of play by dragging the slider.

Jog— Move backward or forward through the Real-Time Range. Accelerate 
playback by dragging farther toward either end.

Scrub— The Scrub control directly links mouse movement to frame movement. 
Small motions advance a few frames forward or backward, large motions advance 
many frames.

Frame Controls
Use the buttons in the frame control area to access RotoDV’s frame editing features.

Safe Regions
The Safe Regions button toggles display of the Safe Regions overlay. The overlay 
displays the center point and pair of margin rectangles to indicate the outer portions 
of the frame, which may not be safe for putting text or important imagery. Using 
the Safe Regions reference can help you avoid putting important details where they 
may be warped or cut off. For more on safe regions, see page 53.

The Shuttle, Jog, and Scrub controls.

Transport frame controls.
65



Chapter 5      Navigating Time and the Frame
Field Mode
The Field Mode button toggles between frames and fields. When you want your 
painting and editing to apply to fields, enable Field Mode by clicking the Field 
Mode button. In Field Mode, each “Frame Advance” moves forward one field. The 
current field is indicated to the right of the SMPTE readout.

Frame Mode—The document window displays both fields in the same frame.

Field Mode—The document window displays one field of the current frame. The 
field number appears at the right of the timecode display.

Auto Paint
Note:  Auto Paint 
options apply to 
work you do with 
the Brush tools in 
Paint, or Clone 
mode. 

This option lets you carry paint you apply forward through the next frames. 
Copying paint forward is useful in many circumstances, particularly when you want 
paint you apply to persist through subsequent frames.

Auto paint copies forward paint applied by:

■ Painting with a brush

■ Pasting onto the frame

■ Dropping a selection by Option-clicking

Using Auto Paint

In the Transport palette, click the Auto Paint button to turn on Auto Paint. You can 
also activate Auto Paint by pressing Command-B on the keyboard.

Note: The Auto 
Paint function will 
copy paint from one 
frame to the next 
when you advance 
frames with the 
Right Arrow key, 
with the Frame 
Forward button on 
the Transport 
palette, or by 
clicking the Record 
button and pressing 
Play.

■ Auto Paint On —Paint you apply in this pass is carried forward to 
subsequent frames. Paint applied earlier is not included. 

1. Paint, paste, or drop paint onto the frame.

2. Click the Transport Palette: Frame Forward button. Your applied paint is auto-
matically copied to the next frame.

3. Apply more paint and continue stepping forward to “grow” the painted region.

4. When you’re finished carrying the paint forward, click the Auto Paint button to 
turn Auto Paint off.
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The Transport Palette
Frame Rate
The frame rate sets the movie’s playing speed. Choose the rate you want from the 
pop-up. You can choose a lower rate to slow the movie down, which can make 
painting easier.

Info Palette
The Info palette provides a technical readout of useful information.

RGB: These values describe the Red, Green and Blue components of the color that 
is beneath the Eyedropper cursor.

A: This value describes the alpha component of the color that is beneath the 
Eyedropper tool.

HSL: These values describe the Hue, Saturation and Lightness of the color that is 
currently beneath the eyedropper cursor.

X, Y: These values describe the coordinate location of the cursor. The origin (0, 0) is 
at the top left corner.

W, H: These values describe the width and height of any rectangular selection you 
make.

Actual FPS: This value reports the actual frame rate (frames per second) achieved 
during playback. When working with a large frame size on some systems, this rate 
might be lower than the movie’s actual rate. 

The Info palette.
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Lightbox Palette
RotoDV’s Lightbox feature lets you work using the onion-skinning technique of a 
traditional cel animator. When the Lightbox is turned on, the document window 
displays the current frame, with subsequent and previous frames appearing in a 
ghosted overlay. 

This ghosted overlay lets you paint the current frame using the preceding and 
following frames as a reference. This is more useful when creating animations from 
scratch than when painting over video.

You’ll use the Lightbox palette to turn the feature on and off and to set the number 
of adjacent frames to include in the overlay. 

Click the light icon to enable/disable the Lightbox.

Frames Back determines how many preceding frames should be included in the 
Lightbox overlay. 

Frames Forward determines how many subsequent frames should be included in the 
Lightbox overlay. 

Opacity sets the opacity dropoff for the first of the overlaid frames.

Fade sets the opacity dropoff (from the first) of each subsequent overlay image. 

The Lightbox palette controls the onion skinning feature.
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The Transport Palette
Clone Palette
The Clone palette provides some special controls for using a cloning brush. Cloning 
lets you sample imagery from one layer and location and paint with it in another. 
The Clone palette is described in “Cloning” on page 121.

The Clone palette
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6 Reaching into 
the Toolbox

About RotoDV’s Tools

RotoDV has a full set of paint, selection, manipulation and navigation tools. These 
tools are similar to those found in other programs, and most artists will recognize 
them immediately.
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Chapter 6      Reaching into the Toolbox
The Tools Palette

This section provides an overview of RotoDV’s tools. Follow the cross references 
for detailed information on tool options or usage.

The behavior of a tool may depend on the type of layer currently selected. For 
example, paint tools only work in paint layers. Selection tools can select and copy in 
video layers, but can cut and paste only in paint layers.

The Tools palette provides access to the tools.

Pointer

Eyedropper

Zoom

Paint ToolsQuick Preview

Hand

Marquee

Lasso

Current Color

Current Dab

Paint Mode Clone Paint Mode

Erase Paint Mode
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The Tools Palette
Selection Tools

Selection tools help you isolate areas of imagery for editing and to control effects. 
Selection tools work in paint and video layers.

To select a selection tool from the keyboard:

■ Press M for the Marquee tool

■ Press L for the Lasso tool

■ Press Q for the Quick Preview tool

For information on setting options for selection tools, see page 79.

For information on taking advantage of selections, see “Selecting and Editing 
Paint” on page 124.

Marquee
Drag in the document to create a rectangular selection.

Lasso
Draw a freehand path around the area you want to select. When you let go, 
RotoDV closes the path and creates the selection.

Quick Preview
The Quick Preview tool allows you to restrict the full motion preview to a selected 
area in the preview window. This is helpful when your system is unable to display 
full-sized frames at full speed.

The Selection tools allow you to select an area for manipulation.

Quick Preview

Marquee

Lasso
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Chapter 6      Reaching into the Toolbox
In the document window, use the Quick Preview tool to drag a selection rectangle 
over the area of interest. You can now play and preview the “boxed region” at 
better frame rates. When you’ve finished, click in the document window to remove 
the preview region.

Manipulation Tools

Use the manipulation tools for painting and working with images in paint layers.

To select a manipulation tool from the keyboard:

■ Press V for the Move tool

■ Press I for the Eyedropper tool

■ Press B for the Paint (brush) tool

Move
The Move tool, is used to move, and manipulate paint selections.

■ Click and drag in a selection with the Move tool to move the selected imagery.

■ Option-click in a selection with the Move tool to stamp the selection onto the 
active paint layer without de-selecting.

Eyedropper Tool
The Eyedropper samples color from the preview window, making it the selected 
color for painting.

Click on the color you want to sample. The new color appears in the current color 
box on the Tools palette.

The manipulation tools help you apply and manipulate paint.

Pointer

Eyedropper

Paint Tools
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The Tools Palette
Paint Tools and Brush Types

The paint tool icon that appears on the Tools palette depends on which brush was 
most recently selected. 

To select a Brush from the Tools palette:

■ Click and hold the Paint tool icon.

■ Select the desired Brush icon from the brush pop-up.

Painting tools work only with pixels in paint layers. They apply and remove color, 
or cloned images in the selected layer. RotoDV has several different types of 
brushes, each with its own characteristics. Each Brush Type can have several 
variants, and you can save custom variants as well. See Chapter 7 for more 
information on customizing Brushes. A table describing the standard paint tools 
appears on the next page.
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Note: All of the 
factory standard 
tools listed here are 
simply pre-set 
variants of 
RotoDV’s multi-
purpose brush tool. 
You can modify 
these tool in 
countless ways and 
save custom 
brushes and brush 
sets. See Chapter 
7 for more 
information.

Tool Description

Paintbrush: Lets you stroke in the document window to apply or remove 
color or cloned material.

Airbrush: Simulates a traditional airbrush by spraying color gradually onto a 
frame. The edges of an airbrush stroke are more diffuse than those drawn 
with the paintbrush tool. When used with a pressure-sensitive tablet, addi-
tional pressure generally yields more paint.

Chalk: Modeled after traditional artists chalks, draws a slightly thicker line 
than the pencil, with slightly rough edges.

Pencil: Works like a pencil, draws thin lines in the selected color.

Ink Pen: Behaves like a pen. Draws somewhat thicker lines than the pencil 
tool, with feathered edges.

Watercolor: Has the effect of using a brush dipped in water on wet paint, 
makes paint run and distort.

Smudge: Works like dragging a finger through wet paint—picks up the color 
of the first pixel you click on and pushes it in the direction you drag.

Dodge: Lightens the area to which you apply it.

Burn: Darkens the area to which you apply it.

Colorize: Changes the color of paint that’s already been applied to the cur-
rently selected color.

Hilite: Tints applied paint a color that is the difference between the applied 
paint and the currently selected color. Try it out to see for yourself.

Effects Brush: A collection of special brushes that simulate effects like fire, 
rain, bubbles and several others. Select the desired effects brush from the 
Brushes Palette. See “Effects Brushes” on page 83 for more information.
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The Tools Palette
Frame View Tools

The two frame view tools, Zoom and Hand, allow you to zoom in and pan across 
the document. Pan control is also available with the scroll bars on the document 
window.

To select a frame view tool from the keyboard:

■ Press H for the Hand tool

■ Press Z for the Zoom tool

Hand
Drag in the document to bring other regions into view (panning). The hand is valid 
when the document window shows a subset of the frame—for example, when 
zoomed in.

Zoom
Click on the area you want to zoom in on to increase magnification by a factor of 
two. You can also press the Z key on the keyboard to select the zoom tool.

■ Option-click with the Zoom tool in the document window to zoom out 
(decrease magnification).

■ Double-click the Zoom tool icon in the Tools palette to return the 
magnification to 100%.

Use the frame view tools to zoom and pan in the preview window.

ZoomHand
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Color and Dab

The Tools palette includes two indicator areas which show the currently selected 
color and dab.

■ Click the color or dab box to select a color or dab from the current color set or 
dab set.

These sets are selected with the Swatches and Dabs palettes. See “Swatches Palette” 
on page 96 for more information on color sets and “The Dabs Palette” on page 91 
for more information on Dabs.

Paint Modes

You can switch between RotoDV’s three different paint modes with the paint mode 
buttons. The buttons also act as an indicator to show which paint mode is currently 
active.

To select a paint mode from the keyboard:

■ Press C for Paint (color) mode

■ Press E for Erase mode

■ Press S for Clone mode (for Sheep)

The color and dab areas show current settings.

Select a paint mode with the bottom buttons on the Tools palette.

Current Color

Current Dab

Paint Mode Clone Mode

Erase Mode
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The Tool Options Palette
Paint
This is the standard paint mode. The currently selected color is applied with the 
chosen brush.

Erase
Use Erase mode when you want to remove pixels rather than apply them. Erase 
mode uses the currently selected brush to remove paint instead of applying it. 
Erasing “wears down” the paint in the currently selected paint layer, so that 
underlying layers begin to show through. Use the Tool Options palette’s Opacity 
slider to control how much paint is removed by the selected brush.

Clone
Select Clone mode when you want to “paint” imagery from one source layer to the 
current layer. To use Clone mode you must first select a Clone source layer from the 
Clone palette. Once you set up the source, use the selected brush to paint the source 
imagery into the current layer. You can find more information on Clone mode in 
“Cloning” on page 121.

See Chapter 9 for complete information on using RotoDV’s paint modes.

The Tool Options Palette

Use the Tool options palette to quickly access frequently used tool options from one 
location. Options only appear in this palette for the Brush, Marquee and Lasso 
tools.

The Tool Options palette as it appears with different tools selected.

Marquee or Lasso selectedPaint tool selected
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Option for Marquee and Lasso Tools:

■ Feather

Feathering describes the width of the transition at the selection border. The setting 
is the number of pixels across which the selection fades from 100% selected to zero. 

Options for Paint tools:

■ Opacity

The Opacity slider controls the density of the media applied in each stroke. 
This control also appears on the Brush Options palette, see “The Brush Options 
Palette” on page 84 for more information.

■ Size

The Size slider scales the dab. Use it to change the size of a brush. 

■ Softness

The Softness slider controls how the dab edge blends with the background. 
More softness produces a more blended edge.

The Size and Softness controls also appear on the Dab Options palette; see “The 
Dab Options Palette” on page 92 for more information.

As feathering increases, edges on the selection become softer. 
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7 Brushes, Dabs, and 
Colors

About Brushes, Dabs, Colors and Sets

RotoDV is designed to allow you to work using your own custom brushes. When 
you’ve adjusted a brush the way you like it, you can save it as a new brush. That 
custom brush is always at hand, so you can easily retrieve and use it.

Brushes consist of a dab which describes shape, and a brush which defines behavior. 
Both the brush and the dab have a set of options which you can adjust to create a 
tool that paints exactly the way you want.

Once you have the right brush you’ll want the right paint. RotoDV lets you define 
colors with RGB values or with the HLS color picker.

And to help manage all of the tools and colors you’ll create, RotoDV offers sets—
collections of saved brushes, dabs and colors. Most artists will build sets based on 
production tasks or on a per-project basis. You can easily switch between several 
sets, so your favorite tool is never far.
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The Brushes Palette

Custom brushes streamline the workflow, saving time and ensuring consistency 
throughout the project. To keep your custom brushes organized, RotoDV lets you 
organize them in sets. You can load multiple sets and switch between them as 
needed, so it’s easy to have a lot of tools readily available.

Each brush set consists of several brush types represented by tool icons. Each brush 
type can have several variants. The pop-up menus on the Brushes palette let you 
choose the brush type, the variant (if more than one exists for that brush type) and 
the set.

Some brushes have several variants associated with them, such as the effects brush 
included in the Factory Brushes set.

To choose a brush variant:

1. On the Brushes palette, click on the brush icon that contains the desired vari-
ant, or choose the type from the Brush Type pop-up.

2. Choose the desired brush variant from the Variant pop-up.

Selecting a variant for a brush type in the Brushes palette associates the variant with 
the tool type icon. For example, if you select the Rain variant of the Effects brush 
type, then change to the Paintbrush, selecting the Effects Brush icon from the Tools 
palette loads the Rain brush again.

The Brushes palette is the hub for selecting brushes and saving them in sets.

Available Brush type

Brush Sets

The Brush Commands
 pop-up holds commands
 for saving custom brushes
 and managing brush sets.

Brush type
Variant

Save Brush Variant and
Delete Brush Variant
82



The Brushes Palette
Effects Brushes
The Factory Brushes set comes with a special set of variants to the FX Brush. The 
FX Brush variants are all created with Links (see “Brush Links” on page 87). These 
brushes let you paint special effects in your project. The effects include things like 
fire, grass, rain, bubbles and more. Check out these brush variants and their links, 
they’re one of RotoDV’s most fun features!

Saving Custom Brushes
After you’ve adjusted a brush the way you want it, you can save the changes to a 
custom brush. The features for customizing brush behavior are described starting 
on page 84. 

To save a custom brush:

Note: Remember 
that you first set up 
the tool the way 
you want, then save 
it. You can’t change 
it later, but you can 
make a new tool 
based on a 
previously saved 
one.

1. First, make any adjustments to the brush options and dab.

2. On the Brushes palette, choose Save Brush Variant…from the Brush Com-
mands pop-up. 

3. Name the tool and choose an icon in the Brush Variant window that appears. 
Remember, the icon determines which brush type your new brush is associated 
with (your new brush will show up in that tool’s Variant pop-up).

4. Click OK to create your new Brush.

RotoDV uses the current settings to build a new brush and add it to the current 
brush set.

Switching between brush sets
To better manage the tools you create, you’ll want to keep them in sets. You can 
have several brush sets open and switch between them using the pop-up on the 
Brushes palette.
83



Chapter 7      Brushes, Dabs, and Colors
Note: If you want 
particular Brush 
Sets loaded 
automatically when 
RotoDV launches, 
place these Brush 
Set files in the 
Brushes folder 
inside the RotoDV 
application folder. 
Everything in the 
Brushes, Dabs, and 
Colors folders is 
loaded 
automatically on 
launch, so you can 
change the default 
Brush, Dab, and 
Color Sets by 
managing the 
contents of these 
folders.

Brush sets are stored in files. You can save, open and close sets as needed. The 
commands for these operations and other management tasks are on the Brush 
Commands pop-up, described below. 

Brush Commands
The Brush Commands pop-up has the commands for saving custom brushes and 
managing brush sets. Management tasks include deleting brushes from a set, 
changing tool icons, and grouping tools.

New Brush Set creates a new, empty brush set. 

Open Brush Set... loads a saved tool set into the Brush Set pop-up. Brush Sets that 
are located in the Brushes folder inside the RotoDV application folder will be 
loaded into the pop-up automatically.

Close Brush Set removes the current tool set.

Save Brush Set opens a dialog so you can save the current tool set.

Save Brush Set As... opens a dialog so you can save the current tool set under a 
different name.

Save Brush Variant… opens the Brush Variant dialog box so you can name your 
new brush and choose an icon.

Delete Brush Variant removes a tool from the current set.

Rename Brush Variant… opens the Brush Variant dialog box so you can rename 
the selected brush.

The Brush Options Palette

You can adjust the brush options to change the behavior of the brush. These 
changes are temporary unless you use the commands on the Brushes palette to save 
a new brush, as discussed in the last section.
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The Brush Options Palette
Note: The Brush 
Tool options are 
distinct from the 
dab options, set in 
the Dab Options 
palette; however, all 
of these settings 
are included when 
you save a new 
Brush Tool.

The Brush Options palette contains controls that describe how the dab is pulled 
along the stroke path.

Brush Controls

Opacity
Opacity controls the density of the media applied in each stroke. 

Preserve Transparency
The Preserve Transparency option causes the brush to operate only on pixels with 
non-zero alpha values. Enable Preserve Transparency to create a brush that alters 
existing color, rather than laying down new color.

Clamp
The Clamp option limits the opacity applied in the stroke. When Clamp is enabled, 
a single stroke, doubled back over the same area, will not increase opacity beyond 
the Opacity slider setting.

The Brush Options palette provides control over brush stroke characteristics.

Links Drawer
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Blend Mode
The Blending Mode controls how the media reacts with underlying colors. Different 
blending modes lead to diverse results when you paint, such as the difference 
between felt pens and spray paint.

Blend modes are available for several RotoDV features. See Appendix  “A” for 
descriptions. 

Spacing
Spacing describes how closely the dab shape is repeated along the stroke path. At 
100%, the spacing is equal to the diameter of the dab. With a lower Spacing value, 
the repeated dabs begin to overlap. Most brushes are designed to have significant 
overlap.

Behavior
The Behavior controls the brush at its most basic level. The pop-up has two options:

■ Paint—applies color or other material.

■ Distort—Picks up pixels and lays them down in a new location. Distort 
affects paint that has already been laid down on a layer.

Fade In
Fade In controls the rate that the medium enters the stroke.

Fade Out
Fade Out controls the rate that the medium leaves the stroke. As a brush runs out of 
paint, the stroke “fades out.”

Bleed
Bleed controls the paint medium’s interaction with existing color. Higher Bleed 
values correlate to paint that behaves as if it were more “wet.” The brush picks up 
color from the layer and carries it along in the stroke.
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The Brush Options Palette
Resaturation
Resaturation controls the supply of the paint medium. At 100% the brush will 
never run low on paint. If you want the brush to dry out toward the end of the 
stroke, set a low resaturation value. 

Brush Links
Clicking the small, round button at the bottom of the Brush Options palette opens 
the Links drawer (see picture below). Links provide a way to set up dynamic 
modulation of brush attributes. While you paint, you can use various data sources 
to change brush and media attributes. 

RotoDV supports multiple links. You can have three, four, or more brush attributes 
linked to the same or different data sources. In most cases, two or three linkages 
will be enough for any brush. Further linkages may be difficult to control and may 
not contribute to the effect.

The most important data source is provided by a drawing tablet and stylus. Typical 
usage links stylus pressure to brush size and paint density, so pressing harder creates 
wider, more opaque strokes. 
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As with all tool options, the links are included when you save a custom brush tool.

To create a link:

1. Click the New button. RotoDV opens a dialog that lets you specify link charac-
teristics.

2. Use the Source Input pop-up to select the data source to control that attribute. 
Descriptions of the data sources are listed in a table on the next page.

The Links drawer in the Brush Options palette lets you set up dynamic modulation of the Brush Tool.

Use the Brush Link Options dialog box to set up link behavior.

Links Drawer
Button
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The Brush Options Palette
3. Use the Brush Attribute pop-up to select the brush feature you want to control 
with a link. The attributes are listed in a table on the following page.

4. Adjust the Amount slider to set the range of modulation. Regardless of the 
source data extremes, the resulting change to the attribute is maintained within 
this range. 

For example—if Hue is the selected attribute, you might set the amount slider 
to 10%. As you paint—regardless of extreme source data—the hue will remain 
within 10% of the current color. 

The significance of these limitations depends on the selected attribute, source, 
and the actual data presented. You’ll probably set up the link, experiment with 
the brush, then return to the Links drawer to adjust the Amount setting. 

To edit an existing link:

Double-click its listing in the Links drawer. Use the dialog as described above to set 
the modulation source, destination and amount.

To remove a link:

Click on a link to select it. Then click Delete.

Table of Link Modulation Sources

Data 

Source
Description

Velocity The speed of the stroke modulates the attribute. This might be linked to size 
or, perhaps, bleed.

Direction The direction of the stroke modulates the attribute. This is often used to con-
trol angle.

Pressure Stylus pressure modulates the attribute. It’s commonly linked to size, opacity 
or feathering.

Tilt X
Tilt Y

The tilt of the drawing stylus in the X or Y dimension modulates the 
attribute. Not all drawing tablet models provide tilt data. 

Random RotoDV modulates the attribute at random.
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Table of Link Destination Attributes

Attribute Description

Hue These attributes affect the paint media. You might put a little randomness in 
the color to give the paint a little variation. Look at the links for the Fire 
Effects brush to see how randomly varying the Hue just a bit adds to the look 
of flickering flames.

Saturation

Luminance

Size These attributes refer to the dab options. See “The Dab Options Palette” on 
page 92 for descriptions. Size is often linked to pressure, so that by pressing 
harder, you get a larger brush dab.Angle

Ratio

Opacity These attributes refer to the Brush Tool options. See “Brush Controls” on 
page 85 for descriptions. Opacity is often linked to pressure, so that by 
pressing harder, you get denser paint.Spacing

Flow

Fade In

Fade Out

Bleed

Resaturation

Position This attribute describes the position of the dab in relation to the stroke path. 
Without modulation, the dab is always centered on the path. 
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The Dabs Palette

The Dabs palette holds saved dabs. These dabs attach to the Brush tool; you can use 
any dab with any brush.

Note: The features 
for customizing the 
dab itself are in the 
next palette, the 
Dab Options 
palette.

The Dabs palette also holds the features for saving dabs, switching between sets of 
dabs, and managing those sets.

To keep your custom dabs organized, RotoDV lets you organize them in sets. You 
can load multiple sets and switch between them as needed.

Note: If you want 
particular Dab Sets 
loaded 
automatically when 
RotoDV launches, 
place the Dab Set 
files in the Dabs 
folder inside the 
RotoDV application 
folder. Everything in 
this folder is loaded 
automatically on 
launch, so you can 
change the default 
sets by managing 
the contents of this 
folder. 

Dab Sets are stored in files. You can save, open and close Dab Sets as needed. The 
commands for these operations are on the Dab Commands pop-up, described 
below. 

To choose a dab:

1. Use either the Tools palette or Brushes palette to choose the Brush Tool that 
you want to use.

2. In the Dabs palette, click the image of the dab you want. 

You can use the Dab Options palette to make further adjustments.

To switch between open Dab sets:

The pop-up on the Dabs palette lists all open Dab Sets. Choose the set you want 
from the pop-up.

The Dabs palette stores saved dabs and lets you switch between them.

Switch between Dab
Sets.

These icons provide access
to the saved dabs in the
current set.

Dab commands pop-up.

The current dab.

Click document to create new
dab. Click the trash can to
delete a selected dab.
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Dab Commands
The Dab Commands pop-up has the commands for creating and saving custom 
dabs and for managing Dab sets. 

New Dab Set creates a new, empty Dab set. 

Open Dab Set... loads a saved Dab set.

Close Dab Set unloads the current Dab set.

Save Dab Set saves changes to the current dab set.

Save Dab Set As... opens a dialog so you can save the current dab set under a 
different name.

Note: You create a 
new dab by 
modifying an 
existing dab.

New Dab saves the current dab, including all of its option settings, to the current 
Dab set.

Delete Dab removes the current dab from this set.

The Dab Options Palette

The Dab Options palette holds features for adjusting the brush dab. Changes you 
make here apply to the current dab, so you can make minor adjustments while you 
paint.
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Note: Remember 
that when you use 
the brush, the dab 
is applied along the 
stroke. You control 
the dab here, in the 
Dab Options 
palette, and you 
control stroke 
behavior in the 
Brush Options 
palette.

If you design a dab you want to keep, you can use the commands on the Dabs 
palette to save it for future use.

Dab Controls
The controls in the Dab Options palette allow you to adjust several aspects of the 
dab. The preview shows the dab image, so you can see the results of your changes.

Style
The Style pop-up lets you choose between Filled and Framed.

■ A Filled dab has a solid center.

■ A Framed dab uses only the feathered, outer regions. 

Size
The Size slider scales the dab. Use it to change the size of a brush.

The Dab Options palette helps you customize the dab.
93



Chapter 7      Brushes, Dabs, and Colors
Angle
Angle controls rotation of the dab shape. (Changing the angle makes more of a 
difference when the dab is flatter.) 

Ratio
The Ratio describes the aspect ratio of the dab. A dab that is inherently round can 
be flattened by reducing the Ratio.

Softness
The Softness slider controls the softness or feathering at the dab edge.

Adjusting Your Brush
The brush you paint with is composed of “a dab attached to a tool.” Both the tool 
and the dab have a set of options, and you may be unsure what to adjust when the 
brush doesn’t look quite right. This section provides some suggestions for adjusting 
brushes to get the effects you want.

All of the brush and dab options apply to the current brush immediately—so you 
can tweak a slider and continue working. It isn’t necessary to save adjustments to a 
new brush unless you want store them for later use.

RotoDV creates the brush stroke by repeating the dab shape along the stroke path. 
If you want to change the appearance of the stroke a brush delivers, you’ll find the 
control to make the change you need in one of four places: 

1. The Brush Options palette is where you set the rules for the stroke path.

The same dab shown at progressive angles.

Reducing the Ratio flattens a dab.
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2. The Links drawer on the Brush Options palette is where you set the rules for 
dynamically modulating Brush tool, dab and media attributes.

3. The Dabs palette holds saved dabs and dab sets.

4. The Dab Options palette is where you adjust dab shapes.

The following table lists common brush-adjustment needs and suggests how to 
resolve them. The numbers refer to the palette locations listed above.

Problem Solution

Brush is the wrong size Change the dab size (4). You may also choose a different 
dab (3).

Media is too weak or too thick Change the opacity (1).

Stroke appears as series of 
spots

Adjust the spacing to increase the dab repeat rate (1). 
When the dabs are close together, they blend into a contin-
uous stroke.

Stroke is too slow Increase the spacing (1).

Edge feathering or 
paint distribution is wrong

Choose a different dab (3).

Brush delivers unexpected 
results

Check the Behavior setting (1). Set the Behavior you want.
Check if any links modulate brush attributes (2). Delete 
unnecessary links.
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Swatches Palette

The Swatches palette lets you save collections of colors in sets, where you can easily 
choose them later. This can help you maintain color consistency throughout a 
project. As with the other features, you can have several sets loaded and switch 
between them.

Switching between color sets
To better manage your saved colors, you’ll want to keep them in sets. You can have 
several color sets open and switch between them using the pop-up on the Swatches 
palette.

Note: If you want 
particular Color Sets 
loaded 
automatically when 
RotoDV launches, 
place these Color 
Set files in the 
Colors folder inside 
the RotoDV 
application folder. 

Color sets are stored in files. You can Save, Open and Close color sets as needed. 
The commands for these operations and other management tasks are on the Color 
Set Commands pop-up, described below. 

To select a color from the current set:

■ In the Swatches palette, click on the color chip of the color you want. The 
selected color is indicated with an outline.

Use the Swatches palette to use and manager color sets.

Color set pop-up menu.
Color set management
commands are found
on the Color palette
commands pop-up.

Click document to create
new color. Click trash can
to delete selected color.
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■ You may also use the Paint pop-up on the Tools palette to choose a color from 
the current set.

To save a color to the current set:

1. Use either the color picker or the Eyedropper tool to select a color.

2. On the Swatches palette, click the document icon. Alternatively, you may use 
the Commands pop-up to choose New Color.

RotoDV adds the current color to the current color set.

To delete a color from the current set:

1. In the color set, select the color you want to delete.

2. On the Swatches palette, click the trash can icon. Alternatively, you may use the 
Commands pop-up to choose Delete Color.

Color Set Commands
The Color Set Commands pop-up holds the commands for saving custom colors 
and managing tool sets. Management tasks include deleting colors from a set.

New Color Set creates a new, empty color set. 

Open Color Set... loads a saved color set.

Color is chosen by clicking and holding on the current color in the Tools palette
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Close Color Set unloads the current color set.

Save Color Set opens a dialog so you can save the current color set.

Save Color Set As... opens a dialog so you can save the current color set under a 
different name.

New Color saves the current color as a new item in the current set. 

Delete Color removes the currently selected color from this set.

Color Palette

The Color Palette offers two styles of color picker—RGB and HLS. Use the pop-up 
to select the style you want. The Color palette also contains two quick shortcut 
buttons for choosing black or white. Of course, you can also choose the Eyedropper 
from the Tools palette and click on the color you want to sample. Refer to page 74 
for information on the Eyedropper tool.

Black and White Shortcut Buttons
The black and white icons are available on the Color palette with either the RGB or 
HLS color picker showing. These buttons provide quick access to the colors at the 
extremes of the luminance range—R,G and B equal 0, 0, 0 (black) and R,G and B 
equal 255, 255, 255 (white).
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Using the HSL Color Picker
The vertical bar at the bottom shows the range of available hues. The triangle 
shows the ranges of both saturation and brightness. Saturation increases left to 
right, and lightness increases from bottom to top.

■ Click in the bar to select the hue you want. You may also set hue values by 
typing numbers in the text field.

■ Click in the triangle to set the saturation/lightness. You may also set saturation 
and lightness numerically by typing in their respective text fields.

Using the RGB Color Picker
The RGB picker provides sliders that set the relative contributions of Red, Green 
and Blue to define the color. The range for each is 0 to 255. When all three have the 
same value, the result is grayscale.

HSL color picker in the Color palette.

The RGB color picker in the Color palette. Choose between RGB and HSL with the RGB/HSL pop-up.

Range of available hues.

Ranges of saturation
and brightness.

Black and White
shortcut buttons

RGB color picker
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8 Layers and Time

Understanding Layers and the Blend Stack

Every RotoDV project has a Media Stack which contains at least one paint layer 
and any layers you have created to hold imported video clips. The combined video 
that appears in the document window depends on the order and contents of the 
layers. If your project requires that the layers interact in more complex ways, you 
can add layers to the Blend Stack. A project with blend layers requires is more 
memory and disk space. Use the controls in the Timeline to switch between viewing 
the Media Stack and the Blend Stack.

■ The Media Stack lists all paint and video layers in the project. These layers are 
the building blocks of your composition. Use the Media Stack to create imagery 
and control sources. If the project has no Blend layers, the order of the Media 
stack determines the output.

■ The Blend Stack arranges layers from the Media Stack in logical relationships, 
like one layer matting the visibility of another. If the project has Blend layers, 
then the Blend Stack determines your final output.

Note: Remember, 
if you don’t create 
any layers in the 
blend stack, then 
the output is 
determined by the 
layer order of the 
Media stack.

As you work, you can switch the document window between displaying the Media 
Stack and displaying the Blend Stack. The two views may be quite different. For 
example, the order of layers in the Media Stack doesn’t influence the display order 
of the Blend Stack.
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Using the Timeline 

The Timeline lists the components of your project. The Timeline shows layer 
display order and provides control over layer opacity.

The timeline shows all layers in your project and their order.
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Using the Timeline
Moving Through Time
The Timeline has a Current Frame Indicator that shows which frame you’re on. The 
current frame is also listed in a SMPTE readout in the Transport palette.

The primary tools for moving through time are on the Transport palette. The 
Timeline also provides some methods for moving to other frames:

■ You can drag the triangular top of the current frame indicator.

■ You can click the thumbnail of the frame you want.

■ You can drag the slider at the bottom of the Timeline window and scrub back 
and forth for a real-time flip book effect. This is a handy way to preview video 
at thumbnail size.

Timeline Thumbnail Options
RotoDV allows you to set options for displaying thumbnails on the layer tracks. At 
lower display levels, the Timeline window has less to update, so you can move 
through it more quickly.

Current frame is designated by the Current Frame Indicator.

Current Frame Indicator.
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To set Timeline options:

1. From the menu, choose Edit> Project Settings.

2. Under Timeline Thumbnails, select the thumbnail display level you want.

■ None—The layer has no thumbnail images. 

■ First and Last Frame—Only the first and last frame are given thumbnails.

■ Every Frame—Every frame has the thumbnail image. This is the highest 
display level.

Timeline Thumbnail options can be adjusted in the Project Settings dialog.
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Layers in the Media Stack

RotoDV lets you work with any number of layers in a project. These layers are the 
building blocks of your composition. The Media Stack lists all paint and video 
layers in the project.

■ Video layers contain imported movie clips—captured video or animations. 
Editing is not allowed in a video layer, but you can select and copy imagery for 
use in paint layers. A video layer will have an alpha channel only if it is enabled 
in the Clip Options dialog. (See “Setting Clip Options” on page 46 for 
information.)

■ Paint layers are 32-bit layers where you can paint with the Brush tools, use 
Selection tools and apply effects.

Generally, each layer adds imagery to the project; however, some layers may hold 
resources for controlling or developing imagery in other layers. This use of layers 
ensures that the original footage isn’t altered and provides tremendous flexibility for 
developing imagery and making changes.

Adding a Layer to the Media Stack
There are two ways to add layers to the media stack: create a new paint layer, or 
import a video clip. Each creates a different type of layer, however video layers can 
be converted to paint layers.

Creating a Paint Layer
By default one paint layer is created in the Media Stack for every new project. You 
can add paint layers as required.
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To add a new paint layer:

■ Click the New Layer button in the Media Stack header in the Timeline. You can 
also create a new paint layer by choosing Layer> New Paint Layer or by 
pressing Command-L.

Note: Frame 
numbering on 
imported clips will 
always start at #0 to 
conform to STMPE 
conventions.

Importing a Clip
When you import a clip (captured video, animation or still image) to the project, 
RotoDV gives you choices of several pre-processing functions, like defining the 
alpha and setting in and out points.

To import a clip:

1. Choose File> Import Clip…, or press Command-I.

Click the new layer button to add a paint layer.

Media Stack
header

New Layer button
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Layers in the Media Stack
2. Select the desired file in the Open dialog box and click Open.

The Clip Options dialog box appears.

3. Select the pre-processing options for the clip. See “Setting Clip Options” on 
page 46 for more information on the Clip Options dialog box.

4. Click OK to import the clip into a new video layer.

When you’re finished pre-processing the clip, it will be placed in the Media Stack.

Media Stack Layers
In the Media Stack, any clip may be used as either a video layer or paint layer. 
There’s a technical difference between the two layer types—editing is not permitted 
in video layers, while editing is fully supported in paint layers. You’ll need to keep 
this in mind to get the behavior you want in the layer. If you want to edit the pixels 
directly, you’ll need to use the clip as a paint layer.

■ In a video layer, editing is not allowed—you cannot paint, apply filter effects, 
cut or paste in a video layer. You can select and copy imagery for use in paint 
layers.

Set clip pre-processing options in the Clip Options dialog box.
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■ In a paint layer, you can paint using the Brush tool, cut and paste selections, or 
apply effects to change the actual data.

In most cases when you want to paint on video, you’ll import the clip as a video 
layer, then create a paint layer above it where you’ll paint. This is advantageous 
because it leaves your video data untouched, and you can make any number of 
changes in the paint layer.

The following occasions require using a video clip as a paint layer:

■ You want to paint directly onto the video, changing its data.

■ You want to apply effects directly onto the video, changing its data.

To convert a video layer to a paint layer: 

■ Select the video layer in the Timeline. From the Layer menu, choose Convert 

to Paint Layer.

Selecting a Layer to Edit
You can only work on one layer at a time in RotoDV. You’ll need to identify the 
layer you want to edit.

■ You can select a layer by clicking its listing (name) in the Timeline.

■ You may change the selected layer by with the Up and Down Arrow keys on 
the keyboard.

Changing the Order of Layers
Note: The order of 
layers in the Media 
Stack does not 
influence the 
display order of the 
Blend Stack.

Higher layers cover those below. You can change the order of layers to achieve an 
arrangement that supports the editing you are doing. For example, if you wish to 
place some painted-in clouds behind a mountain, you can create the clouds on an 
individual layer and place that layer below the layer containing the mountain.

To change the order of layers in the Media Stack:

1. Select the layer you want to move in the Timeline.

2. Pull down the Layer menu and choose the type of move you want:

■ Move To Front—The layer moves to the top of the display order.

■ Move Forward—The layer moves up one position in the display order.
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■ Move Backward—The layer moves down one position in the display order.

■ Move To Back—The layer moves to the bottom of the display order.

You can also use the Move command key shortcuts listed on the menu.

Changing the order of a layer forces RotoDV to redraw the current frame.

Controlling Layer Visibility
Note: These 
controls set layer 
visibility/opacity 
within the Media 
Stack. They have no 
influence on the 
Blend Stack. To 
change opacity in 
blend layers, you 
need to work in the 
Blend Stack. 

When a layer has reduced opacity, lower layers show through. This can be useful 
for some kinds of editing—for example, if you’re using one layer as a guide for 
working in another layer.

To set layer opacity:

1. Select the layer you want to change. 

2. Adjust the View Opacity slider in the Media Stack or enter a specific level in the 
text field.

Use Move commands in the Layer menu to change order of layers in the Timeline.

The opacity of a selected layer may be adjusted with the View Opacity slider at the top of the Media 
Stack.
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Visibility

The visibility control sets whether or not a layer is seen in the document window. 
You might want to hide a layer so that it won’t distract you while you work on 
another.

■ Click the Eye icon to show/hide the layer.

■ Option-click a layer’s Eye icon to make it the only visible layer.

Option-click again to show all layers.

Manual Rendering
Certain actions, (hiding/showing layers and changing the background color) require 
you to update the project manually. When this update is required, the word 
“Unrendered” appears in the Timeline.

I

Click a layer’s Eye icon to hide or show a layer in the document window.

When the project needs updating, “Unrendered” appears in the timeline.
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You have two options when you see “Unrendered” in the timeline:

■ Choose File> Render to force the project to update now. This command 
may take a few seconds to complete. The Render command always updates 
the project to show the current state.

■ Choose File> Treat As Rendered to revert to the previous view and 
remove the “Unrendered” message from the Timeline. This display may not 
accurately represent the current state of the project. If you use the Treat As 
Rendered command, you should always use the Render command at a later 
time.

Creating a Blend Stack

The Blend Stack assembles the layers from the Media Stack in more complex ways 
than are possible with the Media stack alone. The Media stack combines layers in 
the order they appear. For more complex layer interaction it’s necessary to create a 
Blend Stack.

Note: When it’s 
time to export your 
project, RotoDV will 
use the visible 
stack. If you haven’t 
created a Blend 
Stack, RotoDV will 
use the Media 
Stack.

The Blend Stack is built of Blend Layers. Each layer contains one or two layers 
selected from the Media Stack. When you create a Blend Stack, you’ll give it some 
compositing rules. These rules and the order of layers in the Blend Stack are what 
determine the imagery in your final output.

This stack hierarchy offers several advantages:

■ The Blend Stack lets you combine two layers in a single composite effect. The 
most common use is to have one layer matte the contents of another. 

■ The Blend Stack allows you to use a single layer more than once. This offers 
advantages for developing special effects. For example, you can blend a video at 
100% opacity inside a matte, then create a second blend layer and blend the 
same video at 15% opacity outside of the matte, or vice versa. 

While the rules for building a Blend Stack are quite simple, there are many ways to 
take advantage of the Blend Stack.
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Creating and Editing the Blend Stack
For many RotoDV projects you can get the results you want with the Media Stack 
alone. There will come a point when you’re when your project becomes more 
complex and requires the use of a Blend Stack. You don’t need to be done editing 
the layers to set up a Blend Stack. You can add layers to the Blend Stack, then return 
to the Media Stack for further work. You should be aware that adding layers to the 
Blend Stack requires additional memory. If there is not enough memory available to 
add a layer, you may be able to free up some memory by decreasing the real time 
range (page 52).

Note: Not all 
Media Stack layers 
must appear in the 
blend.

Any layer may be 
used multiple times 
in the Blend. 

The layering order in 
the Media Stack is 
completely 
independent of the 
order of layers in 
the Blend.

Creating a Blend is the process of arranging the layers from the Media Stack in 
logical relationships. Two factors control the full result of the Blend—the settings of 
the individual blend layers and the order they appear in the stack. You can modify 
either to get a different blending result.

To create a new blend layer:

1. Choose Layer> New Blend Layer. Alternatively, you may click the “New Doc-
ument” icon in the Blend Stack field of the Timeline.

2. RotoDV opens the Blend Layer Options dialog, described in “Blend Layer 
Options” on page 114.

3. Use the dialog to define this blend layer.

When you close the dialog, RotoDV creates a new layer for the specified blend.

To delete a blend layer:

1. If necessary, click the disclosure triangle to expand the Blend Stack and view the 
separate layers.

2. Select the layer you want to delete. 
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Creating a Blend Stack
3. Click the “Trash Can” icon in the Blend Stack field of the Timeline. You can 
also select Layer>Delete.

To change the order of blend layers:

The order of layers in the Blend Stack is a major determinant in the overall blend 
result. Layers that are higher in the stack cover those that are lower, so you can 
achieve different blend results by changing the display order. 

■ Choose Layer> Move and choose the type of move you want.

To edit a blend layer:

Sometime after creating a blend layer, you might need to change it. You might want 
to switch the alpha usage (inside versus outside) or choose a different blend mode, 
for example. 

1. If necessary, click the disclosure triangle to expand the Blend Stack and view the 
separate layers.

2. Double-click the layer you want to edit. 

3. Make the necessary changes in the Blend Layer Options dialog, described in 
“Blend Layer Options” on page 114.

Delete the selected layer in the Blend Stack by clicking on the Trash Can icon in the Timeline.
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Blend Layer Options
The Blend Layer Options dialog is where you specify which one or two component 
layers are used in this layer and how they’re used. You’ll use this dialog when 
designing a new blend layer or when editing an existing one.

Two types of blend layers are possible—Single and Double. 

■ A Single layer has only one layer, which is displayed directly according to its 
order in the Blend Stack and opacity setting.

The Blend Layer Options dialog. Blending modes are shown in the Blend pop-up menu.
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■ A Double layer combines two layers in a blending operation. Often you’ll use a 
blending mode for special effects.

To set blend layer options:

1. Enter a name for the layer in the name box, if you like.

2. Click the checkbox if you want a Double layer.

3. Use the Layer pop-up to choose the one or two layers you want in this blend. 

The pop-ups list all layers from the Media Stack plus the special “Underlay” 
layer. The Underlay is calculated on the fly from the composited result of all 
underlying blend layers.

4. Use the Blend pop-up to set the type of blending operation you want (Double 
only).

■ Normal—The top layer component covers the lower component. 

■ Inside Alpha—The top layer component fills the alpha region of the lower 
component. 

■ Outside Alpha—The top layer component fills the inverse of the lower 
component’s alpha.

■ Blending Modes—The remaining options are the blending modes, 
described in Appendix A: “Blending Modes.” In these cases, the top 
component blends with the lower component, following the rules of the 
selected mode.

5. Click Blend to apply the settings.

Viewing the Blend Stack
As you work, you can toggle the display in the document window between viewing 
the Media Stack and viewing the Blend Stack. You can continue to edit when 
viewing the Blend Stack; but it’s easier to work while viewing the Media Stack.

To switch your view between the Media Stack and the Blend Stack:

■ Click the Blend Stack/Media Stack view headers on the Timeline to switch 
between the two views. You can also toggle between the views by pressing the \ 
(Backslash) key on the keyboard.
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9 Working with Paint

About Painting

This chapter is about working in paint layers. Paint layers support tools and 
operations that aren’t possible in video layers. In paint layers, you’ll use the Brush 
tools to develop imagery. You’ll use selections to manipulate imagery. And you’ll 
use keys and effects to create and modify imagery.

The Brush is an important and flexible tool. You’ll find the major Brush tool 
features described in this chapter.

The paint that you apply in a paint layer comes from the Color palette, where you 
can choose the color using one of two color pickers.

One special type of painting does not use colors. Cloning draws its medium from 
imagery in any frame of any layer. To help you manage cloning options, RotoDV 
provides a special palette—the Clone palette. Nearly all of the standard brush and 
painting features apply equally to cloning. Special cloning procedures are covered in 
“Cloning” on page 121.

Painting Features

RotoDV’s various painting features are described in the following pages.
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Painting in a Field
RotoDV allows you to apply paint one field at a time, to the interlaced video fields. 
Working in Field Mode, your imagery is recorded at 60 fields per second (NTSC), 
instead of 30 frames per second. 

Moving imagery will benefit from working in fields. RotoDV allows you to switch 
back and forth between working in the whole frame and in separate fields. You can 
save time by using Field Mode only where it provides benefit. See Appendix B, 
“Field Rendering,” for more information on working with fields. 

To use Field Mode:

On the Transport palette, click the Field Mode button.

When you’re working in Field Mode, each “Frame Forward” (using either the 
button on the Transport palette or the Right Arrow key) actually moves forward 
one field. The readout to the right of the SMPTE display shows which field you’re 
on—1 or 2. Field dominance is set in either the New Project or Project Settings 
dialog box.

Painting While the Movie Plays
RotoDV allows you to paint while your project plays. This is a great way to get 
streaks of paint swimming around the frame.

To paint while the movie plays:

1. Transport to the frame where you want to start painting.

2. Select the paint layer you want to work in.

Use the Field Mode button in the Transport palette to switch between frame and fields.

Field Mode
button
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Painting Features
3. If you like, change the frame rate in the Transport palette.

4. Click the Transport palette: Record button to enable recording. There is a short 
pause as the project “cues up”

5. Start painting. The first click in the document window starts recording. You can 
also click the play button in the Transport palette to set the project in motion, 
then apply paint.

Auto Paint
Note: Note: 
RotoDV will only 
carry paint forward 
if you turn Auto 
Paint on before you 
make your first 
paint stroke.

The Transport palette’s Auto Paint button (Command-B) lets you automatically 
carry over paint you apply in one frame when you advance to the next. This is quite 
useful for projects where the painted area grows or changes shape like the first 
tutorial at the beginning of the manual. You might use RotoDV for photographic 
retouching on a film clip. You’ll paint to retouch the image in the first frame; then 
with Auto Paint on, advance through the frames. The same paint will be applied in 
all frames—as long as the retouched element has the same framing, you can “carry 
on.”

Slowing down the frame rate in the Transport palette command pop-up can help when painting on video 
while it plays.
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Chapter 9      Working with Paint
Remember: Auto Paint carries forward paint applied with a brush, by pasting or by 
dropping a selection by Option-clicking. See “Auto Paint” on page 66 for more 
information.

Note: Use the 
paint tool and eraser 
to edit the applied 
paint as you move 
forward and the 
paint appears to 
move in the frame.

Note that you can enable/disable this feature at any time. In a given project, you’ll 
use Auto Paint for some design elements, and not others. When the design suggests 
it, Auto Paint will save you time and deliver excellent results.

Auto Paint also functions across paint layers. For example, if you start painting in 
one paint layer with Auto Paint on, then move to a different paint layer, the paint 
you have applied is copied into the frame where you switched layers.

To automatically carry paint forward to the next frame, click the Auto Paint button in the Transport 
palette before applying the paint to be copied.

Auto Paint
button

Auto Paint moves the applied paint to the new layer at the point where you switched layers.
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Painting Features
Cloning
Cloning lets you move imagery between locations, frames and layers with every 
brush stroke. You load your brush with imagery from one place, time or layer, then 
paint with it in another. As you advance to paint in subsequent frames, you can 
have the frame reference to the clone source advance as well. 

You can assign cloning behavior to any Brush tool. 

To use a cloning brush:

1. Choose the Brush tool and dab you want.

2. Click the Clone button in the Tools palette, or press Command-S.

Clone Brush Setup
Cloning requires a few steps of preparation, most of which take place in the Clone 
palette. 

Click on the Clone button in the Tools palette to create a cloning brush.

Clone Mode icon.
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To set up for cloning:

1. Display the Clone palette by clicking the Clone button on the Button Bar or 
selecting Window>Show Clone, or press F7.

2. Use the Source Layer pop-up to select the layer you want as the source. 

Any video or paint layer may be used as the clone source. If the source clip you 
want to use isn’t in the project yet, you’ll need to bring it in first. You may even 
use the layer where you’re going to paint as the source (which can be useful for 
touch-up work).

3. Use the Transport palette to advance to the frame where you want to paint. 

4. Use one of the following two methods to set the frame-to-frame alignment:

■ On the Clone palette enter the Source Frame number you want. This 
identifies the specific frame in the source layer you want to start cloning.

■ Adjust the Frame Offset by typing a number in the text field. This identifies 
the temporal relationship between the source frame and the current frame 
(where you’ll paint). For example, “-3” means “the source frame is three 
frames behind the current frame.”

The two controls are interdependent. When you change one, RotoDV adjusts 
the other accordingly.

5. The Lock option sets the behavior of the source frame when you advance in the 
project.

■ When Lock is enabled, the source frame you set is fixed—advance in the 
project and you’ll still be cloning from the specified source frame.

■ When Lock is off, the source frame maintains its relationship to the current 
frame—advance in the project and the source frame advances with you.

Setting up a Clone brush

Source Layer pop-up.

Set relationship between clone
source and current frame.

Set to see ghosted overlay
of source frame.

Frame number of where
cloning starts.

Source frame is fixed with
Lock check box checked.
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6. If you want to see a ghosted overlay of the source, adjust the Ghost slider to 
describe the opacity of the overlay. The ghost overlay will be helpful in deciding 
the x, y location of the source material.

At any time, you can hide the overlay (set Ghost slider to zero) to see your 
project clearly.

7. Click on a paint layer in the Timeline where you want to work—your destina-
tion layer.

8. Choose a cloning brush. 

■ To create a cloning brush, choose any type of Brush tool, then click the 
Clone button in the Tools palette. The large color chip will change to a 
clone icon.

9. Set the clone source location within the frame by Option-Clicking on the spot 
you want to sample from. You can repeat this step whenever you want to 
change the source location.

Note: The position 
difference between 
the clone source 
and destination is 
called the X, Y 
Offset. You’ll find a 
readout of this 
offset at the bottom 
of the Clone palette.

10. Click at the location where you want to apply the clone imagery—the destina-
tion.

11. Now you can paint. Each stroke brings in more imagery from the clone source. 

Clone source frame (Fire) can be seen through foreground frame (Ric). The tip of the flame near Ric’s 
mouth shows where cloning has already taken place.
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Selecting and Editing Paint

Selections allow you to move and transform pixel imagery with operations like 
rotate and scale. You can use selections to copy imagery from one frame to another 
or from one paint layer to another. Selections also can constrain image effects and 
painting with the Brush tool.

Selections are independent of layers, but are valid in only one layer at a time. That 
is, once you create a selection, you can use it in any paint layer. The selection applies 
within the current layer, so you need only move to the layer where you want it to be 
effective.

RotoDV allows you to select a region within the current frame, the entire frame, or 
a range of whole frames. For the most part, this chapter discusses regional 
selections that are valid only in the current frame. Operations that may be used on a 
range of frames differ from those for regional selections. This chapter includes a 
separate section for selecting and working with a range of frames.

Selections and Paint
In the document window, you’ll see the region described by a moving black and 
white marquee, often called “marching ants.” Because the selection mask may be 
feathered the actual path that the ants follow may be an approximation of the soft 
edge. 

The image pixels within the selection region are what you’re really interested in. It’s 
this collection of pixels—the paint—that you’ll re-color, copy or move. It’s 
important to maintain the distinction between this collection of colored pixels and 
the mask that distinguishes them from the rest of the current frame in this layer. 
Different operations refer to one or the other.

■ “Selection” refers to the area within the marquee. The selection is created with 
the Lasso and Marquee tools or by selecting the entire frame (Select> All, or 
Command-A).

■ “Paint selection” refers to the collection of pixels from the region. Sometimes, 
when the context is clear, this may be simply “paint,” “pixels” or “imagery.”
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Creating Selections
Selections may be used in any paint or video layer. They apply to one layer at a 
time—the layer currently selected for editing. It doesn’t matter which layer is 
selected when you create the selection. But it does matter when you attempt to use 
the selection. Be sure to choose the layer you want before trying any operation on 
the layer pixels.

To choose which layer the selection will affect: 

You may use either of these methods.

■ Use the up and down arrow keys to select the layer you want.

■ Click the name of the layer you want in the Timeline. 

Using Selection Tools
The selection tools are the principal method for creating selections. Refer to the 
“Selection Tools” on page 73 for more information on the selection tools.

Lasso

Use the Lasso to draw a freehand shape around the region you want to select. 

Rectangle

Use the Rectangle selection tool to create rectangular selections. Just drag in the 
document to create the selection.

Adding to and Subtracting from a Selection
Once you’ve created a selection, you can add to or subtract from it using a key 
modifier. This technique works with either of the selection tools.
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■ Hold down Shift and use the tool to add to the selection.

■ Hold down Option and use the tool to subtract from the selection.

A rectangular selection is drawn, then a second rectangle is added to the selection.

A rectangular selection is drawn, then the lasso tool is used to subtract an irregular area from the 
selection.
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Moving a Selection
You might create a selection, then decide you want to reposition it. Note that this 
refers to moving the selection path—not the pixels within it. You can move the 
selection marquee by dragging within the selection region with a selection tool, or 
by holding down the Command key on the keyboard and pressing the arrow keys.

Selection Commands
Note: This 
command is 
context-sensitive. In 
the Timeline, it 
selects all frames.

In some cases, 
when there is no 
active selection, an 
operation will apply 
to the entire frame. 
For example, 
Select> Fill would 
fill the entire frame 
if no selection was 
active. The same 
applies to any of the 
Effects.

Select All (Command-A)

To select the entire frame, choose Select> Select All.

Deselect (Command-D)

To disable any selection, choose Select> None.

Inverse (Command-Shift-I)

Sometimes it’s easier to select “everything but” the imagery you want. You can then 
invert the selection to get the region you want.

■ With a selection active, choose Select> Inverse. If a pixel was selected before, 
it won’t be now, and vice versa. 

Fill (Command-Shift-F)

Fill floods the active selection with the current color. The Fill command is not 
available in erase or clone mode.

Note: The Rotate, 
Scale and Feather 
commands affect 
the selected 
imagery, not just 
the selection 
marquee.

Rotate…

To rotate the selected area, choose Select> Rotate. This brings up a dialog box to 
specify the angle through which you want the selection rotated.

Enter an angel to rotate the selected area. Enter a negative angle to rotate counter-clockwise.
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Scale…

Use the Scale command to enlarge or shrink the selected area. Enter the same 
percentage in both boxes to scale without distorting the image in either dimension.

Feather… (Command-Option-D)

Selection tools offer options for feathering; however, you might want to change the 
feathering on an existing selection. 

■ With a selection active, choose Select> Feather. In the dialog, enter the 
feathering distance and click OK.

Hide Edges (Command-H)

To conceal the marching ants (selection marquee), choose Select> Hide Edges. 
The selection is still valid, but the marquee isn’t shown. If you need to see marquee 
again, choose Select> Show Edges.

Use the Scale Selection dialog box to alter the size of a selected area.

The Feather dialog is used to set or change the feathering of a selection
128



Selecting and Editing Paint
Frames…

This command on the Select menu allows you to type in a range of frames to select. 
You can also select a range of frames from the Timeline by clicking on the first 
frame and shift-clicking on the last frame in the desired range.

Manipulating Paint Selections
The principal reason for creating a selection is to separate a region of pixels for 
editing. RotoDV offers the basics, like Cut, Copy, and Paste, as well as 
transformations and special features for getting paint into other frames. 

Moving Paint in the Frame
Often, you’ll want to move a bit of imagery in the frame. This operation moves the 
painted pixels, not the selection marquee. A paint selection that has been moved 
floats over its layer. When you deselect it, the paint stops floating and merges with 
the layer. This is called “dropping” the selection.

It’s possible to move a paint selection partially out of the frame. Only the portion 
within the frame will be visible, and when you drop the selection, only this portion 
is retained.

To move a paint selection by dragging:

1. Create a selection.

2. Choose the Move tool.

Enter the frame range to select, or select the frames in the Timelime window.
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3. Drag the paint selection where you want it.

4. Drop the selection by clicking outside the marquee, or choose Select> None 
(command-D).

Option-click to drop the paint without loosing the selection.

The selected area can be dragged with the Move tool.
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Duplicating the Selection
Option-clicking the selection drops the paint but does not de select-the region, this 
lets you duplicate the selection on the same frame or on several frames of your 
project.

■ Option-click to drop the paint and keep the region selected. This let’s you 
preserve the selected region for further use.

■ You can copy the same selection into several frames by advancing with the right 
arrow key, then option-clicking on each frame to drop paint.

Option-click to make lots of money with RotoDV.
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Masking With a Selection
You can use a selected region to mask non-selected areas of a frame. If a selected 
area exists on a frame, the paint tools will only apply media in that area. If you 
want to keep paint off a certain area in the frame, select the area, then invert the 
selection to paint everywhere else.

■ Select an area to confine paint to that area.

■ Choose Select> Inverse to keep paint off the original area.

■ Use the Feather control in the Tool Options palette or in the Select menu to 
smooth the edges of the mask.

Moving Paint Between Frames and Between Layers
You can cut or copy, then move to a different frame or layer and paste there. The 
commands for doing this are on the Edit menu.

Copy (Command-C)

(Paint and Video layers) Edit> Copy duplicates the selected imagery to the 
Clipboard.

Cut (Command-X)

(Paint layers only) Edit> Cut removes the selected paint from the document and 
places it in the Clipboard.

The example on the left shows paint applied into a selected area. In the example on the right the Inverse 
command has been applied to mask the irregular area.
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Clear

(Paint layers only) Edit> Clear removes all opacity from the pixels in the active 
selection. You can see through the cleared region to underlying layers or the 
background. Clearing is equivalent to filling the selection with Eraser paint.

Paste (Command-V)

(Paint layers only) Edit> Paste copies the Clipboard contents to the document. The 
paint selection is pasted at the same location from which it was copied. Select the 
Move tool to move the pasted paint where you want it.

Working with a Range of Frames
Note: Regional 
selection and whole 
frame range 
selection are 
exclusive. 

Several features are available for working with a range of whole frames in a paint or 
video layer. These operations take place in the Timeline window, where the selected 
frames are outlined in your selected system highlight color. You may want to adjust 
the highlight color in the Appearance control panel for best results (see your 
Macintosh OS documentation for more information).

With a range of frames selected, the following Edit menu commands are available: 
Clear, Cut and Copy. After using Cut or Copy, Paste is available. See the next 
section for more information on pasting multiple frames.

With a range of frames selected, you may use any of the Effect menu commands to 
modify the imagery. 

To select frames manually:

1. In the layer track of the Timeline, click on the frame at the start of the range. 

2. Advance to the last frame of the range you want and Shift-click on it.

RotoDV selects the range of frames delimited by the two you clicked on. In the 
Timeline, the selected frames are outlined with a marquee. 

To select frames numerically:

1. In the Timeline, select the paint or video layer you want.

2. Choose Select> Frames or press Command-Shift-A.

3. RotoDV opens the Select Frame Range dialog that allows you to specify the 
range. For more information on the Select Frame Range dialog see “Frames…” 
on page 129.
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4. When you’ve defined the range, click OK.

RotoDV selects the specified frames.

Using Effects

The Effects menu offers several methods for creating and changing imagery. With 
the exception of keying, these commands are valid only in paint layers. Keying is 
possible in paint layers and in a video layer that has alpha data. Refer to “Setting 
Clip Options” on page 46 for information on video clip alpha settings.

Applying a key lets you remove, or “knock-out” pixels containing colors in a 
defined range. This is the method used for traditional blue or green screen effects—
the desired object is filmed against a blue or green background then the background 
color is removed and replaced with the desired imagery.

Applying a Key for Alpha
The keying dialog lets you apply a Color, Channel, Color Range or Difference key 
to a layer in the Media Stack. Trial and error and experience are the best guides for 
which type of keyer to use.You can apply a key filter to a range of frames. You can 
repeat the technique on different sets of frames, using different settings or keying 
methods in each.

To apply a key:

1. Select the layer where you want to apply the key.

2. Select a specific frame, range of frames, or all frames. Refer to “Working with a 
Range of Frames” on page 133 for instructions.

3. Choose Effects> Apply Key, or press Command-Shift-K on the keyboard.

4. In the Key Filter dialog, use the Keyer pop-up at the top to choose the type of 
key you want. RotoDV updates the dialog to show the appropriate options.

You have four choices for setting up a key filter.
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5. Set your keying options and click OK close the dialog and apply the key.

Settings common to several Keyer options are:

Color
This is the easiest keyer option and the one you’ll probably use most.

To set up the Color option:

1. Select a color in the document window with the eyedropper.

2. Adjust the tolerance slider to expand the range of color.

3. Use the softness slider feathers the edges around the knock-out area.

Table of Shared Keyer Options

Setting Description

Invert Knocks-out everything but the keyed pixels; like inverting a selection.

Linear Use a linear function for the falloff slope. Produces a sharper falloff.

Cubic Use a cubic function for the falloff slope. Produces a softer falloff.

Preview Previews the effects of applying the key in the document window.

You use the eyedropper to select a key color with the Color keyer option.
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4. Check the Invert box if you wish to knock-out everything but the key color.

Channel
Use this option to key out a range of color in just one channel (Red, Green, Blue, or 
Luma).

To set up the Channel option:

1. Adjust the Min and Max sliders define the lower and upper range of the color 
value.

2. Use the Falloff sliders determine how color values at the ends of the range tran-
sition from unkeyed to keyed.

Falloff is like the softness slider in the Color key option. You can adjust falloff 
separately for the high and low end of the value range.

3. Fine tune the falloff transition by selecting the Linear or Cubic option.

4. Check the Invert box if you wish to knock-out everything but the key color.

Use the Channel option to remove a color range from a specific color channel.
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Color Range
Defines a key color range by setting values for red, green, and blue. The key range is 
the region where these values intersect in the color space.

To set up the Color Range option:

1. Adjust the sliders to define the range for each color. Min and Max sliders define 
the lower and upper range of the color value.

2. Use the Falloff slider determine how color values at the edges of the color range 
transition from unkeyed to keyed.

3. Fine tune the falloff transition by selecting the Linear or Cubic option.

4. Check the Invert box if you wish to knock-out everything but the key color.

Set the range for each color with the sliders.
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Difference
Used to key out the pixels in the selected layer which differ from the layer selected 
in the Background pop-up.

To set up the Difference option:

1. Select a layer in the Background pop-up to compare to the selected layer.

2. Adjust the tolerance slider to expand the knock-out area.

3. Use the softness slider feathers the edges around the knock-out area.

4. Check the Invert box if you wish to knock-out everything but the difference 
area.

To use the Difference keyer option to isolate a subject:

1. Duplicate a layer.

2. Paint over the desired subject with the background color.

3. Select the original layer and apply the Difference key with the duplicate layer 
selected in the Background pop-up.

The pixels which differ from the original layer will be knocked-out.

Compare two layers and knock-out the different pixels with this keyer option.
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Applying a QuickTime Effect
Applying a QuickTime effect allows you to modify the imagery in a paint layer in 
interesting ways. In some cases, the effect might generate its own imagery. You can 
apply the effect either to a region of the current frame or to a range of frames. 

To apply a QuickTime effect:

1. Select the paint layer where you want to apply the effect.

2. Select a specific frame, range of frames, or all frames. Refer to “Working with a 
Range of Frames” on page 133 for instructions.

3. If desired, select the region to which you wish to apply the filter.

Note: If you are 
using QuickTime 
version 4, a “Save” 
button appears 
under the list of 
effects. This allows 
you to save your 
effect control 
settings for later 
use.

4. Choose Effects> Apply QuickTime Effect. RotoDV displays the Apply Quick-
Time Effect dialog.

5. Use the pop-up to select the effect you want to apply.

6. Use the controls on the right to fine tune the effect.

7. Click OK to apply the effect.

Select Effect... dialog lists QuickTime effects in scrollable window at left. Sliders and menus at right 
control the effect. A preview of the effect is shown at bottom left.
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The pop-up lists the effects that ship with the version of QuickTime you have 
installed.
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A Blend Modes

Blend modes control how one set of color data interacts with another. Each blend 
mode produces a different visual result. The differences may be subtle or profound, 
depending on the color data and the specific blending modes. The blend modes 
allow you to achieve the color effects you’re looking for. Note that the strength of a 
blend mode effect is controlled with the opacity of the media.

Blend modes are available in three areas of RotoDV:

■ Timeline—The Mode pop-up on the Blend stack determines how the stack 
interacts with the other layers. This is the equivalent of the Opacity slider on 
the Media stack.

Use the Mode pop-up on the Blend stack to set how the stack interacts with other layers.
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■ Double Blend Layer—The colors in one component layer are blended with 
another using the selected mode. Tis uses one layer in the blend stack as a way 
of combining layers.

Blend modes are shown in the Blend Layer Options dialog.
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■ Brush Options palette—Color applied with the Brush tool blends with color 
already in the layer using the selected mode.

For Blend layers, you can change the blend mode at any time. Refer to the body 
chapters for information on setting the blend mode.

In the case of color applied with the Brush tool, the blend result is built into the 
pixels of that paint layer. This means you must set the blend mode before painting. 
After you’ve applied paint, you cannot change its blend mode.

If you’re designing a custom brush tool, you’ll set the blend mode appropriate for 
the brush function you want. The blend mode is included when you save a custom 
brush. 

Blend Modes

Normal

The color is applied directly, replacing other colors. This is the default mode.

Dissolve

Color is applied in a scatter pattern. The result is that some pixels of the applied 
color appear, yet some of the old are still visible.

Blend modes are shown in the Brush Options palette.
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Multiply

The applied color is used as a multiplier on existing color. As long as the applied 
color isn’t white, the result is always darker. 

Screen

The inverse of the applied color is used as a multiplier on the inverse of existing 
color. As long as the applied color isn’t black, the result is always lighter.

Overlay

Overlay uses a mixture of Multiply and Screen, depending on the value of the 
existing color. 

Difference

In each color channel (RGB), the difference between color values is calculated. 
These differences define the resultant color.

Exclusion

The value of the applied color is used to modify existing color. With white applied, 
existing color is inverted. Black has no effect. Where the applied color equals the 
existing color, the result is black.

Darken

The applied color is compared to the existing color. The darker of the two is used. 

Lighten

The applied color is compared to the existing color. The lighter of the two is used.

Color Dodge

The existing color becomes less saturated.

Color Burn

The existing color becomes more saturated.
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Soft Light

Depending on the value of the applied color, Soft Light lightens (value above 50%) 
or darkens (value below 50%) existing color. The distance from 50% value 
determines the amount of lightening/darkening.

Hard Light

Hard Light uses Screen where applied color has value above 50% and uses Multiply 
where applied color has value below 50%. The distance from 50% value 
determines the amount of the effect.

Hue

The hue of the applied color replaces the hue of existing color. Existing saturation 
and luminance are unchanged.

Saturation

The saturation of the applied color replaces the saturation of the existing color. 
Existing hue and luminance are unchanged.

Color

The hue and saturation of the applied color replace the hue and saturation of the 
existing color. Existing luminance is unchanged.

Luminance

The luminance of the applied color replaces the luminance of the existing color. 
Existing hue and saturation are unchanged.
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B Field Rendering

About Field Rendering
In interlaced video, the frame is divided into two fields, sometimes identified as 
“odd” and “even” because they’re comprised of the odd and even scan lines, 
respectively. When the video frame is displayed, first one field is drawn—skipping 
every other line—then the other field is drawn, filling in the skipped lines. The field 
that is drawn first is called the dominant field.

Because of this field interlacing, 30 frames-per-second video is more accurately 
described as 60 fields-per-second. When developing video imagery in RotoDV, you 
can take advantage of this higher level of temporal fidelity to achieve smoother 
motion. For the best results on material that is destined for video display, you’ll 
want to use field rendering.

To take full advantage of field rendering in your work, you’ll need to address it at 
three phases—on the way into RotoDV, during your work in RotoDV, and on the 
way out of RotoDV. 

On the Way In
Full frame, real-time video capture hardware delivers interlaced fields. The type of 
source video and your capture settings will determine the field order. Refer to the 
documentation that came with your hardware for more information.

When rendering animations in a 3D program, you should use field rendering to 
generate interlaced fields. The 3D program may allow you to specify the field order. 
147



Appendix B      
While Working in RotoDV
When you begin a new RotoDV project, you should specify the field dominance 
that matches your source video clips and intended output.

When you open an interlaced video clip in RotoDV, you should separate the fields 
according to the field dominance (order) of the source material and project. 
(Separating fields on a clip is part of pre-processing, covered on page 48.) The field 
dominance should be consistent throughout all source materials used in the project.

While working in RotoDV, you should use Paint on Fields Mode when developing 
fast-moving imagery. This allows you to paint into the odd and even fields 
separately, giving you better temporal fidelity. Paint on Fields Mode is not necessary 
for static or slow-moving imagery. Fortunately, RotoDV allows you to switch in 
and out of Paint on Fields Mode, so you can use it only where it’s needed. See 
page 66 for information on working in field mode.

On the Way Out
When you’re finished in RotoDV and you’re ready to output the work, you should 
make the movie with the Paint on Fields option set to the correct dominance. This 
ensures that the project is delivered as 60 fields with the field order your other 
software and hardware are expecting.

Note: DV video is 
second field 
dominant.

It is important to use the same field dominance throughout all phases of the project. 
In most cases the dominance will be determined by your video input/output 
hardware. If you accidently use a different field dominance, at some point, the fields 
will be displayed in the wrong order, and the results will be of lesser quality. 
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C  RotoDV Shortcuts

About Keyboard Commands and Shortcuts

Keyboard commands appear in RotoDV menus opposite the corresponding 
command. Other shortcuts work by holding down a modifier key before clicking 
the mouse. Following are tables which list of all RotoDV shortcuts grouped by 
category.
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Menu Command Keys

Table of Menu Shortcuts

Keys Command

command + A Select > All

shift + command + A Select > Frames...

command + B Edit > Auto Paint

command + C Edit > Copy

command + D Select > None

option + command + D Select > Feather...

option + command + E Layer > Merge Down

command + F Effects > Last Filter

shift + command + F Select > Fill

command + H Select > Hide Edges (of selec-
tion)

command + I File > Import Clip...

shift + command + I Select > Inverse...

command + K Edit > Project Settings...

shift + command + K Effects > Apply Key...

command + M File > Make Movie...

command + N File > New Project...

shift + command + N Layer > New Paint Layer

command + O File > Open...

command + Q File > Quit

command + R File > Render

shift + command + R File > Treat As Rendered
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option + command + R Edit > Set Real-Time Range...

command + S File > Save

shift + command + S File > Save As...

command + V Edit > Paste

command + W File > Close

command + X Edit > Cut

command + Z Edit > Undo / Redo (command)

command + ; Edit > Preferences...

command + ] Layer > Move Forward

shift + command + ] Layer > Move To Front

command + [ Layer > Move Backward

shift + command + [ Layer > Move To Back

Table of Menu Shortcuts

Keys Command
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Appendix C      
Transport Shortcuts

Table of Transport Shortcuts

Key Control

spacebar toggle Play/Stop

control + spacebar Record mode

left arrow Step backward

right arrow Step forward

 option + left arrow Go to start

 option + right arrow Go to end

control + left arrow Rewind

control + right arrow Fast Forward

slash toggle Play Mode (play-to-end 
/ loop / back and forth)
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Tools Palette Shortcuts
Tools Palette Shortcuts

Table of Tools Palette Shortcuts

Key/Control Tool/Mode

B Brush tool

H Hand tool

I Eyedropper tool

L Lasso tool

M Marquee tool

Q Quick Preview tool

V Move tool

Z Zoom tool

C Color material mode

E Erase material mode

S Clone material mode

double-click on zoom tool Zoom document window to 
100%
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Appendix C      
Current Selection Shortcuts

Table of Selection Shortcuts

Key/Control Action

delete clear current selection

command + left arrow nudge current selection left

command + right arrow t nudge current selection right

command + up arrow nudge current selection up

command + down arrow nudge current selection down

option + click/drag make a copy of current selec-
tion
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Timeline Shortcuts
Timeline Shortcuts

Table of Timeline Shortcuts

Key/Control Action

up arrow select layer above

down arrow select layer below

backslash toggle the active stack (Media 
Stack / Blend Stack)

click on stack label activate Media or Blend stack

click on layer label select layer

double-click on layer label open layer options dialog

click on layer eye toggle: show / hide layer

option + click on layer eye toggle: hide other layers / 
show all layers

click on thumbnail select frame and move time 
cursor

shift + click on thumbnail select range of frames
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Appendix C      
Window and Palette Shortcuts

Table of Show/Hide Window and Palette Shortcuts

Key Action

tab show/hide all palettes

shift + tab show/hide all palettes except 
Button Bar

F1 show/hide Transport palette

F2 show/hide Tools palette

shift + F2 show/hide Tool Options pal-
ette

F3 show/hide Brushes palette

shift + F3 show/hide Brush Options pal-
ette

F4 show/hide Dabs palette

shift + F4 show/hide Dab Options palette

F5 show/hide Color palette

shift + F5 show/hide Swatches palette

F6 show/hide Info palette

F7 show/hide Clone palette

F8 show/hide Lightbox palette

F12 show/hide Timeline window

shift + F12 update Timeline window
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I Index
Numerics
1 indicator 63
2 indicator 63
3D animation 12, 47

and fields 147

A
adjusting brushes 94
adjusting the brush dab 92
Airbrush tool 76
alpha

Invert 57
inverting 47
None 47
straight 47

Alpha checkbox 47
Amount slider

in Links tab 89
Angle

in brush links 90
apply effects onto video 108
applying a key 134
Aspect ratio

locking 42
Auto Paint 66
Auto Paint button 66
AutoSpool 52

B
Back and Forth button 64

background color 43, 48
setting 44

Behavior
of brushes 86

Black and white
shortcut buttons 98

Bleed
in brush links 90
in Tool Options 86

Blend Mode
for brushes 86

blend mode
color 145
color burn 144
color dodge 144
darken 144
difference 144
dissolve 143
exclusion 144
hard light 145
hue 145
lighten 144
luminance 145
multiply 144
normal 143
overlay 144
saturation 145
screen 144
soft light 145

blend modes 141
and custom brushes 143

Blend Stack 50, 56–57
Blend View 53
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Index 
blending modes
in double blend layers 142
with Brush Tool 143

blending operations 115
Brush Attribute pop-up 89
brush behavior 86
Brush Commands pop-up 84
Brush Controls

in Brush Options palette 85
brush dab

adjusting 92
brush link attributes

Angle 90
Bleed 90
Fade In 90
Fade Out 90
Flow 90
Hue 90
Luminance 90
Opacity 90
Position 90
Ratio 90
Resaturation 90
Saturation 90
Size 90
Spacing 90

Brush Links
in Brush Options pallette 87

brush links
Direction 89
Pressure 89
Random 89
Tilt X 89
Tilt Y 89
Velocity 89

Brush Options Palette 84
brush problems, resolving 95
Brush Set

closing a 84

creating a new 84
opening 84
removing a tool from 84
saving 84

Brush Set files 84
loading automatically 84

Brush Sets
switching between 83

brush stroke spacing 86
Brush tool 91
Brush variant

deleting 84
Brushes

renaming 84
saving 84
saving custom 83

brushes
adjusting 94
data sources 87
linking to different data sources 87

Brushes palette 82–84
Burn tool 76
Button Bar 17, 47, 56

C
cache

location 43
captured video 12
carrying paint forward 66
CD-ROM delivery 58
Chalk tool 76
Channel key filter 136
choosing a dab 91
Clamp

for brushes 85
Clear 133
Clip Options dialog 44, 46
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Clone palette 69
clone palette 69
clone source location, setting 123
Cloning 121
cloning brush 69
cloning brush, using 121
Close 55
Close Brush Set 84
Close Color Set 98
Close Dab Set 92
color

creating a new 98
Color blend mode 145
Color Burn blend mode 144
Color Dodge blend mode 144
color Key filter 135
color level

and alpha channels 59
Grayscale 59
Millions 59
Millions of colors+ 59
Thousands 59

Color Level pop-up 59
Color Palette 98
Color palette 98–99
Color Picker

HSL 99
RGB 99

Color Range key filter 137
color sets

closing 98
creating a new 97
opening 97
saving 98

Colorize tool 76
colors

deleting 98
Colors palette 98
compositing 58

compression 57, 59
Compression button 57
compression formats 60

Animation 58
Cinepak 58
None 58

compression hardware 60
compression options 58
compression settings 58

Frames per Second 59
Key frame Every ___ Frames 59
Limit Data Rate to __ K/Second 60
Quality 59

Compression Settings dialog 57–58
Compressor pop-up 58
constraining playback 73
conventions 13
Copy 132
creating a link 88
creating a new Dab 92
Current Frame Indicator 52
current frame indicator 52
custom dabs

organizing 91
Custom range 56
customizing a dab 93
Cut 132

D
Dab Commands 92
Dab Commands pop-up 92
Dab Options

Angle slider 94
Ratio slider 94
Size slider 93
Softness slider 94
Style 93
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Index 
Dab Options palette 91–93
Dab Set files 91
dab set files

loading automatically 91
Dab Sets 91
dab sets

closing 92
creating a new 92
opening 92
saving 92
switching between 91

dabs
choosing 91
saving 91

Dabs folder 91
Dabs Palette 91
Dabs palette 91
dabs, deleting 92
Darken blend mode 144
data rate 60
data rate limits 60
Delete Color 98
Delete Dab 92
Delete Tool 84
Deselect 127
Difference blend mode 144
Difference key filter 138

isolating a subject with 138
Digital Origin logo button 17
Direction

in brush links 89
disk cache location

setting 49
display system

and playback 62
Dissolve blend mode 143
Distort control

in Brush Options palette 86
document window 53

document window display
toggling 51

Dodge tool 76
drawing tablet 87
Duplicating the Selection 131
Duration 46
dynamic modulation

of brush attributes 87

E
editing brushes 94
Effects Brush 76
Effects menu 134
End button 64
Exclusion blend mode 144
exporting

Alpha option 57
exporting a project (Make Movie) 55
exporting movies

and alpha channels 56
exporting QuickTime movies 56
Eye icon 110
Eyedropper 74

F
Fade In

in brush links 90
in Tool Options 86

Fade Out
in brush links 90
in Tool Options 86

falloff slope 135
Fast Forward button 64
Fast Reverse button 64
Feather 128

and masks 132
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Feathering
of selection tools 80

field display 63
field dominance 48

consistency 148
First Field Dominant 48
for output 148
Second Field Dominant 49

Field Mode 49, 63, 66
Field Mode button 66
field mode options 48
field order 48
field rendering 48, 147

first field display 63
second field display 63
whole frame display 63

File Types 45
Fill 127
Filled dab 93
first field 63
Flow

in brush links 90
Forward button 64
frame advances

in field mode 63
Frame Back button 64
Frame Forward button 64

and AutoPaint 66
Frame Mode 66
frame rate 59, 67
frame rates

and preview box 74
frame size 42
Frame View tools 77
frame view tools 77
Framed dab 93
Frames 129

H
Hand Tool 54, 77
Hard Light blend mode 145
Hide Edges 128
Hilite tool 76
Hue

in brush links 90
Hue blend mode 145

I
Import Clip 44
importing a clip 44
In Point 46
Info

A 67
Actual FPS 67
HSV 67
RGB 67
W, H 67
X, Y 67

Info palette 67
Ink Pen tool 76
Installation 16
interlaced fields 48
interlaced video 147
Inverse 127
Invert alpha 57
inverting alphas 47
isolating imagery 73

J
Jog 65
jog/shuttle 67
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Index 
K
Key filter

channel 136
Color 135
color range 137
difference 138

Key Filter dialog 134
Key setting

Cubic 135
Invert 135
Linear 135
Preview 135

Keyframes
and temporal compression 59

keys, applying 134

L
Lasso selection tool 73, 125
layer visibility 109–110
layers 50
layers, Paint 105
layers, types of 105
layers, Video 105
light icon 68
Lightbox 68

adjacent frames 68
Fade 68
Frames Back 68
Frames Forward 68
ghosted overlay 68
Opacity 68

Lightbox icon 68
Lightbox palette 68
Lighten blend mode 144
Link Modulation Sources 89, 135
Links

range of modulation 89

links
creating 88
editing 89
removing 89

Links drawer 87, 89
Links tab

Amount slider 89
Live Playback Range 56
Live Window Dragging option 50
Loop button 64
Luminance

in brush links 90
Luminance blend mode 145

M
Magnifier (Zoom) Tool 77
magnifying (zooming) 54
Make Movie 55, 60

Alpha option 57
Compression 57
In Point and Out Point 56

Make Movie dialog 56
manipulation tools 74
marching ants 124
Marquee selection tool 73
Media Stack 44, 50, 56

adding a layer to 105
Media View 53
modifying an existing dab 92
Move Tool 74
movies

saving 60
moving around the frame 54
moving paint selections 74
Multiply blend mode 144
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N
New Brush Set 84
New Color 98
New Color Set 97
New Dab 92
New Dab Set 92
New Project dialog 41–42
New Project on Start-up option 50
nfo palette 67
no indicator 63
Normal blend mode 143

O
onion-skinning 68
Opacity

for brushes 85
in brush links 90

opacity dropoff 68
Open Brush Set 84
Open Color Set 97
Open Dab Set 92
opening an existing file 50
optimizing playback 62
original source material 45
Out Point 46

for exporting 56
Overlay blend mode 144
overwriting a file 60

P
Paint

clone mode 79
color 79
erase mode 79

paint
moving between frames 132

moving between layers 132
moving within a frame 129

Paint control
in Brush Options aplette 86

paint layers 108
Paint Modes 78
Paint On Fields 43

unchecked 48
Paint on Fields Mode 148
paint tools 75
Paintbrush tool 76
Panning 54
panning

with scroll bars 77
with the Hand tool 77

Paste 133
Pause button 64
Pencil tool 76
Play and Stop

toggling between 64
Play button 64
Play Mode 64
Play Mode button 64
Play/Pause button 64
playback 51, 67

constraining 73
optimizing 62

playback speed 62, 67
Position

in brush links 90
Preferences 49
Preferences dialog box 49
Premultiplied alpha 57
Preserve Transparency

for brushes 85
Pressure

in brush links 89
pressure 87
processor speed 62
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Index 
Project 42
Project Duration 43
project length 42
Project Range 56
Project Settings 47
project settings 47
Project Settings dialog 48
Project Settings dialog box 47

Q
Quick Perview tool 73
QuickTime 58

compression formats 58
QuickTime effects, applying 139
QuickTime movie

exporting 56

R
RAM

allocating memory 17
and live preview 42
and Real-Time Range 51
requirements 16

Random
in brush links 89

Ratio
in brush links 90

Real-Time Range 43, 51, 65
adjusting 52
and RAM 51

Record button 64
Rectangle selection tool 125
references 45, 54–55
Rename Brush Varient 84
Resaturation

in brush links 90

in Tool Options 87
Rotate 127
RotoDV

how to use 12

S
Safe Region 53, 65
Safe Regions 54, 67

overlay 65
Safe Regions button 54, 65
Saturation

in brush links 90
Saturation blend mode 145
Save 55
Save As 55
Save Brush Set 84
Save Brush Set As 84
Save Brush Varient 84
Save Color Set 98
Save Dab Set 92
Save dialog

saving movies 60
saving a movie 60
saving a project 54
saving dabs 91
Scale 128
scratch files

location for 43
Screen blend mode 144
Scrub 65
second field 63
Select All 127
selecting frames 133

manually 133
numerically 133

selecting freehand shapes 73
selecting imagery
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from a video layer 73
selection

duplicating 131
Lasso tool 73
Marquee tool 73
masking with 132

selection commands 127
Selection Tool

Feathering 80
Selection Tools 125
Selection tools 73

and paint layers 73
selection tools 73
selection, choosing a layer for 125
selections 73, 124

adding to 125
manipulating 129
moving 127
subtracting from 125

Shuttle 65
Shuttle, Jog and Scrub controls 65
shuttling 65
Size

in brush links 90
SMPTE 63
SMPTE readout 52
Smudge tool 76
Soft Light blend mode 145
Source Input pop-up 88
source material 12, 50
source media 54
Spacing

in brush links 90
of brush stroke 86

Start button 64
stepping forward 66
straight alpha 47, 57
Stylus pressure 89
stylus tilt 89

supported file types 45
Swatches palette 96
system extensions

disabling 62
system requirements 15

CD-ROM drive 15
CPU 15
display system 15
hard disk space 15
OS 15
QuickTime 15
RAM 15

T
Table of Link Modulation Sources 89, 135
technical support 18
temporal compression 59
thumbnail image 52
thumbnail option 48
thumbnails, in timeline 104
Tilt X

in brush links 89
Tilt Y

in brush links 89
time-based compression 59
Timeline 50
tool behavior

and layers 72
Tool Options

Opacity slider 80
Size slider 80
Softness slider 80

Tool Options palette 79
Tool Tips 50
Tools

Quick Preview 73
Tools palette 72–73
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Index 
color box 78
Dab box 78
eyedropper tool 98

Transport buttons 64
Transport controls 64
Transport palette 52, 61, 63

U
Underlay 115
Unrendered

in Timeline 110
using a clip as a paint layer 108

V
Velocity

in brush links 89
video and paint layers, differences 107
video layers 107
video layers, selection in 125
View Opacity slider 109

W
Watercolor tool 76
Web support 17
whole frame 63
www.digitalorigin.com 17

Z
zoom and pan 77
Zoom Tool 54, 77
Zoom tool

temporarily selecting 54
Zooming 54

zooming out 54
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