
or TAR for short...

What TAR lets you do.

TAR allows you to digitally record music and sound from any analogue source onto your Macintosh 
computer. You can record from cassettes, vinyl, 8 Track, reel to reel, even VHS, in fact anything that 
you have playback equipment for. TAR supports 16 and 8 bit recordings in stereo and mono.

TAR records straight to disk, so it does not require large amounts of RAM. Uncompressed CD 
quality digital sound produces huge files - about 10 Mb per minute. (Both sides of a C-90 cassette, 
recorded on Auto Reverse would take 900 Mb.)

TAR has powerful and easy to use editing features that let you break albums or cassettes up into 
discreet tracks. This is very important if you don’t always want to listen to tracks 1,2,and 3 before 
track 4.

TAR produces tracks in AIFF format which are suitable for burning direct onto CD, or for 
compression into Mp3 files.

TAR lets you select a Mp3 encoder, or any other application, and gives you the option of sending 
your saved tracks to this application. 

What TAR does not do

TAR does not burn files onto CD. If you have a CDRW then you almost certainly got bundled 
software with it - probably the excellent Toast.

TAR does not encode Mp3s, but it allows you to select an encoder of your choice, and sends the files 
to that. There are some suggestions about free Mp3 encoders that you can download off the net 
below.

TAR does not do any digital signal processing, but you can also use the encoder selection feature to 
send recorded tracks to any application including a DSP.



What you need

PPC Macintosh Computer
8 Mb Free Ram
System 8.1 or later. - it might work with 7.6 but I haven’t been able to try it.
Monitor Resolution 800 x 600 pixels minimum.
Approx 500 Mb disk space. Note that less than 2 Mb of disk space is required for the program, the 
rest is for your recordings.

Audio Equipment

You can record onto your Macintosh through the internal microphone, however you might prefer to 
record from vinyl, tape, radio or other analogue source.

You will need an amplifier, the source (turntable, cassette deck etc), and some speakers.

Make sure that your Macintosh and all audio equipment is turned off while you are making 
connections.

Most Macs have a 3.5 mm stereo mini plug sound in port. You will need an audio cable with the 
stereo mini plug on one end, and two RCA phono plugs on the other for connection to your 
amplifier.

Some Macs (AV types) have phono sockets and these can be connected to directly.

There are pictures of the correct cables, and other useful info in Mac Help. Look under “Connecting 
audio equipment for inputting sound into you computer” in Mac Help under the Help menu in the 
Finder.

You need to connect your Mac to a tape out port on your amplifier.  You may also be able to connect 
your computer’s sound out port to the tape in port on the amplifier. You can then treat your Mac as if 
it were a cassette recorder. 

The newest Macs have sound inputs via their Firewire or USB ports for which  you will need an 
adaptor. Follow the instructions that come with the adaptor.

Some Free Mp3 encoders

mp3 encoder 0.12 

Works well with TAR, encodes up to 160 kbit/s

http://www.dtek.chalmers.se/~d2linjo/mp3/mp3enc.html

BladeEnc For Mac

Powerful and flexible.

http://www.helsinki.fi/%7Epkamppur/bladeencmac.html

A Cheap Mp3/AIFF Jukebox

Ian’s Digital Jukebox 2.0

Absolutely excellent actually

http://www.weblast.co.uk/Mp3.html

http://www.dtek.chalmers.se/~d2linjo/mp3/mp3enc.html
http://www.helsinki.fi/%7Epkamppur/bladeencmac.html
http://www.weblast.co.uk/Mp3.html


Using The Analogue Ripper

TAR has a powerful on screen help system, that will give you information about the item currently 
under the cursor. If this is not shown (at the bottom of the window) select “Show Help” from the 
Options Menu. Note that this is not available on a screen size of 800 x 600 pixels.

TAR is based on two windows, the “Record to File” window, and the “Edit Sound” window.

TAR will not function properly if another application has access to the sound input device. Make sure 
you shut down any other recording programs before running TAR.

How To Record Sounds to File

TAR will supply you with a default file name to record to. If you want to change this,  either select  
“Save Recording As” from the File menu, or click on the “Save As” button. You can’t change the file 
name after recording has started.

Turn on your recording source, and set the Device and Source popups to suit. This will generally be 
as “Built In” for Device, and either “Sound In” or “RCA In ‘ for Source.

Set the Sample Rate to the highest available or 44100 Hz.

Set the Sample Size to 16 bit.

Set the number of channels to Stereo (2) or Mono (1) depending on what you are recording from. 
(There is no point in recording a mono recording as stereo, it will just take up twice the space)

Set the Input Gain to “Manual Gain”

Set PlayThru to “Is On” if you want the sound signal played back by your Mac, or “Is Off” 
otherwise.

Adjust the Input Gain, by moving the slider, until the level meter is mainly in the yellow area (green 
when recording) with occasional movements into the red zone. A bit of red is OK, but your recording 
will sound distorted if the level stays there. For me an Input Gain of 115% works best, but this will 
vary depending on your equipment.

Adjust the silence threshold so that between tracks or when the sound has finished, if the level meter 
is visible, it stays in the blue area. For me this is best set at 2% - 4% for most clean sources.

Set the “Stop After Silence” period by moving the scroll button. Your recording will automatically 
terminate after this period of sound below the “Silence Threshold”. I recommend  30 seconds.

Set the “Stop After Time” to a value greater than the duration of whatever you are recording from. 
This is really just a fall back in case the source is very noisy. 

Move your source back to the beginning, and click on the “Record” button.

Pausing and Resuming recording.

You can pause recording at any time by clicking on the “Pause” button. While recording is paused, 
the timers are stopped and the “Stop After Silence” feature is disabled.

You can resume recording by clicking on either the “Record” or  “Pause” buttons.

Stopping Recording

Recording will terminate automatically after the sound level has been below the “Silence Threshold” 
for the “Stop After Silence” time, or the “Stop After Time” has elapsed. You can also stop recording 
at any time, by clicking on the “Stop” button.

When you stop recording, the “Record To File” window will close and the “Edit Sound” window 
will open. Your sound will be opened for editing, this may take a little while as TAR has to read the 
whole file to get the volume trace.



How to break an open sound file up into tracks:

When recording has stopped, the Edit Sound Window will open. You can also open other AIFF files 
by selecting “Open AIFF File “ from the File menu. You can only have one file open for editing at a 
time.

You can stop TAR from loading the current sound file by holding down the Escape key or pressing 
Command Period.

TAR presents the sound as a volume trace averaged over 0.1 second periods. The trace is relative and 
no scale can be assumed. Silences are represented by low levels, crescendos by high levels.

Check the LP, Cassette or other source for the number of tracks, but don’t worry if you don’t know 
this.

Set the silence between tracks to one second. Set the minimum track length  to 30 seconds. ( These 
are defaults and will already be set.)

Click on the “Auto” button, to turn on the automatic track seeking feature. (It is set as a default.)

Click on the magenta silence threshold line, and move it slowly up into the recording, the track 
beginnings and ends will start to appear, represented by green and red lines respectively. When the 
“Nº Tracks” shown at top right equals the number of tracks that you were expecting, stop.

Note that you can combine adjusting the “Silence Between Tracks”, the “Minimum Track Length”, 
and the “Silence Threshold” to fine tune this process as you become more experienced.

Do not move the magenta “Silence Threshold” line again or it will move the track markers and delete 
any changes you have made manually.

You can move the light blue start play marker to the beginnings/ends of tracks and click on play to 
check that the track markers are in the right place.  See below under “How to Play  Sounds from the 
File”.

You can move track markers by clicking on them and dragging them. You can add new track markers 
by clicking on the “Place Start” or “Place Stop” buttons and clicking in the volume trace plot area. 
You can delete the selected track marker by clicking on the “Delete” button. The selected track marker 
is the last one you clicked on, or the last one placed, it has small triangles facing up and down at each 
end.

You should now have a list of tracks in the scrolling list at bottom left. These are initially given 
default names based on the name of the sound file. You can edit the names by entering new names 
into the edit field and pressing Return or Enter.  You can select names to edit by pressing Tab, or by 
clicking in the darker grey area of the scrolling list. On clicking in the darker grey area, you will jump 
to the start of that track in the volume trace.

If you don’t want to save all tracks, you can toggle whether tracks are saved by clicking in the right 
hand, lighter grey area of the scrolling list.

If you cannot get tracks to save, it may be because there is insufficient space on the volume that you 
are trying to save them to. TAR will not allow you to try to save files for which there is insufficient 
space. You can see the space available and the space required at bottom right. You can change to a 
different folder or volume by selecting “Select Track Folder” from the File Menu. Note that you can 
save some files to one volume, change volumes and then save the rest.

When you are ready to save tracks, select “Save Tracks “ from the file menu. (This will be dimmed if 
TAR is not registered.)

You can stop TAR from saving tracks by holding down the Escape key or pressing Command 
Period. The track currently being saved will be, the rest won’t.

After you have done this a few times, and are confident in the placement of the track markers, you 
can select “Delete Source after Saving Tracks” from the option menu. When this has a check beside 
it, the source file will be deleted after the tracks have been saved. The source file will not be deleted 
unless all tracks have been saved.



How to Play Sounds from the File

You can play sounds from any position in the sound file. Sound starts playing from the position of 
the light blue start play marker. The position of the actual sound playing is shown by the vertical light 
blue line moving through the volume trace.

The position of the start  play marker and the current play marker can also be seen in time form at the 
right of the button bar.

To start sound playing, click on the “Play” button. Sound will start playing from the position of the 
light blue start play marker. The “Play” button has no effect if sound is already playing.

To pause sound playing click on the “Pause” button. The sound will pause, and the position of the of 
the current play marker is fixed.

To resume sound playing click on either the “Play” or “Pause” buttons.

To stop sound playing, click on the “Stop” button.

Sound will stop playing when the current play marker reaches the end of the file.

If you click on “Place Play” while music is playing, the volume trace will jump to the position of the 
current play marker.

The Options Menu

The options menu contains several er options:

Show Help - select this item to toggle whether help information is shown

Delete Source after Saving Tracks -  select this item to toggle whether the sound file will be 
deleted after you have saved tracks. Note that this will not happen anyway if you have not saved all 
tracks.

Output to Mp3 Encoder. If you have chosen a valid output application and select  this option, 
tracks will be sent to that application after they have been saved. Note that although the menu option 
refers to an Mp3 encoder, you can send your tracks to any application - it would be a good idea to 
make sure that it knows what to do with them.

Follow Music Playing. If this is selected, the volume trace will scroll past the stationary current 
music marker while music is playing. If it is not selected the volume trace remains stationary and the 
current music marker moves. Note that while “Follow Music Playing” is selected and music is 
playing you can’t move markers or the volume scroll.

Show Track Names. If this is selected the track name will be shown in the volume trace to the top 
right of the track start marker.

Select Mp3 Encoder. Select this item to choose an application to send your tracks to after saving 
them.

Backgrounds. Make TAR look different depending on your mood. Is it a red day today or a blue 
day ?



Sending your Tracks to an Mp3 encoder, DSP or other application.

To send your tracks to another application after they have been saved :

Select “Select MP3 encoder” from the Options menu. When you have found the application that you 
want to use click on the Open button. The application is now selected.

Make sure that the “Output to MP3 encoder” menu item under the Options menu is checked.

Your tracks will now be sent to the application you have selected.

Notes :

TAR sends files to your chosen application by saving them with the creator code of that application 
and requesting that the Finder open the files. If your chosen application does not accept Apple Events 
this will not work correctly.

If you do not select an output application - or if the  “Output to MP3 encoder” menu item under the 
Options menu is not checked, your tracks are saved as QuickTime Player documents, and will start 
QuickTime Player when double clicked in the Finder.

How to Register TAR

TAR is limited to ten minutes per recording, and is unable to save tracks unless it is registered. 
Registration costs $19.95.

To register :

Select Register from the File Menu, the registration window will open. Make a note of the registration 
lock. It is all digits - no letters.

Go to this link :

http://www.weblast.co.uk/TAR/Ripper.html

Press the PayPal buy now button. (It’s right at the bottom of the page.)

Follow the instructions, and enter the registration lock in the notes field.

When you have confirmed the payment, PayPal will advise me and I will e-mail the registration key 
to you.

If you forget to enter the registration lock in the notes field, you can e-mail me direct at

i.mann@which.net

Enter the registration key in the field in the Register window and click on the Now Register button.

Registration may become available through Kagi, but TAR will cost more if this payment option is 
selected.

http://www.weblast.co.uk/TAR/Ripper.html
mailto:i.mann@which.net


Bug Reports

If you have problems with TAR please e-mail me and let me know the type of problem, the type of 
Mac, and the system version.

Known Incompatibilities and Bugs

At screen size of 800 x 600 TAR cannot display help - its all in this manual though.
TAR does not currently work with the MacAlly iVoice.

Improvements and Additions.

The Analogue Ripper 1.02

TAR now recognises USB Audio devices that interface through the Sound CP - see note above.
TAR can now be run on Macs with a monitor size of 800 x 600 pixels, but does not display help.
TAR version now correctly shows full version number in the Register window.
Fixed bug in calculating number of frames, that very occasionally led to EOF error.

The Analogue Ripper 1.01

Disabled immediate play feature to prevent crashes caused by stop/start play.
Changed Register window type to improve interface/avoid odd behaviour
Fixed problem with chosen tracks being saved even if no room.
Space available to save tracks now updates correctly as tracks are saved.

The Analogue Ripper 1.0

Gain now set to 1 when recording finished.
Gain now properly set to last setting.
Window names moved to STR# for localisation.
Changed VolumeFreeBytes to work with pre System 8.6
Record button pops up properly
Markers can now be picked up on the line as well as in their triangles.
Pressing Auto now stops further placement of start and stop markers.
TAR now quits properly on Finder quit.
File size limited to 2 Gb (3 hrs 12 minutes at best quality)
Default file name changed to aRip (why was it iRip ?)
Fixed bug where silence time out still happened if recording paused.
Forced stop play before save tracks. (Worked but sounded bad)
Tidied checks on Device in use by another application.
Track Names can now be shown on volume trace.
Added Option for volume trace to scroll to follow current music position.
Made improvements in moving through the file.
Sorted out problems in sound files longer than one hour.

Thanks and Acknowledgements

Thanks are due to Alain Pastor, George Beckman, Robert Purves, Bernie Wylde, Robert Covington, 
Ranko Bojanic, Steven Stratford,  and of course Staz and Andy at Staz Software home of 
FutureBasic^3 .

You can program !

http://www.stazsoftware.com

http://euro.futurebasic.com

http://www.stazsoftware.com
http://euro.futurebasic.com


Legal Stuff

TAR is for use by people wanting to convert their own collections of analogue recordings to digital. It 
is not designed for commercial use. 

I have taken great care in writing TAR, but can accept no liability for any losses arising from it’s use, 
whether registered or unregistered.

TAR is supplied as is. Ian Mann hereby disclaims all warranties relating to this software, whether 
express or implied, including without limitation any implied warranties of merchantability or fitness 
for a particular purpose. Ian Mann will not be liable for any special, incidental, consequential, indirect 
or similar damages due to loss of data or any other reason, or for any claim by any other party, even 
if Ian Mann , or an agent of Ian Mann has been advised of the possibility of such damages. In no 
event shall Ian Mann’s liability for any damages ever exceed the price paid for the license to use the 
software, regardless of the form of the claim. The person using the software bears all risk as to the 
quality and performance of the software.

The user of this program accepts responsibility for obeying all applicable copyright law.

I hope you have a lot of fun with it.


