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Midius ProjectPlanner

Mikael Arctædius, Midius Art & Science

User’s Manual for Midius ProjectPlanner 
version 1.5.1

1.0 Introduction

Midius Project Planner is a tool for creating Gantt charts. It is suitable for small and 
mediumsized projects.

With the Midius ProjectPlanner you can…

• create Gantt charts

• customize default base week work hours

• customize team members’ work hours

• customize default and team members calendar to adapt to local holidays and 
team members vacations.

• track slips in the time schedule

Example of a Gantt chart is shown below.
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FIGURE 1. A Gantt chart

2.0 Acknowledgements and References

• The ProjectPlanner is written in C++  and some plain old C. No class library is 
used. It was modeled in ObjectPlant (http://www.arctaedius.com/ObjectPlant/) 
which also was used to generate code.

• The splash-screen picture was rendered with Persistence of Vision.

• The application icon is based on an icon created by The Iconfactory.
http://www.iconfactory.com

• Information about ProjectPlanner (known bugs, new releases etc) can be found 
at:

http://www.arctaedius.com/ProjectPlanner/

3.0 Typografical conventions

Menu choices are written in helvetica, e.g. Schedule->Project Settings...

4.0 Registration

The ProjectPlanner is distributed as shareware.  You are permitted to use it on a trial 
basis for up to 30 days.  If you wish to continue using the product beyond that 



System Requirements

Midius ProjectPlanner 3 of 26

period, you are expected to pay a registration fee to obtain a license to use Project-
Planner.

Entering the license code into the program will remove shareware popups.

To register use the Register program to create a register form which then shall be 
sent to Kagi Shareware using mail, email or fax.

The price for a single license is 35 USD, there are also site and world licenses avail-
able for 600 USD resp. 2500 USD.

http://www.kagi.com
Email: sales@kagi.com    (1 to 3 day processing time delay)
FAX: +1 510 652 6589     (4 to 8 day processing time delay)
Postal address:                  (4 to 8 day delay plus transit time to Kagi)
Kagi
1442-A Walnut Street PMB #392-MU
Berkeley, California, 94709-1405
USA

5.0 System Requirements

The ProjectPlanner requires:

• 68020 or better (including any PowerPC processor)

• Colour display is required

• MacOS 8.6; built for MacOS X

6.0  Preparing a time plan

6.1 Assumptions

The ProjectPlanner assumes the following:

• that a typical workdays starts at 8 am and ends at 5 pm

• that a typical workday includes one hour lunch during 12:00 - 1:00 pm

These assumptions does not normally create any problems, basically because most 
people do normally work between 8 and 5 and have a one-hour lunch during the 
day, but also because it only influences when doing time charts with a resolution in 
hours. Normally a time plan’s smallest unit is a complete work-day.

6.2 What kind of timeplan do you need?

You can either go for a detailed plan including all activities, listing all project partic-
ipants, their work schedule and so on. Doing this will give a more accurate time 
plan which will also be easier to use when doing follow-ups on a project.

The other alternative is to make a rough timeplan, just estimating the total cost for, 
e.g. s/w development, and not including any details about the personnel, holidays 
etc.

If you decide to make a rough time plan you can skip the first N sections and con-
tinue directly at section 6.8
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6.3 Preparing the base week information

If you want the time plan to be as exact as possible, you should define the default 
base week used by most of the members in the project. When creating a new time 
plan, the default base week will be initialized by setting all weekdays (monday 
through friday) to consist of 8 workhours each. Saturday and sunday are set to zero 
workhours.

Change the default base week of a document by selecting Schedule->Project Set-
tings.... This will bring up the Project Settings dialog window where the General 
tab looks like this:

FIGURE 2. General tab in Project Settings dialog

In this tab it is possible to, for example, specify that you only work 7 hours on fri-
days, or that you normally work nine hours on weekdays.

6.4 Preparing the default calendar

You should also modify the default calendar to suit your “public holiday scheme”. 
When creating a new time chart, the default calendar will be initialize by setting all 
days equal to the defined base week.

Change the default calendar by selecting Schedule->Project Settings.... This will 
bring up a Project Settings dialog window. Then click on the Calendar tab.
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FIGURE 3. Calendar tab in Project Settings dialog

In this tab you can specify the exceptions from the base week, e.g. you can set 
christmas day to be free, i.e. 0 workhours. This has to be done for every month and 
year that the project is running. (Once you have done it, the default calendar can be 
used for other time charts too using the File->Import calendar... command.)

The calendar can only accept hours and tenths of hours, i.e. the following values are 
accepted:

8 8 hours
6.5 6 hours and 30 minutes (5*6 minutes)
7.7 7 hours and 42 minutes (7*6 minutes)

while the following entries would be illegal:

7.25 8.00

6.5  Edit team members

If the time plan should include the name of the people actually performing a certain 
activity, it is best to enter all team members using the Team Member tab in the 
Project Settings dialog which you can bring up by selecting Schedule->Project 
Settings....
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FIGURE 4. Edit team member tab in Project Settings dialog

In a new project, the team member list will be empty. . Add new team members by 
clicking the New... button. Then the “New team member dialog” will be displayed.

The edit and delete buttons will be enabled when any team member in the list is 
selected.

FIGURE 5. New team member dialog (“kr” is the currency unit used in Sweden)

Just type the name of the team member (or some short form, initials for example) 
and the cost per hour (optional) and continue until all team members have been 
entered. Then click the Ready button.
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6.6 Adjust base week for team members

If any of the team members work more or less than specified in the base week dia-
log, you can specify a customized base week for that member. This can be very use-
ful when for example someone is working parttime on a project.

To specify a customized base week for a team member bring up the Base Week dia-
log again. Select the team member from the popup menu and then adjust the base 
week as appropriate.

6.7 Adjust calendar for team members

Each team member can have a customized calendar. By customizing a team mem-
ber’s calendar you can enter information such as the team member’s vacation.

To specify a customized calendar for a team member bring up the Calendar dialog 
again. Select the team member from the popup menu and then adjust the calendar as 
appropriate. For example when the team member is on vacation, his/hers workhours 
should be set to zero.

In the figure below, team member Anna is on vacation starting on Saturday 8:th of 
january and will be back on work Wednesday 19:th.

FIGURE 6. Customized calendar



Preparing a time plan

8 of 26 Midius ProjectPlanner

6.8 Setting up the time scale

The next step would be to select the most appropriate time scale to be used for the 
project’s time plan. For most projects, “weeks” would be the most suitable. You can 
then specify activities to start on a specific day, and each activity must be at least 
one day long. For very long projects, “months” could be better since the time chart 
could then perhaps fit within a window without having to scroll back and forth to 
see the complete time chart.

FIGURE 7. Time Scale setting in General tab in Project Settings dialog

In the General tab in Project Settings dialog you can also select if the duration of an 
activity shall be displayed in days only or weeks and days, e.g. an activity has a 
duration of 7 days. This could either be displayed as 7d (7 days) or 1w 2d (1 week 
and 2 days). There is also an option to change the standard value of hours/day that is 
used when converting duration days to duration hours. Normally a duration speci-
fied as one day euqals 8 hours but this can be changed in this dialog.

If you modify the “number of hours/day” it is wise to also modify the default base 
week to the same number of hours per day. If you don’t do this you might get some 
strange results in the duration computations.

6.9 Setting the start date of the project

When creating a new project in ProjectPlanner, it will automatically set the start 
date of the project. Since the default time scale is weeks, it will set the start date to 
the last sunday. If this doesn’t suit your needs, you can manually set the start date of 
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the project by using Schedule->Set start date... menu command. This will bring 
up a dialog where you shall enter the start date. If you already have some activities 
in the project, you cannot set the start date to be later than the earliest startdate of 
any of the activities.

FIGURE 8. Set start date dialog

7.0 Activities and Summaries

With the ProjectPlanner you can enter all activies in project. An activity can either 
be SW development (high level of abstraction) or performing test of module Z (low 
level of abstraction). Before starting entering activities into the project time plan, 
you should decide what level of abstraction that is necessary for your particular 
project.

A set of activities can be displayed as a single summary activity, where the start and 
end dates of the summary equals the first startdate of any included activity and the 
enddate equals the last enddate of any included activity.

FIGURE 9. Three activities summarized

7.1 Work

An activity always requires a certain amount of work. The shortest possible required 
work for an activity in ProjectPlanner is one day. Work is always expressed in 
weeks, days and hours, where a day equals 8 hours (or as specified in the “Time 
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Scale” dialog)  and a week equals 5 days. When estimating the required work for an 
activity always measure it in work-days, i.e. 8 hour increments, or work-weeks, 5-
day increments. Even if your base week says that you work 7 days a week, the 
workweek equals only five duration days.

An activity always has a startdate and a duration. The stopdate may vary depending 
on the number of assigned team members, the calendar and team members’ calen-
dars and baseweeks.

Please note that the work is not always equal to the number of days between the 
start date and the end date but depends on the number of people assigned to the 
activity (listed in the responsible column).

7.2 Duration

The duration always equals the number of days between the start date and the end 
date but does only include work days as defined by the default calendar. The dura-
tion is basically defined as a number of hours but can be input and displayed as days 
and weeks also. A day equals the number of hours as specified in the General tab of 
the Project Settings dialog. A week always equals 5 days.

7.3 Entering an activity

There are two ways of entering the startdate and duration/work of an activity, using 
the mouse or using the keyboard. The name of the activity is always entered through 
the keyboard by positioning the textcursor inside the “Activity” column of the table 
of activities.

An activity can be entered using the mouse (select the activity tool) by clicking in 
the right area of the window and holding the mouse button down while dragging the 
mouse to get the appropriate duration. The point where you click at first will be the 
startdate of the activity and to create an activity you must release the button while 
pointing to a point to the right of the startdate. If you release the button when the 
mouse is pointing to the left of the startdate no activity will be created.

The other way of entering an activity is by positioning the textcursor in the “Dura-
tion” column in the table of activities, enter a duration, e.g. 12d, then move the text-
cursor to the next column in the table which should be the start date of the activity. 
There you shall enter the start date and time in the format that is currently selected 
(in the Date and Time control panel), e.g. 98-01-13 08.00

When moving the textcursor from the start date column (or just pressing return) the 
activity line will show up in the right area of the window.

7.4 Locking an activity

An activity’s start or stop date can be locked by selecting the activity and then do 
Edit->Lock Activity. By default the activity’s start date will be locked to the current 
setting and a small padlock icon will be displayed in the rownumber column of that 
activity.
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FIGURE 10. A locked activity

When the start date has been locked you cannot edit the startdate column of that 
activity, neither can you move the activity dragging the activity line in the activity 
diagram.

To lock an activity’s stop date you should first lock it to the start date (with the Edit-
>Lock Activity command) and then ctrl-click on the padlock icon to bring up a 
popup-menu where you can select to either unlock the activity or lock the stop date.

FIGURE 11. The padlock popup-menu

When an activity has a locked stop date you cannot edit the stop date column neither 
can you move or extend the activity line in the activity diagram. If you change the 
duration of an activity with a locked stop date, the start date will be adjusted accord-
ingly. Furthermore if you edit the start date, the duration will automatically be 
adjusted.

You can unlock an activity by either selecting the activity (in the table) and do Edit-
>Unlock Activity or by bringing up the popup-menu on the padlock icon and select 
the unlock item in the popup-menu.

7.4.1 Linking a locked activity
There are some rules on how you may link a locked activity:

1) in a chain of linked activities only of the activities can be locked (if you select an 
activity that is linked (directly or indirectly) to a locked activity, the Edit->Lock 
Activity item is disabled)

2) If you try to link two activities which are locked (directly or indirectly) you will 
get a warning popup explaining that the link is illegal.
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7.5 Making a Summary

If you want to make a summary of a group of activities, for example four activities, 
there are two ways to do this. Either you can move the textcursor to the very first 
row of these four activities, and position the textcursor at the very first position of 
the Activity column. Then to make the first activity part of a summary, press the 
TAB-key. A new summary row will automatically be inserted right before the cur-
rent activity row and the current activity row’s activity name will be indented. Then 
continue with the following row. Put the textcursor at the very first position in the 
Activity column and press the TAB-key. This time no new summary-row will be 
created since the activity-row right above already is a part of a summary group. 
Finally do the same for the last two rows.

Another way to create a summary for the four activities is to select the four activi-
ties by shift-clicking in the leftmost column and then use the Edit->Summarize 
menu command.

If you have an activity which you now want to convert to a summary and split it into 
several activities, you can select the activity and then use the Edit->Convert to 
summary command. This will turn the selected row into a summary and a new 
activity will be added below the summary. The new activity will be a copy of the 
original activity, having the same name and same start- and end-dates.

The last of activities in a summary can be converted back to a “main”-activity by 
positioning the textcursor at the Activity’s first character position and then using the 
backspace key.

8.0 Dependencies

An activity can be dependent upon another activity, i.e. the first activity must be 
completed before the next activity can start. This kind of information can be added 
to the diagram using the “Dependency tool”. Select the dependency tool, click in the 
first activity’s end date “diamond”, hold the mouse button down while dragging the 
mouse cursor until you point it to the start date diamond of the depending activity. 
When you have the cursor correctly positioned, you will see a black circle round the 
start date diamond indicating that you can release the mouse button.

FIGURE 12. How the dependency tool indicates when the mouse is positioned over an activity’s 
startpoint
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9.0 Tracking time slips

To be able to track slips in the time plan you can save the original start and end date 
for one or several activities. If you then change the start or end date of an activity 
(with a saved original start and end date) the activity will be drawn with two bars 
one for the original start and end date and one bar for the current start and end date.

To set the original date for all activities just select Schedule->Set Original 
Dates...

If you have one or several activities selected, you can choose to set the original 
dates for the selected activities only.

FIGURE 13. Two activities with original dates and current dates shown

It is also possible to clear the original dates for all or selected activities by using 
Schedule->Clear Original Dates...
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10.0 Reference Manual

10.1 Terminology

10.2 Toolbox palette

The toolbox palette has four different tools:

FIGURE 14. The toolbox palette

10.2.1 Select tool
The Select tool is used mainly for three things:
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• Moving an activity line in the activity diagram

• Resizing an activity in the activity diagram

• Selecting a dependency link to be able to delete it

You do not need to select the Select tool to position the textcursor in the table of 
activities or to select a row in the table of activities. Whenever you move the mouse-
cursor over onto the table of activities it changes into a textcursor. And when you 
position the mouse cursor over the first column of the table, it will change to a select 
cursor automatically, regardless of which tool that is currently selected.

Several consecutive rows in the table can selected by shift-clicking. Note that some 
menu items is only enabled under certain combinations of selected rows.

The Edit->Convert to summary item is enabled only when a single row (that isn’t 
either a summary row or an activity row part of a summary) is selected.

The Edit->Summarize item is enabled only when more than one row is selected. 
None of the rows must be a summary row or an activity row part of a summary.

The select tool can also be used in the activity diagram to customize the look of an 
activity. By ctrl-clicking on an activity line, you will get a popup menu where you 
can

• enable/disable the display of the activity name

• enable/disable the display of the responsibles

• change colour for the activity

FIGURE 15. Activity display options

10.2.2 Activity tool
The Activity tool can be used in the activity diagram to add new activities.

10.2.3 Completed tool
The Completed tool can be used in the activity diagram to mark how much of an 
activity that has been completed. The completed part of an activity will be drawn in 
yellow while the remaning part of a task is painted in blue. The blue and yellow col-
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ours used for remaining and completed activities can be adjusted. In the Edit->Pref-
erences... dialog you can set the two colours individually.

FIGURE 16. The preferences dialog

You can also enter the Completed percentage by entering a percentage value in the 
“Completed” column.

When the Complete tool is selected, the text in the lower left corner of the window 
is replaced by a text showing the current complete percentage when the cursor is 
positioned over an activity.

To mark a part of an activity as completed select the Completed tool and position 
the mouse cursor over the activity line that is to be marked. Click the mouse when 
you have positioned it and the part of the activity to the left of the mouse cursor will 
be yellow (indicating completed part) and the right part of the activity stays blue.

10.2.4 Dependency tool
The dependency tool shall be used to create a dependency link between two activi-
ties.

Position the mousecursor over the endpoint of an activity, press the mousebutton 
and while holding it down, drag the mouse to position the mousecursor over the 
startpoint of the dependent activity then release the mousebutton.

To remove a dependency line, select it using the select tool and then use Edit-
>Clear.

10.3 Gantt Chart

The Gantt chart view of the project window is divided into two panes, the lefthand 
pane holding the table of activities and the righthand pane holding the activity dia-
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gram. The bar separating the two panes can be adjusted to change the panes sizes. 
When moving the mousecursor over the bar, the mousecursor changes into another 
type of cursor indicating that the bar can be moved. Then press the mouse button 
and drag the bar to the left or the right.

10.3.1 Table of activities
The table of activities is a table where each row is related to an activity (unless the 
row is empty of course). An activity has a name (the Activity column) a duration, a 
start date, an end date, a work, an original start date, an original end date and a list 
of “doers” (the Responsible column). Some of these columns may be hidden if you 
wish. If you bring up the Project Settings dialog by selecting Schedule->Project 
Settings... and click on the Display options tab you can choose which columns to 
show. The first column showing the rownumbers and the Activity column can not be 
hidden.

10.3.1.1 Rearranging activity rows
You can rearrange the order of the rows in the table of activities by using drag-and-
drop. Click in the leftmost column and while holding the mouse button down, drag 
the row to where you want to place it. A blinking line will indicate where the row 
will be inserted.

If you try to drag a row which is a part of a summary, you can only drop it within the 
own summary group. If you drag the summary row, the complete group of activities 
will be dragged.

10.3.1.2 Deleting an activity
You can delete an activity (and the corresponding row) by selecting the row(s) (click 
in the row’s leftmost column) and then use Edit->Clear to delete the row(s).

10.3.1.3 Inserting a new activity row
If you want to insert a new activity row, you must select a row where the new row 
shall be inserted. If you select for example row 4, and then do Edit->Insert row and 
new empty row will be inserted at row 3 and the rows below will be pushed down-
wards.

If the textcursor is positioned on the last row and the return key is pressed a new row 
will be appended to the tablebut the text cursor will not move to the new row.

10.3.1.4 Rearranging columns
The columns can be adapted to suit your taste. First of all, the seven last columns, 
Duration, Work, Start Date, Stop Date, Original Start Date, Original Stop Date and 
Responsible can be included or excluded from the Gantt chart using the Schedule-
>Project Settings... dialog.

The order of the columns can be changed by drag-and-drop. Click and hold on a 
column’s title bar, drag it and drop it where you want the column.

Furthermore the width of each column can be adjusted. By positioning the mouse-
cursor above a border line between two columns, the mouse cursor changes and you 
can move the columnborder by clicking the mouse and then dragging the line in 
either direction. Release the mouse button when you have positioned the line at a 
suitable place.
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The width of a column can be adjusted to fit the widest text in the column by dou-
bleclicking on the header of the column.

The width of the leftmost column (activity number) has a minimum width so that 
the disclosure triangles used by summary rows, always fit within the column. 

FIGURE 17. Moving a column border

10.3.1.5 Moving around in the table
You can use the arrow keys to move the textcursor within the table. Up- and down-
arrow keys will move to the adjacent row if the current column is editable in the row 
you’re moving to, otherwise it will move to the next editable row. The left- and 
right-arrow keys can be used to move within a table cell but also to move between 
table cells.

The TAB-key can be used to step through the cells from left to the right, and from 
top to bottom. But the TAB-key has another function too. If the textcursor is posi-
tioned at the very beginning of the Activity column and the TAB-key is pressed, the 
current activity row will become a member of a summary-group.

If the row above is a common activity-row that is not a member of a summary 
group, a new summary row will automatically be inserted before the activity row. To 
indicate that the current row is a part of a summary row, the Activity text will be 
indented.

If the row above is an activity row that is part of a summary group, the current activ-
ity row will also become a member of that summary group.

Shift-TAB can be used to step backwards through the cells of the table. 

The return key can be used to move to the beginning of the next row in the table.

10.3.1.6 Validation of input text
When you have entered a date or a duration, the format of the text will checked. 
This validation will be done when leaving the current table cell. The validation may 
result in an error popup if the format of the date or duration could not be under-
stood.
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10.3.1.7 Computing the end date
When a startdate and a duration has been entered and validated, an end date will 
automatically be computed. If the Responsible column is empty, the program will 
assume that there is only one person (using the default calendar and default base 
week) that will perform the activity.

If there is a name of a team member in the Responsible column, that team member’s 
calendar and base week will be used.

If there is two or more names separated with a comma character ‘,’ each name will 
be assumed to correspond to a person working with the activity. There is no checks 
of the validity of the names. You may enter team members name, or any other name, 
e.g. consultant1.

The default calendar and base week will be used for all persons listed in the 
Responsible column that is not a direct match (case senstive) to any of the team 
members.

If you assign a person to several activities running in parallel, the person is still 
assumed to work 100 % on all activites unless you have specified the percentage for 
that person’s participation in an activity (see below).

10.3.1.8 Entering the responsible person(s)
In the Responsible column, the names of the team members responsible for that 
activity shall be listed. The easiest way to accomplish this is to use the popupmenu 
with all the team members that is displayed when ctrl-clicking in the Responsible 
text field.

FIGURE 18. Team member popupmenu

By selecting a name from the popupmenu, that name will be listed in the Responsi-
ble column. Note that it will erase any previous entry in the text field. If you option-
ctrl-click, and then select a teammember from the popup menu, that team member’s 
name will be added to the text field.

If you have entered all the team members in the Team Members dialog, an auto-
completion feature will complete a name as you enter it. For example if you have 
the following team members: Peter, Tom and Mike, and start entering an ‘M’ char-
acter, ProjectPlanner will automatically complete the name by adding “icke” foll-
wing the M character. The auto-completion feature is case-sensitive why it wouldn’t 
work if you typed an ‘m’ character (there was no team member name starting with 
‘m’ only ‘M’).



Reference Manual

20 of 26 Midius ProjectPlanner

If only entering the name of a responsible person, that person is assumed to work 
100 % on the activity. If a person only works, for example 50 % with a task, you can 
specify this by adding the percentage value after that person’s name:

Anna 50, Micke .7, Tom 0.9

would mean that Anna works 50 %, Micke works 70 % and Tom works 90 %.

10.3.2 Activity diagram

10.3.2.1 Adjusting the activity lines
When the select tool is active, you can adjust the activity lines (not summary lines) 
in the right hand pane. If you want to move an activity line you can simply point the 
mousecursor over the activity line (anywhere except at the end), press the button 
and then drag the activity to where you want it located. You cannot move it to a 
position where the startdate would be a day which the default calendar specifies is a 
non-working day.

During such a move, the date information in the lower left corner of the window 
indicates the new start date.

If the activity is dependent upon other activities, it may not be moved so that it 
would cause a conflict with the dependency.

If you want to adjust the duration of an activity using the mouse you shall point to 
the endpoint of the activity line, press the button and drag the mouse until the 
desired duration is selected. If you release the mouse button when pointing to a date 
prior to the start date, no change of the duration will take place.

During a change of the duration, the date information in the lower left corner of the 
window indicates the new stop date.

10.4 Report View

The project window can either display the Gantt Chart or a Report View. The View 
menu shall be used to toggle between these two different views of the project.

The Report View displays the same information you entered in the Gantt chart but in 
a different way. The Report View consists of only a table pane with a set of columns, 
where each team member is listed along with his/hers allocated activities.
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FIGURE 19. The Report View

The set of columns displayed in the Report View can be set with the Schedules-
>Project Settings.. dialog. There are four mandatory columns: Resource (team 
member), Activity, Start and Stop date. Optional columns include: Allocation, Com-
pleted, Other resources and Cost.

If the Cost column is displayed, the total cost of a team member will computed and 
an extra row will be added below each team member’s set of allocated activities.
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FIGURE 20. Report View with Cost column

Please note that no information in the Report View is editable. Furthermore only 
resources listed as team members (input through the team member dialog) will be 
listed in the Report View.

10.5 Diagram Text Options

The font and the size of the font can be changed to suit your needs by using the 
Schedule->Font and Schedule->Size commands. When a larger font is selected 
it may be necessary to adjust the row height to be able to view the text correctly.

The row height is adjusted by clicking on a row bottom line in the leftmost column 
(i.e. the row number column), holding the mouse button down, drag the bottom line 
and release the mouse button when the row height seems appropriate.

Please notice that modifying the row height will affect all rows including the header 
row of the table. It is not possible to modify the height of a single row nor is it pos-
sible to use different fonts or font sizes for different rows.

10.6 Rules used by ProjectPlanner to compute time

ProjectPlanner automatically computes new values in the activity table when any 
data is changed, for example if the Work column is modified ProjectPlanner will 
automatically update the Stop Date and the Duration columns, if the Start Date col-
umn is modified the Stop Date will updated to match the new start date of the activ-
ity. All these rules are stated below in a table.

TABLE 1. Rules for an unlocked activity

Column modified 
by user Duration Work Start Date Stop Date

Duration - Updated a - Updatedb

Work Updated - - Updated

Start Date - - - Updated
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TABLE 2. Rules for an activity with a locked start date

TABLE 3. Rules for an activity with a locked stop date

10.7 Export / Import

10.7.1 Exporting the activity table
The data in the activity table can be exported to a tab-delimited file using the File-
>Export data... command. The exported file is an ordinary textfile, with one row 
for each row in the activity table. Each row will hold the content of all columns or 
visible columns except the first column in the diagram holding the row number.

An activity row that is a part of a summary will have an asterisk ‘*’ prepended to its 
activity name.

a. Computed based on Start and Stop date and Responsibles

b. Computed as Start date + Duration.

Stop Date - - Updated -

Responsible - Updated - Updated

Column modi-
fied by user Duration Work Start Date Stop Date

Duration - - - Updated

Work Updated - - Updated

Stop Date Updated Updated - -

Responsible Updated - - Updated

Column modi-
fied by user Duration Work Start Date Stop Date

Duration - - Updated -

Work Updated - Updated -

Start Date Updated Updated - -

Responsible - - Updated -

TABLE 1. Rules for an unlocked activity

Column modified 
by user Duration Work Start Date Stop Date
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FIGURE 21. Export data dialog

The complete Gantt chart can also be exported as a picture in either PICT, JPEG or 
HTML format using the File->Export picture... command.

The file created by exporting the diagram in HTML format, requires a set of small 
GIF picture files to be available to the web-browser. There is one picture file for 
each type of information: summary, activity and completed. Furthermore a dummy 
picture file is needed to acheive transparent areas. These four files are stored in the 
(HTML) folder of the ProjectPlanner package (MPPSummary.gif, MPPActivity.gif, 
MPPCompleted.gif and MPPdummy.gif).

Please note that original start and stop dates are not included in the HTML-file.

10.7.2 Importing the activity table
Activity data can be imported into the Gantt chart from a tab-delimited file. The 
expected format is identical to the exported format (but all columns must be present 
in the imported file).
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10.7.3 Importing a calendar
If you once have prepared a calendar with all the public holidays for a year or two, 
you don’t have to redo it for every project document you create. If you have an old 
project document containing a valid calendar you can use the File->Import Calen-
dar... command to import just the calendar from the old document into the new doc-
ument.

10.8 Printing

When printing, only the currently displayed view (Gantt Chart or Report View) will 
be printed. To print both the Gantt chart and the Report you have to do two Prints 
and switch view in between them.

10.8.1 Print Options
The Print Options (File->Print Options...) can be used to specify the appearance of 
the printer output. Each printed page can have a header showing the column headers 
and the date header. If this option is not selected, only the “top row” of pages 
printed will have this information. This last alternative is suitable if you are going to 
“merge” several printed pages into one large diagram.

Each page can also have a footer including the project name, legend, print date and 
an additional free text area. The free text area can hold at most 255 characters and 
will be printed at the very bottom of the footer. You can also specify if the footer 
shall be ouput on every printed page or only the “bottom row pages” (in the case of 
a multipage printout).

FIGURE 22. Printer Options dialog



Reference Manual

26 of 26 Midius ProjectPlanner

10.8.2 Printing Preview
The Printer Preview (File->Print Preview...) can be used to find out if the currently 
selected orientation (portrait or landscape) and the selected scale is suitable for the 
document to be printed.

In the Print Preview dialog, a paper sheet is represented by a red framed rectangle 
and the area needed by the time schedule is drawn in gray. Please note that the ori-
entation of the paper is not shown in this dialog. The length of the sides of the red 
rectangle are not in proportion to the actual size.

 

FIGURE 23. Print Preview showing a time schedule occupying two sheets of paper (but could 
possible fit into one sheet if the orientation of the paper is changed)


