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A Message from Larry Weinberg
In the 1980’s, my secret ambition was to become an illustrator, 
to draw like the great old masters. But something was lacking in 
my brain that kept me from being able to visualize my characters’ 
complex poses. I knew what I wanted to draw, and I knew what 
was great when I saw it, but starting from a blank page just never 
worked. I dropped into my local art supply shop and bought one 
of those little wooden mannequins that I thought would be my 
friend. He wasn’t very nice to me and never did what I asked of 
him. I quickly became determined to put him out of a job and thus 
set out to build the world a better mannequin. At the time, I was 
programming and animating in Hollywood, mostly for Rhythm and 
Hues Studios. I had built up a wealth of 3D math and computer 
graphics knowledge. Why not make a digital mannequin? So, while 
giving life to flaming match characters, Mr. Peanut, and billowing 
sheets of fabric softener during my day job, I began creating Poser 
at night.

All I wanted was a simple visualization tool, one that would be easy 
to pose with and quick to use for any artist. I wasn’t yet thinking 
about high quality rendering, shadows, animation, textures, or 
anything else. But Poser, like old John Henry, had a mind of its own. 
Poser 1 was released in 1995, and grew quickly. I knew Poser could 
be a useful tool but the response was overwhelming and the art it 
helped create was mind blowing.

Throughout the subsequent version releases, Poser’s community 
kept growing and diversifying, with people beginning to incorporate 

Poser into scientific, medical, architectural, CAD, theatrical, and 
dance-based projects and presentations. Ideas kept pouring in 
as more and more people joined the Poser community. Poser 
also evolved to include a new friendlier interface, more rendering 
powers, new content, and many new features.

The following that Poser attracted continues to amaze us all, as 
does the community’s ongoing diversity, creativity, talent, and 
passion. The Poser artists and modelers of the world have pushed 
far beyond anything I thought possible. Poser has been used in 
award winning character animations, as design for huge sculptures, 
for comic books, for medical illustration and instruction, for legal 
reconstruction, and for unleashing the kind of astounding images 
that, well, move us all.

In 2000 Curious Labs took Poser’s reigns. Our team began looking 
at where Poser and human simulation could (and should) continue 
growing. We knew we needed to remain committed to making 
products that would be easy enough for every artist to use. We also 
knew we needed to integrate our capabilities with the world of 
professional 3D graphics productions and with the new emerging 
Web-deployable technologies. Poser 4 Pro Pack was born of these 
needs, allowing Poser scenes and characters to be hosted inside 
high end professional packages such as 3D Studio MAX, Lightwave, 
and Cinema 4D. We also added Flash and Viewpoint Experience 
Technology capabilities for real time display via the Web. 

Today, Poser has obtained huge levels of growth through the 
courageous efforts by many extremely talented and motivated 
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professionals. Believe me, Poser is no longer written by me coding 
alone into the night. It’s a powerful graphics product that is the 
culmination of the work of a very talented group that spans the 
globe.

While streamlining our interface, we’ve integrated a large database 
of scanned human heads into a phenomenal face-designing 
environment. We added realistic rendering capabilities far beyond 
where we started, with the ability to create networks of complex 
shading nodes for unlimited textures and materials. We also added 
physical simulation of cloth and hair. By combining these new 
powers with a new suite of human models and poses, and a new 
portal to allow people to find content on the internet, Poser should, 
well, change the world–again.

Each of us at Smith Micro Software sees what we do as a labor of 
love. Poser could never have gotten this far without each and every 
one of our dedicated staff. And, Poser could certainly never have 
evolved this far without the involvement of the Poser community, 
who has supported our efforts with enthusiasm, forum inundations, 
email blasts, contributions to the product, and a stream of 
unbelievable images.

Thanks to everyone who has touched or been touched by Poser.

Larry Weinberg

Original Poser Creator
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Chapter 1: Welcome to Poser!
Thank you for purchasing Poser®. If you’ve never used Poser 
before, welcome! Are you upgrading from an earlier version of 
Poser? Welcome back! 

Poser is the complete 3D figure design and animation solution. 
Artists and animators can create 3D scenes from a diverse 
collection of ready-to-use 3D human and animal models quickly 
and easily using Poser’s intuitive interface. You can also realistically 
customize your figures and scenes by mapping facial photos to 
create realistic 3D portraits, growing and styling real spline-based 
hair, and creating dynamic cloth objects. With Poser, you can create 
stills and animations and can quickly output movies and images 
for use in Web, print, and video projects. You can also export posed 
figures as 3D objects to add life to scenes created in other 3D 
applications. 3D novices, digital artists, and hobbyists alike can use 
Poser to quickly create breathtaking results!

Poser is offered as the world’s most complete, easy to use 3D 
character solution for artists, illustrators, animators and hobbyists. 
Poser’s collection of powerful features shortcut the traditional 
complexities of working with 3D figures by combining an intuitive 
interface with a large library of ready to use content. Poser takes 
the mystery and challenge out of using 3D characters, allowing new 
users to start making art immediately. For experienced 3D users, 
Poser provides a sophisticated, fully featured character animation 

system, letting them incorporate 3D figure content into riveting 3D 
images and animation for both personal and professional projects.

Dramatic new Poser 8 features include an overhauled user interface 
that maximizes screen real estate while providing better workflow, 
a new search-enabled library that helps users find, organize and 
use their content easier, a dependant parameter tool that lets 
users teach objects in the scene to interact with each other in 
exciting new ways, cross body morph brushes that permit a user to 
smoothly sculpt a figure across every body part, new photorealistic 
rendering features that more accurately reproduce light and 
shadows, improved character rigging which enables better 
character bending. Lastly, Poser 8 has been optimized for better 
performance on multiple processor systems.

What’s New in Poser
Poser includes the following new features:

Workflow Improvements

New User Interface•	 : The new user interface features an 
improved workflow and palettes that you can dock and float 
in any way you choose to maximize your workspace, workflow, 
and efficiency.  The cleaner layout lets you focus on your 
workspace, not the interface, while preserving the elements 
that long-time Poser users are accustomed to.
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Morphing

Morphing Tool Enhancements•	 : The Morphing Tool 
now allows you to morph across multiple body parts, making 
it easier than ever to create master parameter-controlled full 
body morphs. Dial in a morph brush and paint morphs across 
body parts, then save the complete set of individual body part 
morphs as a single Full Body Morph channel in the figure’s 
“Body” parameter.

Dependent Parameters

Dependent Parameters Editor•	 :  Create more complex 
interactions between objects and joints. It is now much easier 
to create advanced body controls such as a muscle bulge 
morph that moves when a limb bends. Use this powerful new 
feature for full body morphs, partial body morphs, advanced 
body controls, joint controlled morph targets, joint controlled 
deformers, and parameter-controlled scene assets. 

Rigging

Improved Rigging System•	 : The new rigging system 
allows for better bending of characters, and features a new 
capsule-shaped falloff zone that allows finer control in 
specifying how joints respond to rotation.  

Multiple Falloff Zones•	 : Joints can now use multiple 
falloff zones for even finer control of joint rotations. Falloff 
zones can be blended by multiplying or adding the values. 
This new system permits figure creators to rig problem areas 
such as hips and shoulders with more precision, and results in 
better bending figures.

Lighting

Indirect Lighting•	 : Indirect lighting effects provide indirect 
lighting that bounces light from other objects in your scene. 
Reflected light and color from adjacent surfaces produces 
vivid, more photorealistic lighting in rendered images.

Light Falloff and Attenuation•	 : Physically correct light 
attenuation for more realistic point and spot lights. Create 
scenes with point and spot light brightness that decreases over 
distance like real-world lights.

FireFly

Tone Mapping and Exposure•	 : Tone mapping and 
exposure control offers more control for brightness, saturation, 
and post-render processing for more accurately rendered 
images.

Normal Maps•	 : Normal mapping support now provided at 
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render time, allowing you to add more surface detail without 
requiring extra geometry or modeling.

Performance Optimizations

Poser 8 features several performance optimizations, including:

Improved multi-processor support improves posing and •	
rendering. Cloth simulations are now completed faster, and 
saves you time.

Figure/Actor pre-lighting and picking is improved.•	

Increased performance for opening and handling of complex •	
scenes.

Bending on multi-core/multi-processor hardware.•	

Improved multi-processor support for better scalability when •	
rendering multiple buckets.

Document Preview

Improved OpenGL Preview•	 : Real-time scene preview 
now displays up to 8 user-selectable lights and their 
accumulated values, sorted by intensity. Mip Map support has 
been enabled for enhanced performance when previewing 
large textures. Together, these real-time preview engine 

enhancements let you view larger textures and offer more 
complete scene previewing when setting up lights.

Library and Content

New Searchable Library System•	 : The Poser 8 library 
has evolved into a content management system that makes 
it easier to find what you’re looking for, even in massive 
collections of content. The new library features the ability to 
perform keyword searches through all or one of your runtimes, 
add items to your favorites list, and keep track of when 
content was installed or modified. 

New Figures: •	 Eight new fully-rigged, fully poseable photo-
real human characters are only a mouse-click away, so you 
can start posing and animating in minutes. Features four pairs 
of male/female characters with European, African, Asian, and 
Hispanic features. The figures are fully compliant with the Face 
Room, Walk Designer, and Talk Designer.

New Content•	 : 1 GB of all new content, including poses, 
props, hair sets, lights, and cameras so you can dive right into 
3D scene building. A new art school-inspired 3D mannikin 
opens in each new scene, serving as a remarkable reference 
figure for artists.

Wardrobe Wizard•	 : Allows you to fit existing clothing 
items onto new figures. 
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PoserPython

wxPython Support•	 : The wxPython support provides more 
robust Python feature development, allowing for development 
of scripts that can run continuously. This will allow for more 
robust third-party support and add-on feature development.

Included Documentation
Poser includes the following documentation:

Poser Reference Manual•	 : This Reference Manual has 
been rewritten and Poser features added. It is included in both 
hard copy and in electronic PDF format on your Poser DVD. 
Selecting Help > Poser Reference Manual from within 
Poser will also launch this manual.

The version of the manual accessible from the help menu 
is optimized for screen viewing. If you wish to print it out, your 
Poser DVD contains a version that is optimized for print in the 
documentation folder.

Quick Reference Card (QRC)•	 : The QRC is a fold-out 
reference that briefly describes key Poser features and includes 
a comprehensive list of Poser keyboard shortcuts.

PoserPython Methods Manual•	 : This manual contains 
an organized listing of each PoserPython method available 
in Poser. It is included in PDF format on your Poser DVD and 
is also accessible from within Poser by selecting Help > 
PoserPython Manual.

Poser Tutorial Manual•	 : This manual provides step-by-
step tutorials to assist you in mastering different aspects of 
Poser, including the Face Room, Cloth Room, Hair Room, and 
more. This manual is available in PDF format by selecting Help 
> Poser Tutorial Manual and on your Poser DVD in the 
Documentation folder.

Quick Start Guide•	 : This Quick Start guide is an on-screen 
step-by-step interactive guide that takes users through the 
necessary steps to quickly create scenes within Poser.

System Requirements
System requirements for Poser installation are as follows:

Windows

Windows XP or Vista•	

700 MHz Pentium class or compatible (1GHz or faster •	
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recommended)

512 MB system RAM (1 GB or more recommended)•	

OpenGL enabled graphics card or chipset recommended •	
(recent NVIDIA GeForce and ATI Radeon preferred)

24-bit color display, 1024 x 768 resolution•	

2 GB free hard disk space (4 GB recommended)•	

Internet connection required for Content Paradise..•	

Windows® Internet Explorer 7 or later•	

Adobe® Flash® Player 9 or later•	

DVD-ROM drive (physical product only)•	

Macintosh

Mac OS X 10.4 or 10.5•	

700 MHz G4 processor (Intel Core Duo or 1GHz G4 or faster •	
recommended)

512 MB system RAM (1 GB or more recommended)•	

OpenGL enabled graphics card or chipset recommended •	
(recent NVIDIA GeForce and ATI Radeon preferred)

24-bit color display, 1024 x 768 resolution•	

2 GB free hard disk space (4 GB recommended)•	

Internet connection required for Content Paradise.•	

Adobe® Flash® Player 9 or later•	

DVD-ROM drive (physical product only)•	

Poser Content Online
Poser’s Content room includes a direct link to the online Content 
Paradise (http://www.contentparadise.com), which offers hundreds 
of figures, props, textures and other content available for use 
within Poser. Also, Poser’s Download Manager makes the process of 
downloading content and installing it to the appropriate Library 
categories fully automatic, so accessing high quality content has 
never been simpler! See Chapter 8: The Content Room on page 
120 for more information about the Content room, and Content 
Paradise.
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Other Smith Micro Software Products
Check out these products from Smith Micro Software:

Manga Studio•	 : Manga Studio, the leading manga and 
comic art software, provides all the essential tools you need 
to create professional, ready-to-publish pages from start to 
finish! Manga Studio offers an intuitive interface, and delivers 
the best suite of ready-to-use screen tones, content and 
special manga and comic effects for hobbyists, experienced 
artists and professionals.

Anime Studio•	 : Anime Studio is your complete animation 
program for creating 2D movies, cartoons, anime and cut 
out animations. Create your own desktop animated shorts 
in the style of SouthParkStudios.com and JibJab.com, or 
use Anime Studio to produce full-length animation for film, 
video or streaming over the web. Anime Studio allows digital 
enthusiasts at home and professionals in the studio to bring 
their imagination to life!

StuffIt•	 : Expand over 25 compressed file formats in Mac 
and Windows. Create ZIP, StuffIt, and TAR archives. Compress 
photos up to 30% without any quality loss.  Archive photos 
and files directly to FTP for backup. 

When You Have Questions
As you begin using Poser for your 3D projects, you’ll undoubtedly 
have questions or want to network with other Poser artists. You’re 
not alone! There are many resources available for Poser artists. 
Here are just a few:

Need Help?
Poser includes the Help menu, which serves to answer most of 
your questions while using the application:

Poser Help•	 : Selecting Help > Poser Reference Manual 
opens the Poser Reference Manual in PDF format.

PoserPython Help•	 : Selecting Help > PoserPython 
Manual opens the PoserPython Methods Manual in 
PDF format.

Tutorials•	 : Selecting Help > Poser Tutorial Manual opens 
the Poser Tutorial Manual in PDF format.

About•	 : Windows users can select Help > About Poser 
to display the Poser version and copyright information. 
Macintosh users should look in the Poser Application menu, 
and select About Poser, to see this information. This option 
will be useful if you need to obtain technical support, since 
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the Technical Support representative will need to know this 
information.

The •	 Help > Content Paradise submenu contains links to 
information on content from Content Paradise.

Smith Micro Software Resources

•	 Online Support: For technical support, customer service, 
downloads, and to visit the Smith Micro Poser community and 
gallery, visit us at http://my.smithmicro.com/support. 

To Learn More•	 : If you’d like to learn more about Smith 
Micro Software, visit us at http://www.smithmicro.com.

•	 Contacting Technical Support: If our Web Knowledge 
Base does not resolve your situation, please contact us 
through http://support.smithmicro.com. Please refer to 
Appendix A: Technical Support on page 523 to view our 
technical support policy.

•	 Sales: You may reach our sales department via e-mail at: 
sales@smithmicro.com.

Other Links•	 : Selecting Help > Smith Micro Web Links 
or Help > Other Web Links within Poser lists other valuable 
online resources.

Third-Party Forums
You may also visit online Poser forums such as:

3D Commune•	 : http://www.3dcommune.com 

Animotions•	 : http://www.animotions.com

Renderosity:•	  http://www.renderosity.com

RuntimeDNA•	 : http://www.runtimedna.com

Smith Micro Software does not regulate content on third-
party forums and their listing and order of appearance in this 
manual is not an endorsement.

Other Important Resources
Visit the following sites to learn about some of the applications and 
technology supported by Poser:

Python resources•	 : The following is a small sample of 
the ever-growing body of online and hardcopy information 
concerning the Python scripting language:

The basic Python interpreter (which allows you to write ��
your own Python scripts for any desired purpose) as well 

http://www.runtimedna.com
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as many in-depth documents and links to other online 
resources is available for free download at http://www.
python.org.

You can find additional online resources on wxPython at ��
http://www.wxpython.org.

Learning Python, 3rd Edition��  by Mark Lutz; 
O’Reilly & Associates; ISBN # 0-596-51398-4

wxPython in Action��  by Noel Rappin and Robin 
Dunn; Manning Publications; ISBN # 1-932-39462-1

About Your Reference Manual
Smith Micro Software strives to provide documentation that is 
complete, accurate, informative, and friendly. Your feedback is 
always welcome. Please e-mail your comments to: techsupport@
smithmicro.com.

The Poser Reference Manual is for both Macintosh and Windows. 
By convention, Macintosh commands precede Windows commands 
in the text. The Poser interface for Macintosh and Windows 
platforms is identical, unless otherwise specified. 

For clarity, this manual uses several notational conventions to 
present information of special importance. Lists of items, points 
to consider, or procedures that do not need to be performed in a 
specific order appear in bullet format:

Item 1•	

Item 2•	

Procedures that must be followed in a specific order appear in 
numbered steps:

Perform this step first1.	

Perform this step second2.	

Specific keyboard keys are depicted in square brackets and are 
capitalized. For example: [ESC]. If more than one key should be 
pressed simultaneously, the notation appears as [KEY1]+[KEY2], 
for example [ALT]+[F4]. When a modifier key differs between 
the Macintosh and Windows platform, the Macintosh modifier is 
listed first followed by a slash and the Windows modifier key. For 
example, [COMMAND]/[CTRL]+[I] is equivalent to the Macintosh 
[COMMAND]+[I] and the Windows [CTRL]+[I]. 

Screen prompts, menu and window names, fields, buttons, boxes, 
etc. appear in bold type. Where you need to access a palette, 
command, or submenu, the syntax is Menu>Submenu. For 
example File > Save As means you should open the File pull-
down menu and then select Save As to open the Save As dialog 
box.

Program and script code appears in standard Courier font, for 
example: 

cd\letters\business\legal [ENTER]

http://www.runtimedna.com
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Notes detail tips, tricks, and other important information.

Warnings alert you to potentially harmful consequences 
such as data loss.
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Chapter 2: Installing Poser
Before opening your DVD holder, please take a moment to read, 
understand, and agree to the Poser End User License Agreement 
(EULA). If you do not agree with the terms of the EULA, please 
return your entire Poser package including the unopened DVD 
holder to Smith Micro Software or your place of purchase. Once you 
have read and accepted the EULA, you may proceed with installing 
Poser on your system.

 The Smith Micro online store will accept the return 
of either physical or electronically downloaded products 
purchased directly from Smith Micro within 30 days of the 
date of purchase. Products purchased in retail stores must 
be returned to the place of purchase and meet their specific 
return policy terms. Smith Micro reserves the right to change 
this policy at any time.

Poser End User License 
Agreement (EULA)
This End User License Agreement (“EULA”) is between you (both 
the individual installing the Program and any single legal entity on 
behalf of which such individual is acting) (“you” or “your”) and 

Smith Micro Software, Inc., and/or its subsidiaries (“Company”).

PLEASE READ THIS EULA CAREFULLY BEFORE USING THE 
SOFTWARE. BY CLICKING THE “I ACCEPT” BUTTON WHEN 
INSTALLING THE PROGRAM, YOU ARE AGREEING TO BE BOUND 
BY THE TERMS OF THIS EULA.  IF YOU DO NOT AGREE TO THE 
TERMS OF THIS EULA, CLICK ON THE “I DO NOT ACCEPT” 
BUTTON.  IF YOU DO NOT ACCEPT THIS EULA, YOU MAY NOT USE 
OR ACCESS THE SOFTWARE. USING OR ACCESSING ANY PART OF 
THE SOFTWARE INDICATES THAT YOU ACCEPT THESE TERMS.

DEFINITIONS

“Content”•	  means animations, characters, clothing, faces, 
hair, geometries, images, materials, meshes, morphs, motion 
files, props, PoserPython scripts, textures, bump maps, 
transparencies, and similar files and data created with the 
intent of being used within the Program and/or third party 
applications.

“Documentation”•	  means any written material in any form 
for installation and use of the Program provided by authorized 
agents or representatives of the Company.

“Legitimate Uses”•	  means (a) creating morph targets based 
on the Restricted Content, provided that any distribution 
of the morph targets will not include the original mesh 
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connectivity information (for example, distribution in the form 
of data utilized with morph moving utilities or in a .CR2 file 
that references the original geometry, but no inclusion of 
the complete mesh); (b) creating texture templates derived 
from the Restricted Content to create new maps for either 
Restricted Content or Other Content; (c) creating tutorials, 
books, or other educational materials using images of the 
Program interface or Content for sale, distribution, public 
display, or public performance, provided such materials are 
intended to educate users as to use of the Program; (d) 
creating original Content for sale, distribution, public display, 
or public performance; (e) creating materials (e.g., shader 
trees) for use with either Restricted Content or Other Content; 
(f) creating characters or props based on Restricted Content 
in Proprietary File Formats, where the original (or modified) 
geometry, texture, or other Restricted Content files are not 
distributed with such characters or props; or (g) creating 
PoserPython scripts.

“Other Content”•	  means Content that is not Restricted 
Content or Unrestricted Content.  Other Content may be 
subject to license terms imposed by the Other Content’s 
original creator.

“Program”•	  means the Company computer software and 
associated files in Proprietary File Formats delivered via the 
accompanying physical media or electronic media.

“Proprietary File Formats”•	  means any of Company’s 
proprietary compressed and uncompressed formats and/
or future proprietary file formats, including files with the 
following extensions: CM2, CR2, FC2, HD2, HR2, LT2, MC6, 
MT5, PP2, PZ2, PZ3.

“Restricted Content”•	  means all Content included with 
or part of the Program that is not Unrestricted Content, 
including without limitation mesh objects (geometry) in any 
format, files in Proprietary File Formats, images, materials, 
texture, transparency maps, Documentation, and Company’s 
proprietary data.

“Unrestricted Content”•	  means Content included with 
or part of the Program that is specifically identified in the 
Documentation or listed in this EULA as Unrestricted Content.  
This version of the Program contains no Unrestricted Content.

THIRD-PARTY TECHNOLOGY AND 
CONTENT
Portions of the Program and Other Content contain technology 
and/or other components licensed by the Company from the 
following third parties: Pixels Digital, Inc., Singular Inversions, 
Inc., Size8 Software, Inc., Automatic Sync Technologies LLC, PhilC 
Designs, and Cindy Carney, each of whom retain the ownership, 
copyrights, trademarks, and patents to their respective contributions 
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to the Program.  Other Content that is subject to third-party rights 
included with Program and Documentation is copyrighted and 
owned by the original Content creators.

GENERAL
You agree to use the Program, Documentation and Content only 
for lawful purposes.  Any use of the Program, Documentation or 
Content other than as granted in this EULA must be approved by 
the Company’s prior written consent.  The Company maintains an 
ongoing EULA enforcement program. Violation of any provision 
in this EULA automatically terminates this EULA.  The Company 
reserves all other rights that it may have for violation of this EULA.

PROGRAM LICENSE
A. Subject to the terms and conditions of this EULA and your 
payment of the license fee, the Company grants you a limited, 
personal, nontransferable and non-exclusive license (without the 
right to sublicense): (i) to use a single copy of the Program (except 
as expressly permitted in the Documentation) solely for your own 
internal business operations on a single computer as set forth in 
Section K below for production operation or, on a temporary basis, 
on a backup system if such equipment is inoperative, consistent 
with the limitations specified or referenced in this EULA and the 
Documentation; (ii) to use the Documentation provided with the 

Program in support of your authorized use of the Program; and (iii) 
to copy the Program to make one (1) archival copy of the Program 
for your personal archival or backup purposes, and to make a 
sufficient number of copies for Legitimate Uses or the intended 
use described in the Documentation, provided that all titles and 
trademark, copyright and restricted rights notices are reproduced on 
all such copies.  Any other uses of the Program, including without 
limitation the Program interface, other than those granted in this 
EULA must be approved by the Company’s prior written consent.

B. You will not use, copy, modify, derive, or transfer the Program or 
Documentation, or any copy, modification, derivation, or merged 
portion thereof, in whole or in part via any means or for any 
purpose whatsoever except as expressly permitted in this EULA 
or the Documentation.  You will not relicense, sublicense, rent, 
lease, or lend the Program for third-party training, commercial 
time-sharing or service bureau use.  You will not, and will not 
permit any third party to, reverse engineer, decompile, debug, 
disassemble, circumvent the security features of, or interfere with 
the normal functionality and operation of the Program for any 
reason whatsoever without the express prior written consent of the 
Company or except to the extent expressly permitted by applicable 
law.  If the Program is an upgrade to a previous version of the 
Program, you must possess and maintain a valid license to such 
previous version in order to use the upgrade. 

C. You expressly acknowledge that the Company has a valuable 
proprietary interest in both the Program and the Documentation. All 
title, ownership, interest and rights in and to the patent, copyright, 
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trademark, trade secret and any other intellectual property 
rights in the Program (and any derivative works thereof) and the 
Documentation (and any derivative works thereof), not expressly 
granted to you by this EULA remain with the Company. You do not 
acquire any other rights, express or implied, in the Program (and 
any derivative works thereof) and the Documentation (and any 
derivative works thereof) other than those rights expressly granted 
under this EULA.  Without limiting the generality of the foregoing, 
the Company retains all title, ownership, interest and rights in and 
to the patent, copyright, trademark, trade secret and any other 
intellectual property rights in the copy of the Program contained 
on your archival media, and all of the terms of this EULA apply to 
such archival copy as if it were the original Company-produced 
copy of the Program that was furnished to you when you paid the 
licensing fee.

D. Except as otherwise expressly permitted in the Documentation, 
you will only use the Program on a single computer, meaning that 
you must treat the Program “like a book.” “Like a book” means 
that the Program may be used by any number of people and 
may be freely moved from one computer to another so long as 
no possibility exists of the Program being used at more than one 
computer simultaneously. More than one person at a time cannot 
read the same copy of a book, and this restriction applies to the 
Program. The Company is pleased to offer site licenses for multiple 
simultaneous users. Please contact the Company at the address 
below for details. 

E. You, your employees, and/or authorized agents must protect the 

Program’s confidentiality and act to enforce your obligations under 
this EULA. You cannot distribute or otherwise make the Program 
or Documentation available to any third party via any means 
whatsoever, public or private, for any purpose, commercial or not, 
unless explicitly allowed by this EULA.

F. You assume full responsibility for your selection of the Program 
to achieve your intended results and for the installation, use, and 
results you obtain from the Program. Company has no obligation 
to provide support, maintenance, upgrades, modifications or new 
releases under this EULA.

CONTENT LICENSE
G. Subject to the terms and conditions of this EULA and your 
payment of the license fee, Company grants you a limited, personal, 
nontransferable and non-exclusive license (without the right to 
sublicense):

a. To reproduce, prepare derivative works based upon, •	
distribute, publicly display, and publicly perform the 
Unrestricted Content for any lawful purpose other than to 
create a product which is intended to compete with the 
Program or to create new content which is intended to 
compete with the Restricted Content.

b. To prepare derivative works based upon the Restricted •	
Content solely for Legitimate Uses and lawful uses.
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c. To reproduce, prepare derivative works based upon, •	
distribute, publicly display, and publicly perform content you 
create using Restricted Content, provided that such use of 
Restricted Content shall be solely Legitimate Uses and lawful 
uses.

H. Notwithstanding the foregoing, nothing shall limit the 
Company’s right to independently create, develop, own, market, 
distribute, license, sublicense, import, export, sell, or otherwise 
exploit any content or materials similar to any derivative works 
based upon the Content.

I. You will use the Other Content in accordance with all applicable 
license terms imposed by the content’s original creator.

J. You will not use, copy, modify, derive, distribute, transfer or 
sublicense the Restricted Content, the Unrestricted Content, or 
the Other Content or any copy, modification, derivation, or portion 
thereof, in whole or in part via any means or for any purpose 
whatsoever except as expressly permitted in this EULA or the 
Documentation.

K. You expressly acknowledge that the Company has a valuable 
proprietary interest in the Restricted Content and the Unrestricted 
Content. All title, ownership, interest and rights in and to the 
patent, copyright, trademark, trade secret and any other intellectual 
property rights in the Restricted Content and the Unrestricted 
Content not expressly granted to you by this EULA remain with the 
Company. You do not acquire any other rights, express or implied, in 
the Company-created Restricted Content (and any derivative works 

thereof) other than those rights expressly granted under this EULA.

L. Except as otherwise expressly permitted in the Documentation or 
unless otherwise provided for herein, you will only use the Content 
on a single computer, meaning that you must treat the Content 
“like a book.”  The Company is pleased to offer site licenses for 
multiple simultaneous users. Please contact the Company at the 
address below for details. 

TERM
M. This EULA remains in full force and effect until terminated. 
You may terminate it at any time by returning or destroying both 
the Program and the Documentation, together with all copies, 
modifications, and merged portions of the Product and the 
Documentation in any form. The Company is in no way obliged to 
issue refunds. Company may terminate this EULA at any time upon 
your breach of any of the provisions hereof.

N. Upon termination, you will immediately cease all use of 
the Program, return or destroy both the Program and the 
Documentation to the Company, together with all copies, 
modifications, and merged portions of the Product and the 
Documentation in any form, and so certify to vendor.  Termination 
of this EULA for any reason in no way limits the Company’s right to 
continue enforcing all rights provided by law and does not entitle 
you to a refund of your license fee except as provided herein. All 
provisions of this EULA that protect the Company’s proprietary 
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rights continue in full force and effect after termination.

LIMITED WARRANTY
O. The Company provides the Program and the Documentation 
AS IS with no warranty.  The Company makes no representations 
or warranties, either express or implied, of any kind with respect 
to the Program and the Documentation.  To the fullest extent 
permissible under applicable law, Company expressly disclaims 
all warranties of any kind, either express or implied, with respect 
to the Program or the Documentation, including warranties of 
merchantability, fitness for a particular purpose, satisfactory 
quality, and non-infringement.  The Company does not warrant 
that the Program’s functionality will meet your requirements or 
that the Program operation will be uninterrupted or error-free. No 
distributor, dealer, or any other entity or person is authorized to 
expand or alter either this warranty or this EULA, and the Company 
will not be bound by any such representation in any way.  You 
assume the entire risk of the Program’s and the Documentation’s 
quality and performance. Should the Program prove defective, 
you assume the entire cost of all necessary servicing repair or 
correction.

LIMITATION OF LIABILITY
P. In no event will the Company be liable to you for any indirect, 
incidental, consequential, special, or punitive damages, including 
damages for any lost profits,  arising out of your use or inability 
to use the Program and the Documentation, even if the Company 
has been advised of the possibility of such damages or for any 
claim by any other party. Some states and countries do not allow 
the limitation or exclusion of liability for certain damages, so the 
above limitation or exclusion may not apply to you. In no event 
will the Company’s liability to you or any other person for damages 
hereunder exceed the amount of the license fee paid by you to 
use the Program regardless of the form of the claim.  The parties 
acknowledge that this limitation of liability are an essential element 
of the bargain between the parties, without which Company would 
not have entered into this EULA. Company’s pricing reflects this 
allocation of risk and the limitation of liability specified herein.

INDEMNIFICATION
Q. You will indemnify and hold harmless, and at Company’s 
request defend, Company and its affiliates, successors and assigns 
from and against any and all claims, losses, liabilities, damages, 
settlements, expenses and costs (including, without limitation, 
attorneys’ fees and court costs) which arise out of or relate to any 
third party claim or threat thereof that your use of the Program, 
Documentation or Content is unlawful or not otherwise permitted 
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by this EULA.  Company reserves the right, at its own expense, to 
assume the exclusive defense and control of any matter otherwise 
subject to indemnification hereunder.

EXPORT LAW ASSURANCES
R. Export of this Program and Documentation is governed by the 
laws and regulations of the United States and import laws and 
regulations of certain other countries.  You will comply with all such 
laws and regulations.  Export of this Program and Documentation 
to any entity on the Denied Parties List and other lists promulgated 
by various agencies of the United States Federal Government is 
strictly prohibited.

U.S. GOVERNMENT RESTRICTED 
RIGHTS
S. The Program and Documentation is provided with RESTRICTED 
RIGHTS. Any use, modification, reproduction, release, performance, 
display or disclosure by the U.S. Government or any of its agencies 
shall be governed solely by the terms of this EULA and shall be 
prohibited except to the extent expressly permitted by the terms 
of this EULA.  The Software and Documentation are deemed to 
be “commercial computer software” and “commercial computer 
software documentation”, respectively, pursuant to DFAR Section 
227.7202 and FAR 12.212(b), as applicable.  Any technical data 

provided that is not covered by the above provisions is deemed 
to be “technical data-commercial items” pursuant to DFAR 
Section 227.7015(a).  Any use, modification, reproduction, release, 
performance, display or disclosure of such technical data shall be 
governed by the terms of DFAR Section 227.7015(b).

MISCELLANEOUS
T. This EULA shall be governed by the laws of the State of California, 
without giving effect to any choice of law rules.  This EULA will not 
be governed by the United Nations Convention on Contracts for the 
International Sales of Goods, the application of which is expressly 
excluded.  Exclusive jurisdiction over and venue of any suit arising 
out of or relating to this EULA will be in the state and federal 
courts of Orange County, California.  If for any reason a court of 
competent jurisdiction finds any provision, or portion thereof, to be 
unenforceable, the remainder of this License shall continue in full 
force and effect.  The waiver by either party of any default or breach 
of this EULA will not constitute a waiver of any other or subsequent 
default or breach.  You may not assign, sell, transfer, delegate 
or otherwise dispose of, whether voluntarily or involuntarily, by 
operation of law or otherwise, this EULA or any rights or obligations 
under this EULA without the prior written consent of the Company.  
Any purported assignment, transfer or delegation by you will be null 
and void.  This EULA constitutes the entire agreement between the 
parties and supersedes all prior or contemporaneous agreements 
or representations, written or oral, concerning the subject matter of 
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this EULA.  This EULA may not be modified or amended except in a 
writing signed by a duly authorized representative of each party.

CONTACT INFORMATION
U. If you have questions concerning this EULA or need to contact 
Customer Service, please contact Company at this address:

Smith Micro Software, Inc., 51 Columbia, Aliso Viejo, CA 
92656.

TRADEMARK AND COPYRIGHT 
NOTICE
Poser, Poser Pro, the Poser logo, and the Smith Micro Logo are 
trademarks and or registered trademarks of Smith Micro Software, 
Inc. Poser copyright (c) 1991-2009. All Rights Reserved. All other 
product names mentioned in the manual and other documentation 
are used for identification purposes only and may be trademarks 
or registered trademarks of their respective companies. Licensed 
product.

This EULA does not grant you the right to use, and you shall not 
use, the copyrighted materials or trademarks of Company or its 
affiliates in any advertising, publicity or promotion, or to express 
or imply any endorsement of such party.  Without limiting the 
generality of the foregoing, you may not express or imply any 

endorsement by the Company or its affiliates of any tutorials, 
books, or other educational materials you create using images of 
the Program interface or Content.

BY CLICKING ON THE “I ACCEPT” BUTTON WHEN INSTALLING 
THE PROGRAM, YOU ACKNOWLEDGE THAT (1) YOU HAVE READ 
AND REVIEWED THIS AGREEMENT IN ITS ENTIRETY, (2) YOU 
AGREE TO BE BOUND BY THIS AGREEMENT, (3) THE INDIVIDUAL 
SO CLICKING HAS THE POWER, AUTHORITY AND LEGAL RIGHT 
TO ENTER INTO THIS AGREEMENT ON BEHALF OF YOU AND, (4) 
BY SO CLICKING, THIS AGREEMENT CONSTITUTES BINDING AND 
ENFORCEABLE OBLIGATIONS OF YOU.

CONTACTING CUSTOMER SERVICE 
AND TECHNICAL SUPPORT 
For Customer Service questions or problems (returns, warranty), 
please visit http://my.smithmicro.com/support.

For technical support, please refer to Appendix A: Technical Support 
on page 523 of your Poser Reference Manual.

Installing Poser
Installing Poser is a straightforward process. Before inserting 
your DVD, be sure to save any work in progress and close all 
running applications, including virus-checking utilities and other 

http://my.smithmicro.com/support
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“background” software. Having this “clean” environment will help 
the installation process proceed smoothly and will prevent any loss 
of data in the highly unlikely event of a problem. To install Poser, 
complete the following steps:

Windows
Instructions for Windows Vista are given below.

Open your Poser DVD holder and insert the 1.	 Application DVD 
into your DVD drive. The Poser installer will start automatically. 
If it does not, select Computer, right-click your DVD drive and 
select Explore, then double-click the Setup.exe icon in the 
window that appears. If you are asked to confirm whether or 
not to run the file, click Run.

The 2.	 Welcome screen appears with additional information 
about the installation process. Be sure to read this information, 
then click Next to continue.

The Poser EULA appears. This is identical to the text contained 3.	
above. Check the I accept the agreement option, then click 
Next to continue.

The Poser 4.	 Readme.txt file displays in the Information 
window. This file contains information that was too recent to 
be included in this manual. Please take a moment to read this 
file, as the changes outlined therein may affect how you install 

and/or use Poser. Click Next to continue.

The 5.	 Select Destination Location screen appears. Select the 
path where you wish to install Poser. You can either accept 
the default selection, type a new path in the Destination 
Directory field, or use the Browse button to visually locate 
your desired installation folder. Click Next to continue.

Select your desired installation option and click 6.	 Next to 
continue:

Most users should choose the �� Full Installation option, 
which installs core content files, current Poser 8 content, 
and Legacy content. 

Selecting �� Compact Installation only installs critical 
Poser files and core content, and is useful if hard drive 
space is limited. 

Selecting �� Custom Installation allows you to select 
portions of the included Poser content to install along 
with the critical Poser files.

The 7.	 Select Content Location screen appears. Select one of 
the following options and click Next to continue:

Shared Documents Directory�� : Recommended for 
multi-user machines, or machines with Windows Vista 
installed and UAC enabled. This is the default choice.
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Poser Directory�� : Installs Poser content in a Runtime 
folder directly beneath your installation folder.  This is the 
method used by older versions of Poser.

My Documents Directory�� : Recommended for multi-
user machines where content will not be accessed by 
multiple users.

Other Location�� : Recommended when you want to 
install your content on a hard disk other than your 
primary disk (such as a secondary or external hard drive). 
If you checked this option and click Next, you will be 
asked to specify the custom content location. Enter a 
path to the desired folder, or click the Browse button to 
locate the folder you want to use. 

The 8.	 Select Start Menu Folder screen appears. You are 
asked to specify a Start Menu folder. The default choice is 
Smith Micro\Poser 8. To specify a different folder, enter a 
new name or click Browse to select an existing folder on your 
hard drive. Then click Next to continue.

If Setup detects a previous installation of Poser 8 installed 9.	
in the same directory, you are asked if you want to remove, 
backup, or use existing preference files. Select the choice that 
you prefer. Then check or uncheck the option to create a Poser 
8 desktop icon, and click Next to continue.

A summary of your selected installation options appears. 10.	

Review this information to ensure it matches your desired 
settings, then click Install to continue or Back to return.

At this point, the Poser files will be copied to your hard drive. 11.	
After the files are installed, a screen presents the options to 
view the Readme file, visit Content Paradise, and open the 
Display Properties to check your OpenGL settings and update 
your video driver. Select the options you want to perform and 
click Finish.

 Portions of Poser 8 require that Flash Player is installed 
on your system. Verify that Flash Player is present before using 
Poser 8.

 Poser’s Content Library utilizes Microsoft Internet Explorer 
technology. To ensure the optimal experience and compatibility 
for the Content Library, the installer will disable “Local 
Machine Lockdown” for the Poser application. This will not 
affect other applications outside of Poser. Details about “Local 
Machine Lockdown” can be found at http://msdn.microsoft.
com/en-us/library/ms537641(VS.85).aspx.

 The installer grants Poser components in <AppLocation>\
Runtime\ui\Flex\ a Flash sandbox setting of ‘localTrusted’.

http://my.smithmicro.com/support
http://my.smithmicro.com/support
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  Some features of Poser, such as the Library and rendering 
in a separate process, require that you allow local network 
communication to operate. The features will not work if a 
personal firewall prevents local network communication.

Macintosh
Open your Poser DVD holder and insert the 1.	 Application 
DVD into your DVD-ROM drive. A DVD icon will appear on 
your desktop; double-click on this icon to open the Poser DVD 
window.

Double-click on the “Install Poser” icon.2.	

The Authentication window appears, and you will be asked to 3.	
enter your user account password, or an account name and 
password with Administrator privileges, in order to proceed 
with the installation.

The Poser Readme file appears. This file contains information 4.	
that was too recent to be included in this manual. Please take 
a moment to read this file, as the changes outlined therein 
may affect how you install and/or use Poser. When you have 
finished reading the Readme file, click Continue to proceed 
with the installation.

The Poser EULA appears. This is identical to the text contained 5.	
above. Click Continue. You are informed that you must agree 
to the terms of the license. Click Agree to continue.

The 6.	 Select Destination screen appears. Select your desired 
installation folder (default is Applications). You can either 
accept the default selection or use the Select Folder... button 
to visually locate your desired installation folder. Once you 
have made your selection, click the Continue button.

Select your desired installation option. Most users should 7.	
choose the Easy Install option. Selecting Minimum Install 
only installs critical Poser files and minimal new content, and 
is useful if hard drive space is limited. Selecting Custom 
Install allows you to select portions of the included Poser 
content to install along with the critical Poser files. If you need 
information about any of the Custom Install options, simply 
click on the [?] information button to the right of the option 
name. When you have selected an installation option, click the 
Install button to continue with the installation.

The setup program asks where you want to locate your Poser 8.	
content Runtime directory. 

Shared User Folder (/Users/Shared/)�� : Optimal 
Runtime location for multi-user machines, or machines 
in access-restricted environments without sys admin 
privileges.
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Documents folder (~/Documents)�� : Recommended for 
multi-user machines where content will not be accessed 
by other users.

Poser folder�� : Traditional installation method with 
Runtime in the application directory, which provides 
maximum backward compatibility.

Choose Other Location�� : Recommended when you 
want to install your content on a hard disk other than 
your primary disk (such as a secondary or external hard 
drive) or when disk space is low on the boot volume. If 
you checked this option and click Next, you will be asked 
to specify the custom content location. Enter a path to 
the desired folder, or click the Browse button to locate 
the folder you want to use. 

At this point, the Poser files will be copied to your hard drive. 9.	
When the files have been copied, click Quit to exit the Finish 
Up screen.

 Portions of Poser 8 require that Flash Player is installed 
on your system. Verify that Flash Player is present before using 
Poser 8.

  Some features of Poser, such as the Library and 
rendering in a separate process, require that you allow local 
network communication to operate. The features will not work 

if a personal firewall prevents local network communication.

 The installer grants Poser components in <AppLocation>\
Runtime\ui\Flex\ a Flash sandbox setting of ‘localTrusted’.

Upgrading From an Earlier Version of 
Poser
When upgrading from an earlier Poser version, be sure to install 
Poser in a separate, empty folder, so as not to interfere with 
existing Poser installations. Additionally, if you have large amounts 
of content from your previous versions of Poser, the ideal way 
to add this content to your Poser installation is with the Add 
Runtime feature. (See  Accessing Different Content Libraries on 
page 91 for more information about the Add Runtime feature.) 
We do not recommend attempting to copy over or reinstall your 
content in other ways, as we cannot guarantee that the content 
will be properly transferred to Poser.

Registering Poser
After installation, you can choose to register your copy of Poser via 
the Web. Registering Poser with Smith Micro Software is required in 
order to receive technical support, free product updates and other 
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benefits.

If you wish to register your copy of Poser, simply check the 1.	
box on the authentication window that appears upon your 
initial launch of Poser, and Poser will automatically register 
your product for you with Smith Micro Software. If you use this 
method, this is the only action necessary on your part; the rest 
will be taken care of automatically.

Alternately, you can open your browser and navigate to 2.	 http://
my.smithmicro.com/register. In the unlikely event you receive 
an error, please wait a while then try again. If you get repeated 
errors or if you do not have an Internet connection (or prefer 
to register via email), you may call or email Smith Micro 
Software to complete your registration.

Select the version of Poser that you wish to register from the 3.	
dropdown list, and click the Next button to continue.

Enter your user information in the form that appears in your 4.	
browser. Fields marked in red are required for you to register 
your copy of Poser. Enter your information, then click Register 
to complete your registration.

If one or more fields are missing information, a message will 5.	
display specifying the incomplete fields. You will be asked 
to add the necessary information and resubmit your user 
information. Once your registration is successful, a summary 
screen will appear. Thank you for using Poser by Smith Micro 

Software!

Updating Poser
Smith Micro Software is committed to supporting all of our 
products by releasing Service Releases and other updaters that 
address issues present in earlier versions and/or enhance the 
product’s usability or functionality. Poser will automatically check 
for product updates upon launching, and will notify you when 
an update is available. Please visit http://my.smithmicro.com/
downloads to download the latest updates. If you wish to disable 
the automatic update notification, you may do so by clearing 
the Check for Updates on Launch checkbox in the General 
Preferences dialog. If you choose not to receive automatic 
notifications, please visit http://my.smithmicro.com/downloads 
regularly to check for product updates. Alternately, you can click 
the Check Now button in the General Preferences dialog 
to execute an immediate update check. (See Setting Application 
Preferences on page 26 for more information about the General 
Preferences dialog.)

Project Selection
Upon launching Poser, you may want to choose Window > Quick 
Start to view the Quick Start dialog. This dialog allows you to 

http://my.smithmicro.com/support
http://my.smithmicro.com/support
http://my.smithmicro.com/support
http://my.smithmicro.com/support
http://my.smithmicro.com/support
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select a Project to load into the Project Guide palette within 
Poser. A Project is an interactive guided workflow that you can use 
for guidance or reference as you undertake specific tasks within 
Poser. Click the icon for the Project you wish to select, or choose 
a Project from the pop-up menu for more options. Once you have 
selected a Project, click OK to close the dialog and complete your 
launch of Poser.  

Figure 2.1

Should you choose to load a different Project once Poser has 
launched, simply select Window > Quick Start to open the 
Quick Start dialog and change the current Project in the Project 
Guide palette.

Project Guide
Use the arrows at the top of the Project Guide palette to navigate 
through a Project. Click on the right arrow to step forward through 
the pages of the Project, or on the left arrow to step backwards 
through the pages. The current page number and title will be 
displayed in the center between the navigation arrows. The page 
content, as well as any associated actions by the Poser application, 
will be specific to the Project you choose to load.

Figure 2.2

The projects in the Project Guide are interactive workflow 
guides, which means that you, the user, perform the tasks 
described within them. However, some steps may include 
actions automatically undertaken by Poser to assist you in 
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following the processes described.

The Project Guide palette functions in the same manner as 
all palettes within Poser; once enabled, it will remain open and 
accessible. You may choose to interact with the Project Guide 
at your own pace, either stepping through a given Project 
methodically or returning to the Project intermittently within the 
process of your own workflow. As such, the Project Guide is a 
flexible tool designed to meet a variety of work styles and needs. 
Should you decide to close the Project Guide palette, simply 
click on the close icon in the upper right corner of the palette. You 
can then reopen the palette at any time by selecting Window > 
Project Guide from the Poser menu bar.
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Chapter 3: Setting Up the 
Poser Workspace
This chapter discusses the ways in which you can customize Poser 
to suit your individual needs. Your preference settings will be 
stored on your system in the home directory for your user name. 
This allows different users on the same system to set up their 
own individual preference settings. For specific information on the 
location of the preference files on your system, please see Poser 
Default File Locations on page 528.

Setting Application Preferences
Poser’s General Preferences dialog allows you to control 
certain global Poser settings. Open this dialog by selecting Edit > 
General Preferences. The General Preferences dialog appears.

Click the OK button when finished to save your preferences 
and close the dialog. The following topics describe the available 
preferences.

Document Preferences
The Document Preferences tab contains settings specific to 
the Document window. The Document Preference options are as 
follows:

Figure 3.1

•	 Launch Behavior: The Launch Behavior options allow 
you to specify whether the Document window will open 
using your customized preferred settings, or the default 
factory settings, whenever you launch Poser. If you customize 
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the Document window by resizing and/or moving it, or 
by changing the character that loads when you start Poser, 
selecting the Launch to preferred state radio button after 
you have adjusted the Document window will save these 
changes when you exit and re-launch Poser. If you want your 
Document window to revert to its default (as installed)  
location and size whenever you launch Poser, select the 
Launch to factory state button. Please refer to Chapter 
5: The Document Window on page 61 for more information 
about the Document window.

•	 Set Preferred State: Click this button after you arrange 
your document window the way you like. This will save it as 
the preferred startup state

•	 Smoothing Preferences: The Default Crease Angle 
setting allows you to specify the default Crease Angle to 
be used in polygon smoothing calculations. Please refer to 
Smoothing Geometry on page 299 for more information on 
the Crease Angle setting.

•	 Undo/Redo: The Undo/Redo options allow you to specify 
the maximum number of levels for the Undo/Redo cache. 
By default the cache size is set to 100 levels of Undo. You 
can leave this setting at 100 if you have available system 
resources, or you can reduce the level to conserve memory. 
Clicking the Clear cache now... button will clear the Undo/
Redo cache.

Interface Preferences
The Interface Preferences tab contains application-level settings 
for Poser’s general user interface. The Interface Preference options 
are as follows:

Figure 3.2

•	 Launch Behavior: If you customize the Poser interface by 
adding, removing, rotating, resizing, and/or hiding different 
elements, or by creating your own palette arrangements in any 
of the Poser rooms, selecting the Launch to previous state 
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radio button after making your changes will save the changes 
when you exit and re-launch Poser. If you want your Poser 
interface to revert to its default (as installed) location and size 
whenever you launch Poser, select the Launch to factory 
state button.

•	 Display Units: Poser allows you to work with real-world 
units, enhancing your ability to make accurate recreations. Use 
the Display units pull-down menu to make your selection. 
The available choices are:

Poser native units��

Inches��

Feet��

Millimeters��

Centimeters��

Meters��

One Poser native unit is the equivalent of 8.6 feet, or 
262.128 centimeters.

•	 Mouse Input: The Tablet Mode option decreases the 
sampling rate for greater accuracy when using a graphics 
tablet as the input device.

•	 3D Mouse: The 3D Mouse options control the behavior of 
a 3D input device such as 3Dconnexion’s SpaceNavigator. 
Checking the Reverse Cameras box changes the direction 
the main and auxiliary cameras rotate when using a 3D 
mouse. Checking the Reverse Dolly Cameras box reverses 
the direction the dolly cameras rotate when using a 3D mouse. 
Checking the Reverse Actors box reverses the direction 
actors move when controlled with a 3D mouse.

Library Preferences
The Library Preferences tab contains setting that are specific 
to the Poser Library. The Library Preference options are as 
follows:
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Figure 3.3

•	 Double-click Behavior: The Double-click Behavior 
setting specifies the results of double-clicking on a Library 
preset. Select the appropriate radio button to choose between 
adding the new preset to the scene, or replacing the selected 
preset in the scene. Note that the first time you double-click 
on a Library preset, a dialog will come up allowing you to 
specify this setting. Your selected option will then be applied to 
all subsequent double-click instances, unless you change the 
setting in the Library Preferences tab.

•	 File Search: When an object is loaded from the Library, 
Poser searches for all the associated files included with that 
object. The File Search options allow you to configure the 
extent of that search. These options are:

None�� : Selecting None disables file searching; this 
option is useful for testing the accuracy of newly 
developed content.

Shallow�� : Selecting Shallow will reduce the amount of 
time spent searching for missing or mislabeled files, but 
will increase the instances of files not found.

Deep�� : This is the default File Search setting. We 
recommend that you select Deep file searching, as this 
option initiates the most extensive searches for content 
file components, hence increasing the likelihood that 
missing or mislabeled files will be found.

Pose Sets•	 : By checking the Apply Universal Poses box, 
poses saved to the library will be automatically written as 
universal poses, and library poses applied to figures by double-
clicking will always be applied as universal poses.

Render Preferences
The Render Preferences tab contains settings that are specific 
to the FireFly render engine. The Render Preference options are as 
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follows:

Figure 3.4

•	 Number of Threads: If you have a multi-processor and/
or multi-core hardware system, you can take advantage of 
multi-threaded rendering by setting the Number of Threads 
slider to a value greater than one. Even if your system is a 
dual-processor or dual-core system, you may see increased 
benefit from setting the number of threads to four, rather 
than just two. However, if you have a single-processor and 
single-core system, we recommend that you set the number of 

threads to one, as the increased memory demand of running 
parallel threads may offset the performance benefits. For more 
information on multi-threaded rendering, see Chapter 18: 
Using The FireFly Render Engine on page 285.

•	 Separate Process: Checking the Separate Process box 
enables running FireFly renders in a separate process on the 
CPU, and vice versa. This feature is disabled by default. For 
more information on Rendering in a Separate Process, see 
Chapter 18: Using The FireFly Render Engine on page 285.

  We recommend rendering your scene with as many 
threads as your system possesses CPU cores, which is the 
default preference after installing Poser. If you are unsatisfied 
with the resulting performance, or if the render fails to 
complete, then reduce the number of threads and/or maximum 
bucket size..

•	 Cache: The Max Cached Renders setting allows you to 
configure the number of renders that will be cached for access 
via the Render Compare feature in the Document window’s 
Render tab. Please see Render Comparison on page 76 for 
more information about the Render Compare feature.
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Miscellaneous Preferences

Figure 3.5

Save Files•	 : Poser offers the following options for file saving:

�� Use File Compression: Poser supports the use of 
compressed files, which can save significant amounts 
of space. To use compressed files, check the Use file 
compression checkbox. Clearing the checkbox disables 
compressed file support.

Poser uses standard Z-lib compression, allowing you to use 
any Z-lib compatible compression/decompression application to 
compress/decompress files.

All Poser files (scene, figure, pose, expression, hair, 
hand, prop, light, camera, material) can be compressed. 
Compressed Poser files have the extension *.**Z (*.PZZ, 
*.CRZ, *.FCZ, etc.). Poser prop files are saved with the 
extension P2Z to avoid confusion with compressed scene 
files. If you plan to distribute files for use by artists with 
previous versions of Poser, please be sure to save them 
uncompressed. Poser supports file compression beginning 
with the Pro Pack add-on for Poser 4.

Some advanced artists use a text editing application to 
directly edit Poser files. You must uncompress compressed files 
before editing them. To do this, you can either load a file into 
Poser, disable compressed file support, and save the results to 
a new filename or use a third-party compression utility such as 
Stuffit to uncompress the file. If you use the second method, 
you can recompress the file when you’ve finished making edits.

�� Use External Binary Morph Targets: Checking 
this box will enable the use of External Binary Morph 
Targets (EBMTs) when saving new content, or resaving 
legacy Poser files. Saving legacy figures to the Poser 
Library with this option enabled will generate new .pmd 
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EBMT files for those figures, thus allowing you to take 
advantage of morph target sharing, reduced file sizes, 
and faster processing speeds for your legacy figures.

•	 Set Python Editor: Clicking the Set Python Editor 
button opens a standard Browse dialog, allowing you to 
select the application you wish to use to edit PoserPython 
scripts (such as Notepad for Windows).

•	 Software Updates: Checking the Check for Updates 
on Launch box enables the Automatic Update Notification 
feature (see Updating Poser on page 23 for more information 
about this feature). Clearing the box disables Automatic 
Update Notification. Clicking the Check Now button will 
execute an immediate update check.

Setting Up Your Workspace
The Poser workspace consists of the entire Poser screen, including 
controls, the Document window, and other room-specific interface 
elements. You can customize most of these elements to suit the 
way you work and store your preferences for later use.

Docking and Floating Palettes
Poser’s sleek interface is geared toward streamlining your workflow. 
You can dock, float, and arrange floating palettes in each of Poser’s 
different rooms, to set up a workspace layout that meets your 
needs. 

The Window menu contains commands that show or hide Poser’s 
many palettes. If a palette is hidden, simply select the desired 
palette from the Window pull-down menu to display it. 

NOTE: The options in the Window > Room Tools submenus 
are enabled only when the respective room is active. For 
example, the commands in the Window > Room Tools > 
Face submenu will only be enabled when you are in the Face 
Room. 

The upper-right corner of each palette contains a Palette Docking 
Control square. Click the square to open the palette docking menu, 
which contains commands that work as described below.

Figure 3.6
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Moving, Repositioning, and Resizing Palettes

Various controls allow you to resize docked or floating palettes, or 
reposition them as necessary. For example:

Figure 3.7

To resize a docked palette, position the cursor over the resize •	

handle and drag in either direction indicated by the double-
arrow resize cursor.

To resize a floating palette, position your cursor over a side or •	
corner, where it turns into a double-arrow resize cursor. Then 
drag to the desired size.

To reposition a palette, position the cursor in the Title area of •	
the palette, where it turns into a hand. Reposition the palette 
to another area on your screen. If the area that you drag to is 
highlighted in blue, the palette will dock into the highlighted 
area of your workspace. If the area that you drag to is not 
highlighted, the palette will float in the new area when you 
release the mouse button.

Some palettes display scroll bars when they contain more •	
information than can be displayed in the allotted space.

Some palettes (such as the Editing Tools or Display Styles •	
palettes) display options that wrap based on the width of the 
palette.

Some palettes cannot be reduced beyond the minimum size •	
required to display all of the palette options and controls. For 
examples, see the Camera Controls or Light Controls palettes. 

Enabling or Disabling Docking

To enable or disable palette docking:
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Click the Palette Docking Control square at the top-right •	
corner of the palette. Check or uncheck Drag-Docking 
Enabled as appropriate. This selection is checked when 
docking is enabled, and not checked when disabled. 

When Drag-Docking is disabled, you can move the palette 
anywhere on the screen over the main workspace or to an 
additional monitor. The palette will always float until you 
enable drag-docking again.

Docking Palettes

To dock a palette, use one of the following methods:

Drag the palette toward the area in which you want to place it. •	
When the area becomes highlighted, release the mouse. If you 
drag the palette into an area that is already populated by one 
or more palettes, the active docking area will split horizontally 
or vertically to provide a location for the additional palette.

Click the control at the top-right corner of floating palette, and •	
choose Docked from the menu. The palette will dock into the 
position where it was last docked.

Floating Palettes

To float a palette, use one of the following methods:

Drag the palette out of the docked location, and toward the •	
document window. Release the mouse when there is no 
highlighted dock location for the palette.

Click the control at the top-right corner of a docked palette, •	
and choose Floating from the menu. The palette will float in 
the Poser workspace.

Closing Palettes

To close an open palette, use one of the following methods:

Click the •	 Close icon in the upper-right corner.

Click the control at the top-right corner of the palette and •	
choose Close from the menu that appears.

Choose an open palette from the •	 Window pull-down menu 
to close it. Palettes that are currently open are indicated by a 
checkmark.

UI Memory Dots
You can save up to nine interface configurations using the 
Memory dots (described in Memory Dots on page 43﻿). Each 
Memory dot retains a separate instance of your selected interface 
settings. This feature is globally applicable, meaning that UI dots 
can be applied regardless of the specific scene or resolution. An 
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alternative method for saving UI settings for accessibility in any 
Poser scene is to modify Poser’s general preferences as described 
in Setting Application Preferences on page 26. However, while 
preferences set in this manner are saved separately for each screen 
resolution, you can only save one UI configuration per resolution 
using the general preferences.

Setting Up the Document Window
Please refer to Chapter 5: The Document Window on page 61 for 
more information on customizing the Document window and 
using the controls found there.
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Chapter 4: The Pose Room
The Pose room is the focal point for much of your Poser activity. 
This is where you add figures and props to your scene and perform 
your desired posing and animation (you’ll use the Hair, Cloth, 
Material, and Face rooms to set up and animate these items 
and can access the Library palette from any room). This chapter 
introduces you to the basic Poser interface. The following chapters 
will describe these interface elements in greater detail, and then 
will move on to discussing the other rooms in Poser. 

The Pose room appears as follows at 1280 x 960 resolution. 

The number of palettes and options that you see in 
each room depends upon your screen resolution. At higher 
resolutions, the default work spaces display more palettes, 
while at lower resolutions you see fewer palettes:

Figure 4.1

In addition to rooms, much of Poser’s functionality is available 
by using floating palettes and windows within the rooms 
themselves. Most Poser rooms (including the Pose room) allow 
you to customize your Poser workspace by hiding/displaying and 
relocating controls anywhere you like. You can even save up to nine 
different screen configurations for the entire Poser workspace.

The numbers on the image above identify the controls available in 
the Pose room:

Menu•	  bar (1)
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Light•	  controls (2)

Camera•	  controls (3)

Room•	  tabs (4)

Editing•	  tools (5)

Document•	  window (6)

Display•	  controls (7)

Properties•	  & Parameters palettes (8)

UI•	  dots (9)

Animation•	  controls (10)

Library•	  palette (11)

Please refer to Setting Up Your Workspace on page 32 for more 
information about creating and saving custom workspace layouts. 
The following sections provide a brief description of the labeled 
interface elements and references to more detailed information.

Menu Bar
The Menu Bar consists of a series of pull-down menus used 
for accessing Poser functionality. Some menus and/or submenus 

duplicate other on-screen interface elements. The Menu Bar 
appears as follows and is available from every Poser room:

Figure 4.2

Light Controls
The Light controls allow you to adjust lighting properties. Use it 
for such purposes as adding and removing lights, and specifying 
light colors and other light properties. The Light controls appear 
as follows:

Figure 4.3

Please refer to Chapter 12: Lighting on page 186 for more 
information about the Light controls.
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Camera Controls
The Camera controls allow you to select and move one or more 
Poser cameras. There are two types of camera controls: View and 
Position:

Figure 4.4

The topmost controls are the View controls. Clicking one of these 
controls activates the Face, Left Hand, or Right Hand camera, 
as appropriate. You can also scroll through the list of available 
cameras. The controls beneath the hand controls are used to turn 
camera animation on or off, or to use the Flyaround camera. The 
Position controls appear below these controls and are used to 
move or rotate the currently selected camera. The Camera Plane 
position controls move the camera along the X, Y, and/or Z axis, 
while the Trackball rotates the currently selected camera without 

changing its location in 3D space. To use the Camera controls, 
simply click and drag your desired control. Moving a camera does 
not change the locations or poses of figures, props, and other 
elements in your scene.

A subset of these Camera controls appears in the upper-right 
corner of the Document window. Please refer to Chapter 11: 
Cameras on page 170 for complete information about the Camera 
controls.

Room Tabs
The Room tabs allow you to switch from room to room within 
Poser. To enter a room, simply click its tab. 

Figure 4.5

Editing Tools
The Editing Tools display contains the tools you use most often 
when posing figures/props:

By selecting a body part or prop followed by the desired Editing 
tool, you can pose objects in various ways such as translating 
(moving side to side or back and forth), rotating, twisting, etc. You 
can also perform other functions such as editing Inverse Kinematic 
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(IK) chains and working with element/material groups. Each 
Editing tool is a little different, but their basic usage is as follows:  

Figure 4.6

Select your desired body part or prop (referred to as an 1.	
element or actor) in your scene by clicking that actor.

Select the desired 2.	 Editing tool. You can only have one 
Editing tool selected at a time. The currently selected Editing 
tool appears yellow within the Poser interface.

Click and drag to perform the selected tool’s function.3.	

You can use the Editing tools in any combination to create a 
virtually infinite number of still or animated poses. Please refer to 
The Editing Tools on page 129 for more information on the Editing 
tools. In addition, each tool is discussed in depth where appropriate 
in this manual.

Document Window
The Document window is your viewport into the Poser workspace 
where you view and pose your figure and interact directly with your 
scene. Each view of the Document window is displayed through a 
virtual camera, which means you can view each scene from multiple 
camera angles, either one at a time or from up to four angles at 
once.

You can position cameras to view your scene from any angle or 
distance and can resize the Document window to suit your needs. 
In addition, the Document window has numerous controls around 
its edges that you use to change the appearance of scene elements. 
You can also select objects within your scene by clicking them 
directly within the Document window or by using the menus on 
the bottom of the window. Please refer to Chapter 5: The Document 
Window on page 61 for more information about the Document 
window.
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Figure 4.7

Display Controls
The Display controls allow you to select your desired preview 
mode for your entire scene, a figure or prop, and/or specific 
elements of your currently selected figure/prop: 

Figure 4.8

Please refer to Chapter 6: The Display Controls and Menu on page 
77 for more information about the Display controls.

Parameters/Properties Palette
Poser offers an easy-to-use Parameters and Properties palette 
that allows you to access any scene object’s properties and 
parameters in one convenient location:

Figure 4.9

To switch between the Properties and Parameters palettes, 
simply click the desired tab at the top of the palette. 
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 Although both properties and parameters appear in 
the same palette, we will treat them as separate entities 
throughout this manual for clarity.

Parameters Palette
The Parameters palette contains all of an object’s parameters 
transformation settings, (as described in Parameters Palette on 
page 138) and morph targets. Each object type has specialized 
parameters, which are described where appropriate in this manual. 
Further, individual objects can have parameters unique to that 
object. For example, different figures have different morph targets 
available.

Properties Palette
The Properties palette contains all of an object’s properties. In 
addition to certain universal properties (which are described in  
Properties on page 135, each object type has specialized properties, 
which are described where appropriate in this manual.

Library Palette
The Library palette consists of three tabs: 

The •	 Library tab contains all of the various categories of 
content from which you can choose. See 

The •	 Search tab allows you to perform keyword searches 
through one or all of your runtimes.

The •	 Favorites tab gives you quick access to your favorite 
content.

Library Tab
The Library tab contain Poser’s Library content categories. The 
Categories icons allow you to access and search through all of 
the content available to your installation of Poser, including content 
included with Poser and any additional content you may have 
obtained. The Library tab contains categories (Figures, Props, etc.) 
and subcategories (Animals, New Figures, etc.) for organizing 
your Poser content: You can also organize your favorite content in 
the Favorites tab for even quicker access.

Use the Library tab to add or remove elements from your Poser 
scenes. The vast collection of content included with Poser allows 
you start building scenes right away. The Library makes it easy to 
add existing and new content collections so that you can find and 
add any items to your scene. Please refer to Chapter 7: The Poser 
Library on page 89 for more information about the Library palette. 

Poser ships with a wide array of content that you can use 
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to create thousands of unique still and animated scenes. You 
can also use the Content room to locate and obtain even 
more free and for-sale content from leading 3D marketplaces! 
Please refer to Chapter 8: The Content Room on page 120 
for more information about the Content room.

Figure 4.10

Search Tab
Use the Search tab to perform keyword searches on one or all 
of your Runtime libraries. This powerful new features makes it 
easier to find the content you want to use, even in large content 
collections. You’ll find more information in Searching the Library on 
page 117.

Favorites Tab
The Favorites tab on the Library palette provides quick access 
to your favorite Poser content. For more information about adding 
favorites, see Favorites Tab on page 118

Memory Dots
Being able to customize your workspace wouldn’t be useful if you 
had no way of saving your preferences. Poser includes Memory 
dots that allow you to save poses, camera locations, and user 
interface (UI) preferences and to switch between saved items with 
a single mouse click.
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Figure 4.11

Clicking the arrow to the left of the description allows you to 
choose between the Poses, Camera, and UI memory dots that you 
have saved.

Figure 4.12

Please refer to the following for more information on each type of 
Memory dot:

Pose Dots•	 : Pose dots are described in further detail in Pose 
Dots on page 150.

Camera Dots•	 : Camera dots are described in further detail 
in Camera Dots on page 185

UI Dots•	 : UI dots are described in further detail in Setting Up 
Your Workspace on page 32.

Using Memory Dots
To use Memory dots:

Set up your pose, cameras, and/or interface (UI) the way you 1.	
want them.

Use the pull-down menu to select the dot type, as described 2.	
above.

Click an empty memory dot. This dot will appear full, as shown 3.	
to the right:

Figure 4.13

To use a dot, simply click it. The stored settings are applied to your 
scene. To clear a memory dot (delete its information and make it 
appear empty again), press and hold [OPT]/[ALT] while clicking the 
memory dot you wish to erase.



Poser 8
Reference Manual

45

Chapter 4: The Pose Room

Animation Controls
The Animation controls allow you to preview animations and set 
up keyframes. You do this by posing your figure, moving to a new 
frame, and changing the pose. Clicking the Play button plays an 
animation using the keyframes. The Animation controls appear 
as follows:

Figure 4.14

Please refer to Using the Animation Controls on page 314 to learn 
more about the Animation controls, and to Chapter 21: Animating 
with Poser on page 311 for more information about creating and 
rendering animations using Poser.

Showing and Hiding Windows 
and Palettes
The Window menu allows you to enable and disable (show and 
hide) various Poser windows and palettes. The upper portion of the 
Window menu contains the following commands:

 The palette options that are displayed in each room vary, 
depending on your screen resolution or upon which room you 

have displayed.

Figure 4.15

•	 Animation Palette: Selecting Window > Animation 
Palette opens the Animation palette. Please refer to Using 
the Animation Palette on page 317 for information about the 
Animation palette and creating Poser animations.

•	 Graph: Selecting Window > Graph opens the Graph 
palette for the selected element in your scene. Please refer to 
About the Graph Palette on page 322 for information about 
using the Graph when making Poser animations.

Libraries•	 : Selecting Window > Libraries opens the 
Library palette. Please refer to Chapter 7: The Poser Library 
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on page 89 for more information about the Library palette.

•	 Hierarchy Editor: Selecting Window > Hierarchy Editor 
opens the Hierarchy Editor palette. Please refer to The 
Hierarchy Editor on page 493 for more information about the 
Hierarchy Editor palette.

•	 Joint Editor: Selecting Window > Joint Editor opens the 
Joint Editor palette. Please refer to The Joint Editor on page 
500﻿ for more information about the Joint Editor palette.

•	 Sketch Designer: Selecting Window > Sketch Designer 
opens the Sketch Designer window. Please refer to Chapter 
19: The Sketch Designer on page 304 for more information 
about the Sketch Designer renderer.

•	 Walk Designer: Selecting Window > Walk Designer 
opens the Walk Designer window. Please refer to Using the 
Walk Designer on page 336 for more information about the 
Walk Designer window.

•	 Talk Designer:  Choose Window > Talk Designer to 
open the Talk Designer window, described in Using the Talk 
Designer on page 344.

•	 Python Scripts: Selecting Window > Python Scripts 
opens the Python Scripts palette. Please refer to The Python 
Scripts Palette on page 520 for more information about the 
Python Scripts palette.

•	 Room Help: Selecting Window > Room Help opens an 
HTML window with information to assist you in using the 
Poser rooms.

•	 Quick Start Guide:  Choose Window > Quick Start 
Guide to open the Quick Start Guide, described in Project 
Guide on page 24.

•	 Project Guide: Choose Window > Project Guide to open 
the Project Guide, described in Project Guide on page 24.

The lower portion of the Window menu contains commands that 
toggle frequently-used palettes on and off:

Figure 4.16

•	 Camera Controls: Selecting Window > Camera 
Controls toggles the Camera controls display on and off. 
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A check mark next to this option indicates that the controls 
are currently displayed, and vice versa. Please refer to The 
Camera Controls on page 170 for more information about the 
Camera controls.

•	 Preview Styles: Selecting Window > Preview Styles 
toggles the Display controls display on and off. A check mark 
next to this option indicates that the controls are currently 
displayed, and vice versa. Please refer to Chapter 6: The 
Display Controls and Menu on page 77 for more information 
about the Display controls.

•	 Editing Tools: Selecting Window > Editing Tools toggles 
the Editing tools display on and off. A check mark next to this 
option indicates that the controls are currently displayed, and 
vice versa. Please refer to The Editing Tools on page 129 for 
more information about the Editing tools.

•	 Light Controls: Selecting Window > Light Controls 
toggles the Light controls display on and off. A checkmark 
next to this option indicates that the controls are currently 
displayed, and vice versa. Please refer to Chapter 12: Lighting 
on page 186 for more information about the Light controls.

•	 Memory Dots: Selecting Window > Memory Dots 
toggles the Memory dots display on and off. A checkmark 
next to this option indicates that the controls are currently 
displayed, and vice versa. Please refer to Memory Dots on 

page 43 for more information about the Memory dots.

•	 Parameters Palette: Selecting Window > Parameters 
Palette shows or hides the Parameters/Properties palette, 
which contains tabs for the Parameters palette and Properties 
Palette. A checkmark next to this option indicates that the 
Parameters/Properties palette is currently displayed, and 
vice versa. Please refer to Parameters Palette on page 138 
for more information about the Parameters palette., and 
to Properties on page 135 for more information about the 
Properties palette.

•	 Animation Controls: Selecting Window > Animation 
Controls toggles the Animation controls display on and off. 
A checkmark next to this option indicates that the controls are 
currently displayed, and vice versa. Please refer to Using the 
Animation Controls on page 314 for more information about 
the Animation controls.

•	 Room Tools: The Room Tools submenus display options 
that are enabled when you are using the Material, Face, 
Hair, or Cloth room. The options for each room are disabled 
until you enter the room to which they apply:

�� Material: When you are in the Material room, a menu 
option allows you to show or hide the Material Palette.  
See Chapter 13: The Material Room on page 204 for 
further information about the Material Palette.
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�� Face: When you are in the Face Room, menu options 
allow you to show or hide the Face Preview, Photo 
Lineup, Texture Preview, Face Texture Tool, or Face 
Shaping Tool.  These palettes are discussed in Chapter 
23: The Face Room on page 358.

�� Hair: When you are in the Hair Room, menu options 
allow you to show or hide the Hair Growth Groups, 
Growth Controls, Styling Controls, and Dynamics 
Controls palettes. These palettes are discussed in 
Chapter 24: The Hair Room on page 372.

�� Cloth: When you are in the Cloth Room, menu options 
allow you to show or hide the Cloth Simulation, Cloth, 
Cloth Groups, and Dynamics Controls palettes. These 
palettes are discussed in Chapter 25: The Cloth Room on 
page 386.

•	 Tool Titles: Selecting Window > Tool Titles toggles 
display of the titles appearing above the enabled tools on and 
off. A checkmark next to this option indicates that the titles are 
currently displayed, and vice versa.

•	 Document Window Size: Selecting Window > 
Document Window Size opens the Preview Dimensions 
dialog allowing you to resize your Document window when 
it is floating. Please refer to Chapter 5: The Document Window 
on page 61 for information about resizing your Document 
window.

The Document Window is only resizeable when it is 
floating. When docked, the document window expands to fit 
into the space that is not used by docked palettes.

•	 Quick Start: Selecting Window > Quick Start opens the 
Quick Start dialog, from which you can select an interactive 
Project.

•	 Project Guide: Selecting Window > Project Guide opens 
the Project Guide palette with the most recently selected 
interactive Project displayed.

Other Basic Operations

Creating a New Scene
Selecting File > New creates a new Poser scene. A dialog will 
appear if you have any unsaved changes in your previous scene. If 
this dialog appears:

Selecting •	 Yes opens a Save Poser Scene dialog box, 
allowing you to save your current Poser scene. After saving 
your current scene, the new scene will be created.

Selecting •	 No creates a new Poser scene without saving your 
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unsaved changes. All unsaved changes will be lost, so use this 
option carefully!

Selecting •	 Cancel closes the dialog and cancels the new scene 
creation, leaving your current Poser scene open.

Opening a Scene
Selecting File > Open opens a standard Open dialog box, 
allowing you to access and work on a previously saved Poser scene 
file. You are prompted to save any unsaved changes in your current 
scene, if any (see above).

Opening a Recent File
Selecting File > Recent Files opens a pop-up list that displays a 
list of the ten most recent document files (.pz3 or .pzz formats) that 
you opened in Poser.

Closing Your Scene
Selecting File > Close closes your current Poser scene while 
leaving the Poser application running. You are prompted to save 
any unsaved changes in your current scene.

Saving a Scene
Selecting File > Save saves your current Poser scene using your 
previously specified filename and save location. If you have not 
previously saved your scene, Poser will open the standard Save 
As dialog box, allowing you to name and save your current Poser 
scene (see below).

Selecting File > Save As saves your current Poser scene allowing 
you to select a different filename and/or save location. This feature 
is useful for creating different versions of work, which allows 
you to return to any previous stage if you decide you don’t like 
your progress beyond a given save point. For example, you could 
save myscene_1.pz3, then save new versions as myscene_2.pz3, 
myscene_3.pz3, and so forth.

Compressed File Support

Poser allows you to compress saved figures/props/scenes to save 
hard drive room. To enable compression support, select Edit > 
General Preferences, select the Library tab, and check the 
Use File Compression box as described in Setting Application 
Preferences on page 26

Reverting Changes
Selecting File > Revert allows you to undo your changes and 
reopen your current scene file in its last-saved state. This is a 
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great way to do your recent changes over, however you will lose 
everything you’ve done since the last time you saved your scene. 
This is why we recommend that you save your scene often and, 
if you think you may want to return to an earlier version, to save 
progressive versions of your work using the Save As command. 
Clicking Cancel returns you to Poser, and clicking Revert proceeds 
to load the last saved version of your current scene.

Importing Files
Selecting File > Import allows you to bring both Poser and non-
Poser files into your scenes. These could be images, movies, or props 
(which you can convert into Poser figures as described in Chapter 
27: The Setup Room on page 428.

Importing Movies

To import movies, select File > Import>AVI Footage (Windows) 
or File > Import>QuickTime (Macintosh). You can use imported 
movies to add background action to your Poser animations. For 
example, you could have a scene with two Poser characters sitting 
on a train with an imported movie showing the scenery rolling past 
as if the train was in motion.

If your imported movie’s size or aspect ratio (width/height) is 
different than your current Document window settings, you will 
be informed that the background width and height are different, 
and will be asked if you want to change the window to match the 

background. 

Selecting •	 Yes resizes your Document window to fit the 
imported movie. It is recommended that you only use this 
option while the Document window is docked. 

Selecting •	 No “stretches” the Document window to 
accommodate the movie. You may see areas of the Document 
window not covered by the imported movie. 

Changing the aspect ratio of imported movies can introduce 
unwanted artifacts and distortions into your scene when rendered. 
Smith Micro Software therefore recommend resizing your 
Document window or importing correctly sized animations. 

Figure 4.17: Proper Fit Figure 2: Improper Fit

Imported movies will begin at the first frame of your Poser 
animation. If your animation is longer than the movie, the movie 
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will remain in the background paused at its last frame. If your 
animation is shorter than the movie, you will see Frames 1-X of 
the imported movie, where x is the number of frames in your Poser 
animation.

When importing movies, you should try to light your scene in 
a manner consistent with the background so as to blend them 
together. Please see Chapter 12: Lighting on page 186 for 
information about lights in Poser.

Importing Background Pictures

You can also import static images as backgrounds. For example, 
if you are creating a scene with Poser characters in a room with 
a window, you could use a background image to simulate the 
view from the window. Selecting File > Import>Background 
Picture opens a standard Open dialog, allowing you to select 
your image’s format and location. As with movie imports, you are 
asked if you wish to resize your Document window to match 
the imported image, and the results are the same as described 
above. Changing the aspect ratio of imported images can introduce 
unwanted artifacts into your scene when rendered and can result 
in blank areas on the sides of the Document window (see above). 
We therefore recommend resizing your Document window 
or importing correctly sized images. Poser supports importing 
background images in a wide variety of formats. The following is 
only a partial list of those formats supported: SGI, BMP, DDS, EXR, 
GIF, HDR, JPG, PCD, PNG, PSD, TGA, TIFF and WBMP.

When importing images, we recommend that you import them 
while the document window is in its docked state. You should try 
to light your scene in a manner consistent with the background so 
as to blend them together. Please see Chapter 12: Lighting on page 
186 for information about lights in Poser.

Importing Poser Documents or Props

Selecting File > Import >Poser Document/Prop loads either 
an entire Poser scene or a Poser prop into your scene. This can be 
useful for inserting props that are not part of your Library palette’s 
Props category. Imported scenes/props become part of your 
current scene complete with animations, morphs, poses, etc. This 
option opens a standard dialog box allowing you to browse for the 
desired file. Use the Files of type pull-down menu to select one of 
the following types of Poser files:

Poser document files (*.PZ3 and *.PZZ)•	 : This option 
imports Poser 3.0 and later scenes, both uncompressed and 
compressed. 

Poser Prop Files (*.PP2 and *.PPZ)•	 : This option 
imports uncompressed or compressed Poser prop files.

See Miscellaneous Preferences on page 31 for more 
information about compressed file support within Poser.
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Importing 3D Objects

Poser allows you to import geometries in the following formats:

3D Studio Max•	  (File > Import>3D Studio)

DXF •	 (File > Import>DXF)

Wavefront OBJ•	  (File > Import>Wavefront OBJ)

Lightwave 5/6 LWO files•	  (File > 
Import>Lightwave...)

COLLADA•	

Most 3D modeling applications support exporting to at least one of 
the above formats. Some formats, such as Wavefront OBJ, allow you 
to save geometries as either polygons or NURBS surfaces. Poser will 
only accept geometries saved as polygons.

Poser will import smoothing groups in Wavefront OBJ format, as 
defined in the source file. (If no smoothing groups are specified in 
the source file, none will be imported.) Please refer to Smoothing 
Geometry on page 299 for more information about smoothing 
groups. Note that while Poser does not support the 3DS Max style 
of defining smoothing groups, Poser does take into account the 
vertex normals when determining creases. As a result, OBJ files 
exported from 3DS Max will usually appear as expected, despite the 
fact that the 3DS Max smoothing groups are not read.

Tips & Tricks

When using your favorite 3D modeling application for creating new 
geometries for conversion into Poser figures/props, it is a good idea 
to follow these guidelines in order to speed up the figure creation 
process and provide a better end result:

Make sure that you do not have duplicate or overlapping •	
polygons. Duplicate polygons occur when you have two 
identical parts of the geometry occupying the same location, 
for example if you accidentally paste an item twice. The 
following graphic depicts an instance of duplicated polygons 
within a 3D modeling application:

Figure 4.18

Eliminate overlapping polygons, which can occur if pieces of •	
the geometry are embedded within each other. The following 
graphic shows an example of overlapping polygons on the 
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left (the smaller pipe embedded within the larger one), and 
the correct way to create the geometry on the right (without 
overlapping polygons):

Figure 4.19

Poser allows you to import geometries as a single file with •	
groups within the file, as separate files, or as a single file with 
no groups. We recommend that you create your geometries 
as single files with no groups, since Poser includes powerful 
grouping tools and since some geometry formats (such as 
Wavefront OBJ) allow you to assign polygons to more than 
one group at a time. Importing geometries with polygons 
assigned to more than one group will cause Poser to duplicate 
those polygons, resulting in additional unwanted figure parts.

Use the following procedure to import geometries into Poser:

Begin the process by creating a polygonal mesh object in your 1.	

favorite 3D modeling application. Once you have finished, 
import it into Poser by selecting File > Import>format, 
where format is the format you wish to import (such as 
OBJ). A Standard Open dialog appears, allowing you to select 
your desired filename and path.

Once you have selected the desired geometry, the 2.	 Prop 
Import Options dialog appears. It contains the following 
options:

Centered�� : Checking the Centered checkbox positions 
the imported geometry in the center of the Poser 
workspace.

Place on floor�� : When enabled, the Place on Floor 
option places the bottom of the prop at “ground level” 
on the floor of the workspace.

Percent of standard figure size�� : The Percent 
of standard figure size option scales the geometry 
relative to the height of a standard Poser figure. For 
example, setting the scale to 50% imports the geometry 
at 50% of the height of a standard Poser figure. The 
rest of the geometry scales to maintain the correct 
proportions relative to the selected height. When 
importing DXF geometries, Poser considers one DXF unit 
as being equal to the height of a standard Poser figure, 
or about six feet.
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Offset�� : Entering numeric values in one or more of the 
Offset fields positions the geometry at the selected 
position within the Poser workspace.

Weld identical vertices�� : When enabled, the Weld 
identical vertices option unites identical vertices within 
the geometry.

Make polygon normals consistent�� : If the 
geometry file contains vertex normals, checking the 
Make polygon normals consistent checkbox makes 
the polygon normals consistent with the vertex normals.

Flip normals�� : The Flip Normals option reverses all of 
the geometry’s normals.

Flip U Texture Coordinates�� : The Flip U Texture 
Coordinates option reverses the geometry’s U texture 
coordinates.

Flip V Texture Coordinates�� : The Flip V Texture 
Coordinates option reverses the geometry’s V texture 
coordinates.

Once you have finished selecting your desired options, 
click the OK button.

The geometry file imports into Poser. The amount of time 3.	
required to import a geometry file depends on factors such 
as the size of the file, number of polygons or groups, speed 
of your computer, etc. A progress indicator tracks the import 

process. When the process is complete, the imported geometry 
appears in your Poser Document window.

Figure 4.20

Imported geometries are treated as static props. You can add props 
to the Library palette as described in Maintaining Your Library 
Palette on page 113 and/or can convert props into poseable Poser 
figures using either the graphical Setup room (see Chapter 27: 
The Setup Room on page 428 for instructions on using the Setup 
room) or the legacy text-based method (refer to the electronic Poser 
3 Advanced Tips & Tricks manual, available in the Documentation 
folder on your Poser CD in the Documentation folder).
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Exporting Files
In addition to supporting a wide range of import formats, Poser 
supports many formats for export, allowing you to use your Poser 
output with your favorite 2D and 3D applications.

Exporting Images

To export an image, select File > Export>Image. A standard 
Save As dialog appears, allowing you to specify your desired 
filename and save location. In addition, you may be able to select 
various image-specific attributes (such as quality for JPG exports).

If you want Poser to write an alpha channel to preserve 
transparency in your exported image, you should export to 
either the PNG, TIFF, or PSD formats. An alpha channel causes 
the foreground to be transparent wherever it is empty, in order 
to allow the background to show through. This feature is 
essential for compositing in image editing applications.

Exporting an image saves a snapshot of your current scene as seen 
in the active tab of your Document window. Therefore, if you are 
in the Preview tab of the Document window, your exported 
image will be a snapshot of the scene exactly as it appears in the 
Preview tab. If you are in the Render tab, your exported image 
will be the rendered image that is currently selected in the Main 
Render menu at the bottom left of the Document window.

Exporting BVH Motion Files

To export a BVH motion capture file:

Select the figure you wish to export.1.	

Select 2.	 File > Export>BVH Motion.

Select 3.	 Scale Automatically. If the exported file looks 
incorrect, re-export it and disable automatic scaling. 

A standard Save dialog appears, allowing you to specify your 
desired filename and save location.

Exporting Painter Scripts

Clicking the Export Painter Script button in the Sketch 
Designer exports the current Sketch Designer settings to Corel 
Painter (see Chapter 19: The Sketch Designer on page 304﻿). This 
has been tested to work with Painter 6 and previous versions, and 
is not supported for later versions though it may work with them.

Exporting 3D Objects

Poser allows you to export 3D objects in RIB, 3DS, DXF, OBJ, 
VRML, LWO, OBJ, and COLLADA formats by selecting File > 
Export>format, where format is one of the supported export 
formats. To export to a 3D format:

Select 1.	 File > Export>format.
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In the dialog that appears, check the appropriate radio button 2.	
to export either a still (at the current frame of your animation) 
or an animation. If you select to export an animation, enter 
the frame starting and ending numbers in the appropriate text 
boxes and click OK.

Select the actor(s) you want to export in the following dialog 3.	
and click OK.

A standard 4.	 Save As dialog appears, allowing you to select 
your desired filename and path.

 If you are trying to create a full-body morph target, do not 
select File > Export>Wavefront OBJ. Instead, select Figure 
> Create Full Body Morph.

Exporting Flash (SWF) Files

Flash is a popular 2D format most commonly used for animating 
Web content. You can export your Poser file to the Flash format 
(.swf file) from the Make Movie dialog, and then use the Flash 
application to modify the file. Flash presentations are normally 
viewed directly within Web browsers using the Adobe Flash plug-in. 

Please refer to Chapter 22: Rendering Animations on page 351 for 
more information about the Make Movie dialog, and to Flash 
Options on page 355 for information about setting Flash export 

options.

Run Python Script
Selecting File > Run Python Script opens a standard Open 
dialog, allowing you to browse for your desired PoserPython script. 
Once you locate your script, select it and click OK to execute it.

Convert Hier File
Selecting File > Convert Hier File opens a standard Open dialog 
box prompting to you locate and open a Poser 3 Hierarchy file 
(*.phi). If this file contains no errors, this function creates a Poser 
Figure (*.cr2) file. Please refer to “About Poser Files on page 525 
for more information about Poser files and their functions.

Hierarchy files are used when creating custom figures using the 
text-based method (see Chapter 27: The Setup Room on page 
428). Since the introduction of the graphical Setup room, this 
older method, while still supported, is far longer and more tedious 
as it forces you to do everything manually while in a text-based 
environment. If you do wish to create custom Poser figures using 
this older method, please refer to the Poser 3 Advanced Tips & 
Tricks Manual. This document is in PDF format and is saved in the 
Documentation folder on your Poser CD.
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Page Setup
Selecting File > Page Setup opens a standard Print Setup 
dialog box allowing you to set up your printers. Please refer to your 
operating system and/or printer documentation for information on 
setting your print preferences.

Print
Selecting File > Print sends your current scene to your selected 
printer. A standard Print dialog box opens allowing you to 
select your desired printer and general printing properties. Poser 
documents always print using the full page size. Please refer to 
your operating system documentation for information on selecting 
print options.

Exit
Selecting File > Exit closes Poser. You are prompted to save any 
unsaved changes. You can also type [COMMAND]/[CTRL]+[Q] to 
exit Poser.

This menu option is available for Windows only. For Macintosh, the 
Quit command appears on the Poser Application menu.

Undo
Selecting Edit > Undo reverses your most recent change to the 
actual scene. You can also press [COMMAND]/[CTRL]+[Z]. Undo 
applies only to alterations made within the actual scene; it is not 
applicable to changes made to application settings, Library content, 
etc. 

Poser supports multiple levels of Undo. Selecting Edit > Undo 
repeatedly allows you to step backwards through your most 
recent document changes, reversing each change individually and 
reverting the scene to its previous state. Some operations within 
Poser will purge the Undo/Redo cache; a warning dialog will 
appear asking you to confirm before the action is implemented. 
Closing the file will purge the Undo/Redo cache.

You can specify the maximum size of the Undo stack. Please see 
Setting Application Preferences on page 26﻿ for more information.

You can specify whether or not the Undo feature will 
apply to camera changes. Open the Properties palette for the 
currently selected camera, and check the “Remember changes 
for undo” checkbox in order to apply Undo to camera changes. 
Alternately, if you do not wish camera changes to be included 
in the Undo feature, make sure to uncheck this checkbox for 
each camera. This checkbox is active by default.
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Redo
Selecting Edit > Redo reiterates the most recently undone action, 
thus reverting the scene to its previous state. You can also press 
[COMMAND]/[CTRL]+Shift+[Z]. To reverse a Redo action, simply 
select Edit > Undo again.

Cut
Selecting Edit > Cut removes the selected element(s) and places 
them in the system Clipboard for later pasting. You can also press 
[COMMAND]/[CTRL]+[X]. You can do this for poses and other 
functions.

Copy
Selecting Edit > Copy copies the selected element to the 
Clipboard. You can copy and paste elements and poses. For 
example, here’s a figure whose Abdomen pose has been copied to 
its arm:

Figure 4.21 Before (left); After (right)

To copy and paste a shaped body part:

Manipulate the body part using any tool you desire.1.	

Select the body part (source), then select 2.	 Edit > Copy or 
press [COMMAND]/[CTRL]+[C].

Click to select the body part you wish to copy to (target) and 3.	
select Edit > Paste (see following subsection). This copies all 
settings from the source to the target, including deformers.
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Paste
Selecting Edit > Paste, or pressing [COMMAND]/[CTRL]+[V], 
places the item stored in the Clipboard into your current scene. If 
you are pasting a pose, select the element to apply the copied pose 
to, then make your selection.

 Copying and pasting poses from one side to the other 
does not mirror the poses. The same pose is applied. To mirror 
poses, use the Symmetry function.

Copy Picture
Selecting Edit > Copy Picture takes a snapshot of your scene, 
which you can then paste into a graphics application such as 
Adobe Photoshop. Your scene is copied exactly as displayed in the 
Document window.

 Copying and pasting images in this manner is not the 
same as rendering. Please refer to part 9 for information on 
rendering Poser scenes.

Duplicate
The Duplicate [ObjectName] option creates an exact duplicate 
of the currently selected figure or prop. The duplicate object is 
placed within the Document window, in the same position as 
the original. The duplicate object will appear in either the Select 
Figure or Current Actor menu, depending on whether it is a 
figure or a prop, and can be resized and repositioned independently 
from the original object.

Restore
Need to restore a scene element to its default state? Selecting 
Edit > Restore opens a submenu allowing you to restore scene 
elements, which are completely restored to their Poser default 
states, including but not limited to position, scale, morphs, 
parameters, materials, parent/child relationships, etc. This function 
is literally for cases when you wish to go back and start all over 
again. Use it with care! The Restore submenu appears as follows:

Your options are:

Element•	 : Selecting Edit > Restore>Element restores the 
current element to its default state. An element could be a 
body part, prop, single camera, or single light.

Figure•	 : Selecting Edit > Restore>Figure restores the 
current figure to its default state.
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Lights•	 : Selecting Edit > Restore>Lights restores all lights 
in your scene to their Poser default state.

Camera•	 : Selecting Edit > Restore>Camera restores the 
current camera to its default state.

All•	 : Selecting Edit > Restore>All restores all scene 
elements to their default states. Use this option with care!

Memorize
While working, you might arrive at a convenient stopping point. You 
know you like what you have so far and do not want to revert all 
the way back to the Poser default state should you need to restore 
one or more scene elements (or even the entire scene) at a later 
time. No problem. Select Edit > Memorize and the element(s) you 
wish to memorize (the list is the same as for the Restore submenu, 
above). Doing this essentially changes the default for your selected 
item(s), which can be undesirable in some cases. Redoing this 
operation saves the new default overwriting the old. If you later 
select Edit > Restore, your element(s) will be restored to the last 
memorized settings.

It is very important when setting up new figures to use 
the Edit > Memorize > Figure command to preserve default 
poses so that Inverse Kinematics works properly.

Memorization works on a per-file basis, meaning that memorizing 
defaults in one file does not affect the defaults of other Poser files 
or Library entries.
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Chapter 5: The Document 
Window
The Document window is your portal to the Poser workspace 
where you view and can directly manipulate your scene and the 
elements within it. The Document window consists of two tabs: 
the Preview tab, which is where you do the work to set up your 
Poser scene; and the Render tab, which is where you can view the 
results of your renders. The following topics discuss the Document 
window controls and how to use them:

Preview Tab
Clicking on the Preview tab at the top left of the Document 
window brings up the scene preview window, where you can 
manipulate figures, props, etc. to set up your Poser scene. Refer to 
Preview Tab on page 281 for detailed configuration parameters 
for the Preview tab’s preview display window. The Preview tab 
contains the following controls:  Figure 5.1
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Title
The Title appears along the top of the Document window, and 
displays the current Poser scene (such as My_Scene.pz3).

Options Menu
Clicking on the arrow at the right side of the Title bar opens the 
Document window’s Options menu. This menu contains the 
following settings and shortcuts:

Figure 5.2

Render
Selecting Render from the Context menu renders your entire 
Poser scene, using the render settings specified in the Render 
Settings dialog, and the render engine specified in the Render 
Engine Selection menu on the Render tab. For more information 
on Poser’s render settings, see Part 4: Rendering on page 276﻿.  The 
render results will appear in the Render tab of the Document 
window.

Export Image
Selecting Export Image opens a standard Save As dialog that will 
allow you to save the scene as it appears in your scene preview 
window as an image file. This can also be accomplished by selecting  
File > Export>Image..

Reload Textures
Clicking on Reload Textures will reload into memory all textures 
for the current scene preview display. This allows you to easily 
update any changes you may have made in other applications to 
the currently loaded textures.
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Reuse Shadow Maps
If you do not make changes to lights or object positions between 
renders, there is no need to recalculate the shadow maps for your 
scene, as they will not have changed. The Reuse Shadow Maps 
option allows you to save the shadow map computations from your 
previous render and reuse them, thereby saving time with each 
subsequent render.

Clear Shadow Maps
Clicking on Clear Shadow Maps will cause Poser to recalculate 
the shadow maps for your scene during the next render. Use this 
option if you have made changes to lights or object positions, as 
such changes will affect the shadows in your scene.

Render Settings
Selecting Render Settings will open the Render Settings dialog. 
See Chapter 17: The Render Settings Dialog on page 280 for more 
information on the Render Settings dialog options.

Render Dimensions
Selecting Render Dimensions brings up the Render 
Dimensions dialog, which contains settings that allow you to 
specify the dimensions of your render tab. See Render Dimensions 
on page 74﻿ for more information on the Render Dimensions 
dialog settings.

Preview Dimensions
Selecting Preview Dimensions brings up the Preview Dimensions 
dialog. Here you can specify your desired height and width 
(in pixels) of the scene preview window. Clicking the Match 
Background button forces the Document window to match the 
dimensions of an imported background image or movie. Clicking 
the Match Production Aspect button sets the scene preview 
window size to the currently selected Production Frame aspect. 
This button is only active when the Production Frame feature is 
enabled (see Production Frame on page 81﻿). Clearing a checkbox 
disables the specified option.

Collisions
A collision occurs when two objects in your scene partially or 
completely occupy the same 3D space. Selecting the Collisions 
menu item opens a pop-up menu that allows you to set the 
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following collision options for your current Poser scene:

Collisions On•	 : Checking the Collisions on option prevents 
objects in your scene from colliding with/penetrating each 
other.

Collisions Off•	 : Checking the Collisions off option allows 
objects in your scene to collide with/penetrate each other.

Show Intersections•	 : Checking the Show intersections 
option displays colliding polygons in red when objects in your 
scene collide with/penetrate each other but does not prevent 
the collision.

Once you have set collision preferences for your scene, you must 
then enable collision detection for each of the objects for which you 
want to use this feature. Do this by selecting your desired objects 
one at a time and checking the Collision Detection checkbox in 
that object’s Properties palette. This feature only works between 
objects that have collision detection enabled. If you have one object 
enabled and one disabled, collision detection will not work.

Objects lose their collision detection settings when hidden.

Document Window Size
The Document window is dockable and floatable. When the 
Document window is in its floating state, there are two ways that 
you can resize it:

Clicking and dragging the bottom right corner of the •	
Document window to your desired size.

Choose •	 Window > Document Window Size, which 
opens the Preview Dimensions dialog. Enter your desired 
scene preview window height and width (in pixels) in the 
appropriate fields and click OK to resize the Document 
window. Clicking the Match Background button forces the 
Document window to match the dimensions of an imported 
background image or movie. Clicking the Match Production 
Aspect button sets the scene preview window size to the 
currently selected Production Frame aspect. This button is only 
active when the Production Frame feature is enabled (see 
Production Frame on page 81). Clearing a checkbox disables 
the specified option. Note that these options are disabled (as 
shown below) when the Document window is docked.
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Figure 5.3

The Document window size is saved in the same manner as 
described in Single/Multiple-View Panes on page 69.

OpenGL Hardware Acceleration
Poser offers OpenGL hardware accelerated rendering as well as 
SreeD software rendering options for the scene preview display. 
Simply right-click (Windows) or Apple key-click (Mac) within 
the preview window to select hardware or software rendering 
for processing the scene previews. In most cases, hardware 
rendered previews will be faster than software rendered previews. 
Additionally, hardware accelerated performance is independent of 
the preview window size, whereas software rendering will yield a 

lower frame rate with larger preview window sizes. Unfortunately, 
due to the vast variety of graphics hardware available, hardware 
acceleration may not be supported on every system. In that case 
please use the SreeD software rendering option. Poser should 
automatically detect whether or not OpenGL hardware rendering 
is supported for your system, and if not, should default to SreeD 
software rendering.

Figure 5.4

Select Figure/Current Actor Menus
The top left of the Preview tab contains the Select Figure (left) 
and Current Actor (right) pull-down menus. The currently selected 
figure and item appear as labels, and those item’s properties and 
parameter dials are accessible in the Parameters & Properties 
palette. Double-clicking anywhere in the scene preview area will 
open the Parameters & Properties palette in the position and 
state in which it was last used, with the settings for the currently 
selected figure and/or actor displayed. You can also select figures, 
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props, and other scene objects by clicking on them directly in the 
scene preview area.

Figure 5.5

Select Figure Menu•	 : Use the Select Figure pull-down 
menu to select your desired figure. This can be helpful if you 
have a number of figures in your scene (particularly if you 
are using conforming clothing, each item of which is a Poser 
figure).

Current Actor Menu•	 : The Current Actor pull-down 
menu allows you to select scene items as follows:

Body Parts�� : Selecting Current Actor>Body Parts 
opens the list of the currently selected figure’s body parts. 
By using this option, you will select only the specified 
body part on the currently selected figure.

Body�� : Selecting Current Actor>Body selects the entire 
body and all body parts of the currently selected figure.

Props�� : Selecting Current Actor>Props opens the 
list of all props in your scene (including hair and cloth 
objects), allowing you to select your desired prop.

Cameras�� : Selecting Current Actor>Cameras opens 
the list of the cameras in your scene. You may select any 
camera from this list. Please refer to Chapter 11: Cameras 
on page 170 for information about Poser cameras.

Lights�� : Selecting Current Actor>Lights opens the list 
of lights in your scene. You may select any light from this 
list. Please refer to Chapter 12: Lighting on page 186 for 
information about Poser lights.

Preview Tab Context Menu
Right-clicking (Windows) or Apple key-clicking (Mac) within a scene 
preview tab will open up the Context pop-up menu. This menu 
includes the following options:
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Figure 5.6

Select•	 : Choosing the Select option opens a pop-up menu 
that lists all the actors that are directly underneath the 
current position of the mouse pointer, following along the 
z-axis relative to the screen. You can use this menu to select a 
specific actor (i.e., one of the finger segments) without having 
to interrupt your workflow to either change your camera 
view in the Document window, or select the actor from the 
Current Actor menu or Parameters/Properties palette.

Camera View•	 : The Camera View option provides a list of 
available cameras for your scene. Click on a particular camera 
in the list to make that camera view for the current pane.

OpenGL/SreeD•	 : Please see OpenGL Hardware Acceleration 
on page 65 for an explanation of the OpenGL hardware 
rendering versus SreeD software rendering options. 

Toon Tones•	 : The Toon Tones menu offers the choice 
of five different cartoon shading styles, for use within the 

scene preview area. These shading styles affect the Cartoon 
Display Style specifically, and are only visible when Cartoon is 
selected as the Document Style, Figure Style, or Element 
Style from the Display menu. Note that these styles are for 
the scene preview only, and are not to be confused with final 
render shading styles.

Area Render
The Area Render feature allows you to select a specific region of 
your scene to render, thereby allowing you to more quickly view 
the results of changes to one part of your scene, without having to 
re-render the entire scene each time. Area Renders appear in the 
Render tab overlaid on the window’s existing image at the time 
the Area Render was taken, so you can view the rendered area in 
the context of your entire scene.

Figure 5.7

To use the Area Render feature, simply click on the Area Render 
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icon at the top of the Preview or Render tab. The symbol will 
turn red, indicating that Area Render has been enabled. Then click 
and drag within the scene preview area to select the portion of the 
scene you wish to render. The results will appear in the Render tab 
of the Document window, using the render settings specified in 
the Render Settings dialog, and the render engine specified in 
the Render Engine Selection menu on the Render tab. Poser 
will save the most recently rendered image in the Render tab, 
allowing you to toggle back and forth between the Preview and 
Render tabs, without losing your rendered image.

Render
The Render icon at the top of the Preview or Render tab is a 
shortcut to the Render command. Clicking this symbol will render 
your entire Poser scene, using the render settings specified in the 
Render Settings dialog, and the render engine specified in the 
Render Engine Selection menu on the Render tab. For more 
information on Poser’s render settings, see Part 4: Rendering on 
page 276. The render results will appear in the Render tab of the 
Document window.

Figure 5.8

Mini Camera Controls
The Mini Camera Controls located at the top right of the 
Preview tab contain a subset of the total available Camera 
controls. From left to right, these are:

Camera Rotation•	 : The Camera Rotation trackball tilts 
and spins the currently selected camera about all three axes.

Move XZ•	 : Clicking and dragging the Move XZ control 
moves the currently selected camera along the X and/or Z 
axes.

Move XY•	 : Clicking and dragging the Move XY control 
moves the currently selected camera along the X and/or Y 
axes.

Please refer to Chapter 11: Cameras on page 170 for detailed 
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information about the Camera controls.

Figure 5.9

Changing Cameras within a Pane
The camera label in the upper left corner of the scene preview 
tab displays the currently selected camera for that pane. You can 
change the selected camera in each pane of the Preview tab. To 
do this, click on the Current Actor pop-up menu, or right-click 
anywhere within the desired pane to open the context menu, and 
click on the Camera View option:

Figure 5.10

To change the camera, click your desired option. The view in the 
selected pane will switch to your newly selected camera.

Single/Multiple-View Panes
By default, the Preview tab consists of one pane, meaning that 
you can view your scene using one camera at a time. You can, 
however, add up to four simultaneous viewing panes (cameras) to 
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your Document window using eight customizable layouts, which 
helps you visualize your scene in all dimensions. To select a layout, 
click the Document window Layout menu button in the lower left 
corner of the Preview tab, and select your desired layout from the 
pop-up menu. To toggle between single pane and the most recently 
selected multiple-pane layout, press [D]. Press [F] to cycle through 
all of the available multiple-pane layouts.

Figure 5.11

You can resize panes by clicking and dragging their borders. Poser 
remembers pane sizes and camera selections if you switch layouts 
while working on a given scene, and these selections are also saved 
when you save your Poser scene. To use the same layout every 
time you launch Poser, select the Previous State option from the 
General Preferences dialog as described in Setting Application 

Preferences on page 26. You can also save up to nine pane/camera 
layouts using the UI Memory dots (see Memory Dots on page 43).

Clicking anywhere in a pane makes that pane active. A red border 
appears around the active pane.

Tracking Mode
Tracking mode determines the type of preview Poser uses to display 
an object when you reposition either that object or a camera. 
The Tracking Mode pop-up menu in the lower left corner of 
the Preview tab offers three tracking mode options. From top to 
bottom, these are:

Box•	 : Displays scene elements (figures and props) as bounding 
boxes all the time, whether still or moving. This is the fastest 
way to preview scenes and is useful for rough blocking work.

Fast•	 : Displays figures and props in the currently selected 
display style while they or the camera are still and as bounding 
boxes when in motion. This combines an accurate scene view 
so you can see before and after images without waiting for 
each frame to fully render. Fast tracking can help save time 
while blocking out scenes and creating animations.

Full•	 : Displays scene elements in the currently selected 
Document window display style at all times, whether still 
or animated. This mode is suitable for users with high-
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performance computers and for performing fine-tuning on 
previously blocked-out scenes.

Depth Cueing and Shadows
The two buttons to the right of the Tracking Mode menu along 
the bottom left of the Preview tab control depth cueing and 
shadows, respectively:

Depth Cueing�� : Depth Cueing adds dimension to 
scene elements visible in the Document window. When 
Depth Cueing is enabled, elements farther away from 
the camera fade into the distance. This provides a quick 
visual indication of the depth of your scene, which can 
be helpful if you are viewing it using a single pane. To 
toggle depth cueing on and off, click the Depth Cueing 
button. Depth Cueing depends on the total depth 
of your scene. For example, if your scene consists of a 
single figure, the portions of that figure farthest from the 
camera will appear faded out. Adding another element 
(such as a prop) farther from the camera than the figure 
will cause the prop to appear faded with the figure being 
more visible. This is useful if you wish to control the 
amount of depth cueing in your scene.

Figure 5.12

Shadows�� : Items in your scene can cast shadows on 
the ground plane, which can help you orient them in 
3D space. Disabling shadows can help speed up scene 
redraw time. Clicking the Shadows button toggles drop 
shadows on and off for your scene. These shadows are 
not shadows in the traditional sense, meaning that they 
do not depend on the scene lighting. They are generic 
shadows intended solely to aid you in creating your 
scene.

Depth cueing and shadows do not affect your rendered 
output.
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Figure 5.13

Colors
You can improve your view of your scene by altering the 
foreground, background, shadow, and ground colors appearing 
within the Document window’s Preview tab. The four dots 

located along the lower-right corner of the Preview tab allow you 
to control the following colors, respectively:

Figure 5.14

•	 Foreground: Clicking the Foreground button opens the 
Poser Color Picker and displays an eyedropper icon. Pressing 
[OPT]/[ALT] while clicking this button opens your operating 
system’s standard Color Picker. Position this dropper over the 
color you wish to select and click it. If you use the operating 
system’s standard Color Picker, you can alter the color using 
numeric values. The Foreground color affects the color of the 
Silhouette, Outline, Wireframe, and Hidden Line display modes 
(see Chapter 6: The Display Controls and Menu on page 77﻿).
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Figure 5.15

•	 Background: Change the Background color as described 
above. This color affects the Poser workspace background.

The final render will always display whatever is attached 
to the Color channel of the Root Background node. However, if 
you wish the same image to appear in the preview render, you 
must also attach it to the BG Picture or BG Movie node. For 
more information about nodes, please refer to Chapter 15: 
Material Room Nodes on page 232.

•	 Shadow: Change the Shadow color as described above. 
This color affects the preview shadow displayed in the 
Preview tab (if enabled).

•	 Ground: Change this color as described above. This color 
affects the ground plane displayed in the Preview tab (if 
enabled).

Render Tab
Clicking on the Render tab at the top left of the Document 
window displays the main render window, where you can see the 
rendered results of your Poser scene. The Render tab contains the 
following controls:  

Figure 5.16
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Render Dimensions
The main render window size is displayed in the upper left corner 
of the Render tab. Clicking this display brings up the Render 
Dimensions dialog, which contains the following settings:

Figure 5.17

Match Preview Window•	 : Clicking the Match Preview 
Window radio button sets the resulting render to match the 
existing render preview window size.

Fit in Preview Window•	 : Alternately, clicking the Fit in 
Preview Window radio button will fit the resulting render 
within the render preview window, while maintaining the 
specified aspect ratio.

Render to Exact Resolution•	 : Clicking the Render 
to Exact Resolution radio button will generate the render 
results according to the specific resolution specified in the 
following fields.

Width•	 : Enter the width in pixels for the render window in 
the Width field. Larger measurements take longer to render 
and require more disk space.

Height•	 : Enter the height in pixels for the render window in 
the Height field. Larger measurements take longer to render 
and require more disk space.

Resolution•	 : Enter the resolution in dot pixels per inch (DPI) 
in the Resolution field. 72DPI is normal for screen-resolution 
images and is suitable for images you intend to distribute 
online. 300DPI is appropriate for most print functions, and 
1200DPI is used when you need extreme detail. Higher 
resolution images require more disk space and take longer to 
render.

Constrain Aspect Ratio•	 : Checking the Constrain 
Aspect Ratio checkbox preserves the render window’s 
aspect ratio (width divided by height). For example, if you 
begin with 640x480 and change the 640 to 1280, the height 
will automatically change to 960. Clearing this checkbox 
disables this option.
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Match Document Window•	 : Clicking the Match 
Document Window button sets the Document window’s 
current size in the Width and Height fields.

The production frame is determined by the aspect ratio resulting 
from the output width and height. You can set the production frame 
to be visible in the Document window’s scene preview area, by 
selecting  Display > Production Frame from the menu bar.

Quick-Scale
The Quick-Scale pop-up menu is along the top left of the Render 
tab. It offers quick access to three different render scale options: 
Full Size, Half Size, and Quarter Size. Note that this feature is not 
intended to replace the Render Dimensions menu, but rather is 
a tool for facilitating quick render previews, as the smaller scale 
render sizes require less time to calculate.

Figure 5.18

Render Engine Selection
Click on the name of the currently selected render engine, along 
the top of the Render tab, to display the Render Engine popup 
menu. This menu allows you to easily switch between the various 
renderers included with Poser. To modify the render settings for 
each render engine, open the Render Settings dialog by clicking 
on Render > Render Settings... in the menu bar (see Chapter 
17: The Render Settings Dialog on page 280 for a description of this 
window).

Figure 5.19

Area Render
Clicking the Area Render icon along the top right of the Render 
tab enables the Area Render feature, which allows you to select 
a specific region of the current image to render, thereby saving 
processing time. Area Render uses the render settings specified 
in the Render Settings dialog, and the render engine specified in 
the Render Engine Selection menu (as described above). Area 



Poser 8
Reference Manual 

76

Chapter 5: The Document Window

Render is available for the FireFly renderer only. Please see Area 
Render on page 67 for a complete description of this feature’s 
functionality.

Render
To render the current image, click the Render icon along the top of 
the Render tab. The results will display in the main render window 
area, using the render settings specified in the Render Settings 
dialog, and the render engine specified in the Render Engine 
Selection menu (as described above).

New Render Window
Clicking the arrow symbol next to the Render icon sends the 
current Main render image to a new window. You can then select 
a previously rendered image, or generate a new one, in the main 
render window and compare the two images side by side.

Pan
If the image you have rendered is larger than the render window 
size, you can pan the image by clicking and dragging in the main 
render window. The Pan symbol at the top right of the Render tab 
activates this feature. Panning is useful as it allows you to shrink 
the Document window as needed, such as when entering the 

Material room, and still have access to your entire rendered image. 

Render Comparison
Poser offers convenient render comparison features, allowing 
you to contrast two different rendered images within the main 
render window. Clicking either of the two squares in the lower 
left corner of the Render tab brings up a pop-up menu listing 
the most recent renders by date and time. By default, the most 
recent render is set as the Main render, and is checked in the list 
under the black square. The second most recent render is the 
default Compare render, and is checked in the list under the white 
square. You can, however, select any render from the list as your 
Main and Compare renders. To compare the Main and Compare 
renders, use the Render Wipe slider at the bottom of the main 
render window. Moving the slider to the right displays the Main 
render, while moving it to the left displays the Compare render. The 
default number of recent renders listed is ten. You can configure 
this number in the General Preferences dialog. (See Setting 
Application Preferences on page 26 for more information about the 
General Preferences dialog.)
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Chapter 6: The Display 
Controls and Menu
Poser allows you to select 12 display styles. Selecting a different 
display style can help you better visualize your scene and/or add 
additional artistic interest to your rendered output. You can select 
display styles on the scene, figure/prop, or element (body part) 
level. By default, the Display controls appears with Document 
selected, as follows:

•	 When the Figure Display Style controls are displayed, there 
is an additional option Use Document Style. This sets the 
currently selected figure to the same display style that you 
have selected for the entire document.

•	 When the Element Display Style controls are displayed, there is 
an additional option Use Figure Style. This sets the currently 
selected element to the same display style as the figure to 
which it is a part.

Figure 6.1

The Display Controls palette has adjustable width and 
height, and the controls auto-wrap to fit the allotted width. 
If additional height is needed to display all the controls, a 
scrollbar appears on the right side of the palette. 

Clicking the arrow to the left of the title opens a pull-down menu 
with the following options:

Figure 6.2

•	 Document Style: Selecting the Document Style option 
accesses the Document Display controls. Changing this 
selection affects how all scene elements (figures and props) 
are displayed.

•	 Figure Style: Selecting the Figure Style option accesses 
the Figure Display controls, which causes only the selected 
figure or prop to display in the selected style without affecting 
the other scene elements.

•	 Element Style: Selecting the Element Style option 
accesses the Element Display control, which causes only 
the currently selected element (body part or prop part) to 
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display in the selected style without affecting the other scene 
elements.

To select a different display style, click the desired button. From left 
to right, these buttons are:

•	 Silhouette: displays the figure/element only as a cutout, as 
shown to the right.

Figure 6.3

•	 Outline: displays the figure/element only as an outline. 
When either the entire scene or an entire figure is displayed in 
this mode, outlines appear around each actor (body part), as 
shown to the right.

Figure 6.4

•	 Wireframe: displays the figure/element as a polygonal 
mesh. This mode displays the actual polygons comprising the 
figure/element, including polygons that would normally be 
hidden from view (such as a figure’s back when viewed from 
the front), as shown to the right.

Figure 6.5

•	 Hidden Line: displays only the figure/element’s polygons 
that would normally be visible from the current camera. 
For example, if you are viewing a figure from the front, the 
polygons forming the back would not be visible, as shown to 
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the right.

Figure 6.6

•	 Lit Wireframe: displays much the same as the Wireframe 
display style, except that the polygons’ colors correspond to 
the color of the surface material, as shown to the right.

Figure 6.7

•	 Flat Shaded: displays figures/elements using the surface 
material colors while displaying the mesh facets, as shown to 
the right.

Figure 6.8

•	 Flat Lined: same as the Flat Shaded display style, except 
that black mesh lines clearly denote polygon edges, as shown 
to the right.

Figure 6.9

•	 Cartoon: displays the figure/element using a simulated 
hand-drawn style, as shown to the right. See Cartoon Tones 
on page 88 for more information about this shading style. 
Poser offers improved Cartoon display effects in conjunction 
with the OpenGL hardware acceleration option (see OpenGL 
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Hardware Acceleration on page 65﻿).

Figure 6.10

•	 Cartoon With Line: same as the Cartoon display style, 
except that figures/elements are outlined with black lines, as 
shown to the right. See Cartoon Tones on page 88 for more 
information. 

Figure 6.11

•	 Smooth Shaded: displays figures/elements as smooth 
continuous surfaces with the material colors, as shown to the 
right.

Figure 6.12

•	 Smooth Lined: combines the Flat Lined and Smooth 
Shaded by displaying the polygons as a black mesh over a 
smooth surface, as shown to the right.

Figure 6.13

•	 Texture Shaded: displays figures/elements using texture 
maps, as shown to the right.
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Figure 6.14

You can also change display styles by selecting Display > 
Document Style, Display > Figure Style, and Display > 
Element Style.

By default, Poser renders using the Texture Shaded mode. While 
rendering high-resolution output using the currently selected 
display styles and/or depth cueing, etc. is not directly supported, 
you can achieve excellent results using the rendering tips discussed 
in Tips & Tricks on page 284.

The Display Menu Commands
As the name implies, the Display menu controls how items 
appear in your Poser workspace, specifically within the Document 
window.

Production Frame
Selecting Display > Production Frame allows you to specify 
whether you wish the production frame to be visible in the 
Document window’s scene preview. You can also select between 
Image Output Size and Movie Output Size, for your production 
frame display. The size of the production frame is determined by the 
aspect ratio resulting from the output width and height. See Render 
Dimensions on page 74and Chapter 22: Rendering Animations 
on page 351 for more information about configuring the output 
dimensions for images and movies, respectively.

Document Style
Selecting Display > Document Style allows you to select a 
display style for your entire Poser scene. This is the same as using 
the Display controls discussed earlier.

Figure Style
Selecting Display > Figure Style allows you to select a display 
style for your currently selected Poser figure. This is the same as 
using the Display controls discussed earlier.

If your currently selected figure does not use the same 
display style as the document, choose Display > Figure Style 



Poser 8
Reference Manual 

82

Chapter 6: The Display Controls and Menu

> Use Document Style to change to change it to the same 
display mode that is selected for Document Display Style.

Element Style
Selecting Display > Element Style allows you to select a display 
style for your currently selected scene element (for example, a body 
part or a prop). This is the same as using the Display controls.

If your currently selected element (body part, prop, hair, 
and so on) does not use the same display style as the figure 
to which it is attached, choose Display > Element Style > 
Use Figure Style to change to change it to the same display 
mode that is selected for the figure.

Depth Cued
Selecting Display > Depth Cued toggles depth cueing on and 
off. Depth cueing makes objects fade as they get further from the 
camera. A check mark appears when this feature is active and vice 
versa. Please refer to Depth Cueing and Shadows on page 71 for 
more information about depth cueing.

Figure 6.15

Tracking
Selecting Display > Tracking allows you to set your desired 
tracking mode. Please refer to Tracking Mode on page 70 for more 
information about tracking modes.

Deformers
As the name implies, deformers (morph targets, parameters, force 
fields, and magnets) affect the shape of figures and props within 
your scene. 
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 The Alyson and Ryan figures utilize many deformers to 
improve bending and joint performance. 

Each deformer type is discussed in its own section later in this 
manual. Selecting Display > Deformers allows you to:

Show all deformers (magnets, waves, and force fields) in your •	
scene (Display > Deformers>Show All). 

Hide all deformers in your scene (•	 Display > 
Deformers>Hide All).

Only show the currently selected deformer. (•	 Display > 
Deformers>Show current selection only).

A check mark appears next to the currently selected deformer 
display mode. You can select hidden deformers using the Current 
Actor pull-down menu. Hiding some or all deformers can reduce 
clutter, particularly in complex scenes.

Ground Shadows
Selecting Display > Ground Shadows displays or hides ground 
shadows, as shown

Please refer to Depth Cueing and Shadows on page 71 for more 
information about ground shadows.

Figure 6.16

Figure Circle
Selecting Display > Figure Circle toggles displaying a white 
circle around your currently selected figure in your scene, which 
turns red depending on cursor location, allowing you to select the 
entire figure. Please refer to Selecting Body Parts on page 127 for 
more information about the Figure Circle.

Bend Body Parts
Selecting Display > Bend Body Parts toggles bending on and 
off. All body parts are separate elements (actors). As you change 
their positions, Poser attempts to maintain continuity over the 
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entire body. The arm should connect smoothly to the shoulder, etc. 
Poser achieves these smooth transitions by bending body parts 
where they join. However, the bends that work well for a body part 
might not work well when applied to figures created from props, 
or figures that have some body parts replaced by props (such as 
replacing a hand with a hook for a pirate character). Rendering 
images with bending disabled can cause figures to appear 
“broken”, as shown above.

Figure 6.17

Foreground/Background Color
Selecting Display > Foreground Color or Display > 
Background Color allows you to specify the Document 
window’s foreground and background colors, respectively. You 
can also do this using the Color controls located next to the 
Document window. Please refer to Colors on page 72 for an 
explanation of foreground and background colors.

Show Background Picture
If you have a background image in your scene that was placed 
there using either the File menu (see Importing Background 
Pictures on page 51﻿) or by pasting the current figure/prop into 
the background (see below), then selecting Display > Show 
Background Picture toggles displaying this image on and off. 
Please refer to Importing Movies on page 50 for more information 
on adding a background animation to your Poser scene.

Clear Background Picture
Selecting Display > Clear Background Picture deletes the 
currently displayed background image (if any).

Paste Onto Background
You can paste an image of your currently selected figure/prop into 
your scene background:
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Figure 6.18

To do this, select the prop/figure you wish to paste into the 
background, then Select Display > Paste onto Background. If 
you do this more than once, each succeeding image supersedes the 
previous one. This is also true if you import a separate background 
image/movie.

Show Background Footage
Selecting Display > Show Background Footage displays 
imported animation footage in the workspace background.

Clear Background Footage
Selecting Display > Clear Background Footage removes 
imported animation footage from your scene.

Guides
Poser provides several guides to assist you when posing figures. 
Guides are particularly useful for helping you achieve a particular 
perspective more easily. To display a guide, select Display > 
Guides and select the guide you wish to display. A check mark 
appears next to visible guides. To hide a guide, select Display > 
Guides and select the guide you wish to hide. Hidden guides have 
no check marks next to them. The available guides are:

Ground Plane

The ground plane provides a basic reference of the camera’s 
position relative to the Poser workspace. It also helps show scene 
elements’ vertical positions relative to one another. You can display 
the ground plane using the same display style as the rest of your 
scene or you can give it its own display styles.

Figure 6.19
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Head Lengths

This guide references the figure’s height. Most people are roughly 
seven “heads” tall, meaning that the average head is 1/7th 
the height of a person. This guide can be helpful when you are 
performing body shaping operations such as using morph targets.

Figure 6.20

Hip-Shoulder Relationship

This guide displays the relationship between the figure’s upper and 
lower body. It helps you see the side-to-side, bend, and twist in the 
hip, abdomen, and chest. This is particularly useful when editing/
viewing your figure using different cameras.

Figure 6.21

Horizon Line

This guide references the Poser workspace’s horizon line. You can 
check camera orientation by selecting a camera and checking its 
position relative to the horizon line. The horizon line is also useful 
when creating perspective between two or more figures or other 
scene elements. For example, if the horizon line crosses the front 
figure’s chest, arrange all the figures so that the horizon line 
crosses their chests as well. This ensures that all figures are on the 
same plane and contributes to a viewer’s sense that all figures 
have their feet on the ground.
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Figure 6.22

Vanishing Lines

Vanishing lines are an artistic technique for achieving realistic 
perspective. You can see this is real life by standing at the corner of 
a long building and sighting along a wall. You will see that the roof 
and the ground appear to converge the farther away you look until 
they eventually meet. This phenomenon is one of the things that 
give objects the appearance of depth in both real and virtual life.

Figure 6.23

Focus Distance Guide

The focus distance is the distance at which objects appear most 
in focus. This distance is individually configurable for each camera. 
The Focus Distance Guide shows you where the focus distance for 
the selected camera falls within the scene, to help you visualize the 
position of various scene elements in relationship to the focal plane. 
For more information on the focal plane and focus distance, see 



Poser 8
Reference Manual 

88

Chapter 6: The Display Controls and Menu

Camera Parameters on page 179.

Preview Drawing
Selecting Preview Drawing allows you to specify whether 
you wish to use OpenGL hardware rendering, or SreeD software 
rendering, for your scene preview display. Please see OpenGL 
Hardware Acceleration on page 65 for more information about 
hardware versus software rendering.

Cartoon Tones
Selecting Cartoon Tones allows you to choose between the 
following options for your scene preview display: One, Two, or 
Three cartoon shading tones, Three Tones Plus Highlights, and 
Smooth Toned. These shading styles affect the Cartoon Display 
Style specifically, and are only visible when Cartoon is selected as 
the Document Style, Figure Style, or Element Style from the 
Display menu. Note that these styles are for the scene preview 
only, and are not to be confused with final render shading styles.
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Chapter 7: The Poser Library
Poser’s hierarchical Library palette provides access to all of the 
content that ships with Poser such as figures, props, lights, cameras, 
etc. It has three tabs: the Library tab that provides access to the 
Poser content categories, the Search tab which allows you to 
search your content folders for specific files, and the Favorites tab 
where you can gain easy access to your frequently used or favorite 
content items. The Library tab contains nine categories, discussed 
below. Each category is further divided into subcategories. You can 
create and remove categories and subcategories, and can add and 
remove content, including your existing content libraries, to/from 
the Library palette. See Maintaining Your Library Palette on page 
113] for information on maintaining your Library palette. 

Poser can also automatically install content purchased or obtained 
using the Content room as described in Chapter 8: The Content 
Room on page 120. 

Figure 7.1 shows the various controls and options that are 
contained in the library palette. The boxed area in Figure 1 shows 
the Library list. Navigate through the Library list as follows:

Use the Up and Down arrow keys to move higher or lower in •	
your content tree.

Use the Right and Left arrow keys to open and close folders.•	

Click or select an item in the list to expand the display and •	
view a larger preview of the content item.

Figure 7.1

1.	 Library Tabs: Allows you to switch between three views in 
the Library Palette: Library, Search, and Favorites.

2.	 Category Icons: Allows you to select one of the nine 
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library categories. From left to right, they are Figures, 
Poses, Faces, Hair, Hands, Props, Lights, Cameras, 
and Materials.

Library Menu3.	 : Click the Docking Control icon in the upper-
right corner to select commands that dock, undock, close, or 
enable/disable dragging.

Library Selection4.	 : Click to display all runtime folders, or a 
selected runtime folder in the library contents window.

Add Library5.	 :  Click the Add Library (+) icon to open the 
Browse for Folder dialog, which allows you to select additional 
Library folders that you have stored on your computer.

 A Remove Library (-) icon appears to the right of the 
Add Library icon when you select a Library that you added 
yourself through the Add Library command. See Removing 
Libraries on page 93 for details.

Category Selection6.	 : Allows you to select a library 
category (listed above in Category Icons) by name.

Collapsed folder7.	 : Click the right arrow to expand the 
contents of the folder. The number that appears in brackets at 
the beginning of the folder name designates the number of 
items that are contained within that folder.

Expanded folder8.	 : Click the down arrow to collapse the 
contents of the folder. The number that appears in brackets at 
the beginning of the folder name designates the number of 
items that are contained within that folder.

Selected item9.	 : The currently selected item is highlighted, 
and displayed with a larger icon. File details appear at the 
left of the icon that indicate file size, date installed, and date 
modified.

Content preview10.	 : If a content item is not selected, a 
smaller preview icon appears beside the name of the file. Click 
once to select the item to view its details.

Single checkmark 11.	 (sometimes referred to as the Apply 
to Scene button): Click the single checkmark icon to replace 
the item that is currently selected in your scene with the item 
that is highlighted in the library. 

Double Checkmark 12.	 (sometimes referred to as the Add 
to Scene button): Click the double-checkmark icon to add 
the currently selected item to your scene. 

 For a detailed explanation of the Single and Double 
checkmark buttons in the various Library categories, see 
Loading and Managing Items using the Library Icons 
on page 94
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Add a Folder (+}: 13.	 Click this button to create a new folder 
or subfolder beneath the currently selected library folder.

Save to Library (+)14.	 : Click this button to add the item that 
is currently selected in your scene into the library.

Delete from Library (-)15.	 : Click this button to delete the 
library content item that is currently selected. Note that this 
button completely removes the library item from the Library, 
not from your scene. 

Add to Favorites:16.	  Adds the item that is currently 
highlighted in the library to the library’s Favorites tab.

Displaying the Library Palette
If the Library Palette is not open, select Window > Libraries. You 
can then dock or float the library palette, and position it wherever 
you like (including on a second monitor) . For further instructions 
on arranging palettes, refer to Docking and Floating Palettes on 
page 32.

You can drag either side of the Library palette across your screen to 
the desired width. While the palette is in its floating state, you can 
resize it like any other window.

Accessing Different Content 
Libraries
Poser contains two Libraries: Runtime (contains the content that 
shipped with your copy of Poser) and Download (a default folder 
for added third-party content). Additional library content will be 
found if you elect to install the Legacy content during installation.

Poser content libraries are arranged in Runtime folders, 
which contain many different types of components that are 
used in Poser. In addition to content such as figures, props, hair, 
and poses, Runtime folders can also contain scripts, interface 
files, plug-ins, and other application-critical data. The  collection 
of different types of elements in a Runtime folder is known as 
a Library. 

You may add as many Libraries as you wish. This feature allows 
you to store Poser content in different folders and/or different 
drives, making content management more powerful than ever. Also, 
should you need to reinstall Poser for any reason, you can do so 
without affecting your custom Libraries. You can access each of your 
Libraries using the Library palette.
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Switching Libraries
To switch Libraries, click on the Show Library menu, which is 
located along the top of the Library tab of the Library palette. 
Doing so will open the Available Libraries pop-up menu, from 
which you can display the contents of any single Library, or of all 
your runtime libraries. 

Figure 7.2

Adding Libraries
As mentioned earlier, Poser creates Runtime and Download 
libraries during installation, dependent upon which content you 
elect to install during installation (Poser Content and/or Legacy 
content). There is also a great deal of third-party content available 
for Poser, and if you have acquired a large collection you may find it 
necessary to arrange your content into multiple library folders. Then 
you can use the following process to make your additional folders 
appear in the Library palette.

To add a Library:

Open the 1.	 Library palette if it is not open.

Click the 2.	 Add Library button (+) to open a standard Browse 
for Folder dialog box. 

Figure 7.3

Select a folder on any of your local or mapped network drives 3.	
within which to build a new Library. Clicking OK creates the 
new Library and adds subfolders for each Library palette 
category (Figures, Props, etc.) under your selected folder. You 
may then populate this new Library at will.
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Figure 7.4

When adding existing Poser libraries to your Poser Library 
palette, you must preserve your Runtime folder name and 
structure (<drive>:\<folder>\<subfolder>\Runtime\<folders>. 
Navigate the Browse dialog to your desired Runtime folder. 
The added Library will appear using the name of the folder 
containing the Runtime folder.

Removing Libraries
The Remove Library button appears when a library other than the 
Poser default libraries is selected. You cannot delete the default 
Poser library. Deleting libraries only severs the link between the 
Library folders and the Library palette. It does not remove any of the 
folders or content from your hard drive. This protects your data from 
accidental deletion and allows you to reuse Libraries at need (such 
as from removable drives).

 If you want to remove the Library from your hard drive 
completely, you will need to do this manually by deleting the 
folder and contents from your hard drive. Exercise extreme 
caution when deleting library folders from your hard drive, as 
they will be irretrievably lost.

To remove a library:

Use the 1.	 Show Library list to select the Library that you want 
to delete.

Click the 2.	 Remove Library button (minus sign) to remove 
the selected Library from the Library palette. The name of the 
library is removed from the Show Library list, and its contents 
no longer appear in the Library.
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Figure 7.5

Loading and Managing Items 
using the Library Icons
The Library icons appear as shown in the following figure. Certain 
Library icons are only available for specific categories. These icons 
appear at the bottom of the palette.

From left to right, these icons are:

Figure 7.6

•	 Single checkmark: Clicking the Apply to Scene (single 
check) button serves different functions as listed below:

Figures Category�� : Changes the selected figure.

Poses Category�� : Applies the pose to the figure for 
which it was originally designed.

Faces:��  Applies the selected face expression to the 
currently selected figure.

Hair:��  Adds selected hair to the scene. 

Hands:��  Applies a hand pose to the currently selected 
figure. You are prompted to specify right hand or left 
hand.

Props:��  Adds the currently selected prop to the scene.

Lights:��  Replaces the existing lights in the scene with the 
currently selected light set.

Cameras:��  Applies the camera settings to the camera.

Materials:��  Applies the single material to the currently 
selected single material in an object; or, applies a 
Material Collection to all materials in the current object.

•	 Double checkmark: The Add to Scene (double check) 
button appears for the following categories and serves the 
purposes listed below:
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Figures Category�� : Creates a new figure in the scene. 
Typically used to add additional human characters, 
clothing, and other poseable figures.

Poses Category�� : Applies the currently selected pose as 
a universal pose.

Lights:��  Adds the lights in the library to those already 
present in the scene.

Add a Folder•	 : Click the Add a Folder (+) button to create 
a folder beneath the currently selected Library folder.

Save to Library•	 : Clicking the Save to Library (+) button 
adds the selected item to the Library palette.

Delete from Library•	 : Clicking the Delete from Library 
(-) button removes the selected item from the Library palette.

Add to Favorites•	 : Click to add the currently highlighted 
library item to your Favorites list.

Placing/Adding Items to the Poser 
Workspace
In addition to using the library icons as discussed in the previous 
section, you can also drag an item from the library and drop it into 
your scene. As you drag an item from the library to the scene, a 

tooltip displays the action that you are performing.

Figure 7.7

Removing an Item From the Poser 
Workspace
To remove an item from the Poser workspace, first select the item 
to remove by either selecting it in the Document window or using 
the Current Actor pull-down menu (see Select Figure/Current 
Actor Menus on page 65﻿), then press [DEL].
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About Library Palette 
Categories
Poser’s new library allows you to quickly select categories and the 
items contained within them:

Click a •	 Category icon to select a Content category. Then drill 
down in the hierarchical list in the Library list to select the 
item you want to add to your scene.

Figure 7.8

You can also drill down through the •	 Category menu to select 

an item. First, click the Category icon to select the main 
category for your content. Then click the Category button 
(shown in the following figure) to drill down in the menus 
until you find the item you want to choose. In the following 
figure, the menu drills down from Hair > Poser 8 Content 
> Poser 8 > Alyson to list all of the available hair objects in 
that folder.

Figure 7.9

The Library palette categories are described in further detail below 
in About Library Palette Categories on page 96. Please refer to 
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Loading and Managing Items using the Library Icons on page 94 for 
information on working with Library palette content.

The default categories are broken down by Poser file type: Figures, 
Poses, Faces, Hair, Hand poses, Props, Lights, Cameras, and 
Materials. Please refer to Poser File Types on page 526 for a brief 
discussion of Poser file types and how they relate to using Poser. 
When you switch between categories, the Library remembers which 
item was selected the last time you used a specific category.

You can navigate through the Content pane as follows:

•	 When you reach a content folder that contains items, you can 
navigate through the contents in the folder using your arrow 
keys. Click to activate a selection in the Content pane, then use 
the Left and Right arrow keys to collapse or expand folders, 
and the Up and Down arrow keys to navigate through the 
folder contents.

•	 Press the Refresh button to refresh the contents. This is useful 
after you install content while Poser is running.

The Library popup menu displays nested menus, but you can •	
also click on a folder or category to switch to it, and then 
highlight an item to load it.

The Figures Category
Figures are poseable content items that use an extension of CR2 
or CRZ. The Figures category houses your poseable Poser figures. 
This category contains many figures to work with, including various 
types of males and females, children, skeletons, mannequins, stick 
figures, and animals. Morph values can be saved with figures if you 
choose the option to do so while saving them. Newer Poser figures 
feature fully articulated hands and feet with movable fingers and 
toes.

 There are two main types of clothing used in Poser: 
conforming clothing (discussed here), and dynamic clothing, 
which are treated as and found in the Props library. You’ll find 
more information about dynamic clothing in Chapter 25: The 
Cloth Room on page 386.
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Figure 7.10

Some models are available in high- and low- resolution versions. 
Use high-resolution models for realism, and low-resolution models 
(these have very low polygon counts) when performance matters. 
For example, using low polygon figures instead of high polygon 
figures in the distance of a large scene can conserve on your 
computer resources. 

Replacing Figures

If you want to replace a figure or light in your scene with one from 
the Library palette:

Select the figure you wish to replace and click the 3.	 Change 
Figure (single check mark) button. 

If you are replacing a figure, the 4.	 Keep Modified 
Geometries dialog appears with the following options:

Keep modified geometries�� : Check this option 
if you have modified the geometry of the figure with 
morphs and want to pass the modifications on to the 
figure that is replacing it.

Keep props attached to figure�� : Check this option 
if you have attached props to the figure and want to 
attach them to the figure that is replacing it.

Keep deformers attached to figure�� : Check this 
option if you want the new object to use any deformers 
(magnets or wave deformers) that you have added to the 
object that is being replaced.

Figure 7.11
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After you make your selections, click 5.	 OK to continue. The 
Change Figure dialog appears:  

To have the new figure retain the old figure’s proportions, 6.	
check the Keep current proportions checkbox. Leaving 
this checkbox blank allows the new figure to retain its own 
proportions. 

Click 7.	 OK to proceed to the next step or Cancel to abort.

Adding Conforming Clothing

The simplest way of clothing figures is with conforming clothing. 
Conforming clothing is poseable, just like a human or animal 
figure.  This type of clothing is typically designed for a specific figure 
(for example, clothing designed for Alyson will not fit or conform 
exactly to the G2 figures). However, when conforming clothing is 
“attached” (or conformed) to the figure, it automatically bends and 
poses along with the character that wears the clothing. 

Conforming clothing is rigged like a figure, including the same 
joint parameters. Some conforming clothing includes morphs that 
correspond with the morphs in the figure.

You will find conforming clothing in either the Figure library or the 
Props library. 

When found in the Figures library (as is typical for older •	
clothing, or conforming clothing created by third-party content 

creators), conforming clothing will use a CR2 or CRZ extension.

When found in the Props library (as is common for Poser 7, •	
Poser 8, and G2 Figure clothing prepared by Smith Micro), 
conforming clothing will use a PP2 or PPZ extension. 

To add conforming clothing to your scene:

Figure 7.12

Select the figure you wish to clothe.1.	
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Select a conforming clothing item from the desired 2.	 Figures or 
Props category. Clothing is often named for the figure that it 
is designed to fit (for example, Alyson Pants).

If your clothing is in the Figures category, click the 3.	 Create 
New Figure button at the bottom of the Library palette. If 
the item is in the Props category, click the Apply Library 
Preset button. The clothing appears to the scene in its default 
position and pose. Alternatively, you can drag and drop from 
the Library to the Document window.

When added to the scene, conforming clothing appears in the4.	  
Select Figure menu pull-down menu (described in Select 
Figure/Current Actor Menus on page 65﻿) . Verify that the 
clothing item that you want to conform is currently selected.

Choose 5.	 Figure > Conform To. The Conform To dialog 
appears, listing all of the figures in your scene.

Figure 7.13

Sometimes you might notice the base figure poking through 
areas of the conforming clothing. There are two ways to 
correct this problem. The first method is to hide the body part 

of the figure that is poking through by setting the body part as 
invisible (see Body Part Actor Properties on page 136). The 
second method of correction is to use the Morph Brush to raise 
the clothing over the hole, or lower the body part underneath 
the clothing (see Creating Morphs with the Morphing 
Tool on page 458). 

Select the figure you wish to conform the clothing to in the 6.	
dialog that appears. Click OK when finished. The clothing 
conforms to the figure:

Apply a pose to the figure, and the conformed clothing should 7.	
automatically snap to the new position.

 If the clothing item that you added does not appear in 
the Select Figure menu, check inside the Current Actor > 
Props menu, because you may have added a dynamic clothing 
item instead. For further information on using Dynamic 
clothing, see Chapter 25: The Cloth Room on page 386.

You can also use conforming clothing without a figure. 
Conforming clothing is treated like any other Poser figure and 
can be added to the Poser workspace and posed/animated just 
like any other Poser figure.
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The Poses Category
The Poses Library palette category houses poses (*.pz2), which 
actually fit into several different categories. 

Figure Poses

Poses were originally designed as pre-defined poses (standing, 
sitting, working, and so on) that you could apply to your currently 
selected figure. Pose files store pose information for an entire figure, 
including its hands (see below for more information). They contain 
joint positions for each of the figure’s joints (such as Left Elbow 
bend 45 degrees). 

 When adding a pose to a figure, facial expressions are not 
applied, even if they are included in the Pose file. This preserves 
any work you have done to your face prior to applying the 
pose. To apply facial expressions, choose items from the Face 
category in your library. If the pose contains morph settings 
they will override the values on the figure to which they are 
applied.

Figure 7.14

To add a pose to a figure:

Select the figure (not its clothing) to apply the pose to.1.	

Open the Poses category and highlight the pose that you want 2.	
to apply to the figure.

Choose one of the following options:3.	

Click the �� Apply Original Pose (single checkmark) 
button to apply the pose to the selected figure when the 
pose was created specifically for that figure.

Click the �� Apply Universal Pose (double checkmark) 
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button to apply the pose to the selected figure as a 
Universal pose.

Drag and drop the pose from the Library to the figure. A ��
tooltip displays the name of the character as your mouse 
hovers over it. Release the mouse when the tooltip 
displays the correct character name.

Figure 7.15

 Some of the Poses included in the Library are Universal 
Poses, meaning they will be compatible with any human Poser 
figure. If you check the Apply Universal Poses option in the 
General Preferences dialog > Library tab, you can save any 
pose to your library as a Universal pose.

 Poses that are set-up for figures with standard rigging 
may not apply correctly when uses with figures that have the 
G2 rigging (as found in Poser 7 or Poser Pro) and Poser 8 
figures.

 Poses that were created in Poser 6 or earlier versions 
applied specifically to a particular figure. For example, a pose 
you may have created for the James figure may not work 
correctly when applied to the Kate figure due to the different 
joint setups between the two figures. However, you can apply 
a legacy pose to the figure for which it was designed, and 
then save it to the Library, which will convert the pose to a 
Universal Pose for use with other figures.

Material (or MAT) Poses

Advanced Poser users have created Material Poses (or MAT files 
for short) which are an alternative to the materials and material 
collections that you can find in the Poser Material library (see The 
Materials Category on page 110). Third-party Poser users invented 
MAT files, which are an advanced feature that has not been created 
or tested by Smith Micro Software.

MAT poses are used to apply different material sets to Poser 
content and are typically used with content or texture sets that are 
made by third-party content creators. If you need help with MAT 
files, please refer to the file creator (if you purchased or obtained 
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a MAT file using the Content room, for example) or to one of 
the many online resources, some of which are listed in Third-Party 
Forums on page 8.

Other Pose Types

Though not as common as figure and MAT poses, you will also find 
a mixture of other types of pose files in the Pose Room. Like MAT 
poses, these are generally created by third-party content creators. 
Other uses for Pose files include:

Many Smith Micro characters (including Ryan and Alyson) •	
include Specialty poses that zero a figure, add deformers, turn 
IK off of the legs and arms, and lock or unlock the toes. Third-
party content may or may not include similar poses. Figure 7.16

•	 MOR poses, which apply character morphs and settings to a 
figure.

•	 INJ and REM poses, which inject or remove injected morphs 
into or from a figure.

When you are not certain what a pose type is used for, check the 
Readme file (which usually accompanies the third-party product), or 
contact the individual that created the product.
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Adding Poses with Animation Layers

If you are adding a Pose set containing Animation Layers to your 
scene, a dialog will appear asking whether or not you wish to Add 
new layers to your scene, or Merge all the layers in the Pose set 
into a single layer, which you can select from a pop-up menu. The 
dialog also provides you with options for how to handle duplication 
of layer names when adding new layers to the scene. For more 
information on Animation Layers, see Layers Tab on page 331﻿.

Figure 7.17

 The Faces Category
The Face Library palette category houses facial expression files 
(*.fc2), which can be applied to your currently selected figure. 

Face files contain parameter settings that activate facial morph 
targets (see Chapter 28: Modifying Figures & Props on page 443 
for information about morph targets) to create the expression. 
These files are the same as if you manually adjusted each of 
the face dials available for your current figure, or if you use the 
Random Face poses in the Library, except that they apply preset 
values at once, saving time. 

Poser Face directories contain full facial expressions (Angry, 
Disgust, Fear, and so on). You can also dial these individually, by 
facial region (eyes, lips, cheeks, and so on). To do so, click on the 
head to find the full set of facial morphs. Any combination of these 
head/face morph targets will be stored in the Face category when 
you add a new entry.

Facial expressions are often designed for a particular figure, since 
each figure can have different facial parameters available. For 
example, an expression file created for the Poser 6 Male figure 
(James) may not work on Ryan, because Ryan has far more 
available facial parameters.

  Ryan and Alyson’s Face directories contain full facial 
expressions. You can also dial the expressions manually in the 
Morphs section of the Parameters palette when you select 
Ryan or Alyson. To dial these individually, by facial region such 
as eyes, lips, or other feature, click the head to find the full 
set of morphs. You can save any combination of these head/
face morph targets when you save a new face to the Library’s 
Face category.
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To add a facial expression:

Select the figure to apply the expression to.1.	

Locate the desired facial expression in the Face library.2.	

Double-click the selected facial expression, or click the 3.	 Apply 
Library Preset button, or drag the selected expression from 
the library to the character. The facial expression on your figure 
changes.

Figure 7.18

The Hair Category
The Hair Library palette category houses hair (*.hr2) files, which 
can be applied to your currently selected figure. Hair created for one 
figure may or may not fit or work with other figures. 

There are three different types of hair used in Poser:

Conforming hair, which is commonly found in the Figures •	
library (usually when created by third-party vendors) or in the 
Hair library (usually when created by Smith Micro). This type 
of hair is added and conformed to your figure as instructed in 
Adding Conforming Clothing on page 99.

Prop hair, which is a modeled and textured OBJ file found in •	
the Hair category, using an HR2 extension.

Strand-based (or dynamic) hair, which is created in the Hair •	
room and typically found in the Hair category, using an HR2 
extension.

 Strand-based hair created in the Hair room cannot be 
saved to the Library palette unless it is saved with underlying 
geometry such as a figure or skull cap.
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Adding Hair to a Figure

Conforming hair is added to your figure using the same method as 
conforming clothing, discussed in Adding Conforming Clothing on 
page 99.

To add either strand-based or prop-based hair to a figure:

Select the figure to which you wish to add hair.1.	

Select your desired hair using the 2.	 Library palette.

Click the 3.	 Apply Library Preset icon or drag the hair from 
the library to your scene. The hair is added to the figure.

If your figure already has prop-based hair, adding new 
hair replaces the old. You can either add or replace selected 
conforming hair, depending on whether you choose the 
single checkmark or double checkmark (which adds another 
conforming hair figure). 

Figure 7.19

While prop-based hair usually orients itself to the angle and 
rotation of the head, you may need to reposition the hair to 
precisely fit the figure’s head (especially if it was created for 
another figure as is the case in this example). To do this, use the 
Current Actor pull-down menu to select the hair, then use the 
hair’s Trans parameter dials as necessary in the Parameters 
palette. To translate conforming hair, you usually use the Translate 
dials in the Head actor of the head.
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Figure 7.20

The Hands Category
This Library palette category houses hand (*.hd2) files, which can 
be applied to your currently selected figure. Hand files are subsets 
of Pose files that only contain positioning information for the hand 
and its children (fingers). Hand poses contain both finger positions 
and wrist positions. 

 Not all figures hands are created using the same number 
of joints. Ryan and Alyson contain an additional joint at the 
knuckle and older hand poses may not work correctly on their 
hands. Additionally, Hand poses saved using Ryan or Alyson 
may not apply to older content correctly.

If you apply a pose file to a figure then apply a hand, only the hand 
positions will change. If, however, you apply a hand file to a figure 
followed by a pose, the pose application will override the positions 
specified by the hand file.

Figure 7.21

To add a hand pose to a figure:

Click the figure to which you want to apply the hand pose.1.	

Select the 2.	 Hands category in the Poser Library, and select the 
hand pose that you want to apply.

Click the 3.	 Apply Library Preset button at the bottom of the 
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Library palette, or drag the hand pose from the library to the 
character to which you want to apply the pose. A dialog asks 
if you want to apply the pose to the figure’s right hand or left 
hand. Click either button to apply the pose. 

The Props Category
This Library palette category houses props (*.pp2), which are 
loosely defined as static or poseable objects that are not figures. 
Items such as swords, balls, canes, furniture, walls, some types of 
clothing (such as dynamic) and other non-conforming items fall 
into this category. You will also find conforming clothing items in 
the Props library.

 For more information about Dynamic Clothing, see 
Chapter 25: The Cloth Room on page 386

Figure 7.22

Adding Props

To add a prop to your scene:

Open the scene to which you want to add the prop.1.	

If you want to replace a prop that is already in your scene with 2.	
another prop from the library, select the prop in your scene 
that you want to replace.
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Choose the 3.	 Props category from the Library palette.

From the 4.	 Library palette, select the prop you want to add to 
the scene.

Click the 5.	 Apply Library Preset (single checkmark) button.

By default the prop appears in the center of the scene in 6.	
its default position. You can use the Translate dials in the 
Parameters palette to reposition the prop to the correct spot in 
your workspace.

Figure 7.23

If you wish to have the prop move with another scene 
item (such as a tennis racket moving in concert with the 

figure’s hand), you need to specify a parent for the racket. 
Please refer to Changing a Parent on page 167 for directions 
on setting a parent for an object.

The Light Category
This Library palette category houses lights (*.lt2), which includes 
the number, color, position, and other lighting attributes. Please 
refer to Chapter 12: Lighting on page 186 for a description of Poser 
lights.
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Figure 7.24

The Camera Category
This Library palette category houses cameras (*.cm2), which 
includes all Poser cameras, their positions, and other attributes. 
Please refer to Chapter 11: Cameras on page 170 for information 
about Poser cameras.

Figure 7.25

The Materials Category
Poser’s Material library provides an easy way to apply preset 
materials to the items in your scene. You can navigate through the 
items in your library, and then drag and drop compatible materials 
from the Library to the objects in your scene. As you drag your 
material into the scene, a tooltip displays the name of the actor in 
your scene. Release the mouse when the tooltip displays the correct 
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actor name.

When saving materials to the library, Poser offers two methods for 
storing material definitions for an entire figure in a single file. Both 
of these methods can save considerable time, since they can apply 
colors and maps to an entire figure simply by loading them from the 
Library palette instead of having to add them one by one. 

This Library palette category houses materials (*.mt5), which 
include all Poser materials and any associated shader trees 
created or loaded into the Material room. Materials and material 
collections can be dragged from the Library and dropped onto an 
object in your scene.

The Material Collection (MC6/MCZ) file format was designed as a 
fully integrated replacement for MAT pose files. Additionally, Poser 
includes a built-in compatibility feature, which enables you to 
simply change the extension of your MAT files to MC6 or MCZ, and 
Poser will recognize them as Material Collections. However, Smith 
Micro Software does support the MAT files included in your Poser 
installation.

Figure 7.26

Adding Materials to the Library Palette

Poser offers the option of saving either single materials, or grouped 
material collections from a single figure, to the Library palette.

To save single material to the Library palette:

Open the Material Room.1.	

In the Library palette, select the desired Category/Subcategory 2.	
that will store the new material.
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Move the mouse into the Preview window, where it turns 3.	
into an Eyedropper tool. Use the eyedropper to “pick up” the 
material that you want to save. The material settings appear in 
the Simple or Advanced view in the Material room.

Click the 4.	 Save to Library icon (+) at the bottom of the 
Library palette.

In the 5.	 New Material Set dialog, select the Single Material 
radio button.

Enter a name for the Material and click 6.	 OK. A square showing 
the single material appears in the currently selected Material 
library category/subcategory.

Adding Material Collections to the Library 
Palette

Poser also allows you to save some or all of the materials for a 
single figure together in a Material Collection, in addition to saving 
single materials individually. Simply select the Material Collection 
option in the Add to Library dialog, as described below, and 
choose which materials you would like to include in the collection. 
Like MAT files, Material Collections provide the convenience of 
grouping materials in a single file, and also offer the added benefit 
of seamless integration into your Poser workflow. Please refer to 
Chapter 13: The Material Room on page 204 for information about 
the Material room.

To save Material Collection to the Library palette:

Open the Material Room and select your desired category/1.	
subcategory.

Move the mouse into the Preview window, where it turns into 2.	
an Eyedropper tool. Use the eyedropper to “pick up” one of 
the materials in the object that uses the material collection 
that you want to save. The single material that you clicked 
appears in Simple or Advanced view in the Material room.

Click the 3.	 Add to Library icon (+) at the bottom of the 
Library palette.

In the 4.	 New Material Set dialog, select the Material 
Collection radio button, and click the Select Materials 
button to open the Select Materials dialog. 

Choose which materials you would like to include in your 5.	
collection from the list presented in the Select Materials 
dialog, and click OK. Select All and Select None buttons 
are also provided to add or clear all materials in the selection 
set.

Enter a name for the Material Collection and click 6.	 OK. A small 
thumbnail of the object with your material settings appears in 
the currently selected Material library category/subcategory.
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Maintaining Your Library 
Palette
You can maintain your Library palette by adding and removing 
items to and from the Library palette, as described below.

Creating Subfolders
You can create new subfolders in the library to store your content. 
Follow these steps:

Use the 1.	 Show Library menu to select <All> libraries, or the 
library to which you want to add the folder.

Click the category icon that applies to the subfolder you want 2.	
to create. For example, if you are using the new folder to store 
a Prop, select the Prop category.

Highlight the folder beneath which you want the new folder 3.	
to appear.

Click the Add Folder icon located at the bottom of the Library 4.	
palette. You are prompted to enter a name for the new folder.

Enter a new folder name and choose OK. The folder appears in 5.	
the Library palette.

Figure 7.27

Adding Items to the Library
The following section provides some notes on saving content in 
general. 

Saving an item to the Library palette adds the appropriate item 
to the currently selected category/subfolder. The actual file location 
of your saved item will display along the bottom of the Library 
palette when you select the item by clicking on its preview image 
once it has been added to the Library. To add an item to the 
Library palette:
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Select your desired category/subcategory.1.	

Click the 2.	 Save to Library icon (+) at the bottom of the 
Library palette.

Figure 7.28

Complete the dialog that follows (see following subtopics for 3.	
information on category-specific dialogs).

Enter a name for the new 4.	 Library palette item and click 
OK. You may be prompted to select a subset of actors for 
inclusion in the saved item, depending on the item type 
being saved (poses, expressions, props, lights, cameras or 
material collections). Please refer to the following sub-topic for 
information on selecting actors.

Depending on the 5.	 Library palette category being saved to, 
you may be asked if you wish to save morph channels (such as 
facial expressions, muscle bulges, etc.). Saving morph channels 
will preserve all adjustments you might have made to any 
morph target parameters. You may also be asked whether you 

wish to save Body transformations; this option will preserve 
any modifications to parameters on the “Body” actor.

Figure 7.29

 This option appears when saving poses, but you 
need to take care when saving morph channels and body 
transformations with poses that you will distribute to others. If 
your pose is designed as a regular pose that reposes the figure 
(for example, from standing to sitting), in most cases you do 
not want to include body transformations or morphs that will 
affect the settings of the figure that is in another user’s scene. 
On the other hand, if your pose is meant to set morph targets 
for a custom figure, you want to include morph channels in 
the pose set.

Poses and Faces can save animated data (such as an animated 6.	
pose like swinging a golf club). To select only the current 
frame, select Single Frame. To save more than one frame of 
animation, select Multiple Frames and enter your desired 
starting and ending frame numbers. If you are adding an 
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animated pose that includes animation layers, the Select 
Layers button will be enabled. Clicking this button opens 
the Select Layers dialog, which allows you to specify which 
layer(s) you wish to save with the pose. Click OK when you 
have finished making your selections. 

Figure 7.30

Your new item will be added to the 7.	 Library palette and 
will be accessible whenever Poser is running. Poser also 
automatically generates an editable .png format preview 
image based on Camera position. You can make a better 
preview image by positioning the camera to focus on the item 
you’re saving.

To add dynamic cloth to the Library palette, add it as you 
would any other prop. For strand-based hair objects, you must 
either save a Poser scene file (PZ3) with your hair object in it or 

grow hair on a prop and save that prop to the Library palette.

Adding Actors to a Library Palette Entry

When you save Poses and Faces to the library, a Select Subset 
button appears in the New Set dialog, allowing you to specify 
which actors to include in the library file. This allows you to create 
poses that affect only a part of the figure (for example, a pose that 
only affects the arms and hands, rather than the entire body of a 
figure).

If you opt to select a subset of actors within your scene for saving 
to the Library palette, the Hierarchy Selection dialog appears, 
allowing you to specify the actors you wish to include in your new 
Library palette entry: 
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Figure 7.31

The list of actors appears hierarchically, just as it does in the 
Hierarchy Editor window (see The Hierarchy Editor on page 493). 
You can expand collapsed hierarchies by clicking the + sign next to 
a collapsed branch, and can collapse expanded branches by clicking 
the - sign next to an expanded branch.

To include an actor in your new Library palette entry, check the 
box to the left of your desired actor. Clearing an actor’s checkbox 
excludes it from the Library palette entry. Excluding an actor that is 
a parent of one or more actors excludes the children actors as well.

Adding Items to the Library Palette 
(Manual Method)
You can also add items to the Library palette by creating folders 
and subfolders in the Poser hierarchy and adding your items directly 
to those folders. Please refer to Appendix B: Poser File Structure on 
page 525﻿ for more information about the Poser file structure.

This is an advanced feature that should only be undertaken 
by advanced Poser users who are familiar with creating 
custom content. Manually adding Library items could result in 
misplacing files, which could cause these Library items to be 
invisible and/or unusable. Smith Micro Software cannot provide 
technical support for people who manually create content 
folders. If you purchased content and are unable to get it to 
appear in the Library or if it has other errors, please contact the 
content creator.

Adding Items to the Library Palette 
(Poser Download Manager)
Poser’s Download Manager can detect and install Poser content 
downloaded using the Content room. Please refer to Chapter 8: 
The Content Room on page 120 for more information about the 
Content room.
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Deleting Items from the Library 
Palette
To delete an item from the Library palette, select it by clicking 
its preview image, then click the Delete from Library icon (-) at 
the bottom of the palette (see below for an image of the Library 
icons).

Figure 7.32

Deletions are permanent! Be sure you really want to 
delete the selected item. If you have not saved your content 
elsewhere (such as archiving the source files), the deleted 
content will be permanently lost. You cannot undo content 
deletions.

Searching the Library
The new Search tab in the library allows you to perform a keyword 
search in all of your content libraries, or in selected categories. 

Figure 7.33

To perform a search, follow these steps:

Switch to the Search tab in the Library.1.	

Enter a keyword (such as Alyson) or a series of keywords (such 2.	
as Alyson shirt) in the Search For field.
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Check or uncheck options as follows:3.	

To perform a search throughout all Library categories, ��
check the All Categories option.

To perform a search in specific categories in your Library, ��
uncheck the All Categories option and then check or 
uncheck Figures, Pose, Face, Hair, Hands, Props, 
Light, Camera, or Materials as needed to find the 
content you are looking for.

Figure 7.34

Click the 4.	 Search button. Poser performs a search for the 
content that you specified, and search results appear in the 
Content pane.

To scroll forward or backward to view previous or later 5.	
searches, you can use the arrow keys to the right and left of 

the Search button.

Figure 7.35

 Poser stores all search strings in a file named 
SearchState.xml file, which is located in your Poser 
installation folder. Windows Vista users can find this file in 
the Users \ (username) \ AppData \ Roaming \ Poser 
\ 8.0 directory. These search terms are used in conjunction 
with the Prev Search and Next Search buttons shown in 
the previous figure. You can edit this file to remove unwanted 
keywords from the search results.

Favorites Tab
The Favorites tab allows you to quickly add your favorite content to 
library folders that you create yourself.

To add an item to the Favorites tab:

Highlight the library item that you want to add to favorites.1.	

Click the 2.	 Add to Favorites button at the bottom of the 
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Library palette. An Add to Favorites menu appears above the 
selected item.

From the menu, select an existing Favorites category, or choose 3.	
<<New Folder>> to create a new Favorites folder. When the 
New Library Name dialog appears, enter a name for your new 
folder and click OK. The new folder appears in the Favorites 
tab and your item appears within it.

Figure 7.36
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Chapter 8: The Content Room
Welcome to Content Paradise! Poser’s Content room accesses 
Content Paradise, which is your gateway to leading marketplaces 
that provide both free and for-sale Poser content. Need a Poser 
figure, prop, texture, or something else? Content Paradise has you 
covered. And, Poser’s Download Manager can auto-install most 
downloaded content and add it to the Library palette. No more 
manually placing files in folders! 

Clicking the Content room tab at the top of the Poser workspace 
opens the Content room.  

Figure 8.1

Aside from the Download Manager, the Content room accesses 
the online Content Paradise Web server. Poser for Windows 
seamlessly displays Web pages in the Poser workspace. Poser for 
Macintosh automatically opens a new browser window connected 
to Content Paradise. Content Paradise features and interface are 
subject to change. Because of this, the discussion in this reference 
manual is limited to discussing the Download Manager.

Content Paradise includes comprehensive online help, which is 
accessible from anywhere in the interface by clicking the Help 
links. Please be sure to read all of the applicable Terms of Service, 
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including the Privacy Policy. Smith Micro Software reserves the right 
to alter these policies at any time without prior notice.

Downloading and Installing 
Content
After you purchase your content and check out of the 
marketplace(s), you will be able to download it to your computer. 
A progress meter keeps you informed of your download’s status. 
Follow the onscreen instructions to begin the download. Once the 
data transfer is complete, you can begin the installation process. 
Macintosh users can simply unpack the downloaded files, and 
install them according to your needs. Windows users can use the 
auto-install option, as described below:

The Install Options dialog appears for each downloaded file once 
data transfer is complete, with the following options:

Install Path•	 : When you click Install, the content will install 
to the folder specified in the Install Path field. By default, the 
Poser Downloads Library folder is specified. To change the 
folder to which content is installed, enter your desired path 
in the Install Path field, or click the folder icon to browse to 
your desired location. Please see Chapter 2: Installing Poser 
on page 11 for information about Libraries and the Library 
palette.

Install•	 : Clicking the Install button installs the downloaded 
content to the path specified in the Install Path field. 

Cancel•	 : Clicking the Cancel button cancels the installation 
process. Downloaded content will remain uninstalled in the 
location to which it was originally downloaded.

If the file being installed already exists, a dialog pops up asking if 
you want to overwrite the existing file. Click No to abort, or Yes to 
proceed with overwriting the old file.

A confirmation dialog appears once installation is complete. Click 
OK to acknowledge successful installation of your downloaded 
content.

If Poser cannot recognize the content or cannot install content 
(such as an executable file), the Copy to Folder dialog appears, 
with the following options:

Copy Path•	 : When you click Copy, the downloaded content 
will be copied to the folder specified in the Copy Path field. 
To change the folder to which content is copied, enter your 
desired path in the Copy Path field, or click the folder icon to 
browse to your desired location.

Copy•	 : Clicking the Copy button copies downloaded content 
to the path specified in the Copy Path field. You will then 
need to manually install the content yourself.

Cancel•	 : Clicking the Cancel button cancels the copy process. 
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Downloaded content will remain uninstalled in the location to 
which it was originally downloaded.

In addition to the Content Paradise website, the Content room 
also contains two buttons: 

The •	 Reset Content Paradise button returns you to the 
Content Paradise homepage. 

The •	 Install From Zip Archive button opens the Install 
Options dialog, which is described above.
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Chapter 9: Posing Figures
This chapter explains how to pose figures and the tools you’ll use 
while doing so. Posing is the process of bending, twisting, and 
pulling a figure into new and fantastic positions. You can even 
create movies by changing poses over time.

General Posing Principles
A pose has two aspects: how the body parts move relative to the 
rest of the body (such as raising or lowering an arm, your shoulder, 
upper arm, forearm, hand, and fingers are moving relative to the 
rest of your body) and the figure’s position relative to the Poser 
workspace (such as walking around a room). Poser’s Editing tools 
(The Editing Tools on page 129) allow you to move body parts, 
figures, and props by simply clicking and dragging. It doesn’t get 
any easier!

When posing in Poser, you’re working in all three dimensions. Your 
only limitations are specific motion limits placed on joints to keep 
poses realistic. Enabling limits prevents, for example, a figure’s 
knees from bending backward or the head from twisting 360 
degrees. However, you can disable limits and put your figures into 
any position you can imagine.

Posing and Camera Views
Newer Poser figures (Version 3 and later) allow you to pose faces 
and hands (expressions, gestures, etc.). Poser includes Face and 
Hand Cameras (see Chapter 11: Cameras on page 170) that zoom 
into these areas for close-up work.

While posing, you can switch cameras to view your work from 
many different angles and can even select up to four simultaneous 
camera views in the Document window (see Chapter 5: The 
Document Window on page 61). It is recommended that you select 
the Posing camera while working, thus saving the Main and 
Auxiliary cameras for your final shots, particularly if rendering 
animations.

The Pose Library
You can add poses you create to the Pose Library, as described in 
Maintaining Your Library Palette on page 113, or you can apply still 
or animated poses from the library to your currently selected figure 
as described in The Poses Category on page 101﻿.

Translation
Translation moves multiple body parts by pulling them in a chain. 
To visualize this, imagine a person lying down with their arms out 
to their sides. If you were to take hold of the hand and lift it, at 
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first only the affected arm would move. Keep moving higher, you’d 
lift the shoulders, chest, hips, and eventually the whole person off 
the ground. Poser’s Editing tools work this way. Drag any part and 
connected parts follow. Parts move, bend, and twist as you would 
expect them to.

Figure 9.1

Inverse Kinematics (IK)
Poser’s Inverse Kinematics (IK) features help you achieve realistic 
poses and add natural-looking motion to your animations. IK effects 
are most apparent when using the Editing tools. 

To demonstrate how IK works, try this:

Create a scene and load the default character (in this case, Andy 
is still configured as the default). Make sure that IK is on (it is on 
by default). Use the Translate tool or the YTran parameter dial to 
translate the hip upward on the Y Axis so that the feet move up off 
the floor. Then move one of the feet to the side with the Translate 

tool. You’ll see an outline appear of where the foot once was. 
That is the IK goal. The foot will move into that position wherever 
possible. 

Figure 9.2

The purpose of IK is to make it easier to pose or animate the arms 
and legs of a figure. For example, when IK is on, you can translate 
the hip, and the legs bend to accommodate the new hip position 
without changing the positions of the feet. Arms behave similarly: 
Place a figure’s hands against an imaginary wall and move the hip 
forward. The arms bend while the hands remain fixed in position. 
For more information on IK, see Understanding IK on page 125.

Enabling IK on a pose created with IK disabled may alter 
your pose.
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Enabling/Disabling IK

Inverse Kinematics can add realism to your scenes. You can toggle 
Inverse kinematics (IK) on and off for the following limbs:

Left Leg•	

Right Leg•	

Left Arm•	

Right Arm•	

To toggle IK on or off for a limb, select Figure > Use Inverse 
Kinematics>limb, where limb is one of the four limbs. A 
checkbox next to a limb indicates that IK is active for that limb, and 
vice versa. 

Figure 9.3

Understanding IK

Kinematics is the study of motion velocity, rotation, and position. 
In terms of structures such as arms and legs, kinematics is used 
to calculate how actions taken at a structure’s root determine the 
position and rotation of the other end. For example, hold your arm 
straight and rotate your shoulder joint. Kinematics calculates the 
change in position of your arm, hand, and fingers. If you know the 
angle by which you rotated your shoulder, you can calculate your 
arm’s new position.

It follows that Inverse Kinematics studies the same problem from 
the other end: The extremity moves, and IK determines how the 
objects joined to it must respond in order to support the new 
placement. If you raise your hand straight out to the side, your 
hand, arm, and shoulder must move to accommodate your hand’s 
new position. Or if someone was to grab your hand and push, your 
arm would bend while your body remains still.

Poser supports IK for the arms and legs. With IK enabled, you can 
translate the hands and feet and achieve appropriate arm and 
leg positions automatically. IK creates targets to indicate the end 
of the chain. When the hands or feet move, the target is set to its 
new position. Moving any other body part keeps the target in its 
original position relative to the rest of the body. Once the target 
is reached, the end of the chain is fixed and the other parts must 
bend to accommodate the hand or foot position. For example, a 
foot reaches its target and the knee bends.
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To work effectively with IK, you need to keep the following things 
in mind:

Enable (turn on) IK when you are working with the •	 Editing 
tools.

The •	 Rotate, Translate, and Twist tools may not behave 
as you might expect for some body parts. For example, you 
cannot easily rotate or translate a thigh or shin when IK 
is enabled for that leg because the foot’s position takes 
precedence. This behavior corresponds to real life: When you 
stand, your feet and legs support your body, meaning that 
you cannot arbitrarily move or rotate them. This consideration 
applies to both the Editing tools and the parameter dials.

You cannot use IK and the •	 Chain Break tool (see Chain Break 
on page 132﻿) on the same limb.

Limiting Motion
Selecting Figure > Use Limits toggles parameter limits on and off. 
Please refer to Editing Parameter Dials on page 141 for information 
about setting limits for parameter dials. The figures included with 
your copy of Poser have realistic limits applied to them, meaning 
that you can’t, for example, bend a knee backward. Limits are 
disabled when this option is toggled off. 

Figure 9.4

The Use Limits option keeps body parts from moving beyond 
natural ranges of motion. The figures that come with Poser have 
realistic limits that were set when the figures were rigged. Third-
party content may or may not have realistic joint limits. If you have 
questions about a particular piece of content, please contact the 
content’s creator or the marketplace where you purchased the 
content. “Natural” is a subjective definition. The limits for Poser 
figures are a rough guideline that may or may not look right to 
you. You can customize maximum and minimum limits using the 
methods described in Editing Parameter Dials on page 141﻿.

Select Figure > Use Limits to toggle limits on and off. A 
checkmark next to this option indicates that limits are being 
enforced, and vice versa.
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Posing Body Parts
Like their real-world counterparts, Poser figures are made of body 
parts connected by joints. Posing a figure is as simple as moving 
body parts to create a new position or pose. Body parts are 
independent, and each considered an actor in its own right. This 
concept holds true no matter what the figure looks like (snake, 
2-legged, 8-legged, etc.). There are some special posing cases:

Hands (see •	 Posing Hands on page 147)

Faces (see •	 Posing Faces on page 145﻿)

Eyes (see •	 Posing Eyes on page 147)

Animals (see •	 Posing Animals on page 149﻿)

Posing a Figure
The easiest way to pose a figure is to use the Editing tools as 
described in The Editing Tools on page 129. The part will move 
based on the part selected, your currently selected Editing tool, 
your camera angle, and whether or not IK is enabled. You can also 
use the parameter dials on the Parameters palette to precisely 
move parts. Most poses are created using the Editing tools to 
get the rough position followed by the parameter dials for fine 
adjustments.

Selecting Body Parts
Before you begin posing figures, you need to know how to select 
the body part Actor(s) you wish to move in order to create your 
still or animated pose. You can select body parts using the Editing 
tools, the Current Actor pull-down menu, or by clicking the 
desired part in the Document window. Each of a figure’s body 
parts is a poseable element.

Figure 9.5

If you right-click (Windows) or Apple key-click (Mac) 
within the Document window, a pop-up context menu brings 
up a menu listing all the body parts positioned under your 
mouse cursor. You can select your desired body part directly 
from this list, without having to interrupt your workflow or 
change your camera view. This process also makes it easier to 
select a specific actor in areas where many objects overlap.
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Using the Editing Tools
To select a body part using the Editing tools, click your desired tool 
then click the body part you wish to pose. The currently selected 
body part is highlighted in the Document window and labeled in 
the Select Figure and Current Actor menus in the top left corner 
of the Document window.

Figure 9.6

Using the Parameters/Properties 
Palette
You can also select body parts using the selection menu that 
appears at the top left corner of the Parameters/Properties palette. 
Click the arrow at the top-left corner of the palette to display the 
menu. Here you can select any of the following:

Any body part for the currently selected figure.•	

The Body Actor of the currently selected figure.•	

Any props connected to the currently selected figure (such as •	
hair, jewelry, articles that are parented to it, and so on).

Any of the cameras in the scene.•	

Any of the lights in the scene. •	

Figure 9.7

Using the Current Actor Pull-down 
Menu
To select a body part Actor using the pull-down menus:
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Figure 9.8

Select the desired figure using the 1.	 Select Figure pull-down 
menu.

Select your desired body part using the 2.	 Current Actor Item 
pull-down menu.

This method can be preferable if your scene has several figures 
and/or detailed body parts (such as poseable fingers and toes).

The Editing Tools
The Editing tools appear as follows on your Poser workspace:  

Figure 9.9

The tools presented in the above image are available 
within the Pose Room. The availability of individual Editing 
tools will vary in different Poser rooms. Additional Editing tools 
available in different rooms will be discussed in the relevant 
chapters of this manual.

As described in Setting Up Your Workspace on page 32, you can 
locate the Editing tools wherever you like on your Poser screen 
and can display or hide the title. The tools will auto-wrap to fit the 
allotted width or height of the palette.  Tool tips are displayed at 
the top of the palette that reveal the name of the tool when you 
hover your mouse over it.

The Editing tools let you move body parts in many different ways. 
A tool’s effect can vary depending on whether or not Inverse 
Kinematics (IK) is enabled. Please refer to Inverse Kinematics (IK) 
on page 124 for information about IK. Editing tools can pose an 
individual body part or a complete figure.

 The Color, Grouping, View Magnifier, Morphing, 
and Direct Manipulation tools serve other purposes than 
posing and are discussed later in this chapter.

The Editing tools work  on an entire figure, or on a body part Actor 
on a figure. 

To pose a body part, select it and drag. •	
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To pose the entire figure, use one of the following methods:•	

Click and drag on the desired �� Editing tool and the entire 
figure will move according to the tool that has been 
selected.

Select your desired �� Editing tool, then select the Figure 
Ring surrounding your desired figure and drag. The 
Figure Ring is highlighted when selected, indicating that 
you are working on the entire figure at once.

To move an entire figure, you can:•	

Click and drag an �� Editing tool.

Select and drag the Figure Ring.��

Select �� Body using the Select Actor pull-down menu.

Select the figure’s hip and move it (with IK disabled).��

When using an Editing tool in the Document window, your cursor 
changes to a visual representation of the selected tool. This helps 
you keep track of how you’re moving the selected figure or element.

When using an Editing tool with a figure prop, you don’t need to 
click and drag with the cursor positioned over the affected item; 
you can click and drag anywhere in the Document window. Also, 
be aware that your camera view affects how your figure or element 
appears. Depending on the pose you are creating, you may want 
to switch to a different camera. For example, if you are moving 
an arm in front of a figure, a side view will give you a good view 

of the arm’s position relative to the figure’s front, and so on. You 
can change Camera views as described in Select Figure/Current 
Actor Menus on page 65﻿, and can even view your Poser scene from 
multiple cameras at once, as described in Changing Cameras within 
a Pane on page 69.

From left to right, the Editing tools are:

Rotate 

The Rotate tool bends a body part at its joint. Rotation works 
in three dimensions, allowing you to make a lot of progress very 
quickly. To rotate a body part, select the body part you wish to 
rotate and drag perpendicular to the part to cause the rotation 
to rotate up and down (relative to your point of view). Dragging 
parallel to the part rotates it in and out, again relative to your point 
of view.

To rotate the entire figure, select it. Dragging the mouse up/down 
and left/right functions as a trackball and rotates the figure on 
its own axes based on your camera location. You can also adjust 
an item’s rotation using the parameter dials, as discussed in 
Parameters Palette on page 138.
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Twist 

The Twist tool rotates a figure/part/prop along its longest 
axis (length). You can twist an entire figure by selecting it and 
dragging. Most of the body’s joints don’t allow much twisting. For 
example, your forearm can twist almost 180 degrees while your 
wrist can hardly twist at all. The twist axis of the head, neck, and 
torso is along the spine. For the forearm, the axis lies along the 
arm’s length. Twisting an entire figure rotates it about its own axis. 
If the figure is standing, it spins around. If lying down, it rolls over. 
You can also adjust an item’s twist using the parameter dials, as 
discussed in Parameters Palette on page 138.

Translate/Pull 

The Translate/Pull tool moves the selected figure/part/prop 
along the camera’s view (vertically... X and Y axes) depending 
how you drag. The translation may occur on the figure’s X, Y, and 
or Z axes depending on the position of the camera relative to the 
figure. You can translate body parts or figures, and can also adjust 
an item’s translation using the parameter dials, as discussed in 
Parameters Palette on page 138.

Translate In/Out

The Translate In/Out tool moves the selected figure/part/
prop along the Camera’s Z axis (in and out). This translation may 
take place along the figure’s X, Y, and/or Z axes. Dragging down 
pulls the item towards you, and vice versa. Moving an item towards 
you makes that items seem larger, and vice versa. You can also 
adjust an item’s translation using the parameter dials, as discussed 
in Parameters Palette on page 138﻿.

Scale 

The Scale tool allows you to scale the selected figure/part/
prop along the camera’s X and Y axes. The item’s affected axes 
will vary depending on the camera’s position relative to that item. 
Dragging in towards the element reduces the scale, and dragging 
away from the element increases the scale. To scale in two 
dimensions, drag laterally. Dragging vertically scales in the third 
dimension. The axes affected depend on your currently selected 
camera position. You can also press and hold Shift while using this 
tool to scale evenly in all three dimensions. Make a mistake? No 
problem. Select Edit > Undo, or press [COMMAND]/[CTRL]+[Z]. 
You can animate scale using the parameter dials as described in 
Parameters Palette on page 138.

To scale an entire figure, select the desired figure using the Select 
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Figure pull-down menu in the Document window or by clicking 
its Figure Ring. A figure’s size is relevant only in relation to 
other figures and props within your scene. To pose a single figure, 
scaling is not necessary: You can simply zoom the camera. If you 
are working with two or more figures and want to give one the 
appearance of being in the distance, it’s best to simply move the 
selected figure to the background using the Translate tool (see 
above). You can also adjust an item’s scale using the parameter 
dials, as discussed in Parameters Palette on page 138.

Taper 

The Taper tool allows you to taper the selected figure/part/
prop along the Camera’s X and Y axes. The item’s affected axes will 
vary depending on the Camera’s position relative to that item. This 
only affects the end of the selected actor that is most distant from 
the center of the body. Dragging to the right increases the amount 
of taper, and dragging to the left decreases the taper, “flaring” 
the selected actor. You can also adjust an item’s taper using the 
parameter dials, as discussed in Parameters Palette on page 138﻿.

Chain Break 

The Chain Break tool ends the chain of parts affected by the 
Translate tools.

Using chain breaks on different body parts can create interesting 
effects. For example, to prevent the chest from moving, apply a 
chain break to it. You can then translate the hand freely without 
moving the chest: only the hand, forearm, upper arm, and shoulder 
will move. You must have IK disabled on the desired limb(s) in order 
for this to work. Please refer to Inverse Kinematics (IK) on page 124 
for information about Inverse Kinematics.

To add a chain break, select the Chain Break tool and click where 
you want the chain broken. A Chain Break icon appears wherever 
you insert a break. You can insert as many breaks in your scene as 
needed. To remove a chain break, click the desired icon.
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Figure 9.10

All figures have chain breaks at their hips. You cannot 
remove these breaks.

Color 

The Color tool allows you to change a material group’s 
surface (diffuse) color. Please refer to Root Nodes on page 232 for 

information about setting colors and other material values.

Grouping 

The Grouping tool opens the Group Editor palette, which is 
discussed in The Group Editor on page 487﻿.

View Magnifier 

The View Magnifier tool allows you to zoom in and out to 
and from your desired areas of the Document window without 
altering the position of your currently selected camera. This can be 
of great help when working with scenes. 

To use the View Magnifier tool, select it:

Click anywhere in the •	 Document window or current view 
pane to zoom in on the selected area. Repeated clicking will 
continue zooming in one step per click.

To zoom in on a specific region in the •	 Document window, 
click and drag a rectangle around the area you wish to 
magnify. Your view will zoom in on the closest point that 
encompasses your selected region.

To zoom out, press •	 [COMMAND]/[CTRL] while clicking in the 
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Document window.

Morphing Tool 

The Morphing Tool opens the Morph Editor palette. The 
Morphing Tool has two operational modes: Combine and Create, 
which are accessed and controlled via the Morph Editor. The 
Combine mode allows you to sculpt any surface on your figure 
using morph targets. The Create mode allows you to manipulate 
the vertices on your model’s mesh to create new morph targets. 
See Chapter 28: Modifying Figures & Props on page 443 for more 
information about morph targets and the Morph Editor palette.

Direct Manipulation 

The Direct Manipulation tool allows you to directly adjust 
an element’s Translate, Scale, and Rotation parameters: You 
can also use this tool to adjust falloff zones when setting up joint 
parameters for a poseable figure.

To adjust an element, first select the Direct Manipulation tool, 
then select your desired element:

Clicking and dragging one of the shaded boxes above the selected 
element increase or decreases the element’s X, Y, or Z scale. This is 

the same as adjusting the xScale, yScale, and zScale parameters, 
respectively.

Figure 9.11

You can also click and drag the colored circles to rotate the selected 
element along its axes. Poser calculates the rotation by using object 
coordinates for optimum control. Dragging the red circle rotates 
about the element’s X axis. The green circle rotates about the 
element’s Y axis, and the blue circle rotates about the element’s Z 
axis. The cursor changes to indicate which transformation will occur. 
For example, move the cursor over the circles, the cursor changes to 
a rotation icon, and so forth. Elements rotate about their origins.

Clicking near the selected element’s origin translates the element as 
if you were using the Translate tool. Clicking away from the origin 
and axes/circles allows you to rotate the element as if you were 
using the Rotate tool.
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The Parameters/Properties 
Palette
Poser offers a combined Properties/Parameters palette that lets 
you quickly switch between a selected element’s properties and 
parameter dials.

For clarity, each tab on this combined palette is referred to as a 
separate palette, either the Properties palette or the Parameters 
palette, as appropriate. To switch between the two, click your 
desired tab. You can also access an object’s Properties palette by 
double-clicking the desired object. Once you do this, clicking the 
Parameters tab opens the same object’s Parameters palette. You 
can also access both palettes by selecting Window > Parameter 
Dials.

Properties
The Properties palette contains the properties available for the 
currently selected scene element. Properties for lights, cameras, 
props, etc. are listed in their respective sections. This section 
describes the properties available to figures and body parts.

Figure 9.12

Figure Properties
Figures have the following properties:

Name•	 : The Name field displays the figure or actor name. 
Enter a new name in this field if you desire.

•	 Visible: Checking the Visible checkbox makes the figure 
visible and vice versa. Invisible objects are not included in any 
render calculations, and do not appear in the rendered scene.

You can animate visibility by clicking the Animation 
Toggle (key icon) next to the Visible checkbox. When 
animation is enabled, the icon appears green. When disabled, 
it appears clear. Clicking the Animation Toggle opens a pop-
up menu that includes the Animated option. Selecting this 
option will place a Visible parameter dial on the Parameters 
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palette. You can then use the parameter dial to adjust the 
degree of Visibility for the selected scene element.

•	 Visible in Raytracing: Checking the Visible in 
Raytracing checkbox makes the figure visible in raytraced 
reflections, such as if the figure is in front of a mirror. Clearing 
this checkbox makes the figure not appear in reflections. This 
option is used when raytracing.

•	 Displacement Bounds: The Displacement Bounds 
property determines the figure’s displacement boundary. 
Please refer to Chapter 18: Using The FireFly Render Engine 
on page 285 for more information about displacement bounds.

Body Part Actor Properties
Body part Actors have the following properties:

Figure 9.13

•	 Internal Name: The Internal Name field displays the body 
part’s internal (hidden) name, which Poser uses to track that 
part. You cannot edit a body part’s internal name within Poser.

•	 Name: The Name field displays the body part’s name. Enter a 
new name in this field if you desire.

•	 Visible: Checking the Visible checkbox makes the body 
part visible and vice versa. Invisible objects are not included 
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in any render calculations, and do not appear in the rendered 
scene. See Figure Properties on page 135 for information on 
animating the Visible property.

•	 Visible in Raytracing: Checking the Visible in 
Raytracing checkbox makes the body part visible in raytraced 
reflections, such as if the figure is in front of a mirror. Clearing 
this checkbox makes the figure not appear in reflections. This 
option is used when raytracing.

•	 Bend: Checking the Bend checkbox enables bending for the 
selected body part and vice versa. Bends are discussed in Bend 
Body Parts on page 83. Remember that selecting Display > 
Bend Body Parts bends all body parts and this property only 
affects the currently selected body part.

•	 Casts Shadows: Checking the Casts Shadows checkbox 
forces the selected body part to cast a shadow, which will be 
visible in your scene. Clearing this box means the selected 
body part casts no shadow.

•	 Collision Detection: Checking the Collision Detection 
checkbox enables collision detection for the currently selected 
body part.

•	 Apply Collision Setting to Children: Clicking the 
Apply Collision Setting to Children button applies the 
currently selected body part’s collision detection setting to that 

part’s children parts (if any).

•	 Load Morph Target: Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing 
you to load a custom morph target for the selected body 
part (which is then editable using the Morphing Tool as 
described in Creating Morphs with the Morphing Tool on 
page 458). Please refer to Chapter 28: Modifying Figures & 
Props on page 443 for more information about loading morph 
targets.

•	 Displacement Bounds: The Displacement Bounds 
property determines the body part’s displacement boundary. 
Please refer to Chapter 18: Using The FireFly Render Engine on 
page 285 for more information about displacement bounds.

•	 Shading Rate: The Shading Rate allows you to specify 
the desired shading rate for the currently selected body part. 
Please refer to Chapter 18: Using The FireFly Render Engine on 
page 285﻿ for more information about shading rates.

•	 Smooth Polygons: Checking the Smooth Polygons 
checkbox causes Poser to smooth the body part’s polygons at 
render time to eliminate or reduce a “faceted” appearance 
caused by flat polygons. This option can cause sharp corners 
to appear round. If the affected body part has sharp edges 
that you wish to preserve while applying polygon smoothing 
to other angles, you should specify those sharp edges using 
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smoothing groups or the crease angle threshold, as polygon 
smoothing will not override these settings. See Smoothing 
Geometry on page 299 for more information on specifying 
hard versus smooth edges.

•	 Crease Angle: The Crease Angle setting establishes a 
threshold up to which creases between adjoining polygons will 
be smoothed. Polygons with crease angles over this threshold 
will not be smoothed, and will be rendered as hard edges. See 
Smoothing Geometry on page 299 for more information about 
using the Crease Angle setting to apply smooth shading.

Parameters Palette
The Parameters palette contains all of the parameters for the 
currently selected scene element:  

Figure 9.14

The following topics discuss the Parameters palette in detail: 

(1) Current Actor Menu•	

(2) Parameters Palette Options Menu•	

(3) Parameter Dial Groups•	

(4) Parameter Dials•	

(5) Parameter Dial Menu•	
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(6) Master Parameter Indicator•	

(7) Dependent Parameter, showing Natural and Driven •	
parameter values

Current Actor Menu
The Parameters palette’s Current Actor pull-down menu (1) 
functions the same as the Current Actor pull-down at the bottom 
left of the Document window. Please refer to Select Figure/
Current Actor Menus on page 65 for more information about the 
Current Actor menu.

Parameters Palette Options Menu
The Parameters palette options menu (2) contains the following 
options:

Figure 9.15

•	 Create New Master Parameter: Creates a new 
parameter dial that can be set up to drive one or more 
dependent parameter dials. For further information on 
dependent parameters, see Using Dependent Parameters on 
page 471.

•	 Create New Group: Selecting Create New Group 
creates a new subgroup under the currently selected group. 
The Create New Group dialog appears prompting you for 
a name. Enter your desired name in the field. To rename an 
existing group (or if you make a mistake when creating the 
group), double-clicking the group name in the Parameters 
palette opens a field allowing you to specify a new name.

•	 Delete Selected Groups: Selecting Delete Selected 
Group deletes the currently selected group. Parameter dials 
in deleted groups are moved to the next highest group or 
subgroup, as appropriate.

•	 Display as ordered list: The Display as ordered list 
option toggles displaying parameter dials in groups or in an 
ungrouped list. A check mark means groups and subgroups 
are not displayed, and vice versa.

•	 Memorize: Selecting Memorize memorizes the current 
parameter dial settings as default. Please refer to “Memorize” 
on page ﻿ for more information on memorizing parameter dials.
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•	 Restore: Selecting Restore restores the most recently 
memorized defaults. Please refer to Restore on page 59 for 
more information about restoring saved defaults.

•	 Delete Object: Selecting Delete Object deletes the 
current object.

Parameter Dial Groups
Poser offers parameter dial grouping (3), which organizes 
parameters into easy to navigate categories.

Different figures may have different parameter dial groups.

Parameter dial groups have the following functionality:

Clicking the •	 + sign next to a collapsed group/subgroup 
expands that group/subgroup.

Clicking the •	 – sign next to an expanded group/subgroup 
collapses that group/subgroup.

Double-clicking a group name allows you to rename that •	
group.

You can drag and drop groups to change their hierarchical •	
relationship to each other. For example, a group could become 

a subgroup under another group, and vice versa.

You can drag and drop parameter dials to different locations •	
within the same group or across groups and subgroups to 
organize them as you see fit.

Parameter dial groups and subgroups are saved in your 
Poser scene files.

Parameter Dials
The parameter dials (4) in the Parameters palette let you pose a 
figure and adjust other attributes for figures, props, lights, camera, 
etc. using precise numerical increments. Each body part and most 
other elements in the scene have their own set of parameter dials. 
When an entire figure is selected, the displayed parameters affect 
the entire figure. To use a parameter dial, you can either click and 
drag it to the right to increase the selected value or left to decrease 
it. You can also click the displayed numeric value and manually 
enter your desired value using the text box that appears.

To restore a parameter dial’s default (or last memorized) setting, 
press and hold [OPT]/[ALT] while clicking the desired parameter 
dial. To change a parameter dial’s default value, set the dial to your 
desired value and either select Edit > Memorize>element, as 
described in Memorize on page 60, or use the Parameter Palette 
menu as described in “Parameters Palette Options Menu” on page ﻿.
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Each parameter dial has its own Parameter Dial menu (5), which 
is accessible by clicking the arrow to the right of your desired 
parameter dial. The Parameter Dial menu has the following 
options:

•	 Reset: Selecting Reset resets the parameter dial to its 
default or last-memorized value.

•	 Settings: Selecting Settings opens the Edit Parameter 
Dial dialog, described in the following topic.

•	 Graph: Selecting Graph opens the Graph palette for the 
selected element. Please refer to Using Graphs on page 322 
﻿for more information about the Graph palette.

•	 Recalculate Dynamics: If you have a dynamic object 
selected (strand-based hair or dynamic cloth), selecting the 
Recalculate Dynamics option recalculates the dynamics for 
that object. Please refer to Step Four: Setting Hair Dynamics 
on page 380 and to Step 4: Cloth Dynamics Controls on 
page 398 for information about strand-based hair and cloth 
dynamics, respectively.

•	 Split Morph: When enabled, selecting Split Morph splits 
the currently selected morph into left and right sides, allowing 
you to apply the selected morph target asymmetrically. You 
can use this, for example, to introduce irregularities into a 
figure’s head, enhancing realism because no person’s head is 

perfectly symmetrical.

Master Parameter Indicator
The Master Parameter indicator appears when the designated 
parameter dial is used to drive settings of other parameter dials. 
Click the Parameter Dial menu arrow to open the Dependent 
Parameter editing tool and the list of parameters controlled by that 
dial. For more information about master parameters, see Using 
Dependent Parameters on page 471.

Dependent Parameter Dials
When a parameter is configured as a dependent parameter, two 
values will be displayed to the right of the parameter dial. These 
dials are referred to as the natural and driven parameters, and are 
explained in detail in Using Dependent Parameters on page 471. 

Editing Parameter Dials
You can edit parameter dials by double-clicking your selected 
parameter dial to open an Edit Parameter Dial dialog, which 
allows you to set the following limits: 
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Figure 9.16

•	 Value: The Value number sets the current parameter dial 
value.

•	 Min/Max Limit: The Min Limit and Max Limit values 
define the minimum and maximum limits for the parameter, 
respectively. The numbers can stand for different types of 
values depending on the parameter you are editing. If it is a 
joint parameter, the value will be expressed in degrees above 
or below 0 (neutral). If you are adjusting a scale parameter, the 
number will be a percentage with 100 being normal size.

•	 Name: You can rename the parameter by entering a new 
name in the Name field.

•	 Sensitivity: The Sensitivity value modifies the parameter 
dial’s sensitivity to clicking and dragging. A lower number 
decreases the sensitivity and vice versa.

•	 Graph: Clicking the Graph button opens the Graph palette 
for the selected element. Please refer to Using Graphs on page 
322 for more information about the Graph palette.

Click OK when you have finished making changes.

Universal/Figure Parameters
This topic discusses both universal parameter dials and those used 
for figures. Parameters for cameras, lights, and other elements are 
discussed in their respective sections.

Scale Parameters
Scale parameters are found in the Transform group of the 
Parameters palette. Their functions are as follows:
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Figure 9.17

•	 Taper: The Taper parameter dial tapers the selected body 
part/prop. This function is the same as using the Taper tool, 
described in Taper on page 132﻿.

•	 Scale: The Scale parameter dial enlarges or shrinks the 
selected body part/prop in all three axes equally. This is the 
same as using the Scale tool, described in Scale on page 131﻿. 
Normal scale is 100%.

•	 XYZScale: The xScale, yScale, and zScale parameter 
dials enlarge or shrink the selected body part/prop along 
the selected axis only. This allows you to squeeze or stretch 
items. This is the same as using the Scale tool. Normal scale 

is 100%.

Posing Parameters
Posing parameters appear in the Transform group of the Parameters 
palette, and appear in yellow text. The following parameters are 
available for posing: Note that the options you see for each joint 
vary, depending on the rotation order of the joint: Each joint will 
have three options, one each for X, Y, and Z rotation.

•	 Twist: The Twist parameter dial rotates a body part along its 
own axis. For example, using twist on the head and neck turns 
the head. This is the same as using the Twist tool, described in 
Twist on page 131.

•	 Bend: The Bend parameter dial rotates a body part on its 
major axis. Most body parts bend forward and back, except for 
the shoulder and hands, which bend up and down.

•	 Side-to-Side: The Side-to-Side parameter dial rotates a 
body part perpendicular to its major axis. The thigh has lots of 
side-to-side motion, while the knee has very little. 

•	 Turn: The Turn parameter dial only appears for the feet 
in some characters, instead of the Twist parameter. This 
parameter turns the feet inward or outward.

•	 Front-Back: The Front-Back parameter dial is used 
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with shoulders and collars to rotate them forward or back, 
perpendicular to their major axis.

Body Parameter Dials
The following parameter dials are available for entire figures. 
Remember to select the correct figure when working with multiple 
figures in a scene:

Figure 9.18
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•	 XYZRotate: The xRotate, yRotate, and zRotate 
parameter dials rotate a figure around the X, Y, or Z axis as 
appropriate.

•	 XYZTran: the xTran, yTran, and zTran parameter dials 
move a figure along the indicated axis.

The XYZTran and other positioning dials reflect the 
currently selected unit of measure, which is available in the 
General Preferences dialog. For example, if a dial is set to 
12 inches and you change units to feet, the dial will now read 
1 foot.

Posing Faces
Poser’s human figures and many third-party figures have fully 
articulated faces, meaning you can position facial muscles such 
as mouth, eyebrows, cheeks, and eyes to create different facial 
expressions using the Parameter dials and/or the Morphing Tool 
(described in Creating Morphs with the Morphing Tool on page 
458﻿).

 Facial expressions work for Alyson and Ryan and their lo-
res versions, even though the warning dialog will appear when 
applying face expressions to the lo-res figures.

Figure 9.19

Different Poser and third-party figures will have different 
body morphs. Smith Micro Software cannot provide support 
for third-party figures. Please contact the vendor where you 
obtained your third-party content for technical support.

Some older Poser figures do not have poseable faces. 

When you select a head, a series of face-specific parameter dials 
appears in the Parameters palette, each dial controlling a different 
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aspect of the face. When using face parameter dials, think of it as 
manipulating facial muscles to achieve the final results.

The Face camera uses the selected figure’s face as its center of 
rotation, allowing you to preview your face poses up close.

Face Parameters
Face parameters normally operate in the range of 0 to 1, with 0 
being fully off and 1 being fully on. Negative values (<0) produce 
inverted poses, and poses greater than +/- 1 give exaggerated 
poses. For example, a negative Frown parameter setting produces 
a slight smile. Face parameters are morph targets that can be 
used in concert to create expressions. Please refer to Chapter 28: 
Modifying Figures & Props on page 443 for information on morph 
targets and how they work inside Poser.

Poser figures contain an array of facial morphs and parameters that 
allow you to create an endless variety of faces and expressions. The 
list of face parameters varies by figure, and the all parameters are 
self-explanatory. To view the available face parameters, select the 
desired figure’s head and open the Parameters palette.

In addition to posing faces, you can also modify facial structure as 
well as Ethnicity, Age and Gender parameters via the Face Shaping 
tool in the Face room. See The Face Shaping Tool on page 366 for 
more information on the Face Shaping tool.

 Alyson and Ryan figures include two levels of facial 
Ethnicity morphs. You will find face shaping morphs in the 
Parameters palette, and Ethnicity, Age and Gender controls in 
the Face room 

Faces & Phonemes
A phoneme is a linguistic term for the positions of the tongue, 
lips, and teeth as they make sounds. Producing certain sounds 
requires the mouth and tongue to be in certain positions. Stringing 
phonemes together is what produces speech.

Poser allows you to create the appearance of phonemes (called 
visemes when observed) to accurately simulate speech, a useful 
feature when adding sound to your scenes (such as a speech). You 
simulate speech by using different phonemes and keyframes to sync 
your figure’s mouth movements to an imported sound (see Sound 
on page 343). Poser’s Talk Designer can automatically generate 
a lipsync animation for you based upon settings that you configure 
in the Talk Designer palette. For more information about the Talk 
Designer, see Using the Talk Designer on page 344﻿.



Poser 8
Reference Manual

147

Chapter 9: Posing Figures

Figure 9.20

Posing Eyes
To pose eyes, select them using either the Editing tools or the 
Current Actor pop-up menu and position them by clicking and 
dragging, or by using the parameter dials.

Alyson and Ryan also have additional morph dials for the eyes, 
which can vary the shape of the iris and pupil, or which move the 
eyes up, down, right, or left.

Figure 9.21

Posing Hands
Many Poser figures have fully articulated hands. When you move 
a finger, the appropriate knuckle(s) bend. You can pose hands for 
both these figures and older Poser figures without articulated hand 
joints by applying hand poses from the Library palette.

The Left Hand and Right Hand cameras use the hand as their 
centers of rotation, making it easier to create precise hand poses.

Use the Editing tools to pose hands as you would any other body 
part. Please refer to The Editing Tools on page 129 for information 
on using the Editing tools. You can also apply preset hand poses to 
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any Poser figure using the Hands category in the Library palette, 
just as you would any other pose.

When you select the main portion of a hand (labeled Left Hand 
and Right Hand in the Item Select menu) on some Poser figures, 
you may also see a special set of hand parameter dials in the 
Parameters palette. These dials are as follows:

•	 Grasp: The Grasp parameter dial controls how tightly the 
hand/fist is clenched.

•	 Thumb: The Thumb parameter dial moves the thumb. 
Higher values move the thumb in towards the hand, and vice 
versa.

•	 Spread: The Spread parameter dial controls the amount 
of hand spread. Higher values spread the hand out, and vice 
versa.

In addition, Alyson and Ryan include several additional controls 
that provide extremely fine control over hand poses. These 
additional options, coupled with the extra joints in their hands, 
provide fine enough control to pose your hands holding chopsticks 
or other eating utensils: These additional dials are found in the 
Hand Controls section in the Parameters palette when you choose 
the hand actor for the Alyson or Ryan:

•	 ThumbBend: Bends all sections of the thumb at the same 
time.

•	 IndexBend: Bends all sections of the index finger at the 
same time.

•	 MiddleBend: Bends all sections of the middle finger at the 
same time.

•	 RingBend: Bends all sections of the ring finger at the same 
time.

•	 PinkyBend: Bends all sections of the pinky at the same 
time.

 Alyson and Ryan also include advanced controls in the 
feet, that bend the toes in a more realistic manner.  Select 
the Right Toe or Left Toe actor, and expand the Toe Controls 
section in the Parameters Palette to find four dials: 
BigToeCurl, BigToeSpread, ToesCurl, and ToesSpread.

Using the Hand Model
The Additional Figures subfolder in the Poser 8 Figures category 
includes disembodied hands that use the new joints found Alyson 
and Ryan. These hands include extra joints that allow you to create 
hand poses that bend in a more realistic manner. Use the Left 
Hand or Right Hand in this subfolder to create hand poses that 
are compatible with Alyson and Ryan. Then save the poses to the 
Hand library for future use.
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Using Preset Hands
When you’re done posing a hand, you can save it to the Hands 
category in the Library. Hand poses are a subset of a figure pose, 
meaning that figure poses include the hands but hands don’t 
include figures.

Figure 9.22

The Hands library folder includes various subcategories. 
When selecting preset hand poses for your figure(s), pay 
attention to the subcategory from which you choose them, as 
You can only apply specific hands to the corresponding figures. 
For example, you can only apply Poser 2 Fig. Hands to Poser 
2 figures. 

To use a preset hand pose:

Click a figure to select it.1.	

Open the 2.	 Library palette, then open the Hands category and 
your desired subcategory.

Double-click the pose you want to use. A dialog appears 3.	
asking if you wish to apply the preset to the left or right hand. 
Make your selection and click OK.

Posing Animals
You can pose animals using the same techniques used to pose 
humans. Animals have their own set of IK settings, bend zones, 
and limits. On the Horse model, for example, moving the hip down 
toward the ground does not make the animal sit, unlike a human 
figure. Editing tools, parameter dials, menus, etc. all work the same 
with animals as they do with humans. Technically speaking, animals 
and human figures are identical, and Poser makes no distinction 
between them.

 Animals do not work with the Walk Designer, which is 
primarily designed for humanoid figures. However, animals can 
work with the Talk Designer if the animal includes morphs that 
support it.
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Figure 9.23

The stock animal figures shipping with Poser use the same 
limb names as humans, that is, front legs and paws are labeled 
Shoulder, Arm, Hand, etc. This means that animal figures will 
not work in the Walk Designer, which was created for use with 
two-legged figures. To animate an animal walking or running, 
you need to keyframe its strides manually.

Posing Animal Heads
Several animal models have fully articulated heads. For example, 
you can pose the dog’s mouth and ears. Use the parameter dials 
just as you would for a human figure. The available parameter dials 
for a given animal’s head will vary depending on the animal.

Pose Dots
You can save up to nine pose configurations using the Memory 
dots (described in Memory Dots on page 43﻿). Each Memory dot 
retains all of your selected figure’s pose. This feature is specific to 
your current scene, meaning that Pose dots cannot be transferred 
to different scenes. To save pose settings and have them accessible 
in any Poser scene, you need to add pose sets to the Library 
palette.

Figure 9.24

Saving Poses in the Library
All parameters are saved along with body part positions when you 
save a pose to the Library palette. To save a pose to the Library 
palette:

Open the 1.	 Library palette.

Select the 2.	 Pose category and your desired subcategory.
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Follow the directions in 3.	 “Adding Items to the Library on page 
113﻿.

Other Posing and Figure Aids
The Object menu allows you to manipulate objects within your 
scene.

Lock Actor
Selecting Object > Lock Actor locks the currently selected 
element (body part, prop, etc.). To lock your desired actor, select it, 
then select Object > Lock Actor. The currently selected actor will 
be locked, meaning that it will not move relative to its parent. For 
example, if the elbow is bent 45 degrees relative to the upper arm, 
it will hold that position. Locking actors is a great way to protect 
your work once you’ve perfected a portion of your figure.

To unlock a locked actor, select it and Object > Lock Actor. A 
checkbox appears next to this menu item when the selected actor is 
locked, and reselecting this option clears the checkbox and unlocks 
the actor.

Point At
You can aim body parts, cameras, props, lights, etc. at other scene 
elements using the Point At command. This works in numerous 
situations, such as having a figure’s eyes track a moving object, 
keeping a camera focused on the action, etc. This is different than 
parenting in that no hierarchical relationship is created. One object 
simply points at another. By contrast, parented objects retain their 
exact position and orientation relative to their parent actors. 

To point an actor at another actor:

Select the element you want to aim using the 1.	 Select Item 
pop-up menu.

Select 2.	 Object > Point At to open a dialog box listing the 
actors in the scene.
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Figure 9.25

Select the object to aim at and click OK. The selected element 
points at the object and a Point At parameter dial appears in that 
element’s Parameters palette. Selecting 1 points the element 
directly at its selected target, and 0 points the element away from 
the target.

When selecting only a single item from the Object Parent 
hierarchy window, you can simply double-click on that item to 
make your selection and close the window.

To disable pointing for an element:

Select the element.1.	

Select 2.	 Object > Point At.

Select 3.	 None in the dialog that appears and click OK.

Figure Height
Poser provides several figure heights, which you can adjust by 
selecting Figure > Figure Height and selecting one of the eight 
heights available. 

Note that these settings may not work with al figures. You will get 
the best results when using these options with legacy figures, such 
as figures made for Poser 4 and earlier versions.  Figure heights are 
intended for figures that have very basic construction.

Figure heights are measured in “heads”, meaning the ratio of the 
head height to the overall body height: 

Baby•	 : 4 heads (each head is approximately 6 inches tall)

Toddler•	 : 5 heads (each head is approximately 6.5 inches 
tall)

Child•	 : 6 heads (each head is approximately 7 inches tall)

Juvenile•	 : 7 heads (each head is approximately 7.5 inches 
tall)

Adolescent•	 : 7.5 heads (each head is approximately 9 



Poser 8
Reference Manual

153

Chapter 9: Posing Figures

inches tall)

Ideal Adult•	 : 8 heads (each head is approximately 9 inches 
tall)

Fashion Model•	 : 8.5 heads (each head is approximately 9 
inches tall)

Heroic Model•	 : 9 heads (each head is approximately 9 
inches tall)

You can create interesting effects by applying different height •	
settings to different figures.

Genitalia
Some male and female nude models are anatomically correct. 
Selecting Figure > Genitalia toggles displaying genitals on or off.

The Poser 8 Figures library includes a Poser 8 > Ryan > Genitals 
subfolder that contains props for all four male figures (Diego, 
Marcus, Ryan, and Tomo). There are versions for the LowRes 
versions of these figures as well. Add the proper library item to the 
male figure in your scene, and then choose Figure > Conform 
To conform to the male figure. Basic, Advanced, Shiny, and 
Ultimate material collection files are found in the Poser 8 > 
Ryan > (figurename) > Genitals subfolders in the Materials 
category.

 Many female figures do not have modeled genitalia, 
relying instead on texture/bump/transparency maps to create 
the appearance of genitalia. This option only works for figures 
that have modeled genitalia that is set up to take advantage of 
this feature. To remove genitals on a female character that does 
not have modeled genitalia, you will need to modify the texture 
map. The Judy and Jessi models contain modeled genitalia, 
which are controllable via this function.

Different figures use different mechanisms for dealing 
with genitalia, so not all figures will be affected by the Figure 
> Genitalia menu option. Some newer figures, such as the 
G2 male figures and Ryan, contain genitalia that is set up as a 
separate conforming figure.

Auto Balance
The Auto Balance feature is a valuable tool for helping 
create realistic poses. When enabled, Poser calculates a figure’s 
mathematical “weight” and maintains it. In the following example, 
there is more weight in the figure’s hip or center portion than in the 
torso. As you pose a figure, Auto Balance adjusts body parts to 
maintain the original weight distribution, resulting in more natural-
looking poses without having to use several position adjustments. 
To further affect the weight distribution and compensation 
calculations, you can reposition the Center of Mass Control 
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Object (red outlined ball) at the base of the figure. This control 
object is adjustable along the X and Z axes in the ground plane. 
Moving the Center of Mass Control Object also adjusts the 
Center of Mass Indicator, which appears as a shaded sphere 
in the XZ (ground) plane under the figure. This Indicator shows 
the position above which the current center of mass is located., 
as calculated from the body part weights and the position of the 
Control Object.

Figure 9.26

When using Auto Balance, use small subtle motions to achieve 
the best results. Large motions may create drastic results. If this 
occurs, restore the figure as described in Restore on page 59. 
You may also want to select Figure > Use Limits while working 
with the Auto Balance feature, to help maintain realistic body 
positioning.

Selecting Figure > Auto Balance toggles Auto Balance on and 
off for the selected figure. When enabled, the Center of Mass 
controls will be visible at the figure’s base. A check mark appears 
next to this option in the menu when it’s enabled. Reselecting this 
option clears the check mark and disables Auto Balance for the 
selected figure.

Lock Figure
Selecting Figure > Lock Figure locks the figure in its current 
position. You cannot pose or move a locked figure. This is a great 
way of protecting your work in complex scenes where you have 
finished posing a figure and don’t want it to move accidentally. A 
check mark appears next to this option when the currently selected 
figure is locked. Reselecting this option removes the check mark 
and unlocks the figure.

Lock Hand Parts
Selecting Figure > Lock Hand Parts locks the selected hand in 
position, protecting it against accidental position changes while 
you pose the rest of your figure. To use this option:

Select the hand to lock.1.	

Select 2.	 Figure > Lock Hand Parts. The hand is now locked. 
This command is not available for all Poser figures.
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Please refer to Posing Hands on page 147 for information on 
posing hands.

Drop to Floor
You can place a figure in any position, such as in the middle of a 
flying leap. You can leave your figure in the air, or you can lower it 
to the ground depending on your needs. Selecting Figure > Drop 
to Floor brings the lowest part of the selected figure or prop 
into contact with the workspace floor. To display the floor, refer to 
Ground Plane on page 85.

Symmetry
The Symmetry command allows you to copy pose characteristics 
from one side of the body to another, which can save you time 
when creating scenes in the Pose room or when building custom 
figures using the Setup room. Pose an arm and/or leg, and use this 
command to instantly apply the same position to the other side. 
You can also swap entire poses from side to side and straighten the 
currently selected figure’s torso:

Figure 9.27. Start pose (left); Right to Left (center); Swap Right and Left (right)

Selecting Figure > Symmetry opens the Symmetry menu, which 
contains the following options for your currently selected figure:

Left to Right•	 : Selecting Left to Right applies the position 
of the bones on the left side of the figure to the right side.

Right to Left•	 : Selecting Right to Left applies the position 
of the bones on the right side of the figure to the left side.

Swap Right and Left•	 : Selecting Swap Right and Left 
swaps the positions of the bones on the right and left sides of 
the figure.

Left Arm to Right Arm•	 : Selecting Left Arm to Right 
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Arm positions the right arm bones in the same position as 
the left arm.

Right Arm to Left Arm•	 : Selecting Right Arm to Left 
Arm positions the left arm bones in the same position as the 
right arm.

Swap Right and Left Arms•	 : Selecting Swap Right 
and Left Arms swaps the positions of the bones on the right 
and left arms of the figure.

Left Leg to Right Leg•	 : Selecting Left Leg to Right Leg 
positions the right leg bones in the same position as the left 
leg.

Right Leg to Left Leg•	 : Selecting Right Leg to Left Leg 
positions the left leg bones in the same position as the right 
leg.

Swap Right and Left Legs•	 : Selecting Swap Right and 
Left Legs swaps the positions of the bones on the right and 
left legs of the figure.

Straighten Torso•	 : Selecting Straighten Torso straightens 
the torso area (Hip, Abdomen, Chest).

When you select a Symmetry function, a dialog box appears asking 
if you wish to copy the joint zone setup as well. Click Yes to apply 
the symmetry to the bone structure, or No to avoid copying the 

joint setup.

 Symmetry also copies element settings (morph targets, 
deformers, parameters, etc.) from one side to the other. For 
example, if you scale the Left Hand to 200% and apply Left to 
Right symmetry, the other hand will scale as well. Do not use 
this command if you want to use asymmetrical settings.

Delete Figure
Selecting Figure > Delete Figure deletes the currently selected 
figure. A confirmation dialog appears. Click OK to proceed with 
the deletion or Cancel to abort. Windows users can also delete a 
figure by selecting it and pressing [DEL].

Hide Figure
Selecting Figure > Hide Figure hides the currently selected figure 
if you have more than one figure in your scene. This is helpful when 
you work with complex scenes, especially where a figure is getting 
in your way. You can also hide a figure by selecting the figure to 
hide by selecting Body using the Select Element pull-down 
menu and clearing the Visible checkbox in the Properties palette 
as described in Properties on page 135﻿.
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 Collision detection settings do not apply to hidden 
objects.

Show All Figures
Selecting Figure > Show All Figures makes all hidden figures 
in your scene visible. You can also make hidden figures visible 
by selecting them and checking the Visible checkbox in the 
Properties palette. If one or more body parts are set to invisible, 
these will remain invisible when the selected figure is shown.
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Chapter 10: Working with 
Props
Poser lets you add props to your scene. Props are three-dimensional 
objects that your figures can interact with or that simply add 
interest to your scene. Props can be accessories to add to your 
figure’s character such as a wig, a moustache, a pair of sunglasses, 
a cigar, or a briefcase. Or, your figure could base its pose on a 
prop, such as leaning on a cane, climbing a ladder, or tossing a 
ball. This chapter covers hair, conforming (figure-based) clothing, 
and miscellaneous props not fitting into these categories. Poser 
treats conforming clothing items like figures, however we will 
treat conforming clothing as props in this chapter for the sake of 
discussion.

About Props
You can manipulate props just as you would any other element, 
which is why you see the term body part/prop used throughout 
this manual. You can change a prop’s color, shape, deformation, 
material, and maps (if it has UV coordinates – refer to the Poser 
Tutorial Manual, About Maps & Templates on page 22 for more 
information). Props can even cast shadows.

Poser’s replaceable geometry feature (see Replacing a Body Part 

with a Prop on page 165﻿) lets you replace body parts with props, 
making the prop actually part of the figure. You can also parent 
a prop to a body part or another prop or scene element, such as 
a briefcase in a hand. Please refer to the Poser Tutorial Manual, 
Hierarchy on page 14 for information about hierarchies in general, 
and to The Hierarchy Editor on page 493 for information on 
creating hierarchies within Poser. Props also add general interest 
and meaning to your scenes, such as a mushroom for a frog to 
perch on.

Figure 10.1

You can select props from the Props category in the Library 
palette, the Content room, or import props in a variety of popular 
3D formats. You can also create your own props in your favorite 3D 
modeling application (provided that application exports to one or 
more formats supported by Poser’s Import function).
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Props function like other scene elements, meaning you can use the 
Editing tools and parameter dials and can specify properties in the 
Properties palette. You can also create groups using the Group 
Editor palette (see The Group Editor on page 487).

Hair
Poser’s Hair room (see Chapter 24: The Hair Room on page 372﻿) 
allows you to create real strand-based hair, or to use prop-based 
hair, when designing your figures. We’ll discuss both forms of hair 
in this section.

Strand-Based Hair
Poser’s Hair room adds dynamic strand-based hair to your scene 
elements for ultimate realism. You can create as much or as little 
hair anywhere you like on any object in your scene and can even 
use it to add fur, lichens, grass, and many other effects. Please refer 
to Chapter 24: The Hair Room on page 372 for more information 
about strand-based hair and the Hair room.

By default, strand-based hair requires significant 
computing resources, so you should be careful not to overload 
your system. Please see the detailed information about the Hair 
room for more information.

Prop-based Hair
Prop-based hair is a special kind of prop that automatically 
attaches itself to a figure’s head. You can choose from a number of 
styles in the Library palette (see The Hair Category on page 105﻿). 
Once assigned, hair moves with the figure’s head. Some newer 
hair models that come with Poser are morphable, as are many third-
party hair props. It is common to use Transparency Maps to improve 
the look of prop-based hair.

Figure 10.2

To add hair to a figure from the Library palette, please refer to 
Adding Items to the Library on page 113﻿. Hair includes parameter 
dials in the Parameters palette (see Prop Parameters on page 
165﻿), allowing you to specify its scale and position. Some hair 
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also includes morph target parameter dials that allow you to, for 
example, swing a ponytail as a character walks. The Library palette 
also contains a pose-able hair model, which contains elements 
just like a figure. You can edit and pose these elements just as you 
would any Poser figure:

To use the conforming hair model:

Add the 1.	 James figure from the Figures category of the 
Library palette.

Select and add the 2.	 Messy Hair model from the 
Hair>Kozaburo category in the Library palette.

Set the head as the parent for the hair as described in 3.	
Changing a Parent on page 167﻿.

Clothing
Poser’s Cloth room (see Chapter 25: The Cloth Room on page 386﻿) 
adds a whole new dimension to adding realistic clothing to your 
figures and cloth objects to your scenes. You can even add realistic 
motion to clothes that will react as the character moves (such as 
a skirt on a walking woman) and can be windblown using wind 
force fields (described in Wind Force Fields on page 449﻿). Of course, 
Poser supports prop-based clothing and ships with both dynamic 
and conforming (figure-based) clothing. We’ll discuss dynamic, 
prop, and conforming clothing in this section. 

Dynamic Clothing
Please refer to Adding Dynamic Clothing on page 387 for 
information about adding dynamic cloth to a figure or scene.

Conforming Clothing
In addition to cloth objects, Poser includes libraries of figure-based 
clothing that you can use on nude figures, which are located in the 
Figures category of the Library palette and includes shirts, pants, 
shoes, dresses, skirts, etc.

Figure 10.3

As mentioned previously, articles of conforming clothing behave like 
regular Poser figures and are the same as any other Poser figure 
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from a technical standpoint. For example, shirts have chest, neck, 
abdomen, and arm elements. Clothing includes all parameters as 
the respective body parts on a figure.

You can add conforming clothing to your scene and define it as a 
conforming figure, meaning that it attaches itself to the base figure 
and snaps to the base figure’s similarly named body parts. Clothing 
moves with the base figure.

Adding Conforming Clothing to a 
Figure
Selecting Figure > Conform To conforms the currently selected 
article of Poser figure-based clothing to the desired base figure. 
Please visit some of the online forums (listed in Third-Party Forums 
on page 8) for information and tutorials about creating conforming 
clothing.

To add conforming clothing to a figure:

Select it from the Library palette and click the Add New Figure 
icon to bring it into your scene. Be sure to select clothing items 
designed for your desired source figure. The clothing appears in the 
scene, as shown in the previous graphic.

Use the 1.	 Choose Figure pop-up to select the clothing item.

Select 2.	 Figure > Conform To, and select the desired base 
figure in the pop-up that appears. Your clothing will snap to 

the figure, assume the figure’s pose, and move as its base 
figure moves.

Figure 10.4

Some tight-fitting conforming clothing may not completely 
cover the base figure’s skin, particularly when the figure 
is animated. To fix this, select the base figure’s body parts 
covered by the clothing and make them invisible using the 
Properties palette.
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Adding & Importing Props
There are several ways to bring props into Poser. Props can be 
added to the document window from the Props library, or you can 
also import props from other 3D applications.

The Props Library
You can add props from the Library palette’s Props category as 
described in Adding Hair to a Figure on page 106.

Using 3D Objects as Props
You can import 3D objects created in other 3D applications to use 
as props. Poser’s Import functionality is described in Importing 
Files on page 50.

Poser places props in the workspace with your specified origin 
point. If you do not specify an origin point, the prop will appear in 
the center of the workspace. If you import a prop and can’t see it, 
the prop may be too large and/or your currently selected camera 
may be zoomed in too close to see it. Try zooming out and/or 
switching cameras. You will probably have to scale and translate 
props to get them where you want them in your scene, using either 
the Editing tools or the prop’s Parameter dials.

Moving, Resizing, and 
Deforming Props
You can move, resize, and deform props using the Editing tools, 
the Properties palette, and/or the Parameters palette.

Deleting Props
To delete a prop, select the prop you wish to delete and either 
select Object > Delete Object or press [DEL].

Creating New Props
You can use the Grouping tool to select specific polygons on a 
figure or prop, as discussed in The Group Editor on page 487. This 
feature allows you to create new props. For example, this graphic 
shows an example of a face mask created to fit the figure by 
selecting polygons in the figure’s face and creating a prop, which 
was then exported to a 3D modeling application for finalizing.
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Figure 10.5

To create a prop:

Select the prop or body part you want to base the prop on.

Select the 1.	 Grouping tool to open the Group Editor palette.

Select polygons for a new group and create and name the 2.	
prop.

The new prop is now listed in the 3.	 Current Actor pull-down 
menu and can be moved, shaped, and edited like any other 
prop.

You can save your new prop to the Library palette as described in 
Adding Items to the Library on page 113﻿﻿.

Creating Prop Parameters
You can use morph targets to create new parameters for your 
props. Please refer to Chapter 28: Modifying Figures & Props on 
page 443 for more information about morph targets.

The Prop Origin
A prop’s origin appears in the Document window as 3D 
crosshairs. This is the center of that prop’s rotation and scale. When 
you rotate a prop, it rotates about its origin. It grows or shrinks 
from the origin point when scaled. You can display a prop’s origin 
by selecting the desired prop and checking the Display Origin 
checkbox in the Properties palette.

You can move a prop’s origin using the originXYZ parameter dials. 
Moving the origin alters the prop’s rotation and scale points. When 
adjusting the origin parameters, remember that you are making 
these adjustments based on the prop’s original origin location, not 
its current position.

Prop Properties
Props have the following properties:

•	 Internal Name: The Internal Name field displays the 
prop’s internal (hidden) name, which Poser uses to track that 
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part. You cannot edit a prop’s internal name within Poser.

•	 Name: The Name field displays the prop name. Enter a new 
name in this field if you desire.

•	 Visible: Checking the Visible checkbox makes the prop 
visible and vice versa. Invisible props are not included in 
any render calculations, and do not appear in the rendered 
scene. See Figure Properties on page 135 for information on 
animating the Visible property.

•	 Visible in Raytracing: Checking the Visible in 
Raytracing checkbox makes the prop visible in raytraced 
reflections, such as if the figure is in front of a mirror. Clearing 
this checkbox makes the figure not appear in reflections.

•	 Casts Shadows: Checking the Casts Shadows checkbox 
forces the selected prop to cast a shadow, which will be visible 
in your scene. Clearing this box means the selected body part 
casts no shadow.

•	 Display Origin: Checking the Display Origin checkbox 
displays the prop’s origin. Please refer to The Prop Origin on 
page 163 for more information about prop origins.

•	 Collision detection: Checking the Collision Detection 
checkbox enables collision detection for the currently 
selected prop. Please refer to Collisions on page 63 for more 
information about collision detection.

•	 Apply Collision Setting to Children: Clicking the 
Apply Collision Setting to Children button applies the 
currently selected prop’s collision detection setting to that 
part’s children parts (if any).

•	 Load Morph Target: Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing you 
to load a custom morph target for the selected prop (which 
is then editable using the Morphing Tool). Please refer to 
Chapter 28: Modifying Figures & Props on page 443 for more 
information about loading morph targets.

•	 Set Parent: Clicking the Set Parent button allows you to 
make the prop a child of another element in your scene. Please 
refer to Changing a Parent on page 167 for information on 
setting prop parents.

•	 Displacement Bounds: The Displacement Bounds 
property determines the prop’s displacement boundary. Please 
refer to Chapter 18: Using The FireFly Render Engine on page 
285﻿ for more information about displacement bounds.

•	 Shading Rate: The Shading Rate allows you to specify the 
desired shading rate for the currently selected prop. Lowering 
the shading rate improves your render quality but consumes 
computer resources. Please refer to Chapter 18: Using The 
FireFly Render Engine on page 285 for more information about 
shading rates.
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•	 Smooth Polygons: Checking the Smooth Polygons 
checkbox causes Poser to smooth the prop’s polygons at 
render time to eliminate or reduce a “faceted” appearance 
caused by flat polygons. This option can cause sharp corners 
to appear round. If the affected prop has sharp angles, you 
should experiment with disabling this option for optimum 
results.

Prop Parameters
Props have the following parameters:

•	 Scale: The Scale parameter dial increases or decreases the 
size of the prop in all axes.

•	 XYZScale: The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the prop in the selected axis.

•	 XYZRotate: The xRotate, yRotate, and zRotate 
parameter dials rotate the prop around the selected axis.

•	 XYZTran: The xTran, yTran, and zTran parameter dials 
move the prop along the selected axis.

Replacing a Body Part with a 
Prop
Poser lets you replace a body part with a prop, such as a hook on a 
pirate’s hand or a mask for a man’s head. This example was created 
by importing a model of a mask, then replacing the figure’s head 
with that mask. 

  You should replace body parts with props before posing 
figures to make positioning and aligning easier. 

Figure 10.6
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To replace a body part with a prop:

Add or import the desired prop.1.	

Position and deform the prop as desired using the 2.	 Editing 
tools, deformers, and/or parameter dials. Be sure that the 
prop’s position overlaps the body a little (in most cases) to 
avoid a “break” where the body meets the prop. You might 
also want to make the body part being replaced invisible using 
the Properties palette as described in Properties on page 
135﻿.

Select 3.	 Object > Replace Body Part with Prop to open the 
Replace Part dialog.

Choose the prop to swap using the 4.	 Prop pull-down menu and 
click OK. The prop assumes the name of the body part being 
replaced.

If the replaced body part doesn’t look right, try disabling bending by 
selecting the replaced body part and clearing the Bend checkbox in 
the Properties palette. You can also use the Joint Editor palette 
to make adjustments. This is an advanced feature and should be 
used with care. Please refer to The Joint Editor on page 500﻿ for 
information on using the Joint Editor palette. The prop retains its 
material groups (see the Poser Tutorial Manual, Chapter 5: Multi/
Sub-object Materials on page 21), meaning you can apply shaders 
to it as you can with any other material groups in your scene.

 Props turned into body parts retain their current positions 
relative to the figure that they had prior to being converted. 
Be sure to place props in their desired locations before turning 
them into body parts.

Changing Figures with Replaced 
Geometry
If you try to change a figure that has a prop for a body part using 
the Change function in the Library palette, a warning will appear 
asking if you want to keep the replaced geometry on the new figure 
replacing the old:

To keep the props that have replaced body parts, check the •	
Keep modified geometries button. To keep the props 
attached to their parents on the new figure, check the Keeps 
props attached to figure checkbox. Click OK when ready.

To undo a geometry change and restore a figure’s default •	
geometry, simply reload the original figure from the Library 
palette.
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Set Figure Parent
You can attach props to body parts, body parts to each other, 
figures to props, figures to figures, cameras to body parts- the list 
goes on and on. Setting a parent creates a hierarchical relationship, 
as described in the Poser Tutorial Manual, Hierarchy on page 14. 
You can parent entire figures to various other scene elements. To 
set a parent for a figure:

Select the figure you wish to parent (make the child of another 1.	
object).

Select 2.	 Figure > Set Figure Parent to open the Object 
Parent dialog:

Select the desired parent object and click 3.	 OK. To parent props, 
camera, etc., select Object > Change Parent as described in 
Changing a Parent on page 167.

Figure 10.7

Changing a Parent
You can attach props to body parts, body parts to each other, 
figures to props, figures to figures, cameras to body parts, etc. 
Setting a parent creates a hierarchical relationship, as described 
in the Poser Tutorial Manual, Hierarchy on page 14. You can even 
control whether parented props bend along with their parent body 
part. Some items like sunglasses, etc. should not bend. However, 
other items such as elbow pads on a roller blader should bend with 
the parent. You should change parent props before posing your 
figures, since it may be harder to align props with figures once the 
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figures have been posed (such as a sword in a warrior’s hand).

Here’s an example of a ball parented to a figure’s right hand: 

Figure 10.8

You could also parent a chair to a figure’s hip and make the chair 
inherit the figure’s bend:

Your parenting choices are virtually unlimited. For example, how 
about parenting a camera to a figure’s head? This could create 
some interesting effects.

To set a parent for an element:

Select the object you wish to parent (make the child of 1.	
another object).

If necessary, use the 2.	 Editing tools, deformers, and/or 
parameter dials to position and shape the object. Ensure the 
correct positioning using either a detailed preview style (such 
as Lit Wireframe), zooming in close, or a test render. You 
can also enable Collision Detection to prevent the selected 

object from penetrating its parent object, or vice versa. Please 
refer to Collisions on page 63 for more information about the 
Collision Detection feature.

Select 3.	 Object > Change Parent (or click the Set Parent 
button in the Properties palette) to open the Figure Parent 
dialog:

Figure 10.9

Select the desired parent object (the object to which the 4.	
currently selected object will be attached).

If you want the prop to bend like its parent, check the 5.	 Inherit 
bends of parent checkbox.
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Click 6.	 OK.

When selecting only a single item from the Object Parent 
hierarchy window, you can simply double-click on that item to 
make your selection and close the window.

In the preceding examples, we parented the ball to the figure’s right 
hand and the chair to the figure’s hip. To set parents for an entire 
figure, select Figure > Set Figure Parent as described in Set 
Figure Parent on page 167﻿.

Delete Object
Selecting Object > Delete Object deletes the currently selected 
prop. A confirmation dialog appears. Click OK to delete the prop, 
Cancel to abort. 
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Chapter 11: Cameras
This section describes how Poser’s cameras work. As indicated 
previously, cameras aim at the Poser workspace from different 
vantage points. Switching cameras allows you to view your scene 
from up to four of these vantage points at once.

Camera View
Selecting Display > Camera View allows you to select one of the 
cameras available in your scene.

Show Camera Names
Selecting Display > Show Camera Names displays the name 
of the currently selected camera in the top left corner of the 
Document window’s scene preview area. Clicking this option 
again disables this feature.

The Camera Controls
The Camera controls allow you to quickly select and position 
cameras. Used in conjunction with the available Document 
window layouts, they allow you to quickly navigate your scene and/

or set up final shots for still or animated output. Remember that 
every view you see of your scene inside the Document window 
is done using one or more cameras. You can move cameras in any 
direction, however positioning them can be a time-consuming 
process. Having multiple cameras allows you to use preset camera 
positions to quickly navigate your scene, while the ability to 
position cameras allows you to create custom still or moving shots 
for use either while working on your scene or during rendering.

The Camera controls appear as follows in the Poser workspace:

Figure 11.1

In addition, the Mini Camera controls appear on the top of the 
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Document window, allowing you to navigate your scene without 
having to have the full Camera controls visible (such as when you 
are using the Material room). 

Figure 11.2

The Animation On/Off control allows you to enable or disable 
automatic keyframe generation when  you move or change rotation 
of a camera. The Flyaround camera view provides an animated 
view of your scene as a camera rotates around it while pointed at 
the center origin.

The Mini Camera controls consist of (from left to right) the 
Trackball, Move XY, and Move XZ controls. These function 
identically to their counterparts in the main Camera controls and 
are therefore detailed in this chapter.

The available 3D cameras are: Main, Auxiliary, Posing, Face, 
Left Hand, Right Hand, and Dolly. The available orthographic 
(2D) cameras are: Left, Right, Top, Bottom, Front, and Back. 
When you render stills or animations, the rendering takes place 
using the currently selected camera. Please refer to Part 4: 
Rendering on page 276 for more information on rendering. Each 
camera is discussed above.

The Main, Auxiliary, and Posing 
Cameras
The Main, Auxiliary, and Posing cameras are revolving cameras, 
which means they rotate about the center of the Poser workspace. 
By default, figures and props are placed at the center of the 
workspace. Moving figures/props does not alter these camera’s 
positions. The Auxiliary camera provides a secondary camera for 
your use, such as when you are deciding which shot to render and 
want to explore possibilities without affecting your previous camera 
positioning/animation work

The Posing camera is similar to the Main and Auxiliary Cameras 
except that it rotates about the currently selected figure, not the 
workspace. If you select another figure, the Posing camera moves 
to that figure/prop.

Figure 11.3
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The Face Camera
The Face camera provides a close-up of the currently selected 
figure’s face, allowing you to precisely adjust facial expressions and 
see your results in detail. This camera rotates around the currently 
selected figure’s face and moves if you select another figure. This 
camera also works with animal figures. To switch to the Face 
camera, select your desired figure and click the Face Camera 
control.

Figure 11.4

For the Face camera to work properly, be sure your 
figures’ heads are all named “Head”. This is not an issue for 
figures that were included with Poser but could be an issue for 
third-party content and custom figures you create yourself.

Left and Right Hand Cameras
Like the Face camera, you can zoom in on the left or right hand of 
the currently selected figure to fine-tune gestures and other hand 
positions. Hand cameras also focus on the currently selected figure. 
If the figure is an animal, the Hand cameras will focus on the feet/
paws/claws as appropriate. To switch to a hand camera, click the 
Left hand or Right Hand icon as appropriate.

Figure 11.5

For the hand cameras to work properly, be sure your 
figures’ hands are all named “Left Hand” and “Right Hand”. 
This is not an issue for figures that were included with Poser 
but could be an issue for third-party content and custom 
figures you create yourself.
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The Dolly Camera
The Dolly camera rotates about its own center independently of 
scene contents, meaning it can move around and between elements 
in the scene. If you want to emulate a motion picture camera, the 
Dolly camera is your best choice.

Orthographic Cameras
The Left, Right, Top, Bottom, Front, and Back cameras are 
orthographic cameras, meaning that they product orthographic 
projections. Orthographic projections makes objects appear flat 
(2D), without the perspective of 3D views. Orthographic cameras 
cannot be rotated, since they are permanently aligned to the X, 
Y, and Z axes in the Poser workspace. Because of this, they make 
excellent references for viewing your scene. Please refer to the 
Poser Tutorial Manual, About 3D Space on page 2 for a general 
discussion about 3D views.

Figure 11.6

Shadow Light Cameras
Shadow light cameras are very useful for aiming lights and creating 
their shadows. Each light in your scene has one Shadow Light 
camera. Each shadow camera shares both XYZ location and 
aim direction with its assigned light. Poser uses these cameras 
to calculate shadows cast by the objects in each light’s path. 
Positioning these cameras and/or adjusting their parameters/
properties can affect how shadows appear in your rendered scenes. 



Poser 8
Reference Manual 

174

Chapter 11: Cameras

You can select these cameras using the Select Actor pull-
down menu. Shadow cameras have a reduced set of properties/
parameters (see Camera Properties & Parameters on page 178﻿ for 
more information).

 If you see poor depth map shadows in a portrait shot, or 
if you see warping or flickering shadows in animation, you can 
tweak the shadow cams to adjust the field of view to the parts 
of the scene that really matter.

Figure 11.7

Changing Cameras
To change a camera, use any of the following methods:

Right-click the camera label in any •	 Document window 
pane and choose one of the options in the Camera View 
submenu.

Click the •	 Face, Left Hand, or Right Hand icon in the 
Camera controls (see The Camera Controls on page 170).

Click the •	 Select Camera control in the Camera controls (see 
Select Camera Control on page 174).

Select •	 Display > Camera View using the Menu Bar, then 
selecting your desired camera in the Cameras pull-down 
menu.

Select Camera Control
Clicking and dragging the cursor over the Select Camera control 
cycles through the available camera views and changes the 
Document window or currently active view pane to the newly 
selected camera.
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Figure 11.8

Just above the main Select Camera control are three shortcut 
buttons for specific cameras. You can replace an existing camera 
shortcut with your currently selected camera by pressing [OPT]/
[ALT] while clicking one of the Select Camera shortcut buttons. 
A shortcut for your currently selected camera will replace the 
previously existing camera shortcut.

Flyaround View
The Flyaround view places the currently selected camera on 
a virtual track above and away from the center of the Poser 
workspace and orbits around your scene, displaying all elements 
within view. This is an excellent way to quickly see how your scene 
looks in 3D space. Once activated, this view remains active until 
toggled off. To toggle Flyaround on and off, click the control or 
make the selection using the Cameras pull-down menu.

Figure 11.9



Poser 8
Reference Manual 

176

Chapter 11: Cameras

Positioning Cameras
In addition to selecting cameras, the Camera controls allow you 
to position your currently selected camera using one or more of 
the following controls. If you have more than one camera active 
(multiple Document window view panes), these controls will only 
affect the currently selected camera.

Camera Plane Controls
The Camera Plane controls constrain camera motion to specific 
3D planes (axes), helping you move the camera with precision:

Move YZ•	 : The Move YZ control constrains camera motions 
to the up/down (Y) and front/back (Z) axes.

Move XY•	 : The Move XY control constrains camera motions 
to the side/side (X) and up/down (Y) axes.

Move XZ•	 : The Move XZ control constrains camera motions 
to the side/side (X) and front/back (Z) axes.

Figure 11.10

Rotation Trackball
The Rotation trackball tilts and spins the currently selected 
camera about all three axes. The Main, Auxiliary, Posing, and 
Dolly cameras rotate about the center of the Poser workspace. 
The Posing camera rotates around the currently selected figure. 
The Face and Hand cameras rotate about the respective actors 
(body parts) of the selected figure. You can also use the Rotation 
trackball by pressing [OPT]/[ALT] and dragging the cursor around 
the workspace using the Document window.
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Figure 11.11

Scale Control
The Scale Camera control works like a zoom lens. Click the control 
and drag right to zoom towards the camera’s aim point (workspace, 
figure, or actor, depending on the camera). Clicking and dragging 
left zooms out, and vice versa.

Focal Length Control
The Focal Length control increases or decreases the selected 
camera’s focal length. Clicking the control and dragging right 
increases the focal length, while clicking and dragging to the left 
reduces the focal length. You can also adjust the camera’s Focal 
Length parameter in the Parameters palette.

Roll Control
The Roll Camera control banks the camera to the left or right, 
tilting your view of the Poser workspace. Click the control and drag 
left or right to tilt the camera in the indicated direction.
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Figure 11.12

Creating Cameras
You can create new revolving or dolly cameras using the Object > 
Create Camera menu option. 

You can specify the type of camera you wish to create by selecting 
either Revolving or Dolly from the Create Camera sub-menu. A 
revolving camera rotates about the center of the Poser workspace, 
regardless of the position of objects within the scene. A dolly 
camera rotates about its own center, and can move around and 

between elements in the scene.

Camera Properties & 
Parameters
When you select a camera, its properties and parameters will 
appear in the Properties and Parameters palettes, respectively. 
To access a camera’s properties and parameters in the appropriate 
palette when you do not currently have a camera selected, you can:

Click your desired camera object if it is visible in the •	
Document window.

Use the •	 Current Actor pull-down menu.

Camera Properties
Cameras have the following properties, available in the Properties 
palette:
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Figure 11.13

•	 Name: The Name field displays the camera name. Enter a 
new name in this field if you desire.

•	 Visible: Checking the Visible checkbox makes the camera 
visible in the Document window, and vice versa. Invisible 
objects are not included in any render calculations, and do not 
appear in the rendered scene. See Figure Properties on page 
135 or information on animating the Visible property.

•	 Animating: Check the Animating box to have the selected 
camera’s movements recorded as keyframes in your animation, 
or clear it to disable this feature. With this feature disabled, 
you can still move the camera but its movements will not be 
recorded as keyframes in your animation. Camera animation 
allows camera movements to appear as part of rendered 
movies, allowing for such techniques as follow shots, flyaround 
views, etc. Please refer to Chapter 21: Animating with Poser 

on page 311 for more information on creating animations. 
To enable/disable camera animation, open the Properties 
palette. 

When a camera is animated, your view of your scene changes over 
time, which can add realism and interest to your animation. Watch 
a movie and notice how often the camera moves. You can animate 
Poser cameras just like any other 3D object using keyframes and 
tween frames. Different cameras will animate differently, since they 
have differing centers of motion.

You can only use one camera per animation; you cannot switch 
cameras in mid animation. To do this, create separate clips then 
edit them together using video editing software such as Adobe® 
Premiere®.

Remember changes for Undo•	 : Checking the 
Remember changes for Undo checkbox specifies that any 
camera changes will be included in the Undo/Redo cache. 
Unchecking this checkbox means that the Undo feature will 
not apply to camera changes.

Camera Parameters
Like all parameter dials, clicking and dragging a dial to the right 
increases its value, and clicking and dragging to the left decreases 
its value. You can also click your desired parameter’s numeric value 
to open a text field allowing you to directly type your desired value.
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Figure 11.14

Other Parameters
The Other Parameters section contains a variety of parameters 
to control the behavior of the selected camera. These parameters 
are as follows:

•	 Focal: The Focal parameter dial sets the camera’s focal 
length. Smaller numbers give wider angles and will add more 
stretching and distortion as they decrease. Larger numbers 
give results like telephoto lenses, and result in less distorted 
but flatter images.

•	 Perspective: The Perspective parameter shifts the current 
camera’s perspective without changing the camera’s location. 
This can give the illusion that the camera is farther or nearer 
to objects in your scene.

•	 Depth of Field: Widening the lens aperture of the camera 
allows you to achieve a Depth of Field effect. The farther 
away items are from the focal plane, the more blurred they 
will appear. Depth of Field can be individually configured for 
each camera.

�� Focus Distance: The focus distance dial controls 
the crosshair so that you can position the focus. Place 
the crosshair at the distance at which objects appear 
most in focus. In Poser, focal distance for each camera 
is determined by a control object located within the 
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scene. You can animate the control object like any other 
figure in Poser, by using keyframes to specify its change 
in position; Poser will interpolate the movement between 
keyframes for you. (For more information about animating 
using keyframes, please refer to Chapter 21: Animating 
with Poser on page 311.) Enter your desired value in the 
camera’s Focus Distance field.

Figure 11.15: The Focus Distance control, with Alyson as the point of focus.

�� F-Stop: The F-Stop number represents a lens aperture 
size. The larger the number, the smaller the aperture 
opening. Each number is multiplied by a factor of 
approximately 1.4 as the scale rises, giving standard 
values of 1.0, 1.4, 2, 2.8, 4, 5.6, 8, 11, 16, 22, 32, etc. 
Each change either doubles or halves the amount of 
light transmitted by the lens to the film plane. Basically, 
f-stop is calculated from the focal length of the camera 

lens divided by the diameter of the bundle of light rays 
entering the lens and passing through the aperture in the 
iris diaphragm. On a physical camera, this represents the 
lens focal length (see next bullet) divided by the f-stop 
value to determine the actual aperture size. Enter your 
desired value in the F-Stop field.

The following images illustrate the Depth of Field effect:

Figure 11.16: Without depth of field (left); With depth of field (right)

 Poser allows you to enable or disable Depth of Field for 
individual renders. Please refer to Chapter 18: Using The 
FireFly Render Engine on page 285 for details on how to do 
this using the FireFly Renderer.

 If the results of your Depth of Field settings are too grainy 
in the blurred areas, try raising the number of Pixel Samples. 
Doing so will result in a smoother effect, but increased render 
times.
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•	 Shutter Open: The Shutter Open value represents the 
shutter opening time in fractions of a frame, where 0.0 is the 
beginning of the frame and 1.0 is the end of the frame. Unlike 
a real camera shutter, this one opens and closes instantly with 
zero elapsed time. Regular camera shutters, while extremely 
fast, require a small time interval to travel between the closed 
and open positions.

•	 Shutter Close: The Shutter Close value represents the 
shutter closing time in fractions of a frame, where 0.0 is the 
beginning of the frame and 1.0 is the end of the frame. Unlike 
a real camera shutter, this one opens and closes instantly with 
zero elapsed time. Regular camera shutters, while extremely 
fast, require a small time interval to travel between the closed 
and open positions. For example, setting a beginning time of 
0.0 and an ending time of 0.5 means the shutter would be 
open for the first half of a frame.

The Shutter Open and Shutter Close settings only result 
in a visible effect when 3D Motion Blur is activated in the 
Render Settings dialog. As the amount of time between 
Shutter Open and Shutter Close increases, the motion blur 
effect increases.

•	 Hither: The Hither parameter controls the distance of the 
clipping plane. Objects (or portions thereof) closer to the 
camera than the hither distance will not appear in your view 

pane.

•	 Yon: The Yon parameter sets the farther range of the 
clipping plane. Objects (or portions thereof) farther from 
the camera than the yon distance will not appear in your view 
plane. The Yon parameter is only applicable with OpenGL 
hardware rendering.

Transform Parameters
When a camera is selected, you can use the parameter dials on the 
Parameters palette to precisely adjust that camera’s position. The 
Dolly, Posing, Face, and Hand cameras have the standard 3D 
Pitch, Yaw, and Roll parameters, while the Main and Auxiliary 
cameras have xOrbit, yOrbit, and zOrbit parameters. These 
parameters are measured in degrees.

XYZ Dolly

The Dolly parameter dials move the selected camera along the 
desired axis without altering its orientation, just like a movie 
camera on a dolly cart, as shown below:

DollyX•	 : The DollyX parameter moves the camera laterally. 
Increasing this value moves the camera to the right.

DollyY•	 : The DollyY parameter moves the camera vertically. 
Increasing this value moves the camera up.
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DollyZ•	 : the DollyZ parameter moves the camera in and out. 
Increasing this value moves the camera in and out.

XYZ Scale

As mentioned above, camera scale functions like a zoom lens. The 
Scale control zooms the camera equally in all three axes. Using the 
parameter dials, however, you can scale in any amount using any 
combination of axes to create distorted effects. While this might 
give the same appearance as distorting the figures/props in your 
scene, scaling cameras only affects the selected camera; items in 
your scene are not affected. Decreasing scale values zooms in along 
the selected axis, and vice versa.

xScale•	 : The xScale parameter changes the camera’s 
horizontal scale.

yScale•	 : The yScale parameter changes the camera’s vertical 
scale.

zScale•	 : The zScale parameter changes the camera’s depth 
scale.

Scale•	 : The Scale parameter dial changes the selected 
camera’s scale equally along all three axes and functions in the 
same manner as the Scale camera control. If you have already 
selected unequal scales using the individual axis controls, the 
Scale dial/control preserves your previously selected ratios.

XYZ Orbit

The Orbit parameters orbit the selected camera around the 
indicated Poser workspace axis. It helps to think of the selected axis 
as the center of a wheel with the camera being at the edge. The 
camera maintains its distance from the axis and remains pointing 
in the same direction relative to its starting point. Setting positive 
degrees of rotation in the Orbit parameter dials orbits the selected 
camera in a counterclockwise direction around the selected axis, 
and vice versa. 

xOrbit•	 : The xOrbit parameter orbits the selected camera 
using the Poser workspace’s X axis as the center of rotation.

yOrbit•	 : The yOrbit parameter orbits the selected camera 
using the Poser workspace’s Y axis as the center of rotation.

zOrbit•	 : The zOrbit parameter orbits the selected camera 
using the Poser workspace’s Z axis as the center of rotation.

Pitch, Roll, Yaw

These parameters rotate the Dolly, Posing, Face, and Hand 
cameras about their own axes. To illustrate this, let’s use the 
example of a small plane with its X, Y, and Z axes labeled:
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Figure 11.17

Pitch•	 : The Pitch parameter rotates the selected camera 
about its own X axis (up/down). A positive number pitches the 
camera up (the scene appears to pitch down), and vice versa.

Roll•	 : the Roll parameter rotates the selected camera about 
its own Z axis (tip left/tip right). A positive number rolls the 
camera to the left (the scene appears to rotate to the right), 
and vice versa.

Yaw•	 : The Yaw parameter rotates the selected camera about 
its own Y axis (rotate left/rotate right). A positive number yaws 
the camera to the left (scene appears to yaw to the right), and 
vice versa.

Pointing & Locking Cameras
As with any other object in your scene, you can use the Hierarchy 
Editor (see The Hierarchy Editor on page 493﻿) to keep cameras 
pointed at certain other objects.

Pointing Cameras at Scene Objects
To point your camera at another scene object:

Select your desired camera using the 1.	 Current Actor pop-up.

Select 2.	 Object > Point At to open the Choose Actor dialog.

Choose your desired scene object in the list of actors (the 3.	
camera can point at anything) and click OK.

The camera will point at the selected object and a Point At 
parameter dial will appear in the Parameters palette for that 
camera. Setting this parameter to 1 locks the camera on target, 
and 0 completely disables pointing. Intermediate values cause the 
camera to lag behind the object it’s pointing at. This parameter 
allows you to create interesting effects when creating animations.

Disabling Camera Pointing
To disable camera pointing:
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Select your desired camera using the 1.	 Current Actor pop-up.

Select 2.	 Object > Point At to open the Choose Actor dialog.

Choose 3.	 None in the list of actors (the camera can point at 
anything) and click OK.

Locking Cameras
Once you have positioned a camera to your liking, you can lock 
it to prevent it from being moved. To lock a camera, select it as 
described above, then select Object > Lock Actor. Selecting this 
option again toggles locking off.

Camera Dots
You can save up to nine camera configurations using the Memory 
dots (described in Memory Dots on page 43). Each Memory dot 
retains the settings for all cameras in your scene. All Memory dots 
are saved with the application, so your saved camera configurations 
will be accessible in any Poser document loaded. You can also save 
camera settings to the Library palette as described below, which 
would allow you to use your Memory dots for other settings.

Saving Camera Sets
The Cameras category in the Library palette allows you to save 
camera positions and access them using a few mouse clicks. 
Camera positions are saved relative to the Poser workspace, not 
figures or other scene items. Saving camera sets saves all cameras; 
you cannot save one camera. As with any other Library palette 
category, you can add subcategories to the Cameras categories. 
Please refer to Chapter 2: Installing Poser on page 11 for a 
description of the Library palette, and to Maintaining Your Library 
Palette on page 113 for information on adding items to it.
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Chapter 12: Lighting
Lights add color to your scene, reveal cues in forms, enhance 
muscle contours, set moods, cast shadows, etc. Good lighting is a 
key element of getting your scene to look right when you render it. 
Lights work in renderings and in the Lit Wireframe and Flat Shaded 
preview modes (refer to Chapter 6: The Display Controls and Menu 
on page 77 for information about display styles). You can use as 
many lights as you need in your scene, with the only limitation 
being your system’s resources. Poser improves the OpenGL preview 
of lights in your scenes. It automatically selects the eight brightest 
lights to display in the realtime OpenGL preview. You can also 
manually select which eight lights to preview in the Light Properties 
palette (see Light Properties on page 194).

Lights can also help you create effects. For example, you could add 
a reflection map to an element in your scene, causing it to direct 
light back at the source. Please refer to the Poser Tutorial Manual, 
Chapter 4: Groups on page 16 or an explanation of material 
groups and to Part 3: Materials on page 203 for information on 
creating material shaders for your scene elements.

The Light controls appear as follows:

Figure 12.1

Each light has customizable characteristics, such as rotation and 
revolution positions, color, and intensity (brightness). You can turn 
lights on or off, adjust how the brightness diminishes as you reach 
the edge of a light’s range (the falloff), and specify whether or 
not a light casts a shadow. You can also animate lights to create 
effects such as lightning or flickering streetlights. As with any other 
Poser object, you can parent lights to scene elements to have the 
light move as the source element moves. By default, Poser scenes 
include three infinite lights.

When you add, remove, move, or adjust lights, the Document 
window, Light controls, and the selected light’s parameter dials 
automatically adjust to show the light’s new position/properties, 
allowing you to preview your changes in real time.
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Light Types
Poser allows you to create four types of lights: infinite, point, spot 
and image based.

Infinite Lights
Infinite lights are comparable to the sun or moon shining on the 
Earth. Rays from infinite lights are parallel as they enter your Poser 
workspace. If you have multiple figures and/or props in your scene, 
infinite lights shine on each item equally. You cannot place any 
scene element beyond an infinite light’s range, and no figure/prop 
can be lit differently than another.

Figure 12.2

Point Lights
Point lights are similar to a light bulb, in that they emit light from a 
single source point outward in 360 degrees. These lights are ideal 
for times when you want an omnidirectional light source that can 
interact with objects and cast shadows in ways that an infinite light 
cannot. For performance reasons depth mapped shadows are not 
supported for point lights; point light shadows must be calculated 
using raytracing.

Spotlights
Spotlights cast light in a specific direction, throwing light along a 
cone-shaped path to create a classic stage spot effect. These lights 
are useful for illuminating specific objects or for creating lighting 
effects. Spotlights can increase rendering times.

Diffuse Image Based Lights (IBL)
Diffuse Image Based Lighting (Diffuse IBL) takes a light probe, 
which is ideally a 360 degree light distribution captured in a single 
map, and illuminates the scene using that map. In Poser, only the 
diffuse component of the light is defined by the light probe. As this 
technique is based on complete light data for a given space, the 
lighting results are very realistic. In order to get realistic shadows 
when using an image based light, we recommend using Ambient 
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Occlusion (see Light Properties on page 194﻿). You must activate 
raytracing in the Render Settings dialog in order to render 
Ambient Occlusion effects.

To attach a light probe to the image based light, press the 
Advanced Material Properties button on the Properties 
palette (see Light Properties on page 194﻿). Once in the Material 
room, you have the option of attaching simply a light probe image 
map, or a shader tree of any complexity, to the color channel of 
your Diffuse IBL.

Poser has the ability to apply the full functionality of its 
procedural shading system to an image map used as an image 
based light. See Part 3: Materials on page 203 for more 
information about the image node manipulations available 
using the shading system in the Material room.

Selecting Lights
You can select lights as follows:

Clicking one of the Lights in the •	 Light Position indicator.

Using the •	 Current Actor pop-up menu.

Creating Lights
To create a light, click the Create Light icon in the Light controls, 
or click on Create Light in the Light Options pop-up menu. Your 
new light will appear in the Light Position indicator. 

Figure 12.3

By default, Poser creates spotlights. To create a different type of 
light, select Object > Create Light, and select the type of light 
you wish to create from the pop-up menu that appears. 

To change a light to another light type, select the new light and 
click the Light Properties icon (see below for information about 
light properties). You can also right-click the Create Light icon (in 
the box above) to access the light type menu. 
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Figure 12.4

If you select the Diffuse IBL light type on the Properties tab, you 
will then need to go to the Material room, select that light as the 
current actor, and apply an image map to use as the lightprobe. 
In the Simple tab, you can simply select an image map via the 
Texture Manager. In the Advanced tab, you would attach an 
image node or a complete shader tree to the color channel. 

Adjusting Light Intensity
You can set a light’s intensity using the Brightness control like a 
dimmer switch. Click and drag the brightness indicator to the left to 
dim the selected light, or to the right to brighten it. 

You can also set the light’s intensity using the parameter dials in 
the Parameters palette.

Figure 12.5

For image based lighting, you must adjust the light intensity in the 
Advanced tab of the Material room. Take care when making 
these adjustments, so that your results will approximate the realism 
of the lighting conditions in the image map you have selected.

You can set a light’s intensity to a negative value, thereby 
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creating a “non-light” that will actually darken the affected 
area(s) of your scene. You can use this feature to create 
interesting effects. 

Light Color
Light colors contribute to your scene’s overall appearance and 
mood. Unlike paints, light colors multiply instead of mixing and 
adding to one another. For example, a red figure with blue lighting 
would appear black, not purple. If you don’t want a light to affect 
the color of items in your scene, set that light’s color to white or 
gray. Because of this relationship between scene items and lights, 
you might want to set your scene items’ colors before setting 
lighting colors. Note that with image based lighting, you should 
generally use a white color, so as not to interfere with the light 
colors already contained within the image map.

To change a light’s color, click the Color icon in the Light controls 
to open a standard Color Picker dialog. Make your selection, and 
your selected light will change to its new color. You can also set a 
light’s color using the parameter dials in the Parameters palette. 
For image based lighting, you can use the Advanced tab of the 
Material room to plug any image node into the color channel of 
that light. Doing so will allow you to see the effects of the image 
based light on any surface in the Material room, which will give 
you an exact idea of how those surfaces will be shaded in the final 
render.

Figure 12.6

Delete Light
Select the light you wish to delete and click the Delete Light 
icon in the Light controls, or click on Delete Light in the Light 
Options pop-up menu.

Aiming Lights
Spotlights and infinite lights are directional light sources, and 
therefore can be aimed with relation to your scene. You should 
finish posing your figures and positioning your props before aiming 
your lights. Doing this in reverse will cause your scene elements’ 
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appearances to change as you move them. For example, rotating a 
figure 180 degrees causes illumination falling on its front to fall on 
its back. You may need to re-aim your lights to continue working. 
Some traditional artists place a bright light above and to the left of 
a figure. Using a strong single light source lets you see shading on 
distant and oblique surfaces, contributing to the scene’s depth and 
curvature. You may want to read books on lighting, including using 
lights in photographic studios, to give you ideas on using lights to 
enhance your Poser scenes.

If you import a background image or movie, you should set your 
lights to mimic the lighting in the background. For example, if your 
background image shows a strong light coming from the figure’s 
right, don’t light the figure from the left. This will help preserve 
consistency between your scene and the background and help 
integrate both elements together. Ideally, when working with 
backgrounds, you should have the background look like part of 
your scene. If your scene is a room using an image of a brightly lit 
background visible through the windows, you should have most of 
your lighting streaming in through the windows to blend the room 
and its contents with the outside world and lend realism to your 
scene.

You can aim lights using any of the following methods:

Using the •	 Light Position control (see below).

Moving a light’s indicator in the •	 Document window (see 
below).

Using the •	 Editing tools (Rotate and Twist for infinite lights, 
and Rotate, Twist, Translate/Pull and Translate In/Out 
for spotlights. Please refer to The Editing Tools on page 129 for 
information on using the Editing tools).

Using the selected light’s parameter dials in the •	 Parameters 
palette.

Using the •	 Object > Point At (Point At on page 151﻿) or 
Object > Set Parent (Changing a Parent on page 167﻿) 
menus.

Using the desired light’s •	 Shadow camera, as described in 
Shadow Light Cameras on page 173.

As discussed above, infinite lights always shine into the scene. 
Aiming an infinite light sets the location from which the light 
shines (such as setting the sun’s position in the sky). When aiming 
spotlights, you’re setting both the angle at which the light shines 
and the light’s position in 3D space.

Using the Light Position Control
The globe in the center of the Light Position indicator represents 
your Poser scene in 3D space, and the light dots represent the 
positions of each of the lights within your scene. These dots can 
be moved in two ways with respect to the globe: Rotation and 
Revolution. Rotation keeps the light in the same physical position 
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relative to the scene, but adjusts its direction around its own local 
axis. Revolution moves the light around the globe to a new position 
relative to the scene, while keeping the light pointed at its parent, 
as shown in the figures below. You can select which positioning 
method you wish to use by clicking either Rotate or Revolve in 
the Light Options pop-up menu. The check mark indicates which 
option is currently selected. Then click and drag your selected light 
dot(s) to change their position and/or direction. Revolving these 
dots to different positions around the globe adjusts the lighting 
angle, as shown below:  

Figure 12.7

Clicking anywhere in the Light Position control selects the 
nearest light.

Using Light Indicators
When you select a light, Poser displays a light indicator describing 
your selected light’s position in the Document window. In some 
cases, viewing the indicator from a different angle can help you 
visualize your light’s position. You can switch Camera views and/
or zoom to view light indicators from different angles. Additionally, 
you can adjust a light’s position by clicking and dragging the light 
indicator in the actual scene. The Light controls will reflect any 
changes you make to the light indicator’s position. Note that image 
based lights have no light indicators, as they surround your entire 
scene.

Infinite Light Indicators
An infinite light’s indicator appears as a ring surrounding the 
currently selected figure/prop. This ring serves as the equatorial 
line of an invisible globe with the light shining down on your scene 
from the point on the equator indicated by the arrows, as shown 
here:
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Figure 12.8

Then viewed from oblique angles, the circle appears as an ellipse, 
helping show if the light is in front of or behind the figure. The light 
is not actually on the edge of the indicator. The indicator simply 
represents a larger globe encompassing the entire Poser workspace. 
You can click and drag a light indicator to reposition the selected 
light.

Point Light Indicators
A point light’s indicator appears as a small outlined circle, depicting 
the light’s position in 3D space (remember, you can position point 
and spotlights in 3D space, unlike infinite lights), as shown here. 

Figure 12.9

As point lights emit light equally in all directions, there is no 
direction indicator as with a spotlight.

Spotlight Indicators
A spotlight’s indicator appears as the outline of a spotlight in your 
Poser workspace depicting both the light’s position in 3D space and 
the direction the light is pointing, as shown in this image.

Figure 12.10

Clicking and dragging a spotlight’s indicator moves the light around 
the scene.

You may want to use orthographic views (Left, Right, Top, 
Bottom, Front, or Back) to move Spotlight indicators, since 
doing so constrains the spotlight’s motion to two dimensions 
(YZ if using the Left or Right views, XZ if using the Top or 
Bottom views, and XY if using the Front or Back views). Using 
perspective views can move your spotlight in oblique directions, 
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causing unexpected lighting effects.

Light Properties
Light properties help you fine-tune your lighting effects. To 
access a light’s properties, select the light and either click the 
Light Properties icon in the Light controls or select Object > 
Properties. You can also access light properties in the Properties 
palette.

Figure 12.11

Depending on the light type that you select, you can control some 
or all of the following light properties:
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•	 Include in OpenGL Preview: By default, Poser displays 
the eight brightest lights. Users can optionally choose which 
eight to display. By providing real time previews of eight 
user-selectable lights, posing and lighting is faster and 
yields better results. Use this option to select each light you 
want to illuminate the scene preview. Mip Map support has 
been enabled for enhanced performance when previewing 
large textures. Together, these real-time preview engine 
enhancements let the user view larger textures and offer more 
complete scene previewing when setting up lights If your 
scene has more than eight lights, you can check or uncheck 
this option to include or exclude the current light from the 
preview display.

•	 Visible: Checking the Visible checkbox makes the light 
visible in the Document window, and vice versa. Invisible 
objects are not included in any render calculations, and do not 
appear in the rendered scene. See Figure Properties on page 
135 for information on animating the Visible property.

•	 Animating: Checking the Animating checkbox allows you 
to animate the light just as you would any other Poser object. 
Animated lights can also have different settings in various 
keyframes. For example, you could create a red spotlight on 
your figure’s left side that orbits overhead and turns blue. 
When you rendered this animation, you would see your 
figure’s color changing and shadows moving with the light. 
You cannot animate lights that are turned off (see above).

•	 On/Off: Checking the On box turns the light on, just like 
flicking its switch. Clearing the checkbox turns the light off. As 
a shortcut, you can also press Opt/Alt while clicking a light in 
the Light controls to toggle the selected light on or off.

•	 Spot/Infinite/Point/Diffuse Image (IBL): Check the 
appropriate radio button (Spot, Infinite, Point or Diffuse 
Image (IBL)) to make your selection. Spot, infinite, point and 
image based lights are discussed above.

•	 Shadows: Checking the Shadows checkbox enables you to 
choose one of the following two options:

•	 Raytrace Shadows: Selecting Raytrace Shadows 
enables raytracing of shadows. Traditionally, raytracing results 
in clear, hard-edged shadows. However, Poser offers a method 
for softening the shadow edges, thus adding more realism to 
your raytraced shadows. You can control this effect using the 
Shadow Blur Radius dial (see below). 

�� Depth Map Shadows: Selecting Depth Map 
Shadows enables depth-based shadow mapping. If you 
are using displacement maps, we recommend you select 
this option rather than raytracing, for greater accuracy. 
Enabling this option activates both the following dials:

�� Shadow Blur Radius: All shadows have a blurry 
region around their edges. The Shadow Blur Radius 
parameter specifies the radius of this blurry region. By 
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default, this dial is set to a low value. Raising the blur 
radius increases the soft shadow edge effect.

�� Shadow Min Bias: The Shadow Min Bias 
parameter specifies how far to shift samples towards the 
light source to prevent self-shadowing of objects.

•	 Ambient Occlusion: Checking the Ambient Occlusion 
checkbox enables Ambient Occlusion for the selected 
light. Ambient occlusion adds realism to your scene by 
approximating the way light and shadows act in real life. It 
helps bring out details in creases and corners. This option 
provides the advantage of calculating Ambient Occlusion 
effects on all surfaces within the scene, without having to 
attach an Ambient Occlusion node to every material. Enabling 
this option activates the following controls:

Strength�� : The Ambient Occlusion Strength dial 
specifies the degree to which Ambient Occlusion effects 
will darken the occluded surfaces within the scene.

Scene AO Options�� : The Scene Ambient Occlusion 
Options button provides access to the global set of 
Ambient Occlusion parameters. These parameters are 
described in the Ambient Occlusion node section under 
Raytrace Nodes on page 253﻿.

Figure 12.12

•	 Atmosphere Strength: The Atmosphere Strength 
dial and field allow you to specify the strength of atmospheric 
(volumetric) effects. This attribute is used in conjunction with 
the Root Atmosphere node, which is described in Root 
Atmosphere Node on page 237﻿.

Figure 12.13

•	 Set Parent: Clicking the Set Parent button allows you to 
make the light a child of another element in your scene.

•	 Color: Clicking the Color button opens the Poser Color 
Picker, allowing you to set the light’s color.

•	 Advanced Material Properties: Clicking the 
Advanced Material Properties button will automatically 
take you to the Material room, with the current light active 
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in the Shader window’s Advanced tab. Please refer to 
Advanced Shader View on page 214 for more information 
about the Advanced tab of the Shader window, and to Root 
Light Node on page 236 for more information about the root 
Light node attributes.

•	 Attenuation:  (Enabled for Spot lights or Point lights only): 
This setting controls how bright or dark a spot light or point 
light gets based on the distance away from the light source. 
Options for spot and point lights are: 

Constant�� : Behaves the same as Poser 7 and earlier 
lights. This setting is predictable and controllable. The 
Start Distance and End Distance parameters are very 
useful for setting how close or far the light reaches.

Figure 12.14. Constant Attenuation.

Figure 12.15. Constant Attenuation with Tone Mapping.

Inverse Linear�� : Use this option for lights that are 
more physically correct. Objects that are close to the 
light source are infinitely brighter (not exponentially, but 
linearly). In other words, of Object B is twice the distance 
from the light as Object A, then Object B receives half as 
much light as Object A. This option allows some artistic 
freedom without being as touchy as Inverse Square 
(described next).

Figure 12.16. Inverse Linear Attenuation
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Figure 12.17. Inverse Linear Attenuation with Tone Mapping

Figure 12.18. Inverse Linear Attenuation with Tone Mapping, Adjusted

Inverse Square�� : This option provides physically 
correct lighting that is more dramatic, and harsher than 
Inverse Linear. The light brightens exponentially as you 
get closer to the light source. If Object B is twice the 
distance from the light as Object A, it receives 1/4 the 
amount of light.

Figure 12.19. Inverse Square Attenuation

Figure 12.20. Inverse Square Attenuation with Tone Mapping

Figure 12.21. Inverse Linear Attenuation with Tone Mapping, Adjusted
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Light Parameters
Be sure to select the light you wish to work with before using the 
parameter dials to avoid accidentally changing settings for the 
wrong light. Once you’ve adjusted a light the way you want it, you 
can use the Lock Actor command (see Lock Actor on page 151﻿) to 
prevent accidental changes. Lights have the following parameters, 
available in the Parameters palette:

Figure 12.22
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Angle Start/End (Spotlight Only)
The Angle Start and Angle End values allow you to specify how 
a spotlight’s light “falls off” as you approach the edge of the cone 
of light projected by the spotlight. The Angle Start parameter 
specifies the amount of light (in percent) present at the start of 
the cone of light projected by the spotlight, and the Angle End 
parameter specifies the percentage of intensity present at the 
cone’s end.

Distance Start/End (Spotlight Only)
As you know, light fades with distance from its source. The 
Distance Start and Distance End parameters specify the 
distance from the light source (in grid units) where the spotlight’s 
intensity begins to drop (fall off), and the distance in grid units 
when the spotlight is no longer casting light, respectively.

Shadow
Poser lights can cast shadows, if you enable this option using the 
selected light’s Cast Shadow property in the Properties palette 
as described above. Shadows add depth, realism, and dramatic 
effects to your still or animated scenes. To change the cast of a 
light’s shadow, move the light.

Spotlights cast shadows based on the spotlight’s angular range, 

meaning that tighter spotlights produce cleaner shadows. By 
contrast, infinite lights adjust the view to fill the screen with all 
objects that cast shadows. Because of this, if you render a close-up 
of a scene with many figures and/or props (especially widely spaced 
items), the shadow map will not contain much information.

Each light has a shadow camera, available using the 
Current Actor pull-down menu. Advanced users can aim these 
cameras as desired. Each light’s shadow map contains shadow 
information for the scene as viewed through that light’s 
shadow camera.

The shadow-related parameter dials are:

Shadow: •	 Use the Shadow parameter dial to specify the 
selected light’s shadow strength. A setting of 0 disables cast 
shadows for the selected light, while a setting of 100% casts a 
dark shadow. You can animate shadow strength over time.

Map Size: •	 The Map Size parameter dial sets the size of 
the selected light’s shadow map in pixels (shadow maps are 
square). Poser uses image maps to apply shadows to objects 
in the scene, and applies these shadows during rendering. 
Larger map sizes increase the accuracy and detail of shadow 
maps, but at a cost in memory and render time. For example, 
each 1024x1024 map requires about 4MB of space, while 
a 2048x2048 map requires 16MB. You cannot animate the 
shadow map’s size.
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XYZ Rotation
Adjusting these dials adjusts the direction in which the light 
is pointing. For example, think of the sun’s path across the sky 
throughout the day and how it appears farther north or south 
with the changing of seasons. When the xRotate and yRotate 
dials are set to 0 degrees, the light aims at the Poser workspace 
from the front. ZRotate is only significant when the xRotate and 
yRotate settings are not 0,0 or 180, 180. In all cases, the figure is 
in the default position:

xRotate•	 : The xRotate parameter rotates the selected light 
about the X axis.

yRotate•	 : The yRotate parameter rotates the selected light 
about the Y axis.

zRotate•	 : The zRotate parameter rotates the selected light 
about the Z axis.

Scale
The Scale parameter dial allows you to scale a light’s indicator. This 
does not affect the light itself.

Red, Green, Blue
The Red, Green, and Blue dials specify the amount of each of 
the three primary colors to add to a light’s final color. A value of 
1 means that the selected color is fully added, and 0 means that 
color is not included at all. Using these three primary colors to 
create a final color is called RGB lighting (Red, Green, Blue). Each 
of the three colors can have 256 values ranging from 0 to 255. This 
gives us 256 red, 256 green, and 256 blue shades to work with, 
or 256^3 (16,777,216) total possible colors. Parameter dial values 
correspond to RGB values as follows:

Parameter dial 0 = RGB color value 0 for the selected color.•	

Parameter dial 1 = RGB color value 255 for the selected color.•	

Intensity
You can control your light’s intensity using the Brightness control 
or the Intensity parameter dial. A setting of 0% means the light is 
fully off, and a setting of 100% means the light is completely on (at 
full brightness/intensity).
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XYZ Translation (Spotlight Only)
The Translation dials allow you to specify a spotlight’s precise 
location in 3D space by specifying grid coordinates. As previously 
described, spotlights emit light from their location in 3D space, 
meaning that objects “behind” the light are not illuminated.

Saving & Loading Light Sets
You can save light sets to the Library, allowing you to reuse them 
in later scenes. Light sets have the file extension *.LT2 and are 
saved to the Lights Library. Please refer to Maintaining Your Library 
Palette on page 113 for information about adding items to the 
Library palette.

Animating Lights
Lights can be animated like other Poser objects using keyframes 
and tween frames. Please see Chapter 21: Animating with Poser on 
page 311 for information about animating within Poser. 
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Chapter 13: The Material 
Room
Poser’s Material room is a very powerful tool for creating and 
editing procedural shaders. The Material room is designed from 
the ground up to provide the ultimate in power, flexibility, and 
ease of use by artists and animators. You don’t need to be a 
programmer! The Material room gives you ultimate control over 
the appearance of your Poser scenes.

The Material room allows you to describe the material properties 
of your objects’ surfaces by giving you full control over every aspect 
of shading a surface, from the surface color to complex lighting 
interactions. In this chapter we will explore the Material room’s 
basic building blocks. For a more detailed look at working with 
shaders and nodes in the Material room, please refer to Chapter 
14: Working with Nodes on page 222  and Chapter 15: Material 
Room Nodes on page 232. 

Access the Material room by clicking the Material room tab at 
the top of the Poser workspace. The Material room appears as 
follows:

Figure 13.1

The number of palettes and options that you see in 
each room depends upon your screen resolution. At higher 
resolutions, the default work spaces display more palettes, 
while at lower resolutions you see fewer palettes:

The Material room offers two options for working with surface 
materials: the Simple and Advanced view tabs. By default, the 
Simple view of the Material Room is displayed when you first 
start up Poser. This allows new users to get familiar with editing 
Materials before diving into the Advanced settings of the Material 
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Room. The Simple tab is actually a less complex front-end for the 
Advanced tab, and allows users to apply and modify materials 
by means of a few basic controls. For more advanced users, 
the Advanced tab offers a powerful tool for defining material 
properties using shaders and nodes. 

Poser’s Material room contains the following items at 1280 x 960 
resolution. Less items will appear at lower resolutions, and more 
options will appear at higher resolutions:

•	 Eyedropper Tool (1): The Eyedropper tool appears 
with the Editing tools. Enabling it and clicking an object in 
your scene opens that object’s shader tree for editing in the 
Shader window.

Document Window (2)•	 : Please refer to Chapter 5: The 
Document Window on page 61 for information about the 
Document window.

Light Controls (3)•	 : Please refer to Chapter 12: Lighting on 
page 186 for information about the Light controls.

Object List (4)•	 : The Object List functions similarly to the 
Current Actor menu and has the following options: Props 
(includes strand-based hair and dynamic cloth), Lights, 
Figures, and Background.

Current Material List (5)•	 : The Current Materials list 
displays all of the material groups in the currently selected 

figure/prop. Poser organizes materials by figure/prop, thereby 
avoiding confusion when assigning materials and allowing 
you to, for example, assign different eye or skin colors to each 
figure. This method of handling materials is referred to as 
multi/sub-object materials and is discussed in more 
detail in the Poser Tutorial Manual, Chapter 5: Multi/Sub-object 
Materials on page 21.

Material Room Help (6)•	 : The (?) icon at the top right 
of the Shader window opens the Material room Help 
document. This HTML document contains information about 
using nodes and shaders to define surface material attributes.

Options pop-up menu (7)•	 : The Options pop-up menu 
is available from the Advanced tab of the Shader window, 
allows you to add, cut, copy, paste, select, and deselect nodes. 
For convenience, this can be also accessed by right-clicking 
within the Advanced tab.

•	 Shader Window (8): The Shader window contains two 
tabs, for Simple or Advanced Material definition techniques. 
The Simple tab allows you to easily modify various attributes 
of your selected material, including Diffuse Color, Highlight, 
Ambient, Reflection, Bump and Transparency. The Advanced 
tab is where you build shaders, which consist of a root 
node and as many connected nodes as you want. Nodes 
can modify other nodes or the root node. Please refer to 
Chapter 14: Working with Nodes on page 222 and Chapter 
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15: Material Room Nodes on page 232 for more information 
about working with shaders and nodes.

•	 Wacro Drawer (9): The Wacro Drawer allows you 
to select from ten predefined shortcuts that cover various 
material setup tasks. For more information about the Wacro 
Drawer, please refer to the description of the Advanced 
Shader View later in this chapter.

Library Palette (10)•	 : Please refer to Chapter 2: Installing 
Poser on page 11 for information on working with the 
Library palette.

Parameters/Properties Palette (11)•	 : Please refer to 
The Parameters/Properties Palette on page 135 for information 
about the Parameters/Properties palette.

Animation Controls (12)•	 : Please refer to Using the 
Animation Controls on page 314 for information about the 
Animation controls.

Navigating the Shader Window
The question mark at the top right corner of the Shader window 
opens the Material Room Workflow help page. This document 
provides information on creating and connecting shader nodes, 
frequently used nodes, and advanced material attributes.

Simple Shader View
The Simple tab of the Shader window provides you with easy to 
use controls for adjusting various material attributes. Each of these 
attributes, and how they can be modified, are discussed in detail 
below. For all attributes in the Simple tab, clicking in the Texture 
Preview Slot will bring up the Texture Manager dialog. Here 
you can preview and select a previously used image map from the 
pop-up list, or browse for a new map. Note that when accessing 
the Texture Manager from the Simple tab, you have the ability 
to select both images and movies. In the Advanced tab, the image 
and movie nodes are separate, so the Texture Manager enables 
you to select one or the other depending on which node you are 
using. Click the OK button to load the image map. A preview 
of your selected map should appear in the appropriate texture 
preview slot of the Simple tab. The Map Strength dial adjusts 
the degree to which that image map affects the surface material. 
Note that the Map Strength dial directly controls the texture 
strength parameter on the image map nodes, which can be seen on 
the Advanced tab. For more information about using and creating 
various types of image maps, please refer to the Poser Tutorial 
Manual, About Maps & Templates on page 22. 
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Figure 13.2

The image map pop-up list in the Texture Manager provides a 
historical list of path names for previously used image maps 
and movies. This list facilitates quick image selection; it does not 
indicate that these files are currently loaded into memory.

Figure 13.3

A Caution symbol (exclamation point in a triangle) will appear 
at any point when the surface attributes you are working with 
are too complex to be edited in the Simple tab. For example, this 
would be the case if a procedural shader node were attached to the 
diffuse color input. Whenever the Caution symbol appears, it is an 
indication that you need to use the Advanced tab for full access to 
this attribute’s configuration parameters. Click the Caution symbol 
to switch to the Advanced tab.
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Figure 13.4

Diffuse Color

The Diffuse color is the primary surface color of the current figure 
or prop. If there is no texture map applied to the figure, the Diffuse 
color will be the figure’s only color (not considering the effect of 
any colored lights). In a high quality rendering, when a texture 
map is loaded the Diffuse color tints the texture map. If you don’t 
want the texture map to be affected by the Diffuse color, leave the 
Diffuse color set to white (the default color).

Figure 13.5

To change the Diffuse color, click on the Color Slot at the top 
of the Diffuse component area. This will bring up the Poser Color 
Picker, where you can select your desired color. If you wish to 
access the system Color Picker, simply click on the RGB bar at the 
top right corner of the Poser Color Picker.
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Figure 13.6

If you choose to have highlights on a textured surface, you might 
want to consider using the same map for Highlights as for Diffuse. 
When you have a texture map applied to the Diffuse component, 
pressing the Apply texture to highlight button will also apply 
the same texture map to the Highlight component. If you have a 
different texture map already loaded for the Highlight component, 
checking this box will override it and apply the texture map from 
the Diffuse component.

Highlights

The Highlight component corresponds to the Specular root 
nodes on the Advanced tab, and controls the object’s highlight. 
Highlights are bright areas appearing where the light is reflected 
directly toward the camera. You can select a highlight color, apply 
a texture map, and adjust the texture map strength, as described 
above. In daylight and under most room lights, highlights are white. 
To complement the lighting environment you’ve set, select a color 

similar to your main light.

Figure 13.7

The Highlight Size dial allows you to determine the size and 
intensity of your material’s specular highlights. Smooth surfaces 
have sharper specular highlights, whereas rougher materials should 
have softer highlights. On the dial, higher values result in larger, 
softer highlights for a duller, more matte effect, and lower values 
result in smaller, sharper highlights for a shiny, more polished effect.
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Ambient

In Poser, you can set the Ambient color for each figure or object 
individually. An object’s Ambient color is the color it emits equally 
in all directions. It simulates an ambient (overall room) lighting 
contribution. Unlike the other color properties, it acts without 
taking into account any light positions or colors. In other words, 
even if all other lights are turned off, the material will continue to 
emit the Ambient color. Thus, using an Ambient color on a surface 
can reduce the effect of shadows on that surface.

Figure 13.8

The Ambient color mixes with the other lighting properties. Too 
much ambience flattens the detail of an object, because it looks 

the same regardless of how the surface interacts with lights in 
the scene. If you want to turn ambient light down or off, set the 
Ambient color to gray or black. If you want more intense ambient 
light, set the Ambient color to white or a bright color. Loading an 
image map into the Ambient component will cause that image to 
function in the same way as an Ambient color. The Ambient color 
selection, texture map selection, and Map Strength control all 
function as described above.

Reflection

Reflection makes a figure or object direct light back at its source, 
giving it a reflective appearance. Poser offers two methods for 
applying Reflection to your scene. The first is to use a Reflection 
map, which is a 2D texture applied to a virtual sphere that 
surrounds your Poser workspace. The texture is then reflected 
from the workspace and onto your object. This method is best 
for scenes requiring subtle reflections, as it renders much quicker 
than raytracing, but results in somewhat less accurate reflection 
calculations. The other method is to use Raytraced Reflection, 
which is calculated using the raytracing rendering technique. This 
method is ideal for scenes containing objects with highly reflective 
qualities, such as chrome or mirrors, as raytracing yields extremely 
accurate reflections. However, using this method will increase your 
render times.
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Figure 13.9

Reflective Color is a tint that is added only when a Reflection map 
is applied. Use the Reflective Color option to create dramatic 
effects in your renderings. To make a highly reflective object appear 
more vivid, use a variation of the object’s color. If the object’s 
color is particularly bright, you may want to use a darker tint of 
the same color. For an unusual tint, use a color that is distinctly 
different from the object’s color. The Map Strength dial adjusts 
the Texture Strength parameter on the Reflection map node on 
the Advanced tab, and determines to what degree the Reflection 
map will affect the material.

The Multiply with Lights / Object color checkboxes directly 

control the Reflection Lite Mult and Reflection Kd Mult 
checkboxes on the Advanced tab. For more information about 
these options, see Root Material (PoserSurface) Node on page 232.

Bump

A Bump map is a special image, wrapped around the object, 
that works with the scene lighting to give the appearance of 3D 
texture on an otherwise smooth object. Bump maps can be used 
on individual objects or parts of a figure to emulate any manner 
of textures, from wrinkles and pores in skin, to raised patterns in 
clothing or props, to cracks and bumps in stone.

Figure 13.10
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You can load Bump maps using the texture preview slot and the 
Texture Manager, and adjust the Bump map strength with 
the Map Strength dial, as described above. The Amount dial 
specifies the amount of Bump, in units specified in the General 
Preferences dialog. Higher values yield more Bump effect, or 
rougher surfaces, while lower values yield less Bump and smoother 
surfaces. The Amount dial corresponds directly to the Bump 
attribute on the Advanced tab.

Note that Bump maps simply disturb an object’s normals. Thus, if 
you apply a Bump map to a sphere, the surface will seem rough 
while the edges remain smooth. Poser’s Material room contains 
a Displacement channel, which allows you to use Bump maps to 
actually alter the geometry of the surface. For example, applying 
a Displacement map to a sphere would make the edges appear 
rough, as well as the surface. The Displacement checkbox 
in the Bump attribute enables the Displacement attribute 
on the Advanced tab, replacing the Bump effect with actual 
Displacement. With Displacement enabled, the Amount dial 
specifies the amount of Displacement rather than the amount of 
Bump.

 For more advanced users, adding a Normal Map can add 
yet more realistic surface details.

Transparency

Transparency allows light to pass through a figure or object, so you 
can see through it. The higher a transparency value, the more of 
the surrounding environment is visible through the object’s surface. 
If no light is reflected on an object, 100% Transparency and Edge 
settings make it invisible.

Figure 13.11

When a Transparency map is applied to an object, its texture 
interferes with the transparency of the object. For example, 
a checkerboard map results in an object that is alternately 
transparent and solid. You can thus use textures as Transparency 
maps.
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The Transparency, Edge, and Falloff dials work together to 
determine how an object’s transparency behaves. 

The Transparency dial affects the transparency of the part of 
the object facing the camera, particularly toward the center of the 
object. Higher Transparency values yield greater transparency.

The Edge dial affects the transparency of the object’s edges 
specifically. A high Edge value makes the object very transparent 
on its edges. For most renderings, you’ll want to use a Transparency 
value that is higher than the Edge value.

The Falloff dial determines the rate at which the transparency 
becomes more opaque as you approach the edges of an object. 
For a real world example, look at a transparent object such as a 
drinking glass. The edges of the glass are less transparent than the 
rest of the surface. This is where the transparency of the glass “falls 
off”. In Poser, you can vary this falloff behavior. A smaller value 
renders a sharper edge appearance, while a larger value renders a 
more gradual falloff. If the Transparency and Edge values are the 
same, there is no falloff in the rendering.

Normal Maps

A normal map is an image, wrapped around the object that works 
with the scene lighting to give the appearance of 3D texture on an 
otherwise smooth object. Normal maps can be used on individual 
objects or parts of a figure to emulate any manner of textures, from 
wrinkles and pores in skin, to raised patterns in clothing or props, to 

cracks and bumps in stone.

Note that normal maps simply replace an object’s normals. Thus, if 
you apply a normal map to a sphere, the surface will seem rough 
while the edges remain smooth. Poser’s Material room contains 
a Displacement channel, which allows you to use displacement 
maps to actually alter the geometry of the surface. For example, 
applying a displacement map to a sphere would make the edges 
appear rough, as well as the surface.

To load a Normal Map, from the Material Room > Material 
Palette, Advanced tab, connect the Image Node containing 
a normal map to the Gradient Bump channel on the Poser 
Surface Node. The channel value controls how much influence the 
normal map has on the surface. Higher values yield more effect, or 
rougher surfaces, while lower values yield less effect and smoother 
surfaces.

Next, select the type of normal map from the Gradient_Mode 
pull-down menu according to how the normal map was exported 
from the application it was created in. Select from the following 
options.

Normal Map (tangent space)•	

Normal Map (object space)•	

Gradient Bump•	 —Legacy option for Poser gradient bump 
maps.
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Figure 13.12

Figure 13.13

Advanced Shader View
The Advanced tab of the Shader window is where you build 
shaders by working with nodes. Please refer to Chapter 14: 
Working with Nodes on page 222  and Chapter 15: Material Room 
Nodes on page 232 for more information about shader nodes and 
how they function within Poser.
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Figure 13.14

The Shader window’s Advanced tab contains the following 
elements:

Object menu (1)•	 : The Object menu functions similarly 

to the Current Actor menu and has the following options: 
Props (includes strand-based hair and dynamic cloth), Lights, 
Figures, and Background.

Material menu (2)•	 : The Material pull-down menu lists all 
of the materials available for the currently selected actor. Poser 
uses Multi/Sub-object materials, which means you will only see 
the materials assigned to the currently selected figure/prop in 
this menu. Please refer to the Poser Tutorial Manual, Chapter 
5: Multi/Sub-object Materials on page 21 for information 
about Multi/Sub-object materials.

Options Menu (3)•	 : Clicking the arrow on the right side of 
the Shader menu opens the Options menu for the Material 
room, which is described in Chapter 14: Working with Nodes 
on page 222 and Chapter 15: Material Room Nodes on page 
232﻿. You can also open this menu by right-clicking in any 
blank area within the Shader window or by clicking any node 
input (see Chapter 14: Working with Nodes on page 222﻿ and 
Chapter 15: Material Room Nodes on page 232).

Title Bar (4)•	 : You can reposition the Shader window using 
its title bar.

Wacro Drawer (5)•	 : The Wacro Drawer allows you 
to select from ten predefined shortcuts that cover various 
material setup tasks. See the “Wacros” section below for 
specific information on these shortcuts.
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Root Node (6)•	 : The root node for the currently selected 
object or material group appears on the left side of the 
Shader window.

Nodes (7)•	 : Additional nodes also appear in the Shader 
window.

Shaders
A shader is a combination of nodes working together to create 
the final desired color, pattern, and texture -- in short, the look 
for your 3D objects. Every shader consists of a root node with a 
different number of attributes depending on the type of root node 
(Background, Material/Hair, Light or Atmosphere) being used. 
Each of these attributes can have one or more linked nodes that 
dynamically controls that attribute’s value or color. You can either 
create materials from scratch or load a pre-made material. Saving 
a material saves that materials’ shader tree, and loading a material 
also loads its shader tree. Also, if you load a pre-made material, 
you can modify it at will to create a whole new look. Please refer 
to Root Nodes on page 232 for a detailed description of the root 
nodes.

Figure 13.15

Wacros
Wacros are easy-to-use scripts designed to complete specific tasks 
within the Material room. The Wacro Drawer comes with ten 
predefined Wacros, each of which accomplishes a basic material 
setup task or process--often with the click of a single button. You 
can save time by using Wacros for some of the more common tasks 
you might wish to undertake in the Material room. Wacros all act 
upon the root node for the selected object or material. For more 
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information on the various attributes on the root nodes, please see 
Root Nodes on page 232﻿. 

Poser also supports user defined Wacros, which you can write 
using Python scripting, and then place in the Runtime\Python\
poserScripts\Wacros\UserDefined folder within your Poser 
installation folder. Your Wacros will then appear in the User 
Defined pop-up menu. Please see Part 7: PoserPython on page 
517for more information about writing Python scripts for Poser. 

Figure 13.16

The following Wacros are included with your Poser installation:

•	 Add Reflection: Before clicking the Add Reflection 
Wacro button, make sure you have selected a material to 
which you want to add reflective attributes. When you click the 
Add Reflection button, Poser will attach the following nodes:
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A Reflect raytrace node will be attached to the input of ��
the Reflection_Color attribute on the root Material node. 
The Reflect node specifies the reflection color when 
raytracing. See Raytrace Nodes on page 253 for more 
information on the Reflect node’s attributes.

A BG Color node will be attached to the input of the ��
Background attribute on the Reflect node.

•	 Add Refraction: Before clicking the Add Refraction 
Wacro button, select a material to which you want to add 
refraction. Refraction causes light to bend as it passes from 
one transparent medium (material) to another; the degree to 
which this occurs depends on the material’s refractive index. 
Note that refraction only affects transparent materials, so the 
material you select must be made transparent for refraction 
to be visible. Click the Add Refraction button. If you have 
selected a material that is opaque, a dialog will appear asking 
whether you wish to make the material transparent and add 
refraction. Click Yes on this dialog to proceed. Poser will then 
add the following nodes:

A Refract raytrace node will be attached to the input of ��
the Refraction_Color attribute on the root Material node. 
The Refract node specifies the refraction color when 
raytracing. See Raytrace Nodes on page 253 for more 
information on the Refract node’s attributes. 

A BG Color node will be attached to the input of the ��

Background attribute on the Refract node. 

Set the Refraction_Value attribute on the root Material 
node to between zero and one, in order to see the 
refraction effect in your rendered image.

Refraction requires raytracing, so be sure to have 
raytracing selected when you render in order to see the 
refraction effect. We also recommend setting the number 
of raytrace bounces to at least two (or higher if you have 
reflective surfaces behind the transparent materials).

•	 Add Subsurface Scattering: Clicking the Add 
Subsurface Scattering Wacro button will configure all the 
lights in the scene to produce SubSurface Scattering effects. 
After you click the Add Subsurface Scattering button, you 
will see a dialog that states “The light(s): <lists the applicable 
lights> were set to produce Depth Map shadows.” Please 
note that for subsurface scattering all active lights will be set 
to produce depth map shadows. When you click OK on this 
dialog, Poser attaches the following nodes:

A Blinn specular node will be attached to the input of the ��
Alternate_Specular attribute on the root Material node. 
See Blinn on page 246 for more information on the Blinn 
node’s attributes.

A FastScatter node will be attached to the input of the ��
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Alternate_Diffuse attribute on the root Material node. 
See FastScatter on page 252 for more information on the 
FastScatter node’s attributes.

An Edge_Blend node will be attached to the input on the ��
FastScatter node. See Edge Blend on page 240 for more 
information on the Edge_Blend node’s attributes.

Additionally, the output on the Image_Map node (which ��
existed before you clicked the Add Subsurface Scattering 
button) will be connected to the input on the Inner_Color 
attribute of the Edge_Blend node.

•	 Set Up Shadow Catcher: Clicking the Set Up Shadow 
Catcher button will enable the ShadowCatchOnly option on 
the Poser Surface node of the selected material. This Wacro 
will turn the selected material into a shadow catcher, 
which means that it will become transparent except for areas 
that are shaded by another object, which will show only the 
shadow. One example of how you might use this Wacro is if 
you created a scene showing a figure on the stairs prop, and 
you wanted to hide the stairs in order to composite the figure 
onto a photograph of actual stairs. For more information about 
the ShadowCatchOnly attribute, and shadow catchers, see 
Root Material (PoserSurface) Node on page 232﻿.

•	 Set Up Toon Render: The Set Up Toon Render Wacro 
will configure your material to appear cartoon-like when 
rendered. Clicking the button opens a dialog asking whether 

you want to have specular highlights on your toon surfaces. 
Click either No or Yes on this dialog to proceed. Poser will 
then attach the following nodes:

A Toon diffuse node will be attached to the input on the ��
Alternate_Diffuse attribute of the root Material node. See 
Toon on page 249 for more information about the Toon 
node’s attributes.

Two additional links will be created from the output on ��
the material’s Image_Map node, to the inputs on the 
LightColor and DarkColor attributes on the Toon node.

If you clicked Yes on the initial dialog, a Glossy specular ��
node will be attached to the input on the Alternate_
Specular attribute of the root Material node. See Glossy 
on page 246 for more information on the Glossy node’s 
attributes.

•	 Create Atmosphere: In order to view the effects of the 
Create Atmosphere Wacro, you need to have something in 
the background of your scene, such as a background plane 
or additional figures or props. Then, select Atmosphere from 
the Object menu at the top of the Shader window. Clicking 
the Create Atmosphere button opens the Choose an 
Atmosphere dialog. Select the type of atmosphere you 
wish to create, from the following options: Fog, Smoke, 
SmokeyRoom, Depth_Cue. Then click OK. Poser will add 
the appropriate nodes to create the atmosphere you have 
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selected. If you wish to know more about any of the specific 
nodes added, see Chapter 15: Material Room Nodes on page 
232﻿. Render your scene to view the atmosphere effects.

•	 Set Up Light Style: The Set Up Light Style Wacro 
allows you to specify the style of light you wish to apply to 
a particular light. First, select the light you wish to configure 
from the Object menu at the top of the Shader window. Then 
click the Set Up Light Style button. The Select a light 
style dialog will appear, asking you to select a light style from 
the following options: diffuse only, specular only, white only. 
When you have made your selection, click OK. You will see a 
message confirming that the light(s) you had selected have 
been set to the light style you specified. Depending on the 
light style you selected, you will see the following effects:

If you selected diffuse only, the Diffuse attribute on the ��
root Light node will be set to white, and the Specular 
attribute will be set to black.

If you selected specular only, the Specular attribute on ��
the root Light node will be set to white, and the Diffuse 
attribute will be set to black.

If you selected white only, the Color, Diffuse and Specular ��
attributes on the root Light node will all be set to white.

•	 Set Up Ambient Occlusion: Clicking the Set Up 
Ambient Occlusion button will create an Ambient_Occlusion 

raytrace node, the output of which is attached to the inputs of 
the Diffuse_Value and Specular_Value attributes on the root 
Material node. See Ambient Occlusion on page 254 for more 
information on the Ambient_Occlusion node’s attributes.

•	 IBL (Image Based Lighting): The IBL Wacro can only 
act upon lights, so make sure you have selected a light from 
the Object menu at the top of the Shader window, before 
using this Wacro. Clicking the IBL button will open the 
Texture Manager, which asks you to select a texture for the 
Image_Map node. 

Poser allows you to connect shader trees of any level of 
complexity to your Image Based Light; the IBL Wacro, 
however, is set up to use a single light probe image as 
an image map. Light probes are panoramic images that 
can record light levels from a 360 degree perspective, 
and are typically created by taking a high-dynamic range 
image of a mirrored sphere. Once you have selected your 
light probe image in the Texture Manager, click OK. 
Poser will attach an Image_Map node using your light 
probe to the input of the Color attribute on the root Light 
node. For more information on the Image_Map node’s 
attributes, see Image Map on page 268﻿. For information 
about Image Based Lighting and light probes, see Diffuse 
Image Based Lights (IBL) on page 187﻿.

To maximize your Image Based Lighting effects, we 
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recommend using Ambient Occlusion. See Light Properties 
on page 194﻿ for information on activating Ambient Occlusion 
for the selected light.

•	 Remove Detached Nodes: Clicking the Remove 
Detached Nodes button will clear away any nodes on the 
currently selected material group whose outputs are not 
attached to at least one other node. This Wacro is particularly 
useful for cleaning up complex shader trees, where the sheer 
number of nodes may make it difficult to see whether there 
are any detached nodes present in the Shader window.

Even if one or more nodes are attached to inputs on a 
given node, if that node’s output is not attached to another 
node, it will be removed by the Remove Detached Nodes 
Wacro.
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Chapter 14: Working with 
Nodes
This chapter describes how to perform various operations with 
nodes in the Shader window of the Material room. For a 
description of the Material room itself, please refer to Chapter 13: 
The Material Room on page 204.

About Nodes
A node is the basic building block used to construct simple or 
complex procedural shaders (also called shaders). All nodes have 
the following elements except where noted:

Figure 14.1

Output (1)•	 : After accepting and processing any inputs 
plus its own values, the end result is passed to the output for 
connection to another node’s input. Root nodes do not have 
this function.

Node Name (2)•	 : This is the name of the node. A number 
will appear when you have two or more of the same node in 
your shader, for example Clouds_2, Clouds_3, and so forth.
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Show/Hide Values Button (3)•	 : Clicking the Values 
button toggles displaying the node values (6) on and off.

Show/Hide Preview Button (4)•	 : Clicking the Preview 
button toggles displaying the node preview (9) on and off. 
Enabling previews gives you a great idea of how each step in 
your shader tree is contributing to the overall look, however 
this can increase required computing resources.

Node Values (5)•	 : This area shows the values that you can 
specify for the particular node.

Value Input (6)•	 : You can either input values directly in a 
node or connect one or more nodes to an input to modify the 
selected value.

Animation Toggle (7)•	 : Clicking the Animation control 
toggles animation on and off for the selected value.

Preview (8)•	 : This displays a preview of the node’s output.

If you are running OpenGL hardware acceleration, you 
may be able to view the results of your procedural shaders 
in the Document window’s Preview tab, to give you a better 
sense of how your rendered scene will appear. For more 
information previewing procedural shaders, please see 
Preview Tab on page 281﻿.

The Material Room Options 
Menu
You can access the Options menu in one of four ways:

Clicking the •	 Options menu arrow at the top right corner of 
the Shader window.

Clicking either mouse button on a node’s input. In this case, •	
the Options menu will only have the New node option 
available and may (depending on the input) have quick access 
options for appropriate nodes to connect to the selected input.

Clicking either mouse button on a node’s output.•	

Right-clicking any blank area in the •	 Shader window.

The Options menu, which varies depending on how it was 
accessed, has the following options:
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Figure 14.2

Disconnect•	 : Selecting Disconnect disconnects the current 
link between the affected node’s input and all shader(s) 
contributing to that input. This option will appear when you 
click a node input with one or more links.

New node•	 : Selecting New node creates a new node. 
Please refer to the following section for more information 
about creating nodes.

Cut•	 : Selecting Cut places a copy of the selected node(s) into 
the Clipboard and deletes the originals from the Shader 
window along with any existing links between the cut nodes 
and others. This preserves any links that exist between the 
copied nodes.

Copy•	 : Use the Shift key to select multiple nodes and/or the 
full rote node to copy into the clipboard. Selecting Copy 
places a copy of the selected node(s) into the Clipboard 
without removing the originals from the Shader window 
without altering their relationships with other nodes. This 
preserves any links that exist between the copied nodes but 
does not copy links between the copied nodes and other 
nodes. In conjunction with the Paste command (see below), 
this is a great way to propagate your shader trees (or any 
portions you like) from shader to shader, thereby allowing you 
to save time by leveraging previous work.

Paste•	 : Selecting Paste places a copy of the node(s) stored in 
the Clipboard into the Shader window.

Delete•	 : Selecting Delete selected nodes deletes all 
selected node(s). Any links to or from deleted nodes are also 
lost, meaning you will need to reestablish broken connections. 
Please refer to Linking Nodes on page 227 for information on 
linking/de-linking nodes.

Apply selected•	 : Selecting Apply to all... applies all 
selected nodes to all materials groups in the current object. 
This overrides existing connections in affected material groups 
but does not delete any nodes.

Select All•	 : Selecting Select All selects all nodes in your 
shader, including the root node.
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Invert Selection•	 : Selecting Invert Selection selects all 
unselected nodes and deselects all selected nodes. In essence, 
this function reverses your selection.

Material Room Node 
Connections
The Advanced view of the Material room uses a plug system to 
connect nodes together. Node inputs typically appear on the right 
side of a node’s palette, and the node output typically appears in 
the upper-left corner of the node palette.

Figure 14.3

You can link nodes to other nodes, thereby controlling one node’s 
input with another node’s output. This interaction between nodes 
is at the heart of the Material room’s functionality and provides 
nearly infinite flexibility. Node interaction works by plugging values 
or colors from one node into another. Although only one node’s 
output can be connected to another node’s input at the same time, 
there is no theoretical limit to how deep these interactions can 
go. Available memory and CPU speed will play a role in setting 
practical limits.

Figure 14.4



Poser 8
Reference Manual 

226

Chapter 14: Working with Nodes

Selecting Nodes
To select a node, simply click any blank area within the desired 
node. To select multiple nodes, press and hold Shift while making 
your selections.

Creating Nodes
Creating additional nodes is the first step to creating your own 
shader tree (remember that all shaders have at least a root node). 

To create a node, use one of the following methods:

To create a new node anywhere in the advanced Material •	
view, right click in the material view and choose New Node 
> Category > Subcategory > Node. Then connect the new 
node to the locations you desire.

Figure 14.5

To create an instance of the node that is currently selected in •	
the Shader window, open the Options menu and select New 
Node > Category > Subcategory > Node. Connect the 
new node as desired.
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Figure 14.6

To create a new node that is automatically connected to •	
a node input, click the desired node input to display the 
Options menu. Alternatively, you can drag from a node’s 
input to an open area in the view will pop up the new node 
menu. Your new node will appear with its output already 
linked to your current node’s input. If you access the Options 
menu in any other manner (see above), the new node will not 
be linked.

Linking Nodes
After creating a node, you may need to link it to an input on 
another node. This is accomplished in one of three ways:

Direct Link•	 : Click the output of the node you wish to link 
and drag the cursor over the node or shader input you wish to 
link to. Release the mouse button to complete the link.

Figure 14.7

Moving Existing Links•	 : To move a link from one node to 
another, click the input you want to unlink and drag the cursor 
off the node. Place the cursor over the input node you wish to 
link and release the mouse button.
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Figure 14.8

Clicking and dragging:•	  Click the input you wish to 
connect a new node to and drag. A node connection will 
appear. When you release the mouse button, the Options 
menu will appear, allowing you to create a new node whose 
output is pre-connected to your selected input.

Figure 14.9

You can link a node to as many other nodes as you wish and each 
node input can be linked to as many input nodes as you wish.

De-Linking Nodes
To break the link between two nodes, click the input you want to 
unlink and select Disconnect in the Options menu.

Expanding/Collapsing Nodes
You can expand and collapse a node’s values and/or preview 
separately, as described in the previous section.
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Moving Nodes
You can move and arrange nodes to suit your particular work 
style. A node’s position has no effect on the shader’s function or 
appearance. To move a node or nodes:

Select the node(s) you want to move as described above.1.	

Hold the mouse button down and drag the node(s) to the 2.	
desired position. Release the mouse button to complete the 
move.

Entering Node Values
To enter a value for a node, click the desired value to open a 
small window with a value field and a parameter dial. Here, you 
can enter a numeric value in the field and/or move the parameter 
dial using the mouse. You can also link one or more nodes to 
the desired value (see below), which will make the appropriate 
adjustments.

Figure 14.10

Some node values are pull-down menus. Use these as you would 
any other pull-down menu. 

Figure 14.11

Also, clicking a color within a node opens a standard Color Picker, 
which you can use to quickly select your desired color.

Figure 14.12
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Figure 14.13

Deleting Nodes
To delete a node, select the node you wish to delete and either 
press [DEL] or select Node>Delete.

Animating Nodes
You can animate node attributes by clicking the Animation 
Toggle (key icon) for the attribute you wish to animate. When 
animation is enabled, the icon appears green. When disabled, it 
appears clear. Clicking the Animation Toggle opens a pull-down 
menu with the following options:

Figure 14.14

Animated:•	  Selecting the Animation option toggles 
animation for the current attribute on or off. A check mark 
appears next to this menu item when animation is enabled, 
and vice-versa.

Info:•	  Each animated attribute has one or more Info options 
depending on the attribute. For example, a numerical node 
will have one Info option for its numeric value, while a 
color node will have three Info options (one each for red, 
green, and blue). Selecting one of these options allows you 
to set the current value, maximum and minimum limits, 
name, and sensitivity. This dialog is exactly the same as the 
Edit Parameter Dial dialog, which is discussed in Editing 
Parameter Dials on page 141.

Graph:•	  For each Info option that appears above, you will see 
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a Graph option. Selecting a Graph option opens the Graph 
palette for the selected channel. Please refer to Using Graphs 
on page 322 for more information about the Graph palette.

Once animation is enabled, you can animate the attribute’s value 
using any combination of the following methods:

Keyframes:•	  Move to a frame and set a value, then move to 
a different frame and set a new value.

Graph Palette:•	  Use the Graph palette to animate the 
node.

Other nodes:•	  Connect other nodes to control how the 
attribute changes over time.

Please refer to Chapter 21: Animating with Poser on page 311 for 
more information about animating within Poser.
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Chapter 15: Material Room 
Nodes
Poser includes the following nodes, which, combined and linked to 
root nodes, can create virtually any shader you can imagine. Nodes 
are divided into several groups: Math, Lighting, Variables, 
3D Textures, and 2D Textures. Each group and its shaders is 
discussed in the following sections:

Root Nodes
As previously mentioned, all shaders include a root node, which can 
be modified using added nodes that modify the root node. Thus, the 
root node is itself a complete shader. The Material room has four 
root nodes: Material, Background, Light, and Atmosphere. 
Let’s examine these nodes further.

Root Node Help
Some node attributes have a question mark (?) icon next to them. 
Clicking this icon opens help for that channel. This help is also 
available by navigating the Material room help window (available 
by clicking on the (?) icon at the top right of the Shader window, 

or by selecting Window > Room Help if the help pages are not 
already displayed in the Material room).

Root Material (PoserSurface) Node
The root Material node and root Hair nodes contain all of the 
attributes required to create a complete shader for almost every 
material group in your scene (figures, props, hair). They both have 
the following attributes:
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Figure 15.1: Visualizes direction of surface normal.

•	 Diffuse Color: The Diffuse_Color attribute is the surface 
color that is multiplied through any light striking the object.

•	 Diffuse Value: The Diffuse_Value attribute defines the 

strength of the diffuse color, where 1=100%.

•	 Specular Color: The Specular_Color attribute defines the 
color of the object’s highlight.

•	 Specular Value: The Specular_Value attribute defines the 
strength of the specular color, where 1=100%.

•	 Highlight Size: The Highlight_Size attribute defines the 
quantity of micro-facets on the object surface. Micro-facets 
are tiny imperfections that are invisible to the human eye, yet 
effect the way light is reflected off the surface. Very smooth 
surfaces (such as glass) have very few imperfections and 
produce a very sharp specular highlight. Surfaces such as 
paper have extremely high numbers of imperfections in their 
surface and thus produce subtler specular highlights.

•	 Ambient Color: The Ambient_Color attribute defines 
the color that a surface has when it receives no light. This can 
be used to simulate overall ambient light or to create self-
illuminating surfaces. Note that the ambient color of a surface 
will also bounce off other surfaces when rendering with 
indirect light enabled.

•	 Ambient Value: The Ambient_Value attribute defines the 
strength of the ambient color, where 1=100%.

•	 Transparency: The Transparency attribute defines the 
object’s opacity, where 1=fully transparent.



Poser 8
Reference Manual 

234

Chapter 15: Material Room Nodes

•	 Transparency Edge: The Transparency_Edge attribute 
defines the object’s transparency at its edges. For example, a 
glass appears opaque at its edges.

•	 Transparency Falloff: The Transparency_Falloff 
attribute defines how the transparency changes as it moves 
towards the object edge. Smaller values create a sharper edge 
and vice versa.

•	 Translucence Color: The Translucence_Color attribute 
is the color of light passing through the object.

•	 Translucence Value: The Translucence_Value attribute 
defines the strength of the translucent color, where 1=100%.

•	 Reflection Color: The Reflection_Color attribute allows 
you to specify a reflective color. This is a good input for 
connecting other nodes to control reflections.

•	 Reflection Value: The Reflection_Value attribute defines 
the strength of the reflective color, where 1=100%.

•	 Refraction Color: The Refraction_Color attribute 
defines the color of light refracted by the current object.

•	 Refraction Value: The Refraction_Value attribute 
defines the strength of the refraction color, where 1=100%.

•	 Bump: The Bump attribute defines the amount of bump in 

the material. See the Poser Tutorial Manual, Bump Maps on 
page 23 for information about bump.

•	 Displacement: The Displacement attribute defines the 
amount of displacement in the material. See the Poser Tutorial 
Manual, Displacement Map on page 25 for information about 
displacement.

•	 Alternate Diffuse: The AlternateDiffuse attribute 
provides an alternate input for diffuse lighting. Use this 
channel for strand-based hair and anytime you wish to use 
custom diffuse lighting.

•	 Alternate Specular: The AlternateSpecular attribute 
provides an alternate input for specular lighting. Use this 
channel for strand-based hair and anytime you wish to use 
custom specular lighting.

•	 Reflection Lite Mult: Checking the ReflectionLiteMult 
checkbox multiplies the total color through the amount 
of diffuse lighting hitting each point on the surface. This 
automatically darkens reflections in areas not seen by lights. 
On by default.

•	 Reflection Kd Mult: Checking the ReflectionKdMult 
checkbox automatically tints the reflection color by the 
surface’s diffuse color value. Off by default.

•	 Gradient Bump: Previous versions of Poser used a 
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proprietary file format for bump maps (*.BUM). If you want 
to use these older file types in Poser, connect an image map 
node to the Gradient_Bump attribute and load your desired 
*.BUM file into that node (see Image Map on page 268 for 
information on loading images). You cannot use *.BUM files 
with the FireFly renderer. The Gradient Mode option also 
allows you to select one of two types of normal maps.

•	 Gradient Mode:

�� Gradient Bump:

�� Normal Map (Tangent space):

�� Normal Map (Object space):

 For more information about normal maps, see Normal 
Maps on page 213.

•	 ShadowCatchOnly: Checking the ShadowCatchOnly 
checkbox allows transparent surfaces to catch shadows, as 
opposed to letting the shadows appear on the opaque surface 
behind them. In other words, this option will treat transparent 
surfaces as opaque, only in terms of their interaction with 
shadows. A prime use of this feature would be if you wish to 
render only a figure and its shadow; you could set up the floor 
as a transparent surface by using the ShadowCatchOnly 
feature to show your figure’s shadow on the transparent floor, 

and render (without the background). The floor will be invisible 
except for the shadow laying on it, so the only things in your 
rendered scene will be the figure and its shadow.

•	 ToonID: By default, selecting the Toon Outline option causes 
an outline to appear around each separate material on the 
figure or object. Depending on how the figure is setup, this 
may lead to too many outlines. In such a case, you can adjust 
the Toon ID assignment on the root node of the material, to 
reduce the number of outlines drawn. Assigning the same ID 
to multiple materials means that the render engine will not 
draw separating outlines between those materials.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

You must have a hair object selected in order to see its 
root node.

Root Background Node
The root Background node contains all of the attributes required 
to create a complete shader for your scene’s background and has 
the following attributes:
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Figure 15.2

•	 Color: The Color attribute allows you to choose the 
background’s base color.

•	 Diffuse Color: The Diffuse_Color attribute is the surface 
color that is multiplied through any light striking the object.

•	 Specular Color: The Specular_Color attribute defines the 
color of the object’s highlight.

•	 Highlight Size: The Highlight_Size attribute defines the 
size of the highlight.

•	 Bump: The Bump attribute defines the amount of bump in 
the material.

The final render will always display whatever is attached 
to the Color channel of the Root Background node. However, 
if you wish the same image or color to appear in the preview 
render, you must also attach it to the BG Picture or BG Movie 
node.

Root Light Node
A root Light node appears whenever you have a light selected. 
Each light in your scene has its own root Light node, which has 
the following attributes:

Figure 15.3

•	 Color: The Color attribute allows you to choose the light’s 
base color.

•	 Intensity: The Intensity attribute defines the light’s 
brightness.

•	 Angle Start: The AngleStart attribute defines the start of 
the light cone (in degrees) for spotlights.

•	 Angle End: The AngleEnd attribute defines the end of the 
light cone (in degrees) for spotlights.
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•	 Angle Expo: The AngleExpo attribute controls how the 
light fades towards the edge of the light cone (falloff).

•	 Diffuse: The Diffuse attribute allows you to create lights 
that use only a diffuse component to light the scene.

•	 Specular: The Specular attribute allows you to create 
lights that use only a specular component to light the scene. 
You can create specular only lights by setting the color in the 
specular channel to black. You can also create a negative 
light source (a light source that darkens or negates certain 
colors in the areas of the scene lit by this light) by setting the 
Specular value to zero (i.e., black) and setting the light’s 
Intensity to -1. Then the Color and Diffuse channels can be 
adjusted to reduce certain aspects of light.

•	 Image Resolution: The Image Resolution attribute 
specifies the width and height of the light probe to be 
sampled. You can attach a light probe of any size, and then 
adjust the resolution to suit your needs. Note that higher 
resolutions require more processing time, whereas with 
extremely low resolutions you will lose image quality. 256 is a 
reasonable default resolution for most light probe images.

•	 IBL Contrast: The IBL Contrast attribute allows you to 
modify the level of contrast in the incoming light probe image. 
The default value of 3 for this attribute is intended for use with 
Low Dynamic Range (LDR) images. For High Dynamic Range 

(HDR) images, the best IBL Contrast setting would be 1.

You must have a light selected in order to see its root 
node.

Root Atmosphere Node
The Root Atmosphere node contains all of the attributes required 
to create realistic atmospheric effects such as fog, haze, etc. in your 
scenes:

Figure 15.4

•	 DepthCue_On: Checking the DepthCue_On checkbox 
enables depth cueing, which varies all surface material colors 
from their original lit colors to the specified depth cue color 
(see below). This gives an effect similar to enabling the Depth 
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Cueing option in the Document window as described in 
Depth Cueing and Shadows on page 71.

•	 Volume_On: Checking the Volume_On checkbox enables 
volumetric effects. You can enable depth cueing and/or 
volumetric effects individually.

•	 DepthCue_Color: The DepthCue_Color attribute 
specifies the color to use when applying the depth cueing.

•	 DepthCue_StartDist: The DepthCue_StartDist 
attribute specifies the distance from the current camera at 
which the depth cueing effect begins. This distance is not 
necessarily displayed in Poser distance units.

•	 DepthCue_EndDist: The DepthCue_EndDist attribute 
specifies the distance from the current camera at which the 
depth cueing effect ends. This distance is not necessarily 
displayed in Poser distance units.

•	 Volume_Color: The Volume_Color attribute specifies the 
color of the volumetric effect. This color is multiplied with the 
color of the lights in your scene. To use the lights’ colors for 
the volume, set this color to white.

•	 Volume_Density: The Volume_Density attribute 
controls the strength of the volumetric effect. This effect is 
multiplied by each light’s Atmosphere Strength attribute. 
If this attribute is set to 1.0, the selected light will cast 

atmospheric effects equal to this attribute and so forth. Please 
refer to Light Properties on page 194﻿.

•	 Volume_StepSize: The Volume_StepSize attribute 
specifies the distance between rendering samples taken 
through the volume. Lowering this value increases the quality 
and requires increased render time.

•	 Volume_Noise: The Volume_Noise attribute adds a 
random factor added to the sample that can help balance out 
the effect of larger step sizes (see previous attribute).

You can connect nodes to the color and density attributes for more 
complex effects.

Figure 15.5: Without volumetric rendering (no fog) on left; With volumetric 

rendering (with fog) on right

Bright infinite lights can wash out volumetric effects 
unless you use a very low density. Volumetric effects are most 
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successfully used with both spotlights and carefully controlled 
density numbers. Also, Volumetric lighting effects only appear 
over a rendered object. They do not appear over an empty 
background, even when a background shader is in place. You 
need at least one object in on screen in order for volumetric 
lighting effects to be visible.

Math Nodes
These are the math nodes included with Poser. You will find them in 
the New Node > Math submenu. Unless specified otherwise, the 
list of attributes for each node is listed from top to bottom:

Blender
The Blender node blends two colors using a value attribute as an 
alpha mask. It has the following attributes:

Figure 15.6

•	 Input 1: The Input_1 attribute defines the first blend color. 
Clicking this attribute opens the standard Color Picker.

•	 Input 2: The Input_2 attribute defines the second blend 
color. Clicking this attribute opens the standard Color Picker.

•	 Blending: The Blending attribute is used to determine the 
amount of blending. Valid values are from 0 (Input 1 color 
only) to 1 (Input 2 color only).



Poser 8
Reference Manual 

240

Chapter 15: Material Room Nodes

Edge Blend
The Edge Blend node blends color nodes based on surface and 
camera angles. It has the following attributes:

Figure 15.7

•	 Inner Color: The Inner Color attribute defines the color 
of surfaces facing towards the camera. Clicking it opens the 
standard Color Picker.

•	 Outer Color: The Outer Color attribute defines the color 
of surfaces facing away from the camera. Clicking it opens the 
standard Color Picker.

•	 Attenuation: The Attenuation attribute defines the 
power curve used for transitioning between the inner and 
outer colors.

Component
The Component node is useful for extracting the red, green, 
or blue components from an input color. It has the following 

attributes:

Figure 15.8

•	 Component: The Component attribute specifies the color 
to extract. 0=red, 1=green, and 2=blue.

•	 Color: The Color attribute provides an input for another 
node, whose output will be processed according to the 
Component attribute setting.

•	 Point: The Point attribute provides an input for a point node 
whose output will be processed according to the Component 
attribute setting.

Math Functions
The Math Functions node is useful for mathematically merging 
values, nodes, and other parameters and can be used to create 
patterns. It has the following attributes:
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Figure 15.9

•	 Math Argument: This pull-down menu defines the math 
function to be used. Your options are:

�� Add: Selecting Add returns Value 1 plus Value 2.

�� Subtract: Selecting Subtract returns Value 1 minus 
Value 2.

�� Multiply: Selecting Multiply returns Value 1 times 
Value 2.

�� Divide: Selecting Divide returns Value 1 divided by 
Value 2.

�� Sine: Selecting Sin returns the sine of Value 1. Value 
2 is ignored.

�� Cosine: Selecting Cos returns the cosine of Value 1. 
Value 2 is ignored.

�� Tangent: Selecting Tan returns the tangent of Value 1. 
Value 2 is ignored.

�� Square Root: Selecting Sqrt returns the square root of 

Value 1. Value 2 is ignored.

�� Power: Selecting Pow returns the Value 1 to the 
Value 2 power (such as 33).

�� Exponential: Selecting Exp returns e to the exponent 
Value 1, Value 2 is ignored (such as eV1).

�� Logarithm: Selecting Log returns the natural log of 
Value 1, Value 2 is ignored.

�� Modulus: Selecting Mod returns the modulus 
(remainder) of Value 1 divided by Value 2.

�� Absolute: Selecting Abs returns the absolute value of 
Value 1. Value 2 is ignored.

�� Sign: Selecting Sign returns –1 if Value 1 is less than 
zero, and 1 if Value 1 is greater than or equal to zero. 
Value 2 is ignored.

�� Minimum: Selecting Min returns Value 1 if Value 1 is 
less than Value 2, otherwise Value 2 is returned.

�� Maximum: Selecting Max returns Value 1 if Value 1 
is greater than Value 2, otherwise Value 2 is returned.

�� Clamp: Selecting Clamp returns Value 1 unless Value 
1 is less than 0 or greater than 1. If Value 1<0, 0 is 
returned. If Value 1>1, 1 is returned. Value 2 is ignored.

�� Ceiling: Selecting Ceil returns Value 1 rounded up to 



Poser 8
Reference Manual 

242

Chapter 15: Material Room Nodes

the next whole number. Value 2 is ignored.

�� Floor: Selecting Floor returns Value 1 rounded down 
to the last whole number. Value 2 is ignored.

�� Round: Selecting Round returns Value 1 rounded to 
the nearest whole number. Value 2 is ignored.

�� Step: Selecting Step returns 1 if Value 1 is less than 
Value 2, and 0 if Value 1 is greater than or equal to 
Value 2.

�� Smooth Step: Selecting Smoothstep returns Value 
1 bicubically smoothed. Value 2 is ignored.

�� Bias: Selecting Bias adjusts the bias of Value 1 by 
Value 2.

�� Gain: Selecting Gain adjusts the gain of Value 1 by 
Value 2.

•	 Value 1: The Value_1 value defines the first value in the 
math equation.

•	 Value 2: The Value_2 value defines the second value in the 
math equation.

Color Math
The Color Math node performs the selected mathematical 
operation with two colors. It has the following attributes:

Figure 15.10

•	 Math Argument: Please refer to the previous node 
explanation, above, for a list of math arguments available in 
this pull-down menu.

•	 Value 1: The Value_1 attribute defines the first color value 
in the math equation.

•	 Value 2: The Value_2 attribute defines the second color 
value in the math equation.

User Defined
The User Defined node allows you to define a custom color. The 
Color Mode (bottom) attribute is a pull-down menu allowing you 
to specify your desired color model.   You can choose RGB, HSV, or 
HSL modes and enter the appropriate attributes in the three fields 
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above, as follows:

Figure 15.11

•	 Red: This attribute allows you to specify the first value:  Red 
(RGB) or Hue (HSV or HSL).

•	 Green: This attribute allows you to specify the second value:  
Green (RGB) or Saturation (HSV or HSL).

•	 Blue: This attribute allows you to specify the third value: Blue 
(RGB) or Value (HSV) or Lightness (HSL).

•	 Color Mode: This attribute allows you to specify the color 
mode that applies to the Red, Green, and Blue setting. Choices 
are RGB (Red, Green, Blue), HSV (Hue, Saturation, Value) or 
HSL (Hue, Saturation, Lightness.

Simple Color
The Simple Color node allows you to access a color picker to 
select a color. Clicking the color (Color attribute) opens the Poser 
Color Picker. To use your operating system’s Color Picker, press 

[OPT]/[ALT] while clicking the color or click the red-green-blue 
button in the top right of the Poser Color Picker.

Figure 15.12

Color Ramp
The Color Ramp node takes four colors and creates a spline color 
map (gradient) with them. You can feed grayscale output from other 
nodes (turbulence, wood, etc.) into this node to create interesting 
still or animated effects using the grayscale values as lookups 
into the color spline, providing a colorized version of the original 
grayscale image. It has the following attributes:

Figure 15.13

•	 Color 1 through Color 4: The Color_1 through Color_4 
attributes allow you to input colors for the color spline. 
Clicking them opens the standard Color Picker.
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•	 Input: The Input attribute is the grayscale value to lookup 
into the color spline. This is where you should plug in your 
grayscale images.

HSV
The HSV node allows you to adjust the Hue, Saturation, and/or 
Value of the Color input.

Figure 15.14

•	 Color: Allows you to specify the color source that you want 
to adjust.

•	 Hue: This attribute allows you to adjust the Hue of the Color 
input. A setting of 1 represents no adjustment. Increase or 
decrease the setting to offset the original hue.

•	 Saturation: This attribute allows you to adjust the 
Saturation of the Color input. A setting of 1 represents no 
adjustment. Increase or decrease the setting to offset the 
original saturation.

•	 Value: This attribute allows you to adjust the Value of the 
Color input. A setting of 1 represents no adjustment. Increase 
or decrease the setting to offset the original value.

Lighting Nodes
These are the light nodes included with the Material room. Unless 
specified otherwise, the list of attributes for each node is listed 
from top to bottom. The Light menu item has several sub-menus, 
each containing one or more nodes.

Specular Nodes
Specular nodes provide different models for calculating highlights 
on objects.

Anisotropic

The Anisotropic node allows you to create irregularly shaped 
highlights. It has the following attributes:
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Figure 15.15

•	 Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights lend 
the illusion of shininess. For example, a piece of wood displays 
no highlight, while a piece of polished metal has one or more 
distinct highlights. This color is generally the same as that of 
the direct lighting falling on the affected surface but does not 
have to be.

•	 Specular Value: The Specular_Value is the amount of 
influence the specular color has on the shader. A higher value 
will create larger, more distinct highlights and vice versa.

•	 U Highlight Size: The U_Highlight_Size attribute is the 
highlight’s size in the U direction.

•	 V Highlight Size: The V_Highlight_Size attribute is the 
highlight’s size in the V direction.

•	 Xdir_X: The Xdir_X attribute controls the size of the 
specular reflection relative to the X-axis.

•	 Xdir Y: The Xdir_Y attribute controls the size of the specular 
reflection relative to the Y-axis.

•	 Xdir_Z: The Xdir_Z attribute controls the size of the specular 
reflection relative to the Z-axis.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Phong

The Phong node defines a model for calculating highlights. It has 
the following attributes:

Figure 15.16

•	 Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights lend 
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the illusion of shininess. For example, a piece of wood displays 
no highlight, while a piece of polished metal has one or more 
distinct highlights. This color is generally the same as that of 
the direct lighting falling on the affected surface but does not 
have to be.

•	 Specular Value: The Specular_Value is the amount of 
influence the specular color has on the shader. A higher value 
will create larger, more distinct highlights and vice versa.

•	 Size: The Size attribute specifies the size of the highlight.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Glossy

The Glossy node defines a model for calculating highlights. It has 
the following attributes:

Figure 15.17

•	 Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights lend 
the illusion of shininess. For example, a piece of wood displays 
no highlight, while a piece of polished metal has one or more 
distinct highlights. This color is generally the same as that of 
the direct lighting falling on the affected surface but does not 
have to be.

•	 Ks: The Ks attribute defines the strength of the specular color, 
where 1=100%.

•	 Roughness: The Roughness attribute defines the size of 
highlights.

Sharpness•	 : The Sharpness attribute defines the sharpness 
of the highlight’s edge.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Blinn

The Blinn node defines a model for calculating highlights. It has 
the following attributes:
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Figure 15.18

•	 Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights lend 
the illusion of shininess. For example, a piece of wood displays 
no highlight, while a piece of polished metal has one or more 
distinct highlights. This color is generally the same as that of 
the direct lighting falling on the affected surface but does not 
have to be.

•	 Eccentricity: The Blinn formula models the microfacets 
(microscopic imperfections) of the surface as ellipsoids of 
revolution. The Eccentricity attribute controls the size and 
variation of the imperfections. Use 0 for very shiny surfaces 
and 1 for very diffuse surfaces. 

•	 Specular Roll Off: The SpecularRollOff attribute controls 
the highlight’s sharpness.

•	 Reflectivity: The Reflectivity attribute controls the amount 
of light reflected back to the eye.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Specular

The Specular node defines a model for calculating highlights. It 
has the same attributes as the Phong node, which is discussed 
below.

Figure 15.19

•	 Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights lend 
the illusion of shininess. For example, a piece of wood displays 
no highlight, while a piece of polished metal has one or more 
distinct highlights. This color is generally the same as that of 
the direct lighting falling on the affected surface but does not 
have to be.

•	 Specular Value: The Specular_Value is the amount of 
influence the specular color has on the shader. A higher value 
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will create larger, more distinct highlights and vice versa.

•	 Roughness: The Roughness attribute defines the size of 
highlights.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Diffuse Nodes

Clay

The Clay node applies a clay-like lighting model to the selected 
material. It has the following attributes:

Figure 15.20

•	 Color: The Color attribute specifies the clay color. Clicking 
the color opens a Color Picker.

•	 Kd: The Kd attribute specifies the strength of the color, where 
1=100%.

•	 Roughness: The Roughness attribute defines the size of 
highlights.

Diffuse

The Diffuse node allows you to use the standard diffuse lighting 
model. It has the following attributes:

Figure 15.21

•	 Diffuse_Color: The Diffuse_Color attribute specifies the 
diffuse color.

•	 Diffuse_Value: The Diffuse_Value attribute defines the 
strength of the diffuse color, where 1=100%.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.
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ProbeLight

The ProbeLight node takes an irradiance environment map, which 
is a 360 degree light distribution contained within a single image 
map, and applies it to your material. It has the following attributes, 
as well as nine coefficients:

Figure 15.22

•	 Exposure: The Exposure attribute specifies the brightness, 
or exposure level, of the irradiance map.

•	 Saturation: The Saturation attribute specifies the degree 
of color saturation within the irradiance map.

•	 SurfaceColor: The SurfaceColor attribute allows you 
to select a color tint by which the irradiance map will be 

multiplied. For more realistic results, you should multiply with 
white.

If your intention is to create an image based light, you 
can do so by simply adding a diffuse image Based light to your 
scene in the lighting controls. See Chapter 12: Lighting on 
page 186 for more information about adding and configuring 
lights.

Toon

The Toon node gives your material a cartoon-like look. It has the 
following attributes:

Figure 15.23

•	 Light Color: The LightColor attribute specifies the light 
color.

•	 Dark Color: The DarkColor attribute specifies the dark 
color.



Poser 8
Reference Manual 

250

Chapter 15: Material Room Nodes

•	 Ink Color: The InkColor attribute specifies the ink color.

•	 Spread: The Spread attribute defines the sharpness/softness 
of edges between colors.

•	 Line Width: the LineWidth attribute specifies the width of 
the ink color.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Special Nodes

Skin

The Skin node allows you to create realistic skin. It has the 
following attributes:

Figure 15.24

•	 Skin Color: The SkinColor attribute selects the skin’s base 
color. Clicking this attribute opens a standard Color Picker.

•	 Sheen Color: The SheenColor attribute is the color of any 
highlight that appears on the object surface. Highlights lend 
the illusion of shininess. For example, a piece of wood displays 
no highlight, while a piece of polished metal has one or more 
distinct highlights. This color is generally the same as that of 
the direct lighting falling on the affected surface but does not 
have to be.

•	 Ka: The Ka attribute controls the ambient light strength, 
where 1=100%.

•	 Kd: The Kd attribute controls the diffuse light strength, where 
1=100%.

•	 Ks: The Ks attribute controls the specular light strength, 
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where 1=100%.

•	 Thickness: The Thickness attribute controls the thickness of 
the top, translucent skin layer.

•	 ETA: The ETA attribute controls the density of the top, 
translucent skin layer.

Velvet

The Velvet node allows you to create the appearance of realistic 
velvety fabric. It has the following attributes:

Figure 15.25

•	 Velvet Color: The Velvet_Color attribute selects the color. 
Clicking this attribute opens a standard Color Picker.

•	 Velvet Sheen: The Velvet_Sheen attribute is the color of 
any highlight that appears on the object surface. Highlights 

lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has one 
or more distinct highlights. This color is generally the same as 
that of the direct lighting falling on the affected surface but 
does not have to be.

•	 Ka: The Ka attribute controls the ambient light strength, 
where 1=100%.

•	 Kd: The Kd attribute controls the diffuse light strength, where 
1=100%.

•	 Ks: The Ks attribute controls the specular light strength, 
where 1=100%.

•	 Roughness: The Roughness attribute controls the 
thickness of the top, translucent skin layer.

•	 Edginess: The ETA attribute controls the density of the top, 
translucent skin layer.

•	 Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.
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Hair

The Hair node allows you to color your characters’ or props’ hair. It 
has the following attributes:

Figure 15.26

•	 Root Color: The Root_Color attribute selects the color for 
the root of the hair. Clicking this attribute opens a standard 
Color Picker.

•	 Tip Color: The Tip_Color attribute selects the color for the 
tip of the hair. Clicking this attribute opens a standard Color 
Picker.

•	 Specular Color: The Specular_Color attribute selects the 
hair’s highlight color. Clicking this attribute opens a standard 
Color Picker.

•	 Highlight Size: Allows you to determine the size and 
intensity of the highlights in the hair.

•	 Root Softness: The Root_Softness attribute controls the 
root’s transparency, which helps hair blend into the scalp.

To create realistic hair shaders, connect this node to the 
root node’s Alternate Diffuse attribute.

•	 Opaque in Shadow: Check this option to create solid 
shadows beneath hair strands. This allows you to create hair 
that looks more full without having to increase the number of 
hairs on the head (thereby requiring less computer resources).

FastScatter

The FastScatter node offers an easy application of SubSurface 
Scattering (SSS) effects. SubSurface Scattering simulates the 
interaction of light with translucent materials, whereby the light 
interacts to some degree with the material below the surface level. 
The results of the FastScatter calculation closely approximate 
true SubSurface Scattering. Additionally, FastScatter has the 
advantage of being several times faster than traditional SubSurface 
Scattering, because it does not require raytracing. The FastScatter 
node has the following attributes:

Figure 15.27
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•	 Color: The Color attribute allows you to specify the color tint 
of the sub-surface area.

•	 Attenuate: The Attenuate attribute specifies that the 
FastScatter node will ignore light originating from the 
direction of the camera, and will afford maximum influence 
to light directed towards the camera. The degree of influence 
of light coming from directions between those two points will 
be weighted in the FastScatter calculation, according to the 
light’s angle in relation to the camera.

Figure 15.28: Without FastScatter/no SSS (left); With FastScatter/with SSS (right)

Raytrace Nodes
To use the raytracing nodes, you must have raytracing enabled in 
the Render Settings dialog, as described in the “The Render 
Settings Dialog” chapter, beginning on page ﻿ .

Reflect

The Reflect node specifies the reflection color when raytracing. It 
has the following attributes:

Figure 15.29

•	 Background: The Background attribute selects the 
background color to be used for raytracing. Clicking this 
attribute opens a standard Color Picker.

•	 Quality: The Quality attribute controls how many rays are 
spawned by hitting a surface. Increasing this value increases 
the realism of reflections but consumes computing resources.

•	 Softness: The Softness attribute controls the randomness 
of the directions of reflected rays.

•	 RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result of 
using raytracing techniques in conjunction with displacement 
maps. RayBias offsets the starting point of the rays above 
the geometry of the surface, so as to avoid the displacement 
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geometry in the raytracing calculation. Be aware that if your 
RayBias setting is too high, your shadows will migrate in the 
scene.

Refract

The Refract node specifies the refraction color when raytracing. It 
has the following attributes:

Figure 15.30

•	 Background: The Background attribute selects the 
background color to be used for raytracing. Clicking this 
attribute opens a standard Color Picker.

•	 Index of Refraction: The Index of Refraction attribute 
controls how much light bends when passing through the 
object.

•	 Quality: The Quality attribute controls how many rays are 
spawned by hitting a surface. Increasing this value increases 
the realism of reflections but consumes computing resources.

•	 Softness: The Softness attribute controls how sharp or 
smooth refracted light appears after passing through an 
object.

•	 RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result of 
using raytracing techniques in conjunction with displacement 
maps. RayBias offsets the starting point of the rays above 
the geometry of the surface, so as to avoid the displacement 
geometry in the raytracing calculation. Be aware that if your 
RayBias setting is too high, your shadows will migrate in the 
scene.

Ambient Occlusion

The Ambient Occlusion node uses raytracing to calculate the 
degree to which other objects within a scene mask (or occlude) the 
ambient light of a surface at a given point. Surfaces with greater 
occlusion ratios will be rendered as darker than surfaces with little 
or no occlusion. This node has the following attributes:

Figure 15.31
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•	 Samples: The Samples attribute determines the number 
of rays projected. Too few samples will result in a grainy 
appearance in the darker areas of the scene. Higher sample 
rates yield higher quality darkened areas, but take longer to 
render.

•	 MaxDist: The MaxDist attribute allows you to control the 
maximum distance that the rays will travel through the scene, 
thus limiting the amount of data collected.

•	 RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result of 
using raytracing techniques in conjunction with displacement 
maps. RayBias offsets the starting point of the rays above 
the geometry of the surface, so as to avoid the displacement 
geometry in the raytracing calculation. Be aware that if your 
RayBias setting is too high, your shadows will migrate in the 
scene.

•	 Strength: The Strength attribute controls the degree to 
which the Ambient Occlusion node will darken the occluded 
surfaces within the scene.

Figure 15.32: Without Ambient Occlusion (left); With Ambient Occlusion/depth 

mapped shadows (right)

Gather

The Gather node uses raytracing to collect color and light 
information from the surfaces within a specific area, which when 
combined with an infinite light source adds a realistic “outdoor” 
lighting effect. This effect also adds some color bleeding to the 
rendered scene. The Gather sampling area, or cone, is defined by 
the following attributes:

Figure 15.33
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•	 Samples: The Samples attribute determines the number of 
Gather rays projected. Higher sample rates yield more realistic 
results, but take longer to render.

•	 MaxDist: The MaxDist attribute allows you to control the 
maximum distance that the Gather rays will travel through the 
scene, thus limiting the amount of data collected.

•	 RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result of 
using raytracing techniques in conjunction with displacement 
maps. RayBias offsets the starting point of the Gather 
rays above the geometry of the surface, so as to avoid the 
displacement geometry in the raytracing calculation. Be aware 
that if your RayBias setting is too high, your shadows will 
migrate in the scene.

•	 Angle: The Angle attribute sets the angle of the cone in 
which the Gather rays will be projected. A wider angle will 
result in a greater area and hence more data. More data will 
give you more realistic results, but longer render times.

Figure 15.34: Without Gather/no color bleeding (left); With Gather/color 

bleeding (right)

Fresnel

The Fresnel node is used for surfaces that are both refractive and 
reflective (also known as dielectrics). Such surfaces tend to reflect 
more when the observer to surface angle is high, and refract more 
when the observer to surface angle is low. Most surfaces that are 
transparent (refractive) are also reflective.

Figure 15.35

To use the Fresnel node with a surface node, plug it into the 
surface node’s refraction_color channel. Set the Diffuse values 
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low, and Transparency to 0. The Fresnel node has the following 
attributes:

•	 Background: The Background attribute selects the 
background color to be used for raytracing. Clicking this 
attribute opens a standard Color Picker.

•	 Index of Refraction: The Index of Refraction attribute 
controls how much light bends when passing through the 
object.

•	 Quality: The Quality attribute controls how many rays are 
spawned by hitting a surface. Increasing this value increases 
the realism of reflections but consumes computing resources.

•	 Softness: The Softness attribute controls how sharp or 
smooth refracted light appears after passing through an 
object.

Environment Map Nodes

Sphere Map

The Sphere Map node is a lighting node for performing spherical 
reflections. Attach this node to a materials’ reflection input (or 
as a raytrace reflection mode’s color attribute) to create spherical 
reflections. This node has the following attributes:

Figure 15.36

•	 Color: The Color attribute specifies the map’s color. Clicking 
the color opens a Color Picker.

•	 Rotation: The Rotation attribute specifies the maps, 
rotation along the X, Y, and Z values.

Variable Nodes
These are the value nodes included with Poser. Unless specified 
otherwise, the list of attributes for each node is listed from top to 
bottom:

N
The N node returns the normal at the specified point. It has the 
following attributes:
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Figure 15.37

•	 X: The X attribute is the normal vector’s X component.

•	 Y: The Y attribute is the normal vector’s Y component.

•	 Z: The Z attribute is the normal vector’s Z component.

Figure 15.38: Visualizes direction of surface normal.

P
The P node defines a point in space. It has the following attributes:

Figure 15.39

•	 X: The X attribute is the point’s X location.

•	 Y: The Y attribute is the point’s Y location.

•	 Z: The Z attribute is the point’s Z location.

Frame Number
The Frame Number node returns the current frame number. It has 
no user-definable attributes.

U Texture Coordinate
The U node returns the S coordinate in texture space of the pixel 
currently being rendered. It has no user-definable attributes.
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V Texture Coordinate
The V node returns the T coordinate in texture space of the pixel 
currently being rendered. It has no user-definable attributes.

dU
The dU node defines the rate of change of surface parameters as 
pertains to the current pixel’s location in S space. The ‘d’ indicates a 
derivative of the ‘U’ parameter.

dV
The dV node defines the rate of change of surface parameters as 
pertains to the current pixel’s location in T space. The ‘d’ indicates a 
derivative of the ‘V’ parameter.

dPdv
The dPdv node represents a varying point surface shader variable. It 
is a vector perpendicular to the surface normal in the ‘V’ direction. 
Specifically, it indicates the derivative of the surface position along 
‘V’. It has no user-definable attributes.

dPdu
The dPdu node represents a varying point surface shader variable. It 
is a vector perpendicular to the surface normal in the ‘U’ direction. 
Specifically, it indicates the derivative of the surface position along 
‘U’. It has no user-definable attributes.

dNdv
The dNdv node represents the derivative of the surface normal in 
the ‘V’ direction. In other words, it defines the rate of change of the 
surface normal along ‘V’. 

dNdu
The dNdu node represents the derivative of the surface normal in 
the ‘U’ direction. In other words, it defines the rate of change of the 
surface normal along ‘U’.

3D Texture Nodes
These are the color nodes included with the Material room. Unless 
specified otherwise, the list of attributes for each node is listed from 
top to bottom.
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Fractal Sum
The Fractal Sum node is a fractal function that returns values 
between –1 and 1. It has the following attributes:

Figure 15.40

•	 X Scale: The scale of the property along the X (horizontal) 
axis

•	 Y Scale: The scale of the property along the Y (vertical) axis.

•	 Z Scale: The scale of the property along the Z (depth) axis.

•	 Octaves: The Octaves attribute defines the number of 
iterations for the fractal function. Higher values produce more 
detailed fractals but may increase render time.

•	 Bottom: The Bottom attribute controls the bottom color 
level or floor.

•	 Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of objects.

•	 Gain: The Gain attribute controls the balance between light 
and dark colors.

fBm
The FBM node is a multi-fractal function. It has the following 
attributes:

Figure 15.41

•	 Signed: Checking the Signed checkbox returns values in 
the range –1 to 1. If unchecked, values less than 0 will be 
returned unsigned, e.g. –25 will be returned as 25.
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•	 Fractal Increment: The Fractal_Increment attribute 
controls noise. Lower values result in a smoother noise 
gradient.

•	 Frequency Gap: The Frequency_Gap attribute controls 
fractal size. Higher values product larger fractals.

•	 Octaves: The Octaves attribute defines the number of 
iterations for the fractal function. Higher values produce more 
detailed fractals but may increase render time.

•	 X Scale: The scale of the property along the X (horizontal) 
axis

•	 Y Scale: The scale of the property along the Y (vertical) axis.

•	 Z Scale: The scale of the property along the Z (depth) axis.

•	 Bottom: The Bottom attribute controls the bottom color 
level or floor.

•	 Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of objects.

•	 Gain: The Gain attribute controls the balance between light 
and dark colors. 

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 

enhanced noise definitions.

Turbulence
The Turbulence node is an unsigned fractal function. It has the 
following attributes:

Figure 15.42

•	 X Scale: The scale of the property along the X (horizontal) 
axis

•	 Y Scale: The scale of the property along the Y (vertical) axis.

•	 Z Scale: The scale of the property along the Z (depth) axis.

•	 Octaves: The Octaves attribute defines the number of 
iterations for the fractal function. Higher values produce more 
detailed fractals but may increase render time.
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•	 Bottom: The Bottom attribute controls the bottom color 
level or floor.

•	 Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of objects.

•	 Gain: The Gain attribute controls the balance between light 
and dark colors. 

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Noise
The Noise node adds random “static” or “snow” effects. It has the 
following attributes:

Figure 15.43

•	 X Index: The x_index attribute defines the position on the 
X axis from which to draw a noise sample.

•	 Y Index: The y_index attribute defines the position on the Y 
axis from which to draw a noise sample.

•	 Z Index: The z_index attribute defines the position on the Z 
axis from which to draw a noise sample.

•	 Min: The Min attribute controls the minimum amount of 
noise.

•	 Max: The Max attribute controls the maximum amount of 
noise.

Cellular
The Cellular node is used to create mosaic or cubic tiles. It has the 
following attributes:
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Figure 15.44

•	 Color1: The Color1 attribute specifies the cell color.

•	 Intensity1: The Intensity1 attribute determines the degree 
of dominance between the cells and the cusps.

•	 Color2: The Color2 attribute specifies the color of the 
borders between the cells.

•	 Intensity2: The Intensity2 attribute determines the degree 
of dominance between the cells and the cusps.

•	 ScaleX: The ScaleX attribute controls the size of the tiles 
along the x axis.

•	 ScaleY: The ScaleY attribute controls the size of the tiles 
along the y axis.

•	 ScaleZ: The ScaleZ attribute controls the size of the tiles 
along the z axis.

•	 RandomColor: Enabling the RandomColor attribute 
specifies that the color of each cell will be randomly 
determined.

•	 CellMode: The CellMode attribute determines the type and 
shape of the cells. It has the following options:

Mode 1�� : This option creates 3D tiles. You can increase 
the Intensity1 value to make the tiles more prominent.

Mode 2�� : This option emphasizes the cracks between the 
cells. Set the Intensity1 value relatively high to maximize 
this effect.

Mode 3�� : This option creates a spider-web effect. The 
Color1 attribute defines the color of the web strands. 
Set the Intensity1 value relatively high to maximize this 
effect.

Mode 4�� : This option is similar to that of Mode 3, but it 
includes an additional dimension.

Mode 5�� : This option creates a quilt-style cell pattern 
when the RandomColor attribute is enabled.
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•	 Jitter: The Jitter attribute controls the irregularity of the cell 
sizes.

•	 Turbulence: The Turbulence attribute controls the 
irregularity of the cell boundaries.

•	 GlobalCoordinates: When the GlobalCoordinates 
attribute is enabled, the object will use the global coordinates.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Clouds
The Clouds node simulates cloud patterns. It has the following 
attributes:

Figure 15.45

•	 Sky Color: The Sky_Color attribute defines the areas 
behind the clouds. Clicking it opens the standard Color Picker.

•	 Cloud Color: The Cloud_Color attribute defines the 
clouds. Clicking it opens the standard Color Picker.

•	 Scale: The Scale attribute defines the size of the clouds.

•	 Complexity: The Complexity attribute defines the 
complexity of the cloud patterns.

•	 Bottom: The Bottom attribute controls the bottom color 
level or floor.

•	 Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of objects.

•	 Gain: The Gain attribute controls the balance between light 
and dark colors.

•	 Global Coordinates: Use the Global_Coordinates 
pull-down menu to select ON or OFF. When on, the texture 
is computes using world space instead of object space and 
vice versa. If this option is on while the object is moving in 
any way, the texture will appear to “slide” through the object 
when rendered.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
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enhanced noise definitions.

Spots
The Spots node consists of a 3D texture composed of random 
spots. It has the following attributes:

Figure 15.46

•	 Base Color: The Base_Color attribute defines the base 
color. Clicking it opens the standard Color Picker.

•	 Spot Color: The Spot_Color attribute defines the spot 
color. Clicking it opens the standard Color Picker.

•	 Spot Size: The Spot_Size attribute defines the size of the 
spots.

•	 Softness: The Softness attribute determines the transition 
from the spot to the base color.

•	 Threshold: The Threshold attribute defines the lean 
towards the base or spot color. Values close to 0 favor the base 
color while values closer to 1 favor the spot color.

•	 Global Coordinates: Use the Global_Coordinates 
pull-down menu to select ON or OFF. When on, the texture 
is computes using world space instead of object space and 
vice versa. If this option is on while the object is moving in 
any way, the texture will appear to “slide” through the object 
when rendered.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Marble
The Marble node is a 3D simulation of marble or other stone 
patterns. It has the following attributes:

Figure 15.47
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•	 Base Color: The Base_Color attribute defines the base 
color. Clicking it opens the standard Color Picker.

•	 Veins: The Veins attribute defines the vein color. Clicking it 
opens the standard Color Picker.

•	 Scale: The Scale attribute defines the size of the veins.

•	 Turbulence: The Turbulence attribute defines the low-
frequency randomness of the brick pattern.

•	 Global Coordinates: Use the Global_Coordinates 
pull-down menu to select ON or OFF. When on, the texture 
is computes using world space instead of object space and 
vice versa. If this option is on while the object is moving in 
any way, the texture will appear to “slide” through the object 
when rendered.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Granite
The Granite node is a 3D simulation of speckled granite textures. 
It has the following attributes:

Figure 15.48

•	 Base Color: The Base_Color attribute defines the base 
color. Clicking it opens the standard Color Picker.

•	 Spot Color: The Spot_Color attribute defines the spot 
color. Clicking it opens the standard Color Picker.

•	 Scale: The Scale attribute defines the size of the speckles 
(spots).

•	 Shades: The Shades attribute defines the number of shades 
used for the texture between and including the base and spot 
colors.

•	 Balance: The Balance attribute defines the lean towards the 
base or spot color. Values close to 0 favor the spot color while 
values closer to 1 favor the base color.

•	 Global Coordinates: Use the Global_Coordinates 
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pull-down menu to select ON or OFF. When on, the texture 
is computes using world space instead of object space and 
vice versa. If this option is on while the object is moving in 
any way, the texture will appear to “slide” through the object 
when rendered.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Wood
The Wood node provides a 3D texture that simulates wood 
patterns. It has the following attributes:

Figure 15.49

•	 Light Wood: The Light_Wood attribute defines the base 
wood color. Clicking it opens the standard Color Picker.

•	 Dark Wood: The Dark_Wood attribute defines the wood 

grain color. Clicking it opens the standard Color Picker.

•	 Scale: The Scale attribute determines the size of the wood 
grain.

•	 Turbulence: The Turbulence attribute determines the 
amount of randomness of the wood grain.

•	 Global Coordinates: Use the Global_Coordinates 
pull-down menu to select ON or OFF. When on, the texture 
is computes using world space instead of object space and 
vice versa. If this option is on while the object is moving in 
any way, the texture will appear to “slide” through the object 
when rendered.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Wave3D
The Wave3D node implements a three-dimensional sin / cos 
trigonometric function, resulting in a three-dimensional wave effect.
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Figure 15.50

2D Texture Nodes
These are the color nodes included with the Material room. 
Unless specified otherwise, the list of attributes for each node is 
listed from top to bottom:

Wave2D
The Wave2D node implements a two-dimensional sin / cos 
trigonometric function, resulting in a two-dimensional wave effect.

Figure 15.51

Image Map
The Image Map node allows you to specify an image to use as a 
map (texture, reflection, transparency, bump, displacement, etc.). 
You can use any image as a map. However, if you want to use 
a map designed for the particular figure/prop, you must use an 
image that has been set up to work that way. Please refer to the 
Poser Tutorial Manual, About Maps & Templates on page 22for a 
general discussion about maps, and to the Poser Tutorial Manual, 
Chapter 14: Creating and Assigning Textures on page 104 for a 
brief description on creating maps. This node has the following 
attributes:

Figure 15.52
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•	 Image Source: Displays the currently loaded image. 
Clicking the Image Source attribute opens the Texture 
Manager dialog. To load an image map, either select the path 
from the drop-down list or click the Browse button to open a 
standard Open dialog and select the image you wish to load. 
A preview of your selected image should appear in the preview 
window. Click OK to implement your changes or Cancel to 
abort.

Figure 15.53

•	 Auto_Fit: Check this option to automatically fit the texture 
map to the currently selected material without tiling.

•	 U Scale: The U_Scale attribute sets the U scale factor to 
apply to the texture map when using UV or VU mapping. 
When using a projection map method (see below), this is one 
of two attributes used to define the world space size of the 
texture map being projected onto the surface.

•	 V Scale: The V_Scale attribute sets the V scale factor to 
apply to the texture map when using UV or VU mapping. 
When using a projection map method (see below), this is one 
of two attributes used to define the world space size of the 
texture map being projected onto the surface.

•	 U Offset: The U_Offset attribute defines the U position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 V Offset: The V_Offset attribute defines the V position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 Texture Coordinates: The Texture_Coordinates pull-
down menu offers the following choices:

UV�� : The UV option behaves like rubber wallpaper that 
can stretch over the object surface; the image file is made 
to correspond with set positions on the object’s surface, 
making any distortion caused by the stretching seem 
more natural. This is the most versatile mapping method.

VU�� : The VU option is identical to UV mapping, except 
that the image map is rotated 90 degrees.
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XY�� : The XY option works like a slide projector in that 
the “screen” being projected onto is the XY plane whose 
size and position are determined using the U_Scale, 
V_Scale, U_Offset, and V_Offset parameters. Any 
surface not oriented with the selected viewing plane will 
distort the texture at render time.

XZ�� : Same as above but uses the XZ plane.

ZY�� : Same as above but uses the ZY plane.

•	 Image Mapped: The Image_Mapped pull-down menu 
offers the following choices:

None�� : The background color will be used for all areas of 
the object not covered by the texture map.

Alpha�� : The background color will be used for all 
areas of the object not covered by the texture map. The 
background color will also be blended with the texture 
map based on the alpha channel of the texture map. 

Clamped�� : The edge pixels of the texture map are 
repeated to cover any area of the object that the texture 
map does not cover.

Tile�� : The texture map will be tiled to ensure total 
coverage. Tiling is controlled using the Mirror U and 
Mirror V attributes, below.

•	 Background: The Background attribute specifies the 

background color. Clicking this attribute opens a standard 
Color Picker.   Global_Coordinates button forces projected 
maps to use global instead of local coordinates.

•	 Mirror U: Enabling the Mirror_U option can help hide the 
seams between texture cells when tiling textures.

•	 Mirror V: Enabling the Mirror_V option can help hide the 
seams between texture cells when tiling textures.

•	 Texture Strength: The Texture_Strength attribute 
defines the strength of the texture map, where 1=100%.

•	 Filtering: The Filtering attribute allows you to select one of 
three options for texture filtering on the selected image map. 
These options are: None--no texture filtering; Fast--high-
speed texture filtering; Quality--high-quality texture filtering.

Brick
The Brick node simulates brick or stone wall patterns. It has the 
following attributes:
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Figure 15.54

•	 Brick Color: The Brick_Color attribute defines the brick 
color. Clicking it opens the standard Color Picker.

•	 Mortar Color: The Mortar_Color attribute defines the 
mortar color. Clicking it opens the standard Color Picker.

•	 Brick Width: The Brick_Width attribute determines the 
horizontal scale of the bricks.

•	 Brick Height: The Brick_Height attribute determines the 
vertical scale of the bricks.

•	 Mortar Width: The Mortar_Width attribute determines 
the spacing between bricks.

•	 Turbulence: The Turbulence attribute defines the low 
frequency randomness of the brick pattern.

•	 Softness: The Softness attribute defines how softly the 
brick blends into the mortar.

•	 Noise: The Noise attribute defines the high frequency 
randomness of the brick pattern.

•	 U Offset: The U_Offset attribute defines the U position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 V Offset: The V_Offset attribute defines the V position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.
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Tile
The Tile node is a 2D texture that simulates tile patterns. It has the 
following attributes:

Figure 15.55

•	 Tile 1: The Tile_1 attribute defines the first tile color. Clicking 
it opens the standard Color Picker.

•	 Tile Shape 1: The Tile_Shape_1 pull-down menu defines 
the shape of the first tile. Your options are:

Rectangle�� : Selecting Rectangular will make the tiles 
rectangular.

Ellipsoid�� : Selecting Ellipsoid will make the tiles 
elliptical.

•	 Tile 2: This attribute defines the second tile color. Clicking it 
opens the standard Color Picker.

•	 Tile Shape 2: The Tile_Shape_2 pull-down menu defines 
the shape of the second tile. This menu has the same options 
as the Tile 1 Shape menu, described above.

•	 Mortar Color: The Mortar_Color attribute defines the 
mortar color. Clicking it opens the standard Color Picker.

•	 Tile Width: The Tile_Width attribute defines the tile’s 
width.

•	 Tile Height: The Tile_Height attribute defines the tile’s 
height in.

•	 Mortar Thickness: The Mortar_Thickness attribute 
determines the spacing between bricks.

•	 Turbulence: Defines the low-frequency randomness of the 
brick pattern.

•	 Softness: The Softness attribute defines how softly the 
brick blends into the mortar.

•	 Noise: The Noise attribute defines the high-frequency 
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randomness of the brick pattern.

•	 U Offset: The U_Offset attribute defines the U position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 V Offset: The V_Offset attribute defines the V position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Weave
The Weave node creates woven textile effects. It has the following 
attributes:

Figure 15.56

•	 Color 1: The Color_1 attribute defines the first woven color. 
Clicking this attribute opens the standard Color Picker.

•	 Color 2: The Color_2 attribute defines the second woven 
color. Clicking this attribute opens the standard Color Picker.

•	 Base Color: The Base_Color attribute defines the 
underlying color behind the woven pattern. Clicking this 
attribute opens the standard Color Picker.

•	 U Scale: The U_Scale attribute defines the size of the weave 
in the U direction.

•	 V Scale: The V_Scale attribute defines the size of the weave 
in the V direction.

•	 Height: The Height attribute defines the height of the 



Poser 8
Reference Manual 

274

Chapter 15: Material Room Nodes

woven pattern.

•	 Bias: The Bias attribute adjusts the weave’s bias.

•	 Gain: The Gain attribute adjusts the weave’s gain.

Movie 
The Movie node allows you to add animations to materials. It has 
the following attributes:

Figure 15.57

•	 Video Source: The Video_Source attribute specifies the 
path containing the selected animation.

•	 U_Scale: The U_Scale attribute defines the size of the 
animation in the U direction.

•	 V_Scale: The V_Scale attribute defines the size of the 
animation in the V direction.

•	 U Offset: The U_Offset attribute defines the U position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 V Offset: The V_Offset attribute defines the V position 
of the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes used to 
define the position of the upper left corner of the projection 
“screen” in grid units.

•	 Texture Coordinates: The Texture_Coordinates pull-
down menu offers the following choices:

UV�� : The UV option behaves like rubber wallpaper that 
can stretch over the object surface; the PICT file is made 
to correspond with set positions on the object’s surface, 
making any distortion caused by the stretching seem 
more natural. This is the most versatile mapping method.
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VU�� : The VU option is identical to UV mapping, except 
that the image map is rotated 90 degrees.

XY�� : The XY option works like a slide projector in that 
the “screen” being projected onto is the XY plane whose 
size and position are determined using the U_Scale, V_
Scale, U_Offset, and V_Offset parameters. Any surface 
not oriented with the selected viewing plane will distort 
the texture at render time.

XZ�� : Same as above but uses the XZ plane.

ZY�� : Same as above but uses the ZY plane.

•	 Image Mapped: The Image_Mapped pull-down menu 
offers the following choices:

None�� : The background color will be used for all areas of 
the object not covered by the texture map.

Alpha�� : The background color will be used for all 
areas of the object not covered by the texture map. The 
background color will also be blended with the texture 
map based on the alpha channel of the texture map. 

Clamped�� : The edge pixels of the texture map are 
repeated to cover any area of the object not which the 
texture map does not cover.

Tile�� : The texture map will be tiled to ensure total 
coverage. Tiling is controlled using the Mirror U and 

Mirror V attributes, below.

•	 Background: The Background attribute specifies the 
background color.

•	 Global Coordinates: Checking the Global_Coordinates 
button forces projected maps to use global instead of local 
coordinates.

•	 Mirror U: Enabling the Mirror_U option can help hide the 
seams between texture cells when tiling textures.

•	 Mirror V: Enabling the Mirror_V option can help hide the 
seams between texture cells when tiling textures.

•	 Texture Strength: The Texture_Strength attribute 
defines the strength of the animated texture map, where 
1=100%.

•	 Frame Number: The Frame Number attribute functions 
primarily as an input for other nodes (such as math and 
variable nodes), and allows you to retime the animation 
controlled by this node.

•	 Loop Movie: Checking the Loop Movie checkbox loops 
the animation.
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Chapter 16: The Render Menu
The Render pull-down menu (in the top Poser menu bar) is where 
you render still images of your scene and access Poser’s render 
settings.

Render
Selecting  Render > Render renders your current scene using 
the currently selected renderer and that renderer’s current settings. 
Please refer to Part 4: Rendering on page 276 for more information 
about the FireFly render engine and adjusting render settings.

Area Render
Selecting  Render > Area Render enables the Area Render 
feature, which allows you to select a specific region of the current 
image to render, thereby saving processing time. Please see Area 
Render on page 67 for a complete description of this feature’s 
functionality.

Sketch Style Render
Selecting  Render > Sketch Style Render renders your scene 
using the current Sketch Designer settings. Please see Chapter 19: 
The Sketch Designer on page 304 for information on working with 
the Sketch Designer. Once you’ve set your options, you can use this 
menu command for rendering at any time while working in your 
scene.

Antialias Document
Selecting Render > Antialias Document smooths rough edges 
in your Document window view for preview purposes. Antialiasing 
is a process of oversampling image data to smooth object edges 
and avoid a jagged appearance along them. The following images 
show a test render both without (left) and with (right) antialiasing 
enabled.
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Figure 16.1 Normal preview (left); Anti-aliased (right)

You can specify whether or not to apply antialiasing during renders 
when specifying render settings. Please refer to Chapter 17: The 
Render Settings Dialog on page 280 for more information about 
specifying render settings.

Motion Blur Document
As you probably know, fast-moving objects appear blurry. The blur 
is caused by the fact that our eyes cannot “refresh” quickly enough 
to see that the object is no longer in its previous location. The 2D 
Motion Blur feature lets you give your animations the illusion of 
motion, adding a whole new dynamic and level of realism to your 
renderings.

Please see Chapter 18: Using The FireFly Render Engine on page 
285 for information about using the 3D Motion Blur feature. You 
can also blur a single frame for test purposes by selecting  Render 
> MotionBlur Document.

Figure 16.2

Render Settings
Selecting Render > Render Settings opens the Render 
Settings dialog. Please refer to Chapter 17: The Render Settings 
Dialog on page 280 for information about the Render Settings 
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dialog.

Render Dimensions
Selecting  Render > Render Dimensions brings up the Render 
Dimensions dialog, which contains settings that allow you to 
specify the dimensions of your render tab. See Render Dimensions 
on page 74 for more information on the Render Dimensions 
dialog settings.

Materials
Selecting  Render > Materials opens the Material room. 
Please refer to Chapter 13: The Material Room on page 204 for 
information about the Material room.

Reload Textures
Selecting  Render > Reload Textures will reload into memory 
all textures for the current scene preview display. This allows 
you to easily update any changes you may have made in other 
applications to the currently loaded textures.

Reuse Shadow Maps
If you do not make changes to lights or object positions between 
renders, there is no need to recalculate the shadow maps for your 
scene, as they will not have changed. Selecting Render > Reuse 
Shadow Maps allows you to save the shadow map computations 
from your previous render and reuse them, thereby saving time 
with each subsequent render.

Clear Shadow Maps

Selecting  Render > Clear Shadow Maps will cause Poser 
to recalculate the shadow maps for your scene during the next 
render. Use this option if you have made changes to lights or object 
positions, as such changes will affect the shadows in your scene.
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Chapter 17: The Render 
Settings Dialog
To open the Render Settings dialog, select Render > Render 
Settings. This window appears as follows:

Figure 17.1

Note that the Render Settings and Movie Settings dialogs 
appear as tabs within a single dialog, thereby making it easy for 

you to toggle between them. 

Render Engines
Poser allows you to render still and animated scenes using three 
separate render engines. You can select which tool you wish to use 
by clicking on the relevant tab in the Render Settings dialog. The 
available Poser renderers are:

•	 FireFly rendering engine: This rendering engine 
supports the use of procedural shaders, contains many 
controls that let you control exactly how you want your 
rendered images/movies to appear, and has the capability 
of generating truly breathtaking results. Please refer to 
Chapter 18: Using The FireFly Render Engine on page 285 for 
information on using the FireFly renderer.

•	 Sketch Renderer: The Sketch Renderer simulates 
a variety of fine art techniques, to render your scene as a 
drawing or painting. This tab also provides access to the 
Sketch Designer, discussed in Chapter 19: The Sketch 
Designer on page 304 .

•	 Preview: If you want to render quality high-resolution 
wireframe or silhouette (or any other display style) views of 
your scene, please choose the Preview rendering engine.

You can also select the Preview tab to configure your scene 
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preview window options.

Sketch Tab  
The Sketch Tab provides thumbnail previews of ten standard 
Sketch preset styles. Simply click on the appropriate thumbnail to 
select the desired preset, and then click the Render Now button 
to render your image using those preset values. Alternately, you 
can use the Sketch Preset pop-up menu to select from a list of 
standard presets and any custom presets you may have saved using 
the Sketch Designer. To easily access the Sketch Designer for 
fine tuning your sketch settings or creating new presets, simply 
click on the Sketch Designer button. Please see Chapter 19: The 
Sketch Designer on page 304 more information about using the 
Sketch Designer render engine, please see .

Figure 17.2

Preview Tab
This tab allows you to customize the Scene Preview display in the 
Document window, using the following settings: The settings in 
this tab apply to the document preview, and the use of Preview for 
actual output.
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Figure 17.3

Display Engine Settings
Select the appropriate radio button to use Poser’s built-in SreeD 
software rendering, or OpenGL hardware rendering, for image 
previews. These settings apply to the document preview, and the 
use of Preview for actual output. Please refer to OpenGL Hardware 
Acceleration on page 65 for more information about the OpenGL 

hardware rendering option for Poser. If you select OpenGL, the 
Accumulation Buffer offers hardware acceleration for a number 
of functions related to combining images in the scene preview. 
We recommend using this hardware acceleration, if your graphics 
card will support it. If you are unsatisfied with the scene preview 
rendering results using the hardware acceleration option, then you 
should select the software option.

Poser supports texture resolutions up to 4096 x 4096 for Scene 
Preview displays. You can set the resolution you wish to use in the 
Document window’s Preview display using the Preview Texture 
Resolution slider. This slider will offer a range of resolutions, from 
128 x 128 pixels up to 4096 x 4096 pixels. 

The maximum resolution available with the Preview 
Texture Resolution slider will be adjusted to match the 
maximum resolution your hardware will support.

Procedural Shader Preview
When using OpenGL hardware rendering, you can choose to see 
the effects of the procedural shaders you are using in your actual 
Scene Preview display, provided your system will support it. Once 
you select OpenGL, Poser will automatically check whether or not 
your system will support the calculation of real-time procedural 
shader effects. Poser will then provide a message within the 
Preview tab, stating whether or not your system will support this 
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feature. If you are not using OpenGL, Poser will provide a message 
that the status of this feature is undefined for your system; simply 
switch to OpenGL to have Poser confirm the support status. 
Procedural shader preview is available for scenes using up to eight 
light sources.

You can enable procedural shader previews by clicking the 
Enable Hardware Shading checkbox, and vice versa. This 
feature is disabled by default. Additionally, you can enable shader 
optimization by checking the Optimize Simple Materials 
checkbox, and vice versa. When shader optimization is enabled, 
shaders will not be generated for simple materials. Optimization is 
enabled by default.

The performance of the procedural shader preview feature will be 
dependent upon your system’s hardware. Complex scenes with a 
large number of shaders may slow preview performance; if you are 
working with a large number of shaders, you may wish to disable 
this feature.

The procedural shader preview feature does not support 
bump or displacement maps. Additionally, certain nodes are 
not supported, such as Ambient Occlusion, normal maps, and 
other raytracing effects, as well as some of the Variable nodes.

Transparency Display
You can set the Transparency Display to the actual transparency, 
or a specified limit, by clicking the appropriate radio button. 

Selecting the •	 Actual button will make any fully transparent 
surfaces invisible in your scene preview. 

If you wish to have some indication of where those items •	
are in your scene preview, you can specify a limit to the 
transparency by selecting the Limit to button, and entering a 
maximum transparency percentage value. In the final render, 
transparent items are always rendered using the actual 
transparency settings. 

Objects with multi-layered transparency, such as hair, can •	
sometimes appear to have inverted polygons in areas 
where the layers overlap. Check the Enhance multi-layer 
transparency option to improve the display of multi-layered 
transparent objects. The preview display runs slower when this 
option is enabled.

Style Options
You can also specify various Style Options for your scene preview 
display, by entering your desired values in the appropriate fields. 
These options include the following:
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Outline Width•	 : The Outline Width option allows you to 
specify the width of the lines used in the Outline display style.

Wireframe Line Width•	 : The Wireframe Line Width 
option allows you to specify the width of the lines used in the 
Wireframe display style.

Cartoon Edge Line Width•	 : The Cartoon Edge Line 
Width option allows you to specify the width of the Toon 
Outline display option, as enabled via the FireFly render 
settings.

Click the OK button to apply your settings.

Movie Settings
You can access the Movie Settings window by toggling the 
Movie Settings tab next to the Render Settings tab. Please 
refer to Chapter 22: Rendering Animations on page 351 for more 
information on movie settings.

Tips & Tricks
This chapter contains a few tips and tricks for improving still and 
animated renders:

Experiment with low render settings and gradually increase •	

them until you get the results you want. This will render your 
scene using the optimal balance between quality and speed. 
Small Web animations might need lower quality rendering 
while a piece of fine art might require very high settings.

Still and animated renders use the currently selected camera. •	
Be sure to select the proper camera before rendering, 
particularly if camera motion is part of your animation.

By default, Poser renders using the •	 Texture Shaded display 
style.

Use the draft and production rendering options to save time •	
while working and produce highly realistic results.

Refer to •	 the Poser Tutorial Manual, Chapter 13: FireFly 
Render Tips on page 99 in the Tutorials folder of your Poser 
installation folder for more tips on render improvements.

Use prop-based hair and figure-based clothing instead of strand-
based hair and dynamic cloth where you do not need dynamic 
effects. This will conserve computing resources.
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Chapter 18: Using The FireFly 
Render Engine
This chapter describes the FireFly technology features and render 
settings:

The FireFly renderer includes a wealth of powerful features, all 
of which help to create beautiful, realistic renders in little time. 
Those aspects of FireFly that are configurable are described in 
the following section. The following features enhance FireFly’s 
performance and results:

•	 High Dynamic Range (HDR) Image Support for 
IBL: Poser supports both High Dynamic Range (HDR) and Low 
Dynamic Range 

HDR images are comparable to analog photo film, ��
with regards to the amount of information stored in 
the image. HDR light probes have a significantly higher 
amount of information, but are much harder to produce. 

 There are a number of different ways to create HDR 
images. Several tutorials appear on the Internet for using 
Photoshop CS2 or later to create HDRI images. Some of them 
appear at http://www.photoshopgurus.com or http://
www.photoshopcafe.com, for example.

You can use LDR images with Image Based Lighting ��
(IBL). LDR light probes are relatively easy to create, using 
a mirrored ball to capture the light information in a 
given environment. However, the amount of information 
captured is much less than with an HDR image, and 
therefore the quality of the light probe is lower. For more 
information about Image Based Lighting and light probes, 
see Diffuse Image Based Lights (IBL) on page 187.

•	 Occlusion Culling: FireFly ignores invisible scene elements 
while rendering, in order to improve render performance. 
Occlusion culling determines which scene elements have 
visible impacts on the scene, and which may be culled 
(ignored). FireFly runs occlusion culling calculations for both 
the object and shadow render passes, to determine whether 
each scene element (a) is visible within the scene, and (b) 
casts any visible shadows. Occlusion culling cannot be used in 
conjunction with raytracing, as raytracing calculations include 
all scene elements, visible or not.

A scene element’s visibility or invisibility with regards to 
occlusion culling is not the same as the Visibility setting the 
Properties palette for that element. When unchecked, the 
Visibility property setting actually hides an object within 
the scene, so that the object is not included in any render 
calculations regardless of its placement within the scene. 
Occlusion culling calculations apply to items that are set to be 
visible within the scene, but are obscured from the camera’s 
perspective by other scene elements.

http://www.photoshopcafe.com
http://www.photoshopcafe.com
http://www.photoshopcafe.com
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•	 Texture Filtering: Texture filtering improves the 
appearance of surfaces rendered using 2D image maps, giving 
you better quality images, and avoiding aliasing and other 
artifacts. Tiled texture loading uses texture filtering to reduce 
the time required for processing. Texture filtering can be 
configured for individual textures on the Image Map node 
in the Material room (see Image Map on page 268 for more 
information).

Figure 18.1: Without Texture Filtering (top); With Texture Filtering (bottom)

•	 Tiled Texture Loading: Upon your first FireFly render 
Poser generates temporary files on the hard disk from the 
textures within the scene, and then selectively accesses them 
during render time. Poser also creates a cache in memory 
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that contains the most recently used texture tiles. Tiled texture 
loading makes use of other features, such as texture filtering 
to reduce processing time. Depending upon your system’s 
resources, you may wish to increase the memory cache size 
to offset the amount of disk access required for tiled texture 
loading, as this feature may use a lot of hard disk space 
(potentially more than 1 GB). For information about increasing 
the memory cache size, see Render Preferences on page 29.

•	 Multi-threaded Rendering: The Multi-threaded 
Rendering feature takes advantage of the increased processing 
power of the multi-processor or multi-core computer 
systems that are now available. Using this feature, you can 
configure FireFly to render any number of separate threads 
simultaneously, which results in reduced render times for 
most renders. The number of threads can be specified in the 
General Preferences dialog (see Render Preferences on 
page 29 for more information). 

 We recommend rendering your scene with as many 
threads (CPU cores) as your system possesses. This is the 
default preference after installing Poser. If you are unsatisfied 
with the resulting performance, or if the render fails to 
complete, then reduce the number of threads and/or maximum 
bucket size.

•	 Rendering in a Separate Process: By default, Poser 

runs the application and the FireFly render engine within 
a single process on the CPU. This means that both the 
application and the render engine share the maximum memory 
allotment given to a single process. Rendering in a separate 
process means that the render engine alone has access to that 
same maximum memory allotment, which can yield significant 
performance advantages for highly complex scenes, depending 
upon the memory configuration of your specific system. In 
addition, rendering in a separate process provides greater 
stability due to the compartmentalization of tasks, as well 
as allowing your system to manage memory more efficiently. 
However, rendering in a separate process does require more 
resource overhead for setting up the render. Therefore, if you 
are running primarily area renders or simple small renders, 
we recommend that you do not use this feature as the setup 
overhead will negate the performance benefits. However, for 
large complex renders, rendering in a separate process will 
definitely yield significant benefits. You can enable or disable 
this feature in the General Preferences dialog (see Render 
Preferences on page 29 for more information).

Firefly Tab: Quality Settings
The FireFly tab offers you a choice between specifying your render 
settings automatically or manually. Check the Auto Settings or 
Manual Settings radio button to display the appropriate render 
setting controls. Note that the Auto and Manual settings are stored 
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independently, so making changes to one will not affect the state 
of the other.  The Auto settings are useful when you first start using 
Poser’s FireFly render settings, because they allow you to quickly 
setup and render your scenes. 

Figure 18.2: Auto Settings

Figure 18.3: Manual Settings

Auto Settings: Draft vs Final Quality
The Auto Settings option contains a Render Quality slider, that 
ranges from Draft Quality (faster render times) to Final Quality 
(slower render times). Moving this slider will automatically adjust 
the values of the specific render settings, as shown on the graphs 
below the slider. The values of the render settings (Min shading 
rate, Pixel samples, Raytrace bounces, and Irradiance caching) are 
depicted using a gradual shaded bar, with lighter color representing 
smaller values and darker representing larger values. Render 
settings such as Cast Shadows and Raytracing are either enabled 
for the render or not, so those settings are depicted using a solid 
color bar indicating the point at which they become enabled.



Poser 8
Reference Manual

289

Chapter 18: Using The FireFly Render Engine

At the Draft Render Quality, the rendering settings will provide 
faster renders at lower quality. Use this option while creating your 
scene to get an idea what it will look like once it’s completed. 
At the Final Render Quality, the render settings yield high-quality 
renders, but with increased render times. Use this option for your 
final output. There are also options below, above, and between 
Draft and Final quality which will increase or decrease rendering 
time depending on your selection.

For a description of the settings that are found in the Auto Settings 
view, refer to Manual Settings on page 289.

Figure 18.4: Increase or decrease render quality with the Render Quality slider.

Manual Settings 

Figure 18.5

Acquire From Auto•	 : Clicking the Acquire From Auto 
button applies the current Automatic Quality Settings to the 
individual Manual Quality Settings parameters.

•	 Cast Shadows: This option is set automatically in Auto 
Settings. Checking the Cast Shadows checkbox causes 
the rendering engine to calculate shadows when rendering. 
Individual settings will override this general setting. For 
example, if a figure in your scene is set to not cast shadows, 
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then it will cast no shadows even if Cast Shadows is turned 
on for all other objects in the scene. However, if the Cast 
Shadows checkbox is not enabled, no shadows will be 
rendered regardless of individual object settings. Enabling this 
option adds realism to your renders but can affect render time.

•	 Indirect Light: Only enabled when Raytracing (below) is 
enabled. See Indirect Light on page 293.

•	 Raytracing: This option is set automatically in Auto Settings. 
Checking the Raytracing box enables raytracing, and vice 
versa. Enabling raytracing greatly enhances renderings, 
especially for curved surfaces, shadows, reflections, and 
refraction. However, it also greatly increases rendering times. 
Raytracing projects rays from the camera through every pixel 
visible in the render window, also called the View pane. 
Each pixel is then set to the color value returned by the ray 
projected through it, based on the ray’s point of intersection 
with an object in the scene. If the ray fails to intersect any 
objects, the pixel will be set to the background color. To 
determine whether the point of intersection is in shadow, a 
secondary ray is projected from the intersection point towards 
each light source. If the shadow rays intersect an object, the 
original intersection point lies in the shadow of that object. 
For reflections, when the ray intersects a reflective surface, a 
new ray is traced starting from the point of intersection and 
the color returned by that ray is incorporated into the color 
of the original intersection. This process is called recursive 

raytracing because reflected rays can spawn more reflected 
rays as long as they keep intersecting reflective objects. The 
images below show an example of raytracing. You can set the 
number of reflections (bounces) using the Raytrace bounces 
option (see below).

•	 Raytrace Bounces: This option is set automatically in 
Auto Settings. When raytracing is enabled, the Raytrace 
bounces option specifies how many “bounces” or recursions 
the renderer will use when raytracing. You should select the 
number of raytrace bounces based on the number of reflective 
or refractive surfaces that will interact in your scene. Higher 
numbers can add realism if the scene requires complex 
raytracing calculations. However, as higher numbers require 
longer render times, in a simple scenario increasing the 
number of raytrace bounces will just waste computation time.

Figure 18.6 One raytrace bounce (left); three raytrace bounces (right)
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•	 Irradiance Caching: This option is set automatically in 
Auto Settings. Irradiance Caching is used to accelerate 
Ambient Occlusion, Gather and Indirect Light effects. This 
is done by reusing and interpolating values instead of 
expensively calculating them separately for every shading 
point. This process speeds up calculations by tracing less 
rays. The irradiance caching quality can be adjusted using 
the Irradiance caching slider. A lower setting means lower 
quality: FireFly will use more estimations, resulting in shorter 
processing times but less accuracy. A higher setting equals 
higher quality: FireFly will run more new calculations, resulting 
in longer processing times but increased accuracy (see Indirect 
Light on page 293).

•	 Indirect Light Quality: See Indirect Light on page 293.

•	 Pixel Samples: This option is set automatically in Auto 
Settings. Select the XY pixel sample rate by moving the Pixel 
Samples slider. Alternatively, you can click the dots at either 
side of the slider to increment (right) or decrement (left) the 
sample size. Pixel sampling rates determine how many pixels 
are sampled when calculating antialiasing for a single pixel. 
For example, a setting of 3 creates a 3-pixel by 3-pixel grid 
with the pixel being sampled in the center. At render time, the 
renderer would examine the 3x3 area when determining the 
color and other values to assign to the pixel currently being 
rendered. Expanding this number can refine your renders 
but will greatly affect render times. 3x3 is considered a good 

default.

•	 Minimum Shading Rate: This option is set automatically 
in Auto Settings. The Minimum Shading Rate value 
determines the level to which object polygons will be 
subdivided (or diced) into micro-polygons. For example, a 
shading rate of 1 means that polygons will be divided into 
micro-polygons that each occupy approximately one pixel 
of the rendered image, and a value of 4 means that each 
micro-polygon will cover approximately 4 pixels of the 
rendered image. Values less than one (such as 0.2) cause each 
micro-polygon to be less than a pixel in size. Micro-polygons 
within a given polygon are as identical in size, shape, and 
area as possible. At render time, the renderer will subdivide 
each polygon, sample each micro-polygon, and assign the 
micro-polygons’ average color to the pixel being rendered. 
Enter your desired sampling rate in the Minimum Shading 
Rate field, or adjust the slider to the desired value. Decreasing 
this value can refine your renders but increases render time. 
You can set this value on a per-object basis using the desired 
object’s Properties palette. Setting this value in the Render 
Settings dialog applies it to the entire scene, and overrides all 
per-object settings that are lower than this global value. If an 
object has a higher shading rate, Poser will use the object’s 
shading rate when rendering that object.
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Figure 18.7 High minimum shading rate (left), loss of detail; Low minimum 

shading rate (right), full detail visible

•	 Maximum Bucket Size: The bucket is the area being 
rendered at any one time. Enter your desired value in the 
Maximum Bucket Size field. For example, entering a value 
of 10 creates a rendering bucket that is no greater than 10-
pixels by 10-pixels in size. At render time, the renderer will 
render one such bucket area at once. Increasing the bucket 
size increases the area being rendered at once but requires 
greater system resources. Use caution when enlarging the 
bucket beyond its default size, and monitor your system 
resources. Note that Poser will automatically detect when 
the specified bucket size will consume excessive resources, 
and in such cases will override the specified bucket size and 
subdivide the buckets into smaller sizes. Smaller sized buckets 
require less RAM, but will take longer to render.

•	 Minimum Displacement Bounds:  This feature 
is enabled only when Use Displacement Maps is 
checked in the Rendering Options window. The Minimum 
Displacement Bounds value is measured in Poser units 
(as specified in the General Preferences dialog), and 
determines the amount of displacement the render engine 
anticipates. Displacement mapping is a rendering technique 
that adds realistic bumps and indentations to surfaces. This 
is normally preferable to modeling deformations directly, 
since you can alter the displacement map (template 
used for calculating displacement) rather than editing the 
object. Further, adding such detail directly to an object 
could exponentially increase its polygon count and therefore 
greatly affect render time. When setting the Minimum 
Displacement Bounds, keep in mind that it is possible 
for displacement deformations to exceed the render bucket 
boundaries. In other words, even though the actual geometry 
of a given object may be entirely contained within the 
current render bucket, the object still may cross into adjacent 
buckets through the displacement of its surface. If a particular 
displacement exceeds the boundaries of the currently rendered 
bucket at any point, you will see a hole or patch crack at 
the affected location. To avoid this problem, the render engine 
takes into account a volume exceeding the actual geometry 
when determining whether or not an object is contained 
within a specific bucket. This volume is specified by the 
displacement bounds. Smaller bounds result in fewer objects 
within the current bucket and therefore faster rendering, 
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but increase the risk of geometry cracks along the bucket 
boundaries. Larger bounds will prevent cracks but will increase 
render time. The above diagram illustrates this concept. In 
this case, the top of the pyramid exceeds the bucket bounds 
and will therefore be cut off, leaving a patch crack. Poser 
will automatically determine the displacement bounds value, 
by evaluating the shader trees defining the materials. If the 
shader tree is particularly complex, Poser might not be able 
to compute an appropriate value. In such a case, you should 
specify a higher value in the Minimum Displacement 
Bounds field. This will become the minimum value Poser is 
allowed to use for the displacement bounds when rendering.

Figure 18.8

Indirect Light
Poser’s indirect light feature provides increased realism by adding 
light that naturally bounces off of objects to illuminate other 
surrounding objects. To use indirect light, create a scene that 

contains objects from which light will bounce onto your figure(s). 
For example, you can scale one or more primitive cubes to use as 
walls behind or near your figure. Point a directional light at the 
walls and the figure, and the light will bounce off the walls to 
illuminate the figure near it.

 Due to the number of interpolations and calculations 
required for this feature, the practical use of indirect light in 
animation will be dependent on the number of elements in 
your scene and the quality settings set in your renderer.

Figure 18.9

Irradiance caching is used to calculate rays for locations where they 
can easily be determined. In-between locations are interpolated. 
The render engine determines whether to calculate or interpolate 
the rays based on the distance and direction of the current location 
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to the locations previously calculated and the distance to other 
nearby objects.

Figure 18.10

Related Settings in the Render Settings dialog include:

Indirect light•	 : Check this option to add indirect light for 
more realistic lighting

Irradiance Caching•	 : Determines the ratio of shading 
points where indirect light will be calculated by raytracing vs. 
those that will be interpolated. 

Low values result in shorter render times, with more ��
interpolation. 

High values achieve more precise results at the expense ��

of increased render times. 

Indirect Light Quality•	 : Indirect Light Quality determines 
the number of rays used to calculate the indirect light. Higher 
values mean higher quality at the expense of longer render 
times.

The renderer will perform one pass as it samples the light rays. 
The prepass displays red dots in the places where indirect light 
is calculated explicitly. Following the prepass, the final render is 
completed using the indirect light calculated in the prepass. 

FireFly Options Settings

•	 Render Over: These options specify the background to be 
used when rendering images or movies. Check the appropriate 
radio button for the option you wish to select.

�� Background Color: Selecting Background Color 
renders the image/movie over the Document window’s 
background color. Please refer to Colors on page 72 for 
information about changing Document window colors.

Black�� : Selecting Black renders the image/movie over a 
plain black background.

�� Background Picture: Selecting Background 
Picture renders the image/movie over the background 
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image in your scene. Please refer to Importing 
Background Pictures on page 51 for information on 
importing background pictures.

�� Current Background Shader: Selecting Current 
Background Shader renders the image/movie over 
the specified background shader. Please refer to Root 
Background Node on page 235 for information about 
using background shaders.

•	 Shadow Only: Checking the Shadow Only checkbox 
will cause only the shadows from your scene to be rendered; 
everything else in the scene will be completely white. This 
feature is most useful for production rendering, as it allows 
you to render just the shadows, thereby allowing you to edit 
them independently from the rest of the scene. You can then 
take the shadow only render into an image editing program, 
and composite it with the unshadowed scene. This setting 
overrides all other render settings.

•	 Smooth Polygons: Checking the Smooth Polygons 
checkbox enables polygon smoothing, and vice versa. 
When enabled, the FireFly rendering engine uses polygon 
subdivision to smooth hard corners on objects. If your scene 
contains hard edges that you don’t wish to have smoothed, 
you should define those hard edges either by specifying 
smoothing groups or by setting a crease angle threshold to 
determine which polygons are affected. Please see Smoothing 

Geometry on page 299 for more information about smoothing 
groups and setting the crease angle threshold. This option 
can be disabled for specific objects as needed, in the object’s 
Properties palette.

Figure 18.11: Without Polygon Smoothing (left); With Polygon Smoothing (right)

•	 Remove Backfacing Polygons: Check the Remove 
Backfacing Polygons option to turn off rendering of all 
polygons that do not face the camera. This option saves 
rendering time, but can effect realism when using raytracing. 
The polygons that are rendered depend upon the angle and 
position of the camera and objects in your scene.

•	 Use Displacement Maps: Checking the Use 
Displacement Maps checkbox enables (checked) or 
disables (cleared) using displacement maps in your rendered 
output. Please see the Poser Tutorial Manual, About Maps & 
Templates on page 22 for a description of maps in general, 
the Poser Tutorial Manual, Displacement Map on page 25 
for a description of displacement maps, and Chapter 13: 
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The Material Room on page 204 for information about the 
Material room (maps are added to nodes that are part of 
shaders).

Figure 18.12: Without Displacement (left); With Displacement (right)

•	 Depth of Field: Widening the lens aperture of the camera 
allows you to achieve a Depth of Field effect. The farther 
away items are from the focal plane, the more blurred they 
will appear. The Depth of Field checkbox allows you to 
enable or disable this effect when rendering your scene. Please 
refer to Camera Parameters on page 179 for information on 
configuring Depth of Field settings.

•	 3D Motion Blur: As you probably know, when you 
shoot a photo of a fast moving object, it appears blurry. The 
amount of blur is directly related to the length of time that 
the camera’s shutter remains open while taking the shot. In 
a similar manner, Poser’s Motion Blur feature lets you give 
your animations the illusion of motion, adding a whole new 
dynamic and level of realism to your renderings. Checking 

the 3D motion blur checkbox enables motion blurring for 
your scene when rendering. When this option is enabled, 
adjusting the shutter open and close times affects the amount 
of blurring. Please refer to Camera Parameters on page 179 
for more information about the Shutter Open and Shutter 
Close parameters.

•	 Toon Outline: The Toon Outline option uses post-
processing during the rendering process to draw an outline 
around the edges of cartoon images. You can select from nine 
outline brush styles. We recommend applying a Toon shader 
node to your images, and then complementing that shading 
with the Toon Outline option. Check the Toon Outline 
checkbox to enable this feature.

Figure 18.13: Toon Outline
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•	 Post Filter Size: The post filter supersamples pixels, 
that is, samples the colors at various points inside a pixel to 
arrive at the final pixel color. This is done in order to reduce 
or eliminate various forms of aliasing (jagged edges) that 
can occur under different circumstances. The final pixel color 
is a weighted average of the supersample. Increasing this 
value increases the area used for supersampling, but affects 
rendering time and resources. You can adjust this value by 
moving the Post Filter Size slider or by clicking the dots on 
either slide of the slider to increment (right) or decrement (left) 
the value.

•	 Post Filter Type: A post filter operates on an image and 
modifies its appearance by applying a specific weighting 
algorithm to the supersamples taken for each pixel. The 
specific algorithm used for determining relative sample 
weights depends upon which filter you select using the Post 
filter type pull-down menu. Your options are as follows:

Box�� : A Box filter gives equal weight to all samples 
within a sampling region with a diameter equal to the 
pixel filter size.

Figure 18.14

Gaussian�� : A Gaussian filter gives a variably decreasing 
amount of weight to all samples within a radius equal to 
half the pixel filter size, with the maximum reduction in 
weight occurring farthest from the center of the sampling 
region.

Figure 18.15

Sinc�� : A Sinc filter uses a decreasing sine wave 
calculation to assign weight to samples within a radius 
roughly half the pixel filter size. The sine wave effect is 
similar to ripples radiating from the center point, where 
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samples will be given weight according to their relative 
positions with regards to the “crests” and “troughs” of 
the ripples.

Figure 18.16

•	 Tone Mapping: This feature is useful for scenes with a 
high dynamic range. Tone Mapping provides more control for 
brightness, saturation, and post-render processing to produce 
better images. It helps control overly bright areas in an image 
to produce better, less blown out final renderings with deeper 
contrast, helping to bring the brightest areas back into a 
reproducible range. It helps preserve as much information 
from a high dynamic range source as possible in an LDR image 
or display. Two modes of tone mapping are available:

Exponential�� : Works like film. The more you expose 
film, the less sensitive it gets. This is a post rendering 
filter that uses an exponential curve to gently approach 
white. The brighter it gets, the less sensitive gets.

HSV (Hue, Saturation, Value) exponential�� : 
Treats V exponentially, none on H, S. Brightness doesn’t 
desaturate or overbrighten color. It not physically 

accurate, but may be easier to control in scenes where 
you want to get brights into a normal range without 
going to white. .

Exposure•	 : Editable when either Exponential or HSV Tone 
Mapping are selected. This setting is the exponent used in 
Exponential calculations.

Once you have finished entering your desired settings, click OK to 
store them. Render settings are saved when you save your scene. 
Clicking Cancel closes the Render Settings dialog without 
storing your changes.

To render your scene as a still image, select Render > Render or 
click the Render Now button in the Render Settings dialog.

To render animations, please refer to Chapter 22: Rendering 
Animations on page 351 for more information.

Saving and Loading Presets
Although FireFly settings are not saved with your Poser scene, you 
can save and load FireFly Presets (including both Auto and Manual 
Quality settings, as well as FireFly Options settings). Simply click on 
the appropriate Preset button along the bottom of the FireFly tab 
for the function you wish to perform. The Load Preset and Delete 
Preset buttons will display pop-up menus listing the presets that 
shipped with your copy of Poser, as well as any additional presets 
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you may have saved. Note that if you make changes to a loaded 
preset, your changes will not be saved unless you use the Save 
Preset button to record them. The Save Preset button will allow you 
to save the current FireFly render settings with a name of your own 
choosing. The Restore Defaults button will restore all FireFly render 
settings to their default locations.

Smoothing Geometry
Poser provides some additional features that make geometry look 
smoother during render time, without having to add additional 
geometry. The smooth shading feature affects an object’s shading 
without changing the geometry of its edges. Smooth shading will 
render creased edges between polygons as rounded, continuous 
surfaces rather than as hard edges. In this way, smooth shading 
allows you to achieve a consistently smooth shading effect, without 
having to alter the geometry by subdividing polygons to minimize 
the creases. 

By default, if there are no smoothing groups specified, smooth 
shading will be applied to all figures and objects within a scene, 
according to the Crease Angle specification in the Properties 
palette for each given current actor. Additionally, you can customize 
smooth shading in one of two ways, as described in the following 
sections:

Geometry smoothing is affected by the following settings, as 
described in the sections that follow:

Crease angles•	 , as set in an actor’s Properties palette or 
globally in the Document tab of the General Preferences 
dialog.

Smoothing groups•	 , definable in the Group Editor.

The •	 Smooth Polygons option in the Firefly Render 
Settings dialog.

Crease Angle
Crease angle represents the angle between the normals of 
adjoining polygons. The Crease Angle property establishes a 
threshold up to which smooth shading will be applied. In other 
words, if the crease angle threshold is set to 70, smooth shading 
will be applied to all polygon creases with angles smaller than 70 
degrees. Polygon creases with angles greater than 70 degrees will 
not be smoothed. 

You can specify the Crease Angle threshold in the Properties 
palette for each individual actor within a figure or object. By 
default, Crease Angle is set to 80 degrees for all actors. 
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Figure 18.17

To change the crease angle globally, select Edit > General 
Preferences, and click on the Document tab.

Figure 18.18

The following images provide examples of a sphere with crease 
angles set at 10 degrees and 80 degrees, respectively:
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Figure 18.19

Smoothing Groups
You can use the Group Editor palette to establish smoothing 
groups, which define the specific polygons to which smooth 
shading should be applied. This approach is useful in that it allows 
you to customize smooth shading at the polygon level, and gives 
you the ability to have hard edges intermixed with smooth creases. 
Smoothing group settings will override the crease angle setting for 
those specific polygons.

Select the Grouping tool from the Editing Tools palette, which 
will bring up the Group Editor palette. You can either assign all 
polygons in one or more of your figure’s existing object groups 
to smoothing groups, or you can create specific new smoothing 
groups, which will enable you to customize smooth shading at the 
polygon level. Please refer to The Group Editor on page 487 for 
more information about creating new groups.

Figure 18.20

Once you have your groups established, simply click on the Assign 
Smoothing ID button to designate the currently selected group 
as a smoothing group. At render time, polygon creases between 
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all adjoining polygons within the same smoothing group will be 
smoothed. Polygon creases between adjoining polygons in different 
smoothing groups will not be smoothed, and will therefore be 
rendered as hard edges. Thus you should take care as to which 
Smoothing ID you assign to each specific polygon group.

Different polygon groups can be assigned the same 
Smoothing ID, which will ensure smooth shading across the 
geometric breaks between groups. To do this, simply create a 
smoothing ID for the initial group, and then select that same 
ID from the pop-up list when assigning Smoothing ID’s to the 
other groups.

Poser will recognize and support existing smoothing groups in 
imported geometry. Thus, if you import figures or objects from 
another 3D application, Poser will apply smooth shading according 
to the imported smoothing group definitions, in the same manner 
as if the smoothing groups had been assigned within Poser.

Smooth Polygons
In the render settings, smooth polygons activates polygon 
subdivision to smooth hard edges at render time. If your image 
contains visible rough edges because your polygon mesh is 
sparse, then the render time polygon smoothing can render those 
edges smooth. See FireFly Options Settings on page 294﻿ for more 
information about applying this option.

Figure 18.21

Note that the render time polygon smoothing will not override hard 
edges specified by either the crease angle or smoothing groups. 
Thus, you can specify hard edges definitively using either of those 
methods, and still apply render time polygon smoothing to all other 
edges. 

The following figure illustrates the render time polygon smoothing 
effect. On the left is a sphere with a crease angle set to 80 degrees, 
with no polygon smoothing. On the right is the same sphere with 
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polygon smoothing enabled.

Figure 18.22
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Chapter 19: The Sketch 
Designer
Poser’s Sketch Designer renders scenes as sketch-like drawings 
using black-and-white or colored brush strokes that you can tailor 
to your liking. Simulate pen, pencil, pastel, charcoal, and even 
watercolors and paintings without ever having to pick up a pencil 
or brush!

Figure 19.1

You can save Sketch Designer renders and reload them later for 

further work. The Sketch Designer also lets you create amazing 
animations that look like hand-drawn movies. For best results, try 
rendering scenes using plenty of detail (hair, clothing, etc.) and 
dramatic lighting.

To access the Sketch Designer, select  Window > Sketch 
Designer. Alternately, you can access the Sketch Designer via the 
Sketch tab in the Render Settings dialog, which also contains 
other render and movie settings.

Sketch Elements
The Sketch Designer recognizes three distinct divisions within your 
scene:

Objects•	 : Checking the Objects radio button allows you 
to determine the sketch style for objects and figures in your 
scene.

Background•	 : Checking the Background radio button 
allows you to determine the sketch style for your scene’s 
background.

Edges•	 : Checking the Edges radio button allows you to 
determine the sketch style for the edges of objects and figures 
in your scene.



Poser 8
Reference Manual

305

Chapter 19: The Sketch Designer

Presets
You can use the Presets pop-up window above the preview tab 
to select one of the available preset sketch styles. You can also use 
the sliders and other options to create an almost infinite variety of 
styles.

The Presets pop-up also allows you to create and remove sketch 
presets. To create a preset, adjust the sketch style to your desired 
settings, then select Presets>Create Preset. Enter a name for 
your preset and click OK. Your new preset will appear in the Presets 
menu.

To delete a preset, select the preset you wish to delete using the 
Presets menu, then select Presets>Delete Preset.

The Delete Preset option allows you to remove the sketch 
presets included with Poser. Once deleted, you must reinstall 
Poser to restore your factory default sketch presets.

Checkboxes
The Sketch Designer has three checkboxes:

Over Black•	 : Checking the Over Black checkbox renders 
your scene over a black background with white strokes. When 
disabled, the background is white with black strokes.

Auto Density•	 : Checking the Auto Density checkbox 
causes stroke density to reach an automatic density based 
on the current scene, ignoring the Density slider setting (see 
below). When disabled, the density is calculated based on the 
Density slider setting.

Colored Strokes•	 : Checking the Colored Strokes 
checkbox causes sketches to be rendered in color. When 
disabled, sketches are rendered in black and white.

Brushes
The Sketch Designer includes several predefined brushes, 
available using the Brushes pull-down menu. For maximum effect, 
try using these brushes with both the Min Width and Max Width 
sliders set to higher values.

Sketch Parameters
The Sketch Designer includes the following parameters, 
controllable using sliders. Moving a slider to the right increases the 
selected value, and vice versa. These parameters customize many 
characteristics of the sketched lines. Your sketch redraws each time 
you adjust a value, allowing you to see the results of your changes.

Density•	 : The Density slider controls the density of lines in 
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the sketch.

Line Length•	 : The Line Length slider defines the length of 
strokes.

Min Width•	 : The Min Width slider defines the width of 
the edge of each stroke, which affects the brightness of the 
original image.

Max Width•	 : The Max Width slider defines the width of 
the center of each stroke, which affects the brightness of the 
original image.

Lo Brightness•	 : The Lo Brightness slider determines the 
band of tone. A low setting only draws lines in the darkest 
parts of your scene. If the Over Black option is disabled, 
setting this control to 0 produces the best results.

Hi Brightness•	 : The Hi Brightness slider determines the 
band of tone. A lower setting only draws lines in the darkest 
parts of your scene. If the Over Black option is enabled, 
setting this control to 1 produces the best results.

Stroke Head•	 : The Stroke Head slider determines the 
amount of taper at the stroke’s head.

Stroke Tail:•	  The Stroke Tail slider determines the amount 
of taper at the stroke’s tail.

Line Random•	 : The Line Random slider controls line 
randomizations. Higher settings result in more randomly 
shaped lines.

Color Random•	 : The Color Random slider controls 
color randomizations. Higher settings result in more random 
colorization.

Opacity•	 : The Opacity slider determines the clarity of lines. 
Lower values create more transparent strokes.

Cross Hatch•	 : The Cross Hatch slider controls the 
frequency of cross-hatching in the strokes.

Total Angle•	 : The Total Angle slider determines the total 
amount of angle change that a stroke can have before it stops 
drawing. Higher values darken the image. Lower this value 
when you have lower Density settings.

Color Cutoff•	 : The Color Cutoff slider determines the 
threshold of color changes allowed for a stroke. Use this slider 
in conjunction with Total Angle.

Light 1, 2, and 3•	 : The Light 1, Light 2, and Light 3 
sliders determine the extent to which the first three lights in 
your scene contribute to the direction of strokes. Higher values 
make the strokes go in the direction of the selected light(s).

BG Direction•	 : The BG Direction slider defines the 
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direction of the background strokes.

Auto Spacing•	 : The Auto Spacing slider controls the 
amount of space between strokes if the Auto Density option 
is enabled.

Color Blend•	 : The Color Blend slider determines how 
much color in the Document window will be blended into 
the sketch.

Rendering Sketches
After setting up your sketch, you can render it to the Document 
window. This is useful if you want to export a movie rendered using 
the Sketch Designer renderer. To render to the Document window, 
select  Render > Sketch Style Render.

Exporting Painter Scripts
Clicking the Export Painter Script button in the lower left corner 
of the Sketch Designer exports the current Sketch Designer 
settings to Corel Painter. This has been tested to work with Painter 
6 and previous versions, and is not supported for later versions 
though it may work with them.
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Chapter 20: The Animation 
Menu
The Animation pull-down menu lets you control various aspects 
of your Poser animations.

Make Movie
Setting Animation > Make Movie opens the Make movie 
window. Please refer to Chapter 22: Rendering Animations on page 
351 for more information on rendering animations in Poser.

Recalculate Dynamics
Choose one of the options in the Animation > Recalculate 
submenu to recalculate all cloth dynamics, all hair dynamics, or all 
cloth and hair dynamics. For more information about dynamic cloth 
and hair, see Chapter 24: The Hair Room on page 372 and Chapter 
25: The Cloth Room on page 386.

Retime Animation
Selecting Animation > Retime Animation allows you to adjust 
the timing of your animations. Please refer to Retiming Keyframes 
on page 329 for more information.

Resample Key Frames
Selecting Animation > Resample Key Frames opens the 
Resample Keys window, which allows you to increase or 
decrease the number of keyframes in your animation: Please refer 
to Resampling Key Frames on page 330.

Loop Interpolation
If your animation contains looping cycles (such as a walk) that 
do not match evenly (causing jerky motions between the end of 
one loop and the start of the next), toggling Animation > Loop 
Interpolation on can smooth out your animation.

Quaternion Interpolation
Quaternion interpolation is a mathematical formula that can 
smooth rough animations. If your animation remains jerky after 
editing keyframes and all other efforts at smoothing it out, 
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selecting Animation > Quaternion Interpolation can possibly 
help. This option should be toggled on as a last resort.

Skip Frames
Selecting Animation > Skip Frames toggles skipping frames on 
and off. This option can help speed playback.

Mute Sound
Selecting Animation > Mute Sound toggles sound muting 
during animation playback. A check mark appears when muting is 
enabled, and vice versa.

Clear Sound
Selecting Animation > Clear Sound deletes the sound previously 
imported into your Poser scene.

Play Movie File
Selecting Animation > Play Movie File allows you to open 
a movie file for playback within Poser. A standard Open dialog 
appears, allowing you to browse to your desired movie file.
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Chapter 21: Animating with 
Poser
Poser allows you to animate figures and props, giving life to your 
scenes. You can use your work in multimedia projects, on the 
Web, and in videos by exporting rendered results to Windows 
AVI, Macintosh QuickTime, or Flash movie format. AVI movies 
are rendered in 32-bit color, which by default includes an alpha 
channel (mask) for each frame. This can aid in compositing the 
animation with other movie footage. QuickTime movies can also 
contain an Alpha channel if set to render at millions of colors.

Once rendered, exported animations can be opened and edited 
in post-production tools such as Adobe Premiere and Adobe After 
Effects, where you can edit sequences and add special effects. 
While you can create long animations, we recommend creating 
a series of shorter animations and piecing your scenes together 
using an editing application. Real movies follow this guideline 
as well: Each time a camera angle changes, you’re seeing a new 
take of a scene or a different scene altogether. This includes cases 
such as conversations, where the camera is switching back and 
forth between the participants. Poser includes many powerful 
tools designed to help you create stunningly realistic animations. 
Animation is easy to learn but hard to master. Start with short 
simple movies and work up as your skills improve. The results may 
surprise you!

Animation Overview
At its simplest, the animation process is as follows:

Decide how many frames you want in your animation. One 1.	
way to do this is to decide how long your animation will be 
in seconds, then multiply that by the your desired number of 
frames per second (frame rate).

Create a starting pose.2.	

Select your next keyframe.3.	

Create a new pose.4.	

Repeat Steps 3 and 4 until your animation is complete.5.	

Poser uses a technique called keyframe animation to simulate 
motion based on a series of still poses. You set up a series of poses 
at different points in time. These are the keyframes. Poser fills in 
the gaps, interpolating between keyframes to create the illusion 
of motion. This keeps you from having to move your figure each 
time you want to create a motion, such as is done in stop-frame 
animation, where each frame is individually positioned (many 
“Claymation” movies use stop-frame animation).
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What You Can Animate
What can you animate using Poser? Just about everything! Here 
are some examples:

Figures (humans, animals, clothing, etc.)•	 : If you 
can imagine a motion, you can create it using Poser! Please 
refer to Chapter 9: Posing Figures on page 123 for information 
about posing human figures, and to Posing Animals on page 
149 for some information about posing animals.

Hands•	 : Gestures and small motions add incredible realism 
to videos. Many amateur animators ignore hands when 
animating, which subtly detracts from your scene’s realism. 
Please refer to Posing Hands on page 147 for information 
about posing hands.

Faces•	 : Animating faces can add emotion and power to your 
scene and can also mimic speech. Please refer to Posing Faces 
on page 145 for more information about posing faces.

Props•	 : You can animate props by moving them about the 
Poser workspace, parenting them to other actors, etc. Please 
refer to About Props on page 158 for more information about 
props.

Lights•	  and Cameras: Change color and position of lights 
and zoom, pan, or bank cameras over time.

Deformers•	 : You can animate magnets, waves, morph 
targets, and parameters. Please refer to Using Deformers on 
page 444 for more information about deformers.

Force Fields•	 : You can animate Force Fields to create 
realistic wind effects for strand-based hair and dynamic 
cloth. Please refer to Wind Force Fields on page 449 for more 
information about force fields.

Materials•	 : You can animate material shaders as described in 
Part 3: Materials on page 203.

Walk Paths•	 : You can create paths that your figures walk 
along, as described in Creating a Walk Path on page 340﻿.

Background•	 : You can animate the background using the 
Material room. Please refer to Part 3: Materials on page 203 
for more information about the Material room.

Movie nodes•	 : You can play movies on any object using 
movie nodes in the Material room.

By default, your animation moves over the Document window’s 
background. You can have still or animated backgrounds in your 
scenes. Please refer to Importing Background Pictures on page 51 
and to Importing Movies on page 50 for more information about 
backgrounds in Poser scenes.



Poser 8
Reference Manual

313

Chapter 21: Animating with Poser

Inverse Kinematics
You can use IK or not in your animations, however it is a global 
setting. If enabled on a figure’s limbs, it’s on for the duration of 
your animation, and vice versa. You can turn it on or off while you 
work, but the final state is what will “stick” in your final animation. 
Toggling IK on and off can affect your animation; it’s best to pick an 
option before starting to animate and stay with it to avoid having 
unexpected changes occur in your animation. Please refer to Inverse 
Kinematics (IK) on page 124 for more information about Inverse 
Kinematics.

Animation Tools
Poser has five animation tools:

•	 Animation controls: The simple, single channel 
Animation controls allow you to create quick click-and-
drag animations as well as preview your work. Access the 
Animation controls by clicking the handle at the bottom of 
your Poser workspace. See Using the Animation Controls on 
page 314 for more information.

 If not displayed, choose Window > Animation 
Controls to show the Animation Controls. They will dock or 
float depending on how you last used them.

•	 Animation Palette: The Animation palette contains 
the advanced editing features, with which you can create 
more complex animations. Among other things, you can edit 
keyframes, animation layers and individual actors, and create 
Animation Sets. Access the Animation palette by selecting 
Window > Animation Palette. Please refer to Using the 
Animation Palette on page 317 for more information about 
the Animation palette.

•	 Graph: Each actor in your scene has a Graph for each of its 
possible motions, allowing you to exercise minute control over 
your animations. Access the Graph for any parameter by using 
the desired parameter dial’s menu as described in Parameters 
Palette on page 138. Please refer to Using Graphs on page 
322 for more information about the Graph.

•	 Walk Designer: Creating realistic walking movements is a 
very time consuming animation task to get right. Poser’s Walk 
Designer takes the effort out of this process and lets you 
quickly create realistic walks (for human figures only). Access 
the Walk Designer by selecting Window > Walk Designer. 
Please refer to Using the Walk Designer on page 336﻿ for more 
information about the Walk Designer.

•	 Talk Designer: Speech is one of the most important 
aspects of many animations; due to the complexity of the 
human face, it is also one of the most challenging things to 
animate realistically. Poser’s Talk Designer animates facial 
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expressions, eye and head movements to create realistic lip 
sync animations based upon speech sound files that you 
import. Access the Talk Designer by selecting Window > 
Talk Designer. Please refer to Using the Talk Designer on 
page 344 for more information about the Talk Designer.

Using the Animation Controls
The Animation controls are dockable and floatable. This 
palette contains the tools most commonly used when creating 
animations. They allow you to add and edit keyframes and preview 
your animation. If the Animation controls do not appear on your 
screen, choose Window > Animation Controls and place them 
where you find it most convenient (generally the top or bottom of 
your document window is the common location). The Animation 
controls appear as follows, and consists of the controls described 
in the following sections:

Figure 21.1

Timeline/Frame Indicator
The center portion of the Animation controls displays the 
Timeline, which represents the total time of your animation in 
Poser. This timeline contains a pointer (Scrubber) representing 
the location of the current frame relative to the entire animation, 
which is visible in the Document window. The Scrubber is very 
commonly used to quickly find specific points within animations. 
Click and drag the Scrubber to quickly navigate your animation.

Just above the Scrubber is the Frame Indicator, which indicates 
both the total number of frames in your animation and your current 
position within that timeline, with the left field indicating position 
and the right indicating animation length. For example, if the two 
numbers read 60 and 120, that means that you are viewing the 
60th frame of an animation that is 120 frames long.

You can jump to a specific frame by clicking the left number 
field and entering the frame number you wish to jump to. You 
can also add or remove frames by clicking the right number field 
and entering the number of frames you wish in your animation. 
Entering a larger number lengthens your animation and vice versa. 
Shortening animations will cut the excess frames from the end. For 
example, if you reduce an animation from 120 to 90 frames, you 
will lose the final 30 frames.
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Recording Keyframes
Poser records changes made to figures, props, materials, etc. as 
keyframes. Create keyframes by moving the scrubber to a new 
point on the timeline and making your desired change(s) to your 
scene. Recorded keyframes store new body part positions, new prop 
positions, material settings, etc. for each figure and prop within 
your scene. You can only record one set of position parameter 
settings for any given keyframe. For example, if you select a frame 
and move a figure’s arm up then change your mind and move 
the arm down again, the downward position is what will be 
“remembered” and what will affect your animation. To make a 
figure’s arm wave up and down:

Select a starting pose.1.	

Move the scrubber to the point in time/frame number you wish 2.	
to edit.

Raise the arm using the 3.	 Editing tools.

Move the scrubber to a later point in time/frame number.4.	

Lower the arm, again using the 5.	 Editing tools.

Continue creating keyframes until the motion sequence is 6.	
complete.

Camera animation must be enabled for the currently 
selected camera In order to automatically record keyframes. If 
animation is disabled, you can add keyframes manually (see 
following subsection).

Play Controls
The Play controls appear on the left side of the Animation 
controls and allow you to preview your animation using VCR-like 
controls. From left to right, the Play controls are as follows:

Figure 21.2

First Frame•	 : Clicking the First Frame button moves to the 
first frame in your animation.

End Frame•	 : Clicking the End Frame button moves to the 
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last frame in your animation.

Stop•	 : Clicking the Stop button stops animation playback at 
the current frame.

Play/Pause•	 : Clicking the Play button plays your animation 
at normal speed, including background movies and sounds (if 
any). While your animation is playing, this button becomes the 
Pause button. Clicking it freezes the animation at the current 
frame.

Step Backward•	 : Clicking the Step Backward button 
moves back to the previous frame (i.e., the frame before the 
current one).

Step Forward•	 : Clicking the Step Forward button moves 
forward one frame (i.e., the frame after the current one).

Loop•	 : Checking the Loop radio button causes your 
animation to repeat itself continuously when playing until you 
click the Stop button. 

Animation previews run in the Document window. Be sure to 
select the appropriate tracking mode (see Tracking Mode on page 
70﻿).

Keyframe Controls
In most cases, Poser’s automatic animation engine records 
keyframes as you create animations. Sometimes, however, you’ll 
want to manually add keyframes, such as when camera animation 
is disabled. It is important for you to track the status of camera 
animation, as you could create a series of keyframes without 
realizing that the animation is off. As mentioned above, if camera 
animation is disabled, you must manually add keyframes in order 
to record them. You may also need to fine-tune animations, which 
may necessitate recording additional keyframes. For example, you 
could position the figure’s left foot at Frames 10 and 20, with 
Poser calculating its position for the tween frames. If you wanted to 
refine this, you could add a keyframe at Frame 15.

The Keyframe controls allow you to quickly and easily add, 
preview, and remove keyframes within your animation. From left to 
right, the Keyframe controls are:

Figure 21.3
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Previous Keyframe•	 : The Previous Keyframe button 
returns to the previous keyframe.

Next Keyframe•	 : The Next Keyframe button advances to 
the next keyframe.

Edit Keyframes•	 : Clicking the Edit Keyframes button 
opens the Animation Palette, discussed next.

Add Key Frames•	 : Clicking the Add Key Frames button 
adds a keyframe at the current frame number. For example, if 
you have existing keyframes at Frames 15 and 30, you could 
drag the Scrubber to Frame 22 and insert a keyframe by 
clicking the Add Key Frames button. You can also insert 
a keyframe by moving to any frame in your animation and 
making a change in your scene. This change will automatically 
be recorded as a new keyframe.

Remove Key Frames•	 : Clicking the Remove Key Frames 
button removes the currently selected keyframe. For example, 
if your character’s arm is over his head in Frame 1, down at 
Frame 15 and out to the side in Frame 30 and you remove the 
keyframe in Frame 15, the figure’s arm will move out to the 
side position specified in Frame 30 without dropping to the 
figure’s side. To delete a keyframe, use the Next Keyframe or 
Previous Keyframe buttons to locate your desired keyframe, 
then click the Remove Keyframe button.

Skip Frames•	 : Check this radio button to skip frames 
during playback. This helps conserve system resources while 
previewing your animation before you render it.

Using the Animation Palette
The Animation palette contains three tabs: the Keyframes tab, 
the Layers tab, and the Animation Sets tab. Each of these tabs 
will be described in detail in the following sections. To display the 
Animation palette, you can either select Window > Animation 
Palette, or click the Display Animation Palette button in the 
Animation controls as described above. To close the palette, either 
select Window > Animation Palette again, or click the small box 
in the upper left corner.

The upper section of the Animation palette contains several 
controls that appear on all three tabs. These are as follows:

Common Controls
Several controls and options are common to all of the tabs in the 
Animation Palette. These options are discussed below.
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Figure 21.4

Current Layer

The Current Layer pop-up menu appears at the very top of the 
Animation palette. This menu allows you to select a specific 
animation layer within the current animation. Please refer to  
Layers Tab on page 331 for more information about animation 
layers.

Frame Rate

The frame rate specifies the number of frames played per second. 
To change the scene frame rate, you can either click the current 
frame rate and enter your desired number in the text box that 
appears or click the arrow to the left of the current frame rate 
and make your selection from the Frame Rate pull-down menu. 
Choices are 12, 15, 18, 24, 25, 30, 50, and 60 frames per second. 
Some common frame rate settings are:

NTSC•	 : 30

PAL•	 : 25

Film•	 : 24

Flash•	 : 12 (recommended) or 15

You can also set the output frame rate using the Movie 
Settings window (Chapter 22: Rendering Animations 
on page 351﻿). This setting is independent from your scene 
frame rate, as specified in the Animation palette (see above). 
Additionally, you can generate a quick preview render by 
specifying the Every N-th Frame setting in the Movie 
Settings window. Again, this setting is for output purposes 
only, and is independent of your scene frame rate.
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Time

The Time control displays the amount of time in your animation 
between the first frame and the currently selected frame. Time is 
displayed in SMTPE format (Hours:Minutes:Seconds:Frame). You can 
jump to a specific point in time by entering your desired numbers 
in the fields. For example, if you jump to 1 minute in an animation 
using 24 frames per second, you’ll arrive at Frame 1440 (24 frames/
sec times 60 seconds). 

Frame

The Frame Indicator is identical to its counterpart in the 
Animation controls. You can jump to a specified frame and add or 
remove frames from your animation as described in Timeline/Frame 
Indicator on page 314.

Play Controls

The Play controls are identical to their counterparts in the 
Animation controls. See Play Controls on page 315﻿ for more 
information. 

Play Range

By default, the entire animation plays when previewing animations 
using the Play controls. You can, however, opt to view only a 
portion of your animation during preview. This feature is useful 

if you have a long animation and only want to focus on small 
portions at a time. The Play Range indicator appears at the 
bottom of all three tabs on the Animation palette. To adjust the 
play range, drag the beginning and/or end point to your desired 
starting and ending frames, respectively.

Animation Palette Options 
Menu
Clicking the Options arrow at the top right of the Animation 
Palette opens the Animation palette Options menu, which 
contains the following options:

Figure 21.5

Display Frames•	 : Selecting the Display Frames option 
toggles the Timeline columns to display using animation 
frames.

Display Time Code•	 : Selecting the Display Time Code 
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option toggles the Timeline columns to display, representing 
your animation’s running time.

Loop Interpolation•	 : Selecting the Loop Interpolation 
option toggles loop interpolation on and off. Please refer to 
Loop Interpolation on page 309 for more information.

Quaternion Interpolation•	 : Selecting the Quaternion 
Interpolation option toggles quaternion interpolation on 
and off. Please refer to Quaternion Interpolation on page 309 
for more information.

Keyframes Tab
The Keyframes tab is where you edit the keyframes in your 
animation. It shows the layout of the keyframes and allows you to 
set and move between them. You can also play animations directly 
from this palette. The Keyframes tab appears as follows: Figure 21.6

When you first display this tab, it shows any keyframes you 
previously created using the Animation controls, for the currently 
selected animation layer. Please refer to  Layers Tab on page 331 
for more information about animation layers. If you wish to see 
the keyframes contained within a different animation layer, select 
the name of the new layer from the Current Layer pop-up menu. 
In addition to the controls described above, the Keyframes tab 
contains the following elements:
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Keyframe Controls
The Keyframe controls are almost identical to their counterparts in 
the Animation controls. The main difference is that the keyframe 
controls in the Keyframes palette feature a button that allows you 
to open the Graph palette. 

Figure 21.7

Previous Keyframe•	 : The Previous Keyframe button 
returns to the previous keyframe.

Next Keyframe•	 : The Next Keyframe button advances to 
the next keyframe.

Show Graph Display•	 : Clicking the Show Graph 
Display button opens the Graph, discussed in Using Graphs 

on page 322.

Add Key Frames•	 : Clicking the Add Key Frames button 
adds a keyframe at the current frame number. For example, if 
you have existing keyframes at Frames 15 and 30, you could 
drag the Scrubber to Frame 22 and insert a keyframe by 
clicking the Add Key Frames button. You can also insert 
a keyframe by moving to any frame in your animation and 
making a change in your scene. This change will automatically 
be recorded as a new keyframe.

Remove Key Frames•	 : Clicking the Remove Key Frames 
button removes the currently selected keyframe. For example, 
if your character’s arm is over his head in Frame 1, down at 
Frame 15 and out to the side in Frame 30 and you remove the 
keyframe in Frame 15, the figure’s arm will move out to the 
side position specified in Frame 30 without dropping to the 
figure’s side. To delete a keyframe, use the Next Keyframe or 
Previous Keyframe buttons to locate your desired keyframe, 
then click the Remove Keyframe button.

Skip Frames•	 : Check this radio button to skip frames 
during playback. This helps conserve system resources while 
previewing your animation before you render it.



Poser 8
Reference Manual 

322

Chapter 21: Animating with Poser

Using Graphs
An element’s Graph palette allows you to perform precise edits 
on keyframes and modify the interpolation methods used in your 
animation.The Graph palette contains the following functions:

Figure 21.8

Animatable Properties•	 : The Animation Properties 
pull-down menu allows you to select all of the animatable 
properties for the currently selected element.

Interpolation Methods: •	 See Selecting Interpolation 
Types on page 322.

Keyframe Controls•	 : See Keyframe Controls on page 316.

Work Area•	 : See below.

The following subsections describe the Graph’s functionality in 
further detail.

About the Graph Palette

The Graph Work Area consists of two axes and a graph. The 
horizontal axis represents time in frame numbers. The vertical axis’ 
values change depending on the selected attribute.    If you choose 
a position attribute such as xTrans, the values represent positions 
in 3D space (Cartesian coordinates). If you select an editing 
property such as Bend, the axis represents degrees. A morph 
parameter’s values are measured in percentages.

The Graph itself shows the actual change in the attribute over 
the course of your animation. Its shape indicates the type of 
interpolation being used. You can also use the Graph palette for 
synchronizing sound to motion, as described in Syncing Sound & 
Motion on page 344.

Selecting Interpolation Types

The Graph contains controls allowing you to specify interpolation 
methods, which can be specified on both the element and frame 
range levels. The Interpolation controls appear as follows:

Figure 21.9
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To choose an interpolation method, select the elements and frame 
range to modify, then click your desired Interpolation button. The 
Animation palette uses color codes to depict varying interpolation 
methods:

Spline•	 : Green

 Splines can sometimes go beyond and exceed the 
maximum keyframed values depending on the slope created 
by tightly-spaced keyframes. Adding additional keyframes can 
constrain the slope into more pleasing levels. 

Linear•	 : Red

Constant•	 : Grayed out

Break Spline•	 : A hash mark appears where Break Spline 
has been applied.

Editing the Graph

You can edit the graph to achieve varying degrees of interpolation. 
For example, to decrease the amount of Spline interpolation, 
straighten the curve. You can set the curve’s shape using preset 
interpolation methods or by dragging the curve’s points to obtain 
your desired shape. You can also apply different interpolation 
methods to different parts of the graph using the Break Spline 
function.

Be aware that changing the graph’s shape affects the selected 
element’s motion. To edit the graph, use the Animation 
Properties pull-down menu or select Graph from the 
Parameters palette (see Using Graphs on page 322﻿) to select the 
attribute to be edited. Next, drag any point on the graph in the 
direction you want to move the curve. The curve will reshape itself 
based on your chosen interpolation method(s). Use the scrollbar to 
view parts of the graph that are not currently being displayed.

To change the type of interpolation applied to a portion of the 
graph, click and drag to select the frames you wish to change. 
Your selected area will become highlighted. Next, click one of the 
Interpolation buttons at the bottom of the palette. This can add 
keyframes to your animation.

Vertical lines on the graph denote keyframes. You can move 
these points to change when keyframes occur, and can also add 
keyframes by clicking the point on the line where you want to insert 
the keyframe.

The Current Frame indicator is a visual reminder of the frame 
you’re currently working on. To select a keyframe, click the Next 
Keyframe or Previous Keyframe button, as appropriate, click 
a keyframe indicator, or drag the Current Frame indicator to the 
frame you wish to edit. Click and drag a rectangle to select a range 
of frames.
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Figure 21.10

You can also perform the following functions using the Graph:

To move keyframes, select the keyframe(s) you want to move, •	
and drag forward or backward in the timeline to a new 
location.

To add a keyframe, drag the •	 Current Frame indicator to your 
desired location and click the Add Key Frames button.

To delete a keyframe, move the •	 Current Frame indicator 
to the desired keyframe and click the Delete Key Frames 
button.

To cut, copy, and paste, use the editing hotkeys •	
([COMMAND]/[CTRL]+[X], [COMMAND]/[CTRL]+[C], 
and [COMMAND]/[CTRL]+[V], respectively) or choose the 
appropriate command from the Edit menu.

To close the •	 Graph palette, click the small box in the upper 

left corner.

Using the Graph With the Animation Palette

If you open the Animation palette, you can access the Graph 
palette for the currently selected scene element by clicking the 
Display Graph Palette button. With both palettes open, you 
have the following options:

Double-clicking any element in the •	 Animation palette’s 
Element list switches the current Graph palette to the 
selected element.

Pressing •	 Opt/Alt while double-clicking any element in the 
Animation palette’s Element list opens a new Graph 
palette for the selected element while not affecting any other 
open Graph palettes. You can use this function to open as 
many Graph palettes as you like at one time, which can 
greatly speed up your animation work. You can even open 
more than one Graph palette for each element, allowing you 
to (for example) adjust the Right Forearm’s Twist and Bend 
at once to achieve smooth realistic movement.

When you have more than one Graph  palette open at 
once, changing elements by double-clicking them will only 
change the most recently opened Graph palette. All other 
Graph palettes will retain their current settings. If you need to 
change more than one graph palette, close out all unneeded 
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palettes, then re-open them by selecting your currently needed 
elements.

Interpolation Controls
The process of filling in the blanks between keyframes (the area 
known as tween frames) is called interpolation, and the frames 
between keyframes are called tweens. Interpolation determines 
how intermediate poses are created. Please refer to the Poser 
Tutorial Manual, Splines on page 11l for a general discussion about 
interpolation. 

Poser supports four types of interpolation, which allows you to 
make subtle changes to your animations. Interpolation settings 
apply to a range of frames, meaning that you can use different 
interpolation methods at different intervals in your animation. 
The Interpolation controls allow you to specify the interpolation 
method:

Figure 21.11

From left to right, the buttons are:

Spline•	 : Places tween poses and settings on a curve. Motion 
begins at one keyframe, accelerates to full velocity, and 
gradually slows down as it approaches the next keyframe. For 
example, if the first keyframe has an arm by a figure’s side and 
the second one has it raised, the arm will begin moving slowly, 
accelerate to a constant velocity, and slow as it reaches the 
second keyframe. This is not to say that the movement will be 
fast; actual speed of motion depends on the amount of change 
between keyframes and the number of tween frames. In our 
above example, having the second keyframe 5 frames from the 
first would make a very rapid motion, while having 100 frames 
would make a very slow motion. The key thing to remember is 
that this type of animation resembles a smooth curve and is 
normally the most realistic.

Figure 21.12

Linear•	 : Takes the two keyframes and divides the motion 
between them equally with no acceleration or deceleration 
of the moving items. In the above example, the arm would 
move at a constant velocity from keyframe to keyframe. If you 
created a third keyframe with the arm back down, the change 
direction at the second keyframe would be abrupt.



Poser 8
Reference Manual 

326

Chapter 21: Animating with Poser

Figure 21.13

Constant•	 : This has no intermediate poses. If you set a 
series of poses with different keyframes, the first pose will be 
maintained until the second keyframe, at which point it will 
instantly change to the second pose, which will be maintained 
until the third keyframe, and so on.

Figure 21.14

Break Spline•	 : Stops interpolation at the selected point 
so you can begin a new interpolation style. This is useful 
for blending different interpolation styles. For example, a 
bouncing ball moves in a smooth arc until it hits the floor, at 
which point it undergoes an abrupt change in direction and 
speed. This is one scenario where changing interpolation styles 
can aid your animating work.

Figure 21.15

Skip Frames
Clicking the Skip Frames radio button enabling this option drops 
frames when previewing your animation, speeding up playback. 
Click the button again to toggle its functionality off.

Loop
Clicking the Loop radio button causes your animation to repeat 
itself continuously when playing until you click the Stop button. 
Click the button again to toggle its functionality off.

This Element/All Elements
This option selects whether changes made using the Keyframes 
tab (interpolation type, keyframe changes, etc.) apply to the entire 
scene or just to the selected element. Click the This Element or 
All Elements radio button, as appropriate, to make your selection.
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Figure 21.16

Elements List/Timeline
The Elements List displays a list of all elements in your scene. 
The Timeline Area displays your animation frames and all of the 
keyframes stored for each body part/prop/material/etc. Keyframes 
appear in red, with tween (interpolated) frames appearing in 
different colors according to their interpolation type (see the Poser 
Tutorial Manual, Splines on page 11). You can expand and collapse 
element listings by clicking the triangles next to elements in the 
list. Each element can be further expanded to display its properties 
and parameters that can be animated. For example, you can view 
the Scale and Transition elements for a figure’s forearm. The 
following image displays a portion of the Elements List for a 
scene:

Figure 21.17

To select an element, click it in the Element List. This selects 
the desired element in the same manner as clicking it in the 

Document window, using the Current Actor menu or selecting it 
using any of the other available selection methods. Poser highlights 
the currently selected element in the Elements List as well as that 
element’s row in the Timeline. Use the vertical scroll bar on the 
right of the Elements List and expand and collapse branches to 
view all of the elements in your scene. Collapsing branches saves 
space in the display.

When you collapse an entire figure in the Elements List, 
the keyframes displayed will only be those pertaining to that 
figure’s location in the Poser workspace. You’ll need to expand 
the Elements List to show posing/parameter changes.

Double-clicking an element in the list, or selecting an element 
and clicking the Show Graph button, opens the Graph for the 
selected item. Please see Using Graphs on page 322﻿.

Editing Keyframes on the Timeline
You can use the Timeline to select, add, edit, or delete keyframes. 
The Timeline appears as a grid that displays keyframes for each 
element in your scene. Columns indicate time, with each column 
corresponding to a single animation frame or point in time (See 
Elements List/Timeline on page 327﻿). The Ruler at the top of this 
area indicates whether the columns indicate frames or points 
in time. Each row corresponds to an element in your scene. As 
described above, the Timeline presents information using color 
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codes. Use the horizontal and/or vertical scrollbars to navigate the 
Timeline if necessary.

Selecting Keyframes
By default, Poser selects the first frame in your animation (Frame 1) 
when you open the Animation palette. You can select any frame 
by clicking in or above its column. You can also enter a number in 
the Frame field. When you select a keyframe, Poser displays the 
current element’s row and time column, creating an intersection.

Selecting a different keyframe moves the intersection to the newly 
selected point. To select a keyframe, click any one of the light green 
squares on the Timeline grid.

Figure 21.18

Adding & Removing Keyframes
Adding keyframes stores a specific pose and/or saves a Poser-
created interpolation (tween) frame. You can add keyframes for 

the entire scene or the selected element by checking either the 
This Element or All Elements radio button as described in 
This Element/All Elements on page 326. When This Element is 
selected, keyframes are only recorded for your currently selected 
element. When All Elements is selected, keyframes are recorded 
for every element in your scene. To add a keyframe:

Select 1.	 This Element or All Elements, as appropriate.

Select the frame or point in time where you wish to add the 2.	
keyframe.

Click the 3.	 Add Keyframes button.

Removing Individual Keyframes

Removing keyframes can modify how your animation appears. You 
can clear a keyframe for a specific element or your entire scene 
by selecting This Element or All Elements, as appropriate. 
Removing a keyframe does not delete the frame, but removes the 
saved information. To remove a keyframe:

Select 1.	 This Element or All Elements, as appropriate.

Select the frame or point in time where you wish to remove 2.	
the keyframe.

Click the 3.	 Delete Keyframes button.
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Removing Multiple Keyframes

To remove an entire range of keyframes, click and drag over the 
keyframes you wish to delete in the Timeline and press [DEL]. To 
remove multiple specific keyframes, press and hold Shift while 
selecting individual keyframes, then press [DEL].

Moving Keyframes
While creating animations, you may decide to have one or more 
keyframes occur earlier or later than your present settings. You may 
also want to apply the settings in some keyframes to others. Poser 
allows you to move both individual and multiple keyframes. To do 
this, click the keyframe you wish to move and drag the colored cell 
horizontally to its new location. To move multiple keyframes, select 
them and drag your selection to its new location on the timeline.

Copying Keyframes
You can copy keyframes, figure parts, and parameters appearing in 
the Element List. By doing this, you can (for example) have several 
Poser figures marching in perfect step. Although Poser does not 
limit how you copy and paste keyframes, you should avoid mixing 
data (such as copying Scale parameter settings to a Rotation 
parameter). You can also obtain unexpected results by copying 
movements from one side of a body to another. If you do copy 

parameters from side to side, you will need to make the affected 
parameters negative on the side you copied to.

Choose Edit > Copy or press [COMMAND]/[CTRL]+[C] to copy 
frames to your clipboard. When you reach your destination, select 
Edit > Paste or press [COMMAND]/[CTRL]+[V].

Alternatively, you can click the desired keyframe then press and 
hold Opt/Alt while dragging the keyframe to its new location. 
You can move multiple keyframes by selecting them and Opt/
Alt+dragging your selection to its new location.

Retiming Keyframes
Selecting Animation > Retime Animation opens the Retime 
Keys dialog, which allows you to adjust keyframe timing in your 
animation:

Figure 21.19

By specifying source and destination frame ranges, you can change 
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the amount of time a motion or motions take to occur. This 
command does not destroy any keyframes, meaning that you can 
use it to repeat motions by copying them from one time to another. 
Selecting a motion in one area and selecting a non-overlapping 
destination re-maps the motion to another time without deleting 
the original motion.

To retime keyframes:1.	

Open the 2.	 Retime Keys dialog box.

Enter the start and end frames for the section of animation 3.	
you want to retime in the Source Frames fields.

Enter the range of frames to retime the animation to in the 4.	
Destination Frames fields. If the destination range is longer 
than the source range, the animation is expanded or slows 
down, and vice versa.

Click 5.	 OK when finished.

When using this command, all existing keyframes in the 
Destination Range are deleted.

Resampling Key Frames
Selecting Animation > Resample Key Frames opens the 
Resample Keys window, which allows you to increase or 
decrease the number of keyframes in your animation:

This window has the following options:

Figure 21.20

Modify•	 : Check the appropriate radio button to sample 
keyframes for the Current Element (prop, body part, etc.), 
Current Figure (entire figure), or Everything (entire scene).

Resample Method•	 : You have two options for resampling 
keyframes:
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Analyze Curvature�� : Causes Poser to examine the 
amount of curvature (change over time) in your animation 
and automatically assign new keyframes.

Make key frame every X frames�� : Check this 
radio button and enter a value in the Frames field to 
create a keyframe every X frames, where X is the value 
you entered in the field.

•	 Frame Range: If you want to resample key frames in a 
specific portion of your animation, enter the start frame and 
end frame in the Frame Range fields.

Layers Tab
Animation layers, also known as non-linear animation, provide you 
with the ability to separate different parts of an animation into 
independent pieces, which can be individually edited, moved, or 
even hidden, with respect to the entire animation. At render time, 
the various layers are composited together into a single animation, 
according to your specifications. The Layers tab on the Animation 
palette contains the controls that allow you to create, configure, 
move and delete animation layers.

Figure 21.21

If you switch from the Layers tab to the Keyframes tab, 
you will see any keyframes that exist in the currently selected 
animation layer. If you wish to see keyframes from another 
layer, use the Current Layer pop-up menu at the top of 
the Animation palette to select any existing layers, without 
having to return to the Layers tab.
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Base Layer
When you first begin to create an animation, only one layer will 
exist; this is known as the Base layer. The Base layer is always 
present, and if you wish, you can create your entire animation just 
in this single layer. The frame count of the Base layer is equivalent 
to the length of the entire animation. The Start frame of the Base 
layer is always Frame 1, and the End frame is the last frame in the 
entire animation. Thus, changing the End frame of the Base layer 
changes the length of your animation, which will affect any other 
layers whose End frames coincide with the End frame of the Base 
layer. 

 You cannot change any properties of a Base Layer other 
than the End frame.

Creating, Deleting & Previewing 
Animation Layers
In addition to the shared controls common to all three tabs on the 
Animation palette (see Using the Animation Palette on page 317 
for a description of these controls), the upper section of the Layers 
tab also contains three buttons:

New•	 : Click the New button to create a new animation layer.

Delete•	 : Click the Delete button to delete the currently 
selected animation layer. This feature is disabled when the 
Base layer is selected.

Current Layer Only•	 : Click the Current Layer Only 
radio button to temporarily exclude all other animation layers 
from the playback. Doing so allows you to isolate the specific 
animation contained within the current layer, which can be 
helpful in scenes with multiple layers.

Figure 21.22

Animation Layer Controls
The lower portion of the Layers tab contains additional controls 
that allow you to configure a selected layer, and the Timeline 
Area, which displays the various layers in editable segments, 
allowing you to see the hierarchy of the layers as well as where 
each layer is placed in the timeline of the entire animation. The 
Layer controls are as follows:
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Figure 21.23

Layer Name•	 : Once you have created a new layer, you can 
change its default name to anything you want. Simply select 
the layer in the Timeline display, and type the new name in the 
text field.

Include in Playback: •	 Check or uncheck this option to 
include or exclude the selected clip when you preview your 
animation.

Start/End Frame•	 : The Start frame and End frame 
controls allow you to specify the Start and End frames for the 

selected layer. While the Base layer always equals the length 
of the entire animation, other layers can be of any length up 
to the entire animation length, and can start and end at any 
point within the duration of the animation. You can change 
the Start and End frames by clicking on the frame number and 
typing a new value into the field. Alternately, you can click 
on the layer segment in the Timeline Area and drag it to a 
new position; the segment length will remain constant, but 
the Start and End frames will change. Clicking and dragging 
on either the beginning or the end of the layer segment will 
change the Start or End frame respectively, without moving 
the position of the segment within the animation timeline. The 
length of the layer segment will adjust to accommodate the 
new Start or End frame number.

Blend In/Out Frames•	 : The Blend In/Out feature allows 
you to gradually blend an animation layer into, or out of, the 
full animation. This feature could be used, for example, to 
create the effect of wind gradually picking up or fading away. 
The Blend in frames and Blend out frames settings allow 
to you specify over how many frames the linear blend will 
occur. The Blend In/Out frame count is indicated on the layer 
segment display as an additional shaded segment attached to 
either the beginning or end of the layer segment.

If the animation contained within a specific layer is 
a gradual movement, then the Blend feature may not be 
effective, particularly if the Blend In/Out frame counts are 
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set too low.

Composite Method•	 : While compositing the full 
animation, Poser begins with the Base layer, and works 
upwards through the layer hierarchy incorporating each layer 
one by one. The Composite method setting allows you 
to specify the manner in which the individual layers will be 
composited. The two options for compositing animation layers 
are Replace and Add.

Replace�� : This is the default composite method for 
animation layers. Selecting Replace means that any 
action on a given parameter for a specific actor will 
replace any actions on the same parameter, on all layers 
below the selected layer. For example, let’s suppose that 
Layer1 is below Layer2 in the animation layer hierarchy. 
Let’s also suppose that in Layer1 James’ chest is twisted 
twenty degrees to the left, but in Layer2 his chest is 
twisted only ten degrees to the left. With the Replace 
option, the Layer2 setting will replace the setting from 
Layer1.

Add�� : Selecting Add means that the values for all 
rotation and translation parameters will be added to 
one another as Poser composites each layer into the 
animation. Using the above example, the twenty degrees 
of Twist from Layer1 would be added to the ten degrees 
from Layer2, resulting in a greater effect of thirty degrees 

of Twist. However, if Layer1 had included a twist of 
negative twenty degrees, while Layer2 had included a 
twist of positive ten degrees, then the Add option would 
result in a final twist effect of negative ten degrees.

Move Up/Down•	 : If you select the Replace composite 
method, the specific order of the layers within the layer 
hierarchy will be very important, as parameter settings in 
higher layers replace those in lower layers (see above for 
additional explanation). You can change the order of layers 
within the hierarchy by clicking the Move up or Move down 
button to move the selected layer either up or down one level. 
Clicking the button a second time will repeat the action.

Repeat Interval•	 : Specifies the number of frames for each 
cycle of a repeated animation clip.

Repeat Count•	 : Specifies the number of times that the 
selected clip repeats in your animation.

Animation Sets Tab
Animation sets allow you to store a series of animation clips 
that are frequently used in combination. For example, you could 
animate a figure raising its arm above its head and save the limb’s 
movements to a named animation set.
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Creating & Editing Animation Sets
To work with animation sets, open the Animation palette by 
selecting Window > Animation Palette. Click the Animation 
Sets tab to open the Animation Sets palette, as shown:

The Frame Rate, Time control, Frame Indicator, Play controls, 
and Skip Frames button all function as described in previous 
sections of this chapter.

Figure 21.24

To create a new animation set, click the •	 New button and 
name your new set. Doing so will populate the Animation 
Sets tab with additional editing controls.

To delete an animation set, select the set from the pop-up •	
menu to the right of the Attributes button, and click the 
Delete button.

To add selected items and/or frames to your animation set, •	
click and drag to make your selection and click the + button. 
You can select any combination of items/frames. The start 
and end frames will be made identical for all items in the 
animation set. 

To remove selected item(s) and/or frame(s), make your •	
selection and click the – button.

Figure 21.25

Setting Animation Set Attributes
The Attributes button is for use with Python scripts. You can add 
any arbitrarily named attribute with an associated value. Using 
Python scripts, you can use these attributes any way you wish. For 
example, you could create a Python script that causes a figure to 
blink their eyes repeatedly. For more information on using Python 
scripts with Poser, please refer to Part 7: PoserPython on page 517﻿, 
or to the PoserPython Methods Manual that accompanied your 
Poser installation.
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Applying Animation Sets to Figures
You can also apply animation sets to figures. For example, if you 
create an animation set of an arm being raised, applying that set 
to your current figure will cause its arm to raise in the exact way 
specified by the animation set. This feature can help you save time 
by allowing you to reuse complex animations over and over.

Using the Walk Designer
Of the wide range of human motions, walking is among the 
hardest to simulate with any degree of accuracy. Walking looks 
simple: just place one foot in front of the other. In reality, however, 
it is an incredibly complex motion involving a variety of muscles in 
the legs, torso, arms– practically the entire body. Thus, creating an 
accurate walk simulation entails a great deal of precision posing. 
Poser’s Walk Designer allows you to bypass most of this and 
create a realistic walk using just a few simple steps.

Figure 21.26

Creating the Walk
To open the Walk Designer, select the figure you’d like to 
animate in the Poser scene, then choose the Window > Walk 
Designer menu command.

Unless you want your figure to walk in place (without a walk path), 
create a walk as follows:

Create a walk path (your figure will follow this path when 1.	
walking)
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Create a walk using the W2.	 alk Designer.

The Walk Designer has two sections. The upper set of controls 
creates the walk’s larger motions, while the lower set lets you set 
up the walk’s secondary motions. To preview a walk, click the Walk 
button at any time while using the Walk Designer. The preview 
will loop indefinitely and the button will change to Stop.

Views
As you can see in the previous graphic, the Walk Designer includes 
a real-time preview of the walk being created. As you change the 
parameters, the walk changes to reflect your updates. You can 
specify the angle from which to preview your walk by checking the 
appropriate radio button underneath the Preview tab:

(default)•	 : Checking the radio button looks at the figure on 
an angle.

Side•	 : Checking the Side radio button looks at the figure’s 
side.

Front•	 : Checking the Front radio button looks at the figure’s 
front.

Top•	 : Checking the Top radio button looks down from the top.

The Walk Designer reflects your current Poser workspace’s 
foreground, background, and shadow colors, as well as 
tracking mode.

Figure Types
This step is optional, however it can address potential issues such 
as irregular or jerky motions in generated walks. To load a figure 
type, click the Load button in the Walk Designer and use the 
standard Open dialog to locate your desired character (*.CR2) file. 
Please see Appendix B: Poser File Structure on page 525 for more 
information about Poser file types, including CR2 files.

Try loading the same figure you’re working on. For 
example, if creating a walk for the Don figure, load him into the 
Walk Designer for best results.

Blend & Tweak Styles
Once you’ve loaded your figure type, you can begin designing your 
walk. By default, the sliders are all in the middle of their ranges. 
This combination applies a workable default walk. Dragging a slide 
to the right increases its value and effect, and vice versa. To create 
a walk:
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Drag the 1.	 Blend sliders to create the large motions. Use 
the preview to view all of the available settings. Try using 
combinations of several settings, and remember that small 
changes can produce dramatic results.

Adjust the 2.	 Tweak sliders to fine-tune the walk.

When your walk looks the way you want it to, click the 3.	 Done 
button to open the Apply Walk dialog (see below).

Clicking the Defaults button restores all sliders to their 
default positions.

Loading & Saving Walks
You can load and save walk files using the Walk Designer. This 
is not the same as saving animated poses to the Library palette. 
To save a walk, create it, then click the Save button to open a 
standard dialog box allowing you to specify the name and location 
for the saved walk. Select your desired path, enter a name for the 
saved walk, and click OK.

To load a walk, click the Load button to open a standard Open 
dialog, allowing you to specify a path and filename for the walk 
file to load.

For greatest realism, load walks created using the same 
figure type.

Applying Walks
Once you’ve created your walk, you need to apply it to the figure’s 
walk path (see Creating a Walk Path on page 340 for instructions 
on creating walk paths). The Walk Apply dialog allows you to 
specify various options for applying your newly created walk. If you 
want your figure to walk in place, you can use this dialog without 
having a walk path.

You have the following options when applying walks:
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Figure 21.27

Figure•	 : If your scene has more than one figure in it, the 
Figure pull-down menu allows you to select the figure to 
apply the walk to.

Walk in Place/Follow Path•	 : Clicking the Walk in 
Place radio button causes the selected figure to walk in place 
without going anywhere. You can use this option to create a 
walk without a walk path. Alternately, if you wish your figure 
to follow a walk path, click the Follow Path radio button.

Path•	 : If your scene has more than one walk path, you can use 
the Path pull-down menu to specify the walk path to use.

Align Head to•	 : Checking the Align Head to box lets 
you control how the figure’s head acts as it moves along the 
walk path. One Step Ahead keeps the head aligned with the 
body and produces the most head movements. End of Path 
keeps the figure’s head looking at the end of the walk path 
no matter where it leads. Next Sharp Turn aligns the head 
to the turns in the walk path, the head only moving when the 
path curves.

Always Complete Last Step•	 : Checking the Always 
complete last step box forces the walk animation to 
complete within the allotted time. This is useful if the walk 
ends in mid-stride at the end.

Transition From/To Pose at Start/End Frames•	 : The 
Transition from pose at start and Transition from pose 
at end options allow your figure to smoothly transition into 
and out of the walk at the beginning and end of the walk 
cycle, respectively. When enabled, Poser interpolates between 
the figure’s pose at the start of the walk and the settings you 
specified in the Walk Designer, and vice versa at the end 
of the cycle. For example, you can use this feature to quickly 
set up a runner by posing the figure in the crouched starting 
position, designing a run, and specifying a realistic transition 
time. When you play your animation, the runner will come off 
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the starting blocks and begin the run. Checking one or both 
boxes enables the specified option(s). Once enabled, enter the 
number of frames to be used for the transition. Longer time 
periods (more frames) allow more realistic movements and 
vice versa.

Start Frame•	 : Enter the frame in your animation where the 
walk will begin in the Start Frame field.

End Frame•	 : Enter the frame in your animation where the 
walk will end in the End Frame field. Poser suggests a value 
that is expected to yield a natural walk speed. The more 
frames allocated, the more time a figure will take to walk 
along the specified path.

Create Keyframes in•	 : The Create Keyframes in 
setting allows you to select either a new or existing animation 
layer for your walk keyframes. Animation layers allow you to 
organize your animations, save and reuse specific aspects of a 
larger animation.

We recommend that you create the keyframes in a new 
animation layer; click the “New animation layer” radio 
button to select this option. Alternately, you can choose 
to use an existing animation layer by clicking the “Layer” 
radio button, and selecting the name of the layer from 
the pop-up menu. If you do not wish to use animation 
layers, you can simply write all keyframes to the Base 

Layer. For more information about animation layers, 
please see Layers Tab on page 331﻿.

Creating a Walk Path
Creating a walking figure is a two-step process. The first step 
entails creating a walk path for your selected figure that defines 
where s/he is going to walk. The figure can walk in place or along 
a path.

Walk paths are designed to work with the Walk Designer (see 
Using the Walk Designer on page 336﻿). While the Walk Designer 
specifies how your figure walks, a walk path specifies where. The 
path is a curve drawn in the Document window that sets the 
figure’s course as it moves about the Poser workspace. Create the 
path, design the walk, and the figure walks along the path from 
start to end, stopping at the end.

To create a walk path, Select Figure > Create Walk Path. A 
default path appears in the Poser workspace. We recommend 
shifting to the Top camera and zooming out to get the best view of 
your scene and walk path, but you can work using any camera you 
like. The following image shows a default walk path:
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Figure 21.28

 Walk paths must be created on the ground plane.

Shaping Curves
The curve’s position is defined using control points. Click and drag 
control points to shape your path any way you like:

Figure 21.29

You can position the beginning and end of the walk path by 
dragging the end control points. You can also reposition the entire 
walk path by selecting the ring that appears when your cursor is 
near the walk path, which functions like the Figure Ring discussed 
in Selecting Body Parts on page 127

Adding and Removing Control Points
To add control points, simply click anywhere along the line. Your 
new control points appear. Adding control points can add detail 
and/or lengthen your walk path:
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Figure 21.30

To delete control points, press and hold Opt/Alt while clicking the 
point you wish to remove.

Once you have completed your walk path, use the Walk Designer 
to design a walk for your figure. Please refer to Using the Walk 
Designer on page 336 for more information about the Walk 
Designer.

Figure 21.31

Because of the nature of the spline used for walk paths, it 
is impossible to create a hard right-angle turn. These and other 
abrupt direction changes can result in unnatural-looking walks.

Once you have created a walk using the Walk Designer, 
you can delete the walk path. The figure will still behave as 
though the walk path was present.
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Sound
Poser allows you to import sounds, which play when your animation 
plays. This is a great way for you to add soundtracks, speech, 
etc. to your animations. To import a sound clip, select File > 
Import>Sound and use the standard Open dialog that appears to 
locate your desired sound file. If you wish to import a speech sound 
clip for use with the Talk Designer, select File > Import>Lip 
Sync Audio (see below for information on the Talk Designer). 
Imported sounds attach to your animations at the first frame and 
play whenever the animation is played. Also, you can only import 
one sound file. If your animation calls for more than one sound, edit 
your desired sounds together in an audio editing application and 
create a new sound file for importing into Poser.

Importing Sound
Selecting either File > Import>LipSync Audio or File > 
Import>Sound allows you to import WAV sound clips that you 
can use as a soundtrack for your animation. Imported speech or 
sounds are added to the beginning of your animation and play 
every time you play your animation. Upon selecting this option, a 
standard Open dialog appears, allowing you to select the filename 
and location of the sound file you wish to import. If you selected 
the LipSync Audio option, the Talk Designer will open with 
your specified audio file selected. Please refer to Syncing Sound 
& Motion on page 344 for information on working with imported 

sounds.

 Importing sounds files will add keyframes based on the 
current frame rate selected. For example a two second long 
sound file will expand the default animation to 60 frames if a 
frame rate of 30 frames per second has been selected for the 
animation

Editing Sound
Sound duration appears in the Sound Range bar at the bottom of 
the Animation Palette. You can clip imported sounds by shortening 
the sound bar. However, if sound playback begins at any frame 
other than 1, the beginning of the sound will be clipped.

Figure 21.32

To specify start and end frames for the sound, drag arrows on either 
side of the sound bar.
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Syncing Sound & Motion
The Graph palette displays a graphic representation of the sound 
file called a waveform, which lets you see where changes in sound 
occur. You can use this information to position keyframes in your 
animation. Simulate speech by matching peaks in the waveform 
with changes in mouth position, as shown above. To display 
waveforms in the Graph palette, open it as described in Using 
Graphs on page 322 and click the Toggle Sound Display button 
to toggle waveform display on and off.

Figure 21.33

Using the Talk Designer
Poser’s Talk Designer automates the task of animating facial 
features for speech. The Talk Designer synchronizes morph 
targets, Emotional Tweak controls, and powerful eye and head 
motion modelling algorithms with your sound file, making it much 
easier to animate realistic facial expressions for speech.

The Talk Designer is configured using the Talk Designer palette. 
This palette can be accessed in the following ways: 

Select File > Import>Lip Sync Audio to import a sound file, 
as described above. At the end of the import process, the Talk 
Designer palette will automatically open with your imported audio 
file selected.
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Figure 21.34

Select Window > Talk Designer to open the Talk Designer 
palette at any time.

Configuring the Talk Designer
The Talk Designer palette settings are described in the following 
sections. When you have configured the Talk Designer to your 
satisfaction, click the Apply button at the bottom of the palette to 
generate a lipsync animation based upon the settings you specified.

Input Files

Sound file•	 : Clicking the “...” button next to the Sound 
file setting allows you to browse to the location of the sound 
file you wish to use for your lipsync animation. Poser supports 
WAV file, as well as AIFF files on the Macintosh.

Supplemental text•	 : For better accuracy, we recommend 
that you include the text of the spoken words in the 
Supplemental text field. Text entries in this field will be 
required if you need to specify an alternative language. You 
can click the “...” button to browse to a text document, or 
click on the “+” button to open a text box and enter the text 
directly.

Language•	 : If you add supplemental text, use the Language 
pull-down menu to specify the language used. In order to 
select another option from the Language menu, you must 
have text entered in the Supplemental Text field. After 
entering your text, you will have the option to select English, 
French, German, or Japanese.
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Viseme map file•	 : A viseme map file provides information 
about which phonemes (speech sounds) are matched to 
which specific visemes, or facial expressions. These viseme 
map files are directly linked to the morph target setup of the 
individual figure. If you are working with any of the newer 
figures included with Poser, you can simply use the default 
viseme map file for the figure. If you wish to use a figure from 
a previous version of Poser, please make sure that a viseme 
map is provided in the associated pop-up menu. If you use 
a figure from a third-party source that was created with a 
different morph target setup, you will need to provide the 
viseme map file that accompanies the figure. We recommend 
that you place the viseme map file into the \Runtime\LipSync\ 
folder that accompanies your Poser installation. Doing so 
will add the file to the pop-up menu in the Talk Designer 
palette. Alternately, you can click the “...” button to browse 
to the location of the viseme map file, if you wish to keep it in 
another location.

If you are unsure whether or not your custom figure was 
created following the morph target standards for included 
Poser figures, you can try your animation using the default 
viseme map file. Smith Micro cannot support third-party 
figures. If you are dissatisfied with the results, you will need to 
contact the content creator. 

Configuration

Figure•	 : Specify which figure in the scene you wish to use for 
the lipsync animation, by selecting the name of the figure from 
the pop-up menu.

Start frame•	 : Specify the Start Frame number for the actual 
lipsync animation. By default, the Start Frame setting is set 
to the Start Frame of the entire scene animation (frame 1).

End frame•	 : Specify the End Frame number for the actual 
lipsync animation. By default, the End Frame setting is set to 
the End Frame of the entire scene animation (generally frame 
30, unless you have specified a different scene End Frame). 
Once you load a sound file, the End Frame setting will 
default to match the length of the sound file. 

If the End Frame number specified in the Talk Designer 
is greater than the End Frame for the entire scene animation 
(as specified on the Base Layer), then additional frames will be 
appended to the scene to accommodate the difference.

Create Keyframes in•	 : The Create Keyframes in setting 
allows you to select either a new or existing animation layer 
for your lipsync animation keyframes. Animation layers allow 
you to organize your animations, save and reuse specific 
aspects of a larger animation.
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We recommend that you create the keyframes in a new 
animation layer; click the “New animation layer” radio 
button to select this option. You will be asked to name 
the new layer. Alternately, you can choose to use an 
existing animation layer by clicking the “Layer” radio 
button, and selecting the name of the layer from the pop-
up menu. If you do not wish to use animation layers, you 
can simply write all keyframes to the Base Layer. For more 
information about animation layers, please see Layers Tab 
on page 331﻿.

Enunciation•	 : The Enunciation slider allows you to 
configure the degree to which the Talk Designer will adjust 
a figure’s visemes, or facial morphs, in response to changes in 
the audio file’s perceived energy. Poser automatically adjusts 
visemes to correlate to the energy of the selected sound file. 
However, you can use the Enunciation slider to raise or 
lower the degree of reaction, to counteract or supplement the 
automatic viseme adjustment. Move the slider to the right to 
increase enunciation, or to the left to decrease.

Head Motions

Eye Blink Rate•	 : The Talk Designer can add intermittent 
eye blinks that have been modeled on studies of actual human 
blink rates, in order to animate blinks realistically in relation 
to the animation of speech. The Eye Blink Rate slider allows 
you to specify an average blink rate, measured in blinks per 

minute (BPM). To change the average blink rate, simply click 
and drag the slider, or click on the numerical value in the 
textbox and enter a number directly. The default value is 12.5 
BPM. A setting of zero (0 BPM) disables the automatic blink 
feature, which means that with this setting you must animate 
all eye blinks manually.

Create eye motion•	 : When people speak, their eyes 
generally look in different directions with relation to their 
subject matter and surroundings. Adding eye movements can 
result in a more realistic animation. Check the Create eye 
motion checkbox to have Poser add eye movements to your 
lipsync animation.

Create head motion•	 : People naturally move their heads 
during speech, which means that adding head motion to your 
animation can yield more realistic results. Check the Create 
head motion checkbox to have Poser add head motion to 
your lipsync animation for you.

Emotional Tweaks

The Talk Designer includes six Emotional Tweaks, which are 
morph targets that can be used in conjunction with speech. These 
morph targets are based upon facial expressions associated with 
the following emotions:

Anger•	
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Disgust•	

Fear•	

Joy•	

Sadness•	

Surprise•	

Each of these Emotional Tweaks is adjusted by a slider, which 
ranges between -100% and 100%. The values within this range 
represent the degree to which each particular emotion will 
manifest in the facial expressions of the figure during the lipsync 
animation. Feel free to mix and match the Emotional Tweaks 
slider values to suit your specific needs. To adjust the values, you 
can either move the sliders to the right or left, or you can click on 
the numerical value to the right of the slider and enter a number 
directly.

Importing BVH Motion Capture 
Files
Selecting File > Import>BVH Motion allows you to import 
motion-capture files in the popular BVH format. A standard Import 
dialog appears, allowing you to select your desired path and 
filename.

To determine the correct axis or scale for the BVH files consult 
the developer’s readme or documentation. Developers such as 
Biovision or House of Moves will provide this information. Or, you 
can specify whether a figure’s arms are aligned in the X or Z axis 
during import. The align axis is determined at the time of recording. 
Choose the correct axis so your figure will move correctly. Begin 
by selecting the body. Import the BVH file and select the Z-Axis 
arm alignment and Scale Automatically options. Some actors 
may not be recognized, but the BVH file will still load. If you make 
a mistake, return to Frame 1 and re-import the file. Imported BVH 
keyframes are applied to the currently selected figure and can 
be edited like any other keyframe (see Editing Keyframes on the 
Timeline on page 327﻿).

 In some cases, figures can float above the surface of the 
floor after you import BVH data. Choose the Scripts > Utility 
> dropFigToFloorAllFrames command for a useful Python 
utility that drops the figure to the floor across all keyframes.

Advanced Animation 
Techniques
This section is where we stop talking about technical details for 
a moment and focus on a few artistic considerations. Editing 
animations is pretty easy work in and of itself. Getting your 
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animation to look just the way you want it and adding realism are 
the hard parts. A jerky movement can turn smooth and flowing or 
an unrealistic motion can become realistic if you keep a few simple 
techniques in mind. 

Keyframes and Timing
How should you space keyframes? Begin by considering time and 
frame rate. Space keyframes so that the motion looks natural at 
the selected frame rate. For example, if you have a motion that 
requires 4/5 of a second, you’ll need 24 frames at 30fps, 20 frames 
at 24fps, 9 frames at 12fps, etc. The basic formula is frame rate (in 
frames per second) times motion duration in seconds = number of 
frames required.

Creating Realistic Motion
Now that you’ve gotten the number of frames required for 
a motion down, what’s next? Break down the motion into 
component parts. For example, look at a baseball player swinging 
a bat. At first glance, it may look like the arms are moving. 
Upon closer inspection, however, you see that the entire body is 
in motion. Some movements, like the arms and legs, are more 
pronounced that others. So, begin with the large movements then 
go back and work on the finer adjustments. Using our baseball 
player example, you could start with two keyframes: One at the 

beginning of the swing, the other at the end. 

Previewing this animation with only two keyframes would probably 
give you a pretty good result, however the details are where your 
animations will shine. 

Now that the major motions are roughed in, let’s add some detail. 
For example, add the hip swings, shoulder tilts, etc. The subtle 
details may not be overly noticeable, but your viewers will pick 
up their presence or absence though they may not be able to tell 
you what’s wrong with your animation if these elements are not 
present. Poser’s Animation palette and graph (described in the 
previous sections) are ideal for this fine-tuning. Smooth transitions 
don’t occur in all movements. For example, when a bat strikes a 
fast-moving baseball, there is an immediate change in direction. 
This is an animation where linear interpolation might be better 
suited. You can adjust splines in the Graph palette, or change 
interpolation types to create motions. You can adjust splines or 
change interpolation types in the Graph palette.

By working this way, you can create any kind of action and can 
make that animation look as realistic as possible.

Long/Complex Animations
If you are trying to make a long movie or one that incorporates 
changing cameras, you should create small clips and edit them 
together in a video editing application such as Adobe Premiere.
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Saving Animations to the 
Library
You can save animations to the Library palette as still (single-
frame) or animated (multiple frame) poses for use with other 
figures/props. See Adding Items to the Library on page 113 for more 
information on saving still or animated poses to the Library.
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Chapter 22: Rendering 
Animations
Your can access the Movie Settings window by selecting 
Animation > Make Movie. This window can also be accessed 
via the Render Settings dialog. The Movie Settings window 
appears as follows:

Figure 22.1

To use the Movie Settings window:

Select your desired movie format using the 1.	 Format pull-down 
menu. Your available options are:

�� Image Files: This option creates an Image 
Sequence, which is a series of still images, one for 
each frame in your animation. For maximum value results 
and optimal quality, we recommend using the Image 
Files option to render your final movie, and then using a 
compositing tool for editing and post-production work.

�� AVI (Windows)/QuickTime (Macintosh): These 
are the default Windows/Macintosh movie formats. We 
recommend that you use these formats only for preview 
purposes while still working on your animation, as they 
provide the fastest possible access to rendered results.

�� Flash: Adobe Flash is a popular format for animations 
posted on Web sites.

If you have selected Flash format, click the 2.	 Options button 
for settings specific to that format. The Flash movie options 
will be discussed in detail later in this chapter.

Select which renderer you wish to use for your animation 3.	
using the Renderer pull-down menu. Your options are the 
FireFly, Sketch or Preview render engines. See Chapter 
18: Using The FireFly Render Engine on page 285 for more 
information about the FireFly renderer, and Chapter 19: The 
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Sketch Designer on page 304 for more information about the 
Sketch Designer renderer. The Preview renderer provides a 
quick draft-quality render of your movie.

Under the 4.	 Options section, you can enable the following 
options for AVI/Quicktime and image files, by checking the 
appropriate checkboxes:

�� Antialias: Antialiasing is available with the Preview 
render engine, to improve the quality of images in draft 
preview renders.

�� 2D Motion Blur: This option provides realistic 2D 
motion blurring effects to images and animations 
rendered with the FireFly or Preview render engines. Use 
the Blur Amount value to customize the results of this 
effect.

Specify your desired export 5.	 Resolution options:

�� Frame Size: Select your desired frame size in pixels by 
entering your desired width and height in the Width and 
Height fields, respectively. Some standard movie sizes 
are: 160x120, 320x240, and 640x480.

�� Constrain Aspect Ratio: Checking the Constrain 
Aspect Ratio checkbox preserves the animation’s 
aspect ratio (width divided by height). For example, if 
you begin with 640x480 and change the 640 to 1280, 

the height will automatically change to 960. Clearing 
this checkbox disables this option. Larger movies require 
vastly increased rendering times and take up far more 
room on your hard drive. 

�� Quick-Scale Resolution: The Quick-Scale pop-
up menu offers quick access to four different render 
scale options: Full Size, Half Size, Quarter Size, and 
Preview Size. Note that this feature is not intended to 
replace the Frame Size value, but rather is a tool for 
facilitating quick render previews, as the smaller scale 
render sizes require less time to calculate.

The production frame is determined by the aspect ratio 
resulting from the output width and height. You can set the 
production frame to be visible in the Document window’s scene 
preview area, by selecting  Display > Production Frame 
from the menu bar.

Specify your 6.	 Time Span settings:

�� Range: Enter the start and end frame numbers for the 
portion of your animation that you wish to render in the 
Start and End boxes. This feature is useful if you wish 
to save a subset of the total animation. For example, if 
you create a 60-frame animation, you could opt to save 
a 15-frame movie beginning 35 frames into the total 
animation. 
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Increment�� : Click the appropriate Increment radio 
button to specify how many frames to render in your 
movie output. Your choices are as follows:

All Frames�� : Clicking the All Frames button will render 
all frames in the specified range, as defined by the 
movie’s frame rate.

�� Frame Rate: Click the Frame Rate (number of frames 
per second) radio button to use the movie’s current 
output frame rate (as opposed to the actual frame 
rate of the Poser keyframe data) or specify your own. 
Enter the desired frame rate in the box, if you wish to 
specify a frame rate other than the rate defined for the 
document (for example, lower frame rates are generally 
recommended for Flash output). Higher numbers give 
smoother animations but require longer rendering times 
and take up more room on your hard drive. Please refer 
to Frame Rate on page 318 for a listing of common 
frame rates. 

�� Every Nth Frame: Clicking this radio button allows 
you to render fewer frames, for fast preview purposes. For 
example, rendering every 2nd frame takes half the time 
as rendering every frame, and so on. Specify your desired 
“N” value in the box.

Click the 7.	 Make Movie button to open the Save Movie 
dialog box, which allows you to browse for your desired folder, 
then click the Save button to save your new animation to 

the selected folder. Animation renders can take some time 
depending on your scene, animation settings, and computer, 
so please be patient.

AVI Options
When you choose to render your animation as an AVI, the Video 
Compression dialog includes the following settings:

Figure 22.2

Compressor:•	  Select which Codec you wish to use from 
the Codec pop-up menu. Note that certain Codecs offer 
additional configuration settings. Click on the Configure 
button, if enabled for your selected Codec, to set up your 
desired configuration.

Certain Codecs may require a specific image aspect ratio 
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in order to function properly.

Depending on which Codec you select, the following settings may 
also be available:

Compression Quality:•	  Adjust the Compression 
Quality slider to your desired level, from 1-100. Higher quality 
compression will take longer to generate and require more 
system resources to compute.

Key Frame every X Frames•	 : This setting specifies how 
often the codec will set up a keyframe in the resulting movie 
file. This is not to be confused with the keyframe frequency in 
your actual Poser animation.

Data Rate•	 : You can choose to specify a maximum rate of 
data processing in KB per second.

QuickTime Options
When you choose Quicktime format and click the Options button,  
the Compression Settings dialog opens. This dialog includes the 
following settings:

Figure 22.3

Compression Type:•	  Select which Codec you wish to use 
from the Compression Type pop-up menu. Note that certain 
Codecs offer additional configuration settings, as mentioned 
below. Available choices are Animation, Apple Pixlet 
Video, Apple VC H.263, DV-PAL, DV/DVCPPRO-NTSC, 
DVCPRO-PAL, DVCPRO50-NTSC, DVCPRO50-PAL, H.264, 
JPEG 2000, MPEG-4 Video, None, Photo-JPEG, and PNG.

Certain Codecs may require a specific image aspect ratio 
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in order to function properly. Depending on the codec you 
select, the selections will vary. 

The following settings are some common settings that may appear 
with one or more compression options:

Frames Per Second•	 : Enter the number of frames per 
second at which you wish your movie to run.

Key Frames Every x Frames•	 : This setting specifies how 
often QuickTime will set up a keyframe in the resulting movie 
file. This is not to be confused with the keyframe frequency in 
your actual Poser animation.

Frame Reordering•	 :

Limit Data Rate to x KBytes/sec•	 : You can choose to 
specify a maximum rate of data processing in KB per second

Optimized for•	 :

Encoding Mode•	 : Choose Multi-pass or Single-Pass

Color Depth•	 : Select your desired color bit depth from the 
Color Depth pop-up.

Quality•	 : Adjust the Compression Quality slider to your 
desired level, from 1-100. Higher quality compression will 
take longer to generate and require more system resources to 

compute.

Flash Options
Clicking the Flash Options button opens the Flash Settings 
dialog:

You have the following options when exporting Adobe Flash 
movies:

Figure 22.4
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Overlap Colors:•	  Checking the Overlap Colors checkbox 
causes Adobe Flash to take the color that is used the most 
and create a silhouette of the entire object (such as a figure 
or prop). The next color is placed on top of the first, and so 
on, with each layer of color containing the layers above it. 
Selecting this option makes for larger files, but will increase 
the quality of the final file. Deselecting this option causes 
blocks of different colors to appear next to each other with no 
overlapping, which could cause the animated object to appear 
broken or discontinuous.

Draw Outer Lines•	 : Checking the Draw Outer Lines 
checkbox draws a border around the entire silhouette.

Draw Inner Lines•	 : Checking the Draw Inner Lines 
checkbox draws lines around each color layer.

Line Width•	 : Enter the desired line width (in pixels) in the 
Line Width box.

Number of colors•	 : Enter the desired number of colors 
in the Number of colors box. Note that adding colors will 
increase the file size and download time for people viewing 
this file via the Web. Four colors are good for most situations, 
though the maximum possible is 253.

Color Quantization•	 : Quantization is the process of 
selecting the specified number of colors that best represent 

your Poser figure. You can select either Auto or Custom 
quantization of colors. In either case, your color choices will be 
saved with the project file.

Auto Quantization•	 : Check the appropriate radio button 
to select if you want the quantization to occur across All 
Frames or at a Specified Frame.

All Frames�� : This option can be useful in situations 
when you want color quantization to be applied to each 
frame; for example, if you are animating materials.

Specified Frame�� : If you selected Specified Frame, 
enter the frame number where the quantization should 
occur in the Specified Frame field. 

Custom Quantization•	 : You can select custom colors 
by clicking within the color preview windows to bring up 
the Poser Color Picker. The number of custom color preview 
windows will be determined by the Number of Colors 
setting (see above). Mousing over any of the preview windows 
will display the RGB color values for that color at the top 
right of the Custom Color display window. Click on the 
AutoGenerate Colors button to restore the default custom 
color values.

For optimal results when exporting to Flash format, use 
the scene preview Cartoon display style when preparing your 
scene.
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Chapter 23: The Face Room
Adding realistic custom faces and creating a personalized head can 
be an extremely complex undertaking, but Poser’s powerful Face 
room greatly simplifies the process. In just a few minutes, you can 
make your figure look like you, one of your friends, or anyone! With 
a few steps, you can reshape a figure’s face using a collection of 
dials that drive sculpting morphs, or import facial photographs to 
match the face in the images.

By default, an HTML Help window opens when you enter 
the face room. This window contains additional tips and tricks 
for obtaining optimal results. If you do not see this window, 
please select Window > Room Help.

The Face room creates heads for use with the following figures 
(listed from newest to oldest): 

Ryan, Alyson, and their ethnic variations, including lo res •	
versions

Poser 7 Figures: SimonG2 and Sydney G2•	

Other G2 Figures: JamesG2, Jessi G2, Kelvin G2, Koji G2•	

Apollo Maximus•	

Miki and Miki2•	

Poser 6 Figures: James and Jessi•	

Poser 5 Figures:  Don and Judy•	

The Face Room is shown below, with all palettes and options 
docked. If you need to show the Face Room windows, choose 
Window > Room Tools > Face, and select Face Preview, 
Photo Lineup, Texture Preview, Face Texture Tool, Face 
Shaping Tool as desired. These windows are described in the 
sections that follow.

Figure 23.1
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The number of palettes and options that you see in 
each room depends upon your screen resolution. At higher 
resolutions, the default work spaces display more palettes, 
while at lower resolutions you see fewer palettes:

The Face room contains the following interface elements in 
addition to some of the standard elements:

Photo Lineup (1)•	 : The Photo Lineup area is where you 
load images and align them using a variety of tools. Activating 
the Apply Shape checkbox generates geometry matching 
your photos. The texture map and the geometry based on the 
photos gets generated on the fly.

Face Texture Tool (2)•	 : The Face Texture Tool area lets 
you apply a multitude of ethnic and other settings to modify 
the current head texture map.

Face Preview window (3)•	 : The Face Preview window 
displays a preview of your 3D head with textures. This window 
features Mini Camera controls in its upper right corner. 
You can also use the Face Shaping Tool (see The Face 
Shaping Tool on page 366) to sculpt the face to your exact 
specifications.

Random Face button (4)•	 : Clicking the Random Face 
button creates a completely random face. This will erase any 
prior work you’ve done in the Face room and should be used 

with care. The Random Face feature is a great way to create 
realistic-looking characters by clicking a single button. Click it 
as many times as you like until you get the look you want!

Reset Face Room button (5)•	 : Clicking the Reset Face 
room button restores the default head shape and texture. This 
will erase all of your prior Face room work. Use this option 
with care.

Texture Preview window (6)•	 : The Texture Preview 
window lets you see your head texture map as you edit it and 
also allows you to load and save textures for further work.

Action buttons (7)•	 : The Action buttons are where you 
apply customized head geometries to your figures, spawn 
morph targets, or import head texture maps.

Face Shaping Tool palette (8)•	 : The Face Shaping Tool 
window is where you control the Face Shaping tool, which 
is the equivalent of the Morphing Tool (see Creating Morphs 
with the Morphing Tool on page 458﻿) for the Face room. You 
can modify heads by using the parameter dials and/or the tool 
in this room.

Each of these areas is discussed below in this chapter. 

As mentioned above, there are several methods for creating custom 
heads:
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Using two images to shape the geometry and create a texture •	
map.

Using the •	 Face Shaping tool to sculpt the head as you 
desire.

Using the •	 Texture Variation area to create custom texture 
maps quickly and easily.

Using the •	 Random Face feature.

The Face room allows you to do any or all of these things 
when creating heads. We’ll discuss the other functionality in the 
subsequent sections. For now, let’s walk through using images to 
create a custom head.

If you want to reset the Face room to its default state, 
click the Reset Face room button. This erases all loaded 
images, deletes geometry changes, and loses any texture 
modifications you might have made. Use this option with care!

Using Images to Create Heads
Creating custom 3D heads from existing images/photographs 
(digital or scanned) requires the following steps:

Load the images.1.	

Align the images (if needed).2.	

Align the geometry to the images.3.	

Apply the new shape to your figure.4.	

Apply the images you used to create the head as a texture map, 
then apply the geometry shape and texture to the head.

Once you’ve completed these steps, you can proceed to use the 
Face Shaping tool and/or the Texture Variation functionality. If 
you do not want to use your own images, feel free to skip ahead 
and explore the other head creation/customization methods.

Step 1: Images
Creating a personalized head that matches a real person involves 
using two pictures to create a texture map. Let’s load some images 
and build a personalized head!

Please follow these simple guidelines for optimum results:
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Figure 23.2

Front image•	 : The front image should be a straight-on front 
view with the subject directly facing the camera and with the 
camera level with the subject’s face. The picture should be 
close enough to capture plenty of detail. Lighting should also 
be adjusted to capture the most detail. Overly bright lighting 
will give the image a washed-out appearance, while overly 
dark lighting will not show off enough detail. The person’s 
mouth should be closed and the overall facial expression 
should be neutral for best results.

Side image•	 : The side image should be a direct side view 
with the subject facing 90 degrees from the camera and 
with the camera level with the subject’s face. The remaining 
guidelines for the front image apply to the side image as well. 
Ideally, the front and side views should be taken from the 
same distance.

The above images are great examples of ideal images. You can use 

less than ideal or even mismatched images, however you may get 
some unpredictable results. Each image has its own alignment tools 
that can help position it optimally (see next step). Of course, you 
can always experiment and have fun if you want to!

The Face room supports most common image formats.

You must import existing images. Poser does not have the 
functionality to create images. Images can be photographs, line 
drawings, paintings, etc. The Face room accepts most common 
image formats. Textures generated from these images are sized 
at 512x512 pixels by default.

Step 2: The LineUp
Begin by clicking the Load icon (see below) for the front or side 
image in the Photo Lineup area and locate the image you want 
to use. For each image, Poser will ask you to locate several points 
on the face. This will help it align and match the default 3D head 
to the images, which you can then fine tune. To locate the specified 
facial point on your own photo, click its location as shown in the 
example face.

For the front image, you’ll be asked to locate the outside corner of 
the figure’s right eye and left corner of the lips, as shown below:



Poser 8
Reference Manual 

362

Chapter 23: The Face Room

Figure 23.3

For the side image, you’ll need to locate the top of the right earlobe 
and the front of the chin in the same manner as you did for the 
front image.

The side image uses the subject’s right side. If your side 
image is of the subject’s left side, you can click the Flip icon to 
reverse the image.

Once loaded, the images appear in the workspace and the 3D head 
and texture map appear.

Figure 23.4

Loading the images and locating the requested areas allows Poser 
to do a good job of approximating the location and shape of the 
head geometry. You may, however, wish to go in and perform some 
manual adjustments of the geometry’s location relative to the 
image. 
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To do this, each of the two images in the Photo Lineup area has 
the following tools:

Load•	 : Clicking the Load icon opens a standard OS dialog 
allowing you to browse for and select your desired front 
image. Once you load an image, you’ll be prompted to locate 
various facial features. This helps Poser custom-fit the 3D head 
to the images, as described above.

Delete•	 : Clicking the Delete icon deletes the currently loaded 
image.

Zoom•	 : Clicking and dragging the Zoom icon allows you to 
zoom in or out of the current image, allowing you to more 
precisely position and shape the head geometry. Clicking the 
Zoom icon and dragging to the right or up zooms in, while 
dragging to the left or down zooms out. This tool simply 
shifts your point of view; it does not affect the images or the 
geometry. You cannot zoom out beyond your image’s original 
size.

Pan•	 : Clicking and dragging the Pan tool moves the image 
in the same direction as your mouse movement. This is 
particularly useful if you need to zoom in to a particular 
area. You can individually pan the front and side images up, 
down, left, or right. The front image will pan in the X and Y 
axes (side-side and up-down) and the side image will pan in 
the Y and Z axes (up-down and front-back). This tool simply 

shifts your point of view; it does not affect the images or the 
geometry.

Rotate Geometry•	 : Improper rotation may cause 
unsatisfactory photo lineup results. Ideally, the head should not 
be rotated relative to the camera. However, many photos show 
the head slightly rotated about the X axis (up and down), the 
Y axis (looking left to right), or the Z axis (tilting left to right). 
The Face room automatically detects and compensates for 
some rotation (about the Z axis in the front view and about 
the X axis in the side view), but you may still need to perform 
additional manual adjustments for best results:

To rotate about the X axis (front view), click and drag the ��
mouse horizontally while pressing Shift.

To rotate about the Y axis (front view), click and drag the ��
mouse horizontally while pressing Opt/Alt.

To rotate about the Z axis (front view), click and drag the ��
mouse horizontally without pressing any keys.

To rotate about the X axis (side view), click and drag the ��
mouse horizontally without pressing any keys.

Scale Geometry•	 : Clicking and dragging the Scale 
Geometry tool scales the geometry to align it to the image. 
This feature is useful if your loaded image(s) are larger or 
smaller than the geometry outline. You can pan up, down, left, 
and/or right. This tool scales the geometry without altering the 
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image or your point of view.

Pan Geometry•	 : Clicking and dragging the Pan Geometry 
tool and dragging the mouse pans the geometry. This feature 
is useful if your loaded image(s) are not perfectly aligned with 
the geometry. The front image will pan in the X and Y axes 
(side-side and up-down) and the side image will pan in the 
Y and Z axes (up-down and front-back). This tool pans the 
geometry without altering the image or your point of view.

Poser does a good job at calculating how to shape the head based 
on the images, however you’ll probably need to fine-tune the head 
for best results. The head appears superimposed on the images 
with red lines showing the facial features and green control points. 
In this case, the head is a bit off-center as can be seen by both the 
superimpositions and the texture map. How do you fix this? Easy: 
Perform a little virtual surgery.

Step 3: Cyber Face Lifts
Looking at your loaded images, you will see the red outlines of a 
head superimposed on the images. Each major facial feature (eyes, 
nose, mouth, chin, etc.) has one or more control points, which 
appear as green dots. All you need to do is move the control points 
until they match the underlying image. Do this by placing the 
mouse pointer over the control point you wish to move. The cursor 
will change, at which point you can drag the selected control point 
up, down, left, or right. For example, you’d move the middle nose 

point until it’s just under the bridge of the nose and the two side 
points until they’re at the corners of the nostrils, and so on. As you 
move the control points, you’ll see the head beginning to conform 
more and more to the figure. You will also see lines indicating 
how each control point has moved from its original position. If you 
wish to undo a control point move, simply use the [COMMAND]/
[CTRL]+[Z] command to return the control point to its previous 
position.

You can also move the entire head using the Rotate Geometry, 
Scale Geometry, and Pan Geometry tools, which are described 
above. These tools move the head outline and alter the head 
geometry to match. To move your image without altering the head 
geometry, use the Pan Image tool, also described above. This will 
cause the image to slide over the geometry.

If you make a mistake while moving the control points, you can 
press [COMMAND]/[CTRL]+[Z] or select Edit > Undo to undo 
your most recent change.

Please refer to the Face room HTML Help window for 
additional tips & tricks. By default, this window appears when 
you enter the face room. If it does not appear, select Window 
> Room Help to open the window.

Here’s an example after adjustments:
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Figure 23.5

You can use the Zoom tool to move in closer to your 
images for even more precise control over the results.

Step 4: Applying the Geometry/
Texture
The texture map is created in real time as you work. Enable the 
Apply Shape checkbox to apply your images to create a custom 
head, which will appear in the Face Sculpting window. The head 
geometry is dynamically updated as long as Apply Shape is active.

Enabling the Apply Shape checkbox will erase any work 
you may have done with the Face Shaping tool. If you want 
to use a combination of images and shaping, be sure to work 
with the images before using the Face Shaping tool. This also 
occurs with textures; loading images will undo any work you 
have done in the Texture Variation area (see below).

Creating Custom Textures
The Face room includes the Texture Variation area, which allows 
you to create custom head textures from scratch or modify existing 
textures. The Face Room generates a new texture and blends 
between the imported texture and the original Poser figure’s texture 
and attempts to color match the new texture to the base figure if 
selected by the user. It also allows the user to select the imported 
Face Room photo resolutions for the new texture. . 

To access the Texture Variation area, click the Texture Variation 
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tab in area 2 of the Face room. This area allows you to:

Create new textures from scratch by modifying the default •	
texture.

Modify textures created by loading images as discussed above.•	

Edit loaded texture maps (see below).•	

Be sure to load/create your texture before using the 
Texture Variation area, as doing so afterward will lose your 
changes.

The Texture Variation area uses parameter dials that function 
similarly to the dials in the Parameters palette, whose 
functionality is described in Parameters Palette on page 138. You 
can use the Parameter Dial menu to access dial settings, reset a 
dial, or open the selected dial’s Graph (discussed in Using Graphs 
on page 322﻿). You cannot, however, memorize Texture Variation 
dials. The available Texture Variation dials are:

Facial Color•	 : The Facial Color dials modify the color of 
several facial regions and include Beard dark/light, Eye 
sockets light/dark, Eyebrows lower light/dark, and 
Eyebrows upper light/dark.

Ethnicity/Age & Gender•	 : The Ethnicity/Age/Gender 
dials generate ethnic, age, and gender traits and include 

less/more African, less/more European, less/more 
Southeast Asian, less/more East Indian, Younger/Older, 
and Male/Female.

To modify your texture or the default texture, simply adjust •	
the dials. Your work will appear in real time in both the Face 
Sculpting and Texture Preview windows.

Textures created in the Face room are scaled to 512x512 
pixels. If you used higher resolution for photo matching and 
want to keep the higher resolution, choose Yes in the dialog 
that appears after pressing Apply to Figure. To use larger 
texture maps, you can also import a custom texture, then 
modify it.

The Face Shaping Tool
The Face Shaping Tool allows you to visually sculpt your custom 
head by selecting and moving vertices. The Face room contains a 
wide array of custom vertex editing parameters for the Poser head 
that allow you to create virtually any face imaginable. By default, 
the Face Shaping Tool is active whenever your cursor is within 
the Face Sculpting window. Just as with the Morphing tool (see 
Creating Morphs with the Morphing Tool on page 458), you can 
use any combination of clicking and dragging morph targets and/
or adjusting Face Shaping parameter dials in the Face Shaping 
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Tool palette.

Figure 23.6

To use the Face Shaping Tool:

Click the portion of the face you wish to adjust and drag the 1.	
mouse. This selects the vertex nearest the spot where you 
clicked and moves it in the direction you drag the mouse. 
You can use the Mini Camera controls in the upper right 
corner of the Face Sculpting window to position the head 
exactly where you want it at any time before, during, or after 
sculpting. Vertices are moved relative to your viewing angle. 
For example, if you are looking at the face head-on, clicking 
and dragging will move the morph up, down, left, and right. 
If you are looking at the top of the head, dragging will move 
vertices left, right, forward, and backward.

The 2.	 Face Shaping Tool can manipulate all selected 
parameters in the Face Shaping Tool palette. Checking 
the checkbox next to a parameter dial includes the specified 
vertex parameter when using the tool, and clearing it means 
the tool will not affect the specified vertex parameter. Even if 
a parameter is enabled, it may or may not be affected by your 
use of the tool. For example, selecting a vertex in the forehead 
may affect the eyebrows but may not affect the mouth. Select 
your desired parameter(s), then click and drag any vertex on 
the head.

Once you have a portion of the head the way you want it, you 3.	
can click the Pin button to freeze the selected vertex from 
further manipulation. Pinned vertices may move as you keep 
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adjusting other portions of the body part, however they will 
retain their current settings.

You can use the [COMMAND]/[CTRL]+[Z] command to undo a 
specific parameter change made with the Face Shaping Tool. Or, 
if you want to reset all morph targets to their default values (0), 
you can click the Clear Morphs button. Also, if you want to clear 
all pins, simply click the Clear Pin Points button. Both buttons 
are located in the Face Shaping Tool palette along with other 
functionality (see below).

The Face Shaping Tool Palette
The Face Shaping Tool adjusts the parameters available in the 
Face Shaping Tool palette, which uses parameter dials that 
function similarly to the dials in the Parameters palette. You can 
use the Parameter Dial menu to access dial settings, reset a dial, 
or open the selected dial’s Graph (discussed in Using Graphs on 
page 322﻿) You cannot, however, memorize Face Shaping Tool 
dials.

This is different than creating facial expressions since 
you are actually modifying head geometry instead of simply 
applying morphs to create a facial expression.

When sculpting a head, you can use the Face Shaping Tool, the 
dials in the Face Shaping Tool palette, or any combination you 

wish. The available Face Shaping Tool parameter dials are:

Facial Morphs•	 : The Facial Morphs dial groups includes 
the following sub-groups and dials:

Brow Ridge�� : The Brow Ridge dials are High/Low, 
Inner Up/Down, Outer Up/Down, and Forward Axis 
Twist.

Cheekbones�� : The Cheekbones dials are High/Low, 
Shallow/Pronounced, Thin/Wide, and Protrusion 
Asymmetry. 

Cheeks�� : The Cheeks dials are Concave/Convex, and 
Round/Gaunt.

Chin�� : The Chin dials are Forward/Back, Pronounced/
Recessed, Retracted/Jutting, Shallow/Deep, Small/
Large, Short/Tall, Thin/Wide, Chin Axis Twist, 
Forward Axis Shift, and Transverse Shift. 

Eyes�� : The Eyes dials are Up/Down, Small/Large, 
Tilt Inward/Outward, Together/Apart, Height 
Disparity, and Transverse Shift. 

Face�� : The Face dials are: Brow/Nose/Chin Ratio, 
Forehead/Sellion/Nose Ratio, Light/Heavy, Round/
Gaunt, Thin/Wide, Coronal Bend, Coronal Shear, 
and Vertical Axis Twist.

Forehead�� : The Forehead dials are: Small/Large, 
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Short/Tall, Tilt Forward/Back, and Forward Axis 
Twist. 

Jaw�� : The Jaw dials are Retracted/Jutting:, Wide/
Thin, Jaw-Neck Slope High/Low, and Concave/
Convex.

Mouth�� : The Mouth dials are Drawn/Pursed, Happy/
Sad, High/Low, Protruding/Retracted, Tilt Up/
Down, Underbite/Overbite, Mouth-Chin Distance 
Short/Long, Corners Transverse Shift, and Twist 
and Shift.

Lips�� : The Lips dials are Deflated/Inflated, Large/
Small, and Puckered/Retracted.

Nose�� : The Nose dials are Coronal Shear, Transverse 
Shift, Up/Down, Flat/Pointed, Short/Long, Tilt Up/
Down, Tip Transverse Shift, Transverse Shift, and 
Vertical Axis Twist.

Nose Bridge�� : The Nose Bridge dials are Shallow/
Deep, Short/Long, and Transverse Shift.

Nose Sellion�� : The Nose Sellion dials are Up/Down, 
Shallow/Deep, Thin/Wide, and Transverse Shift.

Nose Region�� : The Nose Region dials are Concave/
Convex and Frontal Axes Twist.

Temples�� : The Temples dial is Thin/Wide.

Ears�� : The Ears dials are Up/Down, Back/Front, Short/
Long, Thin/Wide, Vertical Shear, and Forward Axis 
Shear.

Ethnicity, Age, and Gender•	 : The Ethnicity/Age/
Gender dials generate ethnic, age, and gender traits and 
include less/more African, less/more European, less/
more Southeast Asian, less/more East Indian, Younger/
Older, and Male/Female.

Standard Figures>Poser 5•	 : The Standard 
Figures>Poser 5 dials generate the appearance of one or 
more of the standard Poser 5 figures and include Don, Judy, 
Will, and Penny.

To create/modify your head, simply adjust the dials or use the tool 
directly on the head. Your work will appear in real time in the Face 
Shaping Tool window.

Caricatures
The Caricature dial allows you to exaggerate or de-exaggerate 
the head and facial features. It has a meta effect, meaning it 
impacts the results of the other sculpting tools. Increasing the value 
increases the exaggeration, and vice versa, as follows:

The default value is 0. Values>0 apply exaggeration to the head, 
and values<0 but greater than –1 apply de-exaggeration. A value 
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of –1 corresponds to the default head. For example, if you created 
a long nose with the other tools, a value of 1 creates a very long 
nose, –1 is the default nose, and –3 creates a very short nose.

Caricature values near –1 will work for overall de-
exaggeration, however other tools (Face Shaping, Random 
Face, etc.) will have little effect due to the Caricature dial’s 
meta effect.

Use Morphs
The Face rooms’s morph database contains both symmetric and 
asymmetric targets. The Use Morphs radio buttons allow you to 
select between the following options:

Both•	 : This option makes all morph targets in the database 
available for interactive face sculpting. When you click on a 
point on the face, Poser will select morphs from either the 
symmetric or asymmetric morph target sets, depending on 
what morphs are available at that location and what will yield 
the best results.

Symmetry•	 : This option makes only the symmetric morph 
target set available.

Asymmetry•	 : This option makes only the asymmetric morph 
target set available. Adding slight asymmetry to the face can 

often improve the realism of a computer generated face, as no 
human face is perfectly symmetric.

Loading/Saving/Previewing 
Textures
The Face room loads the default Poser texture, which is visible in 
the Texture Preview window. The Texture Preview window 
shows real-time previews of your head’s texture beginning with the 
default and through any changes you make by loading images and/
or customizing textures. You can also load and save textures to your 
hard drive for later use. To load a texture, click the Load Texture 
icon on the left side of the Texture Preview window, which opens 
a Load Head Texture window that allows you to browse for the 
file you wish to load. You can modify loaded textures.

To save the texture being displayed in the Texture Preview 
window, click the Save Texture icon on the right side of the 
Texture Preview window, which opens a standard Save As 
dialog (see Saving a Scene on page 49 for information about the 
Save As dialog).

The Poser male figures use different texture coordinates than the 
female and child figures. When loading and saving textures, you are 
prompted to select if the texture is for the male figure. Select Yes if 
the texture if for the male, or No if the texture is for the female or 
child figures.
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Applying Custom Heads/
Textures
Once you’ve finished making changes to the head and/or texture, 
you may perform the following actions:

Apply to Figure•	 : Clicking the Apply to Figure button 
applies the head in the Face room to the currently selected 
figure in your scene. Face-room compatible figures are listed at 
the beginning of this chapter.

Apply Shape Only•	 : Clicking the Apply Shape Only dial 
applies the head shape to the currently selected figure without 
applying the texture map.

Apply Texture Only•	 : Clicking the Apply Texture Only 
dial applies the head texture to the currently selected figure 
without applying the head shape.

Spawn Morph Target•	 : Clicking the Spawn Morph 
Target button allows you to save the head as a morph target. 
Please refer to Spawning Morph Targets on page 470 for more 
information about spawning morph targets.

Import Figure Head Texture•	 : Clicking the Import 
Figure Head Texture button imports the currently selected 
figure’s head texture, which you can then modify by creating 
textures as described above. Imported textures retain their 

original sizes. For example, if you import a 1000x1000 texture, 
all changes you make to it in the Face room will retain the 
imported size. This is a great way to create textures that are 
larger than the Face room’s default 512x512 size.

If you apply one or more heads to a scene with no 
figure, the applied head(s) will become props. If your scene 
has multiple figures, the head will be applied to the currently 
selected figure visible in the Select Figure menu.

To remove a custom texture after applying it to your figure, 
go into the material room and select the faceroomskin 
material. You can then replace the applied texture map with 
one of your own, remove the image map, etc. as desired.

Saving Faces
To save faces from the Face room, you must save PZ3 files 
containing the applied head. You can also spawn morph targets.
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Chapter 24: The Hair Room
Poser’s Hair room allows you to create dynamic strand-based 3D 
hair for your figures or props. You can add hair wherever you like 
on any object in your scene and can add shaders in the Material 
room (see Chapter 13: The Material Room on page 204﻿) to give 
your hair almost any appearance from bleach blond to moss, 
lichens, grass, etc. (a shader tree is created for each hair group and 
is accessible in the Material room). You can even apply Force 
Fields (see Wind Force Fields on page 449﻿) to create realistic wind 
effects for your animations!

Hair contains many polygons that require hefty computing 
resources.

The Hair room appears as follows at 1280 x 960 resolution:

The number of palettes and options that you see in 
each room depends upon your screen resolution. At higher 
resolutions, the default work spaces display more palettes, 
while at lower resolutions you see fewer palettes:

Figure 24.1

In addition to some standard tools, the Hair room has the 
following interface elements:

Hair Growth Groups Controls (1)•	 : The Hair Growth 
Groups controls allow you to create, edit, and delete hair 
growth groups.

Growth Controls (2)•	 : The Growth Controls allow you 
to specify how hair grows on growth groups.

Styling Controls (3)•	 : As the name implies, the Styling 
Controls allow you to control the appearance of hair.
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Dynamics Controls (4)•	 : The Dynamics Controls allow 
you to control how your hair behaves during animations.

The following subsections will walk you through creating strand-
based hair.

You can find skull-cap props with pre-grown and styled 
hair in the hair>Strand-Based hair category within the 
Library palette.

Step One: Defining Hair Groups
Skullcap props for Ryan and Alyson and other figures have hair 
props pre-created. You can use the grouping tool to spawn props 
for this purpose too. 

 If you want to be able to use the hair you are creating for 
other figures, please refer to Adding Strand-Based Hair to 
the Library Palette on page 384 for more information before 
proceeding. 

The first step in creating strand-based hair is to define one or more 
group of polygons as a hair group. A hair group is a cluster 
of polygons that has been defined as an area on which hair will 
grow. A prop or skullcap can contain more than one hair group. 
For example, you can create multiple growth groups on a skull 

cap or hair prop to create a part in the hair; or small sections 
of a conforming hair prop, or a smart hair prop can be detailed 
with wisps of hair.  You learn how to create skullcaps in the Poser 
Tutorial Manual, Chapter 17: The Hair Room on page 179. 

 Please refer to the Poser Tutorial Manual, Chapter 4: 
Groups on page 16 for a general discussion about groups.  

Figure 24.2

To do this:

Select the object you wish to grow hair on.1.	

Click the 2.	 New Growth Group button in Area 1 of the 
Hair room to create a new group called Hair_1 by default. 
Subsequent hair groups are numbered sequentially (Hair_2, 
etc.). You can rename groups by entering a new name in the 
New Growth Group Name box that appears. Click OK to 
proceed or Cancel to abort.
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Click the 3.	 Edit Growth Group button to enable the 
Grouping tool and open the Group Editor palette. Be sure 
that you have the correct hair group selected before selecting 
polygons for the group. Please refer to The Group Editor on 
page 487 for information about using the grouping tools.

Select the polygons you wish to include in the hair group you 4.	
are creating.

You can create as many growth groups as you like, such as head 
hair, moustaches, beards, chest, back, etc.

Figure 24.3

Be sure that you have the correct hair group selected 

in the Group Editor palette before selecting polygons for the 
group!

Step Two: Growing Hair
Once you’ve created a hair growth group, the next step is to grow 
the guide hairs. 

As the name implies, guide hairs influence how nearby hairs will 
grow. To do this, click the Grow Guide Hairs button. The currently 
selected hair group will sprout guide hairs:

Figure 24.4

Guide hairs both shape the hair group and increase performance by 
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allowing you to toggle displaying the fully populated hair group on 
and off (see below). Either before or after growing the guide hairs, 
you can apply some general parameters to determine the overall 
hair shape. These are:

Figure 24.5

•	 Hair Length: The Hair Length parameter determines the 
overall length of the guide hairs and subsequent populated 

hairs. Increasing this parameter lengthens the hair and vice 
versa.

•	 Length Variance: Real hair tends to vary somewhat in 
length. The Length Variance parameter allows you to control 
how much the hair length will vary in the currently selected 
hair group. A value of 0 means that all guide hairs are exactly 
the same length while a value of 1 adds a great deal of 
variation. 

•	 Pull Back: Most hair on peoples’ heads tends to be combed 
or pulled back along the scalp. The Pull Back parameter 
controls the extent to which guide hairs are pulled pack. 
Increasing this value pulls the guide hairs farther back and 
flattens them along the scalp. Negative values push the hair 
forward and away from the scalp. 

•	 Pull Down: Just as most hair is pulled back, it can hang 
down thanks to styling, gravity, or both factors. The Pull 
Down parameter determines the extent to which this occurs. 
Increasing this value pulls the hair down and flattens it along 
the head and vice versa. Negative values create anti-gravity 
hair. 

Once you’ve completed this step, your hair will be in place and •	
will have its rough shape.

Don’t confuse the Pull Back and Pull Down parameters 
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as replacing gravity or other dynamics that you can set after 
styling the hair. These parameters merely set the hair’s starting 
positions.

Step Three: Styling Hair
Now that you’ve grown the guide hairs and set some basic 
parameters for how the hair will look, your next step is to style the 
hair the way you want it. You can do this by setting the included 
styling parameters and/or by using the Hair Edit tool. 

You can use the Hair Edit tool at any time after growing hair, 
although we recommend that you complete the previous step. 
Please see the following subsection for information on using the 
Hair Edit tool. 

You can toggle the Show Populated function on and off 
while you work to check your results as you go.

The hair styling parameters are as follows:

Figure 24.6
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•	 Show Populated: Checking the Show Populated 
checkbox displays both the guide hairs and the population 
hairs. This will show you exactly how the hair will look, but 
does increase display refresh time. The status of this box 
will not affect population of hair in the final render. Hair will 
always appear populated in a FireFly render.

•	 Hair Density: The Hair Density parameter controls the 
total number of hairs in the group. The number of hairs are 
displayed next to the dial’s label. Increasing this number 
makes the hair fuller and more lush. The ability to Control the 
total number of hairs is a powerful feature since it allows you 
to create custom effects, however the total number of hairs 
can impact rendering and redraw times. Experiment with this 
number to get optimum coverage without adding too many 
hairs.

 As a matter of trivia, there are roughly 100-150 hairs in 
eyelashes per lid, roughly 500-1,000 hairs on each brow, and 
roughly 100,000 to 150,000 hairs on the head..

•	 Tip Width: The Tip Width parameter controls the hairs’ 
widths (diameters) at their tips. Hair usually thins somewhat as 
it progresses from root to tip, so this number will typically be 
less than the Root Width parameter, below.

•	 Root Width: The Root Width parameter controls the hairs’ 

widths (diameters) at their roots. Hair usually thins somewhat 
as it progresses from root to tip, so this number will typically 
be larger than the Tip Width parameter, above.

•	 Clumpiness: The Clumpiness parameter determines the 
hairs’ tendency to form dreadlock-like bunches.

•	 Kink Strength: The Kink Strength parameter is the 
measure of how wavy/curly hair is. Increasing this value 
increase the hairs’ waviness, and vice versa.

•	 Kink Scale: The Kink Scale parameter determines the size 
of hair waves/curls. Increasing this value increase the hairs’ 
waviness, and vice versa.

•	 Kink Delay: The Kink Delay parameter specifies the 
distance from the root at which the hair begins to curl/wave. 
Increasing this value increase the distance from the root, and 
vice versa.

•	 Verts Per Hair: The Verts per hair parameter controls how 
many vertex points are in each strand of hair. Increasing this 
value results in smoother, more flowing hair but increases the 
system resources needed to render/redraw your scene.

•	 Style Hairs: Clicking the Style Hairs button selects the 
Hair Select tool and opens the Hair Style Tool palette (see 
below).
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Using the Hair Edit Tool/Palette
The Hair Select tool is only available in the Hair room. It allows 
you to directly edit guide hairs and create a nearly infinite variety 
of hair styles (parts, tails, etc.). You can access it by either selecting 
it in the Editing tools or by clicking the Hair Select button as 
described above. The Hair Style Tool palette appears as follows:

Figure 24.7

You have the following controls available for directly manipulating 
guide hairs:

•	 Add Hairs to Selection (1): Select the Select Hairs 
tool, then click and drag a rectangle around the guide hairs 
you wish to select for further styling. Unselected guide hairs 
are not affected by the Hair Edit tools. Selected hairs are 
all affected equally. Selecting more guide hairs can be faster, 
however you can select as few as one hair for precise control 
over the style.

Figure 24.8

For finer control over which hairs are selected, try 
switching cameras or using the Magnifier tool to zoom in 
close.
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Hair growth is based on the parent object’s polygon count. 
If you wish to add detailed hair groups to a low-poly prop or 
to a portion of a figure with a low poly count, you can spawn 
a prop of the area you wish to grow hair on, subdivide that 
prop in your favorite 3d modeling application, then re-import 
the prop and apply it where needed. This is the same idea as 
skullcaps except that you are not limited to heads.

•	 Translate Hairs (2): The Translate Hairs tool moves the 
selected hair vertically around or laterally around the camera’s 
X and Y axes depending how you drag. The translation may 
occur on the hair’s X, Y, and or Z-axes depending on the 
position of the camera relative to the hair.

•	 Curl Hairs (3): The Curl Hairs tool bends a guide hair. 
Hair rotation works in three dimensions, allowing you to 
make a lot of progress very quickly. Dragging perpendicular 
to the hair rotates it up and down (relative to your point of 
view). Dragging parallel to the hair rotates it in and out, again 
relative to your point of view.

•	 Scale Hairs (4): The Scale Hairs tool allows you to scale 
the selected hair along the camera’s X and Y axes. The hair’s 
affected axes will vary depending on the camera’s position 
relative to that item. Dragging in towards the root reduces the 
scale, and dragging away from the root increases the scale. 
Dragging laterally scales hair in two dimensions, and dragging 

vertically scales hair in the third dimension. The axes affected 
depend on your currently selected camera position. You can 
also press and hold Shift while using this tool to scale the 
selected hair(s) evenly in all three dimensions. 

•	 Remove Hairs from Selection (5): Select the Deselect 
Hairs tool, or simply hold down the [CTRL] key, then click 
and drag a rectangle around the guide hairs you wish to 
deselect from further styling. The Hair Edit tools do not affect 
unselected guide hairs.

•	 Translate In/Out (6): The Translate Hairs In-Out tool 
moves the selected hair(s) along the Camera’s Z axis (in and 
out). This translation may take place along the hair’s X, Y, and/
or Z axes. Dragging down pulls the hair towards you, and vice 
versa.

•	 Twist (7): The Twist Hairs tool rotates selected hair(s) along 
their own axis.

In addition to the editing tools, the palette has the following 
controls:

•	 Constrain Length: Checking the Constrain Length 
checkbox forces all selected guide hairs to retain their current 
lengths no matter how you use the hair editing tools. Clearing 
this box allows the length to vary depending on how you use 
the hair editing tools (for example, you could use the Hair 
Translate tool to lengthen some guide hairs to create a 
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ponytail.

•	 Falloff: The Falloff slider controls the portion of the hair 
affected by the styling. Moving the slider to the left causes the 
tools to only act near the tip of the hair. Moving the slider to 
the right causes the styling tools to affect more of the hair’s 
length. With the slider all the way to the right, the entire hair 
is affected from root to tip.

•	 Lengthen: Moving the Lengthen dial to the right 
lengthens the selected guide hairs and vice versa.

•	 Clear Selection: Clicking the Clear Selection button 
deselects all selected guide hairs.

To exit this tool, either click the Close box on the palette’s upper 
right-hand corner or select another Editing tool.

The Hair Edit tools do not affect figures or props in your 
scene, and the Document Editing tools do not affect hair.

Step Four: Setting Hair 
Dynamics
You’ve got your hair grown and styled. Now let’s add some 
dynamics to control how the hair will behave during animations:

Figure 24.9
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•	 Do Collisions: Checking the Do Collisions box enables 
collision detection for the current hair group, which will 
prevent hairs from penetrating other objects in the scene 
(for example, long hair will not penetrate a figure’s head). In 
order to ensure proper collision detection, make sure that all 
body parts with which you want the hair to collide have the 
Collision Detection checkbox set on the Properties palette.

•	 Gravity: The Gravity parameter controls the strength of 
gravitational force acting on the hair.

•	 Spring Strength: The Spring Strength parameter 
determines the hair’s springiness. Increasing this value 
increases the springiness. A rubber band is a good example of 
an object with a high amount of springiness.

•	 Air Damping: The Air Damping parameter specifies the 
hair’s air resistance that occurs whenever the hair is moving 
through the air. Short hair has a lower resistance than long 
hair. Set this parameter with care as excessive values could 
cause the hair to behave unpredictably.

•	 Spring Damping: The Spring Damping parameter 
controls the hair’s elasticity.

•	 Bend Resistance: The Bend Resistance parameter 
controls the hair’s resistance to bending or folding upon itself.

•	 Position Force: The Position Force parameter is a force 

that pulls the hair vertices towards their choreographed 
position. Increasing this value decreases hair dynamics, and 
vice versa.

•	 Root Stiffness: The Root Stiffness parameter determines 
how stiff the hair is at its root.

•	 Root Stiffness Falloff: The Root Stiffness Falloff 
parameter controls how quickly the hair’s root stiffness 
decreases from root to tip.

•	 Calculate Dynamics: Clicking the Calculate Dynamics 
button applies the current dynamic settings to the selected 
hair group. The number of frames in the keyframed animation 
determines the calculation length. Populated hairs do not 
display during calculation.

Hair Properties & Parameters
To access a hair object’s parameters and properties, you must first 
select the desired hair object. Strand-based hair has the following 
properties and parameters:
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Hair Properties

Figure 24.10

Name•	 : The Name field displays the hair object’s name. Enter 
a new name in this field if you desire.

Visible•	 : Checking the Visible checkbox makes the hair 
object visible and vice versa. Invisible objects are not included 
in any render calculations, and do not appear in the rendered 
scene. See Figure Properties on page 135 for information on 
animating the Visible property.

Visible in Raytracing•	 : Checking the Visible in 
Raytracing checkbox makes the hair object visible in 
raytraced reflections, such as if the figure is in front of a 
mirror. Clearing this checkbox makes the figure not appear in 
reflections.

Bend•	 : Checking the Bend checkbox enables bending for 
the selected hair object and vice versa. Bends are discussed 
in Bend Body Parts on page 83﻿. Remember that selecting 
Display > Bend Body Parts bends all scene objects and this 
property only affects the currently selected body part.

Casts Shadows•	 : Checking the Casts Shadows checkbox 
forces the selected prop to cast a shadow, which will be visible 
in your scene. Clearing this box means the selected hair object 
casts no shadow.

Displacement Bounds•	 : The Displacement Bounds 
property determines the hair object’s displacement boundary. 



Poser 8
Reference Manual

383

Chapter 24: The Hair Room

Please refer to Chapter 18: Using The FireFly Render Engine 
on page 285 for more information about displacement bounds.

Recalculate Dynamics•	 : The Recalculate Dynamics 
option recalculates the dynamics for the current hair object.

Shading Rate•	 : The Shading Rate allows you to specify 
the desired shading rate for the currently selected hair object. 
Please refer to Chapter 18: Using The FireFly Render Engine on 
page 285 for more information about shading rates.

Hair Parameters
Strand-based hair has the following parameters:

Figure 24.11

Dynamics•	 : The Dynamics parameter sets the amount by 
which the previously specified dynamics will be played during 
animations. A setting of 1 means the dynamics will play exactly 
as specified, a value of 2 means the dynamics will behave as 
though all values were set to 200% of their current settings, 
and so forth. Numbers below 1 reduce the amount by which 
dynamics are applied, and negative numbers apply the 
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dynamics in reverse.

XYZRotate•	 : The xRotate, yRotate, and zRotate 
parameter dials rotate the hair object around the selected axis.

Scale•	 : Increases or decreases the size of the hair object in 
all axes.

XYZScale•	 : The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the hair object in the selected 
axis.

XYZTran•	 : The xTran, yTran, and zTran parameter dials 
move the hair object along the selected axis.

Hair Colors and Materials
Each strand-based hair object in your scene has its own shader 
tree, which is accessible in the Material room, allowing you to 
color your hair and add interesting effects. Please refer to Chapter 
13: The Material Room on page 204 for more information about 
the Material room. As with any other object, you can select 
strand-based hair by clicking it in the Document window, using 
the Current Actor menu, etc.

Adding Strand-Based Hair to 
the Library Palette
Strand-based prop hair differs from geometry-based prop hair 
because it needs underlying geometry in order to “grow.” Strand-
based hair grows in strands, much like real hair, rather than being 
made from textured polygons like geometry-based hair. You can’t 
add strand-based hair to figures/props in the same manner as 
prop-based hair. As a result, you can’t save strand-based hair to the 
Library palette unless it is growing from underlying geometry.

There are three ways to save strand-based hair for later use:

Saving a PZ3 file with the hair object in it (you can do a merge •	
function later, as explained in Importing Poser Documents or 
Props on page 51﻿).

Saving a prop/body part with a hair object on it. In this case, •	
simply add the prop with the hair to your scene. For example, 
you could use the Group Editor to select polygons on a 
character’s head and create a skullcap prop, grow hair on that 
prop, and save the hair and prop to the Library palette.

The •	 Library palette includes skullcaps designed to fit the Don, 
Judy, James and Jessi figures. These skullcaps are available 
in the Hair category under their respective figures. To use a 
skullcap, add it to your scene, create and style hair, then save 
the skullcap with your new hair style back to the Library 
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palette for use on other figures. Add skullcaps to figures just 
as you would prop-based hair. This is the preferred method for 
saving strand-based hair.

Skullcaps are also useful because they have a higher 
polygon count than the underlying head, giving you more 
detailed control over hair surfaces. You can spawn props from 
any figure or prop, subdivide them in your favorite 3D modeling 
application, then apply them anywhere you like to obtain more 
detailed results.

To save strand-based hair to the Library palette:

Select a hair group and open the 1.	 Hair>Strand-Based Hair 
category in the Library palette.

Click the 2.	 Add to Library button.

You will be prompted to select your desired hair subset(s).3.	

Clicking the 4.	 Select Subset button in the Set Name dialog 
opens a hierarchical display allowing you to select the hair 
groups that you want to save. Be sure to save the parent 
object!

Strand-based hair is created on a per-object basis for each 
scene.
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Chapter 25: The Cloth Room
Poser’s Cloth room allows you to create realistic cloth that behaves 
like real fabric. Want to add custom clothing to a figure? Create a 
tablecloth? How about a flying carpet? Poser offers powerful tools 
that help you create dynamic cloth that responds realistically when 
animated. You can even apply a Force Field for realistic wind 
effects! 

Using the Cloth Room
The Cloth room appears as follows:

Figure 25.1

The number of palettes and options that you see in 
each room depends upon your screen resolution. At higher 
resolutions, the default work spaces display more palettes, 
while at lower resolutions you see fewer palettes:

In addition to standard UI elements, the Cloth room contains the 
following UI elements:

Cloth Simulations (1)•	 : The Cloth Simulation area 
allows you to create, delete, and set up cloth simulators.
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Cloth (2)•	 : The Cloth area allows you to convert objects 
to and from dynamic cloth objects and to set up collision 
detection for your cloth.

Cloth Groups (3)•	 : The Cloth Groups area is where you 
set up dynamic, choreographed, constrained, and decorated 
cloth groups.

Dynamics Controls (4)•	 : The Dynamics Controls group 
sets up dynamic parameters.

The cloth room help contains additional information about 
importing props for use as cloth.

Conforming vs. Dynamic Cloth
As mentioned in The Figures Category on page 97, conforming 
clothing is a Poser figure, while dynamic cloth consists of props 
with dynamic and other behaviors applied to simulate cloth. Poser 
supports both types of cloth.

Dynamic cloth adds incredible realism to your scenes by causing 
cloth objects to move as they would in real life. For example, you 
can use dynamic cloth to create the following types of items in your 
Poser scene:

 A tablecloth that drapes over a table•	

A slip cover over furniture•	

A flowing skirt that moves as a figure walks•	

Dynamic cloth objects require increased computing resources 
beyond those of conforming clothing. Items such as socks, bikinis, 
or tights don’t need to be dynamic since in real life these types 
of clothing tend to be close-fitting with little to no room for 
independent motion. You should generally use conforming clothing 
for these situations because it requires fewer computing resources.

Adding Dynamic Clothing
Dynamic clothing offers the most powerful means of clothing 
figures, allowing for realistic cloth draping and wrinkles. 
Additionally, it is very easy to create clothing props for use as 
dynamic clothing. Dynamic cloth retains its dynamics when saved to 
the Library palette, but you will need to create a new simulation 
whenever you add saved cloth objects. To add dynamic cloth to your 
current figure:

Select the item from the 1.	 Library palette and add it to your 
scene, then switch to the Cloth room.

Create a new simulation group, and select 2.	 Body as your 
desired collision object.

Recalculate the simulation.3.	
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Please refer to Chapter 25: The Cloth Room on page 386 for 
detailed information about the Cloth room and its controls.

Using Dynamic Clothing 
without a Figure
Dynamic cloth retains its dynamics when saved to the Library 
palette, but you will need to create a new simulation whenever you 
add saved cloth objects. To add dynamic cloth without a figure:

Select the item from the 1.	 Library palette and add it to your 
scene, then switch to the Cloth room.

Create a new simulation group, and select your desired 2.	
collision object(s), if any.

Recalculate the simulation.3.	

Please refer to Chapter 25: The Cloth Room on page 386 for 
detailed information about the Cloth room and its controls.

Step 1: Create/Set Up a Cloth 
Simulator
The first step in creating dynamic cloth is creating and setting up 
a cloth simulator. You may have as many simulators as you wish 
in your scene, however each simulator requires system resources 
(RAM/CPU cycles) and increases rendering time.

Figure 25.2

Creating the Simulator
To create a simulator, click the New Simulation button in the 
Cloth Simulation area of the screen to open the Simulator 
Settings dialog:
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Figure 25.3

The Simulator Settings dialog box has the following options:

•	 Simulation Name: Enter your desired name for the 
new simulator in the Simulation Name field. By default, 
simulators are numbered in the order they are created, e.g. 
Sim_1, Sim_2, etc.

•	 Simulation Range: You can either set the simulator to 
run throughout your entire animation or pick a set of frames 
during which the simulator is active by entering your desired 
frame numbers in the Start Frame and End Frame fields, 
respectively. Increasing the number of frames that a simulator 

is active requires greater amounts of system resources. During 
the frames prior to the start of a simulation, the cloth object 
will remain in its starting state. After the simulation ends, the 
cloth object will remain in its ending state for the rest of your 
animation. Additionally, the Steps per frame parameter dial 
controls the number of calculation steps per frame in order to 
smooth the cloth simulation. Increasing this value improves the 
simulation results but requires additional computing resources.

•	 Additional Cloth Collision Options: These checkboxes 
allow you to toggle the following additional collision detection 
options on and off. By default, collisions are calculated using 
cloth vertices against object polygons.

Object Vertex against cloth polygon�� : Checking 
the Object Vertex against cloth polygon checkbox 
performs additional collision calculations using object 
vertices and cloth polygons, which helps eliminate tears 
or holes that may occur when an object collides with the 
cloth. Enabling this option slows the simulation.

Object Polygon against cloth polygon�� : 
Checking the Object Polygon against cloth polygon 
checkbox performs additional collision calculations using 
object polygons and cloth polygons, which helps eliminate 
tears or holes that may occur when an object collides 
with the cloth. Enabling this option slows the simulation.

Cloth self-collision�� : Checking the Cloth self 
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collision checkbox allows a cloth to detect its own 
polygons during simulation, preventing (for example) a 
cape or a flag from passing through itself. Enabling this 
option slows the simulation.

•	 Cloth Draping: The Cloth Draping options are:

Drape Frame�� : The Drape Frame value allows you to 
set the number of frames per object to settle the cloth.

Calculate Drape�� : Clicking the Calculate Drape 
button calculates the cloth object’s draping behavior and 
caches the simulation. When calculating the simulation, 
cached drape settlings are added before beginning cloth 
simulations, meaning that the settled cloth drape is at 
frame 1 before the simulation begins.

When you have finished setting up the simulator options, click OK 
to accept your choices and create the simulator or Cancel to exit 
without creating the simulator.

The Cloth Simulation area has two other buttons:

•	 Delete Simulation: Simulation results are cached in a file 
during simulation computation, which Poser automatically 
loads to save time and resources. Clicking the Delete 
Simulation button deletes the cache contents.

•	 Simulation Settings: Clicking the Simulation Settings 
button reopens the Simulation Settings window, allowing 

you to alter your cloth simulator settings.

Think of a cloth simulator as an envelope supplying basic 
behavioral properties. You can have multiple cloth objects in 
each simulation and/or multiple simulations in each Poser 
scene. Each cloth object, however, can only belong to one 
simulation at a time. Increasing the number of simulations 
in a scene can add complexity and interest, but also requires 
increased computing resources.

The arrow at the top right of the Cloth Simulation area displays 
the currently selected simulator. Clicking this arrow opens a pull-
down menu allowing you to select any of the cloth simulators in 
your scene for modification.

Step 2: Cloth Controls
Now that you’ve created a simulator, your next step is to add cloth 
objects. Do this using the Cloth controls (area 2 of your screen).
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Figure 25.4

Clothifying Objects
To turn an object into a dynamic cloth object, select it and click the 
Clothify button to open the Clothify window, which displays a list 
of objects eligible to be turned into dynamic cloth. Use the Object 
to clothify pull-down menu to select your desired object, and click 
the Clothify button to make the cloth object, or Cancel to abort. 

Figure 25.5

To turn a dynamic cloth object back into a normal prop, select 
it and click the Unclothify button. The prop will return to its 
pre-clothified shape, however it will retain its vertex groups and 
dynamic parameters, meaning you won’t have to start from scratch 
if you re-clothify the object later.

You can also create static props and morph targets from cloth 
objects as described in Creating Props and Morph Targets on page 
401.

Specifying Collision Objects
Once the simulator is created and you’ve specified the basic 
parameters and created dynamic cloth, the next part of the 
simulator creation process is defining the objects that will use 
collision detection (collision objects) with the cloth. Each collision 
object will behave in accordance with the specified collision 
behaviors when contacting the cloth. Non collision objects will 
not use collision detection with the cloth object. To set up collision 
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objects, click the Collide Against button to open the Cloth 
Collision Objects window:

Figure 25.6

The Cloth Collision Objects window has the following options:

Add/Remove Collision Objects•	 : Clicking the Add/
Remove button opens the Select Objects window, which 
displays a hierarchical list of all the objects in your scene, 
including body parts on figures. By default, all scene objects 
are selected (selected objects are checked). Add and remove 
collision objects by checking/clearing the checkboxes next to 
each object listing in the window, then click the OK button 
to accept your choices or Cancel to abort. Added objects 
appear in the Current Collision Object pull-down menu in 

the Cloth Collision Objects window. You can set collision 
options for each collision object by selecting it using the pull-
down menu and specifying the desired settings.

Figure 25.7

•	 Collision Offset: The Collision Offset parameter 
determines the distance between a cloth object and a collision 
object at which the collision detection calculations begin. 
Increasing this value can help avoid accidental collisions, 
especially during animations, because Poser requires a little 
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time to calculate actual collisions. Increasing this value too 
high can consume extra computing resources. Experimentation 
will quickly yield the proper value for each simulation. 
Please see Collision Offset & Depth on page 394 for more 
information.

•	 Collision Depth: The Collision Depth parameter specifies 
how close the cloth object must be to a collision object 
in order for a collision to take place. Increasing this value 
increases the distance at which the cloth and collision object 
will collide. This is useful when creating clothing, because 
the cloth will be kept away from the figure. Increasing this 
distance makes the cloth appear more static but avoids having 
body parts penetrate the cloth (such as a leg poking through 
a skirt). Experimentation will quickly yield the proper value for 
each simulation. Please see Collision Offset & Depth on page 
394 for more information.

•	 Static Friction: The Static Friction parameter sets the 
coefficient of friction for the collision object. This is similar to 
the Dynamic Friction parameter except that this is the force 
required to get a stationary cloth in contact with a solid to 
start moving. For example, nylon over smooth plastic will have 
a very low amount of static friction while denim over wood 
will have a high amount. You can use the Collision Friction 
checkbox (see below) to use the collision object’s value or the 
simulation’s value.

•	 Dynamic Friction: The Dynamic Friction parameter sets 
the coefficient of friction for the collision object when the 
object is in motion. Moving a piece of cloth across a surface 
causes friction. Silk moving over a steel surface has low 
resistance, while cotton moving over skin or coarse sandpaper 
over rough wood has high resistance. You can use the 
Collision Friction checkbox (see below) to use the collision 
object’s value or the simulation’s value.

•	 Figure Collision Options: The Figure Collision 
Options allow you to specify how the current cloth object 
will behave when it drapes across/collides with a figure. Most 
clothes dressed on a figure are modeled in such a way so that 
they will fit on the target figure when the figure is in default 
pose. However, most simulations including figures and dresses 
will not use figure’s default pose at the start of simulation. In 
order for the simulation to work correctly, we need to simulate 
the cloth draping process: given certain frames, the underlying 
figure will interpolate from default pose to the start pose, and 
the draping simulation ensures the cloth fits the figure at the 
start frame:

	�� Start Draping From Zero Pose: Checking the 
Start draping from zero pose checkbox is used 
when creating cloth to be used as clothing on a figure. 
For example, you can convert conforming clothing into 
dynamic cloth objects and drape them over a figure 
beginning from that figure’s default pose. This is useful 
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when applying dynamic cloth to a posed figure.

�� Ignore Head Collisions: Checking the Ignore 
head collisions checkbox causes the collision detection 
not to apply when the cloth collides with a figure’s head. 
This is useful for cloth that will not normally touch the 
head, such as shirts, pants, etc.

�� Ignore Hand Collisions: Checking the Ignore 
hand collisions checkbox causes the collision detection 
not to apply when the cloth collides with a figure’s hands.

�� Ignore Feet Collisions: Checking the Ignore feet 
collisions checkbox causes the collision detection not to 
apply when the cloth collides with a figure’s feet.

Adding collision objects increases the computing 
resources required to calculate cloth behavior and dynamics. 
Thus, you should specify the minimum number of collision 
objects possible.

When you have finished setting up the collision objects, click OK to 
accept your choices or Cancel to exit without setting up collision 
objects.

The arrow at the top right of the Cloth area displays the currently 
selected cloth object. Clicking this arrow opens a pull-down menu 
allowing you to select any of the cloth objects in your scene for 
modification.

Collision Offset & Depth
The Collision depth and Collision offset dials are limited to 
minimum 0.1cm and maximum 10cm.

Before adjusting these settings, be sure to enable the Object vertex 
against cloth 
polygon and Object polygon against cloth polygon options in the 
Simulator Settings dialog. You may also try reducing the Steps per 
frame value from its default of 0.2 to as little as 0.005.

A real piece of cloth has two sides (inside & outside) and thickness. 
A cloth mesh is composed of polygons, which mathematically have 
zero thickness. The Collision Depth and Collision Offset dials 
emulate thickness by “extruding” the cloth inwards by the amount 
of Collision depth units and outward by the amount of Collision 
offset units. Thus, the cloth now has a “thickness” of collision 
offset + collision depth. Any specified collision object intersecting 
this volume will be treated as a collision.

Step 3: Cloth Groups
Objects being converted to cloth must have single-sided, connected 
(welded) polygons without caps. Once you’ve created a cloth 
simulator and cloth object, the next step is to create cloth groups 
(groups of vertices) within each object, thus subdividing the cloth 
object into regions (in the same manner as, for example, dividing 
a body part into different material groups). The exception is 
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decorative objects such as buttons, belt buckles, etc., which should 
be separate (non-welded) objects. Cloth groups use vertices instead 
of polygons, meaning that the Group Editor palette operates in 
vertex mode in the Cloth room (as opposed to polygons). You can 
convert polygon groups to vertex groups in the Cloth room by 
clicking the Add Group button to open a pop-up list of existing 
groups. Group names with the suffix [P] are polygon groups. 
Selecting polygon groups includes all vertices of the affected 
polygons. 

Figure 25.8

There are four types of groups available for cloth objects:

•	 Dynamic: By default, cloth objects are created with one 
dynamic group (_default_) comprising the entire object. 
Dynamic cloth groups are simulated using the Dynamics 
Controls (see following step), which determine how the cloth 
moves, folds or drapes as it responds to gravity, wind force and 
how an underlying figure/prop moves. Examples of moving 
figures and props include a ball underneath a carpet, or a 
figure underneath clothing. You can create multiple dynamic 
groups for each clothing object, and each dynamic group can 
have different dynamics settings. You cannot directly animate 
dynamic groups with regular keyframing. 

•	 Choreographed: Each cloth object can have one 
choreographed group. An empty choreographed group 
is automatically created when you clothify an object. 
Choreographed vertices can follow keyframed movement or be 
excluded from the cloth simulation.

•	 Constrained: Each cloth object can have one constrained 
group. An empty constrained group is automatically created 
when you clothify an object. Constrained vertices “stick” to 
corresponding polygon faces of the underlying figure and are 
useful for cloth areas that have to follow the movement of 
the underlying body part. They can be used to prevent straps 
on a dress from slipping down the shoulders, or to create a 
skirt’s belt that follows the waist’s movements. If you do not 
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place these vertices in a constrained group, gravity can cause 
the cloth to fall until the skirt hits the body or the ground. 
Constraining the belt vertices keeps the belt at the waist 
and reduces simulation time. If the belt contains complex 
geometry, the simulation will slow down. 

•	 Decorations: Each cloth object can have two decorations 
groups (one “soft” and one “rigid”. These groups are 
automatically created with empty contents when you 
clothify an object. The decoration groups animate, moving 
as underlying cloth moves while staying over the underlying 
body. Good candidates for decoration vertices include tiny or 
thin polygons such as pockets, belt loops, buttons, a knot in a 
tie, etc. These are usually items sitting on another cloth group 
and have only passive movement, either following underlying 
body movement or other parts of the cloth. Because of 
their small size and/or irregularity, these can cause issues 
if not placed into this group. The decorations group favors 
accessories that are geometrically separated from the cloth 
mesh object. There are two reasons for this:

If the decorations group shares vertices with the cloth ��
mesh, the decorations vertices will not be simulated. This 
causes the simulator to treat these areas as boundaries, 
resulting in increased movement of these areas compared 
to neighboring regions of the cloth.

Welding accessories to the cloth mesh often creates a ��
complex mesh where one edge is shared by more than 

two polygons.

The two types of decoration groups are:

Soft: �� Objects in the soft decorated group move with the 
underlying cloth and can flex as the cloth flexes. A good 
example would be a belt loop.

Rigid: �� Objects in the rigid decorated group move with 
the underlying cloth but do not bend or flex. Good 
examples of rigid decoration objects are buttons or the 
knot in a tie.

If you want the current cloth object to consist of a single dynamic 
group, you’re done. Continue on to Step 4 (below) to set your 
dynamics. If, however, you want to create multiple groups, you can 
do so using the following buttons:

•	 New Dynamic Group: Clicking the New Dynamic 
Group button opens the New Dynamic Vertex Group 
Name box. Enter your desired name for the new dynamic 
group and click OK to proceed or Cancel to abort. By default, 
your entire cloth object consists of a dynamic group called 
_default_.   Any vertices that are not part of other dynamic, 
constrained, choreographed, or decorated groups when you’re 
done creating/editing groups will remain in the _default_ 
group.
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Figure 25.9

Since each cloth object can only have one choreographed, 
constrained, and/or one each soft & hard decorated groups, 
you can only assign names to dynamic groups.

•	 Delete Dynamic Group: Clicking the Delete Dynamic 
Group button deletes the currently selected dynamic group.

•	 Edit Dynamic Group: Clicking the Edit Dynamic Group 
button opens the Group Editor palette, which allows you 
to add or remove vertices from the currently selected group. 
Please refer to The Group Editor on page 487 for information 
on using the Group Editor palette.

•	 Edit Choreographed Group: Clicking the Edit 
Choreographed Group button opens the Group Editor 
palette, which allows you to add or remove vertices from the 
currently selected choreographed group (_choreographed_). 
Please refer to The Group Editor on page 487 for information 
on using the Group Editor palette.

•	 Edit Constrained Group: Clicking the Edit Constrained 
Group button opens the Group Editor palette, which allows 
you to add or remove vertices from the currently selected 
constrained group (_constrained_). Please refer to The 
Group Editor on page 487 for information on using the Group 
Editor palette.

•	 Edit Soft Decorative Group: Clicking the Edit Soft 
Decorative Group button opens the Group Editor palette, 
which allows you to add or remove vertices from the currently 
selected soft decoration group (_softDecorated_). Please 
refer to The Group Editor on page 487 for information on 
using the Group Editor palette.

•	 Edit Rigid Decorative Group: Clicking the Edit Rigid 
Decorative Group button opens the Group Editor palette, 
which allows you to add or remove vertices from the currently 
selected rigid decoration group (_rigidDecorated_). Please 
refer to The Group Editor on page 487 for information on 
using the Group Editor palette.

Keep the following in mind when working with cloth groups:

Adding vertices to the current group removes them from other •	
groups. 

Removing vertices from the default group adds them to the •	
choreographed group. 
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Removing vertices from any group adds them to the default •	
group.

The arrow at the top right of the Cloth area displays the currently 
selected cloth group within the currently selected cloth object. 
Clicking this arrow opens a pull-down menu allowing you to select 
any of the cloth groups in the current cloth object for modification. 
To work on a different cloth object, use the pull-down menu 
available in the Cloth area (Step 2).

Step 4: Cloth Dynamics Controls
Once you’ve created and edited cloth groups, the next step is to 
define dynamic properties for each of the dynamic groups in the 
currently selected cloth object. Dynamic properties control how 
the dynamic groups will move and behave when the dynamics are 
calculated. The Cloth Dynamics Controls have the following 
buttons:

Figure 25.10
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•	 Calculate Simulation: Clicking the Calculate 
Simulation button takes into account all of the simulation, 
object, group, and dynamics settings included in the current 
simulation and calculates the behavior of all of the cloth 
objects in the simulation for all of the specified frames. Please 
see above for information on specifying cloth simulation frame 
ranges.

•	 Play Simulation: Clicking the Play simulation button 
plays the currently selected simulation, allowing you to see 
how the cloth behaves over time. If you don’t like the current 
behavior, you can alter any of the Cloth room settings and 
try again.

•	 Clear Simulation: Clicking the Clear Simulation button 
empties all stored data in the current simulation (such as 
altering collision settings, adding/removing objects, editing 
groups, changing dynamics control settings, etc.), allowing you 
to specify new dynamics, thus modifying how the cloth object 
behaves. If you clear the simulation and play the animation, 
what you are seeing is simply keyframe animation with no 
simulation being calculated.

The Cloth room includes the following dynamics controls:

Figure 25.11



Poser 8
Reference Manual 

400

Chapter 25: The Cloth Room

Fold•	  Resistance: The Fold Resistance parameter specifies 
the resistance to out-of-plane bending (folding). Increasing this 
value lessens the cloth’s ability to bend. Soft fabrics like silk 
fold very easily, so a low value (1.0) is appropriate. By contrast, 
hard leather tends not to fold, so a higher value would be 
appropriate.

•	 Shear Resistance: The Shear Resistance parameter 
controls the cloth’s resistance to in-plane shearing, or 
side-to-side bending. A low shearing resistance allows the 
cloth triangles (caused, for example, when the corner of 
a rectangular piece of cloth is draped over a surface) to 
collapse in on themselves, so a value of 50.0 or thereabouts is 
appropriate. Wool has a low shear resistance while leather has 
a very high amount.

•	 Stretch Resistance: The Stretch Resistance parameter 
specifies the cloth’s resistance to in-plane bending (stretching). 
Most cloth is highly resistant to stretching, with some 
exceptions like spandex, which is more elastic. The default of 
50.0 gives a fairly high resistance to stretching suitable for 
cotton-type materials. A lower value might be suitable for 
stretchy materials such as Lycra.

•	 Stretch Damping: The Stretch Damping parameter 
controls the internal energy loss caused by the motion of 
the cloth fibers against each other. Higher damping causes 
the cloth to lose its motion more quickly. Excessively high 

values can make the cloth look like it is moving in syrup, and 
extremely low values can cause the cloth to behave irregularly. 
A value of 0.01 is suitable for more uses.

•	 Cloth Density: The Cloth Density parameter specifies the 
mass-per-unit area density of the cloth in grams per square 
centimeter. If you take a 1cm x 1cm piece of cloth and weigh 
it, the weight in grams is what this parameter should be set 
to. For example, silk is very light while leather is very heavy by 
comparison.

•	 Cloth Self Friction: The Cloth Self Friction parameter 
sets the coefficient of friction between one part of the cloth 
and another, or how easily the cloth moves over itself. Higher 
values prevent the cloth from sliding over itself. For example, 
rayon has a very low amount of self-friction while denim has a 
fairly high amount.

•	 Static Friction: The Static Friction parameter sets the 
amount of friction between the cloth and solid objects. This is 
similar to the Dynamic Friction parameter except that this 
is the force required to get a stationary cloth in contact with a 
solid to start moving. For example, nylon over smooth plastic 
will have a very low amount of static friction while denim over 
wood will have a high amount.

•	 Dynamic Friction: The Dynamic Friction parameter sets 
the coefficient of friction between the cloth and solid objects 
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when the cloth is in motion. Moving a piece of cloth across 
a surface causes friction. Silk moving over a steel surface 
has low resistance, while cotton moving over skin or coarse 
sandpaper over rough wood has high resistance.

•	 Air Damping: The Air Damping parameter specifies 
the cloth’s air resistance that occurs whenever the cloth is 
moving through the air. Tightly woven cloth has a higher 
resistance than loosely woven fabric. Set this parameter with 
care as excessive values could cause the cloth to behave 
unpredictably.

•	 Collision Friction: Checking the Collision Friction 
checkbox ignores the cloth object’s Static Friction and 
Dynamic Friction parameters, instead using those same 
parameters belonging to the collision objects themselves. 
Clearing this checkbox applies the cloth dynamic settings.

•	 Reset: Clicking the Reset button resets all cloth dynamics 
controls.

The label at the top right of the Cloth Dynamics Controls area 
displays the currently selected cloth object. To change the object, 
use the pull-down menu in the Cloth area (Step 2).

Cloth Parameters & Properties
To access a cloth object’s parameters and properties, you must first 
select the desired cloth object.

Dynamic cloth objects have the same properties as props. •	
Please refer to Prop Properties on page 163 for information 
about prop properties.

Dynamic cloth has the same parameters as strand-based •	
hair objects. Please refer to Hair Parameters on page 383 for 
information about hair object parameters.

Creating Props and Morph 
Targets
You can convert cloth objects into static props or morph targets 
for use in scenes where a cloth-like look is desired without the 
need for a dynamic cloth object. For example, you could create a 
tablecloth using dynamic cloth and a table prop then convert the 
dynamic cloth object into a static prop for use in future scenes. 
If you did this, you would only need to include table legs where 
visible between the floor and the edge of the cloth, thereby giving 
you full realism while reducing your scene’s polygon count. 

As another example, you could drape a sheet over a figure to 
create a ghost. Then you could convert the draped sheet to a static 
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prop and use the Setup room to turn it into a poseable ghost.

To create a prop from your dynamic clothing object:

Clothify an object as described above.1.	

Use the 2.	 Animation controls to move to your desired frame 
(the cloth shape changes with each frame as the simulation 
plays).

Use the 3.	 Grouping tool to spawn a new prop. Please refer to 
The Group Editor on page 487 for information on using the 
Grouping tool and the Group Editor palette.

Creating a prop in this method preserves the shape of the original 
cloth object at the time you created the prop but removes all 
transformation (position, rotation, and scale). For example, if you 
stretch a square into a rectangle, the new prop will appear as a 
square deformed by the cloth simulation. In this case, reapplying 
the transformations applied to the original clothified object restores 
the original appearance to the static prop.

To create a morph target, follow steps 1 & 2 above, then spawn 
a morph target as you would for any other prop/body part as 
described in  Spawning Morph Targets on page 470﻿. You can then 
apply the morph target to a prop.

 Morph targets created in this manner work in exactly the 
same manner as other morph targets, meaning that all dynamic 
motion is lost.

You can also export clothified props just like you would any other 
scene object. Exported cloth objects become static mesh objects 
in your chosen export format. To do this, follow steps 1 & 2 above, 
then export the object as described in Exporting Files on page 55﻿.

Adding Dynamic Cloth to the 
Library Palette
Adding dynamic cloth to the Library palette is a special case that 
merits its own topic. To add dynamic cloth:

If not done yet, load your desired figure and be sure to disable 1.	
Inverse Kinematics (see Inverse Kinematics (IK) on page 124﻿). 
Next, open the Joint Editor palette (see The Joint Editor on 
page 500﻿) and click the Zero Figure button.

If not loaded yet, load or import your desired cloth object 2.	
and ensure it fits the figure without obvious intersections. If 
importing a static prop, convert it into dynamic cloth using the 
Cloth room as described in Chapter 25: The Cloth Room on 
page 386.

Select the cloth, then open its 3.	 Properties palette and click 
the Set Parent button (or select Object > Change Parent)

The 4.	 Choose Parent window appears. Select Hip, being sure 
not to check the Inherit bends of parent checkbox.
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Open the 5.	 Library palette to the Props category and select 
your desired subcategory as described above. Save the cloth 
object.

You will be prompted to save the object as a smart prop. Click 6.	
Yes.

If your cloth object is not tied to a figure (such as a 
tablecloth), simply save it as a prop.
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Chapter 26: Wardrobe Wizard
Wardrobe Wizard is a utility that enables Poser clothing models 
originally created for one Poser figure to be worn by another. A very 
large number of figures are supported, and support for many past 
and current Poser/Smith Micro figures are built into Poser.

 For a full complete list of figures that are supported by 
Wardrobe Wizard, see http://www.philc.net/store_WW_
Extra_Figs.php.

Before you use Wardrobe Wizard to convert clothing, you may want 
to consider spending a few minutes reading these instructions. 
Doing so may explain many questions that you might encounter if 
you dive in before understanding what each feature does.

Using the Wardrobe Wizard
Choose Scripts > PhilC > Wardrobe Wizard Menu then open 
the Python window to view the Wardrobe Wizard button menu 
shown below.

Figure 26.1

The commands in this palette are as follows:

•	 Convert: Brings up the Plug in Graphical User Interface 
(GUI), which is explained in Converting Clothing on page 405.

•	 Analyze Full Body Morphs: Before you can add 
compatible Full Body Morphs to the clothing you must first 
allow Wardrobe Wizard to analyze the figure. This only needs 
to be done once, (unless you subsequently change the morphs 

http://www.philc.net/forum/
http://www.philc.net/forum/
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in the figure). Requires the figure to be selected in the scene. 
This process is described in Analyzing Full Body Morphs on 
page 411

Smooth•	 : Allows smoothing operations to be undertaken on 
the clothing. 

Inflate/Deflate•	 : Allows the clothing to be inflated or 
deflated. 

 WW Smooth, WW Smooth More, and WW Inflate 
full body morphs are automatically included in each clothing 
conversion. If the Add Material Dials option is selected, 
further refinement is provided by being able to smooth and 
inflate by material. See Choosing Additional Converting 
Options on page 409 for more details. The Smooth and 
Inflate menu buttons allow you to perform these tasks on any 
figure, independently of the conversion process.

Utilities•	 : Access more utilities, as discussed in Wardrobe 
Wizard Utilities on page 413.

Zero Figure•	 : Zero Pose the figure. This is a convenience 
utility. Neither the figure nor the clothing needs to be within 
the scene when performing a conversion.

Load•	 : Load a character into the scene using a standard 
Windows or Mac file selection dialog rather than using the 

Poser library.

Help•	 : Brings up the Wardrobe Wizard help file.

Version•	 : Displays Wardrobe Wizard version, figure support 
and system information.

Back•	 : Reloads the default Python script buttons.

Converting Clothing
You do not need to have any clothing or figures in your Poser scene 
in order to convert clothing. Simply click the Convert button from 
the main Wardrobe Wizard palette (shown in Figure 26.1) to open 
the Wardrobe Wizard dialog shown in the following figure. 
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Figure 26.2

Choosing the Original Clothing
Using the Original Clothing section of the GUI select the clothing 
that you wish to convert. This may be either a single item or an 
number of items. They can be Poser clothing figures, props or OBJ 
files, either in their compressed or uncompressed format. 

Figure 26.3

 Note that clothing figure files should contain only one 
item of clothing. If you have a multi item CR2 file then load it 
into Poser and save each item back to the library. You can then 
batch convert the set. If you have made multiple selections 
please note that any conversion option selected will be applied 
to the whole batch. Therefore do not convert pant suits within 
a batch containing skirts since each requires different settings.

Please note that gloves are not supported by Wardrobe 
Wizard.
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Selecting the Target Library
Use the Save Result to This Library selector to choose the Target 
Folder into which you wish the converted clothing to be saved. For 
example if you wish the clothing to be saved to the Poser library 
you would select C:\Program Files\Smith Micro\Poser 8 (or 
wherever your Poser 8 installation is located.) 

If you want to save your converted clothing to a remote Poser 
library you would select the folder above that library’s Runtime 
folder. 

Clothing will be saved to a character specific folder. •	

The OBJ file will be saved to the •	 Runtime: Geometries: 
WardrobeWizard: Figure Name folder. In this way you 
can easily reorganize your library if required. 

 You can move the figure CR2 and PNG files without 
worrying about editing the path to the OBJ file. 

Selecting the Figures to Convert 
From and To
Use the Convert From scrollable list to select the figure that the 
original clothing was made for. All the figures that you have the 

support files for will be listed here.

Use the Convert To scrollable list to select the figure(s) that you 
wish the clothing to be converted to. All the figures that you have 
the support files for will be listed here. 

 The names of your available figures will be visible in the 
Convert to and Convert from lists. These are the “out of the 
box” versions of those figures. If you have these figures and 
receive a message that you do not have a supported figure, 
it may mean that the figure was customized by a third-party 
vendor. Sometimes when customizing a figure Poser or the user 
will alter the name of the OBJ file that the figure references. 
For example this can occur if the Poser Face room is used. The 
solution is to either use the out of the box figure or edit your 
custom figure to reference the original OBJ file.

 Click the Extra Figure Support button at the bottom 
of the Wardrobe Wizard window to obtain the most recent 
information on where to obtain add-ons that provide Wardrobe 
Wizard support for third-party Poser figures. 
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Figure 26.4

Choosing the Clothing Type
Select the type of clothing that best describes the clothing being 
converted.

Figure 26.5

Pants, Pant Suites, Shirts, Etc•	 :- Choose this category 
for Pants, Jackets, or any clothing above the hips. Most 
anything that does not fit any of the other categories listed 
below will fit this category.

Loose Skirts, Skirt Suites, Long Robes, Etc•	 :- 
Choose this category for any skirt that tends to fall away from 
the hips. This also includes robes. This is probably going to be 
your preferred skirt option, including short skirts. 

Tight Skirts•	 : Use this option for any skirt that tends to 
closely follow the line of the legs. You may want to use this 
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option if the legs of the figure you are converting to are 
significantly spread apart.

Short Hair•	 : Choose this option for hair that does not extend 
past the neck. 

For long hair use Pants, Pant Suites, Shirts, Etc. 

Shoes that DO fit at Zero Pose•	 : Use this option for any 
shoe, boot, thigh boot that fits the figure when both the figure 
and footwear are at their unconformed zero pose.

Shoes that DO NOT Fit at Zero Pose•	 : Choose this 
option for any shoe, boot, thigh boot that does not fit 
the figure when both the figure and footwear are at their 
unconformed zero pose. Please note that the more the shoe 
does not fit, the poorer the quality of the conversion will be. 
See Footwear on page 425 for more details.

Choosing Additional Converting 
Options
The Options section of the Wardrobe Wizard window contains 
several other options that you can check or uncheck for clothing 
conversion. These options are as follows:

Figure 26.6

High Resolution•	 : Choose from High (checked) or Normal 
(unchecked) resolution. Normal resolution will convert faster 
but at the expense of definition.

Flared•	 : Select this option for flared pants or flared sleeves.

Close Fit•	 : Only deselect this option if you are converting 
particularly baggy clothing.

Force Reanalysis•	 : When an item of clothing is first 
converted Wardrobe Wizard undertakes an analyses of it. The 
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resulting data file is stored for future use. This greatly speeds 
up the time of any future conversion. However if for example 
you converted as a “Loose Skirt” and wish to see if perhaps 
selecting “Tight Skirt” may be better you would need to select 
the “Force Reanalyses” check box to ensure that Wardrobe 
Wizard redid the analyses with the new settings.

Keep Existing Morphs•	 : Wardrobe Wizard has the ability 
to retain any Full Body Morphs contained in the existing 
clothing. By selecting this check box you will subsequently 
be presented with a pop up list of all the available existing 
morphs and be able to select the ones that you wish to keep.

Add Full Body Morphs•	 : Wardrobe Wizard has the ability 
to add Full Body Morphs to the clothing to match the Convert 
To figure. For this you will first have to have Wardrobe Wizard 
analyze the figure. Also accessed via this checkbox option 
are the large number of very powerful clothing adjustment 
morphs. Please see the details in the “Full Body Morph” 
section above.

Regroup•	 : Generally leave this option selected. Only turn 
it off if there is some reason to not have Wardrobe Wizard 
regroup the model. Possibly some custom process that you 
wish to undertake.

Regroup All•	 : Forces a more aggressive regrouping 
algorithm, particularly in the torso. Use if the standard regroup 

option does not give satisfactory results.

Fix Pokethrough•	 : Any cloth that intersects the figure will 
be repositioned so that it remains above the skins surface. Use 
with care. This tool is also included in the Wardrobe Wizard 
Python Script buttons which may be a better time to use it 
since the converted figure will have been saved to the library 
at that point. However you will probably find that adjusting 
the newly created WW_Looseness morph in the clothing’s 
BODY will give better results and be more controllable. 
FixPokeThru works with clothing intersecting the figure. It is 
not designed to work with clothing intersecting clothing.

As Prop•	 : Delivers the converted clothing as a Poser Prop 
rather than a conforming figure. You would use this if you 
wish to use the converted clothing as dynamic clothing in the 
Poser Cloth room.

Add Material Dials•	 : Provides the option to allow 
Wardrobe Wizard to create a set of full body morphs that 
result in smoothing or inflation by selected material. Very 
powerful, very useful, very easy to use. By way of a bonus if 
you select this option you get an extra “Shrink to fit dial”. 
If you haven’t read these instructions you will probable not 
realize that it is there.

Once you have made your selections click the Convert button. 
Depending on your selections you may get supplementary pop 
up windows asking you to select such things as which morphs to 
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keep etc. The progress will be displayed in the Poser Python output 
window. 

Finding Your Converted Clothing
Upon completion open Poser and navigate to the designated library. 
Your converted figures will be in folders bearing the suffix “WW” 
followed by the name of the figure that they were converted to. The 
name of the clothing will be the same as the name of the original 
item, as will the thumbnail if one was available for the original.

Analyzing Full Body Morphs
Wardrobe Wizard has the ability to automatically create full body 
morphs in the clothing to match those contained in the figure that 
you wish to convert to. In this way if you have a figure that has 
been customized using full body morphs you can use Wardrobe 
Wizard to build compatible morphs into the clothing. Before this 
can happen you will first need to have Wardrobe Wizard analyze 
that figure. If you have the Plug in GUI open as shown above click 
the “Cancel” button then proceed as below.

With the desired figure selected in the Poser scene, click the 1.	
Analyze Full Body Morphs button. 

Figure 26.7

A dialog opens, and prompts you to select the morphs that you 2.	
want to include in your clothing. 
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Figure 26.8

Scroll through the list and check the options that you ��
want to add into your clothing.

If you want to include all of the figure’s morphs in your ��
clothing, click the Select All button.

Click �� Select None to deselect all of the selections you 
have made.

Click��  Invert Selection to switch the selected morphs to 

unselected, and vice versa.

Click �� Cancel to exit the dialog without analyzing your 
selections.

Click 3.	 OK to apply your selections. Wardrobe Wizard displays 
another dialog with a summary of the morphs that you 
selected. 

Click 4.	 OK again to perform the conversion.  Wardrobe Wizard 
displays the progress as the morphs are being analyzed. When 
the process is complete, the dialog displays Done! at the end.

Figure 26.9

 You only need to do this once for each figure that you 
wish to have Full Body Morphs added for. The data is stored 
as a MOR file for future use. You would only need to reanalyze 
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the figure if you add/change the morphs in the figure. See 
additional tools below for dealing with characters with non-
standard body morphs etc.

Refining the Full Body Morphs in 
Your Clothing
In addition to the Full Body Morphs that you have transferred from 
your figure to the clothing, Wardrobe Wizard also includes a large 
number of very powerful yet simple to use clothing adjustment Full 
Body Morphs. You will find these dials in the BODY section of your 
converted clothing, and listed under the heading WW Adjustment 
Morphs. 

A number of other WW Adjustment morphs may be included when 
you make your selection from the pop up morph list during the 
conversion process. It is strongly suggested that you try them out. 
They provide a great deal of versatility in the converted clothing. To 
access these powerful morphs simply select the “Add Body Morphs” 
(plug-in:- “Add FBM’s”) and “Add Material Dials” checkboxes. 

The following morphs are built into the clothing automatically by 
Wardrobe Wizard:

Smooth•	 : This will provide a dial in the clothing’s BODY to 
enable small wrinkles to be ironed out.

Smooth More•	 : Similar to WW Smooth but applies to the 
edges of the clothing.

Inflate•	 : Easily adjust how tight/loose the clothing fits the 
figure. If you find a small area of the underlying figure poking 
through turn the WW Looseness dial a little. It is suggested 
that you initially try this rather than the “Pokethru” option.

Shift•	 : Translate the BODY or body parts. Use “Save Changes 
to Geometry” to make the adjustment permanent. 

Cleavage•	 : This adjust the area of the clothing in between 
and below the breasts. It was noticed that when clothing 
made for a well endowed figure was converted to a figure of 
more petite proportions there would be some clothing “left 
over” that tended to sag. (Much the same as in real life). The 
WW Cleavage dial allows you to easily take in the slack.

Under Breast Smooth•	 : Sometimes required to provide 
additional smoothing to loose fitting ladies shirts. 

Wardrobe Wizard Utilities
Clicking the Utilities button in the main Wardrobe Wizard script 
palette brings access to a number of utilities subdivided by function. 
These utilities are not key to converting clothing but are included as 
additional features that may prove useful. 
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The various utilities that are available appear in the menu shown 
below. These utilities are described in the sections that follow.

Figure 26.10

Figure Utilities

Figure 26.11

Figure Utilities Menu 1

Load Figure•	 : Opens a dialog that allows you to navigate 
to a character library folder on your hard drive, and select a 
character file. 
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Zero Figure•	 : Select a figure and then click this button to set 
all joint rotations to zero, and scales to 100%.

 We recommend that you turn IK off before using the Zero 
Figure option.

IK Off•	 : Select a figure and click this button to turn Inverse 
Kinematics off.

IK On•	 : Select a figure and click this button to turn Inverse 
Kinematics on.  IK is applied to hands and feet with this 
option.

Transparency Off•	 : Turns transparency off. Only works in 
older versions of Poser.

Transparency On•	 : Turns transparency on. Only works in 
older versions of Poser.

Weld Figure•	 : Click this button to create a welded copy of 
the selected figure. The copy appears in the Select Actor menu 
and is named new.

More...: •	 Click to display Figure Utilities Menu 2:

Back•	 : Goes back to the previous menu.

Figure Utilities Menu 2

Figure 26.12

Copy Scaling•	 : Copies scaling parameters into the clipboard.

Apply Scaling•	 :  Applies copied settings to the currently 
selected figure.

Save Scaling•	 : After you copy scaling settings to the 
clipboard, saves the scripts to your hard drive. The script is 
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found in your Poser installation folder as Poser 8 \Runtime 
\Python \poserScripts \PhilC \Wardrobe Wizard P8 \
Scale.py.

Remove Scaling•	 : Removes scaling settings from the figure 
that you click.

Remove Magnets•	 :  Removes magnets from the figure 
that you click.

Copy Joint Parameters•	 :  With two (or more) figures in 
the scene, allows you to copy joint parameters from one figure 
and apply them to another.

Back•	 : Goes back to the previous menu.

Morphs Utilities

Morph Utilities Menu 1

Clicking the Utilities > Morph buttons brings up these buttons. 

Figure 26.13

Create MOR from Figure•	 : This will analyze the current 
character settings and create a morph analysis files (MOR 
file.) This eases converting clothing from custom figures 
that are ‘dialed’ from existing morphs; turns it into a 1-click 
conversion.

Create MORs from Dials•	 : This will analyze all the dials 
of the current character and create multiple morph analysis 
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files (MOR files.) This is the same thing as the existing ‘Analyze 
full body morphs’ button, which creates a morph analysis 
for every clothing dial. It is intended to be used with figures 
such as V4, V41 and Apollo etc each of which contain some 
fancy string pulling in their figure CR2 files that result in non-
standard Full Body Morph dials that Wardrobe Wizard can not 
recognize.

Dials to Single Morph•	 : This will convert all current 
character settings to a single Full Body Morph dial on the 
character. This is a powerful feature that will take the existing 
dials and magnets on the figure, and turn it into a single Full 
Body Morph dial on the BODY of the figure. Let’s say you 
have a character that is based on V3 morphs, and requires 15 
morphs to be injected and set. This button will let you turn 
them all into a single ‘new’ morph, that doesn’t require the 
dials to be set, or even injected, any more.

Dials to Multiple Morphs•	 : This will convert all dials 
on the current character to multiple normal morphs on the 
character. This is similar to ‘Dials to Single Morph’ above, but 
creates multiple morphs, one per dial. The new morphs don’t 
require the old dials to be set, or even injected, any more.

Actor Morphs to Figure: •	 This will transfer selected actor 
morphs to the body. This is useful to bring up hair morphs or 
chest morphs etc to the BODY level, where Wardrobe Wizard 
can analyze them.

Figs to Morphs•	 : Provides a method of creating a full body 
morph from a morphed version of the figure. The steps are:

Load the base figure and use the zero figure button.��

Load the reshaped figure. (See �� Save Changes to 
Geometry below) 

With the base figure selected click the Figs to morphs ��
button. This will use the reshaped figure as a morph 
target and build a full body morph into the base figure.

Delete the reshaped figure.��

Save the base figure to the library.��

Save Changes to Geometry•	 : “Fixes” the figure’s 
geometry to whatever is currently displayed in the scene. 
When the figure is saved back to the library this new geometry 
is saved as a new OBJ file. It is very possible that the joint 
parameters will not work well. Its purpose is to:

Provide a figure to be used as a morph target in “Figs to ��
morphs” above.

Enable clothing that does not fit the figure at zero pose ��
to be made to fit and hence produce a good conversion. 
See the “anything else” shoe example below.

Zero All Morphs•	 : Sets all morph dial values to zero. 
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More...: •	 Displays Morph Utilities Menu 2, described next.

Back•	 : Goes back to the previous menu.

Morph Utilities Menu 2

Figure 26.14

Set All Morphs: •	 Sets all the morphs present in the figure 
to a value of 1.000 Intended as a quick way of setting all 
morphs recently created in a blank figure using magnets in 

preparation for using the Poser menu Figure/Create full body 
morph. Anything else and it just has novelty value.

Zero All Scaling: •	 Just what the button says.

Back•	 : Goes back to the previous menu.

Texture Utilities

Figure 26.15
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Set All to White•	 : Click this button to change all Diffuse 
Color settings to white. Links to texture maps remain 
connected to the root node.

Edit Texture•	 : Click this option to display a menu of texture 
maps that apply to the current figure. When you then select 
a texture map, the texture opens in the default program that 
your system uses for editing bitmaps (such as Photoshop or 
another image editor).

Apply Texture to All Mats•	 : Click this button to display 
a menu of texture maps that are applied to the current figure. 
When you then select one of the texture maps, it is applied to 
all materials in the current figure.

 This option is not undoable, and is not recommended for 
content that uses multiple texture maps (such as figures that 
use separate head, body, teeth, and eyelash texture maps).

Copy Texture to Prop•	 : Allows you to copy material 
settings from one prop to another. They must both have the 
same material names.

Transparency Off•	 : Sets transparency to 0%.

Transparency On•	 : Sets transparency to 100%.

Transparency Half•	 : Sets transparency to 50%.

Remove All Textures•	 : Removes textures from the item 
that you click.

Back•	 : Goes back to the previous menu.

Prop Utilities

Figure 26.16

Figure to Single Prop•	 : Converts the figure that you click 
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into a single prop.

Figure to Multiple Props•	 : Converts the figure that you 
click into multiple props, and saves them to the Poser 8 \
Runtime \Python \poserScripts \PhilC \Wardrobe Wizard p8 \
temp folder.

Import Multiple Props•	 : Allows you to import multiple 
props (for example, the individual props saved with the Figure 
to Multiple Props script mentioned above.

Back•	 : Goes back to the previous menu.

Lights Utilities

Figure 26.17

Intensity•	 : Provides several different options for increasing or 
decreasing the Red, Green, Blue, or all channels of a light.

Swap•	 : Flips the orientation of the lights so that right lights 
are moved to the left side, and left lights are moved to the 
right side of the scene.
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Shadows Off•	 : Turns shadows off on all lights.

Shadows On•	 : Turns shadows on on all lights.

Delete All•	 : Deletes all lights in the scene.

Back•	 : Goes back to the previous menu.

Shape Utilities
Clicking on the Utilities > Shape buttons brings up the Shape 
buttons. They allow you to change the shape of the geometry. Once 
you have the shape you like save the figure to the library to make 
the shape permanent. 

The tools are primarily used to fine tune the shape of skirts but may 
be used on other body parts also. 

  These utilities do not create a morph you actually change 
the geometry that gets saved to the OBJ file.

Now for those who really want to “get into it”, here is an 
explanation of how these buttons work and how they can be 
customized. The list of formulas is in the data folder under 
‘formulas.txt.’ Each line is a single formula consisting of the name, 
the direction to apply the adjustment in, the adjustment amount, 
and a set of numbers that control how the formula is applied. 

That set of numbers is most similar to a ‘convolution kernel.’ 

Examples:

0 0 •	 Don’t apply any adjustment.

1 1 •	 All verts top to bottom get the adjustment equally.

1 0 •	 Top half of the actor gets 100% of the adjustment, 
bottom half gets no adjustment.

1 0 0 •	 Top THIRD of the actor gets 100% of the adjustment, 
bottom half gets no adjustment.

0 0 1•	  Top two thirds gets no adjustment, bottom third gets all 
the adjustment.

The ‘number’ of numbers on the line control how many sections 
to divide the actor into. Two numbers divides the actor into 2 
parts top to bottom, 3 numbers divides it into 3 parts, 10 numbers 
divides it into 10 parts, etc.

The ‘value’ of the adjustment is the relative weight to give it.

Example:
pear xz .1 0 1 2 3 3 3 3 3 3 3 3 3 3 3 3

This says:

Move in the xz direction only, which doesn’t affect the length. •	
.1 is the amount to move.
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There are 15 numbers following, that means divide the skirt up •	
into 15 sections.

The highest number is a 3 - that means all entries with 3 •	
get 100% of the adjustment, entries of 2 gets 2/3 of the 
adjustment, entries of 1 gets 1/3 of the adjustment, entries of 
0 get none of the adjustment.

The first number is a zero - that means the top 1/15 gets no •	
adjustment.

The second number is a one - that means the next section gets •	
1/3 of the adjustment.

The second number is a two - that means the next section •	
down gets 2/3 of the adjustment.

The following numbers are all 3’s - that means the remainder •	
of the actor gets 100% of the adjustment.

There are three Shape Utility menus, with various shapes named as 
follows. We suggest experimenting with these shapes to learn how 
you can combine them to achieve the shapes you need:

Menu 1: Includes  Undo, Flare, FlareFront, Taper, TaperFront, •	
InflateThighX, InflateThighZ, and Inflate. Choose More to 
proceed to the second menu, and Back to return to the 
previous menu.

Menu 2: Includes Undo, InflateXZ, InflateX, InflateZ, Pear, Hilo, •	
Puff1, and Puff2. Choose More to proceed to the third menu, 
and Back to return to the first menu.

Menu 3:  Includes Undo, Puff3, Puff4, and Back (which returns •	
to Menu 2).

Shift Utilities
These buttons move the geometry in Poser’s memory as opposed to 
translating the model in 3D space. Redundant in Wardrobe Wizard 
but retained here “just in case”.
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Figure 26.21

Shift Right•	 : Shifts selected geometry to the right.

Shift Left•	 : Shifts selected geometry to the left.

Shift Up•	 : Shifts selected geometry upward.

Shift Down•	 : Shifts selected geometry downward.

Shift Forward•	 : Shifts selected geometry forward.

Shift Backward•	 : Shifts selected geometry backward.

Back•	 : Goes back to the previous menu.

Magnets Utilities

Figure 26.22

Hide All Magnets•	 : Hides all magnets in the scene.
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Show All Magnets•	 : Shows all magnets in the scene.

Delete All Magnets•	 : Deletes all magnets in the scene.

Hide Actor Magnets•	 : Hides all magnets on the currently 
selected actor.

Show Actor Magnets•	 : Shows all magnets on the 
currently selected actor.

Delete Actor Magnets•	 : Deletes all magnets on the 
currently selected actor.

Add Magnet•	 : Adds a magnet to the scene.

Back•	 : Goes back to the previous menu.

More Utilities

Figure 26.23

Fix Pokethrough•	 : If a section of clothing is intersecting 
the figure this button will move it to just above the surface 
of the skin. Use with care since some clothing models 
intentionally have polygons that intersect the skin. You may be 
better served by adjusting the “WW Inflate“ full body morph 
that automatically gets included in each clothing conversion. 
FixPokethru works with clothing intersecting the figure. It is 
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not designed to work with clothing intersecting clothing

Check For Updates•	 : Opens your browser to a web page 
that provides information on obtaining the most recent 
updates for Wardrobe Wizard.

Make Art•	 : Provides a tongue in cheek solution to the often 
asked question of how Poser may be used to create art.

Back•	 : Goes back to the previous menu.

Footwear

Shoes

Original footwear correctly aligns to and covers the original figure 
when both the figure and the footwear are at the zero pose. This is 
achieved without the need to conform the footwear to the figure.

The over riding factor is that the footwear fits the figure, not the 
style of the heel.

Figure 26.24

Hi Heels

The original footwear only fits the figure providing that some 
bending or morphing of the figure or footwear is undertaken. And/
or the feet must be set invisible.

The majority of Poser high heel styled shoes fall into this category.
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Figure 26.25

Other Types of Shoes

Models that have to be “shoe horned” into fitting the zero posed 
figure.

Note that some high heeled shoes are correctly modeled to fit the 
figure when at the zero pose. These then take up their high heel 
shape when the foot is bent. For these use the “Shoe” type of 
conversion. 

Try Shoe type first.

The above two methods are going to cover the majority of shoes 
but for those that fall through the cracks try this.

1.	 By hook or by crook get the shoe to fit the zero posed 
figure.

2.	 Use the Wardrobe Wizard Poser Python buttons Utilities 
> Morphs > Save Changes to Geometry.

3.	 Save the shoes back to the Poser figure library with a 
new name so as to not over write the originals.

4.	 Convert using the newly created Footwear using the 
“Shoe” type but if that does not work try the Hi Heel type. 

Figure 26.26

Common Questions (and 
Answers)
Q: Where can I get additional support for Wardrobe 
Wizard?

A: We suggest the following:
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For online information, video tutorials, etc. see •	 http://www.
philc.net/WardrobeWizard.php

To ask questions in the Wardrobe Wizard forum go to •	 http://
www.philc.net/forum/ (requires creating a free user account).

Q: Wardrobe Wizard starts to analyze the clothing but then 
says that it can not find the OBJ file.

A: Wardrobe Wizard can find paths in the CR2 file when the 
“figureResFile” is given in either of these two these formats:-

Relative Path
Runtime:Geometries:Folder:SubFolder:filename.obj
Runtime:libraries:character:Folder:SubFolder:filen

ame.obj

Absolute Path
C:\Documents and Settings:Administrator:My 

Documents:My Poser Files:Runtime:Geometries:Folder:Sub
Folder:filename.obj

Open the CR2 file in a text editor to find the figureResFile line. It is 
usually within the first ten lines of the file. 

Either will work but if the path is relative check to ensure that the 
CR2 file is within that same Runtime. If the path is absolute check 
that the file is actually where it is supposed to be. 

Q: The conversion went well, but there is one small 
section that needs some extra adjustment. Using the 
Wardrobe Wizard smoothing or inflation morphs affects 
too great an area.

A: Use the Poser Morphing Tool to fine tune as required. This is a 
very useful tool that will allow you to smooth, push or pull small 
areas as required. Suggest setting the Magnitude to a very low 
value to allow fine control. For information about the Morphing 
tool, see Creating Morphs with the Morphing Tool on page 458.

 

http://www.philc.net/forum/
http://www.philc.net/forum/
http://www.philc.net/forum/
http://www.philc.net/forum/


Poser 8
Reference Manual 

428

Chapter 27: The Setup Room

Chapter 27: The Setup Room
The Setup room is one of Poser’s most powerful features. It allows 
you to modify existing props or figures, or even create your own for 
use with Poser. 

The Setup room allows you to fully rig new figures by creating 
and setting up joints, hierarchy groups and IK chains. It allows 
you to create these elements in a graphical environment, rather 
than having to manually edit a configuration file in a text-based 
environment.

When the Setup room opens, it displays many of the controls that 
you will need to create poseable figures. Depending on the size 
of your workspace, you may see the Camera controls, Joint Editor, 
Editing tools, Parameters/Properties palette, or Hierarchy Editor in 
this room. Of particular importance is the Bone Tool, which allows 
you to graphically create a skeleton for your figures:

The number of palettes and options that you see in 
each room depends upon your screen resolution. At higher 
resolutions, the default work spaces display more palettes, 
while at lower resolutions you see fewer palettes:

Figure 27.1

The Setup room is an extremely powerful tool that can 
permanently modify your figures, including those originally 
included with Poser. Always save your figures to the Library 
palette to prevent inadvertently damaging one of your existing 
figures and to enable you to return to a previous figure setup 
if you choose to. This will also help you keep your figures 
organized and easy to find.

Avoid losing your work! Be sure to save your work 
frequently and possibly to different files in case you run into 
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problems.

Creating Figures for Poser
Figures do not have to be anthropomorphic (human-shaped). A 
figure’s mere appearance has no effect on how it functions within 
Poser. In reality, there are two things that determine how you can 
move and animate a figure:

The figure’s underlying •	 skeleton (called a bone structure), 
which determines the hierarchy and location of joints. 

The manner in which the figure’s polygons (the rough •	
equivalent of skin and muscles) are grouped or attached to 
the bones.

Prior to the release of the Pro Pack add-in for Poser 4, figure 
creators pre-grouped OBJ models into specifically-named body 
parts, and then used a text-based method to convert them into 
poseable figures. While Poser still supports this method of figure 
creation, the graphical Setup room can eliminate 90% of your 
figure creation time. This room allows you to create/modify Poser 
figures in a completely graphical environment.

There are three ways to make figures for Poser:

Using hierarchy files combined with an external model•	

 Figure creators wishing to create Poser figures using the 
text-based method should refer to the Poser Tutorial Manual, 
Chapter 26: Advanced Figure Creation on page 278, which 
covers the text-based figure creation method in detail. This 
document is in Adobe Acrobat (PDF) format and is included in 
the Documentation folder on your Poser CD.

Using the hierarchy palette (discussed in •	 The Hierarchy Editor 
on page 493) to combine props together to form a figure.

Importing a geometry and using the •	 Setup room as discussed 
in this chapter.

About the Setup Room
The actual process of creating a poseable figure involves a greater 
number of detailed steps, each of which is discussed in this chapter. 
Briefly, the Setup room figure creation/modification process is as 
follows:

Use props that are included with Poser, or create the geometry 1.	
for your new figure in your favorite 3D modeling application.

Import your geometry as a prop using the 2.	 File > Import 
command. Once the geometry is complete, enter the Setup 
room.
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Create and/or modify your figure’s bone structure or skeleton. 3.	
Like a real skeleton, your figure’s skeleton is the underlying 
framework that determines where bends occur. You can import 
a skeleton from a similar figure or create your figure’s skeleton 
from scratch.

Position the skeleton and joints to match your figure. This step 4.	
is critical to ensure that your figure bends as accurately as 
possible.

“Put meat on the bones” by grouping the various portions of 5.	
your figure and assigning bones to those groups.

Fine-tune the figure’s joints, and then exit the 6.	 Setup room 
to test your new figure and complete the figure creation/
modification process.

Assign IK chains using the 7.	 Hierarchy Editor, set favored IK 
angles and joint limits, and memorize this information.

Readjust your figure’s joints if necessary, and then save your 8.	
new figure to the Library palette.

Exiting the Setup room during the figure creation process 
may cause you to lose some recent changes. A warning will 
appear if exiting the Setup room will cause data loss.

The Setup Room Interface
The Setup room interface is designed to be similar to the Pose 
room interface and functionality, with a few minor changes:

You cannot pose the figure you are creating while in the •	
Setup room. Instead, the figure’s bone structure (if any) 
appears in the Document window, allowing you to position 
and adjust each bone.

While in the •	 Setup room, loading a figure from the Library 
palette loads the selected figure’s bone system and applies 
it to the current object. Geometry is altered when switching 
between the Pose and Setup rooms. While in the Pose 
room, each body part is treated as a separate geometry 
object. While in the Setup room, all of the body parts are 
combined into a single object for easier grouping and welding 
operations. Clicking the Create New Figure button in the 
Library palette loads the selected figure’s bone structure 
for modification and use on the figure you are creating or 
modifying. You can also double-click the figure to load its 
bones.

The following sections explain the figure setup process in detail.
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Step 1: Importing/Arranging 
Geometries
Begin the figure creation process by inserting the prop(s) you wish 
to assemble into a figure. Do this by adding props to your scene 
using the Library palette and/or by importing geometry objects 
(static mesh objects or props). If using more than one prop, be sure 
to arrange your props in their final positions before beginning the 
figure conversion process. 

 Please refer to Importing Files on page 50 for 
information on importing geometries into Poser. 

 In order to be rigged, you need to create your geometry 
properly and assign each body to a unique Material Group; 
otherwise the geometry won’t be treated as a separate body 
part. Group names for the Poser 8 figures are listed in Poser 8 
Figures Hierarchy on page 494.

Step 2: Loading and/or Creating 
Bone Structures
This section describes what bone structures are, what they do, and 
how to create/modify a bone structure for your imported geometry 
or figure.

About Bone Structures
Each Poser figure includes hierarchy and joint information that 
together determine how the figure behaves when posed. The 
Setup room expresses this information as a bone structure or 
skeleton that is tailored to each figure. Skeletons are a critical part 
of your figures because they define where and how the figure 
bends, just as your own bones define how and where you bend. 
Skeletons provide the following information for each figure:

Defining the figure’s hierarchy•	 : The skeleton defines 
the parent/child relationships in your figure. Please refer to the 
Poser Tutorial Manual, Hierarchy on page 14 for information 
about hierarchies within Poser.

Locating joints•	 : Just as with your own skeleton, your 
figure will only bend at joints, which are the places where 
bone ends meet.

Limiting figure movement•	 : By now, you are keenly 
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aware that each joint in your body has a limited range of 
motion under normal circumstances. For example, your 
elbow only bends in one direction and cannot flex beyond 
straightening your arm out, your wrist can move in any 
direction within a narrow cone, and so forth. You can define 
limits for each of your figure’s joints. These limits can prevent 
you from creating unnatural looking poses, one part of the 
figure crossing through another part, etc.

Figure resolution•	 : The more bones your figure’s skeleton 
has, the greater degree of flexibility (resolution) it will have. 
For example, the Andy figure allows you to bend the shoulder, 
elbow, and wrist, but not the palm or fingers. By contrast, 
the Poser 8 Male (Ryan) figure lets you adjust the precise 
position of each finger. 

This image shows •	 Andy’s left hand and underlying bone 
structure on the left, and Ryan’s left hand and bone structure 
on the right. Note that Andy has only one bone to define his 
entire hand, while Ryan has a far more realistic bone structure 
complete with palm and fully articulated finger joints.

Figure 27.2

Bones appear as light gray pyramids with the bases 
pointing towards their parents and the tips pointing towards 
the children. Selected bones appear red.

About Creating a Bone System
There are two basic scenarios for creating or editing a bone system:

Modifying an existing figure•	 : If you have a figure 
loaded when you enter the Setup room, the current figure’s 
normal bone system will automatically be loaded, and the 
separate body parts will be combined into a single object for 
easier manipulation while in the Setup room.
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 Creating a new figure•	 : You enter the Setup room 
with a geometry (prop) selected. You can then load a bone 
structure from an existing figure by selecting the desired 
figure in the Library palette and clicking the Change Figure 
button. Or, you can use the Bone tool to create a fully 
customized bone system. You can also combine these methods 
by loading a bone structure and using the Bone tool to make 
modifications. The Bone tool appears in the Setup room 
workspace with the other Editing tools.

The Bone Tool

The following sections discuss selecting a bone system for your 
geometry and using the Bone tool.

Selecting the Proper Structure
The quickest way to define a bone structure for your new figure is 
to load the bone structure of a figure that resembles your current 
object as closely as possible. For example, the simple geometry 
shown below does not require a high-resolution bone structure, 
since it does not have fingers or other detailed features. If you are 
creating an animal figure, you should probably load an animal 
figure’s bone structure. The basic idea is to minimize the amount of 
work you have to do.

Figure 27.3

 In the above graphic, the positions of the bones match 
the corresponding portions of the geometry. If the skeleton 
does not match the figure, you can position the bones as 
discussed in Positioning the Bones on page 434. 
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Inserting & Deleting Bones
The Bone tool lets you create bones, either within a bone structure 
or from scratch. To create a bone, click at the point where you want 
the bone to begin (base) and drag to where you want the end (tip). 
You can fine-tune the bone’s position and parameters later, so you 
do not need to worry too much about being perfect.

Figure 27.4

New bones are created as children of the most recently selected or 
created bone. You can select a previously created bone (or any bone 
in the skeleton) and add new child bones by single-clicking the 
bone you wish to use as a parent and then clicking and dragging to 
create a new bone as described above.. The graphic shows a new 

bone inserted between the hip (parent) and thigh (child). 

Bones can be selected as follows:

In the Hierarchy or by clicking on the bone with the Bone tool •	
selected

Via the Actor selector in either the Properties palette or the •	
Setup room Preview tab

To delete a bone, simply select it and press [DEL].

Positioning the Bones
Now that your bone structure is built to match your geometry, 
the next step is to align the bones with the geometry. Unless you 
have already built a bone structure for a figure and have simply 
tweaked the geometry slightly, the chances are that the default 
bone positions will not line up with the geometry, as shown in the 
graphic on the right. The figure on the left illustrates the effects 
of having a bone structure that is not positioned according to the 
geometry, while the figure on the right demonstrates proper figure 
behavior.
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Figure 27.5

You can position bones using any of three methods:

Select one of the available •	 Editing tools (Rotate, Twist, 
Translate/Pull, Translate In/Out, or Scale) and position the 
bones using the mouse.

Use the •	 Joint Editor palette to precisely position joints.

Use the •	 Symmetry control (see Symmetry on page 155﻿) to 
position the bones on the opposite side of the figure.

You will probably use a combination of all three methods as 
you work to position the bones on your geometry. The following 
sections discuss each of the three methods in detail.

With the Mouse

You can position bones with the mouse in one of two ways:

Selecting the desired •	 Editing tool followed by clicking in the 
middle of a bone uses the selected tool to modify the position 
of both the selected bone, all of its children, and all joint 
settings for both the current bone and all children (including 
falloff zones). Please refer to Falloff Zones on page 509 for 
an explanation of spherical and capsule falloff zones. This 
Selecting, clicking and dragging into position is the preferred 
method.

Clicking near the beginning or end of a selected bone allows •	
you to translate just the selected endpoint regardless of the 
selected Editing tool. The mouse pointer changes to a bull’s 
eye when you select a bone and place the pointer near the 
beginning or end of the selected bone, as shown.
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Figure 27.6

When editing bone endpoints, joint settings such as falloff 
zones are not adjusted. This method is good for making minor 
adjustments once the bones have been placed near their final 
positions. After you have properly aligned the skeleton to the 
geometry, you can adjust the falloff zones further. Please refer to 
Falloff Zones on page 509 for an explanation of spherical and 
capsule falloff zones.

When positioning bones using the mouse, you should 
use one of the orthographic cameras (Left, Right, Top, Bottom, 
Front, Back) to ensure that you are only positioning them in 
one plane at a time. Alternatively, you can use the Document 

window’s multiple pane view to position the bones in 3D 
space.

With the Joint Editor Palette

In addition to (or instead of) using the mouse to position •	
bones, you can use the Joint Editor palette by selecting 
the bone you wish to edit. Please refer to The Joint Editor on 
page 500 for complete information on using the Joint Editor 
palette.

Using Symmetry

Assuming your imported geometry is symmetrical, you can 
drastically reduce the amount of time it takes for you to position 
bones by positioning only those bones on half of the geometry and 
then using the Symmetry tool to automatically position the rest of 
the bones. Please refer to Symmetry on page 155 for information 
on using the Symmetry tool.

The Symmetry functions involving arms, legs, and the 
torso only work when the bones in those regions have been 
named and grouped so as to belong to the selected areas of 
the geometry. If you have loaded an existing bone structure 
for use with your current geometry, the bones will already be 
named for you.
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When you select a symmetry function, a dialog box appears asking 
if you wish to copy the joint zone setup as well. Click Yes to apply 
the symmetry to the bone structure.

Step 3: Naming the Bones
The Properties palette allows you to modify the following 
settings:

Internal Name•	 : You can modify a bone’s internal name 
while in the Setup room by entering your desired name in 
the Internal Name field. Poser uses internal names to find a 
group of polygons with a matching name. It is best to begin 
with an existing bone structure when creating figures so that 
you can start the process with a set of bones that already 
have standard internal names. You can, of course, create 
figures using custom internal and group names; however, this 
makes the process more difficult since you need to track the 
internal names and the portions of the skeleton and geometry 
they correspond to. 

 This is a critical point. The only way to link a bone to 
a group of polygons is to have them share the same exact 
internal name. The only place to modify internal names within 
Poser is in the Setup room, and then, only in the Properties 
palette.

 If you want your figure to support many of Poser’s 
features, you should respect the bone/body part internal 
naming conventions precisely. Group names for the Poser 8 
figures are listed in Poser 8 Figures Hierarchy on page 494.

Name•	 : The Name field is where you input your desired 
external name, which you use for your own reference. You can 
use any name you wish. This can be helpful if, for example, you 
are working in different languages.

Any other displayed options do not affect bones and 
should be ignored.

Step 4: Attaching Bones to 
Geometry Parts
This is the part of the Setup room figure creation process where 
you associate (group) bones with portions of the geometry, giving 
your geometry the ability to bend and move. It is important that 
you take great care during this step to ensure that your new figure 
will be able to bend and, just as importantly, bend correctly.

Your geometry consists of many polygons that together form its 
overall shape. At this point, Poser knows the skeleton, including its 
joints, parents, and children. It knows that moving one bone will 
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affect its children and may affect the parent, and it knows how 
each joint should behave. However, Poser does not yet know which 
polygons need to move for any given movement of the skeleton. To 
enable your geometry to bend, you must combine logical subsets of 
the polygons that make up your geometry and group each subset 
with the appropriate bone.

Where you need to be careful is in being sure that the correct 
polygons are assigned to the correct bones, that is, the right arm 
should move when you move the right shoulder bone, and so forth. 
It is possible to assign any polygon to any bone. You could have 
polygons in the leg region grouped with a bone in the neck, for 
example. You could even have random polygons scattered around 
the geometry grouped with any bone in the skeleton. While you 
may wish to do this for experimental or artistic purposes, this 
manual will assume that you are trying to create a realistic figure 
from the geometry and skeleton.

Now that the skeleton is complete, it is appropriate to think of each 
bone as a body part. For each such body part, an identically named 
group of polygons on the geometry must exist. Each of the joints 
will cause the grouped polygons to bend where parent and child 
groups touch. Poser knows which polygons to bend by matching 
the internal name of the bone being moved with the internal name 
of a group of polygons.

If you are adjusting an existing figure in the Setup room, 
the necessary body groups will already exist and may already 
be properly set up.

To create groups, select the Grouping tool, which opens the 
Group Editor palette. The Grouping tool can select polygons to 
create a group. Then you can use the Assign Material button to 
assign a name for the body part for the selected polygons.

Requirements
As discussed in Importing 3D Objects on page 52﻿, your imported 
geometry cannot have overlapping or duplicated polygons and, if 
you have created groups when you built the geometry, the polygons 
in the geometry cannot belong to more than one group at a time.

The Setup room allows you to create figures from a single 
geometry consisting of ungrouped polygons. This is the 
recommended method.

Grouping
There are a number of different ways that you can assign groups 
to your figures. For example, some assign groups in their modeling 
application or with other utilities. You can, however, use Poser’s 
Group Editor to create and assign groups to the polygons in your 
model. The Group Editor allows you to select polygons manually 
and then assign them to groups. If your figure does not already 
have groups assigned, you can also use the Auto Group feature 
to automatically generate groups based on the bone structure of 
the skeleton. For further information, refer to The Group Editor on 
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page 487 for information about using the Grouping tool and the 
Group Editor palette.

Step 5: Assigning Rotation 
Orders
With your bones positioned and your groups created, you’re 
almost finished. Your once-static geometry has come alive! You can 
perform this step when you are first creating and defining joints; 
however, it appears here in the figure creation process so that you 
can leave the Setup room to see how changes to the rotation 
order affect your figure’s motion and appearance. Please refer 
to Rotation Orders on page 515 for information on setting joint 
rotation orders.

Step 6: Fine-Tuning Joints
At this point, you may want to go back and fine-tune some or all 
of your joints so as to make your figure behave exactly as you want 
it to. Do this using the Bone tool and/or Joint Editor palette as 
discussed in The Joint Editor on page 500.

Remember that joint bending only occurs between an object and 
its parent. The bends do not progress to other children or above 
the parent in the hierarchy. Be sure to keep this in mind as you 
tweak the joints. Also, if you have body parts which are symmetrical 

left to right, and are named using the convention of starting with 
“r” for right-side body parts and “l” for left-side body parts, you 
can automatically copy joint zones by using one of the symmetry 
commands as discussed in Symmetry on page 155﻿. This can save 
time and effort when tweaking joints, and ensures that one side of 
your figure will behave exactly like the other part.

Step 7: Testing Your Figure
This is the moment you have been working towards. At this 
point, return to the Pose room and put your new figure through 
its paces. You can use multiple view panes and the Camera 
controls to see your figure from all angles to ensure that it is 
performing as expected. If you need to make any adjustments, 
you can always return to the Setup room to further refine your 
figure. Congratulations: Your once-static geometry prop is now a 
moveable Poser figure!

Step 8: Assigning IK Chains
In order for you to be able to use IK on your new figure, you need 
to create at least one inverse kinematics chain using the Hierarchy 
Editor, as discussed in The Hierarchy Editor on page 493.

You created the parent/child hierarchies in your figure 
when you created and edited the bone structure. The Hierarchy 
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Editor will perform all of its functions on your new figure.

Step 9: Inverse Kinematics
If you wish to add IK capabilities to your figure, you need to add IK 
chains as discussed in Creating IK Chains on page 499﻿.

Step 10: Setting & Memorizing 
Favored IK Angles
Poser’s inverse kinematics works based on the current rotations of 
a body part. Proper IK angles must be preset in the figure in order 
for IK to work predictably. The original joint rotation values help the 
IK logic know which way to bend some of the joints and will affect 
how the IK works as the figure moves. Setting and memorizing 
favored IK angles is therefore important. 

Before memorizing the default positions for all of the body parts, 
you should bend the parts used in IK chains so that they favor their 
natural bending directions. For example, a standing person’s thighs 
bend slightly forward and out from vertical, and her or his shins 
bend slightly back and in.

These positions can be tested by lowering the hip joint in the Y (up/
down) direction while IK is turned on for the legs. While doing this, 

the knees should bend smoothly, and not buckle or swing widely to 
either side. 

Then, to test the arms, enable IK on the arms and move the chest 
side to side (X trans). The arms and shoulders should bend naturally. 
If they do not, add small amounts of rotation into the joint to 
correct the unnatural bending. 

With IK off, return the hip to zero and the chest to zero. Preserve 
the rotations on the limbs. Make sure that they are symmetric from 
one side to the other. Then memorize figure to store the rotations.

To set favored IK angles:

Disable the affected IK chain(s).1.	

Position each body part in the chain by slightly bending it in 2.	
the direction it would bend under IK by a few degrees.

Save the angles by memorizing the body parts or the entire 3.	
figure by selecting Edit > Memorize>Element or Edit > 
Memorize>Figure, respectively.

Enable the affected IK chain(s).4.	

Please refer to Inverse Kinematics (IK) on page 124 for more 
information about Poser’s Inverse Kinematics features.
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Step 11: Setting Joint Limits
In the “real world”, each of your body’s joints has limits on its 
motion. For example, you cannot extend your arm at the elbow 
beyond the point where your arm is straight. Further, it is not 
possible for one of your body parts to “collide” or intrude on 
another part. You cannot simply put your hand through your chest. 

Poser allows you to set limits for each joint to mimic these natural 
limits and help prevent you from creating unnatural poses. 
Additionally, you can create limits on the amount that a body 
part can be scaled and tapered, and you may have other options 
available depending on the body part in question. 

 It’s good practice to set limits per parameter for your 
figures. The user can then choose to use or ignore your limits 
using the Figure pull-down menu by toggling the Use Limits 
command on or off. 

To set limits for a body part, simply select the desired body part, 
then double-click any of the parameter dials in the Parameters 
palette to open an Edit Parameter dialog box, where you can set 
limits for the selected parameter. Please refer to Editing Parameter 
Dials on page 141 for information on setting parameter limits.

Step 12: Finalizing Your New 
Figure
At this point, you have created and fine-tuned a new Poser 
figure. From a technical standpoint, the figure creation process is 
complete. If you wish, you can add materials and textures, make 
additional adjustments, and do anything you need to do in order to 
consider the project complete.

 You can also add morphs or use deformers that smooth 
areas like knee and elbow bends and link these morphs or 
deformers to the arm/leg bends as dependent parameters. For 
more information, see Using Dependent Parameters on 
page 471.

Step 13: Memorizing and 
Saving Your New Figure
You have hopefully been saving your figure throughout the creation 
process. Now that it is complete, be sure to memorize the figure 
by selecting Edit > Memorize>Figure. Also, be sure to save 
your figure in the Library palette. You can save your figure in an 
existing subcategory or create your own.
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Deleting Interim Figures
If you have saved draft figures as recommended during the figure 
creation process, you may want to delete these draft figures to 
avoid wasting hard drive space. To delete an item, select it in the 
Library palette and click the Delete from Library icon (-) at the 
bottom of the palette.

Troubleshooting
When creating a new figure from an existing figure, there may be 
existing parameters that no longer function properly with the new 
geometry. For instance, morph targets that used to work on the old 
figure may do nothing if you change the geometry. You can delete 
these channels in the Hierarchy Editor by checking the Show 
Parameters box, selecting the parameters to delete, and pressing 
[DEL].
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Chapter 28: Modifying 
Figures & Props
This chapter explains how to create completely custom looks for 
your figures and props. For example, human bodies come in all 
shapes and sizes. You can modify proportions using various tools to 
achieve interesting effects.

Figure 28.1

Poser includes a wide variety of tools for figure/prop shaping. Here 
are some tips, tricks, and important things to keep in mind when 
editing figures and/or props:

All Poser figures come with morph targets and full body •	

morphs, allowing you to reshape one or more body parts. You 
can find more information about creating morphs in Creating 
Morphs with the Morphing Tool on page 458 and Creating 
Morphs in Other Applications on page 468.

You can use the •	 Grouping tool (see The Group Editor on 
page 487 to create cloth, hair, or other groups. You can also 
deform polygon groups as mentioned in Using Deformers with 
Grouped Objects on page 458. The Grouping tool is located 
in the Editing tools display.

The •	 Scale and Taper tools (see Scale on page 131 and Taper 
on page 132﻿, respectively) can change a body or element’s 
shape. The Scale and Taper tools are located in the Editing 
tools display.

Deformers (magnets, force fields, and waves) can also alter •	
shapes.

You can replace body parts with props (see •	 Replacing a Body 
Part with a Prop on page 165).

You can save your work to the •	 Library palette.

You can modify entire figures or individual body parts. For •	
example, enlarging the abdomen can create a beer belly. 
Widening the head broadens the face. Shaping figures is 
easiest when the figure is in its default pose where you can 
clearly see the results of each of your actions.
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You may want to hide the other figures and props in your •	
scene for an uncluttered view.

As you finish shaping and posing each body part, you can lock •	
it as described in Lock Actor on page 151. And, once you’ve 
posed your figure, you can guard against accidental changes 
by locking the entire figure as described in Lock Figure on 
page 154﻿.

Symmetry can be a huge time saver, allowing you to pose •	
half your figure and apply the pose to the other side. Please 
refer to Symmetry on page 155 for information about using 
Symmetry. Also, try using cutting and pasting to apply poses 
across multiple figures.

If your computer can support it, we recommend enabling •	 Full 
Tracking mode (see Tracking Mode on page 70﻿) so you can 
view your work in real time. This does require extra computing 
resources, which can affect performance depending on your 
computer’s specifications and the complexity of your scene.

Using Deformers
Poser’s deformers (magnets, force fields, waves, morphs) shape 
body parts, props, and figures into new and interesting forms. You 
can stretch a nose, make a belly bounce with a walk, make hair 
and clothing blow in the wind, and create almost any body shape 

you can imagine. You can animate deformer settings and positions, 
allowing you to create (for example) gusting winds (force field), 
bulging muscles (morph targets), etc. The Wave, Force Field, and 
Magnet deformers can also create custom morph targets.

 Deformers can be linked to joint rotations or other 
parameters using the Dependent Parameters Editor. Refer 
to Using Dependent Parameters on page 471 for more 
information..

Magnets
Magnets distort objects by stretching them. You can use the 
Rotate, Twist, Translate, and Scale tools on magnets. Please 
see The Editing Tools on page 129 for information on using the 
Editing tools. Here’s an example of a sphere deformed by a 
magnet:

Figure 28.2



Poser 8
Reference Manual

445

Chapter 28: Modifying Figures & Props

Creating Magnet Deformers

To create a magnet, select the object you wish to deform then 
select Object > Create Magnet. This creates three Magnet 
objects, which together comprise the deformer.

Figure 28.3

The three parts are:

Magnet Object•	 : The Magnet Object defines the behavior 
of the actual magnet.

Magnet Base•	 : The Magnet Base defines the zero point of 
the area to be deformed. Moving the Magnet Base moves the 
Magnet Object as well.

Magnet Zone•	 : The Magnet Zone defines the area being 

deformed. You can move and shape the Magnet Zone to suit 
your needs.

Magnets work by deforming the area within the Magnet Zone 
along the axis defined by the Magnet Base and Magnet Object in 
an amount dependent on the distance between the Magnet Object 
and the Magnet Base.

Using Editing Tools with Magnet Objects

To use Editing tools on a Magnet Object, select the magnet in the 
Current Actor pull-down menu, then select your desired Editing 
tool:

Rotate•	 : The Rotate tool rotates the Magnet Object around 
its three axes.

Twist•	 : The Twist tool rotates the Magnet Object along its 
own axis.

Translate/Pull•	 : The Translate/Pull tool moves the Magnet 
Object horizontally or vertically.

Translate In/Out•	 : The Translate In/Out tool moves 
the Magnet Object in or out from the center of the Poser 
workspace.

Scale•	 : The Scale tool increases or decreases the size of the 
Magnet Object.
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Magnet Deformer Properties

Magnet Objects, Magnet Bases, and Magnet Zones have properties 
that you can edit using the Properties palette.

Magnet Object Properties 

Magnet Objects have the following properties:

Figure 28.4

Name•	 : The Name property allows you to rename the 
Magnet Object by entering your desired name in this field.

Visible•	 : The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See Figure 
Properties on page 135 for information on animating the 
Visible property.

Add element to deform•	 : Checking the Add element 

to deform button opens a hierarchy list, allowing you to 
select added elements to be deformed by the Magnet. This 
only works if the selected element(s) are within the Magnet 
Zone.

Magnet Object Parameters

Magnet Objects have the following parameter dials in the 
Parameters palette:

Figure 28.5

Scale•	 : The Scale parameter dial increases or decreases the 
size of the Magnet Object in all axes.
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XYZScale•	 : The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the Magnet Object in the 
selected axis.

XYZRotate•	 : The xRotate, yRotate, and zRotate 
parameter dials rotate the Magnet Object around the 
selected axis.

XYZTran•	 : The xTran, yTran, and zTran parameter dials 
move the Magnet Object along the selected axis.

Magnet Base Properties

Magnet Bases have the following properties:

Figure 28.6

Name•	 : The Name property allows you to rename the Magnet 
Base by entering your desired name in this field.

Visible•	 : The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See Figure Properties 
on page 135 for information on animating the Visible 
property.

Display Origin•	 : The Display Origin checkbox displays 
the Magnet Base’s axes. This is useful because translations, 
rotations, etc. occur based on the Magnet Base’s axes, not the 
Poser workspace’s. See the Poser Tutorial Manual, Global vs. 
Local Coordinates on page 7 for a discussion about local vs. 
global coordinates.

Casts Shadows•	 : Checking the Casts Shadows checkbox 
forces the selected body part to cast a shadow, which will be 
visible in your scene. Clearing this box means the selected 
body part casts no shadow.

Set Parent•	 : Clicking the Set Parent button allows you to 
make the Magnet Base a child of another element in your 
scene. Please refer to the Poser Tutorial Manual, Hierarchy on 
page 14 for a description of hierarchical relationships and to 
Changing a Parent on page 167 for information on setting 
parents.

Load Morph Target•	 : Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing 
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you to load a custom morph target for the selected force 
field (which is then editable using the Morphing Tool as 
described in Creating Morphs with the Morphing Tool on 
page 458﻿). Please refer to Chapter 28: Modifying Figures & 
Props on page 443 for more information about loading morph 
targets.

Magnet Zone Properties

Magnet Zones have the following properties:

Setting the Magnet Zone’s display style to Wireframe can 
help make it more visible in your Document window.

Figure 28.7

Name•	 : The Name property allows you to rename the 
Magnet Zone by entering your desired name in this field.

Visible•	 : The Visibility checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa.

Group•	 : Checking the Group checkbox enables grouping, 
allowing you to deform a grouped portion of the selected 
element(s). You can create groups to deform, and groups 
can consist of portions of one or more body parts, props, etc. 
Please see The Group Editor on page 487 for information 
on using the Grouping tool. A group is selected when a 
checkbox appears next to the group listing.

Set Parent•	 : Clicking the Set Parent button allows you to 
make the Magnet Zone a child of another element in your 
scene. Please refer to the Poser Tutorial Manual, Hierarchy on 
page 14  for a description of hierarchical relationships and to 
Changing a Parent on page 167 for information on setting 
parents.

Edit Falloff Graph•	 : Clicking the Edit Falloff Graph 
button allows you to edit the Magnet Zone’s Falloff graph, 
which determines where the deforming area ends or falls 
off. Please see Magnet Zone Falloff Graph on page 448 for 
information on using this graph.

Magnet Zone Falloff Graph

Selecting Edit Falloff Graph in the Magnet Zone Properties 
palette opens the Magnet Zone Falloff window:
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The left side of this graph depicts the center of the Magnet Zone, 
and the right side is its edge. By default, a smooth curve appears, 
meaning that the magnet’s influence gradually tapers off towards 
the edges of its zone. By adjusting this curve, you can alter the 
falloff properties:

Figure 28.8

To move control points click and drag them up and down. Raising a 
control point increases the magnet zone’s influence at the location. 
To add control points, click any spot along the curve. You cannot 
remove added control points.

Figure 28.9

Locking Magnets

You can lock magnets to prevent accidental changes. Please refer to 
Lock Actor on page 151.

Wind Force Fields
Selecting Object > Create Wind Force creates a wind force field 
that ads realistic wind to your scenes. Force fields affect strand-
based hair and dynamic cloth.
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Figure 28.10

You can position force fields using the Editing tools just as you 
would any other prop.

Force Field Properties

Force fields have the following properties, available in the 
Properties palette:

Figure 28.11

Internal Name•	 : The Internal Name field displays the 
force field’s internal (hidden) name, which Poser uses to track 
that part. You cannot edit a force field’s internal name within 
Poser.

Name•	 : The Name field displays the force field name. Enter a 
new name in this field if you desire.

Visible•	 : Checking the Visible checkbox makes the force 
field visible and vice versa. Invisible objects are not included 
in any render calculations, and do not appear in the rendered 
scene. See Figure Properties on page 135 for information on 
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animating the Visible property.

Visible in Raytracing•	 : Checking the Visible in 
Raytracing checkbox makes the force field visible in raytraced 
reflections, such as if the figure is in front of a mirror. Clearing 
this checkbox makes the force field not appear in reflections.

Casts Shadows•	 : Checking the Casts Shadows checkbox 
forces the selected force field to cast a shadow, which will 
be visible in your scene. Clearing this box means the selected 
force field casts no shadow.

Display Origin•	 : Checking the Display Origin checkbox 
display’s the force field’s origin. Please refer to The Prop Origin 
on page 163 for more information about force field origins.

Collision detection•	 : Checking the Collision Detection 
checkbox enables collision detection for the currently selected 
force field. Please refer to Collisions on page 63﻿ for more 
information about collision detection.

Apply Collision Setting to Children•	 : Clicking the 
Apply Collision Setting to Children button applies the 
currently selected force field’s collision detection setting to that 
part’s children parts (if any).

Load Morph Target•	 : Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing 
you to load a custom morph target for the selected force field, 

which is then editable using the Morphing Tool. Please refer 
to Creating Morphs with the Morphing Tool on page 458 for 
more information about loading morph targets.

Set Parent•	 : Clicking the Set Parent button allows you 
to make the force field a child of another element in your 
scene. Please refer to the Poser Tutorial Manual, Hierarchy on 
page 14 for a description of hierarchical relationships and to 
Changing a Parent on page 167 for information on setting 
force field parents.

Displacement Bounds•	 : The Displacement Bounds 
property determines the force field’s displacement boundary. 
Please refer to Chapter 18: Using The FireFly Render Engine 
on page 285 for more information about displacement bounds.

Shading Rate•	 : The Shading Rate allows you to specify 
the desired shading rate for the currently selected force field. 
Please refer to Chapter 18: Using The FireFly Render Engine on 
page 285 for more information about shading rates.

Smooth Polygons•	 : to be added.

Crease Angle•	 : to be added.

Force Field Parameters

Force fields have the following parameters, available in the 
Parameters palette:
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Figure 28.12

Scale•	 : Increases or decreases the size of the force field in all 
axes.

XYZScale•	 : The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the force field in the selected 
axis. This is only available for the force field.

XYZRotate•	 : The xRotate, yRotate, and zRotate 

parameter dials rotate the force field around the selected axis.

XYZTran•	 : The xTran, yTran, and zTran parameter dials 
move the force field along the selected axis.

Amplitude•	 : The Amplitude parameter controls the 
strength of the force field. Increasing this value increases the 
wind speed, and vice versa.

Spread Angle•	 : The Spread Angle parameter specifies the 
force field’s angle of effecting degrees.

Range•	 : The Range parameter specifies the force field’s 
range of effect in the currently selected units (feet, millimeters, 
etc.).

Turbulence•	 : The Turbulence parameter controls the 
amount of irregularity in the force field’s wind stream and can 
be used to simulate gusts.

Wave Deformers
Wave deformers distort objects by creating wave paths. You 
can use the Rotate, Twist, Translate, and Scale tools on 
wave deformers. Please see The Editing Tools on page 129﻿ for 
information on using the Editing tools. Here’s an example of a 
sphere deformed by a wave:
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Figure 28.13

Creating Wave Deformers

To create a wave, select the object you wish to deform then select 
Object > Create Wave. This creates two Wave objects, which 
together comprise the deformer. The two parts are:

Figure 28.14

Wave Object•	 : The Wave Object defines the behavior of the 
actual wave.

Wave Zone•	 : The Wave Zone defines the area being 
deformed. You can move and shape the Wave Zone to suit 
your needs.

Using Editing Tools with Wave Deformers

To use Editing tools on a Wave Object, select the wave in the 
Current Actor pull-down menu, then select your desired Editing 
tool:

Rotate•	 : The Rotate tool rotates the Wave Object/Zone 
around its three axes.

Twist•	 : The Twist tool rotates the Wave Object/Zone along its 
own axis.

Translate/Pull•	 : The Translate/Pull tool moves the Wave 
Object/Zone horizontally or vertically. This does not affect the 
Radial wave.

Translate In/Out•	 : The Translate In/Out tool moves the 
Wave Object/Zone in or out from the center of the Poser 
workspace.

Scale•	 : The Scale tool increases or decreases the size of the 
Wave Object.
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Wave Object Properties 

Wave Objects and Zones have properties that you can edit using 
the Properties palette.

Wave Objects have the following properties:

Figure 28.15

Name•	 : The Name field allows you to rename the Wave 
Object by entering your desired name in this field.

Visible•	 : The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See Figure 
Properties on page 135 for information on animating the 
Visible property.

Radial Wave•	 : Checking the Radial Wave radio button 
causes the wave to spread from its origin like ripples in a 

pond.

Directional Wave•	 : Checking the Directional Wave radio 
button causes the wave to spread in a linear fashion. The 
following two properties control the direction.

Deformer Aligned•	 : Checking the Deformer Aligned 
radio button cause waves to propagate along the direction of 
the Wave Object.

Object Normals•	 : Checking the Object Normals radio 
button cause waves to propagate along the affected object’s 
normals.

Add element to deform•	 : Clicking the Add element to 
deform button opens a hierarchy list, allowing you to select 
added elements to be deformed by the wave. This only works 
if the selected element(s) are within the Wave Zone.

Wave Zone Properties

Wave Zones have the following properties:
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Figure 28.16

Name•	 : The Name field allows you to rename the Wave Zone 
by entering your desired name in this field.

Visible•	 : The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See Figure Properties 
on page 135  for information on animating the Visible 
property.

Group•	 : Clicking the Group button allows you to deform a 
grouped portion of the selected element(s). You can create 
groups to deform, and groups can consist of portions of one 
or more body parts, props, etc. Please see The Group Editor 
on page 487 for information on using the Grouping tool. A 
group is selected when a checkbox appears next to the group 
listing.

Edit Falloff Graph•	 : Clicking the Edit Falloff Graph 
button allows you to edit the Wave Zone’s Falloff Graph, 
which determines where the deforming area ends or falls off. 
Please see the following topic for information on using this 
graph.

Set Parent•	 : Checking the Set Parent button allows 
you to set a parent object for the Wave Zone. Please refer 
to Changing a Parent on page 167 for information about 
parenting objects.

Setting the Wave Zone’s Display Style to Wireframe can 
help make it more visible in your Document Window.

Wave Zone Falloff Graph

Clicking the Edit Falloff Graph button in the Wave Zone 
Properties opens the Wave Zone Falloff window, which appears 
and functions in the same manner as the Magnet Falloff Graph 
depicted in Magnet Zone Falloff Graph on page 448﻿.
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Figure 28.17

Wave Deformer Parameters

Wave deformers can use the following parameter dials in the 
Parameters palette:

Figure 28.18

First, there are certain parameter dials that are only available for 
waves:
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Phase•	 : The Phase parameter dial defines the position of 
the wave in infinite time. Use this parameter when animating 
waves.

Amplitude•	 : The Amplitude parameter dial defines the 
wave’s height.

Wavelength•	 : The Wavelength parameter dial defines the 
distance between wave crests (frequency).

Stretch•	 : The Stretch parameter dial controls the sharpness 
of each wave.

Amp Noise•	 : The Amp Noise parameter dial defines the 
randomness or noise of the wave’s amplitude.

Freq Noise•	 : The Freq Noise parameter dial defines the 
randomness or noise of the wave pattern’s frequency.

Sinusoidal•	 : The Sinusoidal parameter dial defines the size 
of the sine wave pattern.

Square•	 : The Square parameter dial defines the shape of 
the wave pattern. Increasing this value creates square-shaped 
waves.

Triangular•	 : The Triangular parameter dial defines the 
shape of the wave pattern. Increasing this value creates 
triangle-shaped waves.

Turbulence•	 : The Turbulence parameter dial defines the 
roughness of a wave pattern. Increasing this value creates 
jagged, turbulent waves, and vice versa.

Offset•	 : The Offset parameter dial defines if the wave’s 
pattern is above, on, or below the wave’s origin. Increasing this 
value brings the wave pattern above the origin. This is helpful 
if, for example, you want to keep clothing from deforming the 
underlying figure.

The following common parameters also apply to Wave objects:

Scale•	 : Increases or decreases the size of the Wave Object in 
all axes.

XYZScale•	 : The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the Wave Zone in the selected 
axis. This is only available for the Wave Zone.

XYZRotate•	 : The xRotate, yRotate, and zRotate 
parameter dials rotate the Wave Object around the selected 
axis.

XYZTran•	 : The xTran, yTran, and zTran parameter dials 
move the Wave Object along the selected axis.
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Using Deformers with Grouped 
Objects
You can create custom groups using the Group Editor palette as 
described in The Group Editor on page 487 and apply deformers to 
these groups. Groups can contain parts of one or more body parts/
props. You can select these groups by name using the Properties 
palette for selected magnets or waves. To apply a deformer to a 
group:

Select the body part/prop containing the group.

Create the deformer as described above.1.	

Select the deformer’s Zone and access that zone’s properties 2.	
as described above. Check the Group checkbox, then select 
one or more groups from the pop-up that appears. A group is 
selected when a checkbox appears next to it.

This procedure deforms on the grouped sections of body parts/
props.

Creating Morphs with the 
Morphing Tool
Morph targets are custom parameters added to body parts or props 
that allow you to reshape the affected part(s). Poser includes some 

built-in morph targets with the stock figures, and you can create 
your own. Morph targets allow you to easily resize and reshape 
items and are fully animatable.

Figure 28.19

While morph targets appear as parameter dials in the Parameters 
palette, they are actually custom geometry containing the 
deformation, which you then apply using parameter dials. Does this 
seem confusing? It’s actually pretty simple once you get the hang 
of it. Let’s explore this functionality a little further. You can create 
your own morph targets using Poser and/or another application. 
This manual primarily covers creating morph targets in Poser, but 
we will discuss using third-party applications in general terms. 
Within Poser, you use a combination of deformers and existing 
morph channels (such as the Surprised parameter) to create morph 
targets. Each morph target gets its own Parameter dial whenever 
the affected element(s) are selected and the morph target is 
loaded. For example, if you create a morph called Bulging Bicep 
for the upper arm, you’ll see the Bulging Bicep parameter dial in 
the Parameters palette when you’ve loaded the morph target and 
selected the upper arm.
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Clicking on the Morphing Tool in the Editing Tools display 
opens the Morph Editor palette. The Morphing Tool has two 
operational modes: Combine and Create, which are covered in the 
sections that follow. Click on the appropriate tab in the Morph 
Editor to switch between these two modes.

Figure 28.20

The Combine Tab
The Combine tab on the Morph Editor allows you to visually 
sculpt your figures’ morph targets by clicking on a body part such 
as the head, then dragging the mouse to change the shape of that 
body part. The changes that you see are all based on the morphs 
that are already present in the body part. You can do this with any 
scene object that has morph targets. 

Figure 28.21

To use the Combine tab:

Select the body part you wish to sculpt, then select the 1.	
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Morphing Tool. The Morph Editor palette appears. The 
Combine tab displays all of the morph targets available for 
the selected body part:

The list of morph targets is hierarchical and displays branches 2.	
containing the available morph targets. Clicking the – icon 
next to an expanded branch collapses that branch, and 
clicking the + icon next to a collapsed branch expands that 
branch. You can also use the scroll bars to navigate the list. 
The Morph Editor will allow you to manipulate all selected 
morph targets. A green dot next to a morph target includes 
the specified morph target when using the tool, and a Lock 
icon means the specified morph target will not be affected by 
the tool. Even if a morph target is enabled, it may or may not 
be affected by your use of the tool. For example, selecting a 
vertex in the forehead may affect the eyebrows but will not 
affect the mouth. Select your desired morph target(s), then 
click and drag any vertex on the selected body part.

Figure 28.22

Once you have a portion of the body part the way you want 3.	
it, you can click the Pin button then click one or more vertices 
to pin them, preventing further manipulation as you work on 
other areas of the object. Pinned vertices appear as red dots 
on the current object and may move as you keep adjusting 
other portions of the body part (depending on how many 
morph targets affect the pinned vertex), however they will 
retain their current settings. Also, pins are retained if you stop 
using the Morphing Tool and resume using it later. To stop 
pinning vertices, click the Morphing button (see below). You 
may notice some trembling if you adjust morphs that affect 
pinned vertices.

The Morph Editor palette has the following functions:
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Figure 28.23

Morphing•	 : Clicking the Morphing button re-enables the 
Morphing Tool. Click this button after pinning vertices to 
resume adjusting morphs.

Pin•	 : Clicking the Pin button disables the Morphing Tool and 
allows you to pin one or more vertices as discussed above.

Clear Morphs•	 : Clicking the Clear Morphs button resets 

all morphs. Use this option with care as it will undo all of your 
changes, even if you exit and resume using the Morphing 
Tool.

Clear Pins•	 : Clicking the Clear Pins button removes all pins 
previously applied to the current object.

Exaggeration min/max•	 : Exaggeration refers to the 
degree to which a morph target’s value will affect the vertices. 
The Exaggeration Min and Exaggeration Max values 
limit the extent of a morph target’s possible effect when the 
Morphing Tool is operating. No morph target can be modified 
beyond these limits (see Editing Parameter Dials on page 141 
for more information about parameter dial limits). Increasing 
these limits therefore increases the exaggeration effects of all 
morph targets. For a technical description of Exaggeration 
Min/Max, see the following note.

Mathematically, each morph target defines a displacement 
vector (v) on each object vertex, and its exaggeration value 
defines a multiplier (w). Thus, a morph target’s net effect is 
p + wv, where p is the original vertex position. If w=1, 
we add v+p. W can be any value. The larger w is, the more 
exaggeration this morph target’s effect has. The Exaggeration 
Min and Exaggeration Max values globally define the limits 
for w across all morph target weights when the Morphing 
Tool operates. 
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Lock All•	 : Clicking the Lock All button locks all morph 
targets, which disables morph-based shape changes. This is 
handy when you’re satisfied with your overall shape and only 
want to fine-tune a few specific morphs. In that case, you 
could use this option then unlock only those morphs you want 
to adjust.

Unlock All•	 : Clicking the Unlock All button unlocks all 
morph targets, allowing you to modify them.

To move in the Z axis, press and hold [COMMAND]/
[CTRL] while dragging.

The Create Tab
The Create tab of the Morph Editor allows you to select and 
modify the mesh vertices to create new morph targets on a single 
body part or across joint seams to adjacent body parts.  As with the 
Combine tab, you can apply the Create tab functionality to any 
scene object that has a mesh.

Deformations made to the mesh while using the Create tab 
can apply to the currently selected actor or to the entire figure. 
In addition to creating morph targets for individual actors, Poser 
also allows you to create Full-Body Morphs (FBMs). For more 
information about Full-Body Morphs, see Creating Full-Body 
Morphs on page 471﻿.

Figure 28.24

To use the Create tab:

At the top of the 1.	 Create tab, click the radio button for the 
action you wish to use to modify the vertices: Push, Pull, 
Smooth or Restore.
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Figure 28.25

Push�� : Selecting Push will enable you to push the 
vertices in the impact region inward from the original 
surface of the mesh, to create a concavity such as a 
dimple or a dent.

Pull�� : Selecting Pull will enable you to pull the vertices 
in the impact region outward from the original surface 
of the mesh. This task is very useful for cleaning up any 
inappropriate intersections between the figure and either 
conforming or dynamic clothing; you can select a region 
of the cloth, and simply pull it out past the point of 
intersection with the figure.

Smooth�� : With the Smooth option you can gradually 
reduce the amount of variation in the surface mesh, to 
create a smoother surface. This is particularly useful for 
surfaces with high frequency variations. Keep in mind that 
this option generally reduces definition.

Restore�� : The Restore option gradually reverts your 
recent changes back towards the original unmorphed 
geometry state. This feature can be extremely useful in 
fine-tuning your modifications, as it allows you to back up 

recent changes by gradual degrees.

Restore is not the same as Undo. If you make a change, 
and then select Edit > Undo, your entire change will be 
erased, and the mesh will revert to the state it was in before 
you made the change. By using Restore, you can revert the 
effects of your change gradually, thus allowing you to edit your 
modification without losing it completely.

Select the mode in which you wish to work: Relative to 2.	
Surface or Screen.

Surface�� : When in Surface mode, all modifications you 
make to the mesh will be made along the direction of 
the surface normal. This is the default mode, as you are 
likely to want to sculpt in relation to the surface normal 
direction for most purposes.

Screen�� : Screen mode allows you to deform the mesh in 
any direction you wish. This option is useful for situations 
when you may wish to sculpt the mesh in a transverse 
or vertical direction. Please note that the direction of the 
modification in Screen mode is determined by the current 
view of the figure as relative to the screen. For example, 
if you wish to deform the mesh towards the camera, you 
should rotate the figure ninety degrees, then make your 
modification by moving your mouse to the side.

Select your desired brush style from the five circular brush 3.	
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style icons. Poser’s morph target creation feature uses a brush 
paradigm, which allows for varying degrees of precision when 
applying your modifications to the mesh. The left most brush 
style impacts only the closest single vertex to your mouse 
pointer, thus allowing for a great deal of precise control. The 
remaining brush styles all affect a region of the mesh. These 
regional brush styles have varying degrees of falloff; the 
modification will affect vertices within the impacted region to 
differing degrees, as determined by the falloff. For example, 
the second brush style from the left has a large falloff region, 
which means that while vertices at the center of the region 
will be strongly impacted by your modifications, the impact 
will decrease gradually over most of the other vertices within 
the impact region. The falloff area decreases with the next two 
brush styles, and the right-most brush style has zero falloff, so 
that all vertices within the region are impacted equally. Figure 28.26

Enabling the Display Brush option in the lower portion 
of the Create tab will display a visual preview of the impact 
region. This preview is color coded to show the falloff effect: 
red indicates the area most strongly affected, yellow indicates 
less effect, and areas shown in green are the least affected 
within the impact region.

Adjust the 4.	 Radius dial to increase or decrease the size of the 
impact region. If you have enabled the Display Brush option, 
the visual preview will adjust automatically to indicate the 
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current impact region radius.

You may want to adjust the 5.	 Magnitude dial to specify how 
much effect the Morphing Tool will have within the impact 
region. A high Magnitude setting will allow you to make 
large-scale dramatic changes, for faster workflow. A low 
Magnitude setting will allow you to make more precise, 
focused changes.

Figure 28.27

We recommend that you start with a relatively low 
Magnitude setting to allow you to become accustomed to the 
Morphing Tool, and then gradually increase the Magnitude 
as needed.

By default, the Morphing Tool allows you to morph across 6.	
multiple body parts. If you want to make changes to a single 
body part, check the Group option (shown in the following 
figure) and select a group from the popup menu.

Figure 28.28

The Group option allows you to specify which specific 
polygons the Morphing Tool will affect. When you 
enable the Group option, the Group pop-up menu 
will display a list of all polygon groups that exist for the 
currently selected actor. You can select a group from this 
list to limit the effect of the Morphing Tool to polygons 
contained in that group. You can also create a group 
for your specific purposes using the Group Editor (see 
Chapter 29: Figure and Prop Editors on page 487 for 
more information about the Group Editor).

Enable or disable the following options to suit your 7.	
requirements:

Average normals:��

Accumulate�� : When Accumulate is enabled (checked), 
your change will continue to accumulate so long as 
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you continue a single click-and-drag movement. This 
option allows you to make a greater degree of change 
with a single motion, but with less precision. When 
the Accumulate option is disabled (unchecked), 
each modification requires a separate click-and-drag 
operation. Use this setting for greater control over your 
modifications. 

Stroke�� : When the Stroke option is enabled (checked), 
the Morphing Tool will implement your modifications 
along the trajectory of your mouse movement. This allows 
you to “paint” deformations onto the surface of the 
mesh as you move your mouse across it. When Stroke is 
disabled, your mouse movements will adjust the degree 
of the deformation, while the effect of the modification 
applies to the original impact region only.

Once you have configured the 8.	 Morphing Tool to your 
specific needs via the Create tab, click and drag directly on 
the current actor to deform the mesh.

When you have completed your modifications, click the 9.	 Save 
Copy As button to propagate your work to a new morph 
target. 

The Create tab also contains the following Display options:

Figure 28.29

Display Mesh•	 : The Display Mesh option will superimpose 
a visualization of the mesh over whatever display style you 
have currently selected. (See Chapter 6: The Display Controls 
and Menu on page 77 for more information on the various 
display styles.) This option can be very helpful in that it allows 
you to see how your deformations affect the surrounding 
polygons.

Display Brush•	 : The Display Brush option displays a 
visual preview of the region you will be impacting with your 
deformation. This preview uses different colors to indicate 
the degree to which each area of the impact region will be 
affected by your selected action. Specifically, red indicates 
the area most strongly affected, yellow indicates that an 
area is less strongly affected, and green areas are the least 
affected within the impact region. The Display Brush option 
is enabled by default. If you have elected to work on a single 
group rather than the entire figure, the brush will display only 
when it is over the group that is selected for editing.
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Figure 28.30

Work With Current Morphs•	 : When enabled, the Work 
With Current Morphs option allows you to visualize the 
current adjusted state of all other morph targets while you 
deform the mesh. This option is useful for creating a morph 
target that acts on top of another morph target.

This setting is useful for understanding how your new 
morph target will interact with other existing morph targets.

When disabled, the Work With Current Morphs 
option allows you to temporarily hide the effects of all 
other morph targets while working within the Create 
tab. Using this option allows you to work on the mesh 
geometry in its neutral state, without losing the settings 
of your other morph targets. If you leave the Create tab, 
those morph targets will automatically revert to their 
specified states.

You can use the following functions to save or reset your morph 

targets:

Figure 28.31

Mirror•	 : The Mirror button at the bottom of the Create 
tab brings up a pop-up menu offering six options of different 
axes and directions for creating symmetrical changes on the 
currently selected object, for example “-x to x” or “z to -z”. 
Note that these axes refer to the local coordinate system of 
the currently selected object only, and are not related to the 
world space coordinates of your Poser scene. Selecting one of 
these options will mirror morph target changes from one half 
of the currently selected object to another half of the same 
object, as defined by the axis and direction you selected from 
the menu.

If the mesh topology of the actor across which you are 
attempting to mirror is not symmetrical, the mirror feature 
may not be able to successfully translate your morph target 
changes.

Zero Morph•	 : The Zero Morph button will reset the surface 
mesh to its undeformed state. Zero Morph will also clear any 
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morphing tool changes (stored in the Custom Morph channel) 
that will generate at each body part and the figure level. If 
the Zero Morph button has been pushed, the channel will still 
exist but the morph data is removed. 

 This Custom Morph channel is used as a receptacle for 
morphing edits with the morphing tool. Save a Copy As is the 
best way to preserve that Custom Morph data for Full Body or 
individual body part morphs.  

 The Zero Morph button only applies to the effects of your 
new morph target; all other morph target states will remain 
unchanged. Be sure to save a copy of your modifications 
before clicking the Zero Morph button if you do not wish to 
lose your changes.

Save a Copy As•	 : Whenever you enter the Create tab, any 
modifications you make will automatically be placed into a 
“Custom Morph” morph target. The Save a Copy As button 
will allow you to save the current state of the Custom Morph 
target to a new, separate morph target. You can use Save 
a Copy As to save incremental modifications as you work 
with the mesh, or to propagate your final modifications to the 
figure for future use. 

Full Body Morphs created using the Save a Copy As and the 
Custom Morph functions are traditional Delta Add morphs 

with values that change linearly with the a master parameter 
value. You can edit them using the dependent parameters 
editor, as mentioned in Using Dependent Parameters on 
page 471.  The Save a Copy As morph saves a channel to each 
body part, and also adds a parameter dial to the Body that 
drives all of the individual body part channels.

The Custom Morph target is cumulative, in that any 
modifications you make will be made on top of the previous 
state of the morph target. Therefore, if you do not save your 
changes to a separate morph target using the Save a Copy 
As button, they will become incorporated into any figure 
changes, and you may have difficulty recovering that previous 
state.

Creating Morphs in Other 
Applications

Creating Custom Morph Targets
You can create morph targets using your favorite 3D modeling 
application so long as that application can import and export 
Wavefront OBJ (*.OBJ) files. To do this:

Export the body part for which you wish to create the morph 1.	
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target as explained in Exporting Files on page 55.

Import the body part into your favorite 3D modeling 2.	
application.

Edit the geometry, being careful to only move vertices. Do not 3.	
add or remove vertices, or your morph target will not work.

Export the edited geometry from the 3D modeling application 4.	
in the Wavefront OBJ (*.OBJ) format.

Load the morph target.5.	

Adding Custom Morph Targets
Selecting Object > Load Morph Target allows you to load a 
morph target for your currently selected element. 

You can add morph targets that you created using a third-party 
application and apply them to your figures and props. You can 
also add third-party morphs obtained from online sources such as 
Poser’s Content room, which links you to several leading Poser 
content marketplaces. Please refer to Chapter 8: The Content Room 
on page 120﻿ for more information on Poser’s Content room. 

To add a custom morph target:

Select the body part/prop to which you want to apply the 1.	
morph and open its properties in the Properties palette.

Click 2.	 Load Morph Target to open the Load Morph Target 
dialog.

Figure 28.32

Enter the complete path and filename to your desired morph 3.	
or use the Locate button to open a standard Browse dialog 
allowing you to locate the correct file. Your selected file must 
be in OBJ format, contain the same number of vertices as the 
original body part/prop, and must only contain the body part/
prop being morphed.

Enter a name for the added file, then click 4.	 OK to exit back to 
the Parameters palette. A new parameter dial appears with 
the name of the newly added morph.

In order for morph targets to work properly, they must have the 
same vertex order as the geometry mesh to which they are applied. 
Some applications have difficulty preserving the vertex order 
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when editing or writing out morph targets. If you find that your 
imported morph targets behave unexpectedly, you may wish to 
check the Attempt Vertex Order Correction checkbox when 
loading them. This checkbox is located on the Load Morph 
Target dialog, which can be accessed by selecting Object > Load 
Morph Target, or clicking the Load Morph Target button on the 
Properties palette. Please note that significant changes to vertex 
order are not possible with automatic correction.

Combining Morphs in Poser
Poser provides a number of different ways that you can combine 
body morphs to create unique characters. For example, you can 
use the Object > Spawn Morph Target command to create a 
parameter dial for body parts and props that have been modified 
with deformers. The Figure > Create Full Body Morph 
command allows you to create a single master dial in the Body to 
drive morphs in several different body parts. Additionally, you can 
use Dependent Parameters to create master parameter dials that, 
in turn, create more realistic interactions between body parts and 
rotations.

Spawning Morph Targets
In addition to the Create tab on the Morph Editor palette, 
you can also create morph targets in Poser directly from the 

Properties palette. Selecting Object > Spawn Morph Target 
creates a morph target from deformed objects (body parts, props) 
in your scene. You will be asked to name your new morph target, 
and a dial with your specified name will appear in the object’s 
Parameters palette. 

Shape an element using any combination of deformers you 1.	
like to get the results you want. Shaping multiple elements on 
a body part includes all changes in the shape in the morph 
target.

Select the body part/prop’s properties in the 2.	 Properties 
palette, then select Spawn Morph Target. A dialog appears 
asking you to name your new target. 

Enter your desired name and click 3.	 OK. A parameter dial 
appears in the Parameters palette with the name of your 
new morph target. At this point, you can delete all deformers 
used to create the morph.

Figure 28.33

Numbers greater than 0 apply the morph to the selected 
element(s), and vice versa. A value of 1 means the morph target is 
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fully applied, a value of -1 means the morph is completely inverted, 
and numbers greater than +/-1 create exaggerated effects. Using 
the Bulging Bicep example, a value of 1 applies the bulge fully, 
a value of -1 applies a full concavity (the reverse of the original 
morph), and so on.

Creating Full-Body Morphs
You can save multiple body parts and then save the entire pose as 
a full-figure morph target, also known as a Full-Body Morph (FBM). 
The new morph target encompasses all of the parameters for that 
pose, meaning that everything morphs at the same time.

Only morph channels combine into a full-body morph. 
Deformers are not automatically turned into morph targets for 
full-figure morphs, nor are scales, rotations, and translations.

To create a full-body morph target:

Create morph targets for as many body parts as you wish. 1.	
Refer to this section for assistance if needed.

Morph each body part using the new 2.	 Parameter dials as 
discussed in Parameters Palette on page 138﻿. Set them to 
the values you want to appear in the full-body morph. For 
example, setting the Bulging Bicep value to 0.5 means that 
the full body morph, when set to 1, will morph that part of the 

figure as if you had applied the original morph with a value 
of 0.5.

Select the entire figure, then select 3.	 Figure > Create Full 
Body Morph. Enter a name for your new morph in the Set 
Name dialog that appears.

When you select the figure’s body again, a parameter dial with 
your new morph target will appear. This morph functions just like 
any other morph: Numbers greater than 0 apply the morph to the 
selected element(s), and vice versa. A value of 1 means the morph 
target is fully applied, a value of -1 means the morph is completely 
inverted, and numbers grater than +/-1 create exaggerated effects. 
Using the Bulging Bicep example, a value of 1 applies the bulge 
fully, a value of -1 applies a full concavity (the reverse of the 
original morph), and so forth.

Using Dependent Parameters
You can change any existing parameter dial or create new master 
parameter dials that can be used to control any number of 
dependent (or slave) parameters. This powerful feature lets you link 
morphs, deformers, transformations, or just about any element in 
the scene to create complex interactions that are all driven by a 
master parameter..

We’ll examine how Ryan and Alyson use dependent parameters to 
control how several magnet deformers shape the forearm and bicep 
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when you bend the forearm on Alyson. 

Ryan and Alyson include several magnet deformers that help joints 
bend more realistically. The dependent parameters feature is used 
to link these deformers to various joints in the figure. 

There are some magnet deformers that cause Alyson’s forearm and 
bicep to bulge when you bend her forearm. In previous versions 
of Poser, you had to edit the figure’s CR2 file in a text or CR2 
editor to create a link between the forearm’s bend rotation and 
the deformers (magnets or morphs) in the forearm and bicep. The 
dependent parameters feature permits the user to create these 
links without having to hand edit text in the CR2 file. In addition, 
it permits the user to create a curved link that can have varying 
driven values at any value of the master parameter. Conversely, 
the old hand-editing method only created linear links between the 
master and dependant parameters.

 You can see all of the magnet deformers used in Alyson 
if you choose Display > Deformers > Show All. You can 
choose Display > Deformers > Hide All to turn them back 
off after you’ve examined them.

In this example, we start by loading Alyson into an empty scene 
and selecting the Top camera view. When you select Alyson’s left 
forearm, you’ll notice the following features in the Parameters 
palette (shown in the following figure):

A Master Parameter icon appears beside any parameter that •	

serves as a Master Parameter. Click on this button to open the 
Dependent Parameters editor. This serves the same function 
as choosing the Edit Dependencies command from the 
Parameters Option Menu (as described next).

When two values appear beside a parameter dial, one above •	
the other, they indicate the following:

The lower number is the �� natural value, which is the 
value as set by the parameter dial itself.

The upper number is the �� driven value, which is the 
sum of the natural value setting plus any values set by 
its master parameter. 
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Figure 28.34

Select Alyson’s Left Forearm, and click the Option Menu arrow at 
the right of the Bend parameter to display the menu shown in the 
following figure. Choose Edit Dependencies from the menu that 
appears. This opens the Dependent Parameters window. Figure 28.35

The Dependent Parameters window displays the following 
settings and options:

•	 Master Parameter: Lists the name of the Master 
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Parameter dial that will control the dependent parameters.

•	 Start Teaching: Click this button to “record” the changes 
that you want to link to the currently selected dial and value.

Value slider and number•	 : Drag the slider left or right 
to increase or decrease the value. You can also click the value 
field and enter a number.

Dependent Parameters•	 : Provides a list of the other 
parameters in the figure that will be affected when you adjust 
the Master Parameter dial. For example, when you dial the 
Bend morph to -90 you want a change to occur in the Left 
Shoulder body part. 

Remove Selected•	 : To remove dependent parameters, 
click to highlight one or more of the entries in the Dependent 
Parameters list, then click the Remove Selected button.

Type: •	 There are two types of Master Parameter dials:

Keyed�� : This master parameter type is the only type of 
dial that you can create in the Dependent Parameter 
palette. You can create linear links or curved links that 
have varying driven values at any value of the master 
parameter. 

Delta Add:��   If you see this type listed, it means that 
the relationship between the master parameter dial and 

its dependent parameters were created externally (most 
often by content developers that created the relationships 
while editing the figure’s CR2 character file). A Delta Add 
type is also created when you use the Morphing Tool 
across body parts. Delta Add parameters are editable 
in the Dependent Parameters editor. When you add 
additional keys to a Delta master parameter, it remains a 
Delta master parameter.

Figure 28.36
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When you look at the Bend parameter in Alyson’s left forearm, 
you’ll notice that there are a number of deformers linked to the 
parameter dial. 

Figure 28.37

These deformers cause Alyson’s forearm and bicep to bulge when 
you bend the forearm. If the deformers are displayed  (Display > 
Deformers > Show All) you can observe how they respond when 
you adjust the Bend parameter on the left forearm. You can adjust 

the dial in the Parameters palette, or in the Dependent Parameters 
window.

Figure 28.38

The Dependent Parameter Editor 
Graph
The Graph in the Dependent Parameters window allows you to 
adjust how the parameter responds between keys. At a minimum 
you need two keys. But you can modify keys in the graph display 
as follows:
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Click on the graph display between two value keys and drag •	
up or down to add a third value key.

Drag the Master Parameter’s value in the graph by clicking on •	
the vertical line and moving it forward or backward.

Click on any value key and drag it up or down to increase/•	
decrease it’s value. 

Click and drag in an open space of the graph to select •	
multiple keys.  You can move this selection to include other 
keys. Key navigation is controlled via the pop-up to the right 
of the graph. 

Creating Master Parameters
You can create a new Master Parameter dial from the Parameters 
option menu in the Parameters Palette. Master and Dependent 
Parameters aren’t restricted for use in figures. For example, you 
can create a Brightness master parameter on the main light in your 
scene, and use it to raise or lower the brightness in all of the lights 
in your scene at the same time.

Using Poser’s default three-light setup as an example, you would 
create a master parameter for Light 2 (the front off-white light) as 
the Master Parameter, as follows:

Select the actor that will serve as the master parameter. In 1.	

this case, we want to add a new Master Parameter to Poser’s 
default Light 2.

Click the Parameters Palette Options menu, and choose 2.	
Create New Master Parameter.

Figure 28.39

The Dependent Parameters Editor opens and displays a 3.	
default name of Master(x), where (x) is a number. If it is the 
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first Master Parameter that you are creating, it will be named 
Master 1.

You need to add two keys for each dependent parameter that 4.	
you want to add. Since Light 2 is selected, we will adjust the 
brightness on that light first. First, click the Start Teaching 
button:

In the Dependent Parameters palette, set the Parameter dial to 5.	
1.000.  This is the value we will use as the “Bright” setting for 
the Master 1 Parameter dial. 

Now you adjust the brightness on all three lights in your 6.	
scene. It doesn’t matter which order you complete them in, but 
since we have Light 2 selected already we’ll do that one first. 
Set the Intensity for Light 2 to 200% (or double the normal 
brightness). 

Repeat Step 6 for Lights 1 and Lights 3, selecting them from 7.	
the Actor Selector in the Parameters Palette. As you make 
these settings, you’ll notice entries are automatically added to 
the Dependent Parameters palette. 

Figure 28.40

Click the 8.	 Next Key button in the Dependent Parameters 
palette to create a key for the other end of the Master 1 
parameter dial. 

In the Dependent Parameters palette, set the Master 1 9.	
parameter to -1.00 (negative value). This is the setting that we 
will use to turn the lights off. 
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In the Properties palette, set the intensity of your current light 10.	
to 0% (off). Then do the same for the other two lights.

Figure 28.41

With all of your settings configured, click the 11.	 Stop Teaching 
button in the Parameters Palette. You can also close the 
Dependent Parameters palette, if desired.

Figure 28.42

To test the new master parameter dial, select Light 2 in the 
Parameters Palette, and adjust the Master 1 parameter dial. All 
three lights should be off when the dial is set to -1, on at their 
normal strength at 0, and at double brightness at 1.
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Figure 28.43

Editing Master Parameters
The Dependent Parameters feature can be used to create or 
enhance Full Body Morphs. In this section, we’ll describe how you 
can use the dependent parameters feature to enhance the Pregnant 
full body morph.

Create a new Poser scene and add Alyson to your scene. Select 
her Body, and expand the FBM morph section. Scroll down, if 
necessary, until you see the Pregnant morph. Click the Master 
Parameter icon to open the Dependent Parameter editor.

Figure 28.44

You’ll notice that a number of dependent parameters already 
appear in the Dependent Parameters editor. If you highlight one of 
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the Dependent Parameters, the selected parameter appears in the 
Parameters palette. For example, when you select the rButtock: 
Pregnant entry in the Dependent Parameters list, the settings for 
the rButtock body part appear in the Parameters palette. 

As mentioned earlier in Using Dependent Parameters on page 471,  
there are two numerical values listed to the right of each morph 
dial: 

The •	 natural value (lower) designates the value that is 
currently set for the morph dial in the Parameters palette.  In 
the example shown, the dial in the Parameters palette is set 
at 0%.

The•	  driven value (upper) designates the value as 
controlled by the master parameter. In this case, we are 
looking at a Master Parameter dial (Pregnant), so its Driven 
value in the Parameters palette is the same as that set in the 
Dependent Parameters window. 

Figure 28.45

The Dependent Parameters list displays a list of the morphs that are 
adjusted by the Pregnant morph. The above figure shows that the 
Pregnant morph dial in Alyson’s Body actor controls the Pregnant 
morph in the hip, waist, abdomen, chest, left buttock, and right 
buttock. If you are already familiar with previous versions of Poser, 
you might recognize this type of morph relationship as a “Full Body 
Morph.”  In earlier versions of Poser, you would have used the 
Figure > Create Full Body Morph command to create a master 
parameter dial in the figure’s Body part. 

While the older method of creating Full Body Morphs is still 
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available, the Dependent Parameters feature provides you with 
even more power. For example, you can link additional partial body 
morphs or full body morphs to the Pregnant dial so that there are 
even more changes to the shape of Alyson’s pregnant body. To 
demonstrate, we are going to make the Pregnant morph even more 
natural looking, by adding additional changes to the breasts and 
hips. The Dependent Parameters feature makes this a very simple 
process.

Since Alyson is already in your scene, select Body as the current 
body part. Scroll down until you see the Pregnant full body 
morph, and dial in or enter a setting of 1 in the Dependent 
Parameters window.

Figure 28.46

In the Dependent Parameters window, click the Start Teaching 
button. This instructs Poser to create a link between the Master 
Parameter and the values that you select until you tell Poser to stop 
teaching the joint parameters.

Now, we’ll adjust some of the breast settings to make them look 
more like those of a pregnant woman.  With Alyson’s Body actor 
selected in the Parameters window, scroll down in the Parameters 
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palette and expand the morphs under the Breasts category. Then 
you can use the dials or enter values numerically. The following list 
shows the values that we set. Yours don’t have to be exactly the 
same, feel free to experiment with other settings if you desire:

Breast Diameter•	 : 1.072

Breast Droop•	 : 1

Breasts Large•	 : 1.216

Breasts Natural•	 : 1

Areola Size•	 : .548

Nipples•	 : .248

Figure 28.47

Notice now that the shape of the breasts looks more natural and 
realistic. Now we’ll add a couple of other Full Body Morphs to the 
mix. We’ll add a touch of the Pear Figure and Rubenesque to 
adjust the overall body shape just a bit. Scroll back up to the Full 
Body morphs section in the Parameters Palette, and adjust the 
following values:
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PearFigure•	 : .199

Rubenesque•	 : .199

Figure 28.48

Now return to the Dependent Parameters window, and click Stop 
Teaching.  The settings that you dialed in while teaching the joint 
should all appear in the Dependent Parameters list. When you 
adjust the dial in the Dependent Parameters window, you should 

see the differences in the Pregnant morph respond accordingly.  
Before you close the Dependent Parameters window, set the value 
to zero.

Figure 28.49

Now, go back to the Pregnant full body morph in the Parameters 
window. Adjust the value up and down to see how the new 
morph responds to the changes in the dial settings. Your new 
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Pregnant morph should respond exactly as it did in the Dependent 
Parameters window. Notice how you also see the values of the 
PearFigure and Rubenesque dials change when you adjust the 
Pregnant morph. The values in the second column reflect the 
settings that are inherited by the links that you created with the 
master parameter.

Figure 28.50

The following figure shows the original Pregnant morph on the left, 
and the new improved version on the right. As you can see, the 

enhancements have made the morph look more natural. 

Figure 28.51

Before we move on to the next topic, there is one more thing to 
examine. The previous shot of the Parameters palette shows what 
happens to the PearFigure and Rubenesque morphs when you dial 
in the enhanced Pregnant morph. You’ll see that when the Pregnant 
master parameter dial is set to .820, it drives the PearFigure and 
Rubenesque morphs to .163. But what happens if we want the 
woman to be more pear-shaped?

The solution is simple enough. You can adjust the natural value 
(the lower value) of the Pear Figure morph just as you can with any 
morph dial that is not affected by a master parameter. The following 
figure shows what happens when the  natural value dial for the 
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Pear Figure morph is increased to .8.  The driven value, which was 
previously set to .163 by the Pregnant morph, increases by your 
.8 setting as well, and the resulting shape of the figure changes 
accordingly.

Figure 28.52

To summarize, Dependent Parameters can be used to create master 
parameter dials that drive other parameters in a figure: morph 

dials, magnets, light settings, material settings, rotations, and more. 
As you experiment with this feature you’ll realize how powerful 
and flexible it is.

Managing Morphed Figures

Saving Morph Targets
You can save morphed figures to the Library palette. Saved figures 
retain their custom parameter dials, meaning you can use them 
the next time you load that figure. To save a figure to the Library 
palette, please refer to Adding Items to the Library on page 113﻿.

Poser saves morph targets to an external binary file format (.pmd), 
which contains only the morph targets for a particular figure or 
scene. This format allows for faster loading and greater flexibility, 
as the targets are no longer enmeshed with the rest of the data 
in the .pz3 scene file. This storage method also requires less disk 
space, as all instances of the same figure reference the same .pmd 
file for morph target data. If you change the morph targets of one 
or more figures created from the Library and then save your scene, 
the morph target modifications will be saved in a single new .pmd 
file accompanying the scene file. If you wish to save the modified 
morph targets for any one figure independently, you must select 
the Use External Binary Morph Targets option in the General 
Preferences palette (see Setting Application Preferences on 
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page 26), and then add the modified figure back into the Library 
as a new figure. A new .pmd file will be created for that figure, 
containing the modified morph targets. You can then reuse that 
figure in other scenes. Additionally, you can easily redistribute 
the morph targets independently of the specific figure, thereby 
affording you options for greater flexibility and efficiency.

It is the responsibility of the user to comply with the Smith 
Micro Software, Inc. End User License Agreement, as well as 
any third party License Agreements, before distributing Poser 
content.

When you open and resave a Poser scene file (.pz3) from a 
previous version, Poser will create a new external .pmd file 
containing the morph targets for that scene. If you wish to save 
morph targets for the figures in that scene independently, simply 
add those figures to the Library as described above, and then 
replace them in your scene. Poser will generate individual .pmd files 
for each of the figures.

Deleting Morph Targets
You can use the Hierarchy Editor palette to delete morphs, as 
explained in Working with Hierarchy Branches on page 497.
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Chapter 29: Figure and Prop 
Editors

The Group Editor
Selecting the Grouping tool from the Editing tools display opens 
the Group Editor palette. The Group Editor lets you select and 
group individual polygons. 

 The Group Editor is very powerful and can permanently 
alter your figures if you overwrite changed figures into the 
Library. Be sure you understand how the grouping tool works 
before editing critical content. It’s wise to practice on a simple 
object or prop to grasp the concepts first.

 It helps to use Smooth Lined preview mode when using 
the Group Editor as polygons and vertices are clearly displayed.

The Group Editor is useful for various tasks within Poser such as:

Creating material groups in the •	 Material room. Please 
refer to Chapter 13: The Material Room on page 204 for 
information about the Material room.

Creating hair groups in the •	 Hair room. Please refer to Chapter 
24: The Hair Room on page 372 for information about the 
Hair room.

Creating cloth groups in the •	 Cloth room. Please refer to 
Chapter 25: The Cloth Room on page 386 for information 
about the Cloth room.

Creating body parts in the •	 Setup room. Please refer 
to Chapter 27: The Setup Room on page 428 for more 
information about the Setup room.

Creating props. You can also create new props and deform •	
and morph selected portions of an element. For example, 
you could use the Group Editor to select polygons around a 
character’s eyes, nose, and forehead, and use those selected 
polygons to create a mask prop. See Creating/Editing Groups 
on page 492 for information on how to select polygons in the 
Group Editor.

Polygon & Vertex Modes
The Grouping tool operates in polygon or vertex mode, depending 
upon which room you are in when you use the Group Editor. 
In polygon mode, you can add/remove your currently selected 
polygon(s) to the current polygon group. In vertex mode, you can 
add/remove your currently selected vertex/vertices to the current 
vertex group.
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In polygon mode, you can only create/edit/delete polygon groups. 
Likewise, in vertex mode, you can only create/edit/delete vertex 
groups. However, polygon groups are accessible from the Group 
Editor palette using certain commands (such as Add Group). 
Polygon groups will appear in the popup menu (#4 in the image) 
with the suffix P. Poser automatically selects the correct mode 
depending on which room you are currently in. For example, in the 
Pose room, the Grouping tool only operates in polygon mode; in 
the Cloth room, it operates in vertex mode.

Poser uses vertex groups for dynamic cloth objects in the Cloth 
room and for styling hair in the Hair room. For cloth, using vertices 
allows you to select the edges of a cloth object (such one side of 
a sheet hanging from a clothesline and blowing in the wind). This 
effect cannot be achieved using polygon grouping.

Using the Group Editor
To create/edit a group, select the Grouping tool, which opens the 
Group Editor palette. 

Figure 29.1

When this option is selected, all figures and objects in the Poser 
workspace turn gray. The Group Editor palette has the following 
sections and functions:

Figure 29.2

Select button (1)•	 : Click the Select button to enable 
polygon selection, and then click within the current object to 
add polygons/vertices to the current group. 

Deselect button (2)•	 : Click the Deselect button to enable 
polygon deselection, and then click within the current object to 
remove polygons/vertices from the current group.

Previous and Next buttons (3)•	 : Clicking the Previous 
(<<) and Next (>>) buttons cycles through the currently 
existing groups. Alternatively, you can use the pull-down menu 
between these buttons to jump directly to the desired group. 
These buttons are primarily used in the Hair and Cloth rooms.

Current Group pull-down menu (4)•	 : Use the 
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Current Group pull-down menu to jump directly to your 
desired group. This menu is primarily used in the Hair and 
Cloth rooms.

New Group button (5)•	 : Clicking the New Group button 
creates a new group with the currently selected polygons. 
Enter a name for the group in the dialog box that appears. 
This function is disabled in the Hair and Cloth rooms.

Delete Group button (6)•	 : Clicking the Delete Group 
button deletes the currently selected group.

Figure 29.3

Add All button (7)•	 : Clicking the Add All button places 
all polygons comprising the current object into the currently 
selected group.

Add Group button (8)•	 : Clicking the Add Group button 
adds all the polygons or vertices from the group you select 
in the Add Group dialog to the current (currently selected) 
group.

Remove All button (9)•	 : Clicking the Remove All button 
removes all polygons from the currently selected group.

Remove Group button (10)•	 : Clicking the Remove 
Group button removes the polygons or vertices from the 
selected subgroup to the current (currently selected) group.

Invert button (11)•	 : Clicking the Invert button inverts the 
current selection, that is, selects all deselected polygons and 
vice versa.

Add Material button (12)•	 : Clicking the Add Material 
button creates a new material group consisting of the 
currently selected polygon(s).

Figure 29.4

Hide Other Objects box (13)•	 : Checking the Hide 
Other Objects checkbox hides all objects in your scene 
other than the currently selected object, which can help if you 
have a complex scene and only want to see the object being 
worked on.

Show Multigrouped Faces box (14)•	 : Checking the 
Show multigrouped faces checkbox displays all polygons 
that are assigned to more than one group. This can occur if 
you grouped your geometry in the 3D modeling application 



Poser 8
Reference Manual 

490

Chapter 29: Figure and Prop Editors

and accidentally assigned some polygons to more than one 
group.

Show Nongrouped Faces box (15)•	 : Checking the 
Show nongrouped faces box displays all polygons that do 
not belong to a group. If you leave the Setup room with one 
or more polygons that are not attached to a bone, they will 
be maintained on a prop attached to the figure and will be 
available for grouping again when you return to the Setup 
room.

The above commands are necessary for creating a 
figure using the geometry and bone structure. The following 
commands are useful and can be performed in the Setup room; 
however, they are not necessary for figure creation. They may, 
however, be necessary for rendering and finishing scenes using 
the newly created figure. 

Figure 29.5

Create Prop button (16)•	 : Clicking the Create Prop 
button creates a new prop from the selected group or 

polygons. Enter a name for your new prop in the dialog that 
appears. 

Spawn Props button (17)•	 : Clicking the Spawn Prop 
button creates props for all groups that have been created. 
Two examples of this might be to create a suit of form-fitting 
armor or the basis for clothing props.

Assign Material button (18)•	 : Clicking the Assign 
Material button creates a new material class for the selected 
polygon(s). A dialog box will appear asking you to name 
the new material class. A material class is a parameter that 
determines the polygons to which a material is applied. For 
example, if you are creating a figure with gloves on, you could 
select the polygons of both gloves as a material class. Later, 
you could use the Material command to assign a material, 
texture, bump maps, etc. to the gloves. You can think of 
material classes as groups that define areas where materials 
are applied.

Assign Smoothing ID button (19)•	 : Clicking the 
Assign Smoothing ID button allows you to delineate 
smoothing groups for the application of smooth shading 
across adjoining polygon edges. A dialog will appear asking 
you to assign a new or existing Smoothing ID to the current 
group. Enter a new ID in the field provided. For more 
information about smoothing groups, see Smoothing Geometry 
on page 299﻿.
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Create Perspective UVs button (20)•	 : Clicking the 
Create Perspective UVs button maps texture coordinates 
for a group. An example of using this command might be 
to map an imported background image of a face to a Poser 
group corresponding to the figure’s face. The face’s texture 
coordinates would map to the image.

Reverse Group Normals button (21)•	 : Clicking the 
Reverse Group Normals button reverses the normals of 
the selected group. This allows you to turn environment-type 
objects or other imports inside out for interactive rendering 
as desired.

Auto Group button (22)•	 : See The Auto Group Command 
on page 491 below.

Weld Group button (23)•	 : See The Weld Group 
Command on page 492 below.

The Auto Group Command
When you are creating groups for a newly imported geometry 
(Setup room), you can save time and effort by clicking the Auto 
Group button near the bottom of the Group Editor palette. This 
option is particularly useful when you are creating custom Poser 
figures in the Setup room. If you choose to use the Auto Group 
feature, be sure to do so after creating, positioning, and naming 
the bone structure! This is because the Auto Group feature places 

polygons into groups based on their location in 3D space relative 
to the available bones. This can cause very unpredictable and 
disorganized results if the bone structure has not been properly 
created, positioned, and named.

If you use the Auto Group feature before you have 
created, positioned, and named the bone structure, it can 
result in unpredictable groups that will then require extensive 
time-consuming repair.  The correct bone structure used by the 
Poser 8 figures is shown in Poser 8 Figures Hierarchy on 
page 494. Other Poser figures use similar hierarchies, but may 
have less control in mouth, hand, and feet parts.

The Auto Group feature is designed for one-time use when you 
first create a figure. You can use it as often as you wish; however, it 
completely regroups every polygon in the geometry or figure, which 
will cause the figure to lose all pre-existing group assignments that 
match bone names. If you must use the Auto Group feature again 
after creating your figure, do it with care.

The Auto Group feature causes Poser to take a “best guess” 
when grouping polygons and bones. You may find that you need to 
fine-tune the automatically created groups by manually selecting 
polygons and moving them to different groups. Do this by selecting 
the target group and then selecting the polygon(s) you wish to 
move to the target group. 

The Grouping tool automatically removes polygons from 
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other named groups (including NO_BONE) and adds them to 
the selected target group in order to avoid having polygons 
assigned to more than one group at a time. Group Editor 
palette commands do not share this functionality. 

The Weld Group Command
The Weld Group feature can be useful if, for example, you need 
to make alterations to your groups after you leave the Setup room 
or if you import a prop with groups that you want to change. In 
the Setup room, once your figure is created, Poser breaks the 
single geometry into pieces corresponding to the groups you 
created. If you reassign polygons to different groups, the original 
breaks remain, which can cause your figure to appear broken or 
disconnected at the point where the old group boundaries lie.

The best way to illustrate this is by using an example. Say you 
create a figure with, among others, groups for the head and neck. 
After leaving the Setup room, Poser breaks the single geometry 
into pieces whose edges correspond to the group boundaries you 
created. This is necessary in order to allow the figure to bend. Later, 
you decide to move the neck higher into the head by reassigning 
some of the polygons in the head group to the neck group. You can 
do this easily using the Grouping tool.

Poser creates a new break in the geometry at the new group 
boundary; however, the old break at the old group boundary 
still exists. This can cause your figure’s neck to appear broken or 

discontinuous as you pose and render it. To solve this problem, you 
would:

Select the 1.	 Grouping tool.

Select the neck group.2.	

Click the 3.	 Weld Group button.

The Weld Group function alters and combines the vertices 
on either side of the break so as to create a smooth bridge 
across the gap. A good way to think of this is to imagine 
sealing a crack. The filler compound joins the two surfaces, but 
does minutely alter the surface topography where the crack 
used to be. The Weld Group function works this way as well, 
modifying the geometry slightly in order to eliminate the break. 
This should be unnoticeable in most cases.

Creating/Editing Groups
To create a group, select the Grouping tool. You can then click 
individual polygons or click and drag to select multiple polygons. 
If you accidentally select one or more wrong polygons, you can 
deselect them by using the Deselect tool (see above) or pressing 
[CTRL] while clicking or dragging. If you are in the Setup room, 
polygons that have been removed from a group will automatically 
be added to a group called NO_BONE so that you can see which 
polygons are unassigned and correct the problems before leaving 
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the Setup room.

To select polygons that are currently out of view, you can use the 
Wireframe display style, the camera trackball to change the view 
of your figure, and/or multiple viewpanes to bring the desired 
polygons into view.

While working with the Grouping tool, pressing [OPT]/
[ALT] allows you to quickly access the camera trackball.

While you are selecting polygons, it is possible that you will 
select some polygons that have previously been assigned to a 
different group, either by accident or by design. If this happens, 
the Grouping tool will remove the subject polygons from their 
previous group and assign them to the new group in order to 
ensure that no polygons belong to more than one group at a time.

The Group Editor palette commands do not share this 
functionality.

When you are creating groups for figures (Setup room), it is 
important to remember that joint bending only occurs between an 
object and its parent. The bends do not progress to other children 
or above the parent in the hierarchy. Keep this in mind as you 
create your groups, and later when you fine-tune your joints.

The Group Editor palette appears whenever the Grouping 

tool is selected.

The Hierarchy Editor
The Hierarchy Editor shows every parent/child relationship and 
every scene element and their various parameters, from lights and 
cameras to morphs and deformers. You can also view the IK chain 
settings and external names of each item. The Hierarchy Editor also 
displays buttons that allow you to configure standard hierarchy, 
rotation order, IK chains, and new figure.

A scene’s hierarchy describes the parent-child relationships of all 
objects in your scenes. 

 Please refer to the Poser Tutorial Manual, Hierarchy on 
page 14 for more information about hierarchies in general. 

Body parts or props that are physically located at a seam are 
generally contained in either a parent or child object. The scene’s 
hierarchy also defines data like joint rotation orders and IK 
relationships. 

A Poser document’s hierarchy contains:

The complete list of all objects in the scene’s universe, •	
including figures, props, body parts, lights, and cameras.
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Hierarchical connections (parent/child relationships) between •	
scene objects.

Parameters, including rotation, translation, morph targets, and •	
Point At (see Point At on page 151﻿).

IK chains.•	

Poser 8 Figures Hierarchy
In order to make a figure bendable, it needs to be attached to 
a skeleton that moves the polygons in the geometry. In order to 
attach the polygons (or “skin”) to the bones, the polygons in the 
geometry must be named the same as the bones in the underlying 
skeleton.

To utilize as many of Poser’s posing and morphing capabilities as 
possible, there are specific naming conventions that should be 
followed. Most human Poser figures follow a hierarchical structure 
that uses the hip actor as its root. Internal body part groups must 
always begin with a lower-case letter, with right and left body parts 
always beginning with a lower-case r (for right) or l (for left) to 
work with Poser’s Symmetry commands properly.

The internal group names that are used by the Poser 8 figures are 
shown below in their correct hierarchical structure. Poser 8 figures 
have additional groups (shown in bold italics) which control the 
top and bottom teeth, several levels for the tongue, and an extra 
joint for each of the fingers and toes to allow for better bending. 

Other Poser figures may have more or less groups, but the basic 
arrangement of the bones will be similar to that shown below:

hip
	 waist
		  abdomen
			   chest
				    neck
					     lEye
					     rEye
					     TopTeeth
					     BttmTeeth
					     Tongue1
						      Tongue2
							       Tongue3
								        Tongue4
									         Tongue5
										          Tongue6
	 lCollar
		  lBreast
			   lShldr
				    lForeArm
					     lHand
						      lThumb1
							       lThumb2
								        lThumb3
						      lIndex0
							       lIndex1
								        lIndex2
									         lIndex3
						      lMid0
							       lMid1
								        lMid2
									         lMid3
						      lRing0
							       lRing1
								        lRing2
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									         lRing3
						      lPinky0
							       lPinky1
								        lPinky2
									         lPinky3
	 rCollar
		  rBreast
			   rShldr
				    rForeArm
					     rHand
						      rThumb1
							       rThumb2
								        rThumb3
						      rIndex0
							       rIndex1
								        rIndex2
									         rIndex3
						      rMid0
							       rMid1
								        rMid2
									         rMid3
						      rRing0
							       rRing1
								        rRing2
									         rRing3
						      rPinky0
							       rPinky1
								        rPinky2
									         rPinky3
	 lButtock
		  lThigh
			   lShin
				    lFoot
					     lToe
						      lBigToe1
							       lBigToe2
						      lIndexToe1

							       lIndexToe2
						      lMidToe1
							       lMidToe2
						      lRingToe1
							       lRingToe2
						      lPinkyToe1
							       lPinkyToe2
	 rButtock
		  rThigh
			   rShin
				    rFoot
					     rToe
						      rBigToe1
							       rBigToe2
						      rIndexToe1
							       rIndexToe2
						      rMidToe1
							       rMidToe2
						      rRingToe1
							       rRingToe2
						      rPinkyToe1
							       rPinkyToe2

Using the Hierarchy Editor
To display the Hierarchy Editor palette, select Window > 
Hierarchy Editor. The Hierarchy Editor palette allows you to:

Select scene elements. Selecting an element in the •	 Hierarchy 
Editor palette selects that item in the Document window, 
Current Actor pull-down, and Graph palette.

Access object properties. Double-clicking an object listing in •	
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the Hierarchy Editor palette opens the Properties palette 
for the selected item.

Quickly hide or view scene elements.•	

Rename or delete elements and parameters such as morph •	
targets or Point At parameters. Use caution, as this is a very 
powerful and very permanent change.

Set up or change parent-child relationships for props.•	

Set up Inverse Kinematics (IK) chains.•	

Change rotation orders for props or body parts.•	

Create new figures. The addition of the graphical •	 Setup room 
(see Chapter 27: The Setup Room on page 428﻿) eliminates the 
need to use the Hierarchy Editor palette to create figures.

Expand or contract the hierarchy list to view parents and •	
children or parents only.

Filtering the Display
You can filter what appears in the Hierarchy Editor palette by 
selecting your desired display options at the top of the palette. 
Checking a box enables the selected option, and clearing it disables 
that option. The options are as follows:

Figure 29.6

Show Figures•	 : Checking the Show Figures checkbox 
displays all figures in the current Poser document.

Show Cameras•	 : Checking the Show Cameras checkbox 
displays all cameras in the current Poser document.

Show Parameters•	 : Checking the Show Parameters 
checkbox displays all object parameters in the current Poser 
document.

Show All Parameters•	 : Checking the Show All 
Parameters checkbox displays all parameters in the current 
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Poser document.

Show Props•	 : Checking the Show Props checkbox displays 
all props in the current Poser document.

Show Deformers•	 : Checking the Show Deformers 
checkbox displays all magnets, waves, morph targets, and 
force fields in the current Poser document (scene).

Show Lights•	 : Checking the Show Lights checkbox 
displays all lights in the current Poser document.

Working with Hierarchy Branches
You can perform the following basic actions using the hierarchy 
listing:

To expand a hierarchy branch, click the right-pointing arrow •	
next to the branch you wish to expand.

To collapse a hierarchy branch, click the downward-pointing •	
arrow next to the branch you wish to collapse.

To select an object, click its listing.•	

To make an object visible or invisible, click the eye next to the •	
desired icon. The eye appears bright white when an object is 
visible and gray when invisible.

To view the •	 Properties palette for an object, double-click the 

selected object’s listing.

To delete a figure, prop, or light from your scene, select the •	
item to delete then press [DEL]. You cannot delete body parts, 
cameras, or the ground plane.

To rename an object, click on its listing once to select it, and •	
then a second time to open a text box. (Do not simply double-
click on the listing, as this will open the Properties palette 
for that object.) Enter the object’s new name in the text box.

Figure 29.7

Reordering Scene Elements
You can reorder scene elements including props and deformers. 
Reordering deformers can be useful, especially when you have 
a long hierarchy listing. You can also reorder morph targets and 
parameters such as rotation orders (this is the same as using the 
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Joint Editor palette). You can also reorder light, camera, and prop 
Point At parameters.

Be careful when changing rotation orders as this might 
cause unexpected behavior. 

Establishing Hierarchal Relationships
This does the same thing as the Set Parent menu command 
(see Changing a Parent on page 167). To establish a hierarchical 
relationship using the Hierarchy Editor:

Load your desired prop(s) into the scene.1.	

Open the 2.	 Hierarchy Editor palette and find the prop.

Drag the child object on top of the root (parent) object. A 3.	
green box highlights the target when the child object is on 
top of it.

Drop the object onto the highlighted object.4.	

Figure 29.8

To reorder a child at the same hierarchical level:

Click the child object and drag to its new location. A white line 1.	
appears just below the target location, indicating where the 
object will be placed once dropped.

Drop the object.2.	

You can also create hierarchies spanning figures (such as a woman 
on horseback):

Select the child figure.1.	
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Drag the child figure onto the desired parent.2.	

Drop the child.3.	

You can also set up hierarchies between figures outside the 
Hierarchy Editor palette as follows:

Use the pop-up to select the child figure.1.	

Select 2.	 Figure > Set Figure Parent (see Set Figure Parent on 
page 167) to open the Set Parent dialog.

Select the parent body/body part in the dialog and click 3.	 OK.

Applying Standard Rotation Order
Please refer to the Poser Tutorial Manual, Applying the Standard 
Rotation Order on page 286 for more information about this 
function.

Applying the Standard Hierarchy
Please refer to the Poser Tutorial Manual, Applying the Standard 
Hierarchy on page 286 for more information about this function.

Creating IK Chains
To create an IK chain:

Scroll to the bottom of the hierarchy list using the scroll bar 1.	
and click the IK Chains entry to enable the Create IK Chain 
button.

Enter a name for the chain y2.	 ou are creating in the dialog box 
that pops up and click OK. A blank IK chain appears in the list.

Plan each element in the IK chain from root to goal. For 3.	
example, the IK chain for the right arm has the right hand as 
the goal.

From the hierarchy list, click and drag body part listings onto 4.	
the new blank IK chain. They will be added to the IK chain in 
the order you drag them from root to goal. Proceed to add 
parts to the chain in the order of root to goal.
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Figure 29.9

Be careful when creating IK chains as you could cause 
your figure to move in unexpected ways when the new IK chain 
is added.

Using IK
To enable IK for your figure, select Figure > Use Inverse 
Kinematics and select the chain you wish to enable. You will see 
the chains you created as well as the standard Poser chains (if you 
added chains to a standard Poser figure). A check mark appears 
next to each enabled IK chain. To disable IK, select Figure > Use 
Inverse Kinematics and select the chain you wish to disable. 
You can also open the Hierarchy Editor and check and uncheck the 
boxes next to each IK chain in the list to enable and disable IK.

Creating a New Figure
Please refer to the Poser Tutorial Manual, Chapter 26: Advanced 
Figure Creation on page 278 for more information on this legacy 
method of figure creation.

The Joint Editor
This section explains how to use the Joint Editor palette for 
positioning and/or fine-tuning joints. To open the palette, select 
Window > Joint Editor.
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Figure 29.10

The Joint Editor palette adjusts the currently selected joint (Pose 
room) or bone (Setup room) by allowing you to control both joints 
and blend zones. You can manipulate joints and blend transformers 
directly, thereby modifying how a joint or bone works. You can use 
this functionality to:

Fine-tune the blending of existing figures to suit your needs.1.	

Create new types of effects.2.	

Customize joints and transformers when creating your own 3.	
figures (such as using the Setup room, described in Chapter 
27: The Setup Room on page 428).

A figure’s joints control how parts bend, twist, and bulge. Realistic 
figure movement is controlled by joint settings. For example, a 
human knee can’t bend forward.

A figure’s bending and twisting motion is created using 
transformers, which skew, stretch, or scale polygons in the 
transformation zones to produce the desired motion. This is how a 
single static mesh object can become a fully pose-able figure within 
Poser. Transformation zones are defined by assigning inclusion and 
exclusion angles to each zone. Polygons in the exclusion angle are 
not affected by a joint bending, while polygons in the inclusion 
angle are affected. The area between the inclusion and exclusion 
angles is called the blend zone, where polygons are adjusted to 
create a smooth transition between surrounding polygons.

Using the Joint Editor
This section discusses using the Joint Editor palette in general 
terms and covers the options common to all joint parameters. 

To edit a joint’s parameters, begin by selecting the desired joint and 
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opening the Joint Editor palette by selecting Window > Joint 
Editor. The general options available are:

Selecting a Joint•	 : To select a joint, click the desired bone 
or joint.

Selecting a Joint Parameter•	 : Use the pull-down menu 
at the top of the Joint Editor palette to select the joint 
attribute you wish to edit from among those available for the 
selected joint. Parameters available for the selected attribute 
will appear in the palette.

Use Spherical Falloff Zones•	 : The Use Spherical 
Falloff Zones option toggles spherical falloff zones on 
and off. Please refer to Falloff Zones on page 509 for more 
information about falloff zones.

Zero Figure•	 : Selecting Zero Figure reverts all joint rotation 
parameters to zero.

The following section contains detailed information for each joint 
attribute.

Editing Joint Attributes
Each joint in a figure’s bone structure has some or all of the 
following attributes. The attributes available for each joint depend 
on the currently selected joint. You can think of the Joint Editor 
palette as working with body parts or bones, since the end result 

is the same. For the sake of discussion, it is appropriate to think of 
the Joint Editor palette as acting on body parts when in the Pose 
room and bones within the Setup room.

This section explains how to adjust each available joint parameter. 
Note that not all parameters will be applicable to every joint. Only 
those parameters applicable to the selected joint will appear in the 
joint editor.

Center

The Center attribute sets the center of rotation for the selected 
bone. It is available for all bones, body parts, and props. For 
example, hold your arm out with the palm up, bend it at the elbow, 
and notice that the center of the rotation is about halfway between 
your inner and outer elbow. Notice how your skin contracts above 
the center of rotation and expands beneath it. Imagine if the center 
of rotation was in a different location and how that would affect 
the appearance of your arm as you bend it. Move some other joints 
and imagine the changes that might occur if you shifted those 
centers. The Center attribute controls this aspect of joint motion.
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Figure 29.11

The following options are available when adjusting the Center 
joint parameter:

Display Deformer•	 : The Display Deformer option 
toggles the display of the actual joint on and off (which may 
be redundant when you are in the Setup room). This option 
works globally for all falloff zones when clicked.

Center Point•	 : The Center Point attribute defines the XYZ 
position of the joint (center of the body part). 0,0,0 is located 
in the center of the bone structure on the floor. 

Orientation•	 : The Orientation attribute defines the XYZ 
rotation of the joint and its axis. Click and drag the dials to set 
a value. Pressing and holding [OPT]/[ALT] while clicking a dial 
resets its value to 0. 

Align•	 : Clicking the Align button aligns the joint with its 
underlying body part or group. This option can be useful 
once you have created groups and attached the bones to the 
geometry. Prior to that point in the process, however, there is 
nothing to align the joint to.

Twist

The Twist attribute changes the location of the twist deformer for 
the selected bone. There is no Twist attribute for the hip bone or 
its equivalent, since the hip is the parent for the entire figure and 
twisting the hip twists the entire figure in unison. Holding your arm 
out with the palm down, twist it so your palm is facing up. Notice 
how most of your arm does not change, except for a region in your 
upper arm where the skin and muscles twist as you move. Imagine 
if the twisting began and/or ended in a different location. The 
Twist attribute controls this aspect of joint motion.
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Figure 29.12

When IK is enabled, child bones rotate when the parent is twisted. 
Twisting the hip normally moves the entire body since the hip is 
usually the parent for the entire figure, meaning that the hip does 
not have this parameter. By default, the Twist axis runs lengthwise 
down the center of each body part. For example, the arm twist axis 
is X, while legs twist along the Y axis.

The Twist parameter has the following settings and options:

Display Deformer•	 : The Display Deformer option 
toggles the display of the Falloff Zone geometries for the 
rotation channels. This setting is on globally for all joints.

Falloff Zones•	 : See Falloff Zones on page 509.

Twist Start •	 and Twist End: Define the beginning and 
ending points of a bone’s twist area. Enter your desired values 
in the appropriate boxes. Note that you can make twist areas 
larger than the selected bone, which can make a twisting 
motion appear more natural. In many cases, the bone’s parent 
should be included in the twist zone.

When this parameter is selected, a line with two handles appears 
on the figure. The red handle represents the starting point of the 
twist transformation area, and the green handle represents the end. 
Dragging these handles increases or decreases the Twist area.

Figure 29.13

You can use the Editing tools to adjust this parameter. This 
parameter exists in three dimensions, meaning you can rotate the 
figure to see the joint from any angle. You may, however, want to 
leave the figure in its default position and use the orthographic 
cameras (Top, Bottom, Left, Right, Front, Back) to constrain 
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movement to two axes, possibly avoiding much confusion.

Bend, Side to Side, and Front to Back

Adjusting the Bend attribute controls the angles of the bend 
transformers and defines how bulges are created. Flex various 
joints and note both the limits of your flexibility and how skin and 
muscles bulge as you move. The Bend attribute lets you control 
how this occurs in your figure.

Figure 29.14. Bend attribute settings.

Like the Bend attribute, the Side-Side and Front-Back attributes 
control the angles of the Side-Side and Front-Back transformers 
and define how bulges are created. These attributes are suited for 
omnidirectional joints such as your wrists, shoulders, hips, ankles, 
etc.

Figure 29.15. Side-Side attribute settings.
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Figure 29.16. Front-Back attribute settings.

The following parameters change the angles of the bend, side-to-
side, and front-to-back transformers, respectively. Further, Poser can 
create bulges to emulate your muscles bulging as you move. Each 
of these three parameters is functionally identical when editing 
these joint attributes in the Joint Editor palette. 

You can use the Editing tools to adjust these parameters. These 
parameters exists in three dimensions, meaning you can rotate the 
figure to see the joint from any angle. You may, however, want to 

leave the figure in its default position and use the orthographic 
cameras (Top, Bottom, Left, Right, Front, Back) to constrain 
movement to two axes, possibly avoiding much confusion.

They consist of the following settings:

Center Point•	 : The Center Point defines the center of the 
joint in 3D space. 0,0,0 is defined as being in the center of the 
skeleton on the floor. The motion (bending, side to side or front 
to back) occurs at the center point.

Joint Angles•	 : The Static A and Static D values determine 
the exclusion angle. The Dynamic B and Dynamic C angles 
determine the inclusion angle.

Bulge Settings•	 : Checking the Apply Bulge checkbox 
causes the polygons to flex and bulge as the joint moves, 
emulating the muscle bulging when real bodies move. If 
the box is checked, the polygons in the blend zone will be 
stretched or pinched to create bulges or wrinkles. Left and 
Right refers to the skeleton’s right and left. The positive dials 
control how much bulging out will occur when the joint moves, 
and the negative dials control the amount of wrinkling and 
pinching.

Inclusion & Exclusion Angles

The Bend, Side-Side, and Front to Back parameters allow you to 
define the inclusion and exclusion angles for the selected joint. The 
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inclusion angle appears as two green lines forming an angle, with 
the exclusion angle being a pair of red lines forming an angle. 

The Inclusion and Exclusion angles control which polygons move 
as a result of a joint bending and how the body parts on either 
side of the joint blend to accommodate the move. When editing 
inclusion and exclusion angles, the red lines represent the exclusion 
angle while the green lines represent the inclusion angle. 

The •	 inclusion angle defines which polygons are affected 
by moving the selected joint. Using the previous example of 
bending your arm at the elbow, your entire arm below your 
elbow moves. 

By contrast, the •	 exclusion angle defines those polygons 
not affected by moving the current joint. Notice that your 
upper arm does not move if you simply bend your elbow.

If you move any part of your body (for example bending your 
elbow), you will note that the skin on your upper and lower arms 
remains still except for the region near your elbow. Around your 
elbow, skin stretches or contracts depending on its location and the 
direction of motion. Slightly removed from the actual motion area, 
your skin and muscles move to adjust to the motion and preserve 
a smooth transition. The area between the inclusion and exclusion 
angles is called the blend zone, where Poser stretches, bends, and 
shrinks polygons to achieve a smooth transition between figure 
elements. This is the same as when you flex your leg and the 
skin in the area of your hip contracts or stretches as needed to 

accommodate the move.

Figure 29.17

The above graphic shows the exclusion angle above the knee , the 
inclusion angle below, and the blend area in the vicinity of the joint 
itself. To edit inclusion and exclusion angles:

Move the cursor to an end point of the inclusion or exclusion 1.	
angles until the cursor changes to a target symbol.

Drag the angle. It is recommended that you use Full Tracking 2.	
mode to view the effects of your changes as you drag. You can 
also enter your desired values in the text boxes.
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You can use the Editing tools to adjust this parameter. This 
parameter exists in three dimensions, meaning you can rotate the 
figure to see the joint from any angle. You may, however, want to 
leave the figure in its default position and use the orthographic 
cameras (Top, Bottom, Left, Right, Front, Back) to constrain 
movement to two axes, possibly avoiding much confusion.

End Zone

If a joint has a single child joint, the endpoint will always be the 
origin of the child. If there are multiple children (as in a hand) the 
endpoint can be set manually. This feature is used for some of the 
interaction tools, such as the Rotate tool for orientation from the 
origin. If there is no child joint (as with the head, typically) the 
endpoint is also editable.

Figure 29.18

Scaling

Each body part has parameters allowing you to scale the parent 
and child body parts. These settings are similar to the Twist 
parameters and follow the Twist axis of the child or parent body 
part. For example, the Poser 4 Business Man figure’s Right Collar 
body part has scaling controls for the chest (parent) along the Y 
axis and the Right Shoulder (child) along the X axis.

Figure 29.19

The High End/Start and Low Start/End parameters define 
a blending area. For example, when scaling the head, you may 
also want to scale the top of the neck to achieve a smooth fit. 
When setting these parameters, only one setting (high or low) is 
relevant. The unused parameter pair gets automatically set to some 
unrealistic number (such as 99,000 or 100,000), thus indicating 
that it is not relevant to the area you’re working on. Do not edit 
these out-of-limit settings.

Each blending zone’s end is represented in red, with its beginning 
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in green. Effects can be either uniform or can use spherical falloff 
zones, discussed below.

Falloff Zones
Falloff Zones are Poser’s fundamental method of creating smooth 
bending figures by blending between two bones or body parts. You 
can use falloff zones on any type of rotation (such as Bend, Side-
Side, Front-Back, Up-Down). A Falloff Zone section appears in the 
Joint Editor where it is appropriate to use falloff zones on a joint. 

There are two types of falloff zones: Spherical and Capsule, 
described in the sections that follow. Multiple Falloff Zones can be 
combined, regardless of type. The type of blending can be set as 
additive or multiply in the Joint Editor. 

Spherical Falloff Zones

When you use a spherical falloff zone, two spheres, a green inner 
sphere and a red outer sphere, represent the falloff zones.

The green sphere defines the area that is 100% affected by the 
transformation (motion), and the red sphere defines the limit of the 
transformer’s effect. The area between the spheres is the blending 
area, and the transformer’s effect gradually decreases from 100% 
at the boundary of the inner sphere to 0% at the boundary of the 
outer sphere.

Figure 29.20

You can edit spherical falloff zones just as you would any bone or 
body part using the Editing tools. 

Click the green sphere to edit the affected area. The •	
Parameters/Properties palette displays its properties as the 
innerMatSphere.

Click the red sphere to edit the unaffected area. The •	
Parameters/Properties palette displays its properties as the 
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outerMatSphere.

Figure 29.21

The following properties can be edited for the inner and outer 
MatSpheres of a spherical falloff zone:

Rotation•	 : To change the rotation of the inner or 
outerMatSphere, change the yRotate, xRotate, or zRotate 
values to change the rotation along the y, x, or z axis 
(respectively).

Scale•	 : Use the Scale setting to uniformly adjust the scale 
along the x, y, and z axes. To change an axis as needed to 

create an ellipse, adjust the xScale, yScale, or zScale setting 
appropriately.

Translation•	 : To move the sphere, adjust the xTran, yTran, 
or zTran setting appropriately.

TIP! You can also use the Direct Manipulation Tool to 
adjust the rotation, scale, or translation of the falloff zone. For 
more information about this tool, see Direct Manipulation 
on page 134.

Capsule Falloff Zones

Capsule falloff zones provide a great deal more flexibility in 
controlling the shape of the zones of influence. The green and 
red capsules work similarly to the spherical falloff zones. The 
green capsule defines the area that is 100% affected by the 
transformation, and the red capsule defines the limit of the 
transformation’s effect. The area in between the capsules defines 
the blending area.
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Figure 29.22

If you choose to create a capsule zone, there are six unique 
parameters in the Parameters Palette to change the shape and size 
of capsules and how they affect the current joint.

Click the green capsule to edit the affected area. The •	
Parameters/Properties palette displays its properties as the 
innerMatCapsule.

Click the red capsule to edit the unaffected area. The •	
Parameters/Properties palette displays its properties as the 

outerMatCapsule.

Figure 29.23

Right Length•	 : Sets the length of the right half of the 
cylinder portion of the capsule.

Right Radius•	 : Sets the radius of the right end of the 
cylinder portion of the capsule.

Right Cap•	 : Sets the length of the cap at the right end of the 
capsule. Increases or decreases the distance from the Right 
Length.

Left Length•	 : Sets the length of the left half of the cylinder 
portion of the capsule.

Left Radius•	 : Sets the radius of the left end of the cylinder 
portion of the capsule.

Left Cap•	 : Sets the length of the cap at the left end of the 
capsule. Increases or decreases the distance from the Left 
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Length.

Creating and Using Falloff Zones
As mentioned previously, you can use Falloff Zones on rotation joint 
rotations such as Bend, Side-Side, Up-Down, and Front-Back. When 
a joint property can utilize Falloff Zones, the Joint Editor displays a 
Falloff Zones area that appears as shown in the following figure.

Figure 29.24

Adding a Falloff Zone

To create a falloff zone:

Select the joint that you want to work on.1.	

Open the Joint Editor, and select the appropriate rotation 2.	
(Side-Side, Front-Back, Up-Down, or other).

In the Falloff Zones section, click the 3.	 + (plus) sign to create a 
new falloff zone. Choose one of the following options:

Add Sphere Zone�� : Choose this option to create a 
spherical falloff zone.

Add Capsule Zone�� : Choose this option to create a 
capsule-shaped falloff zone.

Cancel�� : Choose this option to return to the Poser 
workspace without creating a new falloff zone.

Use the Editing Tools or the parameter dials to adjust the scale, 4.	
rotation, and translation of the inner and outer MatSpheres 
(see Spherical Falloff Zones on page 509) or MatCapsules (see 
Capsule Falloff Zones on page 510).

Repeat steps 1-4 to add additional falloff zones if desired.5.	

Blending Multiple Falloff Zones

In addition to offering two types of falloff zones, Poser 8 also allows 
you to use more than one falloff zone for a joint. The Joint Editor 
now provides a drop-down menu that lists the falloff zones that 
have been created for each joint. You can add one or more spherical 
or capsule falloff zones to any joint. 

For an example of using multiple falloff zones, add the Poser 8 male 
or female to your scene (Ryan or Allison), and in the Joint Editor, 
select the Side-Side property of the right or left Buttock. Click the 
Down arrow to display the list of zones for the currently selected 
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joint. When you expand the list of falloff zones, you’ll see several as 
shown below.

Figure 29.25

NOTE: The CR2 will display a list of zones that affect each 
joint. Figures that use multiple falloff zones or capsule zones 
will not be compatible with older versions of Poser. To create 
a figure that is backwards compatible with earlier versions of 
Poser, use only a single Spherical Zone on the joints that use 
falloff zones.

To change the blending method for a falloff zone, follow these 
steps:

Select the joint that you want to modify.1.	

Expand the Falloff Zones selection menu, and select the 2.	
sphere or capsule falloff zone that you want to change.

Select 3.	 Multiply or Add from the blend mode selection menu. 

Figure 29.26

Deleting a Falloff Zone

To delete a falloff zone, follow these steps:

Select the joint that you want to modify.1.	

Expand the Falloff Zones selection menu, and select the 2.	
sphere or capsule falloff zone that you want to delete.

Click the3.	  - (minus) icon in the Falloff Zones area of the Joint 
Editor.

Enabling or Disabling a Falloff Zone

When a joint rotation uses multiple falloff zones, you can enable 
or disable the influence of a specific falloff zone to determine 
how that particular falloff zone affects the joint rotation. This can 
help you make adjustments to the areas that are affected by the 
selected falloff zone. 

To enable or disable a falloff zone:
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Select the joint that you want to examine, and rotate the joint 1.	
as necessary to determine the effects of the falloff zones.

Expand the Falloff Zones selection menu, and select the 2.	
desired sphere or capsule falloff zone.

Click the checkbox next to the falloff zone name. The falloff 3.	
zone is enabled when the box is checked, and disabled when 
the box is unchecked. 

Figure 29.27: Falloff zone enabled (left) and disabled (right)

Changing Falloff Zone Display Mode

The default display mode for spherical and capsule falloff zones 
is Outline mode. However, you can display falloff zones in any 
available mode. To change how a falloff zone is displayed:

Select the falloff zone that you want to change.1.	

Select 2.	 Display > Element Style.

Select your desired display mode. For example, Wireframe 3.	
mode allows you to see the spheres’ areas of effect while still 
being able to see the underlying bones/geometry. Wireframe 
modes are recommended, as solid shaded modes will make it 
difficult to pick underlying Fall Zone geometries.



Poser 8
Reference Manual

515

Chapter 29: Figure and Prop Editors

Figure 29.28

Rotation Orders
The Joint Editor palette includes the Joint Order pull-down 
menu that defines the joint’s axes of rotation. The joint order is 
expressed as three letters corresponding to the X, Y, and Z axes.

Figure 29.29

Using the Front camera position, the X axis runs from left 
to right, the Y axis runs from bottom to top, and the Z axis 
runs from the back to the front. This is called a right-handed 
coordinate system.

Determining the best rotation order for each joint is an important 
part of getting your figure to move exactly how you want it to. 
When you create new bones with the bone tool, Poser takes its 
best guess at determining the best rotation order for the bone. You 
can select rotation orders by bringing up the Joint Editor palette 
and selecting the desired order from the Joint Order pull-down 
menu.

If you change joint order, you will probably need to 
readjust the joint zones on the currently selected bone.
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Each joint consists of three separate joint primitives, one twist and 
two joints. The twist primitive is always placed first in the joint 
order. Because of ordered rotation problems, it is then best to place 
the rotation axis through which the joint is most likely to move last 
in the order, with the remaining rotation axis placed in the middle. 
For example, a shin is vertical and twists about the Y-axis. When 
the shin bends, it is most likely to bend around the X-axis. Thus, the 
best rotation joint order for the shin is YZX.

This may seem a little confusing at first. A good way to 
visualize the correct rotation order is to picture the figure 
facing directly towards the front of the Poser workspace. For 
each possible motion of a given joint imagine a line running 
through the center of the joint. For example, the shin twists 
along a line running straight up and down and rotates along a 
line running from left to right. The vertical line corresponds to 
the Y axis, and the left-to-right line corresponds to the X axis. 
It is now easy to determine the proper joint order of YZX based 
on this visualization and the requirements outlined above.

You can also use curve bends instead of the normal twist/joint/joint 
bends. When you set up a joint using curves, the joint will have one 
twist and one curve primitive. The curve primitive will automatically 
bend the body part as if that part were part of a curved chain of 
objects. This feature is very handy for body parts such as tails or 
antennae.

Copying and Saving Joint Settings
To copy joint settings from one side of your figure to the other, use 
symmetry as described in Symmetry on page 155. This saves time 
for figure creators by allowing them to rig only one side and then 
duplicate the zone settings to the opposite side.

To save your Joint Editor palette settings, you must either save 
your scene or save the affected figure to the Library palette. 
Please refer to Saving a Scene on page 49 for information on 
saving Poser scenes, and to Chapter 2: Installing Poser on page 11 
for information on working with the Library palette.



Poser 8
Reference Manual

517

﻿

Part 7: 
PoserPython



Poser 8
Reference Manual 

518

Chapter 30: About PoserPython

Chapter 30: About 
PoserPython
This section explains a few Python basics and lists each of the 
customized PoserPython methods, including explaining functionality 
and providing syntax and use examples. It provides a certain level 
of background and behind-the-scenes explanations that will put 
the PoserPython types and methods involved into context.

Note that this chapter assumes that you have at least a basic level 
of understanding about the Python scripting language. While it 
does explain a few basic Python concepts in order to add clarity 
and context, this chapter is not intended to teach you Python. 
There are numerous excellent sources of information for learning 
Python, many of which are available for free. Please refer to Other 
Important Resources on page 8 for a listing of some recommended 
Python resources. 

Python (named after Monty Python’s Flying Circus) is a high-level, 
interpreted, object-oriented scripting language first developed in 
1989 by Mr. Guido van Rossum and first released as free software 
in 1991 after extensive testing. It is an extremely powerful and 
easy-to-learn language that runs on virtually all platforms and 
that can be extensively customized and modified to run with other 
applications (such as Poser) and programming languages. Because 
it is free software, Python is freely usable and can be distributed 

free of charge. Python’s inclusion of a number of high-level data 
types as well as dynamic typing makes it easy for users to get their 
job done without the implementation hassle common to lower-
level languages.

PoserPython is a customized implementation of the Python 
interpreter that includes many commands not found in the 
standard Python releases. This customization integrates Python 
with Poser and provides you with an extensive list of easy-to-use 
commands that can greatly reduce the time you spend performing 
repetitive tasks in Poser.

One of PoserPython’s best features is that you do not need to 
be a programmer to begin enjoying its benefits. Poser includes a 
number of useful sample scripts that can be executed by clicking 
a button. You never have to see a line of code, and none of your 
friends will ever label you as a programmer! That said, another of 
PoserPython’s best features is that you can “get under the hood” 
to write scripts that will do just about anything. PoserPython gives 
you virtually full control over your Poser documents including 
figures, props, lights, cameras, scenes, etc. and their building blocks 
and parameters. As you can see, PoserPython benefits both novice 
and expert alike!

PoserPython also includes the Numerical Python extension, which 
loads automatically when Poser starts up. Many geometry methods 
use this extension for fast manipulation of vertex, set, and polygon 
information. Please refer to http://www.python.org/topics/scicomp/
numpy.html for more information.

http://www.python.org/topics/scicomp/numpy.html
http://www.python.org/topics/scicomp/numpy.html
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Why Python?
Adding support for a scripting language to Poser gives users 
unprecedented power and flexibility to automate and customize 
their Poser experience and liberate creativity and productivity. The 
combination of simplicity, power, extensibility, and free distribution 
rights is making Python an increasingly popular programming 
language and has made it the obvious choice for integration with 
Poser. The PoserPython additions provide advanced Poser users 
with virtually infinite control and flexibility: A few lines of Python 
code can quickly automate processes that might take hours if 
done manually. And, with Poser’s internal structures exposed in 
the Python environment, you can write importers or exporters that 
interact with obscure or proprietary data formats. Because Python 
runs entirely within Poser, the only external application you’ll need 
for creating Python scripts is your favorite text editor.

A Word of Warning
Unlimited control is a double-edged sword. On one hand, users 
have direct access to their creations and underlying data. On 
the other hand, it is impossible to anticipate every conceivable 
PoserPython script. Because of the inherent power that scripting 
provides, it is possible to accidentally or intentionally destroy data, 
possibly beyond Poser itself. We at Smith Micro Software have made 
every attempt to provide “safe” methods for manipulating Poser 

internals, and in most cases a Python mistake simply means that 
the interpreter throws an exception and halts the script execution. 
Nevertheless, Python is an entire programming language designed 
with far more than Poser in mind. It is a powerful tool and, like all 
tools, should be used with care. If you are not familiar with Python 
basics, we strongly recommend that you obtain training and begin 
your Python experience slowly and carefully so as to enjoy a smooth 
and trouble free learning curve.

PoserPython Types & Methods 
Listing
PoserPython consists of hundreds of custom methods, and Smith 
Micro Software is continually updating the list of available methods. 
Please refer to the PoserPython Methods Manual, which contains 
an organized listing of each PoserPython method available in Poser. 
It is included in PDF format on your Poser CD and is also accessible 
from within Poser by selecting  Help > PoserPython Manual.
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Chapter 31: Running 
PoserPython Scripts
Poser includes a simple graphical user interface that allows you 
to execute Python scripts by pressing a button. You can customize 
the Python Scripts palette and, in addition, you can run Python 
scripts directly.

The Scripts Menu
The Scripts menu provides a hierarchical list of PoserPython scripts 
available for use within Poser. When you first launch Poser, this 
menu will list all of the PoserPython scripts that were included with 
your Poser installation. You have the option of placing additional 
Python scripts into the :Runtime:Python:PoserScripts: 
ScriptsMenu directory within your Poser installation; all scripts 
placed into this folder will be accessible within Poser from the 
Scripts menu.

The Python Scripts Palette
Launch the Python Scripts palette within Poser by selecting 
Window > Python Scripts.

Figure 31.1

Clicking some of the buttons will display a submenu 
of buttons within the Python Scripts palette. This is just one 
example of how Python scripts can be used to customize 
Poser. You can write scripts that will open button menus and 
submenus. If you are curious, you can open one of the existing 
submenu scripts to see how this is done.
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Using the Script Buttons
To run a script, simply press the desired button and the script will 
execute automatically.

Assigning Buttons Within the 
Console
Unassigned buttons do not have a label. An ellipsis (...) appears 
in unassigned buttons to mark their availability. To assign a script 
to a button, simply press the mouse on the button and locate the 
desired script (.py file) using the standard operating system file 
picker. Once you have located the desired script, select it and press 
Open.

Editing Scripts Within the Console
You can edit scripts assigned to a Poser Python Scripts palette 
button by pressing and holding [CTRL] while clicking the button 
assigned to the script you wish to edit. This opens the script within 
your operating system’s default text editor for easy modification. 
Save your changes as appropriate for the editor you are using. You 
may also select your own editor via the General Preferences 
dialog, which can be obtained by choosing Edit > General 
Preferences as described in Setting Application Preferences on 
page 26﻿.

Unassigning/Reassigning Buttons 
Within the Console
To reassign a button to a different Python script, you must first 
delete its current assignment and then assign the new script to 
it. Do this by pressing and holding [OPT]/[ALT] while clicking the 
button you wish to unassign. If you wish to assign the newly freed 
up button to a different script, do so as outlined above.

Running Python Scripts Directly
The Poser Python Scripts palette keeps your frequently used 
scripts close by for easy use. However, you can run any script you 
wish by selecting File > Run Python Script to open the standard 
operating system navigation dialog. Locate the script you wish to 
run by browsing your folders and directories, then press Open to 
run the script.

Alternately, you can access your script directly from the Poser 
Scripts menu. 
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Appendix A: Technical 
Support
We’ve worked hard to ensure that Poser’s powerful features are 
both easy to use and available to users running a wide variety of 
computers. However, there may be times when you need technical 
support. Smith Micro Software is pleased to offer free technical 
support to registered users of our products. To receive technical 
support, please visit our Web site at http://my.smithmicro.com/
support and browse through our extensive product FAQs.

Please use the following checklist before contacting Technical 
Support:

Poser Reference Manual•	 : This Reference Manual 
answers most Poser questions. Before contacting Technical 
Support, please read the pertinent section(s) of this manual 
thoroughly.

FAQ•	 : Please visit the product FAQs at the above-listed URL.

Poser Tutorial Manual•	 : This Tutorial Manual provides 
step-by-step instructions for basic and advanced tasks with 
Poser. If you have a “How do I...?” type question, you may 
find the answer here.

Third-party forums•	 : If your question is more artistic than 
technical, check out some of the great online Poser forums 
where artists come together. Please see Third-Party Forums on 
page 8 for links to a few online forums.

Still don’t see your question answered? Please contact Technical 
Support by clicking the link to http://support.smithmicro.com and 
completing our online support form. When contacting Technical 
Support, please fill out the form as completely as possible and 
include as much information as possible. This will help us resolve 
your issue faster. Once the form is complete, a Technical Support 
representative will contact you directly as soon as possible. Support 
requests are answered via e-mail in the order they are received. 
Online support is free to all registered Poser users. Poser users are 
strongly encouraged to register after installing the application on 
http://my.smithmicro.com/register.

Telephone support is also free to registered users. Before using 
telephone support, please check the resources listed above. 
Phone support is intended to solve critical technical issues. We are 
unable to answer project-based questions. Our Technical Support 
phone number is listed on our website at http://smithmicro.com/
contact. Telephone support hours are 10 am to 4 PM (U.S. Pacific 
time). If you call during other hours, or if a representative is not 
able to answer your call immediately, you will be asked to leave a 
message, and we will return your call as soon as possible (generally 
within two business days). When calling, please be in front of your 
computer with Poser running.

http://my.smithmicro.com/support
http://my.smithmicro.com/support
http://supphttp://support.smithmicro.comort.smithmicro.com
http://my.smithmicro.com/register
http://smithmicro.com/contact
http://smithmicro.com/contact
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In order to receive support, we require the following information:

Your name•	

E-mail address•	

Telephone number (including international dialing information, •	
if applicable)

Your current operating system•	

Your computer specifications (CPU, RAM, hard drive, video •	
card, etc.)

Poser serial number•	

Detailed description of the problem•	

This information will help us isolate and resolve your issue. We 
require this information in order to provide support services and are 
unable to respond to incomplete requests in a timely fashion.

For international support, please contact your local distributor. 
Smith Micro Software maintains a list of our international 
distributors at 

http://my.smithmicro.com/store/intlpartners.html.

Smith Micro Software reserves the right to alter our 
technical support policies at any time without advance notice.

http://my.smithmicro.com/store/intlpartners.html
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Appendix B: Poser File 
Structure
This Appendix describes some basics about the Poser file system.

About Poser Files
Some advanced Poser users obtain added control over their work 
by editing the source files directly instead of, or in addition to, using 
the Poser application. This manual provides a detailed description 
of the Poser file formats, including syntax, layout, and commands/ 
parameters contained within each file type.

Poser uses separate files for each character, prop, light, and camera, 
as well as other files for particular character details (face, hands, 
etc.). These files typically reside in Poser’s Runtime folder. The 
Poser installer automatically creates folders and inserts files into 
their correct locations. While each type of Poser file has a separate 
extension and purpose, each of the file types discussed in this 
manual (with the exception of OBJ and non-native Poser formats) 
follows the same general format and uses one or more subsets of 
the overall Poser command/parameter structure.

Please refer to the Poser end user license agreement 
(eula) in part 1 of this manual for information regarding the 

legal uses of the Poser file formats and structures.

A Word of Warning
Editing files directly can give you ultimate control over your Poser 
creations and help provide spectacular results. However, editing 
files directly could cause problems up to and including crashing 
the Poser application file, corrupting your edited file, and causing 
data loss.

Smith Micro Software provides this information as an aid to 
advanced Poser users for reference purposes only. Direct editing of 
Poser files is specifically not recommended and is not supported. 
Please do not contact Smith Micro Software tech support regarding 
file-editing problems. Any work you do within Poser files is done 
solely at your own risk. You are on your own.

This appendix provides some guidance with regard to valid values 
and error handling, however it is impossible to cover the nearly 
infinite ways in which you may edit files and how those edits may 
affect the Poser application or data.

Editing Files
You can edit all native Poser files using a plain text editor such as 
Notepad (Windows) or Simpletext (Macintosh). In addition, some 
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users have created helpful applications to aid you in editing Poser 
data. Please refer to the online 3D community at large for help 
locating and reviewing these third-party applications.

Poser files contain formalized descriptions and instructions written 
in a code that Poser can read. As with any computer program, each 
element of a Poser file must be in the correct format, using valid 
values, and located in the correct portion of the file. Poser files can 
be large and complex, and it is not advisable to modify them unless 
you have a good idea how to go about it.

All native Poser files follow a similar structure, however each 
file type has a separate filename extension and library location 
(discussed below). The simplest Poser files control props, lights, and 
cameras, while the most complex (CR2 and PZ3) describe Poser 
characters and scenes, respectively.

It should rarely be necessary to modify native Poser files outside of 
Poser, with the notable exception of CR2 files. When editing any 
Poser files, be sure to back up the original file and work on a copy. 
This will prevent data loss if something goes wrong. You may also 
wish to save iterations of files as you work, allowing you to easily 
revert to a previous state without losing all of your work.

Poser File Types
There are nine native file types associated with Poser:

Prop•	 : This file type contains information about a prop 
including source geometry, materials, texture and other maps, 
etc. Prop files have the extension PP2. Magnet files are prop 
files with a pre-positioned magnet as the prop. Props are often 
supplied as PP2 files with embedded OBJ information. They 
may also include texture and bump map files. 

Camera•	 : Camera files contain camera information including 
location, direction, focal length, etc. They have the extension 
CM2.

Light•	 : These files contain information on lights, including 
type, position, color, and other attributes. Light files have the 
extension LT2.

Hair•	 : Hair files contain information on hair props and are 
similar to prop files. This file type has the extension HR2. 
Hair files may have the geometry embedded within them (as 
opposed to in a separate OBJ file).   

Face•	 : Face files contain information required to articulate 
and/or deform a face to the desired expression and have the 
extension FC2.

Hands•	 : Like face files, hand files contain information required 
to articulate hands into the desired positions or gestures. Hand 
files have the extension HD2.

Pose•	 : Pose files contain information required to articulate an 
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entire figure into the desired position, which can include face 
and hand information. Pose files have the extension PZ2.

Character•	 : A character file contains all information required 
for a Poser character including reference geometry, Joint Editor 
palette morph targets, materials, default pose, etc. These files 
have the extension CR2.

Scene•	 : This file type is what is created when you create a 
Poser scene and select File > Save within the Poser animation. 
This file type contains all of the information found in the 
above-mention files plus details on movie, background, 
rendering, animation set, lights, cameras, figures, and other 
information. Poser scene files have the extension PZ3. They are 
similar in structure to CR2 files.

Material Collections•	 : A Material Collection is a fully 
integrated file format, which stores groups of materials from 
a single figure for access through the Library palette. Material 
Collection files have the extension MC6/MCZ.

External Binary Morph Targets•	 : Poser saves morph 
targets to an external binary file format, which contains only 
the morph targets for a particular figure or scene. These files 
have the extension PMD.

File Hierarchy
For purely conceptual purposes, it is useful to think of various 
Poser file formats as falling into a loose hierarchy, with some files 
containing subsets of information stored within other file types. 
Also, while each Poser file type contains information unique to 
that format, several file types are virtually identical in structure. For 
example, hand and face information is part of a pose, which along 
with hair forms part of a character, which combined with other 
information is part of a scene.

File Families 
It is also useful to think of Poser files in terms of the types of 
information they contain. For conceptual purposes only, you can 
think of Poser files as being grouped into the following families:

Face, Hands, Pose•	

Hair, Prop•	

Camera, Light•	

Character•	

Pose•	
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Poser Default File Locations
In the list below, note that the following list provides the default 
locations of the Poser file types. If you are downloading any Poser 
files, be sure to place them in their correct locations. File placement 
is most critical for files that belong in the Runtime: Geometries 
folder. Library files have more flexibility. In the following list, an 
expression in parentheses means that the subdirectory or name 
depends upon the figure. You may create your own subfolders 
and relocate files within the Libraries subfolder. In this case, file 
locations will be reflected in Poser’s Library palette. You may place 
graphic (texture, bump, etc.) files wherever you like, since Poser 
allows you to specify their locations. The following list gives all file 
locations relative to the Poser: Runtime folder:

•	 OBJ (figure geometry): Geometries\(figure name) 

•	 RSR (small file, Windows-only thumbnail 
graphic): libraries\character\ (category)\(character name) 

RSR (large file, both Mac and Windows – Binary •	
OBJ): Same location as associated geometry file 

•	 PZ3 (Poser scene): any (user-selected location) 

•	 CM2 (Camera): libraries\camera\Camera Sets 

•	 CR2 (Character): libraries\character\(category)\(character 

name) 

•	 FC2 (Face): libraries\faces\(category) 

•	 HR2 (Hair): libraries\hair\(category) 

•	 HD2 (Hand): libraries\hand\(category) 

•	 LT2 (Light): libraries\light\Light Sets 

•	 PZ2 (Pose): libraries\pose\(category) 

•	 PP2 (Prop): libraries\props\(category)

•	 MT5 (Shader): libraries\material\(category)

TIF, BMP, BUM, JPG (textures, bump maps, etc.)•	 : 
textures\ (category)\(subcategory). You may store additional 
images in any folder you wish.

•	 PZS (Web links): Web links\(category)

•	 MC6/MCZ (Material Collections): libraries\material\
(category)

•	 PMD (Morph Targets): PMD files are binary morph target 
files that are a redistributable means to deliver morph targets. 
If you have Use External Binary Morph Targets enabled in 
the Misc tab of the General Preferences dialog, PMD files are 
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created next to a CR2 (when a figure is added to the Library), 
next to a PP2 (when a prop is added), or next to a PZ3 (when 
a scene file with morph targets was created in an earlier 
version of Poser, or when the morph set of figures and/or 
props has been changed since they were added to the scene).

 Users who download characters or other Poser files 
may need to manually place some or all of the files in their 
correct locations. Please use the above list to ensure correct 
file placement.

 Poser stores files containing preference information in 
the user’s home directory on the system drive. This preference 
information includes: Memory dots, Library preferences, 
Poser UI preferences, and the Poser.ini file. On Windows, 
these preference files are stored in the following location: 
<DriveOnWhichWindowsIsInstalled>:\Documents and 
Settings\<UserName>\Application Data\Poser\. On 
Macintosh OS X, they are stored in the following location: /
Users/<UserName>/Library/Preferences/Poser/.

Poser Downloaded File Locations
By default, Poser places downloaded content (obtained using the 
Content room) in the Download library. Please refer to Chapter 
7: The Poser Library on page 89 for more information about Poser 

libraries.

Other Poser File Types
Some users may encounter PHI and PCF files. Previous versions of 
Poser used PHI to perform functions that are now carried out in 
the hierarchy editor/Setup room (Pro Pack & later). PHI files were 
directly contained within OBJ files, and were located with the OBJ 
file. PCF files are used by an application called Objaction Mover 
and are beyond the scope of this document.

Commonly Used Poser Objects
Morph targets and characters are commonly used and traded/sold 
by and among users and third-party vendors. This section provides 
a brief explanation of each.

Morph Targets
Morph targets are supplied as OBJ files that you import into Poser 
for application to part of a figure. The figure’s CR2 file controls 
morph targets, and a dial appears for each morph target when an 
applicable body part is selected. For example, a head morph target 
dial will appear when you select the figure’s head. This Reference 
Manual defines and discusses OBJ morph targets in Creating 
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Morphs in Other Applications on page 468.

Characters & Clothing
Characters can be modifications of meshes that come with Poser 
or can include entirely new OBJ meshes (models). Characters based 
on pre-existing meshes typically come as CR2, texture, and bump 
files. Also, each piece of conforming clothing uses CR2 files to make 
it poseable, making clothing downloads similar to characters; thus, 
the download is similar to that of a character.

Basic File Syntax
As you will see by examining this document, each Poser file type 
uses the same general syntax.

Tabs
Tabs within Poser files are mostly insignificant, however they serve 
to show file structure, such as:

section 1
		  child 1
			   grandchild
			   grandchild n
		  child n
section n

Brackets & File Sections
Each Poser file opens and closes with brackets ({}), as does each 
section within a Poser file. Major file sections describe the file 
version, location and name of the underlying OBJ file (if any), and 
file properties. One of the major file sections (Channels) contains 
position, size, texture, morph target, and other properties. Poser 
automatically modifies values and adds entries as needed. 

As described above, brackets denote the beginning and end of file 
sections. A left bracket begins each section, while a right bracket 
ends a section:

{begins
} ends

For example,
{
section A
}

Nested Brackets

As implied above, one can nest file sections using brackets to 
denote each section and subsection, as follows:

{
section A
	 {
	 section B
	 }
}
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Parameters
Parameters and other items within a section do not need brackets. 
For example:

{
section A
	 parameter 1
	 parameter n
	 {
	 section B
command 1
		  parameter 1
		  parameter n
	 command 2
		  parameter 1
		  parameter n
	 }
}

Comments

You can insert comments into Poser files, as follows:
{
number 4.01
This text is a comment added to the CR2 file.
}

Poser & OBJ Files
The Geometries folder contains several dozen subfolders with 
names corresponding to Poser figures. Each of these subfolders 

contains OBJ files, each of which is a mesh object, e.g. a set of 
polygons arranged so as to form the desired shape. These polygons 
are placed into different groups that define important subdivisions 
within the mesh (such as body parts, also known as actors). In 
order to work with Poser, these groups must have specific names, 
such as hip, abdomen, etc. Poser groups do not require such 
specific naming conventions; figures created using the Setup room 
could have groups named, for example, Bone_1. 

The OBJ file itself does not contain enough information to allow 
Poser to produce all of the mesh object’s properties, hence 
the presence of CR2 and other files that provide supplemental 
information. Poser files can contain embedded information that 
would normally reside within the OBJ file. This is why many prop 
downloads do not include an OBJ file.

Some native Poser files normally refer to an underlying OBJ 
geometry file, which is also in text format. Native Poser files 
describe parameters controllable within Poser, such as size, 
position, textures, etc. One OBJ file can have more than one Poser 
file pointing to it. This happens, for example, if a modified prop, 
character, etc. is saved to the Library under a different name and/
or location.

Character (CR2) files contain Poser-specific details such as size, 
position, pose, textures, proportions, etc. and also control the dials 
that change the figure. Normally, one CR2 file governs a single 
figure. By combining the OBJ mesh information with the CR2 
details, Poser can create customized poseable figures.
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Some Poser files (pose, face, hands, etc.) work by modifying the 
CR2 itself. Poses, faces, and hands are already described within the 
CR2, however applying the data contained in one of these files 
changes the corresponding values within the CR2 file itself. These 
applied CR2 changes are then saved to the Poser scene (PZ3) file. 
If the user saves the modified character in the Library, the modified 
information gets written to a new CR2 file.

PZ3 files are similar enough to CR2 files to allow changing a PZ3 
extension for a given scene file to CR2, thereby creating a new 
character complete with its associated props, hair, etc.

Dependent Parameters
With Poser you can set up meta-level parameters, called dependent 
parameters, which allow you to modify other parameters and morph 
targets with a single parameter dial. An example of this type of 
dependent parameter would be a full range of belly types, with the 
following values along the dependent parameter dial:

The new Dependent Parameters editor in Poser 8 can help you 
do this and more. Refer to Using Dependent Parameters on 
page 471 for additional information about this feature.

-1.0 underweight belly•	

-0.5 sixpack belly•	

0.0 regular belly mesh•	

0.5 slightly protruding belly•	

1.0 large protruding belly•	

2.0 hanging beer belly•	

This range of belly types would incorporate various morph 
targets and parameter values at each of the key points along the 
dependent parameter dial. Thus, dependent parameters are far 
more powerful in the scope of modifications they can encompass 
than a single morph target or parameter dial.

The following sample code illustrates how to set up a dependent 
parameter. This code is an example of a targetGeom channel in a 
CR2 file. The resulting dependent parameter will appear as a morph 
target parameter dial named “bump3”.

targetGeom bump3
{
name bump3
    initValue 0
    hidden 0
    forceLimits 1
    min -100000
    max 100000
    trackingScale 0.02
    keys
    {
    static 0
        k 0 0
    }
    interpStyleLocked 0
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    numbDeltas 261
    useBinaryMorph 1
    blendType 0
    valueOpKey
        Figure 1
        bone_1:1
        Custom_Morph
        beginValueKeys
            valueKey 0.5 0
            valueKey 0.75 1
            valueKey 1 0
        endValueKeys
}

The end of this sample defines some interesting interactions with 
regards to the “bump3” dependent parameter. The “valueOpKey” 
keyword identifies a section that defines that this parameter can 
be driven by the Custom_Morph dial on the bone_1 actor of the 
specified figure. The “ValueKeys” section defines how exactly the 
“bump3” dependent parameter will be affected: 

If Custom_Morph equals 0.5, the value of bump3 will increase •	
by 0. 

Once Custom_Morph reaches 0.75, the value of bump3 will •	
increase by 1. 

By the time Custom_Morph equals 1, the value of bump3 will •	
increase by 0 again. 

Values in between these points are determined by spline 
interpolation.

In the next example, we are looking at the rotateX parameter of an 
actor (in this case bone_2:1, which is not apparent from the code 
sample below). The resulting dependent parameter dial is called 
“xRotate”.

rotateX xRotate
{
name xrot
    initValue 0
    hidden 0
    forceLimits 0
    min -100000
    max 100000
    trackingScale 1
    keys
{
static 0
    k 0 0
}
interpStyleLocked 0 
valueOpKey
    Figure 1
    bone_1:1
    Custom_Morph
    beginValueKeys
        valueKey 0.25 0
        valueKey 0.75 45
        valueKey 1 0
        valueKey 1.25 -45
        valueKey 1.5 0
    endValueKeys
}

As in the previous example, the “valueOpKey” section defines that 
the Custom_Morph parameter dial on bone_1:1 of the specified 
figure can take control of this parameter. The “valueKey” value 
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pairs add rotation in degrees of xRotate to certain values of the 
Custom_Morph parameter.
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3D Motion Blur  296
3D Mouse  28
3D Objects

Exporting  55
Importing  52

A

Adaption Threshold 
Adaptive Bucket Size 
Add Reflection  217
Add Refraction  218
Add Subsurface Scattering  218
Ambient  210
Ambient Occlusion  220

and Lights  196
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Posing heads  150
Animation

Frame Rate  318
Overview  311

Retiming  309
Saving  350
Skipping frames  310
Tools  313

Animation Controls  45, 47, 313, 314
Animation Layers  318

Adding poses with  104
Base layer  332
Controls  332
Creating  332
Deleting  332
Poses with  387
Previewing  332

Animation Menu Commands
Clear Sound  310
Loop Interpolation  309
Make Movie  309, 351
Mute Sound  310
Play Movie File  310
Quaternion Interpolation  310
Resample Key Frames  309, 330
Retime Animation  309, 329
Skip Frames  310

Animation Palette  45, 313, 317
Layers tab  331
Options menu  319

Animation Sets  334
Applying to Figures  336

Creating  335
Setting attributes  335

Antialias Document  277
Area Render  67, 277
Atmosphere  219
Attenuation  197
Auto Balance  153
Auto Grouping  491
AVI

Rendering options  353
AVI files  351

B

Backfacing polygons  295
Background

Pasting onto  84
Background color  73, 294
Background Footage

Clearing  85
Showing  85

Background Pictures  294
Clearing  84
Importing  51
Showing  84

Background shader  295
Base Layer  332
Bend  137, 143
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Body Parts
Bending  83
Posing  127
Properties  136
Selecting  127

Bones
Assigning names to polygons  437
Attaching to geometry  437
Deleting  434
Inserting  434
Naming  437
Positioning  434
Symmetry  436

Bone structure
About  431
Creating  432
Selecting  433

Bump  211
BVH  348

Exporting  55

C

Camera Controls  39, 46, 174
Camera Parameters

Depth of Field  180
Focal  180
Focus Distance  180

F-Stop  181
Hither  182
Perspective  180
Pitch  183
Roll  183
Shutter Close  182
Shutter Open  182
XYZ Dolly  182
XYZ Orbit  183
XYZ Scale  183
Yaw  183
Yon  182

Camera Plane  176
Camera Properties

Animating  179
Name  179
Visible  179

Cameras  110
Auxiliary  171
Camera dots  185
Changing  69, 174
Creating  178
Dolly  173
Face  172
Flyaround  175
Focal Length control  177
Left Hand  172
Locking  185

Main  171
Mini Camera Controls  68
Orthographic  173
Pointing  184
Posing  171
Positioning  176
Right Hand  172
Roll control  177
Rotation trackball  176
Saving camera sets  185
Scale control  177

Camera views
and posing  123

Capsule falloff zones  510
Cartoon  79
Cartoon Tones  88
Cartoon With Line  80
Cast shadows  137
Center of Mass  153
Chain Break Tool  132
Changing figures

With replaced geometry  166
Clothing  160

Conforming  160
Conforming vs Dynamic  387
Dynamic  160
Fixing pokethrough  100

Cloth Room  386
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Air damping  401
Calculate simulation  399
Choreographed cloth groups  395, 397
Clear simulation  399
Cloth controls  390
Cloth decorations  396
Cloth density  400
Cloth draping  390
Cloth dynamics controls  398
Cloth groups  394
Clothifying objects  391
Cloth parameters  401
Cloth self-friction  400
Cloth simulators  388
Collision depth  393, 394
Collision friction  401
Collision objects  391
Collision offset  392, 394
Collision options  389
Constrained cloth groups  395
Constrained group  397
Creating morphs with  401
Creating props with  401
Delete dynamic group  397
Delete simulation  390
Displaying tools  48
Draping from zero pose  393
Dynamic cloth groups  395, 397

Dynamic friction  393, 400
Figure collision options  393
Fold resistance  400
Ignoring feet collisions  394
Ignoring hand collisions  394
Ignoring head collisions  394
New dynamic group  396
Play simulation  399
Reset  401
Rigid decorative cloth groups  397
Shear resistance  400
Simulation name  389
Simulation range  389
Simulation settings  390
Soft Decorative cloth groups  397
Static friction  393, 400
Stretch damping  400
Stretch resistance  400

CM2  528
Collision detection  , 137
Collisions  63
Colors  72
Color Tool  133
Compressed Files  49
Conforming Clothing  160

Adding from Library  99
Adding to figure  161
Using without a figure  388

Content
Downloading  121
Installing  121
Loading  94
Managing  94
Online  6

Content Collections  118
Content Paradise  120
Content Room  120

Converting clothing. See Wardrobe Wizard
Copy  58
CR2  528
Crease angles  138, 299
Create Atmosphere  219
Current Actor Menu  65, 139
Cut  58

D

Deformers
Showing and hiding  82
Using  444
Using with grouped objects  458

Delete Figure  156
Deleting objects  140
Dependent Parameter Editor

Graph  475
Dependent Parameters  471, 531
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Dials  141
Driven value  480
Natural value  480
Teaching  481

Depth Cueing  71, 82
Depth Map Shadows  195
Depth of Field  180, 296
Dial Groups  140
Dialogs

Quick Start 
Diffuse Color  208
Direct Manipulation Tool  134
Displacement Bounds  136, 137
Displacement maps  295
Display Controls  41, 77

Document  77
Element  77
Figure  77

Display Menu Commands
Background Color  84
Bend Body Parts  83, 137, 382
Camera View  170, 174
Clear Background Footage  85
Clear Background Picture  84
Deformers  83

Hide All  83
Show All  83
Show Current Selection Only  83

Depth Cued  82
Document Style  81
Element Style  81, 82, 514
Figure Circle  83
Figure Style  81
Foreground Color  84
Ground Shadows  83
Guides  85
Paste onto Background  85
Production Frame  75, 81, 352
Show Background Footage  85
Show Background Picture  84
Show Camera Names  170
Tracking  82
Use Document Style  77
Use Figure Style  77

Display Units  28
Documentation  5
Document Style  81
Document Title  62
Document Window  40, 61

Options Menu  62
Preview tab  61
Size  64

Document Window Size  48
Double-click Behavior  29
Downloading content  121
Download Manager  116

Drop to Floor  155
Duplicate  59

Dynamic Clothing  160. See Cloth Room
Adding from library  387
Saving to Library Palette  401
Using without a figure  388

Dynamics
Recalculating  141, 309

E

Editing Tools  39, 47, 129
Edit Menu Commands

Copy  58
Copy Picture  59
Cut  58
General Preferences  26, 49, 300
Memorize  60, 140

Element  440
Figure  440, 441

Paste  58, 59, 329
Redo  58
Restore  59, 60

All  60
Camera  60
Element  59
Figure  59
Lights  60
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Undo  57, 58, 131, 364, 463
Elements List  327
Element Style  82
End User License Agreement  11
Exclusion angles  506
Exit  57
Exporting  55

3D Objects  55
BVH Motion Files  55
Flash Files  56
Images  55, 62
Painter Scripts  55
SWF Files  56

Eyedropper Tool  205

F

Face Parameters  146
Face Room  358

Adjusting points and lines  364
Applying Heads  371
Applying shape  365
Caricatures  369
Customizing textures  365
Displaying tools  48
Face Shaping tool  366
Photo Lineup  361
Saving faces  371

Selecting images  360
Textures and  370
Using images with  360
Using morphs with  370

Faces  104
Falloff zones  509

Adding  512
Blending  512
Capsule  510
Changing display mode  514
Creating  512
Deleting  513
Disabling  513
Enabling  513
Spherical  509

FastScatter  218
FC2  528
Figure Circle  83
Figure Height  152
Figure Hierarchy  494
Figure Menu Commands

Auto Balance  154
Conform To  100, 161
Create Full Body Morph  56, 471
Create Walk Path  340
Delete Figure  156
Drop to Floor  155
Figure Height  152

Genitalia  153
Hide Figure  156
Lock Figure  154
Lock Hand Parts  154
Set Figure Parent  167, 169, 499
Show All Figures  157
Symmetry  155
Use Inverse Kinematics  125, 500
Use Limits  126, 154

Figure Parameters  142
Figures  97

Assigning IK chains  439
Creating  429
Posing  127
Properties  135
Replacing  98
Showing all  157
Testing original  439
Visibility  135

Figure Style  81
File Compression  49

Using  31
File Menu Commands

Close  49
Convert Hier File  56
Exit  57
Export  55, 62

BVH Motion  55
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Image  55
Wavefront OBJ  56

Import  50, 53, 429
3D Studio  52
AVI Footage  50
Background Picture  51
BVH Motion  348
DXF  52
Lightwave  52
Lip Sync Audio  343, 344
Poser Document/Prop  51
QuickTime  50
Sound  343
Wavefront OBJ  52

New  48
Open  49
Page Setup  57
Print  57
Recent Files  49
Revert  49
Run Python Script  56, 521
Save  49
Save As  9, 49

File Search  29
FireFly  280

Saving render presets  298
Flash  351

Rendering options  355

Flash Files
Exporting  56

Flat Lined  79
Flat Shaded  79
Focus Distance  87, 180
Foreground Color  72, 84
Frame Indicator  314, 319
Frame Rate  318
Front-Back  143
F-Stop  181
Full Body Morphs

Analyzing  404
Creating  471

G

Genitalia  153
Geometry

Importing  431
Global Illumination  293
Graphs  45, 313, 322

Editing  323
Parameter dials  142
Using with Animation Palette  324

Ground Plane  85
Color of  73

Ground Shadows
Showing and hiding  83

Group Editor  487
Auto Grouping  491
Creating groups  492
Polygon mode  487
Using  488
Vertex mode  487
Welding groups  492

Grouping figures  438
Grouping Tool  133
Guides  85

H

Hair  105
Adding strand-based to library  384
Adding to scene  106
Colors  384
Materials  384
Prop hair  159
Strand-based  159

Hair Edit Tool  378
Hair Parameters  383
Hair Properties  382
Hair Room

Add hairs to selection  378
Air damping  381
Bend resistance  381
Calculate dynamics  381
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Clear selection  380
Clumpiness  377
Collisions  381
Constrain length  379
Curl hairs  379
Definining hair groups  373
Displaying tools  48
Falloff  380
Gravity  381
Growing hair  374
Hair density  377
Hair length  375
Kink delay  377
Kink scale  377
Kink strength  377
Lengthen  380
Length variance  375
Position force  381
Pull back  375
Pull down  375
Remove hairs from selection  379
Root stiffness  381
Root stiffness falloff  381
Root width  377
Scale hairs  379
Setting dynamics  380
Show populated  377
Spring damping  381

Spring strength  381
Style hairs  377
Styling hair  376
Tip width  377
Translate hairs  379
Translate In/Out  379
Twist  379
Verts per hair  377

Hand Models
Using  148

Hand Parameters
Grasp  148
IndexBend  148
PinkyBend  148
RingBend  148
Spread  148
Thumb  148
ThumbBend  148

Hands  107
Locking  154
Presets  149

HD2  528
HDR Images  285
Head Lengths  86
Help

Getting  7
Online Support  8
Other Resources  8

Reference Manuals  7
About  9

Smith Micro Sales  8
Technical Support  8
Third-Party Forums  8

Help Menu Commands
About Poser  7
Content Paradise  8
Other Web Links  8
PoserPython Manual  5, 7, 519
Poser Reference Manual  5, 7
Poser Tutorial Manual  5, 7
SmithMicro Web Links  8

Hidden Line  78
Hierarchy Editor  46, 493

Filtering display  496
Object relationships  498
Reordering scene elements  497
Rotation orders  499
Standard hierarchy  499
Using  495
Working with branches  497

Hier Files
Converting  56

Highlights  209
Hip-Shoulder Relationship  86
Hither  182
Horizon Line  86
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HR2  528

I

IBL  187, 220, 285

IK  124, 313. See IK
Enabling/Disabling  125
Understanding  125
Using  500

IK Angles
Setting and memorizing  440

IK Chains
Assigning  439
Creating  499

Images
Exporting  55, 62

Importing  50
3D Objects  52
Background Pictures  51
Movies  50
Poser Documents  51
Props  51

Options  53
Tips & Tricks  52

Importing Geometry  431
Inclusion angles  506
Indirect Light  290
Indirect Light quality  291

Infinite Lights  187
Indicators  192

Installing content  121
Installing Poser  11, 18

Upgrading from earlier version  22
Internal name  136
Interpolation

Loop  309
Quaternion  309

Interpolation Controls  325
Interpolation types  322
Irradiance caching  291

J

Joint Editor  46, 500
Using  501

Joint rotation orders  515
Joints

Bend  505
Center  502
Editing attributes  502
End zone  508
Exclusion angles  506
Falloff zones  509
Fine-tuning  439
Front to Back  505
Inclusion angles  506

Scaling  508
Setting limits  441
Side to Side  505
Teaching  474
Twist  503

Joint settings
Copying  516
Saving  516

K

Keyframe Controls  316, 321
Keyframes

Adding  328
and timing  349
Copying  329
Editing on timeline  327
Moving  329
Recording  315
Removing  328
Resampling  309, 330
Retiming  329
Selecting  328

Keyframes tab  320

L

Launch Behavior  26
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Library Palette  42, 89
Accessing different libraries  91
Adding actors  115
Adding dynamic cloth  402
Adding items  113
Adding items manually  116
Adding libraries  92
Adding Material collections  112
Adding materials  111
Adding strand-based hair  384
Categories Tab  42
Category icons  89
Conforming clothing  99
Content Collections  118
Creating subfolders  113
Deleting items  117
Displaying  91
Dynamic clothing  387
Favorites tab  43
Library tabs  89
Maintaining  113
Refreshing  97
Removing libraries  93
Search tab  43
Switching libraries  92
Using arrow keys with  97
Using Download Manager  116

Library Tab  42

Light Controls  38, 47, 191
Light Parameters  199

Angle End  200
Angle Start  200
Color  201
Distance End  200
Distance Start  200
Intensity  201
Scale  201
Shadow  200
XYZ Rotation  201
XYZ Translation  202

Light Properties
Advanced Materials  196
Ambient Occlusion  196
Animating  195
Atmosphere Strength  196
Attenuation  197
Color  196
Depth Map Shadows  195
Include in OpenGL Preview  195
LightType  195
On/Off  195
Raytrace Shadows  195
Set Parent  196
Shadow Blur Radius  195
Shadow Min Bias  196
Shadows  195

Visible  195
Lights  109

Adjusting  189
Aiming  190
Animating  202
Color  190
Creating  188
Deleting  190
Image Based Lights  187
Indicators  192
Infinite lights  187
Intensity  189
Light position control  191
Point lights  187
Properties  194
Saving and loading  202
Selecting  188
Spotlights  187

Light Style  220
Limiting Motion  126
Lit Wireframe  79
Load Morph Target  137
Looping  326
LT2  528

M

Macintosh
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Installation  21
Magnets  444

Base Properties  447
Creating  445
Locking  449
Object Parameters  446
Object Properties  446
Properties  446
Using Editing tools with  445
Zone Falloff Graph  448
Zone Properties  448

Master Parameters  473
Creating  139, 476
Editing  479
Indicator  141

Material Collections
Adding to library  112

Material Nodes
About  222

Material Room  204
Animating nodes  230
Collapsing nodes  228
Creating nodes  226
Deleting nodes  230
Delinking nodes  228
Displaying tools  47
Entering node values  229
Expanding nodes  228

Linking nodes  227
Moving nodes  229
Node connections  225
Options menu  223
Selecting nodes  226

Materials  110, 279
Nodes

2D Texture Nodes  268
3D Texture Nodes  259
Ambient Occlusion  254
Anisotropic  244
Blender  239
Blinn  246
Brick  270
Cellular  262
Clay  248
Color Math  242
Color Ramp  243
Component  240
Diffuse  248
Diffuse Nodes  248
dNdu  259
dNdv  259
dPdu  259
dPdv  259
dU  259
dV  259
Edge Blend  240

Environment Map Nodes  257
Fast Scatter  252
fBm  260
Fractal Sum  260
Frame Number  258
Fresnel  256
Gather  255
Glossy  246
Granite  266
Hair  252
Help  232
HSV  244
Image Map  268
Ks  246
Lighting Nodes  244
Math Functions  240
Math Nodes  239
Movie  274
N  257
Noise  262
P  258
Phong  245
PoserSurface  232
ProbeLight  249
Raytrace Nodes  253
Reflect  253
Refract  254
Root Atmosphere  237
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Root Background  235
Root Light  236
Root Node  232
Simple Color  243
Skin  250
Special Nodes  250
Specular  247
Specular Nodes  244
Sphere Map  257
Tile  272
Toon  249
Turbulence  261
User Defined  242
U Texture Coordinate  258
Variable Nodes  257
Velvet  251
V Texture Coordinate  259
Wave2D  268
Wave3D  267
Weave  273
Wood  267

Properties
Absolute  241
Add  241
Alternate diffuse  234
Alternate specular  234
Ambient color  233
Ambient value  233

Angle  256
Angle End  236
Angle Expo  237
Angle start  236
Attenuate  253
Attenuation  240
Auto Fit  269
Background  253, 254, 257, 270, 275
Balance  266
Base Color  265, 266, 273
Bias  242, 260, 261, 262, 264, 274
Blending  239
Blue  243
Bottom  260, 261, 262, 264
Brick Color  271
Brick Height  271
Brick Width  271
Bump  234, 236
Ceiling  241
Cell Mode  263
Clamp  241
Cloud Color  264
Color  236, 240, 243, 244, 248, 253, 

257, 263, 273
Color Mode  243
Complexity  264
Component  240
Cosine  241

Dark color  249
Dark Wood  267
Depth Cue Color  238
Depth Cue End Distance  238
DepthCue On  237
Depth Cue Start Distance  238
Diffuse  237
Diffuse color  233, 236, 248
Diffuse value  233, 248
Displacement  234
Divide  241
Eccentricity  247
Edginess  251
ETA  251
Exponential  241
Exposure  249
Filtering  270
Floor  242
Fractal Increment  261
Frame Number  275
Frequency Gap  261
Gain  242, 260, 261, 262, 264, 274
Global Coordinates  264, 265, 266, 

267, 275
Gradient bump  234, 235
Gradient mode  235
Green  243
Height  273



Poser 8
Reference Manual 

546

﻿

Highlight size  233, 236, 252
Hue  244
IBL Contrast  237
Image Mapped  270, 275
Image Resolution  237
Image Source  269
Index of Refraction  254, 257
Ink color  250
Inner Color  240
Input  239, 244
Intensity  236, 263
Jitter  264
Ka  250, 251
Kd  248, 250, 251
Ks  250, 251
Light color  249
Light Wood  267
Line width  250
Logarithm  241
Loop Movie  275
Math Argument  241, 242
Max  262
Max Dist  255, 256
Maximum  241
Min  262
Minimum  241
Mirror U  270, 275
Mirror V  270, 275

Modulus  241
Mortar Color  271, 272
Mortar Thickness  272
Mortar Width  271
Multiply  241
Noise  271, 272
Noise Type  261, 262, 264, 265, 266, 

267, 271, 273
Normal Map

  235
Normals Forward  235, 245, 246, 

247, 248, 250, 251
Octaves  260, 261
Opaque in shadow  252
Outer Color  240
Point  240
Power  241
Quality  253, 254, 257
Random Color  263
RayBias  253, 254, 255, 256
Red  243
Reflection color  234
Reflection Kd Mult  234
Reflection Lite Mult  234
Reflection value  234
Reflectivity  247
Refraction color  234

Refraction value  234
Root color  252
Root softness  252
Rotation  257
Roughness  246, 248, 251
Round  242
Samples  255, 256
Saturation  244, 249
Scale  263, 264, 266, 267
Shades  266
Shadow catch only  235
Sheen color  250
Sign  241
Signed  260
Sine  241
Size  246
Skin color  250
Sky Color  264
Smooth Step  242
Softness  253, 254, 257, 265, 271, 

272
Specular  237
Specular color  233, 236, 245, 247, 

252
Specular Color  245, 246
Specular Roll Off  247
Specular Value  233, 245, 246, 247
Spot Color  265, 266
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Spot Size  265
Spread  250
Square Root  241
Step  242
Strength  255
Subtract  241
Surface Color  249
Tangent  241
Texture Coordinates  269, 274
Texture Strength  270, 275
Thickness  251
Threshold  265
Tile  272
Tile Height  272
Tile Shape  272
Tile Width  272
Tip color  252
Toon ID  235
Translucence color  234
Translucence value  234
Transparency  233
Transparency edge  234
Transparency falloff  234
Turbulence  264, 266, 267, 271, 272
U Highlight Size  245
U Offset  269, 271, 273, 274
U Scale  269, 273, 274
Value  242, 244

Veins  266
Velvet color  251
Velvet sheen  251
V Highlight Size  245
Video Source  274
V Offset  269, 271, 273, 274
Volume Color  238
Volume Density  238
Volume Noise  238
Volume On  238
Volume Step Size  238
V Scale  269, 273, 274
X  258
Xdir X  245
Xdir Y  245
Xdir Z  245
X Index  262
X Scale  260, 261
Y  258
Y Index  262
Y Scale  260, 261
Z  258
Z Index  262
Z Scale  260, 261

Rooms
Clouds  264
Spots  265

Roots

Marble  265
MAT poses  102
Maximum bucket size  292
MC6  528
Memorizing Items  60
Memory Dots  43, 44, 47

UI  34
Memory limit buffer 
Memory Settings  30
Menu Bar  38
Minimum displacement bounds  292
Minimum shading rate  291
Morphing Tool  134

Combine tab  459
Create tab  462
Creating morphs with  458

Morphs. See also Full Body Morphs
Adding custom  469
Combining  470
Creating custom  468
Creating in other applications  468
Deleting morph targets  486
Managing morphed figures  485
Saving morph targets  485
Spawning  470
Splitting  141

Morph Targets  529
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Creating in Poser  458
External Binary Morphs  31
Spawning  470

Motion
Limiting  126

Motion Blur Document  278
Motion Capture

Importing BVH files  348
Movies

2D Motion Blur  352
Antialiasing  352
Aspect ratio  352
Flash  351
Frame rate  353
Frame Size  352
Image file sequences  351
Importing  50
Playing  310
Quick-scale resolution  352
Rendering  309, 351
Rendering AVI  351
Rendering fewer frames  353
Setting time range  352

MT5  528
Multi-threaded rendering  287

N

Name  136
Normal maps  213

O

OBJ  528
Object Menu Commands

Change Parent  167, 168, 402
Create Camera  178
Create Light  188
Create Magnet  445
Create Wave  453
Create Wind Force  449
Delete Object  162, 169
Load Morph Target  469, 470
Lock Actor  151, 185
Point At  151, 152, 184, 185, 191
Properties  194
Replace Body Part with Prop  166
Set Parent  191
Spawn Morph Target  470

Objects
Adding new  94
Changing  94
Deleting  169
Duplicating  59

OBJ Files  531
Occlusion culling  285
OpenGL

Hardware Acceleration  65
Options Menu

Document Window  62
Outline  78

P

Page Setup  57
Painter Scripts

Exporting  55, 307
Palettes

Closing  34
Docking  32, 34
Enabling/disabling docking  33
Floating  34
Moving  33
Project Guide  24
Repositioning  33
Resizing  33
Showing and Hiding  45

Parameter Dials  140
Bend  143
Dependent Parameters  141
Displaying graph  141
Editing  141



Poser 8
Reference Manual

549

﻿

Face  146
Front-Back  143
Graph  142
Min and Max limits  142
Name  142
Resetting  141
Scale  143
Sensitivity  142
Side to Side  143
Taper  143
Turn  143
Twist  143
Value  142
XYZ Rotate  145
XYZ Scale  143
XYZ Tran  145

Parameter Groups
Creating  139
Deleting  139

Parameters
Dependent  531
Displaying as list  139
Figure  142
Memorizing  139
Restoring  140
Scale  142
Universal  142

Parameters Palette  41, 42, 47, 135, 138

Dial Groups  140
Options Menu  139
Using  128

Paste  59
Paste Onto Background  84
Phonemes  146
Pictures

Copying  59
Pixel samples  291
Play Controls  315, 319
Play Range  319
PMD  528
Point Lights  187

Indicators  193
Pose Library  123
Poser 8 Figures

Hierarchy of  494
Poser Documents

Importing  51
Poser Download Manager  116
Poser Files

About  525
Characters  530
Clothing  530
Common objects  529
Downloads  529
Editing  525
Families  527

Hierarchy of  527
Locations  528
Morph targets  529
Other types  529
Syntax of  530
Types of  526
Warning about editing  525

Pose Room  37
PoserPython  518

About  518
Accessing manual  519
Running scripts directly  521
Scripts Menu  520
Scripts Palette  520
Warnings about  519
Why used  519

Poses  101
Figure poses  101
INJ and REM  103
MAT poses  102
MOR poses  103
Other types  103
Saving  150
with Animation Layers  104, 387

Posing
And camera views  123
Body Parts  127

Posing Figures  123
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General principles  123
Post filter size  297
Post filter type  297
PP2  528
Preferences

Document  26
General

Setting  26
Interface  27
Launch behavior  27
Library  28
Miscellaneous  31
Mouse input  28
Preferred State  27
Render  29

Preview Drawing  88
Preview Renderer  280
Preview Styles  47
Preview Tab

Context Menu  66
Multiple views  69
Single view  69

Printing  57
Production Frame  81
Project Guide  23, 24, 48
Properties

Bend  137
Body Part  136

Cast shadows  137
Collision detection  137
Collision settings  137
Crease angle  138
Displacement bounds  137
Figure  135
Internal name  136
Load Morph Target  137
Name  136
Shading rate  137
Smooth polygons  137
Visible  136
Visible in raytracing  137

Properties Palette  41, 42, 135
Props  108, 162

3D Objects  162
Adding to scene  108
Creating  162
Deforming  162
Deleting  162
Importing  51
Moving  162
Resizing  162

Props Library  162
Props Parameters

Scale  165
XYZ Rotate  165
XYZ Scale  165

XYZ Tran  165
Props Properties

Casts Shadows  164
Collision Detection  164
Collision Settings  164
Displacement Bounds  164
Display Origin  164
Internal name  163
Load Morph Target  164
Name  164
Set Parent  164
Shading Rate  164
Smooth Polygons  165
Visible  164
Visible in Raytracing  164

Python
Reinitializing  56
Running Scripts  56
Setting Editor  32

Python Scripts  46
Running  56

PZ2  528
PZ3  528
PZS  528

Q

Quick-Scale  75
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Quick Start  48
QuickTime

Rendering Options  354

R

Raytrace bounces  290
Raytracing  290

Visibility  136
Redo  58
Reflection  210, 217
Refraction  218
Registering Poser  22
Reloading Textures  62
Reload Textures  279
Remove Detached Nodes  221
Render  277
Render Dimensions  279
Rendered Image Cache  30
Render Engines  280
Rendering  62, 68, 76

Area Render  67, 75
Auto settings  288
Comparing renders  76
Dimensions  63, 74
Firefly options  294
In separate process  287
Manual settings  289

New window  76
Panning  76
Preview dimensions  63
Quality settings  287
Selecting render engine  75
Separate Process  30
Settings  63

Render Menu Commands
Area Render  277
Materials  279
MotionBlur Document  278
Reload Textures  279
Render  277
Render Dimensions  279
Render Settings  278, 280
Reuse Shadow Maps  279
Sketch Style Render  277, 307

Render Over  294
Render Settings  278

Display Engine  282
Movies  284
Preview Tab  281
Procedural Shader Preview  282
Sketch Tab  281
Style Options  283
Tips and Tricks  284
Transparency Display  283

Render Tab  73

Restoring Items  59
Reuse Shadow Maps  279
Reverting Changes  49
Room Help  46
Room Tabs  39
Rotate Tool  130
Rotation orders  499, 515
Rotation trackball  176
RSR  528

S

Scale  143
Scale Tool  131
Scene

Adding items  95
Scenes

Adding hair  106
Adding props  108
Closing  49
Compressed  49
Creating new  48
Opening  49
Opening recent  49
Removing items  95
Saving  49

Script buttons  521
assigning  521
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Assigning in console  521
Scripts

Editing in console  521
Scripts menu  520
Scripts Palette  520
Select Figure Menu  65
Selecting

with Current Actor menu  128
Setting Up

Document Window  35
Workspace  26

Set Up Ambient Occlusion  220
Set Up Light Style  220
Setup Room  428

Finalizing figure  441
Geometry requirements  438
Loading bone structure  431
Memorizing and saving figures  441

Set Up Shadow Catcher  219
Set Up Toon Render  219
Shaders  216
Shader Window  205, 206

Advanced shader view  214
Navigating  206
Simple shader view  206
Simple view  206

Shading rate  137
Shadow Blur Radius  195

Shadow catcher  219
Shadow Maps

Clearing  63
Reusing  63, 279

Shadow Min Bias  196
Shadows  71

Casting  289
Color of  73

Shadows Only  295
Side to Side  143
Silhouette  78
Sketch Designer  46, 280, 304

Brushes  305
Checkboxes  305
Exporting Painter Scripts  307
Parameters  305
Presets  305
Rendering  307

Sketch elements  304
Sketch Style Render  277
Skip frames  326
Smoothing geometry  299
Smoothing groups  301
Smoothing Preferences  27
Smooth Lined  80
Smooth Polygons  137, 295, 302
Smooth Shaded  80
Software Updates

Checking for  32
Sound  343

Clearing  310
Editing  343
Importing  343
Muting  310
Syncing with motion  344

Spherical falloff zones  509
Spotlights  187

Indicators  193
Subsurface scattering  218
SWF Files

Exporting  56
Syntax

Brackets  530
of Poser files  530
Tabs in  530

System Requirements  5
Macintosh  6
Windows  5

T

Tablet Mode  28
Talk Designer  46, 313, 344

Configuration  346
Configuring  345
Emotional tweaks  347
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Head motions  347
Taper  143
Taper Tool  132
Technical Support

Types of  523
Texture filtering  286
Textures

Reloading  62
Texture Shaded  80
Threads

Number of  , 30
Thumbnail Display 
Tiled texture loading  286
Time Control  319
Timeline

Editing Keyframes on  327
Timeline Indicator  314
Tone mapping  298
Tools

Chain Break  132
Color  133
Direct Manipulation  134
Grouping  133
Morphing  134
Rotate  130
Scale  131
Taper  132
Translate In/Out  131

Translate/Pull  131
Twist  131
View Magnifier  133

Tool Titles  48
Toon outline  296
Toon Render  219
Tracking  82
Tracking Mode  70
Translate In/Out Tool  131
Translate/Pull Tool  131
Translation  123
Transparency  212
Turn  143
Twist  143
Twist Tool  131

U

Undo  57
Undo/Redo

Setting number of  27
Universal Parameters  142
Universal Poses  29, 102
Updating Poser  23

V

Vanishing Lines  87

View Magnifier Tool  133
Visible  136
Visible in raytracing  137

W

Wacro Drawer  206
Wacros  216
Walk Designer  46, 313, 336

Applying walks  338
Blend and Tweak Styles  337
Creating walks  336
Figure Types  337
Loading walks  338
Saving walks  338
Views  337

Walk Paths
Adding control points  341
Creating  340
Removing control points  341
Shaping curves  341

Wardrobe Wizard  404
Analyzing full body morphs  404, 411
Choosing original clothing  406
Clothing Types  408
Convert  404
Convert From  407
Converting options  409
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Convert To  407
Figure Utilities  414
Finding converted clothing  411
Footwear  425
Lights Utilities  420
Magnets Utilities  423
More utilities  424
Morphs utilities  416
Prop utilities  419
Questions and answers  426
Refining morphs  413
Shape utilities  421
Shift utilities  422
Target library  407
Texture utilities  418
Utilities  413

Wave Deformers  452
Creating  453
Falloff Graph  455
Object Properties  454
Parameters  456
Using Editing Tools with  453
Zone Properties  454

Welding groups  492
What’s New  2
Wind Force Fields  449

Parameters  451
Properties  450

Window Menu Commands
Animation Controls  47
Animation Palette  45, 313, 317, 335
Camera Controls  46
Document Window Size  48
Editing Tools  47
Graph  45
Hierarchy Editor  46, 495
Joint Editor  46, 500, 502
Libraries  45, 91
Light Controls  47
Memory Dots  47
Parameter Dials  135
Parameters Palette  47
Preview Styles  47
Project Guide  25, 46, 48
Python Scripts  46, 520
Quick Start  24, 48
Quick Start Guide  46
Room Help  46, 232, 358, 364
Room Tools  47
Sketch Designer  46, 304
Talk Designer  46, 314, 345
Tool Titles  48
Walk Designer  46, 313, 336

Windows
Installation  19
Showing and Hiding  45

Wireframe  78
Workspace

Customizing  32
Setting Up  26

X

XYZ Rotate  145
XYZ Scale  143
XYZ Tran  145

Y

Yon  182


	Part 1: Poser Introduction
	Chapter 1: Welcome to Poser!
	What’s New in Poser
	Included Documentation
	System Requirements
	Poser Content Online
	When You Have Questions
	About Your Reference Manual

	Chapter 2: Installing Poser
	Poser End User License Agreement (EULA)
	Installing Poser
	Registering Poser
	Updating Poser
	Project Selection
	Project Guide

	Chapter 3: Setting Up the Poser Workspace
	Setting Application Preferences
	Setting Up Your Workspace


	Part 2: Building Scenes
	Chapter 4: The Pose Room
	Menu Bar
	Light Controls
	Camera Controls
	Room Tabs
	Editing Tools
	Document Window
	Display Controls
	Parameters/Properties Palette
	Parameters Palette
	Properties Palette
	Library Palette
	Memory Dots
	Using Memory Dots
	Animation Controls
	Showing and Hiding Windows and Palettes
	Other Basic Operations

	Chapter 5: The Document Window
	Preview Tab
	Title
	Options Menu
	Document Window Size
	Render Tab

	Chapter 6: The Display Controls and Menu
	The Display Menu Commands

	Chapter 7: The Poser Library
	Displaying the Library Palette
	Accessing Different Content Libraries
	Loading and Managing Items using the Library Icons
	About Library Palette Categories
	Maintaining Your Library Palette
	Searching the Library
	Favorites Tab

	Chapter 8: The Content Room
	Downloading and Installing Content

	Chapter 9: Posing Figures
	General Posing Principles
	Selecting Body Parts
	The Editing Tools
	The Parameters/Properties Palette
	Properties
	Parameters Palette
	Universal/Figure Parameters
	Posing Faces
	Posing Eyes
	Posing Hands
	Posing Animals
	Pose Dots
	Saving Poses in the Library
	Other Posing and Figure Aids

	Chapter 10: Working with Props
	About Props
	Hair
	Clothing
	Adding & Importing Props
	Moving, Resizing, and Deforming Props
	Deleting Props
	Creating New Props
	Prop Properties
	Prop Parameters
	Replacing a Body Part with a Prop

	Chapter 11: Cameras
	Camera View
	Show Camera Names
	The Camera Controls
	The Main, Auxiliary, and Posing Cameras
	The Face Camera
	Left and Right Hand Cameras
	The Dolly Camera
	Orthographic Cameras
	Shadow Light Cameras
	Changing Cameras
	Select Camera Control
	Flyaround View
	Positioning Cameras
	Creating Cameras
	Camera Properties & Parameters
	Pointing & Locking Cameras
	Camera Dots
	Saving Camera Sets

	Chapter 12: Lighting
	Light Types
	Selecting Lights
	Creating Lights
	Adjusting Light Intensity
	Light Color
	Delete Light
	Aiming Lights
	Using Light Indicators
	Light Properties
	Light Parameters
	Saving & Loading Light Sets
	Animating Lights


	Part 3: Materials
	Chapter 13: The Material Room
	Navigating the Shader Window
	Shaders
	Wacros

	Chapter 14: Working with Nodes
	About Nodes
	The Material Room Options Menu
	Material Room Node Connections

	Chapter 15: Material Room Nodes
	Root Nodes
	Math Nodes
	Lighting Nodes
	3D Texture Nodes
	2D Texture Nodes


	Part 4: Rendering
	Chapter 16: The Render Menu
	Render
	Area Render
	Sketch Style Render
	Antialias Document
	Motion Blur Document
	Render Settings
	Render Dimensions
	Materials
	Reload Textures
	Reuse Shadow Maps

	Chapter 17: The Render Settings Dialog
	Render Engines
	Sketch Tab  
	Preview Tab
	Movie Settings
	Tips & Tricks

	Chapter 18: Using The FireFly Render Engine
	Firefly Tab: Quality Settings
	Indirect Light
	FireFly Options Settings
	Saving and Loading Presets
	Smoothing Geometry

	Chapter 19: The Sketch Designer
	Sketch Elements
	Presets
	Checkboxes
	Brushes
	Sketch Parameters
	Rendering Sketches
	Exporting Painter Scripts


	Part 5: Animating
	Chapter 20: The Animation Menu
	Make Movie
	Recalculate Dynamics
	Retime Animation
	Resample Key Frames
	Loop Interpolation
	Quaternion Interpolation
	Skip Frames
	Mute Sound
	Clear Sound
	Play Movie File

	Chapter 21: Animating with Poser
	Animation Overview
	Using the Animation Controls
	Using the Animation Palette
	Animation Palette Options Menu
	Keyframes Tab
	Layers Tab
	Animation Sets Tab
	Using the Walk Designer
	Sound
	Using the Talk Designer
	Importing BVH Motion Capture Files
	Advanced Animation Techniques
	Saving Animations to the Library

	Chapter 22: Rendering Animations
	AVI Options
	QuickTime Options
	Flash Options


	Part 6: Customizing Content
	Chapter 23: The Face Room
	Using Images to Create Heads
	Creating Custom Textures
	The Face Shaping Tool
	Loading/Saving/Previewing Textures
	Applying Custom Heads/Textures

	Chapter 24: The Hair Room
	Step One: Defining Hair Groups
	Step Two: Growing Hair
	Step Three: Styling Hair
	Step Four: Setting Hair Dynamics
	Hair Properties & Parameters
	Hair Colors and Materials
	Adding Strand-Based Hair to the Library Palette

	Chapter 25: The Cloth Room
	Using the Cloth Room
	Conforming vs. Dynamic Cloth
	Adding Dynamic Clothing
	Using Dynamic Clothing without a Figure
	Step 1: Create/Set Up a Cloth Simulator
	Step 2: Cloth Controls
	Step 3: Cloth Groups
	Step 4: Cloth Dynamics Controls
	Cloth Parameters & Properties
	Creating Props and Morph Targets
	Adding Dynamic Cloth to the Library Palette

	Chapter 26: Wardrobe Wizard
	Converting Clothing
	Analyzing Full Body Morphs
	Wardrobe Wizard Utilities
	Common Questions (and Answers)

	Chapter 27: The Setup Room
	Creating Figures for Poser
	About the Setup Room
	The Setup Room Interface
	Step 1: Importing/Arranging Geometries
	Step 2: Loading and/or Creating Bone Structures
	Step 3: Naming the Bones
	Step 4: Attaching Bones to Geometry Parts
	Step 5: Assigning Rotation Orders
	Step 6: Fine-Tuning Joints
	Step 7: Testing Your Figure
	Step 8: Assigning IK Chains
	Step 9: Inverse Kinematics
	Step 10: Setting & Memorizing Favored IK Angles
	Step 11: Setting Joint Limits
	Step 12: Finalizing Your New Figure
	Step 13: Memorizing and Saving Your New Figure
	Troubleshooting

	Chapter 28: Modifying Figures & Props
	Using Deformers
	Using Deformers with Grouped Objects
	Creating Morphs with the Morphing Tool
	Creating Morphs in Other Applications
	Combining Morphs in Poser
	Using Dependent Parameters
	Managing Morphed Figures

	Chapter 29: Figure and Prop Editors
	The Group Editor
	The Hierarchy Editor
	The Joint Editor


	Part 7: PoserPython
	Chapter 30: About PoserPython
	Why Python?
	A Word of Warning
	PoserPython Types & Methods Listing

	Chapter 31: Running PoserPython Scripts
	The Scripts Menu
	The Python Scripts Palette
	Running Python Scripts Directly


	Appendices
	Appendix A: Technical Support
	Appendix B: Poser File Structure
	About Poser Files
	A Word of Warning
	Editing Files
	Poser File Types
	File Hierarchy
	Commonly Used Poser Objects
	Basic File Syntax
	Poser & OBJ Files
	Dependent Parameters



