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Welcome to Extensis™ Portfolio™! Portfolio is an easy-to-use and
efficient cataloging tool that allows you to organize all your
creative work into on-line libraries that can be browsed. Whether
your creative content is created on Macintosh or Windows, shared
over a network, or accessed from remote locations using TCP/IP
or over the web—Portfolio will forever change the way you view,
organize, manage, select, share and use digital content. 

Portfolio allows you to build visual catalogs from digital media
including images, sounds, movies, and documents automatically,
with detailed reference information and thumbnail images. You
can catalog any media regardless of application, then effortlessly
retrieve them by visually searching or by searching using
keywords or other criteria. You can view your media files as
thumbnails, as a list, or as individual records, and customize the
views to suit your needs.

Portfolio also lets you stay in sync with other users by sharing
your catalogs over networks and across platforms. You can import
databases of information into your catalog, and even export
catalogs or specified items as Web pages.

System and Software Requirements

To install and use Portfolio, you will need the following:

Macintosh:

•  Apple® Power Macintosh® or PowerPC compatibles
•  Mac OS® System 8.1 or later  
•  6MB application RAM, minimum
•  20MB free hard disk space
•  Open Transport 1.1 or higher (only if you will be connecting to

catalogs being served by Portfolio Server software)

Note: If you commonly work with large files or large catalogs, you
may need to increase the amount of RAM allocated to Portfolio.

Windows:

•  486/33MHz or faster PC  (Pentium 133MHz or faster 
recommended)

•  Microsoft® Windows 95®, Windows 98® or Windows NT® 4.0 
•  6MB application RAM, minimum
•  20MB free hard disk space
•  TCP/IP Services (only if you will be connecting to catalogs

being served by Portfolio Server software)
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Note

For additional installation instruc-
tions and system requirements see: 

Server Administration, page 221.
PorWeb, page 236.

SQL Connect Administration, 
page 266.



Installation

You can find instructions for quick and easy installation on the
CD-ROM  that is included with your product or, if you down-
loaded an Extensis product installer from our web site, running the
installer will place an informational Read Me on your hard drive.

Registration

It is important to register your copy of Portfolio so we can provide
you with the best possible service. Registered users of Portfolio
are eligible for technical support, information regarding new ver-
sions and products, discounts and special offers on new products. 

Your registration number is located on the back cover of this
manual or was sent to you via email if you purchased through our
website.  You will need to enter that number to personalize your
copy of Portfolio. If you choose not to personalize your copy,
Portfolio will run in a demonstration mode that allows you to use
the product for 30 days. You can purchase additional registration
numbers in the US at 1-800-796-9798 or 1-503-274-2020. In
Europe call 31 (0) 30 247 50 50.

Technical Support 

For questions regarding Portfolio, please first refer to this manual,
which describes the features and basic operations. We invite you
to visit our Portfolio page on the Extensis website
(http://www.extensis.com) for frequently asked questions and
troubleshooting tips. 

If you have a question which is not addressed in this manual or
on the Extensis website, Technical Support is available by phone
at (503) 274-7030, Monday through Friday, 8:00 a.m. to 5:00 p.m.
Pacific time. When calling for technical support, please be at your
computer and have the following information available: your
Portfolio registration number, your computer configuration, and
your question or a description of the difficulty you’re experienc-
ing—what specifically occurs and when. Take note of any dis-
played error numbers or messages and any other information you
think may be relevant.
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Tip

We can also be reached by:

Fax: (503) 274-0530

E-mail : support@extensis.com

Internet:
http://www.extensis.com/support

Tip

Extensis Customer Service contact
information for the US and Europe
is shown on page 2.

Tip

Extensis now offers suppo rt
forum s for all products. These
forums allow you to share issues
with other users, get help from Tech
Support, read what other users are
doing with the product, and more.
Visit http://www.extensis.com/sup-
port and locate the appropriate
product support forum.

http://www.extensis.com/support


What is Portfolio?

Portfolio is a digital image cataloging application. Using Portfolio
you can take images—including graphics, presentations, movies,
sounds and other digital media files, even documents—that you or
members of your workgroup create and put them into common
catalogs. You can then view, edit, copy, and retrieve items from the
catalog and transfer them to other documents, regardless of file
format, location, platform, or applications that created the files.

It’s quick and easy to view and retrieve images in Portfolio cata-
logs because the catalog stores only thumbnail images of the file
(along with whatever additional information you require), rather
than the full document or image. Portfolio creates pointers to the
original files, so the originals are always available for copying to
applications, previewing, editing, etc., while allowing the catalog
itself to be fast and efficient. 

There is no limit to the number of items a single catalog can con-
tain (bearing in mind that the more items in a catalog, the more
memory and time are required for common operations). To each
item in a catalog, you can add:

• An unlimited number of keywords that will help you easily
search for and select catalog items.

• A description (up to 32,000 characters long) that lets you store
important or useful information about the file.

• Unlimited custom fields, including special field types such as
Date/Time, Strings with multiple values and predefined lists,
URLs, and more.

In a workgroup setting, you can allow all users full access to all
catalog functions, or you can designate catalog administrators to
create, maintain, and control access to catalogs for the entire
workgroup. With Portfolio installed on their computers, members
of your workgroup on both Macintosh and Windows can simulta-
neously search, view, and use items from catalogs whose source
files are located on one or many network servers, shared volumes,
CD-ROMs or removable drives. Users can access the Portfolio
Server remotely using TCP/IP, and you can even create Web
pages of cataloged items.

With the PortWeb plug-in and appropriate web server
setup, even web browser users to can browse Portfolio cat-
alogs. See page 236for details.
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What’s New in Portfolio 5.0?

Portfolio version 5.0 is a major upgrade to this popular cataloging
program, adding a number of exciting new features and enhance-
ments. Major new features and enhancements are listed below.

New to Portfolio in version 5.0 are:

• Palette Interface—Palettes provide easier access to information
that was previously available only from submenus or dialogs.
The new palette interface allows you to execute finds, load
galleries, and sort record sets faster than ever before.

• Dockable Palettes—Helps you keep your workspace uncluttered
by allowing you to dock and undock palettes as you need them.

• Edit in place—Edit fields directly in Record view. 
• Watermarking—Read and embed Digimarc™ watermarks. 
• Disk Previews—Lets you capture a full-sized screen resolution

image when items are cataloged, and access it even if the
original image is on a disk that is not currently mounted.

• Multi-page file format—Allows you to preview each page of a
multi-page document, and search the text inside it.

• Create Placeholder Records—Allows you to create a blank
record for any item whose source file is not yet available.

• Search across multiple catalogs*—Expand searches to include
both intranet (local network) and Internet based catalogs.

• SQL Database Support*—Allows corporate Portfolio users to
interface with a pre-existing SQL database. Sold separately.

• PortWeb*—A Portfolio plug-in (part of the Portfolio
Client/Server package) that allows Portfolio databases to be
published to HTML web servers and dynamically searched by
viewers with web browsers is now included with Portfolio.

Enhancements include:

• Translators—Improved item translation and functionality. 
• Saved Galleries and Finding—Improvements to Galleries and

Finding prompt you to save Galleries, and lets you link a saved
find and predefined sort order to specific Galleries. 

• Slideshow—Adds optional data fields displayed with the image,
enhanced proofing controls, and the ability to export slideshows
as QuickTime™ movies (Mac OS only).

• Background Cataloging—Improvements include multiple
folder watch and easier task monitoring.

• Preview—Adds a host of new features and improved preview
controls.

• Server Administration*—Multiple improvements, including
allowing catalogs to be managed without closing them on the server. 
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Note

Features with an asterisk (*) apply
to Portfolio Network and Portfolio
Server Editions only.



There are two basic ways to use Portfolio: as a tool
to create and manage catalogs of your electronic
media files; and as a tool to view, display, and use
those images.

Portfolio offers a wide range of
features and functions giving you great
flexibility in the storage and display of
cataloged images (these options are
described in the various sections of
this User Guide), but the basic process
of creating and viewing catalogs, as
described below, is simple.

Cataloging Steps Summarized

1. Open Portfolio, create a new catalog, then drag and drop
images or folders of images into the open Gallery window.

2. When prompted for Cataloging Options, select the desired
options, or simply accept common default options.

3. After Portfolio has finished adding the new images to the
catalog, you can view the items in different ways using
commands from the View menu, add information about the
items using commands from the Item menu, or change catalog
parameters using commands from the Catalog menu.

4. You can add keywords, descriptions, and custom fields, then
search on these entries, or search using a number of other criteria.

5. If your catalog is shared over a network or on a Portfolio
Server, you can access and use catalog images at the same time
as other users.

Getting Started with Portfolio

Thumbnail
View

List View

Record
View

Simple to Complex
Searching
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Portfolio Basics

When you create a new Portfolio catalog or add items to an
existing catalog, Portfolio gathers information about the item and
creates a record for it in the Portfolio database. If the source file
being cataloged includes a thumbnail and/or icon, the thumbnail
and/or icon can be added to the item’s record.

Portfolio does not import the item itself, but creates a link to the
file that contains the cataloged item. This allows you to view,
search, and retrieve cataloged items quickly, and to view and
search for items even when the original file is not available (such
as on a hard disk, CD, or network volume that is not mounted).
The only time you need to access the original file is when you
want to Preview the image, Edit the image, or copy it to another
application.

If a cataloged item is moved to another location, renamed, or if
other information about the original file changes, you will want
to make Portfolio aware of the change by “updating” the record.

You view cataloged items in a window called the “Gallery.”
Portfolio provides several different Gallery views, and each of
these views can be customized to meet your needs. You can add
additional information to item records such as keywords, descrip-
tion, and Custom Fields, and then search for cataloged items
using keywords, or use Portfolio’s powerful Find function to
locate items using any of the information fields assigned to them.

If your catalogs are being used in a workgroup and/or network
environment, you can use Portfolio’s standard Level-based
Accessoptions (page 194) or the new User-based Accessoptions
(page 199)to limit access to the different cataloging functions. 

See pages 13 through 20 for a General Overview of Portfolio’s
major functions and features.

The Sample Catalog

If you have not yet cataloged your own files, you can use the
Portfolio Sample Catalog. The Sample Catalog is located on the
Extensis CD, or you can download it from our web site
(http://www.extensis.com).

Note: You can copy the Sample Catalog to your hard drive and
work with it there if you prefer.



General Overview

To create and view a catalog:

1. Open the Portfolio application by double-clicking its
icon, or by selecting it from the Start Menu (Windows).
When the Welcome dialog appears, choose “Create a
new Portfolio catalog,” then click “OK.”

2. Choose a name and location for your new catalog.

Portfolio creates a blank catalog, then opens the catalog
and displays the Gallery window.

3. Drag and drop selected files or folders into the open
Gallery window.  

You can also add items to a catalog by choosing “Add
Items” from the Catalog menu.

When you add items to a catalog, the Cataloging Options
dialog is displayed, allowing you to choose a variety of
options for the cataloged files. You can keep the Cataloging
Options dialog from opening automatically by selecting the
appropriate option under Edit > Preferences. See page 93.
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Tip

If you’d like to learn about Portfolio
but don’t want to create a catalog
yet, you can use the Sample
Catalog located on the Extensis
CD. You can read through steps 1
through 5 and examine the exam-
ples, or go straight to “Gallery
Views” (step 6) on page 16.
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4. Select the desired settings from the Cataloging Options
dialog—or simply allow Portfolio to use the typical
default settings—then click “OK.”

The Cataloging Options dialog allows you to determine what
information will be cataloged with the image, how the
thumbnails will be created, and whether the records should
be updated. You can access and set these options at any time
by choosing Catalog > Cataloging Options (or press
Command+J (Mac OS) or Ctrl+J (Windows)).

Since Portfolio creates catalogs using the image thumbnails
rather than by importing the entire image, updating is re-
quired when any of the images have been relocated; updat-
ing allows Portfolio to update the pointers to the image files. 

Note: Even if an image has been moved and the link to it
lost, you can continue to view and work with the record in
the catalog. It is a simple matter to update links to images
using the Update Items option from the Catalog menu.

5. Portfolio will begin cataloging the items, keeping you
informed of its progress.

Tip

If you have a catalog that you use
frequently, you can specify it as the
Default catalog and have Portfolio
automatically open this catalog
when you start Portfolio. Open the
desired catalog, then choose “Set
Default Catalog” from the FIle
menu.
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6. Gallery Views: When cataloging is complete, the catalog
items will be displayed in the Gallery window, using
whatever view was last displayed.

Portfolio provides three different catalog views: Thumbnail
view, List view, and Record view. You can change views at
any time by selecting a new view from the View menu, or
by clicking the appropriate icon on the
Toolbar, or by using keyboard shortcuts: Command+T, L,
or R (Mac OS) or Ctrl+T, L, or R (Windows).

7. Find: You can search for items in the catalog, or across
multiple catalogs, using a number of different options. 

To do so, choose “Find” from the Catalog menu, or press
Command+F (Mac OS) or Ctrl+F (Windows), or click the
Find icon on the button bar, or enter a keyword to
search for in the search field in the button bar.

You can use multiple search parameters at one time, dis-
play the found items in a new Gallery window, then search
those Gallery items using different search parameters to
narrow the search even more.

Tip

To eliminate having to recreate
detailed Find parameters, save
commonly searched-for parameters
as a Saved Find (page 48).

Tip

With Portfolio Network and Portfolio
Server Edition, you can easily
search across multiple catalogs
(see page 53).
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8. Keywords and Descriptions: You can add additional
information to the items in the catalog, such as key-
words, descriptions, and Custom Fields.

To do so, choose “Item Properties” from the Item menu.

You can also edit the fields, if any, that were included with
the item when it was cataloged. Use Item > Edit Keywords
to assign keywords to multiple items at the same time.

When you close the Properties dialog, the changes are
applied and can be viewed along with the item thumbnail
in any Gallery view that has the keywords, descriptions, or
Custom Fields displayed (this is set in View > Customize).

Note: You can import keywords into catalog records using
Import > Field Values... from the File menu. And you can
add consistency to your keywords by creating a Master
Keywords list that users can choose from when assigning
keywords to catalog items. Master Keywords can only be
added and edited when in Administrator mode.

Tip

If you prefer, you can edit fields
directly, without the need to first
open Item Properties. For informa-
tion on editing directly into fields in
Record view, see page 146.



9. Customize Layouts: You can customize the layout of the
different Gallery views.

Customizing views allows you to include just the informa-
tion you want to see, and determine how that information is
presented. You can change the font size and style of text,
add different background colors and custom borders to the
thumbnails, and more. To customize a Gallery view, choose
View > Customize, or press Command+D (Mac OS) or
Ctrl+D (Windows). 

10. Replace: You can add and replace keywords, descrip-
tions, and Custom Field data for multiple items using
the Replace function.

This allows you
to select a num-
ber of items and
replace key
information for
them all at
once. Choose
“Replace” from
the Catalog
menu, or press

Command+Option+R (Mac OS) or Ctrl+Shift+R
(Windows).

17



11. Using Catalog Items: You can work with catalog items in
a number of different ways, such as previewing the
original image, copying the image to a document, edit-
ing the image (in the parent application), rotating the
thumbnail if appropriate, relocating the original image,
and more.

To use a catalog image in a document: If the application
allows drag and drop, simply drag the image to the open
document window and drop it there. If the application does
not allow drag and drop, open the item Preview window.
Macintosh: Choose “Select All” [Command+A].
Windows: The item is selected automatically. Copy the
image to the Clipboard [Command+C (Mac OS) or
Ctrl+C (Windows)], then Paste it into the document
[Command+V (Mac OS) or Ctrl+V (Windows)].

To access other item options, choose them from the Item
menu.

12. Slideshow: You can view catalog images at their original
size using the Slideshow feature.

The Slideshow displays only the images in the active
Gallery window, so you can limit the Slideshow to just the
items you wish to show by creating a new Gallery and
adding the desired images to it. You can even export
slideshows as QuickTime movies.

To start a Slideshow and access Slideshow Options, choose
them from the Catalog menu. 
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Tip for Macintosh QuarkXPress
Users

To drag and drop catalog items to
QuarkXPress documents you will
need to install QX-Drag&Drop, a
free XTension from Extensis that is
included on the Extensis CD. See
page 59.



13. Multiple Catalogs/Multiple Galleries: You can organize,
view, and search your catalogs in whatever way works
best for you, including opening multiple Catalogs and
creating multiple Galleries.

For example, you might want to create different catalogs
for different types of items, or you might want to put all
your items in one catalog, and create different Galleries to
display them. Or you might want to locate (using keywords
or the “Find” command) items meeting specific criteria and
display them in a new Gallery—you can even save
Galleries for future viewing of only those items.

For information on the differences between Catalogs and
Galleries, see page 28. For information on multiple Catalogs,
see pages 53 and 74; for multiple Galleries, see page 64.

14. Importing and Exporting:

You can import field values, such as keywords and data
from other databases. With Portfolio Network Edition, you
can convert entire Cumulus catalogs (Macintosh) to
Portfolio. 

Export options include the ability to: export catalogs as text
files for input into a database; export “pnot” data
(Macintosh); export an entire catalog or selected items as
HTML Web pages; and export Slideshows as QuickTime
movies.

15. Multiple Drives/Image Networking

Portfolio catalogs can contain images on multiple hard disks,
network servers, CD-ROM drives, removable drives, etc.,
whether or not these drives are mounted. When you want to
work with the original image of an item located on an
unmounted drive, you will be prompted to insert or mount it.

16. Multiple Users/Catalog Networking: Using standard
system filesharing, you can share Portfolio Catalogs
between users. For even greater multi-user capability,
use Portfolio Server software.

In a network environment, a shared catalog can be on a
network file server or on any user’s Macintosh or PC, as
long as the Macintosh or PC is properly networked.

For better performance when sharing catalogs, and to 
allow more simultaneous users, Portfolio Server software
is recommended. You create and access Portfolio Server
catalogs using the standard Portfolio 5.0 application.
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15. Catalog Security/Access Levels:

Portfolio gives you control over who can make changes
to catalog information using four levels of access: Admin-
istrator, Publisher, Editor, and Reader. You can assign
security using either of two methods: Level-based access
or the new User-based access. You can change the current
level or user by choosing “Access” from the Catalog menu,
or press Command+Option+B (Mac OS) or
Ctrl+Shift+B (Windows). 

For more information on catalog access levels, see 
page 192.
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Converting Portfolio 3.0 and 4.0 Catalogs

To access the rich new features added to Portfolio 5.0, catalogs
created in Portfolio 3.0 and 4.0 must be converted to version 5
catalogs. Portfolio 5.0 can open version 3.0 and 4.0 catalogs with-
out conversion, in a limited browsing mode.

Opening a version 3.0 or 4.0 catalog with Portfolio version 5.0 in
Administrator mode allows the catalog to be converted.

To convert a Portfolio 3.0 or 4.0 Catalog:

1. Set the Portfolio default access mode (Edit >
Preferences) to “Administrator.”

This will automatically open the catalog in Administrator
mode. If the catalog requires a password for Administrator
level access, you will be prompted to provide it. If you
open the catalog in any other mode, the catalog will auto-
matically be opened in a limited browsing mode.

2. Open the catalog to be updated. 

You will be asked to confirm the conversion. 

3. Click “OK.”

The catalog is converted and all options (Catalog options,
saved Galleries, etc., are preserved) and saved as a new cat-
alog file.

Choose “Cancel” to open the catalog in limited browsing
mode, leaving it set as a version 3.0 or 4.0 catalog.

Note: Custom Fields are not indexed when converting Portfolio
version 3.x or 4.x catalogs to Portfolio 5.0.
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Tip

To convert a Cumulus catalog 
(Mac OS), see page 182.

To convert a Fetch 1.2 or 1.5
catalog to Portfolio 5.0, contact
Technical Support (see page 8).



22

To open a Portfolio 3.0 or 4.0 Catalog without converting it:

• Open the catalog in any mode except Administrator
mode.

You will be informed that the catalog will be opened in a
limited browsing mode. 

— or —

• Open the catalog in Administrator mode and click
“Cancel” when asked to confirm the conversion.

The catalog will be automatically be opened in a limited
browsing mode. 

When the catalog is closed it will still be a Portfolio
version 4.0 (or 3.0) catalog.
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This chapter describes how to open Portfolio catalogs, how to
view catalog items, and how to search for, select, preview, and
use those items in a variety of ways. You’ll also learn some
techniques for getting the most from Portfolio. 

This chapter assumes that you have an existing catalog with
which to work. If you do not, you can use the Sample Catalog
located on the Extensis CD. For information on creating a
catalog, refer to “Creating and Managing Catalogs” on page 113.

Opening Catalogs

You can open a Portfolio catalog in a number of ways, and you
can have multiple catalogs open at the same time. If you will be
accessing shared catalogs on a Portfolio Server, see page 24.

To open a Portfolio catalog:

• Drag and drop a catalog icon onto the Portfolio
application icon, or double-click a catalog icon.

— or —

• Windows: Choose Extensis Portfolio from the Start menu.

• Double-click the Portfolio icon. 

When prompted to open a new or existing catalog, click
“Open an existing Portfolio catalog,” then locate the
catalog. 

To open Portfolio without a catalog, click “Cancel.”

— or —

• With Portfolio already open, click the Open Catalog
icon on the Toolbar, or choose “Open…” from the
File menu, or press Command+O (Mac OS) or Ctrl+O
(Windows).

The catalog opens to the Gallery window. From the Toolbar you
can access most of the major functions and options in Portfolio.
You can change views, open new Catalogs, open additional
Gallery windows, search the catalog, and more.

Note: If you open a protected catalog, you must enter the appro-
priate access password to view and modify catalog items. If the
catalog won’t open, another user may have it open in Administra-
tor mode or with the Portfolio browser. See “Catalog Access
Levels” on page 192.

Viewing and Searching Catalogs

Tip

If you have one or more catalogs
that you use frequently, you can
have these catalogs opened auto-
matically whenever you start
Portfolio. Open each catalog that
you wish to have opened automati-
cally, then choose File > Open
Catalog at Startup, or select this
option from the fly-out menu on the
Catalogs palette.
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Connecting to a Server

If the catalog you want to open is on a Portfolio Server, you will
need to connect to the Server and then select the appropriate
catalog. When accessing a served catalog, the Portfolio 5.0
application software is referred to as the “client.”

Note: The Portfolio Server is special software that allows you to
share catalogs with more simultaneous users than is possible
using standard system networking. If you need to access a catalog
that has been shared using conventional networking, simply
access the catalog the same way you access other network files.
See your System Administrator for help.

To Open a catalog on a Portfolio Server:

1. Double-click the Portfolio icon and click “Open existing
catalog.”

1a. Click the “Connect to Servers” button (Mac OS) or the
“Servers...” button (Windows). 

The “Connect to Servers” dialog will be displayed.

— or —

1. With Portfolio open, choose “Connect to Server...” from
the File menu, or click the “Connect to Servers”
button on the Toolbar, or press Command+Option+O
(Mac OS) or Ctrl+Shift+O (Windows).

The “Connect to Servers” dialog will be displayed.

Note

This section applies to Portfolio
Network and Portfolio Server
Editions only.
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2. If a list of servers and catalogs appears, skip to step 4
on the following page. If the list is blank (as shown
below) or if the server you want to access does not
appear: Click “Add Server...”

The “Add Server” dialog will be displayed.

3. Enter the Name or IP address of the server that you
want to connect to.

Portfolio will connect to the Server and display a list of
catalogs available on that Server.

Tip

Server connection files are stored
in the “Servers” folder located in
the Portfolio application folder for
each client. Once a server has
been added to one client, its con-
nection file can be distributed
throughout a workgroup by simply
copying the file to each client’s
“Servers” folder, making server
access set up a snap for the entire
group.



Tip

To administer a served catalog
without unserving it, change
access to Administrator level
(page 194) after the catalog has
been opened.
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4. Select the desired catalog from the list, then click
“Open Catalog,” or double-click the selected catalog
to open it.

You will be asked to enter a password if the catalog
requires it.

The next time you “Connect to Servers,” all the servers you
added—and all available catalogs on those servers—will
be displayed on the list, ready to open.

Notes on accessing Served Catalogs:

• Windows clients must have TCP services active to access the
Server. For Macintosh clients, the machine must be using Open
Transport TCP; classic networking is not supported when
accessing catalogs on the Portfolio Server.

• The client application will attempt to open the catalog in the
mode set in the user's Preferences. 
Note: The user will be asked to enter a password if the catalog
requires it.

• For more information on installing and using the client,
administering Catalogs, and administering Servers, refer to 
the other sections of this Portfolio User Guide.
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To remove a Portfolio Server from the list:

1. Open the Connect to Servers dialog (File > Connect to
Servers).

2. From the list of available Portfolio Servers, select the
Server that you wish to remove.

3. Click “Remove Server.”

The server will be removed from your list.

4. Click “Done” to return to Portfolio. 

To change the Name and/or IP Address of a Portfolio Server:

1. Open the Connect to Servers dialog (File > Connect to
Servers).

2. From the list of available Portfolio Servers, select the
Server that you wish to edit.

3. Click “Edit Server...”

4. Make the appropriate changes, then click “OK.”

5. Click “Close” to return to Portfolio.



Viewing Catalog Items in the Gallery

When items are cataloged in Portfolio, a record is created for
each one, and information about the item is stored in this record.
Item information can include keywords, descriptions, and custom
fields that you create, as well as the item thumbnail, source file
name, creator, creation date, source file location, and other
information gathered automatically when the item is cataloged.
A Catalog is therefore a collection of records that provides
information about the items contained in it. 

When you view catalog items in Portfolio you are actually view-
ing the information contained in each item’s record, such as the
item thumbnail, description, and keywords. Your window to these
records is called the Gallery. 

The Gallery: The Gallery is the main window into a Portfolio cat-
alog. A Gallery represents a layout and a specific set of records in
a catalog. A Gallery window is opened automatically each time
you open a catalog, unless you choose otherwise.

You can create and open multiple numbers of galleries. You can
even name your Galleries and save them for future use. 

A special type of Gallery, called a Find Gallery, allows you to
open a Gallery window using a “Saved Find.” For example, you
might want to use this feature to automatically capture any new
images added since the last time the Gallery was viewed. Standard
Galleries are discussed on page 60; Find Galleries on page 65.

Gallery Views: There are three different Gallery views:
Thumbnail, Record, and List views. The different views allow you
to display and view catalog records in a variety of ways. Each of
these views are shown on page 11, and pages 30-32; customizing
the different views starts on page 99.

Toolbar: A Toolbar at the top of the Gallery window gives you
quick and
easy access

to some of the more commonly used functions and options in
Portfolio. To learn more about the Toolbar, see page 35.

Find: You can specify which catalog items you want to view in
the Gallery by using the Find function (page 41). You can
view all the catalog items at once, or locate items matching
specified criteria. You can save find criteria for future use, and
easily access these finds from the Finds palette.

Tip

To hide the Toolbar:

Mac OS: From the View menu,
select Toolbars > None. Win-
dows: From the View menu, de-
select (uncheck) Toolbars.
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Switch Views: You can easily switch between Gallery views
using buttons on the Toolbar. The three Gallery views are:
Thumbnail view , List view , and Record view , or by
selecting the desired item from the View menu. 

Customize Views: Each Gallery view can be customized to
show as much or as little information as you require. You can
even customize the way that thumbnails are displayed—changing
the display size, adding background colors, and even thumbnail
borders. See page 99.

Multiple Galleries: You can create new Galleries to display
as many or as few cataloged items as you wish, drag and drop
items between Galleries, and save Galleries by name for viewing
at any time. This allows you to have a large number of items in a
catalog, yet be able to limit the view to a small number of specific
items. You can customize the view in each gallery, and save
galleries for viewing at a later time. When you make changes to a
Saved Gallery, an asterisk (*) appears beside the Gallery name in
the title bar. Saved Galleries can be easily accessed from the
Galleries palette (page 61) or from the Saved Galleries menu
in the toolbar.

There are a number of other things you can do with cataloged
items in the Gallery window. These procedures are summarized
on page 33, and described in detail throughout this User Guide.

Tip

Saved Galleries (except Saved
Find Galleries, which are updated)
do not change even when items
are added to the catalog. This
feature allows you to create
snapshots of specific catalog
items in specific views, and easily
access them at any time. You
must have Publisher or higher
level access to save Galleries.
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Gallery—Thumbnail View
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Thumbnail view displays catalog items
as thumbnails, with item information dis-
played below the thumbnail. The
Toolbar is shown at the top of the
Gallery window (Mac OS) or Portfolio
window (Windows).

A Title bar: Displays the Catalog name
followed by the Gallery name.
Multiple unnamed Galleries are dis-
played with “Untitled” followed by a
number (representing the order in
which the Gallery was opened). For
example: Untitled 1, Untitled 2, etc.

B Number of Items: Shows how many
items are displayed in the current
Gallery window out of how many total
items in the Catalog. (On the Mac OS,
this number is at the bottom of the
window.)

C Thumbnail: Displays a thumbnail of
each item selected for display in the
Gallery. You can change the size of
the displayed thumbnail from the Cus-
tomize dialog (Click Customize ).

D Item Fields: Lists information about
the item. You determine what fields
are displayed here by selecting them
in the Thumbnails tab of the View >
Customize dialog.
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List view displays catalog items as a list,
allowing you to search quickly by name
and/or location. You can specify what
information will appear in the columns;
thumbnail, keywords, and description for
the selected item are always displayed
at the bottom of the window.

A Title bar: Displays the Catalog name
followed by the Gallery name. Multiple
unnamed Galleries are displayed with
“Untitled” followed by a number (rep-
resenting the order in which the
Gallery was opened). For example:
Untitled 1, Untitled 2, etc. An asterisk
(*) after the Gallery name indicates
that the Gallery has changed since it
was last saved. 

B Toolbar: Gives quick and easy access
to major catalog commands.

C Column Names: Click a column name
to sort by that attribute. Drag a
column divider to widen or narrow a
column.

D Item List: Displays columns of infor-
mation as specified in View >
Customize.

E Number of Items: Shows how many
items are displayed in the current
Gallery window out of how many total
items in the Catalog.

F Thumbnail: Displays a thumbnail of
the currently selected item.

G Keywords: Displays keywords for the
selected item, and indicates how
many other items in the catalog have
the same keyword assigned. Double-
click a keyword to locate all the items
with that keyword and display them in
the current Gallery window.

H Description: Displays description text
for the selected item.

Gallery—List View
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Gallery—Record View

Record view gives you the ability to see
more information about a catalog item
than you can easily see in any other
view. You can scroll the Record list to
see additional items.

A Title bar: Displays the Catalog name
followed by the Gallery name.
Multiple unnamed Galleries are dis-
played with “Untitled” followed by a
number (representing the order in
which the Gallery was opened). For
example: Untitled 1, Untitled 2, etc.

B Toolbar: Gives quick and easy access
to major catalog commands.

C Thumbnail: Displays a thumbnail view
of the selected catalog item.

D Record with Information Fields: Lists
information about the item. You deter-
mine what information is displayed
here by selecting it in the Record tab
of  the View > Customize dialog.

E Number of Items: Shows how many
items are displayed in the current
Gallery window out of how many total
items in the Catalog. (On Windows,
this number is at the top of the win-
dow.)

F Field Name: Specify show or hide
Field Names from the Record tab of
the View > Customize dialog.     

G Edit in Place enabled: Edit in place
allows you to change field information
(add keywords, change description,
etc.) right in the field. Choose View >
Customize. From the Record tab,
click “Edit.” See page 146 for more
information on this feature.

This example also shows list view
enabled. This allows you to view multi-
ple records  in Record View. To enable
listing in Record View, choose View >
Customize. From the Record tab, click
“Display as List.” 
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Sort the items in a Gallery window Click a column heading (List View) or choose one of the “by” commands 
from the View menu. Default is the order in which the items were added
to the catalog. You can also use options on the sorting palette (page 57).
“Keep Sorted” option (page 57) allows you to maintain a selected sort.

Reorder items in a Gallery window Drag the item(s) and drop where you want them to appear. Galleries revert
to the order cataloged after each search.

Select items  Click the item row (List view) or thumbnail (Thumbnail view). To add 
another item to the selection, press Command (Mac OS) or Ctrl (Win-
dows) while clicking the item. To select a contiguous range of items, press  
Shift (Mac OS) or Shift (Windows) while clicking on the first and last item.

Preview an item  Double-click the item’s thumbnail. Or select the item, then select
“Preview Original…” from the Item menu.

Display an item’s properties  Select the item, then choose “Item Properties…” from the Item menu. Or
press Command+I (Mac OS) or Alt+Enter (Windows).

Edit an item’s source file  Select the item, then choose “Edit Original” from the Item menu.

Edit an item’s keyword list  Select the item, then choose “Item Properties…” from the Item menu. Edit
keywords in the Keywords tab. Or enable editing in Record View (page 147).

Edit multiple items’ keyword list Select the items, then choose “Edit Keywords…” from the Item menu.

Add items to a Catalog* From the Finder (Mac OS) or Explorer (Windows), select the item(s) to be    
added, then drag and drop them  into an open Gallery window in the desired
catalog. Or choose “Add Items” from the Catalog menu (see page 119).

Copy items to another Gallery Drag the item thumbnail(s) (or rows) and drop in the other Gallery window. 
in the same Catalog Or use the standard system copy and paste functions to copy items 

from one Gallery to another.

Copy items to a Gallery Drag the item thumbnail(s) (or rows) and drop in the other Catalog. The
in a different Catalog* item is copied to the catalog unless it already exists. Or use the standard

system copy and paste functions to copy items to another catalog. 

Move items to another Gallery Select the item(s) to be moved, then use the standard system Cut and 
Paste functions [Command+X and Command+V (Mac OS) or Ctrl+X and
Ctrl+V (Windows)] to cut cataloged items from one Gallery and paste
them into another. If the Gallery belongs to another Catalog, the items
are copied to the Catalog*.

Delete items from a Gallery Select the item(s) to be deleted, then press the Delete key. Or use the 
standard system Cut function [Command+X (Mac OS) or Control+X 
(Windows)] to remove the item(s). This deletes items from the Gallery 
without deleting them from the Catalog.

Delete items from a Catalog* Select the item(s) to be deleted, then choose “Delete Items” from the 
Catalog menu. From the Delete Items dialog, choose “Delete from  
Catalog.” Or select the item(s) and press Option+Delete (Mac OS)
or Ctrl+Backspace (Windows).

Copy items to another application Drag and drop the selected items into an open document in the receiving
application. The application must be drag and drop aware. For more
information see page 59.

* Requires Publisher or higher level access to the open catalog.

To do this... Follow this procedure...

Working with Items in the Gallery



Contextual Menus

Portfolio displays menu commands on contextual menus for three
separate features: Items (individual records), Gallery windows,
and item Previews. A contextual menu is a menu that pops up
when you press the Control key while clicking the mouse (Mac
OS, if the Contextual Menus Extension is enabled) or Right-click
the mouse (Windows), in the appropriate area of a window. 

Item contextual menu: To access the contextual menu for an
item, select the item, then Control-click (Mac OS) or right-click
(Windows).

Gallery contextual menu: To access the contextual menu for a
Gallery, Control-click (Mac OS) or right-click (Windows)
anywhere in the unused area of a Gallery window (Mac OS: You
can even click in the scroll bars and Toolbar)—but be sure that
you do not accidentally select a cataloged item or a button when
you click.

Preview contextual menu: To access the contextual menu for an
item when the Preview window is active, Control-click (Mac OS)
or right-click (Windows) anywhere in the Preview window.
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The Toolbar

The Toolbar at the top of the Gallery window (Mac OS) or
Portfolio application window (Windows) allows you to easily
access many of Portfolio’s commonly used features, including
QuickFind, a fast way to find items in the catalog without
opening the Find window. As you place the mouse over each
button, the button Tool Tip is displayed, indicating the button’s
function.

Windows only: The last ten QuickFinds performed are listed on
the QuickFind drop-down menu.

The Toolbar
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Macintosh Toolbar

Windows Toolbar

A New Catalog: Create and save a
new catalog.

B Open: Click to locate and open an
existing catalog.

C Connect to Servers: Click to select a
Portfolio Server.

D Always on Top: (Windows only) Click
to keep the Portfolio application win-
dow frontmost, even when another
application is active.

E Help: Click to open the Portfolio
online Help index.

F QuickFind Text Box: Type a keyword
to match in a search. (Windows only:
Choose a previously entered word
from the pop-up list.) Press Return or
Enter to initiate the search. Quick-
Find uses the "starts with" search
criteria and searches only keywords;
the results are displayed in the cur-
rent Gallery. You can choose to open
a new Gallery for QuickFind results
from the Edit > Preferences dialog.

G QuickFind - Find Now: (Windows
only) Click to perform a search using
the word displayed in the QuickFind
text box (see (F)).

H Find: Click to open the Find dialog.

I New Gallery: Click to create a new
Gallery window for the active catalog.

J Saved Galleries Pop-up: Allows you
to choose from a list of saved
Galleries for the active catalog.

K Saved Finds Pop-up: Allows you to
choose from a list of saved finds for
the active catalog.

L Thumbnail View: Click to change to Thumbnail view.

M List View: Click to change to List view.

N Record View: Click to change to Record view.

O Customize Gallery: Click to open the Customize Gallery dialog, allowing you to
change the type and the look of information displayed in any Gallery view.
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Palettes

Palettes provide easy, visual access to many Portfolio features and
options. All the features available from palettes are also available
from pull-down menus in the menubar. Having these features
available on palettes allows you easy access and will make using
Portfolio quicker and easier than ever.

There are six palettes: Galleries, Finds, Sorting, Catalogs,
Categories and Master Palettes (predefined lists of words for a
field, including Master Keywords). Each of these palettes is
described in detail later in this manual. Palettes are catalog
specific. That is, when you change catalogs, palette information
changes to reflect the current catalog.

To show or hide a palette:

• Select the desired palette or function from the Window
menu. If the palette is visible on the desktop, click its
tab to activate it. 

The selected palette will appear on the desktop. If the
palette is docked on another palette, it will be moved to the
front of the palette. Hiding a palette also hides all the
palettes docked on that palette.

Portfolio Dockable Palettes

Dock and undock as often as you like to
keep your workspace organized the
way you like it.

A Docked palettes: Dock as many or as
few palettes as you like by simply
dragging a palette by its tab and
dropping it over another palette. 

B Undocked palettes: Undock a palette
by dragging it by its tab and dropping
away from where it was docked. 

A B
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To dock a palette:

• Click on the palette tab of the palette you wish to dock,
then drag it over the destination palette. When the
palette you are moving is positioned over the destination
palette, drop the palette. 

The newly docked palette will assume the right-most
position on the palette. Click a palette tab to activate it.

Mac OS: A black outline inside a palette indicates that the
palette is ready to receive the palette being moved.

To undock a palette:

• Click on the palette tab of the palette you wish to move,
then drag it away from the grouped palette. When the
grouped palette loses its outline, drop the palette you
are undocking. 

The palette will appear by itself.

Tip

Portfolio dockable palettes work
just like the palettes in popular
graphics programs.
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To move a palette without docking it:

• Click in the Title bar or palette tab of an individual
palette, or in the Title bar only of a docked group, then
drag and drop at the new location.

You can move palettes anywhere you like. 

When moved close to another palette, Portfolio palettes
will automatically be aligned beside each other neatly.



Searching the Catalog Using Keywords

A keyword is a word or phrase that you associate with a particular
item, and a good keyword list can be a valuable tool for finding
the material you need in a catalog. Each catalog item can have an
unlimited number of keywords associated with it.  

Item keywords are available for display in every Gallery view
(see “Customizing Gallery Views,” page 99) so that you can
easily see which keywords are assigned to an item, and have easy
access to other items with the same keyword. 

The number to the right of the keyword indicates how many  other
items in the catalog have that keyword assigned. 

From List view and Record view you can have Portfolio locate
and display all the items with a particular keyword by double-
clicking the desired keyword in the Keywords list. All items with
the selected keyword will be displayed in the active Gallery
window. 

Quick Find: You can also search for keywords using the
QuickFind field on the Toolbar at the top of the Gallery window
(Mac OS) or Portfolio window (Windows) (see page 35).

Tip

In a network environment, a cata-
log administrator (using catalog
access levels), can control who is
allowed to edit item keyword lists
for each catalog. In addition, a
catalog can include a preset list of
Master Keywords. Master Key-
words can help maintain consis-
tent keywords among the items in
a catalog, or across catalogs; see
“Catalog Administration,” page
202, for information on maintain-
ing the list of Master Keywords.

Tip

To find all the items with a particu-
lar keyword when you aren’t sure
what the keyword is (and no Mas-
ter Keywords list exists), choose
Catalog > Catalog Properties.
Select the Statistics tab, then click
the “Calculate” button. This builds
a list of all keywords in the cata-
log. Note: This can be slow in cat-
alogs with a large number of
records. Look through the key-
words listed, then double-click on
a word that looks like it might fit
your search. This locates all the
items matching that keyword and
displays them in the current
Gallery window.  
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Searching from the Master Keywords List
If you create a list of Master Keywords for your catalog 
(page 202) you can find multiple items with specific keyword(s)
assigned to them using the Master Keywords Palette. 

To use the Master Keywords palette, choose Window > Master
Palettes > Master Keywords or press Command+K (Mac OS) or
Ctrl+K (Windows). Locate the desired keyword on the list, then
click “Find” or double-click the keyword. All items with the
selected keyword will be displayed in the active Gallery window.
Windows: Select an item and type the letter of the keyword that
you want to find to scroll the list to entries starting with that letter.
Mac OS: Type a letter in the text entry field of the Master
Keywords palette to move the cursor to the entries starting with
that letter.

Searching from other Master Palette Lists
As well as the Master Keywords list, Portfolio allows you to
create pre-defined lists of words associated with any custom field.
For more information, see page 156.
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Searching the Catalog Using Find Options

You can search for catalog items by examining the items in any
of the Gallery views, or you can speed your search using
Portfolio’s Find function. You can search any field, including
Custom fields and keywords. Creating and adding keywords and
custom lists is discussed in detail on pages 202 through 212.

You will probably find that you will use different search strategies
at different times. For example:

• If your catalog is small or you’re looking for ideas, you might
start by looking through everything the catalog contains.

• If your catalog is very large or you have a general idea of what
you’re looking for, you might want to look only at items related
to a particular subject or concept, or of a particular file type.

• If you’re in the final stages of a job, you probably know exactly
what items you need.

Portfolio can display the results of the search in the current
Gallery window (completely replacing the previous contents, if
any), or in a new Gallery window. 

To open the Find window:

• Click the Find button on the toolbar.

— or —

• Choose “Find” from the Catalog menu.

— or —

• Press Command+F (Mac OS) or Ctrl+F (Windows).

To display the entire contents of a catalog:

• Choose “Find All” from the Catalog menu.

— or —

• Open the Find window and click the “Find All” button.

— or —

• Open the Finds palette and click the “Find All” button.

— or —

• Press Command+' (Mac OS) or Ctrl+' (Windows).
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The Find Window
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Criteria Tab

Enter a single search description for a
simple search, or choose “More
Choices” to perform a complex search
(see following page). 

A Criteria tab

B Saved Finds Pop-up: Specify and
select search criteria for later use.
See “Saving Finds” on page 48.

C Catalog name: Displays the catalog
to be searched, or displays “Multiple
Catalogs” during a multiple catalog
search.

D Search Field: Select the search
criteria.

E Search Options: Select an option to
focus the search criteria. 

F Search Word or Phrase: Type a
value to search for. 

G Find in gallery: Searches the items
in the current Gallery only. Allows
you to perform multiple searches to
narrow the field.

H New Gallery: Click to display found
items in a new Gallery window.

I Search Multiple Catalogs: Click to
extend the search to catalogs
indicated in the Catalogs tab (Mac
OS) or Catalogs palette.

J More Choices: Click "More
Choices…" to display the expanded
window (see following page). 

K Find All: Click to find and display all
items in the Catalog.

L Find: Click to start the search. 

Mac OS: Catalogs Tab

Use this tab to select catalogs to be
searched. Catalogs must be open and
available to appear on the list. Note:
This tab provides the same functionality
as the Catalogs palette; changing an
option on one also changes the other.

M Catalogs tab

N List of currently open catalogs

O Find: Click to start the search. 

P Search: Icon indicates that this cata-
log will be included in the search.

Q Do not search: No icon indicates that
this catalog will not be searched.
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Click “More Choices” to expand the
Find window so you can perform a
complex search. Click “Fewer Choices”
to contract the window for simple
searches (see previous page).

A Saved Finds Pop-up: Specify and
select search criteria for later use. To
save a find, select Save As from the
Saved Finds pop-up menu. 

See “Saving Finds” on page 48.

B And/Or: Select "and" to narrow the
search; "or" to broaden it. 

C Search Field: Select the search
criteria. Any field can be searched.

Options are: Filename, Path,
Extension Win, Short Filename Win,
Description, Volume, Created, Last
Modified, Cataloged, Last Updated,
File Size, Keywords, File Type Mac,
Creator Mac, Zone Mac, Thumbnail
Size, Color Mode, Horizontal
Resolution, Vertical Resolution,
Width, Height, Category, Multipage
Count, PlaceHolder, Watermarked,
Watermark URL, and any Custom
Fields.

D Search Options: Select an option  to
focus the search criteria. 

E Search Word or Phrase: Type a
value to search for. 

F Find All: Click to find and display all
items in the Catalog.

G Find: Click to start the search. 

Notes: 1) Find searches both fields
(Title and URL) of a URL Custom Field.
2) Portfolio searches for values in the
Height and Width fields in pixels; con-
vert other units of measure to pixels
prior to entering values in these fields.

Complex Finds

B
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A
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To find specific items in a catalog:

1. Open the Find window.

Portfolio opens the Find window and displays the default
saved Find, if any exists.

2. Use the Criteria tab in the Find window to describe
what you are looking for, then click “Find.”

Portfolio lets you search for various attributes of an item,
including filename, keyword, file size and so on. See the
table on page 43 for a description of the attributes you can
use in your search. Find searches both fields (Title and
URL) of a URL Custom Field.

Found items are displayed in the Gallery window, replacing
the items there. You can elect to have the found items dis-
played in a new Gallery window by clicking “Display
results in new gallery” option before you initiate the Find.

Using QuickFind

You can quickly locate catalog items in the currently active
Gallery by keyword using the QuickFind field on the Toolbar.

To find items in a catalog using QuickFind:

1. Type in the keyword that you want to search for in the
QuickFind text box located on the Toolbar at the top of
the window.

Windows: You can select previously searched for items  by
selecting the word or phrase from the QuickFind pop-down
menu.

2. Press Return or Enter.

This initiates the search. 

QuickFind uses the “starts with” search criteria and
searches only keywords; the results are displayed in the
current Gallery unless you indicate otherwise in Edit >
Preferences. 

Tip

Since Portfolio stores all the infor-
mation about an item (including its
thumbnail) you do not need to
mount volumes referenced in the
catalog in order to search for and
view them.

When you attempt to Preview or
work with the original item in any
way (such as dragging and drop-
ping it into another application),
Portfolio will prompt you to mount
the volume where the original item
is stored, if it is not already
mounted.
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Cataloged The date and time that an item was first cataloged in Portfolio

Color Mode Color modes: Unknown, Black & White, Grayscale, RGB, CMYK,    
YUV, Lab, and YCCK

Created The date the source file was created

Extension Win The item’s three-character file extension

Description The item’s file description

File Size The item’s file size

Filename The item’s name

Height The item’s height, in pixels

Width The item’s width, in pixels

Horizontal Resolution The item’s horizontal resolution, in dpi

Vertical Resolution The item’s vertical resolution, in dpi

Keywords Any keywords assigned to the item(s)

Last Modified The date the source file was last modified

Last Updated The date the item was last updated in the catalog

Creator Mac The four-character file creator code for the item (empty if cataloged on

Windows)

File Type Mac The four-character file type code for the item (empty if cataloged on
Windows)

Zone Mac AppleTalk Zone where item’s file is located (empty if cataloged on 
Windows)

Path The file path (location) for the item

Short Filename Win 16-bit DOS path and filename

Thumbnail Size The item’s thumbnail size, in pixels: 32 (icon), 112, 256. (This field will be
empty in catalogs converted from Portfolio 3.0, until the thumbnails are
regenerated.)

Volume The physical drive or disk on which the item resides

All fields are indexed for faster searching.

List is continued on following page

This option... Finds...

Search Criteria Options
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Category Items matching the indicated category (from Categories palette)

Multipage Count Items matching a particular page count

PlaceHolder Items created as PlaceHolder Records

Watermarked Items with the indicated watermark

WatermarkURL Items with the indicated watermarkURL

Custom Fields Any custom fields that have been created for the current catalog

All fields are indexed for faster searching. 

This option... Finds...

Search Criteria Options
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Streamlining Searches

Portfolio has several options that can help you search through a
catalog quickly and effectively. For example, you can:

• Select the most efficient searches for Portfolio to carry out.
• Name and save frequently used searches (to save yourself from

having to re-enter the criteria each time).
• Customize the default search displayed when you open the Find

window.

Indexing

Portfolio 5.0 indexes all fields to speed searching. Fields, including
the Text Block Custom Field(page 212)are indexed at the word
level, which means that you can search these fields quickly by
individual words but not by phrases.

When you search on indexed fields, choose “matches” or “starts
with” from the modifier pop-up menu for the fastest searches.
Other types of searches may be somewhat slower because
Portfolio must examine every entry in the catalog:

• Searching is slower when there is a large number of items that
match your search criteria.

• Searching using “contains” or “ends with” is slower when the
catalog is large.

You can also sort the Gallery window on any indexed field (such
as Catalog order, File Name, File Type, Creation date, Custom
Fields, etc.), except Text Blocks. See page 57.

Date/Time Fields

Times are always assumed when searching fields of the type
“Date/Time,” even if a time is not entered, and when the “Display
Time” option for the field is disabled. That is, if a time value was
entered into the field (either by extraction from the source file when
the item was cataloged or by entering a time in the field) and then
hidden by turning off “Display Time,” the time will still be noted
by Portfolio when a search is requested. For example: Searching
for “9/15/99” will not find a record which contains “9/15/99 3:00
pm” because the request is interpreted as “9/15/99 12:00:00 am.”
This is true even if the time is not being displayed.

Note: Portfolio stores dates following the computer’s Date and
Time settings. If Short Dates are used, Portfolio only records the
last two digits of the year, possibly resulting in erroneous find
results. To avoid this potential problem, use the operating system’s
Long Dates format.



Tip

Saving Finds requires Publisher
or higher level access to the open
catalog. See page 194.

Saving Finds

If you routinely need to locate particular types of items in a
catalog, you can name and save a Find that will retrieve those
items.

Your saved finds appear in the Saved Finds pop-up menu in the
Find window. Whenever you want to use a Saved Find, choose its
name from the menu or select the Find from the pop-down menu
using the Saved Finds button on the Toolbar.

To Save a Find:

1. Set up your search in the Find > Criteria tab.

You might want to execute the search to verify that your
specified search criteria is correct.

2. Choose “Save As…” from the Saved Finds pop-up
menu. 

3. Type a name for the new find in the Save Find dialog
box that appears.

4. Click “OK” to return to the Find window.

Portfolio stores the search definition you just created in the
catalog.
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The Default Find

Each time you open the Find window (or choose “Default” from
the Saved Finds pop-up menu) Portfolio populates the search
fields and pop-ups with the attributes specified in the Default
Saved Find. You can edit the Default Find so that it will retrieve
the items you use most often. 

To change the Default Find:

1. Open the Find window and set up the search fields as
you want them to be by default.

2. Choose “Save as Default” from the Saved Finds pop-up.

— or —

1. Select “Default” on the Finds palette, choose Edit Find
from the fly-out menu, then choose “Save as Default” or
“Save” from the Edit dialog.

2. Set up the search fields as you want them to be in the
default find.

You can change the Default Find as often as you want.
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Tip

You will need to specify a Default
find before you can access it from
the Finds palette.



Executing Saved Finds

You can view and select Saved Finds in several ways:

• From the pop-up menu in the Find > Criteria tab

• From the Finds palette

To execute a Saved Find:

1. Open the Find window to the Criteria tab. 

2. Choose the desired Saved Find from the Saved Finds
pop-up menu.

3. Click “Find.”

Tips

You can have Portfolio automati-
cally perform a Saved Find when a
Saved Gallery is opened. This
allows you to also display any new
records added (matching the Find
criteria) since the last time the
Saved Gallery was viewed. See
page 65.
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Finds Palette

The Finds palette allows you to easily
select and work with Saved Finds.

To show the Finds palette, choose
“Show Finds” from the Window menu.

A Finds palette tab

B Saved Finds: All previously Saved
finds, including the Default find, are
listed here. Double-click an entry to
perform that find and display the
results in the active gallery. 

C Finds pop-up menu: Allows you to
easily work with Saved Finds.
Options include Find, Find all, Clear
Gallery, Edit Find, Delete Find,
Rename Find

D Find: Select a Saved Find on the list,
then click this button to perform the
selected Find. 

E Find all: Click to locate and display all
the records in the catalog.

F Clear: Click to clear the active gallery.
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— or —

1. Activate the Finds palette. 

2. Select the desired Saved Find from the Saved Finds list.

3. Click the “Find” button.

You can also double-click any entry on the list to execute
the find.

Editing Saved Finds

You can change the search parameters of your Saved Finds,
rename them, duplicate, or delete them. 

Note: To create a Default find, open the Find dialog, then set the
find criteria. Select “Save as Default” from the pop-up menu (see
page 49).

To change the attributes of a Saved Find:

1. From the Find > Criteria tab, choose the Find you want
to change from the Saved Finds pop-up menu.

The criteria for the selected Saved Find will be displayed
in the Find > Criteria tab.

— or —

1. From the Finds palette, choose the Find you want to
change.

2. Choose “Edit Find” from the fly-out menu.

The Find > Criteria tab will be opened with criteria for the
selected Saved Find displayed.

3. Modify the search criteria and choose “Save” from the
Saved Finds pop-up menu.

The new search criteria are applied to the Saved Find.
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Tip

You can quickly execute a Saved
Find by double-clicking the desired
name on the Finds palette.
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To Rename, Duplicate, or Delete a Saved Find:

1. From the Find > Criteria tab, choose “Edit List…”
from the Saved Finds pop-up menu.

The “Saved Finds” dialog box appears.

2. From the list, select the Saved Find that you want to
edit. 

3. Click the appropriate button to Rename, Duplicate or
Delete the Find.

4. Click “OK” to return to the Find window.

The changes are made to the Saved Find.

— or —

1. From the Finds palette, select the Find that you want to
rename or delete. 

2. From the fly-out menu, choose Delete Find... or
Rename Find... depending on what which task you want
to perform.



Searching Across Multiple Catalogs

Portfolio 5.0 allows you to access multiple open catalogs, and to
find items by searching multiple open catalogs. 

Note: You can keep track of open catalogs, and perform many
catalog functions from the Catalogs palette (Windows > Show
Catalogs). The Catalogs palette is discussed in detail starting on
page 115.

To Search multiple catalogs:

1. Open all catalogs that you wish to include in the search.

Open catalogs will be displayed on the Catalogs palette
(Mac OS: also on the Catalogs tab of the Find window
(Catalog > Find). 

You do not need to include a catalog in a search just
because it is open, but you cannot search through closed
catalogs.

2. Open the Catalogs palette (Window > Show Catalogs)
(or, Mac OS: Open the Find window [Catalog > Find,
or Command+F] and select the Catalogs tab).

3. Optional: De-select any catalogs that you do not wish to
include in the search by clicking to the left of the name
so that the icon disappears. 

An icon to the left of the Catalog name indicates that this
catalog will be included in the search. No icon indicates
that the catalog will be excluded from the search.

Mac OS: The catalog list on the Catalogs tab of the Find
window matches exactly the catalog list on the Catalogs
palette. Changes to the list on one palette affect the catalog
list on the other.
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Note

Searching Across Multiple
Catalogs applies to Portfolio
Network and Portfolio Server
Editions only.



5. Important! In the Find dialog (Mac OS: choose Criteria
tab) enable “Search Multiple Catalogs.”

A checkmark in the Search Multiple Catalogs checkbox
indicates that the catalogs specified in the Catalogs tab will
be searched.

Note: Enabling multiple catalog searching forces the found
results to be displayed in a new gallery.

6. If the criteria for your Find has already been specified
(on the Criteria tab of the Find window), click “Find.”
Otherwise, enter desired search parameters on the
Criteria tab and then perform the Find.

The set of fields displayed in the Fields pop-up on the
Criteria tab is the set of fields common across all selected
catalogs. The field name and type (including precision,
indexing, etc.) must match for the field to be included.
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Finding Placeholder Records

You can easily locate all of the placeholders that you created so
that you can keep track of which placeholders you have created,
update one or more placeholders from the source file, or delete
them if they are no longer needed.

To find all Placeholder records:

1. From the Catalog menu, choose “Find Placeholder
Records.”

A new Gallery will be opened, and all the Placeholder
records will be displayed. 

For information on updating a Placeholder when the source
file is available, see page 91. 
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Finding Document Text

The Find Document Text command allows you to find words or
phrases within the text of cataloged documents, as opposed to in
the item’s record, as with other Portfolio word searches.

To find text in a cataloged document:

1. From the Catalog menu, choose “Find Document
Text...” (Catalog > Find Document Text)

2. Enter the words or phrases that you wish to search for.

3. Choose the desired search criteria from the pop-up
menus.

4. Select the display options from the Options section of
the dialog.

5. Click “Find” to initiate the search.

Documents meeting the search criteria will be displayed.

Find Document Text

The Find Document Text dialog allows
you to search for words or phrases
within the text of cataloged documents,
rather than in the item’s record as with
all other word searches.

A Words to Find: Enter the word or
phrase you wish to search for.

B Criteria: From the pop-up menus,
choose the search criteria. “all” finds
all documents meeting the criteria;
“any” finds any document meeting
the criteria. Other criteria allows you
to indicate different matches for the
word or phrase.

C Options: Select any combination of:
Find in Gallery, Search Multiple
Catalogs, and/or Display Results in
New Gallery.

D Find: Click to initiate the find.

B
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Sorting and Reordering Gallery Items

You can sort on any field in the catalog, including Custom Fields.
You can use the “View by” options from the View menu to
quickly sort items in the active Gallery, or simply select sort
orders from the Sorting palette. 

To Sort the active Gallery:

1. From the Sorting palette, click a field name to sort the
active gallery by that field. Click the name to toggle the
sort between Ascending and Descending sort, or choose
Ascending or Descending from the palette fly-out menu. 

— or —

1. Choose a sort “by” option from the View menu.

Sort options on this menu include: by Cataloged, by
Filename, by File Type Mac, by Extension Win.

Sorting Palette

The Sorting palette allows you to easily
change the sort order of a Gallery.

To show the Sorting palette, choose
“Show Sorting” from the Window menu.

A Sorting palette tab

B Sort Order: Current sort field is dis-
played in bold. Click a field on the list
to sort by that field. Custom fields
can also be used for sorting. 

Arrow indicates Ascending or
Descending sort. Click to toggle
between the two.

C Sorting fly-out menu: Allows you to
select Ascending or Descending
sorts. See also (B).

D Keep Sorted: Click to maintain cur-
rent sort order even when new
records are added. With this option
enabled, attempting to rearrange
records in a gallery by dragging them
simply causes the records to snap
back to their sorted location.
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— or —

1. Choose “by Other...” from the View menu, or press
Command+Option+D (Mac OS) or Ctrl+Shift+D
(Windows).

The View by Other dialog box is displayed.

2. From the list, choose the type of sort, and choose
“Ascending” or “Descending” order.

3. Click “OK” to sort the list and return to the Gallery
window.

To manually Reorder items in the active Gallery:

1. Select the item thumbnail(s) that you wish to relocate,
then drag them to the new location.

Note: Changes to the Gallery view, such as adding items to
the Gallery, may undo these changes (see sidebar Tip).

Note: If “Keep Sorted” has been selected on the Sorting
palette, attempts to manually reorder the records by
dragging will simply result in them snapping back to their
sort location.

Tip

To maintain the new sort order,
enable “Keep Sorted” on the
Sorting palette, or save the Gallery. 
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Dragging and Dropping Catalog Items into Other
Applications

Mac OS: On the Macintosh, you can drag items from Gallery
windows into any application that supports drag and drop.
Extensis provides drag and drop support for QuarkXPress with
the “Extensis QX-Drag&Drop” XTension located on the Extensis
CD. Run the Extensis QX-Drag&Drop Installer to add this
XTension to the QuarkXPress XTensions folder.

Windows: On Windows PCs, you can drag and drop items from
Gallery windows into any application that supports OLE drag-
and-drop. Check your application’s documentation for informa-
tion on OLE drag-and-drop support.

To place one or more Catalog items into a Drag and Drop
aware application:

1. In the Catalog Gallery window, select the item(s) you
wish to place into a drag-and-drop capable document.

2. Drag and drop the item(s) into an open document in the
receiving application.

If the receiving application can accept the item’s file type,
the item will be placed in the application.

— or —

1. Double-click the item to open the Item Preview window
(page 76).

2. Mac OS: Use the crosshair cursor to select an area to
copy, or choose “Select All” from the Edit menu
(Command+A) to select the entire image.

Windows: The item is automatically selected.

3. Choose “Copy” from the Edit menu, or press
Command+C (Mac OS) or Ctrl+C (Windows).

4. Open a document in the receiving application, then
choose “Paste” from the Edit menu, or press
Command+V (Mac OS) or Ctrl+V (Windows). 

Note: You should not use the “Copy” command (which places
items on the clipboard) to place items in other documents, unless
you do so from the Item Preview window (shown on page 77) as
indicated above. When you use the Copy command from a
Gallery window, Portfolio expects you to be copying item records
between Galleries (within or between Catalogs). 
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Opening a New Gallery

As you work with your catalog you may want to create additional
Galleries to display the items in it. You can add, rearrange, and
delete items from Galleries without affecting the items stored in
the catalog.

Note: You can have items from a “Find” request displayed in a
new Gallery by clicking the “Display results in new Gallery”
checkbox on the Find window (Windows) or Find Criteria tab
(Mac OS). See pages 42 and 43.

To move and copy items between Galleries, and to delete items
from them, see below and page 71. To copy or move items
between Catalogs, see page 74.

To open a New Gallery window:

1. Choose Window > New Gallery, or click the New
Gallery button on the Toolbar, or click the New
button on the Galleries palette, or press Command+G
(Mac OS) or Ctrl+G (Windows).

An empty Gallery will open in Thumbnail view. The name
“Untitled”( followed by a number representing the current
gallery) will appear in the title bar of the Gallery window.

You can use options on the Find > Criteria tab to
populate the gallery with records, or click the Find All
button on the Find > Criteria tab to display all the records
in the catalog.

Tip

You can easily create new galleries
and save them for future use. See
page 61.
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Saving a Gallery

Portfolio 5.0 makes it easier than ever to save galleries and view
them later. 

To Save a Gallery:

1. Make sure the Gallery window contains all the items
you want (to also customize the view, see page 99).

You can use the Find function to change the contents of the
current Gallery window, or to create a new window (see
page 44), or you can copy or drag and drop items from
other catalogs (page 74), other Galleries (page 71), or even
add new items. 

2. Sort or manually reorder the Gallery items exactly as
you want them to appear.

3. Choose “Save Gallery” from the Window menu, or
press Command+S (Mac OS) or Ctrl+S (Windows).

The “Save Gallery” dialog box is displayed.

4. Enter a name for the Saved Gallery, then click “OK.”

Your Saved Gallery will appear on the Saved Gallery list
on the Window menu, and on the Galleries palette.

Tip

Saving Galleries requires Publisher
or higher level access to the open
catalog. See page 194.

Tip

You can quickly save the currently
active gallery using the standard
system Save command
[Command+S (Mac OS) or Ctrl+S
(Windows)].
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Viewing a Saved Gallery

Once you’ve saved your gallery, it’s easy to open it for viewing
using the new Galleries palette.

To View a Saved Gallery:

1. Open the Galleries palette (Window > Show Galleries).

2. Double-click the gallery that you want to open. Or
select the gallery name and click “Open.”

The Saved Gallery will be opened in a new gallery win-
dow. The name of the Saved Gallery appears in the title bar
of the Gallery window.

Galleries Palette

The Galleries palette allows you to
view and work with previously Saved
Galleries. Double-click any Gallery on
the list to open it.

To show the Galleries palette, choose
“Show Galleries” from the Window menu.

Note: Until you save a gallery (page 61)
the Saved Galleries list is blank.

A Galleries palette tab

B Saved Galleries list: Lists all the pre-
viously Saved Galleries in the current
catalog.

Icon indicates whether the gallery is
a standard Saved Gallery or Find
Gallery. Find Galleries, when
opened, automatically perform the
Saved Find associated with them.
See page 65.

C New: Click to create a new, empty
Gallery.

D Open: Click to open the Gallery
selected from the list.

E Fly-out menu: Allows you perform
any of the following operations on the
selected Saved Gallery: Open,
Delete, Rename.
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— or —

1. From the Toolbar, choose the
gallery you want to open from the
Galleries List pop-up menu. 

— or —

1. From the Window menu, choose List Galleries to open
the Saved Galleries list.

Select the gallery that you want to open, then click “Open.”

— or —

1. Press Command+Option+G (Mac OS) or Ctrl+Shift+G
(Windows) to open the Saved Galleries list.

Select the gallery that you want to open, then click “Open.”
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More about Galleries in Portfolio 5.0

Portfolio 5.0 represents an exciting new approach to galleries.
Previously, Portfolio galleries were considered static, or unchang-
ing. Galleries are now treated as dynamic documents that can be
changed over time. The result is that Galleries are easier than ever
to create, modify, rearrange, update, and customize. 

When a new gallery window is opened, or when a Find is per-
formed that displays the found records in a new gallery, the name
“Untitled” is displayed in the title bar of the Gallery window.
“Untitled” gallery windows are numbered in the order in which
they are created. For example, after doing multiple different
searches with each result displayed in a different window, you
might have a number of galleries named “Untitled 1,” “Untitled 2,”
etc. Only unsaved galleries will have the term “Untitled” in the
window’s title bar.

As shown on page 61, you can save these galleries for future
viewing. You can add to them if you like, and customize the way
the records are presented (page 99). You can even create
slideshows of your records for presentation or as a quick way to
preview catalog items (page 109).

Once a gallery is saved, the window title bar changes to display
the name of the Saved Gallery. If any changes are made to the
gallery after it has been saved, an asterisk (*) is appended to the
name. This gives you a visual clue that the Saved Gallery has
been modified, either by a change in the record set or the layout. 

If you make changes to a Saved Gallery, when the Gallery is
closed you are prompted with options about saving those changes.

Save: Overwrites the current Saved Gallery.

Cancel: Returns to the Gallery.

Save As...: Allows you to save the changes to a new Gallery
name, preserving the previously saved gallery intact.

Don’t Save: Discards the changes and closes the Gallery.
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Standard Saved Galleries versus Find Galleries

A special type of Saved Gallery, called a Find Gallery, allows you
to automatically open a Saved Gallery using preselected Find
criteria. A Find Gallery does not contain a specific record set, but
rather has a Saved Find attached to it which is executed when the
gallery is opened. The options for creating a Find Gallery are
accessed on the Saved Options tab of the Customize Gallery
dialog.

This powerful feature lets you automatically search for and select
records (matching the specified Find criteria) that have been
added since the last time the Saved Gallery was opened, while
preserving any customized layouts for the gallery. Since a Find
Gallery changes each time records are changed, you may want to
save particular finds as a standard Saved Gallery to preserve their
contents.

To set up a Find Gallery:

1. Open a Gallery window.

2. Create a Saved Find (page 48) using the criteria that
you wish to search on each time the Find Gallery is
opened. 

3. From the View menu, choose “Customize...”. Or click
the Customize button on the Toolbar. 

The Customize Gallery dialog will be displayed. 
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3. Select the “Saved Options” tab.

4. In the Found Gallery section, select “Load Saved Find
when Opened.”

5. From the pop-up menu, select the Saved Find that you
wish to use. 

6. (Optional) Using other options available in the
Customize Gallery dialog, set up the Gallery just as you
want it be.

7. When you have completed customizing the Gallery,
click “OK.”

You will be returned to the active gallery.

8. Save the Gallery to the name of your choice.

Each time your Find Gallery is opened, the records will be
searched and selected using the Find criteria in the Saved
Find that you designated in step 5. 

To open a Find Gallery: Once a Find Gallery has been set up
and saved, select and open it for viewing just as you would any
Saved Gallery (see page 62).
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Making changes to a saved Find Gallery 

Any changes that you make to a saved Find Gallery (such as
manually adding records) can have a serious impact on future
uses of this gallery. Since Find Galleries will most commonly be
used over and over “as is” to find records matching certain
criteria, you will want to be careful not to accidentally overwrite
a Saved Find Gallery. Portfolio provides specific warnings to
prevent a saved Find Gallery from being inadvertently overwritten
as a standard Saved Gallery. 

For Example:

1. We created and saved a Find as shown on page 48. 

In this example, we created a Find to search for items with
the keyword “child.” We created a Saved Find with this
criteria and named it “Children.”

2. Next, we set up a Find Gallery using this Saved Find, as
shown on page 65, starting with step 3.

3. Then we executed the Saved Find by choosing it from
the Saved Finds list in the Find dialog (or from the
Toolbar or on the Finds palette).
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In this example, three items matching the Saved Find
search criteria were found and displayed. 

Note: When a Find Gallery is saved, the next time you
open the Gallery the Saved Find will automatically be
executed.

If you elect to add items to the Gallery, delete items from
the Gallery, or change it in any way, the Gallery is no longer
a Saved Find Gallery, and an alert is given when the Gallery
is closed.
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3. In our example, we manually added an item to the Find
Gallery from another catalog.

The forth item does not belong to the found set, and the
Gallery name (“Children”) now has an asterisk (*) after it,
to indicate that the contents of the Gallery has changed.

4. If you attempt to Save a changed Find Gallery, you will
be presented with an alert.

This is to prevent a Find Gallery from being inadvertently
overwritten as a standard Saved Gallery.
Cancel: Returns to the Gallery.
Save As...: Allows you to create a new Saved Gallery that
represents the specific record set rather than only items
searched for and displayed using the Saved Find.
Don’t Save: Discards the changes and closes the Gallery.

Deleted Items in Saved Galleries

If items that are in a Saved Gallery are deleted from the Catalog
(from any Gallery other than the Saved Gallery), the items will
still be displayed when the Saved Gallery is opened. The thumb-
nail will be indicated as “Item Deleted.” To eliminate the missing
items from the Gallery, choose Refresh from the View menu
[Command+Option+U (Mac OS) or Ctrl+Shift+U (Windows)]
then resave the Gallery.

To Delete or Rename a Saved Gallery:

1. Open the Galleries palette (Window > Show Galleries).

2. Select the gallery that you want to delete or rename.

3. From the palette fly-out menu, select either Delete
Gallery or Rename Gallery.

— or —

1. From the Window menu choose List Galleries… , or
press Command+Option+G (Mac OS) or Ctrl+Shift+G
(Windows).

The “Saved Galleries” dialog box appears. 

2. Select the Gallery you want to edit.

3. Click “Rename…” to rename the selected Gallery, or click
“Delete” to remove the Saved Gallery from the catalog.

4. Click “Done” to close the Saved Galleries dialog box.
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Open Gallery at Startup (Default Gallery)

You can set up your catalog so that a specific gallery is displayed
when the catalog is initially opened. In earlier versions of
Portfolio, this was called the “Default” Gallery.

To specify a Gallery to be opened automatically at startup:

1. Open a Saved Gallery (select it from the list of Saved
Galleries on the Toolbar, on the Galleries palette, or
from Window > List Galleries), and verify that is the
active Gallery.

2. From the View menu, choose “Customize...” (or click
the Customize button on the Toolbar), then click the
Saved Options tab.

3. In the Gallery area, click “Open at Startup.”

— or —

2. Activate the Catalogs palette.

3. From the palette fly-out menu, choose “Open Gallery at
Startup” (this may also read “Display Gallery on
Open”).

The specified Gallery will open automatically whenever
this catalog is open.

Tip

To open large catalogs more quickly,
you can disable the “Open Gallery
at Startup” option from the fly-out
menu on the Catalogs palette.

Saving your default Gallery with just
a few records will also allow the
catalog to open more quickly even
with “Open Gallery on Startup”
enabled.  
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Moving and Copying Items Between Galleries in
the Same Catalog

When you move or copy items between Galleries in the same
catalog, nothing about the individual item records in the database
changes—you are merely creating different ways to isolate and
view cataloged items. 

To copy items to another Catalog, see page 74. For information
on creating new catalogs or adding items to catalogs, see pages
113 and 118.

To Copy items between Galleries in the same Catalog:

1. Open a Saved Gallery, or create a new Gallery 
[choose Window > New Gallery, or click the New
Gallery button on the Toolbar, or click the New
button on the Galleries palette, or press Command+G
(Mac OS) or Ctrl+G (Windows)].

2. From the originating Gallery, select the item(s) that
you want to copy. To select all the items in the Gallery,
choose “Select All” from the Edit menu, or press
Command+A (Mac OS) or Control+A (Windows).

Mac OS: To drag more than 50 records at one time, hold
down the Option key when initiating the drag.

3. Drag and drop the items into the target Gallery
window.

— or —

3. With the items in the  originating Gallery selected,
choose “Copy” from the Edit menu [or press
Command+C (Mac OS) or Ctrl+C (Windows)].

4. Activate the receiving Gallery window by clicking it,
then choose “Paste” from the Edit menu [Command+V
(Mac OS) or Ctrl+V (Windows)].

The items will be copied to the new Gallery.
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To Move items from one Gallery to another:

1. Open a Saved Gallery, or create a new Gallery 
[choose Window > New Gallery, or click the New
Gallery button on the Toolbar, or press
Command+G (Mac OS) or Ctrl+G (Windows)].

2. In the originating Gallery, select the items that you
want to move. To select all the items in the Gallery,
choose “Select All” from the Edit menu, or press
Command+A (Mac OS) or Control+A (Windows).

3. Choose “Cut” from the Edit menu [Command+X 
(Mac OS) or Ctrl+X (Windows)].

4. Activate the receiving Gallery window by clicking it,
then choose “Paste” from the Edit menu [Command+V
(Mac OS) or Ctrl+V (Windows)].

The items will be removed from the originating Gallery
and added to the receiving Gallery. 

Note: Even if you do not Paste the items into another
Gallery, they are not deleted from the Catalog (see page 73).
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Deleting Items from a Gallery

When items are deleted from a Gallery, they are merely deleted
from the current view, not from the catalog. This allows you to
create Galleries that display just the images you want to see. For
example, you can use the Delete from Gallery feature after you’ve
searched for a set of images and found that it contains a few
images that you don’t want to display with the others—simply
delete the ones you don’t want in the Gallery. 

For information on deleting items from a Catalog, see page 75.

To Delete items from a Gallery:

1. From the Gallery window, select the item(s) that you
want to delete.

2. Press the Delete (Mac OS) or Backspace (Windows)
key, or choose “Cut” from the Edit menu, or press
Command+X (Mac OS) or Ctrl+X (Windows).

The selected item(s) will be deleted from the Gallery
window, but not from the catalog.

— or —

2. Choose “Delete Items” from the Catalog menu.

3. Choose “Delete from Gallery,” then click “OK.”

The selected item(s) will be deleted from the Gallery
window, but not from the catalog.

Tip

When you delete items from a
Gallery, you can verify that the
images have not been removed
from the catalog by examining the
numbers in the lower-left corner
(Mac OS) or upper-right corner
(Windows) of the Gallery window.
Only the number representing
how many items are currently
being displayed will have
changed; the number representing
the total number of items in the
catalog remains the same.
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Moving and Copying Items Between Catalogs

When you copy items between catalogs, you are actually copying
the item record (all of the information associated with the item,
including the thumbnail, the link to the original file, and any
Custom field data—if those Custom fields have been defined in
the receiving catalog). 

To Copy items between Catalogs:

1. If you have not created Custom fields, proceed to step 2.

If you have created Custom fields in the originating cat-
alog, open the destination catalog and add those
Custom fields to it.

If you do not recreate the Custom fields in the destination
catalog, Custom field information will be lost when the
records are copied.

2. In the Gallery window of the originating catalog, select
the item(s) that you wish to copy.

3. Drag and drop the items into an open Gallery window
in the receiving catalog.

— or —

3. Choose “Copy” from the Edit menu [or press
Command+C (Mac OS) or Ctrl+C (Windows)].

4. Activate the receiving Gallery window by clicking it,
then choose Edit > Paste [Command+V (Mac OS) or
Ctrl+V (Windows)].

The items and all information in the records will be copied
to the new Gallery. 

To Move items from one Catalog to another: To move items
from one catalog to another you will need to add them to the
destination catalog and then delete them from the originating
catalog. You could do this by making a copy of the catalog and
deleting the appropriate items from each, or by copying the items
to the destination catalog and then deleting them from the
originating one (using this method you would have to recreate any
Custom fields in the destination catalog—see above). Or you
could create a new catalog and add the desired items to it, then
delete the appropriate items from the old catalog (using this
method you would have to re-enter any information that had been
manually added to the record after it had been cataloged).

Tip

When moving and deleting
catalog items, remember that you
are working with references to
image files, not the actual image
source files. Deleting catalog
items deletes the reference from
the catalog, it does not delete the
item file. If you accidentally delete
items from a catalog, you can
restore them by re-adding them to
the catalog (you may have to re-
enter keywords or other custom
information).  

You can use Portfolio to delete an
item’s source file, see page 83.
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Mac OS: To drag more than 50
records at one time, hold down the
Option key when initiating the drag.



Tip

To avoid being warned each time
you delete items, deselect the
“Confirm Delete from Catalog”
option in Edit > Preferences.

Tip

If you have deleted an item’s
source file (and you did not do so
using Portfolio’s Delete Original
command), you will probably also
want to delete the item record from
the catalog. You can do this using
the Delete Items command
discussed here, but if a number of
items are involved it may be easier
to use the Missing Items command
(see page 125).

Deleting Items from a Catalog

Since item records contain so much information that might be
difficult to replace if an item is accidentally deleted, Portfolio
provides some protection from accidentally deleting items from
catalogs. First, you must have Publisher or higher level access to
the catalog (see page 194) to delete items. Second, you will be
given an opportunity to verify that you really want to delete an
item before the item is deleted (this notification can be disabled in
Edit > Preferences).

To Delete items from a Catalog:

1. From a Gallery window, select the item(s) that you want
to delete.

2. Choose “Delete Items” from the Catalog menu.

3. Choose “Delete from Catalog,” then click “OK.”

The selected item(s) will be deleted from the Catalog. 

— or —

2. Press Option+Delete (Mac OS) or Ctrl+ Backspace
(Windows).

You will be asked to verify the deletion.

3. Click “OK.”

The selected item(s) will be deleted from the Catalog.
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Previewing Catalog Items

When you want to look more closely at any image or play sound
or movie items, you can open a Preview window for an item in
Portfolio. This saves you from having to launch the application
that the item’s source file was created in.

The Preview window lets you display and manipulate an item in
various ways depending on the item’s type (image, sound or
movie), as described on pages 76 through 81.

Note: Some file types cannot be previewed. If Portfolio is unable
to preview a file type, you are prompted to view the file in the
application that created it. See “Working with an Item’s Source
File” later in this chapter for details.

To Preview an item:

• Double-click its thumbnail in the Gallery window.
— or —
• Select the item, then press Command+B (Mac OS) or

Ctrl+B (Windows).
— or —
• Select the item, then choose “Preview Original…” from

the Item menu.

Unless items were cataloged using the Disk Previews option
(page 214), before displaying an item in the Preview window
Portfolio must be able to locate the item’s source file—that is, the
original file from which the catalog entry was made. If the source
file cannot be found (because the disk is not mounted or the file
has been moved or renamed), Portfolio will prompt you to insert
the missing disk. If the file is no longer on the requested disk,
click “Cancel” and Portfolio will allow you to manually locate
the missing file.

Portfolio 5.0 takes advantage of Apple's QuickTime 4.0 capabilities
for previewing many multimedia formats, if QuickTime 4.0 is
installed. QuickTime 4.0 installers for both Mac OS and Windows
are available on the Extensis CD.
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Item Preview—Still Images (Pictures)

L

77

A still image initially appears in a Pre-
view window at actual size (100% mag-
nification) or scaled to fit a window
appropriate to your screen size, depend-
ing on your preferences settings.

A File Name: Displays the file name of
the original image file. When a disk
preview (see page 214) is being dis-
played, the words “Screen Preview of”
precede the image name.

B Original Image: Scaled to 100% or to
Fit to Window.

C Zoom In: Click to zoom in, so that you
can see more image detail. 

D Zoom Out: Click to zoom out, so you
can see more of the image. 

E Fit to Window: Click to fit the image to
the window.

F Switch to Original: This button is
dimmed when the Preview is created
from the original image (from the
source file) If a Disk Preview was cre-
ated when the image was cataloged,
this icon is enabled. Clicking it
replaces the disk preview image with
one created from the source file.

G Current Magnification: Displays cur-
rent magnification. Use the Zoom
tools and key commands from the
View menu to examine the image.

H Image resolution: Displays image res-
olution in dpi. (Not available for all file
types.)

I Image size (not available for all file
types): Size is displayed in measure-
ment type indicated in Edit > Prefer-
ences. Options are: inches,
centimeters, millimeters, pixels.

J Partial image selection area: Select
an area of the image to examine or
copy.

K Preview window cursor: Crosshair
cursor helps you select an area.

L Contextual Menu: Control+click
(Mac OS) right-click (Windows) in 
the Preview window to access this
pop-up.
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Select a portion of the image Drag a box around the area (Mac OS only).

Select the whole image Choose Edit > Select All [Command+A (Mac OS)  
Ctrl+A (Windows)].

Increase magnification Click the Zoom In button at the top of the window (shown on 
page 77)  or choose Item > Zoom In [Command+“+” (Mac OS) 
Ctrl+“+” (Windows)]

Decrease magnification Click the Zoom Out button at the top of the window (shown on 
page 77)  or choose Item > Zoom Out [Command+“-” (Mac OS) 
Ctrl+“-” (Windows)]

Fit the image to the window Click the Fit to Window button at the top of the window (shown on 
page 77)  or choose Item > Fit to window [Command+0 (Mac OS) 
Ctrl+0 (Windows)]

Return image to actual size (100%) and adjust Choose Item > Actual Size [Command+’ (Mac OS) or Alt+’
window size to fit (Windows)].

Switch from disk preview to original Click the Switch to Original button at the top of the window 
image (shown on page 77) or choose Item > Switch to Original 

Edit the image’s source file Select the item, then choose Item > Edit Original...

Create a copy of the image file Choose “Copy Original...” from the Item menu.

Copy the image to the Clipboard Select an area to copy, or choose Edit > Select All (Command-A
[Ctrl+A]), then choose Edit > Copy (Command-C [Ctrl+C]).

Regenerate the thumbnail of a modified im- Choose Item > Regenerate Thumbnail (Mac OS only)
age without performing a standard Update (available in Publisher mode or higher only)

View the item’s properties Choose Item > Item Properties... [Command+I (Mac OS) or 
Alt+Enter (Windows)]

To... Procedure
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Item Preview—Multi-page documents

Perform standard select and zoom options See “Still Images” procedures chart on page 78.

Go to the first page in the document Click First Page

Go to the last page in the document Click Last Page

Go to the next page Click Next Page

Got to the previous page Click Previous Page

Switch from disk preview to original Click the Switch to Original button at the top of the window or choose 
image Item > Switch to Original. Only available if “Disk Previews” was 

enabled during cataloging, turning off view multiple pages.

Edit the image’s source file Select the item, then choose Item > Edit Original...

Create a copy of the image file Choose “Copy Original...” from the Item menu.

Set the preview and/or thumbnail image to Select the desired page, then choose Item > Regenerate 
any page other than the first page Thumbnail  (available in Publisher mode or higher only)

View the item’s properties Choose Item > Item Properties... [Command+I (Mac OS) or 
Alt+Enter (Windows)]

To... Procedure

Multi-page documents are a similar to
still images, with the ability to flip through
the pages in the preview. You can select
which page is to be used for the preview
and thumbnail image (see chart below).

A First Page: Go to first page.

B Previous Page: Go to previous page.

C Next Page: Go to next page.

D Last Page: Go to last page.

E Zoom In: See more image detail.

F Zoom Out: See more of the image.

G Fit to Window: Fits image to current
window. Scale is shown in (I).

H Switch Original: Open the document in
the creating application. (See below)

I Current Magnification: Shows current
magnification.

J Image Resolution: Resolution in dpi.

K Size: Size is displayed in measurment
type selected in Edit > Preferences.

L Multi-page Thumbnail Icon: Enable or
disable in Edit > Preferences.
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Viewing Multiple Pages in the Preview: To view multiple pages
in the preview, Disk Previews must be disabled when the item is
cataloged. Doing so disables the “Switch to Original” command.



Poster Frame: You can determine which frame of a movie is
used as the “poster frame” for the catalog thumbnail. To do so,
locate the frame that you want to use, then from the movies
Settings pop-up menu, choose “Set Poster Frame.” (Sets the
poster frame in the file itself.) The Poster Frame can be set only
in Publisher mode or higher.

Item Preview—Movies

Select part of the movie Press Shift and drag the control bar (selected frames appear 
highlighted).

Play or pause the movie Click the play button or press the spacebar. You can also double-click
the movie to play and click it to pause.

Step forward or backward one frame Click the forward or backward step button.

Increase or decrease volume Click the volume control and adjust the slider.

Set the Poster Frame From the Settings pop-up menu, choose “Set Poster Frame”

Go to the Poster Frame From the Settings pop-up menu, choose “Go To Poster Frame”

Edit the movie’s source file Choose "Edit Original" from the Item menu.

Create a copy of the movie file Choose "Copy Original…" from the Item menu.

View the movie’s properties Choose "Item Properties…" from the Item menu.

To... Procedure
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A movie item appears in the Preview
window at its actual size with a standard
QuickTime control bar that lets you start,
stop, and step through the movie; select
frames; and control the volume. You
cannot resize a movie preview.

A File Name: Movie file name.

B Movie window: Displays the movie.

C Play/Stop button: Press to start or
stop the movie.

D Volume control (if movie has sound):
Increase or decrease volume.

E Control bar: Shows movie progres-
sion. Drag to start movie at specified
location.

F Duration: Displays movie duration.

G Step buttons: Allows you to step
through the movie frame by frame.

H Options menu: Select Looping, Play-
back, and Poster Frame options.
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Item Preview—QuickDraw 3D Images  (Mac OS)

A
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A QuickDraw 3D image is a three-
dimensional drawing that can be cata-
loged with Portfolio.

A File Name: 3D image file name.

B Views pop-up menu: Click to select a
particular view from the pop-up menu.

C Magnification: Click to enlarge
(magnify) or reduce the image in
the window.

D Rotate: Click to spin the model in 3D
space.

E Move: Click to move the object
around inside the window.

F Home: Click to return the object to its
original view.

G Grabber: Click in the window and
drag to rotate the item in real time.
The cursor will change to the grabber
hand and a rotation circle will outline
the image.
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A sound item in the Preview window
appears and works much the same as a
movie item, except that there is no visu-
al component. The control bar lets you
start, stop and step through a sound
item; select part of the sound item; and
control the volume.

A File Name: Sound file name.

B Duration: Displays sound duration.

C Volume control: Increase or decrease
volume.

D Options menu: Select Looping and
playback options.

E Play/Stop: Press to start or stop the
movie.

F Control bar: Shows sound progres-
sion. Drag to start sound at specified
location.

G Step buttons: Allows you to step
through the sound frame by frame.

All of the procedures in the table on
page 80 apply to both movies and
sounds.

Item Preview—Sounds

B
C

D

A
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Viewing Item Properties

You can view all the information available about an individual
item from the Item Properties dialog. This view is helpful when
you want additional information, but don’t want to include it in
any of the Gallery views. You can also edit the item’s keywords,
description, and Custom Fields from the Item Properties dialog. 

To view Item Properties:

• Select the item, then choose “Item Properties...” from
the Item menu.

— or —

• Select the item, then press Command+I (Mac OS) or
Alt+Enter (Windows).

You can have up to ten “Item Properties” dialog boxes open at
one time.
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Tip

To change the application that will
be used to edit the item’s source
file, hold down the Option (Mac
OS) or Shift (Windows) key while
choosing Edit Original... from the
Item menu. Locate the application
that you want to open the item
with. The selected application
becomes the one that Portfolio
associates with the file until you
change it.

Working with an Item’s Source File

Once you have identified a catalog item you want, you can work
with it from within the open catalog. For example, you can:

• Switch to another program to edit the source file (the original
file to which the catalog entry points).

• Move, Copy, Delete, Find, or Rename the source file.
• Find out more information about the item.
• Print thumbnails or the item itself.

To Edit an item’s source file:

1. Select the item in the Gallery window, or open a
Preview window for the item.

2. Choose “Edit Original…” from the Item menu
[Command+M (Mac OS) or Ctrl+M (Windows)].

Portfolio remembers the name and location of the applica-
tion last used to edit the source file for any item of the
same type and creator. If necessary (such as the first time
you attempt to edit a file of a particular type) you will be
prompted to choose an application and to specify where
the application is located.

Portfolio launches the application, and opens the source
file for editing.

3. Make the changes you want, save the file, and quit the
application.

After quitting the editing application, you are returned to
Portfolio.
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To Copy a source file:

1. In the Gallery window, select the item(s) whose source
file you want to copy.

2. Choose Item > Copy Original… [Command+Option+C
(Mac OS) or Ctrl+Shift+C (Windows)].

3. In the file directory dialog box, locate and select the
folder you want the original file copied to.

4. Click the “Select” button at the bottom of the directory
dialog box.

Portfolio copies the source file into the folder you
specified.

Note: You can also copy source files by dragging items
from Gallery windows onto the desktop or into folders.

To Move a source file:

1. In the Gallery window, select the item(s) whose source
file you want to move.

2. Choose Choose Item > Move Original… [Command+
Option+Y (Mac OS) or Ctrl+Shift+Y (Windows)].

3. In the file directory dialog box, locate and select the
folder you want the original file moved to.

4. Click the “Select” button at the bottom of the directory
dialog box.

Portfolio moves the source file into the folder you
specified.

Important: “Move Original…” moves the source file from
its current location to the one you specify. If the source file
is locked, “Move Original…” does not move the file, but
makes a copy of it in the new location.

Portfolio automatically updates the catalog after you move
a file.

To Delete a source file:

1. Select the item in the Gallery window.

2. Choose Item > Delete Original… [Command+
Option+X (Mac OS) or Ctrl+Shift+X (Windows)].

3. Click “Cancel” if you change your mind or “OK” to
confirm that you want to delete the file.

Important

In a multi-user setting, be careful
about moving or deleting source
files unless you are sure that your
entire workgroup wants the files
moved or deleted.

Warning!

Be very careful when using the
“Delete Original” command to
delete source files. Once you
confirm the deletion the files are
deleted immediately and cannot
be recovered.

84

Important

Mac OS: If you drag an item to
the trash, the original item, not a
copy, is placed in the trash.



To Find a source file:

1. In the Gallery window, select the item(s) whose source
file you want to find.

2. Choose Choose Item > Find Original… [Command+
Option+F (Mac OS) or Ctrl+Shift+F (Windows)].

The source file will be located and highlighted. Mac OS:
If you select more than one item, Portfolio will open a
window for each folder containing found items, and
highlight all the found source files.

If any of the requested source files cannot be found, Port-
folio will locate the files that it can, and present a dialog
indicating that one or more source files could not be found.

To Rename a source file:

1. Select the item in the Gallery window.

2. Choose Item > Rename Original… [Command+
Option+N (Mac OS) or Ctrl+Shift+N (Windows)].

3. Click “Cancel” if you change your mind or “OK” to
confirm that you want to rename the file.
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Detecting and Reading Digimarc (Watermarks)

A Digimarc watermark is special information that may be
embedded in an item’s source file. Digimarc watermarks can be
detected, displayed, and embedded directly by Portfolio.

You can have Portfolio detect Digimarc data automatically when
items are cataloged by selecting this option from the Add and/or
Update tabs of the Cataloging Options dialog (Catalog >
Cataloging Options > Add or Update tab) (pages 134 and 147). 
You can display the presence of a watermark and/or the watermark
Creator ID (in the form of a link to the Digimarc website where
you can find out more about the Creator) on items in the Gallery
window by selecting these options in the Customize dialog (View >
Customize). 

Using the Read Digimarc command you can have Portfolio
examine an item’s source file for a Digimarc watermark, then
display information about the watermark. When Portfolio displays
the Digimarc information you can click a button to go directly to
the Digimarc website to obtain more information about the
watermark’s creator. To have Portfolio embed a Digimarc
watermark in the source file, see page 89.
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Reading Digimarc Data (Watermarks)

When a single gallery item is selected,
embedded watermark data is added to
the item record in the catalog and that
information is displayed in a dialog box,
as shown here. When multiple items are
selected, the data is added to the item
record in the catalog and a summary
report is displayed indicating how many
watermarks were read.

A Creator ID: Displays the watermark
creator name.

B Copyright Year: Displays the year the
item was copyrighted.

C Image Attributes: Displays information
about the item.

D OK: Click to close the dialog after
examining the displayed data.

E Web Lookup: Click to go to the
Digimarc website to display additional
information about the creator ID (A).
Uses the system’s default web
browser.

A

B
C

D

E

Note

To detect or display Digimarc
watermarks, the item source file
must be JPEG or TIFF without
channels. Portfolio does not
detect watermarks in other file
formats.

Tip

You must have Editor access or
higher to embed watermarks, and
to have the watermark information
that is gathered during a “Read
Digimarc ID” command written to
the item record.



87

To have Digimarc watermark data detected when items are
cataloged:

1. From the Catalog menu, choose Catalog Options.

2. From the Add and/or Update tabs, click “Always Detect
Digimarc.”

When items are cataloged, any existing watermarks will be
detected.

After watermark detection (if the Watermark display option
is selected in View > Customize), each item will display
one of three states: Watermark Detected, when the creator
code is known; Watermark Unknown, when the watermark
has not been detected or read; or Watermark Not Detected.

Tip

To display the watermark
detected field (and/or add a hot
link to the Creator ID that will take
you to the Digimarc website),
choose “Watermarked” and/or
“Watermarked URL” from the
fields list in the View > Customize
tab for the selected Gallery view.
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To read Digimarc watermark data from selected items:

1. In the active Gallery, select the item(s) that you want to
display watermark information for.

2. From the Item menu, choose “Read Digimarc ID.”

Reading the Digimarc ID is the process of obtaining and
displaying information contained in the watermark.

If a single Gallery item is selected when the Read
Digimarc ID command is invoked, Portfolio will display
the watermark information as well as record it in the item
record (see Note below). 

If more than one item is selected, Portfolio will record the
data in each item’s record (see Note below), and display a
summary of the results that includes how many source files
were scanned and how many items were found to have
watermark data embedded in them.

Note: The Read Digimarc command can be used to detect
watermark data in any catalog access mode, however
watermark data will only be written to the database in
Editor, Publisher, or Administrator mode.

Displaying the Digimarc Watermark URL: You can display an
active link to the Digimarc web site that will give you more
information about the watermark creator. To do so, choose
“Watermark URL” from the fields list in View > Customize,
then select the desired catalog item and choose Item > Read
Digimarc ID.
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Embedding Digimarc (Watermarks)

Portfolio allows you to embed a Digmarc watermark directly into
an item’s source file using the Embed Digimarc ID command.
You must be registered with Digimarc to be able to embed
watermarks (see sidebar Tip). Watermarks are permanent data
stored in the item source file.

Portfolio can only embed watermarks in JPEG and certain kind of
TIFF files. Portfolio does not embed watermarks in other file
formats, in 16-bit or multichannel TIFF files, including CMYK
images and grayscale images with alpha channels.

To embed a Digimarc watermark: In the active Gallery, select
the item(s) that you wish to have watermarked. From the Item
menu, choose “Embed Digimarc ID” (Item > Embed Digimarc
ID). Enter your Creator ID and choose the data that you want to
embed in the file. Click “Embed” to complete the process.
Portfolio will add the specified data to the selected item(s)
source file.

Embedding Digimarc (Watermarks)

A Creator ID: Enter your Digimarc  PIN
number and Creator ID

B Copyright Year: Allows you to enter
copyright year for the material. You
may leave this field blank.

C Content: Choose Restricted, Adult
Content, or none.

D Watermark Durability: Allows you to
choose a strength for your watermark.
For more information about choosing
strengths, please refer to the file
watermarking_guide.pdf located
inside the Portfolio folder on the
Extensis CD.

E Target Output: From the pop-up
menu, choose the target for
watermark display: Monitor, Web, or
Print.

F Embed: Directs Portfolio to embed the
specified information in the selected
item(s) source file.

G Cancel: Close the dialog without
making any changes to the selected
item(s) source file.

A

B

D

F

G
C

E

Tip

Digimarc is a proprietary system
for adding watermarks to image
files. To embed Digimarc
watermarks using Portfolio, you
will need to have a Digimarc
Creator ID. For more information
or to obtain a  Creator ID, visit the
Digimarc website at
http://www.digimarc.com.

Important

Watermark data is permanent and
cannot be removed. If you are
concerned about embedding
watermarks in your files, we sug-
gest making a backup copy of the
source file prior to watermarking.

http://www.digimarc.com
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Placeholder Records

If you need to create a record for an item, but for whatever reason
the item is not yet ready to be cataloged, you can add a blank
record using the “Create Placeholder Record” command from the
Item menu.

When the catalog is updated, Portfolio will look for the source
file in the location given when the Placeholder Record is created.

To create a Placeholder Record:

1. Choose Item > Create Placeholder Record… 

The Create Placeholder Record dialog is displayed.

2. Enter the exact name of the item’s source file.

When the catalog is updated, Portfolio will search for a
record by this name, so the name must be entered with the
exact source file name.

3. Optional: Click the “Specify folder on disk” button to
locate and select the folder where the new item’s source
file will be located.

This tells Portfolio where to look for the new item during
updating, so that you do not have to locate the source file
by hand. 

If the folder (where the source file will eventually be
located) does not exist, omit this step. When the catalog is
updated you will be asked to locate the item’s source file. 

Note for Windows: If you do not use an extension for the
file, Windows will not be able to find the file when the
catalog is updated, and you will be asked to locate the file.

Tip

Placeholder Records can be
created in Editor, Publisher, or
Administrator modes only.
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4. Click “OK.”

A blank record will be created for the item, and displayed
in the gallery with a special “Place Holder” thumbnail.

To replace a Placeholder Record information from with the
source file:

1. In the Gallery, select the Placeholder Records that you
want to replace with an actual item.

To locate all of the Placeholder Records in the Catalog,
choose Catalog > Find Placeholder Records.

2. Choose “Update Items” from the Catalog menu, or
press Command+U (Mac OS) or Ctrl+U (Windows).

When the catalog is updated, Portfolio will search for the
source file in the location specified when the Placeholder
Record was created. If no location was specified, you will
be asked to locate the source file. 



Viewing Catalog Properties

You can view general information and statistics about any catalog
from the Catalog Properties dialog. Statistics include Keywords
used in the catalog and volumes linked to catalog items. You can
also export the keywords list from this dialog (see page 204).

To view Catalog Properties:

• Choose Catalog > Catalog Properties... 

— or —

• Press Command+Option+J (Mac OS) or Ctrl+Shift+J
(Windows).

The Catalog Properties for the active catalog will be dis-
played. To view information for another catalog, open it
and make it the active window. You can have up to ten
“Catalog Properties” dialog boxes open at one time.

To view all the Keywords in the Catalog: Open the Catalog
Properties dialog (Catalog > Catalog Properties), select the
“Statistics tab, then click the “Calculate” (Mac OS) or “Calculate
Now” (Windows) button. Portfolio will list each keyword and
indicate how many cataloged items have each keyword assigned.
Calculating the number of keyworded items may take some time
to complete.
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Setting Preferences

You can customize Portfolio to suit your working style and work
more productively by setting preferences using the “Prefer-
ences…” command in the Edit menu. Refer to the table at the top
of page 95 for descriptions of each User Preference.

Where Preferences are Stored

There are two types of Preferences in Portfolio, User preferences
and Catalog preferences. 

User preferences are “user based” and are stored on the user’s
(client’s) machine. These settings apply to any and all catalogs
opened on that machine (such as the Default Catalog to open
when Portfolio is launched). 

Catalog preferences are “catalog based” and are stored directly
in the catalog. Catalog preferences apply to only the catalog
where they are set. Catalog preferences (such as the Default
Gallery to open when the Catalog is opened) are shared by every-
one who opens that catalog. 

The table below shows each Preference setting and whether it is a
User Preference or a Catalog Preference.

For more information on preferences and settings, refer to the
section of this User Guide dealing with the listed topic.

View Defaults View > Customize: Save Defaults User’s system

Default Catalog File > Save as Default User’s system

Editing Application List Item > Edit Original User’s system

File Types List Catalog > Cataloging Options: File Types tab User’s system

User Preferences Edit > Preferences User’s system; Catalog

Default Gallery Windows > Save Gallery Catalog

Default Find Catalog > Find Catalog

These settings Accessed in this location Are stored in
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To set or change User Preferences:

1. Choose “Preferences…” from the Edit menu, or press
Command+Option+E (Mac OS) or Ctrl+Shift+E
(Windows).

The “User Preferences” dialog box is displayed.

2. Select the desired options (see page 95) from the
General and Advanced tabs.

3. Click “OK.”
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Confirm Delete from Catalog When selected, the “Confirm Delete” dialog box appears when you 
delete an item from the catalog. 

Show Options Dialog on Add/Update When selected, the Cataloging Options dialog box appears when you 
add items to or update items in a catalog.

Autoplay Movies and Sounds When selected, movie and sound files are played automatically in 
Preview windows; you don’t need to click the Play button.

Display Welcome Screen When selected, a dialog box prompting you to create a new catalog or
open an existing one appears when you launch Portfolio.

QuickFind Opens New Gallery When selected, QuickFind (page 35) will display found items in a 
new Gallery window.

Fit Preview Images to Window When selected, images are automatically scaled to fit Preview windows. 
When unchecked, images appear at 100% and scroll bars appear in 
the window to allow you to view the entire image.

Prompt on Untitled Close When selected, always prompts you to save untitled (unsaved) Galleries.

Default Open Mode Select the access level with which Portfolio will open the catalog:
Reader, Editor, Publisher, or Administrator (see pages 192–201).

Image Dimensions Select the unit of measure for displaying image dimensions. Applies to 
displays in the Gallery and Preview windows. Note: Pixels are the only unit
measure used in height and width fields.

Display Multipage Icon on Thumbnail When selected, a multiple page icon is added to the item thumbnail in the 
lower right-hand corner.

Preferences-General tab Result

Index Node Size <specify> Controls block size written to the Portfolio database. Generally, increasing
the node size to 4K or 8K will increase the performance of Finds and Sorts,
but may slightly decrease the speed of cataloging. IMPORTANT: Portfolio
4.0 is only capable of reading catalogs created with a 1K node size. For
this reason the default has been left at 1K. If you are working in an envi-
ronment that contains Portfolio 4.0 and 4.0.1 users, do not change the
node size. If all users in your environment have upgraded to 4.0.1 or 5.0, it
is recommended that you create new catalogs with a node size of 4K or 8K
to achieve better performance. If you are using the Portfolio Server version
4.0.1 or later, you can safely change the node size for served clients, even
if some of the clients are using Portfolio 4.0.

Language <specify> Sets what sort of tables are used for a catalog. If you are about to create a
catalog for a language other than English, change the language here so
that values will sort properly in that language.

Open Gallery with Catalog Determines whether a gallery will be opened whenever a catalog is
opened. If you have large numbers of records in your galleries, turning this
option off will allow the catalog to open more quickly.

Preferences-Advanced tab Result
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Printing Catalog Items

Although you will typically find and select a catalog item either
to edit the source file, view it, or use it in another document, you
might want to print from the catalog itself—to show to a client,
for example, or to evaluate items for possible use in a document.
You can specify margin size, and how many items to print per
page (grid). 

Choosing “Print…” from the File menu prints the contents of the
active window. To print thumbnails or a list of catalog items,
select the items you want to include and place them into a Gallery
window. Select the appropriate Gallery view (Thumbnail, List,
Record). Customize the Gallery view just the way you want it to
appear, including sorting, manually reordering items, borders,
background colors, and the like.When the Gallery is set up just
the way you want it, select “Print.”

Printing Grids: When you specify a grid size for printing,
Portfolio will generate pages with the indicated number of
images. That is, 4x4 indicates a page with 16 image cells, 4
across and 4 down. Images will be scaled (enlarged or reduced) to
fit. Text is not scaled, only the image and border (if any). 

Note: If the grid is set smaller than the thumbnail size (such as
2x2), the thumbnails will be enlarged, potentially causing
pixelated images. However, such a setting can be used to
advantage to create high-quality, large thumbnails if you print
“Actual Images” instead of “Thumbnails in Catalog.”

Printing Single Images: To print a single full-size image, print
from a Preview window.

Tip

If the active window is a Pre-
view window when the Print
command is selected, you
will see a standard “Print”
dialog box that contains no
special options for Portfolio.

If the active window is a
Gallery window when the
Print command is selected,
the print dialog box includes
the options described in the
table on page 98.
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Printing Options

B

You can print selected images in the
catalog either as the actual images or
as thumbnails. You can specify the
number of thumbnails to display on the
page and margin space.

A Portfolio options: Select the Portfolio
application from the pop-up menu

B Header: Enter text for page header.

C Footer: Enter text for page footer.

D Number Pages from (Mac OS), 
Print Range (Windows): Begins
printing from the page indicated.

E Use Grid (Mac OS), Thumbnails
Layout (Windows): Allows you to
enter number of Rows and Columns.
If checked, Portfolio will scale the
images to fit the grid indicated. If
unchecked, Portfolio will fill the page
with actual-sized thumbnails.

F Print Using: Choose from Thumbnails
or Actual Images.

G Quality: Available only when Actual
Images has been selected in (F).
Options are: Best, Better, Good

H Margins: Set page margins: Top,
Bottom, Left, Right

C

A

D
E
F
G

H

B
C

F

H E

Mac OS

Windows

D
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Technical Notes

“Print Using Actual Images” with Quality set to “Best” is a
printer-intensive task. Some printers are not equipped with
enough memory to support the amount of data being downloaded
to the printer. If you experience problems, try switching to the
“Better” or “Good” setting. It’s a good idea to run the “Missing
Items” command before printing actual images.

Thumbnails rotated in the catalog are printed with their original
orientation when using “Print Using Actual Images.”

Header Prints a text header centered at the top of the page.

Footer Prints a text footer centered at the bottom of the page. 

Number Pages Page numbers on each printed page. Enter a starting page number in 
the “Number Pages From” text box if you want the start page numbering
at a number other than “1”.

Use Grid Enter grid size for the layout. For example, to print 16 images per page,
enter a grid of 4 x 4.

Print Using… Actual Images Prints thumbnails using the original source files if available. This option
generally yields a higher-quality output, but can be time intensive because
Portfolio must open and process each item’s source file when creating its
thumbnail. Thumbnails in the catalog are substituted for any actual images
that are not found.

Thumbnails in Catalog Always prints from the thumbnail images available in the catalog.

Quality Best Provides the highest-quality output but the slowest print times.

Better Provides medium-quality output at moderate print times.

Good Provides the lowest-quality output but the fastest print times.

Margin Specify margin (white space at edges of page) for Top, Bottom, Left,
and Right

Print Option Result

Gallery Window Printing Options

98



Customizing Gallery Views

You can change the layout of any Catalog Gallery view. This
allows you to display precisely the information you want to see,
including the information in any custom fields that you have
created.

To customize Gallery views:

1. Choose “Customize…” from the View menu, or press
Command+D (Mac OS) or Ctrl+D (Windows), or click
the Customize button on the Toolbar.

The Customize Gallery dialog (page 101) will open to the
tab associated with the current Gallery view.

2. Select the options you want.

The view options are described in the table on page 100.

3. If you are going to modify any of the other Gallery
views, click “Apply” to apply the selections to the
Gallery window without closing the Customize Gallery
dialog box.

4. When you have finished selecting options, click “OK” to
apply the changes and close the dialog box.

Note: Click “Save Defaults” to save the current settings as
the default layout for each Gallery view. The layout will
then be used for all new Gallery windows displayed in
each view.
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Type Font Sets the display font for the view.

Size Sets the font size for the view.

Style Sets the font style for the view.

Thumbnail Size Sets the size of thumbnails in Thumbnail and Record view.

Borders Sets the type of border (or none) for thumbnails.

Space Between Sets the number of pixels between thumbnails in Thumbnail view.

Text Color Sets the color of text in Thumbnail, List, and Record view.

Background Color Sets the window background color on which the records are displayed.

List Text Color Sets the color of the text in List view. 

Background Color Sets the window background color in List view.

Fields List A scrolling list of all available fields in the catalog. Select a field name
to have it displayed in the current view. Drag field names to rearrange
list order, representing the order in which the fields will be displayed. 

In Thumbnail view, the Filename field is selected by default. In List
view, the Filename, File Size, Last Modified, Volume and File Type
fields are selected by default. In Record view, the Filename field is
selected by default. In List view, the Filename, Path, Keywords, and
Description fields are selected by default.

In Record view, the number of lines in the display for Description,
Keyword, and Custom Fields of type “String” that have “Display Multi-
line” enabled or are Multi-valued fields can be edited (item (O) on
page 101). Click the number displayed to the right of these fields to
access a pop-up menu (Mac OS) or click in this area to open an edit 

dialog (Windows).

Display as List Record view only. Sets window to display records as a continuous list.

Show Field Names Record view only. Sets window to display Field Names in front of 
information fields. Field Names are displayed in bold.

Edit Allows editing of fields in Record View (System fields cannot be edited).

Option Choices Description
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You can customize each of the three
Gallery views (Thumbnail, List, and
Record) using the following options.

A Thumbnails tab: Selections apply to
Gallery window Thumbnail view. 

B Type: Select how the text will be dis-
played in the window. Options include
Font Type, Size, and Style.

C Thumbnail: Select Thumbnail Size,
Background Color, Text Color, and
Space Between image thumbnails (in
pixels). From the Border pop-up menu
create and select thumbnail Borders.

D Apply: Click to apply the selections on
the selected tab to the Gallery without
closing the dialog.

E Save as Defaults: Click to save the
settings on all tabs as the Default
settings for that Gallery .

F Restore Defaults: Click to revert set-
tings to the factory set defaults.

G Cancel: Click to close the dialog box
without making any changes.

H OK: Click to accept the changes and
close the dialog box.

I Information Fields Item: Click an item
to select it for viewing (check indi-
cates selected for viewing). Drag
items up or down to position them in
relation to other fields. 

J Information Fields: Displays the full
list of information fields that can be
added to the Gallery view. 

K List tab: Similar selections as
Thumbnails tab but without thumbnail
options. Adds List Background and
Text Color. Selections apply to Gallery
window List view.

L Record tab: Similar selections as
Thumbnails tab, except that records
are listed in a scrolling vertical window.

M Display as List: Allows you to show
records as a continuous list.

N Show Field Names: Allows you to add
Field Names to the information fields.
Field Names are shown in bold.

O Edit: Click to allow editing in place in
Record View (page 146).

P Fields List pop-up menu (Mac OS) or
Edit Dialog (Windows): Allows you to
specify the number of lines to be used
for displayed information in Keywords,
Description, and Custom Fields that
allow multiple lines (see page 209).

Customize Gallery—Thumbnail, List, and Record Views

B

C

K

L

I

J

A

D E F G H

M N

P

O
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Allows you to set up Find Galleries
(page 65) and provides Sorting options
for Saved Galleries opened
automatically when the Catalog is
opened.

A Saved Options tab 

B Find Gallery: Allows you to create a
Find Gallery from the currently active
gallery. 

Load Saved Find when Opened:
When selected creates a Find Gallery
by attaching the indicated Saved Find
to the current gallery. 

Saved Find: Select from the list of
Saved Finds.

C Sorting: Keeps the Gallery sorted.

Field: Specify the sort field for the
gallery.

Sort Order: Specify Ascending or
Descending.

Keep Gallery Sorted: When enabled,
keeps the gallery sort order intact.

D Gallery: Click to open the current
Saved Gallery when the Catalog is
opened.

E Save as Defaults: Click to save the
settings on all tabs as the Default
settings for that Gallery.

F Restore Defaults: Click to revert
settings to the factory set defaults.

G OK: Click to accept the changes and
close the dialog box.

H Cancel: Click to close the dialog box
without making any changes.

I Apply: Click to apply the selections on
the selected tab to the Gallery without
closing the dialog.

Customize Gallery—Saved Options
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Adding Borders to Thumbnails

You can highlight your catalog thumbnails by displaying them in
the Gallery window with Thumbnail Borders. Portfolio provides a
few sample borders for you to use, and you can create unlimited
effects using your own border designs.

Any bitmapped image (PICT, BMP) can be used—all you need to
do is create your border design, copy it to the system clipboard,
paste it into the Edit Borders dialog, then select it in the
Thumbnail or Record tab of the Customize Gallery dialog. 

All thumbnails in the Gallery window will be displayed with the
selected border. Using the Save Galleries feature (page 61) you
can set up special Galleries of items with borders, and others
without, or specify different borders for different Galleries.

When adding borders, you specify which thumbnail size you want
your border to apply to. The Border Box that Portfolio provides
for each thumbnail size is 25% larger than the thumbnail, so your
borders should be 25% larger than the thumbnail size you intend
to use them with (see sidebar table on page 106). If your border
is larger than the Border Box, it will be scaled down to the proper
size. If it is too small it will be hidden by the thumbnail; it may
be visible if the item displays as an icon.

Tip

You can create stunning borders
almost effortlessly with Extensis
PhotoTools, an exciting collection
of Photoshop plug-ins that allows
you to create custom bevels, drop
shadows, embosses, glows, and
more! A Demo version of
PhotoTools is available on the
Extensis CD.
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Edit Thumbnail Borders
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The Borders dialogs allow you to add
thumbnail borders to the catalog, and
change the options of currently installed
borders. Before a border can be dis-
played you must select it from the
Borders List in the Customize Galleries
dialog (View > Customize: Thumbnail
tab or Record tab).

A Borders List: Displays a list of
Borders available in the catalog.

B New: Opens the Edit Borders dialog
to  create and name a new border.

C Edit: Opens the Edit Borders dialog
allowing you to edit the currently
selected border (A).

D Delete: Deletes the currently
selected border.

E OK: Close the dialog box and save
any new or modified Borders.

F Cancel: Close the dialog box without
saving any changes.

G Border Name: Displays name of
border being edited. Enter name for
new border here.

H Thumbnail Size: Select size of
thumbnail border is being created for.

I Dimensions: Displays border size
and actual size. 

J Border Box: Represents the area
allowed for the border. Box size
changes based on the selected
thumbnail size (see table on page
106). The border that you paste is
displayed here.

K Transparency Pixel: Sets the color
map for the transparency (see 
page 108).

L Save: Close the dialog and save the
Border box(es).

M Cancel: Close the dialog box without
making any changes. 

N Paste: Copy the border to the system
clipboard, then click this button to
paste it into the Border box (J).

O Clear: Clears the Border box for the
currently selected thumbnail size.

P Clear All: Clears all Border boxes.



To select a thumbnail border:

1. Choose View > Customize, or press Command+D
(Mac OS) or Ctrl+D (Windows), or click the Customize

button.

2. Click the Thumbnails tab or Record tab to select it. 

Borders are not available in List view.

3. Choose the desired thumbnail Border from the Border
pop-up menu. 

4. Click “OK” to close the dialog and apply the border to
the items in the active Gallery.
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To add a thumbnail border to the catalog:

1. From your image editing application, copy your border
to the system clipboard. 

2. From Portfolio, choose View > Customize, or press
Command+D (Mac OS) or Ctrl+D (Windows), or click
the Customize button.

3. Click the Thumbnails tab or Record tab to select it. 

Borders are not available in List view.

4. Choose “Edit” from the Border pop-up menu. 

The Edit Borders dialog will be displayed.

5. Click “New,” then enter a name for the border.

6. Select the thumbnail size to which you wish to add the
border.

7. Paste the border—it will be pasted into the selected size
Border Box. When you have finished in the Edit Borders
dialog, click “Save.”

You can paste the same or a different border for each
thumbnail size.

8. When you have finished in the Customize dialog, click
“OK.”

How Borders Work / Border Transparency
Border images are displayed behind the thumbnails. This means
that thumbnails and icons will always be displayed in their entire-
ty, at whatever size and orientation they are, “overlapping” the
border image.

Portfolio looks at the center pixel of the selected border image
and sets that as the designated transparency color. This allows
you to create borders that behave like a transparency mask, allow-
ing the background to show through certain areas of the border
design (see the Slide Border example on page 106). Wherever the
transparency color appears in the border image, the background is
allowed to show through. So you can designate areas of the bor-
der image as transparent by coloring them the same color as the
center pixels of the border image. 

Portfolio always sets a transparency color using the center pixel
of the border image, whether you intend to create transparency in
your border or not. For example: Suppose you have a border
image that is a white box with a black border, and your Gallery
background color is blue. Portfolio will set the transparency color
to white because the center pixel of the border image is white. If
the thumbnails completely cover the white area of the border

Thumbnail Size Border Size

32 x 32 40 x 40
64 x 64 80 x 80

112 x 112 140 x 140

256 x 256 320 x 320
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Border Transparency

B
A

EC

D

The center pixel of the Border image
(E) sets the transparency (mask) color.
Everywhere on the Border image that
that color appears becomes a masked
area, allowing the Gallery background
to show through. 

A Border Box Outside Edge: The
outside edge defines the largest area
that the border will occupy. In this
example, the border image is 140 x
140 pixels.

B Border outer box: In this Border
image we created two boxes. Notice,
in the Gallery example, how the
thumbnails overlay the Border. Com-
pare the Border image and its effect
on the thumbnails to get an idea of
what you need to do to create the
border effect you want.

C Border inside box: This is the inside
box of our image. Notice the effect
on the thumbnails in the Gallery view
below.

D Masked areas: In this example, all
four corners of the Border image
were painted the same color as the
center pixels. This allows the gray
background in the Gallery to show
through at the corners of the Border,
creating a “slide” effect.

E Transparency Pixels: Portfolio always
sets the color of the center pixel as
the transparency color. By creating a
4 x 4 pixel box and coloring it pink,
then coloring the four corners with
the same pink color, we created a
mask along the corners that allows
the background to show through.
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image, you will not see the blue background. If the thumbnails
do not completely cover the white area of the border design, some
blue will show through. This may or may not be what you want.
To eliminate potential problems and ensure that you can change
backgrounds without being concerned about transparency, it’s
good practice to add a color in the center of your border image
(using a 4 x 4 pixel square works well) that does not appear any-
where else in the border image.

To set the transparency color of a Border image:

1. Choose a color that is not used anywhere in the Border
design.

This will be your designated transparency color.

2. Color a 4 x 4 pixel area in the center of the image with
the transparency color you selected in step 1.

You could color a larger area with the transparency (mask)
color, but a 4 x 4 pixel area is large enough to see, yet
small enough to be completely covered by the item thumb-
nail or icon.

3. Using the transparency color, color in the areas that
you want to mask.

Everywhere on the Border image that the transparency
color appears will become transparent, allowing the
Gallery background to show through.

Note: Thumbnails (and icons) cannot be made transparent.
Thumbnails and icons are displayed on top of the Border
image and will cover the Border design in that area
whether the Border is transparent or not.

4. Copy and paste the Border image into the Border Edit
dialog as outlined on page 106.

Center pixels
define 

transparency
color
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Slideshows

The Portfolio Slideshow feature lets you create slide shows from
your catalog images (not thumbnails) that can run automati-
cally—with the images being advanced in specified intervals
—or that can be manually advanced.

Portfolio uses the images in the active Gallery for the slide show.
The screen is blanked and the images are displayed against the
background color of the current Gallery view. You can elect to
show images at their actual image size, or to have them scaled up
to fit as much of the display screen as possible. (If an item is too
big for the screen, it is automatically scaled down.) 

When locating items for a Slideshow, if a disk preview is
available, it will be displayed. If no disk preview is found and the
source file cannot be found, the item thumbnail is displayed.

You can also have the slide show run automatically (Catalog >
Administration... > Startup tab) when Portfolio is launched; in this
case the last-saved Slideshow Options are used.  

Display Field
Portfolio 5.0 allows you to specify a field to be displayed along
with the image in slideshows. This option is available on the
Slideshow Options dialog (page 110).

Transition Effects on Export (Mac OS)
When you export a Slideshow as a QuickTime movie (Mac OS),
you can add from QuickTime’s built-in transition capabilities to
enhance your movie. To use transitions, QuickTime must be
installed and the Transitions option selected on the Export
QuickTime Movies dialog (page 191). 

Transition settings can be changed using the Edit button on the
Export QuickTime Movies dialog. Edit options rely on and use
QuickTime internal technology. That is, they are controlled by
QuickTime, not Portfolio. 

Tip

You can close the Slideshow
controller and use the following
keyboard shortcuts to run your
Slideshow. This allows you to run
the show with nothing on the
screen but the images.

Quit Slideshow Esc
Previous Item Page Up
Next Item Page Down
Last Item End
First Item Home
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A Control: Select Manual, for manually
run slide shows, or Timed, for auto-
running slide shows. You can enter a
delay from zero to 99 seconds. 

B Display Size: Actual Size displays the
images at the actual size of the
source file image. Full screen allows
Portfolio to scale the image up to fit
the display screen. In all cases, if the
image is too large, it will be scaled
down to fit.

C Continuous Loop: Allows you to set
auto-running slide shows to loop
continuously.

D Display Field: Allows you to specify a
field to be displayed with the records
in the slideshow. Select field from the
Display Field pop-up menu.

E OK: Close the dialog box and save
the changes.

F Cancel: Close the dialog box without
making any changes.

Slideshow Options
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Slideshow Controls

Manual Preview Controls: Allow you to move from slide to
slide in manually run slideshows. Available to all access levels.

Record Controls: Allow you to manipulate records and their
original items without leaving the slideshow. Helpful for proofing
records quickly without returning to the Gallery. Requires
Publisher or higher level access.

Timed Preview Controls: Allow you to pause a timed slide
show, for example to illustrate a point, and then resume play.
Available to all access levels.

Slideshow controls are displayed on-screen
during the slideshow, unless this option is
disabled.

Manual Preview Controls

A Beginning: Click to go to first slide.

B Back: Click to go back one slide.

C Stop: Click to end the slide show and
return to Gallery view.  

D Forward: Click to go forward one
slide.

E End: Click to go to the last slide.

Record Controls

F Delete Record: Click to delete the
current record from the Gallery.

G Delete Original: Click to remove the
original item from the disk.

H Copy Original: Click to copy to original
item to a new location.

I Move Original: Click to move the
original item to a new location.

J Rename Original: Click to provide a
new name for the original item.

Timed Preview Controls

K Pause/Continue: Click to pause and
continue a Timed slideshow

L Stop: Ends an AutoRun slideshow
and returns to Gallery view.

Slideshow Controls

A

F G H I

B C D E

Manual Mode
Preview
Controls

Record
Controls

Timed Mode
Preview Controls

J

K L
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Tip

To start your Slideshow quickly,
press Command+; (Mac OS) or
Ctrl+; (Windows). 



To set up a Slideshow:

1. From the Catalog menu, choose Slideshow Options…  

2. Select the desired settings (page 110), then click “OK.”

To run a Slideshow:

1. Configure a Gallery window with the items you would
like to be displayed in the slideshow, and arrange the
items in the order in which you want them to be shown.

You can show still images, 3D images, movies, and
sounds. Anything that can be previewed in Portfolio can be
displayed in the slide show.

2. Choose Slideshow from the Catalog menu, press
Command+; (Mac OS) or Ctrl+; (Windows).

3. For manually run slide shows, click the arrows on the
controller to move to the next or previous item.

Click the first/last arrows to move to the beginning 
or the end of the show. 

4. Timed slideshows begin automatically, but you can stop
and start the presentation (perhaps to elaborate or
answer questions) and restart using the pause button

on the mini-controller.  

If the Slideshow is not on “Continuous Loop” it will end
when the last item has been displayed.

5. To stop the slideshow and return to the Gallery window,
press the Stop button.

Note: When using a timed delay, images do not start load-
ing until after the delay period. This means that (depend-
ing upon system parameters) with a delay of 4 seconds, a
small image might show up in 4 to 4-1/2 seconds, while a
large image might take longer.

Hiding the controller: You can hide the controller in both auto-
matic and manual mode by clicking its Close Box, then use the
keyboard commands (page 109) to run the Slideshow.

Display Field: You can display information about each item in
your slide show by enabling the “Display Field” option (Catalog
> Slideshow Options) and selecting the field that you would like
to display.

Controller
Manual Mode

Mini-controller
Timed Mode
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This chapter describes how to create and modify Portfolio
catalogs, including: adding items to a catalog; selecting
cataloging options; adding information to items such as key-
words, descriptions and custom fields; updating cataloged items;
and creating  and using Master Keyword lists. Also covered are
catalog Access Levels and networking without a Server. 

For information on managing a Portfolio Catalog Server see
“Server Administration” starting on page 221. For information on
using Portfolio to find and retrieve cataloged items, see “Viewing
and Searching Catalogs,” starting on page 23.

Creating a New Catalog

To catalog items in Portfolio you “add” them to an open
catalog—Portfolio then handles the cataloging automatically. 
You can add items to a new catalog or to an existing one. New
catalogs created in Portfolio are initially empty. 

This section shows you how to create a new, empty catalog; to add
items to the catalog, see “Adding Items to a Catalog” on page 118.

Note: You'll notice that the Portfolio catalogs you create are
automatically given a “.fdb” filename extension, even on the
Macintosh. This is to ensure cross-platform access to your
catalogs. Macintosh users who do not work in a cross-platform
environment can delete the “.fdb" extension in the Save dialog
when the file is named and saved.

To create a New catalog:

1. Open the Portfolio application by double-clicking its
icon, or by selecting it from the Start
menu (Windows). When the
Welcome dialog appears, select
“Create a New Portfolio catalog,” then click “OK.”

To prevent the Welcome dialog from being displayed each
time you open a catalog, deselect this option in Edit >
Preferences.

Creating and Managing Catalogs

Tip

Most of the procedures in this chap-
ter require Editor or higher level
access to the open catalog (see
pages 193 and 194).

Important

When a new catalog is created,
Portfolio also creates a supporting
file with a “.adm" extension; this
file is placed in the same folder as
the catalog. The “.adm” file is
used to control file access in a
multi-user environment. If you
delete the file Portfolio will recre-
ate it. Deleting the file in a multi-
user environment can cause
unexpected problems for catalog
users.
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— or —

1. Click “Cancel” at the Welcome dialog. When Portfolio
opens, select “New...” from the File menu, or click the
“New Catalog” button on the button bar, or press
Command+N (Mac OS) or Ctrl+N (Windows).

2. Specify a name and location for the new catalog, then
click “Save.”

Portfolio creates the catalog and opens a blank Gallery
window.

3. Add items to the catalog as described in “Adding Items
to a Catalog” on page 118.

Tip

Portfolio automatically opens new
catalogs in Administrator mode.
Administrator mode gives you the
necessary permissions for modify-
ing catalog structure.

You cannot share a catalog when
it is in Administrator mode. Before
sharing the catalog, switch to Pub-
lishing mode or lower (Catalog >
Access). (See page 194)
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Working with Catalogs

The new Catalogs palette in Portfolio 5.0 makes working with
multiple catalogs easier than ever before. With the “Keep Open”
option enabled in your catalogs, you can search across multiple
catalogs (page 53) without needing to have a gallery open in any
of them. 

You can open catalogs and galleries, set default catalog(s) to open
when Portfolio is launched from the user’s machine, open new
catalogs to a default gallery or with all records displayed, instant-
ly close all galleries in a catalog, and more—all from the handy
Catalogs palette. All the options available on the Catalogs palette
are shown in the figure above and in the table on the following
page.

Catalogs Palette

The Catalogs palette allows you to
easily work with all open catalogs,
whether or not any Galleries are
opened for them.

To show the Catalogs palette, choose
“Show Catalogs” from the Window
menu.

A Catalogs palette tab

B Catalog Names: Lists all the currently
open catalogs.

C Open Galleries: Indicates how many
galleries are currently open for each
listed catalog. You can open catalogs
without opening any galleries.

D Search Indicator: An icon in the far
left column indicates that the catalog
is selected for cross-catalog search-
ing. No icon indicates that the catalog
will not be included in cross catalog
searches.

E Open: Click to access the Open Files
dialog to locate a new catalog to
open.

F Close: Click to close the highlighted
catalog.

G Catalogs palette fly-out menu: Select
a Catalog on the list, then select a
function to perform from the fly-out
menu. See page 116.
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Open Catalog on Startup

You can select one or more Catalogs that will be opened automat-
ically each time you start Portfolio.

To specify a Catalog to open on startup:

1. Open or create the catalog that you want to use as the
Default.

2. From the File menu, choose “Open Catalog on
Startup.”

A checkmark appears beside the menu command indicat-
ing that this catalog will be opened automatically when
Portfolio is launched. 

To deselect the catalog, select “Open Catalog on Startup”
again to remove the checkmark.

— or  —

2. Open the Catalogs palette (Windows > Show Catalogs).
Highlight the catalog on the list, then choose “Open
Catalog on Startup” from the palette fly-out menu.

Open Catalog Allows you to locate and open a catalog. 

Close Catalog Closes the selected (highlighted) catalog.

New Gallery Open a new, empty gallery for the highlighted catalog.

New Gallery with Find All Open a new gallery, find and display all records in the catalog.

Close All Galleries Close all galleries in the highlighted catalog.

Open Catalog on Startup Set the selected (highlighted) catalog to open when Portfolio is launched.

Display Gallery on Open When enabled, causes a gallery to be opened automatically when the
highlighted catalog is opened. The catalog’s Default Gallery is opened; if
none is assigned, a gallery with all records selected is opened.

Keep Catalog Open Allows a catalog to remain open with zero galleries open. Helpful for 
having multiple catalogs open for searching, but with no galleries opened.

Open Galleries List Select an open gallery from the list to bring it to the front.

* Options on the Catalog palette fly-out menu apply only to the selected (highlighted) catalog.

Catalogs Palette Menu Option Function Performed*
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To open specified Catalog(s) at Startup:

1. Open or create the desired catalog.

This could be a local catalog, or one on a remote network
or internet.

2. Specify that the catalog should be opened on startup, as
shown on page 116.

3. Repeat step 2 for all the catalogs that you wish to
launch at startup.

To open a Gallery(s) at Startup:

1. Create and save the desired Gallery. Verify that the
desired Gallery is open and is the active Gallery by
clicking in it.

2. From the View menu, choose “Customize.”

3. Select the Saved Options tab.

4. At the bottom of the Saved Options tab in the “Gallery”
section, click the “Open  at Startup.”

Each time the catalog is opened, the selected Gallery will
automatically be opened.

To keep Catalog(s) open after all galleries are closed:

1. Open or create the desired catalog.

This could be a local catalog, or one on a remote network
or internet.

2. Open the Catalogs palette (Windows > Show Catalogs). 

3. Highlight the desired catalog.

4. From the Catalog palette fly-out menu, choose “Keep
Open.”

This feature allows you to search across multiple catalogs
without needing to open any gallery windows. 

You cannot choose both “Open Gallery at Startup” and
“Keep Open” for the same catalog; these commands are
mutually exclusive.
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Adding Items to the Catalog

You can easily add items (including whole folders and volumes of
items) to a catalog from within Portfolio, or by dragging and
dropping them into an open Gallery window.

If you add items to a catalog from disks or network volumes, you
can dismount the drives or volumes and continue to use the cata-
log—viewing, searching, and organizing cataloged items—without
re-mounting the source file volumes. The only time you need to
access the source file is when copying the item to another applica-
tion, when printing from the original, or when using the source file
functions available in Portfolio such as previewing, editing, copy-
ing, renaming, or deleting a source file. And even then, Portfolio
automatically prompts you to insert the necessary volume.

When you add items to a catalog, Portfolio displays the
Cataloging Options dialog so that you can select or change
cataloging options before cataloging begins. (See page 130.) 

Portfolio provides default Cataloging
Options that will serve most needs, so you
can quickly catalog items without spending
time learning about these options. (To select
the default options, click “OK” on the
Cataloging Options dialog.) You can bypass
this dialog altogether by disabling this
option in Portfolio’s Edit > Preferences
dialog. With “Show Cataloging Options”
disabled, Portfolio automatically applies the
default cataloging options (or the last-saved
options if any were specified in Catalog >
Cataloging Options) each time you add
items to the catalog.

When the Cataloging Options have been set, Portfolio begins
cataloging the items and displays a progress window so you can
track its progress.

Note: Since Portfolio works with thumbnails and references to
item source files rather than the actual file content, if you move
or rename files and then wish to access the source file contents,
(such as when copying items to a document in another applica-
tion, Previewing the item, or editing the source file) you will need
to “update” the catalog records. See “Updating Cataloged
Items” starting on page 121. 
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To Add items to an open catalog:

Note: You must have a catalog open, either a new, empty catalog
or an existing catalog, before you can add items.

1. Drag and drop selected files, folders, or volumes into
the open Gallery window. 

— or  —

1. Choose “Add Items...” from the Catalog menu, then
locate the files, folders, or volumes of items that you

want to add to the catalog.

To add... Follow this procedure...

A single file Locate and select the file you want to
add to the catalog, then click “Open.”

All files in a folder Locate and select the folder or volume   
or a volume you want to add. Click the select Folder 

button. 
All files and Locate and select the folder or  
subfolders within volume that you want to add, check the
a folder or volume “Include Subfolders” option. Click the 

select Folder button.

Tip

You can select multiple files from
the Open dialog by pressing Shift
(Macintosh) or Ctrl (Windows) as
you select additional items. Mac
OS: You must have Navigation
Services enabled. 

Tip

Windows: System limitations
prohibit selecting more than
approximately 40 individual files
at the same time (more files can
be selected if they are in folders).
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Tip

Portfolio’s default Cataloging
Options settings are adequate for
cataloging under most circum-
stances. You can change these
options at any time either when
the dialog box is displayed during
an add or update, or by choosing
Catalog > Cataloging Options....

Tip

You can elect to have Portfolio
automatically apply the default
Cataloging Options when adding
or updating. To do so, deselect
the “Show Cataloging Options on
Add/Update” option in Edit >
Preferences.

The Cataloging Options dialog will be displayed, allowing
you to choose a variety of options for the cataloged files. 

5. From the Cataloging Options dialog, select either
“Add” or “Add & Update” from the Modify Method
option of the General tab. You can review or change the
other options, or simply allow Portfolio to use the
default options presented.

Cataloging Options are discussed on starting on page 130.

6. Click “OK.”

Portfolio scans the volume(s) containing the source files,
examines each file before adding it to the catalog, extracts
the data as specified in Cataloging Options, and displays
the “Cataloging Status” dialog to keep you posted on its
progress.

When cataloging is complete, the items just added to the
catalog will be displayed in the Gallery window.

Tip

Once the first process has started
you can drag additional files, fold-
ers, or volumes to a Portfolio
Gallery to initiate more cataloging
processes while the first com-
pletes. Portfolio allows up to three
cataloging processes to be active
simultaneously. 
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Updating Cataloged Items 

When information associated with an item’s source file changes,
you will want to “update” the catalog to reflect the changed
information. You can update items individually, or update whole
folders and volumes at the same time. You can even have Portfolio
track changes and update automatically (see sidebar Tip).

The process of updating changes the pointers to each item’s
source file (if these have changed). Updating can also be used to
regenerate item thumbnails (such as when the source file has been
edited); to read in any new or modified information such as file
modification date; and to update any keywords, descriptions, cus-
tom field data, etc. that is embedded in the file. You can control
which types of fields are updated using the options in the Cata-
loging Options dialog that is displayed when you update items.
You can also set default cataloging options (Catalog > Cataloging
Options).

You will want to update cataloged items when you:
• Move, rename, or delete files, folders, or volumes that have

been cataloged. 
• Edit source file(s) and want the catalog records to reflect those

changes.
• Want to change the thumbnail size displayed in the catalog.

Two Ways to Update

There are two ways to initiate an update:

1. Using the “Add Items...” command (or by dragging and dropping
files into an open catalog). Using this method you provide
Portfolio with the path to the source files (you tell Portfolio
where to find them.) Portfolio will scan the files and update the
information. For example: If you know which files, folders, or
volumes contain source files that need to be updated and you
have easy access to those files, or if you have a large number of
items to update, you can drag and drop them into the catalog’s
open Gallery window, or alternately select Catalog > Add Items,
then locate the files or folders using the system folder hierarchy. 

2. Using the “Update Items...” command. When you update using
this method you are asking Portfolio to locate the source files.
Portfolio will attempt to locate the files using the pathname in
the catalog. If the files are found, the records will be updated. If
the files are not found, you will be asked to locate them. For
example: If you don’t know which links have changed, or you

Tip

When you work with item source
files from within Portfolio (such as
moving, renaming, or deleting
them), Portfolio is aware of
source file changes. This allows
Portfolio to update those records
automatically, reducing or elimi-
nating the amount of manual
updating that you need to do. See
“Working with an Item’s Source
File” starting on page 83.

Tip

You can add and update items
at the same time by dragging
and dropping source file fold-
ers into an open catalog, then
selecting “Add & Update” from
the Cataloging Options dialog.
If Portfolio finds a catalog item
with the same name as any of
the source files, the existing
record is updated. If Portfolio
doesn’t find a catalog item for
a particular source file name, a
new record is created.
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have just a few items to update and you don’t have easy access
to the source files (such as when they are spread across a num-
ber of folders or volumes), you would select those items in the
Gallery window, then choose Catalog > Update Items to initiate
the update. 

After you initiate the update, Portfolio displays the Cataloging
Options dialog so that you can select or change options before
updating begins. Portfolio provides default Cataloging Options
that will serve most needs, so you can quickly update without
spending time learning about these options. (To select the default
options, click “OK” on the Cataloging Options dialog.) You can
bypass this dialog altogether by disabling this option in
Portfolio’s Edit > Preferences dialog. With “Show Cataloging
Options” disabled, Portfolio automatically applies the default
cataloging options (or the last-saved options if any were specified
in Catalog > Cataloging Options) each time you add or update
catalog items.

To Update using the Drag and Drop/Add Items method:

1. Open the catalog that you want to update. 

2. Locate the files, folders, or volumes to be updated, then
drag and drop them into the open Gallery window. 

— or —

2. Choose “Add Items...” from the Catalog menu, or press
Command+E (Mac OS) or Ctrl+E (Windows), then
locate the files, folders, or volumes that you want to
have updated.

Refer to the chart on page 119 for instructions on specify-
ing folders, sub-folders and volumes.

The Cataloging Options dialog will be displayed, allowing
you to choose a variety of options for updating the files. 

3. From the Cataloging Options dialog, select “Update,”
“Add & Update,” or “Update Unconditionally” from
the Modify Method option of the General tab. 

Cataloging Options are discussed on page 130.

4. You can review or change the other options, or simply
allow Portfolio to use the default options presented.
Click “OK.”

Portfolio scans the volume(s) containing the source files
and updates item records based on the Cataloging Options
settings.
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To Update using the Update Items method:

1. Open the catalog that you want to update. 

2. In the Gallery window, select the items that you want
updated. To update all the items, choose Edit > Select
All [Command+A (Mac OS) Ctrl+A (Windows)].

3. Choose Catalog > Update Items... [Command+U
(Mac OS) Ctrl+U (Windows)]. 

4. Review or change Cataloging Options (to change Modi-
fication method see sidebar Tip), or simply allow Port-
folio to use the options presented, then click “OK.”

Portfolio searches for each item’s source file using the
pathname stored in the item record. 

If the source file is found, the record is updated based on
the Cataloging Options settings. 

If the source file cannot be found, you are prompted to
locate it. If you select a new file for the selected item, the
record is updated with information from the new file, based
on the Cataloging Options settings.

If the source file cannot be found and you click “Skip File”
when prompted to locate the file, the selected record is left
untouched.

Tip

Portfolio automatically updates
all selected items located in the
same folder (after you locate the
first file, others in the same fold-
er will be updated automatically).

Tip

The Update Items command
(Catalog > Update Items...)
automatically defaults to the
“Update” Modification Method.
You can set it to “Update
Unconditionally” from the
Cataloging Options dialog.
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Tip

You can edit and update your
images and media files right from
the catalog—without ever having
to search for the source files: Use
the Edit Original command (Item
> Edit Original) to open the item
for editing. Modify and save the
file as usual, then return to Portfo-
lio and choose “Update Items.”
Because the source file has not
moved, Portfolio will update the
record without asking you to
locate it.

Updating to Regenerate Thumbnails

You can elect to regenerate thumbnails when you update catalog
items by choosing this option in the Cataloging Options dialog
(Catalog > Cataloging Options: Update tab). Regenerating during
an update offers the same options: by extracting the thumbnail
from the source file or by building a thumbnail. See page 136 for
more information on generated and extracted thumbnails.

You may want to regenerate the thumbnail for an item when you
have edited the file and the thumbnail has changed. In this case,
choose Regenerate Thumbnails from the Update tab, then choose
“Update Items.” The Cataloging Options dialog opens with the
default update method “Update” selected. Update checks the
modification date; since this has changed, the item will be
updated.

You might also want to regenerate thumbnails in order to switch
between using a 112 x 112 pixel thumbnails and the larger 256 x
256 pixel thumbnails. In this case, choose Regenerate Thumbnails
from the Rules tab, then select “Update Items.” This will open the
Cataloging Options dialog where you can switch the update type
to Update Unconditionally; Update Unconditionally does not
check to see if modification date has changed. A standard Update
would check for a modification date change and skip the update
because the source file has not been modified.

Note: When you change the Modify Method setting during an
update, it only changes the modification method for that session.
That is, if “Add” was set as the Modify Method previously, it will
still be set to “Add” after the “Update Items” command is
executed.

Tip

You can manually update an
item’s thumbnail by previewing
the item, then choosing Item >
Regenerate Thumbnail.
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Identifying Missing Files

Portfolio’s Missing Files command locates cataloged items whose
source file has been moved, renamed, or deleted, and the catalog
link has not been updated to reflect this change. 

Note: Portfolio searches for missing files on mounted volumes
only. If a volume containing cataloged item source files is not
mounted, Portfolio will not report on those files.

To check for Missing Files:

1. Choose “Missing Files...” from the Catalog menu (or
press Command+Option+M (Mac OS) or Ctrl+Shift+M
(Windows).

Portfolio compares each item’s pathname as stored in the
catalog record against all mounted volumes to see if the
source file can be found at that location. The results are
reported in the Missing Files dialog.

2. If Missing Files were located, select each item, then
click either the Update or the Delete button at the
bottom of the dialog to update the catalog.

Update: Initiates a catalog Update (see page 121). Allows
you to manually locate the missing source file.

Delete: Deletes the item from the catalog (see page 75).
Allows you remove items from the catalog if the source
file cannot be located.

Tip

You can select and update or
delete multiple items on the list.
Pressing Shift while choosing
items from the list to select
contiguously. Press Command
(Mac OS) or Control (Windows)
to select non-contiguously.
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Background Cataloging

You can automate the cataloging process by designating “watch”
folders or directories that Portfolio will check at designated
intervals. New files dropped in these folders will automatically be
added to the catalog, and modified files will be updated.

Overview of Background Cataloging

When items are added to the designated “watch” folder, they are
cataloged automatically, using the current settings in Cataloging
Options (Catalog > Cataloging Options). Only new or modified
items are cataloged. You can create as many different automations
as you like, and specify a check frequency that the folders are
checked in increments that range from 5 seconds to 1 day.

Background cataloging automations are catalog specific and must
be enabled each time the catalog is opened. This prevents
automations from being enabled on multiple workstations in a
multi-user environment. 

When the Background Cataloging dialog (Catalog > Background
Cataloging) is opened, Portfolio verifies the path to the Watch
folder. If a problem is encountered, an alert icon is displayed next

Background Cataloging

Background Cataloging allows you to
create, modify, and delete catalog
automations.

A Activate/Deactivate: Click here to
deactivate an automation without
deleting it from the list. To avoid
problems with multiple users,
automations must be activated each
time the catalog is opened.

B Automations: Lists all the background
automations available.

C Status: Lists the current status of the
automation.

D Alert Icon: Indicates the Watch folder
was not found in the specified path.

E Checkmark: Indicates that the
automation is active and running.

F Done: Click here when you have
finished editing or activating
automations.

G Edit Buttons: Use these buttons to
create, edit, and delete automations.

A C

D F

G

E

B

Tip

Portfolio will not automatically
delete items from the catalog that
are no longer found in the folder
being monitored.

126



to the automation. The automation cannot be enabled until the
path is corrected or changed. 

From the Background Cataloging dialog you can enable specific
automations. Automations will continue to operate until the
catalog is closed. If the Run in Silent Mode feature is disabled,
the Cataloging Status window will be displayed on the
workstation when items are being cataloged. 

Enable Run in Silent mode if you want cataloging to proceed
without displaying progress status. When running in Silent Mode,
newly cataloged records will not be added to the active Gallery.
This allows you to perform other work in Portfolio without being
interrupted by the background cataloging.

Automation Settings

The Automation Settings dialog
(Catalog > Background Cataloging >
New or Edit) allows you to specify a
Watch folder and other parameters for
the automation.

A Automation Name: Enter a name for
the automation.

B Scan Frequency: Indicate how long to
wait between scans of the Watch
folder for new items. Intervals are
from 5 seconds to 1 day.

C Watch Folder: Click the folder icon,
then locate the folder to be watched
for incoming items. 

D Include Sub-folders: Monitors files in
sub-folders of the specified directory
as well as the top level folder.

E Run in Silent Mode: Causes Portfolio
to not display the Cataloging Status
window during background
cataloging, and not add newly
cataloged records to the active
Gallery.

F Cancel: Close the dialog box without
making any changes to the
automation.

G OK: Apply the indicated settings to
the automation and close the dialog.

F G

A

D

B

C

E
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To set up a Background Cataloging automation:

1. From the Catalog menu, choose “Background
Cataloging...”

The Background Cataloging dialog is displayed.

2. Click “New.”

The Automations Settings dialog is displayed.

3. Enter a name for the automation.

4. Click the Folder button and locate the folder to monitor
(the Watch folder).

Note: Do not select the same folder for Background
Cataloging and Disk Previews (page 214). Doing so will
disable Background Cataloging.

5. Select other options as appropriate.

6. When you have completed setting up the automation,
click “OK.”

7. Enable the automation by selecting it from the list 
(page 126). 

8. Click “Done.”
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To enable existing Background Cataloging automation(s):

1. Open the catalog that you want to enable Background
Cataloging for.

2. From the Catalog menu, choose “Background
Cataloging...”

Portfolio will check the pathnames for existing
automations and display an alert icon if any problems were
encountered.

2. Place a checkmark in front of each automation that you
want to enable.

3. Click “Done.”

Portfolio will begin checking the Watch folder at the
interval specified for the automation.

To clear an alert icon associated with an automation:

1. Select the automation on the list, then click “Edit.”

2. Click the Folder icon and relocate the appropriate
Watch folder.

3. Click “Done” to close the Automation Settings dialog.

4. Reopen the Background Cataloging dialog (Catalog >
Background Cataloging) and verify that the alert icon
is no longer present.

Reopening the Background Cataloging dialog forces
Portfolio to recheck the path. If the dialog is not reopened,
Portfolio will have no way of knowing that a correction
has been made.
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Cataloging Options

Unless you indicate otherwise in Edit > Preferences, Portfolio
displays the “Cataloging Options” dialog box whenever you drag
and drop files or folders into an open catalog. Whether or not the
Cataloging Options dialog is displayed, the current Cataloging
Options settings are checked any  time that you add items to a
catalog or update the items in a catalog.

Refer to the Cataloging Options dialog boxes and Options lists on
pages 130 through 145 for descriptions of the available options.

A General tab 

B Modification Method: Controls how
source file information affects the cat-
alog. “Add” creates new records for
items, if a record does not exist.
Update updates the item record, if a
matching record exists.

C Path as Keywords: Determines
whether or not the source file path
name will be included as keywords,
and if so, how much of the path
name is used.

D Path as Categories: Determines
whether files are categorized on the
Categories palette (page 169).

E Thumbnail Quality: Sets thumbnail
compression. A higher quality thumb-
nail uses less compression, but takes
up more space in the catalog.

F Thumbnail Size: Controls thumbnail
size. 112x112 takes up less space in
the catalog, but may appear pixelated
when displayed at 256x256.

G Help: Displays information about an
option when the mouse is placed
over it.

H OK: Closes the dialog and accepts
the settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

I Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

Cataloging Options—General tab

B

C

D

F

G

I

A

Tip

The important Cataloging Options
when updating are: Thumbnail
Quality, Thumbnail Size, and the
Update tab and Mappings tab
options. Other Cataloging Options
settings have no effect on the
updating process.
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Modification Method Add Adds a record to the catalog for each item being added, if a
record does not currently exist. Ignores items if a catalog
record already exists for the item.

Update Updates items only if there have been changes. Ignores
changes in pathname if a copy of the source file exists at
the previously cataloged location.

Add & Update Adds items if a record does not already exist, and updates
records if the items exist but have changed.

Add Unconditionally Adds a record for the item even if a record already exists.

Update Uncond. Updates records even if the item source file exists in the
previously cataloged location. Allows you to copy source
files to a new location and have the catalog updated to 
the new location.

Path as Keywords None Filenames and pathnames are not added to the keyword list.

File Name Adds the item’s filename to the keyword list.

File & Folder Name Adds the item’s filename and immediate folder name to the
keyword list.

Path Name Adds the item’s filename and all of its folder names, but
ignores the volume name.

Path and Volume Adds the item’s full path, including volume name.

Path as Categories* None No folder hierarchy is created on the Categories palette.

Selected Folders Creates a hierarchy on the Categories palette based on the
directories of files added. For example, if a cataloged folder
contains 3 items, a folder would be created on the Cate-
gories palette with those 3 items associated with it. If only the
files are cataloged, their immediate parent folder is used.

Thumbnail Quality High Creates a high resolution thumbnail using minimum 
compression.

Medium Creates a medium resolution thumbnail using medium
compression.

Low Creates a low resolution thumbnail using a higher level of
compression.

Thumbnail Size 112x112 Generates a 112 x 112 pixel Thumbnail.

Always generates a 256 x 256 pixel Thumbnail, even if a
256x256 smaller thumbnail exists.

* The Categories palette is discussed in detail starting on page 169.

Option Choices Description

Cataloging Options—General
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Modification Method

When you add items to the catalog, or update existing items
(using either the Add Items/Drag and Drop method or the Update
Items method as described on pages 122 and 123), you can select
from the following options:

• Add
• Add Unconditionally
• Add & Update
• Update
• Update Unconditionally

Which method you select will depend on what you are trying to
accomplish. If you are only adding items, choose “Add” or “Add
Unconditionally.” If you are only updating items, choose
“Update” or “Update Unconditionally.” If you know that you are
both adding and updating, or if you want Portfolio to intelligently
add or update as necessary, select “Add & Update.” “Add &
Update” provides the most flexibility, and is a good choice if you
want to automate the process as much as possible (in this case
you might also want to prevent the Cataloging Options dialog
from being displayed each time items are added or updated—you
can disable this option in Edit > Preferences).

Add: Adds item files to the catalog as new records if Portfolio
determines that the files do not already exist in the catalog. If a
matching record already exists, the file is skipped.

Add Unconditionally: Adds files to the catalog as new records,
regardless of whether a record for the file already exists in the
catalog. 

Add & Update: Performs both the Add process and the Update
process. Portfolio adds a new record to the catalog if it deter-
mines that the file does not exist in the catalog. If a matching
record is found, Portfolio updates the record.

Update: Updates existing records in the catalog if Portfolio deter-
mines that the files match existing records. If no matching record
is found in the catalog, the file is skipped.

Update Unconditionally: Updates existing records in the catalog
looking only at the filename and ignoring record criteria used in
the normal Update logic. Specifically, Portfolio does not examine
file dates and paths when determining whether the file matches an
existing record. 
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More About Update Unconditionally

Update Unconditionally determines a source file match based on
filename only, not pathname. This can be useful when updating
the catalog record from a copy of the source file. 

Update Unconditionally is also useful when you want to update
the catalog record but the file has not changed, such as to change
catalog thumbnail size. (In this case, if you select Update rather
than Update Unconditionally nothing will happen, since the file
has not changed).

Note: Exercise caution when using Update Unconditionally. This is
a powerful and useful tool, but it has the potential to effect
unwanted changes: When you catalog two files by the same name
located in different directories, Portfolio differentiates between the
two records using their different pathnames. When you Update
Unconditionally, Portfolio discards the pathname in its record
search and updates the first record with the selected filename that it
comes to. For example, assume that C:\Artwork\Box.jpg and
C:\Photos\Box.jpg are both cataloged in the same catalog. You
select Update Unconditionally in order to enlarge the catalog
thumbnail for C:\Photos\Box.jpg. Portfolio searches the catalog
records for “Box.jpg” and finds the record for C:\Artwork\Box.jpg,
which it updates. This replaces the thumbnail in the record for
C:\Artwork\Box.jpg with the thumbnail for C:\Photos\Box.jpg.
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Cataloging rules from the Cataloging Options: Add tab is used
when any of the following Modification Methods (page 132) are
selected: Add, Add Unconditionally, Add & Update.
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Cataloging Options—Add tab

B
D
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A

A Add tab 

B General: Controls which, if any,
embedded information is extracted
when items are added to the catalog.
Also indicates how the extracted
information should be handled. Also
controls whether Thumbnails are
regenerated, and whether Digimarc
data is detected. 

Options are: Extract Keywords,
Extract Descriptions, Extract
Thumbnail, Skip Files without
Thumbnails, and Always Detect
Digimarc. These options are
described in the table on page 135.

C Help: Displays information about an
option when the mouse is placed
over it.

D Video: Controls how video is handled
through QuickTime. Options are: Use
Poster Frame (default) as the thumb-
nail; Use Frame #; and Use Frame
after xx seconds. 

E Document Text Indexing: Controls
whether the text in documents
(Acrobat or PowerPoint) is indexed. 

F Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

G OK: Closes the dialog and accepts
the settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

E



General Extract Keywords Looks for and extracts any keywords saved with the 
source file.

Extract Description Looks for and extracts any description saved with the
source file.

Extract Thumbnail Looks for and extracts any preview image saved with the
source file. Note: If you are adding QuickTime movies, we
recommend that you do not use this option. You will get a
larger thumbnail for the movie if you let Portfolio create it,
rather than having it extracted.

Skip Files without Does not catalog the file if a thumbnail cannot be extracted
Thumbnails or generated.

Always Detect When disabled, Portfolio will only look for a Digimarc water-
Digimarc mark when it attempts to generate a thumbnail, not when

thumbnails are extracted. When enabled, Portfolio attempts 
to generate a thumbnail for every item and checks for 
Digimarc data; the Extract Thumbnail option is disabled.

Document Text Indexing Indexes the text of Adobe Acrobat and Microsoft 
PowerPoint files by adding each word to the catalog 
index. Preview the original file to read document  
document text.

Video* Use Poster Frame Use Poster Frame for thumbnail (by default, the first frame).
If the first frame of a group of movies is black, for example,
one of the other options can be used for the thumbnail.

Use Frame # Allows you to choose a particular frame for the thumbnail
(for example, Frame #2).

Use Frame After Allows you to select the frame occurring after a specific
time interval (specify number of seconds).

* QuickTime movies (.mov) only; not compatible with m1v, mpeg, swfl, and animated gifs.

Option Choices When items are Added to catalog:

Cataloging Options—Add Tab
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Thumbnails: Extracted vs Generated

An Extracted Thumbnail is one that already exists in the source
file. If “Extract Thumbnail” is enabled (Catalog > Cataloging
Options: Add or Update tab), Portfolio will look for and extract
Thumbnails from various file types, such as:

• Photoshop files
• EPS files
• Adobe Illustrator files
• Any Macintosh file with a thumbnail in the "pnot" resource

If the source file does not contain a thumbnail, Portfolio will
attempt to generate one.

A Generated Thumbnail is one that is created by Portfolio by
reading the source file with an appropriate translator. If “Extract
Thumbnail” is disabled (Catalog > Cataloging Options > Add tab
or Update tab), Portfolio will always attempt to generate a thumb-
nail, even if a thumbnail exists in the source file. Depending on
the type of embedded thumbnail, Portfolio may be able to render
a better thumbnail than that supplied in the source file. 

Note: Extracting thumbnails is faster than generating them.

Thumbnail Size

Portfolio allows you to store thumbnails at either of two different
sizes: 112 x 112 pixels, or 256 x 256 pixels. 

The advantage in having the larger size thumbnails is as you
might expect—improved resolution when viewed at the larger
size. The disadvantage is that the larger thumbnails occupy about
four times as much catalog space (typically 20K vs 5K). 

Thumbnails that are embedded in the source file typically range
in size from 80 x 80 pixels to 128 x 128 pixels. Portfolio will
scale these extracted thumbnails to the closest size, typically 112
x 112 pixels. If you elect to save thumbnails at 256 x 256,
Portfolio will automatically disable the Extracting Thumbnails
option and will generate the larger thumbnails from the original
image.
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Cataloging rules from the Cataloging Options: Update tab
options are used when any of the following Modification
Methods (page 132) are selected: Update, Update
Unconditionally, Add & Update.

Cataloging Options—Update tab

B

D

C

F G

A

A Update tab 

B General: Controls which, if any,
embedded information is extracted
when items are updated. Also
indicates how the extracted
information should be handled,
whether Thumbnails are regenerated,
and whether Digimarc data is
detected. 

Options: Extract Keywords, Extract
Descriptions, Extract Thumbnail, Skip
Files without Thumbnails, and Always
Detect Digimarc. These options are
described in the table on page 138.

C Help: Displays information about an
option when the mouse is placed
over it.

D Video: Controls how video is handled
through QuickTime. Options are: Use
Poster Frame (default) as the thumb-
nail; Use Frame #; and Use Frame
after xx seconds. 

E Document Text Indexing: Controls
whether the text in documents
(Acrobat, PowerPoint) is indexed.

F Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an
update items request.

G OK: Closes the dialog and accepts
the settings. Starts the cataloging or
updating process if displayed in
response to an update items request.

E
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General Regenerate If disabled (not checked), the Thumbnail in the catalog
record will not be changed. If enabled (checked) the thumb-
nail will be updated if the source file has changed, or if 
Update Unconditionally is selected.

Extract Thumbnail Controls whether Portfolio looks for an embedded Thumb-
nail or creates its own. This option is ignored if Regenerate
is disabled.

Extract Description Replace: Replaces the existing description with the new one.
Append: Adds the new description to the end of the old one.

Extract Keywords Replace: Replaces existing keywords with the new ones.
Append: Adds the new keywords to the existing keywords.

Always Detect When disabled, Portfolio will only look for a Digimarc water-
Digimarc mark when it attempts to generate a thumbnail, not when

thumbnails are extracted. When enabled, Portfolio attempts 
to generate a thumbnail for every item and checks for 
Digimarc data; the Extract Thumbnail option is disabled.

Document Text Indexing Indexes the text of Adobe Acrobat and Microsoft Power-
Point files by adding each word to the catalog index.
Preview the original file to read document document text. 

Video Use Poster Frame Use Poster Frame for thumbnail (by default, the first frame).
If the first frame of a group of movies is black, for example,
one of the other options can be used for the thumbnail.

Use Frame # Allows you to choose a particular frame for the thumbnail
(for example, frame #2).

Use Frame After Allows you to select the frame occurring after a specific
time interval (specify number of seconds).

* QuickTime movies (.mov) only; not compatible with m1v, mpeg, swfl, and animated gifs.

Option Choices When catalog items are Updated:

Cataloging Options—Update Tab
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Tip

Mac OS: To quickly enable or dis-
able mappings, click and drag in
the checkmark column. This also
works in the Action column.

Mappings

Portfolio Mappings give you the ability to extract text data that is
embedded in source files fields other than the standard
Description and Keywords fields. 

Typically, software that allows you to add information to a file
(Photoshop’s File Info is a good example) assigns a numeric ID,
or Tag, to each field of embedded data. Using Portfolio’s
Mappings feature you can map this field ID to a Custom Field in
your catalog, and have Portfolio copy the source file data into the
Custom Field.

Portfolio provides currently known Tag Codes for popular for-
mats (Photoshop, IPTC, TIFF). These are displayed in the
Mappings tab (Catalog > Mappings), and listed in Appendix C
(page 297). But you are not limited to the pre-installed codes—
you can add Tag codes from any software that supports this con-
vention, and also add new codes as they become available. 

To use Mapping, you must create a Custom Field (Catalog >
Administration > Custom Fields tab) for each tagged field that
you want to extract from item source files. If the ID Code for the
source file Tag is already listed in the Mappings table, all you
need to do is Edit the entry and add the Custom Field name that
you want to map it to. If the necessary code is not listed in the
table, you can add it to the list and then map it to your Custom
Field. 

To Enable or Disable an existing Mapping:

Note: Mappings must be created before they can be used. Refer to
the following pages for instructions on creating catalog Mappings.

1. From the Mappings list (Catalog > Cataloging Options:
Mappings), select the Mapping that you want to enable.

2. Click the “Edit” button or double-click the selection to
open the Edit dialog or (Macintosh only) click in the
first column of the Mapping that you want to change. 

3. From the Edit dialog, select “On” from the “State”
pop-up menu, then click “OK.”

A check indicates that the Mapping is enabled: Portfolio
will extract data from the source file field and place it in
the indicated catalog Custom Field. No check indicates that
the Mapping will be ignored.

4. Click “OK” to close the Cataloging Options dialog and
save the settings.
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Notes about Mappings:

1. Mappings (that are enabled) are used during both Add and
Update operations.

2. You cannot map to keywords or descriptions.

3. Some tags are automatically mapped to keywords or
descriptions. These tag codes cannot also be used to map to a
Custom Field.

4. You cannot map one tag code to multiple Custom Fields.

A Mappings tab 

B List Headers: On/Off, Title, Code,
Field, Action (see item descriptions
(H) through (L)).

C Add: Opens the Mapping dialog to
add a mapping.

D Edit: Opens the Mapping dialog to
edit the selected mapping.

E Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

F OK: Closes the dialog and accepts
the settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

G Delete: Deletes the selected mapping.

H Title: Enter a title for the mapping.

I Code: Enter the ID code for the
source file field to be mapped.

J Field: Select an existing Portfolio cat-
alog Custom Field from the pop-up.

K State: On enables the mapping; Off
disables it. Mac OS: You can enable
and disable mappings from the check-
mark column in the Mappings tab. 

L Action: “Replace” replaces any exist-
ing data  in the catalog Custom Field
with the data from the source file field.
“Append” adds data from the source
file field to any existing data in the
catalog Custom Field. Mac OS: You
can toggle Actions (Replace or
Append) by clicking in the Action 
column.

Cataloging Options—Mappings tab  (Macintosh)
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Tip

Since you cannot export a tagged
data field without a Custom Field
to map it to, the Mappings tab will
be blank until you have created at
least one Custom Field.

To Map an existing Tag Code to a Custom Field:

1. Create a Custom Field (Catalog > Administration >
Custom Fields) for each source file tagged field that you
want to extract.

2. Select Catalog > Cataloging Options [Command-J 
(Mac OS) or Ctrl+J (Windows)]. Click the Mappings
tab to select it.

3. Select the first source file Tag Title/Code that you want
to map, then click “Edit.”

The “Mapping” dialog will be displayed, showing the
selected Tag and its ID Code.

A Mappings tab 

B List Headers: On/Off, Title, Code,
Field, Action (see item descriptions
(J) through (N)).

C Add: Opens the Mapping dialog to
add a mapping.

D Edit: Opens the Mapping dialog to
edit the selected mapping.

E Delete: Deletes the selected mapping.

F OK: Closes the dialog and accepts
the settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

G Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

H Apply (Windows): Apply changes.

I Help (Windows): Access online Help.

J Title: Enter a title for the mapping.

K Code: Enter the ID code for the
source file field to be mapped.

L Field: Select an existing Portfolio cat-
alog Custom Field from the pop-up.

M State: On enables the mapping; Off
disables it.

N Action: Append adds data from the
source file field to any existing data
in the catalog Custom Field. Replace
replaces any existing data  in the cat-
alog Custom Field with the data from
the source file field. 

Cataloging Options—Mappings tab  (Windows)
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4. Assign a catalog Custom Field to the Tag by selecting it
from the Field pop-up menu.

5. Set the State to On or Off. 

On instructs Portfolio to import the data from the Tag. Off
instructs Portfolio to ignore the Tag.

6. Select the appropriate Action from the Action pop-up. 

Replace replaces any existing data in the specified Custom
Field with the data from the source file field. Append adds
data from the source file field to any existing data in the
catalog Custom Field. If the field is a Multi-valued field,
Append adds a new value to the list.

7. Click “OK” to accept the settings and return to the
Mappings tab.

8. Repeat steps 3 through 6 for all the tagged fields that
you wish to import.

To Add a Tag ID Code to the Mappings list:

1. Create a Custom Field (Catalog > Administration >
Custom Fields) for each source file tagged field that you
want to map.

2. Select Catalog > Cataloging Options... [Command+J
(Mac OS) or Ctrl+J (Windows)]. 

3. Click the Mappings tab to select it, then click “Add.”

4. Enter the Tag ID Code, and enter a Title for the Tag.

Data is extracted using the ID Code. The tag Title is infor-
mational—you can name the tag anything you like.

5. Assign a catalog Custom Field to the Tag by selecting it
from the Field pop-up menu.

6. Set the State to On or Off, and select the appropriate
Action from the Action pop-up. 

7. Click “OK” to accept the settings and return to the
Mappings tab.

8. Repeat steps 3 through 7 for all the tagged fields that
you want to map.
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Excluding Files from being Cataloged

Using Portfolio Cataloging Options, you can tell Portfolio to skip
files of a certain File Type or Name.

Exclude by Type: You can exclude files of a specific File Type
from a catalog by deselecting or deleting that file type from the
File Types list of the Cataloging Options File Types tab (below).

Exclude by Name: You can exclude files with a specific File
Name by creating an “exclusions” list that specifies an explicit set
of file names or patterns. File name exclusions are specified in
the Cataloging Options Exclude tab (page 145).

File Types

Portfolio recognizes and catalogs all file types, regardless of
whether the file type appears on the File Types list. You only need
to add file types to the list if you want to exclude a type that does
not appear on the list, or if you will be excluding some types and
including other types that do not appear on the list. 

The File Types tab is described on page 144. The default File
Types list is shown in Appendix B, page 296.

To add a File Type:

1. Choose Catalog > Cataloging Options [or press
Command+J (Mac OS) or Ctrl+J (Windows)].

2. Click the File Types tab to select it.

3. Click “Add.”

3. Enter the file type information, or click “Same As...”
and locate a file of the same type. Portfolio will copy the
parameters of this file type into the fields.

4. Click “OK” to add this file type to the list.

Tip

To catalog all File Types, select
“Catalog All Types” from the File
Types tab of the Cataloging
Options dialog (Catalog > Cata-
loging Options).
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A File Types tab 

B Catalog All / Catalog Following
Types: Determines which file types
Portfolio will recognize.

All Types: All File Types will be cata-
loged, even if the File Type does not
appear on the list.

Following Types: Recognizes only
those File Types that are enabled
(checked) in the File Types list.

C File Types list: Displays a list of all
File Types recognized by Portfolio.
Enable the “Catalog Following Types”
option and uncheck a file type to
prevent Portfolio from recognizing it.

D OK: Closes the dialog and accepts
the settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

E Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

F Delete: Deletes the selected File
Type from the list.

G Add/Edit: Opens the File Type modifi-
cation dialog. Click Add to add a File
Type to the list. Select a file type and
click Edit to modify a File Type entry.

H Extension: Enter the 3-letter File
Type extension.

I Mac File Type: For Macintosh files,
enter the File Type.

J Description: Enter a description for
the File Type.

K Storage Preference: Select “Store in
Preferences” (Mac OS) or “Store
Locally” (Windows) to save the File
Types list on the user’s machine so
that it is available for all catalogs
opened on that machine. Select
“Store in Catalog” to store the list in
the catalog, making it available for all
users who open the catalog.

L Same As: Click to locate a file with
the desired File Type. Portfolio will
populate the File Type fields with
information from the selected file.

The default File Types list is shown in
Appendix B, page 296.

Cataloging Options—File Types tab
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Exclude
Using the Cataloging Options Exclude tab you can exclude files
with a specific File Name by creating an “exclusions” list that
specifies an explicit set of file names or patterns. 

To add a File Name  to the exclusions list:

1. Choose Catalog > Cataloging Options [or press
Command+J (Mac OS) or Ctrl+J (Windows)].

2. Click the Exclude tab to select it.

3. Select the file name search parameter from the pop-up
menu: Begins with, Contains, or Ends with. 

4. Enter the filename or partial name that you want to
exclude from cataloging. Letter case (uppercase/lower-
case) is ignored.

5. Click “Add.”

Portfolio searches each pathname and each segment of the
path for text strings matching any of the parameters you
enter.  For example: If you enter “Begins with: DUP” and
“Ends with: 97” Portfolio will exclude “Duplicate_PH050,”
“Report_97,” and “C:\Duplicates\Image.jpg”

A Exclude tab 

B File Name and Name Options Pop-up
menu: Select “Begins with,” “Con-
tains,” or “Ends with,” then enter the
name or partial name that you wish to
exclude from cataloging.

C Exclude list: Lists all of the names
and partial names that will be
excluded from cataloging. Excludes
files matching any of the listed
parameters (acts like an “or”
function).

D Cancel: Close the dialog without
changing any settings.

E OK: Close the dialog and accept the
settings.

F Editing controls: Allows you to Add or
Delete file names from the Exclude
list.

Cataloging Options—Exclude tab
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Tip

A common use of exclusions is to
exclude CMYK plate files from a
catalog, allowing only the compos-
ite file to be cataloged. To do this,
create four exclusions: Ends with
.C, Ends with .M, Ends with .Y,
and Ends with .K. If the plate files
are saved with these extensions
(which they usually are), Portfolio
will skip these files, even if they
are placed in the same folder as
the composite. This allows you to
drop a whole folder of CMYK files
into an open Gallery to catalog
them, without manually selecting
just the composite images.
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Editing Fields in Place in Record View

Portfolio 5.0 adds another dimension to organizing and managing
catalog records—the ability to edit fields directly, without the
need to select and open special editing palettes. 

In Record view, you can edit directly in the desired field by
enabling the “Edit” option in the Record tab of the Customize
Gallery dialog (View > Customize...).

With Edit in Record View enabled, add (+) and delete (-) buttons
are displayed beside multi-valued fields, such as keywords. This
allows you to easily add or delete keywords directly from the
gallery window.

Note: System fields (with the exception of Keywords and
Descriptions) are not editable, since they contain information
entered by the system that is never user-editable. URL fields are
editable, but do not act as hyperlinks when Edit in Record is
enabled.

Movement Key

Next Field Tab

Previous Field Shift-Tab

Next Record Command-↑ (Mac)

Next Record Ctrl-↑    (Windows)

Previous Record Command-↓ (Mac)

Previous Record Ctrl-↓    (Windows)
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To Edit records in place in Record view:

1. From an open Gallery, choose Record view by selecting
it from the View menu, or click the Record view icon

on the Toolbar, or press Command-R (Mac OS) or
Ctrl+R (Windows). 

2. Open the Customize Galleries window by selecting it
from the View menu, or click the Customize Gallery
icon on the Toolbar, or press Command-D (Mac
OS) or Ctrl+D (Windows).

The Customize Gallery dialog is displayed.

3. Select the Record tab. 

4. Put a checkmark in the Edit box located near the
bottom of the window. 

5. Click “OK.”

The Gallery will now allow editing in place in Record
view. You can use the shift and shift-tab to move between
fields, and (Mac OS only) Command-up arrow and
Command-down arrow to move between records.
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Tip

If you double-click a keyword in
the Gallery window List view (or in
Record view, if keywords are dis-
played), all the items with that
keyword are located and dis-
played in the Gallery (replacing
the items previously displayed in
that Gallery).

Note

You must have Editor level access
or higher to modify keywords. See
page 194.

Keywords

Each item in a catalog has certain information associated with it,
such as filename, file type, volume, and so on. Each item can also
have one or more keywords associated with it. A keyword is a
word or phrase that you associate with a particular item, and a
good keyword list can be a valuable tool for finding the material
you need in a catalog. 

Keywords can be extracted from the item’s source file and/or
added to item records manually. An unlimited number of key-
words can be assigned to each item. By using catalog access level
permissions (page 192), a catalog Administrator can control who
is allowed to edit item keywords. 

A catalog can also include a preset list of keywords called the
Master Keywords List. Master Keywords can only be created
with Administrator access. Users select keywords from the Master
Keyword list, which helps maintain consistent keywording among
items in a catalog or across multiple catalogs. See “Catalog
Administration,” (page 202) for information on creating and
maintaining a Master Keywords list.

Adding Keywords by Extracting Them from Source Files

If you have selected the “Extract Keywords” option (Catalog >
Cataloging Options: Add and/or Update tab) for Adding and/or
Updating, Portfolio examines all source files for keywords
created in their native applications when you add and/or update
items in a catalog. As items are cataloged or updated, extracted
keywords are added to the item’s keyword list according to the
settings in the Add and Update tabs (pages 134 and 137).

Viewing Item Keywords

You can view the keywords associated with a selected item in the
following locations:

• At the bottom of the Gallery window in List view (View > List)
• In the Gallery window in Record view (View > Record), if

keywords have been included in the view (View > Customize). 
• In the Keywords tab of the Item Properties dialog (Item > Item

Properties: Keywords)
• In the Edit Keywords dialog (Item > Edit Keywords)

When keywords are shown, the number beside each keyword
indicates how many items in the catalog have that keyword
assigned. 

Tip

For information about searching
using keywords, see page 39.
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To display the keywords for an item:

1. Select the item, then choose Item Properties... from the
Item menu, or press Command+I (Mac OS) or
Alt+Enter (Windows). 

2. In the Item Properties dialog, click the Keywords tab.

The item's keywords appear in a list box on the left. Master
Keywords appear on the right.

3. Click “OK” when you are finished viewing the keywords.

Viewing Keywords for the Selected Item

Gallery Window

Edit Keywords

Item Properties

C

B

A
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A Keywords for the selected item as
displayed in the Item Properties
dialog (Item > Item Properties:
Keywords).

B Keywords for the selected item(s) as
displayed in the Edit Keywords dialog
(Item > Edit Keywords).

C Keywords for the selected item as
displayed in the Gallery List view
(View > List).

For information on adding keywords to
the selected item, see page 152.

For information on viewing keywords for
the entire catalog, see page 150.

For information on extracting keywords
from an item’s source file, see page 204.

For information on creating a Master
Keywords list, see page 202.



Tip

You can export a catalog’s key-
words to a text file by clicking
“Export Keywords....” (Mac OS) or
“Save Keywords to File” (Windows)
on the Statistics tab of the Catalog
Properties dialog (Catalog > Cata-
log Properties: Statistics). This is
useful if you want to import those
keywords into a catalog's Master
Keywords list.

To display the keywords for an entire catalog:

1. Choose Catalog Properties... from the Catalog menu,
or press Command+Option+J (Macintosh) or
Ctrl+Shift+J (Windows). 

The “Catalog Properties” dialog is displayed.

2. Click the Statistics tab to select it.

3. Click “Calculate...”

The keywords for all items in the catalog, and the number
of occurrences of each keyword, are displayed in the list
box on the left. The more items in the catalog, the longer
this process will take.

Adding, Assigning, and Deleting Keywords
You can manually enter and assign keywords to the items in the
catalog, and you can edit an item’s keyword list whether key-
words were added manually or extracted from the item’s source
file. With the exception of the Master Keywords List, you cannot
add keywords to the catalog without assigning them to at least
one item.

To add and assign keywords to items you must first select the
items in the Gallery window. Once the items are selected you can
assign keywords in the following ways:

• Single items: From the Item Properties dialog (Item > Item
Properties), from the Edit Keywords dialog (Item > Edit
Keywords), or from the Master Keywords Palette (View >
Master Keywords Palette). See page 156.

• Multiple items: From the Edit Keywords dialog, or from the
Master Keywords Palette. See page 156.
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From the Item Properties dialog you can
work with a single selected item:

A Add: Enter a keyword, then click
Add to add it to the selected item’s
keyword list (this assigns the
keyword to the selected item).

B Remove: Select a keyword assigned
to the selected item, then click
Remove to remove it from the item’s
keyword list.

C Assign: Select an item from the
Master Keywords list, then select
Assign to assign the keyword to the
item.

D Cancel: Closes the dialog without
applying any changes. 

E OK: Closes the dialog and applies the
keyword changes to the item record.

From the Edit Keywords dialog you can
work with multiple selected items:

F Keyword field: Enter keywords to
assign to the selected items. 

G Keywords list: Shows all keywords
assigned to at least one of the
selected items.

H Add: Adds text in the Keyword field
(F) as a new keyword to all the
selected items.

I Assign: Adds the selected keyword
(which is assigned to one or more of
the selected items) to the rest of the
selected items (see page 155).

J Delete: Deletes the selected keyword
from all selected items.

K Selected Items: Shows how many
catalog items are currently selected.

L OK: Closes the dialog and applies
the keyword changes (indicated in
the State column (N)) to the selected
items.

M Cancel: Closes the dialog without
applying any keyword changes. 

N State: Displays the action that will be
taken with keywords during this
editing session. Options are: Add (H),
Assign (I), or Delete (J). The actions
indicated by the status of the State
field are not applied to the selected
items until the dialog is closed by
clicking “OK.”

Adding and Assigning Keywords to Selected Items

Item Properties
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To Add keywords to a single  item:

1. Select the item that you want to add keywords to, then
choose Item Properties... from the Item menu (or press
Command+I (Mac OS) or Alt+Enter (Windows).

The “Item Properties" dialog is displayed.

2. Click the Keywords tab to select it.

3. Type a keyword in the text box, then click “Add.”

Note: If the catalog administrator has restricted keyword
additions to only those in the Master Keyword list,
Portfolio checks your additions against the list and notifies
you of any “illegal" keywords. 

— or —

3. If you have a Master Keywords list, select a keyword
from the Master Keywords list, then click “Assign,” or

double-click the Master Keyword.
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4. When you are finished adding keywords, click “OK” to
close the dialog and assign the keywords to the item.

To Remove a keyword from an item:

1. Select the item that you want to remove keywords from,
then choose Item > Item Properties [or press
Command+I Mac OS or Alt+Enter (Windows).

The “Item Properties" dialog is displayed.

2. Click the Keywords tab to select it.

3. From the item’s keyword list, select the keyword that
you want to remove.

4. Click “Remove.”

5. When you have finished selecting all the keywords that
you want to remove from the selected item, click “OK.”
This closes the dialog and removes the keyword(s). 

The keywords are not actually removed from the item until
you click “OK.” If you accidentally remove the wrong key-
words, you can click “Cancel” to close the dialog without
applying the changes.

When you delete a keyword it appears in the text entry
box. This is handy if you decide you want to add it back—
you can do so easily by clicking the “Add” button.
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To Add a keyword and assign it to multiple items:

1. In the Gallery window, select the items that you want to
add keywords to.

2. Choose Item > Edit Keywords... [or press Command-Y
(Mac OS) or Ctrl+Y (Windows)].

The Edit Keywords dialog opens.

All the keywords assigned to at least one of the selected
items will be displayed in the keywords list.

3. Type a keyword in the text box, then click “Add.”

The “State” of the keyword is changed to “Add,” indicating
that it will be added to the catalog and assigned to the
selected items.

Note: You do not need to click “Assign” after you add a
keyword—“Add” implies “Assign” (that is, all keywords
with either Add or Assign in the State field will be assigned
to all selected items in the active Gallery when the dialog
is closed. “Add” just tells you it’s a new keyword).

4. When you have finished adding keywords, click “OK”
to close the dialog and assign the keyword to the select-
ed items.

If you close the dialog by clicking “Cancel,” all changes
are discarded.

To take a keyword that is already assigned to one item and
assign it to other items:

1. In the Gallery window, select both the item that has the
keyword you want to assign, and the items that you
want to assign the keyword to.

2. Choose Item > Edit Keywords... [or press Command+Y
(Mac OS) or Ctrl+Y (Windows)].

The Edit Keywords dialog opens.

All the keywords assigned to the selected items will be
displayed in the keywords list.

3. Locate the keyword that you want to assign to the
selected items.

4. Click “Assign.”

The “state” of the keyword is changed to “Assign.”

5. When you have finished assigning keywords, click
“OK” to close the dialog and assign the keyword(s) to
the selected items.

154



To assign keywords to items using the Master Keyword list:

1. In the Gallery window, select the items that you want to
assign Master Keywords to.

2. Choose Master Keywords Palette from the Window
menu [or press Command+K (Mac OS) or Ctrl+K
(Windows)].

The Master Keywords Palette will be displayed, showing
all the Master Keywords in the catalog.

3. On the Master Keywords List, locate and select the
keyword(s) that you want to assign to all the selected
items. [Press Command-click (Mac OS) or Ctrl-click
(Windows) to select keywords non-contiguously.]

4. Click “Assign.”

The keywords are assigned to all the selected items
immediately.

To find all items to which a keyword is assigned:
1. Open the Master Keywords Palette [Window > Show

Master Keywords Palette, or press Command+K (Mac
OS) or Ctrl+K (Windows)].

2. Select the keyword that you want to change, then click
“Find,” or double-click the word.

3. In the Gallery window, all the items with that keyword
will be displayed. 

Assign Keywords from the Master Keywords Palette

B
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Tip

To jump to a particular part of the
list, start typing the keyword in the
edit box. The list will jump to the
first word beginning with the text
that you entered.

Tip

You can drag multiple keywords
from the Master Keywords list and
drop them on the thumbnail of any
one of the selected items to
assign them to all the selected
items at once.

Tip

Keep the Master Keywords
Palette open while you are work-
ing with multiple catalogs. As you
click in different Catalog Gallery
windows, the Master Keywords
Palette is immediately updated
with the keywords for that catalog.

C D

A Find: Enter a keyword or partial key-
word, then click the Find button to
move to the location on the list of the
closest matching keyword. Handy for
quickly moving around a long list.

B List of Keywords: Select a Keyword
from the list, then click Assign to
assign the keyword to the selected
items. You can also drag keywords to
a Gallery to assign them to selected
items. Double-click a keyword to
locate gallery items with that keyword. 

C Assign: Select a Master Keyword from
the list, then click Assign to assign the
keyword to the selected items.

D Find: Select a Master Keyword from
the list, then click Find to locate all
the items with that keyword assigned,
and display them in the Gallery
window.

155



Master Palettes (Predefined Custom Lists)

New in Portfolio 5.0 is the ability to display entries from any
Custom Field with a Predefined List on palettes. 

These lists behave just like Master Keywords on the Master
Keywords List, except that they are created automatically when
Custom Fields designated as Predefined List are created. To
create these kinds of Custom Fields, see page 210. 

After the Custom Field has been created and the list entries
added, the Custom Field name is displayed on the Window menu:
Master Palettes sub-menu as “Show [Field]” where [Field] is the
name of the Custom Field.

Selecting a “Show [Field]” name from the Master Palettes
submenu opens a palette with the Custom Field list displayed.

Show Master Palettes

To open the Master Keyword palette, or
any Custom Field palette (predefined
list Custom Fields only), select it from
the Master Palettes submenu of the
Windows menu.

A Custom Field (Predefined List)
Palettes: Each Custom Field created
as a predefined list will be displayed
here with the word “Master”
preceding the name of the field.
Simply select the name to open the
Master Palette for that field. 

B Master Keywords Palette: Select to
open the Master Keywords palette
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To assign words to items from a Master Palette:

1. In the Gallery window, select the items that you want to
assign keywords to. [Command-click (Mac OS) or 
Ctrl-click (Windows) to select records non-contig-
uously.]

2. Open the appropriate Master Palette: From the
Window menu, Master Palettes sub-menu, choose the
appropriate Custom Field name. 

A palette for the Custom Field will be displayed, showing
all the entries assigned to that field. 

You can dock and undock Master Palettes just like other
palettes (see page 37).

3. On the palette, locate and select the word(s) that you
want to assign to all selected Gallery  items.  [Press
Command-click (Mac OS) or Ctrl-click (Windows) to
select words non-contiguously.]

In our example, we will be assigning the word “In
Progress” to the Status field of several discontiguous
records in the Gallery.

Master Palettes—Custom Field Values

D

C

A Palette tab: Displays the Custom
Field name. Master palettes can be
docked and undocked just like other
Portfolio palettes (see page 37).

B List of Custom Field Keywords: All the
entries for the predefined list field are
displayed.

C Selected list entry (value): Select an
entry on the list, then click Assign to
assign that value to the custom field
of selected items in the Gallery. You
can also drag an entry to a Gallery to
assign it to selected items. 

D Assign: Select a Custom Field value
from the list, then click Assign to
assign that value to the appropriate
Custom Field (shown in the palette
tab, (A)) for selected gallery items.

E Find: Select a Custom Field keyword
from the list, then click Find to locate
all the items with that word assigned,
and display them in the Gallery
window.

F Master palette fly-out menu: Options
are Assign and Find.
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4. Click the “Assign” button at the bottom of the palette,
or select “Assign” from the palette fly-out menu.

— or —

4. Drag and Drop the words onto the Gallery.

The list word(s) are assigned to all selected items in the
Gallery immediately.

To find all items to which a predefined list word is assigned:

1. Open the appropriate Master Palette: From the
Window menu, Master Palettes sub-menu, choose the
appropriate Custom Field name.

2. Select the word that you want to search on, then click
“Find,” or simply double-click the word.

3. In the Gallery window, all the items with that word will
be displayed. 
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Item Descriptions

In addition to adding keywords to any item, you can add a
description up to 32,000 characters long. You can use the descrip-
tion field to keep track of any information about the source file
that you might find useful or important, but information that you
probably won’t use to locate catalog items. You might want to use
the Description field for photo captions, small amounts of market-
ing copy, or miscellaneous notes.

If the original application provides a way for you to enter and
save descriptive text with the source file, Portfolio can often
extract this information automatically as it catalogs the item.
Otherwise, you can add or edit a description after cataloging. In a
network environment, a catalog administrator can control who
edits descriptions.

Adding Descriptions by Extracting Them from Source Files

If you have selected the “Extract Descriptions” option (Catalog >
Cataloging Options: Add and/or Update tab) for Adding and/or
Updating, Portfolio examines all source files for  descriptions
created in their native applications when you add and/or update
items in a catalog. As items are cataloged or updated, extracted
descriptions are added to the catalog according to the settings in
the Add and Updates tab(pages 134 and 137).

Entering and Editing Item Descriptions

You can manually enter item descriptions into a catalog, and you
can edit existing descriptions whether they were added manually
or extracted from an item’s source file. 

To enter or edit a description manually:

1. Select the item to which you want to add a description,
then choose “Item Properties...” from the Item menu.

The “Item Properties” dialog box appears with the General
tab selected.

2. Type a description in the Description text box, then
click “OK.”

The description is added to the item.

Note: If the Description text box is disabled, it indicates that you
do not have permission to edit descriptions for items in the open
catalog (requires Editor mode or higher). If you are working in a
network environment, check with your catalog administrator.
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Adding Data to Custom Fields

If custom fields have been defined for a catalog, you can change
their value (or contents). For example, you can add photogra-
phers' names to a custom “Photographer” field in a catalog of
photographic images. Some custom fields even allow more than
one entry, and others allow you to select from a predefined list of
items so that consistency is maintained from record to record,
and/or between catalogs. See page 206 for information on creat-
ing special Custom Fields.

Note: You must have Editor level access or above to a catalog in
order to change its Custom Field values. Creating new Custom
Fields requires Administrator level access. See page 194. 

Item Properties—Fields Tab
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A Custom Fields tab

B Thumbnail Preview: Displays the
thumbnail for the selected Gallery
item.

C Custom Field List: Lists all the
Custom Fields that have been created
for the catalog, even if no values have
been assigned to a field.

D Edit: Opens the appropriate Edit
dialog for the selected Custom Field.

E Cancel: Closes the dialog without
saving changes in any of the tabs.

F OK: Closes the dialog and saves
changes to all the tabs.



To Edit existing Custom Fields:

1. Select an item in a Gallery window, then choose Item >
Item Properties.

2. In the Item Properties dialog, click the “Fields” tab to
select it.

All custom fields for the catalog are displayed, even if no
data is currently entered in a field for the selected item.

3. Select the field you want to change, then click “Edit...”

The “Edit” dialog box for the field will be displayed. This
dialog differs for the different field types— see page 209.

4. Type the appropriate value in the text box, then click
“OK” to close the edit dialog.

If you enter a value that is incorrect for the field type,
clicking “OK” produces no result. (Re-enter the proper
value type or click “Cancel.”)

5. Click “OK” to close the dialog and accept the changes.

Field Type Data Example

Date/Time 8/20/98 1:15 pm

Decimal 50.00

Integer 100

String Text

Text Block Multiple lines of text

URL www.extensis.com

Tip

In addition to the methods shown
here for adding data to Custom
Fields, you can edit fields directly
in Record View (page 146), or
add words from predefined Cus-
tom Field lists available on Master
Palettes (page 156).
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Custom Field values are entered from
the Item Properties dialog (Item > Item
Properties). The following six editing
dialogs are available. See “Adding
Custom Fields” starting on page 206 for
additional information on field types.

A Single-line string: Enter text strings.
Number of characters allowed is set
when the custom field is created.

B Text Block: Enter text strings that can
be displayed on multiple lines. 

C Predefined list: Select an entry from
the pop-up list of predefined values.

D Multi-value list: Enter a value to add it
to the list.

E Date/Time: Enter date and time using
the syntax mm/dd/yy hh:mm:ss.

F URL: Enter a title for the URL and the
URL string. The text in the Title field is
what will appear in the URL field for
the item. Clicking the Title launches
the selected browser and opens the
indicated URL.

Custom Field Editing Dialogs

Date/Time

Predefined List

Multi-value List

URLText Block
B

C

F

A
String

D

E
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Replacing Keywords, Descriptions, and Field
Values using Search Parameters

You can easily replace keywords, descriptions, and Custom Field
values for multiple items in a catalog at the same time using
Portfolio’s powerful Replace function. For example, if you have
defined a Custom Field for the print date for your images and the
print date for some of those images slips by a week, you can
replace the incorrect date in that field for all the affected images
at once. You can even search on a different field than the field
being replaced, and you can choose to search all the items in the
active Gallery, or limit the search to only the selected items. 

A Context: Determines search context.
Options are:

Replace all Items in Gallery: Repla-
ces the indicated field value of all the
records in the active Gallery with the
value defined in the Replace clause.
Disables the Find clause.

Search Selected Items: Limits the
scope of the Find to the currently
selected items in the active Gallery.

Search Gallery: Searches the entire
active Gallery for matching records.

B and C Find clause: Sets the parame-
ters of the search.

Fields pop-up: Displays all fields,
including Custom Fields. In Portfolio
5.0, all fields are indexed.

Operator pop-up: Defines the search
operator. List changes depending on
find field type (B).

Search value: Enter the string to be
searched for.

D Replace clause: Determines which
field value will be replaced.

Replace text box: Enter the string that
will be used to replace the existing
string.

E Add to Multi-valued List: Controls
how multi-valued fields are handled.
See page 211.

F Replace: Click to initiate the Find and
Replace operation. If the field is a
single value field, the entire contents
of the replacement field are replaced.

G Close: Click to close the dialog box.  

Find and Replace

A

D

E

F

G

CB

B

C

D
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To Replace items based on field values:

1. Choose Replace... from the Catalog menu (or press
Command+Option+R (Mac OS) or Ctrl+Shift+R
(Windows).

The “Find and Replace” dialog box appears.

2. Select the Context of the search using the Context radio
buttons.

• Replace all Items in Gallery: Disables the Find and
forces the Replace value into all records in the Gallery.

• Search Selected Items: For the selected items, Replace
the value for all records matching the search criteria.
Unselected records are not affected.

• Search in Gallery: For all items in the Gallery, Replace
the value for all records matching the search criteria.

3. Enter the parameters of the Find by selecting the field
to be searched and a search clause from the pop-ups,
then enter the text string to search on.

Note: This step does not apply if you selected “Replace all
Items in Gallery” in step 2. 

4. Enter the parameters of the Replace by selecting a field
to be replaced from the Replace Field pop-up, then
enter the data string that will replace the existing data
in the selected field.

If the field you selected is a Multi-valued field, indicate
whether you want the Replace value added to the list of
existing values, or to replace the value indicated in the
Find value field. 

Note: Exercise caution when you perform a Replace where
the Find field is different than the Replace field and “Add
to Multi-valued List” is unchecked, as the entire contents
of the Replace field will be replaced. 

5. Click “Replace.”

Item records matching the Find criteria will be located, and
data in the indicated Replace field will be replaced. 

Note: Because the “Replace” command in Portfolio is
replacing field data in item records that are already being
displayed, and is not (like the Portfolio “Find” command)
searching for items to display, the “Replace” command
has no effect on the Gallery (other than to show any field
data that was replaced during the Replace operation).

Tip

You can populate Custom Fields
based on information in existing
fields. This can be handy when
you want to add a new field
based on existing information
and/or move existing information
into a different field. For example,
you might search for every record
that has a particular vendor name
in the Description field and move
that vendor’s name to a custom
“Vendor Name” field. Then you
might search all the records again
using the Vendor Name, and add
the vendor’s web address to a
custom “Vendor Website” field.
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Add to Multi-valued List Checkbox

The Multi-valued List option is only available when a Custom Field
defined as a Multi-value List is selected in the Replace clause.

There are four possible options for replacing multi-valued fields.
These are based on the type of search being conducted, and
whether the “Add to Multi-valued List” checkbox is On (checked)
or Off (unchecked). An example of each is given below. The first
three options are fairly straight-forward. The fourth can be
extremely powerful, but unless understood fully, may lead to
unwanted results. If you are interested in applying the fourth
scenario, you may want to experiment with a small, unwanted
catalog until you fully understand the ramifications.

For the following, assume that you have a Multi-valued List with
two items it: “cat” and “dog.”

Examples and Results:

Option 1: You want to search for all records containing “cat” and
add the word “snake” to the list. To accomplish this, enter “cat”
in the Find field, enter “snake” in the Replace field, and turn the
“Add Multi-value” checkbox On. This results in a multi-value list
containing “cat,” “dog” and “snake.”

Option 2: You want to search for all records with some common-
ality and add “snake” to the value list. To accomplish this, enter
your search parameter in the Find field (such as a creation date or
partial filename), enter “snake” in the Replace field, and turn the
“Add Multi-value” checkbox On. This results in a multi-value list
containing “cat,” “dog” and “snake.”

Option 3: You want to search for all records containing “cat” and
replace the word “cat” with the word “snake.” To accomplish this,
enter “cat” in the Find field, enter “snake” in the Replace field,
and turn the “Add Multi-value” checkbox Off. This results in a
multi-value list containing only “snake” and “dog.”

Option 4: You want to search for all records with some commonal-
ity and replace the entire value list with the word “snake.” To
accomplish this, enter your search parameter in the Find field
(such as a creation date or partial filename), enter “snake” in the
Replace field, and turn the “Add Multi-value” checkbox Off. This
results in a multi-value list containing only the word “snake.” This
can be helpful when you want to replace the entire value list and
start over again with new values. After replacing the list with a
single value you can perform a regular Find to locate all the items
with that value and add the other list items in the normal way.
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Populating Fields in Multiple Records at the
Same Time

Portfolio makes it easy to add information to multiple records at
the same time, either as a replacement for existing text, or to add
new information to the same field in many records at once. The
easiest way to do this is using the “Replace all items in the
Gallery” command, an option on the Replace dialog (Catalog >
Replace). 

For example, you might have several hundred records that you
want to add a keyword to, or you may have gotten a batch of
photographs that you want to add the artist’s name to. All of this
can be done easily in Portfolio. Simply open a Gallery with all of
the records that you want to change, select this option on the
Replace dialog, choose the field that you want to change from the
pop-up menu, and enter the desired text. 

To populate a field in multiple records at the same time:

1. Open a Gallery and locate all the records that you want
to affect.

2. From the Catalog menu, choose “Replace...”
[Command+Option+R (Mac OS) or Ctrl+Alt+R
(Windows)].

3. Click “Replace all items in Gallery.”

Notice that the search portion of the dialog is no longer
available. This is because you have already found the
records that you want to change (all records in the
currently active Gallery).

4. From the Replace pop-up menu, select the field that
you want to affect.

Only fields that can be replaced will be listed. These
include the system fields Keywords and Description, plus
any Custom Fields that have been created.

5. Enter the text that you want to appear in the selected
field.

Text entered here will completely replace any text already
existing in the selected field. 

6. Click “Replace.”

Entered text will replace any existing text in the selected
field for all records in the active Gallery.

Warning

This is an extremely powerful
feature, allowing you to replace
data in a selected field for many
records at once. Be aware that
any data already existing in the
selected field will be overwritten.
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Tip

You can use Portfolio Mappings
(Catalog > Cataloging Options:
Mappings tab) to extract all user
added data in the File Info fields
of Photoshop files. See page 139
for details.

Preparing Documents and Images for Cataloging

Portfolio works directly with many products to make cataloging
fast and easy. This section describes how to prepare documents
in various applications so that cataloging them is as easy as
possible.

Adobe Photoshop 3.0.x through 5.5

You can save thumbnails, keywords and captions from your
Photoshop documents for use in Portfolio catalogs.

To include a thumbnail and preview in Photoshop:

1. Choose “General...” from the Preferences submenu in
Photoshop’s File menu.

2. Click “More.”

3. In the Image Previews section of the dialog box, select
“Always Save.”

4. Click “OK.”

To include keywords and captions in Photoshop:

1. Choose “File Info” from Photoshop’s File menu.

2. Enter your caption in the caption field.

3. Click “Next” to switch to the “Keywords” panel.

4. Enter your keywords.

5. Click “OK” to close the dialog box.

Adobe Illustrator 7.0 and 8.0

Illustrator automatically saves a thumbnail that Portfolio can
display into native (.ai) files. 

For Illustrator EPS files, in the Save Options dialog, choose to
save both a thumbnail and a preview.

Adobe PageMaker 6.5 (Macintosh only)

PageMaker saves thumbnails that Portfolio can display in the
catalog.



QuarkXPress 3.31 and above  (Macintosh only)

You can save thumbnails of your documents for use in Portfolio
catalogs.

To attach a thumbnail in QuarkXPress:

1. When saving a QuarkXPress document, make sure that
“Include Preview” is selected in the QuarkXPress Save
dialog box.

This will save a black-and-white thumbnail of the first
page of your Quark document.

Tip

Macintosh: Included on the
Extensis CD is the XTension
“Visions Edge Preview Editor
Lite,” which allows you to save
full-color thumbnails of your
QuarkXPress documents. Refer to
the instructions accompanying the
XTension for help. (Extensis can-
not offer Technical Support for
Preview Editor Lite.)

Tip

Macintosh: Included on the
Extensis CD for Portfolio users is
a free Quark XTension “Extensis
QX-Drag&Drop.” This powerful
XTension gives QuarkXPress the
ability to accept drag and drop
items, such as the items in your
Portfolio catalogs. Before you can
use this XTension you must run
the QX-Drag&Drop Installer to
install it in your Quark XTension
folder.
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Categorizing Records—The Categories Palette

Portfolio 5.0 offers the ability to organize groups of records
visually, using a folder hierarchy which is accessible through the
Categories palette. 

For example, you might want to use this feature to organize:

• all the versions of a job file, such as low and high resolution
images, RGB version, CMYK files, etc.

• all the elements of a print job, such as the document files,
images, and fonts

The Categories palette consists of a hierarchy of folders that are
linked to items in the catalog. By double-clicking a folder icon on
this palette you can display all the cataloged items in a folder
and, optionally its subfolders.

Categories Palette

The Categories palette lets you
organize project items visually using a
folder hierarchy.

To open the Categories palette, choose
Window > Show Categories.

A Categories palette tab

B List of Category Folders: All the
folders associated with catalog items
are listed.

Drag folders up and down to create a
hierarchy.

C Expand/contract: Click to expand and
contract the folder hierarchical list.

D New Folder: Click to create a new
folder at the current level of the
hierarchy. 

E Remove from Category: Click to
remove items (selected in the Gallery
window) from the Category.

F Delete Folder: Click to remove a
folder from the palette.

G Categories palette fly-out menu:
Allows you to perform various tasks
with folders and folder contents.
Options are: New, Delete, Rename,
Apply, Remove, Show Records in
Categories, Show Records in Sub-
categories, Create on Disk, Delete All
Folders, Expand All Folders, Collapse
All Folders, Import, Export, and
Refresh. See page 170 for a
description of each menu item.
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Working with the Categories palette can make organizing and
cataloging project files a snap. Using options on the Categories
palette you can create the folder hierarchy manually, then drag
items from the catalog onto the Categories palette folders to link
them. Or you can catalog an entire job of items in nested
subfolders automatically by dragging folders from the desktop
(Mac OS) or Explorer (Windows) directly onto the Categories
palette. When you drag folders onto the Categories palette, items
in those folders are automatically added to the catalog and linked
to their respective folders (sub-directories become sub-categories).

By working with data the other direction—dragging folders from
the Categories palette to the hard drive—you can recreate an
entire job (folders, subfolders, and the cataloged contents), or any
number of individual folders and contents, on any local or
network volume in one easy step. 

New Category... Create a new folder at the root level of the hierarchy. 

Delete Category... Delete the selected folder from the Categories palette.

Rename Category... Rename the selected folder.

Apply Records to Category Assign selected Gallery items to the Category.

Remove Records from Category Remove selected Gallery items from the Category.

Show Records in Category Find all cataloged items in selected folder and display them in the Gallery.

Show Records in Sub-categories Same as Show Records in Category (above), but includes subfolders.

Create on Disk... Copy folder and the original (source) files to the hard drive. 

Delete All Folders Deletes all folders from the Categories palette.

Expand All Folders Expands all folders in the Categories palette.

Collapse All Folders Collapses all folders in the Categories palette.

Import Import saved categories (Portfolio .pjd file). Must be exported from a catalog.

Export Export categories to a Portfolio .pjd file for importing into another catalog.

Refresh Refreshes the Categories palette to reflect recent changes.

Categories Palette Menu Option Function Performed
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Tip

Each folder that you create is con-
sidered a “category.” You may, for
your own organizational purposes,
arrange categories as sub-cate-
gories of other categories by drag-
ging a folder under another folder
on the Categories palette.



To add an existing folder to the Categories palette:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. On the workstation [Finder (Mac OS) or Explorer
(Windows)], locate the folder and sub-folders that you
wish to add to the Category.

3. Drag the top-level folder from the Finder/Explorer and
drop it onto the Categories palette in Portfolio, or onto
another folder on the palette.

The folder hierarchy will be recreated on the Categories
palette, and folder contents will be cataloged and linked to
the appropriate folders on the palette.

Double-click a folder to
display the cataloged
contents in a Gallery
window.

Tip

Macintosh: To drag and drop
folders from the Finder onto the
Categories palette in Portfolio, you
will need to arrange your desktop
so that you can see both the Cat-
egories palette and the window
that you want to drag from. 

To do so, hide all windows except
Portfolio. In the Finder (Desktop),
open the folder containing the
items that you want to drag into
Portfolio. Arrange your folder win-
dow so that it is visible when Port-
folio is active (you may have to
close some or all Gallery windows
in Portfolio). You will now be able
to drag from one to the other.
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Path as Categories

Portfolio allows you to link cataloged items to a Categories folder
automatically at Add and/or Update time using the Path as
Categories option.

To enable Path as Categories:

1. Open the desired catalog, then open the Cataloging
Options dialog (Catalog > Cataloging Options:
General tab).

2. Choose an appropriate Modify Method from the pop-
up menu: Add, Update, or Add & Update. 

3. From the Path as Categories pop-up menu, choose
“Selected Folders.”

When items are added or updated, categories (folders on
the Categories palette) will be created using the same name
as the folders containing the item source file(s). Folder
hierarchy will be maintained when the categories are
created.
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To create a new category using the Categories palette:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. Click the “New...” button or choose “New...” from the
palette fly-out menu.

You will be prompted to enter a name for the folder.

3. Enter the folder name, then click “OK.”

The folder will be created at the selected level (below the
currently selected folder) on the Categories palette.

4. Continue creating folders (steps 2 and 3) until all the
folders have been created.

5. Drag the folders up and down as necessary until the
folder hierarchy is as you like it.

Use the insertion bar to gauge
exactly where to drop each folder. 

If you don’t care about the hierarchy
of submenus, simply drag and drop
sub-folders into the appropriate
folder.

173

Tip

New folders are created at the
same level as the selected folder.
To create folders at the root (top)
level of the hierarchy, click any-
where in the white space of the
palette to deselect all folders. To
place a folder at a lower level,
drag and drop it into the desired
folder on the palette.



To link cataloged items to an existing folder:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. Locate the item(s) that you want to add to a folder on
the palette.

3. Select the items, then drag and drop them into the
desired folder on the Categories palette. 

The selected Gallery items will be linked to the folder.

— or —

3. Select the items in the Gallery. 

4. On the Categories palette, select the target folder.

5. From the Categories palette fly-out menu, choose
“Apply Records to Category.”

The selected Gallery items will be linked to the folder.
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To display cataloged items in a Categories folder:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. Double-click the desired folder.

Items in the selected folder will be displayed in the
Gallery.

To display items in a Category and all sub-categories:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. Select the desired category (by highlighting the folder).

3. Choose “Show Records in Sub-categories” from the
palette fly-out menu.

Items in the selected folder and all sub-folders will be
displayed in the Gallery.

To remove cataloged items from a Categories folder:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. Open a Gallery and select the items that you want to
remove from the folder.

3. Click the “Remove” button on the Categories palette, ,
or choose “Remove Records from Category” from the
fly-out menu.

The selected catalog items will be removed from the
folder, but not from the Gallery or Catalog.

To remove a Category:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. Select the Category that you want to delete, then click
the Delete button at the bottom of the palette, or choose
“Delete Category” from the fly-out menu.
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To create a job on disk from your Categories:

1. Open the desired catalog, then open the Categories
palette (Window > Show Categories).

2. Select the top-level folder that you want to create the
Category from.

3. Drag the folder to the Finder (Mac OS) or Explorer
(Windows).

A dialog will be displayed asking if you want to create one
folder for all the items, or if you prefer to maintain the
folder hierarchy.

— or —

3. Choose “Create on Disk...” from the palette fly-out
menu, then choose a folder where you want the items to
be stored.

4. Click “Create one folder” to have all items placed in a
single folder, or “Create all folders” to maintain folder
hierarchy.

A copy of each source file will be placed in the appropriate
folder on the disk.  
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Tip

Mac OS: The Mac OS uses the “-”
(dash) character to signify a break
in menus. Because of this rule, do
not create scripts with a “-” as the
first character of the filename.

Scripting

A number of Portfolio commands can be accessed through
Scripting.

Macintosh: Portfolio supports AppleScript and any other OSA-
compliant scripting language. 

Windows: Portfolio supports OLE Automation, which can be
accessed by a number of scripting languages such as Visual Basic,
Visual C++, Java, etc.

For information and examples on the scripting interface for each
platform, refer to the “Scripts” folder on the Extensis CD.

Note: Extensis Technical Support cannot provide instruction on
how to use the various scripting languages.

The Scripts Menu

The scripts or applications that you write to automate Portfolio
can be conveniently launched from within the catalog using a
special Scripts menu. This menu is installed in the Portfolio menu
bar when valid scripts are placed in a folder named “Scripts”
located in the same folder as the Portfolio application. Scripts and
applications located in the Scripts folder are added to the Scripts
menu and are available as regular menu commands.

This feature is particularly useful for creating custom commands
for catalog users. For example: A script could be written that
takes the currently selected items and adds the current date to a
custom “Publish Date” field in each record. By placing this script
in the Scripts folder located in the Portfolio application folder, the
user can execute the script by selecting it from the Scripts menu,
without needing to know anything about scripts. In fact, the menu
item would appear to be a built-in function of Portfolio.
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Note

Scripting applies to Portfolio
Network and Portfolio Server
Editions only.



This chapter describes how to Import field values from a
database into Portfolio catalogs, allowing you to automate some
of your keyword and field entries, as well as convert existing
catalogs into Portfolio catalogs. Data can only be imported into
keywords, description, and Custom Fields. Built-in fields, like
Color Mode, Created, etc., cannot be changed on importing.

Also covered are Portfolio Export functions, which allow
you to export catalog data to a text file, to create simple Web
pages of catalog items, to export “pnot” data (Macintosh
only), and to export Slideshows as QuickTime movies.

Technical Notes About Importing and Exporting

1. URL fields are exported and imported with the import and
export fields separated by the Group Separator character (just
like keywords—see table on page 180).

2. URL fields are special when importing: If the “Replace Multi-
valued” checkbox is Off, existing data in a URL field will not
be changed by imported data; empty URL fields can still
receive data. If the checkbox is On, existing URLs will be
replaced as expected with the imported data.

3. Color Mode is exported as a number, not a string, as follows:

Unknown = 0
Black & White = 1
Grayscale = 2
RGB = 3
CMYK = 4
YUV = 5 (TIFF; also known as YCbCr)
Lab = 6
YCCK = 7 (JPEG)

4. Custom Fields of type Date/Time always import/export Time,
even if the “Display Time” checkbox is Off. (See page 209.)

Importing and Exporting
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Importing Field Values

Using Portfolio’s “Import Field Values” you can bring data from
an external database into Portfolio by matching fields from the
database with fields in Portfolio. 

To set up a database file for import into Portfolio, it should be
exported as text, with tab delimited fields and carriage return
delimited records, and should have field headers included (the
first record in the text file is assumed to contain the database field
headers and is therefore not imported).

Portfolio should be pre-configured with any required Custom
Fields prior to initiating the import. Otherwise, data targeted for
Portfolio Custom Fields will not be imported.

To Import Field Values:

1. From the File menu in Portfolio, choose Import > Field
Values.

2. Locate the text file to be imported.

3. Match each Import File Field headers from the data-
base (these should be in the first record) with the
appropriate Portfolio Catalog Field name.

Move the File Fields and Portfolio fields up and down the
list to reorder their relative position. Click between the two
columns to activate the Import pop-up
menu. This allows you to select the appro-
priate import operator: Key, Import, or Skip.
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Symbol Function Description

=    Key Defines the key relationship. The
selected Import File Field will be
searched for matching values in the
Portfolio Catalog Field. Only one Key
relationship can be designated for the
import.

--> Import Indicates that the Import File Field will
be imported into the Portfolio Catalog
Field indicated to the right of the
arrow.

x Skip Indicates that the Import File Field will
not be imported.

4. When you have finished setting up
the import fields, you can save the
settings for future use. To do so,
select “Save As...” from the Saved Sets pop-up menu. 

5. When you are ready to import the database, click
“Import.”

Portfolio will examine the field value data in Record #2
(the first record with data, since the first record holds the
field headers) for appropriate data types by comparing
each value in the record with the paired Portfolio field type
specified at the start of the import (step 3, page 179). If a
value does not match, a warning is presented, allowing you
to cancel the import.

If all record types match, Portfolio will import the data. As
the import progresses, data in any field which does not
match the paired Portfolio field type, is skipped.
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Replace Multi-valued Field Data

When checked, values imported into a Multi-valued field
overwrite the values in the Portfolio record. When unchecked,
the values being imported are added to the end of the list in the
Portfolio record.

Technical Notes about Importing Text Files

Because the import text file is delimited by tabs between fields
and carriage returns between records, make sure your data does
not contain either of these characters within a field, as it will
cause unexpected results on Importing. Portfolio follows the
ASCII standard by recognizing ASCII 11 as the Vertical Tab char-
acter. This character should be used to denote a linebreak within a
field (such as in a text block like the Description field). Portfolio
also recognizes ASCII 29 as the Group Separator character. This
character should be used to delimit values within a multi-valued
field (such as the Keywords field). If you are exporting multi-line
or multi-valued data from other databases, make sure to use these
characters. Some other databases that support multi-valued or
multi-lined fields (such as FileMaker Pro) also support these stan-
dards.
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Converting Cumulus Catalogs  (Macintosh)

To import an existing Cumulus catalog you will need to export
the catalog database in Cumulus, then import those records into
Portfolio.

To convert a Cumulus Catalog:

In Cumulus:

1. Select the records you want to convert to Portfolio, or
choose “Select All” from the Edit menu to select the
entire catalog.

2. Choose File > Export Record...

3. Specify a file name and location where you want to save
the Export file.

In Portfolio:

4. Either open an existing Portfolio 5.0 catalog, or create a
new Portfolio catalog. 

The import process can import records into either a new or
existing catalog.

5. Select Publisher access level or higher (Catalog >
Access > Publisher).

6. Choose File > Import > Cumulus Database...

7. From the Open file dialog, locate and select the Export
file you saved in step 3, then click “Open.”

8. Portfolio will display a progress bar while it converts
the records into its own format. Note that the original
source files do not have to be available during the con-
version process.

Fields from the Cumulus database are imported as indicated in the
table on the following page.
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Cumulus ➮ Portfolio

Record name ➮ Filename

Notes ➮ Description

Categories ➮ Keywords

File Size ➮ File Size

File ➮ Path

Program ➮ Creator Mac

Type ➮ File Type Mac

Vertical Resolution ➮ Vertical Resolution

Horizontal Resolution ➮ Horizontal Resolution

Height ➮ Height

Width ➮ Width

Created ➮ Created

Modified ➮ Last Modified

Cataloged ➮ Cataloged

Modified (2) ➮ Last Updated

File ➮ Volume

Cumulus Fields not Imported into Portfolio:

• Color Mode (Cumulus’ color modes do not match the color
modes used by Portfolio)

• Status
• User Name

Additional Notes:

1. The Portfolio field Zone Mac is populated if the path points
to a different AppleTalk zone.

2. The Portfolio field Extension Win is generated based on the
filename (the same way Portfolio generates it when cata-
loging).

3. The thumbnail is imported at whatever size it was saved in
Cumulus.

4. The Portfolio fields “Thumbnail Size” and “Color Mode”
are left blank. To fill in this information, the Portfolio records
need to be updated with the Regenerate Thumbnail option
enabled. This will also reset the thumbnail to a standard
Portfolio size, which could result in space savings in the
catalog. See page 132 for additional information on Updating
records.
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Export to Text File

You can export your Portfolio catalog data to a text file, and you
can specify which fields will be exported and which fields will be
skipped. Only data for the selected items in the active Gallery will
be exported.

To export catalog fields as text:

1. In the Gallery window, select the items for which you
want to export text data. 

To select the entire catalog, choose View > Find All
[Command+' (Mac OS) or Ctrl+' (Windows) and then
Edit > Select All [Command+A (Mac OS) or Ctrl+A
(Windows)].

2. Choose Export > Text File... [Command+Option+T
(Mac OS) or Ctrl+Shift+T (Windows)].

3.  Click in the left-most column of the Catalog Fields list
to enable or disable items from export. A checkmark
indicates that the item will be exported. 

4. Click “Export.”

5. Enter a name for the file and indicate the storage
location, then click “OK.”

Portfolio will begin exporting the records and will display a
progress bar to keep you posted on its progress. When
exporting is complete, you will have a tab-delimited text file
containing information from each item record that you
selected. In the file, each field within a record is delimited
by a tab, and each record is delimited with a carriage return.

Technical Notes about Exporting Text Files

Because the exported text file is delimited by tabs between fields
and carriage returns between records, Portfolio cannot use either
of these characters within a field, as it will result in an improperly
formatted file. 

Therefore, Portfolio follows the ASCII standard by using ASCII
11 as the Vertical Tab character. This character will be used to
denote a linebreak within a field (such as in a text block like the
Description field). Portfolio also uses ASCII 29 as the Group
Separator character. This character will be used to delimit values
within a multi-valued field (such as the Keywords field). Some
other databases that support multi-valued or multi-lined fields
(such as FileMaker Pro) also support these standards.

Tip

Macintosh: Click and drag in the
checkmark column to quickly add
or delete checkmarks for multiple
entries.
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Export to HTML

The Portfolio Export to HTML function allows you to export
catalog items as static Web pages, for posting on a Web Server.

You can specify either that the HTML pages produced will be
based on the items and the layout of the currently active Gallery
view, or you can specify that Portfolio export the pages using a
custom HTML settings file (Template). Information on creating
such a template (by directly editing the HTML code) is given in
the section “Exporting HTML Templates,” page 277.

To export catalog items as Web pages just as they appear in
the active Gallery:

1. Select the desired Gallery view and customize it so that
it looks just like you want it to look when viewed on the
Web. Thumbnails are exported in the order that they
displayed in the catalog.

Portfolio creates the Web page layout with the items
positioned just as they are in the Gallery, so you may want
to reorder the items to create just the right display.

2. Select the records that you want to export. 

You must indicate which items in the Gallery you want to
export. 
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3. Choose File > Export > HTML [Command+Option+H
(Mac OS) or Ctrl+Shift+H (Windows)].

The Export HTML dialog will be displayed.

4. In the Export HTML dialog, choose “Use Current View
Settings,” then click “Export.”

5. Portfolio will ask you to enter a file name for the first
HTML page, and locate where to save the HTML files
that are created.

If more than one page of HTML is required (depending on
how many records were selected), Portfolio will generate
additional pages and place them in the same location as the
first file. All the Web page files will start with the file
name you entered, followed by a hyphen (“-”) and a num-
ber corresponding the page number. For example, if the
first file was named “PortWeb.htm”, the second file will be
named “PortWeb-1.htm,” etc.

6. Click “Save” to start the export process.

Portfolio will also create a folder named “Images” at the
same location as the Web pages. Portfolio will store JPEG
thumbnails of each of the selected items in the Images
folder. If any files (either the HTML files or the thumbnail
images) already exist in this location, you will be asked
whether you want to replace the files or stop the export
process.
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7. Open the new Web page(s) in your Web browser to
preview the results.

Portfolio's HTML Export process generates relative links.
This allows you to upload the folder of exported items (all
the HTML pages and the Images folder) to your Service
Provider or to a Web site on your corporate intranet and
have the items published without hand-coding any HTML
and without manually linking the images and pages.
Contact your Internet Service Provider or System
Administrator for assistance in uploading and publishing
your folder of catalog Web pages.
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Technical Notes about Exporting HTML

1. Portfolio does not export borders in the HTML documents.
Any border settings in the Gallery view will be ignored.

2. Portfolio exports thumbnails at the size they were when cata-
loged, not at the selected display size in the Gallery window. If
the thumbnails in the catalog were stored at different sizes, the
HTML output will display the thumbnails at different sizes. It
is generally recommended that the exported records all use the
same size thumbnails. If you do have thumbnails of different
sizes, use the Modification Method “Update Unconditionally”
and enable Regenerate Thumbnails (Cataloging Options: Rules
tab); this forces the thumbnails to be reset to one size. Be
aware that the 256 x 256 thumbnails are roughly four times
larger than the 112 x 112 thumbnails, so download times over
the Internet could be significantly longer if you use this size,
depending on the user's bandwidth.

Creating Catalog Web Pages from an HTML Template

Besides being able to automatically export HTML based on the
current Gallery setup, Portfolio can export your catalog items as
Web pages using HTML coding that you provide. This gives you
great flexibility in creating catalog layouts for the Web. 

The HTML information that you enter can be saved as a template.
Any HTML Templates that you create are saved within the
Portfolio catalog, so you can quickly export any set of records to
Web pages using your pre-defined formats at any time.

To export catalog items as Web pages using an HTML
Template:

1. In the active Gallery, select the records that you want to
export as Web pages. The records will be exported in
the order they are displayed in the gallery, so rearrange
the records if desired.

2. Select File > Export > HTML [Command+Option+H
(Mac OS) or Ctrl+Shift+H (Windows)].

The Export HTML dialog will be displayed. 

3. In the Export HTML dialog, click “Add...” to create a
new HTML Export Template.

The Edit HTML  dialog will be displayed, showing the
HTML  codes and tags representing the current Gallery
view.

4. Enter a name for the template.

Tip

See page 279 for additional
Technical Notes about HTML.
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5. In the Table Grid fields, enter the number of rows and
columns of thumbnails that you want to display on each
page. 

This selection controls how many items fit on a page, and
as a result, how many pages are generated for each export
based on the number of items you have selected.

6. Edit the HTML as necessary to produce your desired
result. See the following section for details about the
three HTML data blocks.

7. Click ‘OK’ to save the Template and return to the
Export HTML dialog. 

8. In the Export HTML dialog, choose the “Use
Template” radio button and select your template in the
list.

9. Click “Export” to generate the Web page(s) based on
the  information you configured in the template.

For more information on creating Portfolio HTML templates, see
Templates and Template Macros, page 277.
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Tips

Before exporting pnot data you
may want to select the “Missing
Files” command (Catalog >
Missing Files) to find and update
missing links to ensure that pnot
data is exported for all the select-
ed files.

You may also want to verify that
the source files you want to add
the data to are not stored on a
CD or other write-protected vol-
ume and therefore cannot be
updated with the new data.

Export “pnot” Data  (Macintosh only)

The Export “pnot” Data function embeds standard “pnot”
resources created in Portfolio, such as keywords and description,
directly into each selected item’s source file for use in programs
like Photoshop.

To update item source files with “pnot” data:

1. Select the items whose source file you want to add
“pnot” resources to.

Item’s whose source file cannot be found will be skipped.

2. Choose File > Export > pnot Data...

3.  Select the data you would like to add to the source files.
Options are: Thumbnail, Description, and Keywords.

If you select Keywords, you can elect to replace any
keywords currently embedded in the item’s source file, or
append the keywords to the end of any existing list.

4. Click “OK.”

The data fields you selected will be written to the source
files of the selected items.

When the export has been completed, Portfolio will display
a summary of how many records were successfully
updated.

For more information on the Macintosh “pnot” resource 
search Apple’s Developer website at:
http://www.apple.com/developer
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Export QuickTime Movie (Mac OS)

The Export QuickTime Movie option exports slideshows from the
catalog and saves them in QuickTime movie format. You can
specify Transitions for the movie when the slideshow is exported.

To export a slideshow as a QuickTime movie:

1. Select the slideshow Gallery

2. From the File menu, choose Export > QuickTime
movie.

A dialog box will be displayed asking you to
enter specifics about the size of the movie.

3. Set the movie options and Transition Effects as you
want them.

4. Click “OK.”

5. You will be asked to name the movie file and specify the
location where you want to save it.

6. Click “Save.”

Notes: If the original image (the item’s source file) cannot be
found when the Slideshow is exported, the catalog thumbnail is
exported instead. If you export a QuickTime movie file (.mov), the
resulting movie file will be blank.
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This chapter describes how to maintain Portfolio catalogs and
how to use catalog functions in a multi-user environment. For
help administering a Portfolio Catalog Server, see page 221.

For information on providing access to shared catalogs, see page
235. For information on accessing a Portfolio Server, see page 24.

Catalog Security / Access Levels

Catalog Access Levels

There are four access levels that can be established for a catalog:
Administrator, Publisher, Editor and Reader. Each level can have
its own password (Level-based access). Alternately, you can
assign an access level and password by individual user (User-
based access). Whether you assign passwords by access level or
by user, access levels function the same.

Administrator—the highest level access—provides access to all
catalog functions, including creating Custom Fields and editing
the Master Keyword List. Other users can enter data in Custom
Fields that the Administrator creates, and apply keywords to items
from the Master Keywords List. 

The Administrator is responsible for setting all access level pass-
words, and Administrator is the only access level that can change
passwords. When a catalog is created it is automatically given
Administrator level access, so that you will have access to all the
features functions necessary to set up the catalog.

Important: A shared catalog cannot be accessed by other users
when it is in use by the Administrator. Conversely, you cannot
switch to Administrator level if other users have the catalog open.
Multiple users can have Administrator access (if they know the
password (level-based access) or have permission (user-based
access) but only one person at a time can access the catalog
when it is in Administrator mode.

Portfolio access levels are inherited; that is, the Administrator
level includes the privileges of all other levels (in addition to its
other privileges), the Publisher level includes the privileges of the
Editor and Reader levels, and so on.

You can change catalog access level by selecting “Access” from
the Catalog menu(page 194). To switch to User-based access,
choose Catalog > Administration: Passwords tab (page 199).

Catalog Administration

Tip

Most of the procedures in this
chapter require Administrator level
access.

Tip

If you need to know a password
for a catalog and are unsure who
the Administrator is, select Catalog
> Catalog Properties: General,
and look for the option “Password
set by:”

Tip

You can change the access level
that is set by default when catalogs
are opened on your machine. To do
so, select Edit > Preferences, then
select the desired opening mode
access level from the pop-up menu.



View a catalog ü ü ü ü

Search catalog/search multiple ü ü ü ü

Preview items ü ü ü ü

Copy item source files ü ü ü ü

Categories (create on disk) ü ü ü

Run Slideshows ü ü ü ü

Slideshow Options (temporary changes) ü ü ü ü

Digimarc watermarks (read) ü ü ü

Assign keywords to items ü ü ü

Create and edit thumbnail borders ü ü ü

Edit keywords, descriptions ü ü ü

and custom field values

Import field values ü ü ü

Replace field values ü ü ü

Categories (create/delete/rearrange/export/import) ü ü ü

Digimarc watermarks (embed/write to record) ü ü ü

Add items to an existing catalog ü ü

Cumulus Database Import ü ü

Delete or Rename an item’s source file ü ü

HTML Export ü ü

Move item source files ü ü

Placeholder Records Creation ü ü

“pnot” data Export ü ü

QuickTime Movie Export ü ü

Save Galleries ü ü

Save Finds ü ü

Slideshow Options (make permanent changes) ü ü

Text File Export ü ü

Update cataloged items ü ü

Assign Passwords; Level-based / User-based Access ü

Define Custom Fields ü

Disk Preview ü

Master Keywords List Creation ü

Startup Options ü

Catalog Feature Reader Editor Publisher Administrator

Catalog Access Levels
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Level-Based and User-Based Access

Portfolio 5.0 gives you the option of managing catalog access in
one of two ways: Level-based or User-based. 

Level-based: Level-based access allows all users to open a
catalog in any one of the four levels (Reader, Editor, Publisher, or
Administrator) with a single shared password. This is the standard
access method available in earlier versions of Portfolio.

User-based: User-based access allows you to assign different
access levels and passwords for each individual user.

No matter which method is used to manage catalog access, once a
catalog is opened, the features available in a particular access
level are the same (see table on page 192).  

To open the catalog in Administrator mode:

1. Open the catalog.

2. Choose “Access...” from the Catalog menu [or press
Command+Option+B (Mac OS) or Ctrl+Shift+B
(Windows)].

3. Select “Administrator” from the Mode pop-up menu, then
enter the correct password (if a password has been set).

4. Click “OK.”

To change catalog  Access Level:

1. Open the catalog.

2. Choose “Access...” from the Catalog menu [or press
Command+Option+B (Mac OS) or Ctrl+Shift+B
(Windows)].

3. Select the desired access level from the Mode pop-up
menu, then enter the correct password (if a password
has been set).

4. Click “OK.”

The feature set for the new access level will be engaged
(see table on page 192).

Tip

The catalog must be opened and in
Administrator mode before you can
set passwords (Level-based Access)
or add users (User-level Access).

Tip

You can set a catalog to open
automatically in Administrator mode
by setting this option in Preferences
(Edit > Preferences: General tab,
Default Open Mode).
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Catalog Administration—Passwords tab

D

A

B

A Passwords tab: Allows you to add,
delete, or modify Access Level pass-
words or Users for the active catalog. 

B Level-based Access: Allows you to
set catalog access by level only. All
users open catalogs with a shared
password. Passwords can be set for
each of the four access levels.

C User-based Access: Allows you to set
catalog access for individual users.
Each user is assigned their own
access level and password.

D History: Indicates Administrator who
last changed passwords, and the
date and time of the change.

E Set Password (Level-based): Click to
set a shared password for each of
the four access levels. Listed highest
access to lowest: Administrator, Pub-
lisher, Editor, Reader.

F Edit User Access (User-based): Click
to add or edit users, and set their
individual access level and password.

Using either access method (Level-
based or User-based), access levels
behave the same and are inclusive. For
example, to allow a user to have Editor
access and Publisher access, give them
Publisher permission.

C

FE
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To set either Level-based Access or User-based Access:

1. Open the catalog in Administrator mode. 

Choose “Access...” from the Catalog menu
[Command+Option+B (Mac OS) or Ctrl+Shift+B
(Windows)].

Select “Administrator access level,” then enter the correct
password (if a password has been set).

2. Choose Catalog > Administration... [Command+H 
(Mac OS) or Ctrl+H (Windows)].

The Catalog Administration dialog is displayed.

3. Click either Level-based Access or User-based Access.

If Level-based Access is selected, set access level pass-
words (page 197).

If User-based Access is selected, add users and set their
access level and password (page 199).



Setting Level-based Passwords

Multiple users can use a catalog simultaneously across a network,
within the restrictions of their access privileges. Therefore, pass-
word protection is strongly recommended when a catalog is avail-
able to multiple users. Protection is not necessary, however, if you
are the single user of a catalog on your own computer.

You can set passwords when you first create a catalog, or if you
have Administrator privileges for the catalog.

To set or change catalog passwords:

1. Open the catalog in Administrator mode (page 194).

2. Select “Administration...” from the Catalog menu.

The Catalog Administration dialog box is displayed.

3. Click the Passwords tab.

4. Verify that the Level-based Access radio button is
selected.

5. Click “Set Password...” for the desired Access Level.

The “Set Password” dialog box is displayed.
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6. Type the new password in the appropriate text box,
type it again in the Confirm box, then click “OK.”

Enter the new password in the Confirm field to verify that
you entered it correctly. Passwords must be between 4 and
12 characters in length.

7. Repeat steps 5 and 6 for the other passwords that you
want to set.

8. Click "OK" to close the Catalog Administration dialog
box and save the new password(s).

9. Close the catalog and reopen it to put the password(s)
into effect.

Once a catalog is password-protected with a password for
any access level, Passwords access selections are displayed
when the catalog is opened. Users can then choose their
access level from the Access Mode pop-up menu, enter the
correct password and click “OK” to open the catalog.

Note: Even if you set only a Reader password, users log-
ging in as Editor, Publisher, or Administrator will need
that Reader password to gain access to the catalog. For
example, if you only set an Administrator password, you
won’t need to enter a password to access the catalog in
other access levels.

Tip

You can use a higher level pass-
word to access all lower levels.
For example, if you know the
Administrator password, you can
enter it to access Publisher level.
This is handy if you need to
switch out of Administrator mode
in order to share the catalog with
other users.
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Adding Users and Passwords for User-based
Access

Some multi-user environments are better served by providing
individual users with their own catalog access level and password,
rather than having all users share an access level password. In
these situations, User-based Access should be used.

To add individual users and passwords:

1. Open the catalog in Administrator mode (page 194).

2. Select “Administration...” from the Catalog menu.

The Catalog Administration dialog box is displayed.

3. Click the Passwords tab.

4. Click the User-based Access radio button.

5. Click “Edit User Access...”

The User Access dialog box is displayed.
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5. Click “New...”

6. Enter the user’s Name, enter and confirm their
Password, and select an access level (group) for them
from the pop-up menu.

7. Click “OK.”

The new user will appear on the Users and Groups list.

8. When you have finished adding users, click “OK.”

To change individual users and/or passwords:

1. Open the catalog.

2. Select “Administration...” from the Catalog menu.

3. Click the Passwords tab.

4. Click the User-based Access radio button.

5. Click “Edit User Access...”

The Users and Groups dialog box is displayed.

6. Select the desired user, then click “Edit...” or “Delete...”
depending on what changes you want to make.

Tip

When User-level Access is
enabled you must have at least
one user with Administrator level
permission. If you attempt to
close the User Access dialog (OK
button) with no Administrator set,
a warning dialog will be displayed.
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Importing and Exporting User Lists

If your users may be accessing multiple catalogs, you can create a
Users  list in one catalog, then export it for use in other catalogs.

To export a User Access list:

Note: You must add users (page 199) before you have a list to export.

1. Open the catalog in Administrator mode (page 194).

2. Select “Administration...” from the Catalog menu.

The Catalog Administration dialog box is displayed.

3. Click the Passwords tab.

4. Under “User-level Access,” click “Edit User Access...”

5. Click “Export...”

6. Enter a name and location for the text file that will be
created from the Users list.

7. Click “Save.”

To import a Users  list:

1. Open the catalog in Administrator mode (page 194).

2. Choose Catalog > Administrator: Passwords tab.

The Catalog Administration dialog box is displayed.

3. Under “User-level Access,” click “Edit User Access...”

4. Click “Import...”

5. Locate and open the text file containing your Portfolio
Users and Groups list.
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Creating a Master Keywords List

Establishing a Master Keywords list for a catalog can help you
maintain consistent keywords among the items in the catalog, or
across catalogs. With a Master Keyword list, you can ensure that
only the keywords in the list are used in the catalog.

You can enter Master Keywords manually, or you can import
them from an existing text file.

Note: Master Keywords are not dynamic. That is, when you
change or delete a Master Keyword in the “Catalog Administra-
tion” dialog box, that Master Keyword is not automatically
changed in any items to which it’s been applied.

A Keywording tab: Allows you to add
items to and edit the Master Key-
words list. 

B Keyword text box: Type new key-
words in the text box.

C Master Keywords list

D Allow Only Keywords from Master
Keywords List: Forces users to assign
only keywords that appear on the
Master Keywords list.

E Parse Keyword Phrases: allows key-
word phrases (keywords consisting of
more than one word) to be parsed
into individual keywords.

F Add: Click here to add the keyword in
the keyword text box (B) to the list.

G Delete and Rename: Select one or
more keywords from the list to Delete.
Select keywords one at a time to
Rename; the keyword is renamed in
the list only—the name change is not
applied to catalog items.

H Import and Export: Export Master
Keyword list to a text file for importing
into another catalog. Import from a
text file or Master Keyword list export-
ed from another catalog. 

Catalog Administration—Keywording tab

B

C

F

G

H

D

E

A
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To add keywords to the Master Keywords list:

1. Choose Catalog > Administration... [Command+H 
(Mac OS) or Ctrl+H (Windows)].

2. Click the Keywording tab to select it.

3. Type new keywords into the text box at the top of the
dialog, then click “Add.”

If you enter a word that is already on the list, the “Add”
button will be dimmed.

4. When you have finished adding Master Keywords, click
“OK” to save the changes and close the dialog.

To Rename or Delete Master Keywords:

1. Choose Catalog > Administration... [Command+H 
(Mac OS) or Ctrl+H (Windows)].

2. Click the Keywording tab to select it.

3. Select the keyword that you want to Rename or Delete,
then click the appropriate button.

If you selected Rename, enter a new name for the keyword.

4. When you have finished working with Master
Keywords, click “OK” to close the dialog and save the
changes.

Note: Deleting a keyword from the Master Keyword list
does not remove it from any items that have that keyword
assigned to them.



Exporting and Importing Keywords

You can export the Master Keywords list from one catalog and
import it into another. This is handy if you want to share key-
words across multiple catalogs. You can also export the standard
keywords from any catalog, import it into the Master Keywords
list of another catalog, then work with the list to rename, add, or
remove keywords to build a suitable Master Keywords list.

Portfolio exports keywords to a file in which each keyword is
delimited by a carriage return, so you can also import lists of
Master Keywords from any suitable text file.

To Export a list of Master Keywords:

1. Open the catalog that contains the Master Keywords
that you want to export. You will need to have
Administrator access (Catalog > Access).

2. Choose Catalog > Administration... [Command+H 
(Mac OS) or Ctrl+H (Windows)], then select the
Keywording tab.

3. Click “Export...”

4. Specify a name and location for the exported file, then
click “Save.”

To Import any list of keywords to the Master Keywords list:

1. Open the catalog that you want to import the keywords
into. You will need to have Administrator access
(Catalog > Access).

2. Choose Catalog > Administration... [Command+H 
(Mac OS) or Ctrl+H (Windows)], then select the
Keywording tab.

3. Click “Import...”

4. Locate the file containing the keywords that you want
to import, then click “Open.”

The keywords will be added to the Master Keywords list.

To Export regular catalog keywords:

1. Open the catalog that contains the keywords that you
want to export. (You do not need any special permis-
sions to export standard keywords).

2. Choose Catalog > Catalog Properties... [Command+
Option+J (Mac OS) or Ctrl+Shift+J (Windows)]. 

3. Select the Statistics tab.

Tip

If you decide you do not want to
keep the keywords after they have
been imported, click Cancel in the
Catalog Administration dialog to
close the dialog without saving the
imported keyword list.
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4. On the Statistics tab, click “Calculate...” (Mac OS) or
“Calculate Now” (Windows).

Portfolio will build a list of catalog keywords. If the cata-
log has many records, this may take some time.

5. Click “Export Keywords...”

6. Specify a name and location for the exported file, then
click “Save.”

The keywords will be saved to a file in which each key-
word is delimited by a carriage return, so that it can be
imported into the Master Keywords list of another Portfolio
catalog (see page 204).

Parsing Keyword Phrases

Portfolio offers an option that allows keyword phrases (keywords
consisting of more than one word) to be parsed into individual
keywords. For example, adding the keyword phrase “Mother and
child” with keyword phrase parsing on would result in “Mother
and child,” “Mother,” “and,” and “child” being added to the item.

The advantage of parsing keyword phrases is it allows the user to
do a very fast “Starts with” or “Matches” search on words that
would otherwise not be found without using a “contains” search.
In the example above, searching on “Starts with child” will only
return the item if keyword parsing is on.

To enable or disable keyword phrase parsing: Click this option
on the Catalog Administration Keywording tab. The checkmark
indicates that parsing is enabled.
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Adding Custom Fields

Portfolio Catalogs consist of a number of predefined fields. These
system fields, such as Filename, Path, Created and so on, catego-
rize the file information for each item in a catalog, allowing you
to search for specific items based on that information.

In addition to the predefined system fields, you can define
Custom Fields to hold specialized information about catalog
items. For instance, you might want to add a field for Web site
URLs to a catalog of GIF files, or a “Photographer” field to a
catalog of photographic images.

All fields, including Custom Fields, are indexed.

There are six Custom Field types from from which to choose:

• Date/Time: Enter date and/or time values. You could use this
field type to create a Custom Field for image publication dates,
for example. 

• Decimal: Enter decimal point numeric values. This field type
would be useful for custom fields containing stock image prices.

• Integer: Enter regular numeric values. This field type is ideal
for custom fields containing catalog part or stock numbers (as
long as they contain only numeric values).

• String: Enter single line text values. Can be used for any num-
ber of custom fields, including photographer or artist names.

• Text Block: Enter multiple lines of text with line breaks. 
• URL: This field type is used for Web and other URL addresses.

It creates an active hyperlink on Windows and on Mac OS sys-
tems with Internet Config properly set up. You can enter any ref-
erence in URL format including: http, ftp, telnet, gopher, even
local files or applications. This field can be used to allow users to
click on a web address to go directly to a specific site; or using a
mailto:username@site.com entry, automatically create a mail
message addressed to the username@site that you enter. 

You add data to Custom Fields either by typing it into the item
record (Item > Item Properties: Fields tab), by extracting data
from the source file and mapping it to the appropriate Custom
Field (Catalog > Cataloging Options: Mappings tab), or by
importing them (File > Import > Field Values).

Note: When you copy records from one catalog to another, if the
catalogs have matching Custom Fields, field data will be copied
along with other record data. In other words, if you want to copy
Custom Field data from one catalog to another, you must create
identical Custom Fields in each one.

Field Type Data Example

Date/Time 8/20/98 1:15 pm

Decimal 50.00

Integer 100

String Text

Text Block Multiple lines of text

URL http://www.extensis.com

Tip

Macintosh: Portfolio uses
Internet Config (installed with
QuickTime 4.0) to determine what
application handles the URL type.
Refer to your Internet Config doc-
umentation for details.
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A Custom Fields tab: Allows you to add,
delete, or modify Custom Fields. 

B Custom Fields list

C Add: Click to access the Custom
Fields Definition dialog to add and
define Custom Fields.

D Edit: Select a Custom Field from the
list, then click here to access the
Custom Fields Definition dialog to
edit the selected Custom Field.

E Delete: Select a Custom Field from
the list, then click here to Delete it. 

F Name: Enter a name for the Custom
Field, or change the name of an exist-
ing field.

G Type: Select the type of field. See
pages 209 through 212.

H Length: Allows you to enter a
maximum string length (page 209).

I Multiple Values: Click to allow the
field to contain multiple values.

J Predefined List: Click to indicate that
the field will include a predefined list.

K Edit List: Click to open the Edit Cus-
tom List dialog.

L Entry Box: Enter field list values one
at a time in the text box, then click
“Add” to add it to the list.

M Field data list: Displays the predefined
data list for the selected Custom
Field.

N Add: Click to add the value entered in
the text box (L) to the predefined data
list.

O Delete: Select one or more names
(Mac OS) or individual names (Win-
dows) from the predefined data list
(M) that you want to remove from the
list, then click Delete. The names are
removed from the Predefined Data
list, but not from any items that they
have been assigned to.

P Import and Export: Export the Prede-
fined Data list to a text file for import-
ing into another catalog. Import from a
text file or Predefined Data list export-
ed from another catalog 

Catalog Administration—Custom Fields
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To add Custom Fields to a catalog:

Note: Once a Custom Field has been created and added to the
catalog’s Custom Fields list, only the field Name, Display Time
(Date/Time fields only), Text Block, and Predefined List options
can be changed.

1. Open the catalog in Administrator mode (page 194). 

2. Choose Catalog > Administration... [Command+H 
(Mac OS) or Ctrl+H (Windows)].

3. Select the Custom Fields tab.

4. Click “Add..."

The “Custom Field Definition” dialog box is displayed.

4. Enter a name for the field in the “Name:” text box.

5. Choose the field type from the “Type:” pop-up menu.

The field type determines the values that can be entered
into this field. (See page 209.) Field types cannot be
changed once they are defined.

6. Select the appropriate remaining options for the field
type you selected, then click “OK” to return to the
Custom Fields tab.

7. When you have finished adding Custom Fields, click
“OK” to close the Catalog Administration dialog and
save changes made on any of the tabs.

For more information on setting up each Custom Field
type, see pages 209 through 211.

Custom Field Restrictions

1. URL fields cannot be set up with a predefined list.
2. URL fields cannot have multiple values.
3. URL fields must have both title and URL fields filled.
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Custom Field Types

Date/Time

This field type allows you to enter date and/or time values into
your records. You can elect to have Time values not displayed by
deselecting the “Display Time” option in the Date/Time Custom
Field Definition dialog. Date/Time fields include multiple values,
and/or be configured as a predefined list.

Note: Times are always assumed when searching on Date/Time
fields. That is, if a time value has been entered into the field
(either by extraction from the source file when the item was cata-
loged, or by entering a time in the field) and then hidden by turn-
ing off “Display Time,” the time will still be noted by Portfolio
when a search is generated. For example: Searching for
“5/20/98” will not find a record which contains “5/20/98 3:00
pm” because the request is interpreted as “5/20/98 12:00:00.”
This is true even if the time is not being displayed.

Decimal

This field type allows you to enter decimal point numeric values
with a precision up to 8 decimal points. Decimal fields can
include multiple values, and/or be configured as a predefined list.
To set the Precision, select it from the pop-up.

Integer

This field type allows you to enter regular numeric values. Integer
fields include multiple values, and/or can be configured as a pre-
defined list.

String

This field type allows you to enter single line text values. You can
specify a maximum string length for the field by entering the
number of allowable characters in the Length text box. The data
in a String Field can be from 1 to 249 characters long, and
include multiple values, and/or be configured as a predefined list.
String fields cannot contain multi-lined text (see Text Blocks on
page 212).
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URL

This field type allows you to enter Web and other URL addresses.
If the syntax is correct for a URL, the data will become an active
hyperlink on Windows, and on Mac OS systems with Internet
Config properly set up. To create an active link, enter any
reference in URL format including: http, ftp, telnet, gopher, even
local files or applications. Typically URL data might look like:
http://www.extensis.com; ftp://ftp.extensis.com/pub/file1.zip;
http://www.extensis.com/buynow/cgi?sku=012345;
mailto:username@extensis.com. 

When you edit a URL to add data to it (Item > Item Properties)
the Title that you enter is displayed in the record and becomes the
active link (Portfolio links the Title to the actual URL in the URL
field). You can give the URL any Title you like—the Title does
not need to refer to the actual URL. 

Note: When importing data into a URL field (Import > Field
Values), Portfolio treats the URL field as a multi-valued field with
two values. The first value is the Title and the second value is the
URL address. If you wish to import URLs into Portfolio they must
conform to this format. Portfolio follows the same formatting
when exporting URL data. For more information on importing
field values, see page 179. 

Predefined Lists

You can create Predefined Lists of items for your Custom Fields.
By predefining field entry data you can provide master lists of
data that users can select from when entering data in Custom
Fields (Master Palettes, page 156). All of the Custom Field types
except URL and Text Block can be set up with a predefined list.
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Like the Master Keywords list, predefined Custom Field values
accessed from Master Palettes ensures that the exact same data is
entered in the data field every time. For example, you might want
to create a list of your standard vendors and enter the appropriate
vendor name to an item’s record by selecting it from the list.
Deleting an item from a predefined list does not delete it from
items that have that data assigned.

Multiple Value Lists

Multi-value lists allow you to specify Custom Fields that can
contain more than one value. Keywords is an example, but you
might want to define other multi-value lists, such as multiple
vendor names or multiple item pricing. 

To set up a Custom Field with Multiple Values: Open the
Custom Fields Definition dialog (Catalog > Administration:
Custom Fields tab and click “Add”). Choose any field type except
URL or Text Block, then click “Multiple Values.”

As with all Custom Fields, you add data to the list of values by
typing it into the item record (Item > Item Properties: Fields tab),
by extracting data from the source file and mapping it to the
appropriate Custom Field (Catalog > Cataloging Options:
Mappings tab), or by importing it (File > Import > Field Values.)

You can specify how many lines are made available to display the
multiple value data in Record view (View > Customize: Record
tab). In the Record tab Fields List, fields that have (or can have)
multiple lines of data display a number in the right-most column
(see (P) on page 101).  To change the number of display lines,
select a number from the Display Fields pop-up (Macintosh) or
enter a number in the Edit String dialog (Windows). If no addi-
tional lines have been selected, this number defaults to 1.

211



Text Block

Text Blocks are multi-lined fields that can be any length up to
32K. This field type allows you to add lengthy lines of text to
records (that is, you can include line breaks or carriage returns in
these fields). 

Text blocks are word indexed, allowing even these longer fields to
be searched extremely quickly. The Text Block field cannot be
sorted or phrase searched.

To add text to a Text Block field, open a Gallery and select the
desired catalog item. Then choose Item > Item Properties. Click
the Fields tab. On the Fields list, select the Text Block field that
you want to edit. Click “Edit.” A dialog box will be displayed
where you can enter text. 

Or you could enable Record View and edit the field directly (be
sure to show the field in this view in the Catalog Options dialog).
See page 160 for more information on adding information to
Custom Fields. 

Note: When editing a Text Block Custom Field in Record view, a
maximum of 20 lines can be viewed at one time.
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Setting Catalog Startup Options

The Startup Options allow you to determine which, if any,
processes will be run automatically when the catalog is opened.
Options are:

• Open Find Dialog

• Open MKL (Master Keywords List)  Palette

• Run Slideshow

• Display Custom Splashscreen

• Disable Link to Original

Note: Large splashscreens add to catalog size and can take
a long time to load. It’s good practice to size your splash-
screen so that it is no larger than the screen.

Catalog Administration—Startup tab
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A Startup tab: Allows you to determine
which, if any, processes are run auto-
matically when the catalog is opened. 

B Open Find Dialog: Automatically
opens the Find dialog when the cata-
log is opened.

C Open MKL Palette: Automatically
opens the Master Keywords List
Palette when the catalog is opened.
Handy if you publish catalogs and
want to present the Master Keywords
palette automatically to your users.

D Run Slideshow: Opens the catalog
and automatically initiates a Slide-
show based on the items in the active
Gallery and the Slideshow Options.
See page 109 for more information on
slideshows.

E Disable Link to Original: Disables the
ability to preview the original image.
This is useful when you are distribut-
ing a catalog to clients without the
source files. 

F Custom Splashscreen: Import a JPEG
file to be displayed when the catalog
is opened. If an image appears here,
it is automatically displayed for 4 sec-
onds when the catalog is opened.

G Open and Clear: Use these buttons to
Open a JPEG file to be used as the
Catalog Splashscreen. Click Clear to
remove the image and open the cata-
log without a Splashscreen.



Setting Preview Options (Disk Preview)

When the “generate Previews” option is enabled, Portfolio will
create full-sized 72-dpi JPEG preview images when items are
cataloged. Previews are stored in a folder you designate, which
can be on a local device, or on a file server. This means you can
have the item source files anywhere—even offline (such as on a
CD)—and users will still be able to preview the items.
Additionally, having larger Preview files available on disk can
make opening image Preview dialogs (page 76) much faster.

Multimedia files (movies, sounds, etc.) and files that cannot have
thumbnails generated will not have Previews generated. If
Generate Preview is enabled, Portfolio will always attempt to
generate a Thumbnail and Preview (thumbnails will not be
extracted). The Preview for multi-page items will be generated
from the first page. You can also designate the quality of the
JPEG Preview, either High, Medium, or Low.

To prevent excessively large disk files from previews, the
maximum size of the long side of a preview image is 1000 pixels.
You can set the Maximum Size to any value between 100 and 1000.
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A Previews tab: Allows you to enable
generation of full-sized JPEG pre-
views during cataloging.

B Generate Previews: Checkmark indi-
cates that preview generation is
enabled.

C Location: Click to locate the folder
where previews will be stored. This
can be a local device or network
server. For multi-user catalogs, the
Previews directory should be placed
in a location accessible to all users.

D Preview Quality: Determines the
quality of the created JPEG preview.
Options are: High, Medium, Low.

E Max Size: Sets the maximum size of
the preview. Enter a value between
100 pixels and 1000 pixels. 

F OK: Click to accept the settings and
close the dialog. 

G Cancel: Click to close the dialog
without making any changes.

H Help: Click to open web help.

Catalog Administration—Previews tab
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Notes

The Preview directory must be
accessible to all users.

Selecting a higher quality preview
JPEG will result in larger files
being created.

Tip

Do not select the same folder for
both Disk Previews and Back-
ground Cataloging (page 126).
Doing so will cause Background
Cataloging to fail.



Maintaining a Catalog

Catalogs—especially large ones—that are heavily used and
frequently updated can become out-of-date. In addition to
routinely backing up all catalogs and source files (and keeping
the backups in a safe place), it is a good idea to perform other
housecleaning tasks regularly as well. Portfolio provides the
catalog manager or administrator with tools that can help with
routine catalog maintenance.

Exporting catalogs as text files: See page 184.

Removing Items from a Catalog

The “Delete Items...” command lets you clear a catalog of
unwanted or out-of-date items or references.

To remove specific items from a catalog:

1. In the catalog Gallery window, select the items that you
want to delete.

2. Select “Delete Items...” from the Catalog menu.

The “Delete Items” dialog box is displayed.

3. Select “Delete from Catalog” (Mac OS) or “Delete from
Catalog and Gallery” (Windows), then click “OK.”

Note: Select “Delete from Gallery” if you want to remove
the item from the Gallery window only; the item remains in
the catalog when you click “OK.”

— or —

1. In the Gallery window select the items that you delete
and press Option+Delete (Mac OS) or Ctrl+Backspace
(Windows).

Checking for Missing Files

You can easily determine if any file references in a Portfolio
catalog are no longer valid using the “Missing Files...” command
[Choose Catalog > Missing Items, or press Command+
Option+M (Mac OS) or Ctrl+Shift+M (Windows)]. Portfolio
only checks for missing files on mounted volumes. See 
page 125 for more information on the Missing Files command.
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Recovering Damaged Catalogs

Should you ever have trouble opening a Portfolio catalog and
suspect that it may have been damaged, you may be able to
recover it using the Recover command. Another time to run the
Recovery command is when you experience crashes when sorting
or searching on a particular field.

To Recover a catalog:

1. Close the catalog that you want to recover. 

You cannot run the Recovery command on an open catalog.

2. Choose “Recover...” from the File menu, or press
Command+Option+V (Mac OS) or Ctrl+Shift+V
(Windows).

A directory dialog box is displayed.

3. Locate the catalog you want to recover, then click
“Open.”

A second directory dialog box is displayed.

4. Type a new name for the recovered catalog, select where
you want to save it, then click “Save.”

A progress window is displayed as Portfolio checks the
catalog and attempts to repair the damage. 

5. When the completed status report is displayed, click
“OK.”

Open the recovered catalog to verify that all the items are
intact.



Using Portfolio on a Network

A single Portfolio catalog can contain references to source files
on multiple hard disks, network servers, CD-ROM discs, or
removable disks, whether these media are mounted or not. When
Portfolio needs to retrieve a source file that resides on a network
volume, it automatically mounts that volume, prompting for a vol-
ume password when required.

If a source file is stored on removable media, such as floppy disks
or CD-ROMs, Portfolio prompts for the disk by name. Portfolio
also prompts for source files that have been moved or renamed.

Shared Catalogs

Portfolio provides two ways to share catalogs in a multi-user, net-
worked environment:

Filesharing: Filesharing uses standard system networking to
share catalogs on either a dedicated file server somewhere or on a
user’s computer (provided that filesharing is turned on). Users
connect to these catalogs by choosing Open, navigating to the
particular volume, and selecting the catalog itself. Each user’s
Portfolio application (client) intelligently sets flags within the cat-
alog file itself to control things such as when other users are
allowed to access the catalog, and when other users should be
blocked from writing to a particular record. For example, when
one user writes to a record, other users accessing the catalog are
blocked from writing to that record. Filesharing does not require
the addition of Portfolio Server software, but fewer users can
access catalogs simultaneously. Catalog operations like searching
are much slower than with Portfolio Server software installed.

Client/Server: In this networking scheme, special Portfolio
Server software is used to manage catalogs on a Windows NT or
Mac OS server machine. The Portfolio Server application opens
the catalogs, and monitors the network for clients. End-users,
running standard Portfolio application software (client), access
the Server using the  “Connect to Server” command. Once con-
nected to the server users can select catalogs to open. The server
software then controls all catalog access. Portfolio Server soft-
ware allows a larger number of simultaneous users, and most cat-
alog operations are performed significantly faster. Note: The num-
ber of users permitted to connect simultaneously is set by the
multi-user license agreement. Additional connection requests will
be refused by the Portfolio Server when this limit is reached.

Tip

If someone deletes an item from
a multiuser catalog and that item
is in one or more of your saved
Galleries, an “Item Deleted” icon
appears in place of the item
thumbnail. Choose “Refresh” from
the Catalog menu to remove
these icons from the Gallery, then
resave the Gallery.

Tip

In cross-platform environments,
be sure that network server and
volume names are the same for
each platform. This allows
Portfolio to locate files between
platforms.
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SQL Server: Using Portfolio SQL server software you can keep
catalogs on your SQL server and access them from the Portfolio
client. This provides all of the advantages of using Portfolio to
manage your catalogs, but keep the data on your SQL Server.
SQL Server software is sold separately.

Network Security Protection

Your organization is authorized to use as many copies of Portfolio
as designated in your site license agreement. When you run
Portfolio on a network, the application checks the network to see
how many copies of Portfolio with the same serial number are run-
ning. If the program finds that more duplicate serial numbers are
in use than are in the site license agreement, an alert box appears.
Click “OK” to close the alert box. Another user must quit Portfolio
before you can launch the copy that you want to use.

If you did not purchase a Portfolio site license, only one copy of
Portfolio per serial number may be in use on your network.

Filesharing Network Concerns

In a typical network scenario, many users would open Portfolio,
locate items they want, and leave Portfolio running in the back-
ground while they switch to other applications to edit source files,
work on other documents, read e-mail, and so forth. Meanwhile,
at any given time, only some of those users would be actively
using the catalog to search for and preview items they might be
interested in, while fewer still might be adding or updating items,
keywords, or descriptions.

The greater the number of users who have a catalog open, the
slower individual searches will be, depending on what tasks the
users are performing in Portfolio. The speed of the network and
computer can also affect the performance of Portfolio.

If you want to limit who can write to or read from a catalog, you
can set passwords as described in “Catalog Access Levels”on
page 194.Whether or not your catalog is password-protected, it is
essential that you set up the necessary network access conditions.

If you are experiencing performance problems in a multi-user
network environment, your situation may benefit from installing a
Portfolio Server to manage catalog access.

218



Managing Source Files

There are many ways to organize the source files for items in a
Portfolio catalog. Each strategy has advantages and disadvan-
tages, but considering the options and planning ahead can save
you time in the long run and significantly increase Portfolio’s use-
fulness to you and your workgroup.

One of the key benefits of using Portfolio is that you do not need
to remember where a source file is located or what it is called.
However, because Portfolio can use filenames, folder names, or
entire pathnames as keywords, and because you can then use
those keywords to help in searching, a rational plan for naming
and organizing files and folders is helpful.

Each workgroup must ultimately decide what works best for its
own situation based on how the group works and how work flows
through it. Here are a few suggestions that might help in your
planning.

Organizing Source Files

One of the most obvious ways to organize files into folders is to
set up a series of folders for each project, client, or category (for
example, travel, business or architecture). Within a folder, use
subfolders to partition related files appropriately.

Another approach is to organize files into folders by file type, by
parent application, or by department of origin (for example,
Marketing, Sales or Publications).

Once you’ve organized your files into folders, it’s easy to include
the files into Portfolio catalogs.

Naming Source Files

Use naming and organizing strategies together to make the most
of keyword searching in Portfolio. Once you have decided how to
organize your files, consider the following alternatives for naming
them:

• Use file extensions to indicate file type. This is very important
when using Portfolio in a cross-platform environment, where
you’ll want to keep Windows file naming restrictions in mind
when naming Macintosh files and vice versa.

• Use number or alphabetic prefixes to help sort items in ways
that matter for the kinds of files you use. For example, you
might use frame numbers for images from a single photo shoot
or counter or time code readings for sounds, movies, or images
digitized from video or audio tape.
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Administering Served Catalogs

Catalog Administration is a single-user function. That is, a
catalog that is open in Administrator mode cannot be opened by
anyone else. 

On the Portfolio Server, where catalogs are shared with other
users simultaneously, this means that others will not be able to
access the catalog while you are using it in Administration mode.
When you open a catalog as the Administrator, all other users are
locked out. 

If other users have the catalog open when you change to
Administrator mode, they will be logged off immediately. To
prevent this from happening, we suggest that you use options in
the Server Administration dialog (page 224) to give users a time
period in which to log themselves off (by closing the catalog), or
give them a time period after which they will be logged off. 

To prevent users from being logged off inadvertently, a served
catalog cannot be opened in Administrator mode, even if you set
“Default Open Mode = Administrator” in Edit > Preferences. In
this case, the catalog will default to Publisher mode when it
opens. You can then alert your users and switch to  Administrator
mode (Catalog > Access).

While you have the catalog open in Administrator mode it will
not appear on the “Connect to Servers” dialog for other users
even though the catalog is still being served. To release the
catalog for other users, either close it or change to a different
access mode (Publisher, Editor, Reader).

For additional information on setting up catalogs on a Portfolio
Server, see “Server Administration” starting on page 221.

Note

This section applies to Portfolio
Network and Portfolio Server
Editions only.



The Portfolio Server is a powerful catalog server, allowing
access to Portfolio catalogs using standard Portfolio 5.0
application software. Unlike typical server applications however,
the Portfolio Server is easy to set up and use, and requires almost
no maintenance.

While standard Portfolio 5.0 application software is capable of
providing access to shared catalogs through standard system
filesharing, the Portfolio Server provides superior performance in
multi-user situations. Using the Portfolio Server instead of regular
system networking yields:

• Increased performance in a networked environment
• Increased number of simultaneous connections
• Connection to Portfolio SQL Connect (page 266)

(software sold separately) 

With Portfolio Server you can:
• Connect remotely to the server (using TCP/IP)
• Manage the Server and Catalogs from the standard 

Portfolio 5.0 application (client)
• Keep Catalogs open on the Server while they are being

administered

Note: Instructions on creating and administering Portfolio cata-
logs for access from a web server (PortWeb) start on page 236.

Server Administration versus Catalog Administration

When using the Portfolio 5.0 application in conjunction with the
Portfolio Server, two different types of Administration are available:

Server Administration: The Server Administrator has permission
to administer the Portfolio Server. In addition, the Server
Administrator creates, opens, and closes Catalogs on the Server.
Client access is added through adding special multi-user serial
numbers to the Server. Server Administrator duties are described in
this section.

Catalog Administration: The Catalog Administrator has
permission to access Administrator level functions for particular
Catalog(s). Catalog Administration is discussed starting on page
192.

Server Administration

Tip

For information on administering 
an SQL Connect, see page 266.
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System Requirements

Windows:
•  Pentium PC (233 MHz or faster recommended)
•  Microsoft Windows NT 4.0 or higher (Server or Workstation)
•  32MB RAM (64MB RAM or more recommended)
•  TCP/IP Services installed 
•  For optional SQL Connect requirements, see page 266

Mac OS:
•  Power PC
•  Mac OS 8.1 or higher
•  32MB RAM (64MB RAM or more recommended)
•  TCP/IP Services installed

Server hardware requirements are based on performance. The
Server will function on any WinNT 4.0 system, but performance
will probably be unacceptable if used with any system below the
listed requirements. In addition, the Portfolio Server software will
normally benefit a great deal from a faster processor, more
physical memory, multiple processors, faster network connections,
and faster hard drives (such as Ultrawide SCSI drives).

Note: Extensis does not provide Technical Support for configuring
TCP/IP Services, setting up DNS services, configuring a firewall,
or other networking issues. For assistance with these issues,
please consult your System Administrator or the product vendor’s
technical support.

Installing the Server

Installing the Portfolio Server is quick and easy. Simply launch
the installer and allow it to guide you.

The Portfolio Server application has no interface itself; access to
Server features is handled through standard Portfolio 5.0 applica-
tion software. Note: On Windows NT, the Portfolio Server is a
system service. This service must be started on the Server before
it will be active. To do so, open the “Services” Control Panel.
Select “Portfolio Server” from the list and click “Start.”

To access a Portfolio Server:Open the Portfolio 5.0 application.
From the File menu choose “Administer Servers...” Select a
Server, then click “Administer.” From the Administer Services
dialog you can add and administer one or more Portfolio Servers
(see page 223).
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Administering a Portfolio Server

Portfolio Servers are accessed and administered from the
Portfolio 5.0 application via the Administer Servers command. 

Once a Portfolio Server has been made available to the network
(page 225), the Server Administrator can:

•  Create Catalogs to be served
•  Serve and Unserve catalogs
•  Open and close Portfolio SQL Connect (sold separately) catalogs
•  Log off individual users
•  Set/change Server Administration passwords
•  Add multiple user access by entering special multi-user serial

numbers

Refer to other sections of this Portfolio User Guide for assistance
in creating, managing, and administering Catalogs.

Tip

Before you can perform any
Portfolio Server Administration
operations, the Portfolio 5.0
Server software must running on
the server machine, and the
Portfolio 5.0 application software
must be running on the machine
from which you wish to access the
Server.

Administer Servers Dialog

Allows you to add, remove, and edit
(change name, IP address, password,
etc.) Portfolio Servers, and to access
the Server Administration dialog for the
selected Portfolio Server.

A Servers and Catalogs list: Displays
all available Portfolio Servers and
served catalogs, including Servers
with SQL catalogs. Click the expand
icon (or double-click the Server
name) to display the list of served
catalogs.

B Done: Closes the dialog.

C Administer: Click to open the Server
Administration dialog for the selected
Portfolio Server (see page 224).
From this dialog you can add,
remove, serve and unserve Catalogs,
as well as change Server password
and add multi-user Serial Codes.

D Add Server: Allows you to add a new
Portfolio Server to the list.

E Remove Server: Allows you to
remove selected Portfolio Servers.

F Edit Server: Allows you change the
server name and/or IP address.

A
B

C

D

E

F



Server Administration Dialog

Allows you to administer the selected
Portfolio Server from the Portfolio 5.0
application. To access this dialog,
select (highlight) the desired Server
name from the list on the Administer
Server dialog (File > Administer
Servers), then click “Administer...”

A Catalog and Users list: Includes all
served catalogs on the selected
Portfolio Server, including served
SQL databases (page 266). Click the
expand icon to display the list of
users logged on to each catalog.

B Done: Closes the dialog.

C New: Allows you to create a new
Catalog on the Portfolio Server.

D Serve: Displays a list of catalogs
available for serving (in, or aliased in,
the Server’s “Catalogs” folder), and
allows you to open catalogs for
serving on this Server. 

E Serve SQL: Opens a dialog where
you can set up SQL Servers and
serve SQL databases as catalogs.
See page 266.

F Unserve: Allows you to unserve a
selected catalog or SQL database.
Users will be notified and given a
pre-set time to do so. See page 230.

G Log Off User: Allows you to log off
selected user(s) from a served
Catalog immediately. 

H Set Password: Allows you to set or
change the Administrator password
for the selected Portfolio Server.

I Serialize: Allows you to serialize the
selected Portfolio Server and/or
Portfolio SQL Connect. Multi-user
serial codes are entered into each
individual user’s Portfolio 5.0
application (client).

A
B

C

D

E

F

G

H

I
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Adding a Portfolio Server

Before you can serve catalogs on your Portfolio Server you must
make the server available—that is, tell the Portfolio application
where to find the server.  You do this through the Server
Administration dialog, shown on page 224.

To add a Portfolio Server:

1. Launch the Portfolio 5.0 application.

You do not need to have a catalog open.

2. From the File menu, choose “Administer Servers...”

The Administer Servers dialog will be displayed.

If no servers have been added, the servers list will be
blank.

3. Click “Add Server...”

4. Enter the name and IP address for the Server.

5. Click “OK.”

The Server will be added to the list and will be available
for users to access (see page 235 for setting up user access).

Selecting the
Server name on
the list will
activate the
Administer,
Remove Server,
and Edit Server
buttons.
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Accessing a Portfolio Server for Administration

When one or more Portfolio Servers have been added (made
available) (page 225), you can administer them by creating and
serving Catalogs. To do that, you must first access the Server
through the Server Administration dialog (shown on page 224).

To access a Portfolio Server:

1. Launch the Portfolio 5.0 application.

The Portfolio Server can be accessed via the Portfolio
application from anywhere on the network or internet.
With Portfolio 5.0 there is no separate Server
Administration software.

2. From the File menu, choose “Administer Servers.”

The Administer Servers dialog is displayed.

Note: If no server
names appear on
the list, you will
have to add them
before they can
be administered.
See page 225.

3. Select the desired Portfolio Server from the list, then
click “Administer...”

You will be asked to enter the Server Administrator
password. The first time you access a Portfolio Server as
the Administrator, you will be prompted to serialize the
Server (see page 232).

4. Enter the Server Administrator password, then click
“OK.”

The first time you access a
Portfolio Server as the
Administrator the password
will be blank. You can enter
a password, or just click
“OK” and set the password
later.

Important

While you can do so, in most
environments it is probably not a
good idea to leave the Server
Administrator password blank.
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The Server Administration dialog for the selected Portfolio
Server will be displayed, and any served catalogs for that
Server will be listed. 

You can view any users connected to served catalogs by
clicking the expansion icon, or by double-clicking the
catalog name.

From the Server Administration dialog you can create,
serve and unserve catalogs, log off users, set the password
for the selected Server, and add the Server serial code.
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Creating Catalogs on a Server

From the Administration dialog for the selected server (page 224)
you can create new (empty) catalogs to be served on a Portfolio
Server.

To add a Catalog to a Portfolio Server:

1. Open the Server Administration dialog (File >
Administer Servers > [select server] > Administer).

2. Click “New...”

The New Catalog dialog will be displayed.

3. Enter the name of the catalog that you wish to create.

On Windows, and on Mac OS if compatibility with
Windows users is required, catalogs must be given a
“.fdb” filename extension.

4. Click “OK.”

The Catalog will be added to the list of Catalogs in the
“Catalogs” folder on the Server machine.

— or —

1. Create a Catalog from the Portfolio client (page 113).

2. Copy the catalog (via the operating system) to the
Portfolio Server’s “Catalogs” folder.

You can now serve the catalog (page 229) to make it available to
your users. 
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Serving and Unserving Catalogs

To serve (open for use) a Catalog on a Portfolio Server:

1. Open the Server Administration dialog (File >
Administer Server > [select server] > Administer).

2. Click “Serve...”

A list of available Catalogs on the Portfolio Server will be
displayed.

— or —

2. Navigate through folders and volumes accessible to the
Portfolio Server to locate the Catalog to be served.

Catalogs do not have to be located in the Catalogs folder to
be served (see sidebar Tip).

3. Select the Catalog that you want to serve, then click
“Serve.”

The Catalog will become available to Portfolio users.

Note: When a catalog is first served it is opened
automatically in Administrator mode. To make the catalog
available to users, close the catalog or change access
mode to a level lower than Administrator (Publisher,
Editor, or Reader).

Tip

Catalogs (or their aliases) located
in the “Catalogs” folder of the
Portfolio Server are served
automatically when the Portfolio
Server application is launched.
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To unserve a Catalog on a Portfolio Server:

1. Open the Server Administration dialog for the server
(File > Administer Servers > [select server] >
Administer).

2. From the list of served Catalogs, select the Catalog that
you wish to unserve (make unavailable).

3. Click “Unserve...”

If users are connected to the Catalog, a warning dialog will
be displayed. You can enter a delay time in minutes before
the Catalog closes.

Connected users will be notified of the imminent closing
so that they can close open windows and connections
related to that Catalog.

Notes on Unserved Catalogs:

• Portfolio Server and source images: As with the filesharing
model of multi-user Portfolio access, the Server does not serve
the original files, only the records of cataloged items (see
“Portfolio Basics” on page 12). What this means is that the
client machine must have access via the file system to the
original file in order to perform functions that require the
source file, such as Preview (unless the option “Generate
Previews” was enabled when the item was cataloged); Copy;
Move; Rename; etc.

See page 217 for tips on filesharing in a mixed Macintosh and
Windows environment.

• Server Port number: The Portfolio Server operates via port
2903. In order to avoid conflicts with other applications, make
sure no other server software is using this port on the server
machine. (We are currently unaware of any other application
that uses this port address.) Be aware that if you have clients
attempting to access the server through a corporate firewall,
you may have to have the network administrator open a hole in
the firewall for this port.
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Logging Off Users

To log off users on a Portfolio Server:

1. Open the Server Administration dialog for the server
(File > Administer Servers > [select server] >
Administer).

2. From the list of served Catalogs, locate the Catalog
with users that you wish to log off, then click the
expansion arrow to view a list of active users on the
Catalog.

3. Select the user that you want to log off.

4. Click “Log Off User.”

That user will be logged off immediately.

Note: To allow users a time frame within which they can
log themselves off (by closing their copy of the catalog),
use the “Unserve...” command (see page 230).
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Server Administrator Password

To set or change the Portfolio Server Administrator password:

1. Open the Server Administration dialog for the server
(File > Administer Servers > [select server] > Administer).

2. Click “Set Password...”

The Set Password dialog
will be displayed.

3. Enter and confirm the new Server Administrator
password, then click “OK.”

To exit the dialog without affecting the password, click
“Cancel.”

Serialization

In Portfolio 5.0, the Portfolio Server is activated with a single
Portfolio Server serial code. (Portfolio SQL Connect is activated
with a single SQL Serial Code. See page 276). 

The first time you attempt to administer a Portfolio Server you
will be prompted to enter the serial code. You can also access the
Serial Codes dialog from the Server Administration dialog (File >
Administer Servers > [select server] > Administer > Serialize). 

Multi-user serial numbers (licenses) allow users to connect to the
Portfolio Server, up to the limit of users for that serial number.
The multi-user serial number is entered at each workstation when
the Portfolio 5.0 application (client) is installed. The Portfolio
Server tracks how many connections are open at one time, and
limits access to the catalog to the maximum number of
connections for that serial number. To add additional connections,
simply contact Extensis Customer Service to purchase additional
multi-user serial numbers.
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To serialize a Portfolio Server:

1. Open the Server Administration dialog for the server
(File > Administer Servers > [select server] > Administer).

2. Click “Serialize...”

The Serial Codes dialog is displayed.

3. Click “Add...”

The Add Serial Code dialog is displayed.

4. Enter the Portfolio Server Serial Code (and/or SQL
Connect Serial Code), then click “OK.”

When you click “OK” you will be returned to the Serial
Codes dialog. The newly entered codes will be listed.

5. Click “Done” to return to the Server Administration
dialog.
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Removing a Portfolio Server or SQL Connect Serial Code

This feature is helpful if you wish to move a serial number from
one server to another, such as when setting up a Portfolio Server
in a different location. 

Note that the serial can be used on only one Portfolio Server at a
time.

To remove the serial number from a Portfolio Server, or to
remove SQL Connect:

1. Open the  Administration dialog for the server (File >
Administer Servers > [select server] > Administer).

2. Click “Serialize...”

The Serial Codes dialog is displayed.

3. Select the Serial Code that you wish to remove, then
click “Delete.”

The serial code will be removed from the list, and those
connections will no longer be available on the selected
server.
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Providing Users with Access to Served Catalogs

Once a catalog is served you will want to give users access to
the catalog. Detailed user instructions are given on page 24. 
The process from a Server Administration standpoint is
summarized here.

To access served catalogs:

1. Note the name given to the Portfolio Server(s) that you
wish to give access to. 

Server names are displayed on the Connect to Servers
dialog (File > Connect to Servers) and the Administer
Servers dialog (File > Administer Servers). 

2. Give this name to your Portfolio users.

3. On the user’s machine, launch Portfolio 5.0, then
choose File > Connect to Servers... 

The Connect to Servers dialog will be displayed. 

4. Choose “Add Server...” and enter the name and IP
address of the Portfolio Server.

The client application will poll the Server and display any
catalogs being served. 

5. Click “OK” then click “Done.”

The user can now open catalogs served on that Server.

Notes on Accessing Served Catalogs:

• Client machines must have TCP services active to access the
Server. For Mac OS clients, the machine must be using Open
Transport TCP 1.1 or higher; classic networking is not supported.

• Clients can access a served catalog in Administrator mode, but
all other users must be logged off first. You can log users off
from the Server Administration dialog, or users can simply
disconnect.

• The client application will attempt to open the catalog in the
mode set in the user's Preferences. If the preference is set to
Administrator, the client application will automatically attempt
to connect to the catalog in Publisher mode.
Note: The user will be asked to enter a Password if the catalog
requires it.

• For more information on installing and using the client, refer to
the other sections of this Portfolio User Guide.

Tip

Server connection files are stored
in the “Servers” folder located in
the Portfolio application folder for
each client. Once a server has
been added to one client, its con-
nection file can be distributed
throughout a workgroup, eliminat-
ing the need for other users to go
through the “Add Server” process.
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PortWeb 5.0, a web server plug-in, is an easy-to-use add-on to the
Portfolio 5.0 asset management system that enables web browser-
based users to browse Portfolio catalogs. PortWeb establishes a
connection between a web server and either a Portfolio Server or
a Portfolio catalog on disk to provide a truly dynamic link
between web-based users and Portfolio catalogs, so they can
quickly search up-to-date Portfolio information.

System

To install and use PortWeb 5.0, you will need the following:

Macintosh
Minimum hardware PPC Only
Minimum OS System 8.1
Supported Web Servers StarNine WebStar 2.0–4.2

Apple Web Server  
(Part of Appleshare IP 6)

Windows
Minimum hardware Pentium 200
Minimum OS Windows 95/98/2000/NT 4.0
Supported Web Servers MS Internet Information Server (IIS)

(3.0–5.0)
MS Personal Web Sharing Server 

(95/98)
MS Peer to Peer Web Sharing Services

(NT)

Installing PortWeb

You can find instructions for quick and easy installation on the
CD-ROM that is included with your product or, if you down-
loaded the installer from our web site, running the installer will
place an informational Read Me on your hard drive.

In addition, to use PortWeb, you will also need to install
Portfolio. Refer to other sections of this Users Guide for
instructions on how to install and use Portfolio.

PortWeb

Tip

For additional examples using
PortWeb to serve catalogs over
the internet, we invite you to visit
the PortWeb pages on the
Extensis web site:

http://portweb.extensis.com

236

Note

This section applies to Portfolio
Network and Portfolio Server
Editions only.

http://portweb.extensis.com


Macintosh Memory Usage

As a plug-in, PortWeb does not allocate its own memory parti-
tion, but rather operates within the memory partition of the web
server. Because PortWeb needs more memory than most plug-ins,
you should increase the amount of memory that your web server
allows the plug-in after you have run the PortWeb installer.

WebStar:

1. Make sure that WebStar is not running.

2. Select the WebStar application in the Finder.

3. Choose “Get Info” from the File menu.

4. Increase the “Preferred Size” by 3000 K.

Appleshare IP 6.x:

1. Open the Appleshare IP Web & File Admin application

2. Choose “Web & File Server Settings” from the Server
menu.

3. Switch to the Web Plug-Ins pane.

4. Increase the “Maximum Plug-in Memory Usage” by
3000 K.

5. Restart the web server.

Required Knowledge

Setting up and administering PortWeb is not difficult, but it does
require some understanding of HTML. Much of the necessary
information is covered within this manual, but you will benefit
from additional reading. Some good starting points for tutorials
on the web are:

NCSA Beginner’s Guide to HTML:
http://www.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimer.html

Welcome to the HTML Basics:
http://www.projectcool.com/developer/zones/basics_top.html

Forms tutorial: http://www.devshed.com/resource/intermedi-

ate/html/forms.phtml

Nuthin’ but Links Forms Tutorial:
http://pages.prodigy.net/bombadil/forms.htm

The Compendium of HTML Elements:
http://www.htmlcompendium.org/
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Overview

Overview of Web Server Plug-ins

A web server plug-in extends the functionality of the web server.
Essentially, when a web server is launched, it looks to determine
whether any plug-ins are installed. If plug-ins are found, they are
loaded, so that the web server becomes aware of the new types of
requests that can be handled, and which plug-in should receive the
request.

Overview of PortWeb

PortWeb works by registering itself with the web server, so that
the web server knows to pass certain types of requests on to
PortWeb. The general process that occurs in a user’s search
through PortWeb is as follows:

1. The user loads a static HTML search page containing a
search form.

2. The user enters search criteria and submits the form.

3. The web server passes the form data over to PortWeb.

4. PortWeb parses the data and performs the search in a
specified Portfolio catalog.

5. PortWeb parses the specified Export HTML template.

6. PortWeb merges the search results with the template and
returns the page back to the user’s web browser (via the web
server) for display.
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Plug-In Communication Methods

In general, there are two mechanisms for communicating with a
web server plug-in. These are known as the GET and POST
methods.

Note that the GET method can be used in a form (simply by
setting the Method to “GET”), but it is common practice to use
the POST method in these situations.

The primary difference between the two methods is that POST
allows for user intervention via a form for changing parameters,
while the GET method has hard-coded parameters. Each of these
methods is useful, depending on the situation. For example, if you
wanted to have a simple button that automatically searches a par-
ticular catalog for a particular keyword, then the GET method is
the simpler and more concise approach. However, if you’d like to
ask the user for particular parameters (such as the keywords to
search for) then a form using the POST method is more applica-
ble. In addition, the POST method can have unlimited request
data and parameters, but the GET method can be limited to 4K of
request information (depending on the browser).

PortWeb fully supports both methods, and there are actually
situations where it makes sense to use both methods on the same
HTML page.

GET Typically, the GET method is used as an embedded link, such as:

<A HREF="/scripts/PortWeb.dll?QuickFind=cat&catalog=WebTest">...</A>

POST The POST method, on the other hand, is usually used inside an HTML Form, such as:

<FORM ACTION="/scripts/PortWeb.dll?QuickFind" METHOD=POST >

<INPUT NAME="QuickFind" TYPE="TEXT" VALUE="cat">

<INPUT NAME="catalog" TYPE="HIDDEN" VALUE="WebTest">

<INPUT TYPE="submit" VALUE="Search">

</FORM>

Method Command

Plug-In Communication Methods

239



PortWeb Request Types

Regardless of which method is used to communicate with
PortWeb, the general structure of the request is the same. Each
time a request is sent to the plug-in, the web server must first
identify the plug-in, then the plug-in identifies the command to be
executed and the parameters necessary for that command to work.   

Identifying the Plug-In

The plug-in’s location must always be provided in a request. This
is what tells the web server to pass the request on to PortWeb.
Plug-ins are identified differently on different platforms. Refer to
the section corresponding to the platform of your web server.
Throughout this section, the two platforms will be used
interchangeably. Be sure to use the syntax appropriate for your
platform, as shown in the tables.

Windows

In both cases (GET and POST), you must provide not only the
name of the plug-in, but also the path to the plug-in on the server.
The simplest mechanism for referencing the plug-in is to use a
“root-relative” path, such as “/scripts/PortWeb.dll...” This
indicates that the plug-in is located in the “scripts” directory at the
root level of the web server.

Alternately, you could use a full URL to locate the plug-in, such as:

This is often used when the plug-in is running on a web server
other than the one serving the web pages.

GET Using the GET method, the plug-in is identified as the first part of the HREF:

<A HREF="/scripts/PortWeb.dll?QuickFind=cat&catalog=WebTest">...</A>

POST Using the POST method, the plug-in is identified in the first half of the ACTION attribute:

<FORM ACTION="/scripts/PortWeb.dll?QuickFind" METHOD=POST >

Method Command

Identifying the Plug-In—Windows

<A HREF="http://www.myserver.com/scripts/PortWeb.dll...></A>
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Macintosh

Normally, the path to the plug-in is not required. This is because
the plug-in is registered with the server when the web server
launches.  However, if the plug-in is on a separate web server
other than the one serving the web pages, you would use the full
URL. For example:

GET Using the GET method, the plug-in is identified as the first part of the HREF:

<A HREF=".PortWeb?QuickFind=cat&catalog=WebTest">...</A>

POST Using the POST method, the plug-in is identified in the first half of the ACTION attribute:

<FORM ACTION=".PortWeb?QuickFind" METHOD=POST >

Method Command

Identifying the Plug-In—Macintosh

<FORM ACTION="http://otherserver.com/.PortWeb?QuickFind" METHOD=POST >
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PortWeb Commands

The commands currently supported in PortWeb are shown in the
table below.

The command is always passed in immediately following the
plug-in location. The question mark (?) is used to indicate the
beginning of the request variables. The first variable indicates
which request (quickfind, query, etc.) to perform.

Using the GET method, the command immediately follows the
plug-in location.

Using the POST method, the command is identified in the second
half of the ACTION attribute:

<A HREF="/scripts/PortWeb.dll?quickfind=cat&catalog=Sample">...</A>

<FORM ACTION="/scripts/PortWeb.dll?quickfind" METHOD=POST >

quickfind A very simple search command for doing basic keyword searches.

query A more flexible search command for creating complex searches.

add Adds one or more records to a user’s collection (shopping cart).

show Displays the user’s collection.

remove Removes one or more records from a user’s collection.

adminshow Displays the Administration module for PortWeb.

Command Description

PortWeb Commands

Tip

For sample templates and more
details about PortWeb HTML, see
“PortWeb Templates” starting on
page 281.
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PortWeb Parameters

Each command requires one or more parameters. These are all the
variables that affect what the command does. For example, two of
the most important parameters for any request are the name of the
catalog to search and the response template to be used.    

Using the GET method, parameters are specified directly within
the HREF, and are entered as value pairs (a parameter and its
value). Each value pair is separated by an ampersand (&). The
parameter is separated from the its value by an equals sign (=). In
the following example, the parameter “catalog” is passed in
with the value “Sample.”

Using the POST method, the parameters are defined using form
INPUT tags. In the following example, the parameter “catalog”
is passed in with the value “Sample.” In this case, the parameter
is hidden, so that it cannot be modified by the user. Other INPUT
types (such as “TEXT”) could be used to get information from the
user.  For more information on setting up HTML forms, please
refer to an HTML reference guide. (See “Required Knowledge”
on page 237,for suggested starting points).

<A HREF="/scripts/PortWeb.dll?quickfind=cat&catalog=Sample">...</A>

<FORM ACTION="/scripts/PortWeb.dll?quickfind" METHOD=POST >

<INPUT NAME="catalog" TYPE=ÓHIDDEN" VALUE="Sample">

</FORM>
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Setup and Administration

Before users can access PortWeb, it needs to be configured via
the PortWeb Administration page. This page is accessed by
issuing the “adminshow” command to the PortWeb plug-in.

Using the Administration Module

To access the plug-in, enter the appropriate URL for the platform
hosting the web server:

Windows
http://yourserver/scripts/PortWeb.dll?adminshow

(Where “yourserver” is the IP address or domain name of your
web server.)

Macintosh
http://yourserver/.PortWeb?adminshow

(Where “yourserver” is the IP address or domain name of your
web server.)

With WebStar, you can also access PortWeb’s Administration
module via the Plug-ins page of the WebStar administration
pages.
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You may be asked for an administrator name and password. For
more information on authenticating administrators, refer to the
“Authentication” section, below. The resulting web page should
look something like:
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There are three sections to the Administration module, which are
explained in detail below. The Submit button at the bottom of the
form allows you to save any changes you’ve made. The Reset but-
ton clears any changes you’ve made to the form.

1. Served Catalogs

The Served Catalogs section identifies the mappings between
particular catalogs and their web “aliases.” Using aliases allows
the user to pass in a shorter request (i.e. “dogs” instead of
“D:\Portfolio\Files\Catalogs\dog database.fdb”). 

It also has the added advantage of not requiring an Administrator
to rewrite all of their HTML pages (and response templates)
because the location of a catalog has changed. Instead, changing
the mapping in the Administration module will keep all the
templates current. 

The administration module will display all the current mappings
(both active and inactive) and two additional lines to add new
mappings. If you want to enter more than two mappings in one
session, simply enter the first two and click Submit to get a new
form that contains the new mappings and two new lines in the
form. To permanently delete a mapping, clear the Alias, Path, and
Password entry fields and then click the Submit button.

The four components for a proper catalog mapping (Alias, Path,
Password, and Enabled) are discussed below and on the following
pages.

Alias

This should be a short, easily remembered name by which the
catalog will be referred to when specifying which catalog to
search via PortWeb. Avoid using spaces and non-standard non-
ANSI characters (such as trademark symbols, ellipses, etc.) in
this name, or you will have to take special steps to encode the
alias in the your HTML pages.
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Path

This is the full path to the Portfolio catalog. The catalog can be
either a file on disk or a catalog being served by a Portfolio
Server.

Local (on disk): To reference a local path, simply type in the
entire path name, such as:

Windows
F:\Portfolio\Catalogs\dog.fdb

or

Macintosh
Macintosh HD:Portfolio:dog.fdb

The disk can be in any location accessible via the file system of
the computer hosting PortWeb. Note that some Macintosh
characters do not map to the ISO-standard character set used on
the Internet. If your catalog’s path has odd characters (such as
copyright symbols, curly-quotes, etc.) you will probably need to
change the path on disk to work over the Internet properly.

Served Native:To reference a Macintosh or Windows catalog
(same for both) being served by a Portfolio server, use the
following format:

portfolio://128.0.0.01/dog.fdb

The word “portfolio:” must be all lower-case.

Served SQL:To reference a catalog being served on an SQL
server, use the following format:

portfoliosql://192.168.0.1/dog.fdb

The word “portfoliosql:” must be all lower-case.

Important

When connecting to a served
Portfolio or SQL catalog, be sure
that the pathname containing
“portfolio” is all lower-case. If it is
not, the connection will fail.
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Password

This is the Reader password for the catalog, if one has been
specified. If there is no password for the Reader level of the
catalog, simply leave the field blank. Note that because higher-
level passwords work for lower levels (i.e. you can log into
Reader mode with a Publisher password), it will work to use any
of the four access levels’ passwords in this field.

Note: PortWeb only supports Level-based passwords when giving
access to catalogs. If your catalog is set up with User-based
access, users will not be able to connect to the catalog. To change
to Level-based catalog access, see page 197.

Enabled

This checkbox (see page 245) indicates whether the mapping is
currently active. When this checkbox is unchecked, PortWeb
releases the catalog. This is useful when you want to deactivate a
catalog temporarily without having to delete and re-enter all the
information on the entire line.

When a mapping is enabled, PortWeb opens a connection to the
catalog. As a result, you cannot open a Portfolio catalog in
Administrator mode or with the Portfolio Server while PortWeb is
connected to that catalog.

Be aware that if you have a served catalog enabled in your list,
the catalog will become inaccessible via PortWeb if you close
that catalog on the Portfolio Server and then reopen that catalog
on the Portfolio Server. As a result, you will get an empty page
returned if you make a requests using this served catalog. To rem-
edy this, return to the PortWeb Administration Module page and
resubmit the page (with that mapping enabled). 

If the Administration page displays an unchecked “Enabled” box
after you submit it, verify that the path was entered correctly.
Also verify that catalog is not opened exclusively by a Portfolio
client. If you are trying to access a served catalog, make sure you
are using the appropriate syntax (see “Path” on page 247).
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2. Collections

The Collections section controls the duration for which Collection
records should be kept in the database. Simply specify the number
of days for which the users’ collections should be retained. Bear
in mind that the collection database’s file size will increase the
longer you retain these records.

Authentication

In order to access the Administration module, you must have
administrative access to the web server. PortWeb will attempt to
authenticate that you have such privileges before displaying the
Administration module page. Most web servers have their own
unique mechanism for validating administrators. 

Some web servers do not have any authentication at all; in these
situations, PortWeb will check to see whether you are accessing
the administration page from the same machine (based on IP
address) as the web server itself. If you attempt to access the
Administration module from a remote machine on a web server
that does not support authentication, the attempt will fail.

WebStar 2.0:You must access the Administration module
through WebStar’s administration page. The usual URLs
(http://yourserver/.PortWeb?adminshow) may not work.
When accessed through WebStar’s administration page, PortWeb
will allow any user in the “pi_admin” realm to read and change
settings. (See the WebStar manual for more information on
security, realms, and users.)

WebStar 3.0 and 4.0:If you access PortWeb administration
through the usual URL
(http://yourserver/.PortWeb?adminshow) or through
WebStar's administration page, PortWeb will allow any user in the
Administration realm to read and change settings. You can also
specify the realm for PortWeb administration (i.e.
http://yourserver/pi_admin.PortWeb?adminshow),
and PortWeb will allow users in that realm to access PortWeb
administration. (See the WebStar manual for more information on
security, realms, and users.)

AppleShare IP: PortWeb requires that you access the
Administration module from the machine running PortWeb.
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Windows NT 4.0/Windows 2000 Server Internet Information
Server and Windows NT 4.0/Windows 2000 Workstation Peer
Web Services:With the “Basic Authentication” setting checked
in the Service Properties dialog, the user will be prompted for a
name and password. Any user who belongs to the
“Administrators” group on the server computer will be properly
authenticated and allowed to view and edit the PortWeb
Administration module.

Personal Web Sharing Server for Windows 95 and Windows
98: Most versions of PWS do not support authentication. In these
situations, you must access the Administration module from the
machine running PortWeb.
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Basic PortWeb Tutorial

To get introduced quickly to how PortWeb works, follow the basic
tutorial laid out in the following steps.

Setting Up the Tutorial

This tutorial uses the Portfolio 5.0 Sample Catalog to illustrate
some of the basic features of PortWeb. 

To set up the tutorial:

1. Install the PortWeb plug-in and launch your web server.

Tutorial files are installed at the root level of your web
server.

2. Launch a web browser, and connect to the
Administration module. Do this by entering the URL
appropriate for your platform:

Windows
http://yourserver/scripts/PortWeb.dll?admin-
show

Macintosh
http://yourserver/.PortWeb?adminshow

(Where “yourserver” is the IP address or domain 
name of your web server.)

3. You may be asked to enter your web server
Administrator name and password information. 

4. The resulting page should be the Extensis PortWeb
Administration Module. See “Served Catalogs”on 
page 246.

5. In the first blank line of this section’s form, enter the
name “Sample” in the Alias field.
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6. In the path, enter the path to the Sample Catalog
(located in the “Tutorial” folder). The path should be
the full path, such as:

Macintosh
Macintosh HD:WebStar 3.0:Tutorial:Sample
Catalog.fdb

Windows
C:\Inetpub\wwwroot\Tutorial\Sample
Catalog.fdb

Note that the actual paths may vary based on the
configuration of your computer.

7. Leave the Password field blank and make sure the
Enabled box is checked on this line of the form.
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8. Click the “Submit” button at the bottom of the
Administration form.

This instructs PortWeb to begin accepting requests for
information from this catalog. If the Administration page is
returned with the enable box disabled, check the path and
verify that the catalog is not opened exclusively by a
Portfolio client.

Loading the Basic Page

Once the Sample Catalog is properly being served by PortWeb,
launch your web browser, and load the search page through your
web server. To do this, point your web browser at the web
server’s IP address or domain name, and then follow it with one
of the following search pages:

Macintosh
http://yourserver/Tutorial/Basic.html

Windows
http://yourserver/Tutorial/Basic.html

(Where “yourserver” is the IP address or domain name of your
web server.)

Note: Do not load the HTML page directly from disk (i.e. where
the URL looks like
“ file:///C:/|/Tutorial/Basic_Win.html”) as this will
prevent the forms from functioning correctly.

Trying the Different Options

Try the different searches, and examine the source code for each
one to get a feel for how the different searches work. Open the
“Sample Catalog.fdb” catalog and examine the Export HTML
templates to see how the more advanced search results are
formatted.

There’s much more to PortWeb than what is covered in this
tutorial. For more information on more advanced topics, refer to
“PortWeb Templates,” pages 281 through 291.
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Creating Search Pages

PortWeb does not generate a search form. Instead, you have total
freedom to create search requests in any format you can conceive
of in HTML. This allows PortWeb to integrate seamlessly with
your existing web site. The search form you create can be as
simple or as complex as your needs require. Two different
commands provide for both simple and complex search queries.

QuickFind Command

The quickfind command is a simplified search mechanism for
basic keyword searches. It performs a “Keywords starts with”
search with the specified text. The acceptable parameters are
shown in the table below:

quickfind This is the name of the command, but also the parameter for 
passing in the keyword to search for.

catalog Specifies the alias of the catalog to be used. The alias is mapped
via the settings file to either a catalog on disk or a catalog being
served by a Portfolio server.

template [OPTIONAL] Specifies the name of the Export HTML template to be used for
the response page. If this parameter is not passed in, a default
Export HTML template will be used (a basic thumbnail view layout
in a 4 x 4 grid).

sorton [OPTIONAL] Identifies the field on which to sort the found set is be sorted. 
The sort field must be an indexed single-value field. If it is not
specified, the order of the record set is the order returned by
theFind.

ascending [OPTIONAL] Specifies the order in which the record set is sorted. A value of 0
indicates ascending, a value of 1 indicates descending. If the
sorton parameter is not provided, this parameter is ignored. If the
sorton parameter is provided and this parameter is not, the default 
sort order is 0 (ascending).

offset [OPTIONAL] A positive integer indicating how many records have already been
displayed from the collection. If the parameter is not specified,
the display starts from the first record in the collection.

Parameter Description

QuickFind Command
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Examples:

• This simple search looks for the records containing a keyword
that starts with “Com” in the catalog aliased to “Sample” in the
PortWeb settings file. Records containing the keywords “com-
puter” and “communications” would both be returned.

• This is essentially the same search, but using a form that allows
the user to enter the keywords for which to search. This also
shows all of the optional parameters being used. 

<FORM ACTION="/scripts/PortWeb.dll?QuickFind" METHOD=POST >

<INPUT NAME="quickfind" TYPE="Text" VALUE="">

<INPUT NAME="template" TYPE="HIDDEN" VALUE="Simple">

<INPUT NAME="sorton" TYPE="HIDDEN" VALUE="Filename">

<INPUT NAME="ascending" TYPE="HIDDEN" VALUE="1">

<INPUT NAME="offset" TYPE="HIDDEN" VALUE="10">

<INPUT NAME="catalog" TYPE="HIDDEN" VALUE="Sample">

<INPUT TYPE="submit">

</FORM>

<A HREF="/scripts/PortWeb.dll?quickfind=com&catalog=Sample">...</A>
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Query Command

The query request is the core of PortWeb. This command causes
a search to be performed in a particular Portfolio catalog, and the
results to be returned in a particular layout. The values that can be
passed in shown in the table below.

query This is the set of parameters that define the search. 

catalog Specifies the alias of the catalog to be used. The alias is mapped
via the settings file to either a catalog on disk or a catalog being
served by a Portfolio server.

template [OPTIONAL] Specifies the name of the Export HTML template to be used for
the response page. If this parameter is not passed in, a default
Export HTML template is used (a basic thumbnail view layout in 
a 4 x 4 grid).

sorton [OPTIONAL] Identifies an indexed, single-valued field on which the found set
should be sorted. If it is not specified, the order of the record set
is the order returned by the find.

ascending [OPTIONAL] Specifies the order in which the record set is sorted. A value of 0
indicates ascending, a value of 1 indicates descending. If the
sorton parameter is not provided, this parameter is ignored. If the
sorton parameter is provided and this parameter is not, the 
default sort order is 0 (ascending).

offset [OPTIONAL] A positive integer indicating how many records have already been
displayed from the collection. If the parameter is not specified,
the display starts from the first record in the collection.

Parameter Description

Query Command
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Query Parameter

This parameter is a set of variables which define the search that
should be executed in Portfolio. Each clause of a query is defined
by three variables: Field, Operator, and Value. Each clause (after
the first) must be joined to the previous using a join variable
(either “and” or “or”).   

The acceptable values for each variable are shown in the table
below.

* You can use all of the operators supported by the Portfolio
client in PortWeb, however not all operators work with each
field. If your operator does not work with a selected field, the
search clause is skipped. If you're unsure whether an operator is
supported with a specific field, you can verify it using the
Portfolio client's find feature. Choose your fieldname in the
Portfolio client's find dialog, then use the operator pull-down to
see which operators are supported for that fieldname.

field Any indexed field in the specified database. If an unindexed
field is specified, the query will fail. 

op The following operators are allowed*:
• Matches / Does Not Match – Works with all fields except Date

fields
• Equals / Does Not Equal – Works only with Date fields
• Greater Than / Greater Than or Equal To – Works only with

Number fields
• Less Than / Less Than or Equal To – Works only with Number

fields
• Starts With / Does Not Start With – Works only with String fields

value Only works with Number fields.

join [OPTIONAL] Used only when the query has more than one clause, this can
have a value of either “and” or “or”.  If this parameter is not
specified, “and” will be used.

Variable Acceptable Values

Query Parameter
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A query is validated by the plug-in based on the following
criteria:

• All three variables must exist for each clause. 
• For every clause after the first one, a join variable must also

be supplied (with the value being either “and” or “or”).
• Each field variable and operator variable must meet the

rules set above.

If any of these validations fails for a particular clause, the clause
is skipped. If validation fails for all clauses in a query, the plug-in
returns the “No matching records found” page. If the validation
succeeds, the remaining parameters are evaluated.

A query can contain a maximum of ten clauses.

Example:

The following example shows a two clause query command.
(The comments are just for clarity). The various parameters can
be hidden or exposed, depending on the site’s needs. In this
example, the first clause’s value field is entered by the user, but
all other values are hidden.

<FORM ACTION="/scripts/PortWeb.dll?query" METHOD=POST >

<INPUT NAME="template" TYPE="HIDDEN" VALUE="Simple">

<INPUT NAME="catalog" TYPE="HIDDEN" VALUE="Sample">

<!-- This is the first clause, and prompts the user for a keyword -->

<INPUT NAME="field" TYPE="HIDDEN" VALUE="Keywords">

<INPUT NAME="op" TYPE="HIDDEN" VALUE="matches">

<INPUT NAME="value" TYPE="TEXT" VALUE="">

<!-- This is a second clause (with the required join) that is entirely hidden. -->

<INPUT NAME="join" TYPE="HIDDEN" VALUE="and">

<INPUT NAME="field" TYPE="HIDDEN" VALUE="Extension Win">

<INPUT NAME="op" TYPE="HIDDEN" VALUE="matches">

<INPUT NAME="value" TYPE="HIDDEN" VALUE="jpg">

<INPUT TYPE="Submit">

</FORM>
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Creating Response Templates

The response to a PortWeb command is formatted by a response
template stored in the Portfolio catalog. The response templates
are the same templates that are used by the Portfolio client in the
Export HTML dialog. Response templates are created in the
Portfolio 5.0 client by creating new Export HTML templates. 

The Default Template

The simplest response template is simply no template at all. If no
response template is specified in a PortWeb command, a default
response is generated. For example, the following request will use
the default template because no template parameter is specified.
(This is the same query as the first example in the Basic tutorial.)

Macintosh
http://yourserver/.PortWeb?quickfind=com&catalog=S
ample

Windows
http://yourserver/scripts/PortWeb.dll?quickfind=co
m&catalog=Sample

(Where “yourserver” is the IP address or domain name of your
web server.)

The response is a four by four grid of thumbnails with the
filename displayed beneath each thumbnail. For some purposes,
this default response may be sufficient.
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Creating a Simple Template

In most situations, a customized response template is necessary.
To create simple templates, you can customize your view in
Portfolio and then add a new Export HTML template. The tem-
plate HTML displayed in the Edit HTML dialog is an HTML
approximation of the gallery you have created. 

Example:

1. Open the Portfolio Sample Catalog in the Portfolio 5.0
client. (The Sample Catalog is available on the Extensis
CD or from Extensis’ web site:
http://www.extensis.com/)

2. Load the “Blue text” gallery from the Saved Galleries
button on the toolbar.

3. Choose File>Export>HTML.

4. From the Export HTML dialog, click the Add… button.

5. The Edit HTML dialog is displayed. In this will be the
code Portfolio generated that approximates the view in
Portfolio.

6. Enter a name for the template, such as “blue.”

7. Enter grid settings, such as four rows by one column. In
the case of Record view and List view, you typically
would want one column. 

8. Click Save.

9. Upon returning to the the Export HTML dialog, you’ll
see the template was added to the list of templates in the
catalog. Click Close to return to Portfolio.

To access this template via the web, it is simply a matter of sup-
plying the template name as a parameter. So, building on the pre-
vious example, we can expand it to:

Macintosh 
http://yourserver/.PortWeb?quickfind=com&catalog=S
ample&template=blue

Windows 
http://yourserver/scripts/PortWeb.dll?quickfind=co
m&catalog=Sample&template=blue

(Where “yourserver” is the IP address or domain name of your
web server.)
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Collections

Collections (also known as “shopping carts”) are a common
feature of many web sites, and allow users to keep track of a
particular set of items. This is particularly useful in the context of
an image database, in which a user may want to gather a set of
images from a number of different searches.

PortWeb has built-in support for collections. PortWeb creates a
shopping cart for any user who wants to track items (assuming the
page is designed to make use of shopping carts). PortWeb can
maintain a user’s shopping cart across multiple sessions, and can
maintain separate carts for each catalog a user visits.

Collection record sets are stored in a proprietary database file
named “PortWeb.wdb”. The Administrator has the ability to set
how long collections are kept in the database. Below are the
various commands. Note that the collection requests only work
correctly for users who allow their browsers to accept cookies
(see the end of this section). 

Note: Collections are stored separately for different catalogs. In
other words, items from one catalog cannot be added to the same
shopping cart as items from a different catalog.

Working with Collections

The common user experience with a collection in PortWeb is:
1. The user submits a search via the query command.
2. The user is returned a web page generated by the query request.
3. On the page is a button reading “Add to my shopping cart.”
4. Clicking this generates a Collection request to add one or more

records. If no collection currently exists for the current user in
the current catalog (based on the cookie received in the query),
a new collection record is created. 

5. The result of the Add command is a newly generated page
showing the current collection, and a cookie is placed on the
user’s system.

6. From this shopping cart page, the user can choose to remove
items from the cart. 

To add collection functionality to a site powered by PortWeb, you
can either use collection macros, or use the collection commands
directly. Normally it is easier to use the macros, as PortWeb will
generate much of the necessary HTML automatically. However,
there may be times when the flexibility provided by using the col-
lection commands is desired.
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Collection Templates

Collection templates are not really any different than  any other
response template. The primary difference is that they are
displaying results from a user’s collection set, instead of results
from a particular query. Often the same response templates can be
used for both a query and a collection. Of course, if you want to
provide the users the ability to manipulate the collection, you’ll
need to create collection templates that make use of the Add and
Remove commands.

For more information on collection-specific macros, refer to the
PortWeb Templates section (page 281).

Collections Tutorial

To see how collections work, you can look at the supplied tutorial
(page 251)and examine the Collections example. 
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Collection Commands

Add Command

The add command adds one or more records to the user’s
collection set. If no collection set for the user of the particular
catalog exists, then a new collection set is created and a cookie is
returned to the user. The parameters specified are:

catalog Specifies the alias of the catalog is to be used. The alias is
mapped via the settings file to either a catalog on disk or a 
catalog being served by a Portfolio server.

rid Specifies the record ID in the catalog. Record IDs are unique
within a catalog. This can be one record or a list of records
(e.g., É&rid=70&rid=75&rid=85&É).
Any invalid RIDs are ignored.

template [OPTIONAL] Specifies the alias of the template to be used. If this parameter is
not passed in, a default Export HTML template is used (a basic 
thumbnail view layout).

sorton [OPTIONAL] Identifies an indexed, single-valued field on which the found set
should be sorted. If it is not specified, the order of the record set
is the order returned by the Find.

ascending [OPTIONAL] Specifies the order in which the record set is sorted. A value of 0
indicates ascending, a value of 1 indicates descending. If the
sorton parameter is not provided, this parameter is ignored. If the
sorton parameter is provided and this parameter is not, the 
default sort order is 0 (ascending).

offset [OPTIONAL] A positive integer indicating how many records have already been
displayed from the collection.  If the parameter is not specified, 
the display should start from the first record in the collection.

Parameter Description

Add Command
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Remove Command

The remove command removes one or more records from the
user’s collection set. If no cookie exists, or if the ID in the user’s
cookie does not match any records in the collections database, or
if the IDs in the cookie do not match the catalog specified in the
request, then an error is returned to the user on the “No matching
records found” page. The parameters specified are:

catalog Specifies the alias of the catalog is to be used. The alias is
mapped via the settings file to either a catalog on disk or a 
catalog being served by a Portfolio server.

rid Specifies the record ID in the catalog. Record IDs are unique
within a catalog. This can be one record or a list of records
(e.g., …&rid=70&rid=75&rid=85&…).
Any invalid RIDs are ignored.

template [OPTIONAL] Specifies the alias of the template to be used. If this parameter is
not passed in, a default Export HTML template is used (a basic
thumbnail view layout).

sorton [OPTIONAL] Identifies an indexed, single-valued field on which the found set
should be sorted. If it is not specified, the order of the record set
is the order returned by the Find.

ascending [OPTIONAL] Specifies the order in which the record set is sorted. A value of 0
indicates ascending, a value of 1 indicates descending. If the
sorton parameter is not provided, this parameter is ignored. If the
sorton parameter is provided and this parameter is not, the 
default sort order is 0 (ascending).

offset [OPTIONAL] A positive integer indicating how many records have already been
displayed from the collection. If the parameter is not specified, 
the display should start from the first record in the collection.

Parameter Description

Remove Command
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Show Command

The show command displays the records in a user’s collection
set. The parameters are:

Cookies

Whenever a collection request (add, show, remove) is
successful, a cookie containing the collection’s id number is sent
from the web server to the client’s browser. If the cookie is
accepted, it is stored on the user’s machine, and sent back to
PortWeb for every subsequent request. 

Users can refuse individual cookies, or set their browsers to
refuse all cookies. If cookies are refused, every add request will
create a new, one-item collection in PortWeb’s collection data-
base. In this case, the results of all collection requests (add,
show, and remove) will act as if the request had been applied to
an empty cart. 

Cookies set by PortWeb have an expiration date that matches the
plug-in’s collection expiration setting. 

catalog Specifies the alias of the catalog is to be used. The alias is
mapped via the settings file to either a catalog on disk or a 
catalog being served by a Portfolio server.

rid Specifies the record ID in the catalog. Record IDs are unique
within a catalog. This can be one record or a list of records
(e.g., É&rid=70&rid=75&rid=85&É).
Any invalid rids are ignored.

template [OPTIONAL] Specifies the alias of the template to be used. If this parameter is
not passed in, a default Export HTML template is used (a basic
thumbnail view layout).

sorton [OPTIONAL] Identifies an indexed, single-valued field on which the found set
should be sorted. If it is not specified, the order of the record set
is the order returned by the Find.

ascending [OPTIONAL] Specifies the order in which the record set is sorted. A value of 0
indicates ascending, a value of 1 indicates descending. If the
sorton parameter is not provided, this parameter is ignored. If the
sorton parameter is provided and this parameter is not, the 
default sort order is 0 (ascending).

offset [OPTIONAL] A positive integer indicating how many records have already been
displayed from the collection. If the parameter is not specified, 
the display should start from the first record in the collection.

Parameter Description

Show Command
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Portfolio SQL Connect (sold separately) works in conjunction
with Portfolio Server software and the Portfolio client application
to allow you to store data in existing corporate SQL databases,
such as Microsoft SQL Server and Oracle, and to access those
records from Portfolio as if they were served Portfolio catalogs.

Once the SQL database is set up, and Portfolio SQL Connect and
Portfolio Server are running, accessing and administering the
catalogs is the same as if the catalogs were created and stored
directly on a Portfolio Server.

System Requirements

SQL database, running on any Server:

•  Oracle 8i
•  Microsoft SQL Server 6.5 or Microsoft SQL Server 7.0

Windows NT, required for running the Portfolio Server and
connecting with the SQL Server:

•  Pentium PC (233 MHz or faster recommended)
•  Microsoft Windows NT 4.0 or higher (Server or Workstation)
•  32MB RAM (64MB RAM or more recommended)
•  TCP/IP Services installed 
•  ODBC drivers appropriate for connecting to the SQL Server
•  Oracle only: a System DNS that points to the Oracle Server

Server hardware requirements are based on performance. The
Server will function on any WinNT 4.0 system, but performance
will probably be unacceptable if used with any system below the
listed requirements. In addition, the Portfolio Server software will
normally benefit a great deal from a faster processor, more physi-
cal memory, multiple processors, faster network connections, and
faster hard drives (such as Ultrawide SCSI drives).

Note: Extensis does not provide Technical Support for setting up
an SQL database, configuring TCP/IP Services, setting up DNS
services, configuring a firewall, or other networking issues. For
assistance with these issues, please consult your System
Administrator or the product vendor’s technical support.

SQL Connect Administration
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Tip

This section will help you set up
an SQL database for serving as a
Portfolio catalog, and set up the
Portfolio Server to serve this
catalog. For detailed  information
on administering the Portfolio
Server, see page 221.

Note

This section applies to Portfolio
Network and Portfolio Server
Editions only.
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Getting Started with SQL

Before you can access catalogs through Portfolio, you must verify
that you have the correct ODBC drivers installed on the machine
that will be running Portfolio Server. Then you’ll need to set up
the SQL database. When that is done you can install both
Portfolio SQL Connect and Portfolio Server software. There is no
direct interface in either of these Portfolio products. SQL Connect
requires no user interface, and the Portfolio Server is accessed
and administered remotely using standard Portfolio application
software.

Set up the SQL Server

1. On the SQL database computer, create a new SQL
database.

Refer to the user documentation provided with the SQL
application for guidance. 

SQL Server 6.5:You must specify a maximum size for
your database. As a general rule, estimate 15K/record for
small (112x112) thumbnails and 30K/record for large
(256x256) thumbnails. Since it is difficult to expand a
database after it is created, it may be useful to leave room
for unexpected growth.

2. Create an administrative user for the database.

SQL Server 6.5 and 7.0:A user with administrative rights
must be created for this database. This can either be the
standard “sa” account, or another user with database owner
(dbo) rights. Make sure the “master” database is the default
database for the dbo you’ve created.

SQL Server 6.5 and 7.0:Portfolio Server will create one
connection per user per database. Increase the maximum
number of concurrent connections allowed by the system,
if necessary. For example, if you are serving two Portfolio
SQL catalogs from one SQL server, and each database has
50 users connected (even if they are the same set of users
in each case) you’ll need at least 100 concurrent
connections to the SQL server.

Oracle 8i: The administrative user that you create must
have the DBA role assigned to it.
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Install the Correct ODBC Drivers

SQL Server 6.5 and 7.0: Install the ODBC and SQL
Server drivers according to the instructions supplied with
the Microsoft SQL Server.

Oracle 8i: Install the Oracle Client software (including
ODBC and Oracle driver options). In the ODBC Control
Panel, create a System DSN with the user name you
created in step 2. IMPORTANT! Make sure the “Force
Retrieval of Long Columns” option is checked (enabled).

When the ODBC driver has been verified (and the DSN created if
this is an Oracle database) you can proceed with setting up
Portfolio SQL Connect and Portfolio Server, page 270.

Oracle Only: Create a DSN

To create a DSN:

a) Open the ODBC (32 bit) Control Panel (Start > Settings
> Control Panel > ODBC (32 bit). 

b) In the “ODBC Data Source Administrator” dialog,
select the “System DSN” tab. 

c) Click “Add.”
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d) In the “Create New Data Source” dialog, select the
Oracle ODBC Driver.

e) Click “Finish.”

The Oracle ODBC Driver Setup dialog will be displayed.

f) Enter the following information:

Data Source Name: The name of the
DSN you are adding.

Service Name: The name of the Oracle
instance, usually in the format “database-
name.domain”. Check with the Oracle
Database Administrator for the correct
name.

UserID: A valid user ID for the Oracle
database. This person must have database
ownership rights.

Force Retrieval of Long Columns: Must
be enabled.

All other fields: For the remaining fields,
accept the default settings.

The completed form should look
something like the screen shot shown.

g) Click “OK” to accept the changes and add the DSN.



Tip

Before you can perform any
Portfolio SQL Administration
operations, the SQL database
must be set up, Portfolio SQL
Connect and Portfolio Server must
running on the server machine,
and the Portfolio 5.0 application
must be running on the machine
from which you wish to access the
Server. See page 272.

Installing Portfolio SQL Connect

Installing Portfolio SQL Connect is quick and easy. Simply
launch the installer and allow it to guide you.

SQL Connect has no interface itself; access to Portfolio Server is
handled through standard Portfolio 5.0 application software 

To access a Portfolio SQL Server: Open the Portfolio 5.0
application. From the File menu choose “Administer Servers...”
From the Server Administration dialog you can add and
administer one or more SQL Servers (see page 272).

Serve SQL Database Dialog

Allows you to add, remove, and edit
(change name, IP address, password,
etc.) of SQL Servers, and to serve SQL
databases as Portfolio Catalogs. 

To open the Serve SQL Database
Dialog (A), choose File > Administer
Servers > [select Portfolio Server] >
Administer > Serve SQL.

A Serve SQL Database: Allows you to
add, remove, or change set up for
the selected Portfolio Server, and to
open the Server Administration for it.

B Done: Closes the dialog.

C Serve SQL command: Select the
SQL database that you want to serve
as a Portfolio catalog, then click this
button. You will be asked to specify
whether this catalog is to be opened
automatically when the Portfolio
Server is launched. Then you will
need to log on to the database as the
database owner. The database will
automatically be opened in
Administrator mode. To allow other
users to access the catalog, close the
catalog or change access level to
Publisher, Editor, or Reader.

D Add Server: Allows you to add a new
SQL Server to the list.

E Remove Server: Allows you to
remove the selected SQL Server.

F Edit Server: Allows you to change
parameters of the SQL Server (see
(D)).

A
B

C

D

E

F
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Serving an SQL Database as a Portfolio Catalog

When the Portfolio Server that will be used to serve the SQL
database has been added to the list of servers (page 225), you can
proceed to serve the database as a Portfolio Catalog. 

To serve an SQL database (catalog):

1. From the File menu in the Portfolio 5.0 application,
choose “Administer Servers.”

The Administer Servers dialog is displayed.

Note: If no server appears on the list, you will need to add
one before it can be administered. See page 225.

2. From the list of Portfolio Servers, select the Server that
you will be using to serve the SQL catalog, then click
“Administer...”

The first time you
access a Portfolio
Server as the
Administrator, you
will be prompted to
serialize the Server
(see page 232). At
this time you
should also enter
the SQL Connect
Serial Code (see
page 275).

You will be asked to enter the Server Administrator
password. This is the password to the Portfolio Server.

3. Enter the Administrator password for the Portfolio
Server, then click “OK.”

The first time a
Portfolio Server is
accessed by the
Administrator, the
password will be
blank. You can enter

a password, or just click “OK” and set the password later.

Important

You will need to enter the SQL
Connect Serial Code before you can
access the SQL catalog. See pages
275–276.

Important

While you can do so, in network
environments the Server
Administrator password should
never be left blank.
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The Server Administration dialog for the selected Portfolio
Server will be displayed. Any catalogs already being
served will be listed, including any active users.  

If if no catalogs are being served on this Portfolio Server
(which is typically the case the first time you set up an
SQL Server), the list will be empty.

You will now set up the SQL Server.

4. Click the “Serve SQL” button.

The Serve SQL Database dialog will be displayed.

If if no SQL Servers have been set up (such as the first
time you set up an SQL Server), the list will be empty.

272



5. Click “Add Server.”

6. Select the appropriate ODBC driver from the pop-up
menu, then fill in the rest of the fields. 

You will need to enter a name (this should be a different
name than the name you gave the Portfolio Server) and the
IP address of the SQL or Oracle Server.

You will also need to enter a User Name and Password for
the SQL Server. This can be the same name and password
that you used for SQL Database administration in step 2 on
page 267, but you can use a different name and password
for SQL Server administration if you prefer.

7. When you have finished with SQL Server set up, click
“OK.”

The SQL Server name, and any SQL Databases (catalogs)
that you set up on that SQL Server will be displayed on the
list. Now you will serve the SQL catalog.
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8. Select the SQL database (catalog) that you wish to
serve, then click “Serve SQL.”

9. You will be asked if you want to always serve this
catalog when the Portfolio Server is started up.

This allows you to have the SQL database served
automatically each time the Portfolio Server is launched. 

10. Next you will be prompted to enter the User Name
and Password that you created as the SQL database
administrator.

This must be the same user name and password that you
entered as the database owner (dbo).  

11. Click “OK.”

The catalog will be opened in Administrator mode. When
the catalog is in Administrator mode, other users are locked
out. To allow users to access the catalog, either close the
catalog or change to a lower access level (page 194).

12. You can now administer the catalog just as you would
any other Portfolio catalog. 
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Serialization

Portfolio SQL Connect is activated with a single SQL Serial
Code, and each Portfolio Server is activated with a single
Portfolio Server Serial Code.

To activate Portfolio SQL Connect:After the Portfolio Server is
set up, enter the SQL Serial Code from the Portfolio Server
Administration dialog (File > Administer Servers > [select server]
> Administer > Serialize). See page 276.

Note: The first time you attempt to administer a Portfolio Server
you will be prompted to enter the Server Serial Code. 

Adding Users

Multi-user serial numbers (licenses) allow users to connect to the
Portfolio Server, up to the limit of users for that serial number.
The multi-user serial number is entered at each workstation when
the Portfolio 5.0 application (client) is installed. The Portfolio
Server tracks how many connections are open at one time, and
limits access to the catalog to the maximum number of connections
for that serial number. To add additional connections, contact
Extensis Customer Service to purchase additional multi-user
serial numbers.
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To add an SQL Connect Serial Code:

1. Open the Server Administration dialog for the Portfolio
Server (File > Administer Servers > [select server] >
Administer).

2. Click “Serialize...”

The Serial Codes dialog is displayed.

3. Click “Add...”

The Add Serial Code dialog is displayed.

4. Enter the SQL Connect Serial Code, then click “OK.”

When you click “OK” you will be returned to the Serial
Codes dialog. The newly entered code will be listed.

5. Click “Done” to return to the Server Administration
dialog.

To remove an SQL Connect Serial Code:

1. Open the Server Administration dialog for the Portfolio
Server (File > Administer Servers > [select server] >
Administer).

2. Click “Serialize...”

3. Select the Serial Code that you wish to remove.

4. Click “Delete...”

5. Click “Done” to return to the Server Administration
dialog.



Export HTML Templates

The three HTML data tabs in the Edit HTML dialog represent the
three portions of an HTML document (Header, Item, Footer). The
Header is the set of tags at the top of the file, the Item is the set of
tags written once for each record being written into a page, and
the Footer is the set of tags written at the end of the file.

The following rules apply to each block:

Header:

1. The header must contain the <HTML> tag and the <BODY> tag.
2. Because the grid layout is generated as a table, the Header

must end with a <TABLE> tag. 
3. See the “Export HTML Macros” section (page 279) for

acceptable macros within the Header.

Templates and Macros

Web Page Layout

Header tab

Item tab

Footer tab
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Item:

1. The item tab should contain all of the formatting for a particu-
lar table cell, including the opening <TD> tag and the closing
</TD> tag.

2. Portfolio will generate the row tags (<TR> and </TR>) on its
own, based upon the grid dimensions. Do not include these tags
in any of the cells (unless you are adding your own rows at the
top or bottom of the table).

3. The key to properly configuring the Item tab is in using
macros. Please refer to other parts of this section for informa-
tion on how to use macros.

Footer:

1. The Footer must start by closing out the table with a
</TABLE> tag.

2. The Footer should close out with </BODY> and </HTML>
tags.

3. See the “Export HTML Macros” section (page 279) for
acceptable macros within the Footer.
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Export HTML Macros:

Portfolio uses a macro language in the HTML Templates to allow
for substitution of variable data at the time the HTML files are
actually generated. All macros start and end with a % sign, so the
proper use would be %macro%. To display a “%” sign in the actual
HTML, use two consecutive % signs in the template (i.e. “%%” in
the template produces one “%” in the generated output). The
macros are case-insensitive.

The following tables list the supported macros within the different
blocks:

Technical Notes on Exporting HTML

1. Using the %fieldname%@x (page 280)makes use of two
different form controls (the drop-down menu and the scrolling
list box). Because of this, the page must contain a <FORM> tag
for these tags to be interpreted properly. 

The <FORM> tag can be either in the Item block or in the Header.
If you plan to have a separate set of form controls on the page,
put the <FORM> tag towards the beginning of the item block
(usually just after the <TD> tag) and the </FORM> tag towards
the end (usually just before the </TD> tag). This will prevent the
controls from accidentally causing data to be submitted via your
Submit control.

%prev% Link to previous page. This will be the name of the previous file generated in the series
of files. If this is the first file in the series, the name of the current file is substituted.

Example: <A HREF="%prev%">Previous Page</A>

Results: A hyperlink ("Previous Page") is displayed. When clicked, it
takes the user to the previous page in the generated series.

%next% Link to next page. This will be the name of the next file generated in the series of files. If
this is the last file in the series, the name of the current file is substituted.

Example: <A HREF="%next%">Next Page</A>

Results: A hyperlink ("Next Page") is displayed. When clicked, it takes 
the user to the next page in the generated series.

%page% Substitutes a number indicating which page in the series is being generated.

Example: <TITLE>Portfolio Search - %page%</TITLE>

Results: The text "Portfolio Search – 1" is displayed in the title bar of the browser win-
dow. (Assuming this is the first page in the series and assuming this tag is placed in
the header prior to a <BODY> tag.)

All Blocks



2. To display a large text box for a multi-line field, wrap the field
in a TEXTAREA tag.

Example:<TEXTAREA COLS=50 ROWS = 3 WRAP ="SOFT"
NAME=ÓDescriptionÓ>%Description%</TEXTAREA>

Results: This will cause a scrollable box 3 rows by 50
characters to be drawn with the contents of the record’s
Description field displayed. Note that this is also a FORM
control, so the previous note regarding FORM tags applies here
as well.

3. As with any HTML code, results will vary based on what make
and version of browser the viewer is using. It is recommended
that you test the generated results with any browsers with which
you anticipate your visitors might access the pages.
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%thumbnail% Substitutes a relative path to the thumbnail file for the current record (located in the
Images subfolder). This is most commonly used to display the thumbnail on the page.

Example: <IMG SRC="%thumbnail%">

Results: Thumbnail is displayed on the web page.

%fieldname% Substitutes text data from the named field in the current record. For multi-valued fields,
the text will be displayed as comma-delimited values (the same way it is displayed in
Thumbnail view).

Example: <B>%filename%</B>

Results: "image001.jpg" is displayed in bold. (Assuming the record’s filename is 
"image001.jpg".)

%fieldname^x% Substitutes the value x from a multi-valued in the current record. If there are less than x
values in the field, an empty string is substituted. x can only be a value between 1 and 9.
The primary use of this field is for URLs.

Example: <A HREF=Ó%myurl%^2Ó>%myurl%^1</A>

Results: A hyperlink is generated in which the source is the URL value of the field (i.e.
the second value in MYURL), and the text displayed on screen is the title value (i.e 
the first value in MYURL.)

%fieldname%@x Substitutes text data from from the named field in the current record. However, the data
in the field will be displayed as either a drop-down list or a scrolling list box. This macro
is intended primarily for multi-valued fields. Substituting a value of 0 for x results in a
drop-down list being generated. Substituting a value of 1 through 9 for x results in a
scrolling list box of x lines being generated.

Example: %keywords%@0

Results: The keyword list for the record is displayed as a drop-down list, with the first
keyword displayed.

Example: %keywords%@5

Results: The keyword list for the record is displayed as a scrolling list box that is 
5 rows in height.

Item Block Only

Tip

For more information on the
specifics of creating pages for
the Web and coding in HTML,
consult any of the excellent
tutorials and reference guides
available on the Internet, or
check your local bookstore or
library for additional information.



PortWeb Templates

Exported HTML templates define the HTML that is generated by
PortWeb in response to a request. They can contain virtually any
HTML code of which you can conceive. 

PortWeb does not analyze the HTML you enter, other than to
verify that you have used legitimate macro names. Therefore, any
HTML you can create can be used, including JavaScript,
DHTML, XML, etc. 

There are three key aspects to an Export HTML template that are
unique to PortWeb: Template Blocks, Template Macros, and
Macro Blocks. 

Template Blocks

PortWeb’s HTML templates are made up of three blocks. You can
define HTML for the Header, Item, and Footer. The Header
section is placed at the beginning of each generated page, the item
section is inserted into each table cell, and the footer is placed at
the end of each generated page. In Portfolio’s Edit Template
dialog, you can either type the HTML directly into each block or
paste it in using Paste from the Edit menu. 

The following rules apply to each block in a PortWeb template:

Header:
1. The header must contain the <HTML> tag and the <BODY> tag.
2. Because the grid layout is generated as a table, the Header must

end with a <TABLE> tag.

Footer:
1. The Footer must start by closing out the table with a </TABLE>

tag.
2. The Footer should close out with </BODY> and </HTML> tags.

Item:
1. The item block should contain all of the formatting for a

particular table cell, including the opening <TD> tag and the
closing </TD> tag.

2. PortWeb will generate the row tags (<TR> and </TR>) on its
own, based upon the grid dimensions. Do not include these tags
in any of the cells (unless you are adding your own rows at the
top or bottom of the table).
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Template Macros

Portfolio uses a macro language in the HTML Templates to allow
substitution of variable data at the time the HTML files are
actually generated. All macros start and end with a % sign, so the
proper use would be %macro%. To display a “%” sign in the actual
HTML, use two consecutive % signs in the template (i.e. “%%” in
the template produces one “%” in the generated output). Macros
are case-insensitive.

The complete list of acceptable macros is shown in the table below.

%fieldname% Any field available to the user can be inserted into the item block.
At the time of export, the value of the field for the particular record
being processed is substituted for the macro.

%thumbnail% Substitutes a thumbnail request. Note that this is different
functionality than the existing Export HTML mechanism (which
was putting a path to disk).

%RID% Inserts the Record ID for the particular record. The Record ID is
unique in the catalog and is used by commands such as
Thumbnail, Add, and Remove to reference specific records in 
the catalog.

%prev% Substitutes a relative link to the previous HTML file generated in
the series. If the file being generated is the first file, an empty
string is substituted.

%next% Substitutes a relative link to the next HTML file to be generated in
the series. If the file being generated is the last file, an empty 
string is substituted.

%pagelist% Generates HTML for a set of page number links
(i.e. 1 2 3 4 5 )

%page% Inserts the number of the current page into the HTML.

%totalpages% Inserts the count of the total number of pages that could be 
generated, given the grid size and the count of the found 
record set.

%totalitems% Inserts the count of the total number of found records for the 
submitted query.

%collectionadd% Generates the HTML for a Collection Add request.

%collectionremove% Generates the HTML for a Collection Remove request.

%Ccollectionshow% Generates the HTML for a Collection Show request.

Macro Name Description

PortWeb HTML Template Macros
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Special Macros

A few sets of macros behave differently, depending on whether
the Portfolio client or PortWeb is generating the results.

Page Macros

[%prev%, %next%, and %pagelist%]

The HTML generated by the Portfolio client for %Prev%,
%Next%, and %PageList% macros generate links to other HTML
pages on disk. When these macros are handled by PortWeb, the
generated HTML is instead new quickfind or query commands
with the appropriate offset parameter.

For example, a template that generates two rows by four columns
will use the following macro:

to generate this HTML:

The catalog name, quickfind value, template name, and offset are
all automatically determined based on the original request. When
the user clicks on the link, a new quickfind command is submitted
to PortWeb that instructs PortWeb to start generating results with
the ninth item. This powerful feature means PortWeb only
generates results for one page at a time, meaning response times
are kept to a minimum.

While you could conceivably create these links manually,
Portfolio automates all of this for you.

<A HREF = "%Next%">

<A HREF=".PortWeb?quickfind=test&catalog=Sample&template=Simple&offset=8">
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Thumbnail Macro

[%thumbnail%]

The %thumbnail% macro, when handled by PortWeb, generates
a Thumbnail command (described on page 285) and fills in the
appropriate parameters.

For example, a template that contains the following macro:

will generate the following HTML.

The Record ID specified for the catalog and the catalog name are
automatically determined based on the original request.

<IMG SRC="%thumbnail%">

<IMG SRC="PortWeb.dll?thumbnail=20&catalog=WebTest">
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Thumbnail Command

The thumbnail request is used to request a JPEG data stream of a
particular thumbnail. This allows PortWeb to stream thumbnail
data from a particular record in a catalog back to the web browser
without ever having to write the data to disk first. Typically, these
requests will be embedded in the HTML results from the query
request. This will cause the browser to submit these requests back
to PortWeb, allowing it to return each thumbnail as an individual
JPEG stream. 

The thumbnail command should always be part of an image link:

The two parameters that must be supplied are shown below.

Usage

There are two Export HTML macros you can use to supply the
record id:%thumbnail% and %rid%. The %thumbnail% macro
provides the entire path for the image’s SRC parameter, while the
%RID% supplies only the record’s id. Examples:

Normally it is easier to use the %thumbnail% macro, since it
automatically encodes the RID and catalog name, but there may
be times when you want to use the additional flexibility of manu-
ally establishing the other parameters.

<IMG SRC="PortWeb.dll?thumbnail=%rid%&catalog=Sample">

<IMG SRC="%thumbnail%">

<IMG SRC="PortWeb.dll?thumbnail=80&catalog=WebTest">

thumbnail Specifies the record’s unique ID in the catalog. This parameter 
must appear first when doing a GET request. 

catalog Specifies the alias of the catalog is to be used. The alias is
mapped via the settings file to either a catalog on disk or a 
catalog being served by a Portfolio server.

Parameter Description

Thumbnail Command
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Collection Macros

[%CollectionAdd%, %CollectionRemove%, and
%CollectionShow%]

These commands have no purpose when using Export HTML
with the Portfolio client, as they are dynamic commands that are
built so that PortWeb can remember users’ selections. For more
information on using these commands with PortWeb, refer to
“Collections” on page 261.

Macro Blocks

Export HTML allows for markers to delineate the beginning and
end of “macro blocks.” Macro blocks define the beginning and
end of a section of HTML that surrounds a Portfolio macro. If the
macro evaluates to an empty value, then none of the HTML text
within the macro block is generated. Macro blocks are defined
using HTML comment tags in the following structure:

where the first comment opens the block and the second comment
closes the block. As PortWeb processes the template, each time it
encounters an open comment, it evaluates the macro defined
within. If the macro has a value of nil (for example, if the field is
empty), PortWeb skips the HTML code until the corresponding
close comment is found (or the end of the section is reached).

The most common use for the macro blocks is the “Previous” and
“Next” macros, so that additional information does not get gener-
ated. Take the following example:

When PortWeb processes this section for page one of a search, if
it were on the first page, the %prev% macro would evaluate to
“nothing.” Therefore, PortWeb would not generate any text until
the close comment is encountered.

<!--Port4-%prev%--> 

<A HREF="%prev%">Previous Page</A>

<!--/Port4-%prev%-->

<!--Port4-%macro%--> and <!--/Port4-%macro%-->
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Another example would be to add a field name in front of a field
macro, but not display the field name if there was no value for the
field:

A more elaborate possibility would use the macro of one field as
a logic flag for determining whether to display a completely dif-
ferent piece of information:

The preceding example would insert a hyperlink to the source file,
but only if there was a value in the field “HasSource.”

Note that it is possible to nest macro blocks, but it may result in
unanticipated results if the blocks are not properly nested or if the
blocks are not properly terminated with a close comment, since
PortWeb simply stops generating text until it encounters the
appropriate close block or the end of the section. 

Special Macro Blocks

Several macro blocks are set to evaluate to empty in particular
situations:
• %prev% will evaluate to empty if the page being generated is

the first page in a record set. This is useful for omitting a
“Previous” link from the first page of a set.

• %next% will evaluate to empty if the page being generated is
the last page in a record set. This is useful for omitting a “Next”
link from the last page of a set.

• %collectionadd%, %collectionremove%, and %collec-
tionshow% will evaluate to empty if the page is being generat-
ed by the Portfolio 5.0 client. Since these commands only work
with PortWeb, this can allow you to use the same templates
with both the Portfolio client and PortWeb.

• %totalitems% will evaluate to empty if no items are returned
by a request. This is useful for generating HTML when there is
a found set and you want to hide text, formatting, or buttons
when no records are returned by a search.

<!--Port4-%filename%--> 

File Name: %filename% <BR>

<!--/Port4-%filename%-->

<!--Port4-%HasSource%--> 

<A HREF="%path%">%filename%</A>

<!--/Port4-%HasSource%-->

287



Working with Templates on Disk

The Portfolio 5.0 client has the capability to save Portfolio’s
HTML Templates to disk. This is particularly useful if you are
working with larger amounts of HTML code, as you can then edit
the HTML in an HTML-savvy text editor. In addition, it makes it
much easier to move templates between catalogs or share tem-
plates with other users. Note that Portfolio’s custom formatting
makes it difficult to work with these templates in visual page edi-
tors, such as Macromedia Dreamweaver or Adobe PageMill.

Template File Structure

When templates are written to files on disk, Portfolio inserts
specific comment tags to define the beginning and end of the
three template blocks. The tags are:

Header Start <!ÑPort4-Header-->
End <!Ñ/Port4-Header-->

Item Start <!ÑPort4-Item-->
End <!Ñ/Port4-Item-->

Footer Start <!ÑPort4-Footer-->

End <!Ñ/Port4-Footer-->

In between each set of tags is the contents of each block. Other
than these block tags, the HTML is identical to the HTML dis-
played in the Edit HTML dialog. 

When the template is imported, Portfolio looks for the same tag
pairs to determine into which blocks to place the HTML code.
The tags themselves are stripped.

Exporting Templates

To export a template, simply click the Export… button in the Edit
HTML dialog. You will be prompted to name the file. Once it is
exported, you can open the file in any text editor.
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Importing Templates

To import a template, simply click the Import… button in the Edit
HTML dialog. You will be prompted to locate a file to import.
Once you select a file, Portfolio scans it for the block tags and
imports the information into the appropriate fields. If the appro-
priate start and end tags are not found, Portfolio will not import
any of the data. All three sections do not need to be present in the
file; if a section is missing, the block in the Edit HTML dialog
will be untouched.

Note: Portfolio uses the "%" sign to denote special macros, and
will not handle "%" symbols that may be part of your HTML (such
as "width=100%"). When importing HTML generated by other
applications, convert each "%" sign in the HTML source file to
two consecutive "%" signs in the template (i.e. "width=100%" in
the source file should be changed to "width=100%%" in the
template).
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Using Collection Macros

The three collection macros are %collectionadd%, %collectionre-
move%, and %collectionshow%. These macros behave differently
depending on whether they are placed in the Item block or in the
Header or Footer blocks. 

Collection Macros in the Item Block

When the macros are placed in the Item block, a partial GET
request is generated. For example, entering the %collection-
add% macro results in the following HTML being generated:

.PortWeb?add&rid=75&catalog=Sample

For this to be useful, the macro needs to be inserted into an
anchor of some type. For example, consider the following
template code:

The resulting generated HTML is:

This is then a valid link that, when clicked, would add Record ID
75 to the user’s collection and display the contents of the cart
using the “myCart template.” Note that the
“&template=myCart” parameter had to be specified separately,
as the system does not know what template you want to use to
display the cart. If the template parameter had been omitted, the
default 4x4 thumbnail response would have been used. For more
details on the parameters that are used by each collection com-
mand, refer to the section below, titled “Collection Commands.”

The %collectionremove% and %collectionshow% macros
behave in much the same way when placed in the Item block. The
%CollectionRemove% macro will automatically generate the rid
and catalog parameters; you must supply the template and other
optional parameters. The %collectionshow% macro will auto-
matically generate the catalog parameter; again, you must supply
the template and other optional parameters.

<A HREF = "%collectionadd%&template=myCart">Add to Cart</A>

<A HREF = ".PortWeb?add&rid=75&catalog=Sample&template=myCart">Add to Cart</A>
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Collection Macros in the Header and Footer Blocks

When the collection macros are placed in the Header or Footer
blocks, the generated HTML is different. This is because these
commands have different meaning in this context, because there
are no particular records that can be referenced from these loca-
tions.

Instead, PortWeb generates the start of an HTML Form block. For
example, placing the %collectionadd% macro in the header
results in the following HTML being generated:

While at first glance this may not appear particularly useful, this
is actually a very valuable feature. Because PortWeb is capable of
handling multiple items in an Add add or Remove remove com-
mand, you can set up the template so that multiple records can be
submitted in one form. For example, add the following line to the
item block.

And then place a Submit button and a close Form tag in the
footer.

The generated HTML will have a checkbox for each item. If you
check a set of these boxes and click the “Add Selected Items”
button, all of the checked records will be added to the shopping
cart and the results will be displayed using the “Sample”
template.

<INPUT TYPE="checkbox" NAME="rid" VALUE=%rid%>Add to Cart

<INPUT TYPE="submit" NAME="send" VALUE="Add Selected Items"> 

<INPUT TYPE=HIDDEN NAME=template VALUE="Sample">

</FORM>

<FORM ACTION=".PortWeb?add" METHOD=POST> 

<INPUT TYPE=HIDDEN NAME=catalog VALUE="Sample">
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Command Macintosh Hotkey Windows Hotkey
Create a new catalog Command+N Ctrl+N

Open an existing catalog Command+O Ctrl+O

Connect to Server Command+Option+O Ctrl+Shift+O

Print a Gallery Command+P Ctrl+P

Page Setup Command+Option+P Ctrl+Shift+P

Cut Gallery Items Command+X Ctrl+X

Copy Gallery Items Command+C Ctrl+C

Paste Gallery Items Command+V Ctrl+V

Undo (text entry only) Command+Z Ctrl+Z

Select all items in a catalog Command+A Ctrl+A

Save Gallery Command+S Ctrl+S

Save Gallery As... Command+Option+S Ctrl+Shift+S

Master Keywords Palette (Open/Close) Command+K Ctrl+K

Thumbnail view Command+T Ctrl+T

List view Command+L Ctrl+L

Record view Command+R Ctrl+R

Customize Gallery Command+D Ctrl+D

Sort by Other Command+Option+D Ctrl+Shift+D

Find specific items in a catalog Command+F Ctrl+F

Find all items in a catalog Command+' Ctrl+'

Replace Command+Option+R Ctrl+Shift+R

Add items to a catalog Command+E Ctrl+E

Update items in a catalog Command+U Ctrl+U

Cataloging Options Command+J Ctrl+J

Catalog Properties Command+Option+J Ctrl+Shift+J

Slideshow Command+; Ctrl+;

Preferences Command+Option+E Ctrl+Shift+E

Recover Command+Option+V Ctrl+Shift+V

Export Text File Command+Option+T Ctrl+Shift+T

Export HTML Command+Option+H Ctrl+Shift+H

Administration Command+H Ctrl+H

Change access level Command+Option+B Ctrl+Shift+B

Close a catalog Command+W Ctrl+W

Quit / Exit Command+Q Alt+F4

Appendix A: Keyboard Shortcuts
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Command Macintosh Hotkey Windows Hotkey
Item Properties Command+I Alt+Enter

Preview Original Command+B Ctrl+B

Edit Original Command+M Ctrl+M

Copy Original Command+Option+C Ctrl+Shift+C

Move Original Command+Option+Y Ctrl+Shift+Y

Delete Original Command+Option+X Ctrl+Shift+X

Find Original Command+Option+F Ctrl+Shift+F

Rename Original Command+Option+N Ctrl+Shift+N

Rotate Thumbnail 90° CW Command+] Ctrl+]

Rotate Thumbnail 90° CCW Command+[ Ctrl+[

New Gallery Command+G Ctrl+G

List Galleries Command+Option+G Ctrl+Shift+G

Online Help Help F1

Function Shortcut
Preview an item Double-click the item in any Gallery view

Double-click the item thumbnail in the “Item Properties” dialog

Search using keyword Double-click the keyword in List or Record view

Double-click the keyword in the “Item Properties” dialog box

Double-click the keyword in the “Catalog Properties” dialog box

Double-click the keyword in the Master Keywords Palette

Remove item from Gallery window Select the item and press Delete

Remove item from catalog Select the item and press Option+Delete (Macintosh)

Select the item and press Ctrl+Backspace (Windows)

Function Shortcut
Move between Gallery items Arrow keys

Scroll one screen at a time Page Up / Page Down

Go to Top of Gallery window Home (Macintosh) or Ctrl+Home (Windows)

Go to Bottom of Gallery window End (Macintosh) or Ctrl+End (Windows)

Go to First item in the Row Home (Windows Thumbnail view only)

Go to Last item in the Row End (Windows Thumbnail view only)
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Mac Windows Extract QuickTime Portfolio 5 Liberty
Format File Type Extension Thumbnail 4.0 Native Systems Inso
Adobe Acrobat PDF .pdf ü† ü

Adobe Illustrator 3.0 - 7.0 TEXT .ai ü ü

Adobe Illustrator 8.0 TEXT .ai ü ü

Adobe PageMaker 6.5 AB65 ü**
Adobe Photoshop 2.5 - 5.5 8BPS .psd ü† ü*
AIFF Sound file AIFF .aif ü

AutoCAD .dwg ü

AVI Video .avi ü

CorelDRAW 3.0 - 8.0 .cdr ü

CorelDRAW Presentation Exchange .cmx ü

Encapsulated Postscript EPSF .eps ü ü

FlashPix FPIX .fpx ü

Graphics Interchange Format (GIF) GIFf .gif ü

GIF Animated Graphics GIFf .gif ü

Joint Photo Experts Group (JPEG) JPEG .jpg ü ü

Kodak PhotoCD†† PCDI .pcd

Macintosh Picture PICT .pct ü ü

Macintosh Sound file sfil .snd ü

Macromedia Freehand 5.0 - 8.0 AGD2 ü**
Microsoft Powerpoint 2.0 - 8.0 SLD8 .ppt ü

MIDI Sound file MIDI .mid ü

MPEG Sound/Video MPEG .mpg ü

Multi-Ad Creator MuAd ü**
Portable Network Graphics PNGf .png ü

Postscript Interpretive TEXT .ps ü

QuarkXPress 3.3 - 4.0 XDOC .qxd ü†

QuickDraw 3D Metafile 3DMF .3dmf ü

QuickTime Movie MooV .mov ü

Tagged Image Format (TIFF) TIFF .tif ü ü

Truevision Targa TPIC .tga ü

Windows and OS/2 Bitmap BMPp .bmp, .dib ü ü

(Microsoft) Windows Metafile .wmf ü ü

WAVE Sound file .wav ü

* Translator does not support multi-layer files without Composite Layer/2.5 Compatibility turned on.
† Preview multiple pages

** Mac OS only
†† PDC Translator

Appendix B: File Types
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The following entries in the Mappings list are created automatical-
ly when a new catalog is created. To map these fields and tags to
Portfolio Custom Fields (or enter additional fields), see page 92.

Appendix C: Mappings

Type Field Code

TIFF Document Name 269
Image Description 270
Scanner Make 271
Scanner Model 272
Page Name 285
Creating Software 305
Date & Time 306
Artist 315
Host Computer 316
Ink Names 333
Target Printer 337
Copyright 33432

Photoshop URL 1035

IPTC News Wire 286
Object Name 517
Urgency 522
Category 527
Supplemental Category 532 (multiple)
Keywords 537 (multiple)
Instructions 552
Date Created 567
Time Created 572
Byline 592
Byline Title 597
City 602
State 607
Country Code 612
Country 613
Transmission Reference 615
Headline 617
Credit 622
Source 627
Copyright 628
Caption 632
Caption Writer 634
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B
Background Cataloging   126
Basics, of Portfolio   12
borders, adding to thumbnails   102-109   
“by Extension Win” command   57
“by Filename” command   57
“by FileType Mac” command   57
“by Other...” command   58

C
Catalog Access Levels list   193
Catalog Administration   192-220   
“Catalog Properties...” command   92
catalog properties

General tab   92
Statistics tab   92
viewing   92

Catalog startup options   213
“Cataloging Options...” command  130
Cataloging Options dialog box   130
cataloging options   

Add tab   134
adding file types   143
Exclude Strings tab   145
File Types listed   294
File Types tab   144
General tab   130
Mappings   139-143
Mappings tab   140, 141
Update tab   138

Cataloging Steps Summarized   11
catalogs

adding items to   118-120
administering   see“administration”
Catalogs palette   115
connecting to a server   24-26
converting    see“converting catalogs”
creating   13, 113-114
damaged catalogs, recovering   216   
default catalog, specifying   116   
exclusions   see“exclude”
exporting as text   184
.fdb extension   113
Gallery items, viewing   28-35   
getting started with   11
keywords in   16, 39, 28-33, 39-40, 148-155  
locating missing files in   125
maintaining   215-216  

3D files
previewing   81  

A
“Access...” command   194
access levels    15, 192-201

about    192
changing    194, 197
defined    192
exporting user list    201
Level-based    194, 197-198
listed    193
passwords     197, 199  
features supported in    193
listed    193   
User-based    194, 199-200

“Add Items...” command    119
Add options tab   134
adding   

by dragging    119, 171
catalogs to a Portfolio Server    228
Custom Fields    206-208
items to a catalog    118-120, 134-136 
keywords    148-155
multiple items   119
single items   119

“Administer Servers...” command   226
administration

Custom Fields tab   206-208
Keywording tab   202
of catalogs   192-220
of Portfolio Server    221-235
of SQL catalogs    266-275
Passwords tab   195
Previews tab    214
Startup tab   213  

Adobe Acrobat   
viewing multiple-page PDF documents   79

Adobe Illustrator   167
Adobe PageMaker   167
Adobe Photoshop   167
“Always on Top” command   35

icon, on Toolbar   35
AppleScript   177  see“Scripting”
assigning keywords  see“keywords”
Automations   126  see“Background Cataloging”
Autoplay Movies and Sounds preference   95 

Index
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Master Palettes   156-158   
Multiple Value Lists   211  
Number      161, 162, 206
Pre-defined Lists   210
restrictions    208
and searching   41
and sorting   57
String      161, 162, 206, 209
tab described   160
Text Block   161, 162, 206, 212
types   162, 206, 209-212
URL   161, 162, 206, 210 

custom lists  see also“Master Palettes”
accessing from Master Palettes   156-158
creating   156, 206-210
pre-defined lists   210

“Customize...” command   99
Customizing Gallery windows   17, 99-108

borders, adding to thumbnails   103-108
List view tab   101
options listed   100
Record view tab   101
Saved Options tab   102
thumnail size/border size table   106
Thumbnail view tab   101

D
damaged catalogs, recovering   216
Date/Time fields   161, 162, 209
Decimal fields   161, 162, 209
default

access level, setting   94-95
catalog, specifying   116   
find, setting    49  
gallery, specifying   70, 95

“Delete Original...” command   84  
deleting

items from a catalog   75
items from a Gallery   73
keywords   150
saved Galleries   69
source files   84

descriptions   16, 28-32, 82, 159
adding, in Record view   146
adding, to items   159
adding, to a Gallery view   82
defined   159
entering   159
extracting  159 

missing files, identifying   125
Modification Method option explained   312-138
multiuser   see“multiuser catalogs”
new, creating   113-114
on a network   24, 217
opening   23, 24
options   see“cataloging options”
palettes   36
properties   see“Item Properties”

see“Catalog Properties
records, viewing   see“Gallery”
records, searching  see“searching”
recovering   216
removing items from   75
searching  see“searching”
security   192-201
sharing   217    see aslo“Portfolio Server”
startup options   213
steps to cataloging summarized   11
thumbnails, regenerating   124
thumbnails, size   130, 131, 136
updating items in   121-124
viewing   13-15, 28-33

Catalogs palette   115
Categories palette   169
Confirm Delete from Catalog preference   94-95
“Connect to Servers...”command   24

icon, on Toolbar   35
connecting to an SQL Server   see“SQL Connect”
Contextual Menus   34   
converting catalogs

Cumulus   182
Fetch 1.2/1.5   21
Portfolio 3.0 and 4.0   21

“Copy Original...” command   84
copying

border for thumbnails   106
items between catalogs   74
items between Galleries   71  
source files   84

Custom Fields   
adding data to   160-162
adding, to a catalog   206-212   
Date/Time   161, 162, 209
Decimal   161, 162, 209 
defined   160
dialog boxes   162, 207
editing   160-162, 206-212
Field Type/Data Example table   161, 206
Fields tab   108
Integer      161, 162, 206, 209



F
.fdb extension   113
Fetch, converting catalogs from   21   
Field Values, importing   178-181
file descriptions   see“descriptions”
file types   

adding   143
excluding   143   
File Types tab   144
removing   143
supported   294

filenames   113   
filesharing   217   
“Find All” command   41
find  15, 41

all  41
catalog items, how to   41, 44, 50
Catalogs tab (Mac OS)   42
Criteria tab (Mac OS)   42
Default Find   49
Document Text   56
Editing Saved Finds   51
Find window   42, 43
Finds palette   50
icon, on Toolbar   35
indexed fields   47
keywords   39-40
Master Keywords   40
options   45, 46
palette   50
QuickFind   35, 44
replacing   163-165
Saving Finds   48
Search Criteria Options table   45, 46
Streamlining Searches   47
text   56
using keywords   39, 40
using the Master Keywords list   40
window   43, 44
window, opening   41

“Find...” command   41
icon, on Toolbar   35

finding   see“find” see also“searching”
Finds palette   50
Fit Preview Images to Window preference   94-95
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Digimarc watermarks   86-89, 134-135, 137-138
detecting   87, 134-135, 137-138
embedding   89
reading   88

Disable Link to Original option   213
Disk Previews option   214
Display Welcome Screen preference   95
dragging and dropping items   

between Catalogs   74
between Galleries   71
into other applications   59
into QuarkXPress   18, 59, 168
to add items to a catalog   119, 171
to Categories palette   171
to update cataloged items   122

E
“Edit Original...” command   83
Editing in place option   146-147

enabling   100, 101, 147
using   147

Editor access level 
features available in   193

electronic registration   8
Enhancements, in Portfolio 5.0   10   
exclude

by Name   143, 145
by Type   143
File Types   143-145      
File Types tab   145      

“Export...” command   178
“Export to HTML” command   185
“Export pnot Data” command   190
“Export to Text File” command   184
exporting   178, 184-191

catalogs   184
HTML   185-189, 277-280
keywords   204-205
Master Keywords   204-205
pnot data   190
to Text File   184   

Extensis, contacting   2, 8
Extensis Fetch, converting catalogs from   21
extracting

descriptions    159
Digimarc watermarks    86-88, 134-135, 137-138
keywords   148
thumbnails   135, 136, 138



I
Illustrator   167
Image Dimensions preference   94-95
images   see also“items”

preparing for cataloging   167
previewing   76-81

“Import” command   179 
importing   19, 179-181

Field Values   179
keywords   204-205
Master Keywords   204-205

Index Node Size preference   95
Installation   

Portfolio 5.0 client  8
Portfolio Server   222
PortWeb   236
SQL Connect   270

“Item Properties...” command   82
items

adding   118-220, 134-136
copying, between catalogs   74
copying, between Galleries   71
descriptions   159
displaying   see “Gallery”
drag and drop   see “Dragging and Dropping”
file types of   see “File Types”
finding  39-56    see also “searching”
previewing   see “previewing”
printing   96-98
properties, viewing and editing   82
removing from a catalog   75
removing from Gallery   73
sorting   57
source files   see “source files, working with”
updating   123, 130, 132, 137-138

J
Java   177

K
keyboard shortcuts   292-293
keywords   16, 39, 148-155

about   148
adding   148, 150, 152, 155
assigning   150, 152, 155
creating   150-154
creating Master Keywords list   202
defined   148
deleting   150
displaying, for items   149

G
Galleries palette   62
Gallery   see also “Customizing Gallery Views”

background color   99-100  
customizing   99-108
described   16, 28, 99
List view   31
“New Gallery...” command   60
New Gallery icon, on Toolbar   35   
Open at Startup   70
options   100
printing   96-98
Record view   32
renaming   69
removing items from   73
reordering items in   57 
saving   61-63
sorting   57
thumbnail borders, adding   103-108   
Thumbnail view   30
views   16, 30-32
windows   30-32, 99

Gallery Views   16, 28-33   see also “Gallery”
Gallery windows   see also “Gallery”

background color, adding   99, 100
customizing, how to   99-108
options   100

General Overview   13
Getting Started   11

H
hardware requirements   

Portfolio 5.0 client  8
Portfolio Server   222
PortWeb   236
SQL Connect   266

Help
accessing   35   
icon, on Toolbar   35

hotkeys   292-293
HTML   see also“exporting” and “PortWeb”

about the HTML template   188
and active Gallery   185
and PortWeb   236, 281
exporting records as   185-189
macros   277-291
technical notes about   188, 279-280
template, creating   188-189
using template to export   185-189
Web pages discussed  185
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Parsing Keyword Phrases   202, 205
described   202
renaming   203
search using   40

Master Palettes   156-158 
creating   156, 206-210
predefined list   210
using   157

Microsoft PowerPoint   
viewing multiple-page presentations   79

“Missing Files...” command   125
Modification Method   132-138

Add   132, 134-135
Add & Update  131, 132
Add Unconditionally   131, 132, 134   
Update   132, 137-138
Update Unconditionally  130, 131, 132-133    

“Move Original...” command   84
movie files

previewing   80
moving

items between catalogs   74
items from one Gallery to another   71
source files   83

multimedia files   80-81
multi-page documents, viewing   79
multiple catalogs

searching   53 
moving and copying items between   74 

mutiple Galleries   19, 61-64, 71-72
Galleries palette   62   
saving   61
moving and copying items between   71-72   

multiple users, networking   16, 24, 217, 220
see also“Master Keywords”

multiuser catalogs   
access levels   192-201
administration   192-220
Catalog Access Levels list   193
changing passwords in   194-201
networking discussed   217-218
Portfolio Server application   221
security levels   192-193
setting passwords for   194-201
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displaying, for catalog   150  
editing   151
entering   148, 150, 154
exporting   204-205   
extracting   148
importing   204-205
list of, in catalog   150    
Master   40, 148, 155, 202

see also“Master Keywords”
parsing phrases   202, 205   
removing   153 
replacing, using search parameters   163-164  
search using   39
viewing   28, 29, 39, 148, 149
where to view   148

L
Language preference   94-95
“List Galleries...” command   63
List view   31   see also “Gallery”

accessing   28-29, 35 
customizing   99-102

M
Mac OS requirements, Portfolio 5.0   7  
macros   277-291  
maintaining catalogs   215-216

recovering catalogs   216
removing items   75, 215

Mappings   139-142, 295
adding Tag ID codes   142   
Custom Fields and   139, 141
described   139
disable a Mapping   139
enable a Mapping   139
list   295
notes about   140
tab, Mac OS   140
tab, Windows   141  

Master Keywords   
adding, how to   203
assigning to items   155
creating, how to   202   
defined   155
deleting   203
exporting   204-205
finding items with   40, 155
importing   204-025
List, creating   202
palette   155



Path as Keywords option   130-131
Path as Category option   130-131
Photoshop

and Mappings   139   
including keywords in   167
including thumbnails in   167

Placeholder Records
creating   55
finding   90

playing
movies   80
sounds   81

pnot data, exporting   190
Portfolio Basics   12 
Portfolio Server   221-235  

accessing catalogs on   24-26, 235
adding a server   225
administering   223-235
client system requirements   7
closing   230   
connecting to   24
creating catalogs on   228
installing   222
logging off users   231
opening as Administrator   194, 226-227
password   232
port number   230
serialization   232
server system requirments   222
serving catalogs   229  
unserving catalogs   230

PortWeb   236-265
administration module, using   244
collections, working with   261-265
components for catalog mapping   246-248 
Installation   236
memory usage and   237 
Overview   238
plug-in communication methods   239-243
Required Knowledge   236 
Setup and Administration   244-250 
simple template, creating   260
System Requirements   236
tutorial   251-253 

predefined custom lists   156
Preferences   93-95

Setting   94-95
where stored   93 

Preparing images for cataloging   167

N
naming source files   219
networks see also“Portfolio Server”

connecting to served catalogs   24
filesharing   217
security   192-201

new features   10
“New...” command   113
“New Gallery...” command   60
Number fields    161, 162, 209

O
OLE automation   177
“Open Catalog on Startup...” command  116    
Open Find Dialog on Startup option   213
Open Gallery at Startup option   70
Open Gallery with Catalog preference   95
Open MKL Palette option  213    
opening

catalogs   13-15, 23, 24
Find window   41
Gallery windows   60, 62
palettes   36

OSA compliant scripting  116177
overview, of Portfolio   11, 12, 13-20   

P
PageMaker   167
palettes

Catalogs   115
Categories   169
docking   36
Finds   50
Galleries   62
Master   156
Master Keywords   155
opening   36
Sorting   57

parsing keyword phrases   202, 205
passwords

catalogs   194-201
changing   195-196
entering   194
length of   198
Passwords tab   195
removing   195-196
Server   232
setting   195-196
SQL   267, 274
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Preview windows   76-81
3D images   81
magnification in   77-78
movies   80
multi-page documents   79
pictures   77
printing from   98
QuickDraw 3D   81
selecting in   77
sounds   81
still images   77

previewing   see also“Preview windows”
3D images   81
described   77
images, how to   77  
movies   80
pictures   77
sounds   81

Previews, saving to disk option   214
“Print...” command   96-98
Printing

actual images, print using   98
source file from Preview window   96   
thumbnails in catalog  98
technical notes about  98

Prompt on Untitled Close preference   95
protected catalogs, about   23
Publisher level access   

features available in   193

Q
QuarkXPress   

attaching thumbnails in   168
dragging and dropping items   18, 59, 168
XTensions included on Extensis CD  18, 168    

QuickFind   44
displaying results   44
icon, on Toolbar   35
preference   95
using, how to   44

QuickFind Opens New Gallery preference   44-45
QuickTime

5.0, advantages and multimedia   76   
installer, where located   76      
exporting slideshows as   191      

R
Reader access   192-193

features available in  193
Record view   32   see also “Gallery”

accessing   28, 29, 32, 35 
customizing   99-102
editing fields directly in   xx146

“Recover...” command   216
recovering catalogs   216
Registration   8
removing items

from catalogs   75
from Gallery windows   73

reordering Gallery items   57   
“Replace...” command   163-166

see also“finding”
see also“searching”
items based on field values   163
multi-value fields checkbox   165
replace all in Gallery  166
using   17, 163-166

Run Slideshow on Startup option   213

S
Sample Catalog   12   
“Save Gallery...” command   61
Saved Find Gallery   64-69   
saved finds   

default find   49
deleting   52
duplicating   52
editing   51
Finds palette   50
how to   48
icon, on Toolbar   35
pop-up menu   35, 42
renaming   52
Saved Find Gallery   64-69   

saved Galleries   61-69
customizing   99-102
default   70
deleting   69
editing   50
Galleries palette   62
how to   61
icon, on Toolbar   35
listing   63
opening   62-63
renaming   69
standard versus Saved Find Gallery   65
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manual mode   111, 112
Run Slideshow on Startup option   213
showing   112
timed mode   111, 112

Software Requirements 
Portfolio 5.0 client  8
Portfolio Server   222
PortWeb   236
SQL Connect   266

sorting  57
Sorting and Reordering Gallery Items   57
Sorting palette   57
manually reordering   57

sound files, peviewing   81   
source files, working with   83-85

copying   84
deleting   84
editing   83
finding   85
locating   85   
managing   219
missing, locating   125
moving   84
naming   219
organizing   219
printing   98
renaming   85

Splash screen
customizing   213
enabling at startup   94-95

Startup Options
for catalogs   213
for application   94-95  

String fields
creating   206-208
described   209
editing   146-147, 160-162

supported file types   294   
System Requirements

Portfolio 5.0 client  8
Portfolio Server   222
PortWeb   236
SQL Connect   266

SQL Service   266-276
DSN, creating (Oracle)   268-269 
Installing   270
ODBC drivers and   268
password   267, 274
Serving an SQL Database   271 
setting up an SQL Server   267-269
System Requirements   266

saving
Galleries   61-69
Finds   48-52

Scripting
Macintosh   177
scripts menu in Portfolio catalogs   177
Windows   177 

searching   39-57
Default Find   49
displaying results   41-44
Editing Saved Finds   51
faster   47
Finds palette   50
keywords   39-40
Master Keywords   40
options   45-46
QuickFind   35, 44
replacing   163-166
Saving Finds   48
Streamlining Searches   47
using keywords   39
using the Master Keywords list   40  

security   see also“access levels”
levels   192-201
network protection   218

serial number   
Portfolio 5.0 client  8
Portfolio Server   232
SQL Connect   275

Server   see also“Portfolio Server”
accessing catalogs on   24-26
client system requirements   7
connecting to   24
installing   222
managing   223-235
server system requirments   222

Setting Preferences    93-95
sharing catalogs   217 
shortcuts, key commands   292-293
Show Options Dialog preference   94-95
Show Welcome Dialog preference   94-95
“Slideshow...” command   112
“Slideshow Options...” command   112
slideshows   18, 109-112

adding display field to   109
controls   111
creating   112
described   109
dialog box   110
exporting as QuickTime movies   191
keyboard shortcuts   109
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T
Tag Codes ID  see “Mappings”
Technical Support, contacting   8
template examples

for exporting HTML   185, 277 
for PortWeb   251, 281

Text Block custom field   206, 212
described   212
editing   146-147, 160-162

text file, export to   184
Thumbnail Quality   131  
Thumbnail view   30   see also “Gallery”

accessing   29, 30, 33 
customizing   99-108

thumbnails   
borders, adding   103-108
extracted vs generated   136
extracting   135, 136, 138
printing   96, 98
Quality   131
Size   130, 131, 136
regenerating   124  
specifying quality   131  
updating   124

Toolbar   28, 35
translators   294 

U
unserving catalogs   230   
“Update Items...” command   123
Update options tab   137-138
updating

by drag and drop    122
by “Update Items” comand   123
cataloged items   121-124
Modification Method   132-138
thumbnails   136
unconditionally   130, 131, 132-133
Update tab   137-138

URL Custom Field    38, 110, 140, 143

V
viewing

catalog items   28-35 
catalog properties   92
Gallery items   28-32
item properties   82
keywords   28-33, 39-40, 148-155

views
customizing   99-108

Visual Basic   177
Visual C++   177

W
watermarks   86-89   see also“Digimarc”
website addresses

Digimarc   89
Extensis   2
PortWeb   236
Technical Support   8

What is Portfolio   9
What’s New   10
Windows requirements   7

Z
zooming, in Preview window   77-78   
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