


Introduction

About PiXELS:3D

PiXELS:3D is an integrated suite of professional tools for creating
and animating 3D characters and visual effects. PiXELS:3D gives you
full control of every step in the production process:

• Easily build and edit organic models in real-time

• Create and apply textures and materials

• Position objects and lights within a scene

• Create realistic movements for all objects 

• Produce broadcast quality renderings of your animations

We thank you for choosing PiXELS:3D and look forward to providing
you with powerful and efficient solutions for all of your creative needs.
Should you require help, please contact our technical support desk at
the number below. Your first year of technical support is included with
the purchase of this software, extended contracts are available.

Technical Support: 8 am–5 pm Monday–Friday (pst)

(619) 672-2634

E-Mail: support@pixels.net

URL: www.pixels.net

System Requirements

• PowerPC based computer running MacOS 8.0 or later
• 16 MByte available RAM (Complex scenes may require

more memory)
• 30 MByte of hard disk space
• Color monitor capable of displaying at least 800 x 600

pixels:3d (A large monitor is a definite advantage, since it
helps distinguish details of the wireframe models for
precision work.)
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Legal Notice

The software described in this manual is furnished under license and
may only be used or copied in accordance with the terms of that license.

Installing PiXELS:3D

1. Insert the PiXELS:3D CD in your CD ROM drive.

2. Double click on the PiXELS:3D_2.1_Install icon and follow the
instructions.

3. There are optional files included on the PiXELS:3D CD. If you have
room on your hard drive, you should copy these files into your
PiXELS:3D folder.

• PiXELS:3D application program
• PiXELS:3D utility files
• Shaders and texture maps
• Sample PiXELS:3D models
• Optionally, a Read Me file for late-breaking information about

PiXELS:3D

To begin using PiXELS:3D:

1. If you see a Read Me file, double click on the icon to open it. It
describes last minute changes which may not be included in this guide.

2. Double click on the PiXELS:3D application icon inside the PiXELS:3D
folder.
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3. The first time you use PiXELS:3D, you will see a dialog box asking
for your name, your company name, and a Software Key. The Software
Key can be obtained by following the instructions shown in the dialog.
After obtaining your Software Key, type in the requested information,
and click to imbed it in your PiXELS:3D file. The User Name
and Company Name will appear on the splash screen each time you
launch PiXELS:3D.

4. If PiXELS:3D is installed on a computer that does not have the
proper system requirements (for example, insufficient memory or an
unsupported processor), the application cannot be opened. If this
happens, a dialog box will present an error message explaining the
problem.
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About this Manual

This manual explains everything you need to know to use PiXELS:3D. If
you are new to 3D, it is highly recommended that you read the chapter
entitled 3D Basics before beginning to learn the software.

In addition, we assume that you are familiar with the use of the mouse,
as well as the Macintosh interface, icons and pull down menus. Basic
skills common to all Macintosh applications like clicking, dragging,
scrolling and opening files are not explained within these pages, but are
covered in detail in the manuals that came with your computer.

The Overview section of this manual provides a summary of the
PiXELS:3D interface. Here you will learn the layout of the software and
the locations of the tools and controls that you will use. 

The Exercises and Tutorials sections contain a series of hands on
projects that are specifically designed to teach you how to use the
different tools, controls and features that make up PiXELS:3D. If you
want to get started quickly, this is the place for you.

The Reference section is broken into four chapters: Views, Menus,
Tools and Constraints. Each chapter contains a list of all tools and
features with step-by-step instructions for performing their related
functions.

The chapter on 3D Basics follows the Reference section. This chapter
discusses general 3D topics and their implementation within
PiXELS:3D. Whether you’re a first time user or just want to brush up on
your knowledge of 3D, you can find the facts here.

A Glossary at the back of the manual provides definitions to terminology
used in this guide.

Finally, there is an Index with a list of shortcut commands. This section
will help you locate information contained within the manual.

Introduction

1.4 PiXELS:3D



Introduction

PiXELS:3D 1.5

Understanding Commands

The following notations are used to describe how commands are
entered into PiXELS:3D:

Menus and Menu Items

When instructed to access a menu item from a menu, the following
notation is used: 

For example, means click on the menu and select
the menu item.

When accessing a menu you may find that certain menu items have
sub-menu items. 

The related notation is 

Tools and Tool Groups

When instructed to access a tool from a tool group, the following
notation is used: Tool Group > Tool.

For example, Control > Move means click on the Control tool group and
then select the Move tool.

Keyboard Commands

When instructed to hold down a key while performing an operation, the
following notation is used: 

For example, means hold the shift key while clicking the
mouse button.
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Overview Contents
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Viewing Panes . . . . . . . . . . . . . . . . .2.4
Menu Bar . . . . . . . . . . . . . . . . . . . . .2.4
Tools and Tool Groups  . . . . . . . . . .2.4
Frame Counter  . . . . . . . . . . . . . . . .2.5
Constraints  . . . . . . . . . . . . . . . . . . .2.5
Floating Palettes  . . . . . . . . . . . . . . .2.5
Selecting an Object . . . . . . . . . . . . .2.6
Getting Started  . . . . . . . . . . . . . . . .2.6
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Overview

The PiXELS:3D interface is the heart of P i X E L S : 3 D. This display contains
four resizeable viewing panes (1a–1d), a menu bar (2), a tool palette ( 3 a ,
3b), a frame counter (4) and a constraints palette (5). Let’s look at each of
t h e s e :

1a

3b

5

3a

2

4

1b

1d

1c



PiXELS:3D Overview

2.4 PiXELS:3D

Viewing Panes

By default, the viewing area of the PiXELS:3D display contains four
viewing panes: Top, Front, Right, and Camera views. The Top, Front
and Right views provide a 2D representation of the object(s) from the
corresponding viewpoint. The Camera view is unique in that it
represents the point of view of an object as it exists in PiXELS:3D’ 3D
space. As you manipulate and edit an object, you can see the updates
occur in each view.

Menu Bar

At the top of the PiXELS:3D interface is a menu bar which displays six
menus: , , , , and .

To select a menu, position the cursor over your selection and click and
hold on it, a list of menu items will appear. Positioning the cursor over a
menu item will highlight it, clicking on a highlighted item will activate it.

When instructed to access a menu item from a menu the following
notation is used: 

For example, means click on the menu and select the
menu item.

When accessing a menu you may find that certain menu items have
sub-menu items. 

The related notation is 

Tools and Tool Groups

Along the left side of the interface screen are a column of buttons
known as the Tool Palette. The tool palette is broken up into two distinct
parts separated by a black box containing the Frame Counter. The buttons
that are located above the frame counter are known as Tool Groups, the
buttons below are the To o l s. 

Clicking on any of the top buttons will select the corresponding tool group.
The bottom buttons will change, showing all the tools associated with the
selected tool group. To select a tool, simply click on its button. T h e
selected tool and tool group buttons will appear indented until another tool
is selected. NOTE: Some tools will remain indented for only a second or
two, giving you a visible feedback that the tool has done something.
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When instructed to access a tool from a tool group the following
notation is used: Tool Group > Tool. For example, Control > Move
means click on the Control tool group and then select the Move tool.

Most tools also have keyboard shortcuts associated with them. To view
these, make sure your cursor is not inside a floating palette then simply hit
the space bar. The keyboard shortcuts will be displayed to the right of the
tool it controls. These shortcuts can be modified by editing the
“Preferences” file.

Frame Counter

The frame counter is the black box located in the area between the tool
groups and the tools. The frame counter displays the current frame
number. The current frame can be changed in one of several ways:

• Click on the frame counter or hit the key to open the
dialog. Here you can enter the number of the

frame that you want to go to.
• Select the View > Time tool (or hold down the +

keys) then click and drag in any view to move through
time. Drag to the right to move forward in time, to the left to
move back.

Constraints

The constraint controls are located along the lower left portion of the
interface screen. These controls allow you to specify how an object will
be effected by any given command. To select a constraint, click on the
desired button. More than one type of constraint can be applied at any
given time.

Floating Palettes

Though not a fixed element of the interface, floating palettes are available
to provide valuable information about a scene. You can use floating
palettes to change certain objects or scene parameters. Floating palettes
can be positioned anywhere on the screen. To enter values numerically,
the cursor must be within the palette while typing or hitting the k e y
to apply settings. If the cursor is not within the palette, the software will
process your keystrokes as keyboard shortcuts.
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Selecting an Object

To select an object for editing you can use one of the following
methods:

1. Hold down the key while clicking on any vertex
on the object you want to select. 

2. Hold down the key, click, hold, and drag a
rectangle around one or more vertices on the object you
want to select. Release the mouse to finish the selection.

3. Use the menu.
4. Select the object from the pop-up menu located in the

palette ( ) or the 
palette ( ).

5. Select the object in the palette
( ).

6. Select the object from the schematic view. (See Views)

Getting Started

If you want to learn how to use PiXELS:3D through a hands on
approach, then continue with the Exercises and Tutorials that follow this
chapter. Otherwise, skip to the Reference Guide Sections: Views,
Menus, Tools and Constraints, as they list all controls, tools and
features with step-by-step instructions on how to use them. Either way,
it is highly recommended that you eventually do all of the exercises &
tutorials, as well as read the reference guide sections.
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Exercise Contents
Exercise 1

General Introduction  . . . . . . . . . .3.5
Exercise 2

Organic Modeling  . . . . . . . . . . . .3.15
Exercise 3

Path Animation  . . . . . . . . . . . . . .3.27
Exercise 4

Inverse Kinematics  . . . . . . . . . . .3.39
Exercise 5

Animating with the Timeline  . . . .3.55
Exercise 6

MorphMaker . . . . . . . . . . . . . . . . .3.63
Exercise 7

ShaderMaker  . . . . . . . . . . . . . . . .3.67
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Exercises
The following exercises will introduce you to a variety of tools and
features that make up PiXELS:3D. These exercises should be followed
step-by-step in order to complete them successfully.

Exercise 1: General Introduction

Exercise 2: Organic Modeling

Exercise 3: Path Animation

Exercise 4: Inverse Kinematics

Exercise 5: Animating with the Timeline

Exercise 6: MorphMaker

Exercise 7: ShaderMaker
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Exercise 1

General Introduction

Launch PiXELS:3D

Double click on the PiXELS:3D icon to launch the application. The
PiXELS:3D splash screen will open. After 3 seconds the PiXELS:3D
interface will appear.

Create a cube

Use the Shape > Cube tool to create a cube primitive. Leave all values
at their defaults. Click the button to accept this cube.
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Dolly out

Hold down the key. This invokes the View > Dolly tool. Click in
the Top view and drag the mouse down as shown. Notice how the view
changes.

There are shortcuts for most of the view tools. They are as follows:

Pan shift
Dolly option
Orbit control
Time control + shift

Select the Camera

Hold down the key. This invokes select mode. Click and
drag a rectangle around the Camera as shown. As long as one corner
of the Camera is located within this rectangle, the Camera will be
selected.
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NOTE: You must hold down the key when selecting objects.

Move the Camera

Select the Control > Move tool. Click and drag the mouse as shown to
move the Camera. Notice how the Camera view updates.

Select the cube

Hold down the key. Click and drag a rectangle around one
corner as shown.
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Rotate the cube

Select the Control > Rotate tool. Click and drag as shown to rotate the
cube. Notice how it rotates on all axes simultaneously and how difficult
this is to control.

Undo the last operation

Use the ( ) menu item to reset the model back to the
way it was before rotating.
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Constrained rotation

Using the rotate tool was cumbersome and difficult to control. That’s
because we were trying to rotate in three dimensional space using a
two dimensional pointing device (mouse). To make things more
manageable, we can constrain movement to one or two axes. Click on
the X Axis and Z Axis buttons at the bottom of the screen to disable
them.

Rotate the cube on its y axis

The last operation left only the y axis enabled so the Rotate tool should
now work only on the y axis. Make sure the Control > Rotate tool is still
the currently active tool. Click and drag as shown and notice how the
cube rotates now.
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Scale cube on its y axis

Select the Control > Scale tool. Click and drag in the Front view as
shown to scale the cube. Notice how scaling also is constrained to the
y axis.

Check Object Info dialog

Use the ( ) menu item to open the 
dialog. Notice the numbers in the and edit

fields. These are the numeric equivalents of the transformations (scale
and rotation) you just manually applied to the cube. (Your numbers
probably will not match those shown here.)
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Manually set transformation

To reset the cube back to its original size and orientation, simply change
the to match
the settings in the diagram below. NOTE: you must keep the cursor
inside this dialog while typing. If the cursor is outside this dialog, the
software will think you are using keyboard shortcuts. To apply your new
settings, keep the cursor inside the dialog and hit or .

Scale cube

Enable the x and z axis. Do this by clicking on the X Axis and Z Axis
buttons at the bottom of the screen. Note that the Y Axis should still be
enabled. Select the Control > Scale tool. To scale the cube down, click
and drag in the Front view as shown.
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Park the cube

Use the Control > Park tool to park the cube. dialogue
will open—click to accept defaults. Parking an object sets its scale,
rotation and position values back to their defaults (1, 0, and 0
respectively) without changing the appearance of the object.

Check the Object Info dialog

Use the menu item ( ) to open the 
dialog. Notice that despite scaling the object down to about half its

original size, the , , and values are all 1. This is
the effect of parking the cube.

Create a new scene

Use the ( ) menu item to create a new scene. PiXELS:3D
will ask you if you want to save the current scene before closing (only
one scene can be open at a time.) Click the button to create a new
scene without saving the current one.

Create a cylinder

Use the Shape > Cylinder tool to create a cylinder. Click the button
to accept the default cylinder.
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Set the cylinder’s flex values

Open the dialog using the menu item ( ). Set
the and sliders to 0.4. Sliders can be adjusted in one of three ways:

1. Click in either the up arrow or down arrow to move the slider
up or down.

2. Click and drag in the slider itself.
3. Manually enter values into the fields (use tab to move

through fields). To apply settings, hit the or 
key. The cursor must be inside the dialog while typing.

Select a Vertex

Select the Reshape > Push/Pull tool. Click on the vertex indicated.

NOTE: there is no need to hold down the key, it is only
needed when selecting a new object, not a new vertex. Note also that
not all tools allow you to select vertices. The Move tool (by default) does
not affect the object at a vertex level, so while the Move tool is the
current tool, the software doesn’t select vertices.
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Reshape the cylinder

Click and drag as shown. Notice how the surrounding points are
affected by this tool. The number of points affected is set in the 
dialog. The and values in the dialog represent a percentage of
the surface which will be affected. Try experimenting with different flex
settings and interpolation modes (one of the four icons on the right side
of the dialogue) to see how they affect the surface you are
reshaping.
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Exercise 2

Organic Modeling

Launch PiXELS:3D

Double click on the PiXELS:3D icon to launch the application. The
PiXELS:3D splash screen will open. After 3 seconds the PiXELS:3D
interface will appear.

Create a cylinder

Use the Shape > Cylinder tool to create a cylinder primitive. Click the
button to accept the default cylinder.

Set the cylinder’s flex values

Use the ( ) menu item to open the dialog. Set
the and sliders to 0.38. Change the interpolation mode to smooth
weighted. Type the , or key to apply these settings.
The cursor must be inside the dialog while typing.

Pinch the cylinder closed

Select the Reshape > Pinch tool. Click and drag in the Camera view as
shown. Notice how the cylinder pinches shut. You may have to click and
drag more than once to fully close the cylinder.
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Invoke vertex mode editing and disable the X and Y Axis buttons

Select the Control > Move tool. Select the Tag constraint. Deselect the
X Axis and Y Axis constraints

NOTE: The Tag constraint allows most of the Control tools to work at a
vertex level, as opposed to their default object level. The Tag constraint
does not work with Reshape tools because they are always in vertex
mode.

Tag some points

Hold down the key. Click and drag a rectangle around the
tip of the cylinder as shown.

NOTE: By default, only points on the currently selected object can be
tagged. To tag points on all objects, hold down the -
keys. To tag points on all objects other than the currently selected
object, hold down the - keys.

Move the tagged points

Click and drag as shown to ‘tuck-in’ the nose of our cylinder. Notice how
only the tagged points move.
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Create a sphere

Use the Shape > Sphere tool to open the dialog. Click
the button to accept the default settings.

Numerically scale the sphere

Use the menu item ( ) to open the 
dialog. Change to 2.

To apply settings, hit the or key. The cursor must be
inside the dialog while typing.

Clip the sphere

Use the Reshape > Clip tool to open the dialog. Disable
the option and enable the option. Click the button to
accept. This removes all points of a model that fall below Y=0.
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Move the sphere

The Z Axis should be the only axis constraint active.

Use the Control > Move tool to position the sphere as shown.

Collide sphere into cylinder - step 1

Enable only the Y Axis constraint. Select the Reshape > Collide tool.
Hold down the key and click and drag a rectangle as shown
to select the cylinder.
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Collide sphere into cylinder—step 2

Without holding down the key, click and drag a rectangle as
shown to pick the sphere.

NOTE: Picking is different than Selecting an object. Selecting makes an
object active, whereas Picking identifies an object so a specific
operation may be applied to it. (i.e. Pick a sphere to collide with the
cylinder, or Pick a path to extrude along) It is not necessary to hold
down the key when Picking objects.

Collide sphere into cylinder—step 3

After you’ve picked the sphere, the dialog will open.
Enable the and options and click the button to
accept. Click in the dialog that opens.



PiXELS:3D Exercises

PiXELS:3D 3.21

Save the model

Use the menu item to open the dialog. Type
DogHead into the edit field and click the button
to accept.

Render the scene

Use the menu item ( ) to render the scene into
the Camera view. Click the mouse to exit render mode and return to
model mode.

NOTE: this image will not be saved.

Create a sphere

Use the Shape > Sphere tool to open the dialog. Set
the to 6. Click the button to accept.
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Numerically scale the sphere

Use the menu item ( ) to open the 
dialog. Change the to 0.5 and the to 0.25.

To apply settings, hit the or key. The cursor must be
inside the dialog while typing.

Move the sphere

Enable all axis. Use the Control > Move tool to position the sphere. In
the front view move it up and to the left. In the right view move it back.

Duplicate sphere and position it

Use the menu item to duplicate the sphere. The new
sphere is placed directly on top of the old one. Use the menu item

to open the palette. Remove the
negative sign from the value.

To apply settings, hit the or key. The cursor must be
inside the dialog while typing.
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Render the scene

Use the menu item ( ) to render the scene into
the Camera view. Click the mouse to exit render mode and return to
model mode.

Create a sphere

Use the Shape > Sphere tool to open the sphere dialog.
Set the to 3. Click the button to accept.

Move the sphere

Disable all axis constraints except the Z Axis. Use the Control > Move
tool to position the sphere as shown.

NOTE: the arrow keys can be used with almost any tool to nudge
objects along. Each click of an arrow key is equal to clicking and
dragging the mouse 1 pixel in the direction of the arrow key.
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Add color and texture to “nose”

Use the menu item ( ) to open the
dialog. From the first pop up menu, select 

.

Set nose color

The dialog will appear. Change the sliders as follows:

r: 1.0
g: 0.5423
b: 0.4615

Click the button to accept. In the main dialog, click
the button to apply these settings to the currently selected model.
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Add color and texture to head and eyes

Repeat the last 2 steps for the eyes and head. Set both the eyes’ user
color to:

r: 0.9
g: 0.9
b: 0.95

Set the head’s user color to:

r: 0.5
g: 0.2
b: 0.0

Link parts to head

Select the Control > Link/Unlink tool. Link the nose to the head by
holding down the command key and selecting the nose. Then, without
holding down the command key, pick the head. The 
dialog will appear. Click to accept the default options. A green line
will appear showing this link.

Link the eyes to the head also. Because the eyes have been scaled, a
dialog will appear asking if these objects should be parked before
linking. Click to accept this option.
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Create and position a “null”

Use the Shape > Null tool to create a null object.
Use the Control > Move tool to position it as shown.

NOTE: a null object simply represents a position in space. It doesn’t
show up when rendered.

Tell the head to look at the null

Select the Control > Look/Unlook tool. Tell the head to look at the null
by holding down the key and selecting the head. Then,
without holding down the key, pick the null object.

NOTE: a blue line will appear showing a link between the head and null.
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Create and position another null

Enable all axes. Use the Shape > Null tool to create a null object. Use
the Control > Move tool to position it as shown. Use the
Control > Look/Unlook tool to tell the left eye to look at the null.
Repeat for the right eye.

Render the scene

Use the menu item to render the scene into the
Camera view. Click the mouse to exit render mode and return to model
mode.

Move the head’s “look at” point

Select the first null. Use the Control > Move tool to move it around.
Notice how the eyes still track their look at point (null #2.)
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Exercise 3

Path Animation

Launch PiXELS:3D

Double click on the PiXELS:3D icon to launch the application. The
PiXELS:3D splash screen will open. After 3 seconds the PiXELS:3D
interface will appear.

Dolly out

Hold down the key to invoke the View > Dolly tool. Click and
drag as shown to dolly out in the Top view.

Draw a spline

Select the Shape > Spline tool. The dialog appears.
Select as the spline type and click to accept. 

1
2

3
4

5

6 7

8
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Draw a spline

Click the mouse at position number 1. Release the mouse and move to
position number 2. Notice how the Spline tool tracks the mouse. Click
and release the mouse. Move to position 3 and click again. Repeat up
to position 8. Double click on position 8. This ends Spline mode. If you
forget to double click, hit the key.

Disrupt the path

Use the Reshape > Disrupt tool to open the dialog.
Set the parameters as follows:

0
20
0

Click the button to accept.
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Set views

Use the Dolly ( ) and Pan ( ) tools to size and
position all four views so that the entire path can be seen in each.

Create a circle

Use the Shape > Cylinder tool to open the dialog.
Set the parameters as follows:

tube
10
1
360
10
40

Click the button to accept.

Extrude the circle along the path

With the circle still selected, select the Shape > Path Extrude tool. Click
and drag a rectangle around any vertex on the spline to pick it. The
circle will be extruded along this spline. Use the 
menu item to hide the newly formed tube. Select the circle and hit the

key.



PiXELS:3D Exercises

PiXELS:3D 3.31

Link the Camera to the path

+ click on the Camera to select it. Select the Control >
Path/Unpath tool. Click and drag a rectangle around any vertex on the
spline to pick it, designating this spline as the Camera’s motion path.
The dialog will open. Set the parameters as follows:

0
91

Notice how the Camera aligns itself with the beginning of the path.

Link the Interest to the path

+ click on the Interest to select it. The Interest is the null
object that the Camera looks at. Wherever it goes, the Camera will
track. If you have a hard time finding it, look for the blue line originating
at the Camera. Follow this blue line to its end and you will find the
Interest.

With the Interest selected, click on the Control > Path/Unpath tool. Click
and drag a rectangle around any vertex on the spline to pick it,
designating this spline as the Camera’s motion path. The 
dialog will open. Set the parameters as follows:

-1
90

Save this model. In the use the button to
create a new folder inside the Projects folder located in your PiXELS:3D
folder. Name this new folder RollerCoaster. Name the file
RollerCoaster_scene.
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Render a pencil test

Use the Animate > Pencil Test tool to open the 
dialog. Set the values as follows:

0
90
1
30

Click the button to accept.

Click the mouse or type to stop. Click and drag
the mouse left to right to shuttle.

Return to frame 0

Click on the frame counter (the button separating the tool groups from
the tools) to open the dialog. Type 0 < .
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Change the light color

Use the menu item to open the 
palette. Select from the pop-up menu.
Click in the color box to the right of the pop-up menu
to open the dialog. Set the , and sliders
as follows:

- 100
- 61

- 49

Click to accept.

Change the Light Type

Select from the pop-up menu. Unlike a point light, a
sun has no obvious source in the scene, only a direction from which the
light is cast.

Duplicate the light and change position and color

With the default light still selected, use the command
to make a copy of the light. Use the palette to change the

, and values to:

- negative 50
- negative 50
- positive 50

Click in the color box to the right of the pop-up menu
to open the dialog. Set the , and sliders
as follows:

- 51
- 73

- 100

Click to accept.
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Change the tube’s settings

In the palette, select from the pop-
up menu. Change the following parameters:

- 4
- 8

Apply a texture map to the tube

Use the ( ) menu item to open the
dialog. Select from the first pop-up

menu.

This will open the dialog:

Click in any empty tile or click the button.
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The dialog will open. Navigate to the Textures folder located
inside your PiXELS:3D folder. Locate and select the texture named
bluestone.PICT. Click to load this image. In the 

dialog, click .

The dialog will open. Change the following parameters:

- checked
- checked

- 0.25
- 0.025

Click to accept.
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Change the Specular settings

Change the slider to 0.2 (you can type the value into the edit
field to the left of the slider.) Change the slider to 0.5. Click

to accept.

Render a test frame

Use the menu item to render a test frame into the
Camera viewing pane. Click the mouse to return to model mode.
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Add a bump map

Use the ( ) menu item to open the
dialog. Select from the pop-up

menu. The dialog will open. Click on the
bluestone.PICT tile. Click . The dialog will open.
Change the following parameters:

- checked
- checked

- 0.25
- 0.025

Click to accept.

In the dialog, change the slider to 4. Click .

Render another test frame

Use the menu item to render another test frame
into the Camera viewing pane. Notice how the surface appears to be
bumpy. This is what a bump map does. Click the mouse to return to
model mode.
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Render your final animation

Use the ( ) menu item to open the 
dialog. Enable the option and click .

Use the menu item to render your animation to
disk. In the dialog use the button to create a folder
inside your RollerCoaster folder. Name it Frames. Set the file name to
Frame and click All of the frames for your animation will be
rendered and saved with a numerical extension indicating the frame
number of that image. After rendering, use the 
tool to playback your animation. Select the first frame and click 
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Exercise 4

Inverse Kinematics

Launch PiXELS:3D

Double click on the PiXELS:3D icon to launch the application. The
PiXELS:3D splash screen will open. After 3 seconds the PiXELS:3D
interface will appear.

Create a cylinder

Use the Shape > Cylinder tool to open the dialog. Change the
following parameters:

- Left Leg Skin
- 2.5

Click to accept.

Rotate 90°

Use the palette to set the cylinder’s to 90°. Hit
the key to apply. Remember to keep the cursor inside the dialog
while typing. Leave the palette open.

1

2

3
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Create an IK Chain

Creating an IK Chain is just like drawing a spline. You click the mouse
one time at each joint, then double click on the last joint to end it (or hit
the key.) Select the Shape > IK Chain tool. Click and release the
mouse at position 1. Move the mouse to position 2 and click again.
Finally, double click at position 3. If you forget to double click, hit the

key.

Name the IK Chain

The dialog will open. Set the to Left Leg.
Click the button to accept.
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Link the cylinder to the IK Chain

Select the Control > Link/Unlink tool. Select the cylinder by -clicking
on it. In the Front view, click and drag a rectangle around the top portion
of the IK chain as shown to pick it. (no key). This top portion
is called the root. All initial links need to be applied to this part of the
chain.

The following dialog will appear:

Click . Hierarchies are much more manageable if all objects within
it share the same coordinate system. The dialog will now
appear. Click to accept the default settings.
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Tag some points

Select the Tag constraint. While holding down the key, click
and drag a rectangle as shown. The key is used to invoke
select mode.

Link the tagged points to a different part of the IK Chain

Without holding down the key, click and drag a rectangle as
shown. 

Deselect the Tag constraint.



PiXELS:3D Exercises

3.44 PiXELS:3D

Bend the IK Chain

First, select the last joint on the IK Chain. Next, use the Control > Move
tool to move the last joint as shown. Notice how the cylinder is being
affected by two different parts of the chain. Unfortunately the area
around the joint looks awkward. The next steps will show you how to
resolve this problem.

One common question is “How do I know which IK joint to link my
tagged points to?” There are many factors which can affect how you
decide to link and—as we will soon see—weight points to IK segments.
A good place to start is to link the points just before the pivot point and
all points up to the next pivot point (or in this case the end of the chain)
to the segment which lies between those pivot points. This is the
approach we are taking in this exercise.
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Select the cylinder

Select the V Col constraint. This will allow for the adjusting of an entire
ring of points at once. Hold down the key and click and drag
a rectangle as shown to select the cylinder and a row of points.

Set IK Weight

Use the menu item to open the 
dialog. Set the slider to approximately 0.333. Hit the 
key to apply. Remember to keep the cursor inside the dialog while
typing. Notice how much smoother the transition from top to bottom is.
The parameter defines how much rotation to inherit from the
segment the point is linked to. The remainder is inherited from the
previous segment.

Leave this palette open.
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Set IK Weight continued

Use the button to select the previous ring of points. Set the 
slider to about 0.666. Hit the key to apply. Remember

to keep the cursor inside the dialog while typing.

Straighten out the IK Chain

Select the last joint on the IK Chain. Use the Control > Move tool to
move the last joint as shown.
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Create a sphere

Use the Shape > Sphere tool to open the dialog.
Change the to Left Foot. Click the button to accept.

Clip the sphere

Use the Reshape > Clip tool to open the dialog. Disable
the option and enable the option. Click the button to
accept.

Numerically scale the sphere

Use the palette to numerically scale the sphere.
Set to 0.5 and to 0.33. Hit the key to apply.
Remember to keep the cursor inside the dialog while typing.
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Position the sphere

Use the Control > Move tool to position the sphere as shown.

Link the sphere to the IK Chain

In the front view, use the ( key) and ( key) tools
to zoom in on the foot as shown. Select the Control > Link/Unlink tool.
Without holding down the key, click and drag a rectangle as
shown.

A dialog will appear asking if you want to park the cylinder. Click .
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The dialog will now appear. Click to accept the default
settings.

Create a circle

Use the Shape > Cylinder tool to open the dialog.
Change the following parameters:

- Left Foot - Path
- 1
- 5

Click to accept.



PiXELS:3D Exercises

3.50 PiXELS:3D

Numerically scale the circle

Use the palette to numerically set the to 3. Hit the
key to apply.

Position the circle

Use the Control > Move tool to position the circle as shown. Take care
to ensure that the bottom of the circle aligns with the bottom of the foot.

Path link the last joint to the circle

From the palette, use the pop-up menu to select
the item. Select the Control > Path/Unpath tool. Click
and drag a rectangle as shown to pick the circle as the path.

The dialog will open. Set the parameter to 30
and click .

Constraint
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Invert the path

From the palette, use the pop-up menu to select
the item. Use the Reshape > Invert tool to reverse the
direction of the path.

Position knee constraint

Our leg is bending the wrong way! To correct this, select and position
the knee constraint up and away from the knee as shown. Each joint in
an IK Chain has a constraint associated with it. This constraint can be
found by following the blue line which connects the joint being
constrained with its null. (The null is actually the constraint.) This gives
the computer hints as to how you want the IK Chain to behave.
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Cycle the animation

Select the last joint in the IK Chain. Use the Animate > Dup. Keys tool
to open the dialog. Change the following
parameters:

- 30
- 10

Click to accept.

Link the motion path to the IK

Select the circular motion path. Select the Control > Link/Unlink tool.
Click and drag a rectangle as shown to link the path to the root of the IK
Chain.

A dialog will appear asking if you want to park the cylinder. Click .
The dialog will appear. Deselect the option.
Click to accept these settings.
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Position the left leg

Select the root of the IK Chain. In the palette, change the 
value to -8. Hit the key to apply.

Create, position and name the right leg

With the Left Leg_root object still selected, use the 
menu item to create a duplicate of the left leg. Use the

palette to change the value to 8.

Now click and hold on the pop-up menu in the Object Info palette. You
will notice that you now have duplicate “left foot”, “left leg root”, etc.
Click on each of these names and you will be able to see what part of
what leg is selected. When you see your “right leg” pieces selected,
change the name of that piece to “right foot”, or “right leg root”, etc.

Offset the right leg’s animation cycle

Select the last joint of the right leg. Use the Animate > Offset Keys tool
to open the dialog. Change the following
parameters:

- 300
- -15

Click to accept.
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Render a pencil test

Use the Animate > Pencil Test tool to open the 
dialog. Set the to 0 30. Click to render and
playback a pencil test of the animation.
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Exercise 5

Animating with the Timeline

Launch PiXELS:3D

Double click on the PiXELS:3D icon to launch the application. The
PiXELS:3D splash screen will open. After 3 seconds the PiXELS:3D
interface will appear.

Create a cube

Use the Shape > Cube tool to open the dialog. Click the
button to accept the default settings and create a cube.

Open the Timeline palette

Use the ( ) menu item to open the 
palette. In the , expand the group by clicking in the
box to the left of the group’s name as shown. All the animatable groups
are now visible. If had any objects linked to it (children) they
would show up here as well.

Expand the Position group

In the , expand ’s group by clicking in the
box to the left of the group’s name. All the animatable
parameters ( , and ) for the group are now visible.
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Expand the Position Y parameter

In the , expand the group’s parameter. This is as
far down as we can go. We are now looking at the actual value for this
parameter at this frame. More on that later. Note the green box to the
left of the value. This box represents the function curve’s color. Clicking
on it will open the Apple color picker, allowing you to change the
function curve’s color.

Navigating the Timeline

Navigating the timeline is the same as in any other view. - click
and drag will pan. - click and drag will zoom. Pan the view a
little to the right as shown.

Click in the bottom right corner of the palette. Hold the mouse button
down and drag to resize the window as shown.



PiXELS:3D Exercises

PiXELS:3D 3.59

Function curve viewing panes

To the right of the parameter is that parameter ’s function curve
viewing pane. Since there are currently no keyframes, no function curve
is visible. This viewing pane can be resized by clicking in the bar just
below the viewing pane and dragging it down as shown.

Adding keyframes

Keyframes can be added directly in the . - clicking on
any group will add a keyframe to any value within that group. -
clicking on the group will add keyframes for the , and 
parameters. - clicking on the group would add keys to
all , , , etc... parameters.

- click on the parameter to add a key.

Go to frame 20

The current frame can be changed from within the . To change
the current frame, click and drag the red box inside the frame bar. This
red box is the key insertion point. Any new keyframes will be inserted at
the frame indicated by this marker. Holding down the key while
dragging the current frame indicator will change the add key insertion
point without changing the current frame.

Drag the key insertion point to frame 20 as shown.
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Add some more keyframes

- click on the parameter to add a new key at frame 20. Notice
how the timeline changes. Drag the key insertion point to frame 40 and
add another key for the parameter. Add keys at frames 60 and 80
as well.

Numerically change the Y parameter

Drag the key insertion point to frame 10. Click on the value just below
the parameter. Notice how it becomes highlighted. The value can now
be edited. Type 40 followed by either the or key to
accept. The cube will move up, possibly out of view.

Add even more keyframes

-click on the parameter to add a key at frame 10. Notice how
the function curve updates.

Drag the key insertion point to frame 30. Click on the value just below
the parameter. Type 30 followed by either the or key to
accept. -click on the parameter to add a key at frame 30.

Drag the key insertion point to frame 50. Change the value to 20 and
add a keyframe. Drag the key insertion point to frame 70. Change the 
value to 10 and keyframe this change also.
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Bar mode vs. curve mode

Data can be viewed in one of two ways. The default view (the one we
have been working in) is bar mode. The alternate view is curve mode.
Curve mode allows you to view and edit multiple curves simultaneously.
Any parameter which has been fully expanded in the hierarchy will
show up in this mode regardless of its position in the scrolling list. This
allows you to edit curves from multiple objects simultaneously. To invoke
curve mode, click on the in the upper left corner
of the palette. To switch back to bar mode, click on the 

. Click on the now.

Edit the function curve

Function curves are Adobe Illustrator® style bézier curves. As in Adobe
Illustrator®, there are control handles associated with each control point
(key). These handles can be edited to alter velocity from key to key.
Hold down the key and click and drag a rectangle as shown
to select the first control point. Control handles are only visible for
selected control points. NOTE: multiple control points can be selected.
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Click on the box at the end of the control handle. While holding the
mouse button down, drag the control handle as shown.

Edit the remaining control handles

Hold down the key and click and drag a rectangle as shown
to select the second control point. Notice how two control handles
appear, one to the left of the control point and one to the right. Click and
drag on the left control handle. Notice how the handle on the right
mirrors your movements. This is called maintaining continuity. This
maintained continuity results in smooth motion.

By default, control handles will always maintain continuity. Sometimes it
is desirable to break continuity, allowing for abrupt changes in motion.
To do this, hold down the key when clicking on the control
handle. The continuity will remain broken until you - click on
the control handle a second time. - click and drag the left
control handle as shown.
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Without holding down the key, click and drag the right control
handle as shown.

Repeat this process for each of the remaining control handles, so that
the function curve resembles the one shown below.
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Create a Pencil Test

Navigate the Camera view to match the one shown.

Use the Animate > Pencil Test tool to open the 
dialog. Set the as shown. Click to accept.
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Exercise 6

MorphMaker

Launch PiXELS:3D

Double click on the PiXELS:3D icon to launch the application. The
PiXELS:3D splash screen will open. After 3 seconds the PiXELS:3D
interface will appear.

Create a sphere

Use the Shape > Sphere tool to open the dialog. Click
the button to accept the default settings and create a sphere.

Reshape the sphere

Use the Reshape > Remove tool to open the dialog.
Deselect and select as shown. Click to
remove the current v-step.

Click on the and constraints to deselect them.

Use the Reshape > Pinch tool to close the open end of the sphere as
shown. This end of the sphere will be our character’s mouth.
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Set our Reference pose

Use the menu item ( ) to open the
palette. Click the button to designate

the current shape as the reference pose.

Open the mouth

Use the Reshape > Pinch tool to open the character’s mouth.

Click the button. Name this gesture wide open and
click to accept.

Keep the palette open.
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Make a smile

In the Front viewing pane’s title bar, click on the word front to open the
dialog for this view. Select the option and click

to apply.

In the dialog, click the button to set the
shape to it’s reference state. Use the Tag constraint and the Move tool
to select and position the points around the mouth as shown. The
character should appear to be smiling.

Click on the button. Name this gesture smiling and
click . Move the slider back and forth. Notice how the mouth changes
shape. This slider adjusts the influence that this gesture has on the final
shape. Set the influence to about 0.6. Click on the 
button. This will add a keyframe at the add key insertion point for each
gesture influencing our character ’s current shape.
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Animate the mouth

Open the palette ( ). Set the add key insertion point to
frame 20. In the palette, select the item
from the menu. Adjust this gesture’s influence. The mouth
opens and closes as the slider is moved back and forth. Set the
influence to about 0.5. Click on the button.

Set the add key insertion point to frame 40. Click on the 
button to reset our shape. Click on the button. 

NOTE: Shapes can have a negative influence as well. You can’t set this
with the slider, but you can in the timeline. A negative smile will give you
a frown! Values greater than 1 can be used for exaggerated
expressions.

Render a pencil test

Use the Animate > Pencil Test tool to open the 
dialog. Set the to 0 40. Click to render and
playback a pencil test of the animation.
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Exercise 7

ShaderMaker

Launch PiXELS:3D

Double click on the PiXELS:3D icon to launch the application. The
PiXELS:3D splash screen will open. After 3 seconds the PiXELS:3D
interface will appear.

Create a cylinder

Use the Shape > Cylinder tool to open the dialog.
Click the button to accept the default settings and create a cylinder.

Open ShaderMaker

Use the ( ) menu item to open the
dialog.

Background

Shaders can be created from scratch or you can use the button to
read a shader from disk. Once a shader has been read into
ShaderMaker, it can be edited to create a new look.
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Create a User Color node

Select from the color pop up menu (the first
menu).

Change the color space

The dialog will appear. It has three inputs – one for each
component making up the color space you currently have selected. All
three of the nodes are value nodes. These values are combined to
make a color. The default color space is rgb. Change the color space
from rgb to hsv by selecting from the pop up menu
located in the upper left corner of the dialog.



Tutorials
The animation of digital actors is one of the most complex and
demanding tasks an artist can undertake. Even the simplest of
characters require the coordination of at least three different and distinct
disciplines—modeling, articulation and animation.

On the following pages we will go through, in great detail, all the steps
involved in creating a digital actor—from modeling and texturing the
character, to illuminating the scene and, finally, bringing the character to
life with inverse kinematics.

Milton P. Penguin III
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Tutorial 1: Starting From Scratch

Launch PiXELS:3D

If PiXELS:3D is already running on your machine, choose the 
( ) menu item now.

1. Launch PiXELS:3D.
In the Finder, locate the PiXELS:3D application icon.  Double
clicking on this icon will launch PiXELS:3D.

Import Background Images

We will use pencil sketches as guides for the construction of our
character. PiXELS:3D has a feature which allows any view to display an
image map, allowing the artist to trace over this template.

1. Open the dialog for the front view.
Click on the word Front in the title bar of the lower left
viewing pane. This opens the dialog.

2. Open the dialog.
Select the checkbox, then click on the empty box to
the right of the checkbox to open the 

dialog.
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3. Load a background image.
Click on any empty box. The standard file dialog will open.
Navigate to the sketches folder located inside the tutorials
folder. Open the file inside titled milty_front. Click the 
button to open this texture. Click the button in the

dialog to return to the 
dialog. Click the button in the dialog to
return to PiXELS:3D.

4. Repeat for right view.
Repeat steps 1 - 3 for the right view, this time loading the file
titled milty_side.
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Trace Templates

Now that we have our background images loaded, we can use them as
templates to trace the contours of our character.

1. Select the Shape > Spline tool.
Click on the Shape tool group. Select the Spline tool. The

dialog will open. Select the option
and click .

2. Trace the template.
In the front view, starting from the top of the head, going
counter-clockwise, trace the character ’s left side profile.
Double click to finish drawing the spline. If the double click
doesn’t take, hit the key.
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3. Subdivide the spline.
Click on the Reshape tool group. Select the Subdivide tool.
The dialog will open. Click .

Lathe the Spline to Create a Patch

Splines by themselves cannot be rendered. In order for our spline to be
visible when rendered, we must construct a patch from it. There are
many tools in PiXELS:3D to create patches from splines. The Lathe tool
forms a patch by rotating a profile curve around the y axis. Copies of
the original curve are created at various stages of rotation. These
copies are joined together to form a patch.

1. Lathe the profile curve.
Click on the Shape tool group. Select the Lathe tool. The

dialog will open. Set the option to 20
and click .

PiXELS:3D Tutorials

4.6 PiXELS:3D



2. Park the lathed surface.
Click on the Control tool group. Select the Park tool. The

dialog will open. Click .

Edit Surface to Fit Sketch

In the front view, the newly created patch fits our sketch perfectly, but
the right view shows some problems. We will need to manually edit the
patch to fit our sketch.

1. Set the constraints.
Click on the V Col constraint to select it.
Click on the X Axis and Y Axis constraints to deselect them.
The Z Axis should be the only axis constraint left active.
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2. Reshape side view to match sketch.
In the right view, use the Reshape > Pinch tool and the
Reshape > Push/Pull tool to mold and position each cross
section such that it matches our pencil sketch. The keyboard
shortcut for Push/Pull is a and the keyboard shortcut for
Pinch is d. By simply typing these letters, the corresponding
tool is instantly selected. Type the space bar to see all the
keyboard shortcuts available.

Finish Up

Finally we will check our surface and save it to disk.

1. Render the surface.
Choose the ( ) menu item.
After the rendering has finished, click the mouse button to
return to PiXELS:3D.
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2. Save the model.
Choose the ( ) menu item.
Save the model in the milty folder. Name the model body.

3. Quit PiXELS:3D
Choose the ( ) menu item.
In the next tutorial we will be creating a new project file. We
could simply choose the ( ) menu item, but
restarting PiXELS:3D is preferred. Memory, like a hard disk,
can become fragmented over time. Quitting PiXELS:3D
clears out all the memory used, allowing it to be reallocated
upon launch.
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Tutorial 2: Primitives & ShaderMaker

Launch PiXELS:3D

If PiXELS:3D is already running on your machine, choose the 
( ) menu item now.

1. Launch PiXELS:3D.
In the Finder, locate the PiXELS:3D application icon.  Double
clicking on this icon will launch PiXELS:3D.

Create a Cone Primitive

Not all patches are constructed from manually drawn splines.
PiXELS:3D provides a wealth of basic building blocks, called primitives,
from which you can construct many objects.

1. Select the Shape > Cone tool.
Click on the Shape tool group. Select the Cone tool. The

dialog will open.

2. Change the name to beak and Click .
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Reshape the Primitive

Once a primitive has been created, it can be modified using any of the
Reshape tools.

1. Open the dialog.
Click on the menu. Select the ( ) menu
item. The dialog will open.

2. Adjust the flex setting for the beak.
Set the and sliders as shown. Values can either be
entered numerically or altered interactively using the sliders.

3. Select the Mir U constraint.
Click on the Mir U constraint to select it. The constraints are
located in the lower left corner of your screen.

4. Reshape the cone.
Select the Reshape tool group. Select the Push/Pull tool. In
the top view, click on the cone’s upper right control point.
Click and drag as shown.
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5. Use ShaderMaker to apply yellow color to beak.
Click on the menu. Select the ( )
menu item. The dialog will open. Select

from the color pop-up menu. Click to
return to Pixels:3d.

6. Save the model.
Choose the ( ) menu item.
Save the model in the milty folder. Name the model beak.

7. Create a new scene .
Choose the ( ) menu item. Since the last
model we created was so simple, memory fragmentation is
minimal. In this case, quitting and re-launching would be
excessive.
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Create a Sphere Primitive

1. Select the Shape > Sphere tool.
Click on the Shape tool group. Select the Sphere tool. The

dialog will open.

2. Change the name to left_eye. Click .
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Create an Eyeball Shader

OK, so we have a sphere. How are we going to make it look like an
eyeball?

1. Open the dialog.
Click on the menu. Select the

( ) menu item. The dialog
will open.

2. Create a node.
Select from the first pop-up menu. A

node will be created and a dialog will open
allowing us to set initial parameters. Any parameter set now
can always be edited later. Select from the 
pop-up menu. Select from the pop-up menu.
Set the slider to 1.
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3. Create two nodes.
Select from the first 
pop-up menu. A node will be created and a
dialog will open. Select from the 
pop-up menu and from the pop-up
menu. A second node will be created and
another dialog will open.

4. Setup our parameters.
Select from the pop-up menu.
Select from the pop-up
menu. Set the scale factor for to 2. Click in all
four dialogs.
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5. Render our eyeball.
Use the ( ) menu item to render our
eyeball. Click the mouse to return to PiXELS:3D.

6. Save the model.
Choose the ( ) menu item.
Save the model in the milty folder. Name the model eye.
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How’d We Do That?

Before we can understand how the eyeball shader works, we must first
have a solid understanding of the sphere we are shading. Like all
PiXELS:3D’ primitives, the sphere is made from a patch. All patches
can be unraveled into a rectangular grid—even our sphere. This
underlying grid is parameterized using a 2D coordinate system. To help
differentiate between the standard 3D coordinate system, x and y are
not used to label this coordinate system. Instead we use s and t as
labels (u, v and w are commonly used to label yet another coordinate
system). Any point within this grid can be defined using s and t
coordinates which range from 0 to 1. The exact center of the grid would
be at {0.5, 0.5} in st space.

We can use this parameterized coordinate system to create some
interesting shaders. Our eyeball shader is a good example of this. The
blending between black and white is controlled by a rounded, scaled t
coordinate. The exact function is round( t * 2.0 ).

Let’s examine this in depth.

The node mixes with based on the value
returned by the . So, if was white, 
was black and the returned a value of 0.5, the

node would return grey.

The round function returns the nearest whole number. So round( 0.2 )
would return 0, round( 0.6 ) would return 1 and round( 0.5 ) would also
return 1.

If t ranges from 0 to 1 and we use round( t ) as a 
from black to white, the node will return white if t is greater
than or equal 0.5. As such, we would get a shader that is half black and
half white.

In the eyeball shader we are using black to represent the iris & pupil.
This generally covers only about 25% of the eye, so we need to scale t
so that it will round up to 1 after only 25% of the eye is filled with black.
To do this, we multiply t by 2. Notice that t * 2 will range from 0 to 2,
instead of 0 to 1.

So, if 2t ranges from 0 to 2 and we use round( 2t ) as a 
from black to white, the node will return white if 2t is

greater than or equal 0.5. As such, we would get a shader that is 25%
black and 75% white.

Once we have this function, we simply convert it into a shader.
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Tutorial 3: Putting It All Together

Launch PiXELS:3D

If PiXELS:3D is already running on your machine, choose the 
( ) menu item now.

1. Launch PiXELS:3D.
In the Finder, locate the PiXELS:3D application icon.  Double
clicking on this icon will launch PiXELS:3D.

Import Body Parts

We now have 3 separate files. We will need to import them into one
scene to create our finished character.

1. Open the body model.
Use the ( ) menu item to load the body scene.

2. Import the beak model.
Use the menu item to import the
beak model.

PiXELS:3D Tutorials

PiXELS:3D 4.19



Position and Scale the Beak

The beak is a little too big for the body. We will need to reposition and
resize it to fit.

1. Move the beak.
Use the Control > Move tool to position the beak as shown.

2. Scale the beak.
Use the Pan and Zoom tools to zoom in on the head as
shown. Use the Control > Scale tool to resize the beak.
Don’t worry about trying to match the height, just scale it so
the width matches our sketch.
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3. Reshape the beak.
Disable the Z Axis constraint.

Use the ( ) menu item to open the 
palette. Set and to 0.

Use the Reshape > Pinch tool to constrict each beak cross
section. The beak should now match our sketch.

Import Body Parts

We now have 3 separate files. We will need to import them into one
scene to create our finished character.

1. Import the eye model.
Use the menu item to import the
eye model.
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Position and Scale the Eyes

Like the beak, the eye is a too big for the body. We will need to
reposition and resize it to fit.

1. Move the eye.
In the Front view, use the Control > Move tool to position the
eye as shown.

2. Scale the eye.
Enable the Z Axis constraint. Use the Pan and Zoom tools to
zoom in on the head as shown. Use the Control > Scale tool
to resize the eye.
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3. Move the eye.
Use the ( ) menu item to open the

dialog. Remove the negative sign from the
parameter, moving the eye to the right of center

in the Front view.

4. Create the right eye.
Use the ( ) menu item to create a
duplicate of the eye. In the dialog, add a
negative sign in front of the parameter, moving
the eye to the left of center in the Front view. Change this
object’s name to right_eye.
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Check Our Work And Save

Let’s see what we’ve got and save our current state to disk.

1. Render Milty.
Use the ( ) menu item to render our
character.

2. Save.
Use the menu item to save our composited
character to disk. Name the file milty.
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Model The Legs

Now that we’ve got the head done, let’s concentrate on his legs.

1. Create a cylinder.
Use the Shape > Cylinder tool to open the

dialog. Set the parameters as shown and
click .

2. Rotate the leg 90°.
In the palette, set the parameter to
90. Make sure the cursor is inside the palette and type the

key to apply.

3. Position the leg.
In the Front view, position the leg as shown.
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4. Set our constraints.
Set the axis constraints as shown.

5. Merge the leg and body.
Select the Reshape > Collide tool. Click and drag a marquis
as shown to pick the body.

The dialog will open. Click .

6. Make the left leg.
Select the Reshape > Flip tool. The dialog will
open. Set the parameters as shown and click ..
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Check Our Work And Save

Let’s see what we’ve got and save our current state to disk.

1. Render Milty.
Use the ( ) menu item to render our
character.

2. Save.
Use the menu item to save our composited
character to disk. Name the file milty.
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Tutorial 4: Blend Surfaces

Launch PiXELS:3D

If PiXELS:3D is already running on your machine, choose the 
( ) menu item now.

1. Launch PiXELS:3D.
In the Finder, locate the PiXELS:3D application icon.  Double
clicking on this icon will launch PiXELS:3D.

Import Background Images

As in tutorial 1, we will use pencil sketches as guides.

1. Open the dialog for the front view.
Click on the word Front in the title bar of the lower left
viewing pane. This opens the dialog.

2. Open the dialog.
Select the checkbox, then click on the empty box to
the right of the checkbox to open the 

dialog.
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3. Load a background image.
Click on any empty box. The standard file dialog will open.
Navigate to the sketches folder located inside the tutorials
folder. Open the file inside titled milty_wing_front. Click the

button to open this texture. Click the button in the
dialog to return to the 

dialog. Click the button in the dialog to
return to PiXELS:3D.

4. Repeat for top view.
Repeat steps 1 - 3 for the top view, this time loading the file
titled milty_wing_top.
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Trace Templates

Now that we have our background images loaded, we can use them as
templates to trace the wing.

1. Select the Shape > Spline tool.
Click on the Shape tool group. Select the Spline tool. The

dialog will open. Select the option
and click .

2. Trace the top-right template.
In the top view, working top to bottom, trace the right half of
the wing only. Double click to finish drawing the spline. If the
double click doesn’t take, type the key. Using the

palette, rename this spline wing_right.
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3. Trace the top-left template.
In the top view, working top to bottom, trace only the left half
of the wing. Double click to finish drawing the spline. If the
double click doesn’t take, type the key. Using the

palette, rename this spline wing_left. We should
have 2 separate splines outlining the top contours of the
wing.

4. Trace the front-top template.
In the front view, working left to right, trace only the top half
of the wing. Double click to finish drawing the spline. If the
double click doesn’t take, type the key. Using the

palette, rename this spline wing_top.
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5. Trace the front-bottom template.
In the front view, working left to right, trace only the bottom
half of the wing. Double click to finish drawing the spline. If
the double click doesn’t take, type the key. Using the

palette, rename this spline wing_bottom. We
should have 2 separate splines outlining the front contours
of the wing, for a total of 4 splines outlining the wing.

6. Create the top of the wing.
Select the Shape > 4-Side Blnd tool. The 
dialog will open. Set the parameters as shown and click .

Note: We are not changing the name of the object. If you
prefer, you could change the name to wing.
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7. Create the bottom of the wing.
Select the Shape > 4-Side Blnd tool. The 
dialog will open. Set the parameters as shown and click .

8. Check the bottom wing’s normals.
Select the ( ) menu item. The
surface normals will appear. They show us which direction
the selected patch is facing.
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9. Check the top wing’s normals.
Select the top half of the wing. Notice how the normals are
facing inward, unlike the bottom half of the wing.

10.Flip the top wing’s normals.
Use the Reshape > Invert tool to flip the surface normals for
the selected object.
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11. Join the top and bottom halves.
Select the Reshape > Join tool. Click any vertex on the
bottom half of the wing to pick it. The dialog
will open. Make sure the parameters are set as shown and
click .

12.Pinch the wing tip.
Select the X Axis and Z Axis constraints to deactivate them.
The Y Axis should be the only axis constraint active. Set the
flex settings as shown.

Use the Reshape > Pinch tool to pinch the wing tip closed
on one end as shown.
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13.Delete everything else.
Use the ( ) menu item to hide the
completed wing. Select and delete the bottom half of the
wing and each of the boundary splines. Use the 

( ) menu item to make the wing visible again.

14.Render the wing.
Use the ( ) menu item to render the
wing. Click the mouse button to return to PiXELS:3D.

15.Save the model.
Choose the ( ) menu item.
Save the model in the milty folder. Name the model wing.
Quit PiXELS:3D.
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Tutorial 5: Articulation

Launch PiXELS:3D

If PiXELS:3D is already running on your machine, choose the 
( ) menu item now.

1. Launch PiXELS:3D.
In the Finder, locate the PiXELS:3D application icon.  Double
clicking on this icon will launch PiXELS:3D.

Add The Wing To The Body.

1. Open the milty model.
Use the ( ) menu item to load the milty
scene.

2. Import the wing model.
Use the menu item to import the
wing model.

Size And Position The Wing.

The imported wing is too large, and is improperly oriented. We will need
to rotate, scale and position the wing to fit the body.

1. Rotate the wing.
Use the ( ) dialog to set the and

as shown..
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2. Park the rotations.
Use the Control > Park tool to realign the rotated wing with
world space.

3. Size the wing.
Use the Control > Scale tool to size the wing as shown.

4. Park the wing.
Use the Control > Park tool to realign the scaled wing with
world space.

PiXELS:3D Tutorials

4.40 PiXELS:3D



Articulate The Wing.

If we want to animate the wing doing anything other than simple
movements or rotations, we will need to articulate it. We do this by
adding an Inverse Kinematic (IK) Chain to the wing.

1. Create an IK chain.
Use the Shape > IK Chain tool to draw an IK Chain as
shown.

2. Name the IK chain.
The dialog will open. Set the 
parameter to: wing_ik.
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3. Switch to Schematic view.
Open the dialog for the Front view. Select

from the pop-up menu. Click the 
button.

4. Select the wing.
Hold down the key and click on the Blend_8 (or
wing) tile in the Schematic view to select it.

PiXELS:3D Tutorials

4.42 PiXELS:3D



5. Link the wing to the IK Chain.
Select the Control > Link/Unlink tool. In the Schematic view,
click on the wing_ik_root tile.

The dialog will open. Click the button.

Notice how the Blend_8 tile is now positioned under the
wing_ik tile. This indicates that Blend_8 is now a child of
wing_ik. The Blend_8 tile can be manually repositioned. In
fact, any tile can be moved in the Schematic view without
effecting the model it represents. Use the Control > Move
tool to move a tile.
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6. Set up the constraints.
Click on the V Col and Tag constraints to select them.

7. Tag some points.
In the right view, -click and drag a rectangle as shown to
tag all the points on the 2nd and 3rd v step.

8. Link these points to the 1st joint in the IK Chain.
In the Schematic view, click on the wing_ik_jnt1 tile to pick it.
The tagged points will link to this joint.
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9. Tag some more points.
In the right view, -click and drag a rectangle as shown to
tag all the points on from the 4th v step down.

10.Link these points to the 2nd joint in the IK Chain.
In the Schematic view, click on the wing_ik_jnt2 tile to pick it.
The tagged points will link to this joint.
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11.Weight the v steps around the 1st joint.
Open the ( ) palette. -click and drag a
rectangle, selecting all the points in the 2nd v step. Set the

slider to 0.33.

-click and drag a rectangle, selecting all the points in the
3rd v step. Set the slider to 0.66.
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12.Weight the v steps around the 2nd joint.
-click and drag a rectangle, selecting all the points in the

4th v step. Set the slider to 0.25.

-click and drag a rectangle, selecting all the points in the
5th v step. Set the slider to 0.5.

-click and drag a rectangle, selecting all the points in the
6th v step. Set the slider to 0.75. Close the

palette.
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Pose The Wing.

Now that the wing is articulated, it can easily be posed.

1. Set up the constraints.
Click on the Point constraint to select it. Click on the Tag
constraint to deselect it.

2. Switch to Front view.
Open the dialog for the Schematic view.
Select from the pop-up menu. Click the 
button.

3. Pose the wing.
In the Front view, select and move wing_ik_root as shown.

Select and move wing_ik_jnt1 and wing_ik_jnt2 as shown.
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Create And Pose A Second Wing.

1. Switch to Schematic view.
Open the dialog for the Right view. Select

from the pop-up menu. Click the 
button.

2. Select the parent of the wing hierarchy.
In the Schematic view, -click on the wing_ik_root tile. It will
indent when selected.

3. Duplicate the entire wing.
Use the menu item to create a
copy of the entire wing. -click on the new wing_ik_root tile.
It will be below the original in the Schematic view.
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4. Position the new wing.
Open the ( ) palette. Type a minus sign in
front of the parameter. Rename to wing2_ik_root.
Note: it may be helpful to organize the various wing
components in the schematic view, placing the right wing to
the right of center and the left wing to the left of center.

Repeat this for wing_ik_jnt1 and wing_ik_jnt2. Rename
these to wing2_ik_jnt1 and wing2_ik_jnt2.

5. Render and save.
Use the ( ) menu item to check the
appearance of Milty. Save the current scene as milty 2.
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Articulate The Body.

If we want to animate the body doing anything other than simple
movements or rotations, we will need to articulate it. We do this by
adding an IK Chain to the body.

1. Create an IK chain.
Use the Shape > IK Chain tool to draw an IK Chain as
shown.

2. Name the IK chain.
The dialog will open. Set the 
parameter to: backbone_ik.
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3. Rename the body.
-click on the body to select it. In the palette,

change the name from Untitled to body.

4. Link the body to the IK Chain.
Select the Control > Link/Unlink tool. In the Schematic view,
click on the backbone_ik_root tile.

The dialog will open. Click the button.
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5. Set up the constraints.
Click on the V Col and Tag constraints to select them.

6. Tag some points.
In the Front view, -click and drag a rectangle to tag all the
points shown.

7. Link these points to the 1st joint in the IK Chain.
In the Schematic view, click on the backbone_ik_jnt1 tile to
pick it. The tagged points will link to this joint.
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8. Tag and Link points to the 2nd joint in the IK Chain.
In the Front view, -click and drag a rectangle to tag all the
points indicated. In the Schematic view, click on the
backbone_ik_jnt2 tile to pick it. The tagged points will link to
this joint.

9. Tag and Link points to the 3rd joint in the IK Chain.
In the Front view, -click and drag a rectangle to tag all the
points indicated. In the Schematic view, click on the
backbone_ik_jnt3 tile to pick it. The tagged points will link to
this joint.

PiXELS:3D Tutorials

4.54 PiXELS:3D



10.Weight the v steps around the 1st joint.
Open the ( ) palette. -click and drag a
rectangle, selecting all the points in the v step just below the
1st IK joint. Set the slider to 0.25.

-click and drag a rectangle, selecting all the points in the v
step directly over the 1st IK joint. Set the slider
to 0.5.

-click and drag a rectangle, selecting all the points in the v
step just above the 1st IK joint. Set the slider
to 0.75.
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11. Weight the v steps around the 2nd joint.
-click and drag a rectangle, selecting all the points in the v

step just below the 2nd IK joint. Set the slider
to 0.25.

-click and drag a rectangle, selecting all the points in the v
step directly over the 2nd IK joint. Set the slider
to 0.5.

-click and drag a rectangle, selecting all the points in the v
step just above the 2nd IK joint. Set the slider
to 0.75.
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12.Weight the v steps around the 3rd joint.
-click and drag a rectangle, selecting all the points in the v

step just below the 3rd IK joint. Set the slider
to 0.25.

-click and drag a rectangle, selecting all the points in the v
step directly over the 3rd IK joint. Set the slider
to 0.5.

-click and drag a rectangle, selecting all the points in the v
step just above the 3rd IK joint. Set the slider
to 0.75.
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Link Parts To Body.

The wings and the body are now articulated, but if we move the body
the wings will not remain attached. To correct this, we need to link the
wing’s IK chain to the body’s IK chain.

1. Setup constraints.
Click on the Tag constraint to deselect it.

2. Link the wing to the body.
In the Schematic view, -click on the wing_ik_root tile.
Select the Control > Link/Unlink tool. In the Schematic view,
click on the backbone_ik_jnt1 tile.

The dialog will open. Click .

Repeat this for the duplicate wing_ik_root.
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3. Rearrange Schematic view.
As objects are linked, the Schematic view will adjust to
indicate changes in the hierarchical relationships between
objects. It is often necessary to rearrange object tiles to
accommodate your workflow. Arrange the tiles as shown.

4. In the Schematic view, -click on the beak tile. Select the
Control > Link/Unlink tool. In the Schematic view, click on
the backbone_ik_jnt3 tile.

An alert dialog will open. Click the button. The 
dialog will open. Click the button.
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5. Link the eyes and legs.
Link both eyes to backbone_ik_jnt3. Link both legs to
backbone_ik_root. Arrange the tiles as shown.

6. Save.
Save the scene as milty_3.

Do not quit the application.
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Tutorial 6: Texture

Export A Tag Map Of The Body.

1. Switch to Right view.
Open the dialog for the Schematic view.
Select from the pop-up menu. Click the 
button.

2. Set up the constraints.
Click on the Point constraint to select it.
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3. Tag some points.
In the Right view, -click and drag a rectangle to tag all the
points shown.

4. Export a tag map.
Use the menu item to export a
PICT image depicting all the tagged points on the currently
selected object. Name the image bellyTag.PICT.
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Use The Tag Map To Create A Texture Map.

1. Open the tag map in an Image editor.
Open bellyTag.PICT in your favorite image editor. For this
tutorial we will use PhotoShop™. Select the marquee tool.
Change the marquee shape to elliptical.

2. Marquee the tagged points.
Use the marquee tool to select the tagged points as shown.
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3. Set the foreground and background colors.
Click on the icon to set the foreground color to black and
the background color to white.

4. Fill the selection.
Fill the selection with the background color.
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5. Fill the inverse selection.
Invert the selection. In PhotoShop™ use the

menu item. Fill the inverse selection with
the foreground color.

6. Save the image.
Save the texture map as belly.PICT. Make sure the format is
set to PICT.
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Apply The Texture Map.

1. Open ShaderMaker.
Quit PhotoShop™. If PiXELS:3D is not running, launch it now
and load the milty 3 scene. Select the body. Use the

menu item to open the
dialog.

2. Open the Texture Manager.
Select from the first pop-up menu.
The dialog will open.
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3. Open the texture map.
Click on any empty tile. The standard file dialog will open.
Select the belly.PICT file and click . Click in the

dialog.

The dialog will open. Click . Click in the
dialog to return to PiXELS:3D.

4. Shade the Wings.
Set the diffuse color for both wings and both legs to black.
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Render And Save.

1. Set render options.
Use the ( ) menu item to open the

dialog.

2. Change the background color.
Click in the color swatch. The Apple color
picker will open. Select a light blue color. Click to accept.
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3. Render and save.
Use the ( ) menu item to check the
appearance of Milty. Save the current scene as milty 5.
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Tutorial 7: More Modeling

Launch PiXELS:3D

If PiXELS:3D is already running on your machine, choose the 
( ) menu item now.

1. Launch PiXELS:3D.
In the Finder, locate the PiXELS:3D application icon.  Double
clicking on this icon will launch PiXELS:3D.

Model Milty’s Boots

1. Create a cylinder.
Use the Shape > Cylinder tool to open the

dialog. Change the parameter to
boot. Click .

2. Rotate the cylinder.
Use the menu item to open the

palette. Change the parameter to
90. Type to apply.
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3. Position the cylinder.
Select the Control > Move tool. Deactivate the X Axis and
Z Axis constraints, leaving the Y Axis active.

Position the cylinder as shown.

4. Create a sphere.
Use the Shape > Sphere tool to open the 
dialog. Click .

5. Scale the sphere.
Select the Control > Scale tool. Reactivate the X Axis,
leaving the Z Axis inactive.

Scale the sphere as shown.
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6. Clip the sphere.
Use the Reshape > Clip tool to open the 
dialog. Select the and options. Click .

7. Collide the sphere and cylinder.
Select the cylinder. Select the Reshape > Collide tool. Click
on the sphere to pick it. The dialog will
open. Select the , and options.
Click .

8. Close the boot.
Use the Reshape > Close Ends tool to open the

dialog. Select the 
parameter. Click .

9. Save.
Save the scene as boot.
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Tutorial 8: Multiple Articulation
It is possible to articulate a single patch with multiple IK chains. In this
tutorial we will examine this technique and use it to articulate Milty’s
legs and feet, as well as a small portion of his body.

Launch PiXELS:3D

If PiXELS:3D is already running on your machine, choose the 
( ) menu item now.

1. Launch PiXELS:3D.
In the Finder, locate the PiXELS:3D application icon.  Double
clicking on this icon will launch PiXELS:3D.

Import Boot

1. Open the body model.
Use the ( ) menu item to load milty 5.

2. Import the boot model.
Use the menu item to import the
boot model.

PiXELS:3D Tutorials

PiXELS:3D 4.75



Position Boots

3. Scale and rotate the boot.
Use the ( ) menu item to open the

palette. Change to -90, to
0.5, to 0.25, and to 0.5.

4. Switch to Right view.
Open the dialog for the Schematic view.
Select from the pop-up menu. Click the 
button.

5. Position and rename the boot.
Use the palette to change ,

and as shown.

6. Duplicate the boot.
Use the ( ) menu item to duplicate the
boot. Change and as shown.
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Articulate Boots

1. Create an IK Chain.
Use the Shape > IK Chain tool to draw an IK Chain as
shown. Click in the dialog to accept
the default name.

2. Repeat for the other leg.
Use the Shape > IK Chain tool to draw an IK Chain as
shown. Click in the dialog to accept
the default name.
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3. Link boot to IK Chain.
Select the first boot. Select the Control > Link/Unlink tool.
Click and drag a rectangle as shown to pick the IK Chain.

The park alert will open. Click .

The dialog will open. Click .

Repeat this for the second boot, linking it to the second IK
Chain.
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Articulate Legs

1. Hide both boots.
Use the ( ) menu item to both of
the boots.

2. Setup constraints.
Setup the constraints as shown.

3. Tag some points.
-click and drag a rectangle as shown.

Link these tagged points to the first leg IK Chain.

4. Repeat on left leg.
-click and drag a rectangle as shown.

Link these tagged points to the second leg IK Chain.
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5. Weight the leg’s points.
Tag and weight the right leg’s control points as shown.

Repeat this procedure for the left leg.
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Articulate Body

1. Select the body.
Use the menu item until the body is
selected (highlighted).

2. Tag some points.
-click and drag a rectangle to select the points indicated.

Link these points to the right leg IK Chain.
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3. Weight the body’s points.
Tag and weight the right body’s control points as shown.

Repeat this procedure for the left side of the body.
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4. Render and save.
Use the ( ) menu item to check the
appearance of Milty. Save the current scene as milty 6.
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Congratulations!

You have just created a fully articulated digital actor. What you do from
here is up to you and your imagination.

Additional training material will be periodically made available.
Check www.pixels.net or call (619) 672-2634 for more information.

PiXELS:3D Tutorials

4.84 PiXELS:3D



PiXELS:3D Views

PiXELS:3D 5.1

Base hue on a procedural function

Notice how the three inputs change. Instead of saying r, g and b they
now say h, s and v. These are short for hue, saturation and value.
Select from the hue pop up menu (the one labeled ).

The dialog will appear.

Click to accept this and return to the parent node— .
Click twice more to apply this shader to the current object.

Select the menu item to see how your shader
looks on the cylinder. You have just created your first shader.
Congratulations!

Review

To really get a feel for the power of ShaderMaker we encourage you to
experiment. Go back to the node and change some of the
other sliders, or go one level deeper and play with the node.
You’ll be amazed at the effects you can attain with this simple shader.
One important thing to note is that we didn’t use the node to
define the color of the object, as one might expect. Instead we used

to perturb the hue of a node. What would our
shader look like if we used or to perturb the hue? Try it
and see.

What Next?

For more technical information on procedural shaders, read Texturing
And Modeling, A Procedural Approach by David S. Ebert, et al. (AP
Professional, 1994).
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Views
The viewing area of the PiXELS:3D display by default contains four
viewing panes: Top, Front, Right, and Camera views. The Top, Front
and Right views present a 2D representation of the object(s) from the
corresponding viewpoint. The Camera view is unique in that it
represents the point of view of an object as it exists in PiXELS:3D’ 3D
space. As you manipulate and edit an object, you can see the changes
occur in each window.

Each viewing pane has a number of controls that you can access. Let’s
look at each these.

Sizing

Any of the four viewing panes can be resized in one of two
ways. The first is to click on the “+” sign that is located where
all four viewing panes meet in the center of the interface.
While holding the mouse button down, you can drag this

around to resize all four views simultaneously. Holding the Option key
down while clicking on the “+” sign, will reset all four views back to their
default sizes. The second way to resize the views is to click on any
view’s Zoom Box.



PiXELS:3D Views

5.6 PiXELS:3D

Zoom Box

The Zoom Box can be found in the upper right hand corner of
each view’s title bar. It looks like two intersecting squares.
Clicking in this Zoom Box fills the viewing area with that view.
Any view can be set to fill the viewing area by clicking in its

Zoom Box, including the Camera view. If you hold the Option key down
while clicking in a Zoom Box, the view will zoom horizontally, but not
vertically. This can be useful when working on wide objects or when
using the Twist & Taper view.

Deactivate

Any view can be deactivated by clicking on the first icon from
the left in that view’s title bar. The title bar will dim and that
view will no longer refresh, speeding the refresh of all other
views.

Perspective

Perspective can be turned on or off by clicking on the second
icon from the left in that view’s title bar. When perspective is
on, PiXELS:3D will show objects “realistically” from that
view’s particular point of view. The edges of objects will

converge on a central vanishing point and objects closer to the viewer
will appear larger than objects farther away. Any view can have
perspective either on or off. When modeling, it is usually better to work
without perspective in the top, front and right views.

Grid

Click on this icon to show or hide a visible grid in the top,
front or right views. The dimensions of the grid can be set in
the dialog, or by using the gridsize command
in the window (which can be opened by

selecting Control > Command).

Zoom In/Out

Use this icon to zoom into or out of a view. To use, click on
the icon and drag the mouse up to zoom out or down to zoom
in. The distance from the original mouse click controls the
speed of the zoom. In the Camera view, zoom moves the

Camera forward and back along the line of sight.
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Pan

Use this icon to pan around a view. To use, click on the icon
and drag the mouse up, down, left or right. The view will
move in relation to the mouse. The distance from the original
mouse click controls the speed of the pan.

Orbit (Camera view only)

Use this icon to orbit the Camera around the interest. To use,
click on the icon and drag the mouse up, down, left or right.
The Camera will orbit in relation to the mouse. The distance
from the original mouse click controls the speed of the orbit.

Surface (Camera view only)

Use this icon to toggle between hull and surface view.
Surface view provides a more accurate representation of an
object, but takes longer to draw.
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View Options

Each of the four viewing panes have a number of different
options that can be set. To access the dialog
box, click on the name of the viewing pane that you want to
effect. The name can be found in the left corner of the bar

at the top of each viewing pane. Any changes that you make to the
dialogue box are saved with the current scene and will

be reinstated when that scene is loaded from disk.

Let’s look at each of the options that can be set for the 
dialogue box.
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View

When clicked on, this pop-up menu lists optional views that the selected
viewing pane can display. Any view except the Camera view can be
changed. You can select from the following view options: 

Top View
Front View
Right View
Schematic View—discussed at the end of this chapter
ShaderMaker View—discussed at the end of this chapter
Twist & Taper View—discussed at the end of this chapter

Depthcue

The Depthcue options draws wireframes which fade to the Background
as the distance from the Camera approaches the Outer Radius.

Inner Radius

Distance from the Camera where wireframes begin to fade.

Outer Radius

Distance from the Camera where wireframes are 100% Background.

Background

Every view has a background color. Clicking in the box to the right of
the Background title will open the Apple color picker, allowing you to set
the background color.

Image

Any view can also have a PICT image as a background. This is helpful
when modeling something from a scanned image (i.e. take photos of an
object from the top, front and right) or for placing a computer model into
a real scene. PICT sequences can also be used for rotoscoping. Click on
the box to the right of the Image check box to open the Texture Manager
dialog. See the ShaderMaker section for more details.

Visible Grid

When checked, this option shows this viewing pane’s grid. When
unchecked, the grid will be hidden.
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Grid Size

Sets the size of the visible grid in PiXELS:3D units. The 
option must be checked before the grid can be seen.

Grid Color

Clicking on this box opens the Apple color picker, allowing you to set
the color of the grid lines.

Grid Major

Clicking on this box opens the Apple color picker, allowing you to set
the color of the center or origin grid lines (the ones which intersect at
0,0).

Visible Axis

When checked, this option shows the axis reference icon in the lower
left corner of this viewing pane. When unchecked, the axis reference
icon will be hidden.

Clipping

When checked, portions of objects which are closer than Near Plane or
farther than Far Plane are invisible or clipped. This makes working with
complex scenes much easier, allowing you to focus on a single object
or even a portion of that object.

Absolute/Relative

When the option is selected, the clipping planes are
considered to be absolute (world space) coordinates.
When the option is selected, the clipping planes are
considered relative to the Camera, so as you dolly in and out, different
portions of the scene appear and disappear.
These options are a Radio Group, which means selecting one will
automatically deselect the other. Both cannot be selected at one time.

Near Plane

When is selected, this value defines how close an object can
be to the Camera before being clipped.
When is selected, this value defines the minimum position
where, along the orthogonal (perpendicular) axis to this viewing plane,
objects are visible.
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Far Plane

When is selected, this value defines how far an object can be
from the Camera before being clipped.
When is selected, this value defines the maximum position
where, along the orthogonal (perpendicular) axis to this viewing plane,
objects are visible.
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Special Views

Each of the viewing panes for the top, front and right views can display
one of the following special views: The Schematic View, The
ShaderMaker View or The Twist & Taper View. Let’s examine each of
these.

Schematic View

The Schematic View allows you to view the hierarchical structure of
your scene. Each object is displayed as a small box, with its name
printed inside the box. To the left of the name is the object’s wireframe
color. Objects can be selected from this view, making object selection
much easier in complex scenes. The arrows that connect each object
are color coded. Green arrows show objects that are linked together
with a parent / child relationship, blue arrows show an object’s point of
interest, red arrows show a motion path that an object will follow, while
magenta arrows point to a lattice that will deform an object.
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ShaderMaker View

The ShaderMaker View allows you to view the hierarchical structure of
the currently selected object’s shader nodes. Clicking on a node will
open the options dialog for that node. Clicking on the first node will
open ShaderMaker. Having the ability to see the different nodes that
make up a shader, and being able to access the dialogue box for any of
them, allows you to quickly make changes to a shader.
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Twist & Taper View

The Twist & Taper view is a powerful feature for freeform reshaping of
objects. It allows you to scale and rotate part of an object by moving
four control points along the objects central spline. 

The Twist & Taper View displays a blue (upper) curve that defines the
object’s scale at any given point from front (0) to back (1) and a red
(lower) curve that defines the twist. Dragging any point on the upper
curve will taper, flare and bulge the selected object, while dragging on
the lower curve twists it.
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New
Creates a new, unnamed PiXELS:3D file using default settings to begin
model creation.

1. Choose from the menu or type .
2. An untitled window appears on the screen with the tool

palette on the left, ready to begin. A typical session begins
by choosing or importing a shape. (see Tools > Shape or

.)

A n e w, untitled scene.
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Open
Opens an existing PiXELS:3D file and displays it on the screen. Closes
the file on the screen before opening another.

1. Choose from the menu or type 
2. A dialog box appears listing files in the selected folder that

can be opened from PiXELS:3D. Select a file name from the
list and click or click to abort.

3. A PiXELS:3D file can also be opened directly from the
desktop by double clicking its icon.

The standard Apple open dialog.
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Import
Merges external model or motion data with the current PiXELS:3D
scene.

1. Choose from the menu and drag the mouse to
select and highlight the desired format.

2. Find the folder in which the file to be imported is located.
3. Highlight the desired file, and click . PiXELS:3D opens

the file and displays it on the screen.

Illustrator Import Options

Linearize Spline

When checked, converts Bézier splines to linear splines.

Flatness

Sets the number of subdivisions used when converting Bézier splines to
linear splines. The lower this value, the smoother your curves will
appear. The value is a tolerance in degrees.

Extrude Imported Art

When checked, all of the imported outlines will be extruded. Trim
surface end caps are automatically created and placed. Compound
objects are also detected, so holes in letters are created automatically.
This is very useful for logos and text.
See the Shape > Extrude tool in the Tools section for more details about
the various extrude options.
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Importing Dynamation Files

Dynamation is Wavefront’s high-end particle animation system for
Silicon Graphics workstations. Although some users won’t have access
to this system, the format which it exports provides a very
straightforward way of describing generic particle data. The following
information is provided for those of you who wish to write out
Dynamation files.

A Dynamation file is simply an ASCII file containing the position and,
optionally, directional vector information for any number of particles.
Each file contains only one frame of information, so more often than
not, multiple files will be needed. Each file has a numeric suffix to define
its position in time. A typical file name might be something like
“SwarmOfBees.00001” where 00001 would be the frame number.

The Dynamation File Format

A simple Dynamation file may look something like this:
4  6  5  0  0  1
This is a particle definition. The first three numbers define a particle’s
position in space (x, y and z respectively.) The next three numbers
represent a directional vector. This is simply a line which points in the
direction the particle is heading. Because lines need at least two points
to properly define them, in a direction vector it is assumed that the first
point in the line is {0, 0, 0}. Currently the directional vector is assumed
to be normalized. In other words the total length of the line is 1 unit.
Future versions may use this directional vector to define where a
particle was and where it is going. In this case, the vector would not be
normalized.

For each particle in a scene there should be one particle definition like
the one above. Each particle definition, except the last one, should be
followed by a return character.

When PiXELS:3D imports a Dynamation file, it duplicates the currently
selected object or hierarchy and places it according to the x, y, z
information contained in the Dynamation file. For each particle definition
a new copy of the selected object is created. Once all the particle
definitions are read, PiXELS:3D goes to the next file in order. No more
copies of the object are created. Instead the positional information is
added to the object’s fCurves. This process is repeated until the last file
is read in or the maximum number of keyframes is reached.
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BVA Import Options

Sample Every n Frame(s)

Imported motion data will be sampled every n frames. The function
curve generated is smoothed using all the imported data, but control
points are spaced out giving the animator some room to manipulate the
imported data.

DXF Import Options

Exchange Y and Z

Some modeling systems use a coordinate system that differs from the
one used by PiXELS:3D. This option is used to correct for that.

Smooth Normals

If checked, PiXELS:3D will automatically smooth all normals for shared
vertices.

Scale

Sets the scaling factor for the imported model. (i.e. 0.5 = 50%)
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Smooth Limit

Defines the breaking point (in degrees) for smoothed polygons. If the
angle between adjacent polygons is greater than this value, their
normals will not be shared. If the angle is less than or equal to this
value, the normals will be averaged and shared.

OBJ Import Options

Exchange Y and Z

Some modeling systems use a coordinate system that differs from the
one used by PiXELS:3D. This option is used to correct for that.

Use Existing Normals

If present, use the normals defined within the file, otherwise recompute
them.

Scale

Sets the scaling factor for the imported model. (i.e. 0.5 = 50%)

Smooth Limit

Defines the breaking point (in degrees) for smoothed polygons. If the
angle between adjacent polygons is greater than this value, their
normals will not be shared. If the angle is less than or equal to this
value, the normals will be averaged and shared.
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Export
Saves a PiXELS:3D document in DXF, RIB, 3DGF or 3DMF formats for
use with other software applications. Optionally exports a PICT map of
the surface to aid in the creation of texture maps.

1. Open or create a PiXELS:3D file. 
2. Choose t from the menu and drag the mouse to

select and highlight the desired format. 
3. In the dialog box, type in a name for the file to be exported.
4. Click , or click to return to the model without

creating an export file. 
5. Choose export options for DXF and 3DGF formats.

DXF Export Options

Subdivide

Breaks the object down into finer polygons before exporting. The
resolution is set in the palette, using the and 

edit fields. (See or
for more info on this.)

Scale

Sets the scaling factor for the exported model. (i.e. 0.5 = 50%)
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Tag Map Export

1. Using the tag tool, select key points on a model’s surface.
(i.e. eye sockets)

2. Select . This creates a PICT file
representing the surface of the model, with tagged points
marked as red squares.

3. Import the PICT into your favorite paint package. Use the
tagged points as a reference for painting. (i.e. Paint eyes
where the eye sockets are.)

3DGF Export Options

Splines

Retains spline information when exporting. Splines not supported by
3DGF are converted to the closest supported spline.

Polygons

Converts splines to a linear basis when exporting. Some applications do
not directly support splines, so this option can be used along with the

option to smooth models.
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Subdivide

Breaks the object down into finer polygons before exporting. The
resolution is set in the palette, using the and 

edit fields. (See or
for more info on this)

Scale

Sets the scaling factor for the exported model. (i.e. 0.5 = 50%)
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Save
Saves changes made to the open model to a disk file. If no file has
been created for the model, behaves just like .

1. Choose from the menu or type .
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Save As

Saves a new PiXELS:3D file or saves an existing one under a new
name without overwriting the original version.

1. Choose from the menu. 
2. A dialog box appears showing the default file name: Untitled

Model. Type in a new file name. 
3. Choose the folder and disk on which you want the document

saved. 
4. Click , or click to abort.
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Revert To Saved
Discard any changes you have made to your model since the last time
it was saved.

1. Choose from the menu.
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Render Setup
Sets the various rendering options.

1. Choose from the menu or type
U.

2. Set the parameters as desired.
3. Click the button to accept or the button to abort.

Render Setup Options

Let’s look at each of the options that can be set for the 
dialogue box.
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Renderer

Use this pop-up menu to select the rendering method you wish to use.
PiXELS:3D has four rendering methods to choose from:

Wireframe: The simplest and fastest rendering technique, it shows only
the transparent outline of forms.

Flat Shade: Gives the surface a faceted appearance to approximate the
shape. Fast, but low quality renderings—good for previews.

Gouraud Shade: Renders a smooth, diffuse object by interpolating
shading values between vertices. Not as fast, but higher quality to help
see the details.

Phong Shade: Renders a smooth, specular object by interpolating
normals between vertices. The highest quality renderings, takes longer
but worth it! Use for final rendering to achieve broadcast quality images.
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Image Size

A pop-up menu which lists common image formats. You can select one
of the predetermined image sizes or select the menu item to
manually enter any size.

Pixel Aspect Ratio

Some devices use non-square pixels:3d (such as NTSC television).
This option ensures compatibility of images with these devices. The
ratio is automatically determined for you based on the image size that
you selected.

Scale

A scaling factor to apply to the image when rendering. (i.e. 400x400
with a scale of 0.5 will render at 200x200)

Image Name

The name to be applied to the final rendering when saved.

Current Frame

Renders the current frame only (still image).

Range of Frames

Renders a range of frames (animation). The frame range is set using
the two edit fields immediately below this button. The first edit field is
the start frame # and the second edit field is the end frame #.

Step

Forces the renderer to render every nth frame.

fps

Sets the number of frames needed to create one second of finished
animation. (frames per second)

Background, Ambience & Fog Colors

Uses the Apple color picker to define a background, ambience or fog
color. The background color is merely placed behind rendered images.
The ambient color is a ‘global’ illumination present in all rendered
scenes. The fog color is used when calculating fog in a scene.
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Fog

Enables the fog option for the Flat, Gouraud and Phong renderers.

Inner Radius

Sets a radius around the Camera inside which fog has no effect.

Outer Radius

Sets a radius around the Camera outside which fog has a maximum
effect. All points between the inner radius and outer radius will be
effected by fog based on their distance from the viewer.

Motion Blur

Enables the motion blur option for the internal renderer. Motion blur is
caused by the exposure of a moving object over time.

Shutter Speed

Defines a percentage of time between frames during which the aperture
is open. A higher value causes greater motion blur. A value greater than
one (1) can have unpredictable results and should not be used.

Samples

Defines the number of samples used over time to render one pixel.
Higher sampling rates will result in smoother motion blur, but will require
longer rendering times.

Depth of Field

Enables the depth of field option for the internal renderer. Depth of field
causes objects over a certain range of depth to appear in focus, while
objects outside that range appear blurred.

fStop

Defines the size of the aperture opening on the Camera. A higher value
results in a less pronounced depth of field, while values closer to zero
produce a more exaggerated depth of field. Common values range from
1.2 to 22.
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Anti-alias Sample Rate

Sets the number of sub-pixel samples to average together when anti-
aliasing. Higher values result in better anti-aliasing but require more
RAM and time to render.

Backface Culling

When selected, this feature accounts for all surfaces that can not be
seen from the Camera’s perspective and removes any related rendering
calculations for them. This speeds up rendering time.

Invisible Shadows

Enabling this feature allows shadows to be rendered from an object that
is invisible, providing that the shadow casting feature for that object was
turned on in the palette.

Patch Subdivision

Divides the patches of all models in a scene into smaller pieces to
create more detailed, smoother models. Each model’s sub-division is
based on settings placed in the palette.

Render 2 Sided

When selected, this feature allows the insides of models that are
exposed to the Camera to be rendered.  However, use with caution as
this may cause aliasing.
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Quick Render
Uses the options defined in to render an image into the
Camera view.

1. Choose from the menu or type
.

2. To cancel a rendering in progress type a .
3. When you are finished looking at the rendering, click your

mouse anywhere to return to PiXELS:3D.
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Final Render
Uses the options defined in Render Setup to render a final image, or
series of images to disk.

1. Choose from the menu or type
.

2. To cancel a rendering in progress type a .
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Quit
Exits PiXELS:3D, returning you to the Macintosh desktop.

1. Choose from the menu or type .
2. If any unsaved changes have been made to the open file,

PiXELS:3D asks whether to save the changes before closing
the file.

3. Click to save changes, to ignore changes, or 
to return to the current model without exiting PiXELS:3D.
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Edit
Undo  . . . . . . . . . . . . . . . . . . . . . . .6.27
Cut  . . . . . . . . . . . . . . . . . . . . . . .6.28
Copy  . . . . . . . . . . . . . . . . . . . . . . .6.29
Paste  . . . . . . . . . . . . . . . . . . . . . . .6.30
Clear  . . . . . . . . . . . . . . . . . . . . . . .6.31
Proxy  . . . . . . . . . . . . . . . . . . . . . . .6.32

Proxy Options  . . . . . . . . . . . . . . .6.32
Proxy All . . . . . . . . . . . . . . . . . . . .6.32
Unproxy All  . . . . . . . . . . . . . . . . .6.32
Proxy Selected . . . . . . . . . . . . . . .6.32
Unproxy Selected  . . . . . . . . . . . .6.32

Hide Selected  . . . . . . . . . . . . . . . . .6.33
Hide Unselected  . . . . . . . . . . . . . . .6.34
Show All  . . . . . . . . . . . . . . . . . . . . .6.35
Duplicate  . . . . . . . . . . . . . . . . . . . . .6.36
Duplicate Hierarchy  . . . . . . . . . . . .6.37
Step & Repeat  . . . . . . . . . . . . . . . . .6.38

Step & Repeat Options  . . . . . . . .6.38
Step  . . . . . . . . . . . . . . . . . . . . . . .6.38
x,y,z Offset  . . . . . . . . . . . . . . . . . .6.38
x, y, z Scale  . . . . . . . . . . . . . . . . .6.38
x, y, z Rotation . . . . . . . . . . . . . . .6.38
Create Hierarchy  . . . . . . . . . . . . .6.38
Chain  . . . . . . . . . . . . . . . . . . . . . .6.39

Expand Hierarchy  . . . . . . . . . . . . . .6.40
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Undo
Reverses the most recent movement or repositioning applied to a
model.

1. Choose from the menu or type .
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Cut
Deletes the selected model and stores it on the Clipboard.

1. Select the object to cut.
2. Choose from the menu, or hit .
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Copy
Copies currently selected model into the Clipboard without changing the
original model.

1. Select the object to be copied.
2. Choose from the menu or type . The

item will be stored in the Clipboard for later use.
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Paste
Places the model copied to the Clipboard into the scene.

1. Choose from the menu or type .
2. The model will be pasted where it was when it was originally

copied.
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Clear
Deletes a selected model from the scene, leaving remaining models
unchanged. The clear command cannot be undone.

1. Select the object you wish to clear.
2. Choose from the menu or hit the key.
3. A dialog box alerts you that this operation is irreversible.

Click to confirm and delete, or click to abort.
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Proxy
Creates an approximation of the 3 D object to speed screen refresh.

Proxy Options

Proxy All

Proxies all models in a scene.

Unproxy All

Unproxies all models in a scene.

Proxy Selected

Proxies the currently selected model.

Unproxy Selected

Unproxies the currently selected model.
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Hide Selected
Hides the currently selected model.

1. Select the object you wish to hide.
2. Choose from the menu or type

.



PiXELS:3D Menus—Edit

6.36 PiXELS:3D

Hide Unselected
Hides all models except the currently selected model.

1. Select the object you wish to retain.
2. Choose from the menu or type

.
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Show All
Restore hidden parts of the model to the screen.

1. Choose from the menu, or type .
2. Any hidden objects will be made visible.
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Duplicate
Makes a clone of the currently selected model. The duplicate is placed
directly on top of its twin.

1. Select the object you wish to duplicate.
2. Choose from the menu or type .

A copy of the object will be pasted directly on top of the
original.

3. The duplicate is the currently selected model, so you can
now move, resize, reshape, etc... this object.
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Duplicate Hierarchy
Makes a clone of the currently selected model and all its children. The
duplicate is placed directly on top of its twin.

1. Select the parent of the hierarchy you wish to duplicate.
2. Choose from the menu. A copy

of the hierarchy will be pasted directly on top of the original.
3. The duplicate is the currently selected model, so you can

now move, resize, reshape, etc... this object.
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Step and Repeat
Copies an object and pastes it according to the offset instructions. The
object may be pasted as many times as desired.

1. Select the object you want to affect.
2. Choose from the menu.

Step and Repeat Options:

Step

The number of duplicates desired.

X, Y, Z Offset

Offset factor for x, y or z-axis.

X, Y, Z Scale

Scale factor for x, y or z-axis.

X, Y, Z Rotation

Rotation factor for x, y or z-axis.

Create Hierarchy

Links each duplicate to the first item in the chain.
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Chain

Links each duplicate to the previous item in the chain.

OK

Accept and apply settings.

Cancel

Exit dialog without applying settings.



PiXELS:3D Menus—Window

6.42 PiXELS:3D

Expand Hierarchy
This command affects the appearance of objects in the Schematic view
which can be selected in any of the view panes. When a parent object
(an object that has children in the hierarchy) is collapsed, its children
are not displayed in the Schematic view, but rather only the parent
object is shown with a double outline to indicate that it has hidden
children. When a parent object is selected, this command will expand a
collapsed parent or collapse an expanded parent.
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Window Contents
Object Info . . . . . . . . . . . . . . . . . . . .6.49

Options for Model  . . . . . . . . . . . .6.49
Options for Light  . . . . . . . . . . . . .6.53
Options for Camera  . . . . . . . . . . .6.58

Point Info . . . . . . . . . . . . . . . . . . . . .6.60
Point Info Options  . . . . . . . . . . . .6.60

ShaderMaker  . . . . . . . . . . . . . . . . . .6.62
Nodes . . . . . . . . . . . . . . . . . . . . . .6.62
Node Interaction  . . . . . . . . . . . . .6.62
Shaders  . . . . . . . . . . . . . . . . . . . .6.62

ShaderMaker Options  . . . . . . . . . . .6.63
Preview  . . . . . . . . . . . . . . . . . . . .6.63
Load  . . . . . . . . . . . . . . . . . . . . . . .6.63
Apply to  . . . . . . . . . . . . . . . . . . . .6.64
Diffuse  . . . . . . . . . . . . . . . . . . . . .6.64
Specular . . . . . . . . . . . . . . . . . . . .6.64
Roughness . . . . . . . . . . . . . . . . . .6.64
Opacity . . . . . . . . . . . . . . . . . . . . .6.64
Ambient  . . . . . . . . . . . . . . . . . . . .6.64
Environment  . . . . . . . . . . . . . . . .6.64
Reflectivity . . . . . . . . . . . . . . . . . .6.64
Index of Refraction  . . . . . . . . . . .6.64
Bump  . . . . . . . . . . . . . . . . . . . . . .6.65
Displacement . . . . . . . . . . . . . . . .6.65
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ShaderMaker (continued)
More About Nodes . . . . . . . . . . . .6.65

Color Nodes  . . . . . . . . . . . . . . .6.66
User Defined . . . . . . . . . . . . . . .6.67
Color Model  . . . . . . . . . . . . . . .6.67
r/h Slider . . . . . . . . . . . . . . . . . .6.67
g/s Slider  . . . . . . . . . . . . . . . . .6.67
b/l/v/ Slider  . . . . . . . . . . . . . . . .6.67

Image Map  . . . . . . . . . . . . . . . . . .6.68
Image  . . . . . . . . . . . . . . . . . . . .6.68
Super Sample . . . . . . . . . . . . . .6.68
Max Rate . . . . . . . . . . . . . . . . . .6.68
Mapping Mode  . . . . . . . . . . . . .6.69
Global Coordinates  . . . . . . . . .6.69
Mirror U/V  . . . . . . . . . . . . . . . . .6.69
U/V Scale  . . . . . . . . . . . . . . . . .6.70
U/V Offset  . . . . . . . . . . . . . . . . .6.70

Blender . . . . . . . . . . . . . . . . . . . . .6.71
Input 1 . . . . . . . . . . . . . . . . . . . .6.71
Slider  . . . . . . . . . . . . . . . . . . . .6.71
Input 2 . . . . . . . . . . . . . . . . . . . .6.71
Blending Function  . . . . . . . . . .6.71

Wood  . . . . . . . . . . . . . . . . . . . . . .6.72
Light Wood . . . . . . . . . . . . . . . .6.72
Dark Wood  . . . . . . . . . . . . . . . .6.72
Scale . . . . . . . . . . . . . . . . . . . . .6.72
Turbulence  . . . . . . . . . . . . . . . .6.72
Global Coordinates  . . . . . . . . .6.72

Brick . . . . . . . . . . . . . . . . . . . . . . .6.73
Brick Color  . . . . . . . . . . . . . . . .6.73
Mortar Color  . . . . . . . . . . . . . . .6.73
Brick Width . . . . . . . . . . . . . . . .6.73



PiXELS:3D Menus—Window

PiXELS:3D 6.45

ShaderMaker (continued)
Brick (continued)

Brick Height  . . . . . . . . . . . . . . .6.73
Mortar Thickness  . . . . . . . . . . .6.73
Turbulence  . . . . . . . . . . . . . . . .6.73
Softness  . . . . . . . . . . . . . . . . . .6.73
Noise . . . . . . . . . . . . . . . . . . . . .6.74

Spots  . . . . . . . . . . . . . . . . . . . . . .6.74
Base Color  . . . . . . . . . . . . . . . .6.74
Spot Color  . . . . . . . . . . . . . . . .6.74
Spot Size  . . . . . . . . . . . . . . . . .6.74
Softness  . . . . . . . . . . . . . . . . . .6.74
Threshold  . . . . . . . . . . . . . . . . .6.75
Global Coordinates  . . . . . . . . .6.75

Tile  . . . . . . . . . . . . . . . . . . . . . . .6.76
Tile 1  . . . . . . . . . . . . . . . . . . . . .6.76
Tile 2  . . . . . . . . . . . . . . . . . . . . .6.76
Mortar Color  . . . . . . . . . . . . . . .6.76
Tile Width  . . . . . . . . . . . . . . . . .6.76
Tile Height  . . . . . . . . . . . . . . . .6.76
Mortar Thickness  . . . . . . . . . . .6.76
Turbulence  . . . . . . . . . . . . . . . .6.77
Softness  . . . . . . . . . . . . . . . . . .6.77
Noise . . . . . . . . . . . . . . . . . . . . .6.77

Clouds  . . . . . . . . . . . . . . . . . . . . .6.78
Light Cloud . . . . . . . . . . . . . . . .6.78
Dark Cloud  . . . . . . . . . . . . . . . .6.78
Scale . . . . . . . . . . . . . . . . . . . . .6.78
Iterations  . . . . . . . . . . . . . . . . .6.78
Global Coordinates  . . . . . . . . .6.78
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ShaderMaker (continued)
Marble  . . . . . . . . . . . . . . . . . . . . .6.79

Base Color  . . . . . . . . . . . . . . . .6.79
Veins . . . . . . . . . . . . . . . . . . . . .6.79
Scale . . . . . . . . . . . . . . . . . . . . .6.79
Turbulence  . . . . . . . . . . . . . . . .6.79
Global Coordinates  . . . . . . . . .6.79

Granite  . . . . . . . . . . . . . . . . . . . . .6.80
Base Color  . . . . . . . . . . . . . . . .6.80
Spot Color  . . . . . . . . . . . . . . . .6.80
Scale . . . . . . . . . . . . . . . . . . . . .6.80
Shades  . . . . . . . . . . . . . . . . . . .6.80
Balance . . . . . . . . . . . . . . . . . . .6.81
Global Coordinates  . . . . . . . . .6.81

Math Function  . . . . . . . . . . . . . . .6.82
Function  . . . . . . . . . . . . . . . . . .6.82

Add  . . . . . . . . . . . . . . . . . . . .6.82
Subtract . . . . . . . . . . . . . . . . .6.82
Multiply  . . . . . . . . . . . . . . . . .6.82
Divide  . . . . . . . . . . . . . . . . . .6.82
Sin  . . . . . . . . . . . . . . . . . . . . .6.82
Cos  . . . . . . . . . . . . . . . . . . . .6.82
Tan . . . . . . . . . . . . . . . . . . . . .6.82
Sqrt  . . . . . . . . . . . . . . . . . . . .6.82
Pow  . . . . . . . . . . . . . . . . . . . .6.82
Log  . . . . . . . . . . . . . . . . . . . .6.82
Mod  . . . . . . . . . . . . . . . . . . . .6.82
Abs  . . . . . . . . . . . . . . . . . . . .6.82
Sign . . . . . . . . . . . . . . . . . . . .6.82
Min . . . . . . . . . . . . . . . . . . . . .6.82
Max  . . . . . . . . . . . . . . . . . . . .6.83
Clamp  . . . . . . . . . . . . . . . . . .6.83
Ceil  . . . . . . . . . . . . . . . . . . . .6.83
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Math Function (continued)

Floor  . . . . . . . . . . . . . . . . . . .6.83
Round  . . . . . . . . . . . . . . . . . .6.83
Step . . . . . . . . . . . . . . . . . . . .6.83
Smoothstep . . . . . . . . . . . . . .6.83

Value 1  . . . . . . . . . . . . . . . . . . .6.83
Value 2  . . . . . . . . . . . . . . . . . . .6.83

EdgeBlend  . . . . . . . . . . . . . . . . . .6.84
Inner Color  . . . . . . . . . . . . . . . .6.84
Outer Color . . . . . . . . . . . . . . . .6.84
Attenuation . . . . . . . . . . . . . . . .6.84

Mesher  . . . . . . . . . . . . . . . . . . . . .6.85
Input  . . . . . . . . . . . . . . . . . . . . .6.85
Mesh  . . . . . . . . . . . . . . . . . . . . .6.85
Grid . . . . . . . . . . . . . . . . . . . . . .6.85
Stretch  . . . . . . . . . . . . . . . . . . .6.85
Twist  . . . . . . . . . . . . . . . . . . . . .6.85
Bulge  . . . . . . . . . . . . . . . . . . . .6.85
Pinch . . . . . . . . . . . . . . . . . . . . .6.86
Melt . . . . . . . . . . . . . . . . . . . . . .6.86
Inner Core . . . . . . . . . . . . . . . . .6.86
Outer Core  . . . . . . . . . . . . . . . .6.86

Value Nodes . . . . . . . . . . . . . . . . .6.87
Slider  . . . . . . . . . . . . . . . . . . . .6.87
Frame Number  . . . . . . . . . . . . .6.87
Object Velocity  . . . . . . . . . . . . .6.87
s/t—Texture Coordinate  . . . . . .6.88
x/y/z Current Point  . . . . . . . . . .6.88
x/y/z Surface Angle  . . . . . . . . .6.88
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ShaderMaker (continued)
Value Nodes (continued)

Image Map, Blender, Wood, Brick, Spots, Tile,
Clouds, Marble, Granite Math Function &
Edge Blend . . . . . . . . . . . . . . . .6.88
Function Curve . . . . . . . . . . . . .6.88
x/y/z Current Point (local)  . . . .6.88

fBm  . . . . . . . . . . . . . . . . . . . . . . .6.89
Signed  . . . . . . . . . . . . . . . . . . .6.89
Fractal Increment  . . . . . . . . . . .6.89
Frequency Gap . . . . . . . . . . . . .6.89
Octaves . . . . . . . . . . . . . . . . . . .6.89
x, y and z Index  . . . . . . . . . . . .6.89

Turbulence  . . . . . . . . . . . . . . . . . .6.90
x, y and z Index  . . . . . . . . . . . .6.90
Octaves . . . . . . . . . . . . . . . . . . .6.90

Fractal Sum  . . . . . . . . . . . . . . . . .6.91
x, y and z Index  . . . . . . . . . . . .6.91
Octaves . . . . . . . . . . . . . . . . . . .6.91

More information on
ShaderMaker  . . . . . . . . . . . . . . . .6.92

Shading  . . . . . . . . . . . . . . . . . .6.92
Ambient, Diffuse, Specular Areas
of Illumination  . . . . . . . . . . . . .6.92
Defining Colors  . . . . . . . . . . . .6.93
Defining Values  . . . . . . . . . . . .6.93
2D vs 3D Textures  . . . . . . . . . .6.94
Animating Textures  . . . . . . . . .6.94
Bump Mapping . . . . . . . . . . . . .6.95
Displacement Mapping  . . . . . .6.95
Environment Mapping  . . . . . . .6.96
Shadows . . . . . . . . . . . . . . . . . .6.97
Optimizing Shadows  . . . . . . . .6.98
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Flex  . . . . . . . . . . . . . . . . . . . . . . .6.99
Flex Options  . . . . . . . . . . . . . . . .6.99
u  . . . . . . . . . . . . . . . . . . . . . . .6.99
v  . . . . . . . . . . . . . . . . . . . . . . .6.99
Interpolations . . . . . . . . . . . . . . . .6.99

Link Options
Scale  . . . . . . . . . . . . . . . . . . . . . .6.100
Rotation  . . . . . . . . . . . . . . . . . . . .6.100
Position  . . . . . . . . . . . . . . . . . . . .6.100
Texture  . . . . . . . . . . . . . . . . . . . . .6.100
Lattice  . . . . . . . . . . . . . . . . . . . . .6.100
Boolean  . . . . . . . . . . . . . . . . . . . .6.101
Union  . . . . . . . . . . . . . . . . . . . . . .6.101
Intersection  . . . . . . . . . . . . . . . . .6.101
Difference . . . . . . . . . . . . . . . . . . .6.101

MorphMaker  . . . . . . . . . . . . . . . . . .6.102
Gesture Menu  . . . . . . . . . . . . . . .6.102
Gesture Slider  . . . . . . . . . . . . . . .6.102
Set Reference  . . . . . . . . . . . . . . .6.102
Keyframe Pose  . . . . . . . . . . . . . .6.102
Save Gesture  . . . . . . . . . . . . . . . .6.102
Zero Gestures  . . . . . . . . . . . . . . .6.102

Timeline . . . . . . . . . . . . . . . . . . . . . .6.103
Object Pane  . . . . . . . . . . . . . . . . .6.104
Object Pane  . . . . . . . . . . . . . . . . .6.104
Graph Pane  . . . . . . . . . . . . . . . . .6.105

Full Screen  . . . . . . . . . . . . . . . . . . .6.106
Snap to Grid  . . . . . . . . . . . . . . . . . .6.107
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View
Grid  . . . . . . . . . . . . . . . . . . . . . . .6.108
Normal  . . . . . . . . . . . . . . . . . . . . .6.108
Links  . . . . . . . . . . . . . . . . . . . . . .6.108
Center  . . . . . . . . . . . . . . . . . . . . .6.108
Hull  . . . . . . . . . . . . . . . . . . . . . . .6.108
Surface . . . . . . . . . . . . . . . . . . . . .6.108
Bounding Box  . . . . . . . . . . . . . . .6.108
Fast Navigate . . . . . . . . . . . . . . . .6.109
Motion Paths  . . . . . . . . . . . . . . . .6.109
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Object Info
All objects, including lights and the Camera, have a number of different
settings that can be assigned to them. The Palette displays
all of these settings along with other relevant information about the
currently selected model, light, or Camera. To view and edit these
settings: 

1. Select from the menu or press
.

2. The Palette will appear. Click on the Object
pop-up menu at the top to select either a model, light or
Camera. 

3.  Depending on your selection, different settings will appear.
Settings are typed, toggled, or selected from pull down
menus.

Let’s examine the different settings that are available for models, lights
and the Camera.

Object Info Options for a selected model
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Object

A pop-up menu which allows you to directly select a different object for
editing. 

Color

Click this box to open the Apple color picker to select a color for this
object’s wireframe. It is useful on complex scenes, when you have
multiple objects overlapping each other. By color coding them, they
become easier to spot. Bright colors are usually preferred over muted
tones. This color does not affect the color of the object when rendered.

Name

The name of the model. Can be up to 32 characters.

Rotation X

The rotation factor for the x-axis (pitch).

Rotation Y

The rotation factor for the y-axis (yaw).

Rotation Z

The rotation factor for the z-axis (roll).

Scale X

The scaling factor for the x-axis (width).

Scale Y

The scaling factor for the y-axis (height).
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Scale Z

The scaling factor for the z-axis (depth).

Position X

The translation (offset) factor for the x-axis (left and right).

Position Y

The translation (offset) factor for the y-axis (up and down).

Position Z

The translation (offset) factor for the z-axis (in and out).

U/V Steps

The number of subdivisions or steps this patch contains in each
direction. These values cannot be changed directly.

U/V Basis

The basis of the spline used to interpolate this surface when either
rendering or subdividing.

Close U

Closes the model along its u-steps.

Close V

Closes the model along its v-steps.

U/V Subdivisions

The number of intermediate points added to this object when rendering.
For example, start with an object with a resolution of 10u x 10v. If U and
V Subdivisions were both set to 2, the object would be subdivided to a
resolution of 20u x 20v for rendering. If U and V Subdivisions were both
set to 4, the object would be subdivided to a resolution of 40u x 40v for
rendering.

Bias

Controls the “lean” of the Tau and Beta splines.
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Tension

Controls the “rigidity” of the Cardinal, Tau, Tensed-B, and Beta splines.

Skew

Forces patches with spline deformations to retain parallelism between
v steps.

Proxy

Sets the proxy feature for the selected object. (See 
)

Visible

Sets the visibility for the selected object. (See 
)

Locked

Objects with this set cannot be selected or altered and will appear
dimmed in the modeling views. Locked objects will render normally.

Shadows: Cast

Enables shadow casting for this object. At render time, only objects with
this option enabled can cast shadows.

Shadows: Receive

Enables shadow receiving for this object. At render time, only objects
with this option enabled can receive shadows.
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Object Info Options for a selected light

If the selected object is a light, the is displayed when
the menu-item is chosen.

Light Info Options

Color

Click this box to open the Apple color picker to select a color and
intensity for this light.

Light Type

A pop-up menu from which you select the type of light you want. The
types are:

Null: A light source which has no illumination, but can still glow.
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Point: An omnidirectional light. Light rays travel in all directions from the
light.

Spot: A unidirectional light. Light rays travel in a cone from the position
of the light toward the spotlight interest.

Sun: A light source that is infinitely far from the objects in the scene.
The position of the light and interest are only used to define the
direction the light is coming from.

Position

Defines the position of the light in 3D space.

Interest

Defines the position of the interest in 3D space. (i.e. the spot at which
the light is pointing.)
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Glow

When enabled, this light source will be visible at render time.

Falloff

When enabled, the area of affect of the selected light source will be
limited by the inner and outer core values. When disabled, this light
source will have an infinite area of affect.

Inner Core

Defines the area upon which the light will have full effect.

Outer Core

Defines the area upon which the light will have diminishing effect.
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Rate

Sets the softness or fuzziness of the outer core.

Shadows

Enables shadow tracing for this light. Only objects with shadow casting
enabled will be traced and only objects with shadow receiving enabled
will render with shadows.

Softness

Defines the size of the area light casting the shadows. If softness is set
to zero, area lights are disabled and shadow rendering times will
decrease.

Density

Defines the density of the shadow. Higher values create darker
shadows.
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Cone Angle

Sets the angle at which light rays emanate from a spot light.

Delta Angle

Sets the angle of decreasing light around the light cone.

Icon Visible

Enables the visibility of the light icon in the modeling views. When
disabled, the light will not be incorporated into the rendered image.
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Object Info Options for the Camera

If the selected object is the Camera, the is
displayed when the menu-item is chosen.

Camera Info Options

Color

Click this box to open the Apple color picker to select a color for the
Camera’s wireframe.

Position

Defines the position of the Camera in 3D space.

Interest

Defines the position of the Interest in 3D space.

Roll

Sets the angle of lateral inclination for the Camera.
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Field of View

Sets the angle of view.

Shutter Speed

Defines a percentage of time between frames during which the aperture
is open. A higher value causes greater motion blur. A value greater than
one can have unpredictable results.

fStop

Defines the size of the aperture opening on the Camera. A higher value
results in a less pronounced depth of field, while values closer to zero
produce a more exaggerated depth of field. Common values range from
1.2 to 22.

Fog

Enables the fog option for the Flat, Gouraud and Phong renderers.

Anti-alias Sample Rate

Sets the number of sub-pixel samples to average together when anti-
aliasing. Higher values result in better anti-aliasing but require more
RAM and time to render.

Visible

Enables the visibility of the Camera icon in the modeling views. Does
not effect the rendered image.
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Point info
Used to precisely position points and set their weights for use with
inverse kinematics.

1. Select a point (or a row of points.)
2. Select from the menu.
3. Enter coordinate information and IK information for the

point(s)
4. Use the arrow buttons to edit neighboring points.
5. Click to accept settings or to abort.

Point Info Options

Object

A pop-up menu which allows you to directly select a different object for
editing.

Position

Displays the x, y, and z positions in global coordinates.

Use these to select different points for editing.
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IK Link Model

The IK Chain this point is linked to.

IK Link Point

The joint on the IK Chain this point is linked to.

IK Weight

Sets how much rotational information this point will inherit from the
segment of the IK Chain it is linked to, versus the previous segment in
the chain. (i.e. A value of 1 tells the point to inherit all rotational
information from the IK Segment it is linked to. A value less than 1, and
the point will inherit that percentage from the segment it is linked to and
the remaining rotational information will be inherited from the previous
segment in the chain.)
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ShaderMaker
ShaderMaker allows you to describe the material properties of your
object’s surface. ShaderMaker gives you full control over every aspect
of shading a surface, from the color of the surface to complex light
interactions such as reflection and refraction. All of this can be
controlled using any one of ShaderMaker’s nodes.

Nodes

N o d e is the name given to the basic building blocks used within
S h a d e r M a k e r. To see all the nodes available, choose 

and open the ShaderMaker dialog box then click on the
first Diffuse pop-up menu. Take a moment to read the names of all the
nodes. Every one of these nodes will produce a color, so we call these
color nodes. Now click on the second Diffuse pop-up menu. Every one
of these nodes will produce a numerical value, so we call these value
nodes. Each node has a set of variables associated with it, called input
variables. These variables describe the characteristics of a given node.
Input variables require either a color or a value as input. Some common
variables are scale, softness, grain and turbulence.

Node Interaction

Within ShaderMaker, nodes can be linked to other nodes, making it
possible to control a node’s input variable with the output of another
node. This interaction between nodes may at first seem complex, but it
is, in fact, quite straight forward. It works somewhat like a patch bay,
plugging values or colors from one node into another. There is no
theoretical limit to how deep these interactions can go, however
available memory and CPU speed will play a role in setting practical
limits.

Shaders

A shader is a combination of nodes which work together to create the
final desired color, pattern, texture or look for your 3D object. Every
shader is made up of 14 inputs controlling such variables as Diffuse
Color and Reflectivity. Each of these inputs has a node associated with
it which defines its value or color. Shaders can be created from scratch
or you can use the button to read a Shader from disk. Once a
Shader has been read into ShaderMaker, it can be edited to create a
new look.
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ShaderMaker Options

After selecting the object you want to effect, open ShaderMaker by
choosing the menu item.

From this dialog box you have access to a suite of tools designed to
help you interactively create realistic looking textures without
programming. 

Preview

Applies the current settings to a sphere and renders it into the 
box.

OK

Apply settings to selected model group and return to PiXELS:3D.

Load

Load a shader from disk.

Save

Save the current shader to disk.
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Apply To:

Sets the model group you want this shader applied to. The options are:

Object - Applies the current settings to the currently selected model.

Children - Applies the current settings to all the children of the currently
selected model.

Group - Applies the current settings to all objects associated with the
current object.

All - Applies the current settings to all the models in a scene.

Diffuse

Sets the surface illumination caused by scattering light.

Specular

Sets the intensity of the highlight reflection.

Roughness

Defines the spread of the specular decay over the object surface.

Opacity

Density or transparency of the material.

Ambient

Overall or internal illumination for a given object.

Environment

Defines what is to be reflected or refracted.

Reflectivity

How much of the environment is to be reflected.

Index of Refraction

Defines the distortion of light rays as they pass through transparent or
partially transparent objects.
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Bump

Simulates bumps in a surface by perturbing the normals.

Displacement

Similar to bump, but rather than simulating, displacement actually alters
the surface.

More About Nodes

As discussed earlier, shaders are built of small components called
nodes. There are two types of nodes; those that return colors and those
that return values. Because of the flexibility inherent in ShaderMaker,
the line between color nodes and value nodes is very grey. In fact color
nodes can be used as value nodes. ShaderMaker simply converts the
intensity of the color into a value and passes that to the parent node.
Value nodes cannot directly return color values, but they are used to
define the components of a user color—so you could quite easily create
a shader that used a value node to create a color. A simple example
would be a shader that used a User Color node to define Diffuse Color.
The rgb components could be defined using the absolute value of the
xyz components of the surface normal. Another example would be to
use a Function Curve node to define the hue component of a User
Color node. This allows you to change the hue of your color over time!
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Color Nodes
Color nodes are used to define a color attribute such as what gets
reflected or what color the surface of the object is. The base nodes
which require color node inputs are: Diffuse, Specular, Ambient and
Environment.

White, Black, Red, Green, Blue & Yellow

Predefined colors. These nodes contain no user definable parameters.
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User Defined

Allows the user to define a color in either the rgb, hsv or hsl color
space. Optionally allows the user access to the Apple color picker.

Color Model

A pop up menu used to define the preferred color space. Options
include rgb, hsv and hsl.

r/h Slider

Defines the function/scalar value used to determine the red component
of the user color. When in hsv or hsl mode, this changes to the h slider,
which controls the hue component.

g/s Slider

Defines the function/scalar value used to determine the green
component of the user color. When in hsv or hsl mode, this changes to
the s slider, which controls the saturation component.

b/l/v Slider

Defines the function/scalar value used to determine the blue component
of the user color. When in hsv mode, this changes to the v slider, which
controls the value component. When in hsl mode, this changes to the
l slider, which controls the lightness component.
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Image Map

Uses a PICT image or series of images to define surface color.

Image

The currently loaded PICT image. Click on the preview image to load a
different image. PICT images can be stored in one of three places;
inside the global Textures folder, inside the current project folder or
inside the current project’s Textures folder.

Super Sample

Enables the super sampling option. Super sampling smooths out the
pixelization and aliasing that can occur when viewing textures from a
distance or up close.

Max Rate

Defines the maximum number of samples to use when super sampling.
Higher values give smoother results but can take longer to render.
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Mapping Mode

A pop up menu used to define the mapping method to use.

uv, vu – These two options behave like magic rubber wallpaper that can
be stretched over the object surface – the pixels:3d of the PICT file are
made to correspond with set positions on the object’s surface. As a
result, any distortion from stretching appears more natural. This is by far
the most versatile mapping method. The two options are the same
except that the image map is rotated 90 degrees.

xy, xz, yz – Works like a slide projector. The “screen” being projected
onto is equal to one of the three viewing planes; xy, xz or yz. The size
and position of the ‘screen’ is defined using the U Scale, V Scale, U
Offset and V Offset parameters. Any surface not oriented with the
selected viewing plane will distort the texture when rendering.

Global Coordinates

Forces projected mappings to use global coordinates rather than local
coordinates.

Mirror U/V

When tiling texture maps, these options can help hide the seams
between texture cells.
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U/V Scale

Sets the scale factor to apply to the texture map when using UV or VU
mapping. When using one of the projection map methods, use these to
define the size (in world space) of the texture map you are projecting on
to the surface.

U/V Offset

Defines the position of the first texture tile un UV space. When using
one of the projection map methods, defines the position of the upper left
corner of the projection ‘screen’ in PiXELS:3D units.
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Blender

Merges two color nodes using a value node as an alpha mask.

Input 1

Color node defining source channel 1.

Slider

Sets the weight assignments between channel 1 and channel 2. A value
of 0.0 will reveal 100% channel 1, 0.5 will show a 50/50 blend of
channels 1 and 2, 1.0 will show 100% channel 2.

Input 2

Color node defining source channel 2.

Blending Function

Value node used to define the blending mask. NOTE: the blending
mask DOES NOT override the slider. If you want the blending function
to fully control the output image, set the slider to 1.0.
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Wood

A 3D texture which simulates wood patterns.

Light Wood

Color node used to define the base wood color.

Dark Wood

Color node used to define the color of the concentric rings running
through the texture.

Scale

Slider/Value node used to define the size of the wood grain.

Turbulence

Slider/Value node used to define the randomness of the wood grain.

Global Coordinates

When this item is checked, the texture is computed in world space
rather than object space. If the object is moving in any way and this
option is on, the texture will appear to ‘slide’ through the object when
rendered.
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Brick

A 2D texture which simulates brick or stone wall patterns.

Brick Color

Color node used to define the stone segments.

Mortar Color

Color node used to define the area between stone segments.

Brick Width

Slider/Value node used to define the horizontal scale of the bricks.

Brick Height

Slider/Value node used to define the vertical scale of the bricks.

Mortar Thickness

Slider/Value node used to define the spacing between bricks.

Turbulence

Slider/Value node used to define the low frequency randomness of the
brick pattern.

Softness

Slider/Value node used to define the how softly brick blends into mortar.
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Noise

Slider/Value node used to define the high frequency randomness of the
brick pattern.

Spots

A 3D texture constructed of random spots.

Base Color

Color node defining the area behind the spots.

Spot Color

Color node defining spots.

Spot Size

Slider/value node defining the size of the spots.

Softness

Slider/value node defining the transition from spot to base colors.
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Threshold

Slider/value node defining the lean towards base or spot color. Values
close to zero will favor the base color, while values closer to 1 will favor
the spot color.

Global Coordinates

When this item is checked, the texture is computed in world space
rather than object space. If the object is moving in any way and this
option is on, the texture will appear to ‘slide’ through the object when
rendered.
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Tile

A 2D texture which simulates tile patterns.

Tile 1

Color node used to define the even tiles. The bottom menu is used to
define the tile shape; either rectangular or elliptical.

Tile 2

Color node used to define the odd tiles. The bottom menu is used to
define the tile shape; either rectangular or elliptical.

Mortar Color

Color node used to define the area between tiles.

Tile Width

Slider/Value node used to define the horizontal scale of the tiles.

Tile Height

Slider/Value node used to define the vertical scale of the tiles.

Mortar Thickness

Slider/Value node used to define the spacing between tiles.
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Turbulence

Slider/Value node used to define the low frequency randomness of the
tile pattern.

Softness

Slider/Value node used to define the how softly tile blends into mortar.

Noise

Slider/Value node used to define the high frequency randomness of the
tile pattern.
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Clouds

A 3D fractal texture which simulates cloud patterns.

Light Cloud

Color node defining the clouds.

Dark Cloud

Color node defining the area behind the clouds.

Scale

Slider/value node defining the size of the clouds.

Iterations

Slider/value node defining the complexity of the cloud patterns.

Global Coordinates

When this item is checked, the texture is computed in world space
rather than object space. If the object is moving in any way and this
option is on, the texture will appear to ‘slide’ through the object when
rendered.
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Marble

A 3D texture which simulates marble or stone patterns.

Base Color

Color node defining the main portion of the texture.

Veins

Color node defining the marble veins running through the texture.

Scale

Slider/value node defining the size of the veins.

Turbulence

Slider/Value node used to define the low frequency randomness of the
marble veins.

Global Coordinates

When this item is checked, the texture is computed in world space
rather than object space. If the object is moving in any way and this
option is on, the texture will appear to ‘slide’ through the object when
rendered.
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Granite

A 3D texture which simulates speckled granite patterns.

Base Color

Color node defining the main portion of the texture.

Spot Color

Color node defining the speckles.

Scale

Slider/value node defining the size of the speckles.

Shades

Slider/Value node used to define the number of varying shades visible
inside the texture.
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Balance

Slider/value node defining the lean towards base or spot color. Values
close to zero will favor the base color, while values closer to 1 will favor
the spot color.

Global Coordinates

When this item is checked, the texture is computed in world space
rather than object space. If the object is moving in any way and this
option is on, the texture will appear to ‘slide’ through the object when
rendered.
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Math Function

A utility node. Can be used to mathematically merge values, nodes and
other parameters.

Function

Pop up menu listing available math functions.
The available functions are:

- returns Value 1 plusValue 2.
- returns Value 1 minusValue 2.
- returns Value 1 times Value 2.

- returns Value 1 divided by Value 2.
- returns the sin of Value 1. Value 2 is ignored.
- returns the cosin of Value 1. Value 2 is ignored.
- returns the tangent of Value 1. Value 2 is ignored.
- returns the square root of Value 1. Value 2 is ignored.
- returns Value 1 to the Value 2 power.
- returns Value 1 log Value 2.
- returns the modulus (remainder) of Value 1 divided by

Value 2.
- returns the absolute value of Value 1. Value 2 is ignored.
- returns -1 if Value 1 is less than 0, returns 1 if Value 1 is

greater than 0 and returns 0 if Value 1 is equal to 0.  Value 2
is ignored.

- returns Value 1 if Value 1 is less than Value 2, otherwise
Value 2 is returned.
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- returns Value 1 if Value 1 is greater than Value 2,
otherwise Value 2 is returned.

- returns Value 1 unless Value 1 is less than 0 or greater
than 1. If Value 1 is less than 0, 0 is returned. If Value 1 is
greater than 1, 1 is returned. Value 2 is ignored.

- returns Value 1 rounded up to the next whole number.
Value 2 is ignored.

- returns Value 1 rounded down to the last whole number.
Value 2 is ignored.

- returns Value 1 rounded to the closest whole number.
Value 2 is ignored.

- same as floor.
- returns Value 1 bicubically smoothed. Value 2 is

ignored.

Value 1

Slider/value node defining the first value in the math equation. 

Value 2

Slider/value node defining the second value in the math equation.
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Edge Blend

Blends color nodes based on surface and Camera angles.

Inner Color

Color node defining surfaces facing toward the Camera. 

Outer Color

Color node defining surfaces facing away from the Camera. 

Attenuation

Slider/value node defining the power curve used for transition from inner
to outer colors.
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Mesher

A color node used to apply mesh warps to other color nodes.

Input

Color node defining base image used. This is what will appear in the
preview window.

Mesh

Pop up menu used to select the resolution of the underlying mesh.

Grid

When enabled, the underlying mesh is visible.

Stretch

Pushes and pulls the mesh around.

Twist

Rotates the mesh.

Bulge

Scales the mesh up.
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Pinch

Scales the mesh down.

Melt

Randomly perturbs the mesh.

Inner Core

Defines the portion of the mesh effected 100% by the current tool.

Outer Core

Defines the total area of the mesh effected by the current tool. The area
lying between the inner and outer core is the area of diminishing effect.
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Value Nodes
Value nodes define a value attribute such as bump height or reflectivity.
Value nodes are almost always used in conjunction with a slider. The
value returned by the node is multiplied by the slider value.

Slider

Simply return the value of the slider.

Frame Number

Returns the current frame number.

Object Velocity

Returns the speed, in PiXELS:3D units, at which the current object is
moving.
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s/t - Texture Coordinate

Returns the location, in st space, of the current pixel being rendered.

X/Y/Z - Current Point

Returns the location, in world space, of the current pixel being
rendered.

X/Y/Z - Surface Angle

Returns the surface normal of the current pixel being rendered.

Image Map, Blender, Wood, Brick, Spots, Tile, Clouds,
Marble, Granite, Math Function & Edge Blend

See the Color Nodes section for more information

Function Curve

Graphs values relative to time. Function curve points can be added,
removed and edited from the palette, allowing for almost
infinite control of values over time. To edit a function curve, exit

and open the palette. Expand the current
object. Locate the function curve group. Expand this item and
you will find your newly created function curve.

X/Y/Z - Current Point (Local)

Returns the location, in local space, of the current pixel being rendered.
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fBm

A multi-fractal function. Very robust.

Signed

When checked, values returned will be in the range of -1 to 1. If
unchecked, values less than 0 will be returned unsigned. i.e. a value of
-.25 will be returned as .25.

Fractal Increment

Lower values will result in a smoother noise gradient.

Frequency Gap

Higher values will produce larger fractals.

Octaves

Defines the number of iterations for the fractal function. Higher values
will produce more detailed fractals.

x Index, y Index and z Index

Defines the position point from which to derive a noise sample.
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Turbulence

Another fractal function. Turbulence is always unsigned, returning
values between 0 and 1.

x Index, y Index and z Index

Defines the position point from which to derive a noise sample.

Octaves

Defines the number of iterations for the fractal function. Higher values
will produce more detailed fractals.
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Fractal Sum

Another fractal function. Fractal Sum returns values between -1 and 1.

x Index, y Index and z Index

Defines the position point from which to derive a noise sample.

Octaves

Defines the number of iterations for the fractal function. Higher values
will produce more detailed fractals.
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Shading

At render time, patches are smoothed out and subdivided into triangles.
How smooth a patch becomes is controlled using the 
palette’s settings. The higher these values, the
smoother the patch will appear at render time and the more memory it
will require. Each triangle is a planar surface with its front oriented in
one direction. The renderer calculates the relation between this
orientation and the light sources in order to determine the shading of
each triangle.

Ambient, Diffuse, Specular Areas of Illumination

A surface rendered in PiXELS:3D combines three different types of
illumination to simulate the physical properties of light; ambient, diffuse
and specular. Ambient shading represents the global ‘scattered’ light
present in most scenes. A scene within a brightly lit white room would
have high ambience. A scene in outer space would have no ambience.
A shader with no diffuse or specular, but 100% ambient can be used on
objects which require no shading, like backgrounds or glowing objects.
Diffuse shading is the base illumination of any object, showing the
subtle fluctuations in a surface through variations in highlight and
shadow. Specular shading simulates the effect of light rays bouncing
from the object to the observer’s eyes, creating a highlight or hot spot.
The size of this highlight can be controlled through the Roughness
parameter to simulate a wide variety of materials, from plastic to metal.
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Defining Colors

There are many options for defining colors. The most common is to use
the User Color node.

Defining Values

Most values are defined using a combination of input node and slider
value. The value returned by the node is multiplied by the slider value
before being used. The Slider node always returns a value of 1.0, so
the value set using the slider control is the value that will get passed
into the renderer. If a color node is selected, its rgb value will be
converted to hsv and the v component will be used.
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2D vs. 3D Textures

There are two types of textures in ShaderMaker; 2D and 3D. The
difference between them is the coordinate system upon which they are
based. A 2D texture exists in a 2D world - with only 2 coordinates
available. For each pair of coordinates there is a corresponding color.
The simplest example is a PICT image. Given an xy pair we could
easily find the corresponding pixel and its rgb color. 3D textures are a
bit more complicated. These textures are like blocks of a material with
the object enclosed. Each point within the block can have a different
color.

Animating Textures

Any value parameter can be animated. From the pop up menu, select
Function Curve. Using a Function Curve you can graph values relative
to time. Another way to animate textures is to use an animated PICT
sequence. To do this, you will need a series of sequentially numbered
PICT files, with a five digit numeric extension like this:
‘texturename.00000’. At render time, the Texture Manager will
automatically load the file whose numeric extension matches the current
frame number. If the current frame is greater than the last image, the
system will cycle the frames, starting with the first frame again. If a
frame is missing from the animated PICT sequence, a blank image will
be used in its place.
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Bump Mapping

Bump mapping, also known as normal perturbation, creates the illusion
of surface roughness by altering the surface normals without actually
modifying the surface itself. This illusion works well when viewed from
the front, but when viewed from the side, it becomes obvious that the
surface is actually flat. Height or depth of the bumps can be controlled
using the slider.

Displacement Mapping

Displacement mapping takes bump mapping to the next level, altering
the actual surface itself. Because of this, higher levels of subdivision are
required. To change the subdivision level for an object with
displacement, select the object and use the palette to
change the parameters to a higher value like 8 or 12.
The actual levels required will depend on the resolution of the rendered
image, the object’s proximity to the Camera and the detail inherent in
the displacement map.
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Environment Mapping

Environment mapping can be used to simulate the effect of an image
reflected onto the object’s material—without using raytracing. Any color
node can be used as an environment map, but it should be noted that
all nodes used in this manner will be given a spherical parameterization
as if it were a colored sphere that surrounds the object and reflects from
the object’s surface. Unlike other types of maps, a reflection map is not
linked to the object, and will remain stationery when the object moves or
rotates. The amount of environment reflected in an abject is controlled
using the control.
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Shadows

Any renderable object can receive and/or cast shadows. You can set
these options using the palette. Objects that cast and
receive shadows WILL NOT cast shadows onto themselves.

If an object needs to be self shadowing, an invisible shadow casting
copy will need to be created. To do this, simply select the object, turn
shadow casting for this object OFF and duplicate it. With the copy still
selected, use the palette to turn shadow casting on and
visibility off. This object will now cast shadows, but will not render.
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Optimizing Shadows

All shadow casting lights in PiXELS:3D are raytraced, so the more
triangles an object is made up of, the longer it takes to compute that
object’s shadow. A simple trick for speeding up shadow casting is to use
a ‘stand-in’ object. This object is an invisible, lower detail version of the
rendered object. The technique is very similar to the self shadowing
trick described above. A copy of the object is made, it can be simplified
and/or change the U/V Subdivision settings to 1—so no subdivision
takes place at render time. Make the copy invisible, but turn on shadow
casting. Make sure shadow casting is off for the original object,
otherwise two shadows will be cast.

Other things to remember are:

• Turn shadow casting off for objects whose shadows are not
visible.

• Turn shadow receiving off for objects which do not receive
any shadows.

• Area light sources take much longer to render. A light is
considered an area light if its size is greater than zero.

• Suns cannot cast soft shadows, so setting their size to
anything other than zero will have no visible effect, but may
slow rendering.
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Flex
Sets the surface flexibility of the selected object.

1. Select a model
2. Choose from the menu, or press

.
3. Use the sliders to set new values.
4. Select either linear or smooth interpolation.

Flex Options

U

Sets the area of effect for the u axis.

V

Sets the area of effect for the v axis.

A linear interpolation will be used to remap surrounding points.

A smooth interpolation

A smooth interpolation weighted at the source.

A smooth interpolation weighted at the edges.
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Link Options
Sets which attributes to inherit from the parent object and provides
access to true Boolean modeling.

1. Select a model.
2. Choose from the menu or press 

.
3. Select which attributes to inherit.
4. Click to apply link settings or to abort.

Link Options Options

Scale

Inherit scaling factors from parent.

Rotation

Inherit rotational factors from parent.

Position

Inherit x, y, and z offset from parent.

Texture

Inherit all shader parameters from parent.

Lattice

Inherit lattice deformations from parent. (If the parent is linked to a
lattice).
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Boolean

Sets whether or not this object will affect its parent at rendering time.

Union

Renders the parent and child objects as though they were one. 

Intersection

Renders only the overlapping portions of the parent and child.

Difference

Carves out or subtracts the child from the parent when rendering.
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MorphMaker
MorphMaker is a tool that allows you to define a neutral reference pose
for an object and any number of variations on that reference. These
variations are called gestures. Any number of gestures can then be
blended in any amount to form a pose. This feature can greatly simplify
facial animation, among other things. 

1. Select a model.
2. Choose from the menu or type

.

MorphMaker Options

Gesture Pop-up Menu

Allows you to select a gesture to edit with the .

Gesture Slider

Controls how much of the Gesture shown in the pop-up is
added to the current pose.

Set Reference

Saves the current shape of the selected object as the reference pose.

Keyframe Pose

Saves the current pose in a new keyframe at the current frame number.

Save Gesture...

Opens a dialog allowing you to name a gesture and then saves the
current shape of the selected object under that name.
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Zero Gestures

Sets the effect of each saved gesture to zero, effectively returning you
to the reference pose.

Timeline
Opens a floating window containing a graphical representation of
animation timings for all objects in a scene. All animatable parameters
of an object can be directly edited from within this window.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Timeline in the lower tool palette.

The Timeline window is divided into three main parts. From left to right
they are the: object pane, options pane and graph pane. There is also a
group of push-buttons in the upper left corner. The first button sets the
graph pane to Bar mode. The second button changes it to Curve mode.
The second pair of buttons can be used to constrain movement of
function curve control points. The left button, if depressed, allows
horizontal movement, i.e. you can change the time of a control point.
The right button, if depressed, allows vertical movement, i.e. you can
change the value of the parameter at that time. You can pan by 

in any pane. You can zoom by in any
pane. The window can be resized by dragging its bottom-right corner.
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Object Pane

You can select an object by clicking on its name in the object pane. The
entry for the selected object will appear indented. The object pane is
hierarchical, like an outline. You can click the group expander to the left
of an object name to show or hide the parameter groups for that object.
If the object has any objects linked to it (children) they will show up here
as well. Clicking the group expander for a parameter group will reveal
the animatable parameters for that group. Parameters can be expanded
in this way as well. Expanded parameters reveal a color box and a
value number. The color box shows the color that parameter’s function
curve will have in the graph pane. To change the color, click on the
color box to open the Apple color picker dialog. The value number
displays the value that that parameter has at the current frame. This
value can be changed by clicking on the value number and typing in a
new number. Type the or key to apply the new value. To
create a new keyframe, any object group, parameter
group or parameter. A black keyframe marker will appear in the graph
pane.

Options Pane

There are nine options available in the options pane: Wireframe color,
Visible, Proxy, Lock, Skew, Close u, Close v, Cast shadows, and
Receive shadows. If you click and hold on an option selector for a few
seconds, a description of what it does appears in the pane header. See

for a description these options. Not all objects
have all nine options available. Lights and the Camera, for example,
have wireframe color and visible options, but none of the others.
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Graph Pane

The current frame can be changed by dragging the key insertion point.
If you hold down the key while you drag, the key insertion point
will change, but the current frame will not. This can be used to copy
keyframes from one point in time to another.

The appearance and behavior of the graph pane will differ depending
on whether Bar mode or Curve mode is selected. Bar mode shows the
function curve for each fully expanded parameter in its own function
curve pane. The function curve pane can be resized by dragging the
bar just below the pane. To select bar mode, click on the button
(the left button in the upper left corner of the window). Curve mode
allows you to view and edit multiple curves simultaneously. Any curve
which has been fully expanded in the hierarchy will show up in this
mode, so you can even edit curves from multiple objects. To select
curve mode, click on the button (the second one from the left in
the upper left corner of the window).

Keyframes appear in the bar graph display as black rectangles. If the
horizontal movement button is depressed, you can move a keyframe to
a different time by dragging it. Multiple keyframes can be selected at
one time. To select multiple keyframes, - and drag a box around
the keyframes you want selected. - toggles selected
keyframes. Selected keyframes can be moved or they can be deleted
by typing the key. NOTE: the cursor must be inside the

palette when typing.

Function curves are bézier curves. There is one control point for each
key frame. on a control point to select it. The selected point will
show a control handle that can be adjusted to alter velocity from
keyframe to keyframe. By default, control handles will maintain
continuity from one side of the control point to the other. If you want to
break continuity (to have a sudden change of direction or velocity) at a
control point, and drag the handle. The continuity will
remain broken until you on the handle a second time.
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Full Screen
Sets the viewing window to either fill the screen (default) or fit into a
resizeable, relocatable window.

1. Choose from the menu, or type
.
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Snap To Grid
Provides for more precise positioning by aligning changes to an
underlying grid. The grid size can be changed from the command line
using the gridsize command.

1. Choose from the menu.
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View
A sub-menu which lists a number of viewing options.

1. Select from the menu. A sub-menu will
pop-up.

2. Drag the mouse to the desired option.

View Sub-menu Items

Grid

Toggles the visible grid for the top, front and right views.

Normals

Shows the surface normals for the currently selected object.

Links

Shows all parent/child connections. A green line will appear between a
parent and all of its children to show a standard link. A blue line will
appear to show a look-at link.

Centers

Shows an object’s x, y, and z orientation and center.

Hull

Shows the connectivity between vertices by drawing a vector between
them. This represents an approximation of the actual shape.

Surface

Draws the actual spline curves that make up a shape. This is the most
accurate vector representation of a shape, but can take a long time to
draw.

Bounding Box

Show only the bounding boxes (extents) of each object. The currently
selected object will still draw normally. This provides the fastest screen
redraw.
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Fast Navigate

Will use a proxy of the scene when using the View tools to navigate.
This speeds screen refresh.

Motion Paths

Will draw a blue line which represents the path a given object follows
when animated.
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Select Contents
Parent  . . . . . . . . . . . . . . . . . . . . . . .6.113
Interest  . . . . . . . . . . . . . . . . . . . . . .6.113
Path  . . . . . . . . . . . . . . . . . . . . . . .6.113
Lattice  . . . . . . . . . . . . . . . . . . . . . . .6.113
Bone  . . . . . . . . . . . . . . . . . . . . . . .6.113
Skin  . . . . . . . . . . . . . . . . . . . . . . .6.113
Next Object  . . . . . . . . . . . . . . . . . . .6.113
Previous Object . . . . . . . . . . . . . . . .6.113
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Parent
Selects the parent (if there is one) of the currently selected object.

Interest
Selects the interest (if there is one) of the currently selected object.

Path
Selects the path (if there is one) of the currently selected object.

Lattice
Selects the lattice (if there is one) of the currently selected object.

Bone
Selects the IK chain (if there is one) of the currently selected point.

Skin
Selects the skin (if there is one) of the currently selected IK chain.

Next Object
Selects the next object in the scene list. The order of objects in this list
is determined by the order in which objects are created.

Previous Object
Selects the previous object in the scene list. (see above)
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Tools Contents
View Tools

Pan  . . . . . . . . . . . . . . . . . . . . . . .7.9
Zoom  . . . . . . . . . . . . . . . . . . . . . .7.10
Orbit  . . . . . . . . . . . . . . . . . . . . . . .7.11
Dolly . . . . . . . . . . . . . . . . . . . . . . .7.12
Time  . . . . . . . . . . . . . . . . . . . . . . .7.13

Control Tools
Move . . . . . . . . . . . . . . . . . . . . . . .7.15
Rotate . . . . . . . . . . . . . . . . . . . . . .7.16
Scale  . . . . . . . . . . . . . . . . . . . . . .7.17
Expand . . . . . . . . . . . . . . . . . . . . .7.18
Center  . . . . . . . . . . . . . . . . . . . . .7.19
Align . . . . . . . . . . . . . . . . . . . . . . .7.20
Park  . . . . . . . . . . . . . . . . . . . . . . .7.21
Command . . . . . . . . . . . . . . . . . . .7.22
Link/UnLink  . . . . . . . . . . . . . . . . .7.28
Look/Unlook . . . . . . . . . . . . . . . . .7.30
Path/Unpath  . . . . . . . . . . . . . . . . .7.31
Instance  . . . . . . . . . . . . . . . . . . . .7.32
Copy Shader  . . . . . . . . . . . . . . . .7.33
Copy Shape  . . . . . . . . . . . . . . . . .7.34

Reshape Tools
Push/Pull  . . . . . . . . . . . . . . . . . . .7.35
Spline . . . . . . . . . . . . . . . . . . . . . .7.36
Pinch  . . . . . . . . . . . . . . . . . . . . . .7.37
Subdivide . . . . . . . . . . . . . . . . . . .7.38

Subdivide Options
U Step
V Step
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Reshape Tools (continued)
Collide

Collide Options  . . . . . . . . . . . .7.39
Add
Subtract
Subdivide
Delete B

Join  . . . . . . . . . . . . . . . . . . . . . . .7.40
Join Options
U  to U
V to V

Insert  . . . . . . . . . . . . . . . . . . . . . .7.41
Insert Options

U Insert
V Insert

Remove  . . . . . . . . . . . . . . . . . . . .7.42
Remove Options

U Remove
V Remove

Flip  . . . . . . . . . . . . . . . . . . . . . . .7.43
Flip Options

Global Coordinates
X, Y, Z Axis

Disrupt  . . . . . . . . . . . . . . . . . . . . .7.44
Disrupt Options

X, Y, Z 
Invert  . . . . . . . . . . . . . . . . . . . . . .7.45
3D Emboss . . . . . . . . . . . . . . . . . .7.46
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Reshape Tools (continued)
Clip  . . . . . . . . . . . . . . . . . . . . . . .7.47

Clip Options
Clip X
Clip Y
Clip Z

Close Ends . . . . . . . . . . . . . . . . . .7.48
Close Ends Options

Sharp Edge
Smooth Edge
Radius

Optimize . . . . . . . . . . . . . . . . . . . .7.49
Re-order . . . . . . . . . . . . . . . . . . . .7.50

Re-Order Options
Steps
Uniform Spacing
Random Spacing

Shape Tools . . . . . . . . . . . . . . . . . . .7.53
Cylinder  . . . . . . . . . . . . . . . . . . . .7.53

Cylinder Options
U Step
V Step
Revolution
Radius
Length (z)

Sphere  . . . . . . . . . . . . . . . . . . . . .7.54
Sphere Options

U Step
V Step
Revolution U
Revolution V
Radius



PiXELS:3D Tools

7.6 PiXELS:3D

Shape Tools (continued)
Cone . . . . . . . . . . . . . . . . . . . . . . .7.55

Cone Options
U Step
V Step
Revolution
Radius
Length (z)

Mesh . . . . . . . . . . . . . . . . . . . . . . .7.56
Mesh Options

U step
V Step
Width (x)
Length (z)

Cube . . . . . . . . . . . . . . . . . . . . . . .7.57
Cube Options

U Step
V Step
Width (x)
Height (y)
Length (z)

Spline Tool  . . . . . . . . . . . . . . . . . . .7.58
Extrude Tools  . . . . . . . . . . . . . . . . .7.59

Extrude Options
Step . . . . . . . . . . . . . . . . . . . .7.59
Depth . . . . . . . . . . . . . . . . . . .7.59
Bevel  . . . . . . . . . . . . . . . . . . .7.59
Radius . . . . . . . . . . . . . . . . . .7.60
Height  . . . . . . . . . . . . . . . . . .7.60
Front Beveling  . . . . . . . . . . .7.60
Back Beveling . . . . . . . . . . . .7.60
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Lathe Tools  . . . . . . . . . . . . . . . . . . .7.61
Lathe Options

Step
Degree
Close

Loft Tool  . . . . . . . . . . . . . . . . . . . . .7.62
Light Tool  . . . . . . . . . . . . . . . . . . . .7.63
IK Chain Tool . . . . . . . . . . . . . . . . . .7.64
Lattice Tool  . . . . . . . . . . . . . . . . . . .7.65

Lattice Options
U Step
V Step

Extract Tool  . . . . . . . . . . . . . . . . . . .7.66
Path Extrude Tool  . . . . . . . . . . . . . .7.67
Null Tool  . . . . . . . . . . . . . . . . . . . . .7.68
4-side blnd Tools . . . . . . . . . . . . . . .7.69

4 Sided Blend Options
Name
U Step
V Step
Splines 1–4
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Animate Tools  . . . . . . . . . . . . . . . . .7.71
Pencil Test  . . . . . . . . . . . . . . . . . .7.71
Offset Keys  . . . . . . . . . . . . . . . . .7.72

Offset Keys Options
Frame Range
Offset
All objects

Invert Keys . . . . . . . . . . . . . . . . . .7.73
Invert Keys Options

Frame Range
Centered on
All objects

Scale Keys  . . . . . . . . . . . . . . . . . .7.74
Scale Keys Options

Frame Range
Centered on
Scale
All objects

Dup. Keys  . . . . . . . . . . . . . . . . . .7.75
Duplicate Keys Options

Frame range From To
# of copies
Offset
All Objects



PiXELS:3D View Tools

PiXELS:3D 7.9

Utilities  . . . . . . . . . . . . . . . . . . . . . .7.77
View Pict  . . . . . . . . . . . . . . . . . . .7.77
View Tiff  . . . . . . . . . . . . . . . . . . . .7.78
View Picts  . . . . . . . . . . . . . . . . . .7.79
Render Texture  . . . . . . . . . . . . . .7.80

Render Texture Options
Shader Component
Auto 
Texture Size
Texture Name

Reset Schematic  . . . . . . . . . . . . .7.82
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Pan
Moves the center of the current viewport. This tool does not effect the
geometry of a model. 

1. Click View from the main tool palette.
2. Click Pan in the lower tool palette.
3. Click in any window view and drag the mouse to move the

center of that window.
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Zoom
Scales the current view larger in 200% increments or smaller in 50%
i n c r e m e n t s .

To zoom in:
1. Click View in the main tool palette.
2. Click Zoom in the lower tool palette. 
3. Click in any window view. Each click doubles the size of the

image. 

To zoom out:
1. Click View in the main tool palette.
2. Click Zoom in the lower tool palette. 
3. in any window view. Each click reduces the size of

the image by half. 
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Orbit 
Rotates the Camera around the Interest.

1. Click View in the main tool palette. 
2. Click Orbit in the lower tool palette. 
3. Click in the Camera view and drag the mouse in any

direction. The view turns as the mouse moves around. 
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Dolly 
Interactively changes the user ’s view of the current view port in or out of
a scene.

1. Click View in the main tool palette. 
2. Click Dolly in the lower tool palette. 
3. In any view window, click and drag the mouse. To bring the

model closer (dolly in), move the mouse toward the bottom
of the screen. To move the model further away (dolly out),
move the mouse toward the top of the screen.
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Time
Moves the scene forward or backward in time. Can be used to preview
animations, or navigate through an animation.

1. Click View in the main tool palette. 
2. Click Time in the lower tool palette. 
3. Click in any view and drag the mouse left to move backward

or right to move forward in time. The view and frame counter
change as the mouse moves.
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Move 
Sets how far the model is offset from the center of the grid.

1. Click Control in the main tool palette. 
2. Click Move in the lower tool palette.
3. Click and drag in any window to move the currently selected

model.
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Rotate 
Pivots the model, changing its orientation in 3 D space.

1. Click Control in the main tool palette. 
2. Click Rotate in the lower tool palette.
3. Click in any view and drag the mouse in any direction to

rotate the currently selected model.



PiXELS:3D Control Tools

PiXELS:3D 7.19

Scale 
Resizes the currently selected object.

1. Click Control in the main tool palette. 
2. Click Scale in the lower tool palette.
3. Drag the mouse up or down in any window to rescale the

selected object. Moving the mouse up enlarges the object.
Moving down reduces the selected object. 
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Expand 
Expands the currently selected object by ‘pushing’ each vertex out (or
in) along its normal vector.

1. Click Control in the main tool palette. 
2. Click Expand in the lower tool palette.
3. Drag the mouse up or down in any window to expand the

selected object. Moving the mouse up expands the object.
Moving down contracts the selected object.
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Center
Moves the x, y, z center of the selected object. Used most often to set
an object’s pivot point.

1. Select the object.
2. Click Control in the main tool palette. 
3. Click Center in the lower tool palette.
4. Click and drag to move the center of the currently selected

object. 
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Align 
Aligns the current object’s center point with the center point of the next
object selected.

1. Select the object which you want to align.
2. Click Control in the main tool palette. 
3. Click Align in the lower tool palette.
4. Without holding down the key, pick the object

you want the currently selected object to align to.
5. Or hold down the key and select a different

object. Go to step 4.
6. Set any or all axis you want aligned.
7. Click to apply or click to abort.

Align Options:

- Sets the x-axis alignment factor.
- Sets the y-axis alignment factor.
- Sets the z-axis alignment factor.

Vertex level alignment is also possible. This allows you to align points
on one object to points on another object.

1. Select the object which you want to align points to.
2. Click Control in the main tool palette. 
3. Click Align in the lower tool palette.
4. Click Tag in the Selector tool palette.
5. While holding down the key, select the point(s)

you want to align to.
6. Without holding down the key, pick the point(s)

on any other object you want to align to the previously
selected point(s).
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Park 
Applies all transformations and deformations and locks them into the
object. The object center is reset to 0, its scaling is reset to 1 and its
rotation is reset to 0. The model will still look the same, but may react
differently.

1. Select the object which you want to park.
2. Click Control in the main tool palette. 
3. Click Park in the lower tool palette.
4. The object is now parked, and all rotations, transformations

and deformations have been applied.

Park Options:

- Applies all position offsets to the objects’ mesh and
resets the object’s positions to 0.0.

- Applies all rotations to the objects’ mesh and
resets the object’s rotations to 0.0.

- Applies all scaling factors to the objects’ mesh and
resets the object’s scales to 1.0.
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Command
Provides access to a command line editor for typing in commands.

1. Click Control in the main tool palette. 
2. Click Command in the lower tool palette.
3. Type in commands. (listed in the Glossary.) Hit either the

enter or return key to see the effects of this command.

Commands:

The command line interface is case-sensitive, so type the commands
exactly as they are shown here (replacing variables with the appropriate
value.)

move point x y z

Moves the current point on the current model by x, y, z units.

flexv n

Sets the v Flex of the current model to n.

flexu n

Sets the u Flex of the current model to n.

dolly WindowNumber x

Sets the zoom factor of view WindowNumber to x.

The views are numbered as follows:

1. Top
2. Front
3. Right
4. Camera

pan WindowNumber x y

Pans the view WindowNumber by x and y.
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normalheight n

Sets the length of the normal vectors when the menu item “Show
Normals” is implemented.

gridsize n

Sets the visible grid step to n x n units.

snapto n

Sets the snap-to grid step to n x n units.

autodepth {on off}

Sets the “Window->View->Auto Depth” menu item to on or off.

keyhelp {on off}

Sets the keyhelp feature to on or off. The keyhelp feature shows all the
keyboard short-cuts next to the tool in the tool palette.

showpath {on off}

Sets the “Window->View->Motion Paths” menu item to on or off.

showsurf {on off}

Sets the “Window->View->Surfaces” menu item to on or off.

showvertices {on off}

Sets the “Window->View->Vertices” menu item to on or off.

showhull {on off}

Sets the “Window->View->Hull” menu item to on or off.

showcenters {on off}

Sets the “Window->View->Center” menu item to on or off.

showlinks {on off}

Sets the “Window->View->Links” menu item to on or off.
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shownormals {on off}

Sets the “Window->View->Normals” menu item to on or off.

fastnavigate {on off}

Sets the “Window->View->Fast Navigate” menu item to on or off.

grid {on off}

Sets the “Window->View->Grid” menu item to on or off.

gridsnap {on off}

Sets the “Window->Snap To Grid” menu item to on or off.

tran x y z

Transforms ( moves ) the currently selected object by x, y and z units.

rot x y z

Rotates the currently selected object x°, y° and z°.

scale x y z

Scales the currently selected object x%, y% and z%.

point tran x y z

Transforms ( moves ) the currently selected point by x, y and z units.

point rot x y z

Rotates the currently selected point x°, y° and z°.

set tran x y z

Sets the currently selected object’s absolute x, y and z offsets.

set rot x y z

Sets the currently selected object’s absolute x, y and z rotation.

set scale x y z

Sets the currently selected object’s absolute x, y and z scale
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set renderloc x y

Sets the center of the render window to x, y.

set rendersize x y

Sets the size of the default render window to x, y.

select parent

Selects the current object’s parent and makes it the current object.

select point h v

Selects point h, v on the currently selected object.

select n

Selects the object numbered n and makes it the current object.

select itemName

Selects the object named itemName and makes it the current object.

hide n1 n2

Hides the objects numbered from n1 thru n2.

hide h3ier

Hides the currently selected object and all its children.

hide down

Hides the currently selected object and all objects numbered lower
than it.

hide up

Hides the currently selected object and all objects numbered higher
than it.

hide all

Hides all objects.
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show n1 n2

Shows the objects numbered from n1 thru n2.

show hier

Shows the currently selected object and all its children.

show down

Shows the currently selected object and all objects numbered lower
than it.

show up

Shows the currently selected object and all objects numbered higher
than it.

show all

Shows all objects.

name object itemName

Renames the currently selected object to itemName.

update n

Updates the view numbered n.

update current

Updates the active view.

update {on off}

Sets the auto-update feature to on or off.

cylinder

Opens the Cylinder dialog, allowing you to create a new primitive.

sphere

Opens the Sphere dialog, allowing you to create a new primitive.



PiXELS:3D Control Tools

PiXELS:3D 7.29

cone

Opens the Cone dialog, allowing you to create a new primitive.

mesh

Opens the Mesh dialog, allowing you to create a new primitive.

cube

Opens the Cube dialog, allowing you to create a new primitive.
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Link/Unlink
Applies a hierarchical (parent /child) grouping to objects so that

they operate together but can retain their individual rotation
and scale values. If a link has already been established, this
tool breaks the hierarchical grouping of objects so that they
operate independently once again.

1. Select the object which you want to link.
2. Click Control in the main tool palette. 
3. Click Link/Unlink in the lower tool palette.
4. Without holding down the key, pick the object

you want the currently selected object to link to.
5. Or hold down the key and select a different

object, making it the currently selected object without
establishing a link. Go to step 4.

6. The dialog will appear. Select the desired
options and click to accept or to reject.

OR

1. Select the object which you want to unlink.
2. Click Control in the main tool palette. 
3. Click Link/Unlink in the lower tool palette.
4. The system will beep to indicate that the link was broken

successfully. If there is no beep, than no link was broken.
Most probable cause: The selected object was not linked to
anything.
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Link Options Options:

- Inherit scaling factors from parent.
- Inherit rotational factors from parent.

- Inherit x, y, and z offset from parent.
- Inherit all shader parameters from parent.

- Inherit lattice deformations from parent. (If the
parent is linked to a lattice).

- Sets whether or not this object will effect its parent
at rendering time.

- Renders the parent and child objects as though
they were one. 

- Renders only the overlapping portions of the parent
and child.

- Carves out or subtracts the child from the parent
when rendering.
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Look/Unlook
Creates a hierarchy which forces one object to always face toward
another object. If such a hierarchy has already been established, this
tool breaks the hierarchical grouping of objects so that they operate
independently once again.

1. Select the object you want to ‘look at’ another object.
2. Click Control in the main tool palette. 
3. Click Look/Unlook in the lower tool palette.
4. Without holding down the key, pick the target

object.
5. Or hold down the key and select a different

object, making it the currently selected object without
establishing a link. Go to step 4.

OR

1. Select the object which you want to ‘unlook’.
2. Click Control in the main tool palette. 
3. Click Look/Unlook in the lower tool palette.
4. The system will beep to indicate that the link was broken

successfully. If there is no beep, than no link was broken.
Most probable cause: The selected object was not linked to
anything.
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Path/Unpath
Creates a hierarchy which links an object to a spline, using that spline
as the object’s motion path. If such a hierarchy has already been
established, this tool breaks the hierarchical grouping of objects so that
they operate independently once again.

1. Select the object which you want to ‘path link’.
2. Click Control in the main tool palette. 
3. Click Path/Unpath in the lower tool palette.
4. Without holding down the key, pick the path

spline.
5. Or hold down the key and select a different

object, making it the currently selected object without
establishing a link. Go to step 4.

OR

1. Select the object which you want to ‘unpath’.
2. Click Control in the main tool palette. 
3. Click Path/Unpath in the lower tool palette.
4. The system will beep to indicate that the link was broken

successfully. If there is no beep, than no link was broken.
Most probable cause: The selected object was not linked to
anything.
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Instance
Duplicates a selected object across the surface of a target object. One
copy is created for and aligned with each vertex on the target object.

1. Select the object to be duplicated.
2. Click Control in the main tool palette. 
3. Click Instance in the lower tool palette.
4. Without holding down the key, pick the target

object.
5. Or hold down the key and select a different

object, making it the currently selected object without
instancing. Go to step 4.

6. Set any desired options.
7. Click to apply or click to abort.

Instance Options:

- When instancing, rotate each duplicate as
described below.

- The duplicates are rotated so that their z-axis’
are aligned with the target object’s vertex normals.

- Using a fractal noise, each duplicate is randomly
rotated. This is a good option for simulating natural
elements such as leaves on trees.

A cone instanced onto a sphere



PiXELS:3D Reshape Tools

PiXELS:3D 7.35

Copy Shader
Copies the Shader definition from one object to another.

1. Select the source object (the one whose data you wish to
copy.)

2. Click Control in the main tool palette. 
3. Click Copy Shader in the lower tool palette.
4. Without holding down the key, pick the target

object.
5. Or hold down the key and select a different

object, making it the currently selected object without
copying any data. Go to step 4.
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Copy Shape
Copies the Shape geometry from one object to another.

1. Select the source object (the one whose data you wish to
copy.)

2. Click Control in the main tool palette. 
3. Click Copy Shape in the lower tool palette.
4. Without holding down the key, pick the target

object.
5. Or hold down the key and select a different

object, making it the currently selected object without
copying any data. Go to step 4.
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Push/Pull 
Use to grab any point or column on the mesh and drag it into a new
shape.

1. Select the object you want to reshape.
2. If desired, adjust the flexibility or tension of the object (see

in the menu).
2. Click Reshape in the main tool palette. 
3. Click Push/Pull in the lower tool palette.
4. Click on the vertex you want to move.
5. Drag with the mouse to push and pull that vertex into a new

form.
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Spline 
Uses the central Beziér curve present in every PiXELS:3D object to
bend and reshape that object.

1. Select an object to deform.
2. Click Reshape in the main tool palette. 
3. Click Spline in the lower tool palette. With a color monitor,

the spline of the selected object will appear in red. 
3. Click on any of the spline’s 4 control points and drag to bend

and curve the object along its backbone.
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Pinch
Constricts all the points in the current v step by pulling them toward
their absolute center.

1. Select the object you want to pinch.
2. If desired, adjust the flexibility or tension of the object (see

in the menu).
2. Click Reshape in the main tool palette. 
3. Click Pinch in the lower tool palette.
4. Click on any vertex in the v step you want to pinch. Use the

V Col constraint to help you see which points will be
pinched.

5. Drag the mouse up to bulge the points out, or drag down to
pinch the points in.
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Subdivide
Divides a patch to create a more detailed, smoother, higher resolution
object.

1. Select the object you want to subdivide.
2. Click Reshape in the main tool palette. 
3. Click Subdivide in the lower tool palette.
4. Enter values for and .
5. Click to apply or to abort.

Subdivide Options:

- Sets the number of intermediate points to add
between each u step.

- Sets the number of intermediate points to add
between each v step.
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Collide
Provides the ability to push one object into or out of another to create
dents and bumps.

1. Use the Control tools to line up the two objects to prepare
for collision. 

2. Select the object you want to dent or bump.
3. Click Reshape in the main tool palette. 
4. Click Collide in the lower tool palette.
5. Without holding down the key, pick the object

you want to collide into the currently selected object.
6. Make the desired changes to the 

parameters.
7. Click to collide or to abort. 

Collide Options:

- Causes the collision to happen from the inside,
pushing outward.

- Causes the collision to happen from the outside,
pushing in.

- When selected, causes the object being collided
with to subdivide before collision detection. This
provides a more accurate representation of the
colliding shape, but takes longer to calculate and
returns a more complex model.

- Discards the colliding object (the object used to
make the dent) upon return.
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Join
Bonds two objects together. Objects need the same number of points
along the bonding axis to be joined. 

1. Use the Control tools to line up the two objects to prepare
for joining.

2. Select the first object you want to join. Select the object on
the end you want joined.

3. Click Reshape in the main tool palette. 
4. Click Join in the lower tool palette.
5. Without holding down the key, pick the object

you want to join. Make sure you click on the end you want
joined when selecting the second object.

6. Set the desired parameters.
7. Click to join or to abort. 

Join Options:

- Joins the two selected objects while maintaining the
step count of the v-axis.

- Joins the two selected objects while maintaining the
step count of the u-axis.
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Insert
Adds a column of control points along the u and/or v-axis. 
1. Select the object you want to insert points on.

Inserted column of points will be between the currently
selected point and the next point in line.

2. Click Reshape in the main tool palette. 
3. Click Insert in the lower tool palette.
4. Set the desired parameters.
5. Click to insert or to abort. 

Insert Options:

- Adds a column of points along the object’s u-axis.
The number represents where the new column will
lie between the current column and the next column
in the patch.

- Adds a column of points along the object’s v-axis.
The number represents where the new column will
lie between the current column and the next column
in the patch.
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Remove
Removes a column of control points along the u and/or v-axis. 

1. Select the object you want to effect.
2. Click on a point in the column you want removed.
3. Click Reshape in the main tool palette. 
4. Click Remove in the lower tool palette.
5. Set the desired parameters.
6. Click to remove or to abort. 

Remove Options:

- Removes a column of points along the object’s
u-axis.

- Removes a column of points along the object’s
v-axis.



PiXELS:3D Reshape Tools

PiXELS:3D 7.45

Flip
Reverses the object across the x, y or z plane.
1. Select the object you want to flip.
2. Click in the main tool palette. 
3. Click in the lower tool palette.
4. Set the desired parameters.
5. Click to flip or to abort. 

Flip Options:

- Flips the object’s position values as well as
the geometry.

- Flips the object on its x-axis.
- Flips the object on its y-axis.
- Flips the object on its z-axis.
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Disrupt
Randomly displaces every vertex on the selected patch. 

1. Select the object you want to disrupt.
2. Click Reshape in the main tool palette. 
3. Click Disrupt in the lower tool palette.
4. Set the parameters.
5. Click to disrupt or to abort. 

Disrupt Options:

X - Sets the maximum displacement factor for X.
Y - Sets the maximum displacement factor for Y.
Z - Sets the maximum displacement factor for Z.
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Invert
Reverses the surface normals.

1. Select the object you want to invert.
2. Click in the main tool palette. 
3. Click in the lower tool palette.
4. The object’s normals are now inverted. Use the 

( ) menu item to view the normals.
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3 D Emboss
Uses the luminance values from any PICT image to displace the
selected patch.

1. Select the object you want to emboss.
2. Click Reshape in the main tool palette. 
3. Click 3 D Emboss in the lower tool palette.
4. Set the parameters.
5. Click to emboss or to abort. 

3 D Emboss Options:

Image Box - Displays the current PICT image. If none is selected,
this box will display a message stating so. Click on this
box to load a PICT image.

Displacement - The offset factor. This number is multiplied by the
luminance of the displacement map at any given pixel
to factor how far to offset each vertex. The luminance
values are read as decimals ranging from 0 for pure
black to 1 for pure white.

XY Mapping - Maps the x to u and y to v.
YX Mapping - Maps the y to u and x to v.
Displace Normals - Displacement will follow the surface normal.
Displace XYZ - Displacement will follow the selected axis.
X - Allows displacement along the x-axis.
Y - Allows displacement along the y-axis.
Z - Allows displacement along the z-axis.
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Clip 
Removes any portion of the selected object which lies in the negative
coordinate area of any selected axis. 

1. Select the object you want to clip.
2. If necessary, rotate or move the object so that the part of the

object you want to trim off is positioned in the negative half
of the coordinate axis you are going to use for clipping.

3. Click Reshape in the main tool palette. 
4. Click Clip in the lower tool palette.
5. Set the axis you want to clip using the check boxes in the

dialog.
6. Click to clip or to abort.

Clipping Options:

- Clips any portion of the selected model which lies
below 0 along the x-axis.

- Clips any portion of the selected model which lies
below 0 along the y-axis.

- Clips any portion of the selected model which lies
below 0 along the z-axis.
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Close Ends 
Adds flat or rounded end caps to the open sides of a selected object.

1. Select the object you want to close.
2. Click Reshape in the main tool palette. 
3. Click Close Ends in the lower tool palette.
4. Set the parameters.
5. Click to close or to abort. 

Close Ends Options:

- Sets the angle between the end cap and object at
90°. For B-Splines and NURBs this option also
doubles-up the vertices at the corner to sharpen it.

- Sets the angle between the end cap and object at
45°. Also takes into account the Radius parameter
when factoring edge smoothness.

- Sets the distance between the rounding vertices.
The distance is equal to Radius multiplied by the
distance to the end cap’s center. Vertices closest to
the end cap are moved in by this amount, all other
rounding vertices are moved back by
this amount.
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Optimize
Streamlines planar surfaces by removing redundant vertices that do not
affect the object’s geometry.

1. Select the object you want to optimize.
2. Click Reshape in the main tool palette. 
3. Click Optimize in the lower tool palette.
4. The computer will display a progress bar to let you know it’s

working. When it’s done, the model will be optimized.
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Re-Order
Recreates the existing spline as closely as possible using the desired
number of vertices.

1. Select the object you want to re-order.
2. Click Reshape in the main tool palette. 
3. Click Re-Order in the lower tool palette.
4. Set the desired options and click to accept or to

abort.

Reorder Options

- Sets the number of vertices the resulting spline will
have.

- The resultant spline will have evenly spaced
vertices.

- The resultant spline will have randomly spaced
vertices.
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Cylinder
A straight spline rotated 360° around an axis.

1. Click Shape in the main tool palette. 
2. Click Cylinder in the lower tool palette.
3. Name the object. Naming objects makes them easier to

select from the command line. This is nice when dealing with
a large scene.

4. Set the and 
parameters as desired.

5. Click to create the shape, or click to abort.

Cylinder Options:

- The number of vertices circling the cylinder. A
higher value makes the cylinder rounder but may
take longer to redraw and render. The minimum
number is 3.

- Represents the number of rings this cylinder will
have. A value of 1 will create a circle.

- How far to spin the spline which will form the
cylinder. 360° represents a full, closed cylinder.

- The width (x) and height (y) of the finished cylinder.
- The depth (z) of the finished cylinder.
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Sphere
A semi-circular spline which has been rotated 360° around an axis.

1. Click Shape in the main tool palette. 
2. Click Sphere in the lower tool palette.
3. Name the object. Naming objects now makes them easier to

select from the command line. This is nice when dealing with
a large scene.

4. Set the and
parameters as desired.

5. Click to create the shape, or click to abort.

Sphere Options:

- The number of vertices circling the sphere. A higher
value makes the sphere smoother but may take
longer to redraw and render. The minimum number
is 3.

- Represents the number of rings this sphere will
have. The minimum number is 2.

- 360 degrees forms a full sphere.
- 180 degrees forms a full sphere from top to bottom.

- The width (x) and height (y) and depth (z) of the
finished sphere.
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Cone
A cylinder with the x and y axis scaled down to a point at one end.

1. Click Shape in the main tool palette. 
2. Click Cone in the lower tool palette.
3. Name the object. Naming objects now makes them easier to

select from the command line. This is nice when dealing with
a large scene.

4. Set the 
parameters as desired.

5. Click to create the shape, or click to abort.

Cone Options:

- The number of vertices circling the cone. A higher
value makes the cone rounder but may take longer
to redraw and render. The minimum number is 3.

- Represents the number of rings this cone will have.
The minimum number is 2.

- How far to spin the spline which will form the cone.
360° represents a full, closed cone.

- The width (x) and height (y) of the finished cone.
- The depth (z) of the finished cone.
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Mesh
A flat plane which can be formed into a 3 D shape by pushing and
pulling its points.

1. Click Shape in the main tool palette. 
2. Click Mesh in the lower tool palette.
3. Name the object. Naming objects now makes them easier to

select from the command line. This is nice when dealing with
a large scene.

4. Set the 
parameters as desired.

5. Click to create the shape, or click to abort.

Mesh Options:

- The number of vertices along the u-axis The
minimum number is 2.

- The number of vertices along the v-axis. The
minimum number is 2.

- The width (left to right) of the finished mesh.
- The depth (front to back) of the finished mesh.
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Cube
A six sided solid block.

1. Click Shape in the main tool palette. 
2. Click Cube in the lower tool palette.
3. Name the object. Naming objects now makes them easier to

select from the command line. This is nice when dealing with
a large scene.

4. Set the and 
parameters as desired.

5. Click to create the shape, or click to abort.

Cube Options:

- The number of vertices along the u-axis The
minimum number is 4.

- The number of vertices along the v-axis. The
minimum number is 1.

- The width (left to right) of the finished cube.
- The height (top to bottom) of the finished cube.
- The depth (front to back) of the finished cube.
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Spline
The most basic primitive. This is the building block upon which all other
shapes are based.

1. Click Shape in the main tool palette. 
2. Click Spline in the lower tool palette.
3. Click in any window to enter drawing mode and start

drawing. The first click defines the position of the first vertex.
Each subsequent click will define the next vertex in line.

4. Double click to add the last vertex and exit drawing mode, or
click on the first vertex to close the shape and exit drawing
mode.

5. Use to name the object. Naming
objects now makes them easier to select from the command
line. This is nice when dealing with a large scene.



PiXELS:3D Shape Tools

PiXELS:3D 7.61

Extrude
Pulls a 2-D spline into 3 D space along a pre-defined axis.

1. Select the spline to be extruded. 
2. Click Shape in the main tool palette. 
3. Click Extrude in the lower tool palette.
4. Set the parameters as desired.
5. Click to create the shape, or click to abort.
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Extrude Options:

- The number of vertices along the v-axis The
minimum number is 2.

- The depth (front to back) of the finished object.
- Creates a 45° edge between both faces and the

extruded object. This option will add v-steps to the
finished object if needed. 

- How far the bevel pushes the surface out. A
negative number will push the bevel inward.

- How far the bevel will extrude from the current face.
- Place a bevel on the front face of the extruded

o b j e c t .
- Place a bevel on the back face of the extruded

o b j e c t .
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Lathe
Spins a 2-D spline around the y-axis to create a new 3 D shape.

1. Select the spline to lathe. The spline must be drawn in the
front or right window. The revolution is made around the y-
axis.

2. Click Shape in the main tool palette. 
3. Click Lathe in the lower tool palette.
4. Set the parameters as desired.
5. Click to create the shape, or click to abort.

Lathe Options:

- The number of vertices along the u-axis The
minimum number is 4. The higher this number, the
rounder the final shape will appear.

- The spline will revolve (counter clockwise) the
number of degrees set around the y-axis.

- Closes the object ends.
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Loft
Creates a 3 D object from a collection of splines defining “slices” of the
object.

1. Draw or import a collection of splines representing different
“slices” of the object.

2. Select the first slice of the object.
3. Click Shape in the main tool palette. 
4. Click Loft in the lower tool palette.
5. Without holding down the key, pick each

consecutive slice. As these are selected, a 3 D object will
form.



PiXELS:3D Shape Tools

PiXELS:3D 7.65

Light
Places a light source in the scene and sets its intensity. Any number of
lights may be placed in a scene, and each can be colored and moved.

1. Click Shape in the main tool palette. 
2. Click Light in the lower tool palette.
3. Use the tool to place the object anywhere

in the scene.
4. Set the parameters as desired.
5. Click to create the light, or click to abort.
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IK chain
Allows you to draw kinematic chains. There is no limit to the number of
joints allowed in a single chain.

1. Click Shape in the main tool palette. 
2. Click IK Chain in the lower tool palette.
3. Click in any window to enter drawing mode and start

drawing. The first click defines the position of the first joint.
Each subsequent click will define the next joint in the chain.

4. Double click to add the last joint and exit drawing mode.

IK Chain Options:

Inverse Forward Kinematics—creates a hierarchy in which each joint is
linked to the previous joint in the IK chain.

Inverse Kinematics Only—Creates no hierarchy. Each joint is
independent of the other joints in the IK chain.
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Lattice
A special primitive which resembles a cube. The lattice defines an area
in 3 D space. This area can be deformed by reshaping the lattice. Any
point on any object linked to this lattice, which falls within this lattice, will
be remapped to the lattice’s deformed 3 D space.

1. Select the object you want to create a lattice around.
2. Click Shape in the main tool palette. 
3. Click Lattice in the lower tool palette.
4. Set the parameters as desired.
5. Click to create the lattice, or click to abort.

Lattice Options:

- The number of subdivisions this lattice will have left
to right and top to bottom.

- The number of subdivisions this lattice will have
front to back.
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Extract
Copies the currently selected u-col or v-col and pastes it into the scene,
creating a new 2-D spline.

1. Select the object and col to extract.
2. Select either U-Col or V-Col constraint. If neither is selected

V-Col is assumed.
3. Click Shape in the main tool palette.
4. Click Extract in the lower tool palette.
5. The selected u-col or v-col will be extracted and become the

currently selected object.
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Path extrude
Creates a 3 D object by projecting one spline along another spline
which is used as a path.

1. Select the object to extrude.
2. Click Shape in the main tool palette.
3. Click Path Extrude in the lower tool palette.
4. Without holding down the key, pick the path to

extrude along.

Null
Creates a simple primitive which represents a position in space. A null
does not show up when rendered.

1. Click Shape in the main tool palette.
2. Click Null in the lower tool palette.
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4 sided blend
Uses four user defined boundary curves to interpolate a patch.

1. Use the Spline tool to draw four boundary curves. The
number of steps need not be the same in any of the splines,
but the direction of the opposing curves (front/back and
left/right) should be the same. If not, the resultant shape will
have a twist.

2. Arrange the curves such that they define a boundary. The
corners need not touch, but the closer they are the better.

3. If desired, name them front, back, left and right. This makes
it easier to select in step 6.

4. Click Shape in the main tool palette.
5. Click 4-Side Blnd in the lower tool palette.
6. Use the four pop-up menus to select your boundary curves.
7. Set the number of steps for and 
8. Click to build your blended object or to abort.

4 Sided Blend Options:

- The number of subdivisions the resultant object will
contain along the u-axis.

- The number of subdivisions the resultant object will
contain along the v-axis

- The spline primitive defining the front boundary of
the resultant object.
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- The spline primitive defining the left boundary of the
resultant object.

- The spline primitive defining the rear boundary of
the resultant object.

- The spline primitive defining the right boundary of
the resultant object.
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Trim Surface
Converts a 2D spline drawn in the front (xy) view into a renderable
surface with the same shape as the original spline. If additional 2D
splines are linked to the spline being trimmed, they will be incorporated
into the trim surface as well.

1. In the front view, draw a spline. If you prefer, splines can be
imported from Adobe Illustrator.

2. With the spline selected, click Shape in the main tool palette.
3. Click Trim Surface in the lower tool palette.
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Pencil Test
Renders a B&W wireframe of all the frames in an animation, then plays
them back in real time.

1. Create an animation.
2. Click Animate in the main tool palette.
3. Click Pencil Test in the lower tool palette.
4. Set the and in the 

dialog. Click .
5. The computer will render each frame, one by one. When it is

done, it will play them back at full speed.`
6. To stop playback, click the mouse.
7. To scrub through frames, hold down the mouse and move

left to rewind or right to fast forward.

Pencil Test Options:

- First frame in the Pencil Test Animation.
- Last frame in the Pencil Test Animation.

- Forces renderer to draw every nth frame.
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Offset Keys
Moves all keyframes for the current object or all objects in a scene.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Offset Keys in the lower tool palette.
4. Enter an offset value and a frame range. To alter all objects

in a scene, enable the All objects option. Click to accept
or click to abort.

5. All keyframes for the current object, or all objects, between
the inpoint and the outpoint will be offset by the value
defined.

Offset Keys Options:

- Defines a range of frames which this function will
effect.

- Defines an offset which the keyframes’ position in
time will be offset by.

- When enabled, forces the function to effect all
objects in a scene.
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Invert Keys
Flips all keyframes for the current object or all objects in a scene.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Invert Keys in the lower tool palette.
4. Enter a frame range. To alter all objects in a scene, enable

the All objects option. Click to accept or click to
abort.

5. All keyframes for the current object, or all objects, between
the inpoint and the outpoint will be inverted.

Invert Keys Options:

- Defines a range of frames which this function will
effect.

- Defines a pivot point around which the keyframes
will be flipped.

- When enabled, forces the function to effect all
objects in a scene.
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Scale Keys
Scales all keyframes for the current object or all objects in a scene.

1. Select an object.
2. Click Animate in the main tool palette.
3. Click Scale Keys in the lower tool palette.
4. Enter a scale factor value and a frame range. To alter all

objects in a scene, enable the All objects option. Click to
accept or click to abort.

5. All keyframes for the current object, or all objects, between
the inpoint and the outpoint will be scaled by the value
defined.

Scale Keys Options:

- Defines a range of frames which this function will
effect.

- Defines a reference frame for scaling.
- Defines a scaling factor which the keyframes’

position in time will be scaled by. (i.e. a value
of 0.5 = 50%)
All frames after the last frame scaled will be offset
such that they remain sequenced with this last
frame.

- When enabled, forces the function to effect all
objects in a scene.
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Dup. Keys...
Used to duplicate a set of keyframes for action that repeat in an
animation.

Duplicate Keys Options

- Specifies the range of frames from which
keyframes are copied.

- How many copies to make.
- If offset is zero, copies will be appended to the

existing function curve. If some non-zero value is
specified for Offset, each copy will be shifted
forward that number of frames.

- Copy keyframes for all object or just the selected
one.
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View PICT
A simple utility which allows you to quickly preview any PICT image.

1. Click Utility in the main tool palette.
2. Click View PICT in the lower tool palette.
3. Use the standard dialog which comes up to locate and

select a PICT file.
4. Click the button to accept.
5. A window containing your selected image will appear

centered on the main screen.
6. Click in the image window to return to normal operation.
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View TIFF
A simple utility which allows you to quickly preview any 24bit TIFF image.

1. Click Utility in the main tool palette.
2. Click View TIFF in the lower tool palette.
3. Use the standard dialog which comes up to locate and

select a TIFF file.
4. Click the button to accept.
5. A window containing your selected image will appear

centered on the main screen.
6. Click in the image window to return to normal operation.
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View PICTS
A simple utility which allows you to load and playback a series of PICT
frames.

1. Click Utility in the main tool palette.
2. Click View PICTs in the lower tool palette.
3. Use the standard dialog which comes up to locate and

select a the first frame of your animation. NOTE: the file
name must match standard PiXELS:3D file naming
conventions for sequentially numbered PICTs - file
name.#####.

4. Click the button to accept.
5. A window containing your selected image will appear

centered on the main screen. Each frame in turn will be
loaded and displayed. After all frames have been loaded into
memory they will be played back at the speed set under 

.
6. To stop playback, click the mouse.
7. To scrub through frames, hold down the mouse and move

left to rewind or right to fast forward.
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Render Texture
Allows complex procedural Shaders to be rendered out to uv maps
which can then be applied to the model.

1. Click Utility in the main tool palette.
2. Click Render Tex in the lower tool palette.
3. Set the desired options.
4. Click the to accept or to abort.

Render Texture Setup Options:

- A pop up menu which lists all the base
ShaderMaker nodes. Any one of these can be
rendered out.

- After rendering, the uv map is loaded into memory
and applied to the selected Shader component.
Note: the procedural shader used to render this
map will be overwritten. If you wish to keep this, the
Shader must be saved first.

- The size, in pixels:3d, of the resultant texture map.
- The file name given to the resultant texture map.

The Render Texture  tool has many uses. When dealing with complex
Shaders, this tool can be called upon to create a texture map which
renders much faster than a procedural Shader. If a procedural Shader is
being used on an object with an animated deformation, the Shader may
appear to slide through the object. Rendering a uv map resolves this
problem.
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Reset Schematic
If you have moved objects around in the Schematic view, this command
restores them to their original positions.
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Constraints Contents
Point  . . . . . . . . . . . . . . . . . . . . . . .8.3
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Point
Puts the Push/Pull tool into single point mode. The scene will reflect this
by highlighting only the point currently selected.

1. Click Point in the Constraints palette.
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U col
Puts the Push/Pull tool into U Col mode. The scene will reflect this by
highlighting the point currently selected and all points sharing that
point’s u-step. This tool can help orient you if you’re having trouble
seeing the difference between u and v.

1. Click U Col in the Constraints palette.
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V col
Puts the Push/Pull tool into V Col mode. The scene will reflect this by
highlighting the point currently selected and all points sharing that
point’s v-step. This tool can help orient you if you’re having trouble
seeing the difference between u and v. It can also be useful in
conjunction with the Reshape > Pinch tool to help you visualize which
points will be pinched.

1. Click V Col in the Constraints palette.

Mir U
Mirrors all Push/Pull deformations across the u-axis to help in the
creation of symmetrical shapes. NOTE: If a shape has an uneven
number of u-steps or if you have inserted u-steps on one side of a
model and not the other, this tool will not work properly. The starting
shape MUST be symmetrical to get predictable results.

1. Click Mir U in the Constraints palette.

Mir V
Mirrors all Push/Pull deformations across the v-axis to help in the
creation of symmetrical shapes. NOTE: If a shape has an uneven
number of v-steps or you have inserted v-steps on one side of a model
and not the other, this tool will not work properly. The starting shape
MUST be symmetrical to get predictable results.

1. Click Mir V in the Constraints palette.

Mir UV
Mirrors all Push/Pull deformations across an axis perpendicular to the
u-axis to help in the creation of symmetrical shapes.

1. Click Mir UV in the Constraints palette.
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X axis
Turns the x-axis on or off. Objects can only be transformed along axes
that are “on” (their buttons are pushed in). Works in conjunction with the
control tools to constrain movement.

1. Click X Axis in the Constraints palette.

Y axis
Turns the y-axis on or off. Objects can only be transformed along axes
that are “on” (their buttons are pushed in). Works in conjunction with the
control tools to constrain movement.

1. Click Y Axis in the Constraints palette.

Z axis
Turns the z-axis on or off. Objects can only be transformed along axes
that are “on” (their buttons are pushed in). Works in conjunction with the
control tools to constrain movement.

1. Click Z Axis in the Constraints palette.
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Tag
Sets the transformation selection mode to points rather than object.

1. Click Tag in the Constraints palette.
2. Hold down the key and click on any point to

select it.
OR hold down the key and click and drag a
rectangle around any points you want selected.
OR hold down the +shift keys and click on any point to
toggle it. (If it’s selected, it will become deselected. If it’s
deselected it will become selected.)
OR hold down the +shift and click and drag a rectangle
around any points you want toggled.

3. Use any of the transformation tools to scale, move or rotate
the selected points.

OR use the (PICT) tool to create a 2-D image
of the surface for texture map creation. (See 
(PICT) for more info.)

The Tag tool will only work when the Control tool group is selected. To
select points on objects other than the currently selected object, add the

key to any key combination listed above.



3D Basics

PiXELS:3D 9.3

3D Basics
Cartesian Space  . . . . . . . . . . . . . . .9.3

x, y, z Axis  . . . . . . . . . . . . . . . . . .9.3
x, y, z Coordinates . . . . . . . . . . . .9.3
x, y, z Planes  . . . . . . . . . . . . . . . .9.4
Global and Local Coordinates . . .9.4
Transformation  . . . . . . . . . . . . . .9.5
Translation . . . . . . . . . . . . . . . . . .9.5
Rotation  . . . . . . . . . . . . . . . . . . . .9.5
Scale  . . . . . . . . . . . . . . . . . . . . . .9.5

Basic Elements  . . . . . . . . . . . . . . . .9.6
Points . . . . . . . . . . . . . . . . . . . . . .9.6
Splines  . . . . . . . . . . . . . . . . . . . . .9.6

Spline Types . . . . . . . . . . . . . . .9.7
Linear  . . . . . . . . . . . . . . . . . .9.8
Hermite  . . . . . . . . . . . . . . . . .9.8
Catmull-ROM . . . . . . . . . . . . .9.8
B-Spline . . . . . . . . . . . . . . . . .9.8
NURBs . . . . . . . . . . . . . . . . . .9.8
Cardinal . . . . . . . . . . . . . . . . .9.8
Tau Spline  . . . . . . . . . . . . . . .9.8
Tensed B-Spline  . . . . . . . . . .9.8
Beta Spline  . . . . . . . . . . . . . .9.8

Mesh or Patch  . . . . . . . . . . . . . . . . .9.8
Basis  . . . . . . . . . . . . . . . . . . . . . .9.9

Primitive Shapes . . . . . . . . . . . . . . .9.9
Normals . . . . . . . . . . . . . . . . . . . . . .9.10
Center Splines . . . . . . . . . . . . . . . . .9.10
Camera  . . . . . . . . . . . . . . . . . . . . . .9.10
Interest  . . . . . . . . . . . . . . . . . . . . . .9.11
Lights  . . . . . . . . . . . . . . . . . . . . . . .9.11
Hierarchy . . . . . . . . . . . . . . . . . . . . .9.11



3D Basics

9.4 PiXELS:3D

Animation  . . . . . . . . . . . . . . . . . . . .9.12
Key Framing  . . . . . . . . . . . . . . . .9.12
Animating the Position
of an Object  . . . . . . . . . . . . . . . . .9.12



3D Basics

PiXELS:3D 9.5

3 D Basics

This section introduces basic 3D concepts and explains how they relate
to PiXELS:3D. If you are already familiar with the concepts and
terminology common to 3 D computer graphics, you can safely skip this
section.

Cartesian Space

The hardest concept for a first time user of 3D computer software to
understand, is the notion of working within a virtual three-dimensional
space. This problem is augmented by the fact that your input device (a
mouse) is limited to two-dimensional movement. That is, it cannot report
how high off the table it is, it can only report left to right and top to
bottom values. Furthermore, the computer screen is merely a two-
dimensional interface to this virtual three-dimensional space.

PiXELS:3D uses a mathematical representation of space known as the
Cartesian coordinate system to represent your 3D scene and then
project it onto your monitor’s 2D screen. (The term “Cartesian” is used
in honor of the French mathematician and philosopher Rene Descartes
(1596 – 1650), who was one of the first to employ such coordinate
systems.)

X,Y,Z Axis

The Cartesian coordinate system uses three
axis to represent position: x, y and z. The
positive x axis points to the right, the positive
y axis points up and the positive z axis points
away from you. Where these three axis
converge is called the Origin. The coordinates
of the Origin are (x=0, y=0,z=0). This can be
seen in any PiXELS:3D view. With the grid
turned on, look at the two darker lines—where
these lines intersect is the Origin.

XYZ Coordinates

The Cartesian coordinate system uses three coordinates to locate any
point in space. These coordinates are labeled x, y and z. As a short
hand they are sometimes written enclosed in braces and separated by
commas. For example, the Origin can be written as {0,0,0}.
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XZ, XY, YZ Planes

Because of the limitations inherent in a two-dimensional screen,
PiXELS:3D uses three views aligned with coordinate planes to help you
locate points in three-dimensional space. The Top, Front and Right
views represent these three planes.

Global and Local Coordinates

Each object in PiXELS:3D has its own local coordinate system. When
an object is created its center and orientation are the same as the
world’s. As you move and rotate the object, this changes. The world’s
center and orientation are still the same, but the object’s center and
orientation may have changed.

Take a simple square for
example. Say the upper-left
corner is located at {-5,5,0}.
When the object is first created,
that point is the same in local
and global coordinates because
the object’s center is at {0,0,0}.
If we move the object +7 along
the x axis and +3 along the
y axis, the upper-left corner
would now be at {2,8,0} in
global coordinates but would
remain at {-5,5,0} in local
coordinates—that is relative to
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the center of the object. In other words, any point can be specified
relative to its object’s local coordinate system or relative to the global
coordinate system shared by all objects.

Transformation

The size, location and orientation of an object in 3D space is known as
its ‘transformation’. When an object is first created, its transformation is
set to align with the global coordinates. Its position is set to {0, 0, 0}, its
size is set to {1, 1, 1} and its orientation is set to {0, 0, 0}. As you work
with an object, these values can change. 

Translation

This refers to an object’s position in space. There are three coordinates
that define an object’s position (x,y,z). These coordinates represent
where the center of an object is located.

Rotation

This refers to an object’s orientation in
space. An object will rotate around its
center, so moving an object’s center
can change the way it rotates. There
are three axis of rotation: x, y and z. To
help you visualize this, imagine that
each axis is a pole that your object is
glued to. If you grip the pole between
your forefinger and thumb and roll it
back and forth, how will your object
spin? This is the same rotation you can
expect from PiXELS:3D. 
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Scale

This refers to the size of the object. When an object is created or
parked, its scale is set to 1 (or 100%) for each of the axis—x, y and z.
These numbers represent scaling factors. To compute every point on a
model, the x, y and z components are multiplied by the x, y and z
scaling factors. With this in mind it becomes easy to see how different
values can change the size of your object (i.e. a scale factor of 2 for
each axis would double the object’s size.) The three axis’ scale factors
can be set independently of each other for squashing and stretching
effects—this is called differential scaling. 

Basic Elements

Points and splines, while not themselves visible in your final animation,
are used to control the shape and movement of the objects you see.

Points

A point by itself is merely a location in Cartesian space, but by
connecting multiple points we can start to build splines. Modeling
objects is no more than entering a series of 3D points to define shapes.

Splines

Splines are defined by multiple points, called Control Points. In its
simplest form, a spline is little more than a set of control points
connected together with straight lines. This is a Linear spline. To
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introduce a curve to this set of control points you would only have to
change the Basis by which the spline is computed. The Basis can be
changed using the palette’s and pop-up
menus. There are a total of nine spline types, or bases, supported by
PiXELS:3D. Each basis is described in the following pages.

Spline Types

Splines can be divided into two broad categories: Interpolating and
Approximating. An interpolating spline’s curve will always touch the
points that define it. This gives them a more drastic, skin-like bend than
approximating splines. Approximating splines have a very ‘soft’ curve
because they don’t necessarily touch the points that define them. Either
type of spline requires three or more control points to show any
curvature.

Some spline types have Tension and Bias parameters. The Tension
parameter controls the relative amount of curvature near the control
points of a spline. The Bias parameter controls how much the spline is
skewed to one side or the other of a control point. A very biased spline
will be flatter on one side a control point than the other.

PiXELS:3D provides nine types of splines:

Linear

The simplest spline that can be drawn—it is always the shortest
distance between two points on screen. A linear spline never bends,
and only needs two control points to be drawn. 
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Hermite Spline

A simple interpolating spline.

Catmull-ROM

A simple interpolating spline.

B–Spline

Short for Basis–Spline. A simple approximating spline.

NURBs

Stands for Non-Uniform Rational B-spline. NURBs have explicit weights
and tensions that can be set for each control point, varying the effect of
the line from point to point regardless of distance.

Cardinal

An interpolating spline with a tension parameter added.

Tau Spline

An interpolating spline with both tension and bias parameters added.

Tensed B-Spline

An approximating spline with a tension parameter added.

Beta Spline

An approximating spline with both tension and bias parameters added.

Mesh or Patch

A mesh is made up of two sets of splines that are perpendicular to each
other, and which share the same control points. The resulting grid of
splines defines a surface. In PiXELS:3D the two sets of splines are
referred to as u and v. Although the mesh’s points can be moved
around to change the shape (the geometry), the number of splines and
how they are connected (the topology) stays the same. The resulting
surface is like an infinitely stretchable quilt. You can create more places
to ‘tug’ on a surface by adding a new set of control points to u or v.
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Basis

A single mesh can be constructed from two different types of splines,
one for the u and one for the v. These are referred to as the u Basis
and v Basis.

Primitive Shapes

PiXELS:3D provides you with a library of pre-made objects that are
known as primitives. These can be used as-is, or as a starting point for
modeling more detailed objects. They are the most commonly used
shapes in their simplest forms - Sphere, Cube, Cylinder, Cone, Mesh
and Spline. 

Each of the primitive objects available from the PiXELS:3D library is
constructed from a single mesh. (i.e. The cylinder is simply a rolled up
mesh, and the cone is a cylinder with one end tapered shut.) The
unique power of meshes will allow you to achieve many effects when
you are shaping these primitives. By deleting some of the splines from a
mesh you can slice off sections of a sphere, or chop off levels of a
cylinder until it is just a small ring. Keep in mind that when you deal with
any shape in PiXELS:3D, it can be rolled out to an oblong mesh.
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Normals

The surface normal is a vector (line) which points perpendicular to
(away from) the surface it originates from. Since models have more
than one surface knowing which way the normals are facing can help
you understand how a model will be effected by a particular
function.This is important when rendering a model or for calculating
complex operations such as collision. 

If the normals of a model become inverted, certain routines may behave
erratically or your model may render incorrectly. PiXELS:3D provides
controls that allow you to change the direction of the normals. 

Center Splines

Each primitive in PiXELS:3D has an invisible central spline along which
it is constructed. There are four control vertices that are positioned on
the center spline. Each of these can be selected and moved
independently in order to change the shape of the center spline. As the
center spline is altered, the object’s geometry will bend to follow this
spline, thus creating a new shape. With this procedure, it is relatively
simple to create complex bending and twisting for modeling or
animation purposes. 

Camera

The Camera is a default object, that is to say it always exists (you can’t
delete it). Because the Camera is an object, it can be moved and
animated. There are many settings that can be applied to the Camera
such as its position, angle, field of view and shutter speed. All of the
same rules of animation apply to the Camera as to any other object. 
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Interest

The Interest represents a point in 3 D space which the Camera looks at.
Anywhere the Interest goes, the Camera will track. The Interest can be
linked to other objects, forcing the Camera to track that object. This is
useful in “fly-by” animations, where the Camera is to follow a fast
moving object. The Interest can also be linked to the Camera. This
allows you to set the absolute rotation of the Camera. The Interest is, by
default, located at {0,0,0}.

Lights

A light source is a special kind of primitive. Upon startup there is a
default light located at {50, 50, -50}. There are a number of different
types of lights that can be added to a scene, including spot, point, sun
and glow. Many settings such as color, intensity and position of a light
can also be controlled and animated.

Hierarchy

Objects may be grouped together in a
hierarchy to facilitate manipulation or
to share material. The original object
is known as a parent and each object
linked to it is known as a child.

The best way to understand the
concept of hierarchy is to refer to a
tree. First there is the trunk; then
there are the branches; then there
are the leaves. If you select the trunk
of the tree and move it, all of the
branches and the leaves will move
along with it. If you select one branch
and move it, its branching and the

leaves will move accordingly. If you select only one leaf, only that leaf
will move. In PiXELS:3D, hierarchies behave the same way but the
combination of links that can be created is almost infinite.
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Animation

In PiXELS:3D, all objects including models, lights and the Camera
can be animated. Each of these items have different settings
(parameters) that can also be animated. For example, you can
animate an object’s scale, rotation, translation and shape. You can
animate the color, position, shadow and Interest of a light. You can
animate any component of an object’s texture or shader. Plus, you
can animate  the position, Interest, roll, and focal distance of the
Camera. Creating computer animation involves making changes to
these parameters over time and assigning them to “key frames”.

Key Framing

Animations are made up of individual images known as frames. An
animation is created when a series of frames that have slight variations
from one frame to the next are displayed one after another over time. 

Key framing is at the core of computer animation and involves the
following steps. First a starting frame is created on a timeline and all
parameters for each object in a scene is assigned  to it. Next, an ending
frame is created later on the timeline and all changes to any parameters
are assigned to it. The computer can compare the parameters assigned
to the starting and ending frames and calculate all intermediate frames
that would occur over time between them. This calculation is called
interpolation.

For example, if you tell PiXELS:3D that an object is large and red at
Frame #1 and is then small and blue at Frame #10, these two frames
are the keyframes. The computer will then calculate the intermediate
values for all of the frames in between the keyframes. So as you move
from Frame #1 to Frame #10 the large red ball will continue to get
smaller and turn bluer at each frame until it reaches the values that
were set for it at Frame #10. Thus, keyframing, combined with
interpolation, allows you to create complex animations with a minimum
amount of work.

Animating the Position of an Object

The position of an object can be animated in one of two ways: path
animation or keyframe animation.
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Path animation allows you to create a path (spline) that an object will
follow as it moves. Path animation creates only one function curve: the
values for the keyframes range from 0 to 100 and represent a
percentage of the path length. 

Keyframe animation allows you to animate the position of an object,
Camera or light by defining its original x,y and z coordinates at a
starting keyframe and its final x,y and z coordinates at its ending
keyframe. Three corresponding function curves are generated, one for
each x,y and z coordinate. 

For a more complete discussion of general 3 D animation techniques,
we suggest you read “3 D Computer Animation,” by John Vince
(Addison-Wesley) or “Digital Character Animation,” by George Maestri
(New Riders).
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Aliasing

Also known as “The Jaggies.” Unwanted image artifacts that can result
from sampling an image at too low a resolution. The effects, such as
jagged edges, breakup of lines into dots and Moiré patterns, are most
noticeable in high-contrast images with fine detail.

Bevel
The detailing of small angles where edges meet to soften and
appearance of the model. Bevels are also used to catch and reflect
light.

Bezier spline
Defines a curved surface by interpolating the first and last control points
along with the inner two points governing the curve’s direction.

Bias
The symmetry of the spline near a control point. A very biased curve will
be flatter on one side than the other.

Clipboard
A temporary storage area on the computer to hold the last item that was
cut or copied from the model. The Clipboard is a standard feature on all
Macintosh computers.

Interest
A point in 3D space which the Camera looks at.

Color Space
Any one of a number of methods for quantitatively describing colors,
such that each color is associated with a unique point in space.
Sometimes also called a Color Model.

Control points
Points on the surface of the object that determine the underlying
geometry of the object. The curve of a spline is determined by four or
more control points.

Default
Commonly preferred options set at program startup. Defaults may be
manually changed.
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Displacement Map
The gray level information of any PICT image applied to an object to
deform its geometry.

DXF
Drawing Exchange Format, a file format widely-used for architectural
drawings and other polygonal primitives.

Ease In
A value that defines how abruptly an object at rest accelerates.

Ease Out
The opposite of Ease In. A value that defines how abruptly an object in
motion reaches a dead stop.

Export
Saving files in a different format for use with other software applications.

Extrude
The modeling process of pulling 2-D outlines or profiles into
3 D shapes.

Freeform
Unique shapes that can be designed from drawn 2-D outlines.

Gouraud shading
Rendering technique which varies brightness across each surface
polygon to produce a smooth appearance.

Grid
The horizontal and vertical lines in the background that help place the
model in a perspective setting. The grid does not print.

Hidden line
Built-in rendering of the surface mesh of an object with overlapped or
obscured areas hidden.

Interpolation
Calculation of intermediate points between specified control points to
approximate and smooth the distance between the end points.
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Keyboard shortcuts
Keyboard equivalents that can be used as alternatives to pull down
menus and the mouse.

Lathe
The modeling process of creating a 3 D object by revolving an outline
around an axis.

Loft
Stretches a skin between 2-D shapes placed on a path to create a new
3 D shape.

Menu bar
The row of pull down menu names at the top of the screen.

Mesh
The two-dimensional undersurface grid applied to the model for shaping
purposes.

NURBs
Non-uniform rational B-splines which require an explicit specification of
the parameters that trace out the surface.

Phong shading
Rendering technique which produces shiny surfaces.

Photo realism
A high level of realism accomplished by applying lights, shading, and
textures to the 3 D model.

Picking
(Not selecting)—Clicking directly on an object without holding down the

key. This identifies the object so a specific operation may be
applied to it.

PICT
A graphics file format used by many computer applications. PiXELS:3D
can export rendered images into PICT formats.

Primitives
Common geometrical forms which are used as 3 D building blocks to
make more complex shapes.



Proxy
An approximation of the skeletal structure of the model without all the
wireframe details. PiXELS:3D uses this feature to shorten redrawing
time as changes are made to the model.

Renderer
A computer program that can calculate a final image from the geometry,
shading and lighting of a model stored in digital form.

Rendering
The process of computing the final appearance of an image based on
the geometry, shading and lighting of a model stored in digital form.
Rendering translates bits in a computer into pictures we can see.

Reshape
Modifications and alterations to a model that affect its geometry.

RIB
RenderMan Interface Bytestream protocol. The format generated and
required by MacRenderMan to render an image.

Screen refresh
Redrawing the screen image after changes have been made.

Selecting
(Not picking)— -clicking on an object. It makes the object active.

Shader
A computer program that calculates the appearance of any visible
object based on such parameters as color, roughness, transparency,
etc..

Spline
A curve that is defined by four control points.

Subdivision
The division of surface polygons into smaller polygons to create a
smoother finished appearance of an object.

PiXELS:3D Glossary

G.6 PiXELS:3D



Surface Normal
A vector perpendicular to the plane of every surface polygon used by
the computer to calculate brightness, highlights, reflections, and
distortions of the model.

Symmetry
Changes to a model which affect the shape along the X and Y axis
equally.

Texture mapping
A two-dimensional pattern applied to or wrapped around the surface of
a three-dimensional computer-generated model.

TIFF
Tagged Image File Format. An industry standard graphics file format
that represents an image as an array of pixels:3d. The Tags are used to
label the various kinds of information related to the image such as its
size, resolution, type of compression, etc.

Toggle Command
Operates like an on/off switch. Click on it to enable and click again to
disable.

Tool Palette
Modeling tools to shape, move and alter and manipulate 3 D forms.

U Step
Coordinate space along the horizontal plane of the surface mesh.

V Step
Coordinate space along the vertical plane of the surface mesh.

Vector
A mathematical entity that indicates both direction and magnitude. Think
of it as an arrow that can point in any direction and have any length.

Wireframe
The undersurface skeletal structure of the model.

Z axis
The coordinate used to determine the depth of a model.
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3DGF
3 D Geometry File format that supports spline-based objects but does
not carry shading information.
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Keyboard Shortcuts
Select command key
Pick no key needed
Pan shift key
Orbit control key
Dolly option key
Time control + shift keys
Move q
Rotate w
Scale e
Expand r
Center t
Align y
Park u
Command i
Link/Unlink o
Look/Unlook p
Path/Unpath Q
Instance W
Copy Shader E
Copy Shape R
Copy Keys T
Push/pull a
Spline s
Pinch d
Subdivide f
Collide g
Join h
Insert j
Remove k
Flip l
Disrupt A
Invert S
3D Emboss… D
Clip F
Close ends G
Optimize H
Re-order J
Point Z
U col X
V col C
Mir U V
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Mir V B
Mir HV N
X axis z
Y axis x
Z axis c
Tag v
cylinder 1
sphere… 2
cone… 3
mesh… 4
cube… 5
spline… 6
extrude… 7
lathe… 8
loft… 9
light 0
IK chain !
lattice… @
extract $
path extrude %
null &
4-side blend (
pencil test ,
offset keys +
invert keys <
scale keys -
duplicate keys >
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