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LIMITED WARRANTY AND DISCLAIMERS A. Limited Warranty on Media. Claris warrants the disks on which the Software is recorded to be free from
defects in materials and faulty workmanship under normal use for a period of ninety (90) days from the date of delivery as evidenced by a copy of
the sales receipt. Claris will, at its option, replace or refund the purchase price of the diskette at no charge to you, provided you return the faulty diskette
with the sales receipt to Claris or an authorized Claris Dealer. Claris shall have no responsibility to replace or refund the purchase price of a diskette
damaged by accident, abuse, or misapplication. ANY IMPLIED WARRANTIES ON THE DISKS, INCLUDING IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, ARE LIMITED IN DURATION TO 90 DAYS FROM THE DATE OF
DELIVERY.

B. Disclaimer of Warranty on Software. THE SOFTWARE IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, AND CLARIS
EXPRESSLY DISCLAIMS ALL IMPLIED WARRANTIES, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CLARIS DOES NOT WARRANT, GUARANTEE, OR MAKE ANY
REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF THE SOFTWARE OR ANY ACCOMPANYING
WRITTEN MATERIALS IN TERMS OF THEIR CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS, OR OTHERWISE. THE
ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE AND WRITTEN MATERIALS IS ASSUMED BY YOU.
CLARIS DOES NOT WARRANT THAT THE SOFTWARE WILL WORK CORRECTLY IN YOUR MULTI-USER OR NETWORK
ENVIRONMENT. IF THE SOFTWARE IS DEFECTIVE, YOU, AND NOT CLARIS OR ITS DEALERS, DISTRIBUTORS, AGENTS, OR
EMPLOYEES, ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR, OR CORRECTION. SOME STATES DO NOT
ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.

C. Complete Statement of Warranty. THE LIMITED WARRANTIES PROVIDED IN PARAGRAPHS A AND B ABOVE ARE THE ONLY
WARRANTIES OF ANY KIND THAT ARE MADE BY CLARIS ON THIS CLARIS PRODUCT. NO ORAL OR WRITTEN INFORMATION
OR ADVICE GIVEN BY CLARIS, ITS DEALERS, DISTRIBUTORS, AGENTS, OR EMPLOYEES SHALL CREATE A WARRANTY OR IN
ANY WAY INCREASE THE SCOPE OF THIS WARRANTY, AND YOU MAY NOT RELY ON ANY SUCH INFORMATION OR ADVICE.
THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOUMAY HAVE OTHER RIGHTS, WHICH VARY FROM STATE TO STATE.

D. Limitation of Liability. INNO EVENT WILL CLARIS, OR ITS DEVELOPERS, DIRECTORS, OFFICERS, EMPLOYEES, OR AFFILIATES
BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL, OR INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF THE USE
OF OR INABILITY TO USE THE SOFTWARE OR ACCOMPANYING WRITTEN MATERIALS, EVEN IF CLARIS OR AN AUTHORIZED
CLARIS REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR
INCIDENTAL DAMAGES, THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU. Claris’ liability to you for actual damages for any cause

whatsoever, and regardless of the form of the action, will be limited to the greater of $500 or the money paid for the Software that caused the damages.

U.S. Government Restricted Provisions

If this Software is acquired by or on behalf of a unit or agency of the United States Government this provision applies. This Software:

(a) Was developed at private expense, and no part of it was developed with government funds,

(b) Is a trade secret of Claris for all purposes of the Freedom of Information Act,

(c) Is “commercial computer software” subject to limited utilization as provided in the contract between the vendor and the governmental entity, and

(d) In all respects is proprietary data belonging solely to Claris.

For units of the Department of Defense (DoD), this Software is sold only with “Restricted Rights” as that term is defined in the DoD Supplement to
the Federal Acquisition Regulations, 52.227-7013 (c) (1) Gi) and:

Use, duplication or disclosure is subject to restrictions as setforth in subdivision (c) (1) (ii) ofthe Rights in Technical Data and Computer Software
clause at 52.227-7013. Manufacturer: Claris Corporation, 5201 Patrick Henry Drive, Box 58168, Santa Clara, CA 95052-8168.

If this Software was acquired under a GSA Schedule, the U.S. Government has agreed to refrain from changing or removing any insignia or lettering
from the Software or the accompanying written materials that are provided or from producing copies of manuals or disks (except one copy for backup
purposes) and: ri

(e) Title to and ownership of this Software and documentation and any reproductions thereof shall remain with Claris,

(f) Use of this Software and documentation shall be limited to the facility for which it is acquired, and:

(g) If use of the Software is discontinued to the installation specified in the purchase/delivery order and the U.S. Government desires to use it at another
location, it may do so by giving prior written notice to Claris, specifying the type of computer and new location site. U.S. Governmental personnel
using this Software, other than under a DoD contract or GSA Schedule, are hereby on notice that use of this Software is subject to restrictions which
are the same as or similar to those specified above.
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Welcome to MacDraw Pro

The MacDraw® Pro application is the powerful graphics standard for the

Macintosh. MacDraw Pro version 1.5 supports System 7 features. Additionally,

this version significantly improves MacDraw Pro performance.

This release of MacDraw Pro includes several new features:

options that let you control the speed of object and text drawing

Publish and Subscribe support, so you can create “live” links between

documents, applications, and other Macintosh computers on a network, and

have your changes updated automatically (when you’re using System 7)

options that give you control over text printing precision

QuickTime movie importing, exporting, and playing, so you can

incorporate movies into slide shows to enhance your presentations

new command shortcuts and convenient ways to work with colors, patterns,

and gradients

System 7 Balloon Help support, providing fast on-line information about

menus and window functions

W-l



New Macintosh or Claris MacDraw Pro Users

If you are new to Macintosh systems or MacDraw Pro, read MacDraw Pro
Getting Started. As you become familiar with the drawing tools and methods,

practice using the application and refer to Chapters 1 and 2 of MacDraw Pro
User’s Guide if you need help.

After you learn the basics of MacDraw Pro, browse through this New Features
Guide.

Experienced MacDraw Pro Users

If you’re an experienced user of this application, you can use the new features

right away. Refer to chapters 2 through 5 of this New Features Guide.

New Balloon Help

Cursor on tool icon

W-2

This version of MacDraw Pro supports System 7 Balloon Help, which is a

convenient way to see brief descriptions of the commands and tools you’ll use.

To get this information while MacDraw Pro is running, choose Show Balloons
from the question mark icon next to the Finder icon at the top right corner of
the window. Then put the cursor arrow ona tool, menu, or indicator you want
to learn about.

 

=
XQ Text Tool

  

  

(<a ET
  
  

Click to type text objects
in your drawings.

   Balloon text  

If you prefer to work without Balloon help, choose Hide Balloons from the

same menu.
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Installing MacDraw Pro
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/
Before you can use MacDraw Pro 1.5, you must install the application and files
on your system, and select a printer. The installer program provided in this

package places a copy of all the files you need in your system.

The installation instructions in this chapter replace the instructions in Chapter |
of MacDraw Pro Getting Started.



What's in the Box

The MacDraw Pro 1.5 package contains the following items:

four disks: Installer, Program, Reference, and Help

MacDraw Pro User’s Guide *

MacDraw Pro Getting Started *

this New Features Guide

MacDraw Pro Quick Reference Guide *

MacDraw Pro Color Guide *

* Not included in upgrade package

Hardware and Software Requirements

You must have the following hardware and software:

Hardware:

a a Macintosh Plus or later computer

= 2MBRAM;4 MB recommended for System 7 or for millions of colors

mw one 800K disk drive and a hard disk (minimum)

System Software:

System 6.0.5 or later; System 7 or later to use the Publish and Subscribe and

Balloon Help features

Finder 6.1.5 or later

32-bit QuickDraw 1.2 (not required for System 7, but supplied with
MacDraw Pro 1.5 for System 6 users).
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Installing MacDraw Pro 1.5

The Installer application installs the MacDraw Pro 1.5 application and files
onto your hard disk. You can install all the files at once on your system, or you
can install the required files and a selection of optional files (such as

dictionaries, sample files, tutorial files, and MacDraw Help) to conserve disk
space.

The Installer application creates the MacDraw Pro folder and places the
application and related files in it. It also places some files in the Claris® folder
in your System Folder. If you don’t already have a Claris folder, the installer
creates one for you.

The MacDraw Pro 1.5 Installer has been updated to require less disk space than
in the previous version.

¢ Note Extra space on your hard disk may be required during the installation
process. This space is freed after you’ve installed MacDraw Pro 1.5. If you
have more than one hard disk, install MacDraw Pro on the disk that
contains your system software. You can then drag the MacDraw Pro folder
to any hard disk.

Using the Easy Install Option

Easy Install places a copy of MacDraw Pro, as well as dictionaries, file
translators, color support, and tutorial and sample files on your hard disk.

To install all the files, you must have approximately SMB of space available on
your hard disk.

Using Easy Install:

1. Quit all open applications.

Insert the Installer disk.

Double-click the Installer icon.

When the Installer dialog box opens, click Install.

Follow the Installer prompts to insert disks.



Customise Install

1. Quit all open applications.

Insert the Installer disk.

Double-click the installer icon.

When the Installer dialog box opens, click Customize.

Click or Shift-click the files you want to install.

Click Install.

Follow the Installer prompts to insert disks.

Installing MacDraw Pro
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Improving Performance

2-2

MacDraw Pro 1.5 includes new features that help you create and revise text and

graphics faster, and use your system memory more efficiently. Most of these

improvements are automatic, and don’t require you to do anything. When these

features involve a tradeoff between performance and memory or on-screen

appearance, you can choose Preferences options to make adjustments that best

suit your own working requirements.



Controlling Object Displaying

You can control the way some objects are displayed, with options that can

make the process faster. To use these options, choose Preferences from the

Layout menu. Then click the Display icon.

 Figure 2-1
/ . Preferences

Draw direct to screen option 1

 

 

 

if Draw directly to screen (Screen Buffer Off)

DX] Greek text at: points or less Text display option

C1 Grid behind objects

 General

Panel icon @ Fast Gradient display

CO Best Gradient display Gradient display options
(Crmd-Opt-G to toggle)

 i  

Image Greeking |
. .

0 (Crd-Opt-I to toggle)| Image drawing option 

 

 

 
 

[   

a Touse less application memory, check the “Draw directly to screen” box.

When you select this option, MacDraw Pro shuts off the special display

buffer that makes on-screen drawing faster.

¢ Note Ifyou’re using the screen buffer for faster display and you’re running
low on memory as a result, MacDraw Pro will turn the buffer off
automatically and draw directly to the screen. Choose About MacDraw Pro

from the Apple menu to see the current state of the screen buffer.

= Todisplay small text as a pattern instead of actual characters, select “Greek
text.” You can also enter a point size, at which text will be displayed as a

gray rectangle. You can edit greeked text in the normal way.

@ Note Any greeked objects or text will be printed and saved normally.
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To draw gradients faster but with less on-screen detail, select “Fast
Gradient display.” To draw fully detailed gradients, select “Best Gradient

display.” The fast gradient appearance and drawing speed are improved
over previous versions of MacDraw Pro.

To display an EPSF, TIFF, bitmapped, or QuickTime object as a

“placeholder” instead of the actual image, select “Image Greeking.”

Controlling Text Printing

To set the text precision, choose Preferences from the Layout menu. Then click
the Printing icon. You'll see these options:

 
 Figure 2-2

Panel icon

Preferences
 

 

Maximum resolution (may limit QuickDraw
printer options).

Gradient printing steps:

@ 32 (300 dpi)
 

  

©) 64 (600 dpi)

© 128 (1200 api)

oO Custom: steps ‘gradient

@ Standard character placement (Faster) |
 Printing precision/speed

options
© Precise character placement (Slower) |
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To print text with standard precision, click “Standard character placement

(Faster).” In this mode, text won’t be printed with kerning or tracking
options.

To have high precision text alignment, click “Precise character placement

(Slower).” Use this mode if you want to print text for which you’ve

adjusted kerning and tracking.

Choose Precise character placement when you want to print text that is

kerned in the particular font you’re using, or when you’ve made custom

adjustments to inter-character spacing, or when you want text characters to

be precisely aligned with graphic objects.



= Choose Standard character placement for faster printing, when you don’t
need the more exact text precision in your document.

Figure 2-3

Precise Character Placement

Standard Character Placement

  

This is Tracked Text
This is Plain Text
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Using Publish and Subscribe
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MacDraw Pro 1.5 supports Macintosh System 7 Publish and Subscribe, a

feature that goes beyond simple copying and pasting. You can now transfer

data from one document to another, and have the copy updated automatically

whenever you change the original.

Publish and Subscribe transfers and updates data dynamically, from one

document to many documents and between Macintosh computers in a network.

This feature also lets MacDraw Pro and other applications that support Publish

and Subscribe exchange information.

For more information about Publish and Subscribe, refer to your System 7

Macintosh Reference or the User’s Guide you received with your Macintosh.



About Publish and Subscribe

Figure 3-1

Publisher

When you do “live” copying and pasting from one document to another, the

information appears in three places:

a The publisher. Any data in a MacDraw Pro document that you designate

to share.

a The edition. A separate file containing a copy of the publisher. An edition
is linked to its publisher, and you can have MacDraw Pro update it
automatically when you change the publisher or when you save the

publisher document.

u The subscriber. A copy of the edition that’s inserted into the same

document or other documents, even if they are on another disk or another

Macintosh in a network. The subscriber is the shared information, and you

can set it to update automatically whenever the edition changes.

This is how Publish and Subscribe elements are related:

 

 

Edition

Dandy Cand
vad

  Subscriber 

 

 

 

 

 
EcccunnMNCLLANN 

Publishers and subscribers are linked by the edition file. This link is maintained
even if any of the files involved are moved or renamed.

You can have any number of publishers and subscribers in a document.
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@ Note You must use System7 to set up publishers and subscribers. Once the

links have been established, you can use documents with publishers and

subscribers in System 6—but you can’t update those publishers and

subscribers automatically.

Setting Up Publishers and Subscribers

When you set up a publisher, you define part of your document as shared data

and save it to a separate edition file. When you set up a subscriber, you define

a link between a document and an edition file.

Setting Up a Publisher

To set up a publisher:

1. Choose Create Publisher from the Publishing submenu in the Edit menu.

The pointer changes from an arrow to a framer, which marks a corner of the

publisher area. To cancel the framer, click any tool icon.

2. Press and hold the mouse button as you drag the framer until the marquee encloses the area

you want to select.

Figure 3-2

 Marquee

 

When you release the mouse button, you see the Publisher dialog box.

3. Inthe Publisher dialog box, open the folder where you want fo save the edition file.
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4. Type a name for the edition file in the text box.

Changes that you make in the Publisher dialog box apply only to the

publisher you’ve just created:

 Figure 3-3
 

Preview [Usable Samples ¥ |

 

   

     

  

 

 

} Annual Report
\ nnual Renart Template

hibllography
Business Letter
Business Letterz
CEOs Letter

 arFolder and file list

DOC

Graphic “thumbnail” of the

publisher contents   

 

Name of new edition:
 

 
Publisher name entry box

(J Publish current layer only
i ion options

Publish selection opto (Publish whole objects only
   

5. Check selection options to limit the contents of the publisher.

To publish only objects contained in the frame on the current layer, click
the “Publish current layer only” check box. If you leave this option
unchecked, all framed objects on the current layer and below will be

included.

To publish only the objects that are completely enclosed in the marquee,

click the “Publish whole objects only” check box. If you leave this option
unchecked, objects just partially within the frame will be included.

@ Note MacDraw Pro recognizes grouped objects as a single object.

6. Click Publish.

MacDraw Pro saves a copy of the objects within the marquee frame as an

edition file, and puts a border around the published objects.
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Setting Up a Subscriber

To subscribe to an edition:

1. Open a document in which you want to place the subscriber.

It is possible to subscribe in the same document in which you’ve created a

publisher.

2. Choose Subscribe To from the Publishing submenu in the Edit menu.

You see the Subscriber dialog box.

 Figure 3-4
 = Hard Disk

Desktop

a { Subscribe )

 

 

Preview [a U

   

 

A picture of the selected

edition’s contents

 

     

3. Select the edition you want from the scrolling list and click Subscribe, or double-click the

edition name.

A copy of the edition appears in the document.

Working with Publishers

You can edit the data in a publisher, specify when the edition is updated, open

a publisher’s document from its edition file, cancel a publisher, and work with
more than one publisher at once.

Modifying a Publisher

You can change the contents of an edition by editing the publisher. Any

changes you make to the publisher or its contents are sent to the edition either

when you click the “Send Edition Now” option in the Publisher Options dialog

box, or when you save the document.
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To edit the publisher and select update options:

1. Add, edit, resize, or remove objects in the publisher.

2. Select the publisher by clicking its border.

You see the corner selection handles.

3. Choose Publisher Options from the Publishing submenu in the Edit menu.

You see the Publisher Options dialog box.

 Figure 3-5

Edition name and location

 

Publisher to: = Sphere Edition 1 y|
 

 

- $end Editions:
| Con Save Cancel Publisher

| @ Manually Send Edition Now

Latest Edition: Friday, February 26, 1993 11:27:14 4M

Last Change: Monday, March 1, 1993 2:30:00 PM

 

Update options  

  
 

C Publish current layer only
(C Publish whole objects only

Publisher selection options  

  
 

Changes you make in the Publisher Options dialog box apply only to the

publisher you’ve selected. You can change only one publisher at a time.

4. Specify when you want the edition to be updated.

In the Send Editions area, click “On Save” to update the edition whenever

you save the publisher document.

Click Manually to send changes only when you click Send Edition Now in

this dialog box or Send All Editions Now in the Edition List dialog box.

(See “Working With More Than One Publisher” on page 3-9.)

The Latest Edition date and time tells you when the edition was last

updated. If you select Manually, a second date and time shows you when

you last changed the publisher.
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5. Check selection options to reset the contents of the publisher and its edition.

To include only objects on the current layer, click the “Publish current layer
only” check box. If you leave this option unchecked, all objects within the

publisher’s border on the current layer and below will be included.

To include only the objects that are completely enclosed in the publisher’s
border, click the “Publish whole objects only” check box. If you leave this
option unchecked, objects not completely within the publisher’s border
will be published.

6. Click OK.

Opening a Publisher Through its Edition

Figure 3-6

You can open a publisher’s document from its edition on the desktop by
double-clicking the edition’s icon. You see a window with a PICT view of the

publisher contents:

 

== Sphere Edition 1  
 

 

 

  

PICT dPro Open Publisher
 

To open the publisher’s document, click Open Publisher. The document
containing the publisher opens. If the document’s application isn’t running, it
automatically launches and opens the publisher document. The document may
open behind the currently active window.

To return to the desktop without opening the publisher’s document, click the

window’s close box.



Canceling a Publisher

You can cancel a publisher without affecting the edition file or its subscribers.
After you cancel the publisher, you can’t send further updates to its edition.

To cancel a publisher:

1. Select the publisher by clicking its border.

2. Choose Publisher Options from the Publishing submenu in the Edit menu.

3. In the Publisher Options dialog box, click Cancel Publisher.

You can also cancel a publisher by selecting its name in the Edition List dialog
box, clicking Options, and then clicking Cancel Publisher. To break all the
links at once using the Edition List dialog box, see the next topic.

¢ Note Canceling a publisher is not undoable.

Canceling a publisher does not remove its edition. To remove the edition, drag
it to the Trash and empty the Trash. /

Working with More Than One Publisher

You can seea list of all the editions linked to the open document. This is useful
when you want to update or cancel all the publishers in a document, or to
change a publisher’s options without selecting it in the document.

1. Choose Edition List from the Publishing submenu in the Edit menu.

You see the Edition List dialog box.

 

Figure 3-7 Edition List
  

Selects all publishers related  

to open document
~@) All Publishers © All Subscribers

| oan ie Edition

 

 Edition names for publishers

in the active document

Sends all changes to all editions —

Cancels all publishers

gs Package Design Edition
ex Sphere Edition 1

 

 

 

 Closes this dialog box}—{ Send HY Editions Now | [- Done }-4
 

 

 +—— Shows publisher or
 

 
{Cancel All Publishers] _[ Options... H

  subscriber options
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2. Click the All Publishers radio button.

You seea list of all the editions linked to publishers in the active document.

a To update all the editions in the document at once, click Send All
Editions Now.

= Tocancel all the publishers in the document, click Cancel All
Publishers.

MacDraw Pro asks you to confirm the cancellation. If you click OK, you'll
break all links between publishers in the current document and their

associated editions. The edition files still exist, but you can’t update them.

3. When you finish, click Done.

You can also reset the options for an individual publisher by selecting its name

from the list and clicking Options.

Working with Subscribers

You can edit the data in a subscriber, set when the subscriber receives updates,

cancel a subscriber, and work with more than one subscriber at once.

Modifying and Updating a Subscriber

MacDraw Pro is preset to update a subscriber whenever its associated edition

changes. To change an edition, you must modify its publisher.

You can also edit the subscriber directly.

Going to the Subscriber's Publisher

If you have access to the document that contains the publisher, you can open it
from the subscriber.

To open a publisher’s document from a subscriber:
r

1. Select the subscriber.

2. Choose Subscriber Options from the Publishing submenu in the Edit menu.

3. Click Open Publisher.

The publisher’s application opens, if it is not already open.
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Editing the Subscriber in MacDraw Pro

In a MacDraw Pro document, you can move, resize, scale, and change the pen

weight of a subscribed object. You can also change fonts, font sizes, and font
styles. These changes affect all objects in the subscriber.

@ Note You can’t rotate the subscriber.

All your changes, except moving, are temporary until the next time the

subscriber is updated. To ensure that your changes remain in the document, you

must cancel the subscriber. See “Canceling a Subscriber” on page 3-13.

To edit individual objects in a subscriber, you must first cancel the subscriber

and then ungroup. If a subscriber is linked to an edition whose publisher is not
set to “Publish Whole Objects Only,” then some objects may be cropped in the

subscriber. When you cancel that subscriber, the formerly cropped objects will
reappear in their entirety and may expand beyond the subscriber frame. If you

ungroup those objects, they may fall outside the document’s boundaries. In that

case, MacDraw Pro warns you that you must move the objects away from the

edges of the drawing before you ungroup. .

¢@ Note If you check the “Publish whole objects only” option, MacDraw Pro

creates an edition that includes just the whole objects. When you subscribe

to that edition, partial objects won’t be included.

Updating the Subscriber

You can set a subscriber to update automatically when its edition changes, or
only when you request an update.

To set options for updating a subscriber:

1. Select the subscriber.
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2. Choose Subscriber Options from the Publishing submenu in the Edit menu.

You see the Subscriber Options dialog box.

 

 

 

 

 

 

 
 

 

  

 

  

Figure 3-8
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t Editions:
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Keeps or ignores resizing |_54 Keep size changes

changes  

You can also open this dialog box from the Edition List. See “Working
With More Than One Subscriber” on page 3-13.

3. Specify when you want the subscriber to be updated.

In the Get Editions area, click Automatically to update the subscriber as

soon as the edition file changes.

Click/Manually to update the subscriber only when you click Get Edition
Now.

The Latest Edition date and time show when the edition was last updated.

If you select Manually, a second date and time appear, showing when you

last updated the subscriber.

@ Note Any changes you make ina subscriber are temporary because they will
be overwritten at the next update. If you want to break the link and turn a

subscriber into a grouped object in the document, click Cancel Subscriber.

You can also suspend updates. See “Suspending Changes to Editions” on

page 3-15.

4. To update a subscriber manually, click Get Edition Now.

5. Click OK.

You can also update all the subscribers in the current document at once. See

“Working With More Than One Subscriber” on page 3-13.
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Canceling a Subscriber

You cancel a subscriber by deleting its link to the edition. The most recent

version of the edition remains in the document.

«@ Note You can cancel a subscriber in either System 7 or System 6.

)To cancel a subscriber:

1. Select the subscriber.

If you’re working with more than one subscriber, you can also use the

Edition List to select a subscriber. See the next topic.

2. Choose Subscriber Options from the Publishing submenu in the Edit menu.

You see the Subscriber Options dialog box.

3. Click Cancel Subscriber.

You can also cancel a subscriber by selecting its name in the Edition List
dialog box, clicking Options, and then clicking Cancel Subscriber. To

break all the links at once using the Edition List dialog box, see the next

topic.

4. Save the document.

Canceling a subscriber is not final until you save the document.

Working with More Than One Subscriber

You can seea list of all the subscribers in a document. This is useful when you

want to update or cancel all the subscribers, or select an individual subscriber

and change its options without selecting it in a document.

Using Publish and Subscribe 3-13



To use the edition list:

1. Choose Edition List from the Publishing submenu in the Edit menu.

You see the Edition List dialog box.

 Figure 3-9 Edition List
 

Edition names for subscribers ——-+

in the active document

Requests all changes from all ——
editions

© All Publishers @ All Subscribers

 

' gg Sphere Edition 1

 

 

 

 

—{ Get All Editions Now | {Done |

[Cancel All Subscribers] —_{{ options...]-4-—— Shows subscriber options
 

  |
 

j

Cancels all subscriber links to editions

2. Click All Subscribers.

r To update all the subscribers in the document at once, click Get All
Editions Now.

a Tocancel all the subscribers in the document, click Cancel All
Subscribers. Cancelling a subscriber does not affect the edition file.

MacDraw Pro asks you to confirm the cancellation.

3. Click OK or Cancel.

If you click OK, you either update all subscribers in the document or delete

the link between subscribers and their editions.

4. When you finish, click Done.

¢ Note If you change your mind, choose Revert to Saved from the File menu
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5. Save the source document.

You can reset the options for a subscriber by selecting its name from the list
and clicking Options. For more information on these options, see

“Modifying and Updating a Subscriber” on page 3-10.

Suspending Changes to Editions

If you set MacDraw Pro to update an edition automatically when you save its
publisher, or to update a subscriber automatically whenever its edition changes,

the following things can happen:

= Each time you save a publisher’s document, it takes a few seconds to send

updates to the edition and receive them in the subscriber’s document. This
delay may be inconvenient if you’re in a hurry.

m If you are modifying a subscriber, your changes will be lost if the

subscriber receives new information from an edition. You might not want
this to happen, for example, if you subscribed to a graphic and need to
analyze it for a while before you receive an update.

To suspend updates to editions and subscribers, choose the Suspend All
Editions command from the Publishing Submenu in the Edit menu.

When Suspend All Editions is active, the command is checked in the submenu.

When you choose Suspend All Editions again, it becomes unchecked and

editions are updated with all the changes made to the publishers since you
suspended them.

MacDraw Pro saves this setting with the document.
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Publisher and Subscriber Borders

MacDraw Pro marks publishers and subscribers by surrounding them with a

border. A publisher’s border is light gray; a subscriber’s is dark gray. The

borders never print.

 Figure 3-10

      a
 

Publisher border Subscriber border

If you don’t want borders to appear around all publishers and subscribers,

choose Hide Borders from the Publishing submenu in the Edit menu. To see

the borders again, choose Show Borders from the Publishing submenu.
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Using QuickTime Movies
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If you’ve installed QuickTime, you can bring movies into a MacDraw Pro 1.5

document and play them. You can do anything with a movie that you can with
another object—except rotate and flip it. You can also transfer movies between

MacDraw Pro and any other applications that support QuickTime.

As you play a QuickTime movie, you can control its sound volume, play it
through one time or continuously, advance or rewind it frame by frame, and

fast forward and rewind it.



Opening or Placing a Movie

To place a movie in a document window:

 

 

 

 

Figure 4-1
Place

List of availabl . 7 0 Animated package = Hard Disk
ist of available movies D Product Demo

0 TV commercial
Desktop

 

 

   
 

1. Choose Open or Place File from the File menu.

You see the Open or Place dialog box. |

Note The file type Movies will be included in the pop-up menu list only if
you’ve installed QuickTime. When QuickTime is installed, you'll see the

movie titles you can place in the document when “All Available” or

“Movie” is the pop-up menu selection.

2. Inthe Place dialog box, select a QuickTime file from the scrolling list and then click Place. The

selected movie appears as an object in the document.

If you have not set the image greeking option in the Display Preferences panel,

the current frame of the movie will appear in the document:

Figure 4-2 Selection handle ———————_  
Control badge
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Playing a Movie

Figure 4-3
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To select a movie, click anywhere on its image except on the control badge.
Then, you can resize the image by dragging a selection handle. You can also
reposition it anywhere in the document by dragging.

¢ Note Ifyou resize the movie, you’ll have poorer playback performance and
image quality.

To play the movie, click the control badge in the lower left corner. The badge
disappears and you see the current frame of the movie, as well as the movie
control dialog:

Movie object

 

   

 

Control palette (movable)
 

a[ai|i9|

[7 Continuous Looping

  

 

Play/Stop button 

  
|

Play continuously selection box
 

Volume control

1. Click the Play button.

When the movie starts, the Play button changes to Stop. Click it again to
stop playing at any point.

To play the movie repeatedly, click the Continuous Looping box.

2. To raise or lower the volume, click and hold the volume control button as you adjust the pop-

up volume slide.



Figure 4-4

Figure 4-5

Movie title

To step through the movie frame by frame:

= Click the right frame step button to advance one frame at a time; click the

left button to rewind one frame at a time.

  
   
  

 

)

    === Boat Movie

“TIE [}++— Frame step (forward and reverse) buttons

|— Forward/reverse slider

 

 

C Continuous Looping
  

To fast forward or rewind:

= Hold down the right frame step button (to fast forward) or the left frame

step button (to fast rewind); or move the slider left or right.

If you close the control dialog while the movie is playing by clicking in its close

box, (or by pressing Command-.), the movie continues to play. To make the

control dialog reappear, click anywhere on the movie image.

a To play a movie in slide mode, Command-click the movie.

You can greek a movie by selecting the Image Greeking option in Display
Preferences on the Layout menu.

 

Movie: Boat Movie 

Control badge i

 

   

To play a greeked movie, click its control badge.
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Tips for Maximizing Movie Performance

m If you close the movie control dialog while the movie is playing, or play
several movies at the same time, or resize the movie, playing performance
will be reduced.

a The monitor screen depth should match the depth of the movie. To see the
movie color depth, choose Show Size from View menu and then click and
hold the movie object. To compare the number of colors displayed in the
size bar with the current colors in your monitor, choose Monitors from
Control Panels in your System Folder. If there’s a difference, change the
number of colors in the Monitors dialog box.

a Allow as much RAM as possible. The more RAM, the better the playing
performance.

m You see the best playback when you have the movie controller open, or
when the movie is part of a slide show.

Copying a Movie or a Single Frame

To copy a movie, in playable form:

1. Select the movie image.

2. Choose Copy from the Edit menu, or press Command-C.

To copya single frame (as an image, but not playable):

1. Stop the movie on the frame you want to copy.

2. Press Command-Option-C.

Adding Movies to a Library

To add a QuickTime movie object to a library, select the movie and copy it.
Then choose New Library from the File menu or open an existing library, and
paste the object. You can place a movie in a document by selecting the movie
name from the library window and then clicking Place.

¢ Note You can rename movies in a Library dialog box. The movie name is
used during remote control play.

4-6



  

 

Using New Menus and Commands

— Flemeny

 



 

Using New Menus and Commands
/

This chapter describes the menus and commands that are new or changed in
MacDraw Pro version 1.5. For information about other menus and commands,
see MacDraw Pro User’s Guide.
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Apple menu

Figure 5-1

About MacDraw Pro

The About dialog box, which appears when you choose About MacDraw Pro

from the Apple menu, now includes information about the screen buffer. When

the buffer is on, you see the amount of memory it’s using. When the buffer is

off, you see whether it was turned off by you or by the application because of
memory limitations.

 

 

 

 
i ]

26K used 1122K free

Info about “Untitled! ":
Objects in layer: ia)

Objects in document: if)

Layers in document: 1

Colors in palette: 168
Total colors allocated: 183
Available colors: 256
Screen Buffer: Ooff*

 

* Currently limited by memory

 { Info ] [Credits | ([ Hhaut IIL OK |
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File menu

Window

Choose the Window command to display a submenu you can use to arrange

MacDraw Pro documents on the screen:

Figure 5-2
New 36N
New Library
Open... #0

Close sew
Save #S
Save As... P38S

 

Revert

 

Place File..

 
[ll] Tile Across
| Tile Down

Stack
fia Tile

Package Design
v Sales Presentation Open document list

Window arrangement options

 

 

 

  

Using window arrangement options:

 

 

 

 

To arrange windows... For document visibility Choose:

Vertically, left to right As much as possible Tile Across

Horizontally, top to bottom As much as possible Tile Down

Horizontal stack Title bars, except for top document Stack

Horizontally and vertically As much as possible Tile
 

You can also use the Window submenu to switch between open documents.

The names of all open documents appear below the window arrangement

options. When you choose a name from the list, that document is brought
forward on the screen and becomes active.



Edit menu

Publishing

Create Publisher

Use this command to create a publisher—a selected part of a MacDraw Pro

document that you want to share with other documents.

When you choose Create Publisher, you see a special selection cursor, the

framer, that you drag to form a marquee. When you’ve enclosed within the

marquee all the objects you want to publish, release the mouse button. The

Publisher dialog box appears.

Subscribe To

Opens the subscriber dialog box, which displaysa list of the editions you can

select and then insert in your document.

Publisher/Subscriber Options

This command is active when you have a publisher or subscriber selected. It
opens a dialog box you use to specify update options, get or send editions,

cancel publishers or subscribers, define publisher contents, and keep or ignore
resizing changes.

Edition List

Opens an Edition List of current publishers or subscribers for which you can

send or receive updates, and open the publisher or subscriber options dialog.

Hide/Show Borders

Hides or shows Publisher and Subscriber borders in the current document.

Suspend All Editions

This command discontinues updating of all publishers and subscribers in the

current document until you choose it again.
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Layout menu

5-6

Preferences

Contains options you can use to customize MacDraw Pro functions. On the left
side of the dialog box you see a scrolling list of icons. When you click an icon,

a panel of related options appears.

The Preference panels are:

= General

a Display

a Mouse

a Polygons

a Printing

a Publishing

a Translators

The following paragraphs describe only the new or changed options in
MacDraw Pro version 1.5. For information about other Preferences items, see

chapter 10 in MacDraw Pro User’s Guide.

Display

You have the option of rendering gradients in rough form, which results in

faster drawing of gradient-filled objects on the screen, or of rendering at higher
quality but at slower speed. You can also “greek” movies, TIFF, bitmapped,
and EPSF images and text so they’re not fully rendered on screen but shown as

marked boxes. Greeked objects print correctly.

Two options that were General preferences in MacDraw Pro 1.0 (“Grid behind

objects” and “Fast display of gradients”) are now Display preferences.

Publishing

The options in this panel let you change the default updating conditions for
Publishers and Subscribers.



Balloon Help

Printing

In this panel, you can set text printing to Standard character placement (faster)

or Precise character placement (slower speed).

To see balloons that contain brief explanations about MacDraw Pro tools and

commands, choose Show Balloons from the Help menu. When you place the

pointer on a tool, menu, or window icon, you seea text balloon.

To turn Balloon Help off, choose Hide Balloons from the Help menu.
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Displaying Color and Pen Size

Information

Scaling from the Center or from a

Corner

The Apple Events Slide Show Control

Fast Conversion Options
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Shortcuts and Conveniences

MacDraw Pro 1.5 includes new shortcuts and features that make it easy to:

a select objects by color, pattern, and gradient

= change foreground and background colors in patterns

m scale text with command keys

m= open the Layers dialog box by double-clicking

a display the number of object colors and pen size

mw specify a scaling reference point

= copy an individual movie frame

w close the movie control dialog with command keys

= control slide presentations and movies remotely

= convert files created in previous MacDraw versions
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Selecting Objects by Color, Pattern, or Gradient

You can select objects in your drawing by color, pattern, or gradient attribute.

You can also select objects with a combination of attributes by using the

eyedropper tool and the color, pattern, or gradient palettes. Begin by tearing off
the palette containing the attributes you want to select.

To select objects that have the same pen or fill attribute:

1. Click in the fill indicator or the pen indicator to specify whether you want to select by a fill or

pen attribute.

2. Inthe appropriate palette, click the color, pattern, or gradient you want to select for.

The attribute will appear in the indicator you’ve selected.

3. Click the eyedropper tool to select it.

4. Press Command-A.

MacDraw Pro selects all the objects in your drawing with the color, pattern,

or gradient you clicked.

To select objects that have both fill and pen attributes in common:

1. Select the fill indicator.

2. Inthe appropriate palette, click the color, pattern, or gradient for the fill you want to select

for. Or click the eyedropper tool and then click an object with the desired fill.

The attribute appears in the indicator you’ve selected.

3. Select the pen indicator.

4. Inthe appropriate palette, click the color or pattern for the pen you want to select for. Or click

the eyedropper tool and then click an object with the desired pen.

The attribute appears in the indicator you’ve selected.

5. Hold down the Shift key and click the fill indicator again.

Both the pen and the fill indicators are selected.
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6. Click the eyedropper tool.

7. Press Command-A.

MacDraw Pro selects all the objects that have both the attributes you’re

looking for.

Changing Color in Patterns

You can change the foreground and the background colors in patterns. The

preset pattern in the palette has a black foreground and a white background. To

changea pattern’s foreground and background color:

1. Tear off the color and pattern palettes.

2. Choose Patterns from the Layout menu, or double-click the pattern you want to edit.

The Pattern Editor dialog box appears.

3. Click a color from the color palette to replace the background; Option-click a color to replace

the foreground.

You see the color change in the Pattern Editor preview.

4. Click OK.

@ Note Color patterns with non-white background colors will not print

correctly to certain PostScript devices.

Text Scaling with Command Keys

To scale text in menu size increments:

1. Select the text.

2. Press Shift-Command-> to increase size; Shift-Command-< to reduce to reduce size.

To scale text in 1-point increments:

1. Select the text.

2. Press Shift-Option-Command-> to increase size; Shift-Option-Command-< to reduce size.
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Shortcut to Open the Layers Dialog Box

[a | You can open the Layers dialog box directly by double-clicking the white area

[| around the layer controls.

Displaying Color and Pen Size Information

To see the number of possible colors in bitmapped images (including movies):

1. Choose Show Size from the View menu.

2. Click on the object and hold the mouse button.

The bit depth, or maximum number of colors the object can contain,

appears to the right of other information in the Size bar at the bottom of the

window. The actual number of colors in the object may be smaller than the

number shown.

To see the current pen size, in points:

1. Choose Show Size from the View menu.

2. Click on the object and hold the mouse button.

The pen size of the object appears to the right of the pointer distances in the

Size bar.

Scaling from the Center or from a Corner

By using the Corner/Center Control, you can scale objects from the center or

from the upper left corner.

Center-to-edge control Corner-to-corner control

  

To scale with the center of the object as the point of reference:

1. Select the object you want to rescale.

2. Click the Corner/Center Control so the center-to-edge symbol appears.

3. Choose Scale Selection from the Arrange menu and enter the size percentage you want.

4. Click OK.
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To scale with the upper left corner as the point of reference:

1. Select the object you want to rescale.

2. Click the Corner/Center Control so the corner-to-corner symbol appears.

3. Choose Scale Selection from the Arrange menu and enter the size percentage you want.

4. Click OK.

Apple Events Slide Show Control

MacDraw Pro 1.5 includes a HyperCard® Apple events Slide Show Controller.
With this controller, you can run slide presentations and play movies as part of
a presentation.

A ReadMe file contains some basic information about this Controller.

File Conversion Options

To “drop launch” files created in MacDraw II or MacDraw Pro 1.0:

1. Drag the file icon over the MacDraw Pro 1.5 application icon.

Whenryou release the mouse button, MacDraw Pro 1.5 starts up, opens the

file, and converts MacDraw II files automatically.

2. Choose Save or Save As from the File menu and select a disk location for the converted file.

To convert files in the background if you’re using System 7, or System 6 with
MultiFinder:

1. While the file is converting, click the application selector icon at the extreme right end of the

menu bar.

2. Select another application and open a file.

¢ Note File conversion in the background is slower.
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