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License Agreement

Important!   Please read this licence agreement carefully before opening 
the disk seal! Opening of the disk seal and use of this package indicates 
your agreement to the following terms and conditions. Emagic grants you 
a non-exclusive, non-transferable license to use the software in this 
package.

You may:

1. use the software on a single machine.
2. make one copy of the software solely for back-up purposes.

You may not:

1. make copies of the user manual or the software except as expressly 
provided for in this agreement.

2. make alterations or modifications to the software or any copy, or 
otherwise attempt to discover the source code of the software.

3. sub-license, lease, lend, rent or grant other rights in all or any copy to 
others.

Except to the extent prohibited by applicable law, all implied warranties 
made by Emagic in connection with this manual and software are limited 
in duration to the minimum statutory guarantee period in your state or 
country from the date of original purchase, and no warranties, whether 
express or implied, shall apply to this product after said period. This 
warranty is not transferable-it applies only to the original purchaser of the 
software. Emagic makes no warranty, either express or implied, with 
respect to this software, its quality, performance, merchantability or 
fitness for a particular purpose. As a result, this software is sold “as is”, 
and you, the purchaser, are assuming the entire risk as to quality and 
performance. In no event will Emagic be liable for any direct or indirect 
damages resulting from any defect in the software or documentation.

This agreement will terminate if you fail to comply with any term or condi-
tion in this agreement.

This agreement shall be governed by the laws of the Federal Republic of 
Germany.

This manual, copy-protection and software described herein are copy-
righted © 1992—2002 by Emagic Soft- und Hardware GmbH, Halsten-
beker Weg 96, 25462 Rellingen, Germany
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Welcome

… to the Logic 5 Introduction Manual.

First up, we would like to congratulate you on your purchase. In 
choosing your version of the Logic line, you have selected the 
most widely used audio and MIDI production software in 
professional circles.

The diagram shows—in a counter-clockwise direction from the top left—
the Arrange window with several audio regions and MIDI sequences, the 
Score editor, the Matrix editor and the Track Mixer.

Chapter 1
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1.1 About the Introduction 
Manual and Reference 
Manual

We have created this Introduction Manual with the intention of 
introducing you to many of Logic’s features in a practical 
“hands-on” way. While you can certainly read the Introduction 
Manual on the beach or in your favorite easy chair, we would 
suggest that you take advantage of the accompanying song files 
supplied on your program CD-ROM. These files will assist you 
in quickly learning how to handle MIDI and audio information 
via a series of exercises and examples. 

For those of you who have a keen interest in Logic’s notation 
facilities, we have created an extensive Score Tutorial, which is 
available in electronic form on the program CD-ROM. You will 
also find a number of song files which will provide you with 
source material for the Score Tutorial.

We’re sure that you’re ready to “dive in” to Logic and start 
working through the remainder of the Introduction Manual, 
but before you do … 

We ask that you read the following sections in this chapter, 
which discuss the “basics” of Logic’s user interface and key 
information on Logic’s navigational aids. This information is 
essential reading as Logic offers a range of unique options for 
interaction with it’s user interface. You will need to be familiar 
with these techniques, and the terminology used, as this infor-
mation forms the basis of the Introduction Manual and will 
help you to develop good working habits from the outset. This 
will accelerate your use of Logic and will make learning the 
program more enjoyable and simpler.

The various editing windows, functions and options which you 
will be introduced to throughout the Introduction Manual are 
explained in further detail in the Reference Manual. This 
manual is designed as a reference work. In other words, you can 
open a specific chapter on a specific editing window, setup task 
10
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etc. and find information on it. You will also discover a number 
of further small practical examples as you work your way 
through the Reference Manual which will enhance your under-
standing of features and functions. As a result, a number of 
techniques discussed in earlier chapters (of both this Introduc-
tion Manual and the Reference Manual) are repeated, but as 
the old adage goes, “practice makes perfect”. 

We strongly recommend that you read the entire Reference 
Manual, in addition to this Introduction Manual. This Intro-
duction Manual is designed to get you “up and running” with 
Logic quickly. It is not the final arbiter on all things Logic and 
does not cover all areas of the program in detail.

As you follow the Introduction Manual, you will create your 
own working “template” song file, which will be customized to 
meet your needs and tastes. This template will form the basis 
of your future work with Logic.

Needless to say, you will be introduced to a lot of new termi-
nology as you’re reading through the Introduction Manual. 
This will be particularly noticeable throughout the early chap-
ters. We will include explanations and diagrams throughout to 
help you understand the terms and functions. So, don’t sweat it 
if you encounter a term that you’re unfamiliar with—it will all 
fall into place as you continue reading. On this point, please 
read the Introduction Manual in the order that it is laid out. 
Many techniques that you will learn in one section are directly 
transferable to another. This way, you will have the best 
possible experience as you familiarize yourself with Logic.

We also ask that you pay special attention to comments that 
feature the “Important!” entry shown alongside the text. 
These are generally key points that will help you to understand 
a concept or fact about Logic. Where you see the “Tip” entry 
alongside the text, it usually indicates a shortcut, or some extra 
information that will help to accelerate your use of the program.
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Menu Functions
Menu functions are written in this font: Function.

For functions which can be reached via hierarchical menus, the 
different menu levels are described as follows: Menu > Menu 
entry > Function.

Key Commands
When a function can be operated by a Key Command—that’s a 
computer keyboard shortcut—of the same name, you will see 
this symbol alongside the text. Many Key Commands make use 
of “modifier” keys—S, ç, O, and C in conjunction with 
other keys.

If the names of function and Key Command differ, or if a func-
tion is only available as a Key Command, its name will be 
printed as follows: Key Command. 

We strongly recommend that you use Key Commands when-
ever possible. This will accelerate your use of Logic massively. 
As you are learning how to use the software, we ask that you use 
the Key Commands as you are introduced to them. This will 
aid you in remembering the Key Command and in your under-
standing of the function.

Additional information on Key Commands can be found in the 
Key Commands section, from page 46 onwards.

Options and Parameters
Options set in Logic’s Preferences, and the parameters in 
dialog boxes are printed as follows: Parameters.

Different parameter values are shown as follows: Parameter 
value.

Detailed Explanations

� Periodically, detailed explanations will be written for things which you 
don’t necessarily need to know, in order to understand how to use 
Logic. These are printed in this smaller font.
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1.2 For Those Who Hate Manuals
If you’re a reasonably proficient computer user who is familiar 
with audio and MIDI sequencing, you may wish to skip directly 
ahead to the Using Logic chapter, from page 113, to “get your 
hands dirty”.

Chapters 1 and 2 cover the basics, and background information 
that you will need to know, in order to set up, and more fully 
use, your Logic system.

You can always refer back to these chapters as you’re working 
through the “Using Logic” chapter, if necessary.

We do ask, however, that you do find the time to read these 
chapters at some stage, as this will help you to understand the 
basic structure and mechanics of the program. It will also make 
learning and using Logic more fun, and more productive.

1.3 A Starting Point
In writing this Introduction Manual, we needed to decide on a 
starting point. To this end, we ask that before you begin:

• Your computer meets the minimum requirements necessary 
to run your version of Logic.

• You have followed the separate Installation Guide and have 
correctly installed your version of Logic on your computer’s 
hard disk.

• Your audio and MIDI interface hardware is correctly 
installed and has been identified and set up correctly in 
Logic.

For any hardware setup or software installation issues, please 
refer to your hardware manufacturer’s installation guide(s) and 
the Troubleshooting section of the Logic Installation guide. 
13
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1.4 What Is Logic?
The Logic software is an integrated 32 Bit audio and MIDI 
recording system with flexible notation, fully automated 
mixing and native audio DSP effects processing facilities. You 
can:

• Record MIDI information via connected MIDI input 
devices, such as keyboards, and play back this information 
via any connected MIDI device, including keyboards, 
modules and sound cards with a built-in synthesizer chip.

• Create, arrange and edit MIDI songs, and print out musical 
notation via a printer connected to your computer.

• Digitally record acoustic and electric instruments or vocal 
performances into your songs, and process these audio 
recordings through Logic’s in-built real-time effects.

• Add fully functional software synthesizers and samplers such 
as Emagic’s ES1, ES2, EVP88 and EXS24, or third-party 
VST 2.0 instruments to your copy of Logic. It should be 
noted that Logic ships with three software synthesizers, to 
get you started.

• Mix your MIDI and audio tracks, including effects and soft-
ware-based instrument settings, via a sophisticated total 
recall mix automation system.

• Bounce all audio data, including effects and mix automation 
settings, to a stereo (or multiple Surround format) file(s) for 
mastering or further processing.

Logic incorporates the functionality normally found in an 
entire professional audio production studio. All within an intu-
itive user interface and all within your computer.
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1.5 Audio and MIDI
Now that you know Logic can record and play back both MIDI 
and audio information, we have included the following which 
offers a brief and easy to understand description of both. If you 
already have an understanding of how MIDI and digital audio 
recording systems work, you can skip ahead to the Audio Tracks 
section, from page 22 onwards.

MIDI
MIDI is an acronym for Musical Instrument Digital Interface. 
To break this down further—the “Musical Instrument” part of 
MIDI refers to electronic musical instruments such as synthe-
sizers, samplers and even MIDI guitars. The “Digital Inter-
face” part sounds technical, but really isn’t. 

Basically, MIDI’s “Digital Interface” is broken down into two 
components.

1. MIDI is a computer-based language—and as you probably 
know, computers talk “digitally”. MIDI keyboards, mod-
ules and cards are actually computers in disguise.

2. MIDI’s “Interface” is just that. MIDI is a hardware stan-
dard which consists of a set of physical connectors labeled 
IN, OUT, and THRU. You will find one or more of these 
connectors on all MIDI devices, such as keyboards etc.

The MIDI Language
The “language” of MIDI is understood by all MIDI devices. 
The purpose of the language is to translate your musical perfor-
mance into information that can be understood by a computer. 
(Don’t forget that MIDI keyboards and modules are actually 
computers in disguise).
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When you play your keyboard, or Logic is playing a MIDI song 
file, MIDI information which describes your performance is 
transmitted as a string of “MIDI messages”. These instructions 
tell any connected synthesizer, soundcard etc. how to play a 
piece of music. The synthesizer, module etc. receiving the 
MIDI data actually generates the sounds which you hear. 

MIDI does not send sounds. It only sends instructions.

The MIDI Connection
MIDI, as mentioned, is also a hardware “interface” which 
consists of a standardized set of connectors labeled IN, OUT, 
and THRU.

MIDI connectors consist of a round socket with 5 holes 
arranged in a semicircle. MIDI cables, used for connecting 
MIDI devices have a matching plug with 5 pins. Only three of 
the pins actually carry information.

MIDI only works in one direction on each connector. If you 
want your MIDI keyboard to send messages to, and receive 
messages from Logic, you must connect two cables.

Here’s the way your MIDI connections must be made, in order 
to work:

• MIDI OUT connectors must be connected to MIDI IN 
connectors on the receiving device.

• MIDI IN connectors must be connected to MIDI OUTs

If you connect a MIDI OUT to another MIDI OUT or a MIDI 
IN to another MIDI IN, no communication will happen, and 
your MIDI system won’t work.

The MIDI THRU connector is not found on all MIDI devices. 
It simply mirrors the MIDI messages arriving at the MIDI 
input connector, and allows you to “daisy-chain” more MIDI 
devices. Before doing this, read the section on MIDI channels, 
which is very important when chaining MIDI keyboards, 
modules etc.
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The “MIDI messages” are sent from a MIDI controller such as 
a keyboard or sequencer—i.e. Logic—via the MIDI OUT 
connector. The device (MIDI synth or sound module) 
receiving the MIDI messages at its MIDI IN connector, 
responds to these messages by playing sounds. 

Remember, MIDI does not send sounds. It sends instructions 
on how, what and when to play.

Many MIDI keyboards include both the keyboard controller 
and MIDI sound module functions within the same unit. In 
these units, there’s an internal MIDI link between the 
keyboard and sound module. This internal link can be enabled 
or disabled by setting LOCAL ON or OFF—on the keyboard 
itself. 

When using your MIDI keyboard with Logic, and the keyboard 
is acting as both controller and sound module, you should set 
LOCAL to OFF. Doing so avoids “it sounds like my notes are 
doubled or flanging” types of problems. 

If your keyboard is simply acting as an input device, and you 
don’t want to use its sounds (or it doesn’t have any, as is the case 
with controller keyboards), you simply need to connect it’s 
MIDI OUT to the MIDI IN on your computer. Logic will take 
care of the “channels”, which we’re just about to take a look at.

MIDI Channels
MIDI is divided into 16 logical “channels”. Each channel is 
identified by a special channel number message that is sent 
with the other MIDI messages. Most keyboards can generally 
be set to transmit on any one of the 16 MIDI channels. A MIDI 
sound source—like your synthesizer, sound module or sound-
card—can be set to receive on a specific, or multiple, MIDI 
Channel(s). 

Devices capable of receiving on multiple MIDI channels 
simultaneously are said to be “multi-timbral”. The term liter-
ally means “many sounds”, which can be a little confusing, as 
most synthesizers are obviously capable of producing many 
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sounds. Not all synthesizers, however, are capable of producing 
many sounds at the one time. This capability means that a suit-
ably equipped MIDI keyboard, module or soundcard could be 
used to produce all of the drum, bass, piano, string and brass 
sounds in a performance. 

In this scenario, each part or instrument—drums, piano, strings 
etc.—will be assigned to a specific MIDI channel. Given the 16 
logical MIDI channels available to each MIDI port and a multi-
timbral synthesizer, up to 16 different “instruments” can be 
played simultaneously. Most modern MIDI keyboards, 
modules and sound cards are multi-timbral. 

In all MIDI systems, the sound module must be set to receive 
on the channel (or channels in multi-timbral devices) which 
match the channel(s) that the keyboard controller (or Logic) is 
transmitting on, in order to play sounds. If the channels do not 
match, the receiving device will not play. 

As an example: Imagine a 4-way multi-timbral device (a device 
capable of receiving on 4 MIDI channels simultaneously) is 
receiving song data from Logic with tracks assigned to channels 
1, 2, 4 and 5.

The device itself is set to receive on channels 4 to 8. In this 
case, only the song’s MIDI data sent on channels 4 and 5 would 
be “seen” by the device and subsequently played. The MIDI 
data sent on channels 1 and 2 would be ignored.

As you can see from the above example, each channel needs to 
be “tuned in” to a corresponding channel sent from Logic. 
This, if you use a little imagination, is not unlike tuning in a TV 
or radio channel. If the channel isn’t tuned properly, you won’t 
see or hear anything … and neither will your sound module.
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Audio
Audio, as a term, basically refers to any sound that you can hear. 
In the physical, as opposed to computer world, this is known as 
Analog Audio. When Logic records analog audio signals via an 
audio interface connected to, or installed in, your computer, the 
audio is converted into digital information. This information is 
stored as a Digital Audio file on your computer’s hard disk. 

As with MIDI, the “Digital Audio” part sounds technical, but 
really isn’t. As discussed earlier, computers talk “digitally” and 
need to deal with analog audio signals as digital information.

Unlike MIDI, digital audio files are actually recordings of 
sounds, not an instruction language.

Digital and Analog Recording
While digital audio recording is similar in concept to analog 
recordings made on tape, the technical differences are signifi-
cant. For much of the 20th century, analog tape recordings have 
been used for the storage of audio performances—spoken, sung 
and played. 

The analog tape medium (i.e. the tape itself) is a thin plastic 
strip coated in tiny metal particles. It is usually stored on a roll 
or spool or as a cassette tape, which you’re probably familiar 
with.

The process of analog tape recording involves the transmission 
of small electrical charges, sent to the magnetic “heads” of a 
tape recorder. Changes to the strength of these charges alter the 
magnetic fields generated by the heads and rearrange the posi-
tions of the metal particles on the tape. Needless to say, this is 
a less than precise science. Due to the randomness involved in 
the rearrangement of magnetic particles on tape (and other 
technical reasons), the recordings are said to be “analogous”—
i.e. similar to the actual performance.
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Digital recording, on the other hand, is much less random. 
Analog performances are converted to digital audio files via the 
ADC (Analog to Digital Converter) of the audio interface. 
These files, like all computer files, are stored “digitally”—i.e. 
as a series of ones and zeroes. Provided the source material and 
levels remain consistent, digital recordings will be virtually 
identical each time they are made. 

In a copying situation—i.e. tape to tape—there is no compar-
ison between analog and digital recordings. Each subsequent 
copy of an analog recording becomes noisier and less like the 
source material. This is the “random” factor of the magnetic 
particles becoming less like the original each time a copy is 
made. 

Digital audio files, on the other hand, can be copied any 
number of times, with each subsequent copy adding no noise.

On a more practical level, digital audio files stored on hard disk 
have the following advantages over analog audio stored on tape.

• Digital audio can be cut, copied and pasted freely from loca-
tion to location. Could you imagine physically cutting a 
stereo analog recording—i.e. a tape—into even four or five 
segments and splicing them back together?

• You can move to any spot in a digital audio file almost 
instantly rather than waiting for the tedious mechanical 
rewinding and fast forwarding of an analog tape machine. 

• You can process digital audio in ways that are simply impos-
sible with analog audio. As one example, it is possible to 
adjust the pitch of a digital audio file without changing its 
speed.

Digital Conversions
When an analog audio signal arrives at the inputs of your 
computer’s audio interface, it must be converted into digital 
information before the computer can deal with it. This process 
is called “analog to digital conversion” and is handled by the 
Analog to Digital Converter (ADC) of your audio interface/
soundcard. 
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At the other end of the signal path, the digital signal needs to be 
reconverted into an analog signal so that it can be listened to 
through analog audio playback systems—i.e. an amplifier and 
speakers. This process is called “digital to analog conversion” 
and is dealt with by the Digital to Analog Converter (DAC) of 
your audio interface/soundcard.

About Bits and Sampling Rates
When recording a sound into your computer, the ADC of your 
audio interface takes a “sample” of the sound source, a specific 
number of times per second. This is known as the “sample 
rate”, which is measured in kHz or so-many thousand samples 
per second. The higher the rate, the more samples the AD 
converter takes, and the more accurate the digital representa-
tion of the sound will be. 

Put another way, imagine each sample to be a photograph of a 
concert that you were trying to describe to a friend. If you had 
taken one photo every 10 minutes, you’d find it hard to 
describe the great light show. If you took a thousand photos 
during that 10 minutes, your friend could easily see what 
happened. This increased “rate”, or number of photos (i.e. 
samples), gives a far more accurate overall picture of what 
happened. This is how sampling works. The more “sonic 
photos” taken, the more accurately the sound is represented 
over time.

The sampling resolution—that’s the “bit” thing—is the accu-
racy or precision of the measuring scale used to store the 
numbers of each sample. Remember that computers store 
audio files as digital information—a series of ones and zeroes. 
There are three resolutions commonly in use: 8, 16 and 24 bits. 
24 bit systems are more expensive and are used extensively in 
DVD audio and film production. 
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To give you an idea of the relevance of the sampling resolution, 
imagine two people are building a house. One is using a tape 
measure marked to the nearest foot. The other has a tape 
measure marked to the nearest inch. Although the house built 
with the tape measure accurate to the nearest foot may not fall 
down, the one using the finer scale will build a more accurate 
house.

About MIDI and Audio File Sizes
Digital audio files consume a great deal of hard disk space. “CD 
quality” audio with 16-bit dynamic resolution and 44.1 kHz 
frequency resolution requires 5 megabytes (MB) of hard disk 
space for 1 minute of monophonic audio. For a stereo recording, 
this requirement is doubled, with a one minute audio file using 
10 MB of storage space. 

MIDI file data, on the other hand, is tiny. An average MIDI 
song file, three minutes in length and containing a dozen or 
more tracks will be about 20 kb in size.

The reason for this huge difference in size is that MIDI is, as 
discussed earlier, a language which describes what notes to play. 
The actual sounds themselves are generated by a connected 
MIDI device. 

1.6 Audio Tracks
Dependent on your version of Logic, and the audio hardware 
installed on your system, you can play back up to 192 audio 
tracks. Each audio track has an associated audio channel strip in 
the Audio Mixer/Environment window. We’ll discuss the use of 
the mixer channels as we work through the Introduction 
Manual, but for now we’d just like to cover the relationship 
between “tracks” and “channels”.

Audio tracks and mixer channels are related.
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You can not record or play back audio tracks unless a corre-
sponding audio channel—also known as an audio “object”—is 
first created in the Environment window. Logic will automati-
cally create a number of audio objects when first installed.

You can add and remove audio channels freely at any time, up 
to the capacity of your audio hardware and version of Logic. 
Adding extra channels means that you can then play back more 
audio tracks—provided that your computer and audio hardware 
are up to the task.

We will discuss the creation of audio objects/channels and 
tracks in the next chapter—The Ideal Workspace.

1.7 MIDI Tracks
Where audio tracks are said to have a corresponding “channel”, 
MIDI tracks have a corresponding “instrument” in the Envi-
ronment.

This differentiation in terminology is very important to make a 
mental note of now. As we work through the Introduction 
Manual, you will discover many references to “instrument” and 
“channel”. We will clearly specify audio or MIDI channels 
throughout the Introduction Manual.

We will discuss the creation of MIDI instruments and other 
MIDI objects in the next chapter—The Ideal Workspace.

1.8 Logic Terminology
You’ve obviously encountered a few new terms at this stage, 
like channels, objects, the Environment and many more. This brief 
overview will provide you with some simple explanations 
before moving on to the mechanics of using Logic’s interface.
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• Object—Logic is an “object-oriented” program, which 
means that it is “oriented” towards your interaction with 
graphical “objects”, in order to make use of them. A 
“sequence” or “audio region” could be considered an object, 
as could a graphical fader in the Environment window, or 
another graphical element of Logic’s interface.

• Audio Region—An “audio region” is an “object” which 
appears in the Arrange window. It is simply a pointer to an 
“audio file”, or a part of an audio file.

• Audio File—This is a computer file which is a digital 
recording of a sound. Please refer back to the Audio section, 
from page 19 onwards, if you need a refresher.

• Sequence—An “object” which contains MIDI data. This 
MIDI data can include note, program change, controller or 
other types of MIDI “events”. Please refer back to the MIDI 
section, from page 15 onwards, if you need a refresher.

• Event—refers to a single MIDI message. Technically, a 
“single” MIDI message such as a note event contains four 
messages, but in Logic you will deal with a single “event” 
onscreen. MIDI events can be displayed in a number of 
different ways by making use of several different editing 
windows available in Logic.

The individual editing windows will be discussed in far more 
detail as you work through the Introduction Manual, but here’s 
a quick rundown on the windows you’ll use on a day-to-day 
basis:

• Arrange—Logic’s primary working window. Here, you can 
record, arrange and mix MIDI and audio “objects”. MIDI 
objects are known as “sequences” and audio objects are 
known as “audio regions” in the Arrange window.

• Event List—This editor provides a detailed view of 
“events” and “objects”, allowing you to directly interact 
with, and manipulate them, in an alphanumerical (letters 
and numbers) list.

• Matrix—Note “events” are displayed as horizontal bars 
onscreen. You can directly interact with these events graph-
ically.
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• Score—Again, note “events” are displayed and edited 
graphically, but in the form of standard musical notation.

• HyperEdit—This is a grid-based graphical editor which 
allows you to “draw” in various types of MIDI events.

• Track Mixer—Provides control over volume and pan plus 
other parameters for your MIDI and audio hardware devices. 
Here, you interact with “objects” which look, and behave, 
like the faders on a mixing console.

• Environment—This is a graphical window which essentially 
allows you to set up the input and output routing of your 
MIDI and audio hardware by using icons which represent 
your audio and MIDI devices.

1.9 The Mouse

Basic Functions
Many functions performed with the mouse make use of “modi-
fier” keys—ç, O, and C in conjunction with the methods 
outlined below.

Clicking
Place the mouse pointer on the desired “object”—button, 
input field, MIDI note event, sequence, audio region or file 
etc.- and press (and release) the mouse button quickly. 

Double-clicking
The same as clicking on an object, but you press the mouse 
button twice, in quick succession. You can set the appropriate 
time-span between clicks in your operating system’s Control 
Panels.

Grabbing or Click-holding
The same as clicking on an object, but you keep the mouse 
button held down.
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Moving or Dragging (Drag ’n Drop)
Grab the object and move the mouse (with the mouse button 
depressed) to the desired position. You will generally release 
the mouse button to “drop” the object once the desired desti-
nation has been reached.

Scrolling
Throughout Logic, many menus and windows allow you to 
scroll horizontally or vertically. In most locations this is done 
with the mouse button depressed.

Mouse Input

Checkboxes
Checkboxes are square boxes which become “checked” when 
you click in them to activate an option (or function). Clicking in 
them a second time will remove the “check” and deactivate the 
option.

Pull-down (Flip) Menus
Pull-down menus (also known as Flip menus) open when you 
click and hold on certain input fields or buttons. You can make 
a selection within the menu by scrolling to, and highlighting, 
the desired item and releasing the button. If you wish to choose 
an item which is outside the visible section of the flip menu:

• Move the mouse over the top or bottom edge of the menu; 
the further you move it, the faster you will scroll through the 
menu.

• Hold down the S key as you do this. You can then release 
the mouse button and use the scroll bar to the right of the flip 
menu to scroll through it. When the desired entry is reached 
(indicated by the highlight), release the S key

� Many of Logic’s menus are “sticky”. This means that once the menu 
is opened, the mouse button can be released and the menu will 
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remain open until an option is selected or until you click outside the 
menu with the mouse.

Mouse as Slider
Almost all numerical parameters, including note values and 
lengths, can be adjusted by click-holding on the parameter 
value and moving the mouse up or down. If the parameter is 
comprised of several separate numbers (e.g. song position), you 
can adjust each individually.

Numerical Input
Double-clicking on a numerical parameter value opens a 
numerical input field. The previous value will be highlighted, 
allowing it to be overwritten with a new entry. You can also use 
the mouse to make a partial selection in an input field so that 
only the highlighted value is overwritten (e.g. song position). 

As long as an input field is open, the computer’s keyboard is 
limited to data input, and may not be used for Key Commands.

… by arithmetic
At any time, you can enter numbers by typing in an arithmetical 
operation, e.g. “+2” or “−5”, which then simply changes the 
current value by that amount. Hit the R key to activate your 
choice and exit the parameter field. Alternately, you can click 
once on the window, anywhere outside the parameter area.

… as ASCII-symbols
You can also input numbers as ASCII symbols: Simply type a ` 
or " in front of the symbol, and the ASCII code will be input as 
a number. For example:

"! results in a value of 33
"a results in a value of 97

This function is particularly useful for entering text in SysEx 
strings.
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Text Input
Text names are altered in the same fashion as described for 
numerical input, but the name field need only be clicked once 
to allow input.

Numbered Names
You can give any number of selected objects the same name. If 
the name ends in a number, the number will automatically be 
incremented by 1 for each subsequent object. This allows you 
to name all sequences on a single track quickly, while retaining 
a differentiation between them. The selection of multiple 
objects is discussed in the Selection Techniques section, from page 
38 onwards.

Disabling automatic numbering
To disable automatic numbering, place a space after the 
number at the end of the name. All selected objects will then 
end in the same number.

Tools and the Toolbox
Logic allows recorded data to be handled graphically. This 
means that you don’t need to perform editing operations via 
arcane command line or table entries. Rather, you can deal with 
your data by manipulating graphical “objects” which represent 
your notes, volume levels, pan positions etc. You do this by 
using “tools”.

When editing objects graphically, you always have two tools 
available for immediate use, without needing to visit the 
Toolbox. One is already active, and the other is activated by 
holding down the C key.
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You can change the currently active tool by clicking on the 
appropriate tool in the Toolbox. The mouse pointer will adopt 
the shape of the selected tool, enabling you to know what func-
tion is assigned to the mouse by simply looking at the mouse 
cursor. The Eraser is used for deleting, the Scissors for cutting 
and the Glue tool for merging objects.

Effective Range of the Tools
• Tools are only effective in the working area of the editing 

window in which they were selected. Individual tools can be 
defined for each open window.

• A tool basically affects the object you click on. If multiple 
objects are selected, the tool will operate on them all.

Opening the Toolbox at the Mouse Position
Use Show Tools (default: ™) to open a toolbox at the mouse 
position. This window will disappear as soon as:

• you choose a tool by clicking the mouse
• you choose a tool by pressing a numerical key
• you click anywhere outside the tool window or
• press any key.

Selecting Tools
To select a tool, click on it in the toolbox.

If a toolbox is opened at the mouse position (Key Command: 
Show Tools, Default: ™) you can also use a numerical key to 
choose a tool. Tools are numbered from the top left to the 
bottom right. Press the Show Tools key again to deselect a tool, 
switch to the pointer, and close the box.

Info Line
The Info Line replaces the local menus in the active window 
on Mac OS.
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The Info Line provides useful feedback about the type of oper-
ation you are performing. During operations involving Arrange 
window objects, the Info Line will look similar to the following:

From left to right, the Info Line displays: name of the opera-
tion, mouse (or Arrange window object) position, Arrange 
window object name, track number, and length of the Arrange 
window object.

During operations involving events, the Info Line looks some-
thing like this:

From left to right, the Info Line displays: operation, mouse (or 
event) position, event type, event MIDI channel, first data byte 
(i.e. the pitch for notes), second data byte (i.e. velocity for 
notes), and for notes: length of the note.

About the Tools
There are additional tools to those outlined below, which are 
found in specific editing windows. The following are the 
primary tools used in song construction and editing. The 
window-specific tools are discussed in the Introduction Manual 
and Reference manual, in conjunction with topics and exam-
ples covering their use.

Pointer
The Pointer is the default tool. The mouse cursor also takes on 
this shape outside the working area, when you are selecting 
from a menu or entering a value. Within the working (active) 
area, the Pointer is used for:

• selecting (by clicking on objects)
• moving (by click-holding and dragging)
• copying (by holding down the O key and dragging) and 
• editing lengths (by click-holding the bottom right or left 

corner and dragging). 
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• click-holding and dragging anywhere on the window’s back-
ground allows you to “rubber-band select” multiple objects.

Pencil
The Pencil is used to add new objects. You can also select, drag, 
and alter the length of objects with this tool.

Eraser
The Eraser deletes objects. This is done by clicking on them 
once. When you click on a selected object, all other currently 
selected objects are also deleted (as if you had used the b key). 

Text Tool
The Text tool is used to name Arrange and Environment 
window objects or to add text to a musical score.

Scissors
The Scissors are used to split Arrange window objects, e.g. 
before copying or moving individual sections.

Glue Tool
The Glue tool is the opposite of the scissors: all selected objects 
are merged into a single object, which is given the name and 
track position of the first of the objects on the time axis.

Solo Tool
Click-holding with the Solo tool allows you to isolate and listen 
to selected objects. This function works during playback or 
when the sequencer is stopped. Soloed objects will be outlined 
in yellow.
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Mute Tool
Clicking on an object with the Mute tool stops it from playing 
and places an asterisk in front of its name, to indicate that it is 
muted. The color of the object is also muted, so a bright purple 
will turn a shade of lilac, for example. You can unmute the 
object by clicking on it again with the tool. If multiple objects 
are selected, the mute tool will affect them all.

You may also wish to activate the Muted Objects are textured 
parameter in the Options > Settings > Display Preferences, to 
further highlight muted objects. This is particularly useful on 
gray (non-colored) objects.

Zoom Tool
The Zoom tool allows you to zoom in on a section by “rubber-
banding” it, right up to the maximum possible window size. To 
revert to a non-zoomed view, click on the background of the 
active window with the Zoom tool. 

Crossfade Tool
In the Arrange window, the crossfade tool allows you to simply 
click-hold and drag across the section where two audio regions 
meet. A crossfade will automatically be created between the 
regions.

Velocity Tool
In the Matrix and Score editors, you can use the “V” tool to 
change the velocity of notes. To do so, click-hold on the desired 
note(s) and scroll vertically. Moving up increases velocity, and 
down decreases velocity.

1.10 Window Functions
The basic functions of Logic’s edit windows are the same as 
those found in other Macintosh applications. The display 
options available in Logic’s windows, however, are far more 
extensive.
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In Logic, you can open different combinations of edit windows 
(even several of the same type) and adjust each one individu-
ally. All open, and “linked” windows in a song are constantly 
updated. When linked, any alterations made in one window 
will immediately update the display of all other open windows. 
The various windows can also be set to follow the song position. 
We will discuss the relationship between edit windows at the 
beginning of the next chapter.

Working with Windows

Opening and closing Windows
All Logic edit windows can be opened via the Windows main 
menu. You may open as many copies of the same type of 
window as desired. The relevant Key Command, which allows 
you to open the window without using the mouse, is displayed 
behind each menu item. Read the Key Commands section, from 
page 46 onwards for further information on these keyboard 
shortcuts.

Each time you use the Windows menu, take a quick look at the 
Key Command for each edit window—that way you will soon 
memorize them. As a preferable option to visiting the Windows 
menu, simply use the Key Commands as indicated. If you 
develop the “habit” of using keyboard shortcuts rather than the 
mouse, you will find Logic much faster and more elegant to use.

You can close windows by clicking on the close symbol to the 
top left of the windows. 

If you hold down the O key as you click, all open windows in 
the active song will be closed.

Setting Window Size
You can adjust window sizes by dragging the lower right-hand 
corner of the window, as with any window in the Finder.
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Maximizing window size
The windows maximize button, found in the upper right corner 
of the window, toggles the window between its maximum size, 
and the size it was prior to clicking the button (Windows > 
Zoom Window).

Selecting the Working Area

Scroll Bars
The scroll bars are situated along the right and bottom edges of 
a window. They are visible when the working area exceeds the 
dimensions of the window on either the vertical or horizontal 
axis.

You can scroll through the working area by clicking the arrows 
found at either end of the scroll bars or by click-holding and 
dragging the scroll slider. Note that: 

• the size of the scroll slider changes in relation to the overall 
length of the scroll bar

• the scroll bar’s length corresponds to the overall size of the 
working area

• if the working area and visible area are of a similar size, the 
scroll slider will be longer

• the visible section changes as you move the scroll slider.

X/Y Element
The X/Y element is situated at the bottom left corner of the 
window. By click-holding and dragging it, you can move both 
horizontally and vertically on the currently displayed window 
section, as if you were dragging both scroll bars simultaneously.

Page Scrolling
Use the Page Up, Down, Left and Right Key Commands to scroll 
one page up, down, left or right. 
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The Page Top, Bottom, Left most and Right most Key Commands 
move the visible section of the working area to the top, bottom, 
left or right, as if you had grabbed one of the scroll bar sliders, 
and moved it to one of its extreme positions.

Zooming
The telescope-shaped zoom symbols in a window are used to 
zoom in and out on the working area display. Clicking the 
smaller side of the telescope symbol reduces the size of the 
objects in the display, allowing you to see more objects in the 
same space (zoom out). Clicking on the telescope’s larger side 
increases the size of objects in the display (zoom in). In some 
windows, only one telescope is available, and is used for simul-
taneous horizontal and vertical zooming.

� While “zooming”, the top left selected object will be kept in the 
visible region, whenever possible.

Zooming Selectively

Zooming In on a Section of the Screen
To enlarge a section of the screen until it fills the whole 
window, use the Zoom tool to “rubber-band” the desired 
section. You can do this repeatedly until the required viewing 
size is attained.

Reverting to the Previous Zoom Setting
Click on the window’s background with the Zoom tool. This 
will return the zoom to the previous setting. If you have used 
the Zoom tool multiple times, then each click on the back-
ground will take the zoom level back one step, until the original 
zoom setting for the window is reached. 
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Window Elements

Adjusting the Size of the Window Elements
If you move the mouse over the top left corner of the Arrange 
area, the mouse pointer turns into a crosshair. By dragging it, 
you can now adjust the size relationship of the Bar Ruler, 
Arrange area, Track List and Transport (if shown). You can also 
adjust the window elements in the Score and Matrix Editors 
using the same method.

Concealing/Revealing the Transport Functions
Use View > Show Transport to display or remove the transport 
panel from the top left corner of the Matrix or Arrange 
windows. The number of buttons and indicators shown is 
dependent on the amount of space available to the transport.

Concealing/Revealing the Parameters
The View > Show Parameters (Hide/Show Parameters—Key 
Command H) function allows you to display or hide the entire 
area to the left of the Arrange and other editor windows. This 
area normally contains the toolbox, sequence or object parame-
ters. Hiding these parameters allows more space for the edit 
window itself.

Menus
Most functions are not found in the main menu bar, but appear 
as local menus. These local menus will update to offer func-
tions that are relevant to the currently active editing window.

Key Commands
Many menu functions can be accessed via computer keyboard 
shortcut keys, or combinations of keys. The keys (or combina-
tions) used are shown alongside the menu entries.
36
Emagic
Logic



Window Functions l

X

Logic 5 intro en.book  Page 37  Monday, October 28, 2002  9:34 PM
Please note that you may assign many functions to any desired 
key (or combination of keys) via the Key Commands window. 
Read the Key Commands section, from page 46 onwards for 
further information.

Menu Options with “…” in their Title
Three periods following a menu function, as shown: …, indi-
cates that the entry will open a dialog box, rather than directly 
perform a function.

Dialog Boxes
In Dialog boxes, you can hit the highlighted button by pressing 
the R key.

Window Types
You can open as many windows as desired, including several of 
the same type. Even though the contents of all windows are 
constantly updated, only one window has the status of being 
the “top”, or “active” window. This is the window which is in 
the foreground, when several windows overlap.

The active window can be recognized by its fully-shaded title 
bar. The main distinguishing characteristic of this window is 
that Key Commands only affect this window, and not any of the 
others. 

� The “floating” Transport bar is a special type of window. It is always 
“on top” and cannot be obscured by another window. 

Links between Windows
The two buttons to the top left of a window (shown here), 
determine the window’s relationship to the song position 
(Catch), or to other windows (Link).

Catch
The Catch function means that the visible section of a window 
follows the song position as the song plays. 
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If the button with the walking man on it is illuminated (i.e. if it 
is blue), the window’s display will update to follow the song 
position as the song plays. If the button is not lit, the display 
does not update, even when the song position line scrolls 
beyond the right-hand side of the visible portion of the window. 

To toggle this on/off, simply click on the button, or you can set 
up a Key Command for the Catch Clock Position function.

Automatic Catch Disabling
If you move the visible section manually, Catch is automatically 
switched off, which ensures that the selected song section 
doesn’t disappear, as the display updates to follow the song 
position line.

Autocatch
The Enable Catch when Sequencer starts (Options > Settings > 
Global Preferences…) function always enables Catch mode 
whenever you press play or pause.

Link
Clicking on the Link button activates Link mode. This means 
that the window will show the contents of the selected object. 
Selecting a sequence in the Arrange window will update the 
display of the linked editor to show the contents of the selected 
sequence.

1.11 Selection Techniques
Whenever you wish to perform a function on one or more 
objects, you must first “select” the object(s). This applies to 
Arrange window objects—MIDI sequences and audio 
regions—and individual events (notes, controllers etc.). 
Selected objects are either highlighted, or will blink on and off 
(in the Score editor).
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The selection status of an object applies to all windows. A 
specific object selected in one window will also be selected in 
all other open windows that display the same object. Changing 
the top window doesn’t affect the selection. Ensure that you 
don’t click on the edit window’s background, as this will dese-
lect everything. Click on the desired window’s title bar should 
you wish to switch between open windows without canceling 
the selection.

Selecting Individual Objects
An individual object may be selected by clicking once on it, and 
deselected by clicking on the window’s background, or by 
selecting another object.

Selecting Alphabetically
The T key selects the next object in alphabetical order. In the 
Arrange window, pressing any alphabetical key will select the 
first object with a name that begins with this letter, provided 
that no Key command is also assigned to this key.

Selecting Several Objects
To select several non-contiguous objects, hold down S as you 
click them. As you click on subsequent objects, the previous 
selections are retained. This also works with horizontal or 
rubber-band selection.

Horizontal Selection
To select all objects aligned horizontally on a track, click 
quickly on the track name in the Track List. Similarly, you can 
select all notes of a certain pitch in the Matrix editor by clicking 
the relevant key on the onscreen keyboard.

If in Cycle mode, track selection will only select events falling 
within the Cycle zone.
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“Rubber-Banding”
To select adjacent objects, click on the window’s background 
and drag a “rubber band” over them. You will see an outline 
appear onscreen. All objects touched or enclosed by the rubber-
band outline will be selected, and will be highlighted to indi-
cate their selection status.

Toggling the Selection Status
When you make any selection (including by rubber-band or 
horizontal selection), while holding down the S key the selec-
tion status of the objects is reversed.

You can reverse the selection status of all objects by using Edit 
> Toggle Selection—St. Useful, for example, if you wish to 
select all objects except for a few. In situations where dozens or 
hundreds of objects exist, it’s easier and faster to first select the 
“few” you wish to leave unaltered, and then choose Toggle 
Selection.

Selecting Following Objects
To select all objects which chronologically follow a selected one 
(or, if no object is currently selected, to select all objects after 
the current song position), choose Edit > Select all following—
Sf

Selecting Objects within the Locators (Vertical 
Selection)
Edit > Select inside Locators—Si—selects all objects lying 
completely or partly within the locators.

Selecting Similar or Identical Objects
If you have selected an object, you can use the Edit > Select > 
Select Similar Objects—Ss—function, to select all similar 
objects and the Edit > Select > Select Equal Objects—Se—
function, to select all equal objects.

This table will assist you in defining “similar” or “equal”:
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Selecting All Objects
To select all objects, use Edit > Select All—Ca.

Deselecting All Objects
You can deselect all objects by clicking on the background, or 
by using the Deselect All Key Command.

1.12 Edit Operations
The Edit menus for Logic’s various windows all take the same 
form. The first item is Undo. Below this, you’ll find the typical 
clipboard functions (Cut, Copy, Paste), and at the bottom of 
each menu are the main selection commands.

Undo
Undo allows you to reverse the previous edit. In Options > 
Settings > Global Preferences, you can disable the warning 
message that normally appears when you activate Undo, by 
checking the Disable safety alert for Undo box.

The Key Command for Undo is Cz.

The Clipboard
The clipboard is an area of memory into which you may cut or 
copy selected objects. These objects can then be pasted to a 
different position. The clipboard is independent of any partic-
ular song, which means that it can be used to exchange objects 
between songs.

Object Similar Identical

Controller Event Controller# equal, any 
data byte

Controller# and data byte 
(control value) equal

Note Event Note equal, any octave Note and octave equal
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Cut
All selected objects are removed from their current position and 
placed in the clipboard. The previous contents of the clipboard 
are overwritten in the process: Cx.

Copy
A copy of all selected objects is placed on the clipboard. The 
selected objects are also left in place. As with the Cut function, 
the previous contents of the clipboard are overwritten (Cc).

Paste
All objects from the clipboard are copied to the top window. 
The clipboard is not erased in the process (Cv.

The contents of the clipboard are added at the current song 
position (if they are events or Arrange window objects). The 
song position is incremented by the length of the pasted 
objects.

In the Arrange window, the contents of the clipboard are pasted 
to the selected track. If events are pasted in the Arrange 
window, either a new sequence is created for them, or the 
events are added to a selected sequence.

Any objects that previously existed remain unchanged.

Clear
Edit > Clear erases any selected objects. Clear has no effect on 
the clipboard and is functionally identical to pressing the B 
key.
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1.13 General Functions of the 
Editors

Opening Editors
There is a flip menu in the Options > Settings > Global Prefer-
ences that allows the selection of the editor that will launch, 
when a sequence is double-clicked in the Arrange window. The 
flip menu options are: the Score, Event, Matrix or Hyper 
Editor.

Control Output via MIDI
Activating the MIDI Out button causes MIDI events to be sent 
when they are added, selected, or edited. This allows you to 
audibly monitor every edit, whether you are scrolling through 
the Event List (automatic selection) or lengthening or trans-
posing a note.

Automatic Scroll Functions

… scrolling to the Song position
The walking man button activates the Catch function, which 
updates the window view to show the current song position.

… scrolling to the selected event
The Scroll to Selection Key Command automatically moves the 
window, so that the first of the currently-selected events is 
visible.
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Setting Locators by Objects
The Functions > Object > Set Locators by Objects command 
allows you to set the locators in all Editors (and the Arrange) so 
that they encompass the currently-selected events. The Key 
Command can be found in the Key Commands window under 
Global Commands.

Copy MIDI Events
By selecting Functions > Copy MIDI Events you can move or 
copy all events which fall between the locator positions, to a 
different position. By default, this is the current song position. 
When this function is selected, a dialog window will open 
which displays several copy parameters, as discussed below.

Locators
The start and end points, in which events to be copied fall, 
must be defined. The most recently used Cycle Locator points 
are automatically shown in the Copy Events window. 

First, set the Locators in the bar ruler or Transport window, and 
then open the Copy Events window.

Destination
The Destination defines the position where the copied events 
will be inserted. The Destination point is defined by the 
current song position, so choosing a Destination is as easy as 
moving the song position line. If preferred, you may change the 
position in the Copy Events window. The SPL will move to the 
newly selected position.

Number of Copies
Any number of copies can be generated. Logic copies the 
segments successively. This option is not available in Swap 
Mode.
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Mode
Clicking on the Mode field activates a flip menu with a list of 
options. The Copy Mode determines how Logic will manage 
the source and destination data:

Deleting Events
These basic techniques are the same as for deleting sequences:

• the B (delete) key deletes all selected events,
• the Eraser also deletes all selected events, and any events 

that you click with it (whether previously selected or not).

Display Functions
The View > Show Parameters (Hide/Show Parameters—Key 
Command H) function hides/shows the parameter boxes to the 
left of the window(s), allowing an enlarged working area.

Mode Result

Copy Merge The copied data will be merged with any data at the dest
position.

Copy Replace The copied data replaces any data at the destination posit

Copy Insert The copied data is placed at the destination position, and
existing data is moved to a later position to accommodate
new data.

MoveMerge Like Copy Merge, but the source data is moved, instead o
copied.

Move Replace Like Copy Replace, but the source data is moved, instead 
copied.

Move Insert Like Copy Insert, but the source data is moved, instead of 

Rotate The source data is moved to the destination position. The
destination data, as well as all data between the end of th
source data and the destination position, will be shifted to
the source position.

Direct Swap Source and destination data exchange positions.

Remove The source data is deleted.
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1.14 Key Commands
You can activate most of Logic’s functions via Key Commands. 
A Key Command is a computer keyboard shortcut for a func-
tion or task in Logic. A number of functions are only available 
as Key Commands. The Key Commands window is used for 
the assignment of Key Commands to your computer’s 
keyboard. The use of Key Commands allows you to customize 
Logic to suit your own working style, and will speed up your 
use of the program.

Your personal Key Commands are stored (along with settings 
made in the Preferences pages) in a file called: 

• “Logic 5 Preferences” in your Macintosh System folder (in 
the Preferences folder, to be precise). 

You should:

• make a backup of this file elsewhere on your hard disk;
• make a floppy disk, ZIP or CD backup of it should you need 

to use Logic on another computer.

When you install updates for your version of Logic, your 
personal Key Commands will not be overwritten.

Special Keys
Some keys have special functions:

• The modifier keys S, ç, O, and C can only be used in 
conjunction with other keys. Given the differences in some 
Macintosh keyboards, we have included the following:
The S key = Shift.
The O key = Option.
The C key = the Command key.

• The B key has the fixed “delete selected objects” func-
tion. It can only be assigned to another function in conjunc-
tion with the modifier keys.
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• The  and _ keys increase or decrease any selected 
parameter value in single units. However, they can be 
assigned different functions which overwrite this default 
behavior.

Key Commands Window
The Key Commands window can be opened by selecting 
Options > Settings > Key Commands or by pressing Ok.

All Key Commands are listed to the right of the Key 
Commands window. They are grouped in the following catego-
ries:

• Global commands
• Functions affecting all windows (Various windows)
• Functions affecting the Arrange and all other Editor 

windows (Arrange & Various sequence Editors)
• Functions for the Arrange window specifically (Arrange)
• Functions for the Score Editor (Score window)
• Functions for the Event List Editor (Event window)
• Functions for the Sample Editor (Sample Edit Window)
• Functions for the EXS24 Instrument Editor (EXS24 Instru-

ment Editor)
• Functions for the Note Step Input (Keyboard Input).
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An asterisk or dot which precedes the function description indi-
cates that the function is only available as a Key Command. To 
the left you can see the currently assigned key/key combina-
tion.

Assigning a Function to a Key
• Click on the Learn Key button.
• Select the desired function in the list by clicking once on it 

with the mouse.
• Press the desired key on your computer keyboard, plus the 

modifier keys: S, ç, O and C.
• To create further Key Commands, repeat steps 2 and 3.
• Deactivate the Learn Key!

Deleting Key Command Assignments
• Click on the Learn Key.
• Use the mouse to select the function with a key assignment 

that you wish to delete.
• Press D.
• To erase more assignments, repeat the second and third 

steps.
• Deactivate the Learn Key button.

Checking the Function of a Key
Deactivate the Learn Key, and press the Key Command (or 
combination of keys) that you want to check. The associated 
function will be highlighted, and displayed in the middle of the 
window.

Filtering the Display 
You can use the Hide Used and Hide Unused buttons to hide all 
used, or unused, Key Commands. All other Key Commands 
window functions remain available for your use.
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Finding Key Commands
Due to the large number of possible Key Commands, it can 
sometimes be difficult to find a particular function. To aid in 
this regard, Logic offers a Find function, which allows a search 
for a specific Key Command by typing in its function name (or 
a part thereof) or by entering a character string, i.e. the Key 
Command itself.

Simply click in the white space to the right of the Find: button 
and enter the string of characters (or function) you’re searching 
for. The window will update to display all Key Commands 
containing the character string (plus the selected command, 
even if it doesn’t contain that string) when the Find button is 
clicked or the R key is pressed.

The Find: button switches Find mode on and off. The button is 
automatically activated if a string of characters is entered in the 
text field.

The Key Commands window remains active, even in Find 
mode; you don’t need to leave this mode to continue making 
assignments.

The Find function is not case-sensitive and makes no distinc-
tion between upper and lower case characters.

The Hide Unused and Hide Used buttons work in combination 
with Find. This means that you must switch off both in order to 
see all commands that fit the search criteria, regardless of the 
commands’ current assignment.

1.15 Controlling Windows—
Screensets

Every song created in Logic can have up to 90 “Screensets”. 
Screensets are window combinations which can be customized 
by you and stored to a specific numeric key/combination of 
keys on your computer keyboard. Each Screenset remembers 
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the type of edit or Arrange window/s opened plus size, position 
and zoom settings. This facility accelerates your workflow 
massively and allows you to tailor Logic to fit your needs and 
tastes.

To Set up a Screenset
• Press any of the numeric keys above your computer 

keyboard (you can also use the numeric keypad, if available).
• Open the desired windows by selecting them from the 

Windows menu, or by using the appropriate Key 
Commands.

• Resize, zoom and reposition your selected windows to meet 
your needs.

• Press the numeric key again. 

This will only work for keys/Screensets 1 to 9. 

To Set up More than Nine Screensets
• Press the ç + numeric keys.

You can not use the number “0” for any of your Screenset 
combinations. The reason is that number 0 is assigned for the 
Transport Bar Stop function, using the computer’s keyboard (or 
Play on Mac OS).

To Lock Screensets
• To ensure that your Screensets remain as you intended, you 

should always lock your Screensets by pressing Sl.
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1.16 Song Administration
All events, other objects and settings (apart from the Prefer-
ences and Key Commands) are components of a song. Songs are 
handled in the File menu.

New Song
When you first launch Logic, it opens a default song. This song 
can be customized to match your needs and tastes for use in 
future projects. Once you have learned how to set up your own 
“default song”, by following this Introduction Manual, you 
should save it in the Logic program folder, and name it “Auto-
load”.

Autoload Song
If a song called “Autoload” exists in the Logic folder, it will 
automatically be loaded when Logic is launched. We will 
discuss the creation of an Autoload song in the next chapter. 
When you’re ready to start work on a new song, simply save the 
Autoload under a new name using File > Save as… and begin. 

Creating a New Song
If you select File > New, Logic checks to see if an “Autoload” 
song is available and opens it automatically if found. If not, a 
new default song is created.

Opening the Default Song
If you hold down the O key while selecting File > New, a new 
default song called “Untitled” will be opened. 

Loading a Song
File > Open will launch the standard file selection dialog for your 
operating system. Simply browse to the required song file.
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Checking/Repairing Songs
If you double-click on the Transport Bar’s free events display, 
the memory will be re configured. At the same time, the current 
song will be checked for any signs of damage, structural prob-
lems and unused blocks. 

If any unused blocks are found—which normally shouldn’t 
happen—you will be able to remove these, and repair the song.

Saving Songs
When you select File > Save the current song will be saved with 
its current name intact.

If you don’t wish to overwrite the most recent version of this 
song saved under this name (which is what will happen if you 
use the File > Save, command, use File > Save As… Here, you 
can enter a new name for the song (and select a new directory or 
even create a new folder). The next time the straight Save 
command is used, the new file name and path will be used.

Closing a Song
File > Close closes the currently active song. If you have made 
any changes since the song was last saved, Logic will ask if the 
song should be re-saved before closing, to preserve any changes 
you may have made.

Quitting the Program…
Choose File > Quit to exit the program. If you have not saved 
any changes made to the open song file/s, you will be asked if 
you wish to do so before quitting (press R to save).
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1.17 The Transport Bar
The Transport Bar is used to “transport” you to different points 
in your song. The buttons—from left to right on the top row of 
the left hand side of the Transport are: Record, Pause, Play, 
Stop, Rewind and Fast Forward. These work as per those on a 
tape deck. The record button, to the top left, is used for 
recording both MIDI and audio data on any currently armed 
track, selected in the Track List. The cycle, drop and other 
buttons on the lower row will be explained as we work through 
the Introduction Manual.

• The SMPTE/Bar Position area indicates the current bar 
number occupied by the Song Position Line. In the figure 
above, the display shows 1 1 1 1, which means: first bar, first 
beat, first 16th and first clock pulse. The time position, 
00:00:00 etc. means—0 hours, 0 minutes, 0 seconds, 0 milli-
seconds/frames a.s.o.

• The lower two sets of numbers, from top to bottom, are the 
left and right Locators, which are used for setting cycle 
region points, which will be discussed shortly.

• The Tempo display indicates the tempo accurate to 1/10,000 
of a Beat Per Minute.

• Beneath the tempo, the maximum number of MIDI events 
that it would be possible to record on this particular 
computer is indicated.

• The /16 below the Time Signature of 4/ 4 indicates the 
format for note and bar display, so that any edits you may 
perform on your MIDI or audio data can be carried out with 
more precision. The /16 refers to the number of divisions in 
the bar. Click and hold your mouse button, and drag up or 
down to change this value.
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• The MIDI Activity display shows all MIDI input and output 
and also serves as a “Panic” button. If you have hung notes 
you can click once in the MIDI Activity Window to send a 
MIDI reset message, or double-click to send a Full Panic 
Reset which systematically works through all MIDI chan-
nels and ports and resets all connected MIDI devices. This 
guarantees absolute silence.

• The Song End box displays the bar number at which the 
song will end and sets a maximum song length. By default 
this is set to 201 bars.

• Clicking on the downwards pointing arrow beside the Song 
End box will open a menu of Transport Bar display options, 
which will allow you to customize the appearance of the 
Transport bar to meet your requirements. We suggest that 
you select “Legend” which will turn on the function titles, 
as shown in the image above, at least while learning Logic.

Transport Key Commands
By default, there are several Key Commands assigned to the 
transport functions. They are assigned to the numeric keypad 
of your computer keyboard. ~ must be activated for them to 
function using the numeric keypad. See the following chart for 
these commands, and try to remember and use them while 
working through the Introduction Manual.

Key Command Function

* Record

=/⁄ Play /Play from Locator if set

;/∂ Pause Toggle

R Stop

R pressed twice Return to Zero
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Simple Science…
That’s about as technical as this Introduction Manual gets. We 
don’t want to blind you with science, we just want to help you 
get up and running with Logic. 

Where necessary, we will offer tips and explanations of features 
and functions, but most of the time you will learn by doing. 
Please refer back to this chapter if you forget how to use any of 
the tools, menus or other functions. If, at any stage, you would 
like to get detailed technical or other information on any 
feature or term discussed, you can use the Reference Manual 
supplied with your version of Logic.

Take as much time as you need to complete each task, and have 
fun experimenting with the supplied song files.

Your Emagic Team
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The Ideal Workspace

By following the exercises, examples and steps here with your 
own MIDI and audio hardware, you will create your own 
customized workspace. 

Once this groundwork has been done once, using the Environ-
ment window, you will have a default working song file that can 
be used as a basis for all of your future projects. This will be 
known as your “Autoload” song.

Furthermore, you will learn how Logic communicates with 
audio and MIDI hardware and will start making your first 
experimental musical steps.

Before we get to the Environment window, we’d like to briefly 
cover some conceptual information. This will aid you in under-
standing the structure of the program, and the relationships 
between windows in Logic.

2.1 3 Dimensional Software
Logic has a structure unlike most software you may have used. 
Where Logic is different, is that it features several “levels” to 
it’s architecture. If you compare this to other Mac OS software, 
you can open several documents or “windows”, in which you 
can view and edit content. But there is no relationship between 
these windows. In Logic, all windows are linked and interact 
with each other.

Let’s take a look at Logic’s different windows and levels:

Chapter 2
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• The Arrange window is where you construct your arrange-
ments and songs. In the Arrange window you deal with 
folders and with MIDI sequences or audio regions. Folders can 
contain MIDI sequences or audio regions or other folders. The 
MIDI sequences contain MIDI events. You do not deal with 
MIDI events or audio files directly. You do this in the different 
Editors.

• In the Editors, folders, MIDI sequences and audio regions 
can be opened to look at, and directly manipulate, the raw 
MIDI data—notes, controllers, sysex messages etc.—and 
the underlying audio file on which the audio region is based. 
The editors allow you to go into the depth of your composi-
tion—from the top level of the Arrange to the folders to the 
atomic level of notes and audio files. Let’s take a closer look 
at two of the editors.

• The Score editor allows you to switch between viewing a 
score part for a single track, an individual sequence, a group 
of tracks, and the entire song. This allows you to define what 
you would like to see onscreen and what part(s) you would 
like to print—without changing the MIDI data.

• Similarly, the Matrix editor allows you to simultaneously 
view the contents of a single sequence, all sequences on a 
track, or all sequences in a song, or song section. Viewing the 
contents of multiple sequences allows you to quickly see, 
and change, overlapping notes, velocities and more on 
multiple MIDI channels.

• Finally, there is the Environment, in which the Logic 
sequencer is connected to its MIDI and audio environment. 
The Environment can be divided into layers improved over-
view and easy access to your instruments. For example, you 
would normally have an Environment layer for your JV1080, 
another layer for your Nord Lead, another for your Virus, and 
another for your audio hardware.
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These “link” buttons (chain symbol) are found to the top left of 
all of Logic’s windows. Their function is to keep the various 
windows “linked”, regardless of which level in the song archi-
tecture you happen to be working on—Arrange, Edit etc. You 
will learn more about the practical uses of these buttons—and 
the walking man icon found alongside these buttons—as you 
work through the Introduction Manual.

As you work with Logic, you’ll see the interaction between 
windows, and will learn the practical use of the levels and layers 
we’ve discussed. You will find that this method allows each 
window to perform a particular task efficiently. Key to Logic’s 
operation, and truly unique in the music software world, is the 
Environment. 

2.2 The Environment Concept
Logic’s Environment window—accessible from the Windows 
menu—is Logic’s “brain”. It’s primary purpose is to get MIDI 
and audio information into, and out of, Logic.

The Environment has a direct relationship to the Arrange 
window’s Track List: Each track has a destination, and this 
destination is an object in the Environment.

This is illustrated by the following diagram.
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The Arrange window Track List is shown to the left, with Track 12—
Grand Piano selected. This track corresponds to MIDI channel 1 of the 
GM Device shown in the Environment to the right. Note that the number 
1 button in the GM Device graphic is depressed. If Track 13, the Fingered 
Bass were selected, the Environment window would update to reflect 
this selection, and button 2 would be depressed in the GM Device. The 
automatic updating of the GM Device in the Environment window is due 
to the “linking” discussed earlier in this, and the first chapter.

2.3 The Data Flow
The Environment allows you to set up an onscreen “flowchart” 
which represents the functions and facilities of your connected 
MIDI equipment. On a basic level, you can simply define your 
“instruments” onscreen and route them to a MIDI port. 

If you’re more adventurous, you can incorporate additional 
onscreen tools, such as arpeggiators, MIDI delay lines and 
more to your Environment. These additional tools, plus your 
onscreen “instruments” are collectively known as “objects” in 
the Environment. The Environment can even be used to 
create extremely flexible real-time MIDI data processing 
“machines”, including step sequencers, rhythm generators and 
more. 
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The key word and concept to keep in mind when dealing with 
the Environment is “flowchart”, no matter how simple or 
complex your Environment is, or becomes. The Environment 
allows you to clearly define how you want your MIDI data flow 
to be sent to and from your physical MIDI devices. 

But the Environment does not stop with MIDI: You can also set 
up audio “objects” for your individual audio output, input, 
audio instrument, bus and master fader channels. The creation 
of a number of these audio objects, plus the routing of signals 
between them is automatically taken care of by the Logic instal-
lation procedure. You don’t need to set up anything before 
making use of the audio functionality of Logic.

Logic also allows the interaction of MIDI and specific audio 
objects in the Environment, which we’ll discuss later.

Getting Started
As you’re probably familiar with audio mixers, we thought it 
would be helpful to discuss the flow of audio signals as a point 
of comparison to the data flow in the Environment. Take a look 
at the following image.

As indicated by the arrows, audio signals run out of the synthe-
sizers to the left and run in to the mixer in the center.
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Signals run in and out of the mixer into/from the effects unit to 
the top right. This is often called an “effect loop” and is used to 
route the signals of the three synthesizers (as a group or individ-
ually) in to the effects unit (via the mixer’s effect send). After 
being processed by the effects unit, they will be sent back in to 
the mixer (via the mixer’s send return). 

MIDI signal flow is no different, in concept at least, to the audio 
example above. It must be sent out of one device and in to the 
next device in a “chain”, just as with audio. Let us show you 
what we mean, and please give this a try.

• Launch Logic, if it isn’t already running by clicking on the 
Logic icon in your Logic program folder.

• From the Windows menu, click hold and scroll down to the 
Environment listing or use the çØ Key Command. This 
will launch the Environment window.

• In the Environment, you’ll see the words “MIDI Instr.” on 
the left-hand side of the screen in the Layer flip menu (in 
the diagram it is shown as “(unnamed)”).

• Click-hold in this box and in the flip menu which opens, 
select Create. This will display a blank Environment layer.

• Click on the New menu and select Physical Input from the 
listing. Release the mouse button and a new physical input 
icon will be generated onscreen. (Yours may look different to 
that shown below as this is dependent on the type of inter-
face used and platform).

• Click on the New menu and select Arpeggiator. 
• Click on the New menu and select Instrument. You will now 

have three icons onscreen.

• Connect the cables as shown, ensuring that you cable from 
the Sum output of the Physical Input object.
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• To create a cable, click and hold on the small triangle found 
at the top right of each icon and drag the mouse/cable (which 
will appear onscreen automatically) in to the target icon. You 
will know that the connection has been made when the 
target icon turns white. Once you’ve made the connection, 
release the mouse button.
If no triangles appear to the top right of your icons, click-hold 
on the View menu, and select the Cables entry. If you still 
have problems, select View > Protect Cabling and Positions.

• Click once on the Arpeggio object and, in the parameters 
box to the left of the screen, change the settings to match the 
following: Direction—UpD2, Res—1/16, Length—1/32, 
Octaves—3. 

• Route the “Instrument” object to a MIDI out port that is 
active. You’ll find this on the left of the screen in the param-
eters- as shown in the diagram below. Click and hold in the 
space between Icon and Cha, and select an available MIDI 
port from the flip menu. Once again, the appearance may be 
slightly different on your machine, dependent on the MIDI 
interface used and platform.

• Close the Environment window.
• Select the “Instrument” MIDI track in the Arrange Window 

by click-holding on any of the instrument names in the Track 
List. This will open a hierarchical menu as shown below.
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Take a moment or two to scroll through the hierarchical menu. 
You will notice that the Instrument and Arpeggiator objects you 
created in the Environment also appear in this list—under the 
“unnamed” menu entry. This is a key point to understand. All 
objects you create—on any layer in the Environment: in this 
case the “unnamed” layer—will be available for selection and 
use in this hierarchical menu, and therefore in the Track List. 
In other words, the two are connected, and without objects in 
the Environment, the Track List will be full of “null” (No 
Output) objects.

You can prevent objects from appearing in the list by 
unchecking the Icon checkbox in the object’s parameter box in 
the Environment.

Another point to consider when selecting an output object—i.e. 
an Instrument—in the Track List, is the underlying routing of 
the Instrument within the Environment. If you select an 
Instrument on a track that has an arpeggiator routed in to it, for 
example, then all MIDI data on the track will be sent via the 
Instrument. If, on the other hand, the arpeggiator object was 
selected on a track, the data recorded on the track would be 
sent via the arpeggiator and fed, in turn, to the connected 
Instrument. This would result in the arpeggiation of the data. 

Back to the example. This routing does nothing exciting until 
you hit the Play button on the Transport Bar and hold down a 
chord on your keyboard. Try it!
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While doing so, we ask that you pay attention to the top right-
hand field of the Transport Bar. This is the MIDI activity indi-
cator which displays MIDI input and output. Once you’ve had 
a little fun, press the Stop button on the Transport Bar.

This is one of thousands of possible routings, but is a simple 
example of how the signal flow works. 

Expanding this Example
Open the Environment layer you just created by double-
clicking on the “Instrument” track in the Arrange window’s 
Track List. This will automatically launch the Environment 
window, and will select the layer and Instrument object itself. 
As you can see, the signal is routed from the Physical Input 
object directly in to the Arpeggiator object.

In Logic’s Environment, the Physical Input object is actually the 
equivalent of your real-world hardware MIDI In port(s). Click 
on the New menu, and slowly scroll through the various 
options. You will find a Sequencer Input object amongst the 
items listed. The Sequencer Input object that appears onscreen is 
actually the software input for Logic (the “door” in to the 
program, if you like) 

• Connect your cables as shown. 

• To disconnect the existing cables from the previous 
example, simply click on the cables and drag them to the new 
destination.

• To completely disconnect the cable connection between 
objects, simply click on the cable and drag it back on to the 
source—i.e. the icon it’s routed from.

• Once done, close the Environment Window.
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• Now, if you press the Play button on the Transport and play 
a chord on your keyboard, it works just as it did before with 
one exception—the MIDI In on the Transport works. 

• Once you’ve experimented a little with this, press Stop on 
the Transport. 

• If you press the Record button on the Transport and play a 
chord, your arpeggiated data will be recorded. Give it a try, 
and note that as the recording takes place, a new sequence 
will be created in the Arrange window and displayed as a 
horizontal rectangle. 

• Once you’re done with the recording of your arpeggio, press 
Stop on the Transport Bar.

Sit back and consider this for a moment, and take a look at the 
signal flow. In both examples, the data was routed from the 
actual MIDI port—i.e. the Physical Input object—into the 
Arpeggiator object, where it was processed.

Please Note: The only way to record MIDI data into Logic is via 
the Sequencer Input object. As shown in the first example, it’s 
possible to process MIDI data via the Environment without 
Logic “seeing” any MIDI input. 

As a scenario where the ability to process MIDI data before it 
enters Logic (via the Sequencer Input object) may be practical, 
consider this: You have a basic MIDI keyboard that can only 
transmit on one channel at a time—e.g. a DX 7—but want to 
split/layer it in order to access and control multiple channels of 
a connected sound module simultaneously. In this scenario, 
you could set up your keyboard’s “phantom” controller func-
tions in the Environment before the Sequencer Input object. 
Everything subsequently performed would be processed—i.e. 
split/layered/transposed etc.- prior to being recorded and would 
sound and work in the desired fashion. 

It is also possible to set up similar functionality after the 
Sequencer Input object, although the routing would be very 
different. Some things, however, are difficult (if not impossible) 
as post Sequencer Input processes and vice-versa. As a rule, the 
arpeggiator would generally be used post (after) the Sequencer 
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Input, and would normally be routed directly in to an Instru-
ment. In our example, all MIDI note data entering Logic would 
be arpeggiated, which wouldn’t be great for many (or any) 
styles of music.

Parallel Processes
It’s possible to route the MIDI signal through multiple 
processes in parallel, much like you would in a multi-effects 
processor. 
 

The diagram shows a parallel routing scheme, post the 
Sequencer.

If you follow the flow of the signal in the diagram, you’ll see a 
standard recording setup—the Physical Input runs into the 
Sequencer Input object, several other objects are connected 
independantly.

Not quite as standard in the example shown above: Any MIDI 
note input played or recorded on the “Test In” Instrument 
track—selected in the Arrange window’s Track List—will be 
routed through the Arpeggio, Delay Line and Chord Memo-
rizer objects. All processing done by these objects will be 
routed to the “Test Out” object and will only affect its MIDI 
port/channel.
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The diagram shows a slightly modified parallel routing scheme, 
post the Sequencer.

If you slightly modified this example, it would also be possible 
to route the data from each of the Arpeggio, Delay Line and 
Chord Memorizer objects to separate Instrument objects—e.g. 
“Test Out” 1, 2 and 3. This would mean that the data routed 
from the “Test In” track could be sent via the Arpeggiator to a 
synth “pluck” sound, the Delay Line to a bass sound, and the 
Chord Memorizer to a synth pad, for example.

As you can see, there is no cable between the Sequencer Input 
object and the “Test In” Instrument object. You may be 
wondering what happens to the MIDI data if the signal flow 
chain is “cut”, as it appears to be, between the Sequencer Input 
and the Instrument object. Here’s what happens:

Logic sees all MIDI data arriving at the Sequencer Input. The 
program routes any incoming data, in realtime, to the track you 
have selected in the Arrange. As the “Test In” Instrument object 
is selected as the track destination, the signal flow is not inter-
rupted.

Once MIDI data has been recorded into Logic via the 
Sequencer Input, it will be stored within a MIDI sequence. 
The data within this sequence can then be directed to virtually 
any Environment object, via the track’s destination.
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A Quick Recap
So far, we have covered some key Environment concepts, 
which are condensed as follows:

• The Environment’s primary purpose is to get data into and 
out of Logic.

• The Environment represents physical MIDI devices and 
some of their functions via onscreen icons.

• The Environment contains additional processing tools, 
which can alter MIDI data in real-time.

• The Physical Input object represents your MIDI interface’s 
INPUT ports.

• The Sequencer Input object is used to (and is the only way 
you can) route MIDI data into Logic.

• Once data has entered Logic via the Sequencer Input port, 
the program can redirect this data to almost any object that 
exists in the Environment.

• All objects you create—on any layer in the Environment—
will be available for use as track destinations in the Arrange 
window’s Track List. MIDI data, stored as sequences in the 
Arrange window, can thus be routed to any port, channel, 
instrument or to/from another object.

• Some objects, such as Instrument objects, can be routed to a 
MIDI output port with no need for any cabling.

As shown in these exercises, the main thing you need to do 
when in the Environment is to follow the signal flow. Think 
carefully about what you want to happen to your data, plus 
when and where in the signal path you want it to happen. It 
really is that simple!
69
Introduction Manual
Version 5



Chapter 2
The Ideal Workspace

Logic 5 intro en.book  Page 70  Monday, October 28, 2002  9:34 PM
2.4 Your First Environment
And now, we’d love to help you to set up your own Environ-
ment. This will form the basis of your future work with Logic, 
as the song you will create—your own “Autoload”—will be 
saved as a template for your future projects.

Given the endless variety of MIDI devices available, it’s obvi-
ously impossible for us to cover every one of them here in 
detail. Logic offers a number of universal objects, which can be 
used—and customized—to represent your physical MIDI 
devices.

We will cover the basic set up of hardware with the goal of 
getting MIDI data in and out of your Logic system. We will do 
this by describing several devices and functions, and their 
equivalent object(s) in the Environment.

This information can be adapted to the devices you have in 
your studio. If you have multiple MIDI devices of a particular 
type—i.e. several multi-timbral synthesizers, 2 or 3 effects 
units, a couple of drum machines, etc.—simply repeat the 
setup procedure for each.

In the Quick Environment Setup section, from page 75 onwards, 
we will show you how to use the “Various Multis” song file that 
was installed in your Logic program folder. This song file 
contains pre-built Instrument objects for over 200 different 
MIDI devices. If all devices in your studio are contained in this 
song, set up of your Autoload song will take around five or ten 
minutes. If one or more of your devices is not contained in the 
“Various Multis” song, the other information contained in the 
Manual Instrument Setup section, from page 77 onwards, will aid 
you in setting up and customizing your Autoload. 

If you own the full version of SoundDiver, please refer to the 
SoundDiver chapter, from page 212.
70
Emagic
Logic



Your First Environment l

Important!

Logic 5 intro en.book  Page 71  Monday, October 28, 2002  9:34 PM
Should you wish to further enhance your Environment, after 
reading through this section, we would suggest to take your 
time. This will give you the time to read the Environment 
chapter in the reference manual, and time to learn how you 
want to use Logic, which will place you in a better position to 
then customize the program to meet your needs.

Once you have created a basic setup for your MIDI devices, 
you may wish to skip ahead to the Using Logic chapter, from 
page 113 onwards. You can always return to this chapter at a 
later stage, should you wish to customize, or add to, your Auto-
load song.

Instrument Objects
As you’ve learned, if there are no Instrument objects in the Envi-
ronment, the program has no idea of how and where to route 
MIDI data. To this end, you must inform Logic about the 
MIDI equipment in your studio. This is accomplished by the 
insertion of appropriate Instrument objects, namely the Instru-
ment, Mapped or Multi Instruments. These Instruments will 
directly reflect the type, and number, of real-world MIDI 
instruments, effects units and channels of each device in your 
MIDI rig. Although the term Instrument is used, these objects 
can represent any MIDI-controllable device, be it a MIDI 
mixer, synth, lighting unit or whatever.

The Instrument Object
The Instrument object is designed for devices that operate on 
a single MIDI channel. This makes it the ideal choice for 
effects units, older synthesizers that operate on a single 
channel, electric pianos and some mixing devices.

The Multi Instrument Object
This object is designed for devices that operate on multiple 
MIDI channels simultaneously—i.e. multi-timbral synths. It is 
ideal for most modern synthesizers, and is the most commonly 
used Instrument object type. 
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The Mapped Instrument Object
Is suitable for devices such as drum machines or synthesizers 
that provide multiple sounds on one MIDI channel: Most 
modern multi-timbral synthesizers feature a “Drum” 
channel—usually channel 10. Where this is different to the 
other Instrument object types is that each sound, within the 
channel, is assigned to a different MIDI note number—i.e. a 
key on your keyboard.

Some Preparation
Before you begin the Construction Time section, from page 73 
onwards, take a few minutes to look around your studio and jot 
down a list of all of your MIDI gear on a piece of paper. As 
you’re doing so, use the following chart as a guide.

• The No. Channels column indicates the number of channels 
that the device is capable of simultaneously producing 
sounds on—i.e. its multi timbral use. 

• The Drum entries in the No. Channels column indicates that 
the device features a “drum” mode.

• The Interface Name Column indicates the MIDI interface the 
device is connected to.

• The MIDI In/Out Port columns indicate the physical port 
number on your MIDI interface that the device is connected 
to.

• The Object Type column indicates the type of Instrument 
object which should be used. Some entries use multiple 
Instrument types. MI = Multi Instrument, MP = Mapped 
Instrument, I = Instrument:
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Using the chart above as an example, you can see that all of the 
devices routed to the Unitor 8 interface use a Multi Instrument 
object, except for the 03D mixer. The devices routed to the 
MT4 interface use a Mapped Instrument and Instrument 
object, respectively. Some of the devices—JV1080 and MR 
Rack—use a combination of Instrument objects, namely a 
Multi Instrument and a Mapped Instrument.

2.5 Construction Time
This section covers the creation of a number of different Instru-
ment object types, applicable to your studio setup. Follow the 
steps outlined for each type of Instrument, referring to the 
studio gear list that you just wrote down. Where necessary, 
repeat the steps if you have several instruments of the same 
“type”—i.e. several multi-timbral synths. 

Don’t forget the Undo function discussed in the first chapter, if 
you make a mistake in the Environment window. If you create 
the wrong type of object, you can highlight it by selecting it 
with a mouse click, and can delete it by pressing the B key.

Device Name No. Channels Interface Name MIDI In Port MIDI Out Port O

JV1080 15- 1Drum Unitor 8 1 1 M

K5000 4 Unitor 8 2 2 M

MRRack 15- 1Drum Unitor 8 3 3 M

Nord Lead 4 Unitor 8 4 4 M

MicroWav 8 Unitor 8 5 5 M

E4 16 Unitor 8 6 6 M

S3000 16 Unitor 8 7 7 M

O3D 1 Unitor 8 8 8 I

DM Pro 1Drum MT 4 1 1 M

M5000 1 MT 4 2 2 I
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Plain Vanilla Settings
Before starting, you will need to create a “plain vanilla” song 
file, i.e. a song with no MIDI Environment objects. This 
provides a uniform starting point.

Note that if you only own a single GM device (including 
internal sound cards), then Logic is ready to use, and will 
require no changes to the Environment. Save the default song 
as “Autoload” in the main Logic program folder, by selecting 
File > Save As… and typing in the name. But remember: You 
will learn more by following our “Vanilla” tour.

Creating a “Vanilla” song:

• Create a new Song by selecting New from Logic’s File menu.
• Open an Environment window by selecting Windows > Open 

Environment, or by using the Key Command.
• Select the “MIDI Instr.” Layer from the Layers flip menu.
• Select all objects on the layer by pressing Oa.
• You may also make use of the Options > Layer > Delete func-

tion to completely delete the layer which contains objects 
you do not require. You can freely create new layers at a later 
stage by using the Options > Layer > Insert function. Should 
the layer contain any objects, the following warning will be 
displayed. Clicking Delete will remove the layer.

• Repeat these steps for all layers except the Click and Ports, 
Audio, and All Objects layers.

• Once all unnecessary objects (or layers) have been deleted, 
save the song as “Vanilla” in the main Logic program folder, 
by selecting File > Save As… and typing in the name.
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Quick Environment Setup
You will probably find that at many, if not all, of your MIDI 
devices are contained in the “Various Multis” song file. Should 
you find that there are some devices which are not contained in 
the Various Multis song, please read the Manual Instrument 
Setup section, from page 77 onwards, to complete your studio 
setup. That section also contains information on customizations 
which you can make to your Instruments. These may be of 
benefit when using Logic creatively, so it’s recommended 
reading.

The Various Multis Song
The “Various Multis” song contains pre-configured Multi 
Instruments for over 200 devices. They are organized by manu-
facturer on separate layers.

Refer to your studio gear list and follow these steps. 

• Open your “Vanilla” song file
• Open an Environment window by selecting Windows > Open 

Environment, or use the Key Command.
• Close all other open windows, leaving only the Environment 

open.
• Select the desired layer—Instruments, for example—via the 

layer flip menu to the left of the Environment window.
• If you made use of the Options > Layer > Delete function 

when creating your “Vanilla” song, select Options > Layer > 
Insert. Once created, browse to the newly created Environ-
ment layer.

• Select File > Open. You will be prompted by a dialog box 
asking if you wish to “Close current songs before opening 
new song?”. Click on the Don’t Close button.

• In the ensuing file selection window, browse to the folder 
which contains the “Various Multis” song file, which will 
launch the song file.

• Once open, you will see the Environment window, and a text 
window, which provides text instructions for use of the song.
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• Select the manufacturer of the MIDI device you’re looking 
for by click-holding on the Layer menu in the column to the 
left of the Environment, and scrolling to the appropriate 
manufacturer name.

• Select the appropriate device by clicking once on it.
• Select the Edit > Copy menu option.
• Go to the Windows menu, and select the “Vanilla” song. 

This entry is found towards the bottom of the menu.
• Ensure that the desired layer of the “Vanilla” song is visible 

via the Layer flip menu.
• Select the Edit > Paste menu option.
• In the parameters box to the left, select the appropriate 

MIDI interface/port you wish to route the imported Instru-
ment to.

• Within any Multi Instrument, activate the appropriate 
number of channels, by clicking on each numbered square in 
the grid. Refer to your list while doing this to ensure that you 
only activate as many channels as necessary—i.e. as many 
channels as your MIDI device is capable of playing simulta-
neously.

• Repeat for each device.
• Once all objects have been added, save the song as “Auto-

load” in the main Logic program folder, by selecting File > 
Save As… and typing in the name.

One Layer or More?
Multi Instruments—either copied or manually created—can be 
placed on their own layers or on a single layer. The choice is 
yours.

Multi Instrument objects will create their own hierarchical 
menu listing in the Arrange window Track List. This list 
displays as many channels as you have activated within the 
Multi Instrument.

As this chapter of the Introduction Manual is aimed at setting 
up your Environment as quickly as possible, we would suggest 
that all Multi Instruments be copied (or created) on the 
“Instruments” layer of the Vanilla/Autoload song.
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If, at a later stage, you decide that you would like to separate 
your Instruments onto different layers, you can freely create 
new layers and copy/paste your objects between them.

If you choose to go this way, you can rename the layer(s). You 
should name any newly created layers to match that of the 
device you intend creating on the layer. To do so, double click 
on the text area shown alongside as “type in here”, and type in 
the desired name. Press the R key and you’re done.

2.6 Manual Instrument Setup
This section of the chapter discusses the manual creation of 
objects, should the Various Multis not contain an Instrument or 
Environment suitable for your MIDI device(s).

Input and Metronome Objects 
Your “Vanilla/Autoload” song will contain these objects on the 
Click and Ports layer, so there is no need to perform these steps. 
This section does, however, contain info on the setup of chan-
nels/ports and note assignments for the metronome. You can 
skip to the following section, if you own a MIDI device which 
is not contained in the “Various Multis” song.

Creating and Cabling the Input Objects
• Select the “Click & Ports” Layer from the Layers menu.
• Select Physical Input from the Environment window’s New 

menu.
• Select Sequencer Input from the Environment window’s 

New menu.
• Click & hold on the Sum outlet (triangle) of the Physical 

Input object, and drag a cable to the Sequencer Input object.

Creating the Metronome Object
• Select MIDI Metronome Click from the Environment 

window’s New menu.
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• Assign the appropriate output port, and MIDI channel, plus 
any transpositions necessary for the Note values, changes to 
velocities etc. In the image alongside, you will see the 
default settings for a GM (General MIDI) metronome 
click—i.e. assigned to MIDI channel 10, and using specific 
note values—C#1 is assigned to a sidestick sound in the stan-
dard GM drum kit.

• Save this Song. Give it the name “Vanilla” or similar.

Setting up Single Instruments
This section covers the set up of a single instrument, if appli-
cable to your studio. Maybe you do not have such a simple, 
mono-timbral sound generator. If not, browse to the Multi 
Instrument or Mapped Instrument sections.

• Go to the Layer named “MIDI Instr.” by selecting it from 
the Layers menu.

• For the devices that receive on only one MIDI channel but 
do not have a “drum” mode—remember that “drum” mode 
instruments have multiple sounds on one midi channel—
create an Instrument via the New > Instrument menu func-
tion. This can include effects processors, electric pianos, 
mixing devices, such as the Yamaha 03D and some older 
synthesizers—e.g. the Yamaha DX7 and several analog 
synthesizers.

• Repeat this step for each device which receives on only one 
MIDI channel. 

• Set the port and channel of each Instrument by using the 
mouse as a slider on the Cha parameter, and Port flip menu 
(as shown), found in its Parameter Box to the left of the 
Environment window.
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• Now give each Instrument a name by selecting the name 
tool, indicated below, and clicking on the name below the 
Instrument(s). Simply type in the appropriate name and 
press R. As a word of advice, it’s better to use short names, 
like “DX7”, “Pulse” etc. rather than “Waldorf Pulse Mono 
Synthesizer”.

• After setting up your Instruments, save your song via the File 
> Save menu. This will save your changes to the “Vanilla” 
song file.

Setting up Multi Instruments
To set up a Multi Instrument, if applicable to your set-up, refer 
to your list and follow these steps for each multi-channel device:

• Click on the Layer flip menu, and select the “Instruments” 
layer. 

• Create a Multi Instrument by choosing the New > Multi 
Instrument menu option. This will create a Multi Instru-
ment object onscreen.

• Click on the numbered boxes—1 to 16—within the Multi 
Instrument to activate its “sub-channels”—i.e. MIDI chan-
nels. Only select the number of channels that your MIDI 
device supports.

• Click on the Icon (It looks like a MIDI port) at the top of the 
Multi Instrument object, which will highlight it as shown in 
the diagram below.
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In the image shown above, the Arrange and Environment windows have 
been set up side-by-side. A Multi Instrument has the first 3 channels acti-
vated.

• Set the appropriate physical port for the Multi Instrument by 
clicking on the Port flip menu in the Multi Instrument’s 
parameter box to the left of the Environment window.

• By default the Cha value is set to All. This is a global channel 
setting for the entire Multi Instrument object, and should be 
left alone. Changing the value will override any individual 
sub-channels activated within the Multi Instrument. If 
changed, it would “force” all data, regardless of sub-channel, 
to this global channel setting. 

• Repeat the above procedure for each multi-channel MIDI 
device.

In the diagram, note that:

• Channels 4 to 16 have a diagonal line through them, which 
indicates that these channels are not active in this Multi 
Instrument. 

• The entire Multi Instrument has been sent to the “Creative 
Sou” port. This indicates the Creative SoundBlaster MIDI 
interface installed on the computer that was used for the 
image. 
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• The Cha setting is set to All. What this means is that the 
entire Multi Instrument object will send MIDI data on all 16 
channels. If this value was set to a specific channel, the sub-
channel settings (1—16) of the Multi Instrument object 
would be overridden and re-routed to a single channel—i.e. 
the global channel for the entire Multi Instrument. As 
discussed above, the global Cha setting for the Multi Instru-
ment should be set to All.

Setting up a Multi Instrument is as simple as selecting New > 
Multi Instrument, assigning the appropriate output Port if you 
have multiple ports (On MacOS—USB7 = USB Port 7, M3 = 
Modem port 3, P4 = Printer port 4 a.s.o.) and activating the 
required number of MIDI channels—i.e. the sub-channels—for 
your MIDI synth. 

It is advisable to only select the number of MIDI channels that 
your synth actually requires. E.g.—Kawai K5000—4 channels, 
Waldorf Microwave XT—8 channels, Roland JV2080—16 
channels. This reduces the amount of clutter in the Track List’s 
hierarchical menus, making things easier to find and manage. 

After setting up your Instruments, save your song via the File > 
Save menu. This will save your changes to the “Vanilla” song 
file.

Customizing a Multi Instrument
Once you’ve set up a Multi Instrument, there are a number of 
changes you can make to it which aid in the use of Logic. 
Following is information on how to make these customizations. 
While changing the color(s) and icon(s) aren’t absolutely essen-
tial changes, it won’t hurt. We do, however, strongly recom-
mend that you make changes to the name of the Multi Instru-
ment and also the patch list names within the Multi Instru-
ment. Selecting patches by name is much easier than trying to 
deal with program change numbers.
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Object Color
When recording, the sequence objects in the Arrange window 
can automatically be assigned a color, which makes viewing and 
managing tracks much easier.

• Select a sub-channel in your Multi Instrument by clicking on 
the corresponding number within the Multi Instrument 
“grid”.

• From the View menu, select Object Colors, or use the Key 
Command. This opens a floating color palette which allows 
you to assign a color to each channel.

• Simply select each channel, by clicking on it with the mouse, 
and then the color for each channel—again with a mouse 
click. 

• When you’re done, close the Color Palette via the close 
window button in its top left corner or the Key Command 
used for opening the Color Palette.

Instrument Icon
While you’re selecting your sub-channel colors, why not assign 
icons for each as well? Again, a convenience which makes it 
easier to keep track of your Instruments and their channels.

• Select a sub-channel in your Multi Instrument by clicking on 
the corresponding number within the Multi Instrument 
“grid”.

• In the parameters box to the left of the Environment, click-
hold on the icon itself. This will open a flip menu, from 
which you can select an icon of your choice.

• Simply select each sub-channel, then the icon for each 
channel.

You can prevent objects (including sub-channels in Multi 
Instruments) from appearing in the Arrange window Track 
List, by unchecking the Icon checkbox. This is also useful for 
hiding/disabling a sub-channel that has been activated by 
mistake.
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Instrument Name
Select the name tool, highlighted in the toolbox to the left of 
the image below, then click in the space shown below the Multi 
Instrument and type in an appropriate name for your MIDI 
device. 

Patch Names
Rather than selecting patches via meaningless—and difficult to 
remember—program change numbers, you can select patches 
stored in your synth’s memory by name. To customize patch list 
names for your Multi Instrument:

• Double-click on the icon at the top of the Multi Instrument. 
(It looks like a MIDI port) This will open a window similar 
to the image shown below. 

• To rename the default GM patch list entries, simply double-
click on the names—one by one—and type in the appro-
priate patch name. Note the “New Name” entry to the top 
left of the list.

• Following the naming of each entry, press R, or simply use 
your mouse to double-click on another entry.

• When finished, close the Multi Instrument patch list.
• Repeat all steps for the creation (and customization) of each 

Multi Instrument object which corresponds to the physical 
MIDI synth/modules in your studio.
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You can also type out a list in SimpleText or your word 
processor, and use the copy/paste options, accessible via the 
downwards arrow to the right of the Bank Message flip menu. 

Advanced Patch List Function—Bank Select 
Many synthesizers contain more than 127 sounds. If you own a 
device of this type, this section—and possibly the next—will 
be of interest, and use, to you.

As an additional function, accessible from the patch list 
window, you can assign patches to other banks of sounds (up to 
14) by using the No. Bank specified and Bank Message flip 
menus. This will allow you to access patches beyond the stan-
dard 127 allowed by MIDI—obviously dependent on your 
synth’s capabilities.

To activate new banks—select any of the 14 possible banks 
from the No. Bank Specified flip menu. Most modern synthe-
sizers use Bank Message: Control 32, so it’s unlikely that any 
changes will need to be made in the Bank Message flip menu. 
We suggest that you take a look at this flip menu, as some 
specific synthesizers and modules are listed here, which use a 
different bank select protocol. If you own a synthesizer which is 
named in the list, select it with the mouse. If you own a synthe-
sizer which has multiple banks, but does not use the standard 
Control 32 (or Control 0) message for bank select, please refer 
to the following Custom Bank Messages section.

Each of the new banks will have it’s own patch list which, by 
default, will use the names of the first bank. To rename the 
patches, please follow the instructions

Do not use the Bank functions if you only have one bank of 
patches in your synth. Initializing new banks requires the use of 
more memory for the object, thereby making the object, and 
subsequently your song files, larger.
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Custom Bank Messages
Should you own a synth with an unusual scheme for bank selec-
tion, you will need to set up “Custom Bank Messages”. Here’s 
how to do it without trying to understand the hexadecimal list-
ings found in the back of your synth’s manual.

• Select New > Monitor.
• Run a cable out of the Physical Input’s Sum port in to the 

Monitor object.
• Cable from the Monitor object in to the Sequencer Input 

object.
• Select the various banks from the front panel of your synth, 

using it’s buttons/menus.
• Write down the various numbers that appear in the Monitor 

objects’ window, each time you press the button(s) on your 
synth.

• Once you’ve done this for each bank in the synth, select the 
Multi Instrument object, and choose the Options > Define 
Custom Bank Messages function. A window which looks 
like the diagram below will launch.

• Double click in the Val column, and type in the numbers that 
you’ve written down for each bank and you’re done.

• You will need to type the appropriate patch names into the 
patch list (as discussed in the Patch Names section, from page 
83 onwards), should you wish to select patches by name in 
these higher banks.
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Once set up, whenever you choose a program or bank from the 
Track Parameters box in the Arrange window, it will automati-
cally send the appropriate bank/patch number to your 
connected MIDI device.

As always, after making any customizations to your Multi 
Instruments, ensure that you save your song.

Setting up Mapped Instruments
As with the other instrument types, the creation of a Mapped 
Instrument, is achieved by selecting New > Mapped Instru-
ment. Assign a port and channel as per the Instrument object, 
covered in the Setting up Single Instruments section, from page 78 
onwards. 

Ensure that the Cha setting for the Mapped Instrument 
(Drums Mapped, in the diagram) matches the “drum” channel 
in your synthesizer/module.

Setup for Multi Timbral Synths with a Drum Channel

If your drum module or synthesizer has more than one drum 
kit, cable it as shown. The reason for cabling a multi timbral 
synth in this fashion is to take advantage of the Multi Instru-
ment object’s ability to name patches, as discussed in the Patch 
Names section, from page 83 onwards. Note that when you 
cable the Mapped Instrument object into the Multi Instrument 
object, you will be prompted with the following warning dialog 
box. Click on the Remove button.
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Set up patch/bank names for your different drum kits within 
the Multi Instrument, as per the instructions in the Patch Names 
section, from page 83 onwards. Double-clicking on the mapped 
instrument object will open a window like the one shown 
below.

In this window you can:

• Assign individual notes to be within a “group” (Kick, snare, 
hats, toms etc.)

• Assign a “relative” position—this means you can move the 
note up or down in semitone steps graphically, which does 
not affect the pitch. It does, however, affect the way the note 
appears in the Score editor.

• Change the appearance of the note head.

All of these functions are useful for scoring. As an example of 
where this would prove invaluable, would be in the case of the 
GM drum map. For any module which strictly adheres to this 
standard, there will be a 5 octave tom (tom) kit. If you used a 
tom on note C2 and another tom from C5, your score would 
look awful, to say the least.

Additionally, in the drum map window you can change the Base 
MIDI channel, set via the Mapped Instrument’s Cha parameter 
(normally 10 in GM devices), and Cable channel. This allows 
you to assign particular note values (and therefore, drum 
sounds/samples) to individual MIDI channels. 
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Further facilities allow the reassignment of an input note to a 
different output note, and the setting of velocities on a per-note 
basis. This type of functionality is useful for sampling (and 
other) keyboards which don’t have a GM drum note assign-
ment. 

After setting up all of your Instruments, save your song via the 
File > Save menu. This will save your changes to the “Vanilla” 
song file.

2.7 Creating Audio Objects
That’s about it for the MIDI input and output objects required 
for getting MIDI data into, and out of, Logic. If you have no 
desire to extend your Environment beyond this basic MIDI 
functionality, you can leave things as they are. If you wish to go 
further: There are a number of additional objects which can be 
used for remote control of the MIDI device’s parameters, 
discussed in the Environment Controls section, from page 95 
onwards. You may also make use of the vast number of Environ-
ments found on the Logic program CD and the Internet.

By default, a number of audio objects were created when your 
first installed the program.

We recommend that you do not create further audio objects of 
any type until they are actually required for a project. The 
creation of additional audio objects increases the need for 
system resources, placing undue strain on your computer. In 
other words, creating 64 audio playback tracks “because you 
can” is pointless and wasteful if you only require 8 audio play-
back tracks.

As mentioned, Logic features several “types” of audio objects. 
These different types are based around the same fundamental 
Environment object—namely the Audio object—but each has 
distinct facilities. The “cabling” between audio objects—
which deals with the audio signal flow—is automatically (and 
invisibly) connected by Logic, as new audio objects are created 
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and assigned. This invisible cabling follows a fairly standard 
signal path, normally found on a mixing console, with audio 
channels, busses, master faders etc. As such, the Logic mixer 
will immediately be familiar to you if you’ve had any experi-
ence with mixing consoles. 

All audio objects, with the exception of the Master Volume 
fader, accept the use of software “plug-ins”. Plug-ins are DSP 
(Digital Signal Processing) algorithms which are processed by 
the computer’s CPU. These algorithms can include audio 
effects such as: reverb, chorus, flanging, compression, equaliza-
tion and many more processes. A special Audio object “type”—
the Audio Instrument—allows the use of software plug-ins 
which emulate synthesizers, samplers and drum machines.

Audio Object 
The Audio object is, as mentioned, the fundamental object 
used for audio functionality in Logic’s Environment. By 
default, any Audio object created will be assigned to the first 
available playback channel, or “Audio Track”. 

Audio Input Object
As the name suggests, the Audio Input object allows the 
processing of audio streams entering Logic. This means that 
incoming audio can be monitored (i.e. heard) with effects. A 
separate Audio Input object can be created and assigned for 
each physical input (or input pair) of your audio interface hard-
ware. Note that Audio Input objects do not need to be created, 
in order to get audio in to Logic. These objects simply allow the 
processing of audio on input. 
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Audio Bus Object
This is just like a bus/group on an audio mixing console. It acts 
as a send/return for Audio Track (playback), Audio Input and 
Audio Instrument objects, when effects are inserted. It also acts 
as a “group” fader, where multiple audio channels can be 
routed to it, and volume or pan can be adjusted globally for all 
“grouped” channels. Busses can be routed to Output objects 
(Master Faders) or to other busses.

Audio Output Object
This is Logic’s Master Output object, equivalent to the master 
output fader(s) on a mixing desk. If you have audio hardware 
which features multiple outputs, you can set up an Audio 
Output object for each physical output—or output pair (Out 1 
and 2, Out 3 and 4 etc.). It also acts as a “group” fader, where 
multiple audio channels can be routed to it, and volume or pan 
can be adjusted globally for all “grouped” channels. This fader 
type features a Bnce button which is used to bounce (digitally 
combine, or mix) any incoming audio—from the other fader 
types—to a mono, stereo or multiple Surround-format audio 
files.

Audio Instrument Object
This is a unique audio object in Logic. It supports the use of 
software-based “instrument” plug-ins. These “plug-ins” 
include Emagic’s ES1 and ES2 Synthesizers, EXS24 Sampler 
and EVP88 Piano plus third-party VST2.0 instruments. 
Although the Audio Instrument object looks similar to Logic’s 
other audio objects, it supports MIDI note input, which the 
others do not. This enables appropriate plug-ins placed in the 
top insert “slot” of Audio Instrument channels to be “played”, 
just like an external MIDI synth, sampler or module.

Master Volume
This, as the name suggests, is a Master Volume control for the 
entire mixer. It is Logic’s equivalent to the Control Room fader 
on a mixing desk. 
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The diagram shows—from left to right—the Audio Track, Audio Input, 
Audio Instrument, Bus and Output faders. Please note the “Cha” entr y in 
the parameters box for the selected “Audio 1” Track fader. Another point 
to note are the surround pan controls on three of the first four faders. 
Each can be set to a different Surround format. Logic can use any of 12 
Surround formats simultaneously, on a per-channel or per-bus basis. 
Additionally, note the Touch, Read, Latch, Write and MIDI text windows 
on each fader.

Each audio object, regardless of type, is created in the following 
way. 

• Open the Environment via the Windows menu or Key 
Command

• Select the “Audio” Layer from the Layers menu.
• Create an Audio Object by selecting New > Audio Object. 

This will generate a small “waveform” icon onscreen.
• Double-click on the icon to change it’s appearance to an 

audio fader, as shown in the image above. 
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• Clicking on the Cha entry in the Audio object’s parameters 
box will allow you to select the audio object type via a hierar-
chical menu, as shown in the following diagram.

• It is very important that no two audio objects are assigned to 
the same Track, Instrument etc.—i.e. do not create two audio 
objects that are assigned to Track 1, or Instrument 3, for 
example

• The MIDI channel entry determines the channel used by the 
Audio Object. By default, this will match the Audio Object’s 
Track number—i.e. Track 1 will be set to MIDI channel 1, 
Track two to channel 2 a.s.o. Again, ensure that no two 
objects of the same type are assigned to the same MIDI 
channel. There is no need to concern yourself too much with 
this parameter. It is of little consequence to Logic’s new 
Track Automation system, and is primarily of use for compat-
ibility with songs created in older Logic versions.

You should only set up as many Audio objects as you think you 
will reasonably need. In other words, don’t set up 64 audio play-
back channels if you are only likely to use 16 tracks of audio 
playback in your normal “day to day” use of Logic. The reasons 
for this:
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• Each channel (audio object) occupies an amount of onscreen 
space, and when dealing with an Environment that has, say 
40 audio playback objects, you will find yourself scrolling 
endlessly through faders when using the Environment’s 
audio mixer (Audio > Audio Mixer).

• Each audio object uses system resources, even when not in 
use.

Similarly, you should only set up as many Bus, Audio Instru-
ment and Audio Input objects as you think you will need (and 
your hardware, and Logic version allows).

Although hardware and version dependent, Logic Platinum 
will generally create the following number of audio objects 
when first installed:

• 24 Audio Playback Channels (Audio Tracks)
• 24 Audio Instrument objects
• 8 Bus Objects (Returns)
• As many Master Output objects as your hardware supports. 

These are generally displayed as stereo objects for each stereo 
output pair—i.e. an object for 1 and 2, another for 3 and 4 
a.s.o.

• A Master Volume fader

� Logic Audio (formerly Silver) will create fewer Audio Instruments, for 
example, so don’t be too concerned if your Environment Audio layer 
doesn’t feature all of the objects, as listed.

If you find that you need, or would prefer, more (or fewer) of a 
particular type of audio object as you work with Logic, you can 
return to the Environment and simply create (or delete) them, 
as per the steps outlined. Note that the maximum number of 
each audio object type which can be created, is primarily deter-
mined by the version of Logic you are using. As an example, 
Logic Platinum allows up to 16 busses, Logic Gold up to 8, and 
Logic Audio 4.
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2.8 Setting up Tracks
At this stage, you should have a functional Environment that 
allows MIDI and Audio input and output. Congratulations!

There is one final step, which we strongly recommend, to 
complete the customization of your default song.

Save your song, if you haven’t already done so, as “Autoload” in 
the Logic program folder. This is done via the File > Save As… 
menu. In the ensuing dialog, browse to the appropriate folder, 
if necessary, and type “Autoload”, then press R.

Open the Arrange window via the Windows menu or Key 
Command. You will note that the Track List is filled with “No 
Output” entries.

As you can see in the image, the hierarchical flip menu can be 
used to replace the “No Output” entries with any Audio or 
MIDI object created in the Environment.

Create a number of Audio tracks, MIDI instrument tracks and 
Audio Instrument tracks to suit you. It is unnecessary to create 
a track for every channel of your MIDI synths, or for every 
audio channel—but one or two channels for each synth, a 
couple of audio instruments and four audio tracks should be 
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fine to start with. Delete any unused tracks by clicking on any 
“No Output” track and pressing the B key. As you do this, the 
next track in the list—working from top to bottom—will auto-
matically be selected.

Once done, save your “Autoload” song via File > Save. When-
ever you launch Logic, or create a new song, this Autoload file 
will automatically be opened—with audio tracks, MIDI tracks 
and Audio Instrument tracks prepared—and ready for imme-
diate use.

There are many further customizations that can be made to the 
Autoload song, both in the Environment and elsewhere in the 
program, as preferences. We’ll introduce you to these as we 
continue working through the Introduction Manual. You can 
always make changes—which can be saved in your Autoload—
as you become more familiar with how you prefer using Logic.

2.9 Environment Controls
After setting up all of your Instruments and Audio Objects, you 
may wish to add some additional objects for control over your 
MIDI devices. 

Note that the addition of these objects is optional. They act as 
remote controls for your MIDI devices, and can be used to 
control virtually any function that your MIDI devices are 
capable of understanding. If you do not wish to incorporate this 
type of functionality into your Autoload, you can skip this 
section, and return to it at a later stage, should you change your 
mind.

The Windows > Track Mixer automatically creates a fader for 
each channel, including sub-channels, of each Instrument 
object in the Environment. Each MIDI fader in the Track 
Mixer also allows the use of up to four different types of 
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controller, which you can freely reassign. If your MIDI mixing 
needs do not extend beyond manipulation of volume, pan, and 
filter cutoff and resonance, for example, then there is no need 
to create further Environment objects.

If you have a grander vision, this section of the Introduction 
Manual will provide you with examples for the set up of faders 
and knobs for control of volume and panning. For single Instru-
ments, a single fader and pan pot will suffice. For Multi Instru-
ments, faders will need to be created and assigned appropri-
ately for each MIDI channel used by each Multi Instrument. 
We’ll show you some great shortcuts which will speed up the 
process.

For control over other synthesizer functions, such as filter 
cutoff and resonance, or envelope controls, the procedures you 
will learn here can be applied. Note that this is entirely depen-
dent on the capabilities of your synthesizer, and the controllers 
used will vary from machine to machine—if they can be used at 
all. As such, you will need to consult the documentation of your 
synthesizer(s) for information on controller numbers.

If you own a GM, GS or XG synthesizer, you create a GM Mixer 
object which offers control over volume, pan and several other 
continuous controllers, plus effects functions. See the Setting up 
a GM Mixer Object section, from page 104 onwards.

Setting up a Single Fader
To set up a fader, simply select New > Fader. There are, as you 
will see, a number of choices available in the Fader sub-menu. 
For now, choose Auto. This will generate an onscreen fader. 
Faders can be assigned to any MIDI channel, and require no 
special cabling to be functional. Fader objects can generate 
MIDI data of different types that can be:

• Sent out of Logic.
• Recorded.
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Fader objects can also respond to incoming MIDI messages 
and can convert these messages to different types of MIDI 
data.

The fader in the image has been named “Vol 1”. Also take note 
of the parameters box to the left. In particular, pay attention to 
the Out and In assignments, plus the Channel and -1- entries. As 
you can see, these are matched.

Click on the Out, In and -1- entries to check out the options 
available in these menus. The value of 7 assigned to the -1- 
entries corresponds to the MIDI Controller number for 
“Volume”. MIDI Controllers are often called continuous control-
lers, and are regularly displayed as follows in MIDI device 
manuals: “CC#7” or “CC7”—Volume.

Controller Input
If you were to change the value of the -1- entry, under the In 
section to say, CC#19 (a value of 19 = General # 4, in the flip 
menu), the fader would only respond to controller 19 messages 
coming in to it on MIDI channel 1. All other messages would be 
ignored. This ability (of the fader object) to ignore, rechan-
nelize and convert MIDI data on the fly is particularly useful for 
external hardware controllers. 

As an example, your MIDI keyboard may have a single slider or 
a modulation wheel as it’s only hardware control option. Using 
the remapping facilities of the Fader object, you can use a 
single hardware controller for manual manipulation of volume 
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or other types of MIDI continuous controller. Obviously, 
having multiple faders on an external controller makes life 
easier, but in many cases, even multi-fader external controllers 
will only transmit on a single MIDI channel or will use the 
same CC number on different MIDI channels. Using the fader 
object’s Controller Input facilities allows you to specify the 
incoming MIDI channel, CC number data that the fader will 
respond to.

Please refer to your synthesizer or MIDI device manuals for 
specifics on controller numbers and their operation.

Controller Output
The -1- entry under the Out section, allows you to assign the 
type of continuous controller sent by the fader object. As shown 
in the example above, CC#7—Volume, is being sent by the 
fader. To change this fader’s functionality to act as a Pan control 
for MIDI channel 1:

• Click-hold on the number 7 alongside the -1- entry, under 
the Out section.

• Select CC#10—Pan from the flip menu.

Most people normally associate pan controls with a knob. To 
change the appearance of the Fader to a Rotary knob.

• Click on the Auto Style text in the fader’s parameters box.
• Select any of the as Knob styles available. Selection of Knob 

style 2 is shown alongside.
• You can also change the appearance of an “Auto Style” fader 

by click-holding on the small box to the fader’s lower right 
and dragging the fader’s outline to a different size or shape—
i.e. square as opposed to rectangular. When you release the 
mouse button, the fader’s appearance will change.

You can directly interact with the fader object—and therefore 
generate data—by click-holding on it, and moving the mouse. 
The movement of the mouse will vary, dependent on the style 
of the fader. e.g. horizontal movement will not affect a vertical 
fader.
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Setup Shortcuts for Multiple Faders
Let’s look at some shortcuts for building an automated mixer. 

• Select a layer on which you have created a Multi Instrument
• Create a new fader, if one doesn’t exist.
• Hold the ç key down, and while doing this, click and drag 

the fader object to the right. Release the mouse button and 
ç key. This should have created a copy of the fader object.

• Rubber-band select the two fader objects by clicking outside 
either fader, and dragging, while the mouse button is held 
down. Drag the outline box until both faders are highlighted. 
Below, four fader objects are selected.

• Once highlighted, release the mouse button.
• Hold the ç key down, and while doing this, click on either 

fader object and drag to the right. Release the mouse button 
and ç key.

• You should now have 4 faders onscreen. Repeat until enough 
faders have been created for all used MIDI channels of your 
connected MIDI instrument.

• Rubber-band select all faders, double-click on the Multiple 
sel text in the parameters box, and type in Vol 1, as shown. 

• Note that all of your faders have been automatically, and 
sequentially, renamed Vol 1 to Vol 16.

• Last step is to change the Control Out and Control In MIDI 
channel for each fader. By default, all faders will be assigned 
to MIDI channel 1 for both Control In and Out. You will need 
to change the “Vol 2” fader object to MIDI channel 2, the 
“Vol 3” fader object to MIDI channel 3, the “Vol 4” fader 
object to MIDI channel 4 a.s.o. 

• This is done most efficiently by selecting the Options > 
Apply Buffer Template to > Definition, Channel Increment 
function.
99
Introduction Manual
Version 5



Chapter 2
The Ideal Workspace

Tip

Logic 5 intro en.book  Page 100  Monday, October 28, 2002  9:34 PM
This same set of procedures can be applied to fader objects 
assigned to any other controller. As an example, if you wanted 
to set up pan pots for your mixer, you could simply rubber-band 
select your existing faders, and copy them using the technique 
above.

While all copied faders are selected;

• Rename them to “Pan 1”.
• Change the Output controller number from CC#7 (Volume) 

to CC#10 (Pan).
• Change the faders to knobs.

You can also copy existing faders between Environment layers 
by selecting the standard Edit > Copy and Edit > Paste func-
tions.

How to Automate Faders
While not necessary for the recording and playback of volume, 
pan and other types of MIDI controller data, it can be helpful to 
see your faders moving during playback. The advantage is that 
when you move to different sections of your arrangements and 
songs—when in pause or play mode—your faders will update to 
reflect the current volume, pan (or other continuous controller) 
setting for each channel on each MIDI device. This at-a-glance 
overview can be very helpful when trying to isolate a part that 
isn’t “sitting” properly in your mix. 

Note that the Windows > Track Mixer is fully automated, and 
that Logic 5’s Track Automation system provides graphical 
automation track(s) in the Arrange window. The automation 
track(s) allow a far more accurate overview of various parameter 
settings/levels than is possible with any onscreen fader.

The “Mix” Object
The best solution for this type of “flying fader” automation 
(outside of using the Track Mixer) is to set up a mix object for all 
channels to be recorded to. See the diagram below.
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In this example, the output of the “JV Mix” object has been 
routed in to the Pan and Vol objects. If you wish to set up a 
similar set of faders and a Mix object in your own Environment, 
follow the steps outlined in the preceding sections and this 
section, substituting JV Mix for your own object name.

The JV Mix object is simply an Instrument object, created via 
the New > Instrument menu. It’s icon has been changed to that 
of a Mixer and the Cha parameter has been set to All. 

• Create your own “Mix” object using this method. 
• To set the Cha parameter to All, click-hold on the Instrument 

(Mix object) parameter box Cha value of 1, and drag the 
mouse down.

• As a nice shortcut for changing the icon, you can double-
click on the existing Instrument icon, in the parameters box, 
and type in 304. This will change it to the mixer icon shown. 

• Use any of the naming techniques you learned earlier to 
rename the object. It is recommended that you give it a 
name which is relevant to the device it is controlling.

• Note that all of the Pan and Vol fader objects have been 
cabled serially—i.e. one after the other. To cable your faders 
in this fashion, rubber-band select them and select the 
Options > Cable Serially menu item.

• When cabling the Instrument—i.e. JV Mix—object into the 
first of your faders, as per the image, you will see the 
following dialog box. Select Remove.
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• After doing so, note that the port previously shown in the 
parameters box will now display No Driver or will appear as a 
blank space above the Cha line.

• Repeat this procedure for each channel, of each device 
(where applicable), on each layer.

• Once done, save your “Autoload” song via File > Save.

Using the Mix Object
Please give the following a try, to ensure that your cabling is 
correct, and to get a feel for using the Mix object/Track.

• Select the JV Mix object in the Arrange window’s Track List 
by click-holding on any Track name and scrolling through 
the hierarchical flip menu. Once the JV Mix object is found, 
release the mouse button.

• Reposition your windows to allow the viewing of the Envi-
ronment layer on which the JV Mix object and your faders 
exist, plus the JV Mix track in the Arrange window.

• Activate Record via the Transport Bar or Key Command.
• Move your faders and knobs. As you do so, you’ll note that 

data is recorded onto the JV Mix track. 
• Once done, stop recording by pressing the Stop button on 

the Transport Bar, or via the Key Command.
• On playback, the output of the JV Mix track/object is routed 

in to the various faders and pan pots causing them to move 
in response to the incoming data.

Recording Preferences
Logic’s Recording preferences have a part to play in the way 
your sequence data—controllers or MIDI notes—appears. 
These preferences will affect the way that any MIDI Mix auto-
mation appears in the Arrange window. 

� Note that this does not affect the Track Automation system.
102
Emagic
Logic



Environment Controls l

Logic 5 intro en.book  Page 103  Monday, October 28, 2002  9:34 PM
Open the Options > Settings > Recording Options… menu. You 
will see several options here, which allow you to “merge” or 
“auto create” tracks. We will discuss these recording options in 
more detail later, but for now, keep the following in mind:

The merge options will combine all recorded fader movements 
into a single sequence on the JV Mix track. Recording all of 
your MIDI mix information to one track keeps things neat 
onscreen, and all mix automation data in the one place. Editing 
is easier because you don’t need to open several Event List or 
HyperEdit windows to deal with multiple tracks. Additionally, 
if you want to isolate data, you can simply use the Select Equal 
or Similar filters in your editing windows, which we’ll discuss in 
the next chapter.

If the auto create options are selected, your automation data 
will be recorded onto several discrete sequence objects, as you 
record individual fader movements on each “pass” or “take”. 
The advantage of this is that your fader automation tracks will 
be recorded on a per-fader basis, with a discrete sequence 
appearing in the Arrange window for each fader’s data. While 
this offers some advantages, you can quickly end up with a 
number of sequences stacked on one track—i.e. the JV Mix 
track, or you can end up with a number of tracks. Either way, 
your Arrangement can quickly become filled with automation 
sequences and these sequences will be difficult to manage and 
edit.

Try both the merge and auto create options as you become 
more familiar with working in Logic, and set the appropriate 
preferences. 

� We strongly recommend the use of the Track Automation system, 
which we’ll discuss a little later in the Introduction Manual.
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Setting up a GM Mixer Object
This object is unique in that it is a hybrid object. It combines 
some features that seem more like those of a Multi Instrument 
object, plus a number of faders, pan pots and more into a single 
unified surface. It is ideal for remote control of General MIDI, 
GS or XG synthesizers. If you own one of these types of 
devices, creating a GM Mixer Object is the quickest way to set 
up all of the faders, pan pots and more in the Environment.

• Select the layer which contains your GM synth from the 
Layers menu.

• Create a GM Mixer object by choosing New > GM Mixer in 
the Environment window.

• Set the appropriate port for the new GM Mixer object by 
clicking on the Port flip menu, found in its Parameter Box to 
the left of the Environment window.

• Repeat these steps for each GM, GS or XG device. 
• Once done, save your “Autoload” song via File > Save.
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2.10 Environment Processing
As briefly discussed at the start of the chapter, you can cable 
various objects together to create different types of “machines” 
or processors for your MIDI data.

This section will touch on a few of the other data processing 
objects you will find in the Environment, and will offer some 
practical examples of where they may be useful to you—both 
musically, and on a technical level.

As the old adage goes, a picture’s worth a thousand words. 
We’ve taken this a step further and for these examples, you’ll 
find an accompanying song file.

The point behind this section of the chapter is to introduce you 
to some creative ways of using the Environment objects and a 
couple of key concepts. Namely:

• Objects can often be used for tasks that extend beyond their 
obvious use.

• Objects, when combined, can perform tasks that utilize a 
little of each object’s functionality to create a new processor. 
This new multi-object processor may perform a function 
that is unrelated to the functionality—obvious or other-
wise—of the objects.

We encourage you to spend some time—over the coming 
months—experimenting with each object in the Environment, 
to familiarize yourself with their practical and possible uses.

The Chord Memorizer
• Please load the Chordmemorizer song file, via File > Open. 

Browse to the install directory for this song. It is set up for 
use with a GM device.

• Once opened, press the Play button on the Transport Bar, or 
use the Key Command.
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The screen is split into three windows, showing the Arrange, 
the Matrix and Environment, from top to bottom. As you can 
see, the Arrange window contains a sequence on the “Chord 
Memorizer” track. The Matrix window, in the center, shows 
the contents of this sequence. The Environment window at the 
bottom displays the Chord Memorizer object, which is cabled 
into both the Cha 1 and keyboard objects. 

As the sequence plays, and cycles, you’ll see that the Matrix 
editor only displays single notes, yet you can hear chords and 
see chords being displayed in the keyboard object in the Envi-
ronment. The Chord Memorizer object will trigger a user-
defined chord when it receives a single MIDI note event.

Stop the sequencer by pressing Stop.

Double-click on the Chord Memorizer object in the Environ-
ment.

Click on the notes from C2 through to G2 on the top keyboard. 
As you do so, you’ll note that the chord changes in the bottom 
keyboard. To change voicings in your chords, simply click on 
individual notes in the lower keyboard. To deactivate a note in 
the chord, simply click on the highlighted note a second time.

The obvious use of the Chord Memorizer for single note trig-
gering of chords could be extremely useful for a non keyboard 
player, allowing fast chord runs to be recorded.

Alternate Scales
Another use for the Chord Memorizer could be for alternate 
scales. Individual notes can be reassigned to other notes. To 
view this in action:
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• Press the § key on your computer’s keyboard to recall 
Screenset 3. In the Track List of the Arrange window, you’ll 
see the following on tracks 12 and 13.

• Click on the blue M button on the Tuner track once, so that 
it turns gray.

• Click on the gray M button on the (Chord Memorizer) track 
once, so that it turns blue as shown below.

• Click on the Tuner track in the Track List so that it turns a 
light gray. This will select the track and will update the 
linked Score and Matrix windows to display the contents of 
the MIDI sequence on the Tuner track.

• Press Play on the Transport Bar, or use the Key Command.

As you can see in both the Matrix and Score displays, a Penta-
tonic scale—the white notes from C upwards—is being played. 
What you can hear, however, is being routed via the “Tuner” 
object, which is a second Chord Memorizer that has been set up 
to change incoming notes to other notes.

• Press Stop via the Transport Bar, or Key Command.

Auto Accompaniment
Any sequence can be routed via the Chord Memorizer to play 
an accompaniment part, based on the original sequence. In 
conjunction with other objects, you can limit the accompani-
ment to individual notes, or selected notes within the chord, 
rather than simply doubling up the entire part with a layered 
sound.

• Click on the gray M button on the Tuner track once, so that 
it turns blue.
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• Click on the blue M button on the (Chord Memorizer) track 
once, so that it turns gray as shown below.

• Click on the (Chord Memorizer) track in the Track List so 
that it turns a light gray. This will select the track and will 
update the linked Score and Matrix windows to display the 
contents of the MIDI sequence on the track.

• Press Play on the Transport Bar, or use the Key Command.
• Click once on the Cable Switcher object as the sequence is 

playing. You will hear a string part playing specific notes 
within the chord. The cable Switcher object is simply used 
to switch between cable connections to other objects. In this 
case, it is used to switch the only cable connection on or off—
i.e. connected or disconnected to the Transformer object, 
which in turn is routed to Cha 2—an Instrument object.

The Transformer Object
Please double click on the Transformer object. It will open a 
window which looks like the following.

Without going into extensive detail here, the Transformer 
object is used to “transform” one kind of data into another. In 
the Environment window, the Transform object does this in 
realtime. To explain the settings used in this example:
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• The top flip menu is set to Apply Operation & Filter non-
matching Events. This means that it will perform any trans-
form operations specified in the Operations box and will 
ignore any event which does not match the criteria set in the 
various Conditions.

• The Status is equal to (=) Note events. All other events—i.e. 
any MIDI event that is not a note event, will be ignored.

• The Cha is set to All, which means that MIDI note events on 
any MIDI channel will be allowed Thru, without being 
processed by any operation.

• The Pitch values, as shown, are limited to MIDI note events 
which fall between (Inside) E3 and E4. All note events which 
are outside this range will be ignored.

• Directly below the Pitch condition, an Add operation has 
been applied, with a value of 12.

• Although it looks a little technical, this is quite easy to 
understand. All MIDI note events which fall between E3 
and E4 will have their pitch values added to by 12. In other 
words, notes within this range will be transposed up by one 
octave.

• As the sequence is playing, adjust the range of notes by 
click-holding and dragging on the upper and lower values—
E3 and E4. Adjust the Pitch operation value of 12 using the 
same method.

• Click hold on each of the flip menus and try different options 
out, to familiarize yourself with the Transformer object.

The Transformer is the most flexible object in Logic’s Environ-
ment. It can be used for a wide variety of tasks, including use as 
a simple junction box or a MIDI data filter. Please read the 
Reference manual for a detailed look at the Transformer.

The MIDI Monitor Object
Please stop playback, if you have not already done so, and press 
the 2 key on your computer’s keyboard. This will recall 
Screenset 2 which will be similar in appearance to the 
following:
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This shows several objects set up before the Sequencer Input 
object, which is named “to Recording and Thru” in the 
diagram.

The Cable Switcher and Transformer objects can re-route and 
process data before entering the sequencer, much like the 
Arpeggiator example discussed at the beginning of the chapter. 
Please double click on the Transformer objects to see how they 
are set up. The Pre and Post Process View boxes that you can 
see are MIDI Monitor objects. The one on the left shows the 
raw MIDI data, and the MIDI Monitor on the right shows the 
data after it has been processed by either of the Transformer 
objects. The keyboard object simply displays incoming note 
data.

A simple connection from the Physical Input object to the 
Sequencer Input object will suffice for getting MIDI data into 
Logic. The more complex routing shown is not necessary, but 
use of a MIDI Monitor object can prove useful on input, for 
troubleshooting purposes.

This concludes this brief look at some of the Environment’s 
many objects. Once again, we encourage you to do a little 
experimentation on your own, and to read the Reference 
manual for detailed information on each of the Environment 
objects.
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2.11 MIDI Meets Audio
Logic’s Environment is, as you’ve discovered, responsible for 
getting MIDI and audio data in and out of the program.

We very briefly discussed the Audio Instrument objects in the 
Audio Instrument Object section, from page 90 onwards. As 
mentioned, the Audio Instrument object is unique among the 
Audio objects in that it can accept MIDI note input.

In practice, playing or recording an Audio Instrument is just 
like playing or recording a connected MIDI synthesizer or 
sampler. The Environment’s MIDI processing options—arpeg-
giators, transformers etc.—available to connected MIDI 
devices, are also available to these Software Instruments.

All you need do is remember the lessons learned in this chapter 
regarding signal flow. Cable the MIDI processors in to the 
appropriate Audio Instrument object, set up the desired param-
eters, and get creative.

Please refer to the Environment chapter of the Reference 
Manual over the coming weeks. It contains detailed informa-
tion about the parameters of each Environment object. This 
information will assist you in further enhancing your knowl-
edge and working experience with Logic.
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Using Logic

This chapter covers the basics of many of Logic’s functions by 
using “hands-on” examples. You will learn how to arrange a 
song, record a MIDI sequence, record and insert audio regions, 
plus a number of other techniques. You will also be introduced 
to a number of preferences which affect the way Logic oper-
ates—globally or within specific parts of the program. These 
preferences can be applied to your Autoload song, if desired. 
After working through this chapter, feel free to return to your 
Autoload and adjust the preferences to your liking. Use of 
Logic’s extensive audio mixing facilities are covered in the 
following chapter.

Please ensure that Logic is open and that you read through 
things in order. This is the time to experiment, as this will 
familiarize you with the functions, general working methods 
and interactions between the different parts of the program.

Please use the appropriate Key Command—marked as 
shown—whenever possible. Try to develop this “good habit” 
from the start by using Key Commands throughout the Tutorial 
chapter.

As you’re working through each section, take as much time as 
you need. Repeat any exercises, if necessary, until you feel 
comfortable with the techniques discussed. This is your studio, 
so there’s no need to watch the clock. Oh … and don’t forget to 
have fun!

In order to follow the tutorial you should have:

• installed Logic

Chapter 3
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• a General MIDI tone generator or an equivalent multi-
timbral device (like a soundcard installed in your computer), 
which is correctly connected to your computer’s MIDI inter-
face. 

3.1 Adapting the Tutorial Song
As you work through this chapter, use the provided Tutorial 
song. This song is configured for General MIDI (GM) tone 
generators, but you won’t have any problems using the song 
with tone generators that don’t follow the GM specification. 
The only difference when using a non-GM device, is that you 
will manually need to set the sounds and MIDI channels the 
first time you run the song. You may also need to transpose 
some tracks. If any of these steps are necessary, be sure to save 
your changes, so that you don’t need to repeat the procedure 
every time you reload the song—which we will ask you to do 
several times during this chapter.

Load the Tutorial Song
You can start the Tutorial Song by starting Logic, selecting File 
> Open, and browsing to the Tutorial Song or by double-clicking 
the “Tutorial” song icon in the Logic folder.

Arrange window with the Tutorial song loaded.
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General MIDI Tone Generator
The program change, volume, and pan settings for this song are 
customized for GM tone generators, and are sent to your device 
via MIDI. The transmission of these settings happens automat-
ically, if you play the song from the beginning. You will find the 
settings in a separate sequence—“GM Setup”—at the start of 
the song. As delays can occur with some synthesizers when they 
receive program change data, you should mute this sequence 
after it has been played through once.

To mute the program changes:

• Select the mute tool from the toolbox, and use it to click on 
the sequence named “GM Set-Up”. 

The sequence will turn black, to indicate that it is selected, and 
an asterisk will appear in front of the sequence name. This 
asterisk indicates that the sequence is muted.

You may also wish to activate the Muted Objects are textured 
parameter in the Options > Settings > Display Preferences, to 
further highlight muted objects. 

Non GM, Multi-Timbral Tone Generators
If you do not have a GM tone generator, you need to consider 
the following points: 

One prerequisite for GM compatibility is that the sounds listed 
in the following table are available. If necessary, find similar 
sounds in your own device. 

In addition, the drum kit’s note assignment needs to match that 
of the GM drum map (previously Roland drum map), otherwise 
the percussion passages in the tutorial will be reproduced with 
the wrong drum sounds. Set the appropriate receive channels in 
your multi-timbral synthesizer, and assign sounds similar to 
those listed in the tables. If you need to rearrange your Drum 
kit’s note assignments, follow the percussion instrument table 
in the Drum Kit section.
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Sounds and MIDI Channels

Drum Kit
Here is a list of percussion instruments used by the Tutorial 
song, and their locations. (C3 = Note number #60)

Transposition and relative volume values are only automatically 
correct with GM devices, so you should play the song a couple 
of times to see how it sounds after assigning compatible sounds. 

MIDI Ch. Function Sound Possible Name

1 chord combination piano/E piano Electric Grand, LA Gran

2 bass normal E bass Pick Bass, Rock Bass, E 

3 accents muted E guitar Mute Guitar, Slap Guita

4 melody long dying away melodic 
sound

Synthbell

5 carpet string section Slow Strings, Pad

6 accents wind section Brass Section

7 solo flute-like solo sound Stream, div. “Solo”

10 drums GM-compatible drum set GM Kit

Note Instrument

C1 Kick

D1 Snare (normal)

E1 Snare (hi)

F1 Tom lo

F#1 HHT closed

G1 Tom mid

G#1 HHT closed short

A1 Tom hi

A#1 HHT open

C#2 Crash

D#2 Ride

E2 Ride Bell
116
Emagic
Logic



Adapting the Tutorial Song l

X

X
X

X

X

Logic 5 intro en.book  Page 117  Monday, October 28, 2002  9:34 PM
Open the Track Mixer via the Windows > Track Mixer menu or 
Cm Key Command and use the faders to adjust the MIDI 
volume levels, if necessary. For further information on the 
Track Mixer, see the Track Mixer with Audio Channels section, 
from page 156 onwards.

Once you are happy with the sound selection, transposition and 
level settings, save the song file via File > Save.

Starting the Song
• To listen to the Tutorial Song, simply press E on the 

numeric keyboard. 
• To stop the song, press =. 
• To return to the beginning of the song, push =, on the 

numeric keypad, twice in succession. 

These “Key Commands” for the Transport Bar are much faster 
to use than clicking on the buttons with the mouse. 

Throughout the tutorial, we will indicate the appropriate Key 
Command for various functions. Please use them as you work 
through this section. It will help you to memorize them, and by 
the end of the tutorial, you probably won’t even think about 
“which key?”… you’ll innately know them.

Inside the cover of the Introduction Manual, you will find a Key 
Command reference chart for the default shortcut keys 
assigned in Logic.

Give the song a listen now, and press stop—using =—once 
you’re done.
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3.2 Overview
Within the Tutorial song, you will see the following onscreen:

1 Transport field This is where you control the operation of Logic. 
You can turn on Cycle, set drop in/out points for recording, adjust 
synchronization settings, and many other options.

2 Main menu bar This is where you will find global functions, e.g. for 
saving and loading songs or for opening various windows.

3 Bar/Beat Ruler The Bar Ruler displays Logic’s time axis. Here, you 
can set markers with the mouse, or jump to any desired place in a song.

4 Arrange area, with sequences A track may contain any number of 
sequences. Sequences contain the actual data, such as notes, controller 
data, etc. The data can be edited in a variety of ways.

5 Telescopes If you click on the telescopes, you can alter the magnifi-
cation factor of the window’s contents and adapt them to your screen 
resolution.

6 Transport window The transport window performs the same func-
tions as the transport field, but can be located anywhere onscreen and is 
variable in size. A “slider” enables quick jumps to any song position.

7 Track List column Here, you can determine the MIDI channel for 
each track, swap, insert or delete tracks.

1 2 3 5

6

7

8

9

4
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8 Toolbox Using tools from this box enable you to edit sequences, 
notes or other data in a variety of ways.

9 Sequence parameter box The sequence parameter box is where 
quantization, transposition and other aspects of the playback for a 
sequence can be non-destructively edited.

As you can see, the Arrange window is divided into three basic 
“areas”—from left to right, these are; the Parameters, the Track 
List and the Arrange area. Above the Arrange area, you’ll find 
the Bar/Beat Ruler, sometimes referred to as the Time Line. 

While reading the information in this section, you’ll learn how 
these various areas interact with each other and will also 
discover how similar the handling of both MIDI sequences and 
audio regions is in Logic.

3.3 Tracks and Sequences
Like a multitrack tape machine, Logic works on the basis of 
“tracks”. You can see and access these tracks in the Arrange 
window’s Track List—shown alongside.

Narrow rectangles known as “sequences” appear in the Arrange 
Area—horizontally aligned with the tracks listed in the Track 
List. A sequence represents an individual recording, or “take” 
of MIDI data. Each time you record, a sequence will be created 
on the selected track. You can consider the sequence a 
“container” for the actual MIDI data. This data can include—
either individually or in combination—note events, control 
data, program changes, or even sysex data for your MIDI tone 
generators. To explain;

• Note data are derived from the notes being played on your 
MIDI keyboard. It includes information about the time (bar/
beat position) the note was played, how long the note was 
held and the velocity at which (how fast) the key was struck.

• Control data (continuous controllers) includes volume and 
pan position settings and changes, plus any other controllers 
that you may use and that your synthesizer responds to.
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• Program changes allow you to select different sounds (or 
“patches”) from your MIDI synthesizer or soundcard. 

• Sysex (short for system exclusive) is a part of the MIDI 
language which can be used to store the entire memory of 
your MIDI devices, amongst other things.

Tracks with sequences

Information Track and Instruments
Take a closer look at the Tutorial song’s “information track”.

On track 1, you can see the “A intro”, “B groove”, and subse-
quent sequence objects. “No Output” is displayed in the track 
column of track 1. This is a “dummy track”, which is not routed 
to a MIDI output port. The sequences on this track do not 
contain any MIDI notes or other information. They are simply 
used as reference markers for the various song parts. As you 
continue to work through the chapter, you will be using this 
“information track” as a reference.

Instruments for the Tutorial song are found on the remainder of 
the tracks: piano on track 2, bass on track 3, guitar on track 4, 
and so forth. The MIDI channel used by each track is visible in 
the track parameters box. This information will update as 
tracks are individually selected in the Track List. In addition, 
an icon can be displayed for each track. This visually indicates 
the type of instrument in use and can be freely changed.
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3.4 The Arrange Window 
As mentioned, the Arrange window is divided into three areas. 
This section of the Introduction Manual will give you an over-
view of the Arrange window’s interface.

Parameters Area
There are three “boxes” in the parameters area. They are, from 
top to bottom, the MIDI Sequence/Audio Region parameters, 
the Tool Box and the Track/Instrument parameters.

Sequence/Audio Region Parameters
This parameter box, also known as the Object Parameters Box, is 
directly related to the MIDI sequences and audio regions 
which appear as rectangles in the Arrange Area to the right of the 
Track List. When either a MIDI sequence or audio region is 
selected—by clicking once on it with the mouse—this param-
eter box will update to reflect the parameters assigned to that 
particular sequence/region. Give it a try on several sequences, 
and pay attention to the changes which occur in the Object 
Parameters Box.

Each “object” in the Arrange Area may have its own parameter 
settings, allowing independent transposition, quantization and 
more. The parameters available for MIDI sequences and audio 
regions are different. The reasons for these parameter differ-
ences are due to the very nature of MIDI and audio, which we 
discussed in the first chapter of the Introduction Manual. 

To change a parameter value, simply click-hold to the extreme 
right of the parameters box—alongside the parameter entry. 
This will open a flip menu for some parameters, and for others 
will change the cursor to act as a slider. For these parameters, 
drag the mouse on the vertical axis (up and down) to change the 
value. Please select a sequence, and give this a try for each of 
the parameters to familiarize yourself with the methods used to 
interact with each of them.
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Some Extra Tips for the Object Parameters
• In the Object Parameters box, the transpose, dynamics, gate 

time & delay functions have a couple of “zones” to the right 
of the text where you can click with your mouse. If you click 
to the extreme right of the box, you will be able to incre-
ment/decrement values in individual steps. If you click the 
mouse in about a half centimeter from the right hand edge of 
the parameter box Delay, a flip menu of mathematical vari-
ables will show up—1/8th, 1/16th a.s.o.—allowing you to 
select one, if appropriate to the task at hand. Why not give it 
a try?

• On a program-wide level. Double-clicking on numerical 
values in almost all parameter boxes, editors, on the trans-
port bar etc. will allow you to directly type in a value.  This 
method of direct numerical entry can be used for quantize, 
program changes, many effects parameters etc. which will 
accelerate your workflow. To do this, double-click on the 
numerical values within the various parameter fields and use 
your computer keyboard to type in a new value, followed by 
the R key. Once again … give it a try.

It should be noted that the Object parameters are available as 
real-time processes, meaning that changing these parameter 
values—quantize, transpose etc.—can occur while Logic is 
running. These processes occur on playback and do not actually 
alter the underlying MIDI data. To undo any changes made to 
an object’s parameters, simply select the appropriate object, 
and change the parameters back to their former settings using 
the techniques described above.

The Tool Box
Key to selecting and altering MIDI and audio information in 
the Arrange Window and Logic’s other editing windows, is the 
Toolbox. This contains a pointer, pencil, eraser, scissors & glue 
tools plus others which allow you to select, draw, cut, copy, 
paste, delete, merge and crossfade (audio regions only) 
sequence and/or audio regions. There is also an automation 
“draw” tool.
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The toolbox is context-sensitive. This means: Its look depends 
on the edit window. Different tools will appear for particular 
tasks in the various individual edit windows. As an example, 
there is no crossfade tool in the Score window as audio is not 
handled in this editor. There is, however, a voice separation 
tool in the Score window. The practical use of the tools is 
discussed throughout this chapter.

In the toolbox, you can select any editing tool required by 
simply clicking on it with the mouse. You can also select a 
second tool for use via C + mouse button on Mac OS.

When you need to use any of the tools, hit ™ on your 
computer’s keyboard and the Toolbox will “float” at the loca-
tion your mouse pointer currently occupies onscreen. When the 
floating toolbox appears, simply select the appropriate tool with 
your mouse cursor. As usual, try it out.

The Track/Instrument Parameters
This set of parameters is linked to the second onscreen area—
the Track List—and is used for global parameters such as the 
selection of instruments (Prg—Program Change), the overall 
track volume, transposition and more for all “objects” on the 
track. 

This parameter box will update each time a new track is 
selected in the Track List. 

Please select a few tracks in the Track List with the mouse or 
by using the up/down arrow keys on your computer keyboard. 
While doing so, watch the changes in the Track/Instrument 
parameters box.
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The Track List
The second area of the Arrange window is known as the Track 
List. This is where you can add, delete, select, name and reor-
ganize the tracks/instruments used in your song. 

Note the highlighted track in the list. This (or any) MIDI track 
is automatically “armed” for recording—indicated by the red R 
button—as soon as the track is selected. Any MIDI input 
received by Logic, when in record mode, will be recorded to 
this track. This recording will then appear as a sequence in the 
Arrange area.

The illuminated M on track 11—“Grand Piano”—indicates 
that all objects on the track are muted—i.e. all objects aligned 
horizontally on this track are silent. The mute button actually 
stops MIDI data transmission on the track.

The (orange) indicator you see to the left of track 12—
“Fingered Bass” is a level/activity meter. Such meters appear 
on all active tracks and are useful aids for keeping an eye on 
what tracks contain objects that are currently playing and their 
relative levels.

Recording audio tracks is a little different to that of MIDI 
tracks. Audio tracks must first be “armed”, which is achieved 
by clicking on the R button on the desired track (You can also 
customize the Record Enable Track Key Command). Once 
armed, pressing the Record button on the Transport Bar will 
start recording audio data to the selected track. 

N.B.—Before any audio can be recorded, you must first set a 
recording path and file name—i.e. a location on your 
computer’s hard disk and a name for your audio files. We’ll take 
a look at how to do this shortly.

Muting/unmuting of MIDI or audio tracks is achieved by 
clicking the M button on each track in the Track List or by use 
of the x Key Command on a selected track. Give both a try.
124
Emagic
Logic



The Arrange Window l

Logic 5 intro en.book  Page 125  Monday, October 28, 2002  9:34 PM
Reorganizing Your Tracks
You may want to reorganize your tracks to keep things neat 
onscreen, or to group audio tracks or particular instruments 
together, which can be useful for scoring. To do this, move your 
mouse pointer over the number on the track you wish to move, 
and click-hold the mouse button. This will change the appear-
ance of the cursor to a “hand” icon as shown.

With the mouse button held down, drag the track up or down 
the Track List to the desired location, then release the mouse 
button. This will change your track order, and will also move all 
of the associated Track objects—sequences or audio regions—
in the Arrange area. Please try it out.

The Arrange Area

The third area of the Arrange window’s interface is the large 
gray Arrange Area. This is where your audio regions and MIDI 
sequences are “arranged” into a song. You can freely drag and 
drop your audio and MIDI “objects” from position to position, 
make loops, copies and more. 

Audio and MIDI data can be recorded directly into the Arrange 
area as mentioned earlier. 
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You can add audio regions—in either WAV or AIF format (or 
SDII format on Mac)—directly to the Arrange area by drag and 
dropping them from any folder on your hard disk. Another 
method for adding audio regions to the Arrange window is by 
pressing OS while clicking at the desired location. You can 
also mix your audio and MIDI objects directly in the Arrange 
area, which we’ll discuss in the next chapter.

Above the Arrange area, you’ll see the Bar/Beat Ruler. This is 
used for a number of functions performed in the Arrange area, 
including song navigation. Much of the Bar/Beat ruler’s func-
tionality is tied to the Transport Bar, which we’ll discuss now. 

Reload the original Tutorial Song now, if you have made any 
changes to the sequence parameters, track order etc.

3.5 Navigating the Song
In this section, you will learn how to move to different parts of 
the song, start and limit passages, and to isolate and audition 
specific portions and components within the song—in short, 
you’ll learn how to “navigate” through the song. As you’re 
reading, follow the steps and try out the functions. You can’t 
“break” anything.

The Transport Bar
The second, smaller window, displayed after loading the song is 
the floating Transport window. It is laid out like the control 
surface of a tape machine, with the top row of buttons used for 
operating the Record, Pause, Play, Stop, Rewind and Fast 
Forward functions. In addition, you can use the Transport 
window to change the tempo settings and engage operations 
such as solo, synchronization, or cycle which we’ll cover shortly.
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You can start the song by clicking on the Play button on the 
Transport bar, or by pressing ‰ on your numeric keypad. 

You may hear that the song is not completely arranged, and 
contains a few inconsistencies. As you continue to work 
through this chapter, you will finish arranging the song, add a 
few details, and correct one or two mistakes that we intention-
ally left in. Following this, the song will be completed with the 
addition of some audio files.

Try out the buttons in the upper row of the Transport bar. You 
should be pretty familiar with them as they are identical to the 
functions found on tape machines and cassette recorders. Each 
function has a Key Command, as discussed in the first chapter.

Moving to Different Song Positions
There are several ways to “jump” to specific song positions.

At the top of the Arrange window, you can see the Bar Ruler.

• Click at various spots in the lower half of this ruler and you’ll 
immediately “jump” to that position. As you click, a vertical 
gray line will appear in the Arrange area aligned with the 
point selected on the Bar Ruler. This is the Song Position Line 
(SPL) which, in the most general sense, is comparable with 
the tape position indicator on a traditional recording device.

• Engage Play via the Transport Bar or E. 
127
Introduction Manual
Version 5



Chapter 3
Using Logic

X

Tip

Logic 5 intro en.book  Page 128  Monday, October 28, 2002  9:34 PM
• Now click on the Bar Ruler, and hold down the mouse 
button. Take note of the SPL, which moves to align itself 
with the mouse position in the Bar Ruler. You can move to 
any position in the Bar Ruler, and audition different sections 
of your song instantly, by moving the SPL in this way. Play 
must be engaged for this live “auditioning” (i.e. hearing) to 
occur.

If you would like to “jump” directly to a specific position when 
the sequencer is not in play mode (press the Stop button now, if 
Logic is presently running), you can also take advantage of 
Logic’s “locators”. To the right of the transport buttons, the 
current song position—in both absolute time (that’s hours, 
minutes, seconds, in plain language) and as musical measures 
(bars/beats etc.)—is displayed.

• Click-hold on the song position indicator, and with the 
mouse button depressed, drag the mouse on the vertical axis 
(up and down) until the song position displays “17 1 1 1”, 
and start playback—you know the Key Command. Logic 
will begin playing at measure 17. Take note of the SPL as 
you’re doing so.

• Another way of doing the same thing is to double click on the 
current song position locator on the Transport bar. This will 
open a text dialog box, where you can directly type in 17 1 1 
1. Give it a try.

It is essential that you type 17 and then press the space bar 
(V), then 1, and then the V, and so on. Once all numbers 
have been entered, just press the R key. If the space is not 
added between numerical values, Logic will interpret this as 
bar 17, 111 and will ignore your entry, as it exceeds the song 
length. 

As a great shortcut, you can simply type in 17 and then press the 
R key when you want to jump directly to the beginning of a bar. 
If you want to go to any position other than the first beat in any bar, 
you must include all 4 numerical positions. As an example, 17 3 
2 2 (don’t forget the V), which translates to bar 17, beat 3, 
sub-beat 2, clock tick 2.
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Display Current Song Position
If you manually enter and jump to positions, the song overview 
displayed can, on occasion, not correspond to what you hear. 
You can, however, guarantee that these two things always 
match.

• Click on the Catch button found to the upper left of the 
Arrange window, and the song overview will update, 
following the song position line again.

This facility ensures that when the song position line exits the 
visible portion of the song overview, the display will update to 
follow it. In general, catch mode should be activated while 
using the program.

Zoom a Window Excerpt
You can view the entire song in the visible portion of the 
window by using the telescope symbols at the top right. 

Click on the left half (narrowly spaced lines) of the telescopes 
until you can see all of the sequences in the window. For both 
platforms, there are also Key Commands for zooming, which we 
discussed in the Zooming section, from page 35 onwards.

Give it a try!

Cycle Mode
In cycle mode, you can endlessly repeat a section of the song as 
long as Play is engaged. This is useful for editing sequence 
parts “live”—i.e. as the song is playing, or for the recording of 
new tracks to a specific section of the song. Two “locators” can 
be used for setting cycle regions. These are position markers that 
define the left and right boundaries of a song segment. They 
are found directly to the right of the bottom row of the Trans-
port’s control buttons.
129
Introduction Manual
Version 5



Chapter 3
Using Logic

X

X

Logic 5 intro en.book  Page 130  Monday, October 28, 2002  9:34 PM
To activate Logic’s cycle functions:

• Turn on the cycle mode by clicking on the Cycle button in 
the Transport window or by pressing the cycle Key 
Command—c. When active, the cycle button will turn 
green.

In this example, we’ll use part “C” in the information track as 
the basis for setting the cycle region boundaries. 

• If necessary, use the horizontal scroll bar (by click-holding 
and dragging left or right) at the bottom of the Arrange 
window to scroll the window view, until you can see 
sequence “C”.

• Click on this sequence once, which will turn black, indi-
cating that it is selected.

In the Functions > Object menu, select Set Locators by 
Objects. This will create cycle region boundaries which match 
the size and position of sequence “C’s” left and right bound-
aries. Pay particular attention to the display changes that occur 
in the Bar Ruler at the top of the Arrange window:

This visual representation of the cycle region (the highlighted 
section) can be interacted with directly in the Bar Ruler.

You can adjust it in the following ways:

• Move it by grabbing it in the middle and dragging your 
mouse to the left or right. 

• You can also change the region borders by grabbing either 
the bottom left or right corners of the highlighted section on 
the Bar Ruler, and moving the mouse left or right. 
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Try both and when done, resize to match the region shown. 
Press Play and allow the region to cycle over the selected 8 bar 
section. You can even resize the cycle region while the cycle is 
playing, using the technique mentioned above. When cycle 
mode is engaged, pressing Stop twice will move the SPL to the 
beginning of the cycle region, rather than the beginning of the 
song, which is its default behavior. Give it a try.

Selection Techniques
In order to edit any data type in Logic—be it sequences, audio 
regions or notes—you first need to select them. All functions 
and operations will only affect items that are selected.

Solo
• To start, turn on the solo function by clicking on the Solo 

button in the Transport window or by pressing s—the Solo 
Key Command. The Solo button and the Bar Ruler at the 
top of the Arrange window will turn yellow. 

• Ensure that “Cycle” mode is also enabled, and that the cycle 
region boundaries extend from bar 25 through 33 (Section 
“C”).

• Start playback, and click once on the “Piano C” sequence to 
highlight it. As mentioned earlier, highlighted sequences 
will turn black indicating that they are selected. You will hear 
the piano part in isolation, because when Solo is active, only 
selected sequences will play.

• Click on the other sequences in section C, one at a time, to 
“solo” them. 

• Once you’ve got the hang of this, you can go one step further 
by “soloing” several selected sequences.

• Select “Piano C” once more. 
• Now, hold the S key down, and click on the “Bass C” 

sequence. This will also be selected and played. 
• With the S key still depressed, click on the “Groove Real-

time” sequence. You should now hear the piano, bass, and 
percussion parts.
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• While still pressing the S button, click just below the 
“Groove Real-time” sequence, and keep the mouse button 
depressed. Now, drag a “lasso” over all of the sequences in 
section C.

• Your previous selection will now be reversed and you will 
hear all sequences except for piano, bass and percussion.

Try out the selection functions with other sequences, individu-
ally and grouped (using the S key), if you’d like more practice. 

And congratulations! 
You’ve just mastered the most essential of Logic’s tech-
niques—the selection of objects—sequences, notes, audio 
regions … you name it! 

3.6 Changing and Creating 
Sequences

Although we briefly touched on the Object Parameters in the 
Parameters Area section, from page 121 onwards, and the Tools 
elsewhere, this portion of the Introduction Manual is altogether 
more in-depth and hands-on. You will learn most of the practical 
information you need to handle sequences in this section, so 
take your time. Practice each step as many times as you need to.

Quantize
Quantizing is the rhythmic correction of notes, aligned to posi-
tions on a “grid”. When quantization is applied to any selected 
event or sequence, Logic will move all note events to align 
perfectly with the nearest grid positions.
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In the image, the first 4 beats show unquantized note events. In the 
second four beats, the notes have been quantized, and now align to the 
nearest beat positions on the “grid”.

We’ll use the “Groove Real-time” sequence as an example. 
The timing of note data in this sequence was intentionally left 
slightly off the beat. To correct these small timing errors, you 
will use Logic’s quantization facilities.

To best illustrate how quantization affects MIDI note timing, 
we strongly recommend that you enable the Metronome.

• To do this, click on the Metronome button found towards the 
lower right of the Transport bar. 

By default, Logic transmits the metronome click to channel 10 
of the first available MIDI port. Ensure that your tone gener-
ator (preferably a GM device) is connected to this port, or set up 
a metronome as per the instructions in the Creating the Metro-
nome Object section, from page 77 onwards. 

Press Play and solo the drum sequence, using the technique 
you learned earlier. When compared to the metronome click, 
you will hear that the “groove” is not perfectly on the beat.

• In the Object Parameters box, click-hold on the off (3840) text 
alongside the Qua entry. In the flip menu which opens, select 
the 16D Swing setting, and release the mouse button. This 
quantize value will then be displayed in the sequence’s 
parameter box. As the sequence continues to play, you’ll 
discover that it now sounds rhythmically perfect.

• Try out the other quantize values on this sequence, in order 
to hear the effects of Logic’s quantizing options. Once you’re 
done, reselect the 16D Swing setting.
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Spend some time looking at the quantize settings used on the 
various song parts. Remember that selecting each sequence 
will update the Object Parameters box.

You will notice that the swing factors—Quantize values 
followed by an alphabetic character—are different for many of 
the sequences. Judicious use of these “groove” factors can 
make your choruses sound like they “swing” more than verses 
do, for example. This is a great thing because your music will 
sound like it’s played by you, rather than your computer, even 
if the quantize functions are used.

Another thing to consider, while experimenting with different 
quantize settings, is that this operation happens in real-time, 
while the sequencer is playing. As you’ve also discovered, you 
can jump to different song positions, solo tracks and change 
cycle regions while Logic is playing. This real-time function-
ality is available for most Logic operations and allows you to 
concentrate on your music, not wait for the program to process 
data, while listening. Keep reading, there are many other real-
time features and functions for you to discover which will aid 
your creative flow.

Loops
“Loops” are automatic repetitions of a sequence. The loop 
function enables you to repeat a passage as many times as you 
wish, without having to copy it.

Let’s add a cabasa to the Tutorial song. We’ll use it in the “B 
Theme” and “Groove” sections of the song, as outlined in the 
information track.

A sequence named “cabasa” can be found on track 10 at the 
beginning of bar 17. You will notice that it is muted. Muted 
sequences are identified by an asterisk which precedes the 
sequence name, and are also paler in color than non-muted 
sequences.
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• Click on the sequence once with the mute tool, which will 
unmute, and select it.

• Click once with the mouse alongside the Loop entry in the 
Sequence Parameters box. This will then display the word 
ON to indicate that the loop function is active. 

You should now see the following displayed onscreen:

The cabasa sequence will now be repeated until the end of the 
song is reached. In this example, however, we’d like to stop it 
before then. Loop repetitions are displayed as gray bars that are 
of the same length as the original sequence.

The way the loop function works is as follows:
A looped sequence is repeated until it encounters another 
sequence on the same track (or the song ends). To “turn off” 
the cabasa at a desired position, simply insert an empty 
sequence onto the cabasa track. For now, we’d like you to do 
this at the beginning of section C. Here’s how …

• Select the Pencil tool from the toolbox, and click once in the 
cabasa track at position 25 1 1 1—i.e. directly on top of the 
loop repeats. This will insert a new, empty sequence and 
your screen should now look like this:

The insertion of this blank sequence onto the cabasa track will 
stop the looped cabasa part at measure 25. Press ™ twice.

Copying a Loop
As a final step for you to try with this loop example, we’d like 
you to copy the cabasa part to the “groove” section of the song.

• While pressing the S key, click on the cabasa sequence, 
and—importantly—the “stop” sequence you just inserted. 
When both have been selected, release the S key.
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• Press the O key. Click on the cabasa sequence, and drag 
the entire section to measure 33, while keeping the modifier 
key pressed. The entire passage, including the stop 
sequence, will be copied, and you’re done!

If the “stop” sequence is not copied, the original sequence—
with the Loop playback parameter active—will be copied to the 
desired location. This will create a sequence copy with loop 
repetitions that continue to the song end point, which may not 
be what you want to happen.

The Loop parameter, and the Copy function that you just used 
are a great way to quickly create drum tracks, bass parts etc. that 
are repeated throughout your songs. In many musical styles, 
the use of recurring motifs (the same bassline, drum part, 
chorus etc.) is commonplace, and you now know this technique 
which may help you to arrange your future songs more quickly 
and easily.

Resizing a Sequence
Each sequence (or audio region) can be resized by clicking on 
it’s bottom left or right hand corner and dragging to the left or 
right.

� With audio regions, dragging from the bottom left hand corner to the 
right will also move the anchor point, which we’ll discuss later in the 
chapter. Dragging from the right hand corner to the left will shorten 
the audio region. No audio region can be longer than the underlying 
audio file on which it is based.

The reason why you would want to resize any sequence or 
audio region may be to create a drum “fill”, or simply a variation 
on an existing sequence (or copy). Perhaps a section of a solo?

• Using the looped cabasa section—not its loop repetitions—
you just created, click and hold on the bottom right-hand 
corner and adjust its size by dragging the mouse left or right.
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• As you can see, the cabasa sequence and all of it’s loop repe-
titions have changed length. Now play the sequence (and 
loop repetitions) to hear the differences.

• This is a real time function, so why not set up a cycle region 
over this section and resize a few other sequences to see how 
using a portion of some parts, and lengthening others, can 
completely change your arrangement?

This functionality, combined with the looping and copying 
functions is a great creative tool that can help with quick song 
construction.

While experimenting, ensure that any changes you make to 
your sequence lengths are returned to their original state. 

Moving a Sequence
Using the mouse Arrow—the “default” tool—you can move 
sequences onto other tracks, or to other positions within the 
Arrange window.

To illustrate this, we’ll insert a “B” part in front of the groove 
section of the Tutorial song. From there, we’ll transpose this 
newly created B section by a semitone. Before beginning, 
however, we need to create some room in the arrangement to 
accommodate this new section. Here’s how:

• Press the mouse button and rubber-band select all of the 
groove section sequences. 

• Once all are highlighted, grab and drag them eight measures 
(bars) to the right. 

• Use the position display on the Info Line as a reference 
point. It should read “41 1 1 1” when you release the mouse 
button.

As part of your general working method, you should always 
refer to the Info Line when carrying out any of the following 
operations in Logic: move, copy or cut/divide. This will help 
you when editing and arranging, and can aid in avoiding disas-
trous mistakes. See the Undo section below.
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• The Info Line appears at the top of the active edit window, 
whenever you are performing an edit.

Once you’re done, the Arrange area should look like this:

Undo/Redo
Did you make a mistake, like not selecting all of the sequences, 
or perhaps you moved them to the wrong place?

If so, this is a good time to become acquainted with one of the 
most important functions in Logic—the “Undo”. With the 
Undo function, you can always undo the last editing step, should 
things go wrong.

• To use the Undo function, select Edit > Undo. In this 
example, the sequences will be reset to their original posi-
tions and you can now re-attempt your edit. Give it a try, 
even if you got the edit right.

• To reverse the Undo, select Edit > Undo a second time.

It’s important that you make the distinction between what can 
be undone and what can’t. As an example of this—the quantize 
or transpose playback parameters do not actually alter data. 
They simply change the way it is played back. 
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Real-time playback parameters such as these do not involve an 
edit operation, and therefore the Undo function has no effect on 
them. As covered earlier, to undo a playback parameter, simply 
select the affected sequence, and adjust/reset the appropriate 
parameter to its former (or default) value.

Copying Sequences
Following the repositioning of the “groove” section and the 
creation of the blank measures between bars 33 and 41, it’s time 
to insert our “B” part.

• Rather than recording an entirely new section (don’t worry 
we’ll get to that shortly), you will now copy the “B groove” 
section to the empty area created when we moved the 
“groove” section.

• Rubber-band select the sequences of the “B groove” section 
and release the mouse button. 

• Press and hold O and click-hold on any of the selected 
sequences and move the mouse to the right. A copy of all 
selected sequences is now dragged with the mouse pointer. 
(As you’re dragging, you will see a “ghost” outline appear)

• Drag these sequence copies to measure “33 1 1 1” (keep an 
eye on the Info Line) and release the mouse button, where 
they will fill the space left when you moved the “groove” 
section. These newly created sequences will have the names 
of the originals, with the text “*copied” appended to the end 
of the name. 

You can decide whether or not this extension should appear in 
the sequence’s name by opening the Options > Settings > 
Global Preferences dialog. Click in the checkbox to the left of 
the Add Last Edit Function to Sequence Name option if you want a 
description of any edit operations to appear on edited 
sequences. If not, uncheck the box.
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Cutting Sequences
Now, let’s cut the sequences in the section just copied in half, 
using the Scissors tool. Following this, we’ll take a look at the 
Transpose function. 

• Rubber-band select the sequences that were just copied.
• Select the Scissors tool by clicking the scissors symbol in the 

toolbox. This will change the appearance of the mouse 
pointer to that of a pair of scissors.

• Click on one of the selected sequences, while holding the 
mouse button down, and move the mouse left or right. While 
doing so, constantly refer to the information line. 

• When position “37 1 1 1” is reached, release the mouse 
button. This will cut the selected sequences at the begin-
ning of bar 37.

Transposing Sequences
Reselect the Arrow tool, and rubber-band select the sequences 
between measures 37 and 41. We will now transpose this half of 
the newly created “B” section, while leaving the first half in the 
original key. Transposition is the changing of the pitch of a 
MIDI event or sequence by a number of semitones. 

� There are two semitones to every tone. There are twelve notes in the 
Chromatic scale, which use the letters A, B, C, D, E, F and G. The other 
five notes of the Chromatic scale (A#/Bb, C#/Db, D#/Eb, F#/Gb and 
G#/Ab) are named by placing a sharp (#) symbol after a note letter to 
make it one semitone higher, or by placing a flat (b) symbol after a 
note letter to make it one semitone lower. Transposition makes the 
selected note/sequence play back higher (sharp) or lower (flat) in the 
Chromatic scale.

Take a look at the Transpose parameter in the Sequence Param-
eter box. It contains an asterisk (*). This means that the 
selected sequences each have different transposition values. A 
nice feature of Logic is that global adjustments made to 
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multiple sequences work relatively. In other words, this means 
that individual transposition differences (the relative pitches) 
between sequences are maintained, even if all sequences are 
transposed. 

Let’s get on with the job.

• Click on the asterisk that appears alongside the Transpose 
parameter in the Sequence Parameters Box, and with mouse 
button depressed, move the mouse upwards until the value 
+ 1 is displayed.

• Release the mouse button. The passage has now been trans-
posed up a semitone. A value of +2 would transpose by a 
tone.

Move the song position line to measure 37, press play, and 
listen to the result.

You’ll hear that this transposed section doesn’t sound particu-
larly good, and that some fine-tuning is required. Here’s what 
went wrong.

The percussion part will sound somewhat strange. This is 
because you unknowingly transposed the percussion 
sequences, causing the drum note placement to shift. You will 
need to undo the transposition for the percussion tracks. To do 
so, select the drum sequences, and drag the +1 transpose 
setting down, until the line is empty. This indicates no transpo-
sition.

Another problem is that the bass in the copied, and cut B-
section, which we have transposed (between bars 37 and 41) is 
a loop repeat, not a “real” sequence copy. 

Loop repeats are merely pointers to the original sequence and 
can not be transposed. Only a “real” sequence or a copy may be 
transposed. In order to transpose the bass part, you will need to 
change the loop repeat into a real sequence.

• Select the “Bass theme∗ copied” sequence in this section.
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• Choose Functions > Turn Loops to Real Copies. A new 
sequence will now replace the gray loop repeat. 

• Transpose this up one semitone, from −12 to −11 and your 
transposed section, between bars 37 and 41, will now be 
perfect.

Your First Recording
The final MIDI exercise in the Arrange window is to make your 
first recording. Rather than starting a new song from scratch, 
you can play a solo over the C-section. A flute solo is already in 
this section, but it could almost certainly be replaced by a 
better one. 

As you’re new to using Logic, you may not play the solo 
perfectly on your first attempt. To aid you in this regard, plus 
introduce you to a nice Logic feature, we’ll set things up so that 
you can record several “takes” automatically. Once you’ve 
finished recording, you can then select your favorite version of 
the solo.

• Step One: Delete the existing solo. Select the Eraser from 
the toolbox and click on the “flute” sequence, or select the 
sequence with the Arrow tool and press B. It will be 
deleted.

Now set the cycle and record parameters. You’ll probably want 
a bit of a lead in, before the solo starts, to ready yourself for 
playing. We therefore suggest that you extend the cycle 
region’s start point (remember the left corner drag discussed in 
the Cycle Mode section, from page 129 onwards) to be longer 
than the actual recording—i.e. from 23 1 1 1 to 33 1 1 1. This 
will give you two extra measures before section C commences 
at measure 25.
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We’re sure that you don’t want to manually start and stop 
recording with every cycle region repeat and, thankfully, you 
don’t need to. Logic offers the “Autodrop” function which 
engages and disengages Record automatically at predefined 
points (this is often called “Punch In/Out”). To do so:

• Click on the Autodrop button in the Transport window, just 
to the right of the Cycle button—or use the Key Command. 
On doing so, the Bar Ruler will divide into two sections. The 
Autodrop bar appears just below the cycle region. Adjust-
ment to the left and right ends is as per the cycle region.

• Set this to span bars 25 through 33, as shown above.

Song Settings
For the next step, a few settings need to be changed. 

• Open the Options > Settings > Recording Options window.
• Check the Auto Mute in Cycle Record box.

Selecting this setting causes each previous take to be automat-
ically muted when the cycle repeats. This way, you can record 
one passage after another, without being distracted by (i.e. 
hearing) your previous takes. If you would like to hear the 
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metronome while recording, you should enable MIDI Click now. 
The metronome is sent on channel 10—the drum channel—of 
the first available MIDI port. Confirm the changes to the Auto 
Mute in Cycle Record option by clicking the OK button or R.

Let’s Record!
• Select track 8 on the Track List—the one with the small flute 

icon—by clicking on it. Simply selecting the track will “arm” 
it for recording.

• You can now play the flute sound from your MIDI keyboard.
• You can also select other tracks to try them out—Logic auto-

matically addresses the right instrument (MIDITHRU). 
Finally, switch back to track 8.

To have a few practice runs, you can simply start playing the 
cycle and do a little experimenting on the keyboard while 
listening. 

If you find soloing in E major is difficult, you can Transpose the 
MIDITHRU four semitones down (−4) to C major. If you’re 
unfamiliar with musical keys like “C major”, transposing the 
MIDITHRU as suggested will allow you to play any of the white 
notes on your keyboard, and this should sound OK … i.e. “in 
key”.

MIDITHRU always appears in place of a sequence name in the 
Sequence Parameters Box, when no sequence (i.e. anywhere 
on the gray background) is selected in the Arrange window.

Any changes made to the settings of the MIDITHRU, in the 
Sequence Parameters box, will be applied to any subsequently 
recorded sequences. 

• When you’re confident enough to record the solo, begin 
recording by clicking * on the numeric keypad, or by 
pressing the Record button on the Transport bar. As usual, 
we recommend the use of the Key Command.
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The count-in of two measures will play through, and the cycle 
region will begin to play repeatedly. You can play over the first 
two measures of the cycle region, until Logic reaches the left 
Autodrop point (measure 25) in the song. Anything you play 
from measure 25 onwards will be recorded. At measure 33, 
recording will automatically stop, and a sequence will be 
created on the selected track.

• Allow Logic to continue running. After reaching the right 
cycle region boundary (measure 33), the SPL will jump back 
to the left cycle region boundary (measure 23). At measure 
25, the next recording will begin.

Allow the section to repeat, recording on each pass, until you 
feel that you have one or two good “takes”. Logic will create a 
new track automatically, for every cycle repeat, and will move 
previously recorded tracks down the list.

• Using the Mute tool, you can now audition the individual 
takes.

• Once you’ve decided on a take, simply delete the unwanted 
takes by clicking on the corresponding track(s) in the track 
column. Once selected, use the Functions > Track > Delete 
Track menu function repeatedly, until all unwanted tracks 
are removed.

• If you accidentally delete the good take, don’t forget the 
Undo function.

Saving the Song
Here’s how to save the Tutorial song, with your new solo:

• Choose File > Save As…, and enter a new name—i.e. NOT 
“tutorial”—for the song to be “saved as” in the ensuing file 
dialog.

Reload the original Tutorial song for these additional exercises.
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3.7 MIDI Event Editing
This section briefly discusses the use of Logic’s various MIDI 
editing windows.

The Event List Editor
This editor shows all data contained within a selected sequence 
as an alphanumerical (a collection of numbers and letters) 
listing.

• Open the Event List for the “flute” sequence, via the 
Windows > Event List menu or by pressing C2.

The Status column displays the event type. The “flute” 
sequence contains both note and other types of events. You can 
hide/show specific event types by using the filter buttons to the 
left of the list.

Click on each of the buttons, except for the one showing a 
slider at the bottom of its range, so that they turn dark gray.

The Event List will now only display control change events.

• Click on each button, re-enabling the display of all events. 
Note that as you do this, events of that type will re-appear in 
the list.

We will now insert two program change messages into the solo, 
changing from a flute sound in the first half, to a synthesizer 
sound in the second. 
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� A program change message is part of the MIDI language. It tells a 
synthesizer or soundcard to select a particular sound or “patch”—like 
a flute or synthesizer sound—from a particular memory location. If 
you think about it in a different way, this is like telling your computer 
to select a particular file for copying or editing. Remember that MIDI 
synthesizers and sound cards are really computers in disguise, so a 
program change is a lot like a “select this file” now message.

As the solo begins at measure 25, we’ll place the first program 
change for the flute at measure 25.

• Move the song position line to bar 25 1 1 1 in the Arrange 
window. The SPL is used to determine the insert position 
for the program change event (message).

• Select the Pencil tool from the Event List’s toolbox, and click 
on the program change button shown to the right.

A program change event will be inserted at position 25 1 1 1. 

The program change number is found in the Val column. Set 
this to 73 if you own a GM tone generator. If you are not using 
a GM tone generator, find a program change number that 
selects a flute (or flute-like) sound.

Now, we’ll insert a second program change:

• Move the song position line to position 29 1 1 1, and click on 
the Program Change button. 

Choose a Val of 87 if using a GM tone generator, or a program 
change that selects a synthesizer solo sound, with non-GM 
devices.

• Select the Arrow tool from the Event List’s toolbox and use 
the buttons to hide all event types, except program change 
events.

Your event list should look like the following:
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Graphik

Move the SPL to the beginning of the solo sequence (position 
25 1 1 1) and press Play. You’ll hear the solo switch sounds 
halfway through the sequence.

Congratulations, you’ve mastered the insertion of program 
change events. The Event List is very useful for microscopic 
changes to your sequences. Make sure you read the chapter on 
it in the Reference manual.

About Program Changes
It should be noted that the Event List procedure outlined 
above physically writes the program change message to a MIDI 
sequence object on a track. The advantage of this method is 
that if a program change message is written to a sequence (or 
several sequences) at the beginning of (or throughout) your 
song file, then this information will be sent to your MIDI 
module or soundcard every time you load and play the song. 
This guarantees that the right sounds will be sent every time, 
even if the song is saved as a MIDI file, and played on another 
sequencer or SMF-player (Standard MIDI File Player).

As Logic is full of options which allow you to work the way you 
prefer … it is also possible to send a program change event by 
clicking the checkbox beside the Prg entry and inserting a 
number (or scrolling through a list, with the mouse button held 
down) from the Track Parameters box in the Arrange window. 
You can also do the same from within the Track Mixer window 
via the top panel in each MIDI fader.

The problem with the latter two methods is that the Program 
Change message is not written anywhere. Even though the 
settings you make using either method are saved with your 
song file, there’s no guarantee that your MIDI module or 
soundcard will actually “see” these messages.
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If you find that you’ve loaded a song and your sounds aren’t 
quite right, you should enable the Send Used Instr. MIDI 
Settings after loading checkbox in the Options > Settings > 
MIDI Options, and resave your song. Note that this must be 
done for all previously created songs. 

If done in your Autoload song, which forms the basis of all of 
your future work, this will become a default preference. Once 
done with the Introduction Manual, don’t forget to set this in 
your Autoload song.

The Matrix Editor
Although it looks very different, the Matrix editor is quite 
similar to the Arrange window. Unlike the Arrange window—
note events, rather than sequences—are displayed as horizontal 
bars in the Matrix editor. Editing, as you’ll see, is quite similar.

The “Strings C” sequence displayed in the Matrix window.

• Select the “Strings C” sequence in the Arrange window and 
open the Matrix window via the Windows > Matrix menu.

The keyboard along the left edge of the Matrix window indi-
cates the pitch of the notes/key played in the display. A chord is 
represented by a group of overlapping bars. You can easily see 
that the note lengths of the second chord are unequal. In our 
example, we’ve included a wrong note in the 4th chord, which 
we’ll get you to fix.
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Take a look at this sequence in the Event List as well, by 
choosing Windows > Open Event List or C2. 

As you can see, picking up these inconsistencies in the Event 
List isn’t quite as easy as with the Matrix editor. Close the 
Event List window when you’re done.

When making changes in the Matrix—or any other editor in 
Logic—you can hear the changes you make in real-time. This is 
achieved by activating the MIDI Out button found towards the 
top left, in each of the editor windows. We suggest that you acti-
vate this button by clicking on it. It will be illuminated when 
active.

Changing Note Lengths in the Matrix Editor
• Highlight all notes in the first chord by rubber-band 

selecting them.
• Now, grab the lower right corner of one of the selected notes, 

and drag it to measure 26, so that the end of the bar (i.e. note) 
connects to the start of the next chord. Release the mouse 
button.

Any change made to the length of one note, will affect all other 
selected notes equally in the Matrix editor. i.e.—they will 
retain their relative length differences.

It is possible to override this relative length difference and 
force all notes to have the same end point by pressing S while 
dragging the right corner of selected note events. This method 
will even work on note events selected across multiple bars.

• Repeat the process, to lengthen each chord so that it meets 
the beginning of the next. This will create a legato effect 
(where the end of one note meets the beginning of the next) 
on playback. Increase the zoom level to aid in the editing of 
the events.

You can also adjust the start point of any selected note(s) by 
click-hold and dragging the bottom left corner. Note that the 
S function used to align the end of notes does not work on the 
beginning of notes.
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Changing Note Event Pitches in the Matrix Editor
• Select the Arrow tool from the Toolbox.
• Select any note event, or group of notes, by rubber-band 

selecting them.
• Grab the note(s) in the middle and drag it/them up or down. 

As you do so, you will hear the pitch change. 
• When the desired pitch is reached, release the mouse 

button.

Deleting Note Events in the Matrix Editor
Now it’s time to get rid of that wrong note. 

• Select the Eraser from the toolbox, and click on the short 
note at position 28 1 1 1. The note will disappear.

As an alternative method for deletion of the note—or any other 
selected event—simply press B.

Changing Note Velocities in the Matrix Editor
Velocities (i.e. how fast the note was hit—and usually how loud 
it is) of notes are indicated by color—with “hot” colors, such as 
reds used for higher values and “cool” colors, such as blues 
used for lower velocities. A further indicator of velocities is the 
line within the note event “bar”. Velocities of selected note 
events can be adjusted with the Velocity tool. To do so;

• Select the Velocity tool from the toolbox, as shown.
• Click-hold on the top note in any of the chords and drag the 

mouse up and down. As you do so, you’ll note that the color 
of the selected note event changes and the line within the 
note changes length. Ensure that the velocity of the selected 
note is different to that of the other notes in the chord.

• Release the mouse button and—with the Velocity tool still 
selected—rubber-band select all notes in a chord. Once all 
are selected, release the mouse button.
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• Click-hold on any of the selected notes and drag the mouse 
up and down. As you do so, you’ll see that the velocity of the 
note that you edited individually retains it’s relative distance 
(level) from the other selected events. As you drag the 
mouse up and down, you’ll discover that when maximum or 
minimum values are reached for any of the selected events, 
no further increase or decrease in value is possible.

Using HyperDraw in the Matrix Editor
In all versions of Logic, you can make volume and panning 
changes using the HyperDraw function, within the Matrix and 
Score editors. The Platinum and Gold versions also allow the 
“drawing” of controller curves for other types of continuous 
controllers.

Matrix window with HyperDraw volume curve.

To access the HyperDraw function within the Matrix editor, 
select View > HyperDraw > Volume (or Pan or other controller). 

As an alternative method, you can press @ to show the Volume 
Hyperdraw. £ will toggle back to the standard Matrix editor 
view.

Congratulations, you’ve now completed the edits for the strings 
sequence. Nearly all sequences in the Tutorial song contain 
slight mistakes, which you can easily repair in the Matrix editor. 
Select one or two of the other sequences and edit them as you 
did with the String part.
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You will probably notice a big difference when optimizing the 
lengths of notes in the bass sequences.

The Hyper Editor 
This editor is useful as a drum “grid” editor, and also for graph-
ical controller “drawing”. When used for drum editing, it is 
somewhat similar to the use of pattern-based drum machines of 
yesteryear.

The HyperEdit window

To insert note or controller information:

• Select the Pencil tool and click, or click and drag horizontally 
with your mouse. Higher note velocities/controller values 
appear as taller vertical bars.

To adjust existing note or controller information:

• Click on an individual event and drag vertically with your 
mouse (this can be done with the Pencil or Arrow tools). 
Alternately, you can “draw” over the existing curve.

• Select the “groove basic” sequence, and open the 
HyperEdit window via the Windows menu, or by pressing 
the C5 Key Command and experiment with these tech-
niques, making use of each of the tools.

• While in the HyperEdit window, click hold on the MIDI 
Controls flip menu and select GM Drum Kit. You’ll see a 
very different view of the “groove basic” drum part. Once 
again, please experiment with the various tools on the indi-
vidual parts.
153
Introduction Manual
Version 5



Chapter 3
Using Logic

Logic 5 intro en.book  Page 154  Monday, October 28, 2002  9:34 PM
The Transform Window
In the last chapter, we briefly looked at the Transform objects 
available in the Environment. The Transform window differs 
from the Environment Transformers in the following ways.

• It is not a realtime process
• You can define Conditions by length and position.

The Transform window is a very powerful editor that can be 
customized to build your own preset “transform” operations. It 
can be used for dramatic MIDI data changes, or for subtle alter-
ations. As an example of the latter, it could be used to reduce 
the amount of filter modulation from a value ranging between 
97 and 105, by a fixed percentage. While this type of change 
could be performed in other editors, it would need to be done 
on each individual modulation event. The Transform window 
allows you to quickly achieve the same result on multiple 
events.

To best illustrate how the Transform window can be used, 
please select the “Piano theme 1” sequence.

• Create a a cycle region from bar 9 to bar 17 using the tech-
niques you learned earlier.

• Solo the “Piano theme 1” sequence
• Open the Transform window via the Windows menu or by 

pressing C4.
• Select the Reverse Pitch preset from the flip menu, to the top 

left of the Transform window.
• Press the Play button on the Transport and listen through a 

couple of times.
• While the sequence is cycling, press the Select and Operate 

button and listen to the results.
• Use the Undo function to return the sequence to it’s former 

state.
• Please experiment with the other presets and buttons, 

ensuring that you Undo between each process.
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The Notation (Score) Editor
A detailed Scoring Tutorial is available in electronic form on 
your Logic program CD-ROM. This tutorial is accompanied by 
additional song material, also located on the CD-ROM.

3.8 Audio Tracks and Regions
Logic allows you to digitally record acoustic, electric and elec-
tronic instruments or vocal performances into your songs, and 
to process these audio recordings through Logic’s built-in real-
time effects. As with MIDI tracks, audio recordings are 
displayed in the Arrange window on an Audio Track. 

These audio recordings are referred to as Audio regions in the 
Arrange window. Audio regions are actually visible portions of 
audio files. When you cut or resize an audio region in the 
Arrange window, the audio file itself is not cut or resized. The 
“region” that you see is a visual representation of a part of the 
audio file, and changes that you make to it in the Arrange 
window simply instruct Logic on how to play the audio file. In 
other words, the audio regions are simply “pointers” to the 
underlying audio file, and the reason they look like the MIDI 
sequences (with a waveform display when zoomed) is to make 
things easy to deal with. After all, you’ve spent the time 
learning how to deal with MIDI sequences, so it is reasonable 
to assume that the handling of audio regions should be similar. 
As it happens, they are!

It should be noted, however, that although the handling of 
audio regions and MIDI sequences is similar in Logic, it is not 
exactly the same. As a result, the editing and parameter options 
available for MIDI and audio tracks is slightly different.

Reload the Tutorial Song for more exercises.
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Creating Audio Tracks
We will now create an audio track in the Arrange window, to 
which a drum loop will be added.

• Select the “Piano” track in the Track List, and create an 
audio track in the Arrange window via the Functions > Track 
> Create menu option, or by pressing CE. In the Arrange 
window, a new track will appear below the piano track. 

• Click-hold on the “CHA 1” entry in the Track List, and a 
hierarchical menu will open.

• Browse to Audio > Audio Track > Audio 1, and release the 
mouse button. This will assign the track to the first Audio 
channel.

You can rename this audio track by clicking on Audio 1 in the 
Track parameters box. It may make more sense to you if you 
were to name it “Drums”, for example. This name will be 
reflected in the Track Mixer, making it easier to identify when 
in this window. You can not rename the MIDI tracks associated 
with Multi-Instruments in the same fashion. Multi-Instrument 
MIDI track/channel names are defined in the Environment 
window.

It should be noted that an audio object must exist within the 
Environment (on the Audio layer) to allow its selection from 
the hierarchical flip menu in the Track List. If you require an 
audio track and no audio objects exist in a Logic song, you need 
to create them as per the instructions in the Environment 
chapter. Normally, when working with songs based on your 
Autoload song, this won’t occur, but on occasion, you may 
download or share song files with other users, and may find that 
no audio objects exist.

Track Mixer with Audio Channels
Audio and MIDI tracks can be controlled in a number of ways 
in Logic. The quickest method for level and pan control is via 
the Track Mixer, accessible via the Windows > Open Track 
Mixer menu or Cm. 
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The Track Mixer horizontally reflects the track order as 
displayed—from top to bottom—in the Arrange window’s 
Track List. The viewing of different object classes can be 
changed in the Track Mixer window.

� The updating of the Track Mixer channels is entirely automatic, so as 
you add or delete tracks from the Arrange window’s Track List, the 
Track Mixer will show or hide the corresponding MIDI or audio 
channel fader(s).

Once the Track Mixer is launched, you should see a new 
channel named “Audio 1” or “Drums” (dependent on how you 
named the track). 

If you can’t see any audio objects, click on the Global button, to 
the top left of the Track Mixer.

The number of the corresponding track in the Arrange window 
is shown below each “fader”, or “channel strip”. Four further 
channel strips (Audio 2, Bus 1 and 2 and Master) appear to the 
right of the “Audio 1” or “Drums” channel. The two “Bus” 
channels are used as effects returns. The stereo “Master” fader 
acts as a master volume control for all audio channels. 

• Change the audio channel from mono to stereo operation by 
clicking the button on the lower left corner of the channel 
strip. This is necessary, because we are going to import a 
stereo audio file.

• As a rule, you should use stereo tracks when importing (or 
recording) stereo audio files. Obviously, the same applies to 
mono files and mono tracks.

• Switch back to the Arrange window by closing the Track 
Mixer window.

The Audio layer of the Environment can also be used for audio 
mixing duties. It can be accessed from the Environment 
window, or by selecting the Audio > Audio Mixer menu option.
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Changing the Track Mixer View
To the left of the Track Mixer window, you will see a collection 
of buttons, as shown. These buttons will toggle (hide/show) the 
display of particular classes of channel faders. 

Global—Toggles the display between channels which corre-
spond to those that exist in the Arrange window’s Track List, 
and all MIDI Instrument and Audio objects which exist in the 
Environment. 

When the Global button is inactive (gray) it will display the 
Arrange window’s Track List channels. The other buttons can 
be clicked individually to display all channels of the selected 
class which exist in the Arrange window’s Track List. Multiple 
classes can be selected for display in the Track Mixer by 
holding the C key while clicking on the individual buttons. 

When the Global button is active (green) it will display all MIDI 
Instrument and Audio objects which exist in the Environment. 
The other buttons can be clicked individually to display all 
channels of the selected class which exist in the Environment. 
Multiple classes can be selected for display in the Track Mixer 
by holding C while clicking on the individual buttons. 

Please try the various Track Mixer display modes with the 
Tutorial song to get a feel for how this view functionality works.

It should be noted that the display of additional classes of 
channel faders requires that the underlying objects actually 
exist in the Environment. If they do not, a This song does not 
contain this type of object error message will be displayed. You will 
need to create these objects as per the instructions in the Envi-
ronment chapter.
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Importing an Audio File
Now, let’s import an existing audio recording of a drum loop 
into the Tutorial song.

• Select the Pencil tool, and click at measure 5 of the audio 
track. Logic will now ask for the files’ location via the stan-
dard operating system file dialog.

• Browse to the drive and folder that contains the tutorial 
drum Loop—“Atmo-Drums.wav”. 

• Double-click on this file and it will appear in the Arrange 
window.

• As an alternative method, you can resize Logic. With both 
your desktop and Logic visible, you can browse to the Logic 
program folder and simply drag ’n drop the “Atmo-
Drums.wav” file to the desired location in the Arrange 
window.

If you enlarge the display through 
use of the zoom bars or telescopes, 
you will see a waveform display in 
the audio sequence that was just 
imported. The audio file name is 
displayed above this waveform overview. A symbol indicating 
whether the file is mono or stereo will be shown at the end of 
the file name. Stereo files are indicated by two interlocked 
rings.

Start playback from measure 5, using one of the navigation 
techniques learned earlier. At this point, you should be hearing 
the audio file and will notice that the speed of the MIDI tracks 
and the drum loop are out of time with each other. We can fix 
this by adjusting the speed of the song.
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Sample Editor
Open the Sample Editor by double-clicking on the drum loop 
region in the Arrange window. For precise editing of audio, this 
is the window to use. You’ll notice that the starting point of the 
drum loop’s waveform is not exactly aligned the first beat of 
measure 5.

• Enlarge the Sample editor display with the zoom bars or 
telescopes until you can see the waveform startpoint 
precisely.

• Move the start playback indicator—the small S icon below 
the waveform—so that it is perfectly aligned with the begin-
ning of the waveform, as shown.

• Now press the button featuring the loudspeaker symbol, to 
listen to the audio file.

The startpoint should now be correct, but the audio region’s 
end point must still be corrected. It must be moved forward (to 
the left) until the drum part loops smoothly. The best way to 
check this is by engaging “cycle” mode in the Sample editor. 
Do so by pressing the button shown.

• Scroll to the end of the drum loop and move the end point 
back (i.e. to the left). To do so, drag the end playback indi-
cator—the small E icon below the waveform—until there are 
exactly two measures between the start and end points.
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You should optimize the beginning and end points until the 
loop actually cycles smoothly. It should be noted that this can 
be done as the audio file is actually playing, which makes 
setting loop boundaries much easier. Listen to the loop and 
adjust these points until it cycles perfectly. This is very impor-
tant, as the loop’s length will be used to adapt the tempo of the 
song to the audio file.

• Once you’re done, disengage the speaker button (by clicking 
on it again) and return to the Arrange window by closing the 
Sample Edit window.

• In the Transport Bar (or Bar Ruler), set the locator points to 
cycle between measures 5 1 1 1 and 7 1 1 1.

• Select Options > Tempo > Adjust Tempo using object length 
& Locators, or press t.

• At this point, you will be asked whether the tempo for the 
entire song (global) should be changed to match the audio 
file, or whether a tempo change should be inserted at the left 
cycle point, 5 1 1 1. If global is selected, your arrangement 
should look similar to this:

• Press Play. You’ll notice that the song speed is adapted 
precisely to the drum loop, which you just defined using the 
locator points. The drum loop is two measures long. The 
length and position of the audio region (audio sequence) 
now corresponds exactly to the start and end point changes 
made in the Sample Editor.

You can move, cut, and copy the audio region in the Arrange 
window, just as with MIDI sequences. Please experiment with 
this, making use of the Undo function as you go.
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As mentioned earlier, despite the similarities, the handling of 
MIDI and audio is slightly different. As such, the Matrix and 
Score editors, plus a number of MIDI-specific functions are not 
applicable to audio regions.

The Audio Window
Put simply, the Audio window allows to you to manage all audio 
files used in the open song. Press Cø to open this window or 
browse to it via the Audio > Audio Window menu option.

The Anchor
The changes you made to the “Atmo-Drums.wav” file in the 
Sample Editor have aligned the audio region in the Arrange 
window to position 5 1 1 1. While you can move the audio 
region directly in the Arrange window, by dragging it or using 
the Delay parameter in the region’s Parameter Box, you can also 
make use of the Audio window to adjust the Anchor point.

The Anchor point of each audio file has a direct impact on the 
audio region(s) which point to the file. To illustrate this, posi-
tion your windows in a way that allows you to view the “Atmo-
Drums.wav” region in the Arrange window and the “Atmo-
Drums.wav” file in the Audio window. 

• Select the “Atmo-Drums.wav” region in the Arrange 
window.

• Click-hold on the up arrow beneath the “Atmo-Drums” 
waveform overview in the Audio window, and drag it to the 
right. 

• Release the mouse button around the center of the wave-
form graphic while keeping an eye on the audio region in the 
Arrange window. As you can see, the entire region was 
moved to the left.

• Select Edit > Undo to reverse the process.
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In moving the Anchor point, you have adjusted the audio 
region’s temporal (time) reference point. The Anchor can be 
used to quickly select the “downbeat”, for example, in a looped 
drum region in your arrangement.

The Anchor point can not be positioned before or after the 
Sample Start and End points, respectively.

Quick and Dirty Audio Regions
You can define region start and end points in either the Audio 
window, or directly in the Arrange window. Either method is 
useful for roughly defining a region’s size. If you need precise 
control over the audio region/audio file start and end points (for 
loops etc.), please make use of the Sample Edit window. 

Before commencing this exercise, please ensure that both the 
Audio and Arrange windows are visible.

• In the Audio window, select the tool which looks like a hand 
with an extended index finger.

• Click-hold on the left or right hand end of the “box” which 
encompasses the “Atmo-Drums” waveform overview, and 
drag horizontally. As you do so, the “box” will increase/
decrease in size. 

• Once the desired location has been reached, release the 
mouse button. While doing so, keep an eye on the audio 
region in the Arrange window.

• Now, in the Arrange window, select the Arrow tool, and grab 
either the left or right hand end of the audio region. As you 
do so, the cursor is shown as a hand with an extended index 
finger, and the region will increase/decrease in size. 

• Once the desired location has been reached, release the 
mouse button. While doing so, keep an eye on the audio file 
overview in the Audio window.

If the Sample Edit window was also opened, you would see that 
the adjustments made in the Audio window adjust the Sample 
Start and End points. Adjustments made in the Arrange 
window, however, do not alter the Sample Start and End points. 
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The reason for this is that the Arrange window only deals with 
audio regions, not audio files. The Sample Edit and Audio 
windows, on the other hand, deal with the underlying audio files 
on which the audio regions are based.

Audio File Menu
This menu provides a range of file handling tools, including 
delete, backup, conversion and more. These tools can aid you 
in “housekeeping” tasks for all of the files used in the song. 
Please refer to the Logic Reference manual for detailed infor-
mation on each function.

The Digital Factory
The Digital Factory is a collection of audio processing tools 
which can be used for a number of tasks, including pitch 
shifting and time stretching of audio material. You may follow 
this section now, or return to it at a later stage.

• Reopen the Sample Editor by double-clicking on the drum 
loop region in the Arrange window.

• Click on the Factory menu and take a look at the various 
options, one by one. The Reference manual contains 
detailed information and examples on the use of these tools, 
which you should consult while doing so.

• Please feel free to experiment with the various processes, 
making use of the Undo function as you work through them.

Making Your Own Audio Recordings
First, connect the sound source—a mixer, CD player, or micro-
phone, for example—to the audio input(s) of your system. 
Create a new audio track, using the method described in the 
Creating Audio Tracks section, from page 156 onwards.
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Arming Tracks
Unlike MIDI tracks, audio tracks must be “armed” before they 
can be recorded to, just as the tracks on a tape recorder must 
first be armed. There is a small button marked with an R to the 
left of each audio track in the Track List. Clicking on this icon 
prepares the audio track for recording. The R button will turn 
red, indicating that the track is armed. You can also click on the 
REC button on an audio channel in the Track Mixer, in order to 
arm the appropriate audio fader/track.

Setting a Record Path
Unless you’ve already configured your audio path, the 
following dialog will open. Key Command a.

Click on Set for your audio device(s), and in the dialogue 
window that appears, select the name of the audio file (by 
default, this is “Audio”) and path—i.e. hard disk location—for 
your recording(s).

Global and Song Record Paths
If a Global Recording Path is set, you do not need to repeat this 
procedure before every recording. Subsequent recordings will 
automatically be assigned the same name, with a number 
appended to the end of each file created. To do so, click-hold in 
the panel above the Set button. This will open a flip menu 
where you can select a Global or Song Recording Path. Please 
select the Global Recording Path, for now.
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As you work with Logic, you will generate a great deal of audio 
data. To aid you in managing this data, we suggest that you 
make use of the Song Recording Path option, and follow the tip 
below.

It is recommended that you set up a different file name (and 
folder) for each new song you create, so that the song title and 
the audio files used in it are the same. As an example—The 
“rocksteady” song should be in the “rocksteady” folder. Your 
default audio file name should also be “rocksteady”, and be Set 
to record into this folder.

The advantage of working this way is that all songs and audio 
files associated with a particular project are contained in one 
place, and have an associated (or the same) name. This makes 
things much easier to find, if returning to a project after a period 
of time. It is also beneficial for archiving purposes.

The Global Recording Path is saved with the Preferences, and 
will be used as the “default” path the next time Logic is 
launched. 

The Song Recording Path is saved with the Song file, and will 
be used as the “default” path the next time the specific Song 
file is loaded. 

Using the Audio Object Name
This option in the Audio Record Path dialog allows you to make 
use of Logic’s ability to rename audio objects, as discussed in 
the Creating Audio Tracks section, from page 156 onwards. Such 
object names will then be used for audio files. As an example, if 
an audio object was named “Drums”, then all audio files 
recorded to that channel would automatically be named 
“Drums”, “Drums1” a.s.o. This facility becomes even more 
useful when used in conjunction with the Song Recording Path 
option.
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Stereo Recording
To make a stereo recording, you must first configure the 
selected track’s audio fader as stereo in the Track Mixer, or 
Audio layer in the Environment. 

• Open the Track Mixer and click on the symbol to the left of 
the REC switch, on the highlighted audio fader. This will toggle 
the track between stereo and mono. 

The symbol on the button indicates the current status as 
follows: A single circle—mono. A pair of interlocked circles—
stereo. The level meter will also divide into two discrete 
meters, when an audio fader is set for stereo operation. While in 
the Track Mixer, note that there is now an additional “audio” 
fader. As you create new tracks—MIDI or Audio—in the 
Arrange window’s Track List, a new corresponding fader will be 
created in the Track Mixer.

It should be noted that the underlying objects, on which the 
Track Mixer channels are based, must first exist in the Environ-
ment window. Also of note are the different view options avail-
able to the Track Mixer, as discussed in the Changing the Track 
Mixer View section, from page 158 onwards.

• Once you’re done with setting the stereo/mono status of the 
audio channel, close the Track Mixer.

Levels
As soon as you arm an audio track, you will hear any signal 
being sent to the audio inputs of your system. The audio track’s 
fader in the Track Mixer controls the level of the monitored 
signal—i.e. what you’re hearing. 

The fader always controls the playback level, not the recording 
level. Recording levels must be set externally—i.e. on your 
mixer, or at the original sound source. 
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Care must be taken when setting input levels, as digital audio 
will “clip” when overloaded. Clipping results in particularly 
harsh metallic distortion, so unless you have a penchant for 
heavier musical styles, we don’t recommend overloading the 
inputs.

It’s often quite useful to have the Windows mixer utility open 
while recording into Logic. This allows you to set an input level 
for your audio recordings which doesn’t overload Logic. 

Starting to Record
• Start recording by pressing the Record button on the Trans-

port Bar, or by pressing * on the numeric keypad. You will 
notice that a waveform is drawn, in realtime, in the Arrange 
window during recording.

Keep an eye on the level meter on the audio faders. In the 
event that the clip indicator (top, red LED) lights up, you will 
need to record again, using a lower level. To avoid having to 
watch the level meter constantly; the overload indicator 
remains lit until it is clicked. If your recording level was too 
high, ensure that you click on the overload indicator to reset it.

• Once you’ve finished recording, press Stop on the Transport 
Bar or by pressing = on the numeric keypad.

Congratulations, you’ve recorded your first audio file.

Please do not forget to disarm the track(s) after recording has 
finished. Do this by clicking on the illuminated (red) R button 
which will then turn gray. If the track is not disarmed, you will 
not be able to listen to the audio region on this track.
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3.9 Mixer Functions
The Track Mixer (and the Audio layer in the Environment) can 
be fully automated. This automation allows a full “flying-
fader” mixdown of all audio channels, master faders, busses, 
audio instruments and effects. This section covers the termi-
nology and use of the various parts of the Track Mixer, and a 
brief look at the mix automation facilities available in this 
window. 

Logic’s Arrange window features an enhanced track-based 
automation system, which is covered in the next chapter. We 
strongly recommend the use of this Track Automation system 
over the use of the older methods of previous versions. 

Automatic Mixing
• Open the Track Mixer and the Arrange window. Resize both 

windows if necessary, so that you can see the Track List and 
a few of the faders in the Track Mixer.

• Select View > Track Automation. The Arrange window will 
zoom in vertically. 

• Now click on any track in the Track List—MIDI or audio—
and pay attention to the Track Mixer window. You will see 
that as you select a track in the Track List, the corresponding 
fader in the Track Mixer will be outlined in red.

• Select the Touch option by click-holding on the panel above 
the Pan knob on the outlined fader.

• To record changes to the volume, press Play on the Transport 
Bar (or use the Key Command) and move the “highlighted” 
fader up and down in the Track Mixer. As you do so, you’ll 
see a curved line being created on a gray “bar” in the Arrange 
window. Once done, press Stop.
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• Return to the beginning of the newly recorded automation 
track, using any of the navigation methods you learned 
earlier, and press Play. Note that the fader on the Track 
Mixer is now replaying your recorded automation move-
ments. This automatic playback of changes to the Track 
Mixer’s channel parameters is often referred to as “flying 
fader” automation.

• The same automation method can be used for additional 
channels, pan knob position and also for the EQ parameters 
on audio faders. This also applies to plug-in automation, 
which we’ll cover shortly.

Using the Equalizers
Equalization (EQ) is the process of boosting or cutting certain 
frequencies in an audio signal. EQ is used to make individual 
instruments or frequencies stand out (or the reverse) in an 
overall mix. Each audio channel in Logic features a number of 
parametric (or other) EQ’s. All EQ parameters can be auto-
mated.

The desired EQ type can be selected from the Thru flip menu, 
found in the EQ section at the top of each audio channel strip. A 
stereo or mono EQ will be inserted automatically, dependent 
on the current status of the audio channel strip. The ON button 
is used to bypass or activate the EQ. The other parameter 
panels are described below:

• Hz: This control determines the center frequency of the 
band in Hz or kHz values.

• dB: This parameter determines the extent to which you can 
cut or boost a frequency band. At a value of 0.0 the EQ has 
no effect.

• Q: To minimize the EQ’s effect on the rest of the sound, you 
can limit the bandwidth of frequencies around the center 
frequency value determined by the Hz parameter. The Q 
parameter determines this bandwidth. The greater the Q 
parameter value is, the narrower the filter band.

• Select the drum loop in the Arrange window.
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• In the Transport Bar (or Bar Ruler), set the locator points to 
cycle between measures 5 1 1 1 and 7 1 1 1.

• Solo the drum loop.
• Launch the Track Mixer from the Windows menu or Cm.
• Activate the EQ on the highlighted Audio channel by click 

holding on the Thru panel at the top of the fader.
• Experiment with different values in each of the parameter 

fields described above.
• Insert additional EQ’s by click-holding on the other Thru 

panels, and try to isolate the kick (bass) drum, hi-hats and 
clap sounds, through careful use of the Q and Hz values. If 
possible, reduce/increase the gain (dB) to hear the individual 
parts of the loop in isolation.

Inserting Audio Effects
The internal audio effects of Logic can be inserted into the 
individual audio channels—regardless of type—by selecting 
the desired effect from a flip menu, accessible via the Insert 
“slot”(s) found on each audio channel strip. To insert an effect:

• Open the Track Mixer by pressing Cm, or launch the 
Audio layer of the Environment by double clicking on the 
audio track you just recorded in the Arrange window’s Track 
List.

• Once either “mixing surface” is open, click hold on any of 
the Insert slots on the audio channel, and a hierarchical flip 
menu will open, displaying the various effects, grouped in 
categories. Usually, you would insert effects from the top slot 
down.

• Highlight the category, and then the effect you wish to use 
in the flip menu, and release the mouse button. The Insert 
slot will turn blue, with the name of the selected effect 
displayed. 

• To remove a plug-in from an Insert slot, click hold on the 
desired slot and select No Effect from the flip menu.
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How Effects are Grouped
Logic “groups” effects as follows:

• Audio Channel Type—either Stereo, Mono/Stereo or Mono.
Stereo: Stereo in, stereo out (True stereo). Both input signals 
are processed separately, so the stereo qualities of the signal 
remain unchanged—this is important for summed or stereo 
bus signals used as inserts.
Mono/Stereo: Mono in/Stereo out. For use with mono signals 
only, but the effect output is stereo. Commonly used on the 
following mono signals: Chorus for bass, Reverb for lead 
vocal.
Mono: Mono in, mono out. Should only be used on mono 
signals. Typical applications are for EQ’s or dynamics 
processing (Kick, Snare, Bass).

• By API—Logic, VST, DirectShow. Grouping of effects in this 
fashion makes the selection of effects simpler.

• By effect definition—Dynamic, Modulation, Reverb, Filter 
etc. The effect definition groups effects of a particular type 
together. As an example, Chorus, Flanging and Phasing are 
different types of Modulation effect. This only applies to 
“native” effects.

Logic automatically limits the available effect types shown in 
the plug-in flip menus to match the audio objects signal I/O 
settings. In other words, if an audio object is mono, then only 
mono (and mono/stereo) effects will be available in the plug-in 
flip menu. This also applies to stereo audio objects with only 
stereo plug-ins being available. It is possible to override these 
settings by pressing and holding ç before selecting the plug-
in flip menu on an audio object. 

If you choose to use a plug-in which does not match the audio 
objects’ signal I/O flow, Logic will be forced to do a data stream 
conversion, which places a greater strain on the CPU. This 
translates to fewer simultaneous effects, so keep this in mind.
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The Plug-in Window
You can edit the effect’s parameters by double-clicking on the 
(active) Insert slot, which will launch the plug-in window. Many 
of Logic’s effects feature an enhanced graphical interface. 

Please refer to the Reference Manual for specific information 
on the individual effects, their parameters and their use. 

Effects Settings
Settings are used to store all parameter adjustments you make 
in the plug-in window. Every Logic and third-party plug-in 
allows the storage and recall of Settings. Effects Settings are 
accessible by click holding on the Settings flip menu (the 
downwards-pointing arrow) beside the Bypass button in the 
plug-in window. 

• Within the Settings flip menu you can load an effects 
“preset” via the Load Setting option. 

• To save your own personalized effects settings, adjust the 
parameters of the open plug-in window by click holding on 
any parameter, and moving the sliders/knobs. Once your 
parameter adjustments have been made, click hold on the 
Settings flip menu and select Save Setting. In the ensuing 
operating system file dialog window, type in an appropriate 
name for your Setting, and press the Save button. Please give 
this a try.

• You can also use the Settings flip menu to copy and paste 
parameters between Settings.

� Logic automatically creates a folder called “Plug-In Settings” when 
first installed. Within this folder, a separate folder for each effect is 
created. When you use the save/load preset functions in the Settings 
flip menu, Logic will automatically save/load the Setting file to/from 
the corresponding effect folder. As each effect Setting is stored in its 
own associated folder, you should find it easy to manage hundreds of 
presets. This feature is applicable to all Logic and third-party effects.

It is recommended that you do not attempt to change the folder 
structure within the “Plug-In Settings” folder.
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Reassigning Plug-in Windows
Rather than opening a separate plug-in window for every effect 
on every channel—which would involve a lot of effort and 
require massive amounts of screen space—you can reassign any 
open plug-in window in two different ways, using the two flip 
menus in the gray area of the plug-in window:

• Using the upper flip menu (typically showing a channel 
name) you can switch the editor window between all chan-
nels using this specific plug-in. E.g. if you have applied a 
Compressor to tracks 1/2 and 3/4, you can switch between 
these channels and adjust the parameters independently for 
each instance of the Compressor.

• In the lower flip menu you can switch between the plug-ins 
selected for that specific channel. E.g. if one channel uses a 
Chorus and a Delay plug-in, you can switch the window 
between the two effects.

Changing the Plug-in Display
Many—although not all—of the effects feature an Editor 
button which allows you to toggle between the graphical 
“Editor” and the Controls view of the plug-in. The Controls 
view displays all of the plug-ins parameters, and often saves 
space onscreen.
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The Editor and Controls views of the Tape Delay plug-in. Note all of the 
parameters preceded by an asterisk (*) at the bottom of the Controls 
view. These parameters are not visible in the Editor view. 

Additional Plug-in Window Options
The gray area of the plug-in window displays a Link button and 
a Bypass button, and may contain an Extra Controls button, 
shown in the centre of the image. To explain their use:

• Insert a plug-in in the first Insert slot of the first Audio 
channel, if you have not already done so.

• Double click on the illuminated Insert slot and the floating 
plug-in window will launch.

• Now insert a different plug-in into the second Insert slot of 
the audio channel. You will notice that the open plug-in 
window updates to show you the newly selected plug-in.

• Click on the Link button to the left of the gray plug-in 
window area.

• Now insert a different plug-in into the third Insert slot of the 
audio channel. You will notice that the a new plug-in window 
is automatically spawned for the newly selected plug-in.
These two plug-in window behaviors may be useful for 
different tasks, when assigning effects and mixing in Logic.

The Extra Controls button—if available to the plug-in—is acti-
vated by simply clicking on it. 
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• Click hold on the first Insert slot, and select the Logic > Delay 
> Tape Delay plug-in, and launch the plug-in window if one 
is not already opened.

• Click on the Extra Controls button, just to the right of the 
Link button, and the plug-in window will expand to display 
the additional parameters available to the Tape Delay plug-in. 
This gives you the best of both worlds, allowing you to make 
use of the graphical interface of the plug-in, while having 
access to all options.

The Bypass button is used to “bypass” the effect. This is useful 
for allowing comparisons of an audio signal with and without 
the effect. Bypassing an effect is achieved by simply clicking on 
the Bypass button when in the plug-in window.

If you wish to bypass an effect when no plug-in window is 
opened, press C and click on the desired channel’s Insert slot. 
The bypassing of any plug-in can be automated, so remember 
this option if the effect is not in use during a particularly “busy” 
part of your song, and you need more processing power—i.e. if 
there’s a lot of other effects and/or softsynths in use.

Using the Effect Buses
Effects on Audio Track, Audio Instrument and Audio Input 
channels can be routed to Audio Return (Bus) channels. These 
Audio Bus channels can, in turn be routed to other Bus chan-
nels or Master Outputs. To “send” an Audio Track, Instrument 
or Input to a Bus:

• Click hold on any of the Bus Send slots, and a hierarchical flip 
menu will open, displaying the available Buses.

• Highlight the desired Bus number, and then release the 
mouse button. The Bus Send slot will turn blue, with the 
name of the selected Bus displayed. A small knob will 
appear to the right of the Bus Send slot. This is the Send 
Level control. It determines the amount of signal which is 
sent from the Audio channel to the Bus channel.
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• To adjust the amount of send level, click hold on the knob 
and drag your mouse to the right. You may also press C and 
click on the knob which will automatically set it to a value of 
90.

• Insertion of an effect on a Bus channel is as per effect insertion 
on the other audio channel types.

Serial and Parallel Effects Setup
To offer a brief description:

• In a Serial Configuration, the output from one effect is 
summed with its incoming signal and fed into the input of 
the next effect in a chain. A series configuration will occur in 
Logic when you insert multiple effects into subsequent 
Insert slots on a single audio or Bus channel.

• In a Parallel Configuration, the Bus Sends from each channel 
are fed to multiple Bus channels (with inserted effects) 
simultaneously.

• The results from these two methods of adding effects to an 
audio source is dramatically different, even if the same 
effects are used, in the same order.

You can set up effects—in series—on a single bus, which work 
exactly like the Inserts on a single channel. This way, you can 
route multiple audio channels through one bus, with a partic-
ular serial effects combination, saving you time in setting them 
up, and also conserving CPU resources. 

This type of flexibility allows you to combine different effects 
in different ways, so that you can build your own complex 
multi-effects, which are saved as part of your song files. You 
may wish to set up such a configuration and save it in your Auto-
load song.
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What Sort of Effects Go Where?
Although there are no “unbreakable rules” about what effects 
types should be used, there are a number of traditional uses 
which make sense. The amount of processing power required 
for particular types of effects—particularly reverbs and Logic 
Platinum’s Spectral Gate—demand that they be used judi-
ciously.

Traditionally, reverb effects are inserted into Buses, allowing 
multiple tracks to make use of a single reverb “unit”. As the 
Send Level knob(s) on each audio channel can be used to 
control the amount of signal sent to the Bus(es), the amount of 
reverb applied to each channel’s signal can be varied. This 
traditional use makes sense in Logic too, given the CPU 
resources required by the reverb effect.

Dynamics processing and equalization is generally applied on a 
per-channel basis. The CPU requirements for these types of 
effects are far lower than that of a reverb.

Other effect types, such as modulation processes—chorus, 
flanging etc.—can be used in either the Bus or channel Insert 
slots, but are generally used on Buses. Delays are commonly 
used on Buses. Filter effects are usually channel-based.

Logic’s distortion effects do not incorporate a level control, and 
are best suited to use on Bus channels.

Feel free to make your own choices, based on what provides 
the “right” sound for your music, but please take the processing 
requirements and channel status—mono, mono/stereo/
stereo—of the signal path into account.

About Summed Levels
In digital recording systems such as Logic, each “process”—
volume, panning, adding an effect etc.—performs a data calcu-
lation. These calculations often result in an increase or decrease 
of the perceived level of the signal—i.e. signals can become 
louder or softer with each process.
178
Emagic
Logic



Mixer Functions l

X

Logic 5 intro en.book  Page 179  Monday, October 28, 2002  9:34 PM
As digital audio is unforgiving when signals are too “loud”, you 
must ensure that you keep an eye on your level meters when 
feeding your audio channels to Buses and Master outputs 
directly, or via effects. 

At each step of the signal path, signals are “summed” together, 
so take care in setting each of the effect, channel fader, bus 
send, bus fader and master fader levels. This way you can avoid 
clipping and digital distortion, ensuring that you get the 
cleanest possible sound.

Audio Instruments
The next thing we’ll look at is the use of the Audio Instru-
ments. Audio Instrument channels are designed for use with 
software based synthesizers, samplers, drum machines and the 
EVOC20 vocoder.

To create an Audio Instrument track:

• Select the “Piano” track in the Track List, and create an 
audio track in the Arrange window via the Functions > Track 
> Create menu option, or by pressing CE. In the Arrange 
window, a new track will appear below the piano track. 

• Click-hold on the “CHA 1” entry in the Track List, and a 
hierarchical menu will open.

• Browse to Audio > Audio Track > Audio 1, and release the 
mouse button. This will assign the track to the first Audio 
channel.

• Double click on the Audio 1 Track, which will launch the 
Environment window’s Audio layer.

• Click once on the background of the Environment window, 
which will deselect the Audio 1 object.

• Create an Audio Object by selecting New > Audio Object. 
This will generate a small “waveform” icon onscreen.

• Double-click on the icon to change it’s appearance to an 
audio fader. 
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• Clicking on the Cha entry in the Audio object’s parameters 
box will allow you to select an Audio Instrument object via a 
hierarchical menu, as shown in the following diagram.

• Once you have selected Audio Instrument 1, release the 
mouse button.

Click hold on Audio Instrument 1’s top Insert slot, and select 
the mono > es-m synth. Also available from Emagic are the 
ES1, ES2, EXS24 and EVP88 software instruments, which can 
be purchased separately.

It should be noted that if an Audio Instrument object already 
exists within the Environment (on the Audio layer) it can 
simply be selected from the hierarchical flip menu in the Track 
List. 

• Once you’ve made your selection, a double-click on the slot 
will launch your synthesizer’s plug-in window, and as you’ll 
discover, there are lots of knobs, sliders and more to experi-
ment with. This we’ll let you try on your own. By default, 
the plug-in window will automatically launch.

• To actually record some new music using your selected 
Audio Instrument, you need to return to the Arrange 
window, so for now, close the Track Mixer window.
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• Recording Audio Instruments is just like recording MIDI 
instruments, so simply press Record on the Transport Bar (or 
use the Key Command—*) and start playing your MIDI 
keyboard.

• Once you’re done, press Stop. 
• Audio Instrument tracks can be edited in the same fashion 

as MIDI tracks, although there are some small differences, 
as discussed in the next section.

Remarks on the Use of Audio Instruments
Audio Instruments generally use more CPU resources than 
traditional effects, so you need to be judicious about their use, 
particularly if your computer isn’t a cutting-edge machine. 
Follow these tips to reduce system load if you find your system 
struggling and your audio or Audio Instruments start to ‘glitch’ 
on playback. 

Please note that muting an Audio Instrument track in the 
Arrange does not reduce system load. You can, however, bypass 
the instrument by pressing C and clicking on the Audio Instru-
ment channel’s Insert slot. The bypassing of an Audio Instru-
ment can be automated, so remember this option if the synth is 
not in use during a particularly “busy” part of your song—i.e. if 
there’s a lot of other effects and/or softsynth use.

When an Audio Instrument track is selected, it is ready to be 
played in realtime and consequently produces an amount of 
system load. Normally, Logic releases system resources used by 
the Audio Engine when the sequencer is stopped. This is not 
the case, however, if an Audio Instrument track is selected in 
the Arrange window, and is available for real-time playing. 
Selecting a MIDI track or a standard audio track exits this 
“stand by” mode and releases reserved system resources, when 
the sequencer is stopped. 

Audio Instrument tracks can be processed by the Quantize, 
Transpose or Delay sequence parameters in realtime. 
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To hear Audio Instrument plug-ins in conjunction with plug-in 
effects, Logic must be in play mode. As with all of the other 
plug-ins in Logic, you can alter the parameters of the Audio 
Instruments and save your own Settings for later recall. Please 
read the The Plug-in Window section, from page 173 onwards.

You may notice a delay between playing your keyboard and 
hearing the sound. This is another form of latency, as we 
discussed in Chapter 1. Please refer to this chapter and the 
separate Installation Guide for tips on adjusting your audio card 
settings to minimize this latency. It should be noted that you 
may not be able to completely eliminate this “gap”, as this form 
of latency is completely reliant on your sound card’s driver.

A Quick Word on the Included Instruments
The three synthesizers provided with Logic are briefly 
described below. Coverage of all parameters can be found in 
the online help system and Reference manual.

• The es-m is a monophonic “bass” and lead sound synth, 
modelled on the venerable Roland TB-303 Bassline, but 
offering a number of enhancements on the original. 

• The 8-note polyphonic es-e is great for warm and lush 
“pad” sounds.

• The es-p is also polyphonic, and is well suited to the 
creation of finely-crafted percussive sounds with fast attack 
phases, pads, brass and more. It offers a number of creative 
facilities over the other two synthesizers, making it the most 
versatile of the three.

Plug-in Automation
Parameter adjustments of all effect plug-ins, including soft-
ware-based Audio Instruments, can be recorded and played 
back in realtime, just like the level faders and pan pots on audio 
channels.

� It should be noted that some effect types supported by Logic are not 
designed for realtime use—e.g. Premiere, AudioSuite. These plug-ins 
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are used “offline” in the Sample Editor. Please consult the Logic Refer-
ence manual for further information on their use, if applicable to your 
system.

The procedure for effect parameter automation is as follows:

• Open the Track Mixer by pressing Cm.
• Select Touch or Latch mode from the panel above the pan 

knob on the audio channels with the plug-ins you want to 
automate.

• Double click on an Insert slot which contains an effect. 
(Insert one, if none are active.)

• Press Play and move the sliders and knobs in the plug-in 
window. An automation track will be recorded, but will not 
appear in the Arrange window.

• Press Stop when done.

The newly created automation data can be seen by selecting 
View > Track Automation., and by then selecting the appro-
priate “slot” and parameter in the top panel of the track. More 
on the automation system is found in the next chapter.

3.10 More Files to Try Out
The “Tutorial Song Audio/1” file is an example of a combined 
MIDI /audio arrangement, based on the original Tutorial song. 
The delay and quantizing parameters of the MIDI tracks were 
changed, as the swing groove value originally chosen does not 
work well with the drum loop. Effects from the Track Mixer 
were added to the drum loop and rap sequence. Load it up.

There is a stereo file named “Audio Tutorial (2 Track)” on the 
Logic CD. This is the outcome of edits to the audio portion of 
the tutorial. This is a mini audio master of the “Tutorial Song 
Audio/1” file.
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Now It’s Your Turn …
If you’ve worked through the Tutorial up to this point, then you 
should have a good overview of Logic’s most important func-
tions, and a working knowledge of its operation.

The Reference manual and on-line help system provide 
detailed information on the different parts of Logic. Please 
make use of this documentation if you need specific assistance 
on any function or parameter. Given what you have learned 
throughout the Tutorial and preceding chapters, you will 
benefit greatly by reading the Reference manual.

Before leaving the Tutorial chapter, we’d like to thank you for 
sticking with it. Please run through it again, if you’d like more 
practice, or try out some of the suggestions below.

The Tutorial song contains useful source material for your own 
experiments. We encourage you to spend some more time 
working with it and that you give the following a try. 

• Record more tracks—MIDI and audio (e.g. percussion, 
vocals), or Audio Instruments.

• Test out the different Audio Instruments, and create some of 
your own preset Settings.

• Replace existing tracks with your own recordings, e.g. piano, 
bass, drum parts.

• Create more audio tracks, and insert additional audio files.
• In the Sample Editor, experiment with the various Func-

tions and Factory menu options, and listen to the results on 
a range of different audio files.

• In the Track Mixer window, use the Bus and channel Inserts 
to add effects to the audio tracks. Experiment with different 
delay, reverb (and other effects’) parameters by entering 
their plug-in window editors.

• Look for mistakes in the sequences, and remove them by 
using the various editors.

That concludes our Tutorial, and this portion of the manual.

Have Fun.
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Mix Automation

This chapter will introduce you to Logic’s track-based mix 
automation functions. In preceding chapters, we looked at the 
HyperDraw function and the Track Mixer window for adjusting 
and automating mix and other parameters. These include 
volume and panorama changes, plus real-time changes made to 
effect parameters.

In addition, we’ve also explored the mute and solo, effect 
bypassing and other functions, plus the use of continuous control-
lers which provide you with control over your MIDI devices.

Logic Version 5 (and up) expands on these facilities with an 
enhanced, elegant Track Automation system which is accessed 
directly in the Arrange window. Being able to perform virtually 
all recording, editing, arranging and mixing tasks in a single 
window is both convenient and efficient. This automation 
system can be used either “offline” or “live”, which we’ll 
discuss in this chapter.

The Track Automation system supports 32 Bit fader values 
which, in practical terms, means that it’s very precise. This 
affords extremely detailed realtime, automated control over 
your Audio, Audio Instrument, effect and MIDI parameter 
settings.

Logic Version 5 natively supports the Logic Control and Logic 
Control XT units. These hardware devices are connected to 
your MIDI interface and provide control over many Logic func-
tions, including mixing, transport and more. Many of the proce-
dures outlined in this chapter can be achieved more quickly 
and easily with the Logic Control. For further information, 
please visit www.emagic.de or contact your local Emagic distrib-
utor.

Chapter 4
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4.1 About the Mix Demo Song
As you work through this chapter, use the provided “Mix 
Demo” and “Mix Demo Edit “songs. Both songs feature a 
number of tracks configured for General MIDI (GM) tone 
generators. Please refer to the Tutorial chapter for information 
on adapting the song to your tone generator, if you do not have 
access to a GM unit.

The “Mix Demo” song also makes use of Logic’s built-in soft-
ware synthesizers, the es-m, es-e and es-p.

Load the Mix Demo Song
You can start the “Mix Demo” Song by starting Logic, selecting 
File > Open, and browsing to the song, or by double-clicking on 
the “Mix Demo” song icon in the Logic folder.

The Mix Demo song.
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Play the Mix Demo Song
• To listen to the Mix Demo Song, simply press E on the 

numeric keyboard. 
• To stop the song, press the = key. 
• To return to the beginning of the song, push =, on the 

numeric keypad, twice in succession. 

Song Screensets
A number of Screensets have been defined in the Mix Demo 
Song. Press the numeric keys ! through to % to familiarize 
yourself with them.

4.2 Track Automation Basics
As the name suggests, Track Automation is tied to a specific 
track in the Track List of the Arrange window. When Track 
Automation is enabled, and an automation event type is defined 
on a given track, a transparent gray bar (automation track) will 
appear, aligned with that track. This transparent gray track runs 
the entire length of the song. 

The images above show two sequence objects. The lower image is 
shown with Track Automation enabled. Note that the gray automation 
track runs across both sequence objects. Also note the percentage value 
28.346. This is a 32 Bit fader value, ensuring incredibly accurate and fine 
control over parameters—filter Cutoff frequency, in this case.
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Viewing Track Automation
Track Automation can be shown/hidden by selecting the View 
> Track Automation menu option.

• Please select Screenset 2, and toggle the Track Automation 
view. As you do so, you’ll notice that the individual tracks 
will automatically resize vertically to accommodate the addi-
tional parameters shown on each track in the Track List. 
Relative size differences between zoomed and unzoomed 
tracks is retained.

• Switch to Screenset 1. As you can see, the hide/show status 
of Track Automation data is specific to each individual 
screenset which contains an open Arrange window.

• Switch back to Screenset 2.

Important Information
Logic’s Track Automation is discrete from the Record function 
for Audio, Audio Instrument and MIDI tracks. In other words, 
Logic does not need to be in Record mode in order to write new 
automation data to tracks. In addition, the track you wish to 
automate does not need to be selected in order for automation 
data to be written to it.

Track Automation data can be written “offline” or “online”. 

• Offline—means that Logic is not in Play or Record mode. 
When offline, you can use your mouse to insert “nodes” just 
as with the HyperDraw function. In fact, the Track Automa-
tion facility is an advanced version of the HyperDraw func-
tion.

• Online—means that Track Automation data is written “live” 
as Logic is running. This can be achieved using on-screen 
faders, knobs and switches in the Track Mixer and plug-in 
window, or with an external controller, such as the Logic 
Control.
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Track Automation data can be “tied” to specific sequence 
objects or audio regions, allowing you to move a sequence/
audio region and have the automation data move with it. Track 
automation data can also be completely independent of MIDI 
sequence objects and audio regions. The choice is yours.

HyperDraw & Track Automation Compared
To illustrate the differences between the Track Automation 
and HyperDraw facilities, we ask that you read and try the 
following.

Both the HyperDraw and Track Automation functions allow 
you to visually insert (or record) a set of “nodes”—i.e. “dots” on 
the Automation track or HyperDraw “window”. These 
“nodes” are automatically connected by both functions as a 
segmented line, as shown below.

HyperDraw is shown on the left, and the same data is shown in it’s Track 
Automation form on the right.

Numerical values for the current automation track are automat-
ically displayed at nodes, if there is sufficient space between 
the nodes.

Numerical values are context sensitive (e.g. center of pan is 
displayed as 0 and not 64, volume values are displayed in dB—
decibels).

You can view both HyperDraw and Track Automation data 
simultaneously in the Arrange window on different tracks. If a 
MIDI sequence object or audio region which contains Hyper-
Draw information is placed on a track with Track Automation 
enabled, the HyperDraw information will be “hidden”. The 
HyperDraw information will still exist, but won’t be visible. 

To use HyperDraw (and do give it a try):

• Select the Piano Chords sequence at Bar 1.
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• Open the View > HyperDraw menu and select Volume in the 
list, then release the mouse button.

• This will turn the Piano Chords sequence blue, provided it is 
“zoomed” in enough. Use the zoom controls to get a “close 
up” look, if the blue background is not visible.

• To insert “nodes”, click directly in the blue area of the 
sequence at any point(s) along it’s length with the Pencil or 
Arrow tool. This will insert Volume change messages at 
these “nodes” and a line will automatically “connect the 
dots”.

You will note that the HyperDraw data is contained within the 
boundaries of the Piano Chords sequence. Please move the 
sequence to bar 5, and release the mouse button. Note that the 
HyperDraw data is moved with it. Return it to bar 1, once done.

• Now, select the Piano Chords sequence, and browse to the 
Options > Track Automation menu. 

• Select the Move Current Object Data To Track Automation 
function, and release the mouse button. As you can see, the 
HyperDraw data you inserted has been “converted” to 
Track Automation data. This automation data track 
continues beyond the boundaries of the Piano Chords 
sequence. Also note that new information has appeared in 
the Track List panel beside the sequence.

As with the HyperDraw data, Track Automation data can also 
be moved with the sequence (or audio region). Please give it a 
try by dragging the Piano Chords sequence to the right. When 
you release the mouse button to “drop” the sequence, you will 
see the following dialog box.
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Select No and pay attention to what happens to both the 
sequence and the Automation Track data. We will get to the 
other options in this dialog box shortly.

4.3 Track Automation Menu
The Track Automation functions are found in the Options > 
Track Automation menu.

Automation Settings…
Selecting this menu option will launch the following window.

The Move Automation with Objects parameter is a flip menu 
with the choices Ask, Always and Never. This is where you can 
set your preference for the behavior of the Track Automation 
system when you move objects. It is tied to the dialog box you 
saw a moment ago, when you moved the Piano Chords 
sequence.

Ramp Time is important for the “Touch” mode of faders. It 
determines the time (in milliseconds) that it will take a fader to 
smoothly return to its previous value, once you have released 
the fader. We’ll get to fader “modes” in the Track Automation 
Modes section, from page 193 onwards.

“Write” Mode erases: determines the type of automation data 
that is erased when “Write” mode is active.

“Write” Mode changes to: determines the “mode” that the 
automation system automatically changes to when the “Write” 
mode has completed erasing the automation data.
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Delete Functions
The Track Automation menu contains three delete functions. 
To illustrate these, please:

• Select track 5 of the Track List (The Piano Chords track).
• Click hold on the Cha 1 Volume panel of track 5 in the Track 

List.
• In the ensuing flip menu, select Pan and release the mouse 

button. While you have the flip menu open, browse through 
the two MIDI Control menus. Once you’ve released the 
mouse button, the panel will update to display the automa-
tion data type—i.e. “pan”.

• Insert a few “nodes” along the length of the Piano Chords 
automation track.

• Now, select the Options > Track Automation > Delete 
currently visible Automation Data of Current Track option. 
The “pan” automation data for track 5 has been deleted, and 
will disappear from the Arrange window.

• Click hold on the Cha 1 Pan panel of track 5 in the Track List, 
and in the ensuing flip menu, select Volume and release the 
mouse button. You’ll see that your Volume automation data 
was untouched by the deletion.

• Click hold on the Cha 1 Volume panel of track 5 in the Track 
List, and in the ensuing flip menu, select Pan and release the 
mouse button.

• Now, select the Edit > Undo HyperDraw menu option and 
confirm the “undo” in the ensuing dialog box, which will 
return your Pan automation track to it’s former glory.

• Browse to the Options > Track Automation > Delete All Auto-
mation Data of Current Track option. All of your Volume and 
Pan automation track data will be erased.

• Once again, select the Edit > Undo HyperDraw menu option 
and confirm the “undo” in the ensuing dialog box. This will 
restore your Volume and Pan automation track data.

• The final delete function is pretty self-explanatory. It 
deletes all data on all tracks, whether they are selected or 
not. Don’t try it out, at this stage.
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Move Functions
We introduced you to the Options > Track Automation > Move 
Current Object Data To Track Automation function when we 
“converted” the HyperDraw Volume information into Track 
Automation Volume data.

Where it differs from the Options > Track Automation > Move 
All Object Control Data To Track Automation function is as 
follows:

• The “current” object data of the top “move” function refers 
to the automation data type that is visible in the Arrange 
window, and the Track List panel.

• “All control data” is therefore pretty logical. In our deletion 
example, we created a Volume and Pan automation track. If 
we had used the “move all” function, both the Pan and 
Volume information would have been moved.

4.4 Track Automation Modes
Please select Screenset 1, and take a look at the faders in the 
Track Mixer. You will notice a black panel with the word off 
visible in it, just above the Pan control and the level meter. 
This is a flip menu which enables the different fader modes. 
Click-hold on the panel to view the options. Track Automation 
modes are available individually for all Audio Tracks, MIDI 
Tracks and Audio Instrument Tracks.

• Off—Automation is off. The fader will neither send nor 
receive automation data. Existing automation data remains 
untouched. It will still behave as a fader, however, and will 
adjust the volume or pan position etc. as usual.

• Read—The fader will read (follow) any existing automation 
data, but will not write data, regardless of any movements 
you make with the mouse or external control device.
193
Introduction Manual
Version 5



Chapter 4
Mix Automation

Important!

Logic 5 intro en.book  Page 194  Monday, October 28, 2002  9:34 PM
• Touch—Writes new fader moves when the fader is 
“touched” during playback. This is obviously more relevant 
to a hardware device like the Logic Control, but also applies 
to the mouse. Any existing track automation data (of the 
current fader type) will be replaced by new movements as 
long as the fader is active—i.e. mouse button is depressed or 
a Logic Control fader is being touched.

• Latch—Similar to Touch mode, but the control remains acti-
vated, even when the fader/mouse is no longer being 
“touched”. In other words, following the release of the fader, 
the current fader value will replace the existing automation 
data as long as the sequencer is in playback mode. Press Stop 
to finish.

• Write—Overwrites ALL existing automation data of the 
data types selected in the automation settings, or creates 
new automation data. Only use it if you wish to destroy all 
existing automation data of the selected types.

• MIDI—Disconnects the fader from the Track Automation. 
The fader will act like a standard external MIDI control 
source and will be recorded and played back as normal MIDI 
data in MIDI sequences.

When Logic is not playing—i.e. it is in Stop mode—the Auto-
mation write modes are ignored and no data is written if the 
fader is moved. If there are no dynamic changes (i.e.—no 
movements of the fader), the current fader setting becomes 
valid for the whole song. This is always the case when you start 
a fresh song.

• Please select Screenset 2. In the Track List of the Arrange 
window which is displayed, you will notice that the Audio 1, 
AudioInst 2 and Warm Pad tracks—tracks 1, 2 and 6—have 
been resized.
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• On the Audio 1 track, you’ll notice a yellow “fader” to the 
right. This is ideal for “set and forget” setting of Automation 
data values/levels, saving you the trip to the Track Mixer 
window. This Track List fader automatically updates to 
“follow” changes to the currently visible automation track 
data. It can also be used for writing automation data, but you 
may find the Track Mixer’s faders more convenient to use.

• The Warm Pad track also features a similar fader to the right. 
In this case, it is assigned to Pan. 

• Click hold and drag on both to see how they visually change. 
Also note the automation track “line” while doing so.

• To the bottom left of the Audio 1 and Warm Pad tracks, you’ll 
notice a small panel with the word Off written in it. Click 
hold on this panel on the Audio 1 track.

• As you can see, this flip menu is identical to that in the Track 
Mixer, allowing you to select the desired Automation mode 
directly in the Arrange window. 

• On the AudioInst 2 track, you’ll notice that the Automation 
mode panel is missing. Click briefly to the right of the Audio-
Inst 2 track name, to select the track.

• Now, move the cursor towards the bottom left hand corner of 
the AudioInst 2 track and keep an eye on it. When it changes 
into a hand with an extended index finger, click hold on the 
mouse button and drag down. This will resize the track.

• Release the mouse button when the desired vertical track 
zoom size is reached/when you can see the Automation 
mode panel.
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4.5 On/Offline Automation
We have mentioned “live” and “offline” automation 
throughout the chapter. To explain further:

Online or “Live” Automation
Online/Live creation and editing of Track Automation data is 
achieved by the use of a “controller” while Logic is in Play or 
Record mode. 

A “controller”, in this sense, could be a physical fader or knob 
on a hardware device such as the Logic Control. A “controller” 
could also be a software fader, slider or knob found in Logic’s 
Track Mixer (or Environment). 

This “live” method of writing and editing Track Automation 
data is much more intuitive, not to mention faster. In essence, 
you “perform”—quite literally—your mixes in real-time as 
you’re listening to your music.

Writing “Online” Automation Data
• Please switch to Screenset 1.
• Select the Arrange window title bar to bring it to the fore-

ground and select the View > Track Automation menu 
option.

• Click hold on the Read mode label of the Audio 1 fader in the 
Track Mixer window. 

• Change it to Touch mode.
• Start playback of the song.
• Grab the volume fader of the Audio 1 channel in the Track 

Mixer window, and adjust it as you’re listening to the play-
back. Keep an eye on the Audio 1 track in the Arrange 
window.

• Stop playback when you’re done.
• Return to the beginning of the song and press Play and watch 

your Track Mixer faders.
• If you don’t like your mix automation, simply start playback 

again and overwrite your existing data with new data. 
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Note that if you do overwrite your existing data, the fader will 
still be in Touch mode, so you will need to continue “touching” 
it while overwriting the data. 

Try out the other modes on this, and the other tracks.

Offline Automation
Offline creation and editing of Track Automation data is 
achieved by the use of the mouse, when Logic is not in Play or 
Record mode. In fact, when you clicked in the Volume and Pan 
“nodes” on the Piano Chords track, you were creating “offline” 
automation data. As such, you already know the technique, so 
we won’t repeat ourselves here.

The offline use of the Track Automation facilities is best suited 
to editing tasks on existing automation data. This said, 
however, it can certainly be used as the primary input method. 
It’s your choice.

4.6 Automating Plug-in 
Parameters

You will notice that the AudioInst 2 track also displays an Auto-
mation track assigned to Cutoff. This refers to the Resonance 
Cutoff control of the es-p synth assigned to this Audio Instru-
ment channel.

Online Automation of effect and Audio Instrument parameters 
can only be performed in the plug-in window. You can perform 
“offline” automation of effect and Audio Instrument plug-in 
parameters directly in the Arrange window.

Any effect or channel parameter can be automated online, 
regardless of the automation type selected in the Track List. The 
display automatically switches to the parameter being written.
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• Please double click on the es-p panel in the AudioInst 2 
channel of the Track Mixer. This will launch the plug-in 
window.

• Set the appropriate “mode” (Touch or Latch) in the Track 
Mixer.

• Start playback and adjust the Cutoff knob in the es-p plug-
in window by click holding and dragging (vertically) on it.

• Once you have completed your Cutoff automation, press 
Stop.

This technique can be applied to any effect parameter in any 
“Slot”.

Effects “Slots”
You will often use multiple effects on individual channels, 
busses etc. Each effect Insert slot is recognized, and enumer-
ated by the Track Automation system. Slot 1 is the top Insert 
“panel” on the channel fader, Slot 2 is the second Insert 
“panel” a.s.o.

� Slots are helpful aids for identifying and separating the parameters of 
each effect inserted on the channel. As an example of where this 
delineation may be useful, many effect plug-ins feature a number of 
identically named controls. (i.e. “Mix”, “Low Cut”, “High Cut” etc.) 
In this scenario, it could become difficult to identify which plug-in the 
“Mix” parameter you were writing/adjusting belonged to. A quick 
glance at the Slot value will ensure that the appropriate “Mix” param-
eter is being adjusted. 

Click hold on the 1 Cutoff panel on the AudioInst 2 track in the 
Arrange window Track List. You will see a hierarchical menu 
like that shown in the image. To explain:

• Main—are the primary channel “controllers”. They include 
Volume, Pan, Balance, Solo, Mute and Bypass functions.

• es-pp—menu entry contains the specific parameters for the 
es-p synth plug-in. All parameters that can automated in 
the plug-in are shown.
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• Tape Delay—menu entry contains the specific parameters for 
this effect plug-in. All parameters that can automated in the 
plug-in are shown.

� The entries shown in the menu (below the Main entry) reflect the 
plug-in “slot” order, as they appear in the associated channel fader. 
In this example, for AudioInst 2, the es-p would be “Slot 1”, and the 
Tape Delay would be “Slot 2”.

4.7 Editing
Please load the “Mix Demo Edit” song file for further exer-
cises.

This section will introduce you to the techniques needed to 
make corrections and edits to existing automation data. You will 
also get a “feel” for handling of the automation data and should 
find it quite an “organic” and intuitive process.

On launch of the “Mix Demo Edit” song, you’ll see an Arrange 
window with a zoomed AudioInst 2 track, which contains an 
amount of Track Automation data. The automation data 
consists of several “nodes” connected by lines. Above or below 
each node, you will see a numerical value which indicates the 
“level” (as a percentage in this case) of the node.

Nodes and connecting lines can be interacted with directly 
through use of the mouse. You can select nodes, lines, or a 
combination of both while editing. You can also make use of 
“modifier” keys to change the behavior of the mouse when you 
click on lines or nodes.

Handling Nodes

Inserting Nodes
A short click any where in the automation track will insert a 
node at that position and value. A short click on, or just outside 
a line, will insert a node on the line. Please try this.
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Deleting Nodes
To delete a node, simply click on it quickly i.e.—a short click. 
The position of the node will determine what happens to the 
automation data. Try these and use the Undo or Revert to 
Saved functions between each.

• Click on the first node, and it will be deleted. This will, in 
turn, make the second node the first node. A click on this 
node will delete it and make the (original) third node, the 
first node a.s.o.

• The same also applies to the last node, but works backwards 
from the last, second to last, third to last nodes a.s.o.

• Clicking on a node which falls between two other nodes will 
delete it, and the nodes which surrounded it will be joined 
directly by a recalculated line. To illustrate this, click on the 
forth node (bar 7—value of 57.480).

Moving Nodes
The behavior of nodes, when moved, is best illustrated by actu-
ally doing it. Please follow these steps.

• Click and hold on the third node (around bar 5—value of 
37.795).

• Now, slowly drag it to the left.
• Continue dragging until it passes the position of the second 

node and watch what happens. Ensure that you keep the 
mouse button depressed.

• Now, move back to the right and watch what happens. When 
you’ve neared the node’s original position, release the mouse 
button. You can freely move to the left or right, and the 
behavior will be the same.

• Click hold on the node again, and drag it vertically, again 
passing the vertical positions (values) of the nodes above it. 
Return it to it’s former position when done.
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Moving Multiple Nodes
It is possible to select and move multiple nodes (and therefore 
the lines which connect them). You can move adjacent nodes—
i.e. nodes that are beside each other—or you can move non 
contiguous nodes. Please follow these steps.

To select adjacent nodes:

• Click and hold on the line between nodes 2 and 3. Alter-
nately, you can hold S and rubber-band select the desired 
automation area.

• In the dark gray area which appears, drag horizontally and 
vertically to see what happens. 

For non-adjacent nodes, the technique is slightly different:

• Press and hold S and click on the nodes (or lines) you wish 
to select directly. Do this with node 2, node 7 (bar 13—value 
57.480) and the last node.

• If you click the wrong nodes, simply click them a second 
time.

• You will notice that the nodes visually change from a solid to 
a hollow dot, indicating that multiple nodes are selected.

• Once again, release S, click hold on any of the gray areas 
and drag horizontally or vertically.

To deselect all nodes, press S and click anywhere on the back-
ground of the automation track.

Limiting the Movement of Nodes
Logic “intelligently” analyses the direction of mouse move-
ments, making the control over nodes in the Track Automation 
data much easier. 

In cases where the mouse is initially moved in one direction—
vertically or horizontally—the move is “limited” to this direc-
tion. This makes it easy to retain the node(s) value(s) while 
changing the position(s), or to keep the position(s) while 
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changing the value(s). If the mouse is moved on the other plane 
in the X-Y axis (horizontally or vertically), the directional 
“limit” will be overridden and you can freely position the 
node(s). 

You can, of course, limit the movement of nodes to one direc-
tion.

• If you press S while changing the value, the selected 
node(s) is limited to horizontal movement.

• If you press ç while changing the value, the selected 
node(s) is limited to vertical movement.

Handling Lines
Lines are created automatically between nodes. The following 
“node” functions are pertinent to lines.

• a short click on, or just outside, a line (not a node) will add a 
new node on the line.

• a long click on a line allows you to move the line, along with 
its two endpoints—i.e. the nodes that encompass the line.

• a long click outside a line will create and select a new node, 
allowing you to move that node immediately.

Curves
There may be occasions where you wish to create nonlinear 
automation data. 

• Linear means a straight line. 
• Nonlinear means curved.

Click-holding on a line or a selection, with Oç depressed, 
allows you to set various curves on a line or the current selec-
tion.
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Four types of curve shapes are available. These can be set by 
moving the mouse different directions:

• horizontal S-Curve
• vertical S-Curve
• convex
• concave

The most useful shape when changing the level is the hori-
zontal S-Curve. Click on a line with Oç depressed and move 
the mouse to the right.

A short click while holding down Oç on a line or a selection 
will reset the curve of the current line or current selection to 
linear—i.e. a straight line.

Please experiment with these.

Selection Handling
The following functions affect a selected area (selection) of 
visible automation data allowing you to cut, copy and move it.

Hold S and rubber-band select nodes 4 through to 8, as shown 
in the diagram, to try out these functions.
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Delete
• Press the B key to delete the current selection. 
• Select Edit > Undo Clear or use the Oz Key Command, to 

reverse the deletion.

Copy
• Hold down O and click-hold on the selected area (this also 

works on lines and nodes). Drag the selected section to bar 
21 on the right to copy it.

• Select Edit > Undo HyperDraw or use the Oz Key 
Command, to undo the copy.

Move
• Deselect the area by clicking quickly on the background of 

the selected area.
• Now, hold down O and move your mouse cursor to a posi-

tion just before node 5—bar 11. 
• Click hold at this position and you’ll notice that all data from 

the current mouse position through to the last node is 
selected. It can be freely moved horizontally or vertically. 

• If you release the mouse button (but keep the keys 
depressed) and click at a position after node 5, the selection 
area will change.
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Moved or copied automation data will automatically erase any 
data which exists in the destination area. This works “intelli-
gently” with non-contiguous selections. 

Why not apply the techniques you’ve learned about multiple 
selections and moving or copying automation data to see this 
“intelligence” in action?

4.8 The Final Mix
The Introduction Manual has introduced you to the basic infor-
mation you will need to effectively record, arrange, edit and 
automate the mix of your audio and MIDI tracks.

The last step in the recording process is often referred to as the 
“(final) mix” or “mixdown” of your song. It contains:

• Audio Tracks
• Audio Instrument Tracks
• MIDI Tracks—recorded as audio files 
• Any effects used on these tracks
• Automation of levels, pan positions, mutes and effect param-

eters etc. throughout the song 

To facilitate your “mixdown”, Logic features a Bnce (Bounce) 
button at the bottom of the Master Fader in the Track Mixer.

The “final mix” or Bounce, as it is known in Logic, is a real-time, 
digital process. The entire song—or a section of it defined by 
the left and right locators—is played. All mix automation data of 
tracks routed to the selected Master Fader is performed in realtime 
as the song is played back. These “mixed” and effected Audio 
tracks and Audio Instruments are combined into a single mono 
or stereo file. Mono/Stereo status is determined by the button 
beside the Bnce button.

� It is also possible to Bounce to a number of discrete files for Surround 
sound purposes. Please consult the Logic Reference manual for 
further information.
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Bouncing—Procedure
This section presumes that all Audio and Audio Instrument 
tracks have been recorded, arranged and have effects inserted 
or bussed appropriately. Any automation data for these tracks is 
also presumed to be “complete”.

• Open the Track Mixer. Don’t forget to make use of the 
various view buttons to the left of the window.

• Ensure that all Audio, Audio Instrument and/or Bus chan-
nels are routed to the desired Master fader.

• Ensure that the Automation Mode status is set to Read, Touch 
or Latch on each Audio, Audio Instrument and/or Bus 
channel that features automation track data.

• Click the Bnce button on the desired Master Fader (if you 
have audio hardware with more than one output pair). This 
will usually be “Output 1-2” or “Master 1”. The following 
window will launch.

• Check that the Start and End positions are correct. By 
default, they will encompass the area from the beginning of 
the first audio region to the last audio region. You may wish 
to add an extra bar or so to the End position to ensure that you 
capture any Reverb “tails” or Delay repeats, if applicable.

• Select the other parameters—Resolution, File Format, File-
type as desired, by click holding in each flip menu panel. 
Further information on these parameters is available in the 
Logic 5 Addendum and Reference manual.
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• Press the Bnce button and an operating system File Save 
dialog window will open. Browse to the desired folder, and 
name the file.

• Press Save and the bounce will commence.
• Once completed, the bounced file will be available for your 

use in CD-burning applications, Logic or other applications.

About MIDI Sequences and Tracks
MIDI sequences or tracks will not be bounced unless they have 
been recorded as audio files and assigned to Audio Tracks. 
There is a common misconception of users new to MIDI and 
digital audio recording that MIDI can be “converted” to audio. 
As outlined in the first chapter, MIDI and audio data are very 
different. 

If your song contains MIDI sequences (played by your synthe-
sizers, modules etc.) that you would like to include in your final 
mix, simply record them as you would any audio source. Once 
recorded as an audio file, you are free to insert effects, or 
perform any other process available for audio files and regions 
in Logic.

As a tip, we recommend that you record each MIDI part as a 
separate audio file. Use the track or sequence Mute or Solo 
functions, the locators and other techniques you’ve learned, to 
simplify the task. The advantage of keeping your MIDI tracks 
separate—and this can include individual drum sounds in a 
“kit”—is that you can individually process these sounds/parts. 
This gives you far more creative flexibility, and control, during 
the mixing process.

Bounce—Saving Resources
It should be noted that the bounce procedure is a very processor 
and disk-intensive task. It requires additional processing 
resources due to the fact that a new audio file is calculated and 
written, in addition to the playback of your various tracks and 
effects. The following collection of tips may assist you with 
your bounces.
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• To check the status of your CPU resources before and during 
a bounce, please select the Audio > System Performance 
meter. This gives you an overview of the CPU and disk 
usage.

• Deselect any Audio Instrument tracks in the Track List—i.e. 
select a MIDI track.

• Mute any unused tracks in the Track List. Remember that 
Mute can be automated, so make use of this when parts are 
not playing.

• Disable the Catch function in all open windows, or better 
yet, close all windows except the Track Mixer.

• Bypass all unused effects. Remember that Bypass can be 
automated, so make use of this ability when the effect is not 
needed.

• For grouped fade ins or outs, use a Bus or Master fader, rather 
than automating each channel individually. It is more CPU-
efficient and less labor intensive.

• Bouncing 24 Bit files is more disk-intensive. If bouncing for 
CD-delivery, use 16 Bit, 44.1 kHz.

• If your system is close to its processing limits with the play-
back duties alone, you may need to perform two discrete 
bounce processes, combining the resultant file of the first 
bounce with the remaining unbounced tracks. Use the Solo 
and Mute functions, or the Outputs or Buses to facilitate this.
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4.9 Audio Configuration
While not strictly a “mixing” function, you may wish to exper-
iment with or change your effects routings. You may also wish 
to quickly change the routing of your Audio and Audio Instru-
ment tracks. While these tasks can be performed in the Track 
Mixer, Logic features an additional window which gives you an 
overview of your audio configuration. It is launched by 
selecting the Audio > Audio Configuration menu option.

A portion of the Audio Configuration window is shown above. It 
provides you with an overview of your Audio objects.

Once launched, the View menu provides you with options to 
view All or All Used Components.

The two Tools allow you to insert, remove, bypass and move 
effects. Please experiment with them.

The Edit menu provides you with options to Remove EQ’s, 
Plug-Ins, Sends and the Record Path. The Edit menu also 
provides you with the usual cut, copy and paste functions. We’ll 
allow you to experiment with these on your own, and ask that 
you take into account the following:

• Remove allows you to strip out all unused/unwanted effects 
by type.

• Cut, copy and paste functions work between songs.
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When combined, you can quickly strip down one set of effects 
and/or routings from a song, and apply this routing configura-
tion to another song.
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Miscellaneous Info

First up, we’d like to congratulate you on working your way 
through the Introduction Manual. At this stage, you should be 
reasonably comfortable with the basic working methods, 
windows and terminology of Logic. You’re probably also ready 
to get started on your own musical ideas and productions.

5.1 The Autoload Song
We ask that you re-load your Autoload song now. Feel free to 
make any desired changes to the Preferences, Screensets and 
Key Commands that you may have picked up, while working 
through the Introduction Manual. These don’t have to be made 
right now, but keep them in mind. It’s probable that you’ll 
change your working methods as you become more familiar 
with the program. Remember that as you do, you should incor-
porate these changes into your Autoload song by changing the 
song Preferences and Screensets. Changes made to Key 
Commands and Global Preferences affect Logic at a program-
wide level. Such changes are saved in a separate file which 
resides in your Preferences folder.

The Autoload song is the template for all of your future work. 
When starting a new project, the first thing you should do after 
Logic has launched, and (auto)loaded your Autoload song is to:

• Use the File > Save As… function, and give it a different 
name (and select the appropriate folder path, as desired).

• Following this, you’re ready to go.

Please make use of the Introduction Manual and Reference 
manual if you need to jog your memory on working methods, or 
on customizing your Autoload.

Chapter 5
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The other topics in this chapter briefly cover the integration of 
Logic with external software and hardware.

5.2 SoundDiver
SoundDiver is a program, manufactured by Emagic, that 
provides editing control and storage (librarian) facilities for 
MIDI devices. It supports well over 500 devices including: 
synthesizers, effects units. MIDI controlled mixers, samplers 
and more.

SoundDiver features a unique ability to “interrogate” MIDI 
devices and to extract information about sounds, patches and 
settings from them. This information is then categorized and 
stored in a library file.

When run at the same time as Logic, the information extracted 
by SoundDiver can be passed on to Logic’s Environment as a 
set of patch names for each device.

This is handled by a dynamic internal “bridge” between the 
two programs called Autolink. 

About Autolink
The Autolink facility provides much more than the simple 
exchanging of patch names between SoundDiver and Logic. It 
also allows any realtime changes made in SoundDiver’s MIDI 
device editors to be recorded directly to the currently selected 
track in Logic.

Autolink is enabled in Logic by selecting the Options > 
Settings > MIDI Interface Communication > Use AUTOLINK 
with SoundDiver or SoundSurfer if available checkbox.
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Using Autolink
Logic must be launched before SoundDiver.

When both programs are launched, and Autolink is active, 
Logic handles all MIDI inputs and outputs. 

• Any MIDI data arriving at a MIDI IN port will be routed via 
Logic to SoundDiver. 

• SoundDiver’s MIDI output is routed via Logic to a MIDI 
OUT port.

• SoundDiver’s MIDI THRU sends the incoming data to the 
currently selected MIDI device.

SoundDiver will automatically scan the currently loaded Logic 
song for an Instrument object in the Environment which 
matches the MIDI port, and channel settings, of the MIDI 
device presently selected in SoundDiver. If no matching Instru-
ment object exists in Logic, you’ll be asked if you’d like to 
create one.

This facility is ideal when setting up Logic for the first time. 
You can simply allow SoundDiver to scan all of your MIDI 
ports. Once it finds and interrogates all of your MIDI devices, 
the patch name information of the devices is passed on to 
Logic. 

This information is dynamic, so any changes you make in 
SoundDiver are communicated to Logic, automatically 
updating the patch name lists for each Instrument object. 

� It should be noted that the changes made to names in SoundDiver are 
not saved with the Instrument objects in the Logic song. This means 
that you will always need to run SoundDiver alongside Logic when 
loading this song. Alternately, you can manually make changes to the 
Instrument objects through use of the Update via Autolink function. 
More information on this is available in the Logic Reference manual.
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5.3 Logic Control
As the name suggests, Logic Control provides “control” over 
Logic Platinum’s (version 5 and higher) many functions. The 
Logic Control XT is an expansion unit which adds additional 
channels. 

The immediate benefit of using the Logic Control is that 
recording, mixing and editing tasks are greatly accelerated, as 
you have simultaneous “hands-on” control over multiple chan-
nels and/or parameters. These include; transport, scrubbing, 
mute, solo, volume, pan, plug-in parameters, screensets—in 
fact, any “control” you can think of. This control over multiple 
channels/parameters is more convenient than use of the mouse, 
which is limited to one task at a time.

Any changes made by you on the Logic Control’s surface are 
reflected in Logic, in realtime. When these changes are 
recorded and played back, the Logic Control will physically 
update to “follow” the automation. Its motorized faders will 
move smoothly as fades are played back, the main display and 
the LED’s for each switch will update in realtime to indicate 
their current value.
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The Logic Control and each Logic Control XT unit (if appli-
cable) must have a discrete MIDI IN and MIDI OUT connec-
tion to a free, dedicated MIDI port on your MIDI interface. We 
recommend the use of the Emagic Unitor8, AMT8 or MT4 
interfaces.

When Logic Platinum 5 (or higher) is launched, it will automat-
ically “sense” the Logic Control unit(s) and will send informa-
tion about the current program and song settings. The current 
song position and parameter values will appear on the Logic 
Control’s displays.

The faders, knobs and switches on the Logic Control and XT 
units do not have fixed functions or channels. This allows you 
to switch between fader “banks”, or to increment in channels. 
To explain, audio channels 1—8 would be bank 1, audio chan-
nels 9—16 would be bank 2 a.s.o. Incrementing by channel 
could allow the switching between plug-ins where all 8 faders 
and knobs are assigned to the parameters of the plug-in. As an 
example, two instances of the ES2 synthesizer are inserted on 
Audio Instrument “channels” 3 and 4. Switching by channel 
allows you to toggle between the two. As you do so, the status 
of all relevant faders, knobs, switches and displays will update 
to reflect your current selection.

As new functions are added to future versions of Logic, the 
Logic Control unit(s) will automatically receive this informa-
tion each time Logic is launched. This ensures that the Logic 
Control units will remain “current” for many years to come.

For further details on the Logic Control and it’s integration 
with Logic, please visit our website at www.emagic.de
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5.4 Synchronization
Logic Platinum and Gold feature extensive synchronization 
facilities. These facilities allow you to “lock” Logic to film and 
video, drum machines, other sequencers, digital audio worksta-
tions (DAW’s) and more. Logic can act as the Master—control-
ling the timing of the slave—or Slave—where Logic follows the 
timing of the master.

Logic Audio (formerly Silver) is limited to MIDI Time Code 
(MTC) and MIDI Clock synchronization. This means it can 
only be synchronized with devices which communicate their 
timing information via MIDI.

When synchronized, transport controls such as start, stop or 
continue are sent from the Master to the Slave. Timing infor-
mation about the current bar/beat, or an “absolute time” posi-
tion is also sent. Absolute time is measured on a 24 hour clock 
and is divided into hours, minutes, seconds, frames, sub-
frames. The frames and sub-frames come from the use of 
synchronization with film. This terminology and technology 
was dreamed up by the Society of Motion Picture and Televi-
sion Engineers (SMPTE). 

• Absolute time is more commonly known as SMPTE time 
code. This type of synchronization is only available in Logic 
Gold or Platinum.

• MIDI Time Code (MTC) is the MIDI world’s equivalent of 
SMPTE time code. It is available to all Logic versions.

• MIDI Clock is a simple timing pulse which is sent out. It 
does not contain any positional information, but does send 
start and stop messages.

The Transport Bar changed to display the current SMPTE (absolute time) 
position. This is achieved by clicking on the “down” arrow to the right of 
the display. From left to right it displays hours, minutes, seconds, frames, 
sub-frames.
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The Logic Reference manual covers the specifics of each 
synchronization parameter, and their use, which we’ll allow you 
to view at your leisure.

Synchronization Tips
If you are running an external MIDI device that is capable of 
sending MIDI Clock or MIDI Time Code (MTC) messages 
(Drum Machine, Sequencer, Workstation keyboard etc.) then 
you may encounter strange error messages or odd “stuttering” 
behavior in Logic. To rectify the problem, try these tips—one 
at a time:

• Open the Options > Settings > Synchronization Settings > 
General menu/page. Uncheck the Transmit MIDI Clock and 
Transmit MTC options which will stop a “loop” of MIDI 
synchronization data occurring. 

• In the Options > Settings > Synchronization Settings > MIDI 
menu page, you can specify a port for synchronization data if 
you wish to send it to a specific device, but not to all of your 
devices.

• Check your digital clock settings (if applicable to your 
setup). Please consult the separate Installation Guide, and 
your audio interface documentation, for further information.

That concludes the Logic Introduction Manual. 

Please make use of the Reference manual and our online 
resources at www.emagic.de Our international distribution team 
and dealer network are also available to assist you with any sales 
or technical queries you may have. 

We wish you many years of successful music making, inspira-
tion and enjoyment with Logic.

We will continue to bring you the very best in music technology 
and look forward to a long and fruitful creative partnership with 
you.

Your Emagic Team.
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