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Introduction

The goal behind the examples in Learning Director is to provide you 
with the basic skills you’ll use most of the time when you work 
with Macromedia Director. But Director is such a rich 
environment that it’s impossible for a single book to cover 
everything there is to know about it. The fact is that nobody 
knows everything there is to know about it. New ways to use 
Director are constantly being discovered as people find that they 
need to do things they’ve never done before.

If you’re new to Director, work through the chapters in this book, 
and you’ll have a firm grasp on how to make Director work for 
you. If you already have experience using Director, you may find 
in these tutorials an introduction to features you haven’t had the 
opportunity to try out before. Once you’ve worked you’re way 
through this guide, you’ll not only have a handle on basic skills, 
you’ll also be in a position to experiment on your own and 
discover the techniques that work best for you.
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What’s in this manual

This guide has eight chapters.

Chapter 1, “Basic Animation,” leads you—in about an hour—through 
the entire process of creating an animated Director movie.

Chapter 2, “Creating Text in the Paint Window,” focuses on the 
process of creating and modifying a cast member. It introduces the 
paint window’s text tool (which you use to create bitmapped text) and 
the Switch, Reveal, and Transparent inks.

Chapter 3, “Creating Text with the Tools Window,” shows how to 
create QuickDraw text and how to convert it into bitmapped text. It 
also shows how to position cast members on the stage precisely.

Chapter 4, “Animating a Sequence of Cast Members,” focuses on 
animating an image—such as a bird flapping its wings—that changes as 
it moves across the stage. It also shows how to colorize a black-and-
white cast member.

Chapter 5, “Working with Sounds,” shows how to add sounds to a 
Director movie.

Chapter 6, “More Animation Techniques,” covers an invaluable 
collection of techniques: creating the intermediate stages of an 
animation with the In-Between Special command, using Director to 
generate cast members automatically, and using registration points to 
align cast members precisely on the stage.

Chapter 7, “Creating Effects,” focuses on the special effects you can 
create using Director’s transition and palette channels.

Chapter 8, “Adding Interactivity to a Movie,” leads you through the 
process of creating buttons and hypertext links in a Director movie. It 
also provides an introduction to writing Lingo scripts.

You can find terms that look like this in the glossary at the end of Using 
Director.

Note This guide assumes that you know how to use a Macintosh computer. If you 
run into a problem and you need help, see the user’s guide that came with your 
computer.
Introduction2



                             
Where to go for more information

If the experiments in this guide leave you with a couple of new 
questions for every one they answer, that’s a good sign. It means 
you’ve grasped the basics of Director and you’re ready to move on to 
advanced concepts and more sophisticated techniques. Here are some 
topics you might be interested in and how to find out more about 
them:

◆ Procedures. Additional ways of using Director’s tools and 
features are covered in chapters 1 through 4 of Using Director.

◆ Director’s windows. If you’re interested in the details of how any 
of Director’s windows works, see Chapter 5, “Window 
Reference,” in Using Director.

◆ Director’s menus and dialog boxes. For information about any 
command on any of Director’s menus or about any of the options 
that appear in any of the dialog boxes, see Chapter 6, “Menu 
Reference,” in Using Director.

◆ Techniques. It doesn’t take long for someone new to Director to 
discover that creating a Director movie involves more than using 
just Director and just the computer you’re working on. You’ll 
find yourself using files created in Photoshop and SoundEdit Pro 
and taking into consideration that the movie you’re working on 
may need to run on a less powerful Macintosh or even a Windows 
computer. For tips on performance, synchronization, debugging 
strategies, and cross-platform development, see Tips & Tricks.

◆ Lingo. If you’re interested in learning more about the Lingo 
scripting language after working through the examples in Chapter 
8, “Adding Interactivity to a Movie,” see Using Lingo.
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◆ Expert advice. The body of knowledge about Director grows 
constantly as more and more people find new and creative uses for 
it. One of the best ways to keep abreast of the most efficient and 
most inventive ways to use Director is to join a user’s group or to 
connect with an on-line forum such as Macromedia’s 
CompuServe forum. Here are some ways to keep in touch with 
other Director users:

User groups. A user group is a great way to network with 
Macromedia developers and users, multimedia enthusiasts, and 
corporate contacts. To find out if there’s a user group in your 
area—or for information about starting one if there isn’t—call 
Macromedia.

Macromedia International User Conference. Every year the 
Macromedia International User Conference brings together 
people from around the world to discuss product development, 
engineering, marketing, and business strategies. The conference 
offers an opportunity to network with industry leaders and learn 
about the latest multimedia technology. For information about the 
conference, call Macromedia.

On-line services. Two of the world’s largest on-line services, 
CompuServe and America Online, offer forums for users of 
Macromedia. The forums provide access not only to other users, 
but to the people at Macromedia who developed Director. If you 
have an account on CompuServe, log on, and then type GO 
MACROMEDIA at the prompt. If you have an account on 
America Online, log on, and then enter KEYWORD: 
MACROMEDIA.

◆ Training. Macromedia and its network of Authorized Training 
Providers offer expert training on Macromedia products. Courses 
are led by professional instructors whose comprehensive product 
knowledge results from first-hand experiences as expert users and 
developers. To register for Macromedia courses and for help 
locating a Macromedia Authorized Training Provider near you, 
call Macromedia.
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Hardware and software requirements

For information about the type of Macintosh computer and the 
version of the system software you need to use Director, see the 
“Introduction” in Using Director.
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Chapter 1

Basic Animation

This chapter leads you—in about an hour—through the entire 
process of creating an animated Director movie.

A movie is the term used for a multimedia piece you create with 
Director. Like animated motion pictures, Director movies 
contain animation, sound, music, special effects—even digital 
video (such as QuickTime movies). They can also have a 
dimension no motion picture is capable of: interactivity. 
Interactivity means that a movie responds to the choices people 
make—it gives people control over the direction a movie takes.
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The example used in this chapter is quite simple. It involves 
drawing the moon, importing an illustration of a Japanese shrine, 
and then animating the moon rising over the shrine.

The moon rising over a Japanese shrine

The example gives you experience working with the paint window, 
selecting a background color for the stage, and applying the Matte ink 
effect. You also find out how to import cast members and drag them 
to the score. Most important, you get to work with animation 
techniques: real-time recording, step recording, in-betweening, and 
layering. Finally, you create a projector—a play-only version of the 
animation. (A projector is the best format to use if you distribute the 
movies you create to others.)

Note The art that appears in the examples in this guide is taken from the sample 
movies packaged with Director. To play the sample movies, go to the 
Macromedia Director 4.0 folder, open the Sample Movies folder, and then 
open the Lingo Expo folder. Then play Begin.Dir (in the Kiosk folder), 
MECH (in the Simulation folder), or Noh_Tale (in the Storybook folder).
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Starting Director

If you haven’t already installed Director, follow the instructions in 
“Installing Director” in Using Director.

To start Director:

þ Go to the folder named Macromedia Director 4.0, and 
double-click the icon labeled “Director 4.0.”
The startup screen appears for a moment while Director is 
loading.

Note If you’ve already started Director, choose New from the File menu (or press 
Command-N) to open a new movie.
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The startup screen goes away, and the stage remains on the screen. 
The windows that were open the last time you used Director 
reappear automatically. If this is the first time you’ve started the 
application, Director displays the control panel, the cast window, and 
the score.

If you need to open the control panel, the cast window, or the score, 
here’s how to do it:

To open the control panel:

þ Choose Control Panel from the Window menu (or press 
Command-2).

To open the cast window:

þ Choose Cast from the Window menu (or press Command-3).

Control panel

Score

Cast window Stage
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To open the score:

þ Choose Score from the Window menu (or press 
Command-4).

Director has 11 windows, but you need only 5 of them to create 
simple animation: the paint window, the cast window, the score, the 
control panel, and the stage.

The paint window provides the same tools you’d find in a paint 
application such as MacPaint Pro. You can use it to create or edit the 
artwork that appears in a movie. You’ll get a chance to work with 
many aspects of the paint window in the examples in this guide.

The cast window stores every piece of artwork in a movie. It’s a 
multimedia database of graphics, text, sound effects and music, color 
palettes, buttons, digital video (such as QuickTime movies), and the 
Lingo scripts that provide interactivity and control of a Director 
movie. Anything stored in the cast window is called a cast member.
Basic Animation 11



             
You can create cast members either by using the tools that Director 
provides or by importing the cast members into Director from other 
applications. For an overview of the different types of cast members 
and the ways you can create them, see “Creating cast members” in 
Chapter 1 of Using Director.

As you import or create cast members, Director adds them to the cast 
window automatically. Once the cast members are part of a movie’s 
cast, you can use them in any frame of the movie.

The score keeps track of the position of each cast member on the 
stage in each frame of a movie and controls tempos and the timing of 
sounds, transitions, and palette changes.

The control panel provides a set of controls similar to those on a 
VCR. You can use them to play, stop, or rewind a movie or to step 
through it frame by frame.

The stage is the window where the movie you’re creating appears. 
It’s always open, and it normally appears behind any of the other 
windows that are open. (You can close all the windows that are 
open—and hide the menu bar as well—by choosing Stage from the 
Window menu.)

For complete information about all of Director’s windows, see 
Chapter 5, “Window Reference,” in Using Director.
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Assembling the cast

The term cast member covers every element that can be part of a 
Director movie: graphics, text, sound effects and music, color 
palettes, QuickTime movies, buttons—even the Lingo scripts that 
make buttons work. As mentioned in the previous section, there are 
two ways to fill the cast window with cast members. One way is to 
create cast members inside Director using the paint window, the tools 
window, a text or script windows, or the Record Sound command. 
(When you create a cast member in Director, Director adds it to the 
cast window automatically.) The other way is to import cast members 
you’ve created outside Director, with applications such as Photoshop, 
Canvas, SoundEdit Pro, and Premiere.

This section shows how to create a cast member in Director’s paint 
window and how to import a cast member that you’ve created 
outside Director.
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Creating a cast member in the paint window

Follow the steps below to draw the moon that you’ll later animate 
rising over the Japanese shrine. The first step is to open the paint 
window.

To open the paint window:

þ Choose Paint from the Windows menu (or press 
Command-5).
The paint window looks like this:

For a complete description of the paint window, see Chapter 5, 
“Window Reference,” in Using Director.

As you open and close windows in Director, you’ll notice that the 
menus listed on the menu bar change. For example, when you open 
the paint window, Director adds the Paint and Effects menus to the 
menu bar.

Foreground color chip

Drawing 
area
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Select the foreground color for the moon:

1. Point to the foreground color chip (below the tools palette, 
on the left) and hold down the mouse button to display the 
color palette.
The palette looks like this:

2. Drag the pointer to the yellow chip that’s in the top row, 
fourth from the left.
The foreground color chip changes to the color you’ve selected.

Draw the moon:

1. Select the filled ellipse tool.
Use the right side of the ellipse tool to draw a filled ellipse or 
circle. Use the left side to draw just the outline of an ellipse or 
circle.

2. Move the cursor to the drawing area.
It turns into a crosshair.

Foreground color chip

Select this yellow
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3. Hold down the Shift key and drag until you get a circle 
about an inch across.
Holding down the Shift key constrains the shape you draw to a 
circle.

4. Close the paint window.
Director automatically places the moon in the cast window.
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Importing a cast member

When you import a cast member, Director places it in the cast 
window. You can import PICT, MacPaint, sound, Scrapbook, PICS, 
Director movie, and QuickTime movie files. There are two ways to 
import PICT, AIFF sound, and Director movie files: you can import 
them directly into the cast window, or you can create a link to a file. 
(Whenever you import a QuickTime movie, it’s linked 
automatically.) Creating a link has two advantages: the movie you’re 
linking the cast member to doesn’t increase in size because it doesn’t 
contain the cast member, and any changes you make to the cast 
member file outside Director are automatically reflected in the 
movie. (For information about linking a cast member, see “Import” 
in Chapter 6, “Menu Reference,” in Using Director.)

The next step in creating the animation you’re working on is to 
import the shrine that serves as the background for the animation.

To import the shrine:

1. Choose Import from the File menu (or press Command-J).
The Import dialog box appears.

2. Choose PICT from the Type pop-up menu if it isn’t already 
selected.

Type pop-up menu
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3. Go to the folder named Macromedia Director 4.0, open the 
Tutorials folder, then the Learning Director folder, select 
the file named “Shrine,” and then click Import.
A thumbnail version of the shrine appears next to the moon in 
the cast window.

Adding a cast member to the score

Importing or creating a cast member makes the cast member part of a 
movie’s cast, but to make the cast member part of the movie’s action, 
you need to add the cast member to the movie’s score.

The score tells Director what each element of a movie is doing 
moment by moment. For example, the score tells Director which cast 
members are on the stage and where they’re located, which sounds to 
play, which color palette is in control of the monitor, and which 
Lingo scripts to follow.

The score is laid out as a grid made up of cells. It’s designed so that 
each column of cells is a frame of animation and each row forms a 
channel.

Frame

Cell

Channel
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The parts of the score

A cell is the smallest unit in the score. Each cell contains information 
about one cast member at a particular moment in a movie. (Cast 
members include graphics, text, sound effects and music, color 
palettes, QuickTime movies, buttons, and Lingo scripts). Cells can 
also contain information about things other than cast members, such 
as transitions and tempo settings.

A frame—a column of cells—represents a single moment in a 
Director movie. It’s the sum of all the information in all the cells in a 
single column. It’s much like a frame of a motion picture: it’s a 
snapshot of everything you see on the stage at any given moment. A 
frame also contains information about things you don’t see, such as 
sound effects and the Lingo scripts that control interactivity.

A channel is a row of cells. Each channel is dedicated to a specific type 
of information. There are 5 effects channels (1 each dedicated to 
tempo settings, color palettes, and transitions, and 2 dedicated to 
sounds), a script channel (for Lingo scripts), and 48 sprite channels 
(for animation, graphics, text, QuickTime movies, and buttons).

Tempo channel

Transition channel

Script channel

Palette channel

Sound channels

Sprite channels
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The playback head serves the same purpose as the playback head on a 
VCR: it determines which moment of a movie is currently displayed 
on the screen. When you play a movie, the playback head moves 
through the score from one frame to the next. When it reaches a 
frame, Director checks the information in each cell in the frame and 
carries out whatever instructions it finds there. For example, Director 
positions each graphic or text cast member that appears in a sprite 
channel at its appropriate spot on the stage, plays the sound effects or 
music identified in the sound channels, produces the transition called 
for in the Transition channel, and so on. When a movie is stopped, 
the playback head continues to function: when you move the 
playback head to a specific frame, Director displays a snapshot of what 
things look like at that moment in the movie.

The information that appears in the score describes in shorthand form 
what happens in each frame of a movie. Learning to read the notation 
in the score is like learning to read music. It’s only after seeing 
examples of animation and its notation that you can begin to make 
the connection between abstract bits of data and what the animation 
actually looks like.

Dragging a cast member to the stage or the score

You can add a cast member to the score—and so make it part of a 
movie’s action—in one of two ways:

◆ You can drag the cast member from the cast window directly to 
the score.

◆ You can drag the cast member from the cast window to the spot 
on the stage where you want it to appear.

Playback head
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When you want to add a cast member to a movie, it doesn’t matter 
which technique you use. When you drag a cast member to the 
score, Director not only adds it to the score, it also displays the cast 
member in the center of the stage. When you drag a cast member to 
the stage, Director not only displays it there, it also adds it to the 
current frame in the score (the playback head shows which frame is 
current). The stage and the score are simply two different views of 
the movie you’re creating; anything you do to one affects the other.

It’s better to drag a cast member to the score when your primary 
concern is the moment at which the cast member appears in a 
movie—the moment at which a cast member appears is determined 
by the frame where you place the cast member. On the other hand, 
it’s better to drag a cast member to the stage when your primary 
concern is the spot on the screen where the cast member appears. 
You can adjust both the frame where a cast member appears and its 
position on the stage after you’ve added it to the movie—being able 
to drag the cast member to either the score or the stage just makes it a 
little easier to get started.

You’ll get plenty of practice with both techniques throughout the 
course of the examples in this guide.

Cast members and sprites 

When you place a cast member on the stage, you don’t actually move 
the cast member bodily from the cast window to the stage as you put 
a chessman on a chessboard. Instead, when you drag a cast member 
from the cast window to the stage or the score, Director creates a 
new element: a sprite. A sprite is an image of a cast member, and it’s 
the image of the cast member—not the cast member itself—that 
Director displays on the stage.
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A cast member and a sprite aren’t identical. A cast member is a 
template for a sprite. When you drag a cast member to the stage, it’s 
like making a copy of a form letter: the master letter remains 
unchanged, but the copy gets filled in with specific information. The 
specific information the sprite gets “filled in with” includes its 
location on the stage, any change you make to its size, and so on. 
You can have more than one sprite based on the same cast member. 
Each one is a separate image of the cast member, and each can be a 
different size, located at a different place on the stage, and so on.

Adding the shrine to the movie

To add the shrine to the movie:

þ Point to it in the cast window, and drag it to cell 1 in 
channel 1 of the score.

The shrine appears centered on the stage.

Save the movie at this stage. It’s always a good idea to save the movie 
you’re working on every 15 minutes or so. If something happened—
such as a power outage—that caused you to lose work that wasn’t 
saved, you’d have to recreate only a few minutes of work, not several 
hours’ worth.
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In this case, there’s another reason to save the movie in its current 
state. The next section shows how to use real-time recording to 
create animation. You may want to experiment with real-time 
recording until you’re sure you’ve got the hang of it. Having a copy 
of the movie you started from in its original state makes 
experimenting much easier.

To save the movie:

1. Choose Save from the File menu.
The directory dialog box appears.

2. Name the movie “Moon,” and click Save.
Director saves the movie.
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Real-time recording

Recording in real time means that as you drag a sprite across the 
stage, Director keeps track of its path and records its location moment 
by moment in consecutive cells in the score. The tempo that’s set in 
the control panel determines exactly what “moment by moment” 
means. For example, if the tempo is 30 FPS (frames per second), 
Director records the sprite’s location every 1/30 of a second.

˛ Tip For better control when you’re recording in real time, use the tempo control in 
the control panel to record at a speed that’s slower than normal. (For 
information, see “The control panel” in Chapter 5, “Window Reference” in 
Using Director.) When you play the movie back, you can adjust the speed 
with a different tempo setting to make the animation look normal. (See 
“Adding a tempo setting” in Chapter 3, “Working Behind the Scenes” in 
Using Director.)

One way to create an animated sequence showing the moon rising 
over the Japanese shrine is to record the animation in real time. The 
process is simple: first you hold down the Control key and the 
spacebar simultaneously to turn on real-time recording, and then you 
drag the moon along the path you want it to follow.

Tempo setting
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Before you start:

þ If the Loop button on the control panel is down, click it to 
turn looping off.

When the Loop button is down, Director starts playing the 
animation you’ve recorded over and over again as soon as you 
finish recording it.

˛ Tip You can also turn looping on and off by choosing Loop from the Edit menu or 
by pressing Command-L.

To record the rising of the moon in real time:

1. Close the score and move the control panel to the upper 
left corner of the stage.
You’ll often find as you work through the examples in this guide 
that the windows that are open get in the way of what you want 
to do on the stage. Feel free to close them or move them to get 
them out of the way. Remember that you can close all the 
windows that are open in front of the stage by pressing 
Command-1. To open any window, choose it from the Window 
menu.

2. Choose Rewind from the Edit menu (or press Command-R) 
to make sure the playback head is in the first frame of the 
movie.

3. Select the moon in the cast window.
Don’t drag the moon from the cast window to the stage—just 
select it.

Looping is on

Looping is off
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4. Hold down the Control key and the spacebar, and position 
the pointer near the top of the shrine like this:

As soon as you press the mouse button in the next step, Director starts 
to record the movement of the pointer. Be ready to move the pointer 
as soon as you press the mouse.

Position the pointer here
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5. Hold down the mouse button and drag the pointer across 
the stage like this:

6. Release the mouse button.

Drag the pointer 
across the 
stage to here
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Take a look at the score:

þ Choose Score from the Window menu (or press 
Command-4).
The score appears.

The score before and after real-time recording

The shrine’s position
The moon’s position
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Director has recorded the moon’s position at each moment during 
the time you were holding the mouse button down. It has also 
recorded the position of the shrine in each frame even though the 
shrine hasn’t moved. That’s because a frame contains information 
about everything that’s on the stage at any particular moment. If 
Director didn’t record the shrine’s position as well as the moon’s, 
when you ran the movie, the shrine would disappear from the stage 
after the first frame.

It may take a little practice with real-time recording to get the 
animation to look the way you want. You can do several “takes” and 
use the one you like best. But before you record a second take, run 
the first one to see how it looks. The next section describes how.

Save the animation you’ve created as a new movie:

1. Choose Save As from the File menu (or press Command-
Shift-S).
The directory dialog box appears.

2. Name the movie “Moon 1,” and click Save.
Director saves the movie.

You’ll find that you create and save quite a few movies in the course 
of working through the examples in this guide. Saving copies of the 
movies you’re working on allows you to take a second look at them 
after you’ve finished them. Comparing the animation you’ve created 
with the information that’s recorded in the score is a good way to 
learn how the score works and how Director interprets the 
information that’s recorded there. The movies, nonetheless, take up 
considerable disk space, and it’s a good idea to delete them once 
you’ve finished with them.
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Playing animation

You can use the buttons on the control panel to rewind and play back 
an animated sequence, just as you would with a videotape.

If the control panel is no longer on the screen:

þ Choose Control Panel from the Window menu (or press 
Command-2).

To see how the animation of the moon looks:

1. Close the score.

2. Click the Rewind button on the control panel (or press 
Command-R).
Director moves the playback head to frame 1 of the movie.

3. Click the Play button (or press Command-P).
The moon follows the path you traced on the stage.

There are at least two adjustments that need to be made to the 
animation (you may want to make others as well):

◆ The white box surrounding the moon needs to be removed.

◆ The moon needs to rise behind the shrine, not in front of it.

Both adjustments are covered later in this chapter.

If you want to examine the animation in more detail to see if there 
are any other changes you want to make, you can turn looping on so 
that Director plays the animation over and over again.

Rewind

Step Backward

Stop

Step Forward

Play
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To play the animation over and over:

1. Click the Loop button to turn looping on (or press 
Command-L).
The once-through icon on the button is replaced with the 
looping icon.

2. Click the Rewind button (or press Command-R).
Director moves the playback head to frame 1 of the movie.

3. Click the Play button (or press Command-P).
The animation plays over and over until you stop it.

4. Click the Stop button (or press Command-period).

When you’re finished watching the animation play over and over, 
turn looping off:

þ Click the Loop button (or press Command-L).

If you don’t like the way the animation you’ve created looks, do a 
few more takes until you get something you like. To do another take, 
open “Moon,” the version of the movie you saved before you 
created the animation, and then repeat the steps in “Real-time 
recording.” Give each take a different name when you save it.
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Using the Matte ink

Normally when you place a sprite on the stage, its bounding box—the 
rectangular area around the image—is treated as part of the sprite. 
That’s not always desirable. For example, when you place the moon 
on the stage, you want it to look like a circle, not like a colored circle 
inside a white box.

To get rid of the bounding box, you use the Matte ink. The score has 
a variety of inks that let you modify the way a sprite looks on the 
stage. The inks don’t affect the appearance of the cast member a sprite 
is based on, just the sprite you apply the ink to.

Bounding box
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The inks that are available appear on the Ink pop-up menu in the 
score window:

For a quick overview of the effect each ink creates, take a look at the 
sample movie Ink Effects. To play it, go to the Macromedia Director 
4.0 folder, open the Tutorials folder, and then open the Learning 
Director folder. Double-click the icon labeled “Ink_FX.” When 
you’re finished watching the movie, press Command-period to stop 
it. For a description of each of the ink effects, see “The score” in 
Chapter 5, “Window Reference,” in Using Director.

To apply the Matte ink:

1. Open the score.

2. Double-click the 2 beside channel 2 to select the entire 
channel.

3. Choose Matte from the Ink pop-up menu in the score.
The bounding box surrounding the moon disappears.

Ink pop-up menu
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Setting the background color of the stage

The color of the stage is white by default, but you can use the 
background color chip on the control panel to change it to any color 
in the palette.

To set the background color of the stage:

1. Click the control panel to make it the active window (or 
press Command-2).

2. Point to the background color chip on the control panel, 
and hold down the mouse button.
The color palette appears.

3. Select a color that complements the illustration.
The background changes to the color you’ve selected, but the 
color is visible only where the background isn’t masked by the 
illustration.

To make the background color of the stage visible behind the 
illustration, you need to make the illustration’s background 
transparent. The next section, “Using the Background Transparent 
ink,” shows how.

Stage background color chip
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Using the Background Transparent ink

When you apply the Background Transparent ink to a sprite, its 
background color becomes transparent. Whatever happens to be 
behind it on the stage shows through where the background color 
used to be.

The effects of the Background Transparent ink are similar to, but not 
quite the same as those of the Matte ink. The Matte ink makes the 
background color around a sprite transparent. The Background 
Transparent ink, however, makes the background color transparent 
not just around the sprite, but anywhere it appears within the sprite as 
well.

Matte ink

The Matte ink makes
the background
around a sprite
transparent…

…but leaves the
background color
within the sprite

opaque
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Background Transparent ink

When you apply the Background Transparent ink to the illustration 
of the shrine, the background color you’ve chosen for the stage will 
show through. You’ll also be able to show the moon rising behind 
the shrine.

To apply the Background Transparent ink:

1. Click the score to make it active (or press Command-4).

2. Double-click the 1 beside channel 1 to select all the cells in 
the channel.
Channel 1 contains the information about the shrine.

3. Choose Bkgnd Transparent from the Ink pop-up menu in the 
score.
The white background of the shrine becomes transparent, and 
the color you’ve chosen for the background shows through.

If you don’t like the color you’ve chosen now that it fills the screen, 
change it.

The Background
Transparent ink makes

the background color
transparent wherever

it appears in a sprite
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Changing layering

Now that you’ve applied the Background Transparent ink to the 
shrine, you can move the moon behind the shrine.

The way sprites are layered—whether a sprite appears in front of or 
behind another sprite—is determined by the channels the two sprites 
occupy. A sprite that’s in a channel closer to the top of the score 
appears behind a sprite that’s in a channel closer to the bottom. The 
sprite in channel 1 appears behind the sprite in channel 2, channel 2 is 
behind channel 3, and so on.

When you add a sprite to a channel that’s closer to the bottom of the 
score than another channel already occupied by a sprite, it’s like 
placing a new layer on top of the existing one.

To move the moon behind the shrine:

1. Double-click the 2 beside channel 2 to select all the cells in 
the channel.

2. Click the Shuffle Backward button at the bottom of the 
score window.
Director swaps the information in channels 1 and 2. On the stage, 
the moon moves behind the shrine.
Basic Animation 37



Run the animation again to see how it looks now that you’ve 
switched the channels that the moon and the shrine occupy:

1. Choose Control Panel from the Window menu (or press 
Command-2) to make the control panel active.

2. Click the Rewind button.
Director moves the playback head to frame 1. The control panel 
also shows the current location of the playback head: the number 
of the frame where the playback head is located appears in the 
frame counter.

3. Click the Play button.
The moon rises into the sky behind the shrine.

Save the changes you’ve made to the animation in this section:

þ Choose Save from the File menu (or press Command-S).

Frame counter
Chapter 138



Step recording

Director has many different techniques you can use to animate cast 
members in addition to real-time recording. Step recording is the 
process of animating by taking snapshots of the position of a cast 
member in successive frames of a movie. You record the position of a 
cast member in a frame, step forward to the next frame, move the cast 
member to its new position, record that position, step forward to the 
next frame, and so on until you’ve completed the animation.

This section shows how to produce the same animated sequence you 
created in the previous section—the moon rising over the shrine—
using step recording rather than real-time recording.

Using In-Between Linear

The In-Between Linear command has two main uses: to create the 
intermediate frames in an animated sequence and to fill a number of 
frames with a static image.

When you recorded the moon rising over the shrine in real time, 
Director automatically recorded the position of the shrine at the same 
time it recorded the path of the moon. That doesn’t happen when 
you use other animation techniques. Instead, you need to use a tool 
such as the In-Between Linear command to make sure the 
background you want to appear on the stage behind an animation is 
inserted in the same frames where you create the animation.

The steps that follow show how to use In-Between Linear to fill 
enough frames with the image of the shrine so that it remains on the 
screen during the animation of the moon rising.
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First open the movie with the shrine and the moon you’re going to 
use to create the animation:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Scene,” and then click Open.
If “Scene” doesn’t appear in the dialog box, go to the folder 
named Macromedia Director 4.0, open the Tutorials folder, and 
then open the Learning Director folder.

To fill the frames with the image of the shrine:

1. Go to the score, select the first cell in channel 1, and then 
Shift-click the cell in frame 8.
Director highlights cells 1 through 8.
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2. Choose In-Between Linear from the Score menu (or press 
Command-B).
Director fills the range of cells with the image of the shrine. In 
the score, notice the dots over the information in frames 1 to 8. 
The dots indicate that the sprites in the cells were produced by 
in-betweening. 

Dots indicate in-betweening
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Preparing the moon

Before you record the moon rising, you need to move the moon to 
the stage and apply the Matte ink to it to make its bounding box 
transparent.

Drag the moon to the stage:

1. Select cell 1 in channel 2.

2. Drag the moon from the cast window to the stage. Position 
it like this:

You of course want the moon to rise behind rather than in front 
of the shrine, but once again it’s easier to set up the animation in 
front, where you can see it, and then move the moon behind the 
shrine afterwards.
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Apply the Matte ink:

1. Click the score to make it active (or press Command-4).
Cell 1 in channel 2 is still selected. It contains the information 
about the moon’s position on the stage.

2. Choose Matte from the Ink pop-up menu in the score.
The bounding box surrounding the moon disappears.

Ink pop-up menu
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Step recording the moon rising

Director automatically shifts into step-record mode whenever you 
drag a cast member from the cast window to the stage or the score. 
You can tell by the heavy selection rectangle that appears around the 
cast member’s sprite and by the step-record indicator next to the 
channel where Director is storing information about the sprite.

◆ To start step-record mode when it’s not active, you select the 
sprite you want to record and then hold down the Option key 
and click the sprite again; you can also go to the score, hold 
down the Option key and click the number to the left of the 
channel that contains the sprite you want to record.

◆ To create animation when step-record mode is active, you click 
the Step Forward button on the control panel to move the 
playback head to the next frame, position the sprite where you 
want it to appear in that frame, and then step to the next frame.

◆ To stop step-record mode, you click the Play, Rewind, or Step 
Backward button on the control panel, or drag the playback head 
in the score.

Step-record indicator

Heavy selection rectangle
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When you’re step recording more than one sprite at a time, it’s 
important to keep track of which sprites you’re working with. The 
easiest way to do that is to select every sprite you want to record. 
When you select a sprite under normal conditions, Director displays a 
thin selection rectangle around the sprite. When Director is recording 
a sprite in step-recording mode, it changes the thin selection rectangle 
around the sprite to a thick selection rectangle. It’s important to 
remember, however, that what determines whether a sprite is being 
recorded is not a thick selection rectangle around it, but a step-record 
indicator next to the channel the sprite occupies. A thick selection 
rectangle appears around a sprite that Director is recording only if the 
sprite happens to be selected.

To step record the moon rising:

1. Make the control panel active.
A heavy rectangle should still appear around the moon to show 
that Director is recording it, and a step-record indicator should 
still appear next to channel 2. If that’s not the case:

p Select cell 1 in channel 2 to select the moon.

p Hold down Option and click the moon.

2. Click the Step Forward button on the control panel (or 
press Command-right arrow).
The playback head in the score moves to the next frame and 
copies the information about the sprite there.
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3. Drag the moon slightly up and to the right, like this:

4. Click the Step Forward button on the control panel again.
The playback head in the score window moves to the next frame.

Note Make sure you don’t click any of the other buttons on the control panel or 
Director will stop recording.

5. Drag the moon slightly.
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6. Repeat steps 4 and 5 five more times, until the moon is 
positioned over the shrine like this:

þ Rewind the movie, and then run it to see what the 
animation looks like.
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Changing layering

Move the moon behind the shrine:

1. Select everything in channel 2.

2. Click the Shuffle Backward button at the bottom of the 
score window.
Director swaps the information in channels 1 and 2 in the score. 
On the stage, the moon moves behind the shrine.

þ Rewind the movie, and then play it to see how the 
animation looks now.
Remember that you can close all the windows that are open by 
pressing Command-1.

Save the changes you’ve made to the animation:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Moon 2,” and click Save.
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Animating with In-Between Linear

Earlier you used In-Between Linear to fill a series of frames with the 
illustration of the shrine. You can also use In-Between Linear to 
automatically produce the intermediate frames in an animation once 
you’ve set the starting and ending positions of the sprite you want to 
animate. (Frames that mark key positions in an animated sequence are 
called key frames.)

To animate the moon rising with In-Between Linear:

1. Go to the score, select cells 2 through 8 in channel 1, and 
then choose Clear Cells from the Edit menu (or press 
Delete).
Director erases the information in the cells.

2. Select cell 8 in channel 1.
Cell 8 marks the end point of the animation. When you use In-
Between Linear, you set just the beginning and end of an 
animated sequence, and then let Director calculate the 
intermediate positions in the sequence.

3. Make the cast window active, and drag the moon to its final 
position on the stage.

4. Make the score active, and choose Matte from the Ink pop-
up menu to remove the white rectangle around the moon.

5. Shift-click cell 1 in channel 1 to select the entire range of 
cells.

6. Choose In-Between Linear from the Score menu (or press 
Command-B).
Director fills in the cells between the beginning and ending 
frames with an equally spaced set of in-between positions for the 
moon.

þ Rewind the movie, and then play it to see the results.

Save the changes you’ve made to the animation:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Moon 3,” and click Save.
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Using In-Between Special

In-Between Linear is a simple and straightforward way to create 
animation. But it always creates animation that proceeds along a 
straight path—which may not always be the kind of path you want to 
create. If you want to animate something that moves along a curve or 
in a circle, you can use In-Between Special.

Animate the moon rising along a curved path:

1. Select all the cells in channel 1 except for the first and last 
ones, and then choose Clear Cells from the Edit menu (or 
press Delete).
Deleting everything but the first and last cells leaves the key 
frames—the frames that define where the animation starts and 
stops. To create a curved animation, you need to add a third key 
frame between the moon’s beginning and ending points to define 
the arc of the curve.

2. Select cell 5 in channel 1.
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3. Make the cast window active, and drag the moon to a spot 
on the stage between the starting and ending points of the 
animation:

4. Make the score active, and choose Matte from the Ink pop-
up menu to remove the white rectangle around the moon.

Starting point

Set the third key
point here

Ending point
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Set up the path you want the moon to follow:

1. Select the first cell in Channel 1, and then Shift-click the 
last cell in the same channel to select the entire range.

2. Choose In-Between Special from the Score menu (or press 
Command-Shift-B).
The In-Between Special dialog box appears.

3. Select Location as the In-Between option (make sure none 
of the other options are selected).

4. Drag the Path slider as far as it will go to the Outside end.
Dragging the slider changes the curvature of the path. The effect 
of the setting you choose is shown by the way the square above 
the slider changes.

5. Click Preview Path to see the path the moon will follow.
Director removes the dialog box and draws the path on the stage.

Path slider
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If the path doesn’t look right:

1. In the score, select cell 5 in channel 1.
Cell 5 contains the third key frame.

2. On the stage, adjust the position of the moon.

3. Go back to the score, and select the entire range of cells in 
channel 1.

In-Between the key frames:

1. Choose In-Between Special from the Score menu again (or 
press Command-Shift-B).
The In-Between Special dialog box reappears. The settings you 
selected are still set.

2. Click OK.
Director creates the positions of the moon along the path 
between the key frames.

3. Rewind the movie and play it to see the results.

Save the changes you’ve made to the animation:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Moon 4,” and click Save.

If you’d like to see the results of in-betweening using the Inside curve 
setting in the In-Between Special dialog box, clear the in-betweened 
cells from the score, and repeat the process.
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Creating a projector

One of the best things about Director is that you can turn any movie 
you create into a projector. A projector is a movie that’s packaged 
with a play-only version of Director built into it. That means anyone 
can play the movie—even people who don’t own a copy of Director.

To create a projector:

1. Choose Create Projector from the File menu.
If you’ve made changes to the movie since the last time you 
saved it, a message appears asking you if you want to save the 
changes. Click Save if you want to save the changes, or Don’t 
Save if you don’t.

The Create Projector dialog box appears.

The names of the movies in the current folder appear in the 
Source Movies list, on the left side of the dialog box.

2. Select “Moon 4,” and then click Add.
Director transfers “Moon 4” to the list on the right side of the 
dialog box.
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If “Moon 4” doesn’t appear in the dialog box, go to the folder 
named Macromedia Director 4.0, open the Tutorials folder, and 
then open the Learning Director folder.

For a complete explanation of all the options that are available 
when you create a projector, see “Create Projector” in Chapter 
6, “Menu Reference,” in Using Director.

3. Click Create.
The Save dialog box appears.

4. Name the projector “Moonrise,” and then click Save.
Director produces a projector version of the movie. (The 
projector and the movie are separate files; Director preserves the 
movie in its original form when it creates the projector.)

5. Click Done to remove the Create Projector dialog box from 
the screen.

To play the projector:

1. Choose Quit from the File menu (or press Command-Q) to 
quit Director.

2. Go to the folder named Macromedia Director 4.0, open the 
Tutorials folder, and then open the Learning Director folder.

3. Double-click the icon named “Moonrise” to play the 
projector.
The stage appears, the moon rises over the shrine, and then the 
stage disappears from the screen.

The disappearance of the stage may seem abrupt, but that’s because 
the animation is so short. It nonetheless demonstrates the function of 
a projector, which is simply to play a movie. A projector doesn’t 
provide access to any of Director’s windows, menus, or tools—and 
that means that no one can make any changes to the movie you’ve 
created. It’s also not possible to open a projector in Director and edit 
it that way.

The stage doesn’t, however, have to vanish as soon as the animation 
in a movie ends. You can give users some degree of control over a 
movie, such as whether they want to quit the movie or run it again. 
For information, see Chapter 8, “Adding Interactivity to a Movie.”
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Chapter 2

Creating Text in the Paint 
Window

Director has two text tools: one in the paint window and one in 
the tools window. You can use either to create text—but the text 
you create with the two tools isn’t identical.

Text you create in the paint window is bitmapped (bitmapped 
text is stored as a graphic image of the text). Text you create with 
the tools window or in a text window is QuickDraw text 
(QuickDraw text is stored as the information that defines the 
text—the letters you’ve typed, the font, size, and style you’ve 
chosen, and so on).
Creating Text in the Paint Window 57



Paint window text 

Because the text you create in the paint window is bitmapped, 
Director can animate it faster than text you create in a text window 
or with the text tool in the tools window. You can also use the paint 
window’s ink effects on bitmapped text, and you don’t have to worry 
about whether users have the fonts you’re using installed on their 
systems. The disadvantage of bitmapped text is that once you’ve 
created it, you can’t edit it: if you want to change what you’ve typed, 
you have to erase it and type it again.

Tools window and text window text 

Any text that you create with the text tool in the tools window, you 
can also display in a text window. And any text that you create in a 
text window, you can edit with the tool window’s text tool once 
you’ve place the text on the stage. The link between the two is the 
cast window: text created with either the tools window or in a text 
window becomes a text cast member in the cast window.

QuickDraw text takes less space than bitmapped text because 
Director saves only the information that defines the text, not every 
pixel that makes up the image of the text. QuickDraw text also looks 
much better when it’s printed (so it’s the better choice when you plan 
to print frames of a movie, say, for handouts). Perhaps most 
important, you can edit QuickDraw text after you’ve created it.

If you prefer working with QuickDraw text but you want to take 
advantage of Director’s ability to animate bitmapped text faster, you 
can create and edit the text with the tools window or in a text 
window, and then use the Convert to Bitmap command on the Cast 
menu to change it into bitmapped text. (See Chapter 6, “Menu 
Reference,” in Using Director for more information.)

This chapter covers the basics of creating text in the paint window. 
The examples take about half an hour to work through.
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Before you start:

1. Start Director if it isn’t still running.

2. Make sure that looping is turned off.
When looping is on, there’s a check mark next to Looping on 
the Edit menu, and the Loop button on the control panel is 
down. To turn looping off, choose Looping from the menu to 
remove the check mark next to it, or click the Loop button on 
the control panel.
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Creating a title for a movie

The first experiment in this chapter shows how to create a title screen 
in the paint window using two different sizes of text. It also shows 
how to use the Switch ink to change the color behind the text 
without affecting the color of the text itself. You’ll also find out how 
to move the text from the paint window to the stage.

Selecting foreground and background colors

The first step in creating text in the paint window is to select the 
foreground and background colors you want to use. The foreground 
color determines the color of the text itself. The background color 
sets the color of the bounding box around the text.

Open the movie that you’re going to add the text to:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Title,” and click Open.
If “Title” doesn’t appear in the dialog box, go to the Macromedia 
Director 4.0 folder, open the Tutorials folder, and then open the 
Learning Director folder.

When the file opens, an image of the shrine you worked with in 
the previous chapter appears on the stage.

Foreground color Background color
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Open the paint window:

1. Choose Paint from the Window menu (or press 
Command-5).
When the paint window appears, the moon is in the drawing 
area.

2. Click the Add button (or press Command-Shift-A) to create 
a new cast member.
The moon disappears from the window, and Director displays a 
blank drawing area.

Text tool

Foreground color chip
Background color chip
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Select the foreground color:

1. Point to the foreground color chip and hold down the 
mouse button to display the color palette.

2. Drag the pointer to black, located in the last chip in the last 
row.
The foreground color chip changes to the color you’ve selected.

Select the background color:

1. Point to the background color chip and hold down the 
mouse button.

2. Drag the pointer to white in the first chip in the top row.
The background color chip changes to the color you’ve selected.

Note The background color chip affects only the background color of a text block and 
the second color in a pattern.

Select black

Select white
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Using the text tool

To type text:

1. Select the text tool.
When you move the pointer to the drawing area, it changes into 
an I-beam.

2. Go to the Text menu, and select New York from the Font 
submenu.

3. Select 18 point from the Text menu’s Size submenu.

4. Select Bold from the Text menu’s Style submenu.

Note You can also change the font, size, and style—as well as the foreground and 
background colors—after you type the text, as long as you do so before you set 
another insertion point or select another tool.

5. Click the I-beam to set the insertion point in the drawing 
area, and type:
Noh Tale to Tell 

The text appears in the foreground color you’ve chosen. (The 
background color—when you choose a color other than white—
doesn’t appear until you set another insertion point or select 
another tool.)

Mixing two sizes of text

Suppose you want to make the N in “Noh Tale to Tell” twice as 
large as the rest of the text. One of the disadvantages of creating text 
with the text tool in the paint window is that all the text in a single 
block has to be a single font, size, and style. To create an N that’s 
twice as large as the rest of the text, you need to create a separate text 
block containing the large N, and then align it with “oh Tale to 
Tell.”
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To create the large N:

1. Click the I-beam in a different spot to set the insertion 
point there.

2. Choose 36 point from the Text menu’s Size submenu.

3. Type N.

Erase the smaller N at the beginning of “Noh Tale to Tell”:

þ Select the eraser, position it over the smaller N, and click.
The N disappears.

Using the lasso

You can use either the lasso or the selection rectangle tool to select 
images in the paint window. The lasso works best for images that 
aren’t rectangular.

Both the lasso and the selection rectangle tool have Shrink and No 
Shrink modes:

◆ The lasso’s Shrink mode fits the selection marquee to the shape of 
the image, excluding the background entirely; the selection 
rectangle tool’s Shrink mode reduces the selection marquee to 
the smallest rectangle that can contain the image.

◆ The lasso’s No Shrink mode selects exactly the area you outline, 
including both background and foreground colors; the selection 
rectangle tool’s No Shrink mode selects the entire area inside the 
rectangle you draw.

Lasso’s Shrink mode Selection rectangle’s Shrink mode

Lasso’s No Shrink mode Selection rectangle’s No Shrink mode
Chapter 264



Use the lasso to select the letter N:

1. Point to the lasso icon, hold down the mouse button, and 
choose Shrink from the pop-up menu that appears.

2. Use the lasso to draw a circle around the letter N.
You don’t have to draw a complete circle with the lasso. If the 
two ends of the line don’t cross when you release the mouse 
button, Director connects them with a straight line.

The N starts to flash.

˛ Tip Try selecting the letter N with lasso’s No Shrink mode selected, and then with 
the selection rectangle tool’s Shrink and No Shrink modes selected to see how 
they work.

3. Point to the N, hold down the mouse button, and drag it to 
align it with “oh Tale to Tell.”
You can adjust the N’s position one pixel at a time using the 
arrow keys on the keyboard.

4. Click anywhere outside the N to deselect it.
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Using the Switch ink

The Switch ink lets you use the paintbrush to replace one color with 
a different color.

Normally when you use the paintbrush, the color you’re using covers 
anything you drag the brush over. The Switch ink changes the way 
the paintbrush works. Instead of indiscriminately covering everything 
with the current foreground color, the Switch ink covers only the 
areas where a specific color you’ve selected appears—switching the 
selected color to a different color.

One of the things you can do with the Switch ink is to paint the 
background behind an image you’ve already created. The steps that 
follow show how to paint a background such as this behind the text 
you’ve created:

The paintbrush normally 
works like this

The paintbrush works like 
this when the Switch ink is 
in effect
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The first step is to select the color you want to change:

þ Select the eyedropper and use it to click the background 
color behind the text.

The foreground color chip changes to the color you’ve clicked 
with the eyedropper—the white of the background.

One of the important things to remember about the Switch ink is 
that it reverses the way the foreground color chip works: instead of 
using the foreground color chip to choose the color you want to 
paint with, you use it to identify the color you want to replace.

The next step is to choose the color you want to use in place of the 
background color behind the text:

þ Point to the destination color chip, press the mouse button, 
and when the palette appears, choose one of the reds.
When you’re using the Switch ink, the destination color chip—
not the foreground color chip—identifies the color that you paint 
with.

Click the eyedropper here

Destination color chip
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Next, select the brush shape you want to use and then paint the 
background behind the text:

1. Double-click the paintbrush.
The Brush Shapes dialog box appears.

2. Chose the shape fourth from the left in the top row.

3. Click Set.

Note If the color in the foreground color chip has changed, it’s because Color Sticks 
to Brush Tools is selected in the Paint Window Options dialog box. The 
foreground color that has appeared is the one you use with the paintbrush most 
recently. Choose Paint Window Options from the Paint menu, deselect Color 
Sticks to Brush Tools, and then repeat steps 1, 2, and 3.

Choose this shape
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4. Select Switch from the Ink pop-up menu.

5. Drag the paintbrush slowly to paint over the text like this:

As you paint, the background changes to red, but the text is 
unaffected.

Note Ink effects normally stick to the last tool you’ve used them with—which means 
that the next time you choose the paintbrush, Director will automatically select 
the Switch ink from the Ink pop-up menu. If you don’t want ink effects to 
stick to the tools you use them with, choose Paint Window Options from the 
Paint menu, and uncheck Ink Effect Sticks to Tool in the dialog box that 
appears.

Ink pop-up menu
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Moving text to the stage or score

Director automatically places the text in the cast window, as it does 
with anything you create in the paint window. You don’t, however, 
have to go to the cast window to move the text to the stage or score. 
You can use the paint window’s Place button to move the text 
directly from the paint window to the stage or score.

To move the text to the stage:

1. Make the score active, and then select cell 10 in channel 3.
Selecting a cell in the score sets the moment in the movie when 
you want the title to appear. Selecting cell 10 means that the title 
will appear in frame 10, after the moon has risen over the shrine.

2. Make the paint window active again.

3. Point to the Place button, and hold down the mouse button.
The pointer changes to a hand.

4. Drag the hand to the stage.
As soon as the hand moves out of the paint window and onto the 
stage, a dotted outline representing the text appears. When you 
release the mouse button, the text appears on the stage.

5. Close the paint window, and move the score toward the 
bottom of the screen.

Place button
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6. Position the title like this:

The bounding box around the title is opaque, so you need to use 
the Matte ink to make it transparent.

7. Make the score active, and then choose Matte from the Ink 
pop-up menu.
The white box surrounding the title disappears.

Rewind the movie, and then play it to see how the title fits in with 
the animation.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Title 1,” and then click Save.
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Creating a title using the Reveal and Transparent inks

The second experiment in this chapter shows how to create another 
title treatment. The second experiment uses the Reveal ink to create 
an irregular rice paper background for the title. It also shows how to 
use the Transparent ink to make the background behind the title text 
transparent.

Using the Reveal ink

Suppose you’re creating the title screen for Noh Tale to Tell and 
instead of using a solid color behind the title, you decide on a scanned 
image of rice paper as the background. But you don’t want to display 
just a rectangle of rice paper, you want to paint the rice paper on to 
the background in an irregular shape that looks something like this:

You can create an effect such as that using the Reveal ink. The 
Reveal ink works like this: Imagine a cast member and the 
background behind it painted on a pane of glass that covers another 
cast member. As you use the Reveal ink to paint over the cast 
member in front, you remove the cast member and its background, 
revealing the other cast member underneath.
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Here’s how to use the Reveal ink:

1. Choose Open from the File menu (or press Command-O).
The Open dialog box appears.

2. Select the file named “Reveal,” and then click Open.
If Reveal doesn’t appear in the dialog box, go to the Macromedia 
Director 4.0 folder, open the Tutorials folder, and then the 
Learning Director folder.

A movie that looks much like the one you used in the previous 
example appears.

3. Make the cast window active.

Cast member 3 is the scanned image of the rice paper, and cast 
member 4 is a template for the shape you want to create. (You don’t 
need a template for the Reveal ink to work; the template is provided 
just to make the example easier to follow.)

Cast member
underneath

Cast member in front

Area painted with the 
Reveal ink

Rice paper Template for shape
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One essential when you use the Reveal ink is this: in the cast 
window, the cast member you’re revealing must be located 
immediately to the left of the cast member where you’re using the 
Reveal ink.

To paint with the Reveal ink:

1. Double-click cast member 4 to display the template in the 
paint window.

2. Select the paint bucket.

3. Choose Reveal from the Ink pop-up menu.

4. Fill the template with the Reveal ink.
The rice paper background fills the template.

Remember that unless you’ve unchecked Ink Effect Sticks to 
Tool in the Paint Options dialog box, Director will automatically 
select the Reveal ink the next time you choose the paint bucket.

Using the Transparent ink

The next step in creating the title is to type the text of the title on the 
irregular rice paper background you just created with the Reveal ink.

If you simply type the text of the title on the rice paper, you end up 
with an opaque bounding box around the text. The result looks like 
this:

To make sure that the rice paper shows through the bounding box 
around the text, you need to use the Transparent ink.
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Add the text of the title to the rice paper background:

1. Select the text tool.

2. Use the foreground color chip to select black from the 
color palette.
The foreground color chip sets the color of the text you’re about 
to type.

3. Change the selection on the Text menu’s Size submenu 
from 36 point to 18 point.

4. Choose Transparent from the Ink pop-up menu.

5. Click the I-beam on the rice paper to set the insertion point, 
and type:
Noh Tale to Tell 

6. Click anywhere else in the drawing area.
The bounding box around the text disappears, and you can see 
the rice paper through the letters.

Remember that unless you’ve unchecked Ink Effect Sticks to 
Tool in the Paint Options dialog box, Director will automatically 
select the Transparent ink the next time you choose the text tool.

Ink pop-up menu
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Placing the text on the stage

To place the text on the stage:

1. Make the score active, and then select cell 10 in channel 3.
Selecting cell 10 means that the title will appear in frame 10, after 
the moon has risen over the shrine.

2. Make the paint window active again.

3. Point to the Place button, and hold down the mouse button.
The pointer changes to a hand.

4. Drag the hand to the stage.
As soon as the hand moves out of the paint window and onto the 
stage, a dotted outline representing the text appears. When you 
release the mouse button, the text appears on the stage.

5. Close the paint window.

6. Position the title like this:

The bounding box around the title is opaque, so you need to use 
the Matte ink to make it transparent.

7. Make the score active, and then choose Matte from the Ink 
pop-up menu.
The white box surrounding the title becomes transparent.

Rewind the movie, and then play it to see how the title fits in with 
the animation.
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Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Title 2,” and then click Save.
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Chapter 3

Creating Text with the Tools 
Window

As mentioned in the previous chapter, the text tool in the tools 
window creates QuickDraw text rather than bitmapped text, like 
the paint window’s text tool.

The examples in this chapter show how to create text using the 
text tool in the tools window, and also how to add margins, a 
border, and a drop shadow to the text you’ve created. You’ll also 
find out how to convert QuickDraw text to bitmapped text.

The chapter covers techniques you can use to draw and place 
objects precisely: the examples show how to use the rulers in the 
paint window to create a box of a precise size to limit the area 
where the text appears and how to use the Sprite Info command 
on the Score menu to place the box at a precise location on the 
stage.
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The chapter also demonstrates several more of Director’s graphics 
features: using the tools window’s drawing tools, using two more of 
the score window’s ink effects (Blend and Background Transparent), 
changing the text cast member’s color depth to 1 bit to save disk 
space, and then colorizing the 1-bit cast member.

The examples in this chapter take about half an hour to work 
through.

Before you start:

1. Start Director if it isn’t still running.

2. Make sure that looping is turned off.
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Creating text on the stage

When you create text with the text tool in the tools window, you 
create it directly on the stage.

Defining the size of the text block

When you type text directly onto the stage, you may need to define 
the exact boundaries of the area where you want the text to appear—
to prevent it from spilling over into areas you’ve set aside for other 
things. You can define an area by creating a box of exact dimensions 
in the paint window, placing the box on the stage, and then typing 
the text inside the box.

Open the movie that contains the background for the text:

1. Choose Open from the File menu.
The directory dialog box appears.

2. Select the file named “Text,” and then click Open.
If “Text” doesn’t appear in the dialog box, go to the Macromedia 
Director 4.0 folder, open the Tutorials folder, and then open the 
Learning Director folder.

Open the Paint window:

1. Choose Paint from the Window menu (or press 
Command-5).
When the paint window appears, the shrine scene is in the 
drawing area.

2. Click the Add button to create a new cast member.
The shrine scene disappears from the window, and Director 
displays a blank drawing area.
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To create a box of exact dimensions:

1. Choose Show Rulers from the Paint menu (or press 
Command-Shift-K).
Rulers appear along the top and left edges of the Paint window.

2. Click the units indicator in the upper left corner of the 
drawing area until Pixel appears.
Changing the indicator changes the unit of measurement to 
pixels. When you select pixels as the unit of measurement, each 
major division marks 100 pixels (a single pixel is only 1/72nd of 
an inch). The numbers on the ruler represent hundreds of pixels, 
not individual units (for example, 1 stands for 100 pixels).

Click here to change the
unit of measurement
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3. Resize the paint window if you need to so that you can see 
the 220 pixel mark on the top ruler and the 100 pixel mark 
on the left ruler.

4. Click the left side of the rectangle tool to draw an unfilled 
rectangle.

5. Choose black as the foreground color and white as the 
background color.

6. Choose the thinnest line width.

Each major division equals 100 pixels

100 pixel mark

220 pixel mark

Choose this line width
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7. Start at the spot in the drawing area that corresponds to 
the zero mark on both the rulers, and draw a rectangle 220 
pixels wide by 100 pixels long.
The result looks like this:

Hide the rulers:

þ Choose Hide Rulers from the Paint menu (or press 
Command-Shift-K) again.
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Positioning the rectangle precisely on the stage

You can enter a set of coordinates in the Sprite Info dialog box to 
position a cast member at an exact spot on the stage.

Remember that when you place a cast member on the stage, Director 
displays a sprite based on the cast member—not the cast member 
itself—on the stage. It stores information about the sprite (its location 
on the stage, any ink effect you’ve applied to it, and so on) in a cell in 
the score. You can see a summary of the information about a sprite if 
you select Extended from the Display pop-up menu in the score 
window.

For an explanation of what the notation in the score means, see “The 
score window” in Chapter 5, “Window Reference,” in Using 
Director.

Before you move the rectangle to the stage, select the cell in the score 
where you want Director to record the information about the 
rectangle:

1. Make the score active.

2. Select the first cell in channel 2.

Display pop-up menu
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Move the rectangle to the stage:

1. Make the paint window active.

2. Point to the Place button, hold down the mouse button, and 
then drag the pointer to the stage.

3. Close the paint window.

Position the rectangle:

1. Make sure the rectangle is still selected.

2. Choose Sprite Info from the Score menu (or press 
Command-K).
The Sprite Info dialog box appears.

3. In the Location section at the bottom of the dialog box, 
type 108 as the number of pixels from the left edge of the 
stage and 72 as the number of pixels from the top edge.
Since there are 72 pixels to an inch, 108 pixels places the upper 
left corner of the rectangle 1-1/2 inches from the left edge of the 
stage, and 72 pixels places it 1 inch from the top edge.

4. Click OK.
Director positions the rectangle where you’ve indicated on the 
stage.
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Using the text tool

To create text with the text tool in the Tools window:

1. Choose Tools from the Windows menu (or press 
Command-7) to display the Tools window.

2. Choose black as the foreground color and white as the 
background color.

3. Click the text tool.

4. Position the text pointer in the upper left corner of the 
rectangle you’ve drawn, hold down the mouse button, and 
drag to the right to draw a text box.
You can make the box as wide as you want, but Director lets you 
make it high enough for only a single line. The box will expand 
automatically as you enter text in it.

5. Type:
Out of the mists a village girl appeared, unbidden, quite 
unexpected. He asked her name. 

Don’t worry about the exact size or position of the text right now. 
You’ll adjust it later.

Text tool

Foreground color chip
Background color chip
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Save the changes you’ve made to the original file as a new movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the file “Text 1,” and click Save.

You’re going to continue working with the same movie in the next 
section.

Setting the font, size, and style of QuickDraw 
text

You set the font, size, and style of QuickDraw text after you’ve typed 
the text.

To set the type characteristics of the text you’ve just typed:

1. Select the text block if it isn’t still selected.
If you can’t get a selection rectangle to appear around the text 
block, it’s because the art behind the text is selected. Click the 
white border around the background art to deselect the 
background art, then click the text block to select it.

You can also select the text block by selecting cell 1 in channel 3 
of the score. That’s the cell that contains the information about 
the text block’s location on the stage.

2. Highlight the text in the text block.
Highlight the text as you would in any word processing 
application: position the pointer at the beginning of the text, hold 
down the mouse button, and drag to the end of the text. You can 
also triple-click anywhere inside a block of text to highlight all 
the text in the block.

3. Go to the Text menu, and choose Times from the Font 
submenu.

4. Choose 18 point from the Size submenu and Plain from the 
Style submenu.
The text changes to match the settings you’ve chosen.
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If you need to adjust the width of the text:

þ Drag the handle on the right side of the box to the left until 
the dotted outline is inside the rectangle.

To position the text precisely:

1. Make sure the text is still selected.

2. Choose Sprite Info from the Score menu.
The Sprite Info dialog box appears.

3. In the Location section at the bottom of the dialog box, 
type 114 as the number of pixels from the left edge of the 
stage and 78 as the number from the top.
The values that you enter position the text six pixels farther from 
the top and left edges of the stage than the rectangle you drew 
earlier.

4. Click OK.
Director repositions the block of text.

Drag here to change the width of 
the text block
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Using the Scrapbook

One of the pieces of information recorded about a sprite in a cell is a 
sprite’s location on the stage. If you want to save a copy of a sprite—
the cast member as well as the additional information about it 
recorded in a cell—you can do so in the Scrapbook.

Saving a sprite in the Scrapbook

Once you’ve set up a block of text, saving the rectangle you used to 
define the text area is a good idea. If you save it as a sprite, you can 
place it on the stage in other frames in exactly the same location 
where it appears in the current frame just by pasting it into the score. 
Since its location is saved with it in the Scrapbook, you don’t have to 
do anything to reposition it to get it in the same location.

To save the rectangle in the Scrapbook:

1. Select cell 1 in channel 2 of the score.
Cell 1 in channel 2 contains the information about the location of 
the rectangle sprite.

2. Choose Copy Cells from the Edit menu (or press 
Command-C).

3. Choose Scrapbook from the Apple menu.
The Scrapbook appears.
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4. Choose Paste from the Edit menu (or press Command-V).
The information that appears in the Scrapbook looks something 
like this:

5. Close the Scrapbook.
The Scrapbook disappears from the screen.

Since you were using the rectangle just to define the text area, now 
that you’ve typed the text you can remove the rectangle:

1. Select the cell in frame 1 of channel 2 of the score, if it 
isn’t still selected.

2. Choose Clear Cells from the Edit menu (or press Delete).
The information is removed from the cell, and the rectangle 
disappears from the stage.
Creating Text with the Tools Window 91



Copying a sprite from the Scrapbook

Copy the sprite you just saved in the Scrapbook:

1. Choose Scrapbook from the Apple menu.

2. Locate the sprite information.

3. Choose Copy from the Edit menu (or press 
Command-C).

4. Close the Scrapbook.

Paste the sprite in the next frame of the movie:

1. Select cell 2 in channel 2 of the score.
The second background screen in the movie appears.

2. Choose Paste Cells from the Edit menu (or press 
Command-V).
The rectangle appears in the same place it appeared on the 
previous screen.
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Displaying text against the background

þ Click the Rewind button on the control panel (or press 
Command-R) to go back to frame 1.
The shrine scene reappears on the stage.

Now that you’ve removed the rectangle from the shrine scene, you 
can see that the background behind the text you’ve typed is opaque.

Use the Background Transparent ink in the score window to make 
the background transparent:

1. Select cell 1 in channel 3 of the score.
The cell contains the information about the text sprite.

2. Choose Bkgnd Transparent from the Ink pop-up menu.
The background behind the text will become transparent as soon 
as you deselect the text block.

But watch what happens:

þ Click anywhere outside the text block.
Because the text is black, it almost disappears against the 
background.

Ink pop-up menu
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Change the color of the text so it’s easier to see:

1. Select cell 1 in channel 3 of the score to select the text 
block.

2. Highlight the text in the block.

3. Use the foreground color chip in the tools window to 
display the color palette, and then choose a light color 
(such as one of the pale yellows in the top row) for the text.
The text changes to the color you’ve selected.

4. Click anywhere outside the text block to see what the text 
looks like against the shrine scene.

Save the movie:

þ Choose Save from the File menu (or press Command-S).

You’re going to continue working with the same movie in the next 
section.
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Giving a text block a border and drop shadow

One way to display text is to give it a transparent background, as you 
did in the previous section. Another way to display it is with an 
opaque background surrounded by a border with a drop shadow.

This section shows how to create a border and drop shadow using 
Director’s standard options and how to create a more realistic custom 
drop shadow.

Border

Margin

Drop shadow
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Dragging a text cast member to the score

This experiment uses the background in the second frame of the 
movie and a text cast member that’s already in the cast window.

Drag the text cast member to the score:

1. Position the score so that you can see channel 3 when the 
cast window is active.

2. Drag cast member 3 from the cast window to cell 2 in 
channel 3.
Director displays the picture of the girl and places the text in cast 
member 3 in the center of the stage.

Reposition the text block:

1. Make sure the text is still selected.

2. Choose Sprite Info from the Score menu.
The Sprite Info dialog box appears.

3. In the Location section at the bottom of the dialog box, 
type 114 as the number of pixels from the left edge of the 
stage and 78 as the number from the right.
The values that you enter position the text in exactly the same 
place where you positioned the block of text you created on the 
first screen—six pixels farther from the top and left edges of the 
stage than the rectangle you pasted on the screen earlier.

4. Click OK.
Director repositions the block of text.

Delete the rectangle:

1. Select cell 2 in channel 2 in the score.

2. Choose Clear Cells from the Edit menu (or press Delete).
The rectangle disappears.
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Adding a border and drop shadow

Adding a border and drop shadow is easy: you can choose the settings 
from the Border and Box Shadow submenus on the Text menu.

To add a border and drop shadow:

1. Select cell 2 in channel 3 in the score to select the text 
block.

2. Highlight the text.

3. Go to the Text menu, and choose 2 pixels from the Border 
submenu.
A border appears around the text.

4. Choose 2 pixels from the Box Shadow submenu.
A drop shadow appears along the right and bottom edges of the 
border.

You can also add a margin—space between the text and the border.

To add a margin:

1. Make sure the text block is still selected and the text is still 
highlighted.

2. Choose 3 pixels from the Margin submenu.
Director makes the border slightly larger so there’s more space 
between it and the text.

3. Click anywhere outside the text block to see the results.
Creating Text with the Tools Window 97



Choosing a color for the background

Choose a color for the background behind the text:

1. Select cell 2 in channel 3 in the score to select the text 
block.

2. Use the background color chip in the tools window to 
display the palette, and choose a light color.
The background inside the border changes to the color you’ve 
selected.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the file “Text 2,” and click Save.

You’re going to continue working with the same movie in the next 
section.

Creating a realistic shadow

Instead of using the standard drop shadow, you can create a custom 
shadow for the text block—a semi-transparent shadow that only 
darkens the background under the text block rather than blacking it 
out.

A standard drop shadow, while it looks less realistic than a custom 
shadow, has one advantage over the latter: if you change the size of 
the text box, the drop shadow adjusts to the new size automatically. If 
you change the size or position of the text box after you create a 
custom shadow, you have to adjust it by hand.
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To create a realistic shadow, first remove the drop shadow that’s 
currently part of the text block:

1. Select cell 2 in channel 3 in the score to select the text 
block, and then choose None from the Box Shadow 
submenu on the Text menu.
The drop shadow disappears.

2. Click anywhere outside the text block to remove the 
selection rectangle around it.

Create a rectangle the same size as the border that surrounds the text:

1. Choose the filled rectangle tool from the Tools window.

2. Use the foreground color chip in the Tools window to 
display the palette, and choose the gray in the color chip 
sixth from the right in the bottom row.

3. Position the crosshair directly over a corner of the border 
around the text and draw a rectangle that matches it.
The rectangle appears over the text.

4. Drag the rectangle slightly down and to the right like this:

Use this gray
Creating Text with the Tools Window 99



Move the rectangle behind the text block:

þ Click the Shuffle Backward button at the bottom of the 
score window.
The gray rectangle moves behind the text block.

Make the gray rectangle partly transparent by applying the Blend ink 
to it:

1. Make sure the gray rectangle is still selected on the stage.

2. Choose Blend from the Ink pop-up menu in the score 
window.
There may be no visible change in the gray rectangle. That’s 
because not only do you have to apply the Blend ink, you also 
have to set a blend value that indicates how transparent you want 
it to be.

3. Choose Set Sprite Blend from the Score menu.
The Set Sprite Blend dialog box appears.

4. Set the percent to 50, and then click OK.
The dialog box disappears, and the gray rectangle becomes semi-
transparent.

5. Click anywhere outside the rectangle to see the effect.

Save the changes you’ve made to the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the file “Text 3,” and click Save.

You’re going to continue working with the same movie in the next 
section.
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Converting QuickDraw text to bitmapped text

As mentioned in the previous chapter, QuickDraw text takes less 
space than bitmapped text because Director saves only the 
information that defines the text, not every pixel that makes up the 
image of the text. You can often save even more space by converting 
QuickDraw text to bitmapped text and then changing the color 
depth of the text from 8 bits (256 colors) to 1 bit (2 colors).

You can use the Convert to Bitmap command to change QuickDraw 
text into bitmapped text (and to change PICT graphics into 
bitmapped graphics). Before you do that, however, it’s important to 
make sure you have the text set up just the way you want it because 
you can’t edit the text after you’ve converted it.

˛ Tip Just in case you decide you want to make changes after you’ve converted a cast 
member to a bitmap, before you do the conversion, make a duplicate of the cast 
member or save it in the Scrapbook.

To change the text block to a bitmap cast member:

1. In the cast window, select cast member 3.

2. Choose Convert to Bitmap from the Cast menu.
The QuickDraw text icon in the lower right corner of the text 
thumbnail changes to a bitmap icon.

Changing a bitmapped cast member’s color depth

If you’re working with a cast member that has no more than two 
colors, you can save both memory and disk space by changing its 
color depth to 1 bit. (The two colors don’t have to be black and 
white, as the section following this one shows.) Since text is usually a 
single color (and its background is usually transparent or a single 
color), it’s an ideal candidate for reducing to 1 bit.

Color depth is a fairly complex subject. For a thorough discussion of 
it, see Chapter 1, “Working with Cast Members,” in Using Director.
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To change the color depth of the text:

1. Select the cast member 3 in the cast window.

2. Choose Transform Bitmap from the Cast menu.
The Transform Bitmap dialog box appears.

3. Choose 1 Bit from the Color Depth pop-up menu.

4. Select the Remap to Closest Colors option.
The Remap to Closest Colors option selects the colors from the 
new set that’s available that are closest to the cast member’s 
original colors.

5. Click OK.
An alert appears telling you that the change you’re about to make 
can’t be undone.

6. Click OK.
The cast member is converted to a 1-bit cast member. The text 
remains black, but the background becomes white.
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Colorizing a 1-bit cast member

You can choose any two colors for a sprite based on a 1-bit cast 
member—one color for the foreground and one for the background. 
The colors you choose affect only the sprite—the cast member 
remains unchanged.

When you’re working with a text cast member, the foreground color 
you choose determines the color of the text, and the background 
color determines the color of the background behind the text.

To change the color of the text:

1. Select cell 2 in channel 4 in the score to select the text 
block.

2. Use the foreground color chip in the tools window to 
display the palette.

3. Choose a dark blue.
The text—and the border around it—change to the color you’ve 
selected.

To change the color of the background behind the text back to the 
background color you chose earlier:

1. Make sure the text block is still selected.

2. Use the background color chip in the tools window to 
display the palette.

3. Choose the same background color you selected earlier.
The background behind the text changes to the color you’ve 
selected.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the file “Text 4,” and click Save.
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Chapter 4

Animating a Sequence of 
Cast Members

The basic animation techniques in Chapter 1 showed how to 
create animation by moving a single sprite across the stage. 
Animation often involves objects that—unlike the moon—
change as they move. A bird, for example, flaps its wings as it flies 
across the sky. This chapter shows how to create animation using 
a sequence of cast members.

This chapter also covers a second important topic: colorizing cast 
members. The previous chapter demonstrated how to reduce the 
color depth of a cast member from 8 bits to 1 bit. This chapter 
shows the reverse: how to increase the color depth of a 1-bit cast 
member to 8 bits and then change it from a black-and-white cast 
member to a color cast member in a color movie.
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The examples in this chapter take about half an hour to work 
through.

Before you start:

þ Start Director if it isn’t still running.
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Colorizing a cast member

Colorizing a cast member has much the same effect as colorizing a 
black-and-white movie: images that were originally black and white 
now appear in color. Colorizing a cast member serves a somewhat 
different purpose, however. Usually you colorize a black-and-white 
image because you’ve imported it into a color movie and you want it 
to look like the other cast members in the movie.

Increasing a cast member’s color depth

Colorizing a cast member begins with increasing its color depth. 
Changing a cast member’s color depth from 1 bit to 8 bits means that 
you increase the number of colors you can use from 2 to 256.

Color depth, as mentioned in the previous chapter, is a fairly complex 
subject. For a thorough discussion of it, see Chapter 1, “Working 
with Cast Members,” in Using Director.

Open the movie that contains the image of the Buddhist priest used 
in the movie Noh Tale to Tell:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Priest,” and then click Open.
If “Priest” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

A rice paper background appears with grass and a bird in the 
foreground.

Five cast members appear in the cast window: the rice paper, two 
versions of the grass, a bird, and the priest. The current color depth of 
the priest—unlike the other cast members—is 1 bit.
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Change the color depth of the priest cast member so you can 
colorize it:

1. Select the thumbnail of the priest—cast member 5—in the 
cast window.

2. Choose Transform Bitmap from the Cast menu.
The Transform Bitmap dialog box appears.

3. Choose 8 Bits from the Color Depth pop-up menu.

4. Select Remap to Closest Colors, and then click OK.
An alert appears telling you that you can’t undo the change 
you’re about to make.

5. Click OK.
The cast member is converted to an 8-bit cast member.

Filling areas with color

The easiest way to colorize a cast member is to fill solid black or 
white areas in it with color. The steps that follow show how to fill the 
priest’s robe with color.
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Start by displaying the priest in the paint window:

þ Go to the cast window and double-click the thumbnail of 
the priest.
The paint window appears.

Fill the priest’s robe with a color:

1. Select the paint bucket.

2. Select Normal from the Ink pop-up menu.

3. Use the foreground color chip to display the palette.

4. Choose the green in the seventh color chip from the left, in 
the sixth row from the bottom.

5. Position the paint bucket at the shoulder of the robe and 
click.
The front of the robe fills with color.

6. Click inside the bottom part of the robe in the back.
It fills with color.

Foreground color chip

Ink pop-up menu

Choose this green
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Zooming in

Sometimes it’s difficult to work with parts of an image because 
they’re too small to see clearly. When that’s the case, you can magnify 
them so they’re easier to work with.

The two remaining parts of the priest’s robe are easier to fill if you 
zoom in on them.

To zoom in on the back of the robe:

1. Position the paint bucket over the back of the robe and 
hold down the Command key.
The cursor changes to a magnifying glass.

˛ Tip Holding down the Command key when you’re using any of the drawing tools 
changes the cursor to the magnifying glass.

Zoom in here
Zoom in here
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2. Click the mouse button.
Director magnifies the image.

If you want to magnify the image more, choose Zoom In from 
the Paint menu (or press Command-+). When the image is 
magnified as much as it can be, Zoom In appears dimmed.

To finish filing the robe with color:

1. Click the paint bucket in the white area on the back of the 
robe.
It fills with color.

2. Scroll to the front of the robe and fill it with color the same 
way.
Make sure you fill all the white pixels below the priest’s neck.

To switch back to normal view:

þ Hold down the Command key and click anywhere in the 
drawing area.

Colorizing with patterns

You can fill areas with patterns as well as with solid colors. The 
pattern chip, just below the foreground and background color chips, 
shows the pattern that’s currently selected. Use it to display the 
pattern palette, where you choose the pattern you want to use.

Pattern chip

Pattern palette
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The colors of the patterns that appear on the palette are determined 
by the foreground and background colors. If you can’t find a pattern 
you like in the palette, you can create your own. (For information, 
see the Paint menu’s Patterns command in Chapter 6, “Menu 
Reference,” in Using Director.) The bottom row in the pattern palette 
contains tiles. Tiles are multicolored patterns based on a cast member. 
(For information about creating a tile, see “Tiles” in the same chapter 
of Using Director.)

Fill the priest’s hat with a pattern.

You don’t have to change the foreground color—use the same green 
you’ve been using for the priest’s robe.

Flap

Crown

Veil
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Choose a different green for the background color:

þ Use the background color chip to display the palette, and 
choose the green in the fifth row, seventh from the right.

Choose a pattern and fill the priest’s hat:

1. Use the pattern chip to display the pattern palette, and 
choose the crosshatch pattern third from the right in the 
third row from the bottom.

2. Select the paint bucket if it’s not already selected.

3. Click inside the crown of the hat.
The crown fills with the pattern.

4. Click inside the veil to fill it.

5. Zoom in on the flap, and click the paint bucket inside it to 
fill it.

6. Zoom out again when you’re finished.

Choose this green for the 
pattern’s background color

Choose this pattern
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Colorizing with the Switch Colors command

Use the Switch Colors command on the Effects menu to replace a 
specific color used in a cast member with a different color. Switch 
Colors has the same effect as the Switch ink, but it works in a 
different way. When you used the Switch ink in the previous chapter, 
you used the paint brush to paint over the area you wanted to 
change. When you use Switch Colors, you select the area you want 
to change with the lasso or the selection rectangle tool, and then 
choose Switch ink from the Effects menu.

The steps that follow show how to use the Switch Colors command 
to change the color of the priest’s face and foot to a flesh color.

First, select the color you want to replace:

þ Select the eyedropper, and then click the priest’s face.
The foreground color chip changes to white. Notice that the 
foreground color in the destination color selector is also white.

Select the color you want to use in place of white:

1. Use the destination color chip to display the color palette.

2. Choose the pink in the eighth color chip from the right in 
the top row.

Foreground color

Foreground color

Destination color

Choose this pink
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Switch the white areas inside the image of the priest to the pink 
you’ve chosen:

1. Point to the lasso icon, hold down the mouse button, and 
when the pop-up menu appears, make sure that Shrink is 
selected.

2. Select the priest with the lasso.

3. Choose Switch Colors from the Effects menu.
The priest’s face and feet change to pink.

4. Click anywhere in the drawing area to deselect the priest.

The priest is now completely colorized. Place the cast member on the 
stage:

1. Point to the Place button, and hold down the mouse button.
The pointer changes to a hand.

2. Drag the hand to the stage.
As soon as the hand moves out of the paint window and onto the 
stage, a dotted outline representing the priest appears.

3. Close the paint window.
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4. Position the priest like this:

When you release the mouse button, the priest appears on the 
stage. The bounding box around it is opaque, so you need to use 
the Matte ink to make it transparent.

5. Make the score active, and then choose Matte from the Ink 
pop-up menu.
The white box around the priest becomes transparent.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Priest 1,” and click Save.

Leave the movie open after you save it so you can use it in the next 
section.
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Working with a sequence of cast members

This section focuses on three techniques you’ll find invaluable when 
you’re working with a sequence of cast members:

◆ Arranging all the cast members in the sequence on the stage 
simultaneously to align them properly

◆ Using the Space to Time command to transfer the cast members 
you’ve arranged to consecutive cells in a single channel

◆ Using the Paste Relative command to extend an animated 
sequence by pasting a copy of the sequence at the end of the 
original.

Preparing the movie

Before you add the sequence of cast members to the movie, you need 
to do two things to get the movie ready:

◆ Move the bird perched in the grass to the channel below the one 
where the priest is located. Switching the layers where the priest 
and the bird are located has no effect on the way the movie looks, 
it just makes working with the bird easier.

◆ Fill enough frames with the static elements on the stage—the rice 
paper, the grass, and the priest—so they remain on the stage 
while the bird is flying.

To switch the channels the bird and the priest occupy:

1. Select the first cell in channel 6.
A selection rectangle appears around the priest on the stage.

2. Click the Shuffle Backward button at the bottom of the 
score.
Director moves the priest to channel 5 and the bird to channel 6.
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To fill the frames that the animation will occupy with the static 
elements:

1. Select cell 1 in channel 1 and Shift-click cell 10 in channel 
5 to select the entire block.

2. Choose In-Between Linear from the Score menu (or press 
Command-B).
Director copies the information that’s in cell 1 of each channel 
into the rest of the cells you’ve selected.

Arranging a sequence of cast members on the stage

When you create an animated sequence, it’s often useful to place all 
of the cast members on the stage at once—in a single frame—so that 
you can align and space them properly. You can then use the Space 
to Time command, as shown in the next section, to have Director 
transfer the cast members to successive frames in a single channel.

This section shows how to arrange the cast members that make up a 
sequence of a bird taking flight.

First, import the rest of the cast members in the sequence:

1. Choose Import from the File menu (or press Command-J).
The Import dialog box appears.

2. Choose PICT from the Type pop-up menu if it isn’t still 
selected.

3. Open the folder named Bird, and select “Bird 1.”
If the folder named Bird doesn’t appear in the dialog box, go to 
the Macromedia Director 4.0 folder, open the Tutorials folder, 
and then open the Learning Director folder.

4. Click Import All.
Thumbnails showing a bird in three phases of flight appear in the 
cast window.
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Position the cast members that make up the sequence on the stage:

1. Press Command-R to rewind the movie.
Rewinding the movie moves the playback head to frame 1 so 
that the bird perched in the grass appears on the screen.

2. Close the score window so you can see the stage.

3. If you need to, move the cast window so you can see the 
bird perched in the grass.

4. Drag Bird 1 (cast member 6) to the stage and position it just 
above the bird perched in the grass, like this:
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5. Drag the other cast members to the stage one by one and 
position them like this:

Notice that the sequence ends with the same cast member it starts 
with. The reason is that later in this chapter you’re going to use the 
Paste Relative command to paste a copy of the sequence at the end of 
the original to extend the sequence. When you use Paste Relative to 
extend a sequence, the result always looks best when you overlap the 
copy and the original. To make an overlap possible, you need to start 
and end the sequence with the same cast member.

Once you have the cast members aligned and spaced right, you can 
shift them to the same channel. The next section shows how.

Bird 1 (cast member 6)

Bird 2 (cast member 7)

Bird 3 (cast member 8)

Bird 2 (cast member 7)

Bird 1 (cast member 6)
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Using the Space to Time command

The Space to Time command transforms a series of cast members that 
are in separate channels in a single frame into an animated sequence 
by moving the cast members to successive frames in a single channel.

When Director shifts the cast members to a single channel, it 
leaves each one in exactly the same position on the stage where 
you placed it.
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Turn the series of cast members of the bird into an animated 
sequence:

1. Open the score, and select the first cell in channels 6 
through 11.
The first cell in channel 6 contains the information about the bird 
perched in the grass. You include it because it’s really the first cast 
member in the sequence, although unlike the other cast 
members, it’s not repeated as the bird flies.

2. Choose Space to Time from the Score menu.
The Space to Time dialog box appears.

3. Make sure the Number of Frames setting is 1, and then 
click OK.
Director shifts the information from channels 6 through 11 in 
frame 1 to successive frames in channel 6.

þ Rewind the movie, and then play it to see how the 
animation looks.
Turn looping on if you want to watch the animation play over 
and over.

Save the changes you’ve made to the movie:

þ Choose Save from the File menu (or press Command-S).
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Joining two sequences with Paste Relative

The animated sequence you’ve created is, as it stands, too short: it 
ends before the bird reaches the top of the screen. One way to extend 
sequence is to repeat the process you went through to create the first 
sequence as many times as you need to until the entire animation is 
long enough. A less labor-intensive approach is simply to copy the 
sequence you’ve created and then use the Paste Relative command to 
attach the beginning of the copy to the end of the original sequence.

The difference between Paste and Paste Relative is this: If you simply 
paste a copy of the sequence in the cells following the original 
sequence, the animation simply repeats itself in exactly the same place 
on the stage. But if you use Paste Relative, Director automatically 
adjusts the positions of the cast members on the stage so that the first 
cast member in the copy follows the last cast member in the original. 
The result looks like this:

Copy

Original sequence
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To extend the animated sequence using Paste Relative:

1. Select cell 2 in channel 6 and Shift-click cell 6 in the same 
channel to select the sequence.
Don’t include cell 1 in the selection: it contains the bird perched 
in the grass.

2. Choose Copy Cells from the Edit menu (or press 
Command-C).
Director copies the cells to the Clipboard.

3. Select cell 6 in channel 6.
Remember that a copy of a sequence pasted relative to the 
original looks best when:

p The same cast member is at the beginning and end of the 
sequence.

p You overlap the first cell in the copy with the last cell in the 
original.

Since the same cast member is at both the beginning and the end 
of the sequence, Director splices the two together without any 
interruption in the flow of the animation.

4. Choose Paste Relative from the Score menu (or press 
Command-Shift-V).
Director pastes the copy of the sequence into the score.

þ Rewind the movie, and then play it to see the results.

If you want to extend a sequence farther than one copy takes you, use 
the Paste Relative command as many times as you need.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Priest 2,” and click Save.
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Creating a film loop

A film loop is an animated sequence that you can handle as if it were a 
single cast member. For example, another way to create an animation 
of a bird taking flight is to create a film loop of the sequence of sprites 
that show the bird flapping its wings. Then, instead of using the 
frame-by-frame technique where you position each sprite in the 
sequence on the stage one by one, you can set the first and last 
positions of the film loop as if it were a single sprite and then use In-
Between Linear to create the intermediate positions. When you run 
the animation, what you see is the bird flapping its wings as it moves 
across the stage.

A film loop behaves just like any other sprite that’s part of an 
animation with two exceptions. The first is that when you step 
through an animation that contains a film loop (either by using Step 
Forward or Step Backward, or by dragging the playback head in the 
score), the film loop doesn’t animate. Animation occurs only when 
the movie is running. The second is that you can’t apply ink effects to 
a film loop. If you want to use ink effects with a film loop, you need 
to apply them to the sprites that are part of the animation before you 
turn it into a film loop.

To create a film loop of the bird flapping its wings, first open a 
version of the movie that’s slightly different from one that you 
created:

1. Choose Open from the File menu.
The directory dialog box appears.

2. Select the file named “Birdloop,” and then click Open.
If “Birdloop” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The first screen of the movie looks exactly the same as the one you’ve 
been working on, but the animation is somewhat different.
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Play the movie to see what the animation looks like:

1. Go to the control panel, make sure the Loop button is 
pressed, and then click Play button.
The bird flaps its wings in place instead of flying toward the top 
of the screen.

2. Click the Stop button.

The reason that the animation is set up so that the bird remains in 
place as it flaps its wings is this: when you turn the animation into a 
film loop and then move the film loop across the stage, two different 
animations are going on simultaneously. In one—the film loop—the 
sequence of the bird flapping its wings repeats over and over. In the 
other—the series of positions recorded in the score—the film loop 
moves across the stage as if it were a single cast member. There’s no 
need for forward movement in the film loop because movement is 
provided by the series of positions recorded in the score.

To turn the animation of the bird into a film loop:

1. Display a part of the cast window that has an empty cast 
member position, and make sure you can see it when the 
score is active. 

2. In the score, select cell 2 in channel 6 and Shift-click cell 5 
in the same channel to select the range.
Don’t include cell 1 in the selection—it contains the bird perched 
in the grass.

3. Drag the range to the empty position in the cast window.
The Film Loop dialog box appears.

4. Name the film loop “Flying,” and click OK.
Director turns the sequence into a film loop and adds it to the 
cast window.
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Note When you create a film loop, the cast members that are part of it have to 
remain in the cast window.

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Loop 1,” and click Save.

Leave the movie open after you save it so you can use it in the next 
section.

In-betweening a film loop

In-betweening a film loop is an alternative to animating a sequence of 
cast members by setting the position of each one on the stage a frame 
at a time. For example, you can use In-Between Linear and the film 
loop you created in the last section to create an animation that’s 
virtually identical to the one you created earlier in the chapter. 
Instead of using Paste Relative to extend the sequence to the top of 
the screen, you set the film loop cast member at the spots that mark 
the beginning and end of the bird’s path, and then use In-Between 
Linear to create the intermediate positions along the path.

The first step in the process of in-betweening the film loop is to 
remove the animation you used to create the film loop from the 
score:

1. Go to the score, select cell 3 in channel 6 and then Shift-
click cell 5.
Don’t include cell 2 in the selection. It contains the first sprite in 
the animated sequence. You’ll use the sprite in a moment to set 
the beginning of the film loop’s path across the stage.

2. Choose Clear Cells from the Edit menu (or press Delete).
Director removes the information from the cells you selected.

To set the beginning of the film loop’s path at the same spot where 
the first sprite in the animated sequence is located on the stage, 
replace the sprite with the film loop:

1. Select cell 2 in channel 6 of the score.

2. Select the film loop in the cast window.
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3. Choose Switch Cast Members from the Score menu (or 
press Command-E).
Director replaces the sprite with the film loop both in the score 
and on the stage. (There’s no apparent change on the stage 
because the sprite you’ve replaced and the first sprite in the film 
loop are identical.)

To set the spot where the bird’s path ends, first copy the film loop to 
the cell that marks the end of the sequence:

1. Make the score active, and make sure cell 2 in channel 6 is 
still selected.

2. Choose Copy Cells from the Edit menu (or press 
Command-C) to copy the information in the cell.

3. Select cell 10 in channel 6 and choose Paste Cells from the 
Edit menu (or press Command-V).
The information from cell 2 appears in cell 10.

The information that Director copies from cell 2 to cell 10 includes 
not just which sprite to display on the stage, but also where the sprite 
is currently located. 

To set the spot where the film loop’s path ends, you need to drag the 
sprite from its current location to the place on the stage where you 
want it to arrive at the end of the animated sequence.
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þ Drag the bird across the stage until it’s positioned nearly 
off the stage, like this:

To generate the bird’s intermediate positions along the path:

1. Make sure cell 10 in channel 6 is still selected, and then 
shift-click cell 2 in channel 6 to select the entire range of 
cells.

2. Choose In-Between Linear from the Score menu (or press 
Command-B).
Director fills the blank cells with the in-between positions of the 
bird.

þ Rewind the movie, and play it to see the results.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Priest 3,” and click Save.

Position the bird here
Animating a Sequence of Cast Members 129



Chapter 4130



Chapter 5

Working with Sounds

Of all the effects you can create in Director, sounds are among 
the most versatile. You can add voice-overs to provide 
information, music to create a mood, atmospheric sounds to set a 
scene, realistic sounds such as footsteps or explosions to reinforce 
animation, fantastic sounds to enhance special effects—just about 
anything you can imagine.
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Director treats the sounds and music you import into a movie as 
cast members and displays them in the cast window, just like the 
graphics you import. But unlike graphic cast members, which 
appear in the sprite channels of the score, sound cast members 
appear in the two channels set aside for sounds:

Director provides several ways to play sound files and synchronize 
them with the animation in a movie:

◆ In-betweening a sound. If you want to play just enough of a 
sound file to fill a certain segment of a movie, you can in-
between the sound in one of the sound channels just as you in-
between a graphic background in one of the animation channels. 
You use In-Between Linear as described in Chapter 1.

◆ Controlling a sound with a tempo setting. If you want to play 
an entire sound file before the movie continues, you can add a 
tempo setting to the Tempo channel that instructs Director to do 
so. Adding a tempo setting is described in “Playing a sound file 
before continuing,” later in this chapter.

◆ Controlling a sound with Lingo. You can also use Lingo, 
Director’s scripting language, to control sound outside the score. 
Lingo provides much more control over sound files than you can 
achieve in the score, allowing you to fade them in and out and to 
change their volume. For more information, see Chapter 4, 
“Working with Sounds,” in Using Lingo.

Sound channels
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This chapter shows how to import sound cast members and how to 
add them to the score. It also shows how to set up a sound effect you 
want Director to play over and over (such as a horse’s hooves), and 
how to use the Set Tempo command to make sure a sound plays all 
the way through before the movie proceeds.

The examples in this chapter take about fifteen minutes to work 
through.

Before you start:

1. Start Director if it isn’t still running.

2. Make sure that looping is turned off.
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Importing sound cast members

You can import several types of digitized sounds: SoundEdit files 
(such as those that you create with MacRecorder or record with the 
Macintosh microphone), AIFF files, AIFC files, and SND (8-bit) 
resources. You can also use MIDI format files, but to do so, you need 
to write a Lingo statement that uses an external command (XCMD). 
(For more information, see Appendix B, “Using XCMDs,” in Using 
Lingo.)

Open the file you’re going to add the sound to:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Opening,” and then click Open.
If “Opening” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The shrine scene appears on the stage.

The following steps show how to add music to the movie and then 
set up the music so that it plays when the movie’s title is on the 
screen.
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First, import the sound file that contains the music:

1. Choose Import from the File menu (or press Command-J).
The Import dialog box appears.

2. Choose Sound from the Type pop-up menu.

3. Select the file named “Music,” and then click Import.
A thumbnail with the name “Music” and the sound cast member 
icon appears in the cast window.

Type pop-up menu
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Previewing a sound file

If you’re working with a movie that has lots of sounds, you may not 
be able to tell just from a cast member’s name which sound it 
represents. You can use the Play button in the Cast Member Info 
dialog box to play any sound cast member without having to add it to 
the score first.

To preview the sound file you just added to the movie:

1. Select cast member 6 in the cast window.

2. Choose Cast Member Info from the Cast menu (or press 
Command-I).
The Sound Cast Member Info dialog box appears.

˛ Tip You can also display the Sound Cast Member Info dialog box by clicking the 
Info icon at the top of the cast window or by double-clicking the sound cast 
member you want information about.

3. Click the Play button.
Director plays the sound file.

4. Click Cancel to remove the dialog box from the screen.
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Looping Sounds

Some sound files are set to repeat—or loop—over and over. If the 
sound you want to hear is set to loop, select the Looped option in the 
Sound Cast Member Info dialog box to have Director repeat the 
sound.
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Adding a sound to a movie

Adding a sound to a movie is a simple matter of selecting the cell in 
the sound channel where you want the sound to start and then 
choosing the sound from the Set Sound dialog box. 

Add the music to the movie:

1. Make the score active.

2. If the sound channels aren’t visible, click the Jump to Top 
button.

You may have to click the button twice. When you click the 
button the first time, Director moves the script channel to the top 
of the score if it isn’t already positioned there. Clicking the 
button a second time displays the effects channels.

3. Select cell 3 in sound channel 1, and then choose Set 
Sound from the Score menu.
The Set Sound dialog box appears.

Jump to Top 
button
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4. Select “6:Music” and click OK.
The number that precedes “Music” is its cast member number. 
The same number appears in the cell in the sound channel where 
you’ve just set the sound.

5. Rewind the movie and play it.
The title appears for an instant, and if you hear anything at all, it’s 
just a snippet of sound at the beginning of the music. Then the 
movie proceeds.

The reason you hear so little of the music is that it occupies only one 
cell in the sound channel and the playback head moves to the next 
frame before the music can finish playing. The next section, “Playing 
a sound file before continuing,” explains how to adjust the way the 
movie runs so that the entire piece of music plays before the movie 
continues.

Comparing several sound files

If you need to compare several sound files to find the one you want 
to add to a movie, select the cell in the sound channel where you 
want to add the sound, and then choose Set Sound from the Score 
menu. The Set Sound dialog box appears. Select the sound you want 
to listen to, but instead of clicking OK to add the sound to the score, 
click Play. Director plays the sound. If it’s not the one you want, 
select another one, and click Play. When you find the sound file 
you’re looking for, click OK to add it to the score.
Working with Sounds 139



Playing a sound file before continuing

Sometimes you may want a sound file to finish playing before 
anything else happens in a movie. That’s possible with the Set Tempo 
command.

The Set Tempo command has nothing to do with the tempo of the 
sound itself. Rather, it gives you a way to control the tempo of a 
movie, to insert pauses where you need them, and to make sure the 
movie finishes doing one thing before it moves on to something else. 
(You’ll notice there’s already a tempo setting in frame 2: the setting 
makes Director pause the movie for one second while the scene of 
the shrine is on the screen before it displays the title.)

One way to make sure that there’s time for an entire sound file to 
play is to slow down the rate at which the movie plays. Another way 
is to have the movie stop and wait until the sound file is finished. The 
second approach is the easier one to accomplish. Different computers 
with different processors play at different rates. The tempo that’s 
perfect on your system may be too fast or too slow on someone else’s.

The score has a separate channel for tempo information:

This section shows how to set a tempo that prevents the movie from 
going on to frame 4 until the music in frame 3 is finished.

Tempo channel
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To add the tempo setting:

1. Select cell 3 in the tempo channel of the score.

2. Choose Set Tempo from the Score menu.
The Set Tempo dialog box appears.

˛ Tip You can also display the Set Tempo dialog box by double-clicking the cell in 
the Tempo channel where you want to set the tempo.

3. Select Wait for Sound1 to Finish.

4. Click OK.
Director adds the tempo setting to the score.

5. Rewind the movie, and play it to see how the tempo setting 
affects the music.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Opening 1,” and click Save.
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Repeating a sound

Occasionally you may want to use a short sound (such as footsteps or 
the clip-clop of a horse’s hooves) that needs to be repeated over and 
over to create the right effect. The easiest way to repeat a sound is to 
fill a continuous series of cells in one of the sound channels with the 
sound. That approach works, however, only if the sound file was set 
up to loop when it was created. If the file wasn’t set up to loop, you 
have to signal Director to start playing the sound again each time you 
want it to repeat. The simplest way to signal Director to start playing 
a sound is to make sure there’s a blank cell preceding the one where 
you want the sound to start.

The following steps show how to create the continuous sound of 
horse’s hooves using a sound file that contains a single set of steps.

Open the file you’re going to add the sound to:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Genji,” and then click Open.
If “Genji” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

A scene with several carriages and a man on horseback appears.

Import the sound file:

1. Choose Import from the File menu (or press Command-J).
The Import dialog box appears.

2. Choose Sound from the Type pop-up menu if it isn’t still 
selected.

3. Select the file named “Hooves,” and then click Import.
A thumbnail with the name “Hooves” and the sound cast 
member icon appears in the cast window.
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Add the sound to sound channel 1:

1. Select cell 2 in sound channel 1, and then shift-click cell 10 
in the same channel to select the entire range.

2. Choose Set Sound from the Score menu.
The Set Sound dialog box appears.

3. Select “5:Hooves” and click OK.
Director fills the range with the number that identifies the sound 
in the cast window.

4. Rewind the movie and run it to hear the results.
Even though the sound notation extends over the entire range of 
frames, you hear only one set of the horse’s hooves.

The reason you hear only one set of the horse’s hooves is that there’s 
no blank frame to stop the sound so that it can start again. To repeat 
the same sound in the same sound channel, the sound cast members 
have to be separated by at least one blank frame. Otherwise, Director 
continues to play the same sound file. If it’s a short sound file like the 
horse’s hooves, the sound Director is playing is over long before the 
playback head reaches the last cell in the sound channel.

Make every other cell in the sound channel blank:

1. Select cell 3 in the sound channel and then choose Cut 
Cells from the Edit menu (or press Command-X or Delete).

2. Do the same in cells 5, 7, and 9.

3. Rewind the movie and run it again to hear the results.
Now you hear the sound of the horse’s hooves repeatedly, but 
the playback head is moving too fast for the entire sound to be 
played in each instance.
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To make sure each sound gets played completely before the playback 
head moves to the next frame, add a tempo setting to each frame with 
a sound:

1. Double-click cell 2 in the tempo channel.
The Set Tempo dialog box appears.

Note The tempo setting in frame 1 sets the tempo of the movie. Because some 
computers are faster than others, the playback speed of the sample file has also 
been locked so the movie will play back at the same speed on most computers. 
If you create a movie with an effect where timing is important, it’s a good idea 
to set the playback speed and then lock it. For more information, see Chapter 
3, “Working Behind the Scenes,” in Using Director.

2. Select Wait for Sound1 to Finish.

3. Click OK.
Director adds the tempo setting to the score.

Copy the setting to each of the other frames where you want the 
sound to play:

1. Make sure cell 2 in the tempo channel is still selected.

2. Hold down the Option key, and drag the information in cell 
2 toward the right.
As soon as you move the pointer beyond cell 2, a rectangle 
representing the contents of the cell appears.

3. Drag the rectangle to cell 4, and then release the mouse 
button.
Director places a copy of the setting that’s in cell 2 in cell 4.

4. Repeat the process to copy the setting to cells 6, 8, and 10 
in the tempo channel.

5. Rewind the movie and play it.
The playback head waits at each frame where you’ve added a 
tempo setting until the sound in the frame finishes playing.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Genji 1,” and click Save.
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Chapter 6

More Animation Techniques

The two earlier chapters about animation dealt with two 
essentially different types of animation. Chapter 1 showed how to 
animate the moon rising by moving a single sprite across the 
stage, and Chapter 4 showed how to create the animation of a 
bird in flight using a sequence made up of several cast members.

The first section in this chapter, “Working with In-Between 
Special,” focuses on techniques that are useful when you’re 
moving a single sprite across the stage: it shows how to in-
between a sprite’s blend value, how to decelerate the sprite as it 
nears the end of its path, and how to in-between two of the 
sprite’s attributes at the same time.
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The remaining techniques are most useful when you’re creating 
animation using a sequence of cast members. They demonstrate how 
to use Director to generate a series of cast members from a single cast 
member, how to drag an entire sequence of cast members to the stage 
and have them arranged in a single channel automatically, how to 
align the cast members that are part of a sequence, and how to reverse 
an animated sequence.

The examples in this chapter take about half an hour to work 
through.

Before you start:

þ Start Director if it isn’t still running.
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Working with In-Between Special

As you know from Chapter 1, you can use In-Between Special to in-
between a sprite’s location along a curved path. You can also use the 
In-Between Special command to in-between a sprite’s size, 
foreground color, background color, and blend value. The In-
Between Special dialog box also has options you can use to gradually 
accelerate an animation at the beginning of its path or to gradually 
slow it down as it nears the end of its path.

This section demonstrates how to in-between a sprite’s blend value 
and size, how to slow a sprite down as it nears the end of its path, and 
how to in-between two attributes of a sprite at once.
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In-betweening a sprite’s blend value

The following steps show how to animate a bird so that it slowly 
fades out as it flies into the distance.

First, open the movie that contains the animation of the bird:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Flight,” and then click Open.
If “Flight” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

This scene appears:

3. Run the movie to see how it looks before you make any 
changes to it.
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To alter the sequence so the bird fades out as it nears the moon, first 
apply the Blend ink to the sequence where the bird glides without 
flapping its wings:

1. Make the score active.

2. Double-click channel 2 anywhere between cells 7 and 13.
Double-clicking a range of cells containing the same sprite selects 
the entire range.

3. Choose Blend from the Ink pop-up menu in the score.

Ink pop-up menu
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When you’re in-betweening a sprite’s blend value, once you’ve 
applied the Blend ink, you need to set the blend values at the 
beginning and end of the sequence. In this case, the beginning blend 
value is 100%, or opaque. The default blend value for any sprite you 
apply the Blend ink to is 100%, so you don’t have to set a blend value 
for the sprite at the beginning of the sequence.

The blend value for the sprite at the end of the sequence is 0%, or 
invisible.

To set the blend value:

1. Select cell 13 in channel 2.

2. Choose Set Sprite Blend from the Score menu.
The Set Sprite Blend dialog box appears.

3. Set the blend value to 0%, and click OK.
The bird at the end of the sequence becomes invisible.
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Use In-Between Special to make the bird gradually disappear as it 
flies toward the moon:

1. Double-click channel 2 anywhere between cells 7 and 13.

2. Choose In-Between Special from the Score menu (or press 
Command-Shift-B).
The In-Between Special dialog box appears.

3. Select Location and Blend as the In-Between options, make 
sure none of the other In-Between options are selected, and 
click OK.
Director fills in the empty cells with intermediate blend values.

4. Rewind the movie and run it again to see how the animation 
looks.

Save the movie before you go on to the next section:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Flight 1,” and click Save.
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Using In-Between Special to decelerate animation

You use the In-Between Special command to adjust the rate of 
change at the beginning or end of an animated sequence, in effect 
gradually speeding up the change at the beginning of the sequence or 
gradually slowing it down at the end.

This section shows how to decelerate the animation of the bird as it 
flies toward the moon so it seems to move more slowly as it gets 
farther away. You’re also going to in-between two aspects of the bird 
at once: its location and its size.

Open the movie that contains the animation of the bird:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Soar,” and then click Open.
If “Soar” doesn’t appear in the dialog box, go to the Macromedia 
Director 4.0 folder, open the Tutorials folder, and then open the 
Learning Director folder.

The scene that appears looks the same as the one in the previous 
movie.

3. Run the movie to see the current speed of the animation.

Changing the size of a sprite

The Scale setting in the Sprite Info dialog box provides an easy way 
to change the size of any sprite that’s on the stage.

Changing the size of a sprite has no effect on the cast member that’s 
the basis of the sprite—or on any other sprites based on the same cast 
member. Remember that a cast member and a sprite aren’t identical. 
A cast member is a template for a sprite, but a sprite isn’t defined 
solely by a cast member. A sprite has information associated with it 
that’s totally unrelated to the cast member it’s based on—its position 
on the stage, for example, or an ink you’ve applied to it.
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Another of those pieces of information is the sprite’s scale relative to 
the size of its cast member. Changing the sprite’s size doesn’t even 
affect the sprite permanently—like any of the other information 
associated with a sprite, you can change it to a different value in a 
different frame.

You need to make the bird in the final frame of the movie smaller to 
make its flight look more realistic: objects get smaller as they travel 
into the distance.

To change the size of the bird:

1. Select cell 20 in channel 2 of the score.

2. Choose Sprite Info from the Score menu (or press 
Command-K).
The Sprite Info dialog box appears.

3. Change the Scale setting to 5%.

4. Click OK.

The size of the bird on the stage changes to something not much 
larger than a dot.

Scale setting
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In-betweening two attributes at once

You can use the In-Between options in the In-Between Special 
dialog box to animate changes to as many as five attributes of a sprite 
at once. You’re going to use the Location and Size options to 
generate in-between positions and in-between sizes for the bird as it 
flies across the stage.

In-between the cells between the first and last frames:

1. Double-click in channel 2 anywhere between cell 7 and 
cell 20.
Director selects the entire range.

2. Choose In-Between Special from the Score menu.
The In-Between Special dialog box appears.

3. Select Location and Size as the In-Between options (and 
deselect any other options that are selected).

The Decelerate pop-up menu lets you choose the number of frames 
over which you want the deceleration to occur.

Decelerate pop-up menu
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4. Choose Other from the Decelerate pop-up menu
A dialog box appears where you can enter the number of frames 
over which you want the deceleration to take place.

5. Type 14 and click OK.
Fourteen frames covers the latter part of the animation, during 
which the bird glides without flapping its wings. When you click 
OK, the dialog box disappears.

6. Click OK in the In-Between Special dialog box.
Director records the information about the intermediate size, 
location, and speed of the bird in the cells between the first and 
last in the range.

7. Rewind the movie and run it again to see how the animation 
looks.

Save the movie before you go on to the next section:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Soar 1,” and click Save.
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Using Reverse Sequence

You may find it’s sometimes easier to create an animated sequence 
from end to beginning rather than from beginning to end. For 
example, if you want to have two sprites meet at exactly center stage, 
it’s easier to start them there and work backward. Or you might find 
yourself creating an animated sequence in which the second half is 
simply the reverse of the first half. For example, a door closing is the 
mirror image of the same door opening. An easy way to accomplish 
either task is to use the Reverse Sequence command.

The steps that follow demonstrate how to copy a sequence that shows 
a block of text fading in and then use Reverse Sequence to create a 
sequence that shows the text fading out.

First, open the movie that contains the text:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Nonomiya,” and then click Open.
If “Nonomiya” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the tutorials folder, and 
then open the Learning Director folder.

A blank green screen appears.

3. Play the movie.
The text fades in.

Duplicate the fade-in sequence:

1. Go to the score, and double-click anywhere between cell 1 
and cell 10 in channel 1.
The entire range is selected.

2. Hold down the Option key and drag the selection.
A rectangle representing the selection appears.

3. Drag the rectangle to cells 11 through 20.
Director copies the information in cells 1 through 10 to cells 11 
through 20. The result is two sequences showing the block of 
text fading in.
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Play the movie to see what it looks like before you use the Reverse 
Sequence command:

þ Rewind the movie and play it.
The same text fades in twice.

To create the fade-out sequence:

1. Make sure cells 11 through 20 are still selected in the 
score.

2. Choose Reverse Sequence from the Score menu.
Director reverses the sequence of the information in the cells so 
that the information that was in the first cell is now in the last 
cell, the information that was in the last cell is now in the first 
cell, and so on.

3. Rewind the movie and play it again.
The text fades in and then fades out.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Nonomiya 1,” and click Save.
More Animation Techniques 157



Creating cast members automatically

You can use the Auto Distort command to have Director 
automatically generate cast members in the intermediate stages of a 
change. For example, using Auto Distort is an ideal way to create a 
wheel in various stages of rotation. All you need to provide Director 
with is a single image of the wheel for it to create the entire sequence.

This section shows both how to use Auto Distort to create a wheel in 
various stages of rotation and how to move the sequence of wheels to 
the score in such a way that Director arranges them automatically in 
consecutive frames.

Using Auto Distort

To use Auto Distort to create a sequence of cast members, you first 
create or import the cast member as it appears at the beginning of the 
sequence and then use one of the “distorting” commands on the 
Effects menu—Rotate Left, Rotate Right, Free Rotate, Perspective, 
Slant, or Distort—to make the cast member look the way you want it 
to appear at the end of the sequence. You can then use Auto Distort 
to generate the intermediate cast members.

Open the movie that contains the wheel:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Wheel,” and then click Open.
If “Wheel” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.
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This scene appears:

Rotate the wheel to its final position:

1. Make the cast window active.

2. Double-click the thumbnail of the wheel to display it in the 
paint window.

3. Point to the selection rectangle, and hold down the mouse 
button to display the pop-up menu. Make sure Shrink is 
selected.

4. Select the wheel.

5. Choose Free Rotate from the Effects menu.
Handles appear at each of the corners of the selection rectangle.
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6. Drag any of the corners in a complete circle around the 
center of the wheel. Make sure you leave the wheel 
selected.

Create the intermediate cast members with Auto Distort:

1. Choose Auto Distort from the Effects menu.
The Auto Distort dialog box appears.

2. Type 12 as the number of cast members you want to create 
and click Create.
As Director creates the cast members it displays each of them in 
the cast window.

3. Close the paint window.

The final cast member is the same as the original. Delete it:

þ Select the thumbnail of cast member 14 and choose Clear 
Cast Members from the Edit menu.
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Using the Cast to Time command

When you have a series of cast members that are all part of an 
animated sequence—such as the cast members that make up the 
rotating wheel—you use the Cast to Time command to move them 
to the score in a single step and have Director automatically arrange 
them in subsequent frames in a single channel.

Move the cast members that make up the rotating wheel to the score:

1. Select cell 1 in channel 2 of the score.

2. Arrange the score and the cast window so channel 2 of the 
score is visible when the cast window is active.

3. Resize the cast window so you can see all the wheel cast 
members at the same time.

4. In the cast window, select cast member 2, and then Shift-
click cast member 13 to select the entire sequence.

5. Choose Cast to Time from the Cast menu (or hold down 
Option and drag the entire selection to channel 2 of the 
score).
Director places the cast members in the sequence in successive 
cells in channel 2.
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Make the background of the wheel cast members transparent so you 
can see the scene behind the wheel between the spokes as the wheel 
turns.

1. Double-click the 2 beside channel 2 to select all the cells in 
the channel.

2. Choose Bkgnd Transparent from the Ink pop-up menu in the 
score.
The scene behind the wheel becomes visible through the spokes 
of the wheel.

Ink pop-up menu
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Move the wheel into position:

1. Make sure the cells in channel 2 are still selected.

2. Drag the wheel until it’s positioned like this:

3. Rewind the movie and play it.
The wheel rotates in place.

If you want to make a wheel cross the stage as it rotates, turn it into a 
film loop; then use the film loop as a cast member and create an 
animation path for it across the stage. For more information, see 
“Creating a film loop” in Chapter 4, “Animating a Sequence of Cast 
Members.”

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Wheel 1,” and click Save.
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Aligning cast members precisely

Every cast member has a registration point, which determines its 
position when you move it to the stage. When you’re working with 
an animated sequence that remains in the same spot on the screen—
such as the rotating wheel in the previous example—it’s important 
that the registration points of all the cast members be aligned precisely 
to make the animation look right. The problem is taken care of for 
you when you use Auto Distort because as Director creates each cast 
member in the sequence, it keeps the registration point in the same 
position. When you’re creating cast members separately, however, 
you have to make sure the registration point for each cast member in 
a sequence is set correctly.

This section shows how to align registration points, how to use the 
Align Bitmaps command to check the alignment of cast members, 
and how to use the Switch Cast Members command to align sprites 
on the stage.

Aligning registration points

When you import a series of cast members, Director places each one’s 
registration point at the center of the image. That works well when 
you’re dealing with a set of cast members that are all exactly the same 
size. But take a look at this series of images:
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Because they show an arm in motion, each image is slightly taller than 
the one before it. A registration point in the center of the image 
would mean that the bottom of each image would be slightly lower 
than the bottom of the one preceding it.

The solution is to move the registration point to part of the image 
that remains in the same place throughout the animation: a spot near 
the bottom edge.

To set the registration point for a cast member, you use the 
registration tool in the paint window.

The steps that follow show how to change the position of the 
registration point on a series of images.

Open the movie containing the cast members shown above:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Weeping,” and then click Open.
If “Weeping” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The image that appears looks like this:
More Animation Techniques 165



Use the Align Bitmaps command to see how the cast members are 
currently aligned:

1. Go to the cast window and select cast members 3 
through 6.

2. Choose Align Bitmaps from the Cast menu.
Align Bitmaps doesn’t reset the position of the registration points 
to align the images (Director has no way of knowing how you 
want the images aligned). Align Bitmaps lines up the images in 
the paint window based on where their registration points are 
currently set.

3. Double-click cast member 3 to display it in the paint 
window.

4. Use the right and left arrows on the keyboard to flip back 
and forth through the four cast members rapidly.
As you can see, their alignment is slightly off.

5. Display cast member 3 in the paint window again.
Notice that there’s a cross at the bottom (you may have to scroll 
down a bit to see it).

The cross shows where the registration point should be set. When 
you create a cast member in an application outside Director, it’s a 
good idea to add a mark that shows where the registration point 
should be set. After you set the registration point, you can erase the 
mark.

Set the registration point for each of the cast members:

1. Select the registration point tool.
Two intersecting lines appear in the paint window. The point 
where they intersect is the current registration point.

2. Drag the crosshair to the cross below the cast member.
The intersection point of the two lines follows the crosshair as 
you drag it.

3. When you have the crosshair positioned precisely over the 
cross, release the mouse button.
The two lines remain aligned with the cross, and the new 
registration point corresponds to the center of the cross.
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4. Repeat the procedure with each of the other cast members 
in the sequence, including cast member 2.
Cast member 2 is the master shot that all the arm positions are 
based on. It needs to have the same registration point as the arm 
positions.

5. Close the paint window when you’re finished.

Using Switch Cast Members to align sprites on 
the stage

The Align Bitmaps command aligns cast members in the paint 
window, not sprites on the stage. An easy way to align sprites on the 
stage—once you have the registration points of the cast members 
they’re based on set correctly—is to use the Switch Cast Members 
command.

For the movement of the woman’s arm to look right, the registration 
point on each sprite in the sequence needs to align with the 
registration point on the master shot. The easiest way to align each of 
the sprites is to put a copy of the master shot in each frame of the 
movie where you want the sequence to appear, and then switch each 
sprite in the sequence with the copy of the master shot in the 
corresponding frame. Director automatically aligns the registration 
point of the sprite with the registration point of the master shot 
you’re replacing.

The first step is to copy four cells of the master shot from channel 2—
one cell for each sprite in the movement of the woman’s arm—and 
paste them in channel 3:

1. Select cells 2 through 5 in channel 2 to make a copy of the 
master shot.
Don’t include cell 1: the first position of the woman’s arm is 
shown in the master shot, and it needs to appear on the stage in 
frame 1.

2. Choose Copy Cells from the Edit menu (or press 
Command-C).

3. Select cell 2 in channel 3.
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4. Choose Paste Cells from the Edit menu (or press 
Command-V).
The copies of the master shot appear in cells 2 through 5 of 
channel 3.

The next step is to use Switch Cast Member to replace the copies of 
the master shot in the second through fifth cells in channel 3 with the 
appropriate sprite in the sequence. When Director replaces one sprite 
with the other, it positions the registration point of the new sprite in 
exactly the same position as the old sprite’s. The result is that the 
sprites in the sequence will be perfectly aligned with each other and 
with the master shot.

To switch cast members:

1. Select cell 2 in channel 3 of the score.

2. Go to the cast window, select cast member 3, and then 
choose Switch Cast Members from the Score menu (or 
press Command-E).
The number in the cell changes to show that Director has 
replaced the master shot with cast member 3.

3. In the cast window, select cast member 4.

4. Go to the score, select cell 3 in channel 3, and then choose 
Switch Cast Members from the Score menu (or press 
Command-E).

5. Repeat the process to replace the master shot in cell 4 with 
cast member 5 and the master shot in cell 5 with cast 
member 6.

6. Rewind the movie and play it.
The woman raises her hand to her eyes.

If the animation is too fast, you can add a tempo setting to the first 
frame of the movie to slow it down. For information, see “Adding a 
tempo setting” in Chapter 3, “Working Behind the Scenes” in Using 
Director.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Weeping 1,” and click Save.
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Chapter 7

Creating Effects

You’re already familiar with many of the effects you can create in 
Director from previous chapters. The Background Transparent, 
Matte, Reveal, and Transparent inks were covered in Chapters 1, 
2, and 3. Chapter 6 demonstrated how to in-between a sprite’s 
transparency and size.

This chapter shows how to use Director’s built-in transitions. 
You can choose from over 50 transitions, so you have a wide 
range of effects at your disposal.

You can also create effects using color palettes. You can have 
Director cycle through a range of colors in the palette, which 
causes any area containing any of the colors in the range to 
change to each of the other colors in succession. You can also 
have Director shift from one palette to another, which causes any 
color on the stage to shift to its corresponding color in the new 
palette. This chapter shows how to achieve both effects.
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The examples in this chapter take about half an hour to work 
through.

Before you start:

1. Start Director if it isn’t still running.

2. Make sure that looping is turned off.
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Setting transitions

A transition is a way of making a change on the stage—usually from 
one scene to another—through a series of intermediate steps.

A Wipe Left transition

Director provides more than 50 predefined transitions you can use to 
create such effects in a single step. For example, you can dissolve from 
one scene to the next, display a new scene strip by strip, or switch to 
a scene as if revealing it through Venetian blinds. You can wipe across 
the screen revealing the new scene as you go, slide the old scene off 
the stage revealing the new scene underneath, or slide the new scene 
onto the stage covering the old. You can also use many of the 
transitions to make individual elements appear or disappear from the 
screen, and you can even use transitions to create animation—for 
example, you can make bars appear to grow on a bar chart as you 
wipe the new scene over the old.
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There’s a special channel for transitions, just as there are channels for 
sounds and tempos:

The steps that follow show how to use just one transition—zooming 
open a block of text—but the techniques are applicable to all 
transitions.

Open the movie that contains the block of text:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Controls,” and then click OK.
If “Controls” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The movie appears. All that’s visible in the first frame of the 
movie is a rice paper background.

3. Play the movie to see how it looks before you set the 
transition.
The controls and the text simply appear on the stage.

Before you select the frame where you want to set the transition, it’s 
important to understand how transitions work. A transition always 
takes place between the end of the current frame and the beginning 
of the frame where the transition is set. So, when you want to zoom 
open a block of text, you set the transition in the same frame where 
the text first appears.

Transition channel
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Make sure the transition channel is visible:

1. Make the score active.

2. If the transition channel isn’t visible, click the Jump to Top 
button.

You may have to click the button twice. When you click the 
button the first time, Director moves the script channel to the top 
of the score if it isn’t already positioned there. Clicking the 
button a second time displays the effects channels.

Set the transition:

1. Select cell 3 in the transition channel.
The text “Click to go back” appears on the stage.

2. Choose Set Transition from the Score menu.
The Set Transition dialog box appears.

Jump to Top 
button
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˛ Tip You can also display the Set Transition dialog box by double-clicking the cell 
in the transition channel where you want to set the transition.

3. Scroll down to the bottom of the list and select Zoom Open.

4. Select Changing Area (one of the two options under the 
heading “Transition Applies to” near the top of the dialog 
box).
Selecting Changing Area limits the transition to just the text 
that’s being displayed (it’s the only change that’s taking place on 
the stage).

5. Make the Duration 2 and the Chunk Size 1.
Duration sets the length of time the transition takes in fourths of a 
second (a duration of 2 is one-half second). Chunk size sets the 
size of each intermediate step in pixels (a chunk size of 1 is the 
smoothest possible transition).

6. Click Set.
Director adds the transition to the score.

7. Rewind the movie and play it.
Instead of just appearing on the screen, the text “Click to go 
back” zooms open.

Copying a transition

Copying a transition is an easy way to take an effect you’ve set up and 
reproduce it elsewhere in the same movie. When you copy a 
transition, you copy just the effect, not the part of the animation the 
transition applies to.

1. Hold down Option and drag the transition in cell 3 to cell 5, 
then to cell 7, and then to cell 9 to place copies of the 
transition in each of those cells.

2. Rewind the movie and play it again to see how the 
additional transitions affect it.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Controls 1,” and click Save.
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Palette transition effects

A palette transition is a gradual change from the colors in one palette 
to the colors in another.

As explained in Chapter 1 of Using Director (in “Changing Color 
Depth”), a monitor—depending on its type and the graphics display 
card that’s installed—can display 1-bit color (black and white), 2-bit 
color (4 colors), 4-bit color (16 colors), 8-bit color (256 colors), 16-
bit color (32,768 colors), 24-bit color (16.7 million colors), and 32-
bit color (16.7 million colors and 8 bits of special effects).

Color palettes are available only when the monitor’s color depth is set 
to 2, 4, or 8 bits. When you have the monitor set to 1 bit, there’s no 
color palette because the only colors you have to choose from are 
black and white. When you have the monitor set to thousands of 
colors (16-bit color) or millions of colors (24- or 32-bit color), you 
choose colors not from a palette—a collection of 4, 16, or 256 
discrete colors—but from a continuous spectrum of the thousands or 
millions of colors available.

Palettes and how they work are fairly complex subjects; for a 
thorough discussion, see Chapter 3, “Working Behind the Scenes,” 
in Using Director.
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This section shows how to use a series of six palette transitions to 
create the changes in light that occur during the day from sunrise to 
sunset (the scene is the same Japanese shrine you worked with in 
Chapter 1). To create a palette transition, you use a palette setting 
rather than a transition setting. Palette settings, like tempos, sounds, 
and transitions, have their own channel in the score:

The most important thing to remember about effects you create with 
palette settings is that they affect not just the stage, but anything that 
appears on the monitor. For example, if you fade a movie to black at 
the end, everything on the screen—the menu bar, the Finder, and so 
on—fades to black.

Open the movie that contains the Japanese shrine and the custom 
palettes you need to create the transitions:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Daylight,” and then click Open.
If “Daylight” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The shrine appears on the stage.

Palette channel
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The background looks odd because the System palette is currently in 
effect and the background was designed to be used with the custom 
palettes that appear in the cast window (Night, Twilight, Daylight, 
and Black). (For information about creating custom palettes, see 
Chapter 3, “Working Behind the Scenes,” in Using Director.)

Since the palette that’s active affects everything displayed on the 
monitor—including Director’s interface—you’ll find it difficult to see 
what you’re doing after you switch to the custom palettes in the 
course of the steps that follow. 

To avoid that problem, switch to Director’s black-and-white user 
interface:

1. Choose Preferences from the File menu.
The Preferences dialog box appears.

2. Select Black and White User Interface.
The black-and-white interface looks the same no matter which 
palette is active.

3. Click OK.
Director’s interface changes to black and white, but the image on 
the stage remains in color.

Select this setting
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Create the first palette transition:

1. Select cell 1 in the palette channel of the score.

2. Choose Set Palette from the Score menu.
The Set Palette dialog box appears. The settings in the dialog box 
depend on whether the Color Cycling or the Palette Transition 
setting is selected.

˛ Tip You can also display the Set Palette dialog box by double-clicking the cell in 
the palette channel where you want to add a palette setting.

3. Select the Palette Transition setting if it isn’t already 
selected.
The dialog box looks like this:

4. Choose Night from the Palette pop-up menu.
As soon as you select the Night palette, it becomes the active 
palette, and the system remaps everything on the screen to the 
colors it contains.

5. Set the speed slider to 15 fps.

6. Click Set.
The dialog box disappears, and the palette setting appears in the 
first cell of the palette channel.
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Create the second palette transition:

1. Double-click cell 2 in the palette channel.
The Set Palette dialog box appears.

2. Select the Palette Transition setting if it isn’t already 
selected.

3. Choose Twilight from the Palette pop-up menu.
The Twilight palette becomes the active palette, and the system 
remaps everything on the screen to the colors it contains.

4. Make sure the speed slider is still set at 15 fps.

5. Click Set.
The dialog box disappears, and the palette setting appears in the 
second cell of the palette channel.

The steps are the same for each of the other four frames in the 
animation:

1. Double-click the appropriate cell in the palette channel of 
the score.
The Set Palette dialog box appears.

2. Select the Palette Transition setting if it isn’t already 
selected.

3. Choose the name of the palette from the Palette pop-up 
menu:

p For cell 3, choose Daylight.

p For cell 4, choose Twilight.

p For cell 5, choose Night.

p For cell 6, choose Black.

4. Make sure the speed slider is set at 15 fps.

5. Click Set.
The dialog box disappears, and the palette setting appears in the 
appropriate cell of the palette channel.

6. Rewind the movie and play it to see how the palette 
transitions look.
The scene changes from night to dawn to morning to afternoon 
to twilight to night to black.
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Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Daylight 1,” and click Save.

Switch back to Director’s color user interface:

1. Choose Preferences from the File menu.
The Preferences dialog box appears.

2. Click the checkbox next to Black and White User Interface 
to remove the X.

3. Click OK.
Director’s interface changes back to color.
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Color cycling

You can choose a set of colors adjacent to each other on the palette 
and have Director cycle through them. For example, if you select a 
range of four colors—say red, green, blue, and yellow—any area 
that’s red will change to green, then blue, and then yellow during the 
cycling; any area that’s green will change to blue, yellow, and then 
red; and so on.

This section shows how to use color cycling to create the effect of the 
sun setting behind the Japanese shrine.

Open the movie that contains the shrine:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Sunset,” and then click Open.
If “Sunset” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The shrine appears on the stage.

Creating a gradient

The sunset effect uses an interesting technique to create the illusion of 
the setting sun. The palette for the scene contains a broad range of 
yellows and oranges that are close to each other in hue. From those 
colors you create a gradient: a color that’s a gradual blend of colors 
starting with the brightest yellow and ending with the darkest orange. 
As Director cycles through the colors in the yellow-orange range, the 
sky appears to darken.
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The first step in creating a gradient is to choose the colors you want 
to use:

1. Choose Paint from the Window menu (or press Command-5) 
to display the paint window.

2. Click the Add button to display a blank cast member in the 
drawing area.

3. Click the zoom box to expand the window to its full size.

Destination color chip

Foreground color chip

Line width selector

Foreground color chip

Zoom box
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4. Use the foreground color chip to choose the yellow in the 
last chip in the second row as the foreground color.
There are two foreground color chips. You can use either to 
choose the foreground color.

5. Use the destination color chip to choose the orange in the 
second chip in the top row as the destination color.

Create the gradient:

1. Select the filled rectangle tool.

2. Choose Gradients from the Paint menu.
The Gradients dialog box appears.

Choose this orange as the destination color

Choose this yellow as the foreground 
color
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3. Select the settings shown in the illustration and then click 
Set.
For a description of all the options that are available in the 
Gradients dialog box and the effect each setting produces, see 
“Gradients” under “Paint menu” in Chapter 6 of Using Director.

4. Select the dotted line in the line width selector.
The dotted line lets you draw a shape without an outline.

5. Draw a rectangle that fills the window.
The result looks like this:
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Remove the bottom third of the gradient so the sun appears to set on 
the horizon:

1. Select the selection rectangle.

2. Select the bottom third of the gradient.

3. Press Delete.

4. Close the paint window.

Place the gradient on the stage:

1. Select cell 1 in channel 1 of the score.

2. Open the cast window if it isn’t already open.

Select this part of
the gradient
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3. Drag the gradient cast member from the cast window to 
the stage, and position it like this:

Director places the gradient behind the shrine, which is located in 
channel 2 of the score.

In-between the gradient and the shrine scene in front of it:

1. Select cell 1 in channel 1 and then Shift-click cell 30 in 
channel 2 to select the entire range.
Thirty frames provide the appropriate amount of space to create 
the animation of the sunset.

2. Choose In-Between Linear from the Score menu (or press 
Command-B).
The gradient and the shrine fill the frames.

Gradient
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Selecting the options that control color cycling

Color cycling is controlled by a palette setting. The information 
contained in the palette setting comes from the Set Palette dialog 
box, where you choose the palette you want Director to use, speed 
and number of cycles, and—most important—the colors you want 
Director to cycle through.

The steps that follow show how to select the settings that will turn 
the gradient you’ve created into an animated sunset.

Open the Set Palette dialog box:

1. Select the first cell in the palette channel of the score and 
then Shift-click cell 30 in the same channel to select the 
range.

2. Choose Set Palette from the Score menu.
The Set Palette dialog box appears. The settings in the dialog box 
depend on whether the Color Cycling or the Palette Transition 
setting is selected.

3. Select the Color Cycling setting if it isn’t already selected.
The dialog box looks like this:
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4. Select the Over Time option in the lower half of the dialog 
box.
The Over Time option extends the color cycling over as many 
frames as you select in the score rather than running through the 
entire cycle in each frame.

Select the colors you want to cycle through in the palette that’s 
displayed:

1. Select the orange in the second chip in the top row.

2. Shift-click the yellow in the last chip in the second row.

3. Click Set.
Director adds the settings to the score.

4. Rewind the movie and play it.
The sky deepens to orange as the sun sets.

If the effect happens too fast, you can add a tempo setting to the first 
frame of the movie to slow it down. For information, see “Adding a 
tempo setting” in Chapter 3, “Working Behind the Scenes” in Using 
Director.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Sunset 1,” and click Save.

Select the range from this orange…

…to this yellow
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You can create other illusions of movement with color cycling. For 
example, by cycling through the colors on a striped ball, you can 
make the ball look like it’s rotating. By cycling through a range of 
pale blues and near-whites, you can create the illusion of a water 
falling or waves breaking on a shore.
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Chapter 8

Adding Interactivity to a 
Movie

Making a movie interactive means building into it the ability to 
respond to choices that users make. The goal of interactivity is to 
give users some degree of control over a movie. Interactivity can 
sometimes be extraordinarily subtle and difficult to achieve, but 
when your goals are modest you can achieve remarkable results 
with very little effort.

Normally, the only control a user has over a movie you’ve 
created is to start it and let it run until it reaches the end. The 
simplest level of control you can build into the movie itself is to 
give users control over the pace at which they move from one 
part of the movie to the next.
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Director gives you two ways to provide that kind of control. The 
easiest to use is a tempo setting. One of the options you have to 
choose from when you create a tempo setting stops the movie and 
simply waits until the user clicks the mouse button or presses any key 
on the keyboard before it allows the movie to go on to the next 
frame. A more sophisticated approach is to create “next” and 
“previous” buttons that allow users to move both forward and 
backward through a movie.

A more complex form of interactivity is branching—allowing users to 
choose a path through a movie, rather than limiting them to a single 
path that goes directly from beginning to end.

Branching uses buttons to show users what their choices are. 
Whenever you create a button—whether to allow users to go from 
one segment to the next or to choose the path they want to follow—
you also need to write a Lingo script that tells Director what to do 
when someone clicks the button. While writing scripts may sound 
like the kind of thing only people with experience in programming 
should try, it’s a lot easier and less intimidating than you may think.

This chapter shows how to create a tempo setting that halts a movie 
and waits for a mouse click, how to create and use markers, how to 
create buttons and write scripts for them, and how to set up hypertext 
links.

The examples in this chapter take about half an hour to work 
through.

Before you start:

1. Start Director if it isn’t still running.

2. Make sure that looping is turned off.
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Waiting for a mouse click

The simplest way to add interactivity to a movie is to pause the 
movie until a user either clicks the mouse button or presses any key 
on the keyboard. The Set Tempo dialog box contains an option you 
can use to do just that.

The steps that follow show how to create a tempo setting that pauses 
a movie until the user clicks the mouse or presses a key. The pause 
allows users to control when they want to proceed to the next screen 
image.

Open the movie that contains the images:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Images,” and then click Open.
If “Images” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The shrine scene appears.

3. Play the movie.
The first image is replaced by the second almost immediately.
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Add the tempo setting that pauses the movie:

1. Select cell 2 in the tempo channel of the score.

2. Choose Set Tempo from the Score menu.
The Set Tempo dialog box appears.

˛ Tip You can also display the Set Tempo dialog box by double-clicking the cell in 
the tempo channel where you want to add the tempo setting.

3. Select Wait for Mouse Click or Key.

4. Click OK.
Director adds the tempo to the score.

Play the movie again to see how the tempo setting affects it:

1. Make sure that looping is off, and then press Command-1 to 
close all the windows.

2. Press Command-R to rewind the movie, and then press 
Command-P to play it.
The first image remains on the screen. Notice that the cursor 
changes to an icon of the mouse.

3. Click the mouse button or press any key.
The next image appears.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Images 1,” and click Save.
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While waiting until the user clicks the mouse or presses a key is the 
easy way to provide interactivity, it has one drawback: the user can 
only go in one direction—forward. If you want to find out how to 
set up buttons that let a user go both forward and backward through a 
movie, see the tutorials in Lingo Expo.
Adding Interactivity to a Movie 195



Creating buttons

Creating buttons that appear on the screen is another easy way to 
allow interactivity. Creating a button is slightly more complicated 
than using a tempo setting because you have to write a Lingo script 
that tells Director what to do when a user clicks the button. Writing a 
script is a lot easier and less intimidating than it may sound. For 
example, in this section you’ll create a button that requires a script 
only seven words long—and Director provides three of those words 
before you start.

For more information about creating buttons, see Chapter 4, 
“Making a Movie Interactive,” in Using Director. For detailed 
information about writing Lingo scripts, see Using Lingo.

Creating and labeling a marker

You can write a script that tells a movie to go to a specific frame that 
marks the beginning of a segment. Such a script would say something 
like “go to frame 13”—which means to go to the frame 
numbered 13 in the score.

Frame 13
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The problem with that approach is that if you add or delete a frame 
before frame 13, the script no longer tells the movie to go to the right 
place. A much better practice is to put a marker in the first frame of a 
segment and give the marker a name. 

When there’s a marker, the script can tell the movie to go to the 
marker, and you can add and delete frames without worrying about 
having to rewrite scripts whenever you do so. A script that tells a 
movie to go to a marker looks something like this: 

go to frame "Screen Two" 

The script is always accurate as long as you don’t rename the marker.

Marker

Marker name
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If you’ve looked at the Director sample movie Noh Tale to Tell 
included in the package, you may remember that it starts with a 
screen that explains how to use the controls that are part of it. The 
screen looks like this:
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When you click the Start Story button, this screen appears:

The frame where the text “Japan” appears is identified with a marker 
labeled “Start.” The Start Story button has a script that tells Director 
to go to the frame labeled “Start” when a user clicks the button.

This section shows you how to create the marker and label it.

Open the movie that shows the first two screens of Noh Tale to Tell:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Tale,” and then click Open.
If “Tale” doesn’t appear in the dialog box, go to the Macromedia 
Director 4.0 folder, open the Tutorials folder, and then open the 
Learning Director folder.

The image that appears is blank except for the rice paper 
background.

3. Play the movie.
The instructions explaining the controls appear, and they’re 
followed immediately by a black screen with the text “Japan.”
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Add the marker to the frame where “Japan” appears:

1. Go to the score, drag a marker from the marker well, and 
place it above frame 13.

2. Type Start next to the marker and press Return.
You can now use the label “Start” to refer to the frame in a 
script.

The markers window

The label you give a marker appears not only at the top of the score 
but also in the markers window.

To display the markers window:

þ Choose Markers from the Window menu.
The markers window appears.

Marker well

Marker positioned above frame 13
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You can use the marker window to add comments about a frame and 
to display the part of the score where a marker is located. (For more 
information, see Chapter 4, “Making a Movie Interactive,” in Using 
Director.)

þ Close the markers window.

Creating a button

The tools window has a special tool you can use to create a standard 
button:

The button automatically highlights when a user clicks it, just like any 
standard button. But remember that the button you create with the 
Standard Button tool is just an animated image—it needs a script 
before it can do anything.

To create a button:

1. Select cell 11 in channel 14 of the score.
That marks the location in the score where you want to record 
the information about the button.

2. Choose Tools from the Window menu (or press 
Command-7) to open the tools window.

3. Select the Standard Button tool.

Standard button
Standard Button tool
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4. Use the Standard Button tool to draw a rectangle on the 
stage:

When you release the mouse button, Director replaces the 
rectangle with a blank button.

5. Type Start Story in the button.

6. Highlight the text and choose Chicago from the Text 
menu’s Font submenu and 12 point from the Size submenu.

7. Drag the handle on the right of the button to adjust its size.
The result is the kind of button you’d expect to see in a dialog 
box.

˛ Tip To change the text on a button, either select the button on the stage and 
change the text there or go to the cast window, double-click the button cast 
member, and edit the text in the text window that appears.

Draw a rectangle here
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Creating a script for the button

To work, a button needs a script. Without a script, a button is just 
another graphic element on the stage. You can click it, and Director 
will highlight it just like any other button—but nothing will happen.

The script for the Start Story button is simple. It tells Director to go 
to the frame named “Start” when someone clicks the button.

To create the script for the button:

1. Make the cast window active.

2. Select cast member 15, the thumbnail that represents the 
Start Story button.

3. Click the Script button at the top of the cast window.
The Cast Member Script window appears.

Director automatically supplies the first and last lines of the script. 
You need to supply only the middle line.

Script button

Button icon
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The first line, on mouseUp, means “when a user clicks this 
button with the mouse.” The last line, end, indicates the end of 
the script.

4. On the middle line of the script, type:
go to frame "Start" 

Make sure you enclose “Start” in quotation marks. The 
quotation marks tell Director that “Start” is a marker.

The entire script in English means, “When a user clicks the 
mouse on this button, go to the frame that has the marker named 
‘Start’. That’s the end of the script.”

5. Press Enter on the keypad to close the Script window.

Adding a pause

When you add a button to a movie, you give users a choice. For 
example, the Start Story button implicitly asks the question, “Do you 
want to start the story?” Clicking the button means yes, not clicking 
it means no. When you give users a choice, you also need to give 
them an opportunity to make the choice.

You’ll remember that earlier in the chapter, you used a single tempo 
setting to do two things:

◆ Pause a movie

◆ Continue the movie when a user clicked the mouse button or 
pressed a key.

The pause was just a way of giving users the opportunity to choose to 
display the next image when they were ready, rather than being 
forced to go to the next image when the movie was ready to move 
on. What’s missing from the movie you’re working on now is a pause 
that allows users to make the choice you’ve given them.
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Play the movie and watch what happens:

þ Press Command-R to rewind the movie, and then press 
Shift-Enter to play it. (Use Enter on the keypad.)
Pressing Shift-Enter closes any windows that are open and starts 
the movie. The text explaining the controls appears, the Start 
Story button flashes on the screen for an instant, and then the 
screen turns black and “Japan” appears.

Adding a pause requires another script. The new script is connected 
with the frame where the Start Story button appears rather than with 
the button itself. Director records scripts that are connected with a 
frame in the script channel, which is just above channel 1:

Script pop-up menu

Script channel
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To set up the script that tells Director to pause:

1. Select cell 11 in the Script channel of the score.

2. Choose New from the Script pop-up menu in the score 
window.
A new script window appears. 

Director automatically supplies the first and last lines of the script. 
You need to supply only the middle line.

The first line, on exitFrame, means “when it’s time to go to the 
next frame.” The last line, end, indicates the end of the script. So, if 
you were to add a middle line that read

pause 

the script would mean, “When it’s time to go to the next frame, wait 
for further instructions. That’s the end of the script.” The instructions 
Director waits for are supplied by the script attached to the button the 
user clicks.

3. On the middle line of the script, type:
pause 

4. Press Enter on the keypad to close the script window.
Director turns the script into a cast member. The number that 
appears in the cell of the script channel is the number of the script 
cast member.
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Run the movie to see how the two scripts—the script for the button 
and the script in the script channel—work:

1. Make sure that looping is off, and then press Command-1 to 
close all the windows.

2. Press Command-R to rewind the movie, and then press 
Command-P to start it.
The screen that explains how to use the controls appears.

3. Click the Start Story button.
The screen with the text “Japan” appears.

Any button that you set up in the same way as the Start Story 
button—to refer to a frame marked with a label—works the same 
way. Whenever someone clicks the button, Director goes to the 
frame that’s named in the script.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Tale 1,” and click Save.
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Creating hypertext links

Some people would argue that during the millennia before computers 
came into existence, text was invariably linear: you started at the 
beginning of a piece and read without deviation straight through to 
the end. That’s an over-simplification.

Writers have for centuries used cross-references, footnotes, tables of 
contents, and indexes to direct their readers from one place to 
another, from one pertinent passage to the next. Computers have, 
however, made it possible to automate the links between related 
chunks of information. The result is hypertext—text in an electronic 
form with built-in links between information that’s connected. 
Readers of hypertext documents don’t need to track down the 
section heading that contains the cross-reference they’re looking for; 
they need only to click the text that’s linked to a related passage, and 
the passage appears on the screen.

In Director, a hypertext link works just like a button: when a user 
clicks the text that’s linked with a related passage, a script associated 
with the text tells Director to go to the frame in the movie where the 
passage is located.

There are two ways to set up a hypertext link:

◆ You can make an entire text block act as the button.

◆ You can make just a word or phrase within the cast member act 
as the button.

Making an entire text block a button is easy: you write a script for it 
in exactly the same way you wrote the script for the Start Story 
button in the previous section. (For the complete procedure, see 
“Using an entire text block as a button” in Chapter 4, “Making a 
Movie Interactive,” in Using Director.)

The steps that follow show how to manage the more difficult 
approach: using a single word within a block of text as a button.
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Open the movie that’s set up for you to experiment with:

1. Choose Open from the File menu (or press Command-O).
The directory dialog box appears.

2. Select the file named “Hypertext,” and then click Open.
If “Hypertext” doesn’t appear in the dialog box, go to the 
Macromedia Director 4.0 folder, open the Tutorials folder, and 
then open the Learning Director folder.

The scene that appears looks like this:

The movie has one hypertext link set up. Run the movie to see how 
it works:

1. Press Shift-Enter to start the movie.

2. Click Genji.
A screen of text appears with information about The Tale of Genji.

3. Click the Return button in the lower right corner of the 
screen.
The first screen reappears.

4. Press Command-period to stop the movie.
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Take a look at the score:

1. Make the score active.
Notice that there’s a marker labeled Genji. The marker identifies 
the frame that contains the text that appeared on the screen when 
you clicked the word Genji.

2. Click just below the marker labeled Genji to move the 
playback head to the frame with the text about The Tale of 
Genji.
The text appears on the screen.

3. Move the playback head to frame 1.
The illustration of Genji’s departure reappears.

Take a look at the block of text on the screen and you can see why 
you can’t make the entire block a hypertext button: two words—
Genji and Rokujo—are in red. Each has a separate passage related to it, 
and so each needs its own script to tell Director where to find the 
passage. (Rokujo isn’t linked with its passage yet—that’s the hypertext 
link you’re going to set up later in this section.)

But that presents something of a mystery: The script linking Genji 
with its related passage isn’t part of the text block’s cast member, and 
the script can’t be connected directly with Genji because Genji isn’t a 
separate cast member. How, then, is Genji linked with the passage 
that appeared when you clicked it? The answer is that the script for 
Genji is part of a transparent button that overlays the word Genji.

Click here to move the playback head to 
this frame
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Display the transparent button overlaying Genji:

þ Select cell 2 in channel 6.
The selection rectangle that appears on the stage makes the 
button visible.

Because the button is completely transparent, it looks as if you’re 
clicking Genji when in fact you’re not—you’re clicking the button 
on top of it.

Take a look at the script that’s attached to the button sprite:

1. Make sure cell 2 in channel 6 is still selected.
Notice that a script appears in the script preview area at the top of 
the score.

Transparent button

Script preview area
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2. Click anywhere in the script preview area to display the 
script window.
The script window that appears looks like this:

The script there reads:

on mouseUp
play frame "Genji"

end 

You’ll remember that when you created the script for the Start Story 
button earlier in the chapter, you used the statement go to frame 
"Start". The statement in the preceding script, play frame 
"Genji", works the same way: it tells Director to go to the frame 
that’s named in the script. The difference between the two is this: 
play frame "name" is always paired with another statement, play 
done. The purpose of play done is to tell Director to return to the 
frame it came from.

The process works like this: You place play frame "name" at the 
point in a movie where you want Director to branch to the 
beginning of a different segment; you place play done at the end of 
the segment. When Director comes across play frame "name" it 
goes to the frame that’s named. When it comes across play done, it 
returns automatically to the frame it came from.
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The play done statement is part of the script for the Return button 
that’s on the screen that contains the information about The Tale of 
Genji:

Take a look at the script:

1. In the cast window, select cast member 12.

2. Click the Script button at the top of the cast window.
The text in the script window is replaced by the script attached to 
the Return button.

Return button
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The script reads:

on mouseUp
play done

end 

The interaction between the play frame "Genji" script and the 
play done script works like this: When you click the word “Genji” 
on the first screen of the movie, Director branches to the frame that 
contains the information about The Tale of Genji. There’s a pause 
script in the script channel of the frame, so Director simply waits 
there for further instructions. When you click the Return button, 
Director reads the script there, comes across the play done 
statement, and returns to the place it came from.

þ Close the script window.

Script: pause Script: pause

Script: play frame "Genji" Script: play done
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Types of scripts

You may have noticed that the script for the transparent button 
overlaying the word Genji is connected with the cell where the 
button’s sprite is recorded, but the script for the Return button is 
connected with the button’s thumbnail in the cast window. That’s 
because the scripts are different types of scripts. The script associated 
with the transparent button is a sprite script; the script associated with 
the Return button is a cast member script.

A sprite and its script

The cell where the
button’s sprite is

recorded

The script recorded
with the sprite in

the same cell
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A cast member and its script

Cast member scripts

A cast member script—which you attach to a cast member in the cast 
window—becomes a permanent part of the cast member. The script 
goes with the cast member no matter where you use the cast member 
in the movie. (You can attach a script not just to a button cast 
member, but to any bitmap, PICT, shape, or text cast member; that 
means you can use any of those cast members as a button.)

The cell where the
button’s sprite is

recorded

The script connected
directly with the

button cast member

The button cast
member
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You use a cast member script when you want Director to do exactly 
the same thing whenever anyone clicks the cast member that the 
script is attached to. That’s why the Return button uses a cast 
member script: you want Director to return to the frame it came 
from whenever a user clicks the Return button.

But be aware that “do exactly the same thing” means “do absolutely 
exactly the same thing.” Suppose, for example, you’ve set up a button 
named Next at the end of the first screen of a movie, and you want 
the button to take the user to the second screen. So you label the 
marker in the first frame of the second screen Screen Two and attach 
this cast member script to the button:

on mouseUp
go to frame "Screen Two"

end 

The button works fine. But if you try to use the same button on the 
third screen, Director will go, not to the fourth screen, but back to 
the second screen. That’s because even though the button says Next, 
the script tells Director to go to the frame labeled Screen Two no 
matter where the button is located in the movie.

It’s a good idea before you start working with cast member scripts to 
open the Cast Window Options dialog box (to do so, choose Cast 
Window Options from the Cast menu), and then select Indicate Cast 
Members with Scripts. Once you’ve done that, when you attach a 
script to a cast member, an indicator appears in the lower left corner 
of the cast member’s thumbnail in the cast window.

Script
indicator
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Sprite scripts

Remember that when you place a cast member on the stage, what 
Director displays is not the cast member itself, but a sprite associated 
with the cast member. The cast member remains in the cast window, 
and the sprite—an image of the cast member—appears on the stage.

Remember also that a cast member and a sprite aren’t identical. A cast 
member is the template for a sprite, and the sprite has information 
associated with it—such as its position on the stage—that isn’t 
associated with the cast member. Director stores information 
associated with a sprite in a cell in the score, and that information—
like the sprite’s position—can change from cell to cell. Part of the 
information that can be stored in the cell is a script associated with a 
sprite.

Because the information associated with a sprite can change from cell 
to cell, a sprite script—unlike a cast member script—is associated with 
a button in only one cell at a time. You could, for example, have two 
sprites associated with the same cast member on the stage at the same 
time, and if they had different sprite scripts, something different 
would happen when you clicked each of them. In fact, that’s exactly 
what you’re going to do in the next section: you’re going to create 
another sprite based on the transparent cast member used as the 
button overlaying Genji, position the new sprite over the word 
Rokujo, and write a script that tells Director to go to a different frame 
containing different text.
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Creating a sprite script

Create a new sprite and position it over Rokujo:

1. Select cell 2 in channel 7 of the score.

2. Drag cast member 10 from the cast window over the word 
Rokujo on the stage.
Director creates a sprite based on the cast member. The sprite 
looks blank because it’s white like the background.

The information about the sprite appears in the cell you selected 
in the score.

3. Go to the score, and select Bkgnd Transparent from the Ink 
pop-up menu to make the sprite transparent.

All you have to do to make the new hypertext link work properly is 
to give the sprite a script similar to the one for Genji. The script tells 
Director to go to the frame labeled Rokujo.

To create the script:

1. Make sure cell 2 in channel 7 is still selected.

Script pop-up menu
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2. Choose New from the Script pop-up menu.
A script window appears.

3. On the second line of the script, type:
play frame "Rokujo" 

Make sure to include the quotation marks around Rokujo.

4. Press Enter on the keypad to close the Script window.

Play the movie again to see how the new hypertext link works:

1. Press Command-R to rewind the movie.

2. Press Shift-Enter to start it.

3. Click Genji.
A screen of text appears with information about The Tale of Genji.

4. Click the Return button.
The first screen reappears.

5. Click Rokujo.
A screen of text appears with information about Rokujo’s role in 
The Tale of Genji.

6. Click the Return button.
The first screen reappears.

7. Press Command-period to stop the movie.

Save the movie:

þ Choose Save As from the File menu (or press Command-
Shift-S), name the movie “Hypertext 1,” and click Save.
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This chapter just scratches the surface of the hundreds of ways you 
can use buttons and the thousands of things you can do with Lingo. 
One of the next things you’ll probably want to find out is how to 
make a sprite highlight when a user clicks it. For information, see 
Chapter 4, “Using Puppets,” in Using Lingo. Using Lingo contains not 
only a dictionary of all the elements that make up Lingo, but a 
comprehensive set of tutorials that provide a thorough grounding in 
how Lingo works and how to make the best use of it. 

Note The movies you’ve created in the course of working through the examples in 
this guide take up considerable disk space. It’s a good idea to delete them once 
you’ve finished with them.
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IndexIndex
A
Add button (paint window) 182
Align Bitmaps command 166–167
America Online, contacting Macromedia on 4
Auto Distort command 158–160

B
background color

of bitmaps, setting 60–62
of the stage, setting 34

background color chip (control panel) 34
background color chip (paint window) 62
background color chip (tools window) 98, 103
Background Transparent ink, using 35–36
bitmapped text 57, 58

background color 60–62
changing color depth 101–102
foreground color 60–62

Black and White User Interface (Preferences 
dialog box) 177

Blend (score Ink pop-up menu) 100, 149
branching, defined 192
Brush Shapes dialog box 68
buttons

adding scripts to 203–204
creating 196–207
pausing with 204–207
using to create hypertext 208–221
Index
C
Cast Member Info dialog box 136
cast member scripts 216–217
cast members

adding to cast window 13–18
adding to the score 18–23
aligning 164–168
animating sequences of 105–129
creating automatically 158–163
creating in the paint window 14–16, 61
defined 11
differentiated from sprites 21
dragging to the score 20–23, 96, 186
importing 17–18, 134–135
scripts attached to 203, 216–217

Cast to Time command 161–163
cast window

adding cast members 13–18
defined 11
Shift-clicking to select multiple cast members 

in 161
text cast members, creating 58

cast, assembling 13–23
cells

defined 19
double-clicking to select a range of 149, 156
Option-dragging to copy a range of 144, 156
Shift-clicking to select a range of 49, 118, 

143, 186
Changing Area (Set Transition dialog box) 174
channels

defined 19
selecting 33
shuffling in the score 37

Clear Cells command 127
color cycling 181–189
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color depth, changing for a bitmapped 
image 101–102, 107–108

color gradients 181–186
color palettes

setting 187–189
transitions 175–180

color, setting the stage background 34
colorizing a text sprite 103
CompuServe, contacting Macromedia on 4
control panel 12, 30–31

background color chip 34
Loop button 25
setting the tempo in 24

Convert to Bitmap command 58, 101
Copy Cells command 128, 167
Create Projector command 54–55
Cut Cells command 143

D
destination color chip (paint window) 67, 183
Director

creating a new movie 9
distributing movies 54–55
interactivity 191–221
projectors, creating 54–55
starting 9

distributing Director movies 54–55

E
eraser (paint window) 64
eyedropper (paint window) 67

F
filled rectangle tool (paint window) 183
Film Loop dialog box 126
film loops

creating 125–129
defined 125
in-betweening 127–129
Index224
foreground color chip (paint window) 62, 183
foreground color chip (tools window) 103
foreground color of bitmaps, selecting 60–62
frames

defined 19
labeling with markers 196–201

Free Rotate command 159

G
go to command 197, 204
Gradients command 181–186

H
hypertext 208–221

defined 208

I
Import command 17–18, 118, 134–135
In-Between Linear command 39–41, 49, 118, 

127–129, 186
In-Between Special command 50–53, 147–155
ink

Background Transparent 35–36
Matte 32–33
Reveal 72–74
Switch 66–69, 114–116
Transparent 72–75

interactivity 191–221
buttons 196–207
defined 191
hypertext 208–221

J
Jump to Top button 138, 173



L
lasso (paint window) 64–65
layering of sprites 37–38
line width selector (paint window) 184
Lingo

go to command 197, 204
on mouseUp keyword 204, 212, 214, 217
pause command 204–207
play command 212, 214, 217, 220
scripts

adding to buttons 203–204
types 215–218

Location option, In-Between Special dialog 
box 52

Loop command 25
looping, setting 25

M
Macromedia Authorized Training Providers 4
Macromedia International User Conference 4
marker well (score window) 200
markers

creating 196–201
labeling 196–201

markers window 200–201
Matte ink, using 32–33
mouse clicks, waiting for user’s 193–195
mouseUp keyword 204, 212, 214, 217

N
New command 9

O
on mouseUp keyword 204, 212, 214, 217
on-line services, Macromedia 4
Over Time option (Set Palette command) 188
Index
P
paint bucket (paint window) 74, 108–109
paint window 11

Add button 61, 182
background color chip 62
creating a cast member in 14–16
creating text in 57–77
destination color chip 67, 183
eraser 64
eyedropper 67
filled rectangle tool 183
foreground color chip 62, 183
lasso 64–65
line width selector 184
paint bucket 74, 108–109
paintbrush 68
patterns 111–113
Place button 70, 115
rectangle tool 83–84
selection rectangle 159, 185

Paint Window Options 68
paintbrush 68
palette channel (score window) 176
Palette Transition setting (Set Palette dialog 

box) 178
palettes

color cycling 181–189
setting 187–189
transitions 175–180

Paste Cells command 128, 168
Paste command, compared to Paste Relative 

command 123
Paste Relative command 123–124
Path slider (In-Between Special dialog box) 52
patterns (paint window) 111–113
pause command 204–207
pausing a movie with interactivity 204–207
Place button (paint window) 70, 115
play command 212, 214, 217, 220
playback head, defined 20
playing movies 30–31, 209
Preferences command 177

Black and White User Interface 177
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Preview Path button, In-Between Special dialog 
box 52

projectors 54–55

Q
QuickDraw text 57, 58

colorizing 103
converting to bitmapped text 101–103
creating 79–103

R
real-time recording 24–29
recording

real-time 24–29
step 39–48

rectangle tool (paint window) 83–84
registration points

aligning 164–167
defined 164

Remap to Closest Colors option (Transform 
Bitmap dialog box) 108

Reveal ink 72–74
Reverse Sequence command 156–157

S
sample movies 8
Save command 23, 29
scene transitions 171–174
score window 12, 18–20

Ink pop-up menu 32–33, 35–36, 100, 162
Jump to Top button 138, 173
marker well 200
markers 196–201
palette channel 176
script channel 205
Shuffle Backward button 37, 117
sound channels 132
tempo channel 140–141
transition channel 172
Index226
Scrapbook
copying a sprite from 92
saving a copy of a sprite in 90–91

script channel (score) 205
scripts

adding to buttons 203–204
for cast members 216–217
for sprites 218–220
types 215–218

selection rectangle (paint window) 159, 185
sequences of cast members, animating 105–129
sequences of sprites, reversing 156–157
Set Palette command 178, 187–189
Set Sound command 138
Set Sprite Blend command 150
Set Tempo command 140–141

Wait for Mouse Click or Key 193–195
Set Transition command 173–174
shadow, creating for text 98–100
Shuffle Backward button 37, 117
sound channels (score window) 132
sounds 131–144

Cast Member Info for 136
importing 134–135
repeating 142–144

Source Movies list (Create Projector dialog 
box) 54

Space to Time command 121–122
Sprite Info command 89, 152–153
sprite scripts 218–220
sprites

aligning on the stage 167–168
attaching scripts to 218–220
bounding boxes of 32
defined 21
differentiated from cast members 21
layering 37–38
scaling 152–153

stage
adding a button to 201–202
aligning sprites on 167–168
defined 12
setting the background color of 34

Standard Button tool (tools window) 201–202
starting Director 9



step recording 39–48
Switch Cast Members command 128, 167–168
Switch Colors command 114–116
Switch ink 66–69, 114–116

T
tempo

changing with the In-Between Special 
command 152–155

pausing with interactivity 204–207
setting in the control panel 24

tempo channel (score window) 140–141
text

adding a border to 95–100
animating 60–71
bitmapped 57, 58
cast members 58
converting QuickDraw to bitmapped 58, 

101–103
creating in the paint window 57–77
creating with the tools window 79–103
displaying against a background 93–94
making interactive (hypertext) 208–221
moving to the stage and score 70–71
QuickDraw 57, 58

Text menu 63
Border submenu 97
Box Shadow submenu 97

text tool (paint window) 63
text tool (tools window) 81–89
tools window

background color chip 98, 103
creating text 79–103
foreground color chip 103
Standard Button tool 201–202

training, Macromedia 4
Transform Bitmap command 101–102, 108
transition channel (score window) 172
transitions 171–174
Transparent ink 72–75
Index
U
user control (interactivity) 191–221
user groups, Macromedia and 4

W
windows

opening 10–11
See also entries for specific Director windows.

Z
Zoom In command 110–111
Zoom Open (Set Transition dialog box) 174
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