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Chapter 1: Introduction

Welcome
Image Doctor is a set of Photoshop filters that clean up visual defects in digital photos.  With 
Image Doctor, you can seamlessly remove small things like pimples or large things like an 
ex-husband.  You can even make a low quality JPEG image from the Web look good again.

Image Doctor consists of five filters in a sub-menu off of Photoshop’s Filter menu.  All of the 
filters work on 8 or 16-bit images, which means that they work on Raw images after they 
are loaded into Photoshop.  All of the filters work in either Grayscale or RGB mode.

How to Use This Manual
The Getting Started chapter covers installation and running Image Doctor for the first time.

The User Interface chapter explains how to preview filters, apply them, and work with 
settings.  To get the most out of Image Doctor, be sure to read this chapter.  We have a lot of 
cool features that may not be obvious.

Please read the Before You Start and Making Selections chapters before you jump into 
Image Doctor!  Before You Start will help you choose the right filter for the job.  Making 
Selections will give you better results and make your work easier.

There is a chapter on each of the five filters: Dust and Scratch Remover, Smart Fill, 
Blemish Concealer, Skin Softener, and JPEG Repair.
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Chapter 2: Getting Started
Installing Image Doctor is pretty quick and painless, but to be safe, follow these instructions.

Host Requirements
Image Doctor is a plug-in. That means that you must already have installed one of the 
following host programs. It is possible that Image Doctor will work with other image 
editors, but we have only tested with and support the ones below.

•  Adobe Photoshop CS2 or later

•  Adobe Photoshop Elements 4 or later

•  Macromedia Fireworks CS3 or later

•  Corel Paint Shop Pro Photo XI or later

Installing Image Doctor is quick and painless, but follow these instructions to be safe.

Macintosh Installation
1.	 Shut down your graphics host program (usually Photoshop).

2.	 Insert the Image Doctor CD into your computer.  Or, if you purchased an electronic  
	 version of Image Doctor, locate the installation program that you downloaded from the  
	 online store.

3.	 Double-click the Install Image Doctor 2 icon in the Finder.

4.	 An authentication dialog will appear.  Enter the user name and password of an account  
	 with administrator privileges on your computer.  For information on configuring your  
	 user account for administrator privileges, talk to your IT guy or consult your Mac OS X  
	 user manual.

5.	 The welcome screen will appear.  Click Continue.

6.	 The License Agreement screen will appear.  

7.	 After reading the License Agreement, click Continue.  Click Agree.

8.	 The registration information screen will appear.  Enter your name, company name  
	 (optional) and your registration code.

Note: The registration code is a 12-letter sequence on the front of the Quick Start Guide.  If 
you purchased an electronic version of Image Doctor, you will find the 12-letter code in the 
e-mail invoice sent with your downloaded software.  Store this code in a safe place for future 
installations.

9.	 Click Register.  The installer will search for all compatible graphics programs on your  
	 computer and display them in a list.

10.	Highlight one program in the list and click OK.  You can only install into one graphics  
	 program at a time.  Rerun the installer if you wish to install into another graphics program.
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Windows Installation
1.	 Shut down your graphics host program (usually Photoshop).

Note: To install Image Doctor, your Windows user account must have administrator privileges.  
For information on configuring your user account for administrator privileges, talk to your IT gal 
or consult your Windows user manual.

2.	 Insert the Image Doctor CD into your computer.  Or, if you purchased an electronic  
	 version of Image Doctor, locate the installation program that you downloaded from the  
	 online store.

3.	 Double-click the setup.exe icon.

4.	 The welcome screen will appear.  Click Next.

5.	 The License Agreement screen will appear.  

6.	 After reading the License Agreement, click Accept.

7.	 The registration information screen will appear.  Enter your name, company name  
	 (optional) and your registration code.

Note: The registration code is a 12-letter sequence on the front of the Quick Start Guide.  If 
you purchased an electronic version of Image Doctor, you will find the 12-letter code in the 
e-mail invoice sent with your downloaded software.  Store this code in a safe place for future 
installations.

8.	 Click Next.  Our installer will search for all compatible graphics programs on your  
	 computer and display them in a list.

9.    Highlight one program and click OK.  You can only install into one graphics program at  
	 a time.  Rerun the installer if you wish to install into another graphics program.
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Running Image Doctor
To run Image Doctor, first start up your graphics host program (usually Photoshop).  Open 
your image.  You will be running one of the Image Doctor filters by going to the menu Filter-
>Image Doctor 2.  Before you do, you need to decide what sort of repair you will do.

If you are going to remove an object from the scene, make a careful selection around it.  
The selection should be close to the object all the way around, but not touching it.  If you 
are removing…

a facial blemish, then run Blemish Concealer.

a thin object, then run Dust and Scratch Remover.

any other object, then run Smart Fill.

If you are smoothing skin, then select the area of skin and run Skin Softener.  For an entire 
face, do one patch at a time so you only act on shadows, midtones, and highlights in 
separate runs.

If you are cleaning up a highly compressed JPEG image, then you don’t need a selection.   
Just run JPEG Repair.

Registration
You must register your software to receive technical support and critical product updates.  
Registration also qualifies you for upgrade pricing on future versions of Image Doctor.  
Register online at www.alienskin.com/register.

If you purchased Image Doctor directly from Alien Skin Software, you are automati-
cally registered with us and do not need to register!  You need to register only if you 
purchased Image Doctor elsewhere.
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Chapter 3: User Interface
This section outlines the menus, buttons, settings, and other items in the Image Doctor 
user interface.

Navigation

Menus
Command menus are accessible when you launch any filter. Macintosh users will see the 
menus in place of their usual menu bar. Windows users will see the menus at the top of the 
filter preview window.

Edit Menu
The Edit menu provides an unlimited number of undo’s and redo’s. If you experiment with 
the sliders and find that you prefer a previous group of settings, select the Undo command 
from the Edit menu, or click ⌘+Z (Ctrl+Z on Windows machines) to back up as many times 
as necessary.

The Edit menu also lets you copy, cut, paste and delete values from parameter fields

Filter Menu
The Filter menu lets you switch between Image Doctor filters without leaving the user 
interface. Photoshop users should note that switching filters will make the Actions, 
History, and Last Filter Used functions behave oddly. These will record the filter initially 
selected, not the filter applied.

View Menu
The View menu lets you zoom the preview in and out.  To display the entire image in the 
preview window, select Fit On Screen.  To display the preview at 100% magnification, 
select Actual Pixels. See Keyboard Shortcuts for some nifty zooming shortcuts.

Help Menu
The Help menu leads to local documentation and online Web pages. Clicking Help>Filter 
Help accesses filter-specific documentation. The same assistance can be reached by 
pressing F1 (Windows) or Help (Macintosh).

To access a Table of Contents for the online Help file, click Help>Contents.
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The Filter Window
Title Bar (A):  The title bar displays the currently selected filter, in addition to the currently 
selected setting (see Maintaining Settings, below).

Tabs (B):  You can access the advanced controls for each filter by selecting one of the tabs 
above the settings area.  Refer to the filter chapters for detailed control descriptions.  You 
can click the Settings tab to return to the setting lists.

Show Original, Split, Move and Zoom (C):  The Show Original, Move (hand), and Zoom 
(magnifying glass) buttons are found above the preview window.

The Show Original button toggles the preview between filtered and unfiltered 
versions of your image.  Click and hold the button to view the unaffected image.  

Release the button to preview the effect.  The original image is also displayed while the 
spacebar key is depressed.

Click the hand to enable the Move tool, then click and drag to move around the 
preview image.

Click the magnifying glass to enable the Zoom tool.  Click in the preview window 
to zoom into your image.  Option+click to zoom out (Alt+click for Windows users).  

Double-clicking the magnifying glass at any time resets the preview window to 100% 
magnification.

While in zoom mode, holding down the spacebar temporarily switches to the move cursor.
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UpToDate Message Indicator (D):  When you see this visual cue, you have a new message 
from Alien Skin Software. See the UpToDate Messages section for more details.

Split Screen Preview (E):  Above the preview area is a menu of options for split screen 
previewing. When enabled, this feature shows the original image in half of the preview. The 
entries in the Split Screen menu specify the orientation of the split line or simply turn it off.

OK and Cancel Buttons (F):  Clicking the OK button applies the filter with the current 
settings. Clicking Cancel closes the filter window without applying the effect.

Mouseover Help (G):  Whenever you move your cursor over a user interface element, a 
short description appears in the bottom left corner of the window.

Preview Area (H):  Preview the effect on your image here. Resize the filter window to make 
the preview area larger or smaller.

Navigation Thumbnail (I):  Click and drag the movable red box to move the preview to 
any spot in the selected layer.

Progress Bar (J):  The rectangle to the left of the magnification indicator displays the 
percentage of rendering completed.

Magnification Indicator (K):  The current level of magnification is shown to the right of the 
render status bar at the lower right corner of the filter window.

Factory Settings (L): The settings that are included with the product are displayed in the 
factory settings list.  Click on any of these settings to try them on your image.

User Settings (M): The user settings list contains settings that you create.  See Maintaining 
Settings, below.

Maintaining Settings
A setting is a snapshot of all of a filter’s controls.  When you apply a setting, all of the 
controls on the filter are reset to their remembered values.  

The Settings tab in each filter window lets you create, manage, and share your favorite 
settings.

There are two lists on the Settings tab.  The top list contains factory settings.  Factory 
settings are supplied with the product and can’t be changed.  The bottom list contains user 
settings, which are settings you can create yourself.

Each settings list contains two types of item.  A folder icon (           ) identifies a category.  A 
category contains one or more settings.  To open a category, click the disclosure indicator 
next to the folder icon.  This will reveal all of the settings in that category.  A setting item  
(          ) indicates a setting.  

To apply a setting, simply click the desired setting.
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Saving Settings
To save a setting, first adjust the sliders and other filter controls to your satisfaction.  Then, 
click the save button at the bottom of the Settings tab.  You can also save a setting by 
pressing ⌘+S (Macintosh) or Ctrl+S (Windows).  The Save Setting dialog box will appear.

In the Setting Name box, type a name for your new setting.

The Category radio button allows you to specify a category for your new setting.  If you 
don’t want a category, choose the None button.  If you want to use an existing category, 
choose the Existing button and then select the category in the list to the right.  If you want 
to create a new category, choose the New button and type the name of the new category 
in the box to the right.

Settings are always saved in the User Settings list.

Renaming User Settings
To rename a setting:

1.	 Right click (Ctrl+Click for Mac users) the setting you want to rename.

2.	 Choose Rename or Change  Category

3.	 Type a new name for the setting in the Setting Name box.

4.	 Press OK.

Changing the Category of a User Setting
To move a setting to another category, or to remove its category completely:

1.	 Right click (Ctrl+Click for Mac users) the setting whose category you want to change.

2.	 Choose Rename or Change Category

3.	 Choose the appropriate category option.

4.	 Press OK.
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Deleting a User Setting
To delete a setting:

1.	 Right click (Ctrl+Click for Mac users) the setting whose category you want to change.

2.	 Choose Delete.

3.	 Click Yes to confirm the deletion.

E-Mailing a User Setting
When you e-mail a setting, Image Doctor packages the recipe in a tiny file and attaches 
it to an e-mail message that you can send to a friend.  The E-Mail function only works 
with Microsoft Outlook on the Windows platform and with Apple Mail on the Macintosh 
platform.

To e-mail a setting:

1.	 Right click (Ctrl+Click for Mac users) the setting you want to e-mail.

2.	 Choose Send By E-Mail

3.	 Type the recipient in the mail window which appears.

4.	 Press Send.

Exporting a User Setting
When you export a setting, Image Doctor saves the setting to a folder you specify.  You can 
use the export feature to back up settings that you cannot live without or to share settings 
with a friend.

To export a setting:

1.	 Right click (Ctrl+Click for Mac users) the setting you want to export.

2.	 Choose Export

3.	 Navigate to the location where you want to store the settings file.

4.	 Click OK.

Importing Settings
Importing a setting into Image Doctor is as easy as locating it in your OS file view and 
double clicking it.  You can also download settings directly from the web.  We occasionally 
post new settings on our forum at www.alienskin.com/forum.



13

UpToDate System
The UpToDate messaging system informs you about the latest Alien Skin Software 
products, special offers, software updates and other news. When messages are waiting, an 
unobtrusive visual cue announces, Click here for new messages from Alien Skin. Click 
this link to read your new messages. 

Receiving messages is optional. See the Preferences section for information on disabling 
UpToDate.

Resetting Settings to Factory Default
Every filter has a Neutral setting. Clicking this setting resets the current filter parameters. You 
can also press the F5 key (Windows) or ⌘+R (Macintosh) to reset the filter.

Preferences
Certain global preferences can be set in the preferences dialog. You can invoke this dialog 
by pressing Ctrl+K (Windows) or ⌘+K (Macintosh).

Preferences dialog
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UpToDate System
You can set the interval at which UpToDate checks for messages. Select your desired 
frequency using the Message Checking Frequency list. If you prefer not to receive 
UpToDate messages, set the frequency to Never.

Windows users: If you have a dial-up Internet connection, you should select the Ask me 
before making a network connection option. If not, your computer will make unex-
pected phone calls.

Macintosh users: If you have a dial-up Internet connection, deselect the Ask me before 
making a network connection option. You must establish an Internet connection before 
receiving UpToDate messages.

Preview Background
You can specify the appearance of transparent pixels in the filter preview window by 
choosing one of the options from the Background Style list. The options are None, which 
displays a checkerboard background or a solid matte, either Black, Gray, White, or Custom.

You can choose the checkerboard colors using the two color swatches in the Checkerboard 
group. The size of the checkerboard grid can be adjusted using the Grid Size box.

The custom background color is specified using the Custom Background Color swatch.
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Keyboard Shortcuts

Shortcut Function	 Macintosh	 Windows

Navigate to Next Control	 Tab	 Tab
Navigate to Previous Control	 Shift+Tab	 Shift+Tab
OK	 Return	 Enter
Cancel	 Escape	 Escape
Undo	 ⌘+Z	 Ctrl+Z
Redo	 ⌘+Y	 Ctrl+Y
Cut	 ⌘+X	 Ctrl+X
Copy	 ⌘+C	 Ctrl+C
Paste	 ⌘+V	 Ctrl+V
Next Filter	 ⌘+]	 Ctrl+]
Previous Filter	 ⌘+[	 Ctrl+[
Zoom In	 ⌘++	 Ctrl++
Zoom Out	 ⌘+-	 Ctrl+ -
Actual Pixels	 Option+⌘+Zero	 Alt+Ctrl+Zero
Fit on Screen	 ⌘+Zero	 Ctrl+Zero
Load Factory Default Setting	 ⌘+R	 F5
Load Last Used Setting	 ⌘+L	 Ctrl+L
Save Setting	 ⌘+S	 Ctrl+S
Switch to Move Tool (hand)	 H	 H
Switch to Zoom Tool	 Z	 Z
Preview Move (with zoom enabled)	 Space Bar+Drag	 Space Bar+Drag
Zoom In (with zoom enabled)	 Mouse Click	 Left Mouse Click
Zoom In (with move enabled)	 ⌘+Click	 Ctrl+Click
Zoom Out	 Option + Mouse Click	 Alt + Mouse Click
Drag preview (with zoom enabled)	 Hold spacebar while dragging	 Hold spacebar while dragging
– also displays original image
Zoom to Actual Pixels	 Double-click Zoom Tool	 Double-click Zoom Tool
Increase/Decrease Slider by 1	 Up/Down Arrow	 Up/Down Arrow
Increase/Decrease Slider by 10	 Shift+Up/Down Arrow	 Shift+Up/Down Arrow
Access Online Help	 ⌘+/ or Help	 F1
Open Preferences Dialog	 ⌘+K	 Ctrl+K
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Chapter 4: Before You Start!
It is important to choose the right Image Doctor filter for the situation at hand.  If you try 
to use JPEG Repair to remove a pimple, you’ll get pretty frustrated!  Before you tackle an 
image repair, use the guide below.

Filling gaps or removing unwanted objects
•  The next chapter on selections will help with both of these filters.

•  For small or thin objects on a simple background, use Dust and Scratch Remover.

•  For more difficult objects or backgrounds, use Smart Fill.  It’s usually good to try Dust  
    and Scratch Remover first, since it is easier to use.

Touching up skin
•  The next chapter on selections will help with all of these filters.

•  Start by removing discrete blemishes, such as pimples, one at a time with Blemish  
    Concealer.

•  If the blemishes have sharp edges, like moles or tattoos, then Smart Fill or Dust and  
    Scratch Remover may work better than Blemish Concealer.

•  Then apply Skin Softener to bumpy or splotchy areas of skin.  Tackle one similarly lit area  
    at a time.  Trying to do an entire face with one selection will dull the lighting.

Repairing compressed images
If your client is forcing you to use an overly compressed JPEG image he found on the web, 
then JPEG Repair can help.  You can usually just apply this filter to the entire image.  For a 
really screwed up image, use selections to tackle regions with different settings.
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Chapter 5: Making Selections
Before you run an Image Doctor filter (except JPEG Repair), you must make a selection in 
Photoshop.  The quality of the selection will have a big effect on how well Image Doctor 
works.

The key to making good selections is to get as close to the edge of the object as possible 
without touching it.  Make sure your selection encompasses the object’s shadow too.

The Lasso Tool or Polygonal Lasso Tool are useful if you want to make a quick selection of a 
relatively large object.  The Elliptical Marquee Tool is good for selecting pimples.  For very 
thin scratches we recommend you use Quick Mask Mode (see the next section).

Here is an example of a selection that encompasses a shadow.  You can see that a larger area below the brush was 
selected to include the shadow cast on the floor.

 
Making selections using the Quick Mask Mode

If you have a lot of thin scratches or dust to remove, Photoshop’s Quick Mask Mode can be 
very useful.  Quick Mask Mode lets you create a selection with a paint brush.

The screen shot below shows you how to get started with Quick Mask Mode.  The Quick 
Mask Mode button is circled in green at the bottom of the tool bar.  The paint brush tool is 
circled in blue higher up the tool bar.  In the example, the brush was stroked over areas that 
need to be fixed.
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You can flip back and forth between black and white foreground color to switch from 
building the selection to erasing it.  When you come out of Quick Mask Mode, you will need 
to invert your selection.  That makes your brush strokes be the selected area rather than the 
unselected area.  To do that, either use the menu item Select->Inverse or the shortcut key 
Shift+⌘+I (Macintosh) or Shift+Control+I (Windows). 

Here is a typical use of Quick Mask Mode.

1.	 Enter Quick Mask Mode (Q).

2.	 Select the Brush Tool (B).

3.	 Using a hard brush, adjust the size to match the size of the scratch or dust you want to  
	 remove using the [ and ] keys.

4.	 Paint the dust/scratch you want to remove.  It should be colored with a semi- 
	 transparent red.

5.	 Exit Quick Mask Mode (Q).

6.	 Since the red, painted area is actually the unselected region in quick mask mode, you  
	 need to invert your selection with Shift+⌘+I (Macintosh) or Shift+Control+I (Windows).

7.	 Run Scratch Remover or Smart Fill.
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Since you will do some of these steps frequently, it is convenient to have Photoshop 
Actions to handle them.  If the action is tied to a shortcut key then this all becomes a 
lot easier.  Below are some actions you might want to record and use.  These will also be 
available in a post at the top of our online Image Doctor 2 discussion forum.  Our forums 
are at  http://www.alienskin.com/forum/.  You can download the actions and then import 
them into Photoshop by going to the Actions palette menu and choosing Load Actions.

The actions below assume that you are in quick mask mode and just painted over a scratch 
you want to fix.

Run a filter, stay in Quick Mask Mode
1.	 Leave Quick Mask Mode (Q)

2.	 Invert Selection (Shift+⌘+I on Macintosh or Shift+Control+I Windows)

3.	 Run the filter

4.	 Deselect (⌘+D on Macintosh, Control+D on Windows)

5.	 Enter Quick Mask Mode (Q)

Run a filter, leave Quick Mask Mode
1.	 Leave Quick Mask Mode (Q)

2.	 Invert Selection (Shift+⌘+I on Macintosh or Shift+Control+I Windows)

3.	 Run the filter

4.	 Deselect (⌘+D on Macintosh, Control+D on Windows)
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Chapter 6: Dust and Scratch Remover
Dust & Scratch Remover offers the quickest answer to texture repair and defect removal 
in Image Doctor. Scratch Remover is a simpler-to-use counterpart to the more elaborate 
Smart Fill filter, and should be used to clean up minor texture defects placed in fairly 
homogenous surrounding textures. Use it primarily for eliminating linear defects such as 
tears and creases or to remove small text, such as time stamps, from images. If you want to 
specify where the source texture is taken from, use Smart Fill.

Scratch Remover samples textures from areas surrounding your selection and recombines 
them inside your selection to organically repair images. This avoids the repetitive patterns 
that result from directly cloning source textures.

Example use of Dust and Scratch Remover.  Separate selections were used in the hair and background areas.

Usage
1.	 Before running this filter, make a selection around the object you want to remove.  See  
	 the Making Selections chapter for some tips.

2.	 Start the filter from Photoshop’s Filter->Image Doctor 2 menu.

3.	 Try some of the settings in the Settings tab.  If you need more control, move to the  
	 Basic tab and adjusts the controls, which are described in the next section.

4.	 Click on Random Seed a few times in the Basic tab until you find the best repair.

5.	 Click OK to apply the results.
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Control Descriptions

Contract/Expand Selection
You can widen or thin your selection with this slider.  This is easier than leaving the filter, 
editing your selection, and then restarting the filter.  The selection changes only apply 
while this filter is running.

Scratch Feature Size
Use this slider to specify the texture sample size used for texture replacement.  The feature 
size is relative to your selection size.  It is best to start at the default size of 5 (a middle 
value).  You can then adjust the value up or down to see if you can improve the result.

Background Complexity
This slider can be used to alter the way in which the region is filled depending on the 
characteristics of the background (the region surrounding the area to be filled). If the fill 
region is surrounded by a simple pattern (a blue sky or a repetitive pattern), a low value is 
appropriate. If the background is complex, such as when the fill area crosses the horizon 
or an irregular pattern, a high value is appropriate. For example, if the scratch goes across 
a sharp edge (such as someone’s head), you might increase the slider to get the boundary 
to meet cleanly. On the other hand, having the value high will tend to bring in texture from 
further away. If you want the fill to only take in texture local to the fill region, it is best to set 
it low.

Random Seed
Hit random seed a few times to see if you can get the look just right.

Tips, Tricks and a Tutorial

Making Selections
Great image corrections start with good selections. Try to get a selection that includes your 
defect and only your defect. See the Making Selections chapter for guidance.

To get the best results, divide your work into sections when a defect spans several visually 
different areas. 

Removing Large Quantities of Similar Defects
When removing a large number of similar defects from an image, use the following 
technique to speed up your work:

1.	 Run the filter on an individual defect.

2.	 Select the remaining defects.

3.	 Use the filter ‘redo’ key (⌘-F on Macintosh, Control-F on Windows) to quickly remove  
	 the remaining defects.



22

Tutorial: Repairing an Image with Many Scratches
Scratch remover automatically fills in gaps by copying texture from the surrounding area 
into the scratch. If there are scratches close to the area you are filling you might find that 
your scratch is filled with another scratch.  You can avoid this problem in most cases by 
selecting all of the scratches at once. However, when there are too many scratches you 
need to work progressively.

First, set the feature size and background complexity to low values (or select the “Dust” 
setting).  Start at one end of the scratch (the end with less surrounding scratches) and 
repair a section at a time.  If you get to a section that doesn’t repair well, hit random seed a 
few times to see if that fixes it.  If two scratches are close together, try selecting them both 
at once.  If problems persist, use Smart Fill’s manual mode.

Here is picture with a lot of problematic scratches.
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The selections used are shown in blue.  The filter was applied to each one before moving on to the next.

I still have more work to do, but the large scratch was removed in a couple of minutes.
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Chapter 7: Smart Fill
Use Smart Fill to remove large objects from images with complex background details. Smart 
Fill is unique; rather than directly cloning parts of an image, the filter intelligently samples 
patches around the area to be removed, and then smoothly recombines the patches to create 
a contiguous background texture where the original object once appeared. Dust & Scratch 
Remover can be used to automatically remove relatively simple objects, but when you want 
more control over where the source samples come from, use Smart Fill.

Smart Fill was used to remove this fire hydrant.  One selection was used in the shrub area and one was  
used in the dirt area.

Usage
1.	 Before running this filter, make a selection around the object you want to remove.  See  
	 the Making Selections chapter for some tips.

2.	 Start the filter from Photoshop’s Filter->Image Doctor 2 menu.

3.	 Try some of the settings in the Settings tab.  If you need more control, move to the  
	 Basic tab and adjusts the controls, which are described in the next section.

4.	 Click on Random Seed a few times in the Basic tab until you find the best repair.

5.	 Click OK to apply the results.
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Control Descriptions

Contract/Expand Selection
You can widen or thin your selection with this slider.  This is easier than leaving the filter, 
editing your selection, and then restarting the filter.  The selection changes only apply 
while this filter is running.

Source Mode
Automatic Source – Samples are taken from the immediate area around the selection.  In 
this mode, Smart Fill works very similar to Dust and Scratch Remover.

Manual Source Selection – You specify where samples come from using the Adjustment Tool.

To switch to the Adjustment Tool, click on the pointer button above the preview.  It is 
shown below.

Select the circled button to switch to the Adjustment Tool in Smart Fill.  This lets you move the source sample area.

When you switch to the Adjustment Tool, a box appears in the preview that shows where 
samples will be drawn from.  The hash marks on the box give you a rough idea of the size of 
patches used in the repair.  You can resize and drag this box over the area you want sampled.  
Make sure the source box doesn’t overlap your selection too much, because the area inside 
the selection can’t be used for sampling.  After all, that’s the area we are getting rid of.

This is what the source area looks like when Smart Fill is in Manual Source Mode.

Feature Size
Use this slider to specify the texture sample size used for texture replacement.  The feature 
size is relative to your selection size.  It is best to start at the default size of 5 (a middle 
value).  You can then adjust the value up or down to see if you can improve the result.

In the preview you can see hash marks that give a rough indication of the size of the 
patches that will be used in the repair.  In Automatic Source Mode, the hash marks are on 
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the edges of the preview.  In Manual Source Mode, the hash marks are on the source box.

Background Complexity
This slider can be used to alter the way in which the region is filled depending on the 
characteristics of the background (the region surrounding the area to be filled). If the fill 
region is surrounded by a simple pattern (a blue sky or a repetitive pattern), a low value is 
appropriate. If the background is complex, such as when the fill area crosses the horizon or 
an irregular pattern, a high value is appropriate.

Random Seed
Hit random seed a few times to see if you can get the look just right.

Tips and Tricks
The following tips will help you get the best results when using Smart Fill.

Using the Manual Source Mode
The size of the source rectangle should be sufficient to get enough good samples.  Some 
things to consider:

•  If it is directly over your selection, there will be no samples in the selection area.  Make  
    the source rectangle cover a significant area outside of the selection.

•  Samples near the edge of the source rectangle might not get included.  A patch can only  
    be used if it completely fits within the rectangle.  You may need to make your source  
    rectangle a little bigger to include all the source material you want.

Use Multiple Selections to Remove Objects from  
Complex Backgrounds
When you wish to remove an object that traverses several different background textures, 
you should you use multiple selections and applications of Smart Fill to get the best effect. 
The fire hydrant example at the beginning of this chapter required two separate selections 
and applications of Smart Fill to get the best result.

Using Smart Fill on Long or Narrow Selections
With long or narrow objects (like a car or phone booth), dividing your work into small 
selections gives you more control and better results when using Smart Fill—especially if 
the object you are removing lies on a background of multiple textures—grass, asphalt, and 
dirt, for example. 

Making Good Selections
Great image corrections start with good selections.  Try to get a selection that includes 
only the defect you wish to remove.  Specifically, we recommend that you do not use 
a geometric selection tool, such as Photoshop’s Marquee tool to make your selections.  
Instead, Photoshop users should use the Lasso tool.  See the Making Selections chapter for 
more guidance.
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Chapter 8: Blemish Concealer
This filter completely removes obvious blemishes such as acne, freckles, and shadows 
under eyes.  It is also good at removing small water stains, mold spots, or any other softly 
colored low contrast defect from a relatively smooth background texture.

Usage
1.	 Using the Lasso Tool, select the area around the spot that you want to remove.  Try to  
	 select an area as close as possible to the spot, but make sure you select the entire  
	 defect.  You can make multiple selections around similar objects, if desired.

2.	 Start the filter from Photoshop’s Filter->Image Doctor 2 menu.

3.	 Start Removal Strength at a low value and start nudging it upward until the blemish  
	 is gone.  Try to use this slider only as much as necessary.  Extremely high values can  
	 completely blur the authentic texture of the skin.

4.	 If necessary, adjust the boundary of the selection using the contract/expand  
	 selection slider.

5.	 Click OK to apply the results.

Repeat the same effect to similar objects by hitting Control-F (Windows) or ⌘-F (Mac).   
To bring up the filter window again, use Control-Alt-F (Windows) or ⌘-Option-F (Mac).

Note: If you want to completely remove a blemish and cannot get the results you want 
from Spot Lifter, use Dust and Scratch Remover or Smart Fill.
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Control Descriptions

Contract/Expand Selection
You can widen or thin your selection with this slider.  This is easier than leaving the filter, 
editing your selection, and then restarting the filter.  The selection changes only apply 
while this filter is running.

Removal Strength
This slider controls the intensity of the smoothing process.  Start with a low value and work 
your way up until you like the result.  Too high a value will give blurry results.

Removing Large Quantities of Similar Blemishes
When removing a large number similar facial blemishes or small defects from an image, use 
the following technique to speed up your work:

1.	 Run the filter on an individual blemish.

2.	 Select the remaining blemishes.

3.	 Use the filter ‘redo’ key, Control-F (Windows) or ⌘-F (Mac), to quickly remove the  
	 remaining spots.

4.	 To bring up the filter window again, you can use Control-Alt-F (Windows) or  
	 ⌘-Option-F (Mac).
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Chapter 9: Skin Softener
This filter softens large areas of skin.  It will reduce wrinkles, small shadows, and oily skin 
glare and generally improve the look of skin without making the face look like “plastic”.  It 
will blend seamlessly with the background so you won’t have to manually blend it in with a 
feathered selection.

You should remove any distinct small blemishes, like pimples, with Blemish Concealer 
before you use Skin Softener.  In the example below, some freckles were first removed with 
Blemish Concealer before Skin Softener was applied.

The freckles were removed with Blemish Concealer and Skin Softener was used in small patches.

Usage
1.	 Using the Lasso Tool, select the area around the spot that you want to remove.  Limit  
	 the selection to a region with homogenous lighting.  Don’t span both highlight and  
	 shadow areas at once.  You can make multiple selections around similar swatches of  
	 skin if desired.

2.	 Start the filter from Photoshop’s Filter->Image Doctor 2 menu.

3.	 Start Soften Amount at a low value and start nudging it upward until you like the  
	 results.  Try to use this slider only as much as necessary.  Extremely high values can  
	 completely blur the authentic texture of the skin.

4.	 If necessary, adjust the boundary of the selection using the contract/expand selection  
	 slider.
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5.	 Click OK to apply the results.

Repeat the same effect to similar areas by hitting Control-F (Windows) or ⌘-F (Mac).   
To bring up the filter window again, use Control-Alt-F (Windows) or ⌘-Option-F (Mac).

Control Descriptions

Contract/Expand Selection
You can widen or thin your selection with this slider.  This is easier than leaving the filter, 
editing your selection, and then restarting the filter.  The selection changes only apply 
while this filter is running.

Soften Amount
This slider controls the intensity of the smoothing process.  Start with a low value and work 
your way up until you like the result.  Too high a value will give blurry results.

Good Selections for Skin Softener
This filter will seamlessly blend the boundary of your selection with the background so 
you have to be aware of where the boundary lies.  If your boundary crosses a shadow, the 
dark shadow may creep into the skin tone.  Thus, it is best to run the filter separately on 
homogenous areas.  Handle your shadows and highlights in separate runs of the filter.
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Chapter 10: JPEG Repair
Low quality JPEG images contain ugly 8x8 pixel blocks and fuzzy halos around sharp edges.  
Sadly, designers are often forced to use them by clients who found their favorite image 
on the web.  Luckily, JPEG Repair can help.  It can’t restore details lost in the compression 
process, but it can make the ugly compression artifacts more aesthetically pleasing.

JPEG Repair blended the square blocks together and removed fuzzy halos in the white areas.

Usage
Unlike the other filters in this set, JPEG Repair can be applied to the entire image.  However, 
for extreme cases you might want to apply it to similar areas sequentially.

1.	 Start the filter from Photoshop’s Filter->Image Doctor 2 menu.

2.	 Try some of the settings in the Settings tab.  If you need more control, move to the  
	 Basic tab and adjusts the controls, which are described in the next section.

3.	 Starting from the lowest setting, increment the Deblocking Amount slider until the  
	 perceptible blocky defects of JPEG compression have been removed. Do not overuse.

4.	 If even the strongest Deblocking Amount settings do not remove all of the blocky  
	 artifacts, use just enough Blur Amount to remove the remaining artifacts.
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5.	 Use the Add Grain slider to add back any surface detail lost during Steps 2 and 3. Use  
	 only as much grain as needed.

6.	 Click OK to apply the results.

Less is more.  Start with the sliders low and creep them up until you get the best results.  If 
you are too aggressive, the result will be overly soft.

Control Descriptions

Deblocking Amount
This softens the sharp edged 8x8 pixel blocks found in heavily compressed JPEG images.  
Moving the slider to the right strengthens the deblocking effect.  You might assume 
that selecting the highest value would give you the best results, but that is not the case.  
Excessive deblocking results in an unnaturally soft appearance.

Blur Amount
This slider controls softens the fuzzy halos around sharp edges.  Some blur can help wipe 
out defects, such as extra stubborn artifact edges.  Too much can wipe out all detail from 
your image.

Add Grain
This slider adds simulated film grain to your image, which helps give the illusion of 
natural detail.  That is useful when you are working with an image that has lost detail due 
to JPEG compression.

Tips and Tricks

Resize Images after Using JPEG Repair
When you first obtain a horribly compressed JPEG image, make JPEG Repair the first 
operation you perform on it.

JPEG Repair relies on the fact that JPEG compression works on 8x8 blocks.  Resizing your 
image before applying JPEG Repair will limit the effectiveness of the filter.  Use JPEG Repair 
first, then resize.  Note, it is ok to crop beforehand.

Using JPEG Repair with Selections
You can use JPEG Repair with or without a selection, but we suggest using selections to 
separately treat the areas in your image with perceptibly different levels of damage.  For 
example, skin may exhibit stronger artifacts than hair.  Applying the same strength of repair to 
the entire image may wash out some details that you wish to preserve in the hair.  In this case, 
you should select and treat the hair first, then repeat the procedure on the skin-toned areas.


