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Before You Begin 

Welcome to the Adobe Illustrator 88TM program, a program that combines 
the ease and speed of a computer with the control of fine detail formerly 
possible only when drawing by hand. 

Before you start using the program, be sure to read the next few pages. 
They tell you what this package includes and the equipment you need to 
use the software. 

The Adobe Illustrator 88 program package 

Here is what your Adobe Illustrator 88 program package should include: 

■ The "Adobe Illustrator 88 Video Demonstration" 

■ The Adobe Illustrator Program disk 

■ The Adobe Illustrator Tutorial/Utilities disk (including the 
Adobe SeparatorTM utility and the DrawOverTM utility) 

■ The Adobe Illustrator 88 Tutorial 

■ The Adobe Illustrator 88 User Guide 

■ The Adobe Illustrator 88 Color Guide 

■ The registration card 

If you are missing any of the above items, see your dealer. 

Registration 

Adobe Systems wants to hear from you. Please fill in the enclosed 
registration card and mail it back to us. 



2 User Guide 

What you need 

To use the Adobe Illustrator 88 program, you need one of the following 

three configurations, in addition to the Program disk: 

■ A Macintosh® Plus, with either a hard drive or an 800K external drive 

■ A Macintosh SE, with either a hard drive 

■ A Macintosh II, with either a hard drive 

You will also need the Apple® System software version 4.2 or later. 

To print Adobe Illustrator 88 program documents, you use one or more of 
the following printers: 

■ An Apple ImageWriter® (for draft-quality printing only) 

■ An Apple LaserWriter® or any other laser printer that contains a 

PostScript® interpreter. Such laser printers are currently available from 
Agfa-Gevaert, Apollo Computer, AST Research, Dataproducts, Diconix, 
Digital Equipment Corporation, ITT Qume, The Laser Connection, 
Linotype, NBI, NEC Information Systems, QMS, Sun Microsystems, Texas 
Instruments, Varityper, and Wang Laboratories. 

You can produce color documents with any Macintosh, and you can print 
these documents on any laser printer that prints in color and that 
contains a PostScript interpreter. However, if you will be printing many 
copies, it is more efficient to produce color-separation negatives with the 
Adobe Separator utility and then have them printed by a professional 
printer. If you have a Macintosh II with a color monitor, you will be able 
to preview your illustrations in color. Color illustrations appear in 
appropriate shades of gray on a black-and-white monitor. For complete 
information about printing in color, see the Adobe Illustrator 88 Color 
Guide. 

With the Adobe Illustrator 88 program, you can trace over scanned images 
to create your artwork. Any scanner that saves images in either MacPaint® 
or MacDraw® PICT format can be used. For more information, see "Using 
Scanned Images" in Chapter 1, "Getting Started with the Adobe Illustrator 
88 Program." 
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Learning the Adobe Illustrator 88 program 

Although the Adobe Illustrator 88 program is easy to learn and use, it 
gives you more control over the creation of artwork than any other 
graphics program on the market. In order to provide this control, the 
program works somewhat differently than other drawing and painting 
applications with which you may be familiar. Even if you are an 
experienced user of other graphics applications, you will need to learn how 
to take advantage of all of the possibilities the Adobe Illustrator 88 
program places in your hands. 

This package includes everything you need to make learning the program 
easy and enjoyable. It assumes that you are already familiar with 
Macintosh usage and conventions. We recommend that you use the 
materials provided in the following order. 

First, watch the videotape. It demonstrates the fundamentals of the 
program. Watching the videotape is bound to help you master the Adobe 
Illustrator 88 program more quickly. 

Second, go through the tutorial. It takes you step by step through each of 
the basic techniques you will need to use the program successfully. It also 
provides examples with which you can practice what you've learned so 
that you can become a more proficient user. 

Third, use the program to create your artwork. If you need help as you 
work, refer to this guide. If you are working in color, also refer to the Adobe 
Illustrator 88 Color Guide. 

The Adobe Illustrator 88 program and the PostScript language 

One of the distinctions of the Adobe Illustrator 88 program is its ability to 
take full advantage of the resolution or print quality of the PostScript 
language to create crisper, sharper artwork than can be created using 
programs like MacPaint. Here's why that is possible. 

When you scan an image, or when you use MacPaint to create an image, 
the image is defined by the arrangement of dots (pixels) on the screen. 
When you create artwork with the Adobe Illustrator 88 program, you 
create an image that consists not of dots but of a collection of lines and 
curves, each of which has its own mathematical definition. It is this ability 
to translate images into mathematical constructs that makes it possible for 
this program to create high-quality artwork. 

A PostScript language program comprises all of the definitions that make 
up a piece of artwork. The PostScript language is a computer language 
that conveys information to a printer about the appearance of text and 
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graphics on a page. Each time you print your artwork, you execute the 

PostScript language program that defines that artwork. However, you don't 

need to know anything about PostScript language programming to use the 

Adobe Illustrator 88 program. 

The PostScript language program that defines the artwork is resolution 

independent, meaning that the resolution of the printed artwork is based 

entirely on the resolution of your printer. This means that artwork printed 

on a LaserWriter will have a resolution of 300 dots per inch, artwork 

printed on a LinotronicTM 300 will have a resolution of up to 2540 dots per 

inch, and so on. 
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Chapter 1: Getting Started with the 
Adobe Illustrator 88 Program 

This chapter describes how to start the Adobe Illustrator 88 program, open 
new or existing documents, name documents, close and save documents, 
and quit the program. It also tells you how to plan your work, use 
scanned images, and correct mistakes. 

Starting a work session 

Before you start to use the program, turn on your computer and check to 
be sure you have everything you need. See "Before You Begin," earlier in 
this guide, for a description of the requirements. 

Make a backup copy of the Program disk that you can work with. If you 
need help making a backup copy, see your Macintosh user's guide for 
instructions. 

If you have a hard disk, use the backup copy to install the Adobe 
Illustrator 88 program on your hard disk. 

If you do not have a hard disk, insert the backup copy of your Program 
disk into your internal drive. If you have an external drive, you can save 
your documents to a data disk in that drive. If you do not have an external 
drive, you will have to eject and remove the Program disk each time you 
want to save a file to a data disk. 

NOTE: The Program disk does not include a System Folder. If you have a 
hard disk, it must already have a system installed on it. If you do not have 
a hard disk, you must insert a disk that contains a system into one of your 
two drives before inserting the Adobe Illustrator 88 Program disk in the 
other drive. 

88 
Adobe Illustrator 88" 

Double-click on the Adobe Illustrator 88 program disk icon on the desktop. 
Then double-click on the program icon, a large, curved A with 88 to the 
right of it. 

The first time you start the program, a dialog box appears asking you to 
personalize your copy of the program. 

Adobe 
Illustrator 88TM 

tlK 

Cancel 

—Please personalize your copy of Adobe Illustrator"' 88 —

Name: 

Organization: 
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Enter your name and the name of the organization you work for, if 

applicable, and click OK. The Adobe Illustrator 88 program startup screen 

appears, followed by the program's desktop, which looks like this. 

a File Edit Arrange View Stgle Window 

You are ready to open a document and start working. 

Working with templates and artwork 

Artwork documents 

Whenever you use the Adobe Illustrator 88 program you open an Adobe 

Illustrator 88 artwork document. You open either a new artwork document 

to create a new drawing or an existing artwork document to revise or print 

a drawing. 

You can open a new artwork document and just start drawing, as you 

would on a blank piece of paper. The line art and type that you create with 

the program are referred to as your artwork. 

Untitled artt 
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In addition to opening an artwork document, you may or may not also 
open a template document. The program displays template documents on 
the screen as background bitmaps. 

You use the template as a tracing guide for creating finished artwork. The 
template appears less distinct than the artwork you will create. You can 
make the template visible or invisible, but you cannot change the template 
in any way. 

You can start new artwork by tracing the template, and then refer to the 
template at any time to revise your artwork. 

_❑ Flower Rrt:Flower Template  
4 

cJ 

Usually, when you open an existing artwork document, the corresponding 
template document is displayed automatically. You can use a different 
template, or none at all, by forcing the program to prompt you to choose a 
template. 

Any MacPaint file or any MacDraw file saved in PICT format can be 
opened as a template. 

You create a template either by scanning an existing image or by 
converting a document created with another application. The next section, 
"Using Scanned Images," gives you more information about scanning. 
Chapter 16, "Working with Other Applications," provides more 
information about the use of images created with other programs. 

As you work in the Adobe Illustrator 88 program, you can choose to see the 
artwork only, the template only, or both the artwork and the template at 
any time. For more information about ways of looking at your document, 
see Chapter 2, "Viewing Documents." 

Procedures later in this chapter show you how to open both new and 
existing documents with and without templates. 
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Using scanned images 

If you have a scanner, you can create an Adobe Illustrator 88 program 
template by scanning an existing image. The image you use can be your 

own rough sketch, a photograph, a map or chart, or any other image, even 

one of low quality. With a video camera, you can scan three-dimensional 

objects. 

Scan the image, following the procedures that come with your equipment. 

You must save the image in either MacPaint format or MacDraw PICT 
format in order to use it as a template when you open an Adobe 
Illustrator 88 program document. 

IMPORTANT: Please remember that existing art or images that you may 

desire to scan as templates for your new artwork may be protected under 
copyright law. The unauthorized incorporation of such art or images into 
your new work could be a violation of the rights of the author. Be sure you 
obtain any permission required from such authors. 

Opening documents 

With the program started, you can open a blank (new) document with a 
template, a blank document without a template, or an existing artwork 

document, with or without a template. 

To simplify the opening of documents, it is a good idea to keep 
corresponding artwork and template documents in the same folder. 

To open a new document with a template: 

1. Choose New from the File menu, or press :•:-N. 

A dialog box appears, asking you to choose the template you want to open. 

2. Double-click on the name of the template you want to open. 

A window opens with the name Untitled artl: template in its title bar, where 
template is the name of the template document. The template appears at 
its actual size. 

The number after Untitled art refers to the number of the open window, in 
this case, 1. Each time you open another window, the name in its title bar 
automatically provides a new window number. 

You are ready to start creating your artwork. 

w 

hi 



Chapter 1: Getting Started with the Adobe Illustrator 88 Program 9 

To open a new document without a template: 

1. Choose New from the File menu, or press ::-N. 

A dialog box appears, asking you to choose the template you want to open. 

2. Click None. 

A window opens with the name Untitled artl in its title bar. You are ready 
to start creating your artwork. 

To open existing artwork: 

1. Choose Open from the File menu, or press -O. 

A dialog box appears, asking you to choose an illustration (an artwork 
document) or a template. 

2. Double-click on the name of the artwork you want to open. 

' NOTE: Don't double-click on a template name. If you do, the program will 
open it with a blank artwork document. 

A window opens, with the name of the artwork in its title bar. The new 
window overlaps any other document windows open on the desktop. For 
more information about viewing several windows at the same time, see 
"Displaying Multiple Views of One Document" in Chapter 2, "Viewing 
Documents." 

The artwork appears at its actual size. You can resume working on it. 

To use no template or a different template: 

1. Hold down the Option key, and choose Open from the File menu, or press 

A dialog box appears containing a list of artwork documents. 

2. Double-click on the name of the artwork document you want to open. 

Another dialog box appears, asking you to specify the template document 

you want to open, if any. 

3. Double-click on the name of the template document you want to open 

with the artwork document. 

If you don't want a template, click None. 

If you specify a different template, that template will automatically 
correspond to the artwork document in the future. To have the original 

template correspond to the artwork again, repeat the above procedure, 

selecting the original template name. 
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Planning your artwork 

Before you start drawing, think about how you want your final artwork to 
look. Then take into consideration that the easiest and most efficient way to 
work in the Adobe Illustrator 88 program is to create your drawing in 
layers. 

Unlike many other graphics applications, the Adobe Illustrator 88 
program does not regard all of the objects you draw as occurring on the 
same plane; successively drawn objects are placed in front of one another 
(although they do not necessarily overlap). You can use several techniques 
to change the layering order of objects in the drawing at any time, but you 
may find that your work progresses more smoothly if you learn to take 
advantage of this layering ability. 

The layering order of objects corresponds to their painting order. As you will 
see from studying the example that follows, the best way to approach your 
artwork, when possible, is to create the background first, place large shapes 
in front of it, place smaller shapes in front of those, and put details in last. 

I 
The Adobe Illustrator 88 program is very flexible. You can always change 
the layering order of objects after you have drawn them to create the final 
effect you want. 

For more information about changing the order of objects in your artwork, 
see Chapter 5, "Selecting Objects," Chapter 8, "Moving Objects," Chapter 
9, "Copying Objects," and Chapter 10, "Deleting Objects." To learn more 
about painting order, see Chapter 13, "Painting." 
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Correcting mistakes 

You do not need to be concerned about drawing your artwork perfectly on 
the first attempt. You can make adjustments as you create your artwork 
and at any time after it is created. See Chapter 7, "Adjusting Paths," for 
more information. 

In addition, you can use the Undo command to easily correct mistakes you 
make while using the Adobe Illustrator 88 program. Often, operations can 
be undone, and operations that have been undone can be redone. 

To undo an operation: 

1. Choose Undo from the Edit menu, or press :•:-Z. 

You must choose Undo immediately after the operation, before you click 
anywhere or perform any other operation. The wording of the Undo 
command corresponds to the operation you have just performed. For 
example, if you have just moved an object, the command will read "Undo 
Move." 

If an operation cannot be undone, the Undo choice is dimmed. 

To redo an operation that has been undone: 

1. Choose Redo from the Edit menu, or press :•:-Z. 

You must choose Redo immediately after the Undo operation, before you click 
anywhere or perform any other operation. 

The wording of the Redo command corresponds to the operation you have 
just undone. For example, if you have just undone some typing, the 
command will read "Redo Typing." 

—, If an operation cannot be redone, the Redo choice is dimmed. 

Closing documents 

NOTE: -Z is a toggle. Each time you press it, the most recent operation is 
either undone or redone. 

You close and save Adobe Illustrator 88 program documents much as you 
do documents in other Macintosh applications, by closing their windows. 
Closing a document removes it from the Adobe Illustrator 88 program 
desktop. Once a document is closed, you must open it again to work on it. 



12 User Guide 

❑° 

To close a document: 

1. Choose Close from the File menu, or click in the close box in the upper left 
corner of the document window. 

Naming documents 

If you have changed the document since the last time you saved it, you will 
be asked if you want to save the changes. 

If you have not saved your document before (Untitled art appears in the 
title bar), you will be asked if you want to save the document, and if so, 
give it a name. 

Because you will often be working with two kinds of documents, you 
should adopt a consistent naming scheme so that you can easily 
distinguish artwork documents from template documents. Adobe 
recommends that you name your artwork documents using the form 
Document art and your template documents using the form Document 
template. For example, you could name an artwork document Flower art 
and the template document Flower template. 

When you open a document, the title bar of each window tells you the 
name of the artwork document, followed by the name of the template 
document (if any), followed by the view number (if more than one view 
exists on the desktop), separated by colons. For example, the second view of 
your document might be named Flower art:2: Flower template:2. 

Choosing a preview format 

None 

Before you save your artwork, decide in which format you want to save the 
preview image. It can be saved in one of three formats, as described below. 
The preset option is None. 

If you choose None, your artwork is saved as a complete PostScript 
language program. You can open documents saved with this preview 
format in the usual way to edit, preview, or print them. It is best to use one 
of the other two options to save your document when you want to use it 
with another application that supports the EPS (Encapsulated PostScript) 
format. You can also save your document with None and use it with an 
application that supports the EPS format, but when you preview your 
artwork, you will see only a gray box. 

If you know how to program in the PostScript language, you can also 
open documents saved with this preview format with any word processor 
and make changes to them, although you should take certain precautions 
before editing Adobe Illustrator 88 program documents. Some 

I 
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modifications of the PostScript language file will cause the file to be 
unopenable, although you will still be able to place it or print it. When 
you are not sure about the effects of a change you want to make, check 
with the following Adobe Systems documentation, published by Addison-
Wesley: PostScript Language Program Design, PostScript Language Tutorial and 
Cookbook, and PostScript Language Reference Manual. 

Apple Macintosh 

IBM PC 

Saving documents 

If you choose Apple Macintosh, your artwork is saved in an EPS-format file 
that contains both the PostScript language program for your artwork and 
a preview image in Macintosh QuickDraw PICT format. You cannot edit 
this document with most word processors. This format is designed to be 
used with page composition applications that support the 
Aldus/Altsys/Adobe Encapsulated PostScript file format. Applications that 
support this format display the preview image on the screen for 
placement, scaling, and cropping and send the appropriately transformed 
PostScript language file to the printer. 

If you choose IBM® PC, your artwork is saved in an EPS-format file that 
contains the PostScript language program for your artwork in the 
Aldus/Altsys/Adobe Encapsulated PostScript file format for IBM PC 
products. You cannot edit this document with most word processors. This 
format is designed to be used with page composition applications that run 
on IBM PCs and that support the Aldus/Altsys/Adobe Encapsulated 
PostScript file format. You will have to transfer the file onto an IBM PC-
compatible disk in order to use it with an IBM PC. 

Save your document frequently as you work. Do not wait until your 
artwork is complete, or you may have to redo all of it if something goes 
wrong. 

When you save an Adobe Illustrator 88 program document, you are saving 
the latest version of it. The document remains on the desktop, and you can 
continue working on it. The first time you save a document, you are asked 
to name it. See "Naming Documents," earlier in this chapter, for more 
information. 

When the program saves a document, only the artwork is saved. The 
template, which is stored as a separate document, never changes, and thus 
there is no need to save it. 
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Saving a document under a new name creates a duplicate document under 

a different name while retaining the existing document under its original 

name. You can save a document under a new name as an Adobe Illustrator 
version 1.1 document. 

To save a document: 

1. Choose Save from the File menu, or press 

The Save dialog box appears. 

o HardDisk20 

Adobe Illustrator F... 
d Adobe Separator 
d Applications 
❑ DrawOver Folder 

Save illustration as: 

o HardDisk20 

Drive 

Save , 

Cancel 

-Include preview for 
©Q None Q Macintosh•" Q IBM PC® 

❑ PostScript files for other applications 

❑ Save Adobe Illustrator 1.1 compatible file 

Include copy of placed Encapsulated 

If you have already saved and named your document, the File menu will 
remain highlighted, the watch icon will appear on your screen, and you 
will not be able to continue work on your drawing until the save operation 
is complete. 

If you have not saved your document before, you will be asked to name 
and save the document. Follow steps 2 through 4. 

2. Type the name in the Save Illustration As field. 

3. Choose the format in which you want to save the preview image. 

You can choose None, Apple Macintosh, or IBM PC. See "Choosing a 
Preview Format," earlier in this chapter, for more information. 

If you have placed EPS images in the document you are saving, and you 
will be using the document with page layout applications, click in the 
"Include Copy of Placed Encapsulated PostScript Files for Other 
Applications" checkbox. This saves the EPS files containing the placed 
images with your Adobe Illustrator 88 file. For more information, see 
"Placing EPS Files" and "Saving the Placed Files," in Chapter 16, 
"Working with Other Applications." 
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If you want to save the file as an Adobe Illustrator program version 1.1 
document, click in the "Save Adobe Illustrator 1.1 Compatible File" 
checkbox. If you save in this format, custom colors are converted to process 
colors, masking is not in effect (although all objects involved in the mask 
are present), and patterns and all placed images are removed. 

4. Click Save. 

The document remains open on the desktop, and you can continue 
working on it. 

If you click Cancel, the document is not saved. 

To save a document under a new name: 

1. Choose Save As from the File menu. 

A dialog box appears, asking you for a new document name. 

2. Type the new name in the Save Illustration As field. 

3. Choose the format in which you want to save the preview image. 

You can choose None, Apple Macintosh, or IBM PC. See "Choosing a 
Preview Format," earlier in this chapter, for more information. 

If you have placed EPS images in the document you are saving, and you 
will be using the document with page layout applications, click in the 
"Include Copy of Placed Encapsulated PostScript Files for Other 
Applications" checkbox. This saves the EPS files containing the placed 
images with your Adobe Illustrator 88 file. For more information, see 
"Placing EPS Files" and "Saving the Placed Files," in Chapter 16, 
"Working with Other Applications." 

If you want to save the file as an Adobe Illustrator version 1.1 document, 
click in the "Save Adobe Illustrator 1.1 Compatible File" checkbox. If you 
save in this format, custom colors are converted to process colors, masking 
is not in effect (although all objects involved in the mask are present), and 
patterns and all placed images are removed. 

4. Click Save. 

The document remains open on the desktop, with the new name in the 
title bar. The document still exists under its original name as well, but that 
version is now closed. 

If you click Cancel, the document is not saved. 
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Quitting the Adobe Illustrator 88 program 

To leave the Adobe Illustrator 88 program, choose Quit from the File 
menu, or press :•:-Q. 

If you have made changes to any document currently on the desktop since 
you last saved the document, you are asked if you want to save the 
changes. You can reply Yes, No, or Cancel. 

■ Yes—Saves and closes the document. If it has never been saved (Untitled art 
appears in the title bar), you are asked to name it first. 

■ No—Closes the document without saving it and proceeds to ask you about 
the next open document, if there is one. 

■ Cancel—Cancels Quit command. You can resume work on the current 
document. 

When all documents have been closed, you are returned to the Macintosh 
desktop. 
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Chapter 2: Viewing Documents 

This chapter describes all of the tools and techniques you can use to 
control your view of a document. 

You can use several methods to control how your document is displayed 
on the screen. These methods let you move around in the document, zoom 
in or zoom out, preview the printed output, or display several views of one 
document. This chapter discusses how you can control the visibility of the 
template, the artwork, and the toolbox. You can also control the visibility 
of the rulers. For more information, see "Displaying the Rulers" in 
Chapter 12, "Measuring and Constraining." 

Looking at the working area 

Here's how your screen looks when you first open a document, in this case 
a template. 

=_Q  [hair Rrt:Chair Template  
4 

L 

The document working area is a square 1008 by 1008 points (14 by 14 
inches). It is subdivided into pages when you print. The number of pages 
into which it is divided depends on how you set up the page. See "Setting 
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Up Pages" in Chapter 15, "Printing Documents," for more information. 
When you use the most common setting (U.S. letter size paper printed at 
100 percent), the document is divided into nine pages. 

Dotted lines define the printed surface of each of nine pages. You can see 
how the pages relate to your whole working area when you view the entire 
document on the screen with the Fit In Window command. You can also 
see parts of these dotted lines as you scroll your document at its actual size 
while you are working. 

Chair Rrt:Chair Template   

2 3 

6 

Four of the page numbers-2, 3, 5, and 6—appear in the working area. 
These are for your reference only. The page numbers themselves are never 
printed and do not affect the art you create. 

Only page 5 appears in its entirety. You can adjust the placement of page 
5 within the working area. You will often draw your artwork only on page 
5, although you can draw on and print any of the pages in the working 
area. See Chapter 15, "Printing Documents," for more information. 
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Scrolling a document 

You can view different areas of a document by using the scroll bars or the 
hand tool. 

Using the scroll bars 

R 

ri 

The scroll bars work just as they do in 
other Macintosh applications. You have 
three options. 

To use the scroll bars: 

Option 1 Click the scroll arrow that points in the direction you want to 
see: up, down, left, or right. 

You can scroll continuously by keeping the mouse button pressed on the 
scroll arrow. 

Option 2 Click the gray area of the scroll bar, above or below the scroll 
box, depending on the direction you want to see. 

This scrolls half a window at a time. 

Option 3 Drag the scroll box to the location in the scroll bar that 
approximates the location in the document you want to see. 

Using the hand tool 

You can use the hand tool to control the area of the document you see. 
Moving the hand tool around on your document is like moving a piece of 
paper around on your desk with your hand placed on top of the paper. 

To scroll with the hand tool: 

1. Click on the hand tool in the toolbox. 

The pointer becomes a hand when moved to the active window. 

2. Drag the hand in the direction in which you want the document to move. 

Be sure to keep the mouse button held down. The document moves with 
the hand. 
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To move the hand around on the document without moving the document 

itself, release the mouse button and move the mouse. 

SHORTCUTS: To scroll quickly with the hand tool while using another tool, hold 

down the Space bar and drag the hand. As soon as you release the Space bar, the 
previously selected tool is available again. 

To see the full 14-inch by 14-inch working area, double-click on the hand tool. 

This is equivalent to choosing the Fit In Window command. 

Magnifying and reducing with the zoom tool 

  The zoom tool, represented by a magnifying glass in the toolbox, lets you 
  zoom into or zoom out of any area in your document. You can use it to 

control how much of the document you see in the active window. 

Each time you click with the zoom tool, the document is magnified or 
reduced by a factor of two. In other words, each click either doubles or 
halves the size of the image you see. Zooming does not change the size of 
the actual objects, only the magnification at which you see them. For 
information about enlarging or reducing the objects themselves, see "Using 
the Scale Tool" in Chapter 11, "Transforming Objects." 

You can zoom through a total of nine magnification or reduction levels. 
Starting from 100 percent scale when you open a document, you can 
enlarge it to 200 percent, 400 percent, 800 percent, and 1600 percent, and 
you can reduce it to 50 percent, 25 percent, 12.5 percent, and 6.25 percent. 

If rulers are displayed, zooming also affects them. See "Displaying the 
Rulers" in Chapter 12, "Measuring and Constraining." 

To magnify or reduce with the zoom tool: 

1. Click on the zoom tool in the toolbox. 
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The pointer becomes a magnifying glass with a plus sign in the center, 
indicating that the zoom tool will magnify. 

I NOTE: If you hold down the Option key, the magnifying glass will have a 
minus sign in the center, indicating that the zoom tool will reduce. 

2. Position the magnifying glass in the center of the area you want to 
magnify or reduce. 

The document will zoom around this point. 

3. Click. 

a 
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O° 

The document zooms in or out by a factor of two. If you click again, the 
document again zooms by a factor of two. 

I NOTE: The plus sign and the minus sign in the magnifying glass 
disappear when the document cannot be magnified or reduced further. 

=p Chair flrt:ChairTemplate 
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SHORTCUTS: To magnify while using another tool, hold down the Space bar 
and the :•: key simultaneously, and click. When both keys are released, the 

previously selected tool is available again. 

To reduce while using another tool, hold down the Space bar, the :•: key, and the 

Option key simultaneously, and click. When all three keys are released, the 
previously selected tool is available again. 

To magnify from the center of the active window, double-click on the zoom tool 
in the toolbox. 

To reduce from the center of the active window, hold down the Option key, and 
double-click on the zoom tool in the toolbox. 

To scroll and zoom at the same time, drag the magnifying glass. The magnifying 
glass changes to the hand while you hold the mouse button down. 
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Displaying documents 

You can display your documents in more than one way while you work. 

When you open a document, it is displayed at actual size in the working 
area. Yet at actual size you see only part of the whole document. You can 
choose a view that displays the entire document, and you can choose 
multiple views of the same document. 

In addition, you can choose the kind of document you display: template 
only, artwork only, or template and artwork. At any time, you can preview 
how your artwork will look when it is printed. 

Fitting documents in the window 

When you choose the Fit In Window command, the document is scaled 
and centered so that it can be viewed in its entirety in the active window. 

You can manipulate objects in this view just as you can when they are at 
actual size. 

To fit a document in the window: 

1. Choose Fit In Window from the View menu, or press 

The entire document appears in the window. 

  Chair Rrt:Chair Template  
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SHORTCUT: Double-click on the hand tool in the toolbox to choose Fit In 
Window. 

Restoring documents to actual size 

At any time, you can restore your document to actual size. 

To restore a document to actual size: 

1. Choose Actual Size from the View menu, or press -H. 

The document is displayed at its actual size and is centered in the active 
window. 

SHORTCUT.: Double-click on the hand tool in the toolbox while you hold down 
the Option key to choose Actual Size. 

Displaying multiple views of one document 

You can display several views of the same document. Each view of the 
document is in a separate window on the desktop. 

For example, you can simultaneously view several magnification levels of 
one drawing, or you can display a preview image in one window and 
artwork in another. 

When two or more views of the same document are on the desktop, the 
program assigns each a number, which appears in their title bars. 

To open a new window: 

1. Size the existing window to approximately half its current size so that there is 
enough room for the window you are going to create. 

2. Choose New Window from the Window menu. 

A new window appears on top of the previously active window. The two 
windows are identical except for their window numbers. The scroll bars in 
window 2 are shaded, which indicates that it is the active window. 
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Size and move the new window so that you can see both windows at the 
same time. For help with sizing or moving windows, see "Managing 
Multiple Windows," later in this chapter. 

Chair Rrt:Chair Template:1 ❑= Chair Rrt:Chair Template:2 =❑_ 

Viewing the template and artwork 

You have several choices about what is visible in a window. You can 

display the template only, the artwork only, or the template and artwork 

together. You can also display a preview image of your artwork, as 
described in the next section. The Template Only command temporarily 

removes the entire artwork from view. Removing the template or artwork 

from view does not delete either one. 

To view the template and/or the artwork: 

1. Choose the appropriate command from the View menu. 
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The following illustrations show the effects of each command. 

Template Only Artwork & Template 

Artwork Only Preview Illustration 

Previewing printed output 

You can use the Preview Illustration command at any time to get a rough 
idea of what your artwork will look like when it's printed. When you 
choose this command, an image of your artwork is displayed in the active 
window, with the currently selected paint and type attributes. Only the 
previewed image appears; the artwork and template are not displayed. 

You can perform viewing operations on a preview window, but you cannot 
edit a preview image. Therefore, the only tools that you can use from the 
toolbox are the hand tool, the zoom tool, the measure tool, and the page 
tool. You cannot use any commands from the Edit menu, Arrange menu, 
or Style menu. 
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If you are working on a Macintosh II with a color monitor, you can 
preview either in color or in black and white. See the Adobe Illustrator 88 
Color Guide that accompanies this manual for instructions on adjusting 
your color monitor before you preview. 

To preview your artwork: 

1. Choose Preview Illustration from the View menu, or press -Y. 

The previewed image does not represent your artwork exactly but it will 
give you a rough idea of how your artwork will look when it is printed. See 
the illustration at the end of the previous section for an example of a 
previewed image. 

Managing multiple windows 

The Adobe Illustrator 88 program supports four standard Macintosh 
window manipulation techniques. With them, you can do the following: 

■ Change the window size 

■ Restore the window to normal size 

■ Move a window 

■ Close the active window 

To change the size of a window: 

1. Position the pointer on the size box (in the lower right corner of the window), 
and drag it. 

2. Release the mouse button when the window is the size you want. The 
window remains at the new size. 

To restore a window to its normal size: 

1. Click the window's zoom box (in the upper right corner of the window). 

The window is restored to the size it was when you started the program. 
The zoom box is a toggle. Clicking it again changes the window back to its 
last size. 

9 
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To move a window: 

1. Position the pointer anywhere on the title bar of the window, except in the 
close box. 

2. Drag the window to the new position, and release the mouse button. 

The window remains at the new position. 

To close the active window: 

1. Click its close box, or choose Close from the File menu. 

If the document was saved previously and there have been no changes, the 
active window closes. 

Displaying the Clipboard 

If you have cut or copied objects, you can show the Clipboard window at 
any time to see how many objects it currently contains, and then you can 
hide it again. 

This command is a toggle. Choosing Show Clipboard changes the menu 
command to Hide Clipboard, and choosing Hide Clipboard changes the 
menu command to Show Clipboard. 

To show or hide the Clipboard: 

1. Choose Show Clipboard from the Window menu. 

The Clipboard window appears, indicating the number of objects it 
currently contains. 

2. Choose Hide Clipboard from the Window menu, or click in the close box 
of the Clipboard window. 

The Clipboard window disappears. 
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Managing the toolbox 

When you open a document, the toolbox appears on the left of the screen. 
At the top of the toolbox is a title bar (no title appears) and a close box. 
The rest of the toolbox contains the following tools. 

T 

0 
C)

selection tool 

hand tool 

zoom tool 

type tool 

freehand tool 

auto trace tool 

pen tool 

rectangle tool 

oval tool 

blend tool 

scale tool 

rotate tool 

reflect tool 

shear tool 

scissors tool 

measure tool 

page tool 

If you want more room to work, you can hide the toolbox and use the 
equivalent keyboard commands instead. You can also move the toolbox to 
another area of the screen. 
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Showing and hiding the toolbox 

You can hide the toolbox from the desktop to get a little more room on the 
screen. 

To hide the toolbox: 

1. Choose Hide Toolbox from the Window menu, or click the toolbox close box. 

If the toolbox is invisible, you can still use the last tool you selected. 

To regain access to all the tools, you must make the toolbox visible. 

To show the toolbox: 

1. Choose Show Toolbox from the Window menu. 

The toolbox reappears. 

Moving the toolbox 

When it's visible, you can move the toolbox around on the screen, but it 
always remains frontmost. 

To move the toolbox: 

1. Position the pointer in the title bar of the toolbox. 

2. Drag the toolbox to the new position, and release the mouse button. 

The toolbox remains in the new position. 



Chapter 3: Drawing Paths 

This chapter describes exactly how the Adobe Illustrator 88 program 
defines paths. Then it tells you how to use the freehand tool, the auto trace 
tool, or the pen tool to draw straight line paths and curved paths. Note 
that this chapter does not tell you how to adjust paths. For information on 
making adjustments, see Chapter 7, "Adjusting Paths." 

Defining paths 

A path is any line or shape you create by using the Adobe Illustrator 88 
software drawing tools. The freehand tool, the auto trace tool, and the pen 
tool are described in this chapter. The rectangle tool and the oval tool are 
described in Chapter 4, "Drawing Rectangles and Ovals." 

A path can consist of a single anchor point, a single segment, or two or more 
segments. 

A path consisting of one anchor point is not connected to any segments. 

A path consisting of one segment has anchor points that are connected 
only to that segment. 

A path consisting of two or more segments has anchor points that are 
connected to two adjacent segments. 

a 
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Open and closed paths 

You can create either open paths or closed paths. Open paths consist of a 
sequence of straight lines and/or curves spanning from one distinct 
endpoint to another distinct endpoint. 
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Closed paths have no endpoints. Their first anchor point and their last 

anchor point are the same. 

open path 

G 
closed path 

All segments 

Each segment can be either a straight line or a curve. Segments are both 

bounded by and connected by anchor points. The anchor points define 

where each segment starts and ends. The first and last anchor points on a 

path are also called endpoints. 

A segment's shape and size is determined by the anchor points, direction 

points, and direction lines associated with it. 

Curved segments 

On curved segments, each selected anchor point displays either one or two 
direction points, at the ends of direction lines. The direction lines are 
always tangent to (touching) the curve at the anchor points. 

The position of each direction point and direction line relative to its 
anchor point determines the size and shape of the curved segment. 

I 
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The slope of each direction line relative to its anchor point determines the 
slope of the curve. 

The length of each direction line relative to its anchor point determines the 
height or depth of the curve. 

See "Understanding a Few Rules," later in this chapter, for more 
information about drawing curves. 

Straight line segments 

On straight line segments, both direction points and their direction lines 
are coincident with the anchor points. This means that the direction lines 
occupy the same position as their anchor points and are therefore not 
displayed. 

0 
a 

Continuous paths 

You can draw a straight line path consisting of several segments, but 
drawing just one segment is more efficient. 
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To draw continuously curved paths with the freehand tool, just draw the 
line the way you want it. 

freehand tool 

To draw continuously curved paths with the pen tool, follow the Bump 

rule described later in this chapter. 

pen tool 

Continuously curved paths are connected by smooth points. Contrast this 
with corner points, described next. 

Paths with corner points 

Corner points form automatically when your path goes from one straight 
line segment to another straight line segment, because the direction lines 
are of 0 length. 
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There are three instances in which you need to create corner points on 
paths: 

■ When joining a straight line segment to a curve segment 

■ When joining a curve segment to another curve segment so that they are 
non-continuous 

■ When joining a curve segment to a straight line segment 

Working with paths 

To create corner points with any of the drawing tools, see "Adding 
Segments to Existing Open Paths," later in this chapter. 

As you are drawing a path, you can constrain the location of its anchor 
points relative to the currently set angle of the x and y axes of the 
document. For more information, see "Rotating the X and Y Axes," in 
Chapter 12, "Measuring and Constraining." 

After you draw a path, you can adjust, paint, or transform it in several 
ways to obtain the exact look in your artwork that you want. 

The whole path, or any of its anchor points or segments, can be adjusted 
at any time. For more information, see Chapter 7, "Adjusting Paths." 

The whole path (not just parts of it) can be filled and/or stroked with 
black, white, shades of gray, patterns, or process or custom colors. In 
addition, masking, line weight, and other line attributes can be specified. 
Single anchor points cannot be painted. For more information, see 
Chapter 13, "Painting." 

The whole path, or any of its anchor points or segments, can be 
transformed at any time. For more information, see Chapter 11, 
"Transforming Objects." 



36 User Guide 

Choosing a drawing tool 

You can draw paths in the Adobe Illustrator 88 program with three 

drawing tools: the freehand tool, the auto trace tool, or the pen tool. Each 

tool works somewhat differently, making it useful for particular drawing 

needs. 

Paths created with any of the three tools are adjusted, painted, or 

transformed in exactly the same way. 

In rare cases, you may draw a path that is either too long or too complex. 

The program will stop drawing the path and will display an error 

message. When you release the mouse button, the beginning of the path 

that you were drawing will remain, but to finish the path, you must go 

back to the ending anchor point and start drawing again. 

The freehand tool 

The freehand tool lets you work just as if you were drawing with a pencil 

on paper, and is best suited to fast sketching. It is very useful for drawing 

when you do not have to be extremely precise or when you want your 

artwork to have a more spontaneous look than you could achieve using 

the pen tool. However, you cannot easily create perfectly straight lines with 

the freehand tool, and the curved lines you create may be somewhat 

bumpy. 

The freehand tool allows you to erase paths as you are drawing them. 

When you use the freehand tool, anchor points are automatically set down 

for you; you do not determine where they occur, although you can adjust 

them when the path is complete. The number of anchor points set down is 

determined by the length and complexity of the path and by the freehand 

tolerance value set in the Preferences dialog box. 

The freehand tolerance value allows for the fact that your hand may 

wobble a bit as you are drawing. See the next section, "Drawing with the 

Freehand Tool," for more information. 

If you draw a freehand path that extends outside the active window, that 

path will continue to be drawn past the edge of the active window, and you 

will be able to see it when you scroll. 

You cannot constrain the location of anchor points drawn with the 

freehand tool. To constrain the location of anchor points while you draw a 

path, you must use the pen tool. 

You can create corners on curve segments by using the Option key with 

the freehand tool as you do with the pen tool. See "Adding Segments to 

Existing Open Paths," later in this chapter. 
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The auto trace tool 

The auto trace tool traces template shapes automatically to draw paths for 
you. With a template open, you choose the auto trace tool and click near 
the edge of the shape you want to trace. The auto trace tool draws a path 
around the shape, returning to the point at which you clicked. You can 
also trace only between two points that you specify. The new path has the 
currently set paint attributes. It can be adjusted just like any path you 
might draw with the other tools. 

The auto trace tool is especially suited to tracing around simple shapes or 
lines. This relieves you of the tedium of having to spend time drawing the 
basic outlines of your artwork. 

If part of a template shape is very complex, you can draw that part of the 
path with either the freehand tool or the pen tool, and draw the simpler 
parts automatically with the auto trace tool. 

The pen tool 

The pen tool is best used when you want to draw with precision. It allows 
you to create very straight lines or smooth, flowing curves. Your work, 
whether tracing templates or creating an elaborate structure from scratch, 
can be much more precise than it would be if you were using the freehand 
tool. 

You use the pen tool to create a path by setting down anchor points one at 
a time exactly where you want them. You have complete control over each 
anchor point you set down. 

If you hold down the Shift key while drawing with the pen tool, you can 
constrain a straight line to 45-degree multiples relative to the angle of 
constraint specified in the Preferences dialog box. 

If you hold down the Option key while drawing a curved path with the 
pen tool, you can create a corner. See "Adding Segments to Existing Open 
Paths," later in this chapter. 

If you draw a path with the pen tool that extends outside the active 
window, the window automatically scrolls to the adjacent part of the 
working area so that you can finish drawing the path. 
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Drawing with the freehand tool 

You draw paths with the freehand tool by dragging the pointer in the 
working area just as you would move a pencil on paper. You can easily 

draw curved paths with the freehand tool. If you try to draw straight line 
paths, they usually do not appear perfectly straight. Adjusting them so 
that they are straight is very time-consuming. Use the pen tool when you 

want to draw straight lines. 

To draw a freehand path: 

1. Click on the freehand tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

2. Position the x where you want the path to begin. 

3. Drag the mouse to draw a path. 

. 

....per 

As you drag, the x changes to an 
arrowhead and a dotted line trails behind 
it. The faster you drag, the fewer the dots 
in the line. 

You can erase any part of the dotted line 
as you are drawing it by holding down the 

key and going back over the line. You 

can erase only before you release the 
mouse button. While you are erasing, the 
previously solid arrowhead becomes 
hollow. 

When you're finished erasing, redraw the 
line the way you want it. 
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4. Release the mouse button when the path is the way you want it. 

Anchor points automatically appear at 
both ends of the path and at various 
locations along it. The path becomes solid, 
and it is selected. The arrowhead changes 
back to an x, indicating that you can start 
drawing another line. 

If you change your mind, you can immediately choose Undo Freehand 
from the Edit menu to delete the path you just drew. 

5. You have two options. You can start a new path, or you can continue the 
existing path. 

Option 1 To start a new path, repeat steps 1 through 4, positioning the x 
anywhere on the screen except on an endpoint of an existing path. 

Option 2 To continue the existing path, position the x on an endpoint of 
the path, and start dragging the mouse. Release the mouse button when 
the line is the way you want it. 

To continue the path with a corner, hold down the Option key and drag to 
draw the corner you want. 

Setting the freehand tolerance 

When you use the freehand tool, it responds to slight variations in the 
speed and direction of your hand movements by creating bumps in the 
path you are drawing. You can control the sensitivity of the freehand tool 
to your hand movements, and therefore control the smoothness of your 
lines, by setting the freehand tolerance before you draw, or at any time. 

To set the freehand tolerance: 

1. Choose Preferences from the Edit menu, or press 
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The Preferences dialog box appears. 

Preferences  

® Snap to point 
® Preview and print patterns 
❑ Transform pattern tiles 

OK 

Cancel 

Constrain angle: 0 ° —Ruler units 

Corner radius: pt 
Q Centimeters 
Q Inches 0 

Cursor keg distance: 1 pt Q Picas/Points 

Freehand tolerance: 2 piHels 

Rutotrace gap distance: 0 pixels 

Change Progressive Colors... 

2. Enter a value in the Freehand Tolerance field. 

This field is calculated in number of pixels. The preset value is 2. You 

must enter a positive number between 0 and 10. 

The larger the number of pixels you specify, the more bumps the program 

will ignore, and the smoother your lines will be. 

3. Click OK. 

Drawing with the auto trace tool 

You use the auto trace tool to automatically trace paths around template 

shapes. You can use the auto trace tool to draw entire paths, or you can 

use it to draw part of a path either started by or finished by the freehand 
tool or the pen tool. Paths drawn with the auto trace tool are painted with 

the paint attributes set when you started using the tool. 

Both the freehand tolerance and auto trace gap distance settings in the 
Preferences dialog box affect the auto trace tool. Before you use the tool, 
choose Preferences from the Edit menu and enter the values that you want 

to apply. See the next section, "Setting the Auto Trace Gap Distance," and 

see "Setting the Freehand Tolerance," earlier in this chapter, for more 
information. 

The following procedures apply to lines as well as shapes. When you use 

the auto trace tool to trace a line, it travels all the way around the line and 
comes back to where you clicked, forming a closed path, not an open one. 
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To trace a template shape: 

1. Open a new artwork document with a template. 

. v+ 

2. Click on the auto trace tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

3. Position the x on the template where you want a path to be automatically 
traced. 

You must position the x within 6 pixels of the edge of a bitmapped shape. 
The auto trace tool is guided by the boundary between the black bitmap 
and the white background. 

4. Click. 

A path is traced around the shape on which you clicked. The path is 
drawn so that it starts where you click and follows around the shape, 
keeping the black bitmap always on its right. 
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ID  f 

In some cases, the path will be drawn clockwise, and in other cases, 
counterclockwise, depending on where you click and how the black bitmap 
and the white background relate. 

-w 

If you change your mind, you can immediately choose Undo Auto Trace 
from the Edit menu to delete the path just drawn. 

To trace part of a template shape: 

1. Open a new artwork document with a template. 

2. Click on the auto trace tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

U 

U 

U 

U 

U 

U 
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3. Drag (the x changes to an arrowhead) from the place on the bitmap shape 
where you want the path to start to the place where you want the path 
to end. 

The drag should start and end within 2 pixels of the edge of the shape. 

The auto trace tool automatically traces a path between the points you 
dragged. The path is drawn so that it starts from the beginning point of 
the drag and follows around the shape keeping the black bitmap always 
on its right. In some cases, the path will be drawn clockwise, and in other 
cases, counterclockwise, depending on where you start the drag and how 
the black bitmap and the white background relate. 

If you change your mind, you can immediately choose Undo Auto Trace 
from the Edit menu to delete the path just drawn. 

To connect a new auto trace path to an existing path traced along a 
bitmap, start the drag on the anchor point of the existing path where you 
want the paths to connect. The anchor point must be within 2 pixels of the 
edge of the shape you want to trace. To connect them with a corner, use the 
following procedure. 
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To draw a corner with the auto trace tool: 

1. Click on the auto trace tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

2. Position the x on the anchor point of the existing path where you want the 
corner to be. 

3. Hold down the Option key and drag to the place on the bitmap where you 
want the path to end. 

If you change your mind, you can immediately choose Undo Auto Trace 
from the Edit menu to delete the path just drawn. 

Setting the auto trace gap distance 

The lines and shapes in bitmapped template images often contain gaps 
that are visible when you enlarge your view of the document. You can 
control the accuracy with which the auto trace tool traces lines or shapes 
with gaps. You do so by setting the auto trace gap distance in the 
Preferences dialog box. 

The gap distance setting tells the auto trace tool to ignore gaps that are 
equal to or less than the number of pixels you specify. For example, 
setting the distance to 1 tells the auto trace tool to ignore gaps of 1 pixel or 
less. 

To set the auto trace gap distance: 

1. Choose Preferences from the Edit menu, or press 

The Preferences dialog box appears. 

2. Enter a value in the Auto Trace Gap Distance field. 

This field is calculated in number of pixels. The preset value is 0. You 
must enter either 0, 1, or 2. 

3. Click OK. 

I 

I 

U 
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Drawing with the pen tool 

You draw curved paths with the pen tool by clicking to set down anchor 
points and then dragging to establish their corresponding direction points 
and direction lines. When you draw curves, you must be aware of five 
simple rules. See "Understanding a Few Rules," later in this chapter. 

To draw a path of straight lines: 

1. Click on the pen tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

2. Move the x to where you want the straight line path to begin, and click. 

-  The x changes briefly to an arrowhead and 
then to a cross. A solid square appears. It 
is an anchor point, and it is selected. 

+ 

IMPORTANT: Do not move the mouse while you click. If you do, you will 
start a curve instead of a straight line. For an anchor point to be associated 
with a straight line, the pointer must stay within 2 pixels of where you 
click. 

3. Click again where you want the first segment of the straight line path 
to end. 

If you change your mind, you can immediately choose Undo Pen from the 
Edit menu to delete the path you just drew. 

You can also constrain the straight lines you draw so that they appear at 
or in 45-degree multiples relative to the angle of constraint specified in the 
Preferences dialog box. To constrain a line, hold down the Shift key while 
you click the anchor points. No constraint is applied when you click the 
first anchor point on a path or when you close a path. See "Rotating the X 
and Y Axes" in Chapter 12, "Measuring and Constraining." 
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4. Continue clicking to create straight lines. 

An additional anchor point appears at the 
end of each new line segment. The last 
anchor point added is always a solid 
square, indicating that it is selected. 
Previous anchor points become hollow 
squares. 

5. End the straight line path. 

You can end the path in one of two ways. You can leave the path open, or 

you can close the path. 

Option 1 To end an open path, click on the pen tool in the toolbox. 

The cross changes back to an x, indicating that you can start a new path. 

Option 2 To close the path, click on top of the first anchor point. 

The program connects the last anchor point you clicked with the first 
anchor point, and the cross changes back to an x, indicating that you can 
start a new path. 

Understanding a few rules 

If you keep in mind the following five rules, you can quickly and easily 
draw any kind of curve. 

■ The One-Third rule 

One-Third rule 

When you are drawing a curved line, 
make the distance between the direction 
point you are dragging and its 
corresponding anchor point 
approximately one-third the length of the 
segment you want to create. 

If you have difficulty figuring out what one-third of the curve is, imagine 
the curve as a straight line. 
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■ The Bump rule 

When you are drawing a series of continuous curves, draw one "bump" at 
a time, placing anchor points at the beginning and end of each bump, not 
at the top. 

This is the best way to draw a path that consists of multiple curves. Using 
more anchor points would be less efficient and probably more confusing, 
and would actually give you less control. 

less efficient more efficient 

■ The Stride rule 

Take big strides. When drawing a segment, use as few anchor points as 
possible, placing them as far apart as possible. 

less effcient more efficient 

Working this way is very efficient. If anchor points turn out to be too far 
apart, you can add more points later by using the scissors tool. See 
"Adding Anchor Points" in Chapter 7, "Adjusting Paths," for more 
information. 

■ The Tangent rule 

Tangent rule 

When you drag, imagine that you are 
butting a ruler up against the curve and 
that the ruler is tangent to the curve at its 
anchor point. The direction line that you 
create when you drag to establish a 
direction point represents that ruler. 



48 User Guide 

■ The Direction rule 

Always drag the direction point in the direction the curve is traveling at 
the anchor point. If you drag the direction point in the opposite direction, 
the curve will be drawn in the opposite direction. 

To draw a curved path: 

1. Click on the pen tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

2. Position the x where you want the curve to begin. 

3. Press and hold down the mouse button. 

The first anchor point appears, and the x 
changes to an arrowhead. 

4. Drag in the direction you want the curve to be drawn. 

As you drag, the arrowhead leads one of 
two direction points. The two direction 
points move in opposition to each other 
around the stationary anchor point. Their 
position when you release the mouse 
button sets the starting direction of the 
curve. Both direction points are the same 
length. You can adjust one or both later. 

U 

U 

U 
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5. Release the mouse button when the direction points are the way you want 
them. 

The arrowhead changes to a cross. 

6. Position the cross where you want the curve segment to end, and press and 
hold the mouse button. 

A second anchor point is set, and the 
arrowhead appears. 

You can constrain the position of anchor points by holding down the Shift 
key while you place them. The anchor point is placed at a multiple of 
45 degrees from the previous anchor point, relative to the angle of 
constraint set in the Preferences dialog box. See "Rotating the X and Y 
Axes" in Chapter 12, "Measuring and Constraining." When you place the 
first anchor point in a path or close a path, no constraining occurs. 

7. Drag to position the direction points that will determine the height and 
slope of the next curve segment. 

If you hold down the Shift key while dragging a direction point, the 
direction line will be constrained to a multiple of 45 degrees relative to the 
angle of constraint set in the Preferences dialog box. See "Rotating the X 
and Y Axes" in Chapter 12, "Measuring and Constraining." 
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8. Release the mouse button. 

+ 

If you change your mind, you can 
immediately choose Undo Pen from the 
Edit menu to delete the anchor point you 
have just set. 

9. Repeat steps 6 through 8 as many times as you want. 

10. End the curved path. 

You can end the path in one of two ways. You can leave the path open, or 
you can close the path. 

Option 1 To end an open path, click on the pen tool. 

The cross changes back to an x, indicating that you can start a new path. 

Option 2 To close the path, click on top of the first anchor point and 
drag. 

The program connects the last anchor point you clicked to the first anchor 
point. 

The cross changes back to an x, indicating that you can start a new path. 

Drawing with two tools 

At times you may want to draw parts of an object with the freehand tool 
and other parts with the pen tool. You can easily switch back and forth 
between the two tools while drawing, connecting paths drawn with one tool 
to paths drawn with the other. 

SHORTCUT: If you have a Macintosh SE or a Macintosh II, you can toggle by 
using the Control key. This shortcut works no matter which tool is currently 
selected. For example, if you just drew a path with the pen tool and it is still 
highlighted in the toolbox, you can hold down the Control key and draw with the 
freehand tool in effect. Releasing the key automatically restores the pen tool. 
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To draw a path with two tools: 

1. Click on either the freehand tool or the pen tool. 

2. Draw a path. 

3. Select the other tool. 

4. Position the x on an endpoint of the existing path. 

Continue drawing the path with the other tool. 

Adding segments to existing open paths 

You can add straight lines, continuous curves, or corner points to open 
paths, as described in the following procedures. For information about 
adding line segments to closed paths, see "Splitting Paths with the Scissors 
Tool" in Chapter 7, "Adjusting Paths." 

To add a straight line to an open path: 

1. Click on the pen tool in the toolbox. 

The pointer changes to an x when you 
move it to the active window. If the last 
segment of the path is a straight line, click 
on the path's endpoint, 

O 0 

0 

and then click where you want the new 
straight line to end. 
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2. If the last segment of the path is a curve, hold down the Option key while 
you click on the path's endpoint, 

+ 

and then click where you want the new 
straight line to end. 

To add a continuous curve to an open curved path: 

1. Click on either the freehand tool or the pen tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

If you are using the freehand tool, position 
the x on the path's endpoint, and drag to 
draw the curve you want. 

When the path is complete, release the 
mouse button. The path is selected with 
the last endpoint highlighted. Do not go 
on to step 2. 

If you are using the pen tool, position the x on the path's endpoint and 
drag to establish the direction points for the starting side of the new curve. 
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The x changes to a cross. Go on to step 2. 

2. Position the cross where you want the new curved segment to end, and 
drag to establish the direction points for the ending side of the new curve. 

( )H 

To add a corner to an open path: 

When the path is complete, release the 
mouse button. The path is selected with 
the last endpoint highlighted. 

1. Click on either the freehand tool or the pen tool in the toolbox. 

The pointer changes to an x when you move it to the active window. 

2. If you are using the freehand tool, position the x on the path's endpoint. 
Hold down the Option key and drag to draw the corner you want. Do not 
go on to step 3. 
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When the path is complete, release the 
mouse button. The path is selected with 
the last endpoint highlighted. 

If you are using the pen tool, position the x on the path's endpoint, hold 
down the Option key, and drag to establish a direction point for the corner. 

The x changes to a cross. Go on to step 3. 

3. Position the cross where you want the new curved segment to end, and 
drag to establish the direction points and direction lines for the ending side 
of the new curve. 

When the path is complete, release the 
mouse button. The path is selected with 
the last endpoint highlighted. 
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This chapter tells you how to use the rectangle tool and the oval tool to 
draw rectangles, squares, ovals, and circles. The shapes that you create can 
be transformed using any of the transformation tools described in Chapter 
11, "Transforming Objects." They can also be filled and/or stroked with 
black, white, shades of gray, patterns, process colors or custom colors, or 
they can be used as masking objects. See Chapter 13, "Painting," for more 
information. 

Drawing rectangles and squares 

You can easily draw rectangles and squares by using one of three 
procedures: 

■ Dragging from any corner to an opposite corner 

■ Dragging from the center to any corner 

■ Specifying a height, width, and corner style in a dialog box 

All three methods of drawing rectangles or squares are described in two 
procedures later in this chapter. 

The rectangles and squares you draw are actually grouped objects 
consisting of two paths. The first path consists of four straight line 
segments connected at the corner points. The second path is a single point 
at the center of the rectangle. The center point can be used as an alignment 
aid. If you do not need this point, you can delete it. For more information 
on groups, see "Grouping and Ungrouping Objects" in Chapter S, 
"Selecting Objects." 

— path 

alignment point 

grouped rectangle 

You can control whether the rectangles you draw have rounded or squared 
corners. If you want to use rounded corners, you must enter corner radius 
values in the Preferences dialog box before you draw the rectangle. See the 
next section, "Specifying a Corner Style," for more information. 
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NOTE: The current orientation of the x and y axes affects the creation of 
rectangles and squares. The sides of the rectangles or squares you create 
are aligned with the x and y axes. For example, if the x and y axes are 
currently rotated by 20 degrees, any square or rectangle you create is 
drawn at a 45-degree multiple relative to the 20-degree angle. See "Rotating 
the X and Y Axes" in Chapter 12, "Measuring and Constraining." 

To create a rectangle or square by dragging: 

1. Click on the rectangle tool in the toolbox. 

The pointer changes to a cross when you move it to the active window. 

2. You have two options. 

Option 1 Position the cross at one corner of the rectangle or square you 
want to create, and drag diagonally to the opposite corner. 

Option 2 Position the cross at the center of the rectangle or square you 
want to create, hold down the Option key, and drag diagonally to any 
corner. U 

The cross changes to an arrowhead. A 
rectangle or square appears. 

To constrain the shape to an exact square, hold down the Shift key as you 
drag. 
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3. Release the mouse button when the rectangle or square is the size and 
shape you want. 

+ 

The four corners and the center of the 
rectangle or square have anchor points, 
indicating that it is selected. The rectangle 
or square is also grouped. The arrowhead 
changes back to a cross, indicating that 
you can make another rectangle or square. 

If you change your mind, you can immediately choose Undo Rectangle 
from the Edit menu to delete the rectangle you just drew. 

To draw a rectangle or square by specifying dimensions: 

1. Click on the rectangle tool in the toolbox. 

The pointer changes to a cross when you move it to the active window. 

2. Click at the center of the rectangle or square you want to create. 

The Rectangle dialog box appears. 

❑  Rectangle  

Width: 

Height: 

Corner radius: 

0 

0 

0 

pt 

pt 

pt 

Cancel 

The width and height you specify are measured in inches, centimeters, or 
points and picas, depending on which unit of measure you set in the 
Preferences dialog box. The current unit of measure is indicated to the right 
of each field. The Width and Height fields display the dimensions of the 
last rectangle or square you drew. 

3. Enter the width you want the rectangle or square to be in the Width field. 

You must enter a positive number. 

4. Enter the height you want the rectangle or square to be in the Height field. 

You must enter a positive number. 
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5. Enter the corner radius value you want the rectangle or square to have, if 
any. 

The Preferences dialog box is updated with the value you enter here. 

Rectangle  

Width: 

Height: 

Corner radius: 

100 

50 

10 

pt 

pt 

pt 

I  Cancel 

6. Click OK. 

A rectangle or square of the width and height you designated appears, 
centered on the point where you clicked in step 2. It has the currently 
specified corner style. 

1 

L 1 
The four corners and the center of the 
rectangle or square have anchor points, 
indicating that it is selected. The rectangle 
or square is also grouped. The arrowhead 
changes back to a cross, indicating that 
you can create another rectangle or square. 

If you change your mind, you can immediately choose Undo Rectangle 
from the Edit menu to delete the rectangle you just drew. 

Specifying a corner style 

The corner style of the rectangle or square you draw is determined by the 
corner radius value you specify either in the dialog box described in the 
second procedure in this chapter or in the Preferences dialog box. If you 
specify a corner radius value in one dialog box, the other dialog box is 
updated accordingly. 

When the corner radius value is 0, which is the preset value, the corners 
are squared. You can specify a corner radius value that will round the four 
corners of a rectangle or square by the amount you specify. The value you 
enter should represent the radius of a hypothetical circle drawn in the 
corner of the rectangle or square. The value is calculated in the current 
unit of measure set in the Preferences dialog box. 

I 

I 

I 

I 
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The size of the corner radius can be no more than one-half the size of 
either the height or width (whichever dimension is smaller) of the 
rectangle being drawn. 

For example, if a rectangle is 50 points by 75 points, the corner radius 
value must be 25 points or less. 

If the radius you specified is too large for the rectangle, the radius for the 
largest oval that can possibly fit in the corner of the rectangle will be used. 

Here are some examples of how a rectangle 50 points by 75 points looks 
with different corner radius values. 

Opts 5pts 
 J 

10pts 

oo 

15pts 20pts 25pts 

Use the second of the earlier two procedures if you want to specify a corner 
radius value, or choose Preferences from the Edit menu, enter a value in 
the Corner Radius field, and then use either one of the earlier procedures. 

NOTE: You must specify the corner radius value you want before you 
draw the rectangle. If you select the rectangle and then change the radius 
value, the new value will not apply to the selected rectangle, only to newly 
created ones. 
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Drawing ovals and circles 

Q 

grouped oval 

You can easily draw ovals and circles with the oval tool. 

The oval tool works very much like the rectangle tool. The ovals and circles 
you create are actually grouped objects consisting of two paths. The first 
path has four curved segments joined by four anchor points, one every 90 
degrees. The second path is a single point at the center of the oval or circle. 
The center point can be used as an alignment aid. If you do not need this 
point, you can delete it. For more information on groups, see "Grouping 
and Ungrouping Objects" in Chapter 5, "Selecting Objects." 

- path 

alignment point 

You can draw ovals or circles by using one of three procedures: 

■ Dragging from any edge to an opposite edge 

■ Dragging from the center to any edge 

■ Specifying height and width in a dialog box 

All three methods of drawing ovals and circles are described in the 
following two procedures. 

NOTE: The current orientation of the x and y axes affects the creation of 
ovals and circles. The horizontal and vertical axes of any oval or circle you 
create are aligned with the current x and y axes. For example, if the x and y 
axes are currently rotated by 10 degrees, any oval or circle you create is 
drawn at a 45-degree multiple relative to the 10 degree angle. See "Rotating 
the X and Y Axes" in Chapter 12, "Measuring and Constraining." 

To draw an oval or circle by dragging: 

1. Click on the oval tool in the toolbox. 

The pointer changes to a cross when you move it to the active window. 
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2. You have two options. 

Option 1 Position the cross at one edge of the oval or circle that you want 
to draw, and drag diagonally until the oval or circle is the size and shape 
you want. 

Option 2 Position the cross at the center of the circle or oval that you 
want to create, hold down the Option key, and drag diagonally. 

The cross changes to an arrowhead. As 
you drag, an oval or circle appears. 

css 
 x____._ . , 

To constrain the shape to an exact circle, also hold down the Shift key after 
you start dragging. 

3. Release the mouse button when the oval or circle is the size and shape you 
want. 

The four quarters and the center of the 
oval or circle have solid anchor points, 
indicating that it is selected. The circle or 
oval is also grouped. The arrowhead 
changes back to a cross, indicating that 
you can make another oval or circle. 

If you change your mind, you can immediately choose Undo Oval from 
the Edit menu to delete the oval you just drew. 

To draw an oval or circle by specifying options: 

1. Click on the oval tool in the toolbox. 
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2. Click at the center of the oval you want to draw. 

The Oval dialog box appears. 

   Dual  

Width: 0 pt I OK 

Height: pt U ( C:ant:el 

The width and height are measured in inches, centimeters, or points and 
picas, depending on the unit of measure set in the Preferences dialog box. 
The current unit of measure is indicated to the right of each field. The 
Width and Height fields display the dimensions of the last oval or circle 
you drew. 

3. Enter the width you want the oval or circle to be in the Width field. 

You must enter a positive number. 

4. Enter the height you want the oval or circle to be in the Height field. 

  Dual  

Width: 75 pt K0 

Height: pt 50 Cancel 

You must enter a positive number. To create a circle, enter a value in the 
width field and then click on the word "Height." This copies the width 
value to the Height field. 

5. Click OK. 

An oval of the height and width you specified appears, centered on the 
point where you clicked in step 2. 

The four quarters and the center of the 
circle have solid anchor points, indicating 
that it is selected. The circle or oval is also 
grouped. The arrowhead changes back to a 
cross, indicating that you can create 
another circle or oval. 

If you change your mind, you can immediately choose Undo Oval from 
the Edit menu to delete the oval you just drew. 

U 

U 



Chapter S: Selecting Objects 

This chapter explains how to select and deselect objects. 

Before you can perform any operation on an object, you need to 
distinguish it from the objects around it. You do that by selecting the 
object. You can select artwork objects only when you are viewing either the 
artwork or the template and the artwork. You cannot select the templates. 

An object can be a single anchor point, a segment, a path, a block of type, 
a group of objects, or a placed image. When you select a path, its anchor 
points, endpoints, and direction points become visible, as is described later 
in each selection procedure. When you select type, its alignment point and 
baselines become visible. 

Objects remain selected until you either deselect them or select another 
object. You can deselect an object that you selected by mistake or an object 
you no longer want to work with. 

Selecting or deselecting an object does not modify it in any way. 

You can also group, lock, or hide selected objects. This chapter also 
explains how and why you perform these operations. 

Using the selection tool 

You select objects with the selection tool, which is available for use when 
you click on it in the toolbox. You can also hold down the :•: key to obtain 

the selection tool temporarily while performing another task, such as 
drawing a path. 

There are two selection techniques. 

■ Clicking 

■ Dragging the selection marquee 

Both are described in the following sections. 

Use these techniques to select single anchor points, segments, paths, and 
type, as well as to select more than one object at a time. 

Clicking 

The simplest selection technique is to click within 2 pixels of the desired 
object with the selection tool. 

If you click over several overlapping objects, the frontmost object that is 
within 2 pixels of the pointer is selected. The frontmost object is the object 
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in front of all other objects in your artwork and last in the painting order. 
See Chapter 13, "Painting," for more information on painting order. 

You can more easily and precisely select an object if you either lock or hide 
some of the objects that overlap it so that they cannot be selected. See 
"Locking and Unlocking Objects" and "Hiding and Showing Objects," later 
in this chapter. 

If you click more than 2 pixels away from any object, all objects in your 
artwork are deselected. 

Dragging the marquee 

You can also select objects by dragging the selection pointer over them. 

To drag, hold down the mouse button and move the mouse diagonally 
across your desk. As you drag, a dotted rectangular box is displayed. This is 
the selection marquee (hereafter called the marquee). 

One corner of the marquee is the starting 
position of the drag, and the diagonally 
opposite corner is the current pointer 
position. 

R 

k 

You can drag from any corner to the 
opposite corner, depending on your 
specific needs. 

If you drag the marquee and it covers only part of an object, the part of 
the object that it covers is selected. 

If you drag the marquee over two or more overlapping objects, all objects 
within the marquee are selected, regardless of painting order, even if they 
overlap. 

If you drag the marquee and it does not cover any objects, all currently 
selected objects in your artwork are deselected. 
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Selecting anchor points 

You can select an anchor point either by clicking on it 

or by dragging the marquee around it. 

Selected anchor points are displayed as solid squares. If the anchor point is 
connected to a curve, the direction points associated with the selected 
anchor point appear as solid circles at the end of the direction lines. 

Selecting an anchor point also selects any segments that are connected to 
it. Thus, selecting an anchor point may also select zero, one, or two 
segments. 

If a selected anchor point is connected to a straight line, the direction 
points are not displayed, since they occupy the same position as the 
anchor points. 

When you select at least one anchor point on a path, all anchor points on 
the path are displayed. Selected anchor points appear as solid squares. 
Endpoints (if not selected) and all other anchor points appear as hollow 
squares. 

Painting, grouping, locking, and hiding work on entire paths. If you select 
even one anchor point on a path and perform any of these operations, the 
whole path, and not just the anchor point, is affected. 
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When anchor points overlap at the same location, dragging the marquee 
selects all of them, and clicking selects the frontmost anchor point only. 
You can select and lock the frontmost anchor point and, sequentially, any 
anchor points in back of it, to arrive at the anchor point you want. 

Selecting segments 

You can select a segment either by clicking anywhere on it 

or by dragging the marquee around all 

or part of it. 

When you select a segment, all of the anchor points on the path are 
displayed. If an anchor point is also selected, it appears as a solid square. 
Endpoints (if not selected) and all other anchor points appear as hollow 
squares. 
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Selecting paths 

If you select a segment that's a curve, its direction points are displayed as 
solid circles with direction lines drawn from each direction point to the 
associated anchor point. 

If you select a segment that's a straight line, the direction points are not 
displayed, since they are coincident with (occupy the same position as) the 
anchor points. 

Painting, grouping, locking, and hiding work on entire paths. If you select 
even one segment on a path and perform any of these operations, the 
whole path, and not just the segment, is affected. 

You can select an entire path (all of its anchor points and segments) in 
three ways. You can drag the marquee around all of it. 

All endpoints and anchor points within the marquee appear as solid 
squares. Direction points are not shown when an entire path is selected. 

Or you can hold down the Option key and either click on the path 
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or drag the marquee around part of it. 

Q

All endpoints and anchor points of the paths selected with the marquee or 
selected by clicking appear as solid squares. Direction points are not 
shown when an entire path is selected. 

Selecting type 

You can select a block of type either by clicking on its alignment point or 
anywhere else on a baseline, 

,,Select a block of type 
either by clicking or by 
using the marqueg 

or by dragging the marquee around all 

Select a block of type 
either by clicking or by 
using the marquee. 
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or part of any baseline. 

$elect a black of type 
either by clicking or by 
using the marquee. 

R 

Select a block of type 
either by clicking or by 
IICing the marquee. 

The text alignment point for the block becomes a solid square, indicating 
that the type is selected. The baselines of all selected type are also displayed. 

You cannot select part of a block of type. If you select any part of the block, 
the whole block becomes selected. 

Selecting placed images 

When you place an EPS image, it appears in your artwork as a rectangle 
with diagonal lines crossing through it. You can select it and then move, 
scale, rotate, reflect, or shear it. To select a placed EPS image, click on any 
of the four corner anchor points or on any of the lines. You can also 
preview the EPS image, but the previewed image has no anchor points and 
cannot be selected. 

Selecting several objects 

You may want to select several objects at a time if, for example, you want 
to group them. You can do this by dragging the marquee to cover all of 
the objects. This may be awkward, however, if some of the objects are only 
partially visible in the active window. Another way to select several objects 
at the same time is to extend the selection by using the Shift key while you 
either click or drag the marquee, as described in the following procedure. 
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To select several objects with the Shift key: 

1. Select the first object by either clicking or dragging the marquee. 

2. Hold down the Shift key, and select the second object. 

Both the first and second objects are selected. 

3. Hold down the Shift key, and select the remaining objects one at a time. 

4. Release the Shift key. 

NOTE: You can select several entire paths one at a time by holding down 
both the Shift key and the Option key as you select. 

Selecting all objects 

There may be times when you want to select every object in the artwork. 
The Select All command lets you do that. 

To select all objects in the artwork: 

1. Choose Select All from the Edit menu, or press :•:-A. 

All anchor points become solid squares, indicating that all objects in the 
artwork are selected. 

Deselecting objects 

You deselect objects when you no longer want to work with them. 

You can deselect just one object, several objects, or all objects in your 
artwork. Deselecting objects does not affect painting order. 

1 NOTE: Objects cannot be deselected unless they are already selected. 

The Shift key acts as a toggle for selecting and deselecting objects. 

To deselect one object: 

You have three options. 

Option 1 Click at least 2 pixels away from the object. 

Option 2 Select another object by clicking or dragging the marquee. 

Option 3 Hold down the Shift key, and click on the object or drag the 
marquee around it. 

Holding down the Option key as well as the Shift key will deselect an entire 
path at one time. 
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To deselect all objects: 

1. Click the selection pointer or drag the marquee at least 2 pixels away from any 
object in your artwork. 

All objects are deselected. 

To deselect objects one at a time: 

1. Hold down the Shift key, and deselect the first object by clicking on it or 
dragging the marquee around it. 

Holding down the Option key as well as the Shift key will deselect an entire 
path at one time. 

The object you are deselecting must already be selected, or else it will 
become a selected object. 

2. Continue holding down the Shift key and deselecting objects until there are 
no more objects you want to deselect. 

Grouping and ungrouping objects 

You can combine several objects into a group that is then treated as one 
object. Groups can be nested; that is, they can be grouped with other objects 
or groups to form larger groups. Grouped objects remain grouped until 
you ungroup them. 

Only entire paths can be grouped. Even if you select only part of a path 
(anchor points or segments), the entire path will become part of the group. 
Blocks of type and placed EPS images can also be grouped. 

The advantage of grouping is that it allows you to manipulate several 
objects as a unit. For example, you can move, transform, or delete several 
objects as a single unit, rather than working with each object individually. 
Once objects have been grouped, they cannot be selected individually. 
Selecting one object from a group selects all objects in the group. 

You can also make a group that contains only a single object, such as one 
path. Grouping a single path is a handy way to avoid inadvertent changes 
to it. 

When you mask, you must group the masking object and the objects it 
masks in order to complete the masking procedure. See "Masking Objects" 
in Chapter 13, "Painting," for more information. 

Grouping is saved when you save your artwork. Therefore, when you open 
it again, all the objects you grouped in your previous work session will 
still be grouped. 
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NOTE: If you have difficulty selecting an object that you want to edit, or if 
editing an object produces unexpected results, grouping may be involved. 
Check to see whether the object is part of a group, and ungroup it if 
necessary. If groups have been nested, that is, if there are groups within 
groups, you may need to choose the Ungroup command several times 
before you solve the problem. 

To group objects: 

1. Select the objects to be grouped. 

2. Choose Group from the Arrange menu, or press ::-G. 

The objects are now grouped and cannot be selected individually. 

If you change your mind, you can immediately choose Undo Group from 
the Edit menu to undo the grouping operation. 

Grouping does not change the painting order of the individual objects in 
the group relative to one another, but it does change their painting order 
relative to other objects in the document, because the group is placed 
frontmost in the document. 

To ungroup grouped objects: 

1. Select the group to be ungrouped. 

2. Choose Ungroup from the Arrange menu, or press :•:-U. 

If you change your mind, you can immediately choose Undo Ungroup 
from the Edit menu to undo the ungrouping operation. 

Ungrouping does not deselect any objects. It also does not change the 
painting order of the objects that had been grouped. 

Locking and unlocking objects 

You can lock objects so that they can no longer be selected. This ability is 
useful when objects overlap one another. You can lock all the objects you 
do not want to select, and then select and work with one or more 
remaining objects. 

Only entire paths can be locked. Even if you select only part of a path 
(anchor points or segments), the entire path becomes locked. 

Locking is saved when you save your artwork. Therefore, when you open it 
again, all the objects you locked in your previous work session will still be 
locked. 
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NOTE: Neither Lock nor Unlock All can be undone with the Undo 

command. 

The following procedure locks one object or several objects at a time. 

To lock an object: 

1. Select the object you want to lock. 

To select more than one object, hold down the Shift key and continue 

selecting. 

2. Choose Lock from the Arrange menu, or press ::-1. 

The object is locked and deselected; it cannot be selected. 

If you hold down the Option key while you choose the Lock command 

from the menu, all unselected objects are locked. 

To unlock all locked objects: 

1. Choose Unlock All from the Arrange menu, or press 

All locked objects are unlocked and are selected. Any previously selected 

objects are deselected. 

NOTE: The Unlock command applies to all locked objects. You cannot 

unlock one object at a time, unless only one object was locked. 

Hiding and showing objects 

You can hide objects so that they temporarily cannot be seen. This ability 

is useful in a complex drawing when you want to concentrate on working 

with one object and hide those objects surrounding or overlapping it. 

Hiding objects is also useful when several objects are close together and 

you do not want to inadvertently select or affect one object while working 

on another. When an object is hidden, it cannot be selected or manipulated 

in any way. 

Only entire paths can be hidden. Even if you select only part of a path 

(anchor points or segments), the entire path will become hidden. 

Hiding an object does not change its painting order or alter it in any other 

way. Hidden objects are not visible when you preview or print your 

drawing. 

Hiding is not saved when you save your artwork. Therefore, when you 

open it again, all the objects hidden in your previous work session will be 

shown. 
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INOTE: Neither Hide nor Show All can be undone with the Undo 
command. 

The following procedure hides one object or several objects at a time. 

To hide an object: 

1. Select the object you want to hide. 

To select more than one object, hold down the Shift key and continue 
selecting. 

2. Choose Hide from the Arrange menu, or press X-3 

The object is hidden. 

If you hold down the Option key while you choose the Hide command 
from the menu, all unselected objects are hidden. 

The Show All command applies to all hidden objects. You cannot show 
one hidden object at a time, unless only one object was hidden. 

To show all hidden objects: 

1. Choose Show All from the Arrange menu, or press 

All hidden objects are shown and are selected. 
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This chapter tells you how to enter, edit, and paint type. It also describes 
type attributes and tells you how to set them. 

Working with type 
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Entering type 

You can enter type into any artwork by using the type tool. Type can be 
used as the basis for design elements that you scale, rotate, reflect, shear, or 
mask. 

When you enter type, you control such attributes as font, size, leading, 
spacing, and alignment. The type you enter can be printed in any 
PostScript language outline font on printers that use Adobe's PostScript 
interpreter. 

As you work with type, remember that a block of type is treated as an 
object. Consequently, all of the actions you perform on objects, including 

painting, moving, copying, deleting, transforming, and grouping, can also 

be performed on type. 

Blending is an exception. You cannot use either a block of type or 
individual type characters in a blend procedure. To blend with "type," use 

one of the characters available in the Adobe Collector's Edition I. Those 
characters are paths and not real type. You can also use one of the 

drawing tools create a path that looks like a type character and then use it 

in a blend. 

This chapter tells you how to enter blocks of type, edit existing type, and 

change type attributes. See the relevant chapters in this guide for 
information about the other operations that can be performed on type. 

A block of type can consist of one letter or symbol, one word, or one or 

more lines of type. The maximum number of characters in any block of 

type is 255. 

The angle at which type appears depends on the current orientation of the 

x and y axes. For example, if you have rotated the axes by 30 degrees, the 

baseline of either newly entered or currently selected type will appear at a 

30-degree angle. For more information, see "Rotating the X and Y Axes" in 

Chapter 12, "Measuring and Constraining." 
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To enter a block of type: 

1. Click on the type tool in the toolbox. 

The pointer changes to an I-beam. The small horizontal line near the 
bottom of the I-beam marks the position of the baseline of the first line of 
type to be entered. 

2. Position the I-beam where you want the type to start, and click. 

Clicking sets the alignment point for the type. Whether the type will 
appear to the left of, to the right of, or centered around the alignment 
point depends on the alignment style you specify in the Type dialog box. 

The Type dialog box appears. A blinking I-beam appears in the large text 
entry box at the bottom. You enter the type there. 

Type 

Helue tic a 
Heluetica-Bold 
Heluetica-BoldOblique 
Heluetica-Condensed i.J 

OK 

Cancel

Size: 12 pt Rlignment  

Leading: pt 12 ~a o Q 

Spacing: 0 pt 

3. Enter the type that you want to have appear in your artwork. 

Press the Return key for each new line of type you want. If you type a few 
lines without using the carriage return, the words wrap around in the text 
entry box, but appear on one long, straight line in your document and 
may extend out of the working area. If the type does not appear the way 
you want it to in your artwork, you must open the Type dialog box and 
insert carriage returns in the text where necessary. 
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Use the Backspace key for simple corrections. See also the next section, 
"Editing Type," if necessary. 

Type  

Heluetica-Bold 
Heluetica-Bold Oblique 
Heluetica-Condensed 

Size: 

Leading: 

Spacing: 

12 

12 

0 

pt alignment  

pt r ®=  
o 

pt 

OK 

Cancel 

0 

Enter the type that 
you want to appear in 
your artwork 

4. Click OK or press the Enter key on the numeric keypad. 

Pressing the Return key is not equivalent to clicking OK in this instance. 
The Type dialog box closes, and the type you entered appears in your 
artwork. 

Jnter the type that 
you want to appear in 
your artwork 

The type is selected. The baseline of each line of type is indicated, as well as 
the alignment point, denoted by a solid square. 

If you change your mind, you can immediately choose Undo Type from 
the Edit menu to delete the type you just entered. 

If you want to set different type attributes, see "Setting Type Attributes," 
later in this chapter. 
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Editing type 

You can make changes to a selected block of existing type by editing it in 
the Type dialog box. 

To display the Type dialog box at any time, you can either choose Type 
from the Style menu or press •:-T. 

To edit the text, use the standard Macintosh text-editing procedures. You 
can cut and paste text to and from the Clipboard while editing in the text 
entry box of the Type dialog box. 

NOTE: You can edit type only in the Type dialog box. You cannot edit type 
directly in your artwork. 

Painting type 

You can paint type blocks in the same way that you paint other objects in 
your artwork. However, each type block can have only one set of paint 
attributes. You must select type before you paint it. For more information 
about painting, see Chapter 13, "Painting." 

Understanding type attributes 

Here are the type attributes that you can set. Enter values in points or 
fractions of points. 

■ Font 

Displays the names of the available fonts in a list box. The currently 
selected font is highlighted. Click on the font you want to use. If necessary, 
use the scroll bar to locate the desired font. 

■ Size 

Indicates the current type size, expressed in points. To change the type size, 
type a new number in the Size field. The number must be positive. 

■ Leading 

Specifies the amount of vertical spacing between baselines in blocks of 
type, expressed in points. To change the leading, type a new number in the 
Leading field. You can specify negative leading by preceding the number 
with a minus sign. Negative leading spaces baselines so that the bottom of 
a line of type approaches or overlaps the top of the line of type 
underneath. 

■ Spacing 

Specifies the amount of space between all adjacent type characters, 
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expressed in points. To change the spacing, type a new number in the 
Spacing field. You can specify negative spacing by preceding the number 
with a minus sign. Negative spacing spaces type characters so that they 
approach or overlap one another. 

■ Alignment 

Controls how lines of type are positioned relative to one another. The 
alignment you specify also affects the position of the alignment point in 
the blocks of type you create. You can choose left-aligned (flush left, ragged 
right), centered, or right-aligned (flush right, ragged left) text. 

Setting type attributes 

The Adobe Illustrator 88 program lets you control the font, size, leading, 
spacing, and alignment of type. You can either set these attributes before 
you enter new type or reset them to change the appearance of existing 
selected type. You can set attributes for several blocks of type at once if they 
are all selected. However, each block of type can have only one font, point 
size, leading value, and so on. You cannot vary type attributes within one 
type block. 

The preset type attributes are 12-point Helvetica, 12-point leading, 0 
spacing, and left alignment. 

To set type attributes: 

1. Select the blocks of type whose attributes you want to set. 

Select the blocks of 
type whose attrihiites 
you want to change. 

When they are selected, the baseline for each line of selected type is 
displayed, as well as the alignment point for each block of type. 

2. Choose Type from the Style menu, or press -T. 

The Type dialog box appears, showing you the type attributes set for the 
currently selected type. 

If you selected one block of type, it appears in the text entry box, and its 
type attributes are indicated. 
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If you selected more than one type block, no type appears in the text entry 
box, and only the type attributes common to all selected type blocks are 
indicated. 

3. Set the type attributes. 

Scroll through the list of fonts, and click on the one you want to use. Enter 
the size you want the font to have in the Size field, the leading you want 
between baselines in the Leading field, and the spacing you want between 
characters in the Spacing field. Click on the button next to the alignment 
you want to set. 

❑ Type  

aneSerif-Bold 
StoneSerif-Bold Italic 
StoneSerif- Italic 
StoneSerif-Semibold 

4 

d3 

OK J 
( Cancel

Size: 9 pt Rlignment  

Leading: pt 12 ~® 0 0 

Spacing: 0 pt 

Select the blocks of 
type whose attributes 
you want to change. 

4. Click OK. 

$elect the blocks of 
type whose attributes 
you want to change. 

Any type attributes that you set affect not only the currently selected type 
blocks but also any type blocks you enter in the future. 
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You will often need to modify the paths and shapes that you have created 
with the freehand tool, the auto trace tool, the pen tool, the rectangle tool, 
the oval tool, or the blend tool. This chapter describes several ways of 
making adjustments. You can 

■ Move anchor points 

■ Add anchor points 

■ Average the positions of anchor points 

■ Join endpoints of open paths 

■ Split paths 

■ Adjust paths while drawing them 

■ Redraw segments 

■ Change the shape and size of curve segments 

■ Move direction points 

■ Adjust several points or segments simultaneously 

You can also constrain the adjustment of anchor points, direction points, 
and curve segments so that they are constrained at 45-degree multiples 
relative to the angle of constraint set in the Preferences dialog box. See 
"Rotating the X and Y Axes" in Chapter 12, "Measuring and 
Constraining." 

IMPORTANT: Objects created with the rectangle tool, the oval tool, and the 
blend tool are grouped. If you want to adjust a path in an object created 
with one of those tools, you must ungroup the object first. 
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Throughout the following procedures, the figures show parts of this 
sailboat being created and adjusted using all of the techniques just listed. 

Moving anchor points 

You can change the shape of any path by moving one or more of its 
anchor points. 

To move an anchor point: 

1. Click on the selection tool in the toolbox. 

2. Position the pointer on the anchor point you want to move. 

U 
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3. Drag the anchor point to a new location. 

As you drag, an image of the path is 
temporarily left in its original location for 
your reference. A second image, of the 
segments connected to the anchor point 
you are moving, changes continuously but 
remains fixed at its other anchor points. 

To constrain the movement of the anchor point so that it moves exactly 
horizontally, vertically, or diagonally, hold down the Shift key while you 
drag. 

You can also move the object using the cursor (arrow) keys or the Move 
dialog box. See Chapter 8, "Moving Objects," for more information. 

4. Release the mouse button when the anchor point is where you want it. 

The anchor point and the segments 
connected to it remain in their new 
position. The anchor point is still selected. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to undo the move you just performed. 

Adding anchor points 

You can add new anchor points in the middle of the segments of an 
existing path. Added anchor points can give you more control over the 
path shape. 

You add anchor points by using the scissors tool. Adding anchor points is 
different from splitting paths. Splitting a path breaks the path and adds 
endpoints. Adding an anchor point does not break either a closed or open 
path; it only adds a new anchor point in the middle of any segment, 
straight or curved. 
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To add an anchor point: 

joining endpoints 

1. Select the path on which you want to add an anchor point, if you want to see 
the current anchor points. 

2. Click on the scissors tool in the toolbox. 

The pointer changes to a cross when you move it to the active window. 

3. Position the cross on a path segment where you want to add an 
anchor point. 

NOTE: You cannot add an anchor point on top of an existing anchor 
point or endpoint. 

4. Hold down the Option key and click. 

A new anchor point appears, and it is 
selected. If the anchor point was added to a 
curve segment, direction points also 
appear. If you did not hold down the 
option key, the path will be split. 

If you change your mind, you can immediately choose Undo Scissors from 
the Edit menu to delete the anchor point. 

The Join command lets you either connect the endpoints of an open path 
to create a closed path or join the endpoints of two open paths. 
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Joining the endpoints of two open paths combines them into one longer 
open path. 

: ,U

Joining the endpoints of one path (if the endpoints are not coincident) 
closes it with a straight line segment. 

To join endpoints that are not coincident: 

1. Click on the selection tool in the toolbox. 

2. Select exactly two endpoints. 

If you select fewer than two or more than 
two, no endpoints will be joined. 

3. Choose Join from the Arrange menu, or press :•:-J. 

If the endpoints you are joining are not 
coincident, they will be joined by means of 
a straight line segment. 
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To join coincident endpoints: 

1. Click on the selection tool in the toolbox. 

2. Select exactly two endpoints. 

If you select fewer than two or more than 
two, no endpoints will be joined. 

3. Choose Join from the Arrange menu, or press 

The Join dialog box appears. 

Join   

Join points 
Corner point 

Q Smooth point 

I OK 

Concel

4. Click on the option that indicates the type of join you want. 

Your options are a corner point 
joined corner point 

joined smooth point 
or a smooth point. Corner Point is the 
preset option. 
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5. Click OK. 

The two endpoints are connected and 
remain selected. 

I NOTE: If the two selected endpoints occupy the same place, they are 
replaced with a single anchor point when joined. 

If you change your mind, you can immediately choose Undo Join from the 
Edit menu to undo the joining of the endpoints. 

Averaging anchor points 

The Average command lets you move two or more anchor points to a 
position that is the average of their current locations. 

Averaging anchor points differs from joining endpoints in the 
following ways: 

■ Averaging moves anchor points. Joining does not move any anchor points. 

■ You can average any number of anchor points. You can join only two 
anchor points, both of which must also be endpoints. 

■ Averaging does not create any new segments. Joining creates a straight line 
segment between endpoints (if they are not coincident). 

■ Averaging does not merge anchor points. Joining will sometimes merge two 
anchor points into one. 

■ You can average along either the x or y axis. Joining always occurs along 
both axes. 

■ You can average grouped objects, but you cannot join anchor points on 
grouped paths. 

■ You can average text alignment points as well as path anchor points, but 
you cannot join text alignment points. 

Averaging text alignment points might be useful if you wanted to align 
blocks of type along a common vertical or horizontal axis. 
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To average anchor points: 

1. Click on the selection tool in the toolbox. 

2. Select two or more anchor points. 

3. Choose Average from the Arrange menu, or press 

The Average dialog box appears. 

❑  Ruerage   

Ruerage along 

® Both ages 

O Horizontal axis only 
Q Vertical axis only 

I OK 

Cancel 

4. Click on the option that indicates how you want the averaging to occur. 

Your options are to average along both 
axes, 

along the horizontal (x) axis only, 
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or along the vertical (y) axis only, relative 
to the angle of constraint set in the 
Preferences dialog box. 

Th
The preset option is to average along both axes. 

5. Click OK. 

The selected anchor points move to their 
averaged position, and the paths 
containing the anchor points change 
shape accordingly. The averaged anchor 
points remain selected. 

If you change your mind, you can immediately choose Undo Average from 
the Edit menu to undo the averaging of the anchor points. 

Splitting paths with the scissors tool 

You may sometimes want to split paths that you have already created or 
that were created using the auto trace tool. Using the scissors tool, you can 
either split an open path into two paths or split a closed path so that it 
becomes an open path. 

The scissors tool can be used to produce a split anywhere on a path, except 
on an endpoint of an open path. You can split any path that is not part of 
a group. For information about ungrouping objects, see "Grouping and 
Ungrouping Objects" in Chapter 5, "Selecting Objects." 

Splitting an open path creates two open paths. 

+ ■ 
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Splitting a closed path creates one open path. 

After you split an open path into two paths, you will probably want to 
move the paths apart. After you split a closed path, you will probably 
want to move the endpoints apart. Directions for all three procedures 
follow. 

To split a path: 

1. Select the path you want to split, if you want to see its current anchor points. 

2. Click on the scissors tool in the toolbox. 

The pointer changes to a cross when you move it to the active window. 

3. Position the cross on the path where you want to split it. 

Do not position the pointer on an 
endpoint. 

4. Click. 

If you split the path in the middle of a 
segment, two new endpoints appear, one 
on top of the other. Both endpoints are 
selected. 

If you split the path at an anchor point, one new anchor point appears in 
the same place as the original anchor point. Both anchor points are 
selected. 

I 
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If you change your mind, you can immediately choose Undo Scissors from 
the Edit menu to undo the splitting of the path. 

To move the endpoints apart: 

1. Click on the selection tool in the toolbox. 

2. Hold down the Shift key, click on the overlapping endpoints, and release 
the Shift key. 

The frontmost endpoint is deselected, and 
the other endpoint remains selected. 

3. Drag the endpoints to their new positions. 

The endpoints remain in their new 
position and are still selected. 

You can also move the endpoints by using the cursor (arrow) keys or the 
Move dialog box. See Chapter 8, "Moving Objects," for more information. 

If you change your mind, you can immediately choose Undo Move from 

the Edit menu to undo the move you just performed. 

To move the paths apart: 

1. Click on the selection tool in the toolbox. 

2. Click at least 2 pixels away from any object to deselect all objects in your 

artwork. 
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3. Hold down the Option key, click anywhere on the path you want to move, 
and release the Option key. 

The entire path is selected. 

4. Drag the selected path to its new position. 

The path remains in its new position and 
is still selected. 

Li 

You can also move the path by using the cursor (arrow) keys or the Move 
dialog box. See Chapter 8, "Moving Objects," for more information. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to undo the move you just performed. 

Adjusting paths while drawing them 

When you draw a path with the pen tool, you can adjust a path's anchor 
points, endpoints, direction points, or segments as you are creating it. You 
adjust paths created with the freehand tool by erasing while you draw. See 
"Drawing with the Freehand Tool" in Chapter 3, "Drawing Paths," for 
more information. 

To adjust a path while drawing it: 

1. Click on the pen tool in the toolbox. 

2. Start drawing a path. 

The most recent anchor point you set 
appears as a solid square, indicating that 
it is selected. If the anchor point 
terminates a curve segment, the direction 
points appear as solid circles. All other 
anchor points appear as hollow squares. 
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3. Hold down the :•: key and select the anchor point, direction point, or curve 
segment you want to adjust. 

Holding the :: key down changes the cross 
back to a selection pointer. 

4. Continue to hold down the :•: key and move or change any selected part of 
the path by dragging. 

5. Release the mouse button and the :•: key when the path is the way you 
want it. 

If you selected more than one part of the 
path, the pointer changes to an x. 
Otherwise, the pointer is still a cross. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to undo the last adjustment you made. 

6. Resume drawing the path. 

If the pointer is a cross, set the next anchor point. If the pointer is an x, 
position it on the last endpoint you drew before you adjusted the path. If 
the last endpoint is part of a curve, drag to establish the direction points. 
If the last endpoint is part of a straight line, just click on the endpoint. 
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Redrawing segments 

If you need to correct a segment that is part of a longer path, you can 
redraw it without redrawing the entire path. 

To redraw a segment: 

1. Click on the selection tool in the toolbox. 

2. Select the segment that you want to redraw. 

R 
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3. Press the Backspace key. 

The segment is deleted. The remaining 
segments on the path become selected. 

4. Click on either the pen tool or the freehand tool in the toolbox. 

5. Redraw the segment you deleted. 

Make sure you connect the new segment to 
both of the anchor points to which the 
deleted segment was connected. 

If you change your mind, you can immediately choose Undo Pen or Undo 
Freehand from the Edit menu to delete the segment you just drew. 
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Changing curve segments 

You can modify the shape of a path by changing the shape and size of one 
or more of its curve segments. You change the curve segment either by 
moving the segment itself or by moving one or more of its direction 
points. Moving direction points affects only curve segments; you adjust 
straight line segments by moving the anchor points. 

To move a curve segment: 

1. Click on the selection tool in the toolbox. 

2. Select the curve segment you want to change. 

3. Position the pointer on the selected segment, anywhere between its two 
anchor points. 

4. Drag the curve segment. 

As you drag, an image of the path is 
temporarily left in its original location for 
your reference. A second image of the 
selected curve segment changes shape and 
size while remaining fixed at its anchor 
points. The curve's direction points also 
move to reflect changes in the shape and 
size of the segment. 

To constrain the movement of the curve segment so that it moves at 
45-degree multiples relative to the angle of constraint set in the Preferences 
dialog box, hold down the Shift key while you drag. 

You can also move the curve segment by using the cursor (arrow) keys or 
the Move dialog box. See Chapter 8, "Moving Objects," for more 
information. 
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5. Release the mouse button when the curve is the size and shape you want. 

The curve retains the new size and shape 
and is selected. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to undo the move you just performed. 

To move a direction point: 

1. Click on the selection tool in the toolbox. 

2. Select the anchor point or the curve segment whose direction point you 
want to move. 

3. Position the pointer on the direction point you want to move. 

4. Drag the direction point to where you want it. 

An image of the selected curve segment is 
temporarily left in its original location for 
your reference. A second image indicates 
the change in the direction point you are 
dragging and the curves connected to it. 
Either one or two segments will change 
shape, depending on whether a corner 
point or smooth point was established. 
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To constrain the movement of the direction point so that it moves at 
45-degree multiples relative to the angle of constraint set in the Preferences 
dialog box, hold down the Shift key while you drag. 

You can also move the direction point by using the cursor (arrow) keys or 
the Move dialog box. See Chapter 8, "Moving Objects," for more 
information. 

5. Release the mouse button when the direction point and the curve are the 
way you want them. 

The direction point and curve segments 
remain in their new positions. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to undo the move you just performed. 

Adjusting several anchor points or segments 

You can select several anchor points or segments, on the same path or on 
different paths, and adjust them all simultaneously. 

To adjust several anchor points or segments: 

1. Select several anchor points and/or segments. 

You can use the Shift key, the Option key, 
or the marquee to select them all. See 
"Selecting Several Objects" in Chapter 5, 
"Selecting Objects," for more information. 
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2. Drag the selected anchor points and/or segments to their new position. 

All of the selected anchor points and/or 
segments move in unison. 

To constrain the movement so that the selected objects move at 45-degree 
multiples relative to the angle of constraint set in the Preferences dialog 
box, hold down the Shift key while you drag. 

You can also move the objects by using the cursor (arrow) keys or the 
Move dialog box. See Chapter 8, "Moving Objects," for more information. 

3. Release the mouse button when the anchor points and/or segments are 
where you want them. 

All of the selected anchor points and/or 
segments remain in their new position 
and are selected. 
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Chapter 8: Moving Objects 

This chapter covers all the methods you can use to move objects from one 
part of your artwork document to another. To move an object, you can 

■ Drag it, with or without constraining its movement 

■ Use the cursor (arrow) keys 

■ Use the Cut command, and then use the Paste, Paste In Front, or Paste In 

Back command 

■ Use either the Bring To Front or Send To Back command 

■ Use the Move dialog box 

n 

n 

Note that this chapter explains only how to move objects within a single 
document. To move or paste objects between Adobe Illustrator 88 program 
documents, see Chapter 9, "Copying Objects." To move or paste objects 
between Adobe Illustrator 88 documents and other applications, see 
Chapter 16, "Working with Other Applications." 

If an object that you want to move is painted with a pattern, you can 
choose to move the pattern tiles as well as the object itself. Before you move 
the object, choose Preferences from the Edit menu and click in the 
Transform Pattern Tiles checkbox. An x appears, indicating that the option 
is turned on. (The preset option is off.) 

Turning this option on means that if you move or transform an object 
painted with a pattern, the pattern will also be transformed. However, 
moving a patterned object by using the Cut and Paste commands does not 
move or transform the pattern in any way. 

Turning this option on or off in the Preferences dialog box updates the 
same option in all of the transformation dialog boxes as well. Turning this 
option on or off in any of the transformation dialog boxes updates this 
option in the Preferences dialog box. For more information, see the last 
section in this chapter, "Moving Objects a Specific Distance and Direction." 
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Moving objects to a new location 

You can move one or more objects from one place to another in your 
artwork either by dragging the object or by using the cursor (arrow) keys. 
Using the cursor keys is an effective way of moving objects by small, 
specific increments, as illustrated in the procedure that follows. 

The cursor keys allow you to move selected objects in the direction 
indicated by the arrow on the key. How far the selected object moves each 
time you press one of the cursor keys depends on the value specified in the 
Cursor Key Distance field of the Preferences dialog box. The preset value is 
1 point. If you are going to use the cursor keys and want to use a different 
distance value, you must first open the Preferences dialog box and enter the 
new value. See "Setting Cursor Key Distance" in Chapter 12, "Measuring 
and Constraining." 

Keeping the cursor key held down moves the selected object continuously. 

I NOTE: If you want to view the complete document in the window as 
you move objects, first choose Fit In Window from the View menu. 

To move an object by dragging: 

1. Select the object you want to move. 

2. Position the pointer on the selected object. 

In the case of type, position the pointer on 
any of the baselines. 

3. Drag the selected object to its new location. 

As you drag, an image of the object is 
temporarily left in its original location for 
your reference. d 
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4. Release the mouse button. 

The object remains in its new location, 
and it is selected. 

L J 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to delete the move you just performed. 

NOTE: If you are working at actual size and you move an object to a part 
of the artwork that is outside the window while dragging, the document 
scrolls to keep the object in view. 

To move an object with the cursor keys: 

1. Select the object you want to move. 

2. Position the pointer on the selected object. 

In the case of type, position the pointer on 
any of the baselines. 

3. Press the cursor key that indicates the direction in which you want the 
object to move. 

You can press the key as many times as 
you want. You can press different cursor 
keys one after another to change the 
direction in which the object moves. As 
you press, the object moves in the 
direction indicated by the arrow on the 
key, for the distance set in the Cursor Key 
Distance field of the Preferences dialog box. 
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4. Stop pressing the cursor keys when the object is where you want it. 

The object remains in its new location, 
and it is still selected. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to undo the move you just performed. 

Moving objects horizontally, vertically, or diagonally 

You can constrain the movement of one or more objects so that they move 
in a precise horizontal, vertical, or diagonal direction, relative to the 
current orientation of the x and y axes. See "Rotating the X and Y Axes" in 
Chapter 12, "Measuring and Constraining," for more information. 
Constrained diagonal movement is always calculated in multiples of 45 
degrees relative to the current axes. 

To move an object horizontally, vertically, or diagonally: 

1. Select the object you want to move. 

2. Position the pointer on the selected object and hold down the mouse button. 

3. Hold down the Shift key, and drag the object in the approximate 
horizontal, vertical, or diagonal direction you want. 

The object's movement is constrained so 
that it moves exactly horizontally, 
vertically, or diagonally. 

I 
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4. Release the mouse button and the Shift key when the object is where you 
want it. 

0 
If you change your mind, you can immediately choose Undo Move from 

the Edit menu to undo the move you just performed. 

Moving objects to the center of the window 

The following procedure positions one or more objects in the exact center 

of the active window. 

To move on object to the center of the window: 

1. Select the object you want to move. 

2. Choose Cut from the Edit menu, or press :-X. 

The selected object is temporarily deleted and placed on the Clipboard. 

3. Choose Paste from the Edit menu, or press :•:-v. 

The object is pasted to the center of the active window, in front of all other 

objects in the document, and it is selected. 

If you change your mind, you can immediately choose Undo Paste from 

the Edit menu to undo the paste you just performed. 

If you paste in more than one object, the relative painting order among the 
individual objects pasted from the Clipboard remains the same. 
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Moving objects in front of or in back of other objects 

The ordering, or layering, of objects in your artwork affects the final 
appearance of the document when it is previewed or printed. Use the 
following procedure to move one or more objects in front of or in back of 
other objects. To move an object all the way to the front or back of your 
artwork without placing it on the Clipboard, see the following section, 
"Sending Objects to the Front or Back." 

To move an object in front of or in back of other objects: 

1. Select the object you want to move. 

In the example at left, the door is in the 
backmost paint layer. 

2. Choose Cut from the Edit menu, or press :•:-X. 

The selected object is temporarily deleted and placed on the Clipboard. 

3. Select the object or objects in front of which (or in back of which) you want 
the Clipboard object to appear. 

U 

U 

4. Choose Paste In Front (or Paste In Back) from the Edit menu, or 
press ::-F or ::-B. 

The Clipboard object is pasted in front of 
(or in back of) the object you selected in 
step 3, in terms of relative painting order. 
You can move the pasted object to its final 
position. 
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If you change your mind, you can immediately choose Undo Paste from 

the Edit menu to undo the paste you just performed. 

5. Choose Preview Illustration from the View menu to see the result of the 
move. 

If you paste in more than one object, the relative painting order among the 
individual objects pasted from the Clipboard remains the same, even 

though you have changed the painting order of all Clipboard objects 

relative to other objects in the document. 

Sending objects to the front or back 

Two commands provide a fast way for you to move an object to the front 

or back of the artwork without cutting and pasting. The object you move 

becomes either the frontmost or backmost object in the entire document. 

To send an object to the front or back: 

1. Select the object you want to move. 

2. Choose either Bring To Front or Send To Back from the Edit menu, or 

press :.-= or :.-- (hyphen). 

The selected object is sent all the way to the front or back of your artwork. 

If you change your mind, you can immediately choose Undo from the Edit 

menu to undo the change you just made. 

Use the Preview Illustration command from the View menu to see the 

result of the move. 
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Moving objects a specific distance and direction 

Rather than dragging objects, you can move them a specific distance and 
direction by providing information in the Move dialog box. Alternatively, 
you can move a copy of an object rather than the object itself. 

The Move dialog box always displays the distance and direction of the last 
move operation, and the current unit of measure set in the Preferences 
dialog box. To obtain this information at any time, simply hold down the 
Option key and click on the selection tool in the toolbox. 

You can either move or copy and move one or more objects at a time 
using the following procedure. 

If an object that you want to move is painted with a pattern, you can 
choose to move the pattern tiles as well as the object. For more information 
about pattern tiles, see "Understanding Pattern Tiling," in Chapter 13, 
"Painting." 

To move an object a specific distance and direction: 

1. Select the object you want to move. 

2. Hold down the Option key and click on the selection tool in the toolbox. 

The Move dialog box appears. The Distance field displays the distance of 
the last move operation, if any, that was performed. The current unit of 
measure is indicated to the right of the Distance field. 

Moue 

Distance: 

1
-Direction 

0 pt 

Horizontal moue 
Q Vertical moue  
Q Rngled moue: 

❑ Moue pattern tiles 

I OK 

Cancel 

Copy
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3. In the Distance field, type the distance that you want the object to move. 

4. Click on the button that indicates the direction in which you want the 
object to move. 

❑ Moue 

Distance: 

—Direction 

-15 pt OK 

Q Horizontal moue 
O Vertical moue  
O Angled moue: 

❑ Moue pattern tiles 

Cancel 

Copy

You can move the object horizontally, vertically, or at any arbitrary 
diagonal angle. If you click on Horizontal Move, objects move to the right 
for the diatance you specified. If you click on Vertical move, objects move 
up (toward the top of the window) for the distance you specified. 

y axis 
(-270°) 

(-225°) A (-315°) 
135° 45° 

(-180°) 180° 

225° 
(-135°) 

270°
(-90°) 

 ► 0° x axis 

315° 
(-45°) 

If you want to move the object diagonally, type the angle at which you 
want the object to move, in degrees, in the Angled Move field. The angle 
you enter is calculated in degrees from the horizontal, which is 0 degrees. 
Positive angles (ones that are not prefixed) specify a counterclockwise 
move. Negative angles (ones that are prefixed by a minus sign) specify a 
clockwise move. 

NOTE: The distance and direction you specify in the Move dialog box are 
relative to the current orientation of the x and y axes, which may or may 
not be parallel to the sides of the window. For example, if the axes have 
already been rotated by 10 degrees, specifying an angled move of 30 degrees 
actually moves the object along a line 40 degrees from the window's 
horizontal axis. See "Rotating the X and Y Axes" in Chapter 12, 
"Measuring and Constraining." 
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5. Click in the Move Pattern Tiles checkbox if you want to move the pattern 
tiles as well as the object itself. 

6. Once you have specified a distance and direction, you have three options. 

Option 1 Click OK to move the object. 

The object moves to the specified location, 
and remains selected. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to undo the move you just performed. 

Option 2 Click Copy to create a duplicate of the selected object at the 
distance and in the direction specified. 

The object is copied to the new location 
and remains selected while the original 
object remains in position. n

Option 3 Click Cancel if you decide not to move or copy the object. 

NOTE: You can repeat a move or copy operation by choosing Transform 
Again from the Arrange menu, or by pressing C-D. 



Chapter 9: Copying Objects 

This chapter describes how to copy objects within a document or between 
Adobe Illustrator program version 1.1 documents and Adobe Illustrator 88 
program documents. There are six copy procedures. You can 

■ Copy an object by moving a copy 

■ Copy an object by transforming a copy 

■ Copy an object to the center of the window 

■ Copy an object on top of the original object 

■ Copy an object in front of or in back of other objects 

■ Copy an object from one Adobe Illustrator program document to another 

Copying objects by moving copies 

You can simultaneously copy an object and move that copy to a new place 
by using this simple procedure. 

To copy an object by moving a copy: 

1. Select the object you want to copy. 

2. Position the pointer on the selected object. 

c_. 

In the case of type, position the pointer on 
one of the selected baselines. 

(opying objects 
while moving 
them 
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3. Start to drag the selected object to its new location, and then hold down the 
Option key. 

As you drag, an image of the selected 
object is temporarily left in its original 
location for your reference. 

4. Release the mouse button, and then release the Option key. 

The original selected object remains, and a 
copy of the object appears at the new 
location. The copy is now selected. 

If you change your mind, you can immediately choose Undo Move from 
the Edit menu to delete the copy you just made. 

Copying objects by transforming copies 

You can simultaneously copy an object and rotate, scale, shear, or reflect 
the copy. For example, you can copy and rotate a petal shape several times 
to create a flower. For more information about using the transformation 
tools, see Chapter 11, "Transforming Objects." 

You can copy an object while you transform it either by dragging or by 
specifying values in a dialog box. Both procedures are provided below. In 
both cases, choosing Transform Again will create additional copies of the 
moved or transformed objects. The following transformation procedures do 
not work with the blend tool. 

To transform a copy by dragging: 

1. Select the object you want to copy and transform. 

I 
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2. Click in the toolbox on the transformation tool you want to use. 

For example, click on the scale tool. The 
pointer changes to a dotted cross when 
you move it to the active window. You use 
the cross to fix an invisible point of origin 
from which the copy of the object will be 
transformed. 

Position the cross at the point at which you want the transformation to 
begin, and click. The cross changes to an arrowhead. 

3. Select a point and start to drag the arrowhead to transform the object, and 
then hold down the Option key. 

4. Release the mouse button, and then release the Option key. 

A copy of the object selected in step 1 
appears at the point of transformation. It 
is rotated, scaled, sheared, or reflected. The 
copy is now selected. 

If you change your mind, you can immediately choose Undo from the Edit 
menu to delete the copy you just made. 

To transform a copy by using a dialog box: 

1. Select the object you want to copy and transform. 

h~ 
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2. Click in the toolbox on the transformation tool that you want to use. 

For example, click on the reflect tool. The pointer changes to a dotted cross 
when you move it to the active window. You use the cross to fix an 
invisible point of origin from which the copy of the object will be 
transformed. 

3. Position the cross at the point at which you want the transformation to 
begin. 

4. Hold down the Option key and click. 

A dialog box appears. 

5. Fill in the dialog box with the values you want to apply to the copy of 
the object. 

❑   Reflect  

—Reflect across 
O Horizontal axis 
O.  Vertical axis 
O Angled axis: 

❑ Reflect pattern tiles 

OK 

Cancel 

Copy j 

6. Click Copy (instead of OK). 

invisible axis of reflection 

A copy of the object selected in step 1 
appears at the point of transformation. It 
is rotated, scaled, sheared, or reflected, 
according to the values you specified. The 
copy is also selected. 

If you change your mind, you can immediately choose Undo from the Edit 
menu to delete the copy you just made. 

I 
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Copying objects to the center of the window 

This procedure lets you place a copy of an object in the exact center of the 
active window. 

To copy an object to the center of the window: 

1. Select the object you want to copy. 

2. Choose Copy from the Edit menu, or press :•:-C. 

A copy of the selected object is placed on the Clipboard. 

3. Choose Paste from the Edit menu, or press -V. 

The Clipboard object is pasted in the center of the active window. 

If you change your mind, you can immediately choose Undo Paste from 
the Edit menu to delete the copy you just made. 

Copying objects on top of the originals 

Sometimes it is useful to place a copy of an object exactly on top of the 
original. For example, you might want to place an outline on top of a 
filled area of the same shape. 

To place a copy of an object on top of the original: 

1. Select the object you want to copy. 

2. Choose Copy from the Edit menu, or press ::-C. 

A copy of the selected object is placed on the Clipboard. 

3. Choose Paste In Front from the Edit menu, or press :•:-F. 

The Clipboard object is pasted directly in front of the object you selected. 

You can only see the selected copy. The 
unselected original is directly behind it. 

R 



114 User Guide 

If you change your mind, you can immediately choose Undo Paste from 
the Edit menu to delete the copy you just made. 

You can paint or transform the copy in any way. 

In the example at left, the original 
(backmost) object was selected and stroked 
with black using a line weight of 4. The 
copied object (frontmost) was selected and 
stroked with white using a line weight of 
1. Neither object was filled. 

Copying objects in front of or in back of other objects 

This ability is useful when you want to rearrange the look of and/or 
change the painting order of overlapping objects. It is also helpful when 
you want to create shadows or paste scaled copies of the same object in 
front of or in back of the original. 

To copy an object in front of or in back of other objects: 

1. Select the object you want to copy. 

2. Choose Copy from the Edit menu, or press :•:-C. 

A copy of the selected object is placed on the Clipboard. 

3. Select the object in front of which (or in back of which) you want to place 
the Clipboard object. 

N 
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4. Choose Paste In Front (or Paste In Back) from the Edit menu, or press 

or ..-B. 
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The Clipboard object is pasted in front of (or in back of) the original object 
selected in step 1. In terms of painting order, (layering), it is in front of (or 
in back of) the object you selected in step 3. The copy is selected. 

You can move the copy if it is not where 
you want it. Then you can paint it or 
transform it in any way. 

5. Preview your artwork to check the final painting order. 

If you change your mind, you can immediately choose Undo Paste from 
the Edit menu to undo the paste you just performed. 

Copying between two Adobe Illustrator documents 

You can copy your artwork (from either Adobe Illustrator 88 program 
documents or Adobe Illustrator program version 1.1 documents) to the 
Clipboard and paste it into Adobe Illustrator 88 program documents in the 
same way that you copy and paste between documents in other Macintosh 
applications. You can also copy artwork from Adobe Collector's Edition I. If 
you paste Adobe Illustrator 88 program artwork into Adobe Illustrator 
program version 1.1 documents, the documents must subsequently be 
opened using the Adobe Illustrator 88 program. 

For information about copying between Adobe Illustrator 88 program 
documents and other applications, see Chapter 16, "Working with Other 
Applications." 

NOTE: The Adobe Illustrator 88 program slows down when you are 
working on very complex artwork. You can alleviate this problem by 
creating your artwork in sections (as separate documents) and then 
pasting each section into one final artwork document. Hiding objects you 
are not working with also helps keep the program from slowing down. 
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To copy between two Adobe Illustrator documents: 

1. Select the objects you want to copy, or select all objects. 

2. Choose Copy from the Edit menu, or press :•:-C. 

The selected objects are placed on the Clipboard. You can choose Show 
Clipboard from the Window menu to find out how many artwork objects 
are on the Clipboard. 

3. Open the document that is to receive the artwork from the Clipboard. 

4. Choose Paste from the Edit menu, or press :•:-v. 

All objects on the Clipboard are pasted in 
the center of the active window. 

Objects pasted from the Clipboard are placed in front of all other objects 
in the document. However, the relative painting order among the 
individual objects pasted from the Clipboard remains the same. 

5. Preview your artwork to see the effect of the paste on the painting order. 

~\ I 



Chapter 10: Deleting Objects 

This chapter describes all the ways in which you can delete objects from 
your artwork. There are three procedures you can use. You can delete one, 
several, or all objects from your artwork, and you can do so temporarily or 
permanently. You can also undo or redo deletions. 

Deleting objects temporarily 

You delete an object by using the Cut command from the Edit menu. 
Cutting an object places it on the Clipboard temporarily. If you want to 
paste it back into your artwork, you must choose Paste from the Edit menu 
before you cut or copy another object. 

To delete an object temporarily: 

1. Select the object you want to delete temporarily. 

2. Choose Cut from the Edit menu, or press :•:-X. 

The selected object disappears from the working area and is placed on the 
Clipboard. It remains there and can be pasted back into your artwork until 
you cut or copy another object. 

Deleting objects permanently 

You can permanently delete any object that you are sure you will not be 
using again. You delete an object by using the Clear command from the 
Edit menu. 

IMPORTANT: Clearing an object does not place it on the Clipboard. If you 
think you might need an object that you have deleted with Clear, choose 
Undo Clear from the Edit menu immediately. Then use the Cut command 
instead. 

To delete an object permanently: 

1. Select the object you want to delete permanently. 

2. Choose Clear from the Edit menu, or press the Backspace key. 

If you have a Macintosh SE or a Macintosh II, you can press the Delete key. 

The selected object is deleted and disappears from the working area. It 
cannot be pasted in again unless you undo the deletion immediately. 
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Deleting all objects 

You can delete all of the objects in your artwork simultaneously. This is 
useful if you want to start your drawing all over again. You delete all 
objects by using the Clear command from the Edit menu. 

IMPORTANT: Clearing an object does not place it on the Clipboard. If you 
think you might need an object that you have deleted with Clear, choose 
Undo Clear from the Edit menu immediately. Then use the Cut command 
instead. 

To delete all objects: 

1. Choose Select All from the Edit menu, or press :•:-A. 

2. Choose Clear from the Edit menu, or press the Backspace key. 

If you have a Macintosh SE or a Macintosh II, you can press the Delete key. 

All objects are deleted and disappear from the working area. They are not 
placed on the Clipboard and cannot be pasted in again unless you undo 
the deletion immediately. 

Undoing a deletion 

If you change your mind about the last deletion you made, you can undo 
it but only immediately after you make the deletion. If you click anywhere 
or perform another operation, you will not be able to use the Undo 
command. 

To undo a deletion: 

1. Choose Undo Cut or Undo Clear from the Edit menu, or press 

The deleted object is restored to the working area. 
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This chapter provides a complete description of all the transformation 
tools and tells you how to use them. 

You can transform any number of objects, from a single anchor point to 
all of the objects in a document. The transformation tools let you modify 
the physical shape, size, and appearance of objects. You can transform 
objects by using one or more transformation tools, alone or in sequence. 
For example, you can scale an object, rotate it, and then blend the area 
within its outlines. 

If an object that you want to transform is painted with a pattern, you can 
choose to move the pattern tiles as well as the object itself. Before you 
transform the object, choose Preferences from the Edit menu and click in 
the Transform Pattern Tiles checkbox. An x appears, indicating that the 
option is turned on. (The preset option is off.) 

Turning this option on means that in the future all patterns used to paint 
objects will be transformed if you move the objects or transform them with 
any of the transformation tools, either by dragging or by using the dialog 
boxes. 

Turning this option on or off in the Preferences dialog box updates the 
same option in all of the transformation dialog boxes as well. Turning this 
option on or off in any of the transformation dialog boxes updates this 
option in the Preferences dialog box. For more information, see the 
individual transformation procedures in this chapter that discuss using 
dialog boxes. See also "Understanding Pattern Tiling" in Chapter 14, 
"Using Patterns." 

Choosing a transformation tool 

Here is what each tool does: 

■ The scale tool enlarges or reduces objects, uniformly or nonuniformly. 

■ The rotate tool rotates objects at any angle counterclockwise or clockwise. 

■ The reflect tool creates mirror images of objects along any axis. 

■ The shear tool slants (skews) objects in any direction. 

■ The blend tool creates intermediate shapes between two different paths. 
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Using a transformation tool 

All transformations (except blending) start from a point of origin, which you 
specify. A point of origin is a fixed spot in your artwork from which a 
transformation begins. 

The basic procedure is similar for all transformations (except blending): 

r Select an object. 

■ Choose a transformation tool. 

■ Specify the point of origin of the transformation. 

■ Drag the object to transform it visually, or fill in a dialog box specifying the 
parameters of the object's transformation. 

Simple commands let you repeat the last transformation you made as 
many times as you want or undo the last transformation. 

In addition, you can use the transformation tools with the Option key or 
dialog boxes to transform a copy of an object rather than the object itself. 
For more information, see "Copying Objects by Transforming Copies" in 
Chapter 9, "Copying Objects." 

Transforming works differently than painting does. Painting affects an 
entire path, even if only part of a path is selected. Transforming affects 
only the part of a path that is selected. If you want to transform an entire 
path, you must select all of it. 

Using the scale tool 

Scaling an object enlarges or reduces it horizontally (along the x axis), 
vertically (along the y axis), or both, relative to a fixed point of origin that 
you designate. 

Uniform scaling enlarges or reduces objects equally along the x and y axes. 
Nonuniform scaling lets you enlarge or reduce objects more along one axis 
than another. 

Copying while scaling is a quick way of creating different-sized copies of 
the same object. See also "Copying Objects by Transforming Copies" in 
Chapter 9, "Copying Objects." 

There are two scaling procedures: 

■ Dragging the object 

■ Specifying scale factors in a dialog box 
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Scaling by dragging 

You can drag the object to visually stretch or compress it. 

NOTE: Line weights are not scaled by this method. To scale line weights 

while scaling objects, use the method described in the next section, "Scaling 

by Specifying Scale Factors." 

If the Transform Pattern Tiles option is turned on in either the Preferences 

dialog box or any of the transformation dialog boxes, patterns used to 

paint objects will also be scaled by dragging. 

To scale by dragging: 

1. Select the object you want to scale. 

f ~ t 

2. Click on the scale tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 

window. You use the dotted cross to specify an invisible point of origin 

from which the object will be scaled. 

3. Position the dotted cross at the point from which you want the object to be 

scaled, and click. 

Clicking sets the point of origin for the 
scale operation. The dotted cross changes 
to an arrowhead. 

4. Move the arrowhead away from the invisible point of origin. 
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5. Drag the arrowhead away from or toward the point of origin. 

As you drag, an image of the selected 
object is temporarily left in its original 
position for your reference. 

If you drag the arrowhead away from the point of origin, a second image 
of the object is scaled up (enlarged). If you drag the arrowhead toward the 
point of origin, the image is scaled down (reduced). If you drag 
horizontally, the image is enlarged or reduced horizontally. If you drag 
vertically, the image is enlarged or reduced vertically. 

To have finer control of scaling, start to drag farther from the point of 
origin. 

To constrain the scaling so that it is uniform, hold down the Shift key as 
you drag the arrowhead. Uniform scaling enlarges or reduces objects 
equally along the x and y axes. Nonuniform scaling lets you enlarge or 
reduce objects more along one axis than another. 

To scale a copy of the object instead of the object itself, hold down the 
Option key after you start to drag. 

6. Release the mouse button when the scaled image is the size and shape you 
want. 

The object remains at its scaled size and 
shape and is still selected. The arrowhead 
changes back to a dotted cross, ready for 
you to specify the next point of origin. 

To undo the scaling operation, choose Undo Scale from the Edit menu, or 
press :•:-z. 

To repeat the scaling operation, choose Transform Again from the Arrange 
menu, or press :•:-D. 

If you do not want to continue scaling, click on another tool in the toolbox. 
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Scaling by specifying scale factors 

This method lets you specify very exact scaling. It also lets you choose 
whether to scale or preserve line weights (with uniform scaling). 

To scale by specifying scale factors: 

1. Select the object you want to scale. 

' r  Y 

2. Click on the scale tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 

window. You use the dotted cross to specify an invisible point of origin 

from which the object will be scaled. 

3. Position the dotted cross at the point from which you want the object to be 

scaled. 

4. Hold down the Option key and click. 
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The Scale dialog box appears. It displays the settings for the last scale 
operation, if any. 

❑   Scale 

Q Uniform scale: 100 

Q Preserve line weights 
Q Scale line weights 

Q Non-uniform scale: 

FiE~~ixE~r~tt►i: 

Ve3iiE€ : 

❑ Scale pattern tiles 

OK 

( Cancel 

Copy 

5. Specify the new scale parameters. 

Scale 

Q Uniform scale: 160 

Q Preserve line weights 
Q Scale line weights 

Q Non-uniform scale: 

i1E31'i:IEl3l~fli: 

Ier1i(€ l: 

❑ Scale pattern tiles 

b OK 

Cancel 

( Cop!J  1 

You can choose uniform or nonuniform scaling. If you choose uniform 
scaling, enter the scale factor as a percentage. 

With uniform scaling you can also choose to either preserve line weights 
or scale them. Preserving line weights is the preset option. If you scale 
them, the line weights of all stroked paths (as specified in the Paint dialog 
box) are scaled along with the objects. See "Setting the Line Weight" in 
Chapter 13, "Painting," for more information. 

If you choose nonuniform scaling, enter the horizontal and vertical scale 
factors as percentages. The scale factors are relative to the specified point of 
origin, and they can be negative. For example, a nonuniform scale with 
-100 percent horizontal scaling and 100 percent vertical scaling is 
equivalent to reflection about a vertical line that passes through the point 
of origin. 
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Line weights cannot be scaled with nonuniform scaling. 

If the object you are scaling is painted with a pattern, and you want to 
scale the pattern as well as the object, click in the Scale Pattern Tiles 
checkbox. Turning the option on here also turns it on in the Preferences 
dialog box. For more information about pattern tiling, see "Understanding 
Pattern Tiling," in Chapter 14, "Using Patterns." 

6. Click OK. 

The object assumes its scaled size and 
shape and is still selected. Line weights are 
scaled also, if you specified that option. 
The arrowhead changes back to a dotted 
cross, ready for you to specify the next 
point of origin. 

To undo the scaling operation, choose Undo Scale from the Edit menu, or 
press -z. 

To repeat the scaling operation, choose Transform Again from the Arrange 
menu, or press :•:-D. 

If you do not want to continue scaling, click on another tool in the toolbox. 

If you click Copy instead of OK, a copy of the object is scaled, and the 
original object remains the same. 

Using the rotate tool 

Rotating an object moves it around a fixed point that you designate. You 

can rotate an object up to 360 degrees either counterclockwise or clockwise. 

Copying while rotating is a useful method of creating radially 
symmetrical objects; such as the petals of a flower. See also "Copying 
Objects by Transforming Copies," in Chapter 9, "Copying Objects." 

There are two rotation procedures: 

■ Dragging the object 

■ Specifying an angle of rotation in a dialog box 
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Rotating by dragging 

You can drag the object to visually rotate it. 

Tithe Transform Pattern Tiles option is turned on in either the Preferences 
dialog box or any of the transformation dialog boxes, patterns used to 
paint objects will be rotated by dragging. 

To rotate by dragging: 

1. Select the object you want to rotate. 

f 

2. Click on the rotate tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 
window. You use the dotted cross to specify an invisible point of origin 
around which the object will rotate. 

3. Position the dotted cross at the point around which you want the rotation 
to occur, and click. 

Clicking sets the point of origin for the 
rotate operation. The dotted cross changes 
to an arrowhead. 

4. Move the arrowhead away from the point of origin of the rotation. 

5. Drag the arrowhead in a circular motion around the point of origin. 

As you drag, an image of the selected 
object is temporarily left in its original 
position for your reference. A second 
image of the object rotates. 
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To rotate by multiples of 45 degrees, hold down the Shift key as you drag 
the arrowhead. To rotate a copy of the object instead of the object itself, 
hold down the Option key after you start to drag. 

6. Release the mouse button when the image has been rotated to the position 
you want. 

The object remains in the rotated position 
and is still selected. The arrowhead 
changes back to a dotted cross, ready for 
you to specify the next point of origin. 

To undo the rotating operation, choose Undo Rotate from the Edit menu, 
or press :•:-Z. 

To repeat the rotating operation, choose Transform Again from the 
Arrange menu, or press :•:-D. 

If you do not want to continue rotating, click on another tool in the 
toolbox. 

Rotating by specifying an angle 

You can also rotate by specifying an angle of rotation, rather than by 
dragging the object. This lets you be very exact about the amount by which 
an object is rotated. 

To rotate by specifying an angle: 

1. Select the object you want to rotate. 

2. Click on the rotate tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 
window. You use the dotted cross to specify an invisible point of origin 
around which the object will be rotated. 
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3. Position the dotted cross at the point around which you want the rotation 
to occur. 

4. Hold down the Option key and click. 

The Rotate dialog box appears. It displays the angle of the last rotation, if 
any. 

❑   Rotate  

Angle: 0 4 

❑ Rotate pattern tiles 

Cancel 

Copy 

5. Enter the new rotation angle, in degrees. 

❑  Rotate  

Angle: 90 4 

Cancel

❑ Rotate pattern tiles ( Copy

Positive angles rotate counterclockwise; negative angles rotate clockwise. 

I NOTE: Do not precede positive angles with a plus sign, but precede 
negative angles with a minus sign. 

If the object you are rotating is painted with a pattern, and you want to 
rotate the pattern as well as the object, click in the Rotate Pattern Tiles 
checkbox. Turning the option on here also turns it on in the Preferences 
dialog box. For more information about pattern tiling, see "Understanding 
Pattern Tiling," in Chapter 14, "Using Patterns." 
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6. Click OK. 

The object assumes its rotated position 
and is still selected. The arrowhead 
changes back to a dotted cross, ready for 
you to specify the next point of origin. 

To undo the rotating operation, choose Undo Rotate from the Edit menu, 
or press -Z. 

To repeat the rotating operation, choose Transform Again from the 
Arrange menu, or press >:-D. 

If you do not want to continue rotating, click on another tool in the 
toolbox. 

If you click Copy instead of OK, a copy of the object is rotated, and the 
original object remains the same. 

Using the reflect tool 

1 Reflecting an object creates a mirror image across an invisible axis that 
passes through a point that you specify. 

Copying while reflecting is a powerful tool for creating a mirror image of 
an object. See also "Copying Objects by Transforming Copies" in Chapter 
9, "Copying Objects." 

There are two reflecting procedures: 

■ Dragging the object 

■ Specifying an axis of reflection in a dialog box 

Reflecting by dragging 

You can drag the object to visually reflect it. 

If the Transform Pattern Tiles option is turned on in either the Preferences 
dialog box or any of the transformation dialog boxes, patterns used to 
paint objects will be reflected by dragging. 
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To reflect by dragging: 

1. Select the object you want to reflect. 

2. Click on the reflect tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 
window. You use the dotted cross to specify an invisible axis of reflection. 

3. Position the dotted cross on one point along the invisible axis across which 
you want the reflection to take place, and click. 

Clicking sets the point of origin for the 
reflect operation. The dotted cross changes 
to an arrowhead. 

invisible axis of reflection 

4. Position the arrowhead at another point along the invisible axis. 

You now have two options. 

Option 1 Click to reflect the object across. 

When you click, the selected object crosses 
over the defined axis. 
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The object remains in the reflected 
position and is still selected. The 
arrowhead changes back to a dotted cross, 
ready for you to specify the next axis of 
reflection. 

Option 2 Adjust the axis of reflection by dragging the arrowhead instead 
of clicking. 

As you drag, the invisible axis of reflection 
rotates around the point you clicked in 
step 3. An image of the selected object is 
temporarily left in its original position for 
your reference. A second image is reflected 
across the axis and follows the movement 
of the arrowhead as you drag it. 

When the moving image is in the position 
you want, release the mouse button. The 
arrowhead changes back to a dotted cross, 
ready for you to specify the next axis of 
reflection. 

To undo the reflecting operation, choose Undo Reflect from the Edit menu, 
or press -Z. 

To constrain the reflection axis to multiples of 45 degrees relative to the 
angle of constraint set in the Preferences dialog box, hold down the Shift 
key after starting to drag the arrowhead. 

To reflect a copy of the object instead of the object itself, hold down the 
Option key after you start to drag. 

To repeat the reflecting operation, choose Transform Again from the 
Arrange menu, or press :•:-D. 

If you do not want to continue reflecting, click on another tool in the 
toolbox. 
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Reflecting by specifying an axis 

You can also reflect by specifying an axis of reflection, rather than by 
dragging the object. This lets you be very exact about the way in which an 
object is reflected. 

To reflect by specifying an axis: 

1. Select the object you want to reflect. 

2. Click on the reflect tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 
window. You use the dotted cross to specify an invisible axis of reflection. 

3. Position the dotted cross on one point along the invisible axis across which 
you want the reflection to take place. 

invisible axis of reflection 

4. Hold down the Option key and click. 

The Reflect dialog box appears. It displays the orientation of the axis of the 
last reflection, if any. 

❑  Reflect   

—Reflect across 
Q Horizontal axis 
Q Vertical axis 
Q Rngled axis: 

❑ Reflect pattern tiles 

~( OK 

( Cancel ) 

( Copy  . 
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5. Click on the axis across which you want the object to be reflected. 

Reflect  

Reflect across 
O Horizontal atsis 
Q Vertical axis 
O Rngled aHis: 

❑ Reflect pattern tiles 

OK 

Cancel 

Copy

You can reflect an object across a horizontal, a vertical, or an angled axis. 

If you choose an angled axis, enter the angle of reflection, in degrees, 
relative to the x axis, that you want the axis of reflection to have. 

Positive angles reflect the axis counterclockwise; negative angles reflect it 
clockwise. 

If the object you are reflecting is painted with a pattern, and you want to 
reflect the pattern as well as the object, click in the Reflect Pattern Tiles 
checkbox. Turning the option on here also turns it on in the Preferences 
dialog box. For more information about pattern tiling, see "Understanding 
Pattern Tiling," in Chapter 14, "Using Patterns." 

6. Click OK. 

The object assumes its reflected position 
and is still selected. The arrowhead 
changes back to a dotted cross, ready for 
you to specify the next point of origin. 

To undo the reflecting operation, choose Undo Reflect from the Edit menu, 
or press -z. 

To repeat the reflecting operation, choose Transform Again from the 
Arrange menu, or press :•:-D. 

If you do not want to continue reflecting, click on another tool in the 
toolbox. 

If you click Copy instead of OK, a copy of the object is reflected, and the 
original object remains the same. 
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Using the shear tool 

Shearing an object slants (skews) it uniformly along an axis and at an 
angle you specify. Usually, objects are sheared either horizontally or 
vertically, but the Adobe Illustrator 88 program also lets you shear along 
any arbitrary axis. 

There are two shearing procedures: 

■ Dragging the object 

■ Specifying an angle and an axis of shear in a dialog box 

Copying while shearing is a simple way of producing slanted copies of an 
object and is particularly useful for creating cast shadows. See also 
"Copying Objects by Transforming Copies" in Chapter 9, "Copying 
Objects." 

'NOTE: Contrary to the way the program works in other instances, the 
shear angle is always calculated clockwise relative to the current x axis. 

Shearing by dragging 

You can drag the object to visually shear it. 

If the Transform Pattern Tiles option is turned on in either the Preferences 
dialog box or any of the transformation dialog boxes, patterns used to 
paint objects will be sheared by dragging. 

To shear by dragging: 

1. Select the object you want to shear. 

J 'y 7

2. Click on the shear tool in the toolbox. 

The pointer changes to a dotted cross. You use the dotted cross to specify 
the point of origin of the shear axis. 
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3. Position the dotted cross at the point from which you want the shear to 
begin, and click. 

N~ 

Clicking sets the point of origin for the 
shear axis. The dotted cross changes to an 
arrowhead. 

4. Move the arrowhead away from the shear axis. 

The farther away you start, the finer the control you have over shearing. 

5. Drag the arrowhead in the direction in which you want to shear the object. 

As you drag, an image of the selected 
object is temporarily left in its original 
position for your reference. 

If you drag horizontally, a second image of the object is sheared along the 
x axis. If you drag vertically, the image is sheared along the y axis. 

To shear along an angle that is a multiple of 45 degrees relative to the 
current x axis, hold down the Shift key after starting to drag the 
arrowhead. 

To shear a copy of the object instead of the object itself, hold down the 
Option key after you start to drag. 

6. Release the mouse button when the image is the shape you want. 

The object remains in the sheared shape 
and is still selected. The arrowhead 
changes back to a dotted cross, ready for 
you to specify the next shear axis. 

To undo the shearing operation, choose Undo Shear from the Edit menu, 
or press :•:-z. 
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To repeat the shearing operation, choose Transform Again from the 
Arrange menu, or press -D. 

If you do not want to continue shearing, click on another tool in the 
toolbox. 

Shearing by specifying an angle and an axis 

You can specify the exact shear axis and shear angle that you want to 
apply to an object. This gives you precise control over the shear operation. 

To shear by specifying an angle and an axis: 

1. Select the object you want to shear. 

2. Click on the shear tool in the toolbox. 

The pointer becomes a dotted cross when you move it to the active window. 
You use the dotted cross to specify the point of origin of the shear axis. 

3. Position the dotted cross at the point from which you want the shear to 
begin. 
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4. Hold down the Option key and click. 

The Shear dialog box appears. It displays the orientation of the last shear 

axis and the angle of the last shear, if any. 

❑ Shear  

Angle: 0 

—Shear along 

a 

Q Horizontal axis 
O Vertical axis 
O Angled axis: 

❑ Shear pattern tiles 

I OK 

( Cancel  J 
Copy

5. Enter the new shear angle. The shear angle is the amount of slant to be 

applied to the object, relative to a line perpendicular to the shear axis. 

6. Specify the axis along which the selected object is to be sheared. 

Shear   

Angle: -25 

—Shear along 

O 

O Horizontal axis 
O Vertical axis 
Q Angled axis: 75 O 

❑ Shear pattern tiles 

I OK 

Cancel 

Copy J 

You can shear an object along a horizontal, a vertical, or an angled axis. 

If you choose an angled axis, type the angle of the axis that you want, in 

degrees, relative to the x axis. The origin of the angled axis will be the 
point you set when you clicked in step 4. 

If the object you are shearing is painted with a pattern, and you want to 

shear the pattern as well as the object, click in the Shear Pattern Tiles 

checkbox. Turning the option on here also turns it on in the Preferences 

dialog box. For more information about pattern tiling, see "Understanding 

Pattern Tiling," in Chapter 14, "Using Patterns." 
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7. Click OK. 

Using the blend tool 

The object assumes its sheared shape and 
is still selected. The arrowhead changes 
back to a dotted cross, ready for you to 
specify the next shear axis. 

To undo the shearing operation, choose Undo Shear from the Edit menu, 
or press •:-Z. 

To repeat the shearing operation, choose Transform Again from the 
Arrange menu, or press -D. 

If you do not want to continue shearing, click on another tool in the 
toolbox. 

If you click Copy instead of OK, a copy of the object is sheared, and the 
original object remains the same. 

Blending lets you create a series of intermediate shapes between two objects. 
Depending on the way you paint the objects you are blending, you can 
produce airbrush effects such as complex shading, highlighting, or 
contouring with different line weights, shades of gray, or process or custom 
colors. 
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You can blend between two objects painted with two process colors or two 

custom colors. If you blend between one object painted with a process color 

and another object painted with a custom color, the blended shapes will be 
painted with an appropriate process color. If you want to blend a custom 

color with white, do not use process white. Use 0 percent tint of the same 

custom color instead of white to get an appropriate custom tint. For more 
information on blending with colors, see the Adobe Illustrator 88 Color 

Guide that accompanies this manual. 

You can also blend between two patterned objects but they must have the 

same pattern. If the two patterned objects have different transformations of 

the pattern, the intermediate shapes created when blending will be painted 

with appropriate intermediate transformations of the pattern. 

You cannot blend between an open path and a closed path. Both paths 

must be either open or closed. 

There is only one blending procedure. You specify blend factors in the 
Blend dialog box. 

To blend, you select one or more pairs of points on two selected paths 
between which you want to blend. Then you specify the number of 
blending steps you want to have occur between those two paths. You also 

specify the blending percentages of the first and last steps. 
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The program interpolates between the pairs of points and creates 
intermediate shapes by calculating which percentage of the perimeter of 
the selected paths to use for each new step. The more anchor points you 
select, the greater the control you usually have over the blending of the 
paths, as shown in the following illustrations. 

When you are blending open paths, be sure to click the blend tool on at 
least one endpoint from each path. (You can select more than one point on 
each path, but be sure to click the blend tool on selected endpoints.) 

In addition, you should paint the paths between which you will be 
blending before you blend them, and you should place them at the correct 
distance from one another. 

IMPORTANT: You must ungroup paths, if they are grouped, before you 
can blend them. 
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To blend between two paths: 

1. Click on the selection tool in the toolbox. 

2. Click on one or more points on the paths between which you want to 
blend. 

li  S 

If you want to select all the points on both 
paths, hold down the Option key while 
you click. 

3. Click on the blend tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 
window. 

4. Click once on each selected path, on two corresponding selected points. 

After the first click, the right arm of the 
cross is extended. 

G  S 

The Blend dialog box appears. 

Blend  

Number of steps: 

First blend: 

Last blend: 

1 

50 

50 % 

OK 

Cancel 

5. Specify the number of intermediate steps in which you want to blend. 

The number of steps you enter determines how many intermediate objects 
are created. This number excludes the originally selected blend paths. 

The preset option is 1. Enter a whole positive number between 1 and 1008. 
The more steps indicated, the finer the gradation between shapes or paint 
attributes. 
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Based on the number of steps you enter, the percentages of the first and 
last blend steps are automatically calculated and displayed in the fields. 
The preset options are 50 percent and 50 percent. 

6. Enter new values for the first and last blend steps, in percentages. 

You can enter any positive or negative number between -100 and 200. 

  Blend  

Number of steps: 19 OK 

First blend: 5 Cancel 

Last blend: 95 % 

For example, if you specify 19 steps, the First Blend and Last Blend fields 
display 5 percent and 95 percent, respectively. This means that the first 
blend will occur 5 percent of the way between the two selected objects, and 
the last blend will occur 95 percent of the way between them. (The second 
blend will occur 10 percent of the way, the third blend 15 percent of the 
way, the fourth blend 20 percent of the way, and so on.) 

See the examples following step 7 for a description of how different values 
in these fields affect the blend that is created. 

7. Click OK. 

The blend you specified is created between the two objects. The entire set of 
blended objects (but not the original paths) is selected and grouped. In the 
painting order, the intermediate objects are between the original blend 
paths. Preview the blend to see approximately how it will look when 
printed. 
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Keeping the same number of steps but specifying different percentages for 
the first and last blends produces different effects. For example, still 
specifying 19 intermediate steps, if you specified 30 percent for the first 
blend and 60 percent for the last blend, the resultant blend would look like 
this. 

Or you could enter -25 and 125 in the First Blend and Last Blend fields, 
respectively. The first blend would occur 25 percent (of the distance between 
the two original paths) above the selected top path, and the last blend 
would occur 25 percent below the selected bottom path. The first and last 
blends would have the paint attributes of the top original path and the 
bottom original path, respectively. The resultant blend would look like this. 
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Repeating transformations 

Sometimes you may want to repeat the same transformation several times, 
especially when you are copying objects. The Transform Again command 
lets you repeat a move, scale, rotate, reflect, or shear operation as many 
times as you want. You must choose the command immediately after you 
perform the operation. This command does not work with the blend tool. 

To repeat a transformation: 

1. Choose Transform Again from the Arrange menu, or press 

The last transformation you performed is repeated. 

If you change your mind, you can choose Undo Transform Again from the 
Edit menu. That command is a toggle. Choosing it changes the menu 
command to Redo Transform Again, and choosing Redo Transform Again 
changes the command to Undo Transform Again. 



Chapter 12: Measuring and Constraining 

This chapter describes the three mechanisms by which you can precisely 
measure and align objects while you create your Adobe Illustrator 88 
program artwork. 

The first such mechanism is the measure tool. The second is a pair of 
rulers that you can calibrate. The third mechanism is the ability to rotate 
the x and y axes to any angle and then constrain drawing, movement, or 
transformation along the axes or at 45-degree angles relative to them. 

The program also allows you to set the distance that a selected object 
moves when you press a cursor (arrow) key and to specify whether or not 
objects should snap to the nearest anchor point. 

Using the measure tool 

The measure tool calculates the distance between any two points in the 
working area. Such a measurement might be useful before you create, 
move, or constrain an object. You indicate the points between which you 
want to measure by clicking. 

You can measure the distance between endpoints or anchor points on the 
same path or on different paths, or between any two locations in a blank 
area of your artwork. 

To measure the distance between two points: 

1. Click on the measure tool in the toolbox. 

The pointer changes to a dotted cross when you move it to the active 
window. 

2. Click on the two points whose distance you want to measure. 

If you are clicking on anchor points, they do not have to be selected. On 
the first click, the right arm of the dotted cross is extended. After the second 
click, the Measure dialog box appears. 

❑ Measure  

Distance: 183.172 pt  O 
Hngle: 31.61 0

Horizontal: 156 pt 
Vertical: 96 pt 



146 User Guide 

The distance between the two points appears after Distance. The angle of 
the line between the two points appears after Angle. The distance between 
the two points horizontally (along the x axis) and vertically (along the y 
axis) is also provided. All measurements except the angle are calculated in 
the unit of measure currently set in the Preferences dialog box. That unit is 
shown to the right of the Distance field. 

You may sometimes want to constrain a measurement. Constraining a 
measurement is useful when you want to measure between a point and a 
place on a curve, for example, between a block of text and a curved object 
that is near it. 

Holding down the Shift key never constrains the first of two measurement 
clicks. It sometimes constrains the second of the two clicks. If the second 
click is on an anchor point, the Shift key has no effect on the distance 
measured. If the second click is on a path which intersects a 45-degree axis, 
then the measurement is constrained to where the path intersects that axis. 
If the second click is not on a path, or is on a path that does not intersect 
any 45-degree axis, then the measurement is constrained to a point along 
the nearest 45-degree axis. 

3. Click OK. 

Rotating the x and y axes 

When you open a new document, the x and y axes are parallel to the sides 
of the document window. 

° x axis 
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You can leave the axes parallel, or you can rotate them by a specifying an 
angle of constraint so that they are no longer parallel to the sides of the 
window. 

axes rotated 30° 

~ 
0o

After you rotate the axes, any objects or operations to which you apply 
constraint are constrained at 45-degree multiples relative to the angle you 
specified. In addition, blocks of text and any objects you draw with the 
rectangle or oval tool are aligned with the current axes. 

The rotation of the axes also affects scaling, reflecting, and shearing. It does 
not affect rotating or blending. In addition, the angle reported in the 
Measure dialog box is relative to the rotation of the axes. 

NOTE: You must specify the constrain angle you want before you draw an 
object. If you select an object and then specify a constrain angle, the new 
angle will not apply to the selected object, only to newly created ones. 

The rotation of the axes does not affect drawing with either the freehand 
tool or the auto trace tool. 

The rotation of the axes is not saved with individual documents but in the 
Adobe Illustrator 88 Preferences file in your System Folder, and so it affects 
all documents opened in the future until you change it. 

To rotate the axes: 

In this example, the key was drawn with 
no constraint specified, and then rotated. 
A graph will be drawn after a 15-degree 
angle of constraint is specified. 
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1. Choose Preferences from the Edit menu, or press 

The Preferences dialog box appears. 

  Preferences  

® Snap to point 
® Preview and print patterns 
❑Transform pattern tiles 

OK 

Cancel 

Constrain angle: 0 ° —Ruler units 

Corner radius: 0 pt 
Q Centimeters 
Q Inches 

Cursor key distance: 1 pt Q Picas/Points 

Freehand tolerance: 2 pixels 

Hutotrace gap distance: 0 pixels 

Change Progressive Colors...) 

2. Enter the angle at which you want the axes rotated in the Constrain Angle 
field. 

If you enter a positive number (preceded by no sign), the axes are rotated 
counterclockwise. If you enter a negative number (preceded by a minus 
sign), the axes are rotated clockwise. 

3. Click OK. 

Blocks of text or any objects either created with the rectangle or oval tools 
or to which you apply constraint will be constrained along the rotated axes 
or their diagonals. 
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Using the rulers 

The Adobe Illustrator 88 program has two rulers, one across the bottom 
and one along the right side of the document window. 

,5 

Q] 
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When you open a document, the rulers 
are not visible, but you can display them 
at any time. You use the rulers to more 
accurately place and measure objects in 
your artwork. 

The placement of the ruler origin also affects the appearance of patterns. 
See "Changing the Ruler Origin," later in this chapter, and also 
"Understanding Pattern Tiling," in Chapter 14, "Using Patterns." 

To show the rulers: 

1. Choose Show Rulers from the View menu, or press -R. 

The rulers appear along the right side and the bottom of the window. This 
command is a toggle. The command on the View menu changes to Hide 
Rulers. 

When the rulers are visible, you can hide them. 

To hide the rulers: 

1. Choose Hide Rulers from the View menu, or press -R. 

The rulers disappear. The command on the View menu changes back to 
Show Rulers. 

Setting the unit of measure 

The preset unit of measure shown on the rulers is points and picas. You 
can change the unit of measure to either inches or centimeters. One inch 
equals 72 points, 6 picas, or 2.54 centimeters. 

The large tick marks indicate large units of measure (such as an inch) and 
the small tick marks indicate small units of measure (such as 1/8 inch). 
When you magnify or reduce the document with the zoom tool, the units 
of measure reflect the change in scale. 
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The unit of measure that you set for the ruler also applies in the dialog 
boxes that appear when you measure objects, move objects, and create 
patterns. It does not apply in the Type and Paint dialog boxes, which 
always measure size, spacing, leading, line width, and line dash in points. 

Changing the unit of measure does not visually affect artwork objects that 
you created with another unit in effect. The current unit of measure is 
always used when objects are created and edited, and is valid at all levels of 
magnification. 

The unit of measure setting is not saved with individual documents but in 
the Adobe Illustrator 88 Preferences file in your System Folder, and so it 
affects all documents opened in the future until you change it. 

To set the unit of measure: 

With the rulers either visible or invisible, 

1. Choose Preferences from the Edit menu, or press :•:-K 

The Preferences dialog box appears. 

2. In the Ruler Units options, click to specify the unit of measure you want 
the ruler to use. 

You have three choices: points/picas, inches, or centimeters. 

3. Click OK. 

The ruler changes to the unit of measure you specified. 

Changing the ruler origin 

You can set the origin (the point where 0 appears on each ruler) for the 
rulers at any time. The ruler origin is tied to the document, not the 
window. As you scroll and zoom around the document, the rulers adjust 
accordingly. 

When you open a document, the ruler origin is at the lower left corner of 
page 5. 

The position of the ruler origin affects the tiling of patterns. See 
"Understanding Pattern Tiling," in Chapter 14, "Using Patterns." 

I 
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To change the ruler origin: 

1. Move the pointer to the lower right corner of the rulers, where they intersect. 

2. Drag the pointer into the working area, and position it where you want 
the new ruler origin. 

As you drag, the pointer changes to a dotted cross, and crosshairs in the 
window and in the rulers indicate the changing ruler origin. 

3. Release the mouse button when the crosshairs in the rulers are where you 
want the 0 point to appear. 

The 0 point on each ruler appears at the new point of origin. The rulers 
themselves remain along the edges of the window. 

If you change your mind, you can immediately choose Undo Ruler from 
the Edit menu to return to the previous ruler origin. You can also choose 
Redo Ruler if you decide you want the rulers the way you set them. 

Setting Cursor Key Distance 

This option allows you to specify the distance that you want a selected 
object to move when you press one of the cursor (arrow) keys on your 
keyboard. When you press a cursor key, the currently selected object moves 
in the direction indicated by the arrow for the distance you set using this 
procedure. See "Moving Objects to a New Location" in Chapter 8, "Moving 
Objects." 

The distance that the object moves is measured in points, inches, or 
centimeters, depending on the unit of measure currently set in the 
Preferences dialog box. 

The cursor key distance is not saved with individual documents but in the 
Adobe Illustrator 88 Preferences file in your System Folder, and so it affects 
all documents opened in the future until you change it. 

To set Cursor Key Distance: 

1. Choose Preferences from the Edit menu, or press ::-K 

The Preferences dialog box appears. 

2. In the Cursor Key Distance field, enter a value for the distance you want 
selected objects to move. 

3. Click OK. 
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Setting Snap To Point 

The Snap To Point option allows you to snap the movement of objects to 
an anchor point whenever the pointer is within 2 pixels of that anchor 
point. An x appears in the Snap To Point checkbox in the Preferences 
dialog box when Snap To Point is turned on. 

The Snap To Point setting is not saved with individual documents but in 
the Adobe Illustrator 88 Preferences file in your System Folder, and so it 
affects all documents opened in the future until you change it. 

To set Snap To Point: 

1. Choose Preferences from the Edit menu, or press K 

The Preferences dialog box appears. 

2. Click in the Snap To Point checkbox to turn it either on or off. 

The option is preset to on. Snap To Point is a toggle. Clicking it turns it on 
when it's off and turns it off when it's on. 

3. Click OK. 
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Chapter 13: Painting 

This chapter describes how to paint your artwork. It gives you detailed 
information about painting paths and type and about the order in which 

they are painted. It tells you how to paint with patterns and how to 
transform patterns used to paint paths. This chapter also tells you how to 

see the currrent paint attributes and provides a description of each 
attribute and how to set it. In addition, it describes how to mask objects, 
how to set flatness, and how to annotate your artwork. 

With the Adobe Illustrator 88 program, you can paint the objects in your 
artwork with black, white, shades of gray, process or custom color, or 
patterns. If you have a black-and-white monitor, artwork painted with 
color will preview in shades of gray but will print in color on a color 
printer. Artwork painted with color and printed on a black-and-white 
printer will print more or less the way it previews in black-and-white. For 
complete information about painting and printing in color, see the Adobe 
Illustrator 88 Color Guide which accompanies this manual. 

The Adobe Illustrator 88 program treats all the objects it paints, including 
type characters, as paths. Whenever you draw a path it is automatically 

painted with the paint attributes that are currently set in the Paint dialog 
box. If you do not change the paint attributes, the preset attributes are 

used. See "Looking at the Current Paint Attributes," later in this chapter, 

for more information. 

Understanding painting order 

The Adobe Illustrator 88 program paints your artwork by applying 
successive layers of opaque paint to the objects. This layering model is also 

used when you preview and print your documents. 

The order in which the program applies layers of paint corresponds to the 
order in which objects are layered in the artwork. If you have not changed 

the order of objects in your artwork, the painting order corresponds to the 

order in which objects were created. The most recently created object is 

always frontmost and is painted last. Since the paint is opaque, if objects 

overlap, some objects may be partially or completely obscured by objects in 

front of them. 

Grouping objects affects painting order. It does not affect the order of 

individual objects in the group relative to one another, but it does change 

their painting order relative to other objects in the document, because the 

group is placed frontmost in the document. Copying or cutting and 

pasting also change the painting order of objects. See Chapter 9, "Copying 

Objects," for more information. 
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Previewing as you paint 

Painting paths 

To see a close approximation of how your artwork will be painted when it 
is printed, choose Preview Illustration from the View menu. You can do 
this at any time. 

It is a good idea to preview your artwork frequently as you work. In this 
way, you will see how your picture is affected by each new path you draw 
and paint. 

You can also keep two views of your artwork open at the same time, one 
showing the artwork only and one showing the preview image. However, 
the program will process slowly if you work this way. See Chapter 2, 
"Viewing Documents," for more information on previewing and on 
working with windows. 

Although new paths are automatically painted with the current paint 
attributes, you can select a path and change its paint attributes at any 
time. The new paint attributes will also be assigned to all new paths you 
create, until you change the attributes again. 

You will often want to set the paint attributes for each path right after you 
create it, while it is still selected. If you have a preview window open, you 
can immediately see how the painted path will look. Painting a path 
immediately after you draw it saves time if you are going to duplicate the 
path and use the same paint attributes for each copy. 

You can also draw several objects and then select and paint each one, or 
you can set the paint attributes for several paths before you create them. 
Setting the attributes beforehand can be useful in some instances, for 
example, if your artwork is a line drawing in which all of the lines will be 
black and will have the same line weight. 

Paths consisting of a single anchor point are not painted. 
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Filling and stroking paths 

When paths are painted, they may be filled, stroked, or both filled and 
stroked, with the paint attributes currently set in the Paint dialog box. The 
paths in your artwork can be filled and/or stroked with black, white, 
shades of gray, colors, or patterns. 

Filling a path paints the area that is enclosed by the path. Stroking a path 
paints a line that is centered on the path. 

If a path is both filled and stroked, it is filled first and then stroked. Paths 
must be stroked if you are going to specify a dashed line; otherwise the 
Dash Pattern option is not available. 

Filling and stroking affect closed and open paths differently, as the 
following examples illustrate. Open paths are filled as if the endpoints 
were connected by a straight line. 

n 

The program fills paths according to the Winding Number rule. Knowing 
this rule may be useful when trying to determine how a self-intersecting 
path will be filled. 
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Winding Number rule 

Pick a point in your artwork. To determine whether that point is inside a 
path (and therefore filled), draw a ray from the point across the path in 
any direction. Do not place the point directly on the path. 

Starting anywhere on the path and following around either clockwise or 
counterclockwise, count each place the path crosses the ray. Start with 0, 
add 1 each time the path crosses the ray from the left, and subtract 1 each 
time the path crosses the ray from the right. 

If your total is not 0, then the point is inside the path and the point is 
painted. If your total is 0, the point is outside the path and the point is not 
painted. 

By applying the Winding Number rule to the artwork shown on the left 
below, you will see why it is painted as it is in the preview on the right. 
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Filling and stroking type 

In the Adobe Illustrator 88 program, type objects are considered to be closed 
paths. Normally, blocks of type are filled and not stroked. If you want to 
create special effects, such as simulating a neon glow, you can set paint 
attributes to stroke the outlines of the type object instead of or in addition 
to filling it. 

Looking at the current paint attributes 

You can see the current paint attributes at any time by choosing Paint 
from the Style menu or by pressing :•:-I. The Paint dialog box appears, 

showing you the current settings. When you first open a new document, 
the following settings are displayed: 

❑   Paint  

—Fill 
Q None 
Q White 
Q€€i Black 
Q Process Color 
Q stcirn Colo 
C> €>EStif?r€1 

Black: 100 

❑ Ouerprint 

Stroke 
Q+ None 
o White 
Q Black 
Q Process Color 
o t: €aslam Calm 
o I>otta rn 

...[111411 p ttcrit .......................... ....... 

(s; Solid 13€ash ad: 

❑ Mask 

iiEtair}J~t:€. ..

I1i1 a€. .......... 

lirnii: 

Caps ............. 

Flatness: 

Note: 

p1 

x 

I OK 

Cancel )

0 piHels 

If an object is selected, the paint attributes for that particular object appear 
in the dialog box. If several objects are selected, only the paint attributes 
common to all of them are displayed, and nothing is displayed for the 
attributes that differ. 

Setting paint attributes 

You can set paint attributes either for existing selected paths or for paths 
you are about to create. Newly created paths are automatically painted 
with the current paint attributes set in the Paint dialog box. Paint 
attributes also apply to blocks of type. 

Only entire paths can be painted. Even if you select only part of a path 
and set paint attributes for it, the entire path to which the selected part 
belongs will be painted. 
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To set paint attributes: 

1. Select one or more paths or blocks of type whose paint attributes you want to 
change, or deselect all paths or type in your artwork if you want the attributes to 
apply only to new paths or type you create. 

2. Choose Paint from the Style menu, or press I 

The Paint dialog box appears. 

3. Change the settings for the paint attributes. 

See the sections on setting particular types of attributes later in this 
chapter. 

If several paths or blocks of type are selected, only the values for their 
common attributes are displayed. Settings for differing attributes are 
blank. If you enter new values for the blank settings, all paths or type are 
painted alike. If you do not enter new values for the blank settings, the 
paths or type retain their original individual attributes. 

4. Click OK. 

The Paint dialog box disappears. Clicking Cancel instead of OK voids any 
changes you have made. 

Currently selected paths and type, and new paths and type you create, are 
given the paint attributes that you just set. 

Setting fill attributes 

You can display the Paint dialog box to change the fill attributes at any 
time. To see the Paint dialog box, choose Paint from the Style menu, or 
press ::-I. 

The fill attributes determine whether or not a path is filled and, if it is 
filled, whether it is filled with black, white, gray, a process or custom color, 
or a pattern. 

How a path is filled, if at all, is independent of how it is stroked. 

Not filling a path 

If you do not want a path to be filled, display the Paint dialog box and 
click on None in the Fill options. Not filling a path makes it transparent 
in relation to paths in layers in back of them. 
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Filling a path 

To fill a path, display the Paint dialog box and click on the fill setting for 
the paint attribute you want. 

To fill with white, click on White. Painting with white is an effective way of 
"erasing" an area. 

Black is the preset fill option. The value in the Black field is automatically 
set to 100 (all black paint). 

To fill with a shade of gray, click on the Black option and type a number 
between 1 and 100 in the Black field. (Typing 0 will fill with all white 
paint; typing 100 will fill with all black paint.) 

To get an accurate reading of how shades of gray will look in your final 
artwork, make up a sample page containing shades of gray in 5 percent 
increments, from 0 percent to 100 percent black, and print it on the printer 
you will be using for final output. 

Filling with color 

You can fill with either process color or custom color. If you have a black-
and-white monitor, the artwork will preview in shades of gray but will 
print in color on a color printer. 

For detailed information about painting and printing with color, see the 
Adobe Illustrator 88 Color Guide which accompanies this manual. 

Filling with pattern 

See "Painting with Patterns," later in this chapter. 

Setting stroke and line attributes 

You can display the Paint dialog box to change stroke and line attributes at 
any time. To see the Paint dialog box, choose Paint from the Style menu, or 
press -I. 

Stroke attributes determine the shade of gray, the pattern, or the color that 
is used for stroking paths. Line attributes, which are available only if you 
stroke a path, control whether a path is solid or dashed, the dash pattern if 
it is dashed, the line weight, the miter limit, and the style of line joins and 
line caps. 

How a path is stroked, if at all, is independent of how it is filled. 
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Not stroking a path 

If you do not want a path to be stroked, display the Paint dialog box and 
click on None in the Stroke options. 

Stroking a path 

To stroke a path, display the Paint dialog box and click on the option you 
want in the Stroke options. 

To stroke with white, click on White. 

To stroke with black, click on the Black option. The Black field appears. 
The value in this field is automatically set to 100 (all black paint). 

To stroke with a shade of gray, click on the Black option and type a 
number between 1 and 100 in the Black field. (Typing 0 will stroke with all 
white paint; typing 100 will stroke with all black paint.) 

To get an accurate reading of how shades of gray will look in your final 
artwork, make up a sample page containing shades of gray in 5 percent 
increments, from 0 percent to 100 percent black, and print it on the printer 
you will be using for final output. 

Stroking with color 

You can stroke with either process color or custom color. If you have a 
black-and-white monitor, the artwork will preview in shades of gray but 
will print in color on a color printer. 

For detailed information about painting and printing with color, see the 
Adobe Illustrator 88 Color Guide, which accompanies this manual. 

Stroking with pattern 

See "Painting with Patterns," later in this chapter. 

Setting the line weight 

The line weight determines the thickness of the stroke, in points. 

To specify a line weight, click in the Weight field. Type in the line weight 
you want, in points. 

To get an accurate reading of how line weights will look in your final 
artwork, make up a sample page containing a set of line weights and print 
it on the printer you will be using for final output. Hairlines thinner than 
0.25 point may not reproduce correctly when used in camera-ready artwork. 
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CAUTION: Be careful when stroking paths to simulate shading or to 
create regular patterns. The results are device dependent when you choose 
line weights that approach or become smaller than the size of the device 
pixel. 

For example, the thinnest line you can print on a LaserWriter is thicker, 
and darker, than the thinnest line possible in Linotronic output. As a 
result, artwork that uses closely spaced lines to simulate shading produces 
a darker image when printed on the LaserWriter than it does on a 
Linotype. Use blending to simulate shading. See "Using the Blend Tool" in 
Chapter 11, "Transforming Objects." 

Setting the line cap style 

The line cap style affects the appearance of the endpoints of open paths 
and the drawn ends of dashed lines. 

Click on the line cap style you want in the Caps options to specify it. 

You have three line cap styles to choose from, as described below. 

■ Butt cap 

i Round cap 

■ Projecting cap 

The line has squared-off ends that are 
perpendicular to the path. The cap does 
not extend beyond the end of the path. 

The line ends in a semicircular cap. The 
diameter of the cap is equal to the width 
of the line. 

The line has square ends that extend half 
of the line width beyond the end of the 
line. 
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' CAUTION: If you specify a round or projecting cap with a dashed line 
style, the line caps will spill over into the spaces between the dashes. 

Setting the line join style 

The line join style determines the appearance of the corners of stroked 
paths. It has no effect at the points where stroked paths intersect. 

Click on the line join style you want in the Joins options to specify it. 

You have three line join styles to choose from, as described below. 

■ Miter join 

■ Round join 

v~v A 
■ Bevel join 

The edges of two converging strokes are 
extended until they meet, as in a picture 
frame. When this option is selected, the 
Miter Limit option becomes available. See 
the next section, "Setting the Miter Limit." 

Corners are connected with a circular arc 
whose diameter is equal to the weight of 
the line. 

The straight lines that meet at the corner 
point are finished with butt caps, and the 
resulting notch is filled with a triangle, 
giving the corner a squared-off look. 

CAUTION: Avoid using round joins with butt caps. If an endpoint of an 
open path is less than half the line weight from the nearest corner, the 
circle that is used to make the join may overlap the butt cap. 
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Setting the miter limit 

You can set the miter limit only if you have specified a miter join; 
otherwise, the Miter Limit option is dimmed. 

When a mitered join is created by two lines that meet at a sharp angle, a 
long spike is formed that extends well beyond the intersection of the lines. 
By specifying a miter limit, you control when the program switches from 
a mitered (pointed) join to a beveled (squared-off) join. 

The miter limit is the maximum ratio of the spike length to the line 
weight at the join. It must be specified as a number greater than or equal 
to 1. The lower the miter limit value, the sooner bevel joins replace spiked 
ends. 

You can enter a value between 1 and 10. In the Adobe Illustrator 88 
program, the miter limit is preset to 4, which means that when the spike 
length reaches 4 times the line weight, the program switches from a miter 
join to a bevel join. A miter limit of 1 always causes a bevel join to be used. 

miter limit 2 
L 

V 
miter limit 4 

miter limit 10 
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Setting the dash pattern 

When the stroke attribute is White, Black, Process Color, or Custom Color, 
you can set the dash pattern to create either solid or dashed lines. You can 
paint dashed lines with patterns also, but this is not recommended. If the 
stroke attribute is set to None, the Dash Pattern option is dimmed. 

To create a dash pattern you specify the lengths of dashes and the gaps 
between them in the Dash Pattern fields. It isn't necessary to fill in all of 
the fields if you can establish your pattern in fewer than six fields, but you 
should specify an even number of fields (that is, one gap for each dash). 
Do not leave any blank fields within your dash pattern. 

The preset option is Solid. If a dashed pattern is currently set and you 
want to specify solid lines, click on Solid in the Dash Pattern option group. 

To set dashed lines: 

1. Click on Dashed in the Dash Pattern options. 

The dash and gap fields become available. 

2. Type the length of the first dash, in points, in the first dash field. 

3. Press the Tab key. 

4. Type the length of the first gap, in points, in the first gap field. 

5. Repeat steps 2 through 4 to complete the remaining fields. 

The dashed line pattern always starts again at the beginning of each path. 

—••—••—••—••—••— 632123 

515251 

9212 

44 

These dashed lines have butt caps. 
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These dashed lines have rounded caps. To create a dotted line, set the dash 
values low and the gap values high. For example, use a .1 point dash and 
a 4. point gap. 

1

.1 383.1 9! 

--• --• --• --• 6424.18 

33 

.1 4 

Using paint attributes from an existing object 

It is often convenient to apply paint attributes from one object to objects 
you're about to create. 

To use paint attributes from an existing object: 

1. Select the object whose paint attributes you want to use. 

2. Choose Paint from the Style menu, or press >:-I. 

The Paint dialog box appears. 

3. Click OK. 

The Paint dialog box disappears. 

4. Create the new objects in your artwork. 

The newly created objects will have the paint attributes of the object you 
selected in step 1. 

Painting with patterns 

You can fill and/or stroke paths, including type, with any existing pattern. 

When you fill or stroke a path with a pattern, you can also transform the 
pattern by moving, scaling, rotating, reflecting, or shearing it. See the next 
section, "Transforming Patterns," for more information. 

You can fill or stroke paths only with the patterns available for the 
currently open documents. For more information, see "Understanding 
Pattern Availability," in Chapter 14, "Using Patterns." 

I NOTE: You can paint dashed lines with patterns, but this is not 
recommended. 
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The display of the pattern in your artwork usually begins at the current 
ruler origin. If you want the pattern to begin at the top of the artwork, and 
the ruler origin is at the bottom, you must either move the ruler origin, or 
move the pattern. See "Changing the Ruler Origin," in Chapter 12, 
"Measuring and Constraining," and "Understanding Pattern Tiling" in 
Chapter 14, "Using Patterns." 

NOTE: Text that is either filled or stroked with a pattern cannot be 
previewed. 

To fill or stroke with a pattern: 

1. Select the path you want to fill or stroke. 

2. Choose Paint from the Style menu, or press I 

The Paint dialog box appears. 

3. Click on Pattern under either Fill or Stroke. 

A list of all available patterns appears. 

4. Select the name of the pattern you want to use. 

Paint 

Fill 
O None 
o White 
O Black 
O Process Color 
O Custom Color 
Q Pattern 

d~Qddd deQd 
d d d d 

bricks 
dewdrops 
dots°3 
granite 
graphic 1 
lo.o desi.n 
raindrop_ u 

Transform...]

Stroke 
o None -
Q White 
Q Black  
O Process Color 

O Custom Color 
o Pattern 

Black: 100 

❑ Overprint 

Dash pattern 
oQ Solid o Dashed:: 

❑ Mask 

Weight: 

Miter 
limit 

1 pt 

4 

—Caps —

o ~ Q( )
O I.—.I

Flatness: 

Note: 

0 

x 

OK 

Cancel 

Joins —
o 

o 
pixels 
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If you want to transform the pattern, go on to step 4 in the next section, 
"Transforming Patterns." If not, go on to step 5 below. 

5. Click OK. 

The path is filled or stroked with the 
pattern you selected. 

Transforming patterns 

You can transform patterns that fill or stroke paths by moving, scaling, 
rotating, reflecting, or shearing them. Transforming the pattern that fills 
or strokes a particular selected path does not change the definition of the 
original pattern as it appears on the pattern list and does not change the 
way the pattern appears in other paths in the same document or in 
different documents. 

In the following procedure, only the pattern is transformed, not the path 
that is filled or stroked with it. To transform the path, or the path and 
pattern together, see the procedures for using the transformation tools with 
dialog boxes in Chapter 11, "Transforming Objects." 

To transform a pattern: 

1. Select the path that is filled or stroked with the pattern you want 
to transform. 

2. Choose Paint from the Style menu, or press 

The Paint dialog box appears. 

3. Click on Pattern under either Fill or Stroke. 

A list of all available patterns appears. The name of the pattern filling or 
stroking the currently selected path is selected. 
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4. Click Transform. 

The Transform Pattern Style dialog box appears. It contains dialog boxes 
for all the transformation tools (except the blend tool). 

5. Fill in one or more dialog boxes with the values that will produce the 
transformation you want. 

   Transform Pattern Style  

—Moue 

Distance: 

Direction: 
O Horizontal 
O Vertical 
Q Angled: 

25 

-180 

pt 

° 

Rotate angle: -15 

—Reflect across 
Q None 
O Horizontal 
O Vertical 
O Angled: 

° 

Scale 

Q Uniform 

Q Non-Uniform 

tJ£rl'irarstttl: 

1381'tl£ 3l{: 

50 

—Shear  

Angle: ° 

Arris: 
Q Horizontal 
O Vertical 
O Angled: 

25 

OK )) 

Cancel 

If you need help, see Chapter 11, "Transforming Objects," for a description 
of how to fill in the dialog box for each transformation tool. 

6. Click OK. 

The fill or stroke pattern is transformed according to the values you 
specified. The transformations occur in this order: move, scale, rotate, 
reflect, and shear. The program uses this order regardless of the order in 
which you entered the transformation values. 
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You can create an object and indicate in the Paint dialog box that you want 

to use it as a masking object. The boundary of the masking object defines 

the boundary for all objects that overlap it and that are in front of it in the 

painting order. Only those objects or portions of objects that fall within the 

boundary of the masking object are previewed or printed. Objects placed in 

back of the masking object are not masked. 

Masking is similar to using a stencil, as you do, for example, when you 

screen-print or airbrush. You lay down a stencil or some other opaque 

mask and then apply paint or dye to the exposed area, that is, the area 

within the boundaries of the stencil. When you use a stencil, whatever is in 

back of the stencil is affected by it. However, in the Adobe Illustrator 88 

program, whatever is in front of the masking object (the stencil) is affected. 

Grouping the masking object and the masked objects completes the 

masking procedure, and turns masking off for subsequently created objects 

until you turn it on again. You can mask as many times as you want in 

any document, but each prior masking object and the objects it masks 

must be grouped before the mask option can be turned on again. 

Previewing the grouped mask shows you how it will look when it is 

printed. 

preview 

1 NOTE: You cannot preview text used as a mask. 
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A masking object should consist of a single object, and only one masking 
object should be used for any set of masked objects. You can mask a 
blended object, but you cannot use a blend as a masking object. Once you 
create the masking object, you can draw objects in front of it, move already 
existing objects in front of it, or do both. Or, if you want to mask existing 
artwork, you can move the masking object behind the objects you want to 
mask. 

You can mask an already masked group, but only with a single masking 
object. In other words, you can place one masking object in back of an 
already masked group so that the masked group will be masked again. 

IMPORTANT: Rectangles and ovals must be ungrouped before they can be 
used as masking objects, and the anchor point in the center must be 
deleted. 

To mask objects: 

1. Draw or select the shape you want to use as a masking object. 

Be sure it is selected and ungrouped. 

U 

L 

I 

I 
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2. Choose Paint from the Style menu, or press X-I. 

3. Click in the Mask checkbox to specify that the currently selected object is to 
be used as a mask. 

An x appears in the checkbox. The preset option is off (blank). 

4. Set the paint attributes for the masking object, and click OK. 

5. Choose Preview Illustration from the View menu, or press >:-y. 

Check to see if the masking object looks the way you want. Then choose 
Artwork Only from the View menu. If necessary, display the Paint dialog 

box and change its paint attributes. 

6. Draw or move one or more objects in front of the masking object. 

In this example, a leaf is masking a blend 
of rectangles. Alternatively, you could use 
the Send To Back command to place the 
leaf in back of the objects to be masked. In 
either case, be sure to preview your 
artwork. 

7. Paint the objects to be masked, if they are not already painted. 

8. Select the masking object and all the objects it masks. 

9. Choose Group from the Arrange menu, or press :•:-G. 

This groups the masking object and all the objects it masks, completing 

the masking procedure. 

Previewing the masked group shows you how it will look when it is 
printed. 
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Setting flatness 

The flatness setting determines how curved segments look when you 
preview and print them. The value in the Flatness field of the Paint dialog 
box applies to both stroked and filled paths but does not apply to blocks of 
type. 

Usually, you do not need to change the flatness value. Change the flatness 
only to avoid or correct a PostScript language limitcheck error, as explained 
below. 

The Adobe Illustrator 88 program creates curved segments by linking a 
series of straight line segments. The flatness setting controls how closely 
the straight line segments approximate the curve. The smaller the flatness 
value, the greater the number of straight lines used and the more accurate 
the curve. 

Using more straight lines also uses more program memory, however, 
which causes the program to operate more slowly. If you draw a very long 
curved path, you may receive a limitcheck error message, telling you that 
the program cannot handle that long a path. In some cases, no message 
will appear, but your artwork will not print. To avoid or correct the 
limitcheck, you can either draw shorter paths (or split existing long ones), 
or you can change the flatness setting. 

You see the effect of the flatness setting only when you preview or print; 
the artwork image on the screen is not affected. 

Since printers vary in their resolution, flatness settings are device-
dependent. A flatness setting that will be effective on one printer, for 
example, a laser printer, may not be adequate for another printer, for 
example, a Linotype printer. 

To set the flatness: 

1. Select the object whose flatness you want to change. 

2. Choose Paint from the Style menu, or press >:-I. 

The Paint dialog box appears. 
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3. Type a value in the Flatness field. 

The preset value is 0. You can set the flatness to be between 0 and 100. The 
screen or printer you are using measures flatness in terms of its own 
display units (pixels.) When flatness is set to 0, the screen preview image 
uses a flatness setting of 1, and the printer uses its own preset value. 

Annotating objects 

In the previous illustration, the flatness setting for the leaf on the left was 
increased, resulting in the leaf on the right. 

The Note field in the Paint dialog box lets you enter an annotation for an 
artwork object. Annotated objects are useful in applications that read the 
PostScript language output created by the Adobe Illustrator 88 program 
when either the application or a programmer wants to locate particular 
objects in a drawing. 

To annotate an object: 

1. Select the object you want to annotate. 

2. Choose Paint from the Style menu, or press 

The Paint dialog box appears. 

3. Type your annotation in the Note field. 

You can enter up to 254 characters. 

4. Click OK. 

The annotation is associated with the object. 

When you save the artwork, the annotation is written as a %%Note 
comment in the PostScript language program that corresponds to the 
artwork. 
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Using keyboard search 

Whenever you open the Custom Color, Paint, Type, or Pattern dialog 
boxes, the names of colors, fonts, or patterns are listed alphabetically to 
make it easy for you to find the one you want. To make it even easier, you 
can use the built-in keyboard search capability to automatically search the 
lists for a name. Before you can start the search, you must first click in the 
scroll bar or on any name in the list. There must be no blinking insertion 
point in any editable field of the Paint dialog box. 

To search, type one or more consecutive letters or numbers that are unique 
to the name you are searching for. The program will search the list from 
top to bottom. The first instance of a name containing the letters you typed 
will be selected. 

Keyboard search is case-sensitive. You must type upper- and lower-case 
letters just as they appear in the on-screen name. Before you type, you 
must click once on any name in the list or in the list's scroll bar. If you 
pause for more than one second, the search will start again at the top of 
the list, looking for the last letter you typed. 

Suppose that your list consisted of the six pattern names shown below. To 
search for dewdrops, type dew. If you typed only d, the first name 
containing the letter d would have been selected. In that case, you could 
immediately type ew and dewdrops would then be selected, since it is the 
only name containing all three letters. 

o None rte,

o White ~ Q 

o Black 
L J 

o Process Color 
o Custom Color 
Q Pattern 

dots °3 
graphic 1 
logo design 
raindro•s 

Stroke 
o. None 
o White 
o Black 
o Process Color 
o Custom Color 
o Pattern 

Paint 

~, Solid
t!S 1 3E1 tt. r1t ........................ . ... 

❑ Mask 
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...................... 

IEt 
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This chapter describes how to create, paste, redefine, rename, delete, and 
preview patterns. It also discusses pattern tiling and pattern availability. 

You can create your own unique patterns using any of the Adobe 
Illustrator 88 program tools. You can either create a pattern from scratch 
or use existing artwork as a pattern. The pattern can be simple or complex 
and can be painted with any of the paint attributes in the Paint dialog 
box. 

Once the pattern is created, you can use it in two ways. You can 

■ Fill or stroke paths or text in one or more open artwork documents with the 

pattern 

■ Paste a copy of the pattern's definition into any open document 

If you paint a path with a pattern, you can transform just the path, just 
the pattern, or both the pattern and the path. For information about 
painting with patterns and transforming patterns, see Chapter 13, 
"Painting." 

If you paste a copy of the pattern into an open document, the program 
considers it a set of objects, not a pattern. You can treat the copy of the 
pattern just as you would any other object you copied into your document. 

The more complex the patterns you use are, and the more complex the 
shapes filled by the patterns, the longer they take to print. 

Creating patterns 

You can create patterns from scratch with any of the tools in the Adobe 
Illustrator 88 program. In addition, existing artwork can be used in a 
pattern. 

When you create a pattern, you automatically give it a definition, that is, 
you define exactly what its components are. You define a pattern by 
drawing or placing artwork inside a rectangle. A rectangle containing a 
pattern is known as a pattern tile. The rectangle is actually a masking 
object that masks the contents of the pattern. 
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The placement of the rectangle around the pattern affects the tiling of the 
pattern. Be sure to read "Understanding Pattern Tiling," later in this 
chapter, for more information. 

To create a pattern: 

1. Open an Adobe Illustrator 88 document. 

If you want to draw your pattern from scratch, you might want to open a 
new document. If you plan to use existing as a pattern, open the document 
that contains that artwork. 

2. Draw a rectangle. 

If you are using existing artwork, draw the 
rectangle around the part of it that you 
want to use as the pattern. Consider how 
the pattern will be tiled. If you are drawing 
from scratch, draw any size rectangle you 
want. You can use either the rectangle tool 
or the pen tool to draw the rectangle. 

If you use the rectangle tool, the corner radius must be 0. If you use the 
pen tool, the angle of constraint set in the Preferences dialog box must be 0. 

The rectangle can be as large as you want. You can draw a large rectangle 
to work in and then scale it down before you create the pattern. This is 
useful if you are creating a detailed pattern. 

IMPORTANT: The rectangle must be the backmost object of the pattern. 
Draw it first and draw or place other objects in front of it, or use the 
Send To Back command to place the rectangle in the back. 

3. Paint the rectangle (if it is not already painted). 

Whatever fill attribute, if any, you use to paint the rectangle becomes the 
background of the pattern. You can specify no fill, or you can fill it with 
black, white, a shade of gray, or a process or custom color. 

If you want the boundary of the pattern tiles to remain invisible, do not 
stroke the rectangle. If you stroke it, the boundaries of the tiles will show 
up as part of the pattern. 

I 
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4. Draw a pattern inside the rectangle (if you did not draw a rectangle 
around existing artwork). 

6 6 4 4 
4 4 

6 6 6 

You can also draw a pattern outside the 
rectangle and move the rectangle around 
it. Just be sure that the rectangle remains 
the backmost object. 

I IMPORTANT: The pattern may not contain placed images, masked 
groups, or objects painted with patterns. 

5. Select the rectangle and its contents. 

Use the selection technique that best suits your situation: Drag the 
marquee around the entire rectangle, choose Select All from the Edit menu, 
or click and use the Shift key to select the rectangle and all the objects in 
it. 

6. Choose Pattern from the Style menu. 

The Pattern dialog box appears. 

❑  Pattern  

4 

Q 

€:It<tl'I£1£3 3'3ftCi'E£3 t£t: 

OK 

( Cancel

( New
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7. Click New. 

The name New Pattern followed by a number appears both in the pattern 
list and in the Change Name To field. It is selected in both places. A 
previewed image of the patternis scaled to fit into a box at the bottom right 
of the dialog box. 
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8. Enter a name for the pattern you created. 

The name can be up to 31 characters in length. The name you enter 
automatically appears in the Change Name To field as well as in the 
pattern list. 

Pattern  

Pasting patterns 

Change name to: 

raindrops 

~(  OK 

( Cancel 

N €? €.€J 

lielete 

Paste 

Select RII Unused 

If a pattern with the same name already exists, a message will ask you to 
choose a different name. 

The pattern is now created and named. It can be used to paint paths or 
type in an open document or treated as an object when pasted into an 
open document. 

9. Click OK to close the dialog box and return to your artwork. 

After you have created a pattern, you can paste a copy of it into any open 
artwork document. The program then considers the copy of the pattern to 
be an object, not a pattern. You can work with the copy of the pattern just 
as you would any other object in your document. 

Pasting patterns is useful when you want to change the appearance of the 
copy or create a new pattern similar to the original. 

To paste a pattern: 

1. Open the document into which you want to paste a copy of the pattern. 

2. Choose Pattern from the Style menu. 
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The Pattern dialog box appears, with a list of all the patterns contained in 
that document. 

Pattern   

basketweave 
bricks 
dewdrops 
dots °3 
granite 
graphic 1 
logo design 
raindrops 

4 

TlflrCle t£1: 

OK 

( Cancel ) 

N £? €k3 

(Select RII Unused) 

NOTE: If more than one document is open, the patterns contained in all 
open documents are listed, and are available for pasting. For more 
information, see "Understanding Pattern Availability," later in this 
chapter. 

3. Click on the name of the pattern you want to use. 

4. Click Paste. 

5. Click OK to close the dialog box and return to your artwork. 

A copy of the pattern is pasted in the center of the active window of the 
open document. 

You can adjust, transform, or paint the copy of the pattern. 

If you change the copy of the pattern, you are not changing the pattern 
itself, but you are changing the object you pasted in. 

If you want to define the new object as a new pattern, you must select all of 
it and follow the pattern creation procedure described in the previous 
section, "Creating Patterns." 

Changing the copy of the pattern does not change the definition of the 
original pattern. To redefine the original pattern, see the next section, 
"Redefining Patterns." 
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Redefining patterns 

After you have created a pattern, you can redefine it, that is, you can 
change the rectangle or its contents while keeping the original pattern 
name. Any existing objects that are painted with that pattern are 
automatically painted with the new definition rather than the old 
definition. 

IMPORTANT: When you redefine a pattern, it is redefined in all open 
documents in which it is contained. If you want to keep different 
definitions of the same pattern name in several documents, close any 
documents that you do not want to be affected. 

To redefine a pattern: 

1. Open the document containing the pattern you want to redefine. 

If you want the pattern's new definition to be similar to the old definition, 
follow steps 2 through 5 in the previous section,"Pasting in Patterns." If 
the new definition will be radically different, you may prefer to start from 
scratch, as described in "Creating Patterns," earlier in this chapter. 

2. Select the rectangle and its contents. 

3. Choose Pattern from the Style menu. 

4. Select the name of the pattern to be redefined. 

5. Click OK. 

Clicking OK saves the new pattern definition with the original pattern 
name. If you had clicked New instead of OK, you would have created a new 
pattern with the name New Pattern, which you could change. 

If you started by pasting the original definition, and you do not want the 
copy of the pattern to appear in your artwork anymore, delete it by 
choosing Cut or Clear from the Edit menu. 

Renaming patterns 

You can rename any pattern you have created. You may want to rename a 
pattern to avoid conflicts between patterns used in the same document. 

For example, you might have previously created a pattern of small dots 
which you simply named "Dots." If you now want to call another pattern 
you have just created "Dots," you could rename the first pattern "Small 
Dots" and thus avoid any confusion between the two names. 

Renaming a pattern does not change its definition. Any existing objects 
which were painted with the pattern are still painted with it, under the 
new name. 
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To rename a pattern: 

1. Open the document containing the pattern you want to rename. 

2. Choose Pattern from the Style menu. 

The Pattern dialog box appears, with a list of all the patterns contained in 
that document. 

3. Click on the name of the pattern you want to rename. 

4. Enter the new name for the pattern in the Change Name To field. 

The new name must be unique. It can be up to 31 characters in length. 
The name you enter automatically appears in the Change Name To field 
as well as in the pattern list. 

The pattern now has a new name but retains its original definition. 

5. Click OK to close the dialog box and return to your artwork. 

Deleting patterns 

You can delete any patterns that you have never used or that you will no 
longer be using. Deleting a pattern removes the pattern from all open 
documents, making the pattern unavailable. If the same pattern appears 
in other closed documents, it will still be contained those documents. 

You can also use a shortcut to delete all (or most) of the patterns not being 
used in currently open documents. 

Use the following procedure to delete one or more patterns. 

To delete a pattern: 

1. Open one or more Adobe Illustrator 88 artwork documents. 

2. Choose Pattern from the Style menu. 

The Pattern dialog box appears, containing a list of all the patterns 
contained in the open documents. 

3. Click on the name of the pattern you want to delete. 

If you want to delete more than one, hold down the Shift key to select 
additional pattern names. 

4. Click Delete. 

The name of the selected pattern is removed from the pattern list. 

5. Click OK to close the dialog box and return to your artwork. 
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If you change your mind, you can choose Undo Delete from the Edit menu 
to undo the deletion immediately after closing the dialog box. 

Any existing object painted with the deleted pattern will now be painted 
with 100 percent black instead. 

To delete all unused patterns: 

1. Open one or more Adobe Illustrator 88 artwork documents. 

2. Choose Pattern from the Style menu. 

The Pattern dialog box appears, containing a list of all the patterns you 
have created. 

3. Click Select All Unused. 

The program selects (highlights in the pattern list) the names of all 
patterns that are contained in the documents but are currently not being 
used. If you want to keep some of the selected patterns, perhaps because 
you intend to use them soon, hold down the Shift key to deselect the 
patterns you want to keep. 

4. Click Delete. 

The names of all the selected patterns are removed from the pattern list. 

5. Click OK to close the dialog box and return to your artwork. 

Previewing patterns 

The Preview and Print Patterns checkbox in the Preferences dialog box lets 
you choose whether or not patterns used in your artwork appear in both 
the previewed and printed image that you see when you choose the Preview 
Illustration command. Previewed images of the pattern also appear in the 
Paint and Pattern dialog boxes when they are open and you click on the 
Pattern option. 

The preset option for the Preview and Print Patterns checkbox is on. When 
the option is off, paths painted with a pattern will preview in the 
background color (or shade of black and white) of the pattern, and the 
previewing and printing processes are faster. 

U 

U 
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Understanding pattern tiling 

Patterns are laid out in your artwork on one or more pattern tiles. The tiles 
themselves are not visible; only the patterns are. You determine the size of 
each pattern tile when you draw the rectangle that forms the boundary for 
the pattern. A pattern tile can be as large as your entire artwork. Usually, 
though, you create smaller tiles that are repeated in columns and rows 
across your artwork. 

The lower right corner of the first pattern tile in your artwork always 
starts at the ruler origin of your artwork, unless the pattern has been 
moved. Be sure to adjust the ruler origin so that the pattern starts where 
you want it to. See "Changing the Ruler Origin" in Chapter 12, 
"Measuring and Constraining," for more information. 

Laying out pattern tiles 

Since pattern tiles lie adjacent to one another in your artwork, you must 
plan the layout of your pattern when you either draw it in the bounding 
rectangle or place the rectangle around it. In particular, you must think 
about how the edges of tiles will interact. 

The following example shows two ways of laying out a simple pattern, 
and the results of both layouts when tiled. When the tiling rectangle is 
centered on the diamonds, the pattern tiles as previewed on the right. 
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If the tiling rectangle were moved to the left, the pattern would tile in a 
different way. 

Moving pattern tiles 

In both the Move dialog box and the Preferences dialog box, you are given 
the option to move the pattern tiles as well as the object. If you move the 
pattern tiles when you move the object, the pattern within the object 
remains the same. 

U 

U 

U 
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You can also choose to move the object without moving the pattern. In 

that case, the pattern will appear somewhat differently on the object. 

If you want to move only the pattern and not the object, you must use the 

Transform Pattern Style dialog box. See "Transforming Patterns," in 

Chapter 13, "Painting," for more information. 

Transforming pattern tiles 

In all the transformation dialog boxes and in the Preferences dialog box, 

you are given the option to transform the pattern tiles for a patterned 

object as well as the object itself. Transforming the pattern transforms all 

the pattern tiles in that object's paint layer in exactly the same way as the 

object is transformed. 

If you want to transform only the pattern and not the object, you must use 

the Transform Pattern Style dialog box. See "Transforming Patterns," in 

Chapter 13, "Painting," for more information. 
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Understanding pattern availability 

In the Adobe Illustrator 88 program, every pattern is contained in both the 
document in which it was created and in every document in which the 
pattern is used to paint a path. 

In the Paint and Pattern dialog boxes, a list of all the patterns contained in 
the currently open documents is displayed. If more than one document is 
open, the list will include the patterns contained in all open documents. 
Any pattern on the list can be used in any of the open documents. Any 
pattern used in an object on the Clipboard is also included in the pattern 
list and is available for use. 

In order to use a pattern in a document when that pattern is not already 
contained in the document, you need to open another document in which 
the pattern is contained. 

For example, suppose that you wanted to use a pattern in document A that 
is currently contained in document B. You must have both document A 
and document B open. When you open the Paint dialog box in document 
A, all the patterns contained in both documents are listed and are 
available. You can then select the document B pattern you want from the 
list and use it in document A. 

To eliminate some searching for patterns, you can create a document 
containing all of the patterns that you will probably be using over and 
over. That way, you can open only that one document and have many of 
the patterns you need available. 

Patterns remain in documents until you delete them, even if all the objects 
which were once painted with them are no longer in the document. For 
more information, see "Deleting Patterns," earlier in this chapter. 
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This chapter describes how documents are tiled for printing, and how you 

can adjust the tiling. It also tells you how to set up pages for and print 

with the Apple LaserWriter or Image Writer. 

As you design your artwork, you may want to check your progress 

occasionally by printing the intermediate stages. Of course, you will also 

print the final version of your artwork. You can print Adobe Illustrator 88 

artwork on any printer that supports the Adobe PostScript page-

description language, such as the Apple LaserWriter. You can also print 

your work on an Apple ImageWriter, but the quality will not be high. 

In addition, you can print your artwork on any color printer that uses a 

PostScript interpreter. The Adobe Separator utility provided with the 

program allows you to make a set of color-separation negatives of your 

artwork and send them to a professional printshop to be printed. For 

complete information about printing in color, see the Adobe Illustrator 88 

Color Guide which accompanies this manual. 

Understanding tiling 

The Adobe Illustrator 88 working area is a square with 1008 points, or 14 

inches, on each side. These dimensions do not match the paper sizes 

commonly used with printers. 

When you print a document, the program subdivides the working area 

into rectangles that correspond to the paper size you are using in your 

printer. This subdivision is called tiling. 
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NOTE: If the tiling lines do not appear, it means that a printer has not 
been selected yet. Choose Chooser from the Apple menu and select a 
printer. 

The tiling of the document is defined on your screen as a grid of dotted 
lines. Think of the boundaries of the grid as being the boundaries of paper 
"tiles" that are adjacent to one another, similar to ceramic tiles on a wall. 

Sections of the tiled grid are visible as you scroll around in an open 
document; the entire grid is visible when you choose Fit In Window from 
the View menu. The preset options specify using U.S. letter size paper and 
printing at 100 percent. When you use these preset values, the document is 
tiled into nine pages numbered from left to right and from top to bottom, 
starting with 1. You can print all of the pages, or specify particular pages, 
when you choose the Print command. The page numbers for pages 2, 3, 5, 
and 6 appear for your reference only; the page numbers themselves are 
never printed. 

If you choose Page Setup from the File menu to change the page 
orientation or to change the reduction or enlargement, the tiling and the 
page grid are adjusted accordingly and the changes are displayed in all 
views of the active document. 

The page grid is never printed; it simply indicates the boundary between 
the printable surfaces of each sheet of paper. 

NOTE: On some printers, the printable surface is slightly smaller than 
the actual paper size. For example, the printable surface for 8.5-inch by 11-
inch U.S. letter paper on the Apple LaserWriter is actually 7.68 by 10.16 
inches. 

Tiling documents into pages 

When you plan your drawing and as you work, take into account the way 
in which your drawing relates to the boundaries of the page grid and to 
the total dimensions of the working area. Most of the time, your entire 
drawing will be within the boundaries of page 5. If your drawing spills 
over onto any other page, for example, page 6, part of your drawing will 
be printed on a separate sheet of paper that corresponds to page 6, even if 
you specified printing only from page 5 to page 5. 

You can easily avoid this situation by adjusting the page grid as described 
in the next section. Another alternative is to either specify a reduction or 
change the page orientation when you set up pages, so that all of the 
artwork will fit on one page. 
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NOTE: As illustrated below, the artwork itself has an invisible bounding box 
around it. The program may print blank pages if the document is tiled in 
such a way that the bounding box of the artwork intersects pages that do 
not contain any artwork. If any direction points extend into pages that do 
not contain any artwork, blank pages will be printed, since the bounding 
box includes the direction points. 
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Adjusting the page grid 

One way you can control how your artwork is tiled into pages is by 
adjusting the placement of the page grid on the working area, as described 
in the procedure that follows. You may find it easier to choose Fit In 
Window from the View menu first, so that you can see the entire 
document while you adjust the page grid. 

To adjust the page grid: 

1. Click on the page tool in the toolbox. 

The pointer becomes a dotted cross when you move it to the active window. 

2. Drag the dotted cross around on the drawing area. 

As you drag, the program displays a dotted rectangle, which represents the 
printable surface of one printed page. 

3. Release the mouse button when the page grid is where you want it. 

The program redraws the new placement of the page grid on all views of 
the active document. 
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Setting up pages 

If you change your mind, you can immediately choose Undo Page from the 
Edit menu to undo the new placement of the page grid. 

Before you print, you should specify how you want the pages to be set up. 
Page setup controls the printing of all the pages in the document. 

The changes you make to the page setup affect only the current document, 
and the page-setup information you specify is saved along with your 
document. 

When you open a document, the Adobe Illustrator 88 program attempts to 
use the page-setup parameters that were saved with the document. The 
program can do so only if the printer currently chosen with the Chooser is 
the same printer that was specified when the document was saved. Be sure 
to choose the same printer if it is not already chosen. If the printers do not 
match, the program uses the page-setup parameters from the current 
printer's resource file, rather than those from the open document. 

Since page setup affects the tiling of the document, you sometimes may 
want to specify how pages are set up before you start drawing, so that the 
page tiling, and consequently the working area, more accurately reflects 
the dimensions of the printed page. Be sure to select the printer you will be 
using in the Chooser first. 

To set up the page for the Apple LaserWriter: 

1. Choose Page Setup from the File menu. 

The LaserWriter Page Setup dialog box appears. 

LaserWriter Page Setup OK 

Paper: Q US Letter 0 114 Letter Reduce or 
100 

85 Letter Enlarge: Cancel 
0 US Legal Q 

Orientation Printer Effects: Options 

® Font Substitution? Help 
© Smoothing? 

Faster Bitmap Printing? 
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2. Click on the paper size you are using. 

The choices are 

■ US Letter 

■ US Legal 

■ A4 Letter (European) 

■ B5 Letter 

8 1/2" wide by 11" tall (preset choice) 

8 1/2" wide by 14" tall 

210mm wide by 29 7m tall 

176mm wide by 250mm tall 

3. Click on the page orientation you want. 

The preset page orientation is portrait, which is a vertical orientation. 
The other page orientation is landscape, which is a horizontal orientation. 

4. Specify any reduction or enlargement, as a percentage of the original size 
of the artwork. 

The preset option is 100 percent. Specifying 80 percent, for example, 
means that the final printed output will be reduced so that it is 20 percent 
smaller than the artwork's actual size. 

For the Apple LaserWriter, you can choose any value between 25 percent 
and 400 percent. 

5. Click OK. 

Clicking Cancel voids any changes you have made. 

Clicking Options brings up the Options dialog box. You can print Adobe 
Illustrator 88 documents using any of these options. However, when you 
are printing complex drawings, the results may be unpredictable. 

The program ignores the Smoothing printer effect. Font Substitution has 
no effect on the appearance of printed output. 

To set up the page for the Apple Image Writer: 

1. Choose Page Setup from the File menu. 

The ImageWriter Page Setup dialog box appears. 

Image Writer 
Paper: Q US Letter 

O US Legal 
O Computer Paper 

Orientation Special Effects: 

O R4 Letter 
O International Fanfold 

❑Tall Adjusted 
❑ 50 % Reduction 
❑ No Gaps Between Pages 

OK 

Cancel 
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Printing 

2. Click on the paper size you are using. 

The choices are 

■ US Letter 

■ US Legal 

■ Computer Paper 

■ A4 Letter (European) 

■ International Fanfold 

8 1/2" wide by 11" tall (preset choice) 

8 1/2" wide by 14" tall 

8 1/2" wide by 11" tall (fanfold) 

210mm wide by 297mm tall 

210mm wide by 29 7m tall 

3. Click on the page orientation you want. 

The preset page orientation is portrait, which is a vertical orientation. The 
other page orientation is landscape, which is a horizontal orientation. 

4. Click on Tall Adjusted so that it is turned on. 

This ensures that the proportions of your image are not distorted due to 
the fact that the Image Writer prints a different number of pixels per inch 
vertically than it does horizontally. 

5. Specify 50 percent reduction if you want it. 

6. Click OK. 

Clicking Cancel voids any changes you have made. 

Before you print any artwork on a LaserWriter or an ImageWriter, be sure 
to choose the printer you want with the Chooser on the Apple menu. Also 
be sure to connect the printer to your Macintosh with the Control Panel 
and to specify the settings you want in the Page Setup dialog box. 

To print with a LaserWriter: 

1. Choose Print from the File menu, or press 

The LaserWriter Print dialog box appears. 

LaserWriter 

Copies: Pages: ® nil 0 From: 

Cover Page: (. No Q First Page 0 Last Page 

Paper Source: ® Paper Cassette 0 Manual Feed 

To: 

OK 
J1 

Cancel 

Help 
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2. Enter the number of copies you want to print in the Copies field. 

The preset option is 1. 

3. Indicate which pages you want printed. 

The preset option is All. When All is chosen, the program prints any 
pages that intersect with the artwork's bounding box. If you want to print 
a particular page or range of pages, click on From and enter the beginning 
and ending page numbers to be printed in the appropriate fields. Usually, 
you will indicate that you want to print from page 5 to page 5. 

4. Indicate whether or not to print a cover page. 

The preset option is No. If you want the first page to be the cover page, 
click on First Page. If you want the last page to be the cover page, click on 
Last Page. 

5. Click on either Paper Cassette or Manual Feed to indicate the paper source. 

The preset option is Paper Cassette. 

6. Click OK to start printing. 

Click Cancel if you decide not to print and want to resume drawing. 
While the program establishes a connection to the LaserWriter and 
initializes it (if necessary), a dialog box with the message "Waiting to 
print... Press :•:-period to cancel" appears. 

After printing begins, the message changes to "Printing page n" where n is 
the number of the page being printed. 

To print with an Image Writer: 

1. Choose Print from the File menu, or press :•: P 

The ImageWriter Print dialog box appears. 

Image Writer 

quality: 
Page Range: 
Copies: 

Paper Feed: 

Q Best 

a 

All 
® Faster 

Q From: 

Automatic Q Hand Feed 

Q Draft 

To: 

OK ' 

Cancel 



194 User Guide 

2. Click on either Best or Faster in the Quality options. 

3. Indicate which pages you want printed. 

The preset option is All. When All is chosen, the program prints any 
pages that intersect with the artwork's bounding box. If you want to print 
a particular page or range of pages, click on From and enter the beginning 
and ending page numbers to be printed. Usually, you will indicate that 
you want to print from page 5 to page 5. 

4. Enter the number of copies you want to print in the Copies field. 

The preset option is 1. 

5. Click on either Automatic or Hand Feed to indicate the paper source. 

The preset option is Automatic. 

6. Click OK to start printing. 

Click Cancel if you decide not to print and want to resume drawing. 

After printing begins, the message changes to "Printing page n" where n is 
the number of the page being printed. 



Chapter 16: Working with Other Applications 

This chapter tells you how to place artwork from the Adobe Illustrator 88 
program into other applications, and how to place scanned images or 
images from other applications (saved in EPS format) into Adobe 
Illustrator 88 documents. It also describes how to convert MacDraw 
documents (saved in PICT format) to Adobe Illustrator 88 documents. 

Placing Adobe Illustrator 88 artwork into other applications 

You may sometimes want to place Adobe Illustrator 88 artwork into 
documents created with page composition software or other software. 

The application into which you place your artwork must accept the 
Aldus/Altsys/Adobe Encapsulated PostScript file format (EPS). To find out if 
it does, consult the manual for the program or contact the software 
developer. Applications that support this format display an image 
representative of your Adobe Illustrator 88 artwork on the screen for 
placement, scaling, and cropping, and they send appropriately 
transformed PostScript language code to the printer. 

To place Adobe Illustrator 88 artwork into another application: 

1. Save the Adobe Illustrator 88 document with either an Apple Macintosh or an 
IBM PC preview, whichever is appropriate. 

2. Open the document that is to receive the Adobe Illustrator 88 artwork. 

3. Follow the usual procedure in the other application for placing 
documents. 

See the user's manual for the other application if you need help. 

Placing EPS files 

You can use the Place EPS command to place elements of files saved in the 
EPS file format into an Adobe Illustrator 88 document, much as you would 
place an artwork image into a page layout program. 

Scanned images, as well as images created with applications such as 
Aldus FreehandTM, CricketDrawTM, ImageStudioTM, MacPerspectiveTM, 
Mac Publisher IITM, PageMaker®, Pixel PaintTM, Pro3DTM, or Super3DTM 
can be saved in the EPS file format and placed in your artwork. 

n 
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An image of the EPS element you place appears in a box in your Adobe 
Illustrator 88 artwork. You can move, scale, rotate, reflect, or shear the EPS 
image in the same way as you would any other Adobe Illustrator 88 object, 
but you cannot adjust any of its anchor points, segments, or paths, or use 
the Paint or Type commands. If you place a file containing text, the text 
cannot be edited. The image box always remains a parallelogram, even if 
you transform it. 

If the image contains color elements, it will print in color on a color 
printer, but will preview only in black and white, even on a color monitor. 
You can place as many EPS images as you want in an Adobe Illustrator 88 
document, but you can place only one image at a time. 

To place EPS files: 

1. Start the Adobe Illustrator 88 program. 

2. Open the document into which you want to place the EPS file. 

3. Choose Place EPS from the File menu. 

A dialog box appears, containing a list of all EPS files. 

4. Click on the name of the EPS file that you want to place. 

5. Click Open. 

You are returned to the active window of your artwork document. 
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An outlined box appears, with diagonal 
lines crossing from corner to corner. This 
box defines the EPS file's dimensions. 
The box is placed in the center of the 
active window, in front of all other 
artwork in your document, and it is 
selected. 

6. Move the box to its final position. 

When you preview your artwork, either the box will become gray or you 
will see a rough image of the EPS file you placed, depending on the 
application you used to create the image. 

In the following finished Adobe Illustrator 88 artwork, a placed EPS file 
containing an image of clouds was masked by the word "clouds." Other 
text and graphics were then added. 
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Saving artwork with placed EPS files 

Adobe Illustrator 88 artwork containing placed EPS format images cannot 

be completely re-created without the corresponding EPS files. Usually, you 

will have both files on the same disk, and the EPS format image will 
appear in your artwork both when you preview and when you print. If 
you do open an Adobe Illustrator 88 document without the necessary EPS 

files, you will see a white area on the screen where the EPS image had been 

placed. If you print the document, nothing will print in that spot. 

If you are going to use Adobe Illustrator 88 artwork containing placed EPS 

images with another application, or give your artwork file to someone else, 

you need to be sure to save the EPS file information with the Adobe 
Illustrator 88 file, as described in the procedure that follows. 

IMPORTANT: Be sure to keep copies of the EPS files that contain the 
placed images in the same folder as your Adobe Illustrator 88 artwork 
document so that the program can refer to them. Do not throw them out 

until you delete the placed image from your artwork. 

To save artwork with a placed EPS file: 

1. Open the Adobe Illustrator 88 artwork containing placed EPS images. 

2. Choose Save As from the File menu. 

The Save As dialog box appears. 

EPS Folder 

L. li' S f i 
I:  €'S irm<tg€x 

4 o HerdDisk20 

Eject 

Drive 
e~ 

Save illustration as: 

EPS Art 

Save

Cancel 

-Include preview for 
Q None Q Macintosh'" Q IBM PC® 

Include copy of placed Encapsulated 
❑ PostScript files for other applications 

❑ Save Adobe Illustrator 1.1 compatible file 
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3. Click in the Include Copy of Encapsulated PostScript Files for Other 
Applications checkbox. 

4. Click OK. 

The placed image and corresponding EPS file are saved with your Adobe 
Illustrator 88 artwork. 

Converting MacDraw files using DrawOver 

You can use the DrawOver application that is included with this program 
to convert MacDraw (version 1.9 or 1.9.5) files into Adobe Illustrator 88 
documents. 

The objects converted from MacDraw are rendered in Adobe Illustrator 88 
as follows: 

■ Straight line paths and curved paths are rendered accurately. 

■ Rectangles, squares, ovals, and circles are rendered accurately. 

■ Black, white, and shades of gray are rendered accurately. 

■ Lines drawn with the MacDraw freehand tool are rendered using vectors, so 
that there are many anchor points all along the lines. 

The converted file becomes a document that is compatible with both the 
Adobe Illustrator version 1.1 program and the Adobe Illustrator 88 
program. If you open it using the Adobe Illustrator 88 program, you can 
create blends with the blend tool and paint objects with custom color, 
process color, or patterns. 

To convert MacDraw files using DrawOver: 

DrawOver 1 .4 

1. Save the MacDraw document that you want to convert, specifying PICT format. 

Rename the MacDraw document, adding the extension .PICT. 

2. Quit MacDraw. 

3. Double-click on the DrawOver application. 
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The DrawOver dialog box appears, with a list of MacDraw documents 
saved in the PICT format. 

Please Select a PICT File: 

Pict Folder 

❑ PieChart t ® Oatulisk 

Eject , 

Urine 

Open 

Cancel 

4. Click on the name of the document you want to convert. 

5. Click Open. 

A box containing a preview image of the MacDraw artwork appears. 

Preview of "PieChart" 

Cancel OK 

6. Click OK if the box displays the artwork you want to convert. 

Otherwise, click Cancel and select another MacDraw PICT file. 
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PieChart.ART 

After you click OK, the DrawOver dialog box reappears, displaying the 
name of the MacDraw PICT file with the extension .ART. 

Pict Folder 

4 

b 

PostScript Text File: 

PieCllart.RRT 

I DataDisk 

Eject 

Drlue

Saue 

Cancel 

7. Click Save. 
A message appears informing you of the progress of the conversion from 
PICT to the PostScript language and allowing you to cancel the process. 
When conversion is complete, the DrawOver dialog box appears again. 

8. Click Cancel. 

The converted file is now an Adobe Illustrator 88 document and appears 
on the desktop under its new name. 

To open a converted MacDraw document: 

1. Double-click on the Adobe Illustrator 88 icon to start the program. 

2. Choose Open from the File menu, or press -O. 

A list of available Adobe Illustrator 88 documents appears, including 
converted MacDraw documents. 

3. Click on the name of the document you want to open. 

A list of MacDraw documents appears. You are asked if you want to use 
the corresponding MacDraw document as a template for the converted 
artwork you are opening. 

4. Click on the name of the corresponding MacDraw document to be used as 

a template. 

Click None if you do not want to use it. 

5. Click Open. 
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The converted document is opened, displaying Adobe Illustrator 88 artwork 
and the corresponding MacDraw template, if you chose one. 

Once you have opened the converted artwork, you can use the Adobe 
Illustrator 88 program to manipulate it in any way you want. 

3.78% 

Quarter l y I ncome 
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Appendix A: Problems and Solutions 

Anchor points refuse to be selected 

Problem: I'm clicking on an anchor point, but the program refuses to 

select it. 

n 

fl
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Cause: The object is locked, or there is an anchor point on top of the 

anchor point you want to select. 

Solution: If you think the object might be locked, choose Unlock All from 

the Arrange menu. If you still can't select the anchor point, select the path 

that is on top of the path containing the anchor point you want to select, 

and lock it. Select (and adjust as necessary) the anchor point you have been 

trying to work with. When you are through, choose Unlock All again. 

Jumping anchor points 

Problem: I'm trying to position an anchor point precisely, but it keeps 

jumping to a nearby anchor point. 

Cause: The Snap To Point option is chosen. When this option is set, an 

anchor point that you are dragging will snap to any anchor point that is 

within 2 pixels of its position. 

Solution: Choose Preferences from the Edit menu, and click the Snap To 

Point checkbox so that the option is no longer chosen. Then click OK to 

return to your document. If you prefer to leave Snap To Point set, use the 

zoom tool to magnify your document so that you have more control. 

Mysterious blank pages 

Problem: When I print, I get extra blank pages. 

Cause: You are drawing too close to the Adobe Illustrator 88 program's 

page border. A direction point in one of your curves may extend to another 

page. 

Solution: When you are ready to print, choose Print from the File menu. 

Then click the From button and specify the pages you want to print. 

Another option is to use the page tool to adjust the page grid so that the 

artwork is farther away from the edge of the page. See Chapter 15, 

"Printing Documents," for information on the page tool. 



204 User Guide 

Corners don't line up properly 

Problem: Stroked shapes that appear to be aligned in my artwork do not 
line up when I preview or print. 

Cause: The miter line join style is causing the corner points to extend way 
beyond the actual anchor points. When this style of line join is specified, 
the outer edges of two lines that form a corner are extended until they 
meet. If the lines form a sharp angle or are stroked with a heavy line 
weight, the outer corner can extend farther than you had anticipated. 

Solution: Select the path that has the jutting corners, and choose Paint 
from the Style menu. Change the line join style by clicking on either the 
bevel (flat) join button or the round join button in the Joins options. 
Another solution is to specify a lower miter limit for mitered corners. The 
lower this limit, the sooner the program switches from a miter join to a 
bevel join. 

Sharp spikes in stroked letters 

Problem: When I print, some of the letters, such as M and W, have long, 
sharp corner points. 

Cause: The miter line join style is causing the corners to extend too far. 

Solution: See the solution to the previous problem. 

Blank screen in preview mode 

Problem: When I preview my artwork, all I see is a blank screen. 

Cause: The mask attribute is set for a small object in your document, 
such as a line or a single anchor point, and it is causing all of the objects 
in front of it to be masked. This is especially likely to happen if you have 
inadvertently assigned the mask attribute to the center point of a rectangle 
or oval. 

Solution: Choose Select All from the Edit menu, and then choose Paint 
from the Style menu. Click in the Mask checkbox to turn the masking 
option off for all objects in the document. You may have to click twice 
before the box becomes blank. Be sure to ungroup any rectangles and ovals 
you use as masking objects and to delete their center points. For more 
information, see the discussion of masking in Chapter 14, "Painting." 
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Rotated/reflected/sheared object disappears 

Problem: I rotated/reflected/sheared an object with the dialog box, and 
now I don't see it anymore. 

Cause: You have rotated/reflected/sheared the object off the screen. 

Solution: Scroll to display the object in its new location. 

Rectangles or ovals appear at an angle 

Problem: The rectangles or ovals I draw are all set at an angle. 

Cause: The x and y axes have been rotated. When you draw a rectangle or 
oval, its sides are placed parallel to the current axes. 

Solution: Choose Preferences from the Edit menu. The value in the 
Constrain Angle field shows the current angle of the x axis. You can either 
change this value to 0, delete any rectangles you've drawn at an angle, and 
redraw them so that they are straight, or you can use the rotate tool to 
rotate the rectangles into the correct position. 

Symbols don't appear in text 

Problem: I typed an Option-Shift key combination to produce a math 
symbol, but I didn't get the symbol I wanted. 

Cause: Some programs reencode fonts with symbols from other fonts, 
meaning that if a font does not contain the character you want, the 
program will bring it in from another font, such as the Symbol font. The 
Adobe Illustrator 88 program does not do this, and thus you are limited to 
the characters available in the font that is currently selected. 

Solution: If you require a specific symbol that is not in the font you are 
using, you must enter your type in separate blocks. Enter the symbol in its 
own block, assigning it the font that contains the character you need. 
Sandwich this symbol block between blocks containing the text that is to 
appear before and after the symbol, so that the blocks appear to be an 
unbroken string. 
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Patterns not available 

Problem: I can't stroke or fill with patterns; the option is dimmed. 

Cause: The Pattern option is dimmed because no patterns are available. 

Solution: Either create one or more patterns for the document or open a 
document containing the patterns you want to use. 

Program won't draw a long path 

Problem: When I draw a very long path, I get a message telling me to 
shorten the path. 

Cause: The PostScript interpreter limits the number of anchor points in a 
single path, based on the amount of memory available. Your path has 
exceeded that limit. 

Solution: To shorten the path, break it into two paths in which the 
endpoint of one path lies directly on top of the other path's endpoint. Use 
the scissors tool to do this. This solution will not work for filled paths. 

Program won't open an Adobe Illustrator 88 document 

Problem: I can't open an Adobe Illustrator 88 document. The program 
displays a dialog box telling me that the document contains an illegal 
operator. 

Cause: You have started version 1.1 of the program by mistake. This can 
happen if you have both versions on your hard disk. Any document that 
uses an operator not supported in the older version of the program cannot 
be opened by that version. 

Solution: Quit the program, and start the Adobe Illustrator 88 program. 

Paths streaked with white 

Problem: When I preview a filled shape, it has a funny white streak. 

Cause: The path is not closed. 

Solution: Find the anchor points that are not connected (zoom in to 
magnify the artwork if necessary), and use the Average and Join 
commands to close the path. 

U 



Appendix B: Adobe Illustrator 88 Error Messages 

Message: A dash pattern length is missing! 

Cause: One of the fields in your dashed line pattern is blank. 

Solution: Enter a measurement for each consecutive dash and gap that 
you want to specify. It is all right to leave blank fields at the end of the 
pattern. 

Message: Adobe Illustrator 88 requires a LaserWriter file version 3.1 or later! 

Cause: The System Folder on your disk contains an old version of the 
LaserWriter driver. 

Solution: Install a LaserWriter driver with a version number of 3.1 or 
later. To see the version number, click once on the LaserWriter icon on the 
Finder's desktop, and then choose Get Info from the File menu. 

Message: Adobe Illustrator 88 requires a Macintosh Plus! 

Cause: The Adobe Illustrator 88 program will not run on models of the 
Macintosh earlier than the Macintosh Plus. 

Solution: Start the program on a Macintosh Plus or a later model. 

Message: Not enough memory to run Adobe Illustrator 88! 

Cause: There is not enough free memory in your system to run the Adobe 
Illustrator 88 program. 
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Solution: If you are running under MultiFinder or Switcher, try to free up 
more memory by quitting from other programs you are currently 
running. If your system has 1 MB of memory or less, you will not be able 
to run the Adobe Illustrator 88 program under MultiFinder. Specify Finder 
as the startup system and restart your Macintosh. 
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Message: Adobe Illustrator 88 (Separator) requires Macintosh System 
Software Version 4.2 or later. 

Cause: Your disk contains an old version of the Macintosh System Folder. 

Solution: Install a System Folder version 4.2 or later. No system software 
is provided with the Adobe Illustrator 88 program. See your Apple dealer 
for the most recent version. 

Message: Can't average the points! 
Can't blend the paths! 
Can't change the paint style! 
Can't change the style! 
Can't change the type style! 
Can't clear the objects! 
Can't copy the illustration! 
Can't copy the objects! 
Can't create a definition point! 
Can't create a new illustration! 
Can't create a new window! 
Can't create an oval! 
Can't create a path! Please draw a shorter curve. 
Can't create a pattern definition from the Clipboard contents! 
Can't create a rectangle! 
Can't create type! 
Can't cut the objects! 
Can't define a new pattern from the selection! 
Can't delete the selected pattern or patterns! (Probably out of 
memory.) 
Can't finish the preview! 
Can't group the objects! 
Can't join the points! 
Can't make new custom color! 
Can't move the objects! 
Can't open the desk accessory! 
Can't open the illustration! 
Can't paste the objects! 
Can't redefine the selected pattern! (Probably out of memory.) 
Can't reduce/enlarge the objects! 
Can't reflect the objects! 
Can't rename the custom color! 
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Can't rename the selected pattern! (Probably out of memory.) 
Can't rotate the objects! 
Can't save the illustration! 
Can't scale the objects! 
Can't scissor the path! 
Can't send the objects! 
Can't shear the objects! 
Can't show the Clipboard! 
Can't ungroup the objects! 
Can't update the Clipboard! 

Cause: The specified operation cannot be performed for the reason listed. 
Out of memory is the most common reason. The other possible reasons 
are as. follows: The disk is full. I/O error. The disk is locked. The file is 
locked or in use. The message "Can't open the illustration!" may also 
occur if the file you are trying to open is not an Adobe Illustrator file. 

Solution: Correct the problem, if possible. If you are out of memory, make 
sure the RAM cache is turned off in the Control Panel. If you have more 
than one window open, close all but the one in which you are working. If 
you are running more than one program concurrently under MultiFinder 
or Switcher, quit from all programs except the Adobe Illustrator 88 
program. 

Message: Can't prepare the illustration for printing! Please open the Chooser 
and select a printer. 

Can't print the illustration! Please open the Chooser and select a 
printer. 

Cause: These messages usually occur because your printer is turned off or 
not connected or because no printer is specified in the Chooser. 

Solution: Correct the problem with the printer, or select Chooser from the 
Apple menu and specify a printer. 

Message: Can't preview a path! Please shorten the path or increase its flatness. 

Cause: One of the paths in your document is too long. 

Solution: Shorten the path by breaking it in two (use the scissors tool for 
this), or select the path, display the Paint dialog box, and increase the value 
in the Flatness field. 
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1 
Message: Nearly out of memory! Please free up more memory immediately. 

Cause: Your system is running out of memory. This can happen if you 
are working on a complex illustration, have a number of windows open, 
or are running more than one program at once. 

Solution: Close all windows but the one in which you are working. Make 
sure that the RAM cache is turned off in the Control Panel. If you are 
running under MultiFinder or Switcher, quit from any other programs 
that you are running. If these tactics don't work, you may have to specify 
Finder as the startup system and restart your Macintosh. 

Message: Out of memory, can't create a path! Please draw a shorter curve. 

Cause: There is not enough free memory in your system to draw the 
curve you are attempting. 

Solution: Draw a shorter curve, or try to free up memory by turning off 
the RAM cache in the Control Panel, closing open windows and, if you are 
running under MultiFinder or Switcher, quitting other programs. 

Message: Out of memory! You will be asked to save changes to your work and 
then Adobe Illustrator 88 will quit. 

Cause: Your system is out of memory. This can happen if you are 
working on a complex illustration, have a number of windows open, or 
are running more than one program at once. 

Solution: Save your work. Make sure that the RAM cache is turned off in 
the Control Panel. If you are running under MultiFinder or Switcher, quit 
from any other programs that you are running and try restarting the 
Adobe Illustrator 88 program and working with the document. If there is 
still insufficient memory, you may have to specify Finder as the startup 
system and restart your Macintosh. 

Message: Please select two endpoints of ungrouped and open paths to join! 

Cause: You chose the Join command while an inappropriate number of 
points was selected, or one or both of the selected anchor points is either 
not an endpoint or forms part of a group. 

Solution: Before choosing the Join command, be sure that you have 
selected exactly two endpoints and that the path or paths you are joining 
are not grouped. 
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Message: Please select two or more points to average! 

Cause: You chose the Average command with fewer than two anchor 
points selected. 

Solution: Select the anchor points you want to average, and then choose 
the Average command. 

Message: Please use the blend tool on a selected endpoint of an ungrouped 
open path! 

Please use the blend tool on a selected point of an ungrouped path! 

Cause 1. One or both of the paths you are blending is grouped. 

Solution: Select both paths, and choose Ungroup from the Arrange menu. 
If either of the paths was created with the oval or rectangle tool, delete the 
center point after you ungroup the object. 

Cause 2. One or both of the anchor points you are clicking on with the 
blend tool is not selected. 

Solution: After you have selected the blend tool, click on two 
corresponding selected anchor points to set up the blend operation. 

Cause 3. If you are blending open paths, you may not be clicking on an 
endpoint. 

Solution: After you have selected the blend tool, click on one endpoint of 
each open path. 

Message: Please use the blend tool on two different paths! 

Cause: You have clicked with the blend tool on two points on the same 
path. 

Solution: With one or more anchor points selected in each path, click on 
the blend tool and then click once on each path. 
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Message: Please use the blend tool on two open or two closed paths! 

Cause: One of the paths you are blending is open and one is closed. 

Solution: You cannot blend an open path with a closed one. Either close 
the open path or open the closed one. 

Message: Please use the scissors tool/Option key combination on a segment of 
an ungrouped path! 

Cause: The segment to which you are trying to add an anchor point is 
part of a grouped path. 

Solution: Ungroup the path before you add the anchor point. You can 
group it again afterward. 

Message: Please use the scissors tool on a segment or an anchor point (but not 
an endpoint) of an ungrouped path! 

Cause: With the scissors tool selected, you clicked on the endpoint of an 
open path or on a grouped path. 

I 

Solution: If you did not click on an endpoint, select the path and choose 
Ungroup from the Arrange menu. 1 

Message: That name is too long! Please use a name shorter than 31 characters. 

Cause: You have entered a name for a pattern or custom color that is too 
long. 

Solution: Enter a name with fewer than 31 characters. 

Message: That text block is too long! Please use a block shorter than 255 
characters. 

Cause: The block of text you entered in the text box of the Type dialog box 
contains too many characters. 

Solution: Each block of type must have 255 or fewer characters. If you 
need to have more characters in one sequence, create several blocks of type. 



Appendix B: Adobe Illustrator 88 Error Messages 213 

Message: The angle must be between -1008 and 1008 degrees! 
The black value must be between 0 (white) and 100 (black) percent! 
The blend percentage values must be between -100 and 200 percent! 
The cyan value must be between 0 (no cyan) and 100 (maximum 
cyan) percent! 
The dash lengths must be between 0 and 1008 points! 
The dash lengths must not be all zero! 
The distance must be between -1008 and 1008 points! 
The distance must be between 0 and 1008 points! 
The flatness must be between 0 (default flatness) and 100 pixels! 
The freehand tolerance value must be between 1 and 10 pixels! 
The from and to values must be between 0 and 1008 points, and the 

— scale must be between -10080 and 10080 percent! 
The kerning must be between -1008 and 1008 points! 
The leading must be between -1008 and 1008 points! 
The magenta value must be between 0 (no magenta) and 100 
(maximum magenta) percent! 
The miter limit must be between 1 (always beveled) and 10 (very 
long spikes)! 
The auto trace gap distance must be between 0 and 2 pixels! 
The oval height must be between 0 and 1008 points! 
The oval radius must be between 0 and 1008 points! 
The oval width must be between 0 and 1008 points! 
The rectangle height must be between 0 and 1008 points! 
The rectangle width must be between 0 and 1008 points! 
The scale must be between -10080 and 10080 percent! 
The size must be between 0 and 1008 points! 
The spacing must be between -1008 and 1008 points! 
The steps value must be between 1 and 100! 
The stroke weight must be between 0 and 1008 points! 
The tint value must be between 0 (no tint) and 100 (maximum tint) 
percent! 
The yellow value must be between 0 (no yellow) and 100 (maximum 
yellow) percent! 

Cause: The value you entered in the specified field is invalid. 

Solution: Enter a value within the range indicated in the message. 
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Message: The illustration contains an illegal operand. 
The illustration contains an illegal operator. The illustration contains 
an illegal or misplaced operator. 
The illustration contains an incomplete or garbled object description. 
The illustration does not have the correct number of operands for an 
operator. 
The illustration doesn't contain the "%%BoundingBox" comment. 
The illustration doesn't start with the "%!PS-Adobe-" comment. 
The illustration ended unexpectedly. 
The illustration exceeds an implementation limit. 

Cause: There is a problem with the PostScript language code that 
describes the illustration. This usually occurs if the file is not an Adobe 
Illustrator document or if the file is damaged. 

Solution: Be sure that you are opening a file created with the Adobe 
Illustrator program. If you think the file may be damaged, try recovering it 
from a backup copy. 

Message: The pattern is too complex. 

Cause: The pattern you are attempting to define has too many elements. 

Solution: Try to find ways to simplify the pattern. 

Message: There are no patterns associated with this artwork. 

Cause: You have not defined any patterns for the illustration. 

Solution: Define patterns before using them to fill and stroke paths. To 
use patterns defined in another document, you must have that document 
open. 

Message: To define a pattern, the backmost selected object must be a rectangle 
defining the tile boundary! 

Cause: You have not correctly defined the boundary of the pattern. 

Solution: Select the rectangle that is to serve as the tile boundary for the 
pattern, and place it behind the pattern by selecting the pattern and then 
choosing Paste In Back from the Edit menu. Be sure that the rectangle is 
selected. 
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If you already have the Adobe Illustrator program version 1.0 or 1.1, here 
is a list of all the features that are new or different in the Adobe Illustrator 

88 program. See the appropriate sections of this guide for complete details 
on these features. 

New tools 

Blend tool 

The blend tool creates intermediate shapes between two paths. Depending 
on how you paint the paths you can produce smooth blends between two 
different shades of gray, colors, or line weights. You can also use the blend 
tool to create animated effects. 

Freehand tool 

The freehand tool allows you to draw by dragging the pointer in the 
working area. It is provided as an alternative to the pen tool, for times 
when you want to produce a fast sketch rather than precise lines and 
curves. 

Measure tool 

The measure tool calculates the distance between any two points in the 
working area. 

Auto trace tool 

The auto trace tool automatically draws artwork over template shapes and 

lines. 

New features 

Color 

You can fill and stroke objects in your artwork with color. The Adobe 

Separator program, included in this package, allows you to print color-
separation negatives. You can produce negatives for printing in custom 
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Masking 

Patterns 

Command changes 

File menu 

Edit menu 

ink colors or ones for printing with the four-color process. See the Adobe 
Illustrator 88 Color Guide for more information. 

You can define any path as a masking object. This masking object then 
masks (forms a boundary around) any objects that lie in front of it and are 
grouped with it. If part of a masked object falls outside the mask boundary, 
it is hidden from view when you preview or print. 

You can create your own patterns using any of the Adobe Illustrator 88 
program tools. You can then use the patterns to fill and stroke objects in 
your artwork. When you transform qr move objects filled or stroked with a 
pattern, you have the option of transforming or moving the pattern as 
well. 

The Place command has been added to allow you to import documents in 
the EPS format created in other applications into Adobe Illustrator 88 
documents. 

In the Save As dialog box, a checkbox has been added to allow you to 
include copies of placed EPS files in the PostScript language code for the 
illustration. Another checkbox has been added to allow you to save your 
Adobe Illustrator 88 program artwork as Adobe Illustrator program 
version 1.1 artwork. 

The Bring To Front and Send To Back commands have been added. These 
commands make the selected object the frontmost or backmost layer, 
respectively, in the illustration. 

The Show Clipboard command has been moved to the Window menu. 

I 

I 

I 

I 
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The Preferences command has been added. It displays the Preferences dialog 

box, which contains the following options: 

Snap To Point: Indicates whether an object should jump to an 

anchor point whenever the pointer is within 2 pixels of that anchor 

point. 

Preview and Print Patterns: Indicates whether patterns should 
appear when you preview or print the illustration. 

Transform Pattern Tiles: Indicates whether to transform pattern 

tiles when an object painted with a pattern is moved or transformed. 

Constrain Angle: Specifies the angle by which the x and y axes 
should be rotated. This was formerly a command on the Arrange 
menu. 

Corner Radius: Specifies the radius of a circle used to make rounded 
corners in any rectangles you draw. 

Cursor Key Distance: Specifies the distance by which a selected object 
will move when you press one of the cursor (arrow) keys. 

Freehand Tolerance: Controls the sensitivity of the freehand tool to 

variations in your hand movement. 

Auto Trace Gap Distance: Determines the largest gap across which 

the auto trace tool will jump as it traces a template 

Ruler Units: Sets the unit of measure displayed in the ruler and used 

in many dialog boxes. 

Change Progressive Colors: Brings up a dialog box that allows you 

to adjust your color display from within the Adobe Illustrator 88 
program. 

Arrange menu 

A dialog box now appears when you choose the Join command after 
selecting two coincident endpoints (one directly on top of the other). It 

allows you to indicate whether the resulting anchor point is to be a corner 

point or a smooth point. 

A dialog box now appears when you choose the Average command. It 

allows you to specify whether averaging is to occur along the horizontal 

(x) axis, the vertical (y) axis, or both axes. 
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The Lock command has been added. It locks the selected object so that it 
cannot be selected. The Unlock All command has been added. It unlocks all 
locked objects in the illustration. 

The Hide command has been added. It removes the selected object from the 
window temporarily. The Show All command has been added. It shows all 
objects in the artwork. 

The Constrain command is now an option in the Preferences dialog box, 
available from the Preferences command on the Edit menu. 

View menu 

The Preview command has been renamed Preview Illustration. 

The New Window (formerly New View) and Show/Hide Toolbox 
commands have been moved to the Window menu. 

The ruler origin is preset at the bottom left of page 5, rather than the 
bottom right. 

Style menu 

In the Paint dialog box, the Process Color, Custom Color, Pattern, and 
Overprint options have been added to both the Fill and Stroke option 
groups. You use the Pattern command to define and work with patterns. 
You use the Custom Color command to create your own custom colors. In 
addition, the Mask option has been added. (See "Masking," under "New 
Features" earlier in this section.) 

In the Type dialog box, the Kerning field is now called the Spacing field. 
The function of this field has not changed. 

Window menu 

This menu is new. It contains the following commands: 

Show/Hide Clipboard (moved from the Edit menu) 

Show/Hide Toolbox (moved from the View menu) 

New Window (replaces New View command, formerly on the View menu) 

The Window menu also lists all documents currently open on the desktop. 
You can bring any document to the front and make it the active window 
by choosing its name from the Window menu. 

I 

I 

I 

I 

I 

I 

U 

U 

U 

U 

U 



Appendix C: Adobe Illustrator 88 Program Update 219 

Toolbox changes 

Several of the tool icons have been redesigned. 

Four new tools have been added: The freehand tool, the auto trace tool, the 
blend tool, and the measure tool. See "New Tools," earlier in this section, 
for more information. 

The origin of the page tool is preset at the bottom left of the screen, rather 
than the top left. 

The square tool has been renamed the rectangle tool. The circle tool has 
been renamed the oval tool. 

A dialog box has been added to the rectangle and oval tools, allowing you 
to enter the height and width of the shape you want to create. You can also 
specify a corner radius value in the Rectangle dialog box so that you can 
create rectangles with rounded corners. 

Other program changes 

The Preview Illustration and Select All commands are no longer dimmed 
when the illustration contains no objects. 

A checkbox that allows you to transform pattern tiles along with the object 
being transformed has been added to the dialog box for each of the 
transformation tools and to the Move dialog box. This checkbox works in 
coordination with the checkbox of the same name in the Preferences dialog 
box. 

n 
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Glossary 

alignment How lines of type are stacked. You have three choices: left 
alignment (flush left, ragged right), center alignment (ragged left, ragged 
right), and right alignment (ragged left, flush right). The alignment of a 
block of type is indicated by the position of its alignment point. 

alignment point The point on which a block of type is aligned. Each 
block of type has one alignment point. The point appears as a solid 
square when the block of type is selected and otherwise appears as an x. 

anchor point The point that determines where a segment starts or ends. 
Anchor points are invisible unless any segment of the path they form is 
selected. Anchor points that end curve segments have direction lines and 
points associated with them. A single anchor point, with no segments 
connected to it, appears as an x when not selected. 

artwork The paths and type that constitute a single document created 
with Adobe Illustrator 88. Stroke and fill attributes are not visible in an 
artwork image. Compare with preview image and template. 

TI 

TI 

n 

auto trace To trace around the shapes or lines in a template 
automatically. 

auto trace gap distance A setting in the Preferences dialog box that 
determines the number of pixels that the auto trace tool jumps over as it 
traces a path around a template shape. 

average To move selected anchor points to a position that is the average 
of their original locations. Compare with join. 

baseline The line upon which type rests. In Adobe Illustrator 88, the 
baselines of a block of type are visible when the type is selected. You click 
on a baseline to select type and drag it to move type. 

bevel join A style of line join in which the corner point looks as though 
it were sliced off diagonally. Compare with miter join and round join. 

Bezier curve A curve, named after Pierre Bezier, that is defined 
mathematically by four control points. These control points are the four 
direction points at the ends of the two direction lines that are tangent to 
each curve. All curves in Adobe Illustrator 88 are Bezier curves. See also 
curve. 
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bitmap A graphic image consisting of a matrix of dots (pixels). 
Templates and preview images are bitmap images. 

blend To create a series of successive shapes or shadings between two 
selected paths. 

butt cap A style of line cap that is squared off perpendicular to the line. 
The cap does not extend beyond the end of the path. Compare with 
projecting cap and round cap. 

cap See line cap. 

click To press and then immediately release the mouse button. 

clip art Off-the-shelf art for the Macintosh. Clip art pieces are stored as 
MacPaint documents. 

closed path A path with no endpoints, that is, a path that has no 
obvious beginning or end. Compare with open path. 

coincident Occupying the same position. In a straight line, an anchor 
point and its two direction points are coincident. 

collinear Occurring along the same straight line. The anchor point 
and two direction points of a smooth point are collinear. 

constrain To restrict a draw or move operation or a transformation to 
an angle that is a multiple of 45 degrees, relative to the angle of constraint 
you specified in the Preferences dialog box. 

corner point An anchor point that joins two straight lines, a straight 
line and a curve, or two curves that are not continuous. In the case of two 
curves, the anchor point and its two direction points do not lie on a 
straight line when they form a corner point. Compare with smooth point. 

corner radius The radius of the circle used to form rounded corners in a 
rectangle. 

current attributes The paint and type attributes currently in effect. 
These attributes are assigned to new paths or blocks of type you create. The 
current attributes appear in the Paint dialog box when no objects are 
selected. 
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cursor key distance The distance that selected objects move each time 
that you press a cursor (arrow) key. 

curve A smooth trajectory defined by two anchor points and two 
direction points. The anchor points define where the curve starts and ends. 
The direction points determine the shape of the curve. 

custom color An ink color that you assign to objects in your drawing. 
With custom color, you produce one negative for each color used in the 
artwork. Compare with process color. 

dash pattern The pattern of lines and gaps that makes up a dashed 
line. You create a dash pattern for a stroked path by entering in the Paint 
dialog box the length, in points, of each dash and of each gap between the 
dashes. 

define (pattern) To draw or place artwork inside a rectangle and then 
give it a name in the Pattern dialog box. 

digitizer See scanner. 

direction line The straight line between an anchor point and its 
direction point. The direction line touches the curve at the anchor point. 

direction point A point that defines the direction in which a curve 
enters or leaves an anchor point. The position of a curve's two direction 
points determines the shape of the curve. 

drag To hold down the mouse button while you move the pointer. 

DrawOver An application that converts MacDraw files to Adobe 
Illustrator 88 documents. 

Encapsulated PostScript ([PS) format A file format that describes a 
document written in the PostScript language and that contains all of the 
code necessary to print the file. 

endpoint An anchor point at the beginning or end of an open path. 

[PS See Encapsulated PostScript format. 

fill To paint an area enclosed by a path with a gray shade, a color, or a 
pattern. 
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flatness The maximum distance, in device pixels, of any point on a 
rendered curve from the corresponding point on the true curve. 

freehand tolerance A value that controls how sensitive the freehand 

tool is to variations in your hand movement. 

group To combine two or more objects so that they act as a single 
object. 

hide To remove a path or block of type from the artwork temporarily. 
Objects that are hidden do not preview or print. 

insertion point A blinking vertical line that indicates where characters 

you type will appear. 

interpreter Software that converts commands written in a computer 

language into primitive instructions that the device on which the software 

is running can understand. A PostScript interpreter built into a printer or 
typesetter converts PostScript language commands into a form the printer 

can use to draw an image. 

join (noun) See line join. 

join (verb) To connect two endpoints with a straight line segment. When 

you join the endpoints of an open path, the program closes the path. 

When you join the endpoints of two open paths, the program combines 
them into one longer path. Compare with average. 

landscape A horizontal printing orientation in which the top of the 
page is one of the long edges of the page. Compare with portrait. 

layer To place objects in layers that are in front of one another. See also 
painting order. 

miter limit The ratio that determines the angle at which Adobe 
Illustrator 88 switches from a mitered (pointed) line join to a beveled 
(squared-off) line join. The miter limit is equal to the maximum ratio of 
the diagonal line through a line to the width of the lines producing the 
join. The smaller the miter limit, the less sharp the angle at which the 
program switches from a mitered to a beveled line join. 

object An anchor point, segment, path, or block of type, or a group of 
anchor points, segments, paths, and blocks of type. 
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open path A path with two endpoints, that is, a path that has a 
beginning and an end. Compare with closed path. 

overprint To specify that a colored object show through another colored 
object that overlaps it. Normally, the object underneath is hidden by the 
object in front. 

paint To fill a region defined by a closed path with a shade of gray, a 
color, or a pattern, or to stroke a line that is centered on a path with a 
shade of gray, a color, or a pattern. 

painting order The sequence in which the objects in a document are 
painted. Objects are painted from back to front, meaning that in a number 
of layered objects the frontmost object will obscure all or part of the objects 
that lie behind it. 

path One or more connected segments. 

pattern One or more objects that has been bounded by a rectangle and 
defined as a pattern. Once defined, patterns can be used to paint paths. 

pattern tile The rectangle within which a pattern is defined. 

pica Twelve points, or one-sixth of an inch. 

pixel A single dot on a computer display. Templates and bitmaps are 
collections of pixels. 

PICT format A format used for transferring QuickDraw graphics 
between programs on the Macintosh. Before Adobe Illustrator 88 can read a 
MacDraw document, it must be saved in PICT format. 

place To import a scanned image or an EPS format file into an Adobe 
Illustrator 88 document. 

point A unit of measure, used in Adobe Illustrator 88 for specifying type 
and line attributes. There are 72 points in an inch. 

point of origin A fixed spot that you specify in your artwork from 
which a transformation begins. 

portrait A vertical printing orientation in which the top of the page is 
one of the short edges of the page. Compare with landscape. 
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Postscript language A computer language invented by Adobe Systems 
that is used to define the appearance of type and images on the printed 

page. When you save an Adobe Illustrator 88 document, you are actually 

saving a PostScript language program. 

preset values The values in effect for all fields in Adobe Illustrator 88's 
dialog boxes when you start the program. These are the program's 
defaults. 

preview image The view of your Adobe Illustrator 88 artwork as it will 
appear when printed. The artwork is displayed on your screen as a 

bitmap image. You can specify whether paint and pattern attributes 
appear in the preview image. A version of the preview image is saved 

along with the PostScript language code for the artwork document when 

you specify one of the preview options before saving your artwork. 
Compare with artwork. 

process color One of the four colors—cyan, magenta, yellow, and 
black—blended to produce colors in the four-color process. With process 
color, you produce a maximum of four negatives, regardless of the number 

of colors used in your artwork. Compare with custom color. 

progressive colors The four process colors plus white and the various 
combinations of cyan, magenta, and yellow. The Change Progressive 
Colors option in the Preferences dialog box allows you to adjust the 
appearance of the progressive colors on your computer display. 

projecting cap A style of line cap that is squared off perpendicular to 
the line. It extends one-half of the line's width beyond the endpoint of the 
path. Compare with butt cap and round cap. 

QuickDraw A graphics language built into the read-only memory 
(ROM) of the Macintosh. 

redefine (pattern) To change the definition of a pattern by altering the 
pattern's content but not its name. 

reflect To create a mirror image of an object across an axis of reflection 
that you specify. 

resolution The number of dots per inch displayed on a screen or 

printed on a printer. 

rotate To revolve an object about a specified point. 
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round cap A semicircular line cap placed at the end of a solid or 
dashed line. The diameter of the cap is equal to the width of the line. 
Compare with butt cap and projecting cap. 

round join A style of line join in which the corner formed by two 
segments is rounded. Compare with bevel join and miter join. 

scale To change the size of an object vertically, horizontally, or both. 

scanned image The image that results when a photograph, 
illustration, or other two- or three-dimensional image is converted into a 
bitmap. On the Macintosh, scanned images are stored as MacPaint 
documents. 

scanner An electronic device that converts a photo, illustration, or other 
two-dimensional image into a bitmap. A video camera is a scanner that 
converts three-dimensional objects into bitmaps. 

segment A line or curve that is defined by two anchor points and their 
respective direction points. 

select To define an object to be acted upon by the next command or 
mouse operation. You must select an object before you can change or edit 
it in any way. You generally select an object by clicking on it with the 
selection pointer or by dragging the selection marquee around it. 

selection marquee A dashed rectangular region used to select objects. 

selection pointer An arrow-shaped pointer used for selecting and 
moving objects. 

shear To slant or skew an object vertically, horizontally, or along an 
arbitrary line. 

smooth point An anchor point that lies on a straight line between its 
two direction points. The curve segments connected to such an anchor 
point form a continuous curve. Compare with corner point. 

spacing The amount of space, in points, that is added or removed 
between every pair of characters in a type block. Spacing affects the 
amount of white space in a type block. 

stroke To paint a line that is centered on a path. 
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tangent Touching a line or curve at only one point. The direction line 
is tangent to the curve at the anchor point. 

template A bitmap image, such as a scanned image or a graphic from 
a program such as MacPaint, that you trace over to create artwork in 
Adobe Illustrator 88. The template appears on the screen as a gray image 
behind the artwork; it is not part of the final printed document. Compare 
with artwork and preview image. 

tile (page) To divide Adobe Illustrator 88's drawing area into pages for 
the page size currently specified in the Page Setup dialog box. 

tile (pattern) To repeat a pattern in columns and rows across the layer 
of the document in which that pattern paints a path. 

tint A percentage of one of the process or custom colors. 

toggle A command that lets you switch between two settings. The 
Show/Hide Rulers command is an example of a toggle. 

toolbox The set of tools displayed to the left of the drawing area when a 
document is open. 

ungroup To separate a group into individual objects or into subgroups. 

unlock To remove the lock attribute from an object so that it can be 
selected. 

x axis The horizontal reference line to which objects are constrained. 

y axis The vertical reference line to which objects are constrained. 

zoom To magnify or reduce your view of the current document. 
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A 
Actual Size command 24 
adjusting 

anchor points or segments 97 
curves 95 
paths 81, 92 

Adobe Illustrator 88 
desktop 6 
icon 5 
starting 5 
quitting 16 

Adobe Illustrator 88 documents 
closing 11 
naming 12 
opening 8 
problems opening 206 
saving 12, 13 

Adobe Separator program 2, 187, 
alignment (definition) 221 

of type 79 
alignment point (definition) 221 

setting the 76 
anchor point (definition) 221 
anchor points 32 

adding 83 
adjusting 97 
averaging 87 
constraining 83 
jumping 203 
moving 82 
selecting 65, 203 

annotating objects 173 
Apple Image Writer 

page setup for 191 
printing with 193 

Apple LaserWriter 188 
page setup for 190 
printing with 192 

arrow keys 
See cursor keys 

artwork (definition) 221 
placing into other programs 195 
planning 10 
printing 187 

Artwork and Template command 25 
artwork document 6 

creating with a template 8 
creating with no template 9 
opening 9 

opening with a different template 9 
naming 12 

Artwork Only command 25 
auto trace (definition) 221 
auto trace gap distance (definition) 221 

setting the 44 
auto trace tool 37, 215, 219 

creating corners with 44 
drawing with 40 

average (definition) 221 
Average command 87, 211, 217 
averaging anchor points 87 
averaging versus joining 87 

B 
backup copy 5 
baseline (definition) 221 

215 bevel join 162, (definition) 221 
Bezier curve (definition) 222 
bitmap (definition) 222 
blank pages 203 
blend (definition) 222 
Blend dialog box 141 
blend tool 119, 138, 211, 212, 215, 219 
blending 

objects 138 
grouped paths 140 

Bring To Front command 
Bump rule 47 
butt cap 161, (definition) 222 

216 

C 
Change Progressive Colors option 217 
Chooser 190, 192 
circles 

drawing 60 
Clear command 117, 118 
click (definition) 222 
Clipboard 

copying to the 116 
displaying the 28 

close box 12, 28 
Close command 12, 28 
closed path (definition) 222 
closed paths 31 

filling 155 
closing documents 11 
color 

filling with 159 



230 User Guide 

stroking with 160 
color illustrations 2, 215 
constrain (definition) 222 
Constrain Angle field 148 
Constrain Angle option 217 
constraining 45 

anchor points 83 
and x and y axes 146 
curves 49 
direction lines 49 
movement 102 
straight lines 37 

continuous paths 33 
copying 

between Adobe Illustrator 
documents 115 

copying objects 109 
by moving 109 
by transforming 110 
in front of or in back of other 
objects 114 
on top of the original 113 
to center of window 113 
to the Clipboard 116 

copyright law 8 
corner point (definition) 222 
corner points 35 

creating 37 
corner radius (definition) 223 
Corner Radius option 217 
corner style 

specifying the 58 
corners 

lining up 204 
correcting mistakes 11 
cursor key distance (definition) 223 

setting the 151 
Cursor Key Distance field 100, 151 
Cursor Key Distance option 217 
cursor keys 

moving objects with 100, 101 
curve (definition) 223 
curves 32 

adjusting 95 
and flatness value 172 
continuous 34 
drawing 48 
noncontinuous 35 
rules for drawing 46 

custom color (definition) 223 
and blended objects 139 

Custom Color command 218 
Cut command 117 

D 
dash pattern (definition) 223 

setting the 164 
dashed lines 155, 207 

creating 164 
defining patterns 175 

deleting 
all objects 118 
patterns 181 

deleting objects 
permanently 117 
temporarily 117 

deletions 
undoing 118 

deselecting 64 
deselecting objects 70 
diagonal movement 

See constraining 
direction line (definition) 223 
direction lines 32 
direction point (definition) 223 
direction points 32 

moving 96 
displaying documents 23 
displaying documents 

multiple views 24 
drag (definition) 223 
drawing 

rectangles and squares 55 
with the auto trace tool 40 
with the freehand tool 38 
with the pen tool 45 

drawing tool 
choosing a 36 

DrawOver (definition) 223 
DrawOver application 199 

E 
editing type 78 
Encapsulated PostScript format 
(definition) 224 
endpoint (definition) 224 
endpoints 32 
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joining 84 
enlarging artwork 191 
EPS files 

placing 195 
EPS format 12, 13, 195, 216 
equipment needed to run 
Adobe Illustrator 88 2 

F 
fill (definition) 224 
Fill options 158 
filling 

paths 155, 158 
self-intersecting paths 155 

filling and stroking type 157 
Fit In Window command 18, 23 
flatness (definition) 224 
flatness value 

setting 172 
fonts 

choosing 78 
freehand tolerance (definition) 224 
freehand tolerance 

setting the 39 
freehand tool 36, 215, 219 

continuing a path with 39 
drawing with 38 
starting a new path with 39 
switching to pen tool 50 

G 
group (definition) 224 
grouped objects 

blending 140 
grouping 

and ovals 60 
and painting order 153 
and rectangles 55 
masked objects 169 
selecting a path for 65 

grouping objects 71 

H 
hand tool 19 
hidden objects 

showing 74 
hide (definition) 224 
Hide Clipboard command 28 
Hide command 218 

Hide Rulers command 149 
hiding 

objects 73 
horizontal movement 

See constraining 

I 
IBM PC preview format 13 
insertion point (definition) 224 
interpreter (definition) 224 
Image Writer 

page setup 191 
printing with the 193 

1 
join (definition) 224 
Join command 84, 210, 217 
joining 

endpoints 84 
versus averaging 87 

K 
kerning 

See spacing 
keyboard search 174 

L 
landscape (definition) 224 
LaserWriter 

page setup 190 
printing with the 192 

layer (definition) 225 
layering 10, 153 
leading 

setting 78 
line cap 

setting 161 
line join 

setting 162 
line weight 

setting 160 
lscaling 124 

Lock command 218 
locked objects 203 
locking objects 65, 72 
long paths 206 



232 User Guide 

M 
MacDraw 7 
MacDraw files 

converting to artwork 199 
MacPaint 3, 7, 8 
magnifying documents 20 
Mask option 218 
masking 169, 216 

blended objects 170 
Measure dialog box 145 

and x and y axes 147 
measure tool 145, 215, 219 
measuring distances 145 
memory 172, 209, 210 
miter limit (definition) 225 

setting the 163 
miter line join 162, 204 
Move dialog box 106, 184 
moving 

direction points 96 
moving objects 99 

a specific distance or direction 106 
by dragging 100 
constraining 102 
in front of or in back of other objects 
104 
to the center of the window 103 
to the front or back 105 
with cursor keys 100, 101 

moving pattern tiles 108, 184 

N 
naming documents 12 
New command 8, 9 
New Window command 24, 218 
Note field 173 

O 
object 63, (definition) 225 
objects 

copying 109 
deleting 117 
deselecting 64 
grouping 71 
hiding 73 
locking 72 
moving 99 
selecting 63 
transforming 119 

ungrouping 72 
unlocking 73 

One-Third rule 46 
open path (definition) 225 
open paths 31 

adding segments to 51 
blending 140 
ending 46, 50 
filling 155 

opening a new window 24 
opening documents 8 
orientation 

of the page 191, 192 
oval tool 60, 219 

and x and y axes 148 
ovals 

as masking objects 170 
drawing 60 
specifying dimensions of 60 

overprint (definition) 225 

P 
page grid 

adjusting 189 
page layout programs 

placing artwork into 195 
page setup 190 
Page Setup command 190, 191 
page tool 189, 219 
paint (definition) 225 
paint attributes 

displaying 157 
setting the 157 

Paint dialog box 157 
painting 153 

order 153 
selecting a path for 65 
type 78 
with patterns 165 

painting order (definition) 225 
paper size 

specifying the 191, 192 
pasting objects 

from the Clipboard 116 
path (definition) 225 
paths 

adjusting while drawing 92 
closed 31 
closing 46 
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continuous 33 
extending 51 
filling 206 
open 31 
painting 154 
selecting 67 
splitting 89 
with corners 34 

pattern (definition) 225 
Pattern command 218 
pattern tile (definition) 225 
pattern tiles 183 

laying out 184 
moving 108, 184 
reflecting 133 
rotating 128 
scaling 125 
shearing 137 
transforming 185 

patterns 175, 214, 216 
and blended objects 139 
availability of 185, 206 
creating 175 
defining 214 
deleting 181 
painting with 165 
pasting 178 
previewing 183 
redefining 180 
renaming 181 
transforming 167 

pen tool 37 
drawing with 45 
switching to freehand tool 50 

pica (definition) 225 
PICT format 7, 13, 195, 200, 

(definition) 226 
pixel (definition) 225 
place (definition) 226 
Place command 195, 216 
placed images 

selecting 69 
point (definition) 226 
point size 

setting the 78 
portrait (definition) 226 
PostScript language 3, 214, 

(definition) 226 
PostScript language file 

creating 12 
Preferences command 217 
Preview and Print Patterns checkbox 183 
preview format 12 
Preview Illustration command 26, 219 
preview image (definition) 226 
previewing 26, 154, 204 

in color 27 
problems with 209 

previewing patterns 183 
Print dialog box 192, 193 
printers 2 

setting up pages for 190 
printing 192 
printing 187 

preset options 188 
process color (definition) 226 

and blended objects 139 
program copy 

personalizing the 5 
Program disk 5 
progressive colors (definition) 226 
projecting cap (definition) 227 
projecting line cap 161 

Q 
QuickDraw 13, 

(definition) 227 
quitting the Adobe Illustrator 88 
program 16 

R 
rectangle tool 55, 219 

and x and y axes 148 
rectangles 205 

as masking objects 170 
corner style 58 
drawing 55 
specifying dimensions of 57 

Redo command 11 
reducing artwork 191 
reducing documents 20 
reflect (definition) 227 
Reflect dialog box 132 
reflect tool 119, 129 
reflecting 

pattern tiles 133 
reflecting objects 

by dragging 129 
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with the Reflect dialog box 132 
reflection axis 

specifying the 133 
repeating transformations 144 
resolution (definition) 227 
rotate (definition) 227 
Rotate dialog box 128 
rotate tool 119, 125 
rotated objects 205 
rotating 

pattern tiles 128 
x and y axes 147 

rotating objects 
by dragging 126 
with the Rotate dialog box 127 

round cap (definition) 227 
round join (definition) 227 
round line cap 161 
round line join 162 
ruler origin 

changing 150 
Ruler Units option 217 
rulers 149 

hiding 149 
showing 149 

S 
Save As command 15 
Save As dialog box 216 
Save command 14 
saving 

placed EPS files 197 
saving documents 13 
scale (definition) 227 
Scale dialog box 124 
scale parameters 

specifying the 124 
scale tool 119, 120 
scaling 

line weights 124 
nonuniform 120, 124 
pattern tiles 125 
uniform 120, 124 

scaling objects 
by dragging 121 
with the Scale dialog box 123 

scanned image (definition) 227 
scanned images 

placing 195 

using as templates 8 
scanner (definition) 227 
scissors tool 83, 89, 212 
scroll bars 19 
scrolling in a document 19 
searching 174 
segment (definition) 227 
segments 32 

adjusting 97 
redrawing 94 
selecting 66 

select (definition) 228 
Select All command 219 
selecting 

all objects 70 
anchor points 65 
by clicking 63 
by dragging 64 
objects 69 
paths 67 
placed images 69 
segments 66 
type 68 

selection marquee 63, 64 
selection tool 63 
Send To Back command 216 
shear (definition) 228 
shear angle 

specifying the 137 
shear tool 119, 134 
shearing 

pattern tiles 137 
shearing objects 

by dragging 134 
with the Shear dialog box 136 

Show All command 218 
Show Clipboard command 28 
Show Rulers command 149 
Show/Hide Clipboard command 218 
Show/Hide Toolbox command 218 
size box 27 
smooth point (definition) 228 
Snap To Point option 152, 203, 217 

spacing (definition) 228 
type 78 

splitting paths 89 
squares 

drawing 55 
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straight lines 33 
constraining 37 
drawing 45 

Stride rule 47 
stroke (definition) 228 
Stroke options 160 
stroking paths 155, 159 
system software 2, 208 

T 
Tall Adjusted option 192 
tangent (definition) 228 
Tangent rule 47 
template (definition) 228 

tracing with the auto trace tool 
template document 7 

creating 7 
opening 8, 9 
viewing 25 

template documents 
naming 12 

Template Only command 25 
tile (definition) 228 
tiling 187 
tint (definition) 228 
toolbox (definition) 229 

hiding 30 
moving 30 
showing 30 

Transform Again command 108, 144 
Transform Pattern Style dialog box 167 
Transform Pattern Tiles option 217 
transformation tool 119 
transforming objects 120 

while copying 110 
transforming pattern tiles 185 
transforming patterns 167 
type 

aligning 76 
editing 78 
entering 76 
filling and stroking 157 
math symbols 205 
painting 78 
selecting 68 
transforming 75 
working with 75 

type attributes 78 
preset values 79 

setting the 79 
Type dialog box 76 
type tool 76 

U 
Undo command 11 
ungrouping 

objects 72 
unit of measure 

setting the 149 
Unlock All command 218 
unlocking objects 73 

V 
41 vertical movement 

See constraining 

w 

winding number rule 155 
windows 

changing the size of 27 
closing 28 
managing 27 
moving 28 

working area 17 
page grid 187 

X 
x and y axes 35,205 

and move operations 107 
and ovals 60 
and rectangles 56 
and type 75 
rotating 146 

x axis (definition) 229 

Y 
y axis (definition) 229 

Z 
zoom (definition) 229 
zoom box 27 
zoom tool 20 
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The equipment 

Word processing—Macwrite and Microsoft Word on the Macintosh Plus 
and Macintosh II 
Illustrations—Adobe Illustrator 88, MacDraw, and SuperPaint on the 
Macintosh Plus, and Macintosh II 
Scanned images and templates—VersaScan Plus on the Microtek scanner 
Page compostion—Frame Maker on the Sun Workstation 3/50 
Page proofs—Varityper VT600, LaserWriterIl NTX 
Color separation—Tutorial and User Guide: Process black and custom 
color separations using Adobe Separator on the Macintosh II 
Color Guide: Four-color process and custom color separations using 
Adobe Separator on the Macintosh II 
Camera-ready art—Linotronic 300 typesetter 
Typeface—The Stone family of typefaces was used throughout this book 

The players 

Adobe Illustrator 88 program design John Warnock, Mike Schuster, 
Teri Pettit, John MacMillan, John Kunze, Bill Paxton 
Adobe Illustrator 88 program implementation—Mike Schuster, 
Teri Pettit, John MacMillan, Steve Schiller 
Adobe Separator program design—Mike Schuster, Tom Baffico, John 
Kunze, Russell Brown, Jim Morton, Pat Coleman 
Adobe Separator program implementation—Mike Schuster, Tom Baffico 
DrawOver program design and implementation—Michael Everest, 
Mike Schuster 

Product management John Kunze 
Publications management—Mary Dieli 

Tutorial written by—Sue Crissman 
User Guide written by—Elaine Pendergrast 
Color Guide written by Jim Morton 
Editor—Rebecca Pepper 
Index Jim Morton, Rebecca Pepper, Jodi Edwards 
Proofreader—M. Vivian Ledeboer 

Art direction and graphic design—Pat Coleman, Russell Brown 
Package design and cover design—Luanne Seymour Cohen, Don Craig 
Icon design—David Smith 

Startup screen design—Luanne Seymour Cohen, Don Craig 
Illustrations—Tutorial: Pat Coleman, JoJo Soriano, Nat Robinson 
User Guide: Nat Robinson 
Color Guide: Jim Morton, Dean Dapkus, Kim Isola, Pat Coleman, 
Mike Schuster, JoJo Soriano 
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LIRIEL poster design—Luanne Seymour Cohen 

INDIAN SPRINGS label design—Woods and Woods Design 

Book production—Pat Coleman, Nat Robinson, Keala Hagmann, 
Russell Brown, Mike Schuster, Jan Marti, Jim Morton, Donna Helliwell, 
Schon Carlisle, Lynn Edwards, Ottmar and Venus 

Botticelli Venus Photograph—The Bettman Archive 

Adobe Illustrator 88 Video Demonstration—Pedersen Associates 

Technical assistance—Glenn Reid, Mike Schuster, Russell Brown, 
Andy Shore, Tom Baffico 

Quality assurance testing—Alicia Buelow, Laura Chan, Pat Coleman, 
Dean Dapkus, Laura Dower, Kim Isola, Fred Lloyd, Grant Narita, Julie 
Olson, Nat Robinson, Margaret Schafle, JoJo Soriano 

Thanks also to our reviewers: Loren Archer, Tom Baffico, Liz Bond, 
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