
Delivering the Curriculum Through 

Creativity™

Introduction

Digital Video is a contributory factor 

in improving the pace of learning 

allowing young people to explore their 

interests and talents, to develop and extend 

learning and communication through 

innovative ideas. Digital video offers 

unique opportunities for them to 

communicate their learning experience 

through the medium of moving images.

At Kudlian we have looked at ways in which we might use our considerable 

experience in producing award winning, high quality educational software, to 

extend the exciting new developments in DV into education. More specifically, 

to try to introduce it into the whole curriculum and not just via a media 

studies conduit, but through all curriculum areas.

The result is I Can Animate.

Many thanks to Oscar Stringer of South Street Studios for his help, input and 

for suggesting the name of the application.

http://www.southstreetstudios.co.uk

Delivering the Curriculum Through Creativity™ is a trademark of Kudlian 

Software Limited.

QuickTime, iMovie, iDVD and iLife are trademarks of Apple Computer, Inc., 

registered in the US and other countries.

All other trademarks are acknowledged.

This document is copyright © Kudlian Software Limited 2006

This manual documents the features in I Can Animate – Version 1.2.0
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System Requirements

A Macintosh computer running Mac OS X 10.3 or later, a minimum of 256 MB 

of memory is recommended.

iLife ‘04 containing iMovie version 4 or higher if you wish to export and edit 

an iMovie project.

The I Can Animate application requires around 3 MB of disc space.

User Requirements

To be generally familiar with using the Mac OS X operating system, launching 

applications, opening and saving files.

Installation

• Insert the CD ROM into the CD/DVD ROM drive.

• Run the Install I Can Animate package and follow the instructions in the 

installer.

• Once installation is complete, run the I Can Animate application from the 

Applications folder on your computer.

• Choose Register Software… from the I Can Animate application menu.

• Enter your details and the serial number which can be found on the licence 

card included in the software pack.

• If you have correctly entered your serial number then the Register button 

should become enabled. Click on the Register button, you should only 

need to do this once.
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Quick Start Guide

For those of you who want to get started on creating a short stop frame 

animated movie without getting too involved with all the features of the 

software this quick tutorial will guide you step by step through the process. I 

Can Animate allows you to create stop frame animation by either capturing 

pictures from a camera or by creating drawings. You can also use both 

techniques together.

Using a Camera

I Can Animate currently requires a camera that is plugged into the Firewire 

port on your Macintosh. Suitable cameras include a DV camcorder, an Apple 

iSight or an alternative Firewire web cam. The advantage of using an iSight is 

that they are relatively cheap and easy to set up but the image quality is not 

as good as using a DV camcorder.

If you are using a DV camcorder then we recommend you check the following 

points to ensure that your camera behaves well for use with our software.

• Remove the tape from the camera. Some cameras will turn themselves off 

after a couple of minutes if a tape is left in the camera when set to 

recording, you will not require a tape in the camera when using I Can 

Animate.

• Disable Demo mode. Some cameras have a ‘demo’ mode which displays 

the facilities of the camera if it is left unattended for a couple of minutes. 

This feature is only really useful when the camera is set up for display in a 

shop.

• Connect the camera to its mains power supply. Some cameras will happily 

allow you to work off batteries while the battery is charge, some however 

will turn off after a couple of minutes. You may be able to configure this for 

your camera, but we would still advise that you use the power supply.

• Position the camera so that it is not easily moved, this is really important 

when capturing a series of frames. We would advise that you use a tripod to 

mount the camera. Proper video tripods can be quite expensive but you 

don’t need one of those for this purpose, a small table tripod will be quite 

adequate. A tripod will also give you more flexibility when positioning the 

camera. If you are using an iSight or web cam you might want to use some 

sticky tape to stop the camera from moving.

• Check that another application isn’t using the camera. Typically this might 

be iChat or iMovie.
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• Before running I Can Animate you must plug your camera into the 

computer and switch the camera on. If you are using a DV camcorder you 

will probably need to set this to the recording mode.

• Launch the I Can Animate application.

When the application launches it configures itself appropriately depending on 

whether there is a camera available. If there is then I Can Animate should 

display what the camera can see in the Preview and the Capture button 

should also be enabled.

The preview can be set to either display the camera, the currently selected 

frames or both the camera and the frames.

Note: If you click on the Play button to view your movie then I Can Animate 

will automatically switch to the Frames view. Click on Camera to switch back 

to the camera view.

To Capture a Frame

• To capture a frame, click on the Capture button. You can also use 

the keyboard shortcut Command-Return or the number 1. You can 

also use the numbers 2 to 9 to capture that number of frames if you 

want the action to pause for a small time.

When you have captured a frame, a small thumbnail will appear in the 

Frames View at the bottom of the main window.

• Make some small appropriate changes to the items you are animating and 

capture another frame.

• Continue to do this until you have finished the action you wish to create. 

You should also regularly save your work.

• To save your work, choose File > Save from the menu bar. A save sheet 

will open asking you to choose a location and a file name for your project.
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To Preview your Movie

• Click on the Rewind button to select the first frame you captured.

• Click on the Play button to play back your sequence of frames.

Clicking on the play button toggles playing on and off. When I Can 

Animate reaches the end of the sequence of frames it stops playing 

the movie. If you click play when the last frame is selected then I Can 

Animate will automatically rewind to the beginning of the frame sequence and 

start playing the movie again.

You can also toggle playing the movie by using the Spacebar on the 

keyboard.

Sharing your Movie

Once you have created your movie you will probably want to share this with 

others. To do this:

• Choose File > Share… from the menu bar.

A sheet will open that allows you to choose to export as either a QuickTime 

movie or as an iMovie project.

• Click on the appropriate format in the tool bar at the top of the sheet.

• If you want a QuickTime movie then you can also choose from a range of 

presets that affect the size and quality of the exported movie. If you choose 

to export as an iMovie project then you also have the choice to Launch the 

iMovie Project.

• When you have made your choices, click on the Share button.

A save sheet will then open asking you to choose a name and a location to 

save your QuickTime movie or iMovie project.
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Finding Your Way Around

Launching I Can Animate opens an untitled project window.

The main part of the project window comprises of the preview area. The 

preview can display either the video feed from the camera, a selection of 

frames or both the camera and a selection of frames together.

If a suitable camera is plugged in and turned on then the preview will 

automatically default to Camera view.

Clips and Frames View

This displays the Clips or Frames in your I Can Animate project.

Clicking on Clips switches the view to display each of the clips in the project.

Clicking on Frames switches the view to display all of the frames that make 

up the currently selected clips. You can also use the arrow keys on your 

keyboard to move the selections forwards and backwards.
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When you have multiple frames selected then the last four frames in the 

selection will be all displayed in the preview window at the same time, 

showing the onion skinning effect on the capture frames.

Clicking the Play button will play the selected clip. If more than one Clip is 

selected then the whole selection of clips will be played.

Preview Settings and Onion Skinning

If you choose to preview both the camera and frames then you will see the 

currently selected frame and the feed from the video camera. This technique 

is called onion skinning. Onion skinning is a useful technique that allows you 

to view the progressive movement of an object.

Each time you capture a new frame it is added to the end of the clip and the 

frame selection will advance so that the new frame will become part of the 

selection. The preview will now show both the feed from the camera and the 

selected frame although until you move the objects being animated  you 

might not see the onion skinning effect.

You can change the relative opacity of the camera to the selected frames by 

using the slider control below the View switches. This slider is only enabled 

when the view is set to Both.

You may also find this feature useful if you inadvertently move your model or 

camera, allowing you to reposition either with reasonable accuracy.

Page 7



Compositing

Each frame in I Can Animate can have up to three layers. These layers are 

then composited to form a single image. This technique facilitates a number 

of different effects. The diagram below illustrates how each of the three layers 

are composited one on top of the other.

Background Layer

A background picture can be loaded by 

choosing File > Load 

Background… from the 

menu bar. A background 

picture will not be seen if 

there is also a captured 

layer and there is no chroma 

key mask. Please refer to the 

section Chroma Key 

Backdrops for more details 

on using a chroma key 

mask.

The background picture is a 

property of the currently selected 

clip. The background image is 

then used for all frames in the 

clip. If you want to use a different 

background picture, then you will 

need to create a new clip.

Although each frame in a 

clip uses the the same 

background picture, you 

can modify the zoom and 

position of the background 

picture on a per frame 

basis. Please refer to the 

section Background Picture 

for further details.

Captured Layer

This layer contains the 

image that has been 

captured from a camera. If a suitable camera is plugged into your computer 

when I Can Animate is launched, then the preview will default to showing the 
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current image from the camera. You capture this image by clicking on the 

Capture button, when you do this I Can Animate automatically creates a 

frame and adds the captured image to the capture layer.

Aside: When a new frame is created it is automatically added to the end of the 

currently selected clip, if there is no clip selected then I Can Animate will 

automatically create a new clip and make it the current clip before adding the 

new frame into it. This is what happens when you first capture a frame in a 

new project.

Drawing Layer

The drawing layer allows you to create drawings using a number of different 

drawing tools. The drawing tools are detailed in the Drawing section.

The drawing layers sits on top of the captured layer. This means that you can 

add graphics to captured frames. The example movie Caterpillar makes use 

of this effect. The smoke clouds were added as drawings after the frames were 

captured.

The drawing layer also allows us to remove parts of an animation that we do 

not want to see, the example file Aeroplane1 shows an aeroplane flying 

across the sky, but we can see the rod supporting it. Compare this to the 

example file Aeroplane2. Exactly the same piece of animation has been used 

but, we have added a mask using the drawing tools to remove the string. 

Please refer to the section Special Effects Using the Chroma Key for further 

details on this technique.
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Clips and Frames

I Can Animate allows you to organise your frames into clips. An I Can 

Animate project contains a number of clips and each clip contains a number 

of frames. This is very similar in concept to iMovie. We recommend that you 

create a new clip every time you want to create a new shot. This makes 

keeping track of your frames much easier. Each clip in I Can Animate is also 

an individual clip when exported to iMovie.

When you create or capture a new frame, this frame is added to the currently 

selected clip. If there is no clip selected, (which will be the case when you 

start a new project), then a new clip is automatically created and selected, the 

new frame is then added to the new clip.

Viewing the Clips

• To view the clips in a project, click on the Clips segment button just above 

the clips / frames view.

The default thumbnail for a clip will be the same as the first frame in the clip. 

It also displays the number of frames in the clip and time duration for the clip 

when it is exported. The time duration of the clip is formatted to show 

minutes:seconds:frames and is dependent on the number of frames in the clip 

and something called the Limiting Factor which is discussed further in the 

section Limiting Factor.

To Create a New Clip

• Either choose Clips > Add Clip from the menu bar or click on the Add Clip 

button which is displayed when the Clip tab is selected.

A new empty clip will be added to the clips view and will also become 

selected. Any new frames added will now be placed into this clip. A clip can 

contain any number of frames.

In order to edit the frames in a clip, first click on the individual clip to select it, 

then switch back to the frames view.
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Clips Settings

Each clip has its own set of properties, 

these are currently; a name, a 

background picture and a limiting factor.

• To change any of the clip settings, 

select the clip(s) for which you wish to 

change the settings and ensure that the 

Clip tab is selected. The current 

settings for the clip(s) will be displayed 

in the clip tab.

Clip Name:

• Click in the text field labelled Name: 

and enter the name you wish to give to 

the clip. This does not have any affect 

on the movie other than offering a way 

to help you identify your clips. This 

name is also used when exporting to an 

imovie project.

Background Picture:

Each clip can have its own background picture. A background picture can 

only be seen if either the frame has no captured image or it has a chroma key 

colour set. To set the background picture:

• Choose File > Load Background… from the menu bar. A file open sheet will 

appear allowing you to choose a graphic file for the background.

Limiting Factor:

The limiting factor determines the duration that a frame is displayed when 

exported as a QuickTime movie or the number of times the frames is 

duplicated when exporting to iMovie. The default setting of 2 is usually 

suitable for most animations, it effectively means that you are working with an 

approximate frame rate of 12 or 15 frames per second for PAL and NTSC 

respectively. If you increase the limiting factor the clip will play slower. A 

more comprehensive description of this feature is described in the section 

Limiting Factor.

Add Clip:

This is a convenience button that allows you to add a new empty clip to your 

movie. It duplicates the functionality of the Clips > Add Clip item in the menu 

bar.
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Frame Settings

Each frame has its own set of settings, 

these are currently; use a chroma key, a 

chroma key colour and the chroma 

tolerance. You can also set a zoom for a 

background picture if it is present and 

also adjust the position of the 

background picture for each frame.

• To change any of the frame settings, 

select the frame(s) for which you wish 

to change the settings and ensure that 

the Frame tab is selected. The current 

settings for the frame(s) will be 

displayed in the frame tab.

Chroma Key:

If you have shot your frames against a 

chroma key background then you can 

turn on this feature so that a background picture 

can be seen behind the subject.

• Click on the Use Chroma Key check box to turn 

on this feature.

Chroma Key Colour Models:

I Can Animate uses four different methods for 

calculating which colours should be used for the 

chroma key mask. These are: From Colour, Red, 

Green and Blue. There is also a default setting of 

Automatic where I Can Animate automatically 

selects one for the four colour models.

If you need to select a chroma key colour 

manually from a captured frame then:

• Click on the (by default green) colour well to 

open the colour picker. The Colour picker has a magnifying glass near the 

top left corner, you can use this to select the chroma key colour in your 

frame by clicking on the magnifying glass then click on the chroma key 

background in your frame. This picks up the exact colour from your frame.

Note: You must also load a background picture into the clip, this is detailed 

on the previous page. Please refer to the section Chroma Key Backdrops for 

further details on using the chroma key feature.
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Chroma Key Tolerance:

This slider enables you to set a tolerance for chroma key colour. Ideally you 

will want to set this as small as possible so that all of the background is 

shown. If you set it too high you may find that some of your foreground 

subjects start to disappear too. If you need to set it very high it is because 

your chroma key background is not evenly lit. Please refer to the section 

Chroma Key Backdrops for tips on using a chroma key background.

Background Picture:

For each frame you can change the zoom and pan on the background picture. 

In order for these controls to be enabled you must have a background picture 

loaded into the current clip and the chroma key setting must be turned on if 

you have a captured image from a camera.

Setting the Zoom of the Background Picture:

• Click and drag on this slider to change the zoom of the background picture.

Setting the Position of the Background Picture:

• Move the cursor to the main preview. The cursor should change to an open 

hand indicating that the picture can be moved.

• Click and drag to move the background picture around. You probably won’t 

want to do this unless you have zoomed in on the picture as you will get a 

white border where there is no picture.

• If you want to position the picture exactly back to the centre of the preview 

click on the Reset Values button.

Tweening the Background Settings:

As you may have gathered, because you can set a different zoom and pan for 

each frame, it is possible to have the background picture appear to move as 

the movie is playing. The question is how can we do this so that the 

movements look smooth and are also quick and easy to set up? This is where 

we do some tweening!

Try the following example:

• Create a number of frames where you can see the background picture. The 

example file Ball provided on the I Can Animate CD ROM can be used.
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• Select all the frames by using the keyboard shortcut Command–A.

• Select the Frame tab and zoom in the background picture. This will set the 

zoom for all the frames.

• Then click on just the first frame to select only that frame. Click in the 

preview to adjust the position of the background for the first frame.

• Then select the last frame and set the position of the background to be 

somewhere different to the first frame.

• Finally, select all the frames again and click on the Tween button. This will 

make all the background settings increment from the first frame to the last 

frame in the selection. Click on the Play button to see the effect.

You can also make the zoom settings different for the start and end frames 

too, we just made them the same in the above example. You also don’t have 

to do this for all the frames, you might only want to do it for a smaller 

selection of frames.

Duplicating Frames

One of the powerful features of I Can Animate is it ability to allow you to 

duplicate frames in a number of ways. Firstly you can just duplicate a single 

frame which will be inserted after the selected frame, but you can also 

duplicate a selection of frames and also have them reversed as they are 

inserted. This is particularly useful if say you have animated an eye closing 

and then just want to use the same frames again to show it opening, but 

obviously we need the frames to be inserted in reverse order.

Duplicate Frame:

To duplicate a single frame you must have only one frame selected.

• Select the frame you wish to duplicate.

• Choose Frames > Duplicate Frame from the menu bar. Alternatively you 

can use the keyboard shortcut Command–D.

The frame is inserted next to the original frame and the duplicated frame then 

becomes selected itself. If you wish you can drag the duplicated frame to a 

new position.

Duplicating a Selection of Frames:

To duplicate multiple frames you must have more than one frame selected.

• Select the frames you wish to duplicate.
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• Choose Frames > Duplicate Frames… from the menu bar. Alternatively 

you can use the keyboard shortcut Command–D.

A sheet will drop down from the title bar offering a range of options you can 

choose when duplicating frames.

You can choose where you want each of the frames to be inserted and 

whether you want to reverse the order of the frames. This is particularly useful 

if you have animated an eye which has gone from open to closed and you 

want to duplicate the frames of the eye opening again, but you need the order 

of frames reversing.

The easiest way to explain how each if the options work is by looking at the 

result of duplicating the frames shown below of a falling ball, the duplicated 

frames are the ones that are then selected.

Insert after each frame produces:

This would have the effect of slowing down the animation as each frame is 

now appearing for twice as long.
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Insert after selected frames produces:

This is useful if you have a complete cycle of animation which you wish to 

reproduce.

Insert after selected frames, with Reverse order of duplicates produces:

Here you can see that the ball is now appearing to bounce back again. This is 

useful where you have animated the first cycle of an animation and wish to 

reproduce it in reverse.

Insert after selected frames with Reverse order of duplicates and Don’t 

duplicate last frame produces:

This is similar to the previous copy but we haven’t duplicated the last frame of 

the ball being squashed. This will stop the ball appearing to pause as it is 

squashed.

Remember that after you have duplicated the frames, if you don’t get the 

result you were hoping for, you can always delete frames, duplicate single 

frames again and move any of the frames around.

I Can Animate is very flexible in what it allows you to do with each frame in a 

sequence.
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Drawing

I Can Animate also features path based 

drawing tools. This means that any 

shapes created in a frame can be easily 

manipulated in duplicated frames.

There are a couple of rules to remember 

when you are using the drawing tools.

1. You can only draw into a frame.

This may seem fairly obvious, but it 

does mean that when you are starting 

with a new I Can Animate project there 

are no frames. The Drawing tab has both 

Add Frame and Duplicate Frame 

buttons which are placed here as a 

convenience.

2. You must select a shape, (or a number of shapes), in order to change their 

Fill Colour, Line Colour, Line Width or any of their other properties. You use 

the Select tool to select objects you have created.

Drawing Tools

The Drawing panel has a number of tools which you use depending on 

whether you want to select, edit or create a new shape.

Select Tool
 
 
 Freehand Tool

 Edit Path Tool
 Create Line


 Create Oval
 Create Polygon
Create Rectangle
 
 
 Create Curve

Select Tool:

The select tool is used to select, move, resize and delete shapes. To select a 

shape you must click on the line of the shape if it does not have a fill colour. If 

the shaped is filled then you can click on the fill too. By holding down the 

Command key you can add more than one shape to the selection. Any 

changes you make will then apply to all the selected shapes. You can also 
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group multiple shapes together. When a shape is selected it’s bounds are 

displayed with a blue rectangle around them. The rectangle always 

encompasses all selected shapes. The small rectangles in each corner can be 

used to resize the shapes.

Edit Path Tool:

The edit path tool allows you to move the individual points that make up a 

path. You use it in a similar manner to the select tool to select a shape, except 

you cannot select multiple objects when using this tool. When the shape is 

selected, each path point has a small rectangle over it. You can click and drag 

these points to adjust the shape.

Create Line Tool:

The create line tool lets you drag out a straight line. Select this tool, then click 

where you want the line to begin and drag to where you want the line to finish. 

When this tool is selected the cursor changes to a cross-hair.

Freehand Tool:

The freehand tool allows you to create an arbitrary shaped path. Select this 

tool, then click and drag to draw a path. When this tool is selected the cursor 

changes to a pencil.

Create Rectangle:

The create rectangle tool lets you drag out a rectangle. Select this tool, then 

click and drag to create a rectangle. When this tool is selected the cursor 

changes to a cross-hair.

Create Oval:

The create oval tool lets you drag out an oval. Select this tool, then click and 

drag to create an oval. When this tool is selected the cursor changes to a 

cross-hair.

Create Polygon:

This tool allows you to create many sided shapes, it is especially useful for 

tracing around objects on the captured layer. Click the mouse at the point 

where you wish to start drawing and then move to the second point and click 

again. A line will automatically be drawn to connect these two points. 

Continue moving and clicking until you have the desired shape. If you 

position the last point close to the starting point the tool will automatically 

close the shape. When this tool is selected the cursor changes to a pen. If you 

move the cursor out of the preview when creating a polygon then the path 

creation process will end.
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Create Curve:

This works in a similar way to the polygon tool except that each time you 

click in the drawing area a curved line is drawn between the points. When this 

tool is selected the cursor changes to a pen.

Fill Colour and Line Colour

• You need to select the shape you intend to change by either using the 

select or edit path tool. The Fill Colour button will now be enabled.

• The fill and line colour can be individually checked. This is denoted by a 

tick in the box next to each option.

To change the colour:

• Click in the colour well to select it and as you do this the colour picker will 

appear.

• Choose the colour you wish to use in the colour picker or by using the 

magnifying glass. You can also change the opacity of the fill and line colour 

using the Opacity slider in the colour picker. Your choice of colour is 

immediately reflected in the colour well and in the selected objects in the 

preview.

Line Width

• Select the shape whose line width you wish to change.

• Use the line width slider to increase and decrease the line width or you can 

type a value into the text field. The value is in points and using the slider is 

limited between 0 and 20.

End Style

This option sets the end style of the line. Choose from either Butt, Round or 

Square in the drop down list.


 
 
    Butt
 
 
 
   Round
 
 
 
   Square
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Join Style

This sets the style where two lines join together. Choose from either Miter, 

Round or Bevel. 


 
 
    Miter
 
 
 
   Round
 
 
 
     Bevel

Copy and Pasting Shapes

All of the drawn objects can be copied and pasted from one frame to another 

and from frames in one clip to those in another, alternatively you can just 

duplicate a frame using the Duplicate Frame button, but you can also choose 

specific objects from frames and copy and paste them to another single frame 

or to a selection of frames. This can considerably speed up the process of 

animation.

Grouping Shapes

I Can Animate allows you to group shapes together. This is very convenient if 

you have drawn an object which is made up of lots of different shapes which 

you then want to copy or move together.

To group shapes together:

• Select at least two shapes that you wish to group. To select multiple shapes 

hold down the Command key while clicking to select the shapes.

• When you have all the required shapes selected, choose Drawing > Group 

from the menu bar.

When shapes are grouped, if you select any shape in the group then all 

shapes in the group are also selected. This means any changes you now 

make to one shape will apply to all shapes in the group as they are all 

selected. If you want to just make a change to one shape in the group then 

you will need to ungroup the shapes first.

Ungrouping Shapes

To ungroup a group of shapes:

• Select the group of shapes you wish to ungroup.

• Choose Drawing > Ungroup from the menu bar.
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Arrange the Order of Shapes

As you create and add new shapes to your drawing you will notice that each 

new shape appears on top of any previous shapes. I Can Animate allows to 

arrange the order in which the shapes are drawn. To do this:

• Select the shape(s) whose order you wish to change.

• Choose one of the re-ordering options from the Drawing menu on the menu 

bar. The re-ordering options are: Bring Forward, Bring to Front, Send 

Backward and Send to Back. Depending on where the shape(s) are 

positioned in the layering order will affect which of these options is 

available.

Special Effects Using the Chroma Key

In the example file Aeroplane2 we have masked out the rod that is supporting 

the aeroplane. The polygon tool is especially useful for tracing around items 

that you want to remove.

Removing Unwanted Artefacts

If you are using a chroma key then the trick here is to set either the line or fill 

colour to the same as that used for the chroma key depending how big the 

item is that you want to mask out. If you are using a fill colour then you 

probably want to turn off the line colour. If you toggle the Use Chroma Key 

switch for a frame you will be able to see the object that you are drawing that 

will act as a mask. When you turn the chroma key back on the items that the 

drawing covers will be removed and the background will show through.

You don’t necessarily need to use a chroma key to remove unwanted items. 

So long as your background is fairly even in colour and not too complicated 

you can still use shapes to remove items in the capture layer.

More Onion Skinning…

As explained earlier, if you have more than one frame selected then up to the 

last four frames will preview composited on top each other, we call this 

technique onion skinning. When you have multiple frames selected you can 

still edit the graphics in the last frame, this helps you to position and move 

the shapes while still viewing their positions in the previous few frames.
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Camera Settings

• Choose Window > Camera Settings from the menu bar to open the Camera 

Settings panel as shown below:

This panel enables to switch on chroma key when previewing the live video 

feed from the camera, opens a QuickTime video compression settings 

dialogue for controlling various aspects of your video camera and to also 

configure and set a time lapse for capturing images from the camera.

Use Chroma Key:

This setting works in much the same way as it does on a frame. Please refer 

to the section Chroma Key Backdrops for further details.

Note: This will have no effect if there is no background picture for the 

currently selected clip. When you capture an image the settings for chroma 

key, the chroma key colour and its tolerance are all copied to the new 

captured frame.

Transform Image:

You can use this pop-up menu to transform the image from the camera. By 

default this is set to None. You can choose to either Flip Vertically, Flip 

Horizontally or Upside Down. Upside down is probably the most useful as 

some tripods allow you to mount the camera upside and in doing so you can 

get the lens very low to the work surface.
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Device:

This pop-up button list all the current devices you can select for capturing. 

Generally there will only be one device listed here, and it should reflect the 

name or model of your camera.

Configure <camera model>…

Clicking on this button opens a QuickTime settings dialogue for your 

particular camera. You may be able to use this to configure certain aspects of 

your camera. Be aware that using this dialogue inappropriately may mean 

that the video feed may stop working. If this happens, then you will need to 

quit I Can Animate and re-launch the application. For this reason we do not 

save the settings from this dialogue in the user’s preferences.
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Time Lapse

I Can Animate also allows you to set up a camera for time lapse photography. 

Time lapse means you can set a time interval where by a frame is 

automatically captured after each time interval has elapsed. It is especially 

effective for observing objects that change very slowly over a long period of 

time, for example plants growing, fruit decaying. You can only set a time 

lapse on a single open project.

To use this feature:

• Select the I Can Animate project that you wish to use for time lapse. This 

will not be necessary if there is only one project open.

• Choose Window > Camera Settings from the menu bar to open the Camera 

Settings panel.

• Enter the time interval in the Time Lapse text field and choose the 

appropriate time unit from the pop-up menu. Note: 30 seconds will be 

interpreted the same as 0.5 minutes.

• Click on the Start button to start the time lapse. The Start button will be 

disabled if I Can Animate cannot start a time lapse, for example if you do 

not have a camera plugged in, or if the view setting is set to Frames. The 

first frame is taken after the time lapse interval, if you want to capture a 

frame before then, you can click on the Capture button at any time.

• Click on the Stop button to stop the time lapse.

For this to be used effectively, you are going to need to have a Macintosh 

switched on and left undisturbed for a long period of time. You will also need 

to ensure that the subject you are filming will be left consistently lit during 

that time.
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Sharing and Exporting

I Can Animate can export your project as both a QuickTime movie and also 

as a complete iMovie project. To do this:

• Choose File > Share… from the menu bar. The share sheet will appear from 

the title bar of the project window.

Exporting a QuickTime Movie

• Select the QuickTime item in the tool bar of the sheet to export your clips 

as a QuickTime movie.

• Choose an appropriate preset from the pop-up menu for the type of movie 

you want to export.

Full Quality DV

Select this item if you intend to use the movie in iMovie, iDVD or any other 

application where the quality of the final movie is important. This option may 

create quite a large file. Note that this does not create a file that contains just 

a pure DV stream, it is a QuickTime movie that uses DV compression on each 

frame.

Email, Web and CD-ROM

Select one of these settings to export a movie appropriate for one of these 

applications. All of these settings will create a movie compressed using 

MPEG 4.
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Exporting an iMovie Project

• Select the iMovie item in the tool bar of the sheet to export your clips as an 

iMovie project.

• You can optionally choose to launch the iMovie project. To do this check 

the appropriately labelled check box.

Share Selected Clips Only

For both QuickTime and iMovie you can choose to just share just a particular 

selection of clips. If you wish to do this you will need to switch to the Clips 

view and select the required clips before opening this sheet.

Sharing the Clips

Once you have made your choices:

• Click on the Share button. The share sheet will close and a save sheet will 

open in its place.

• Choose a suitable location and file name for your exported movie or iMovie 

project.

• Click on the Save button.

Note: If you are exporting an iMovie project then I Can Animate looks for a 

version of iMovie on your Macintosh. If it finds iMovie HD, which is installed 

as part of iLife ‘05, then it will create an iMovie project in the new iMovie HD 

format otherwise it will use the previous iMovie project format.
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Preferences

I Can Animate has a number of preferences which can be configured for each 

user.

Captured Image Quality:

This slider allows you to alter the quality of the captured images from the 

camera. The further you move the slider to the left then the quality of the 

captured images becomes compromised but the size of your saved 

documents might be considerably smaller.

Note: This setting will only affect any new frames that you capture, it does not 

effect frames that have already been captured.

Moving the slider to the right increases the quality of the images but only very 

slightly, the file sizes however can increase quite considerably.

Video Standard:

This pop-up button sets the default video standard used in a project. If you 

live in the US, Mexico, Japan or some parts of Canada then you probably 

want to change this to NTSC. Most other countries use PAL which is the 

default setting. You can change the setting after creating a project but the 

quality of the final output may be compromised. This setting also affects the 

working frame rate when exporting to QuickTime and iMovie.

Limiting Factor:

This pop-up menu allows to you set the default limiting factor when a new clip 

is created. You can change the limiting factor on a clip at any time. Please 

refer to the section Limiting Factor for further details.
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Play Capture Sound

This switch allows you to turn off the shutter sound which is played each time 

a frame is captured.

Revert to Default Settings

Click on this button to return all the settings to their default values.

Printing
I Can Animate will allow you to print the currently selected frame.

• Choose File > Print… from the menu bar. The print sheet will appear from 

the title bar of the project window where you can make any appropriate 

changes before printing.
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More Advanced Features

Chroma Key Backdrops

A chroma key process allows you to replace a colour in a picture or movie 

clip with a completely different image. This process is sometimes called Blue 

Screen Compositing. Chroma keys are commonly either blue or green. In 

digital video it is better to use a green screen. The reason for using either blue 

or green is because these colours are not present in flesh tones, so they are 

ideal for placing an image behind a person.

The illustration below demonstrates the effect that can be achieved.

Since we first released I Can Animate we have extended the chroma key 

feature to give much improved results when keying against either a green, 

blue, or if need be, a red background. If you have an existing project which 

uses chroma key then you may need to make some small adjustments.

I Can Animate uses four different methods for calculating which colours 

should be used as the chroma key mask. These are: From Colour, Red, Green 

and Blue. The original method we used was From Colour. The default setting 

for the colour models is Automatic. With this selected I Can Animate picks 

one of the four models automatically which should provide good results for 

most of the time, but you can select a specific colour model if you wish. The 

following section discusses each of the colour models and looks at the pros 

and cons of each.
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From Colour

This was the model we used in earlier releases of I Can Animate. It requires 

you to use the colour picker to pick a colour from either a captured frame or 

from the preview.

Pros:

• You can choose any colour you wish for the chroma key from anywhere on 

a frame.

• The chroma key colour can be different for each frame.

• Earlier I Can Animate projects used this model so it may work better with 

those projects.

Cons:

• You need to manually select the colour using the colour picker. If there is 

any variation in the chroma key colour over a range of frames then you 

may need to keep selecting the colour for each frame, which is quite time 

consuming.

• If the tolerance setting is too high then colours that appear grey may 

become part of the key and disappear.

• It doesn’t always work well if moving projects from one type of computer to 

another.

Red, Green, Blue

These models all work in effectively the same way for each of the respective 

colours. If you know that the background is one of these colours then you can 

just select this colour model without having to keep using the colour picker.

Pros:

• Is easier to use; you don’t have to manually selecting the chroma key 

colour and is less time consuming.

• Can give substantially better results and is technically faster.

Cons:

• The chroma key colour must be either red, green or blue and ideally the 

chroma key background should be well lit.
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Automatic

This setting looks at the colour which is set in the colour well, (green by 

default), and then decides with colour model to use. If the colour in the colour 

well appears to be either red, green or blue then I Can Animate will use that 

colour model, if it doesn’t appear to be close enough to either red, green or 

blue then it will use the ‘from colour’ method with the colour set in the colour 

well.

Pros:

• Tries to make the best choice of model for you based on the colour you set 

in the colour well from the colour picker.

Cons:

• It might not necessarily make the best choice of colour model in which case 

you can manually select which model works best.

Regardless of which method you use, you will always get better results if you 

follow the tips below.

Tips on Using a Chroma Key Screen 

Make sure the chroma key screen is flat with no wrinkles and is uniformly lit. 

Shadows on the screen will cause poor results. This is one of the most 

important areas to consider.

Try to get the person or subject to stand away from the screen in order to 

avoid casting shadows.

Make sure the person or subject is well lit but not directly from the front as 

this may also cause shadows to appear on the screen.

Ensure that the person or subject is not wearing anything that includes the 

colour of the screen or that piece of clothing will have part of the background 

appearing on it.

Experiment with having the subject slightly out of focus as this can help blend 

the edges of the subject with the background.

Tolerance

When you capture a subject in front of a chroma key background, I Can 

Animate will attempt to make anything that is the colour of the background, 

(usually blue or green), transparent, i.e. it is not drawn. In this way we can 

then see the background behind the subject. However, no matter how careful 

you are when filming the clip, the background will not be exactly the same 

colour all over. This means that a certain degree of tolerance is required to 

determine what range of colours should be considered to be in the 

background.
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The Tolerance slider determines how far away a colour can be from the 

chroma key colour in order to make it transparent. The more tolerance you 

add, the more likely that parts of the subject will start to disappear.

Tip: Try to set this slider as low as possible while ensuring that all of the 

chroma key colour disappears and that you can see all of the background.

If a colour is just outside the range of tolerance then I Can Animate will 

attempt to blend that colour with the background, this should give an 

improved appearance around the edges of the subject.

The diagram below illustrates the idea behind this.

Note: The tolerance setting will give slightly different results between using for 

example the From Colour model with a green colour and the Green colour 

model.
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Limiting Factor

Those of you unfamiliar with animation, and also any professional animator, 

may be wondering what we mean by the limiting factor, and that’s because 

we’ve made it up! We have been unable to get a name for this even from the 

professionals, but we know that they use this technique and that it is part of 

what they would call limited animation.

Frame Rates

All types of moving image have what is called a frame rate, this is the number 

of frames that are displayed each second. In cinema films this is 24 frames 

per second (fps), but television in the UK and many other countries uses 25 

fps. America, Canada, Mexico and Japan has a format called NTSC and this 

uses 29.97 (nearly 30) fps.

Why is this important? Because it’s about time! When you are making a 

movie you need to think about time and how long you want each clip to last. 

This means that depending on whether you are working with PAL (25 fps) or 

NTSC (effectively 30 fps) you need to think about how many frames are 

required to produce a clip of a given length in time.

Let’s say you want 10 seconds of animation. If you are working in PAL that 

means you would need to capture 25 x 10 = 250 frames, (or 300 for NTSC). 

That’s quite a lot of frames for just 10 seconds. Professional animators when 

working with film have a technique whereby they are able to cut down the 

number of movements they need to set up by capturing two frames at once, 

they then make the movements of the characters twice what they would be 

normally. If they really want to cut down their workload they can even capture 

three or four frames at a time, but then the action would appear quite jerky. 

This is part of a technique called limited animation.

When using a computer, you don’t actually need to keep capturing two, three 

or four frames, (unless you deliberately want to freeze the image for a 

moment), instead you only need to capture one frame, but I Can Animate will 

duplicate your captured frames for you when it exports them to iMovie, in 

effect slowing down the action. The number of frames which it duplicates is 

what we call the limiting factor. The higher the limiting factor, the slower your 

action will appear in QuickTime or iMovie.

So returning to the mathematics of the number of frames you need to capture; 

for 10 seconds we need 10 x 25 = 250 frames when exported, by using a 

limiting factor of 2, we only need capture half as many frames, 250 / 2 = 125 

frames. If that is still too many then you can set the limiting factor to 3 and 

only capture 250 / 3 = 83 frames (approximately).

The default limiting factor for each clip is set to 2. You can adjust the limiting 

factor for each clip.
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Appendix

Organisations Offering Training on Animation

• South Street Studios – http://www.southstreetstudios.co.uk

Suppliers of Animation Accessories – UK

Aardman Animations use a clay called Newplast which is available from 

Newclay Products Ltd.

http://www.newclay.co.uk

Tel: 01626 835700    Fax: 01626 835707

Woolton Armature Wire Supplies,

4 Longworth Way

Woolton Park

Liverpool  L25 6JJ

Tel: 0151 428 5097    Fax: 0151 421 0907

Suppliers of Animation Accessories – US

Van Aken International – http://vanaken.com/home.html
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