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Welcome to the HexaSuper2, an easy to use 3D

graphics software featuring a wide variety of functions,

including the world's most advanced Curved Surface

and 3D Manga. We hope you enjoy using

HexaSuper2.

In order to use HexaSuper2 you need to have an

understanding of the basic operations of a Macintosh

computer. Please refer to the documentation that

comes with your computer.

System Requirements

CPU: Power PC (a G3 or G4 is recommended)

Memory: 32MB or greater

OS: Mac OS 7.5 or later

Extension: QuickDraw 3D 1.5 or later

Starting HexaSuper2

(1) Start your Macintosh.

(2) Double click the HexaSuper2 icon to start

HexaSuper2.

(3) The following dialog box appears. Press "Not Yet"

to use the demo of HexaSuper2.

(4) HexaSuper2 starts and a new document window,

as shown in the figure on the next page appears. With

the demo version, you cannot save or export any files,

except those in POV-Ray format.

NOTE

There is no problem using HexaSuper2 on the newer

systems that come with an iMac or iBook. However, if

running Mac OS 7.5 or 7.6 and QuickDraw3D is not

installed, an error message will appear and the

software will fail to start. In this case, install

QuickDraw3D 1.5 or later, or QuickTime 3.0 or later

released by Apple Computer. 

Registration

HexaSuper2 is shareware. You have to register

HexaSuper2 to use its full functions. To register

HexaSuper2:

(1) Visit http://www.HexaSuper.com/

(2) Click the "Register" link and purchase a user

license for HexaSuper2.

(3) Shusaku Co., Ltd. will send you your serial number

by E-mail.

(4) Restart HexaSuper2 on your Macintosh.

(5) Input your name and serial number in the Register

HexaSuper2 dialog box, then press Register to

complete the registration.

Getting Started



1 1

User Support

Support for this product is offered to registered users

via E-mail and postal mail.

E-mail: shusaku2@cd.mbn.or.jp

Postal Address: 

Shusaku User Support Division,

3-23-13-206, Kugahara, Ohta-ku, Tokyo,

146-0085, Japan.

Please include the following details to allow us to

provide clear and helpful support:

(1) Serial No. of HexaSuper2. 

(2) Model of Macintosh you are using. 

(3) Information on operating environment 

1. Mac OS version.

2. Unused block size of Mac OS memory.

3. Number of colors displayed by the system.

4. QuickDraw3D version

5. HexaSuper2 version

6. Application memory size of HexaSuper2

7. Unused block size of HexaSuper2 memory

(The above information can be obtained by choosing

Apple > System Information when HexaSuper2 is

running)

(4) Detailed description of the problem or

question. 

(5)Your mailing address.

Please refer to our Web site for the latest information

on HexaSuper2.

http://www.shusaku.co.jp/
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About This Manual

(1) Document Conventions

The following document conventions are used

throughout this manual.

1. Menus, commands and dialog boxes

Names of menus and buttons are written in title cap.

e.g. File menu, Apply button.

2. Menu hierarchy

The hierarchy of menus are shown as in the

following example.

e.g., Edit > Select > Select Wire

In this case, choose Select from the Edit menu and

then choose Select Wire to select wires.

(2)  Basic operations

The following are definitions of some of the basic

operations used throughout this manual.

1. Mouse input

i. Click

To press and release the mouse button once without

moving the mouse.

ii. Double-click

To press and release the mouse button twice quickly

without moving the mouse.

iii. Drag

To position the mouse pointer over an object, press

and hold the mouse button, then move the object to a

different location and release the button.

2. Key input

i. The terms enter, shift, option and command

refer to the enter key, shift key, option key and

command key (apple key) respectively.

ii. Certain operations require two or more keys to be

pressed at the same time.  e.g. command-Nrefers to

pressing the command and N keys simultaneously.

3. Combined mouse and key input

i. Shift-click

To click the mouse button while pressing the shift key.

4. Others

i. Show/hide

This refers to the showing and hiding of things such as

an object or window.
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Tutorials
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In this chapter, you will learn how to use HexaSuper2

by practicing various techniques demonstrated through

tutorials. There are five tutorials.

1-1 Creating a shape from objects

Making a cute penguin using the basic functions of

HexaSuper2, such as creating various shapes from

solid objects and moving vertices.

1-2 Using Manga mode

Creating 3D outlines from a 2D illustration using the

3D Manga function.

1-3 Using Input Line and Select/Move Area

Tools 

Creating a desk lamp using advanced functions of

HexaSuper2 such as Polyline and Select/Move Area

tools.

How to Do Tutorials
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1-4 Using Symmetry mode

Creating a realistic human face using various

techniques and some of the more advanced functions

of HexaSuper2 such as Symmetry mode.

1-5 Rendering with POV-Ray

Creating a realistic picture (rendering) using the

freeware POV-Ray that comes with this software

package.

The tutorials start off fairly easy with 1-1 and 1-2, and

then however, as we move on to 1-3 and 1-4 they

become a little more difficult. We recommend that you

work through these tutorials in order starting with 1-1.

However, 1-5 is also easy. If you are a 3D-beginner,

try 1-1 first and then 1-5, before proceeding to tutorial

1-2. Surely, this will increase your appreciation of the

3D world.

For details on each menu and tool, refer to Chapter 2

and 3.
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Creating "The Hexa-penguin"

Let's create a cute penguin from a basic sphere. In this

tutorial, you will learn how to use the Select/Move

Area tool and Curved Surface function.

Original design: Koji Ando

(1) First, let's learn how to display different

views.

After starting HexaSuper2, drag the mouse pointer

within the the Angle window. The green grid cube

moves.

The viewpoint rotates around the grid cube.

To show the front, side or upper view, click the cross

sections of the Angle window. 

1-1 Creating a Shape from Objects

Indicator

Top

Left side Front Right side

Bottom 

Distance Meter
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Hold down the space key and drag the mouse pointer

in the document window. The viewpoint moves

parallel to the monitor.

Drag the slider of the Distance Meter located at the

bottom of the Angle window.

Dragging the slider towards the right decreases the size

of the view and dragging towards the left increases it.

Finally, choose View > Initialize Viewpoint to reset

the viewpoint to its original state.

You can also use the tool from the Tools

window to zoom in or out.

(2) Now, let's create a sphere.

Press and hold the tool in the Tools window. If

you keep it pressed, a menu appears. Select the 

(Sphere) tool.

Hold down the option key and drag downwards from a

position just below the center of the document window

to make a sphere (which is a kind of object).

The object appears in a selected state.

(3) Moving the sphere.

Select the tool and move the mouse pointer over

the sphere. The mouse pointer shape changes to .

In this state, you can drag the sphere parallel to the

bottom plane of the grid cube (parallel to the plane

Selection frame
Handle
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with purple cross lines).

The plane with purple cross lines is called the "base

plane." Objects and areas move parallel to the base

plane.

Next, hold down the command key and drag the

sphere. The sphere moves perpendicular to the base

plane. The black line stretching from the center of the

sphere to the base plane gives you an idea of the height

of the sphere .

After practicing moving the sphere, return the sphere

to its original position.

(4) Stretching the sphere.

Drag the selection handle of the sphere. The shape of

the sphere and selection frame surrounding it changes.

Holding down the command key while you drag,

changes the shape perpendicular to the base plane.

Holding down the shift key, permits the shape to be

changed in a right-left or forward-backward direction

only. 

After practicing changing the shape, return the sphere

to its original shape.

(5) Changing the base plane.

Click the base plane button at the lower left of

the document window. The base plane changes to a

left-back plane as shown by the purple cross lines.

Base plane buttons

Drag the handle of the selection frame. Now, the shape

of the sphere changes parallel to the left-back plane.

You can change the moving and modifying direction

by changing the base plane like this.

Dragging the mouse pointer up or down changes the

height of the sphere by stretching or shrinking it.

Stretch the sphere to a height similar to that of the

sphere shown in the following picture.
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When you have finished stretching, click the base

plane button to return back to the original base

plane.

(6) Modifying the sphere shape.

Move the indicator on the Angle window to show the

sphere from a right side view. If the view is showing

an upper, front or side view, the base plane

automatically changes to a view parallel to the display.

At the moment the object looks like a rugby ball. To

transform it into the body of a penguin, we need to

shrink the top part and enlarge the bottom part.

Hold down and choose the (Medium

Range) tool.

First, enlarge the bottom of the sphere. Move the

mouse pointer over the lowest vertex. The mouse

pointer shape changes to . Then, hold down the

mouse button and drag the lowest vertex upwards. 

The lowest vertex moves along with its surrounding

vertices.

Next, drag the highest vertex upwards.

Modifying the shape in this way moves the entire

object to a position higher than the original position.

Use the tool to lower the object to a position

within the grid cube.

(7) Rotating the head.

Next, we will use the Select/Move Area tool to

select and modify an area.

With the (Medium Range) tool selected, drag the

mouse pointer across the area shown in the following

picture to generate a rectangular selection area.



2 2

1–1

Any elements within this selection area are selected.

Then, select the tool from the Tools window and

drag the selected area. If you move the mouse right or

left, the area rotates. Rotate the area towards the left as

shown the picture.

(8) Shrinking the head shape.

As in (7), select the tool and drag the mouse

pointer across the area shown in the picture to generate

a rectangular selection area.

Choose Modify > Magnify. The mouse pointer

changes shape to indicate HexaSuper2 is in Magnify

mode.

If you drag the selected area, it increases or decreases

in size. Decrease the size of the selected area to a size

similar to that shown in the picture.

Once you release the mouse button, the mouse pointer

returns to its original shape to indicate that

HexaSuper2 is no longer in Magnify mode.

You have created the penguins body and head. Move

the indicator of the angle window to check the body

shape and see how it differs from the initial sphere.

Now, take a well deserved break. 

(9) Zooming in on the penguin's head to create its

eyes.

Move the indicator of the Angle window to show a

front view of the penguin.

Then, select the tool and drag around the upper

part of the body. This magnifies the view of the upper

part.
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(10) Creating an eye.

Select the tool. Hold down the option key and

drag from the position where you think one of the eyes

should be to create a small sphere. This sphere is one

of the eyes.

Drag the mouse pointer, to create a sphere, from an

appropriate position on the head (not from a position

where nothing exists) to give a sense of depth by

making it seem like it is an integral part of the head.

Then, choose View > Undo Viewpoint. The view

returns to its original state before you used the Zoom

tool. 

Check the position of the eye using the Angle window.

(11) Creating the other eye.

Select the tool and click to select the eye. Then,

choose Edit > Duplicate. An identical eye (new

sphere) appears in a position a little offset from the first

eye.

Change the view to show the front and side, and drag

the new eye to an appropriate position.

(12) Creating the beak.

Change the view to show the front of the penguin.

Then, hold down the tool and select the 

(Cone) tool. Drag on the body to create a cone like the

one in the picture below.

Change the view to show the right side. Create a beak,

like the one in the following picture, from the cone by

adjusting its size with the tool and its direction

with the tool. 
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Rotate the view using the Angle window to check the

shape. It is beginning to resemble a penguin.

(13) Creating a wing using the Lift function.

First, hold down and choose the (Small

Range) tool. Change the view to show the right side of

the penguin.

Click the center face of the body as shown in the

picture below. The clicked face becomes selected.

Choose Modify > Lift. The following dialog box

appears. Select "Lift directly" and press the OK button.

The face is raised up. It will become one of the

penguins wings.

(14) Moving the wing.

Set the view to show the front. Drag the selected face

to the right and in a downward direction until it

resembles a wing.
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Then, set the view to side view and drag the selected

face to the left.

Note: When moving vertices.

In principle, to accurately move shapes, you should set

the view to front, side or upper view. If you move

shapes from a different view such as at a diagonal

view, the direction of the depth will be effected and it

will be difficult for you to know how they have

changed.

(15) Ungrouping the face.

Using Lift from the Modify menu grouped the four

vertices and four lines of the wing together. As a group

they always move together at the same time and it is

impossible to move each vertex or line individually.

To ungroup them select the four vertices and four lines

and choose Edit > Ungroup, then Unselect All. You

can now move each vertex and line individually.

(16) Making the tip of the wing narrower.

Move the vertices and lines to form a wing like the one

in the picture below.

Select the tool. Then, lower the highest line and

raise the lowest line of the four lines. 

At first, it is a little tricky to move the lines to the

position you desire, but do not worry, you will soon

get used to using the  tool. 

Does your penguin look like the one in the picture?

When you have finished the left wing, use the same

procedure to make the right wing. 

(17) Creating the tail.

Set the view to show the side of the penguin. Hold

down the tool and select the (Medium
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Range) tool.

Then, drag the vertex on the bottom of the penguin to

the right to create the tail.

You have now finished the penguin's body.

(18) Creating the feet from spheres.

Set the view to upper view. Then, select the tool

and drag to create a long and narrow sphere.

Next, select the tool and drag the vertices to

adjust the shape of the sphere until it resembles a foot

like the one in the following picture. Check the shape

of the foot from a side view as well. 

(19) Rotating the foot.

Set the view to show the bottom of the penguin. Then,

select the tool and drag the foot to rotate it to a

suitable angle. Next, select the tool and drag the

foot into an appropriate position for a foot.

View the foot from the side and front, and make

suitable adjustments.  

Create the other foot in the same way .
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(20) Creating a smooth surface.

The shape now looks like a penguin, except that it

appears rigid and stiff. Real penguins have smooth

bodies. To rectify this, select the tool, then

choose Edit > Select All. Next, choose Modify >

Unsharp Line. The color of the lines turn from blue to

black. From the Object menu choose Curved Surface.

The surface of the penguin's body becomes curved and

smooth.

The whole shape is now complete.

(21) Before painting the penguin.

Hide all the shapes except the body. Shift-click the

eyes, beak and feet to select them as in the following

picture. Choose View > Hide Selection. All objects

except the body disappear. (Of course, you can show

them again later.)

(22) Painting the body.

Select the tool and choose an appropriate blue for

a penguin from the color palette.

Click on the body to paint the whole body blue. Next,

select white from the color palette. Then, shift-click the

faces of the stomach area. Each time you shift-click a

face, its color turns white.
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(23) Painting the eyes, beak and feet.

Choose View > Show All. The eyes, beak and feet are

shown.

Select the tool and paint the eyes black, and beak

and feet yellow. The penguin looks cuter if you paint

part of its eyes white.

(24) Changing the view mode.

Choose Show Smooth Faces from the View menu.

Congratulations, you have completed the penguin.
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Creating 3D outlines from an
illustration

Here, we will create 3D outlines of a human face from

a 2D illustration using Manga mode. Manga is

Japanese for cartoon

(1) Start HexaSuper2 and choose  File > New In

Specified Mode > Manga Mode. A new document

window appears in Manga mode. Initially, nothing is

shown in the document window.

In Manga mode, the indicator of the Angle window is

positioned in the center as shown below. However, this

position is just for the sake of convenience. You do not

have to change the view angle, when you edit in

Manga mode the angle indicator is used only for

checking shapes.

1-2 Using Manga Mode
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(2) Choose View > Background Color and select the

Face button at the bottom of the color palette. The

Open dialog box appears. Open Tutorial 2 Picture

located in the Tutorial folder in HexaSuper2 folder. An

illustration of a human face is shown in the document

window as a background picture.

(3) To make it easier to see the illustration while you

are tracing, move the Distance Slider in the Angle

window to the left, to zoom in on the eyes, nose and

mouth. (You can zoom in or out at any time while you

are editing in Manga mode.)

(4) To specify the face direction, click the button

in the Tools window. The button changes to .

Click the button again to return to the original button.

You must choose the button with the face in the same

direction as the face or object in the illustration you are

going to trace. 

The face in the illustration we are using for this tutorial

is looking towards the left, so select the button.

If the face on the button is looking in the opposite

direction to the face or object in the illustration, the

front and back of the 3D outline is inverted.

(5) Set the line width to 2 pt by choosing Modify

> Line Width > 2pt. Any lines you draw now will be

thick enough to allow you to see them clearly. 
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(6) Select the tool and click on the lower part of

the nose. A line is displayed from the clicked position

to the mouse pointer's position. Next, click on the tip of

the nose. A new vertex appears at the position you

clicked. (For the purpose of demonstration, these lines

are thick, but under normal circumstances, the lines

you draw will be thin.)

Double-click on the upper part of the nose to finish

drawing the nose like in the picture. You have drawn a

total of two lines and three vertices.

By the way, you can change the line color. If it is

difficult to see the lines because the background

illustration is dark, choose View > View Settings to

display the View Settings dialog box. Then, select the

Environment tab, click the color square of Line

Colors/Manga mode and set a lighter color.

(7) Click the left side of the left eye and double-click

the right side of the left eye to draw a line like the one

in the following picture.

If you draw a line in the wrong position, select the

tool in the Tools window, click-select the line,

then choose Edit > Clear to delete the line. 

(8) Next, draw a line on the right eye and one on the

mouth like in the picture. There are now 5 lines.

In Manga mode, you must draw lines in pairs with one

on the left side and another on the right side. If there is

a vertex on left eye, there must be another

corresponding vertex on the right eye. An exception is

if there are lines and vertices in the center of the object

when looking at it from the front, as is the case with

the two lines on the nose.

Center Line
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(9) Drag the indicator in the Angle window. The

background illustration disappears and only the lines

you drew remain displayed. With eyes, a mouth, and a

line for the nose at the front, it is beginning to resemble

a face, isn't it? 

When you view the face from different angles, it looks

three dimensional because the depth of the lines have

been automatically calculated.

(10) Release the mouse button. The lines are again

shown in their original positions and the background

illustration reappears.

(11) The color of the vertices changes from white to

black. This means that each vertex on the right side has

been paired with a corresponding vertex on the left

side. To show lines in three dimension, not only must

there be the same number of vertices on the right side

as there are on the left side, but it is necessary to know

which vertices are paired. However, when you start

dragging the indicator in the Angle window,

HexaSuper2  automatically pairs vertices.

Let's check which vertices are pairs. Select the 

tool and move the mouse pointer near to a vertex.

(You do not have to click the vertex.) A dotted line

appears from this vertex to its paired vertex.

In the picture below, the vertices on the inner part of

each eye are paired.

Move the mouse pointer near to the vertex at the top of

the nose. No line appears because the vertex is on the

center line of the face and therefore it corresponds with

itself.
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(12) To learn more about Manga mode, delete the

lines you have drawn by choosing Edit > Select All,

then Clear.

(13) Select the tool again and trace the lines for

the eyes, nose and mouth like in the picture below.

This time, use four vertices to draw the left eye. This

seems a bit repetitious, but it is a necessary part of this

tutorial.

(14) Drag the indicator in the Angle window. This

time it does not really resemble anything, except

maybe  a one-eyed goblin.

(15) Let's see which vertices are paired together to

determine why the shape looks strange. Select the

tool and move the mouse pointer near one of the

vertices of the left eye. Each vertex on the left eye must

be paired with a vertex on the right eye. However, one

of the vertices on the left eye is paired with another

vertex on the left eye.

If the number of vertices differs between the left and

right side, the vertices may be unappropriately paired

and their depths may not be calculated correctly. As a

result, the shapes will look disproportional.

(16) Choose Edit > Undo. The black vertices change

to white and they are no longer paired.

Basically, you should choose Undo, if the shapes look

disproportional when you drag the indicator in the

Angle window. Correct the shapes following the

instructions described below to make the number of

vertices on both the left and right side identical, and

manually assign pairs.

(17) Correcting the number of vertices on the eyes.

Select the tool and click on the line of the right

eye while holding down the option key. A new vertex
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appears where you clicked. Drag the vertex in an

upward direction as demonstrated in the picture.

(18) Hold down the option key and click on the line

again. There are now four vertices on the right eye too.

(19) Now, there are an identical number of vertices on

the right and left side and the shape appears well

proportioned when you drag the indicator in the Angle

window. 

Sometimes, the shape appears disproportional, even if

the number of vertices on the left and right are

identical. When this happens, you need to manually

pair  vertices. Let's try paring some vertices. 

(20) The tool is not just for checking pairs of

vertices, but can also be used to manually pair them.

Select the tool and click the vertex on the left end

of the mouth, then click the one on the right end. They

become paired and their color turns black. (The

vertices can also be clicked in the opposite order.)

(21) Making vertices on the nose correspond to

themselves. A Vertex on the center line of the face

corresponds to itself. It is therefore necessary to click

the same vertex twice to assign itself as the

corresponding vertex. 

Click the lower vertex of the nose twice. This vertex

also turns black. If there is not another line branching

off from the vertex, all the other connected vertices

will also assign themselves as corresponding vertices.

(22) Click the vertex on the inner part of the right and

left eyes. Now all vertices have been assigned a

corresponding vertex.
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By the way, if you want to unassign a pair of vertices,

click one of vertices of the pair, then click anywhere in

the document window where no other vertex exists. 

(23) Drag the indicator in the Angle window. Now,

the depth is calculated correctly and the shape looks

proportional. Normally, vertices are automatically

paired. However, if the shape is unproportional, please

pair them manually.

(24) Adding lines to fill in the details. Select the 

tool, hold down the option key and click the line on the

upper part of the nose. A new black vertex appears.

When both vertices of a line are assigned to

themselves, any new vertex is also automatically

assigned to itself. 

(25) Hold down the option key and click the mouth

line. Two new vertices appear. One at the clicked

position, and the other at a position symmetrical to it.

(26) Drag the new vertices to positions similar to those

in the picture below, to curve the mouth.

(27) Select the tool and add three lines for the

pupil of the left eye. If you move the mouse pointer

over another vertex, a "." (dot) appears in the lower

right part of the mouse pointer. Clicking it when the

mouse pointer shows this dot connects the new line to

the original vertex.
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(28) Add more lines to finish off the rest of the eyes.

As the right eye is close to the nose, be careful not to

connect them together. 

(29) Add eyebrows and lower lip like in the picture

below. Again, be careful not to connect the right eye

and eyebrow.

(30) Drag the indicator in the Angle window. It looks

more like a face now. However, the face appears wider

than the face of the illustration. 

(31) If the shape is too wide or narrow, adjust the

width with the Width Slider in the Tools window. In

our case, adjusting the width to about 35 will be

enough.  

(32) Drag the indicator in the Angle window. The face

has become narrower. 

(33) Let's add the final touches to the shape. Draw the

hair, ears, neck and shoulder using the tool, and

divide eye and eyebrow lines using the tool,

while referring to the following the picture.

It is easier to roughly draw the lines using the tool

first, then check the depth by dragging the indicator in
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the Angle window. Then, divide the lines using the

option key and tool.

You do not have to strictly trace the outline of the

illustration. Use your imagination as you draw more

symmetrical lines to create your own original shape.  

(34) We have finished. Drag the indicator in the Angle

window and admire your work. 

(35) You can create a 3D outline by tracing an

illustration in this way. You can also use photographs

of mirror-symmetry objects taken from a diagonal

view. It is possible to create 3D outlines from a variety

of things including animals, cars, aircraft, etc. 

However, you should avoid using pictures with objects

that face directly towards the front, top or bottom, or

pictures with an unordinary perspective (for example,

the front is big and the back is small). 
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(36) Now, let's learn how to use the outline in other

modes.

To bring outlines from Manga mode into another

mode, choose Edit > Copy in Manga mode, then open

another document window in either Symmetry or

Normal mode and choose Edit > Paste. All the outlines

will be pasted on the document window.

Furthermore, you can also choose Edit > Switch

Symmetry/Normal Mode when you are in Manga

mode to switch to either Symmetry or Normal mode.

In Manga mode, you can only edit wire-outlines, but

bringing the outlines to Symmetry or Normal mode

allows you to do such things as create smooth surfaces

from the outlines. To do this, use the tool to

connect lines together to form rectangles or triangles,

then choose  Modify > Create Faces For All. 

Note:

If you paste outlines to a document window in

Symmetry or Normal mode or switch from Manga

mode to Symmetry or Normal mode, the outlines are

grouped together to form one object even though the

object may be made up of several objects.

Furthermore, if you save a Manga mode document

and reopen it, the outlines are always grouped together.

To ungroup the objects choose Edit > Ungroup.
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Creating a Desk Lamp

In this section, we will create a desk lamp using the

Input Line and Select/Move Area tools.

(1) In HexaSuper2, choose File > New to open a new

document..

(2) Set the viewpoint angle to upper view with

the Angle window.

(3) Choose Object > Snap to Grid.

(4) First, we will create the base of the desk lamp.

Select the tool and input a hexagon as in the

picture below. Positions where you click become

vertices. Finally, double-click on the first position you

clicked to complete the input operation. As Snap to

Grid is active, the input operation will be conducted

smoothly.

(5) Select the tool and drag around the hexagon

to select all of its lines.

1-3 Using Input Line and Select/Move Area Tools



4 1

(6) Choose Modify > Extend. A copy of the

hexagon is generated and the vertices of the two

hexagons are connected together by lines.

Set the viewpoint angle to side view with the

Angle window. As the base plane is

automatically positioned parallel to the monitor,

an object or area moves in parallel to the monitor.

Drag the selected upper hexagon and move it

over the lower hexagon as in the picture below.

You should drag a vertex instead of a line,

because the position of a vertex snaps to the grid,

which makes it easier to move the hexagon.

(9) Click anywhere in the document window

where nothing exists to remove the selection.

(10) Set the viewpoint angle to upper view with

the Angle window.

(11) In HexaSuper2, you can only create faces on a

triangle or square. So select the tool and add a

horizontal line as in the picture below.

Note that, when two vertices are connected with a line,

they overlap each other and the vertex nearest the front

is active. Therefore, the line we have just input is for

the upper hexagon. 

(12) Choose Modify > Create Faces For All.

All faces are created. Rotate your work with the Angle

window to check its shape.
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(13) Set the viewpoint angle to upper view with

the Angle window again.

(14) Next, we will create a support for the stand.

While holding down the option key, first click the left

side position on the line, then the right side position on

the face and another position on the face, finally

double-click any position on the line to complete the

input operation. Do not worry, a rough shape is fine.

When the input operation is completed, the faces

surrounding the lines disappear.

(15) Rotate your work with the Angle window to

check its shape. Note that, holding down the

option key and clicking any position on the line,

creates a vertex which divides the line, and clicking

any position on the face creates a vertex with the same

depth as those on the face. After checking your work,

return the viewpoint angle to upper view with the

Angle window.

(16) Choose the tool and select four lines

including the three you just input.

(17) Choose Modify > Extend.

(18) Set the viewpoint angle to side view with the

Angle window.

(19) Move the shape that was created with the

Extend command to a position just over the

original shape.

(20) Set the viewpoint angle to a diagonal view

with the Angle window.

(21) In the current state you cannot create faces.

So choose the  tool and input four lines to create

triangles and squares as in the next picture.
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(22) Choose Modify > Create Faces For All.

Faces are created. Then, choose Edit > Deselect

to remove the selection.

(23) Choose View > Show Smooth Faces. The

object looks a little strange because only its faces

are shown as its lines are hidden. In HexaSuper2,

lines except for sharp ones are shown as if they

were continuous and seamless.

(24) Now, we will create sharp lines in the parts

that require them to look realistic.

Choose Edit > Select > Select Edges Sharper than 60

Degrees to show edges as sharp ones.

(25) Choose Modify > Sharp Line. The selected

lines become sharp lines. Then, choose Edit >

Deselect All to remove the selection. Now the

edges are shown clearly and naturally.

(26) Choose View > Show Smooth Faces + Lines

to return the view to its original state. 

(27) Next, we will create the stand.

First, we will hide the base of the lamp to make it

easier to work. Choose Edit > Select All, then choose

View > Hide Selection. The base of the lamp

disappears. 

(28) Hold down the tool for a while to show the

menu, then choose and click in the center of the

grid. A small cylinder is generated.

(29) The tool is now active. While holding down

the command key, drag any of the upper four handles

of the cylinder to stretch it upwards. Drag it until the

stand is around 3/4 the height of the grid.

m
When you create an object

using the Solid Object Tool,

edges are clear from the

beginning. This is why edges

are set to Sharp Line by

default.

m
Choosing View > Show All

shows any object which has

been hidden.
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(30) Now we will divide the stand in order to be

able to bend it later.

Set the viewpoint angle to front view with the Angle

window.

(31) Select the tool and drag around the cylinder

to select all its elements.

(32) While holding down the shift key, drag around

the top of the cylinder to remove the selection within

the area you drag around. Note that when you drag

around an area while holding down the shift key, the

selected area you drag around is deselected and the

other portions remain selected.

(33) While holding down the shift key, drag

around the bottom of the cylinder to remove the

selection.

(34) Choose Modify > Subdivide > Other. The

dialog box appears. Then, specify 12 and click

OK. As only the side lines of the cylinder are

selected, the cylinder is divided in a vertical

direction.

(35) Click anywhere on the screen where nothing

exists to remove the selection.

(36) Now we will create a lampshade.

Leave the viewpoint angle as it is, and choose the 

tool. While holding down the option key, drag over the

top of the stand to create a cylinder about the size of

the one in the picture below. Note that the cylinder

looks like a sphere, as the viewpoint angle is set to

front view.
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(37) Set the viewpoint angle to side view.

(38) Select the tool and adjust the position of the

cylinder (lampshade) until it is on the stand as in the

picture below.

(39) Choose the tool and select the right side

element of the lampshade.

(40) Choose Modify > Magnify. The mouse

pointer changes to .

(41) Place the mouse pointer on the selected

element and drag it. When you move the mouse

pointer to the left, the selected element decreases

in size. Change the size of the lampshade to about

the same size as the one in the picture below. The

lampshade is now finished.

(42) Next, we will attach a light bulb. 

Hold down the tool, then choose . While

holding down the option key, drag on the left side of

the lampshade to generate a sphere.

(43) Choose the tool and move the sphere to a

position half hidden behind the lampshade. The light

bulb is now finished.
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(44) Next, we will arrange the whole shape.

Choose View > Show All to show the base of the lamp

which has been hidden. Rotate your work with the

Angle window to check the shape. The positions of the

base, stand and lampshade are out of place.

(45) Choose Show View > Show Lines Only to

make it easier to see the positions of the objects.

Change the viewpoint angle to front or side view

and adjust the positions of the objects.

(46) When the positions are correct, choose File

> Save As to save the document. You can enter

any name for the file.

(47) Now we are close to finishing our desk

lamp.

We will bend the stand to make it look more like a

desk lamp.

Set the viewpoint angle to side view with the Angle

window. Choose View > Show Smooth Faces + Lines

to return the view to its original state.

(48) Choose the tool and select the upper

portion of the stand along with the lampshade.

(49) Select the tool and drag the selected area by

moving the mouse pointer to the left and right to rotate

the object. However, the object does not move

flexibly, so choose Edit > Undo to return the object to

its original state.

(50) Hold down the tool and.choose .

(51) Choose the tool again and drag the selected

area to rotate it. This time, the stand can be bent

flexibly.

When you choose , from the Select/Move Area

tool menu, the selected object plus three segments

counting from the border can be moved and rotated

flexibly.(When you choose , the object plus five

segments counting from the border can be moved and

rotated.)

Now, bend the lampshade and stand as in the picture

below, then release the mouse button.

m
The center of rotation is the

border of the selected and

unselected area.



4 7

Now, the shape looks good. If you are in a hurry, you

can skip the intermediary steps and jump to (59) and

finish your work. However, if you want to learn more

about the special features of HexaSuper2, choose Edit

> Undo to return your work to its original state. We

will show you another way of modifying the object.

(52) Now, we will show you another way of

modifying the object while explaining functions

of the group area.

The upper portion of the arm is selected. In this state

choose Edit > Group. The selected area becomes a

group area. Then, choose Edit > Deselect All to

remove the selection.

(53) Choose the tool and click the lampshade.

The whole group is selected. After checking the

selection state, click anywhere on the screen where

nothing exists to remove the selection.

(54) Next, we will drag the lampshade. You can

move the elements of the whole group

simultaneously, without selecting the element

that you want to move. After checking the

movement, choose Edit > Undo to return the object to

its original state. Note that, you can use any of the 

tools to select vertices, lines or group

area.

(55) Back to our work. Now, we will bend the

stand.

Hold down the tool and choose (red icon).

(56) Select the whole desk lamp, including the

lampshade and lower portion of the stand.
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(57) Choose the tool. Move the mouse pointer

over the lampshade and drag to rotate it. The selected

stand is bent flexibly while the shape of the lampshade

does not change. Bend the stand as in the picture and

release the mouse button.

(58) Click anywhere in the document window

where nothing exists to remove the selection.

When we bent the stand in (51), the range of

bending was restricted to the third segment

counting from the border. However, when you

choose , you can bend the inside elements of the

selection area separately, so you can specify the

modifying range as you want.

Furthermore, when you drag a group area to modify it,

the shape does not change. As you have just seen, the

shape of the lampshade did not change.

To summarize, a group area has the following three

characteristics.

1. When you click a group area, it is selected as a

whole.

2. When you drag a group area it moves as a whole.

3. When you drag a group area to modify the elements

in the selection area, the shape of the group area does

not change as a whole.

(59) Finally, paint your work with colors to add

the finishing touches.

Select light yellow from the Color palette, choose the

tool and click on the light bulb. The color of the

light bulb changes to light yellow.

(60) Select black from the Color palette and click

on the stand. The color of the stand changes to

black.

(61) Choose View > Show Smooth Faces. 
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You have now finished the desk lamp.
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Creating a human face 

Everyone who uses 3D software desires to create a

human face. Let's create a realistic human face using

Symmetry mode. The same techniques can also be

applied  to a variety of other shapes.

Original design: Koji Ando

(1) Switching to Symmetry mode.

Choose File > New to open a new document window.

Next, choose Edit > Switch Symmetry/Normal Mode

and press the OK button in the dialog box that appears.  

(2) Drawing an eye.

Set to front view with the Angle window. Select the

tool and draw five lines for an eye on the right

side of the grid cube as in the picture below

When you have finished drawing with the polyline

tool, an identical shape is shown in symmetry on the

left side. This is a mirror image of the shape you drew.

1-4 Using Symmetry Mode
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(3) Trying to move the eyes.

Select the tool and drag the right eye. When you

drag the right eye, the left mirror image moves at the

same time. You cannot move the right eye to the left

side of the grid cube. When you have finished moving

the eye, return it to its original position. 

By the way, pressing the / key allows you to switch the

side which permits editing. Doing so transforms the

actual objects into mirror-images and vice versa.

Next, try dragging the left eye. You will find that it

cannot be dragged. You cannot move a mirror image

or an actual shape to the left side in Symmetry mode.

However, these limitations allow you to create

symmetrical shapes easily.

(4) Drawing a nose, mouth and cheeks.

Select the tool. To draw two lines for the

mouth, first click the lower left position, then

click the lower right and finally the lower left

position again. If you click the left side, the

vertex appears on the center line and becomes a

mirror-center vertex.

A mirror-center vertex cannot be moved to the

left or right, as its movement is restricted to an

upward and downward direction, or towards the

front or back of the document window.

Next, draw lines for the nose and cheeks as in the

picture below. (Click on the left side to create a vertex

for the top of the nose. This vertex is a mirror-center

vertex.)
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(5) Adding depth to lines. 

Set the view to right side view, and move the lines in a

horizontal direction to give a sense of depth using the

tool.

At first, it does not matter which lines you move or

where you move them to. Arrange the lines for the

nose, mouth, cheeks and eyes on the left side, then do

the same for the lines on the right.

Drag the indicator in the Angle window to check the

shape. Now, each element has its own depth.

(6) Adding depth with more precision. 

Set the view to side view and select the tool.

Move the vertices to positions similar to the ones

shown in the picture. Be careful because some vertices

overlap each other.

To move vertices horizontally in a side view, hold

down the shift key, and drag them. If you move

vertices vertically, the shape will look different when

viewed from the front. 

Drag the indicator in the Angle window and admire

the shape. The shape now looks more natural.

(7) Creating center lines.

Set to side view and draw new lines for the nose, as in

the picture, using the tool. The lines turn blue.

When you input lines from a side view in Symmetry

mode, the new vertices and lines become mirror

center.

(However, if you connect a new line to an existing

vertex, the line becomes a normal line and is not

mirror center.)
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(8) Moving outlines more precisely.

Move the vertices precisely until you are satisfied with

the face. It is better to decide the rough image of the

face now as it becomes harder to alter the shape after

you have added more vertices.

Note: 

You can also draw the outlines in Manga mode as

described in Section 1-2, Using Manga Mode. Choose

whichever mode you prefer.

(9) Adding vertices.

Now, let's add more vertices and lines to give more

details to the face.

Select the tool, hold down the option key and

click on the lines to add new vertices as in the picture

below.

Then, add lines beneath the eye with the 

tool.
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(10) Adding lines.

Let's draw more lines to add contour to the face as

shown in the picture below. First, draw lines from a

front view, then give the shape more depth by

adjusting them from a side view.

(11) Adding more lines.

Add more lines as shown in the next picture.

To obtain a good surface, adjacent polylines must have

the same number of vertices. (Refer to art-sketch

books when you try to draw face lines.)

(12) Preparation for creating faces.

Connect vertices of the face together to create an array

of rectangular frames using the tool. 

HexaSuper2 allows you to create triangles as well, but

for our purposes rectangles create a better surface. 
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(13) Before creating the faces.

The picture below shows the shape after creating an

array of rectangular frames.

In this shape, some vertices were automatically added

to make rectangles or triangles look natural.

Furthermore, eyelashes were added to the shape.

(14) Creating the faces.

Choose Modify > Create Faces For All. A face

appears within each rectangular frame of the shape.

(15) Creating the eyeballs.

Create a sphere for an eyeball using the tool and

paint the pupil of the eyeball. 
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(16) Creating a curved surface.

Select the tool and click the face to select it. Then

choose Object > Curved Surface. The surface of the

face becomes curved.

However, this shape is too smooth, it needs to be given

a bit more life.

(17) Setting sharpness.

Select the eye sphere and choose View > Hide

Selection. 

Select the tool and shift-click the lines in the

picture. The lines around the eye, nose and mouth

should have sharp edges.

Next, choose Modify > Set Sharpness > 80%. The

next pictures shows the faces before (top) and after

(bottom) setting the sharpness. Now, the face has been

given life.
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(18) Creating Hair.

Create the hair by drawing several oblong shapes and

arrange them like in the picture below. 

It is easier to create the hair if you hide the face and

eyes beforehand. To hide the face and eyes, choose

Edit > Select All and then choose View > Hide

Selection.

(19) Increasing the amount of hair.

Copy and paste many oblong shapes and arrange them

so as they look like hair.

Use the Sphere tool to draw an ear like the one in the

picture, and place it in position before arranging the

hair around the ear position.
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(20) Creating texture.

Creating detail on the eyebrows and lips using texture

mapping. (Texture mapping is the process of adding

detail to a 3D object by creating a picture or pattern

[texture] that can be wrapped around the object.)

Set to front view, select the tool and click the

face to select it. Then choose File > Export > Unwrap

For Texture. The dialog box below appears. Make the

same settings as those shown in the picture below and

press the OK button. The file save dialog box appears.

Enter a name for the picture and save it. 

A wire-image picture like the one on the left side of the

following picture is saved. If you add color and detail

to this picture using any paint software available, you

can create a picture similar to the one on the right side

in the next picture.

(21) Adding texture.

When you have finished adding color and detail to the

picture, select all and copy it in the paint software.

Then select the face in HexaSuper2 and choose Edit >

Paste.

The dialog box below appears. Press the OK button to

add the texture to the face.
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The hair and eyes are hidden in the picture above to

show the texture clearly.

Finished! We have created a pretty girl. (But someone

said she looks like a Stone-Age man.)
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Rendering the penguin

Here, we learn how to use the software POV-Ray with

HexaSuper2. POV-Ray allows rendering to make your

picture look more realistic. Rendering is the creation of

a picture with geometric models, using color and

shading to give the picture a more realistic look.

POV-Ray is freeware developed by the Pov-Ray team.

How to use POV-Ray differs depending on its version.

Our instructions presume that you are using POV-Ray

3.1 for Macintosh.

(1) Download POV-Ray 3.1 from

http://www.povray.org/ and install it on your hard

disk. 

(2) Opening the file to be rendered. 

Start HexaSuper2 and choose File > Open.

Navigate to and open the file "Tutorial5(Penguin on

Ice)" in the "Tutorials" folder. A penguin walking on

ice is displayed in the document window.

(3) Exporting this document in POV-Ray format.

Choose File > Export > POV-Ray. Enter a name

for the file and save it. Remember the filename

and the folder where you saved it.

1-5 Rendering with POV-Ray
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(4) Starting POV-Ray. 

Double-click the file that you saved, or drag and drop

it on the POV-Ray application icon. POV-Ray will

start and open the file.

(5) In POV-Ray choose Edit > Render Settings. The

dialog box below appears. Click the Output tag to

select it. Then, select "512 x 384 - 12" LC" from the

Image Size list and  "PICT (MacOS)" from the Save

Image As list.. Click the Save button to close the

dialog box and save the settings.

(6) Choose Render > Start Rendering, in POV-Ray.

Rendering starts immediately and takes a few minutes

to complete.

(If rendering does not start and the message "Ran out

of application memory" is displayed in the POV-Ray

Status window, increase the application memory of

POV-Ray and retry)

(7) The picture below shows the finished image.

The image file is saved automatically. Although

it takes a long time to perform rendering, it adds

reflections and shadows to make the image look

more realistic.
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2
Windows &Tools
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2-1

This window is where graphics are edited.

The base plane buttons on the lower left part of the

document window are for selecting the base plane

along which objects are moved. The plane with purple

(default color) cross lines is the base plane. Change it

by clicking one of the four base plane buttons. It

changes to the following when each respective button

is clicked.

: Base plane

: Left plane

: Right plane

: Parallel to monitor

Shape elements move parallel to the base pane when

they are moved. 

The message box at the bottom of the document

window displays descriptions of each button, tool or

the present status.

The input mode box displays the mode you are in now

(Normal, Symmetry or Manga mode).

2-1 Document Window

Base plane buttons Message box Input mode box (Normal/Symmetry/Manga)

Area for editing graphics
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Rotate Tool (R)

Lasso and Magic Wand Tool (L)

Add or Delete Vertices/Lines Tool (C)

Solid Object Tool (M)

Zoom Tool (Z)

Paint Bucket Tool (K)

Color Palette

(V) Select/Move Object Tool

(A) Select/Move Area Tool

(P) Input Line Tool

(N) Surface Object Tool

(H) Hand Tool

(I) Eye Dropper Tool

Face Right/Left
Switch Button

Right and Left
Co r respond ing
Tool

Width Slider

2-2 Tools Window

When in Normal/Symmetry mode

When in Manga mode
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Buttons with "v" on their lower left have pop-up

menus. Pressing one of these button for a short amount

of time displays the menu. (The amount of time it

takes to display the menu can be set on the Operation

page of the Preferences dialog box, which is displayed

by choosing Edit > Preferences.) 

The letter displayed within parenthesis in the message

box when you position the mouse pointer over a tool

button is the name of the key assigned as its shortcut

key. For example, pressing the V key selects the

Select/Move Object Tool. In addition, the following

keys have been assigned as shortcuts

Space key:When this key is pressed the mouse

pointer changes to , allowing you to move the

viewpoint parallel to the monitor by dragging the

mouse pointer. 

X key: When this key is pressed the mouse pointer

changes to , allowing you to rotate the

viewpoint around the center of the grid cube by

dragging the mouse pointer.

S key: When this key is pressed the mouse pointer

changes to , allowing you to alter the distance by

dragging the mouse pointer to the left or right. 

. (period) key: Pressing this key once temporarily

hides the red selection lines within a selected area.

(Hiding selection lines allows you to see a shape

clearly.)

Control+1-9: Pressing the control key and one of the

keys 1-9 when Large Range is selected as the

Select/Move Area tool, allows you to specify the size

of the area of the shape to select or move. Pressing the

1 key specifies a small area (same as Small Range) and

pressing the 9 key allows you to specify a large area.

The size of the area is set to that of the 5 key by

default.

HexaSuper2 supports Intuos 4D mouse.

4D Mouse: The view and distance of the active

window (window showing a perspective view when

four windows are displayed simultaneously) can be

changed with the Intuos 4D Mouse of Wacom

Technology Co. If the distance does not change when

you move the mouse wheel choose Apple > Control

Panel and set the 4D mouse wheel, to work with

applications in the control panel for the Intuos tablet. 

Select/Move Object Tool 

Selects, moves and changes the size of an object.

Selecting an object.

(1) Moving the mouse pointer to the position of

an object, changes the mouse pointer to when

it is over an object, and when it is over a selection

handle. Clicking the mouse when it is over an object

selects the shape elements, and a selection frame and

handles appear as shown in the following diagram.
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(2) Dragging the mouse pointer from a place where no

object exists allows you to make a rectangular

selection.

(3) Shift-clicking an object deselects an object that

was already selected and adds it to the selection if it

was not selected before you clicked it.

Clicking in a place where no object exists deselects all

objects in the selection.

(4) Dragging an object moves it parallel to the XZ

plane. Pressing the command key allows it to be

moved in an upwards or downwards (along the Y

axis) direction. 

Dragging a handle changes the size of the object in the

direction you drag.

You can change the base plane along which an object

moves parallel, by selecting one of the base plane

buttons on the lower left of the document window.

Rotate Tool, Rotation Center is

Clicked Position Tool

Rotates a selected area or object.

Pressing the shift key when rotating restricts the

rotation to 90 degree increments. Pressing the

option key when rotating leaves the original

object as is and rotates a duplication of the object.

Normally, an object is rotated parallel to the base

plane, however, selecting the button (Move

objects and areas parallel to monitor)rotates

objects or areas parallel to the monitor.

Rotate Tool

Drag the mouse pointer to the left or right, within

a selected area to rotate it. The border line of the

selected and unselected area becomes the center

of rotation. 

Dragging elements outside of the selection area

rotates only the elements you drag. 

The red dot displayed when you rotate a selected

object is the center of rotation.

m
Refer to the glossary at the

back of this Instruction

Manual for an explanation on

an area or group area.

HandleSelection frame

Center of rotation
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When more than one object is selected, the center of

rotation is the dragged object. By default, HexaSuper2

is set to rotate around the center of an object, however,

choosing Object > Set Rotation Center allows you to

set the center of rotation yourself. 

For example, if you have made a person's arm out of

one object, setting the center of rotation to the point

where it is joined to the body makes it easy to adjust

the angle of the arm. 

Rotation Center is Clicked Position Tool

Rotates an object or area around the center of the

position you first clicked on the base plane when

you started dragging the mouse pointer. 

If the Select/Move Area tool is set to Medium

Range or Large Range when you rotate an area,

the area around the borders of the selected area

are blended with the selected area. However, if

Modify Selection is selected, the effect of the

rotation on the area around the borders is the

same as when Small Range is selected 

Rotating in Symmetry mode allows you to move an

object or area in the lower-left part of the document

window, where objects normally cannot be edited in

this mode.  Note that the position of vertices of

portions of an object or area that extend outside of the

lower-left part of the document window will be forced

back to the center plane (parallel to YZ axis) when it is

moved.

Select/Move Area Tool

Selects or moves an object or shape elements (faces,

lines and vertices) on the base plane. 

Selecting an object.

(1) Moving the mouse pointer over the object you wish

to select, changes the shape of the mouse pointer to

one of the following.

: When over a face.

: When  over a line.

: When over a vertex. 

Clicking when the mouse pointer is one of the above,

selects the shape element.

(2) Making a rectangular selection by dragging from a

place where no shape element exists, selects all

elements within the rectangle.

(3) Clicking shape elements while the shift key is

pressed deselects elements that were already selected

and increases the selection area to include elements

that were not already selected.

(4) Clicking a place where no shape elements exists

deselects all selected elements..
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Even if a shape element has not been preselected,

dragging moves it parallel to the base plane. Pressing

the command key when you drag moves shape

elements perpendicular to the base plane.

You can change the base plane with the Base Plane

buttons at the bottom of the document window. 

When more than one shape element is selected at the

same time, all elements of the selection are moved

together. Dragging a group area moves and changes all

the vertices of the group at the same time. Shape

elements can be grouped together by choosing Edit >

Group.

Small Range

Moves the selected elements or area only.

Medium Range, Large Range

Moves the selected elements or area and blends

them with the surrounding shape elements to

create a continuous and seamless area.

Original shape When there are no

sharp lines

Moving a selected area

Moving a face that is

connected to a sharp line

When there are 2

sharp lines

When a sharp line is

positioned at a distance from

the selected area

Sharp line

Sharp line

Sharp lines

Modifying shapes when Medium Range or Large Range is selected
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Modify Selection Tool

Dragging elements outside of a selection has the

same effect as using the Small Range tool,

however, dragging elements within a selection

moves or changes only the selected elements.

Lasso Tool

Dragging around an area with this tool allows you to

select it. Also, clicking an object or shape element

selects it.
To select one shape element and only the elements

directly connected to it, first, move the mouse pointer

over the shape element and drag around it. This tool is

useful for selecting certain parts of a shape

Pressing the shift key allows you to increase the

selection by dragging around different elements. 

Original shape

When there are no

sharp lines

Moving a selected area When there is a sharp line

connected to a group areaGroup area Group area

Sharp line

Sharp line

Sharp line

When there is a sharp line

on the border of an area

Moving a face that is

connected to a sharp line

Modifying only shapes within an area
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Selecting an area with the Select/Move Area tool

Selecting an area with the Lasso tool

Magic Wand Tool

Selects faces with the same color. Clicking a face

selects all adjacent faces with the same color and

level of shine as the one you clicked. Clicking a

face while pressing the option key selects all

faces with the same color and level of shine as

the face you clicked. This tool allows you to

easily organize shapes by color and gain a clear

understanding of how colors are being used.

Input Line Tool

Inputs polylines, rectangles and circles.

Polyline Tool

Inputs polylines.

Each time you click in the document window creates a

vertex of a polyline. Double-click or press the enter

key to finish drawing a polyline.

Normally, a polyline is generated parallel to the

monitor, and with the same depth as the center of the

grid cube, but if you click in the same location as one

of the vertices of an already existing object when you

are drawing a polyline, the polyline is generated with

the same depth as that vertex. 

Holding down the shift key when you input a polyline,

restricts the input of a vertex to 45 degree increments,

around the last inputted vertex. You can delete the last

inputted vertex with the delete key. 

You can input a vertex on top of a line or face, by

clicking the mouse pointer when the option key is

pressed. However, this deletes all adjacent faces.

Clicking the mouse pointer when the command key is

pressed, creates a vertex on the base plane.
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In Symmetry mode, sometimes a polyline is generated

on the left half of the grid cube where editing is

prohibited. Note that, if you try to move the vertex of a

polyline protruding into the left half, it will be forced

onto the center face (YZ plane).

Square Tool

Creates a square or rectangle in the position you drag

the mouse pointer.

Pressing the command key creates a rectangle that is

aligned to the base plane. 

Pressing the shift key creates a square.

Pressing the option key when you release the mouse

button, creates a rectangle on the face of an object.

Clearing the rectangle leaves a rectangular hole on the

object.

Circle Tool

Creates a circle in the position you drag the mouse

pointer.

Pressing the command key creates a circle that is

aligned to the base plane. 

Pressing the shift key creates a perfect circle.

Pressing the shift key and option key when you release

the mouse button, creates a circle on the face of an

object. Clearing the circle leaves a circular hole on the

object.

The number of subdivisions for a sphere and circle is

set to 12 by default. You can change the number of

subdivisions on the Operation page of the Preferences
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dialog box.

Add or Delete Vertices/Lines Tool

Clicking a line or vertex deletes it. 

However, when deleting a vertex or line will cause two

faces to overlap, it cannot be deleted. 

If you hold down the option key and click a line when

there is a triangular face on both sides of it, the line is

deleted and both faces are combined to become one

rectangular or square face.

Holding down the command key and dragging from

one vertex to another, joins them together to become

one vertex.

Surface Object Tool

Creates a surface object (a two dimensional

object with border lines) in the position you drag

the mouse pointer.

Creating a surface object.

(1) Click and hold down the mouse pointer at the

location on the base plane where you wish to create an

end vertex of the object.

(2) Drag the mouse pointer to create the object and

adjust its size. 

Pressing the option key and dragging a handle, adjusts

the size of the object proportionally.

Solid Object

Tool

Creates a solid object (a three dimensional object

without border lines) in the position you drag the

mouse pointer.

How to create a solid object.

(1) Click and hold down the mouse pointer at the

location on the base plane where you wish to create an

end vertex of the object.

(2) Drag the mouse pointer to create the object and

adjust the size of the bottom face. 

(3) Press the command key and drag one of the

handles up or down to alter the objects height.

Pressing the option key and dragging a handle, adjusts

the size of the object proportionally.

m
The Symmetrical Square,

Symmetrical Circle,

Symmetrical Cube,

Symmetrical Cylinder,

Symmetrical Sphere and

Symmetrical Cone tools can

only be used in Symmetry

mode.
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Hand Tool

Moves the viewpoint of an image horizontally.

You can use the Hand tool when another tool is

selected by holding down the space key 

Choosing View > Undo Viewpoint returns the

viewpoint to its original state.

Zoom Tool

Magnifies or reduces the size of the view.

Each click magnifies the view by double its size,

centering the display around the point you click.

Dragging a rectangular selection magnifies the area

inside the selection around its center.

The plus sign of the mouse pointer changes to the

minus sign while the option key is pressed, allowing

you to reduce the size of the view.

Choosing View > Undo Viewpoint returns the

viewpoint to its original state.

Eye Dropper Tool

Reads the color, shine and transparency level of a

clicked face. 

Paint Bucket Tool

Paints the current color, shine and transparency

level of the color palette to the place you click

and to any adjacent area of the same color. Also,

paints the whole area of an object if it is selected

when you click it. 

Clicking within a selected area paints inside the

selected area only. When the color displayed is a

texture, the following Texture Mapping dialog box

appears.

The Paint Bucket tool changes to the Eyedropper tool

while the option key is pressed.

You can increase the size of the area painted by

clicking faces one at a time while pressing the shift

key.

Color Palette: Display Color

Clicking within the color square at the bottom of the

Tools window displays the color palette

Choosing a color from the color palette selects it as the

current palette color and it is displayed in the color

square at the bottom of the Tools window.

Selecting this button allows you to choose a color

from the Color Picker.

Selecting this button displays the Open dialog

box, allowing you to set a texture for the color palette

by specifying a file in PICT format.
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Copying an image in PICT format while in another

application and pasting it into HexaSuper2, allows you

to specify the image to be a texture.

Changing the color of the color palette does not change

the color of a selected object or area. To change the

color of an object or area use the Paint Bucket tool.

Color Palette: Shine

Adjusts the shine.

When the level of shine is high an object is

displayed brightly, and when the level is low it is

dull.

Moving the Shine slider when an object or area is

selected does not change its level of shine. To change

its level, first move the slider to the desired level, then

select the Paint Bucket tool and click the object or area.

Color Palette: Transparency

Adjusts the level of transparency.

Moving the Transparencyslider when an object or

area is selected does not change its level of

transparency. To change its level, first move the slider

to the desired level, then select the Paint Bucket tool

and click the object or area.

If your computer is not equipped with Apple

Computer's QuickDraw 3D accelerator card the

changes will not be displayed.

Manga Mode: Face Right/Left Switch

Button

Specifies the direction of an object drawn in Manga

mode.

Clicking this button switches the face on it between a

left or right direction. Clicking the button again returns

it to its original direction. You must select the same

direction as the face or object in the illustration to be

traced. In Manga mode, when objects such as a

person's face, airplane or car look towards the left, the

face on the button must also look towards the left, and

when they look towards the right it must look towards

the right. You can change the direction even if you

have already started drawing the outline. 

If the face on the button is looking in the opposite

direction to the face or object in the illustration, the

front and back of the 3D outline will be inverted.

For a more detailed explanation on using Manga

mode, refer to Section 1-2,Using Manga Mode.

Manga Mode: Right and Left

Corresponding Tool

Assigns corresponding right and left vertices in Manga

mode.

In Manga mode, each vertex on the right side of an

object must be paired with a vertex on the left side.

Normally, changing the viewpoint angle with the

Angle window after drawing a polyline,  automatically

pairs right and left vertices, so there is no need to use

this tool. However, sometimes the pairs of vertices are

not successfully assigned and the outline does not look

proportional in three dimension.

If this happens, immediately choose Edit > Undo, then

use this tool to manually pair right and left vertices. 

m
The color palette:

Transparency slider is not

shown by default. To set it to

be shown at the bottom of the

Tools window, choose Edit >

Preferences, and select  the

check box of the "Show

Transparency slider" option on

the Operation page of the

Preferences dialog box.
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With this tool selected, first click a vertex on the right

side and then click the vertex that corresponds to it on

the left side. (The vertices can also be clicked in the

opposite order.) The vertices turn black to signify they

have been paired.

When a vertex at the end of a polyline is paired with

another vertex, all the other vertices on the line are

automatically paired.

A Vertex in the center of an object, as with the nose

above, should correspond to itself. Click the same

vertex twice to assign itself as a corresponding vertex. 
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If you want to unassign a pair of vertices, click one of

vertices of the pair and then click anywhere in the

document window where no other vertex exists.

For a more detailed explanation on using Manga

mode, refer to Section 1-2, Using Manga Mode.

Manga Mode: Width Slider

In Manga mode, you can adjust the width of a 3D

shape. If you think the shape of an outline is too wide

or narrow, adjust it to a suitable width with the Width

slider of the Tools window.  
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Moving the indicator (blue circle) around the locator in

the Angle window changes the viewpoint angle of the

objects in the document window. The indicator can be

moved by dragging the mouse pointer. Pressing the

shift key while dragging it, changes the angle in 15

degree increments, and pressing the option key rotates

it from the front.

The viewpoints of the locator in the Angle window are

as shown in the picture below.

Selecting snap makes it easier to view objects directly

from the front or side.

The Distance Meter (slider at the bottom of the Angle

window) allows you to set the magnification of the

view.

Moving the slider to the left brings objects nearer and

magnifies them, moving it to the right sends them

further away and reduces their size.

You can alter the distance of the furthest view by

choosing View > View Settings, and then changing the

smallest range on the Operation page of the View

Settings dialog box. 

The way objects are viewed can be changed with the

Lens buttons. 

Wide: Strong sense of perspective.

Normal: Normal.

Narrow: Weak sense of perspective.

Ortho: Orthographic projection. 

You can show or hide this window by choosing either

Show Angle or Hide Angle from the Window menu.

2-3 Angle Window

Back 

m
Setting the Lens to Ortho

makes it easy to create

precise shapes.

Left
side

Front Right
side

Back 

Top 

Bottom 
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The angles within the locator of the Lights window are

the same as that of the Angle window. Moving the

light symbols of Light 1 and Light 2 around in the

locator changes the origin of lights within the

document window.  

Pressing the option key when you drag the Light 1

symbol ensures that only Light 1 is moved. Likewise,

pressing the command key when you drag the Light 2

symbol ensures that only Light 2 is moved. Selecting

the Show Lights check box displays the origin of the

lights within the document window.

Dragging the Strength of Light 1 and Strength of Light

2 sliders changes the brightness of each light,

respectively. Clicking Default settings, returns the

lights to their original state. 

You can show or hide this window by choosing either

Show Lights or Hide Lights from the Window menu.

2-4 Lights Window
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This window displays information on coordinates and

ratio when you use various tools from the Tools menu.

Choosing either Show Value or Hide Value from the

Window menu allows you to show or hide this

window.

Clicking one of the buttons in this window has the

same effect as holding down the corresponding shift,

option, or command key.

With this function you can perform most tasks within

HexaSuper2 using just the mouse.

Choosing either Show Keyboard or Hide Keyboard

from the Window menu allows you to show or hide

this window.

2-5 Value Window 2-6 Keyboard Window
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This window is for organizing objects in different

layers. You can show or hide each layer by switching

between Show and Hide modes, and allow or prevent

editing by switching between Edit and Lock mode.

Each layer is displayed in the lower part of the

window.

New Button

Clicking this button creates a new layer and it becomes

the currently selected layer.

Delete Button

Clicking this button deletes the currently selected layer.

The objects in the layer are not deleted, they are moved

to the layer immediately above.

Move Button

Clicking this button moves any objects which are

selected in the document window to the currently

selected layer.

Sort Button

Clicking this button allows the layers to be organized

by assigning each object its own layer.

Layer

On each layer the layer number, Show/Hide Layer

button, Edit/Lock Layer button and number of objects

within a layer are shown from left to right.

Clicking the part of the layer with number indications

selects the layer as the current layer and it turns light

blue. Any new object created by, for example, using

the tools, becomes part of the current

layer. An object that is copied and pasted also becomes

part of the current layer. 

Double-clicking the part of the layer with number

indications selects all the objects within the layer.

Double-clicking it again deselects the objects. 

Show/Hide Layer Button

Clicking this button switches between the Show and

Hide modes. When a layer is hidden, any objects

within it are not exported if you choose File > Export.

More than one layer can be switched between Show

and Hide Modes at the same time by clicking the

Show/Hide Layer button of the top layer you wish to

select and dragging the mouse downwards.

Edit/Lock Layer Button

Clicking this button switches between the Edit and

Lock modes. When the layer is locked you can still see

the objects within it in the document window, but they

cannot be selected or edited. 

More than one layer can be switched between Lock

and Edit modes at the same time by clicking the

Edit/Lock Layer button of the top layer you wish to

select and dragging the mouse downwards.

2-7 Layers Window
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New

Creates a new document window. 

A new document window is created when you start

HexaSuper2. 

New In Specified Mode

Creates a new document in a specified mode. You can

select from Normal, Symmetry and Manga mode.

New In Specified Mode > Normal Mode

Creates a new document  in Normal mode. This mode

allows you to create a normal shape.

New In Specified Mode > Symmetry Mode

Creates a new document in Symmetry mode. This

mode allows you to create left-right symmetrical shapes

easily.

In Symmetry mode, the shapes on the right side of the

grid cube are actual objects and the ones on the left are

mirror images of them. Mirror images cannot be

selected, moved or edited. Shapes of the actual objects

can be edited, but only on the right side of the grid

cube; moving them to the left side is not permitted in

Symmetry mode. Furthermore, vertices (mirror-center

vertices) created in the center of the grid cube (0

position on the X coordinate) can only be moved in the

3-1 File Menu
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center. However, these limitations allow you to create

symmetrical shapes easily.

Pressing the / key allows you to switch the side which

permits editing. Doing so transforms the actual objects

into mirror-images and vice-versa. For a more detailed

explanation on using Symmetry mode, refer to Section

1-4,Using Symmetry Mode.

New In Specified Mode > Manga Mode

Creates a new document in Manga mode. This mode

allows you to use the 3D Manga function to create a

three dimensional object from a photograph or

illustration.

Normally, in Manga mode you choose View >

Background Color, and select the Face button at the

bottom of the color palette to show the photograph or

illustration you wish to create a 3D outline from. Then,

you use the tool to trace an outline. You must

draw the same number of vertices and lines on both the

left and right side. 

When you view the outline from different angles by

dragging the indicator in the Angle window, the

background disappears and the outline looks three

dimensional because the depth of the lines are

automatically calculated. Releasing the mouse button,

returns the viewpoint angle to its original position and

the background  reappears.

Normally, in Manga mode Show Lines Only is selected

in the View menu, and you cannot use the Surface

Object, Solid Object, Eyedropper and Paint Bucket

tools. Also, you cannot create faces, edit or use many of

the commands from the menus.

To bring outlines from Manga mode into another

mode, choose Edit > Cut in Manga mode. Then, open

another document window in either Symmetry or

Normal mode and choose Edit > Paste. All the vertices

and lines are pasted on the document window. You

cannot copy or cut a shape from a document in

Symmetry or Normal mode and paste it into a

document in Manga mode. For a more detailed

explanation on using Manga mode, refer to Section 1-

2,Using Manga Mode.

Open...

Opens a document that has been created with

HexaSuper2.

Close

Closes the active document. If changes to the document

have not yet been saved, the save dialog box appears

and prompts you to save the changes. The document

can also be closed by clicking the close box in the top

left corner of the document window.

Save

Saves the contents of the active document as a file in

HexaSuper2 format.

Save As...

Saves the contents of the active document under a

different  name as a new file in HexaSuper2 format. 
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Import

The data of files in a variety of formats can be read in

the document window currently active. Files other than

those of HexaSuper2 format that are imported into the

document window when in Symmetry mode are

displayed as left-right symmetrical mirage images. To

prevent this from occurring, switch to Normal mode

before importing the file by choosing Edit > Switch

Symmetry/Normal Mode. 

HexaSuper2 can import the following formats:

• DXF

• 3DMF

• LightWave3D

• Rokkakudaioh (freeware version of HexaSuper2)

Import > All Types...

Reads data from any file in a format supported by

HexaSuper2. Although HexaSuper2 is able to

distinguish between any filename extension when it

reads a file, for some unexpected reason, a file may not

be recognized. In the event that this does happen, enter

the appropriate extension after the filename, such as

".dxf" if it is a DXF file, or ".lwo" if it is a LightWave3D

file.

Import > DXF...

Reads files in DXF format. However, HexaSuper2 only

reads DXF files with 3D faces or polyline shapes.

Furthermore, only polylines that are 3D polymeshes or

2D polymeshes can be read. HexaSuper2 cannot

correctly read shapes of polymeshes that use the vertex

group code 71, 72, 73 or 74. You can solve this problem

by exporting the shapes as 3D faces from the other

software you are using, then trying to import the file into

HexaSuper2 again. 

Import > 3DMF...

Reads data from a file in 3DMF format. 

Import > LightWave3D...

Reads data from a file in LWO format. However,

HexaSuper2 only reads the polygon and color data, as it

cannot read curve, patch and texture data.

Import > Rokkakudaioh...

Reads data from a file in Rokkakudaioh format. When

data is read in Symmetry mode, symmetrical shapes are

imported into HexaSuper 2 unchanged. 

Export

The current active document window can be saved in a

variety of formats. Objects in a layer that is set to hide in

the Layers window are not exported. Also, objects

displayed with a curved surface at the time of export, are

saved with a curved surface.

HexaSuper2 can export the following formats:

• DXF

• 3DMF

• LightWave3D

• VRML 1.0/2.0

• Rokkakudaioh (freeware version of HexaSuper2)

• 3DS

• Wavefront Obj

• Locked File

• ROX-TRACE

• X-Trace

• POV-Ray

• Unwrap For Texture

• PICT

Export > DXF...

Saves data of faces as 3D faces in DXF format in

approximately 256 colors.
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When a file is imported into some software the colors

(especially gray) may not be read correctly, or the

software may not be able to read the color information.

When this happens, reset the colors in the software.

Also, some software cannot correctly read the color of

shapes created in HexaSuper2 with more than one color.

To solve this problem select each shape and paint it with

one color with the Paint Bucket tool before exporting, or

reset the colors of the shapes in the other software after

you have imported the file. 

Export > 3DMF...

Saves data of faces, color and textures in 3DMF format.

Some software cannot read texture data.

Export > LightWave3D...

Saves data of faces and lines in LWO format. Texture

data cannot be exported in LWO format.

Export > VRML...

Saves data of faces in VRML format. As the color data

of textures are saved as characters, large image data

generates extremely large files. 

Export >  Rokkakudaioh...

Saves data of faces and lines in the format of the

freeware, Rokkakudaioh. Shapes are saved to the left

side of the document because Rokkakudaioh does not

support left-right symmetry mirror images.

Export > 3DS...

Saves data of faces in 3DS format. Texture data cannot

be saved in 3DS format. When the number of faces

(number of rectangular shapes x 2 + number of

triangles) of an object exceeds 65,000, it cannot be

saved in 3DS format and trying to do so generates an

error message. 

Furthermore, there are cases when some software

cannot read the color data.

Export > Wavefront Obj...

Saves data of faces and normal vectors in Wavefront

Obj format. Faces organized in layers are saved as they

are, but color and texture data cannot be saved.

Export > Locked File...

Saves the contents of the document in HexaSuper2's

Locked format. When files saved in Locked format are

opened in HexaSuper2, changes cannot be saved and a

shape cannot be cut or copied. This reduces the worry of

somebody using your artwork without your permission. 

HexaSuper1 cannot read Locked format.

Export > POV-Ray...

Saves data of faces in the format of the freeware, POV-

Ray. Retracing allows POV-Ray to display the image as

it is  in HexaSuper2 because texture, display angle and

shine data can be saved in POV-Ray format. POV-Ray

can be downloaded from http://www.povray.org/.

Export > ROX-Trace...

Saves data of faces in the format of the freeware, ROX-

Trace. Retracing allows ROX-Trace to display the

image as it is in HexaSuper2, because all texture, display

angle and shine data can be saved in ROX-Trace

format. 

Export > X-Trace...

Saves data of faces in the format of the shareware, X-

Trace. Saves the same data as that saved in ROX-Trace

format.
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Export > Unwrap For Texture...

Saves a wire-image picture of an object or area in

PICT format. Using this picture makes it is easier to

create texture (to paste on an object). 

Choose Unwrap For Texture to display the dialog box

shown above. Set the size of the picture, what to show,

method of unwrap and click OK. Next, import the

picture into a paint software and create a texture

(picture) while referring to the wire image. Then, copy

the picture in the paint software and paste it in

HexaSuper2. Ensure that the same area is selected and

viewpoint angle is set when you paste the picture into

HexaSuper2. In the Texture Mapping dialog box that is

displayed, set "How to map" to the same setting that was

set in the Unwrap For Texture dialog box, "No. of repeat

times" to 1 for both vertical and horizontal, and "Picture

ratio" to fit to object.

If more than one object, or an area containing more than

one object is selected, a picture of the largest object is

exported.

Export > PICT

Saves the image in the active document window in

PICT format. 

Page Setup...

Displays dialog box for setting print options such as

paper size and orientation.

Print...

Choosing Print when there is an active document

displays the dialog box for printing and setting various

options.

Quit

Quits HexaSuper2

If there are any open documents with changes that have

not yet been saved, the save dialog box appears and

prompts you to save the changes.
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Undo

Restores the active document to the state before

you performed your last change. Normally, you

can undo a change even if you have selected an

object or area after performing the change.

However, please note that under certain circumstances

the selected object or area cannot be restored to its

previous state. 

Cut

Removes a selected object or area from the

active document and places it on the Clipboard.

When you select an area containing a part of an object

and any one of the faces of the object is selected, the

selected face plus the selected lines which are not a

part of the selected face are deleted. 

When no face of an object is selected, all selected lines

plus faces which have a selected line as a part are

deleted.

Copy

Copies the selected object or area to the

Clipboard.

Paste

Inserts data that has been copied to the Clipboard into

the active documentas a new object.

When an image has been copied from another

application in PICT format, it is pasted as the texture of

the selected object or area. However, if nothing has

been selected, the PICT image is captured in the color

palette.

Edit Menu3-2
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Paste Left and Right

Pastes the contents of the clipboard that have been

copied in Symmetry mode to the right of the grid box,

and creates a mirror image on the left of the grid box.

This command is only effective in Symmetry mode.

Detailed Explanation

After copying an object in Symmetry mode to the

clipboard and pasting it into the document window, the

mirror image part becomes an actual object and all

actual objects are positioned to the right of the YZ axis.

Duplicate

Duplicates the selected object. When an area is

selected, the objects in the area are duplicated. 

Clear

This is similar to Cut in that it deletes the selected

object or area,  but it does not place it on the Clipboard.

Select All

Selects all the objects in the active document.

Deselect All

Deselects all selected objects or areas.

Invert Selection

Inverts a selection area. All selected objects are

deselected, and any object which is not selected is

selected. When an area is selected, all selected lines are

deselected and any line which is not selected is

selected

Select > Select 3 Faces Edges

Selects lines connected by three or more faces.

Select > Select Sharp Lines

Selects sharp lines.

Select > Select Wire

Selects wire frames (lines without faces).

Select > Select Edges Sharper Than xx

When the angle of the faces on both sides of a

line are greater than the specified sharpness, the

line is selected.

What is a line with a sharpness level higher than xx?

As in the following diagram, when a line has a face on

either side of it, the angle of "A" becomes the angle of

the line. Sharpness refers to when the angle is greater

than "A."

m
Paste Left and Right has been

included in HexaSuper2 to

maintain compatibility with

the freeware version,

Rokkakudaioh. Under normal

circumstances, there is no need to

use this command.
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Lines connected to three or more faces are selected

normally.

Select > Select Face Boundary

Selects lines connected to one face, or three or

more faces. Under some circumstances, lines

selected with Select Face Boundary, cannot be

altered with the Boolean command of the Object

menu.

Select > Sharpness 10%-90%

Selects lines that have had their sharpness set by

the Set Sharpness command of the Modify menu.

Group

Assembles two or more selected objects into a single

object so they can be moved or changed as a group.

Once objects have been grouped together, choosing

Undo from the Edit menu will not disassemble them.

To disassemble a group, choose Edit > Ungroup.

If there are one or more selected areas, the elements of

the selected area or areas are grouped together. Refer

to (52) to (59) of Chapter 1-3, Using Polyline and

Select/Move Area tools.

Ungroup

Disassembles any selected grouped object into

individual objects so they can be moved or changed

individually. 

One object can be divided into two or more objects.

(One object can even lose its integral shape if any of its

lines or faces are deleted. Choosing Ungroup makes

each connected part of a shape become its own object.) 

Choosing Undo from the Edit menu will not

reassemble them. To reassemble ungrouped objects

choose Edit > Group. 

Any selected group area is also disassembled.

Switch Symmetry/Normal Mode

Switches the editing mode between Symmetry

and Normal.

Normally, when you create a new document, it is in

Normal mode. Therefore, the first time you choose this

command, the editing mode switches from Normal

mode to Symmetry mode, which moves all the objects

in the document window to the right side of the grid

cube (to minus position on the X coordinate), and

shows identical shapes on the left side. 

The shapes on the right side of the grid cube are the

m
A "group area" is two or

more selected areas that are

treated as one.

Clicking an element of a

group area with the

Select/Move Area tool,

simultaneously selects all the

elements within it. Also,

dragging an element, drags

all the elements within the

group area. 

Mirror images

Normal mode Symmetry mode
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actual objects, and the ones on the left are mirror

images of them. Mirror images cannot be selected,

moved or edited. Shapes of the actual objects can be

edited, but only on the right side of the grid cube;

moving them to the left side is not permitted in

Symmetry mode. Furthermore, vertices (mirror-center

vertices) created in the center of the grid cube (0

position on the X coordinate) can only be moved in the

center. However, these limitations allow you to create

symmetrical shapes easily.

Pressing the / key allows you to switch the side which

permits editing. Doing so transforms the actual objects

into mirror-images and vice-versa.

Switching back to Normal mode  changes the mirror images

to actual objects and they can be selected, moved and edited.

The limitations described above no longer apply.

Preferences...

(1) General

Selecting or unselecting each check boxes at the top of

the page determines whether the corresponding dialog

box or message is displayed. On the lower part of the

page there are three options to set which mode a new

document is in when you start HexaSuper2, or choose

New from the File menu.

(2) Operation

The amount of time it takes to display a pop-up menu

when you press one of the buttons with "v" on it in the

Tools window can be set by choosing from one of the

"Pop-up menus of tools" options.

"Sphere and Circle" allows you to specify the number

of subdivisions of objects created with the Circle of the

Input Line tool, Circle of the Surface Object tool, and

Cylinder, Sphere, Cone, Symmetrical Cylinder,

Symmetrical Sphere and Symmetrical Cone of the

Solid Object tool. 

Selecting the check box of "Show Transparency

slider" shows the Transparency slider at the bottom of

the Tools window. If your computer is not equipped

with Apple Computer's QuickDraw 3D accelerator

card the changes will not be displayed in HexaSuper2.

However, even if your computer is not fitted with this

accelerator card, when the picture is imported to ROX-

Trace or POV-Ray, changes made with the

Transparency slider will be displayed.

Selecting the "Save as sequential files" check box

prevents a file from being overwritten. When this is

selected, every time you choose File > Save, the

contents of the document window are saved as a new

file and a sequential number is added after the name.
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This menu contains the main commands for

modifying a selected area.

Create Faces For All

Creates faces for triangular or rectangular parts of

all objects. When you use either this or Create

Faces For Selection, faces may be created in

places that you did not expect. For example, if

you draw a cross and then enclose it with lines

using the Input Line tool as shown in the left of

the picture below, not only four triangle faces,

but also one large square face is created.

If undesired faces are created, use Clear Face to delete

them. For example, in the case above, selecting the

four lines surrounding the cross with the Select/Move

Area tool, then choosing Clear face allows you to

delete it. 

Create Faces For Selection

Creates triangular or rectangular faces for a selected

object or area.

Clear Face

Deletes faces of a selected object or area, leaving just

the wire frame. 

3-3 Modify Menu

Create Faces For All
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Line Color

Allows the color for a selected line to be chosen

from a color palette. It is only effective if the

"Display line type by color" option is deselected

on the Environment page in the View Settings

dialog box of the View menu.

Line Width

Allows you to specify the width of selected lines.

You can only display line width when View >

Show Lines Only is selected.

Sharp Line

Creates sharp lines for the lines of objects within

a selected area.

If you make modifications using the Select/Move Area

tool, create smooth surfaces using Smooth, or

subdivide an object using the Subdivide from the

Modify menu, surfaces surrounding the sharp lines

remain sharp. And if you create curved surfaces on an

object using Curved Surface from the Object menu,

surfaces for which Sharp Line is specified remain

sharp  (refer to the Section Set Sharpness, for more

details)

Unsharp Line

Changes sharp lines within a selection to normal lines.

m
Refer to the Select/Move Area

tool explanation in Section 2-2,

Tools Window, when modifying

sharp lines. 

Sharp line
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Set Sharpness

Sets the sharpness of lines in a selected area.

When making curved surfaces using Curved

Surface from the Object menu, setting sharpness

for lines generates a surface with a variety of

sharpness ranging between the Sharp Line and

Unsharp Line modes. Choosing Sharp Line sets

the sharpness at 100%, whereas choosing

Unsharp Line sets the sharpness at 0%. Setting

the sharpness is convenient for displaying subtle

shapes. 

Varying the sharpness of the top part of a cone has the

following effects.

Apart from when an object is given a curved surface, a

line with its sharpness level set, behaves like a normal

line. In other words, the part of a line with its sharpness

level set can be modified like a normal line with the

Select/Move Area tool, or by choosing Modify >

Smooth or Modify > Subdivide.

Subdivide

Divides lines or faces by number of times

specified. All lines, except sharp lines, are

divided into smooth subdivisions. 

Only selected lines are subdivided. For example,

selecting two of the side lines of a rectangle subdivides

them as in the picture below.

Selecting the lines produced by the previous

subdivision and choosing Subdivide again, results in

the face having been subdivided both lengthwise and

crosswise.

Curved

surface

Uncurved

surface

Sharp line Sharpness: 50% Unsharp line

Same
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Smooth

Smoothly blends faces connected to a selected

area when a vertex within the area is moved to

create a continuous and seamless area. However,

any surrounding sharp lines remain sharp.

The Smooth command removes the unevenness from

adjacent vertices, and by repeating this process creates

a smooth surface over a wide area.

Flatten

This moves the vertices of selected faces to

flatten them parallel to the base plane.

An exception is when the base plane button is

selected. In this case, the selected face is flattened

perpendicular to the base plane.

Polygon Reduction

Reduces the number of lines within a selected area by

the specified amount.

Lines are reduced by automatically detecting and

deleting short lines and vertices of areas with few

uneven parts. 

Extend

Duplicates a selected area and connects it to the

original area by lines. 

The duplicated area is grouped together with the

original area.

Lift

Separates and lifts a selected face away from an

unselected area. The method of lifting and amount of

lift can be specified in the Lift dialog box shown

below. 
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(1) Lift directly

Calculates an average face (which is an

imaginable face created by connecting the most

outer vertices of faces within a selected area) and

lifts the selected faces in parallel with the average

face. Finally, new faces are created between the

lines connecting the vertices of the original faces

and the new faces.

(2) Offset

Lifts each selected face in parallel to its original

face, and new faces are created between the lines

connecting the vertices of the original faces and

the new faces.

(3) Make offset surface

Creates a new object by lifting each selected face

in parallel to its respective original face. This

option can be used, for instance, to make clothes

by applying the function after creating a human

object.

Magnify

Choosing Magnify changes the shape of the mouse

pointer to . When this shape is displayed, dragging

an element of a selected area to the left or right with

the mouse pointer magnifies or reduces the size of all

elements within the area. Dragging an unselected

element to the left or right with the mouse pointer

magnifies or reduces its size.
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Stretch

Choosing Stretch changes the shape of the mouse

pointer to . When this shape is displayed, dragging

an element of a selected area in any direction with the

mouse pointer stretches all the elements within the

area. Dragging an unselected element in any direction

with the mouse pointer stretches it. Holding down the

shift key, permits the shape to be stretched in one

direction only.
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Invert Face

HexaSuper2 cannot correctly perform Boolean

calculations if there are faces of an object

positioned towards the back. For example,

"Boolean: Difference" results are obtained for a

"Boolean: Union" calculation. Therefore, before

performing Boolean calculations, invert all back

faces. To determine whether faces are positioned

toward the front or back, select them with the

Select/Move Area tool. Faces with thick lines are

positioned toward the front, and those with thin

lines are positioned toward the back.

Cut Face

Cuts off a portion of a preselected object in the

shape of the object that was selected afterwards

by shift-clicking. Unlike with "Boolean: Difference,"

the portion which was cut off is not covered with a

surface, but remains as a hole.

Boolean

Joins two objects together or hollows out a hole

in the face of an object with another object.

Performing Boolean generates short lines and

long, thin faces, but the tool allows you to

delete the short lines, thus creating a nice shape.

3-4 Object Menu
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Boolean > Union

Creates one object from two objects by joining

them together, as shown in the following picture. 

Boolean > Difference

Cuts off a portion of an object with the shape of

another object, as shown in the following picture.

When two objects are selected by shift-clicking,

the difference of the two objects can be

calculated because the order of selection of the

two objects can be determined. However, when

two objects are selected by performing a

rectangular selection with the Select/Move

Object tool, the order of selection cannot be

determined.

Boolean > Intersection

Creates an object from the intersecting part of two

objects, as shown in the following picture.

Modify Value

A selected object or area can be moved, rotated,

or magnified or reduced in size by entering

specific values in the Move and Rotate Selection

dialog box shown below.

Choosing the "Relative" option allows you to specify

the amount of movement, angle of rotation and

percentage change in size, with regards to its present

position. Choosing the "Absolute" option allows you

to specify the amount of movement, angle of rotation

and percentage change in size, with regards to its

position in relation to the grid cube. Changing the

selection from the "Absolute" to "Relative" option or

vice-versa, returns the values to their initial value.

Deselecting the "Same scale" check box allows you to

specify the direction of change values separately.

When an area is selected, you can only set the values

for the position. Entering a minus value for the x axis

of the size options allows you to invert an object from

left to right.  
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Set Rotation Center

Sets the center of a selected object or area as the

rotation center. To actually carry out rotation, use the

Rotate tool.

When more than one object is selected, the center point

between all the objects becomes the center of rotation. 

Align To Base Plane

Moves a selected object to the base plane of the

grid cube.

Curved Surface

Creates curved surfaces using Pixar's

"Subdivision Surface" technology. Not only the

display of an object, but the actual object itself

becomes smooth. The following applies when

creating a curved surface.

(1) Shaves the sharpness of vertices and edges to create

rounded surfaces . 

(2) In addition, surfaces are pulled together

around positions where many vertices and lines

are concentrated.

(3) The edges of sharp lines cannot be made

smooth.

(4) Parts that have had the sharpness set remain

slightly sharp.

The shape of a surface is dependent on the vertices and

lines. Therefore, move the vertices and lines to

indirectly change the shape of a surface. 

Curved surfaces slow down the display of shapes,

however, you can temporarily remove all the

curved surfaces and display the shapes as

polygons by choosing View > Show Curved

Surface As Polygon, or by pressing the tab key. 

The following describes how making smooth curved

surfaces with the Curved Surface command differs

from using the Subdivide command from the Modify

menu. Use the most suitable method for your

purposes.

1.Creates a smoother curved surface.

2.Does not require as many vertices or lines to display

a smooth surface, thus the size of the data is smaller. 

3.As a curved surface can be created in a position quite

far away from vertices and lines, it takes a while to get

use to. 

The curved surface of the bottom left shape, in the

following picture, was created by choosing Object >

Curved Surface. The curved surface of the bottom

right shape was created  by choosing Modify >

Subdivide.

Center of rotation
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Polygon Surface

Changes a curved surface of a selected object to a

normal polygon surface.

Subdivide By Curved Shape

Subdivides the shape of a curved surface of an object.

Use this command when you want to make subtle

adjustments to the shape of a curved surface. 

Snap To Grid

Makes objects or areas snap to the grid cube when they

are moved. The center of an object or selected

elements of an area are snapped to the grid cube when

they are moved. The length of snap can be specified

with the "Snap" option in the Grid dialog box.

Grid

Various options can be set for the grid in the Grid

dialog box. 

The grid below is shaped like a dice.

Create Various Objects > Spiral Curve

Specifying the length, radius, number of rolls and

number of roll lines allows you to generate a spiral

curve. A spiral curve is centered on the Y axis. You

can use the path of the spiral curve to create, for

example, a spring by choosing Create Various Objects

> Pipe. 

Grid

Base plane Grid lines
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Create Various Objects > Sin Curve

Specifying the length, width, number of waves and

number of wave lines, allows you to generate a sin

curve. A sin curve is created on the XY plane. You can

use the path of a sin curve to create, for example, a

wavy water surface, by first selecting the sin curve

with the tool, then choosing Modify > Lift and

selecting the "Lift directly" option from the Lift dialog

box that subsequently appears. 

Create Various Objects > Rotation Shape

Rotates an object without any faces on the Z axis, to

generates a rotation shape with the number of sides

specified.

A rotation shape cannot be generated from a grouped

object.
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Create Various Objects > Pipe

Generates a pipe shaped object for specified section

object and path object. First, select the tool and

click the section  object to select it. Then, shift-click the

path object to select it. Finally, choose Create Various

objects > Pipe to display the Pipe dialog box. Both

section objects and path objects cannot have faces, and

path objects cannot have a branch or be a circular

shape.

In the Pipe dialog box, you can choose whether the

angle of the section object is fixed with the "Parallel

sections" option, or can be moved with the "Moved

sections" option. If "Parallel sections" is selected, the

angle of the pipe section is fixed parallel to the path

from start to finish. If "Moved sections" is selected, the

angle changes as the direction of the path changes. A

good pipe can be created when the line at the end of

the path nearest the section object is perpendicular to

the section object.

The pipe on the left of the following picture has been

generated with the "Parallel sections" option selected,

and the one on the right with the "Moved sections"

option selected.

Show Information

Shows the Object Information dialog box which

displays various information about the selected

object or area.

Path object

Section object
Vertical
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Commands from the View menu only effect the

currently active document window.

Undo Viewpoint

Restores the viewpoint angle or magnification of

the contents of the document window to the state

before you performed your last change using the

Zoom or Hand tool. You can restore the

viewpoint for up to 10 previous changes.

However, the document window cannot be restored by

this command, if changes have been made with the

Indicator or Distance Meter of the Angle window. 

Redo Viewpoint

Returns the document window to the state before you

used Undo Viewpoint.

Show All Objects

Adjusts the view so that all objects within the

document window can be seen.

Initialize Viewpoint

Returns the view in the document window to the same

viewpoint as when the document was first created,

with the grid in the center.

3-5 View Menu
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Show Lines Only

Displays lines only. When this is selected the

display of the contents of the document window

is very fast. 

Show Monocolor Faces + Lines

Displays monocolor Faces + Lines only. As the

display of the contents of the document window

is faster than when Show Stiff faces + Lines or

Show Smooth Faces + Lines is selected, this is useful

when editing complicated shapes.

Show Stiff Faces + Lines

Displays faces and lines. Faces are displayed with a

stiff finish.

Show Smooth Faces + Lines

Displays Faces + Lines.Faces are displayed with a

smooth finish.

Show Smooth Faces

Faces are displayed with a smooth finish

Show Stiff Faces

Faces are displayed with a stiff finish
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Show Curved Surface/Show Curved Surface As

Polygon

Choosing Show Curved Surfaces shows the

curved surfaces of shapes. Choosing Show

Curved Surface As Polygon, temporarily removes

the curved surfaces and displays the shapes as

they were before Object > Curved Surface was

chosen. When Show Curved Surfaces is selected,

the display of shapes is slow, so we recommend

that you select Show Curved Surface As Polygon

when creating shapes, and Show Curved Surface

to occasionally check the shapes.

Show Grid/Hide Grid

Shows or hides the grid cube.

Background Color

Displays a color palette for choosing the

background color. 

Choosing the button allows you to select a

background color from the Color Picker.

Choosing the button displays the Open

dialog box, allowing you to specify a PICT file to

be displayed as the background picture.

Selecting a background picture when viewpoint angle

is snapped to front face or side face displays the

background picture at the same size as the grid cube,

and when you magnify or reduce the size of shapes it

changes size appropriately, making it easy to trace the

outline of the illustration or photograph. However,

with any other viewpoint angle, the picture is imported

at its actual size.

View Settings

Displays View Settings dialog box for making

various view settings.

(1) Method

All the options on the Method page, except

"Contour," can be set via Menu commands.

However, all options set via the View Settings

dialog box are made simultaneously.

Choosing the "Show" contour option, displays contour

lines on a surface in the color of group lines.Select this

option when you want to closely check the shape or

smoothness.
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(2) Environment

When the "Display line type by color," is deselected,

the color settings below are ineffective and all lines,

except contour and selection lines, are displayed in

black by default. Lines which have had their color set

by choosing Modify > Line Color, are displayed in the

set colors. Selecting "Display line type by color,"

displays line types in the colors shown below. Clicking

the color square allows you to select a different color

from the Color Picker.

The "Curved surface subdivision" option allows you to

set the subdivision of curved surfaces. This specifies

the number of subdivisions displayed for a face of an

object when you choose Object > Curved Surface. 

Selecting the "Show drag in all windows" option,

displays the drag of objects in all windows. This

slows down the display of objects, but makes it

easy to see how the objects are being changed

and moved.

If you have a high-performance computer, it may

be difficult to see the lines when you drag an

object, depending on the number of colors set for

the monitor. In this case, select the "Delay drag to

show lines on fast Macs" option, to slow down

the display of lines and make them easier to see. 

(3) Operation

The "Range of distance meter" option allows you

to set the smallest range of the Distance Meter in

the Angle window.

Hide Selection

Hides selected objects or area. To show them again,

choose View Menu > Show All.

Hide Selected Lines + Vertices

Hides the lines and vertices of selected objects or area.

To show them again, choose View Menu > Show All.

Hide Mirror Image

Hides mirror images when editing in Symmetry Mode.

Show All

Shows all hidden objects.

Polygon Outline

Symmetrical Lines

Sharp Lines

Selected Area Lines
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New Window

Creates a new window showing the contents of

the active document window.

1 Window

Changes the display of the active document from 4

windows to 1 window. Documents are normally

displayed as 1 window.

4 Windows

Changes the display of the active document from 1

window to 4 windows. (Refer to the picture on the

next page.)

Show Tools/Hide Tools

Shows or hides the Tools window. Clicking the close

box on the top left of the window has the same effect

as choosing Hide Tools from the Window menu.

Refer to Section 2-2,Tools Window, for an explanation

on the Tools window.

Show Angle/Hide Angle

Shows or hides the Angle window. Refer to Section 2-

3, Angle Window, for an explanation on the Angle

window.

Show Lights/Hide Lights

Shows or hides the Lights window. Refer to Section 2-

4, Lights Window, for an explanation on the Lights

window.

Show Values/Hide Values

Shows or hides the Values window. Refer to Section

2-5,Values Window, for an explanation on the Values

window.

3-6 Window Menu
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Show Keyboard/Hide Keyboard

Shows or hides the Keyboard window. Refer to

Section 2-6, Keyboard Window, for an explanation on

the Keyboard window.

Show Layers/Hide Layers

Shows or hides the Layers window. Refer to Section

2-7, Layers Window, for an explanation on the Layers

window.

Document Window

The names of all open document windows are

displayed in the Window menu. Selecting a

document name activates that document.

m
Dragging in one window is

displayed in all windows

when 4 Windows is selected. 

To display dragging in the

currently active window only,

choose View > View Settings

and unselect the "Show drag in

all windows" check box on the

Environment page of the View

Settings dialog box.

Four windows
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About Balloon Help...

Displays an explanation about Balloon Help.

Show Balloons

HexaSuper2 does not provide support through

Balloon Help. Therefore, even if you turn it on

from the Help menu, balloons explaining

HexaSuper2 features will not be displayed.

3-7 Help Menu
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Active document

The document window which is

currently being edited is called the

active document

Area

A selection of elements.

Base Plane

The plane that objects are moved and

rotated on. When you create a surface

or solid object the base plane is the

bottom plane. Objects are moved

parallel to the base plane and rotated

around an axis perpendicular to the

base plane. The base plane can be

specified by selecting one of the base

plane buttons at the bottom of the

document window. 

Boolean

One way of modifying shapes, that

involves the combination of two

objects to make one new object. There

are three methods of Boolean. The

creation of a union between two objects

which is called "Union." The hollowing

out of a hole in one object to attach

another object which is called

"Difference," and the combining of the

common parts of two objects which is

called "Intersection."

Border Line

A line that has one or more faces

connected to it, or a line that divides a

selected area and an unselected area. 

A border line also exists around a

surface object.

Bottom Plane

A base plane.

Clipboard

A special memory area that stores the data

of shapes of areas or objects when you

choose either Cut or Copy from the Edit

menu in HexaSuper2. It is not possible to

directly check the contents of the clipboard

in HexaSuper2, but choosing Edit > Paste

allows you to pastes its contents into the

document window. 

Color Palette

Color information stored internally in

HexaSuper2. The color palette stores

information about color, shine, and level

of transparency. 

Dialog Box

A special window, displayed as a result

of operations such as choosing a menu

command, which solicits a response

from the user. Detailed data is input in

and valuable information can be gained

from a dialog box.

Document

A file created with HexaSuper2. A new

document can be created by choosing

File > New, and an existing

HexaSuper2 document can be opened

via the Open dialog box which is

displayed by choosing File > Open. 

Drag

To position the mouse pointer over an

object, press and hold the mouse button,

then move the object to a different location

and release the button.

Edge

A line that has one or more faces

connected to it. A line that has no faces

connected to it is known as a wire

frame. 

Front/Back Face

A face has a front and back side. The side

facing towards the outside of an object is

the front side, and the side facing towards

the inside side is the back side. 

Grid

A cube with light-green lines in the

shape of a lattice, which is shown when

you open a new document window. 

The position of the base plane, the center

face of left-right symmetry and the center

axis when you rotate an object are all

positioned in accordance with this grid. It

is convenient to refer to the grid position

and angle when you create shapes.

Group

Two or more objects that have been

assembled into a single object by choosing

Edit > Group. Grouped objects are treated

in the same way as a single object.

Group Area

A collection of elements, or areas that

can be treated as one. Clicking an

element of a group area with the

Select/Move Area, simultaneously

selects all elements within the group

area. Also, dragging one element of a

group area, simultaneously moves all

elements within the group area. 

Handle

A red square at an end vertex of a

selection frame that appears when you

select an object. Dragging a handle allows

you to change the shape or size of an

object. 

Initial state, Default

The state of HexaSuper2 just after

being installed.

Light

In 3D computer graphics, pictures of a

Glossary
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a model (object) can be taken with a

camera. In HexaSuper2, a light refers to

the light shinning on the objects.

Mirror-center Vertex

A vertex created on the center face (XY

plane) in Symmetry mode. Mirror-center

vertices created on the center face of the

grid cube can only be moved within the

center face, however, these limitations

allow you to maintain the symmetry of

shapes.

Mirror Image

An object displayed in Symmetry mode

that cannot be edited.

Modeling

The process of creating an object within a

three dimensional space.

Normal Line, Average Normal Line

Normal line of a face means a vertical

direction in reference to the surface of the

face.

Average normal line of a vertex means an

average direction calculated from normal

lines of faces surrounding the vertex.

Object

A shape that is made up of connected

lines and faces.The smallest unit the

Select/Move Object tool can select and

move is an object. Objects can be

grouped together. 

QuickDraw 3D

An extension supplied by Apple Computer

for displaying 3D computer graphics.

HexaSuper2 uses it for displaying images

on the screen.

Shape Element

The vertices, lines and faces that make

up the shapes of objects. Each shape

element can be selected and moved

with the Select/Move Area tool.

Sharp Line

A line which is not smoothly blended

to its surrounding area to create a

continuos and seamless area when

modified with the Select/Move Area

Tool. Also, its surrounding area is not

displayed as a continuos and seamless

area even when you choose View >

Show Smooth Faces. To create sharp

lines, choose Modify > Sharp Line.

Shine

The gloss effect on a face is known as

shine. If the value of the Shine slider of the

Tools window is set high the level of shine

is high and if it is set low the level of shine

is also low.

Solid Object

An object with a fill and no border

lines. All objects generated with the

Solid Object Tool are solid objects. 

Surface Object

An object with border lines that has no

fill. All objects created with the Surface

Object tool are surface objects. 

Texture

A picture that is pasted onto a selected

or unselected object is called a texture.

Transparency

A state of transparency of a face. If the

transparency value is large, the level of

transparency is low and you cannot see

through a face. If the transparency

value is small, the level of transparency

is high and you can see other objects

through a face.

HexaSuper2 files are referred to as

documents throughout this manual.

Toggle, Toggle Operation

To switch back and forth between two

settings. For example, you can toggle snap

to grid on and off with Object > Snap to

Grid. Selecting it once turns it on, and

selecting it a second time turns it off. 

Viewpoint

In 3D computer graphics, pictures of a

model (object) can be taken with a

camera. The viewpoint is the position

of the camera, that is the location from

where it views the object. 

Wire Frame

A shape with lines but no face. In

HexaSuper2, you can make a wire-

frame shape with the Input Line tool.

You can also hide the faces of a shape

so as to view the wire frame only by

choosing View > Show Lines Only.

X/Y/Z axis, XY/YZ/ZX plane

In HexaSuper2 the coordinate axis are

set as in the picture below.

Glossary
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