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| Preface

Filevision IV has a long Macintosh history and is the latest and probably
the most dramatically changed version of the original Filevision pro-
gram written in 1984. In fact, Filevision was actually programmed on
Apple's Lisa computer prior to the release of the first Macintosh.

The Filevision program has undergone two major metamorphoses to
reach the current Filevision IV stage and has experienced an impressive
following through these changes. Included are many of the Fortune
1000, colleges and universities, and numerous government agencies.
Professionals in most of the major disciplines have also found unique
solutions for their professions using Filevision and its offspring.

The original Filevision was considered a masterpiece of Macintosh
programming by many reviewers. When the first version of Business
Filevision was released, it received the award for Best Software of the
Year by the American Federation of Information Processing Services
(AFIPS) who mainly consist of managers of information services (the
M.LS.s) throughout business and industry.

Filevision was designed as a totally unique object oriented database
that packed a considerable amount of power considering the limitations
of the earlier Macintoshes. The program included a fully functioning
drawing page with every object linked to an attached database record.
While the drawing page was limited to a small 4 x 6 size, and the data-
base was somewhat restricted, the unique concept of hypergraphics
and integrated imaging was born.

From its earlier origins, a major upgrade was released in the early part
of 1986 which bore the unimaginative name of Business Filevision.
While the name may have been unimaginative, the inner workings of
the new Filevision were far from mundane.

The drawing page was increased in size and many new methods for
creating, identifying, manipulating and presenting the graphic objects
were provided. Several additional database functions were added to
allow for sorting, searching and better highlighting, increased reporting
flexibility, larger records, fields and files, print preview, LaserWriter
compatibility, the ability to paste graphics from the Clipboard, storage
of graphics in record fields, annotation fields, mail merge form letters
and much much more. '

Since 1984, the Macintosh continued to grow in power and capacity

and the possibilities for bigger and better versions of Filevision became
both obvious and realizable. Avid Filevisionaries began submitting
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So what's new?

Filevision IV

their "wish lists" and in 1987 the development of Filevision IV began.
Over forty of those requests have been implemented in Filevision IV.

All files created using either Filevision or Business Filevision are
convertable to Filevision IV.

Filevision IV has been enhanced far beyond the initial versions of
Filevision and Business Filevision. Some of these enhancements are:

An increased drawing page size which is incrementally selectable
up to a full 30 inches tall by 32 inches wide. The Info page is still
30" X 30H'

The entire drawing and Info pages can now be selectively output to
a printer via the Print Page function.

A relocatable windowed drawing and Info page with standard
scroll bars, zoom, close and resize boxes.

The ability to import various graphic formats directly from their
files. This includes MacPaint, discrete object PICTs, and EPSF (En-
capsulated PostScript Format) graphic types.

The ability to export to a separate PICT file any single object on the
drawing or Info page, group of discrete objects or the entire
drawing page.

The ability to import EPSF graphics, store and catalog them, output
them to a printer or export them back to an EPSF graphic file.

Version 1 color development in both the drawing and Info pages
with combinations of foreground and background colors for
graphic objects, shades, symbols, text and record fields.

The ability to display the full 256 color palette of imported version
2 color or photographic gray scale images.

Four drawing page zoom views from 33% to 200% with drawing,
mini page and text entry features fully supported in all views.

A floating and disposable tool box with pop-up line width and line
color menus, current shade preview box and added drawing tool
functions.

Larger symbol and shade palettes with 40 units per palette.

The added ability to copy any number of customized shade
palettes to the Scrapbook.



Added rotate, slide and invert functions in the Shades Editor.
File protection with semi-automatic and/or manual file Save.
On-line context sensitive help (fully illustrated).

Maximum monitor utilization on both monochrome and color
monitors with up to 35 inch screens.

Overlapping or side by side drawing and Info page windows.
Extended MultiFinder compatibility.

Windowed form and print layouts.

A scrollable -View Print- preview window.

An increase in drawing page layers and database Types to a
maximum of 32.

Increased drawing page object size and the number of an object's
anchor points allowed.

Increased drawing page text entry to 4,000 characters per block
An increased file size to a maximum of 16 megabytes.

An increased record size to a maximum of 16 kilobytes.

An increased field size to a maximum of 8,000 characters.

The maximum number of fields has been increased to 255.

The Import/Export Utility, previously packaged separately, has
been integrated as a directly invokable Filevision IV function.

Increased number of characters in formula fields (up to 300).

Pop-up field menu in the field set-up dialog for auto placement of
bracketed field names in formula fields.

The ability to hide field names in the Info page (for creating
spreadsheet look-a-likes or adding spreadsheets to the Info page).

The added ability to group multiple fields in the Info page layout
and Print Format windows for concurrent relocation.

Modifiable drawing page rulers with selectable points of origin,

scaling, adjustable zeroing, adjustable initial starting values and a
selection of several standard linear measures.
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What's next?

iv Filevision IV

Horizontal and vertical cursor tracking screen coordinates.
Print optional drawing page grid and guide lines.
Optional display/print front/back grid and guidelines.

Increased number of fonts available from the hierarchical Text
menu (up to 256).

New Options menu for several drawing page options.
Increased number of text sizes and styles.

Increased number of line widths.

Rounded rectangle edit dialog with variable corner contouring.
Optional text masking.

Auto scrolling.

A field "Close Lines" function has been added to fill in the empty
lines and spaces when printing labels or form letters.

Automatically copy the attributes (color, shade, font, font size,
style, symbol, line width & color, etc.) of any object for use in
creating a new object.

We apologize for those requests that were not included; however, to
accomplish them all would have required another year or two of
programming time. They are all on the list for consideration in the next
version of Filevision IV.

Every effort has been made to insure the trouble free use of Filevision
IV. If you run into a problem that you feel should not have occurred,
we would very much like to hear from you.

Regards,

Marvelin Corporation 3420 Ocean Park Blvd., Suite 3020

Santa Monica, CA 90405
Phone: (213) 450-6813
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|Introduction

What is
Filevision IV?

Filevision is a combination drawing program and muliilayer database with each
of 32 possible drawing layers attached to their own unique database. The
drawing layers can be displayed in several combinations with all layers show-
ing, selected layers showing, selected objects in each layer showing or in any
combination. Each object (shape, symbol, line or text) is attached to its own
record within that drawing layer’s database Type.

If desired, up to 32 databases can be established within one file without the re-
quirement to attach drawing page objects. Each database can be unique with its
own record set-up and reports.

[ & File Edit

Types HAccess Options Teut Symbols Shades

Filevision is easy to set

g

us Map - Actual Size g  up and use and provides

l:% E:
400] . 800] | 1200] __ 1&00] | 2000 2400 | 2800] . ("2 all of the standard
Median Family Income .
15,000 A|C] database features with
] » 15,000-47,500 to one of the most flexible
4 . #
8 £ g2 1< and understandable
7 Py s 777 20’000-22’500 ’Q -~ .
_______ 1500077 R A 2:.50025,0m / methods provided on
] st AN R 250005 s —] any computer. Features
§ such as Highlighting
= 7
ECT Info for this Income: (51 records) S5 —")T) both records and
. /7] EITLINTN  Colifornia Total Population 26,345,300 drawing page objects,
2 2-| [HHIncome 0-5k | 11.5% | [HH Income” 5-7.5k | T 1%
g »-| [HHincome 7.5-9k [ 7.8%][HH Income 10-15k 4.8% many ways to format
- 77| [AHIncome 15-20k 13.1% | (HH Income 20-25k 0% and display fields,
s+ [HHIncome 25-35k 16.5% | |[HH Income 35-50k 9% ) .
3 22| [HHInceme 50k Up 3% unrestricted field
3 Per Capita Income $8,296 | [Owners of Homes 3,837,000 .
§ Homes 0-30K | 5.1% | [Homes 30- S0k IT 10.5% contents and the ability
19 1 Homes 50-30k 29.8% | |[Homes 80-100k 19.0% .
Homes 100k U 35.5% | [Median Home Yalue $84,700 o Change any of these
[MedianRent [ §353] features at any time.
12T 2 o Total Income {MM) $218,561] [Number of Households 9,709,500
8 Relall Sales [MM] | $167,364 ] [Median HH income | $18,170
9] Buying Index 11,964 } [Me dian Family Income 321479 The Highlightjng feature
[Prev)Mext](Bever ) (Drawing ) (i ink] E
— not only allows you to
2] find all records meeting

your specified search
criteria but it also highlights all drawing page objects that are attached to those
records.

The 32 x 30 inch drawing page supports a full set of drawing tools, a modifiable
shades palette, multiple line widths, text and a modifiable symbol palette for
entering special symbols. All of the objects entered on the drawing page can be
displayed with different foreground and background colors.
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You can also import and export, store, retrieve, print and display Paint, discrete
object PICT and Encapsulated PostScript (EPS) graphics. PICT's can be im-
ported and exported as both discrete objects or single image pictures. All can
be attached to or stored in their own Info field.

The drawing page can be set to a drawing mode or to various display modes
such as blinking, black or nothing when an object is selected. All objects
entered on the drawing page can be identified and named in the information
area title bar.

Besides the various ways to display each layer or object, pop-ups can be created
to display detailed information about the object selected or to create legends or
other general information. Double clicking an object can link you directly to
that object’s database record or to another file which can provide even more
detailed information concerning the object. All of this is supported in either
black and white or color.

Picture an information management package that integrates a full function filing
system and complete drawing system with a versatile report generator. A
system complete with computed fields, three-level sorting, and statistics.

Filevision represents information in pictures, as well as numbers and words. It
sorts and analyzes the extensive data behind these “smart drawings”. And
Filevision prints out a limitless variety of business reports.

Filevision is unique amongst the computer programs offered for personal
computers. It doesn't fit any of the many standard classifications used to
categorize these programs.

Filevision is a database but goes far beyond the concept of standard databases.
Filevision is a drawing program but goes far beyond the concept of standard
drawing programs. Filevision is a desktop publishing tool, a desktop presenta-
tion tool, a desktop mapping tool, a mini word processor/mail merge program
and it now even emulates a mini spreadsheet program.

These are all functions that Filevision provides to allow the development of
powerful solutions as an object oriented integrated imaging database. The idea
underlying Filevision is to demystify the accumulation of data and to allow a
connection between the data being accumulated and the real visual world.



For instance, if you are working with a map of the United States and
would like to determine who all of the personnel are in your Chicago
office, double-click the Chicago branch symbol on the map and bring
up the database record to provide that information.

Creating a master file to represent this task would appear something
like the following illustration:

Drawing page

MASTER FILEVISION IV FILE

(é File Edit Types HAccess Options Text Symbols Shades

Master File - Actual Size

Info page

E[J=————= Info for this Branch 0ffice: (7 records) g—_ﬁlél

Branch Office

Chicage

Address

Chicage

Job Description Personnel

3482 Main Street
Chicago, IL 60111

REVCRCENED Sl Jack Cohen 5023} 444-5555
Cust Relations RDEIEESlels:l0) %2) 4314_1111

Order Desk Jill Barton
Branch Manager BETIENT

Factory Mngr Bill Baxter
shipping Dept - B
AlR Kay Mason

AlP Sally Newmanr . $1485,322
Credit Mngr Dennis Kelly $4,444,250
Bookkeeper Faye Albetts
Receptionist Jane Kelly

|

Prev][Hext]Baver ) [Drawing J[Link) K] |
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5




6

Filevision IV

Using this scenario, your master file could be represented graphically something
like this:

Drawing page Info page
Layer (type) #1 - Branch Office Record for the Chicago
Grench Orficas branch office.
- W =

Layer (type) #2 - U.S. Map

The fact that there is one drawing page object per office does not limit the
number of records that could be created for each office. As long as the key sort
field is entered with sequential keying information, a separate record could be
created for every employee at that office.

The drawing page layers provide links to their own unique database type with
each object linking to its own database record. The records for each of the
other branch offices are represented below:

Drawing page Info page
Layer (type) #1 - Branch Office Record for the Chicago
Brench Orfices \ branch office.
w
Y/ [\
C——
/ C———
/ e [\

AR\

j ]
Layer (type)#2 - U.S. Maj Miami \
yer (typ >l p_—_: , — : L———A\
ouston I——-
yA I I :
;7/ Los Angeles I \
y Seattle l—————\\

4
77 T N\
#/ San Francisco \




So far only records from the Branch Office type have been shown. The U. S.
Map may contain additional information relating to the 50 states, such as
demographics:

Drawing page Info page

Layer (type) #1 - Branch Office

Branch Offices

/ u ; Map \ Record for Florida
demographics
| I |
/
o= / [ \

aa g W
PR _ \  —

Layer (type) #2 - U.S. Map /

/ e

In this case, there could be 50 separate records, one for demographic informa-
tion on each state.

But the file is lacking some important information. What about customers. A
new type can be added any time for additional data on various areas of interest
and can be easily placed at any level of the drawing page. Even if the new layer
were placed at the bottom, a direct double-click on one of the customer sym-
bols would bring up their record:

Drawing page Info page

Layer (type) #3 - Customers

Customers Record for XYZ Corp
- .- - in Orlando, Florida

Layer (type) #2 - U.S. Map

And if there were several areas of interest that were all related, either visually
(as with the examples so far) or that require data only, up to 32 database types
could be established within a single file. While the addition of new types will
create additional drawing page layers, it is not necessary to enter objects on the
drawing page for the Info page to supply the necessary data:
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MASTER FILEVISION FILE

Drawing page Info page
Records without attached
drawing page objects
y AN
AN
L AN
Type layers without objects y4 2\
4 AN
N\
AN
N\
AN
N\
4 AN

L ] [ AN

A S Y

e——— ] ————————

J A————— Y

N\

y A —\

/ Customers \

It might appear that most any complex problem could be handled with the
power and flexibility shown in these examples. However, in case the problem
requires even more definition, Filevision provides additional capability in rapid
file linking.

Filevision automatically provides a Link field in every record of every type
which allows you to link directly to other Filevision files. For instance, if you
wanted to view a detailed floor plan of your Chicago office, all that is required is
to click the Link button with the Chicago record selected. The floor plan file
launches automatically, replacing the current Master File.



If the name of the Chicago office floor plan file is entered in the Link field as
"Chicago", whenever the Chicago branch office record is selected, clicking the
Link button (from either the drawing or Info page) will automatically launch
that file. The option to double-click the Chicago icon from the drawing page's
map to launch the Chicago file is also available if desired. The Chicago record
would now appear as:

E0)====—=—= Info for this Branch Office: (? records) S===—==="| Linking to any file hierarchy in
Fﬁ_ ~ Address any direction is possible without
5 M i S . . . M
chicago 2482 Maln Shreet limitation to the number of files

Job Description Personnel Chicago, IL 60111

except as restricted by available
disk space. All folders will be
searched for the targeted link file.

Sales Manager Helegeslicl] m(ﬁgz) 444-5555 ]

Cust Relations RNl EIt]
Order Desk Jill Barton ZX3 (602 4441111 ]

Factory Mngr Bill Baxter Branch Manager

Shipping Dept  Faeengiield Office Manager XY . .

AIR Kay Mason The new Chicago file also has all

AlP Sally Newman Sales MTD $7,485,322) s

Credit Mngr Dennis Kelly Sales YTD $4.444.250] of the capabilities of the master

Bookkeeper Rl Filevision file and any to the

Receptionist Jane Kelly . . .

' (NI Chicage ) records in Chicago file can be set

e T T e T to link to even more files or back

to the master file.

r % File Edit Types HRccess UD@B_T\BH'( Symbols Shades

f=——_--==—=—--= Chicago -fictual Size
b 1\6‘&}_/1 L

01 . SCII ) 1 OOI 200| 250| 3001 350'
: Floor Plan
0 1
1 Parts Finished Goods
g_ Dept Inventory _I
Black
] —

|oo—-

' “ Reception
As:;r::llﬂ 1 Production Line #1 P
Branch

Final i1 H
Assembly2 Production Line #2 Manager
Final ( onLi
= Production Line #3 .
AssembI;3 Accounting

lnt.n—-

Icom

Floor Plan: (44 total> h:95 v: 18 Ruler:Feet

| [Prev]Hext)(info) Eiwi]]

In linking files, up to five levels of nesting is provided that allows you to return
to each of the previous files in the order that they were first called. This is easily
accomplished from the File menu's Return To... function or by issuing a Com-
mand-; (semicolon).
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Filevision information is organized in a simple hierarchy: files, types, objects
and records, and fields. An office filing cabinet offers a good analogy to that hi-
erarchy. Suppose you have a filing cabinet with four types of information
stored: employees, customers, inventory and production. (Floor Plan would be a
fifth type with no records.)

File
records
[ | = Name 7
5 Address a record
(| City, ST ZIP
/ Record ||} Phone .
=" //é 1z Soc Sec # fields
Employees Salary
. Department
I:I ! Start Date ——
mi Cu;ig_;w ors record for
this object the
\ File
(| E==————=hicago - fActual Size BE
501 100l 15El| ZDDI 250 300[
[— . l ﬂ=t- 1 i
fventory Floor Plan
the re-
- cord's
.l pe= object
Production p - and
= Parts Finished Goods ' .
= Dept Inventory ocation
Types —
1
3_ Le Le e |l Recention || the
Assembly 1 ( Em Info for this Employee: (22 records) object's
3 Name DI Info
o Add 3482 lllinois Ave, Apt 4-A
! {5 erro— _ page
I d 0] State FA[ 60611 d
selecte Phone i recor
H Final
object E ( Soc Sec # IR
% Department
selected [ Firwal Assemnbly N
T Tor26 |
ype = $5.20 perhour}, .
. Employee: Talbot, James| 5 fle|dS
[ [Prev)fext)(info) s midka]_TiCrav)Bext) Bever t) (Draving (g (O
10 Filevision IV



using the file

You could then say that a

File refers to the file cabinet.
Type refers to either “Employees”, “Customers”, "Inventory" or
"Production”.

Object  refers to an individual employee, customer, part/assembly or
production station or cost center.

Record  refers to the file folder of information you keep about each
employee, customer, part/assembly or production station or
cost center.

Field refers to the placeholder for each specific piece of informa-
tion in the record, like Name, Birth date, or Street Address.

However, this analogy tells only a small portion of the Filevision story. The
simple file handling described above can be achieved by most any ordinary file
manager or database.

The main difference with Filevision is that you can set up several different
integrated imaging database Types in one file AND you can illustrate the

locations of every object contained in that file, visually showing the relation-
ships. Even if they are objects from different database Types.

Now that the files are set up, there are a number of ways to display, enhance,
report and generally manipulate the information (both data and graphics) to an
extraordinary analytical advantage. A few are shown below:

* You can print the current page, either drawing or Info.

* You can print reports, forms, labels or mail merge form letters.

*  You can sort, find or highlight and analyze various information.

* You can create pop-ups for "tuck-a-way" legends or greater details on
any drawing page object.

* You can create shaded map thematics for analyzing potential new
markets.

Infroduction 11



printing a page

In printing the current page, Filevision allows you to print all of the page or

selected sections. Issuing a Print Page instruction from the File menu, either of
the following dialogs (depending on which page you are currently working in)
will allow you to select which section (page) or sections to print:

setting up and
printing reports

Select drawing pages to be printed:

[ Print guides
[ Print grid

Drawing page Print dialog

Select info pages to be printed:

Info page Print dialog

In printing out reports, forms, labels and mail merge form letters, a Print Library
is supplied to allow you to keep an archive of all of the various reports for easy
selection and printing. If you select Print Records from the File menu, you will

be presented with the following dialog:

Print Library

From the Print Library dialog, you will have the option to
print all of the records, highlighted records or selected
records. You will be able to direct the output to a printer,
to the screen for a preview and final adjustments or to a
text file for use with a word processor or other programs.

==  liew Print

Print format Type Style
Pop & Area States Report
Demographics States Form
Sales Branch Dffice Report
Customers Customers Label
Form Letier Customers form
[ pelete ] [ Eait ) {( New ]
fRlecords to print: Print to:
O Al ) Printer
@ Highlighted @ Screen
O Selected (QFile
g
State Name 51‘;'59
. Califomia
If you send the print Pew York
request to the screen, it
. ] annsyivania
another window titled Hinois
. . . Florida.
View Print will be Ohio
: . Michigan
displayed to show how Hew durvey
the output will appear gonh Carolina.
. . eorgia
on your printer. This Messachusetts
: Yirginia.
will allow you to make Indiona
final adjustments to Mssourt
. Owerall Count:
eliminate a few wasted Overall Total:
Overall Average:
Pages or sheets Of Overali Standard Deviation:
labels. [Eancel)[ Done ] K7]

] Population % U.5. Pop.

States with over
5,000,000 population

Sq Miles % U.S. Area

26,345,300 10,967 158,762 4319
17,966,200 7479 49,656 1.351
16,408,700 5.831 267,346 7072
12,012,000 5.001 46,063 1253
11,640,400 4846 56,400 1.534
11,435,200 4760 60,295 1.640
10,236,000 4511 41,222 1121

9,211,900 3835 96,791 2633
7,618,300 3172 8,220 0.224
6,304,300 2 625 52,596 1.430
5,990,500 2.494 58,924 1.603
5,847,400 2.434 9,216 0.251
5,785,000 2.408 42,326 1.151
5,585,800 2.325 36,519 0.993
5,003,300 2.121 69,674 1.895
5 5

158,082,000 65.509 1,054,005 28.670

10,538,800 70,267
5,924,710 85,170
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sort and
statistics

Sort printing as follows:

Primary sort field:

[State Name ]

[ secondary sort field:
[% u.s. Area ]

% 11.5. Area

& U.S. Pop

Link

Population
Square Miles
State Name
Total US Pop

plicate sort

fields

Start a new
page for each:

O0

g

a

If you need to do a specific sort or create statistical information for your report,
Filevision offers easy to understand and fast methods to set up these functions
with the following dialogs:

highlighting

Statistics for: [Square Miles |

Standard

Count Total Average deviation
Overall statistics . . . . X | [} |
By State Name . . . . . a a a O
By % WS.Area . . . . . . M| O [ |
By%Uus.Pop . . . . .. O [ O [
Use "Sort" to select different detail statistic fieids.
Sefpat TNuerlCY from (he Formal meag 1o eanble alf statisling,
( cancel | ( Prev Field | ( Neut Fieid ] (_pone |

One of the most powerful and unique features of Filevision is the ability to

select specific records based on an extremely versatile Highlighting search
criteria and then to isolate these records from all others. Not only are the
highlighted records isolated in the database but all of the drawing page objects
that are attached to the highlighted records are themselves highlighted. The
search criteria dialog for achieving a Highlight condition is easy to use:

Highlight "Customers™s meeting these conditions

Credit Limit is

greater than or equal to

$10,000
——— @ AND — OR

Credit Limit

Name
Receivables

O &ankiG ta 5

Receivables is

greater than or equal to
Credit Limit

@ AND =) DR

{® AND — OR
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The criteria in this example would find all customers that were at or over their
credit limit, but only those with credit limits greater than or equal to $10,000.
With Highlight, you can search on one or more values, on the ranking, i.e. the
fifth highest buyer or all of the top ten buyers, or on a comparison of one or
more fields as in the this example. You can AND or OR the search criteria up to
four times per page and you can AND, OR or Replace several pages of High-
lighting criteria each session. You can "swap" all Highlighted records for all Not
Highlighted records by toggling them with a Command-W command key chord.
The possibilities are limitless.

And if that isn't impressive enough, Highlight not only finds all of the records
that meet your search criteria, it also Highlights all of the objects on the drawing
page that are attached to those records. Once highlighted, you can easily locate
and analyze or perform other drawing page functions such as changing their-
shade patterns (or colors).

Besides the numerous obvious advantages that Highlight provides, it also adds a
quick and simple method to generate thematics. The following example shows
the easy process to create mapping thematics.

Using the U.S. Map type from the Master File (containing income demographic
information), Highlight all states with median family incomes of between
$20,000 and $22,500. The highlighted drawing page would appear as:




pop-ups

Access the Shades palette and assign the highlighted states a shade pattern (or
colors). By repeating this process for each range of incomes, you would end up
with a full thematic representation of all state's median family income levels.

If you then copied all of the thematically shaded states into a new type, you
would have a permanent record for this thematic. Add a legend and your
thematic map is complete.

E[E==——————=———-————— Master File - Actual Size

///7// 7 77,777
7

Z

Median Family Income
] 0~15,000
15,000-17,500
17,500-20,000
2 20,000-22,500

22,500-25,000
B 25,000 & Up

Income: (51 total)

Prev)Hext||Infojli ink

After finishing your new Income Type map, select Hide All from the Access
menu and the map is hidden from view until needed. You are then free to
create additional thematic types and hide them for later access and analysis.

If a little more detail is required to provide additional information on an object,
Filevision allows you to create pop-ups. The process for creating a pop-up is
simple and pop-ups can be added at any time you feel that further explanation
or information is required but not enough to keep it visible at all times. The
pop-up can be of any size, up to the full drawing page. Information such as
topographical features, the migration of the Monarch butterfly or the firing of a
neural synapse could be displayed at the click of a button.

Intfroduction 15



what you can do
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As an example, let's assume that your branch manager in Chicago was planning
a visit to the Los Angeles office but was unfamiliar with the Southern California
freeway system and wanted to see the best route to the office from LAX. Just
click on the FWY button:

v Beveﬁy
Hills Lo

Hamthorme

Gardena Com?ton
; o

Bellflower

You can put Filevision to work helping to solve your personal and business
problems. Or training. Or research. Or whatever your interests may be. With a
little creativity and a few clicks of the mouse you can:

e Point at any part on a technical drawing and retrieve printed specs and
detailed exploded views.

* Map an urban community and provide detailed information on every
element within the community.

e Create a complete estimating, job scheduling, invoicing, daily reporting,
backlog reporting and scheduling board for the operations of your busi-
ness.

e Utilize demographic information to create map thematics for determining
new markets.

e Store your library of Paint, PICT and PostScript type graphics for later
retrieval.



what Filevision
can do

Develop a security system with a database of your employees including
their personal information and identification photographs.

Identify, catalog and illustrate your prized butterfly, stamp or coin collec-
tion.

Manage an archaeological dig with map locations and detailed information
on all finds.

Click on a stock shelf and retrieve the cost of goods. Then print out a
report that calculates gross margins.

Identify the location of dated perishables in your inventory.

Click on a symbol and “pop up” a detailed drawing. Or hide details that
clutter your view.

Highlight your best markets on the screen. Or print out last month’s worst
performers.

File customers using an on-screen sales map. Then printa customer list,

sorted by anything from flavor preference to shoe size. In the click of a
mouse.

record, edit and interrogate visual, numeric and written information

importt and display gray scale photographic quality scanned images.

sort, merge, select, compute, initialize and copy information

draw, stretch, shrink, reshape, shade, cut, paste, move and copy graphics
import and export PICTs, Paint and EPSF (Encapsulated PostScript) graphics
overlap, hide and highlight visual information

change and create shades and icon-like “symbols”

import and export text files from any Macintosh or other system program

exchange text and graphic information via the Macintosh Clipboard with
other Macintosh programs

copy complete database types with their objects and records to the Clip-
board and then to a new file

print lists, reports, form letters, labels and pictures

Introduction 17
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e create a file without graphics—and add graphics later, or never at all

e print counts, totals, averages and standard deviations for the whole report
or part of the report

* set up a mini spreadsheet with up to 256 cells or combine your standard
record fields with a mini spreadsheet

¢ link to related and nested files

e calculate the contents of a field automatically, using the information in
other fields

e create files of up to 32,000 records and 16 megabytes in size
e doitall in color (if equipped)

Because it combines a filing system with a drawing system, Filevision IV creates
a new kind of business and personal software. Tt will revolutionize your ability
to analyze information.

Just picture the potential.

To use Filevision IV you need this minimum equipment:

. a Macintosh Plus, SE or II with 1 megabyte of memory
. an external or hard disk drive
. the original Filevision IV Program Disks

It’s best to have a Macintosh-compatible printer for printing out reports and
graphics.

Also, a Macintosh-compatible gray scale scanner with a Mac II would be
required to realize the full integrated imaging potential of Filevision IV.



How to use this manual

The first thing to do is to make sure you read Section One “Before you start...”.
It contains important material that may save you problems. This "Introduction”
can also give you a quick overview of Filevision.
Section Two, “The Tour”, furnishes you with a sample file in order to teach you
the fundamentals of Filevision. You won't be just an onlooker—you’ll add
information to the file, identify patterns, and print reports on that information.
Section Three, “Using Filevision”, rounds out your knowledge of Filevision. It
tells you how to use every one of Filevision’s functions, step by step. You
should browse through it once just to get a feeling for the scope of Filevision’s
capabilities, then refer to it when you need directions for a specific operation.
Section Four, “Reference”, contains several appendices which include:

¢ Filevision IV specifications

e Filevision IV menus and dialogs

¢ lists of double-click shortcuts and special key combinations

e alist of Filevision and system error messages and possible remedies

e Importing and Exporting text examples

* an ASCII character chart for entering special characters in Filevision

¢ 2 Glossary of terms used in Filevision IV

Infroduction 19
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Info for this Help: (1 records)

PHOENIX MaAP HELP

This map provides access to information relating to specific roadway projects in the Phoenix
area. At present, the only roadways selectable are the highways being built under the
financing of Proposition 300. These are called Freeways under the types menu. DOUBLE
CLICKING on a colored roadway shown on the map will transfer you to a - project specific -
table of contents file containing tinks to additional - more specific - graphics and data base
information.

SELECTABLE OBJECTS
Roadways: Transfers you to related roadway file.

DATA BASE FILES
No attached data bases.

Click on the DRAWING button to return to the drawing.
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Phoenix Arizona
Freeway System Construction Project
Courtesy DelLeuw & Cather
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Before you start...

what you
should know

make a working
copy of each
Filevision IV
disk

converting
Filevision and
Business
Filevision files
to Filevision IV
(see Appendix B)

Before you start using Filevision IV, please read this section. It will save you
time and trouble, whether or not you're an experienced Macintosh user.

You should know these fundamentals of the Macintosh, all of which are cov-
ered in Macintosh, the owner’s guide:

+ how to turn on the Macintosh

s how to insert a disk

+ how to initialize a disk

+ how to use the mouse

* how to select one or several documents on the Desktop
¢ what a menu is and how to choose menu items

* how to use the keyboard and the Edit menu

This section also shows you how to copy disks and files. Be sure to copy your
original Filevision TV disks before you begin the Tour, examples or Tutorials,
and to use those working copies.

The very first thing to do with your Filevision IV disks is 1o copy them. Use the
copies in place of the originals.

If you don’t know how to copy a disk, see “Copying Disks and Files” at the end
of this section.

Business Filevision users who are converting their files to Filevision TV need
only to open the file from Filevision IV. Filevision IV will offer the option to
make a back-up copy in the original Business Filevision format before proceed-
ing with the conversion. After the conversion is finished, nothing else is
required to put the file to immediate use.

Those who wish to convert the older Filevision files to Filevision IV will first
have to convert to Business Filevision. Use the Filevision Convert Utility located
on your Start-up disk. From the converted Business Filevision file, use the same
procedure as above (see Appendix B for detailed instructions).

Before you start. .. 23



copy important
files before
using them

please send
in your
registration
card!

24 Filevision IV

A file is the portion of the disk where Filevision keeps the information you work
with. When you use a file, Filevision automatically updates that informatior.. So
i'sa good idea to make a backup copy of an important file before using it.

If you don't know how to copy a file, see the next section “Copying Disks and
Files”.

The enclosed registration card serves a variety of purposes. When you send it
in you'll be enrolled in Marvelin Corporation's Customer Service Program. Your
membership entitles you to:

* special promotional offers

» notification of upgrades when available

* free tips and hints

free technical assistance

You must send in your registration card 1o receive these services.



~  Copying Disks and Files

c°pying This section tells you how to copy disks and files. If you're an experienced
Filevision IV Macintosh user, there’s nothing new here. But experienced or not, copy your

— . Filevision IV disks immediately!
files onto a

hard disk
copying to «  Start by first creating a new folder called Filevision IV on your hard
— your hard disk disk desktop {the rcot directory).

* Insert each of the
- Filevision IV diskettes
& File Edit Uiew Special into the floppy drive. As
soon as the floppy icon
is showing, double-click
it with your mouse
pointer to open the

N == T floppy.
o =..! i wme 702K in disk 9B available

K

HD20
13 ,6€2K in disk

i 2iters

Sy stem Folder

»  Select all” of the files on
the floppy by marquee-
dragging, shift-clicking,
command-A or by
chosing Select All from
the Edit menu. All of

- the file icons will turn

o black when they are

selected.

- +  With the mouse button depressed and the pointer on one of the
selected files, drag all of the files to the Filevision IV folder on your
hard disk. Your Filevision |V folder will turn black as soon as you
have positioned the mouse pointer over it.

*CAUTION: If your hard disk already has a System Folder, do not copy the
— System Folder that is included on your Filevision TV Start-up disk. Having more
than one system file on your hard disk can cause unexpected problems.

If you want to replace your hard disk System files with the Filevision IV system,
boot yvour Macintosh using the Filevision IV Start-up disk and then remove the
System Folder on the hard disk. You can then copy the new System Folder
safely.

Before you start... 25



The Macintosh will show you a dialog informing you of the copying actions and
when it is finished.

copying + Insert the disk to be copied into the internal drive.
Filevision
disks

+ Insert a new disk or a disk you don't need in the external drive.

This is called the destination disk.

= If the destination
disk is new, a
dialog box will ask
if you want the
disk to be initial-
ized. Click the
Initialize button,
then type in a
name when it's
requested—for
example, Copy of
Start-Up Disk—
and click OK.

% File Edit Uiew Special

»  Close all the
windows on both disks by clicking the square cioseboxes at the
upper-left corner of each window.

« Move the pointer on top of the icon of the disk you want to copy.
Press and hold down the mouse button.

The icon turns black.

+  Still holding down the mouse button, drag the icon of the disk you
want to copy over the icon of the destination disk. The icon of the
destination disk will turn black when the pointer is positioned prop-
erly:

- Release the mouse button.

Youll be asked to confirm this action, which will erase all the files on the desti-
nation disk.

+ Click OK.

26 Filevision IV



copying a file or
folder onto the
same disk

% AN Edit  Diew Special

In a few moments the disk will be copied. If you are using an older version of
the systern, it will automatically eject the disk in the internal drive and ask you
to reinsert the system disk.

» |f asked, insert the system disk when the copy is compiete.

In this example youw'll make a copy of the Tour folder, which contains two files.

+ Locate the Tour Folder on you hard disk (there isn't enough free
space to copy the Tour Folder on the same floppy disk).

« Click the icon of the Tour Folder.
The folder icon turns black.,

»  Choose Duplicate from the File menu.

New Folder 3N

Open *0 71K, availshl
Print 4, arars

Close sgwBE= Filevision 11} =
14 436K in dizk 4, 716K avatlable

Get Info ®1 =
Duplicate . ®D

HETHIEtEHE T
4 hiz First! Taue Faldar

Page Setup...
Print Directory...

Fiagt HE

TeachText Import/Export Files

After 2 moment you'll see the new folder appear, bearing the name of the old
one but preceded by the words Copy of. Both of the new Tour files inside the
folder copy will retain their original names.

Before you start... 27



LEGEND
PETROLEUM FACILITY

Col cuemcal FaciTy

LEGEND
%,  HESS
*»

R
N

DOUGLAS
LL&E

97-5@ U.S. COAST GUARD 9250
@ e

Mobile, Al. 36652-2924
{205) 690-2201

Facility Information Form

Facility Name: | Alabama Dry Dock and Shipbuilding Carporation (AD0SCO)

Address Facilily Type:

SEE BELOW FOR FACILITY TYPES
Cunn & Bradstreet No.

Telephone: |

Transport Mode Avaijable

][Rail: [1 | [Truck: [50] [Pipe: [1 ]

Emergency Informalion

Please check the
appropriate box or boxes . 1 SR |

24 Hour Telephone No's.: |
24 Hour Contacl Persons: |

Security Guard Tel. Na's.: |

Guard Dog (Y/N)] [Tel. Ro's.. |

Local Fire Dept. Tel. No's.: | |

Product Information
Hax.Cap.(a) Product{b)

Product(a) rax.Cap.{b)
—

FACILITY TYPES:[NEC, OWP, BULK, HAZP, POTY, CHEMIEAL |

Local Police Dept_Tel No's.: | ]

: THREEMILE
.- CREEK ..

Hazardous Materials and Spill Control solution
for the Mobil Bay Alabama waterway system.

Courtesy of the U.S. Coast Guar
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Segtion Two

The Tour

Starting the tour

A first look at Filevision IV
The Info page

Types

Records

Fields

Highlighting

The Drawing page
Printing a Report
Graphics

Hiding and Showing
Linking to another file



Courtesy Bruce Parkinson
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| The Tour

before
you start...

This is where you learn the basics of Filevision. You'll use Filevision to manage
a real estate townhouse development situated next to a golf course.

It you haven’t read the preceding sections, please do. They'll help vou get the
most out of Filevision and start you off with good working habits.

A word of caution: Never turn off the Macintosh without first choosing Quit

from the File menu and returning to the desktop. Your file could be damaged

and you would definitely loose maest of your work on the file after your last

Saved version.

|D

|Daw

Edit Types Access Options Text Symbols Shades é
Nt . =X E Brushwood Heights - Actual Size E
Gpea.. ] | %00] | 1200 _ 1500 1800 , 210 Z4007
Close Brushwood Hei...
Save b3 ﬁ:"

Save Rs... Brushwood Hills
Retuts 8., O I I Estaies and
Country Club

Import Graphics...
Epgart Graphics...
Import/Export Teut...

1\

Page Setup...

Page Size..,

Print Page... %®U -
Print Records... %P |, .1

||Dom

(27 total)

Tosnhouse :

[Prev][Next][infolfi ink]

h:241 w3

Ruler:Feet

The Four

@
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Starting
the tour

starting...

Now that you have read the preceding sections, you're ready to embark on your
tour. You should use a working copy of the Filevision Start-Up Disk in your
Macintosh internal disk drive and a working copy of the Program Disk in the
external drive. If you are working with a hard disk, ignore the drive instruc-
tions.

You will be exploring and adding to a file that a manager of a townhouse
development or a home owner’s association might use.

*  Turn on your Macintosh.

* Insert your working copy of the disk labeled Copy of Filevision IV
Tour in the internal drive. Hard disk users open the folder that con-
tains your Tour Folder.

The desktop and file icons appear.

S[1=—— Filevision Tour ==—0)5| copying the Tour files
4 itemsz 72,300K in disk 4 ,644K zvailable
7~ You'll alter the Tour file, so the first thing to do is
- — to copy the Tour Folder. That way, someone else
- can take the tour later.
Tour Folder Print Estimator
+ Click the Tour Folder icon to select it.
+ Choose Duplicate from the File menu.
Import/Export Files US Map (Color) {Floppy drive users will have to copy
] the Tour files to another diskette as
K2 R there isn't enough room for both the

opening the
Tour file

32 Filevision IV

original file and copy.)

A new, "Copy of Tour Folder" icon appears.

« Click the Copy of Tour Folder icon to select it.
+ Choose Open from the Fiie menu.

You'll see two files, Brushwood Heights and Optima.
»  Click the Brushwood Heights icon to select it.

+ Choocse Open from the File menu.



A first look at In a few moments you'll see the display shown below. The most

. . frequently referred to parts of Filevision are labeled in the illustration.
Filevision IV Don'’t click anything yet; this is a good time to become familiar with the
Filevision Drawing display. Its parts are either labeled in the picture or
discussed separately below.

window close box — file title and window viewing size menu bar
£ £ MultiFinder icon

f Vrile Edit Types Rccess l}pljo’ns Text Symbols Shades —— window zoom box
[ffe==———=————— Brushwood Heights - Actuat Size =

[x] , 3DO| . 600' . QJDI . 12BD| . WSUU‘ . . .
5 T e o v— —— drawing window title bar
] cuh Avenue custom rulers
tool box (see below)
,g' vertical scroll bar
8] w thumb slide
E
] ]
S
§_ fors
'§_ drawing window
¢
. ruler measure
Prav|[Naxi] Infollt : nk . .
window resize box
mouse pointer position
herizontal scroll bar
seiection info area
link file button
info (record) page button = |
next object or record button pointer &} freehand
previous object or record button text | A || rectangle (sq)
record icon box
mini page symbol |E8 || rounded rect
mini page scroller line | [ oval (circle)
polygon ||| arc (pie slice)
(NOTEZ The screen ) If what you see doesn’t look anything = I?ne wilth
display shown above was | like this and a button reads Drawing Black]] line color
created using a 13" at the bottom of the display window current shade
monitor. Your screen the file has been used before and vou're
display may only show a looking at the Info display window. Click the Drawing button or

kpOl“tiOFl of this illustration. ) window close box to return to the Drawing display window,
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se|ecting A “file” is where you keep the information you work with. The individual items
objects in a Filevision file are called “objects” when referring to the Drawing page and

"records" when referring to the Info page. Each object can have its own record
and records may have, but don't require their own objects.

- There are two rows of townhouses in the middle of the work area.
Click the one on the right in the bottom row.

Brushwood Heights - fictual Size
1800

When you click the townhouse, a box surrounds it, indicating
that the object has been “selected”.

EC====———— 8rushwood Heights - Actual Size S e—— 5]
EX

I

»  (Click one of the houses
in the framed box over
the word Models at the
middle of the display.

R/ = R
20 0|0|S ||

A floor plan appears. You've just
clicked a special kind of graphic
called a “pop-up™. It’s also an
object; in fact, all Filevision
graphics are objects.

[

Garage

h:360 v 114 Ruler:Feet

deselecting »  Click the pointer tool (the arrow) in the toolbox or any other non-
objects graphic area of the drawing.

The floor plan of the pop-up and the box surrounding it disappear, indicating
that the pop-up has been “deselected”.
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viewing an
object’s record

You probably noticed that when you selected the Townhouse the information
Townhouse: 1023 Linkside Way appeared in the selection information area.
There’s a great deal more information that an object can contain.

+  Click the townhouse next to the one you clicked before.

Brushwood Heights - Actual Size

300 GDEI| QDD| 1 2DCII 1500
MNP IFEFPIFE WIS PPN AT I AP |

:::%

Brushwood Hills
Estates and
Country Club

NS
Olo[o]0)s

=y

.

Green

1

-
6
o1
0 1
32
7] H
] o
A
] o
1+ =
21
] G
=]
] A
0
LR

The info button
for display of the
object's record page.

Prev][Hext][Infolf. ink

This one has another pop-up that was created from a scanned photograph. A
box appears around it once more and the address of that townhouse, 1021
Linkside Way, appears in the selection information area at the bottom of the
screen.
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The Info page +  Click the Info button right under the address and the ‘“Info display”

appears:
Brushwood Heights - Aictual Size
E[[==——=————=|nfo for this Townhouse: (27 records}

e

B
a record §
is -1
made up
of fields

B

You can also click
on the zoom box to
increase the size of
the Info page
window to fill your
monitor screen.

returning from

the info display

36 Filevision

o Price ggg@ =58 ‘ Comments

| {Ne- of bedrooms [5 |{+ 5 car garage

EXTIEETN 1021 Linkside Way |

Model [Square feet [2,300 |
_— i

= Frn‘nt View

® Central heating

[Mo. of hathrooms|3 || Central air-conditioning
Available? * Oak-panel den

* Exfra-thick insulation
Floor Plan { 1st f1r) |ERRCEEREIERi gl qaaleley

TD-nhouse 1021 Llnk5|de May

I §";'~s>ev| Fex i [ir;ij[i. irmﬂ@l

Ruler:Feet

This is the record for the house.

There’s a box near the top of the display labeled Address, with the address of
the house you clicked filled in.

The rest of the boxes contain information yowd expect to see in a record of
information about a townhouse.

Those boxes, called fields, are placeholders for information. You'll soon learn

how to type in (“enter”} information into fields, and to change the sizes, names,
and placement of the ficlds.

»  To get back to the picture of the townhouse development, click the
Drawing button.

This view of the file is called the “Drawing” page.

Vv



using the
Prev and Next
— buttons to
select objects

using a
double-click
as a shoricut

At this point, you should be looking at the Drawing display and 1021 Linkside
Way should he selected. If you don't see 1021 Linkside Way in the selection
information area at the bottom of the display, choose Townhouse from the
Types menu, then click the Next button in the lower left of the display until the
address 1021 Linkside Way appears in the selection information arca.

»  Click the Prev button in the left end of the window horizontal scroll
bar.

The selection information arca now reads 1020 Lake Avenue. That townhouse is
shown selected (there’s a box around it).

»  Click the Prev button again.

The selection information area reads 1019 Linkside Way and the next
townhouse down has a box around it.

+  Double-click the graphic of 1019 Linkside Way.

The record for 1019 Linkside Way appears.

Fliil3

2

Info for this Townhouse: (27 records) E] Double-clicking an

object is a shorteut you

1019 Linkside Way | §%|

can use in place of

— Model

[Square feet [2.300 |

kima

clicking the Info

Price | $850,766 » Central heating

button,

[No. of bedrooms

S || e 3car garage

INn. of bathrooms

}
[

»  C(Click the Next

3 ||* Central air-conditioning

Available?
- = A EUERERlgY | * Lead -plass front door

¢ Qak-panel den
* Extra-thick insulation

button.

The record for 1020
Lake Avenue appears.

As you can see, Next
and Prev work equally
well on both the Info
page and the Drawing
page.

]

«  (Click Drawing to return to the Drawing page.
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adding an Adding an object is simple. Let's add a townhouse.
object ‘ .
«  Click the pointer tool at the top of the toolbox.
+ Chcose Townhouse from the Types menu.
Symbols are madifiable icons. It's very easy to add them to a drawing and to

customize them (to learn how to change these symbols or create new ones, read
page 115, “The Symbol Editor™).

+  Pull down the Symbols menu and choose the two-story house from
its third top row position.

+ Click the symbol tool. It's between the text tool and the line tool.

| & File Edit Types RAccess Options Test LM Shades
ED ———— Brushwaood Heights - Actud Editor ... e

T © Z00] &00] 500] | — 1800
copfe sl E)II e AL @ =

iPalh A\rienueé

ol

Icr

9 3
u] .
a "
faumad AP &\ $ m\
. Toenhouse: 1017 Linkside Hngl Ruler:Feet
[PreviMext){infolli :«i]

The pointer now resembles the two-story house you just selected. The symbol
tool always takes the shape of the selected symbol.

< Without holding the mouse button down, position the townhouse as
shown on the next page and click.
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The townhouse is now placed. You've just added an object, though there’s no
information in its record.

+ Look at the selection information area.

A blinking insert bar is waiting for you to type in an address next to the type
name Townhouse,

+ Type 1025 Linkside Way.

. Townhouse: 1025 Linkside Hay|

[Prev)Hext](infolli inx]K] |

«  Click the Prev button a few times.

Different townhouses are selected.,

That's all there is to adding an object. Later you'll learn how to fill in the rest of
the information in its record.
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Types Objects are grouped by type. You're used to this method of classifying things in
everyday life: knives, forks, spoons and plates are "objects" of the type dinner-
ware, while windshields, bumpers and fan belts are “objects” of the type auto-
mobile. Likewise, each townhouse in this file is an ohject of the type
Townhouse.

Brushwood Heights - Actual Size
[T . 3au| €00]

e
iy

Palll'l Avenuq * \Q/
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E H Lake Awenud ,-‘,a;: ’ g

oo ae e |’ =
pr s

e
GE B
B
5]
el

i

« Click 1017 Linkside Way to select it:
In the selection information area, the address, 1017 Linkside Way, is preceded

by the word Townhouse, its type name. 1017 Linkside way is a single object of
the type Townhouse.

«  Move the pointer to the Types menu and hold down the mouse
button while you examine the menu.

m LI Access  Options Text
thange Layout... JHeights - Ag

iq O ... 3 Delete Type a00]
0 1 { 1| RddType... :
0 1 i Palm
Background
R Golf Hole
z 1 Lake
81 w Lake| Street
1 @ sTownhouse
PIERER 1 Model
7] Salesperson
E' & Eig Customer o
071 Click Link e
Link =
I A e o I s
- Tosnhouse: 1017 Linkside Wayl

[ IPreviext)(infol(.ins)i] |

Not only does it list all the types in the file, it has a check beside Townhouse,
the type of the selected object.
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+ Release the mouse button and click one of the models.

r % File Edit Types HAccess ODptions Teut Symbols Shades
S Ee==r——a——o—x————= Brushwood Heights - Actual Size

é;_l

) 21DU| . 24004

UI 300' \ 600' 900' . 1200! ) 1500'

‘__;-"'

|DDu

Modeil: Adventure|

[ [Erev]Mext)(infol Eins)K]]

The floor plan appesars. This is a special kind of graphic called a “pop-up”
whose properties we’ll explore later. Look at the selection information area.
The type name in the selection information area changes to Model. That makes
sense, since the object you just clicked is a Model.

+ Once again, move the pointer to the Types menu and hold down the
mouse button while you examine the menu.

This time the check is beside Model, which is now the selected type.

» Release the mouse button and click the Prev and Next buttons
several times each.

You'll see different models selected, their floor plans appearing and disappear-
ing as you go. If you keep clicking just Next or just Prev you'll begin to notice
a pattern. Only models are selected. Prev and Next work only on objects of
the currently selected type. '
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Records

42

You should be looking at the Drawing display right now. (If the top of the

screen reads “Info for this...”, you’re on the Info display and you should click

the Drawing button.

» Choose Salesperson from the Types menu.

»  {lick Next until the selection information area reads Salesperson:

Eusey.
«  Click Info.
= jE===————== |nfo for this Salesperson: (? records} D——m=oceHg|
|||||!|1||||[!||ZI|!||||[3|||||[ll4l|||¥|||SIJIIII|I6i{}

Fusey a

First name e |
Home address
2345 10th Street

Santa Monica, C4 90405

Home Phone 213-957-4321%

Sales Agent

Arnual Quota $1,7275.300
Sales YTD $1.400,500

Commission Rate{ %)
NOTE: Sales * Camm. Rate =
Commissions

Eummissiuns 42,015
387-654-3210 |

‘Hlllllll"ﬂlll]lil"{llli||l“"’lll|l|\

MNGTE: Sales
¥YTD/Quota=
% of Luota

% of Quota
79

!

»  Click the Drawing button.

Prev][Hext]{Revert](Drawing J[i ins]

=l

You are now
looking at the
record for the
Sales Agent,
Michael Euscy.

You've probably
seen personnel
records before, or
patient records or
insurance records.
Here it’s the same
idea; information
in a standard
format. With
Filevision, you can
create those
formats yourself in
a flash. You can
change them just
as easily anytime.

Nothing appears to be selected on the display. The reason is that we've se-
lected a Salesperson record, and for this sample file we've chosen not to give

Salesperson records a graphic part.

But there’s a way to tell whether or not the currently selected object has a

graphic part. Look to the right of the page miniature (at the lower left of the
display). If you have been watching the page miniature up untii now, youw’ll
notice something new: the “record icon”.
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record icon

Salesperson: Eusey|

IEIllPr‘eu]lHextll Infolliink]

Fields

\\
NOTE:

You can also
double-click the
record icon to
access the Info

record selected.
4

The record icon tells you that the currently selected object is 2 record with no
graphic.

Now we’ll explore records and their component parts a little more.

Make sure the current type is Salesperson by choosing it from the Types menu,
and make sure the current record is that of the Sales Agent, Michael Eusey, by
clicking Next or Prev until the selection information area reads Salesperson:
Eusey.

« Click Info to go to the Info display.
Take a look at the layout of the record. Each field has a name (in white letters
on a black background) and a place for information (hlack letters on a white
background).
In records of the type Salesperson, the field names are First name, Last name,
Home Address, Title, Home Phone, Social Security Number, Sales Year to Date,
Commission Rate, Annual Quota, Commissions, % of Quota and Photo. These
are all data fields (including Photo). There are also two annotation fields

(NOTE:...} that are used for information that does not change from record to
record.

«  Move your pointer over the white area where Eusey is entered.
Notice that the pointer has changed to a vertical bar that looks like an "I" beam.

«  (Click the area just to the left of the “E” in “Eusey”.

There's a flashing vertical bar in the Last name field. You can type (or “enter”)
information where it appears,

Notice also that there are two handles on the Last name field, indicating that it's
selected.
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editing the
contents
of a field

Revert...

a4

Filevision IV

Ler’s use standard Macintosh editing techniques te change the information in a
field.

*  Without holding down the mouse button, move the pointer just to the
left of the "M" in Michael.

«  Now hold the mouse button down and drag the mouse to the right of
the "I" in Michael.

Michael is now selected and ready to be edited. Double-clicking anywhere
within a word is another way to select it

- T hn.
Last Hame ype John

First name I ;] John replaces Michael
Home address ¥ in the first name field.

2345 19th Street Now let's restore

Santa Monica, CA 90405 Michael the easy way,
using Undo.

» Choose Undo
Home Phone 213-987-4321 from the Edit

menu.
Jales Agent

Undo undoes the last
action.

Michael reappears. Undo works with almost everything you do when you're
using Filevision. Most actions that can’t be undone are preceded by warnings to
that effect.

- Choose Redo from the Edit menu.

Redo reverses Undo.

Clicking the Revert button at the hottom of the window would have been an
alternate method to change back to the original record'’s information. Revert is
generally used when several changes to a record are decided to be unnecessary.

«  With the First name field back to reading John, click the Revert
button.



‘% §42,015] NOTE: Sales

YTD/uota=
EDEmg e senn ]| A
[Prev](Hext](Revert][Drawing ][ ins] HHEEH

Revert button

The following alert dialog will be displayed giving you a chance to change your
mind if you happened to click the wrong button.

Do you want ta revert to your original record?
You will not be able to undo this action.

- Click Revert to revert back to the original record’s data.

The First name field should now read Michael again.

moving from «  Click the Last name field in the record for the Sales Agent, Michael
field to field Eusey.

If you're not on that record or that type, choose Salesperson from the Types
menu. Then click Next until vou reach the record for Michael (or John, if yau
didn’t follow the procedure in the last section) Eusey.

»  Press the Tab key.
The Tah key moves you from field to field in sequence.

The First name field is selected—handles appear on its top and on its lower
right corner, and the text is reversed: white letters on a black background.

st
Sa

First name 'ichael

You can also get to a field by clicking in it or by double-clicking if you want to
change an existing entry.
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Highlighting

Highlight...

46

Filevision IV

+  Double-click the Sales YTD field (in the data area).
Michael's sales for year to date have changed, so let's update the field.
«  Type $3,690,250.00.

Notice that the two calculated fields change (Commissions and % of Quota).
More on calculated fields later.

» Hold down Shift and press Tab.

The Soc. Sec. # field is now selected. Shifi/Tab moves back one field.
» Hold down Option and press Tab.

Option/Tab always selects the first field.

Later youw’ll learn how to add fields of your own.

Highlighting is a key to effective use of Filevision. It's used to show patterns and
to filter information according to conditions you set.

Highlighting creates a subset of objects from the selected rype. When you want
to petform an operation on a specifically-defined part of your file, highlighting
is the way to find that part. When highlighting is in effect, Next and Prev cycle
through only the highlighted objects.

Highlighting is shown on the Drawing display by fading out all non-highlighted
objects and by adding a shadow to the highlighted ones, giving them a three-

dimensional appearance.

In this example, we’ll highlight townhouses that are available for purchase at
$200,000 or less.

= (Go to the Drawing page by clicking the Drawing button.
+ Choose Townhouse from the Types menu.

+  Choose Highlight... from the Access menu.



filling in
selection fighting.
conditions

| Address

EEN
B ] ] =

@) Dalue
I Rankil fo 15
O Field

You'll see the Highlight... display. It's where you set the conditions for high-

address is
B cqual to

@ AND —) OR

@ AND = OR

@ AND — OR

The first step is to enter “Available? is equal to yes”,

Here’s how you do it.

The first field that you're interested in is Available?, but the field shown is Ad-

dress.

Highlight "Townhouse®s

Available?
Comments

Floor Plan 1st fIr)
Front Vjiew

Link

Model

Mo. of bathrooms
Mo. of bedrooms
Price

$quare feet

iipar

« Click on Address with your
mouse pointer and hold the
mouse button down.

A pop-up menu will be displayed
showing all of the field names of the
Type Townhouse.

+ Drag the mouse pointer
down to the field name
Available? and then
release the mouse button.
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Available?

The name in the pop-up menu now reads "Available?”. Notice that the sum-
mary of conditions box to the right of the pop-up menu has also changed to

read "Available?".
+  Click the is button.
«  Click the = button.
+  Click the Value button.
+  Type yes as the value you want to find.

«  So far, your highlighting conditions look like this:

Available? is

M| equal to

B ] [«

yes

eq

—-—-—(%’INI] —(0R

L@} Value
Lo T NPT S .|

Highlight "Townhouse™s meeting these conditions

@ AND =) OR

M
+  Click the “less than or equal to” (<) box.
+  Click the Value button.

- Type $200,000.

This is what your complete entry should look like:

Available? is

< is not

) equal to

[

yes

@ AND —) OR

Price is

&3

200,000

L] B [
=

(@ Dalue
rRank il fo 2
 Field

BB less than or equsal to
$200,000

@ AND =) OR

[

Filevision IV

—————@ AND —) OR

Click the AND ,
button between the
condition boxes.

Change the field to
Price from the field
pop-up menu.

Click the is box.

As you can see, the right
of the display shows a
surnmary of the conditions
you've entered. The con-
dition you're currently
working on is connected
to the left side of the
display, where you
actually enter or change
the condition.

Click Done.



The Drawing
page

window

200Mm views
Show Ruler %A
Hide Tonlbox *®T
Hide Mini Page %K
Hide Titles
Hide Windowr

~Show Actual Size . 1
Show 50% Size %®5
Show 200% Size ®2

Ruler Origin at Bottom Left
vIracking

Grid
vEuidelines

S$nop to Guide

Snap to Alignment

Edit Rounded Corners...

$how Grid & Guides in Froni

The Highlight... display is replaced by the Drawing display and a message
telling you how many objects are left to check as Filevision searches for objects
meeting your conditions.

After a moment’s wait, eight townhouses are highlighted.

=—————— Brushwood Heights - Actual Size
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Ruler:Feat

-Ell

To cancel Highlighting you would select Cancel Highlighting from the
Access menu. Don't do it vet,

The work area you'll usually use on the Drawing page (the one you've been
using up to now) is only part of the Filevision work area. What you've seen up
to this point is a small area that is governed by the size of your monitor.

However, the actual work area is currently set to 2 10" x 16" page even though
there is only about 8" by 10" heing used. The drawing page can be set to as
large as 30" x 32". There are a number of options provided to be able to view
other parts of the drawing page or to view all of the page at one time.

+ From the Options menu, select Show 33% Size.
Notice that there is a command-key equivalent which is a shortcut method to

perform the same function. Command-3 (hold the 38 key down while pressing
3) will do the same thing.
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mini page

moving around
on the
drawing page

50

Filevision IV

The full 10 x 16 work area is shown scaled down to 33%. The active working
area is shown with a drop shadow rectangle. There is also a 50% and a 200%
window zoom size available.

& File Edit Types HAccess Options Text Symbols Shades |
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You can work on this area as easily as you can work on the full or actual size,
moving, stretching, drawing and selecting objects.

Notice that the mini page now shows all white. The normal white rectangle on
the black background represents the viewing area of the working page (the
area that shows on your monitor) and as the full working page is now showing,

the full mini page is white.

= Select Show Actual Size from the Options menu (or press Com-
mand-1).

The mini page now shows the small white rectangle again with the rectangle
positioned in the same area that you are currently viewing.

The mini page also has a scroller function.

»  Move the pointer tool over the white rectangle.

The normal arrow pointer now becomes a four pointed arrow,



* Hold the mouse button down and drag the mini page down
and notice on the drawing page that a "dotted” marquee has

RN

i °s%§=\‘

new viewing area
marquee

now appeared.

The marquee provides a reference to the new viewing position as soon
as you release the mouse button.

The mini page also provides an easy method to find the center of vour
working page.

* Hold down the Command key (3£ ) and click the white rec-
tangle on the mini page.

The drawing page is now centered in your overall
working area. In this example, as the full working

Townhouse:

(E:E P p———gy area is set 1o 10 x 10, the viewing area is on 4 partial

[Prev][Hext][Info |i ik

blank part of the page.

Townhouse: 1001 Linkside May  Click Next a few times, Watch the page miniature

[Preu] [Hext] [Infu] [i ér;é&] and the selection information area.

Next (and Prev) now cycle through only the

Townhouse: 1010 Lake Avenue highlighted townhouses, not ali townhouses as they

[Prev](fext])[Info]l ink] did before. Selected objects appear as dots in their

relative positions on the mini page.

There remains yet another way to move around on your drawing page. This is
the standard Macintosh method of scrolling using the vertical and horizontal
scroll bars to the right and bottom of your screen.

Moving the pointer to the arrows at either end of the scroll bar and holding the
mouse button down causes the page to scroli in small increments. Using the
mouse pointer to "grab” the thumb slide and drag it to a new position causes the
drawing page to scroll in one large increment.

If you move the pointer to any of the grey area between the arrows and then
click with the mouse button, the working area will "page" either up, down, left
or right depending on which bar and which side of the thumb slide you are
clicking. The amount paged is dependent on the size of the monitor that you
are using and the current window size.
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window control

52

Filevision IV

The size of the window can be casily adjusted by "grabbing" the double squares
at the intersection of the vertical and horizontal scroll bars in the lower right
corner of the screen.

2100 240

Move (drag) the pointer in any direction within the confines of your monitor
and release the mouse button when you have the resize where you want it. A
shadow marquee of the scroll bars will show your current position.

When you decide to return to the original window size, you have the option of
dragging the resize squares back to their original position or you can click once
on the window zoom box in the upper right camer of the window.

If you reduce the size of the window with the resize box and wish to move the
window to a new position on your monitor screen, grab the window title bar a
drag.

| & File Edit Types Hccess Options Tewt Symbols |

S[1===—— Brushwood Heights - RActual Size %E}E‘

|l| 100 200 3an| 400 50
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This also applies to the tool box as it is also a window with a title bar and close
box.

Ii%! ——
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Other window control functions will be described in Section Three,



Printing a report on the highlighted objects

You can print records and information from records in three different ways with
Filevision; as columnar reports, as forms, and as labels. You can create your own
formats for all three kinds of printout, and you can save those formats in a library

for future use.

In this example, you're going to print out a columnar report on the homes you
just highlighted. Your report will use the information from these fields: Address,

No. of bedrooms, Price, and Model.

Let’s get ready to print now. You should be looking at the Drawing display, with
8 townhouses highlighted ar the moment. If you're not, start back at page 46,

“Highlighting”.

+ Choose Print records... from the File menu. You'll see this Print
Library which shows you what print formats have been saved, and

fets you customize them or create new ones.

Print Library

Print format Type Style
Listings Townhouse Report
Mail-Labels Salesperson Label
Sales Report Salesperson Report
Form-tetter Salespersen Form
Form-letter Customer Form

Records to print: Print to:

@ Al @ Printer

I O Highlighisd ) Screen
(o Sole teg ) File

Page setup

For a new file, you'll typically create a print format from scratch, but we've sup-
plied six for this tour. The Listings report was left unfinished so yvou could
learn about changing a typical format,

+ (Click Listings.
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editing a Before actually printing the report, let's look at the format that will be used to
print format print it and make one change to it.

+  Click the Edit bution.

You'll see this display:

[ % File Edit Types Access Tert Format $hades
= pPrint lLapout ==e)FF"u——=———= 1]

i |

|||I|I|I1IIII|I|I2|I|LlI|I3|Illl||l4|I|I|I|ISJI|i|Illsllllllll-G
Format-name:
Header:
Brushwood Hills Estates Development Company
P.0. Bax 4069, Malibu CA 90265-1369
Street & Address Maodel Bedrooms

Each record:
E &ddress Madel MNo. of bedro

Footer:

Page &p

|||||M|t||l|l-‘|||||||l

Cancel]{fitecve Fiaid](Sort||Add Field

The Price field was left off this print format. Let’s put it in, First we'll have to
scroll the print format to make room for it.

« I required, use the scroll bar at the bottom to scroll the print format
until you see an open area to the right of No. of Bedrooms.

+  Click the Add Field button.

A small dialog appears at the bottom of the display, giving you the choice to
add a data field or an annotation field. We'll talk about annotation fields a little
later.

[Cancet] [Annotation Field] {Data Field |

« Click Data Field.

54 Filevision IV



Another dialog box appears, asking which data field you want to add to the
layout.

Address

— Available?
Comments

Ftoor Plan 1st fIr)

. ) Show field name and contents
t:::t Diew : @ Show field conteats only

No. of bathrooms
No. of hedraoms
Price

+  Use the field pop-up menu to select Price.

Leave the Show field contents only radio button selected.

= Click Add.

A Price field appears in the middle of the display.

» lsing the move handle at the top of the field, drag the Price field to
the right of the No. of bedrooms fieid in the Each record: area. To
drag it, point at the move handle, hold down the mouse hutton, drag
the field where you want it, and release the mouse button when
you're satisfied with its placement.

==———7————— — Print Layout EBE————————— -
|||||||I||||l|I2|lllllll3|I|I|I|I¢|IiIII|I51I|III|I6|I|I|I|I?|I|

Farma -nome

ader:
Brushwood Hills Estates Development Company
P.0. Box 4069, Malibu CA 90265-1369
treet & Address Madel Bedrooms
—Jch recard: =
ddress Model & No. of bedro Price
E | - 4
Hoter:

Page &p

Remove Field)(Scrt][fdd Field](Done
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« Choose Numeric, Dollar sign, and Commas from the Format
menu.

Filevision will print commas and a single dollar sign in each Price field whether
or not they were included when the data was entered. As the Price field was
originally set up for general text entry, the Alphabetic attribute has to first be
changed to Numeric before the Dollar sign and Commas are enabled.

Now let’s prepare Price to give us the total inventory value of each model of
highlighted homes at the end of this report.

+ Click the Price field to select it.
+  Choose Statistics... from the Format menu.

The Statistics dialog appears.

Statistics for: |Price |
Standard

Count Total Average depiation
Ouverall statistics . . . . O < O O
ByMedel . . . . . . . . O X O O
Use "Sort" to select different detail statistic fields.
Seipnd "Numeri T fram the Fermal mens 30 eoable st statistins,
[Eﬂm:el] ( Preuv Field ] [ Newut Field ] [ Done ]

«  Click the Total checkbox for both Overall statistics and By Maodel.
* Click Done.
annotation fields Look at the field in the upper left of the print format. It contains the company
logo, and it’s in an annotation field. Annotation fields are used to:
+ Print the contents of other data fields.

* Print fixed text or pictures, like “P.O. Box” or the logo used
here.

s Create form letters.
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e Print the page number of the report or forms.

e Print the system date or time.

Annotation fields don't have names, just information or a picture. Annotation
fields can also be used on the Pint Layout; see page 167, “adding an annotation
field”. For more about their use in printing, see “adding an annotation field" for

printing, page 244,
Let's add an annotation field to serve as a column title,

+  Click the Add Field button.

A small dialog appears at the bottom of the display, giving you the choice to

add a data field or an annoctation field.

[ Cancel ] [nnnutaiiun FiEEJ (pata Field )

+ Click Annotation Field.

An annotation field appears.

+«  Choose Underline and Bold from the Text menu.

r ® File Edit iypes HccessFurmat $hades

=—————_""—_"#{1k »
»

==

ch record:

I|||I||1|I|||I|2||I|||t| Size . llllJ?L 7
[d Plain text
Format-name prpafee k }| . Underline
ader: «Bald
B premmme e Background Color M| fladic
3 5 Brushwood %em Mas ki . g[[iﬂ]%%lﬁ%m ny
] ==ll P.D. Box 4069, Malibu CA 90tvo—ou
B
+ireet & Address Model Bedrooms Price

||N|

oter:

Page &p

« Choose Align Right from the Fermat menu.

ddress § Model § No. 0f bedrocy Price
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+ Using the move handle at the top of the field, drag it just to the right
of the Bedrooms field in the header and type Price.

1t should look like this:
{ & File Edit fipes Access Tewt Format Shadsas l
_ —————————— Print Lﬂgﬂut m__@gl
1||||11|||||»||2|||i||||3[|||||||4||l||||Is||||||||6I|E|||I|7l|I K
Format-name-
ader:
_—- Brushwooed Hills Estates Development Company
— H P.O. Box 4069, Maliby CA 90265-1369
| Thes
+treet & Address HModel Bedrooms Price
“ch record:
—ddress § Model Mo, of bedro Prics
| 2] .
Joter:
Page &p

You've completed the print format,
« Click Done.

You are returned to the Print Library.

printing it out If you don’t have a printer, yowll still be able to use most of this section. Print
to: Screen lets you preview on-screen what printed material will look like on
the printer. Print to: File sends the output to a MacWrite-usable text file on

disk.
»  Click the Highlighted bution.
= Click the Screen button.

»  Click the Print button.

A message states that the print is sorting and as soon as it finishes, the following
screen report is displayed.
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r % File Edit Tgpes RAccess Tedwt Format shados

L__% Diew Print
Brushwood Hills Estﬂte_s Development Company
P.0. Box 4069, Malibu CA 90265-1369

Sireet & Address Model Bedrooms Price
1001 Linkside way Adventure 3 $184,850
1004 Lake Avenue Adventure 3 $165,050
1005 Linkside Way Adventure 3 $184,850

Model Total: $554,750
99% Linkside Way Contempa 3 $199,950
1003 Linkside wWay Contempo 3 $199,900
1006 Lake Avenue Contempo 3 $199,900
1007 Linkside way Contempo 3 $199,750
1010 Lake avenue Contempo 3 $195,950

Model Total: $999,450

Concel][ Done ] it R S B R e R s R

Overall Total:

$1,554,200

After you are satisfied with the appearance of the final screen printout, you can
then send it directly to your printer. Its exact appearance may differ according
to the printer you're using. The settings for a standard LaserWriter are shown

below,

»  Select these printing options:

Laserli/riter “Laserllriter” 52

Cover Page: {® No (O First Page (O Last Page

Paper Source: ® Paper Cassette O Manual Feed

Cupies:m Pages:@® All ) From: I:l To: l:l

+  Click OK.

Copies remaining to print

Records remaining in this
copy

[1 ]

A message appears telling you how many copies are left to

E print and how many objects remain to be printed in this copy.

[F‘e;:;w]

(Resume) You can stop printing anytime with Cancel, suspend it with

Pause and continue it with Resuimne.
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Here's a printout of the report printed with the LaserWriter When the printing is
finished, you are returned to the Print Library.

B Brushwood Hills Estates Development Company
P.O. Box 4069, Malibu CA 90265-1369
Street & Address Model Bedrooms Price
1001 Linkside Way Adventure 3 $184,850
1004 Lake Avenue Adventure 3 $185,050
1005 Linkside Way Adventure 3 $184,850
Model Total: $554,750
999 Linkside Way Centempo 3 $199,950
1003 Linkside Way Contempo 3 $199,%00
1006 Lake Avenue Contempo 3 $199,900
1007 Linkside Way Contempo 3 $199,750
1010 Lake Avenue Contempo 3 $199,850
Model Total: $999,450
Overall Total: $1,554,200

»  Click Quit.

The objects you printed are still highlighted.

+ Choose Cancel Highlighting from the Access menu.

Section Three describes this and other printed output in greater detail—Labels,
Forms and more on Reports.
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Graphics

Although we've emphasized Filevision's capabilities for organizing written infor-
mation, Filevision gives you the ability to manipulate graphics in ways that no
other filing system or graphics program can.

- Hyou're on the Info display, click the Drawing button.

»  Click any object.

Some objects aren’t selectable. Most other objects indicate selection with
handles. Symbols are shown with frames around them, and selected text is
shown in reverse colors:

E Brushwooad Heights - Actual Size =—F—=— EI
Selected symbols are 300] £00] ano
shown with black ==k I e -4y
frames around thermn. E
e aEa o e &
Selected text is -~ E"; 'V ; :
shown in reverse. 1 e $ :@
. The Yeldt
z] A
01
Most objects 0]
are shown ]
selected with ]
handles. 6 : ] i
2 : (3 selected? Buler:Feet H
""""" 0
pop-ups +  Click the middle townhouse symbol over the Models

legend again.

Its floor plan appears. The part of a pop-up that’s always
visible — the townhouse symbol, in this case — is called its
button. As long as the button of a pop-up is selected, the rest
of the pop-up will remain visible. As soon as the button of a
pop-up is deselected, everything but the burtton disappears.

»  (Click the right model symbaol.

The first pop-up disappears and a new pop-up appears. It’s
the floor plan for Ultima model townhouses.
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graphic layers
(Types)

| Tupes

Change Layout...
Delete Type
Add Ffype...

vBackground
bolf Hole
Lake
Sireet
Townhouse
Modei
Salesperson
Customer
Click Link

The Filevision drawing page is made up of a series of layers, each layer being
attached to a "Type”. The terms Type and Layers could be used interchangeably
when working with the program, using Layers to refer to drawings and Types to
refer to the attached databases.

In the Brushwood Heights tour, there are nine Types as can be seen in the
Types menu. Six of the nine Types (Background, Golf Hole, Lake, Street,
Townhouse and Model) have attached Layers on the drawing page. The other
three (Salesperson, Customer and Click Link) are database Types only with no
drawing page counterparts,

To see an example of the layered drawing page, first make sure that you are on
the drawing page, and then:

«  Select Background from the Types menu.
+  Select Show Only These from the Access menu.
Notice at the top of the Access menu that the type "Background"s: is

entered. All actions of the Access menu refer to the currently selected
Type (where an action on a Type can be performed).

"Background"s:

Sort By...
Find...
Find Same
Highlight...

Highlight All
Hide RII

Show ANl

Show Only These
Ignore

Highlight Seledied
%80
£+ 3H
£+ 385

. The drawing page now looks like this:
*®

%H
5l

Brushwood Hills |JJE
Estates and X
Country Ciub

Show All Types

faanal Highlighiing

Previous Record
NeHxt Record
info Page
Drawing Page
Link

43P
3N

%1
30
S
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All of the golf holes, lakes, streets, townhouses, and mode]s have dis-
appeared. If you had selected Townhouses and Show Only These,
only the townhouses would have been displayed. This provides an
easy method to work on individual elements of a drawing without the
clutter of all other objects on the drawing page.



Adding a
new Type

To retrieve all of the Types that have been hidden:

» Select Show All Types from the Access menu.

The drawing page is back to normal.

Suppose your townhouse development has some company-owned property: a
recreation room, golfing facilities, maintenance buildings. Nothing currently on
the Types menu is suitable for keeping track of the company property. You
need to create a new Type.

The new type Property will be simple. The fields will be Name, Location, Cost
and Property tax. We will use the Property field to demonstrate computed fields
and Location to demonstrate initial text fields.

» Choose Add Type... from the Types menu.

The Layout for this Type display appears. The Type-name box comes with a
nondescript name: "I'ype I'.

[ & File Edit Types 8ccess Text Format Shades |
BE==———— nid Type - Type | %@E‘
|I1||i|1||ll||I|2||I|||IlallI|t|||4lllllllasilll||I16ﬁ}

Type-name  Tupel

Remove Field Add Field

« Type in the name Property.

Typing Property automatically replaces the name Filevision had generated.
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adding fields to the
Type layout

b Plain tent

Cotor »
Mask Color b
Texl Masking

underline
Beld
Flafic
Shadom
Cmilime

n Chicago
?12?9 : Courier
c 5: 4 Garamond
Helueti
Mask Colar  » M"’uﬁﬁc',fa
Text Masking N Heilvelica Narrow

Font

Style
Color

New Century Schibk
New York

Palatino

Times

Zapf Chancery
Zapf Dingbats

Mask Color
Tent Masking

Hierarchical
Text menu
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The Name field is fine. Next, we need a field telling us where the
building is located.

« Click the Add Field button.

A small dialog box appears, asking whether we want a data field or
an annotation field.

(concel] [Annotation Field] [ Data Field |

= (Click Data Field.

A field appears in the middle of the display.

« Choose Plain text, 12 point, and Geneva from the Text
menu.

The text in each field you add from now on will use these character-
istics unless you change them. Each field can have different charac-
teristics if you like.

»  Type in the name Location.

» Using the move handle on top, drag it under the Name
field, then reiease the mouse button.

» Using the stretch handle on the battom right corner,
strefch the Location field until it's the length of the Name
field.

The picture should now look like this.

mﬂpﬂuue-wnelﬁma
E!|I|I1I||I|lll|12II|EI|I|I3|I|Il\|l4ll|lll|lsllllllllé{}

Type-name Jagl0e4Y

Locatio

Since all buildings in this file are in Brushwood Heights, Location
should be made into an initial text field. With the Location field
selected:



Field Setup *  Choose Field Setup... from the Edit menu.

The field setup dialog box appears.

Setup for the Location field:

O Standard { Copy from previous record
@® Initial Text O Compute using a formula
Initial tent:

Brushwood Heights

Field Names: |Location |

(cancel ]  [Prev Field (Next Fieid )

»  Click Initial Text.

+ Type Brushwood Heights.

« Click Done.
The field setup dialog box disappears. Now each record that's added will
automatically fill in the Location field with the text Brushwood Heights. It
can be edited like any other text. Now for the Cost field.

+  Click the Add Field button.

*  Click Data Field.

«  Type Cost.

«  Move the Cost field just below the Location field.
Last, the Property tax field.

+ Click Add Field again.

+ Click Data Field.

The field appears.
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*  Type Property tax.
= Move the Property tax field just below the Cost field.

There's not enough room for the data, so let’s stretch it differently
this time.
A
Property Tax

»  Pull the stretch handte down, doubling the height of the

1& fild.

Now let’s make it a formula field.

= Choose Field Setup... from the Edit menu.
You'll see the field setup dialog.
« Click Compute using a formula.

+  Typein the formula shown below. Make sure you type
square brackets {[ ]} around the word Cost.

Setup for the Property TaH field:

) standard ) Copy from previous record
{1 Initial Tent ® Compute using a formula
Formula:

[Cost]*2.5%

NOTE: The percentage sign (%) following a number tells Filevision to multiply
the number by .01 automatically.

There is a short-cut here for entering field names in calculations. You can enter
the field name automatically by selecting it from the list of Field Names: at the
bottom of the dialog hox. By selecting the field from the pop-up menu, the
name is entered into the formula box complete with square brackets.

Field Names: N
Link

Location [ Next Field ) (_Done ]
Name
Property Tau
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It will calculate property tax by taking a percentage of cost. When you enter
numbers into the Cost field later, the Property tax will be computed and entered
automatically.

« Click Done.

» Choose Dollar Sign and Commas from the Format menu.

This will cause the contents of the Property tax field to be displayed with a
leading dollar sign and a comma every thousand.

The layout should lock something like this:

Add Type - Type | =—————-"|

5

I§|IIIJ!1|I'|I]I|I2|IJ§I|I|I3II|I|I|I4|I|I|I|I5|IlI|I|]6

Type-name Qaigus= gl

Property Ta

RBemove Field|Dptionsjifdd Field

el

You've finished designing the “Type Layout” for your new Type, Property. You
won't be able to enter information into it until you click Done and you are
returned to the Info page.

« Click Done.

If the Drawing page reappears.

+  Click Info.
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filling in Now you'll see the Info display for a Property record waiting to be filled in.
information
This will be the first object of the Type Property.

Because Location is an initial text field, it already has Brushwood Heights
filled in.

*+  Type Utility Shed in the Name field.
» Press the Tab key to move to the Cost field.
+  Type $10,000 and press return.

The Property tax field immediately shows §250; it has computed the property
tax correctly.

The record is all filled in and should look somewhat like this:

Info for this Property **New** (0 records)

UBYCPN Utitity Shed
Location IEEG e et HE T

Even though this object is called Utility Shed, there's no graphic for the
building itself.

» Click Drawing.
The record icon is visible next to the page miniature, indicating that the object

selected doesn’t have a graphic associated with it. But before we draw the utility
shed, let’s take a look at the Filevision drawing tools.
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using the

drawing tools
to create the
utility building

The palette of tools located on the Drawing display will look familiar to people
who have used MacPaint or MacDraw.

This is a floating palette that can be moved to any location on the screen to get
it out of the way. It can also be closed by clicking on the close box in the upper
left corner of the tool box or by selecting Hide Tools from the Options menu.
To bring the tool box back to the drawing page screen, select Show Tools
from the Options menu,

All text, symbol and graphic objects can be set to different foreground and
background colors for use with color monitors and printers.  Color will be
covered in detail in Section Three.

a first look at the
drawing tools

pointer
text

symbol

line -

polygon

]

N[/ =P
J10100¢

Elll

freehand
rectangle
round rec
oval circ
arc pie
lines menu
color menu

shade

Use the pointer to select and deselect objects.
Use the text tool to add text to a drawing.

Use the symbol tool to add icon-like “symbols” to draw-
ings. They're easy to create and add to the drawing.

Use the Hne tool to draw straight lines. Hold the Option
key down to constrain to horizontal, vertical or 45° angles.

Use the polygon tool to draw polygons. Polygons are
shapes with straight sides, often with asymmetrical angles.
If you hold down the Option key while drawing, you will
draw only 0°, 45° and 90°, angles. The polygon tool can
also be used to draw semi freehand lines. Double-click at
the end of the last "polygon” line to exit the polygon tool.

Use the freehand tool to draw as if you were using a pen.

Use the rectangle and rounded rectangle tools to draw
rectangles. If you hold down the Option key while draw-
ing, you will draw squares. Double-click on the rounded
rectangle tool to set the radius of the corners.

Use the oval tool to draw ovals. If you hold down the
Option key while drawing, you will draw circles.

Use the arc tool to draw oval arcs and pie slices (filled
arcs). If you hold down the Option key while drawing, you
will draw circular arcs and pie slices.
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lines, shades,
and multiple
selection

&

Aadts
0100

I

e

NMEails
2101010

wBlatk

= E

m

a =
=
)

Green
Blue
Cyan

Yel

7

[we)

Filevision IV

Lines: The line tool, the polygon tool, the freehand tool, the rectangle tools,
the oval tool and the arc tool all have adjustable line widths, color and fill
shades. Choose the line width you want from the lines menu and the shade
from the Shades menu before you use the tool, or while the object is selected to
change its line width or shade after the fact. The back slash line (————)
indicates that no line will be drawn (for filled shades without line borders, etc.).

Shades: The polygon tool, the freehand tool, the rectangle tools, the oval tool
and the arc tool all have adjustable shades and can draw filled shapes, just select
the shade from the Shades menu before you use the tool, or while the object is
selected to change its shade.

With the freehand and polygon tools, you'll have to make sure the beginning
and end points of the shape meet for the object to be shaded. The shade box at
the bottom of the tool box indicates the currently selected shade.

Symbols: The symbol tool is in reality an icon tool. Fach of the symbols stored
in the symbols palette is a 16 by 16 pixel icon that can be edited and changed
much the same as a "fat bits" drawing in MacPaint.

When the currently displayed symbol is selected as the tool, the normal pointer
will become that symbol. Move the symbol the same as though you were
moving the pointer and when you have the symbol over the location that you
want to have it placed, click the mouse button once.

Muhtiple selection: You probably know that when you're using the Finder you
can select several neighboring icons at once simply by pointing at an imaginary
upper left-hand corner, pressing the mouse button and, continuing to hold the
mouse button, dragging the pointer to an imaginary lower right-hand corner
and releasing the mouse button (known as dragging a marquee).

You can select multiple graphics the same way with Filevision. You can also
select multiple objects by shift-clicking them. Hold the Shift key down while
each object is being selected with the pointer tool.

You can use multiple selection on objects to change all of their lines or shades
simultaneously to whatever line or shade you choose from the menu while
they're selected.

After each object is entered or drawn, the tool used will revert to the pointer
tool to allow you to adjust the position of the object. If you want to enter
several objects of a kind without loosing the currently selected tool, hold the
Shift key down until you are finished with the tool.



This illustration shows what tools were used to draw parts of the Tour

drawing.
entered with the
text tool ———————___ [ Lake Avenud

S [ EETYY: WY

drawn with the e
symbol tool Dy (B . (A

:t e
drawn with the ‘

4

linc tool .-

drawn with the
rectangle ool ————

drawn with the
freehand tool —

drawn with the
polygon tool ————

drawing the »  Choose Property from the Types menu.
Utility Shed

+  Click the rectangle tool.

»  Choose the single-width line from
the Lines menu.

*  Choose Black from the Lines
Color menu.

«  Choose one of the light gray
shades from the Shades menu

= Point the mouse near the middle of
the edge of the golf course, hoid
down the mouse butten, and drag
the mouse diagonally down.

* Release the mouse buiton when
the rectangle is about this size.
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It doesn’t have to match the picture perfectly.
+ Select the polygon tool.

» Choose the darker gray from the Shades menu.

«  Draw a roof on the building by clicking at each corner, then single
click the beginning corner to finish the polygon.

Now you have what looks like a building, but there are a few problems: the roof
and wall are separately selectable, the information we typed in so far isn't
connected to the drawing of the roof or wall, and the graphics are far too big.

This is a good time to learn about grouping, moving, and stretching.

grouping Group lets you combine several graphics of the same type into a single object.
graphics Anything that can be grouped can be ungrouped just as easily. The objects that
make up a group may share a single record among them, but no more than one.

+ Choose Property from the Types menu to make sure it's selected,

then press Next or Prev until the record icon appears and the
selection information reads Property: Utility Shed.
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moving and
stretching

The record icon (IE2 ) has appeared. By having the record icon showing
(selected) while grouping the individual elements of the graphic, the graphic
drawing page object will also be connected to its Info page record during the
"Group".

« Holding down the Shift key, click both parts of the building.

»  Choose Group from the Edit menu.

The handles on the two objects merge into one set and the record icon disap-
pears indicating that the record is now attached to the grouped object.

You've created a grouped graphic. You can now select, move, and stretch it as
one object. And you can always ungroup this or any graphic simply by selecting
it and choosing Ungroup from the Edit menu.

Filevision graphics can be moved,
stretched and shrunk.

»  Click a corner handle of the
utility shed (handies on the
outside of an cbject are
called stretch handles), and,
continuing to hold the mouse
button down, shrink it until it's
a convenient size.

The Tour 73



changing an
object’'s Type

Change Laycut...
Delete Type
Add Type...

vBackground
balf Hole
Lake
Street
Townhouse
Model
Salesperson
Customer
Click Link

Then click and hold the mouse button down anywhere within the graphic to
move it into place.

Filevision provides you with an easy way to change objects from one Type to
another. Now that we have a Type Property, we can move the guard house
into that Type.

«  Select the rectangle next to the
entrance of the golf course (the
guard house} by clicking on it.

+  With the Shift key down, select
Property from the Types menu.

The guard house is now located in Type Property.
- With the object still selected, type in Guard house.

The information display now has Guard house entered as the second object in

the Type Property.
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Hiding and
Showing

In this instance, as the guard house object had only a Name field in its Type
with no information entered, there was no problem in changing the Type.
However, had there been other fields and entries in any of those fields, a alert
would have been displayed:

You are about to change selected records
inte type "Property”.

If the layout for type "Property” is not a
copy of the layout for type "Background”,
"Background” fiekds may be lost or
inappropriately assigned.

You will not be able 10 undo this action.

If you were confident that all fields were the same in both Types, then there
would be no reason not to continue with the ¢change. Inthe above example,
there would be no information lost by attempting to change Background objects
into type Property.

Filevision is good at handling visual clutter. Two of the techniques it uses are
hiding and showing objects from the sclected Type. Hiding makes objects dis-
appear from the Drawing page. The objects remain in the file and you can see
their records on the Info page, but you can't see the graphics. Showing causes
the objects to reappear on the Drawing page.

- From the Drawing page, deselect any objects by clicking the pointer
tool.

The display is now ready for a demonstration of hiding.
+  Cheose Townhouse from the Types menu.
« Choose Hide All from the Access menu.

All the townhouses vanish.
» Choose Show All from the Access menu.

The townhouses reappear.
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Ignoring and
Activating

Linking to
another file

76 Filevision |V

Ignoring makes the objects of a type unselectable. When you click them,
nothing happens. Let's demonstrate on Townhouse.

+ Choose Townhouse from the Types menu.
« Choose Ignore from the Access menu.
» Click a townhouse.

Nothing happens. It's not selected, and the selection information area reads:

Tomnhouse: (28 unselectable?

lé*yww BT ﬁll infa | (5. i)

(Notice that none of the buttons are active.)

Ignore can be reversed by Activate.
+ (Choose Townhouse from the Types menu.
«  Choose Activate from the Access menu.

« Click a townhouse.

Linking closes the current file and opens the one named in the Link field for that
particular object. It’s a very good way to connect and access related files
conveniently.

Your tour is provided with a linked file.
= Select Click Link from the Types menu and the Next button.
Look at the information area at the bottom of the window. It shows that there is

a record to link To Ultima Floor Plan and the Link button is now active
(black type).

Click Link: To Ultima Floor Plan

31|82 e | [Bosax '§|| InfDIILinhl

+  Click the Link button.



The screen clears briefly, then a new display appears with the legend Ultima.
This is a brand new file that was opened automatically because the Link field
had the name of the file, Ultima, already entered.

r ir_nlaEdlt 'Vrgp'esr ﬁccesé l]ptmns ”Tent”méhlﬁhuls Shades

lE[l=——"—————— Itima - Actual Size

e LA 2 o TUOT O T

| [ Kitchen S

] Dining Family o
g ] Room Room AlC

; —‘ t (O

: — | =l
%; 4
B L —

] '
5 [ 1
4 Master

] Bedroom (Garage
3

L —

] “Yltima™
iR Townhouss

Fleor Plan Bedroom Bed-
Room: <15 total3> Ruler:Feet
[Prev][Hext][Info][i ink]K]

Ultima is a small file. It’s designed strictly to demonstrate linking. Linking is a
convenient way to get from one file to another, related file. Each object can
have a different link file, so if you have 3,000 objects in a file, you could poten-
tially have 5,000 different link files.

If you get the message “Ultima cannot be found. Sorry.", the Ultima filc is
missing from your disk. Copy it onto your disk from the original Start-Up disk.

Returning = To return to the Tour file you've been using, choose Return to
Brushwood... from the File menu.
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Congratulations

78
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«  To exit the tour, choose Quit from the File menu.
After a moment, you return to the desktop.

Don’t turn off the Macintosh before you choose Quit from
the Filevision File menu. That could make the file unusable

to Filevision.

You've finished your tour of Filevision. The Tour introduced you to
the basics, but you’ve barely scratched the surface of Filevision.
Where do you go from here?

* Browse the other Types and Print Formats to get a feel for
the many different ways that a Filevision file can be set up and
used.

e ...Read Section Three. Section Three shows you how to use
all of Filevision’s features. Although you don’t have to memorize
them all, you'll at least know what to Jook for when you want to try
something new.

. You can start work on your own applications, if you

haven't already.

LI Browse through the numerous example files that have

been included with Filevision. Considerable insight can be gained
by looking at what others are doing to create their own solutions.
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MY BUTTERFLY COLLECTION

Hunting butterflies with a camera and 200 mm. lens using
extension tubes - Karen, nr. Nairobi, Kenya, July 1977 to May 1978.

FAMILY SLIDE ALBUM

Dangidae - Monarchs
Pieridae - Whites

Lycaenidae - Blues

S > |
Papilionidae - Swallowtails m m 5]
El

Bovw
il vl vl v
@Y g
Bouw
B Al v

OLew-wHI
iog
| ev e

Nymphalidae - Nymphalids g
Satyridae - Browns v ﬂ E 5\
[~ Acraeidae - Acreas
Unidentified E[J== Infe for this Slides: (33 records) aE
[Name [ Acraes Oncaea | [Family| Acraeidas ] &
[English Name [window Acroea ]
| Page | |Date| | Slides Motes L Link
1 Sept.| [7 Good. it just sat on T
2 77 37, the end of a dry
BREL f;;Ck posing for r this Butterflies: (65 records)
jcaea | [Habitat | Bush Country.
_ ITTustration

ACRAEA ONCAEA

Window Acraea

5 Info for this Family: (7 records)

1

G

I
Name [Acracidac-Acreas | Information Family - Acraeidae (Acreas)

A family of mediurr-sized butterflies related to the Mo narchs, with long
narrow wings and slow, buoyantflight. Like the Monarehs they are
distasteful to predators. Their predominant colours are red and orange.
They are often sparcely scaled with semi-ransparent patches.

Light orange-red
- Black

Cells of both fore and hindwing closed; inner margin of hindwing Description

without abdominal groove, Wingspan 4.5 - 5 cm. Rather thinly scaled on forewi ng with

T ;i ina ) ine) 1 . 1 i teh and black
‘@ fever 1) (Drasin i) Ka] ] uy dark streaks below apex. Narrow black apical patcha c

spots on both wings.

. Male light orange- red, female pale to dark brown.
Courtesy D.M. Dennison
‘ Mext)|ftcver t | [Drawing ) (i ink) K3 .
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| Using Filevision IV

Overview

Section Three contains step-by-step instructions for everything Filevision does.
Read Section Three through once just to get an idea of what Filevision can do,
then use it as a reference when you need to.

Part 1, “The parts of a Filevision file”, contains a brief summary of the parts of a
Filevision file and what they do: the file itself, Types, objects, records, and
fields. If you want to create your own file but aren’t sure where to begin, this
may be all you need to get started.

Part 2, "Context Sensitive Help", describes the features and how to use
Filevision's on-line context sensitive help utility.

Part 3, "The Drawing Page" covers all of the drawing page window features
including the information area, page size, rulers, grid, guides, alignment, zoom
views and display modes .

Part 4, “Graphics and drawing” shows you how to select and draw Filevision
graphics, using the tool box, grouped graphics, pop-ups, color and importing
and exporting graphics .

Part 5, "Pop-ups" explains the ways to create and use the versatile pop-up.

Part 6, "Hiding and Showing Objects" explains how to create and maintain total
visual control on the drawing page. Hide all objects of a Type or hide only
those selected. Show only the objects of the currently selected Type, etc..

Part 7, "Importing and Exporting Graphics" shows the methods to import PICTs,
MacPaint (bit and pixel mapped) and EPSF (Encapsulated PostScript Format)
graphics. This section also shows some of the versatility in using the Clipboard
to import and export both graphic objects and their records.

Part 8, “Creating a type”, shows you how to create the layout for a Type and set
up its fields.

Part 9, “Adding information”, shows you how to enter data in records, connect
a record to a graphic, and change an object’s Type.

Part 10, "Importing and Exporting Text" explains the many facets of Filevision's
ability to import and export to most standard applications and to and from

different hardware systems.
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Part 11, “Linking Filevision files”, shows you how to set up objects so that
they’ll automatically open another file when you click the Link button.

Part 12, "Sort and Find", explains how the drawing page objects (or Info
records) are rapidly found searching on the first 22 characters of the sort field
(the key field) and how to reorder that field. More complex sorts are handled
by the Print Records function and more complex finds are handled by the
Highlight function.

Part 13, "Highlighting" goes into detail on how to make the best use of the
powerful highlighting feature, Highlighting or selecting records and displaying
their graphic objects for various visual effects.

Part 14, "Printing Reports, Forms and Labels" covers the many print formats that
can be developed and stored in Filevision. Setting up the Print Layouts for
Report, Form, Labels are covered in detail. '

Part 15, "Form Letters and Mail Merge" shows the simplicity of setting up form
letters for general mailings.

Part 16, "Printing Recap" shows a number of examples for creating information
on reports that goes beyond setting up Reports, Forms, Labels and form letters.

Part 17, “Special Printing Features”, shows you how to make the most out of
Filevision's tools when setting up reports.

Part 18, “Editing Tools and Other Features”, is a section for miscellaneous infor-
mation, tips and how to achieve the best use of Filevision. The Macintosh tools
allow you to cut, copy and paste text and pictures, you can also cut, copy and
paste graphics with their records, Type Layouts, Print Formats, and the symbol
and shade palettes. This section covers the terms and concepts you'll use when
you translate your ideas into a Filevision file.
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1. The parts of a Filevision IV file

Here’s how files, types, objects, records, and fields fit into the Filevision picture.

Files Filevision keeps the information you work with in a file:
text, numbers, and graphics. File icons look like this:

mﬂ[rrra

» To start a new file, insert your working copy of  Brushwood Heights
- the Filevision Start-Up Disk in your internal
— drive.
ilevision® IV
Filewvision
o If you are using a hard disk, double-click the Filevision icon and
the Filevision disregard the next two steps.
program icon

« Insert your working copy of the Filevision Program

_ Cfeemm Disk in your external drive.
8 Brashanoos eights »  Click the Filevision icon, then choose Open from the

2 Copy of Fitevision T...
D EPSFs

e
Create o Filevision 1W File:  [_New )

File menu.

[Work Fite] ] (Cancel)
A quicker way to open a file from the Finder (your starting desk-
top) is to double-click on its icon.
«  After the Filevision menu bar is showing, select New
Archive [ €oHDB0

from the File menu.

0 ARIZONA RUIATION MAP
0 Banner

0 Brushwaood Heights

O Copy of filevision Tour
3 EPSFs

) Filevision Examples

0 Filevision Program

O Fil ion Start-up

Type in th for th file and click the N
},‘ . ype in the name 1or the new tlle and Cclic e New
button.

Cancel

+ To use an existing file, select Open from the File menu,

then select the file you wish to launch and then click
N ] Open
Boea.., i
Close Work File _ Filevision updates your file on disk as you use it, so it’s a good
Ay - idea to duplicate an important file before using it. Also, it is a very

Save fis...

Return to Brushwood... %; wise practice to save your working file frequently while you are

modifying it. Should you loose power to the computer or have any
Import Graphics... other inadvertent system failure, you will at least be able to recover

Eunpart Graphics... ,
Import/Export Text... the file up to your last Save.

Page Setup... « To back up a file, choose Save As... from the File
Page Size... menu

Print Page... %0 !

Print Records... ®P

» To save your working file, choose Save from the File
Quit #0 menu or Command-S for a short cut.
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As Filevision does do intermittent updates to your disk file, in the event of an in-
advertent closure, much of the Info page data would be recovered from after
your last Save. Any graphics or other information entered in the drawing page,
after your last Save, would be lost.

Types You'll often have different categories of information in a Filevision file. These
categories are called Types. In Section Two, the Tour file included the Types
Background, Golf Hole, Lake, Street, Townhouse, Model, Salesperson,

. Customer, Click Link and Property.
Change Layout...
I:‘|2|9te Tgpe You can add new Types from the Info for this Salesperson: (7 records)
i e Last Name
LS Types menu.
Heme address
4512-8 Slowway
Backgrnund Austin, TX 78751
Info for this Customer: (6 records) =
Golf Hole PR fone vene
Lake 3"9 Filevisionary
Phonelwork [(EEIEIENG L et et
rEE Model] Sales ¥TD $850,000
- 3
Current Mailing Address [ Contemg
vTownhouse 21330 Atlantic Coast Highway I sto0 Retel %)
Model Maliou, CA 59265 D°"’"e‘ NOTE: Safes * Comm Rate =
_ ___ c Commissigns 5 R
SBIESDBI’SDI'I none, Shardn, Sam Commissions NOTE: Sales % of Quota
Have they already purchased? fg;f:(g;d;'éf:' Soc. Sec. * V;Dalfunug;:: 45 |
Customer Last Contact IEG—ETEE L e e v U Gran ma L]
Click Link [ ‘Enter date info in MDDIVY Format Credit info: o s pgy iy
IC in Remarks |5 Info for this Property: (2 records)
Property ETYor Utirity shed |
TSN 6rushvvood Heights ]
Cost 310,000
et ey s e T B In Dctober 1975

1,200 square feet

Property tax
$250

Info for this Townhouse:

! (27 records)

LULIEER 090 Linkside way | Front Yiew
v b
records of [ Model |[square feet [ 1,500 | X
Coptempe

different Types Frice 9198650 Comments
* Central heating

(No_ of bedrooms [3 |!. pecreation room

[No. of bathrooms[3 || Deep-pile carpet

Available? ITeR) * Microwave oven

¢ Cool in summer

Floor Plan ( tst fIr)

Garage

fievee t ] [Drawing

=l
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Objects Objects are the things you file. In the Tour file of Section Two, each town-
house and salesperson record is an object.

Some objects, like the decorative border of a picture, are there only to improve
the appearance of the display. For other objects, like townhouses in Section
Two, you may want information connected to the graphic. And for other
objects, like those of the type “salesperson” in the Tour file, you may want to
use just information without graphics.

graphic object
(several grouped
objects)

=====——=— Info for this Salesperson: (? records
At A oS o S

| photo ]

Home address i

10980 Straitmore, #10
Los Angeles, CA 90049

DILOA I 213-478-9876

Customer Seryice Manager

[ Annual Guota | $500,000
Sales YTD $750,000

Commission Rate{%®) 3%
NOTE: Sales * Comm. Rate =
Commissions
Commissiuns $22,500
Bl Ml 543-50-0000
(Erey)

a record
without a
graphic object

I|||l||¢'\I||111IN|I|||I|I-1I|||I|

Info for this Townhouse: (27 records)

LU LIGERY 1026 Lake Avenue
Model |[Sauare feet
Uime
e Central heating
« 3 car garage
o Central air-conditioning

Avaitable? mes . Oak-pan_el dgn )
* Extra-thick insulation

a graphic object
and its record

Garage
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Records
and fields

Fields

A record contains information about an object. Records are divided into fields;

each field is a placeholder for a piece of information.

ENE==—=—=———————— Info for this Townhouse: (27 records)
mggg Linkside Way | Front Yiew
Model [Square feet [1,900 S

Comments
=3
Pri i} B

“ rice |81]@_._5@ | » Central heating

m“- of bedrooms |3 ||« Recreation room
[Mo. of bathrooms]3 || » Deep-pile carpet

Available? s Microwave oven

A Record —

86 Filevision IV

« Cool in summer
Floor Plan { st fir)

Garage

7
[Prev]Hext)[fiever t) [Drawing [ inx] K] |

All of the records of one Type share the same field arrangement. That arrange-
ment is known as the Type Layout. Different Types usually have different Type

Layouts.

Unlike other database programs, there are only two basic field types to con-
sider, the data field and the annotation field. The data field can have differ-
ent information in every record and the annotation field has the same informa-

tion in every record.

The information in data fields can only be changed while working in the Info
page while the information in an annotation field can only be changed in the
Add Type... or Change Layout... modes.

Filevision does not care what you put into a field and is smart enough to deter-
mine if it is text, a number or a picture. After you have established the field, you
have the option of changing its format, position or size at any time without
leaving the Info page. The format could include text style, size, border, show
field name or not, invert and alignment. Filevision will support up to 255 fields
per Type and a field can contain up to 4,000 characters or a 30" x 30" picture.
Each record can contain up to 8,000 characters total (about 3 typewritten

pages).



2. Context Sensitive Help

finding the
Help file

entering Help
from the
Apple menu

File Edit Types

Before we get too deeply involved in the workings of Filevision, the context
sensitive help file should be covered in case you need some quick help while
creating your new file.

The On-line Context Sensitive Help file describes all major functions of
Filevision, and may include some items that are not covered in this User Manual
as additions may be made after this has "gone to print". Where there is addi-
tional information on a subject in this User Manual. the Help Page references
the User Manual page numbers to provide an easy way to locate the topic.

While Help is made easily available from any Filevision file in any folder, there
is a recommended configuration for optimizing the use of the Help file. The
Help file should be located in the same folder as your Filevision program. All
accesses of Help will be automatic in this configuration with no need to locate
the Help file.

If you are unable to keep the Help file in the same folder as your program, the
first attempt to use Help will open a dialog that requests that you “Please Locate
a Help File”. At this point, you will have to show the program where Help is
located.

[&3 Filewision Program |
EUTEE | — 090

fiacl

fripe

Cancel

<l

Please Locate A Help File

Rbout Filevision® ID...

Set Aside Filevision® IV

If your Help file is located in the same folder as your Filevision program
when you first launch, you will be able to access Help directly from the

v A Filevision® I}
B finder

Apple Menu.

«  From the Apple (& ) menu, select Help....
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The following help screen appears:

Help Item:| About Help | Page: 1 of 2
- — Preuv
Help Hem: Click on the Help ttemn Page: Whenever the page L——]

pop-up menu ta see an index of all help || marker is displayed, there is
items. From this menu, select the help | | more than one page included in
item desired by elicking on it. that help item. To continue to

the next or previous page, click

the Mext or Prev buttons. {}

Browse: If you wish to page through all of the main help items without
selecting any particular item from the Help item menu, click the Up arrow } Browse
to go to the previous item and the Down arrow to go to the next item.

hen you reach a help item with more than one page, click Prev or Next.

-

Help: If you wish to enable the context sensitive help cursor, click the

Help button. Once the “Help” cursor is present, pull down any program } m
menu and click on the menu item that you would Tike to see help on.

Exit: After you are finished viewing the help screens, click the -~
Exit button to leave the help screen and return to your file. P Extit

Help item: Once in the Help window, you have the option to select a major Help Item
pop-up menu topic by pulling down the pop-up menu, Help item:.

+ Click and hold the mouse pointer on the Help Item: pop-up menu
and drag down to Highlight....

[ W File Edit Y #t Symbels Shades
Background eights - Actual Size
Bring to Front
Color Page: 3013
€ d Key Chords
Prev
CO 10[‘ DIF, SDF & SYLK fesigning in color as [—J
your illustral Delete Records... and white monitor.
The exampled phite while the left
butter| Delete THDE foyan patterns in the
Al solid colors

«{ Double-click
Drawing Page
Drawing Tools
Drawing page 2oom liew
Edit Rounded Carners...
Edit functions
Error messages
Field Setup...
Find...
Formatting

Forms

Gather

6rid & Rulers...
Group
Hide-Show Types
Highlight...

1E Dptions menu
Icon types
ignore-Activate
Import-Export File menu
A4

h:?7 v:27

After you release the mouse button the screen will change to show help page
on Highlighting.
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entering context
sensitive Help

the help cursor

= Edit Types

Access

| Page:1ef9

Help Item:| Highlight...

Prev

nghllght . emphasizes objects that pass these conditions

Summary of one candition —;

Price is
| less than or equal to

@ AND— ) OR-
Use this pop-up menu to
select another field
between

Tess than or equal to
greater than or equal to
equal to

O Rank (1 to 373
O Field

Use this to erase selected condition

et

Just select the topic that you want information on and the first page of multiple
page topics or the only page of single page topics will be displayed.

The Help Item: pop-up menu will not necessarily show all of the program
menu items which is done to restrict the number of Help menu items to a
manageable number. For instance, if you click “10” point in the Text menu
when in the context sensitive mode, the help item that would be automatically
linked is Text Size. Also, there are many pages of help that have no menu
counterpart. These are listed by topic name in the Help Item: pop-up menu

There are several ways to access a particular help item, via the Help Item: pop-
up menu or from the context sensitive mode. The context sensitive mode is
entered by pressing Command-?. It is not necessary to shift the ? key as it will
read the key press either in shifted or non-shifted mode.

+  While working in either the Info page or the Drawing page, press
Command-?.

The cursor will change to the word FElJ.

By moving the Helf cursor to open the menu (same as with the normal
pointer cursor) and then moving it to the menu selection that help is

New... '
0pen...
Close 4

Save as...
Return to...

3#0

required on, the help page on that item would be shown as soon as the
mouse button is released.
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»  After the Help cursor is showing, pull down the File menu and
release on Save. After a brief moment, the File menu help screen

appears.
Help Item:l File menu J Page: 1 of 2
File fUﬂCtiOﬂS Addenda page 336 Prev

® New...opens a new file under the name you enter. (38-N) -

& Open... opens an existing file. (3§-0)

@ Close... closes the file that is currently open and leaves you in the G
Filevision ¥ program. Browse

® Save saves the current file without closing the file. In the eventof a
power failure or other unexpected system failure which could cause
severe damage to the file, the Save function would assure that

the file is in tagt to the point of the last Save (38-5). -

# Save as... provides a back up copy of the current file. HIGHLY RECOM-
MENDED to provide an additicnal safety factor against lost files. Enit

In Help, if the topic has more than one page, a Page 1 of X will be shown next
to the pop-up menu. To view all pages, click the Next or Prev buttons. This
operates as a carousel and will return you to the first page after you have
pressed Next from the last page.

multiple help If you are interested in browsing through the main topics of the Help file, click

topic pages the up and down arrows to view the next or previous topic. If you find that you
need to locate a specific Filevision menu item and it is not shown in the Help
Item list, click the Help button and you will be returned to the context sensitive
Help cursor. From here you can again pull down a program menu and select the
specific item for help.

Help Item:[ Highlight... | Page: 1 of 9

nghllght . «emphasizes objects that pass these conditions

Sumnmary of ore condition -1 { Next ]

Price is
| Tess than or equal to
$3,500

exiting help To exit help,

or Command-? again from the Felp cursor.

»  Click the Exit button from the Help window
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3. The Drawing Page

the drawing
page window

It is difficult to place the importance of the Drawing page over the Info page in
setting up a database; however, as both are important to the operation of
Filevision, let's start with the first thing that greets you when you enter Filevision
- the Drawing page. If you plan to use Filevision as a file manager only, without
graphic objects, then you can skip ahead to Part 8, Creating a Type.

The drawing page window is tvpical in many ways with the standard Macintosh
user interface. It has a window title bar. standard scroll bars, a zoom box and
resize box. Unlike the standard Macintosh window, the close box is used to
close the window only, not the file. This is to allow the user full access to the
MultiFinder (see your Apple Macintosh User Manual) desktop without closing
the file or resizing the window.

There are several unique elements to the window which provide a considerable
amount of control and information about your file. These elements are all
contained at the bottom of the window and include:

* A mini page viewer and mini page scroller.

+ The information display.

«  Cursor tracking coordinates and ruler information.
» Record icon box.

*  Prev, Next, Info and Link buttons.

ruler info

cursor tracking coordinates

information area -
mini page -

Townhouse: (20 total>

72 Ruler:Feet

|

mini page scroller

lPreullﬂextll Info]li ink

record icon box

B

— Link to specified file button

Info button - brings up the Info page
Next object/record button

Prev object/record button

Part 3. The Drawing Page o1



the mini page

centering
the window
on selected

objects

centering
the window

92
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The mini page (the black rectangular area) is a scaled down view of the drawing
page working area. As you change the page size of the working area, the mini
page will also change to represent the new window area.

screen window

8" x 10" drawing page 30" x 32" drawing page

The mini page scroller (the white rectangle) is a scaled down view of the
window area that you are currently working in (the on screen area). It can be
dragged to any position on the mini page and the window to your working area
will track its position.

+
4

Start Position End Position

Besides showing the mini views of the working page and viewing area, any
selected object or group of objects will be represented by reversed pixels.
Objects selected within the mini page scroller will be shown as black and
objects selected outside the scroller will be shown as white.

Selected Objects

When moving between the Info page and the drawing page or to different
scaled views, the viewing screen area will always try to center around any
selected object or group of objects. For instance, if you are working in the Info
page and have a record selected who's object is outside of the current drawing
page viewing area, as soon as you click the Drawing button from the Info
page, the drawing page window will be relocated to bring that object into view.

If you wanted to center the viewing area in the middle of your working page,
hold the Command key down while clicking on the mini page. In this case, a
selected object may be placed out of view.



drawing
page size

the
information
area

The drawing page size can be changed from the File menu.

+ Select Page Size... from the File menu.

The following dialog is displayed:

From this dialog, you have
Select a drawing page size: the option of selecting any of
------------- twelve drawing page configu-
rations. Each page rectangle
represents an 8" by 10" area
which matches standard

Cancel printer output.
The currently selected size

shown here is 20" high by 24"
wide (six 8 x 10's side by
side). To change the page
size to 30" by 32", click on the
lower right rectangle.

The drawing page size can be changed at any time. No information will be lost
if you have objects entered on a large drawing page and then reduce it to a
smaller page. Even though you won't be able to see any objects that are no
longer in the active page area, clicking the Prev and Next buttons will let you
know that they are there and the mini page will invert a pixel as close to the
object as possible when the object becomes selected.

The information area provides the current Type selected and the name of the
current object selected. If no object has been selected, the total number of
records in the selected Type is shown. If records have been highlighted, the
total number of highlighted records is shown. If the Type selected is currently
set to Ignore, the information will be for the total number of objects in that
Type and that they are not selectable. If the Info page sort field connected to
the object contains a picture, the information area will display -- Picture --.

As soon as you have entered an object on the drawing page, a blinking cursor
will appear in the information area. Without having to select

j the text tool, you can enter a name for that object by just

2

typing it in directly.

Background: Suymbol|

[Eraw ] (B & I[info | N
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cursor Tracking

94

Filevision IV

The name that you type in will be entered at the same time in the sort field of
the Info page. If you later change the sort field and continue to add objects and
type in their names from the drawing page, the object's name will be entered
incorrectly in the Info page (assuming that you want all of the objects' names in
one field).

The field that is automatically set as the sort field, when first adding a new type,
is the Name field. This can be changed after the Type is established by resort-
ing on a new field using Sort By... from the Access menu.

You may also enter an object's name in the sort field of that object's record and
it will be automatically displayed in the information area of the drawing page.
As the sort field can be large enough to accept 4,000 characters of text, the
information area will show two periods (..) after all of the field information that
can be displayed (22 characters).

OE

E[= Info for this Background: (1 records)

IIIIJJ_|

Name
his is a symbolic representation
| of the species homo sapien.

[Frav]Bex {)[Bovert](Drawing | T

Background: This is a sumbolic

[ [Fre)Bed(nrol Lin)KI

s

&
||
® R
vl

<l

||lm|||l|I|I

Cursor Tracking can be turned on and off from the

Options menu and represents the screen position Show Ruler ®R
of the cursor at any given time. The h:v coordi- Hide Toolbox &1
. p Hide Mini Page 8K
nates are a measure of pixels (usually 72 perinch) | oo e
with the lowest number occurring in the upper left | yide window
corner (h:1 v:1) and the highest in the bottom right
corner (depending on the size of your monitor). vShow RActual Size #1
Show 50% Size %5
o ‘ o show 33% Size ®3
Tracking is toggled on and off each time that it is Show 200% Size %2

selected with a check mark indicating that it is

currently ON. The tracking coordinates will only
display while the cursor is over an active part of the
screen.

If you attempt to resize the window to less than 6
1/4" horizontally, the tracking coordinates will no
longer be displayed.

Ruler Origin at Bottom Left

Grid X
vGuidelines

Snap to Guide

Snap to Alignment

Edit Rounded Corners...

Show Grid & Guides in Front




display mode
preferences

record icon box
and attaching
graphic objects

Undo #2
Cut H
Copy L
Paste ®U
Clear

Bring to Front  <{-3F
Send to Back %8B

Gather N 38T
Reshape %A

Ungroup A0

Add Record #A
Duplicate Record %V
Delete Records...

Preferences... #E
Grid & Rulers...
Field Setup... 3=

S[IE=——=—————  When the rulers are showing, the cursor
b i1 A position is also tracked on the rulers as
\__/ dotted lines.

The combined tracking features provide a
more precise method to enter objects on
A the drawing page.

)
Q./nl.l.

The record icon is displayed in the record icon box anytime a record having
no object is selected. This provides visual evidence of the records selection
when working on the drawing page and is most useful in attaching objects to
objectless records at a later time.

Whenever you want to attach an object to a record, use the following proce-
dure:

+  First select the record while working in the Info page to make sure
that it is the record that you want.

+ Click the Drawing button to move to the drawing page.

«  With the Shift key depressed, select the object that you wish to
attach. This now selects both the record and the object.

»  From the Edit menu, select Group.
Your record is now attached to the new object.
To change an object's record or record's object:

»  First select the record or its object.

+  Select Ungroup from the Edit menu (Group and Ungroup are
toggles to the same menu entry).

A dialog will appear
warning that: Ungrouping will result in a
record that has no graphic.
+  Click OK.
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Prev and Next
buttons

Info and Link
buttons
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You can now repeat the procedure for attaching an object and record.

Double-clicking on a record icon is the same as double-clicking on an object
with an attached record. If the selected Type is set (via the Options dialog in
Add Type or Change Layout) to transfer you to the Info page for a double-
clicked object, a double-click on the record icon will produce the same results.

The Prev and Next buttons are for the sequential selection of records and
objects. The action of clicking either of these buttons in the Info page or
Drawing page are the same. Each click advances you to the next or previous
record of the selected Type.

If the next or previous record does not have an object attached on the drawing
page, the record icon will appear as described above.

Records and their attached objects are stored in sort order. As Filevision
handles records dynamically (constantly moving them in and out of memory
and changing the sort position), the next or previous record will always follow
in alphabetical order. If an object is entered and is not identified in the informa-
tion area, it will become the last in the series of unidentified objects but will be
placed before any identified objects or records. In other words, "null" sort fields
precede "non-null" fields in the collating sequence.

Aocess

"Background"s:

The Info button is used to access the database :F’r; By... <
P nd...

record for the currently selected Type and object, fing Same

while the Link button is used to link your current Highlight... KN

file to the one named in the Link field of the Hightight Selecied B

currently selected record. Highlight Al G%A
Hide All £»3H
Show Al {>%S
Show Only These

The Prev, Next, Info and Link buttons all have Ignore

their counterparts in the Access menu. You can
also use Command-key short cuts to access the
various options described here.

Show Al Types
{ anoal Highlighting  Bd

Previous Record %P

Neut Record N
Info Page ®1
Drawing Page ESH
Link 3




drawing page The drawing page rulers differ from the Info page rulers in providing several
grid and rulers options for set up and display. Those options can be activated from the Grid &
Rulers... option in the Edit menu.

*  From the Edit menu, select Grid & Rulers....

The following dialog is displayed:

Edit drawing page rulers and grid for this file:

* Show ruler in: [Inches |

+ 5et initial reference point at;
® Upper left - positive numbers down & right.
{0 Lower left - positive numbers up & right.

Initial ruler starting values: Horiz D Uvert D
* Grid o.......... Elmths of an inch [J Show grid
s Alignment .E‘?Ends of an inch []Snap to alignment
¢ Guides........ &J Show guide [1Snap to guides

As can be seen, there are a number of options when defining the Grid and

Rulers.
Show ruler in: By clicking the pointer on the pop-up : : : N\

menu, you will be given these options Feet

for setting the ruler measure. The list Yards

provides for most standard linear Miles

measure from points to miles. Centimeters
Meters
Kilometers
Points
Picas
Pixels
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Set ruler scale
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Points and Picas are printer's measure, while Pixels is a computer screen
measure. Pixels and Points are generally the same measure, depending on the
monitor being used. If the monitor has a resolution of 72 pixels per inch, the
Points measure will be accurate. However, if the monitor has a resolution other
than 72 pixels per inch, which is the case with some color monitors, the Point
measure will be slightly off.

The selection that first displays in Show ruler in: is Inches. This would
provide standard inch rulers on the drawing page.

'é"l|ll||l1|I|lllllﬂ

* Show ruler in: [Inches |

Illllﬂlllllll

If you select Feet from the Show ruler in: pop-up menu, a box becomes
visible to enter the scale that you want reflected by the rulers. If you wanted to
do an architectural drawing and have the rulers show a scaled measure in Feet
with 4 feet = to 1 inch (quarter scale), then set the scale accordingly.

L 8

* Show ruler in: [Feet |

With 1 inch = |4 ]reet E

|.:>

Set to Picas for desktop publishing:

.|.|.l.|.|.6|.|.|.l.|.|'.2|

* Show ruler in: [Picas |

|m

[N

Set to Miles for a scaled map: 100 200

* Show ruler in: [Miles |
Wwith t inch = {100 [Miles

As can be seen, you must set a scale for the rulers if you select other than a
measure that can be scaled at a 1:1 ratio.



Set initial If you select the Upper left radio button for initial reference, the rulers would
reference show as below with vertical measurement increasing downward:

point at:

=S ==————————— Ruler File - Actual Size EF—————————4
1||||l|1||l||1112]||i||||3||||||||4|||l'|||5]xl|]|||6'1

2

hl|||

Background: (0 total> Ruler: Inches

| [Ered]Eexy)(Info) GinsfI] ] 0

If you prefer that your rulers show at the bottom of the screen with vertical
measurement increasing upward, select the Lower left radio button: (Notice
the location of the mini page scroller.)

EL] Ruler File - fictual Size
1]
o] 'Buckground: (0 total Ruler: Inches
T T T T 1 1 T 1 T T T T T T T T T T T T T T T n
(ML AL LA AR AR NN AARRARR” RARRAN" M
Pr o] [Hext] [Info) (a2 =1

If you need to show the intersection of the two rulers when displayed at the
bottom, select Hide Mini Page from the Options menu. You can also hide the
information display area by selecting Hide Titles from the Options menu.
Your drawing page and rulers would then appear as:

E(1=————=———— Ruler file - Actual Size ﬁ—_mél

Sl

(]

S

]Illl||‘||||||'|2||]]I|'|3||I|l|||4|||l]|||5||||||]|6||
|Fr e ext) (Info) £ ms K

mika
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Initial ruler
starting values:

adjusting the
ruler zero
position

Grid

It is not necessary to have your rulers always start at 0,0. Using the Horiz and
Vert boxes, the ruler can have a beginning reference of anything you wish from
0 up to 9999 by 9999. This provides a method to start a reference relative to
some fixed point, to continue a large drawing in more than one file and have
the rulers start where the previous file ended or whatever your needs may be.

You can also set your true zero or relative zero position to any location on the
drawing page. This is easily done by holding your mouse button down with the
pointer in the ruler intersection and dragging to a new position. As you drag
out of the intersection box, a vertical and horizontal guide line will display
letting you know where your new zero position will be as soon as you release
the mouse button:

[T}

E[[&===——————= Ruler File - [J==——— Ruler File -

-Lllllll‘llllllllzI|I|le31JJ ‘“'g"||||||_11‘|1|l|||0||I|||I|‘(|I
e

.

™.

‘Illlalllllll

;

To return the rulers to their original zero position, click once inside the intersec-
tion box with your mouse pointer.

You can also display a grid on the drawing page which can be set to twelfths of
an inch. Setting the grid to 6 (or 6 twelfths) would be the same as setting it to 1/
2 inch (6 + 12). The acceptable range for setting the grid is from 1 (1/12 inch) to
120 (10 inches).

The grid can be turned on and off by either clicking the Show grid check
box in the Grid & Rulers... dialog or by selecting Grid from the Options
menu.

Show Ruler R
Hide Toolbox 8T
Hide Mini Page %K
Hide Tities
Hide Window

vShow Actual Size %1
Show 50% Size %5
Show 33% Size 83
Show 200% Size 82

* To turn on the grid, choose Grid & Rulers... from the Edit menu.

You'll see the Grid option in the dialog box.

Ruler @rigin at Bottom Left
Tracking

vbrid

vGuidelines
Snap to Guide
Snap to Rlignment
Edit Rounded Corners...
Show &rid & Guides in Front

* Grid .oen...... Ethhs of an inch [X] Show grid

* You can type in the alignment spacing in 12ths of an inch, or you
can simply leave it at its current value.
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= Click the Grid button to turn it on if there's no X in the checkbox, and
to turn it off if an X is present.

The grid can be shown either behind or in front of all objects on the drawing
page display and is selectable from the Options menu.

[ % File Edit Types RAccess Options Teut symbols Shades ]
EO==———=— The Eye - Actual Size === |

éSupen’o:k Recius: Musclej: éf\rierw:s And Yeinz Of T!‘le Ey eb:all

Coniunctivefa of

Theméba" AT EREREN e, | . Sheath Ofithe 0 tie Merve

IFis

Cornea

.. batersl Bectus Misele... .7 5 o I U

< eee i Infevipr. Dbligge Musate A L N L L N AN e

Eyeball: Conjunctivea of the ey. .

| [Prev)Hext)(nfo} L im][T]

Alignment Alignment provides a method to draw or to move graphics in fixed increments,
Alignment can be turned on by either selecting the Snap to Alignment op-
tion from the Options menu or by dlicking in the check box Snap to align-
ment in the Grid & Rulers... dialog hox.

Alignment can be set to any value from 1 (1 pixel or 72nd of an inch) to 72 {1
inch}.

* Alignment .[9 |72nds of an inch [] Snap to alignment

Alignment can be used for several drawing page functions:

1. To move graphics, symbols or text blocks in alignment increments.
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For instance, if you wanted all objects on the drawing page to align every half
inch, set Alignment to 36 (36 + 72 = 1/2 inch) and turn alignment on. When you
attempt to move an object, it will "jump” in half inch increments either horizon-
tally, vertically or diagonally. Once an object is moved, it will always come to
alignment in common with all other objects that have been moved (with
alignment on) to the same vertical or horizontal alignment plane.

2. To draw graphic objects to the same or to a precise proportional
size.

For instance, if you set alignment to 54 (54 + 72 = .75 inch), all shape objects
would be drawn in increments of 3/4 inch. If you wanted to draw a rectangle 3/
4 inch tall by 1 1/2 inches wide, stast the rectangle and drag down one click
(jump) then drag to the left or right two clicks (jumps).

Ovals and arcs can also be drawn to a precise height:width ratio by using
alignment. If you want an oval that is precisely twice as wide as it is high, draw
it with alignment on and then turn alignment off and proportionally resize the
oval (Shifi-Option-drag) until it is the size that you want it. Tt will remain twice
as wide as it is high.

3. Toremove "reshape” points. (Reshape is covered in Part 4:
“Graphics and drawing” in this section.)

Reshape points are easily added to a line by clicking the pointer tool wherever
you want the point added on that line. However, removing a reshape point
requires that it is moved to a precise alignment with another existing reshape
point. The easiest way to insure that they are precisely aligned is to move them
both to an alignment point.

When working with alignment turned on, it is important to undesstand how
alignment functiocns. Due to the nature of aligning to an invisible alignment
plane, alignment was designed to align based on the direction that the object is
being moved. This prevents erratic movement that would normally be experi-
enced if an object was slightly smaller or larger than the alignment distance.

Alignment occurs on the leading edge of the object that is being aligned which
is determined by the direction that movement of the object begins. For in-
stance, if you wished to align an object on its right edge, you would have to
start to the left of the alignment plane and move the object to the right until you
reached that alignment plane.



Guides

As an example, the following illustration shows three 54 pixel by 54 pixel
squares two of which were aligned to common alignment planes.

Squares 1 and 2 are to align at opposite comers of an invisible alignment
intersection (dotted lines). Square 3 is to align to the next intersection of the 72
pixel alignment planes.

2 W@w&mww

In this example, square 1 must be dragged from above and to the right of the
intersection. Square 2 must be dragged to the left of the alignment plane, the
mouse button is then released and repressed and the square is then moved to
the right and up to the intersection. Square 3 must be dragged to the left and up
to its intersection.

Symbols align in the center of the symbol and alignment plane.

A single line of text aligns at its baseline and left edge. A block of text with
several lines of text aligns at the baseline of the top line of text.

Guides provides another method to align objects on the drawing page. The
guides are displayed by dragging them from the rulers. Dragging from the
horizontal (top} ruler creates a horizontal guide line. From the vertical (side)
ruler creates a vertical guide line. You can drag as many guide lines onto the
drawing page as you need.
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To "grab" a guide line, first move your pointer tool over the ruler. Depress and
hold the mouse button (the pointer tool changes to a double arrow) and while
you are still holding the mouse button down, drag the guide line out of the ruler
and position it where you need it. To remove a guide line, grab it with the
pointer tool and drag it back to the ruler.

[==—————————— = Rulers - Actual Size FFF————
Illllllill]lll |2||||| 3[Llll§l|l4|Ill]!llsllll|||I6|I|Illll7|

wlaig

L

Show Ruler
Hide Toolbou
Hide Mini Page
Hide Tities
itide Window

#R | Once you have your guide lines in place, you have the option of turning on
#T | the Snap to Guide function from either the Options menu or the Grid &

vShow Actual Size
Show 50% Size
Shew 33% Size
Show 200% Size

¥K1 Rulers... dialog box.

%1 * Guides........ Show guide (<] Snap to guides
®5

®3

®2

Tracking
Grid

Snap to Alignment
Edit Rounded Corners...

Ruler Origin at Bottom Left

Snap to Guide creates what is best described as a "magnetic force rhat
causes an object to "jump" to the guide line as soon as it is moved within a
few pixels of the line. If you are working with a color monitor, guide lines

~Guidelines are colored in magenta so that they don't conflict with the grid lines
_Snap lo Guide gi colored in cyan.

Show 6rid & Guides in Front| You also have another option which is to either show or hide the guide
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lines. This feature is useful if you are continuing development on the
drawing page and wish to leave the guides in place but don't want them to
show when you are in one of the display modes (display modes are covered
under Display Mode Preferences at the end of this section).

The guide lines can be shown or hidden by clicking the Show guide check box
in the Grid & Rulers... dialog or by selecting Guidelines from the Qptions
menu. If Gaidelines is checked, the lines will show.



drawing page

Z0om views

Filevision has four drawing page zoom views, 33%, 50%, Actual Size (100%) and
200%. The question as to why these unusual zoom view percentages has an
easy answer. These were the only zoom sizes that could be translated by the
mini page and as the mini page is an important feature of Filevision, it pretty
much governs the drawing page sizes.

The zoom views can be entered from the Options menu or by Command key
chord sequences of:

*  Actual Size (100%) 38 -1
«  200% Size # -2
» 33% Size * 3
«  50% Size 3 -5

All drawing functions including text entry can be performed in any of the zoom
views.

The following U.S. Map example is a double page (10" x 16") setup shown on a

13" monitor with zoom set to Actual Size. The map shows a thematic represen-
tation of median family income in the United States.

Notice the mini page and viewing area of the map.

uUs Map - Actual Size

15
lilgl|I||||1|U|zl||||1|1||||1||112|1||lslTlsll\|||II|4||I|11111|I\||I

(=i ) o0
\lrlnlLI|ln||Itl|I|||l\|1l||||||ﬂ|||||

2?/ J/(-V///zf//////f ~ s e
v s srrrissn g
‘42525' 'zz/zzz/zzz/zz,yaz?/‘ P i
"'/f///f//fff/r///ff PLEORL IS
d%‘ PN NNy /PR RS

7
W rsr v v vvvparrrisadoccsrareirsrrisy 1&
fﬂ’////////r’//!///t‘f/ PR AV S
I g g P R R s Py
7 ®

V// ey =
Ry r) >

Median Famtily Income

// 15,000~ 17,500
%

7 17,500-20,000
P2 20,000-22,500
22,500-25,000
R 25,000 & Up

Income: (51 total? W
o ]
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The following example is of the same 11.8. Map zoomed to 50% size. In this
example, the drawing page area is in full view and is shown as a drop shad-
owed rectangle. As the full drawing page is now in view, the mini page reflects
it by showing all white.

ST R T N I
= ,
% r?/////, 7 L 2 ‘?g

E /////4 //{{///4%%/% g Elo

K 4

iR = R

By ] A 2

f—; Il \a h‘“@ | E%i?‘

The view below is a 200% zoom which allows you to work in much greater de-
tail. The area of the drawing page that is zoomed to is controlled by first
selecting the object that is to center in the window.

Eg

US Map - 260% Size

Income: (51 total)
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display mode
preferences

Undo ®Z
Cut &H
Copy £
Paste 8o
Clear

Bring to Front  {»3%F
Send to Back {+3B

Group ®G
Gather 3T
Reshape 4+3R
Add Record #A

Duplicate Record Y
Delete Records...

Preferences...
Grid & Rulers...
Field Setup... =

Handles

Filevision is not only a powerful tool for creating an object oriented
database. It also has several features to allow various modes of display.
The current display mode is controlled from the Preferences selection
from the Edit menu,

By either selecting Preferences or issuing a 38-E, the following dialog
is displayed:

I Preferences for this file:

¢ Show selected graphies using:
@ Handles O Black (O Blinking (O Nothing

s Double-click on graphics: @ Accept ) Ignore

| []Info & Form rulers on: @ Inches () Metric

The first eniry, Show selected graphics using: sets the way that cach
object will react on the drawing page when it is selected. Under
nermal development, where objects are being entered on the drawing
page, Handles must be selected. Handles is the working mode and
describes the handles that are displayed when a shape or line is
selected. Handles also controls the display of the tool box, which is
automatically removed from the drawing page when other than
Handles is selected.

All other options cause drawing page objects to react as described by
the option. Black causes the selected object to turn black, Blinking
causes the object to flash and Nothing causes no action even though
the ohject is selected which can be verified by the changing information
area and mini page.

The Double-click on graphics: cniry is used to force a single-click
reaction where you do not want the Info page to be displayed or to be
linked to a link file if an object is inadvertently double-clicked. In this
case, set the option to Ignore.

Info & Form rulers on: is for selecting the method and display of
rulers in the Info and Layout pages ONLY .

Part 3. The Drawing Page 107



4. Graphics and Drawing

The toolbox

108
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Graphics, drawing, and information: Filevision has the unique capability of
lerting you create graphics, then connect information to those graphics. A
typical example was used in Section 2's Tour, where you could double-click a
graphic of a townhouse and instantly see a record of information about that
townhouse.

How drawings are put together: Filevision drawings are made up of individ-
ual pieces, like a jigsaw puzzle. Those pieces can be "grouped" in order for
them w behave as if they were a single object, and objects can be ungrouped
just as easily. Complex shapes are always made up of simpler ones; using
Filevision's graphic tools is a process similar to creating a collage.

Symbols and pop-ups: Filevision features two unusual graphics options in
addition to the standard drawing tools: symbols and pop-ups. Symbols are
small, icon-like graphics that are particularly easy to use with Filevision. They
lend a professional look to a file and you can create your own. Pop-ups are
grouped graphics with only one normally visible part. When you click the
visible part (called the "button") the rest of the graphics appear. Pop-ups let
you take full advantage of the limited screen space of the Macintosh and create
startling effects.

Using Color: Filevision can create color graphics (and text) using a Macintosh
11 with a color monitor. The use of color in Filevision is easy to learn and can
emphasize both your drawing page objects and Info page layouts. (Vintage
Macintoshes can also display in color with color monitors and color cards.)

Importing and Exporting graphics: Filevision allows you to import graphics
either from the Clipboard or directly from 4 graphic file. Besides the common
MacPaint and MacDraw (PICT) formats, you can also import (and export)
Encapsulated PostScript Format (EPSF) graphics. Using EPSF graphics allows
you to create files with the ability to store and print high resolution graphics
much the same as a standard desktop publishing program.

The tool box: The small floating window (palette) of icons usually found in
the upper right of the drawing page window is called the toolbox. As you can
see, it's where you find the Filevision drawing tools. This section is where to
learn how the Filevision drawing tools work.



The pointer

selecting a
single object
with the pointer

selecting
several
neighboring
objects

with the pointer

m

The pointer, which looks like an arrow at the top of the toolbox,
works just like it does when you're using the Finder. To select the
pointer, click it.

»  Click the pointer tool.

+ To select a single object, click it.

Fioor Plan - Hoiual s

SR FLOOR PLAN

Notice how handles appear around it.

+ To select several neighboring objects at once, point to an area near
the group of objects that isn't itself occupied, hold down the mouse
button, and drag the pointer diagonally across the group of objects.

A dotted rectangle appears as you drag, which is referred to as a "marquee”.
When you release the mouse button, all the objects within the rectangle will be
selected (assuming that they have not been set to Ignore from the Access
ment):
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selecting
neighboring
objects of one
Type with the
pointer

selecting
several non-
neighboring
objects with
the pointer

The text tool
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* You can use the above method of selecting several neighboring
objects, but constrain it to select only objects of the currently
selected Type by holding down the Option key while you draw the
marquee by dragging over a set of objects.

e To select several objects that aren't neighboring, hold down the Shift
key while you click each object. If you click it again the object will be
deselected, though the others won't be.

This method can be mixed with the previous methods. Items that were selected
will become deselected and vice versa.

With a few limitations, text is handled like any other graphic in the drawing
area. You can't stretch it, but you can move it around the drawing area, and
change its size, font, style, masking and color using the Text menu.



The Text menu

«  Select the text tool from the toolbox:

"

+ Choose a style, size, and font from the Text menu.

I

The "I" heam will appear as soon as you move the mouse.

« To add text to the drawing, select a starting point by clicking on it
wherever you've moved the | beam.

A flashing vertical bar will appear when you select an area. That's where the
text will begin when you start typing (the insertion point).

+  Now type, using the keyboard just as you would a typewriter.
You can type up to 4,000 characters at a time. There are no word wrap func-
tions when entering text and you will have to hit the Return key at the end of

each line,

= To finish using the text tool, click the pointer or any other tool.

Text can he any of a number of different

fonts, sizes, styles or colors. You can also Font 4
provide a mask for the text being entered Size 8
so that it will show up against shaded or Y Plain text

colored backgrounds. All of these Color »| Underline
attributes are selectable from the Text

menu. Mask Color »

ftatic
Text Masking Shaidom
The Text menu is hierarchical and (0lultilliinte]

presents sub menu items when you drag
1o a selection. The sub menus work the
same as a normal or non hierarchical menu by sliding the mouse pointer over to
the sub menu and then releasing on the selection required.
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Size
Style
Eolor

There are five hierarchical menus on the Text menu that appear as follow:

h fAivant Garde

Bookman
Brush Script
Cairo

Mask Color
Tert Masking

4
4
>
»

CalligraphylLaser
Carta

Filevision IV

Chicago
Courier
Garamond
Genevd

Hobo

Muobile

Monaco

N Heluetica Narrow
New Century Schibk
New York

Palatino

Times

Zapf Chancery
Zapf Birt_ghats

«Helvetica

Tenxt

| Font )]

Size g 6

Style b 8

Color LY
1m

Mask Color p|12

Tent Masking 14
18
24}
30
36
48
60
73

Font [ 4

Size »

Style b

0 vBlack

[Mhite

Mask Color | Aed

Teut Masking Green
Blue
Cyan
Magenta
Yellow

Font b ‘
Slze
~/Pla|n tent
Color Underline
Bold
Mask Color B| Flabic
Text Masking Shacdom
[0juitlEnle]
Mask Color UGS
Text Masking |vWhite
Red
hireen
Blue
Cyan
Magenta
Yellow

« The Font menu provides storage for up to 256 different fonts.

- The Size menu allows the selection of point sizes from 6 to 72
points. The sizes shown in outline style indicate that the font chosen
has a corresponding accurately scaled screen font to match the

printer font.

*  The Style menu selects the style that the currently select font will

print in.

«  The Color menu allows you to select any of 8 colors (including black
and white). This menu works in conjunction with the Mask Color
menu to provide foreground (text color} and background (mask color)

combinations.

Even if you are not fortunate enough to be working with a color monitor, the
combination of text and mask colors have other uses. For example, a white
mask with black text will block out backgrounds that prevent the text from
being read easily. Don't forget to turn on Text Masking by selecting it {a check
mark means that text masking is on).



working with
drawing page
text

In entering text on the drawing page, it should be noted that text is primarily
used to identify objects, describe object button functions, for banners and
titling, and some brief instructions or descriptions. It is not intended to function
as a word processor, even though a business letter could be created with a little
effort.

Text attributes (font, style, size, etc.} apply evenly to a single block. For in-
stance, if you set underline ON, all text in that block will be underlined. If you
wanted a block of text to show without underlining but wanted one word in
that group of text underlined, you would have to leave a blank space in the
block and then create a separate underlined word to move into the empty
space.

/’

This is a block of plain
text that requires one word

to be for
emphasis. underined
Main block Insert

This is a block of plain
text that requires one word

to be ynderlined for

emphasis.

Combined drawing page text block

/

Text editing features also apply to drawing page text blocks. To select an
individual word or group of words within a block for editing, you can either
place the text cursor at the beginning or end of the word(s) and "sweep" across
the word(s) with the mouse bution down. You can also double-click on a
single word to select it. You could also insert the cursor at the beginning of a
word and while holding the Shift key, click at the end of the word(s} or block of
text to be selected. This will select all text in between.

Once the word or words are selected (shown in inverse) you can type in a new
word replacing the old. Also, all functions of the Edit menu will apply to the
selected text.

This is a block ofthat shows the words
"plain text” as being selected for editing.

While the Filevision drawing page is not a word processor, with a little imagina-
tion you can still get the job done.
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The symbol tool  Symbols serve several purposes; they're convenient, they lend a consistent and
professional look to drawings and they're easy (o create,

+ To add a symbol to your drawing, click the symboi tool.

S
% When you move to the drawing area, the pointer takes on the shape of the
symbol you just selected. In reality, the symbols are all cursors that replace
¥ An the pointer tool as the active cursor.
i «  Click where you want the symbol on your drawing.

BD| |||
q&

+ To change the symbol in the tool box, choose the symbol you
want from the Symbols menu.

E

The Symbols palette can be shown by pulling down the Symbols menu. The
Symbol Editor can also be accessed by double-clicking on the symbol tool
in the tool box or by selecting the "Editor..." option from the Symbols
menu. A symbol can be both selected or edited from the Symbol Editor.

+(O]|CE |™
=14
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L
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|
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If your drawing already has symbols entered and you would like to use one

of the symbols already being used, click on the drawing page symbol while

holding down the Option key and the tool box symbol will change to match
automatically.

Symbol Editor

The symbol being edited

magnified about 600%.
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The
Symbol Editor

symbol rotation

Whenever you need to modify existing symbols or create new symbols, use the
Symbol Editor. As mentioned previously, the Symbol Editor can be accessed
by either double-clicking on the symbol icon in the tool box or by selecting
Editor... from the Symbols menu palette.

+  Double-click the symbol icon on the tool box.

The Symbol Editor is displayed (previous page). Besides the full palette of
symbols, the editor has an edit box and other button and pop-up menu options.

rotate 90° rotate 90°
counter clockwise | Hilg v clockwise
SEEEEEEN_ BN
B E N E EE NN
N NN N EERE
]
) H — slide symbol
flip horizontal — I = flip vertical

ForeGnd: Black | symbaol color
BackGnd: pOp-up menu

return to original ——( Revert ) (invert ) swap background
before editing and foreground

The editing box is designed to allow each magnified pixel (square) to be turned
on {black} or to be tumed off (white) by clicking on it with the cross hair (+)
cursor. This operates much the same as "fat bits" in some paint programs.

The triangle shaped arrow heads to each side and the top and bottom will mave
the current group of pixels one pixel in the direction of the arrow each time the

arrow is clicked. This allows you to center a small symbol or to get a little more

room to work if you miscalculated the position when you started designing your
new symbol.

The small icons in the four corners allow you to rotate or flip the symbol to the
indicated orientation. It should be noted that if an icon is rotated after it has
already been used, every occurrence of that icon will also be changed to appear
the same as the edited version. If your drawing requires mote than one rotation
of a particular symbol, copy the primary symbol, select an unused symbol from
the palette and then paste the symbol into that unused position.
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symbol colors
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Once the primary symbol is in the new palette location it can then be edited or
rotated and used independently of the primary symbol. This same procedure
could be used to generate several views of any symbol, i.e. the primary plus two
90° rotations and a flip horizontal or vertical with the "flipped" views allowing
further rotation.

The Invert button creates a "negative” image of the symbol by making all black
pixels white and vice versa.

The Revert button allows you to change your mind if you want to start over
when editing an existing symbol. By clicking Revert, all editing is erased from
the time you selected the current symbol] for editing.

ForeGnd: and BackGnd: are pop-up menus to set the foreground and back-
ground colors of the symbols palette (not the individual symbol). Here again,
you have the option of setting the symbols palette to any of 8 foreground and 8
background colors for a potential total of 56 different combinations (using the
same color for both the foreground and background would not be a good
option) with each symbol. If you then include the 40 different symbols, you
have a total of 2,240 different symbol combinations (with a color monitor and/
or printer).

As with text and other graphic objects, once you have a symbol designed and
one or more placed on the drawing page, to re-use the same symbol attributes,
just click on it with the Option key down and the symbol tool in the tool box
will change to that symbol and color combination. You can then select the
symbol tool and place additional symbols of that type.

Not only will the symbol tool change to the colors of a selected "working"
symbol, the symbol palette will also change to the same cojor combination.
This allows the selection of associated symbols of that color.

A subilety in using background color with symbols should be mentioned. The
symbol background color is a mask of the foreground image and will "paint"
approximately two pixels around the foreground image. There is no mask for a
background image which means that if vou Invert the image, where the fore-
ground becomes the background, the background will become a solid square,

o

Symbol Background mask Inverted background
(color only)



changing a
symbol's color

Foreond: [T

BackGnd:| White

Red
breen

Cyan "
Magenta

Yellow

Using colors
with symbols

Once a symbol has been colored, changing its color requires a specific se-
quence of operations. To change a symbol's color:

= Change the symba! palette colors by using the Symbol Editor or by
clicking on another symbol of the desired color combination with the
Option key held down.

+ Selsct the symbol to be changed.
»  Open the symbol palette from the Symbol menu.

« Click on the symbol palette’s icon that is currently bordered by a
heavy line (your selected symbol).

« Click Done.

Your symbol has now been converted to the new color(s).

Using color, whether it is with symbols or graphic objects, should be done with
some thought as to those who might be working with your Filevision file and
what kind of Macintosh hardware they will be using.

All background coloss will be automatically converted to white (no color) if
your file is run on a black and white monitor. This is obviously necessary as a
colored background and a colored foreground would combine to produce a
solid black object on a black and white monitor.

If you or others will be using your file on a black and white monitor, be sure
that you don't design symbols or objects with background colors that are
essential to the recognition of different object meanings.

/’
DESIGN TEP:

sion lines.
.

In illustrating architectural or
mechanical drawings, try -.L — | ul] A 12in
designing symbol arrows to
attach to the ends of dimen- T —|| = <

— 48 —
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saving your Filevision allows you to save your newly created symbols (the full palette) to
symbols for use the Scrapbook for use in other files. You can save as many palettes as the
Scrapbook will hold. These can then be used to replace the symbols in your

in other files .
current file.

You can only use up to 40 symbols at one time and if you change
symbol palettes after you have used symbols from the original palette,
any changes in the new symbol palette will be reflected in those same
positions. For instance, if the upper left palette symbol was the stick
man symbol, if you change palettes and the stick man is replaced with
some other symbol, every occurrence of the stick man that had been
used on your drawing would change to the new symbaol.

DESIGN TIP:

If you find that you need
more than the 40 symbols
provided in Filevision, any
of several symbol fonts
can be used. Carta pro-
vides cartographic sym-
bols if you are developing
various maps. Symbol,
Mobil and Cairo are com-
mon symbol fonts that are
supplied with the Laser-
Writer.

Color combinations of symbols are not included in the 40 symbol re-
striction; however, any symbols with defined colors which are replaced
with the new palette's symbols will retain the same old color patterns.
If the old stick man symbol had a foreground color of red and a
background color of yellow, any symbol that replaces the stick man
will have a foreground of red and a background of yellow.

A font editor, available
from most dealers, would
allow you to develop your
own special symbol fonts
for most any purpose.

To copy the current symbol palette to the Scrapbook:

«  Access the Symbaol Editor by way of the Symbols menu or
by double-clicking on the symbol tool.

e

* Hold the Option key down and select Copy from the Edit menu.

This will place the symbol palette image in the Clipboard for copying into the
Scrapbook or directly into a new Filevision file if you don't intend to archive the
palette.

«  From the Apple menu (),
select Scrapbook.

Fileyision® SYMBOL PALETTE If Scrapbook is not in your desk
Fromfile: Special Symiols 1 accessories, you will have to install it
with Font/DA Mover (See your
Macintosh manual).

< After the Scrapbook opens,
select Paste from the Edit
menu.

EH@EEEE%

2]
-]
[e]
o]
(=]
]

The symbol palette will be copied to
the Scrapbook which will be indicated
by the message to the left.

FvaY, TEXT

[#][+]
(3] (a]
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Notice that the identification used to announce where the symbols were created
is the file name of that file. In the example, the file was purposely named
Special Symbols 1 so that a more specific identification could be provided. The
file could have been named Cartographic if you were developing a set of
mapping symbols just te keep archived in the Scrapbook.

Normally, you won't have the option to create the Scrapbook symbol archive
under an identifiable name and you will have to accept what ever your
Filevision work file was named when you developed those special symbols.

load a symbol
palette from the
Scrapbook

DESIGN TIP:

Another method to pro-
vide an unlimited number
of symbols for use in your
tile would be to create a
separate Type for that
purpose. Standard
symbols can be stored in
any of the possible 255
fields per record and
several records can be
used. If yvour need is for
non-standard symbols,
create them on the
drawing page or in
anocther drawing program
and store them in the
same way.

To change vour current symbol palette to one which has been previously saved
in the Scrapbook, reverse the procedure for copying to the Scrapbook:

Bring up the Symbeol Editor by double-clicking on the symbol tool or
from the Symbels menu.

From the Apple menu (#), select Scrapbook.

Find the palette that you want to replace the current palette with.

Select Copy from the Edit menu.

Close the Scrapbook from the File menu or by clicking the close

box.

+  Select Paste from the Edit menu.

The following alert dialog will be displayed warning that the paste
cannot be undone:

A

Pasting will replace the current Symhol Palette

with the one on the Clipboard.

You will not be able to undo this action.

(Fore )

+ Click the Paste button.

The Scrapbock palette is now transferred into your current file.
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The line tool
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The line tool is the basic drawing tool for drawing straight lines. However, the
line can be more than just a straight line. Tt can be any width from 1 pixel (point
in printers measure) to 14 pixels. It can be any of 8 colors (including gray) or it
can be white. It can also be set to no line at all (——1).

+ Todraw a straight line, select the line too! from the toolbox.
B

*

+ Choose a line width and line color from the tool box pop-up menus.

As soon as you move the pointer off of the tool box and over the drawing page,
it will change to an open crosshair cursor ({¥). After selecting any drawing tool
the pointer will change to the crosshair.

= Press the mouse button where you want the line to start.

* Holding the mouse button down, drag to an end point and release
the button.

As soon as you release the mouse button, your drawing cursor will return to a
pointer tool and the line will remain selected. This is to allow you to make any
fine adjustments to the position of the line after you have drawn it.

DESIGN TIP:

To draw several lines, symbols or graphic objects without returning to the
pointer ool each time you finish an object, hold the Shift key down
before selecting the drawing or symbol tool and continue to hold the Shift
key until you are finished .

S

™ To move the line, click anywhere on the line and while holding the
mouse button down, drag the line to its final position. To restrict the
movement to a horizontal or vertical plane, hold the Option key down
before "grabbing" the line.

To change the length of the line, click on either of the two end handles
and drag to the new length. If the line was constrained when first

A drawn and you wish to retain that constraint, be sure to hold the option

key down before clicking on the end handle.

120
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drawing
constrained
lines

To constrain the line to horizontal, vertical or 45° angles, hold the Option key
down before you start to draw the line. You can also turn alignment on by
selecting Snap to Alignment from the Options menu to constrain lines. Set
your alignment value in the Grid & Rulers... dialog (Edit menu) to control
angular lines,

You can use either the line tool or the polygon tool to draw straight lines. If
you use the polygon tool for straight lines, double-click the mouse button at the
end of the line to be drawn, {See polygon tool below.)

DESIGN TIP:
To create precise width double lines, select a line width of three pixels
or more and draw the first line. While the line is still selected, copy it
using Copy from the Edit menu or Command-C. Then paste the copy
back to the drawing using Paste from the Edit menu or Command-V.
Reduce the copied line by 2 pixels (select a line width from the lines
pop-up menu 2 pixels smaller). Change the color of the copied line to
white and move over the original black line.

A

The polygon tool

The polygon tool is used primarily to draw shapes with straight sides. The
polygon is automatically filled with the current shade unless you leave one side
open.

= Todraw a polygon, select the
polygon tool from the tool box:

+ Choose a line width and line color from the tool box pop-up menus.

«  Choose the fill shade from the Shades menu, unless you're drawing
an open polygon.

s Click the mouse button where you want to begin the polygon.

« Draw each side by clicking once at each change of direction (to
create an anchor point).

It is not necessary to hold the mouse button down between points as the line
will be automatically drawn between mouse clicks. If you do attempt to draw
the line while holding the mouse button, the line will end as soon as you
release the button and attempt a change direction with another mouse click,
You will be returned to the pointer tool in this case, without finishing your

polygon.
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To finish the polygon, do one of these two things:
«  Click twice without moving the cursor,

or

»  Click the starting point to close the shape.

~
DESIGN TIP:

Besides drawing polygons and straight lines, the polygon tool is a good choice
for freehand lines for those that have trouble controlling the freehand tool.
Using the polygon tool for freehand lines works much the same as "connect-
the-dots" type drawings. By clicking frequently while drawing, a precision
freehand can be achieved. NOTE: You must move more than 2 pixels before
clicking or you will end the line.

limiting line and
polygon angles

The
freehand tool

122 Filevision IV

You can limit the line and polygon tools to drawing lines with only 07, 45°, or
90° angles.

*  Hold down the Option key while using the polygon tool.

You can also limit or constrain your angles by turning on Snap to Alignment
from the Options menu.

The freehand tool has a singular use for "sketching". This could be compared to
using a pencil to doodle with.

»  Select the freehand drawing
tool from the toolbox:

» Choose a line width and line color from the tool box pop-up menus.
*  Hold down the mouse button and draw.
« Release the mouse button when you're finished drawing.

You can adjust the lines shape by choosing Reshape from the Edit menu; see
page 131, reshaping, for details.



Squares and .
rectangles

Edit Round Rect
Corners

Edit Round Rect Corners

Select one of the two rectangle tools from the toolbox: (Standard or
rounded carner)

E=

Choose a line width and color from the tool box pop-up menus.

Choose a fill shade from the Shades menu.
Move the crosshair to where you want the corner.

While holding down the mouse button, drag the mouse to the oppo-
site corner.

Release the mouse button when you're satisfied with the square or
rectangle.

If you want to draw a square, hold down the Option key while
drawing the rectangle.

If you want to adjust the radius of the corners on a rounded rectangle
before you begin to draw, double-click on the rounded rectangle tool.

This will bring up the Edit Round Rect Corners dialog box. By
then adjusting the thumb slides on the scroll bars (either by dragging
or with the scroll arrows) you will be able to adjust the corner radii,

The corner adjustment has a wide range of radii from a very "tight"
radius to an object that looks very much like an oval. You can also
set the adjustment non proportionally by making the horizental
value differ from the vertical value. This results in a graphic that
resembles a "drum”.

normal round rect oval round rect drum round rect

T —————

Rounded Rectangles
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TECHNICAL NOTE:

The full oval and drum shapes can't be interpreted

by PostScript printers using the current version of
the LaserWriter driver (6.0.2) and will appear as
normal rounded rectangles when printed on a oval round rect

drum round rect

LaserWriter. They will print correctly on Quick-
Draw printers such as the ImageWriter. Maximum

\rounding on the LaserWriter results in a half circle,

To adjust the corners on an existing rounded rectangle:

Circles and .
ovals

124 Filevision IV

Select the rounded rectangle to be adjusted.
Select Rounded Corners from the Options menu.

Adjust the Edit Round Rect Corners dialog by using the horizontal
and/or vertical slide bars.

Click Done.

Select the oval too! from the toolbox:

S

Choose a line width and line color from the tool box pop-up menus.
Choose a fill shade from the Shades menu.
Move the crosshair cursor to a starting location.

While holding doewn the mouse hutton, drag the mouse until the
object is the size you want.

Release the mouse button when you're satisfied.

If you want to draw a circle rather than an oval, hold down the Option
key while drawing the circle.




Arcs »  Select the arc tool from the toolbox:

R

-y

eliptical arc +  Choose a line width and line color from the tool box pop-up menu.

» Choose afill shade from the Shades menu.

+ Move the pointer to a starting location.

, bttt *  While helding down the mouse button, drag the mouse until it's the
circle arc (Option key) size and shape you want.

+ Release the mouse button when you're satisfied.

= It you want to draw an arc based on a circle (a pie slice}, hold down
the Option key while drawing the arc.

circle arc reshaped A constrained arc drawn holding the Option key will result in a full quadrant of
to a pie slice arc the circle being drawn. If you then want to adjust it to a smaller or larger "pie
slice”, use Reshape from the Edit menu ( £»38R Shift-Command-R) to change
the angle of the arc. This angle can be Reshaped to a full 360° circle.

DESIGN TIP:

To create a pie chart, first draw the circle arc and then Reshape it to a full circle. With the full circle
arc selected, copy it and then paste back a copy. Change the shade for the second arc and rcpeat this
step as many times as there are pie slices. Move all of the full circle arcs to overlap and then using
Reshape again, adjust each pie slice to its final size when the new circle comes into view. This same
sequence can be used with an oval arc for a 3D pie chart affect.

N -/
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The
Shades palette

)
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The Shades palette comes with 40 shades. You can change 38 of them using
the Shade Editor.

None and Glass have special properties. None means the shape won't be
filled and the outline is the only selectable part. None is "transparent”, of
course, 5o if you draw a rectangle using None as its shade, only the sides will
be drawn.

Glass is transparent but selectable. If you draw a pie slice using Glass as its
shade, for example, you'll be able to select it by clicking the inside of the slice,
even though it's transparent.

None and Glass can't be edited. If you can't bring up the Shades Editor, it is
probably due to either the None or Glass shades currently being selected.

The Shades palette can be shown by pulling down the Shades menu. The
Shade Editor can also be accessed by double-clicking on the Shade preview
box in the tool box or by selecting "Editor..." from the Shades menu. A shade
can be both selected or edited from the Shade Editor.

If your drawing already has shaded objects and you would like to use one of the
types of shades already being used, click on the drawing page object with that
shade while holding down the Option key and the palette shade will change to
match automatically.

The
Shades Editor

126 Filevision IV

F N

ForeGnd:; |Red I
BackGnd: _

Whenever you need to modify existing shades or create new shades, use the
Shade Editor. As mentioned previously, the Shade Editor can be accessed by
either double-clicking on the Shade preview rectangle in the tool box or by
selecting Editor... from the Shades menu palette.



shade rotation

+ Doubie-click the Shade rectangle on the tocl box.

The Shade Editor is displayed (previous page). Besides the full palette of
shades, the editor has an edit box, other buttons and pop-up menu color
options.

rotate 90° T rolate 90°
counter clockwise —[ hd '@w clockwise
mEERaEn
% 4 (- 41— siide symbol
]
+ a

flip horizontal ﬁ' -~ |ﬁ flip vertical

ForeGnd: [Red | symbol color
. Op-up Menu
BackGnd; [Fellow | P
return to original _

swap background
before editing ——_Revert ] [lovert | and foreground

The editing box is designed to allow each magnified pixel (square) to be turned
on (black) or to be tumed off (white) by clicking on it with the cross hair (+)
cursor. This operates much the same as "fat bits" in some paint programs.

The triangle shaped arrow heads to each side and the top and bottom will move
the current group of pixels one pixel in the direction of the arrow each time the
arrow is clicked. This can be used to create some interesting affects with the
shade being edited.

The small icons in the four corners allow vou to rotate or flip the shade to the
indicated orientation. It should be noted that if an shade is changed or rotated
after it has already been used, every occurrence of that shade will also be
similarly changed. If your drawing requires more than one version of a particu-
lar shade, copy the primary shade, select an unused shade from the palette and
then paste the shade into that unused position where you can then edit it.

Once the primary shade is in the new palette tocation it can then be rotated and
used independently of the primary shade. This same procedure could be used
to generate several views of any shade, i.e. the primary plus two 90° rotations
and a flip horizontal or vertical with the "flipped" views allowing further rota-
tion.
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shade colors

The Invert button creates a "negative” image of the shade by making all black
pixels white and vice versa,

The Revert button allows you to change your mind if vou want to start over
when editing an existing Shade. By clicking Revert, all editing is erased from
the time you selected the current shade for editing.

ForeGnd: and BackGnd: are pop-up menus to set the foreground and back-
ground cotors of the Shades palette (not the individual shade). Here again, you
have the option of setting the Shades palette to any of 8 foreground and 8
background colors for a potential total of 56 different combinations (using the
same color for both the foreground and background would not be a good
option) with each shade. If you then include the 38 different shades, you have
a total of 2,128 different shade combinations (with a color monitor and/or
printer). '

As with text and other graphic objects, once you have a shade designed and
one or more placed on the drawing page, to re-use the same shade attributes,
just click on it with the Option key down and the Shade preview recrangle in
the tool box will change to that shade and color combination. You can then
select a drawing tool and draw additional shaded objects of that type.

Not only will the Shade rectangle change to the colors of a selected "working"
shade, the Shade palette will also change to the same color combination. This
allows the selection of associated shade patterns of that color.

-
DESIGN TIP:

4 pt blue line

N

If you are designing a complex drawing and plan to use several different symbols, symbol colors,
shade patterns, shade colors, line widths and line colors, create a palette on your drawing page.
Once you have the palette created, any time you want to draw a new object with existing patterns,
shade colors, line widths or line colors, all you have to do is click on the existing palette object while
holding the Option key down and all of the attributes of that object are automatically loaded.

Shade/line patterns Pattern Blu FG/Yel BG Sym GrF/Yel B

B

changing a
shade's colors

128 Filevision v

Once a shade has been colored, changing its color requires a specific sequence
of operations. To change a shade's color:

+ Change the shade palette colars by using the Shade Editor or by
clicking on another shade of the desired color combination with the
Option key held down.



oo T
BackGna:| White

Red
Green
Cyan K

Magenta

Yellow

using colors
with shades

saving your
shades for use
in other files

*  Select the shaded object to be changed.
*  Open the shade palette from the Shades menu.

*  Click on the shade paiette's icon that is currently bordered by a
heavy line (your selected shade pattern).

* Click Done.

Your shaded object has now been converted to the new color(s).

Using color should be done with some thought as to those who might be
working with your Filevision file and what kind of Macintosh hardware they will
be using.

All background colors will be automatically converted to white (no color) if
your file is run on a black and white monitor. This is obviously necessary as a
colored background and a colored foreground would combine to produce a
solid black object on a black and white monitor.

If you or others will be using your file on a black and white monitor, be sure
that you don't design shades or objects with background colors that are essen-
tial to the recognition of different object meanings.

Filevision allows you to save your newly created shades (the full palette) to the
Scrapbook for use in other files. You can save as many palettes as the Scrap-
book will hold. These can then be used to replace the shades in your current
file.

You can only use up to 40 shades at one time and if vou change Shade palettes
after you have used shades from the original palette, any changes in the new
Shade palette will be reflected in those same positions.

Color combinations of shades are not included in the 40 shade restriction;
however, any shades with defined colors which are replaced with the new
palette's shade patterns will retain the same old color patterns. If the old brick
shaded object had a foreground color of red and a background color of yellow,
any shade pattern that replaces the brick shade will have a foreground of red
and a background of yellow.
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To copy the current Shade palette to the Scrapbook:

«  Access the Shade Editor by way of the Shades menhu or by double-
clicking on the Shade preview box.

+ Hold the Option key down and select Copy from the Edit menu.
This will place the Shade palette image in the Clipboard for copying into the
Scrapbook or directly into a new Filevision file if you don't intend to archive the

palette.

«  From the Apple menu (g ), select Scrapbook.

Scrapbook

#
Filevision®s |V SHADE PALETTE

Fromfile: Special Shades 1

FvSH, TEXT

If the $crapbook is not in your desk accessories, you will have to install it with
Font/DA Mover {See your Macintosh manual),

+  After the Scrapbook opens, select Paste from the Edit menu.

The Shade palette will be copied to the Scrapbook which will be indicated by
the message above.

Notice that the identification used o announce where the shades were created
is the file name of that file.

Normally, you won't have the option to create the Scrapbook shade archive
under an identifiable name and you will have to accept what ever your
Filevision work file was named when you developed those special shades.



load a shade To change your current Shade palette to one which has been previously saved
palette from the in the Scrapbook, reverse the procedure for copying to the Scrapbook:

Scrapbook »  Bring up the Shade Editor by double-clicking on the Shade preview

box or from the Shades menu.
+  From the Apple menu (§§ ), select Scrapbook.
+  Find the palette that you want to replace the current palette with.
- Select Copy from the Edit menu.

+ Close the Scrapbook from the File menu or by clicking the close
box.

+  Select Paste from the Edit menu.

The following alert dialog will be displayed warning that the paste cannot be
undone:

Pasting will replace the current Shade Palette
with the one on the Clipboard.

You will not be able 1o undo this action.

—_ =

+  Click the Paste button.

The Scrapbook palette is now transferred into your current file,

Reshaping Reshape, from the Edit menu, is used to modify lines, arcs, rectangies and
polygons. Obviously, if a rectangle or square is reshaped, it becomes a poly-
gon. A line can become almost anything.

To reshape, vou can use the existing or add "reshape handles" to an object, then
stretch or shrink the object using those handles. The handles are actually the
"anchor" points of the graphic's line and occur every time the line changes
direction. The line between the anchor points is like a "rubber band" and can
be stretched to any length.

In this example we're going to reshape a line into a star:
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Select the line tool and draw a horizontal line about 3" long.
Select the line.

Choose Reshape from the Edit menu.

Add reshape handles to the line = k
by clicking where you want
them. Add two to the line.

Pull down the right handle.

3
Pull down the left end so that it's i j
parallel to the botiom of the "V"
A ¥
r—.l

Pull the top right edge down to
the bottom left edge and add a
reshape handle by clicking on
the middle of the bottom of the
triangle.

Pull up on the reshape handle
you just added to the bottom of

the triangle. Add three reshape
handles in the middle of the left ; It

side. Q



Bringing to
front and
sending to back

+ Repeat the process on the left /\

side: add three reshape handles

and pull the middle one out.
The star is now complete. You can fill it by selecting a shade from the Shades
menu; you can also change the style of the line around it by selecting a new line
width or line color from the tool box pop-up menus.

You can remove paints by dragging one point on top of another, a process
that's made easier when alignment is on.  You can turn on alignment temporar-
ily by holding down the Command key before you drag the point.

»  Click the pointer tool to end reshaping.

You can change the order in which graphics overlap with Bring to Front and
Send to Back from the Edit menu or by using the Command key chords <+ 36F
(Shift Command F) for Bring to Front and <*#B (Shift Command B) for Send to
Back.

«  Select a graphic object that's partly behind another object.

+  Choose Bring to Front from the Edit menu.
The object is now on top of the objects that concealed it.In fact, it's considered
to be the front most object in the file regardless of the Type that it belongs to
and which Type is the topmost drawing layer.
Send to Back works the opposite way. Try moving the object behind all other
objects by clicking the object and choosing Send to Back from the Edit menu.
The object is now the backmost object on the drawing page and is behind all
other objects of all other Types.
Bring to Front and Send to Back also work on:
¢ Several selected objects

*» Highlighted objects (if nothing else is selected)

« All objects of a Type (if no objects are selected or highlighted, all objects of
the current Type will be sent to the back or brought to the front).
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DESIGN TIP:

To create a "drop shadow box", first draw a rectangle and shade it white. While it is still selected,
copy and paste a second image of the rectangle and shade it black. While it is still selected, send it to
the back. You can now enter any text or graphics and your drop shadow box is done.

Drop Shadow
Highlight Box

Grouped Frequently you'll want several graphics to function together as a single object.
graphics That allows you to click on any of its parts to select the object as a whole. If

you group the parts of an office floor plan, for example, you can double-click
anywhere on the floor plan to get the record for the office.

You can only group graphics of the same type, and they can't have more than
one record among them. To move and stretch graphics of more than one Type
or with several records among them, use Gather.

Pop-ups are a variation on grouped graphics. A pop-up has only one visible
part until the pop-up is selected. When that part is selected, the rest of the pop-
up "pops up” into view. When the pop-up is deselected, it disappears except for
the part that was visible to begin with {called a button).

Often you don't need to group or gather graphics to perform an operation on
several of them at once. Highlighting and multiple selection can frequently do
the same thing with less effort. For instance, all you have to do to change the
fonts of several different text objects at once is to select them all at once, then
choose the new font from the Text menu.

Group You can combine graphics using Group so that they behave as if they were a
single object. Clicking any part of the grouped graphic will result in the appear-
ance of a single set of handles around all of them. If you need to group the
graphics temporarily for moving or stretching, use Gather. Both are available
from the Edit menu or by using the Command key chords 386 (Command-G)
for Group and <»3T (Shift Command-T) for Gather.
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- «  Select the graphics using Shift-click or by holding down the mouse
button and drawing a dotted rectangle {marquee) around them.

— - Choose Group from the Edit menu.

- .l—:l_|_|/._\ 1—:

Optica SLR

— If the graphics are of more than one type or have more than one record be-
tween them, Group will be unselectable.

— + Click elsewhere to deselect the group.

Now, anytime any of the objects in the group are selected, a single set of
— handles will appear around the whole group:

If only one of the graphics has a record conzaining data, that record becomes

- the group's record. If there is more than one record containing data among
those selected, you will not be able to group the objecis.
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Ungroup

Any grouped graphic can be ungrouped.

[ £ Fie MQpes Access Options Text Symbols Shades | «  Select the grouped graphic.
Er===== Undo %2 [Actual Size e8|
Cut %H »  Choose Ungroup from the Edit
Copy B menu. (Group and Ungroup
gf:;f ®U toggle the same position on the
Edit menu.)
Bring to Front  <%F
Send 1o Back C 6 If you group a graphicless record to one

Gather
&eshape

Ungroup #¥6

K

or more graphics, it will become disassoci-
ated from any of the graphics when the

Add Record

Guplicats Hedorg BY
Delete Records...

ungrouping takes place, and a dialog box
will warn you:

#®A

Grid & Rulers
fiaid Setup..

Preferences..

Ungrouping will resuit in a
recerd that has no graphic.

Ways to
select objects

Moving objects

Camara FJY: Optica SLA|
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You've already been introduced to the ways you can select objects with the
pointer tool. There are several other ways to select objects.

« The Prev and Next buttons select one object of the currently se-
lected Type at a time.

+  Find... or Find same (see page 225 for more details) selects one
object at a time.

« Adding an Info page record selects that record.

« Drawing an object selects that object.

Any selectable object can be moved.

Note: Selection is shown differently on symbols and text. Symbols are shown
within a black box, and text is shown in reverse.

e Ifit's text, press and hold down the mouse button on the text block,
and drag the text. Release the mouse button when you've put the text where
you want it.



moving multiple
objects of one

Type

moving a ext block
or text character

moving a text block
or text character

» Ifit's a symbol, press and hold down the mouse button on the symbol,
and drag the symbol. Release the mouse button when you've put the symbol
where you want it.

» Ifit's a shaded graphic, press and hold down the mouse button any-
where on the object except one of the outside handles. Hold down the mouse
button, and drag the object to its new location

SONE O

To move several objects at one time, first select the objects to be moved using
the marquee drag or shift click methods. If you wish to move objects of one
Type only, select the Type from the Types menu and Show Only These from
the Access menu.

After you have the "group" of objects all selected, gather them temporarily by
sclecting Gather from the Edit menu or by using <#3T (Shift Command T).
Gather can (must) also be used 1o temporarily "group” objects from different
Types for moving. Once the objects have been gathered, the combined group
will show one set of "handles".

Press and hold the mouse button down anywhere within the gathered group
except the outside handles. Drag to the new location and release the mouse
hutton. As soon as the mouse button has been released, the gathered objects
will ungather.

Notice that the objects disappear as soon as you press down on the mouse
button. The only remaining object is & rectangle about the size of the original
group of objects. This is known as the "hounding rectangle" and is provided to
give you a reference for positioning.
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The bounding rectangle is used any time there are more than five objects 1o be
moved at one time. If every object were to show during the move, each object
would have to be "re-painted" with each increment of the move. Obviously,
this could require a great deal of time if there were many complex objects to
move.

If you must have the objects showing during the move, there is a way 1o
accomplish this:

«  Press the Caps Lock key down before the move.

- o 3

) 5
O

This will show all of the objects as outlines which does allow for precise
placement over other existing objects. Be prepared for the move to take some
time as the outlines will be redrawing at each increment of the move.
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Trouble shooting
object selection
and moves

Stretching
graphics

Trouble shooting: Remember that Ignore/Activate on the Access menu and
Show selected graphic using: in the Preferences... dialog affect how
selection is shown.

If you select an object and nothing happens, you may have chosen o Ignore
objects that type; if 50, choose Activate on the Access menu to activate the
objects. Or you may have chosen that something hesides the handles show
selection for all objects in the file; choose Preferences... from the Edit menu
and select Handles under Show selected graphic using,

One of the most common problems in moving graphics belonging to several
different types is 1o forget that one of the Types has been set to Ignore from the
Access menu. Another is 1o forget 1o Show All Types from the Access menu
only to realize after the move that the objects in one or more Types is now out
of alignment with the moved ohjects.

You can stretch and shrink graphics other than symbols and text.
«  To stretch a graphic, select it so that handles appear on it.
+  Now move the pointer to any handle but the center one, hold down

the mouse button, and pull or push the handle. The object will
stretch or shrink accordingly:

[ % File fdit Types Rccess Dptions Tewt Symbols Shades |
Eﬂﬂ_ Stretch - Actual Size %@E‘

Bockground: (35 toial)
Prev)(Mext]linfo]li irk
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While it was mentioned above that graphics are the only objects that can be
stretched, there is a method to stretch symbols and text. This is accomplished
by first Exporting the text or symbol as a PICT and then Importing it back to
the drawing page. Once back, it can be handled as with any graphic object.
The stretched text will print on a LaserWriter correctly; however, the symbol will
appear as a magnified group of square blocks. (See Importing and Exporting
Graphics, page 151.)

e _ ™

6

I g

|

Unfortunately, your Macintosh monitor can't reproduce the high resolution
PostScript image and both the letters and the symbol will appear as a series of
squares {magnified pixels).

oo —

proportional Objects are usually stretched without regard to the proportion between horizon-
and square tal and vertical stretching (and shrinking).
stretch

*  You can change that by holding down Shift and the Option keys
while stretching. The ratio of horizontal to vertical stretch remains
proportional.

»  You can also hold down the Option key by its self while stretching.
The object is stretched and shrunk on a square plane.
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Gather--
moving and
stretching
graphics of
mixed types

Gather is used to hold several graphics together briefly for moving or stretch-
ing. To group graphics of different types, or graphics with more than one
record among them, use Gather to unite them temporarily to be moved or
stretched together.

« To gather graphics, select them using Shift-click or by helding down
the mouse button and drawing a dotted rectangle (marquee) around
them.

(For more information on selecting several objects at once, read the sections
beginning with "selecting several neighboring objects with the pointer”, page
110

[ # File Edit Types HAccess Oplions Test Symbols Shades

ECI = Biplane - Actual Size
|

B Engine Oil

§ wo-a0 - . -

- Dry Graphite - = L

-, Grease Gun

@ Hend Pack Bipkene Lubricailon POk

& Luk Sehodule

Mixed: (50 selected’

[__[Prev]Mext)(infolCradid] T

= Choose Gather from the Edit menu.

Fight handles appear around the objects (plus one in the center) as if they were
one large object.

In this example, we're going to move the gathered biplane graphics as a single
unit so that we can center the Legend.

§ wo0
W Dry Graphite
=, Grease Gun
¥ Hard Pack

+  Move them by dragging any-
where except by one of the
outside handles.

»  Click the pointer tool to deselect
the objects.

mm‘fm . Each of the objects now has its own set of
B plalile] on Polate

& Lo Sehedle handles; the gathered objects have re-

Hixed. <50 gathered?

gained their individual identities.
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While you have a series of mixed Type graphics gathered, you can also do
proportional or distorted stretches. The following illustration shows the same
biplane stretched to fill the top part of the screen.

[ % File Edit Types Access Options Text Symbols Shades &

E==———————=——--————" fiplane - Actual Size ceee=u=—-—- == T
& P

Engine i)
i wo-40
W= [y Graphite
wm-, Greage Gun
'v Hand Pack

Biplkane Lubricalion Polnte
& Lub Sehedule

Lube Type:

This stretch was done proportionally by first moving the gathered objects to the
upper left corner of the screen and while holding the Shift and Option keys,
dragging the lower right corner handle to its new position.

Ungather Any gathered graphics can be easily ungathered.

* Choose Ungather from the Edit menu.

Deselecting also ungathers them.
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5. Pop-ups

Pop-ups are grouped graphics having only a single part of the group normally
visible. When that part of the graphic (called a button) is clicked, the rest of the
group appears. When the pop-up is deselected, everything but the button
disappears. Pop-ups provide a way to show greater detail about any object
without leaving the drawing page.

Pop-ups can be a graphic, text, symbol or combinations of all. Consider the
pop-up as another layer of the drawing page which is normally hidden from
view. You can have as many pop-ups as vou require and they can be associ-
ated with any object (button? in any Tvpe. (The Tyvpe must be set to Active
from the Access menu.)

| #% File Edit Types Access Options Texl Symbols Shades
EGE Califarnia - Actuai Size BVFFfe0eF——oc——1]

h SanLeandro

Pop—ups: Son Francisco Bayl

| [Prev)Mext)(info] isi)K7]

Under normal circumstances, your drawing page will have many different
objects that will make it difficult to work on the pop-up. The easiest way to
create a pop-up is to select the object that will become the button and clear the
rest of the drawing page by selecting Show Only These from the Access
menu. (See Hiding and Showing objects, page 149.)
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Now that you have a4 clean drawing page with only the pop-up button showing,

you can create your pop-up object or group of objects.

The following example is a pop-up of a detailed view of San Francisco bay. It
could contain highways, points of interest, camp grounds or anything required

to enhance your file.

Acress

Options Text Symbois Shades

EO==— undo

%82 lifornia - Actual Size

Cut ®xH
Copy ®r
Paste ®0
Elear

Bring to Front  <-3%F
Send to Back
ngroup
Lather
Reshape

Richmond Concard

Add Record A
Dupinate Horprg &Y
Delete Records...

Preferences... *E
6rid & Rulers...
Fiald Solup...

Pop—ups: San/F/runeisco Bayl

[EreviMekt](infolli is]

hutton - - -— -

= Tocreate a pop-up, select the
graphic or group to act as the
button and choose Send to
Back from the Edit menu.

= After you finish the pop-up
ilustration, with all objects se-
lected other than the button,
choose Bring to Front from the
Edit menu.
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pop-up objects

button object

+ Now select the button along with the object(s) that will make up the
body using Shift-click or by holding down the mouse button and
drawing a dotted rectangle (marquee) around all of them.

wi Leandmm

(For more information on selecting several objects at once, read the sections
beginning with "selecting several neighboring objects with the pointer”, page

109.3

*  While holding down the Command {3 } and Shift keys, choose
Group from the Edit menu.

It won't work if you hold down the Command and Shift keys after yvou choose
Group from the Edit menu,

+  While the grouped pop-up is still selected, choose Bring to Front
from the Edit menu.

This will make sure that you are able to select the pop-up button and that some
other glass object is not resting over it.

«  Click the pointer tool to deselect the pop-up, and everything but the
button will disappear.
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1f only one of the graphics has a record, that record becomes the pop-up's
record. If there is more than one record among those selected, you will not be
able to group the objects into a pop-up.

The body of a pop-up is unselectable, and you can't make it into the buiton for

another pop-up. Also, none of the objects within a pop-up are selectable which
prevents their use as buttons for other pop-ups.

restoring a Any pop-up can be restored to its individual parts quite easily.
Oop-u
pop-p + Select the pop-up by clicking its button.

+  Choose Ungroup from the Edit menu,

moving a When yvou move the button of a pop-up, the body stays behind.

pop-up »  To move the button and the body of a pop-up at the same time, click

the button.
The body of the pop-up appears.
= Choose Ungroup from the Edit menu.
« Choose Gather from the Edit menu.
A single set of handles appears around the objects.

»  With the mouse down in any area of the gathered graphics except
the outside handles, drag the graphics where you want them.

»  While holding down the Command (38 ) and Shift keys, choose
Group from the Edit menu to restore the pop-up.
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6. Hiding and Showing Objects

Hiding and Showing objects on the drawing page is closely associated with
the database portion of Filevision. All of the Hide/Show functions are selected
{rom the Access menu, which is tied closely to the Types menu. In fact, the
first item on the Access menu is the Type that is currently selected.

In the following exampie, the Jet Aircraft was drawn with its fusclage parts
nstacked" which allows us to "peel” away clements of the aireraft and display
only those that we want to view,

"Skin“s:

[ # File Edit Types RAecess Optiens Text Symbols Shades

Sort By... E[Je====——=——=—— et Aircraft - Actual Size
Find... ®F

fippd Smemy

Highlight... %H

Highlight Selected %L

4{+3A

Highlight All
Hide Selected
Show B#lected
Show Only These
lgnore

Show Al Types
L uneal Highlighiing

#d - FHE ULTIMATE IN JET POFERED SPORT AIRCRAFT -

Previous Record 3P
Next Record LN
Info Page €1
Drawing Page H
{ink Eef

Skin: Fuselage Covaring|

Prev|[ttext)(Info) i ink

Notice that the fuselage covering is selected and the information area identifies
the object and the Type. If the Types menu were opened, the Type Skin
would be checked. This, in turn, controls what the Access menu will operate
on.

+  Open the Access menu. The first name in the menu surrounded by
quotes is the current Type selected.

«  With the object to be hidden selected, choose Hide Selected from
the Access menu.
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As soon as you release the mouse button, the following change has occurred to
the drawing:

[ & File Edit Types Access Oplions Texut Symbols Shades |
E[j=====—===x= et Aircrafl - Aclual Size =—————|

- FHE UITIMATE IN JET POWEREDR SPORT ATIRCRAFT ~

Skin: (0 of 1 visible>
| [PreviMext](info) Ein)[]

The skin has been "peeled” from the fuselage.

By using the various options from the Access menu along with the selection of

specific objects and/or Types, a view of any one or group of objects is possible.

The Access menu Hide/Show selections have the following basic functions:
If an object or objects are selected -

+ Hide Selected will hide the currently selected object(s).

* Show Selected will show a selected object that was previously hidden.
(Clicking the Prev/Next buttons or Find. .. can also show a hidden object.)

» Show Only These will show only the selected object(s) and will hide all
other objects.

If no objects are selected -

* Hide All will hide all objects of the currently selected Type.

e Show All will show all objects of the currenily selected Type.

¢ Show Only These will show all objects of the currently selected Type and
will hide all objects of all other Types.

Show All Types will always show every object that has been created.



Change Layout... |

Delete Type
Rdd Type...

Fuselage
Wing

Canopy
Rudder
Landing Gear
Intake
Cockpit
Landing Gear
Control Link
Engine

Fuel Tank
Background
Skin

creating a blank
drawing page

Hiding and

Showing some
or all objects

of a Type

If you wanted to show the aircraft frame and fuselage without showing any
other objects:

+  Select Frame from the Types menu.

+  Select Show Only These from the Access menu.
+  Select Fuselage from the Types menu.

«  Select Show All from the Access menu.

The result would be the following:

It is easy to erase (hide) all objects from the drawing page in two steps.

. Select any object and then Show Only These from the Access
menu.

Only the object selected is showing.

+  Return immediately to the Access menu and choose Hide Selected.
The result is a blank page.
You can hide some or all ohjects of the current Type. Hiding causes the objects
of that type to disappear from the drawing page, but they remain in the file and

you'll still see their records on the Info page.

You can also select hidden objects by using the Next, and Prev buttons, or by
using Find... or Highlight....

«  Choose the Type of objects you want to hide from the Types menu.
« Choose Hide All from the Access menu.
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The objects disappear. You can make them reappear anytime.,

+ To reveal any hidden objects, choose the Type you want shown from
the Types menu, then choose Show All from the Access menu.

Hide All will become Hide Selected if any objects are selected and will work
accordingly. Hiding and Showing are overridden by Highlighting.

showing only You can hide all of the objects in the file except those of one Type with Show
one Type Only These.

» Choose the Type you want shown from the Types menu.

+  Choose Show Only These from the Access menu.

All the objects except those of the selected Type disappear.

r";_File Edit Tgpeslim&_ﬁt‘ions Text Symbois Shades T

ER———— N LT TR ze
Sort By...
Find... ®F
fiad Saing 4%
Highlight... 3H
ftightight Selactrd 5 MOY USGS MULTICOLOR
Highlight Rl <»36H MAPS ARE MADE
Hide RAll £ 9%H (olick here)
Show Rl

i Show Only These
Ignore
Show Al Types
faonal Higntighting  3d

Previous Record <r3EP
Next Becord LN
.| Info Page £
3| Drawing Page ®D

7 F!!é 'Edil Types Access Options Fexnt Symbols Shades
[y US6$ Color Maps - Aclual Size EEeme—r s IS

HOW USGS MULTICOLOR
MAPS ARE MADE
{click here)
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7. Importing and Exporting Graphics

Importing
graphics

The ability to import and export graphics created either by Filevision or another
drawing program provides considerable flexibility in creating a Filevision file.
Graphics can be imported directly from a separate graphic file into the drawing
page, an Info page field or a Print Layout field.

To import a graphic:

«  First decide if the graphic is to be imported to the drawing page, the
Info page or Print Layout and select that page.

Importing to the drawing page requires no special considerations.

= Inthe Info page or Print Layout, provide a field for the graphic to be
imported to. (See Creating A Type in the next section, page 163 or
Printing Reports, Forms & Labels, page 240.)

MgERE ., RN
EEETE TN =i
Close Import/Edport
Sape S
fave fis...

Bebarn o, ®;

Import Graphics...
Export Graphics...
Import/Exdport Text...

Page Setup...

Page Size...

Print Page ey
Print Records... %P

Quit ®0

The following applies to importing either to the drawing page or the Info page:

« From the File menu, select Import Graphics....
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7. Importing and Exporting__g_@_ph__ics

The ability to import and export graphics created either by Filevision or another
drawing program provides considerable tlexibility in creating a Filevision file.
Graphics can be imported directly from a separate graphic file into the drawing
page, an Info page field or a Print Layout field.

Importing To import a graphic:

graphics
« First decide if the graphic is to be imported to the drawing page, the
Info page or Print Layout and select that page.

Importing to the drawing page requires no special considerations.
» Inthe Info page or Print Layout, provide a field for the graphic to be

imported to. (See Creating A Type in the next section, page 163 or
Printing Reports, Forms & Labels, page 240.)

MR, BN
Bneva.., R
Close lmport/Export
Save ®S
Save As...

Beiurn b, O

Import Graphics...
Export Graphics...
Import/Export Text...

Page Setup...

Page Size...

Print Page #u
Print Records... 3P

Quit %0

The following applies to importing either to the drawing page or the Info page:

« From the File menu, select Import Graphics....
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The Import dialog will be displayed.

<5 Map PIETs
0O Change Type PICT [===p |} 111}
0 Combo Map PICT _
D Highlight PICT
D Income info PICT
D Report PICT m
: Import as:

PICT MacPaint

® < @ Single PICT

Qepst O Discrete Dbjects

Notice at the bottom of the dialog box that there are several radio button

options. The currently selected buttons are PICT and Import as: Single PICT.

« Select the type of graphic to be imported by clicking on the appropri-
ate radio button at the bottom of the dialog box.

If you select the PICT format, you will also have the option to Import it as a
single PICT or as discrete objects.

« Select the file to be imported and click the import button.

As soon as the file has been read from disk and is ready to be placed, the
pointer cursor will change to a right angle cursor with an arrow:

|\._

- Move the right angle cursor to the upper left corner of where you
want the graphic placed and click the mouse button.

The graphic flows onto the screen from where you positioned the right angle
cursor down and to the right. The graphic remains selected so that you can
adjust its position.

1If you have imporied a PICT and selected Import as: Discrete objects, each
of the objects contained in the PICT will be separated (ungathered) from the
original gathered image as soon as you deselect the image.



Exporting To export a Filevision graphic to a separate file:

graphics _ _ o
- Select the graphic or group of graphics to be exported by clicking on

it or selecting all objects to be exported.
»  Choose Export Graphics... from the File menu.

The following Export dialog will be displayed:

3 FreeHand Folder
o Fitewisian® = HBao
% Filpuistond i ’
& Frostand
D MucSESMnp FrasH e
SE & 3 Shoufreehamt |
0y SE i s Banireena.. 1
Sove fis: [ Export |
O PICT
@ EPSF

If you have an EPSF graphic selected to export, the option of exporting it either
as a PICT or as an EPSFE is provided. Non EPSF graphics can only be exported
as PICTs.

+  Enter a file name to export the graphic object(s} to and click the
Export button..

You can export graphics either from the drawing page, from an Info record or
Print Layout field. As soon as the graphic export has finished, you will be re-
turned to either the drawing page or the Info page depending on where you
selected the graphic to be exported from.
Graphic formats  Filevision imports three basic graphic formats:
PICT which is 2 MacDraw or object oriented type graphic,
MacPaint which is a bit mapped or pixel mapped graphic

and

EPSF which is an encapsulated PostScript format graphic.
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PICTs

QuickDraw
PICTs vs
PostScript
(EPSF)

TIFF graphics

154 Filevision [V

PICTs are the most common graphic format that you will be using in Filevision .
These graphics are interpreted by the Macintosh QuickDraw routines as a series
of individual objects {circles, squares, symbols, lines, text, etc.) that lend them-
selves to the basic operation of Filevision. Each individual object in a PICT can
be attached to an Info page record. This supports the basic Filevision function.

This discussion of QuickDraw PICT's versus PostScript EPSF only "scratches the
surface" but should be enough for a better understanding of the Import and
Export features and using these graphics int Filevision.

There are two basic methods that an object (text or graphic) is processed by the
Macintosh, with QuickDraw which is a function of the Macintosh operating
system or with PostScript which is used by high resolution devices such as the
LaserWriter for reproducing these same objects. Any object that is printed on a
Macintosh screen is created by QuickDraw. The ImageWriter and other dot
matrix type printers also rely on QuickDraw.

The best resolution that QuickDraw is capable of is 72 pixels (dots) per linear
inch (5,184 per square inch) and regardiess of the device that QuickDraw is
sending to, the output will not exceed 72 dpi (dots per inch). On the other
hand, PostScripi is considered to be device independent and the resolution of
PostScript output is determined by the device that is doing the printing. This
also assumes that the printing device has a PostScript interpreter (as does the
LaserWriter).

When sending object (squares, circles, shapes, etc as opposed to bit mapped)
information to a PostScript type of printer or other device, PostScript interprets
QuickDraw commands and creates high resolution output. When sending Post-
Script darta to a QuickDraw device such as your monitor, QuickDraw relies on a
PICT that should have been created when the PostScript image was first drawn.
If that PICT was not created, QuickDraw would have nothing to display except
the text code that makes up the PostScript instructions.

The most common PostScript output will be seen with the LaserWriter which
vields a 300 dpi resolution. That same PostScript object can be output by other
higher resolution devices that are capable of greater than 2,500 dpi.

The PostScript graphics used by Filevision are of the Encapsulated PostScript
Format (EPSF) type which is a method of storing these PostScript generated
graphics as separate "reusable" images. Most PostScript illustration programs
and scanners use EPSF in saving the information generated.

TIFF (Tag Indexed File Formar) is another method for saving the same image.
Filevision does not support TIFF graphics.
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The following swallowtail butterflies illustrate the basic difference between
QuickDraw and PostScript output:

ImageWriter & Screen
output at 72 dpi

High Resolution
PostScript output

The third type of graphic image that can be imported directly from a separate
file is a MacPaint format. MacPaint type graphics are bit mapped (aka pixel
mapped) which can't be interpreted as discrete ohjects and are essentially
procduced by turning pixels on and off, one pixel at a time and one row at a time
over the entire 8 x 10 drawing page. Reproduction of MacPaint type graphics is
by printing each pixel as it appears on your screen.

In general, graphics created in Filevision will he similar to object oriented
QuickDraw version 1 PICTs. Version 1 pictures support a palette of eight basic
colors in Filevision. Objects created in Filevision will actually be created in
Filevision's PicB formar which can be converted o the version 1 PICT when
exported for use with other Draw type programs. The PicB format includes
other information to accommodate the object to record association of Filevision.

The Macintosh 1 (and subsequent models) will support an enhanced type of
color and gray scale video display know as Color QuickDraw or version 2 color.
Version 2 PICTs support a palette of 256 colors or gray shades as of this writing.
This will increase as hardware devices are developed to use the added colors
and gray shades.
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The main difference between version 1 (QuickDraw) and version 2 (Color
QuickDraw) graphics is in the way they are represented by the Macintosh II'z
video boards and monitors. While the screen display of version 1 graphics is in
the form of bit mapped images (72 dpi), version 2 provides what is known as
pixel mapped images. Pixel mapped images are in the same 72 dpi resolution
with the exception that each pixel is provided with much more information.

Whereas version 1 supplies information to each pixel for the display of eight
basic colors, version 2 is designed to supply information for up to 256 colors
and gray shades (2% per pixel. This could change in the future as hardware is
enhanced. QuickDraw is designed to handle a potential of 2* colors and gray
shades per pixel.

Most scanners available for use with the Macintosh are able to scan in various
degrees of "gray scale". These images, when imported in Filevision (while
being used with a Macintosh 1I), will be displayed in gray scales that result in a
photographic quality image. The LaserWriter printer is also capable of printing
a fairly accurate representation of these gray scale images.

While Filevision cannot create version 2 pictures, it can import these images and
will usually display them in their original colors or gray scale on a Macintosh II.
This depends on how the version 2 pictures were stored by the program that
was used to create them. Unfortunately, as of this writing there has been no
accepted standard developed to store all version 2 pictures in the same way.

Even though Filevision will display version 2 pictures created by another pro-
gram in the full palette of 256 colors, any version 2 picture imported into
Filevision will be converted to the version 1 format as a single PICT object.
Importing a version 2 picture will evoke the following alert dialog:

0 This Picture is a version 2 PiCT.

Only version 1 PICTs can be decoded by Fitevision 1Y,
This PICT will be imported as a single ob ject, not
as Filevision IV discrete objects.
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All graphic objects used in Filevision are created in, or must be converted to the
Filevision format which is known as PicB. This is necessary due to the nature of
Filevision as an object oriented database. In Filevision, all objects entered on
the drawing page must carry additional information which provides the linking
information to the Info page record.

An explanation of the way that graphics are imported info, are treated while
being used by, and can be exported from Filevision follows:

Imported MacPaint graphics become single object Filevision PICTs and can only
be exported as single object PICTs. Their bit mapped identity is lost unless
converted back to a bit map by another program. When these graphics are
exported from Filevision, they are exported in PICT format and can only be
recognized by programs that accept PICT format.

MacPaint graphics that are exported via the Clipboard will retain their bit
mapped identity if pasted directly into a Paint type program. The printout of
these graphics is only supported in 72 dpi (bit mapped) regardless of the printer
resolution.

Version 1 PICTs can be imported either as one single PICT or as discrete objects.
Discrete objects allows the use of any object making up the PICT to be used to
link to its own record in the Info page. A single PICT object, which brings all of
the individual objects in as one object will have only one record in the Info
page. This can reduce the size of a file considerably if the individual elements
of the PICT serve no putrpose in the file.

Single PICT Discrete Objects

Version 1 PICTs either generated by or imported into Filevision can be exported
as discrete objects (if originally imported as discrete) and can be used in or
modified by any program that recognizes the version 1 PICT format.
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When importing a PICT as a single PICT, all lines and shading will be as origi-
nally created. If the PICT is imported as discrete objects, Filevision will try to
match the lines and shading of each object from the current palettes. If a
matching shade can't be found, the object will be shaded in Glass which can be
changed later as required.

Version 1 PICTs can be interpreted by a PostScript output device and will yield
the highest resolution provided by that device.

Version 2 PICTs can be imported as a single object version 1 PICT. The version
2 extended color and gray scale may or may not be displayed by Filevision.
Once imported into Filevision, version 2 PICTs become version 1 single object
PICTs and can only be exported as such.

EPSF graphics can be imported only as a single objects and can have only one
linked record per graphic. As the Macintosh monitor will not display an EPSF
image, a PICT is created to represent the EPSF graphic when the graphic is first
created. This PICT is also imported along with an EPSF text file that describes
the image. Unfortunately, if a PICT was not created by the original source of the
EPSF (which is sometimes the case), Filevision will not be able to import the
EPSF.

PostScript is a programuming language that was developed expressly for the
enhanced creation and reproduction of printed images. This can be either
graphics or text. The advantage of using PostScript is the ability to manipulate
images with much greater flexibility and with much finer detail. High resolution
EPSF scanner files can also be used by, stored in and printed with Filevision.
This provides much higher quality output when these scanned images are used
by Filevision.

The EPSF image is made possible by a PostScript text code file that is used to
define the image. As a PICT image was created for the PostScript file to create a
displayable imnage for the screen, Filevision offers the option to export the EPSF
in its full PostScript form or as a single object PICT.

If a high resolution printout of the image is not required, the file can be reduced
in size by eliminating the PostScript code from the file. Converting an EPSF1oa
PICT can reduce the file size by several kilobytes.

To convert an EPSF to a PICT:

« Either import the EPSF to Filevision or select an existing EPSF in
Filevision to be converted.
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+ Choose Export Graphics... from the File menu.
»  Click the PICT radio button (if not already selected).
« Click on the Export button.
After the graphic has been saved, delete the EPSF graphic from Filevision and;
* Choose Impott Graphics... from the File menu.
*  Click the PICT radic button.
« Select the graphic that was just exported as a PICT.

+  Click the Import button.

Place the graphic as before and the conversion is done.

The ability to import high resolution scanned images onto the drawing page or
into an Info page field provides the essence of integrated imaging. This means
that any detailed photograph, a hand written or other document requiring a
confirming signature, charts, graphs and other graphic materials necessary to
provide a particular solution for most any application, is now possible.

For instance, setting up a security system that reqguires a high quality photo-
graph and personal information, sample signatures and other identification for
authorized personnel is possible with Filevision, a Macintosh If and access to a
high quality gray scale (or color) scanner.

Maintaining an auto insurance claims adjustment application would be a simple
matter to set up and operate with Filevision. Damage photos, handwritten
adjuster's reports, accident location maps and any other visual information
necessary to the claim is accepted by Filevision's integrated imaging capabilities.

One of the many uscs of Filevision is the ability to import scanned standard
forms in common use by a company. The form can be pasted into an annota-
tion field (see Adding Annotation fields, page 167) and data entry fields can
then be placed over the active entry areas of the form,

This creates an easy transition from manually processed standard forms to
computer processed forms without the necessity to change documents that have
been in use for years. Personnel using these forms require little to no training to
convert to the computer.
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The import or export of Filevision information through the Macintosh Clipboard
is not obvious and requires some explanation. Unlike the standard method that
other Macintosh programs use to "copy and paste”, any object that is copied
from the Filevision drawing page carries the information in s record with it.
This has its advantage and disadvantage.

The advantage is the ability to copy not only the objects of a Type but fo also
copy all of the information entered into the records for those objects. This
allows a simple way to transfer information from one Filevision file to another
or from one Type to another. If you were to select four graphic objects, with
each of the four records containing five fields of data, all twenty separate fietds
of information along with the graphics would be copied to the Clipboard.

drawing page

Last name
First name

Current Mailing Address
PO Bex 7738
| Saint Louis, MS 33401

Phonel/Home 296-8979
Phonei!Work 5236543

Info page

Last name [0TI0 ]
First name [N ]

Last name
First name
Current Meiling Address
27330 Atlantic Coast Highway

Jediber €4 90265

PhonetHome NN
Phonei¥ork

Current Mailing Addres=s
27930 Atlantic Coast Highway

,!.f I

objects selected
for copying

[ Matibu, A 90265

PhenefHome 2136774873
Phone/¥ork NN

Last name
First name g

27353 Alisntic Goast Highweny

records included
for copying with the objects

by, 4 30265

PhonefHome 213-457-2242
Phonettork
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If you then paste the
contents of the Clip-
board into a new
Filevision file having the
same Type and record
layout, all four objects,
four records and twenty
fields of information
would be transferred.
The new file would have
exactly the same records
and information as the
original file. This is also
true if you copy from
one Type to another in
the same file.
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The disadvantage arises when attempting to copy a large number of objects and
their records. This depends on the amount of information that has to be
handled by the Clipboard. Copying 500 objects, each with 500 records having
100 fields could take a fair amount of time. Filevision does not keep all of the
records of a file in memory at one time. When copying to the Clipboard as
described here, every record must be read into the Clipboard from your disk
which takes considerably more time than reading from memory.

While copying to the Clipboard may require more time than expected, pasting
the contents of the Clipboard to the Scrapbook will take considerably longer.
Unfortunately, if you attempt to paste a large file to the standard Macintosh
Scrapbook, the program may hang as the Scrapbook works with a limited
amount of storage. There are third party Scrapbooks available for the Macintosh
that will provide much more space for storage than the Macintosh's Scrapbook.

These problems in working with the system Clipbeard and Scrapbook are
problems that can't be resolved from within Filevision. Once the Macintosh
system takes over the copy and paste functions, no software provision is offered
to break out of them. A hardware reset (turning off the computer or pressing
the reset button) is the only alternative.

The time required may lead you to believe that the computer is "hung” {not
performing the copy function and not releasing the computer back to you).
This means that you would have to press the hardware reset button or turn off
the computer to regain control as there is no other way to stop a copy or paste
in progress. If you break out of the program in this manner, you always risk
damaging your file.

It would be advantageous to be able to provide some guidelines as to what
constitutes too large a file to attempt this copy and paste procedure. Unfortu-
nately, there are far too many variables involved to be able to do this. The best
way to determine how your file and hardware will perform under these condi-
tions is to give it a try with a limited number of objects and records. However
much time it takes for any given number of records will be about doubled if
twice the number were to be attempted.

Where a large amount of information is contained in the records of objects to be
copied and transferred to another file, use the following procedure:
»  First setect the objects to be transferred.
+ Using the Export Graphics... option from the File menu, export all
objects to a PICT file.
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» Using the import/Export Text... option from the File menu, create
an intermediate Export file.

This will separate the record's text information from the object's graphic infor-
mation.

» Import the graphic PICT file using Discrete Objects and the text
intermediate file into the new Filevision file using the standard proce-
dure described in Part 10: Impoerting and Exporting Text, page 188.

«  After the graphic objects and records have been imported, re-attach
each object to its record by first selecting the record and while
holding the Shift key, select the record's object and Group the two.

Importing discrete object PICTs through the Ciipboard, created by programs
other than Filevision, will bring those images in as one object.

In other words, if you have access 10 a map with all 50 states drawn as individ-
ual objects in a Draw type program, copying the map graphic and pasting it
through the Clipboard into Filevision will yield a single graphic object. Each of
the discrete objects will have been combined into one large object,

To insure that any multiple object PICTs created in other Macintosh programs
retain their separate object identities, always import the PICT using the Import
Graphics... option from the File menu.

Filevision does not provide the ability to combine more than one EPSF graphic
and to copy the combination to an Info page or Print Layout field. Also, EPSFs
cannot be combined with other PICT objects. This is also true when attempting
to export more than one EPSF or an EPSF and any other object to a single EPSF
file.
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8. Creating a Type

This section explains how to add a new Type to your file. When you add a new
Type you design the layout of its records; it's like designing a new form for use
in vour office.

You can always change the layout of Filevision records even after you've
entered data into some of them. It's like being able to change the forms for
vour employee records after you've added information to them, without having
to reenter the data from records that were used before the format was changed.
Filevision “reenters” the data automatically when you change Type layouts.

You eater information into the records (for instance, employee names and
numbers) only after you've created or edited the Type layout; see page 177,
“Adding Information”, for details.

Adding a type When vou add a Type, you first create a Type layout by adding and
placing fields, which act as placeholders for individual pieces of infor-
- mation. Every record for a Type uses the same Type layout; only the
NOTE: You can change *information in the fields differs.
the background shade of |
any layout screen from the | . Choose Add Type... from the Types menu. The Add Type

Shades menu.

Editar...

%

s

e ]
6‘&
IJ.)., A "0

display wili appear.
r % File Edit Tgp_és §§§:€ #3s  Text Fﬁ}_mat Shadesm 7 - |
= fddiype - TYype  =Fr—————
I|I|I|I1|!|III|I2|1II|I|I3II|]|I|I4II|I|I|I5|III|I|Isl

Type-mame Tup® t

Sl

[|I||MI|||I|"'|I|||I|

i Cancel][Bascvs Fiaid)iiptions][Add Field][Done] [ -
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Note: Because every object in a file must be of some Type, when you begin
work on a new file the Type Background is already supplied. [t's no different
from any other Type, so you can change its Type layoul, rename it, or remove it
completely . However, if Background is the only Type, it can't be removed.
One Type must always remain.

Filevision automatically supplies a name for each new Type, but you're encour-

naming a type
aged to change it to a more meaningful one.

= Onthe Add Type display, enter the new name in the Type-name
box. The name can't be more than 15 characters long (a character
is any letter, number, a space, or punctuation mark).

adding a « At the bottom of the Add Type window, click the Add Field button.

data field

A dialog box appears:

(Cancel ] [Annotation Field ]

« (lick Data Field.

A field appears in the middle of the display.

« Point at the move handle on the top of the field and, holding the
mouse button down, move the field where you want it. Click any-
where outside the field to deselect it when you're happy with its

location.

= AddType - Type A —————-—-———P)7|
xlxllllljillill|21|i|||l|3|(Ia|:I|4i|||||J|5|1I||1I161|MG

Type_name

Il‘-‘lllhll
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You can have up to 255 fields in each Type layout,

The Type layout is much bigger than the part you see on the display. It's 30"
wide and 30" high. You can open the window to the full size of your monitor
by clicking on the zoom box or by dragging the resize box.

Zoom box

E Change Layout - Patient =icer——
et A Al sl E

Type_nome

Bz

o]

resize box

+  Use the scroll bars at the bottom and right of the window to bring its
other portions into view:

Cance |

scroll arrow —

naming a field «  Onthe Add Type display, select the field you want to name by
clicking anywhere on the field.

+ Type in the field's name, then deselect the field by pressing enter or
tab, or by clicking somewhere else on the layout.

i
| First name ;

Field names can’t be longer than 31 characters. You can change the size of the
field name by holding down the Option key and typing "hard" spaces after iL.
Also, it is not necessary to name a field if you have a particular reason not to.
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changing the When you add a field, it is given a standard size. You can change the size of the
size of a field field anytime using the following method:

= Select the field.

'wo handles appear on it, 2 move handle at the top and a stretch handle at the
lower right:

First name -

«  Paint at the stretch handle and, holding the mouse button down,
stretch the field fo the size you want it to be.

B

|
®

You can also pull the field downward to make it several lines deeper.

*

Fields can be increased in size up to 10" wide by 30" high.

+  Click anywhere on the background to deselect the field.

Fields can be stacked or overlapped.

First name

Middle Initial

moving a field - To move a field, first select it.

+  Point at the move handle and, holding down the mouse button, drag
the field where you want it.

+ Release the mouse button when you're satisfied with your placement
of the field.
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moving several
fields together

first select fields by
dragging a marquee

around all ficlds

grab any move handle
and drag to the new

position

removing a field

adding an
annotation field

Several fields can be moved at one time by first selecting them with a marquee.
After all ficlds to be moved are selected, mouse down on any of the move
handles and drag to the new position.

First Hame § i
social Security Number

First Hame
— i _
Sociai Security Mumber

First HName
Social Security Numbe

- Onthe Add Type display. select the field you want to remove.
= Click the Remove Field button.
The sort (Name ficld in these examples) and Link fields can’t be removed. You

can hide the Link field using the Options dialog on the Add Type or Change
Layout displays. Link fields will be covered in this section under Options.

Keep in mind that if a field’s name is used in a formula, removing the field will
make the related formula field useless. A dialog box will warn you if that
happens.

You can add “annotation fields” to the Type layout; fields that display the same
thing in every record. They're handy for directions to the person entering infor-
mation into records or to show the same picture or text in each record.

« To add an annotation field, click the Add Field button.

The Add Field dialog box appears:

" Annetation Field, SITXCRAL Y

+  Click Annotation field.
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A field appears, but the opticn to assign the field a name is not available as
annotation fields can't be named.

Add Type - Type B Swoe i
ittt b At B B 8

+ Type in the information you want to

appear in each record,

Lebata i gt
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Type name

Paste in a picture from the Clipboard,

+ Import a graphic from any PICT, EPSF or bit mapped file.

Annotation fields, unlike data fields, remain the same for every record and can
only be changed when first adding a new Type or when in Change Iayout. The
annotation field is used to add repeating information, logos, standard forms or
other information comimon to all records.

The following example is of a standard form pasted into the annotation field
with hidden name active data fields overlapping for data entry.

=———=———=———- Add Type - Type B %EEI

|||||ll1|111|l||2|||JIl|13|I|!II|l4lI|I|I||5|IiI|IG
Type-name Furchases

|_T]

| Peschizse Order Rosm PO# oo

2] Qty | PN Description Each Total

S I

Cuncell([Bencve ¥ieid)lOptions]||Add Fieldj(Done [:>




Field setup

Fields are where you enter data in a record. Normally you enter data using the

keyboard and editing tools—Cut, Copy, Paste, and Clear. The standard field
setup requires no special preparation and accepts text, numbers, and pictures.

Filevision also provides three methods of automatic data entry: initial text fields,
copying the field contents from the previous record, and formula fields. You
give fields these attributes with the field setup dialog, as explained below.

setup for the field:

@ standard O Copy from preyious record
O Initial Tent O Compute using a formula
Initial or formula text (not active):

Field Names: [[ink 3

(Cancel ["preu Field ) ( Newt Fiexd |

{Tnone )

standard fields .

+« Click Done.

initial text fields .

+  Select a field while on the Add Type,
Change Layout or the Info display,
then choose Field setup... from the Edit
menu, or double-click a field name from
the Info display.

You’'ll see the field setup dialog box:

Click Standard for unrestricted data or graphic entry.

Click Initial Text to create a field that will automatically fill in the
information you specify when a record is added.

An initial text field always starts with the same text each time a record is added
using Add record. For example, if you want all records to have Net 30 days in
the Terms field, you can use an initial text field.

Setup for the field:

(O Standard { Copy from previous record

@ Initial Test £) Compute using a formula

Initial text:

Net 30 days|

Field Names: [Link 1

[cancet] [ Preu Field ] (Nent Field ] ( pone ]

Initial text fields can also display the system date
and time in two different formats.

«  Type in the information you want used as
initiat text.

You can also have the system date or time inserted
automatically if you Type in these special charac-
ters:
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« Type &D to display the system date in long form (for example,
Tuesday, March 11, 1989).

Type &d to display the system date in short form (for example, 89/
03/11). The order is year/month/date.

This format for displaying dates allows you to use the date for comparisons in
Find... and Highlight.... conditions.

+ Type &T to display the system time with seconds (for example,
10:32:14 or 14:00:03

- Type &t to display the system time without seconds (for example,
10:32 or 14:00

+ Click Done.

Any time a record is added using Add Record from the File menu, the informa-
tion you just typed in will appear automatically in that field.

Initial text can be edited like any other text.

If you change the initial text in the field setup after adding records, only records
added after the change will be affected.

+ Click Copy from previous record if you want each new record to
“inherit” the value that was in the same field of the last record.

+ Click Done.

For example, if the Batch number field is given the Copy from previous
record attribute, and you enter a batch number of 242, each time you click Add
Record from the Info display, the new record will contain 242 in the Batch
number field.

If you change the batch number in a record to 243, then each time thereafter
that you click Add Record from the Info display, 243 will be entered into the
Batch number field. Previously added records are not updated with the new
value; it applies only 1o records added after the change.

» Click Compute using a formula to create a field that automatically
enters a computed value based on the contents of one or more other
fields.



Filevision does all the wortk—it calculates the value according to a formula you
give it and enters the result into the computed field; you cannot enter informa-
tion into a formula field directly.

s Type in the formula.

Setup for the Extended price field:

(O Standard (O Copy from previgus record
O Initial Texut @® Compute using a formuia
Formula:

[Quantity]*IUnit price]

Field Names: |Unit price |

[cancel ) ( Prev Field ] [ Nent Field ] ( pone ]

A simple example of a computed field is shown 1o
the left. It’s the extended price on a purchase
order. The extended price is the quantity pur-
chased times the unit price. We're assuming that
your Type layout already has fields named Ex-
tended price, Quantity, and Unit price.

+  Click Done.

Note: There’s an alternative to typing in field
names used as part of a formula.

+  Using the Field names: pop-up menu, select the field name to be
entered into the formula. The name will be entered automatically
with square brackets.

Notice that square brackets appear

Setup for the Extended price field:

around the field name when it
becomes part of the formula. Any
data field may be used as part of
the formula regardless of the

Oy standard ) Copy from previous record
) Initial Text @ Compute using a formula
Formula:

[Quantityl

Extended price
Link

information that may be contained
in that fietd. It would be up 1o the
user 1o enter numeric information
in ficlds that are part of a formula
field.

unit price
Cancel l Next Field I

The formula can contain up to 300
characters. If additional space is
required, an intermediate field
would have to be used to contain

the additional information.

The Table 2-1 on the next page provides examples of the information that can
be contained in a formula field. '
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This table shows what you can use in a formula.

Symbols Examples

Arithmetic operators + - /"

Numbers (up to 10 before the | 9,999,999,999.999
decimal point and 4 after)

Unary signs (in front of -1453.54  +994.999

numbers)

Commas every 1,000 25,600.497

[Field name] in brackets [Order quantity]

Square root (Option-v) ./ [Score average]

Parentheses (can be ([Retail]-[Wholesale])

nested)

|Absolute value| of an l[Income]-[Delta]

expression

Currency symbol $25,000 33¢
¥250 £99

Percent sign {multiplies the 40%
number in front of it by .01)

Here are some examples of formulas:

[No. shipped] + [No. left in warehouse]
[Wholesale] * 140%
([Spoilage] + [Defective]) * [Unit price]

Notice that the slash (/) is used for division, and the asterisk (*) is used for
multiplication.

You're given a choice regarding the way the Link field and double-clicking an
object from the Drawing display are used for all the objects of each Type. The
Add Type display has an Options button that lets you make those choices:



hiding and
showing the
link field

Hide link field conceals the link field on the Info dispiay, but doesn't erase the
field or its contents. Show link field restores the link field’s visibility.

- To hide link fields of all of a Type's cbjects, click Options from the
Add Type or Change Layout displays.

Hide link field
Show link Tield

Dptions for this type:

+  Select Hide link field from
the Options for this Type

@ Double-click goes to Info display dialog.
> Double-click goes to Link file

*  You can reverse it anytime
by clicking Show link field.

double-clicking
to the Info
display or

Link file

+ Click Done.

When you're creating a Type layout, Filevision assumes that when you double-
click on a graphic, you'll want to see the Info (record) for that graphic.

But you can change the meaning of double-click. A double- click can mean
instead that Filevision is to link to the file named in the Link field for that
graphic.

This works on all the objects of a given Type. It can be set ditferently for
objects of each Type.

® Hide link field
) Show link field

Options for this type:

« Click the Options button on

{ Double-click goes to Info display the Add Type display.

Qﬂouble“click goes to Link file .
+ Select Double-click goes

to Link file from Options

Using the
Format menu

for this Type.

* You can reverse it anytime by clicking Options again from the Add
Type display and selecting Double-click goes to Info display.

+  Click Done.
A number of formatting options are available for ficlds, both from the Add Type
and Change Layout displays, from the Print Layout display and from the Info
display.

«  Choose Align Left, Align Middle, or Align Right from the Format

menu to align the field data.
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= Choose Show Border or Hide Border from the Format menu {o

« Alphabetic %0 show or hide the field border.
Numeric 39
«  Choose Invert to show the field name in white letters on a black
Dollar Sign M background. For annotation fields, the entire text contents of the -
Commas 3, field will be in white letters on a black background. Do Not Invert
Decimals... 38, reverses this.
Statistics... - . Choose Hide Field Name to show the field with just the data en-
tered. Useful for creating a spreadsheet appearance or for overlay-
» Align Left %6 ing fields on a standard form for data entry. Hidden field names will
Align Middie %7 be shown when the Field Setup dialog is accessed.
filign Right %8
Hide Border =&=——= Info for this Spreadsheet: (1 records) =——===UF|
Do Not Invert ||||i||11|l|||||2||I|||i|3||||||||4l|l|||I|5||IG

Hide Field Name

TG 15t Quarier- 1959 Sales |

Across...
Close Lines

1] Divizion January February barch
Show Ruler R ] Chicago 3 623,998 4.943,000] 36,2330
Metric Ruler - Los Angeles 8,364,460 5332977  $9,112,877
= New Y ork 7B55456] 7001399 35,778,546
] TOTAL $20.163.373] $16,277,376] _§24,125,357
| 7]
R $62.566.108]
—

e

Fryamns iﬁshxi.llﬂeuer‘t Drawing |§..mk|

In this example, the row and column numbers are annotation fields, the spread-
sheet cells are hidden name fields and the others are standard. Cells 5-B,C,D
and Total Quarterly Sales arce ali formula fields.

« Choose Hide Ruler to hide the ruler on the top and left of the layout,
and Show Ruler to restore it. The ruler is not printed on forms,
reports, or labels.

»  Metric Ruler turns the ruler on the top and left of the layout into a
metric ruler; Inch Ruler turns it back.

Using the You can choose different fonts, sizes, colors and styles of text on the Type
Text menu layout.

+  Select the field.

- Choose a style, point size, text color and/or background color and
font from the Text menu.
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Font »
Size 4
Style 4
Color »
Background Color ¥
fent Masking

The point sizes that look the best are shown outlined. You can change the font
and size of a field name, but not its style; field numes are always bold text. But
the contents of the field will be displayed according to the style, point size and
foni chosen for that field.

There's a shortcut you can use if you want to perfori a TEXT operation on all
of the fields at once.

Font [
6
styl b 8 . . .
Color M © »  Simply hold down the Option key while you make your changes and
10 ,
Background Color b2 they’ll alt be affected the same way.
Font Maiking 14
i@
24
30
ig In the example below, all of the fields will be made a uniform point size (12
&0 i
o point).
E Info for this Temp Help: (123 records) === IIoldir.lg down the Optif)n key_ whil.e
vl l1| Lol ‘ZI S |3E p s |4| EEBEN| [Sl | IG Ch()()smg12fromthchlerarchlcalSlze

Ili|IIM|]]I|I["'\‘I}I‘I

£1izabeth |

selection on the Text menu changes all the

fields to a 12 point size.

Last Name [T

w_

ECJ==—— Info for this Temp Help: [123 records) g
?HﬂtnT’HS I Il\1!|Il|IllII‘I2|i|IhllL3l||I|I|I4EllI|I|I5|I‘|{}
yes Worked with us before? BN First Name [P ats !

Diid extremely well.

IESEYITN Grovse -

FIT time
. F ]

[Prev][Hext] [Recvert ) [Drawing J{Link

Using the
Shades menu

on

the

Type layout

i

’ Counselor in day school

Day(s) hired IHIICHRIEE |

Worked with ns before?
eI
Did extremely well.

||l|1|*‘-‘|i|||

&

[Prev)(Hoxt] [Rovert ]{Drawing | [L.ink

When you're on the Add Type display (or the Info display) you can change the
shade of the background for that Type.

Choose a new shade from the Shades menu while you're on the Add Type or
Info display.

You can create new shades by altering the ones on the Shades menu; see page

126, “The Shades Editor”, for more details.
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Saving the
Type layout

copying and
pasting the
Type layout

changing the
Type layout later
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»  On the Add Type display, click Done to save the changes you made
to the Type layout.

When you change the Type layout, all existing records reflect any changes that
you made.

You can save a lot of time by making effective use of the Clipboard and Scrap-
book when you design Type layouts. The Clipboard and Scrapbook give you

the ability to reuse layouts instead of redesigning them every time you create a
new file or add a new Type.

The example below shows how to replace an old Type’s layout with one from
the Clipboard. From the Add Type display, hold down the Option key and
choose Copy from the Edit menu.

The Type layout is now copied onto the Clipboard.

Caution: Remember that the contents of the Clipboard will be replaced by the
next thing you cut or copy.

*

Choose the Type you want to change from the Types menu.

+ Transfer the layout on the Clipboard to the layout you’re working on
by choosing Paste from the Edit menu.

A dialog box will remind
you that you're replacing

f Pasting witl replace the entire layout with the
the entire old Type.

one an the Clipboard.

You will not be able to undoe this action.

You can save a layout [ Paste §

permanently by pasting it
into the Scrapbook.

«  Choose Scrapbook from the Apple (#§ ) menu.

+ Choose Paste from the Edit menu. !ﬁevision@ v TYPE LAYOUT |

!

The information is saved as: 1
Type-name: Monthly

Pictures in annotation fields aren’t saved From file: Master
when a Type layout is copied.

You can always change the layout—rename fields, move them, change their
sizes, add new or remove existing ones—even if you've aiready added objects
and entered data in records. Use Change Layout... from the Types menu.



9. Adding Information

Adding a
record

Duplicating a
record from
the Info display

Entering
information
into fields

Once you've created a Type layout and clicked Done, you can add records.

+ Choose Add Record from the Edit menu.
These fields will automatically fill in information when you use Add record:

e ¢ Initial text fields
*+ Copy from previous record tields

+  Choose Duplicate Record from the Edit menu.

A new record is created, and all its information is exactly the same as the current
record’s.

If the record has a graphic associated with it, select the graphic from the Draw-
ing display and choose Copy and Paste from the Edit menu to duplicate both
the graphic and its record.

This section tells you how to add a record by filling in information into its fields,
not how 1o change its layout. To change its layout, see "Changing the Type
layout later®, page 176.

Don't forget that when vou're entering information, you can use the Edit menu:
Cut, Copy, Paste, Clear, and of course Undo. The Scrapbook, Clipboard, and

the Notepad are aiso available. See page 310, “Editing Tools and Other Fea-
tares”, for more on those.

+ From the Info display, select the field you want to fill in with the
mouse or the Tab key, described below.

You can use the scroll bars at the right and bottom of the display to reach the
fields of a record that’s larger than the display,

+  Type in the information.

A field can hold a maximum of 8,000 characters and a record can hold a maxi-
mum of 16,000 characters.
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Fields with
pictures
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or

or

or

or

=[J=——= Info for this Floor Plan: (1 records) S==—=0|

FEEIIA) Electrical service
Il Phone system [IEN
Sprinkler service
Reception TN Fason Alerm |
General Manager CYE U g1l Mason Alarm
Factory Manager AL A S Edisor Company |
¥.F. 3ales
Aecounting XN irban Gas Company |

Shipping T R M Se Counties ‘Water
overhead doors |NGENE] Fire extinguisher service
m_' T §|LTrax Extinguisher Service

When you're finished, deselect the field by pressing Enter,

Press Tab to move to the next field,

Hold down Shift and press Tab to move back a field,

Press Option-Tab to move to the first field,

Click another field with the mouse.

Fields can hold pictures as easily as they hold text. No special preparation is re-
quired. Any application that uses the Clipboard or creates a PICT, EPSF or
MacPaint format graphic can be used to create graphics for Filevision. Graphics
created using the Filevision drawing page can also be copied to a field. Ready
made clip-art graphic libraries would be a good source for artwork.

Pictures can be copied to a field by using the Clipboard or by using Import
Graphics... from the File menu.



Copying
graphics
to a field from
the Clipboard

Any graphic stored in the Scrapbook or copied to memory from the Filevision-
drawing page or another program, can be pasted in a field using the following
procedure:

«  Copy the picture onto the Clipbecard.

Undo w7

Cut #H

Paste 1 -
Clear m National Aviation Comparison Map J

Bring to Front  {-¥F
Send to Back 3EB
Brous HE
Brpifier

geshape

Add Record #A
fpzrtivatas Buonrg WY
Delete Records...

Top &irline
Markets For :
— Fhoeriz
wwiey Tuceon

Preferences... #E = -
Grid & Rulers...
Fiahd S ban...

The graphic is now in the Clipboard.
To paste the Clipboard image to a field:
«  Click Info to go to the Info display.
+  Select the record in which you want the picture to appear.
*  Select the field in which you want the picture to appear.
+ Choose Paste from the Edit menu.
The picture is scaled to match the size of the field, stretching and shrinking as
the field is stretched or shrunk. However, you can choose to keep the picture’s

original size.
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Airline Market

+ Hold down the Opticn key and click either of the field’'s handles.

Dyin Migaiin nueo

Airline larkel

ﬂ' Metionat Aviation Comparison Mapj

Top dirline
il Markets For
MZA " Phoenix

Qc‘lm.d
2y

The size of the picture reverts to its original size. Open the field so that all of
the picture can be displayed in the field at one time.

+ To return to the scaled size, hold down the Option key and click one
of the field's handles again.

Because fields can be overlapped, you can put a field holding a picture behind
another field. For example, you might want to print mailing labels and have an
annotation ficld containing a border pattern surrounding the printed text.

N EeE LR e g ann f LA e nne ey PR YRR TAAT N PR AR AT YA N

James W. Turner
TURNER CONSULTING
123 30th Street, Suite 1-A
Irvine, CA 92714




Importing from

graphic files

New...

dpen...

Close Work File
Save

Save As...

Return to US Map

N
0

E3]

%;

Import Graphics... N

EMport Graphics...

Import/Edport Text...

Page Setup...

Page Size...

Print Page... ®’Y
Print Records... %P
Quit 80

Graphics from separate PICT, Paint or EPSF files can be imported to and
exported from an Info page record. This provides both a way to use graphics
from most any source (o illustrate your file and can be used to store and catalog
your library of graphics or customer's jobs.

Both version 1 and version 2 color and gray scale illustrations may be stored
and displayed in their original colors and gray scale. See Importing and Export-
ing Graphics, page 151, for a description of the various graphic formats,

To import a graphic into an Info page data field:

» Select the Info page record with the field to import into.

»  Select Import Graphics... from the File menu.

The import dialog will be

displayed.
0 Cambo Map PACT o HDE0
O BeskTop When the PICT button is
Fjact .

g ]','::""E Info PICT selected, only graphics of the

0 Report PIET PICT type will be displayed

0 Test PICT in the menu.

01 Test Shade PICT

If you select MacPaint or
@PICT (O MacPaint import as: EPSF by clicking on their but-
@) Single PICT

) EPSF tons, only files of their type

(O Discrete Dbjects K
will be displayed:

+  Select the graphic that you wish to import.

»  Click the Import
button.
O3 BFu Bou Art.eps — Hl8e
i i i i 0O BoxArtEPSF2
Thg Ehmplorft dialog W'lllli disappear B ol eps
an € INro page will reappccar. 0 MacUser.eps _
[ Marvelin BRM.eps
. 0 Maruloge 90.eps
* Move the pOInter any- [ Please send.eps
where over the field ta D Scan.tf 3 - SP - EPA
be imported to and the O Summer Special.eps
. . R Import as:
pointer will change to a OPICT  OMackaint o cingle PICT
H @ EPSF
right angle cursor. O Biscrets Ghjecls

+  Click the mouse button once if the field is already selected or twice if
the field requires selection and the graphic will be deposited into the
selected field.
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Exporting to
graphic files

New... N
Open... %0
Close Work File

Save ®BS
Sape As...

Return to US Map ¥;

Import Graphics...

Export Graphics... N

Import/Export Text...

Page Setup...

Page Size...

Print Page... U
Print Recards... ®BP
Quit ®0

Going to the
next or previous
record

As with graphics pasted from the Clipboard, the imported graphic will center in
the field and will scale itself to the field size.

Once the graphic has been imported, it behaves the same as any graphic except
that it will retain its type identity if imported as a PICT or EPSF. MacPaint types
will become PICTs once imported.

If a PICT is imported as discrete objects, it can be copied to the drawing page
whenever needed and can be used as discrete objects. 1t can also be exported
to a PICT file and will retain its discrete object form. If the same PICT is im-
ported as a single object picture, it looses its identity of discrete objects.

Exporting graphics from an Info page field is essentially the reverse of the
above.

«  Select the record and field containing the graphic to be exported.

«  Select Export Graphics... from the File menu.

The export dialog will be displayed:

1.5 Please seng

iy BYy Bou Bl

Y BF e Boos firlesy

3 B¥ v toge

0 By Laga Lebed

0 BYu Lo lewmpialy

+  Enter a file name and click
the Export button.

The new graphic file can be used Saue fs:
by any other Macintosh program.
@PicT
OIrsy

Records added in Filevision are dynamically entered in the sort order of the sort
field. Unless you change the sort field by selecting Sort... from the Access
menu, the sort field is the automatic field entered when you first set up a new
Type. The field name assigned to it is Name. Unlike most file managers, there
is no need to resort every lime that you add a new record in Filevision.

In using the Next and Prev buitons, the record accessed will not necessarily be
the last record entered as the last record entered was placed in the Type's sort
order (ascending).

Info page window ——— ﬁ (Prev][Next][fizver i) [(Drawing ][5 éraklEEI I
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«  Click Next to see the next record of the selected Type, Prev to see
the previous record.



each selected
record's object
shows as a dot
on the mini page

record with no
object icon

Entering
a record

Canceling
changes made
to a record

When you're on the drawing page, the page miniature always shows each
currently selected record's object as a dot:

Townhouse: (4 selected)

|Preu||Hext|| Infolli. ink ]

*  When you hold down the Shift key while clicking Next or Prev, if the
selected object is off screen, the drawing page viewing area will
reposition itself automatically to display the selected object.

If the record doesn’t have a graphic object, the record icon will appear to the

right of the page miniature on the drawing page. Think of the record icon
(E3) as the graphic for a record that has no other graphic object.

Salesperson: Al len|
= |I‘Iext||lnfn”§.s'ra§&|
|

Double-clicking on the record's no object icon will show the Info page for that
record the same as double-clicking a normal object connected to a record.

+ Toenter (save) a record from the Info display, click Next or Prev,

or,
»  (lick the Drawing button,
or,
+  Click the Info page window Close Box,
or,
«  Click anywhere on the drawing page window if it is exposed.
or,

+ Select Add Record from the Edit menu.

Any change or series of changes you've made to the record you're currently
working on can be undone as long as you haven't entered the record by using
any of the methods listed above.

» Click Revert.

You’ll be warned that this action can’t be undone.
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Deleting +  Choose Delete Records... from the Edit menu.

records , )
« You're given these options:

Delete records using these options:

@ Selected "Golf Hole"s only
) Highlighted "GolT Hole®s only
Al "Golf Hole"s

@ Records and their graphics
" Records only
() Graphics only

You wilt not be able to undo this action.

To delete highlighted records you must first have some highlighted; for more
details, see page 228, “Highlighting”.

Likewise, you can’t delete selected records unless one or more objects or
records are selected. See page 109, “selecting a single object”, and pages 109 to

110 on "selecting several objects at once".

»  Click the options you want.

+  Click Delete.
Separating a +  When you're on the drawing page you can select an object and, if it
record from its has a record, separate the graphic from its record using Ungroup

graphic object from the Edit menu.

You'll get a dialog box warming you that you're about to create a graphicless
record:

Ungrouping will result in a
record that has no graphic.

The record and the record's graphic object are now separated.
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Attaching a
graphic object
to a record

If you create a record without a graphic, and later want to add a graphic object

to that record, follow this procedure:

+  With the objectless record selected, click Drawing to get to the

drawing page.

You’'ll see the tiny record icon (B2 next to the mini page, indicating that the
currently selected record is a record without an associated graphic object.

You can easily merge the record and the graphic object together.

« Hold down the Shift key while selecting the graphic{s). Both the
record and the graphic(s) will be selected under the standard rule for

multiple object Shift key selection.

E00

File

Shift Key down -

drawing page objects

+  Choose Group from the Edit
menu o merge the objects into a

'RW Tupes Access Opt
Undo ®ZE
Cut %H
Capy $6C
Paste U
Clear
Bring to Front  {:38F
Send to Back {38

#G

Gather k
Reshape

3T
38R

/le Recard £ ]

Duplicate Record 3V
Delete Records...

Preferences... RBE
Grid & Rulers...
Field Setup.., 8=

B EE @

~ and Info page record single object and the record with
selected - that object.
select Group from
the Edit menu
If Group is unselectable, it means that one
of the graphic objects already has a
record,
Adding
information to s easy to fill in the record for a graphic object.
a graphic
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U.5. Map - Actuai §ize

U.S. Data Hap: Arizona

| [Prev)Bext)(nfe) Lok AT ]

= Click the graphic object on the drawing page:

The object’s Type appedrs in the selection information area.

«  Click the Info button.

An empty record for the selected object of that Type is waiting to be filled in:

E[ [===== Info for this U.5. Data Map: (50 records)

STATE NAME [TSER Faa REcION NN
AYIA. DIRECTOR

i PHOKE:- I

AREA 50. MILES % OF NATL ARES D

POPULATION( N <o v s ror.

1981 GA AIRCRFT % U5 alrcrarT [N

1981 5T AIRMEN % of us AIRMEN I
[

Prev][Hext][Revert](Dragwing JB ink]

Initial text fields will already be filled in.
What if the object isn’t the right Type? You can easily change its Type by

holding down the Shift key and choosing a new one from the Types menu. For
more details, see “Changing an object’s Type”, on the next page.
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Changing an
object’s Type

Every object has a Type—whatever Type is selected on the Types menu when
that object is added. Keep that in mind when you add objects, but don't worry if
you make a mistake. You can easily change an object's Type anytime, whether
the object is a record or a graphic.

+  Select the object or record whose Type you want to change.
You can also select several objects and change all their Tvpes at once. See

“selecting several neighboring objects”, page 109, for more details on selecting
several objects at once.

«  Hold down the Shift key and choose the new Type from the Types
menu.

You'll be given this warning:

You are about to change seiected records
into type "Background”.

If the layout for type "Background” is not
copy of the layout for type "U.5. Data
Map”, "U.5. Data Map" fields may be lost or
inapprapriately assigned.

You will not be abie to undo this action.

+ If the old and new Type layouts are identical, you can transfer the
information by clicking Change Type.

This will also work properly if the new Type layout is the same as the old one
but with any fields that are different located below (after) the common fields of
both Types.

- Ifthe new and current Type layouts aren’t similar or if the new one
isn't a superset of the old, and you don't wish 1o loose the infermation
in the current record, click Cancel.

You would then have to add those fields to the new Type belore changing the
record over to the new Type.
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10. Importing and Exporting Text

What is
Import/Export
Text...?

What you can
do

188 Filevision IV

Import/Export Text... is accessed from the File
menu and was designed 1o enhance the features
already present in Filevision by letting you move data
into and out of Filevision [iles casily and flexibly.

Filevision gives you tools for representing informa-
tion in pictures, numbers, and words. [t lets vou
analyze extensive data and get insight into what the
data really means in a way that no other software lets
you. But there are other tools you can use with your
data. Or you may want to get new data from other
places. Or you may want to provide your data to
other programs or people. That's where Import/
Export Text can help you.

N R
Boea... Rt
Close Text Exchange
Sape ®S
Save As...

Hedurn g, =,

Import Graphics...
Export Graphics...
Import/Eqport Text.

Page Setup...

Page Size...

Print Page U
Print Records... %P

Quit 0

Import/Export Text can take data in a variety of forms and enter it automati-
cally into your Filevision file. Or it can take data that is already in a Filevision
file and convert it into forms that many other programs can use.

You can use Import/Export Text to help Filevision solve your business prob-

lems. Some examples are:

» Build a Mail-Mcrge file of "hot prospects” for use with your word-process-
ing program. (Single page mailers can be produced in Filevision withour

the need to use Import/Export)

* Automatically enter the customer list from another dara base program.

s Update your production costs as caleulated by your spreadsheet or by o

special program you wrote yourself.

* Prepare sales data for your corporate computer.

* Keep stock prices current with data you get from on-line retrieval services.

Extract columnar data for inclusion in a report




+ Exchange data with other Filevision files.

What Import/Export Text... can help you “import” new data into a Filevision file or
Import/Export “export” data you already have in the file. It can:

Text... can do » Import and export data in industry standard formats:

s ASCII—used by many word-processing and data-base programs.

* DIF—Data Interchange Format, used by VisiCalc and some other
spreadsheet programs.

» SDF—System Data Format, used by dBase-1I and dBase-IIL

» SYLK—Symbolic Link format, used by Multiplan, Excel and some other
programs.

» Select from one to 255 fields in a Filevision type layout io import or export
data.

» Add new records to your file or change selected information in existing
records.

» Highlight those records with information that changed so you can focus on
new data.

= Highlight the new records you add to your file,

» Export data for all records of a type or just those yvou have previously
highlighted.

» Convert data using several options:

» Convert all characters to upper case.

s Translate several special characiers to other characters.

» Ignore characters you select.

¢ Convert numbers in scientific format to normal format.
¢ Build a standard “setup” file to automate the import or export process.
¢ Indicate which data was missing in your exchange file.

¢ Use the “Field setup” capabhilities of Filevision when you add new data.

» Switch among different Filevision files and types.

Part 10. Importing and Exporting Text 189



back up your
file before you
Import or
Export any text

exchanging
data with other
programs
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Importing data makes changes to your Filevision file. In fact, it may make many
changes automatically, based on the data and commands you give it. Soit’s a
good idea 10 make a backup copy of important files before you use them to
protect against bad data or errors in cominands.

Exchanging data between two programs usually involves three files:
» the file that has the original data,
¢ the file that is supposed to receive the data, and

e the file that carries the data between these two. We'll call this file the
exchange file:

N [= )

]

ORIGINAL EXCHANGE RECEIVING
DATA FILE FILE FILE

The reason for the third file is simple. The file that has the original idea is
usually in a special format that can be used only by the program that made the
file. For instance, if the original data came from a spreadsheet, that file may
include equations, protection codes, window placement, and other things in
addition to the data itself.

And the file that is supposed to receive the data is built in a special formar that
can be used only by its program. For instance, if the target file is a Filevision
file, it may include graphics, type layouts, highlighting rules and report layouts.

To facilitate exchange of data between different programs, many programs
allow standard alternatives to their own formats. They can read or write data in
these formats too. Import/Export Text is specifically designed to convert
Filevision data files to and from these standard alternatives.

To use Import/Export Text you must know which one of the standard formats
your other program uses. You can use Appendix F (pages 351 to 300) to help
you choose. It lists several other programs, standard formats they use, and in-
structions on how to make them process data in that format.



which way does
the data go?

which data
goes where?

what if the data
shouldn't look
the same?

If your other program doesn’t run on a Macintosh, you will have to communi-
cate the exchange file between the Macintosh and the computer the other
program runs on. There are several programs, like MacTerminal or Micro-
phone, that you can use to do this, but describing their use is beyond the scope
of this manual.

Importing data means bringing data created by another program into a
Filevision file. In order to import data you must first use the other program to
create the exchange file and use Filevision to prepare a file to receive the data,

Exporting data means copying data already in a Filevision data file into an
exchange file. Naturally the data must already be in the Filevision file. And
after you use Import/Export Text to copy it into the exchange file, you will need
to use the receiving program to process it.

You can use Import/Export Text to export data from one Filevision file and to
import it back into the same or another file. But before you do that, you may
want to reread “Editing Tools and Other Features” | page 310. You may be able
to transfer the data directly using Filevision without using Import/Export Text.

One of the reasons that each program has its own special data is that it helps the
program to know where to get or put your data. For instance, a spreadsheet
program needs to know that you want $7.35 in cell D21 and a data-base pro-
gram needs to know that “1234 Fifth 5t.” is the “Address” of customer “Jones”.

Since different programs may refer to data differently, Import/Export Text lets
you specify how to associate data in a Filevision file with data in the exchange
file. You do this by choosing from the list of fields in a Filevision Type layout
and matching them with the fields in the exchange file,

Sometimes you find that the data in Filevision and the data in the other program
need to be different. For instance, some programs handle only upper case
letters, some require only numeric data in certain fields, some require the data
to have a fixed number of characters in each field, or a specified decimal
placement and some programs don’t allow certain characters, like tab, carriage
return, or new line.

Import/Export Text allows you to specify rules to format the data when import-
ing or exporting it.
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It is normally easy to set up the rules to import or export data. But if you do the
same process regularly, you can save time by saving the rules in a setup file. At
any time in Import/Export Text you can save the rules you have entered and
return to that condition again.

Exporting data means sending data that you have in a Filevision file to an ex-
change file. Then you can use the exchange file to import data into a second
program. There are several choices you make to control how this happens:

e In what standard format should the exchange file be built? 1F that
format has options, what values should be used for them?

e Which Filevision file, type, and fields correspond to fields in the ex-
change file?

» Should any special processing be done for each field?

e Which Filevision records should be exported?
we'll use the sampile file called Personnel provided on your Tour Disk
(Import/Export Folder) to explain the process. The Personnel file lists the

current employees of the XY7Z Company. The file has two types: Background
and Employee. The type layout for Employee is shown below:

E[J====—— Info for this Employee: (5 highlighted) =z=}]

IEETN Green, Curt H. B Employee no.
Y I r I 670 S. Hampton Blvd. |
ST Central City | state Zipcode [T

(555) 555-1269

M=Married

Hourly salary Status 3-Single

weekly pay Federal exemptions [
LYWl 01/02/86 State exemptions

[Prev][Hext][Bevert }[Drawing | [E.ini] K] .




exporting
the file

The type layout for Employee includes, among other ficlds, the employee’s
Name, address, and some payroll data. The Weekly pay reflects the actual
take-home pay the employee receives each week. Computing Weekly pay is a
complex process that changes year to year and you have developed a model for
doing it in your spreadsheet program. However, that model invelves the payroll
data you have in the Personnel file. This sample will show you how to export
the data for your spreadsheet model to use to compute Weekly Pay. In the
next chapter, you will see how o import the new Weekly pay back into your
Filevision file.

First, you must launch the file Personnel and then get into Import/Export Text.
»  From the File menu, click Import/Export Text....

The Import/Export Text menu bar switches with the Filevision menu bar.

Edit Types Edgport Options

Import 1
vEuport BE
New Setup BN
lL.oad Setup... #*L
Save Setup... 365
Return to Filevision
Nuit 0
Many spreadsheet programs accept data in the Select Fields... - |
standard exchange formats of either ASCIT (Amer- Select Hecords... %R
can Standard Codes for Information Interchange),
DIF (Data Interchange Format) of SYLK (Symbolic ASCil... #1
Link). For this example we’ll use the SYLK format. BIf %2
SDF ... ®3
»  Choose Export from the File menu. M
Start... %6

»  Choose SYLK from the Export menu.

There are no options to choose for formatting SYLK files, so that’s all you need
to do,

»  Choose Select Fields... from the Export menu.
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A dialog appears showing the list of fields available for the Employee type and
a list to let you specify where those fields go in the exchange file. You can
scroll through either list using the scroll bar for that list. If you scroll the
Employee ficlds down, you will see a bullet next to Name indicating the field
currently used by Filevision for sorting Employees.

File-name: Perscnnel
Type-name: Employee Order of imported fields

City
Employee no.
Federal exemptions
Hourly salary
Link

* Name
Phone no.

= LA L N -

[ selectan | [ selectan |

[JFite begins with a list of field names.

The fields your spreadsheet model requires in order to compute Weekly pay
are: Hourly salary, Status (Married or Single), Federal Exemptions, and
State Exemptions. In order to know which employee you are computing
take-home pay for, you also need the Name. Here's how 1o specify which
fields go in the exchange file and their order (You will need to scroll the
Emplovee field list to find some of the fields mentioned below):

+ Click Name {o select it. Choose Append field from the Edit menu.

= Select Hourly Salary and choose Append field from the Edit menu.

- Select Status and choose Append field from the Edit menu.

+ Select Federal exemptions and choose Append field.

»  Select State exemptions and choose Append field.
The: five fields that you selected are now listed as fields 1 to 5 in the exchange

file. The section starting on page 208, a reference about the Select Fields
dialog, explains several other commands you can use to build this list.
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The data in salary and exemptions fields is numeric; that is, it contains only
numbers. If you have entered the data in a form that includes only digits, an
optional sign, and an optional decimal point, thern Import/Export Text will send
it to your spreadsheet as numeric data. However, if you have included com-
ments, commas, dollar signs or other characters along with the numeric data, it
will be sent as textual data. You can instruct Import/Export Text to remove all
non-numcric data from a field. Although the Personnel file has only numeric
data for these fields, we'll show you how that's done.

= Click field “2 Hourly salary” on the exchange file list and choose
Field Setup... from the Edit menu.

The Field Setup dialog appears. Several options are grayed in the dialog.
These options are for use with other data formats,

Field setup for 2: "Hourly salary”:

Fipis w3l i charapiersh
O et slign data b (g,
O fenter duta in fskl
O fight align deln in fleld

I Fad charagien

[] Format data numerically.
Mumber of digits to right of decimasl point:
[ suppress ading veraas.
[] fispiany simn waitng,

Indicate missing data with: | |

[ cancel | [Prev field | [Nent field | [ Done |

« Click Format data numerically and enter 2 for Number of digits to
the right of the decimal point.

»  Click Next field for Field setup for 3: “Status”. It needs no special
processing.

+  Click Next field for Field setup for 4: “Federal exemptions”. Click
Format data numerically and enter 0 for Number of digits to the
right of decimal point.

«  Click Next field and do the same for Field setup for 5: “State ex-
emptions”.

« (lick Done on the Field Setup dialog.
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» Click Dane on the Select Fields dialeg.

Three of the five fields in the exchange file are set up 1o be exported in the
numeric format. The normal setup for Fields “1 Name” and “3 Status” was not
changed and their data will be exported as regular text.

. Choose Select Records... from the Export menu.

A dialog appears allowing you to choose which Employee records to export.
The sample Personnel file has been prepared with several, but not all,
Employee records highlighted. You can choose either option.

Select records 1o edport based on the following:

@& Enport all Empioyee records.
(O Euport oniy ighlighted Employee records.

I Bow't export nuH records.

« Click Done.

You are now ready to start the process of exporting data to your exchange file.
The rest of the work will be done by Impornt/Export Text. Here’s how te start it:

+  Choose Start... from the Export menu.

A dialog appears for you to enter the name of the exchange file.

0y Califmnis

Oy Bate Caltuintny
T Binosaurs

< Fitewisiang

N Pertodic hard
O Farspuned

Export records to:
lEmpIuyee Datq | Cancel

Hitpa




Importing data

+ Type ‘Employee data” and click Save. If a file called Empioyee
data already exists on that disk, confirm that you want to replace
existing “Employee data”? by clicking Yes.

Import/Export Text displays a dialog showing its progress as it exports data,
You can cancel the process at any time by clicking Cancel.

Exporting record |3 | of |5 |

Name: Jones, Allan Jr. l

*  When the process is complete, choose Return to Filevision... form
the File menu.

You could now use your spreadsheet model to operate on your Employee
data to compute Weekly Pay. On your Set-up Disk, the file “New Weekly
pay” has been prepared as if you had done that. You’ll see how to import that
data into your Personnel file next.

Importing data means adding data created by another program into an existing
Filevision file. There are several choices you make to control how this happens:

» In what standard format is the exchange file? If that format has options,
what values should be used for them?

=  Which Filevision file, type, and fields correspond to the fields in the
exchange file?

e Should any special processing be done for each field?
» How should Filevision records and their highlighting be affected?

We'll use the sample file called Personnel on your Set-up Disk to explain the
process. The Persennel file lisis the current employees of the XYZ Company.
The file has two types: Background and Employee. The Type layout for
Employee is shown on the next page. It includes, among other fields, the
employee’s Name, address and payroll information. On page 193 you saw how
to export the dara needed by your spreadsheet program to compute the current
(take-home) Weekly Pay. In this section you will see how to import the newty
computed Weekly pay back into the Personnel file. The file New Payroll data
on your Set-up disk contains the result of the spreadsheet computation,

Part 10. Importing and Exporting Text 197



importing
a file

choosing the
format to
import data

198 Filevision IV

With the Personnel file loaded and running:
+ From the File menu, click Import/Export Text....

The Import/Export Text menu switches with the Filevision menu.

| & iiEW Edit Types Import Options

+Iimport ®1

Export $BE

New Setup 3EN _

Load Setup... L Select Fields... ®n-

Sape Setup... ¥#S Select Records... ¥R

Return to Filevision vASCI...

Quit %0 oIF *2
SOF ... *E3
SYLK 84

«  Choose ASCII from the Import menu.

Start... %06

The dialeg box below appears:

Process ASCII files for the folicwing programs:

O Filevision® 11! O Excel

¢ 0B Master (Import only) O Jazz

O FileMaker

O Heliy O Macllrite, etc.
) Microsoft File

O Omnis 3

O DverVUE 2.0
O PFS:File (Import only)

In the export text section, you provided the data to the spreadsheet program in
SY1K format. However, many database programs don’t support the SYLK
standard. So we have decided to show you an alternative: importing data using
the ASCI format for files. In the New Payroll data file, each Employee record
consists of three fields: Name, Weekly pay and As of— a field indicating the
date the Weekly pay was last updated. Fields are separated by tab characters,
and records are separated by carriage return characters. You need to specify
these parameters to Import/Export Text.

« Click Other to set up the parameters for the New Payroll data file.



choosing the
Type and fields

The dialog box below appears.

r Process ASCII files as follows:

@ Delimit nul fields and fields with special cheracters.
{ Delimit all fields.

 Delimit alphabetic fields.

{_ Do not delimit any fields.

Record separator: [“m |

Field separator: _:T— |
Field delimiter:
Ignore these characters: |0-"I,"n-31 l

= Click the Do not delimit any fields button.

To Delimit means to surround the data in the field with a special character. That
character is called the Field delimiter. In our case, the data values for Name,
Weekly pay and As of are all characters you can type on the keyboard and
they do not include either tab or a carriage return. That way, Import/Export
Text can tell when the data in each field and each record end. However, if the
data did include a tab or carriage return, the program could not tcll the differ-
ence between a carriage return in the data and a carriage return indicating end
of a record. In that case you would need to tell Import/Export Text that fields
were delimited and choose the field delimiter character.

+ Enter the value: 13 (carriage return) for Record separator, 9 (tab)
for Field separator, and 0-31 for kgnore these characters. The
Field delimiter is not used.

When you need to enter a character code in an Import/Export Text dialog, you
can do it in one of several ways. Appendix G explains them all. Briefly, vou
can always enter the decimal value of the character code you want and that's

what we are doing here.

. Click Done on the format parameter dialog,

. Click Done on the ASCIH dialog.

Choose Employee from the Types menu.

+  Choose Select Fields... from the Import menu.
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A dialog appears showing the list of fields available for the Employee type and
a list you use to specify which fields occur in the exchange file. If you scroll the
Employee fields down, you will see a circle next to Name indicating the fietd
currently used by Filevision for sorting Employees. When you import data you
can have Import/Export Text match new data against existing records by com-
paring their sort field values. In fact, we'll use that feature next.

Fite-name: Personnel
Type-nama: Employee order of imparted fields
Employee no. 1 Name
Federal exemptions 2 Weekhy pay
Hourly salary 3 As of
Link 4
* Name 92
Phone no. 6
Stafe T
[ selectali | (" selectan |

[J File begins with a list of field names.

«  Click Name to select it. (You will need to scroll the Employee field
list down to see Name.) Choose Append Fields from the Edit menu.

+  Select Weekly pay and choose Append Fields from the Edit menu.
= Select As of and choose Append Fields from the Edit menu.
This instructs Import/Export Text that Filevision's field Name corresponds to

the first field of the New Payroll data file, Weekly pay corresponds to the
second field, and As of to the third.

«  Click field 2 Weekly Pay and choose Field Setup... from the Edit
menu.

The dialog box appears (next page).



Selecting the
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modify records
and their
highlighting

Field setup for 2: "Weekly pay":

Fiold wsigih {in «haraniarsh
O ieft align date in Oald,
Oy enter daln in figld
O Right alige dals in field

Pad charaoten

[JFformat data numerically.
Number of digits to right of decimal point:
[ suppsass tsading 2araas,
(] sspiay sign trailing.

Indicate missing data with: | |

[ Cancel ][Preu field] [Ne:-:t field][ Done ]

This dialog allows you to establish special processing for each field. For this
example, the program that made the New Payroll data file shows the Weekly
pay accurately o $0.01. However, you want Weekly pay values in the File-
vision file to reflect only whole dollar amounts. To convert the data correctly,
do the following:

+ Click Format data numerically and enter 0 for Number of digits to
the right of decimal point.

Click Done on the Field Setup dialog.

Ciick Done on the Select Fields dialog.

« Cheose Select Records... from the Import menu.

A dialog appears allowing you to specify how you want new data to affect
Filevision records and what you want to happen to highlighting. Tn our
example, Employees listed in the New Payroll data file should correspond o
records in the Personnel file. However, there are more fields in the Filevision
Employee record than merely Name, Weekly pay and As of. ‘Therefore, you
should instruct the program to change only those. But, if a Name in the
exchange file does not match any existing record, add it anyway.
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Process imported data records based on the following:

@ Add all imported data as new records.

(} Update matching records; otherwise add new records.
(") Update matching records; otherwise disregard.

(O Replace matching records; otherwise add new records.
) Replace malching records; otherwrise disregard.

@ Do not change highlighting.

(rMake all new or changed records highlighted.

() Make only new records highlighted.

(> Make only changed records highlighted.

{yMake all new or changed records NOT highlighted.

»  Click Update matching records, otherwise add new records.

After the data has been updated, you will probably want to browse through the
Personnel file in Filevision and look at the new information. To help you do
this:

«  Click Make all new or changed records highlighted.

» Click Done.
You are now ready to start the process of importing new data. The rest of the
work will be done by Import/Export Text. Here's how to start it:

+ Choose Start... from the Import menu.
A dialog appears listing the files available to import data from.

+ Select the New Payroll data file and click Open.
Import/Export Text displays a dialog showing its progress as data is imported

from the file. You can cancel the process at any time by clicking Cancel, but
data already imported will have been added to the file. Remember, if you are

going to make changes to your files, it's a good idea to back them up first.

Importing record li——___1

Name: Pole, Anne B. J




Details of
Importing and
Exporting

File menu

Import

Export

+  Choose Return to Filevision from the File menu. You can now use
Filevision to browse through the Personnel file and look at the new
data.

This section contains two parts. The first part tells you haw to use each of the
functions in Import/Export Text. You should use the samples with Exporting
data and Importing data as a guide 1o what steps you need to do to import or
export data. Then, if you have questions about the details of those steps, refer
to the explanation here.

The second part contains several reference tables. In particular, if you have a
question about how to use Import/Export Text with another program, check the
list of programs and suggestions in Appendix F, How to use Import/Export
with other programs.

Use this to select berween Import and Export. This also allows you to save
and lead Import and Export Setups. After finishing with Import/Export Text,
return to Filevision from the File menu.,

+ Choose Import to tell the program that you want to import data into
the current Filevision file.

To import data, you must first have prepared an exchange file with the data you
want to import, When you choose Import, the Export menu disappears from
the menu bar and the Import menu replaces it.

+ Choose Export to tell the program that you want to export data from
the current Filevision file.,

Import/Export Text will produce an exchange file for use with another program.

When you choose Export, the Import menu disappears from the menu bar
and the Export menu replaces it.
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New Setup When vou first enter Import/Export Text, all of the choices you can make are set
to standard values.

« Choose New Setup when you want to restore these standard
values. If you have made some important choices of parameters,
you may be asked to confirm this command before it is actually
done.

Load Setup_ . After you have set up Import/Export Text to work, you may want to save the
values of your choices as a “setup” (See: Save Setup... below).

« Choose Load Setup... when you want to restore the choices of an
earlier setup that you have saved.

When you choose Load Setuap... you are shown a list of setup documents.

0) Daiby stogk 1 o KD40
D New Radrasses _ »+  Select the setup docu-
2 Sales Upload ment you want and click
{0 Setup file Open
5
Save Setup... - Choose Save Setup... to save your current Import/Export Text

choices in a document that you can later use {See the discussion
above under Load Setup...).

(3 Baihg +iotk quotes [ = HDd40
0y Moy Bedresees _
5 Sates Bpead +  Type in a name for your
G Setup Hle setup document and
] click Save.
Save curreni setup in:
Return to « Choose Return to Filevision to return to exit Import/Export Text.

Filevision
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Edit menu

Cut, Copy,
Paste and Clear

Append Fields

Field Setup...

+ Choose Undo when you want to reverse the last command you gave
to Import/Export Text.

In most cases, commands you give can be “undone”. When they cannot, the
program asks you to confirm your command before proceeding.

Cut, copy, Paste and Clear are only available for the Select Fields dialog.
You can use them along with “Append Field(s) to help build the list of fields in
the exchange file.

Cut is available when you have selected one or more fields from the list in the
exchange file. Cutting removes the field assignments for the selected fields and
clears their field setup parameters to standard values. A copy of the information
replaced the current contents of the Clipboard. You can Paste the contents of
the Clipboard into your Scrapbook for later use.

Copy is available when you have selected one or more fields from either list.
Copying replaces the current contents of the Clipboard with values from the

fields selected.

Paste appends fields to the list of fields in the exchange file. You must first Cut
or Copy field selection and setup data to the Clipboard.

Clear acts the same as Cut, except that it does not affect the Clipboard.
Append fields lets you add one or more Filevision fields to the list of fields in
the exchange file.

+  Select one or more fields from the list of Filevision fields.

« Choose Append fields from the Edit menu.
A shortcut for Append fields is to double-click a single Filevision field. This

means select the field and then append it to the exchange file list.

Field Setup... allows you to set special processing parameters for a field on the
list for the exchange file. It is available whenever you have selected one field
from that list.

+ Select one field from the list of fields in the exchange value.

»  Choose Field Setup... from the Edit menu.
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A shortcut for Field Setugp... is to double-click a single field in the exchange file
list, ‘This means select the field and then proceed as if Field Setup... were
chosen.

When you choose Field Setup... the following dialog appears: (Not all parame-
ters are available for all data formats. Check the explanation for each parameter
10 see when it is available and what it is used for.)

Field setup for 2: "Hourly salary":

Field width (in characters):
O Left align data in field.
O Center data in field.
) Right align data in field.

Pad character:

[] Farmat data numerically.
Number of digits to right of decimal point:
O suppress leading zeroes.
O pisplay sign trailing.

Indicate missing data with: r l

( cancel ] [Prev field | [Neut field]f Done |
—

+  Enter the Field width (in characters) for this field.

This item is available only if you have previously chosen SDF from the Import
or Export menu and not chosen the Delimit fields option. You can specify a
vahue between 1 and 2000 characters. A value of ¢ indicates that you don’t want
to use this field.

+ Choose Left align data in field, Center data in field, or Right
align data in field for this field.

These choices are available only if you have chosen Export and SDF, and have
not chosen the Delimit fields option. They instruct Import/Export Text how to
align daia shorter than the Field width you have entered for the field.

« Enter a character code for the Pad character for this field.

This choice is available only if you have chosen Export and SDF, and have not
chosen the Delimit fields option. The Pad character is used to fill fields that
have data that is shorter than the Field width, according to the alignment you
choose.



Types menu

» Choose Format data numerically whenever you want data for this
field treated only as numbers.

Filevision fields can contain numbers, text, pictures or a combination of num-
bers and text. Some other programs require fields containing numbers to have
no additional text and may not allow other characters, such as commas (as thou-
sands separators) or currency svmbols in the number. Format data numeri-
cally uses the decimal positicning you specify below to re-format the data
numericaily, It can be used while importing or exporting data.

As a convenience, when data is exported in DIF or SYLK format, numeric data is
identified as such even if you don't choose Format data numerically. How-
ever, if you have Filevision data that includes commas, currency symbols, or
other textual comments and you want it treated by another program as a num-
ber, you must choose Format data numerically for those fields.

* Enter0,1,2,3, or 4 for the Number of digits to right of decimal
point whenever you choose Format data numerically. If you enter
0, no decimal point is output.

»  Click Suppress leading zeroes to affect formatting numeric data on
export.

This choice is available only if you have chosen Export and SDF, and have not
chosen the Delmit fields option. It is used only if you have also chosen
Format data numerically.

+ Click Display sign trailing if you want a “+” or “-" sign output as the
rightmost character of the field.

Normally, the minus sign is displayed to the left of the digits of a number and no
plus sign is displayed; however, some programs expect the sign on the right,.
This choice is available only if you have chosen Export and SDF, and have not
chosen the Delimit fields option. Tt is used only if you have also chosen
Format data numerically.

+ Click Next field, Prev field, Cancel, or Done as appropriate.

The Types menu lists the Types for the current Filevision file. The currently
selected Type is shown with a check mark.

+ Choose a Type from the Types menu to change the current Type to
that Type.
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Note: When you change types, all Select Fields and Field Setup parameters
are cleared to their standard values. If you want to save some of these values
for use with the new type, first use Copy to put those values on the Clipboard.

Select Ficlds... is avajlable whenever you have selected a Filevision file and
have chosen a type. When you choose Select Fields... the following dialog

appears:
File-name: Tour —-ll

{ Type-name: Townhouse Order of imported fields
¢ Address
flvailable?
Comments
Link
Madel
No. of bathrooms
No. of bedrooms

= S N L NN -

I [ setectall ] [ selectan )

[} File begins with a list of field names.

The left list shows the Filevision fields that you can select to import ot export
data. They are listed alphabetically. Only data fields are listed (not annotation
fields). And only fields with a name are included. If you have two fields with
the same name, they will both appear, but you will not know which is which.
The circle to the left of one field shows the field that is currently being used by
Filevision 1o sort records of this type (the sort field).

The right list shows the fields in the exchange file. There can be up to 255 of
them. You use this dialog to choose which Filevision fields are associated with
the fields in the exchange file. Here’s how:
+ Click a field to select it.
- Hold down the Shift-key and click more fields to select them too. If
you click a field that is already selected, it is removed from your
current selection. You can select fields from only one list at a time.

»  Click and drag the mouse to select multiple fields.

. Click Select all under either list to select all fields of that list.



Select records...
(importing)

+ Hold down the Option-Key, click and drag a field in the exchange
file list to move it to a different position in the exchange file list.

»  Double-click a field in the Filevision list to append it to the exchange
file list.

+ Choose Append Fields from the Edit menu to append selected
Filevision fields to the exchange file list.

* Choose Cut, Copy, Paste or Clear from the Edit menu to remove or
append selected fields from the exchange file list.

* Choose Field Setup... from the Edit menu to change the special
field handling rules for a selected field in the exchange file list.

» Click Cancel or Done as appropriate.

Notes: the easiest way to build the exchange file list is to double-click the
Filevision fields in the order you want them to occur in the exchange file. If you
make a mistake, choose Undo from the Edit menu or click Cancel and then
Select Fields... again.

If you have special field handiing rules, first build the full exchange file list: then
double-click field 1 in the list and use Next field on the Field Setup dialog to
specify the rules for each field.

Advanced applications: You may leave fields in the exchange list unused. Hold
down the Option-key and drag fields to set up unused fields where you want
them, or use Cut or Clear. If data is imported for an unused area, it is ignored.
If data should be exported for an unused field, a null data value is provided by
Import/Export Text. You can use this feature to ignore spreadsheets when im-
porting using DIF or $YLK format. You can also provide blank columns when
exporting data to spreadsheets.

Any Filevision field may appear in the exchange file list only once.

This command allows you to specify what happens to records as they are
processed from the exchange file. There are two general choices you may
make: what happens to the records themselves and how highlighting is af-
fected. Remember that the Field Setup command in Filevision itself affects field
values in new and existing records. Initial text and Copy from previous
record options affect new records and Compute using a formula affects field
values in all records. The choices for processing imported records are described
next:
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Process imported data records based on the following:

@ Add all imported data as new records.

) Update matching records; otherwise add new records.
7} Update matching records; otherwise disregard.

O Replace matching records; otherwise add new records.
(O Replace matching records; otherwise disregard.

{® Do not change highlighting.

O Make all new or changed records hightighted.

() Make only new records highlighted.

) Make only changed records highlighted.

) Make all new or changed records NOT highlighted.

Field

Add all imported data as new records:
This choice means that all imported data is treated as new data and
additional records are added to the file.

Imported data Matching data? Result

Add all imported data as new records:

{New record)

Name{Sort) Box (Doesn’'t matter) Box
Height 13 13

Width 10 10

or

Update matching records; otherwise add new records:

Update matching records; otherwise add new records:

Each new record received is compared against existing records in the
Filevision file. If the sort field of the imported data matches the sort
field of any existing record then it is treated as a change to that record.
Otherwise, the imported record is added as a new record to the file.
Updating a record leaves fields in the “old” records that do not appear
in the imported data unaffected. Replacing a record removes all fields
from the old record and them adds the imported data. See the table
below for examples.

(Existing record)

Name{Sort) Box Box Box
Height 13 15 13
Width {Not in data) 10 10



{New record)

Name(Sort) Cannister (No match) Cannister
Height 19 19

Width (Not in data) (No data in field)

or

+ TUpdate matching records; otherwise disregard:
Each new record received is compared against existing records in the
Filevision file. If the sort field of the imported data matches the sort
field of any existing record then it is treated as a change to that record.
Otherwise, the imported data is disregarded and the file is not changed.
Updating a record leaves fields in the “old” records that do not appear
in the imported data unaffected. Replacing a record removes all fields
from the old record and then adds the imported data. See the table
below for an example.

Update matching records; otherwise disregard:
{Existing record)

Name(Sort) Box Box Box

Height 13 15 13

Width {Not in data) 10 10
Name(Sorn) Cannister {No match) (Record not
Height 19 added to file)
Width {Not in data)

or

* Replace matching records; otherwise add new records:
Each new record received is compared against existing records in the
Filevision file. If the sort field of the imported data matches the sort
field of any existing record then it is treated as a change to that record.
Otherwise, the imported record is added to the file as a new record.
Replacing a record removes all fields from the old record and then adds
the imported data. Updating a record leaves fields in the “old” records
that do not appear in the imported data unaffected. See the table
below for an example.

Replace matching records; otherwise add new records:
{Existing record)

Name(Sort) Box Box Box
Height 13 15 13
Width (Not in data) 10 {No data in
field)
{New record)
Name(Sort) Cannister (No match) Cannister
Height 19 19
Width {Not in data) 10 {No data in
field)
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or

Replace matching records; otherwise disregard:

Each new record received is compared against existing records in the
Filevision file. If the sort field of the imported data matches the sort
field of any existing record then it is treated as a change to that record.
Otherwise, the imported data is distegarded and the file is not affected.
Replacing a record removes all fields from the old record and then adds
the imporied record. Updating a record leaves fields in the “old”
records that do not appear in the imported data unaffected. See the
table on the next page for an example.

Replace matching records; otherwise disregard:

(Existing rec.)

Name(Sort) Box Box Box

Height 13 15 13

Width {Not in data) 10 (No data in fid)
Name(Sort) Cannister {No match) {Record not
Height 19 added to file)
Width (Not in data)

If two records have the same data for their sort fields, Import/Export Text
matches the first one found. But Import/Export Text matches a particular
record only once per Start... command.

The following choices affect how highlighting is changed by the import process.

You can use highlighting to provide an easy key to later browsing through the
records that are affected by the process. Remember that only one set of high-
lighted records can be in effect at a time. So, if highlighting is changed because
of the import process, any highlighting that was in effect before the process is

lost.

or

or

Do not change highlighting: New records are added, not high-
lighted. Existing records remain in their current highlighted or non-
highlighted condition.

Make all new or changed records highlighted: Any existing
highlighting is first cancelled. Then new records are highlighted and
any existing records that are updated or replaced are also highlighted.

Make only new records highlighted: Any existing highlighting is
first cancelled. Then, new records are highlighted. However, existing



records that are merely updated or replaced are left without highlight-
ing. You can use this highlighting technique to find imported data
which did not match existing records.

or

 Make only changed records highlighted: Any existing highlighting
is first cancelled. New records are added without highlighting. How-
ever, any existing records that are updated or replaced are highlighted.

or

» Make all new or changed records NOT highlighted: Any new
records are added without highlighting. Existing records that are
updated or replaced are also marked NOT highlighted. Otherwise,
highlighting for existing records is not affected.

+ (lick Done when you have completed your record processing

choices.

Select records... This command allows you to specify which records of the current type are
¥ p
(exporting) included in the exchange file.

$elect records to export based on the following:

{® Export all Townhouse records.
) Export only highlighted Townhouse records.

] Don't edport null records.

¢ Export all Townhouse records: Choose this to include all records of the
current type.

or

* Export only highlighted Townhouse records: Choose this to include
only highlighted records of the current type.

ar

¢ Don’t export null records: When you use the Select Fields dialog to
choose which Filevision fields are included the exchange file, you may
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decide to include only some fields of the current type. So there is a chance
that some records you have included for export may have no data in any of
the fields you have chosen. You can click Don’t export null records to
instruct Import/Export to disregard those records and not include them in
the exchange file. This option is not used when exporting DIF format files.

+ Click Done when you have completed your choices for selecting
records.

ASCII... This command sets the format of exchanged data to ASCIL. Import/Export Text
presents you with a list of programs which support the ASCIT format.

Process ASCII files for the following programs:

O Filevision® I1U () Excel

(O DB Master (Import only) o dazz

O FileMaker

O Helix O MaclUrite, etc.
(O Microsoft File

) Bmonis 3

) OuerbUE 2.0
) PFS:File (import only)

« Click the target program of your exchange to set up the correct parameters.
Please check Appendix F for further information on exchanging data with
these program formats.

or

e If the program you want to exchange data with does not appear in the list
or you wish to control the parameters yourself, click Other for the
secondary ASCII dialog.

Process RASCII files as Tollows:

@ Delimit null fizlds and fields with special characters.
O Delimit all fields.

) Belimit aiphabetic fields.

{ Bo not delimit any fields.
fRecord separator:
Field separator: “1
Field delimiter: "
Ignore these characters: (B-"1"n-31 |
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ASCII files do not have a single, universal format like DIF or SYLK files do. You
need to specify certain parameters to the Import/Export program so that it can
create or interpret ASCII files correctly. These parameters are explained on the
next page.

Record separator: This character indicates the end of a record.
Typical choices for this parameter are 12 {form-feed) or 13 (carriage
return). See the discussion in Appendix B, Entering character codes,
for help on entering data in this item.

Field separator: This character indicates the end of a field or data.
The last field in a record is not followed by a field separator; instead it
is followed by a record separator. Typical choices for this parameter
are 9 (tab), 13 {carriage return), 43 (comma).

Field delimiter: For some choices of record and field separators, a
single ASCIT character can be used either as a record separator or a field
separator or normal character of data. In order to interpret the charac-
ters correctly, ASCII file specifications may require that data fields be
surrounded with delimiting characters. You choose how this feature is
used by commands explained below. Typical choices for the field
delimiter are 34 (double-quote marks) or 39 (single-quote marks).

Ignore these characters: 'This feature allows you to disregard certain
ASCII characters found in field data. You may want to use this to
remove currency symbols, commas, carriage returns, characters with
diacritical marks, or other characters you choose from field data.
Filevision data fields may include all characters with decimal codes of
32 or greater and the carriage-return character (13). Any other charac-
ter code (0 to 12 and 14 to 31) is removed automatically from imported
data. If you are considering using this feature, you may also wantto
look at the Translate... command on the Options menu.

Special rules affect how you enter the list of character codes you want to ignore.
You can use most normal rules for entering character codes except for the two
characters comma (*,”) and minus (“-”). Enter them as 44 and 45, respectively.
Use commas to separaie character codes you enter. Use a minus to indicate a
range of characters. For example, to enter “control codes through 0 through 31
and the dollar, yen, and sterling symbols”, you would type “0-31, $, ¥, &

Delimit null fields or fields with special characters: Null fields
are fields that have no data in them. Special characters are ail charac-
ters except the following: space(“ <), plus (“+™), minus (*-"), decimal
point (“.), the digits, and the letters of the alphabet. Fields with special
characters in the data will have the field delimiter character placed
around them. Also, if the field delimiter character is found in the data,
it will be duplicated. (This is called an “escape sequence”).
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or
» Delimit all fields: This option surrounds alt fields with field delimiters.
or

« Delimit alphabetic ficlds: Because numeric fields are never null and
contain only the digits, decimal point, and sign characters, they seldom
need to be delimited. This option delimits all non-numeric fields but does
not delimit number fields.

Qr

« Do not delimit any fields: Choose this option only if the record and field
separator characters cannot occur as normal data characters.

DIF (Data Interchange Format) is a specification for formatting data that was
first used by Software Arts in its program VisiCalc. This format is currently
supported by several spreadsheet and data-base programs for exchange of data.

» Choose DIF to specify a Data Interchange Format exchange file.
SDF (System Data Format) is the specification for exchanging data with dBase-II

and dBase-11I programs. It is also supported by several Macintosh data-base
programs as well. When you choose this format the dialog to the tight appears:

Process SOT files as follows:

B< Delirnit Tields.

Field delimiter: E

e Click Delimit fields to choose whether fields are separated or not in the
data. If you do not choose Delimit fields, you must specify the number of
characters that each field occupies in the data stream. You do this on the
Field setup dialog. The Field setup dialog is available when you have
selected an exchange file field on the Select fields dialog. For SDF files,
the field separator character is always comma (“,”) and the record separator
character is always carriage return (13).



SYLK

Start...

e Enter the code for the Field Delimiter. Standard dBase-II and -III allow
only single quote (), double quote (), and comma (*,”). Comuma is permit-
ted only when dBase exports data. If you select comma, no delimiter is
used, since comma is already used as the field separator. Import/Export
will automatically remove commas and carriage returns (13) from data.

SYIK (Symbolic Link) is a specification for formatiing data that was first used by
Microsoft in its program Multiplan. This format is currently supported by many

Macintosh programs.

» Choose SYLK to specify a Symbolic Link exchange file.

«  Choose Start... from the
Import or Export menu to
begin the process after
you have set up all neces-
sary parameters. If you
are importing data, the
dialog to the right appears,
listing the files with data to
import:

[0 California = HD4D

03 Date Calcuiater —

01 Dinosaurs
0O Periodic Chart _
o Suicide Sub
[ Tour Folder
0 U.5. Map

»  Select the file that has the data you want and click Open.

Import/Export Text displays a dialog showing its progress as data is imported.
You can cancel the process at any time by clicking Cancel, but data already im-

ported will have been added to the file.

If you are exporting data, the dialog
to the right appears instead.

- Enter a name for the
exchange file and click
Save. i a file with that
name already exists,
confirm that you want to
replace it.

o Galttarnia — HD40

3 Bate Calcuinloy -

[y Binasauty

& Filestsignd Tive

D Parkadic hert

i Personaei

Exporl records to:
l Cancel

Export displays a dialog showing its progress as data is exported. You can
cancel the progress at any time by clicking Cancel.
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Clipboard
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(Import/Export Text)

Translate...
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You can also impaort or export <data directly from the Clipboard rather than use a
field. To do this:

«  Hold down the Option-key while you choose Start... from the
Import or Export menu.

Import/Export Text displays a dialog showing its progress as data is imported
or exported from the Clipboard

'The Translate... dialog allows you to control some special features of the
exchange file, These features are not usually required, but are useful in certain
areas,

Translate files as follows:

Translate into End-0f-File Char

[ ]

@ Keep CR characters.
_J Convert CR to Space.
) Delete CR in exported data.

[ Append LF to CR.

The two columns of five entries let you choose up to five characters that you
want to translate into other characters. This feature allows you to change say, a
vowel with a diacritical mark into a normal ASCII character for programs that do
not support the Macintosh extended character set.

«  Enter the character code that you want translated in one of the five
rows under the first column.

+ Enter the character code that you want to be translated to in the cor-
responding row of the second celumn. If you leave the second
column blank, Import/Export will merely delete instances of the first
character from the data.

Some operating systems indicate an end-of-file by a special character in the
data. Dara after that character in the file should be ignored.



Convert to
upper case

«  Enter the character code that you want used as End-Of File Char.

If you don't use this option, Import/Export Text will use the standard Macintosh
end-of-file indication. If you do enter a character code here, all dara, after the
end-of-file character is found, will be ignored while importing and the character
will be put at the end of all regular data while exporting.

The following options are available only when you export data.

or

ar

Click Keep CR characters if carriage-return characters (13) that you
entered in Filevision fields are to remain in exported data. Beware that
some data interchange formats automatically remove carriage-returns from
the data. Also some programs do not allow carriage-returns in the data.
Check your target program specification.

Click Convert CR to Space to ensure that no carriage-return characters
(13) are included in the field data. They will be replaced by spaces (32).

Click Delete CR in exported data to ensure that no carriage-return
characiers (13) are included in the ficld data. They will be deleted from the
data.

Click Append LF to CR if the target program you are sending  data to
expects the sequence carriage return {13), line-feed (10) to indicate a line
scparator.

Whenever any of the Translate options are in effect, you will see a check mark
next to the Translate... item on the Import/Export Text Options menu.

. Choose Convert to upper case to have Import/Export convert all
lower case letters {“a” through “2”) to upper case letters ("A” through
“Z"). Choose it again to disable this option.

Whenever Convert to upper case is in effect, you will see a check mark next
to it on the Import/Export Text Options menu.
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11. Linking Filevision IV Files

Any object can be made to “link” to another Filevision file, A link is a way of
quickly and smoothly closing the current file and opening another one, all
automatically and without using the File menu.

Why are links so important?

First, linking is a way to connect related files. You can use Link to get an
“exploded view” of a part of your file, like the city insets on state maps. You can
also use linking to get more detailed data about an object that just won't fit into
one record. For example, a large company using a main file showing the
company organization and a link for each division, or a link file of vendors for
each segment of the firm.

Second, links are convenient. If you have several files that you use often, Link
offers 4 way to switch rapidly from one to the other.

Creating *  From the Change Layout display, click Options.

a link

220

You'll see the Options dialog box:

(ptions for this type:

> Hide link field ) Double-click goes to Info display
(ﬂsnow link field ® Double-click goes to Link file

+  Click Show link field and the desired Double-click instructions.

+ (Click Done.

. When you're on the Info display for a record, fill in the Link field with
the name of the file you want that object to link to:

T So Cal Fwy System |

Filevision IV



Make sure that you enter the exact name of the file you’re linking to. Even
spaces preceding file names count, although the Macintosh doesn't distinguish
between upper and lowercase letters in a file name.

You can have a different link for each ohject or record in a file. For instance, if
your file contained a total of 1,000 records, you could link te any of 1,000 files
each of which could further link to additional files.

ARIZONA RVIATION MAP - Actual Size

LT SRV EGIAS o
A~

b == info for this

RirSeruc Pts: 16 record

CETY NAME BOARDINGS/YEAR RREIY
BOLLIS
e ra TUCSON INTL AIRLINES [TENIEINGIN

All files have link fields, but the link field may be
hidden for all objects of a Type. You can make the
fields reappear using the “Show link field” option on
the Change Layout display; for more details, see
hiding or showing the link field, pages 173 and 220.

PHOENX TUCSGNALP 1

L3 Gl
CliT,

[Prev)[Next](Revert](Drawing Lis]A] E
i Pt 3

AN G E-UES
*

CLICK & LK
us. MapP

SRET

ARIZONA AVIATIO

AirServe Pts: TUCSON INT'L|

il s el oo Cinn) 51

GENERAL ALIATION

TUCSON PRRKING RPRON - Actual §ize

TUCSON ALP - Actual Size

PARKING

EIIEYN Tucson Farking Apron |

BTy TUCSON FARKING APRON
Ereo] ext) (Bever U(Draming JLinkd ] ]

i

i o] ] ST i I

<

TUCSON INTERNATIONAL AIRPORT
GENERAL AVIATION PRRKING RAPRDN

i B IR i A T

Y v
-4 | s

Y]

- a o b ase

E[CE Info for this AC TIE DOIBN: 122 records

SPOT NUMBER | Fad H-NUMBER
JWHER NAHE [ [7E5 ]

STATE OF ARIZONA

1801 w. JEFFERSON 4-426M

[dext](igeer ) {Brasing ) Link) K|}

The aircraft in spot 62's record then links to
the file containing an illustration and all
pertinent information about the aircraft tied
down in spot 62. This could be an actual
gray scale scanned photograph of the plane,

Link P

Tn this example of file linking, the
Arizona Aviation Map is linked to
the Tucson ALP file through the
Tucson record. The Tucson
Parking Apron record links to the
actual Tucson Parking Apron file,

SPOT 62 ) 4= CLICK HERE TWICE FOR INFO_
il FapE] ]

- OHHER IHFO: N-66528
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another file

Returning from
a linked file.
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« Select the object.

*  Click the Link button or double-click the object if the Type's options
are set up 1o link on a double-click.

The file you’re currenily using will be closed and the file named in the Link
field will be opened, all in one quick, smooth action.

+ To return to the last file you used, choose Return to... from the File
menu.

New ... N
Open... %0
Close TUCSON PARKIN...
Save 38
Save As...

Return to TUCSON RLP

Import Graphics...
Export Graphics...

Import/Export Test...
Page Setup...

Page 5Size...

Print Page... U
Print Records... ®e
Quit *®0

Filevision “remembers” the last five nested files that you linked from.



12._ Sort and Find

Up to this point, Section Three has dealt with creating the framework of a file
and filling in records. This part shows some of the miscellaneous information in
working with the Access menu.

Do you want to order objects by a field other than Name— say. Area code or
Zip code? No problem—use Sort by....

Do you need to find a particular record fast. Use Find... (only on the sort field)
for quick access.

Sometimes you'll want objects to be visible but unselectable—background
graphics often fall into this category. Ignore will take care of that, and you can
Activate those graphics just as easily.

The Access Use of the Access menu is ai the heart of
menu Filevision. It includes sorting, finding, high- “Background"s:

lighting, hiding objects, showing objects and Sort By...

ignoring objects. Notice the first entry in the Find... %F

Access menu. It's the currently selected Find Same LR8S

Type's name. Highlight... %H

Highlight Selected %W

All operations listed in the Access menu refer Highlight All {-%A

to the selected Type only, except Show All Hide Selected < %H

Types. If you select Sort By..., you will be Show Selected

sorting the currently selected Type. If you Show Onily These

select Find..., you will be searching in the Ignore

currently selected Type. If you select High- [~

light... you will be highlighting the currently Show H"‘TUD_ES )

setected Type, cic.. Cancel Highlighting 34
Preuious Record {»38P
MNext Record N
info Page *®1
Drawing Page *®0
Link L
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The records of each Type are sorted (ordered) according to the contents of a
particular field. The default sort field is Name, but you can change it to any
field in the Type layout, anytime. The sort order is important for:

» the order in which objects are selected using the Next and Prev buttons

¢ the selection information area—the contents of the sort field are shown there
when an object is selected.

* Find... and Find Same
* Rank inquiries for the Highlight... display

+ To change the sort fieid of the selected Type, choose Sort by... from
the Access menu.

A dialog box apoears, showing the name of the current Type, the current sort
field in that Type and warning you that "You will not be able to undo this
action.” if you proceed.

Sort "Customer”s by:

[Last name ]

You will not be able to unde this action.

« To change the sort field, use the pop-up menu where the field name
is located to select the new sort field.

Credit info:

Current Mailing Address

Bown Payment

First name

Have they already purchased?

Last Contact |

Last name

Link hction.

Maodel

Phone Home
Phone Work .

Remarks

Salesperson
Spouse, children's names




Find...

+ Click Sort.

A progress dialog is displayed that provides the current status for each of the
three sort processes (records input, sorting and records output).

| Quit | Sort input phase, records: 340 l
I Quil Sort outpul phase, records: 500 I

» If you want to cancel the sort at any time prior to its finigh, click the
Quit button.

The sort will be terminated and a dialog box will inform you that your records
are unsorted. Filevision reverts back to the original sort if a new sort is
cancelled. Tf you wish to sort by some other field, 'Use "Sort by..." to resort
them' again.

The records are unsorted.

Use "Sort by..." to resort them.

You can easily locate any object of the selected Type, or any number of objects
with related characteristics, simply by giving Filevision a few clues. All you
need is a word or letter(s) contained in the first 22 characters of the sort field
that you are searching for.

Find... searches the first 22 characters in the sort field (the data contained in the
drawing page information area). Use Highlight... to search for information in
other fields, or to compare text in the sort or any field of up to 8,000 characters.
Highlight... scarches all 8,000.

In this hypothetical example you have a file with records of the Type Client,
and Client records are the companies you're dealing with. You want to look for
a company whose name you only partly remember. It's something like “Finance
Software”, or “Business and Finance”, or “Software and Finance”... You know
only that the name has something to do with Finance.

+ Choose Find... from the Access menu.
A dialog box appears. In this example, we're going to look for all objects of the

Type Client whose Company name field (the current sort field) contains the
word Finance.
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+ Enter Finance in the dialog box as you see below:

Find this Client Company name:

[Finance |

[ Cancel ] [ Find First ] [_Find Next ]

- After the name is filied in, click the Find First button.

Filevision will now look through the Company name sort field of all the
records in Type Client.

Find... selects the first object that matches the conditions you set.

Partial strings (letters within a word), words located only at the beginning of
the field or words that you aren't certain of the spelling can also be searched.
To constrain the search to a first word in the Company name field, enter an up
carat {~) (Shifi-6) before the word Finance:

find this Client Company name:

|’“Finance J

(cancet | (Find First ] [ Find Next |

To find a partial string, use a double period (..) for the unknown or variable
portion of the string: Using Fina.. would find the first occurrence of the words
Finance, Financial or Final.

Find this Client Company name:

ll-'ina..| [

[cancel | [Find First ] [ Find Nest |

—

If you weren't certain of how the company spelled their name (some do use
tricky ways), use an at (@) character for any letters that you are not certain of:
Filevision's Find... function is not case sensitive and will find all occurrences in
either upper or lower case.



Find this Client Company name:

rFina@ce |

(cancel | [ FindFirst | [ Find Next |

+  If you hold down the Shift key when you click the Find First button,
the drawing window will-bring the object into view (if the record has

a graphic object that is off screen).

To find succeeding abjects that match the conditions you set, choose Find

Find Same
S$ame from the Access menu, or Find Next from the Find dialog.

«  If you hold down the Shift key when you choose Find... or Find
Same from the Access menu, the drawing page window will relocate
to bring the object into view if it has a graphic that is not currently in

the viewing area.

Previous Record. Next Record. Info Page. Drawing Page and Link are

other Access _
s provided for Access menu and Command keyv chord access 1o those functions.

menu selection
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13. Highlighting

Highlight...

highlighting
all objects
of a Type

228
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Highlighting lets you find groups of objects based on information contained in
their records.

Da you need to locate all patient records with “April” in the Last checkup field
with length of visit longer than 10 minutes in the Time field? Use Highlight....

Perhaps your needs are quite a bit more specific. You want to produce a
mailing list of all the firms that sent in more than $50,000 worth of orders last
year, OR have been customers of yours for the last three years, AND who come
from the 52600 through 52999 zip codes. IUs a breeze for Highlight... and
you'll see those firms highlighted on the drawing page as well, where you'll
really get some fast insight into your customer base.

The purpose of any filing system is to help you make the best use of the
information in your files. Highlighting does that for you by extracting or
finding only the particular records and objects you need to work with.

For example, in the Tour we had a file full of townhouses and information
about those townhouses. But we only wanted to know about the ones that
were available and in a certain price range.

We used highlighting to set those apart from the others visually as well as to
collect just those records for inspection. Highlighting can be thought of as
giving objcets a visible theme on the drawing page so that they stand out from
the rest.

In slightly more technical terms, highlighting creates a temporary subset of
objects from the selected Type. Once you've isolated the objects by highlight-
ing, functions like Prev and Next operate only on the highlighted records and
objects. You can use Show Only These for ¢ven more emphasis, you can
change just those objects into objects of a diffcrent Type, hide just those objects
so they dor't distract you, and so on. Filevision is designed to make highlight-
ing as instinctive and as flexible as you want.

+ To highlight all objects of the currently selected Type, choose High-

light All from the Access menu.

Those ohjects will be emphasized with a drop shadow, while other objects will
be faded:



all non-highlighted objects /

are faded 1o gray

all highlighted Townhouses ‘/—*@ @ &) @ i | @

are solid color with a
drop shadow

highlighting
selected objects
of a Type

highlighting
some objects
of a Type

( % File Edit Types Access Options TJext Symbols
E =——==—=——o" Brushwood Heights - fActual Size

Dopim bvnaue

] : . : : : :
e G @y

Townhouse: (28 highlighted?

| [Prev)fext) (info) GirsdKi[ ]

If you've selected one or more objects, the Access menu will let you highlight
them.

+ Choose Highlight Selected from the Access menu.

« To highlight objects of the selected Type based upon information in
their records, choose Highlight... from the Access menu.

You'll be presented with this display:

Highlight “Widget™s meeting these conditions:

Naine is

equal to
[} =] [ @ AND —O) OR
|

@ ANE =) 0R

@ Dalye
 Rank (0 to 0)
{ Field

@ AND —(D 0R
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The following sections explain how to fill in the Highlight... conditions.

You're allowed to set up to four conditions at once for highlighting. Each
condition has these four comparison operators available to it:

(equal to}
{greater than or equal 1o},
{less than or equal to),

- (between).

YIAV I

The comparison operators are preceded by

is or
is not

They work on text as well as numbers.

Each condition in a Highlight... can be based on one of three kinds of infor-
mation: a value you enter, a rank, or the data in another field.

« Click Value to compare the value you [Narme |
enter.
For example, like "100" in Sales Order is =] =] [

greater than or equal to 100 or Name in Name

[Thoreau

|

is greater than or equal to "Thoreau”.

@ Palue
(" Rank (0 to 0]
) Field




Rank + Click Rank for a positional comparison
comparison among ali of the objects (only in the sort
field).

Rank can select the first record, the last record or
any record for a specified position(s) in between.

For example, the 10th to 20th largest cities of 75
cities tested (total number of records in the Cities

Type).

Rank works only on the sort field and in this

[Population |

o alue
@ Rank (1 to 73)
{3 Field

example, the Cities Type would probably have to be resorted to the

Population field before Rank could he used.

Field *  Click Field to compare the value in the [State allowances]
comparison selected fleldl {top entry box) with the _ _
value of the field to be compared with iz not
placed in the lower entry box. B :] [ =
For example, the number of State allowances is Federal allgwances |
not equal to the number of Federal allowances.
{1 Ualue
O Rank{l 16 7%
@ Field
example » To set a condition for a specific field, use the pop-up menu(s} to
Highlight select the field{s) used in the conditions.
Color
Link Highlight "Widget™s meeting 1hese conditions:
Name
selected field pop-up menu price N Price is
Size = Tiot aqual to
(Beight
7 [ [ ® AND —O) OR
secondary f.ield pop-up ‘ @ AND =0 OR
when the Field button @® Dalue
is selected. O Runk i ta (B
=) Field  ®ANDB—OOR
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- Click is or is not as appropriate; [is]in this example.

+  Click the comparison operator; |< | in this example.

Price is

Price

less than or equal to

] B [

[ ]|

l@ Value

@ AND — OR

(® AND ={) OR

+ Click Value for a value comparisen in this case.

= Fill in the value; $3,500 in this example.

Highlight "widget s meeting these condilions:

Price is
less than or equal to
$3,500

@ AND — > DR

® AND =) OR

The value appears both at the right of the condition box in the recap box and

in the condition box itself.

In "long hand®, the above example would read, "Highlight alt Type Widgets
whose Price is less than or equal to $3,500". This notation is fairly close to
the way that the right side recap box reads.

If you want 1o use more than one condition for highlighting, you can connect
up to 4 per session with ANDs and ORs.

»  Set the first condition.



Highlight “Airport™s meeting these conditions:

Direct to London Dbirect io London is
= equal to
= [:]

eg

»  Click AND or OR, whichever is the appropriate choice for the next
condition; AND in this example.

Direct to Londen is

equal to

The next box is selected.

«  If you don’t need to change the AND or OR, click the side box to go
on to the next condition.

Highlight “Airport™s meeting these conditions:

B G G

yes

T

Direct to London is
equal to
yes

® AND — DR
Bonus mileage is
equal 1o

+  Set the next condition. Repeat this procedure for up to four condi-
tions, then click Done to begin the highlighting process.

Part 13, Highlighting 233



comparison
by numeric
characters

234

Filevision IV

ighlight “"Airport™s meeting these conditions:

Direct to London is

gqual to
yes

@® AND — OR
Bonus mileage is
equal to
yes

@® AND =) OR
@ Value Security level is
rannk i fo 4 greater than or equal to

O Field 5

@ AND -~ OR
Average seats per aircraft is
greater than or equal to
100

The brackets enclosing the two pairs of condition boxes are used as if the two
pairs of conditions had parentheses around them. If alk four conditions are
used, they are evaluated like this:

(Condition 1 AND/OR Condition 2)
AND/OR
(Condition 3 AND/OR Condition 4)

Literally, this would be evaluated as: Find and Highlight all Airporis who pro-
vided direct flights to London, who offered bonus mileage, whose security level
was at least 5 and whose average seats per aircraft were at least 100.

When Filevision compares two values, it can treat them either as numbers or as
text. Filevision has a flexible definition of “number”. It includes commas,
percent signs, and currency symbols.

You can also type other information after the number, and that field will be
treated as if it had only the number in it. If you type $49.95, but don’t bill
until Feb. 1 in the Payment Due field, the $49.95 will still be treated as the
number 49.95. If there is more text after a number in a field, the data following
the number is ignored and the number is still treated as a number.

The table on the next page shows how Filevision views numbers in a Value
comparison. For example, you don't have to worry about commas in numbers
of 1,000 or more and you can use currency symbols. Filevision still treats and
evaluates numbers with those characters in them as numbers.



Table 3-2

comparison by
text characters

text values

Characters in field Numeric value Comments

1234 1234 Positive number

-1234 -1234 Negative number

$1,234 1234 Currency symbols are

¥1,234 1234 ignored. Notice that

£1,234 1234 cents and dollars eval-
1,234¢ 1234 uate as the same value.

99,999,999,999.99995 value error Numbers with more

than 10 digits to the left
and 4 to the right of the
decimal point are not
legal.

112% 1.12 Percent symbaols mean
automatic divide by 100.

12/34 12 Text characters follow-

12434 12 ing a number are
12 pieces 12 ignored.

Information in a field other than numbers (as defined by the table above) and
pictures fall into the category of text characters. Filevision offers several ways
to compare text characters.

The tables on the next page show how Filevision would search through differ-
ent fields for different kinds of values and how the search characters are used.
The double period (..) search character matches any set of characters of any
length. 1t's used most often to find a sequence of characters at the beginning of
a word or at the end of a word. The up carat (A) search character will only look
for a match at the beginning of a field; it won’t continue the search in the
middle of the field. Use this table for both Find... and Highlight....
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Information in the Name fields for all records in the file.

Chemical Investments, Inc.
Biochemical Products, Inc.

Colorado Chemical Corp.
Chemicals for Agriculture

International Petrochemicals

Value specified

Meaning

Records selected

Name is = Chemical

Find a Name with

the whole word
"Chemical" anywhere
in the field.

Chemical Investments, Inc.
Colorado Chemical Corp.

Name is = ..Chemical

Find a Name that
contains a word
ending with the letters
"Chemical".

Chemical Investments, Inc.
Colorado Chemical Corp.
Biochemical Products, Inc.

Name is = Chemical..

Find a Name that
contains a word begin-
ning with the letters
"Chemical”,

Chemical Investments, Inc.
Colorado Chemical Gorp.
Chemicals far Agriculture

Name is = ..Chemical..

Find a Name with the
letters "Chemical”
anywhere in it.

Name is = *Chemical

Find a Name that begins
with "Chemical" as the
first word.

Chemical investments, Inc.
Colorado Chemical Corp.
Biochemical Products, Inc.
Chemicals for Agriculture

International Petrochemicals

Chemical Investments, Inc.

Name is = *Chemical..

Find a Name that begins
with the letters "Chemn-
ical”.

Chemical Investments, Inc.
Chemicals for Agriculture

Filevision [V

The at symbol (@) search character takes the place of any single letter. Keep in
mind that the infermation in the Part no. field below isn’t treated as numeric
information. To be considered a number by Filevision, the contents of a field
must start with a numeric character.



Table 3-4

Table 3-5

Summary of
Highlight
and Find
comparisons

Information in the Part no. field of all the records in the file

R23-001 Q23-001 Q23-123 Q71-001

Objects

Value specified Meaning selected
Part no. is = @23-001 Find "23-001 preceded by any character. R23-001
Q23-001

Part no. is = Q23-@@@ Find "Q23-" followed by any 3 characters. Q23-001
Q23-123

Part no. is = Q@@-001 Find "Q" followed by any two characters, Q23-001
followed by "-001". Q71-001

Uppetr/lower case and diacritical marks are ignored

Information in the Name field of all the records in the file

e.e. cummings

Cairns Cooperative

Cairns Codperative

Value specified

Explanation

Records
selected

Name is = E.E. Cummings

Case is ignored.

e.e. cummings

Name is = Cooperative

Diacritical marks (like the
umlaut) are ignored.

Cairns Cooperative
Cairns Codperative

Here's a summary of the way comparisons and search characters work:

Word searches find the word anywhere in the field. If you ask for “Chemical”
you'll get “Chemical Investments” and “Colorado Chemical”, but not “Petro-

chemical”.

Any sequence of characters can be found with the double period (..) search
method. The most frequent use of .. is to find all words that start or end with
some sequence of characters you know. If you ask for “..Chemical” you'll get
“Chemical Investments, Inc.” and “Petrochemical”, but not “Chemicals for

Agriculture”.

Values only at the beginning of the field can be found with the up carat (A)
search character. It will find “Chemical Investments” but not “Colorado Chemi-
cal”,
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Any single character will match the at (@) search character. If you ask for
“@BC” you'll find “ABC” and “ZBC” but not “ZABC”.

Case and diacritical marks are ignored, so you'll find “E.E. Cummings” if you
ask for “e.e. cummings”, and “cotperative” if you ask for “Cooperative™.

Use any of these search comparisons for Find... and Highlight....

- |f you want to erase selection conditions, select the appropriate
condition box and click Clear.

If objects are already highlighted when you enter highlighting rules, you can
choose to replace their highlighting altogether using Replace, or make the
currently highlighted objects pass the new conditions in order to remain
highlighted using AND, or leave highlighted all the currently highlighted
objects, while other objects that meet the new rules are highlighted using OR.

Highlight “Author’s meeting these

Mame is
equal 1o
Thoreau

® AND — OR

Thioresal

@ AND = OR

@ Value
() Rank (0 to 0)
C Field

® AND —C) OR

+  Use the pop-up menu to select the condition you want:

eplace ghlig {
AND With Current Highlighting &=
OR With Current Highlighting




highlighted to
not hightighted
toggle

canceling
highlighting

halting the
highlighting
process

+  AND With Current Highiighting means that only the objects that
are currently highlighted are tested. Those that fail the new condi-
tions lose their highlighting; those that pass retain it.

. OR With Current Highlighting means that all the objects that are
currently highlighted remain highlighted, and any other objects that
meet the new highlighting rules will also become highlighted.

« Replace Current Highlighting does just that.

+  Click Done.

If you are working in the Info page. and want to toggle from highlighted to
those records that are not highlighted. issue a Command-W (3-W) key chord.
All of the non-hightighted records will become active and the window title bar
will change from x (records) highlighted to x (records) not highlighted.

Notice with the example windows below, the first window shows 1 high-
lighted. As only that record is active, the Next and Prev buttons are inactive.
In the second window, after issuing a Command-W, 5 records are not high-
lighted and the Next and Prev buttons are now active allowing vou to browse
through all of the records.

=C/== Info for this Author: (1 highlighted) ==HE|

[ Name RETTEEY I

ECI= Info for this Author: (5 not highlighted) =05|

N Thoresu |

Prav) B s) Gever 1) (Drawing )

Prev) (Mext) (Bovert ) | Drawing ) 5sox] 0] |

+  You can remove all highlighting by choosing Cancel Highlighting
from the Access menu.

When you click Done on the Highlight... display, Filevision starts scanning the
objects to see which should be highlighted.

«  You can stop the highlighting process anytime by clicking the Quit
button on the highlighting progress dialog while records are being
highlighted.

Records highlighted: 29

l Records to check: 518
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This is where you learn how to print forms, reports, and labels. It's a two-step
process. In step 1 you design a print format, and in step 2 you print using that
format.

You can also print a copy of your current activity; for example, the print format
you're designing. Sce page 309, “Priniing what you’re wosking on”.

With Filevision you can design formats in any of three styles:

Forms typically look like the forms you'd create for your office. You can also
use forms to create form letters, using Filevision for mail merge.

Reports are columnar reports that can contain computed fiekls and statistical
functions—counts, totals, averages, and standard deviations. For example, you
can print reports that automatically show total sales for cach month, or that print
average inventory levels for each warehouse.

Labels are usually mailing labels.

How to use this section: To print forms, reports, or labels, you must first design
a print format or edit an existing one. Examples for each style (columnar
reports, forms, labels, and form letters) are given in the “Preparing...” sections.
General design and editing procedures are covered in “Editing print formats”,
page 292, and “Printing with special information”, page 297.

Once you've designed a format it's saved in the Print Library. Then you actually
print using that format; see also Part 17 “Special Printing Features”, page 296.

There arc two steps in printing a Report. The first is designing a Report
format, and the second is printing using that format. This section walks you
through the design and printing of an example Report.

Once you design the format, i's automatically saved in the Print Library, and
you can reuse or edit it anytime. Keep in mind that a Report includes records
of only one Type.

The example shown here uses only a few of Filevision’s printing capabilities.
Additional features are discussed in Part 16, “Printing Recap”, page 286, and Part
17, “Special Printing Features”, page 290.



- The picture below shows a simple Type layout, which we'll use 1o create a
Report. You may want to create a small file based on this Type layout. Then
. you can fill in a few records (half a dozen is fine), and if you follow the steps
— here as you read them, you’ll be able to print out a Report on those records.
For the best results in this particular example, put CA in the State field of at
least 2 records, and CT in at least 2,

(“Eml-'ile Edit Types #Hucess Text Format Shades )
Eee—————————=————pddType - Type A =n———— 5|
t|||l|l1|I|l§IlJZII|I|t|I3[I|III[]41I|lII‘I5|l'Illila

|
Type-name
|
|
I
|
i

1989 Sales

Address and Street

|l\|||M|i|||||"}|l|jli

Carncel) HBamave Fieidl0ptions (Add_Field][Done] ]

One of the filled in records in the Info page might look something like this:

=——=———— Info for this Customer: (7 records) F‘_'I-l
¥

Company ]
o Bob's audio Los Angeles
1989 Sales
Robert Blakestone $89,333 90406

EI 1bF

Address and Street
4456 Barrington

Prev][Hext][fever 1) (Draming J[3 ink]

As an exampie of the Info page entries, a sample Report printout as shown in
the View Print window might look something like this:
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ffiew Print

Cramer
Diistrlomiens

Company

Bob's Audio

Flex Plastic Products
Manson Plumbing
Sampson Plastics

Bear Bicycle Parts
Del Mar Farm Supplies
King, Inc.

Cancel]{ Done |

[ July Sales by State |

City Siate
Los Angeles CA
Newport Beach
Los Angeles
Orange

State Total:
Cambridge CT
Del Har
Cavannaugh

State Tolal:
Overall Count: 2
Overall Tatal:

1989 Sales

$89,333
$44,652
$12,692
$23,540

$170,217

$34,351
$25,632
$45,223

$105,406

$275,623

« Choose the Type for which you want to design a Report from the

Types menu.

In this example it’s Type Customer.

« Choose Print Records... from the File menu.

The Print Library appears.

If you want to edit an
existing format, select it
and click Edit. However,
we'll design a new one in
this example.

* Click the New
button.

A dialog box appears,
asking you what style you
want to print.

Print Library
Print format Type styie
o
=
Records to print: Print to:
@ ftHl @ Printer
O Hightighted (O Screen
O Seiocied O File




Print report
style: Form,
Report or Label

the Print Format
window

Header -

Choose a style for printing Order Form records:

HCnncel ]l i: Forms ]

+ Click the Report button.

An initial print format appears. Filevision automatically creates such a format
each time you click the New button, but you can alter the format any wiy you
wish.

Each record

Footer ---

Print Oz
[I!Ilz'I1ll|l|l|i2|lllll|13rlllllll4|]|lll|lsll|I|IiG
Format-name:- Farmat &
| | Header:
= Report Title
—1: Campan Cit State C
__~ Each record:
Compan Cit State CE
2 Footer:
] Page &p

naming the
print format

Cancel](Resnwe Fipts Sort](Add Field

Its three main sections are labeled Header, Each record and Footer. The size:
of each section will determine how many records will be printed on a page.
The Each Record: section will print as many records in columns as it can on
one page, then go on to the next page.

The first box, Format-name, contains a preset name for the Report format like
Format A or Format B.

* Replace the name in the Format-name box with Sales report.

format-name: BEES reportj

Sales report will appear in the Print Library as the name of the print format
you're now designing.
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setting up the The Header and Footer areas contain information that’s printed at the top or
Report title bottom of each page; they can be edited or removed.

»  Replace the words Report title in the Header with July Sales by
State.

July Sales by Siéfé

July Sales by State will be printed at the top of each page.
adding an For some company identification, let's add the company name to print in the
annotation field Header section on each page of the printout.

+  Click the Add Field bution.

The Add Field dialog will appear:

“ Annotation Field ||
X !

«  Click the Annotation Field button.

A blank annotation field will appear.

Resize the annotation field by
dragging the resize handle
down one line. Enter the
company name of Cramer
Distributors. Change the
font to any serif style, increase
the text size to 18 point and
change the style to Bold and
Outline from the Text menu

Distrilbuiors
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- removing + Select the CEQ data field in the Each record area.

unwanted
fields

«  Click the Remove Field button,

The field vanishes. Use this technique to remove any field, whether it’s a data
field or an annotation field, and whether it's in the Header, Footer, or Each
record area of a print format.

= Now change the CEO column title in the Header area to read 1989
- Sales.

This is an annotation field and could read as anything (such as July 1989 Sales)
- without affecting the actual sales figures in the Record area.

»  From the Format menu, select Align Right.

The Footer contains an annotation field that reads Page &p. The ampersand
(&) nexi to the p indicates that the current page number of the report will be
printed in place of the &p. This could be changed to read anything or it could
be removed.

adding a +  Click the Add Field button.
data field

A small dialog box appears over the button, giving you the choice between a
Data Field and an Annotation Field.

(cancet] [Annotation Field ]
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« Click Data Field.

Another dialog appears showing a field name in a box. The field name box is a
pop-up menu that shows all of the field names for this Type.

Choose a field to add:
I o C Show field name and contents
Lt | @ Show field contents only

+  Press the mouse button with the pointer on the field pop-up menu to
select from the list of data fields for the 1989 Sales field.

Choose a field to add:

¢ Show field name and contenis

1985 Sales ® Show fieid contents only

Address and Street
City
Company
Link
State

ZIP

» Release the mouse button when you have the 1989 Sales field
seiected and click Add.

1ol sales.




sorting the
Report

The dialog box disappears and the 1989 Sales ficld appears in the middic of
the display.

+ Use the move handle on the top of the field to place it as shown:

The print format will automatically move left as you move the field beyond the
right edge of the display—you don't have to use the scroll bar.

« Choose Plain text, 12, and Geneva from the Text menu.

»  Choose Numetic, Dollar signh, and Commas from the Format
menu.

Now 1989 Sales figures will be printed with a leading dollar sign and commas.
To recap, the Report layout now has six annotation fields in the Header area,

four data fields in the Each Record area and one annotation field in the Footer
darea.

Now let’s sort the Report by State, City, and Company for printing purposes.
State will be the “primary” sort field.  Within the State order, records will be
sorted by City, making City the “secondary” sort field. The third level of
sorting, Company, is called the “tertiary” sort field.

= Click the Sort button at the bottom of the display window.
The Sort printing dialog box appears.

+ Use the Primary sort field pop-up menu to select State.

»  Click the checkbox next to Secondary sort field:.
It’s now selected.

»  Use the Secondary sort field pop-up menu to select City.

- Finally, click the checkbox next to Tertiary sort field: and select
Company.
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That takes care of sorting. Your choices should ook like this:

Sort printing as follows: Start a new
. . page for each:
Primary sort field:
[state | A-Z a
(4 Secondary sert field:
ICity l -2 O
[ Tertiary sort field:
[Company ] R-2Z O

[ Do not print duplicate sort fields

+ Click Done.
The Sort printing dialog disappears.

Note: Sort on a print format is used to set the order for printing Forms, Re-
ports, and Labels. The sort field used on the Info and Drawing pages is not
affected by this choice.

Each of the three sort fields are set to ascending order (A-Z). to change the

order, just click the sort order box [¢ - v and the order will reverse to descend-
ing.

The Do not print duplicate sort fields check box is used where there may be
a long list of repeat information such as CA in the State field. By checking this
box, CA wilt print only once at the beginning of the column and will be blanked
out after that. It will not affect the printing of information in other columns.

It should be mentioned that only the first 31 characters of field information are
checked. If you were using a list of part numbers, for instance, and the num-
bers were sequential as in: AFQ-CMT-10344-4556-1112-5656-AA-1 through -20,
only the first number would print. The dash 1 through dash 20 suffix would not
be detected and the program would assume that the numbers were all the same.

In the Start a new page for each: column, if checked - the printout will do a
form feed to the next page each time the information in that field changes.



detail statistics:
getting sales
by state

overall statistics:
a count of all the
records

Now that we have the proper sort order, we can print a4 subtotal of 1989 Sales
for each State.

Select the 1989 Sales field in the Each record: area.
+  Choose Statistics from the Format menu.
The Statistics dialog box appears.

Click the Total checkbox for Overall statistics and for By State.

statistics for: [1989 Sales i
Standard

Count Total Average deviation
Overall statistics . . . . O = O M
By State . . . . . . . . O | [} |
Bylity . . . . . . . . O O O d
By Company . . . . . . O [ O 0
Use "Sort” to select different detail statistic fields.
Selepet "Numparke " from the Formal mens o pnable aif statislics.,
(cancel | [ Prev Field | [ Nenut Field | [ Done |

This will give you an overall sales total, and a sub total on 1989 Sales for each
State. Your choices so far should look like the dialog to the left:

Normally, vou'd click Done, but we also want an overall count—a count of all
the Companies in the file.

Click the Next field bution

Statistics for: [Company

| until the top reads Statistics

By State
By City
By Company

OveraH statistics . . . .

Use "Sort" to select different detail siatistic fields.
Select “Numeric’ from the Format menu 1o enable ali statisties.

Standarg for Company.

Count feind Buerane deuisting
& O O O +  Click the Count checkbox for
.. O Cl O O Overall statistics.
. O a O O
. O O O O Now you're finished.

Click Done.

[ cancel |

[ Prev Fiend |

You return to the report format you've

( Nent Fietd ) { Done )

been designing.
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- Click Done to save the format.

You return to the Print Library. As you can see, the print format you just
designed has been added to the Print Library.

previewing Remember that there are two steps in printing reports: designing a format, and

the Report printing the report. You've just completed the first step, the designing. But
hefore the Report is sent to a printer, let's first check it to see if everything will
print OK.

— « From the Print Library, click Screen
Print Library under Print to:.
Print format Type Style
sales Report Lustomer Tl | Clicking File would create a Macintosh disk

file of the output for use with a word processor
application like MacWrite. Clicking Printer
would send the output to your printer.

[ vetete ) Edit

»  Click Print.
Records to print: Print to:
CLU O Printer There is a short delay while the records are
Q thghtighted gs_”“" being sorted. The screen display window,
) setectnd File . . . .
View Print, is then displayed:

E= Vliew Print

Cramer

@! [[‘ﬁ)‘[ﬂ July Sales by State

Company City State 1989 Sales

Bob's Audio Los Angeles CA $89,333

Manson Plumbing $12,692

Flex Plastic Products Mewport Beach $44,652

Sampson Plastics Orange $23,540
Gtate Total: $170,217

Bear Bicycle Parts Cambridge CT $34,551

King, Inc. Cavannaugh $45,223

Del Mar Farm Supplies Cel Mar $25,632
State Total: $105,406

Overall Count:

T

Overall Total: $279,623
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printing
the report

Notice that the states only printed on the first row of each state and that Los
Angeles was only printed for Bob's Audic and not Manson Plumbing. All of
those items would print if you set the Do not print duplicate sort fields
check box to off {(no check mark) in the Sort dialog box.

The location of statistical information can be controlled by which sort field you
request the information on. The statistic, such as Qverzll Count: 7 for the
Company field will print under the field that the statistic is called for, The
statistic alignment will be the same as the field alignment.

To send this Report to a printer:

»  From the Print Library dialog, select Printer under Print to: then
click Print.

The records are sorted, then a standard printer dialog box appears, depending
or the type of printer being used and the current version of the driver. For the
LaserWriter, version 5.2, it would look like the following:

Laserlriter “Laserlliriter” 52
Cupies:lil Pages: @ Al ) From: I_I To: Ij

Cover Page: & No O First Page () Last Page

Paper Source: @ Paper Cassette () Manual Feed

copy

Cancel ]

Fause Renuwie

You will also see a progress dialog box that advises of

Copies remaining to print D the number of copies left to print and the number of

records to print. If using an ImageWriter, a Pause

Records remaining in this button allows you to halt the printing tempaorarily. 1F

using a LaserWriter, the Pause button is inactive:

other features
of Reports

= +  Click the appropriate printer settings, then
OK to begin printing.

That's it! Your report is printed, and the Print Library reappears when printing is

complete.

This section showed only two of the many possible ways you can print Re-
ports. For a complete reference on designing Report formats, see Part 16,
"Printing Recap” page 286, and Part 17, “Special Printing Features™ page 296.
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Preparing a
Form for
printing
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There are two steps in printing Forms. The first is designing a print format, and
the second is printing using that format. This section walks vou through the
design and printing of an example printout of Forms.

Once you design the print format, it's automatically saved in the Print Library,
and you can reuse and edit it anytime. Keep in mind that any ¥orm includes
records of only one Type.

For a complete reference on designing Form formats, see Part 16, Printing
Recap" page 286, and Part 17, “Special Printing Features™ page 296.

The picture below shows a simple Type layout, which we'll use to create the
Form. You may want to create a small file based on this Type layout. Then
you can fill in a few records (two is plenty), and if you follow the steps here as
yau read them, you'll he able to print out the Forms for those records,

ﬂddTgpe—TupeB%EE
1|II!II1IIII|||I2|I|li)113lll_L|I|I4|I|III[]5I1|I||||6{}

Typo-name

Part llustration

Unit Cost

Customer Order Date:

Date format:
DD/ MMAYY
For example,
July 7, 1989
is Q7707759

||111|MI|]|I||-1I|I|IL

@<k

[Cancel][fiesove ¥ icid)lOptions](Add Field][Done |3 -

An example screen preview of the finished print layout Form sent to the View

Print window would look like the picture on the next page. As you can see, 4

Form print style approximates your original Type layout. This can be modified
to appear any way that you want.

The graphic used for the logo in the Header area could be imported via the File
menu Import Graphics... function using scanned photographs or one of the
PostScript illustrations or other graphic type. It could also be illustrated on the
drawing page and pasted in. The graphics contained in the Part Illustration
field would be entered in each Info page record using the same methods.



Diew Print

Valley
Computer
Supply Co.
= pply
[ 1tem name [#Apple [IXT Yidea board | Fart Mustration
[Catalog no. | 303-33-198 |
Unit Cost Quantity
$124.95 1
Customer Order Date:
John Godfrey 06/07/89
208 Mathias Dr,
Thor, NH 03454
Ship to Address: Delivered on:
Sare 19707 /89
[ 1tem name [Clock chip | Part IMustration
[ Catalog no. [ 5-301 |
Unit Cost Quantity
$1.95 200
Customer Order Date:
Computer Specialty Co. nz/07/89
4201 E. Chestnut S5t.
Thor, NH 03454
Ship to Address: Delivered on:
4100 E. Walnut 19707789
Thor, MH 03454
[Cancel][ Done ] K] |

going to the = Choose the Type for which you want to design a Form from the
Print Library Types menu.

In this example it's Type Order Form.
» Choose Print Records... from the File menu.
The Print Library appears.

If you want to edit an existing format, seicct it and click Edit. However, we'll
design a new one in this example,

»  Click the New button.
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naming the
Print Format

settingup a
title for the
Form
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A dialog box appears, asking you what style you want to print.

Print Library
Print format Type Style

Sates report Customer Report

Choose a style for printing grder Sheet records:

(o)

« Click the Forms button.
An initial print format appears. Filevision automaticaily creates such a format
each time you click the New button, but you can alter the format any way you

wish.

Its main body is labeled Each record. The size of the Each record area helps
determine how many records will be printed on a page.

The Header and Footer areas contain information that will be
printed at the top or bottom of each page. They can be edited or removed.
The first box, Format-name, contains a preset name like Format A or Format B.
. Replace the name in the Format-name box with Order Sheet.
Order Sheet will appear in the Print Library as the name of the print format
you're designing.
- Press Tab once.

The words Report title in the Header area are shown selected. Grab the resize
handle and reduce the length of the annotation field and open it to 3 lines deep.

. Typein Valley Computer Supply Co. on the 3 lines as shown.



Valley Computer Supply Co. will be printed at the top of each page.

| Supply Co.

adding Header Add a second annotation field to the Header area :

information
+ Click the Add Field button.

« Select Annotation Field from the Add Field dialog.

A blank annotation field will appear in the Header area. Move it to the lefi side
and open it to fit the full left area of the Header using the move and resize
handles.

«  Select Import Graphics... from the File menu.

Import the EPSF Macintosh computer graphic (this assumes that you have one
available). Any picture from any EPSF, PICT or MacPaint source can be imported
directly into the annotation field. Any image that can be copied to the Clipboard
can also be pasted into an annotation field.
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removing The field that reads Date format: DD/MM/YY, For cxample, July 7, 1989 is
unwanted 07/07/89 is only there as a reminder to the data-entry person. Let's remove it.

fields »  Press the Tab key several times until that field is selected.

When you select a field with the Tab key, the field is shown in reverse:

If you copied the sample Type layout at the beginning of this section, you'll
notice that the print format window is repositioned to give you a better view of
the field when you Tab to it.

33

Guaniily

« Click the Remove Field button.

The field vanishes. Use this technique to remove any field, whether it's a data
field or an annotation field, and whether it’s in the Header, the Footer, or the
Each record area of a print format.

adding an Let’s add an annotation field to the Each record: area that will show the date of
annotation the printout.
field

« (Click the Add Field button.

A small dialog box appears over the button, giving you the choice between a data
field and an annotation field.

+ Click Annotation Field.

The dialog box disappears and a blank annotation field appears.

»  Use the top handle to move the annotation field under the Order date:
field and align it even with the Ship to Address field.
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« Use the stretch handle on the bottom right to pull the field down to
open to 2 lines. -

printing the » Type Delivered on: &d
date on each

record The ampersand (&) next to the d indicates that the system date will be printed in

place of the &d in each record.
+ Choose Bold, 10, and New York from the Text menu.

+ Choose Align Middle and Hide Border from the Format menu.

Delivered on:t

The Footer contains an annotation field that reads Page &p. The ampersand (&)
next to the p indicates that the current page number of the report will be printed
in place of the &p. This could be changed to read anything or it could be
removed.
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The Each record area shows how much room each record will occupy on the
printed page. As the side ruler shows, this form takes up about 4 1/4" including
the Header and Footer which means that only three forms can be printed on
each page (4 1/4" for the 1st form plus about 2 1/2" for each of the 2nd and 3rd
forms). A fourth form would increase the size beyond the capacity of letter size

paper.
Let’s add some room to the bottom of the Each record area so that it will be

easier to distinguish between the three records that will appear on each page of
the printout.

+  Pull down the bottom handle on the Each record area about 1/2".

Each :

Item name
Catalog no.
U Quantity

Customer Order Date:

Ship to Address:

Footer:

I‘-’!Ili_l|1I-HIlttillf-'illlllllh'\llllill

[Cance | J[Humovs Fiaid [Sort](Add Field)[Done][]

As you pull down on the Each record: area to make it larger, the Footer: area
also moves down automatically to make additional room.

You're now finished designing the print format.
« Click Done.

You return to the Print Library. As you can see, the print format you just de-
signed has been added to the Print Library.



repeating the
Forms Across

By doing a little redesigning of the print layout, the example Form can be
adjusted to print four records up per page. ‘This is accomplished by using
Across... from the Format menu. Before we set the format to print more than
one across, an adjustment is required to the lavout.

+ Select the Order Sheet menu option from the Print Library dialog.

+  Click the Edit button.

The Order Sheet print layout
is again displayed. Adjust the
fields as shown and reduce
the width of the Each record
area by using the right resize
handle:

If you plan to print this layout
to a LaserWriter, keep the
width of the Each Record
ared to 4" or less. This will
print 2 across on the 8"
standard print width of the
LaserWriter in portrait mode.

= Select Across...
from the Format
menu.

The Across dialog appears:

I A T T

Header:

Suppiy Co.

Each record:
Item name

e ——
Cataleg no. —

Customer Ship to Address:

e ry
Part NMustration

]:lll|||||-N|1||I||U1|!||I||MI|||I||'1I|||!||

Footer:
Cancet)(nessve 3 ieia

Print how many records across each page?

The current setting is: 1.

() wm ) )

*  Click the 2 button.

Depending on the amount of information you wish to present in each Form, the
Form print layout can provide up to 4 Forms across and as many down the page
as will fit. Additional room for adding more Forms per page could be achieved
by reducing or removing the Header and/or Footer areas.
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Forms
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The final four up print of the adjusted Forms would appear as:

liew Prinl cecF——————————15

Valley

[y Computer

T~ Supply Co.
Item name | Apple [1X7 Yideo board ] [1tem name ]Clock chip
Catalog no. [303-33-15§ Catalog no. [ 5-301
Customer Ship to Address: Customer Ship te Address:
Jahn Godfrey Same Computer SpecialtyCo. | 4100 E. Walnut
206 Msthias Dr. 4201 E. Chestnut 51, Thor, MR 03454
Thor, NH 03454 Thor, NH 03454

Part Hlustration

™

: fart Nystration (Unit Cost |
$124.95 g T $1.95
[Guantity | [Quantity |

Order Date: Order Date:
06/07/89 02/07/89
Delivered on: Delivered on:
FRIR L hit:] [RIak ST
Item name | Mac SE Accelerator Board | Item name | Macintesh 11 Power Supphy
Catalog no. [MSE-34-5781 Catalog no. [ M {1-34-889
Customer Ship te Address: Customer Ship to Address:
Craig Sampson Same Jack Beresford Same
4471 Grange Ave 6681 Crest Dr.
Cancel]| Done |¢|‘ “:}

Remember that there are two steps in printing Forms: designing a format, and
printing the Forms. You've just completed the first siep, which is designing the
format.

The second and final step is printing the Forms. In this example we’re assuming
that you have a printer with the appropriate software attached to your system.

« From the Print Library dialog, click Printer under Print to:.

Clicking Screen would preview your forms on screen, and clicking File would
create a Macintosh disk file of the output for use with a word processor applica-
tion like MacWrite.

«  Click the Print button.
The records are sorted, then a standard printer dialog box appears.
« Click the appropriate settings, then OK to begin printing.

That's it! Your Forms are printed, and the Print Library reappears when printing
is complete.



Preparing There are two steps in printing Labels. The first is designing a format for Labels,

Labels for and the second is printing using that format. This section walks you through the

. design and printing of an example Label format.

printing & P & P
Once you design the format, it’s automatically saved in the Print Library, and
you can reuse and edil it anytime. Keep in mind that a Label format includes
Labels of only one Type.

& File Edit Types ficcess Tent Format Shades ' The picture to the left shows a
=—— = fadiype - lype C=——————1"13| simple Type layout, which
l|l|lll1ll|I|I|l2II|I|l!I3|I|lllllq'_{lflllllslI|I}I|IGG we'll use to create the Labels.
Type-name You may want create a small
file based on this Type layout.
Then you can fill in a few
records (half a dozen is
plenty), and if you follow the
steps here as you read them,
yvou'll be able to print out the
Labels for those records.

Street

Registered owner? §

Registration number

A partial page of Labels would
look something like this:

1|\||N|i|||ll|-‘||||

— i
|[Cance | Gonaue Ficia Gptions){Add Field)(Done}] | E:)@]
Anne Moore Brican Anderson
2222 Damarascotta Ave., 8820 Algonguin Circle
Solon, OH 44139 Solon, OH 44139
Danny Novak Evan Birkhead
1682 American Rd. 1897 Cosell 5t. i
Solon, OH 44139 Sclon, OH 44139 E
%

John E. Campbell Larry McClain %
9591 Banta Ave. 10 E. Liberty ;
Solon, OH 44139 Solon, OH 44139 i

Meaghan Carpenter
4045 Echwin Blvd.
Solon, CH 44139
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going to the - Choose the Type for which you want to print labels from the Types
Print Library mend.

In this example, it’s Customer.
+ Choose Print Records... from the File menu.
The Print Library appears.

If you want to edit an existing format, select it and click Edit. However, we’ll
design a new one in this example.

« Click the New button.

A dialog box appears, asking for what style you’d like to print records.

Print Library

Print format Type Style
Sales report Customer Report
Grder Sheet Ordet Sheet Form

Choose a styte for printing Customer records:

[ Forms | ( Report |

+ Click the Labels button.

An initial print format appears. Filevision automatically creates such a format
each time you click the New button, but you can alter the format any way you

wish.
naming the The first box, Format-name, contains an automatically entered name like
print format Format A or Format B.

« Replace the name in the Format-name box with Mailer.
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— The automatic Label lavout will appear as in the picture below. Mailer will
appear in the Print Library as the name of the format you're now designing.

T —_—  Prinl YVYVYr——————u
|1 131y Iﬂljl Ll Pilll ||i|3||I illil4|I|I II|I5|Il1 ll||6{}

Formnt-name.

! tCustomar name
Streef

City

i :State

[Mllil‘ll"ﬁll‘lll

Cancel)(#enove Fieic]([Sort]{Bdd Field][Done)[1] |

removing We aren’t going to use the City or State data fields in this example. ‘They will be

— unwanted replaced with an annoctation field containing the same information in a different

fields WA
- +  Select the City field.

* (Click the Remove button.

The ficld vanishes. Use this technique to remove any field, whether it's a data
ficld or an annotation field.

« Remove the State field.

1t vanishes too.

Your layout should now appear as: e

Street

adjusting the The label stock that will be used for P —————"
Label size this example is 1 1/2" high by 4" wide. | Street SR
To space the Labels properly for
printing on this standard label stock, )
the Label print lavout background can fﬁ\
be stretched using the stretch handles.
The side and bottom handles are constrained and will either widen or deepen

the Label. The corner handle can be used to adjust the size in either direction.

Part 14. Printing Reports, Forms and Labels 263



using an
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other fields
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Resize the Label to 1 1/ ——  Print eee—oo-—————
2"h]ghby4"W1d€ ||i|l{111E|IL||I|2i|I|1|I|3||1!|1{|4||I1||l\5{

Formot-nome:

The Label print format
should now appear as:

! 'Customer name
i | Street

To take advantage of the
larger label size, stretch
the Customer name and
Street fields to the width
of the label background.

{M'I[ILI"‘!'!EI'I

Cusiomer name ™
The Label now appears as: iiStraet

To get the city, state, and zip code all on one line, we'll use a different method
that provides certain advantages. Annotation fields have no data of their own,
but you can use them to print the contents of data fields simply by typing the
names of the data fields inclosed by square brackets | ]. The advantages of
using this method is in creating an automatic "slide” between the fields, remov-
ing any spaces due to the varying lengths of the field data and the ability to add
commas or other punctuation marks between fields.

«  (lick the Add Field button.

A small dialog hox appears giving you the choice between a data field and an
annofation field.

|| Annotation Field N ETICRALT:

= Click Annotation Field.

The dialog box disappears and a blank annotation field appears.

«  Use the move handle on top to move the field snugly underneaih the
Street fieid.

« Use the stretch handle on the bottom to stretch the field to the same
length as the Street field:



slide left

final label
adjustments

close lines

«  Type "[City], [State] [Zip]" in the annotation field.

The Label format now _
Appears as: " | [City], [State] [Zip] |

Bracketed fields will : 1
automatically slide the text '
data to the left to remove

any blank spaces.

The fields still require some final adjustments.

+  With the Option key down, select 14 point size and Geneva from the
Text menu.

Using the Option key while changing any of the text attributes will make the
same changes to all fields.

The fields will be overlapping due to the increased text size. Adjust them so
that they all clear each other.

« Drag a marquee

around all fields to #

select them and Custorner name
center them by Street 3 "
dragging any one [City], [State] [Zip]

of the top move #
handles. ;

1f you are using fields that may be empty on some labels, the fields below the
blank line(s) can be moved up to fill the empty space. In order to achieve this
"closing of blank lines", the Label would have to be formatted using bracketed
fields in an annotation field such as in the [City], [State] [Zip] line in the above
example. Restructure the Label to appear as follows, also adding [Companyl:

[Customer name]
[Company] L
[Street]
[City], [State] [Zip]

\ . |
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using Across...

v RAlphabetic %0 |
Numeric 39

Doliar Sign &M
Commas 8,
Decimals... 3.

Statistics... 8-

« Align Left 86
Align Middle 3%7
Align Right %38
Hide Border
Do Mot Invert
Hide Field Name

Show Ruler EEH

Metrie Ruler

printing
the Labels

266 Filevision IV

In the top example on the previous page, any records that did not supply ecither
the Customer name or Street would eave a potential blank line during printout.
By using a single annotation field and bracketed data fields from the database
file, the automatic space and line compression will slide all lines together to fill
in the blank lines and will eliminate all unwanted spaces between ficlds.

If the empty lines and blank spaces are required, use all standard data fields. If

a combination of btank and compressed lines or spaces are required, use both
methods together.

Now alt you have to do is to instruct Filevision to print two Labels wide (or
however many labels across your label stock can print).

+ Choose Across... from the Format menu.

A dialog box appears, giving you the choices for the number of records you can
print across each page: (Each Label is a record.)

Print how many records across each page?

The current setting is: 1.

) ) D)

« Click the 2 button.
That's it. The Label print format is finished.

= Click Done.

You are returned to the Print Library. As you can sce, the print format you just
designed has been added to the Print Library.

Remember that there are two steps in printing Labels: designing a format, and
printing the Labels. You've just completed the first step, which is designing the
format. For a complete reference on designing Label formats, see Part 16,
Printing Recap" page 286, and Part 17, “Special Printing Features™ page 296,

The second and final step is printing them. In this example we're assuming that
you have a printer with the appropriate software attached to your system.



« From the Print Library dialog, click Page setup.

A dialog similar to the following will be presented depending on the type of
printer you are using and the version of the driver software:

Laserilriter Page Setup 52 -
Paper: @ US Letter (O A4 Letter (CTabloid
QO US Legal (O BS Letter
Reduce or % Printer Effects:
Enlarge: {7 Font Substitution?
Orientation [ Test Smonthing?
1 [] Graphics Smoothing?
i L|111J [ raster Bitmap Printing?

You will need to click the appropriate buttens for label stock. It's often 12", and
the button may be labeled “International Fanfold™. f yvou are using a Laser-
Writer, be sure to select Larger Print Area by first clicking the Options button
which brings up the following LaserWriter Options dialog.

Laserllfriter Options 52

[ Flip Harizontal

O Flip Dertical

1 Invert Image

] Precision Bitmap Alignment (4% reduction)
& Larger Print Area (Fewer Nownloadable Fonts)
] Unlimited Downtoadable Fonts in @ Dotument

i

« From the Page Setup dialog, click the appropriate settings, then OK.
»  From the Print Library dialog, click Printer under Print to:.
Clicking Sereen would preview your Iabels on screen, and clicking File would

create a Macintosh disk file of the output for use with & word processor applica-
tion like MacWrite.

»  Click Print.
The records are sorted, then a standard printer dizlog box appears.
»  Click the appropriate settings, then OK to begin printing.

That's it! Your Labels are printed, and the Print Library reappears when printing
is complete.
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Form letters, also called mail merge, are “personalized” with information from
data fields in the letters. You can create form letters of one page in size with up
to 16,000 characters (or bytes), the maximum a record can hold.

There are two steps in printing Form letters. The first is designing a format for
the letters, and the second is printing using that format. This section walks you
through the design and printing of an example business promotion letter.

Once you design the format, it's automatically saved in the Print Library, and
you can reuse and edit it anytime. Keep in mind that a report includes records
of only one Type,

The example shown here uses only a few of Filevision’s printing capabilities.
For a complete reference on designing Form Letter formats, see Part 16, "Print-
ing Recap” page 286, and Part 17, “Special Printing Features” page 296.

The picture below shows a simple Type layout, which we'll use to create the
form letters. You may want to create a small file based on this Type layout.
Then you can fill in a few records (three is plenty), and if you follow the steps
here as you read them, you'll be able to print out the form letters for those
records.

i |

:I|||I|1||l|i|I12||I|||I|3I|I|!|I|4l|l|||I15||I|||i16]

Type-nome

i

Picture

Last name
First name

Lalits

Current Mailing Address

PhonelHome
PhonelWork

Last Contact

Enter date info in DDIMNMYY Format

Salesperson

INIul{ll]b-iI|||I||

Cancel[Besove ¢inid)l0ptions

Down Payment

@[

Add Field][Done]




setting up
records for the
Form letter

We're going to create a business letter that looks like this:

Brushwood Hills Estates Development Company
P.O. Box 4069, Malibu, California 90265-1369

Al Hockwalit Wednesday, November 23, 1988
P.O. Box 7788
Saint Louis, MS 33401

Dear Al,

I wanted to take this opportunity to send you the floor plan of the Adventure model
townhouse that you were interested in when you were in the office on 9/23/88.

The down payment on the Adventures have been reduced to $24,500. If that provides
any renewed interest in the property, give me a call so that we might discuss the
chance of moving you into a new home.

There is also a good chance
that we might be able to
re-negotiate Jack Allen's
commission to make you

a better deal.

Best Regards,

SN0

Jim Callum,
Senior Vice-President of Sales

CC: Jack Allen, Sales Representative

Al, please give me a call at you earliest convenicnce.

In setting up the records for this example, you will need to copy the floor plan
from the Tour file found in the Townhouse Type (unless you wish to draw your
own). See the section on Importing and Exporting Graphics, page 151 for
details on how this is done.

The floor plan can either be copied to the Scraphook or Exported to a PICT file.
Either method will allow you to use it in your form letter layout.
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As soon as you have the floor plan ready for impeorting into your Customer

Type, set up your records by entering some general data in the data fields and

pasting the floor plan picture into the Picture field.

A filled in record should appear similar to the following:

E[J======== Info for this Customer: (6 records) =eeeem=T5|
|lllllr1||I|||l|2[||11|||3Ii]|||I14I|||I|I|5]|I1||I|E'G

BN ast name LLOGEY -

el First name [EY

] Current Mailing Address

| 1] {PO. Bux 1788

4 [ Saint Louis, MS 33401

By Dhone!Home

BN Phonelwork

Wil a5t Contact 9123188

Al Enter date info in DD/MWYY Formal

= Tk AT

— |;E:a| Advenlure

& Down Payment | $24,500

(Prev]

+  Choose the Type for which you want to design a print format from
the Types menu.

In this example it’'s Type Customer.
« Choose Print Records... from the File menu.

The Print Library appears,

Print Library
Print format Type Style
K
2
[ Betete ) et [ New ]
Recards to print: Print to:

@ AN @® Printer

O tightighted O Screen

) Salod tpg () Fife




If you want to edit an existing format, select it and click Edit. However, we'll
design a new one in this cxample.

+  Click the New button.

A dialog box appears, asking yvou what style you want to print.

Choose a style Tor printing Customer records:

m Report Labels

» Click the Forms button.

An initial print format appears. Filevision automatically creates such a format
each time you click the New button, but you can alter the format any way you
wish.

|I|J|I|I1lllliI|I2|I||lljlzlllllliI4!I1III|15II|IIJ|I6]I|illJl?|lllll|\3||

Format_nome:

Header:

Report Title

Each record:

Enter dete info in DDIMM'YY Fornat

Footer:
[Cance l)[Fescve #3014 Sort)[Rdd Field

L’tll!l|t|N|JlI|l{NllII|I|M|III|1|"||I[I|I|

[

I

Its body is labeled "Each record:". The size of the Fach record area helps deter-

mine how many records will be printed on a page. The header and footer areas
contain information that’s printed at the top or bottom of each page; they can be
edited or removed,
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In this example, none of the fields that were automatically entered by Filevision
will be used,

naming the The first box, Format-name, contains a preset name like Format A or Format B.
print format

« Replace the name in the Format-name box with Follow up.

Follow up will now appear in the Print Library as the name of the print format
you're now designing.

editing the As previously mentioned, we will not be using any of the fields as they currently

print format

272

exist. We can also close the Header and Footer areas as we will not require
them.

« Select all of the fields one at a time and click the Remove Field
button.

NOTE: Filevision will not allow you to remove the last field. To remove all of

the unwanted fields, we must [irst add one field to satisfy the one field require-
menL.

+ (Click the Add Field button.

unler:

sl R
Howove £iaid)Sort (RENETIED Dene )] |

The add field dialog appears:

" | Cancel | | Data Field | IJ

» Click Annotation Field.

»  Using the top move handle, move the new annotation field anywhere
into the Each Record: area.

The last automatic field can now be selected and removed.
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closing the
Header and
Footer

After all of the fields have been removed except the new annotation field, the
Print Format should appear as follows:

Pr|ntmgl
J[ll|||l||1|lII|I2EI|i|I|I3|l|llEillqll!I|||;'|5|I|||||16|||||||ITItIIII|\3II

Format-name: IR

Header:

Each record:

!I|I|'1|II!|I]

Faoter:

|-'!I||rillﬁll{ll:l%llfwlllhhln

s Fiaid)(Bort){Add Field

(2

ance |

While we could use the Header area for this form letter, it is not necessary and
will be easier to layout the contents of the letter in their proper positions
without using the Header or Footer areas.

»  On both the Header and Footer, grab the bottom handles and slide
the field closed.

; P [
TheprlntldYOUtShOU.ld | T I P T T
now appear as:

Header:
Each recard: ] \

Using the same method
of grabbing the bottom
area handle, stretch the
Each Record: area down
until it is a full 10 inches
(the normal printing
area). This will provide
enough room 1o lay out
our letter.

TN RN TN A

Footer:

]
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If you are using a printer that has larger than the normal 8 x 10 printing area,
open the Each Record area to take advantage of it.

the Form letter To start the form letter layout, you would have the option to use one large

Iayout annotation field with the Picture data field and an annotation field for the
signature, or you can break the form up into smaller fields. The smaller fields
will allow you more flexibility in final adjustment of the letter for best appear-
ance.

» Click the annotation field that was added, then use its top move
handle to move the field into the upper left corner.

+ Using the lower stretch handle, stretch the field to about 7" wide by 2
lines deep.

+ Type in the company name and address as shown and set the text to
12 point, Plain, Helvetica (or Geneva) from the Text menu and Align
Middle, Hide Border and Do Not Invert from the Format menu.

The form layout should appear similar to:

0. Box 4069, Malibu, California 90265-1369

We need to add a line under the company name which could be done either as
an annotation field entering the underline character or as a line drawn on the
drawing page and pasted in as a graphic., The drawn line will insure a clean
non-breaking line when printed.

«  Add another annotation field and move it under the company letter-
head field. Stretch it so that it is slightly narrower than the bottom
line of the company address. Set it to 6 point from the Text menu.

»  Exit the Print Layout temporarily by clicking the Done button.
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+  Click Quit from the Print Library dialog.

+  On returning to the drawing page, draw a horizontal line about 5" or
6" long using a 1 point line width from the lines pop-up menu.

+  With the line still selected, copy it to the Clipboard using Copy from
the Edit menu.

» Re-enter the Follow up Print Layout by selecting Print Records...
from the File menu and Edit from the Print Library dialog while
Follow up is selected.

- As soon as you are back in the Print Layout for Follow up, select the
new line annotation field and select Paste from the Edit menu.

The line that was just drawn was still in the Clipboard and was pasted into the
annotation field.

The layout should now appear as:

The next field to be added is the customer name and address annotation field.

«  Add another annotation field as described previously and move it to
the left edge of the Each Record area at about the 1 1/4" inch mark
on the ruler. Stretch it to 2 1/2" wide and 4 lines deep.

+  Set the field to 12 point, Plain, Times (or New York) from the Text
menu and Align Left, Hide Border and Do Not Invert from the
Format menu.
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+  Enter the data field names in square brackets for [First name] [Last
name] and [Current Mailing Address] as shown below.

=
{First name] [Last name]
[Current Mailing Address]

Any time that a data field name is entered in an annotation field in square brack-
ets, the contents of that data field replaces the bracketed field name. This is true
where ever the bracketed field name is entered within the body of the text (as
we will see later). The annotation field will not increase in size if there is more
information than can be contained in the pre-sized annotation field. It is there-
fore necessary to estimmate the largest amount of data that will be substituted for
the bracketed field names and to make the annotation field large enough to
accommodate it.

adding The next thing that we will add is an automatic date eniry field. Again, this is
ampersand &D done using another annotation field.
auto dates « Add another annotation fieid and move it to the right side of the Each
Record area, in line with the address field above. Streich it to
approximately 2 1/2" wide.
= Set the field to 12 point, Plain, Times (or New York} from the Text
menu and Align Right, Hide Border and Do Not Invert from the
Format menu.
» Type an &D in the annotation field (no brackets).
Your form letter layout should now appear similar to the illustration on the next
page:
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using bracketed
field names in
annotation fields

The ampersand (&) D will be replaced with today's full system date in the form
of Thursday, May 20, 1989. If you prefer the short form date format, enter a
lower case "d" as in &d. This will be replaced with the short form 89/05/20
date format (for example) during print out.

The next part of our form letter will be the salutation field. This could be placed
within the body of the letter field but will offer more versatility in the final
position adjustments if kept separate.

» Add another annotation field and place it under the address field as
shown in the next illustration.

* The remainder of the text fields should be set to 12 point, Plain,
Times (or New York) from the Text menu and Align Left, Hide
Border and Do Not Invert from the Format menu.

Once these field formatting attributes are selected, they should remain the same
after each field is entered (unless changed deliberately).

+ Type in "Dear [First name],", in the field. Notice that any punctua-
tion entered outside of the field will print as entered.

Typing punctuation marks or any other text in-line with a bracketed data field
name will automatically print as entered relative to the data field information
that replaces the bracketed field name. This allows a smooth normal flow of
text without breaks or unusual spacing.

The form letter layout should now appear as illustrated on the next page.
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Dear [First name],

The remaining annotation fields and text entry for the body of the letter can be entered using
the same general method that has been described above. The body text layout should appear
as follows:

wanted to take this 6bp6ﬁun1ty tosend you the floor planofthe [Mbdel] model townhouse that you
‘were interested in when you were in the office on [Last Contact].

‘Thedown payment onthese [Model]s have beenreduced to [Down Payment]. If that provides any
‘renewed interest in the property, give me acall so that we might discuss the chance of moving youintoa
‘new home.

There is also a good chance
that we might be able to
re-negotiate [Salesperson]'s
commission to make you a
better deal.

Best Regards,

Tim Callum,
Senior Vice-Presi‘denvtrof Salg:s_ _

[Salesperson], Sales Representative

[First name], please give me a your earliest conve
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adding graphics
to annotation
fields

There are two more fields to place that will contain graphics and one field for
design effect.

+  Add another annctaticn field and place it for a signature.

» Unless you have a signature graphic handy, return to the drawing
page and create one using the freehand or polygon tool. You can
create the signature oversize as it will be scaled when added to the
signature annotation field.

Note: An actual scanned signature could be imported here using Import
Graphics... from the Text menu.

«  Copy it to the Clipboard using Copy fram the Edit menu.
» Return to the Follow up form letter print layout.

»  Select the annotation field that will contain the signature and paste
the contents of the Clipboard using Paste from the Edit menu.

» Resize the annotation field (and signature) by using a combination of
the stretch handle and text Size from the Text menu.

Even though the text size has nothing to do with the signature graphic, by
changing the height of the field, the size of the graphic is adjusted to fit. If using
the stretch handle or text size seems to have no affect on the signature graphic,
one of the field handles may have been inadvertently selected while the Option
key was down. This will cause the graphic contents of any field to rescale to
full size. To remedy this, hold the Option key down again and click on one of
the field handles. This will toggle the graphic from full to scaled size.

Now that the signature is added, the form should appear as follows:
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adding data
fields to form
letters

280 Filevision IV

We still need to enter the field for showing the floor plan of the model
townhouse of interest by the customer. If all customers were interested in one
model and every form letter were to show that same model, a floor plan of the
one model could be pasted into an annotation field. Every letter would show
the same graphic.

However, in this example, each follow up letter may contain a different floor
plan. In this case, the actual floor plan of the model of interest to a specific
customer would have to be placed in that customers record. To change the
graphic on each letter, the data field for that graphic will have to be used in the
form letter.

- Click the Add Field button.

The add field dialog appears:

Cancel ] [Annotation Field ] [LEICRED)
+  Click the Data Field button.
The data field dialog appears:
Choose a field to add:
[Last name l () Show field name and contents

QShaw field contents only

When setting up a Form, the Choose a field to add: dialog opens with Show
field name and contents selected. In this example, the letter will look more
professional if the field name does not appear on the floor plan graphic.

+  Select Show field contents only.

- Hold the pointer and mouse button down on the Choose a field to
add: pop-up menu.

A menu of all the fields in the currently selected Type are displayed.



Current Mailing Address
Down Payment

First name

Last Contact

Last name

Link

— Model

Phone Home

Phone Work

(O Show field name and contents

salesperson @ Show field contents only

Cancel

The field that contains the various floor plans is Picture.
»  Select the Picture field.
*  Click the Add button.

The picture field appears in the middle of the display.

Using the move and stretch handles, reposition the field and stretch it to the
approximate size show in the following illustration:
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The precise shape and size of the field is not important as the graphic will scale
to fit whatever size is provided. If you wanted to create a full size graphic in
this field, you could use the Option key - click on a field handle method. Only
that portion of the graphic that fit in the field would print in this case.

overlapping There is one more touch to the layout before we are finished. Using the ability

fields to show an annotation field Inverted (black on white) provides an ideal drop
shadow for our graphic field. A shade pattern could be pasted into the annota-
tion field for effect; however, black will do.

« Add a blank annotation field and resize it to the same size as the
Picture field.

« Set the field to Invert from the Format menu while it is still selected.

« Move the field so that it is slightly above and to the right of the
Picture field.

The inverted annotation field drops behind the Picture field, creating a drop
shadow.
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previewing the
Form letter

The precedence of overlapping fields of either kind (annoctation or data) is
govermned by the relative positions as there is no front/back control. The field
that moves to the back is the field that is first encountered when scanning the
layout from the top down. This allows data fields (or other annotation fields) to
easily overlay an annotation field for background effects.

Importing or pasting an illustrated background or a company's standard form
into an annotation field background allows overlaying of data fields over the
background or standard form.

You're now almost finished designing the Form Letter print format.
+ Click Done.
You return to the Print Library. As you can see, the print format you just

designed has been added to the Print Library.

From the Print Library, let's preview the form to see if it centers to the page
correctly and to determine any other adjustments required.

+ Click Screen under Print to:.

*  Click the Print button.

The View Print window is displa;}ed:

= liewbPimt B cF————-———1

T _F' Brushwood Hills Estates Development Company

Bfi P.0. Box 4069, Matibu, California 90265-17%69
Al Hockwalt Sunday, Janusary 29, 1989
P 0. Box 7788

Saint Louds, MS 33401

Dear Al,

I wanted 1o take this opportunity to send you the floor plen of the Adventure modet
townhouse that you were interested in when you were in the office on 6/12 /88,

The down pavment on these Adventuras have been reduced to $24.500. If this provides any
renewed interestin the property, please give me a ¢all so that we might discuss the
possibility of moving youintec & new home

There is also a gond
chance that % might
be able 10 renegotiate
Bob Allen’s
commizsion o make
you e more favorable
Jeal.

Garage

Cance ) Hext ) (4]

Part 156. Form Letters and Mail Merge 283



adjusting the
position of the
letter contents

284

Filevision IV

If you scroll to the bottom of the page using the vertical scroll bar, you will
notice that there is a lot of "white" indicating that the letter is too high on the
page. This can be easily adjusted:

« Click the Cancel button on the View Print window.

You are returned to the Print Library dialog.

+  Click the Edit button.

*  After returning to the Follow up print layout, grab the Header area
stretch handle and reopen the Header. As the normal print area is
8" x 10" and as there is approximately 2" of white space below the
letter, stretch the Header to about 3/4".

The Each record: area moves down an inch to accommodate the larger header.

Frint HE

|||||l||II|Lll|||2||I|||||3i|ll[|||“'l|l||||lsl|||lllle"lllilll-"llG’1

Format-name: JEdiLiCSi

Header:

Each record:

Brushwood Hitls Estates Development Company
P.0O. Box 4069, Malibu, California 90265-1369

w3t naime t a0ne
[Current Mailing Address]

B8T | 1¥1ra3t NAme |,

IlI’-'iJ\||I||Mi||||||"|l||l!||

If you wanted to move the letterhead annotation field and line up, select both
the letterhead and the line field by using the marquee drag method (mouse
down outside the upper left and drag the pointer to the lower right encompass-
ing both fields). Use either of the two move handles that are now showing to
move the letter heading up into the Header area. The Header must be large
enough to accommodate both fields or the computer will beep at you and the
fields will snap back to the Each record area.

This same method (marquee drag selection) can be used to move all of the
fields to the right (or down) if required.




printing the
Form letters

Remember that there are two steps in printing form letters: designing a format,
and printing the form letter. You've just completed the first step, which is de-
signing the format.

The second and final step is printing the form letters. In this example we're
assuming that you have a printer with the appropriate software attached to your
system. There are several other printing options, however, and they are

covered in the sections beginning with Part 16, "Printing Recap” page 286, and
Part 17, “Special Printing Features” page 296.

»  Click Printer under Print to..
Clicking Screen would preview your form letters on screen, and clicking File
would create a Macintosh disk file of the output for use with a word processor
apptlication like MacWrite.

+  Click Print.
The records are sorted, then a standard printer dialog box appears.

+  Click the appropriate settings, then OK to begin printing.

That's it! Your form letters are printed, and the Print Library reappears when
printing is complete,
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16. Printing Recap

This section covers miscellaneous information that is common to printing all
Reports, Forms and Labels.

selecting You can print records for:

records to print
s all objects of a type
s highlighted objects of a type
» selected objects of a type

If you want to print records for highlighted or selected objects, they must be
highlighted or selected before you choose Print Records... from the File
menu

+ To print Forms, Reports, or Labels, choose Print Records... from
the File menu.

You'll see the Print Library. It contains any print formats you have created,

Print Library
Print format Type Style
Mail-Labels Salesperson Labet
Sales Report Salesperson Repott
Form-letier Salesperson Form
Form-letter tustomer Form
Letter (6r.) Customer Form
Records to prnint: Print to:

® Ml (O Printer

O tghlightes @ Screen

O selected (O File

If you forgot to highlight or select records, click Quit, take care of the highlight-

ing or selection, and return to the Print Library. You can always choose to print
All records.
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Page Setup...
dialog

If you selected Print Records... while working in the Info page, the record that
was showing at the time is the Selected record. If you invoked Print
Records... while working on the drawing page and had more than one object
of the current Type selected, then Selected includes ALL of the attached records
for those objects. If you entered Print Records... from the drawing page and
had no objects selected and a record icon was net present, then the Selected
radio button will not be selectable,

+  Choose the Print format you want to print from:

»  Click the appropriate choice under Records to print:.

The Macintosh has to know what kind of paper you're using.  If it’s anything
other than 8 1/2" x 11", continuous feed computer paper, make sure the page
setup is correct by clicking the Page setup button on the Print Library or by
choosing Page Setup... from the File menu.

For instance, labels are frequently packaged on 12" continuous feed stock; the
settings for it are shown below. Notice that 12" paper is shown as Interna-
tional Fanfold on the Tmagewriter Page Setup... dialog.

ImagelWriter w27

Paper: (O US Letier ) A4 Letter

1 US Legal ® International Fanfold

(O Computer Paper
Orientation Special Effects: [ Tall Adjusted

I 056 % Reduction
) No Gaps Between Pages

A less obvious use of Page Setup... is in printing much larger records using the
50 % Reduction check box. For example, if you create a type layout 16" wide
by 20" leng, you can print the whole thing on a standard 8 1/2" x 11" paper by
clicking the 50 % Reduction check box. Likewise, you could print a 27" record
using legal paper, which is 14" long. In printing ImageWriter label stock, be
sure to click the No Gaps Between Pages check box.

Standard paper sizes offered for the TmageWriter are:

s S Letter: 81/2" by 11"
s US Legal: 8 1/2" by 14"
» Computer Paper: 11" by 15"

* A4 Letter: 8.3" by 11.7"
+ International Fanfold: 12" label
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If you are using a LaserWriter, the Page Setup... shows a different dialog than
that of the ImageWriter:

Laseriliriter Page Setup 5.2

Paper: ® US Letter O A4 Letter ) Tabloid
CUS Legal O BS Letter Cancel

Reduce or Printer Effects:
Enlarge: ?"

] Fant Substitution?

@rientation B Text Smoothing?
1775 T@ Grophics Smoothing?
M X] Faster Bitmap Printing?

Here you are offered additional standard paper sizes of B5 which is 6.9" by 9.8"
and Tabloid which is 11" x 17". Special Printer Effects: are offered, scaled
reductions and enlargements and a special Options dialog for several other
effects:

| LaserlUriter Options 52
; ] Fiip Horizontal
T C 1
il [ FHip Vertical
[ tnrert Image
[ Precision Bitmap Alignment {47 reduction}

[ Larger Print Area (Fewer Downloadable Fonts}
J Unlimited Bownloadabie Fonts in a Document

The icon in the LaserWriter Options dialog changes to reflect any of the check
hoxes that are checked. In printing LaserWriter label stock, be sure 1o check the
Larger Print Area check box. Without this box being selected, the standard
page output for US Letter is 8" x 10" which clips the top and bottom 1/2" margin.
For additional informarion on Page Setup, consult your printer manual.

Your Page Setup... dialog box may look different, depending on the kind of
printer or printer software you're using.

Filevision actually offers three kinds of “printing”, as you can see from the Print
to: choices in the Print Library.

* "Printing" to the printer



This is just what you'd expect; normal printed output of your Forms, Reports,
and Labels, using your ImageWriter, LaserWriter, or other printer with the ap-
propriate software.

s “Printing” to the screen
Filevision lets you preview your printed output on the Macintosh screen.

e “Printing” to a file
You can create a standard Macintosh text file of the field contents (and names,

wherever $how field name and contents is selected from the add field dialog)
by choosing Print to: File.

printing to the »  From the Print Library dialog, click Printer under Print to:

rinter
P +  Click the Print button.

The records will be sorted and after a few moments this dialog appears if you
are using an ImageWriter,

Imagelllriter ¥2.7 l i1 4 l

Quality: T Best ® Faster O Draft
Page Range: @ All O From: || To: | | Eancel
Copies: D

Paper Feed: @ Rutomatic ( Hand Feed

or this dialog if you are using a LaserWriter:

Laserlifriter “Laserlriter” 52 m
Euuies:lil Pages:® ANl From: To:
Cancel

Cover Page: @ Mo () First Page (O Last Page

Paper Source: @ Paper Casseite O Manual Feed

After the printing is started, a status dialog appears letting you know the number
of copies remaining to be printed and the number of records remaining in each
of those copies:
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previewing
forms, reports
and labels on
the screen

200

Filevision [V

| Copies remaining to print l:l

Becords remaining in this
capy 236

Cancel ReSUME

If you are using an ImageWriter, the Pause button will be active and you can
pause at any time to change paper or make adjustments to the printout. Click
Resume to continue. If you are using a LaserWriter, the Pause button will be
inactive. The LaserWriter prints a page at a time while the TmageWriter prints a
line at 2 time. This means that Pause has no real meaning when using a Laser-

Writer.
- Click the appropriate settings, then OK to begin printing.

You can cancel printing anytime by clicking Cancel or by using the standard
Command-. (period) cancel action key chord

When you're designing formats, you're not always sure what the printed version
will look like. The Screen button on the Print Library offers a good way to find
out without wasting paper.

+  From the Print Library dialog, click Screen under Print to:.

« (Click the
Print
button.

Desert Golf Information
After a few mo-

ments you'll see
. ¥ ) I Fve West ]
the View Print Champ Yardage BH3
: ! Men's Yardage [EE
window: Ladies Yardage §5E
RLP Handitap (9)

CC's Handicap (9 B
Cancel returns CC's Handicap (27) 3

you to the Print [P NN ¢y ENSSS
Library.

Met quite a3 evil as it appears fromthe tee,
this hole requires the playerto hit the drive
andtheapproach shol over weter, Any

Next previews
shotright afthe [sirway s gonna drown. Ka

the next record or
page full of
records.

teeshotis hit{eft through the fairway on
this slight dogleg ight hole itcould also
find waker in the lake fronting Jix West's
areen orsand inthe greengide bunk

L]




saving Forms,
Reports and
Labels in a
disk file

Due to the size of the Macintosh Plus and SE screens, you can see only about
the leftmost 7" of the printed cutput when previewing. Use the scroll bars to
bring the rest of the page into view.

The View Print window will utilize the full size of the monitor being used.
Expand the window by using the window zoom box or resize box.

Headers and footers are shown at the top and bottom of the preview area.
Information in the Each record: area fills the screen (or page) in between with
as many records as will fit.

You can “print” forms, reports and labels to a Macintosh text file on the disk for
use with programs like MacWrite or other databases and word processors.

The text file includes only the field contents and where Show field name and
contents was chosen, the field name.  Annotation fields with pictures, and field
sizes and layouts are omitted so that any application that uses lab delimited text
files can use Filevision text files.

This same information can be exporied to an intermediate file using Import/
Export Text... from the File menu; however, for simple tab delimited file
handling, print to file provides an easy method. The file created using print to
file can be re-imported into another Filevision file or new Type by using
Import/Export... Text.

Ficlds are separated by tabs, and records are separated by carriage returns.

Click File under Print to:.

Ciick the Print button.

You'll be asked to name the file.

+ Typeinaname
) oy BH Ceuntiy Olub k¥ <= HDBO
»  Click the Save button. Lakes
After the file has been created,
you're returned to the Print Library.
Save printing in:
Course Description| | (“cancer )
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Editing print
formats

adding a data
field to the
print format
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You can reuse print formats, change them, or throw them out.  You can save -
up to 20 print formats in each file. You can even save copies of them in the
Scraphook.

This section, “Editing print formats”, assumes you are designing a new print
format or editing an existing one. To edit a print format, go to the Print Library
by selecting Print Records... from the File menu, select the format you want
to edit and click the Edit button. To stait designing a new print format, click
the New button.

You can put data fields anywhere in the Header, Each record and Footer areas.
When working in the Print layout, there are several buttons at the bottom of the -
window for performing various functions in setting up the layout:

|l[:uncel|lHenuue Field](Sort |[[EENAIIL]

» Click the Add Field button.

A small dialog box appears:

[Eancel ] [ﬂnnotation Field ||

= Click the Data Field button.

N,
Another dialog box appears. It shows a field name in a box and radic button
options in how you want the fiekd name to display (or not display):

Choose a field to add:

|K I ® Show field name and contents
ey k ) Show field contents only

- Move the mouse pointer 1o the field name box and press and hold
the mouse button to display the list of data fields in the type layout in
alphabetical order, allowing you to select one.



CC's Handicap 27)
CC's Handicap 9}
Champ. Yardage -
Comments

@ Show field name and contents
Ladies vardage ) Show Tield cantents only

™Men's Yardage
Name

Par

BLP Handicap 9)
View

+  Move the pointer to the field name that you want to add. Click Show
field name and contents or Show field contents only, depending
on how you want the field to look on the printout.

«  Click the Add button.

The dialog box disappears and the selected field appears in the middle of the
display.

«  Use the move handle on the top of the field to place the field where
you want it (see “moving fields” below, if you don’t know how to use
the move handle).

moving a field « To move a data or annotation field on a print format, first select it.

or fields on the

print format »  Select the move handle on top of the field and, holding down the

mouse button, drag the field.
+ Release the mouse button.

»  To move several fields at one time, first select the fields by dragging
a marguee around all fields to be moved.

Each record:
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Rield handles appear on all of the fields within the marquee:

{Address

Grab one of the top move handles with the mouse pointer and drag to the new
position:

Moving fields on the print format does not affect fields on the Type layout.

changing the . Move the pointer to the stretch handle on the lower right corner of

size of a field on the field.

the print format Press and hold the mouse button down and drag the handle to

siretch or shrink the field size.
Price ‘ Price

+ Release the mouse button.

Changing the sizes of fields on the print format does not affect fields on the

Type layout.
removing a field . To remove a field from the print format, select the field, then click the
from the print Remove Field button.

format

Remove Field ISur‘tHHdd Fieldﬂl]unel

Removing fields from the print format does not affect the Type layoul.
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using scroll bars
to move your
work area

The print format is often larger than the part you're working with on-screen; for
instance, most printers have 8 1/2" wide paper and the print format display on
smaller Macintosh monitors is only 6" wide. To maneuver around the whole
working area of the print format, use the scroll bars.

Address Mode! Price

Add Field
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17. Special Printing Features

This section explains:
* how to use annotation fields in printing
* how to use special information in printing
» how to use the Format menu
*  how to use the Text menu
e how to get running totals in forms and columnar reports
* how to sori records

* how to get statistics in columnar reports

adding You can use annotation fields on print formats for:
annotation
fields to the « titles for reports and forms (text or pictures)

print format

296

» column titles for reports {use underlined annotation fields with the names
of the data fields that make up the columns)

» print the contents of data fields {(for instance, in form letters)

» the page number (use the special characters &p}

e the system time and date (use the special characters &t, &T, &d, and &D)
You can put annotation fields anywhere in the Header, Footer, and Each record
areas.

«  From the bottom bar of the Print window, click the Add Field button.

ICuncell Romeve Fieid][Sort |EEMETRD

[Done]
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A small dialog box appears:

(Cancer ) (Data Freid ) |

*  Click Annotation Field.

The dialog box disappears and a blank annotation field appears in the middle of
the display.

*  Move the field where you want it and stretch or shrink it as appropri-
ate.

«  Type in text, paste a picture from the Clipboard or import a picture
using import Graphics... from the File menu into the annotation
field. 1f you type text, choose a text style, text size, color, back-
ground color and font from the Text menu.

Every record that’s printed will show what you just typed or pasted into the
annotation field.

You can also use “special information”, characters that print the page number,
the system time or date, or print the contents of another field. See “printing
with special information”, below.

Adding annotation fields to the print format does not affect the Type layout.

printing Filevision has a number of typewritten “special characters” that can he used in
with special annotation fields. Special characters are all used in conjunction with the

. . ampersaind (&).
information P

Special characters themselves aren't printed, only what they stand in for. For
example, &p will be replaced by the page number of the printout every time &p
is used in an annotation field.

¢ To use a special character, click the annotation field to select it, then type
one (or more) of the following:

¢ &p prints the page number.

= &D prints the system date in long form, for example, Tuesday, March 11,
1989,

Part 17, Special Prinfing Features 297



using page
Headers

stretching or
shrinking a
header
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« &d prints the system date in year-month-day short form, for example, 89/
03/11.

* &T prints the system time with seconds.
e &t prints the system time without seconds.

« The contents of a data field are printed if the field name is enclosed in
brackets, for example, [Name],

If you want to print an ampersand before a “p”, “D”, or “T”, precede the letter
with two ampersands. For example, to print “&p” you would type “"&&p”.

You can have information printed at the top of every page of a Form or Report.
That top area is called a page Header. All you have to do is put fields in the
Header box when you're editing the Form or Report.

The header area has stretch handles on its bottom; you can eliminate the header
by removing fields from it and shrinking it until it looks like a single line, or
stretch or shrink the header to any size.

+ Press and hold the mouse button on a stretch handle, drag until the
header is the correct size, and release the mouse button.

_ jineee————— =
|I|Illtll|l|Illllzllllllllsli!III|I41I|I|I|I5|I|I|I||6|]|1|I|I?{}

Format-name: FIgZ=naigh

Header:

Each record:

Footer:

J|||l||MI||<i||'1I||1I||

ancel][Rescue ¥ icid]bort)iAdd Field)Done]in] |

[

Headers are frequently used for:

« titles for Reports and Forms (use text or pictures in annotation fields)



» column titles for reports {use underlined annotation fields that have the
names of the data fields that make up the columns)

*» the page number (use annotation fields with the special characters &p)

» the system time and date (use annotation fields with the special characters
&t, &T, &d, and &D)

using page You can have information printed at the bottom of every page of a Form or
Footers Report. That bottom area is called a page Footer. All you have to do is put
fields in the Footer area when you're creating the Form or Report.

Label formats don’t have Headers or Footers.

Footers use exactly the same techniques as Headers, above.

contro"ing how When you're creating or editing print formats, you have a number of options
the contents of from the Format menu when you select a field.

fle_lds are. +  Click the field to select it. Then choose from these items on the
printed with the Format menu:
Format menu
= Alphabetic: Nothing special is done to the information as it’s printed. This
is the standard setting for ail fields except formula fields.

Alphabetic %0 |

L/ Numeric %0 o Numeric: If the field begins with a number, print only the number. You

can then choose whether you want commas, dollar signs, or a different
number of decimal places; see the following three paragraphs for more
details.

v Dallar Sign %€M
v Commas 3,

Decimals...  #. » Dollar Sign: Contents of numeric fields will be preceded by a dollar sign.

Statistics... 38- . .o .
tatis » Commas: Print the contents of numeric fields numbers with a comma

every 1,000.

Align Left #6
Align Middle 37
« Align Right 38
Show Border
Invert

Hide Field Name

* Decimals...: Contents of numeric fields will be printed using one of these
choices of decimal formats: no decimals, for whole numbers; or one, two,
three, or four digits to the right of the decimal point.

Display "Square feet" numbers with this decimal format:

Across... 7 037 Ay O7 ORI
Hide Ruler #¥R

Metric Ruler
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Close lines

300

these lines would
close if no data
were available

these lines would
not close

Filevision IV

e Align Left, or
Align Middle, or
Align Right: Field information can be aligned to the left, right, or center.

e Show/Hide Borders: Show borders causes the field borders to be printed,
Hide borders reverses it.

» Invert/Do Not Invert: Invert causes field names and the text contents of
annotation fields to be printed in white letters on a black background; Do
not invert reverses it.

» Hide Field Name: Prevents the field name from showing in the print
layout window and printed report.

* Across...: Across may be used for both Labels and Forms. It gives you
some control over how many records are printed horizontally. For ex-
ample, you can print from one to four labels across each page of label
stock. Or you can print more than one Form across each page, if the Each
record area is narrow enough.

Print how many records across each page?

The current setting is: 1.

Page setup... from the File menu or the Print Library (see page 287, “the Page
setup...” dialogue) determines the physical width of the page. So check your
page setup if Across... doesn’t do what you expected it to.

* Show/Hide Ruler: Show ruler displays a ruler on the top and left sides of
the print format. I’s never printed, except with Print page.

* Metric/Inch Ruler: The ruler can be either in inches or centimeters. The
miler is never printed, except with Print Page.

An automatic close lines function moves field information up to fill blank lines
in a Label or Form letter. Field names must be entered in brackets in a single
annotation field. Only lines that begin and end with brackets and that contain
no other information (such as the comma in the example) will close.

{Customer namel #
[Company} ¢ {{Customer namel
[Strest] i i [Company] N

fiiStreet]

——{Cityl, [State] [Zip] :
PiICityl, [State] [Zip]

i Dear[Salutation],




sorting printed
output

Sort is used to set the order for printing Forms, Reports, and Labels. Tt may also
be used to control where detail statistics are printed in reports.

“Cum:el stemeve Fioid @Mdd Fiald)[Done )

*  Click the Sort bution at the bottom of the Print format window.

Note: The sort field used on the Info and Drawing displays is not affected by
this choice.

You're presented with these choices:

Sort printing as follows: Start a new

B ) page for each:
Primary sort field:

[ Address | A-2Z O
[(1Secondary sort field:

[ g ] gz ]
[ ¥erdiery surt fiekd:

[ nonn ] P O

[ po not print duplicate sort fields

» To change the sort field, click the field name pop-up menu.

Primary sort field:

Availlahle? d:

Comments "

Floer Plan 1st fir) :I
Front UView

Link -
Model 1

No. of bathrooms
No. of bedrooms
Price

Square feet

hte sort fields

Secondary and tertiary sorting are sorting within the primary sort field.

* To enable secondary or tertiary sorting, click the appropriate box and select
a sort field with the pop-up menu,
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e To choose whether the sort fields will be sorted in ascending or descending
order, click the A-Z button.

Filevision normally prints the contents of a sort field only if they are different
from the last record’s.

« If the Do not print duplicate sort fields box isn’t checked, Filevision will
print the contents of a sort field regardless of the value in the previous
record.

« You can automatically start a2 new page each time the contents of one of the
sort fields change using the Start a new page for each checkbox next to
each sort field.

For example, if State is the primary sort field and the Start a new page for
each State box is selected for the secondary sort field, then a new page wilt be
started each time the name of the state in the State field is different from the last
record’s.

running totals in You can create fields on the type layout that will show running totals when
forms, reports,  P""Un8 ‘

and labels Let’s create a cumnulative inventory cost field in this hypothetical Type layout.
The layout already has Unit cost ficld and Quantity on hand fields.

«  Choose Change Layout... from the Types menu because you're
going to add a field to a Type layout.

«  Add a data field and name it Cumulative cost.

+ Choose Field Setup... from the Edit menu.

Setup for the Cumuiative cost Tield:

(O standard O Copy from previous record
O Initial Text @® Compute using a formuia
Formula:

[Unit costl*[Quantity on hand]l+[Cumulative costl

Field Names: il:umulatiue cost |
[ cancel ] [_Preu Field ] [ Next Field Done ]

302 Filevision IV



Table 3-6

using statistics
in columnar
reports

+ Click the Compute using a formula button.

+  Type [Unit cost] * [Quantity on hand] + [Cumulative cost].

+ Choose Doilar Sign from the Format menu

« (Click Done.

The Field Setup dialog disappears.

e Click Done (o save the revised Type layout.

Here’s a table showing what might happen in the first three records of the file:

Quantity Cumulative cost Cumulative cost
Unit cost on hand (on Info page) {on Report layout)
$3.00 4 $12.00 $12.00
$5.00 6 $30.00 $42.00
$8.00 6 $48.00 $90.00

Note: Running toral fields show the contribution 1o the running total on the Info
page, and the accumulation on Forms, Reports, or Labels. In more technical
terms, it means that formula fields that refer to their own values use a value of 0
when computing their values on the Info page. But in Forms, Reports, and
Labels, they use the value printed for the previous record.

Reports allow you to get statistics about fields.

+  Click the field for which you want statistics.

» Choose Statistics... from the Format menu.
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Overall statistics

Detail statistics

304

Filevision |V

You're given these choices for statistics:

Statistics for: |Price |

Standard

Ceunt Total Arerage deviation
Overall statistics . . . . [ O il O
ByRddress . . . . . . . O O O O
By Square feet . . . . . O (| {1 (N
ByPrice . . . . . . . . O O 4 O

Use "Sort” 1o select different detail statistic fields.
Seipet Numeric T o the Formel meau 1o saable af statisting,

Cancel Prev Field

If the field vou selected is Alphabetic according to the Format menu, the only
statistic available will be Count. You can treat a field as numeric for printing
purposes by selecting the field and choosing Numeric from the Format menu
while you are editing a print format. However, on the Info page, only formula
fields are numeric, so don’t worry if you' make a field Numeric for printing
purposes and find out that it’s still Alphabetic on the Info page.

There are two ways statistics can be used: as overall statistics and as detail
statistics.

»  Click Overall statistics if you want statistics to be computed at the
end of the report.

For example, if you chose Overall Average for a Price ficld, and the price of the
items average $199,500, then at the end of the report this will automatically be
printed:

Overall Average: $199,500

+ Click the detall statistics {By Address in the above example dialog)
if you want statistics to be computed whenever the value in a sort
field changes. The statistic is printed with the name of the field and
type of statistic in front of it, just after the value in the specified sort
field changes.

For example:

Address Average: 186,000



Counts

Totals

Averages

Standard
deviations

If you want detail statistics for a field it must be one of the sort fields; see
“Sorting printed output”, page 301. This refers to the sort fields as established
from the print layout Sort function, not the Info page sort field. If the Primary,
Secondary and Tertiary sort fields are all active, statistics will be available on all
three fields.

»  Click Count to count the number of occurrences of that field in the
report.

It counts only unique occurrences of values in a sort field, so:

* If you sort on the Address field and have a total of 28 records from all
addresses, and you count addresses, you'll get a count of 28 addresses.

« If the field you are counting is alphabetic but not a sort field, then all
records that are printed are counted, regardless of repeat occurrences of a
value.

e If the field you are counting is numeric but not a sort field, then only valid
numbers and empty fields will be counted. Empty fields are treated as con-
taining zero.

« Click Total to add the values of a single field.

If a file has three records, and the Orders received fields in them contain 11,
21, and 13, then an overall total of the Orders received field will print 45.

» Click Average for the average of values in a single field.

If a file has three records, and the Orders received fields in them contain 11,
21, and 13, then an overail average of the Orders received ficld will print 15.

«  Click Standard deviation for standard deviation according to this

formula:
2 (;( - Xi )2
Sx — —
n-1

average of x

>
i
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If a file has three records, and the Orders received fields in them contain 11,
21, 13, and 32, then an overall standard deviation of the Orders received field
will print 8.

sample Report Here's an example of a what a very small Report listing could look like:

August Salss by Selected Regions
Division Region Sales
Seattle Western $123,000
San Francisco $286,976
Los Angeles $766,768
Region Total: $1,176,744
Region Average: $392,248
Chicago Central $498,722
Houston $323,685
Region Total: $822.407
Region Average: $411,204
New York Eastern $658,732
Miami $552,456
Region Total: $1,211,188
Region Average: $605,594
Overall Total: $3,210,339

306 Filevision IV



. Reusing print
formats

copying the
print format

pasting the
- print format

- saving a print
format in the
Scrapbook

You can copy an entire print format onto the Clipboard, then paste it into
another format in the file or save it in the Scrapbook for use in another file.

This is often helpfu! when you're creating several print formats that will have

similar characteristics. It saves you the time required to create them from
scratch.

*  While you're editing a print format, hold down the Option key and

choose Copy from the Edit menu.
A copy of the print format is now on the Clipboard.
Remember that the next thing you cut or copy will repiace the print format on
the Clipboard, so you may want to save it in the Scrapbook.,
«  While you are editing a print format and you have a print format on

the Clipboard, choose Paste from the Edit menu.

A dialog box appeurs, warning you that you are about to replace the print
format you are editing with the one on the Clipboard.

Pasting wili replace the entire layout with the
one on the Clipboard.

You will not be able to undo this action.

(This only works if you have a print format on the Clipboard.}

While you have a print format on the Clipboard, you may want to save it in the
Scrapbook.

« Immediately after you've copied a print format onto the Clipboard,
choose Scrapbook from the Apple (8§ ) menu.

+ Choose Paste from the Edit menu.
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imported
graphics in
print formats

308
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The Scraphook will show this information about a print format:

f[E=——————=———= Scrapbook =—-——=—“‘“——|

Filevision® Iv¥ PRINT FORMAT

Formmat-name:  Travel Report
Type-name:  Alport

Style: Report

From file: Widgets

1125 FwFF, TEXT

All of the information necessary to recreate this print format in another Type or
another file is now stored in the Scraphook. Even if you were to remove the file
that this print format was taken from, the format could be used in other
Filevision files.

If you have set up a new Form and decide to paste in a Report from the Scrap-
book, the current Form will be changed to a Report. The current print formar's
Type fields must include the Type fields that the original print format was saved
from or the paste will not function properly.

Only the data and annotation field set up and text entered in annotation fields is
stored in the Scrapbook. Any graphics in annotation fields aren't saved. If the
graphics being used in these annotation fields are not easily accessible from
their original source, they should be copied and pasted to the Scrapbook
separately.

Graphics may be imported into or exported from print layout annotation fields.
This includes PICTs, bit or pixel mapped Paints and EPSF (Encapsulated Post-
Script Format) graphics, All of these graphic formats can be copied to the
Scrapbook and can be used by other Filevision files. See the section on Import-
ing and Exporting Graphics, page 151.



Printing what
you're working
on

Print Page...

You can print your current activity easily.
Depending on what you're doing, you can guickly print:

¢ The Info page record you're looking at or
¢ Any section of the drawing page or

¢ A Shade or Symbol Editor page or

* The Print Layout page.

= To print your current activity, choose Print Page from the File menu.

If you are working on the Info page, the following dialog will be displayed:

Select info pages to be printed:

Select any one or group of the page rectangles that vou want to print by
clicking on it. Each rectangle represents an 8" x 10" section of the full size Info
page working area.

If you are working on the drawing page, the following dialog will be displayed:
Again, select the page or pages that you would like to print by clicking on the
corresponding page rectangle.

Select drawing pages to be printed:

B4 Print guides
[ Print grid

You also have the option to print the guidelines and/or grid by checking the
appropriate check boxes. Grids and Guidelines will only print if they are cur-
rently visible on the drawing page.
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18. Editing Tools and Other Features

Using the
editing tools

310

Filevision IV

Editing tools provide ways to use Filevision efficiently and in concert with other
Macintosh applications like MacPaint and MacWrite.

The editing tools (Cut, Copy, Paste and Clear) not only work on Filevision
graphics and text, they can also be used to copy the symbeol and shade palettes,
Type layouts, and print formats onto the Clipboard and Scrapbook for use with
other Filevision files.

The Clipboard and $Scrapbook let Filevision trade information with other appli-
cations like MacPaint, and among its own files.

Understanding the Clipboard is central to using the editing tools. The Clipboard
is where the last object that was cut or copied is stored. The Clipboard only
holds one thing at any one time, so if you cut an object, then another, you won't
be able to get the first one back with Paste or Undo. Use the Scraphook to
hold several items; anything that can be put on the Clipboard can go into the
Scrapbook, and your Scrapbook is limited in size only by disk space.

You can hold these things in the Cliphoard or Scrapbook:

s [ext

* pictures

» graphics and their records
¢ Type layouts

» print formats

» single symbols

symbol palettes

single shades

shades palettes

This section shows how Cut, Copy, Paste, Clear and Reshape can help you
get the most out of Filevision Cut, Copy, Paste and Clear are shown on both
the Drawing and the Info pages, and Copy and Paste are shown in use with the
symbol and shade editors, and the Type and print layouts.



Cutting graphic
objects

Cutting something moves it to the Clipboard. The next item to be cut or copied
replaces it, so if you want to save it permanently, paste it into the Scrapbook.

Copying something duplicates it onto the Clipboard. The next item to he cut or
copied replaces it, 5o if you want to save it permanently, paste it into the
Scrapbook.

If you select more than one object , you can cut or copy them all at ence.

The Clipboard is the only way to the Scrapbook. To paste something into the
Scrapboolk, it must first be on the Clipboard. To get something onie the Clip-

hoard, copy or cut it.

The Scrapbook can hold anything the Clipboard can; the difference between
them is that the Scrapbook holds more than one item at a time.

s Select the object or objects.

T ~

r % file Edit Types HAccess Dptions Text Symbois Shades
—————————— LEditing Tools - Actual §ize = ———+ gl‘

S T A Y IS T -

] ) L
3 4
g t | O
E ~ |
3 " =™
E
=
E [
-

'|||||

Background: Oid Glary Ruler: Inches

e Choose Cuat from the Edit menu.

The object vanishes,
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Old Glory

Rul er: Inches

Background: 0id Glory

When vou cut an object, it doesn’t just wink out of existence. It gets moved to
the Clipboard. You can paste the object into the Scrapbook and use it in
MacPaint or inn another Filevision file. However, as soon as you cut or copy
another object, the new one will replace the one on the Clipboard, so paste it
into the Scrapbook immediately if you plan to usce it later.

tf you cut an object that has a record, the record is cut along with the object,
and is also moved onto the Clipboard.

Copying and “Copying” something means to copy it onto the Clipboard. In this example

pasting objects

312

we'll make use of that fact by pasting a copy of an object several times to save
ourselves the work of drawing a new one each time. This technique is espe-
cially useful when you want copies of a graphic to repeat in precise relationship
with its parent (original) graphic.

= Click the object to select it.

L]

o

»  Choose Copy from the Edit menu. Though it looks like nothing has
changed, there’s now a copy of the object on the Clipboard. You can
now make as many duplicates of it as you want.

Filevision IV



copying and
pasting the
symbol palette

«  Choose Paste from the Edit menu.

The object appears in the middle of the display or near a currently selected
chject.

» Use its move handle or grab anywhere on the line or background (if
filled with glass or a shade) to place it.

L

«  Without deselecting the pasted copy, Paste the same object (or
objects) as many times as you want.

Each pasted copy of the object will be positioned in the exact relationship with
the last pasted object as the first pasted object was to the parent object.

If you copy and paste a graphic that has a record, the record is copied and
pasted with it. Pictures in fields aren't pasted.

You can save a single symbol or the whole symbol palette in the Scrapbook for
use with another Filevision file.

The symbol and palette is the set of 40 symbols you see on the Symbols menu.

«  (Choose Editor from the Symbeols menu or double-click on the
symbol tool in the tool box.

The Symbol Editor display appears.

« Tocopy a single symbol onto the symbol palette, choose Copy from
the Edit menu.

« To copy the entire symbo! paletts onto the Clipboard, hold down the
Option key and choose Copy from the Edit menu.

A copy of the symbol or symbol palette is now on the Clipboard.
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« To copy the symbol palette into the Scrapbook, choose Scrapbook
from the Apple menu, then choose Paste from the Edit menu.

You'll see this information about the symbol palette in the Scraphbook:

[l [+]

s[[==—— Scraphook

Filevision® ¥ SYMBOL PALETTE

Fromt file: Editing Tools

FySY, TEXT

To use the symbol palette in another file:
»  Choose Close from the File menu.

+ Choose New... or Open... to start a new file or open and existing
one.

« Click Drawing if you are looking at the Info display.

= Choose Editor... from the Symbols menu or doubte-click on the
symbol tool in the tool box.

« Choose Paste from the Edit menu.

copying and Copying and pasting the shade palette is done using the same method as the
pasting the symbol palette. (See above)

shade palette
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copying and
pasting Type
layouts

You can save Type layouts in the Scrapbook for use with another Filevision file.

Choose the Type whose layout you want to save from the Types
menu.

Choose Change Layeut... from the Types menu.
Select any field or the Type-name box.
Hold down the Option key and choose Copy from the Edit menu.

To copy the Type layout into the Scrapbook, choose Scrapbook from
the Apple menu (# ), then choose Paste from the Edit menu.

You'll see this information in the Scrapbaook:

=1

Scrapbook 0n—c————|

Filevision® IV TYPE LAYOUT

Tvpe-name:  Edit Features
From file: Editing Tools

1132 FyTL, TEXT

To use the Type layout in another file:

Choose Close from the File menu.
Choose New... or Open... to start a new file or open an existing one.
Choose Add Type... from the Types menu.

Choose Paste from the Edit menu.
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copying and

pasting
formats

316

print

Filevision IV

You can save print formats in the Scrapbook for use with another Filevision file.
« Choose Print Records... from the File menu.
The Print Library appears.
= Click the name of the print format you want ta copy.
«  Click the Edit button.
The print format appears.
«  Hold down the Option key and choose Copy from the Edit menu.
A copy of the print format is now on the Clipboard.

- To copy the print format into the Scrapbook, choose Scrapbook
from the Apple (4 ) menu, then choose Paste from the Edit menu.

You'll see this information in the Scrapbook:
Filevision® IV PRINT FORMAT:
Format-name: Listings
Type-name: Townhouse
Style: Report
From file: Tour
To use the print format in another file:

+ Choose Close from the File menu.

+  Choose New... or Open... from the File menu to start a new file or
open an existing one.

«  Choose Print records... from the File menu.

- Click New, then Report, Forms, or Labels, whichever is appropri-
ate—Report in this example.

+ Choose Paste from the Edit menu.



Clearing objects

Reshaping

Clearing is an alternative to cutting. The only difference is that the object isn't
copied onto the Clipboard. If you make a mistake and realize that you didn’t
want to clear the object, you can restore it with Undo last change.

+  Click the object to select it.
«  Chgose Clear from the Edit menu.
The object vanishes.

It’s not stored on the Cliphoard the way it would be if you had Cut it, so the
only way to restore it if you made an error is to choose Undo from the Edit
menu immediately,

Reshape is used to modify straight lines, frechand lines, arcs, rectangles and
polygons. Each of these objects (except arcs} are drawn with an anchor point
(reshape handle) every time the line changes direction, These handles can then
be dragged to new positions which stretches the connecting lines like rubber
bands. Anchor points can be added anywhere on the line to create a new po-
tential change of direction point.

To reshape, you can either add reshape handles or move the existing handles of
an object, then stretch or shrink the line between the reshape handles.

In this example, we will change a straight line into a square wave form.

« First draw a single horizontal line the length of the square wave.
Hold the Option key down to constrain the line to horizontal.

+  Move a horizontal guide line down from the top ruler, dragging it with
your mouse pointer.

» Select the line and choose Reshape from the Edit menu.

= Add the reshape handles by clicking where you want them. Use the
pointer tool to add a reshape handle to every juncture (click at that
point on the line).

!

vﬂ
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Other features

memory and
disk use

318 Filevision IV

«  Grab any area of the line between reshape handles an drag the point
to the guide line.

n—F\Fﬁ—= — = — =a

« Grab the next area on the half finished square and do the same.

- Repeat these steps until the square wave is finished.

S I D AU I I B

You can remove points by dragging one point on top of another, a process
that's made easier when alignment is on. You can turn on alignment temporar-

ily: hold down the Command key before you drag the point.

+  Click the pointer tool or cfick on an inactive area to deselect the
square wave object and end reshaping.

This section contains information on miscellaneous Filevision features:
e memory and disk use
* using Save As... on the File menu

+  To find out how much memory and disk space you have left, choose
About Filevision® 1V... from the Apple (# ) menu.

= Filevision® IU
Z Dersion 1.0 - Thursday, April 6, 1989
Copyright 1985-1989 Marvelin Corporation.
Phone: (213) 450-6813
By David Murray, Matthew Jacobs, Robert Jeckell,
Howard Metcalfe & Scott Sullivan. Rewritten by
faulkner White.
“Brushwood Heights" uses:
52328 bytes of memory, 506K of disk.
Approximate room to grows:

416504 bytes, 4331K disk.




Using Save as... Saveas...on the File menu lets you save a duplicate of the file you are work-
ing on, without leaving it.

Use it when:
* You first open an important file.

+ You are about to make a major change to a file and would like to have a
backup.

+ Select Save As... from the File menu.

NG

Gpei..,

Close US Map w/cities
Save ®S
Save As... k
Return to Brushwood..} 3%;

Import Graphics...
Export Graphics...
Import/Export Text...

Page Setup...

Page Size...

Print Page #0U
Print Records... #p
Quit %0

The save dialog will be displayed with the file name preceded by Copy of
already entered.

M HBaw tane Q = HD8a
Dy Bruehipopi

0 Hrushusnod Heighls
0y Wrushupont Hedghls..

fjent

<

!

Save a copy in:

Copy of US Map w/cities

(Cancel )

Use the name as is, or change it to one of your choice.
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#14-586-3800

2 j ﬁ WORKORDER ¥ Dl.:ri;:‘ulsx:;.g&
_ éﬁ 20034 10:00 AM
FPRIMTING SAHD R AFPHICS IHC ORD EFI BY:
23024 LAKE FOREST DRIVE ¢ LAGUNA HILLS o CA 92653 Denise A
Customer:] [Shipte:]
Protec Comporabion c.PU. [ Date: | 3123184}
2420 El Toro Blvd,
El Tore, CA 92650 [Phone: | {714} 386-8820
Date | Time |Who Regarding Date [ Time {whao Regarding
PRE-PRESS: Estimake Extenzion
Typesetting, Paste up: 30.00 25895
Customer changes: 4995
Negs and Plates: 10.00 10.00
PRESS:
DESCRIPTION BUN X UP = TOTAL COLORS UNIT
P1 | Letterhead 1,000 i 1,000 2 B850 65.50
P2 | Envelope con i 500 2 59 90 34.95
P3 | Business Card 250 4 1,600 2 34.50M 34.50
P4 | Pads 1,000 4 4,000 2 9.50/M 38.00
P5
kATERIALS:
QPD IN PAPER STOCK COLOR SIZE BASIS
51 % Clagsic Linen ety 3.5x11 29%
52 X Classic Linen Isvory 10 24%
53 x Classic Linen Ivory 2x3.5 Bo#
54 % Meenah Bond 'White 4 %5 208
55
ORD N INK.COLORS
i1 * Black PhS 293 Green
12 Same Same
13 Same Sarne
4 Same Same
15
BINDERY { SPECIAL INSTRUCTIONS: PRICE { UNIT
B1
B2
B3 | Ttim NC
B4 | Padin 503 25 paud 20.00
BS
Press YWash-upls] 15.00
Orderapproved by: PMS Ink colors 40.00
Sub Total 336.8S
Tax/Resale 20.21
Shipping
Signature Total §357.06
Cash-Ck #3054 Deposit $200.00
COoD. Balance $157.06

| Courtesy Printex
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| Reference

Overview

Section four is the reference section and includes several appendices and a
glossary of terms to enhance the use of Filevision.

Appendix A, “Filevision specifications”, lists Filevision’s attributes in a series of
tables.

Appendix B, “Converting Filevision files for use with Filevision IV”, shows you
how to use the “Convert” application that comes with Filevision IV. This is
only for owners of the original Filevision. Conversion of Business Filevision is
also covered as part of the Filevision to Business Filevision to Filevision IV
COMVErsion process,

Appendix C, “Filevision IV menus and primary dialogs”, shows pictures of all
the Filevision menus with all menu items enabled and the dialogs that are
displayed where applicable.

Appendix D, “Shortcuts and Special key combinations”, lists all the double-
clicks you can use to shortcut the menus. This section also lists all the com-
mands that require holding down a key while clicking or choosing from a
menu, like pressing Option while drawing with the oval tool to draw only
circles. A command key chord chart is also included.

Appendix E, “Filevision error messages”, expands on error messages the
Macintosh or Filevision may issue. For example, you might leave out a paren-
thesis or bracket in the formuta for a computed field, or you might try to print
without the printer properly attached. This section tries to help you understand
and correct such situations.

Appendix F, “How to Import and Export text with other programs”, provides
examples for importing and exporting specific target programs. Included are
exchanges between Filevision, Filemaker, Helix, MacWrite, Microsoft File,
Multiplan, Omnis and OverVUE.
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Appendix G, “How to enter character codes”, explains how to enter ASCII
characters codes to set parameters for processing Imported and Exported texc
files. This section also provides a table of all ASCII character codes for refer-
ence.

Glossary, provides a brief explanation for all of the major terms used in
Filevision IV.

Index, provides a quick lookup of where to find the information on any subject
in Filevision IV.



Appendix A:

Filevision IV specifications

Table 4-1

File specifications

Maximum file size: 16 megabytes
Minimum file size: 10 kilobytes
Maximum number of Types per file: 3z

Maximum number of objects and/or records
allowed per file:

Maximum number of fields per Type

32,000 - Limited by memory and
disk space.

File recovery - Info page:
File recovery - drawing page.

255
layout:
Maximum number of characters per field: 8,000
Maximum number of characters per record: 16,000
File Save - Info page: Automatic
File Save - drawing page: Manual

To last manual Save plus
To last manual Save

Maximum length of field name:

31 characters

Maximum field size for graphics:

30" by 30"

Maximum graphic size per field:

Maximum freehand or polygon graphic size:

Limited by memory

3,000 anchor points

Maximum size of drawing page:

30" high by 32" wide

Maximum size of Info page:

30" high by 30" wide

Maximum number of text characters as one
object on the drawing page:

Graphic formats that can be imported:

4,000 characters

Paint {bit or pixel mapped), PICT,

EPSF, Filevision IV (PicB)

Discrete object graphic import:

PICTs, Filevision IV (PicB}

Color supported:

Version 1 internal

Version 2 as imported graphics

Appendix A: Filevision IV specifications
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Table 4-2

326 Filevision IV

Working with files

Query (Highlight)
conditions for
graphics and/or
records

Up to 4 conditions

Value comparisons

Interfield comparisons

Rank comparisons

Can replace, refine or expand existing query

Fades graphics that do not meet highiight conditions
Provision for manual highlighting of objects

Evaluation order of
query conditions

(A and/or B) and/or {C and/or D)

Find
Find via Highlight

22 significant characters (sort field only)
8,000 significant characters {any field)

Wildcard characters
in Find and Highlight

(double petiods) matches any string of characters
A constrains search to first word in field
@ matches any single character

Link function

Chains unlimited number of files with nesting to 5 levels

Sort By Sort on any field in the information entry mode

Sort Sorts to 3 levels in the print records mode (independent of
Sort By)

Hide/Show Hides or shows selected graphics or selected Types
Suppresses selection of the Type's objects

Ignore/Activate

Import Graphics

Will import graphic formats directly from MacPaint, PICT
(discrete ohjects or single object) or EPSF files

Export Graphics

Will export the selected graphic to a PICT or EPSF file.

Import/Export Text

Will allow the import or export of text files from other
Macintosh programs or other systems by the use of an
internal filter capability




Table 4-3

Drawing and graphics

Drawmg area

Up to 30" by 32" selectable in page increments of 8" by 107

Graphic objects

Text - font, size, style, color, masked and mask color
Symbols - 16 x 16 dot editable from a palette of 40
Shadaes - 8 x 8 dot editable from a palette of 40
Straight lines - constrainable to 0°, 45° and 90° angles
Polygons - constrainable to 0°, 45° and 90° angles
Reclangles - constrainable to squares

Round rectangles - infinite corner radii control

QOvals - constrainable to circles

Arcs - elliptical or circular, shaded or nen shaded
Freehand lines - from 1 to 14 point

Imported graphics

PICTs (discrete object or single object), EPSF {Encapsu
lated PostScript Format), MacPaint (it or pixel mapped)
and Filevision 1V (PicB which includes attached records)
Any currently available clip-art.

Filevision IV symbaols and symboi palettes.

Filevision IV shades and shade palettes.

Lines

Shades

Adjustable width - none to 14 points in incremerts of 1 pt.

38 editable plus Glass which is transparent but selectable,
None is transparent and unselectable. Glass and None
can not be edited.

Object selection

Shown with handles bllnklng black or nothlng

Multiple selection

As with the Finder; using marquee and Shift/click methods
Using the Option key when selecting objects with a marguee
constrains the selection to tha current Type anly. Multiple
selection allows a single action to affect all selected objects;
for example, all selected graphics will be filled with a shade
chosen from the Shades menu.

Stretch and shrink

Stretching and shrinking of graphics can be constrained to
square stretch using the Option key and a proportional
stretch using the Shift and Option keys together.

Drawing layers

32 individually controllable via the Types and Access
menus.

Overlapped
graphics

Unlimited layers in a front and back relationship. Object's
positions can be altered using Bring To Front and Send To
Back. All objects retain their individual Type identities.

Appendix A: Filevision IV specifications 327



Table 4-3

continued Drawing and graphics: continued

Grouping

Graphic and text objects can be grouped "permanently”
using Group (ithey can be ungrouped at any time). Graphic
objects and their records can be grouped and ungrouped.
Graphic objects of different Types or with more than one
record between them can be temporarily grouped using
Gather. Grouping is restricted to a maximum of 10 Ievels.

Pop-ups

Pop-ups are grouped graphics consisting of a trigger button
and a pop-up body. The body is invisible and unselectable
until the trigger button is selected.

Double-click

Can be set to go to the object's record, to activate a file link
or to be ignored.

Page zoom views

Selectable in Actual size (100%), 33%, 50% or 200% zoom
views. All drawing and text is fully functional in all zoom
views.

Colors supported

All graphlc objects, symbols and text can be foreground and
background colored in Black, White, Red, Green, Blue,
Cyan, Magenta or Yellow. Background colors will be
converted to White when using a monochreme monitor.
Imported graphics from Version 2 (256 color palette) and
gray sc:ale scanned lmages are supported

Grid

Optional. Adjustable in 1/12" increments from 1 to 120. Can
he printed or suppressed when using Print Page.

Rulers

Optional. Selectable from Inches Centimeters, Points and
Pixels which are ali proportional and Fest, Yards, Miles and
Kilometers which are all scalable. Adjustable zero point,
starting values and page orientation (upper left or lower left
ongm)

Guide lines

Optional. Vemcal or honzontal dragged from the ruler bars.
Enable or disable Snap To Guides or Show/Hide functions.
Can be printed or suppressed when using Print Page.

Alignment

Optional. Adjustable in 1/72" increments from 1 to 71.
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Table 4-4

Adding and removing information

Editing tools

Superset of standard Macintosh editing tools. In addition to
cut, copy, paste and clear for text, these items may also be

cut, copied and/or pasted: Graphics and their records, Type
layouts, print formats, single symbols and symbol palstie,
single shades and shade palette.

Record deletion

Selected graphic(s) only. Selected graphic or group and i{s
record. Selected record only. All highlighted objects and/or
their records. Complete Type with all records and graphics.

Fields

Data, link or annotation. Data fields can be added, deleted or
changed from record to record and can contain either data or
graphics. Annotation fields can only be changed from the
Type layout form. All fields are size adjustable at anytime.
Individual field selection for fonts, font sizes, font styles and
font colors.

Data entry

features supported. Link fields can be hidden or displayed.

Tab moves to next field. Shift-tab moves to previous field.
Option-tab moves to the first field. Formula fields are only
editable for succeeding records. All Macintosh editing

Field setup

Standard (holds numbers, text or pictures), Formula, Initial
Text (enters this in each new record) and Copy from
previous record.

Formula field
specifications:

Operators: + - / *

Numbers from 9,995,999,999.9999 to -9,999,999,999.999
Unary operators: + - ¥

Commas entered in numbers are ignored

Square bracketed field name enters contents of a field.
Nested parentheses up to 15 levels

Absolute value: |value|

Local currency symbols entered in fields are ignored

Text following a numeric entry is ignored

% multiplies the preceding valuse by .01

Clipboard &
Scrapbook can
hold:

Text (can be expoited to other applications)
Pictures (can be exported to other applications)
Records

Graphics and their records

Type layouts

Print formats

Single symbols and the symbol palette

Single shades and the shades palette
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Table 4-5
Printed output

Copy of current
activity

30" by 32" drawing page selectable in any 8" by 10"
increments. The current Info page up to 30" by 30" select-
able in any 8" by 10" increments. The Type layout. The
Symbol and Shades palsttes. A Print format. Highlight
conditions.

Styles of printing
records

Forms (can be used for form letters and mail merge)
Reports
Labels

General features
Forms, Reports
and Labels

Generated automatically from the Type layout. Completely
editable.

Can be soried on up to three fields.

Headers, Footers and Each record areas occupy any
amount of space on printout.

Data fields can be moved, removed, resized and used in
multiple locations.

Annotation fields independent of the Type layout annotation
fields.

Special information such as system date and time in two
formats each, current page number (Form or Report only).

Print formats {editable layouts for printing Forms, Labels and
Reports.

Up to 20 print fermats can be saved in each file's library.

Reports, Forms and Labels can be previewed on screen.

Reports, Forms and Labels can generate text file output.

Field alignment: Center, Right or Left

Field formatting: As numbers, as text, numbers with
commas, decimal point {1 to 4 places) and currency
symbols.

Annotation fields

Report statistics

Sort

Can print: Fixed text or pictures on each record.
Pictures can be pasted from the Clipboard or imported
directly fram PICT, bit/pixel map or EPSF files.
Contents of data fields (field names in square bracksts []).
Special infarmation.

Count, Total, Average, Standard deviation
For entire report or by break
Running total

Can sort on up to 3 fields in printing. Ascending or
descending order. Printing of duplicate sort field information
can be suppressed. Optional new page (form feed) on
report break points.
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Appendix B:

Converting files for use with Filevision v

Converting
Filevision files
to Business
Filevision

Before you can convert Filevision files to Filevision IV format, you must first
convert the file to Business Filevision format.

The Convert application on the Start-Up Disk converts the original Filevision
files into Business Filevision for just that purpose. Once ihe file is in Business
Filevision format, Filevision TV can convert the file automatically.

Because the Start-Up Disk comes to you almost full, the best way to use Convert
is to copy it onto a disk of its own along with the "System" and "Finder" files.
Remember to leave disk space on it or the external disk for the converted files,
and keep in mind that the Filevision IV files may take up to 400% more space
than the original Filevision files and 100% more than Business Filevision files.

This example assumes that the disk in the internal drive contains the "Fincer",
“System", and "Convert" files on it, and that the external drive is less than half
full and contains the Filevision 1 files to be converted.

+  Click the Convert icon:

Filewizion Convert

«  Choose Open ... from the deskiop File menu.
A gray desktop appears.
« Choose Open ... from the Convert File menu.

You'll be given a list of Filevision files on that disk:
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{ €3 Hydraulics Folder |

G BF-START HYD.DESEGN 2 E = Genus
£ DRAIVING FILE

If you don't see any Filevision files listed, click the Drive button.
+  Click the name of the file you want converted to select it.

+  Click the Open button.

The convert program suggests a name under which you can save the converted
file; type in a new one if vou wish.

[€3 Hydrauiics Folder]

3 DRAWING FILE ﬁq o Genus
TyOSTRET BYRBELIEN 2

Eject

Drive

save converted file as: L Seve |
BF_START HYD.DESIGN 2 (Cancel )

+  Click the Save button.

A conversion progress dialog will be displayed:

Converting Filevision® file "START HYD.DESIGN 2" to
Business Filevision® file "BF-START HYD.DESIGN 2",

18% complete
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Converting
Business
Filevision files
to Filevision IV

After a few moments your Filevision file will be converted and the gray desktop
reappears. To convert any other files, repeat these steps.

«  When you're finished converting files, choose Quit from the File
menu.

You now have a Business Filevision version of your file.
To conveit Business Filevision files to Filevision IV , use the following proce-
dure:

« Launch Filevision IV as you normally would to open a new or existing
file.

+ Choose Open... from the File menu.

The nomal Filevision IV Open dialog appears:

& POL Filevision

2 Hyd. Design 2 = Genus

[ Hydraulics Folder

I Inside Mac Folder
[ Journal Index Folder

[ Karmann Ghia Folider
1 Lendscaping

[ Lease Map Folder
(o Living Room Inventory
[ LT ROCK APARTMENT STUDY [T

«  Select the file to be converted and click the Open button.

A Filevision IV conversion dialog will appear asking if you want to save a back
up copy of the file in Business Filevision.

0 This is an older version Business Filepvision file.
If you continue, the old persion will be lost.

ag—

save back-up|
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*  If you wish to save the back-up, click Save back-up.

«  If you want to go directly into the conversion, click the Continue
button.

After a few moments, the file wilt be converted and Filevision IV will open with
the new file running.

file icons If you have converted from Filevision to Filevision IV, the file icons created will
appear as:

Filevision

START HYD DESIGN 2

Business Filevision ———— &I

BF-START HYD.DESIGN 2

Filevision TV

e

BF-START HYD.DESIGN 2

334 Filevision IV



Appendix C:
Filevision IV menus and primary dialogs

Some menu items change according to the context, and atl menu jtems are
shown enabled. For example, Ignore will read Activate if you've already set
the currently sclected Type to Ignore. and if you're using a file, New... and
Open... on the File menu will be disabled.

Filevision® 1V

Persion 1.0 - March 30, 1989

Copyright 1985-1989 Marvelin Corporation.
Phone: (213) 450-6813

By Pavid Murray, Matthew Jacobs, Robert Jeckell,
About Filevision® IW... |- — Howard Metcalfe & Scott Sullivan. Rewritten by
Help - Faulkner White.

. Sy | "Brushweod Heighis" uses:
Set Aside Filevision® U 53318 bytes of memaory, 24K of disk.

Approximate room 1a grow:

Apple menu

e

v A Filevision® tU) i 253666 bytes, 15437K disk.
K rinder
Help ltEm:l_ﬁhoui Help I
ey - — ] .
Help lem: Click on the Help Hem Fage: Whenevet the page M—l

pop-up Tneny to see an index of all help || marker is displayed, there is }
[ iterns. From this menu, select the help | | more than one page included in

temn desired by ¢licking on it. that help item. To continue to
the next or previous page, olick
the Mext or Prev buttons,

Browse: If you wish to page through all of the main help items without
selecting any particular item from the Help [tem renu, elick the Up arrow '
to go to the previous item and the Down arrow to go to the next itern.

‘When you reach a help itern with more thar one page, lick Prev or Next.

Help: 3f you wish to enable the context sensitive help cursor, elick the
Help button. Ones the “Help” cursar is present, pull down any program
renu and click an the meny item that you would like to see help on. '

Exit button to leave the help screen and return to your file. Exit

Exit: After you are finished wiewing the help screens, elick the
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File menu

= Fllevision® 1)

Return to Menu Source 56;

New... #N
bpen... 0 -
Close Menus

Save S
Save As...

Import Graphics...
Export Graphics...
Import/Export Tent...

Page Setup...
Page Size...

Print Page ¥l +—
Print Becords... ®p
Quit ¥0

ae

Select drawing pages to be printed:

[1Print guides

rint grid

Laserlliriter Page Selup

52

Enlarge:

Orientation

Paper: @ US Letter (O A4 Letter (O Tabloid
QOUSLegal (O BS Letter
Reduce or Printer Effacts:

(-

[X] Font Substitution?

B Text $Smoathing?

[ Graphics Smoothing?
[ Faster Bitmap Printing?

T
-
5
Create a Filevision File: E :E Di“‘t;—;'“ . K] = Hdge
" mport/Eupor
[New Fiie | (Cancel) | | vovet ile
[ Menu Source
by Menus
Printing Fiie :
Printing File 2
e
i
3 Rrchive — HDBO
0 HREZENR BHIRHIDN
ganner E
Hgshironit Houghty [ Drive
g IE::;JF!.] of Filevision T... E—— = —ungo
s .
0 Copy of Filevisian Tour i
Save a copy in: @‘ 0 EPSfs —-f i
py tn: | |Ca Filevision Examples
Lopy of Banner (“cancel|| |< Fievision Progrem
3 fHewislon Start-up P
0 Fwil Banner !|
- 0 Fulll Pyramid —
L o (2 Large Files Iy
_ import as:
I— ® PIEI O MacPaint O single PICT
" Qs @ Biscrete Objects
% = ——— 1
Edit Types (mport O rmqo—s J—
vIimport ®1 0 Backup of Flepisino ..
Export SE  Banners
1 Conversion Test Trine
Neuwr Setup #N DIEPSFs
S Fitewisiondd i3
Load Setup... ®L
Save Setup... %S Save fis: [ﬂg
[Test PiCT | (concer)
RBeturn to Filevision
Quit *0 @PICT
OEpsy

Lanel

Select a drawing page

Select inTo pages to be printed:

size;

0K

Print Library
Print format Type Style
Menu 1 Background Form 9_
Menu 2 Background Report
Menu 3 Background Label
]
(Gaee ) (&)
Records to print: Print to:
@ AN ® Printer
O Highlightes O Screen
Q) setecterd O File
Page setup Print
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Edit menu

Belete records using these options:

@ Sejected “Townhouse”s only
(> Highlighted "Townhouse"s only
) ANl "Townhouse"s

{® Records and their graphics
(O Records only

(O Graphics only

Undo %2 vou will not be able to undo this action,
ut -
Capy %€C
Paste £ L
Clear Preferences for this file:
+ Show selected graphics using:
Bring to Front  {+&F @ Handles O Black (O Blinking ) Nething
Send to Back 4 3%B
Group €6 * Double-click on graphics: @ Accept (O Ignore
Gather 4-%T
Reshape %K
(] Info & Form rulers on: @& Inches O Metric
Add Record %R

Duplicate Record 32Y
Delete Records... !

Preferences... %E
6rid & Rulers... — T
Field Setup... 8= _ _

Edit drawing page rulers and grid for this file:

# Show ruler in: [Feet |
with 1 inch = [T Feet

+ Set initial reference point at:
{® Upper left - positive numbers down & right.
{) Lower left - positive rumbers up & right.

Selup for the Comments fieid:

C Standard ) Copy from previous recq Initial ruler starting values: Horiz |0 Il.lert 0 |

® Initial Text ) compute using a formuly

Initial text: ® Grid ........... E]I 2ths of aninch [] Show grid

| « filignment .72nds of an inch [ Snap to alignment
s Guides........ & Show guide [ Snap to guides

Field Names: [Price 1

(tancel ) { prev Field | [ Newt Field | { pene )
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Types menu

Change Layout... - Change Layout... opens the change mode window for the current Type.
Delete Type
Add Type... | Add Type... opens the new Type layout window

Background
Golf Hole
Lake
Street
vTownhouse
Model
Salesperson
Customer Sort "Background's by:

Click Link

[Current Mailing Address |

Access menu vYou will not he able to unde this action.

|

"Background"s:
Sort By... 74! _
Find... ¥F | o
this Back Name:
Find Same SBS Find this Background Name
Highlight ... gHF—— [unit 2 ]
Highlight Selected 1N
Highlight All £ %A (Cancel | [ Find First | [ Fing Next |

Hide Selected 4+ ¥H
Show Selected
Show Only These

Ignore
Narne is

Show RIl Types . equal to
Cancel Highlighting  3J : Jarmes Turner

: —————@® AND —3 OR
Previous Record 3P
Next Record M
Info Page ®1 ® AND =3 OR
Drawing Page 0
Link 8L

@ AND —O OR
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Text menu

Font »

h Avant Garde

Size 4 Size Bookman
style » Style M Brush Script
Color } Color 4 Cairo
Mask Color Mask Color b Eglrl:graphgtaser
Texut Masking Text Masking Chicago
Eourier
Garamond
vhGeneva
Helvetica
Hobo
Mobile
Monaco
|4 N Helvetica Narrow
Style | 4 New Century Schibk
Color M @ New York
im Palatino
Mask Color »|i2 Times
Tesut Masking 14 Z2opf Chancery
18 Zapf Bingbats
2d)
30
36 m
48 Font 4
60 Size »
12 BT -riain teut
Color P| Underline
Bald
Mask Calor M| Ftatc
Tent Masking | Bhmdom
| Tent [ Ontline
Font »
Size »
Style >
o1 vBlack
White
Mask Color | Red
Text Masking Green
Blue
Cyan
Magenta 3 nlo Black
vellow Text Masking |~iWhite
Red
Green
Blue
Cyan
Magenta
Yellow
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Options menu

Show Ruler *R
Hide ToolboH BT
Hide Mini Page 8K
Hide Titles
Hide Window

vShow Rctual Size %1
Show 50% Size ®5
Show 33% Size ®3
Show 2007% Size ®2

Ruler Drigin at Botiom Lefi
Tracking
brid
vGuidelines
Snap to Guide
Snap to fllignment
Edit Rounided Corners...
Show Grid & Guides in Frant
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Symbaols menu

Editor...

t][*][o][~]
II@E
[][-][C][¥]
[s][+][O][=]
[o][2][+][~]
#= ][]
[=][a][:]=]
[+][=]{=][x]
[+1[=][=] ]
[¢][m][-][a]

Shades menu

| snade: EE

|:||:1 i
I:II:!
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Format menu

Display "Price’ numbers with this decimal format:

@7 one QO et Ornn

(Cancer)

~Riphabetic 30 |
Numeric *9
Dollar Sign  #M Statistics for: [Price |
Commas *, standard
Decimals... o Count Tolal Average deviation

Dverall statistics . . . . d &= O |

Statistics... -} ByMedet . . . . . . . . O 4] [ O

By Price . . . . . - . . M M [l 1

v Align Left #n By Rddress . . . . . . . O O I} M
Align Middle 37
Align Right ®e Use "Sort” to select differant detail statistic fields.
Hide Border Lpipet MY Tram She Pormat mean 1o eanble all statistine,
Do Not Invert
Hide Field Name Prey Field (Nent Fieta ] [_Done ]
Across... e
Show Ruler R
Metric Ruler Print how many records across each page?

The current setting is: 1.

) 2 (=] (e
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Impott/Export [« I coit_Types Export Gptions

Text... Import 81
wExport %E
selection from the main
File menu creates a new New Setup %N
menu bar Load Setup... ®L
Save Setup... xS Background
) baolf Hole
Return to Filevision Lake
m fuit %0 J’;" eet
Undo %7 cwnhouse
; L n . Moded
Field setup for 2: "Hourly salary”:
) o ) Salesperson
Cut #*H Frel(d) width {l_n characters): Customer
[:DI]U %C Left align dn}a |_n field. click Link
O center data in Tield. ICK Lin
Paste A > Right align data in field.
Clear B Pad character:
[ Format data numericaiy.
Eietd setup... %= Number of digits to right of decimal point:
_ ] Suppress leading zeroes.
Rppend field %A O Dpisplay sign trailing.
Indicate missing data with:
File-name: Personne!
{cancel | (Prev fietd ] {Neut fieid | Dend| Type-name: Employee  Order of imported fields
City

Employee no.
Federal exempiions
Hourly salary
Link

s Name

Phone no.

Process imporied nata records based on

@ Ada al! imported dale 85 new records.
) Update motching records; otherwise o
(O Updale metching records; otherwise o

() Replace matching records; etherwise Select all _

) Replace matching records; otherwise

Wk WA

® Do nat change nightighting. [IFile begins with a list of field names,

(O Moke ol new or thenged records high|
sele':t fields gg_ fQ (O Make only new records highlighted.
T (O Make only cheng ighli
select records... 3B }— ——————— ©Makealnew or chonged racards NDT highlighted. I
Process ASCU files for the following programs:
v 1
ASCII % O Filevision® 1V ) Excel
[11R3 %2 O BB Master (Import only) O fezz
O FileMaker
SDF ... %3 ) Helin - ) Macllrite, etc.
S'I.LK ¥4 O Microsoft File
O bmnis 3
) DverbUE 2.0
() PFS:File (import onty)
Start... ®G
P SBF il follows:
rovess SOF fifes as Tolows Trd
B Delimit fields. ile Ch
Field delimiter: iil Translate Into End-9f-File Char

@ Keep CR characters.
) convert CR to Space.
) Delete CB in exported data.

[Jappend Lf to CR.

Translate... BT
Convert to upper case 3H
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Appendix D:

Filevision IV shortcuts and special key combinations

Keyboard
shortcuts

Filevision IV, like most Macintosh software, has a number of keyboard and
mouse shorteuts for the experienced user.

Double-click the symbol tool to use the Symbol Editor.
Double-click the shade preview box {o use the Shade Editor.

Double-click the rounded rectangle tool to use the RoundRect
Editor.

Double-click the record icon to look at the current record. This is
the same as clicking the Infe bution for that object.

Double-click an object to get Info on it, or to link to another file.
This depends on what choices have been made on the Edit menu's
Preferences dialog.

Double-click on the field name in an Info record to get the Field
Setup dialog.

Double-click on a field in the Print Layout to get the Statistics dialog
for that field.

Hold down the Command key (3£ )while clicking the mini page
scroller to center the drawing page.

Clicking on any Filevision IV graphic, text, symbol, line or shaded
object with the Option key down will load that object’s attributes into
the tool box, text menu or symbol and shade palettes. To change
the existing attributes of an object, select the object and then make
any changes from the respective menus or editors.
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special key
combinations

344

Filevision 1V

Holding down the Elgf_t key

While selecting objects keeps all currently selected objects.

While holding down the Command key (38) and choosing Group
from the Edit menu creates a pop-up.

While holding down the Option key and stretching an object will
stretch it proportionately.

While clicking Next or Prev will bring the object selected into the
drawing window viewing area for the selected graphic.

While holding down the Command key (32) and clicking the page
miniature will center the drawing window.

When choosi'ng Find... or Find Same from the Access menu will
bring the object into view, if found.

When choosing a Type from the Types menu will change the Type
of the currently selected object(s}.

While drawing won't deselect the drawing tool when the mouse
button is released.

Holding down the |Option. key

While stretching an object will limit stretching to a square.

With the straight iine tool will draw only 0°, 45°, and 90° lines.

With the polygon tool will draw only 0°, 45°, and 907 lines.

* With the rectangle or round rectangle tools will draw only squares or

rounded squares.
With the oval tool will draw only circles.
With the arc tool will draw oniy circular arcs.

While moving an object will move it only on a horizontal or vertical
plane in the direction you started the move.

While stretching or shrinking an object will stretch or shrink it only
horizontally or vertically.

During reshaping other than arcs will move handles only horizontally
or vertically.



Command key
chord menu
and control
combinations

Table 4-6

Holding down the ()_l;t;)n key

» During reshaping arcs will constrain the arc angle to 45° angle click

stops.

«  With Copy from the Edit menu will copy the Type layout from the
Type layout display, the print foermat from the Print layout display, or

symbol or shade palettes while editing symbols or shades.

= With anything on the Text menu from the Info page, Type layout or
Print layout display will change all fields to the selected attribute.

+  With the Command key ( 3 ) will align drawing, moving. stretching
and reshaping, even if Alignment isn’t selected from Preferences,

or temporarily disable Alignment if it is.

If you press and hold the Command key (3§ ) while pressing one of these keys,
you'll activate the menu item or control shown on the following chart. The up
arrow and Command key symbol ({+3€ ) indicates that the Shift key is also

held down while applying the Command key chord,

Command key chord chart

Add a new record while working in the Info page or,

Append field to exchange file field list if in Import/Export Text. ..
send the currently sefected object{s) or Type to the Back or,
Clear selected without copying to he Clipboard.

Copy the currently seiected object or selected text

access the Drawing page if currently working in the Info page
display the Preferences... dialog box or,

set Export text if working with Import/Export Text...

display the Find... dialeg box

bring the currently selected object(s) or Type to the Front
Group all selected objects or a record with a graphic object or,
Start Import or Export from Import/Export Text...

display the Highlight dialog

Hide All/Selected of the current Type or selected objects of Type
access the info page if currently working in the drawing page
Cancel all Highlighting

Hide the mini page

Load Import/Export setup file if working in iImport/Export Text...
Format a Numeric Print Layout field with a Dollar sign

create a New Filevision |V file or,

start New Setup if working in Import/Export Text...

go to Next record {object)

¢

oy
EEEEE EEEEEEEEEEEL TR LT
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2
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Table 4-6
continued
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Command key chord chart continued

2>
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Open an existing Filevision |V or Business Filevision file.
access the Print Records... Print Library dialog

go to the Previous record

Quit if working in Filevision 1V or Import/Export Text...
Show/Hide Rulers in any window or,

select Records if working in Import/Export Text. ..
Reshape selected line, rectangle or arc

Save the current file or,

Save the current Setup if working in Import/Export Text. ..
Find Same using the last Find criteria

Hide/Show the tool box or,

Translate if working in Import/Export Text...

Gather all selected objects for tempaorary grouping
print the current Page or,

convert to Upper case if working in import/Export Text...
Paste the contents of the Clipboard

Highlight Selected if working on the drawing page or,
toggle from highlighted to not highlighted if in Info page
Cut currently selected object or text

Duplicate record

Undo/Redo the last edit

set drawing page to Actual size (100%) or

import or export text to an ASCII file

zoom drawing page o 200% size or,

import or export text to a DIF file

zoom drawing page to 33% size or,

import or export text to a SDF file

import or export text to a SYLK file

zoom drawing page to 50% size

Align Left in the current text field or,

Align Middle (center) in the current text field

Align Right in the current text field

set field to Numeric in Print layout

set field to Alphabetic in Print layout

select Field Setup dialog

Return to last file linked from or last file closed

set field to print Commas in Print layout

set field Decimal places in Print layout

select the report Statistics dialog or,

Select fields to import or export in Impor/Export Text. ..
enter context sensitive help

Filevision IV




Appendix E:

Filevision IV error messages

System errors

/0 and printing
errors

Sometimes the Macintosh or Filevision will encounter a situation so unusual that
an error message is issued. An error message attempts to tell you what's wrong
and whalt can be done about it. Here’s a list of Filevision error messages and
possible remedies for the problems they represent.

Systern errors are shown with: an ID number, Restart and Resume huttons, and
a picture of 4 bomb.

Always click Resume when possible. Resume attempts to close your file
properly before returning vou to the desktop. Restart returns you to the
desktop but risks the loss of your file.

ID = 3 Ilegal instruction error.

This error should never occur. It indicates that the program has malfunctioned.
Click Resume and if the problem continues, ¢lick Restart, If this does not
correct the problem, replace the Filevision IV application or System files.

ID = 4 Zero divide error.
See ID = 3, above,

1/O and printing error messages are given with a number.  The messages and
possible reasons or remedies are listed below.

-33 The disk directory is full,
Choose Quit from the File menu and throw at least one file into the Trash. You
should back up any important files before throwing them away.

-34 The disk is full
Sec -33, above.

-36 Your drive or disk may be faulty

This may represent a mechanical failure. It can be caused by bad drive align-
ment, a defect in the diskette, or a defective file (which can be eliminated by
throwing out the file). These errers are difficult to recover from; you may
have to take your Macintosh in for repair.
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Filevision IV

-39 The file is damaged

This can happen if you were using a file and the reset switch was hit, or the
Macintosh lost power during the brief period that a directory was being up-
dated. Throw away that file and use the kst backup copy you made.

-41 There is not enough memory === Inf0

Be sure you are using a Macintosh with at least S oo Loeked [ ]
one megabyte. If you're using MultiFinder, make =

sure that you haven’t reduced the minimum Sne 205 168 nutes used, 416K on disk

amount of memory MultiFinder requests for Whers: HDEO, SC510

Filevision. This can be set by selecting the

Filevision application icon on the desktop and Get | eamed: 1o w51, 196, 106 1
Info from the deskiop File menu. Be sure that Version: 1.0/€19851989 Marvetn, Core.
Application Memory Size is set to at least 650K.

-43 The printer driver (or some other

needed file) cannot be found Suggested Memory Size (K): 650
Install your ImageWriter or other printer driver in Application Memory Size (K):

the “System” used by Filevision.

-44 The disk is write protected
Remove the diskette and slide the write-protect tab up so that it covers the hole
and try again.

-47 That file is in use. It cannot be replaced

This can happen if: 1) You're using Filevision in a network and someone else is
using the file you are attempting to open, 2) You're running more than one
Filevision under MultiFinder and another copy of Filevision is using the file, or
3) There was a bug in the previous application that used the file and you
haven't turned the Macintosh off or reset it since the error occurred. Use
another file until the first one is closed, or, if 3) occurred, turn the Macintosh off
and try again.

-49 The file has been left open by another application
See -47, above.

-108 There is not enough memory
See -41, above.

-192 A needed RESOURCE cannot be found

This can happen when the printer driver and the file called “System” are from
different releases and therefore don't recognize each other. If you use the
“System” and “ImageWriter” (or other printer driver) resource files we supply,
you shouldn’t encounter this problem. Install your ImageWriter or other printer
driver in the “System” file.

-193 A needed resource FILE cannot be found
See -192, above.



Errors in
formula fields

Formula fields (see “formula fields”, page 170) have their own set of error mes-
sages. ,

There is an unexpected sequence of characters in the formula
This is the most commonly encountered error message. Possible causes
include:

No formula: You clicked Compute using a formula on the Field
Setup... but didn't enter a formula.

The formula doesn’t begin with a valid character: A formula must begin
with 2 number, a unary sign (+, -, or ¥ ), an opening parentheses, an
opening absolute value sign (1), or a field name in brackets. For
example,

Net rate}

The opening bracket is missing in this example.

The formula seems to end before the last character: It looks to Pyramid
as if there’s garbage at the end of a formula. For example,

[Dealer price] * 20%0
The last zero is redundant in this example.
You forgot a closing parenthesis or absolute value sign: Parentheses
and absolute value signs come in pairs, and it’s easy to forget the one
on the right. For example,
|[Net rate]
The closing absolute value sign is missing in this example.
There are unbalanced parentheses
For example,
[Quantity on hand] + ([Surplus}] - [Spoilage]
The closing parenthesis is missing in this example.

There is something wrong with a reference to a field
Here are the most common problems:
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You typed more than 31 characters without a closing bracket: The
maximum length of a field name is 31 characters.

A value in brackets isn't a field name: When field names are referred to
in a formula, they must be bracketed. If a word in brackets isn't a field
name, you get this error.

The left bracket is missing: You may have typed in a field name
without an opening bracket.

There are too many nested parentheses
Formulas allow up to 15 levels of parentheses, “implied” or not.
Implied parentheses refer to the order of evaluation: that is, in expres-
sion A * B + C evaluates identically to (A * B) + C, because the multipli-
cation operator (*) always takes precedence over the addition operator
(+). So the expression A * B + C is considered to have one pair of
implied parentheses.

A value is too large or too small
Both positive and negative numbers are accurate to 10 digits to the left
of the decimal and 4 to the right, so any number greater than
9,999,999,999.9999 or less than - 9,999,999,999.9999 won't be stored
accurately.

You may also have attempted to take the square root of a negative
number.

#Val?
This means “Value error” and it usually indicates something preity
obvious: a word appeared where a number should have, or a number
was divided by zero, the square root of a negative number was re-
quested, etc.

?Ref?
This means “Reference error” and it indicates that you've used a field
reference in a formula field, but the field referred to was removed.
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Appendix F:

How to Import/Export Text with other programs

How to
exchange data
between
Filevision IV
files '

This appendix includes instructions for using Import/Export with specific target
programs. If the program you want to exchange data with appears in this list,
please read the appropriate section here. If it does not, please refer to your
program’s manual and the section on Import and Export Text in this manual.

Filevision IV includes several tools for exchanging graphics, data, symbols and
layouts between Filevision IV files. For a brief review of these features, see:
Editing tools, the Clipboard, and the Scrapbook in this manual. You can also
use Import/Export Text to exchange data between two Filevision IV files.
Here’s how:

+ Select Import/Export Text... from the File menu and choose
Export; choose ASCII from the Export menu; click Filevision IV
and click Done.

+  Choose Select Fields... from the Export menu; double-click the
fields you want to include in the exchange file, in the order you want
them to appear — they will be appended to the list of fieids in the ex-
change file in the order you double-click them; click Done.

+ Choose Start... from the Export menu; type in a name for the ex-
change file and click Save.

+  Open the Filevision file that will import this exchange file.

«  Select Import/Export Text... and choose Import from the File
menu; choose ASCII from the Import menu; click Filevision IV and
click Done.

+ Choose Select Fields... from the Import menu; double click the
fields that match the fields you chose above in the order that you
chose them; click Done.

«  Choose Start... from the Import menu; select the exchange file you
created above and click Open.

«  When the process is complete, choose Return to Filevision from
the File menu.
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How to import
data from Excel

How to export
data to Excel

352

Filevision IV

Microsoft Excel provides for importing and exporting data in Text, SYLK
(Symbuolic Link), and WKS (Lotus 1-2-3) formats. We describe exchanging Text
files here; the process for exchanging SYLK files is similar.

Select the Excel document that has the data you wish to import into
Filevision IV and choose Open from the Finder’s File Menu. This
starts Excsl.

Choose Save As... from the File menu; click Text; type a name for
the exchange file and click Save.

When the process is complete, choose Quit from the File menu.

Start the Filevision IV file that you want to import into; select Import/
Export Text... from the File menu, select lmpott from the Import/
Export File menu, select the Type that you want to import into from
the Types menu, choose ASCIl from the Import menu; click Excel;
click Done.

Choose Select Fields... from the Import menu; double-click the
fields you want to receive data into in the same order as the ex-
change file.

Note: Excel includes all cefls with data in them in the exchange file. A row in
the spreadsheet corresponds to a Filevision IV record; a column corresponds to
a Filevision IV field. Excel column numbers correspond directly to exchange
file field numbers. Therefore, you may need to *move’ Filevision IV fields
around to match them up with the right columns. Remember, you can use
Option-drag to move a field and you can leave exchange file fields “unused” for
columns that you don't want to receive data into.

Click Done.

Choose Start... from the Import menu; select the exchange file you
created with Excel and click Open.

When the process is complete, choose Return to Filevision from
the File menu.

From the Filevision file that you are going to export data from, select
Import/Export Text... from the File menu; choose Export from the
File menu; choose ASCIH from the Export menu; click Excel; click
Done.

Select the Type you want to export from the Types menu.



How to import
data from
FileMaker

»  Choose Select Fields... from the Export menu; double click the
fields you want to include in the exchange file, in the order you want
them to appear as columns in Excel. They will be appended to the
list of fields in the exchange file in the order you double-click them;
click Done.

+  Choose Start... from the Export menu; type in a name for the ex-
change file and click Save.

«  When the process is complete, choose Quit form the File menu.
+  Start Excei; choose Close All from the File menu.

»  Choose Open from the File menu; select the exchange file you
created in Import/Export Text...; click Open and wait for the process
to complete.

FileMaker provides for importing and exporting data in three formats that it calls
“Text files (word processing)”, “Text files (BASIC)”, and “SYLK files”. We
describe exchanging “Text files (word processing)” here; the processes for the
other formats are similar.

Note: FileMaker converts carriage-return characters found in the data to spaces
when it created an exchange file,. It expects no carriage-return characters in
clata when it receives an exchange file. When you click FileMalker in the ASCIL
dialog, Import/Export Text... automatically sets the Convert CR to Space option
on the Translate dialog. Do not change this choice.

+  Select the FileMaker file that has the data you wish to import into
Filevision IV and choose Open from the Finder’s File menu. This
starts FileMaker.

+ Choose Qutput to... from the File menu. Type in a name for the
exchange file and click New; click Text file (word processing).

+ Click the fields you want to exchange in the order you want them to
occur in the exchange file, and click »Move» for each field you
select.

«  Click Output. When the process is complete, choose Quit from the
File menu.

- Start the Filevision IV file that you want to import into; select Import/
Export Text... from the File menu, select Import from the Import/
Export File menu, select the Type that you want to import into from
the Types menu, choose ASCII from the Import menu; click File-
Maker; click Done.
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How to export
data to
FileMaker

How to import
data from Helix
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Choose Select Fields... from the Import menu; double-click the
fields you selected in creating the exchange file, in the same order
you specified them in FileMaker; click Done.

Choose Start... from the Import menu; select the exchange file you
created in FileMaker and click Open.

When the process is complete, choose Return to Filevision from
the File menu.

From the Filevision |V file that you are going to export data from,
select Import/Export Text... from the File menu; choose Export
from the File menu; choose ASCI from the Export menu; click
FileMaker; click Done.

Choose Select fields... from the Export menu; double-click the
fields you want to include in the exchange file, in the order you want
them to appear. They will be appended to the list of fields in the
exchange file in the order you double-click them; click Done.

Choose Start... from the Export menu; type in a name for the ex-
change file and click Save.

When the process is complete, choose Quit from the File menu.

Select the FileMaker file that you want to add the data to and choose
Open from the Finder’s File menu. This starts FileMaker.

Choose Input From... from the File menu; select the exchange file
you just created in import/Export Text... above and click Open; click
Text file (word processing).

Click the fields you include in the exchange file, in the order you
included them in Import/Export, and click »Move» for each field you
select.

Click Input and wait for the process to complete.

Odesta’s Helix provides for importing and exporting data using a pair of
processes it calls “loading” and “dumping”. Here’s how to use them:

Select the Helix Collection document that has the data you wish to
import into Filevision IV and choose Open from the Finder’s File
menu. This starts Helix.



How to export
data to Helix

If necessary, choose Show Collection from the File menu.

Select the Relation icon that has the data and choose Open from
the lcons menu.

Drag a Template icon from its well to the work area of the Relation
window; name it; choose Open from the lcons menu; click the Pen
& Ink switch and draw rectangles in the work area, one for each field
you want to exchange. Next, click the Field icon list switch; drag a
field from the field list to an empty rectangle for each field you want
to exchange. The order of fields on the exchange file is left to right,
top to bottom on the Template. Choose Close from the lcons
menu.

Drag a Selection icon from its well to the work area of the Relation
window: name it; choose Open from the cons menu; select the
Template you just created above from the list in the Templates
column; choose Show Form from the Search menu.

Choose Dump... from the File menu; type in a name for the ex-
change file and click Save.

When the process is complete, choose Quit from the File menu.

Start the Filevision IV file that you want to import into; select Import/
Export Text... from the File menu, select Import from the Import/
Export File menu, select the Type that you want to import into from
the Types menu, choose ASCII from the Import menu; click Helix;
click Done.

Choose Select fields... from the Import menu; double-click the
fields you selected in creating the exchange file, in the same order
you specified them in the Helix Template. They will be appended to
the list of fields in the exchange file in the order you double-click
them; click Done.

Choose Start... from the Import menu; select the exchange file you
created in Helix and click Open.

When the process is complete, choose Return to Filevision from
the File menu.

From the Filevision 1V file that you are going to export data from,
select Import/Export Text... from the File menu; choose Export
from the File menu; choose ASCII from the Export menu; click
Helix: click Done.
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+ Choose Select fields... from the Expott menu; double-click the
fields you want to include in the exchange filg; in the order you want
themn to appear. They will be appended to the list of fields in the
exchange file in the order you double-click them; click Done.

» Choose Start... from the Export menu; type in a name for the ex-
¢change file and click Save.

= When the process is complete, choose Quit from the File menu.

»  Select the Helix Collection document that you want to add the data
to and choose Open from the Finder’s File menu. This starts Helix.

» Create a Template and Selection icon in a manner similar to the
one described just above. Remember, make sure the order of fields
in the Template matches the order you defined in Import/Export
Text. '

= While the Selection icon is open and the form is showing, choose
Load... from the File menu; select the exchange fite you just created
in import/Export Text above.

= Click Load Text and wait for the process to complete.

MacWrite and most other Macintosh word processors can save a document in
either their own internal format or in TEXT format. They can also convert TEXT
documents into their own format. You can use these features to exchange data
with them. Here's how: (The following example shows MacWrite Version 4.0
command sequences.)

+  Select the MacWrite document that has the data you wish to import
into Filevision IV and choose Open from the Finder’s File menu.
This starts MacWrite.

Note: Ensure that the MacWrite data has “fields” separated by tab characters
and “records: terminated by carriage-retums.  You cannot include carriage-
returns in the data except as “record separators.

»  Choose Save As... from the File menu; click Text only; type a name
for the exchange file and click Save; click Paragraphs for “Should a
Carriage return be put at the end of each line or only between
paragraphs?”.

+  When the process is complete, choose Quit from the File menu.
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Start the Filevision 1V file that you want 1o import into; select Import/
Export Text... from the File menu, select Import from the Import/
Export File menu, select the Type that you want to import into from
the Types menu, choose ASCII from the Import menu; click
MacWrite, etc.; click Done.

Choose Select Fields... from the Import menu; double-click the
fields you included in the exchange file, in the order you placed them
above; click Done.

Choose Start... from the Import menu; select the exchange file you
created in MacWrite and click Cpen.

When the process is complete, choose Return to Filevision from
the File menu.

From the Filevision 1V file that you are going to export data from,
select Import/Export Text... from the File menu; choose Export
from the File menu; choose ASCII from the Export menu; click
MacWrite, etc.; click Done.

Choose Select Fields... from the Export menu; double click the
fields you want to include in the exchange file, in the order you want
them to appear as columns in MacWrite (or other word processor).
They will be appended to the list of fields in the exchange file in the
order you double-click thern; click Done.

Choose Start... from the Export menu; type in a name for the ex-
change file and click Save.

When the process is complete, choose Quit from the File menu.

Select the exchange file and choose Open from the File menu. This
starts MacWrite. If this is an older version of MacWrite, the ex-
change document will open as “Untitled”. If this is a newer versicn,
you will need to respond to Paragraphs to Should a Carriage
return signify a new paragraph or a line break?, and acknowledge
OK to This document is heing converted and will open as
Untitled.

Note: When the conversion to MacWrite internal format is complete, you will
need to set the tab stops so that you can see where fields begin.
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Omnis 3 provides for importing and exporting data in ASCII, DIF and SYLK
formats. We will describe exchanging delimited ASCII files here; the processes
for the other formats are similar.

Start the Omnis 3 Utilities application; click Select Library; select the
library containing the data you want to import into Filevision IV and
click Open.

Choose Export data from the Utilities menu and click Delimited.

If you do not remember the field names, choose List Field names
from the Utilities menu and note the names of the fields you want to
exchange. When you are done, click the Close Box.

Using the Tab key or mouse to select fields, enter the field names in
the order you want them to appear in the exchange file; click Start;
type a name for the exchange file and click OK.

When the process ins complete, click OK; then choose Quit from the
File menu.

Start the Filevision IV file that you want to import into; select Import/
Export Text... from the File menu, select Import from the Import/
Export File menu, select the Type that you want to import into from
the Types menu, choose ASCH from the Import menu; click Omnis
3; click Done.

Choose Select Fields... from the Import menu; double-click the
fields you included in the exchange file, in the order you placed them
above; click Done.

Choose Start... from the Import menu; select the exchange file you
created in Omnis 3 and click Open.

When the process is complete, choose Return to Filevision from
the File ment.

From the Filevision |V file that you are going to export data from,
select Import/Export Text... from the File menu; choose Export
from the File menu: choose ASCII from the Export menu; click
Omnis 3; click Done.

Choose Select Fields... from the Export menu; double-click the
fields you want to include in the exchange file, in the order you want
them to appear. They will be appended to the list of fields in the
exchange file in the order you double-click them; click Done.



Choose Start... from the Export menu; type in a name for the ex-
change file and click Save.

When the process is complete, choose Quit from the File menu

Start the Omnis 3 Utilities application; click Select Library; select
the library containing the data you want te add and click Open.

Choose Import data from the Utilities menu; click Select File;
select the exchange file you just created and click Open. The
display should indicate that the file is “Delimited”.

Using the Tab key or mouse to select fields, enter the field names in
the order they appear in the exchange file; click Start to begin the
process.

When the process is complete, click OK then choose Quit from the
File menu.

How to import QverVUE 2.0 provides a full set of wols for receiving data from other programs
data from Over- and a single tool for sending data back to them. To import data from OverVUE,

VUE 2.0

you need to use its Print Report to Disk function. Here's how to do it:

Select the QverVUE document that has the data you wish to import
into Filevision IV and chocse Open from the Finder's File menu.
This starts OverVUE.

Choose a Blank Report format from the Print menu and choose
Edit Report Template from the Print menu; choose Microsoft File
from the Special menu. (This specifies the correct set of field and
record separators and field delimiter options.)

Use the size box to expand the work area and then drag the fields
you don't want to appear in the exchange file down toward the
bottom. Drag the other fields arcund in the window to reflect the
order you want in the exchange file. Use Cut, Copy, and Paste on
the EditText menu to place tab characters (shown as “~" by Over-
VUE) between adjacent fields. Use the size box to shorten the
report to one line, hiding those fields that you don’t want to appear in
the exchange file.

Choose Page Length from the Layout menu; type in a length of 0
lines and click OK; choose Report Title from the Template menu;
type in a title for the format and click OK; choose Quit from the
Temptate menu and click Yes to Do you want to save changes to
‘ReportName’?.
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Choose Print Report On Disk from the Print menu. OverVUE will
create a file with a name that is the same as the OverVUE document
with the word “report”’ appended to the end.

When the process is complete, choose Quit from the File menu.

Start the Filevision IV file that you want to import into; select Import/
Export Text... from the File menu, select Import from the import/
Export File menu, select the Type that you want to import into from
the Types menu, choose ASCI from the Import menu; click Over-
VUE; click Done.

Choose Select Fields... from the Import menu; double-click the
fields you included in the exchange file, in the order you placed them
in the report above; click Done.

Choose Start... from the Import menu; select the exchange file you
created in OverVUE and click Open.

When the process is complete, choose Return to Fitevision from
the File menu.

From the Filevision 1V file that you are going to export data from,
select Import/Export Text... from the File menu; choose Export
from the File menu; choose ASCI from the Export menu; click
OverVUE; click Done.

Choose Select Fields... from the Export menu; double-click the
fields you want to include in the exchange file, in the order you want
them to appear. They will be appended to the list of fields in the
exchange file in the order you double-click them; click Done.

Choose Start... from the Export menu; type in a name for the ex-
change file and click Save.

When the process is complete, choose Quit from the File menu.

Start OverVUE; choose Close from the File menu; choose Import...
from the File menu; select the file you just created in Import/Export
Text...: click Text; click Tab between fields; click Open and wait for
the process to complete.



Appendix G:

How to enter Character Codes in Import/Export Text

In several of the Import/Export Text... dialogs you enter ASCII character codes to
set parameters for processing your data. Here’s how to do it.

Enter the decimal value equivalent to the ASCII character. These
values are shown in the foltowing, ASCII Character Codes, next
page. For instance, to enter the character code for Tab, enter 9.
You can always use this method to enter character codes.

If the decimal value of the character code is between 1 and 26, enter
caret (“"") followed by letter “A” through “Z” or “a” through “z” respec-
tively. For instance, to enter the character code for Tab, enter Moar
Aj. This is an alternative to entering the decimal value.

If the character is a normal, printable character, except one of the
digits 0 through 9, just enter the single character itself. For instance,
to enter a comma (*,”), enter the character “,”. You can't enter a
single digit this way because it would be interpreted as a decimal
value of a character code. You can't enter either Space or Option -
Space because you can't see these characters. And you can’t enter
those characters that are shown as “boxes” when you type them
because they all look the same.

Appendix G shows all options for each character that you can enter and shows which
one is the preferred form. You can enter a code using any of the optional forms
availabie for it. When Import/Export Text... shows you the value of a character
code, it uses the “preferred” form.
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Enter as {column 1) is the preferred method of entering the character code. Columns 2 and 3,
if shown, are also accepted.

Decimal Character Enter as Decimal Character Enter as
Code 1 2 3 Code 1 2
0 Null 0 32 Space 32

1 SOH Aa A 1 33 ! ! 33
2 STX Ab B 2 34 “ “ 34
3 ETX Ac AC 3 35 # # 35
4 EOT Ad D 4 36 $ $ 36
5 ENQ he AE 5 37 % % 37
6 ACK Af AR 6 38 & & 38
7 BEL Ag "G 7 39 ‘ ‘ 39
8 BS Ah AH 8 40 { { 40
9 Tab Aj 4| 9 41 ) ) 41
10 Line-feed Aj AJ 10 42 * * 42
11 VT Ak A 11 43 + + 43
12 Form-feed #l AL 12 44 , , 44*
13 Return Am AM 13 45 - - 45*
14 S0 An AN 14 46 ; . 46
15 Sl ] O i5 47 / / 47
16 DLE Ap P 16 48 0 48

17 DCA Aq AQ 17 49 1 49

18 DC2 Ar "R 18 50 2 50

19 DC3 Ag A5 19 51 3 51

20 DC4 At AT 20 52 4 52

21 NAK Ay AU 21 53 5 53

22 SYN Ay Y 22 54 6 54

23 ETB Aw AW 23 55 7 55

24 CAN Ax X 24 56 8 56

25 EM Ay 8 4 25 57 9 57

26 SUB rZ ~Z 26 58 . : 58
27 Escape 27 59 ; ; 59
28 FS 28 60 < < 60
29 GS 29 61 = = 61
30 RS 30 62 > > 62
31 us £y | 63 ? ? 63

*NOTE: Comma (*,") and minus (“-") have special meaning when entering ignore these charac-
ters on the secondary ASCII dialog. Use 44 or 45, respectively, for these codes there.
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Decimal Character Enter as Decimal Character Enter as

Code 1 2 3 Code 1 2
64 @ @ 64 26 ‘ ‘ 96
65 A A 65 97 a a 97
66 B B 66 98 b b 98
67 C C 67 99 ¢ c 99
68 D D 68 100 d d 100
69 E E 69 101 e e 101
70 F F 70 102 f f 102
71 G G 71 103 g g 103
72 H H 72 104 h h 104
73 1 I 73 - 105 i i 105
74 J J 74 106 j j 106
75 K K 75 107 k k 107
76 L L 76 108 ] | 108
77 M M 77 109 m m 109
78 N N 78 110 n n 110
79 O O 79 111 o] (4] 111
80 P P 80 112 p P 112
81 Q Q 81 113 q q 113
82 R R 82 114 r r 114
83 S S 83 115 S s 115
84 T T 84 116 1 t 116
85 U u 85 117 u u 117
86 vV v 86 118 v v 118
87 W w 87 119 w w 119
88 X X 88 120 X X 120
89 Y Y 89 121 y y 121
o0 Z Zz a0 122 z z 122
91 [ [ 91 123 { { 123
92 \ \ 92 124 | | 124
93 ] ] 93 125 ) } 125
94 A A 94 126 ~ ~ 126
95 95 127 Delete 127
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Code 1 2 Code 1 2

128 A A 128 160 1 t 160
129 A A 129 161 ° ° 161
130 C ( 130 162 ¢ ¢ 162
131 E E 131 163 £ £ 163
132 N N 132 164 § § 164
133 o] 6 133 165 . . 165
134 0 0 134 166 q q 166
135 a a 135 167 B B 167
136 a a 136 168 ® ® 168
137 a a 137 169 © © 169
138 | i 138 170 ™ ™ 170
139 i i 139 171 ’ . 171
140 a a 140 172 172
141 c ¢ 141 173 # # 173
142 é é 142 174 &£ E 174
143 8 [ 143 175 %] 7] 175
144 é é 144 176 - oo 176
145 é é 145 177 + + 177
146 i i 146 178 < < 178
147 i i 147 179 > > 179
148 i i 148 180 ¥ ¥ 180
149 i i 149 181 m n 181
150 fi fl 150 182 0 d 182
151 d o 151 183 py 3 183
152 6 6 152 184 I1 I 184
153 ) o 153 185 T T 185
154 6 o 154 186 i f 186
155 & & 155 187 a 2 187
156 i ) 156 188 0 e 188
157 G u 157 189 Q Q 189
158 1] ] 158 190 ® ® 190
159 i a 159 1N ) o 191
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Code 1 2 3 Code 1 2
192 é é 192 224 None 224
193 i i 193 225 None 225
194 = = 194 226 None 226
195 Xt v 195 227 None 207
196 f f 196 228 None 228
197 = = 197 229 None 229
198 A A 198 230 None 230
199 « « 199 231 None 231
200 » » 200 232 None 232
201 201 233 None 233
202 Option-space 202 234 None 234
203 A A 203 235 None 235
204 A A 204 236 None 236
205 0 0 205 237 None 237
206 CE (E 206 238 None 238
207 e e 207 239 None 239
208 - - 208 240 None 240
209 — — 209 241 None 241
210 “ 210 242 None 242
211 ” 211 243 None 243
212 ) ’ 212 244 None 244
213 ' ’ 213 245 None 245
214 + + 214 246 None 246
215 O ¢ 215 247 None 247
216 y v 216 248 None 248
217 None 217 249 None 249
218 None 218 250 None 250
219 None 219 251 None 251
220 None 220 252 None 252
221 None 221 253 None 253
222 None 222 254 None 254
223 None 223 255 None 255
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equal to

<= <
less than or equal to

= >
greater than or equal to

between

A
Look for exact match at beginning of field.

- (two periods)
Matches any characters.

@
Matches any single character.

&p
Prints the page number of a Report or Form.

&D
Prints the system date in long form (Thursday, February 12, 1989).

&d
Prints the system date in short form yy/mm/dd (89/02/12).

&T
Prints the system time as 07:25:17 (with seconds).

&t
Prints the systern time as 07:25 (no seconds).

&&
Prints an ampersand character.

Access
The menu that describes Filevision’s most comprehensive manipulation of files:
sorting, finding, highlighting, hiding, showing, ignoring and activating.

activate

To make ignored objects selectable, and to make hidden objects visible and
selectable.
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align left

align middle

align right

Settings to center, right-justify or left-justify text in fields.

annotation field

An annotation field on the type layout shows in every record whatever is typed
or pasted into it when the type tayout is designed or changed (with Change
layout ... on the Types menu). You can't change the contents of an annotation
field from the Info display. On a print format, an annotation field has the same
properties and others. It can print the system time or date, the page number, or
the contents of a data field.

arc tool
A drawing tool used to draw filled and unfilled pie shapes and arcs.

arrow
The selection tool—its technical name is the pointer.

Background
The name of the type that all Filevision files start out with. You can eliminate or
rename it; it has no special qualities,

bit map

a term used to describe the method used to represent a picture in MacPaint type
programs. Usually containing one level of information per bit, i.e. a black
screen bit or a white screen bit. See pixel map.

black
A drawing page display mode selected from the Preferences dialog that shows
selected objects by drawing a black frame around the object.

body
The part of a pop-up that’s visible only when the button has been clicked.

button

1. A picture of a push button used in Macintosh dialog boxes to initiate or
cancel an action.

2. The part of a pop-up that's always visible.

Cancel
A button that always lets you exit a function without carrying it out. It usually
undoes any portion of the chosen action up to the time Cancel was clicked.

caret
1. The character used to limit “finds” to the first word in the field.
2. The character that’s printed when you type Shift/0 (/).

character

Anything that can be typed, including tabs, carriage returns, spaces, and odd
characters typed using the Option key.
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clear
To delete a selected object without copying it onto the Clipboard. It leaves
whatever is on the Clipboard intact.

Clipboard

A temporary holding place. Any selected object that’s cut disappears but is
copied onto the Clipboard. Any selected object that’s copied doesn’t disappear
but is also copied onto the Clipboard. The object on the Clipboard is replaced
by the next object that's cut or copied.

Command ( 3§ ) key
The key just to the left of the space bar. It has a cloverleaf pattern on it.

comparison operator
The equal to (=), less than or equal to ( £ ), greater than or equal to ( > ), ot be-
tween (- -} signs used in Highlight. ..

condition
The specified highlighting condition.

constrain
Another name for the Option key when it's used in conjunction with drawing
tools to keep angles perpendicular, ovals circle, etc.,

data field

A placeholder for information. 1t’s always the same size and in the same place
in each record: for instance, the Name field. A data field performs the same
purpose as a place, for example, on a patient record for the patient’s last name
or Social Security number. Data fields have names, which can only be changed
while a Type layout is being designed (with Add Type ... on the Types menu or
changed (with Change Layout ... on the Types menu), and a place for informa-
tion. Fields can hold text, numbers, or pictures,

default
A preset choice that can be replaced by one of your own. For instance, Back-
ground is a default type that a new Filevision file begins with.

deselect

To indicate that an item is no longer subject to the current action. For instance,
clicking on a new tool deselects the old one you were using. You can always
deselect on the Drawing display by clicking the pointer tool.

display
What you see on the Macintosh screen.

Done
A button used to initiate or confirm an action.

drag

To point to an item, press the mouse button, and pull the item while continuing
to hold the mouse button down. You release the mouse button only when the
object is where you want it.



Drawing
The display that shows the graphic objects in a file (if it has any graphic ob-
jects).

edit

1. To cut, copy, paste, or clear an object.
2. To create a new symbol or shade,

3. To change a Print Layout.

editor, shade — see shade editor
editor, symbol — see symbol editor

Encapsulated PostScript Format (EPSF) '
A high reselution graphic format generated from a PostScript itlustration pro-
QI Or SCANNET.

enter
To type in information.

Enter
The Enter key on the Macintosh keyboard

€rror message

A dialog box that notifies you if Filevision is unable to fulfill an action you've
requested. For instance, you'll get an error message if you try to add informa-
tion to a file when the disk is full.

export
1. The act of saving a graphic object(s} via Export Graphics to a separate file.
2. The act of creating an intermediate text file with Import/Export Text.

field
See annofation field or data field.

field name
The name of an area where information is entered in a record.

file
The place on a disk where Filevision keeps the information you work with.,

font
The shape of the letters in an alphabet.

footer
Information that appears on the bottom of each page of printed outpur.

Form
A print format that provides printed output that is formatted similarly to the way
that the Info page is laid out.

freehand tool
The drawing tool that works like a pen.
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glass(on the shade editor)
A shade that's invisible, but can be clicked. Tt differs from the None shade in
that None can't be clicked; you must click the surrounding line.

graphic
An object drawn on the Filevision Drawing page.

grid
A reference for drawing and placement of drawing page objects.

group

1. To cause the selected graphics to behave as if they were a single object.

2. When chosen from the Edit menu while the Command and Shift keys are
pressed, Group turns the selected objects into a pop-up.

grouped graphic
A number of graphics that can be selected, and generally bebave, as if they
were a single graphic.

guidelines
Vertical and horizontal single lines that are dragged from the rulers for aligning
objects on the Drawing page.

handles
The tiny black squares that appear around an object or field when i’s selected.
Handles are used to move or stretch objects or fields.

header
Information that appears at the top of each page of printed output in the Print
Layout window.

Hide
To make an object invisible on the Drawing page.

highlight
To create a subset of objects using conditional operators. Graphic objects are
emphasized on the display.

I-beam
The pointer that shows where text can be entered.

ignore
To make a graphic object unselectable.

import

1. The act of loading a graphic object(s) via Import Graphics from a separate
file.

2. The act of reading text data from an intermediate text file with Import/
Export Text,

Info page
The view of an object’s record.



Label
A print layout used to produce mailing or similar labels.

link

A file that's opened automatically, taking the place of the file you're currently
using. Links are handy to organize large amounts of information and an espe-
cially convenient way to move among frequently-used files.

link field
The field in which you enter a name for the link file. Tt is always named Link;
you cannot rename it.

lock

To make a part or all of a file unalterable. A file is locked under these condi-
tions:

1. If any method of emphasis other than handles is chosen from the Prefer-
ences. .. dialog in the Edit menu. This only removes the drawing tools;
records can still be edited.

2. Ifthe file is locked from the Finder using Get Info.

3. If the disk is locked using the write-protect tab.

page miniature (mini page)

The icon at the lower left of the Drawing page window. The page miniature
represents the the current drawing area on which a Filevision drawing is
situated. The white square within it is called the “page scroller” (see below).

page scroller (mini page scroller)

The white square within the page miniature. It shows your current viewing
window of the drawing area. You can drag the scroller to reveal any area on
your drawing page.

palette, symbol — see symbol paletie

paste
To copy the contents of the Clipboard onto the selected area.

PICT
A graphic format that represents all elements of the graphic as separately
defined objects.

pixel map
The multi level graphic representation of screen pixels with grey scale or
extended color capability. See also bit map.

point size
The size of text in 1/72s of an inch.

pointer

The tool used for selection in Macintosh applications. You can choose it
explicitly anytime by selecting it from the toolbox.
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polygon tool
A drawing tool used for shapes that have straight but not necessarily perpen-
dicular sides.

pop-up
A grouped graphic whose body appears only while the button is selected. The
button is the part of the graphic that’s always visible.

print format

The arrangement of fields in a format used to print either forms, reports, or
labels. Tt does not affect the type layout, but all data fields come from the Type
layout. Annotation fields can be added to the print format. A print format must
be created before Reports, Forms, or Labels can be printed.

Print Library
The list of existing print formats. It allows you to design or edit print formats.

proportional stretch
To constrain horizontal and vertical stretching so that they occur proportion-
ately.

rank

A range of relative, rather than specified, values—for example, the top 9 states
in population, as opposed to the states with populations between 30 million
and 8 million.

record
The place where information about an object is kept. All records of a Type
have the same layout of fields.

Report
A printed listing of information from any single Type’s data in columnar Format.

Return To...
Automatically closes the current file and reopens the last one.

Revert

1. To restore a record to the information it contained before you began editing
it.

2. To restore a symbol or shade to its state before you began editing it.

rounded rectangle tool

A drawing implement that produces rectangles and squares with rounded
corners.

Save
Saves the current file under the current file name.

Save As...
Copies the current file under a different name.



screen
The Macintosh monitor.

scroll
To move up or down a list of field names, or to move the visible portion of a
record up and down.

scroll bar
The rectangular bar along the right or bottom of a display that lets you move the
visible portion vertically or horizontally.

scroller

A pair of up and down arrows you click in order to choose a condition from a
list of possible ones. Be careful not to confuse scroller with page scroller,
above.

select
To indicate that an item is the one that's currently being used.

selection information area
Information at bottom of the Drawing window that identifies the currently
selected Type and the contents of its sort field.

Shade Editor
A tool used to create new shades for use in the backgrounds of arcs, rectangles,
ovals, poelygons and the Info page.

shade palette
The selection of 40 currently available shades on the Shade Editor and Shades
menu.

Show
To render an object visible on the Drawing display.

sort
To order records according to the contents of fields. The default sort field is
Name, or whatever you've labeled the first field in a Type layout.

sort column
A field used to sort records for printed output.

sort field

Filevision orders objects according to the contents of a field called a sort field.
The default sort field is Name, or whatever you've labeled the first field in a
Type layout. The object named Abel would be the first in a file that consisted of
only the objects Abel, Baker and Charlie. But if you changed the sort field
(using Sort By... from the Access menu) to Zip code, then the records would be
reordered according to the numeric values in the Zip code fields.

Symbol Editor
A tool used to alter the symbols used in a Filevision file.
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symbol palette
The selection of 40 currently available symbols on the Symbol Editor and
Symbol menu,

system disk
A disk with the system files “Finder” and “System” on it.

toolbox
The floating window on the Drawing page containing all of the tools necessary
for drawing objects, entering text and symbols.

tracking _
Tracks the pointer ot current toolbox tool's current screen position in horizontal
and vertical increments of one screen pixel. Also refers to the "ghost” image
produced in the rulers to indicate the current position of the cursor.

pe
The classification by which objects are grouped on both the Drawing page and
the Info page. Type also defines the layers of the Drawing page.

Type layout
The arrangement of fields shared by all records of 2 Type.

ungroup
To retum the individual identities to the selected objects. Any group of objects
can be ungrouped.

version 1 PICT
The graphic format used in pre Macintosh II. Colors are limited to 8. Uses
QuickDraw in drawing the PICT graphic.

version 2 PICT
The graphic format used for the Macintosh Il defining colors with a palette of
256. Uses the newer Color QuickDraw in drawing the PICT graphic.

work area
The portion of a Filevision display that can be typed or drawn on.

working copy
A copy of any of the distribution disks.



A-Z sort order button 302

About Import/Export Text 203
About Filevision IV.. 318

Access menu 223, 227, 338
Across... 259, 266, 269-300

activate the Type's objects 223, 326
Add Field button 244

adding a record 170, 177

adding a Type 86,163-165, 176, 315
adding a new record 182 -

adding a data field 164

adding an annotation field 167-168
adding and removing information 329
adding an object 38

Align Left 173, 275, 300

Align Middle 173, 257, 300

Align Right 173, 245, 276, 300
Alignment 101-103

Alphabetic 299, 304

ampersand (&) D 277

AND 228, 232-233, 238-239
AND/OR 234

annotation fields 86, 167-168, 244, 245-

255, 256, 264, 272, 296-297
Append field(s) 205, 209
Apple menu 335
arc tool 69, 70, 125, 344
arcs 125
ascending order 248
ASCII import and export text 214-215
ASCII Character Codes 362
at (@) search 236-238
attach an object 95-96
automatic sort field 182
Average 304-300, 330

B

Background Type 164, 213
background color, shades 128
background color, symbols 117

Black, display 107

Blinking, display 107

brackets, square for field names 171, 264,
298, 330, 349-350

Bring to Front 133, 144-145

business letters 269

C

Cancel Highlighting 239

canceling record changes 183

Caps Lock, show all objects in move 138

centering the window 92

centering the window on selected objects
92

Change Layout... 86, 167-169, 173, 176,
302

changing an object’s type 74, 187

changing shade color 128

changing symbol colors 117

Character Codes in Import/Export Text
301

characters per field, maximum 325

characters per record, maximum 325

choose a field to add 280

circles and ovals 124

Clear 169, 205, 310, 317

Clipboard 108, 130, 156-157, 160-162, 176,
179, 182, 205, 218, 310-312, 330

Close Lines 265

color menu 112

Command key chord chart 345-346

Commas 299

compare text characters 234-235

comparisons for highlighting 230-238,
326

compound highlighting 238

Compute using a formula 170-171, 303,

computed field 171

Context Sensitive Help 87-90

Convert to upper case, import and export
text 219

converting files for use with Filevision IV.
331

index 375



i

Filevision files to Business Filevision
23,332
Business Filevision files to Filevision
1V 23, 333
File icons 334
Copy 169, 205, 207, 312-316
Copy from previous record 169, 177
copy and paste 160
copying a file or folder onto the same disk
27
copying and pasting objects 312
copying and pasting print formats 316
copying and pasting the shade palette 314
copying and pasting the symbol palette
313
copying and pasting type layouts 315
copying graphics to a field from the Clip-
board 179
copying Filevision IV disks 26
copying Filevision IV files 25
copying to your hard disk 25
Count 249, 251, 304, 305, 330
cursor tracking 94
Cut 205, 310-311, 317

D

data field 86, 164, 168, 171, 181, 245-246,
264, 268-277, 280-283, 292-293,
330

data field dialog 280

date 169, 170, 247, 256-257, 277, 296, 330

Decimals... 299

Delete Records... 184

Delimit fields 206

descending order 248

deselecting objects 34

detail statistics 301, 304-305

DIF 216

discrete objects 152

disk file 250, 251, 260, 267, 285

Do Not Invert 174, 277

Do not print duplicate sort fields 248

Dollar Sign 299

double lines 121

double period (..) search 235-237

Double-click 343

Double-click on graphics 107

Filevision Iv

double-click as a shortcut 37
double-click link 173
Double-clicking 96

Drawing and graphics specs 327-328
Drawing page 91

drawing page rulers 97

drawing page size 93

drawing page window 91

drawing page zoom views 105
drawing page, creating a blank 149
Duplicating a record 177

E

Each record area 254, 271
Edit 310-318
Edit Round Rect Corners 123-124
editing print formats 292
adding a data field 292
moving fields 293
changing size of a field 294
removing a field 294
using scroll bars 295
editing tools 310
entering a record 183
entering information into fields 177
EPSF graphic, exporting 153
EPSF graphics, imported 158
EPSF to PICT, converting 158
error messages 347
errors in formula fields 349
exchange file 190, 192, 203, 208
Exchanging data with other programs 190
which way does the data go? 191
which data goes where? 191
what if the data shouldn't look
the same? 191
Export 193, 203
Export menu 193
export graphic 153, 159, 182
exporting data 192, 196
exporting the file 193

F

Field Setup 169
standard fields 169
initial text fields 169
auto entering the date and time in



fields 170
copying the field contents from the
previous record 170
formula fields 170
Field setup, Import/Export... 205-206
field comparison 231
fields 43, 164
ediling the contents 44
Revert 44
moving from field to field 45
naming a field 165
changing the size 166
moving a field 166
moving several fields together
167
removing 167
adding an annotation field 167
fields with pictures 178
file specifications 325
file, disk 250
files 83
filling in information 68
Find First 226, 227
Find Same 227
Find... 223-226
Font menu 112
Footer area 244, 254
Footers 299
foreground color, shades 128
Form letters, preparing for printing 269
going 10 the Print Library 270
naming the print format 272
editing the Header 272
closing the Header and Footer 273
the Form letter layout 274
adding ampersand &D auto dates 276
using bracketed field names in
annotation fields 277
adding graphics to annotation fields
279
adding data fields to Form letters 280
overlapping fields 282
previewing the Form letter 283
adjusting the position of the letter
contents 284
printing the form letters 285
Format data numerically 207
Format menu 173, 299, 341

Forms, preparing for printing 252
going to the Print Library 253
naming the print format 254
setting up a title for the forms 254
adding Header information 255
removing unwanted fields 256 ,
adding an annotation field 256
printing the date on each record 257
spacing the forms vertically 258
repeating the forms Across 259
printing the forms 260

Forms, Reports, and Labels 240

freehand tool 69, 70, 122

G

Gather 134, 135, 137, 141, 328
Glass shade 101, 126
graphic formats 153, 157
PICTs 154
QuickDraw PICTs vs PostScript
(EPSE) 154
TIFF graphics 154
QuickDraw and PostScript print
comparisons 155
MacPaint or bit mapped graphics 155
Version 1 vs Version 2 color pictures
155
graphic, attaching to a record 185
graphics, adding information to 185
grid and rulers, drawing page 97
Show ruler in: 97
Set ruler scale 98
Set initial reference point at: 99
Initial ruler starting values: 100
adjusting the ruler zero position 100
Group 95, 134-136, 162, 185, 344
grouped graphics 72, 134
limit file size using Group 134
Guidelines 103-104

H

Handles 107, 109, 137, 139
hardware reset 161
Header area 244, 254
Headers 298

help file, finding 87

index 377



Help Item: pop-up menu 88
help topic pages 90
help, context sensitive 89
help, exiting 90
hidden objects 149, 150
Hide All 148, 150
Hide Border 174
Hide Field Name 174, 300
Hide link field 173
Hide Mini Page 99
Hide Ruler 174
Hide Selected 147, 148, 150
Hide Titles 99
Hide/Show 147-148
Hide/Show ruler 174
Hiding and Showing some or all objects
of a Type 149
Highlight 46, 228-239
filling in selection conditions 47
highlighting all objects of a type 228
highlighting selected objects of a type
229
highlighting some objects of a type
220
setting conditions for “Highlight...”
230
AND and OR 232
comparison by numeric characters
234
comparison by text characters 235
text values 235
text with very similar information 230
Highlight All 228
Highlight, erasing a condition 238
Highlight, terporary override 239
highlighting, canceling 239
highlighting, halting the process 239

I

I/0 and printing errors 347

Ignore and Activate 76

Ignore double-click on graphics 223

Import and Export menus 208

Import and export via the Clipboard 160,
218

Import Graphic... 151, 159

Import menu 198

Filevision IV

import a graphic into an Info page 181
import graphics dialog 181
import PICTs 182
Import/Export Edit Menu 205-207, 337
Undo 205
Cut, Copy, Paste and Clear 205
Append field(s) 205
Field setup 205
Import/Export File Menu 203-204, 336
Import 203
Export 203
New setup 204
Load setup 204
Save setup 204
Return to Filevision 204
Import/Export Text 188-219, 342, 351
Edit 342
Exchange data between Filevision IV
files 351
Export to Excel 352
Export to Filemaker 354
Export to Helix 356
Expert to MacWrite and word proces-
sors 357
Export to Omnis 3 359
Export to OverVUE 2.0 360
Import 342
Import from Excel 352
Import from Filemaker 353
Import from Helix 355
Import from MacWrite and word
processors 356
Import from Omnis 3 358
Import from OverVUE 2.0 359
Options 342
Types 342
Importing and Exporting data 197-202
importing a file 198
choosing the format to import data
198
choosing the type and fields 199
how to treat data in each field 200
Importing graphics 151, 181
Info & Form rulers 107
Info button 96
Info display 36
Info page 91
information area 93



Initial Text 169-170, 177
initial print format 262
initial text fields 169
Integrated Imaging 159
Invert 174

Invert button, shades 128
Invert/Do not Invert 174
Inverted 282

is 230

is not 230

K

Keyboard shortcuts 343

L

Labels, preparing for printing 261
going to the Print Library 262
naming the print format 262
removing unwanted fields 263
adjusting the label size 263
using an annotation field for contents

of data fields 264
final label adjustment 265
using Across 266
printing the labels 266

line color 121

line tool 120
drawing constrained lines 121
limiting line and polygon angles 122

line width 70, 121

lines menu 70

Link button 91, 96, 222

link, creating 220

linking to another file 76, 220-222
returning 77

Load Setup... 204

Locate a Help File 87

M

MacPaint 153, 155

MacPaint graphics, imported 157
marquee 206

memory and disk vse 318
menus and primary dialogs 335
Metric/Inch Ruler 174, 301

mini page 92
modify records and highlighting 201
move 4 field 166
move handle 166, 264
move several fields 167, 293
moving and stretching 73
moving objects 136
moving multiple objects of one Type
137
Trouble shooting object selection and
moves 139
moving on the drawing page 50
multiple selection 70

N

New 83

New button 242

New Setup 204

next or previous object 182
None (shade} 101, 126
Numeric 299

O

objects 85

Open 83

Option Start... 218

Options button 172

Options menu 94, 104

Options Menu, Import/Export Text 218
Translate 218
Convert to upper case 219

Options menu, Filevision 339

Options, Type 172
hiding and showing the link field 173
double-clicking—to Info display or

Link file 173

OR 232-234, 238

oval tool 69, 70, 124

Overall Average 304

Overall statistics 304

overlapping fields 180, 283

P

Page Setup dialog 267
Page Setup... 287-289, 300

Index 379



Page Size... 93

page number 297, 299

Paste 205, 313

PicB forrnat 155-157

PICT graphic, exporting 153
PICT graphics 108, 154
pointer 69, 109

polygon tool 69, 70, 121, 344
pop-up 34

pop-up 108, 134, 143-146
pop-up button 144-145
PostScript EPSF 154
Preferences 107

Prev and Next buttons 96
Prev and Next to select abjects 37

Previewing Forms, Reports and Labels 290

primary sort field 247
Print button 260
Print Library 242, 250, 262, 267, 286
Print Page... 309
Print Records... 242, 270, 275, 286-287
Print to 260
print format 316
print format, annotation fields 296
print formats, reusing 307
copying the print formar 307
pasting the print format 307
saving a print format in the Scrap-
book 307
imported graphics in print formats
308
print Layout 275
print layout, EPSF, PICT or Paint 255
Printed output 330
printer dialog box 251
printing Form letters 268
printing Forms 252
printing Labels 261
printing to a file 289
printing to the printer 289
printing to the screen 289
printing what you're working on 309
printing with special information 297
processing imported records 209-216
proportional stretch 142
Filevision IV PICTs 157

Filevision IV

Q

QuickDraw PICTs 154

R

Rank comparison 231
record icon 183, 185
record icon box and attaching graphic
objects 95
record without a graphic 185
Records 42, 86, 96
Records to print 287
records, adding 177
rectangle tool 69, 123
Remove Field 167, 294
Remove Field button 245
Replace 238
Report 242
Report button 243
Reports, preparing for printing 240
going to the Print Library 242
Print Report style: Form, Report or
Label 243
The Print Format window 243
narming the print format 243
setting up the report title 244
adding an annotation field 244
removing unwanted fields 245
adding a data field 245
sorting the report 247
detail statistics: getting sales by state
249
overall statistics: a count of all the
records 249
previewing the Report 250
printing the Report 251
other features of Reports 251
Reshape 131-133, 310, 317
restore pop-up 146
Return to Filevision 203
Return to... 222
reuse print formats 292
Revert 183
Revert button, shades 128
Rounded Corners 124
rounded rectangle 123, 124
rounded rectangle tool 69



ruler zero position 100

S

Save 83-84
Save As... 83, 319
Save Setup... 204
save a layout 176
saving Forms, Reports and Labels in a
disk file 291
scaled size 180
scanned standard forms 159
scanner 158
Scrapbook 161, 176, 308, 311
Scrapbook symbol palette 119
Scrapbook, shade palette 130
SDF 216
Secondary sort field 247
Select all 209 -
Select records (exporting) 21
Select records (importing) 209
select fields 205, 208
selected Objects 92
selected Type 223
selecting objects 34, 136
selecting records for export 196
selecting records to print 286
Send to Back 133, 144
separating a record from its graphic 184
Shade rectangle 127
shade palette 130, 131
Shades Editor 126-131
shade rotation 127
shade colors 128
changing a shade’s colors 128
using colors with shades 129
saving your shades for use in other
files 129
load a shade palette from the Scrap-
book 131
Shades menu 70, 121, 126, 129, 340
shades palette 126
shorteuts and special key combinations
343
Show All Types 148
Show border/Hide border 174
Show field contents only 280
Show grid 100

Show guide 104
Show link field 173
Show Only These 148, 149
Show Ruler 174
Show ruler in 98
Show selected graphics using 107
Show/Hide Borders 300
Show/Hide Ruler 300
shrink graphics 139
Single PICT 152
Size menu 112
Snap to Alignment 121
Snap to Guide 104
Sort 301
Sort By... 94, 223-225
Sort printing dialog box 247
sort field 94, 301
sort order 96
sorting printed output 301
Sort... 182
special characters 297
special key combinations 344
specifications 325
Files 325
Working with files 326
Drawing and graphics 327
Adding and removing information
328
Printed output 330
square brackets 276
squares and rectangles 123
round rectangle edit dialog 123
Standard deviation 305
standard company forms, imported 159
standard format 190-192
Start a new page 302
Start a new page for each 248
Statistics dialog box 249
statistics in columnar reports 303
overall statistics 304
detail statistics 304
counts 305
totals 305
averages 305
standard deviations 305
sample Report 3006
stretch handle 166, 263
stretch label background 263

Index 381



stretching graphics 139
proportional and square streich 140
stretching or shrinking a Header 298
Style menu 112
sumrmary of Highlight and Find comypari-
sons 237
SY1K 217
Symbol Editor 115-119
symbol rotation 115
symbol colors 116
changing a symbol’s colors 117
Using colors with symbols 117 _
saving your symbols for use in other
files 118
oad a symbol palette from the Scrap-
bock 119
symbol colors 116
symbol Revert 116
symbol rotation 115
symbol ool 69, 114-119
Symbols 70, 108, 114-119
Symbols menu 114, 118, 340
system date 170, 297, 298, 289
system errors 347
system time 170, 298-299

T

Tab key 177
Tertiary sort field 247
Text editing 113
Text Masking 112
Text menu 111-112, 134, 174, 339
text tool 69, 110-111
TIFF 154
time 169
toolbox 108
pointer 109
selecting a single object with the
pointer 109
selecting several neighboring objects
with the pointer 109
selecting neighboring objects of cne
Type with the pointer 110
selecting several non-neighboring
objects with the pointer 110
Total 305
totals, running 302

Filevision IV

Tour file 32
tracking 94-95
transferring text and graphics 161-162
Translate. .. 218-219
Type layout 176
Type layout background shade 175
Type layout, saving 161, 176

copying and pasting the type layout

176

changing the type layout later 176
Type, showing only one 150
Types menu 207, 338
Types menu, Import/Export 207
Types, adding 163

naming a type 164

U

Ungather 142
Ungroup 136
up carat (A) 237
Using Color 108

A\

Value comparison 230
version 1 PICTs, imported 157
version 2 PICTs, imported 158
View Print 283, 264, 291
viewing an object’s record 35

w

Window control 52
edjting a print format 54
annotation fields 56
printing it out 58
pop-ups 61
graphic layers (types) 62
adding fields to the type layout 64
field setup 65

Working with files 326

working copy 23

working with drawing page text 113

Z

zoom views 49, 105





