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Chapter 1
Welcome to FileMaker Pro

Welcome to the FileMaker® Pro 6 application. FileMaker Prois
designed to help you manage information easily and effectively.

About this guide

Thefirst section of this FileMaker Pro Getting Started Guide tells
you how to install the application on your Windows or Mac OS
computer, andintroduces new featuresin FileMaker Pro. The second
section isatutoria that shows you how to use the major features of
FileMaker Pro.

The User’ s Guide describes how to use the most common featuresin
FileMaker Pro. For detail s about some advanced features, aswell as
new features added in FileMaker Pro 5.5 and FileMaker Pro 6, see
FileMaker Pro Help.

Note When afeature or procedureisspecificto aparticular platform,
you see instructions and illustrations that are also specific to that
platform. For features or procedures that are similar on both
platforms, you may seeillustrations for either Windows or the
Mac OS.

Registration and customer support

Please take the time to register your product during installation,
through the FileMaker web site at www.filemaker.com/register, or
by choosing Help menu > Register Now in FileMaker Pro.

For information about technical support and customer service, see:

www.filemaker.com (North American customers)
www.filemaker.com/intl (customers outside North America)

or choose Help menu > FileMaker on the Web. At the web site, you will
find the FileMaker Service Directory, which details the service
options available to North American customers, aswell aslinksto
FileMaker worldwide sites, answers to frequently asked questions,
and access to the Techlnfo Knowledge Base used by Technical
Support. If you do not have access to the Web, please refer to the
FileMaker Service Directory included in the software box. North
America customers can also call 1-800-965-9090 to learn about the
service options available.

About the installation code

Theinstallation code is a seventeen-digit number |ocated on amulti-
part sticker on aseparate paper sheet within the box. Do not lose this
installation code; it cannot be replaced. We recommend that you
place one of the stickers on the inside front cover of your manual .

Important Y ou must enter the installation code during installation or
the software will not install.

The installation code ensures adherence to the single user license
agreement, which alows for use of one (1) copy of the Software on
asingle computer at atime (refer to your Software License). If the
codeisinvalid or if another copy of the application installed with that
same code is running on the network, the FileMaker Pro application
displays this error message: “ The maximum number of licensed
users are currently using this copy of FileMaker Pro. Please refer to
the Installation Code section of your Getting Started Guide for
further instructions.”
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If you receive this error message, you have entered a duplicate
installation code. To install FileMaker Pro on multiple computers,
you must have a unique installation code for each user, or obtain a
volume license. Y ou must license one copy of FileMaker Pro for
each computer.

Hardware and software requirements

Toinstall and use FileMaker Pro, you need the CD-ROM in the
FileMaker Pro package and the following minimum equipment
and software:

Windows requirements
* an Intel-compatible Pentium 90 or higher
* atleast 32 MB of RAM

® ahard disk with at least 210 MB of free space (for a Complete
installation)

* aCD or DVD drive

* Windows 98, Windows Me, Windows X P, Windows 2000
Professional, or Windows NT 4.0 with Service Pack 6

Mac 0S requirements

* an Apple computer that supports and is running Mac OS 8.6,
Mac OS 9 versions 9.0 through 9.2.2, or Mac OS X versions 10.1
through 10.1.4

®* aCD or DVD drive

¢ the amount of RAM and disk space required depends on the
Mac OS version:

Disk space
RAM (for an Easy Install)
Mac OS 8.6 or at least 32 MB at least 60 MB
Mac OS 9.x
Mac OS X at least 128 MB at least 60 MB

Important note about supported operating systems

At the time this book was written, FileMaker, Inc. tested
FileMaker Pro 6 with the Windows and Mac OS operating systems
listed above. FileMaker Pro may or may not work with newer
operating system releases. For information on newer operating
systems, see www.filemaker.com.

Some FileMaker Pro features are unique to or work differently on
certain operating systems. Thismanual and online Help use the label
“Mac OS 9.x or earlier” to indicate when a described feature is
specific to Mac OS 8.6 through 9.2.2. However, keep in mind that
Mac OS 8.6 isthe earliest Mac OS version that FileMaker Pro 6
supports, and that FileMaker Pro 6 does not support Mac OS X 10.0
through 10.0.4.

Networking requirements

If you plan to share FileMaker Pro files with other computerson a
network, you need to know which type of network you’'re using.
FileMaker Pro 6 supports the following network protocols:

FileMaker supports
this network protocol On these operating systems

TCP/IP (recommended)  All supported Windows and Mac OS
operating systems

IPX/SPX Supported Windows operating systems only

AppleTak Mac OS 9.x or earlier

If you're not sure which network protocol isinstalled and in use on
your computer, check with your network administrator before you
begin installation.

Note FileMaker recommends using the TCP/IP protocol on both
Windows and Mac OS networks. Y ou must use the TCP/IP protocol
to share files on a mixed Windows and Mac OS network.

Computers running Windows also require a Windows-compatible
network card and a software driver for the card.



Web publishing requirements

To publish a database on the Web using the FileMaker Pro Web
Companion, you need a host computer with access to the Internet or
an intranet via TCP/IP. The Web Companion network protocol
(TCP/IP) isindependent from the network protocol you choose for
FileMaker Pro. For example, you can choose AppleTalk or IPX/SPX
for the FileMaker Pro network protocol and still publish your
database on the Web via TCP/IP.

Important Accessto the Internet requiresan Internet service provider
(ISP). FileMaker Pro does not provide an Internet account for you.

Requirements for advanced features (Windows)

Some of the advanced features of FileMaker Pro require
additional software.

FileMaker Pro

advanced feature Software requirement

Welcome to FileMaker Pro 9

FileMaker Pro

advanced feature Software requirement

URL support and the
Speak script step

In Mac OS 9.x or earlier, the Internet control panel
and the Speech Manager extension are usually
available as part of anormal system software
installation. Make sure they’re turned on in the
Extensions Manager control panel.

Send Mail script step - A Mail API (MAPI) enabled email client software

Phone dialing Phone dialer or other Telephony API (TAPI)
compliant software
ODBC features Microsoft Data Access Components (MDAC)

version 2.5. To update MDAC software, use
Microsoft Windows Update or see the Microsoft web
site at www.microsoft.com.

Insert QuickTime
movie and image files

QuickTime software (available at www.apple.com)

Requirements for advanced features (Mac 0S)

FileMaker Pro

advanced feature Software requirement

Send Mail script step E-mail client software

Insert QuickTime QuickTime software (available at www.apple.com if
movie and imagefiles it was not included with your Mac OS version)

Features not supported in Mac 0S X

In Mac OS X, FileMaker Pro does not support the following
features:

® Toolbars
® Status (CurrentPrinterName) function

* Dial Phone script step

Opening files from previous versions

FileMaker Pro 6 can open files created in earlier versions of
FileMaker Pro as described in the following sections.

Important There may be date considerations when converting a
database from an earlier version of FileMaker Pro. For more
information about how FileMaker Pro handlesY ear 2000 issues, see
www.filemaker.com.

FileMaker Pro 5.x databases

Because FileMaker Pro 5.x and FileMaker Pro 6 sharethe sameformeat,
FileMaker Pro 6 can open FileMaker Pro 5.x files without converting
them. Y ou can even use FileMaker Pro 6 files with FileMaker Pro 5.x.
However, the new features that you usein a newer version will not be
supported when you open thefilein a previous version.

We recommend that, once you have created or opened afilein
FileMaker Pro 6, you do not make database design changes using an
earlier version of FileMaker Pro, particularly to features that have
changed in FileMaker Pro 6.



10 Getting Started Guide

FileMaker Pro 4.x/3.x/2.x databases

When you convert aFileMaker Pro 4.x/3.x/2.x file, FileMaker Pro 6
software saves your original FileMaker Pro 4.x/3.x/2.x file and
creates a copy that has been converted to the FileMaker Pro 5.x/6
format. The original fileis not modified and you can open it in the
previous version of FileMaker Pro. The converted file can only be
opened in FileMaker Pro 5.x/6.

To convert and open aFileMaker Pro 4.x/3.x/2.x file:

1. Start FileMaker Pro 6.

2. Choose File menu > Open and select the file to convert.
3. Click Open.

4. Click OK to append “OId” to the name of the original
FileMaker Pro 4.x/3.x/2.x file.

This file was created with a previous version of
Filetaker Pro and must be converted to the
Filetaker Pro 5.0 format

¥ Rename old file 2s: (BRI

Carcel

5. Click Save to start the conversion.

By default, this converted file will have the original file's name.
Preserving this name isimportant if you have existing relationships
or scripts, which might not function correctly if it is changed.

FileMaker Pro converts the file and opensit.

Keep these pointsin mind when converting files:

® You can also convert aFileMaker Pro file by dragging the file on
top of the FileMaker Pro 6 application icon.

¢ |f you add or remove the .FP5 filename extension as part of the
conversion process, you must re-specify file locations for related or
external files when the database is first opened.

* If you are converting acopy of aFileMaker Profile, close thefile
beforeyou copy it. Filesthat are copies of open fileswill not convert
correctly.

* If consistency check or auto-repair error messages appear during
conversion, try recovering the file first using a previous version of
FileMaker Pro.

FileMaker Pro 1.x databases

Onthe Macintosh, you can convert FileMaker Pro 1.x databaseswith
FileMaker Pro 6. Follow the instructions in the previous section,
“FileMaker Pro 4.x/3.x/2.x databases,” to convert your file to
FileMaker Pro 6.

FileMaker Pro for Windows cannot convert FileMaker Pro 1.x
databases directly. To use a database created by FileMaker Pro 1.x
with FileMaker Pro 6 in windows, do the following:

1. Convert the file on aMac OS computer using FileMaker Pro 2.x
or later.

If you have a Mac OS computer but do not have FileMaker Pro 2.x
or later, you can download atrial version of FileMaker Pro for
Macintosh from www.filemaker.com, and use it to convert the file.

2. Transfer the converted file to your Windows-based computer.

3. If necessary, follow the instructions in the previous section,
“FileMaker Pro 4.x/3.x/2.x databases,” to convert the fileto
FileMaker Pro 6.

Updating your User Dictionary

If you added words to a User Dictionary in a previous version of
FileMaker Pro, you may want to use it with FileMaker Pro 6. For
more information about converting a User Dictionary, see
FileMaker Pro Help after you have installed FileMaker Pro 6.
Choose Help menu > Contents and Index, click the Index tab, and type
di ctionari es.



Chapter 2
Installing FileMaker Pro in Windows

Before you begin the installation process, exit other open programs
and save your work. For late-breaking information about
FileMaker Pro, browsethe contents of the CD and view the Read Me
file or visit www.filemaker.com.

Installation notes

Before you install FileMaker Pro, review the following notes:

* Toinstall FileMaker Pro in Windows N T, Windows XP or
Windows 2000 Professional, you must log on with Administrator or
Power User privileges.

* If FileMaker Pro 5.x is already installed, you can install
FileMaker Pro 6 without uninstalling FileMaker Pro 5.x. Y ou can
use either version of FileMaker Pro on the same computer.

* If your computer is running virus protection software, turn it off
prior toinstalling FileMaker Pro, and then turn it back on afterwards.

* When you areinstalling FileMaker Pro, you will see the License
Agreement panel. Read the Software License Agreement. If you
accept the terms of the license agreement, click | accept..., then click
Next.

* By default, FileMaker Pro will beinstalled in the C:\Program
Files\FileM aker\FileMaker Pro 6 folder. During installation, you
can choose another drive or another folder if you wish.

* During installation, you can choose whether to install all program
features (Complete), or to install only selected portions of the
program (Custom). For example, you may choose not to install
certain featuresin order to save disk space.

* During installation, you will be prompted to choose one of the
following network protocols for sharing databases: TCP/IP, IPX/SPX,
or None. If you are not certain which protocol to use, ask your
network administrator, or choose TCP/IP. (If you make a mistake
and choose the wrong network protocol, you can changeit later. See
“Adjusting network software” on page 12 after you have installed
FileMaker Pro.)

Installing FileMaker Pro

Y ou must usetheinstallation programto install FileMaker Pro—you
can't install FileMaker Pro by dragging files to your hard disk.

If you want to create an install log file that lists the registry entries
and path of all installed files, you must install FileMaker Pro 6 from
thecommand line. See“Installing FileMaker Pro from the command
ling’ on page 12.

Toinstall FileMaker Pro on your hard disk:
1. Insert the CD into your CD or DVD drive.
2. Click Install FileMaker Pro 6.
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% FileMaker Pro 6

FileMaker

Install FileMaker Pro 6

Browse CD Contents

Yiew the ReadMe

v+ v 3

Exit

&, FileMaker

The FileMaker Pro Install Shield Wizard appears.
3. Install FileMaker Pro by following the on-screen instructions.

For details about installation issues, see “Installation notes’ on
page 11.
4. When the installation is complete, click Finish.

When installation compl etes, you see a Product Registration panel.
You can register online if you have an Internet connection. If you
chooseto register by letter or by fax, aform will appear inthe Adobe
Acrobat Reader application. Y ou can fill out the form on your
computer, print acopy of the form, and mail or fax it to FileMaker.

Installing FileMaker Pro from the command line

Toinstal FileMaker Pro from the command line and create an
installation log file:

1. Insert the FileMaker Pro 6 CD.
2. Open a command window.

3. In the command window, type
E\F les\setup.exe /v*/Lr C\FWP6InstallLog.txt”

4. Follow the on-screen instructions.

The FMP6InstallLog.txt file will be located on the C drive of your
hard disk. You can view it with Notepad, Wordpad, or aword
processing program.

Note If your CD or DVD driveisnot located at drive E, then
substitute the correct letter for your drive.

Where files are stored on your hard disk

The FileMaker Pro installer copiesfiles to several folders on your
hard disk, depending on theinstall ation options you choose and your
operating system. If you performed acommand line installation and
specified an install log file, you can view the install log file, which
lists the location of each installed file. Thisfile can be viewed with
Notepad, WordPad or aword processing application.

Uninstalling, modifying, or repairing
FileMaker Pro

Y ou can use the Windows Add/Remove Programs Control Panel to
uninstall FileMaker Pro, replace missing or corrupt files, or to
change which features are installed. For more information about
using Add/Remove Programs, refer to Windows Help.

Note Uninstalling doesn't deletefilesthat you' ve created, aslong as
they are named differently than the sample and templatefilesthat are
installed with FileMaker Pro.

When you modify or repair FileMaker Pro, you may be prompted to
enter your installation code.

Adjusting network software

Depending on the networking protocol you' re using, you may have
to modify settings on the host and/or guest computers.



Changing the network protocol

During installation, you select a network protocol (or none) for
FileMaker Pro. Y ou must choose a network protocol if you want to
share FileMaker Pro databases over anetwork, either asaguest or as
ahost. The protocol you choose for FileMaker Pro database sharing
does not affect other intranet or Internet activities. Y ou can change
the FileMaker Pro database sharing network protocol at any time
without reinstalling the software.

Important The network protocol settingin FileMaker Pro must bethe
same on the host and guest computers.

For more information about your network configuration, see
“Networking requirements’ on page 8, or consult your network
administrator.

To change the network protocol:
1. In FileMaker Pro, choose Edit menu > Preferences > Application.

2. In the General tab, choose a network protocol from the Network
Protocol drop-down list.

3. Click OK.

Changes to this setting don’t take effect until you restart
FileMaker Pro.

Changing the IPX/SPX frame type

If you're using IPX/SPX as the network protocol, you must select a
frame type. A frame encapsul ates packets of informationin a
recognizable format; all computers communicating with each other
on a network must use the same frame type. For help in deciding
which frame type to select, see your network administrator.

Note If youareusing TCP/IP networking, you do not need to change
the frame type.

Installing FileMaker Pro in Windows 13

Changing the frame type (Windows 98 and Windows Me)
To change the frame type with |PX/SPX networking:

1. Open the Network control panel and click the Configuration tab.
2. Select the IPX/SPX protocol from the list and click Properties.
3. Click the Advanced tab.

4. Click the frame type in the Property dialog box.

5. Make a selection from the Value drop-down list.

Note To allow themaximum recommended number of guests(10) to
connect, consider increasing the |PS/SPX Maximum Connectionsto
90 or greater in the Network control panel.

6. Click OK.

Windows prompts you to restart your computer for these new
changes to take effect.

Changing the frame type (Windows NT)

To change the frame type with IPX/SPX networking:

1. Open the Network control panel and click the Properties tab.
2. Select the IPX/SPX protocol from the list and click Properties.
3. Select aframe type from the drop-down list.

4. Click OK to apply the frame type, and click OK to close the
Network dialog box.

Windows prompts you to restart your computer for these new
changesto take effect.

Changing the frame type (Windows XP and Windows 2000

Professional)

To change the frame type with IPX/SPX networking:

1. From the Start menu, open the appropriate control panel:
* Windows XP: the Network Connections control panel

* \Windows 2000 Professional: the Network and Dial-up Connections
control panel
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. Right-click on the network connection you are using.

. Select Properties from the menu.

. Select the IPX/SPX protocol from the list and click Properties.
. Select aframe type from the drop-down list.

. Click OK to apply the frame type.

. Click OK to close the Connection Properties dialog box.

0 N O G A~ W N

. Close the Network and Dial-up Connections window.

With Windows X P and Windows 2000 Professional, you do not
need to restart your computer.

Changing the FileMaker Pro cache size

FileMaker Pro maintains an internal cache of portions of your
database. Depending on your computer’s memory configuration,
you may want to adjust the cache size to improve performance.

Y ou may want to consider increasing the cache sizeif you plan to:
¢ work on alarge database file

* work on several database files at once

* host database files

* use adatabase file that contains many graphics

* insert alarge graphic into a database file

Consider decreasing the cache size if you plan to run several
applications at the same time and you have a limited amount of
memory (RAM) installed.

Note When you increase or decrease the FileMaker Pro cache size,
you also increase or decrease the amount of memory needed to run
FileMaker Pro.

For more information on managing memory, see the documentation
that came with your computer.

To change the cache size that FileMaker Pro uses:
1. In FileMaker Pro, choose Edit menu > Preferences > Application.
2. Click the Memory tab.

General | Layout  Memon | Plugdns |

Save changes to disk:

@ {during idle tme

 gwery | 10minutes | or when necessary

File cache is always on. Current size is 511K

Altempt cache size of [512 K on FilsMaker restart

Cancel

3. Type anumber in the Attempt cache size of box.
4. Click OK.

The next time you start FileMaker Pro, the new cache sizeis used.

Where to go from here

After youinstall FileMaker Pro, you canimmediately begin working
with the application. Here are some suggestionson whereto gointhe
documentation to get started:

* |f you're new to databases, read chapter 1, “ FileMaker Pro basics,”
inthe FileMaker Pro User’s Guide to |earn basic database concepts.

¢ |f you're new to FileMaker Pro, work through the tutorial. The
tutorial lesson files are automatically installed when you do a
Complete installation. The tutorial begins on page 31 of this guide.

¢ |f you've used FileMaker Pro before, read chapter 4, “New
featuresin FileMaker Pro” on page 23 to learn about new features
availablein FileMaker Pro 6.



Chapter 3
Installing FileMaker Pro in the Mac OS

Before you begin the installation process, quit other open programs
and save your work. For late-breaking information about
FileMaker Pro, browsethe contents of the CD and view the Read Me
file or visit www.filemaker.com.

Installation notes

Before you install FileMaker Pro, review the following notes:

* The FileMaker Pro CD contains two installer programs, one for
Mac OS 9.x or earlier, and one for Mac OS X. Before you install
FileMaker Pro, confirm your Mac OS version. With the Finder
application active, choose About this Computer or About this Mac from
the Apple menu. A window will appear that lists your Mac OS
version.

* |f you're upgrading, you can install FileMaker Pro 6 without
removing the previous version of FileMaker Pro that you may
already have installed.

* |f your computer is running virus protection software, turn it off
prior toinstalling FileMaker Pro, and then turn it back on afterwards.

* During installation, you can choose whether to install al the
program files (an Easy Install), or to install portions of the program
(aCustom Install). For example, you may choose not to install
certain featuresin order to save disk space.

* Mac OS X: if you'reinstalling FileM aker Pro on a computer with
multipleuser accounts, see” Accessing filesfrom other user accounts
(Mac OS X)” on page 17 after you install FileMaker Pro.

® Mac OS X: ODBC drivers are not automatically installed. You
must install the drivers manually. See “Installing ODBC driversin
Mac OS X” on page 16, after installing FileMaker Pro.

Installing FileMaker Pro

Y ou must usetheinstallation programto install FileM aker Pro—you
can'tinstall FileMaker Pro by dragging filesto your hard disk.
Toinstall FileMaker Pro on your hard disk:

1. Insert the CD into your CD or DVD drive.

Y ou see the disc’s window on your screen. If you see only the disc
icon, double-click the CD icon to open its window.

2. Using the table below, locate and double-click the appropriate
Start Here file for the Mac OS version in use on your computer.

For this Mac OS version:  Double-click this file:

Mac OS 9.x or earlier

Start Here hac 05 Classic

Mac OS X e
2
Start Here hac 05 x

Y ou see the Software License Agreement.

3. Read the Software License Agreement. If you accept the terms of
the license agreement, click Accept.

Y ou see the FileMaker Pro Installer dialog box.
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06 Start Here Mac 0S X

Choose
Easy Install or
Custom Install

Easy Install ﬂ

Performs an installation of FileMaker Pro & software including

» FileMaker Pro 6 Application

s Networking and Web Support files

» Help files and Spelling Dictionaries

s FileMaker Pro Tutorial and Templates

» FileMaker Pro and Apple Events Information and Example files

Approximate disk space needed: 41 412K

Displays where —— " -
FileMaker Pro | (3 ; e
will be installed Install Location: | Macintosh HD m ’ Install Y

4. Choose Easy Install or Custom Install from the pop-up menu.

TheEasy Install optioninstallsall of the FileMaker Pro programfiles.
The Custom Install option allows you to choose which portions of the
product to install. (In most cases you should use the Easy Install
option.)

5. Look inthe Install Location area, and make a note of the folder and
hard drive where FileMaker Pro will be installed.

If you want to, you can choose another hard drive or another folder
from the Install Location pop-up menu.

6. Click Install.
Y ou see the personalization dialog box.

7. Typeyour name, company name (if any), and your FileMaker Pro
installation code into the appropriate text boxes.

Theinstallation code is a seventeen-digit number located on a
multi-part sticker on a separate paper sheet within the box. See
“About the installation code” on page 7 for more information.

8. Click OK.
The Installer begins copying files.

When installation compl etes, you see a Product Registration dialog
box. Y ou can register online if you have an Internet connection. If

you choose to register by letter or by fax, aform will appear in the
Adobe Acrobat Reader application. Y ou can fill out theform onyour
computer, print acopy of the form, and mail or fax it to FileMaker.

A final dialog box tells you the installation on your hard disk was
successful.

9. Click Quit to leave the Installer.

Where files are stored on your hard disk

The FileMaker Pro installer copiesfiles to severa folders on your
hard disk, depending on theinstallation options you choose and your
operating system. When installation is complete, you can view the
Installer Log Filein the FileMaker Pro 6 folder. Thelog fileliststhe
location of each installed file. Y ou can view it with TextEdit (Mac
OS X), SimpleText (Mac OS 9.x or earlier), or aword processing
program.

Installing ODBC drivers in Mac 0S X

In Mac OS X, you must manually install the ODBC drivers after the
FileMaker Pro installation is complete.

Note Toinstall thedrivers, you will need an administrator password,
such as the password created when you first set up Mac OS X.

1. Navigate to the folder Applications/FileMaker Pro 6 folder/
FileMaker ODBC Drivers.
2. Double-click the FileMaker Pro Mac OS X ODBC Driversfile.

3. Follow the installer instructions.



Accessing files from other user accounts (Mac 0S X)

If youlogged in asan administrator and installed FileM aker Prointo
the default Applications folder on a computer with multiple user
accounts, other users who log in with a non-administrator password
will not be able to access some FileMaker Pro application folders
and files.

* Template and tutorial files: If a non-administrator user needs to
accessthesefiles, perform a Custom Install and install thesefilesinto
the user’s Applications folder.

* Web Security folder and Web folder: Set file permissions so that
all valid users have Read & Write access to the Web Security
databases and Read only access to the Web folder.

For more information on setting file permissions, see the Mac OS X
Help topic "Setting Access Privileges."

Choosing a network protocol (Mac 0S 9.x
or earlier)

Y ou must choose a network protocol if you want to use

FileMaker Pro over anetwork, either asaguest or asahost. For more
information about your network, see “ Networking requirements’ on
page 8, or consult your network administrator.

Important Thenetwork protocol setting in FileMaker Promust bethe
same on the host and guest computers.

To choose a network protocol:

1. Choose Edit menu > Preferences > Application.

2. In the General tab, choose a network protocol from the Network
protocol pop-up menu.

3. Click OK.
Changesto this setting don't take effect until you restart FileMaker Pro.
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Adjusting memory

Y ou might need to change the amount of memory reserved for
FileMaker Pro if you plan to:

¢ work on alarge database file

* work on several database files at once

® host database files

* use a database file that contains many graphics

* insert alarge graphic into a database file

Mac OS X allocates memory to applications differently than
Mac OS 9.x or earlier. To adjust the memory amount, follow the
appropriate instructions for your Mac OS version:

* For Mac OS X, follow the instructions in the next section,
“Adjusting the FileMaker Pro cache (Mac OS X).”

® For Mac OS 9.x or earlier, see “ Adjusting memory requirements
(Mac OS 9.x or earlier)” on page 18.

Adjusting the FileMaker Pro cache (Mac 0S X)

Because Mac OS X dynamically allocates memory to applicationsas
needed, there is no way to set a specific amount of memory to
allocate to the FileMaker Pro application. However, you can adjust
the FileMaker Pro cache size.

Y ou may want to increase the cache sizeif you plan to do any of the
itemslisted in “ Adjusting memory,” above. Consider decreasing the
cachesizeif you plantorun several applicationsat the sametimeand
you have alimited amount of memory (RAM) installed.

To change the cache size that FileMaker Pro uses:

1. In FileMaker Pro, choose the FileMaker Pro application
menu > Preferences > Application.

2. Inthe Application Preferences dialog box, click the Memory tab.
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Application Preferences

[ General T Layout Y Memqu Plug-Ins \

. Save changes to disk

@® during idle time

O every 10 minutes %' or when necessary

File cache is always on. Current size is 8191K.

Attempt cache size of 8132 K on FileMaker restart.

Cancel ) 0K )

3. Type anumber in the Attempt cache size of box.
4. Click OK.

The next time you start FileMaker Pro, the new cache sizeis used.

Adjusting memory requirements (Mac 0S 9.x or earlier)

Y ou may want to increase the amount of memory reserved for
FileMaker Proif you plan to do any of theitemslisted in“Adjusting
memory” on page 17. Consider decreasing the amount if you plan to
run several applications at the same time and you have alimited
amount of memory (RAM) installed.

Keep the following pointsin mind:

® The amount of memory you give to FileMaker Pro affects your
ability to run other applications. If the Mac OS and FileMaker Pro
take up all the available memory, you won't be able to open other
applications while FileMaker Pro is running.

* Avoid specifying less memory than the Suggested size in the
FileMaker Pro Info dialog box.

To change the amount of memory FileMaker Pro uses:

1. If FileMaker Pro is open, quit the application by choosing File
menu > Quit.

2. Inthe Finder software, open the FileM aker Pro 6 folder. Select the
FileMaker Pro application icon by clicking it once.

Note If you click the application icon twice, you will start
FileMaker Pro. If that happens, choose File menu > Quit and try again.

3. Choose File menu > Get Info > Memory.

0 =———=rileMaker Pro ni=—"—~—8H

@ |FiIeMaker Pro

N L —

Kind: application program

Memory Requirements

Suggested Size: 13316

K
HMinimum Size: [3220 K
Preferred Size: [13316 K

Note: This application may require 3,076 K less
memory i moved to another hard disk and virtual
memory i3 turned on in the Memary control panel

Change the amount of
memory FileMaker Pro
uses here

[ Locked

4. Inthe Memory Requirementsarea, double-click the Preferred Size
number and type a number to change the memory allocated for
FileMaker Pro.

If you can’t type in the box, make sure you' ve quit FileMaker Pro.
5. Click the close box.

The next time you start FileMaker Pro, it will use the amount of
memory you specified in the Preferred Size text box if that amount of
memory is available.



Enabling the FileMaker Pro Web
Companion (Mac 0S X)

Note For instructions on enabling the FileMaker Pro Web
Companion in Mac OS 9.x or earlier, see chapter 14 of the
FileMaker Pro User’s Guide.

FileMaker Pro uses the FileMaker Pro Web Companion plug-in to
serve databases over the Web.

To enable the Web Companion in Mac OS X:

1. Start the FileMaker Pro application.

2. Choose the FileMaker Pro application menu > Preferences >
Application.

3. Inthe Application Preferences dialog, click the Plug-Ins tab.
4. Select the Web Companion checkbox.

Application Preferences

[ General T Layout T Memory Y Plug-Ins 1

Enabled Plug-In Name

[ Aute Update
[ Local Data Access Companion

[0 Remote Data Access Companion
& Web Campanian

— Description

Select the Web Companion checkbox to
provide access to your databases on the
Web. Also set up Companion Sharing
(choose Sharing fram the File menu).

Cancel @

After you enable the Web Companion, you must specify which port
number, or virtual connection, the Web Companion will useto
publish data.
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The first time you enable the Web Companion, FileMaker Pro
displays the following dia og, which requests permission to make a
one-time change to your computer’s setting to facilitate web
publishing on a port number below 1024.

) To use the standard settings for web publishing,
FileMaker Pro must make a one-time change to your
computer's settings.

To make this change, you need an administrator
password (created when you first set up Mac OS X).

See the “Cetting Started Guide”for mare information

(" Cancel (" Advanced .. ) ('e!mmm! ‘,

The standard port number for web publishing is 80 (ports are
numbered between 1 and 65535), and most web serversand browsers
use this port as the default. Port 80 is also the default port for the
FileMaker Pro Web Companion. For security reasons, Mac OS X
restricts accessto ports below 1024. To configure the FileM aker Pro
Web Companion to use ports below 1024 while maintaining the
Mac OS X access restrictions on these ports, it is necessary to make
a one-time change to the file permissions of the Web Companion
Enabler to give it the authority to open privileged ports (ports 1-
1023). To make this change, you will need an administrator
password, such as the password created when you first set up

Mac OS X.

Note If you use aport other than port number 80 for FileMaker Pro
web publishing, your userswill need to append acolon (“:”) and the
number of the port to their URL s to access your web hosted
databases. For more information, see “ Accessing databases that are
published to the Web” on page 21.
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5. Do one of the following three options:

To

Click

Configure the Web Companion to use
the default port 80, or any other valid
port number (Thisistherecommended
option, but it requiresaMac OS X
administrator password.)

Continue. Proceed with the next stepin
this section.

Configure the Web Companion to use
port 1024 or higher (This option does
not require aMac OS X administrator
password.)

Advanced. For further instructions, see
the section “ Configuring the Web
Companion for use with ports

1024 and higher” on page 20.

Skip enabling the Web Companion at
thistime

Cancel. The Web Companion will not
be enabled, and your system settings
remain unchanged.

6. Enter an administrator name and password in the Authenticate

diaog.

The administrator name and password you enter can be the same as
the name and password used when Mac OS X wasinstalled, or if you

have administrator privileges but do not know an administrator
password, you can create a new user and password with
administrator privileges. For more information on creating an

account with administrator privileges, seetheMac OS X Help topics

“Working as an administrator” and “Changing your password.”

Authenticate

-~ You need an administrator name and password

to make changes in FileMaker Pro.

Name:

Password:

Cancel

7. Click OK.

The Web Companion is now configured to use port 80.

8. Click 0K again to close the Application Preferences dialog.

To use aport number other than 80, open the Application
Preferences dialog again (choose the FileMaker Pro application
menu > Preferences > Application), click the Plug-Ins tab, select the
Web Companion plug-in, and click Configure. In the Web Companion
Configuration dial og, enter the port number you want (between 1 and
65535) in the TCP/IP Port Number box, and click OK.

Configuring the Web Companion for use with ports
1024 and higher

Y ou do not need an administrator password to configure the
FileMaker Pro Web Companion to use a port number between 1024
and 65535. Unlike ports below 1024, the FileMaker Pro Web
Companion can use ports 1024 and above without atering your
system’s settings.

To configure the FileMaker Pro Web Companion to use only ports
1024 and above:

1. Choose the FileMaker Pro application menu > Preferences >
Application.

2. Inthe Application Preferences dialog, click the Plug-Ins tab.
3. Select the Web Companion checkbox.
Y ou see the following dia og.

) To use the standard settings for web publishing,
FileMaker Pro must make a one-time change to your
computer's settings.

To make this change, you need an administrator
password (created when you first set up Mac OS X).

See the “Cetting Started Guide”for mare information

»

(" Cancel (" Advanced .. ) fe::nti'nul,,, ‘,

4. Click Advanced.

Y ou see the following dialog.



& To publish using TCP/IP port number 80 (the default setting and the
standard port for web activity), or any port numbered below 1024,
you need to enter an administrator password so FileMaker Pro can
make a one-time change to your computer's settings.

Or, you can assign a TCP/IP port number between 1024 and 65535
(inclusive).

See the "Ceting Started Cuide” for more information

(" Cancel )

" Change Port.. " W

5. Click Change Port.
Y ou see the Web Companion Configuration dialog.

6. Enter a port number between 1024 and 65535 in the TCP/IP Port
Number box.

Web Companion Configuration

— Web Companion User Interface — Logging

[0 Access log file
[ Error log file
[ Information log file

@ Enable Instant Web Publishing
Home Page: | (Built-in} q

Language: English ﬂ

— Remote Administration — Security
® Disabled @® FileMaker Pro Access Privileges
O Requires no password Web Security Database
O Requires password:
[2) Restrict access to IP address(es)
TCP/IP Port Number: I |
IP Guest Limit: 10 Cancel @

Enter the TCP/IP port number here

7. Click 0K to save your changes.

Y ou arefinished. The Web Companion is now configured to use the
port you have specified.
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Accessing databases that are published to the Web

When you publish a database to the Web, your users access that
database by entering the host machine’s URL in their web browser.
If the FileMaker Pro Web Companion is configured to use port
number 80, the default port, the URL your userswill enter will look
likethis:

http://12. 34.56. 78/

The number “12.34.56.78” is an example; in its place, your users
would enter the actual URL of your host machine.

If the FileMaker Pro Web Companion is configured to use a port
number other than the default, the URL your users will enter will
look like this:

http://12. 34. 56. 78: 1024

Again, the number “12.34.56.78:1024” is an example; your users
would enter the actual URL of the host machine, followed by acolon
(“:) and the port number specified in the FileMaker Pro Web
Companion Configuration dialog.

For more information on accessing FileMaker Pro databases on the Web,
see chapter 14 of the User’ s Guide, “ Publishing databases on the Web.”

Where to go from here

After youinstall FileMaker Pro, you canimmediately begin working
with the application. Here are some suggestionson whereto gointhe
documentation to get started:

* |f you' re new to databases, read chapter 1, “ FileMaker Pro basics,”
inthe FileMaker Pro User’s Guide to learn basic database concepts.

* If you're new to FileMaker Pro, work through the tutorial. The
tutorial lesson files are automatically installed when you do an Easy
Install. The text of the tutorial begins on page 31 of this guide.

¢ |f you've used FileMaker Pro before, read chapter 4 of this guide
to learn about new features available in FileMaker Pro 6.
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Chapter 4
New features in FileMaker Pro

This chapter provides you with an overview of the new featuresin
FileMaker Pro 6. See page 29 for asummary of the new featuresin
the previous version, FileMaker Pro 5.5.

Important See FileMaker Pro Help for complete details on new
featuresin FileMaker Pro 6.

Import and export XML data

Extensible Markup Language (XML) is a standard language for
structured data interchange on the Internet or an intranet. Instead of
being arigid file format, XML is alanguage for defining agreed-
upon formats that groups can use for exchanging data. Many
individuals, organizations, and businesses are using XML to transfer
product information, transactions, inventory data, and other business
data.

FileMaker Pro 6 can import, open, and export XML. Additional
documentation and sampl e files are available that demonstrate the
capabilities of the FileMaker Pro 6 XML import/export features. See
the XML Documentation and XML Examples folders (inside the
FileMaker Pro 6 folder). For general information on XML and links
to XML resources, see the FileMaker web site at
www.filemaker.com.

Edit View Inser Records  Scripts
New Database..
Open... %0
Open Remote.. %O
Close #W
Define Fields. .. 48D
Define Value Lists...
Define Relationships...
Access Privileges [ 3
Sharing...
Page Setup...
Print... %P

Import Records > File...

Export Records... Folder...
Save a Copy As...

Recover... Digital Camera...

XML Source...
ODBC Source...

New Import Records submenu

Import and convert XML data

FileMaker Pro 6 canimport XML datainto an existing FileMaker Pro
fileorinto anew FileMaker Profile. The XML can beaphysical file,
or theresult of an HT TP request sent to aweb server. For example, you
could set up an Orders database to send tracking numbersto a package
delivery company in the form of an HTTP request, and their web
server could return the latest package tracking information in XML
format, ready to be imported into the Orders database.

The XML that you import must conform to the FileMaker
FMPXMLRESULT grammar format. If your XML isin adifferent
format, you can apply an Extensible Stylesheet Language for
Transformations (X SLT) style sheet during import to transform your
XML into the FMPXMLRESULT grammar.

Y ou can use the Import Records and Open script steps to create
scripts that import and open XML data.
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Export XML data
FileMaker Pro 6 can export datain two XML grammars:

* FMPXMLRESULT: agrammar that defines the database structure
(field names, field types, number of records, date formats, and time
formats) as well asthe dataitself.

* FMPDSORESUL T: agrammar that is useful for publishing
databases on web pages that are formatted with cascading style
sheetsor XSLT. The FMPDSORESULT grammar is compatible
with the Microsoft XML Data Source Object used by Microsoft
Internet Explorer.

You can apply an XSLT style sheet during export to transform either
of the above grammarsinto adifferent XML format, or into a
completely different format such asHTML or plain text. For
example, through XML export you can create a data-driven web
page, or atext file of datathat uses a custom field delimiter.

Y ou can use the Export Records script step to create scripts that
export XML files.

Import photos from a digital camera
(Mac 0S X)

FileMaker Pro 6 makes it easy to import photos from a digital
camera. Previously, you would have to download your photos to
disk, and then insert them one at atime into your database. Now all
you haveto do is connect your camerato your computer, and
FileMaker Pro can directly import some or all of the photos.
FileMaker Pro aso imports photos from memory card readers.

Import Field Mapping

Data in: "C-2040Z00M"

(Image Thumbnail)
(File Path}

1600

1200

24

72.00

2002:01:14 03:06:13
0.03333334

1.80

100

nfa

nfa

0.00

nja

View by: last order ?]
Map Fields in: "DigiCam Pictures”
=[Image
=+ Download Path
=+ Width m
= Height
=+ Bit Depth
=+ DPI
=+ Date Time Original
=+ Shutter Speed
=+ Aperture
=150
@ | Exposure Time
| FNumber
=+ Exposure Bias
=+ Subject Distance

E Scan Data Record 1 of 3

Import Action

® Add new records
(@] Replace data in current found set

——
Define Fields..

— Map Legend

= Import data

e Don't import

) Update matching records in current found set

Add remaining records

4+ Match fields

Cancel fﬂnpana

It's easy to import photos and EXIF annotation
data from your digital camera (Mac 0S X)

In addition to the photos, FileMaker Pro can also import
Exchangeable Image File (EXIF) annotation data if your digital
camera providesit. EXIF annotations typically include the date and
time the photo was created, aperture, shutter speed, and other
information about each photo. FileMaker Pro 6 includes new
templates that make use of the photo import feature. Y ou can use
these templates as is, or modify them to suit your needs.

Y ou can use the Import Records script step to create scripts that
import photos.

Import a folder of files in a single operation

FileMaker Pro 6 can import afolder of filesin a single operation.
Instead of having to insert several graphics or QuickTime files one
by one, you can now save time by importing them all at once. You
can also import afolder of text files, which is much faster and easier
than copying and pasting the contents of each file one at atime.



FileMaker Pro 6 can import any graphics file format that you can
insert with the Insert Picture and Insert QuickTime commands,
including GIF, JPEG, EPS, TIFF, and many other formats. Y ou can
import afolder of graphicsfilesinto container fields, and import a
folder of text filesinto text, number, date, or timefields.

FileMaker Pro creates one new record for each file in the imported
folder.

In addition to the file content, FileMaker Pro 6 also provides
additional information about each file that you can import into other
fields: the filename, the file path, and (for picture and QuickTime
files only) a smaller thumbnail image.

You can use FileMaker Pro 6 to import afolder of filesin al
supported operating systems: Windows, Mac OS X, and Mac OS 9.x
or earlier. Y ou can use this feature to import photos that you have
previously downloaded from a digital camera. However, when you
import afolder of graphicsfiles, you will not be able to import
Exchangeabl e Image File (EXIF) annotation datathat may be present
inthefiles. If you' reusing Mac OS X and you want to import photos
with EXIF annotations, make sure you import photos directly from
your digital camera or memory card reader.

Y ou can use the Import Records script step to create scripts that
import afolder of files.

Find and replace data

Asin aword processing application, you can now find and replace
data across multiplefields (including related fields) in arecord or in
afind request, acrossafound set of records or find requests, or across
text objectsin alayout. You can search for datain any type of field
except container fields. Although you can search for datain fields

that are viewable but not modifiable, you can’t replace datain them.
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Find/Replace 2]

Replace & Find
Replace
Replace All

Close

v

Find what [

Feplace with, |

Direction;  |Forward @

Search across: Search within
I~ Match case & 4l records Al fights
€' Current fisld

I~ Match whole words only € Cunent recard

Find and replace operations are scriptable and can be controlled
using access privileges.

Constrain and extend a found set

Y ou can now easily constrain (narrow) and extend (broaden) an
existing found set using the new Constrain Found Set and Extend
Found Set commands. Previously, some searches based on multiple
criteriarequired multiple find requests. With these two new menu
commands, it’s easier to manipulate afound set.

Constrain and extend operations are scriptable and can be controlled
using access privileges.

New and updated templates

The templates provided with FileMaker Pro have been updated in
appearance and functionality. Four templates are new.

See the Customizing Templates.pdf located in the Electronic
Documentation folder (inside the FileMaker Pro 6 folder) for
information on how to customize templates.
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Scripting improvements
Scripting improvements include:

* The new Show Custom Dialog script step lets you create a custom
dialog box that can accept data from a user and transfer it to the
specified field.

Specify Custom Dialog

Specify the input
P fV flelllds rGeneraI T Inp‘u(#l Y Input #2 Y Input #3 ]

— Dialog Title

O Field value | Specify

® Text Find a persan
— Dialog M
Specify the title
4 O Fi —T
messagetext,and (O Field value = Specify

® Text Please enter the first name, last
name, and city of the person you are
searching far.

button captions
for the custom
dialog box

— Button Captions

First (default): OK

Second: | Cancel

Third:

Cancel ( 0K ‘

Creating a custom dialog box

Find a person

Please enter the first name, last name, and city of the
person you are searching for.

First Name

Last Name

City

Cancel ' oK y

The finished custom dialog box

* The new Open Find/Replace and Perform Find/Repl ace script steps
allow you to perform a find/replace operation automatically.

® The Perform Find script step now has options for constraining and
extending afound set.

* The Import Records and Export Records script steps now provide
support for handling XML, photos, and multiple filesin asingle
operation.

* Default script steps are no longer added when a new script is
created.

Ease-of-use improvements

FileMaker Pro 6 provides a number of improvementsin response to
customer requests and feedback:

* The ahility to sort adatabase by right-clicking or Control-clicking
inafield.

* Moreresizable dialog boxes, for example, the Set Layout Order
dialog box. When you reposition or resize a dialog box,
FileMaker Pro remembers the location and size when you reopen
your file or re-launch the application.



* The Format Painter -&f givesyou the ability to select an objectin
Layout mode and copy its formats to other objects.

Web Companion improvements

The FileMaker Pro 6 Web Companion improves the security of your
web published files with a new, more secure Web folder structure.
When you use the new cdml_format_files folder (in the

FileMaker Pro 6 folder), browser clients are restricted from directly
viewing the source code and design of your web content files and
CDML format pages. Instead, these pages are returned to a browser
client only after being processed through the Web Companion.

For information on this and other recommended security practices,
see the Web Security.pdf located in the Web Security folder (inside
the FileMaker Pro 6 folder).

Mac 0S X improvements

Improvementsin FileMaker Pro in Mac OS X include:

* Mac OS X Services, such as sending atext selection to the
Mac OS X Mail application, are now supported from within
FileMaker Pro.

* ODBC import, ODBC export, and the Execute SQL script step are
now supported. (You must manually install the ODBC drivers after
the FileMaker Pro installation is complete.)

* The FileMaker Pro Open and Import commands now provide
support for filename extensions, such as .FP5 and .JPG.

¢ | ong filenames (up to 255 characters, including filename
extensions) are now supported.

* FileMaker Pro 6 requires Mac OS X version 10.1 and has been
developed for improved performance with it.
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Multiple-user installation improvements
(Windows)

For multiple-user installations on one computer, thereis now the
ability to set the network protocol and define a user name upon
launching FileMaker Pro for the first time by each user.

Windows XP support

FileMaker Pro 6 supports both the Professional and Home editions
of Windows XP and has earned the Designed for Windows XP logo,
which identifies products that work well with Windows XP.

If you're using FileMaker Pro under asite license and have multiple
userslogged into one computer, you can use Windows X P Fast User
Switching to quickly switch between user accounts without having

to quit FileMaker Pro.

Support for people with special needs

FileMaker Pro 6 documentation is provided in tagged Adobe
Portable Document Format (PDF). Tagged PDF files work with
assistive technology, such asthe JAWS for Windows screen reader.
For more information about tagged PDF files, see www.adobe.com.

Compatibility with FileMaker Server 5.5

FileMaker Pro 6 is compatible with FileMaker Server 5.5.
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Changes to keyboard shortcuts

Keyboard shortcuts for manipulating objectsin Layout mode have
changed in FileMaker Pro 6.

Command FileMaker Pro 5.5 FileMaker Pro 6
Ungroup objects Shift-36-G Shift-38-R
Lock an object 8-H (Mac OS 9) Option-88-L

Windows

Command FileMaker Pro 5.5 FileMaker Pro 6
Bring an object Ctrl-Shift-F Ctrl-Shift-[
forward

Bring an object tothe  Ctrl-Shift-Alt-F Ctrl-Alt-[

front

Send an object Citrl-Shift-J Ctrl-Shift-]
backward

Send an object tothe  Ctrl-Shift-Alt-J Ctrl-Alt-]

back

Group objects Ctrl-G Ctrl-R
Ungroup objects Ctrl-Shift-G Ctrl-Shift-R
Lock an object Ctrl-H Ctrl-Alt-L
Unlock an object Ctrl-Shift-H Ctrl-Alt-Shift-L
Rotate an object Ctrl-Shift-R Ctrl-Alt-R

Mac 0S

Command FileMaker Pro 5.5 FileMaker Pro 6
Bring an object Shift-88-F Shift-88-[
forward

Bring an object to the  Shift-Option-88-F Option-38-[
front

Send an object Shift-88-J Shift-86-]
backward

Send an object tothe  Shift-88-Option-J Option-88-]
back

Group objects 8-G 8-R

Option-88-H (Mac OS X)

Shift-8-H (Mac OS 9)
Shift-Option-38-H
(Mac OS X)

Option-88-R

Unlock an object Shift-Option-38-L

Rotate an object No change

Consistent conversion of dates with
two-digit years

FileMaker Pro 6 improves the input of dates with two-digit years,
such as“99” and “02.” FileMaker Pro 6 uses one consistent method
for converting two-digit yearsinto four-digit years. (FileMaker Pro
3.0 through 5.5 used different conversion methods depending on
how the dates were entered.)

FileMaker Pro 6 conversion method

FileMaker Pro 6 converts two-digit year dates asfollows: if the
current year is among the first ten years of the century (as in 2000-
2009), then FileMaker Pro converts two-digit yearsin the range 00-
89 to datesin the current century, and 90-99 to datesin the previous
century.

For example, if the current year is 2002, then FileMaker Pro
converts:

* 97 to 1997
* 05 to 2005
* 83 to 2083



In the future, when the current year is between 2010 and 2089,
FileMaker Pro 6 will convert two-digit years to datesin the current
century. For example, in 2010, FileMaker Pro 6 will convert 97 to
2097.

To improve the accuracy of date input, FileMaker recommends that
you alwaysenter datesin four-digit year form, and use the validation
option that displays an error message when a date entry contains a
two-digit year. For more information about year 2000 issues, seethe
“Y ear 2000 Readiness Disclosure” document, available at
www.filemaker.com.

Previous conversion methods

In FileMaker Pro 3.0 through 5.5, the processing of dates with two-
digit years was different depending on how they were entered.

Two-digit year dates entered or edited directly in afield converted
using one method, but the following types of two-digit year input
used a different conversion method:

e dates input or modified viaimporting, Apple events, ODBC,
JDBC, or the Web Companion

® dates input via drag-and-drop or script commands to a non-active
field

* datesinput as part of acalculation expression in the Specify
Calculation dialog box

* dates entered for the Auto-Enter Data option in the Define Fields/
Options diaog box

* dates entered for the Vaidation In range option in the Define
Fields/Options dial og box

* dates entered as literal valuesin calculation expressions or scripts

If you need details on how FileMaker Pro 3.0 through 5.5 converted
datesin each of these situations, seethe “Y ear 2000 Readiness
Disclosure” document, available at www.filemaker.com.
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New features in FileMaker Pro 5.5

Thefollowing featureswere added in FileMaker Pro 5.5 and are also
availablein FileMaker Pro 6:

* support for Windows 2000 Professional and Mac OS X

* many ease-of-use improvements, for example, being ableto resize
the Specify Calculation diaog box

* the ability to secure individual records through FileMaker Pro 5.5
access privileges, including record-by-record security for databases
published on the Web

® many new script steps and functions, for example, an Execute SQL
script step

¢ extended ODBC and SQL functionality, such as the ability to
execute SQL statements from afield value

* improved functionality, for example, importing named ranges of
Microsoft Excel data

* more power in publishing data on the Web, for example, support
for more script stepsin Instant Web Publishing

Important See FileMaker Pro Help for complete details on new
featuresin FileMaker Pro 5.5.

Hands-on, task-oriented tutorial

To get new users up to speed more quickly, FileMaker Pro features
an extensive hands-on tutorial. Tutorial lessons guide you through
common database tasks, including finding records, creating
databases, calculations, scripts, and reports, and defining

rel ationships. See the next chapter for the first lesson in the tutorial.
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Lesson 1
FileMaker Pro basics

Welcome to the FileMaker® Pro tutorial. This tutorial shows you
how you can manage your information in FileMaker Pro.

Y ou will learn how to use FileMaker Pro software to:
* |ocate and sort information

* create and enter records in asimple database

* create mailing labels

* create calculations, buttons, and scripts

® create and run reports

* usetherelational capabilities of FileMaker Pro

It takes approximately four hoursto completethistutorial, which can
be done in one session or several shorter sessions.

How to use this tutorial

These lessons are based on the membership database of afictitious
travel firm, The Corporate Travelers Club. Corporate travelers who
aremembers of thisclub savetheir businesses money ontravel costs,
and the club’ s expenses are offset by an annual membership fee.
FileMaker Pro is used to track the members' names, addresses, and
membership status, as well as to generate labels and form lettersto
contact members.

It's best to complete these |essons sequentialy, as the concepts
introduced in early lessons are assumed to be understood in later
lessons. However, because the lessons are self-contained, it's
possibleto skip lessons entirely, or to complete them later if desired.

Thistutorial assumes that you are familiar with your computer’s
operating system. Opening files, locating fol ders, and other activities
that require some knowledge of your computer’s OS are a necessary
part of completing this tutorial.

Note All personsand companieslisted in the samplefilesare purely
fictitious, and any resemblance to existing persons and companiesis
purely coincidental.

Filesincluded with thistutoria areintended to illustrate the features
of FileMaker Pro, and as such, might be unsuitable for use as
templates for further development.

We begin with a demonstration

To show you the goal of each lesson up front, we guide you through
asamplefilethat illustrates afeature or concept. Thisway, you will
aways know alesson’s objectives.

We explain how it works

Aswe introduce new techniques and concepts, we will explain how
to use them in other situations.

You build the structures

Because using FileMaker Pro is the most effective way to learn the
application, each lesson features a hands-on activity designed to
guide you through menus, screens, and concepts step by step.

Where to find the lesson files on your hard drive

Thefiles used in thistutoria areinstalled as part of atypical
FileMaker Pro installation set.
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The samplefilesillustrate the concepts explained in the lessons, and
let you see how features work before you build them. Refer back to
the sample file associated with each lesson if you need to. The
tutorial sample filesfor lessons 2 through 9 areinstalled in
FileMaker Pro\Tutorial\Sampl e Files. The samplefilesfor lesson 10,
which explains relational databases, areinstalled in

FileMaker Pro\Tutorial\Sample Files\Sample10.

The working files mimic the sample files, except the features being
taught in particular lessons have been removed. Y ou will add these
missing items and structures as you complete each lesson. The
working files for lessons 5 through 9 are installed in

FileMaker Pro\Tutorial\Working Files. The working filesfor lesson
10 areinstalled in FileMaker Pro\Tutorial\Working
Files\MyFiles10.

Overview of the FileMaker Pro Tutorial folder structure

N

FileMaker Pro

2

Tutorial
Sample Files Working Files
I
Sample02.fpb MyFile05.fp5
Sample03.fp5 MyFile06.fp5
Sample04.fp5 MyFile07.fp5
Sample05.fpb MyFile08.fp5
Sample06.fp5 MyFile09.fp5
Sample07.fp5 MyFiles10 folder
Sample08.fph MyCompanies10.fp5
Sample09.fp5 MyMembers10.fp5
Sample 10 folder
Companies10.fp5

Members10.fp5

If you need to start over

If you make a mistake or need to start over, you can reinstall the
tutorial files without having to reinstall the entire FileMaker Pro
application. For Windows-based systems, see the Custom setup
instructionsin “Installing FileMaker Pro” on page 11. For Mac OS
systems, see “Installing FileMaker Pro” on page 15.

Database concepts

What is a database?

A database is amethod of organizing and analyzing information.

Y ou’ ve probably used several databasesrecently without realizing it.
A date book, a partslist, and even your own address book are
databases.

Why use a database?

Storing information in adatabase file has many benefits. A database
doesn’t just hold information—it hel psyou organize and analyze the
information in different ways. For example, databases allow you to
group information for reports, sort information for mailing labels,
count your inventory, or find a particular invoice.

Computerized databases offer many additional advantagesover their
paper-based counterparts: speed, reliability, precision, and the ability
to automate many repetitive tasks.

How is a database organized?

A databasefileisorganized into records. Each record isacollection
of fields.

Imagine your address book is a FileMaker Pro database file. Each
listing in your address book is one record. Each record has
information, such as name, address, and phone number. Each of
these pieces of information—name, address, and phone number—is
stored in a separate field.



FileMaker Pro basics

Unlike most word processing or spreadsheet programs, FileMaker
Pro saves your work automatically. Consequently, it's important to
carefully consider your actions when making sweeping changes to
your files, especially when deleting records. Once records are
deleted, they are completely removed from your database.

Asyou will learnin lesson 11, you should back up your fileson a
regular basis. Backups can save you many hours of unnecessary
work and worry in the event that your files become lost or damaged,
or records are inadvertently deleted.

About FileMaker Pro modes

When you work in FileMaker Pro, you work in one of four modes.
® Use Browse mode to enter data and view records.

* Use Find mode to locate arecord or a group of records quickly.

* Use Layout mode to specify how information will appear on the
screen or when you print it.

* Use Preview mode to see what the pages will look like when you
print them.

Once you have opened a database, you can switch from one mode to
another using either the View menu or the mode pop-up menu at the
bottom of the application window. Y ou can also quickly determine
which modeyour FileMaker Pro databaseisusing by referring tothis
pop-up Menu.
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Filename

Sample02.ip5

5]
Name of layout —}{fzem =

The Cormporate Travelers Club

Number of the
current record oo

First Hame  Mary
Last Hame  Smith
Home Address1 123 EIm 5t

City  MNew Tork
Country UsaA
e i —
Menbership Type () MNew @ Continuing
Fee Paid  $100.00
Date Paid 12/12/1999
Renewal Fee 100

— Fields

Browse mode

]
100 | Browse [4]

For more information
For moreinformation on FileMaker Pro basic concepts, seechapter 1
of the FileMaker Pro User’s Guide.

Y ou can also find specific information about the procedures and

concepts introduced in the following chapters in the FileMaker Pro
Help.

To access FileMaker Pro Help:

Choose Help menu > FileMaker Pro Help.

To see an overview of the FileMaker Pro Help topics:

Choose Help menu > Contents and Index.
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Lesson 2
Browsing information

Y ouview, enter, or changedatain Browse mode. Thisisthesimplest
way to interact with your database.

In thislesson you will:
* open a database with data already in it
* move between records

¢ view information in different ways by switching layouts

* see the difference between formview, list view, and table view

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Open a database and move
between records

To open the sample database for this lesson:

1. Open the Tutoria Folder in the FileMaker Pro folder.
2. Open the Sample Filesfolder.

Y ou should be here: FileMaker Pro\Tutorial\Sample Files.
3. Open Sample02.fp5.

4. Notice that the database isin Browse mode. FileMaker Pro
defaults to Browse mode when a database is opened.

« ——— The mode pop-up
Preview menu identifies the
(ool Erovee [T cyrrent mode

In the status area, notice that there are 30 records and that the first
record is displayed.

Bookmark —
Bookicon —E-‘

R
Number of —p==__ |
records T

The Corporate Travelers Club

Member Humber 1

First Name  Mary
Status area —— Last wane  Smith
Home Address 1 123 Elm St

Record currently displayed

5. Click the bottom page of the book icon to move forward one
record at atime, and click the top page to move back onerecord at a
time.

6. Move between records by dragging the bookmark up or down.

Y ou can a so typearecord number in the areaimmediately bel ow the
book icon to change the current record displayed.

View information in different ways

Even though you enter information only oncein FileMaker Pro, you
can use that information in many ways. Layouts let you view some
or al of your fields.

Becauseit is not necessary to see all of your fieldsin each layout,
layouts are a powerful tool for working with or printing just the
information you need to accomplish a particular task.
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L] []
Toaves
Steve Williams
Evenn
789 Ninth Avenue oL
New York, NY 10001
Dear Sophe,
Thank you for reserving acruise with us. We
value your business and appreciate the
Erenriane Phone List PpOItUNity to serve you.
Toaves
JenitaAlvarez s55.103 If you have any questions about your
Michalle Canmon gy reservations, please call us—we want you to
Andre Common 555-1234 be satisfied with your cruise.
Marie Durand 555-1234 ncerel
Jean Durand 5551234 Sincerely,
William Johnson 555-1234 John Lee
John Lee 555-1234
Patrick Murphy 555-1234
LeNguyen 555-1234
Kentaro Ogawa 555-1234
Mary Smith 555-1234
John Smith 555-1234
Sophie Tang 555-1234
Steve Williams 555-1234
Betty Wilson 555-1234

The same data can be arranged differently with multiple layouts

See a different layout

To see some layoutsin action, use the Sample02.fp5 samplefileyou
just opened.

1. Click on the layout pop-up menu, located above the book icon. A
list appears showing the layouts available in thisfile.

Layout pop-up menu

—Layout #1
Layout *2
]
-J List of Members
N Labels
Welsome Letter
IMembership Type Report
Member ship Fee Report

Records

2. Examine Layout #1. Layout #1 shows all of the fieldsin the
Sample02.fp5 database.

I=————Sampel2ipfi=—"——r————
[Layout =1

Tily | m

The Corporale Travelers Club

Records
30

Found: Member Number 1
= First Hame  Mary
Eante LastHame  Smith
Home Address 1 123 Elm St
Home Address 2
City  Mew Tork
Country US4
Company [DEF i ]
Membership Type (3 Mevw @ Continuing
Fee Paid  §100.00
Date Paid  12/12/1939
Renewal Fee 1010

100 EC|_Browse 4] D

SEl

Layout #1 displays all of the fields in the Sample02.fp5 database

3. Goto thelayout pop-up menu and choose the List of Members layoLt.

Thislayout shows each record as one row in a columnar list. Notice
that the List of Members layout contains only four of the fields that
were present in Layout #1. No data has been removed from the
database. Because fewer fields are present on this layout, some data
issimply not displayed.



O=———————sample02fp5 2] =]
[List of Me__|| =
= 5
M Last Name First Name Company, Membership Type
g Smith hary DEF Lkd Continuing
Records Common Andre ABC Company  Continuing
Williarns Steve ABC Company  Mew
F”D“"d Ogawa Kentare ABC Company  Centinuing
Sorted Durand Marie DEF Lkd Continuing
Cannon Michelle HTZ Inc Continuing
Srnith John HYZ Ine. Hew
Murphy Pafrick HTZ Inc Mew
Durand Jean HYZ Ine. Hew
Mguyen Le DEF Ltd Mew
Lee John HYZ Ine. Hew
Tang Sophie DEF Ltd Continuing
Alvarez Juanita DEF Lkd Continuing
ilzon Battw Y7 In b o
100 | Browse 4] D2

The List of Members layout displays only four of the fields present on Layout #1

4. Go to the layout pop-up menu and return to Layout #1. No data
has been lost.

View your layouts as forms, lists, and tables

Y ou canview your layoutsinthreedifferent ways. asaform, asalist,
and asatable.

* Form View displays your current layout one record at atime.

* List View shows your current layout as alist, with one record
appearing beneath another.

® Table View shows you many records at onetimein agrid.

Generally, layouts can be toggled between form view, list view, and
table view while the database is in Browse mode.
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=——— @mH
e t Hame Fist ame Company. Menbership Type.
| s iy R —
Reooras
»
Fnd
=
Sorted
Lastane Fist ame Company. Menbership Type.
Smith Mary DEF Ltd Gontinuing
Gormmon Andre ABC Company  Continuing
Wilars Steve ABC Company  New
& Ogawa, REdne————oe|
ot Durand Marie | [Ferorve || LastNarme Frsthame Company | Merbershp Type
00 [l Erovee < carrion Michelle = [ St Mary DEF Lid [Contnung |
(£ | |[witems Steve ABC Company | New
Murphy Palrick Ogawa Kentaro ABC Cormpany Continuing
Duand dean || || Durand Marie [ [Continuing |
Nauen e 5 Gannon Michelle X Gontinuing
b I | el L Jofin X
e jonn | Founa
Muphy Patick X
= [ty
Durand Jean X
P [ T K| Sorted || Nouyen Le DI
Leo Jofin X
n Sophie O nlinuing
Alvarez Juanta il Gontinuing
Wison tty X New
Johnson Willarn ] Continuing
Vargas Julla X Gontinuing
hehmet Afimet X Gontinuing
Verhaag Annelies OF Gontinuing Ll
onzen lens anfinuing S
(oo ] rovwse <1 Z

Switch between form view, list view, and table view in the same
layout to see how they are different.

1. In Sample02.fp5, switch to the List of Members layout. Y ou see
many records, in the form of alist.
2. Choose View menu > View as Form.

Y ou now see asingle record, displayed in the same layout. Only the
viewing option has changed.

3. Choose View menu > View as Table.

The View as Tablefeature allows you to view many records at once
inagrid.

4. Choose View menu > View as List to return to the origina view of
the List of Members layout.
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Sample02.fp5 =13
ot = First Narme Last Harne Horrie Ackress 1 Horme Ackress 2 City =
Mary Srnith 123 Elrn 5t. MNew York
Ardre Comrren 147 White Avenue Los Angeles
Steve Williarms T&I Ninth Avenue MNew York
Kertars Crpwa 2236 Imachi Setaaya Tokyo
Records: Marie Durand 1 rue de la Poste Paris
30 Michelle Canron 123 4th 5t SW Edronten
John Sirith 41 Mary St Sytiney
Unsorted Patrick MWurphy &9 Laverwerth Place | Castleknock Dublin
Jean Durand 1001 place du Monde Montreal
Le Nouyen 123 placede la Paris
John Lee 123 5t. Johns Circle Londen
Sophie Targ 126, Despwater Bay Kowleon
Juanitz. Alvarezr 147 Houston Avenue MNew York
Betty Wilson 455 Fifth Avenue MNew York
Williarm Johnson H62 Marsh Road Londen
Juliz Vargas Avenicla Sevilla 87 tadrict
Ahrnet Mehrmet Bahar Cacidesi 5015 | Etiler Istznbul
Arnneliss Verhaag Blauwburgstraat 33 Arnsterdarn
Jens Jensen Breckade 127 Copentagen
Juan Garcia Calle Real Marzara | Colonia Acguirners Mexice Df
Gerand LeFranc Chez Pierre 455 Fue Eiffel Paris
Juttz Sehrnict Grosse Elbestrasse Harnburg
Swven Svensson Klarnrmendarnmscatan Steckhelm
Watti Virtanen Watintie 2 Helsinki -
100] ufudl 5| Browse <[] | D

5. When you are finished with thislesson, close the file by choosing
File menu > Close.

For more information

Y ou have opened a database, browsed through records, switched
layouts, and learned the differences between form view, list view,
and table view. For more about browsing information in
FileMaker Pro, see chapter 2 of the FileMaker Pro User’s Guide.



Lesson 3
Finding and sorting records

Y our database isacollection of records. Sometimesyou' || work with all
of the recordsin the database (to mail out an annua catalog for each
customer record in the database, for example). Often, however, you'll
work with asubset of your database—people who comefrom aparticular
city, for example, or recordsthat fal within a particular range of dates.

In FileMaker Pro, this process of searching for records that match
particular criteriais called finding records. Once you’ ve found the
records you want to work with, you can changetheir order by sorting
them. Records can be sorted in ascending or descending order.

In thislesson, you will:
¢ find records matching criteriain asingle field and multiple fields
¢ find records matching arange of data

* narrow your searches by omitting records

* sort records in ascending and descending order

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Find records based on criteria in a single field

In the membership database, find all of the members that are from
New York City.

1. Open the Tutorid folder in the FileMaker Pro folder.

2. Open the Sample Filesfolder.

Y ou should be here: FileMaker Pro\Tutorial\Sample Files.
3. Open Sample03.fp5.

4. Choose View menu > Find Mode.

In Find mode, you create afind request using thefieldsin the layout
you see. Type the criteria you want to search for directly into the
fields on the request.

5. Type New York in the City field.
6. Click the Find button in the status area.

O=————samplelifps—"r—————[ 5
Layout *1 I .
The Corporate Travelers Club ¢ %‘
1
Requests:
1
Dlomit Menber Nunber
First Name
L Last Mame
Fmd A Home Address 1
buttOn Home Address 2
City
Country
Company |
Membership Type ) New (O Continuing
Fee Paid
Date Paid
Renewal Fee |
100 | Find [4] D2

Y our find request returns records for four memberswho livein New
York. Thisis the found set.

Layout *1 I
el
=
Total number of records in the database ——% "
Number of records in the found set ——+"™"

7. Click the book iconto view each of thefour recordsin the found set.
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Find records based on criteria
in separate fields

Y ou can find records that match multiple criteria, for example

memberswho are both from the United States and are new members.

This type of search is commonly referred to as an AND search. To
perform an AND search in FileMaker Pro, type each search criterion
directly into the appropriate field in Find mode.

To find all memberswho live in the United States and are new
members:

1. Choose View menu > Find Mode.
2. Type USA inthe Country field.

3. Locate the Membership Type field, and select the New radio
button.

Select the New radio button
in the Membership Type field

Memnbership Type |@ Mewe (O Continuing

4. Click Find in the status area.

Y our find request returns afound set of two recordsfor the two new
members who live in the United States.

5. Tofind al of therecordsin your database, choose Records menu >
Show All Records.

Note It isnot necessary to choose Show All Records before
performing aFind, as FileMaker Pro always finds records from the
entire database.

Find records that match multiple
criteria in the same field

Sometimes you need to find records that match more than one
criterion in asingle field. For example, you may need to find all
memberslocated in either New Y ork or London. Thistype of search
iscommonly referred to asan OR sear ch, because your found set will
consist of records that match any one of the find criteria.

To perform an OR search in FileMaker Pro, you will need to use
multiple find requests.

* Typethefirst search criterion into the appropriate field of the first
find request.

* Create a second find request and enter the second search criterion
in the samefield.

Whenyou click the Find button, FileM aker Prowill retrieveall of the
records that match any of the criteriayou’ ve entered.

Tofind al membersliving in New Y ork or London:

1. Choose View menu > Find Mode.

2. Type New York inthe City field.

3. Choose Requests menu > Add New Request.

Notice that the status area shows that there are two requests.

Number of requests —=

4. Type London inthe City field of this second request.
5. Click Find in the status area.

Y our find request returns afound set of six records for six members
who live in either New Y ork or London.



Find records that match a range
of criteria in the same field

Sometimes, you might want to find records that match a range of
criteriawithin asinglefield. For example, you might want to find al
of the recordsthat fall within aone-month period, or locate al of the
sales invoices numbered between 500 and 1000.

To perform this type of search in FileMaker Pro, you use a specid
range symbol in your find request to specify the lower and upper
limits of your find criteria.

To find the members who paid their membership fees between
January 1, 2000 and June 30, 2000:

1. Choose View menu > Find Mode.

2. Type 1/ 1/ 2000 inthe Date Paid field.

3. Inthe status area, click the Symbols pop-up menu. Select range
from the list.

The Compon

Symbols pop-up menu

I P [ I Kl

4. Your find request should now have 1/ 1/ 2000. .. inthe Date
Paid field. Immediately after the ellipsis(...), type 6/ 30/ 2000.
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Fee Paid
Date Paid

Renewal Fee

5. Click Find.

Y our search returns six records, for six memberswho paid their fees
within the first six months of the year 2000.

Narrow your search

Sometimes, you might need to find recordsthat match certain criteria
while at the same time excluding others (for example, finding all of
therecords that were added in agiven year except for those added in
February, or finding al customers who residein New Y ork state
except for thosein New Y ork City). Y ou can perform these types of
finds by using a combination of multiple find requests and omitting
certain records.

Because FileMaker Pro processes multiple find requestsin the order
they are created, it is possible to create very specific, layered
searchesin this manner. Omitting recordsin a search does not delete
them from the database.

To find the records of members who paid their feesin the first six
months of 2000, except for those who paid their feesin February:

1. Choose View menu > Find Mode.
2. Type 1/ 1/ 2000 inthe Date Paid field.

3. Inthe status area, click the Symbols pop-up menu. Select range
from the list.

4. After the ellipsis, type 6/ 30/ 2000.

5. Choose Requests menu > Add New Request. Notice that the status
area shows that thisis the second request.

6. Type 2/ 1/ 2000 inthe Date Paid field.
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7. Inthe status area, click the Symbol s pop-up menu and select range
from the list.

8. After the ellipsis, type 2/ 29/ 2000 in the Date Paid field.
9. Click Omit in the status area to select it.

[Layout 1
i
Omit checkbox FEomit
symbols =]
10. Click Find.

Y our search returnsfive records for five memberswho paid their fees
within the first six months of 2000, except the month of February.

Sort your found set

Once you have afound set of records to work with, you might want
to sort those records. For example, you might want to display the
recordsin alphabetical order, or sort them from newest to oldest.

To sort records in aphabetical order by the members’ last names:

1. Go to the layout pop-up menu and choose the List of Members

layout. Thislayout will makeit easier to seethe results of the sorting.

2. Choose Records menu > Sort.

3. If any fields appear in the Sort Order column on the right side of
the dialog box, click Clear All.

4. Inthelist of available fields, select Last Name and click Move.

Sort Records

Sort Order

j Clear All
Clear
Sort
Unsort
st Pal
Memnbership Type |
Mernbership Revenus Done -

4

[ include summary fields

Sort direction

al @ ascend &
buttons become —;‘ b O b
active when a i Qo sed on vaks lst
field is selected [ Override fizld's languags for sort

Notice the sort direction symbol to the right of the Last Name field
increases in size from left to right. Thisindicates that when the
database is sorted by thisfield, the datawill be in ascending order
(from ato z).

5. Click Sort.

The namesin the List of Members are now in alphabetical order by
last name.

6. When you are finished with this lesson, close each open file by
choosing File menu > Close.

For more information

Y ou have found records based on avariety of criteria, and narrowed
your searches by using Omit. Y ou have sorted the results of your
searches. For more information on finding and sorting recordsin
FileMaker Pro, see chapter 3 of the FileMaker Pro User’s Guide.



Lesson 4
Creating a database and entering records

In the previous lessons, you saw how to use a simple database with
existing data. Now you will create your own file and add records.

In thislesson you will:

* create a simple database

¢ definefieldsto hold different kinds of data
* create records

* enter data

* modify data

If you are not familiar with database basics, you should do the first
two lessons in this tutorial before continuing.

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Create a simple database and define fields

Look at the sample file

The samplefileisthe model for thefile you'll create. It shows you
how fields are defined and that different field types hold different
types of data.

1. Open the Tutorial folder in the FileMaker Pro folder.

2. Open the Sample Filesfolder.

Y ou should be here: FileMaker Pro\Tutorial\Sample Files.
3. Open Sample04.fp>5.

4. Choose File menu > Define Fields.

Y ou see the Define Fields dialog box showing all of thefieldsin the
database.

Define Fields for “Sample04.fp5”
4 field(s) Wiew by [ custom order

|

Field Name [ Type | options:
+ Last Name Text

# First Hame Text

* Fee Paid Nunber

# Date Faid Date

4] ID

field Name | |
Type

& Text #T () Container %0 {&] [_outions... |
(J Number ®N (3 Calculation 3L m m
ST STl S e £ [_save |
O Time ®1 () Global G Delete Done

)

5. Noticethat the First Name and Last Name fields are of type Text, Fee
Paid is of type Number, and Date Paid is of type Date.

6. Click Done.
7. Notice that the datain each field corresponds to the field type.

Y ou will learn how to add text and graphics, like thetitle and logo,
inlesson 5.

About field definitions

You create afield for each category of information you want, such
as First Name or City. To find, sort, calculate, and display data
correctly, the field type should match the kind of datait contains
(text, number, date, and so on). For example, you can’t search for
text valuesin afield of type Number.

You will learn about other field typesin |ater lessons.
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Create a database
1. Choose File menu > New Database.

2. If you see the New Database dialog box, choose Create a new
empty file, then click OK. If not, go to step 3.

3. Goto the Working Filesfolder and select it asthelocation for this
file.

4. For File Name, type M/Fi | e04.
5. Click Save.

The Define Fields dialog box appears. Y ou will now create fieldsto
store information.

6. To create thefirst field, type F rst Nane in the Field Name box.

7. Notice that the field typeis Text.

Define Fields for “MyFileD4_fp5™

0 field(s) Wiew by | creation order B

Fikd Name [ Tupe [ Gptions |

Name a field

Field Names |ﬁ.sl Wamd

[ Typ
S fy th & Text " Containgr \_IE[eale —IDE“DMS
peci € —— € Humber " Calculation c Duplicat
feldtype | Cooe  Cmm | — | 0|
© Time © Blobal et | pone ! y
7

8. Click Create.
9. Type Last Nane in the Field Name box.
10. Click Create.

11. Type Fee Pai d in the Field Name box, select Numberin the
Type area, then click Create.

12. Type Date Pai d intheField Name box, select Date in the Type
area, then click Create.

Y our defined fields should match those in the samplefile.
13. Click Done.

Y ou seethe empty fieldsin anew, blank record. Field labelsidentify
thefields. Your fileisready for dataentry.

First Name {— Enter data here
. Last Name
Field labels —{ Fee Paid

Date Paid

FileMaker Pro automatically saves your changes as you work.

Enter data into the database

Now you can begin to enter members' data.

Create the first record

1. If you don’t see field boxes, press Tab to begin data entry.
2. Type Jane in thethe First Name field.

3. Press Tab to move to the next field.

4. Type Doe inthe Last Name field.

5. Type 25 in Fee Paid.

Y ou will learn how to format number fieldsto display ascurrency in
the next lesson.

6. Type 11/ 11/ 2000 in Date Paid.
The completed record should look like this:

First Name ilane

Last Name [0
Fee Paid 25

Date Paid [11/11/2000



Create another record
1. Choose Records menu > New Record.

2. Asyoudidfor Jane Do€' srecord, enter datafor John St h, who
paid 75 dollarson 2/ 2/ 2000.

Y our database now contains two records. Click the book icon to see
each record.

Modify data in a record

Suppose you redlize that Jane Doe paid 75 dollars, not 25. Y ou can
easily correct the entry.

1. Go to Jane Do€' s record.
2. Select the amount in Fee Paid.

First Mame  iJane

Last Mame [l0E
Fee Paid

Date Paid ]

3. Type the new amount, 75.
4. Click an empty area outside afield to save the change.

5. When you are finished with this lesson, close each open file by
choosing File menu > Close.

For more information

Y ou have created a simple database and defined fields, and added
and modified records. For more information, see chapter 5 in the
FileMaker Pro User’s Guide. Y ou can also use or build on the
database template files included with FileMaker Pro; see chapter 5.
For moreinformation on entering datain different field types and by
different methods, including import, see lesson 7 in this tutorial and
chapters 2 and 12 in the FileMaker Pro User’s Guide.
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Lesson 5
Customizing what you see

Y ou can enhance the way your data looks by adding graphics and
other effects.

In thislesson, you will:

® |earn how layouts determine what you see

* add, resize, and move fields

e display valuesin anumber field as currency

* add text to alayout, and change its size and color

* add graphics

¢ see where to find other ways you can customize alayout

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Customize your view in Layout mode

Look at the sample layouts

1. Open the Tutorial folder in the FileMaker Pro folder.

2. Open the Sample Filesfolder.

Y ou should be here: FileMaker Pro\Tutorial\Sample Files.
3. Open Sample05.fp>5.

4. Choose Layout#1 from the layout pop-up menuiif it is not already
selected.

Layout pop-up menu

Records:
6

Sorted

Y ou see asimple layout.

5. Choose Layout #2 from the layout pop-up menu.
6. Notice that although this is the same record, now:
* First Name and Last Name are side by side

* you see the City field

* Fee Paid shows adollar sign

* the club’s name and logo are at the top of the screen

The Corporale Travelers Club

First Name Last Name
Mary Smith
city  Mew Tork
Country  USA
Fee Paid  $100.00

Y ou will make the above changesin this lesson.
7. Choose View menu > Layout Mode.

Use Layout mode to customize the appearance of your data. Notice
that although the datais still in the file, you do not see it here.
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About customizing layouts

Design layoutsin Layout mode. Y ou can include any combination of
fields, text, and graphics on alayout. Y ou can change the font and
color of fields and text. Y ou can aso change the formatting of
Number or Date fields.

Changesyou makein Layout mode affect only the way data appears.
The dataitself remains asit was entered.

L eave the sample file open to refer to as you build these featuresin
the working file.

Customize a layout

Youwill changeasimplelayout inthislesson’ sworking fileto make
it look like Layout #2 in the sample file.

1. Open the Tutorial folder in the FileMaker Pro folder.

2. Open the Working Files folder.

Y ou should be here: FileMaker Pro\Tutorial\Working Files.
3. Open MyFile05.fp5.

4. Choose View menu > Layout Mode.

You seeaplainlayout. Youwill modify thislayout in different ways
in the following sections.

Resize, move, and add a field

Select and resize a field
1. In Layout mode, click the First Name field to select it.

— Hand|
7 andle

First Narne [ElrsI.Mama %

2. Drag the handle at the lower-right corner of the field to the left
until thefield issmaller, yet large enough to display the longest first
name you expect in your file.

3. Choose View menu > Browse Mode to see your field.
4. Flip through the records.

If the field doesn’t display all names completely, return to Layout
mode and make the field larger.

5. Repeat this process for Last Name.

Move a field
1. Choose View menu > Layout Mode.

2. Click inside the Last Name field and drag it beside the First Name
field.

First Mame  [First

Last Marne
Country  [Cauntn
Fee Paid |FeaPaid .

3. Drag the Last Name field |abel above the Last Name field.
4. Drag the First Name field label above the First Name field.
5. Choose View menu > Browse Mode to see your results.

Add a field

If afield hasbeen defined in Define Fields, you can display it on any
layout. In this database, some defined fields are not on this layout.
Y ou will add one of these fields now.

1. Choose View menu > Layout Mode.

2. UsingtheField tool, drag thefield to thelayout, and placeit below
the First Name field.



IAI N IE
OIS e First Hame Last Hame
H s A Drag the
Field —{E=e—2]| 2 ¥ new field
tool ] Country [Couniry ]

e ] o] Fee Paid |C&e Paid....|

3. In the Specify Field dialog box, select the City field.
4. Click OK.
5. Choose View menu > Browse Mode to see your field.

Y ou see acity entered in each record. City data was entered
previously, and the field holds the data.

Display a number as currency

Y ou can display anumber as currency, even though only the number
istyped into thefield.

1. Choose Window menu > Sample05.fp5.
2. Choose View menu > Browse Mode.

3. InLayout #2, look at Fee Paid and notice that the number displays
as currency.

4. Click the number to see the data actually entered in the field.

Formatting affects only the way datais displayed. It does not change
the data.

5. Choose Window menu > MyFile05.fp5.
6. Choose View menu > Layout Mode.
7. Select the Fee Paid field.

8. Choose Format menu > Number.

9. Select options as shown in the following dialog box.
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Number Format for "Fee Paid" HE

© General fomat
© Leave data formatted as entered
€ Fomat a3 Boolean

Stovnunzeices av |Yes Showzeies e [No

&' Format as decimal
IV Fized number of decimal digits:  [2

I Use potation: | Currency [leading) ~|  Cumency symbol: 4

I~ Da ot display number if zero

r Megati

Decimal separator: Format as: | 1234 -
™ Use thousands separatar: | ™ Use color. 8- [

- Sample

654390 [ s |
[k | concal |

10. Click OK.

11. Choose View menu > Browse Mode to see the formatted data.

Add custom text to a layout

Y ou will add the name of the organization to the top of the layout,
then format the text.

Add text
1. Choose Window menu > Sample05.fp5.

2. Choose View menu > Layout Mode and look at the heading at the
top of the layout.

Thisisyour model.

3. Open MyFile05.fp5 if it is not already open.
4. Choose View menu > Layout Mode.

5. Select the text tool.
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Lapout #H = 0] L1111

Text tool —

Body

b
) K N
4 N N R R

6. Click thetop of thelayout where you want to begin the line of text.
7. Type The Qorporate Travel ers d ub.
8. Click the selection tool k| to end the text entry.

Change text size and color

1. Click the Qorporate Travel ers A ub text to select the text
block.

“The Corporate Travelers Clul,

2. Choose Format menu > Text.

3. Choose 18 point from the Size list.
4. For Color, choose any dark blue.
5. Click OK.

Add a graphic to the layout
Add alogo beside the club name.
1. Choose Window menu > Sample05.fp5.

2. In Layout #2, choose View menu > Layout Mode and notice where
the logo appears on the layout.

3. Open MyFile05.fp5 if it is not aready open.

4. Choose View menu > Layout Mode.

5. Click beside the Gorporate Travel ers A ub text, where you
want to place the club logo.

Y ou will see no change onscreen yet.

6. Choose Insert menu > Picture.

7. Open the Working Files folder.

8. Make sure dl file types are showing, and select logo.gif.

9. Click Open.

10. Drag the logo to move it if necessary.

11. Choose View menu > Browse Mode to see the finished layout.

12. When you are finished with this |esson, close each open file by
choosing File menu > Close.

For more information

Y ou have learned how to enhance the appearance of your data by
using graphics, custom text, field formatting, and creative
positioning of objects on layouts. There are many other ways to
customize the appearance of fields and layouts.

For example, after you' ve created alayout, you can:

* add effects like embossing or patterns to objects

* use lines or boxes to highlight or separate information
* add scroll barsto individual fields

* change background or field color

When you create anew layout, you can apply color and styleusing a
theme.

Chapters 6 and 7 in the FileMaker Pro User’s Guide explain how to
add these enhancements and others. The database templates that
come with FileMaker Pro aso show ways to enhance layouts. See
chapter 5 for information about how to use the templates.



Lesson 6
Creating lists, mailing labels, and form letters

Y ou can easily create layouts to view and print information in many
different ways.

In thislesson, you will create:
* alist of your records
* mailing labels

e aform letter

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Create a columnar list

A columnar list shows many records simultaneously. Each row is
one record. Each column holds one category of data, such as Last
Name or Phone Number.

Look at the sample list

You can create alist of records that shows just the information you
want to see.

1. Open the Tutoria folder in the FileMaker Pro folder.

2. Open the Sample Filesfolder.

Y ou should be here: FileMaker Pro\Tutorial\Sampl e Files.
3. Open Sample06.fp>5.

4. Choose the List of Members layout from the layout pop-up menu.

Layout pop-up menu —{iterrien |

Y ou see a columnar list showing some of your fields.

Last MWarme Eirst Mame Company Membership Type
Smith Mary DEF Ltd. Continuing
Commaon Andre ABC Company Continuing
Williams Stave ABC Company e

Qgawa Kentara ABC Company Continuing
Durand Marie DEF Ltd. Continuing

About columnar list layouts

Choose View menu > Layout Mode to view the layout that produces
the columnar list you just looked at.

Each field on the layout appears once, but the list displays many
records.

Mernbership Type

Last Name First Name Company

Create a columnar list

1. Open the Tutoria folder in the FileMaker Pro folder.

2. Open the Working Filesfolder.

Y ou should be here: FileMaker Pro\Tutorial\Working Files.
3. Open MyFile06.fp5.

4. Choose View menu > Layout Mode.
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5. Choose Layouts menu > New Layout/Report.

6. For Layout Name, type Li st of Menbers.

7. Select Columnar list/report for the new layout type and click Next.
8. Select the Columnar list/report layout again, then click Next.

9. Double-click each of the following fieldsin the order you want it
to appear in the list:

® Last Name

® First Name

* Company

* Membership Type

These fields move to the Layout fields list.

Mew Layout/Report HEBE
Specify Fields
Specify the fields you wart on your lapout. Make sure the fislds are in the order you want them
10 appear on your layaut.
Auvailable fislds:
Curnent File [ "MyFileDs fpS"] - Layout fields:
Home Addiess 2 - 4+ First Name:

City

Country

Company

Fee Paid

Date Paid

Membership Type

Membership Revenue
o Fas

v + Last Mame
+ Company

Mowe All # Membership Type

Clear 4l

(|

< Back I Mext > I Cancel Help

10. Click Next.

11. Click Next on each of the next four panelsto accept the defaults.

12. Click Finish.
13. Choose View menu > Browse Mode.

Thedatain all records for the fields Last Name, First Name, Company,
and Membership Type appearsin the List of Members layout.

Create mailing labels

Look at the sample labels

1. Choose Window menu > Sample06.fp5.

2. Choose View menu > Browse Mode.

3. Select Labels in the layout pop-up menu.

Y ou see the mailing label for the current record.

4. Choose View menu > Preview Mode.

Y ou see a page of labels asit will print.

5. Notice that not all records have the same number of lines of text.

Recordswith four-lineaddresses display all lines. In records needing
only three lines, the extraline is omitted so thereis no blank linein
the labels.

6. Choose View menu > Layout Mode.

Y ou see the names of fields that will appear on the labels.

Body

Merge fields

About label layouts

Label layoutsuse mergefields. Mergefields expand or contract to fit
the datain the field, and take no spaceif the field is empty. Merge
fields are for display and printing only. You don’t enter datainto
merge fields.

Create a label layout

In this section, you will use the New Layout/Report assistant to:
* create alabel layout

¢ select fields to include on the labels



Create the label
. Choose Window menu > MyFile06.fp5.

. Choose View menu > Layout Mode.

. Choose Layouts menu > New Layout/Report.

. For Layout Name, type Label s.

. Select Labels for the new layout type.

. Click Next.

. Choose Avery 5160 from the Use label measurements for list.
. Click Next.

Now you're ready to specify the label contents.

W N O CG1 A W N =

Choose the fields that will appear on the labels
1. Double-click First Name in the list.

First Name moves to the Label Contents area. The insertion point
flashes.

New Layout/Report [ 7] =]
Specify Label Contents
Conrent File 'S amplelE (p5'] <] Build a labsl by selecting fields and adding them to the
label contents box, To add text, spaces, punctuation, or
First Name ] line retums typs them directly into the Iabel contents box
Last Name
Home Address 1
Home Address 2
City
Cauntry LI Add Freld Clear &1

Label Contents:

<<First Name> 3|

<Back [ Met> | Cancel Help

2. After First Name, type a space.
3. Double-click Last Name in the list.

4. After Last Name, press Enter (Windows) or Return (Mac OS).
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5. Double-click Home Address 1 in the list, then press Enter
(Windows) or Return (Mac OS).

6. Double-click Home Address 2in the list, then press Enter
(Windows) or Return (Mac OS).

7. Double-click City in the list.

8. Type a comma, then a space.

9. Double-click Country in the list.
Now you have set up the merge fields.
10. Click Next.

11. Click View in Layout mode.

12. Click Finish.

Y our label should look like this:

Label Contents:

<<First Name>>» <<Last Name>>
<<Home Address 13>

<<Home Addiess 25>

<<City> >, <<Countrys>

13. When you finish viewing your |abel layout, choose View menu >
Preview Mode.

Y our labels should look like those in the sasmple file.

Create a form letter

Look at the sample letter

1. Choose Window menu > Sample06.fp5.

2. Choose View menu > Browse Mode.

3. Choose Welcome Letter from the layout pop-up menu.

4. Flip through the records and look at the letter. Y ou might need to
scroll down to see al of it.

5. Notice the personalized address and salutation for each record.
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6. Also notice that the wording in each letter isthe same, except that
the company namefor each record appearsinthefirst paragraph. The
text flows around the company name, regardless of its length.

This letter isready to print, for every record in the database.

About form letter layouts

The letter is simply alayout containing text, merge fields, and a
graphic.

1. Choose View menu > Layout Mode.

2. Click anywhere on the text.

Y ou see the handlesin the corners of the entire text block. All of the
text isin asingle text block.

3. Notice that Company is amerge field in the body of the | etter.
The address and salutation also use merge fields.

Create a form letter

To create thisletter, you will:

* create a blank layout

* create atext block to contain your letter

* add merge fields for the recipient’ s name and address

* typetheletter

* customize the letter with the recipient’s company name
* add the closing

Create a one-page blank layout
1. Choose Window menu > MyFile06.fp5.

2. Choose View menu > Layout Mode.

3. Choose Layouts menu > New Layout/Report.
4. For Layout Name, type V¢l cone Letter.
5. Select Blank layout for the new layout type.

6. Click Finish.

7. On the layout, click the Header tab, then press Backspace
(Windows) or Delete (Mac OS).

8. Click the Footer tab, then press Backspace (Windows) or Delete
(Mac 0S).

This letter will not use a header or footer.
9. Drag the Body tab down to about 11 inches.

When you release the mouse button, you will seethe page boundary.
If you don’t see the page boundary, drag the Body tab down some
more.

| I

Eody

Body tab

Page boundary

10. Now drag the Body tab up to just above the page boundary.
The page boundary line will disappear.

11. Use the scroll bar at the bottom of the screen to scroll afew
inches to theright.

Y ou seeaheavy dotted linealong theright side. Thisistheright-side
page boundary. Y our letter will be within these boundaries.

12. Scroll back al the way to the left.
13. Scroll up to the top of the layout.

Create the text block
You will create atext block with a 1.5-inch margin on all sides.
1. Click the text tool |A.

2. Drag arectangle starting about 1.5 inches from the top left side of
the layout, and ending about 1.5 inches from the bottom right side,
asindicated by the page boundary lines.



When you rel ease the mouse, theinsertion point flashesin thetop I eft
of the text box. Y ou will type the letter inside this box.

¥ FileMaker Pro
File Edt View Insst Fomat Layouts Amange Seripts Window Help

I MyFilc06
[y ! B P A A T e S

The text tool
is selected

Add the address
1. Choose Insert menu > Merge Field.

2. Select First Name in the list and click OK.

3. Type aspace.

4. Choose Insert menu > Merge Field.

5. Select Last Name in the list and click OK.

6. Moveto the next line (enter aline space):

Windows: Press the Enter key above the Shift key on the keyboard.
Mac OS: Press Return.

7. Add mergefields for the street address, city, and country, with
appropriate spaces, new lines, and punctuation.

Type the letter

1. Press Enter (Windows) or Return (Mac OS) twice to create two
line spaces at the end of the address.

2. Start the salutation line: type Dear and a space.
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3. Insert mergefieldsfor thefirst and last name, separated by a space.

In your own letters, you can use more fields (for example, atitle
field) for amore elegant salutation.

4. Type acommaand two line spaces.
5. Typetheletter:

The Qorporate Travel ers d ub wel cones you and your
conpany to our organi zation.

V¢ | ook forward to doi ng business with you and hope
you have many pl easant trips wth us!

Customize the letter with the company name
1. Click after the word company in the first paragraph.

2. Type acommaand a space.
3. Insert amerge field for the company name.

4. Type another comma.

Add the closing
1. Click at the end of the text and enter two line spaces.

2. Press tab several timesto go to the center of the text block.
3. Type S ncerel y, then enter four line spaces.

4. Press Tab severa timesto aign the insertion point with Sincerely,
and type John Jones.

5. Enter aline space, then press Tab again to align the cursor with the
previous lines of text, then type Presi dent.

Y our layout should look like the letter in the samplefile.
6. Choose View menu > Browse Mode to see your letter.

It should look like the letter in the sample file. See lesson 5 to learn
how to add alogo.

7. When you are finished with this lesson, close each open file by
choosing File menu > Close.
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For more information

In thislesson, you have created list, label, and form-letter layouts.
Y ou can create as many layouts as you like, to organize your
information in any way you like. To learn how to create other
layouts, see lesson 9 in this tutorial and chapter 6 in the
FileMaker Pro User’'s Guide.



Lesson 7
Simplifying data entry

You can simplify the way you enter datain FileMaker Pro and
improve accuracy by using value lists, calculation fields, and data
auto-entry.

In thislesson, you will:
® see how value lists can aid data entry

* write and test a calculation formula

* use afield’ s auto-entry options to automatically enter data

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Enter data using value lists

Value lists let you choose the value you want from ascrolling list, a
pop-up menu, checkboxes, or radio buttons. These lists can contain
predefined values, or can be constructed dynamically based on the
valuesin aparticular field. They are an efficient way to enter
frequently used values into your database.

Look at the sample value list
1. Open the Tutoria folder in the FileMaker Pro folder.

2. Open the Sample Filesfolder.
Y ou should be here: FileMaker Pro\Tutorial\Sample Files.
3. Open Sample07.fp5.

4. Choose Layout #1 from the layout pop-up menuif it is not already
selected.

5. Locate the Membership Typefield on the current record. Y ou see
two radio buttons, one for New and one for Continuing. These
correspond to the two choices in the Membership Types value list.
Click one to enter the corresponding value in the field.

A value list with predefined values, displayed as radio buttons

Membership Type  [@ Mew O Confinuing |

Define a value list

1. Open the Tutoria folder in the FileMaker Pro folder.

2. Open the Working Filesfolder.

Y ou should be here: FileMaker Pro\Tutoria\Working Files.
3. Open MyFile07.fp5.

4. Choose Layout #1 from the layout pop-up menu if it is not already
selected.

5. Choose File menu > Define Value Lists.
6. Click New.
7. Name the new value list by typing Menber shi p Types.
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8. Click into the large box and enter the valuesfor thislist, New and
Gont i nui ng, by typing each value on its own line.

Edit Value List [x]

Value List Name [Membership Type

& Use custom valuss: Mew 1=
Each value must be separated Continuing]
by a cariage et
Add a divider by entering a
hyphen " o  line by itself
I |

1 Use values from field:

e < rdefired)

€ Use value list from anther fis:

e < rdefired)

&

9. Click OK.
10. Click Done.

Assign a value list to a field and display it as radio buttons
1. Choose View menu > Layout Mode.
2. Select the Membership Type field.

gembership Type  [Marmbership Tvbe - I

A

3. Choose Format menu > Field Format.

4. In the Style area, click the triangle next to Pop-up list and select
Radio buttons from the list.

5. Click the triangle button to the right of using value list and select
Membership Types from the menu.

Field Format for “Membership Type”

__Style
(O Standard fisld

[ nelude vertizal soroll bar

Select ® (Eatiobuttons [ £ ustog value Tt ([Fembership Types £ ) Selectthe
RadiO [ include "Other.." item ta allow entry of other walues Membership

[ nclude “Edit...” item to allow diting of walue Tist

buttons Types value list

Show Dﬂ field's 1 defined repetitions
Use (oA arintation

Behavior

’7E ATl entry inta field ‘

[CJ Selest entire contents of field on entry

)

6. Click OK. Your radio buttons should be visible in Layout mode.

O==——————samplelifps5=—————"———FH 8B
Layout #1 ‘"\u\u\‘u\|\|\|\zuu\|\|\zu\u\u\|\4|\u\uu\Su\u\uu\suu\uu:\
I 3 The Corporate Travelers Club
I%ayouts —:
A=
o] [ = Member Number
ol - First Name
| Last Name
- Home Address 1 [}
= Home Address 2 [}
. | City |Gy,
Membership = country [Gaiohy
Type field E Company [ Cormpary ]
formatted as . ip Type 0 New D) Conbniing i
radio buttons J Fee Paid [Ese.
'"7_ Date Paid |
100 [ Jul[ B[S Layout A [ Dz

7. In Browse mode, test your value list and buttons by clicking them.



Generate values with a calculation field

When you want FileMaker Pro to perform acalculation for you, for
exampl e to determine the amount of tax owed or the proper feeto be
paid, you use a calculation field. Calculation fields are one of the
FileMaker Pro field types. FileMaker Pro can perform simple and
complex calculations.

The calculation formula uses values from the current record or
related records. Theformulacan usevauesfrom al field types. You
can use calculations to return text values (for example, combining
the contents of first name and last namefieldsinto afull namefield),
dates, times, and the contents of container fields.

See how calculations speed data entry

Members of the Corporate Travelers Club pay an annual fee. New
members pay a fee of $200, while continuing members pay $100.

Thefollowing steps show the cal culation you are going to build. The
calculation returns amembership renewal fee based on membership

type.
1. Choose Window menu > Sample07.fp5.

2. Choose Layout #1 from the layout pop-up menuif it is not already
selected.

3. Create anew record by choosing Records menu > New Record.
Notice there’ s no datain the Renewal Feefield.

4. Inthe Membership Typefield, click New. The Renewal Feefield
indicates 200.

The Renewal Feefield isacalculation field.

5. In the Membership Typefield, click Continuing. The valuein
Renewal Fee changesto 100.

6. Delete this record by choosing Records menu > Delete Record.
Deleting this record is necessary to set up alater part of thislesson.

7. Click Delete in the confirmation dialog box.
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Create a calculation field

Thereareseveral different waysof formulating acalculation, each of
which can yield the correct result. The following method uses an If
statement to compare the data entered in the Membership Typefield
with one of the membership types. The calcul ation returns one of two
results.

1. Choose MyFile07.fp5 from the Window menu.

2. Choose File menu > Define Fields.

3. For Field Name, type Renewal Fee.

4. For Type, click Calculation to make thisacalculation field.

Define Fields

12 field(s) Wiew by

# Membership Type  Text Indesced
# Membership Revenue Summar y = Total of Fee Paid

4] ID

Field Name IRE"EWﬂl Fee I

Type -

Q Text #T (O Container %0 w [_options... |
(O Number 3N —@ Calculation 3C Duplicate
(O Date #D | O Summary %S

O Time ®l (O Global #G Delete Done

Fa

Click Calculation

5. Click Create.
The Specify Calculation dialog box appears.

6. Scroll through thelist of formulasin the upper-right corner of the
Specify Calculation dialog box until you locate

If (test, result one, result two). Double-click this formula so that it
appearsin this dialog box.
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Thisformula has three parts: atest, aresult if the test evaluates as
true (result one), and aresult if thetest evaluates asfal se (result two).
Y ou will replace the placeholderstest, result one, and result two with
the actual components of the calculation.

Specify Calculation

Current File (" MyFile07.fps "] & Operstors  View [Callby name

a+

HMember Number GetRepetition (repesting field, nfa
First Name GetSummary (summary field, br E
. Last Hame Hour (time) — F |
|| Home Address 1 If (test, result one, result two) |2
F||e|d Home Address 2 Int (number) Iotrmu a
Cit IsEmpty (field)
ISt C;:nlru Izt alid (Field) Is
Company Last (repeating field) -
Renewal Fee =
If (test, result ane, result twol =
Replace these placeholders
with your calculation
Verify the type of data to be
returned by the calculation L
| -
Cateutation result s [Foamber 1% Storane ontioms
[ Repeating fisld with & maximum of [2 |values
IS 0 ot evatuate 1 21 rforsnced fes re sty

7. Select the placeholder testand type Menber shi p Type =
“Qonti nui ng” exactly asit appears here.

8. Select the placeholder result one, and type 100.
9. Select the placeholder result two, and type 200.
10. Make sure the calculation result is set to Number.

Specify Calculation

Current File ("MyFile07 fp5 ™) 3 Operators Yiew [ all by name 3

Mernber Number GetRepetition [repeating field, m
First Name = GetSummary (summary fieTd, br
Last Hamne = BB Hour (time)

Homne Address 1 If (test, result one, result two)
Hone Address 2 @B ot Grumberd

City IsEmpty (field)

Country || @B and levalid (field)

Company - or Last (repeating field)

Renewal Fes =

If (Membership Tupe = "Continuing”, 100, 200) -

The completed calculation

Caloulation result is [Humber | 2] -
Storage Options...

[ Repeating field with a masimum of [2|values

[ Do not evaluste if 2N referenced fields are empty Cancel

11. Click OK.

If you receive an error message, make sure that all spaces and
punctuation are identical to the formula shown above.

12. Click Done.

The Renewal Fee field appears at the bottom of the layout.
Depending on the size of your screen, you may need to scroll down
to seeit.

Y our calculation formulais now complete. When datais entered in
the Membership Type field, FileMaker Pro will compareit to the
word we are testing for, “Continuing.” The test istrueif it matches
thisword, and the calculation will return your first result, 100. If it
doesn’'t match, the test is false, and the second result is returned.

Test your calculation

To seeif your calculation works, try changing the valuein the
Membership Typefieldto New and notice the result in the Renewal
Fee field—it should change as the membership type changes.



Automatically enter a serial number

FileMaker Pro letsyou automatically enter certain types of data—for
example, incremental numbers—when you create a new record.

Look at a serial number example
1. Choose Window menu > Sample07.fp5.
2. Go to the last record in the database.

3. Locate the Member Number field, and note the current number of
this record.

4. Create anew record by choosing Records menu > New Record.

The value in the Member Number field of the new record is
increased by one.

Note If you did thefirst activity in this chapter, you will notice that
the value in Member Number is 32, even though there are now 31
records in the Sample07.fp5 database. FileMaker Pro continues to
increment serial numbers even if intervening records have been
deleted, such as record 31 in this case.

Create a field for serial numbers

1. Choose Window menu > MyFile07.fp5.
2. Choose File menu > Define Fields.

3. For Field Name, type Menber Nunter.
4. Select Number asthe field type.
5. Click Create.
6. Click Options.
7

. Select Serial number on the Auto-Enter tab. Y ou don’t need to
change amounts for next value and increment by for this exercise.
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=——— Options for Field “Member Number”

Select Serial —
number

8. Click OK.
9. Click Done.

The new field appears at the bottom of the layout. (Y ou might need
to scroll down to seeit.)

10. Test your new field entry option by choosing Records menu >
New Record. Each time you create a new record, the value in the
Member Number field increments by one.

To learn how to change the position of the new field, see lesson 5.

11. When you are finished with this |esson, close each open file by
choosing File menu > Close.

For more information

Y ou have learned how to simplify data entry by defining and
formatting value lists, calculation fields, and auto-entered serial
numbers. For more information on calculation fields and field
auto-enter options, see chapter 5 of the FileMaker Pro User’ s Guide.
For more information on defining and formatting value lists, see
chapter 7 of the FileMaker Pro User’s Guide.
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Lesson 8
Automating tasks with buttons and scripts

FileMaker Pro lets you automate many database tasks with buttons
and scripts. These powerful features can save you alot of time by
performing a series of actions with asingle click.

In thislesson you will:
* make and use a button to perform atask
® create and run asimple script to perform a multi-step task

* use a button to perform a script

Note You caninstal afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Perform a task using a button

Look at a sample button

A button is an object on alayout that you can click to perform many
FileMaker Pro commands. Y ou can use a button to switch layoutsin
your database.

1. Open the Tutorial folder in the FileMaker Pro folder.

2. Open the Sample Filesfolder.

Y ou should be here: FileMaker Pro\Tutorial\Sample Files.
3. Open Sample08.fp5.

4. Locate the button labeled Go to List of Members at the top of
Layout #1.

5. Click the button. Y ou should now be viewing the List of Members
layout (as indicated by the layout pop-up menu).

Create the button

1. Open the Tutorial folder in the FileMaker Pro folder.

2. Open the Working Files folder.

Y ou should be here: FileMaker Pro\Tutorial\Working Files.
3. Open MyFile08.fp5.

4. Choose Layout #1 from the layout pop-up menuif it is not already
selected.

5. Select View menu > Layout Mode to switch to layout mode.

6. Click the button tool )

7. Draw the button at the top of the layout.

Button
O———————————— sampletens 2=
e TP PP A T i TP G T T A
—f I E
@“ 3 The Corporate Travelers Club <
— |7
;ayuuts | [eager ]
Al
O O.—? | Menber Number  Mernber Hurmber
kel First Hame | Eirst Narm:
Fil........ ] o Last Hame  [LastNarm
E Home Address 1 [Home Address 1
: Home Address 2 | Horme Acldrs
&0 | City | City
CSEACE e country [Counmy
ﬂ A 1et| 1 Company | Company |
i Membership Type [ N&W () GorENUING |
= Fee Paid [Fee Paid
] Date Paid  [Date Paid =
| Renewal Fee [HSnoyal hd
100 = Layout Q] oy

8. Inthe Specify Button dialog box, select the Go to Layout command
from the list.

9. In the Options area, select the List of Members layout.
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Specify Button
Do Nathing [=] - options
Control E
Perform Seript . .
Resume Soript Speoify: [ List of Members e SpeCIfy the List of
Exit Soript
ok oot Members layout
it
Else
End It _ Button Style
Loop
Exit Loop If @ Rectangular button
End Laop
Allow User dbart 3 Rounded button
Set Errar Capture
Havigation
o to Record/Request/Page [ change to hand cursor aver butten
Go to Relsted Record
Go to Portal Row = Cancel -
2

11. Noticethat theinsertion point isnow in the center of your button.
Type @ to List of Menbers inyour button to identify it.

12. Click outside the button.

If you need to move the button, select it and drag it to the desired
location, as with any other layout element.

Totest your button, go to Browse mode and click it. The button takes
you to the List of Members layout.

Perform a series of tasks using a script

Asyou have just seen, you can use a button to perform asingle
command. To make FileMaker Pro perform a sequence of
commands, use a script.

Run a script in the sample file
1. Choose Window menu > Sample08.fp5.

2. Choose Scripts menu > Preview Labels Layout.

Y ou should now see the Labelslayout, in Preview mode. This script
lets you preview labels before you print.

About scripts

A script lets you construct a series of instructions for FileMaker Pro
to perform. Like buttons, scripts allow you to automate most of the
FileMaker Pro menu commands, aswell as activate some commands
not found in the FileMaker Pro menu structure (such as Send Mail
and Dial Phone). Simple scripts can perform asingle task, while
complex scripts might combine elements (such as user feedback and
control) with programming techniques (such as branching and
looping) to make powerful, dynamic instruction sets.

Create a script to preview the Labels Layout

1. Choose Window menu > MyFile08.fp5.

2. Choose Scripts menu > ScriptMaker.

3. Inthe Script Name text box, type Previ ew Label s Layout.
4. Click Create.

In the resulting Script Definition dialog box, notice that a script has
been created, and that it includes some default script steps. All
FileMaker Pro scriptsare created with these same default script steps
present. Y ou will clear these default steps before adding your own
steps to the script.

=————Script Definition for “Preview Label Layout”

Wiew | all by cateqory 2

Control + Enter Browse Mode 1 -
Perform Seript + o to Layout [“Layout #1]
Pause /Resume Seript + Page Setup [Restore, Ho dialog]

: Delete these
Exct Seript Show All Records :
Halt Soript + Unsort default SCrlpt
i + Print [1 steps

Else

End If

Loop

Excit Loop If

End Laop

Allow User dbort

“Preview Label Layout ™

T »
I

Set Error Capture
Havigation =
Go to Layout
Go to Record/Request /Page i L
Go to Relsted Record
Go to Portal Row
Go to Field
Go to Nesct Field -

— Dptions

[ Clear All ][ Move ][Duplicate

Camcel ) o]
=]

5. Click Clear All.



6. Select the Go to Layout script step and click the Move button. (Y ou
can aso select and move script steps by double-clicking them.)

7. Inthe Options area, select the Labels layout from the list of
available layouts.

Script Definition for “Preview Label Layout™

Wiew [Lall by category 3

Control
Perform Seript
Pause /Resume Script
Exit Seript
Halt Seript
it
Else
End If
Loop
Exit Laop If
End Loap
Allow User Abort
Set Error Capture
Havigation

"Breview Label Layout*

4

T »

4]

Ga to Layaut KIIm] D SpeC|fy the
s || S layoutyou
e to Parta) Row [ Refresh window wantthe script
ﬁ: :: :«I:: Field -] Speeity: Labele i togoto

Clear All ] [ Clear ] [ Duplicate ] /J

8. From the list on the l€eft, scroll down and select the Enter Preview
Mode script step, and move it over to your script.

9. With this script step selected, deselect the Pause checkbox in the
Options area.

When you use a script to change modes, FileMaker Pro givesyou the
option of pausing the script. This can be useful if you require some
input before continuing the script. In thisinstance, Enter Preview
Mode isthe last step of the script, SO no user input is necessary.
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Script Definition for “Preview Label Layout”" =—————

Wiew [(all by category B

“Preview Label Layout ™

1

Go to Nexct Field ] |+ GotoLayout [“Labels ] - The finished
Go to Previous Field + Enter Preview Made (1 4

Enter Browse Mode script

Enter Find Mode

Enter Preview Mode
Sort/Find/Print
Sort
Unsort
Shaw All Records
Shaw Omitted
Omit Record
Omit Multiple
Perform Find
Modify Last Find =
Page Setup P1im Tr

— Dptions

4]

Copy

Clear All ][ Clear ][ Duplicate

Camcel ) o]
=]

10. Click 0K, then click Done.

11. To run the script you have just created, choose Scripts menu >
Preview Labels Layout. FileMaker Pro displays the Labels layout and
switches to Preview mode.
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Assign a script to a button

While buttons are generally more convenient for users, scriptsare a
more powerful feature, allowing you to combine many menu
commands into a single executable action. Using a button to run a
script gives you the best of both features.

To assign the script you just created to a button:

1. In MyFile.08.fp5, choose Layout #1 from the layout pop-up menu.
2. Choose View menu > Layout Mode.

3. Double-click the button you created earlier in this lesson.

4. In the Specify Button dialog box, select the Perform Script script
step from the top of thelist on the left.

5. In the Options area, select Preview Labels Layout from the list of
available scripts. Leave the rest of the default settings asthey are.

If you have not already created this script, follow the steps described
in“Create a script to preview the Labels Layout” on page 64.

Specify Button
ing on the
Do Hothing ] —options
Control =
Resume Seript Speoify: [ Preview Label Layout B
Exit Seript ) Corrent Soript
Halt Seript IR IS S
It
Else
End I _ Button Style
Loop
Exit Loop If @ Reotangular button
End Loap
Allow User Abort (2 Rounded button
Set Error Capturs
Havigation
o to Layout
5o to Record /Request /Page [O Change ta hand cursor over button
o to Relsted Record
5o to Portal Row — Cancel -
_

6. Click OK to save this button.

Rename the button
1. Click the text tool Al

2. Click the button once. The text insertion point appearsin the
button.

3. Type Previ ew Label s Layout to rename this button.

Test the button
1. In Browse mode, test the button by clicking it.

Clicking this button performs the script, which displays the Labels
layout and switches to Preview mode.

2. When you are finished with this lesson, close each open file by
choosing File menu > Close.

For more information

Inthislesson, you have created buttons and scripts, and used thesetwo
featurestogether. For moreinformation on creating buttons and scripts
in FileMaker Pro, see chapter 10 of the FileMaker Pro User’s Guide.



Lesson 9
Creating and running reports

The process of retrieving and organizing data from a database is
called reporting. Summary reports present just the total's of your
data; they do not break information into smaller groups.
Subsummary reports, also referred to as reports with grouped data,
categorizeinformation by aparticular field or fields, allowing you to
group information hierarchically. This subsummarized information
can then be subtotaled, averaged, or counted.

In this lesson you will:
* generate areport with grouped data
* generate a report with grouped data and totals

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

Generate a report with grouped data

Look at a sample report

This example shows a report that groups the members by
membership type. The report has been saved to a script.

1. Open the Tutoria folder in the FileMaker Pro folder.

2. Open the Sample Files folder.

Y ou should be here: FileMaker Pro\Tutorial\Sampl e Files.
3. Open Sample09.fp>5.

4. Choose Scripts menu > Membership Type Report to generate the
membership type report.

5. Examine the resulting report.

First, notice that you are in Preview mode. Preview modeis
necessary to view summarized data on the screen. Second, notice
how the members are grouped by the membership type, and further
a phabetized by last name within each of these categories.

Meribaiship Tipe Report
Thi Lo ame Fist Hame
is report groups Cortinuing
Alvarez Juanita
data by the o
Membershlp Type Cermmon Andre
. Durand Marie
field, also referred to senoen e
as the break field donron il
LeFranc Gerard
Mehmet Ahmet
Neronha il
Ogawa Kentaro
Sraith Mary
Tang Sophie
Vargas Julia
Verhaag Annelies
Duport: Jacques
Durand Jean
Garcia Juan
Lee John
Murphy Palrick
Nguyen Le
Sehmidt Jutiz
Smith John
Svensson Sven
Vitanen Malti
Williams: Steve
Wilsen Belty

6. Click the Continue button in the status area to complete the script
and return to Layout #1.
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About subsummary reports

A report with grouped data requires a number of elements to work
properly.

Subsummary reports include:

* asubsummary part in the report layout for each level of detail you want
to break out. The New Layout/Report assstant creates these for you.

¢ afield or fieldsto group records by. Thesefields arereferred to as
break fields.

* records sorted by these break fields, in the order the subsummary
parts appear on your report layout.

Create a subsummary report

To create the Membership Type Report:

1. Open the Tutoria folder in the FileMaker Pro folder.

2. Open the Working Files folder.

Y ou should be here: FileMaker Pro\Tutorial\Working Files.

3. Open MyFile09.fp5.

4. In Layout mode, choose Layouts menu > New Layout/Report.

5. For Layout Name type Menber shi p Type Report.

6. Select Columnar list/report for the new layout type and click Next.

New Layout/Report [2]x]

Create a Layout/Report

Layout Name:  [Membership Type Report V' Include in layout pop-up menu

Select a layout type:

Standard form
Colymnar list/report

Table view
Blank lapout
Labels
Envelope

Sets up a simple columnar report or a comples
repoit with grouped data and tatals or subtatals
Shows records in rows and fields in calumns.

ik [ Mews | Caned | Help

7. Select Report with grouped data, and click Next.

New Layout/Report

Choose Report Layout
" Columnar List/Report

Sets up a simple columnar iepart, The fields pou specity

appea left to fight acioss the body of the layout, with feld
labels s column headings. If there are many fiskds, they -
will sxtend beyord the right pags maigin

I Carstrain to page width .

o

{Heport with grouped dats

Sets up o complex 1eport in an extended columnar lapout
Grouping records lets you summarize your dats by any field,

such as region or month, Select either or both of the
checkbares i you want to total group data

™ Include Subtotals
™ Include Grand Tatals

<Back [ Met> | Cancel Helps

Select the fields used in this report

1. Double-click Membership Type, the first field to be used in this
report, to move it to the Layout fields list.

2. Select and move the Last Name field.
3. Select and move the First Name field.



New Layout/Report [2]x]

Select Fields

Select the fislds that you want on your 1epott. Make sure the fields are in the order you want
them ta appear in your report.

Available fields,
Current File [ MyFile03"] -

Wember Humber -

First Name

Last Name

Home Address 1 Moye
Home Address 2

Ty Mowe Al

Country

Compan
Fon Bt o) | Cemai

Repoit fields

+ Membership Type

< Back I Hext » I Cancel Help

4. Click Next.

5. Move the Membership Type field to the Report categories list to
organize the records by membership type.

New Layout/Report [z 1]

Oiganize Records by Category

Grouping records lets you subsurmarizs your data by similar field values such as rsgion or date,
Your seleetion order determines the hierarchy of the categories (subsummary parts] in the report.

Fleport fields Repott categories
[{ [ty i + Membership Type
Last Hame -
First Mame

Hove -
Clear A1

<Back [ MWets | Concel | Help

Membership Typeisreferred to as a break field because you are
using the contents of thisfield to break the recordsinto categoriesfor
your report.

6. Click Next.
7. Move the Last Name field to the Sort order list.
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This sorts the records in each group of membership types
alphabetically by members' last names. Notice that the break field
Membership Type appears automatically at the top of the Sort order
list to enable FileMaker Pro to group records by this category.

New Layout/Report

Sort Records

Select any fields you want to soit by and their sort order.

Feport fields: Sort order
Membership Type & Membership Type ]

Last Name ¢ Lost Name al}
First Name o 1
Clear A1

al ) Sscendng Hider
h. €0 DEscending rde

La ) Custor order based on walis list <unkniowin 5

<Back [ News | Coancel | Hep |

8. Click Next.

Select a theme and create the header and footer

1. Select the Standard theme to set the text size, color, and style of
the finished report.

2. Click Next.
3. Go to the Top center list and select Large Custom Text.

4. Type Menber shi p Type Report for the header of the report and
click OK.

5. Go to the Bottom center list and select Page Number to number the
pagesin the report’ s footer.
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New Layout/Report [2]x]

Header and Footer Information

*You can show the page number, curent dats, & loga, the layaut name, or custom text in the header
or fouler areas of your report.

Select the information that you would like to appear at the top of every page.

None 2l [Lage Custom Test. 2] [None =
Top eft Top genter Top fight

- Footer

Select the information that you would like to appear at the bottom of every page.

None Bl Mone =

Bottom it Bottom center Bottom right

< Back I Hext » I Cancel Help

6. Click Next.

Create a script to run this report again
1. Click Create a script.

2. Leave Script Name as it appears. Click Next.

3. Click View the report in Preview mode if it is not already selected.
4. Click Finish.

Y our finished report should look like the report pictured on page 67.

Generate a report with grouped data and totals

Look at a sample report

This subsummary report:

* groups the members by membership type

* subtotals the fees collected for each membership type
* provides agrand total of these fees

1. To view the finished sample report, choose Window menu >
Sample09.fp5.

2. Choose Scripts menu > Membership Fee Report to generate the
membership fee report.

3. Examine the resulting report.

Asin the previous example, the members are grouped by
membership type. Additionally, the fees collected for each
membership type are subtotal ed beneath those members' names, and
agrand total of all fees appears at the bottom of the report.

Membership Fée Heport
Lascane st same fee ria
Continuing
Alvarez Juanita 100
Cannon Michelle 100
Commen Andre 100
Durand Marie 100
Jensen Jeng 100
Johnson Yrilliam 100
LeFranc Gerard 100
Mehinet Ahmet 100
Moronha il 100
Ogawa Kentaro 100
Srnith Mary 100
Tang Sophie 100
Vargas dulia. 100
“Yerhaax Annelies 100
contnuing * 1400 Subtotals
New
Dupont Jacques 200
Durand Jean 200
Garcia Juan 200
Lee John 200
Murphy Parick 200
Ngupen Le 200
Sehmidt Jutta 200
Srnith Jdohn 200
Swensson Sven 200
Yitanen Matti 200
Williams Steve 200
Wilson Befty 200
Nevr 2400
w—— Grand Total
.

4. Click the Continue button to complete the script and return to
Layout #1.

A report with grouped data and totals requires the same elements as
areport with grouped data: a subsummary part in the report layout
for each category, afield or fields to group records by, and a sort of
the database by these fields.



Two additional elements are also required:
* agrand summary layout part

e summary field(s) to display totals, averages, or counts

Create a report with grouped data and totals

To create the Membership Fee Report:

1. Choose Window menu > MyFile09.fp5.

2. In Layout mode, choose Layouts menu > New Layout/Report.

3. For Layout Name, type Menber ship Fee Report.

4. Select Columnar list/report for the new layout type and click Next.

5. Select Report with grouped data and then select Include Subtotals
and Include Grand Totals.

New Layout/Report [z 1]

Choose Report Layout
€ Columnar List/Repart

Sets Up a simple columnar report. The fields you spacify

appear left o right acress the bodp of the lapout, with field
Isbels a5 column headings. If thers are many fislds, they —
will extend beyend the right page margin.

el e o e

Sets up a complex report in an extended columnar layout
Girouping records lets you summarize your data by any field,

such = region or month. Select sither o1 bath of the
checkbares if you want to total group data.

I¥ Include Subtotals

I Include Grand Totals

< Back I Mext > I Cancel Help

6. Click Next.

Select the fields used in this report

1. Select thefirst field to be used in this report, Membership Type,
and move it to the Layout fields list.

2. Select and move the Last Name field.
3. Select and move the First Name field.
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4. Select and move the Fee Paid field.
5. Click Next.

6. Y ouwant to organizethe recordsby Membership Type. Movethis
field to the Report categories list.

7. Click Next.

8. Movethe Last Name field to the Sort order list to sort the records
in each group of membership types alphabetically by members’ last
names.

9. Click Next.

Specify subtotals and grand totals

A summary field is atype of field you can specify when you define
fields. Summary fields allow calculations across all of therecordsin
your found set. In general, when you need to total data across a
number of records, you must use a summary field.

In the Membership Fee Report, you want to see subtotals for fees
paid by each type of member, New and Continuing, and to see a
grand total of both groups’ fees at the end of the report. To
accomplish this, you will need to specify subtotal and grand total
summary fieldsin the New Layout/Report Assistant.

The summary field you will use is Membership Revenue, which has
already been defined for you. Membership Revenue totals the fees
entered in the Fee Paid field.

1. Click Add Subtotal to add the Membership Revenue field as the
subtotal. ThistellsFileMaker Pro to create asubtotal of membership
fees paid beneath each membership category.

2. Click Next.
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New Layout/Report

Specify Subtotals

Select [or creats] summary fiskds for sach fisld you want to summarize. You can display
sublotals above and/or below the groups of summarized recards. After you make each set
of choices, click Add Sublotal. You can add mors than ane sublatal,

Summary fields: LCategory to summarize by

| Membership Revenue 7| [ Membership Type

Subtotal placement:
=1 [Below record group =

Lo BddSubiel ] Femowe Subwial |

Membership Type

Subtotalls]

Membership Revenue

<Back Met > Cancel Helps

3. Click Add Grand Total to add the Membership Revenuefield asthe
grand total at the end of thereport. ThistellsFileMaker Proto create
agrand total of membership fees.

New Layout/Report [z 1]

Specify Grand Totals

Select [or create] summany fields to calculate grand totals for each field. YYou ean display
arand totaks at the begining and/or end of your report. After you make each set of choicss,
click Add Girand Total. You can add more than one grand total

Summany fields Grand total placement:

[ Membership Feverue =] [End of repon =
R Grard TiEl | Removs Grand Total
Grard totalls)

Merbership Revanus End of 1spart

< Back Mext > Cancel Help

4. Click Next.

Select a theme and create the header and footer

1. Select the Standard theme to set the text size, color, and style of
the finished report.

2. Click Next.

3. Go to the Top center list and select Large Custom Text.

4. Type Menber shi p Fee Report for the header of the report and
click OK.

5. Go to the Bottom center list and select Page Number to number the
pages in the report’ s footer.

6. Click Next.

Create a script to run this report again
1. Click Create a script.

2. Leave Script Name as it appears. Click Next.

3. Click View the report in Preview mode if it is not already selected.
4. Click Finish.

Y our finished report should look like the report pictured on page 70.

5. When you are finished with this lesson, close each open file by
choosing File menu > Close.

For more information

In this lesson, you generated reports with grouped data, and
reports with grouped data and totals. For more information on
creating reportsin FileMaker Pro, see chapters 6 and 7 of the
FileMaker Pro User’s Guide.



Lesson 10
Making databases relational

Relational databases |et you easily view relationships between files
and streamline data entry. Y ou can enter data once, then view and
use that datain related files.

In thislesson, you will:

* see how relational databases work

¢ define arelationship

¢ display datafrom one related record
¢ display alist of related records

The sample filesin thislesson are a Members file with records for
individual Corporate Travelers Club members, and a Companiesfile
for compani es where these members work. Each company has many
members.

Note Youcaninstall afresh copy of thetutorial filesat any time. For
Windows-based systems, see the Custom setup instructionsin
“Installing FileMaker Pro” on page 11. For Mac OS systems, see
“Installing FileMaker Pro” on page 15.

View data from one related record

See how relationships work in the sample files
1. Open the Tutoria folder in the FileMaker Pro folder.
2. Open the Sample Filesfolder.

3. Open the Samplel0 folder.

Y ou should be here:
FileMaker Pro\Tutorial\Sample Files\Sample10.

4. Open Companies10.fp5 and browse through the records.

Y ou see onerecord for each of the three companiesthat has members
in the Corporate Travelers Club.

5. Open Members10.fp5 and browse through the records.
6. In Members10.fp5, create a new record for Jane Doe.
7. For Company, choose ABC Conpany.

First Name Jane

Last Mame  Doe

Company  |ABC Compan k

8. Notice that the address for ABC Company automatically appears.

First Name  Jane
Last Hame  [Diog
Company  ABC Company

Company tddress 345 Industrial Park Blvd.
Chicago
USA

About related files
Companies10.fp5 and Members10.fp5 are related files.

When you enter a company name in arecord in the Membersfile,
FileMaker Pro identifies the record for that company in the
Companiesfile. FileMaker Pro then displays the address from this
matching company record in the Membersfile.
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How does this happen? The Membersfile has arelationship to the
Companiesfilethat is based on matching datain the Company field
inboth files. The Company field isthematch field. The Membersfile
displays the company address using related fields based on this
relationship.

You will learn both parts of this process: how to define the
relationship and how to display data using the relationship.

Exit or Quit FileMaker Pro to close both files before continuing.

Display a related record in a file

Define a relationship to another file

1. Open the Tutorial folder in the FileMaker Pro folder.
2. Open the Working Files folder.

3. Open the MyFiles10 folder.

Y ou should be here:
FileMaker Pro\Tutorial\Working Files\MyFiles10.

MyMembers10.fp5 and MyCompanies10.fp5 are the same as the
sample files, but without the relational structures. Y ou will build
these structures now.

4. Open MyMembers10.fp5.
5. Choose File menu > Define Relationships.

6. Click New, navigate to the MyFiles10 folder in the Working Files
folder, and double-click MyCompanies10.fp5.

7. Inthe Edit Relationship dialog box, select the Company field in the
left column, and the :Company field in the right column.

Fieldsin the file you are working in (MyMembers10.fp5) are on the
left. Fieldsin the file you want to see data from
(MyCompaniesl10.fp5) are on the right.

8. Notice that the relationship name defaults to the name of the
related filee MyCompanieslO.

Edit Relationship [21=]

Relationship Mame  [MyComparies10

A& relationship defines a set of matching related
records fior each record in the curent file:

Specify File...

With data from field in related fle
MyCompanies10.fp5

Match data from field in current fle
MyFile05.fp5
Member Humber -
First Mame ~Compary Addiess
Last Name “City

Hare Address 1 ~County
Hame Address 2

I~ when delating a 1ecord in this fil,
also delete related records

I~ Alow creation of related rscords

I Sortrelated records — Specify

9. Click 0K, then click Done.

Display data from a related record

Once you' ve defined the relationship, set up the layout to display
data using that relationship. Here, you want to display the company
address.

1. In MyMembers10.fp5, choose View menu > Layout Mode.
2. Using the Field tool [Eigla...........

drag afield onto the layout.

You seealist of fieldsin thisfile.

3. In the Specify Field dialog box, click Current File
(“MyMembers10.fp5”) and choose the MyCompanies10 relationship
from the list.

You now see alist of thefieldsin the related file
MyCompanies10.fp5. The colons (::) before each field name show
that these are related fields, not fields defined in the file you are
currently working in. Theserelated fields will display data from the
related file.



Specily Field [2]x]
wyCompariesi  —=4+— Choose the relationship

to display fields from the
Compary Addess related file

“Courty h

IV Crate field Isbel

Cancel

4. Click ::Company Address, then click OK.
5. Repeat steps 2-4 for City and Country.

6. Movethefieldsif necessary, and make the fields large enough to
display all the datathey contain. The fields should look like this:

First Name

Last Name -
Company ComEa nE I

Company Add, SRompany Addrs
civy [LCiR
Country

7. Choose View menu > Browse Mode and flip through the recordsto
view company addresses from the MyCompaniesfilein the
MyMembersfile.

8. When you are finished, Exit or Quit FileMaker Pro to close all
files before continuing.
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View data from a list of related records

Suppose you want to show all club membersfor each company. Y ou
also want to add new members to the Members file without entering
the company name for each.

Work with related records in the sample files

View a list of related records
1. Open the Tutorial folder in the FileMaker Pro folder.

2. Open the Sample Files folder.
3. Open the Samplel0 folder.

Y ou should be here:
FileMaker Pro\Tutorial\Sample Files\Samplel0.

4. Open Companies10.fp5.
5. Browse through the records.

Y ou see alist of members at each company. They areall individuals
in the Membersfile.

Add to the list
1. Go to the ABC Company record.

2. Add anew member by clicking thefirst empty lineunder First Name.

Company | ABC Cormpany
Company Address | 345 Indusirial Park Blvd
city | Chicago
Country [LUSA

Displays a list of

First Hame Last Nune members from the
AR oo related file
Skeve Williarns

Click here to enter | [Kefisre g

a new member for e tiss

this company —F ]
L3

[l

3. Type Joe, then press Tab and type WI | i ans in thelast name
field.
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View the new record in the related file
1. Open Membersl10.fp5.
2. In Members10.fp5, go to the last record.

Y ou see Joe Williams' record, with the company information filled
in. You automatically created this record when you typed Joe
Williams into the list in the Companiesfile.

Add a new record and view it in the list

1. In Members10.fp5, create arecord for anew member who works
at ABC Company.

2. Now return to Companies1O.fp5 and look at the ABC Company record.

Y ou see the new member in the list (scroll down if necessary).

About working with lists of related records

Inthe“View datafrom onerelated record” on page 73, arelationship
in the Members file displays data (company addresses) from the
Companiesfile. Here, arelationship in the Companies file displays
data (member names) from the Membersfile.

Both relationships use the same match field, Company, but thistime,
there is more than one matching record in the related file because
there is more than one member from each company. A portal in the
Companies file displays the members for each company.

When you added Joe Williams to the list of members who work at

ABC Company, the relationship automatically created arecord for
Joe Williamsin the Membersfile. ABC Company is automatically
entered into the match field because the name was added to the portal
of the ABC Company record.

A new member added to the Members file automatically appears at
the end of the members list in the matching company record in the
Companiesfile.

Exit or Quit FileMaker Pro to close all open files.

Display a list of related records

Create a portal to display matching records

1. Open the Tutorial folder in the FileMaker Pro folder.
2. Open the Working Files folder.

3. Open the MyFiles10 folder.

Y ou should be here:
FileMaker Pro\Tutorial\Working Files\MyFiles10.

4. Open MyCompanies10.fp5.

A relationship must always be defined before you can display data
from related records. The relationship to MyMembers10.fp5 has
already been defined for you, using the process described in “ Define
arelationship to another file’ on page 74.

5. To view the relationship, choose File menu > Define Relationships,
select the relationship (MyMembers10), and click Edit.

6. Notice that Allow creation of related records is selected. Thislets
you add a nameto the list.

7. Click 0K, then click Done.
8. Choose View menu > Layout Mode.

9. Click the portal tool and draw a box to hold the list of names

rA
L .

10. In the Portal Setup dialog box, show records from the
MyMembers10 relationship.

11. Show 7 rowsin the portal.

Each row displays one matching member record.
12. Select Show vertical scroll bar.

13. Click OK.



Arrange the fields in the portal

1. Make the first portal row (the white part at the top of the portal)
tall enough to hold afield.

2. Using the Fidld toal [Eigd...........
row.

3. Select the ::First Name field and click OK.
4. Drag another field beside ::First Name and specify ::Last Name.

5. Move the First Name and Last Name field labels above the portal,
above their respective fields.

drag afield into the first portal

7

The portal should look like this when you are done.

First Name Last Name

[.:First Hame | [:Last Hame:

6. Choose View menu > Browse Mode to view your list of members.

7. Test your new structure: type the name of anew member at ABC
Company, thenlook to seeif it appearsin MyMembers10.fp5 (it will
be the last record).

8. When you are finished with this lesson, Exit or Quit
FileMaker Pro to close al open files.

For more information

Y ou have seen how to use and create simple one-to-one and one-to-
many relationships. This tutorial covers just the basics; there are
many important points to consider when building arelational
database system. Be sure you read chapter 8 in the FileMaker Pro
User’s Guide before using relational structuresin your own files.

Making databases relational

77



THIS PAGE INTENTIONALLY LEFT BLANK



Lesson 11
Keeping your data safe

Power failures, disk problems, and other unexpected computer
problems can happen to anyone at any time. To help prevent data
loss, regularly back up all important documents on your compuiter,
including your databases.

In this lesson you will learn:

* how and when to back up your database

* where to learn about other ways to protect your files

How to back up your database
There are many ways to back up afile. Thisisone way.
1. Determine the size of the database.

Windows: Right-click the icon for the file, then choose Properties.

Mac OS: Click theicon for thefile, then choose File menu > Get Info.

2. |dentify adisk or volume that has enough available space for a
copy of the database.

3. Open the database you want to back up.

4. Choose File menu > Save a copy as.

Create Copy [21=]
Save n: | ) Backup fies =

Select the disk
and folder where
you want to save

your copy

Acceptthe —
default filename
for your copy, or File name: [MyFile Copy.ip5

Change the name Save as lype: IF\\eMakel Filess [* fp5:= fp3* frn)

Save I

Savea

ﬂ Cancel Copy Of
—=——+ currentfile

v

Save & [cony of cunent fle

5. Click Save.

Important Next time, back up to adifferent disk or volume. Never
back up over the only or most recent copy of your file. Y ou should
have several different backups at all times.

When to back up
Y ou should back up:

* as often as necessary to be sure you can restore al of your datain
an emergency.

* before you make amajor or irreversible change like deleting
records, deleting afield from Define Fields, or replacing data using
the Import or Replace features.

Remember, it takes far less time to back up afile than it doesto
recreate alost or damaged file!

For more information

This lesson has shown you one way to protect a database. For other
ways to prevent and overcome difficulties with your files, see
appendix B in the FileMaker Pro User’s Guide.
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