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UPDATING FROM PREVIOUS VERSIONS OF DRAGSTRIP

If you have been using a previous version of DragStrip, it’s a good idea to back up your 
previous strips before installing. Upon installing DragStrip and converting your 1.0 or 2.0 
strips to 3.x, your strips will look and work the same except they will have many new options.

CONVERTING 1.0/2.0 STRIPS TO 3.X STRIPS

The way in which DragStrip 3.x stores files has changed since version 1.0 and 2.0. DragStrip
no longer stores icons, aliases, etc. in the same way. Therefore, existing strips from earlier ver-
sions need to be converted to 3.x strips. DragStrip 3.5 and higher will automatically convert
your existing strips, as well as your preferences file and your document list. DragStrip renames 
the old strips with an “old” suffix.

NOTE: You cannot convert 3.5 or higher strips back to earlier version strips.

INSTALLING DRAGSTRIP

1) To install, copy the DragStrip installer from the CD-ROM to your hard drive, and restart 
your Mac with extensions off. Installation problems can usually be avoided by installing 
applications with minimal extensions loaded.

2) Locate and double-click the DragStrip installer icon.

3) Click “Save” if you want to save the startup text to follow along as you perform the 
installation.You can also print a copy of this text by clicking the “Print” button. (This 
will only print a copy if you have your printing extensions enabled.)

4) Click the “Continue” button.When you are ready to proceed with the installation, click 
the Continue button; to quit, click the “Cancel” button.

5) Click “Agree.” You must agree to the License Agreement before installing the software.
If you do not agree to the License Agreement you must quit the installation and remove 
the software.When you click “Agree” the main installation window is displayed next.

6) Click the “Install” button for a full installation of all parts of the DragStrip package.
This includes all the extra tools that are useful for creating and managing strips.

7) Select a destination for the installation.A dialog is presented asking where you would like 
to install DragStrip. Once you have selected the destination, click the “Install” button.

8) Click “Quit”.When the installation is complete you should see a dialog allowing you to 
“Continue” or “Quit.”  If you wish to install again, for example, onto another drive or 
partition, click “Continue.”  
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GETTING STARTED

WHAT IS A STRIP?

Strips are composed of buttons, a status bar, page tabs, and a title bar.

The buttons on a strip display aliases for items you wish to make launchable from strips. (An
alias is an icon you can use as a representation for a document, program folder, or disk, which
“points” to that item.) Also, buttons can hold data in the form of pictures, text, sound, URLs,
and QuickTime™ movies.

The status bar gives information about the current date, time, and names of strip items.

Page tabs let you switch between different pages of buttons.

The title bar allows you to name and move your strips around your desktop.

When you start up DragStrip for the first time, it will open a new untitled strip ready for use.
After the first time you start up DragStrip, a new untitled strip will only appear if you close all
of your other strips and launch DragStrip.

DRAGSTRIP PAGES

Strips can be broken down into multiple pages. Each page can have its own page color and can 
contain as many items as the strip can hold. Pages are a great way of organizing your strips
based on the projects you are working on or the applications you use frequently.

When page tabs are visible, you will see the page’s name in a tab along one edge of the strip.
Page tabs can be drawn along the top, bottom, left and right side of the strip, or they can be
hidden entirely. Even when page tabs are hidden, you can switch between pages by pressing
the option-tab key combination.

PLACING ALIASES ON A STRIP

You can create an alias by dragging items from the Finder to a square on your strip. When you
open an alias, or click on a DragStrip button, the original item will open.

DragStrip will also open a separate default Processes strip showing the currently running 
processes on your Macintosh. This strip is similar to the Applications menu in the upper right
hand corner of the Macintosh menu bar. As you place your cursor over an icon, the name of
the process appears in the status bar of the strip. The process you are currently using is 
indicated by a box around the corresponding icon. By clicking once on a process, you will
make it the front-most active application. If you are in one application and click on a different
application on the Processes strip, the application you clicked on will become active.
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CREATING A NEW STRIP

Let’s go through a simple process of making a new strip and creating our first strip.

1) Launch the DragStrip application by double-clicking on the icon from the DragStrip 
Folder. The DragStrip Folder is located on your hard drive.

2) Choose “New” from the File menu. This will create a new untitled strip. You also need to 
choose from various button size and style options (see below), which will be explained in 
more detail in “Configuration.”  After you have selected these options, a new strip will 
appear with empty buttons that you can fill with items.

3) Next, place an item on a strip by dragging it from the Finder onto one of the blank 
squares on your strip. You can drag any item from your desktop (applications, documents,
folders, hard drives, etc.) onto a blank square and have it appear there. Essentially, when 
you drag these items, you are not physically moving the item to the strip, you are creating 
an alias of that item. For a more detailed description of what types of items can be placed
on your active strip, see below.

NOTE: If you do not have Finder 7.1.3 or later, you will need to option-click on a blank 
square on your strip to install your items.

INSTALLING ITEMS ON A STRIP WITHOUT USING DRAG AND DROP

1) First, option-click on a blank square of your new strip.

2) A standard dialog box will appear. Choose the item that you want to make an alias 
of on your strip.

3) Choose “Open” from the File menu. Now your strip has an item and you’re ready to go! 

SAVING YOUR STRIPS

By now it’s probably a good idea to save your first strip. You can save your strips by going to
the File menu and choosing “Save” or “Save As.”  

1) Highlight the File menu and choose  “Save” or “Save As.”   

2) Pick the location where you want to save the strip. It is a good idea to save your strips in 
the DragStrip folder. Having a DragStrip area on your hard drive will make it easier to 
manage strips.

3) After picking the location, type in the name of your new strip and choose “Save.”  
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CLOSING A STRIP

Because DragStrip is an application, a strip is simply an open document. In many word 
processing programs, you can have multiple documents open at the same time and switch
between them; in this way, you can also have many open strips. Remember, if you close a strip
and then restart DragStrip, that strip will not appear on the screen until you open it. Only
previously-saved strips that you leave open will automatically appear on the screen when you
restart DragStrip, but your other strips will still be available, just like any other document. If
you want to close an open strip, you can do this in two different ways:

1) Choose Close “Active Strip” under the File menu, or 

2) Click on a strip’s close box in the upper left hand corner of the title bar of a strip.

SELECTING A STRIP

Switching between multiple strips can be accomplished by clicking anywhere on a strip. Since
an active strip may have its title bar hidden, it will also be marked as active by a darker shadow
on the bottom and left sides. Additionally, the File menu displays the active strip name after
the Close command. This is particularly useful if you have your strips displayed without title
bars. Also, in the Windows menu, the active strip is indicated with a checkmark.

DELETING ITEMS FROM A STRIP

Dragging a strip item to the Finder’s trash will delete the item from your strip, but not from 
your hard drive. Remember, items on strips are aliases of the real items. Therefore you are
not deleting the original file, only the reference to the file on that strip.

You can also shift-click one or more items, and then choose “Clear” from the Edit menu, or
press the Delete key to delete the selected strip items.

REARRANGING ITEMS ON A STRIP

You can move an existing item on a strip by clicking on the item and dragging it onto a blank
button on the strip itself, or you can drag to it to a blank button on another open strip.
In addition, if you option-drag an item from one location on a strip to a blank button on
another open strip, that will put a copy of that item on the new button.

You can also copy an item by shift-clicking on it, selecting the “Copy” command, clicking the
pointer on the button or strip you wish to move the item to, and choosing “Paste.“ Cut and
Paste works in this manner as well. Copying items from one strip to another can also be very
useful in cleaning up strips, or placing frequently-used applications, files, or folders on many 
different strips or different pages on the same strip.
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You should make room for the new items you are copying or cutting (see below) before you 
paste them. If you don’t have room for all the items on the strip you are moving them to,
DragStrip will only paste the items (consecutively) that it has room for on the strip. If you find 
that all the items you wanted to paste onto the new strip aren’t there, resize the strip and
paste them again.

RESIZING A STRIP

You can resize a strip by dragging on the grow box in the bottom right hand corner of the
strip. Strips can resize horizontally or vertically by rows or columns. Also, a strip grows 
button by button; you cannot make a strip smaller than will allow all of the icons on a strip to
be visible, because the strip needs enough space to fit all the items. For example, if you have
four items on a strip, the strip must have at least four buttons.

To resize a strip:

1) Select the strip you want to resize by clicking on its title bar.

2) While clicking and holding the grow box located in the lower right hand corner of the 
strip, pull out the strip to the size you want it to be.

You can also insert rows and columns into a strip by choosing Insert Row or Insert Column 
from the Options menu. Then click the location where you wish to insert on the new row or 
column on the currently active strip. If you just want to resize the buttons on a strip without 
adding new columns or rows, hold down the option key while resizing the window. This will 
only work if the icon style you have chosen can be resized.

USING STRIPS

This section shows you all of DragStrip’s functions. You can place various types of items on a
strip, including applications, documents, folders, volumes, and data. Depending upon the item
placed on the strip, many different functions are available to you.

Applications

Click once on an application item to launch that application. If you drag one or more 
documents from the Desktop (or from a strip) and drop it onto an application item on a strip,
the application will launch, attempting to open the documents you selected. For example, if
you have a word processor alias on one strip, and your memo template file is on another strip,
just drag your memo template alias to the word processor button. The application will then
launch the application and open your document.

Hold down the Command key on your keyboard and click once on the item to reveal the item
in its Finder window.
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Click-and-hold on an application to produce a list of associated documents in a popup menu.
These are documents that have been dropped onto that specific application strip item before.
Choosing one of the menu items opens that document in the chosen application. You can
change the number of documents DragStrip will hold for each application in the DragStrip
preferences dialog box.

Items can be deleted from the document popup menu by choosing the document from the 
application document popup and holding down the Delete key while letting go of the mouse 
button. This will remove the chosen document from the document menu associated with that 
application. You can also use the Documents window to remove items from the documents
list.

Documents

Clicking once on a document on a strip will launch that document in its associated application.
Dragging one or more document items onto an application item opens the document(s) in the 
selected application.

Holding down the Command key on your keyboard and clicking once on the item opens the 
enclosing folder of the selected item in the Finder.

Folders

You can click on a folder icon and hold the mouse button down to produce a list of items 
enclosed in that folder in a hierarchical popup menu. Choosing one of the menu items will 
activate that item (i.e., launch a selected application, open a selected document). The folder 
popup menu is hierarchical up to five levels deep. On color monitors, items in the popup
menu will appear in the color of their Finder labels.

If you drag an item from the Finder over a folder listed in the hierarchical popup menu, you
can place an item in that folder.

As with documents and applications, you can hold down the Command key on your keyboard 
and click once on the item to reveal the selected item in its Finder window.

Disks

Volumes (such as your hard drive) work much the same as folders; when clicking on unmounted 
volumes (such as removable media) or items from unmounted volumes, you may be presented 
with the Finder AppleShare password dialog box.

6



STORING DATA ON A STRIP

You can drag text, pictures, sounds, URLs, and QuickTime movies to a strip and it will store 
them as clippings. Macintosh Drag and Drop allows you to copy select items such as text in
your drag-savvy word processor and drag them by selecting the items and holding down the
mouse button. If the item is text or a picture, the strip will show a little bit of it on its button.
If you drag them off, they go as their native data types, appearing on the desktop as clipping
files. This data can also be transferred in and out of DragStrip through the clipboard.

A good rule of thumb is that whatever you can put into the scrapbook you can store on a 
DragStrip. Also, if you shift-click on a DragStrip button, you can copy its data contents to the 
clipboard or paste contents to the strip from the clipboard. The strip can hold different kinds
of data in each strip button. Thus, you can have text, pictures, and sounds all stored on the
same strip. When you save the strip, the contents of the strip are stored in the strip files.

To store data (without using drag-and-drop):

1) Open a text or picture document, select the data you wish to store, and choose “Copy” 
from the Edit menu. This will copy the selected part(s) to the clipboard.

2) Select a DragStrip button by shift-clicking on it.

3) Next select “Paste” from the Edit menu. Now your data is stored in the button on the 
strip. By clicking on the strip and holding the mouse button down, the button contents 
will be displayed in a popup window (see above).

7



CONFIGURING DRAGSTRIP

DRAGSTRIP PREFERENCES

You can access the DragStrip Preferences dialog box from the Edit menu. Choose 
“Preferences...”  to access a list of different preference categories. Choose a category by 
clicking on its name in the scrolling list in the lower left corner of the window. The options
list to the right changes depending on which category you choose. Clicking the “Cancel” 
button exits Preferences without saving your changes. Clicking the “OK” button exits 
Preferences and saves your changes.

GENERAL PREFERENCES

Play click sound

When clicking on a button on a strip, you will hear an audible click from your Macintosh. You
can achieve this function by clicking the “Play click sound” checkbox.

Single click actions

DragStrip actions on a strip are usually initiated by a single click. This is DragStrip’s default
behavior. You can have DragStrip respond to clicks from the mouse much like the Finder.
Single-clicks will select items, while double-clicks will launch items. Choose this option with
the Single click actions checkbox.

Allowing multiple copies of an application

The Allow multiple copies of same application preference lets you launch a second copy of an
application that is already running, rather than automatically sending dropped documents, etc,
to the running copy.

Automatically mount volumes

When you click on a shared volume on a strip, DragStrip will try to mount (i.e., make files
available in) the volume. In addition, when you click on an unmounted volume to see 
its hierarchical file menu or move an unmounted volume on a strip, DragStrip will also try to
mount the volume automatically.

You can choose this option by clicking the “Automatically mount volume” checkbox.
Automatically mounting volumes can be useful when you want to remount a server drive or
remote drive.
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Resolve alias files when adding

When dragging an alias file onto a strip, you cannot store an alias to an alias. Instead you can
have DragStrip automatically resolve alias files by checking the “Resolve alias files when adding”
checkbox.

Hide empty buttons

Empty buttons on a strip appear as blank buttons. You can make these empty buttons 
disappear by choosing the “Hide empty buttons” checkbox.

Dim items on unmounted volumes

In the Finder, items from unmounted volumes are dimmed. DragStrip can also dim items 
located on currently unmounted volumes. You can have DragStrip dim these items by choosing
the “Dim items on unmounted volumes” checkbox.

Allow drags to other applications

The “Allow drags to other applications” preference allows you to turn on and off the ability to
drag items off of strips and drop them in the Finder. If you often accidentally drop things in
the Finder, you may want to keep this preference turned off.

Draw clipping contents on buttons

Because you can store data on strips, you have the option to not draw the text or pictures on
a button when the button contains text or picture data. This can make drawing your 
strips faster.

Jump windows to front when obscured

Sometimes there are other windows in front of a strip window when you want to drag a
something onto one of the items on the strip. When this option is on, DragStrip will make 
the strip jump in front of other applications when you drag on it, then it will go back behind
when you finish the drag or drag out of the window.

Only drag icon outline

On Macs that support it, DragStrip will drag a translucent version of the icon when you drag
an item that is on the strip. If you turn this option on, DragStrip will only drag the 
outline of the icon, not the translucent image.
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HOT SPOTS

If you are in another application, you may find that you want to access a file or function on a
strip that is hidden behind other windows. You can quickly bring the DragStrip application to
the foreground by touching your cursor to one of the Hot Spots you configure in the 
Preferences screen. You may choose one or many of the four corners of your main monitor
as DragStrip Hot Spots.

HOT KEYS

Hot keys allow you to switch between processes, bring DragStrip to the front, or toggle the
visibility of all of DragStrip’s windows.

To set your Hot Keys:

1) First, click the “Enable Hot Keys” button.

2) Choose which Hot Key process you want to use.

3) Click the “Set” button.

4) Press the key combination and the dialog will show you what keys activate that Hot 
Key(s).

When using the Hot Keys to switch between processes, a window will appear and show the
processes you can switch to one at a time. Holding the keys down allows you to switch
between processes. Letting go of the keys will switch you to the process shown in the 
window.

If you set function keys (for example, F1 or F2), you can switch between processes without
having to hold down the keys. Hitting “Return” or “Enter” will switch you to the process 
shown in the window.

Toggling DragStrip’s visibility will either hide all of DragStrip’s windows or show them each
time you hit the configured key combination.

You can also disable the hot key to quit DragStrip. This can keep you from accidentally hitting
Command-Q and quitting DragStrip.
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PROCESSES STRIP

A process is something that is currently running on your Macintosh. This can be a process
such as the File Sharing Extension, as well as an application. The Processes strip shows all of
the currently-active processes on your Macintosh on one strip. This is similar to the Applications
menu in the upper right hand corner of the Macintosh menu bar, but more versatile.

The name of the active process appears in the Status Bar of the Processes strip. As you saw in
the previous section, you can set your Hot Keys to switch between processes on your 
Processes strip.

By clicking once on a process, you will make that process the frontmost application. If you are
in one application and click on another application on the Processes strip, the one you clicked
on will become active.

Option-clicking on a process item will hide that processes windows and option clicking on the
process again will show that processes windows.

Show processes strip at startup

If you would like the Processes strip to show up automatically when you launch DragStrip,
check “Show Processes” strip at startup.

Show only applications

The Processes strip (as its name indicates) shows more than just running applications. It also
shows running processes, such as the File Sharing Extension. Check “Show only applications”
to limit the types of processes that appear in your Processes strip.

Always keep window on screen

Many users like to maintain their Processes strips in a specific location on their screen. The
Processes strip constantly resizes itself depending on which applications are currently running.
Checking the “Always keep strip on screen” option moves your Processes strip up on the
screen when it runs out of room to place new active applications.

Leaving this option off will ensure that your Processes strip always stays in the same location.
When it runs out of room, active processes will continue to be placed, but off-screen.

Alphabetize Process List

You can configure the list of the processes on the Processes strip to make the items appear in
alphabetical order.
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Hide other processes when switching

When this option is on and you click on a process in the processes strip, DragStrip will switch
to the process you chose and hide all other processes so that only the chosen application and
DragStrip are visible.

Hidden Processes

Hiding processes can be helpful in keeping your Processes strip less cluttered. To hide a
process:

1) Click “Add item...”

2) Select the process you don’t want to show in your Processes strip. Removing hidden 
processes to make them visible again is just as easy as hiding them.

STARTUP ACTIONS

Startup actions are helpful because when you startup your Macintosh you will want to see all
of your strips so you can get to your files.

Reopen strips automatically

Click on the “Reopen strips automatically” checkbox if you want DragStrip to open the strips
that were active when you last quit DragStrip.

Finder to front

After DragStrip is done launching, it will bring the Finder to the front and make it the active
process.

DOCUMENT LISTS

DragStrip stores references to each document that has been dropped on an application on a
button in a strip. These are seen as popup menus when you click on an application and hold
down the mouse button.

Documents to remember

You can modify the number of document references DragStrip will hold for each application by
using the “Documents to remember” popup menu. Your choices for this modification are
None, 5, 10, 15, 20, 25, 30, and Unlimited.
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FOLDER MENU

The Folder menu is hierarchical up to five levels deep. On color monitors, items in the popup
menu will appear in the color of their Finder labels.

Hide invisible items in popup menus

Your Macintosh stores certain files on your hard drive that are invisible. Files such as the
Desktop and File Sharing documents are invisible in the Finder. You can decide whether or 
not you want to see these items in DragStrip’s hierarchical menu function by checking the
“Hide invisible items in popup menus” checkbox.

Pop up when dragging over folders

This item ensures that when dragging an item onto a folder located on a strip, the popup
menu will appear. You can then put the item within the folder.

Menu Font and Size

You can change the default font and size of the popup menus here for folders and volumes. It
is a good idea to keep the font size small and pick a font that is easy to read.
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OPTIONS FOR STRIPS

As you have seen, DragStrip has many configurable options. Some of these are set as global
options for all strips and the DragStrip application, while others are options set specifically for
the currently active strip.

STRIP OPTIONS FOR “ACTIVE STRIP”

Anchoring a strip

Strips can be anchored to the bottom of the screen or to the right of the screen. This means
that when a strip changes size (e.g., button sizes, Processes strip grows/shrinks) it will remain
the same distance from the bottom or right side of the screen that it did when it was original-
ly placed. This is really handy for things such as the Processes strip. For example, you can
anchor it to the bottom of the screen when it is set to draw vertically and it will grow up and 
down again as processes are launched and quit.

Show name when cursor hovers over item (Tool Tips)

When a strip is configured to have only icons showing and no status bar, it is sometimes 
convenient to be able to see the name of the item that the cursor is over. When this option 
is turned on, a small box will appear below the item that the cursor is over showing the name
of the item. These boxes are often referred to as “Tool Tips”.

Float this window above all applications

When this checkbox is checked, the strip will remain in front of all windows, even in other
applications. This makes it possible to click on the strip without first bringing DragStrip to
front. When enabled, the strip will always cover windows in other applications so it is best to
do this with smaller strips or strips that are placed on your monitor where it will not interfere
with the content or scrollbars of other windows.

Variable buttons

The variable button style is configurable in the “Active strip” Options dialog box. Variable
options are only available for the following icon styles: Large Icon With Name, Small Icon 
With Name, No Icon With Name and, of course,Variable. If your strip icon style is variable
you can configure both its height and width. On the icon styles Large Icon With Name,
Small Icon With Name, and No Icon With Name, you can only change the width of the icon.
To change the size of a button, click in the “button” area and pull. You will be able to change
the size vertically and/or horizontally according to what type of button style you have chosen.
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STRIP COLORS FOR “ACTIVE STRIP”

For the Current page color, Status bar color, Status text color, and Button color click the 
colored box next to the item. This will bring up the Macintosh Color Picker. Note that if
“apply page color to buttons” is turned on, button color will be overridden with the current
page’s color.

The popup menu lets you choose which page you’re configuring. You can choose any of the
pages from the popup and the current pattern and page color will show up within the box.
The strip will also switch to that page so that you can see what your changes will look like if
you apply them.

Clicking the checkbox next to the pattern box enables the drawing of patterns on the page
background and optionally the buttons. You can choose a different pattern by clicking the up
or down arrows next to the pattern swatch. Even when the pattern is on, the page’s tab 
color is drawn in the page color, so it is a good idea to make your page color a complementary
color to your pattern.

You can apply colors to particular items on a strip from the Labels menu in DragStrip. The
Apply label color options on the preferences screen allow you to determine whether the 
strip button, the icon, both, or neither receive the color chosen from the Labels menu.

Apply page pattern/color to buttons lets you use whatever the page’s color (or pattern, if that
is selected above) as the background for buttons too. If you have one of the button styles that
has a name on it, like large icon with name, then the text will be drawn in a box that has the
page or button color behind it. This makes it easier to read the text on some patterns.

The patterns that DragStrip uses are stored in a file called “DragStrip Patterns” in the same
folder as DragStrip. When DragStrip is not running, you can add patterns to this file using a
resource editing program such as ResEdit. These patterns will then be available in the list of
patterns. When you first run DragStrip, it will attempt to import the patterns from the 
Desktop Pictures control panel. If that control panel is not available, you will not have very
many patterns to choose from.

NOTE: Patterns require MacOS version 8.0 or later. Users running MacOS versions 
earlier than 8.0 will not be able to configure patterns for pages.
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BUTTON FONT FOR “ACTIVE STRIP”

Set the font and font size for the text that appears in the buttons and the status bar by 
selecting them from the popup menus.

PROCESSES STRIP

Since the Processes strip can be set as either an active or default strip, the processes dialog
box is the same as the preferences dialog box. The processes dialog will only appear in the
“Active Strip” Options dialog when the processes strip is selected. Refer to the processes
strip in the Preferences section.

ITEM OPTIONS DIALOG

The Item Options dialog allows you to enter some text that is associated with an item and to
set a hotkey that will open the item at any time. This is a convenient way to launch frequently
used applications, or open common URLs, documents or folders. To set the hot key, click the
“Set...”  button, then type the key combination and the dialog will show you what keys will
open that item. You can clear a hot key by clicking “Set...”  and then pressing the Delete key.

DRAGSTRIP MENUS

Many of the configurable options on strips are available directly from menus.

OPTIONS MENU

The options menu has so many options that you can apply directly to the frontmost strip 
window that there are two modes, Simple Mode and Expert Mode. The only real difference is
the number of items that appear in the Options menu.

“Active Strip” Options 

“Active Strip” Options (where “Active Strip” is the name of the frontmost strip window) lets
you access the strip options dialog for the indicated strip (see above.)  

Item Options

Item Options opens the Item Options dialog, allowing you to set a hot key to open an item
and some comments that are associated with the item (see above.)  
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Strip Styles

DragStrip comes with several predefined strip styles. Styles are groups of settings that are
remembered and can be applied to other strips. The “Default” style is the one that is used
whenever you create a new strip. You can create other styles based on the settings in the
frontmost strip by selecting “Create Style From Current Strip...”  You can apply a style to any
strip by selecting that style’s name from the Strip Styles submenu. If you hold down the option
key, you will apply all of the stored strip settings for that style. Without the option key,
DragStrip only applies color information.

You can redefine the “Default” style by creating another style called “Default”. This way, you
can set a strip up the way you like it then create a style called “Default” and all new strips will
then appear just how you configured them.

Icon Style

DragStrip has six different icon styles for your strips. These are Large Icon, Large Icon With
Name, Small Icon, Small Icon With Name, and Variable.

The Variable button style is configurable in the “Active strip” Options dialog box. Variable
options are only available for the following icon styles: Large Icon With Name, Small Icon 
With Name, No Icon With Name, and of course Variable. If your strip icon style is Variable
you can configure both its height and width.

On the icon styles Large Icon With Name, Small Icon With Name, and No Icon With Name,
you can only change the width of the icon.

Button Style

You can change the look of the buttons that appear on your strip. There are several types to
choose from, including Raised, Beveled,Tiled, Embossed, Embossed Rounded, and None.

Status/Title Bar

Using these options, you can hide or show the status or title bar, date, time, and seconds for
the active strip. You can also choose to draw the strip vertically or horizontally.

Rotate Strip

Selecting this menu item will rotate the strip 90 degrees counter clockwise. Selecting Rotate
Strip again will return the strip to its normal position.

Clean Up

Clean Up allows you to shift the items on your strip around without having to move them
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each individually. You can access these Clean Up options from the Options menu 
under Clean Up. Clean Up choices are:

1) Normal, which will move all your items in a strip to be next to each other.

2) Slide items left, which will move all of your strip items to the left.

3) Slide items up, which will move all of your strip items up.

4) Alphabetically, which will sort the items by name.

Iconize

You can iconize a strip down to the size of one button by clicking the zoom box in the upper
right hand corner of the strip or by choosing this menu item.

Add Page...

Add Page allows you to add a new page to the strip. It will prompt you for a name for the
page, then add it and switch to it so you can begin adding items.

Rename Page...

Rename Page allows you to change the name of the current page. You can also rename the
current page by double clicking on a page tab.

Change Page Color...

Change Page Color lets you change the color that is associated with a page. You can also
change the page color but option double clicking on a page tab or using the DragStrip Color
Picker.

Remove Page

Remove Page deletes the current page and all of the items on it.

Renaming Items

You can rename items on the strip by selecting the item, then choosing “Rename Items” from
the Options menu.
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Document List

The Document List dialog is available after shift-clicking on a strip item. You edit the list of
items associated with the strip item and add, remove, make default, temporary, or make them
permanent.

Permanent items are items that you want to always be associated with the item on your strip.
If you make an item a default item, each time you launch that application with DragStrip the
default document will be opened.

To add a document to the popup menu:

1) Shift-click on a strip item that has documents associated with it.

2) Choose “Document list... “ from the Options menu.

3) Choose the items you want to Remove,Add, make Default,Temporary, or make Permanent.

4) Click “Done” when you are finished editing the list. You can also add items to the 
document list by clicking on them in the Finder and dragging them to the Document List 
dialog window.

Insert Row and Insert Column

You can also insert rows and columns into a strip by choosing Insert Row or Insert Column
from the Options menu and clicking the location where you wish to insert on the currently
active strip.

ACTIONS MENU

DragStrip allows the user to perform certain actions on one or many currently selected items
on a strip. Items on the Actions menu will be dimmed if there are no selected items on the
currently active strip.

You can shift-click items on a strip to select them. You can also choose “Select All” or 
“Select by Label” from the Edit menu to select items on a strip. (Selecting “Reverse” from the
Edit menu will unhighlight the current selection of the active strip and will select those items
that were not selected.) Selected items appear as “pressed” buttons. Choosing “Select None”
from the Edit menu will deselect all items on the active strip.

Open Selection

Choosing Open Selection opens or launches the selected item(s) on the active strip.
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Reveal In Finder

Choosing Reveal In Finder opens the enclosing folder for the selected DragStrip item(s) 
and selects them.

Get Info

Choosing Get Info will open the Finder Info box for the selected items on the active strip.

Verify Strip/Selection

When you delete a file that is represented on a DragStrip, the strip icon does not automatically
update. Choosing “Verify Strip” checks the legitimacy of all the items on the active strip. If
items on the active strip are selected,Verify Selection checks the legitimacy of the selected
items on the active strip. These commands check to see if the actual documents, folders, and
applications referenced still exist on your hard drive.

LABELS AND COLORS MENU

The labels menu lets you apply a label to individual items on a strip. To do this, select an item
or items by shift-clicking them, then select one of the labels from the menu. Once an item has
a label, you can select items with any label and perform actions on the selection.

WINDOWS MENU

The Windows menu shows the currently running strips. You can switch between strips that
are open by using the Command key and the strip number or by selecting the strip name from
this menu.

The DragStrip Color Picker

The Windows Menu also lets you open the Color Picker tool. The DragStrip Color Picker is a
window that opens and displays an array of colors. You can click on any of these colors and
drag them to a part of a strip. When you do this, the part of the strip you dropped the color
on will use that color. For example to change the color of a page tab, you can drag a color
from the DragStrip Color Picker and drop it on the page tab you want to change.

CONTEXTUAL MENUS

DragStrip has extensive support for contextual menus. This is often a quicker way of 
changing things on your strip than using the Options menu or the strip preferences dialog.

There are contextual menus for buttons, page tabs, process items, empty buttons and more.
When the control key is held down, the cursor will change to a contextual menu cursor to let
you know you can click now to get a contextual menu.
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SCRIPTING DRAGSTRIP

DragStrip includes extensive scripting support. For complete information, please visit:

http://www.aladdinsys.com/dragstrip/scripting.html 

DRAGSTRIP ADDITIONS

WHAT ARE DRAGSTRIP ADDITIONS?

DragStrip Additions are plug-in modules for DragStrip that allow you to increase DragStrip’s
functionality. They allow you to add functions to DragStrip without requiring an update to 
the main application. Additions can encompass many functions that you use all the time.
However, by installing them on your strip, you can access a variety of functions from only one
application, which makes your desktop easier to manage. Developers using languages such as
C and Pascal can write their own DragStrip Additions. A technical note about writing
DragStrip Additions is in the DragStrip folder on your hard drive.

USING ADDITIONS

DragStrip Additions reside as files on your hard disk. DragStrip Additions can only be activated
by dragging them onto your strip; they will not work by double-clicking on Addition documents
in the Finder.

Additions can behave in many different ways; Some Additions are popup menus, some respond
to single clicks, some just display information, and some do all of the above. Below are short 
descriptions of some of the Additions that came bundled with the 3.7 version of DragStrip.

Audio CD Player

If an audio compact disc is currently mounted, clicking the Audio CD Player icon on your strip
will alternately play and pause the audio CD. Clicking and holding the mouse button down will
display the Audio CD Player window giving volume controls, track controls, and an eject button.
Just drag your cursor over the appropriate controls to activate a function.

NOTE: The Audio CD Player only works with SCSI CD-ROM drives. IDE CD-ROM 
drives (such those in PowerBooks) are not currently supported.

Set Volume

Clicking and holding the mouse button down on this icon displays a menu letting you change
the system volume on your Macintosh. Clicking once on the Set Volume Addition displays the
Sound Control Panel.
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Set Monitor Depth

Clicking and holding the mouse button down on this icon displays a popup menu allowing you
to change the monitor depth on any monitor connected to your Macintosh. Choose the 
monitor by checking one of the “monitor #” choices at the bottom of the popup menu. The
number of monitors will not appear if you only have one monitor. Clicking once on the 
Monitors Addition will bring up the Monitors Control Panel.

Calendar

Clicking and holding the mouse button down displays a calendar window. This window allows
you to navigate to any month in any year, see the position of the day within the year, and view
the phase of the moon for that day.

Moon Phase

The Moon Addition constantly displays the current phase of the moon.

Show Memory Usage

The Show Memory Usage Addition graphically displays the current status of used and unused
memory. Clicking and holding down the mouse button displays a memory status window for
all of the currently running applications. Clicking once on the Show Memory Usage Addition
will bring up the Memory Control Panel.

Grouped Items

Grouped Items is an addition that allows you to add many items to a single DragStrip button,
and open them all with one click. You can add items to the Grouped Items Addition by dragging
any combination of files and folders onto its icon. The Grouped Items Addition will remember
these items, even after DragStrip quits.

To see the list of currently-configured items, click and hold on the button containing the
Grouped Items Addition and a list will pop up. Selecting an item will open just that item.
Holding down the “Delete” key while selecting an item will remove that item from the list.
If you just click on the icon, the Grouped Items Addition will attempt to mount and open all 
of the items in its list.

You can have multiple copies of the Grouped Items Addition on a strip. To differentiate
between them, paste a different icon on them and/or change the icon’s name using the 
“Rename Item” command in the Options menu.
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File Router

File Router is an Addition that allows you to copy files or folders to a destination with one
simple drag-and-drop. You can add destination folders to File Router by holding down the
“Option” key while dropping a folder or folders onto its icon. File Router will remember
these folders, even after DragStrip quits.

You can send a document, etc. to each destination folder by dropping it on that icon on the
strip. To see the list of currently-configured folders, click and hold on the button containing
File Router and a list will popup. Selecting an item will open that folder on your desktop.
Holding down the Delete key while selecting an item will remove that folder from the list.
If you just click on the item, File Router will attempt to mount and open all of the folders in 
its list.

Whenever you drop files, folders, applications, etc. on File Router without holding the “Option”
key down, it will attempt to copy the items you are dropping to all of the destination folders in
its list. If DragStrip is the frontmost application at the time of the drop and one of the 
destination folders is on an unmounted volume, File Router will ask you to connect to the
server or mount the volume. If DragStrip is not the frontmost application in this situation,
that folder will not have the items copied to it.

You can have multiple copies of the File Router Addition on a strip. To differentiate between
them, you can paste a different icon on them and/or change the icon’s name using the “Rename
Item” command in the Options menu.

International Clock

International Clock is an addition that displays the current time in many different cities around
the world. When you add International Clock to a strip, it will show you the current time for
wherever you currently are. If you click and hold on it, it will present a menu with many 
different cities around the world. When you select a city, International Clock will show you
the name of that city and the current time there. The International Clock addition will 
remember the chosen city, even after DragStrip quits.

NOTE: The menu can take a long time to pop up since there are so many cities. Be 
patient!  International Clock looks best with either a small named icon or no 
icon with name view. Some city names require the grid items to be very wide.
You can have multiple copies of the International Clock addition on a strip.

TickTalk

TickTalk is an addition that displays the current time in many different languages from around
the world...and beyond. Languages include English, French, Japanese, Spanish, Finnish, Babytalk,
Klingon, C, Pig Latin, and others! 

When you add TickTalk to a strip, it will show you the current time in English words (like
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“Nine Fifty-Two.”)  If you click and hold on it, it will present a menu with many different 
languages. When you select a language,TickTalk will show you the current time in that 
language. The TickTalk addition will remember the chosen language, even after DragStrip quits.

TickTalk looks best with either a small named icon or no icon with name view. Some languages
require the grid items to be very wide. You can have multiple copies of the TickTalk addition
on a strip.

Analog Clock

If you prefer the look of an analog clock, this Addition will display the current time with a 
multitude of clock face choices. To switch clock faces, click-and-hold on the addition once 
you have installed it onto a strip and choose a different face from the popup menu.

CONTROL STRIP MODULES

Control Strip is a desktop utility from Apple Computer. Control Strip has modules that 
perform certain functions much in the same way that DragStrip Additions do. Unlike 
DragStrip however, Control Strip does not have a drag and drop launcher interface. In 
addition, unlike Control Strip, DragStrip does not require restarting to install modules.

Many Control Strip modules are available from third-party developers (especially over the
Internet.)  In order to allow you to take maximum advantage of all available extensible 
modules, DragStrip lets you use Control Strip modules with strips as well as DragStrip 
Additions.

Install Control Strip modules as you would DragStrip Additions by dragging and dropping the
Control Strip module document onto an empty button on your strip or option-clicking on a
blank strip button.

DragStrip buttons are of a fixed size. Some Control Strip modules may try and draw 
themselves larger than a DragStrip button. In this case not all of the modules’ graphics will be
visible. To compensate for the size of the graphics, use the Variable icon style to make a button
large enough to fit the Control Strip module.

WRITING ADDITIONS

One of DragStrip’s most powerful features is its extensibility through DragStrip Additions.
Additions are stand-alone code resources that allow special behavior when they are clicked or
when items are dropped upon them. Creating Additions is a very simple process.

A technical note about writing DragStrip Additions is located within the DragStrip folder on
your Macintosh hard drive. This technical note includes some sample Addition code and 
information on how to write additions.
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TIPS AND TRICKS

DragStrip has a huge number of time-saving features built into it. Here is where you will find
information on many of the “hidden” secrets of DragStrip!

• Control-clicking any part of a strip brings up a contextual menu that lets you do all sorts 
of things to strips, pages and the items on them.

• The contextual menu for page tabs lets you reorder the tabs by shifting the current page 
tab to the left or to the right. This is the only way you can reorder them.

• Command-clicking a file item reveals that item in the Finder.

• Shift-clicking a button selects it. Most operations that can be performed on a single 
button, can also be performed on a selection of buttons.

• Hitting the “Delete” key will ask if you want to delete the currently selected item. If you 
say “OK”, the item will be deleted. If it’s an item on the Processes strip, the application 
will quit. (Note: removing items from strips does not delete the item in the Finder.)

• Hitting option-delete will delete the item or selection without asking. If it’s an item on the
Processes strip, the application will quit immediately.

• Dragging an item from a strip to the Finder trash can will delete the item from the strip,
or quit an application if you dragged it from the processes strip.

• Dragging an item to a Finder window will create an alias to it there.

• Option clicking an item in the processes strip will hide that application’s windows. If it is 
already hidden, option-clicking it will show the application’s windows.

• Shift-option-clicking an item in the processes strip will hide all applications except the 
application you clicked on in DragStrip.

• Holding the option key when selecting an item from one of the folder or document list 
popup menus will change the cursor to a document icon. If you click on a folder, it will 
copy the selected item to the folder. If you click on an application, it will launch the appli
cation with the selected item. If you click on an empty button on a strip, you will add the 
item to the strip.

• Selecting option-tab will switch to the next page on the frontmost strip. If the current 
page is the last page, it will go to the first page. Typing option-shift-tab will go to the 
previous page.
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• Typing the first few letters of an item’s name will select that item.

• Selecting tab will show the next item in the strip alphabetically. Shift-tab goes in the 
opposite direction.

• The arrow keys also work for navigating around the buttons on strips.

• Hitting the enter key opens the current selection.

• Command-Control clicking anywhere in a window lets you drag the window around.
This should work in any window in DragStrip, except for the about box.

• Holding down the command key while dragging a window’s title bar moves the window 
without bringing it to the front. This is actually true of most Macintosh applications, but 
many people don’t know this.

• Holding down the option key while applying a style to a strip will not only apply the 
colors, but also all of the other strip information too. This includes button and icon styles 
as well as page tab and status bar positions.

• Option-clicking an empty button will bring up the standard file chooser to let you select a 
file or folder to add to that empty location.

• Double-clicking a page tab lets you change its name.

• Option-double-clicking a page tab lets you change its color.

• Double-clicking a color in the DragStrip Color Picker tool lets you change the colors in 
the palette.

• Holding down the “Delete” key while selecting an item from the popup document list 
menu will delete that item from the document list for that application. The same thing 
works for the Grouped Items and File Router additions.

• Clicking and holding the mouse down on an item in the Processes strip pops up the same 
document list for that application as you get in a ‘regular’ strip.

• Enabling “Show name when cursor hovers over item (ToolTips)” pops up a little window 
over items when the cursor sits there for a little while. This is a great way of finding out 
which folder you are over if the status bar is hidden, since folders often look alike.

• Tool tips work when you are dragging too.

• When you drag over a folder, if you hold the mouse still for a little bit, the folder will pop 
up and you can enter into the hierarchical popup menu. Dropping a file on an application 
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launches that application, dropping the item in other places will copy it to the appropriate 
folder.

• DragStrip can store text and pictures (and sounds, and URLS...) You can drop a phone 
number on a strip and it will keep it handy for you. You could even create an entire page 
of phone numbers, or addresses, or urls, or pictures of your children, or your pet, or your 
car, or your house, or... well, you get the picture.

• You can drop ControlStrip modules on a strip and they will function just like DragStrip 
Additions do. It works best if ControlStrip is NOT running on your Macintosh, since 
ControlStrip assumes that its modules will only pop up menus wherever the Control Strip
bar is running.

• If you really like the appearance of a strip you have created, create a new strip style based 
on it and name it “Default” (without the quotes). Then whenever you create a new strip, it
will have the same properties and colors.

• In the Strip Options panel of the Strip Options dialog, holding down the option key while 
clicking pops up a menu of widths when you can configure the width or height of a button.

• The document list window supports dragging files into the list from the Finder.

• When a file is set as the “Default” in the document list window, launching that application 
from DragStrip will always open that document automatically.

• You can rearrange the items on your strip easily by choosing one of the four “Clean Up” 
options from under the Options menu.

• You can make DragStrip always start up when you start up your Macintosh by selecting 
“Install...” from the File menu.

• You can drag on to an iconized strip and it will expand to accept the drag. When you 
finish your drag, it will iconize again.

• If you click an iconized strip, it will zoom to full size until you switch out of DragStrip, then
it will iconize again.
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