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New…
This command creates a new project.

To create a new project:

1. Choose New… from the File menu.

(If you have made any changes to an open project, a dialog box opens 
and prompts you to save the changes, then the project closes.)

A directory dialog box, as shown in Figure 1.1, opens.

2. Open the folder (or create a new folder) where the new project 
file will be stored.

3. Replace the default name by typing a name for the new project 
file (unless you want to use the default).

4. Either click Save or press Return.

Another directory dialog box, as shown in Figure 1.2, opens, which 
allows you to add models to the project.

w
You do not have to add models to the project at this time. Models 
can be added to a project at any time, as discussed in the sections 
“Add > Model…” (page 1-12) and “Add > Import…” (page 1-22).

Figure 1.1   Directory dialog box used to create a new project
The ElectricImage™ Reference 1-3
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5. If you want to add a model to the project at this time, go on to 
Step 6 now.

If you do not want to add a model at this time, click Done.

The ElectricImage workspace, comprised of the World View and 
Camera View windows, opens. For an explanation of these windows 
and their use, refer to Chapter 6: The World View Windows and 
Chapter 7: The Camera View Window.

6. Open the folder where the model is located (if necessary).

w
ElectricImage works only with models in the FACT format (to see 
a listing of all FACT files in the directory dialog box, click See all 
FACT files), however it is capable of converting models from the 
most popular formats into the FACT format so that they can be 
used in ElectricImage projects.

7. If you want to add a FACT format file, go on to Step 11 now.

If you want to add a non-FACT format file, click Import.

A directory dialog box, as shown in Figure 1.3, opens.

8. Open the folder where the model is located (if necessary).

Figure 1.2   Directory dialog box used to add a model to a project
1-4 ElectricImage™ Animation System
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9. If the model is not listed in the directory, either click the Show 
All File Types check box or select the correct format from the 
Type pop-up menu.

w
Most files can be opened with the Automatic file format (the 
default in the Type pop-up menu). Figure 1.19 (page 1-23) provides 
a list of the file formats that ElectricImage can import.

10. Use the controls in the dialog box to select import options (if 
desired). For an explanation of these controls, refer to the 
section “Import Options” (page 1-25).

11. Click on the model filename in the directory, and click Add.

If the model contains a single group only, or two or more groups that 
are hierarchically linked, it is automatically added to the project and 
the directory dialog box reopens to allow you to add another model to 
the project (go on to Step 13 now).

If the model contains two or more groups that are not hierarchically 
linked, an alert dialog box, as shown in Figure 1.4 (page 1-6), opens, 
allowing you to create a hierarchy for the groups.

w
You do not have to create a hierarchy at this time. Hierarchies can 
be created at any time by using the Link to Parent tool, as 
discussed in the section “Link to Parent” (page 5-18) in 
Chapter 5: The Tools Menu Commands or the section “The Link to 
Parent Tool” (page 19-19) in Chapter 19: The Tool Palette.

Figure 1.3   Dialog box used to convert a model to FACT format
The ElectricImage™ Reference 1-5
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12. If you want to create a hierarchy at this time, choose the parent 
group from the Parent Group pop-up menu and click Select.

If you do not want to create a hierarchy, click Separate.

The model is added to the project and the directory dialog box reopens 
to allow you to add another model to the project.

13. If you want to add another model to the project, repeat the steps 
for selecting a model.

If you do not want to add another model, click Done or Cancel.

The ElectricImage workspace, comprised of the World View and 
Camera View windows, opens. For an explanation of these windows 
and their use, refer to Chapter 6: The World View Windows and 
Chapter 7: The Camera View Window.

Figure 1.4   Alert dialog box for a model not hierarchically structured
1-6 ElectricImage™ Animation System
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Open…
This command opens a previously created project.

To open a previously created project:

1. Choose Open… from the File menu.

(If you have made any changes to an open project, a dialog box opens 
and prompts you to save the changes, then the project closes.)

A directory dialog box, as shown in Figure 1.5, opens.

2. Open the folder where the project is located (if necessary).

3. Click on the project file and click Open.

The project starts loading and, if all project files are located, the 
ElectricImage workspace, comprised of the World View and Camera 
View windows, opens. For an explanation of these windows and their 
use, refer to Chapter 6: The World View Windows and 
Chapter 7: The Camera View Window.

If, however, the project contains a model that cannot be found, an 
alert dialog box, as shown in Figure 1.6, opens (go on to Step 4 now).

If the project contains a texture that cannot be found, an alert dialog 
box, as shown in Figure 1.7, opens (go on to Step 5 now).

Figure 1.5   Directory dialog box used to open a project
The ElectricImage™ Reference 1-7
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4. At this point you can either:

• Click Cancel to cancel the Open… command.

• Attempt to find the model in a different folder or on a 
different disk. To do so, open the folder where the model is 
located, select the model file and click Find.

• Open the project with a different model to replace the 
missing model. To do so, select a different model file and 
click Find.

• Click Remove to open the project, removing the missing 
model from the project. (Removing the model will change 
the hierarchical structure of the project.)

If you do not cancel the Open… command, the project continues 
loading and, if all remaining files are located, the ElectricImage 
workspace, comprised of the World View and Camera View windows, 
opens. For an explanation of these windows and their use, refer to 
Chapter 6: The World View Windows and Chapter 7: The Camera 
View Window.

If the project contains a texture file that cannot be found, an alert 
dialog box, as shown in Figure 1.7 (page 1-9), opens.

Figure 1.6   Alert dialog box when a model is not found
1-8 ElectricImage™ Animation System
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5. At this point, you can either:

• Click Cancel to cancel the Open… command.

• Attempt to find the Texture in a different folder or on a 
different disk. To do so, open the folder where the texture is 
located, select the texture file and click Find.

• Open the project with a different texture to replace the 
missing texture. To do so, select a different texture file and 
click Find.

• Click Skip to open the project with the missing texture 
disabled.

• Click Skip All to open the project with all missing textures 
disabled.

• Click Remove to open the project, removing the missing 
texture from the project.

If you do not cancel the Open… command, the project continues 
loading and the ElectricImage workspace, comprised of the World 
View and Camera View windows, opens. For an explanation of these 
windows and their use, refer to Chapter 7: The Camera View Window 
and Chapter 7: The Camera View Window.

Figure 1.7   Alert dialog box when a texture is not found
The ElectricImage™ Reference 1-9
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Close
This command closes the current project.

To close the current project:

1. Choose Close from the File menu.

(If you have made any changes to the current project, a dialog box 
opens and prompts you to save the changes.)

The current project closes, but ElectricImage remains open.

2. At this point, you can:

• Create a new project, as discussed in the section “New…” 
(page 1-3).

• Open a previously created project, as discussed in the 
section “Open…” (page 1-7).

• Display a QuickTime movie, as discussed in the section 
“Display…” (page 1-11).

• Transfer to the Projector application, as discussed in the 
section “Projector” (page 1-56).

• Quit the ElectricImage Animation System, as discussed in 
the section “Quit” (page 1-57).
1-10 ElectricImage™ Animation System
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Display…
This command displays a QuickTime movie in a separate window.

w
The Display… command provides a way of watching a QuickTime 

movie created by the Camera window’s preview function, as discussed 
in the section “Previewing Animations” (page 7-9) in Chapter 7: The 
Camera View Window.

To display a QuickTime movie:

1. Choose Display… from the File menu.

A directory dialog box, as shown in Figure 1.8, opens.

2. Open the folder where the QuickTime movie is located (if 
necessary).

3. Click on the movie file and click Open.

A standard Macintosh QuickTime display window opens and the 
QuickTime movie begins playing. You can control the display of the 
movie with the window’s slider bars.

4. When done, click the window’s close box.

Figure 1.8   Directory dialog box used to display a QuickTime® movie
The ElectricImage™ Reference 1-11
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Add > Model…
This command adds a model to the current project.

w
This command is intended primarily for adding models that are in the 
ElectricImage FACT format (see the note below). To add a non-FACT 
format model, you can still use this command, or use the Add > Import 
command, explained in the section “Add > Import…” (page 1-22).

To add a model to the current project:

1. Choose Add > then Model… from the File menu.

A directory dialog box, as shown in Figure 1.9, opens.

2. Open the folder where the model is located (if necessary).

3. If you want to add a FACT format file, go on to Step 4 now.

If you want to add a non-FACT format file, click Import.

Refer to the section “Add > Import…” (page 1-22) for direction on 
importing non-FACT format files.

4. Click on the model filename in the directory, and click Add.

Figure 1.9   Directory dialog box used to add a model to a project
1-12 ElectricImage™ Animation System
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If the model contains a single group only, or two or more groups that 
are hierarchically linked, it is automatically added to the project and 
the directory dialog box reopens to allow you to add another model to 
the project (go on to Step 6 now).

If the model contains two or more groups that are not hierarchically 
linked, an alert dialog box, as shown in Figure 1.10, opens, allowing 
you to create a hierarchy for the groups.

w
You do not have to create a hierarchy at this time. Hierarchies can 
be created at any time by using the Link to Parent tool, as 
discussed in the section “Link to Parent” (page 5-18) in 
Chapter 5: The Tools Menu Commands or the section “The Link to 
Parent Tool” (page 19-19) in Chapter 19: The Tool Palette.

5. If you want to create a hierarchy at this time, choose the parent 
group from the Parent Group pop-up menu and click Select.

If you do not want to create a hierarchy, click Separate.

The model is added to the project and the directory dialog box reopens 
to allow you to add another model to the project.

6. If you want to add another model to the project, repeat the steps 
for selecting a model.

If you do not want to add another model, click Done or Cancel.

Figure 1.10   Alert dialog box for a model not hierarchically structured
The ElectricImage™ Reference 1-13
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Add > Sound…
This command adds a sound file to the project.

w
Sound files must be in either AIFF or QuickTime format. For more 
information on using sound files, refer to Chapter 12: The Sound Info 
Window.

To add a sound file to the current project:

1. Choose Add > then Sound… from the File menu.

A directory dialog box, as shown in Figure 1.11, opens.

2. Open the folder where the sound file is located (if necessary).

3. To see a listing of all AIFF format files, click the See all AIFF files 
button.

4. To preview sounds, click the Preview button.

5. Click on the sound file and click Add.

Figure 1.11   Directory Dialog box used to add a sound file to a project
1-14 ElectricImage™ Animation System
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Add > Record Sound…
This command enables you to record a sound and add it to the 
project.

To record a sound file to add to the current project:

1. Choose Add > then Record Sound… from the File menu.

A dialog box, as shown in Figure 1.12, opens.

2. Record the sound.

3. To save the recorded sound, click Save or press Return.

A directory dialog box opens for you to save the sound file, and the file 
is added to the project.

Figure 1.12    Dialog box used to record a sound file to add to a project
The ElectricImage™ Reference 1-15
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Add > Light…
This command adds a light to the project.

To add a light to the current project:

1. Choose Add > then Light… from the File menu.

The mouse arrow changes to a light icon.

2. Position the light icon in any of the World View windows and 
click the mouse.

The light is added to the project and can be repositioned and 
configured as desired.

w
For an explanation of the various settings and attributes for lights 
in ElectricImage, refer to Chapter 11: The Light Info Window.
1-16 ElectricImage™ Animation System
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Add > Font…
This command creates a font model in ElectricImage FACT format 
and adds it to the current project.

To create a font model and add it to the current project:

1. Choose Add > then Font… from the File menu.

A dialog box, as shown in Figure 1.13, opens.

2. Open the folder where the font is located.

3. If the typeface is not listed in the directory, click the Show All 
Types check box. Only PostScript Type 1 fonts are displayed in 
the file directory.

4. In the large edit box beneath the directory, type the characters 
to be converted into a model. (To convert the entire alphabet, 
click the ß button on the upper left side of the dialog box.)

5. Use the controls in the dialog box to select modelling options (if 
desired). For an explanation of these controls, refer to the 
section “Font Modelling Options” (page 1-18).

6. Click on the typeface in the directory and click Open.

The font model is created and added to the current project.

Figure 1.13   Dialog box used to create a font model
The ElectricImage™ Reference 1-17
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Font Modelling Options

Smooth This edit box contains a value that determines the angle at which a 
hard edge appears between polygons when using smooth shading 
(see Fix Smooth Shading, below). The default is 40˚.

This feature works by comparing the angle of the polygon to the 
angle of the polygon next to it. If the angle is greater than the value 
in the Smooth edit box, the polygon will shade as a hard edge. If the 
angle is less than the value in the Max Angle edit box, the edge will 
smooth shade.

Fix Smooth Shading This check box option, when enabled, creates hard edges when 
smooth shading a model (see Smooth, above).

Max Angle This edit box contains a value that determines whether the font 
outlines are sampled in a course or smooth fashion. The default angle 
is 4˚, meaning that the outline will be sampled so that there is no 
angle greater than 4˚ along the edge of the resulting model, providing 
in a fairly smooth font. The larger the angle, the courser the font. If 
the font you are working with has very shallow curves, a smaller Max 
Angle is advised, but be aware that this will create a far greater 
number of polygons.

Space This edit box contains a value that adjusts the width between the 
characters in the font. The value of the spacing size is in units, 
relative to the other values found in the Extrude and Bevel Size edit 
boxes.

w
Occasionally, when creating large, outside bevels, letters will overlap 
with each other. To adjust inter-character spacing, enter the result of 
twice the bevel size (bevel size * 2) into the Space edit box. The letters 
will just touch, but not overlap.

Extrude This edit box contains a value that gives a font depth. The default 
distance for the extrusion is 300 units (units are relative to the other 
values found in the Space and Bevel Size edit boxes). To make a font 
flat, set the value in the Extrude edit box to 0.
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Bevel Size This edit box contains a value that sets the size of the bevel (the 
default is 0 for no bevel). The value of the bevel size is in units 
relative to the other values found in the Extrude (page 1-18) and 
Space (page 1-18) edit boxes. A negative value will bevel inside the 
original font outline, and a positive value will bevel outside the 
original outline, as shown in Figure 1.14.

w
Larger bevels can sometimes twist back into themselves, causing the 
absence of front faces, so be conscious of bevel size. Tolerances are 
reached faster if you bevel inward than if you bevel outward.

In order for the bevel to be straight, the Fillet Sides edit box 
(page 1-20) needs to be set to zero (the default value).

Bevel Angle This edit box contains a value that works in conjunction with the 
Bevel Size edit box to set the degree to which the bevel will occur on 
the font, as viewed from the side.

The default is 45˚; an angle smaller than 45˚ will cause the bevel to 
recede towards the center of the model (as viewed from the side); an 
angle larger than 45˚ will cause the bevel to advance away from the 
center (as viewed from the side), as shown in Figure 1.15.

Negative size value 0 size value (no bevel) Positive size value

Figure 1.14   Bevel sizes (side views)

Bevel angle < 45° Default bevel angle (45°) Bevel angle > 45°

Figure 1.15   Bevel angles (side view)
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Fillet Sides This edit box contains a value that creates a rounded bevel. You can 
add a rounded edge to the font instead of an angled bevel by 
increasing the value in the Fillet Sides edit box to a value larger than 
zero. The value determines how many segments are to be in the fillet. 
For a good rounded appearance, a number of 6 or 8 is sufficient, as 
shown in Figure 1.16.

w
Filleting adds many polygons to the model, and, as a result, the font 
model will take significantly longer to create.

Create Back Bevels This check box option, when enabled, creates a font model with back 
facing bevels as well as front facing bevels.

Reverse Back Bevel This check box option, when enabled, reverses the angle of the back 
bevel so that it is opposite the front bevel. This can result in a 
“stepped,” pyramid-like bevel or fillet, as shown in Figure 1.17.

Calculate Flexing This check box option, when enabled, causes subtle curves to be 
added to what are actually straight lines, utilizing flexing 
information contained in Type 1 fonts. If you do not wish to have 
the flexing in a 3D font model, uncheck this box.

Figure 1.16   
Side view of rounded bevel

created with Fillet Sides value of 6

Figure 1.17   
Right side view of
reverse back bevel
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Group Whole Characters This check box option, when enabled, causes all faces of individual 
characters in the font model to be grouped together as single groups 
(as opposed to the default grouping, which has the extruded sides as 
the parent group to the front face, back face, front bevel and back 
bevel).

Group Similar Sides This check box option, when enabled, causes similar faces of all 
characters in the font model to be grouped together, such as both 
bevels in one group and both faces in another group (as opposed to 
the default grouping, which has the extruded sides as the parent 
group to the front face, back face, front bevel and back bevel).
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Add > Import…
This command imports a model into the current project, converting 
non-FACT and non-standard FACT files to the FACT format required 
by ElectricImage.

w
If the model you wish to add to the project is already in the 
ElectricImage FACT format, you do not need to use this command. 
Instead, use “Add > Model…” (page 1-12).

To import a model into the current project:

1. Choose Add > then Import… from the File menu.

A dialog box, as shown in Figure 1.18, opens.

2. Open the folder where the model is located.

3. If the model is not listed in the directory, either click the Show 
All File Types check box or select the correct format from the 
Type pop-up menu.

w
Most files can be opened with the Automatic file format (the 
default in the Type pop-up menu). 

Figure 1.19 (page 1-23) provides a list of the file formats that 
ElectricImage can import.

Figure 1.18   Dialog box used to convert a model to FACT format
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Figure 1.19   Table of formats that 
ElectricImage can import 

Alias Sketch! (Styleguide export)

Architrion II

Autodesk 3D Studio

Cad-3D (an Atari format)

Cubicomp

Cyberware 

DXF (Macintosh and PC DXF files are supported) 

Dynaware—Dynaperspective

FACT—ElectricImage model file format

Filmroll

Generic (a text file) 

Lightwave (Newtek Video Toaster™)

MacConcept

Mac 3D (text files only) 

Movie.BYU

MPS Demo (Evans & Sutherland) 

OFF (.geom)—Digital Equipment Corporation

OSU (.DETail)—Ohio State University

Phoenix 3D

Sculpt 3D (Amiga and Macintosh) 

Super 3D (text file only) 

Swivel 3D 

TWGES (for VersaCAD/PC)

Videoscape (an Amiga file format) 

Wavefront .OBJ 

Zing (Pro 3D)

Zoom

3D Turbo

3DGF Binary (Macromind 3D)
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4. Use the controls in the dialog box to select import options (if 
desired). For an explanation of these controls, refer to the 
section “Import Options” (page 1-25).

5. Click on the model file and click Open.

The model is converted to FACT format and added to the current 
project.

w
If the model selected is in Cyberware format, a dialog box opens for you 
to set import preferences. For information on these controls, refer to the 
section “Cyberware Import Preferences” (page 1-29).
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Import Options

Combine Groups This check box option, when enabled, takes a model file with many 
groups and places all the entities into a single group in the file. If the 
result is saved as a FACT file, all of the entities are placed in a single 
group; if the result is saved as a DXF file, all of the entities are placed 
in a single layer, etc.

w
This option does not smooth shade across merged groups; you must 
re-import the saved FACT file to smooth shade the entire group.

Combine Polygons This check box option, when enabled, searches the database for 
duplicate polygons—that is, polygons occupying the exact same 
space. This can be a time consuming process if you are converting 
large models, and only needs to be used if there is some kind of 
shading irregularity (if a model appears to have a consistent shading 
glitch, it may have a duplicate polygon in the area of the glitch). Use 
this option to correct the problem. You can select Get Info from the 
File menu before and after to check the polygon count and see if any 
polygons were removed.

Merge Polygons This check box option, when enabled, sorts through the database, 
locating all co-planar polygons (polygons which lie on the same 
plane) and fuse them together, forming one complex polygon. Its 
effects can be modified, depending upon your choice of the 
sub-options.

• The edit box contains a value for the angle tolerance to be used 
when determining whether or not polygons are co-planar. The 
default is set to 0.5°.

• The Match Colors radio button option, when selected, prevents 
polygons with different colors from being merged, when using 
the Merge Polygons option. (This defaults to on, since you would 
most likely wish to retain colored polygons. If for some reason 
you not wish to retain unique colors, de-select the button.)
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• The Match Edges radio button option, when selected, will force 
both ends of an edge to share points before the two polygons can 
be merged.

Note that turning off this feature allows two polygons to be 
merged if they share only one point and part of one edge.

Merge Edges This check box option, when enabled, forces edges that fall within 
the angle tolerance (as indicated in the edit box) to merge. For 
example, a polygon with three points in a row on a straight edge 
would lose the middle point.

Fix Cone Point Shading This check box option, when enabled, adjusts the apex of cones so 
that cones and cone–like shapes will shade correctly (if not enabled, 
seams will appear). If your data contains one or more cone–like 
entities, you may wish to turn this option on. Most models don’t 
need this option, so it defaults to off to save time.

Flat Complex Polygons This check box option, when enabled, prevents shading artifacts 
(e.g., wrinkles) from appearing on complex polygons (a polygon with 
more than four vertices). It defaults to on.

Combine Coordinates This check box option, when enabled, ensures that polygons which 
share edges also share vertices. You can also use it to seal vertices, that 
is, weld points together, which fall within the tolerance indicated in 
the Distance edit box, to the left of the Combine Coordinates check 
box. This is an optimization feature which ensures that your models 
will smooth shade correctly.

Fix Smooth Shading This check box option, when enabled, determines the angle at which 
a hard edge appears between polygons. The default is 40˚, which 
appears in the Angle edit box to the left of the Fix Smooth Shading 
check box.

This feature works by comparing the angle of the polygon to the 
angle of the polygon next to it. If the angle is greater than the value 
in the Angle edit box, the polygon will shade as a hard edge. If the 
angle is less than the value in the Angle edit box, the edge will 
smooth shade. You may change the angle in the edit box to suit the 
model you are importing. If there is a question as to what the correct 
angle should be, try a test rendering in ElectricImage.
1-26 ElectricImage™ Animation System



Add > Import…

Book  Page 27  Friday, July 21, 2000  4:18 PM
Preferences This pop-up menu provides a means of setting preferences for 
importing DXF and Alias Sketch files.

DXF…

Choosing DXF opens a dialog box, as shown in Figure 1.20.

• Build Groups From

These radio buttons offer a choice of building groups from layers, 
blocks or colors. The Colors option puts all elements of the same 
color into a single group.

• Convert Polylines To

These radio buttons offer a choice of methods for converting 
closed polylines into complex polygons. The Automatic option 
will examine the file and attempt to identify which method to 
use. Otherwise, you can select the Lines or Polygons methods. 
The Lines options always converts closed polylines to lines as 
defined by Autodesk. The Polygons option always converts closed 
polylines to polygons.

w
These choices are provided so that DXF files that do not follow the 
Autodesk standard can be imported into ElectricImage.

• Exchange Y and Z coordinates

This check box, when enabled, causes the model to be imported 
with its Y and Z coordinates exchanged (useful for models 
created in programs that use different 3D coordinate 
orientations).

Figure 1.20   Dialog box to set DXF file import preferences
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Alias Sketch!…

Choosing Alias Sketch! opens a dialog box, as shown in Figure 1.21.

The Surface Edges edit box contains a value for the number of edges 
to use in breaking up splines and patches when converting them to 
polygons.

Figure 1.21   Dialog box to set Alias Sketch file import preferences
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Cyberware Import Preferences

When a Cyberware model is imported, a dialog box, as shown in 
Figure 1.22, opens.

Horizontal Points This is the number of horizontal point samples in the file.

Horizontal Samples This is the number of horizontal samples in the output polygon mesh 
(calculated using the horizontal minimum, maximum and step 
values).

Vertical Points This is the number of vertical point samples in the file.

Vertical Samples This is the number of vertical samples in the output polygon mesh 
(calculated using the vertical minimum, maximum and step values).

Horizontal Min This edit box contains a value for the minimum horizontal range of 
sampled points for conversion to a polygon mesh. The minimum 
allowable value is zero.

Horizontal Max This edit box contains a value for the maximum horizontal range of 
sampled points for conversion to a polygon mesh. The maximum 
allowable value is the number of horizontal points in the file minus 1.

Figure 1.22   Dialog box used to set Cyberware import preferences
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Horizontal Step This edit box contains a value for the number of points to skip over 
for each horizontal vertex of the mesh. This option is provided to 
reduce the total number of generated polygons.

Vertical Min This edit box contains a value for the minimum vertical range of 
sampled points for conversion to a polygon mesh. The minimum 
allowable value is zero.

Vertical Max This edit box contains a value for the maximum vertical range of 
sampled points for conversion to a polygon mesh. The maximum 
allowable value is the number of vertical points in the file minus 1.

Vertical Step This edit box contains a value for the number of points to skip over 
for each vertical vertex of the mesh. This option is provided to reduce 
the total number of generated polygons.

Data Offset This edit box contains a value used to create wrinkled spheres and 
cylinders or to change the base altitude of terrain maps.

Data Scale This edit box contains a value used to modify the altitude of the 
polygon mesh vertices.

Sample Points This radio button option, when enabled, ignores skipped points, 
creating a more precise mesh (but producing more jagged results).

Average Points This radio button option, when enabled, averages skipped points, 
creating a smoother mesh (recommended when either the horizontal 
or vertical step is greater than zero).

Build Triangles This radio button option, when enabled, converts the imported mesh 
to triangles.

Build Quadrangles This radio button option, when enabled, converts the mesh to 
quadrangles. This is the recommended option because fewer 
polygons are created and they look better when rendered.

Strip Bad Points This check box option, when enabled, will not generate polygons 
from points which were not correctly sampled.

Data Format This information indicates the type of points in the Cyberware 
file—cartesian, cylindrical or spherical.
1-30 ElectricImage™ Animation System



Add > Mesh…

Book  Page 31  Friday, July 21, 2000  4:18 PM
Add > Mesh…
This command adds the Mesh Generator to the project. The Mesh 
Generator is used to animate various shape transformations, 
primarily a plane into a sphere (or vice versa).

w
This command will only appear in the File menu if the Mesh Generator 
plug-in is stored in the EI Sockets folder. The Mesh Generator will then 
be accessible from the Object palette as well.

To add the Mesh Generator to the project:

1. Choose Add > then Mesh… from the File menu.

A dialog box, as shown in Figure 1.23, opens.

2. Select the mesh type, specify its attributes, and either click OK or 
press Return.

w
For more information on the use of the Mesh Generator plug-in, 
refer to “The Mesh Generator” (page 20-6) in Chapter 20: The 
Object Palette.

Figure 1.23   Mesh Generator dialog box
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Add > Mr. Nitro™…
This command adds the Mr. Nitro™ special effect to the project. 
Mr. Nitro™ is used to animate realistic explosions of models.

w
This command will only appear in the File menu if the Mr. Nitro™ 
plug-in is stored in the EI Sockets folder. Mr. Nitro™ will then be 
accessible from the Object palette as well.

To add the Mr. Nitro™ special effect to the project:

1. Choose Add > then Mr. Nitro™… from the File menu.

A dialog box, as shown in Figure 1.24, opens.

2. Specify the attributes of the explosion, and either click OK or 
press Return.

w
For more information on the use of the Mr. Nitro™ plug-in, refer to 
“Mr. Nitro™” (page 20-9) in Chapter 20: The Object Palette.

Figure 1.24   Mr. Nitro™ dialog box
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Add > Particle…
This command adds the Particle Generator to the project. The 
Particle Generator is used to animate special effects such as sparks, 
jets of fire, and fountains or streams of water.

w
This command will only appear in the File menu if the Particle 
Generator plug-in is stored in the EI Sockets folder. The Particle 
Generator will then be accessible from the Object palette as well.

To add the Particle Generator to the project:

1. Choose Add > then Particle… from the File menu.

A dialog box, as shown in Figure 1.25, opens.

2. Specify the attributes of the particle generator, and either click 
OK or press Return.

w
For more information on the use of the Particle Generator plug-in, 
refer to “The Particle Generator” (page 20-13) in Chapter 20: The 
Object Palette.

Figure 1.25   Particle Generator dialog box
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Add > Standard Shape…
This command adds a standard shape (or primitive) to the project. 
Standard shapes include planes, cubes, cylinders, cones and spheres.

w
This command will only appear in the File menu if the Standard 
Shapes plug-in is stored in the EI Sockets folder. Standard Shapes will 
then be accessible from the Object palette as well.

To add a standard shape to the project:

1. Choose Add > then Standard Shape… from the File menu.

A dialog box, as shown in Figure 1.26, opens.

2. Choose the type of shape, specify its attributes, and either click 
OK or press Return.

w
For more information on the use of the Standard Shapes plug-in, 
refer to “Standard Shapes” (page 20-17) in Chapter 20: The Object 
Palette.

Figure 1.26   Standard Shapes dialog box
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Save Model > FACT…
This command creates a new model in FACT format from selected 
model(s) in the current project.

To save a model:

1. Select the model(s) to be saved into a new model.

2. Choose Save Model > then FACT… from the File menu.

A dialog box, as shown in Figure 1.27, opens.

3. Specify whether or not you want to preserve a model’s 
hierarchical structure by clicking the appropriate radio button.

4. Click OK or press Return.

Another dialog box, as shown in Figure 1.28, opens.

5. Open the folder (or create a new folder) where the new model 
will be stored.

6. Replace the default name by typing a name for the new model 
(unless you want to use the default).

7. Click Save or press Return.

Figure 1.27   Dialog box used to set hierarchy

Figure 1.28   Directory dialog box used to save a model
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Save Model > Other…
This command creates a new model from selected model(s) in the 
current project and converts the model from ElectricImage FACT 
format to any number of commonly used file formats.

To save a model in a non-FACT format:

1. Select the model(s) to be saved into a new model.

2. Choose Save Model > then Other… from the File menu.

A dialog box, as shown in Figure 1.29, opens.

3. Specify whether or not you want to preserve a model’s 
hierarchical structure by clicking the appropriate radio button.

4. Click OK or press Return.

Another dialog box, as shown in Figure 1.30, opens.

5. Open the folder (or create a new folder) where the new model 
will be stored.

6. Replace the default name by typing a name for the new model 
(unless you want to use the default).

7. Select the export model type from the Type pop-up menu.

Figure 1.29   Dialog box used to set hierarchy

Figure 1.30   Directory dialog box used to export a model
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Figure 1.31 provides a list of file formats that ElectricImage can 
export.

8. Use the controls in the dialog box to select export options (if 
desired). For an explanation of these controls, refer to the 
section “Export Options” (page 1-38).

9. Click Save or press Return.

Figure 1.31   Table of formats that 
ElectricImage can export

DXF (Macintosh and PC DXF files are supported)

Dynaware—Dynaperspective

FACT (ElectricImage file format)

Lightwave (Newtek Video Toaster™)

Movie.BYU

MPS Demo (Evans & Sutherland)

Sculpt 3D

Super 3D (text file only) 

Videoscape (an Amiga file format)

Wavefront (.OBJ)

Zoom

3DGF (Macromind 3D)
The ElectricImage™ Reference 1-37



Chapter 1: The File Menu Commands

Book  Page 38  Friday, July 21, 2000  4:18 PM
Export Options

Output Points This check box option, when enabled, allows the saved model file to 
contain point data (otherwise points will be filtered out of the model 
file). Since ElectricImage renders point data, this option defaults to on.

Output Lines This check box option functions the same as the Output Points 
option, above, except that it applies to lines instead of points. Since 
ElectricImage also renders lines, this option defaults to on as well.

Output Polygons This check box option, when enabled, allows the output of polygons 
in the model file. If you do not wish to have polygons contained 
within the file, then uncheck this button. Since polygons give an 
object its “skin” this option defaults to on.

Output Vertices as
Points

This check box option, when enabled, generates points at every 
vertex contained within the model file. Turning off the other output 
options and leaving this one on results in a mesh of points to render.

Output Edges as Lines This check box option, when enabled, draws lines around the edges 
of all the polygons contained within the model file. It is useful for 
simulating grill work around transparent objects and so forth. Also, if 
you were to turn off all other output options but this one, the result 
would be a true wireframe representation of your model. Since two 
lines will be generated whenever two polygons share an edge, the 
wireframe can be simplified by re-importing the model with the 
Combine Polygons option turned on.

Breakup Concave
Polygons

This check box option, when enabled, forces the breakup of concave 
polygons (polygons which might be indented, such as a five pointed 
star), automatically converting them to convex. ElectricImage 
renders convex polygons only, so for FACT files, this option is always 
on. For other file formats this feature is optional, as those other 
formats, such as Super 3D, may be able to read concave polygons.

w
ElectricImage is not able to break up polygons that have edges that 
cross. Non-flat complex polygons can also cause problems when they 
are broken up.
1-38 ElectricImage™ Animation System



Save Model > Other…

Book  Page 39  Friday, July 21, 2000  4:18 PM
Side Limit This edit box contains a value that sets the maximum number of 
edges or sides for exported polygons. When exporting to Super 3D, 
for example, you could restrict the exported polygons to triangles 
and quadrangles by entering “4” into the side limit box. “0” (the 
default) sets the maximum number of sides supported by the export 
format.

Preferences This pop-up menu enables you to reset the preferences to system 
defaults, or to set preferences for saving models in DXF format.

DXF…

Choosing DXF opens a dialog box, as shown in Figure 1.32.

Text Format These radio buttons give you a choice of text formats for the DXF file:

Mac

This mode (the default) follows text lines with a <CR> character.

IBM

This mode follows text lines with both <CR> and <LF> characters. 
This is the text format used on IBM PC and UNIX computers.

Output Polygons As These radio buttons give you a choice of how polygons are output:

3DFACE

This mode (the default) outputs polygons as four-sided 3DFACE 
elements.

POLYLINE

This mode outputs polygons as multi-sided POLYLINE entities. 
Although this is not a “legal” AutoCAD DXF format, many other 3D 
modelers use it to store complex polygons.

Figure 1.32   Dialog box to set DXF file export preferences
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Decimal Digits This edit box contains a value for the number of digits to the right of 
the decimal point to output to the DXF file.

Exchange Y and Z
coordinates

This check box, when enabled, swaps the Y and Z coordinates of 
exported DXF files.
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Save
This command saves the current project (if you have made any 
changes).

To save the current project:

Choose Save from the File menu.
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Save As…
This command creates a copy of the current project under a new 
name, after which the new copy becomes the current project.

w
See also “Save Copy As…” (page 1-43), which creates a copy of the 
current project under a new name, but maintains the original file as 
the current project.

To create a copy of the current project and work on the copy as 
the current project:

1. Choose Save as… from the File menu.

A directory dialog box, as shown in Figure 1.33, opens.

2. Open the folder (or create a new folder) where the copy of the 
project file will be stored.

3. Replace the default name by typing a name for the copy of the 
project file (unless you want to use the default).

4. Either click Save or press Return.

Figure 1.33   Directory dialog box used to save a copy of the project file
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Save Copy As…
This command creates a copy of the current project under a new 
name, but maintains the original file as the current project.

w
See also “Save As…” (page 1-42), which creates a copy of the current 
project under a new name, after which the new copy becomes the 
current project.

To create a copy of the current project and maintain the original 
file as the current project:

1. Choose Save Copy as… from the File menu.

A directory dialog box, as shown in Figure 1.34, opens.

2. Open the folder (or create a new folder) where the copy of the 
project file will be stored.

3. Replace the default name by typing a name for the copy of the 
project file (unless you want to use the default).

4. Either click Save or press Return.

Figure 1.34   Directory dialog box used to save a copy of the project file
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Collect Files…
This command copies all related model and image files of the current 
project into a collection in a designated folder (a copy of the project 
file is also included).

To collect the project files:

1. Choose Collect Files… from the File menu.

A directory dialog box, as shown in Figure 1.35, opens.

2. Open the folder (or create a new folder) where the files will be 
collected.

3. To create a new folder for the project’s model(s), click Create 
Model Folder.

To create a new folder for the project’s texture(s), click Create 
Texture Folder.

To create a new folder for the project’s reflection(s), click Create 
Reflection Folder.

4. Either click Collect or press Return.

Figure 1.35   Directory dialog box used to collect project files
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[Camera/Light/Group/Sound] Info
This command is case-sensitive; that is, the menu item displayed 
depends upon what type of object is currently selected:

• If the camera is selected, the command is Camera Info (see 
below).

• If a light is selected, the command is Light Info (page 1-46).

• If a group is selected, the command is Group Info (page 1-46).

• If a soundtrack is selected, the command is Sound Info 
(page 1-47).

• If nothing is selected, the command is unavailable.

Camera Info

This command opens the Camera Info window, accessing settings for 
the camera’s icon display in the World View windows, and its 
location, directionality, and orientation (yaw, pitch and roll).

To open the Camera Info window:

1. Click on the camera’s icon (in either the World View or Project 
windows) to select it.

2. Choose Camera Info from the File menu.

w
For an explanation of the Camera Info window, refer to 
Chapter 10: The Camera Info Window.
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Light Info

This command opens the Light Info window for the selected light, 
accessing settings for the light’s light type, location, directionality, 
angle of coverage, shadow characteristics, color, intensity, and special 
effects such as glow and fog.

To open the Light Info window for a light in the project:

1. Click on the light’s icon (in either the World View or Project 
windows) to select it.

2. Choose Light Info from the File menu.

w
For an explanation of the Light Info window, refer to Chapter 11: The 
Light Info Window.

Group Info

This command opens the Group Info window for the selected group, 
accessing settings for the group’s location, orientation, scale, shading 
characteristics and surface attributes.

To open the Group Info window for a group in the project:

1. Click on the group’s icon (in either the World View or Project 
windows) to select it.

2. Choose Group Info from the File menu.

w
For an explanation of the Group Info window, refer to Chapter 13: The 
Group Info Window.
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Sound Info

This command opens the Sound Info window for the selected 
soundtrack, accessing settings for the track’s playback speed and 
timing.

To open the Sound Info window for a soundtrack in the project:

1. Click on the soundtrack’s icon (in the Project window) to select 
it.

2. Choose Sound Info from the File menu.

w
For an explanation of the Sound Info window, refer to Chapter 12: The 
Sound Info Window.
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Statistics…
This command displays the following information about the current 
project:

• How many elements (camera, lights, groups) it contains

• How many vertices and polygons it contains

• How many model and image files it contains

• How much memory is in use and how much is available

To view the project statistics:

1. Choose Statistics… from the File menu.

The Statistics dialog box, as shown in Figure 1.36, opens.

2. When done, either click OK or press Return.

Figure 1.36   Statistics dialog box
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Page Setup…
This command opens the standard Macintosh Page Setup dialog box 
for setting basic page attributes. For an explanation of what you can 
print in ElectricImage, refer to the section “Print” (page 1-50).

To set basic page attributes for printing:

Choose Page Setup… from the File menu.

The standard Macintosh Page Setup dialog opens for the printer 
selected in the Chooser.
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Print
This command prints project data for the current project. It is the 
same data as seen in the Project window, which is discussed in 
Chapter 8: The Project Window.

To print the project data:

1. Choose Print from the File menu.

A print dialog box opens for the printer selected in the Chooser 
(Figure 1.37 shows a dialog box for a generic laser printer).

2. Use the controls in the dialog box to select your printing 
preferences. For an explanation of these controls, refer to the 
section “Printing Preferences” (page 1-51).

3. Either click Print or press Return.

w
If the amount of data to be printed is too large to fit on a single 
page, tiling is performed automatically.

Figure 1.37   Print dialog box for generic laser printer
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Printing Preferences

Use Project Window This check box option, when enabled, prints the project data as it is 
currently displayed in the Project window. It defaults to on.

Use Project Cell Size This check box option, when enabled, uses the size of the data cells as 
they are currently set in the Project window. It defaults to on.

Selected Objects Only This check box option, when enabled, prints data for selected 
object(s) only.

All Frames This check box option, when enabled, prints the project data for all 
frames of the project. It defaults to on.

Order View by This pop-up menu gives you a choice of two display modes for the 
information. The menu choices are:

Flat

This option (the default) displays information in a flat list mode.

Hierarchy

This option displays information in a hierarchical mode (showing 
children grouped and indented beneath their parents).

Show View of This pop-up menu gives you a choice of printing project data from 
one of the four editing modes. The menu choices are:

Time

This option (the default) displays timing data.

Frame

This option displays frame data.

Keyframe

This option displays frame data with keyframes individually 
indicated.

Index

This option displays keyframe data only.
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View by This pop-up menu gives you a choice of what specific object class 
data to be printed. The menu choices are:

Position

This option displays object position data only.

Rotation

This option displays object rotation data only.

Scale

This option displays object scale data only.

Color

This option displays object color data only.

All

This option (the default) displays all object class data.

Custom…

This option opens a dialog box, as shown in Figure 1.38, which is 
used to select the specific object class data to be printed.

The dialog box’s Element pop-up menu gives you a choice of 
Camera, Light and Group.

The list below the Element pop-up menu shows the kind of data 
available for the selected element.

Figure 1.38   Dialog box used to select custom view
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To select data to display, click on the data in the list (shift-click to 
select more than one type of data from the list), then either click OK 
or press Return.

Cell Size
Width and Height

These edit boxes contain values that specify the width and height of 
the cells to be printed (if not using the project default values).

Frame Range
Start and Stop

These edit boxes contain values that specify the beginning and end 
frames of the data to be printed (if not using all frames).
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Render…
This command opens the Render Control window, which is used to 
set the current project’s global rendering attributes as well as to 
render the project.

To open the Render Control window:

1. Choose Render… from the File menu.

The Render Control window opens, as shown in Figure 1.39.

2. Use the window’s controls to set the rendering attributes you 
want for the project (if you are not using the default settings).

w
For an explanation of the Render Control window and its use, see 
Chapter 9: The Render Control Window.

3. If you do not want to render the project at this time, you can 
close the window or reposition it.

If you want to render the project at this time, click Go.

(If you have made any changes to the current project, a dialog box 
opens and prompts you to save the changes.)

A directory dialog box, as shown in Figure 1.40, opens, prompting you 
to enter a name for the rendered image file.

Figure 1.39   Render Control window
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4. Open the folder (or create a new folder) where the project’s 
image file will be stored.

5. Replace the default name by typing a name for the image file 
(unless you want to use the default name).

6. Either click Save or press Return.

The ElectricImage application closes and the ElectricImage Camera is 
launched to render the project.

w
For an explanation of the ElectricImage Camera, refer to 
Chapter 22: The ElectricImage Camera.

Figure 1.40   Directory dialog box used to save a rendered image file
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Projector
This command closes the ElectricImage application and launches the 
Projector application, which is used to display rendered images and 
animations from ElectricImage projects, PICT files, and QuickTime 
movies. It also contains powerful functions for editing and applying 
filters to rendered images and animations.

To launch Projector:

Choose Projector from the File menu.

(If you have made any changes to a currently open project, a dialog 
box opens and prompts you to save the changes.)

The ElectricImage application closes and the Projector application 
opens.

w
For an explanation of the Projector application and its use, refer to 
The Projector Reference.
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Quit
This command closes the current project and exits the ElectricImage 
Animation System.

To quit the ElectricImage Animation System:

Choose Quit from the File menu.

(If you have made any changes to a currently open project, a dialog 
box opens and prompts you to save the changes.)
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Chapter 2 The Edit Menu Commands

w
The Edit menu commands are different depending upon what windows 
are active and whether or not objects, text, textures, etc. are selected. 
When, for example, the Surface Editor is open, the preference selection 
commands are unavailable, but there is a Revert command to reset the 
surface attributes of the current group to their original settings.

Undo ................................................................................................ 2-3

Cut.................................................................................................... 2-3

Copy ................................................................................................. 2-4

Paste ................................................................................................ 2-4

Clear................................................................................................. 2-5

Copy Special [Text] ........................................................................ 2-5

Select All ......................................................................................... 2-6

Find…............................................................................................... 2-6

Find Again....................................................................................... 2-7

Duplicate ......................................................................................... 2-7

Revert (available in Surface Editor only) ................................... 2-8
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Keyframe… ......................................................................................2-9

Keyframe Preferences  2-10

Drawing…......................................................................................2-11

Drawing Preferences  2-12

Grid & Scale… ...............................................................................2-17

Grid & Scale Preferences  2-18

Field Chart…..................................................................................2-20

Field Chart Preferences  2-22

Preview/Render… ........................................................................2-26

Preview Preferences  2-27

Render Preferences  2-29

Color… ...........................................................................................2-31

Color Preferences  2-32

Import….........................................................................................2-33

Model Preferences  2-34

Sound Preference  2-34

Project File… .................................................................................2-35

Project File Preferences  2-36

Default Preferences .....................................................................2-37
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Undo
This command undoes any changes that have been made in the 
current project. It is a single-level undo (only the last change is 
undone).

Cut
This command cuts the following kinds of information (when 
selected) from the current project and copies them to the scrap:

• surface attributes (from the Surface Editor)

• information in cells (from the Project window)

• text in edit boxes (from all windows with edit boxes)
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Copy
This command is case-sensitive; that is, the menu item displayed 
depends upon what window is active and what type of object is 
currently selected:

• If text is selected in an edit box, the command is Copy Text (as 
shown at left) and it copies the selected text to the scrap.

• If the Surface Editor is active, the command is Copy Surface 
Color and it copies the surface attributes to the scrap.

• If the Group Texture window is open and a texture is selected, 
the command is Copy Texture Map and it copies the selected 
texture to the scrap.

• If the Project window is active and a data cell is selected, the 
command is Copy Cells and it copies the selected cell data to the 
scrap.

Paste
This command is case-sensitive; that is, the menu item displayed 
depends upon the type of data was copied to the scrap with either the 
Cut command (page 2-3) or Copy command (page 2-4):

• If text was copied, the command is Paste Text (as shown at left) 
and it pastes the text into the selected edit box.

• If surface attributes were copied, the command is Paste Surface 
Color and it pastes the surface attributes into the selected group.

• If a texture was copied, the command is Paste Texture and it 
pastes the texture into the selected group.

• If cell data was copied, the command is Paste Cell Text and it 
pastes the cell data into the selected cell(s) in the Project window. 
Refer to “Selecting a Range of Frames” (page 8-13) in 
Chapter 8: The Project Window for more information.

• If Excel text was copied from a Microsoft Excel file into the 
clipboard or Scrapbook, the command pastes the text into the 
selected data cells in the Project window (page 8-13).
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Clear
This command clears (deletes) selected models, lights and/or text 
fields from the project. It will not remove the camera.

Copy Special [Text]
This command copies text (the menu display is case-sensitive) when 
the standard Copy command (page 2-4) is being used to copy 
attributes.
The ElectricImage™ Reference 2-5



Chapter 2: The Edit Menu Commands

Book  Page 6  Friday, July 21, 2000  4:18 PM
Select All
This command selects all cameras, lights and model groups in the 
current project.

w
Objects that are locked cannot be selected with this command. Objects 
are locked (or unlocked) in the Project window, as discussed in the 
section “The Object Status Panel” (page 8-17) in Chapter 8: The Project 
Window

Find…
This command is used to locate and select objects in the project.

To find an object:

1. Choose Find… from the Edit menu.

A dialog box, as shown in Figure 2.1, opens.

2. Type the name of the object or a search string.

3. Specify whether or not the search string is a whole word (the 
default) and whether or not to match the case of the letters.

4. Either click Find or press Return.

Figure 2.1   Dialog box used to find an object
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Find Again
This command re-executes the Find… command (page 2-6) using the 
same search criteria.

Duplicate
This command duplicates selected elements in the current project. It 
will not duplicate the camera.

w
When an object is duplicated, all of its attributes are duplicated as 
well. If you are creating similar objects, set up the first object as desired 
(including textures for models), and then duplicate it.
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Revert (available in Surface Editor only)

This command resets the surface attributes of the current group to its 
original settings.
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Keyframe…
This command enables you to set your preferences for how keyframes 
are to be treated in the project.

To set your keyframe preferences:

1. Choose Keyframe… from the Edit menu.

A dialog box, as shown in Figure 2.2, opens.

2. Use the edit boxes to set your preferences. For an explanation of 
these controls, refer to the section “Keyframe Preferences” 
(page 2-10).

3. To save the settings, click OK. Otherwise, click Cancel.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.2   Keyframe Preferences dialog box
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Keyframe Preferences

Motion Path Segments This edit box contains a value for the number of segments to be 
included in the animation path. The default is 5 line segments per 
spline between keyframes.

Path Velocity
Calculation Maximum

Deviation

This edit box contains a percentage value for the accuracy of 
calculation of the path. The default is 0.001%.

If a high value is specified, the calculation is less accurate but the 
algorithm runs faster. If a small value is specified, the calculation is 
more accurate, however the algorithm runs slower. You would 
generally change this value if the path is short and many frames are 
generated on it. The distances between frames could be so subtle that 
a large error factor could affect the output, so you can change the 
path deviation to generate a more correct path distance. The path 
deviation is the percentage of the exact path distance.

Compute
Attach/Lookat/Rotate

Automatically

This check box, enabled by default, determines whether or not 
custom frames will be automatically generated when the Attach to 
Object, Look at Object, and Auto Rotate Object functions are 
executed. If automatic frame generation is disabled, custom frames 
will be generated for these procedures only under the following 
conditions:

• When the project is rendered.

• When the project is previewed.

• When the Calculate Auto Frames command is chosen from the 
Keyframe menu, as discussed in the section “Calculate Auto 
Frames” (page 4-8) in Chapter 4: The Keyframe Menu Commands.
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Drawing…
This command enables you to set your preferences for how the 
system draws models in the World View, Camera View and Group 
windows.

To set your drawing preferences:

1. Choose Drawing… from the Edit menu.

A dialog box, as shown in Figure 2.3, opens.

2. Use the edit boxes, check boxes and pop-up menus to set your 
preferences. For an explanation of these controls, refer to the 
section “Drawing Preferences” (page 2-12).

3. To save the settings, click OK. Otherwise, click Cancel.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.3   Drawing Preferences dialog box
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Drawing Preferences

Drawing Detail
(World View,
Camera View,

Group Windows)

These check box options, when enabled, specify the level of detail to 
be drawn in the World View, Camera View and Group windows, as 
well as the inclusion of lights and motion paths in the Camera View 
window. The four levels of drawing detail (from lowest level to 
highest level) are:

Draw Group Extents

Group extents are cubes that surround groups and show only the 
space in which groups exist. When this option is enabled, group 
extents are drawn, as shown in Figure 2.4.

Group extents also indicate, by way of a diagonal line through the 
center of the cube, in which direction the model is facing as it was 
imported into ElectricImage. The front face of the model is where the 
diagonal line touches the bottom of the cube.

Draw Vertices

Vertices are points that define a whole polygon. When this option is 
enabled, vertices are drawn, as shown in Figure 2.5.

Figure 2.4   Example of Group Extents level drawing

Figure 2.5   Example of Vertices level drawing
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In Figure 2.5, the model is a sphere, and the vertices of the sphere 
appear as points that are visible around the sphere.

Draw Polygons

Polygons are geometric entities used to denote a surface or skin of the 
model. When this option is enabled, polygons are drawn, as shown 
in Figure 2.6.

In Figure 2.6, the model is a sphere, which is more clearly apparent 
when the polygons are indicated.

Draw Shaded

This option shades the polygons of the group, accounting for the 
current lighting in the scene. There are two methods of shaded 
drawing, selected from the pop-up menu: Poly and Pixel.

Shaded Poly level drawing is flat, with no smoothing, as shown in 
Figure 2.7.

Shaded Pixel will draw smooth spotlighted areas—at the expense of 
processing speed.

Figure 2.6   Example of Polygons level drawing

Figure 2.7   Example of Shaded Poly level drawing
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Other Camera View
Window Drawing

Options

The Camera View window also has the following check box options:

Draw Lights

When enabled, any lights within the camera’s angle of view will be 
drawn in the Camera View window.

Draw Paths

When enabled, motion paths of animated objects will be drawn in 
the Camera View window.

Switch Color Depth This check box option, when enabled, switches color depth on the 
fly, as needed, to the proper setting.

Screen Colors This pop-up menu gives you a choice of screen colors, though it is 
dependent on the display card in use. The menu choices are:

2

4

16

256 (the default and recommended, as it is the fastest to update)

Thousands

Millions

Picture Cache This edit box contains a value for the number of kilobytes to be set 
for the picture cache—the amount of memory (in kilobytes) set aside 
for the background image. Since the background image is fetched 
from the disk a piece at a time, the complete frame buffer memory of 
the image does not need to be allocated. This feature enables you to 
specify how much of the total memory can be allocated so that you 
can continue working with the project. It also enables you to read in 
large images (up to 4K) without running out of memory. There is also 
a speed increase with larger buffers as the image grows in size.

Activate drawing
windows when mouse is

clicked in window
content

This check box option, when enabled, causes World View windows to 
be activated when you click in them.
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Suspend drawing while
application in

background

This check box option, when enabled, suspends drawing (and 
processing) in ElectricImage while the ElectricImage application is in 
the background. Use this option when ElectricImage drawing may 
slow down another application (such as Projector) that you have 
running in the foreground.

Show Grid while
dragging

This check box option, when enabled, displays the grid in the 
Camera View window while the camera is being dragged. Showing 
the grid provides a better frame of reference for viewing the scene.

Show Recorded Image This check box option, when enabled, shows the actual picture 
rendered when a pixel aspect ratio of other than 1 is set in the Render 
Control window (as this would cause the rendered image to be taller 
or wider, depending upon the setting).

Mouse Drag Pause This edit box contains a value (in seconds) for the time interval 
between the moment when camera dragging stops and the image is 
redrawn in the Camera View window. This allows the extent box 
display to remain for a specified period of time before wireframe 
information is drawn.

Key Entry Pause This edit box contains a value (in seconds) for the time interval 
between the moment when key entry stops and the image is redrawn 
in the Camera View window. This allows the extent box display to 
remain for a specified period of time before wireframe information is 
drawn.

Miscellaneous These check box options indicate the preferred drawing routine and 
whether or not subpolygons are to be drawn in constructing models.

Use QuickDraw

This check box option, when enabled, uses QuickDraw (the default) 
rather than the ElectricImage routine. For faster drawing, particularly 
for previews, deselect it. For an explanation of previews, refer to the 
section “Previewing Animations” (page 7-9) in Chapter 7: The Camera 
View Window.
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Show Subpolygons

This check box option, when enabled, draws fully detailed 
constructions of models, including subpolygons (at a cost of slower 
performance.)

Figure 2.8 shows an example of a font model drawn with Use 
Subpolygons disabled.

It shows a multi-sided polygon, along with the three- and four-sided 
subpolygons that the render uses. This is a more “viewable” form of 
the type face.

Figure 2.9 shows an example of a model drawn with Use 
Subpolygons enabled. Note the extra information being drawn on 
the type face.

It shows the actual polygons that the render will use to generate an 
image of the type.

Figure 2.8   Example of model drawn without subpolygons

Figure 2.9   Example of model drawn with subpolygons
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Grid & Scale…
This command enables you to set your preferences for the origin and 
scale of grids, and for the display of ruler bars, numbers and objects 
close to the camera.

w
In ElectricImage, scale is used as a relative means of display, and is not 
related to measurements such as inches, millimeters, etc. It is keyed to 
the scale of the first object added to the project.

To set your grid, rulers and number display preferences:

1. Choose Grid & Scale… from the Edit menu.

A dialog box, as shown in Figure 2.10, opens.

2. Use the check boxes, edit boxes and pop-up menus to set your 
preferences. For an explanation of these controls, refer to the 
section “Grid & Scale Preferences” (page 2-18)

3. To save the preferences, click OK or press Return.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.10   Grid & Scale Preferences dialog box
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Grid & Scale Preferences

World Grid
Origin and Scale

These edit boxes contain values for the location and scale of the grid 
in the World View windows. They default to origins of 0 for the X, Y 
and Z coordinates, and to a scale value of 100.

World Grid
Pixel limit

This edit box contains a value that specifies (in number of pixels) 
how close two parallel grid lines can be drawn in the world view 
windows. This feature can help you avoid the situation where all grid 
lines touch each other or are being drawn on top of each other, 
resulting in a solid background (negating the effect of grid limit). 
More dense or sparse grid spacing can thus be set by changing the 
pixel limit. A larger pixel limit also means faster grid update (fewer 
grid lines to draw). Pixel limit does not apply to the Camera View 
window because there are no two projected lines that are parallel.

Camera Grid
Size

This edit box contains a value for the size or area of the grid that can 
be shown in the Camera View window.

Camera Grid
Divisions

This edit box contains a value for the number of divisions in the 
Camera View window grid. As the size of the camera grid is increased, 
it is a good idea to increase the number of divisions (to maintain the 
appearance of the grid). These divisions do not represent fixed values, 
and are rescaled depending upon the zoom factor of the window. To 
cancel division scaling (forcing the divisions to be fixed) set the pixel 
limit to a small number, such as 1 or 2.

Snapping Grid
Origin and Scale

These edit boxes contain values for the location and scale of the 
invisible grid to which elements in the file will “snap” when placed.

w
Grid snap can be toggled on and off using either the Snapping Grid tool 
on the Tool Palette, as discussed in the section “The Snapping Grid 
Tool” (page 19-12) in Chapter 19: The Tool Palette, or the caps lock key.

Real Number Display
Precision

Fractional Digits

This edit box contains a value that specifies the number of digits that 
will appear after the decimal point in real numbers (such as those 
contained in edit boxes). The default is 4 (such as 2.3456).
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Ruler Bar
Subdivisions and

Minimum Divisions

These edit boxes contain the number of subdivisions (default is 10) 
and minimum division (default is 5) for the rulers when displayed.

Ruler Bar
Style

This pop-up menu selects the style of ruler to be displayed. The menu 
choices are as shown in Figure 2.11:

Start Windows
with Rulers

This check box option, when enabled, sets automatic inclusion of the 
rulers when the World View windows are displayed.

w
The rulers can be toggled on and off using the Show Rulers command in 
the Windows menu (Command-M), as discussed in the section 
“Show/Hide Rulers” (page 3-14) in Chapter 3: The Windows Menu 
Commands.

Space Clipping
Minimum Z Distance

This edit box contains a value that specifies the distance out from the 
camera for which information in the Camera View window will be 
clipped (also known as the “hither clipping plane”).

Figure 2.11   Ruler styles
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Field Chart…
This command enables you to set your preferences for the display of 
a field chart in the Camera View window.

A field chart is a grid subdivided into quadrants, which are further 
subdivided into fields. Each field maintains the aspect ratio of the 
current format resolution.

Figure 2.12 shows a standard field chart (said to be a 12 field chart), 
twelve fields across by twelve fields high.

Components of the field chart can be individually activated or 
deactivated, and the colors of these components are selectable, as 
described in the following procedure.

Figure 2.12   Standard field chart
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To set your field chart preferences:

1. Choose Field Chart… from the Edit menu.

A dialog box, as shown in Figure 2.13, opens.

2. Use the check boxes and color buttons to set your preferences. 
For an explanation of these controls, see the section “Field Chart 
Preferences” (page 2-22).

3. To save the preferences, click OK or press Return.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.13   Field Chart Preferences dialog box
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Field Chart Preferences

Grid This check box turns on the field chart grid, as shown in Figure 2.14.

Title Safe This check box turns on a frame, as shown in Figure 2.15, within 
which is considered to be the safe area to display titles (with no risk 
of cropping).

Figure 2.14   Camera View window with field chart grid

Field Chart Grid

Figure 2.15   Field chart with title safe frame enabled

Title Safe Frame
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Action Safe This check box turns on a frame, as shown in Figure 2.16, within 
which is considered to be the safe area to display action (with no risk 
of cropping).

Cross Lines This check box turns on the cross lines in the center of the field chart 
display, as shown in Figure 2.17.

Hatch Lines This check box turns on the diagonal hatch lines of the field chart 
display, as shown in Figure 2.18.

Figure 2.16   Field chart with action safe frame enabled

Action Safe Frame

Figure 2.17   Field chart with cross lines enabled

Cross Lines
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All Field Chart Elements With all field chart elements selected, the Camera View window 
would appear as shown in Figure 2.19.

Figure 2.18   Field chart with hatch lines enabled

Hatch Lines

Figure 2.19   Field chart with all elements enabled
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Field Size This edit box contains the number of divisions in the field. The 
default is 12 (for a standard 12 field chart).

Color Buttons The color buttons to the left of each check box are used to select a 
color for that element of the field chart. Setting a different color for 
each element can eliminate confusion in the display.

Clicking a color button opens the standard Apple Color Picker.
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Preview/Render…
This command enables you to set your preferences for how the 
preview function works and where rendered preview files should be 
placed. For an explanation of the preview function and its use, refer 
to the section “Previewing Animations” (page 7-9) in Chapter 7: The 
Camera View Window.

To set your preview/render preferences:

1. Choose Preview/Render… from the Edit menu.

A dialog box, as shown in Figure 2.20, opens.

2. Use the pop-up menus and edit box to set your preferences. For 
an explanation of these controls, see the sections “Preview 
Preferences” (page 2-27) and “Render Preferences” (page 2-29).

3. To save the preferences, click OK or press Return.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.20   Preview/Render Preferences dialog box
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Preview Preferences

Output This pop-up menu is used to indicate where the preview is to be 
output. The menu choices are:

To Screen

This option (the default) displays the preview on the screen.

To Image

This option renders the preview to an Image file. It can then be 
viewed in the Projector application (refer to The Projector Reference).

To QuickTime

This option renders the preview to a QuickTime movie. It can then be 
viewed with the Display… command in the File menu. See 
“Display…” (page 1-11) in Chapter 1: The File Menu Commands.

Detail This pop-up menu is used to indicate the detail to which the preview 
will be shown. The menu choices are:

Extents

This option (the default) shows group extents only.

Polygons

This option shows polygons (considerably slower than group extents 
only).

Polygon Shaded

This option shades the polygons of groups, accounting for the 
current lighting in the scene. The drawing is flat, with no smoothing.

Pixel Shaded

This option also shades the polygons of groups, with smooth 
spotlighted areas.

w
For an explanation of drawing level detail options, refer to the section 
“Drawing Preferences” (page 2-12).
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Background This pop-up menu is used to indicate how the background is to be 
treated during the preview. The menu choices are:

None

This option (the default) removes the background from the preview.

Still

This option uses the current background in the preview.

Increment

This option increments the background in the preview by frame 
number and recycles if the background sequence contains fewer 
frames than the animation sequence being previewed.

Play back immediately This check box option is used for QuickTime files. When enabled, a 
looping playback is initiated immediately after the preview is 
generated. Playback will continue until you click the QuickTime 
window’s close box.
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Render Preferences

Data Folder This pop-up menu is used to indicate where the project’s data temp 
files are to be stored during rendering. The menu choices are:

Image

This option stores the data in the folder where the rendered image 
file is being written.

Camera

This option (the default) stores the data in the folder where the 
Camera application resides.

Project

This option stores the data in the folder where the project file resides.

Custom

This option opens a directory dialog box in which you can specify a 
folder in which to store the data.

Shadow Folder: This pop-up menu is used to indicate where the project’s shadow, 
mirror and environment temp files are to be stored during rendering. 
The menu choices are:

Image

This option stores the data in the folder where the rendered image 
file is being written.

Camera

This option (the default) stores the data in the folder where the 
Camera application resides.

Project

This option stores the data in the folder where the project file resides.

Custom

This option opens a directory dialog box in which you can specify a 
folder in which to store the data.
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Transparency Layers This edit box contains a value that specifies the maximum number of 
transparent objects that can be layered in one pixel. The available 
range is 0-255 and the default is 10.

Depending upon the amount of transparent polygons per pixel in a 
single frame, this value can be used to speed up render time for filter 
transparencies (if the range is small). The Camera application will not 
create more layers than necessary, even if the value is set beyond the 
actual amount for the single frame. As the number of transparencies 
approaches the layer value, they will gradually become opaque.
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Color…
This command enables you to set your preferences for the use of 
color in the work environment.

To set your color preferences:

1. Choose Color… from the Edit menu.

A dialog box, as shown in Figure 2.21, opens.

2. Use the buttons to set your preferences. For an explanation of 
these controls, see the section “Color Preferences” (page 2-32).

The Apple Color Picker opens when you click a button.

3. Select a color from the Apple Color Picker and click OK.

The Color Preferences dialog box reopens, displaying the selected 
colors in the buttons.

4. To save the preferences, click OK or press Return.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.21   Color Preferences dialog box
The ElectricImage™ Reference 2-31



Chapter 2: The Edit Menu Commands

Book  Page 32  Friday, July 21, 2000  4:18 PM
Color Preferences

Foreground This button sets the color for the foreground and light control 
regions in the Camera View window, and of the camera and light 
icons and controls in the World View windows.

Background This button sets the color for the background in the World View and 
Camera View windows.

Grid Color This button sets the color for the grid in the World View and Camera 
View windows.

Extent Color This button sets the color for the group extents drawn for models in 
the World View and Camera View windows. For an explanation of 
group extent drawing, refer to the section “Drawing…” (page 2-11).

Vertex Color This button sets the color for the vertices drawn for models in the 
World View and Camera View windows. For an explanation of vertex 
drawing, refer to the section “Drawing…” (page 2-11).

Key Color This button sets the color of the keyframes in the World View 
windows (when multiple keyframes exist for an object).

Handle Color This button sets the color of the handles in Bezier spline motion 
paths (when the motion path spline is set to Bezier).

Element Path Color This button sets the color for the element, or motion, path when 
more than one keyframe exists for an element.

Reference Path Color This button sets the color for an element’s reference path when more 
than one keyframe exists for the element’s reference point.
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Import…
This command enables you to set your preferences for how models 
and sound files are imported into projects.

To set your import preferences:

1. Choose Import… from the Edit menu.

A dialog box, as shown in Figure 2.22, opens.

2. Use the check boxes and pop-up menu to set your preferences. 
For an explanation of these controls, see the sections “Model 
Preferences” (page 2-34) and “Sound Preference” (page 2-34).

3. To save the preferences, click OK or press Return.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.22   Import Preferences dialog box
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Model Preferences

Default Inherit Position This check box option, when enabled, causes a parent group’s 
position values to be passed to its children.

Default Inherit Rotation This check box option, when enabled, causes a parent group’s 
rotation values to be passed to its children.

Default Inherit Scale This check box option, when enabled, causes scaling done to a parent 
group to be passed its children.

Default Inherit Visibility This check box option, when enabled, causes a parent group’s 
visibility status to pass to its children.

Default Inherit
Deformation

This check box option, when enabled, causes deformations 
performed on a parent group to affect its children (which may cause 
unwanted distortions). For more information on deformations, refer 
to Chapter 16: The Group Deformation Window.

Sound Preference

Frequency This pop-up menu sets the frequency range of imported sound files. 
The higher the frequency, the higher the fidelity of the sound (but 
the more memory required). The menu choices are:

• 5 kHz

• 7 kHz

• 11 kHz

• 22 kHz (the default)

• 44 kHz
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Project File…
This command enables you to set your preferences for which project 
data is stored in the project file.

To set your project file preferences:

1. Choose Project File… from the Edit menu.

A dialog box, as shown in Figure 2.23, opens.

2. Use the check boxes to set your preferences. For an explanation 
of these controls, see the section “Project File Preferences” 
(page 2-36).

3. To save the preferences, click OK or press Return.

w
To reset the system’s default preferences at any time, choose 
Default Preferences from the Edit menu.

Figure 2.23   Project File Preferences dialog box
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Project File Preferences

Store Display Data This check box option, when enabled, causes the project’s display 
data to be stored in the project file.

Store Project Window
Content

This check box option, when enabled, causes the project’s window 
content to be stored in the project file.

Store Sound Data This check box option, when enabled, causes the project’s sound data 
to be stored in the project file.

w
Storing these attributes in the project file dramatically speeds up the 
loading of projects into ElectricImage, as they would normally be 
created as the file is read into memory. Enabling these options, 
however, will cause project files to take up more disk space.
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Default Preferences
This command resets all preferences to their system defaults.

w
This command is helpful if the display becomes difficult to view.
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Tool Palette
This command toggles the display of the Tool Palette, shown in 
Figure 3.1, which is used to perform such tasks as scaling, rotating 
and deforming objects, hierarchically linking groups together, etc.

w
For an explanation of the Tool Palette and its use, refer to 
Chapter 19: The Tool Palette.

Figure 3.1   Default view of the Tool Palette
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Location Palette
This command toggles the display of the Location Palette, shown in 
Figure 3.2, which indicates the cursor’s global coordinates as it is 
moved within any of the World View windows.

w
For an explanation of the Location Palette and its use, refer to 
Chapter 21: The Location Palette.

Figure 3.2   The Location Palette
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Object Palette
This command toggles the display of the Object Palette, shown in 
Figure 3.3, which is used to perform such tasks as adding 
FACT-format models to the project, creating and adding font models 
to the project, recording and adding sounds, importing models of 
non-FACT format into the project, adding lights, and executing 
plug-ins (if loaded in the EI Sockets folder).

w
For an explanation of the Object Palette and its use, refer to 
Chapter 20: The Object Palette.

Figure 3.3   Default view of the Object Palette
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Top View
This command toggles the display of the top World View window, 
shown in Figure 3.4, which looks down on the universe from above, 
displaying the X/Z coordinate plane.

w
For an explanation of the World View windows and their use, see 
Chapter 6: The World View Windows.

Figure 3.4   The top World View window
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Side View
This command toggles the display of the side World View window, 
shown in Figure 3.5, which looks toward the left of the universe, 
displaying the Y/Z coordinate plane.

w
For an explanation of the World View windows and their use, see 
Chapter 6: The World View Windows.

Figure 3.5   The side World View window
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Front View
This command toggles the display of the front World View window, 
shown in Figure 3.6, which looks to the rear of the universe, 
displaying the X/Y coordinate plane.

w
For an explanation of the World View windows and their use, see 
Chapter 6: The World View Windows.

Figure 3.6   The front World View window
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Camera View
This command toggles the display of the Camera View window, 
shown in Figure 3.7, which shows what the camera is seeing at all 
times, and which is used to preview animations.

w
For an explanation of the Camera View window and its use, see 
Chapter 7: The Camera View Window.

Figure 3.7   Default view of the Camera View window
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Project Window
This command toggles the display of the Project window, shown in 
Figure 3.8, where the project editing mode is set and where all of the 
attributes within the project file are available for viewing and editing.

The Project Window has a different appearance for each editing 
mode and can be resized and scrolled to show information not visible 
in the default view.

w
For an explanation of the Project window and its use, see 
Chapter 8: The Project Window.

Figure 3.8   Default view of the Project window (Time mode)
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Camera Velocity
This command toggles the display of the Camera Velocity window, 
shown in Figure 3.9, which charts the rate of change of the camera’s 
speed of movement when the camera is animated.

The timing of the camera’s keyframes, and the shape (area) of the 
motion path affect the camera’s velocity.

w
For an explanation of the Camera Velocity window and its use, refer to 
the section “Camera Velocity” (page 17-9) in Chapter 17: The Velocity 
Windows.

Figure 3.9   Default view of the Camera Velocity window
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Light Velocity
This command toggles the display of the Light Velocity window, 
shown in Figure 3.10, which charts the rate of change of the selected 
light’s speed of movement when the light is animated.

The timing of the light’s keyframes, and the shape (area) of the 
motion path affect the light’s velocity.

w
For an explanation of the Light Velocity window and its use, refer to 
the section “Light Velocity” (page 17-10) in Chapter 17: The Velocity 
Windows.

Figure 3.10   Default view of the Light Velocity window
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Model Velocity
This command toggles the display of the Model Velocity window, 
shown in Figure 3.11, which charts the rate of change of the selected 
model’s speed of movement when the model is animated.

The timing of the model’s keyframes, and the shape (area) of the 
motion path affect the model’s velocity.

w
For an explanation of the Model Velocity window and its use, refer to 
the section “Model Velocity” (page 17-11) in Chapter 17: The Velocity 
Windows.

Figure 3.11   Default view of the Model Velocity window
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Close Window
This command closes the current (or front) window.
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Show/Hide Rulers
This command toggles the display of the rulers in the World View 
windows, shown in Figure 3.12.

When the rulers are already displayed, the command in the Edit 
menu is Hide Rulers.

w
For an explanation of the various options for setting ruler display 
preferences, refer to the section “Grid & Scale…” (page 2-17) in 
Chapter 2: The Edit Menu Commands.

Figure 3.12   World View window with rulers
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Add Keyframe
This command adds a keyframe to every data channel for all selected 
objects (regardless of whether or not a channel is being animated) or, 
if the Project window is frontmost and in Keyframe mode, keyframes 
will be added wherever frame cells are selected.

w
For an explanation of keyframes and their use in ElectricImage, refer to 
The ElectricImage Starter.

Delete Keyframe
This command deletes selected keyframes for the selected object.

w
To delete all keyframes for a selected object, use the Clear All 
Keyframes command (see below).

Clear All Keyframes
This command deletes all keyframes for the selected object, and the 
currently selected keyframe becomes the object’s base keyframe.

w
To delete selected keyframes only, use the Delete Keyframe command 
(see above).
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Offset Keyframes
This command offsets the values for time, position, scale, rotation 
and reference by a consistent amount for all keyframes (and, 
optionally, custom frames) of the selected object. It can also be used 
to scale the time values of keyframes for the selected object.

To offset keyframe values:

1. Choose Offset Keyframes from the Keyframe menu.

The Offset Keyframe window, as shown in Figure 4.1, opens.

2. Type a value in the edit box for the amount of offset to be 
applied to that characteristic of the selected object. The 
characteristics that can be offset are time, position (offset), 
center, scale and rotation.

w
For the camera and lights, which have a reference value and not a 
rotation value, you can offset the reference value by clicking the 
Use Rotation as Reference check box and then typing values in the 
Rotation edit boxes.

The check boxes to the left of the offset value edit boxes are 
automatically enabled when values are typed.

Figure 4.1   Offset Keyframe window
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3. If you have custom frames that you wish to offset along with 
keyframes, click the Change Custom Frames check box. 
Otherwise, only keyframes will be offset.

4. To prevent an offset, click in the check box to disable it.

5. Either click OK or press Return. The keyframe (and, optionally, 
custom frame) values are offset by the entered amount, and the 
offsetting can be repeated each time you click OK or press 
Return.

To scale the timing of keyframes:

1. Type a value in the Scale Time edit box for the factor by which 
to scale the timing of keyframes. For example, a factor of 2 will 
double the amount of time between the first and last keyframes 
for the selected object, scaling the timing of any intermediate 
keyframes accordingly. A factor of 0.5 will halve the amount of 
time between the first and last keyframes.

2. Type a value in the Around edit box to set the time around 
which the keyframes will be scaled.

Figure 4.2 (page 4-5) shows examples of the effects of offsetting and 
scaling keyframe time values.
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Figure 4.2   Examples of keyframe timing values offset and scaled

Original keyframe values for group
(keyframes at 0, 1, 2, 3, 4 and 5 seconds)

Keyframe time offset by 1.0 seconds
(keyframes now at 1, 2, 3, 4, 5 and 6 seconds)

Keyframe time scaled by 0.5 around 0.0 seconds
(keyframes now at 0, 0.5, 1, 1.5, 2 and 2.5 seconds)

Keyframe time scaled by 0.5 around 2.5 seconds
(keyframes now at 1.25, 1.75, 2.25, 2.75, 3.25 and 3.75 seconds)

Keyframe time scaled by 0.5 around 5 seconds
(keyframes now at 2.5, 3, 3.5, 4, 4.5 and 5 seconds)

Keyframe time scaled by 2 around 0 seconds
(keyframes now at 0, 2, 4, 6, 8 and 10 seconds)
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Recalculate Selected Frames
This command forces a reinterpolation of keyframe data for a 
selected range of frames in the Project window. This function is used 
to recalculate the data to be used for the frames between keyframes 
(and thus remove any custom frames created by fill, blend, “attach 
to” and/or “look at” operations). It is only available when working in 
Frame or Keyframe editing modes, by selecting a range of frames and 
choosing this command.

w
For more information on the Project window and its use, see 
Chapter 8: The Project Window.
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Recalculate All Frames
This command is similar to the Recalculate Selected Frames 
command (page 4-6), except that it forces a reinterpolation of 
keyframe data for all frames in the project, regardless of whether or 
not any objects or specific frames are selected. It is a way of “wiping 
the slate clean” of custom frames for the entire project.
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Calculate Auto Frames
This command is used to generate custom frames when they are not 
generated automatically. By default, custom frames are generated 
automatically when any of the following features are used:

• Attach to Object

• Look at Object

• Auto Rotate Object

If, however, you disable auto calculation of custom frames for the 
above procedures, you can use this command to generate them. For 
information on how to disable auto calculation of custom frames, 
refer to the section “Keyframe…” (page 2-9) in Chapter 2: The Edit 
Menu Commands.
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Chapter 5 The Tools Menu Commands

w
The commands in the Tools menu duplicate the icon buttons in the 
Tool Palette, which are discussed in Chapter 19: The Tool Palette. The 
Tools menu thus provides an alternate means of using the same 
functions. Also, some of these tools are available in the Project 
window’s tool palette, as discussed in the section “The Tool Palette” 
(page 8-26) in Chapter 8: The Project Window.
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Move
This command makes the Move tool (the default tool) the current 
tool (and keeps it the current tool until another tool is selected).

The Move tool enables you to move a selected object in any direction 
by dragging the object’s icon in a World View window, as shown in 
Figure 5.1.

Movement can be constrained in the horizontal, vertical and 
diagonal directions by repeatedly pressing the Tab key and cycling 
through a series of changes to the Move tool icon:

When the Move tool has this icon, movement will not be 
constrained.

When the Move tool has this icon, movement will be 
horizontally constrained.

When the Move tool has this icon, movement will be 
vertically constrained.

When the Move tool has this icon, movement will be 
diagonally constrained (to a 45° angle).

Figure 5.1   Move tool icon in a World View window

Move tool 
icon
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X Rotate
This command makes the X Rotate tool the current tool (and keeps it 
the current tool until another tool is selected).

The X Rotate tool enables you to rotate a selected object around its 
X axis by dragging the object’s icon in a World View window, as 
shown in Figure 5.2.

w
In the case of the camera or a parallel or spot light, an added benefit is 
the ability to rotate around the look–at point (the case for all 
rotational modes).

w
You can also rotate an object around its X axis with the Move tool 
(page 5-3) by pressing the Option and Control keys while dragging.

Figure 5.2   X Rotate tool icon in a World View window

X Rotate 
tool icon
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Y Rotate
This command makes the Y Rotate tool the current tool (and keeps it 
the current tool until another tool is selected).

The Y Rotate tool enables you to rotate a selected object around its 
Y axis by dragging the object’s icon in a World View window, as 
shown in Figure 5.3.

w
You can also rotate an object around its Y axis with the Move tool 
(page 5-3) by pressing the Command and Control keys while dragging.

Figure 5.3   Y Rotate tool icon in a World View window

Y Rotate 
tool icon
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Z Rotate
This command makes the Z Rotate tool the current tool (and keeps it 
the current tool until another tool is selected).

The Z Rotate tool enables you to rotate a selected object around its 
Z axis by dragging the object’s icon in a World View window, as 
shown in Figure 5.4.

w
You can also rotate an object around its Z axis with the Move tool 
(page 5-3) by pressing the Command, Option and Control keys while 
dragging.

Figure 5.4   Z Rotate tool icon in a World View window

Z Rotate 
tool icon
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Scale
This command makes the Scale tool the current tool (and keeps it 
the current tool until another tool is selected).

The Scale tool scales a selected object uniformly by dragging the 
object’s icon in a World View window, as shown in Figure 5.5.

w
The Scale tool applies only to geometric objects, not cameras or lights.

Figure 5.5   Scale tool icon in a World View window

Scale tool 
icon
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Zoom Window
This command makes the Zoom Window tool the current tool (and 
keeps it the current tool until another tool is selected).

The Zoom Window tool zooms in or out on an area of a window, 
centered on the point over which the tool’s magnifying glass icon is 
placed.

• Zooming in is the default, as indicated by a plus (+) symbol in the 
magnifying glass icon (as shown in Figure 5.6).

• To zoom out, hold down the option key, which changes the plus 
symbol to a minus (-) symbol.

w
Zooming in or out is done by a factor of 2 with each click of the mouse.

w
You can also zoom in on an area of the window by pressing the Option 
key while dragging a rectangle around the area.

Figure 5.6   Zoom Window tool icon in a World View window

Zoom 
Window 
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Drag Content
This command makes the Drag Content tool the current tool (and 
keeps it the current tool until another tool is selected).

The Drag Content tool scrolls the contents of a World View window 
(top, front or side) by clicking and dragging in the window, as shown 
in Figure 5.7.

w
You can also scroll the contents of a World View window with the Move 
tool (page 5-3) by pressing the space bar while dragging.

Figure 5.7   Drag Content tool icon in a World View window

Drag Content 
tool icon
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Visible Grid
This command toggles the visible grid on or off in the World View 
and Camera View windows, as shown in Figure 5.8.

w
Preferences for the dimensions and use of the visible grid are set with 
the Grid & Scale command in the Edit menu, as discussed in the 
section “Grid & Scale…” (page 2-17) in Chapter 2: The Edit Menu 
Commands.

Figure 5.8   Examples of a World View window with visible grid on and off
Visible Grid On Visible Grid Off
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Snapping Grid
This command toggles the invisible snapping grid on or off in the 
World View windows. The snapping grid is used to align objects to 
pre-determined positions—they will “snap” to a position when 
moved.

w
Preferences for the dimensions and use of the snapping grid are set with 
the Grid & Scale command in the Edit menu, as discussed in the 
section “Grid & Scale…” (page 2-17) in Chapter 2: The Edit Menu 
Commands.

w
You can also toggle the snapping grid by pressing the Caps Lock key.
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Group Deform
This command opens the Group Deformation window for the 
selected group.

The Group Deformation window, shown in Figure 5.9, is used to 
deform the group’s shape in various ways, including bending, 
twisting, tapering, stretching, etc.

w
For an explanation of the Group Deformation window and its use, refer 
to Chapter 16: The Group Deformation Window.

Figure 5.9   Group Deformation window
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Group’s Texture
This command opens the Group Texture window for the selected 
group.

The Group Texture window, shown in Figure 5.10, is used to set 
texture and reflection mapping for the group.

w
For an explanation of the Group Texture window and its use, refer to 
Chapter 14: The Group Texture Window.

w
You can also open the Group Texture window for a group by pressing 
the Command key while double-clicking the group’s icon.

Figure 5.10   Group Texture window
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Group’s Linkage
This command opens the Group Link window for the selected group.

The Group Link window, shown in Figure 5.11, is used to set pivot 
points and rotation information for the group.

w
For an explanation of the Group Link window and its use, refer to 
Chapter 15: The Group Link Window.

w
You can also open the Group Link window for a group by pressing the 
Command and Option keys while double-clicking the group’s icon.

Figure 5.11   Group Link window
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Group’s Modification
This command opens the Modify Axes window for the selected 
group.

The Modify Axes window, shown in Figure 5.12, is used to change 
the orientation of the group in local space (i.e., exchanging or 
reversing axes to, for example, make the top become the bottom, the 
front become the back, etc.).

Figure 5.12   Modify Axes window
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Show Motion Path
This command displays the path of motion for the selected object, as 
shown in Figure 5.13. No path is shown if the object has no 
keyframes, or has not changed position at all.

Figure 5.13   Motion path visible in a World View window

Motion path

Keyframes
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Hide Motion Path
This command hides the selected object’s path of motion (assuming 
its path is visible).

w
To show the motion path for a select object, use the Show Motion Path 
command (page 5-16).
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Link to Parent
This command allows you to choose a new parent for the selected 
object(s). If many objects are selected, the new parent will apply to all 
the selected objects.

To link an object to a new parent object:

1. Select the object to be linked (the child object) in either a World 
View or the Project window.

2. Choose Link to Parent from the Tools menu.

An instruction appears in the menu bar, as shown in Figure 5.14.

3. To complete the operation, click on the object to be the parent 
in either a World View or the Project window.

To cancel the operation, use the menu bar instruction as you 
would a menu and choose Terminate Operation, as shown in 
Figure 5.15.

w
To unlink an object from its parent object, refer to the section “Unlink 
from Parent” (page 5-19).

Figure 5.14   Instruction in menu bar

Figure 5.15   Canceling the operation
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Unlink from Parent
This command removes parentage from all selected objects.

w
To link an object to a parent object, refer to the section “Link to 
Parent” (page 5-18).
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Look at Object
This command forces the selected object to look at another object.

• If the selected object is the camera or a light, its reference point 
will be locked to the object it is looking at.

• If the selected object is a group, its rotation will be affected by the 
object it is looking at.

w
Use of this command will generate custom frames for the selected 
object’s reference (or rotation) channel.

To force an object to look at another object:

1. Select the object to be forced, in either a World View or the 
Project window.

w
An object can be forced to look at another object at any time in 
the animation, and for any range of frames.

2. To apply the command at a specific time, set the Project window 
to Time mode and move the time selector to the time at which 
the command is to start.

To apply the command for a range of frames, set the Project 
window to Keyframe or Frame mode and select the range of 
frames to be affected.

3. Choose Look at Object from the Tools menu.

An instruction appears in the menu bar, as shown in Figure 5.16.

4. To complete the operation, click on the object to be looked at, in 
either a World View or the Project window.

To cancel the operation, use the menu bar instruction as you 
would a menu and choose Terminate Operation, as shown in 
Figure 5.17.

Figure 5.16   Instruction in menu bar
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w
To remove the Look at Object function, refer to the section “Cancel 
Look at” (page 5-22).

Figure 5.17   Canceling the operation
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Cancel Look at
This command removes the Look at Object function (page 5-20) 
from the selected object (but does not recalculate custom frames).

w
To force an object to look at another object, refer to the section “Look at 
Object” (page 5-20).
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Attach to Object
This command forces the selected object to maintain its position 
relative to the position of another object. As the other object changes 
position, the selected object will change position.

w
Use of this command will generate custom frames for the selected 
object’s position and reference (or rotation) channels.

To attach an object to another object:

1. Select the object to be attached, in either a World View or the 
Project window.

w
An object can be attached to another object at any time in the 
animation, and for any range of frames.

2. To apply the command at a specific time, set the Project window 
to Time mode and move the time selector to the time at which 
the command is to start.

To apply the command for a range of frames, set the Project 
window to Keyframe or Frame mode and select the range of 
frames to be affected.

3. Choose Attach to Object from the Tools menu.

An instruction appears in the menu bar, as shown in Figure 5.18.

4. To complete the operation, click on the object to attach to, in 
either a World View or the Project window.

To cancel the operation, use the menu bar instruction as you 
would a menu and choose Terminate Operation, as shown in 
Figure 5.19.

Figure 5.18   Instruction in menu bar
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w
To remove the Attach to Object function, refer to the section “Detach 
from Object” (page 5-25).

Figure 5.19   Canceling the operation
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Detach from Object
This command removes the Attach to Object function (page 5-23) 
from the selected object (but does not recalculate custom frames).

w
To attach an object to another object, refer to the section “Attach to 
Object” (page 5-23).
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Auto Rotate Object
This command forces a moving object to follow the line of its motion 
path, rotating on its local axes and always “looking” in the direction 
of the path.

w
Use of this command will generate custom frames for the selected 
object’s rotation channels.

To automatically rotate an object on its motion path:

1. Select the object to be automatically rotated, in either a World 
View or the Project window.

w
An object can be automatically rotated at any time in the 
animation, and for any range of frames.

2. To apply the command at a specific time, set the Project window 
to Time mode and move the time selector to the time at which 
the command is to start.

To apply the command for a range of frames, set the Project 
window to Keyframe or Frame mode and select the range of 
frames to be affected.

3. Choose Auto Rotate Object from the Tools menu.

If the Auto Rotate sequence is for the camera or a light, you can 
override the length of the object’s reference vector.

To modify the reference vector:

1. Set the Project window to Keyframe mode and double-click on a 
cell in the Auto-Rotate channel, as shown in Figure 5.20.

w
Auto rotation sequences are numbered (AR #1, AR #2, etc.), 
permitting multiple auto rotation sequences for an object during 
the course of the animation.
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A dialog box, as shown in Figure 5.21, opens.

2. Enter a value in the Reference Length edit box. The value 
corresponds to the scale of the rulers in the World View 
windows.

3. Click OK or press Return.

w
To cancel the Auto Rotate function, refer to the section “Cancel Auto 
Rotate” (page 5-28)

Figure 5.20   Auto-Rotate channel in the Project window

Figure 5.21   Dialog box used to set auto rotation options
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Cancel Auto Rotate
This command removes the Auto Rotate function from the selected 
object (but does not recalculate custom frames).

w
To use the Auto Rotate function, refer to the section “Auto Rotate 
Object” (page 5-26)
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Overview
The World View windows are the drawing windows of the 
ElectricImage workspace. It is in these windows that objects (models, 
lights and the camera) are represented by icons which can be selected 
and dragged with the mouse. Also, the paths that objects travel (if 
animated) are visible as lines which can be edited in much the same 
way as lines are edited in most popular Macintosh drawing programs.

There are three World View windows, showing three views of the 
ElectricImage universe:

• Top (from the top looking down)

• Side (from the right side looking across to the left side)

• Front (from the front looking to the back)

Each view can also be changed to any of the other views. Figure 6.1 
shows a top World View window. 

Figure 6.1   Sample World View window

Visible grid (page 6-7)

Group icon (page 6-10)

Light icon (page 6-11)

Scroll bar (page 6-14)

Shading button (page 6-15)

Coordinate plane pop-up menu
(page 6-15)

Camera icon (page 6-9) Zoom buttons (page 6-14)
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Opening the World View Windows

The World View windows open automatically when ElectricImage is 
launched and a project file is opened. The windows can be closed and 
reopened, however, through the use of the following commands in 
the Windows menu:

• Top View, discussed in the section “Top View” (page 3-5) in 
Chapter 3: The Windows Menu Commands.

• Side View, discussed in the section “Side View” (page 3-6) in 
Chapter 3: The Windows Menu Commands.

• Front View, discussed in the section “Front View” (page 3-7) in 
Chapter 3: The Windows Menu Commands.
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Top View
The top World View window looks down on the universe from above, 
showing the X/Z coordinate plane, as illustrated in Figure 6.2.

In the top view, objects are seen and manipulated in global X and Z 
coordinate space only. The Y coordinate space for objects is therefore 
not affected in the top view.

Figure 6.2   X/Z coordinate plane (in gray) shown in the top view
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Side View
The side World View window looks toward the left of the universe, 
showing the Y/Z coordinate plane, as illustrated in Figure 6.3.

In the side view, objects are seen and manipulated in global Y and Z 
coordinate space. The X coordinate space for objects is therefore not 
affected in the side view.

˙

Figure 6.3   Y/Z coordinate plane (in gray) shown in the side view
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Front View
The front World View window, looks to the rear of the universe, 
showing the X/Y coordinate plane, as illustrated in Figure 6.4.

In the front view, objects are seen and manipulated in global X and Y 
coordinate space. The Z coordinate space for the object is therefore 
not affected in the front view.

Figure 6.4   X/Y coordinate plane (in gray) as shown in the front view
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Window Elements

Grid and Rulers

The World View windows contain grids and rulers to aid in 
positioning objects (groups, lights and the camera).

Visible Grid The visible grid is scaled to the first object added to the project, but 
can be rescaled, as shown in Figure 6.5.

Figure 6.5   Visible grid at two different scales

X, Y and Z scale set at 100

X, Y and Z scale set at 200
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Snapping Grid In addition to the visual grid, there is also an invisible snapping grid 
to which objects will “snap” when placed. Grid snap can be toggled 
on and off using either the Snapping Grid tool on the Tool Palette, 
as discussed in the section “The Snapping Grid Tool” (page 19-12) in 
Chapter 19: The Tool Palette, or the Caps Lock key.

Rulers The rulers are not displayed by default, but can be toggled on and off 
with the use of the Show Rulers command in the Windows menu, as 
discussed in the section “Show/Hide Rulers” (page 3-14) in 
Chapter 3: The Windows Menu Commands (or press Command-M). 
Figure 6.6 shows a World View window with rulers displayed.

Configuring the Display To configure the grid and ruler display to your own preferences, use 
the Grid & Scale… command in the Edit menu. For an explanation 
of the various grid and ruler settings, refer to the section “Grid & 
Scale…” (page 2-17) in Chapter 2: The Edit Menu Commands.

Figure 6.6   Rulers in a World View window

Rulers
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The Camera

Figure 6.7 shows the camera icon and its various elements.

Focal plane This box indicates the position of the camera. Dragging it changes 
the camera’s position, but not where it is looking.

Camera reference This arrowhead indicates the direction in which the camera is 
looking. Dragging it changes where the camera is looking but not its 
position.

View vector This line between the focal plane box and the reference arrowhead 
maintains a fixed orientation for the camera. Dragging it changes 
both the camera’s position and where it is looking.

Camera angle These lines indicate the angle of view seen by the camera’s lens, and 
is displayed only if enabled.

Fog projection These circles represent the area of fog, and is displayed only if 
enabled and if fog is specified in the Render Control window.

w
Camera angle and fog projection are not displayed by default. They 
must be enabled in the Camera Info window, which is also used to 
position and orient the camera with numerical values (refer to 
Chapter 10: The Camera Info Window). For an explanation of fog, 
refer to Chapter 9: The Render Control Window.

Figure 6.7   Camera icon elements

Focal plane (camera body)

View vector

Camera angle

Fog projection

Camera reference
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Groups

Figure 6.8 shows a group icon in its various levels of drawing detail.

Group extent This is a cube that surrounds a group and shows only the space in 
which the group exists. It also indicates, by way of a diagonal line 
through the center of the cube, in which direction the model is 
facing as it was imported into ElectricImage. The front face of the 
model is where the diagonal line touches the bottom of the cube.

Group vertices These are points that define a whole polygon.

Group polygons These are geometric entities denoting a surface or face of the group.

Group shading This shows the polygons of the group, accounting for the current 
lighting in the scene. There are two methods of shaded drawing:

• Shaded Poly level drawing is flat, with no smoothing.

• Shaded Pixel will draw smooth spotlighted areas—at the expense 
of processing speed.

w
The drawing level can be set on the fly with the Shading button 
(page 6-15) or by setting preferences with the Drawing… command in 
the Edit menu, as discussed in the section “Drawing…” (page 2-11) in 
Chapter 2: The Edit Menu Commands.

Figure 6.8   Group icon elements at different shading levels

Group
extent
level

Group
vertices

level
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Polygon
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Group
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6-10 ElectricImage™ Animation System



Window Elements

Book  Page 11  Friday, July 21, 2000  4:18 PM
Lights

Figure 6.9 shows a light icon and its various elements.

Light body This icon represents the position of the light.

Light reference This arrowhead represents the direction in which the light is pointed. 
It is applicable only to parallel and spot light types; radial, ambient, 
camera and tube light types radiate light in all directions.

Angle of coverage These lines represent the angle within which objects will be 
illuminated by the light, and is displayed only if enabled.

Dropoff distance This circle represent the distance from the light beyond which 
objects will not be illuminated by the light, and is displayed only if 
enabled.

Shadow angle These lines represent the angle within which objects illuminated by 
the light will cast shadows, and is displayed only if enabled.

Fog/glow projection These circles represent the area of visible fog or glow, if such effects 
are enabled.

w
Angles and distance visibility are enabled in the Light Info window, 
which is also used to select the light type, set special effects, and 
position and orient the light with numerical values (refer to 
Chapter 11: The Light Info Window).

Figure 6.9   Light icon elements

Light body

Angle of coverage

Shadow angle

Fog/Glow projection

Dropoff distance

Light reference
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Motion Paths

Figure 6.10 shows a motion path and its various elements.

Motion path This line represents the path followed by an animated object, and is 
visible only if the object is animated. There are four different spline 
types available for motion paths: linear, natural cubic, Hermite and 
Bezier. They are set in the Project window 

Keyframe This box represents the location of a keyframe.

Editing handles These are used to edit the motion path (for Bezier splines only).

Figure 6.10   Motion path elements

Motion path

Editing handles
(Bezier mode only) Keyframes
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Window Controls
In using the World View windows, there are several controls that you 
can use to manipulate the view, as shown in Figure 6.11.

The view can be changed in three basic ways:

• The area displayed can be changed by zooming in, zooming out 
and scrolling or dragging the window’s contents, as discussed in 
the section “Changing the Area Displayed” (page 6-14).

• The coordinate plane can be changed, effectively changing the 
view to top, side or front, as discussed in the section “Changing 
the Coordinate Plane” (page 6-15).

• The shading of groups can be changed to a higher level of detail, 
as discussed in the section “Changing the Shading Level” 
(page 6-15).

Figure 6.11   Window controls
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Changing the Area Displayed

There are several ways of changing the area displayed inside a World 
View window. To zoom in and out:

• Use the zoom buttons in the lower right corner of the window. 
To zoom in, click on the right zoom button. To zoom out, click 
on the left zoom button. To zoom in or out to a view that 
includes all objects in the project, hold down the option key 
while clicking either one of the zoom buttons.

• Use the Zoom Window tool from either the Tool Palette or the 
Tools Menu. To zoom in, click on the area you wish to zoom in 
on with the Zoom Window tool. To zoom out, hold down the 
option key while clicking with the Zoom Window tool. For an 
explanation of the Zoom Window tool, refer to the section “The 
Zoom Window Tool” (page 19-9) in Chapter 19: The Tool Palette, 
or the section “Zoom Window” (page 5-8) in Chapter 5: The Tools 
Menu Commands.

• Hold down the option key and drag a rectangle around the area 
you wish to zoom in on.

To scroll the window’s contents:

• Use the vertical and horizontal scroll bars.

• Use the Drag Content tool from either the Tool Palette or the 
Tools menu to scroll the window’s contents. For an explanation 
of the Drag Content tool, refer to the section “Zooming in or out 
is done by a factor of 2 with each click of the mouse.” (page 19-9) 
in Chapter 19: The Tool Palette, or the section “Drag Content” 
(page 5-9) in Chapter 5: The Tools Menu Commands.
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Changing the Coordinate Plane

The coordinate plane shown in a World View window can be 
changed to a top, side or front view through the use of the coordinate 
plane pop-up menu located to the left of the horizontal scroll bar in 
the lower left corner of the window, as shown in Figure 6.11 
(page 6-13).

This pop-up menu gives you the choice of Side, Top or Front, and its 
button changes to show the current display axes for the window.

w
Because you can use this pop-up menu to toggle among the side, top 
and front views, you can, if you wish, display only one world view 
window at a time and use the remaining space on your monitor for the 
Project window (and/or other windows).

Changing the Shading Level

Objects in the World View windows can be shaded to more readily 
observe the forms of models or to preview the effect of lighting in the 
scene. The various drawing levels are discussed in the section 
“Groups” (page 6-10).

The shading button in the lower left corner of the window, as shown 
in Figure 6.11 (page 6-13), can be used to change on the fly what a 
World View window will draw.

Clicking the button will shade the group(s) in the window. Pressing 
the Option key while clicking the button will open a pop-up menu 
that enables you to choose a drawing level for the window. The 
drawing levels are discussed in the section “Groups” (page 6-10).
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Overview
The camera view window shows what the camera is seeing at all 
times, with readouts for current time (represented as time code) and 
current frame. Figure 7.1 shows the Camera View window as it 
appears when ElectricImage is launched and a project file is opened.

w
The Camera View window simulates the view through the viewfinder of 
an actual production camera. When you look through the eyepiece of 
one of those cameras, the viewing image appears either on what is 
called the ground glass, or viewing reticle (film), or on a small CRT 
(video). The ground glass has lines etched upon it indicating various 
film projection formats, Title Safe and Action Safe areas. ElectricImage 
represents the maximum viewing (rendering) area by the white (or 
clear) rectangle in the Camera View window. This was done so you can 
tell when something is just outside of camera view (it comes in very 
handy when animating).

Figure 7.1   Camera View window

Aspect ratio and
area to be rendered (page 7-4)

Visible grid (page 7-4)

Shading button (page 7-8)

Preview button (page 7-9)

Field chart overlay (page 7-6)
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Opening the Camera View Window

The Camera View window opens automatically when ElectricImage is 
launched and a project file is opened. The window can be closed and 
reopened, however, through the use of the Camera View command 
in the Windows menu, discussed in the section “Camera View” 
(page 3-8) in Chapter 3: The Windows Menu Commands.
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Window Elements

Aspect Ratio and Area to be Rendered

In the Camera View window, the white rectangle shows the current 
aspect ratio of the image to be rendered. The aspect ratio is set in the 
Render Control window, as discussed in Chapter 9: The Render Control 
Window. It defaults to the current screen’s aspect ratio. Whatever falls 
within the white (or clear) rectangle will appear in the final image. 
Whatever falls outside, in the gray region, will be outside of the 
camera view when the image is rendered. Figure 7.2 shows how two 
different aspect ratios would appear in the Camera View window.

Visible Grid

The Camera View window contains a grid to aid in observing the 
scene (by providing perspective). The scale of the grid and the 
number of divisions can be configured to suit your requirements 
through the use of the Grid & Scale… command in the Edit menu, as 
described in the sections “Camera Grid Size” (page 2-18) and 
“Camera Grid Divisions” (page 2-18) in Chapter 2: The Edit Menu 
Commands.

When the camera is dragged, the grid is turned off (by default) to 
speed redrawing. To keep the grid turned on, use the Drawing… 
command in the Edit menu, as discussed in the section “Show Grid 
while dragging” (page 2-15) in Chapter 2: The Edit Menu Commands.

Standard 35mm (4:3) aspect ratio TechniScope aspect ratio

Figure 7.2   Aspect ratios in ElectricImage
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Changing What the Camera Sees

The camera is manipulated by either clicking and dragging it in any 
one of the three World View windows, or by editing numerical values 
in the Camera Info and Project windows. The effects of moving the 
camera are shown in the Camera View window:

• Dragging the reference point (arrow head) changes where the 
camera is looking.

• Dragging the focal plane (square) of the camera changes the 
position of the focal plane as well as its yaw and pitch, but the 
reference point remains stationary. As the camera is dragged 
around an object, it would always be looking in the direction of 
the reference point.

• Dragging on the line between the focal plane and reference will 
drag both camera and viewpoint, without affecting the yaw, 
pitch, or roll of the camera. This would equate to a “trucking” or 
“dolly” motion.

Objects Visible in the Camera View Window

Since the Camera View window displays what the camera sees at all 
times, the various objects in the project will be seen if they fall within 
the camera’s field of view. The window can be configured, however, 
to display or not display shading detail for models, the position of 
lights, and motion paths for animated objects. The section “Drawing 
Objects in the Camera View Window” (page 7-8) discusses how these 
elements are controlled.
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Window Controls

Field Chart Overlay

A field chart can be overlaid in the Camera View window and toggled 
on and off by clicking the Field Chart toggle button in the lower left 
corner of the window.

The components of the field chart can be activated or deactivated by 
holding down the Option key while clicking on the Field Chart 
toggle button. A pop-up menu will give you a choice of field chart 
components to be displayed. When all elements of the field chart are 
enabled, the result is similar to that shown in Figure 7.3.

For an explanation of the field chart elements, or how to set 
permanent field chart preferences, refer to the section “Field Chart…” 
(page 2-20) in Chapter 2: The Edit Menu Commands.

Figure 7.3   Camera View window with all field chart elements shown

Field Chart toggle button
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Fast Background Image Drawing

If the project contains a background image (single or multiframe) 
and the background image is set to be displayed in the Camera View 
window, the paint brush button appears at the bottom of the 
window, as shown in Figure 7.4.

Clicking on this button forces the background image to be drawn 
before anything else. Otherwise, the background image will be drawn 
slowly because other windows will be updated at the same time.

For an explanation of background images and how they are set to be 
displayed in the Camera View window, refer to the section 
“Background Image Control” (page 9-20) in Chapter 9: The Render 
Control Window.

Figure 7.4   Camera View window with background image
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Sphere model in project
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Drawing Objects in the Camera View Window

Objects in the Camera View window can be shaded to more readily 
preview the effect of lighting in the scene. The Camera View window 
can also show lights and motion paths.

The shading button in the lower left corner of the window, as shown 
in Figure 7.5, can be used to change on the fly what the Camera View 
window will draw.

Clicking the button will shade the group(s) in the window. Holding 
down the Option key while clicking the button will open a pop-up 
menu that enables you to choose a drawing level for the window as 
well as to enable or disable the drawing of lights and motion paths.

w
Preferences for drawing level can also be set with the Drawing… 
command in the Edit menu. For an explanation of the options for 
drawing level, see the section “Drawing…” (page 2-11) in 
Chapter 2: The Edit Menu Commands.

Figure 7.5   Shading button in Camera View window

Shading button
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Previewing Animations

Animations can be previewed in the Camera View window, or by 
writing the preview to an image file (for real time viewing in the 
Projector application) or to a QuickTime movie.

The preview button in the lower left corner of the window, as shown 
in Figure 7.6, is used to initiate a preview and also to specify on the 
fly the drawing level and output options for previews.

Clicking the button will initiate the preview. Holding down the 
Option key while clicking the button will open a pop-up menu that 
enables you to choose preview options.

w
Preferences for drawing level and output of previews can also be set 
with the Preview/Render… command in the Edit menu. For an 
explanation of the options for previewing animations, see the section 
“Preview/Render…” (page 2-26) in Chapter 2: The Edit Menu 
Commands.

Figure 7.6   Preview button in the Camera View window

Preview button (page 7-9)
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When the preview is output to the screen, the Camera View window 
changes slightly, as shown in Figure 7.7.

To stop the preview and return to the normal window display, click 
anywhere in the window.

Timing Indicators Beneath the white viewing area rectangle, from left to right, are a 
speed indicator, showing the actual playback speed of the animation 
in frames per second, the timecode readout, which gives a current 
frame count using SMPTE timecode, starting at time zero, and the 
current frame indicator, where the current frame is displayed.

Playback Controls Playback controls are visible in the lower scroll bar, and work in a 
similar fashion to the way VCR controls work. Clicking on the Pause 
button will pause the playback, and enable you to “step” through the 
animation by clicking on the step forward or step backward buttons.

You can go to the beginning of the animation at any time by clicking 
on the “Go To First Frame” button, or you can go to the end of the 
preview by clicking on the “Go To Last Frame” button.

Figure 7.7   Camera View window in preview mode

Playback controls

Timing indicators
7-10 ElectricImage™ Animation System



Rotoscoping

Book  Page 11  Friday, July 21, 2000  4:18 PM
Rotoscoping
Rotoscoping involves the “tracing” of existing images, usually to 
locate or isolate some component of the source image for later use in 
a special effect shot, or to match a motion for an element to be added 
later. When using a multiframe background image for rotoscoping, a 
frame count is displayed at the bottom of the window, along with the 
scroll bar.

In Figure 7.8, the display indicates the frame number of the 
background image that is currently being drawn in the window. The 
scroll bar is used to change the frame being displayed.

Figure 7.8   Using the Camera View window for rotoscoping
Current frame Scroll bar used to change the frame being displayed

Background image
(checkerboard)

Sphere model in project
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Overview
The Project window is the single most important window in 
ElectricImage. It contains a complete animation overview of the 
project and as such is very powerful, offering a great deal of 
information. It is in this window that you set the animation mode in 
which to edit the project, and where you can observe and animate all 
of the attributes within the project file.

There are four editing modes: Time, Keyframe, Frame and Index 
(discussed in detail on the following pages). The default view is Time 
mode, as shown in Figure 8.1.

In Time mode, the Project window is used to set the duration of the 
animation and the timing of individual events.

In the other modes, the Project window resembles a spreadsheet, 
with a column of editable data for each frame in the project 
(Keyframe and Frame modes show all frames; Index mode shows 

Figure 8.1   Project window in Time mode

Pop-up menu palette (page 8-19)

Editing mode pop-up menu
(page 8-5)

Frames per section pop-up menu
(page 8-14)

Object Status panel (page 8-17)

Object Name panel (page 8-18)

Tool palette (page 8-26) Time Scale (page 8-15)
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only the keyframes, listed in order of creation). You can thus use the 
Project window to specify virtually all attributes of the scene (as a 
supplement to clicking and dragging in the World View windows).

The Project window also accepts input from spreadsheet programs 
such as Microsoft® Excel or Mathematica™, as a means of, for 
example, importing formulas for animated sequences.

Opening the Project Window

To open the Project window, choose Project Window from the 
Windows menu, as discussed in the section “Project Window” 
(page 3-9) in Chapter 3: The Windows Menu Commands.
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Editing Modes
The appearance and use of the Project window differ according to the 
editing mode selected. The editing mode is selected in the editing 
mode pop-up menu, as shown in Figure 8.2.

There are four editing mode choices on the menu, as follows:

• Time Mode (page 8-6)

• Keyframe Mode (page 8-7)

• Frame Mode (page 8-8)

• Index Mode (page 8-9)

Figure 8.2   The Project window’s editing mode pop-up menu

Editing mode pop-up menu
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Time Mode

In Time mode (the default), the Project window appears as in 
Figure 8.3.

In this mode, the data panel contains timing control devices so that 
the Project window can be used to control the timing of events in the 
animation. For an explanation of these controls, refer to the section 
“Setting the Timing of Events” (page 8-15).

When in Time mode, the World View windows will draw objects at 
the currently active (selected) time. Those objects may or may not 
contain keyframes which are present at the current time.

Keyframes are automatically added any time you change the current 
time in the Project window (by dragging the time selector) and then 
set an event, such as changing the position of a model, or adjusting 
the color of a light.

Figure 8.3   The Project window in Time mode

Time Scale

Current time

Keyframe indicators
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Keyframe Mode

In Keyframe mode, the Project window appears as in Figure 8.4.

When in Keyframe mode, the Project window displays all events 
occurring in the project by keyframes and interpolated frames, with 
keyframes indicated by key icons. Therefore, instead of a time scale to 
set the current time (as is the case in Time mode), you are presented 
with a frame scale to select the current frame (in the example above, 
frame 49 is selected).

The Keyframe mode will actually let you edit animation values 
directly by clicking in a data cell, and then entering the new value in 
the edit box, as discussed in the section “Editing Data” (page 8-11). If 
you make a change or addition to a channel that does not contain a 
keyframe, a new keyframe is automatically added at that position.

In this mode you can also select a range of frames to which you can 
apply effects, as discussed in the section “Selecting a Range of 
Frames” (page 8-13).

Figure 8.4   The Project window in Keyframe mode

Selected (current) frame

Keyframe indicator

Interpolated frames
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Frame Mode

In Frame mode, the Project window appears as in Figure 8.5.

When in Frame mode, the Project window displays all events 
occurring in the project by actual frames. Setting the active frame in 
Frame mode works the same as in Keyframe mode (page 8-7), by 
clicking the frame number in the frame scale.

Unlike Keyframe mode, however, editing a frame’s data in Frame 
mode changes the value for that frame only—no keyframes are 
created and no interpolation will occur; you would be creating data 
that deviates from the keyframes you have created and the frames 
interpolated from those keyframes. This feature can be thus be used 
to create intentional “glitches” in the animation. (If you need to, you 
can always reinterpolate the frame list by selecting the range of 
frames and choosing Recalculate Frames from the Keyframe menu, 
or Recalculate All Frames for all frames.)

Changed frame values are underlined in the data cell, and the 
underline remains in the cell if you switch back to Keyframe mode.

Figure 8.5   The Project window in Frame mode

Edited frame value

Changed frame value
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Index Mode

In Index mode, the Project window appears as in Figure 8.6.

When in Index mode, the Project window displays keyframes only, 
by the order in which they were created for each object. The current 
index is set by clicking the appropriate value in the index scale at the 
top of the data panel.

In Figure 8.6, there are four keyframes for the camera (appearing in 
index columns 1 through 4) and one keyframe for the Light and 
Group (appearing in index column 1).

w
As in Keyframe and Frame modes, you can edit animation values 
directly, as described in the section “Editing Data” (page 8-11).

Figure 8.6   The Project window in Index mode
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Window Controls

Resizing and Scrolling the Display

All panels are resizable by moving the cursor to a vertical edge of a 
panel, clicking on it, and dragging that edge to its new location.

• If the size of the panel becomes too small, the edge will snap to 
the nearest edge of the next panel or window.

• If the size of the panel is too large, the edge stays at the 
outermost position indicating the panel’s maximum size.

The following controls are also available for scrolling the display:

• The horizontal scrollbar in the Object Name panel can be used if 
the names extend beyond the panel’s edges.

• In Frame and Keyframe modes, the horizontal scrollbar in the 
Object Data panel can be used if there are more cells to be 
displayed beyond the right edge of the window.

• In Time mode, the horizontal scroll bar is used to show more 
keyframes in the time line, if any.

• All panels can be scrolled vertically with the vertical scrollbar.

• In Time mode, the zoom controls in the lower right corner of the 
window can be used to zoom the window. Holding down the 
Option key while clicking either zoom control centers the time 
display between the start and stop times of the project.
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Editing Data

The Project window’s edit box is used to update information in the 
window’s data cells and to rename objects (e.g., lights and groups). 
The edit box functions in all editing modes other than Time mode.

To edit cell data: 1. Click in the data cell to be edited.

The cell is selected and the cell’s data is put into the edit box, as 
shown in Figure 8.7, highlighted for editing.

2. Type a new value for the cell.

3. Press Return.

The new data replaces the old data in the data cell.

Figure 8.7   Selected cell and its data in the edit box

Edit box

Selected cell
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To rename an object: 1. Click on the object’s name in the object panel.

The object is selected and the object’s name is put into the edit 
box, as shown in Figure 8.8, highlighted for editing.

2. Type a new name for the object.

3. Press Return.

The new name replaces the old name in the object panel.

Figure 8.8   Selected object and its name in the edit box

Edit box

Selected object
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Selecting a Range of Frames

In all editing modes other than Time mode, a range of frames can be 
selected, as shown in Figure 8.9, to restrict an operation to only those 
frames.

To select a range of frames, click on the first frame in the range and 
either drag to the last frame or shift-click on the last frame. 

Operations that can be performed on a range of frames include:

• Fill (page 8-22)

• Blend (page 8-23)

• Cycling (page 8-23)

• Look at Object (page 8-27)

• Attach to Object (page 8-28)

• Auto Rotate Object (page 8-29)

w
You can also paste cells from a Microsoft Excel file into a range of cells 
in the Project window. This enables you to create animation data from 
formulas in Excel, copy the Excel data to the clipboard or Scrapbook, 
and replace a selected range of frames in the Project window with the 
Excel data.

Figure 8.9   Example of selected range of frames
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Setting Frames Per Second

The FPS pop-up menu is used to select the number of frames per 
second to be calculated and rendered.

Along with duration, FPS determines the total number of frames for 
the animation (i.e., if the duration is 10 seconds, selecting 30 FPS 
calculates and renders 301 frames—frame 0 plus 300 frames).

The menu choices are:

Custom… This option opens a dialog box, shown in Figure 8.10, that enables 
you to specify a number other than the NTSC (30 FPS), PAL (25 FPS) 
or motion picture (24 FPS) standards.

NTSC: 30 This option uses the NTSC video standard of 30 FPS.

NTSC: 30i This option uses the NTSC video standard of 30 FPS, but with 
interlacing. Each frame is split into two fields, so that in Keyframe 
and Frame modes the data panel will show frames as 0a, 0b, 1a, 1b, 
2a, 2b, etc.

PAL: 25 This option uses the PAL video standard of 25 FPS.

PAL: 25i This option uses the PAL video standard of 25 FPS, but with 
interlacing. Each frame is split into two fields, so that in Keyframe 
and Frame modes the data panel will show frames as 0a, 0b, 1a, 1b, 
2a, 2b, etc.

Film: 24 This option uses the motion picture standard of 24 FPS.

Figure 8.10   Dialog box used to set custom frames per second
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Setting the Timing of Events

In Time mode, the horizontal time scale, shown in Figure 8.11, is 
used as a reference for setting the duration and timing of events, in 
seconds.

Time Selector The Time Selector is a vertical bar with a box at the top that contains 
the current time. To set the time at which events occur in the 
animation, drag the Time Selector by its box across the time scale. 
The value in the box changes as the Time Selector is dragged.

“Go” Icon The green “go” icon, which appears in the time scale, indicates the 
start time of the animation (it defaults to 0). The animation’s start 
time can be changed by clicking and dragging this icon to the left or 
right (activating the Time Selector).

“Stop” Icon The red “stop sign” icon, which also appears in the time scale, 
indicates the stop time, or duration, of the animation (it defaults to 
10 seconds; here it is seen at 5 seconds). The animation’s stop time 
(or duration) can be changed by clicking and dragging this icon to 
the left or right (activating the Time Selector).

Keyframe Icons The diamond-shaped icons in the data panel indicate the occurrence 
of keyframes at specific times in the animation. The times at which 

Figure 8.11   The Project window’s time scale

Keyframe icons

“Go” icon Time Selector with current time indicator “Stop” icon
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keyframes occur can be changed by clicking and dragging these icons 
to the left or right (activating the Time Selector).

In Figure 8.11, the animation is 3 seconds in duration (the green “go” 
icon is at 0 seconds on the time scale and the red “stop sign” icon is 
at 3 seconds on the time scale), with keyframes for Group occurring 
at 0 and 1.5 seconds. The keyframe at 1.5 seconds is currently 
selected, and that is where the Time Selector is currently visible.
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The Object Status Panel
Located down the left side of the Project window, this panel, as 
shown in Figure 8.12, shows flags indicating the status of an object’s 
visibility and selection locking.

The status can be changed by clicking on the appropriate icon:

• Clicking the visibility control toggles the visibility of the object. 
Invisible objects are not rendered, but animation information 
will be passed to their children (if so hierarchically structured).

• Clicking the selection lock prevents the object from being 
selected in the World View windows. It may still be selected in 
the Project window, however.

w
Pressing the Option key while clicking either of these controls will toggle 
the status of both the group you are clicking and any groups 
hierarchically linked below it.

Figure 8.12   The Project window’s status panel

Object Status Panel

Selection lock

Visibility control
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The Object Name Panel
Located to the right of the flag panel, the Object Name panel, as 
shown in Figure 8.13, contains window controls and titles for the 
objects in the project.

w
The appearance of an object’s children (groups hierarchically linked 
below the parent group) in the Object Name panel can be toggled on 
and off by pressing Command-H.

Objects can be selected by clicking on their icons or on their names. 
Double-clicking opens the object’s Info window.

w
Object names can be changed (except for the camera), using the Project 
window’s Edit box (page 8-12).

Figure 8.13   The Project window’s object panel

Object Name Panel
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The Pop-Up Menu Palette
The palette at the top of the Project window is a collection of pop-up 
menus used to control the Project window’s contents.

Clicking on the icon in the palette opens a pop-up menu, and some 
icons change to indicate the particular menu choice. The pop-up 
menus, from left to right, are:

Flat/Hierarchy View

This pop-up menu is used to control the window’s hierarchical 
display. The window can be viewed as either a hierarchical list or in 
order of creation, organized as class types, for camera, light, or 
model. The menu choices are:

Flat This option shows a flat listing of objects in order of creation.

Hierarchy This option (the default) shows objects in hierarchical order. 
Children are indented from the parent to show their relationship.

Snap to Frame

This pop-up menu (used in Time mode only) controls whether or not 
the Time Selector will snap to a frame or keyframe when it is dragged 
to a new position. The menu choices are:

None This option turns off the snap to frame function.

Snap to Frame This option (the default) causes the Time Selector to snap to a frame 
when it is dragged to a new position.

Snap to Keyframe This option causes the Time Selector to snap to a keyframe when it is 
dragged to a new position.
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Custom View

This pop-up menu is used to control what data is displayed in the 
Project window. The menu choices are:

All This option (the default) shows all data in the project file.

Custom… This option opens a dialog box, as shown in Figure 8.14, that enables 
you to specify which data for which object class to display.

1. Select the object class from the Element pop-up menu (Camera, 
Light or Group).

2. Click on the attributes in the window list below (shift-click to 
select more than one), or click All to select all attributes from 
the list (clicking None de-selects any selected attributes).

3. Either click OK or press Return.

Position This option shows only data for the position of objects.

Rotation This option shows only data for the rotation of objects.

Scale This option shows only data for the scale of objects.

Color This option shows only data for the color of objects.

Figure 8.14   Dialog box used to specify a custom view
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Open/Close

This pop-up menu is used to open or close the different levels of 
hierarchical data in the Project window’s data panel. The menu 
choices are:

Open Root This option opens data cells for all roots.

Open Selected Root This option opens data cells for selected roots.

Open Animated This option opens data cells for all animated values.

Open Selected Animated This option opens data cells for selected animated values.

Open All This option opens all data cells.

Open Selected All This option opens all data cells for selected objects.

Close All This option closes all data cells.

Close Selected All This option closes all data cells for selected objects.

Show/Hide Children This option toggles display of a parent object’s children (keyboard 
equivalent is Command-H).

Cell Size

This pop-up menu is used to change the size (width and height) of 
the key and frame cells. There is one selection from the pop-up 
menu, which opens a dialog box that enables you to specify values 
for column width and height.

w
Click the Default button to return to the default settings for cell size.
The ElectricImage™ Reference 8-21



Chapter 8: The Project Window

Book  Page 22  Friday, July 21, 2000  4:18 PM
Fill

This pop-up menu (used in Keyframe, Frame or Index modes) fills the 
data cells in a range of selected frames with a specified constant 
value. It can also be used to invert, scale and offset the values in the 
selected range frames.

w
The range of frames is selected by clicking and dragging or 
shift-clicking.

The menu choices are:

Fill Selected This option fills the selected range of frames with the data from the 
first (left-most frame) in the selection of frames. For example, 
selecting frames 1 through 5 and choosing this option would fill 
frames 2 through 5 with the data from frame 1.

Fill Constant… This option opens a dialog box that enables you to specify a value 
that will fill the selected range of frames.

Invert This option inverts the data in the selected range of frames (positive 
values become negative, and vice versa).

Scale… This option opens a dialog box that enables you to specify a factor by 
which the data in the selected range of frames will be scaled.

Offset… This option opens a dialog box that enables you to specify a value by 
which the data in the selected range of frames will be offset.
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Blend

This pop-up menu (used in Keyframe, Frame or Index modes) 
controls the blending of data across a range of selected frames 
(page 8-13), in order to “smooth” the data values in those frames in 
either a linear or curved fashion. This operation is very useful if you 
wish to smooth out rough moves, or create some kind of transition to 
Project window data values.

w
Blended frames are custom frames, denoted in the Project window by 
underlined text. Custom frames need to be reevaluated when changed, 
and that recalculation will occur when the animation is previewed, 
rendered or saved (or when recalculated manually).

The menu choices are:

Blend Linear This option uses a linear method of interpolating the data.

Blend Curve This option uses a curve method of interpolating the data.

Cycling

This pop-up menu (used in Keyframe or Frame modes only) controls 
the cycling of data across a range of selected frames (page 8-13), 
causing a sequence to repeat cyclically until the end of the 
animation. This operation is very useful for repetitive motion, such 
as a 5° rotation on a wheel, or the flapping wings of a butterfly. It can 
be used to increment motion as well.

w
Cycled frames are custom frames, denoted in the Project window by 
underlined text. Custom frames need to be reevaluated when changed, 
and that recalculation will occur when the animation is previewed, 
rendered or saved (or when recalculated manually).
The ElectricImage™ Reference 8-23



Chapter 8: The Project Window

Book  Page 24  Friday, July 21, 2000  4:18 PM
The menu choices are:

Repeat This option repeats the selected sequence of frames until the end of 
the animation. For example, repeating frames 1 through 5 would 
repeat the values from frames 1 through 5 starting with frame 6 and 
continuing until the end of the animation (i.e., the new sequence of 
frames would be 1, 2, 3, 4, 5, 1, 2, 3, 4, 5, 1, 2, 3, 4, 5, etc.).

w
When repeating within a range of keyframes, select all frame cells with 
the range except the very last keyframe. This will ensure a smooth 
transition between repeat cycles.

Oscillate This option oscillates the data from the selected sequence of frames 
until the end of the animation. For example, oscillating frames 1 
through 5 would take the values from frames 1 through 5 and repeat 
them in an oscillating sequence starting with frame 6 and continuing 
until the end of the animation (i.e., the new sequence of frames 
would be 1, 2, 3, 4, 5, 4, 3, 2, 1, 2, 3, 4, 5, etc.).

w
When oscillate repeating within a range of keyframes, select all frame 
cells with the range except the very last keyframe. This will ensure a 
smooth transition between repeat cycles.

Offset Repeat This option repeats and incrementally adds the values from the 
selected sequence of frames until the end of the animation. For 
example, offset repeating frames 1 through 5 would both repeat and 
add the incremental change in values from frames 1 through 5 
starting with frame 6 and continuing until the end of the animation 
(i.e., the new sequence of frames would be 1, 2, 3, 4, 5, 5+1, 5+2, 5+3, 
5+4, 5+5, 5+5+1, 5+5+2, 5+5+3, 5+5+4, 5+5+5, etc.).

w
When offset repeating within a range of keyframes, select all frame 
cells with the range including the very last keyframe. This is different 
than the previous choices due to the fact that offset is always adding 
the value and offset to the previous frame.
8-24 ElectricImage™ Animation System



The Pop-Up Menu Palette

Book  Page 25  Friday, July 21, 2000  4:18 PM
Render

This pop-up menu is used to specify the frames that are to be 
rendered.

w
The same options are available in the Render Control window’s Render 
pop-up menu, as described in the section “Render” (page 9-25) in 
Chapter 9: The Render Control Window.

The menu choices are:

All Frames This option (the default) renders all frames in the animation.

Range of Frames This option opens a dialog box for entering the specific start and stop 
frame numbers to be rendered.

Every Nth Frame… This option opens a dialog box for entering the specific nth frames to 
be rendered (i.e., every 2nd frame, every 3rd frame, etc.).
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The Tool Palette
The tool palette to the right of the pop-up menu palette contains a 
collection of tools from the Tool Palette and Tools menu. The tools 
(active only when an object is selected) from right to left, are:

Sound

This tool plays the selected soundtrack object. If a portion of the 
soundtrack is selected, only that portion will play. For information 
on adding soundtracks to a project, refer to the sections “Add > 
Sound…” (page 1-14) and “Add > Record Sound…” (page 1-15) in 
Chapter 1: The File Menu Commands.

Group Deform

This tool opens the Group Deformation window for the selected 
group. For an explanation of the Group Deformation window and its 
use, refer to Chapter 16: The Group Deformation Window.

Group’s Texture

This tool opens the Group Texture window for the selected group. For 
an explanation of the Group Texture window and its use, refer to 
Chapter 14: The Group Texture Window.

Group’s Linkage

This tool opens the Group Link window for the selected group. For 
an explanation of the Group Link window and its use, refer to 
Chapter 15: The Group Link Window.
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Link to Parent

This tool allows you to choose a new parent for the currently selected 
object. If many objects are selected, the new parent will apply to all 
the selected objects. To cancel the operation, press the 
command-period keys.

For more information on the use of this tool, refer to the section 
“Link to Parent” (page 5-18) in Chapter 5: The Tools Menu Commands.

Unlink from Parent

This tool removes parentage from all selected objects.

Look at Object

This tool forces the selected object to “look at” another object. If the 
selected object is the camera or a light, its reference point will be 
locked to the object it is looking at. If the selected object is a group, 
its rotation will be affected by the object it is looking at.

w
This tool creates custom frames for the selected object’s reference (or 
rotation) channels, denoted in the Project window by underlined text. 
Custom frames need to be reevaluated when changed, and that 
recalculation will occur when the animation is previewed, rendered or 
saved (or when recalculated manually).

For more information on the use of this tool, refer to the section 
“Look at Object” (page 5-20) in Chapter 5: The Tools Menu Commands.
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Cancel Look at

This tool removes the Look at Object function from the selected 
object (but does not recalculate custom frames).

Attach to Object

This tool forces the selected object to maintain its position relative to 
the position of another object. As the other object changes position, 
the selected object will change position. In effect, it is a way of 
temporarily connecting groups together, much like the hierarchy 
feature. The major difference is that the Attach to Object function is 
temporary and time-based, and can be cancelled at any point in the 
animation. Hierarchies, on the other hand, are global, and any 
changes made apply to the entire animation. Because of this, you 
should assign hierarchies before animating.

w
This tool creates custom frames for the selected object’s position and 
reference (or rotation) channels, denoted in the Project window by 
underlined text. Custom frames need to be reevaluated when changed, 
and that recalculation will occur when the animation is previewed, 
rendered or saved (or when recalculated manually).

For more information on the use of this tool, refer to the section 
“Attach to Object” (page 5-23) in Chapter 5: The Tools Menu 
Commands.

Detach from Object

This tool removes the Attach to Object function from the selected 
object (but does not recalculate custom frames).
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Auto Rotate Object

This tool forces the selected object to change its orientation as it 
follows its motion path, always “looking” in the direction it is going.

w
This tool creates custom frames for the selected object’s rotation 
channels, denoted in the Project window by underlined text. Custom 
frames need to be reevaluated when changed, and that recalculation 
will occur when the animation is previewed, rendered or saved (or when 
recalculated manually).

For more information on the use of this tool, refer to the section 
“Auto Rotate Object” (page 5-26) in Chapter 5: The Tools Menu 
Commands.

Cancel Auto Rotate

This tool removes the Auto Rotate Object function from the selected 
object (but does not recalculate custom frames).
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The Data Channel Panel
Located to the right of the object panel, the data channel panel 
contains the data (attributes) for objects in the project. In all editing 
modes other than Time, the data cells in this panel can be edited, as 
discussed in the section “Editing Data” on page 8-11.

Displaying Data Channels

When the Project window is first opened, the data channels are not 
displayed. Each object in the object panel can be opened up to list its 
data channels in much the same manner as folders in the Finder can 
be opened up to list their files.

w
You can also use the Open/Close pop-up menu in the Project window’s 
pop-up menu palette to open and close the display of selected 
attributes. Refer to the section “Open/Close” (page 8-21).

When the list becomes longer than the height of the window, you 
can then scroll the window’s contents with the window’s scroll bar.

Available Data Channels

The data channels available for the camera are listed in 
Appendix A: Camera Data Channels.

The data channels available for lights in the project are listed in 
Appendix B: Light Data Channels.

The data channels available for groups in the project are listed in 
Appendix C: Group Data Channels.

The data channels available for soundtracks in the project are listed 
in Appendix D: Sound Data Channels.
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Overview
The Render Control window, as shown in Figure 9.1, is used to set the 
current project’s global rendering attributes and/or to initiate 
rendering.

The window’s global settings enable, disable and override group level 
settings and special effects.

Opening the Render Control Window

To open the Render Control window, choose Render… from the File 
menu, as discussed in the section “Render…” (page 1-54) in 
Chapter 1: The File Menu Commands.

Figure 9.1   Render Control window

Global shading level (page 9-4)

Global transparency level (page 9-5)

Rendered image depth (page 9-6)

Camera aspect ratio (page 9-7)

Fog projection controls (page 9-9)

Image resolution controls
(page 9-11)

Image anti-aliasing controls
(page 9-12)

Motion blur controls (page 9-13)

Global Enable/Disable controls Background image Color settings
(page 9-16) (page 9-20) (page 9-19)

Video Interlacing Timing configuration controls
(page 9-18) (page 9-23)
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Global Shading Level
The Camera pop-up menu sets the maximum shading level used for 
the entire image. It overrides group level rendering settings, which 
are discussed in Chapter 13: The Group Info Window, and defaults to 
Phong shading, the highest quality shading level.

w
This global shading control is very useful for creating motion tests, 
where full quality Phong shading is not necessary (but faster rendering 
is). Rather than reduce the shading level for each group, reduce the level 
at this stage, then increase it again after the test is done.

The menu choices are:

Wireframe Shade This option overrides any Flat, Gouraud and Phong group level 
settings and renders groups in wireframe (for the fastest rendering 
times).

Wireframe images can be anti-aliased if the Anti-Aliasing pop-up 
menu (page 9-12) is set to either Adaptive or Oversample. Wireframe 
thickness in pixels is controlled by the Point/Line Thickness value, set 
in the Point/Line Thickness edit box (page 9-19).

Flat Shade This option sets the maximum shading level to Flat shading, which 
delivers the lowest quality (but fastest) solid rendering. It allows 
Wireframe and Flat shading set at the group level, but overrides any 
Gouraud and Phong shading set at the group level.

Gouraud Shade This option sets the maximum shading level to Gouraud shading, 
which delivers a higher quality (but slower) solid rendering than Flat 
shading. It allows Wireframe and Flat shading set at the group level, 
but overrides any Phong shading set at the group level.

Phong Shade This option, the default, sets the maximum shading level to Phong 
shading, allowing all shading types set at the group level. Phong 
shading provides the highest quality (but slowest) solid rendering.
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Global Transparency Level
The Transparency pop-up menu sets the maximum transparency 
level used for the entire image. It overrides group level transparency 
settings, which are discussed in the section “Transparency” 
(page 13-5) in Chapter 13: The Group Info Window, and defaults to 
Filter format, the highest level of transparency shading.

w
This setting is only relevant when rendering transparent groups.

The menu choices are:

Dither This option sets the maximum transparency level to Dither format, 
which provides only 16 levels of transparency and no transparency 
mapping, but with very fast rendering times. Any Filter format group 
level settings are overridden and transparent groups are rendered in 
Dither format.

Filter This option (the default) sets the maximum transparency level to 
Filter format, allowing all transparency formats set at the group level. 
Filter format provides 255 levels of transparency and transparency 
mapping, but with slower rendering times.
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Rendered Image Depth
The Image pop-up menu controls the final bit depth of the image to 
be rendered.

w
All images are first created in 32 bit color and then converted to the 
final image depth as set with this control. 256 color animations are 
histogrammed from the 32 bit IMAGE file, resulting in a consistent 
frame-to-frame 8 bit color palette. 256 shades are rendered directly in 
gray scale; no histogramming is required.

The menu choices are:

B&W Lines This option renders the image in black and white, with lines only. 
The shading level is set to Flat, overriding the Camera pop-up menu 
setting (page 9-4). Anti-aliasing is turned off.

B&W Filled This option renders the image in black & white, with polygons 
rendered in the same color. Shading level is set to Flat, overriding the 
Camera pop-up menu setting (page 9-4). Anti-aliasing is turned off.

B&W Dithered This option renders the image in black and white, with polygons 
shaded in a MacPaint-style dither pattern. The shading level is set to 
Flat, overriding the Camera pop-up menu setting (page 9-4). 
Anti-aliasing is turned off.

B&W Summation This option renders the image in black and white, with polygons 
shaded in a summation dither pattern. The shading level is set to 
Flat, overriding the Camera pop-up menu setting (page 9-4). 
Anti-aliasing is turned off.

256 Shades This option renders the image in gray scale, with normal polygon 
shading at the level set in the Camera pop-up menu (page 9-4).

256 Colors This option renders the image in optimized 8 bit color, with normal 
polygon shading at the level set in the Camera pop-up menu 
(page 9-4).

True Color This option renders the image in 32 bit color, with normal polygon 
shading at the level set in the Camera pop-up menu (page 9-4).
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Camera Aspect Ratio
The Aspect Ratio pop-up menu sets the aspect ratio for the 
image/animation to be rendered. The aspect ratio is the 
mathematical relationship between the X by Y pixels of the image to 
be rendered.

w
The default Macintosh aspect ratio is expressed as 4:3, given the pixel 
resolution of 640 by 480. ElectricImage will default to the aspect ratio 
of the startup display card. The current aspect ratio is equivalent to the 
aspect ratio of the white rectangle visible in the Camera window.

The menu choices are: 

Custom… This option opens a dialog box, as shown in Figure 9.2, for entering a 
custom aspect ratio (other than those on the menu).

Either enter values in the Horizontal Size and Vertical Size edit 
boxes (with units of measure a selected from the pop-up menu), or 
enter an aspect ratio in the Frame Aspect edit box, then either click 
OK or press Return.

Computer This option (the default) specifies the 4:3 aspect ratio of a native 
Macintosh display screen. Default focal length of the camera is set to 
2.0 on start up of the program. The focal lengths listed below are 
factored from this focal length, and the results have been rounded.

Super 8mm This option specifies the 4:3 aspect ratio of Super 8mm film. Focal 
length is 11mm.

Figure 9.2   Dialog box used to set a custom aspect ratio
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16mm This option specifies the 18:13 aspect ratio of 16mm film. Focal 
length is 21mm.

Super 16mm This option specifies the 5:3 aspect ratio of Super 16mm. Focal length 
is 25mm.

35mm This option specifies the 3:2 aspect ratio of 35mm slide film. Focal 
length is 75mm.

35mm Full This option specifies the 4:3 aspect ratio of full frame vertical 4 perf 
35mm film (also known as Academy aperture, after the Academy of 
Motion Picture Arts and Sciences). Focal length is 50mm.

VistaVision This option specifies the 3:2 aspect ratio of the VistaVision format (8 
perf horizontal). Focal length is 75mm.

65mm This option specifies the 16:7 aspect ratio of 65mm vertical 5 perf 
film. Focal length is 105mm.

IMAX This option specifies the 6:5 aspect ratio of 65mm horizontal 15 perf 
IMAX. Focal length is 141mm.

70 mm This option specifies the 2.19:1 aspect ratio.

TechniScope This option specifies the 2.35:1 aspect ratio.
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Fog Projection
w

Fog projection in ElectricImage simulates atmospheric “depth cuing” 
(aerial density). While it can simulate distant haze or fog in a 
landscape, it does not induce atmospheric effects such as visible light 
shafts or glows.

In order for the following settings to take effect, the Fog check box 
(page 9-16) must be enabled.

Fog Mode

This pop-up menu determines the type of transition that will occur 
between the region in which the fog effect starts, and the region in 
which the fog effect reaches its maximum density. The choices are:

Linear This method (the default) results in an even increase in density in the 
fog region, as defined by the fog radius edit boxes.

Exponential This method forces the density in the fog radius to increase in an 
exponential fashion.

Fog to

This pop-up menu determines the type of fogging technique to be 
used. The choices are:

Color This method (the default) fogs to a color selected with the Fog Color 
Button (page 9-19).

Alpha This method fogs to the alpha value 0 (transparent). When digitally 
compositing the scene, the objects enveloped by fog will eventually 
fade out to the composited background.

Background This method fogs to the background color as set in the Background 
Color button (page 9-19). The alpha value of the obscured objects 
will remain unchanged.
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Fog Radius

These edit boxes contain values that define the inner and outer fog 
radii of the camera. The inner radius is where the fog will begin, and 
the outer radius is where the fog will be the most dense.

The inner and outer fog radii are drawn in the world view windows as 
two circles which enclose the camera controls. These circles are 
visible only when the camera is selected.

The inner radius delineates where the fog effect would begin. The 
outer radius delineates where the fog value would reach maximum 
density (opacity).

The inner radius and outer radius edit boxes set the fog region. The 
origin of the fog region is at the camera position. The radii are listed 
as distances in world coordinate space.

To view the inner and outer fog radii in the World View windows, 
you must select the camera and enable the fog projection in the 
Camera Info window, as discussed in the section “Show Fog” 
(page 10-4) in Chapter 10: The Camera Info Window.
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Image Resolution
The Resolution pop-up menu and accompanying edit boxes 
determine the final X by Y pixel resolution of the image to be 
rendered. The resolution constrains to the aspect ratio set with the 
Aspect Ratio pop-up menu. The choices are:

• 260 x 200

• 320 x 240

• 640 x 480

• 1024 x 768

• 1280 x 960

• 2048 x 2048

• 4096 x 4096

• Current Screen (the default)

• NTSC

• PAL

• HDTV

• Abekas NTSC

• Abekas PAL

X and Y Edit Boxes These edit boxes contain values for resolution (allowing for manual 
entry of X and Y resolution values as opposed to choosing from the 
Resolution pop-up menu). The maximum theoretical resolution is 
16,000 pixels by 16,000 lines.

Pixel Ratio This edit box contains a value that controls the aspect ratio of each 
pixel when rendered. It defaults to 1.0 to render square pixels for 
display on Macintosh screens. NTSC, PAL and HDTV pixels are not 
square, however, so this control is available to adjust the pixel aspect 
ratio accordingly when necessary. The value in this box changes 
automatically according to the selection in the Resolution pop-up 
menu.
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Image Anti-Aliasing
Anti-aliasing is a filter which removes the jagged edge look (“jaggies”) 
from an image. 

Anti-Aliasing

This pop-up menu determines the quality of anti-aliasing used in an 
image. The choices are:

None This option specifies that no anti-aliasing be performed on the image.

Adaptive This option specifies that adaptive anti-aliasing be performed on the 
image. The resulting image appears sharper than the Oversample 
technique (discussed below) though reduction of video artifacts may 
not be as effective (depending on the thresholds set in the Adaptive 
Sampling Thresholds edit boxes, discussed below).

Oversample This option (the default) specifies that the oversample technique be 
performed on the image. This produces a softer image, but 
significantly reduces artifacting. It is the default because it produces 
consistently better images for video.

Adaptive Sampling Thresholds

The Min and Max edit boxes contain values that control the type of 
anti-aliasing to be performed between adjacent pixels of different 
color values. If the difference in levels between the pixels is less than 
the minimum value, the image is sharper. If the difference in the 
levels is greater than the maximum value, the image is softer. If the 
difference falls between the minimum and maximum values, 
adaptive anti-aliasing is performed. The higher the difference, the 
softer the image; the lower the difference, the sharper the image.
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Motion Blur
This section of the Render Control window is used to control the 
various motion blur features of ElectricImage.

Shutter Angle

This edit box contains a value in degrees for the circular angle at 
which the camera shutter is open. A value of 360° simulates a shutter 
that is always open. A value of 180° (the default) simulates a shutter 
that is open for half a frame, mimicking a motion picture camera. 
This feature controls the length of the motion blur streak in that the 
higher the shutter angle value, the longer the streak.

w
Streak length is computed by the distance an object moves past the 
camera’s field of view from frame to frame.

Point/Line

This check box, when checked, enables the point/line motion blur 
technique at the global level. In this mode, only points and lines 
leave streaks behind them.

w
This technique is most suitable for motion blur of star streaks and 
particle systems.

Blur Intensity

This edit box, used only in conjunction with the Point/Line 
technique, contains a value that controls the brightness of streaks left 
by points and lines. A value of 0.0 (the default) imparts a constant 
value regardless of the length of the streaks. Large values produce 
brighter streaks. Smaller values produce dimmer streaks. In general, 
the longer the streak the dimmer the streak.
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Motion Vector

This check box, when checked, enables the motion vector technique 
at the global level. All model elements (points, lines and polygons) 
are blurred. Blurs are always linear—they are never curved when 
viewed as a single frame.

w
This is a fast, versatile and very high quality technique. It is most 
suitable for rendering single elements which can later be composited 
together to produce the final animation. An example of when not to use 
this technique is for spinning fan blades partially obscured by their 
stationary housing. This would produce undesirable results, and would 
be better served by the Multi-Frame technique (discussed below).

Blur Noise

This edit box, used only in conjunction with the Motion Vector 
technique, contains a value for the number of blur samples per pixel. 
The higher the number, the less visible noise in the streak. A value of 
zero produces the maximum number of samples for a streak based on 
its length. A value of 4 (the default) renders quickly and produces 
high quality results. Values over 10 will drastically slow rendering 
and will not improve the image.

Multi-Frame

This check box, when checked, enables the multi-frame technique, 
which renders multiple samples of each frame at different times 
before averaging them together. It takes longer to render and can 
produce a strobe-like effect if too few samples are rendered. The 
number of samples is set in the Blur Frames edit box, discussed below.
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w
This technique, which can be used in conjunction with the Point/Line 
and Motion Vector techniques, is best applied to a range of frames (as 
opposed to the entire animation) when there is complex or rapid 
motion. 

Blur Frames

This edit box, used only in conjunction with the Multi-Frame 
technique, contains a value for the number of samples rendered for 
each frame before they are averaged together. The time required to 
render a single frame with this technique is the Blur Frames value 
times the amount of time required to render the frame without 
blurring.
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Global Enable/Disable Controls
These check boxes are used to turn on or off special effects functions. 
The effects are enabled if the boxes are x’ed.

Fog This check box option enables/disables the fog feature. It defaults to 
off. When enabled, the fog radius projection is displayed in the World 
View windows.

Ambient This check box option enables/disables the global ambient feature. If 
defaults to on. To view or change the value of the global ambient, 
click on the Ambient button, located in the upper right corner of the 
window (page 9-19).

Background This check box option enables/disables the selected background color 
or image. It defaults to off. When a background color or image has 
been assigned, this check box is automatically enabled.

Textures This check box option enables/disables texture maps for rendering. It 
defaults to on. This function must be on for texture maps to be 
rendered.

Reflections This check box option enables/disables reflection maps for rendering. 
It defaults to on. This function must be on for reflection maps to be 
rendered.

Color Blend This check box option enables/disables the color blend effect. It 
defaults to off. All groups flagged for color blending at the group level 
are enabled with this option on.

Super Sample This check box enables/disables the super sample effect. It defaults to 
off. All groups flagged for super sampling at the group level are 
enabled with this option on.

Enable Shadow This check box enables/disables the casting and receiving of shadows 
set at the individual light and group level. It defaults to on.
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MIP Enable This check box enables/disables MIP mapping. It defaults to on.

w
ElectricImage provides two methods of filtering for texture, reflection, 
bump and environment maps: MIP and summation. These are used to 
negate the moire and popping effects which occur when attempting to 
map a finite grid of pixels onto the surface of an infinitely resolvable 
model. MIP mapping can sometimes result in “blurry” images. The 
alternative is summation mapping (see below), which creates texture 
maps that appear sharper. Summation mapping requires more memory, 
however, than MIP mapping.

Sum Enable This check box enables/disables summation mapping. It defaults to on.

Add Noise This check box enables/disables the addition of dithering noise to 
images, which eliminates banding. It defaults to on. There is really no 
reason to disable this function, as doing so will effectively reduce 
image quality.
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Video Interlacing Control
The Even Field check box enables/disables Even Field interlace 
rendering. It defaults to off.

w
With Even Field rendering, video field 2 is rendered first, then video 
field 1, putting the even video field before the odd field. Normally, video 
always displays field 1, the odd field, first, however some Macintosh 
display cards may flip the field order.
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Color Settings

Fog

This color button sets the color of the fog value for the image to be 
rendered, if Fog to Color is the method selected from the Fog to 
pop-up menu (page 9-9). Click on the button to get to the Apple 
Color Picker to change the fog color. The new fog color will appear in 
the button.

Ambient

This color button sets the minimum light value of the image to be 
rendered.

It can be used to prevent dark areas of the image from going 
completely black. Click on the button to get the Apple Color Picker 
to change the minimum amount of fill. The new color value will 
appear in the button.

Background

This color button sets the color of the background of an image to be 
rendered. Click on the button to get to the Apple Color Picker to 
change the background color. The new background color will appear 
in the button.

Wireframe Point/Line Size
When a project is rendered in wireframe, as selected from the Camera 
pop-up menu (page 9-4), the thickness of points and lines in the 
wireframe defaults to 1 pixel. You can specify a different thickness, 
however, with the Point/Line Thickness edit box.
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Background Image Control
The Background Image button is used to assign an image to be 
composited into the background when the image is rendered. This 
eliminates the need to digitally composite the foreground and 
background later. The button is also used to remove a previously 
assigned background image.

w
The background image can either be a single frame or an animation, 
but must be in Image format. (Refer to The Projector Reference for 
information on converting other picture file formats to Image.)

To add a background:

1. Click on the Background Image button.

A dialog box, as shown in Figure 9.3, opens.

If there is already an image assigned to the background, it is 
shown in the Background: window. Otherwise, that window is 
empty (as in Figure 9.3).

2. Click in the Background: window of the dialog box.

Figure 9.3   Dialog box used to add/remove background image
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A directory dialog box, as shown in Figure 9.4, opens.

3. Open the folder where the background image file is located 
(if necessary).

4. Click on the background image filename.

When selected, the file’s RGB channels are displayed in the 
window to the left of the file list. The Show pop-up menu above 
the display window can be used to also show the file’s alpha 
channel (if it has one) and the file’s image depth and dimensions 
in pixels.

5. Either click Add or press Return.

The directory dialog box closes and the dialog box shown in 
Figure 9.3 (page 9-20) reappears with the selected background image 
shown in the Background Image window.

6. If you wish to see the background image in the Camera View 
window, click the Show in Camera View check box.

7. When done, either click OK or press Return.

Figure 9.4   Directory dialog box used to add background image
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To remove a background:

1. Click on the Background Image button in the Render 
Control window.

The dialog box shown in Figure 9.3 opens.

2. Click in the Background: window of the dialog box.

The directory dialog box shown in Figure 9.4 opens.

3. Click the Remove button.
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Timing Configuration

Start Time and Stop Time

These edit boxes contain values for the start and end times of a 
sequence of frames to be rendered. The start time represents the 
beginning of the sequence of frames, and the stop time represents the 
end of the sequence.

w
The start and stop times are represented in the Project window when in 
Time mode by the green “Go” sign and the red “Stop” sign, located in 
the horizontal time scale. For an explanation of the Project window 
and Time mode editing, refer to “Time Mode” (page 8-6) in 
Chapter 8: The Project Window.

Total Frames

This edit box contains a value for the number of frames to be 
rendered. A number greater than one must be entered here if an 
animation is to be rendered and/or to preview an animation in the 
Camera View window. This number is the result of the formula:

((( timerange x FPS + 1 = total frames )))

where timerange equals the duration of the animation in seconds 
(the distance between the Start and Stop icons in the Project 
window’s time scale), FPS is the number of frames per second selected 
(see the FPS pop-up menu discussion on the next page), and the 1 is 
for an additional frame because the first frame in the animation is 
Frame 0.

The total frames is included in this window primarily as a reference. 
Changing the number in this edit box will result in the Project 
window’s stop sign being reset based on the above formula.
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Nth Frame

This check box option with edit box is used to specify that only every 
nth number of frames (as set in the edit box) should be rendered. The 
edit box contains a value for the nth number of frames to be 
rendered (i.e., 1 for every frame, 2 for every second frame, 3 for every 
third frame, etc.).

w
This feature works independently of the Render pop-up menu 
(page 9-25); that is, no matter what you select from the Render pop-up 
menu (all frames or a range of frames), the Nth frame value will cause 
every Nth frame of that selection to be rendered.

FPS

This pop-up menu is used to select the number of frames per second 
(FPS) to be calculated and rendered. When taken into consideration 
with the duration of the animation, FPS determines the total number 
of frames for the animation.

The menu choices are:

Custom… This option brings up a dialog box for entering a specific FPS, as 
shown in Figure 9.5.

Enter a number other than the NTSC (30 FPS), PAL (25 FPS) or 
motion picture (24 FPS) standards. For interlace rendering, click the 
Interlace check box (see explanation of interlace rendering, below).

NTSC: 30 This option (the default) specifies the NTSC video standard of 30 FPS.

Figure 9.5   Dialog box used to specify custom FPS
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PAL: 25 This option specifies the PAL video standard of 25 FPS.

Film: 24 This option specifies the motion picture standard of 24 FPS.

Interlace Rendering Selecting either NTSC:30i or PAL:25i enables interlace rendering. 
Each frame is split into two fields, with the odd field dominant unless 
the Even Field check box is enabled.

Render

This pop-up menu is used to select the range of frames that are to be 
rendered. The menu choices are:

Current Frame This option (the default for single-frame projects) causes only the 
current frame in the animation to be rendered.

All Frames This option (the default for multi-frame projects) causes all frames in 
the animation to be rendered.

Range of Frames This option opens a dialog box for entering the specific start and stop 
frame numbers to be rendered.

w
These options are affected by the value in the Nth Frame edit box 
(page 9-24); that is, no matter what you select from the pop-up menu 
(all frames or a range of frames), the Nth frame value will cause every 
Nth frame of that selection to be rendered.
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Rendering the Project
To initiate rendering, click the Go button in the lower right corner of 
the window, which will close the project and launch the 
ElectricImage Camera application.

w
For an explanation of the Camera interface, refer to Chapter 22: The 
ElectricImage Camera.
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Overview
The Camera Info window, as shown in Figure 10.1, contains settings 
for the camera’s icon display in the World View windows, and 
current stats on its location in global space, directionality, and 
orientation (yaw, pitch and roll).

Opening the Camera Info Window

To open the Camera Info window, select the camera, then choose 
Camera Info from the File menu (or double-click on the camera).

Figure 10.1   The Camera Info window

Icon display options (page 10-3)

Focal length (page 10-7)

Field of view (page 10-7)

Coordinates (page 10-6) Reference (page 10-6) Yaw, pitch and roll (page 10-6)

Focal mode (page 10-8) Camera roll control (page 10-6)
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Icon Display Options
The left side of the Camera Info window contains check boxes which 
control two elements of the camera icon’s display in the World View 
windows:

• the projection of the camera’s viewing angle

• the fog effect

For more information on these elements, refer to the section 
“Window Elements” (page 6-7) in Chapter 6: The World View 
Windows.

Show Angle

This check box option enables the display of the camera’s viewing 
angle (focal length projection) in the World View windows, as shown 
in Figure 10.2.

The viewing angle emanates from the center of the camera and 
projects two lines which define the maximum view area of the lens as 
indicated in the Focal Length edit box.

Figure 10.2   Camera icon’s viewing angle projection

Area within the camera’s view
(will be seen by camera)

Area outside the camera’s view
(will not be seen by camera)
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Show Fog

This check box option enables the display of a circular fog projection 
in the World View windows, assuming that fog has been set in the 
Render Control window.

w
This type of fog is used primarily for “depth cuing,” in much the same 
way as atmospheric haze renders distant objects less distinct than 
objects close to the viewer’s eye. For an explanation of the use of fog 
and the fog settings in the Render Control window, refer to the section 
“Fog Projection” (page 9-9) in Chapter 9: The Render Control Window.

As shown in Figure 10.3, the fog projection emanates from the center 
of the camera, and is defined by two circles:

• The dark circle shows the outer extent of the fog boundary.

• The lighter circle shows the inner part of the fog boundary.

Figure 10.3   Camera icon’s fog projection

Inner part of fog boundary

Outer extent of fog boundary
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Current Stats
The right side of the Camera Info window contains information 
about the camera’s position in global space, it’s direction and 
orientation (yaw, pitch and roll), and its lens’ focal length and field of 
view. There is also an interactive control for setting the camera’s roll.

Changing the values in this section of the window produces different 
results, depending on which editing mode is in effect when the 
camera is selected:

• In Index mode, changing the values updates the values for the 
current keyframe.

• In Frame mode, changing the values creates a custom frame that 
includes the new values. A custom frame is not affected by the 
interpolation of frames between keyframes, and can thus be used, 
for example, to create a glitch in the animation of the camera’s 
position.

• In Keyframe mode, changing the values either updates the 
values for the current keyframe (if the selected frame coincides 
with an existing keyframe) or creates a new keyframe that 
includes the new values (if the selected frame does not coincide 
with an existing keyframe).

• In Time mode, changing the either updates the values for the 
current keyframe (if the selected point in time coincides with an 
existing keyframe) or creates a new keyframe at the selected point 
in time that includes the new values (if the selected point in time 
does not coincide with an existing keyframe).

w
The editing mode is set in the Project window. For an explanation of 
editing modes and the Project window, refer to Chapter 8: The Project 
Window.
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Camera (X, Y and Z)

These edit boxes contain values for the camera’s X, Y, and Z 
coordinates (its physical location in global space), at the current 
keyframe, frame or point in time (depending on the editing mode in 
effect).

Reference (X, Y and Z)

These edit boxes contain values for the X, Y and Z coordinates of the 
camera’s reference point (the point at which the camera is aimed). 
The camera’s reference point is represented in the World View 
windows by the arrow on the camera icon. As with the Camera edit 
boxes, above, the values in the Reference edit boxes are those for the 
current keyframe, frame or point in time (depending on the editing 
mode in effect).

Angles (Yaw, Pitch and Roll)

These edit boxes contain values, in degrees, for the camera’s 
orientation at the current keyframe, frame or point in time 
(depending on the editing mode in effect), and are an absolute 
reference.

Camera Roll Control

This interactive control is used to set the camera’s roll angle for the 
current keyframe, frame or point in time (depending on the editing 
mode in effect). It is an alternative method to entering a value in the 
Roll edit box, above. To induce a roll angle, drag in the control 
region. The Camera View window and Camera Roll edit box will 
update as the control is actuated.
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Focal Length

This edit box contains a value for the focal length of the camera’s 
synthetic lens at the current keyframe, frame or point in time 
(depending on the editing mode in effect), and is an absolute 
reference.

The number in this box is case sensitive, and is determined by the 
Aspect Ratio pop-up menu in the Render Control window. As the 
aspect ratio is changed the focal length of the camera would be 
recalculated accordingly. The focal length value is in millimeters if 
the aspect ratio is other than Computer (otherwise it is a scale value). 
For more information on aspect ratios and the Render Control 
window, refer to Chapter 9: The Render Control Window.

w
When using the cine aspect ratios, the focal length calculation 
corresponds to the recommendations found in the American 
Cinematographers Manual.

Field of View

This edit box contains a value, in degrees, for the view angle of the 
camera’s synthetic lens. The text in this edit box always corresponds 
to the camera lens’ focal length (contained in the Focal Length edit 
box, above). Either value can be changed at any time, and changing 
one automatically changes the other.
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Focal Mode

This pop-up menu controls how the focal length is calculated. The 
menu choices are:

Vertical This option calculates the focal length based upon the frame’s 
vertical dimension.

Horizontal This option (the default) calculates the focal length based upon the 
frame’s horizontal dimension.

Diagonal This option calculates the focal length based upon the frame’s 
diagonal dimension.
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Overview
The Light Info window, as shown in Figure 11.1, contains permanent 
settings for the light’s light type and shadow characteristics, current 
stats on the light’s color, intensity, location in global space, 
directionality, and angle of coverage, and current settings for special 
effects such as glow and fog.

Opening the Light Info Window

To open the Light Info window for a specific light, select the light, 
then choose Light Info from the File menu (or double-click on the 
light’s icon).

Figure 11.1   The Light Info window

Light Modes (page 11-4)

Icon display options (page 11-7)

Lens flare settings (page 11-16)

Shadow settings (page 11-13)

Glow settings (page 11-15) Fog Settings (page 11-15)

Other settings (page 11-20) Current Stats (page 11-10)
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Light Modes
This pop-up menu in the upper left side of the Light Info window is 
used to select the type of light. The available light modes are as 
follows:

Camera

This type of light simulates a point light that is attached to the 
camera itself. It is radial in nature (in that all beams of light from this 
source emanate from it’s center).

Parallel

This type of light simulates a light placed an infinite distance away. 
The light rays are parallel, providing an even illumination. Use this 
type for sunlight, stars, etc. This is the best light source for 
illuminating flat shaded scenes.

Radial

This type of light (the default) simulates artificial lights, by nature of 
the way the rays emanate radially, like the spokes of a wheel, from 
the center of the light. The light has no sense of direction, just 
location and dropoff.

w
Radial lights can also be set to be darklights. When a dropoff other 
than zero is specified in the Dropoff edit box (see below), a negative 
intensity can be used in the intensity box to create a subtractive 
lighting effect. Whatever color is specified in the Color Button (see 
below) will be subtracted from the scene.
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Ambient

This type of light simulates a non-directional, overall illumination, 
much like you would see on a cloudy day. It is normally used so that 
objects don’t shade to absolute black.

w
An ambient light, as with all lights (except for darklights), adds more 
light to the scene. This can result in images appearing to be 
overexposed. To compensate for a strong ambient light, drop the 
intensity value of your other lights accordingly. It takes some practice, 
but the ambient light can add tremendous realism to a scene when 
used properly.

The Ambient button in the Render Control window sets a minimum 
amount of light which falls onto any surface and will not over expose 
the image. For more information about the Ambient button and its 
use, refer to the section “Ambient” (page 9-19) in Chapter 9: The 
Render Control Window.

Spot

This type of light simulates a directional, limited area light, placing a 
pool of light over a specified area. The pool is circular in nature, and 
the lights contain several different variables, such as an inner and 
outer cone size (note that the inner cone is always smaller than the 
outer cone), which controls the umbra and penumbra of the light. 
The dropoff distance of the spotlight can also be set, as well as 
whether or not the effective dropoffs are calculated linearly or 
logarithmically.

w
Spotlights can also be set to be darklights. When a dropoff other than 
zero is specified in the Dropoff edit box (see below), a negative intensity 
can be used in the intensity box to create a subtractive lighting effect. 
Whatever color is specified in the Color Button (see below) will be 
subtracted from the scene.
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Tube

This type of light simulates artificial lights from a tube-like source. A 
tube light is basically an elongated radial light (its length can be 
adjusted) which, when used as a fog or glow light, can create visual 
effects such as fluorescent bulbs or laser beams.
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Icon Display Options
The upper left side of the Light Info window contains check boxes 
which control four elements of the light icon’s display in the World 
View windows. For more information on these elements, refer to the 
section “Window Elements” (page 6-7) in Chapter 6: The World View 
Windows.

Show Angle

This check box option enables the display of the light’s spotlight 
and/or shadow cone angle in the World View windows.

As Figure 11.2 shows, the cone angle projection emanates from the 
center of the light toward the direction indicated by the reference 
point of the light. It will project four lines which define the 
maximum area of the cone as indicated in the Inner Cone and Outer 
Cone edit boxes, discussed below.

Figure 11.2   Light icon’s angle display

Outer cone

Inner cone
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Show Dropoff

This check box option enables the display of the light’s dropoff 
indicator, as shown in Figure 11.3, when the light is selected.

Show Fog/Glow Radius

These check boxes enable the display of the light’s fog and glow radii, 
as shown in Figure 11.4, when the light is selected.

w
For more information on the fog and glow effects, refer to the section 
“Special Effects (Glow and Fog)” (page 11-15).

Figure 11.3   Light icon’s dropoff display

Dropoff indicator

Figure 11.4   Light icon’s fog radius display

Inner radius

Outer radius
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Show Size

This check box option enables the display of the light’s size, as shown 
in Figure 11.5, when the light is selected.

Show Flare

This check box option enables the display of the light’s flare in the 
Camera View window, as shown in Figure 11.6.

Figure 11.5   Light icon’s size display

Size indicator

Figure 11.6   Lens flare shown in Camera View window

Lens flare indicators
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Current Stats
The upper right corner of the Light Info window contains 
information about the light’s color, intensity, angle of coverage, 
position in global space and reference (direction).

Changing the values in this section of the window produces different 
results, depending on which editing mode is in effect when the light 
is selected:

• In Index mode, changing the values updates the values for the 
current keyframe.

• In Frame mode, changing the values creates a custom frame that 
includes the new values. A custom frame is not affected by the 
interpolation of frames between keyframes, and can thus be used, 
for example, to create a glitch in the animation of the camera’s 
position.

• In Keyframe mode, changing the values either updates the 
values for the current keyframe (if the selected frame coincides 
with an existing keyframe) or creates a new keyframe that 
includes the new values (if the selected frame does not coincide 
with an existing keyframe).

• In Time mode, changing the either updates the values for the 
current keyframe (if the selected point in time coincides with an 
existing keyframe) or creates a new keyframe at the selected point 
in time that includes the new values (if the selected point in time 
does not coincide with an existing keyframe).

w
The editing mode is set in the Project window. For an explanation of 
editing modes and the Project window, refer to Chapter 8: The Project 
Window.
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Light Color

This button selects the color of the light at the current keyframe, 
frame or point in time (depending on the editing mode in effect). 
When the color button is clicked, the Apple Color Picker comes 
forward for color selection. The color button will then change to the 
color of the light, and the center of the light icon will also change to 
the new color in the world view windows (when deselected).

Intensity

This edit box contains a value for the brightness of the light at the 
current keyframe, frame or point in time (depending on the editing 
mode in effect). The default intensity is 1. If it is necessary to increase 
the brightness of the light, then the Intensity value should be greater 
than 1. If a “darklight” effect is required (where light is subtractive 
rather than additive), then a negative value should be entered into 
the box.

Dropoff

This edit box contains a value for the dropoff distance of a light at 
the current keyframe, frame or point in time (depending on the 
editing mode in effect). Dropoff is not available for parallel lights or 
ambient lights. You can use the rulers (command-M) to see the actual 
scale of your scene, and to determine the dropoff distance you would 
like to use. To view the dropoff in the world view windows, click the 
Show Dropoff check box in the upper left corner.

Size

This edit box contains a value for the size of the light.
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Outer Cone (for Spot mode only)

This edit box contains a value for the outermost diameter of the area 
illuminated by the spot light. The area outside the outer cone will 
not be illuminated by the light. The area between the outer and inner 
cones is a transition area between full illumination and none.

Inner Cone (for Spot mode only)

This edit box contains a value for the diameter of the area receiving 
the full illumination of the spot light. The light falls off between the 
inner and outer cones.

Factor (for Spot mode only)

This edit box contains a value for the rate at which the spot light falls 
off between the inner and outer cones. The default is 1.0, which 
provides an even transition. A higher number creates a sharper 
transition.

Position (X, Y and Z)

These edit boxes contain values for the X, Y, and Z coordinates of the 
light (its physical location in global space), at the current keyframe, 
frame or point in time (depending on the editing mode in effect).

Reference (X, Y and Z)

These edit boxes contain values for the X, Y and Z coordinates of the 
light’s reference point (the point at which the light is aimed). The 
reference point of the light is represented in the World View windows 
by the arrow emanating from the center of the light icon. As with the 
Position edit boxes, the Reference edit boxes show the position of 
the light’s reference point at the current keyframe, frame or point in 
time (depending on the editing mode in effect).
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Shadow Info
The lower left side of the Light Info window contains information 
and settings that pertain to the light’s shadow casting capability.

Enable Shadow

This check box option enables the light to cast shadows.

Outside Buffer Area in Shadow

This check box option, when enabled, causes the entire area of the 
image outside the outer cone angle (specified in the Outer Cone edit 
box) to be rendered in shadow (simulating the effect of a real 
spotlight).

Calculate Shadow Only Once

This check box option, when enabled, causes the shadow image to be 
calculated only once, as it appears in the initial frame of an 
animation. This feature saves rendering time when the shadow image 
does not change during an animation (such as when only the camera 
is moved).

Buffer Size

This edit box contains a value for the shadow buffer resolution. The 
larger the buffer size, the greater the rendering detail for the shadow, 
however greater memory is required to render the shadow. The 
default is set to 1280 pixels square, which creates good looking 
shadows but uses 6.5 mb of RAM.
The ElectricImage™ Reference 11-13



Chapter 11: The Light Info Window

Book  Page 14  Friday, July 21, 2000  4:18 PM
Gap

This edit box contains a value for the minimum distance between a 
surface casting a shadow and the point at which a shadow first 
appears.

Softness

This edit box contains a value affecting how the shadow’s edge 
appears. The larger the value, the softer or fuzzier the shadow’s edge 
will appear. A value of 1 creates fairly crisp shadows.

Samples

This edit box contains a value for the number of shadow samples per 
pixel. A larger value reduces the noise around the edge of a shadow 
but takes longer to render.

Transition

This edit box contains a value for the fade-in distance between a 
surface casting a shadow and the surface upon which the shadow 
appears.

Smoothing

This edit box contains a value for the softness of shadow edges when 
viewed up close. Longer values can reduce the stairstep of shadow 
edges, but can also cause shadows to appear further away from the 
surfaces which cast them.
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Special Effects (Glow and Fog)
The lower right corner of the Light Info window contains settings for 
the light’s glow and fog effects, which make the light visible and can 
be animated. The rules for changing values in this section are the 
same as those discussed in the section “Current Stats” (page 11-10).

Enable Glow/Fog

This check box option enables the glow and fog special effects.

Outside Color

This button opens the color editor to select the color at the edge of 
the glow/fog. If the outside color is different than the inside color 
(see below), a blend will occur between the two.

Inside Color

This button opens the color editor to select the color at the center of 
the glow/fog. If the inside color is different than the outside color 
(see above), a blend will occur between the two.

Inner Radius and Outer Radius

These edit boxes contain values for the size of the effect. Within the 
inner radius it is opaque; the outer radius is where it becomes clear. 
To see these radii in the World View windows, click on the Show 
Glow Radius and/or Show Fog Radius check boxes (page 11-8).

Factor

This edit box indicates the rate (default is 1) at which the glow/fog 
will drop off between opacity at the inner radius and transparency at 
the outer radius. The higher the value, the greater the rate of drop off.
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Lens Flare Effect
This section of the Light Info window contains settings to apply and 
control a lens flare effect from the light source.

Flare

This pop-up menu contains all available lens flare plug-ins contained 
in the EI Sockets folder (plus any additional lens flare plug-ins 
contained in the project but that are not found in the EI Sockets 
folder).

To enable a lens flare, choose the lens flare plug-in from the pop-up 
menu (which defaults to None).

Enable Obscuration

This check box option, when enabled, turns off the lens flare when 
the light source is obscured by an object during rendering.

w
The flare elements will turn off completely for those frame in which the 
light is obscured. There is no fade-in or fade-out of the effect.

Option…

This button opens the lens flare plug-in’s dialog box for controlling 
the various elements of the flare.

w
If you are not using the ElectricImage lens flare plug-in, please refer to 
your plug-in developer’s documentation.

The ElectricImage lens flare dialog box is shown in Figure 11.7 
(page 11-17).
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Lens Type This pop-up menu provides a choice of two types of lens: 50-100mm 
Zoom (the default) and 35mm Prime. Each produces a different type 
of lens flare with different sets of ring and streak elements.

Spherical/Anamorphic These radio buttons provide a choice between spherical and 
anamorphic lenses. A spherical lens produces circular rings and 
streaks. An anamorphic lens produces ovals and squashed streaks. 
The default is Spherical.

Rotation This edit box contains a value in degrees for the angle of rotation for 
the streaks. This control can be used to simulate the spinning of a 
lens and to produce special effects. The default is 0.0 for no rotation.

Aspect Ratio This edit box, used only in conjunction with anamorphic lenses, 
contains a value for the lens’s aspect ratio. The default is 2 (2:1) 
because that is the aspect ratio of most anamorphic lenses.

Ring Scale This edit box contains a value for the overall scale of the flare’s ring 
elements. It defaults to 1 for standard-sized rings. The higher the 
value, the larger the rings.

Figure 11.7   Dialog box used to set lens flare preferences
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Ring Intensity This edit box contains a value for the overall brightness of the flare’s 
ring elements. It defaults to 1 for standard intensity rings. The higher 
the value, the brighter the rings.

Ring Contrast This edit box contains a value for the contrast in the flare’s ring 
elements. It defaults to 1 for standard contrast rings. The higher the 
value, the higher the contrast.

Remove Ring Tint This check box, when enabled, changes all of the flare’s ring elements 
to gray scale. This option makes them easier to color with the Origin 
Glow, Outer Glow, Halo and Lens Reflections color buttons, 
described below. It defaults to off.

Origin Glow This check box, when enabled, creates the flare’s origin glow ring. It 
defaults to on. The adjacent color button opens the Apple Color 
Picker to adjust the color of this element. The color defaults to white 
(for no color adjustment).

Outer Glow This check box, when enabled, creates an outer glow ring around the 
flare’s origin glow ring. It defaults to on. The adjacent color button 
opens the Apple Color Picker to adjust the color of this element. The 
color defaults to white (for no color adjustment).

Halo This check box, when enabled, creates a halo around the flare’s origin 
glow ring. It defaults to on. The adjacent color button opens the 
Apple Color Picker to adjust the color of this element. The color 
defaults to white (for no color adjustment).

Lens Reflections This check box, when enabled, creates the flare’s other ring elements. 
It defaults to on. The adjacent color button opens the Apple Color 
Picker to adjust the color of these element. The color defaults to 
white (for no color adjustment).

Streak Scale This edit box contains a value for the scale of the flare’s streak 
elements. It defaults to 1 for standard-sized streaks. The higher the 
value, the longer the streaks.

Streak Intensity This edit box contains a value for the overall brightness of the flare’s 
streak elements. It defaults to 1 for standard intensity streaks. The 
higher the value, the brighter the streaks.
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Streak Contrast This edit box contains a value for the contrast in the flare’s streak 
elements. It defaults to 1 for standard contrast streaks. The higher the 
value, the higher the contrast.

Remove Streak Tint This check box, when enabled, changes all of the flare’s streak 
elements to gray scale. This option makes them easier to color with 
the Streaks color button, described below. It defaults to off.

Streaks This check box, when enabled, creates the flare’s streaks. It defaults to 
on. The adjacent color button opens the Apple Color Picker to adjust 
the color of the streaks. The color defaults to white (for no color 
adjustment).

Use Light Intensity This check box, when enabled, uses the light source’s intensity 
(page 11-11) to factor the intensity of the lens flare’s elements. Lights 
with higher intensities will have brighter lens flares. It defaults to on.
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Additional Settings
There are four additional check boxes in the upper left portion of the 
Light Info window:

Enable Highlight

This check box option enables the rendering of the specular 
highlight on objects illuminated by the light and for which the 
specular attribute has been set (in the Surface Editor).

Blend Glow

This check box option enables the blending of adjoining glow lights 
into a continuous glow light. Disabling this option will cause the 
overlapping areas of separate glow lights to increase in intensity, 
eventually going to white. Blend Glow defaults to On because it is 
more aesthetically pleasing.

Interpolate Fog RGB

This check box option, when enabled, specifies the use of RGB 
interpolation for the inside to outside color of the fog effect. 
Otherwise, HSV interpolation is used.

Interpolate Glow RGB

This check box option, when enabled, specifies the use of RGB 
interpolation for the inside to outside color of the glow effect. 
Otherwise, HSV interpolation is used.
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Overview
The Sound Info window, as shown in Figure 12.1, contains controls 
for playing the selected soundtrack, along with settings for the 
selected soundtrack’s start time in the project. It also contains 
settings for selections of the soundtrack and the creation and 
maintenance of cues (small sections of the soundtrack).

Opening the Sound Info Window

To open the Sound Info window, select the soundtrack in the Project 
window, then choose Sound Info from the File menu (or 
double-click on the soundtrack icon).

Figure 12.1   The Sound Info window

Current time of soundtrack

Playback controls

Rate of playback

Volume of playback

Sound file name Timing controls

Cue list Cue information
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Playback Controls
The left side of the Sound Info window contains controls for playing 
the soundtrack.

Play This button, when clicked, plays the soundtrack. While the 
soundtrack is playing, the button changes to read Stop.

Pause This button, when clicked, pauses the soundtrack during play. While 
the soundtrack is paused, the button changes to read Continue.

Loop This check box, when enabled, causes the soundtrack to loop 
continuously during playback. It can be clicked on and off during 
playback.

Volume This edit box and slider bar sets the volume of playback relative to 
the volume setting of the Sound control panel. It defaults to full 
volume (100). If you do not hear the sound during playback, check 
the setting of the control panel.

Rate This edit box and slider bar sets the playback rate of the soundtrack. 
It defaults to full speed (100) and can be slowed down.
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Timing Controls
The right side of the Sound Info window contains timing controls.

Duration Time This number represents the overall duration of the sound file.

Starting Time This edit box contains a value for the time in the project at which the 
sound starts.

Selection Start Time This edit box contains a value for the time in the project at which the 
selected portion of the soundtrack starts.

w
A portion of the soundtrack can be selected in the Project window by 
clicking and dragging inside the waveform of the sound. For an 
illustration of how a selection appears in the Project window, refer to 
Figure 12.2 (page 12-5).

Selection Stop Time This edit box contains a value for the time in the project at which the 
selected portion of the soundtrack stops.
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Sound Cues
The lower right portion of the Sound Info window contains controls 
for creating and managing sound cues, which are segments of the 
soundtrack that can be recalled and located at any time.

Cue List This box contains a list of cues created by selecting a portion of the 
soundtrack and clicking the Add button, below.

Add This button is used to add a selected portion of the soundtrack to the 
cue list.

Delete This button is used to delete a selected cue from the cue list.

Time This edit box contains a value for the time at which the selected cue 
starts.

Duration This edit box contains a value in seconds for the duration of the 
selected cue.

Notes This edit box can be used to annotate the selected cue.

Figure 12.2 shows examples of how a soundtrack, a selection of the 
soundtrack, and the selection added as a cue, appear in the Project 
window.

Figure 12.2   Examples of soundtrack in Project window

Complete soundtrack

Soundtrack selection

Soundtrack cue
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Overview
The Group Info window, as shown in Figure 13.1, contains two types 
of information for the selected group: permanent rendering settings 
for the group’s shading, and current values for the group’s location in 
global space, the location of its center point, its orientation in local 
space, and its scale.

There is also a button for opening the Surface Editor to set the group’s 
color, ambient, diffuse, specular, luminance, reflectivity, transparency 
and edge density values, as discussed in Chapter 18: The Surface Editor.

Opening the Group Info Window

To open the Group Info window for a specific group, select the group, 
then choose Group Info from the File menu (or double-click on the 
group).

Figure 13.1   The Group Info window

Rendering options (page 13-7)

Line size (page 13-5) Shadow Density (page 13-8) Blur Intensity (page 13-6)     Current Stats (page 13-9)

Blur Mode Shading Level      Transparency Level          Surface Editor
(page 13-6) (page 13-3) (page 13-5)             (page 13-10)
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Rendering Info
The left side of the window contains information and settings in 
pop-up menus, check boxes and edit boxes that control how the 
group will be rendered.

Statistics

This information includes the number of polygons, lines and points 
for the group, as well as the X, Y and Z values of the boundaries of 
the group’s cubic extent.

Shading

This pop-up menu is used to set the shading type for the group. The 
menu choices are:

Wireframe This level of shading renders the group in wireframe (only the edges 
of polygons are rendered). The thickness of the wireframe is set in the 
Line Size in Pixels edit box, discussed below.

Flat This level of shading calculates a single color intensity across the 
surface of the entire polygon. When shading calculations are made, 
the orientation of the polygon relative to the lights illuminating it 
are factored into the defined color of the polygon. Flat shading uses 
only one normal per polygon to calculate shade. The resulting image 
has a very “faceted” appearance.

w
Flat shading is very fast, and is often used for basic lighting and 
positioning tests, as well as animated move tests. It can also be used for 
special effects, where a faceted look is desired.
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Gouraud This level of shading calculates the shade of a polygon by linearly 
interpolating color intensity at the vertices of shared polygons, and 
then averaging the shade across the surface of the polygon. Instead of 
using the polygon normal, gouraud shading uses the normals at each 
vertex of the polygon. The resulting image is smooth shaded, but can 
have artifacting at the polygon boundaries, which is very noticeable 
if there is a highlight on the object.

Phong This level of shading (the default) takes the vertices of the polygons, 
and their associated normals, and interpolates the new normals 
across the surface of the polygon, and then uses the new normals to 
generate a shade for each pixel contained within the polygon. The 
resulting image takes longer to calculate than the other shading 
methods, but yields the highest quality results. Also, special features 
such as bump mapping and shadow casting are available only when 
phong shading is used.

w
Group shading settings can be overridden in the Render Control 
window, where the maximum shading level is set for all groups in the 
project, as discussed in the section “Global Shading Level” (page 9-4) in 
Chapter 9: The Render Control Window.
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Transparency

This pop-up menu is used to select the type of transparency that will 
be used for the group (depending on the group’s transparency 
attributes as set in the Surface Editor, discussed in Chapter 18: The 
Surface Editor). The menu choices are:

Dither This level of transparency provides 16 levels of transparency and no 
transparency mapping, but with very fast rendering times.

Filter Transparency This level of transparency (the default) provides 255 levels of 
transparency and transparency mapping, but with long rendering 
times.

w
Group transparency settings can be overridden in the Render Control 
window, where the maximum transparency level is set for all groups in 
the project, as discussed in the section “Global Transparency Level” 
(page 9-5) in Chapter 9: The Render Control Window.
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Blur Mode

This pop-up menu provides a choice of motion blur techniques for 
the selected group. The menu choices are:

None This option (the default) renders the group without motion blur.

Point/Line This option enables the point/line motion blur technique for the 
group. In this mode, only the group’s points and lines leave streaks 
behind them. Choosing this option adds another edit box for Blur 
Intensity to the Group Info window (see below).

w
The point-line technique is most suitable for motion blur of star streaks 
and particle systems.

Motion Vector This option enables the motion vector technique for the group. In 
this mode, all of the group’s elements (points, lines and polygons) are 
blurred. Blurs are always linear—they are never curved when viewed 
as a single frame. This is a fast, versatile and very high quality blur 
technique.

w
The motion vector technique is most suitable for rendering single 
elements which can later be composited together to produce the final 
animation. An example of when not to use this technique is for 
spinning fan blades partially obscured by their stationary housing. 
This would produce undesirable results.

Blur Intensity

This edit box, used only in conjunction with the Point/Line motion 
blur technique, contains a value that controls the brightness of 
streaks left by the group’s points and lines. A value of 0.0 (the default) 
imparts a constant value regardless of the length of the streaks. Large 
values produce brighter streaks. Smaller values produce dimmer 
streaks. In general, the longer the streak the dimmer the streak.
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Other Rendering Options

Smooth Across Faces This check box option enables smooth shading for the group. If not 
checked, the group will have a faceted appearance when rendered.

Super Sample This check box option enables super sampling for the group (the 
group is shaded four times per pixel). This will make highlights on 
sharp edges and small bumps appear less jagged and will make 
textures appear sharper. Super sampled groups can take up to four 
times as long to render, so this option should be used sparingly.

Color Blend This check box option enables smooth blending of polygon colors 
across polygon edges (soft color transitions between polygons). This 
option is group bound; colors will not blend across groups.

Override Old Color This check box option is automatically enabled when a new color is 
set for the group in the Surface Editor (refer to Chapter 18: The Surface 
Editor). To restore the group’s original color, unclick the check box.

Show Bounding Box This check box option enables the display of the group’s cubic extent 
bounding box in the World View windows, explained in the section 
“Drawing…” (page 2-11) in Chapter 2: The Edit Menu Commands.

Cast Shadow This check box option enables the group to cast shadows onto other 
groups which can receive a shadow—if the other groups have 
Receive Shadow checked and the illuminating light has Enable 
Shadow checked in its Light Info window, as discussed in the section 
“Enable Shadow” (page 11-13) in Chapter 11: The Light Info Window.

Receive Shadow This check box option enables the group to receive shadows from 
other groups—if the other groups have Cast Shadow checked and 
the illuminating light has Enable Shadow checked in its Light Info 
window (page 11-13).
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High Precision Shadow This check box option is used for precisely built models to make 
shadows appear closer to the objects that cast them.

w
This option may cause shadow artifacts on certain models. If you 
notice this happening, then disable this option. The shadows processed 
for this group will be less precise, but should show no shadow artifacts.

Line Size in Pixels

This edit box contains a value for the size of the wireframe lines, in 
pixels, when Wireframe is selected from the Shading pop-up menu 
as the shading type for the group (page 13-3).

Shadow Density

This edit box contains a value for the density of the shadows cast by 
the group. Values between zero and 15 create shadows of varying 
density (zero casts no shadows while density 15 casts solid shadows). 
A low value can simulate shadows cast from a transparent group.
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Current Stats
The right side of the Group Info window contains information in 
edit boxes about the group’s current position in global space, the 
current position of its center point, its current orientation in local 
space, and its current scale. There is also a button for opening the 
Surface Editor to assign surface attributes to the group.

Changing the values in this section of the window produces different 
results, depending on which editing mode is in effect when the group 
is selected:

• In Index mode, changing the values updates the values for the 
current keyframe.

• In Frame mode, changing the values creates a custom frame that 
includes the new values. A custom frame is not affected by the 
interpolation of frames between keyframes, and can thus be used, 
for example, to create a glitch in the animation of the camera’s 
position.

• In Keyframe mode, changing the values either updates the 
values for the current keyframe (if the selected frame coincides 
with an existing keyframe) or creates a new keyframe that 
includes the new values (if the selected frame does not coincide 
with an existing keyframe).

• In Time mode, changing the either updates the values for the 
current keyframe (if the selected point in time coincides with an 
existing keyframe) or creates a new keyframe at the selected point 
in time that includes the new values (if the selected point in time 
does not coincide with an existing keyframe).

w
The editing mode is set in the Project window. For an explanation of 
editing modes and the Project window, refer to Chapter 8: The Project 
Window.
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Surface

This button opens the Surface Editor, which is used to set the group’s 
color, ambient, diffuse, specular, luminance, reflectivity, transparency 
and edge density values. For a complete description of the Surface 
Editor, refer to Chapter 18: The Surface Editor.

Position

These edit boxes contain values for the X, Y, and Z coordinates of the 
object (its physical location in global space), at the current keyframe, 
frame or point in time (depending on the editing mode in effect).

Center

These edit boxes contain values for the X, Y and Z coordinates of the 
object’s center point, at the current keyframe, frame or point in time 
(depending on the editing mode in effect).

Rotation

These edit boxes contain values, in degrees, for the amount of the 
object’s orientation in local space, by way of its X, Y and Z rotation, 
respectively, at the current keyframe, frame or point in time 
(depending on the editing mode in effect).

Scale

These edit boxes contain values that indicate, in relative terms, the X, 
Y and Z scale of the object, at the current keyframe, frame or point in 
time (depending on the editing mode in effect).
13-10 ElectricImage™ Animation System



Book  Page -1  Friday, July 21, 2000  4:18 PM
Chapter 14 The Group Texture Window
The ElectricImage™ Reference



Book  Page 0  Friday, July 21, 2000  4:18 PM
ElectricImage™ Animation System



Book  Page 1  Friday, July 21, 2000  4:18 PM
Chapter 14 The Group Texture Window

Overview ....................................................................................... 14-3

Opening the Group Texture Window  14-4

Adding/Removing Images ......................................................... 14-5

Adding a Texture (Texture 1 or Texture 2)  14-6

Adding a Reflection  14-7

Copying and Pasting Textures  14-9

Removing/Replacing Textures and Reflections  14-9

Mapping Controls...................................................................... 14-10

Map Type  14-10

RGB  14-14

Alpha  14-16

Align  14-19

Softness  14-20

Map Filter  14-20

Enabling Mapping Functions  14-21
The ElectricImage™ Reference 14-1



Chapter 14: The Group Texture Window

Book  Page 2  Friday, July 21, 2000  4:18 PM
Positioning/Fine Tuning Controls ...........................................14-22

Group Display Window  14-22

Edit Boxes  14-26

Map Filter Controls  14-27

Bump Mapping Control  14-27

Texture Surface Attributes .......................................................14-28
14-2 ElectricImage™ Animation System



Overview

Book  Page 3  Friday, July 21, 2000  4:18 PM
Overview
The Group Texture window, shown in Figure 14.1, is used to set 
texture and reflection mapping for a group.

Figure 14.1   Group Texture Window

Filtering (page 14-28) Mapping Controls (page 14-10)

Adding/removing images
(page 14-5)

Group display window
(page 14-22)

Positioning/Fine tuning controls
(page 14-22)
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Opening the Group Texture Window

The Group Texture window can be opened in any of the following 
ways:

• Select the group and choose Group’s Texture from the Tools 
menu, as discussed in the section “Group’s Texture” (page 5-13) 
in Chapter 5: The Tools Menu Commands.

• Select the group and choose the Group’s Texture tool from the 
Tool Palette, as discussed in the section“The Group’s Texture 
Tool” (page 19-14) in Chapter 19: The Tool Palette.

• Select the group in the Project window and click the Group’s 
Texture tool in the Project window’s tool palette, as discussed in 
the section “Group’s Texture” (page 8-26) in Chapter 8: The Project 
Window.

• Command-double-click on the group’s icon in either the World 
View or Project windows.
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Adding/Removing Images
Textures and reflections are created by assigning image files to the 
group. Two textures and one reflection are allowed per group, and 
these images must be in the Image file format (for information on 
converting files to Image format, refer to The Projector Reference).

The order of assignment is also important to consider, as textures are 
calculated in a back to front order (Texture 2 is applied on top of 
Texture 1, which is applied on top of the group’s shading attributes).

The Texture Name boxes (Texture 1, Texture 2 and Reflection) are 
used to select the textures and reflection assigned to the group.

The Filter buttons to the right of each texture are used to open the 
Texture Editor for setting filtering attributes in much the same way 
the Surface Editor is used for setting shading attributes. The display 
sphere in the button indicates the current settings.

As shown in Figure 14.2, if a texture is assigned to the group, its 
name is shown in the Texture Name box, its RGB and alpha channels 
(if available) are shown in the RGB and Alpha windows, and the 
check box to the left of the Texture Name box is enabled (unless you 
disable it). Otherwise, the boxes and picture fields are empty.

The procedures for adding and removing Image files for use as 
textures and reflections are presented on the following pages:

• Adding a texture (page 14-6)

• Adding a reflection (page 14-7)

Figure 14.2   Textures added to the group
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Adding a Texture (Texture 1 or Texture 2)

To add a texture to the group:

1. Double-click on the empty Texture Name box.

A directory dialog box, as shown in Figure 14.3, opens.

2. Open the folder where the Image file is located (if necessary).

3. Click on the Image file to select it.

When selected, the file’s RGB channels are displayed in the window to 
the left of the file list.

The Show pop-up menu above the display window can be used 
to also show the file’s alpha channel (if it has one) and the file’s 
image depth and dimensions in pixels.

4. Use the Modify in pop-up menu to select which group(s) are to 
be assigned the texture (defaults to Current Group Only).

5. Either click Add or press Return.

The dialog box closes. The check box next to the Texture Name is 
enabled, the Texture Name box contains the name of the texture file, 
and the RGB and Alpha windows show the texture file’s RGB and 
alpha channels (if available).

Texture Statistics The right side of the window contains statistics for the currently 
selected texture: size of the texture in pixels (X by Y), the amount of 
frames in the texture, RGB color depth, and alpha depth.

Figure 14.3   Directory dialog box used to add/replace/remove textures
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Adding a Reflection

One of three types of reflections can be assigned to a group:

• Image file reflection

When an Image file is applied to the group as a reflection, the 
Image file serves as the image reflected by the group.

• Environment reflection (environment mapping)

When an environment reflection is applied to a group, 
ElectricImage maps a 360 degree view of the scene from the 
group’s perspective and wraps that view around the group. The 
object will thus automatically reflect all of the other objects in 
the scene. The amount of reflection is determined by the group’s 
reflectivity setting (as set in the Surface Editor). The image 
quality of the reflection is controlled by the Buffer Size edit box 
(discussed on page 6-192).

• Mirror reflection

When a mirror reflection is applied to a group, a flat reflection of 
the group’s environment is mapped to the group (as opposed to 
the cubic reflection of the environment reflection).

To add a reflection to the group:

1. Double-click on the empty Reflection Name box.

A directory dialog box, as shown in Figure 14.4, opens.

Figure 14.4   Directory dialog box used to add/replace/remove reflections
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2. To add an environment reflection, click the Environment 
button.

You are returned to the Group Texture window. The check box next to 
the Reflection Name box is enabled and the Reflection Name box 
contains the words “Automatic Environment.” The RGB and Alpha 
windows remain blank.

3. To add a mirror reflection, click the Mirror button.

You are returned to the Group Texture window. The check box next to 
the Reflection Name box is enabled and the Reflection Name box 
contains the words “Automatic Mirror.” The RGB and Alpha windows 
remain blank.

4. To add an Image file reflection, open the folder where the Image 
file is located (if necessary).

5. Click on the Image file to select it.

When selected, the file’s RGB channels are displayed in the window to 
the left of the file list.

The Show pop-up menu above the display window can be used 
to also show the file’s alpha channel (if it has one) and the file’s 
image depth and dimensions in pixels.

6. Use the Modify in pop-up menu to select which group(s) are to 
be assigned the texture (defaults to Current Group Only).

7. When done, either click Add or press Return.

You are returned to the Group Texture window. The check box next to 
the Reflection Name box is enabled, the Reflection Name box contains 
the name of the reflection file, and the RGB and Alpha windows show 
the reflection file’s RGB and alpha channels (if available).
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Copying and Pasting Textures

Textures can be copied from one group and pasted to another group.

To copy the current texture:

1. Choose Copy Texture Map from the Edit menu.

2. Click on the icon of the group to which the texture is to be 
copied (in either the world view or Project windows),

3. Choose Paste Texture from the Edit menu.

Removing/Replacing Textures and Reflections

Textures and reflections can be removed and new textures and 
reflections can be applied to replace them.

To remove a texture or reflection:

1. Double-click on the text box with the name of the texture.

A directory dialog box, as shown in Figure 14.3 for textures, and 
Figure 14.4 for a reflection, opens.

2. Click the Remove button.

The dialog box closes and the Group Texture window’s texture boxes 
are blank.

w
If you want to replace one texture or reflection with another, you do not 
need to remove the old texture or reflection. Selecting a new texture or 
reflection automatically replaces a previously assigned texture or 
reflection.
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Mapping Controls
The pop-up menus in the upper right portion of the Group Texture 
window control the manner in which the assigned images are 
mapped to the group.

Map Type

This pop-up menu is used to select the projection style to be applied 
when the texture is mapped to the group. The menu choices are:

Flat This option (the default) is best used for flat or flattish objects. If 
applied to a non-flat-object, the texture will streak along the sides of 
the object as it is projected onto all surfaces of the group along the 
texture’s positive Z axis, as shown in Figure 14.5.

The rectangle in the display represents the map and consists of an 
“x” shape through the center, and two arrows, one pointing to the 
top of the map, and the other pointing out from the center of the 
map to indicate the texture’s positive Z axis.

The flat projection scale defaults to the group’s extents. The scales of 
the projection are visible in the X Scale, Y Scale, and Z Scale edit 
boxes and can be changed by typing new values into the edit boxes.

Using a negative value for the Z scale will cause the projection to be 
reversed opposite the direction indicated by the gray arrow. Enabling 
the Negative Z check box will cause the texture to be projected into 
both the positive and negative Z directions.

Figure 14.5   Flat projection display
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Cylindrical This option projects a cylindrical image around the group, as shown 
in Figure 14.6.

A cylinder is oriented around the center of the object, with an arrow 
pointing towards the top of the cylinder, and a line indicating where 
the seam will be. This is the best mapping type to use if the object is 
roughly cylindrical.

Cylindrical map types have two projection alignment controls, Wrap 
Angle and Height. The wrap angle controls the longitude projection, 
and the height factor controls the latitude projection of the cylinder. 
The wrap angle axis allows angles from 0˚ to 360˚. The default is 180˚.

The height factor allows a real number factor, with 1 being the 
default size.

Figure 14.6   Cylindrical projection display
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Spherical This option projects a spherical image around the group, as shown in 
Figure 14.7.

There will be a sphere centered around the group, with a line running 
along the sphere. This line is where the seam of the map will occur, 
and also points to the top of the map. This is the best mapping type if 
the object is roughly spherical.

The spherical texture type has two separate projection alignment 
controls, Wrap Angle and Band Angle. The wrap angle controls the 
longitude projection, and the band angle controls the latitude 
projection. The Wrap Angle axis is a circular axis allowing angles of 0˚ 
to 360˚.

The Band Angle axis is half circular, allowing for angles of 0˚ to 180˚.

Figure 14.7   Spherical projection display
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Cubic This option projects a cube around the group, repeating the image for 
each side of the cube, as shown in Figure 14.8.

The front face of the cube will have an “x” through the center, much 
like the flat type. There will also be a line indicating the top of the 
map, as well as indicating the front direction of the map.

When this map is used with a cube-shaped group, all sides should 
project onto the group with minimal distortion. If this mapping type 
is applied to a curved group, the edges of the cubic map will be seen, 
appearing like a seam. Seaming also occurs when the projection is 
not properly aligned to a cube-shaped object.

The front face is the active face, which determines the overall 
mapping characteristics of the selected group. Use the active face to 
correctly scale the texture to the group, as well as to correctly orient 
the projection to the group’s coordinate space.

Figure 14.8   Cubic projection display
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RGB

This pop-up menu determines how the RGB channel of the texture is 
treated when applied to the group. The menu choices are:

Disabled This option disables use of the RGB channel for any processing on 
this particular texture. The color channel of this texture will therefore 
not be visible.

Surface This option (the default) replaces the selected group’s surface color 
values with the RGB channel of the texture.

Diffuse This option replaces the selected group’s diffuse values with the RGB 
channel of the texture. If the Alpha mode for the texture is set to 
Decal, then only the opaque area of the texture would be affected by 
this setting—see “Alpha” (page 14-16).

Ambient This option replaces the selected group’s ambient values with the 
RGB channel of the texture. If the Alpha mode for the texture is set to 
Decal, then only the opaque area of the texture would be affected by 
this setting—see “Alpha” (page 14-16).

Specular This option replaces the selected group’s specular values with the 
RGB channel of the texture. If the Alpha Mode for the texture is set to 
Decal, then only the opaque area of the texture would be affected by 
this setting—see “Alpha” (page 14-16).

Reflectivity This option replaces the selected group’s reflectivity values with the 
RGB channel of the texture. If the Alpha Mode for the texture is set to 
Decal, then only the opaque area of the texture would be affected by 
this setting—see “Alpha” (page 14-16).

Transparency This option replaces the selected group’s transparency values with 
the RGB channel of the texture. If the Alpha Mode for the texture is 
set to Decal, then only the opaque area of the texture would be 
affected by this setting—see “Alpha” (page 14-16).
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Luminance This option replaces the selected group’s luminance values with the 
RGB channel of the texture. If the Alpha Mode for the texture is set to 
Decal, then only the opaque area of the texture would be affected by 
this setting—see “Alpha” (page 14-16).

Edge Density This option replaces the selected group’s edge density values with the 
RGB channel of the texture. If the Alpha Mode for the texture is set to 
Decal, then only the opaque area of the texture would be affected by 
this setting—see “Alpha” (page 14-16).
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Alpha

This pop-up menu determines how the alpha channel of the texture 
map is treated when applied to the group. The menu choices are:

Disabled This option disables use of the alpha channel for any processing on 
this particular texture.

Decal This option (the default) activates the RGB channel filters.

w
Decal is similar to a decal sheet often found in plastic model kits. For 
example, by positioning an image of the Stars & Bars with an alpha 
channel on the surface of an aircraft wing, the Stars & Bars would 
appear to be placed upon the surface of the wing when rendered, fully 
anti-aliased. This functions as if a real decal had actually been used on 
a real model airplane.

Replace This option forces the object to take on all characteristics of the 
texture map, including the alpha channel information.

w
For example, by mapping an image with an alpha channel with a circle 
shape in it onto a square, the resulting image when rendered would 
appear to be a square with whatever the background color was showing 
through the circle, as if it were a hole. Indeed, it is a hole, but not the 
kind of hole that might be expected. This hole exists in the alpha 
channel of the rendered image, so if a background was digitally 
composited into the image, that background would be seen coming 
through the hole. This is due to the special matting techniques for 
which alpha can be used. It is not likely that the “Replace” mode would 
be used too often, but it is nice to know that it is there.

Bump This option enables bump mapping, or “surface normal 
perturbation.” Bump mapping uses the alpha channel to determine 
the amplitude (height) of the surface normal, with the white areas of 
the alpha channel being the highest points and the black areas being 
the lowest. If the texture has no alpha channel, a gray scale of the 
RGB channel is used.
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Surface This option multiplies the alpha channel of the texture with the RGB 
color of the group’s color. Wherever the alpha value of the texture is 
on (255, or white), the surface shade will be the group’s color. 
Wherever the alpha value of the texture is off (0, or black), the 
surface shade will be black.

Diffuse This option multiplies the alpha channel of the texture with the 
diffuse value of the group to compute the diffuse value of the surface. 
This can be used to create a weathered effect on the surface. Lower 
alpha values will darken the surface.

Ambient This option multiplies the alpha channel of the texture with the 
ambient value of the group to compute the ambient value of the 
surface.

Specular This option multiplies the alpha channel of the texture with the 
specular value of the group in order to compute the specular value of 
the surface. Wherever the highlight occurs on the surface, the pattern 
formed by the alpha channel would be seen. This is very effective for 
simulating the way light would reflect off of surfaces with different 
reflective values.

Reflectivity This option multiplies the alpha channel of the texture with 
reflectivity value of the group to result in the reflectivity value of the 
surface. This setting would reflect where the reflectivity occurs on a 
surface. For instance, if there is a grid pattern in the alpha channel of 
a texture, and the group is 100% reflective, this setting would result 
in a surface which would appear to reflect only where the grid 
pattern would be.

Transparency This option multiplies the opaque transparency value of the group by 
the alpha channel of the texture map. This effect can be used to cut 
holes in a surface or to simulate cloud-like effects when the alpha is 
between zero and 255.
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Luminance This option multiplies the alpha channel of the texture with the 
luminance color of the group resulting in the luminance value of the 
surface. Wherever the alpha value of the texture is white (255) the 
surface would be the real value of the texture before shading. 
Wherever the alpha value of the texture is black (0), the surface 
would be the color of the texture after it had been shaded.

Edge Density This option multiplies the opaque edge density value of the group by 
the alpha channel of the texture map. This can be used to add rough 
fringe effects around the edges of a group.
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Align

This pop-up menu aids in the alignment of textures to the group.

w
The menu choice displayed on this pop-up menu at any given time will 
not necessarily indicate the current setting of the texture as it is being 
applied to the group. This is because the menu is a tool only and not an 
attribute indicator. The map projection in the View window is the best 
way to verify the alignment.

The menu choices are:

Midpoint This option (the default) aligns the texture to the center of the group. 
The aspect ratio of the texture map is maintained. Map Type 
projection should be used before using this option. 

Front This option aligns the texture to the front of the group’s cubic extent. 
Map Type projection should be set before using this option.

Back This option aligns the texture to the rear of the group’s cubic extent. 
Map Type projection should be set before using this option.

Top This option aligns the texture to the top of the group’s cubic extent. 
Map Type projection should be set before using this option.

Bottom This option aligns the texture to the bottom of the groups cubic 
extent. Map Type projection should be set before using this option.

Left This option aligns the texture to the left of the group’s cubic extent. 
Map Type projection should be set before using this option.

Right This option aligns the texture to the right of the group’s cubic extent. 
Map Type projection should be set before using this option.

w
The texture is projected on the object by way of the Map Type pop-up 
menu. The Map Type pop-up menu should be correctly set before the 
Texture Align pop-up menu is used.
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Softness

This pop-up menu is used to soften or sharpen the texture map as it is 
applied to the object. The menu choices are:

None This option does not apply smoothing to the texture map. The map 
appears to be pixilated when it is scaled up large in a rendered image.

Sharp This option (the default) uses linear smoothing to remove pixilation 
from texture maps. It yields sharper texture maps and renders faster 
than the Soft mode. Aliasing within the texture map may be more 
visible in a rendered image, however, when this mode is selected.

Soft This option (not used with summation mapping—see below) uses 
cubic smoothing to remove almost all appearance of pixels within a 
texture map. It takes slightly longer to render than the Sharp mode 
and sharp edges within rendered textures appear softer. If aliasing is 
objectionable when using the other softness settings, this option is 
the solution.

Map Filter

This pop-up menu provides of choice of filtering (anti-aliasing) 
methods for the texture map, which are used to negate the moire and 
popping effects which occur when attempting to map a finite grid of 
pixels onto the surface of an infinitely resolvable model. The menu 
choices are:

None This option specifies that no anti-aliasing filter is used on the texture.

MIP This option specifies that MIP filtering is used. 

w
MIP filtering can sometimes result in “blurry” images. The alternative 
is summation filtering (see below), which creates texture maps that 
appear sharper. Summation filtering requires more memory, however, 
than MIP mapping.

Summation This option (the default) specifies that summation filtering is used.
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Enabling Mapping Functions

Located below the pop-up menus are a series of enable check boxes 
which allow for special processing of the selected texture.

Repeat X This check box option repeats the texture along the texture’s X axis. 
Repeating the texture will place the texture side by side with itself, 
and will not hide seams if they are present.

Repeat Y This check box option repeats the texture along the texture’s Y axis.

Mirror X This check box option mirrors the texture along the texture’s X axis. 
Mirroring will flip the texture back and forth, so that all the seams 
will match.

Mirror Y This check box option mirrors the texture along the Y axis.

Negative Z This check box option projects the texture along the texture’s 
positive and negative Z axis. Disabling this function projects the 
texture only along the positive Z axis.

Enable Filter This check box option enables the material filter for a texture. The 
texture’s material filter is set by clicking the Filter button, as discussed 
in the section “Texture Surface Attributes” (page 14-28).
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Positioning/Fine Tuning Controls
A number of controls are available to assist you in fine-tuning the 
position of the texture map.

Group Display Window

A group display window, as shown in Figure 14.9, is located in the 
center of the Group Texture window, and is used to assist in the 
alignment of the texture to the group.

The view can be changed in two basic ways:

• The area displayed can be changed by zooming in, zooming out 
and scrolling or dragging the window’s contents, as discussed in 
the section “Changing the Area Displayed” (page 14-23).

• The coordinate plane can be changed, effectively changing the 
view to top, side or front, as discussed in the section “Changing 
the View” (page 14-24).

Figure 14.9   Window controls

View pop-up menu

Zoom buttons
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Changing the Area
Displayed

There are several ways of changing the area displayed inside the 
group display window. To zoom in and out:

• Use the zoom buttons in the lower right corner of the window. 
To zoom in, click on the right zoom button. To zoom out, click 
on the left zoom button. To zoom in or out to a view that 
includes all objects in the project, hold down the option key 
while clicking either one of the zoom buttons.

• Use the Zoom Window tool from either the Tool Palette or the 
Tools Menu. To zoom in, click on the area you wish to zoom in 
on with the Zoom Window tool. To zoom out, hold down the 
option key while clicking with the Zoom Window tool. For an 
explanation of the Zoom Window tool, refer to the section “The 
Zoom Window Tool” (page 19-9) in Chapter 19: The Tool Palette, 
or the section “Zoom Window” (page 5-8) in Chapter 5: The Tools 
Menu Commands.

• Hold down the option key and drag a rectangle around the area 
you wish to zoom in on.

To scroll the window’s contents:

• Use the vertical and horizontal scroll bars.

• Use the Drag Content tool from either the Tool Palette or the 
Tools menu to scroll the window’s contents. For an explanation 
of the Drag Content tool, refer to the section “Zooming in or out 
is done by a factor of 2 with each click of the mouse.” (page 19-9) 
in Chapter 19: The Tool Palette, or the section “Drag Content” 
(page 5-9) in Chapter 5: The Tools Menu Commands.
The ElectricImage™ Reference 14-23



Chapter 14: The Group Texture Window

Book  Page 24  Friday, July 21, 2000  4:18 PM
Changing the View The information displayed in the window can be changed through 
the use of the View pop-up menu located to the left of the horizontal 
scroll bar at the bottom of the window. This pop-up menu gives you a 
choice of views, and its button indicates the current selection.

The menu choices are:

Camera

This option shows the object as the camera sees it.

Skew

This option (the default) shows the object at a skewed angle to 
represent a three-dimensional view. The detail to which the object is 
drawn can be set in the Drawing Preferences box, selectable from the 
Edit menu.

Top

This option shows the object in the Y/Z coordinate space.

Side

This option shows the object in the X/Z coordinate space.

Front

This option shows the object in the X/Y coordinate space.

RGB

This option shows the RGB channel of the object’s texture map (if a 
texture map has been applied to the object). This can also be 
displayed by clicking the RGB picture in the texture assignment area. 
In this view, the texture image can be cropped, as discussed in the 
section “Cropping the Image” (page 14-25).

Alpha

This option shows the alpha channel of the object’s texture map (if a 
texture map has been applied to the object that contains alpha 
channel information). This can also be displayed by clicking the 
alpha picture in the texture assignment area. In this view, the texture 
image can be cropped, as discussed in the section “Cropping the 
Image” (page 14-25).
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Cropping the Image

The texture image can be cropped so that only a portion of the image 
is used. Selecting RGB or Alpha from the View pop-up menu 
(page 14-24) displays the image in the Group Display window with a 
crawling selection rectangle, as shown in Figure 14.10.

To crop the image, drag any of the sides or corners of the selection 
rectangle.

Figure 14.10   Example of cropping a texture map image

Area of image file to be
used as texture map

Area of image file not to
be used in texture map

(cropped out)

Selection rectangle Drag selection rectangle to crop image
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Edit Boxes

Below the group display window are edit boxes that affect the 
placement and orientation of the selected texture relative to the 
group.

X, Y and Z
Position and Rotation

These edit boxes contain the texture’s X, Y and Z position and 
rotation. As the various settings in the Align pop-up menu are 
selected, these boxes are updated with new coordinates 
automatically. The values can be changed by typing in the edit boxes.

Optional Edit Boxes To the right of the Position and Rotation edit boxes are a set of 
case-sensitive, optional edit boxes. As the various settings in the 
Align pop-up menu are selected, these boxes are updated with new 
values automatically. The values can be changed by typing in the edit 
boxes.

Depending on the map type of the selected texture or reflection (as 
set in the Map Type pop-up menu), the column heading for the edit 
boxes is set to the name of the map type, and the edit boxes pertain 
to the specific map type:

• If the map type of the selected texture is Flat (page 14-10), the 
optional edit boxes contain the texture’s X, Y and Z scale values.

• If the map type of the selected texture is Cylindrical (page 14-11), 
the optional edit boxes contain the texture’s radius, wrap angle 
and height values.

• If the map type of the selected texture is Spherical (page 14-12), 
the optional edit boxes contain the texture’s radius, wrap angle 
and band angle values.

• If the map type of the selected texture is Cubic (page 14-13), the 
optional edit boxes contain the texture’s X, Y and Z scale values.

• If a reflection is selected and the reflection is Automatic 
Environment, the optional edit box contains the buffer size value 
for the map.
14-26 ElectricImage™ Animation System



Positioning/Fine Tuning Controls

Book  Page 27  Friday, July 21, 2000  4:18 PM
Map Filter Controls

In the lower right corner of the Group Texture window are edit boxes 
used for map filtering.

MIP Density This edit box contains a value that controls the blurriness of the 
texture maps. The default setting is 1, providing the most sharpness 
without aliasing. Values lower than 1 will induce aliasing and are 
therefore not recommended. The higher the number, the more 
blurred the image.

MIP Maximum This edit box contains a value that sets the maximum blurriness for 
the selected map. This is used to reduce excessive blurring at the 
poles of spheres and cones. A value of 0 (the default) disables the 
feature. Values less than 20 are not recommended because they will 
induce aliasing.

w
MIP Density and MIP Maximum affect summation filtering as well as 
MIP filtering.

Bump Mapping Control

In the lower right corner of the Group Texture window is an edit box 
used for bump mapping.

Bump Factor This edit box contains a value that is used when the Alpha pop-up 
menu is set to Bump (page 14-16). It determines the amplitude, or 
height, of the bump map. The default factor is set to 1. To make a 
bump map seem higher, increase the number of the bump factor. To 
invert a bump map, type a negative number into this edit box.
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Texture Surface Attributes
Once a texture is assigned to a group, it can have its own surface 
attributes assigned (color, diffuse, ambient, specular, reflectivity, 
luminance, transparency and edge density) in much the same 
manner as a group’s surface attributes are set in the Surface Editor.

w
For example, if you have a non-reflective group to which you want to 
map a reflective decal (such as lettering), set the Alpha mode to Decal. 
Then use this feature to assign reflectivity to the texture. That attribute 
will override the group’s reflectivity setting where the texture’s alpha 
channel is white.

Attributes set for Texture 2 will override attributes set for both Texture 
1 and the group where the textures overlap.

To assign a texture’s surface attributes:

1. Click the Enable Filter check box (page 14-21) to enable the 
Filter.

2. Click on the Filter button (page 14-5) for the texture.

The Texture Editor dialog box, as shown in Figure 14.11, opens.

Figure 14.11   Texture Editor
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w
The Texture Editor is organized and used for filtering texture 
images in the same manner as the Surface Editor is used for 
setting a group’s surface attributes. For an explanation of the 
Surface Editor and its controls, refer to Chapter 18: The Surface 
Editor.

3. Use the controls to set the surface attributes for the texture. By 
default, these settings (accept for group color) will override 
individual surface attributes set at the group level. If you do not 
want any specific attributes to override the group level settings, 
be sure to disable the check boxes for those attributes.

Figure 14.12 shows two examples of mapping with texture 
surface attributes replacing the surface attributes of the group. In 
both cases, the alpha channel is set to Decal. In the example on 
the left, an image of the letters EIAS with a band of color is 
mapped onto a solid color cube; the surface color attributes of 
the map replace the surface color attributes of the cube. In the 
example on the right, the RGB channel is set to Disable; the 
reflectivity attributes of the map are set to a maximum and 
replace the reflectivity attributes of the cube (which were set to a 
minimum) where the letters appear.

4. Click OK or press Return when done.

Figure 14.12   Examples of applying a color decal (left) and a reflective decal (right)
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Overview
The Group Link window, shown in Figure 15.1, is used to set linking 
and rotation information for the selected group.

Each group can have its own link type and location. A link is the 
pivot point of the group, and the type determines how the pivot 
point will react relative to the parent of the group. The pivot point is 
oriented so that correct movement is achieved, as defined by the link 
type. Certain link types use the Z axis as the major axis, or the axis on 
which motion is achieved.

Figure 15.1   Group Link window

Rotation order (page 15-8)

Alignment position (page 15-9)

Alignment Orientation (page 15-9)

Link type (page 15-10)

Group inherit settings (page 15-12)

Gnome (page 15-4)

Group icon (page 15-4)

View pop-up menu (page 15-7)

Position and rotation settings
(page 15-13)
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The Group Link window also contains check boxes to establish the 
selected group’s relationship with a group hierarchically ordered 
above it (if applicable). These options can be used to control whether 
or not the selected group will inherit position, rotation, scale, 
visibility and deformation attributes from its parent group.

Opening the Group Link Window

The Group Link window can be opened in any of the following ways:

• Select the group and choose Group’s Linkage from the Tools 
menu, as discussed in the section “Group’s Linkage” (page 5-14) 
in Chapter 5: The Tools Menu Commands.

• Select the group and choose the Group’s Linkage tool from the 
Tool Palette, as discussed in the section“The Group’s Linkage 
Tool” (page 19-15) in Chapter 19: The Tool Palette.

• Select the group in the Project window and click the Group’s 
Linkage tool in the Project window’s tool palette, as discussed in 
the section “Group’s Linkage” (page 8-26) in Chapter 8: The 
Project Window.
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Window Elements
The display area in the center of the window, as shown in 
Figure 15.2, shows the group and its pivot point.

The pivot point is indicated by the gnome, which is a three 
dimensional crosshair icon, with each axis labeled. This crosshair is 
used to assist in the alignment of the group’s pivot point.

Figure 15.2   Window elements

Gnome

Group

Pivot point
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Window Display Controls
In using the Group Link window, there are several controls that you 
can use to manipulate the view, as shown in Figure 15.3.

The view can be changed in two basic ways:

• The area displayed can be changed by zooming in, zooming out 
and scrolling or dragging the window’s contents, as discussed in 
the section “Changing the Area Displayed” (page 15-6).

• The view can be changed, as discussed in the section “Changing 
the View” (page 15-7).

Figure 15.3   Window controls

View pop-up menu (page 15-7)

Zoom buttons (page 15-6)
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Changing the Area Displayed

There are several ways of changing the area displayed inside a World 
View window. To zoom in and out:

• Use the zoom buttons in the lower right corner of the window. 
To zoom in, click on the right zoom button. To zoom out, click 
on the left zoom button. To zoom in or out to a view that 
includes all objects in the project, hold down the option key 
while clicking either one of the zoom buttons.

• Use the Zoom Window tool from either the Tool Palette or the 
Tools Menu. To zoom in, click on the area you wish to zoom in 
on with the Zoom Window tool. To zoom out, hold down the 
option key while clicking with the Zoom Window tool. For an 
explanation of the Zoom Window tool, refer to the section “The 
Zoom Window Tool” (page 19-9) in Chapter 19: The Tool Palette, 
or the section “Zoom Window” (page 5-8) in Chapter 5: The Tools 
Menu Commands.

• Drag a rectangle around the area you wish to zoom in on.

To scroll the window’s contents:

• Use the vertical and horizontal scroll bars.

• Use the Drag Content tool from either the Tool Palette or the 
Tools menu to scroll the window’s contents. For an explanation 
of the Drag Content tool, refer to the section “Zooming in or out 
is done by a factor of 2 with each click of the mouse.” (page 19-9) 
in Chapter 19: The Tool Palette, or the section “Drag Content” 
(page 5-9) in Chapter 5: The Tools Menu Commands.
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Changing the View

The view of the Group in the display area can be changed through 
the use of the pop-up menu located to the left of the horizontal scroll 
bar in the lower left corner of the window, as shown in Figure 15.3. 
The menu choices are:

Camera This option shows the object as the camera sees it.

Skew This option (the default) shows the object at a skewed angle to 
represent a three-dimensional view. The detail to which the object is 
drawn can be set in the Drawing Preferences box, selectable from the 
Edit menu.

Top This option shows the object in the Y/Z coordinate space.

Side This option shows the object in the X/Z coordinate space.

Front This option shows the object in the X/Y coordinate space.

Positioning the Pivot Point

The pivot point can be dragged in the display area to the desired 
position relative to the group (only in the Top, Side and Front views, 
though it can be rotated in a skew view).

For more precise positioning, there are edit boxes below the display 
area that affect the placement and orientation of the pivot point 
relative to the group, as discussed in the section “Position and 
Rotation” (page 15-13).
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Pivot Point and Rotation Controls

Rotation Order

This pop-up menu is used to select the order, according to XYZ 
coordinates, in which the group rotates about its pivot point. The 
menu choices are:

XYZ

XZY

YXZ

YZX

ZXY (the default)

ZYX

XYX (z)

XZX (y)

YXY (z)

YZY (x)

ZXZ (y)

ZYZ (x)

The letters in parentheses indicate the coordinate channel that 
controls the last rotation in the order. For example, XYX (z) indicates 
an X rotation, then a Y rotation, then another X rotation controlled 
by the Z coordinate channel.
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Link Alignment Position

This pop-up menu is used to select the position of the group’s pivot 
point (denoted by the gnome in the display area, as shown in 
Figure 15.2 on page 15-4).

The position of the pivot point can be further modified by either 
typing in coordinates in any of the position or rotation boxes located 
under the display area, as discussed in the section “Positioning the 
Pivot Point” (page 15-7), or by use of the X, Y and Z Rotate tools in 
the Tool Palette, as discussed in Chapter 19: The Tool Palette.

The menu choices are:

Midpoint This option (the default) positions the pivot point at the group’s 
midpoint.

Front This option positions the pivot point at the group’s front.

Back This option positions the pivot point at the group’s back.

Top This option positions the pivot point at the group’s top.

Bottom This option positions the pivot point at the group’s bottom.

Left This option positions the pivot point at the group’s left side.

Right This option positions the pivot point at the group’s right side.

Link Alignment Orientation

This pop-up menu is used to re-orient the group’s coordinates (if so 
desired). The menu choices are:

Z proper This option (the default) maintains the group’s coordinates.

Z is X This option swaps the group’s Z and X coordinates so that the Z 
coordinate becomes the X coordinate.

Z is Y This option swaps the group’s Z and Y coordinates so that the Z 
coordinate becomes the Y coordinate.
The ElectricImage™ Reference 15-9



Chapter 15: The Group Link Window

Book  Page 10  Friday, July 21, 2000  4:18 PM
Link Type

This pop-up menu is used to select which link type will be assigned to 
the pivot point of the group. Some link types use the Z axis as the 
major axis. The menu choices are:

Custom… This option opens a dialog box, shown in Figure 15.4, that enables 
you to set locks on the position and rotation of the group for a 
customized link type.

Free This link type allows total freedom of movement. This is the default 
link type for parent groups and if the object is to be included in the 
project without any hierarchy. 

Ball Planar This link type allows front and side directional motion, and rotation 
of all three axes.

Cylinder Planar This link type allows rotation around the top and side axes, and 
directional motion along the front and side. No up and down motion 
is allowed.

Planar This link type allows directional motion along the front and side 
axes, with rotation along the top axis only.

Socket This link type allows rotation on all three axes only.

Cylinder This link type allows back to front motion and rotation only.

Universal This link type allows rotation along the top and side axes only.

Slide This link type allows up and down motion along the Z axis only. 
Position the Z axis of the pivot point (as indicated by the gnome) 
along the correct axis of movement for the group.

Figure 15.4   Dialog box used to create a customized link type
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Pin This link type allows rotation along the Z axis only. Position the Z 
axis of the pivot point (as indicated by the gnome) along the correct 
axis of movement for the group.

Lock This link type does not allow motion of any kind.
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Inherit Characteristics Controls
The check boxes under the pivot point and rotation pop-up menus 
control what characteristics the group inherits from its parent group 
hierarchically ordered above it (if it is linked to a parent group).

w
Preferences for inherit options can also be pre-configured using the 
Import… command in the Edit menu, as discussed in the section 
“Import…” (page 2-33) in Chapter 2: The Edit Menu Commands.

Inherit Position This check box option, when enabled, links the position of the group 
to its parent group hierarchically ordered above it. As the parent 
moves, the group will move with it.

Inherit Rotation This check box option, when enabled, links the rotation of the group 
to its parent group hierarchically ordered above it. As the parent 
rotates, the group will rotate with it.

Inherit Scale This check box option, when enabled, links the scaling of the group 
to its parent group hierarchically ordered above it. As the parent is 
scaled, the group will be scaled with it.

Inherit Visibility This check box option, when enabled, links the visibility of the group 
to its parent group hierarchically ordered above it. As the parent’s 
visibility is switched off and on, the group’s visibility will be switched 
off and on accordingly.

Inherit Deformation This check box option, when enabled, links the deformation of the 
group to its parent group hierarchically ordered above it. As the 
parent is deformed, the group will be deformed as well.
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Position and Rotation
The edit boxes at the bottom of the window contain values for the 
pivot point’s X, Y and Z position coordinates and rotation angles. As 
the various settings in the pivot point and rotation control pop-up 
menus are selected, these boxes are updated with new values 
automatically and can then be used to “fine tune” the pivot point’s 
position and rotation.
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Overview
The Group Deformation window, as shown in Figure 16.1, is used to 
apply a variety of geometrical transformations to a group.

Deformations, which alter the shape and structure of the group, can 
be applied singly or in combination, and can be animated. The 
process of applying a deformation is basically a two-step process:

• Defining a region, or area, of the group in which the deformation 
will occur. This region defaults to the entire group, but can be 
assigned to a part of the group and, therefore, multiple regions 
can be defined for different parts of the group.

• Assigning a deformation to the selected region. There are various 
types of deformations available, and they can be controlled in 
terms of the amount of deformation and the axes of the 
deformation region that are affected. Multiple deformations can 
be assigned to the same region.

Figure 16.1   The Group Deformation window

Region list (page 16-5)       Deformation list (page 16-11) Grow box (page 16-3)

Delete region or deformation (page 16-5) Containing face check boxes (page 16-6)

Deformation options (page 16-10)

Deformation type (page 16-11)

Deformation amount (page 16-11)

Axis of deformation (page 16-11)

Axes to be deformed (page 16-11)

Show regions (page 16-9)

Region manipulation (page 16-6)
16-2 ElectricImage™ Animation System



Overview

Book  Page 3  Friday, July 21, 2000  4:18 PM
The types of deformations available are:

• Scale (page 16-13)

• Shear (page 16-14)

• Twist (page 16-15)

• Taper (page 16-16)

• Bend (page 16-18)

• Bulge (page 16-19)

• Linear Wave (page 16-21)

• Circular Wave (page 16-23)

• Stretch (page 16-25)

• Bezier (page 16-27)

w
Deformations work best on models that are broken up into a large 
number of small polygons.

Opening the Group Deformation Window

The Group Deformation window can be opened in any of the 
following ways:

• Select the group and choose Group Deform from the Tools 
menu, as discussed in the section “Group Deform” (page 5-12) in 
Chapter 5: The Tools Menu Commands.

• Select the group and choose the Group Deform tool from the 
Tool Palette, as discussed in the section“The Group Deform Tool” 
(page 19-13) in Chapter 19: The Tool Palette.

• Select the group in the Project window and click the Group 
Deform tool in the Project window’s tool palette, as discussed in 
the section “Group Deform” (page 8-26) in Chapter 8: The Project 
Window.

• Command-Control-Double Click on the group.

The bottom portion of the window can be hidden and redisplayed by 
clicking the grow box in the upper right corner of the window.
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Deformation Regions
Deformations are applied to a group within regions that are created 
in the Group Deformation window and configured either 
numerically in the window or by direct manipulation in the World 
View windows.

When a deformation is applied to a group, the group’s vertices are 
deformed. Regions allow for control over which vertices are 
deformed. However, depending on the type of deformation applied, 
vertices outside the region may be affected. Figure 16.2 shows an 
example of a deformation that affects vertices outside the region 
alongside an example of a deformation that is completely contained 
within the region.

Figure 16.2   Examples of deformations that occur both outside and completely inside the defined region

Deformation 
regions

A simple bend (affects vertices outside the region) A simple bulge (affects only vertices within the region)
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Defining a Region

The first step in applying a deformation to a group is to define the 
deformation region.

To define a region:

1. Click the New… button under the Region list.

A dialog box, as shown in Figure 16.3, opens to allow you to name 
the deformation region.

2. Type a name for the region (if not using the default).

3. Either click OK or press Return.

The name of the region appears in the Region List and the Region and 
Deformation controls become active.

4. Configure the region’s position, rotation and minimum and 
maximum dimensions (relative to the center point of the group) 
by using either the numerical controls at the bottom of the 
window or by clicking and dragging the region’s handles in the 
World View windows. The “ghost region” (page 16-9) must be 
visible to directly manipulate the region.

For an explanation of how to manipulate the region, refer to the 
section “Manipulating the Region” (page 16-6). If you want to 
define a deformation for the region in its current configuration, 
refer to the section “Creating a Deformation” (page 16-11).

w
To delete a region you have defined, drag the region from the 
Region list to the trash can icon below the list.

Figure 16.3   Dialog box used to name a deformation region
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Manipulating the Region

There are two ways to manipulate the region: through numerical 
manipulation in the Group Deformation window, and by direct 
manipulation in the World View windows.

Numerical Manipulation The bottom portion of the window, as shown in Figure 16.4, contains 
text entry boxes that allow you to control the position, orientation 
and size of the region relative to the center point of the group.

w
Every text entry box in the window has a corresponding animation 
channel in the Project window, as discussed in Appendix C: Group 
Data Channels.

To the right of each text entry box is a rocker button that allows 
incremental adjustments to the value in its text entry box. By default, 
a rocker button changes its value in increments of 1/100 (0.01). 
However, the increment increases by a factor of ten for each modifier 
key that is held down while the mouse is clicked on the rocker 
button. For example, if the Shift and Option keys were both down, 
then the value would change by increments of 1.0. If the Shift, 
Option and Command keys were down then the value would change 
by increments of 10.0.

There are also six check boxes that determine whether each face of 
the deformation region will be a “containing face” or not. 
Containing faces allow greater control over which vertexes are 
affected by a deformation and are discussed below (page 16-7).

Figure 16.4   Region controls
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Direct Manipulation Almost every parameter that can be controlled through the Group 
Deformation window can also be controlled through direct 
manipulation of the deformation region in a World View window. 
Figure 16.5 shows an undeformed active deformation region as it is 
displayed in a World View window.

The origin knob indicates the origin of the deformation region’s 
space. The user can reposition the region by dragging the origin 
knob. The red lines extending from the origin indicate the current 
deformation’s axis of deformation (the longer red line) and the axes 
being deformed (the shorter red lines). The axis of deformation and 
the axes being deformed can only be changed in the Group 
Deformation window.

The six deformation face knobs allow the user to change the size of 
the deformation by clicking and dragging. Additionally, a 
command-click on a face knob toggles the “containing face” attribute 
of the face. If a face is a containing face, then a criss-cross is drawn 
through the face. In Figure 16.5, all the faces are containing faces.

Finally, if you click and drag anywhere inside the deformation region 
but not on any of the knobs, then you can interactively change the 

Figure 16.5   Deformation region in a World View window

Deformation face knobs

Deformation origin knob

Deformation face knobs
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deformation amount in increments of 1.0 by dragging horizontally. 
By double-clicking in the deformation region away from the knobs, 
you can bring up the deformation’s custom options dialog box (if one 
exists for the selected deformation). These options are discussed in 
the sections for each deformation, following.

To directly manipulate the active deformation region’s orientation in 
the manner of a trackball, you must hold down the control key. 
Upon pressing the control key, a virtual sphere is drawn around the 
active region as shown in Figure 16.6.

Dragging the mouse anywhere in a World View window while the 
Control key is down allows you to rotate the active region around 
two of its axes. To constrain rotation to just one axis, you can also 
hold down the command and/or option keys. The convention for 
rotating deformations regions is the same as for rotating groups in 
ElectricImage, the only difference being the appearance of the virtual 
sphere.

Figure 16.6   Rotating sphere (trackball)
16-8 ElectricImage™ Animation System
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Displaying Regions

Two check boxes in the center of the Group Deformation window 
control how the deformation regions are displayed in the World View 
windows. 

Show Ghost Region This check box option determines if the active (selected) deformation 
region’s “ghost image” is displayed or not. The ghost image shows 
the deformation region in its original undeformed position. It 
provides direct manipulation of the deformation region’s position 
and size from within the World View windows. Figure 16.7 shows an 
example of a ghost region.

Show All Regions This check box option determines whether or not the group’s 
inactive (not selected) deformation regions are displayed.

Figure 16.7   A group with three deformation regions (twist, taper and bend)

Ghost region
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Deformations
ElectricImage provides the following deformations, selectable from 
the Type pop-up menu once a region for them has been defined:

• Scale (page 16-13)

• Shear (page 16-14)

• Twist (page 16-15)

• Taper (page 16-16)

• Bend (page 16-18)

• Bulge (page 16-19)

• Linear Wave (page 16-21)

• Circular Wave (page 16-23)

• Stretch (page 16-25)

• Bezier (page 16-27)

Depending on which type of deformation is selected, the Options… 
button to the right of the pop-up menu activates to select further 
options for controlling the deformation.
16-10 ElectricImage™ Animation System
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Creating a Deformation

To create a deformation (for the active region):

1. Select the type of deformation from the Type pop-up menu.

The name of the deformation appears in the Deformation list to the 
right of the Region list.

2. Set the amount of deformation by either entering a value in the 
Amount edit box or using the rocker buttons.

w
The actual label for the Amount edit box changes according to the 
type of deformation being applied. For Twist, Bend and Shear 
deformations, the edit box is labeled “Angle.” For Scale, Taper and 
Bulge deformations, the edit box is labeled “Percentage.” For 
Stretch and Bezier deformations, the edit box is labeled 
“Strength.”

3. Select the axis along which the deformation will be calculated 
(X, Y or Z) by clicking the appropriate Along Axis radio button. 
For an illustration of the various effects to be achieved by 
selecting different “Along Axis” settings, see Figure 16.8 
(page 16-12).

4. Select which axis (or axes) to deform by clicking the applicable 
Deform Axes check box(es). For an illustration of the various 
effects to be achieved by selecting different “Deform Axes” 
settings, see Figure 16.8 (page 16-12).

You can view the results of your settings in the World View and 
Camera View windows.

w
If you are applying deformation(s) to a group that has been previously 
scaled, the effect of deformations will be scaled as well. It is therefore 
preferable, if you need to scale a group to which you will be applying 
deformations, to scale the group first using the Scale deformation, as 
discussed in the section “Scale” (page 16-13).
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Figure 16.8   Examples of Along Axis settings (X, Y and Z)

Figure 16.9   Examples of Deform Axes settings (Y, Z and YZ)
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Scale

The Scale deformation is used to uniformly shrink or expand either 
all or part of a group in one, two or three dimensions. A 
one-dimensional scale is similar to extruding a shape along an 
arbitrary axis. Figure 16.10 shows an example of two 
one-dimensional scale deformations. One negative scale compresses 
part of the group while the other positive scale expands a different 
part of the group.

The scale deformation works by moving vertexes either toward or 
away from the origin of deformation depending on the deformation 
amount. The deformation amount acts like a percentage. If -100.0% 
is entered as the deformation amount, then all vertexes affected by 
the deformation move all the way to the origin. If 100.0% is entered, 
then vertexes move twice as far from the origin as their original 
position. A deformation amount of 0.0 indicates no deformation.

Figure 16.10   Example of Scale deformation

Negative scale

Positive scale

Original Shape
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Shear

The Shear deformation is used to “shear” the group, as shown in 
Figure 16.11. Shearing is typically done in one direction rather than 
two.

Figure 16.11   Example of Shear deformation

Original Shape
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Twist

The Twist deformation is used to “twist” the group, as shown in 
Figure 16.12. The deformation amount for a twist corresponds to the 
angle of the twist in degrees.

Figure 16.12   Example of Twist deformation

Original Shape
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Taper

The Taper deformation is used to “taper” the group. The amount 
value for tapering is a percentage similar to Scale deformations. A 
taper of -100.0% tapers an object down to nothing in one or two 
dimensions. A taper of 100.0% doubles the object’s size in one or two 
dimensions. Figure 16.13 shows an example of two negative, 
one-dimensional tapering deformations.

Figure 16.13   Example of Taper deformation

Taper (filleted)

Taper (not filleted)

Original Shape
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In Figure 16.13, the upper taper has smooth transitions while the 
lower taper has hard corners. The smooth transitions are created by 
filleting the taper, an optional function of the Taper deformation.

To fillet a taper:

1. Click the Options… button next to the Type pop-up menu.

A dialog box, as shown in Figure 16.14, opens to allow you to specify 
filleting.

2. Use the check box options and the display window to set the 
filleting option you prefer.

3. Either click OK or press Return.

Figure 16.14   Dialog box used to create filleted taper
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Bend

The Bend deformation is used to “bend” the group. Bending typically 
works best in one dimension rather than two. The deformation 
amount for a bend corresponds to the angle of the bend in degrees. 
Figure 16.15 shows an example of two 90° bends applied to an object.

Bending deformations can create some of the most visually 
interesting effects, but must be used carefully when combined with 
other deformations. Because a bend can move the vertexes above the 
deformation regions substantially, unnatural results occur when a 
bend is followed by another deformation in the same region. A good 
rule of thumb when combining multiple deformations in the same 
region is to place any bend(s) at the end of the list of deformations.

An interesting jello-effect can be achieved by applying a slight bend 
along the length of an object, and then animating rotation of the 
deformation region around the axis being deformed (be sure to turn 
off the “containing faces” to get this effect).

Figure 16.15   Example of Bend deformation (two 60° bends)

Original Shape
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Bulge

Bulge deformations are useful for implementing the classic “squash 
and stretch” motion commonly used in character animation. The 
deformation amount for a bulge corresponds to the percentage of 
bulge. Figure 16.16 show s a -100% bulge with the origin of 
deformation moved away from the object being deformed. In order 
to deform vertexes outside the region of deformation, the region’s 
“containing faces” check boxes must be unchecked (the default).

As with Taper deformations, Bulge deformations can be filleted.

To fillet a bulge:

1. Click the Options… button next to the Type pop-up menu.

A dialog box, as shown in Figure 16.17 (page 16-20), opens to allow 
you to specify filleting.

2. Click the Filleted Bulge check box to select a filleted bulge.

The little display window indicates your selection.

Figure 16.16   Example of Bulge deformation

Original Shape
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3. Either click OK or press Return.

Figure 16.17   Dialog box used to create filleted bulge
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Linear Wave

The Linear Wave deformation allows you to send a sine wave through 
the vertexes within the deformation region. The wave travels along 
the axis of deformation, and the amplitude of the wave extends in 
the direction of the axis being deformed. Typically only one axis is 
deformed for Linear Wave deformations. The amplitude of the wave 
is determined by the deformation amount value. The frequency and 
phase of the wave are set in the wave deformation’s custom options 
dialog box shown below. Amplitude, frequency and phase can all be 
animated using the Project window. Figure 16.18 shows an example 
of a simple Linear Wave along the vertical axis.

Settings for the frequency and phase of the wave form, and a choice 
between a sine wave and modified cosine wave are available as 
options for the Linear Wave deformation.

To set Linear Wave deformation options:

1. Click the Options… button next to the Type pop-up menu.

Figure 16.18   Example of Linear Wave deformation

Original Shape
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A dialog box, as shown in Figure 16.19, opens to allow you to set 
wave options.

2. Type values for the number of waves and the phase of the wave 
form in the Waves and Phase edit boxes respectively.

3. Select a wave type by clicking the appropriate Wave Type radio 
button.

The little display window indicates your settings.

4. Either click OK or press Return.

Figure 16.19   Dialog box used to set Linear Wave options
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Circular Wave

The Circular Wave deformation, as shown in Figure 16.20, is used to 
simulate the concentric waves created when an object strikes a liquid 
surface. The amplitude of a Circular Wave extends along the axis of 
deformation and is determined by the height of the deformation 
region along the “Along Axis.” The deformation amount can thus be 
used to animate the outer radius of the concentric waves, while the 
height of the region can be used to dampen the wave as it disperses.

The Deform Axes check boxes are ignored by the Circular Wave 
deformation.

In Figure 16.21 (page 16-24), notice that the deformation region 
extends beyond the dimensions of the object being deformed. The 
Circular Wave deformation uses the size of the deformation region to 
determine the distance from the Circular Wave’s outer radius to its 
inner radius which in turn determines the frequency of the waves 
(along with the number of waves which is set in the custom options 
dialog).

Figure 16.20   Example of Circular Wave deformation

Original Shape
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A setting for the number of rings in the deformation is available as an 
option for the Circular Wave deformation.

To set the number of rings:

1. Click the Options… button next to the Type pop-up menu.

A dialog box, as shown in Figure 16.22, opens to allow you to set 
wave options.

2. Type a value for the number of rings in the Number of Rings 
edit box.

3. Either click OK or press Return.

Figure 16.21    Circular Wave deformation region

Figure 16.22   Dialog box used to set the Circular Wave’s number of rings
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Stretch

The Stretch deformation is used to “grab a hold” of a region of 
vertexes and move, rotate, contract or expand them however you 
want by moving, rotating and resizing the region of deformation. 
You can also specify a “blend factor” that allows vertexes surrounding 
the deformation region to be blended toward those being warped. 
Figure 16.23 shows an example of a stretch in which the captured 
vertexes are moved, rotated and blended to the undeformed vertexes.

A Stretch deformation is unlike any of the other deformations. Rather 
than apply a deforming function to vertexes, you simply grab hold of 
the vertexes and then animate the position, orientation and size of 
the deformation region. In order to make this work, you must first 
“capture” the vertexes to be warped. Capturing the vertexes is like 
taking a snapshot of them in their undeformed state. 

To capture the vertexes:

1. Click the Options… button next to the Type pop-up menu.

A dialog box, as shown in Figure 16.24, opens.

Figure 16.23   Example of Stretch deformation

Original Shape
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2. Click the Capture Vertexes button.

w
Typically, vertexes are captured at frame zero of an animation, 
but they can be captured at any frame. No deforming occurs until 
the “Capture Vertexes” button is pressed.

3. If you want to create a blend, set the blend factor by typing a 
value in the Blend Factor edit box.

A blend factor of 0.0 will not blend the vertexes surrounding the 
deformation at all. A blend factor of 1.0 will blend vertexes that 
are within an area twice the size of the deformation region. The 
larger the blend factor, the larger the area surrounding the 
stretch region that is affected.

4. Either click OK or press Return.

w
The deformation amount for a Stretch deformation can be used to 
specify the strength of the warping region in a magnet-like fashion. A 
Stretch deformation is basically a linear interpolation of vertexes from 
a starting position to a warped position. Instead of animating the 
position, orientation and size of the deformation region, you may 
choose to capture the vertexes and then reposition the region all in the 
same frame, and then animate the strength of the warp to simulate a 
magnet.

Figure 16.24   Dialog box used to set blend factor and capture vertexes
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Bezier

The Bezier deformation is used to deform a group in a “free-flowing” 
manner through the use of Bezier control arms. These control arms 
work in much the same way as curves are manipulated by popular 
Macintosh drawing programs such as Aldus Freehand®, Adobe 
Illustrator® and Canvas™. As you move these control arms, the 
group’s vertexes follow. Figure 16.25 shows an example of a simple 
Bezier deformation.

Each Bezier control arm is comprised of three points, an “anchor” 
point, a “control” point, and a “spin” point.

In Figure 16.26 (page 16-28), the anchor points are surrounded by a 
circle, the control points are at the end of the longer arms, and the 
spin points are at the end of the shorter arms. Each of the points can 
be animated independently, however ElectricImage will make sure 
that three points always form a 90° angle by adjusting the spin point 
as necessary.

Figure 16.25   Example of simple Bezier deformation

Original Shape
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Figure 16.26   Bezier deformation with control elements

Control point

Anchor point

Spin point
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The points can be manipulated in the World View windows, or 
numerical values can be entered.

To enter numerical values for the anchor, control and spin points:

1. Click the Options… button next to the Type pop-up menu.

A dialog box, as shown in Figure 16.27, opens.

2. Enter coordinates in the edit boxes.

To reset the coordinates to their original, undeformed positions, 
click the Reset Points button.

w
You can also set the type of Bezier deformation to specify whether 
or not continuity is maintained at the edge of the deformation. 
The default Bezier deformation minimizes the amount of pinching 
that occurs during tight bends, however it may create 
discontinuous corners if the deformation is not applied to the 
entire group. Figure 16.28 (page 16-30) shows examples of default 
and continuous deformations.

3. If you want to use the continuous Bezier deformation that 
maintains continuity at the edge of the deformation, click the 
Curve Continuity check box.

Figure 16.27   Dialog box used to set Bezier deformation options
The ElectricImage™ Reference 16-29



Chapter 16: The Group Deformation Window

Book  Page 30  Friday, July 21, 2000  4:18 PM
4. Either click OK or press Return.

w
Bezier deformations should generally not overlap geometrically with 
other deformations in the same group, as the results can be difficult to 
predict.

Figure 16.28   Examples of default and continuous Bezier deformations
Default Bezier deformation Continuous Bezier deformation
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Overview
The Velocity windows for the camera, lights and models contain 
graphs that chart the changes in velocity of animated data and 
provide controls for adjusting the velocity, as shown in Figure 17.1.

w
The Velocity windows are best used as a tool in conjunction with the 
motion path spline, and the timing of the individual keyframes. When 
taken as a whole, these different approaches will yield the most control 
over an animated sequence.

Figure 17.1   Velocity window for the camera

Window controls (page 17-4)

Motion path spline pop-up menu
(page 17-8)

Graph elements (page 17-6)
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Opening the Velocity Windows

To open the Camera Velocity window, select the camera, and choose 
Camera Velocity from the Windows menu, as discussed in the 
section “Camera Velocity” (page 3-10) in Chapter 3: The Windows 
Menu Commands.

To open the Light Velocity window for a specific light, select the 
light, then choose Light Velocity from the Windows menu, as 
discussed in the section “Light Velocity” (page 3-11) in Chapter 3: The 
Windows Menu Commands.

To open the Model Velocity window for a specific model, select the 
model, then choose Model Velocity from the Windows menu, as 
discussed in the section “Model Velocity” (page 3-12) in 
Chapter 3: The Windows Menu Commands.
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Window Controls
The data channels displayed in a velocity window and the height of 
the data channel display can be customized through the use of the 
two controls in the upper left corner of the window.

Channel Display

This pop-up menu is used to select which data channels are displayed 
in the graph. By default, all data channels are displayed. This control 
enables you to restrict the display to only those data channels you 
wish to see.

To customize the display:

1. Choose Custom… from the Channel Display pop-up menu.

A dialog box, as shown in Figure 17.2, opens, to enable you to 
configure the display.

2. Select which channels you wish to display.

3. Either click OK or press Return.

Figure 17.2   Dialog box used to select velocity channels to display
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Graph Size

This pop-up menu is used to set the size of the data channels in the 
display. The smallest possible size is the default, and this control can 
be used to increase the height of the data channels.

To change the height of the data channels:

1. Choose Size… from the Graph Size pop-up menu.

A dialog box, as shown in Figure 17.3, opens, to enable you to set the 
graph size.

2. Type a value for the data channel height in the Graph Size edit 
box.

3. Either click OK or press Return.

Figure 17.3   Dialog box used to set graph size
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Graph Elements
Figure 17.4 shows the basic elements of the velocity graph.

• The active keyframe is drawn as a vertical red line while the other 
keyframes bars are drawn in black.

• The actual velocities for the keyframes are at the top of each 
graph channel.

• The speed curve is drawn in blue, as is the teeter bar.

Figure 17.4   Graph elements

Motion path spline selection

Keyframe bar

Teeter bar

Active keyframe

Keyframe time

Velocity at keyframe Speed curve
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Graph Controls
To change the camera’s velocity at a specific keyframe (and thus the 
curve of the graph), select the keyframe and drag the center of the 
teeter bar up or down, as shown in Figure 17.5.

To change the acceleration (and thus change the bias of the curve), 
drag either teeter bar handle up or down, as shown in Figure 17.6.

To change the time of a keyframe, drag the keyframe bar left or right, 
as shown in Figure 17.7.

Figure 17.5   Changing the velocity at a specific keyframe

Velocity

Click and drag here, up and down

Figure 17.6   Creating an irregular motion

Acceleration

Click and drag here, up and down

Figure 17.7   Changing the time of a keyframe

Keyframe Time

Click and drag here, left and right
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Motion Path Splines
A pop-up menu next to the channel name, as shown in Figure 17.4 
(page 17-6), is used to select the motion path spline for the channel. 
This is an alternative to selecting the spline type in the Project 
window. The different spline types available in ElectricImage are:

Linear Splines These are not actually splines, but rather a simple line. All motion 
using linear interpolation results in a very mechanical (sometimes 
awkward) motion.

Natural Cubic These splines give a very fluid motion, and are the best to use if you 
do not care about the precision of object placement, since editing 
one keyframe along the spline will change the whole curvature of the 
spline.

Hermite Splines These splines are more versatile to use but require greater effort to 
control. Unlike the natural cubic spline, editing one keyframe along 
the spline will not change the whole curvature of the spline, and thus 
the curve can be manipulated with greater precision.

Bezier Splines These splines are the same splines used by popular Macintosh 
drawing programs such as Aldus Freehand®, Adobe Illustrator® and 
Canvas™, however ElectricImage Bezier splines are 3-dimensional.
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Camera Velocity
The velocity graphs for the camera chart the changes in velocity of 
positional movement, reference direction and roll angle when the 
camera is animated.

As shown in Figure 17.8, the window shows three data channels:

Camera Position This channel shows the change in velocity of the combined X, Y, and 
Z position of the camera.

Camera Reference This channel shows the change in velocity of the combined X, Y, and 
Z position of the camera reference point.

Camera Roll This channel shows the change in velocity of the camera’s roll axis.

Figure 17.8   Camera Velocity window
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Light Velocity
The velocity graphs for lights chart the changes in velocity of 
positional movement and reference direction when lights are 
animated.

As shown in Figure 17.9, the window shows two data channels:

Light Position This channel shows the change in velocity of the combined X, Y, and 
Z position of the light.

Light Reference This channel shows the change in velocity of the combined X, Y, and 
Z position of the light reference point.

Figure 17.9   Light Velocity window
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Model Velocity
The velocity graphs for models chart the change in velocity of 
positional movement, rotation and scale when models are animated.

As shown in Figure 17.10, the window shows eight data channels:

Position This channel shows the change in velocity of the combined X, Y, and 
Z positions. 

Center This channel shows the change in velocity of the center point. 
Velocity is zero if the center of the group has not been animated. 

X Rotation This channel shows the change in velocity of the X axis rotation.

Y Rotation This channel shows the change in velocity of the Y axis rotation.

Z Rotation This channel shows the change in velocity of the Z axis rotation.

X Scale This channel shows the rate of change for scale on the X axis.

Y Scale This channel shows the rate of change for scale on the Y axis.

Z Scale This channel shows the rate of change for scale on the Z axis.

Figure 17.10   Model Velocity window
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Overview
The Surface Editor, as shown in Figure 18.1, is a dialog box used to 
change or modify the shading characteristics for the surface of any 
group in a model.

w
Depending upon which editing mode is in effect (as set in the Project 
window), shading characteristics can be set for specific frames, 
keyframes or times, or for all frames, keyframes or times. For a 
discussion of editing modes and the Project window, refer to 
Chapter 8: The Project Window.

Figure 18.1   The Surface Editor

Attribute values in edit boxes
(page 18-5)

Attribute values in slider bars
(page 18-5)

Application controls (page 18-16) Attribute selection
(page 18-7)

Current/previous color (page 18-7) Display sphere (page 18-6)
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Opening the Surface Editor

The Surface Editor can be opened in either of two ways:

• Open the Group Info window for the group and click on the 
Surface button located in the Group Info window, as discussed in 
Chapter 13: The Group Info Window. The Surface button is actually 
a miniature representation of the surface settings for the selected 
group.

• Open the Project window (in Keyframe, Frame or Index modes) 
and double-click on the group’s attribute channel, as discussed in 
Chapter 8: The Project Window.
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Editor Controls

Slider Bars and Edit Boxes

The left side of the Surface Editor, as shown in Figure 18.2, contains 
seven slider bars which are used to set the component values of 
various shading attributes.

Above each bar is the name of the component which it controls, as 
well as an edit box which contains the current value of the 
component (and in which a value can be typed).

The appearance of the slider bars and the components they control 
are case sensitive, depending upon which shading attribute has been 
selected from the Attribute pop-up menu, as discussed in the section 
“Surface Attributes” (page 18-8).

Figure 18.2   Slider bars and Edit boxes for Group Color attribute
The ElectricImage™ Reference 18-5



Chapter 18: The Surface Editor

Book  Page 6  Friday, July 21, 2000  4:18 PM
Display Sphere

This display is used as a visual aid in setting the group’s shading 
attributes, and thus indicates the effect of the settings on the group. 
The sphere shows all of the attribute settings at all times. As you 
make changes to the settings, the display is updated in real time to 
indicate the changes.

w
You can copy a group’s surface attributes for pasting to another group 
by clicking the display sphere to select it (a border appears around the 
display to indicate that it is selected), and then choosing Copy Surface 
Color from the Edit menu.

The background of the display defaults to the black & white checker 
pattern, however a solid color background can be employed. This 
feature is helpful when you want to preview the effect of surface 
attributes settings against a specific solid color background.

To change the
background of the

display sphere:

1. Hold down the Option key and click anywhere in the display 
area (without the Option key, clicking selects the display).

A pop-up menu, as shown in Figure 18.3, opens.

2. Choose one of the options (shown in Figure 18.3).

Selecting Custom color… opens the Apple Color Picker. The color 
you select becomes the background for the display.

Figure 18.3   Display sphere background pop-up menu
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Type

This edit box is used to name the settings in the Surface Editor as a 
whole material value. The settings can then be copied into the 
scrapbook and pasted into other groups by use of the Copy and Paste 
commands in the Edit menu. The scrapbook can thus be used as a 
library of materials (when the material is copied into the scrapbook, 
the sphere and type name are shown in the scrapbook window). Note 
that the name is for scrapbook reference only and will not normally 
be visible in this field.

Current/Previous Color Display

This display is similar to the one found in the Apple color picker. The 
top of the box will update to the new color value in real time, while 
the bottom of the box shows the color of the group before any 
changes.

Attribute

This pop-up menu determines which surface attributes you are 
editing while in the Surface Editor. There are eight surface attributes 
available for editing, and there is an enable check box for each, 
located beneath the pop-up menu.

These check boxes are enabled by default, and can be individually 
turned off (by clicking in the check box) should you not wish to have 
a particular attribute rendered.

The Specular and Edge Density attributes also have edit boxes for 
setting specific shading dropoff and specular dropoff values. For an 
explanation of these and the other surface attributes, refer to the 
section “Surface Attributes” (page 18-8).
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Surface Attributes
There are eight surface attributes available for editing, and there is an 
enable check box for each, located beneath the pop-up menu. The 
attributes can be edited by using either the slider bars or the edit 
boxes atop the slider bars. In addition, there are edit boxes on the 
right side of the Surface Editor which further control shading, 
specular highlight and edge density.

Group Color

This attribute controls the base color of the group. When selected, 
the Surface Editor appears as in Figure 18.1 (page 18-3).

The controls for this attribute are as follows:

Alpha This control sets the group’s matte channel density.

Red, Green, Blue These controls fine tune the group’s surface color.

Hue This control sets the base color of the group’s surface.

Sat(uration) This control sets the amount of color added to the group’s surface.

Val(ue) This control determines the degree to which the color is adjusted 
towards black or white.

Shading Dropoff This edit box contains a value for the rate of fall-off in illumination 
from the area of the group that is illuminated to the area that is not, 
thus affecting the size of the transition area.

w
Modeling systems can create objects with more than one color in a 
group. Should you change the group color in this situation, all of the 
polygons in the group will be changed to the new color.
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Diffuse

This attribute controls the group’s diffuse sensitivity, which 
determines the amount and color of light scattered from the group. 
When selected, the Surface Editor appears as in Figure 18.4.

Red, Green, Blue These controls fine tune the color value of the group’s diffuse 
sensitivity.

Hue This control sets the base color of the group’s diffuse sensitivity.

Sat(uration) This control sets the amount of color added to the group’s diffuse 
sensitivity.

Val(ue) This control sets the level of diffuse sensitivity. A small value 
produces a very shiny, but dark surface; a high value produces a very 
dull, but brightly lit surface (the default setting is 255).

w
When rendering transparent objects, it is preferable to lower the diffuse 
value to avoid having the object appear overexposed. Also, the diffuse 
value does not affect the reflectivity value, so an object with an 
apparently dull surface can appear highly reflective.

Figure 18.4   Surface Editor with Diffuse attribute selected
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Ambient

This attribute controls the group’s ambient light sensitivity, which 
determines the amount and color of ambient light reflected by the 
group. When selected, the Surface Editor appears as in Figure 18.5.

Red, Green, Blue These controls fine tune the color value of the group’s ambient 
sensitivity.

Hue This control selects the base color of the group’s ambient sensitivity.

Sat(uration) This control sets the amount of color added to the group’s ambient 
sensitivity.

Val(ue) This control sets the amount of ambient sensitivity of the group. The 
default setting is 255, which results in the object reflecting the full 
amount of ambient light determined by the global Ambient value set 
in the Render Control window, as discussed in Chapter 9: The Render 
Control Window.

Figure 18.5   Surface Editor with Ambient attribute selected
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Specular

This attribute controls the size and color of highlights in the group’s 
surface—if highlights are enabled for the illuminating light, described 
in “Enable Highlight” (page 11-20) in Chapter 11: The Light Info 
Window. When selected, the Surface Editor appears as in Figure 18.6.

Glossy This control adds light to the group to achieve apparent glossiness.

Red, Green, Blue These controls fine tune the color value of the group’s highlights.

Hue This control selects the base color of the group’s highlights.

Sat(uration) This control sets the amount of color added to the group’s highlights.

Val(ue) This control sets the amount of specularity (how much highlight 
reflects off of the group.

Specular This edit box contains a value for the size of the highlight. The 
greater the value, the smaller the highlight will appear.

Specular Dropoff This edit box contains a value for the rate of fall-off from the 
highlight to its surrounding region, thus controlling the relative 
smoothness or hardness of the highlight.

Figure 18.6   Surface Editor with Specular attribute selected
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Reflectivity

This attribute controls the amount of reflectivity and the color bias of 
the group’s reflection.

w
These settings do not automatically cause the group to reflect its 
surroundings. They only enable and modify a reflection image which 
must be assigned and defined in the Group Texture window, as 
discussed in Chapter 14: The Group Texture Window.

When selected, the Surface Editor appears as in Figure 18.7.

Alpha This control is not used for this attribute.

Red, Green, Blue These controls fine tune the color value of the group’s reflection.

Hue This control selects the base color of the group’s reflection.

Sat(uration) This control sets the amount of color added to the group’s reflection.

Val(ue) This control sets the amount of reflectivity for the group. The greater 
the value, the brighter the reflection image is rendered.

Figure 18.7   Surface Editor with Reflectivity attribute selected
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Luminance

This attribute controls the apparent luminance of the group. It does 
not actually cause the group to emit light, but rather it determines 
the amount of shading to be considered when the group is rendered. 
When selected, the Surface Editor appears as in Figure 18.8.

Luminance This control determines the amount of shading to be considered 
when the group is rendered. It forces an amount of shading for the 
whole group and affects the whole surface of the group, regardless of 
the group’s specular or reflectivity settings. Glow lights will not be 
visible in front of groups using this setting.

Red, Green, Blue These controls fine tune the color value of the group’s luminance.

Hue This control selects the base color of the group’s luminance.

Sat(uration) This control sets the amount of color added to the group’s 
luminance.

Val(ue) This control provides an alternative to the Luminance control, above. 
The specular highlight and reflectivity of the group will not be 
affected by the luminance calculation, and instead will shade 
normally. This can provide a translucent effect.

Figure 18.8   Surface Editor with Luminance attribute selected
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Transparency

This attribute controls the transparency rendering of the group. 
When selected, the Surface Editor appears as in Figure 18.9.

w
There are two transparency modes: Filter, with 255 levels and 
transparency mapping capability; and Dither, with 16 levels and no 
transparency mapping (but faster rendering). The mode is set in the 
Group Info window, as discussed in the section “Transparency” 
(page 13-5) in Chapter 13: The Group Info Window.

Opacity This control sets the level of transparency for the Dither mode.

Red, Green, Blue These controls fine tune the color value of the group’s transparency 
rendering.

Hue This control selects the base color of the group’s transparency 
rendering.

Sat(uration) This control sets the amount of color added to the group’s 
transparency rendering.

Val(ue) This control sets the level of transparency for the Filter mode.

Figure 18.9   Surface Editor with Transparency attribute selected
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Edge Density

This attribute adjusts the density of a transparent group’s edges. 
When used with the Transparency attribute (page 18-14), the effect of 
decreased transparency through the group’s edges can be achieved. 
When selected, the Surface Editor appears as in Figure 18.10.

Opacity This control sets the level of edge density for Dither transparency 
mode—see the note on transparency modes (page 18-14).

Red, Green, Blue These controls fine tune the color value of the group’s edge density.

Hue This control selects the base color of the group’s edge density.

Sat(uration) This control sets the amount of color added to the group’s edge 
density.

Val(ue) This control sets the level of edge density for Filter transparency 
mode.

Edge Density This edit box contains a value for the rate of fall-off from 
transparency in the group’s center to opacity at its edges. The greater 
the value, the faster the rate of transition from transparency to 
opacity, and the greater the area of density around the group’s edges.

Figure 18.10   Surface Editor with Edge Density attribute selected
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Applying the Attribute Settings
The controls at the bottom of the surface editor are used to apply the 
attribute settings and to specify how the attribute settings are to be 
applied.

w
To cancel any modifications made since opening the Surface Editor, 
click the Cancel button.

Modify in:

This pop-up menu is used to select the group or groups to which the 
various attributes are to be applied. The menu choices are:

Current Group Only This option (the default) applies the attribute settings to the current 
group only.

All Children This option applies the attribute settings to all children of the current 
group (groups ordered hierarchically below the current group).

All Groups This option applies the attributes to all groups within the current 
group’s model.
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Dialog Buttons

These dialog buttons complete the process of applying attributes. 
They are case sensitive, depending on the editing mode in effect:

Time Mode In Time mode, the buttons appear as follows:

All Keys

Clicking this button applies the settings to the entire sequence (all 
keyframes).

Current Time

Clicking this button (the default) applies the settings at the current 
time only.

Keyframe or
Frame Mode

(if not on a keyframe)

In Keyframe and Frame modes (if not on a keyframe), the buttons 
appear as follows:

All Frames

Clicking this button applies the settings to all frames in the project.

Current Frame

Clicking this button (the default) applies the settings at the current 
frame only.

Keyframe or
Frame Mode

(if on a keyframe)

In Index and Keyframe modes (if on a keyframe), the buttons appear 
as follows:

All Keys

Clicking this button applies the settings to all keyframes in the 
project.

Current Key

Clicking this button (the default) applies the settings at the current 
keyframe only.
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Chapter 19 The Tool Palette

w
The tools in the Tool Palette duplicate the commands in the Tools 
menu, which are discussed in greater detail in Chapter 5: The Tools 
Menu Commands. The Tool Palette thus provides an alternate means 
of using the same functions. Also, some of these tools are available in 
the Project window’s tool palette, as discussed in the section “The Tool 
Palette” (page 8-26) in Chapter 8: The Project Window.
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Overview
The Tool Palette contains tools used to control the display, rotate and 
scale objects, hierarchically link groups together, and more. It is a 
“floating palette;” that is, it floats above the other windows, as long 
as it is visible.

When initially opened, the Tool Palette is configured in a horizontal 
display, as shown in Figure 19.1.

Opening and Configuring the Palette

To open the Tool Palette, choose Tool Palette from the Windows 
menu, as discussed in the section “Tool Palette” (page 3-2) in 
Chapter 3: The Windows Menu Commands.

To change the orientation of the palette from horizontal to vertical, 
click the flip palette button, located in the upper right of the drag bar, 
as shown in Figure 19.1.

To hide the palette, click the hide palette button, located in the upper 
right of the drag bar, as shown in Figure 19.1.

To close the tool palette, click in the palette’s close box, located in the 
upper left of the drag bar, or choose Tool Palette from the Windows 
menu again.

Figure 19.1   Tool Palette in horizontal display

Close palette Flip palette Hide palette 
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The Move Tool
This tool (the default) allows you to move a selected object in any 
direction by dragging the object’s icon in a World View window, as 
shown in Figure 19.2.

Movement can be constrained in the horizontal, vertical and 
diagonal directions by repeatedly pressing the Tab key and cycling 
through a series of changes to the Move tool icon:

When the Move tool has this icon, movement will not be 
constrained.

When the Move tool has this icon, movement will be 
horizontally constrained.

When the Move tool has this icon, movement will be 
vertically constrained.

When the Move tool has this icon, movement will be 
diagonally constrained (to a 45° angle).

Figure 19.2   Move tool icon in a World View window

Move tool 
icon
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The X Rotate Tool
This tool enables you to rotate a selected object around its X axis. In 
the case of the camera or a parallel or spot light, an added benefit is 
the ability to rotate around the look–at point (the case for all 
rotational modes). Double clicking this button preserves this mode 
until another button is clicked.

The X Rotate tool allows you to rotate a selected object around its 
X axis by dragging the object’s icon in a World View window, as 
shown in Figure 19.3.

w
In the case of the camera or a parallel or spot light, an added benefit is 
the ability to rotate around the look–at point (the case for all 
rotational modes).

w
You can also rotate an object around its X axis with the Move tool 
(page 19-4) by pressing the Option and Control keys while dragging.

Figure 19.3   X Rotate tool icon in a World View window

X Rotate 
tool icon
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The Y Rotate Tool
This tool enables you to rotate a selected object around its Y axis by 
dragging the object’s icon in a World View window, as shown in 
Figure 19.4.

w
You can also rotate an object around its Y axis with the Move tool 
(page 19-4) by pressing the Command and Control keys while dragging.

Figure 19.4   Y Rotate tool icon in a World View window

Y Rotate 
tool icon
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The Z Rotate Tool
This tool enables you to rotate a selected object around its Z axis by 
dragging the object’s icon in a World View window, as shown in 
Figure 19.5.

w
You can also rotate an object around its Z axis with the Move tool 
(page 19-4) by pressing the Command, Option and Control keys while 
dragging.

Figure 19.5   Z Rotate tool icon in a World View window

Z Rotate 
tool icon
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The Scale Tool
This tool enables you to scale a selected object uniformly by dragging 
the object’s icon in a World View window, as shown in Figure 19.6.

w
The Scale tool applies only to geometric objects, not cameras or lights.

Figure 19.6   Scale tool icon in a World View window

Scale tool 
icon
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The Zoom Window Tool
This tool enables you to zoom in or out on an area of a window, 
centered on the point over which the tool’s magnifying glass icon is 
placed.

• Zooming in is the default, as indicated by a plus (+) symbol in the 
magnifying glass icon (as shown in Figure 19.7).

• To zoom out, hold down the option key, which changes the plus 
symbol to a minus (-) symbol.

w
Zooming in or out is done by a factor of 2 with each click of the mouse.

w
You can also zoom in on an area of the window by pressing the Option 
key while dragging a rectangle around the area.

Figure 19.7   Zoom Window tool icon in a World View window

Zoom 
Window 
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The Drag Content Tool
This tool enables you to scroll the contents of a World View window 
(top, front or side) by clicking and dragging in the window, as shown 
in Figure 19.8.

w
You can also scroll the contents of a World View window with the Move 
tool (page 19-4) by pressing the space bar while dragging.

Figure 19.8   Drag Content tool icon in a World View window

Drag Content 
tool icon
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The Visible Grid Tool
This tool toggles the visible grid on or off in the World View and 
Camera View windows, as shown in Figure 19.9.

w
Preferences for the dimensions and use of the visible grid are set with 
the Grid & Scale command in the Edit menu, as discussed in the 
section “Grid & Scale…” (page 2-17) in Chapter 2: The Edit Menu 
Commands.

Figure 19.9   Examples of a World View window with visible grid on and off
Visible Grid On Visible Grid Off
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The Snapping Grid Tool
This tool toggles the invisible snapping grid on or off in the World 
View windows. The snapping grid is used to align objects to 
pre-determined positions—they will “snap” to a position when 
moved.

w
Preferences for the dimensions and use of the snapping grid are set with 
the Grid & Scale command in the Edit menu, as discussed in the 
section “Grid & Scale…” (page 2-17) in Chapter 2: The Edit Menu 
Commands.

w
You can also toggle the snapping grid by pressing the Caps Lock key.
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The Group Deform Tool
This tool opens the Group Deformation window for the selected 
group.

The Group Deformation window, shown in Figure 19.10, is used to 
deform the group’s shape in various ways, including bending, 
twisting, tapering, bulging, etc.

w
For an explanation of the Group Deformation window and its use, refer 
to Chapter 16: The Group Deformation Window.

Figure 19.10   Group Deformation window
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The Group’s Texture Tool
This tool opens the Group Texture window for the selected group.

The Group Texture window, shown in Figure 19.11, is used to set 
texture and reflection mapping for the group.

w
For an explanation of the Group Texture window and its use, refer to 
Chapter 14: The Group Texture Window.

w
You can also open the Group Texture window for a group by pressing 
the Command key while double-clicking the group’s icon.

Figure 19.11   Group Texture window
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The Group’s Linkage Tool
This tool opens the Group Link window for the selected group.

The Group Link window, shown in Figure 19.12, is used to set pivot 
points and rotation information for the group.

w
For an explanation of the Group Link window and its use, refer to 
Chapter 15: The Group Link Window.

w
You can also open the Group Link window for a group by pressing the 
Command and Option keys while double-clicking the group’s icon.

Figure 19.12   Group Link window
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The Group’s Modification Tool
This tool opens the Modify Axes window for the selected group.

The Modify Axes window, shown in Figure 19.13, is used to change 
the orientation of the group in local space (i.e., exchanging or 
reversing axes to, for example, make the top become the bottom, the 
front become the back, etc.).

Figure 19.13   Modify Axes window
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The Show Motion Path Tool
This tool displays the path of motion for the selected object, as 
shown in Figure 19.14. No path is shown if the object has no 
keyframes, or has not changed position at all.

Figure 19.14   Motion path visible in a World View window

Motion path

Keyframes
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The Hide Motion Path Tool
This tool hides the selected object’s path of motion (assuming its 
path is visible).

w
To show the motion path for a select object, use the Show Motion Path 
tool (page 19-17).
19-18 ElectricImage™ Animation System



The Link to Parent Tool

Book  Page 19  Friday, July 21, 2000  4:18 PM
The Link to Parent Tool
This tool enables you to choose a new parent for the selected 
object(s). If many objects are selected, the new parent will apply to all 
the selected objects.

To link an object to a new parent object:

1. Select the object to be linked (the child object) in either a World 
View or the Project window.

2. Click the Link to Parent tool in the Tool Palette.

An instruction appears in the menu bar, as shown in Figure 19.15.

3. To complete the operation, click on the object to be the parent 
in either a World View or the Project window.

To cancel the operation, use the menu bar instruction as you 
would a menu and choose Terminate Operation, as shown in 
Figure 19.16.

w
To unlink an object from its parent object, refer to the section “The 
Unlink from Parent Tool” (page 19-20).

Figure 19.15   Instruction in menu bar

Figure 19.16   Canceling the operation
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The Unlink from Parent Tool
This tool removes parentage from all selected objects.

w
To link an object to a parent object, refer to the section “The Link to 
Parent Tool” (page 19-19).
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The Look at Object Tool
This tool forces the selected object to look at another object.

• If the selected object is the camera or a light, its reference point 
will be locked to the object it is looking at.

• If the selected object is a group, its rotation will be affected by the 
object it is looking at.

w
Use of this tool will generate custom frames for the selected object’s 
reference (or rotation) channel.

To force an object to look at another object:

1. Select the object to be forced, in either a World View or the 
Project window.

w
An object can be forced to look at another object at any time in 
the animation, and for any range of frames.

2. To apply the command at a specific time, set the Project window 
to Time mode and move the time selector to the time at which 
the command is to start.

To apply the command for a range of frames, set the Project 
window to Keyframe or Frame mode and select the range of 
frames to be affected.

3. Click the Look at Object tool in the Tool Palette.

An instruction appears in the menu bar, as shown in Figure 19.17.

4. To complete the operation, click on the object to be looked at, in 
either a World View or the Project window.

To cancel the operation, use the menu bar instruction as you 
would a menu and choose Terminate Operation, as shown in 
Figure 19.18.

Figure 19.17   Instruction in menu bar
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w
To remove the Look at Object function, refer to the section “The Cancel 
Look at Tool” (page 19-23).

Figure 19.18   Canceling the operation
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The Cancel Look at Tool
This tool removes the Look at Object function (page 19-21) from the 
selected object (but does not recalculate custom frames).

w
To force an object to look at another object, refer to the section “The 
Look at Object Tool” (page 19-21).
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The Attach to Object Tool
This tool forces the selected object to maintain its position relative to 
the position of another object. As the other object changes position, 
the selected object will change position.

w
Use of this tool will generate custom frames for the selected object’s 
position and reference (or rotation) channels.

To attach an object to another object:

1. Select the object to be attached, in either a World View or the 
Project window.

w
An object can be attached to another object at any time in the 
animation, and for any range of frames.

2. To apply the command at a specific time, set the Project window 
to Time mode and move the time selector to the time at which 
the command is to start.

To apply the command for a range of frames, set the Project 
window to Keyframe or Frame mode and select the range of 
frames to be affected.

3. Click the Attach to Object tool in the Tool Palette.

An instruction appears in the menu bar, as shown in Figure 19.19.

4. To complete the operation, click on the object to attach to, in 
either a World View or the Project window.

To cancel the operation, use the menu bar instruction as you 
would a menu and choose Terminate Operation, as shown in 
Figure 19.20 (page 19-25).

Figure 19.19   Instruction in menu bar
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w
To remove the Attach to Object function, refer to the section “The 
Detach from Object Tool” (page 19-26).

Figure 19.20   Canceling the operation
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The Detach from Object Tool
This tool removes the Attach to Object function (page 19-24) from 
the selected object (but does not recalculate custom frames).

w
To attach an object to another object, refer to the section “The Attach 
to Object Tool” (page 19-24).
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The Auto Rotate Object Tool
This tool forces a moving object to follow the line of its motion path, 
rotating on its local axes and always “looking” in the direction of the 
path.

w
Use of this tool will generate custom frames for the selected object’s 
rotation channels.

To automatically rotate an object on its motion path:

1. Select the object to be automatically rotated, in either a World 
View or the Project window.

w
An object can be automatically rotated at any time in the 
animation, and for any range of frames.

2. To apply the command at a specific time, set the Project window 
to Time mode and move the time selector to the time at which 
the command is to start.

To apply the command for a range of frames, set the Project 
window to Keyframe or Frame mode and select the range of 
frames to be affected.

3. Click the Auto Rotate Object tool in the Tool Palette.

If the Auto Rotate sequence is for the camera or a light, you can 
override the length of the object’s reference vector.

To modify the reference vector:

1. Set the Project window to Keyframe mode and double-click on a 
cell in the Auto-Rotate channel, as shown in Figure 19.21.

w
Auto rotation sequences are numbered (AR #1, AR #2, etc.), 
permitting multiple auto rotation sequences for an object during 
the course of the animation.
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A dialog box, as shown in Figure 19.22, opens.

2. Enter a value in the Reference Length edit box. The value 
corresponds to the scale of the rulers in the World View 
windows.

w
To cancel the Auto Rotate function, refer to the section “The Cancel 
Auto Rotate Tool” (page 19-29)

Figure 19.21   Auto-Rotate channel in the Project window

Figure 19.22   Dialog box used to set auto rotation options
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The Cancel Auto Rotate Tool
This tool removes the Auto Rotate function from the selected object 
(but does not recalculate custom frames).

w
To use the Auto Rotate function, refer to the section “The Auto Rotate 
Object Tool” (page 19-27)
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Overview
The Object palette is used to perform such tasks as adding models, 
sounds and lights to the project. It is a “floating palette;” that is, it 
floats above the other windows, as long as it is visible.

w
The tools in the Object Palette parallel the Add > commands in the File 
menu, as discussed in Chapter 1: The File Menu Commands.

When initially opened, the Object Palette is configured in a 
horizontal display, as shown in Figure 20.1.

w
When object plug-ins are stored in the EI Sockets folder, they are also 
accessible from the Object Palette. This chapter documents only the 
ElectricImage plug-ins (whose icons are visible in the bottom row of the 
palette in Figure 20.1). If you add another developer’s plug-ins to the EI 
Sockets folder, refer to that developer’s documentation for the use of 
those plug-ins.

Figure 20.1   Object Palette in horizontal display

Close palette Flip palette Hide palette
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Opening and Configuring the Palette

To open the Object palette, choose Object Palette from the Windows 
menu, as discussed in the section “Object Palette” (page 3-4) in 
Chapter 3: The Windows Menu Commands.

To change the orientation of the palette from horizontal to vertical, 
click the flip palette button, located in the upper right of the drag bar, 
as shown in Figure 20.1.

To hide the palette, click the hide palette button, located in the upper 
right of the drag bar, as shown in Figure 20.1.

To close the palette, click in the palette’s close box, located in the 
upper left of the drag bar, or choose Object Palette from the 
Windows menu again.
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The Add Model Tool
This tool is used to add a FACT format model to the current project. 
Clicking it is equivalent to choosing Add > Model… in the File 
menu. For information on how to use this command, refer to the 
section “Add > Model…” (page 1-12) in Chapter 1: The File Menu 
Commands.

w
This tool will not work for models that are not in the FACT format. To 
add a non-FACT-format model to the current project, use the Import 
Model tool (page 20-5) which will convert the model to FACT format 
and then add it to the project.

The Add Light Tool
This tool is used to add a light to the current project. Clicking it is 
equivalent to choosing Add > Light… in the File menu. For 
information on how to use this command, refer to the section “Add > 
Light…” (page 1-16) in Chapter 1: The File Menu Commands.

The Add Sound Tool
This tool is used to add a sound file to the current project. Clicking it 
is equivalent to choosing Add > Sound… in the File menu. For 
information on how to use this command, refer to the section “Add > 
Sound…” (page 1-14) in Chapter 1: The File Menu Commands.
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The Record Sound Tool
This tool is used to record a sound and add it to the current project. 
Clicking it is equivalent to choosing Add > Record Sound… in the 
File menu. For information on how to use this command, refer to the 
section “Add > Record Sound…” (page 1-15) in Chapter 1: The File 
Menu Commands.

The Add Font Tool
This tool is used to create a font model and add it to the current 
project. Clicking it is equivalent to choosing Add > Font… in the File 
menu. For information on how to use this command, refer to the 
section “Add > Font…” (page 1-17) in Chapter 1: The File Menu 
Commands.

The Import Model Tool
This tool is used to import a non-FACT format model into the current 
project, converting the file to the FACT format required by 
ElectricImage. Clicking it is equivalent to choosing Add > Import… 
in the File menu. For information on how to use this command, refer 
to the section “Add > Import…” (page 1-22) in Chapter 1: The File 
Menu Commands.

w
If the model you wish to add to the project is already in the FACT 
format, you do not need to use this tool. Instead, use the Add Model 
tool, discussed above.
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The Mesh Generator
This tool adds the Mesh Generator to the project. The Mesh 
Generator is used to animate various shape transformations, 
primarily a plane into a sphere (or vice versa).

w
This icon will only appear in the Object Palette if the Mesh Generator 
plug-in is stored in the EI Sockets folder.

To add the Mesh Generator to the project:

1. Click the Mesh Generator icon in the Object Palette.

A dialog box, as shown in Figure 20.2, opens.

2. Use the controls of the dialog box to configure the mesh to your 
preferences. For an explanation of these controls, refer to the 
section “Mesh Generator Controls” (page 20-7).

3. Either click OK or press Return.

Figure 20.2   Mesh Generator dialog box
20-6 ElectricImage™ Animation System



The Mesh Generator

Book  Page 7  Friday, July 21, 2000  4:18 PM
Mesh Generator Controls

Mesh Type This pop-up menu provides a choice of five different animated mesh 
objects. The menu choices are:

Flat

This option creates a flat, two-dimensional mesh grid.

Sine Wave

This option creates a mesh object containing animated circular 
waves.

Breathing Cylinder

This option creates a cylinder that expands and contracts as if 
breathing.

Screw Thread

This option creates an object that simulates a screw thread which 
reverses its threads inwards and outwards over time.

Sphere Wrap

This option (the default) creates an object that transforms itself from 
a plane into a sphere (and back again).

U Points This edit box contains a value for the number of horizontal grid 
segments.

V Points This edit box contains a value for the number of vertical grid 
segments.

Loop Time This edit box contains a value in seconds for the amount of time it 
will take for one complete transformation. In the case of a Sphere 
Wrap, for example, the loop time would be the amount of time it will 
take for the plane to transform into a sphere (before transforming 
back into a plane).
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X, Y and Z Scale These edit boxes contain values for the scale of the object along the 
X, Y and Z axes. For a Sine Wave object, you can use the Y Scale value 
to control the height of the waves.

w
Once the object is added to the project, this dialog box can be reopened 
to modify your preferences. To do so, open the Group Info window for 
the object and click the Options… button.
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Mr. Nitro™
This tool adds the Mr. Nitro™ special effect to the project. 
Mr. Nitro™ is used to animate realistic explosions of models.

w
This icon will only appear in the Object Palette if the Mr. Nitro™ 
plug-in is stored in the EI Sockets folder.

To add the Mr. Nitro™ special effect to the project:

1. Click the Mr. Nitro™ icon in the Object Palette.

A dialog box, as shown in Figure 20.3, opens.

2. Use the controls of the dialog box to configure the blast to your 
preferences. For an explanation of these controls, refer to the 
section “Mr. Nitro™ Controls” (page 20-10).

3. Either click OK or press Return.

The Mr. Nitro™ effect is added to the project as an object.

4. Link the group(s) to be exploded to the Mr. Nitro™ object. For 
an explanation of how to link groups, refer to the section “The 
Link to Parent Tool” (page 19-19) in Chapter 19: The Tool Palette.

Figure 20.3   Mr. Nitro™ dialog box
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Mr. Nitro™ Controls

Ground Zero These edit boxes contain values for the X, Y and Z coordinates of the 
blast’s origin, or “ground zero.” This is the point from which the 
shock wave of the blast originates, emanating in all directions. By 
positioning ground zero farther away from the group(s) to be 
exploded, you can create more of a “wall-shaped” shockwave.

w
To position and configure the blast to your requirements, you should 
first check the coordinates and size of the group(s) to be blasted in their 
respective Group Info windows. You can then set Mr. Nitro’s values 
accordingly.

Gravity Direction
& Force

These edit boxes contain values for the direction and force of gravity 
which will affect the manner and speed in which the blast fragments 
fall. The ± edit boxes enable you to impart a variability to each value 
so that some fragments are more affected by gravity than others.

Blast Time This edit box contains a value for the time in the project at which the 
shock wave will commence. A negative value will result in the shock 
wave originating prior to the start of the animation.

You will need to use a negative blast time value when ground zero is 
far away from the group(s) to be exploded—otherwise the moment of 
impact will occur long into the animation. For the blast to occur in 
the first frame of the animation, blast time should be set according to 
the following formula:

Blast Time = - distance from Ground Zero to group ÷ Speed

For example, if ground zero is a distance of 1000 from the group and 
the blast speed (see Speed edit box, below) is 10, blast time would be 
-1000 ÷ 10, or -100 seconds.

Ground Level This edit box contains a value for the Y axis coordinate of an invisible 
ground plane below which blast fragments disappear as they fall.

Air Resistance This edit box contains a value for the amount of air resistance which 
will affect the manner in which the blast fragments fall. The higher 
the value, the more air resistance slowing the fragments.
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Dissolve This edit box contains a value for the amount of time in seconds for 
blast fragments to dissolve after being hit by the shockwave. A value 
of 0 (the default) prevents fragments from dissolving.

Outer Blast These edit boxes control the speed, rotation, turbulence and force of 
the initial shockwave of the blast. An explosion can have two 
shockwaves, the outer blast (first) and the inner blast (second).

% This edit box contains the percentage value for the outer blast (initial 
shockwave). It defaults to 100, so that there is only the outer blast. To 
create two shockwaves, assign a value less than 100% to the outer 
blast and the Inner Blast % edit box will be adjusted accordingly (so 
that they add up to 100%).

Speed This edit box contains a value for the speed (distance per second) of 
the shockwave. When used in conjunction with the Blast Time value 
(page 20-10), this value can control the moment when the 
shockwave hits the group(s).

Rotation This edit box contains a value in degrees for the maximum amount 
of rotation of the flying blast fragments. Fragments rotate around 
random axes.

Turbulence This edit box contains a value for the amount of air turbulence which 
will affect the manner in which the blast fragments rotate. With a 
value of zero, fragments rotate around their centers. A value other 
than zero will cause fragments to rotate off-axis.

Force This edit box contains a value for the force of the shockwave. The 
greater the force, the faster the fragment will move in the direction of 
the shockwave. A force of 1.0 will cause fragments to move at the 
same speed as the shockwave. The ± edit boxes enable you to impart 
a variability to the value so that some fragments fly faster than 
others.

Fragment Size These edit boxes contain size values for the smallest and largest blast 
fragments, relative to the size of the exploding group. To have all 
fragments of approximately the same size, enter the same value in 
both the Smallest and Largest edit boxes.
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w
Setting a minimum size value that is too small will generate a very 
large number of fragments, which will take too long to generate and 
may also cause you to run out of memory. As a starting point for the 
minimum size, try using a value that is 1/10 the longest dimension of 
the group; for the maximum size, use a value that is twice the 
minimum size.

Fragment Shape These edit boxes contain values for the percentage of fragments that 
are to be triangles versus quadrangles. The default is 50% for each. 
Changing one value will adjust the other value accordingly (to add 
up to 100%).

Fragment Color This check box, when enabled, allows you to assign a color to the 
blast fragments, overriding the surface color setting of the group. The 
color of the blast fragments can be animated over time through the 
use of the Age Color buttons, discussed below.

Age Color These buttons invoke the Apple Color Picker to enable you to set 
different colors for the blast fragments at different stages of the blast. 
The age values are all in seconds and can be edited.You can change 
the color of the fragments before they are hit by the shockwave by 
setting the first age value to less than zero.

w
Once the Mr. Nitro object is added to the project, this dialog box can be 
reopened to modify your preferences. To do so, open the Group Info 
window for the Mr. Nitro object and click the Options… button.
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The Particle Generator
This tool adds the Particle Generator to the project. The Particle 
Generator is used to animate special effects such as sparks, jets of fire, 
and fountains or streams of water.

w
This icon will only appear in the Object Palette if the Particle 
Generator plug-in is stored in the EI Sockets folder.

To add the Particle Generator to the project:

1. Click the Particle Generator icon in the Object Palette.

A dialog box, as shown in Figure 20.4, opens.

2. Use the controls of the dialog box to configure the particle 
stream to your preferences. For an explanation of these controls, 
refer to the section “Particle Generator Controls” (page 20-14).

3. Either click OK or press Return.

Figure 20.4   Particle Generator dialog box
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Particle Generator Controls

Maximum Particles This edit box contains a value for the maximum number of particles 
in existence at any particular time during the effect.

New Particles
Per Second

This edit box contains a value for the number of new particles to be 
created each second for the duration of the effect. The ± edit box 
enables you to impart a variability to the value so that the number of 
new particles generated each second will vary.

Particle Life Time This edit box contains a value in seconds for the duration of time a 
particle can exist before disappearing. The ± edit box enables you to 
impart a variability to the value so that some particles will last longer 
than others.

Create Particles
From Time

These edit boxes contain values for the start and end times of the 
animation during which particles will be generated.

X Position and
Direction

The Position edit box contains a value for the X coordinate position 
of the emission point (the point from which particles are emitted). 
The ± edit box enables you to impart a variability to the coordinate 
value so that particles are emitted at varying positions to the right 
and left of the X Position coordinate.

The Direction edit box contains a value for the X component of the 
particles’ initial direction vector. The default direction for particles is 
along the Y axis (like a fountain), hence the default value for the X 
direction is zero.

Y Position and
Direction

The Position edit box contains a value for the Y coordinate position 
of the emission point (the point from which particles are emitted). 
The ± edit box enables you to impart a variability to the coordinate 
value so that particles are emitted at varying positions above and 
below the Y Position coordinate.

The Direction edit box contains a value for the Y component of the 
particles’ initial direction vector. The default direction for particles is 
along the Y axis (like a fountain), hence the default value for the Y 
direction is 1.
20-14 ElectricImage™ Animation System



The Particle Generator

Book  Page 15  Friday, July 21, 2000  4:18 PM
Z Position and
Direction

The Position edit box contains a value for the Z coordinate position 
of the emission point (the point from which particles are emitted). 
The ± edit box enables you to impart a variability to the coordinate 
value so that particles are emitted at varying positions in front of and 
behind the Z Position coordinate.

The Direction edit box contains a value for the Z component of the 
particles’ initial direction vector. The default direction for particles is 
along the Y axis (like a fountain), hence the default value for the Z 
direction is zero.

Deviation Angle This edit box contains a value in degrees for the angle at which 
particles can deviate from their initial direction vector. The ± edit box 
enables you to impart a variability to the deviation value so that 
some particles will deviate more than others.

Velocity This edit box contains a value for the speed at which particles will be 
emitted from the generation point. The ± edit box enables you to 
impart a variability to the speed so that some particles will travel 
faster than others.

Gravity These edit boxes contain values for the direction and force of gravity 
which will affect the manner and speed in which the particles fall. 
The ± edit boxes enable you to impart a variability to each value so 
that some particles are more affected by gravity than others. A 
negative gravity value for the Y axis (the default) causes the particles 
to fall downward (as in a fountain).

Y Ground Level This edit box contains a value for the Y axis coordinate of an invisible 
ground plane upon which the fragments land or bounce.

Bounce Factor This edit box contains a value for the amount of bounce given to 
particles. A value of zero prevents particles from bouncing—they 
land and stick to the ground plane. Values less than one cause 
particles to bounce with ever-decreasing height. Values greater than 
one cause particles to bounce with ever-increasing height.

Air Resistance This edit box contains a value for the amount of air resistance which 
will affect the manner in which the particles fall. The higher the 
value, the more air resistance slowing the particles.
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Bounce Friction This edit box contains a value for the amount of friction which will 
affect the distance over which particles bounce. The higher the value, 
the more friction to reduce the distance of each bounce.

Energy These three color buttons enable you to animate the color of particles 
over time, from the higher energy level at the start of a particle’s life 
(1.0) to the midpoint of its life (0.5) to its end (0.0). Clicking a button 
opens the Apple Color Picker.

w
Once the particle generator object is added to the project, this dialog 
box can be reopened to modify your preferences. To do so, open the 
Group Info window for the object and click the Options… button.
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Standard Shapes
This tool adds a standard shape (or primitive) to the project. Standard 
shapes include planes, cubes, cylinders, cones and spheres.

w
This icon will only appear in the File menu if the Standard Shapes 
plug-in is stored in the EI Sockets folder.

To add a standard shape to the project:

1. Click the Standard Shapes icon in the Object Palette.

A dialog box, as shown in Figure 20.5, opens.

2. Use the controls of the dialog box to configure the shape to your 
preferences. For an explanation of these controls, refer to the 
section “Standard Shapes Controls” (page 20-18).

3. Either click OK or press Return.

w
Once a standard shape is added to the project, its form can be bent, 
tapered, stretched, bulged, rippled and otherwise deformed through the 
use of the Group Deformations window. For information, refer to 
Chapter 16: The Group Deformation Window.

Figure 20.5   Standard Shapes dialog box
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Standard Shapes Controls

Shapes These radio buttons provide a choice of five standard shapes:

• Plane

• Cube

• Cylinder

• Cone

• Sphere

Click the button for the type of shape you wish to create.

Color This button is used to set the color of the object. Clicking it opens the 
Apple Color Picker.

Orientation These radio buttons, for planes only, provide a choice of how the 
plane is to be oriented in 3-D space. The choices are:

• XY (oriented along the X and Y axes)

• YZ (oriented along the Y and Z axes)

• XZ (the default) oriented along the X and Z axes)

Dimensions These edit boxes are case sensitive, changing according to the type of 
shape selected. They contain values for the dimensions of the object 
according to the current scale of the project.

Divisions These edit boxes are case sensitive, changing according to the type of 
shape selected. They contain values that refer to the number of 
divisions in a mesh to be generated for each face of the object 
(effectively breaking each face into a number of polygons). If you 
plan to deform the object, it is necessary to create it with at least the 
default number of divisions.

w
Once the object is added to the project, this dialog box can be reopened 
to modify your preferences. To do so, open the Group Info window for 
the object and click the Options… button.
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Overview
The Location Palette indicates the cursor’s global coordinates as it is 
moved within any of the World View windows, as shown in 
Figure 21.1. It is a “floating palette;” that is, it floats above the other 
windows, as long as it is visible.

Opening and Configuring the Palette

To open the Location Palette, choose Location Palette from the 
Windows menu, as discussed in the section “Location Palette” 
(page 3-3) in Chapter 3: The Windows Menu Commands.

To hide the palette, click the hide palette button, located in the upper 
right of the drag bar, as shown in Figure 21.1.

To close the palette, click in the palette’s close box, located in the 
upper left of the drag bar, or choose Location Palette from the 
Windows menu again.

Figure 21.1   Location Palette indicating cursor’s position in the Top View window

Close palette Hide palette
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Overview
The Camera application is the rendering engine of the ElectricImage 
Animation System, and it is automatically launched when an 
ElectricImage project is rendered.

All four windows in the Camera interface default to open when 
Camera is launched, as shown in Figure 22.1.

The Windows menu can then be used to close and re-open the four 
windows, together or individually.

Figure 22.1   Camera interface

Information window (page 22-5)

Status window (page 22-10)

Frame window (page 22-11)

Monitor window (page 22-9)
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The File Menu Commands
The File menu is used to pause/continue and quit rendering. If these 
options are not utilized during processing, the project will render 
until completion, the Camera application will close and the Projector 
application will be launched. The commands are:

Pause This command temporarily suspends processing. To restart the 
rendering, select Continue from the File menu.

Continue This command causes processing to resume after Pause had been 
selected from the File menu.

Quit This command cancels processing and re-launches the ElectricImage 
application (a dialog box reminds you that rendering was not 
completed and gives you the opportunity to not quit and resume 
rendering).
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The Windows Menu Commands
The Windows menu is used to hide or show the four windows of the 
Camera application. The commands are:

Hide All Windows This command hides all currently open windows.

w
Hiding the windows can reduce rendering time since the processor does 
not need to update information in the windows while it is also 
rendering.

Show All Windows This command opens all four of the Camera windows.

Information This command toggles the display of the Information window, 
described in the section “The Information Window” (page 22-5).

Monitor This command toggles the display of the Monitor window, described 
in the section “The Monitor Window” (page 22-9).

Status This command toggles the display of the Status window, described in 
the section “The Status Window” (page 22-10).

Frame This command toggles the display of the Frame window, described in 
the section “The Frame Window” (page 22-11).
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The Information Window
The Information window displays descriptive data for the project 
being rendered, as shown in Figure 22.2.

Figure 22.3 (page 22-6) is a table of definitions for the data displayed 
in the upper half of the window.

Figure 22.4 (page 22-7) is a table of definitions for the data displayed 
in the lower half of the window.

Figure 22.2   The Information window
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Figure 22.3   Table of Information window data (upper half of window) 

Label Description

Volume The volume name where the output Image file is being written.

File Name The file name of the output Image file.

Estimated
Animation
Time

An estimate of the rendering time for the animation. The completion time can vary 
significantly during the progress of an animation and should be considered a rough 
approximation.

Previous The time required to render the previous frame of the animation.

Difference The difference in rendering times between the previous two frames.

Average The average time per frame for the completed frames of the animation.

Total The estimated total rendering time for this animation.

Remaining The estimated time required to complete the remaining frames of the animation.

Completion The estimated time of completion of the rest of the frames in the animation.

Estimated
Animation
Size

An estimate of the disk space required to store the animation. The total size can vary 
significantly during the progress of an animation and should be considered a rough 
approximation.

Previous The size in bytes of the previous rendered frame.

Difference The size difference in bytes between the previous two rendered frames.

Average The average size in bytes of all rendered frames.

Total The estimated total file size for this animation.

Remaining The estimated size in bytes of remaining frames of the animation.

Free The free disk space on the volume where the animation is being written. If the free 
disk space falls below the estimated remaining animation size, a warning will appear 
in the top right corner of the window.
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Figure 22.4   Table of Information window data (lower half of window) 

Label Description

Max Memory The total memory available for rendering.

Free Memory The free heap space available after the rendering memory has been allocated. This 
value should never fall below 32KB.

Image Resolution The horizontal/vertical pixel resolution of the current frame.

Pixel H/V Ratio The horizontal/vertical pixel aspect ratio of the current frame.

Anti Aliasing The anti-aliasing quality of the current frame. This can be none, averaged or 
oversampled.

Field Interlace Field interlace status. This can be off, fast or super.

Image Type The color depth of the current frame. This can be black and white, gray scale, 256 
colors and true color (millions of colors).

Rendering Level The maximum rendering level for the current frame. This can be wireframe, flat, 
Gouraud or Phong.

Background Description of the current frame’s background. This can be a color or an Image file.

Perspective Shows whether perspective is turned on or off for the current frame.

Ambient The scene ambient value for the current frame.

Fog/Depth Cue Fog or depth cue status. This can be off, to color, to background or to alpha.

Color Blending The total number of color blended groups in the current frame. Disabled indicates 
that color blending has been disabled.

Super Sampling The total number of super sampled groups in the current frame. Disabled indicates 
that super sampling has been disabled.

Transparencies The number of groups in the current frame containing filter transparencies. 
“Disabled” indicates that filter transparencies have been disabled.

Shadows The number of shadow casting light sources in the current frame. “Disabled” 
indicates that shadows have been disabled.

Textures The total number of texture and bump maps in the current frame. Disabled 
indicates that texture mapping has been disabled and no texture maps or bump 
maps will be rendered.

Reflections The total number of reflection and environment maps in the current frame. 
Disabled indicates that reflection mapping has been disabled and no reflection 
maps or environment maps will be rendered.
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Lights The total number of light sources in the current frame.

Groups The total number of groups in the current frame.

Coordinates The total number of vertex coordinates in the current frame.

Elements The total number of points, lines, triangles and quadrangles in the current frame.

Points The total number of points in the current frame.

Lines The total number of lines in the current frame.

Triangles The total number of triangles in the current frame.

Quadrangles The total number of quadrangles in the current frame.

Complex The total number of complex polygons (polygons containing more than four sides) 
in the current frame.

Inactive Groups The number of invisible groups in the current frame.

Bent Facets The number of quadrangles which were broken into two triangles for rendering 
because they were not flat.

Purged Facets The number of points, lines, triangles and quadrangles which were purged because 
they were behind the camera.

XY Clipped Facets The total number of points, lines, triangles and quadrangles which are completely 
outside the edges of the current frame.

Z Clipped Facets The number of lines, triangles or quadrangles which lay partially behind the 
camera.

Added Coords The number of additional vertex coordinates which were generated whenever a 
line, triangle or quadrangle lay partially behind the camera.

Added Facets The number of triangles which were generated whenever a quadrangle was broken 
into two parts because it lay partially behind the camera or because it was not flat.

Active Coords The total number of active vertex coordinates which are to be used to render the 
current frame.

Active Facets The total number of active points, lines, triangles and quadrangles which are to be 
used to render the current frame.

Figure 22.4   Table of Information window data (lower half of window) (continued)

Label Description
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The Monitor Window
The Monitor window shows the image as it is being rendered, as 
shown in Figure 22.5.

w
The image in the window is not saved when the window is obscured or 
hidden (to conserve memory and speed rendering time). When 
subsequently made visible or uncovered, the window will display black 
until the next frame or part of a frame is completed.

Figure 22.5   The Monitor window
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The Status Window
The Status window shows, in a graphic display, the status of the 
current rendering operation, as shown in Figure 22.6.

The rendering operations displayed include:

• Reading (Facets, Coordinates, Polygons, etc.)

• Hiding Surfaces

• Shading Surfaces

• Sampling Pixels

• Storing Image

• Computing Motion Blur

• Expanding Motion Blur

• Drawing Motion Blur

• Converting Motion Blur

• Writing Image

• Converting Image (to 256 colors)

Figure 22.6   The Status window
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The Frame Window
The Frame window shows, in a graphic display, the progress of the 
animation processing in frames, as shown in Figure 22.7.

• The number in the upper right corner of the window is the 
number of the frame currently being rendered.

• The number in the lower left corner of the window is the first 
frame number of the animation.

• The number in the lower right corner of the window is the last 
frame number of the animation.

Figure 22.7   The Frame window
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Listing of Camera Data Channels
This appendix lists the data channels available for the camera, as they 
appear in the Project Window. For information on the Project 
window and its use, refer to Chapter 8: The Project Window.

w
Values for camera attributes can also be displayed and set in the 
Camera Info window, as described in Chapter 10: The Camera Info 
Window, and in the Camera Velocity window, as described in 
Chapter 17: The Velocity Windows.

Attach This channel contains the name of the object, for a given frame, to which the camera is 
attached (if any).

The camera is attached to other objects with the Attach to Object tool, discussed in the section 
“The Attach to Object Tool” (page 19-24) in Chapter 19: The Tool Palette

Track This channel contains, for a given frame, the name of the object at which the camera is forced 
to look (if any).

The camera is forced to look at other objects with the Look at Object tool, discussed in the 
section “The Look at Object Tool” (page 19-21) in Chapter 19: The Tool Palette.

Auto-Rotate This channel contains the name of the camera’s auto rotation sequence in effect (if any) for a 
given frame.

Auto rotation is set with the Auto Rotate Object tool, discussed in the section “The Attach to 
Object Tool” (page 19-24) in Chapter 19: The Tool Palette.

Visibility This channel indicates whether or not the camera will be visible for a given frame. You can 
control the visibility on a frame by frame basis.

This function actually has no effect when rendering an animation because the camera is 
recording the scene. It does, however, affect all other object classes (i.e., groups, lights).
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Position These channels contain the following values for the camera’s position:

Motion Path A pop-up menu provides a choice of four types of motion path spline:

Linear These are not actually splines, but rather simple lines, resulting in 
a very mechanical (sometimes awkward) motion.

Natural 
Cubic

These splines give a fluid motion, but have limited precision since 
editing one keyframe along the spline will change the whole 
curvature of the spline.

Hermite These splines also give a fluid motion, but are more versatile and 
precise than natural cubic splines because editing one keyframe 
along the spline will not change the whole curvature of the 
spline. The following values are available for editing:

Hermite 
Tension

This value determines the tautness (tension) of the 
segment between keyframes.

Hermite 
Bias

This value determines how much the segment leans 
(is biased) toward one end or the other.

Hermite 
Continuity

This value determines the smoothness (continuity) 
of the connection between the path and its 
endpoints.

Bezier These splines are the same splines used by popular Macintosh 
drawing programs such as Aldus Freehand®, Adobe Illustrator® 
and Canvas™, however ElectricImage Bezier splines are 
3-dimensional.

Velocity The relative velocity of the camera’s position. The value is equivalent to the 
height of the teeter bar in the Camera Velocity window, described in the 
section “Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the camera’s position. The value is equivalent to the bias of 
the speed curve in the Camera Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

X The camera position’s X coordinate.

Y The camera position’s Y coordinate.

Z The camera position’s Z coordinate.
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Reference These channels contain the following values for the camera’s reference point:

Motion Path A pop-up menu provides a choice of four types of motion path spline:

Linear See “Linear” on page -3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page -3 for an explanation.

Hermite See “Hermite” on page -3 for an explanation.

Bezier See “Bezier” on page -3 for an explanation.

Velocity The relative velocity of the camera’s reference point. The value is equivalent to 
the height of the teeter bar in the Camera Velocity window, described in the 
section “Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the camera’s reference point. The value is equivalent to the 
bias of the speed curve in the Camera Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

X The camera reference point’s X coordinate.

Y The camera reference point’s Y coordinate.

Z The camera reference point’s Z coordinate.

Roll (Z) These channels contain the following values for the camera’s roll angle (Z axis rotation):

Motion Path A pop-up menu provides a choice of three types of motion path spline:

Linear See “Linear” on page -3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page -3 for an explanation.

Hermite See “Hermite” on page -3 for an explanation.

Velocity The relative velocity of the camera’s roll. The value is equivalent to the height of 
the teeter bar in the Camera Velocity window, described in the section “Graph 
Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the camera’s roll. The value is equivalent to the bias of the 
speed curve in the Camera Velocity window, described in the section “Graph 
Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Data The camera’s angle of roll (Z axis rotation) in degrees.

Focal Length A value for the camera lens’ focal length.
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Listing of Light Data Channels
This appendix lists the data channels available for lights in the 
project, as they appear in the Project Window. For information on 
the Project window and its use, refer to Chapter 8: The Project Window.

w
Values for light attributes can also be set in the Light Info window, as 
described in Chapter 11: The Light Info Window, and the Light Velocity 
window, as described in Chapter 17: The Velocity Windows.

Attach This channel contains the name of the object, for a given frame, to which the light is attached 
(if any).

Lights are attached to other objects with the Attach to Object tool, discussed in the section 
“The Attach to Object Tool” (page 19-24) in Chapter 19: The Tool Palette.

Track This channel contains, for a given frame, the name of the object at which the light is forced to 
look (if any).

Lights are forced to look at other objects with the Look at Object tool, discussed in the section 
“The Look at Object Tool” (page 19-21) in Chapter 19: The Tool Palette.

Auto-Rotate This channel contains the name of the light’s auto rotation sequence in effect (if any) for a given 
frame.

Auto rotation is set with the Auto Rotate Object tool, discussed in the section “The Attach to 
Object Tool” (page 19-24) in Chapter 19: The Tool Palette.

Visibility This channel indicates whether or not the light will be visible for a given frame. You can control 
the visibility on a frame by frame basis, as discussed in the section “The Object Status Panel” 
(page 8-17) in Chapter 8: The Project Window.
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Position These channels contain the following values for the light’s position:

Motion Path A pop-up menu provides a choice of four types of motion path spline:

Linear These are not actually splines, but rather simple lines, resulting in 
a very mechanical (sometimes awkward) motion.

Natural 
Cubic

These splines give a fluid motion, but have limited precision since 
editing one keyframe along the spline will change the whole 
curvature of the spline.

Hermite These splines also give a fluid motion, but are more versatile and 
precise than natural cubic splines because editing one keyframe 
along the spline will not change the whole curvature of the spline. 
The following values are available for editing:

Hermite 
Tension

This value determines the tautness (tension) of the 
segment between keyframes.

Hermite 
Bias

This value determines how much the segment leans 
(is biased) toward one end or the other.

Hermite 
Continuity

This value determines the smoothness (continuity) 
of the connection between the path and its 
endpoints.

Bezier These splines are the same splines used by popular Macintosh 
drawing programs such as Aldus Freehand®, Adobe Illustrator® 
and Canvas™, however ElectricImage Bezier splines are 
3-dimensional.

Velocity The relative velocity of the light’s position. The value is equivalent to the height 
of the teeter bar in the Light Velocity window, described in the section “Graph 
Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the light’s position. The value is equivalent to the bias of the 
speed curve in the Light Velocity window, described in the section “Graph 
Elements” (page 17-6) in Chapter 17: The Velocity Windows.

X The light position’s X coordinate.

Y The light position’s Y coordinate.

Z The light position’s Z coordinate.
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Reference These channels contain the following values for the light’s reference point:

Motion Path A pop-up menu provides a choice of four types of motion path spline:

Linear See “Linear” on page B-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page B-3 for an explanation.

Hermite See “Hermite” on page B-3 for an explanation.

Bezier See “Bezier” on page B-3 for an explanation.

Velocity The relative velocity of the light’s reference point. The value is equivalent to the 
height of the teeter bar in the Light Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the light’s reference point. The value is equivalent to the 
bias of the speed curve in the Light Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

X The light reference point’s X coordinate.

Y The light reference point’s Y coordinate.

Z The light reference point’s Z coordinate.

Inside Angle 
(Spot mode)

This channel contains a value, in degrees, for the size of the angle within which is the area of full 
illumination from the spot. The area between the inner and outer angles is a transition between 
full illumination and none.

Outside 
Angle 
(Spot mode)

This channel contains a value, in degrees, for the size of the angle within which is the area of 
illumination from the spot. The area outside this angle will not be illuminated by the spot. The 
area between the outer and inner angles is a transition area between full illumination and none.

Dropoff 
Radius

This channel, for all light modes except Parallel and Ambient, contains a value for the distance 
at which the light’s illumination drops off.

Dropoff 
Factor

This channel contains a value for the rate at which the light’s illumination drops off from full 
illumination to none.

Intensity This channel contains a value for the light’s brightness. It is used to control the intensity of the 
light, especially useful when multiple lights are being used.

Color These channels contain the following values for the light’s color:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)
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Glow 
Outside 
Color

These channels contain the following values for the glow effect’s outside color:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Glow 
Inside Color

These channels contain the following values for the glow effect’s inside color:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Inside Glow 
Radius

This channel contains a value for the distance from the center of the glow to the outer edge of 
its opaque region, where the glow starts to transition from opacity to transparency.

Outside 
Glow Radius

This channel contains a value for the distance from the center of the glow to the outer edge of 
its transparent region, beyond which it is no longer visible.

Glow 
Exponential

This channel indicates the rate at which the glow effect transitions from opaque to transparent.

Fog Outside 
Color

These channels contain the following values for the fog effect’s outside color:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Fog Inside 
Color

These channels contain the following values for the fog effect’s inside color:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Inside 
Fog Radius

This channel contains a value for the distance from the center of the fog to the outer edge of its 
opaque region, where the fog starts to transition from opacity to transparency.

Outside Fog 
Radius

This channel contains a value for the distance from the center of the fog to the outer edge of its 
transparent region, beyond which it is no longer visible.

Fog 
Exponential

This channel indicates the rate at which the fog effect transitions from opaque to transparent.
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Shadow 
Buffer Size

This channel contains a value for the light’s shadow buffer resolution.

Shadow Gap This channel contains a value for the minimum distance between a surface casting a shadow 
and the point at which a shadow first appears.

Shadow 
Transition

This channel contains a value for the fade-in distance between a surface casting a shadow and 
the surface upon which the shadow appears.

Shadow 
Softness

This channel contains a value affecting how the shadow’s edge appears.

Shadow 
Smoothing

This channel contains a value for the softness of shadow edges when viewed up close.

Shadow 
Samples

This channel contains a value for the number of shadow samples per pixel.
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Listing of Group Data Channels
This appendix lists the data channels available for groups in the 
project, as they appear in the Project window. For information on the 
Project window and its use, refer to Chapter 8: The Project Window.

w
Values for group attributes can also be set in the Group Info window, as 
described in Chapter 13: The Group Info Window, the Surface Editor, 
as described in Chapter 18: The Surface Editor, the Group Deformation 
window, as described in Chapter 16: The Group Deformation Window, 
and the Model Velocity window, as described in the section “Model 
Velocity” (page 17-11) in Chapter 17: The Velocity Windows.

Attach This channel contains the name of the object, for a given frame, to which the group is attached 
(if any).

Groups are attached to other objects with the Attach to Object tool, discussed in the section 
“The Attach to Object Tool” (page 19-24) in Chapter 19: The Tool Palette.

Track This channel contains, for a given frame, the name of the object at which the group is forced to 
look (if any).

Groups are forced to look at other objects with the Look at Object tool, discussed in the section 
“The Look at Object Tool” (page 19-21) in Chapter 19: The Tool Palette.

Auto-Rotate This channel contains the name of the group’s auto rotation sequence in effect (if any) for a 
given frame.

Auto rotation is set with the Auto Rotate Object tool, discussed in the section “The Attach to 
Object Tool” (page 19-24) in Chapter 19: The Tool Palette.

Visibility This channel indicates whether or not the group will be visible for a given frame. You can 
control the visibility on a frame by frame basis, as discussed in the section “The Object Status 
Panel” (page 8-17) in Chapter 8: The Project Window.
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Position These channels contain the following values for the group’s position:

Motion Path A pop-up menu provides a choice of four types of motion path spline:

Linear These are not actually splines, but rather simple lines, resulting in 
a very mechanical (sometimes awkward) motion.

Natural 
Cubic

These splines give a fluid motion, but have limited precision since 
editing one keyframe along the spline will change the whole 
curvature of the spline.

Hermite These splines also give a fluid motion, but are more versatile and 
precise than natural cubic splines because editing one keyframe 
along the spline will not change the whole curvature of the 
spline. The following values are available for editing:

Hermite 
Tension

This value determines the tautness (tension) of the 
segment between keyframes.

Hermite 
Bias

This value determines how much the segment leans 
(is biased) toward one end or the other.

Hermite 
Continuity

This value determines the smoothness (continuity) 
of the connection between the path and its 
endpoints.

Bezier These splines are the same splines used by popular Macintosh 
drawing programs such as Aldus Freehand®, Adobe Illustrator® 
and Canvas™, however ElectricImage Bezier splines are 
3-dimensional.

Velocity The relative velocity of the group’s position. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s position. The value is equivalent to the bias of 
the speed curve in the Model Velocity window, described in the section “Graph 
Elements” (page 17-6) in Chapter 17: The Velocity Windows.

X The group position’s X coordinate.

Y The group position’s Y coordinate.

Z The group position’s Z coordinate.
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Center These channels contain the following values for the group’s center point:

Motion Path A pop-up menu provides a choice of four types of motion path spline:

Linear See “Linear” on page C-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page C-3 for an explanation.

Hermite See “Hermite” on page C-3 for an explanation.

Bezier See “Bezier” on page C-3 for an explanation.

Velocity The relative velocity of the group’s center point. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s center point. The value is equivalent to the bias 
of the speed curve in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

X The center point’s X coordinate.

Y The center point’s Y coordinate.

Z The center point’s Z coordinate.

X Rotation These channels contain the following values for the group’s X axis rotation:

Motion Path A pop-up menu provides a choice of three types of motion path spline:

Linear See “Linear” on page C-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page C-3 for an explanation.

Hermite See “Hermite” on page C-3 for an explanation.

Velocity The relative velocity of the group’s X axis rotation. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s X axis rotation. The value is equivalent to the 
bias of the speed curve in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Data The group’s angle of X axis rotation in degrees.
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Y Rotation These channels contain the following values for the group’s Y axis rotation:

Motion Path A pop-up menu provides a choice of three types of motion path spline:

Linear See “Linear” on page C-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page C-3 for an explanation.

Hermite See “Hermite” on page C-3 for an explanation.

Velocity The relative velocity of the group’s Y axis rotation. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s Y axis rotation. The value is equivalent to the 
bias of the speed curve in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Data The group’s angle of Y axis rotation in degrees.

Z Rotation These channels contain the following values for the group’s Z axis rotation:

Motion Path A pop-up menu provides a choice of three types of motion path spline:

Linear See “Linear” on page C-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page C-3 for an explanation.

Hermite See “Hermite” on page C-3 for an explanation.

Velocity The relative velocity of the group’s Z axis rotation. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s Z axis rotation. The value is equivalent to the 
bias of the speed curve in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Data The group’s angle of Z axis rotation in degrees.
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X Scale These channels contain the following values for the group’s X axis scale:

Motion Path A pop-up menu provides a choice of three types of motion path spline:

Linear See “Linear” on page C-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page C-3 for an explanation.

Hermite See “Hermite” on page C-3 for an explanation.

Velocity The relative velocity of the group’s X axis scale. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s X axis scale. The value is equivalent to the bias 
of the speed curve in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Data The group’s X axis scale value.

Y Scale These channels contain the following values for the group’s Y axis scale:

Motion Path A pop-up menu provides a choice of three types of motion path spline:

Linear See “Linear” on page C-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page C-3 for an explanation.

Hermite See “Hermite” on page C-3 for an explanation.

Velocity The relative velocity of the group’s Y axis scale. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s Y axis scale. The value is equivalent to the bias 
of the speed curve in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Data The group’s Y axis scale value.
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Z Scale These channels contain the following values for the group’s Z axis scale:

Motion Path A pop-up menu provides a choice of three types of motion path spline:

Linear See “Linear” on page C-3 for an explanation.

Natural 
Cubic

See “Natural Cubic” on page C-3 for an explanation.

Hermite See “Hermite” on page C-3 for an explanation.

Velocity The relative velocity of the group’s Z axis scale. The value is equivalent to the 
height of the teeter bar in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Acceleration The acceleration of the group’s Z axis scale. The value is equivalent to the bias 
of the speed curve in the Model Velocity window, described in the section 
“Graph Elements” (page 17-6) in Chapter 17: The Velocity Windows.

Data The group’s Z axis scale value.
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Color These channels contain color values for the group’s surface attributes, equivalent to the color 
settings made in the Surface Editor, as described in the section “Editor Controls” (page 18-5) in 
Chapter 18: The Surface Editor.

Surface These channels contain values for the group’s surface color:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Alpha 256 levels (0-255)

Diffuse These channels contain values for the color bias of the group’s diffuse value:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Ambient These channels contain values for the color bias of the group’s ambient value:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Specular These channels contain values for the color bias of the group’s specular value:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Alpha 256 levels (0-255)

Transparency These channels contain values for the color bias of the group’s transparency value:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Alpha 256 levels (0-255)
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Reflectivity These channels contain values for the color bias of the group’s reflectivity value:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Luminance These channels contain values for the color bias of the group’s luminance value:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Alpha 256 levels (0-255)

Edge These channels contain values for the color bias of the group’s edge density value:

Red 256 levels of red (0-255)

Green 256 levels of green (0-255)

Blue 256 levels of blue (0-255)

Alpha 256 levels (0-255)

Specular 
Index

This channel contains a value for the size of the group’s specular highlight.

Edge Index This channel contains a value for the rate of fall-off from transparency in the 
center of the group to opacity at its edges (when Edge Density is applied).

Terminator This channel contains a value for the rate of fall-off in illumination from the area 
of the group that is illuminated to the area that is not, thus affecting the size of 
the transition area.

Hilight 
Dropoff

This channel contains a value for the rate of fall-off from the specular highlight 
to its surrounding region, thus controlling the relative softness or hardness of 
the highlight.
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Deformation These channels contain values for the various deformation attributes, equivalent to the settings 
made in the Group Deformation window, as described in Chapter 16: The Group Deformation 
Window. These channels appear in the Project window only if a deformation has been defined 
for the group.

Region For each defined region (Region 1, Region 2, etc.), the following data channels 
are available:

Position These channels contain the following values for the deformation 
region’s position (relative to the center of the group):

Motion 
Path

A pop-up menu provides a choice of four types of 
motion path spline:

Linear See “Linear” on page C-3.

Natural 
Cubic

See “Natural Cubic” on page C-3.

Hermite See “Hermite” on page C-3.

Bezier See “Bezier” on page C-3.

Velocity The relative velocity of the deformation region’s 
position. The value is equivalent to the height of the 
teeter bar in the Model Velocity window, described 
in the section “Graph Elements” (page 17-6) in 
Chapter 17: The Velocity Windows.

Accelera- 
tion

The acceleration value of the deformation region’s 
position. The value is equivalent to the bias of the 
speed curve in the Model Velocity window, 
described in section “Graph Elements” (page 17-6) 
in Chapter 17: The Velocity Windows.

X The deformation region’s X coordinate position, 
relative to the center point of the group.

Y The deformation region’s Y coordinate position, 
relative to the center point of the group.

Z The deformation region’s Z coordinate position, 
relative to the center point of the group.
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Xrot These channels contain the following values for the deformation 
region’s X axis rotation (relative to the center of the group):

Motion 
Path

A pop-up menu provides a choice of three types of 
motion path spline:

Linear See “Linear” on page C-3.

Natural 
Cubic

See “Natural Cubic” on page C-3.

Hermite See “Hermite” on page C-3.

Velocity A value for the relative velocity of the deformation 
region’s X axis rotation.

Accelera- 
tion

A value for the acceleration of the deformation 
region’s X axis rotation.

Data A value in degrees for the deformation region’s 
rotation on its X axis.

Yrot These channels contain the following values for the deformation 
region’s Y axis rotation (relative to the center of the group):

Motion 
Path

A pop-up menu provides a choice of three types of 
motion path spline:

Linear See “Linear” on page C-3.

Natural 
Cubic

See “Natural Cubic” on page C-3.

Hermite See “Hermite” on page C-3.

Velocity A value for the relative velocity of the deformation 
region’s Y axis rotation.

Accelera- 
tion

A value for the acceleration of the deformation 
region’s Y axis rotation.

Data A value in degrees for the deformation region’s 
rotation on its Y axis.
The ElectricImage™ Reference C-11



Appendix C: Group Data Channels

Book  Page 12  Friday, July 21, 2000  4:18 PM
Z rot These channels contain the following values for the deformation 
region’s Z axis rotation (relative to the center of the group):

Motion 
Path

A pop-up menu provides a choice of three types of 
motion path spline:

Linear See “Linear” on page C-3.

Natural 
Cubic

See “Natural Cubic” on page C-3.

Hermite See “Hermite” on page C-3.

Velocity A value for the relative velocity of the deformation 
region’s Z axis rotation.

Accelera- 
tion

A value for the acceleration of the deformation 
region’s Z axis rotation.

Data A value in degrees for the deformation region’s 
rotation on its Z axis.

Min These channels contain the following values for the deformation 
region’s minimum face coordinates:

Motion 
Path

A pop-up menu provides a choice of four types of 
motion path spline:

Linear See “Linear” on page C-3.

Natural 
Cubic

See “Natural Cubic” on page C-3.

Hermite See “Hermite” on page C-3.

Bezier See “Bezier” on page C-3.

Velocity A value for the relative velocity of the region’s 
minimum face coordinates.

Accelera- 
tion

A value for the acceleration of the region’s 
minimum face coordinates.

X A value for the region’s minimum face X coordinate 
position, relative to the center point of the region.

Y A value for the region’s maximum face Y coordinate 
position, relative to the center point of the region.

Z A value for the region’s maximum face Z coordinate 
position, relative to the center point of the region.
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Max These channels contain the following values for the deformation 
region’s maximum face coordinates:

Motion 
Path

A pop-up menu provides a choice of four types of 
motion path spline:

Linear See “Linear” on page C-3.

Natural 
Cubic

See “Natural Cubic” on page C-3.

Hermite See “Hermite” on page C-3.

Bezier See “Bezier” on page C-3.

Velocity A value for the relative velocity of the region’s 
maximum face coordinates.

Accelera- 
tion

A value for the acceleration of the region’s 
maximum face coordinates.

X A value for the region’s maximum face X coordinate 
position, relative to the center point of the region.

Y A value for the region’s maximum face Y coordinate 
position, relative to the center point of the region.

Z A value for the region’s maximum face Z coordinate 
position, relative to the center point of the region.
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Scale If a Scale deformation is defined, as discussed in the section 
“Scale” (page 16-13) in Chapter 16: The Group Deformation 
Window, these channels are available:

Percent- 
age

These channels contain values for the percentage 
amount of the Scale deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation percentage.

Accelera- 
tion

The acceleration value of the 
deformation percentage.

Data The percentage of deformation.

Shear If a Shear deformation is defined, as discussed in the section 
“Shear” (page 16-14) in Chapter 16: The Group Deformation 
Window, these channels are available:

Angle These channels contain values for the angle amount 
of the Shear deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation angle.

Accelera- 
tion

The acceleration value of the 
deformation angle.

Data The angle of deformation.
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Twist If a Twist deformation is defined, as discussed in the section 
“Twist” (page 16-15) in Chapter 16: The Group Deformation 
Window, these channels are available:

Angle These channels contain values for the angle amount 
of the Twist deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation angle.

Accelera- 
tion

The acceleration value of the 
deformation angle.

Data The angle of deformation.

Taper If a Taper deformation is defined, as discussed in the section 
“Taper” (page 16-16) in Chapter 16: The Group Deformation 
Window, these channels are available:

Percent- 
age

These channels contain values for the percentage 
amount of the Taper deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation percentage.

Accelera- 
tion

The acceleration value of the 
deformation percentage.

Data The percentage of deformation.
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Bend If a Bend deformation is defined, as discussed in the section 
“Bend” (page 16-18) in Chapter 16: The Group Deformation 
Window, these channels are available:

Angle These channels contain values for the angle amount 
of the Bend deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation angle.

Accelera- 
tion

The acceleration value of the 
deformation angle.

Data The angle of deformation.

Bulge If a Bulge deformation is defined, as discussed in the section 
“Bulge” (page 16-19) in Chapter 16: The Group Deformation 
Window, these channels are available:

Percent- 
age

These channels contain values for the percentage 
amount of the Bulge deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation percentage.

Accelera- 
tion

The acceleration value of the 
deformation percentage.

Data The percentage of deformation.
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Linear 
Wave

If a Linear Wave deformation is defined, as discussed in the 
section “Linear Wave” (page 16-21) in Chapter 16: The Group 
Deformation Window, these channels are available:

Amplitude These channels contain values for the amplitude 
amount of the Linear Wave deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation amplitude.

Accelera- 
tion

The acceleration value of the 
deformation amplitude.

Data The amplitude of the deformation.

Frequency These channels contain values for the frequency of 
the Linear Wave deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation frequency.

Accelera- 
tion

The acceleration value of the 
deformation frequency.

Data The frequency of the deformation.
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Phase These channels contain values for the phase of the 
Linear Wave deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the 
deformation phase.

Accelera- 
tion

The acceleration value of the 
deformation phase.

Data The phase of the deformation.

Circular 
Wave

If a Circular Wave deformation is defined, as discussed in the 
section “Circular Wave” (page 16-23) in Chapter 16: The Group 
Deformation Window, these channels are available:

Outer 
Radius

These channels contain values for the outer radius of 
the Circular Wave deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the outer 
radius.

Accelera- 
tion

The acceleration value of the outer 
radius.

Data The outer radius of the deformation.
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Stretch If a Stretch deformation is defined, as discussed in the section 
“Stretch” (page 16-25) in Chapter 16: The Group Deformation 
Window, these channels are available:

Strength These channels contain values for the strength of 
the Stretch deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the strength.

Accelera- 
tion

The acceleration value of the strength.

Data The strength of deformation.

Blend 
Factor

These channels contain values for the blend factor 
of the Stretch deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the blend 
factor.

Accelera- 
tion

The acceleration value of the blend 
factor.

Data The blend factor of the deformation.
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Bezier If a Bezier deformation is defined, as discussed in the section 
“Bezier” (page 16-27) in Chapter 16: The Group Deformation 
Window, these channels are available:

Strength These channels contain values for the strength of 
the Bezier deformation:

Motion 
Path

A pop-up menu provides a choice of 
three types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Velocity The relative velocity of the strength.

Accelera- 
tion

The acceleration value of the strength.

Data The strength of deformation.

Min 
Anchor 
Point

These channels contain values for the minimum 
anchor point of the Bezier deformation:

Motion 
Path

A pop-up menu provides a choice of 
four types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Bezier (see “Bezier” on page C-3 for 
an explanation).

Velocity The relative velocity of the minimum 
anchor point.

Accelera- 
tion

The acceleration value of the 
minimum anchor point.

Data The minimum anchor point of the 
deformation.
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Min 
Control 
Point

These channels contain values for the minimum 
control point of the Bezier deformation:

Motion 
Path

A pop-up menu provides a choice of 
four types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Bezier (see “Bezier” on page C-3 for 
an explanation).

Velocity The relative velocity of the minimum 
control point.

Accelera- 
tion

The acceleration value of the 
minimum control point.

Data The minimum control point of the 
deformation.

Min
Spin
Point

These channels contain values for the minimum spin 
point of the Bezier deformation:

Motion 
Path

A pop-up menu provides a choice of 
four types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Bezier (see “Bezier” on page C-3 for 
an explanation).

Velocity The relative velocity of the minimum 
spin point.

Accelera- 
tion

The acceleration value of the 
minimum spin point.

Data The minimum spin point of the 
deformation.
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Max 
Anchor 
Point

These channels contain values for the maximum 
anchor point of the Bezier deformation:

Motion 
Path

A pop-up menu provides a choice of 
four types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Bezier (see “Bezier” on page C-3 for 
an explanation).

Velocity The relative velocity of the maximum 
anchor point.

Accelera- 
tion

The acceleration value of the 
maximum anchor point.

Data The maximum anchor point of the 
deformation.

Max 
Control 
Point

These channels contain values for the maximum 
control point of the Bezier deformation:

Motion 
Path

A pop-up menu provides a choice of 
four types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Bezier (see “Bezier” on page C-3 for 
an explanation).

Velocity The relative velocity of the maximum 
control point.

Accelera- 
tion

The acceleration value of the 
maximum control point.

Data The maximum control point of the 
deformation.
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Max
Spin
Point

These channels contain values for the maximum 
spin point of the Bezier deformation:

Motion 
Path

A pop-up menu provides a choice of 
four types of motion path spline:

Linear (see “Linear” on page C-3 for 
an explanation).

Natural Cubic (see “Natural Cubic” 
on page C-3 for an explanation).

Hermite (see “Hermite” on page C-3 
for an explanation).

Bezier (see “Bezier” on page C-3 for 
an explanation).

Velocity The relative velocity of the maximum 
spin point.

Accelera- 
tion

The acceleration value of the 
maximum spin point.

Data The maximum spin point of the 
deformation.
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The ElectricImage™ Reference D-1



Appendix D: Sound Data Channels

Book  Page 2  Friday, July 21, 2000  4:18 PM
Table of Sound Data Channels
This appendix lists the data channels available for soundtracks in a 
project, as they appear in the Project Window. For information on 
the Project window and its use, refer to Chapter 8: The Project Window.

Mono This channel displays the digitized sound wave for a monaural signal. The horizontal axis is 
time and the vertical axis is amplitude.

Stereo Left This channel displays the digitized sound wave for the left channel of a stereo signal. The 
horizontal axis is time and the vertical axis is amplitude.

Stereo Right This channel displays the digitized sound wave for the right channel of a stereo signal. The 
horizontal axis is time and the vertical axis is amplitude.

Other 
channels

If the signal contains additional channels, they are assigned the names Center, Surround 
Left, Surround Right, and Subwoofer.
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Appendix E Keyboard/Mouse Commands

Conventions.....................................................................................E-2

World View Window Controls ......................................................E-3

Camera View Window Controls ...................................................E-4

Project Window Controls ..............................................................E-4

QuickTime Window Controls ........................................................E-4

Velocity Window Controls.............................................................E-5

Light Info Window Controls .........................................................E-5

Group Info Window Controls........................................................E-6

Group Link Window Controls .......................................................E-6

Group Texture Window Controls .................................................E-7

Tool and Object Palette Controls .................................................E-7

Render Control Window Controls................................................E-8

File Menu Controls..........................................................................E-8

Edit Menu Controls.........................................................................E-8

Windows Menu Controls ...............................................................E-9

Tools Menu Controls.......................................................................E-9

Special Controls ............................................................................E-10
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Conventions

Keyboard Symbols

The following symbols are used to represent specific keys:

Command key

Option key

Control key

Shift key

Using the Tables

To achieve the desired result as listed in the right column, press the 
key(s) shown in the left column while performing the mouse action 
described in the middle column (if any). When two or more keys are 
shown, hold down the keys simultaneously.
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World View Window
Controls

Figure E.1 lists keyboard/mouse actions available for use in the World 
View windows

Figure E.1   World View window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click zoom button. Fit world size into window.

Click Zoom Window tool. Zoom out.

Click and drag rectangle. Zoom to selected area.

Click and drag object part (camera 
and lights only).

Constrain movement along the reference vector.

Click and drag object part. Rotate object on X axis.

Click and drag object part. Rotate object on Y axis.

Click and drag object part. Rotate object on Z axis.

Click and drag group center. Drag group center.

Arrow key Move selection in frontmost window by 1 pixel.

Arrow key Move selection in frontmost window by 10 pixels.

Click Shading button. Open pop-up menu for drawing preferences.

Click Preview button. Open pop-up menu for preview preferences.

Double-click group. Open Group Texture window for group.

Double-click group. Open Group Link window for group.

Double-click group. Open Group Deformation window for group.

Double-click light. Select light color.

Click in title bar. Select new projection.

Click and drag Bezier handle. Dolly the handle.

Click and drag Bezier handle. Realign handles to create continuous curve.

Click and drag Bezier handle. Break handles to create non-continuous curve.
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Camera View Window
Controls

Figure E.2 lists keyboard/mouse actions available for use in the 
Camera View window.

Project Window
Controls

Figure E.3 lists keyboard/mouse actions available for use in the 
Project window.

QuickTime Window
Controls

Figure E.4 lists keyboard/mouse actions available for use in the 
QuickTime display window.

Figure E.2   Camera View window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click Shading button. Open pop-up menu for drawing preferences.

Click Preview button. Open pop-up menu for preview preferences.

Figure E.3   Project window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click in data cell. Select all data cells in row.

Click zoom button in Time mode. Fit timing size into window.

Click flags in status panel
(flat view).

Set elements down the list in the same class to the 
toggled value.

Click flags in status panel 
(hierarchical view).

Set children to the toggled value.

Double-click soundtrack icon. Play/stop selected soundtrack.

Double-click group. Open Group Texture window for group.

Double-click group. Open Group Link window for group.

Double-click group. Open Group Deformation window for group.

Figure E.4   QuickTime window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click in title bar. Select new QuickTime option.
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Velocity Window
Controls

Figure E.5 lists keyboard/mouse actions available for use in the 
Velocity windows.

Light Info Window
Controls

Figure E.6 lists keyboard/mouse actions available for use in the Light 
Info window.

Figure E.5   Velocity window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click zoom button. Fit velocity size into window.

Click zoom out button. Shrink velocity graph size.

Click zoom in button. Expand velocity graph size.

Click and drag on keyframe bar. Drag without snap to frame.

Click and drag intersection of 
keyframe and teeter bars.

Drag time and velocity.

Figure E.6   Light Info window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click button/pop-up. Set all lights to value.

Click button/pop-up. Set remaining lights to value.

Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.
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Group Info Window
Controls

Figure E.7 lists keyboard/mouse actions available for use in the Group 
Info window.

Group Link Window
Controls

Figure E.8 lists keyboard/mouse actions available for use in the Group 
Link window.

Figure E.7   Group Info window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click button/pop-up. Set all groups to value.

Click button/pop-up. Set remaining groups to value.

Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.

Figure E.8   Group Link window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click and drag gnome. Rotate Z axis.

Click and drag gnome. Rotate Y axis.

Click and drag gnome. Rotate X axis.

Click zoom button. Fit world size into window.

Click Zoom Window tool. Zoom out.

Click and drag rectangle. Zoom to selected area.

Click in content. Create new selection area if in texture.

Click button/pop-up. Set all groups to value.

Click button/pop-up. Set remaining groups to value.

Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.
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Group Texture Window
Controls

Figure E.9 lists keyboard/mouse actions available for use in the Group 
Texture window.

Tool and Object Palette
Controls

Figure E.10 lists keyboard/mouse actions available for use in the 
Velocity windows.

Figure E.9   Group Texture window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click and drag gnome. Rotate Z axis.

Click and drag gnome. Rotate Y axis.

Click and drag gnome. Rotate X axis.

Click zoom button. Fit world size into window.

Click Zoom Window tool. Zoom out.

Click and drag rectangle. Zoom to selected area.

Click in content. Create new selection area if in texture.

Click button/pop-up. Set all groups to value.

Click button/pop-up. Set remaining groups to value.

Click button/pop-up. Set all children to value.

Click button/pop-up. Set immediate children to value.

Figure E.10   Palette keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click Translation icon. Show custom drag angle when in custom drag mode.

Click Deformations tool. Toggle deform enable bit.

Click a plug-in icon. Show plug-in information.

Click Unlink icon. Reset prerotations when unlinking.
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Render Control Window
Controls

Figure E.11 lists keyboard/mouse actions available for use in the 
Velocity windows.

File Menu Controls Figure E.12 lists keyboard/mouse actions available for use with the 
File menu.

Edit Menu Controls Figure E.13 lists keyboard/mouse actions available for use with the 
Edit menu.

Figure E.11   Render Control window keyboard/mouse controls

Press Key(s) + Mouse Action Result

Click Go. Select remote camera.

Figure E.12   File menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Choose Add > Plug-in. Show plug-in information.

Choose Group Info. Open Group Texture window for selected group.

Choose Group Info. Open Group Link window for selected group.

Choose Group Info. Open Group Deformation window for selected group.

Choose Light Info. Select light color.

Choose Sound Info. Play/stop selected soundtrack.

Choose Projector. Launch Projector without exiting ElectricImage.

Figure E.13   Edit menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Choose Default Preferences. Reset window defaults only.

C --- Select Special Copy
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Windows Menu Controls Figure E.14 lists keyboard/mouse actions available for use with the 
Windows menu.

Tools Menu Controls Figure E.15 lists keyboard/mouse actions available for use in the 
Velocity windows.

Figure E.14   Windows menu keyboard/mouse controls

Press Key(s) + Mouse Action Result

Choose Top View. Reset Top View window to default position and size.

Choose Front View. Reset Front View window to default position and size.

Choose Side View. Reset Side View window to default position and size.

Choose Camera View. Reset Camera View window to default position and 
size.

Choose Project. Reset Project window to default position and size.

Choose Model Velocity. Reset velocity window to default position and size.

Choose Camera Velocity. Reset velocity window to default position and size.

Choose Light Velocity. Reset velocity window to default position and size.

Figure E.15   Tools menu controls

Press Key(s) + Mouse Action Result

Choose Translation. Show custom drag angle when in custom drag mode.

Choose Deformations. Toggle deform enable bit.

Choose Unlink from Parent. Reset prerotations when unlinking.
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Special Controls Figure E.16 lists keyboard/mouse actions available for use in certain 
specific situations.

Figure E.16   Special controls

Press Key(s) + Mouse Action Result

. --- Exit ElectricImage while application is loading.

Q --- Exit ElectricImage while application is loading.

1 --- Select top view of frontmost World View window.

2 --- Select side view of frontmost World View window.

3 --- Select front view of frontmost World View window.

[ --- Zoom in on frontmost World View window.

] --- Zoom out of frontmost World View window.

= --- Fit to window frontmost World View window.

H --- Toggle hide children flag of selected objects.

Caps Lock --- Lock dragging to grid values.
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  Symbols
% edit box

In Mr. Nitro™ dialog box 20-11

Numerics
16mm option

In Aspect Ratio pop-up menu
In Render Control window 9-8

256 Colors option
In Image pop-up menu

In Render Control window 9-6
256 Shades option

In Image pop-up menu
In Render Control window 9-6

35mm Full option
In Aspect Ratio pop-up menu

In Render Control window 9-8
35mm option

In Aspect Ratio pop-up menu
In Render Control window 9-8

3DFACE option
DXF export preferences

Saving models to non-FACT 
formats 1-39

65mm option
In Aspect Ratio pop-up menu

In Render Control window 9-8
70mm option

In Aspect Ratio pop-up menu
In Render Control window 9-8

A
Abekas 9-11
Action Safe option

In Field Chart Preferences dialog 
box 2-23

Activate Drawing Windows When 
Mouse is Clicked in Window 
Content option

In Drawing Preferences dialog box 
2-14

Adaptive option
In Anti-Aliasing pop-up menu

In Render Control window 9-12
Add > Font… command

In File menu 1-17 to 1-21
Add > Import… command

In File menu 1-22 to 1-30
Add > Light… command

In File menu 1-16
Add > Mesh… command

In File menu 1-31
Add > Model… command

In File menu 1-12 to 1-13
Add > Mr. Nitro™… command

In File menu 1-32
Add > Particle… command

In File menu 1-33
Add > Record Sound… command

In File menu 1-15
Add > Sound… command

In File menu 1-14
Add > Standard Shape… command

In File menu 1-34
IX-1
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Add button
In Sound Info window 12-5

Add Font tool
In Object Palette 20-5

Add Keyframe command
In Keyframe menu 4-2

Add Light tool
In Object Palette 20-4

Add Model tool
In Object Palette 20-4

Add Noise option
In Render Control window 9-17

Add Sound tool
In Object Palette 20-4

Age color buttons
In Mr. Nitro™ dialog box 20-12

Air Resistance edit box
In Mr. Nitro™ dialog box 20-10
In Particle Generator dialog box 

20-15
Alias Sketch!… option

In Preferences pop-up menu
In Import Model dialog box 1-28

Align pop-up menu
In Group Texture window 14-19

All Children option
In Modify In pop-up-menu

In Surface Editor 18-16
All Frames button

In Surface Editor 18-17
All Frames option

In Render pop-up menu
In Render Control window 9-25

Printing project data 1-51
Rendering options

In Project window 8-25
All Groups option

In Modify In pop-up-menu
In Surface Editor 18-16

All Keys button
In Surface Editor 18-17

All option
Custom view options

In Project window 8-20
Printing project data 1-52

Alpha control
Group Color settings

In Surface Editor 18-8
Alpha option

In Fog To pop-up menu
In Render Control window 9-9

Alpha pop-up menu
In Group Texture window 14-16 to 

14-18
Ambient color button

In Render Control window 9-19
Ambient lighting

Enabling/Disabling for project 9-16
Setting minimum light value with 

color 9-19
Ambient lights

Selecting for lights 11-5
Ambient option

In Alpha pop-up menu
In Group Texture window 14-17

In Attribute pop-up menu
In Surface Editor 18-10

In Light Modes pop-up menu
In Light Info window 11-5

In Render Control window 9-16
In RGB pop-up menu

In Group Texture window 14-14
Anamorphic radio button

In Lens Flare Plug-In dialog box 
11-17

Angles edit boxes
In Camera Info window 10-6

Anti-aliasing
Setting adaptive sampling 

thresholds 9-12
Setting for project 9-12

Anti-Aliasing pop-up menu
In Render Control window 9-12

Aspect ratio
Observing in Camera View window 

7-4
Aspect Ratio edit box

In Lens Flare Plug-In dialog box 
11-17

Aspect Ratio pop-up menu
In Render Control window 9-7 to 

9-8
Attach to Object command

In Tools menu 5-23 to 5-24
Attach to Object function

Applying 5-23 to 5-24, 8-28, 19-24 
to 19-25

Automatic frame calculation 4-8
Canceling 5-25, 8-28, 19-26
Setting auto frame options 2-10

Attach to Object tool
In Project window 8-28
In Tool Palette 19-24 to 19-25

Attribute pop-up menu
In Surface Editor 18-7

Auto Rotate function
Applying 5-26 to 5-27, 8-29, 19-27 

to 19-28
Automatic frame calculation 4-8
Canceling 5-28, 8-29, 19-29
Setting auto frame options 2-10

Auto Rotate Object command
In Tools menu 5-26 to 5-27

Auto Rotate Object tool
In Project window 8-29
In Tool Palette 19-27 to 19-28

Average Points option
Cyberware import preferences

Converting models to FACT 
format 1-30

B
B&W Dithered option

In Image pop-up menu
In Render Control window 9-6

B&W Filled option
In Image pop-up menu

In Render Control window 9-6
B&W Lines option

In Image pop-up menu
In Render Control window 9-6

B&W Summation option
In Image pop-up menu

In Render Control window 9-6
Back option

In Align pop-up menu
In Group Texture window 14-19

In Link Alignment Position pop-up 
menu

In Group Link window 15-9
Background color button

In Color Preferences dialog box 2-32
In Render Control window 9-19

Background Image button
In Render Control window 9-20 to 

9-22
Background option

In Fog To pop-up menu
In Render Control window 9-9

In Render Control window 9-16
Background pop-up menu

In Preview/Render Preferences 
dialog box 2-28

Backgrounds
Applying a background image 9-20 

to 9-22
Enabling/Disabling for project 9-16
Observing in the Camera View 

window 7-7
Removing a background image 9-22
Setting background color 9-19

Ball Planar option
In Link Type pop-up menu

In Group Link window 15-10
Band Angle edit box

In Group Texture window 14-26
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Bend option
In Type pop-up menu

In Group Deformation window 
16-18

Bevel Angle edit box
In Font Model dialog box 1-19

Bevel Size edit box
In Font Model dialog box 1-19

Bezier option
In Type pop-up menu

In Group Deformation window 
16-27 to 16-30

Bezier Splines option
In pop-up menu

In Camera Velocity window 17-8
In Light Velocity window 17-8
In Model Velocity window 17-8

Blast Time edit box
In Mr. Nitro™ dialog box 20-10

Blend Curve option
Blend options

In Project window 8-23
Blend Glow option

In Light Info window 11-20
Blend Linear option

Blend options
In Project window 8-23

Blur Frames edit box
In Render Control window 9-15

Blur Intensity edit box
In Group Info window 13-6
In Render Control window 9-13

Blur Mode pop-up menu
In Group Info window 13-6

Blur Noise edit box
In Render Control window 9-14

Bottom option
In Align pop-up menu

In Group Texture window 14-19
In Link Alignment Position pop-up 

menu
In Group Link window 15-9

Bounce Factor edit box
In Particle Generator dialog box 

20-15
Bounce Friction edit box

In Particle Generator dialog box 
20-16

Breakup Concave Polygons option
Saving models to non-FACT formats 

1-38
Breathing Cylinder option

In Mesh Type pop-up menu
In Mesh Generator dialog box 

20-7
Buffer Size edit box

In Group Texture window 14-26
In Light Info window 11-13

Build Groups From option
DXF import preferences

Converting models to FACT 
format 1-27

Build Quadrangles option
Cyberware import preferences

Converting models to FACT 
format 1-30

Build Triangles option
Cyberware import preferences

Converting models to FACT 
format 1-30

Bulge option
In Type pop-up menu

In Group Deformation window 
16-19 to 16-20

Bump Factor edit box
In Group Texture window 14-27

Bump mapping
Enabling 14-16
Setting bump map height 14-27

Bump option
In Alpha pop-up menu

In Group Texture window 14-16

C
Calculate Auto Frames command 2-10

In Keyframe menu 4-8
Calculate Flexing option

In Font Model dialog box 1-20
Calculate Shadow Only Once option

In Light Info window 11-13
Camera

Angle
Setting focal length 10-7
Showing in World View windows 

10-3
Changing acceleration of 17-7
Changing velocity of 17-7
Controlling roll 10-6
Finding in projects 2-6 to 2-7
Manipulating in the World View 

windows 6-9
Observing what it sees in the 

Camera View window 7-5
Orienting by yaw, pitch and roll 

10-6
Positioning 10-6
Positioning reference point 10-6
Selecting 2-6
Selecting diagonal dimension for 

focal length 10-8
Selecting focal length calculation 

technique 10-8

Selecting horizontal dimension for 
focal length 10-8

Selecting vertical dimension for 
focal length 10-8

Setting field of view 10-7
Setting focal length 10-7
Setting keyframe data 10-5 to 10-8
Velocity graphs for 17-9

Camera application 22-1 to 22-11
File menu 22-3

Continue command 22-3
Pause command 22-3
Quit command 22-3

Frame window 22-11
Information window 22-5 to 22-8
Monitor window 22-9
Status window 22-10
Windows menu 22-4

Frame command 22-4
Hide All Windows command 

22-4
Information command 22-4
Monitor command 22-4
Show All Windows command 

22-4
Status command 22-4

Camera edit boxes
In Camera Info window 10-6

Camera Grid Divisions edit box
In Grid & Scale Preferences dialog 

box 2-18
Camera Grid Size edit box

In Grid & Scale Preferences dialog 
box 2-18

Camera Info command
In File menu 1-45

Camera Info window 10-1 to 10-8
Angles edit boxes 10-6
Camera edit boxes 10-6
Camera roll control 10-6
Current Stats section 10-5 to 10-8
Field of View edit box 10-7
Focal Length edit box 10-7
Focal Mode pop-up menu 10-8

Diagonal option 10-8
Horizontal option 10-8
Vertical option 10-8

Icon display options 10-3 to 10-4
Opening the window 1-45, 10-2
Reference edit boxes 10-6
Show Angle option 10-3
Show Fog option 10-4

Camera lights
Selecting for lights 11-4

Camera option
In Data Folder pop-up menu
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In Preview/Render Preferences 
dialog box 2-29

In Light Modes pop-up menu
In Light Info window 11-4

In Shadow Folder pop-up menu
In Preview/Render Preferences 

dialog box 2-29
Camera pop-up menu

In Render Control window 9-4
Camera roll control

In Camera Info window 10-6
Camera Velocity command

In Windows menu 3-10
Camera Velocity window 17-1 to 17-9

Acceleration control 17-7
Displaying data channels 17-4
Opening the window 3-10, 17-3
Setting the size of 17-5
Timing control 17-7
Velocity control 17-7

Camera View command
In Windows menu 3-8

Camera View window 7-1 to 7-11
Controlling drawing detail 7-8
Drawing Detail options 2-12 to 2-14
Initiating previews 7-9 to 7-10
Observing aspect ratio 7-4
Observing background images 7-7
Observing field charts 7-6
Observing what the camera sees 7-5
Opening the window 3-8, 7-3
Rotoscoping 7-11
Setting preferences

Space Clipping Minimum Z 
Distance edit box 2-19

Cancel Auto Rotate command
In Tools menu 5-28

Cancel Auto Rotate tool
In Project window 8-29
In Tool Palette 19-29

Cancel Look At command
In Tools menu 5-22

Cancel Look At tool
In Project window 8-28
In Tool Palette 19-23

Cast Shadow option
In Group Info window 13-7

Cell data
In Project window

Editing 8-11
Cell Size edit boxes

Printing project data 1-53
Cells

Copying data in 2-4
Cutting data in 2-3
Pasting data into 2-4

Center edit boxes
In Group Info window 13-10

Channels, see Data channels
Circular Wave option

In Type pop-up menu
In Group Deformation window 

16-23 to 16-24
Clear All Keyframes command

In Keyframe menu 4-2
Clear command

In Edit menu 2-5
Close All option

Open/Close options
In Project window 8-21

Close command
In File menu 1-10

Close Selected All option
Open/Close options

In Project window 8-21
Close Window command

In Windows menu 3-13
Collect Files… command

In File menu 1-44
Color

Groups
Blending across polygon edges 

13-7
Overriding original 13-7

Color Blend option
In Group Info window 13-7
In Render Control window 9-16

Color blending
Enabling/Disabling for project 9-16

Color button
In Standard Shapes dialog box 20-18

Color buttons
In Field Chart Preferences dialog 

box 2-25
Color of window elements

Setting preferences 2-31 to 2-32
Background color button 2-32
Element path color button 2-32
Extent color button 2-32
Foreground color button 2-32
Grid color button 2-32
Handle color button 2-32
Key color button 2-32
Reference path color button 2-32
Vertex color button 2-32

Color option
Custom view options

In Project window 8-20
In Fog To pop-up menu

In Render Control window 9-9
Printing project data 1-52

Color… command

In Edit menu 2-31 to 2-32
Combine Coordinates option

In Import Model dialog box 1-26
Combine Groups option

In Import Model dialog box 1-25
Combine Polygons option

In Import Model dialog box 1-25
Compute Attach/Lookat/Rotate 

Automatically option
In Keyframes Preferences dialog box 

2-10
Computer option

In Aspect Ratio pop-up menu
In Render Control window 9-7

Containing faces, see Deformations
Continue button

In Sound Info window 12-3
Continue command

In File menu
In Camera application 22-3

Convert Polylines To option
DXF import preferences

Converting models to FACT 
format 1-27

Coordinate plane
In the World View windows 6-15

Copy command
In Edit menu 2-4

Copy Special command
In Edit menu 2-5

Create Back Bevels option
In Font Model dialog box 1-20

Create Particles From Time edit boxes
In Particle Generator dialog box 

20-14
Cross Lines option

In Field Chart Preferences dialog 
box 2-23

Cubic option
In Map Type pop-up menu

In Group Texture window 14-13
Cue List box

In Sound Info window 12-5
Current Frame button

In Surface Editor 18-17
Current Frame option

In Render pop-up menu
In Render Control window 9-25

Current Group Only option
In Modify In pop-up-menu

In Surface Editor 18-16
Current Key button

In Surface Editor 18-17
Current Stats
IX-4 ElectricImage™ Animation System



D

Book  Page 5  Friday, July 21, 2000  4:18 PM
In Camera Info window 10-5 to 
10-8

In Group Info window 13-9 to 13-10
In Light Info window 11-10 to 

11-12
Current Time button

In Surface Editor 18-17
Cursor location

In World View windows 21-2
Custom option

In Data Folder pop-up menu
In Preview/Render Preferences 

dialog box 2-29
In Shadow Folder pop-up menu

In Preview/Render Preferences 
dialog box 2-29

Custom… option
Custom view options

In Project window 8-20
In Aspect Ratio pop-up menu

In Render Control window 9-7
In FPS pop-up menu

In Project window 8-14
In Render Control window 9-24

In Link Type pop-up menu
In Group Link window 15-10

Printing project data 1-52
Cut command

In Edit menu 2-3
Cyberware import preferences

Converting models to FACT format 
1-29 to 1-30

Cylinder option
In Link Type pop-up menu

In Group Link window 15-10
Cylinder Planar option

In Link Type pop-up menu
In Group Link window 15-10

Cylindrical option
In Map Type pop-up menu

In Group Texture window 14-11

D
Data channels

Displaying in Project window 8-30
Data Folder pop-up menu

In Preview/Render Preferences 
dialog box 2-29

Data Format information
Cyberware import preferences

Converting models to FACT 
format 1-30

Data Offset edit box
Cyberware import preferences

Converting models to FACT 
format 1-30

Data Scale edit box
Cyberware import preferences

Converting models to FACT 
format 1-30

Decal option
In Alpha pop-up menu

In Group Texture window 14-16
Decimal Digits edit box

DXF export preferences
Saving models to non-FACT 

formats 1-40
Default Inherit Deformation option

In Import Preferences dialog box 
2-34

Default Inherit Position option
In Import Preferences dialog box 

2-34
Default Inherit Rotation option

In Import Preferences dialog box 
2-34

Default Inherit Scale option
In Import Preferences dialog box 

2-34
Default Inherit Visibility option

In Import Preferences dialog box 
2-34

Default Preferences command
In Edit menu 2-37

Deformations
Deformation regions 16-4 to 16-9

Containing faces 16-6
Defining 16-5
Orienting

Dragging in World View win-
dows 16-8

Using edit boxes 16-6
Positioning 16-6 to 16-8

Dragging in World View win-
dows 16-7 to 16-8

Using edit boxes 16-6
Deformation types 16-10 to 16-30

Bend 16-18
Bezier 16-27 to 16-30

Anchor points 16-27 to 16-29
Control points 16-27 to 16-29
Setting options 16-29 to 16-30
Spin points 16-27 to 16-29

Bulge 16-19 to 16-20
Setting options 16-19 to 16-20

Circular Wave 16-23 to 16-24
Setting options 16-24

Creating 16-11 to 16-12
Linear Wave 16-21 to 16-22

Setting options 16-21 to 16-22
Scale 16-13

Selecting from menu 16-11
Shear 16-14
Stretch 16-25 to 16-26

Setting options 16-25 to 16-26
Taper 16-16 to 16-17

Setting options 16-17
Twist 16-15

Opening Group Deformation 
window 8-26, 19-13

Delete button
In Sound Info window 12-5

Delete Keyframe command
In Keyframe menu 4-2

Detach from Object command
In Tools menu 5-25

Detach from Object tool
In Project window 8-28
In Tool Palette 19-26

Detail pop-up menu
In Preview/Render Preferences 

dialog box 2-27
Deviation Angle edit box

In Particle Generator dialog box 
20-15

Diagonal option
In Focal Mode pop-up menu

In Camera Info window 10-8
Diffuse option

In Alpha pop-up menu
In Group Texture window 14-17

In Attribute pop-up menu
In Surface Editor 18-9

In RGB pop-up menu
In Group Texture window 14-14

Dimensions edit boxes
In Standard Shapes dialog box 20-18

Disabled option
In Alpha pop-up menu

In Group Texture window 14-16
In RGB pop-up menu

In Group Texture window 14-14
Display… command

In File menu 1-11
Dissolve edit box

In Mr. Nitro™ dialog box 20-11
Dither option

In Transparency pop-up menu
In Group Info window 13-5
In Render Control window 9-5

Divisions edit boxes
In Standard Shapes dialog box 20-18

Drag Content command
In Tools menu 5-9

Drag Content tool
In Tool Palette 19-10

Draw Group Extents option
The ElectricImage™ Reference IX-5
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In Drawing Preferences dialog box 
2-12

Draw Lights option
In Drawing Preferences dialog box 

2-14
Draw Paths option

In Drawing Preferences dialog box 
2-14

Draw Polygons option
In Drawing Preferences dialog box 

2-13
Draw Shaded option

In Drawing Preferences dialog box 
2-13

Draw Vertices option
In Drawing Preferences dialog box 

2-12
Drawing detail

Controlling in the Camera View 
window 7-8

Controlling in the World View 
windows 6-15

Setting preferences 2-11 to 2-16
Activate Drawing Windows 

When Mouse is Clicked in 
Window Content option 
2-14

Draw Group Extents option 2-12
Draw Lights option 2-14
Draw Paths option 2-14
Draw Polygons option 2-13
Draw Shaded option 2-13
Draw Vertices option 2-12
Drawing Detail options 2-12 to 

2-13
Key Entry Pause edit box 2-15
Mouse Drag Pause edit box 2-15
Picture Cache edit box 2-14
Screen Colors pop-up menu 2-14
Show Grid while Dragging option 

2-15
Show Recorded Image option 

2-15
Show Subpolygons option 2-16
Suspend Drawing While 

Application in Background 
option 2-15

Switch Color Depth option 2-14
Use QuickDraw option 2-15

Drawing Detail options
For Camera View window 2-12 to 

2-13
For Group windows 2-12 to 2-13
For World View windows 2-12 to 

2-13
Drawing… command

In Edit menu 2-11 to 2-16

Dropoff edit box
In Light Info window 11-11

Duplicate command
In Edit menu 2-7

Duration edit box
In Sound Info window 12-5

Duration Time
In Sound Info window 12-4

DXF export preferences
Saving models to non-FACT formats 

1-39
DXF… option

In Preferences pop-up menu
In Import Model dialog box 1-27

E
Edge Density edit box

In Surface Editor 18-15
Edge Density option

In Alpha pop-up menu
In Group Texture window 14-18

In Attribute pop-up menu
In Surface Editor 18-15

In RGB pop-up menu
In Group Texture window 14-15

Edit boxes
Copying text in 2-4, 2-5
Cutting text in 2-3
Pasting text into 2-4

Edit menu 2-1 to 2-37
Clear command 2-5
Color… command 2-31 to 2-32
Copy command 2-4
Copy Special command 2-5
Cut command 2-3
Default Preferences… command 

2-37
Drawing… command 2-11 to 2-16
Duplicate command 2-7
Field Chart… command 2-20 to 

2-25
Find Again command 2-7
Find command 2-6
Grid & Scale… command 2-17 to 

2-19
Import… command 2-33 to 2-34
Keyframe… command 2-9 to 2-10
Paste command 2-4
Preview/Render… command 2-26 to 

2-30
Project File… command 2-35 to 

2-36
Revert command 2-8
Select All command 2-6
Undo command 2-3

Editing

Clearing objects from projects 2-5
Copying cell data 2-4
Copying surface attributes 2-4
Copying text 2-4, 2-5
Copying texture maps 2-4
Cutting cell data 2-3
Cutting surface attributes 2-3
Cutting text 2-3
Pasting cell data 2-4
Pasting surface attributes 2-4
Pasting text 2-4
Pasting texture maps 2-4
Undoing changes 2-3

Editing modes 8-5 to 8-9
Frame 8-8, 10-5, 11-10, 13-9
Index 8-9, 10-5, 11-10, 13-9
Keyframe 8-7, 10-5, 11-10, 13-9
Selecting in Project window 8-5
Time 8-6, 10-5, 11-10, 13-9

EI Sockets folder
Storing plug-ins 3-4

Element menu options
Printing project data 1-52

Element path color button
In Color Preferences dialog box 2-32

Enable Filter option
In Group Texture window 14-21

Enable Fog option
In Light Info window 11-15

Enable Glow option
In Light Info window 11-15

Enable Highlight option
In Light Info window 11-20

Enable Obscuration option
In Light Info window 11-16

Enable Shadow option
In Light Info window 11-13
In Render Control window 9-16

Energy color buttons
In Particle Generator dialog box 

20-16
Environment mapping, see Reflections, 

Environment 14-8
Even Field option

For video interlacing 9-18
Every Nth Frame… option

Rendering options
In Project window 8-25

Exchange Y and Z Coordinates option
DXF export preferences

Saving models to non-FACT 
formats 1-40

DXF import preferences
Converting models to FACT 

format 1-27
Exponential option
IX-6 ElectricImage™ Animation System
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In Fog Mode pop-up menu
The ElectricImage™ Reference IX-7



F

Book  Page 8  Friday, July 21, 2000  4:18 PM
In Render Control window 9-9
Extent color button

In Color Preferences dialog box 2-32
Extents

Enabling display of 13-7
Extents option

In Detail pop-up menu
In Preview/Render Preferences 

dialog box 2-27
Extrude edit box

In Font Model dialog box 1-18

F
Factor edit box

In Light Info window 11-12, 11-15
Field Chart… command

In Edit menu 2-20 to 2-25
Field charts

Observing in the Camera View 
window 7-6

Setting preferences 2-20 to 2-25
Action Safe option 2-23
Color buttons 2-25
Cross Lines option 2-23
Field Size edit box 2-25
Grid option 2-22
Hatch Lines option 2-24
Title Safe option 2-22

Field of View edit box
In Camera Info window 10-7

Field Size edit box
In Field Chart Preferences dialog 

box 2-25
File menu 1-1 to 1-57

Add > Font… command 1-17 to 
1-21

Add > Import… command 1-22 to 
1-30

Add > Light… command 1-16
Add > Mesh… command 1-31
Add > Model… command 1-12 to 

1-13
Add > Mr. Nitro™… command 1-32
Add > Particle… command 1-33
Add > Record Sound… command 

1-15
Add > Sound… command 1-14
Add > Standard Shape… command 

1-34
Camera Info command 1-45
Close command 1-10
Collect Files… command 1-44
Display… command 1-11
Group Info command 1-46
Light Info command 1-46
New command… 1-3 to 1-6

Open… command 1-7 to 1-9
Page Setup… command 1-49
Print command 1-50 to 1-53
Projector command 1-56
Quit command 1-57
Render… command 1-54 to 1-55
Save As… command 1-42
Save command 1-41
Save Copy As… command 1-43
Save Model > FACT… command 

1-35
Save Model > Other… command 

1-36 to 1-40
Sound Info command 1-47
Statistics… command 1-48

Fill Constant… option
Fill options

In Project window 8-22
Fill Selected option

Fill options
In Project window 8-22

Fillet Sides edit box
In Font Model dialog box 1-20

Film:24 option
In FPS pop-up menu

In Project window 8-14
In Render Control window 9-25

Filter button
In Group Texture window 14-28

Filter option
In Transparency pop-up menu

In Group Info window 9-5
Filter Transparency option

In Transparency pop-up menu
In Group Info window 13-5

Find Again command
In Edit menu 2-7

Find command
In Edit menu 2-6

Fix Cone Point Shading option
In Import Model dialog box 1-26

Fix Smooth Shading option
In Font Model dialog box 1-18
In Import Model dialog box 1-26

Flare pop-up menu
In Light Info window 11-16

Flare, see Lens flare
Flat Complex Polygons option

In Import Model dialog box 1-26
Flat option

Flat/Hierarchy view options
In Project window 8-19

In Map Type pop-up menu
In Group Texture window 14-10

In Mesh Type pop-up menu

In Mesh Generator dialog box 
20-7

In Shading pop-up menu
In Group Info window 13-3

Printing project data 1-51
Flat Shade option

In Camera pop-up menu
In Render Control window 9-4

Flat shading
Selecting for a group 13-3
Selecting for all groups 9-4

Focal length
Diagonal dimension

Selecting for camera 10-8
Horizontal dimension

Selecting for camera 10-8
Selecting calculation technique 10-8
Vertical dimension

Selecting for camera 10-8
Focal Length edit box

In Camera Info window 10-7
Focal Mode pop-up menu

In Camera Info window 10-8
Fog

Applying to projects 9-9 to 9-10
Enabling/Disabling for project 9-16
Mode options 9-9
Selecting alpha technique 9-9
Selecting background technique 9-9
Selecting color technique 9-9
Selecting exponential mode 9-9
Selecting linear mode 9-9
Setting fog color 9-19
Setting inner and outer radii 9-10
Showing in World View windows 

10-4
Technique options 9-9

Fog color button
In Render Control window 9-19

Fog lights
Enabling and configuring 11-15
Setting dropoff factor 11-15
Setting inner radius 11-15
Setting inside color 11-15
Setting outer radius 11-15
Setting outside color 11-15
Showing in World View windows
Using RGB interpolation 11-20

Fog Mode pop-up menu
In Render Control window 9-9

Fog option
In Render Control window 9-16

Fog Radius edit boxes
In Render Control window 9-10

Fog To pop-up menu
In Render Control window 9-9
IX-8 ElectricImage™ Animation System
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Font models
Adding to project 1-17 to 1-21, 20-5
Design options 1-18 to 1-21

Bevel Angle edit box 1-19
Bevel Size edit box 1-19
Calculate Flexing option 1-20
Create Back Bevels option 1-20
Extrude edit box 1-18
Fillet Sides edit box 1-20
Fix Smooth Shading option 1-18
Group Similar Sides option 1-21
Group Whole Characters option 

1-21
Max Angle edit box 1-18
Reverse Back Bevel option 1-20
Smooth edit box 1-18
Space edit box 1-18

Force edit box
In Mr. Nitro™ dialog box 20-11

Foreground color button
In Color Preferences dialog box 2-32

FPS pop-up menu
In Project window 8-14
In Render Control window 9-24 to 

9-25
Fragment Color option

In Mr. Nitro™ dialog box 20-12
Fragment Shape edit boxes

In Mr. Nitro™ dialog box 20-12
Fragment Size edit boxes

In Mr. Nitro™ dialog box 20-11
Frame command

In Windows menu
In Camera application 22-4

Frame editing mode 8-8, 10-5, 11-10, 
13-9

Frame option
Printing project data 1-51

Frame Range edit boxes
Printing project data 1-53

Frame window
In Camera application 22-11

Frames
Adding keyframes 4-2
Blending data 8-23
Calculating frame data for Attach to 

Object function 4-8
Calculating frame data for Auto 

Rotate function 4-8
Calculating frame data for Look at 

Object function 4-8
Clearing all keyframes 4-2
Cycling data 8-23 to 8-24
Deleting selected keyframes 4-2
In Project window

Selecting a range 8-13

Offsetting keyframe values 4-3 to 
4-5

Recalculating all frame values 4-7
Recalculating selected frame values 

4-6
Scaling keyframe times 4-3 to 4-5
Snapping Time Selector to 8-19

Free option
In Link Type pop-up menu

In Group Link window 15-10
Frequency pop-up menu

In Import Preferences dialog box 
2-34

Front option
In Align pop-up menu

In Group Texture window 14-19
In Link Alignment Position pop-up 

menu
In Group Link window 15-9

Front View command
In Windows menu 3-7

Front View window 6-6
also see World View windows
Opening the window 3-7

G
Gap edit box

In Light Info window 11-14
Glossy control

Specular settings
In Surface Editor 18-11

Glow lights
Blending two or more 11-20
Enabling and configuring 11-15
Setting dropoff factor 11-15
Setting inner radius 11-15
Setting inside color 11-15
Setting outer radius 11-15
Setting outside color 11-15
Showing in World View windows
Using RGB interpolation 11-20

Gnome
In Group Link window 15-4

Go button
In Render Control window 9-26

Gouraud option
In Shading pop-up menu

In Group Info window 13-4
Gouraud Shade option

In Camera pop-up menu
In Render Control window 9-4

Gouraud shading
Selecting for a group 13-4
Selecting for all groups 9-4

Gravity Direction & Force edit boxes
In Mr. Nitro™ dialog box 20-10

Gravity edit boxes
In Particle Generator dialog box 

20-15
Green “Go” icon

In Project window 8-15
Grid & Scale… command

In Edit menu 2-17 to 2-19
Grid color button

In Color Preferences dialog box 2-32
Grid option

In Field Chart Preferences dialog 
box 2-22

Grids
Setting preferences 2-17 to 2-19

Camera Grid Divisions edit box 
2-18

Camera Grid Size edit box 2-18
Snapping Grid Origin and Scale 

edit boxes 2-18
World Grid Origin and Scale edit 

boxes 2-18
World Grid Pixel Limit edit box 

2-18
Snapping

Toggling on/off 5-11, 19-12
Using in the World View 

windows 6-8
Visible

Observing in Camera View 
window 7-4

Toggling on/off 5-10, 19-11
Using in the World View 

windows 6-7
Ground Level edit box

In Mr. Nitro™ dialog box 20-10
Ground Zero edit boxes

In Mr. Nitro™ dialog box 20-10
Group Color option

In Attribute pop-up menu
In Surface Editor 18-8

Group Deform command
In Tools menu 5-12

Group Deform tool
In Project window 8-26
In Tool Palette 19-13

Group Deformation window 16-1 to 
16-30

Displaying 8-26, 19-13
Opening the window 5-12, 16-3
Options… button 16-17, 16-19, 

16-21, 16-24, 16-25, 16-29
Region edit boxes 16-6
Type pop-up menu 16-11

Bend option 16-18
Bezier option 16-27 to 16-30
Bulge option 16-19 to 16-20
The ElectricImage™ Reference IX-9
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Circular Wave option 16-23 to 
16-24

Linear Wave option 16-21 to 
16-22

Scale option 16-13
Shear option 16-14
Stretch option 16-25 to 16-26
Taper option 16-16 to 16-17
Twist option 16-15

Group Info command
In File menu 1-46

Group Info window 13-1 to 13-10
Blur Intensity edit box 13-6
Blur Mode pop-up menu 13-6

Motion Vector option 13-6
None option 13-6
Point/Line option 13-6

Cast Shadow option 13-7
Center edit boxes 13-10
Color Blend option 13-7
Current Stats section 13-9 to 13-10
High Precision Shadow option 13-8
Line Size in Pixels edit box 13-8
Opening Surface Editor from 13-10
Opening the window 1-46, 13-2
Override Old Color option 13-7
Position edit boxes 13-10
Receive Shadow option 13-7
Rotation edit boxes 13-10
Scale edit boxes 13-10
Shading pop-up menu 13-3 to 13-4

Flat option 13-3
Gouraud option 13-4
Phong option 13-4
Wireframe option 13-3

Shadow Density edit box 13-8
Show Bounding Box option 13-7
Smooth Across Faces option 13-7
Super Sample option 13-7
Transparency pop-up menu 13-5

Dither option 13-5
Filter option 9-5
Filter Transparency option 13-5

Group Link window 15-1 to 15-13
Changing the area displayed in 15-6
Changing the view in 15-7
Display of gnome 15-4
Displaying 8-26, 19-15
Link Alignment Orientation pop-up 

menu 15-9
Z is X option 15-9
Z is Y option 15-9
Z Proper option 15-9

Link Alignment Position pop-up 
menu 15-9

Back option 15-9
Bottom option 15-9

Front option 15-9
Left option 15-9
Midpoint option 15-9
Right option 15-9
Top option 15-9

Link Type pop-up menu 15-10 to 
15-11

Ball Planar option 15-10
Custom… option 15-10
Cylinder option 15-10
Cylinder Planar option 15-10
Free option 15-10
Lock option 15-11
Pin option 15-11
Planar option 15-10
Slide option 15-10
Socket option 15-10
Universal option 15-10

Opening the window 5-14, 15-3
Rotation Order pop-up menu 15-8

Group Similar Sides option
In Font Model dialog box 1-21

Group Texture window 14-1 to 14-29
Align pop-up menu 14-19

Back option 14-19
Bottom option 14-19
Front option 14-19
Left option 14-19
Midpoint option 14-19
Right option 14-19
Top option 14-19

Alpha pop-up menu 14-16 to 14-18
Ambient option 14-17
Bump option 14-16
Decal option 14-16
Diffuse option 14-17
Disabled option 14-16
Edge Density option 14-18
Luminance option 14-18
Reflectivity option 14-17
Replace option 14-16
Specular option 14-17
Surface option 14-17
Transparency option 14-17

Band Angle edit box 14-26
Buffer Size edit box 14-26
Bump Factor edit box 14-27
Changing the area displayed in 

14-23
Changing the view in 14-24
Displaying 8-26, 19-14
Enable Filter option 14-21
Filter button 14-28
Height edit box 14-26
Map Filter pop-up menu 14-20

MIP option 14-20
None option 14-20

Summation option 14-20
Map Type pop-up menu 14-10

Cubic option 14-13
Cylindrical option 14-11
Flat option 14-10
Spherical option 14-12

MIP Density edit box 14-27
MIP Maximum edit box 14-27
Mirror X option 14-21
Mirror Y option 14-21
Negative Z option 14-21
Opening the window 5-13, 14-4
Position edit boxes 14-26
Radius edit box 14-26
Repeat X option 14-21
Repeat Y option 14-21
RGB pop-up menu 14-14 to 14-15

Ambient option 14-14
Diffuse option 14-14
Disabled option 14-14
Edge Density option 14-15
Luminance option 14-15
Reflectivity option 14-14
Specular option 14-14
Surface option 14-14
Transparency option 14-14

Rotation edit boxes 14-26
Scale edit boxes 14-26
Softness pop-up menu 14-20

None option 14-20
Sharp option 14-20
Soft option 14-20

Wrap Angle edit box 14-26
Group Whole Characters option

In Font Model dialog box 1-21
Group windows

Drawing Detail options 2-12 to 2-13
Group’s Linkage command

In Tools menu 5-14
Group’s Linkage tool

In Project window 8-26
In Tool Palette 19-15

Group’s Modification command
In Tools menu 5-15

Group’s Modification tool
In Tool Palette 19-16

Group’s Texture command
In Tools menu 5-13

Group’s Texture tool
In Project window 8-26
In Tool Palette 19-14

Groups
Ambient values, see Ambient option
IX-10 ElectricImage™ Animation System
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Blending colors across polygon 
edges 13-7

Changing orientation of 5-15, 19-16
Color of, see Group Color option
Deformations, see Deformations
Diffuse values, see Diffuse option
Disabling motion blur 13-6
Edge density values, see Edge Density 

option
Enabling display of extents 13-7
Enabling smooth shading 13-7
Enabling super sampling 13-7
Luminance values, see Luminance 

option
Manipulating in the World View 

windows 6-10
Opening Group Deformation 

window for 8-26, 19-13
Opening Group Link window for 

8-26, 19-15
Opening Group Texture window for 

8-26, 19-14
Orienting by rotation 13-10
Overriding original color 13-7
Pivot point

Assigning ball planar link type 
15-10

Assigning custom link types 
15-10

Assigning cylinder link type 
15-10

Assigning cylinder planar link 
type 15-10

Assigning free link type 15-10
Assigning locking link type 15-11
Assigning pin link type 15-11
Assigning planar link type 15-10
Assigning slide link type 15-10
Assigning socket link type 15-10
Assigning universal link type 

15-10
Dragging to position 15-7
Link type options 15-10 to 15-11
Positioning at back 15-9
Positioning at bottom 15-9
Positioning at front 15-9
Positioning at left side 15-9
Positioning at midpoint 15-9
Positioning at right side 15-9
Positioning at top 15-9
Positioning options 15-9
Setting rotation order 15-8

Positioning 13-10
Positioning center point 13-10
Reflections

Adding to group 14-7 to 14-8
Removing 14-9
Replacing 14-9

Using automatic environment 
14-8

Using automatic mirror 14-8
Using Image file 14-8

Reflectivity values, see Reflectivity 
option

Rotating on X axis 5-4, 19-5
Rotating on Y axis 5-5, 19-6
Rotating on Z axis 5-6, 19-7
Scaling size 5-7, 13-10, 19-8
Selecting a shading technique 13-3 

to 13-4
Selecting Flat shading for 13-3
Selecting Gouraud shading for 13-4
Selecting motion blur technique 

13-6
Selecting motion vector motion 

blur 13-6
Selecting options for re-orienting 

coordinates 15-9
Selecting Phong shading for 13-4
Selecting point/line motion blur 

13-6
Selecting transparency technique 

13-5
Selecting wireframe shading for 

13-3
Setting keyframe data 13-9 to 13-10
Setting linesize for wireframe 

rendering 13-8
Setting point/line motion blur 13-6
Setting shadow options 13-7, 13-8
Setting surface attributes 13-10
Specular values, see Specular option
Surface attributes

Resetting 2-8
Surface attributes, see Surface 

attributes
Swapping Z and X coordinates 15-9
Swapping Z and Y coordinates 15-9
Textures

Adding to group 14-5 to 14-6
Copying 14-9
Pasting 14-9
Removing 14-9
Replacing 14-9

Transparency values, see 
Transparency option

H
Halo option

In Lens Flare Plug-In dialog box 
11-18

Handle color button
In Color Preferences dialog box 2-32

Hatch Lines option

In Field Chart Preferences dialog 
box 2-24

HDTV 9-11
Height edit box

In Group Texture window 14-26
Hermite Splines option

In pop-up menu
In Camera Velocity window 17-8
In Light Velocity window 17-8
In Model Velocity window 17-8

Hide All Windows command
In Windows menu

In Camera application 22-4
Hide Motion Path command

In Tools menu 5-17
Hide Motion Path tool

In Tool Palette 19-18
Hierarchical ordering of objects 8-19
Hierarchies

Ordering objects 5-18, 8-27, 19-19
Unlinking objects 5-19, 8-27, 19-20

Hierarchy option
Flat/Hierarchy view options

In Project window 8-19
Printing project data 1-51

High Precision Shadow option
In Group Info window 13-8

Highlights, see Specular highlights
Horizontal Max edit box

Cyberware import preferences
Converting models to FACT 

format 1-29
Horizontal Min edit box

Cyberware import preferences
Converting models to FACT 

format 1-29
Horizontal option

In Focal Mode pop-up menu
In Camera Info window 10-8

Horizontal Points information
Cyberware import preferences

Converting models to FACT 
format 1-29

Horizontal Samples information
Cyberware import preferences

Converting models to FACT 
format 1-29

Horizontal Step edit box
Cyberware import preferences

Converting models to FACT 
format 1-30

Hue control
Ambient settings

In Surface Editor 18-10
Diffuse settings

In Surface Editor 18-9
The ElectricImage™ Reference IX-11
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Edge Density settings
In Surface Editor 18-15

Group Color settings
In Surface Editor 18-8

Luminance settings
In Surface Editor 18-13

Reflectivity settings
In Surface Editor 18-12

Specular settings
In Surface Editor 18-11

Transparency settings
In Surface Editor 18-14

I
Image option

In Data Folder pop-up menu
In Preview/Render Preferences 

dialog box 2-29
In Shadow Folder pop-up menu

In Preview/Render Preferences 
dialog box 2-29

Image pop-up menu
In Render Control window 9-6

IMAX option
In Aspect Ratio pop-up menu

In Render Control window 9-8
Import Model tool

In Object Palette 20-5
Import… command

In Edit menu 2-33 to 2-34
In Render Control window 9-18
Increment option

In Background pop-up menu
In Preview/Render Preferences 

dialog box 2-28
Index editing mode 8-9, 10-5, 11-10, 

13-9
Index option

Printing project data 1-51
Information command

In Windows menu
In Camera application 22-4

Information window
In Camera application 22-5 to 22-8

Inner Blast edit boxes
In Mr. Nitro™ dialog box 20-11

Inner Cone edit box
In Light Info window 11-12

Inner Radius edit box
In Light Info window 11-15

Inside Color button
In Light Info window 11-15

Intensity edit box
In Light Info window 11-11

Interlacing, see Video interlacing

Interpolate Fog RGB option
In Light Info window 11-20

Interpolate Glow RGB option
In Light Info window 11-20

Invert option
Fill options

In Project window 8-22

K
Key color button

In Color Preferences dialog box 2-32
Key Entry Pause edit box

In Drawing Preferences dialog box 
2-15

Keyframe editing mode 8-7, 10-5, 
11-10, 13-9

Keyframe menu 4-1 to 4-8
Add Keyframe command 4-2
Calculate Auto Frames command 

2-10, 4-8
Clear All Keyframes command 4-2
Delete Keyframe command 4-2
Offset Keyframes command 4-3 to 

4-5
Recalculate All Frames command 

4-7
Recalculate Selected Frames 

command 4-6
Keyframe option

Printing project data 1-51
Keyframe… command

In Edit menu 2-9 to 2-10
Keyframes

Adding by command 4-2
Changing timing of 17-7
Clearing all frames 4-2
Deleting selected frames 4-2
Icons in Project window 8-15
Offsetting values 4-3 to 4-5
Recalculating data for all frames 4-7
Recalculating data for selected 

frames 4-6
Scaling times 4-3 to 4-5
Setting preferences 2-9 to 2-10

Compute Attach/Lookat/Rotate 
Automatically option 2-10

Motion Path Segments edit box 
2-10

Path Velocity Calculation 
Maximum Deviation edit 
box 2-10

L
Left option

In Align pop-up menu

In Group Texture window 14-19
In Link Alignment Position pop-up 

menu
In Group Link window 15-9

Lens flare
Dealing with obscuring objects 

11-16
Enabling and configuring 11-16 to 

11-19
Enabling halo 11-18
Enabling origin glow ring 11-18
Enabling outer glow ring 11-18
Enabling ring elements 11-18
Enabling streak elements 11-19
Selecting anamorphic lens 11-17
Selecting available plug-ins 11-16
Selecting options 11-16
Selecting spherical lens 11-17
Selecting type of lens 11-17
Setting angle of streak rotation 

11-17
Setting aspect ratio for anamorphic 

lens 11-17
Setting intensity 11-19
Setting ring contrast 11-18
Setting ring intensity 11-18
Setting ring scale 11-17
Setting rings to gray scale 11-18
Setting streak contrast 11-19
Setting streak intensity 11-18
Setting streak scale 11-18
Setting streaks to gray scale 11-19
Showing in Camera View window 

11-9
Lens Reflections option

In Lens Flare Plug-In dialog box 
11-18

Lens Type pop-up menu
In Lens Flare Plug-In dialog box 

11-17
Lens-Flare Plug-In dialog box

Anamorphic radio button 11-17
Aspect Ratio edit box 11-17
Halo option 11-18
Lens Reflections option 11-18
Lens Type pop-up menu 11-17
Origin Glow option 11-18
Outer Glow option 11-18
Remove Ring Tint option 11-18
Remove Streak Tint option 11-19
Ring Contrast edit box 11-18
Ring Intensity edit box 11-18
Ring Scale edit box 11-17
Rotation edit box 11-17
Spherical radio button 11-17
Streak Contrast edit box 11-19
Streak Intensity edit box 11-18
IX-12 ElectricImage™ Animation System
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Streak Scale edit box 11-18
Streaks option 11-19
Use Light Intensity option 11-19

Light color button
In Light Info window 11-11

Light Info command
In File menu 1-46

Light Info window 11-1 to 11-20
Blend Glow option 11-20
Buffer Size edit box 11-13
Calculate Shadow Only Once 

option 11-13
Current Stats section 11-10 to 11-12
Dropoff edit box 11-11
Enable Fog option 11-15
Enable Glow option 11-15
Enable Highlight option 11-20
Enable Obscuration option 11-16
Enable Shadow option 11-13
Factor edit box 11-12, 11-15
Flare pop-up menu 11-16
Gap edit box 11-14
Icon display options 11-7 to 11-9
Inner Cone edit box 11-12
Inner Radius edit box 11-15
Inside Color button 11-15
Intensity edit box 11-11
Interpolate Fog RGB option 11-20
Interpolate Glow RGB option 11-20
Light color button 11-11
Light Modes pop-up menu 11-4

Ambient option 11-5
Camera option 11-4
Parallel option 11-4
Radial option 11-4
Spot option 11-5
Tube option 11-6

Opening the window 1-46, 11-3
Option… button 11-16
Outer Cone edit box 11-12
Outer Radius edit box 11-15
Outside Buffer Area in Shadow 

option 11-13
Outside Color button 11-15
Position edit boxes 11-12
Reference edit boxes 11-12
Samples edit box 11-14
Show Angle option 11-7
Show Dropoff option 11-8
Show Flare option 11-9
Show Fog Radius option 11-8
Show Glow Radius option 11-8
Show Size option 11-9
Size edit box 11-11
Smoothing edit box 11-14
Softness edit box 11-14
Transition edit box 11-14

Light Modes pop-up menu
In Light Info window 11-4

Light Velocity command
In Windows menu 3-11

Light Velocity window 17-1 to 17-10
Acceleration control 17-7
Displaying data channels 17-4
Opening the window 3-11, 17-3
Setting the size of 17-5
Timing control 17-7
Velocity control 17-7

Lights
Adding to project 1-16, 20-4
Angle

Showing in World View windows 
11-7

Changing acceleration of 17-7
Changing velocity of 17-7
Clearing from projects 2-5
Dropoff

Showing in World View windows 
11-8

Duplicating 2-7
Enabling fog lights 11-15
Enabling glow lights 11-15
Enabling shadows from 11-13
Enabling specular highlight 11-20
Finding in projects 2-6 to 2-7
Fog lights, see Fog lights
Glow lights, see Glow lights
Lens flare, see Lens flare
Manipulating in the World View 

windows 6-11
Positioning 11-12
Positioning the reference point 

11-12
Selecting 2-6
Selecting ambient mode 11-5
Selecting camera mode 11-4
Selecting light type for 11-4
Selecting parallel mode 11-4
Selecting radial mode 11-4
Selecting spot mode 11-5
Selecting tube mode 11-6
Setting color 11-11
Setting dropoff distance 11-11
Setting intensity 11-11
Setting keyframe data 11-10 to 

11-12
Setting lens flare 11-16 to 11-19
Setting shadows 11-13 to 11-14
Setting size 11-11
Size

Showing in World View windows 
11-9

Spot mode
Setting falloff 11-12

Setting inner cone diameter 
11-12

Setting outer cone diameter 11-12
Velocity graphs for 17-10

Line Size in Pixels edit box
In Group Info window 13-8

Linear option
In Fog Mode pop-up menu

In Render Control window 9-9
Linear Splines option

In pop-up menu
In Camera Velocity window 17-8
In Light Velocity window 17-8
In Model Velocity window 17-8

Linear Wave option
In Type pop-up menu

In Group Deformation window 
16-21 to 16-22

Link Alignment Orientation pop-up 
menu

In Group Link window 15-9
Link Alignment Position pop-up menu

In Group Link window 15-9
Link to Parent command

In Tools menu 5-18
Link to Parent tool

In Project window 8-27
In Tool Palette 19-19

Link Type pop-up menu
In Group Link window 15-10 to 

15-11
Location Palette 21-1 to 21-2

Configuring the palette 21-2
Opening the palette 3-3, 21-2

Location Palette command
In Windows menu 3-3

Lock option
In Link Type pop-up menu

In Group Link window 15-11
Look at Object command

In Tools menu 5-20 to 5-21
Look at Object function

Applying 5-20 to 5-21, 8-27, 19-21 
to 19-22

Automatic frame calculation 4-8
Canceling 5-22, 8-28, 19-23
Setting auto frame options 2-10

Look at Object tool
In Project window 8-27
In Tool Palette 19-21 to 19-22

Loop option
In Sound Info window 12-3

Loop Time edit box
In Mesh Generator dialog box 20-7

Luminance control
Luminance settings
The ElectricImage™ Reference IX-13
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In Surface Editor 18-13
Luminance option

In Alpha pop-up menu
In Group Texture window 14-18

In Attribute pop-up menu
In Surface Editor 18-13

In RGB pop-up menu
In Group Texture window 14-15

M
Map Filter pop-up menu

In Group Texture window 14-20
Map Type pop-up menu

In Group Texture window 14-10
Match Colors radio button

In Import Model dialog box 1-25
Match Edges radio button

In Import Model dialog box 1-26
Max Angle edit box

In Font Model dialog box 1-18
Max edit box

For Adaptive Sampling Thresholds
In Render Control window 9-12

Maximum Particles edit box
In Particle Generator dialog box 

20-14
Merge Edges option

In Import Model dialog box 1-26
Merge Polygons option

In Import Model dialog box 1-25
Mesh Generator plug-in

Adding to project 1-31, 20-6 to 20-8
Mesh Generator dialog box

Loop Time edit box 20-7
Mesh Type pop-up menu 20-7

Breathing Cylinder option 20-7
Flat option 20-7
Screw Thread option 20-7
Sine Wave option 20-7
Sphere Wrap option 20-7

Scale edit boxes 20-8
U Points edit box 20-7
V Points edit box 20-7

Options 20-7
Selecting a breathing cylinder 20-7
Selecting a flat mesh grid 20-7
Selecting a plane-to-sphere 

animation 20-7
Selecting a screw thread animation 

20-7
Selecting animated circular waves 

20-7
Setting horizontal grid segments 

20-7
Setting object scale 20-8

Setting transformation duration 
20-7

Setting vertical grid segments 20-7
Mesh Generator tool

In Object Palette 20-6 to 20-8
Mesh Type pop-up menu

In Mesh Generator dialog box 20-7
Microsoft Excel

Pasting data from 2-4
Midpoint option

In Align pop-up menu
In Group Texture window 14-19

In Link Alignment Position pop-up 
menu

In Group Link window 15-9
Min edit box

For Adaptive Sampling Thresholds
In Render Control window 9-12

MIP Density edit box
In Group Texture window 14-27

MIP Enable option
In Render Control window 9-17

MIP mapping
Enabling/Disabling for project 9-17

MIP Maximum edit box
In Group Texture window 14-27

MIP option
In Map Filter pop-up menu

In Group Texture window 14-20
Mirror X option

In Group Texture window 14-21
Mirror Y option

In Group Texture window 14-21
Model Velocity command

In Windows menu 3-12
Model Velocity window 17-1 to 17-11

Acceleration control 17-7
Displaying data channels 17-4
Opening the window 3-12, 17-3
Setting the size of 17-5
Timing control 17-7
Velocity control 17-7

Models
Adding non-FACT to project 1-22 to 

1-30
Adding to project 1-4 to 1-6, 1-12 to 

1-13, 20-4
Changing acceleration of 17-7
Changing velocity of 17-7
Clearing from projects 2-5
Converting to FACT format 1-4 to 

1-5, 1-22 to 1-30, 20-5
Alias Sketch! import preferences 

1-28
Surface Edges edit box 1-28

Combine Coordinates option 
1-26

Combine Groups option 1-25
Combine Polygons option 1-25
Cyberware import preferences 

1-29 to 1-30
Average Points option 1-30
Build Quadrangles option 1-30
Build Triangles option 1-30
Data Format information 1-30
Data Offset edit box 1-30
Data Scale edit box 1-30
Horizontal Max edit box 1-29
Horizontal Min edit box 1-29
Horizontal Points information

1-29
Horizontal Samples informa-

tion 1-29
Horizontal Step edit box 1-30
Sample Points option 1-30
Strip Bad Points option 1-30
Vertical Max edit box 1-30
Vertical Min edit box 1-30
Vertical Points information 

1-29
Vertical Samples information 

1-29
Vertical Step edit box 1-30

DXF import preferences 1-27
Build Groups From option 1-27
Convert Polylines To option

1-27
Exchange Y and Z Coordinates

option 1-27
Fix Cone Point Shading option 

1-26
Fix Smooth Shading option 1-26
Flat Complex Polygons option 

1-26
Match Colors radio button 1-25
Match Edges radio button 1-26
Merge Edges option 1-26
Merge Polygons option 1-25
Preferences pop-up menu 1-27

Duplicating 2-7
Finding in projects 2-6 to 2-7
Import file formats 1-23
Saving as FACT 1-35
Saving as non-FACT 1-36 to 1-40
Saving to non-FACT formats

Breakup Concave Polygons 
option 1-38

DXF export preferences 1-39
3DFACE option 1-39
Decimal Digits edit box 1-40
IX-14 ElectricImage™ Animation System
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Exchange Y and Z Coordinates
option 1-40

Output Polygons As options
1-39

POLYLINE option 1-39
Text Format options 1-39

Output Edges as Lines option 
1-38

Output Lines option 1-38
Output Points option 1-38
Output Polygons option 1-38
Output Vertices as Points option 

1-38
Side Limit edit box 1-39

Selecting 2-6
Setting import preferences 2-33 to 

2-34
Default Inherit Deformation 

option 2-34
Default Inherit Position option 

2-34
Default Inherit Rotation option 

2-34
Default Inherit Scale option 2-34
Default Inherit Visibility option 

2-34
Structuring groups within 1-6
Velocity graphs for 17-11

Modify In pop-up-menu
In Surface Editor 18-16

Monitor command
In Windows menu

In Camera application 22-4
Monitor window

In Camera application 22-9
Motion blur

Disabling for groups 13-6
Motion Vector technique

Selecting for groups 13-6
Selecting for project 9-14
Setting blur samples per pixel 

9-14
Multi-Frame technique

Selecting for project 9-14
Setting blur samples per frame 

9-15
Point/Line technique

Selecting for groups 13-6
Selecting for project 9-13
Setting blur intensity for groups 

13-6
Setting blur intensity for project 

9-13
Setting for the project 9-13 to 9-15
Setting shutter opening angle 9-13
Technique options for groups 13-6

Motion Path Segments edit box

In Keyframes Preferences dialog box 
2-10

Motion paths
also see Splines
Editing in the World View windows 

6-12
Hiding 19-18
Hiding in World View windows 

5-17
Showing 19-17
Showing in World View windows 

5-16
Spline options

In Camera Velocity window 17-8
In Light Velocity window 17-8
In Model Velocity window 17-8

Motion Vector option
In Blur Mode pop-up menu

In Group Info window 13-6
In Render Control window 9-14

Mouse Drag Pause edit box
In Drawing Preferences dialog box 

2-15
Move command

In Tools menu 5-3
Move tool

In Tool Palette 19-4
Mr. Nitro™ plug-in

Adding to project 1-32, 20-9 to 
20-12

Mr. Nitro™ dialog box
% edit box 20-11
Age color buttons 20-12
Air Resistance edit box 20-10
Blast Time edit box 20-10
Dissolve edit box 20-11
Force edit box 20-11
Fragment Color option 20-12
Fragment Shape edit boxes 20-12
Fragment Size edit boxes 20-11
Gravity Direction & Force edit 

boxes 20-10
Ground Level edit box 20-10
Ground Zero edit boxes 20-10
Inner Blast edit boxes 20-11
Outer Blast edit boxes 20-11
Rotation edit box 20-11
Speed edit box 20-11
Turbulence edit box 20-11

Setting air resistance 20-10
Setting blast time 20-10
Setting fragment color 20-12
Setting fragment color over time 

20-12
Setting fragment dissolve time 

20-11
Setting fragment rotation 20-11

Setting fragment shape 20-12
Setting fragment size 20-11
Setting ground plane 20-10
Setting initial shockwave 20-11
Setting percentage difference 

between initial and secondary 
shockwaves 20-11

Setting secondary shockwave 20-11
Setting shockwave direction and 

force 20-10
Setting shockwave force 20-11
Setting shockwave origin 20-10
Setting shockwave speed 20-11
Setting shockwave turbulence 20-11

Mr. Nitro™ tool
In Object Palette 20-9 to 20-12

Multi-Frame option
In Render Control window 9-14

N
Natural Cubic Splines option

In pop-up menu
In Camera Velocity window 17-8
In Light Velocity window 17-8
In Model Velocity window 17-8

Negative Z option
In Group Texture window 14-21

New Particles Per Second edit box
In Particle Generator dialog box 

20-14
New… command

In File menu 1-3 to 1-6
None option

In Anti-Aliasing pop-up menu
In Render Control window 9-12

In Background pop-up menu
In Preview/Render Preferences 

dialog box 2-28
In Blur Mode pop-up menu

In Group Info window 13-6
In Map Filter pop-up menu

In Group Texture window 14-20
In Softness pop-up menu

In Group Texture window 14-20
Snap to frame options

In Project window 8-19
Notes box

In Sound Info window 12-5
Nth Frame edit box

In Render Control window 9-24
Nth Frame option

In Render Control window 9-24
NTSC 8-14, 9-11, 9-24
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NTSC:30 option
In FPS pop-up menu

In Project window 8-14
In Render Control window 9-24

NTSC:30i option
In FPS pop-up menu

In Project window 8-14
Number display

Setting preferences
Real Number Display Precision 

Fractional Digits edit box 
2-18

O
Object Palette 20-1 to 20-18

Add Font tool 20-5
Add Light tool 20-4
Add Model tool 20-4
Add Sound tool 20-4
Configuring the palette 20-3
Import Model tool 20-5
Mesh Generator tool 20-6 to 20-8
Mr. Nitro™ tool 20-9 to 20-12
Opening the palette 3-4, 20-3
Particle Generator tool 20-13 to 

20-16
Record Sound tool 20-5
Standard Shapes tool 20-17 to 20-18

Object Palette command
In Windows menu 3-4

Offset Keyframes command
In Keyframe menu 4-3 to 4-5

Offset Repeat option
Cycling options

In Project window 8-24
Offset… Selected option

Fill options
In Project window 8-22

Opacity control
Edge Density settings

In Surface Editor 18-15
Transparency settings

In Surface Editor 18-14
Open All option

Open/Close options
In Project window 8-21

Open Animated option
Open/Close options

In Project window 8-21
Open Root option

Open/Close options
In Project window 8-21

Open Selected All option
Open/Close options

In Project window 8-21
Open Selected Animated option

Open/Close options
In Project window 8-21

Open Selected Root option
Open/Close options

In Project window 8-21
Open… command

In File menu 1-7 to 1-9
Option… button

In Light Info window 11-16
Options… button

In Group Deformation window 
16-17, 16-19, 16-21, 16-24, 
16-25, 16-29

Order View By menu options
Printing project data 1-51

Orientation radio buttons
In Standard Shapes dialog box 20-18

Origin Glow option
In Lens Flare Plug-In dialog box 

11-18
Oscillate option

Cycling options
In Project window 8-24

Outer Blast edit boxes
In Mr. Nitro™ dialog box 20-11

Outer Cone edit box
In Light Info window 11-12

Outer Glow option
In Lens Flare Plug-In dialog box 

11-18
Outer Radius edit box

In Light Info window 11-15
Output Edges as Lines option

Saving models to non-FACT formats 
1-38

Output Lines option
Saving models to non-FACT formats 

1-38
Output Points option

Saving models to non-FACT formats 
1-38

Output Polygons as options
DXF export preferences

Saving models to non-FACT 
formats 1-39

Output Polygons option
Saving models to non-FACT formats 

1-38
Output pop-up menu

In Preview/Render Preferences 
dialog box 2-27

Output Vertices as Points option
Saving models to non-FACT formats 

1-38
Outside Buffer Area in Shadow option

In Light Info window 11-13
Outside Color button

In Light Info window 11-15
Override Old Color option

In Group Info window 13-7
Oversample option

In Anti-Aliasing pop-up menu
In Render Control window 9-12

P
Page Setup… command

In File menu 1-49
PAL 8-14, 9-11, 9-25
PAL:25 option

In FPS pop-up menu
In Project window 8-14
In Render Control window 9-25

PAL:25i option
In FPS pop-up menu

In Project window 8-14
Parallel lights

Selecting for lights 11-4
Parallel option

In Light Modes pop-up menu
In Light Info window 11-4

Parent objects
Linking to 5-18, 8-27, 19-19
Removing parentage 5-19, 8-27, 

19-20
Particle Generator plug-in

Adding to project 1-33, 20-13 to 
20-16

Particle Generator dialog box
Air Resistance edit box 20-15
Bounce Factor edit box 20-15
Bounce Friction edit box 20-16
Create Particles From Time edit 

boxes 20-14
Deviation Angle edit box 20-15
Energy color buttons 20-16
Gravity edit boxes 20-15
Maximum Particles edit box 

20-14
New Particles Per Second edit box 

20-14
Particle Life Time edit box 20-14
Velocity edit boxes 20-15
X Direction edit box 20-14
X Position edit box 20-14
Y Direction edit box 20-14
Y Ground Level edit box 20-15
Y Position edit box 20-14
Z Direction edit box 20-15
Z Position edit box 20-15

Setting air resistance 20-15
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Setting direction vector deviation 
20-15

Setting direction vector X 
coordinate 20-14

Setting direction vector Y 
coordinate 20-14

Setting direction vector Z 
coordinate 20-15

Setting emission point X coordinate 
20-14

Setting emission point Y coordinate 
20-14

Setting emission point Z coordinate 
20-15

Setting gravity force and direction 
20-15

Setting ground plane 20-15
Setting number of new particles per 

second 20-14
Setting number of particles 20-14
Setting particle bounce 20-15, 20-16
Setting particle color over time 

20-16
Setting particle duration 20-14
Setting particle generation start/end 

times 20-14
Setting particle velocity 20-15

Particle Generator tool
In Object Palette 20-13 to 20-16

Particle Life Time edit box
In Particle Generator dialog box 

20-14
Paste command

In Edit menu 2-4
Path Velocity Calculation Maximum 

Deviation edit box
In Keyframes Preferences dialog box 

2-10
Pause button

In Sound Info window 12-3
Pause command

In File menu
In Camera application 22-3

Phong option
In Shading pop-up menu

In Group Info window 13-4
Phong Shade option

In Camera pop-up menu
In Render Control window 9-4

Phong shading
Selecting for a group 13-4
Selecting for all groups 9-4

Picture Cache edit box
In Drawing Preferences dialog box 

2-14
Pin option

In Link Type pop-up menu
In Group Link window 15-11

Pivot points
Assigning ball planar link type to 

15-10
Assigning custom link types to 

15-10
Assigning cylinder link type to 

15-10
Assigning cylinder planar link type 

to 15-10
Assigning free link type to 15-10
Assigning link types to 15-10 to 

15-11
Assigning locking link type to 15-11
Assigning pin link type to 15-11
Assigning planar link type to 15-10
Assigning slide link type to 15-10
Assigning socket link type to 15-10
Assigning universal link type to 

15-10
Dragging to position 15-7
In Group Link window 15-7
Positioning 15-9
Positioning at back of group 15-9
Positioning at bottom of group 15-9
Positioning at front of group 15-9
Positioning at left side of group 15-9
Positioning at midpoint of group 

15-9
Positioning at right side of group 

15-9
Positioning at top of group 15-9
Setting rotation order 15-8

Pixel Ratio edit box
In Render Control window 9-11

Pixel Shaded option
In Detail pop-up menu

In Preview/Render Preferences 
dialog box 2-27

Planar option
In Link Type pop-up menu

In Group Link window 15-10
Play back immediately option

In Preview/Render Preferences 
dialog box 2-28

Play button
In Sound Info window 12-3

Point/Line option
In Blur Mode pop-up menu

In Group Info window 13-6
In Render Control window 9-13

Point/Line Thickness edit box
In Render Control window 9-19

Polygon Shaded option
In Detail pop-up menu

In Preview/Render Preferences 
dialog box 2-27

Polygons option
In Detail pop-up menu

In Preview/Render Preferences 
dialog box 2-27

POLYLINE option
DXF export preferences

Saving models to non-FACT 
formats 1-39

Position edit boxes
In Group Info window 13-10
In Group Texture window 14-26
In Light Info window 11-12

Position option
Custom view options

In Project window 8-20
Printing project data 1-52

Preferences
Return to default settings 2-37

Preferences pop-up menu
In Import Model dialog box 1-27

Preview/Render… command
In Edit menu 2-26 to 2-30

Previews
Initiating in the Camera View 

window 7-9 to 7-10
Setting preferences 2-26 to 2-28

Background pop-up menu 2-28
Detail pop-up menu 2-27
Extents option 2-27
Increment option 2-28
None option 2-28
Output pop-up menu 2-27
Pixel Shaded option 2-27
Play Back Immediately option 

2-28
Polygon Shaded option 2-27
Polygons option 2-27
Still option 2-28
To Image option 2-27
To QuickTime option 2-27
To Screen option 2-27

Print command
In File menu 1-50 to 1-53

Printing project data 1-50 to 1-53
Page setup 1-49
Preferences 1-51 to 1-53

All Frames option 1-51
All option 1-52
Cell Size edit boxes 1-53
Color option 1-52
Custom… option 1-52
Element menu options 1-52
Flat option 1-51
Frame option 1-51
Frame Range edit boxes 1-53
The ElectricImage™ Reference IX-17
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Hierarchy option 1-51
Index option 1-51
Keyframe option 1-51
Order View By menu options 

1-51
Position option 1-52
Rotation option 1-52
Scale option 1-52
Selected Objects Only option 

1-51
Show View Of menu options 1-51
Time option 1-51
Use Project Cell Size option 1-51
Use Project Window option 1-51
View By menu options 1-52

Project File… command
In Edit menu 2-35 to 2-36

Project option
In Data Folder pop-up menu

In Preview/Render Preferences 
dialog box 2-29

In Shadow Folder pop-up menu
In Preview/Render Preferences 

dialog box 2-29
Project window 8-1 to 8-30

Attach to Object tool 8-28
Auto Rotate Object tool 8-29
Cancel Auto Rotate tool 8-29
Cancel Look At tool 8-28
Detach from Object tool 8-28
Displaying data 8-20
Displaying data channels 8-30
Editing data 8-11 to 8-12

Editing cell data 8-11
Renaming objects 8-12

FPS pop-up menu 8-14
Custom… option 8-14
Film:24 option 8-14
NTSC:30 option 8-14
NTSC:30i option 8-14
PAL:25 option 8-14
PAL:25i option 8-14

Green “Go” icon 8-15
Group Deform tool 8-26
Group’s Linkage tool 8-26
Group’s Texture tool 8-26
Keyframe icons 8-15
Link to Parent tool 8-27
Look at Object tool 8-27
Opening the window 3-9, 8-4
Pop-up menus 8-19 to 8-25

Blend options 8-23
Blend Curve option 8-23
Blend Linear option 8-23

Cell size options 8-21
Custom view options 8-20

All option 8-20

Color option 8-20
Custom… option 8-20
Position option 8-20
Scale option 8-20

Cycling options 8-23 to 8-24
Offset Repeat option 8-24
Oscillate option 8-24
Repeat option 8-24

Fill options 8-22
Fill Constant… option 8-22
Fill Selected option 8-22
Invert option 8-22
Offset… option 8-22
Scale… option 8-22

Flat/Hierarchy view options 8-19
Flat option 8-19
Hierarchy option 8-19

Open/Close options
Close All option 8-21
Close Selected All option 8-21
Open All option 8-21
Open Animated option 8-21
Open Root option 8-21
Open Selected All option 8-21
Open Selected Animated op-

tion 8-21
Open Selected Root option 8-21
Show/Hide Children option

8-21
Open/close options 8-21
Rendering options 8-25

All Frames option 8-25
Every Nth Frame… option 8-25
Range of Frames option 8-25

Snap to frame options 8-19
None option 8-19
Snap to Frame option 8-19
Snap to Keyframe option 8-19

Red “Stop” icon 8-15
Resizing 8-10
Scrolling 8-10
Selecting a range of frames 8-13
Selecting editing modes 8-5
Selection lock 8-17
Setting event timing 8-15 to 8-16
Sound tool 8-26
Time Selector 8-15
Unlink from Parent tool 8-27
Visibility control 8-17

Project Window command
In Windows menu 3-9

Projector application
Transferring to 1-56

Projector command

In File menu 1-56
Projects

Adding font models to 1-17 to 1-21, 
20-5

Adding lights to 1-16, 20-4
Adding models to 1-12 to 1-13, 20-4
Adding Mr. Nitro™ to 1-32, 20-9 to 

20-12
Adding non-FACT models to 1-22 to 

1-30, 20-5
Adding sounds to 1-14, 20-4
Adding Standard Shapes to 1-34, 

20-17 to 20-18
Adding the Mesh Generator to 1-31, 

20-6 to 20-8
Adding the Particle Generator to 

1-33, 20-13 to 20-16
Applying fog to 9-9 to 9-10
Clearing objects from 2-5
Closing 1-10
Collecting files from 1-44
Creating new 1-3 to 1-6
Disabling anti-aliasing 9-12
Duplicating objects in 2-7
Finding objects in 2-6 to 2-7
Opening existing 1-7 to 1-9
Printing data from 1-50 to 1-53
Quitting 1-57
Recording sounds into 1-15, 20-5
Rendering 1-54 to 1-55

Camera application 22-1 to 22-11
Saving 1-41
Saving a copy 1-42, 1-43
Selecting adaptive anti-aliasing 9-12
Selecting all objects in 2-6
Selecting anti-aliasing for 9-12
Selecting aspect ratio for 9-7 to 9-8
Selecting flat shading for 9-4
Selecting global shading technique 

9-4
Selecting global transparency 

technique 9-5
Selecting Gouraud shading for 9-4
Selecting image depth for 9-6
Selecting image resolution for 9-11
Selecting oversample anti-aliasing 

9-12
Selecting Phong shading for 9-4
Selecting wireframe shading for 9-4
Setting 16mm aspect ratio for 9-8
Setting 35mm aspect ratio for 9-8
Setting 35mm full frame vertical 

aspect ratio for 9-8
Setting 65mm aspect ratio for 9-8
Setting 70mm aspect ratio for 9-8
Setting adaptive anti-aliasing 

thresholds 9-12
IX-18 ElectricImage™ Animation System
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Setting computer screen aspect ratio 
for 9-7

Setting custom aspect ratio for 9-7
Setting file storage preferences 2-35 

to 2-36
Store Display Data option 2-36
Store Project Window Content 

option 2-36
Store Sound Data option 2-36

Setting frames per second to be 
rendered 8-14, 9-24 to 9-25

Setting image resolution for 9-11
Setting IMAX aspect ratio for 9-8
Setting motion blur for 9-13 to 9-15
Setting number of frames to be 

rendered 9-23
Setting pattern of frames to be 

rendered 9-24
Setting pixel aspect ratio for 9-11
Setting start time for frames to be 

rendered 9-23
Setting stop time for frames to be 

rendered 9-23
Setting Super 16mm aspect ratio for 

9-8
Setting Super 8mm aspect ratio for 

9-7
Setting TechniScope aspect ratio for 

9-8
Setting VistaVision aspect ratio for 

9-8
Viewing statistics from 1-48

Q
QuickTime movies

Displaying 1-11
Quit command

In File menu 1-57
In Camera application 22-3

R
Radial lights

Selecting for lights 11-4
Radial option

In Light Modes pop-up menu
In Light Info window 11-4

Radius edit box
In Group Texture window 14-26

Range of Frames option
In Render pop-up menu

In Render Control window 9-25
Rendering options

In Project window 8-25
Rate control

In Sound Info window 12-3

Real Number Display Precision 
Fractional Digits edit box

In Grid & Scale Preferences dialog 
box 2-18

Recalculate All Frames command
In Keyframe menu 4-7

Recalculate Selected Frames command
In Keyframe menu 4-6

Receive Shadow option
In Group Info window 13-7

Record Sound tool
In Object Palette 20-5

Red “Stop” icon
In Project window 8-15

Reference edit boxes
In Camera Info window 10-6
In Light Info window 11-12

Reference path color button
In Color Preferences dialog box 2-32

Reflection maps, see Reflections
Reflections

Adding to Groups 14-7 to 14-8
Enabling/Disabling for project 9-16
Environment

Adding to groups 14-8
Setting buffer size 14-26

Image file
Adding to groups 14-8

Mirror
Adding to groups 14-8

Removing from groups 14-9
Replacing 14-9

Reflections option
In Render Control window 9-16

Reflectivity option
In Alpha pop-up menu

In Group Texture window 14-17
In Attribute pop-up menu

In Surface Editor 18-12
In RGB pop-up menu

In Group Texture window 14-14
Region edit boxes

In Group Deformation window 16-6
Remove Ring Tint option

In Lens Flare Plug-In dialog box 
11-18

Remove Streak Tint option
In Lens Flare Plug-In dialog box 

11-19
Render Control window 9-1 to 9-26

Adaptive Sampling Thresholds
Max edit box 9-12
Min edit box 9-12

Add Noise option 9-17
Ambient color button 9-19
Ambient option 9-16

Anti-Aliasing pop-up menu 9-12
Adaptive option 9-12
None option 9-12
Oversample option 9-12

Aspect Ratio pop-up menu 9-7 to 
9-8

16mm option 9-8
35mm Full option 9-8
35mm option 9-8
65mm option 9-8
70mm option 9-8
Computer option 9-7
Custom… option 9-7
IMAX option 9-8
Super 16mm option 9-8
Super 8mm option 9-7
TechniScope option 9-8
VistaVision option 9-8

Background color button 9-19
Background Image button 9-20 to 

9-22
Background option 9-16
Blur Frames edit box 9-15
Blur Intensity edit box 9-13
Blur Noise edit box 9-14
Camera pop-up menu 9-4

Flat Shade option 9-4
Gouraud Shade option 9-4
Phong Shade option 9-4
Wireframe Shade option 9-4

Color Blend option 9-16
Enable Shadow option 9-16
Fog color button 9-19
Fog Mode pop-up menu 9-9

Exponential option 9-9
Linear option 9-9

Fog option 9-16
Fog Radius edit boxes 9-10
Fog To pop-up menu 9-9

Alpha option 9-9
Background option 9-9
Color option 9-9

FPS pop-up menu 9-24 to 9-25
Custom… option 9-24
Film:24 option 9-25
NTSC:30 option 9-24
PAL:25 option 9-25

Go button 9-26
Image pop-up menu 9-6

256 Colors option 9-6
256 Shades option 9-6
B&W Dithered option 9-6
B&W Filled option 9-6
B&W Lines option 9-6
B&W Summation option 9-6
True Color option 9-6

MIP Enable option 9-17
Motion Vector option 9-14
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Multi-Frame option 9-14
Nth Frame edit box 9-24
Nth Frame option 9-24
Opening the window 1-54 to 1-55
Pixel Ratio edit box 9-11
Point/Line option 9-13
Point/Line Thickness 9-19
Reflections option 9-16
Render pop-up menu 9-25

All Frames option 9-25
Current Frame option 9-25
Range of Frames option 9-25

Resolution pop-up menu 9-11
Shutter Angle edit box 9-13
Start Time edit box 9-23
Stop Time edit box 9-23
Sum Enable option 9-17
Super Sample option 9-16
Textures option 9-16
Total Frames edit box 9-23
Transparency pop-up menu 9-5

Dither option 9-5
Video interlacing

Even Field option 9-18
X edit box 9-11
Y edit box 9-11

Render pop-up menu
In Render Control window 9-25

Render… command
In File menu 1-54 to 1-55

Rendering
All frames 9-25
Camera application 22-1 to 22-11
Current frame only 9-25
In 32 bit color 9-6
In 8 bit color 9-6
In black and white 9-6
In black and white, dithered 9-6
In black and white, lines only 9-6
In black and white, summation 

dithering 9-6
In gray scale 9-6
Initiating 9-26
Opening the Render Control 

window 1-54 to 1-55
Range of frames 9-25
Selecting frames to render 8-25, 

9-25
Setting 24 FPS for film standard 

8-14, 9-25
Setting 25 FPS for PAL standard 

8-14, 9-25
Setting 30 FPS for NTSC standard 

8-14, 9-24
Setting custom FPS 8-14, 9-24
Setting frames per second to be 

rendered 8-14, 9-24 to 9-25

Setting number of frames to be 
rendered 9-23

Setting pattern of frames to be 
rendered 9-24

Setting preferences 2-26 to 2-30
Camera option 2-29
Custom option 2-29
Data Folder pop-up menu 2-29
Image option 2-29
Project option 2-29
Shadow Folder pop-up menu 2-29
Transparency Layers edit box 

2-30
Setting start time for frames to be 

rendered 9-23
Setting stop time for frames to be 

rendered 9-23
Repeat option

Cycling options
In Project window 8-24

Repeat X option
In Group Texture window 14-21

Repeat Y option
In Group Texture window 14-21

Replace option
In Alpha pop-up menu

In Group Texture window 14-16
Resolution pop-up menu

In Render Control window 9-11
Reverse Back Bevel option

In Font Model dialog box 1-20
Revert command

In Edit menu 2-8
RGB controls

Ambient settings
In Surface Editor 18-10

Diffuse settings
In Surface Editor 18-9

Edge Density settings
In Surface Editor 18-15

Group Color settings
In Surface Editor 18-8

Luminance settings
In Surface Editor 18-13

Reflectivity settings
In Surface Editor 18-12

Specular settings
In Surface Editor 18-11

Transparency settings
In Surface Editor 18-14

RGB pop-up menu
In Group Texture window 14-14 to 

14-15
Right option

In Align pop-up menu
In Group Texture window 14-19

In Link Alignment Position pop-up 
menu

In Group Link window 15-9
Ring Contrast edit box

In Lens Flare Plug-In dialog box 
11-18

Ring Intensity edit box
In Lens Flare Plug-In dialog box 

11-18
Ring Scale edit box

In Lens Flare Plug-In dialog box 
11-17

Rotation edit box
In Lens Flare Plug-In dialog box 

11-17
In Mr. Nitro™ dialog box 20-11

Rotation edit boxes
In Group Info window 13-10
In Group Texture window 14-26

Rotation option
Custom view options

In Project window 8-20
Printing project data 1-52

Rotation Order pop-up menu
In Group Link window 15-8

Rotation window
Pop-up menus

Custom view options
Rotation option 8-20

Rotoscoping
Observing object overlay in the 

Camera View window 7-11
Ruler Bar Style pop-up menu

In Grid & Scale Preferences dialog 
box 2-19

Ruler Bar Subdivisions and Minimum 
Divisions edit boxes

In Grid & Scale Preferences dialog 
box 2-19

Rulers
Displaying 3-14
Setting preferences

Ruler Bar Style pop-up menu 2-19
Ruler Bar Subdivisions and 

Minimum Divisions edit 
boxes 2-19

Start Windows with Rulers option 
2-19

Using in the World View windows 
6-8

S
Sample Points option

Cyberware import preferences
Converting models to FACT 

format 1-30
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Samples edit box
In Light Info window 11-14

Saturation control
Ambient settings

In Surface Editor 18-10
Diffuse settings

In Surface Editor 18-9
Edge Density settings

In Surface Editor 18-15
Group Color settings

In Surface Editor 18-8
Luminance settings

In Surface Editor 18-13
Reflectivity settings

In Surface Editor 18-12
Specular settings

In Surface Editor 18-11
Transparency settings

In Surface Editor 18-14
Save As… command

In File menu 1-42
Save command

In File menu 1-41
Save Copy As… command

In File menu 1-43
Save Model > FACT… command

In File menu 1-35
Save Model > Other… command

In File menu 1-36 to 1-40
Scale

Setting preferences 2-17 to 2-19
Scale command

In Tools menu 5-7
Scale edit boxes

In Group Info window 13-10
In Group Texture window 14-26
In Mesh Generator dialog box 20-8

Scale option
Custom view options

In Project window 8-20
In Type pop-up menu

In Group Deformation window 
16-13

Printing project data 1-52
Scale tool

In Tool Palette 19-8
Scale… option

Fill options
In Project window 8-22

Screen Colors pop-up menu
In Drawing Preferences dialog box 

2-14
Screw Thread option

In Mesh Type pop-up menu
In Mesh Generator dialog box 

20-7

Select All command
In Edit menu 2-6

Selected Objects Only option
Printing project data 1-51

Selection lock
In Project window 8-17

Selection Start Time edit box
In Sound Info window 12-4

Selection Stop Time edit box
In Sound Info window 12-4

Shading
Flat technique

Selecting for a group 13-3
Selecting for all groups 9-4

Gouraud technique
Selecting for a group 13-4
Selecting for all groups 9-4

Phong technique
Selecting for a group 13-4
Selecting for all groups 9-4

Selecting a technique for a group 
13-3 to 13-4

Selecting global technique 9-4
Wireframe technique

Selecting for a group 13-3
Selecting for all groups 9-4

Shading Dropoff edit box
In Surface Editor 18-8

Shading pop-up menu
In Group Info window 13-3 to 13-4

Shadow Density edit box
In Group Info window 13-8

Shadow Folder pop-up menu
In Preview/Render Preferences 

dialog box 2-29
Shadows

Calculating once in scene 11-13
Creating automatic shadow area 

11-13
Enabling and configuring 11-13 to 

11-14
Enabling for lights 11-13
Enabling groups to cast 13-7
Enabling groups to receive 13-7
Enabling/Disabling for project 9-16
Setting buffer size 11-13
Setting density of 13-8
Setting edge smoothness 11-14
Setting gap 11-14
Setting precision of 13-8
Setting samples per pixel 11-14
Setting softness 11-14
Setting transition area 11-14

Shapes radio buttons
In Standard Shapes dialog box 20-18

Sharp option

In Softness pop-up menu
In Group Texture window 14-20

Shear option
In Type pop-up menu

In Group Deformation window 
16-14

Show All Windows command
In Windows menu

In Camera application 22-4
Show Angle option

In Camera Info window 10-3
In Light Info window 11-7

Show Bounding Box option
In Group Info window 13-7

Show Dropoff option
In Light Info window 11-8

Show Flare option
In Light Info window 11-9

Show Fog option
In Camera Info window 10-4

Show Fog Radius option
In Light Info window 11-8

Show Glow Radius option
In Light Info window 11-8

Show Grid while Dragging option
In Drawing Preferences dialog box 

2-15
Show Motion Path command

In Tools menu 5-16
Show Motion Path tool

In Tool Palette 19-17
Show Recorded Image option

In Drawing Preferences dialog box 
2-15

Show Size option
In Light Info window 11-9

Show Subpolygons option
In Drawing Preferences dialog box 

2-16
Show View Of menu options

Printing project data 1-51
Show/Hide Children option

Open/Close options
In Project window 8-21

Show/Hide Rulers command
In Windows menu 3-14

Shutter Angle edit box
In Render Control window 9-13

Side Limit edit box
Saving models to non-FACT formats 

1-39
Side View command

In Windows menu 3-6
Side View window 6-5

also see World View windows
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Opening the window 3-6
Sine Wave option

In Mesh Type pop-up menu
In Mesh Generator dialog box 

20-7
Size edit box

In Light Info window 11-11
Slide option

In Link Type pop-up menu
In Group Link window 15-10

Smooth Across Faces option
In Group Info window 13-7

Smooth edit box
In Font Model dialog box 1-18

Smooth shading
Enabling for groups 13-7

Smoothing edit box
In Light Info window 11-14

Snap to Frame option
Snap to frame options

In Project window 8-19
Snap to Keyframe option

Snap to frame options
In Project window 8-19

Snapping grid
Toggling on/off 5-11, 19-12

Snapping Grid command
In Tools menu 5-11

Snapping Grid Origin and Scale edit 
boxes

In Grid & Scale Preferences dialog 
box 2-18

Snapping Grid tool
In Tool Palette 19-12

Socket option
In Link Type pop-up menu

In Group Link window 15-10
Soft option

In Softness pop-up menu
In Group Texture window 14-20

Softness edit box
In Light Info window 11-14

Softness pop-up menu
In Group Texture window 14-20

Sound cues
Adding to cue list 12-5
Annotating cues 12-5
Creating and setting 12-5
Deleting from cue list 12-5
Listing 12-5
Setting duration 12-5
Setting start time 12-5

Sound Info command
In File menu 1-47

Sound Info window 12-1 to 12-5

Add button 12-5
Continue button 12-3
Cue List box 12-5
Delete button 12-5
Duration edit box 12-5
Duration Time 12-4
Loop option 12-3
Notes box 12-5
Opening the window 1-47, 12-2
Pause button 12-3
Play button 12-3
Playback controls 12-3
Rate control 12-3
Selection Start Time edit box 12-4
Selection Stop Time edit box 12-4
Starting Time edit box 12-4
Stop button 12-3
Time edit box 12-5
Timing controls 12-4
Volume control 12-3

Sound tool
In Project window 8-26

Sounds
Adding to project 1-14, 20-4
Continuing play after pause 12-3
Controlling rate of playback 12-3
Controlling volume 12-3
Cues, see Sound cues 12-5
Duration time 12-4
Looping play 12-3
Pausing play 12-3
Playback controls 12-3
Playing 12-3
Playing from Project window 8-26
Recording into project 1-15, 20-5
Selecting a portion of a soundtrack 

12-4
Selection starting time 12-4
Selection stop time 12-4
Setting import preferences 2-33 to 

2-34
Frequency pop-up menu 2-34

Starting time 12-4
Stopping play 12-3
Timing controls 12-4

Soundtracks, see Sounds
Space Clipping Minimum Z Distance 

edit box
In Grid & Scale Preferences dialog 

box 2-19
Space edit box

In Font Model dialog box 1-18
Specular Dropoff edit box

In Surface Editor 18-11
Specular edit box

In Surface Editor 18-11
Specular highlights

Enabling for lights 11-20
Setting fall-off 18-11
Setting group values 18-11
Setting highlight size 18-11

Specular option
In Alpha pop-up menu

In Group Texture window 14-17
In Attribute pop-up menu

In Surface Editor 18-11
In RGB pop-up menu

In Group Texture window 14-14
Speed edit box

In Mr. Nitro™ dialog box 20-11
Sphere Wrap option

In Mesh Type pop-up menu
In Mesh Generator dialog box 

20-7
Spherical option

In Map Type pop-up menu
In Group Texture window 14-12

Spherical radio button
In Lens Flare Plug-In dialog box 

11-17
Splines

Selecting Bezier 17-8
Selecting Hermite 17-8
Selecting linear 17-8
Selecting natural cubic 17-8

Spot lights
Selecting for lights 11-5
Setting falloff 11-12
Setting inner cone diameter 11-12
Setting outer cone diameter 11-12

Spot option
In Light Modes pop-up menu

In Light Info window 11-5
Standard Shapes plug-in

Adding to project 1-34, 20-17 to 
20-18

Plane orientation options 20-18
Setting dimensions 20-18
Setting mesh divisions 20-18
Setting shape color 20-18
Shape options 20-18
Standard Shapes dialog box

Color button 20-18
Dimensions edit boxes 20-18
Divisions edit boxes 20-18
Orientation radio buttons 20-18
Shapes radio buttons 20-18

Standard Shapes tool
In Object Palette 20-17 to 20-18

Start Time edit box
In Render Control window 9-23

Start Windows with Rulers options
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In Grid & Scale Preferences dialog 
box 2-19

Starting Time edit box
In Sound Info window 12-4

Statistics… command
In File menu 1-48

Status command
In Windows menu

In Camera application 22-4
Status window

In Camera application 22-10
Still option

In Background pop-up menu
In Preview/Render Preferences 

dialog box 2-28
Stop button

In Sound Info window 12-3
Stop Time edit box

In Render Control window 9-23
Store Display Data option

In Project File Preferences dialog 
box 2-36

Store Project Window Content option
In Project File Preferences dialog 

box 2-36
Store Sound Data option

In Project File Preferences dialog 
box 2-36

Streak Contrast edit box
In Lens Flare Plug-In dialog box 

11-19
Streak Intensity edit box

In Lens Flare Plug-In dialog box 
11-18

Streak Scale edit box
In Lens Flare Plug-In dialog box 

11-18
Streaks option

In Lens Flare Plug-In dialog box 
11-19

Stretch option
In Type pop-up menu

In Group Deformation window 
16-25 to 16-26

String Bad Points option
Cyberware import preferences

Converting models to FACT 
format 1-30

Sum Enable option
In Render Control window 9-17

Summation mapping
Enabling/Disabling for project 9-17

Summation option
In Map Filter pop-up menu

In Group Texture window 14-20
Super 16mm option

In Aspect Ratio pop-up menu
In Render Control window 9-8

Super 8mm option
In Aspect Ratio pop-up menu

In Render Control window 9-7
Super Sample option

In Group Info window 13-7
In Render Control window 9-16

Super sampling
Enabling for groups 13-7
Enabling/Disabling for project 9-16

Surface Attributes
Copying 18-7

Surface attributes
Applying to all frames 18-17
Applying to all keyframes 18-17
Applying to current frame only 

18-17
Applying to current keyframe only 

18-17
Applying to current time only 18-17
Fine tuning color values for 

ambient sensitivity 18-10
Fine tuning color values for diffuse 

sensitivity 18-9
Fine tuning color values for edge 

density 18-15
Fine tuning color values for group’s 

surface 18-8
Fine tuning color values for 

luminance 18-13
Fine tuning color values for 

reflections 18-12
Fine tuning color values for specular 

highlights 18-11
Fine tuning color values for 

transparency 18-14
Group modification options 18-16
Modifying all groups within current 

model 18-16
Modifying children of current 

group 18-16
Modifying current group only 18-16
Naming 18-7
Pasting 18-7
Resetting 2-8
Setting alpha channel density 18-8
Setting ambient level 18-10
Setting apparent luminance 18-13
Setting base color for ambient 

sensitivity 18-10
Setting base color for diffuse 

sensitivity 18-9
Setting base color for edge density 

18-15
Setting base color for group’s 

surface 18-8

Setting base color for luminance 
18-13

Setting base color for reflectivity 
18-12

Setting base color for specular 
highlights 18-11

Setting base color for transparency 
18-14

Setting color level 18-8
Setting color saturation for ambient 

sensitivity 18-10
Setting color saturation for diffuse 

sensitivity 18-9
Setting color saturation for edge 

density 18-15
Setting color saturation for 

luminance 18-13
Setting color saturation for 

reflectivity 18-12
Setting color saturation for specular 

highlights 18-11
Setting color saturation for surface 

color 18-8
Setting color saturation for 

transparency 18-14
Setting diffuse sensitivity level 18-9
Setting edge density fall-off 18-15
Setting glossiness 18-11
Setting group ambient values 18-10
Setting group color values 18-8
Setting group diffuse values 18-9
Setting group edge density values 

18-15
Setting group luminance values 

18-13
Setting group reflectivity values 

18-12
Setting group specular values 18-11
Setting group transparency values 

18-14
Setting illumination/shadow area 

transition 18-8
Setting level of dither transparency 

18-14
Setting level of edge density 18-15
Setting level of filter transparency 

18-14
Setting luminance level 18-13
Setting opacity for edge density 

18-15
Setting reflectivity level 18-12
Setting specular fall-off 18-11
Setting specular level 18-11
Setting specular size 18-11

Surface button
In Group Info window 13-10

Surface Edges edit box
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Alias Sketch! import preferences
Converting models to FACT 

format 1-28
Surface Editor 18-1 to 18-17

All Frames button 18-17
All Keys button 18-17
Ambient settings

Hue control 18-10
RGB controls 18-10
Saturation control 18-10
Value control 18-10

Attribute pop-up menu
Ambient option 18-10
Diffuse option 18-9
Edge Density option 18-15
Group Color option 18-8
Luminance option 18-13
Reflectivity option 18-12
Specular option 18-11
Surface attributes

Attribute options 18-7
Transparency option 18-14

Current Frame button 18-17
Current Key button 18-17
Current Time button 18-17
Diffuse settings

Hue control 18-9
RGB controls 18-9
Saturation control 18-9
Value control 18-9

Display sphere 18-6
Edge Density edit box 18-15
Edge Density settings

Hue control 18-15
Opacity control 18-15
RGB controls 18-15
Saturation control 18-15
Value control 18-15

Group Color settings
Alpha control 18-8
Hue control 18-8
RGB controls 18-8
Saturation control 18-8
Value control 18-8

Luminance settings
Hue control 18-13
Luminance control 18-13
RGB controls 18-13
Saturation control 18-13
Value control 18-13

Modify In pop-up menu 18-16
All Children option 18-16
All Groups option 18-16
Current Group Only option 

18-16
Opening from Group Info window 

13-10

Opening the dialog box 18-4
Reflectivity settings

Hue control 18-12
RGB controls 18-12
Saturation control 18-12
Value control 18-12

Shading Dropoff edit box 18-8
Slider bars and edit boxes 18-5
Specular Dropoff edit box 18-11
Specular edit box 18-11
Specular settings

Glossy control 18-11
Hue control 18-11
RGB controls 18-11
Saturation control 18-11
Value control 18-11

Transparency settings
Hue control 18-14
Opacity control 18-14
RGB controls 18-14
Saturation control 18-14
Value control 18-14

Type edit box 18-7
Surface option

In Alpha pop-up menu
In Group Texture window 14-17

In RGB pop-up menu
In Group Texture window 14-14

Suspend Drawing While Application in 
Background option

In Drawing Preferences dialog box 
2-15

Switch Color Depth option
In Drawing Preferences dialog box 

2-14

T
Taper option

In Type pop-up menu
In Group Deformation window 

16-16 to 16-17
TechniScope option

In Aspect Ratio pop-up menu
In Render Control window 9-8

Text Format options
DXF export preferences

Saving models to non-FACT 
formats 1-39

Texture maps
Copying 2-4
Pasting 2-4

Texture maps, see Textures
Textures

Adding to Groups 14-5 to 14-6
Aligning to group’s back 14-19
Aligning to group’s bottom 14-19

Aligning to group’s front 14-19
Aligning to group’s left side 14-19
Aligning to group’s midpoint 14-19
Aligning to group’s right side 14-19
Aligning to group’s top 14-19
Alpha channel

Activating RGB channel decal 
14-16

Disabling 14-16
Multiplying with group’s 

ambient value 14-17
Multiplying with group’s diffuse 

value 14-17
Multiplying with group’s edge 

density value 14-18
Multiplying with group’s 

luminance value 14-18
Multiplying with group’s 

reflectivity value 14-17
Multiplying with group’s RGB 

channel 14-17
Multiplying with group’s specular 

value 14-17
Multiplying with group’s 

transparency value 14-17
Replacing all group 

characteristics 14-16
Using for bump mapping 14-16

Applying a cubic mapping 
projection 14-13

Applying a cylindrical mapping 
projection 14-11

Applying a flat mapping projection 
14-10

Applying a spherical mapping 
projection 14-12

Applying MIP anti-alias filtering 
14-20

Applying summation anti-alias 
filtering 14-20

Controlling blurriness 14-27
Copying from groups 14-9
Cropping 14-25
Disabling anti-alias filtering 14-20
Disabling smoothing 14-20
Enabling material filter 14-21
Enabling/Disabling for project 9-16
Mirroring along X axis 14-21
Mirroring along Y axis 14-21
Opening Group Texture window 

8-26, 19-14
Pasting to groups 14-9
Positioning 14-26
Projecting along negative Z axis 

14-21
Removing from groups 14-9
Repeating along X axis 14-21
Repeating along Y axis 14-21
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Replacing 14-9
Replacing individual group surface 

attributes 14-28 to 14-29
RGB channel

Disabling 14-14
Replacing group’s ambient values 

14-14
Replacing group’s diffuse values 

14-14
Replacing group’s edge density 

values 14-15
Replacing group’s luminance 

values 14-15
Replacing group’s reflectivity 

values 14-14
Replacing group’s specular values 

14-14
Replacing group’s surface 14-14
Replacing group’s transparency 

values 14-14
Rotating 14-26
Scaling 14-26
Selecting alignment options 14-19
Selecting anti-alias filtering options 

14-20
Selecting mapping projection 14-10
Selecting softness options 14-20
Setting bump map height 14-27
Setting maximum blurriness 14-27
Sharpening 14-20
Sizing 14-26
Softening 14-20
Using the alpha channel 14-16 to 

14-18
Using the RGB channel 14-14 to 

14-15
Textures option

In Render Control window 9-16
Time edit box

In Sound Info window 12-5
Time editing mode 8-6, 10-5, 11-10, 

13-9
Time option

Printing project data 1-51
Time Selector

In Project window 8-15
Setting event timing 8-15
Snapping to frames 8-19

Title Safe option
In Field Chart Preferences dialog 

box 2-22
To Image option

In Output pop-up menu
In Preview/Render Preferences 

dialog box 2-27
To QuickTime option

In Output pop-up menu

In Preview/Render Preferences 
dialog box 2-27

To Screen option
In Output pop-up menu

In Preview/Render Preferences 
dialog box 2-27

Tool Palette 19-1 to 19-29
Attach to Object tool 19-24 to 19-25
Auto Rotate Object tool 19-27 to 

19-28
Cancel Auto Rotate tool 19-29
Cancel Look At tool 19-23
Configuring the palette 19-3
Detach from Object tool 19-26
Drag Content tool 19-10
Group Deform tool 19-13
Group’s Linkage tool 19-15
Group’s Modification tool 19-16
Group’s Texture tool 19-14
Hide Motion Path tool 19-18
Link to Parent tool 19-19
Look at Object tool 19-21 to 19-22
Move tool 19-4
Opening the palette 3-2, 19-3
Scale tool 19-8
Show Motion Path tool 19-17
Snapping Grid tool 19-12
Unlink from Parent tool 19-20
Visible Grid tool 19-11
X Rotate tool 19-5
Y Rotate tool 19-6
Z Rotate tool 19-7
Zoom Window tool 19-9

Tool Palette command
In Windows Menu 3-2

Tools menu 5-1 to 5-28
Attach to Object command 5-23 to 

5-24
Auto Rotate Object command 5-26 

to 5-27
Cancel Auto Rotate command 5-28
Cancel Look At command 5-22
Detach from Object command 5-25
Drag Content command 5-9
Group Deform command 5-12
Group’s Linkage command 5-14
Group’s Modification command 

5-15
Group’s Texture command 5-13
Hide Motion Path command 5-17
Link to Parent command 5-18
Look at Object command 5-20 to 

5-21
Move command 5-3
Scale command 5-7
Show Motion Path command 5-16
Snapping Grid command 5-11

Unlink from Parent command 5-19
Visible Grid command 5-10
X Rotate command 5-4
Y Rotate command 5-5
Z Rotate command 5-6
Zoom Window command 5-8

Top option
In Align pop-up menu

In Group Texture window 14-19
In Link Alignment Position pop-up 

menu
In Group Link window 15-9

Top View command
In Windows menu 3-5

Top View window 6-4
also see World View windows
Opening the window 3-5

Total Frames edit box
In Render Control window 9-23

Transition edit box
In Light Info window 11-14

Transparency
Dither technique

Selecting for a group 13-5
Selecting for all groups 9-5

Filter technique
Selecting for a group 13-5
Selecting for all groups 9-5

Selecting global technique 9-5
Selecting technique for groups 13-5

Transparency Layers edit box
In Preview/Render Preferences 

dialog box 2-30
Transparency option

In Alpha pop-up menu
In Group Texture window 14-17

In Attribute pop-up menu
In Surface Editor 18-14

In RGB pop-up menu
In Group Texture window 14-14

Transparency pop-up menu
In Group Info window 13-5
In Render Control window 9-5

True Color option
In Image pop-up menu

In Render Control window 9-6
Tube lights

Selecting for lights 11-6
Tube option

In Light Modes pop-up menu
In Light Info window 11-6

Turbulence edit box
In Mr. Nitro™ dialog box 20-11

Twist option
In Type pop-up menu
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In Group Deformation window 
16-15

Type edit box
In Surface Editor 18-7

Type pop-up menu
In Group Deformation window 

16-11

U
U Points edit box

In Mesh Generator dialog box 20-7
Undo command

In Edit menu 2-3
Universal option

In Link Type pop-up menu
In Group Link window 15-10

Unlink from Parent command
In Tools menu 5-19

Unlink from Parent tool
In Project window 8-27
In Tool Palette 19-20

Use Light Intensity option
In Lens Flare Plug-In dialog box 

11-19
Use Project Cell Size option

Printing project data 1-51
Use Project Window option

Printing project data 1-51
Use QuickDraw option

In Drawing Preferences dialog box 
2-15

V
V Points edit box

In Mesh Generator dialog box 20-7
Value control

Ambient settings
In Surface Editor 18-10

Diffuse settings
In Surface Editor 18-9

Edge Density settings
In Surface Editor 18-15

Group Color settings
In Surface Editor 18-8

Luminance settings
In Surface Editor 18-13

Reflectivity settings
In Surface Editor 18-12

Specular settings
In Surface Editor 18-11

Transparency settings
In Surface Editor 18-14

Velocity edit boxes
In Particle Generator dialog box 

20-15

Velocity graphs
Displaying camera velocity 3-10
Displaying data channels 17-4
Displaying light velocity 3-11
Displaying model velocity 3-12
For lights 17-10
For models 17-11
For the camera 17-9
Setting the size of 17-5

Vertex color button
In Color Preferences dialog box 2-32

Vertical Max edit box
Cyberware import preferences

Converting models to FACT 
format 1-30

Vertical Min edit box
Cyberware import preferences

Converting models to FACT 
format 1-30

Vertical option
In Focal Mode pop-up menu

In Camera Info window 10-8
Vertical Points information

Cyberware import preferences
Converting models to FACT 

format 1-29
Vertical Samples information

Cyberware import preferences
Converting models to FACT 

format 1-29
Vertical Step edit box

Cyberware import preferences
Converting models to FACT 

format 1-30
Video interlacing 9-25

Enabling/Disabling even field 
rendering 9-18

View By menu options
Printing project data 1-52

Visibility control
In Project window 8-17

Visible grid
Toggling on/off 5-10, 19-11

Visible Grid command
In Tools menu 5-10

Visible Grid tool
In Tool Palette 19-11

VistaVision option
In Aspect Ratio pop-up menu

In Render Control window 9-8
Volume control

In Sound Info window 12-3

W
Windows menu 3-1 to 3-14

Camera Velocity command 3-10
Camera View command 3-8
Close Window command 3-13
Front View command 3-7
Light Velocity command 3-11
Location Palette command 3-3
Model Velocity command 3-12
Object Palette command 3-4
Project Window command 3-9
Show/Hide Rulers command 3-14
Side View command 3-6
Tool Palette command 3-2
Top View command 3-5

Wireframe option
In Shading pop-up menu

In Group Info window 13-3
Wireframe Shade option

In Camera pop-up menu
In Render Control window 9-4

Wireframe shading
Selecting for a group 13-3
Selecting for all groups 9-4
Setting group line size for 13-8
Setting point/line size for all groups 

9-19
World Grid Origin and Scale edit boxes

In Grid & Scale Preferences dialog 
box 2-18

World Grid Pixel Limit edit box
In Grid & Scale Preferences dialog 

box 2-18
World View windows 6-1 to 6-15

Changing the area displayed 6-14
Changing the coordinate plane 6-15
Controlling drawing detail 6-15
Displaying rulers in 3-14
Dragging content 5-9, 19-10
Drawing Detail options 2-12 to 2-13
Editing motion paths 6-12
Front view 3-7, 6-6
Knowing cursor location in 21-2
Manipulating groups 6-10
Manipulating lights 6-11
Manipulating the camera 6-9
Moving objects in 5-3, 19-4
Opening the windows 6-3
Side view 3-6, 6-5
Top view 3-5, 6-4
Using rulers 6-8
Using the snapping grid 6-8
Using the visible grid 6-7
Zooming in/out 5-8, 19-9

Wrap Angle edit box
In Group Texture window 14-26
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X
X Direction edit box

In Particle Generator dialog box 
20-14

X edit box
In Render Control window 9-11

X Position edit box
In Particle Generator dialog box 

20-14
X Rotate command

In Tools menu 5-4
X Rotate tool

In Tool Palette 19-5

Y
Y Direction edit box

In Particle Generator dialog box 
20-14

Y edit box
In Render Control window 9-11

Y Ground Level edit box
In Particle Generator dialog box 

20-15
Y Position edit box

In Particle Generator dialog box 
20-14

Y Rotate command
In Tools menu 5-5

Y Rotate tool
In Tool Palette 19-6

Z
Z Direction edit box

In Particle Generator dialog box 
20-15

Z is X option
In Link Alignment Orientation 

pop-up menu
In Group Link window 15-9

Z is Y option
In Link Alignment Orientation 

pop-up menu
In Group Link window 15-9

Z Position edit box
In Particle Generator dialog box 

20-15
Z Proper option

In Link Alignment Orientation 
pop-up menu

In Group Link window 15-9
Z Rotate command

In Tools menu 5-6
Z Rotate tool

In Tool Palette 19-7

Zoom Window command
In Tools menu 5-8

Zoom Window tool
In Tool Palette 19-9
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	Menus and Commands
	The File Menu Commands
	Chapter�1 The File Menu Commands
	New…
	To create a new project:
	1. Choose New… from the File menu.
	Figure 1.1��� Directory dialog box used to create a new project

	2. Open the folder (or create a new folder) where the new project file will be stored.
	3. Replace the default name by typing a name for the new project file (unless you want to use the...
	4. Either click Save or press Return.
	Figure 1.2��� Directory dialog box used to add a model to a project

	5. If you want to add a model to the project at this time, go on to Step�6 now.
	6. Open the folder where the model is located (if necessary).
	7. If you want to add a FACT format file, go on to Step�11 now.
	Figure 1.3��� Dialog box used to convert a model to FACT format

	8. Open the folder where the model is located (if necessary).
	9. If the model is not listed in the directory, either click the Show All File Types check box or...
	10. Use the controls in the dialog box to select import options (if desired). For an explanation ...
	11. Click on the model filename in the directory, and click Add.
	Figure 1.4��� Alert dialog box for a model not hierarchically structured

	12. If you want to create a hierarchy at this time, choose the parent group from the Parent Group...
	13. If you want to add another model to the project, repeat the steps for selecting a model.


	Open…
	To open a previously created project:
	1. Choose Open… from the File menu.
	Figure 1.5��� Directory dialog box used to open a project

	2. Open the folder where the project is located (if necessary).
	3. Click on the project file and click Open.
	Figure 1.6��� Alert dialog box when a model is not found

	4. At this point you can either:
	Figure 1.7��� Alert dialog box when a texture is not found

	5. At this point, you can either:


	Close
	To close the current project:
	1. Choose Close from the File menu.
	2. At this point, you can:


	Display…
	To display a QuickTime movie:
	1. Choose Display… from the File menu.
	Figure 1.8��� Directory dialog box used to display a QuickTime® movie

	2. Open the folder where the QuickTime movie is located (if necessary).
	3. Click on the movie file and click Open.
	4. When done, click the window’s close box.


	Add > Model…
	To add a model to the current project:
	1. Choose Add > then Model… from the File menu.
	Figure 1.9��� Directory dialog box used to add a model to a project

	2. Open the folder where the model is located (if necessary).
	3. If you want to add a FACT format file, go on to Step�4 now.
	4. Click on the model filename in the directory, and click Add.
	Figure 1.10��� Alert dialog box for a model not hierarchically structured

	5. If you want to create a hierarchy at this time, choose the parent group from the Parent Group ...
	6. If you want to add another model to the project, repeat the steps for selecting a model.


	Add > Sound…
	To add a sound file to the current project:
	1. Choose Add > then Sound… from the File menu.
	Figure 1.11��� Directory Dialog box used to add a sound file to a project

	2. Open the folder where the sound file is located (if necessary).
	3. To see a listing of all AIFF format files, click the See all AIFF files button.
	4. To preview sounds, click the Preview button.
	5. Click on the sound file and click Add.


	Add > Record Sound…
	To record a sound file to add to the current project:
	1. Choose Add > then Record Sound… from the File menu.
	Figure 1.12��� Dialog box used to record a sound file to add to a project

	2. Record the sound.
	3. To save the recorded sound, click Save or press Return.


	Add > Light…
	To add a light to the current project:
	1. Choose Add > then Light… from the File menu.
	2. Position the light icon in any of the World View windows and click the mouse.


	Add > Font…
	To create a font model and add it to the current project:
	1. Choose Add > then Font… from the File menu.
	Figure 1.13��� Dialog box used to create a font model

	2. Open the folder where the font is located.
	3. If the typeface is not listed in the directory, click the Show All Types check box. Only PostS...
	4. In the large edit box beneath the directory, type the characters to be converted into a model....
	5. Use the controls in the dialog box to select modelling options (if desired). For an explanatio...
	6. Click on the typeface in the directory and click Open.


	Font Modelling Options
	Smooth
	Fix Smooth Shading
	Max Angle
	Space
	Extrude
	Bevel Size
	Negative size value
	0 size value (no bevel)
	Positive size value
	Figure 1.14��� Bevel sizes (side views)


	Bevel Angle
	Bevel angle < 45°
	Default bevel angle (45°)
	Bevel angle > 45°
	Figure 1.15��� Bevel angles (side view)


	Fillet Sides
	Figure 1.16��� Side view of rounded bevel created with Fillet Sides value of 6

	Create Back Bevels
	Reverse Back Bevel
	Figure 1.17��� Right side view of reverse back bevel

	Calculate Flexing
	Group Whole Characters
	Group Similar Sides
	Add > Import…
	To import a model into the current project:
	1. Choose Add > then Import… from the File menu.
	Figure 1.18��� Dialog box used to convert a model to FACT format

	2. Open the folder where the model is located.
	3. If the model is not listed in the directory, either click the Show All File Types check box or...
	Figure 1.19��� Table of formats that ElectricImage can import�

	4. Use the controls in the dialog box to select import options (if desired). For an explanation o...
	5. Click on the model file and click Open.




	Import Options
	Combine Groups
	Combine Polygons
	Merge Polygons
	Merge Edges
	Fix Cone Point Shading
	Flat Complex Polygons
	Combine Coordinates
	Fix Smooth Shading
	Preferences
	DXF…
	Figure 1.20��� Dialog box to set DXF file import preferences

	Alias Sketch!…
	Figure 1.21��� Dialog box to set Alias Sketch file import preferences



	Cyberware Import Preferences
	Figure 1.22��� Dialog box used to set Cyberware import preferences
	Horizontal Points
	Horizontal Samples
	Vertical Points
	Vertical Samples
	Horizontal Min
	Horizontal Max
	Horizontal Step
	Vertical Min
	Vertical Max
	Vertical Step
	Data Offset
	Data Scale
	Sample Points
	Average Points
	Build Triangles
	Build Quadrangles
	Strip Bad Points
	Data Format
	Add > Mesh…
	To add the Mesh Generator to the project:
	1. Choose Add > then Mesh… from the File menu.
	Figure 1.23��� Mesh Generator dialog box

	2. Select the mesh type, specify its attributes, and either click OK or press Return.


	Add > Mr. Nitro™…
	To add the Mr. Nitro™ special effect to the project:
	1. Choose Add > then Mr. Nitro™… from the File menu.
	Figure 1.24��� Mr. Nitro™ dialog box

	2. Specify the attributes of the explosion, and either click OK or press Return.


	Add > Particle…
	To add the Particle Generator to the project:
	1. Choose Add > then Particle… from the File menu.
	Figure 1.25��� Particle Generator dialog box

	2. Specify the attributes of the particle generator, and either click OK or press Return.


	Add > Standard Shape…
	To add a standard shape to the project:
	1. Choose Add > then Standard Shape… from the File menu.
	Figure 1.26��� Standard Shapes dialog box

	2. Choose the type of shape, specify its attributes, and either click OK or press Return.


	Save Model > FACT…
	To save a model:
	1. Select the model(s) to be saved into a new model.
	2. Choose Save Model > then FACT… from the File menu.
	Figure 1.27��� Dialog box used to set hierarchy

	3. Specify whether or not you want to preserve a model’s hierarchical structure by clicking the a...
	4. Click OK or press Return.
	Figure 1.28��� Directory dialog box used to save a model

	5. Open the folder (or create a new folder) where the new model will be stored.
	6. Replace the default name by typing a name for the new model (unless you want to use the default).
	7. Click Save or press Return.


	Save Model > Other…
	To save a model in a non-FACT format:
	1. Select the model(s) to be saved into a new model.
	2. Choose Save Model > then Other… from the File menu.
	Figure 1.29��� Dialog box used to set hierarchy

	3. Specify whether or not you want to preserve a model’s hierarchical structure by clicking the a...
	4. Click OK or press Return.
	Figure 1.30��� Directory dialog box used to export a model

	5. Open the folder (or create a new folder) where the new model will be stored.
	6. Replace the default name by typing a name for the new model (unless you want to use the default).
	7. Select the export model type from the Type pop-up menu.
	Figure 1.31��� Table of formats that ElectricImage can export

	8. Use the controls in the dialog box to select export options (if desired). For an explanation o...
	9. Click Save or press Return.



	Export Options
	Output Points
	Output Lines
	Output Polygons
	Output Vertices as Points
	Output Edges as Lines
	Breakup Concave Polygons
	Side Limit
	Preferences
	DXF…
	Figure 1.32��� Dialog box to set DXF file export preferences


	Text Format
	Mac
	IBM

	Output Polygons As
	3DFACE
	POLYLINE

	Decimal Digits
	Exchange Y and Z coordinates
	Save
	To save the current project:

	Save As…
	To create a copy of the current project and work on the copy as the current project:
	1. Choose Save as… from the File menu.
	Figure 1.33��� Directory dialog box used to save a copy of the project file

	2. Open the folder (or create a new folder) where the copy of the project file will be stored.
	3. Replace the default name by typing a name for the copy of the project file (unless you want to...
	4. Either click Save or press Return.


	Save Copy As…
	To create a copy of the current project and maintain the original file as the current project:
	1. Choose Save Copy as… from the File menu.
	Figure 1.34��� Directory dialog box used to save a copy of the project file

	2. Open the folder (or create a new folder) where the copy of the project file will be stored.
	3. Replace the default name by typing a name for the copy of the project file (unless you want to...
	4. Either click Save or press Return.


	Collect Files…
	To collect the project files:
	1. Choose Collect Files… from the File menu.
	Figure 1.35��� Directory dialog box used to collect project files

	2. Open the folder (or create a new folder) where the files will be collected.
	3. To create a new folder for the project’s model(s), click Create Model Folder.
	4. Either click Collect or press Return.


	[Camera/Light/Group/Sound] Info
	Camera Info
	To open the Camera Info window:
	1. Click on the camera’s icon (in either the World View or Project windows) to select it.
	2. Choose Camera Info from the File menu.




	Light Info
	To open the Light Info window for a light in the project:
	1. Click on the light’s icon (in either the World View or Project windows) to select it.
	2. Choose Light Info from the File menu.

	Group Info
	To open the Group Info window for a group in the project:
	1. Click on the group’s icon (in either the World View or Project windows) to select it.
	2. Choose Group Info from the File menu.



	Sound Info
	To open the Sound Info window for a soundtrack in the project:
	1. Click on the soundtrack’s icon (in the Project window) to select it.
	2. Choose Sound Info from the File menu.

	Statistics…
	To view the project statistics:
	1. Choose Statistics… from the File menu.
	Figure 1.36��� Statistics dialog box

	2. When done, either click OK or press Return.


	Page Setup…
	To set basic page attributes for printing:

	Print
	To print the project data:
	1. Choose Print from the File menu.
	Figure 1.37��� Print dialog box for generic laser printer

	2. Use the controls in the dialog box to select your printing preferences. For an explanation of ...
	3. Either click Print or press Return.



	Printing Preferences
	Use Project Window
	Use Project Cell Size
	Selected Objects Only
	All Frames
	Order View by
	Flat
	Hierarchy

	Show View of
	Time
	Frame
	Keyframe
	Index

	View by
	Position
	Rotation
	Scale
	Color
	All
	Custom…
	Figure 1.38��� Dialog box used to select custom view

	Cell Size Width�and�Height
	Frame Range Start�and�Stop
	Render…
	To open the Render Control window:
	1. Choose Render… from the File menu.
	Figure 1.39��� Render Control window

	2. Use the window’s controls to set the rendering attributes you want for the project (if you are...
	3. If you do not want to render the project at this time, you can close the window or reposition it.
	Figure 1.40��� Directory dialog box used to save a rendered image file

	4. Open the folder (or create a new folder) where the project’s image file will be stored.
	5. Replace the default name by typing a name for the image file (unless you want to use the defau...
	6. Either click Save or press Return.


	Projector
	To launch Projector:

	Quit
	To quit the ElectricImage Animation System:




	The Edit Menu Commands
	Chapter�2 The Edit Menu Commands
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	Find…
	To find an object:
	1. Choose Find… from the Edit menu.
	Figure 2.1��� Dialog box used to find an object

	2. Type the name of the object or a search string.
	3. Specify whether or not the search string is a whole word (the default) and whether or not to m...
	4. Either click Find or press Return.



	Find Again
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	Revert (available in Surface Editor only)
	Keyframe…
	To set your keyframe preferences:
	1. Choose Keyframe… from the Edit menu.
	Figure 2.2��� Keyframe Preferences dialog box

	2. Use the edit boxes to set your preferences. For an explanation of these controls, refer to the...
	3. To save the settings, click OK. Otherwise, click Cancel.
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	Drawing…
	To set your drawing preferences:
	1. Choose Drawing… from the Edit menu.
	Figure 2.3��� Drawing Preferences dialog box

	2. Use the edit boxes, check boxes and pop-up menus to set your preferences. For an explanation o...
	3. To save the settings, click OK. Otherwise, click Cancel.
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	Figure 2.9��� Example of model drawn with subpolygons
	Grid & Scale…
	To set your grid, rulers and number display preferences:
	1. Choose Grid & Scale… from the Edit menu.
	Figure 2.10��� Grid & Scale Preferences dialog box

	2. Use the check boxes, edit boxes and pop-up menus to set your preferences. For an explanation o...
	3. To save the preferences, click OK or press Return.
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	Figure 2.11��� Ruler styles
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	Field Chart…
	Figure 2.12��� Standard field chart

	To set your field chart preferences:
	1. Choose Field Chart… from the Edit menu.
	Figure 2.13��� Field Chart Preferences dialog box

	2. Use the check boxes and color buttons to set your preferences. For an explanation of these con...
	3. To save the preferences, click OK or press Return.


	Field Chart Preferences
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	Figure 2.14��� Camera View window with field chart grid

	Title Safe
	Figure 2.15��� Field chart with title safe frame enabled

	Action Safe
	Figure 2.16��� Field chart with action safe frame enabled
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	Figure 2.18��� Field chart with hatch lines enabled
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	Figure 2.19��� Field chart with all elements enabled

	Field Size
	Color Buttons
	Preview/Render…
	To set your preview/render preferences:
	1. Choose Preview/Render… from the Edit menu.
	Figure 2.20��� Preview/Render Preferences dialog box

	2. Use the pop-up menus and edit box to set your preferences. For an explanation of these control...
	3. To save the preferences, click OK or press Return.
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	Color…
	To set your color preferences:
	1. Choose Color… from the Edit menu.
	Figure 2.21��� Color Preferences dialog box

	2. Use the buttons to set your preferences. For an explanation of these controls, see the section...
	3. Select a color from the Apple Color Picker and click OK.
	4. To save the preferences, click OK or press Return.
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	To set your import preferences:
	1. Choose Import… from the Edit menu.
	Figure 2.22��� Import Preferences dialog box

	2. Use the check boxes and pop-up menu to set your preferences. For an explanation of these contr...
	3. To save the preferences, click OK or press Return.
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	Project File…
	To set your project file preferences:
	1. Choose Project File… from the Edit menu.
	Figure 2.23��� Project File Preferences dialog box

	2. Use the check boxes to set your preferences. For an explanation of these controls, see the sec...
	3. To save the preferences, click OK or press Return.
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	To offset keyframe values:
	1. Choose Offset Keyframes from the Keyframe menu.
	Figure 4.1��� Offset Keyframe window

	2. Type a value in the edit box for the amount of offset to be applied to that characteristic of ...
	3. If you have custom frames that you wish to offset along with keyframes, click the Change Custo...
	4. To prevent an offset, click in the check box to disable it.
	5. Either click OK or press Return. The keyframe (and, optionally, custom frame) values are offse...

	To scale the timing of keyframes:
	1. Type a value in the Scale Time edit box for the factor by which to scale the timing of keyfram...
	2. Type a value in the Around edit box to set the time around which the keyframes will be scaled.
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	(keyframes now at 1.25, 1.75, 2.25, 2.75, 3.25 and 3.75 seconds)
	Keyframe time scaled by 0.5 around 5 seconds
	(keyframes now at 2.5, 3, 3.5, 4, 4.5 and 5 seconds)
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	Figure 4.2��� Examples of keyframe timing values offset and scaled


	Recalculate Selected Frames
	Recalculate All Frames
	Calculate Auto Frames

	The Tools Menu Commands
	Chapter�5 The Tools Menu Commands
	Move
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	Figure 5.3��� Y Rotate tool icon in a World View window
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	Figure 5.4��� Z Rotate tool icon in a World View window
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	Figure 5.5��� Scale tool icon in a World View window
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	Figure 5.9��� Group Deformation window
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	To link an object to a new parent object:
	1. Select the object to be linked (the child object) in either a World View or the Project window.
	2. Choose Link to Parent from the Tools menu.
	Figure 5.14��� Instruction in menu bar

	3. To complete the operation, click on the object to be the parent in either a World View or the ...
	Figure 5.15��� Canceling the operation
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	To force an object to look at another object:
	1. Select the object to be forced, in either a World View or the Project window.
	2. To apply the command at a specific time, set the Project window to Time mode and move the time...
	3. Choose Look at Object from the Tools menu.
	Figure 5.16��� Instruction in menu bar

	4. To complete the operation, click on the object to be looked at, in either a World View or the ...
	Figure 5.17��� Canceling the operation
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	To attach an object to another object:
	1. Select the object to be attached, in either a World View or the Project window.
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	3. Choose Attach to Object from the Tools menu.
	Figure 5.18��� Instruction in menu bar

	4. To complete the operation, click on the object to attach to, in either a World View or the Pro...
	Figure 5.19��� Canceling the operation
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	1. Select the object to be automatically rotated, in either a World View or the Project window.
	2. To apply the command at a specific time, set the Project window to Time mode and move the time...
	3. Choose Auto Rotate Object from the Tools menu.

	To modify the reference vector:
	1. Set the Project window to Keyframe mode and double-click on a cell in the Auto-Rotate channel,...
	Figure 5.20��� Auto-Rotate channel in the Project window
	Figure 5.21��� Dialog box used to set auto rotation options

	2. Enter a value in the Reference Length edit box. The value corresponds to the scale of the rule...
	3. Click OK or press Return.
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	To edit cell data:
	1. Click in the data cell to be edited.
	Figure 8.7��� Selected cell and its data in the edit box

	2. Type a new value for the cell.
	3. Press Return.

	To rename an object:
	1. Click on the object’s name in the object panel.
	Figure 8.8��� Selected object and its name in the edit box
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	3. Press Return.
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	To add a texture to the group:
	1. Double-click on the empty Texture Name box.
	Figure 14.3��� Directory dialog box used to add/replace/remove textures

	2. Open the folder where the Image file is located (if necessary).
	3. Click on the Image file to select it.
	4. Use the Modify in pop-up menu to select which group(s) are to be assigned the texture (default...
	5. Either click Add or press Return.
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	To define a region:
	1. Click the New… button under the Region list.
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	3. Either click OK or press Return.
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