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Getting Started

 

Welcome to Adobe® FrameMaker 7.0®—the complete publishing system that provides all 

the tools you need for word processing, page design, graphics, and book building. 

Combined with all of this is an easy-to-use environment for preparing and authoring 

documents for storage in or output to valid structured FrameMaker formats.

Whether you’re writing simple one-page memos or complex multichapter documents 

with imported graphics, this versatile application is ideal for organizations that need to 

reuse and distribute content on multiple devices and operating systems. For example, a 

single document created with FrameMaker 7.0 can be used for an eBook document, an 

HTML document for the Web, or an XML document.

 

The power and flexibility of FrameMaker 7.0

 

With support for both the Standard Generalized Markup Language (SGML) and the 

Extended Markup Language (XML), FrameMaker 7.0 allows you to easily import, open 

and work with existing structured documents and then save them back to SGML or XML 

when you’re finished.

Adobe FrameMaker 7.0 is a robust tool for organizations that need to quickly and 

efficiently publish complex documents to multiple channels, including XML, HTML, 

Adobe PDF (Portable Document Format), print, and SGML. 

Additional key features include WYSIWYG (what you see is what you get)-based context-

sensitive guided editing and authoring for structured documents; automated generation 

and updating of indexes, tables of contents, cross-references, and hyperlinks.

 

About Classroom in a Book

 

Adobe FrameMaker 7.0 Classroom in a Book

 

® is part of the official training series for 

Adobe graphics and publishing software developed by experts at Adobe Systems. These 

lessons are designed to let you learn at your own pace. If you’re new to Adobe FrameMaker 

7.0, you’ll learn the fundamental concepts and features you’ll need to master the program. 

If you’ve been using it for a while, you’ll find this book teaches many advanced features, 

including tips and techniques for using the latest version of Adobe FrameMaker.
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Although each lesson provides step-by-step instructions for creating a specific project, 

there is room for exploration and experimentation. It is recommended that you follow 

the book from start to finish, especially if you have never used FrameMaker before; but 

you can, if you wish, do only the lessons that correspond to your interests and needs. 

Screen illustrations vary among the Windows, Mac OS, and UNIX platforms. Platform, 

or operating system, differences are mentioned only when they are substantial.

 

Prerequisites

 

Before using 

 

Adobe FrameMaker 7.0

 

 

 

Classroom in a Book

 

, you should have a working 

knowledge of your computer and its operating system. You should know how to use a 

mouse and standard menus and commands. You should also know how to copy, open, 

save, print, and close files. If you need to review these techniques, see your Microsoft® 

Windows®, Macintosh® (Mac™ OS), or UNIX® documentation. Adobe Acrobat® 5.05 

Distiller is provided on the main installation disk, so that you can perform the exercises 

involving PDF file preparation, but you will need the Acrobat program for viewing them 

(see “Installing 

 

Adobe Acrobat Distiller 5.05 and Internet browsers

 

” on the next page).

 

Installing the FrameMaker 7.0 program

 

Before you begin using 

 

Adobe FrameMaker 7.0 Classroom in a Book, 

 

make sure that your 

system is set up correctly and that you’ve installed the required software and hardware. 

You must purchase the Adobe FrameMaker 7.0 software separately. For system 

requirements and complete instructions on installing the software, see the 

 

InstallReadMe

 

 

file on the Adobe FrameMaker 7.0 Application CD.

You must install the application from the Adobe FrameMaker CD onto your hard disk; 

you cannot run the program from the CD.

 

 

 

Follow the on-screen installation 

instructions. Make sure your serial number is available before installing the application; 

you can find the serial number on the registration card or CD sleeve. 

If you’re upgrading from an earlier version of FrameMaker, be sure to save a copy of your 

user dictionaries before installing the application.
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Installing Adobe Acrobat Distiller 5.05 and Internet browsers

 

You must install Adobe Acrobat Distiller 5.05, which comes on the installation disk, in 

order to complete the later lessons in this book. You also need to have Adobe Acrobat 

Reader® 4.0 or later or the Adobe Acrobat® 4.0 or later to view files. You should have 

Netscape® Navigator 4.7 or later or Microsoft® Internet Explorer 5.5. or later.

 

Installing WebWorks and XML Cookbook

 

WebWorks® by Quadralay Corporation and the XML Cookbook are covered in late lessons 

of this Classroom in a Book

 

 

 

(CIB)

 

. 

 

For system requirements and complete instructions on 

installing the software, see the 

 

InstallReadMe

 

 file on the Adobe FrameMaker 7.0 

Application CD

 

.

 

Installing the Classroom in a Book fonts

 

To ensure that the lesson files appear on your system with the correct fonts, you may need 

to install the Classroom in a Book font files. The fonts for the lessons are located in the 

Fonts folder on the 

 

FrameMaker 7.0 Classroom in a Book

 

 CD. If you already have these on 

your system, you do not need to install them. If you have ATM

 

®

 

 (Adobe Type Manager

 

®

 

), 

its documentation describes installation of fonts. Or, ATM Light is available from the 

Adobe web site (www.adobe.com). If you require additional fonts, installing ATM from 

the CIB CD will automatically install the necessary fonts. 

 

Note

 

: Windows XP/2000 has built-in support for both TrueType and Type1 fonts. Windows 

95/98/ME has built-in support for TrueType fonts, but requires Adobe Type Manager (ATM) 

to use Type1 fonts. 

 

In some instances, a lesson might require fonts that are not installed on your system. If 

necessary, FrameMaker will automatically substitute similar fonts, and will display a font 

substitution dialog box. To reformat the document using available fonts, click OK.

(UNIX) The UNIX-compatible fonts are in the tar archive (unixcib.tar) located in the 

Unix folder on the

 

 FrameMaker 7.0 Classroom in a Book

 

 CD. For instructions on how to 

install fonts for FrameMaker 7.0 UNIX, consult the online manual 

 

Working With Fonts in 

FrameMaker for UNIX

 

 installed with the FrameMaker application. For your convenience, 

the online manual is also included in the Unix folder as the file Fonts_UNIX.pdf.
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Installing fonts from the Adobe FrameMaker 7.0 Classroom in a Book CD

 

Use the following procedure to install the fonts on your hard drive.

 

1

 

Insert the Adobe FrameMaker 7.0 Classroom in a Book CD in your CD-ROM drive.

 

2

 

Install the font files using the procedure for the version of your operating system:

 

•

 

Windows (other than Windows XP or 2000). Open the ATM installer files on the CD, 

which are located in the Fonts/ATM folder. Double-click the installer file (Setup), and 

follow the on-screen instructions for installing ATM and the fonts.

 

•

 

Windows XP and 2000. Do not use the ATM font installer to install the fonts. Instead, 

simply drag the fonts from the CD to your hard disk and place them in your Adobe 

common fonts folder (typically in C:\Program Files\Common Files\Adobe\Fonts).

 

•

 

Mac OS 9. Open the Fonts folder on the CD. Double-click the ATM 4.6.1 + Fonts 

Installer to install the fonts.

 

•

 

Mac OS X. Open the Fonts folder on the CD. Select all of the fonts in the Fonts folder 

and drag them into the Library/Fonts folder on your hard disk. You can select and drag 

multiple fonts to install them, but you cannot drag the entire folder to install the fonts.

 

(Windows and Mac OS) You should also install the Classroom in a Book fonts by copying all 

the files in the fonts folder on the Adobe FrameMaker 7.0 Classroom in a Book CD to the fonts 

folder within the folder where you installed FrameMaker 7.0 on your hard disk. Doing so makes 

the fonts available to FrameMaker 7.0 but not to other applications. (If there is no fonts folder in 

the same folder where the program is installed, add a folder named

 

 

 

fonts

 

 (all lower case), and 

then copy the fonts into it. (Unix) Copy the fonts into the (Frame_path)/fminit/fmfonts directory.

 

Note:

 

 If you encounter a missing fonts message, you can force FrameMaker to permanently 

substitute fonts by going to File > Preferences and turning off the “Remember Missing Font 

Names” option. When you open any files with unavailable fonts in a FrameMaker session, the 

unavailable fonts will be permanently substituted with available fonts once the file is re-saved 

with the File > Save As command.

 

Copying the Classroom in a Book files

 

The Classroom in a Book CD includes folders containing all the electronic files for the 

lessons. Each lesson has its own folder, and you must copy the folders to your hard drive 

to do the lessons. To save room on your drive, you can choose to install only the folder for 

each lesson as you need it, and remove it when you’re done.
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To install the Classroom in a Book files:

 

1

 

Make sure the 

 

Adobe FrameMaker 7.0 Classroom in a Book

 

 CD is in your CD-ROM 

drive.

 

2

 

Create a folder named FM_CIB on your hard drive.

 

3

 

Copy the lessons you want to the hard drive:

 

•

 

To copy all of the lessons, drag the Lessons folder from the CD into the FM_CIB folder. 

 

•

 

To copy a single lesson, drag the individual lesson folder from the CD into the FM_CIB 

folder.

 

Note: 

 

If you are installing the files in UNIX, follow the instructions in Appendix D, “Copying 

the Sample Files (UNIX).”

 

Note: 

 

If you are installing the files in Windows, you need to unlock them before using them. 

You don’t need to unlock the files if you are installing them in Mac OS. 

 

4

 

In Windows, unlock the files you copied:

 

•

 

If you copied all of the lessons, double-click the unlock.bat file in the Lessons folder 

within the FM_CIB folder.

 

•

 

If you copied a single lesson, drag the unlock.bat file from the Lessons folder on the CD 

into the FM_CIB folder. Then double-click the unlock.bat file in the FM_CIB folder.

 

Starting the FrameMaker 7.0 program

 

When you start FrameMaker 7.0 for the first time, you are prompted to choose between 

two interfaces: the standard FrameMaker mode and Structured FrameMaker. Lessons 

specific to using Structured FrameMaker begin at Lesson 14.

 

To start Adobe FrameMaker in Windows: 

 

Do one of the following: 

 

•

 

Choose Start > Programs > Adobe > FrameMaker 7.0. 

 

•

 

Choose Start > Run, and then enter the full pathname of the program executable file, 

enclosed in double quotation marks (optionally followed by the name of a file to open): 

“C:\Program Files\Adobe\FrameMaker 7.0\FrameMaker.exe”.
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To start Adobe FrameMaker in Mac OS:

 

Open the FrameMaker folder, and double-click the FrameMaker program icon. (If you 

installed the program in a folder other than Adobe FrameMaker, open that folder.) 

 

To start Adobe FrameMaker in UNIX:

 

In a UNIX window, do one of the following: 

 

•

 

To start the U.S. Edition, enter 

 

maker.

 

•

 

To start the International Edition, enter 

 

maker -l

 

 (lowercase L) and the name of the 

language you want to use (for example, ukenglish, japanese, francais, or deutsch). For 

example, to start the French version of FrameMaker, you would enter 

 

maker -l francais.

 

 

 

Unstructured and Structured FrameMaker 7.0

 

FrameMaker 7.0 combines the power and flexibility of regular FrameMaker and 

FrameMaker+SGML to provide users with a robust set of stable, mission-critical tools for 

XML and SGML authoring. You can work with documents in two distinct ways: 

unstructured and structured.

Unstructured mode, referred to as standard FrameMaker, will be most familiar to users 

of word processing software and supports a WYSIWYG template-based authoring and 

publishing workflow.

In structured mode, FrameMaker extends its WYSIWYG authoring environment to 

support the structuring of content into a hierarchy of elements and attributes using 

Document Type Definitions (DTDs). It includes a styling language, known as Element 

Definition Document, or EDD, that enables sophisticated context-sensitive formatting 

and layout. Structured FrameMaker supports users working with and creating valid 

SGML and XML. Users choose their preferred mode at first program launch and through 

the Preferences dialog box, so that those who are not currently working in structured 

authoring can work with a simpler interface. 

The Element Catalog and the Structure View provide context-sensitive guided editing. 

The Element Catalog quickly shows you which elements are valid; the Structure View 

window displays any validity errors as they occur in real time. Structured FrameMaker 

supports round tripping XML, so you can open, edit, and save XML files and DTDs. After 

authoring and tagging tasks are complete, you can easily save standards-compliant XML 
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files for further processing. FrameMaker 7.0 also includes support for namespaces and 

Unicode (UTF-8/UTF-16).

 

Adobe FrameMaker 7.0 and Microsoft® Word®

 

Adobe FrameMaker 7.0 is especially compatible with Microsoft® Word® and Microsoft 

Excel®. This user-friendly capability makes it easy to import Word and Excel files into 

FrameMaker 7.0 and allows you to quickly utilize all its advanced authoring and 

document management tools. FrameMaker is a significant word processing application 

in its own right. As your comfort level grows with its many powerful aspects, you will be 

able to do all of your document creation, starting with the original input, directly in 

FrameMaker 7.0 itself.

 

Additional Resources

 

Adobe FrameMaker 7.0 Classroom in a Book 

 

is not intended to replace documentation that 

comes with the FrameMaker 7.0 program. Only the commands and options used in the 

lessons are explained in this book. For comprehensive information about program 

features, refer to these resources:

 

•

 

The 

 

Adobe FrameMaker 7.0 User Guide, 

 

which is included with the Adobe FrameMaker 

7.0 software, contains a complete description of all features, tools, and commands in the 

software. It is designed to be used as a reference tool, and provides instructions for using 

FrameMaker on the Windows, Mac OS, and UNIX platforms.

 

•

 

The 

 

Adobe FrameMaker Quick Reference Card 

 

contains basic information about 

FrameMaker tools and palettes, and shortcuts for using them.

 

•

 

Online Help, an online version of the 

 

User Guide

 

, is accessible by choosing 

Help > Contents. (For more information, see Lesson 1, “Getting to Know the Work 

Area.”)

 

•

 

The 

 

Installing FrameMaker Products

 

 (UNIX) guide contains information for system 

administrators for setting up, licensing, and maintaining FrameMaker on a UNIX 

network.

 

•

 

The Adobe Web site (www.adobe.com), which you can view by choosing 

Help > Adobe Online if you have a connection to the World Wide Web. 
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Adobe Certification

 

The Adobe Training and Certification Programs are designed to help Adobe customers 

improve and promote their product proficiency skills. The Adobe Certified Expert (ACE) 

program is designed to recognize the high-level skills of expert users. Adobe Certified 

Training Providers (ACTP) use only Adobe Certified Experts to teach Adobe software 

classes. Available in either ACTP classrooms or on site, the ACE program is the best way 

to master Adobe products. For Adobe Certified Training Programs information, visit the 

Partnering with Adobe Web site at http://partners.adobe.com.
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